Matrix Science header

Matrix Science Mascot Parser toolkit

Modules

  • Mascot results file module - To extract data from Mascot results files into other applications or to a relational database
  • Mascot configuration files module - To access the Mascot configuration files from a server or client application.
  • Mascot security and authentication module - For Mascot 2.1 and later server side applications only.
  • Mascot utilities and tools module - Miscellaneous tools for creating CDB files, zipping files, other file utilities and clustering.
  • Error handling and logging - for details on error handling and logging.
  • Quantitation analysis for Mascot Server and Distiller - for client and server applications.
  • Classes for calculating masses of peptides and fragments. - Classes for calculating masses of peptides and fragments.
  • Accessing a Mascot Server using HTTP - login, search submission and results retrieval are supported.

Installation

  • C++ toolkit installation
  • Java toolkit installation
  • Perl toolkit installation
  • Python toolkit installation
  • C# toolkit installation

Getting Started

  • License information for Mascot Parser
  • Getting started with Mascot Parser

Upgrading from previous versions

  • Release notes and version history
  • Updating from earlier versions of Mascot Parser

The following files are distributed with Mascot Parser.

The C++ files are categorised under directories named after each supported C++ compiler. The Perl module is supplied and installed with Mascot Server from version 2.0 onwards.

Directory | Files | Description
compiler/include | msparser.hpp and a number of other include files. | C++ headers; see C++ toolkit installation
compiler/lib | *.lib or *.a *.dll or *.so.1 | C++ library files; see C++ toolkit installation
compiler/example_cxx | *.cpp | C++ examples
doc | index.html Other html and javascript files | Help for use from a web browser
 | MascotParserUML.pdf | The UML diagram as a PDF (same as in the HTML help)
 | Developer Licence Agreement.pdf | Developer Licence Agreement as a PDF
example_csharp | *.cs | C# examples
example_java | *.java | Java examples
example_perl | *.pl | Perl examples
example_python | *.py | Python examples
java | msparser.dll or libmsparserj.so msparser.jar | Java library; see Java toolkit installation
perl516 (Linux only) perl518 (Linux only) perl520 (Linux only) perl522 (Linux only) perl524 perl526 perl528 perl530 perl532 perl534 (Linux only) | msparser.dll or msparser*.so msparser.pm | Perl module; see Perl toolkit installation
python27 python34 python36 python37 python38 python39 | _msparser.so or _msparser.pyd msparser.py | Python module; see Python toolkit installation
csharp | msparsercs.dll matrix_science.msparser.dll | C# module; see C# toolkit installation
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:14


License information for Mascot Parser

The license agreement for Mascot Parser is located in a pdf file in the doc directory.

Mascot Parser uses a number of 3rd party libraries. The code for all of these libraries except the stdc++ libray for Linux is compiled into each .so, .dll, .a and .lib file, so there is no requirement for an application to link these separately. Any application that uses Mascot Parser must abide by the license for Mascot Parser and these components:

Library | Platforms
Xerces C++ XML Parser | All
libcurl - multiprotocol file transfer library | All Unix platforms - not Windows
Portable Hardware Locality (hwloc) | Linux only
libstdc++ | 64 bit Linux only
zlib | All
Regex Library | Windows only
Simplified Wrapper and Interface Generator (SWIG) | Perl, Java, Python and C# modules on all platforms
C Clustering library | All
OpenSSL | Linux only

Xerces C++ XML Parser

The following text can be found at http://www.apache.org/licenses/LICENSE-1.1

/* ====================================================================
 The Apache Software License, Version 1.1
 Copyright (c) 2000 The Apache Software Foundation.  All rights
 reserved.
 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions
 are met:
 1. Redistributions of source code must retain the above copyright
    notice, this list of conditions and the following disclaimer.
 2. Redistributions in binary form must reproduce the above copyright
    notice, this list of conditions and the following disclaimer in
    the documentation and/or other materials provided with the
    distribution.
 3. The end-user documentation included with the redistribution,
    if any, must include the following acknowledgment:
       "This product includes software developed by the
        Apache Software Foundation (http://www.apache.org/)."
    Alternately, this acknowledgment may appear in the software itself,
    if and wherever such third-party acknowledgments normally appear.
 4. The names "Apache" and "Apache Software Foundation" must
    not be used to endorse or promote products derived from this
    software without prior written permission. For written
    permission, please contact apache@apache.org.
 5. Products derived from this software may not be called "Apache",
    nor may "Apache" appear in their name, without prior written
    permission of the Apache Software Foundation.
 THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
 WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
 OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
 DISCLAIMED.  IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR
 ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
 LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
 USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
 ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
 OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 SUCH DAMAGE.
 ====================================================================
 This software consists of voluntary contributions made by many
 individuals on behalf of the Apache Software Foundation.  For more
 information on the Apache Software Foundation, please see
 <http://www.apache.org/>.
 Portions of this software are based upon public domain software
 originally written at the National Center for Supercomputing Applications,
 University of Illinois, Urbana-Champaign.
 */

libcurl - multiprotocol file transfer library

The following text can be found at http://curl.haxx.se/docs/copyright.html

OPYRIGHT AND PERMISSION NOTICE
Copyright (c) 1996 - 2007, Daniel Stenberg, <daniel@haxx.se>.
All rights reserved.
Permission to use, copy, modify, and distribute this software for any purpose
with or without fee is hereby granted, provided that the above copyright
notice and this permission notice appear in all copies.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN
NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE
OR OTHER DEALINGS IN THE SOFTWARE.
Except as contained in this notice, the name of a copyright holder shall not
be used in advertising or otherwise to promote the sale, use or other dealings
in this Software without prior written authorization of the copyright holder.

Portable Hardware Locality (hwloc)

https://www.open-mpi.org/projects/hwloc/license.php

Copyright &#169; 2004-2006 The Trustees of Indiana University and Indiana University Research and Technology Corporation.  All rights reserved.
Copyright &#169; 2004-2005 The University of Tennessee and The University of Tennessee Research Foundation.  All rights reserved.
Copyright &#169; 2004-2005 High Performance Computing Center Stuttgart, University of Stuttgart.  All rights reserved.
Copyright &#169; 2004-2005 The Regents of the University of California. All rights reserved.
Copyright &#169; 2009      CNRS
Copyright &#169; 2009-2016 Inria.  All rights reserved.
Copyright &#169; 2009-2015 Université Bordeaux
Copyright &#169; 2009-2015 Cisco Systems, Inc.  All rights reserved.
Copyright &#169; 2009-2012 Oracle and/or its affiliates.  All rights reserved.
Copyright &#169; 2010      IBM
Copyright &#169; 2010      Jirka Hladky
Copyright &#169; 2012      Aleksej Saushev, The NetBSD Foundation
Copyright &#169; 2012      Blue Brain Project, EPFL. All rights reserved.
Copyright &#169; 2013-2014 University of Wisconsin-La Crosse. All rights reserved.
Copyright &#169; 2015      Research Organization for Information Science and Technology (RIST). All rights reserved.
Copyright &#169; 2015-2016 Intel, Inc.  All rights reserved.
See COPYING in top-level directory.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
1. Redistributions of source code must retain the above copyright
   notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.
3. The name of the author may not be used to endorse or promote products
   derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

libstdc++

The following text can be found at http://gcc.gnu.org/onlinedocs/libstdc++/17_intro/license.html

Licenses for the Library

There are two licenses affecting GNU libstdc++: one for the code, and one for the documentation. Here we will describe both of them, and try to answer some of the widespread questions. If you have more questions, ask the FSF or the gcc mailing list; the person writing this page is a programmer, not a lawyer.

The Code: Runtime GPL
The source code of libstdc++ is distributed under version 2 of the GNU General Public License, with the so-called "runtime exception," as follows (or see any header or implementation file):

   As a special exception, you may use this file as part of a free software
   library without restriction.  Specifically, if other files instantiate
   templates or use macros or inline functions from this file, or you compile
   this file and link it with other files to produce an executable, this
   file does not by itself cause the resulting executable to be covered by
   the GNU General Public License.  This exception does not however
   invalidate any other reasons why the executable file might be covered by
   the GNU General Public License.

 Hopefully that text is self-explanatory. If it isn't, you need to speak to your lawyer, or the Free Software Foundation.

Q: So any program which uses libstdc++ falls under the GPL? A: No. The special exception permits use of the library in proprietary applications.

Q: How is that different from the GNU {Lesser,Library} GPL? A: The LGPL requires that users be able to replace the LGPL code with a modified version; this is trivial if the library in question is a C shared library. But there's no way to make that work with C++, where much of the library consists of inline functions and templates, which are expanded inside the code that uses the library. So to allow people to replace the library code, someone using the library would have to distribute their own source, rendering the LGPL equivalent to the GPL.

Q: I see. So, what restrictions are there on programs that use the library? A: None. We encourage such programs to be released as open source, but we won't punish you or sue you if you choose otherwise. The Docs: GPL, FDL

The documentation shipped with the library and made available over the web, excluding the pages generated from source comments, are copyrighted by the Free Software Foundation, and placed under the GNU Free Documentation License version 1.1. There are no Front-Cover Texts, no Back-Cover Texts, and no Invariant Sections.

For documentation generated by doxygen or other automated tools via processing source code comments and markup, the original source code license applies to the generated files. Thus, the doxygen documents are licensed GPL.

If you plan on making copies of the documentation, please let us know. We can probably offer suggestions.

Comments and suggestions about this page are welcome, and may be sent to the libstdc++ mailing list. Comments or questions about the licenses themselves are also welcome, and should be directed to the GCC list as descibed above.

zlib

The following text can be found at http://www.zlib.net/zlib_license.html

 zlib License
/* zlib.h -- interface of the 'zlib' general purpose compression library
  version 1.2.3, July 18th, 2005
  Copyright (C) 1995-2005 Jean-loup Gailly and Mark Adler
  This software is provided 'as-is', without any express or implied
  warranty.  In no event will the authors be held liable for any damages
  arising from the use of this software.
  Permission is granted to anyone to use this software for any purpose,
  including commercial applications, and to alter it and redistribute it
  freely, subject to the following restrictions:
  1. The origin of this software must not be misrepresented; you must not
     claim that you wrote the original software. If you use this software
     in a product, an acknowledgment in the product documentation would be
     appreciated but is not required.
  2. Altered source versions must be plainly marked as such, and must not be
     misrepresented as being the original software.
  3. This notice may not be removed or altered from any source distribution.
  Jean-loup Gailly jloup@gzip.org
  Mark Adler madler@alumni.caltech.edu
*/

Regex Library

Copyright 1992, 1993, 1994 Henry Spencer.  All rights reserved.
This software is not subject to any license of the American Telephone
and Telegraph Company or of the Regents of the University of California.
Permission is granted to anyone to use this software for any purpose on
any computer system, and to alter it and redistribute it, subject
to the following restrictions:
1. The author is not responsible for the consequences of use of this
   software, no matter how awful, even if they arise from flaws in it.
2. The origin of this software must not be misrepresented, either by
   explicit claim or by omission.  Since few users ever read sources,
   credits must appear in the documentation.
3. Altered versions must be plainly marked as such, and must not be
   misrepresented as being the original software.  Since few users
   ever read sources, credits must appear in the documentation.
4. This notice may not be removed or altered.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
/*-
 Copyright (c) 1994
    The Regents of the University of California.  All rights reserved.
 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions
 are met:
 1. Redistributions of source code must retain the above copyright
    notice, this list of conditions and the following disclaimer.
 2. Redistributions in binary form must reproduce the above copyright
    notice, this list of conditions and the following disclaimer in the
    documentation and/or other materials provided with the distribution.
 3. All advertising materials mentioning features or use of this software
    must display the following acknowledgement:
    This product includes software developed by the University of
    California, Berkeley and its contributors.
 4. Neither the name of the University nor the names of its contributors
    may be used to endorse or promote products derived from this software
    without specific prior written permission.
 THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
 ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
 FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
 DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
 OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
 OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 SUCH DAMAGE.
    @(#)COPYRIGHT	8.1 (Berkeley) 3/16/94
 */

Simplified Wrapper and Interface Generator (SWIG)

The following text can be found at http://swig.sourceforge.net/copyright.html

 Simplified Wrapper and Interface Generator  (SWIG)
 SWIG is distributed under the following terms:
 =================================================
 I.
 This software includes contributions that are Copyright (c) 1998-2002
 University of Chicago.
 All rights reserved.
 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions are
 met:
 Redistributions of source code must retain the above copyright notice,
 this list of conditions and the following disclaimer.  Redistributions
 in binary form must reproduce the above copyright notice, this list of
 conditions and the following disclaimer in the documentation and/or
 other materials provided with the distribution.  Neither the name of
 the University of Chicago nor the names of its contributors may be
 used to endorse or promote products derived from this software without
 specific prior written permission.
 THIS SOFTWARE IS PROVIDED BY THE UNIVERSITY OF CHICAGO AND CONTRIBUTORS
 "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
 LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
 PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE UNIVERSITY OF
 CHICAGO OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
 TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 II.
 Copyright (c) 1995-1998
 The University of Utah and the Regents of the University of California
 All Rights Reserved
 Permission is hereby granted, without written agreement and without
 license or royalty fees, to use, copy, modify, and distribute this
 software and its documentation for any purpose, provided that
 (1) The above copyright notice and the following two paragraphs
 appear in all copies of the source code and (2) redistributions
 including binaries reproduces these notices in the supporting
 documentation.   Substantial modifications to this software may be
 copyrighted by their authors and need not follow the licensing terms
 described here, provided that the new terms are clearly indicated in
 all files where they apply.
 IN NO EVENT SHALL THE AUTHOR, THE UNIVERSITY OF CALIFORNIA, THE
 UNIVERSITY OF UTAH OR DISTRIBUTORS OF THIS SOFTWARE BE LIABLE TO ANY
 PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
 DAMAGES ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION,
 EVEN IF THE AUTHORS OR ANY OF THE ABOVE PARTIES HAVE BEEN ADVISED OF
 THE POSSIBILITY OF SUCH DAMAGE.
 THE AUTHOR, THE UNIVERSITY OF CALIFORNIA, AND THE UNIVERSITY OF UTAH
 SPECIFICALLY DISCLAIM ANY WARRANTIES,INCLUDING, BUT NOT LIMITED TO,
 THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 PURPOSE. THE SOFTWARE PROVIDED HEREUNDER IS ON AN "AS IS" BASIS, AND
 THE AUTHORS AND DISTRIBUTORS HAVE NO OBLIGATION TO PROVIDE MAINTENANCE,
 SUPPORT, UPDATES, ENHANCEMENTS, OR MODIFICATIONS.

C Clustering library

Version 1.45 of the library was downloaded from here: http://bonsai.hgc.jp/~mdehoon/software/cluster/

where the manual is also available.

The following text appears at the top of the single 'c' source file that is used in Mascot Parser:

/* The C clustering library.
 Copyright (C) 2002 Michiel Jan Laurens de Hoon.
 This library was written at the Laboratory of DNA Information Analysis,
 Human Genome Center, Institute of Medical Science, University of Tokyo,
 4-6-1 Shirokanedai, Minato-ku, Tokyo 108-8639, Japan.
 Contact: mdehoon 'AT' gsc.riken.jp
 Permission to use, copy, modify, and distribute this software and its
 documentation with or without modifications and for any purpose and
 without fee is hereby granted, provided that any copyright notices
 appear in all copies and that both those copyright notices and this
 permission notice appear in supporting documentation, and that the
 names of the contributors or copyright holders not be used in
 advertising or publicity pertaining to distribution of the software
 without specific prior permission.
 THE CONTRIBUTORS AND COPYRIGHT HOLDERS OF THIS SOFTWARE DISCLAIM ALL
 WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED
 WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL THE
 CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY SPECIAL, INDIRECT
 OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
 OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE
 OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE
 OR PERFORMANCE OF THIS SOFTWARE.
 */

OpenSSL

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit.

  OpenSSL License
  ---------------
/* ====================================================================
 Copyright (c) 1998-2007 The OpenSSL Project.  All rights reserved.
 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions
 are met:
 1. Redistributions of source code must retain the above copyright
    notice, this list of conditions and the following disclaimer.
 2. Redistributions in binary form must reproduce the above copyright
    notice, this list of conditions and the following disclaimer in
    the documentation and/or other materials provided with the
    distribution.
 3. All advertising materials mentioning features or use of this
    software must display the following acknowledgment:
    "This product includes software developed by the OpenSSL Project
    for use in the OpenSSL Toolkit. (http://www.openssl.org/)"
 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to
    endorse or promote products derived from this software without
    prior written permission. For written permission, please contact
    openssl-core@openssl.org.
 5. Products derived from this software may not be called "OpenSSL"
    nor may "OpenSSL" appear in their names without prior written
    permission of the OpenSSL Project.
 6. Redistributions of any form whatsoever must retain the following
    acknowledgment:
    "This product includes software developed by the OpenSSL Project
    for use in the OpenSSL Toolkit (http://www.openssl.org/)"
 THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY
 EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
 PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR
 ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
 NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
 LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
 STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
 ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
 OF THE POSSIBILITY OF SUCH DAMAGE.
 ====================================================================
 This product includes cryptographic software written by Eric Young
 (eay@cryptsoft.com).  This product includes software written by Tim
 Hudson (tjh@cryptsoft.com).
 */
 Original SSLeay License
 -----------------------
/* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)
 All rights reserved.
 This package is an SSL implementation written
 by Eric Young (eay@cryptsoft.com).
 The implementation was written so as to conform with Netscapes SSL.
 This library is free for commercial and non-commercial use as long as
 the following conditions are aheared to.  The following conditions
 apply to all code found in this distribution, be it the RC4, RSA,
 lhash, DES, etc., code; not just the SSL code.  The SSL documentation
 included with this distribution is covered by the same copyright terms
 except that the holder is Tim Hudson (tjh@cryptsoft.com).
 Copyright remains Eric Young's, and as such any Copyright notices in
 the code are not to be removed.
 If this package is used in a product, Eric Young should be given attribution
 as the author of the parts of the library used.
 This can be in the form of a textual message at program startup or
 in documentation (online or textual) provided with the package.
 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions
 are met:
 1. Redistributions of source code must retain the copyright
    notice, this list of conditions and the following disclaimer.
 2. Redistributions in binary form must reproduce the above copyright
    notice, this list of conditions and the following disclaimer in the
    documentation and/or other materials provided with the distribution.
 3. All advertising materials mentioning features or use of this software
    must display the following acknowledgement:
    "This product includes cryptographic software written by
     Eric Young (eay@cryptsoft.com)"
    The word 'cryptographic' can be left out if the rouines from the library
    being used are not cryptographic related :-).
 4. If you include any Windows specific code (or a derivative thereof) from
    the apps directory (application code) you must include an acknowledgement:
    "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"
 THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND
 ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
 FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
 DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
 OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
 OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 SUCH DAMAGE.
 The licence and distribution terms for any publically available version or
 derivative of this code cannot be changed.  i.e. this code cannot simply be
 copied and put under another distribution licence
 [including the GNU Public Licence.]
 */

        Copyright © 2022
           Matrix Science Ltd.
             All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Release notes and version history

Version 2.8.1 - released with Mascot Server 2.8.1

ID | Title
13751 | Add shippers for Python 3.7, 3.8, 3.9
13766 | 502.2 - Bad Gateway on opening search results, caused by segfault while reading empty protein description
13864 | Sorting unassigned list fails if filtering is active, caused by findPeptides() always returning results in query order
13927 | Start and end of quantitation match range can be reversed causing out of memory
13961 | Error message 539 lacks information - relevant taxonomy node files now added to error message
13962 | Dodgy protein inference when two interlinked proteins have the same very short beta peptide
13963 | Add TMTpro 18plex quant method
13989 | Xml configuration files should not be written in place
14000 | Increase limit of taxonomy choice include/exclude line length - new limit is 32kB

Version 2.8.0 - released with Mascot Server 2.8

ID | Title
12447 | Calculate an expect value for error tolerant matches. See Error tolerant searches.
13357 | End of 32-bit Parser on Windows. Parser 2.8 and later are now 64-bit only on all platforms.
13378 | Section title "Using STL classes" should mention vectord, vectori, VectorString
13406 | getThresholdForFDRAboveIdentity() doesn't always work when Percolator is enabled
13514 | Parser 2.7.0 C# is built with VS2015, not VS2012
13604 | New setting for number of input file parsing threads
13633 | updateForInstaller: replace PercolatorFeatures with new feature set
13634 | New options PercolatorTargetRankScoreThreshold and PercolatorTargetRankRelativeThreshold
13639 | Add static and shared libraries for VS2017. Parser 2.8 ships with libraries compiled for VS2012, VS2013, VS2015 and VS2017.
13663 | ms_aahelper never returns internal ions over 700 Da
13673 | ms_proteinsummary needs to check inference flags
13696 | New parameter for ms-createpip.exe multithreading
13715 | Only return false from getThresholdForFDRAboveHomology() if closest FDR is not within a factor of 2 of target FDR
13716 | Make ms_searchparams thread safe and more efficient
13726 | Logging and error handling documentation is mostly missing
13730 | Allow zero child elements in mxm:accessions, mxm:filters, mxm:scope, mxm:settings
13746 | Remove ICC2016 shippers. The GCC 4.8.5 static and shared libraries now shipped with Parser can be used with both GCC 4.8.5 and later, and Intel® Compiler 2016 and later. See C++ toolkit installation on Unix.
13759 | New ms_peptidesummary parameters: target FDR and FDR type. See Target-decoy searches and false discovery rate.
13763 | Add willCreateCache methods which take a ms_mascotresults_params argument
13769 | Update unimod.xml and unimod_xl.xml for 2.8.0
13806 | Target FDR algorithm: maximise the number of target matches if FDR is 0%
13808 | Update element descriptions in crosslinking schema for the crosslinking configuration editor
13818 | If alpha and beta are in different proteins, one of them is not assigned to any protein
13848 | Add Parser targets for Perl 5.32 and 5.34 (Linux) and Perl 5.32 (Windows).

Version 2.7.1 - released with Mascot Distiller 2.8

ID | Title
11666 | Add MS1 quantitation result reading to msparser
12409 | ms_ms1quantitation needs to handle normalisation
13548 | ms_http_client_session::submitSearch should be able to use -batch option
13556 | Schema changes required for Mascot Distiller 2.8
13607 | Multiple issues with ms_quant_helper::isPeptideQuantifiable for MS1 based quantitation
13614 | MS1 quantitation, XML output, Hit ratio set to invalid when it should be valid
13667 | ms_quant_helper VarModStringToVector doesn't handle letters correctly
13686 | ms_xic is not thread safe
13702 | Memory leak in mshandle
13725 | HTTP authentication fails if POST request redirects to GET (e.g. search with -batch mode)
13743 | More problems with ms_quant_helper
13760 | Missing and additional protein ratios for Precursor quantitation when mass-time-match is enabled

Version 2.7.0 - released with Mascot Server 2.7

ID | Title
10427 | ms_aahelper needs argument to generate mass values for all neutral losses
10714 | Parser error handling is not thread safe
10752 | Satellite ions should not be restricted to fragments containing R
10793 | findPeptides() with FT_PEPTIDE_EXP_MZ and FC_SEARCH_ALL_RANKS returns all ranks with no match
11802 | Python example script emits "query out of range" errors and crashes
12100 | single underscore character identifier is defined in des.h
12326 | Add switch to mascot.dat to over-ride asynchronous search submission (batch mode)
12493 | Add an internal interface for fast conversions between strings and numbers
12496 | Disallow creating a database whose name differs from an existing one only by case
12624 | Use cache files from 2.4 and 2.5 in test harness to ensure backwards compatibility won't break
12672 | ms_mascotoptions setters should check the limits or be removed
12753 | ms_tinycdb openIndexFile uses string comparison on gmt timestamps to check file dates
12808 | ms_umod_configfile::findModification should be optimised with a lookup table
12820 | Add a clear() method to ms_progress_info
12832 | Expand parser test harness with files combining, mod search and ambiguity groups
12857 | Potential crash when sorting peptides
12860 | willCreateCache adds errors to the ms_mascotresfile object, resulting in duplicates
12863 | Search modification by name with findPeptides returns only one value on Windows
12888 | Add a documentation page for the FDR procedure
12891 | Test harness scripts should be converted to python
12895 | Add a utility function to compare XML files
12902 | Modification statistics for error tolerant search can be highly misleading
12913 | Revert to just saving rank 1 in percolator pip file
12921 | Add PSM and sequences used for ID to proteinHit element of quant XML export
12924 | Peptide summary cache file name is different between master_results and ms-searchcontrol
12932 | Support for Visual Studio 2005, 2008 and 2010 has now been dropped.
12959

Added XML export to ms_ms2quantitation and cdb file export and import to record user protein-peptide ratio selections. The following methods have been renamed and moved to ms_quantitation from ms_ms1quantitation: addHeaderInfo renamed to addHeaderField, addRawFileInfo renamed to addRawFileField, clearHeaderInfo renamed to clearHeaderFields and clearRawFileInfo renamed to clearRawFileFields.

For examples, see: ms_ms2quantitation::saveXmlFile, ms_ms2quantitation::saveCdbFile, ms_ms2quantitation::loadCdbFile, ms_ms2quantitation::loadCdbFiles, ms_quantitation::addHeaderField, ms_quantitation::clearHeaderFields, ms_quantitation::addRawFileField and ms_quantitation::clearRawFileFields

12936 | Report of Error tolerant search does not display all matches when None is selected
12937 | Update from SWIG 2.0.12 to SWIG 3.0.12 for ALL languages supported by Parser
12950 | Compile Parser with GCC 4.8.5
12951 | Support for GCC 4.1 and Intel Parallel Studio XE 2013 has now been dropped. Static libraries on Linux are compiled with GCC 4.8.5 and Intel Parallel Studio XE 2016. Support for 32-bit Linux has been dropped.
12977 Support for Perl 5.8 to Perl 5.14 has been dropped on Linux. Support for Perl 5.28 and 5.30 has been added on Linux.
Support for Perl 5.8 to Perl 5.16 has been dropped on Windows. Support for Perl 5.24, 5.26, 5.28 and 5.30 has been added on Windows.
12990 | Logging: Improvements for ms_loggingmonitor required including better documentation
13020 | I don't believe PSM and PepSeq counts for Percolated results
13029 | Add ActivePerl 5.24, 5.26, 5.28, 5.30 build targets on Linux
13033 | .MSP File Format Issues (Was Error message text for ERR_MSP_NIST_MSP_NO_SPECTRA is misleading)
13047 | Crosslinking changes for protein inference and Parser results file API
13048 | Why are a third of the tests slower on Windows compared to Linux?
13101 | Add support for Python 3.6
13108 | .MSP File Format Issues #2
13122 | Mascot Server reporters error with ms-ms data when variable reporter ion modifications are selected
13124 | Segfault when caching an iTRAQ 4-plex file with variable mod group
13200 | New ms_peptidesummary constructor parameter: minimum number of significant unique sequences
13203 | Make ms_mascotresfile more const
13230 | ms_mascotresfile::appendResfile() generates lots of XML errors unless used on Mascot Server
13234 | Crosslinking method definition API and class structure
13241 | Description of getMaxPepModArrangements method in the documentation is confusing
13243 | Update unimod.xml to the latest one
13268 | ms_peptidesummary::isDataCached() returns false for BUGFIX_12740
13276 | ms_mascotresfile::getMasses() sets electron mass to 0.0 for results files from 1.9 and earlier
13278 | ms_aahelper must support ET and library mods
13284 | DEFAULT_MINPEPLENINPEPSUMMARY should be 7
13288 | ms_fragment needs a constructor for precursor NL peaks
13294 | Replace Numerical Recipes code with ALGLIB
13301 | Add flanking residues to the distiller xml MS1 quantitation results export
13310 | Peptide without required fixed mod for Reporter quant incorrectly has quant ratios
13312 | Add new option in ms_mascotoptions for suppressing PIP file creation during the search
13315 | Review default crosslinking methods in crosslinking.xml
13324 | New method ms_mascotresults::getDiscoveredLocalModDeltas(), and output order of getDiscoveredErrTolModDeltas() is ambiguous
13409 | ms_peptide::getIonsScore() and ms_mascoresults::getIonsScore() return different values with same args.
13437

Add Options: DechargeFragmentPeaks

Version 2.6.2 - released with Mascot Server 2.6.2

ID | Title
10731 | ms_processors produces bogus results for more than 64 logical CPUs
12944 | Last pretty rank 2 peptide incorrectly assigned to a protein in ms_peptidesummary cache file, caused by dangerous map deletion during iteration. Occasional exception thrown in debug mode.
13064 | New option UseHTTPProxyForHTTPS available from ms_mascotoptions::isUseHTTPProxyForHTTPS and ms_connection_settings::isUseHTTPProxyForHTTPS

Version 2.6.1 - released with Mascot Server 2.6.1

ID | Title
12276 | Documentation changes for schema paths with spaces. See, for example: ms_distiller_data::loadXmlFile .
12538 | Performance improvements when expanding proteins etc. in a 3GB results file. Used to take several minutes with some files.
12606 | The rank argument of ms_mascotresults::getHomologyThreshold has been changed from an int to an enum.
12642 | Add functionality to allow a specified range of spectra in an MSP file to be exported/saved. Additional parameters for ms_spectral_lib_file::saveAs.
12643

Add Parameter in the options section of mascot.dat to specify max number of spectra in a block. See ms_mascotoptions::getSpectraPerLibraryBlock.

12656 | Segmentation fault if you pass null as filename to ms_mascotresfile has been fixed.
12657 | New parameter in options section: number of peaks per 100 Da to choose from observed spectrum when creating library spectrum. See ms_mascotoptions::getCrawlerNumPeaksPer100Da.
12683 | User entered sensitivity count or significance threshold not working as expected for low scores in library-only search.
12689 | Fixed small memory leaks in ms_datfile, ms_mascotoptions and ms_processors.
12695 Supply additional schema files to support reading of Distiller xml files:
  • distiller_data_1.xsd
  • distiller_preferences_1.xsd
  • distiller_massdelta_1.xsd
  • distiller_master_project_1.xsd
  • distiller_quantitation_1.xsd
  • distiller_quantitation_2.xsd
12704 | New functions, ms_mascotresfile::getSLFragmentTolerance and ms_mascotresfile::getSLFragmentToleranceUnit for reading spectral library fragment tolerance.
12717 | Minor peptide sorting changes for duplicate peptides from spectral libraries.
12721 | Calling the function willCreateCache used to create the directory if it didn't exist.
12724 | Change default value for ms_mascotoptions::getPepSearchTool
12729 | When searching two or more spectral libraries mapped to the same reference, all the proteins reported are to the same SL in master_results_2
12731 | Added a new methods for annotating an MSP spectrum : ms_spectral_lib_entry::annotatePeaks and ms_spectral_lib_peak_list::annotatePeaks.
12737 | Fixed a segmentation fault if you call setReferenceFasta() before setToleranceInDa() or setToleranceInPPM()
12740 | With Percolator enabled get "Protein: KLH40_HUMAN has 1 cached, but 0 from the re-load"
12749 | Added support for std::wstring in C#

Version 2.6.0 - released with Mascot Server 2.6

ID | Title
11481 | Improvements to ms_peptidesummary::getThresholdForFDRAboveHomology and ms_peptidesummary::getThresholdForFDRAboveIdentity
12026 | More progress reports when building cache files for ms_peptidesummary with hundreds of thousands of protein hits.
12036 | Changes to ms_peptidesummary::findPeptides to support finding error tolerant modifications
12037 | Added ms_mascotoptions::getSpectrumViewerColourSchemeString
12053 | Improved examples for using ms_peptidesummary
12101 | Support for C# under Windows. See C# toolkit installation and Using the toolkit from Perl, Java, Python and C#
12121 | Mascot security doesn't allow multiple Fasta files to be specified in multiple groups. The ms_security_tasks::addTask function was just adding the first item in the array.
12172 | Implement protein inference for both database and library matches. See Spectral libraries
12173 | New mascot.dat configuration values for spectral libraries. Primarily adding a new DATABASE_TYPE
12174 | New mascot.dat Options for library search and compression tool configuration. See ms_mascotoptions::getCompressToolSL
12212 | Fixed index error in ms_mascotoptions::isDefaultTargetFDRPercentage
12222 | The module for HTTP Communication to a Mascot Server could not be used from Perl and the documentation needed improving.
12244 | Occasional failure to write session files in cases where the authentication type was IP address or computer name
12331 | Support for Perl 5.20 and 5.22 on Linux
12232 | Chimeric duplicate peptide matches missing from some queries in merged results
12244 | Occasional failure to write session files for IP address and computer name
12265 | matrix_science::ms_http_helper class needs to support https
12291 | Added a new matrix_science::ms_loggingmonitor class
12349 | Extend Percolator calculations to all ranks
12364 | Some Error tolerant search reports junk matches and average threshold score of 0
12391 | Added ms_mascotresults_params
12405 | mzIdentML export of fragment matches fails if ITOL is ppm
12408 | Add XML_SCHEMA_DIRECTORY option to ms_mascotresfile::getXMLschemaFilePath
12414 | Support Python 3
12428 | Create Python scripts for the Parser Documentation
12430 | Score distribution does not include ET matches and the values look wrong
12431 | Support Visual Studio 2015
12433 | matrix_science::ms_http_client now works properly on Linux
12438 | Supply Perl, Python and Java modules built using VS2012 rather VS2005/VS2008. See Installation on Windows, Python toolkit installation, Installation on Windows for details of Visual Studio Runtime Library requirements.
12448 | Cache file with missing quantitation if errors due to missing xsd file causes missing quantitation information
12456 | Added an additional bool parameter (addMissingResidueMasses)to the matrix_science::ms_masses constructor that takes a ms_umod_configfile parameter.
12458 | Inconsistent handling of whitespace in user parameters between cache and non-cache mode
12468 | Add ms_umod_modification::isSameAs comparison method and ms_umod_modification::getSpecificityBySiteAndPosition
12497 | New overloaded method ms_inputquery::getRetentionTimes for reading all rtinseconds values
12508 | New mascot.dat setting for ions score cutoff checkbox / edit box ms_mascotoptions::getDisplayNonSignificantMatches
12578 | Changes to updateForInstaller for Mascot Server 2.6
12604 | ms_inputquery fails to parse a peak list if it contains no colons

Version 2.5.2 - released with Mascot Server 2.5.1 and Mascot Insight 2.5.2

ID | Title
11333 | The default value returned by ms_mascotoptions::getPercolatorMinQueries is 100 and this is too low for when there are 15 features. Increased the value to 750.
11806 | Make getProteinRatio() return negative standard deviation, standard error and p-values when protein ratio type is weighted, and add a new interface to ms_protein_quant_ratio for querying the reason why the values are unavailable.
11825 | Performance improvements for ms_inputquery.
11856 | The function getNumDiscoveredErrTolMods filters peptides based on Ions score below a significance threshold. This was also being applied to the Error Tolerant peptides as well and so erroneously filtered out some error tolerant peptides and their modifications.
11858 | The Mascot Server Windows installer should now always set ForkForUnixApache to 0. If the IFLG_UPDATEAPACHEFORKOPT flag is set when calling updateForInstaller then the value passed in wst is ignored and setForkForUnixApache is always called with 'false'. This change is for Windows only.
11862 | Support filtering of peptides using decimal mass values as doubles rather than strings. See ms_mascotresults::findPeptides.
11863 | Use correct Xerces encoding transcoder when loading and saving xml files. Supports UTF-8 correctly now so that some latin characters are parsed correctly.
11883 | Add support to ms_ms2quantitation::normaliseIntensities to allow for normalisation to selected peptides or proteins when using summed intensities.
11884 | ms_ms2quantitation::getCombinedReportRatioNames now returns unique ratio names in file order rather than alphabetical order.
11885 | Warning message : Attempting to call function matrix_science::ms_peptidesummary::getPeptide before createSummary() has completed with some files where _ignoreiosscorebelow is non-zero and it is an error tolerant search.
11888 | Support for Visual Studio 2013, Update 3.
11892 | Specificity visibility class was not allowing for multiple sites of the same name that differ by position.
11899 | ms_umod_modification::findSpecGroup sorts modification sites incorrectly. For example, it does not find the correct spec group for Phospho (ST) if the input string is "Phospho (ST)" and the T specificity preceeds S in in the list of specificities. This is because the method doesn't sort the sites, so its internal string ends up as "Phospho (TS)", which is of course different from "Phospho (ST)".
11907 | ms_peptidesummary::getQuantitationComponentForPeptide, should exclude a peptide if it matches more than one component. Added code to identify ambiguous components.
11937 | Implementation of willCreateCache function that doesn't require a ms_mascotresfile object and checks both cache files.
11959 | Performance improvements for ms_mascotresfile::getRepeatSearchString.
11960 | Open cache files for writing as soon as possible to reduce potential problems with multiple processes trying to create at the same time

Version 2.5.1 - Released with Mascot Server 2.5

ID | Title
6930 | Error tolerant match with exactly the 'same' score as a standard match is not discarded.
10671 | New function: ms_mascotresults::getQuantitationComponentForPeptide
11467 | Add a new MSPEPSUM flag to specify using homology threshold for ignore ions score below. See: matrix_science::ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH
11486 | Support Perl 5.16 under Windows and Linux, and Perl 5.18 under Linux.
11545 | Cron and ExecAfterSearch in mascot.dat cannot cope with spaces in paths.
11547 | matrix_science::ms_peptidesummary::getProtein() fails to return null when dbIdx is incorrect
11622 | A residue mass of zero is not permitted in mod_file. It is allowed in a unimod file.
11634 | Report standard error as well as standard deviation. Added function: matrix_science::ms_protein_quant_ratio::getStandardError
11686 | Added support for global and per-group modification visibility for matrix_science::ms_umod_configfile
11705 | Improved behaviour for chimeric spectra. New flag: matrix_science::ms_peptidesummary::MSPEPSUM_REMOVE_CHIMERIC_DUPES
11708 | ms_peptide::getAnyMatch was broken and always returned true in version 2.4.4 and version 2.5.0
11718 | Added new functions: getNumDistinctPeptideRepeats and getDistinctPeptide
11797 | ms_datfile::updateForInstaller shouldn't update parse rules if Database Manager is being used.

Version 2.5.0.1, 27th February 2014, released with Mascot Insight 2.5.1

ID | Title
11679 | ms_ms2quantitation is not taking uniquePepseq value from the passed quantitation method
11717 | If peptide ratios are manually excluded from a protein ratio then values from duplicate same query are used

Version 2.5.0, 26th November 2013, released with Mascot Distiller 2.5 and Mascot Insight 2.5

ID | Title
10290 | Added support for HTTP Communication to a Mascot Server
11234 | Move quantitation support from the perl cgi scripts to Mascot Parser. See Peptide and protein quantitation
11235 | Added a new function: ms_mascotresults::getProteinEmPAI
11358 | When combining results files, need to check that quantitation methods match rather than just comparing names. Added a new function isMethodCompatible
11392 | Need to be able to return std::string & parameters in Java. SWIG supports returning references to native types in Java by passing a single element array of, for example an int. However, it doesn't support this for std::string. Where a parameter is a std::string & it is now necessary to supply a StringBuffer object which will be modified by Parser. Note that const std::string & parameters are unaffected, and still expect a Java String
11399 | Simplify the requirements for specifying the location of the unimod and quantitation schema files when using ms_mascotresfile. See Specifying xml schema file locations
11409 | Temporary cdb file created even when MSPEPSUM_DISCARD_RELOADABLE not specified. Minor performance issue, but no other side effects.
11411 | Save qmatch and qploghole in the cdb file to improve performance.
11415 | ms_mascotresfile now inherits from the ms_errors class. See ms_mascotresfile now inherits from ms_errors
11422 | Under Windows, file sizes stored in cdb files are limited to 32 bits. Larger files had 'wrapped around' values and cdb files will be rebuilt automatically for these files.
11425 | New function ms_mascotresults::getIonsScore to return an ions score more rapidly than calling ms_mascotresults::getPeptide and then ms_peptide::getIonsScore
11438 | The functions ms_mascotresfile::getObservedCharge and ms_mascotresfile::getObservedMrValue need an optional parameter for specifying the summary or decoy summary section
11513 | Save the values returned by ms_protein::getCoverage in the cache
11568 | Remove support for Mascot Integra
11631 | Sign the msparser.jar file using a CA trusted certificate

Version 2.4.4, 4th November 2013. Released with Mascot Server 2.4.2

ID | Title
10873 | Support Python 2.7
11559 | Add MISECTASK_ flags for Mascot Insight to the security_tasks.xml file
11560 | MSPEPSUM_DISCARD_RELOADABLE and MSRES_INTEGRATED_ERR_TOL are incompatible.

Version 2.4.3, 1st October 2012. Released with Mascot Server 2.4.1

ID | Title
11115 | Provide interface to the tree/hierarchical cluster method of the C Clustering library: ms_treecluster.
11266 | New function: ms_mascotresfile::getNumEtSeqsSearched().
11190 | The function getProteinTaxonomyIDs() now also returns taxonomy IDs for PMF results where they are available for Mascot 2.4.1 and later. In version 2.4.0, it only returned values from the proteins section (for ms-ms searches).
11269 | Incorrect return value for getObservedCharge() when the charge state is greater than 8+.
11275 | Additional return values for getThresholdForFDRAboveIdentity() and getThresholdForFDRAboveHomology()
11305 | Get error: "Requested query 1, hit -64 in function ms_proteinsummary::getPeptide" with some PMF mixture results when creating a ms_proteinsummary

Version 2.4.2, 26th July 2012. Released with Mascot Distiller 2.4.3

ID | Title
11182 | Support streaming of compression date using ms_zip
11185 | Support for multiple modifications on one site in ms_aahelper. See: Multiple modifications for the same site for details.
11201 | ms_aahelper constructor using a results file needs path(s) to unimod schema and needs to report errors when the schema cannot be found.

Version 2.4.1, 23rd April 2012. Released with Mascot Server 2.4.0

ID | Title
10471 | Load and save mascot.dat using matrix_science::ms_datfile can move comments around. Also added functions: matrix_science::ms_datfile::getHeaderComments matrix_science::ms_datfile::setHeaderComments matrix_science::ms_customproperty::getPreceedingComments matrix_science::ms_customproperty::setPreceedingComments
10797 | Added functions to save and load custom parameters for ms_group and ms_user. See: matrix_science::ms_group::saveStringParam and matrix_science::ms_user::saveStringParam
10798 | New functions matrix_science::ms_mascotoptions::getReportBuilderColumnArrangement and matrix_science::ms_mascotoptions::setReportBuilderColumnArrangement
10823 | New function matrix_science::ms_peptide::getSummedModsStr for improved support in Mascot 2.4 for modifications on labelled residues. See also Multiple modifications for the same site
10874 | New function matrix_science::ms_taxonomyrules::getSpeciesFormatRegex() for additional regular expression in the Taxonomy_n section to read speclist.txt
10906 | New function matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity returns false and fails to find reasonable values for some Percolator files
10943 | Cron emulator improvements including new ms_cronoptions functions: getLoggingLevel(), setLoggingLevel(), getLogFileName() , setLogFileName() , deleteCronJob() and setCronJob() and new ms_cronjob functions: isEnabled() and setEnabled()
10979 | Add support for RAWFILE and LOCUS to matrix_science::ms_inputquery
10991 | matrix_science::ms_mascotresfile::versionGreaterOrEqual returns incorrect value.
10995 | Internal change to allowed values for identity threshold.
11002 | Change minPepLenInPepSummary functionality. Don't show proteins in which the only significant peptides have length < MinPepLenInPepSummary.
11018 | matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity and matrix_science::ms_mascotresults::getThresholdForFDRAboveHomology can fail to get the best values.
11042 | matrix_science::ms_mascotresfile doesn't fail safely if a cache file cannot be created due to incorrect permissions. Issue was introduced when Bug 10745 was fixed in version 2.4.0.
11041 | On 64 bit Linux only, the function matrix_science::int ms_mascotresults::getQmatch() can return a 'wrapped' negative number in the extremely rare case of the qmatch_x= value being > INT_MAX. In such cases, it now returns INT_MAX on all platforms.
11094 | Using matrix_science::ms_peptidesummary::MSPEPSUM_NO_PROTEIN_GROUPING can cause a crash when creating a ms_peptidesummary object.

Version 2.4.0, 9th August 2011. Released with Mascot Distiller 2.4

ID | Title
10536 | IgnoreIonsScoreBelow is converted to a score and rounded to an integer internally. First fixed as bug #567 in version 2.3, but this minor issue was re-introduced in version 2.3.1
10610 | "Possible duplicate accession string" errors caused by two accessions that only differ in upper/lower case.
10611 | Memory efficient mode for large search results. See matrix_science::ms_peptidesummary::freeHit and matrix_science::ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE
10621 | Added new class: matrix_science::ms_taxonomytree and function: matrix_science::ms_mascotresults::getProteinTaxonomyIDs to support additional taxonomy information available in Mascot 2.4 and later.
10622 | Added functions matrix_science::ms_mascotresults::createSummary, matrix_science::ms_mascotresults::getCreateSummaryProgress and matrix_science::ms_mascotresults::cancelCreateSummary to enable an application to cancel creating an ms_peptidesummary object.
10623 | Confusing error messages if ExecAfterSearch logging level set incorrectly.
10624 | Increase 2Gb CDB file size limit to 4Gb for 32 bit applications.
10626 | Font size in chm (help) file is too large.
10627 | On Windows, NTFS, cache files get re-created when going to/from daylight savings. Cache directory names also change.
10628 | New function: matrix_science::ms_mascotresfile::resetKeepAlive and added a %f tag for displaying the filename, which is useful with Combining multiple .dat files
10629 | Small memory leak in protein family grouping.
10630 | New function: matrix_science::ms_connection_settings::setUserAgent() and matrix_science::ms_connection_settings::getUserAgent()
10631 | Rare crash when using results cache with family summary and minPepLenInSearch < minPepLenInPepSummary.
10632 | ms_protein copy constructor is not reliable when using the results cache
10634 | ms_protein copy constructor is not reliable when using the results cache
10652 | Cannot load protein description line from ms_mascotresfile when protein accessions contain an = sign.
10657 | matrix_science::ms_peptide::getProteins() can return incomplete list when lead protein in a family is not the highest scoring.
10668 | Added function matrix_science::ms_mascotresfile::getMultiFileQueryNumber useful with Combining multiple .dat files
10673 | Added function matrix_science::ms_mascotresults::findProteins and added flags for searching for modifications.
10682 | Added functions: matrix_science::ms_mascotoptions::setIgnoreDupeAccession() and matrix_science::ms_mascotoptions::setReportNumberChoice()
10704 | Add support for a taxonomy rule where TaxID explicitly given.
10711 | Make matrix_science::ms_tinycdb thread safe.
10712 | Add a method to matrix_science::ms_session to return the timeout value.
10716 | New functions matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity and matrix_science::ms_mascotresults::getThresholdForFDRAboveHomology.
10734 | Use only the filename part of result files when constructing the cache filename for a multi-file peptide summary.
10745 | Creating an ms_mascotresfile object with a 'junk' file when specifying RESFILE_USE_CACHE creates a (tiny) cache file. The second time the ms_mascotresfile object is created with the same parameters, it reads the tiny cache file but fails to set the INVALID_RESFILE error.
10749 | matrix_science::ms_mascotresfile::getNumQueries() incorrectly returned -1 for the last file in a multi-file result set.
10780 | Change definition of matrix_science::ms_mascotresults::isPeptideUnique to be unique per family member rather than per family.
10804 | Change matrix_science::ms_mascotresults::getPeptideThreshold() to allow return of either homology or identity threshold as double.

Version 2.3.3, 11th October 2010. Released with Mascot 2.3.02

ID | Title
461 | matrix_science::ms_umod_configfile::getElementByName() hangs if called with null argument. Now just returns NULL.
596 | Documentation improvements and restructuring of some of the help.
614 | matrix_science::ms_aahelper::createPeptide now supports more than 9 variable modifications.
629 | Added matrix_science::ms_peptidesummary::FC_SEARCH_ALL_RANKS for use with matrix_science::ms_peptidesummary::findPeptides
630 | Accession strings with spaces in are truncated when loading proteins from cache.
632 | Added new function matrix_science::ms_peptidesummary::getFlags2()
633 | MinPepLenInPepSummary not used for family gouping. Also added function matrix_science::ms_peptide::getPeptideLength.
634 | matrix_science::ms_datfile error message says that 'mascot.dat. file does not exist even when opening file with different name, for example 'not.mascot.dat'. Change message to output the name of the file.
635 | Added support for Combining multiple .dat files
638 | matrix_science::ms_mascotresfile::getRepeatSearchString does not include scans, rawscans, rtinseconds and index
639 | Added matrix_science::ms_mascotresfile::enumerateQuerySectionKeys
641 | Unigene reports too slow. A cache file is now created and used automatically. See matrix_science::ms_unigene
644 | Added tags to pass through session_id and task_id in matrix_science::ms_mascotoptions::getExecAfterSearch
645 | Can't load family report for an ET search with ignoreIonsScoreBelow >0 and < 1
647 | Add Support for Python under Linux. See Python toolkit installation
649 | Performance improvements for matrix_science::ms_mascotresults::getProteinDescription and matrix_science::ms_mascotresults::getProteinMass
653 | Very slow to create cache files when > 100k potential proteins in the results file.
654 | Concurrency issue on Windows when using matrix_science::ms_session
655 | matrix_science::ms_fragment::getLabel returns an string with a truncated rather than a rounded neutral loss. For MetOx, this reports -63 rather than -64.
656 | Concurrency issue: if two processes try to create a directory using matrix_science::ms_fileutilities::createDirectory at the same time, one process may fail.

Version 2.3.2, 11th May 2010. Released with Mascot 2.3.01

ID | Title
624 | Family grouping no longer requires that the top scoring protein for a group appears as a lead protein. There are cases where more compact grouping can be obtained by making the highest scoring protein a subset/intersection.
626 | In rare cases, a protein could be marked as a subset when it should have been another family member. This is because the algorithm defined a protein as a subset when all of the peptides were found in any other protein, rather than any other family member protein.
627 | Change to matrix_science::ms_aahelper::ms_aahelper constructor when creating from a matrix_science::ms_mascotresfile. Added an additional optional parameter to pass a quantitation schema that will be used before calling matrix_science::ms_mascotresfile::getQuantitation
628 | Functions matrix_science::ms_protein::getNumDisplayPeptides and matrix_science::ms_protein::getNumDistinctPeptides return incorrect values for an error tolerant search when the flag for aboveThreshold is set to true. Error tolerant matches are now ignored in this case.

Version 2.3.1, 29th March 2010. Released with Mascot 2.3

See Upgrading to Mascot Parser 2.3.x from 2.2.x For a summary of changes required to scripts using Mascot Parser 2.2,

ID | Title
17 | Would like to collapse peptides that only differ with Isoleucine <-> Leucine. For the new protein grouping, peptides with the same same score and same query are considered to be the same, so, for example, Q <-> K will also collapse if the tolerances are wide enough.
117 | matrix_science::ms_mascotresults::getNextSubsetProtein is now significantly faster.
511 | Increase maximum number of enzyme cutters from 5 to 20 and improve error message and documentation.
523 | Mascot security doesn't work when specifying user_type=computer_name on Apache. This was because the session file names are case sensitive under unix.
531 | Allowed p value for significance threshold has been changed from 0 < p < 0.1 to 1E-18 < p < 1.
569 | Change homology threshold reporting. Can now report a homology threshold value where the qmatch value is less than 100 and the version is Mascot 2.3 or later.
575 | Session timeout fails to give an error if the session file has been deleted and guest is enabled.
582 | Support 64 bit Java for Windows.
583 | Better support for AMD processors.
584 | Added a flag to matrix_science::ms_umod_configfile::save_buffer() for whether to validate.
585 | Added matrix_science::ms_tinycdb for giving access to tinycdb files.
586 | Cache the ms_peptidesummary results. See Caching Mascot Results
587 | matrix_science::ms_mascotresults::isNA() should look in peptide matches and not protein matches. It used to return incorrect results in cases where there were no significant protein matches.
588 | Add a function to return a 'histogram' for all ions scores. Added: matrix_science::ms_mascotresults::getIonsScoreHistogram()
589 | matrix_science::ms_aahelper::calcFragmentsEx() used to not take fixed modifications into account for searches where a quantitation method was specified.
590 Added functions:
  • matrix_science::ms_inputquery::getRawScans
  • matrix_science::ms_inputquery::getIndex
Added additional parameter to:
  • matrix_science::ms_mascotresfile::getNumSeqs()
  • matrix_science::ms_mascotresfile::getNumSeqsAfterTax()
  • matrix_science::ms_mascotresfile::getNumResidues()
  • matrix_science::ms_inputquery::getScanNumbers
  • matrix_science::ms_inputquery::getRetentionTimes
593 | Add a function: matrix_science::ms_protein::getNumUniquePeptides()
594 | Add a function: matrix_science::ms_umod_modification::getRecordID()
595 Add functions to find accessions, descriptions, masses, sequences:
  • matrix_science::ms_peptidesummary::findProteinsByAccession()
  • matrix_science::ms_peptidesummary::findProteinsByDescription()
  • matrix_science::ms_peptidesummary::findPeptides()
598 | Add Using Percolator scores
600 | Add function to retrieve flags and other parameters required for creating an ms_peptidesummary or ms_proteinsummary.
601 Quantitation: Support Multiplex with multiple ions series (e.g. for IPTL)
Deprecated functions:
  • haveIonSeries()
  • dropIonSeries()
  • setIonSeries()
New funtions:
  • getNumberOfIonSeries()
  • clearIonSeries()
  • appendIonSeries()
  • getIonSeries() (New optional index parameter)
  • updateIonSeries()
  • deleteIonSeries()
Updated schema from 2.0 to 2.1
606 | matrix_science::ms_protein::isShowSubsets() does not read the value from mascot.dat because it is looking for ShowSubsets rather than ShowSubSets
607 Call to delete should be delete [] in ms_mascotresfile destructor. Will show up in valgrind as
          Mismatched free() / delete / delete []
            at 0x4C20A6E: operator delete(void*) (vg_replace_malloc.c:346)
            by 0x5B89ACB: matrix_science::ms_mascotresfile::~ms_mascotresfile()
613 | The only way to be able to get an ms_peptide object is to have an ms_mascotresults object which can be slow, so add a new flag to create an ms_peptidesummary object with no proteins. New flag added: matrix_science::ms_peptidesummary::MSPEPSUM_NO_PROTEIN_GROUPING
615 | Support for EMBL EST Taxonomy and Unigene. New enumeration: matrix_science::TAX_SPECIES_ACC2TAXID

Version 2.3, 17th June 2009. Used with Mascot Distiller 2.3

ID | Title
198 | Added matrix_science::ms_protein::getPepNumber() function, for when you're working bottom to top
456 | Added matrix_science::ms_mascotresfile::getMasses() function to create an ms_masses object from ms_mascotresfile.
465 | Additional function for PMF iteration: matrix_science::ms_protein::getMasses
471 | Added the function matrix_science::ms_peptidesummary::getQueryList(QL_FLAG flag) for an easier repeat search. Requires Mascot 2.3
474 | In security, add parameter to restrict spoofing. Additional security task: matrix_science::ms_security_tasks::SECTASK_SPOOFNAMEDGROUPSONLY and function matrix_science::ms_session::getSpoofableUsers() that is used in Mascot 2.3 ms-status.exe for the Show=MS_USERS command.
497 | matrix_science::ms_umod_element::setMonoMass and setAvgMass now check input parameters correctly
514 | Added a new matrix_science::ms_aahelper::ms_aahelper constructor to create an object based on the masses and modifications in a results file. Makes it easier to produce the tables found, for example in the peptide view table.
530 Initial implementation of new protein grouping for Mascot 2.3.
Warning: This code is experimental and there may be further changes before Mascot 2.3 is released
Additional flag: matrix_science::ms_peptidesummary::MSRES_CLUSTER_PROTEINS and additional function: matrix_science::ms_peptidesummary::getNextFamilyProtein
Added matrix_science::ms_mascotresults::getTreeClusterNodes which is used to provide values for producing the dendrograms in the Mascot 2.3 reports. Note that new license C Clustering library needs to be included in applications that use Mascot Parser
536 | Added a function: matrix_science::ms_peptidesummary::getAllProteinsWithThisPepMatch
538 | Added matrix_science::ms_mascotresfile::getFastaPath to retrieve the path to the fasta file(s) used in a search
540 | Support Perl 5.10. See Perl toolkit installation for details of which versions of Perl are supported on which platforms
542 | h1_q1_et_mods_pep and reqpep were not retrieved properly. This only affected protein summary, where they are are not used in the standard Mascot protein summary reports which don't show error tolerant matches
545 Added support for searches against multiple databases (introduced in Mascot 2.3). Existing functions just have an added optional parameter.
  • matrix_science::ms_searchparams::getNumberOfDatabases - [new function]
  • matrix_science::ms_searchparams::getDB - [function updated]
  • matrix_science::ms_mascotresfile::getFastaPath - [function updated]
  • matrix_science::ms_mascotresfile::getFastaVer - [function updated]
  • matrix_science::ms_mascotresults::getProtein - [function updated]
  • matrix_science::ms_protein::getDB - [new function]
551 | Added functions matrix_science::ms_umod_configfile::getMajorVersion() and matrix_science::ms_umod_configfile::getMinorVersion().
552 | Added matrix_science::ms_mascotoptions::getMinEtagMassDelta and matrix_science::ms_mascotoptions::getMaxEtagMassDelta .
556 | Memoryleak in ms_modfile fixed
557 | Added matrix_science::ms_mascotoptions::getMaxDatabases function.
558 Support for Quantitation version 2 schema. A number of functions have been added and some deprecated:
  • Added: matrix_science::ms_quant_average::getNumPeptides, matrix_science::ms_quant_average::getSelection, matrix_science::ms_quant_average::getReferenceAccession
  • Added: matrix_science::ms_quant_component::getSatellite
  • Added: matrix_science::ms_quant_configfile::getMajorVersion matrix_science::ms_quant_configfile::getMinorVersion
  • matrix_science::ms_quant_integration - a number of functions have been deprecated
  • Added: matrix_science::ms_quant_integration::getMatchedRho matrix_science::ms_quant_integration::getXicThreshold matrix_science::ms_quant_integration::getXicMaxWidth matrix_science::ms_quant_integration::getXicSmoothing matrix_science::ms_quant_integration::isAllChargeStates matrix_science::ms_quant_integration::getAllChargeStatesThreshold
  • Added: matrix_science::ms_quant_normalisation::getPeptides matrix_science::ms_quant_normalisation::getProteins
  • matrix_science::ms_quant_precursor - a number of functions have been deprecated.
  • Added: matrix_science::ms_quant_quality::isUniquePepseq matrix_science::ms_quant_quality::getIsolatedPrecursorThreshold
  • Added: matrix_science::ms_quant_reporter::getReporterTol
559 | Added Caching Mascot Results
560 | Add basic support for ontology files in the .obo format. See matrix_science::ms_obofile .
561 | Added a function matrix_science::ms_mascotresults::getQmatch to retrieve the the qmatch value from the results file.
564 | The default value for matrix_science::ms_mascotoptions::getInterFileBasePath was C:/InetPub/Mascot/data for Linux and Unix platforms.
565 | For Java, throw an exception if out of memory
566 | Added a security task matrix_science::ms_security_tasks::SECTASK_MAXNOENZQUERIES that enforces a separate query limit for no enzyme searches
567 | IgnoreIonsScoreBelow was converted to a score and rounded to an integer internally. No internal rounding performed now.
568 | Add simple_ratio to integration in quantitation_2
573 Quantitation reporter protocol: need to be able to specify a mod as required. Added functions:
  • matrix_science::ms_quant_modgroup::haveRequired
  • matrix_science::ms_quant_modgroup::isRequired
  • matrix_science::ms_quant_modgroup::setRequired
  • matrix_science::ms_quant_modgroup::dropRequired
  • matrix_science::ms_quant_modgroup::getRequiredSchemaType
574 | Added matrix_science::ms_peptidesummary::isPeptideUnique for quantitation support
577 | Finer control over progress reports. See matrix_science::ms_mascotresfile::outputKeepAlive
578 | Experimentatl support for Python. Windows only for now. See Python toolkit installation
579 | More security tasks: matrix_science::ms_security_tasks::SECTASK_MAXFASTAFILES and matrix_science::ms_security_tasks::SECTASK_DENYQUANT

Version 2.2.8, 25th June 2009 - Used by Mascot Server 2.2.06

ID | Title
581 | Patch for Dunnington, i7 and Nehalem processors for Linux. (Bug #562 only supported Windows)

Version 2.2.7, 8th January 2009 - Patch for Dunnington, i7 and Power5+ processors. Used by Mascot 2.2.05

ID | Title
562 | Support for Dunnington and Intel i7 processors.
563 | Support for Power5+ processors.
458 | matrix_science::ms_processors class may give incorrect information about number of cores per cpu in 64 bit Windows. (Linux and 32 bit Windows unaffected).

Version 2.2.6, 5th September 2008 - Used by Mascot Distiller 2.2.0

ID | Title
546 | The function matrix_science::ms_masses.copyFrom leaves a dangling pointer.
550 | Added statistical algroithm for use by Distiller to the Mascot utilities and tools module.

Version 2.2.5, 26th June 2008

ID | Title
509 | matrix_science::ms_mascotresults::createUnassignedList did not free some memory when the ms_mascot_results object was deleted.
539 | Add support for UltraSPARC T1 and T2, and IV+ processors
543 | Corrupt text could be caused by unicode characters in reference fields in unimod.xml. Error returns from Windows functions are now handled properly.

Version 2.2.4, 5th March 2008

ID | Title
532 | Support mingw and a more recent version of gcc. See Using the MinGW compiler
526 | Performance improvements in calls to getHomologyThreshold()
522 | The example code, create_mgf.pl misses last peak
520 | Add matrix_science::ms_peptide::getNum13C function
519 | Support Java 6. Previous releases would occasionally crash with Java 6 on Windows
518 | Need to escape spaces in schema file paths that are passed to Xerces.
493 | ms_proteinsummary is wrong for NA searches where there are hits from different frames. Instead of reporting a separate protein hit for each frame, the results are merged into one hit.

Version 2.2.3, 22nd June 2007

The following items were fixed in this release which was shipped with Mascot Server 2.2.02

ID | Title
512 | Calls to matrix_science::ms_fileutilities::setAccessRights can result in security tokens being repeated multiple times. (Only visible using command line cacls)
508 | matrix_science::ms_modification::setNeutralLoss could not be called from java or perl
507 | Trailing tabs in database definition line caused problems for some 3rd party software

Version 2.2.2, 18th April 2007

The following items were fixed in this release which was shipped with Mascot Distiller 2.1.1

ID | Title
504 | Failed to retrieve a remote configuration file when using an https Mascot server
502 | Failed to retrieve a remote configuration file when a proxy server requires a username and password to be specified

Version 2.2.1, 26th March 2007

The following items were fixed in this release which was shipped with Mascot 2.2.1

ID | Title
482 489 | Changes to matrix_science::ms_datfile::updateForInstaller for Windows installer

Version 2.2.0, 15th March 2007

The following items were fixed in this release which was shipped with Mascot 2.2

ID | Title
485 | Change matrix_science::ms_databases::findDatabase to allow searching of inactive databases
473 | The limit of 64 databases should only count active databases
481 | Added a function for Mascot installers to perform all required changes to mascot.dat. See matrix_science::ms_datfile::updateForInstaller()
480 | ms_license fails to report an error message in some cases
476 | Add support for a feature string in the mascot license file (required for BigMascot)
470 | standalone="no" is now omitted in xml-documents
466 | Add new function: matrix_science::ms_processors::getNumCores()
462 | Bugs in plpa library for 64 bit Linux fixed.
460 | Increase limit on number of parse rules from 64 to 256
449 | Homology threshold now uses the significance threshold value
447 | Mudpit score now decreases when the significance threshold is decreased
453 | Added matrix_science::ms_mascotoptions::getMaxVarMods() and matrix_science::ms_mascotoptions::getMaxEtVarMods()
451 | Errors now detected while saving config files
448 | Issue with leading space in comments when modifying mascot.dat fixed
446 | There are no longer and unicode versions of the Parser library for Windows. Applications that are compiled with unicode support should still be able to link against the non-unicode versions of Parser
444 | If modification is missing from ms_modvector, ms_aahelper crashes and burns
370 | Download of unimod.xml (0.5Mb) will be too slow over the internet. Parser now downloads the compressed unimod.xml, using the matrix_science::ms_zip class
442 | Curl support has never worked on 64 bit AIX and possibly other platforms
441 | Unigene support has never worked properly on 64 bit AIX release, (and possibly SGI/Sun/Tru64). The 64 bit Linux versions were not affected by this issue
440 | Add a new option to mascot.dat - access through matrix_science::ms_mascotoptions::getMaxPepNumVarMods
439 | ShowSubSets is now a double rather than a boolean. Add matrix_science::ms_mascotoptions::getShowSubsets and allow matrix_science::ms_mascotoptions::setShowSubsets to take a double as well as a boolean value
414 | 64 Bit Windows in now supported using Visual Studio 2005, service pack 1. This is available as a separate package
320 | Support for files > 2Gb introduced a file handle leak bug when accessing parameters in the query sections.
438 | Add matrix_science::ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB. See matrix_science::ms_peptidesummary::ms_peptidesummary for details.
437 | Add security task matrix_science::ms_security_tasks::SECTASK_SEESEARCHINANYGROUP for the right to view searches for all users in all groups belonged to. Shouldn't require any changes to any third party applications that call matrix_science::ms_session::canResultsFileBeViewed
436 | File Handle Leak in matrix_science::ms_mascotresfile with a zero byte file
435 | Spaces at the start of all configuration files are now stripped.
434 | A database name that starts with End is treated as the end of the database section.
433 | Preliminary support for UniGene section in mascot.dat: See matrix_science::ms_unigeneoptions. The main aim purpose of this change is to get the mascot.dat file to save correctly for the installation program.
427 | matrix_science::ms_enzyme::verifyEnzyme doesn't complain about numbers in restrict and and also allows lower case letters.
423 | Integrated error tolerant - numerous further changes, but may be complete now?
424 | ms_fragmentationrules::verifyRule - further additions to rules
427 | verifyEnzyme doesn't complain about numbers in restrict and and also allows lower case letters.
430 | Added z+2 series
154 | Sort order for peptide summary with single etag - now sorted by delta.
253 | Integra session files now get deleted properly. They now use the default timeout period.
293 | When logging in using the 'guest' username, guest session files, such as guest_12312312313 session no longer get created.
295 | Show Sub-sets is now a fraction, not boolean. See Grouping proteins together
298 | matrix_science::ms_aahelper::createPeptide documentation improved.
320 | File larger than 2Gb can now be read on 32bit parser.
335 | Calling matrix_science::ms_mascotresults::createUnassignedList for a protein summary when there is no protein summary no longer gives errors, but just creates an empty list.
337 | Mascot Integra users can no longer log in through Mascot - they must login through Integra.
343 | Taxonomy strings can now contains commas.
391 | Add method to ms_umod_modification to generate ms_modification objects.
393 | Threshold cut-offs have changed. Old behaviour was to suppress the homology threshold if there were less than 1000 sequences in the search. New behaviour is to supress the threshold if qmatch is less than 100. There is also now a minimum for identity threshold of 13.
409 | Verify enzyme used to return false if Restrict was empty
420 | matrix_science::ms_mascotresults::getIonsScoreCorrected was incorrect if ITOL units were mmu rather than Da
421 | Added matrix_science::ms_mascotoptions::getMudpitSwitch() and matrix_science::ms_mascotoptions::getSelectSwitch()
415 | Support for minInternalMass and maxInternalMass. See matrix_science::ms_fragmentationrules::getMinInternalMass() matrix_science::ms_searchparams::getMinInternalMass() and matrix_science::ms_inputquery::getMinInternalMass()
413 | New security params - varmods, varmods ET, num accessions. See matrix_science::ms_security_tasks::SECTASK_MAXVARMODS matrix_science::ms_security_tasks::SECTASK_MAXETVARMODS matrix_science::ms_security_tasks::SECTASK_MAXETACCESSIONS
410 | Add PSI_MS_Name ( ex_code_name) and maybe Approved. See matrix_science::ms_umod_modification::getExCodeName() and matrix_science::ms_umod_modification::isApproved
408 | Remove limit of 1024 mods - make it unlimited
407 | msparser class ms_umod_xref needs to have url-property
397 | Speed up ms_inputquery
396 | Output keep alives in matrix_science::ms_peptidesummary::createUnassignedList()
394 | Example C++ projects have the wrong compiler options for debug DLL versions
385 | Added matrix_science::ms_inputquery::getScanNumbers() and matrix_science::ms_inputquery::getRetentionTimes()
384 | mascot.dat Options functions missing: SortUnassigned etc.
358 | getTagStart, getTagEnd, getTagSeries stuck in infinite loop
313 | Unigene file parsing not quite right. File format change in unigene files now processed properly
402 | add validation precedures to fragrules and enzymes
395 | Keep alives need to be flushed. On Linux, the keep alive html comments are kept in a buffer and not flushed. This means, assuming that the standard text and default time of 5 seconds is used, that it takes 20 minutes for something to appear.
386 Support for mulitple neutral losses. The function matrix_science::ms_searchparams::getVarModsNeutralLosses which returns an array of neutral losses has been added.
matrix_science::ms_searchparams::getVarModsPepNeutralLoss and matrix_science::ms_searchparams::getVarModsReqPepNeutralLoss have also been added.
387 | The functions: matrix_science::ms_searchparams::getFixedModsName matrix_science::ms_searchparams::getFixedModsDelta matrix_science::ms_searchparams::getFixedModsNeutralLoss matrix_science::ms_searchparams::getFixedModsResidues have been added.
329 | Return the new parts of the results file required for quantitation
332 | Support decoy search results
338 | New option ResultsFileFormatVersion in mascot.dat
339 | ICAT mods mapping accepts only modnames without spaces
355 | Need to escape text in ms_inputquery::getINSTRUMENT() and ms_inputquery::getIT_MODS()
356 | Need to read enzyme and taxonomy sections of resfile
373 | getSeriesName returns empty string for ion series 19,20
376 | setDelta() for unimod modification disables mod delta
326 | If an old ICAT search is repeated with Mascot 2.2 or later, then the ICAT=ON should be translated to QUANTITATION=ICAT. The name 'ICAT' is retrieved from the options section of mascot.dat using getICATQuantitationMethod()
327 | If the require bold red flag is set, then the wrong protein number used to appear in the yellow popup. The protein accession string was correct.
328 | Further changes to quantitation.xml design. [Remove from 2.2 changes list]
330 | Support MODS and INSTRUMENT at the query level. See getINSTRUMENT(), getRULES() and getIT_MODS(). Needed for instruments that, for example, can switch between ETD and CID.
329 | Support more than 9 variable mods. See Increase in the number of variable modifications for details on the impact of this to existing clients using Mascot Parser.
333 | Add 3 new search parameters: getQUANTITATION() , getPEP_ISOTOPE_ERROR() and getDECOY()
248 Support for new PMF iterations introduced in Mascot 2.2
See: matrix_science::ms_mascotresfile::isPmfQueryUsed()
297 | A Java or Perl application calling matrix_science::ms_aahelper::calcFragments can now access the fragments array.

Version 2.1.03, 9th March 2006

The following items were fixed in this release which was shipped with Mascot 2.1.04

ID | Title
300 | Support high charge state fragments in aa_helper. Mascot only matches singly and doubly charged fragments, and there are no plans to change this. However, if someone wants to label peaks with higher charge states in Mascot Distiller or any other product that uses Mascot Parser, they can now do this.
301 | aa_helper used to give a negative peptide mz value for negative charge.
302 | calcPeptideMz() now gives correct mz values for higher charges.
307 | A dual core Xeon system with HT disabled in the bios was not detected correctly. The work-around was to enable HT in the bios.
310 | Process Affinity was not working on some 2.6 kernels (Linux). This has been fixed by using the PLPA library from Open-MPI.

Version 2.1.02, 18th October 2005

The following items were fixed in this release which was shipped with Mascot 2.1.02

ID | Title
263 | If a search was run using 'MONOISOTOPIC' rather than 'Monoisotopic', then a repeat search using search_form.pl would submit the second search using average masses because it doesn't recognise MONOISOTOPIC. This has been fixed in this parser release.
270 | The Tru64 release of parser 1.x sometimes gives a different sort order for the concise protein summary due to a bug in the Tru64 compiler. This problem has been fixed in this release by using a patched Tru64 compiler.
276 | Advanced topic! MSRES_DUPE_REMOVE_A will always be set which causes incorrect filtering when modifying these advanced flags. This does not affect any standard reports.
280 | getNextSubsetProtein() now always returns false unless MSRES_SHOW_SUBSETS is set. This makes coding for the client a little easier and more transparent.
281 | In cases where the highest scoring protein has no bold red peptides, selecting REQUIRE_BOLD_RED used to return no hits. Obviously, it is very rare for the highest scoring protein to not have any rank 1 peptide hits.
282 | Add SECTASK_BIOTOOLSBATCH in preparation for next Bruker Biotools release. Added this task to the PowerUsers group.
283 | Some customers still have systems with the electron mass being incorrect from the Mascot 1.9 installation. 'Fudge' the code by returning the correct value (0.000549) if the value in the file is 0.00549. If, so some bizarre reason, you really want the electron mass to be 0.00549, then specify it as 0.005490 in the masses file.
285 | The matrix_science::ms_processors class now supports dual core AMD Opteron and reports that process affinity is available on Linux 2.6 kernels. Additional functions are now available to determine the name of the processor manufacturer and a description of the hyperthreading/multi-core/SMT functionality on the processor.
286 | matrix_science::ms_protein::getFrame used to return -1 for protein database if the search was PMF. It now returns 0 as specified in the documentation.
287 and 290 | Using the require bold red flag, it was possible to get occasional matches to proteins without any bold red peptides.

Version 2.1.01, 24th June 2005

The following items were fixed in this release which was shipped with Mascot 2.1.01

ID | Title
261 | Java version of ms_aahelper fails. C++ and Perl worked OK.
262 | Passing a directory name rather than a file name caused a crash.
266 | ms_searchparams::getUSERID returns -1 for old searches - meaning that it is impossible to see old searches unless the view all searches token is set.
267 | In rare circumstances, a single peptide match generates multiple protein hits. Only happens at the random matching level and if minPepLenInPepSummary is non-zero.
267 | getErrTolModMasterNeutralLoss() returned an incorrect value.
272 | Java Parser on Linux fails to run.
273 | Performance improvement for results files with matches to a large number of ambiguous residues

Version 2.1.0, 30th April 2005

The following items were fixed in this release which was shipped with Mascot 2.1

ID | Title
2 | Read and parse the Mascot configuration files. See Mascot configuration files module
122 | Ambiguous residues coped with transparently. matrix_science::ms_peptide::getPeptideStr now takes an optional argument to specify whether ambiguous residues are reported with the substituted value
126 | Documentation - ms_searchparams class reference had multiple references to MASS=
142 | ms_protein::getFrame() is now a const function
143 | Documentation - now specifies that oneInXProb has lower limit of 10
144 | Documentation - now specifies that 0 is returned for auto in matrix_science::ms_searchparams::getREPORT()
145 | Documentation - matrix_science::ms_peptide::getIonsIntensity() is now clearer
146 | Documentation - matrix_science::ms_peptide::getNumIonsMatched() is now clearer
151 | Provide functions to calculate peptide and fragment masses. See Mascot utilities and tools module
162 | Example perl script for protein summary and peptide summary have incorrect tag calls.
164 | C++ test harness: peptide_list.cpp only builds on Windows.
173 | Performing a search in the Windows msparser help no longer gives the same 'Title' for all pages.
175 | Documentation - Ions series are now correct in matrix_science::ms_searchparams::getRULES()
183 | Peptides with and without ambigious residues are now split into two entries. When decides whether to check if one protein is a sub-set of another it now compares the substituted peptide strings instead of original.
186 | Mascot User authentication and login. See Mascot security and authentication module
187 | Re-organise the help into separate modules, and provide example code in the examples directory as well as the online help.
199 | Huge results files loaded and parsed using less memory.
200 | AutoSelectCharge is a new parameter in the options section of mascot.dat See: matrix_science::ms_mascotoptions::getAutoSelectCharge()
206 | Before loading whole results file, check it really is a Mascot result file.
218 | Support for negative charge state.
221 | In the help, remove the class and class hierachy menu in the tree. These are now grouped together under the separate modules.

Version 1.2.2, 19th January 2004

The following items were fixed in this release which was shipped with Mascot 2.0:

ID | Title
134 | Support non-threaded build of Perl on Linux. Perl supplied with RedHat Linux is normally built with threads support. The default build of Perl (and therefore the one supplied with most other Linux distributions) has thread support disabled. See Installation on Linux platforms for details of which version of msparser.so is required for your system
135 | If a query contains a tag or an etag, then the homology threshold is now suppressed.
137 | New protein scoring for MudPIT type searches. See matrix_science::ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE
139 | Version string format in msparser.pm changed from, for example: $VERSION = "1.2.1" to $VERSION = 1.002001; for more reliable version checking with different versions of perl.
140 | Add matrix_science::ms_mascotresults::getProteinExpectationValue() and matrix_science::ms_mascotresults::getPeptideExpectationValue()

Version 1.2.1, 15th December 2003

The following items were fixed in this release:

ID | Title
121 | Support for tag and etag additions in Mascot 2.0 result files has been added. See for example, matrix_science::ms_peptidesummary::getTagString() , matrix_science::ms_peptidesummary::getTagDeltaRangeStart() and matrix_science::ms_peptidesummary::getTagDeltaRangeEnd()
125 | The C++ documentation referred to msparser.h where it should have been 'msparser.hpp'
127 | DLLMain is no longer defined in the Windows static C++ libraries.
128 | Added matrix_science::ms_mascotresfile::getUniqueTaskID() to support taskid's used by Mascot Daemon in Mascot 2.0
129 | Fixed a crash for a faulty results file with the incorrect number of queries.
130 | Sort order for proteins with identical scores used to be incorrect with .NET 2003 compiler, and Linux Intel compiler. Code generated by all other compilers was working properly.
132 | getAvePeptideIdentityThreshold used to be incorrect for a search that has queries with no matches. Also, added matrix_science::ms_mascotresults::getMaxPeptideIdentityThreshold() as a safer option to display above the histogram on the Mascot 2.0 reports.

Version 1.2.0, 20th October 2003

Support for Java has now been added. See Java toolkit installation for details.

Windows Visual C++ .NET 2003 is now supported along with Visual C++ 6.0. Separate directories are provided for each compiler. The DLLs no longer require Perl to be installed on the computer.

Important Windows Perl users please note that the msparser.dll file is now located in a perl56 or perl58 directory. Do not use the one in the lib directory as this no longer provides any perl support.

The following items were fixed in this release:

ID | Title
5 | Proteins with identical scores are now sorted by accesion number. If the accessions contain numbers (e.g. gi numbers), then the sorting is by the actual number. Otherwise, it sorts lexicographically. See also issue #48 below.
15 | A warning message is now provided for duplicate accessions. Duplicate accessions are normally an indication of a faulty database, or incorrect parse rules, and should be investigated by the Mascot Administrator.
16 | A new function matrix_science::ms_mascotresults::isNA can be called to determine if the search was against a protein database or a nucleic acid database.
36 | Peptide mass fingerprint mixture mode is now supported. See Peptide mass fingerprint mixtures
40 and 102 | Version information can now be found using the standard perl and java interfaces. Further information can be found at: matrix_science::ms_mascotresfile::getMSParserVersion()
42 | Added a function to find number of proteins in the results. see matrix_science::ms_mascotresults::getNumberOfHits()
43 | Added two new functions: matrix_science::ms_mascotresfile::enumerateSectionKeys matrix_science::ms_searchparams::getAllUSERParams to get 'user' parameters.
48 | For a full protein summary report, the sort order now has a one to one correspondence with the entries in the results file. See also issue #5 above, which affects concise summary and peptide summaries.
49 | Added a new function matrix_science::ms_mascotresults::getProteinScoreForHistogram to return the top 50 scores.
50 | Issue with symbol log10: referenced symbol not found on some Solaris systems has been resolved.
54 | A number of minor problems with the unassigned list have been resolved
56 | Added two new functions: matrix_science::ms_inputquery::getPepTol() matrix_science::ms_inputquery::getPepTolUnits()
57 | Changed matrix_science::ms_peptidesummary::getProteinsWithThisPepMatch to have an extra default parameter that returns quotes around the accession strings. This is required to allow accessions with spaces.
58 | Add matrix_science::ms_protein::getUnmatchedMasses to get the list of observed mass values that failed to get a match to a protein hit in a PMF (listed at end of each hit in a protein summary report).
59 | For a peptide summary, the probability cutoff calculation was not the same as in the Mascot 1.9 results reports, which use the average peptide probability. This is always a very minor difference.
60 | Calculation for protein score in peptide summary is now exactly the same as in the Mascot 1.9 results reports. This resulted in very rare minor differences.
61 | Error handler changes. IsValid() no longer returns false if there are only warning messages. Messages are now classified by severity. The test harness shows new code to print out warnings if the file is valid. Messages no longer have the file name at the beginning.
62 | Added new function: matrix_science::ms_searchparams::getElectronMass().
71 | Changes to the output of matrix_science::ms_mascotresults::getReadableVarMods for error tolerant search results.
72 | Calling getProteinMass used to fail for hit number 50.
74 | Option to 'leak bytes' to keep browser connection alive when a report is taking a long time to produce. See: matrix_science::ms_mascotresfile::ms_mascotresfile and matrix_science::ms_mascotresfile::outputKeepAlive()
76 | Added a method for getting a protein or peptide summary for single hit very quickly. A parameter 'singleHit' has been added to both matrix_science::ms_peptidesummary::ms_peptidesummary and matrix_science::ms_proteinsummary::ms_proteinsummary.
77 | Any SQ always used to return false - even for a sequence query.
78 | Added matrix_science::ms_protein::getRMSDeltas to return RMS error for a protein.
79 | Proteins in a protein summary are now collapsed by query number rather than peptide string. See Grouping proteins together for further information. This should give compatible results with Mascot 1.9 reports.
81 | Key names in the results files are now always matched case insensitively.
82 | Sample code for repeating a search is now provided in Perl, Java and C++ in the relevant 'test_' directory. See also Automated repeating of searches
83 | Trying to read a result files from Mascot versions earlier than 1.02.00 will now produce an error. These files are not supported.
84 and 85 | matrix_science::ms_mascotresfile::getRepeatSearchString used to fail to return the peptol() parameter in cases where an override peptide tolerance had been specified. It also returned seq() instead of comp() for a composition query.
86 | Minor differences in the output for an error tolerant search have been fixed.
91 | Changed matrix_science::ms_peptidesummary::getProteinsWithThisPepMatch() is now considerably faster
92 | Added matrix_science::ms_inputquery::getPepTolString()
93 | The parameter minPepLenInPepSummary now behaves in the same way as the Mascot 1.9 reports. In the previous version, peptides shorter than this were totally ignored. Now, they are just ignored for Grouping proteins together purposes.
103 | OneInXprobRnd is now a a double rather than an int - it was previously possible to overflow this value.
104 | Added a new function: matrix_science::ms_mascotresults::getSequenceMass to calculate the relative mass of a sequence.
110 | The function: matrix_science::ms_peptide::getPrettyRank has changed. The ordering of the numbers is now slightly different and is consistent with the original Mascot reports.
113 and 116 | A bug in: matrix_science::ms_protein::getCoverage that caused to large a value to be reported (particularly with error tolerant searches) has been fixed. The getCoverage function is not supported for Mixture mode and Unigene - and will return 0 for these results.

Known bugs in Version 1.2.0
39 - Installer required for installing the perl package

Version 1.01, 5th March 2003

The following items were fixed in this release

ID | Title
1 | Unigene indexes are now fully supported. Simply pass the name of the Unigene index file when creating a results object.
28 | matrix_science::ms_mascotresfile::anyMSMS() always used to return false if there was just one query. It now functions properly.
29 | matrix_science::ms_mascotresfile::getRepeatSearchString used to have a line feed at the end of the string, making it inconvenient to use.
30 | matrix_science::ms_peptide::getMrExperimental() can return 0. This is "by design", since it is calculated from getMrCalc() + getDelta(). It is generally recommended that matrix_science::ms_mascotresfile::getObservedMrValue() is used, since this will always return the relative mass, even for no match. Documentation has been updated.
31 | matrix_science::ms_mascotresults::MSRES_REQUIRE_BOLD_RED now functions properly. In version 1.0, supplying the flag had no effect.
32 | The C++ test harness now (optionally) loads parameters from a configuration file. This functionality is solely designed to help in-house testing of the library.
35 | Error messages: ERR_UNASSIGNED_??? were all reported incorrectly. (Message numbers were all out by one).
37 | The documentation is no longer supplied as a pdf file. This help is only available in html format now. The image for the UML diagram was poor quality in the PDF document - a separate PDF file is now supplied.
38 | "Corrupt" title strings could sometimes be returned by matrix_science::ms_inputquery::getStringTitle(true). Spaces were treated correctly, but other characters such as a parenthesis were not handled correctly. The unescaped string was always returned correctly.
-- | Solaris and Linux versions now available.

Known bugs in Version 1.01
39 - Installer required for installing the perl package

Version 1.0, 28th November 2002

The following items were fixed in this release

ID Title
22

Duplicate accession strings in database or repeated peptides in a protein cause confusion. Added matrix_science::ms_protein::getNumDisplayPeptides()

23

Add function to get the string for a repeat search. See: matrix_science::ms_mascotresfile::getRepeatSearchString()

24

Documentation addition. Added requirement for

      #define _MATRIX_USE_STATIC_LIB

when compiling under Windows using static library. See Compiler Options

25

Add "summary" example C++ test file. This outputs a list of of the top matching proteins. C++ example only.

26

Failure to get protein mass from proteins section. If a protein was in the proteins section, but not in the summary section, then the protein mass was not returned when calling matrix_science::ms_mascotresults::getProteinMass()

27

Added matrix_science::ms_mascotresfile::getMSParserVersion() to return the Mascot Parser version.

Known bugs in Version 1.0
Bug 1 - Unigene support. Interfaces available, but not yet implemented.

Beta 7, 10th November 2002

The following items were fixed in this release

ID | Title
14 | Supply all (or nearly all!) combinations of C++ static and DLL libraries for Microsoft Windows.
21 | Update the C++ example code documentation.
18 | Infinite loop in perl test harness.

Beta 6, 24th September 2002

The following items were fixed in this release

ID | Title
4

Backward compatibility - need to know if there is a peptides block. Two new functions should enable this:

  • matrix_science::ms_mascotresfile::doesSectionExist()
  • matrix_science::ms_mascotresfile::anyPeptideSummaryMatches()

6

Need MinPepLenInPepSummary. There is a new parameter to matrix_science::ms_peptidesummary::ms_peptidesummary.

7

How to do AUTO. Improved documentation. See the examples.

9

Null accessions now create an error. See matrix_science::ms_mascotresfile::ERR_NULL_ACC_PEP_SUM and matrix_science::ms_mascotresfile::ERR_NULL_ACC_PROT_SUM.

10

Error reporting - instead of just keeping one error, have a list of errors. See Error Handling for details.

11

There is now a way of getting the list of unassigned peptides. See Unassigned peptides list for details.

12

Need an IsBold function.
See matrix_science::ms_protein::getPeptideIsBold()

13 | Need a IsDisplayCheckBox function See matrix_science::ms_protein::getPeptideIsBold()

Beta 5, 13th September 2002

First release with these help pages.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Updating from earlier versions of Mascot Parser

Upgrading to Mascot Parser 2.8.x from 2.7.x

Windows compiler support

Support for 32-bit Windows has been dropped.

Linux compiler support

Static libraries for Intel Parallel Studio XE 2016 and later are no longer shipped with Parser. Please use the GCC 4.8.5 compiled libraries, which are binary compatible with the Intel compiler.

Error tolerant search changes

Mascot Server 2.8 added target-decoy support for error tolerant searches. The results file has new sections et_decoy_summary and et_decoy_peptides, which are analogous to et_summary/decoy_summary and et_peptides/decoy_peptides, respectively. Parser classes automatically read the new sections if they are present.

If the error tolerant search is from Server 2.8 or later, error tolerant matches now have expect values denoting statistical significance. See Error tolerant searches for more information.

If the error tolerant search is from Server 2.7 or earlier, expect values are not available. Previous Parser versions reported a non-zero, numerically incorrect value. It's best to check the return value of ms_mascotresults::getPeptideExpectationValue(): if it's -1, expect value is not available.

MinProbability and IgnoreIonsScoreBelow

If the search is error tolerant and from Server 2.8 or later, Parser applies separate significance thresholds (minProbability) to first pass and second pass (ET) matches. These are available through ms_mascotresults::getProbabilityThreshold() and ms_mascotresults::getErrTolProbabilityThreshold(). The active thresholds may differ from the minProbability parameter passed to the constructor if the TargetFDR parameter is specified.

Because there are two thresholds, IgnoreIonsScoreBelow is restricted to only two values, making it into a binary choice.

  • IgnoreIonsScoreBelow=0: all matches are shown.
  • IgnoreIonsScoreBelow=-1: only statistically significant matches are shown.

In the latter case, Parser uses either the first or the second pass threshold to suppress non-significant matches.

If the search is not error tolerant, IgnoreIonsScoreBelow operates as an expect value or score filter like in previous versions. The value -1 ("automatic") is available in both ET and non-ET searches.

MS1 quantitation

Parser now has complete support for MS1 quantitation using Mascot Distiller project files. See Quantitation analysis for Mascot Server and Distiller.

Upgrading to Mascot Parser 2.7.x from 2.6.x

Windows Compiler support

Support for Visual Studio 2005, 2008 and 2010 has been dropped.

Linux compiler support

Support for GCC 4.1 and Intel Parallel Studio XE 2013 has been dropped. Static libraries are now compiled with GCC 4.8.5 and Intel Parallel Studio XE 2016. The shared libraries remain compatible with GCC versions older than 4.8.

Support for 32-bit Linux has been dropped.

Reading crosslinked search results

Mascot 2.7 introduced support for intact crosslinking and cleavable crosslinking. The results file contains a new section for intact crosslinked matches.

The default mode in Parser 2.7 and later is to mimic 2.6. That is, if you use the default flags, for example from get_ms_mascotresults_params(), then the file is opened in "linear-only" mode. If you want to see the intact crosslinked peptide matches, specify MSPEPSUM_CROSSLINK_INTEGRATED as the special mode flag to the ms_peptidesummary constructor.

Opening the files in Parser 2.6 and earlier is possible. Older versions will simply ignore intact crosslinked matches. If there are any matches with monolinks, however, client code will report the intact linker mass as the modification delta.

See Crosslinked search results for more information.

Upgrading to Mascot Parser 2.6.1 from 2.6.0

The matrix_science::ms_spectral_lib_file::FILE_FORMAT enum has been replaced by the matrix_science::ms_spectral_lib::FILE_FORMAT enum.

Upgrading to Mascot Parser 2.6.x from 2.5.x

Reading spectral library search results

Mascot 2.6 introduced integrated spectral library searches, where the peak lists are searched simultaneously against FASTA database(s) and NIST-format spectral libraries. The results file contains additional sections for spectral library metadata and matches to library entries. There are no changes to the non-library sections of the file.

Opening the files in Parser 2.5 and earlier requires no changes to your code; the file works as if it contained no spectral library data.

The default mode in Parser 2.6 and later is to mimic 2.5. That is, if you use the default flags, for example from get_ms_mascotresults_params(), then the file is opened in "Mascot-only" mode. If you want to see the library matches, specify either MSPEPSUM_SL_INTEGRATED or MSPEPSUM_SL_ONLY as the special mode flag to the ms_peptidesummary constructor.

See Spectral libraries for more information.

Modification Statistics

In Mascot 2.6, Modification Statistics are based on modifications observed in rank 1 significant matches assigned to a protein hit, whereas they used to be based on matches which could be in the unassigned list.

This change applies to methods matrix_science::ms_mascotresults::getNumDiscoveredFixedMods(), matrix_science::ms_mascotresults::getNumDiscoveredVariableMods(), matrix_science::ms_mascotresults::getNumDiscoveredLocalMods(), matrix_science::ms_mascotresults::getDiscoveredLocalModNames(), matrix_science::ms_mascotresults::getNumDiscoveredErrTolMods(), matrix_science::ms_mascotresults::getDiscoveredErrTolModNames(), matrix_science::ms_mascotresults::getDiscoveredErrTolModDeltas(), matrix_science::ms_mascotresults::getNumDiscoveredLibraryMods(), matrix_science::ms_mascotresults::getNumDiscoveredNonSpecCleavage() .

Upgrading to Mascot Parser 2.5.x from 2.4.x

Specifying xml schema file locations

In Mascot Parser, functions and classes that access Unimod or Quantitation XML configuration files require the schema files in order to validate the XML content. The required schema files are supplied with Mascot Parser in the config directory. The Mascot result files, (accessed using the ms_mascotresfile class), also contain a copy of the relevant part(s) of the XML configuration files that were used during the search. In Mascot 2.4 and earlier, some ms_mascotresfile member functions, or functions that pass a ms_mascotresfile object also require the relevant schema file. To avoid having to specify the schema file in multiple places, a directory can now be passed to the constructor to specify the location of the schema files. Additionally, a new function: setXMLschemaFilePath() may be called for finer grained access.

To ensure backward compatibility, it was necessary to add an additional parameter (with a default value) to ms_mascotresfile::getUnimod. If you are using this function, then this version of Mascot Parser is backward compatible with your existing code. However to simplify your code, if you have passed the relevant directory to the ms_mascotresfile constructor, then you may wish to remove the call to ms_umod_configfile::setSchemaFileName and then pass 'true' as useSchemaFromResfile when calling ms_mascotresfile::getUnimod.

It is strongly recommended that applications using Mascot Parser now:

  • Ship all the *.xsd files in the Mascot Parser config directory.
  • Specify the directory that contains these files in the ms_mascotresfile constructor.
  • Replace any calls to ms_mascotresfile::getQuantitation with ms_mascotresfile::getQuantitationMethod
  • Pass 'NULL' or 0 for the quantSchemaFilePath and unimodSchemaFilePath parameters to the ms_aahelper constructor

ms_mascotresfile now inherits from ms_errors

For consistency and simplicity, ms_mascotresfile now inherits from ms_errors.

The enumerated definitions for errors declared in error numbers are now deprecated. The error numbers defined at ms_errs::err should be used instead for new applications. The numbers for the two lists are the same and have not been changed in any version of Parser, thus ensuring backward compatibility.

The following functions

  • ms_mascotresfile::getNumberOfErrors
  • ms_mascotresfile::getErrorNumber
  • ms_mascotresfile::getErrorString
  • ms_mascotresfile::appendErrors

just call the relevant ms_errs functions.

ms_connection_settings additions

In Mascot Parser 2.1 and later, it is possible to download and parse configuration files from a remote Mascot Server using http. When accessing these files remotely, for example, using ms_enzymefile it is necessary to supply an ms_connection_settings object. In versions prior to 2.5, when the Mascot Server has authentication enabled, an http username and password needed to be supplied in the url for the ms_enzymefileobject. In Parser 2.5 and later, it is more convenient to supply these values using: ms_connection_settings::setHttpUsername and ms_connection_settings::setHttpPassword

User group based modification privacy. ms_umod_configfile and ms_modfile behaviour changes

Mascot Server 2.5 now allows locally defined modifications to have restricted access based on user groups. If security is enabled then Mascot Parser 2.5 will check these restrictions and remove modifications from the ms_modfile and ms_modfile object instances. During construction, passing a valid ms_connection_settings object with a session_id into these instances will apply the restrictions for that user. If no ms_connection_settings object is used then the default session will be employed. This behaviour will work for both fat and thin client applications.

Windows Compiler support

Support for Visual Studio 6 and VS2003 has been dropped.

Support for VS2010 and VS2012 has been added.

Windows SDK 2003 SP1 required for Visual Studio 2005

Upgrading to Mascot Parser 2.4.x from 2.3.x

Multiple modifications for the same site

For all versions of Mascot, it has been possible to search using multiple variable modifications for the same residue. In this case, Mascot searches for one modification or the other on each particular site. It never searches for both modifications being applied to the same site.

In Mascot Server 2.4 and later, it is possible to search for two modifications being applied to the same site. This is most useful with chemical labels used for quantitation, so it is currently only implemented when using a Quantitation method with exclusive modifications. For example, with a SILAC method, where the label is Label:13C(6)15N(2), it is also possible to specify Acetyl (K) as a variable modification. When Mascot is searching for the 'heavy' SILAC component it will look for:

  • a labelled K (delta 8 Da) or
  • a labelled K plus the Acetyl - a total delta of 8 + 42 = 50

The function matrix_science::ms_peptide::getVarModsStr() returns a single string from the q1_p1= line in the results file as before. A new function matrix_science::ms_peptide::getSummedModsStr() returns a new string of the same format.

For example, consider the case where the SILAC label is specified as an exclusive modification, and Methyl (KR) and Acetyl (K) are both specified as variable modifications.

In the case where K1 has the SILAC label + Methylation and K6 has the SILAC label + Acetyl, the results file would contain:

delta1=42.010565,Acetyl (K)
NeutralLoss1=0.000000
. . .
delta3=14.015650,Methyl (KR)
NeutralLoss3=0.000000
. . .
delta6=8.014199,Label:13C(6)15N(2) (K)
NeutralLoss6=0.000000

q3_p1=2,1057.657852,0.000561,8,KQLATKAAR,17,06000060000, . .
q3_p1_summed_mods=03000010000

matrix_science::ms_peptide::getVarModsStr() would return "06000060000" and matrix_science::ms_peptide::getSummedModsStr() would return "03000010000"

This new functionality is only available when MULTI_SITE_MODS is defined in the search input and this is not enabled by default. See matrix_science::ms_searchparams::getMULTI_SITE_MODS

When using matrix_science::ms_aahelper, use the new overloaded version of createPeptide with the summedMods and summedModsNL parameters. The varModVector passed to matrix_science::ms_aahelper::setAvailableModifications should obviously include the summed mods and the variable mods.

Upgrading to Mascot Parser 2.3.x from 2.2.x

Percolator

In Mascot 2.3 and later, ms-ms searches can also be run through Percolator, and the Percolator scores can then be shown in the Mascot reports. See Using Percolator scores for details.

Support for searching multiple fasta files

There is now support for searching multiple fasta files. A search against a single fasta file will create a results file similar to that in Mascot 2.2. However, when searching multiple fasta files, remember that the same accession may exist in different fasta databases. The following are additional/changed functions that may be useful:

  • matrix_science::ms_searchparams::getNumberOfDatabases - [new function]
  • matrix_science::ms_searchparams::getDB - [function updated]
  • matrix_science::ms_mascotresfile::getFastaPath - [function updated]
  • matrix_science::ms_mascotresfile::getFastaVer - [function updated]
  • matrix_science::ms_mascotresfile::getNumResidues - [function updated]
  • matrix_science::ms_mascotresfile::getNumSeqs - [function updated]
  • matrix_science::ms_mascotresults::getProtein - [function updated]
  • matrix_science::ms_mascotresults::getProteinMass - [function updated]
  • matrix_science::ms_mascotresults::getProteinDescription - [function updated]
  • matrix_science::ms_protein::getDB - [new function]
  • matrix_science::ms_peptidesummary::ms_peptidesummary - [function updated for single hit]

New protein inferencing

New protein grouping. See Using MSRES_CLUSTER_PROTEINS. Software needs to specify the new flag and call matrix_science::ms_mascotresults::getNextFamilyProtein as described in Using MSRES_CLUSTER_PROTEINS

Caching results

It is now possible (but not required) to cache results. This is fully described in Caching Mascot Results

Support for Quantitation 2

An updated schema, version 2.1 (quantitation_2.xsd) is supplied with Mascot Parser 2.3. Version 1.0 was supplied with Mascot Parser 2.x and version 2.0 was supplied with Mascot Distiller 2.3. To support files (for example results files) with quantation_1 and quantation_2 formats, both schema must be made made available.

The following calls worked with Mascot Parser 2.1 and 2.2, but will fail with Mascot Parser 2.3 and Quantiation 2:

  $objResFile = new msparser::ms_mascotresfile("F001234.dat");
  $objQuantFile = new msparser::ms_quant_configfile();
  if ($objResFile->getQuantitation($objQuantFile)) {
    # abort on fatal error. Note that isValid() remains true if there are only warnings
    unless ($objQuantFile->isValid) {
    . . .
  }

The schema filenames now need to be set before the getQuantitation() call as described in matrix_science::ms_mascotresfile::getQuantitation

Upgrading to Mascot Parser 2.2.x from 2.1.x

[TODO]

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Deprecated List

Member ms_fragmentationrules::getFirstSerie ()
Use getFirstSeries().

Member ms_fragmentationrules::getLastSerie ()
Use getLastSeries().

Member ms_group::GROUPID_INTEGRA_SYSTEM
The Mascot Integra system group, only member is normally USERID_INTEGRA_SYSTEM. Users will never be able to log in as this user - it is only used from the Integra server.

Member ms_http_client_search::sessionId () const
Use getSessionID()

Member ms_license::ms_license ()
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Member ms_license::ms_license (const char *filename)
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Member ms_license::read_file ()
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Member ms_license::setFileName (const char *filename)
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Member ms_mascotoptions::getMudpit () const
For Mascot 2.2 and later, use getMudpitSwitch() and getSelectSwitch().

Member ms_mascotoptions::isShowSubsets () const
See getShowSubsets().

Member ms_mascotoptions::setShowSubsets (const bool value)
See setShowSubsets(const double).

Member ms_mascotresfile::err
- use ms_errs::err instead

Member ms_mascotresfile::get_ms_mascotresults_params (const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const
This function is deprecated. All new code should use ms_mascotresfile::get_ms_mascotresults_params(const ms_mascotoptions &, ms_mascotresults_params &) instead, as all the parameters are encapsulated in the ms_mascotresults_params class.

Member ms_mascotresfile::getQuantitation (ms_quant_configfile *qfile) const
See getQuantitationMethod() which is generally easier to use.

Member ms_mascotresfile::setPercolatorFeatures (const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes)
This function is deprecated and has been replaced with matrix_science::ms_mascotresfile::setPercolatorFeatures(const ms_mascotoptions&, const char*).

Member ms_mascotresfile::staticGetPercolatorFileNames (const char *szDatFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists)
This function is deprecated and has been replaced with matrix_science::ms_mascotresfile::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, std::vector<std::string>&, std::vector<bool>&).

Member ms_mascotresults::FC_ALL_PEPTITDES
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.

Member ms_mascotresults::findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.

Member ms_mascotresults::findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.

Member ms_mascotresults::getProbOfPepBeingRandomMatch (const double score, const int query) const
Use getPeptideExpectationValue().

Member ms_mascotresults::getProbOfProteinBeingRandomMatch (const double score) const
Use getProteinExpectationValue().

Member ms_modification::copyMassFile (const ms_masses *massFile)
Do not use.

Member ms_processors::getHyperThreadedCPUsMask () const
Use isPrimaryLogicalProcessor(), getCoreFromLogical() and getPhysicalFromLogical() instead.

Member ms_processors::getWhichAvailableForMascot () const

Use isLogicalCPUAvailableForMascot() instead.

Use getWhichAvailableForMascot2

Member ms_protein::getSimilarProteinDB () const
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.

Member ms_protein::getSimilarProteinName () const
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.

Member ms_quant_integration::dropMassDelta ()
Not in use.

Member ms_quant_integration::dropMassDeltaUnit ()
Not in use.

Member ms_quant_integration::dropPrecursorRange ()
Do not use.

Member ms_quant_integration::dropProcessingOptions ()
Do not use.

Member ms_quant_integration::getMassDelta () const
Not in use.

Member ms_quant_integration::getMassDeltaSchemaType () const
Not in use.

Member ms_quant_integration::getMassDeltaUnit () const
Not in use.

Member ms_quant_integration::getMassDeltaUnitSchemaType () const
Not in use.

Member ms_quant_integration::getPrecursorRange () const
Do not use.

Member ms_quant_integration::getPrecursorRangeSchemaType () const
Do not use.

Member ms_quant_integration::getProcessingOptions () const
Do not use.

Member ms_quant_integration::getProcessingOptionsSchemaType () const
Do not use.

Member ms_quant_integration::haveMassDelta () const
Not in use.

Member ms_quant_integration::haveMassDeltaUnit () const
Not in use.

Member ms_quant_integration::havePrecursorRange () const
Do not use.

Member ms_quant_integration::haveProcessingOptions () const
Do not use.

Member ms_quant_integration::setMassDelta (const char *value)
Not in use.

Member ms_quant_integration::setMassDeltaUnit (const char *value)
Not in use.

Member ms_quant_integration::setPrecursorRange (const char *value)
Do not use.

Member ms_quant_integration::setProcessingOptions (const std::string value)
Do not use.

Member ms_quant_multiplex::dropIonSeries ()
Replaced with clearIonSeries().

Member ms_quant_multiplex::setIonSeries (const std::string ionSeries)
Replaced with appendIonSeries().

Member ms_quant_precursor::dropAllChargeStates ()

Moved to ms_quant_integration.

Moved to ms_quant_integration.

Member ms_quant_precursor::dropAllowElutionShift ()

Moved to ms_quant_integration.

Moved to ms_quant_integration.

Member ms_quant_precursor::getAllChargeStatesSchemaType () const
Moved to ms_quant_integration.

Member ms_quant_precursor::getAllowElutionShiftSchemaType () const
Moved to ms_quant_integration.

Member ms_quant_precursor::haveAllChargeStates () const
Moved to ms_quant_integration.

Member ms_quant_precursor::haveAllowElutionShift () const
Moved to ms_quant_integration.

Member ms_quant_precursor::isAllChargeStates () const
Moved to ms_quant_integration.

Member ms_quant_precursor::isAllowElutionShift () const
Moved to ms_quant_integration.

Member ms_security::getIntegraUsers () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_options::getIntegraAppServerURL () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_options::getIntegraDatabaseName () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_options::getIntegraOracleServerName () const
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_options::setIntegraAppServerURL (std::string newVal)
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_options::setIntegraDatabaseName (std::string newVal)
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_options::setIntegraOracleServerName (std::string newVal)
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_security_tasks::SECTASK_INTEGRASYSTEMACCOUNT
CLIENT: Integra system account.

Member ms_session::ms_session (const std::string userName, const std::string connectionID, const std::string database)
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Member ms_user::USER_INTEGRA
Mascot Integra is not supported in Mascot Parser 2.5 and later. Login etc. is done through Mascot Insight.

Member ms_user::USERID_INTEGRA_SYSTEM
Mascot Integra is not supported in Mascot Parser 2.5 and later.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Modules

Here is a list of all modules:
  • Installing Mascot Parser
    • Perl toolkit installation
    • C++ toolkit installation
      • C++ toolkit installation on Windows
      • C++ toolkit installation on Unix
    • Java toolkit installation
    • Python toolkit installation
    • C# toolkit installation
  • Getting started with Mascot Parser
    • Quickstart: how to open a results file
    • Using the toolkit from C++
    • Using the toolkit from Perl, Java, Python and C#
    • Garbage collection problems (advanced reading)
    • Multithreading (advanced reading)
  • Mascot results file module
    • Examples for the results file module
    • UML Class Diagram
    • Issues with backward compatibility for results files
    • Error Handling
    • Peptide mass fingerprint mixtures
    • Grouping proteins together
    • Unassigned peptides list
    • Treatment of duplicate peptides
    • Detecting ambiguous peptide matches
    • Error tolerant searches
    • Crosslinked search results
    • Using the singleHit parameter to return a single protein
    • Automated repeating of searches
    • Target-decoy searches and false discovery rate
    • Using Percolator scores
    • Caching Mascot Results
    • Combining multiple .dat files
    • Query-level modifications
    • Spectral libraries
    • Spectral library score threshold (advanced reading)
  • Mascot configuration files module
    • Configuration files
    • Examples for the configuration files module
    • Fixed values for quantitation.xml
    • Fixed values for crosslinking.xml
  • Mascot security and authentication module
    • Using the Mascot security module
    • Examples for the Mascot security module
  • Mascot utilities and tools module
    • Examples for the Mascot tools module
    • Spectral library Classes
  • Error handling and logging
    • Error Handling
    • Logging using ms_loggingmonitor
    • Examples for error handling in Mascot Parser modules
  • Quantitation analysis for Mascot Server and Distiller
    • Peptide and protein quantitation
    • Accessing Distiller Quantitation Results
    • Accessing Distiller Multi-file Quantitation Results
    • Extracting quantitation results with the Distiller toolkit
    • Source code for the Shapiro-Wilk W test algorithm
    • Examples for the Mascot Parser quantitation module
  • Classes for calculating masses of peptides and fragments.
    • Examples for the mass calculation module
  • Accessing a Mascot Server using HTTP
    • HTTP Communication to a Mascot Server
    • Examples for the Mascot http client module
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Modules

Installing Mascot Parser

Modules

Perl toolkit installation
C++ toolkit installation
Java toolkit installation
Python toolkit installation
C# toolkit installation

Detailed Description

This section provides information on installing Mascot Parser on your chosen platform. It also gives general instructions on how to write (and compile) programs that use Mascot Parser. For more detailed information about using Mascot Parser in a particular programming language, see Getting started with Mascot Parser.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Perl toolkit installation
[Installing Mascot Parser]

To use the toolkit, an appropriate version of Perl must be installed.

Installation on Windows

Supported versions (Windows)

The supported versions of Perl on Windows are 64-bit versions 5.24, 5.26, 5.28, 5.30 and 5.32 of ActiveState ActivePerl and Strawberry Perl. ActivePerl is available for download from https://www.activestate.com/. Strawberry Perl can be downloaded from https://strawberryperl.com/.

Determine which version of Perl you are using (Windows)
To find out which version of perl you have, type the following at a command prompt:
    perl -v
This will report the Perl version and copyright. The first line gives the version number. For example:
This is perl 5, version 26, subversion 2 (v5.26.2) built for MSWin32-x64-multi-thread

If it reports built for MSWin32-x64... then the 64 bit version of Mascot Parser is required. If it reports built for MSWin32-x86... then the 32 bit version of Mascot Parser is required. In this case, please use Parser 2.7 or earlier.

Find the correct version of the Mascot Parser Files (Windows)
The correct Mascot Parser files will be in the following directories:
Perl version | Directory
ActivePerl/Strawberry Perl 5.24.x | perl524
ActivePerl/Strawberry Perl 5.26.x | perl526
ActivePerl/Strawberry Perl 5.28.x | perl528
ActivePerl/Strawberry Perl 5.30.x | perl530
ActivePerl/Strawberry Perl 5.32.x | perl532
Copy the two files to a suitable location (Windows)
To use Mascot Parser in your program, the files msparser.pm must either be in the same directory as your program, or in a directory searched by the Perl interpreter.
In either case, msparser.dll must be copied into a subdirectory auto\msparser that is relative to msparser.pm. For example:
C:\msparser\perl526>dir

Directory of C:\msparser\perl526

19/07/2019  08:56    <DIR>          .
19/07/2019  08:56    <DIR>          ..
19/07/2019  08:56    <DIR>          auto
18/07/2019  15:59           582,464 msparser.pm
               1 File(s)        582,464 bytes
               3 Dir(s)  862,835,568,640 bytes free

C:\msparser\perl526>dir auto\msparser

Directory of C:\msparser\perl526\auto\msparser

19/07/2019  15:05    <DIR>          .
19/07/2019  15:05    <DIR>          ..
18/07/2019  16:34        25,823,927 msparser.dll
               1 File(s)     25,823,927 bytes
               2 Dir(s)  862,835,568,640 bytes free
Define the module path (Windows)
If the msparser.pm file is not in the current directory, there are four alternative ways to define the module search path:

  1. Define or modify PERL5LIB:
    You can define the PERL5LIB environment variable to point to the directory where Mascot Parser Perl files are located.

  2. Add use lib into your program:
    You can use the lib module to add the directory where Mascot Parser Perl files are located to the module search path:

    use lib 'c:\path\to\msparser\perl_files';

  3. Use the -I command-line flag:
    You can use the -I command-line flag when running Perl to add a directory to the module search path.

  4. Global installation:
    You can copy the Mascot Parser Perl files to C:\Perl\site\lib directory as follows:
    • Copy msparser.pm into C:\Perl64\site\lib
    • Make a directory C:\Perl64\site\lib\auto\msparser
    • Copy msparser.dll into C:\Perl64\site\lib\auto\msparser
    (The directories above assume that ActivePerl is installed in C:\Perl64).
Install Microsoft Runtime Libraries (Windows)
You may also need to install the Microsoft Visual C++ 2015 Update 1 (or later) Redistributable Package
To check if you need this:
  1. Download and run depends.exe from https://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparser.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download the Visual C++ 2015 Update 1 (or later) redistributable package from the Microsoft Download Center: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
  4. Choose vc_redist.x86.exe for 32-bit and vc_redist.x64.exe for 64-bit
Test the installation (Windows)
Type the following at a command prompt:
    perl -e "use msparser;"
This should give no output and just return to the command prompt.

Installation on Linux platforms

Supported versions (Linux)

Different releases and builds of Perl are supported on 64-bit Linux. Support for 32-bit Linux has been discontinued. This version of Mascot Parser provides the following builds of the Perl module:

.so filename | Linux - 64bit
msparser516-thread-multi_64.so | X
msparser518-thread-multi_64.so | X
msparser520-thread-multi_64.so | X
msparser522-thread-multi_64.so | X
msparser524-thread-multi_64.so | X
msparser526-thread-multi_64.so | X
msparser528-thread-multi_64.so | X
msparser530-thread-multi_64.so | X
msparser532-thread-multi_64.so | X
msparser534-thread-multi_64.so | X

You need to determine which .so file matches your version of Perl, and then make a soft link or rename it to msparser.so.

Determine which version of Perl you are using (Linux)
To find out which version of perl you have, type the following at a shell prompt:
perl -v
This will report the Perl version and copyright. The first line gives the version number. For example:
This is perl 5, version 26, subversion 1 (v5.26.1) built for x86_64-linux-thread-multi
Find the correct version of the Mascot Parser Files (Linux)
The correct Mascot Parser files will be in the following directories:
Perl version | Directory
5.16.x | perl516
5.18.x | perl518
5.20.x | perl520
5.22.x | perl522
5.24.x | perl524
5.26.x | perl526
5.28.x | perl528
5.30.x | perl530
5.32.x | perl532
5.34.x | perl534
Determine Perl build options (Linux)

In earlier versions of Parser, the naming convention of the shared library was:

msparser[ver][-thread][-multi][-64int][_64].so

This version of Parser only ships with:

msparser[ver]-thread-multi_64.so

For reference, the build options [-thread], [-multi] and [-64int] refer to the following:

[-thread]

Type perl -V (note the uppercase V) and look for the line starting usethreads or useithreads. For example:

   usethreads=define useithreads=define ...

If usethreads is define, then you will need an .so file with -thread in the name. (This option is no longer supported in Mascot Parser)

[-multi]

Type perl -V (as above) and look for the line containing usemultiplicity. If it is define, then you will need an .so file with -multi in the name. (This option is no longer supported in Mascot Parser)

[-64int]

Type perl -V (as above) and look for the line containing use64bitint. If it is define, then you will need an .so file with -64int in the name. (This option is no longer supported in Mascot Parser)

[_64]

Type perl -V (as above) and look for the line containing ptrsize. For example:

  intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678

If ptrsize is 8, then you will need an .so file with _64 in the name.

If any of the required build options are missing, we recommend compiling Perl from source or installing a supported version of ActiveState ActivePerl from https://activestate.com.

Copy the two files to a suitable location (Linux)
To use Mascot Parser in your program, the file msparser.pm must either be in the same directory as your program, or in a directory searched by the Perl interpreter.
  • In both cases, msparser.so must be in the directory auto/msparser relative to msparser.pm.
  • In that directory, make a soft link msparser.so to the msparser[ver]-thread-multi_64.so file
Define the module path (Linux)
If the msparser.pm file is not in the current directory, there are four alternative ways to define the module search path:

  1. Define or modify PERL5LIB:
    You can define the PERL5LIB environment variable to point to the directory where Mascot Parser Perl files are located.

  2. Add use lib into your program: You can use the lib module to add the directory where Mascot Parser Perl files are located to the module search path:

    use lib '/path/to/msparser/perl_files';

  3. Use the -I command-line flag: You can use the -I command-line flag when running Perl to add a directory to the module search path.

  4. Global installation: You can copy the Mascot Parser Perl files to the site_perl directory as follows. Note that the exact path will depend on your distribution and how Perl has been configured; the following example is from CentOS 7 64-bit:
    • Copy msparser.pm into /usr/local/lib64/perl5/site_perl/5.16.3/x86_64-linux-thread-multi/
    • Make a directory /usr/local/lib64/perl5/site_perl/5.16.3/x86_64-linux-thread-multi/auto/msparser
    • Copy msparser516-thread-multi.so into /usr/local/lib/perl5/site_perl/5.16.3/x86_64-linux-thread-multi/auto/msparser
    • Make a soft link msparser.so in /usr/local/lib/perl5/site_perl/5.16.1/x86_64-linux-thread-multi/auto/msparser

Using the Perl toolkit

Reasonable proficiency in Perl programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Modules

C++ toolkit installation
[Installing Mascot Parser]

Modules

C++ toolkit installation on Windows
C++ toolkit installation on Unix

Detailed Description

To use the toolkit, reasonable proficiency in C++ programming is required. Internally, the library makes extensive use of different STL containers, but this is 'hidden' from the user of the toolkit. A working C++ compiler is required on any platform.

The following compilers are supported. Directory refers to a subdirectory in the unpacked Mascot Parser directory tree. Note that not all compiler directories are present in every Mascot Parser package.

Platform | Directory | Compiler
Microsoft Windows | vs2012 | Microsoft Visual Studio 2012 (Update 3)
 | vs2013 | Microsoft Visual Studio 2013 (Update 3)
 | vs2015 | Microsoft Visual Studio 2015 (Update 1)
 | vs2017 | Microsoft Visual Studio 2017 (15.7)
 | mingw | Minimal GNU for Windows (MinGW) 5.0.0 using GNU g++ 4.9.2
Linux (x86, x86_64) | gcc | GNU g++ 4.8.5 or later

Other compilers have not been tested with Mascot Parser, and are unlikely to work.

See C++ toolkit installation on Windows for details on installing the development kit under Microsoft Windows, and C++ toolkit installation on Unix for installing under supported Unix platforms.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


C++ toolkit installation on Windows
[C++ toolkit installation]

Directory structure

Directory | Files | Description
compiler/include | msparser.hpp and a number of other include files. | You only need to #include "msparser.hpp" -- this includes the other files. Make sure that this directory is on your include path.
compiler/lib | msparser.lib msparserD.lib msparserDS.lib msparserS.lib msparser.dll msparserD.dll | Mascot Parser library file; see Choosing the correct DLL file and Using the MinGW compiler.
compiler/example_cxx | *.cpp build_all.cmd | Source code for C++ examples. These can all be built from the command line using the build_all.cmd command. Make sure that the C++ compiler is on the system path when running build_all.cmd.

Using Visual C++

Choosing the correct DLL file

For Microsoft Visual C++, there are three choices:

Debug or release builds.

It is normally necessary to use the debug build of Mascot Parser with a debug build of your application, and the release build for release builds of your application.

If the wrong build of msparser.dll is used, then, for example, Mascot Parser will be using the non-debug version of the Microsoft run time library, while application code will be using the debug version. Since pointers to memory are being passed between msparser and application code, they need to use the same RTL. Note however, that the debug version can be very slow with very large files.

Static or dynamically linked.

A statically linked library has the advantage that you won't need to ship any extra modules with your application. The disadvantage is increased executable size.

With a dynamically linked library, the advantage is that if there is a bug fix or an enhancement in Mascot Parser, then you would only need to ship a patched version of the msparser.dll file. The disadvantage is, of course, having to ship the file with the application.

Unicode or MBCS.
Use whichever version your application uses. However, note that Mascot only saves single byte characters in the results files, so separate unicode builds of the library are not required and will not be supplied in version 2.2 and later.

The filenames for the .lib and .dll files and the directories for the test harness are shown below:

Debug | Static | .lib name | .dll name | Directory
 |  | msparser.lib | msparser.dll | Win32_Release
 | X | msparserS.lib | n/a | Win32_ReleaseS
X |  | msparserD.lib | msparserD.dll | Win32_Debug
X | X | msparserDS.lib | n/a | Win32_DebugS

Compiler Options

When compiling against the static libraries, you need to add the following definition in your source code, or add it to the project file:

#define _MATRIX_USE_STATIC_LIB

If in doubt, check the options in the appropriate test harness.

Note the following:

  • When using the DLL versions, you must compile your application using the multithreaded DLL runtime library. You cannot use the statically linked runtime.

  • When using the statically linked library versions, you must compile your application using multithreaded or multithreaded debug runtime library. You cannot use the DLL runtime libraries.

  • When using the MFC library with Visual C++ compiler, you must specify the /FORCE:MULTIPLE linker option to avoid an error message about a duplicate operator new() symbol in debug configurations.

Where to install msparser.dll

Mascot Parser is being used by some mass spectrometer vendors. This means that there is the possibility that another version of the DLL may be installed on the computer. To avoid any possible conflict, it is strongly recommended that you do not install this DLL in the system32 directory, but just put it in your application directory.

Compiling examples from the command line

It is possible to compile the Windows C++ examples from the command line rather than creating a project. For example, to build using the static library:

  C:\>cl -D _MATRIX_USE_STATIC_LIB /MT /EHsc -I ..\include resfile_error.cpp
    /link ../lib/msparserS.lib ws2_32.lib advapi32.lib wininet.lib /OPT:NOREF

There is a cmd file, build_all.cmd, in the C++ examples directory that builds all the examples.

Using the MinGW compiler

The mingw/lib directory contains three files:

File | Description
libmsparser.a | Static library without debugging information.
msparser.dll | DLL for use with applications compiled using MinGW
libmsparser_import.a | Import library for use when compiling an application to be dynamically linked with msparser.dll

To compile and link one of the example programs statically:

  $ g++ -D _MATRIX_USE_STATIC_LIB  -I ../include -L ../lib  resfile_summary.cpp -lmsparser -lwininet

To compile and link one of the example programs dynamically:

  $ g++ -I ../include  -L ../lib  resfile_summary.cpp -lmsparser_import

In this case, you will need to make sure that msparser.dll is in the same directory as the .exe file or is located on the system path.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


C++ toolkit installation on Unix
[C++ toolkit installation]

Directory structure

Directory | Files | Description
gnu/include | msparser.hpp and a number of other include files. | You only need to #include "msparser.hpp" -- this includes the other files. Make sure that this directory is on your include path.
gnu/lib | libmsparser.a | Static library for C++ development, and can be linked against as long as one of the supported compilers is used.
 | libmsparser.so.1 | Shared library for C++ development, and can potentially be used by compilers other than mentioned here.
gnu/example_cxx | *.cpp | Source code for C++ examples.

Installation and compilation under Linux

One version of the libraries is supplied. The libraries in the gnu directory are compiled using GNU g++ 4.8.5. These are compatible with both GNU g++ 4.8.5 or later and the Intel® C++ Compiler 2016 and later.

There are four ways to link Mascot Parser in your program:

  1. Static library using GNU g++
  2. Static library using Intel® C++ Compiler
  3. Shared library using GNU g++
  4. Shared library using Intel® C++ Compiler

The static library file is gnu/lib/libmsparser.a, while the shared library file is gnu/lib/libmsparser.so.1. To use libmsparser.so.1 in its existing directory, simply add the directory to LD_LIBRARY_PATH. Under bash and sh, for example, you can do:

    export LD_LIBRARY_PATH=/path/to/msparser/gnu/lib:$LD_LIBRARY_PATH

You also need to make a soft link to the .so file:

    cd /path/to/msparser/gnu/lib
    ln -s libmsparser.so.1 libmsparser.so

Remove the soft link if you want to revert to using the static library.

Optionally, you can install the shared library in /usr/local/lib:

  1. cp libmsparser.so.1 /usr/local/lib
  2. cd /usr/local/lib
  3. ln -s libmsparser.so.1 libmsparser.so
  4. ldconfig -v

Static library using GNU g++

To compile the example code in the example_cxx directory and statically link to Mascot Parser, use the following command:

    g++ -m64 -D__LINUX64__ -D_GLIBCXX_USE_CXX11_ABI=0 -I../include -pthread -static resfile_summary.cpp -L../lib -lmsparser

This will produce a binary that has no dependencies on any shared libraries.

Static library using Intel® C++ Compiler

The library gnu/lib/libmsparser.a has been built without -Kpic. It has been compiled using the GNU stdc++ library.

It may be possible to build a binary that links to all C and C++ libraries statically using the Intel® C++ Compiler (Parallel Studio or OneAPI). The Intel® C++ compiler is binary compatible with libraries compiled with GCC 4.8.5 or later. Please consult the Intel® compiler documentation for suitable command-line arguments and switches.

Shared library using GNU g++

To compile the example code in the example_cxx directory, use the following command:

    g++ -m64 -D__LINUX64__ -D_GLIBCXX_USE_CXX11_ABI=0 -I../include -pthread resfile_summary.cpp -L../lib -lmsparser

This will produce a binary that has dependencies on libmsparser.so and on the GNU stdc++ and C libraries (use ldd a.out to list the dependencies). In some versions of GCC, you may also need to use the flag -static-libstdc++ to link statically to the GNU stdc++ library.

Shared library using Intel® C++ Compiler

To compile the example code in the example_cxx directory and dynamically link to Mascot Parser, use the following command:

    icpc -D__LINUX64__ -I../include resfile_summary.cpp -pthread  -L../lib -lmsparser

This will produce a binary that has dependencies on libmsparser.so, the Intel® compiler libraries, libstdc++ and glibc (use ldd a.out to list the dependencies). In some versions of the compiler, the dependency on the Intel® compiler libraries can again be removed by using the -i-static flag.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Java toolkit installation
[Installing Mascot Parser]

To use the toolkit, an appropriate version of Java Development Kit must be installed.

Installation on Windows

Mascot Parser Java toolkit has been tested with Oracle/Sun JDK versions 1.6.0_31 (Java SE 6) and 1.7.0_3 (Java SE 7). The Java Development Kit for Windows is available for download from http://www.oracle.com/technetwork/java/javase/downloads/.

You may also need to install the Microsoft Visual C++ 2012 Update 3 (or later) Redistributable Package
To check if you need this:

  1. Download and run depends.exe from http://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparserj.dll in the program.
  3. If depends.exe reports that the dependent MSVCR110.dll and MSVCP110.dll are missing, download the Visual C++ 2012 Update 3 (or later) redistributable package from the Microsoft Download Center: https://www.microsoft.com/en-us/download/details.aspx?id=30679
  4. Choose vcredist_x86.EXE for 32-bit and vcredist_x64.EXE for 64-bit

To use Mascot Parser, both msparserj.dll and msparser.jar must be accessible by your program.

msparserj.dll must be visible on the PATH

Either put msparserj.dll in your program directory or modify the PATH environment variable to include the directory where msparserj.dll is located.

Alternatively, the location of msparserj.dll can be specified explicitly in your program. To do this, instead of using the System.loadLibrary() method used in the examples, call the System.load() method. For example,

    static {
        try {
            System.load("C:/temp/parser/msparserj.dll");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. " + e);
            e.printStackTrace();
            System.exit(1);
        }
    }

msparser.jar must be present on your Java Classpath

You can either define the classpath when running java.exe or javac.exe by specifying the -classpath option, or modify the CLASSPATH environment variable. We recommend that you place the msparser.jar archive in a readily accessible location and define the classpath on the command line to include msparser.jar as required.

Installation on Unix platforms

Mascot Parser Java toolkit has been tested with Oracle/Sun JDK version 1.6.0_45 (Java SE 6). The Java Development Kit is available for download from http://www.oracle.com/technetwork/java/javase/downloads/. The Mascot Parser Java toolkit should also be compatible with OpenJDK, which can be installed from the package repository of most recent Linux distributions. The Mascot Parser Java toolkit requires glibc-2.5 or later and libstdc++-6.0.8 or later.

To use Mascot Parser, both libmsparserj.so and msparser.jar must be accessible by your program.

libmsparserj.so must be visible on LD_LIBRARY_PATH

You have two choices: either put libmsparserj.so in your program directory or put it in some other readily accessible location. In the first case, you need to add the working directory (.) to LD_LIBRARY_PATH; in the second, the full path to the directory where libmsparserj.so resides.

Modifying LD_LIBRARY_PATH can be done under bash and sh as follows:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/some/path"; export LD_LIBRARY_PATH

Note that this change is temporary. Consult your operating system manual how to make the change permanent.

Alternatively, the location of libmsparserj.so can be specified explicitly in your program. To do this, instead of using the System.loadLibrary() method used in the examples, call the System.load() method. For example:

    static {
        try {
            System.load("/tmp/parser/libmsparserj.so");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. " + e);
            e.printStackTrace();
            System.exit(1);
        }
    }

msparser.jar must be present on your Java Classpath

You can either define the classpath when running java or javac by specifying the -classpath option, or modify the CLASSPATH environment variable We recommend that you place the msparser.jar archive in a readily accessible location and define the classpath on the command line to include msparser.jar as required.

Building and running the Java examples in Windows

Open a command prompt, and change to the example_java directory.

To compile (for example) resfile_params.java:

    javac -classpath .;../java/msparser.jar resfile_params.java

To run the example:

    java -classpath .;../java/msparser.jar resfile_params F981123.dat

Building and running the Java examples in Unix

Open a terminal window, and change to the example_java directory.

To compile (for example) resfile_params.java:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:../java" javac -classpath .:../java/msparser.jar resfile_params.java
Note:
This command temporarily sets LD_LIBRARY_PATH to include the java directory, where libmsparserj.so resides.

To run the example:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:../java" java -classpath .:../java/msparser.jar resfile_params F981123.dat

Using the Java toolkit

Reasonable proficiency in Java programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Python toolkit installation
[Installing Mascot Parser]

To use the toolkit, a Python interpreter must be installed.

In Windows, the supported versions of Python are 2.7, 3.4, 3.6, 3.7, 3.8 and 3.9. Only 64-bit versions are supported. Both official Python (CPython) from https://python.org and ActiveState ActivePython from https://www.activestate.com/ are supported.

On Linux systems, the supported versions of Python are 2.7, 3.4, 3.6, 3.7, 3.8 and 3.9. Only 64-bit versions are supported. Python can be installed from the package repository of most Linux distributions, and it can also be downloaded and compiled from source from from https://python.org/.

Please contact us if you require Mascot Parser for a different version of Python.

Note:
Mascot Parser Python modules are not Unicode-aware. Make sure that any string objects you pass as parameters to Mascot Parser functions are non-Unicode string objects.

To use Mascot Parser in your program, the files msparser.py and _msparser.pyd (_msparser.so on Linux) must either be in the same directory as your program, or in a directory searched by the Python interpreter. In the latter case, there are three alternatives.

Define or modify PYTHONPATH:

You can define the PYTHONPATH environment variable to point to the directory where Mascot Parser Python files are located.

  • Setting PYTHONPATH

Use sys.path.append():

You can use sys.path.append() in your program to add the directory where Mascot Parser files are located to the module search path. This is equivalent to modifying PYTHONPATH, except that the path is hardcoded in your program.

Global installation:

You can copy the Mascot Parser Python files to the site-packages directory of your Python installation.

  • In Windows, assuming CPython 3.6 or ActivePython 3.6, this is C:\Python36\Lib\site-packages.
  • In Linux, this is similar to /usr/local/lib/python3.6/site-packages, assuming Python 3.6. The exact path depends on how the Python version has been configured.

Visual C++ Redistributable Package (Windows)

You may also need to install the Microsoft Visual C++ 2015 (or later) Redistributable Package
To check if you need this:

  1. Download and run depends.exe from http://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparser.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download the Visual C++ 2015 (or later) redistributable package from the Microsoft Download Center: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0
  4. Choose vc_redist.x86.exe for 32-bit and vc_redist.x64.exe for 64-bit

Running a Python example on Windows

Open a command prompt, and change to the example_python directory. To run, say, resfile_error.py:

    python.exe resfile_error.py C:\Inetpub\mascot\data\F981119.dat

If python.exe is not in PATH%, prefix the command with the absolute path to python.exe.

Running a Python example on Linux

Open a terminal window, and change to the example_python directory. To run, say, resfile_error.py:

    ./resfile_error.py /usr/local/mascot/data/F981119.dat

This only works if resfile_error.py has the executable bit set, and if the script has the correct "shebang" line. The "shebang" line is the first line of the script, and gives the location of the Python interpreter:

    #!/usr/bin/python

You can use the Python interpreter directly:

    python resfile_error.py /usr/local/mascot/data/F981119.dat

Using the Python toolkit

Reasonable proficiency in Python programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


C# toolkit installation
[Installing Mascot Parser]

To use the toolkit, an appropriate version of the Microsoft .NET Framework must be installed.

Installation on Windows

Mascot Parser C# toolkit has been built using the Microsoft .NET Framework 4.0 and tested with the .NET Framework 4.5. If not already installed, the .NET 4.5 Framework can be downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=30653.

You may also need to install the Microsoft Visual C++ 2015 Redistributable Package. To check if you need this:

  1. Download and run depends.exe from http://www.dependencywalker.com/ or Dependencies program from https://github.com/lucasg/Dependencies
  2. Open msparsercs.dll in the program.
  3. If it reports that the dependent MSVCR140.dll and MSVCP140.dll are missing, download and install the Visual C++ 2015-2019 redistributable package.

You can download the correct files from Microsoft Download Center:

Missing file | Packages for 32-bit and 64-bit Windows
MSCVR140.dll, MSCVP140.dll | Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 Choose vc_redist.x86.exe for 32-bit and vc_redist.x64.exe for 64-bit

Using Visual Studio

In order to access the Mascot Parser C# toolkit in a C# project in Visual Studio 2015 or later, you must add a reference to matrix_science.msparser.dll to your project. To do this, right click over your project and click on Add Reference... in the context menu. In the window that opens, select the Browse option and then browse to, and select, the matrix_science.msparser.dll file.

Using Mascot Parser in compiled programs

To use Mascot Parser, both matrix_science.msparser.dll and msparsercs.dll must be accessible by your program.

To avoid any possible conflict, it is strongly recommended that you do not install these DLLs in the system32 directory, but just put them in your application directory.

Using the C# toolkit

Reasonable proficiency in C# programming will be required. Please see Quickstart: how to open a results file and Examples for the results file module.

Compiling examples from the command line

It is possible to compile the Windows C# examples from the command line rather than creating a project. The C# compiler is called csc.exe, which you must ensure is on your system path before trying to build the example files. You can do this by opening a Developer command prompt, either from the Visual Studio->Visual Studio Tools folder of your Start menu, or you may had an entry on your Start menu for the installed .NET Framework.

For example, the following would compile config_mascotdat.cs to config_mascotdat.exe

c:\>csc.exe /r:matrix_science.msparser.dll config_mascotdat.cs

All of the examples in the example_csharp directory can all be built from the command line using the build_all.cmd command. Make sure that the C# compiler is on the system path when running build_all.cmd.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Modules

Getting started with Mascot Parser

Modules

Quickstart: how to open a results file
Using the toolkit from C++
Using the toolkit from Perl, Java, Python and C#
Garbage collection problems (advanced reading)
Multithreading (advanced reading)

Detailed Description

This section gives details on how to use Mascot Parser in the supported programming languages, which in this version are C++, Perl, Java and Python.

  • Quickstart: how to open a results file describes how to write a minimal Mascot Parser program.
  • Using the toolkit from C++ describes C++ memory management conventions.
  • Using the toolkit from Perl, Java, Python and C# describes syntax and idioms when using Mascot Parser from Perl, Java and Python.

Source code examples for each programming language are available in

  • Examples for error handling in Mascot Parser modules
  • Examples for the results file module
  • Examples for the configuration files module
  • Examples for the Mascot security module
  • Examples for the Mascot tools module
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Quickstart: how to open a results file
[Getting started with Mascot Parser]

Prelude: linking or importing Mascot Parser

Before Mascot Parser can be used in your program, it must be linked in or imported. Details depend on the programming language.

C++

Details how to link Mascot Parser statically or dynamically to your program depend on the operating system, compiler and linker. Please refer to C++ toolkit installation on Windows and C++ toolkit installation on Unix.

You must include msparser.hpp before using Mascot Parser classes:

    #include "msparser.hpp"

All classes live in the matrix_science namespace. You will either need to import the namespace or explicitly state the namespace before each class name:

    {
        // Import the namespace into the current scope.
        using namespace matrix_science;
        ms_mascotresfile resfile(filename);
    }

    // Or explicitly:
    matrix_science::ms_mascotresfile resfile(filename);

Perl

Before you can call Parser functions, you need to import the msparser package with use.

    use msparser;

It is also a good idea to enable strict error checking with use strict;. Additionally, if you add use warnings; or use the -w command-line flag, the Perl interpreter will warn you if you try to use constants that are not defined anywhere. This is very useful in checking for typos in names of global constants and enumerated values.

If Mascot Parser Perl libraries are not in the current directory and are not installed in a system-wide path, you must also add the directory of msparser.pm and msparser.dll or msparser.so to the module search path with use lib. For example:

    # On Windows:
    use lib 'c:\path\to\msparser\perl_files';
    use msparser;

    # On Unix:
    use lib '/path/to/msparser/perl_files';
    use msparser;

The use lib statement must precede the use msparser statement.

For more details, see Perl toolkit installation.

All Mascot Parser classes are defined in the msparser package, which you must always prefix to the actual class name. For example, to create a new ms_mascotresfile object:

    my $resfile = msparser::ms_mascotresfile->new($filename);

    # Or C++ style syntax:
    my $resfile = new msparser::ms_mascotresfile($filename);

Java

You need to use the -classpath command-line parameter with javac and java when you compile and run your program. See Building and running the Java examples in Windows and Building and running the Java examples in Unix.

Before you can use Mascot Parser classes, you need to import them from the matrix_science.msparser namespace.

    // Import everything:
    import matrix_science.msparser.*;

    // Import selectively:
    import matrix_science.msparser.ms_mascotresfile;
    import matrix_science.msparser.ms_peptidesummary;

In addition to this, the msparserj library must be loaded into your Java class. The following should be added at the top of your Java code before any class method definitions:

    public class MyClass {
        static {
            try {
                System.loadLibrary("msparserj");
            } catch (UnsatisfiedLinkError e) {
                System.err.println("Native code library failed to load. "
                                   + "Is msparserj.dll on the path?\n" + e);
                System.exit(0);
            }
        }

For more details, see Installation on Windows.

Python

Before you can use Parser classes, you need to import them from the msparser package:

    import msparser

Alternatively, you can selectively import a subset of classes:

    from msparser import msparser.ms_mascotresfile, msparser.ms_peptidesummary

If Mascot Parser Python libraries are not in the current directory and are not installed in a system-wide path, you must also add the directory of msparser.py and _msparser.dll or _msparser.so to the module search path by appending the directory to sys.path:

    # On Windows:
    import sys
    sys.path.append('C:\path\to\msparser\python_files')
    import msparser

    # On Unix:
    import sys
    sys.path.append('/path/to/msparser/python_files')
    import msparser

sys.path.append must precede the import msparser statement.

For more details, see Python toolkit installation.

All Mascot Parser classes are defined in the msparser package. For example, to create a new ms_mascotresfile object:

    resfile = msparser.ms_mascotresfile(filename)

C#

You need to use the /r:matrix_science.msparser.dll command-line option with csc.exe when you compile your program. You also need to put msparsercs.dll and matrix_science.msparser.dll in the directory containing your executable when you run your program. See Compiling examples from the command line

All Mascot Parser classes live in the matrix_science.msparser namespace. You will either need to import the namespace or explicitly state the namespace before each class name:

    {
        // Import the namespace into the current scope.
        using namespace matrix_science.msparser;
        ms_mascotresfile resfile = new ms_mascotresfile(filename);
    }

    // Or explicitly:
    matrix_science.msparser.ms_mascotresfile resfile = new matrix_science.msparser.ms_mascotresfile(filename);

For more details, see Installation on Windows.

Getting basic information from the results file

Opening a results file is very easy. Simply create an ms_mascotresfile object, passing the file name as the only parameter:

C++
    ms_mascotresfile resfile("F981123.dat");
Perl
    my $resfile = msparser::ms_mascotresfile->new("F981123.dat");
Java and C#
    ms_mascotresfile resfile = new ms_mascotresfile("F981123.dat");
Python
    resfile = msparser.ms_mascotresfile("F981123.dat")

All data in the results file is accessible using Mascot Parser classes and methods. For example, the search parameters can be found by using the params() method of the resfile object, which returns an ms_searchparams object. The following code be used to find the MODS entry:

C++
    std::string mods = resfile.params().getMODS();
Perl
    my $mods = $resfile->params->getMODS;
Java
    String mods = resfile.params().getMODS();
Python
    mods = resfile.params().getMODS()
C#
    string mods = resfile._params().getMODS();

It is also possible to read the raw data from the results file. For example, you can read the MODS entry from the "parameters" section directly:

C++
    std::string mods = resfile.getSectionValueStr(ms_mascotresfile::SEC_PARAMETERS, "MODS");
Perl
    my $mods = $resfile->getSectionValueStr($msparser::ms_mascotresfile::SEC_PARAMETERS, "MODS");
Java
    String mods = resfile.getSectionValueStr(ms_mascotresfile.SEC_PARAMETERS,"MODS");
Python
    mods = resfile.getSectionValueStr(msparser.ms_mascotresfile.SEC_PARAMETERS, "MODS")
C#
    string mods = resfile.getSectionValueStr(ms_mascotresfile.section.SEC_PARAMETERS, "MODS");

The ms_mascotresfile class has many more methods for reading 'raw' information from the results file. In general, it is easier, faster, and less error-prone to use objects instead of directly reading the character strings from the file. Using objects will also guard your application from changes in the underlying data format.

Getting protein information

ms_mascotresfile provides only a low-level view of the results file. You need to create an ms_proteinsummary or ms_peptidesummary object to access protein hits and peptide matches. Which one is needed depends on the type of the search results: a Protein Summary should be used with a peptide mass fingerprint search, while Peptide Summary is more convenient for MS-MS searches.

The easiest and recommended way to choose is to use get_ms_mascotresults_params(). This is a helper function of the resfile object that returns default flags and parameters to use in order to re-create the same report shown by Mascot Server. The function is called with a single argument: an ms_mascotoptions object. If you are running the program on the Mascot Server, this should be fetched from the ms_datfile object; otherwise you can simply pass an empty ms_mascotoptions object.

The following example demonstrates how to fetch the default parameters, and how to select which type of report to open. The scriptName parameter can generally be ignored outside Mascot Server.

C++
    // If running on Mascot Server:

    ms_datfile datfile("../config/mascot.dat");

    bool         usePeptideSummary;
    unsigned int flags, flags2, minPepLenInPepSummary;
    int          maxHitsToReport;
    double       minProbability, ignoreIonsScoreBelow;

    std::string scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(),
        &flags,
        &minProbability,
        &maxHitsToReport,
        &ignoreIonsScoreBelow,
        &minPepLenInPepSummary,
        &usePeptideSummary,
        &flags2
    );

    if (usePeptideSummary) {
        ms_peptidesummary pepsum(
            resfile, flags, minProbability, maxHitsToReport, "",
            ignoreIonsScoreBelow, minPepLenInPepSummary, "", flags2
        );

        /* Call pepsum methods... */
    } else {
        ms_proteinsummary proteinsum(
            resfile, flags, minProbability, maxHitsToReport
        );

        /* Call proteinsum methods... */
    }

    // If running outside Mascot Server:

    std::string scriptName = resfile.get_ms_mascotresults_params(
        ms_mascotoptions(),
        &flags,
        &minProbability,
        &maxHitsToReport,
        &ignoreIonsScoreBelow,
        &minPepLenInPepSummary,
        &usePeptideSummary,
        &flags2
    );

Perl
    # If running on Mascot Server:

    my $datfile = msparser::ms_datfile->new('../config/mascot.dat');
    my ($scriptName,
        $flags,
        $minProbability,
        $maxHitsToReport,
        $ignoreIonsScoreBelow,
        $minPepLenInPepSummary,
        $usePeptideSummary,
        $flags2
    ) = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions);

    if ($usePeptideSummary) {
        my $pepsum = msparser::ms_peptidesummary->new(
            $resfile, $flags, $minProbability, $maxHitsToReport, '',
            $ignoreIonsScoreBelow, $minPepLenInPepSummary, '', $flags2
        );

        # Call $pepsum methods...
    } else {
        my $proteinsum = msparser::ms_proteinsummary->new(
            $resfile, $flags, $minProbability, $maxHitsToReport
        );

        # Call $proteinsum methods...
    }

    # If running outside Mascot Server:

    my ($scriptName,
        $flags,
        $minProbability,
        $maxHitsToReport,
        $ignoreIonsScoreBelow,
        $minPepLenInPepSummary,
        $usePeptideSummary,
        $flags2
    ) = $resfile->get_ms_mascotresults_params(new msparser::ms_mascotoptions);

Java
    // If running on Mascot Server:

    ms_datfile datfile = new ms_datfile("../config/mascot.dat");

    int[]    flags = {0};
    double[] minProbability = {0};
    int[]    maxHitsToReport = {0};
    double[] ignoreIonsScoreBelow = {0};
    int[]    minPepLenInPepSummary = {0};
    bool[]   usePeptideSummary = {false};
    int[]    flags2 = {0};

    String scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(),
        flags,
        minProbability,
        maxHitsToReport,
        ignoreIonsScoreBelow,
        minPepLenInPepSummary,
        usePeptideSummary,
        flags2
    );

    if (usePeptideSummary[0]) {
        ms_peptidesummary pepsum = new ms_peptidesummary(
            resfile, gpFlags[0], gpMinProbability[0], gpMaxHitsToReport[0], "",
            gpIgnoreIonsScoreBelow[0], gpMinPepLenInPepSummary[0], "", gpFlags2[0]
        );

        /* Call pepsum methods... */
    } else {
        ms_proteinsummary proteinsum = new ms_proteinsummary(
            resfile, gpFlags[0], gpMinProbability[0], gpMaxHitsToReport[0], "", ""
        );

        /* Call proteinsum methods... */
    }

    // If running outside Mascot Server:

    String scriptName = resfile.get_ms_mascotresults_params(
        new ms_mascotoptions(),
        flags,
        minProbability,
        maxHitsToReport,
        ignoreIonsScoreBelow,
        minPepLenInPepSummary,
        usePeptideSummary,
        flags2
    );
Python
    # If running on Mascot Server:

    datfile = msparser.ms_datfile('../config/mascot.dat')
    (scriptName,
     flags,
     minProbability,
     maxHitsToReport,
     ignoreIonsScoreBelow,
     minPepLenInPepSummary,
     usePeptideSummary,
     flags2) = resfile.get_ms_mascotresults_params(datfile.getMascotOptions())

    if usePeptideSummary:
        pepsum = msparser.ms_peptidesummary(
            resfile, flags, minProbability, maxHitsToReport, '',
            ignoreIonsScoreBelow, minPepLenInPepSummary, '', flags2
            )

        # Call pepsum methods...
    else:
        proteinsum = msparser.ms_proteinsummary(
            resfile, flags, minProbability, maxHitsToReport
            )

        # Call proteinsum methods...

    # If running outside Mascot Server:

    (scriptName,
     flags,
     minProbability,
     maxHitsToReport,
     ignoreIonsScoreBelow,
     minPepLenInPepSummary,
     usePeptideSummary,
     flags2) = resfile.get_ms_mascotresults_params(msparser.ms_mascotoptions())
C#
    // if running on Mascot server
    string scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(),
        out flags,
        out minProbability,
        out maxHitsToReport,
        out ignoreIonsScoreBelow,
        out minPepLenInPepSummary,
        out usePeptideSummary,
        out flags2
    );

    if (usePeptideSummary)
    {
        ms_peptidesummary pepsum = new ms_peptidesummary(
            resfile, flags, minProbability, maxHitsToReport, "",
            ignoreIonsScoreBelow, (int) minPepLenInPepSummary, "", flags2
        );

        /* Call pepsum methods... */
    }
    else
    {
        ms_proteinsummary proteinsum = new ms_proteinsummary(
            resfile, flags, minProbability, maxHitsToReport, "", ""
        );

        /* Call proteinsum methods... */
    }

    // if running outside Mascot server
    string scriptName = resfile.get_ms_mascotresults_params(
        new ms_mascotoptions(),
        out flags,
        out minProbability,
        out maxHitsToReport,
        out ignoreIonsScoreBelow,
        out minPepLenInPepSummary,
        out usePeptideSummary,
        out flags2
    );

Once you have created the summary object, you can access protein hits by calling getHit(). Here is an example how to get the accession string of the top-scoring protein hit.

C++
    ms_protein *top_hit = pepsum.getHit(1);
    std::string acc = top_hit->getAccession();

    std::cout << acc << std::endl;

Perl
    my $top_hit = $pepsum->getHit(1);
    my $acc = $top_hit->getAccession();

    print $acc, "\n";

Java
    ms_protein top_hit = pepsum.getHit(1);
    String acc = top_hit.getAccession();

    System.out.println(acc);

Python
    top_hit = pepsum.getHit(1)
    acc = top_hit.getAccession()

    print(acc)

C#
    ms_protein top_hit = pepsum.getHit(1);
    string acc = top_hit.getAccession();

    Console.WriteLine(acc);

Next steps

  • Using the toolkit from C++
  • Using the toolkit from Perl, Java, Python and C#
  • Examples for error handling in Mascot Parser modules
  • Examples for the results file module
  • Examples for the configuration files module
  • Examples for the Mascot security module
  • Examples for the Mascot tools module
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Using the toolkit from C++
[Getting started with Mascot Parser]

Memory management conventions

Variables are passed by value in C++. When dealing with ms_mascotresfile objects that can be as large as the data file on disk (even gigabytes in size), it is obviously good practice to pass a reference or a pointer to such an object instead of calling its copy constructor.

Similarly, if one has a ms_mascotresfile object, and one wants to view a portion of it, say a protein hit entry with ms_mascotresults::getHit(), it would be possible to return a copy of the subset of the data file to the caller. But for performance reasons, it is often more desirable to simply return a reference or a pointer to an object internal to the c ms_mascotresfile object.

This creates a subtle problem with hidden parent-child relationships between objects that is not obvious from the API. If object P returns a reference or a pointer to object C, and P is deallocated, is it still safe to use C? Usually, in Mascot Parser, the answer is no. The reason is that C often has an internal reference to the parent object P, and deallocating P means the reference points to some arbitrary chunk of memory. Calling methods in C, if they happen to reference P, will then cause a segmentation fault.

Two rules of thumb

The rules of thumb elaborated here serve as general guidelines: follow them and you will not introduce subtle bugs that may lead to crashes. In some cases it is possible to break the rule and survive, but this usually requires knowledge of Parser internals. (In other words, don't do it.)

There are two rules of thumb. In both of them, it is assumed both A and B are in the matrix_science namespace, i.e. classes defined in Mascot Parser.

  1. Methods returning a reference or a pointer:

        A* B::func();
    A& B::func();

    You must keep both the returned object and b in memory as long as you use either. Parser owns the returned object, which means you must not deallocate it.

  2. Methods or constructors taking a reference or a pointer:

        B::B(A *a);
    B::B(A &a);

    B::func(A *a);
    B::func(A &a);

    Ownership does not change: if you owned a previously, you still do. However, you must keep both objects in memory as long as you use either.

Beware of implicit deallocation when you allocate things on the stack. The following code will segfault when function print_db_name() is called:

    using namespace matrix_science;

    ms_searchparams& get_parameters(string filename) {
        ms_mascotresfile resfile(filename);

        if (!resfile.isValid())
            throw new std::runtime_error(resfile.getLastErrorString());

        return resfile.params(); // PROBLEM HERE
    }

    void print_db_name(string filename) {
        ms_searchparams& params = get_parameters(filename);
        std::cout << params->getDB() << std::endl; // CRASH HERE
    }

The resfile object gets deallocated at the end of get_parameters(), as it is allocated on the stack. This means the object referenced by params in print_db_name() will also be deallocated (because Parser owns the ms_searchparams object) and havoc ensues.

Examples of the rules of thumb

    ms_mascotresfile resfile(filename);
    ms_searchparams& params = resfile.params();
    ms_inputquery q1(resfile, 1);

Rule of thumb 1: resfile must be kept in memory for as long as you use params.

Rule of thumb 2: resfile must be kept in memory for as long as you use q1.

    ms_mascotresfile resfile(filename);
    ms_peptidesummary pepsum(resfile);
    ms_protein* hit = pepsum.getHit(1);

Rule of thumb 1: pepsum must be kept in memory for as long as you use hit. Do not deallocate hit; it belongs to Parser.

Rule of thumb 2: resfile must be kept in memory for as long as you use pepsum.

    ms_datfile datfile();
    const ms_databases* dbs = datfile.getDatabases();

Rule of thumb 1: datfile must be kept in memory for as long as you use dbs. Do not deallocate dbs; it is owned by Parser.

    ms_quant_configfile qf();
    bool success = resfile.getQuantitation(&qf);

Rule of thumb 2: resfile must be kept in memory for as long as you use qf.

Using Apache Xerces and Parser in the same application

Parser uses the XML parser library Apache Xerces internally to read and write XML configuration files. Xerces symbols are in the xercesc namespace, which is an alias of the version-specific namespace. For example, Xerces 3.1 namespace is xerces_3_1.

If your application also links against Xerces, special care may need to be taken depending on the platform (Windows or Linux) and whether you're linking against the dynamic or static version of Parser. If your application does not use Xerces, you can ignore the rest of this section.

Origin of the problem

Xerces mandates that the global constructor xercesc::XMLPlatformUtils::Initialize() is called before any other Xerces method calls, and the global destructor xercesc::XMLPlatformUtils::Terminate() called after the last Xerces method call. Normally these calls are done at the start and end of main() or in a global application constructor and destructor class.

Parser calls both Initialize() and Terminate() internally. The Initialize() function takes as parameters pointers to an error handler and a memory manager, which are assigned to variables shared by Xerces methods inside the library.

If your application links against both Parser and Xerces, it is possible (see below) that the application ends up with only one copy of Xerces. The linker may silently choose one or the other copy of Xerces depending on linking order and how the static or shared Parser was constructed. This means that if you also call xercesc::XMLPlatformUtils::Initialize() (with or without your own error handler), it can corrupt the internal Xerces pointers. You will either receive no error messages or the application will crash while using Xerces or Parser methods.

Xerces and statically linked Parser

The statically linked Parser calls Initialize() and Terminate() as needed. The calls are balanced exactly, so that when a Parser class or method uses Xerces, Initialize() is called right before and Terminate() right after the Xerces calls.

When you link statically against both Parser and Xerces, the linker on both Windows and Linux will include only one copy of Xerces in the final application. This is fine as long as you are very careful about when and how you use Xerces. Only use Xerces strictly before or strictly after any calls to Parser functions, and never interleave the two.

Consider the following singlethreaded example:

  1. Program starts.
  2. Call xercesc::XMLPlatformUtils::Initialize() within your application.
  3. Do some XML processing with Xerces.
  4. Call xercesc::XMLPlatformUtils::Terminate() within your application.
  5. Create ms_datfile and read options from mascot.dat.
  6. Create ms_mascotresfile.
  7. Create ms_peptidesummary and iterate over hits.
  8. Delete or free the Parser objects.
  9. Call xercesc::XMLPlatformUtils::Initialize() within your application.
  10. Do some XML processing with Xerces.
  11. Call xercesc::XMLPlatformUtils::Terminate() within your application.
  12. Program ends.

This sequence is safe, because Xerces is deinitialised before steps 5-7 and there are no explicit calls to Xerces between steps 5-7. Parser may call xercesc::XMLPlatformUtils::Initialize() and xercesc::XMLPlatformUtils::Terminate() some number of times in steps 5-7. After step 8, Parser will have deinitialised Xerces; the calls are balanced exactly. This means step 9 is safe, and as long as there are no Parser calls in steps 2-4 and 9-11, the program will work as expected.

Note that there are additional restrictions concerning Xerces in multithreaded applications; see Multithreading (advanced reading).

Xerces and dynamically linked Parser on Windows

The Windows DLL version of Parser does not suffer from the problem. The shared library contains its own, separate copy of Xerces, which is initialised and deinitialised in DllMain(), right before and after your application starts. You can link against Xerces and the two libraries will not conflict.

Xerces and dynamically linked Parser on Linux

The Linux shared library version of Parser may export Xerces symbols depending on the compiler and linker. The library initialises Xerces in a library constructor function before main() is run, and deinitialises in a library destructor function after main(). Although Parser does not export the internal Xerces variables, the implementation within Parser refers to them internally. It is possible that the final application contains only the Parser implementation or only the other implementation of Xerces. In this case, using Xerces methods either explicitly in your application or implicitly through Parser will almost certainly cause a crash, whether you call xercesc::XMLPlatformUtils::Initialize() or not.

The only way to avoid the problem is to move your copy of Xerces in a different namespace (e.g. my_xercesc). To do this, you need to either change the default namespace of Xerces and recompile it, or create a statically linked wrapper library. This may not be an option of you are linking against Xerces installed as a system library.

Another way to avoid the problem is to use a different version of Xerces. Parser 2.5 uses Xerces 3.1. Xerces namespaces are versioned, so you could use Xerces 3.0 or 3.2 or any other version and the linker should keep the two implementations separate. Future versions of Parser may use a different version of Xerces, though.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Using the toolkit from Perl, Java, Python and C#
[Getting started with Mascot Parser]

On this page:

  • The matrix_science namespace in Perl, Java, Python and C#
  • Using enumerated values and static const ints in Perl, Java, Python and C#
  • Type equivalence between C++ and Perl, Java, Python and C#
  • Passing objects to functions in Perl, Java, Python and C#
  • Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
  • Catching C++ exceptions in Perl, Java, Python and C#
  • Default parameters in Perl, Java, Python and C#
  • Static functions in Perl, Java, Python and C#
  • Object initialising functions in Perl, Java, Python and C#
  • Multiple return values in Perl, Java, Python and C#
  • Maintaining object references: two rules of thumb

The matrix_science namespace in Perl, Java, Python and C#

All Mascot Parser classes are defined in the matrix_science namespace. When you use Mascot Parser from Perl, Java or Python, these objects are available in a package or class.

Perl

All classes are available in the msparser package. For example, the class matrix_science::ms_mascotresfile is accessible as msparser::ms_mascotresfile.

Java

All classes are available in the matrix_science.msparser package. For example, the class matrix_science::ms_mascotresfile is accessible as matrix_science.ms_parser.ms_mascotresfile.

Python

All classes are available in the msparser class. For example, the class matrix_science::ms_mascotresfile is accessible as msparser.ms_mascotresfile.

C#
All classes are available in the matrix_science.msparser namespace. For example, the class matrix_science::ms_mascotresfile is accessible as matrix_science.msparser.ms_mascotresfile.

Using enumerated values and static const ints in Perl, Java, Python and C#

Using enumerated values and static const ints in Perl, Java and Python

In the documentation for ms_mascotresfile, the following 'enum' definition is used:

    enum section {
      SEC_PARAMETERS,
      SEC_HEADER

These values are available in the following way in the class they are defined in:

Perl
    $msparser::ms_mascotresfile::SEC_PARAMETERS

Java
    ms_mascotresfile.SEC_PARAMETERS

Python
    msparser.ms_mascotresfile.SEC_PARAMETERS

Using enumerated values in C#

In C#, enum values are wrapped as proper C# enums. The enum values are the available in the following way in the class and enumeration they are defined in:

C#
    ms_mascotresfile.section.SEC_PARAMETERS

To use enumeration values as function parameters in C#, you will need to cast the enum value to the required parameter type, usually an int or uint. For example, to use the ms_mascotresfile.willCreateCache method, the flags parameter needs to be cast to a uint :

    string cachefile;
    bool will_create_cache = ms_mascotresfile.willCreateCache(
        "F981123.dat",
        (uint) matrix_science.msparser.ms_mascotresfile.FLAGS.RESFILE_USE_CACHE,
        new matrix_science.msparser.ms_mascotoptions().getCacheDirectory(),
        out cachefile
    );

Type equivalence between C++ and Perl, Java, Python and C#

Some values are converted automatically between C++ and the calling code. If a function returns, say, std::string, this is equivalent to a native string object.

In short:

C++ | Perl | Java | Python | C#
std::string const std::string & char * const char * | ordinary Perl string | String | non-Unicode string object | string
int long float double | ordinary number | int long float double | ordinary number object | int long float double
bool | ordinary number (0 means false, any other number means true) | boolean | Bool | bool
std::string & | usually a return value; see Multiple return values in Perl, Java, Python and C# | StringBuffer | usually a return value; see Multiple return values in Perl, Java, Python and C# | out string
int & |  | int[] |  | out int
unsigned int & |  | long[] |  | out uint

Some keywords have a different interpretation:

C++ | Perl | Java | Python | C#
const | can be ignored | roughly equivalent to final but see special case const std::string & | can be ignored | roughly equivalent to C# const but see special case const std::string &
inline virtual | can be ignored

Passing objects to functions in Perl, Java, Python and C#

In Perl, Java, Python and C# all objects are references. The same is not true in C++, where a variable can point to the object in three different ways. All three ways are collated transparently into references, which means you do not need to worry about it. Objects can be passed to C++ functions as they are.

You can recognise the three different ways easily. The three following lines all declare a function that takes an object as a parameter:

    void func1(ms_mascotresfile resfile);
    void func2(ms_mascotresfile &resfile);
    void func3(ms_mascotresfile *resfile);

These three functions would all take an object reference in Perl, Java and Python:

Perl
    my $resfile = msparser::ms_mascotresfile->new(...);
    func1($resfile);
    func2($resfile);
    func3($resfile);

Java
    ms_mascotresfile resfile = new ms_mascotresfile(...);
    func1(resfile);
    func2(resfile);
    func3(resfile);

Python
    resfile = msparser.ms_mascotresfile(...)
    func1(resfile)
    func2(resfile)
    func3(resfile)

C#
    ms_mascotresfile resfile = new ms_mascotresfile(...);
    func1(resfile);
    func2(resfile);
    func3(resfile);

For example, take a function such as ms_fileutilities::getLastModificationTime():

    static time_t getLastModificationTime(const char *filename, ms_errs *err=NULL);

The function expects an ms_errs object as a parameter. You can simply pass an object reference:

Perl
    my $errs = msparser::ms_errs->new();
    my $time = msparser::ms_fileutilities::getLastModificationTime($filename, $errs);

    if (!$errs->isValid()) {
        ...
    }

Java
    ms_errs errs = new ms_errs();
    int time = ms_fileutilities.getLastModificationTime(filename, errs);

    if (!errs.isValid()) {
        ...
    }

Python
    errs = msparser.ms_errs()
    time = msparser.ms_fileutilities.getLastModificationTime(filename, errs)

    if not errs.isValid() :
        ...

C#
    ms_errs errs = new ms_errs();
    long time = ms_fileutilities.getLastModificationTime(filename, errs);

    if (!errs.isValid()) {
        ...
    }

Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

Some functions take or return arrays of values. In C++, these are called vectors, and each vector can only store values of one particular type. std::vector is the "Standard Template Library" (STL) class for vectors. std::vector<int> can only store integer values, while std::vector<std::string> can only store string values. An example function that both returns a vector and takes vectors as arguments is getAllProteinsWithThisPepMatch(). When calling such functions, you must create a vector object of the correct type:

Perl
    my $vectorOfInts    = new msparser::vectori;       # For std::vector<int>
    my $vectorOfLongs   = new msparser::vectorl;       # For std::vector<long>
    my $vectorOfDoubles = new msparser::vectord;       # For std::vector<double>
    my $vectorOfBools   = new msparser::vectorb;       # For std::vector<bool>
    my $vectorOfStrings = new msparser::VectorString;  # For std::vector<std::string>

Java and C#
    vectori vectorOfInts    = new vectori();           # For std::vector<int>
    vectorl vectorOfLongs   = new vectorl();           # For std::vector<long>
    vectord vectorOfDoubles = new vectord();           # For std::vector<double>
    vectorb vectorOfBools   = new vectorb();           # For std::vector<bool>
    VectorString vectorOfStrings = new VectorString(); # For std::vector<std::string>

Python
    vectorOfInts    = msparser.vectori()      # For std::vector<int>
    vectorOfLongs   = msparser.vectorl()      # For std::vector<long>
    vectorOfDoubles = msparser.vectord()      # For std::vector<double>
    vectorOfBools   = msparser.vectorb()      # For std::vector<bool>
    vectorOfStrings = msparser.VectorString() # For std::vector<std::string>

The different vector classes share a common interface, as shown next.

Perl

Vectors are similar to Perl arrays, but with two differences: appending and modifying items is more restricted, and vectors are strictly typed. Strict typing means that if you try to append an integer to VectorString, for example, you will get a runtime exception. See Catching C++ exceptions in Perl, Java, Python and C#.

    # Create a vector of size 0. (In this example, we'll use integer vectors.)
    my $vector = new msparser::vectori;
    # Create a vector of any size, say 20. Items will be initialised to undef.
    my $vector2 = new msparser::vectori(20);

    # Append a value at the end of the vector.
    $vector->push(100);
    $vector->push(200);

    # Get the number of items in the vector. Vector indices run from 0
    # to $size - 1.
    my $size = $vector->size();

    # Get item at any index. If the index is out of range (negative or
    # greater than $size - 1), an exception will be thrown.
    my $val = $vector->get(1);

    # Set the value of item at a given index. After this call, $vector
    # is [200, 200].
    $vector->set(0, 200);

    # Remove the last item of the vector and return its value. If
    # $vector->size() is zero, this will throw an exception.
    $val = $vector->pop();

    # Predicate testing whether the vector is empty (equivalent to
    # testing $vector->size == 0).
    if ($vector->empty) { ... }

    # Iterate over all items in the vector.
    for my $i (0 .. $vector->size-1) {
        print $vector->get($i), "\n";
    }

    # Clear the vector, i.e. remove all of its elements.
    $vector->clear();

Java

STL vectors are similar to Java Vectors; std::vector<int> is analogous to Vector<int>. However, there is no compile-time type checking, which means that if you try to append values to the vector that are not of the correct type, a runtime exception will be thrown. See Catching C++ exceptions in Perl, Java, Python and C#.

    // Create a vector of size 0. (In this example, we'll use integer vectors.)
    vectori vector = new vectori();
    // Create a vector of any size, say 20. Items will be initialised to null.
    vectori vector2 = new vectori(20);

    // Append a value at the end of the vector.
    vector.push(100);
    vector.push(200);

    // Get the number of items in the vector. Vector indices run from 0
    // to size - 1.
    int size = vector.size();

    // Get item at any index. If the index is out of range (negative or
    // greater than size - 1), an exception will be thrown.
    int val = vector.get(1);

    // Set the value of item at a given index. After this call, 'vector'
    // contains values [200, 200].
    vector.set(0, 200);

    // Remove the last item of the vector and return its value. If
    // vector.size() is zero, this will throw an exception.
    int val = vector.pop();

    // Predicate testing whether the vector is empty (equivalent to
    // testing vector.size() == 0).
    if (vector.empty()) { ... }

    // Iterate over all items in the vector.
    for (int i = 0; i != vector.size(); i++)
        System.out.println(vector.get(i));

    // Clear the vector, i.e. remove all of its elements.
    vector.clear();

Python

Vectors are similar to Python arrays, but with two differences: appending and modifying items is more restricted, and vectors are strictly typed. Strict typing means that if you try to append an integer to VectorString, you will get a runtime exception. See Catching C++ exceptions in Perl, Java, Python and C#.

    # Create a vector of size 0. (In this example, we'll use integer vectors.)
    vector = msparser.vectori()
    # Create a vector of any size, say 20. Items will be initialised to None.
    vector2 = msparser.vectori(20)

    # Append a value at the end of the vector. If the value is not of
    # the correct type (integer for vectori, string for VectorString, etc.),
    # an exception will be thrown. See below how to catch it.
    vector.append(100)
    vector.append(200)

    # Get the number of items in the vector. Vector indices run from 0
    # to size - 1.
    size = len(vector)

    # Get item at any index. If the index is out of range (negative or
    # greater than size - 1), an exception will be thrown.
    val = vector[1]

    # Set the value of item at a given index. After this call, vector
    # is [200, 200]. If the index is out of range, an exception will be
    # thrown.
    vector[0] = 200

    # Remove the last item of the vector and return its value. If
    # vector.size() is zero, this will throw an exception.
    val = vector.pop_back()

    # Predicate testing whether the vector is empty (equivalent to
    # testing len(vector) == 0).
    if vector.empty()
        ...

    # Iterate over all items in the vector.
    for item in vector:
        print(item)

    # Clear the vector, i.e. remove all of its elements.
    vector.clear()

C#

STL vectors are similar to C# Lists; std::vector<int> is analogous to List<int>. However, there is no compile-time type checking, which means that if you try to append values to the vector that are not of the correct type, a runtime exception will be thrown. See Catching C++ exceptions in Perl, Java, Python and C#.

    // Create a vector of size 0. (In this example, we'll use integer vectors.)
    vectori vector = new vectori();
    // Create a vector of any size, say 20. Items will be initialised to null.
    vectori vector2 = new vectori(20);

    // Append a value at the end of the vector.
    vector.Add(100);
    vector.Add(200);

    // Get the number of items in the vector. Vector indices run from 0
    // to size - 1.
    int size = vector.Count;

    // Get item at any index. If the index is out of range (negative or
    // greater than size - 1), an exception will be thrown.
    int val = vector[1];

    // Set the value of item at a given index. After this call, 'vector'
    // contains values [200, 200].
    vector[0] = 200;

    // Remove the last item of the vector and return its value. If
    // vector.size() is zero, this will throw an exception.
    val = vector[size-1];
    vector.RemoveAt(size-1);

    // Predicate testing whether the vector is empty (equivalent to
    // testing vector.size() == 0).
    if (vector.Count == 0) {  }

    // Iterate over all items in the vector.
    for (int i = 0; i != vector.Count; i++)
        Console.WriteLine(vector[i]);

    // Clear the vector, i.e. remove all of its elements.
    vector.Clear();

Here is an example how to call a method that takes vectors of multiple types as arguments.

Perl
    my $start = new msparser::vectori;
    my $end   = new msparser::vectori;
    my $pre   = new msparser::VectorString;
    my $post  = new msparser::VectorString;
    my $frame = new msparser::vectori;
    my $multiplicity = new msparser::vectori;
    my $db    = new msparser::vectori;
    my $accessions = $pepsum->getAllProteinsWithThisPepMatch(
        1, 1, $start, $end, $pre, $post, $frame, $multiplicity, $db
    );

In the API documentation, the method getAllProteinsWithThisPepMatch() returns a VectorString. However, any vector returned from a function is automatically converted into an array reference in Perl.

You can access the elements of each vector by using the get() method, and calling size() returns the number of elements in the vector. For instance:

    for my $i (0 .. $multiplicity->size()-1) {
        print $multiplicity->get($i), "\n";
    }

    # This assumes $db->size() == scalar(@$accessions).
    for my $i (0 .. $#$accessions) {
        print $db->get($i), '::', $$accessions[$i], "\n";
    }

It is easy to convert STL vectors into Perl arrays:

    sub stl_to_array { [ map { $_[0]->get($_) } 0 .. $_[0]->size-1 ] }

    # Usage (assuming $db is a vectori object as above):
    my $db_arr = stl_to_array($db);

    # And now the loop is more symmetrical:
    for my $i (0 .. $#$accessions) {
        print $$db_arr[$i], '::', $$accessions[$i], "\n";
    }

Java
    vectori      start = new vectori();
    vectori      end   = new vectori();
    VectorString pre   = new VectorString();
    VectorString post  = new VectorString();
    vectori      frame = new vectori();
    vectori      multiplicity = new vectori();
    vectori      db    = new vectori();
    VectorString accessions = pepsum.getAllProteinsWithThisPepMatch(
        1, 1, start, end, pre, post, frame, multiplicity, db
    );

You can access the elements of each vector by using the get() method, and calling size() returns the number of elements in the vector. For instance:

    for (int i = 0; i != multiplicity.size(); i++)
        System.out.println(multiplicity.get(i));

    // This assumes db.size() == accessions.size().
    for (int i = 0; i != accessions.size(); i++)
        System.out.println(new String(db.get(i)) + "::" + accessions.get(i));

Python
    start = msparser.vectori()
    end   = msparser.vectori()
    pre   = msparser.VectorString()
    post  = msparser.VectorString()
    frame = msparser.vectori()
    multiplicity = msparser.vectori()
    db    = msparser.vectori()
    accessions = pepsum.getAllProteinsWithThisPepMatch(
        1, 1, start, end, pre, post, frame, multiplicity, db
    )

You can then iterate over the items in each vector:

    for m in multiplicity:
        print(m)

    # This assumes db.size() == accessions.size().
    for i in range(accessions.size()):
        print("%d :: %s" % (db[i], accessions[i]))

C#
    vectori      start = new vectori();
    vectori      end   = new vectori();
    VectorString pre   = new VectorString();
    VectorString post  = new VectorString();
    vectori      frame = new vectori();
    vectori      multiplicity = new vectori();
    vectori      db    = new vectori();
    VectorString accessions = pepsum.getAllProteinsWithThisPepMatch(
        1, 1, start, end, pre, post, frame, multiplicity, db
    );

You can then iterate over the items in each vector, and accessing the Count parameter returns the number of elements in the vector. For instance:

    for (int i = 0; i != multiplicity.Count; i++) {
        Console.WriteLine(multiplicity[i]);
    }
    // This assumes db.Count == accessions.Count.
    for (int i = 0; i != accessions.Count; i++) {
        Console.WriteLine("{0}::{1}", db[i], accessions[i]);
    }

Catching C++ exceptions in Perl, Java, Python and C#

Exceptions from within Parser can be caught using exception handling mechanisms in the native language, as shown below. Exceptions will only be thrown by STL classes; Mascot Parser handles errors internally (see Error Handling).

Perl
    my $vectori = new msparser::vectori;

    # This will always throw an exception for an empty vector.
    eval { $vectori->pop() };

    if ($@) {
        print $@;
    }

Java
    vectori vector = new msparser.vectori();

    // This will always throw an exception for an empty vector.
    try {
        vector.pop();
    } catch (Exception e) {
        System.out.println(e);
    }

Python
    vector = msparser.vectori()

    # This will always throw an exception for an empty vector.
    try:
        vector.pop_back()
    except Exception as e:
        print(e)

C#
    vectori vector = new vectori();
    try {
        // this will always throw an exception for an empty vector.
        vector.RemoveAt(0);
    } catch (Exception e) {
        Console.Error.WriteLine(e);
    }

Default parameters in Perl, Java, Python and C#

In C++, functions take a fixed number of arguments. However, some of these arguments can have default values. For example, the getDB() function has the following declaration:

    std::string getDB(int idx = 1)

Whenever you see an equals sign (=) in the function documentation, the parameter next to the sign has a default value. This means that you can leave out the parameter when calling the constructor or method:

Perl

Assume $params is of type ms_searchparams.

    my $db = $params->getDB();   # Equivalent to $params->getDB(1)
    my $db2 = $params->getDB(2); # Override default parameter

    # This will always print 'yes'.
    if ($params->getDB eq $params->getDB(1)) {
        print "yes\n";
    }

Java

Assume params is of class ms_searchparams.

    int db = params.getDB();   // Equivalent to params.getDB(1)
    int db2 = params.getDB(2); // Override default parameter

    // This will always print 'yes'.
    if (params.getDB().equals(params.getDB(1))) {
        System.out.println("yes");
    }

Python

Assume params is of type ms_searchparams.

    db = params.getDB()   # Equivalent to params.getDB(1)
    db2 = params.getDB(2) # Override default parameter

    # This will always print 'yes'.
    if params.getDB() == params.getDB(1):
        print("yes")

C#

Assume _params is of class ms_searchparams.

    int db = _params.getDB();   // Equivalent to _params.getDB(1)
    int db2 = _params.getDB(2); // Override default parameter

    // This will always print 'yes'.
    if (_params.getDB().equals(_params.getDB(1))) {
        Console.WriteLine("yes");
    }

Static functions in Perl, Java, Python and C#

Some functions in Mascot Parser are defined at class level rather than object level. In C++, C# and Java, these are called static functions, while in Perl and Python they are called class methods. Static functions can be used directly without creating an object of the class, as the following example shows:

Perl
    my ($will_create_cache, $cachefile) = msparser::ms_mascotresfile::willCreateCache(
        "F981123.dat",
        $msparser::ms_mascotresfile::RESFILE_USE_CACHE,
        msparser::ms_mascotoptions->new->getCacheDirectory(),
    );

    if ($will_create_cache) {
        print "ms_mascotresfile will use $cachefile as the cache file.\n";
    } else {
        print "ms_mascotresfile will not use the cache.\n";
    }

Java
    String[] cachefile;
    boolean will_create_cache = ms_mascotresfile.willCreateCache(
        "F981123.dat",
        msparser.ms_mascotresfile.RESFILE_USE_CACHE,
        new msparser.ms_mascotoptions().getCacheDirectory(),
        cachefile
    );

    if (will_create_cache) {
        System.out.println(
            "ms_mascotresfile will use " + cachefile[0] + " as the cache file."
        );
    } else {
        System.out.println(
            "ms_mascotresfile will not use the cache."
        );
    }

Python
    will_create_cache, cachefile = msparser.ms_mascotresfile.willCreateCache(
        "F981123.dat",
        msparser.ms_mascotresfile.RESFILE_USE_CACHE,
        msparser.ms_mascotoptions().getCacheDirectory(),
        )

    if will_create_cache :
        print("ms_mascotresfile will use %s as the cache file." % cachefile)
    else :
        print("ms_mascotresfile will not use the cache.")

C#
    string cachefile;
    bool will_create_cache = ms_mascotresfile.willCreateCache(
        "F981123.dat",
        (uint) matrix_science.msparser.ms_mascotresfile.FLAGS.RESFILE_USE_CACHE,
        new matrix_science.msparser.ms_mascotoptions().getCacheDirectory(),
        out cachefile
    );

    if (will_create_cache) {
        Console.WriteLine(
            "ms_mascotresfile will use {0} as the cache file.",
        cachefile);
    } else {
        Console.WriteLine(
            "ms_mascotresfile will not use the cache."
        );
    }

Object initialising functions in Perl, Java, Python and C#

Some functions in Mascot Parser are used to initialise an object. These are not constructors, but rather take an object reference as an argument, whose member fields are then filled in.

In C++, these "object initialising functions" take a pointer or reference argument. In Perl, Java, C# and Python, you can simply pass an object reference. For example, ms_mascotresfile::getQuantitation() (which is used in the example below) takes an ms_quant_configfile object, while staticGetPercolatorFileNames() takes two vectors as arguments and fills them in.

Perl
    my $resfile = msparser::ms_mascotresfile->new($filename);
    my $qf = msparser::ms_quant_configfile->new();
    $qf->setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        . " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        . " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        . " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
    );

    if ($resfile->getQuantitation($qf)) {
        print "Quantitation name: ", $qf->getMethodByNumber(0)->getName(), "\n";
    } else {
        print "No quantitation section\n";
    }

Java
    ms_mascotresfile resfile = new ms_mascotresfile(filename);
    ms_quant_configfile qf = new ms_quant_configfile();
    qf.setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        + " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        + " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        + " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
    );

    if (resfile.getQuantitation(qf))
        System.out.println("Quantitation name: " + qf.getMethodByNumber(0).getName());
    else
        System.out.println("No quantitation section");

Python
    resfile = msparser.ms_mascotresfile($filename)
    qf = msparser.ms_quant_configfile()

    qf.setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        + " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        + " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        + " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
        )

    if resfile.getQuantitation(qf) :
        print("Quantitation name: %s" % qf.getMethodByNumber(0).getName())
    else :
        print("No quantitation section")

C#
    ms_mascotresfile resfile = new ms_mascotresfile(filename);
    ms_quant_configfile qf = new ms_quant_configfile();
    qf.setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        + " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        + " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        + " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
    );

    if (resfile.getQuantitation(qf))
        Console.WriteLine("Quantitation name: " + qf.getMethodByNumber(0).getName());
    else
        Console.WriteLine("No quantitation section");

Multiple return values in Perl, Java, Python and C#

Some functions in Mascot Parser return multiple values. In C++, this is usually handled by returning values in pointer arguments. In the API documentation, parameters to these kinds of functions are marked either as "in" or "out": "in" means the parameter is read by the function, and "out" means the function returns a value in the parameter. If the function parameter has no "in" or "out", it is assumed to be "in" by default.

In Perl, "out" values are returned as a list, while in Python the values are return as a tuple. In C# you mark the "out" parameters with the out keyword. In Java, however, you must use arrays of length 1 as the following example shows:

Perl

In Perl, a function can return a list of values. This means that a Mascot Parser function may also return multiple values. There are only a few functions in Mascot Parser that do so; these are documented in the API. An example is get_ms_mascotresults_params().

    my ($scriptName,
        $flags,
        $minProbability,
        $maxHitsToReport,
        $ignoreIonsScoreBelow,
        $minPepLenInPepSummary,
        $usePeptideSummary,
        $flags2
    ) = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions);

The returning in a list only applies to native types, for example integers, doubles and strings. Objects passed to the function documented by [in,out] should be passed as normal to the function.

Java

Note that std::string & parameters require a StringBuffer and the value in the StringBuffer is modified by the Mascot Parser function. There is no need to follow the instructions below for these parameters.

In Java, methods can only have one return value. If a Mascot Parser method returns multiple native values via pointers, you must use arrays of length 1 as parameters to that function. The return values will then be at the zeroth index of the arrays. For example, get_ms_mascotresults_params() returns multiple values:

    int[]     flags = {0};
    double[]  minProbability = {0};
    int[]     maxHitsToReport = {0};
    double[]  ignoreIonsScoreBelow = {0};
    int[]     minPepLenInPepSummary = {0};
    boolean[] usePeptideSummary = {false};
    int[]     flags2 = {0};

    String scriptName = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(),
        flags,
        minProbability,
        maxHitsToReport,
        ignoreIonsScoreBelow,
        minPepLenInPepSummary,
        usePeptideSummary,
        flags2
    );

    // Results in flags[0], minProbability[0], ...

Python

In Python, functions can return multiple values in tuples. The same applies to Mascot Parser functions that return multiple values; an example is get_ms_mascotresults_params().

    (scriptName,
     flags,
     minProbability,
     maxHitsToReport,
     ignoreIonsScoreBelow,
     minPepLenInPepSummary,
     usePeptideSummary,
     flags2) = resfile.get_ms_mascotresults_params(datfile.getMascotOptions())

C#

In C#, methods can have multiple return parameters, specified using the out keyword. Therefore, any parameter documented as an "out" parameter in the Mascot Parser API must be preceded by the out keyword when calling the method from C#. For example, get_ms_mascotresults_params() returns multiple values:

    uint flags, flags2, minpeplen;
    int maxhits;
    double minprob, iisb;
    bool usePepsum;
    string scriptname = resfile.get_ms_mascotresults_params(
        datfile.getMascotOptions(),
        out flags,
        out minprob,
        out maxhits,
        out iisb,
        out minpeplen,
        out usePepsum,
        out flags2
    );

    // results in flags, minprob ...

With C#, every out parameter must be supplied, even if the documentation states that there is a default value.

Maintaining object references: two rules of thumb

Innocent-looking programs that crash

Consider the following three programs in Perl, Java, and Python, respectively. (Error handling is omitted for clarity, but adding it would not fix the problem.)

Perl
    #!/usr/local/bin/perl
    use strict;
    use msparser;

    sub get_params {
        my $resfile = msparser::ms_mascotresfile->new($_[0]);
        return $resfile->params;                 # PROBLEM HERE
    }

    my $params = get_params($ARGV[0]);
    print $params->getNumberOfDatabases, "\n";   # CRASH HERE

Java
    import matrix_science.msparser.*;

    public class example {
        static {
            try {
                System.loadLibrary("msparserj");
            } catch (UnsatisfiedLinkError e) {
                System.exit(0);
            }
        }

        private static get_params(String filename) {
            ms_mascotresfile resfile = new ms_mascotresfile(filename);
            return resfile.params();    // PROBLEM HERE
        }

        public static void main(String argv[]) {
            ms_searchparams params = get_params(argv[0]);
            System.gc();                // See below why these are needed
            System.runFinalization();   // to trigger the crash.
            System.out.println(params.getNumberOfDatabases()); // CRASH HERE
        }
    }

Python
    #!/usr/bin/python
    import msparser
    import sys

    def get_params(filename):
        resfile = msparser.ms_mascotresfile(filename)
        return resfile.params()           # PROBLEM HERE

    params = get_params(sys.argv[1])
    print(params.getNumberOfDatabases())   # CRASH HERE

All of the programs crash at the end of the main program while trying to print the number of databases. (Go ahead and try!) In this case, the params() method of the resfile object returns an object that contains an internal reference to the parent resfile object. At the end of get_params(), resfile goes out of scope. The program will then crash when methods of the params object are accessed, because resfile is no longer in scope.

The same problem can be demonstrated in C#:

C#
    using System;
    using matrix_science.msparser;
    class GarbageCollectionExample
    {
        private static ms_peptidesummary loadPeptideSummary(string filename)
        {
            ms_mascotresfile resfile = new ms_mascotresfile(filename);
            ms_datfile datfile = new ms_datfile("../config/mascot.dat");

            ms_mascotoptions opts = new ms_mascotoptions();

            uint flags, flags2, minpeplen;
            int maxhits;
            double minprob, iisb;
            bool usePepsum;
            resfile.get_ms_mascotresults_params(opts, out flags, out minprob,
                out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);

            return new ms_peptidesummary(resfile, flags, minprob,
                maxhits, "", iisb, (int)minpeplen, "", flags2); // PROBLEM HERE
        }

        public static void Main(string[] argv)
        {
            ms_peptidesummary pepsum = loadPeptideSummary(argv[0]);
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                ms_protein hit = pepsum.getHit(i);
                for (int e = 1; e <= hit.getNumPeptides(); e++)
                {
                    int q = hit.getPeptideQuery(e), p = hit.getPeptideP(e);
                    ms_peptide peptide = pepsum.getPeptide(q, p);
                    Console.WriteLine(peptide.getPeptideStr());   // CRASH HERE
                }
            }
        }

    }

This program will crash within a few iterations when calling peptide.getPeptideStr() . Again, the problem is that the ms_peptidesummary object contains an internal reference to an ms_mascotresfile object which goes out of scope at the end of loadPeptideSummary.

If you are interested in gritty details, see Garbage collection problems (advanced reading).

Note:
The Java and C# examples have an explicit call to the system garbage collector. Without those statements, the example program may work just fine most of the time, and then once in a blue moon crash unexpectedly. This is because the Java and C# garbage collector are run at unpredictable times, not necessarily at the end of scope.
Note:
Do also note that the following is safe in Python, because if, for and while do not create a new lexical scope, but just inherit either the global or function (local) scope:
    #!/usr/bin/python
    import msparser
    import sys

    if sys.argv[1]:
        resfile = msparser.ms_mascotresfile(sys.argv[1])
        params = resfile.params()

    if params:
        print(params.getNumberOfDatabases())  # No crash here.

Two rules of thumb

There are two easy rules of thumb to avoid crashes such as above. In the following, suppose that $b contains an object of class B, and $a contains an object of class A.

  1. When the C++ function of class B takes a pointer or a reference as an argument, and you pass it $a, you must keep a reference to $a for as long as you use $b.
  2. When the C++ function of class B returns a pointer or a reference as an argument, and you store it in $a, you must keep a reference to $b for as long as you use $a.

There is one exception:

  • If a method of class B takes or returns only objects not in the matrix_science namespace, no coupling will be introduced, and no precautions are needed for $b and $a.

How do you recognise a C++ pointer or reference in the API documentation?

  ms_protein* ms_mascotresults::getHit(const int hit);
  ms_inputquery::ms_inputquery(const ms_mascotresfile &resfile, const int q);

The first line defines a function getHit that returns a pointer. The second line defines a function (actually a constructor) ms_inputquery that takes a references as a parameter. So, be on a lookout for ampersands (&) and asterisks (*) when reading the API documentation.

In practice, the rules of thumb are easily followed by keeping the objects together in a hash, dictionary or array until they are no longer needed, or by creating a wrapper class that holds references to all affected objects. In short programs and scripts, you may wish to just make ms_mascotresfile, ms_proteinsummary and ms_peptidesummary objects global instead of lexically scoped, or wrap them in singleton classes.

Examples of the rules of thumb

The following examples are written in Python, as Python code is syntactically close to natural language, and can serve as an effective pseudocode. Statements are terminated with semicolons to make the code more familiar for Perl, Java and C# programmers.

    resfile = msparser.ms_mascotresfile(filename);
    params = resfile.params();
    q1 = msparser.ms_inputquery(resfile, 1);

Rule of thumb 1: keep a reference to resfile for as long as you use params.

Rule of thumb 2: keep a reference to resfile for as long as you use q1.

    resfile = msparser.ms_mascotresfile(filename);
    pepsum = msparser.ms_peptidesummary(resfile);
    hit = pepsum.getHit(1);

Rule of thumb 1: keep a reference to pepsum for as long as you use hit.

Rule of thumb 2: keep a reference to resfile for as long as you use pepsum.

    datfile = msparser.ms_datfile();
    dbs = datfile.getDatabases();

Rule of thumb 1: keep a reference to datfile for as long as you use dbs.

    qf = msparser.ms_quant_configfile();
    success = resfile.getQuantitation(qf);

Rule of thumb 2: keep a reference to resfile for as long as you use qf.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Garbage collection problems (advanced reading)
[Getting started with Mascot Parser]

Perl
    #!/usr/local/bin/perl
    use strict;
    use msparser;

    sub get_params {
        my $resfile = msparser::ms_mascotresfile->new($_[0]);
        return $resfile->params;                 # PROBLEM HERE
    }

    my $params = get_params($ARGV[0]);
    print $params->getNumberOfDatabases, "\n";   # CRASH HERE

Java
    import matrix_science.msparser.*;

    public class example {
        static {
            try {
                System.loadLibrary("msparserj");
            } catch (UnsatisfiedLinkError e) {
                System.exit(0);
            }
        }

        private static get_params(String filename) {
            ms_mascotresfile resfile = new ms_mascotresfile(filename);
            return resfile.params();    // PROBLEM HERE
        }

        public static void main(String argv[]) {
            ms_searchparams params = get_params(argv[0]);
            System.gc();                // See below why these are needed
            System.runFinalization();   // to trigger the crash.
            System.out.println(params.getNumberOfDatabases()); // CRASH HERE
        }
    }

Python
    #!/usr/bin/python
    import msparser
    import sys

    def get_params(filename):
        resfile = msparser.ms_mascotresfile(filename)
        return resfile.params()           # PROBLEM HERE

    params = get_params(sys.argv[1])
    print(params.getNumberOfDatabases())   # CRASH HERE

C#
    using System;
    using matrix_science.msparser;
    class GarbageCollectionExample
    {
        private static ms_peptidesummary loadPeptideSummary(string filename)
        {
            ms_mascotresfile resfile = new ms_mascotresfile(filename);
            ms_datfile datfile = new ms_datfile("../config/mascot.dat");

            ms_mascotoptions opts = new ms_mascotoptions();

            uint flags, flags2, minpeplen;
            int maxhits;
            double minprob, iisb;
            bool usePepsum;
            resfile.get_ms_mascotresults_params(opts, out flags, out minprob,
                out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);

            return new ms_peptidesummary(resfile, flags, minprob,
                maxhits, "", iisb, (int)minpeplen, "", flags2); // PROBLEM HERE
        }

        public static void Main(string[] argv)
        {
            ms_peptidesummary pepsum = loadPeptideSummary(argv[0]);
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                ms_protein hit = pepsum.getHit(i);
                for (int e = 1; e <= hit.getNumPeptides(); e++)
                {
                    int q = hit.getPeptideQuery(e), p = hit.getPeptideP(e);
                    ms_peptide peptide = pepsum.getPeptide(q, p);
                    Console.WriteLine(peptide.getPeptideStr());   // CRASH HERE
                }
            }
        }

    }

Why do the example programs crash?

The programs crash because the resfile object is deallocated from memory too early.

The resfile object is lexically scoped only to the get_params() function (or the loadPeptideSummary function in the C# example). When get_params() or loadPeptideSummary ends, resfile becomes unreachable and is ready for garbage collection. In Perl and Python, this happens at the end of the function; in Java and C#, this happens at an arbitrary point during execution, but you can force it at any time by calling System.gc(); System.runFinalization(); in Java (as we do in the example program to illustrate the problem).

By itself, this is not a problem at all. The problem becomes clear when you look at the declaration of matrix_science::ms_mascotresfile::params(). Mascot Parser uses SWIG (Simplified Wrapper and Interface Generator, http://swig.org/) to generate the mappings between C++ and the target language. The params() method returns a C++ reference to an ms_searchparams object, not a copy, which the SWIG layer helpfully wraps into a native class object, thus masking the real nature of the return value.

So the resfile object is freed from memory at the end of scope, and all its internal data deallocated, which also means the ms_searchparams object. But we still have an object pointing to the internal ms_searchparams object! It now points to some arbitrary chunk of memory, which most certainly is not executable code. If you then try to call its methods, you will crash the program with a segmentation fault.

Why is this not handled in SWIG? Because the SWIG layer cannot detect that the ms_searchparams object has an internal reference to the parent ms_mascotresfile object. This is hidden inside the C++ implementation. A general solution to this problem would need to track all pointer and reference assignments in the C++ code, and then increase and decrease the reference count of each wrapped object in the runtime environment of whichever programming language you are using. It is very difficult to implement correctly.

Note that the problem in Java and C# is even more subtle than in Perl and Python. If you remove the System.gc() and System.runFinalization() lines from the example program, the program may run just fine for hundreds of times, and then one time, if the system is running out of memory for some reason, or any other similar issue, the JVM or .NET CLR garbage collector might be run just before params.getNumberOfDatabases() -- and bang! Your program, which has worked hundreds of times before, crashes for no reason. This is obviously even harder to detect and debug in a large program.

Luckily there is a safe fix: follow Two rules of thumb when writing programs using Mascot Parser.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Multithreading (advanced reading)
[Getting started with Mascot Parser]

Using Parser in multithreaded applications

If your application is singlethreaded, you can safely skip this section.

Restrictions on threads

Parser classes and methods are not guaranteed to be reentrant or thread-safe. However, with some care, it is possible to use Parser in a multithreaded application.

The easiest and safest solution is to only use Parser from a single thread in your application. For example, if your application has four threads, only use Parser classes and methods in thread 3 and never from threads 1, 2 or 4. If you can guarantee that no thread other than thread 3 uses Parser or has access to thread 3's variables or memory space, then Parser methods will work just fine. Note that if thread 3 should transfer data to or from the other threads, the data cannot be encapsulated in Parser objects; that is, don't pass ms_protein or ms_peptide objects between threads, or any other Parser objects.

If you need to use Parser from multiple threads, you have two choices: either create a synchronised data abstraction class (shared global data) or use thread-local storage for completely independent instances of Parser objects in each thread.

In the synchronised class scenario, you need to write a data abstraction class that uses Parser internally (storing copies of the ms_mascotresfile etc. objects), whose methods are guarded by a single mutual exclusion lock (mutex). The mutex must guard access to the entire data abstraction object, and each method must start by acquiring the mutex. If thread 3, for example, makes a method call and acquires the mutex, then any other thread making the same or different method call on the object will block until thread 3's method call has finished and released the mutex. This strict mutual exclusion prevents race conditions and ensures the Parser data shared between threads is only ever accessed by one thread at a time.

However, there are two caveats: 1) the data abstraction class must not return Parser objects or otherwise expose them, as this would nullify the protection of the mutex; and 2) the data abstraction class must be instantiated in a global memory space shared between all threads, so that it is not specific to a thread. The data abstraction class need not implement the Singleton pattern; you could have multiple instances of the class, each with its own internal, independent copies of Parser classes. If you do make it a Singleton, ensure you follow a thread-safe Singleton pattern.

In the other scenario, each thread could have its own copies of Parser classes that are independent of each other. For example, if thread 1 creates an ms_mascotresfile object resfile1, and thread 2 creates resfile2, then thread 1 can call methods of resfile1 concurrently with thread 2 calling methods of resfile2. This is in effect the same situation as the singlethreaded mode, with the same restrictions: thread 2 must not call methods of resfile1, or vice versa, and the threads must not pass Parser objects between themselves. If you do, the application is almost certain to crash sooner or later.

Further restrictions in C++

The above design restrictions apply to all programming languages, including C++. However, the C++ version of Parser has an additional restriction related to Apache Xerces; please refer to section Using Apache Xerces and Parser in the same application.

Multithreading does not change these issues in the dynamically linked case on either platform, but you must take extra care if you are linking statically against Parser and Xerces. Section Xerces and statically linked Parser shows an example sequence of Xerces and Parser calls that is safe in a singlethreaded application. The same sequence will only be safe in a multithreaded application if you can guarantee that no two threads call Parser and Xerces functions concurrently. Otherwise you are almost certain to corrupt the internal Xerces state.

The only easy fix is to do all Parser and Xerces processing in a single thread strictly following each other (not interleaved in any way). It may be best to use a different XML library in statically linked multithreaded applications to avoid the problem entirely.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Mascot results file module

Classes

class | ms_inputquery
This class encapsulates the input data in the mascot results file. More...
class | ms_linker_site
Position of an intact link between alpha and beta peptide or a looplink. More...
class | ms_linker_site_vector
A vector of linker sites. More...
class | ms_mascotresfile
The first requirement before using any other functions or classes is to create an ms_mascotresfile object. More...
class | ms_mascotresults
Abstract class for either ms_peptidesummary or ms_proteinsummary. More...
class | ms_mascotresults_params
Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary. More...
class | ms_peptide
This class encapsulates a peptide from the mascot results file. More...
class | ms_peptidesummary
Use this class to get peptide summary results. More...
class | ms_protein
This class encapsulates a protein in the mascot results file. More...
class | ms_proteinsummary
class | ms_searchparams
This class encapsulates the search parameters in the mascot results file. More...
class | ms_unigene
This class encapsulates a complete unigene file. More...
class | ms_unigene_entry
This class encapsulates a single entry from a unigene file. More...

Modules

Examples for the results file module
UML Class Diagram
Issues with backward compatibility for results files
Error Handling
Peptide mass fingerprint mixtures
Grouping proteins together
Unassigned peptides list
Treatment of duplicate peptides
Detecting ambiguous peptide matches
Error tolerant searches
Crosslinked search results
Using the singleHit parameter to return a single protein
Automated repeating of searches
Target-decoy searches and false discovery rate
Using Percolator scores
Caching Mascot Results
Combining multiple .dat files
Query-level modifications
Spectral libraries
Spectral library score threshold (advanced reading)

Detailed Description

The Mascot results files module is used for parsing information from the results files. This data is typically used to populate a database with search results, or to provide custom reports. The standard Mascot reports uses this module.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Examples for the results file module
[Mascot results file module]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation

The quick guide Quickstart: how to open a results file shows how to get very basic information from the search result files with just a few lines of code. The following examples are more comprehensive.

Description | Perl | C++ | Java | Python | C#
Error handling | resfile_error.pl | resfile_error.cpp | resfile_error.java | resfile_error.py | resfile_error.cs
Retrieving information about the search | resfile_info.pl | resfile_info.cpp | resfile_info.java | resfile_info.py | resfile_info.cs
Retrieving the input spectrum for the search results | resfile_input.pl | resfile_input.cpp | resfile_input.java | resfile_input.py | resfile_input.cs
Retrieving the search parameters from the search results | resfile_params.pl | resfile_params.cpp | resfile_params.java | resfile_params.py | resfile_params.cs
Retrieving peptide or protein summary information from the search results | resfile_summary.pl | resfile_summary.cpp | resfile_summary.java | resfile_summary.py | resfile_summary.cs
To repeat a search | repeat_search.pl | repeat_search.cpp | repeat_search.java | repeat_search.py | repeat_search.cs
To create a Mascot Generic File (mgf) from search results | create_mgf.pl | - | - | create_mgf.py | create_mgf.cs
To display peptide level information (cgi) | - | peptide_list.cpp | - | - | -
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


UML Class Diagram
[Mascot results file module]

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Issues with backward compatibility for results files
[Mascot results file module]

Matrix Science endeavours not to make changes to the Mascot search results files that would 'break' 3rd party applications. In general, any application that uses Mascot Parser will be safe when a new version of Mascot Server is released -- even if that software is not re-built (or re-linked) with the latest version of Mascot Parser. There are some exceptions to this, and these are listed below.

Increase in the number of variable modifications

From Mascot version 1.5 to 2.1, the limit on the number of variable modifications is 9. The variable modification string returned by ms_peptide::getVarModsStr() is of the form 0110030. One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2, etc., in the masses section of the results file. An 'X' is used to indicate an error tolerant modification that can be retrieved using ms_peptidesummary::getErrTolModName.

Mascot Server 2.2 and later still limit the number of variable modifications specified in the search form to 9 per search. However, 'exclusive' modifications are supported in quantitation methods, and these are reported using the same variable modifications string. It is possible that the number of modifications could then exceed 9. To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32. In Mascot Parser 2.2 and later, the method ms_mascotresults::getReadableVarMods() will return the correct modifications for values A to W. Earlier versions of Parser ignore any non numeric value apart from X. Any third party client software that parses the string returned from ms_peptide::getVarModsStr() will need to be modified to support A to W, and convert these to the numbers 10 to 32.

Separation between form-level and query-level modifications

Mascot 2.2 introduced query-level modifications, which are modifications speficied locally in an MS/MS peak list in a Mascot Generic Format (MGF) input file, using the IT_MODS parameter. Mascot 2.2, 2.3 and 2.4 combine search form-level modifications, exclusive modifications and all query-level modifications into a master list before the search starts. The master modification list is saved in the search parameters section, as above, available via ms_searchparams. The modifications string of a peptide match, getVarModsStr(), always refers to the indices of the master list.

Mascot 2.5 and later treat form-level and query-level modifications separately. The master list contains only form-level modifications and no query-level modifications. If query X has a local IT_MODS parameter and its rank Y match uses at least one local modification, Mascot writes a new parameter to the results file, called qX_pY_local_mods. The variable modifications string getVarModsStr() continues to refer to the master modification list, while the new query-level modifications string is available as getLocalModsStr(). The latter is a string of 1-based indices to the IT_MODS parameter of the corresponding input query. The Unimod section lists the equivalent of the master list of modifications, including all query-level modifications used in the search.

Most Parser functionality remains unaffected by the changes. For example, getReadableVarMods() takes the local modifications string automatically into account, and the duplicatedness status of peptide matches within a protein hit takes both form-level and query-level modifications into account when comparing peptide modifications. This means that for most common tasks, or if you do not use query-level modifications, you do not need to change anything in your program. In particular, Parser 2.5 and later fully support Mascot 2.4 and earlier results files.

If you do use query-level modifications, note that Parser 2.4 and earlier are not aware of the new qX_pY_local_mods strings in Mascot 2.5 and later results files. You can extract the raw values using getSectionValueStr(), but Parser 2.4 and earlier will not parse the values or include the query-level mods internally in getReadableVarMods() or elsewhere.

See Accessing query-level modification information for more details on query-level modifications in Mascot 2.5 and later results files.

Monolink deltas in crosslinked searches

Mascot 2.7 introduced intact crosslinks and cleavable crosslinks. Both types can produce monolinks, which are variable modifications. However, the monolinks of a linker usually have deltas different from the intact linker mass. Monolinks share the same variable mod number in the variable mods string and are differentiated by the monolink number in ms_peptide::getMonoLinkStr().

Parser 2.6 and earlier are not aware of the monolink string and will report incorrect deltas for monolinks.

Parser 2.7 and later automatically inspect the monolink string where relevant, for example in getReadableVarMods(). If you're processing the variable mods string manually, you must use the new API described in Crosslinked search results.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Error Handling
[Mascot results file module]

Error handling in ms_mascotresfile

All errors from all classes in the Mascot results file module are accumulated into a list in the ms_mascotresfile object, even if the error occurs in a related object. The errors are accumulated in the ms_mascotresfile object that was given as the parameter to the other object constructor. For example, when you create a new ms_peptidesummary object, errors are accessed through the ms_mascotresfile object, not the ms_peptidesummary object:

C++
    ms_mascotresfile *resfile = new ms_mascotresfile(filename);

    if (!resfile->isValid()) {
        /* Handle errors... */
    }

    resfile->clearAllErrors();

    ms_peptidesummary *pepsum = new ms_peptidesummary(resfile);

    if (!resfile->isValid()) { // resfile now contains errors from ms_peptidesummary
        /* Handle errors... */
    }

Perl
    my $resfile = new msparser::ms_mascotresfile($filename);

    if (not $resfile->isValid()) {
        # Handle errors...
    }

    $resfile->clearAllErrors();

    my $pepsum = new msparser::ms_peptidesummary($resfile);

    if (not $resfile->isValid()) { # resfile now contains errors from ms_peptidesummary
        /* Handle errors... */
    }

Java and C#
    ms_mascotresfile resfile = new ms_mascotresfile(filename);

    if (!resfile.isValid()) {
        /* Handle errors... */
    }

    resfile.clearAllErrors();

    ms_peptidesummary pepsum = new ms_peptidesummary(resfile);

    if (!resfile.isValid()) { // resfile now contains errors from ms_peptidesummary
        /* Handle errors... */
    }

Python
    resfile = msparser.ms_mascotresfile(filename)

    if not resfile.isValid():
        # Handle errors...

    resfile.clearAllErrors()

    pepsum = ms_peptidesummary(resfile)

    if not resfile.isValid(): # resfile now contains errors from ms_peptidesummary
        # Handle errors...

The list of errors is only ever cleared by calling clearAllErrors().

To determine the number of errors, call getNumberOfErrors(). To access a particular error by its number, call getErrorNumber(i), where i is a number between 1 and getNumberOfErrors(), inclusive. To get the error string for the same error, use getErrorString(i).

Multiple similar errors are grouped together. For, example, suppose that creating a peptide summary gave 3000 errors for null accession strings (and no other errors). getNumberOfErrors() then would return 2, but the second error would have the following error message:

Null accession number found for query x, rank y in peptides section. (Error repeated 2999 times)

Errors are classified as 'fatal' or 'warning'. The function isValid() will return true if there are just warnings, and false if there are any fatal errors.

Example code:

C++ | resfile_error.cpp
Perl | resfile_error.pl
Java | resfile_error.java
Python | resfile_error.py
C# | resfile_error.cs

For a list of error return values, see ms_mascotresfile::err.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Peptide mass fingerprint mixtures
[Mascot results file module]

With Mascot Server 1.9 and later, all peptide mass fingerprint searches test for the possibility that the sample is a mixture of proteins. Mascot will automatically detect and report statistically significant protein mixtures of up to six components. The results are saved in a 'mixtures' section of the results file. The 'summary' section of the results file is unchanged.

To ignore PMF mixtures, set the flag ms_mascotresults::MSRES_IGNORE_PMF_MIXTURE when creating the ms_proteinsummary object.

ms_proteinsummary::getHit() can return a protein that is a 'mixture'. However, this is not a 'real' protein but just a container for a number of component proteins. To determine if the protein is a 'mixture', use the method ms_protein::isPMFMixture().

This 'mixture protein' has a list of peptides and in general can be treated as a normal protein object, with the difference that its accession will be "Mixture k", where k is an integer. Also, the description line returned from ms_mascotresults::getProteinDescription() will be of the form:

  Mixture from proteins:"gi|1234","gi|5432","gi|9999"

ms_mascotresults::getProteinMass() will always be zero for 'mixtures'.

To find out how many component proteins a 'mixture' originates from, use ms_protein::getNumComponents(). You can then access each component protein with ms_protein::getComponent().

To find the number of peptides that matched, use ms_protein::getNumDisplayPeptides(). Only peptides that matched in two or more component proteins are counted in the number. To display a 'colour coded' report, the component ID for the getComponent() call is also available for each peptide that matched with ms_protein::getProteinComponentID().

For the concise protein summary report, a single protein is never collapsed into a mixture and a mixture is never collapsed into a single protein.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Grouping proteins together
[Mascot results file module]

Why group proteins together?

It is generally not useful to have a results page with a list of many (possibly hundreds) of highly homologous proteins. In most cases, it is far better to group these proteins together. The goal of grouping is to answer the following question: "which minimal set of proteins completely accounts for the peptides found in the experimental data?".

There are two separate algorithms for grouping proteins in Mascot Parser. The first option MSRES_GROUP_PROTEINS uses Occam's Razor and was introduced in the first version of Mascot Parser. The second option MSRES_CLUSTER_PROTEINS is more inclusive and is the algorithm used for the MS-MS search results in Mascot Server 2.3.

Using MSRES_GROUP_PROTEINS

The flag MSRES_GROUP_PROTEINS can be used with both ms_peptidesummary and ms_proteinsummary objects.

In this grouping mode, Occam's Razor is ruthlessly applied to the results, so that proteins which span the same set or a subset of peptides can be collapsed into a single entry in the hit list.

There is a subtle difference between the test used to group proteins for a peptide mass fingerprint search and for other searches. If there are any MS-MS data, then proteins are grouped together if the peptide sequences for each match are the same. If there is no MS-MS data, proteins are grouped together when the input masses of peptide matches are the same.

Using MSRES_CLUSTER_PROTEINS

The flag MSRES_CLUSTER_PROTEINS is only supported with ms_peptidesummary.

One of the disadvantages of the MSRES_GROUP_PROTEINS algorithm is that a protein may be excluded from being a subset or sameset protein because it has just one 'new' peptide that prevents it from being grouped. The MSRES_CLUSTER_PROTEINS mode groups proteins by considering shared peptide matches above homology threshold. Each protein hit consists of a 'family' of proteins, where each protein in the family shares at least one peptide match above homology threshold with another family member.

Proteins in the hit can be accessed in the following way:

 | Protein | Description | getGrouping returns | getSimilarProteins returns
1.1 | A | This is the 'lead' or 'master' protein for hit 1 [returned by getHit(1)] | GROUP_NO | nothing
 | B | A protein with the same peptide matches as Protein A [returned by getNextSimilarProteinOf("A", 1, 1)] | GROUP_COMPLETE | Protein A
 | C | A protein that contains a subset of the peptides in Protein A and Protein I [returned by getNextSubsetProteinOf("A", 1, 1)] | GROUP_SUBSET | Protein A Protein I
 | D | A protein that contains the same set of the peptides in Protein C [returned by getNextSimilarProteinOf("C", 1, 1)] | GROUP_COMPLETE | Protein C
1.2 | E | This is another family member of the first hit [returned by getNextFamilyProtein(1,1)] | GROUP_FAMILY | nothing
 | F | A protein with the same peptide matches as Protein E [returned by getNextSimilarProteinOf("E", 1, 1)] | GROUP_COMPLETE | Protein E
 | G | A protein that contains a subset of the peptides in Protein E [returned by getNextSubsetProteinOf("E", 1, 1)] | GROUP_SUBSET | Protein E
 | H | A protein that contains the same set of the peptides in Protein G [returned by getNextSimilarProteinOf("G", 1, 1)] | GROUP_COMPLETE | Protein G
1.3 | I | This is another family member of the first hit [returned by getNextFamilyProtein(1,2)] | GROUP_FAMILY | nothing
 | J | A protein with the same peptide matches as Protein I [returned by getNextSimilarProteinOf("I", 1, 1)] | GROUP_COMPLETE | Protein I
 | K | A protein that contains a subset of the peptides in Protein I [returned by getNextSubsetProteinOf("I", 1, 1)] | GROUP_SUBSET | Protein I
 | C | A protein that contains a subset of the peptides in Protein A and protein I [returned by getNextSubsetProteinOf("I", 1, 2)] | GROUP_SUBSET | Protein A Protein I
 | L | A protein that contains the same set of the peptides in Protein K [returned by getNextSimilarProteinOf("K", 1, 1)] | GROUP_COMPLETE | Protein I
2.1 | X | This is the 'lead' or 'master' protein for hit 2 [returned by getHit(2)] | GROUP_NO | nothing

Note that Protein C is a subset of Protein A and Protein I. An alternative way of showing subsets is to have a single list at the end of the family. For this case, it is probably easier to call getNextSubsetProtein(hit, id, searchWholeFamily) with searchWholeFamily == true, which returns each subset protein in the family, one at a time. See also getSimilarProteins(), which returns the list of proteins that a subset protein belongs to (in some sense the 'superset' proteins of the subset protein).

For family grouping, it is important to call getNextSimilarProteinOf() and getNextSubsetProteinOf() rather than getNextSimilarProtein() and getNextSubsetProtein(). Otherwise the list of similar proteins will always be for the 'lead' protein.

minPepLenInPepSummary

In peptide summary only (using either method of grouping), any peptides shorter than minPepLenInPepSummary will be ignored when grouping proteins together. You need to specify this value when creating an ms_peptidesummary object. The default value may be obtained from ms_mascotoptions::getMinPepLenInPepSummary().

Handling 'subset' proteins

Assume that

  • protein 'A' has three peptide matches (to queries 1, 2 and 3); and
  • protein 'B' has only two peptide matches (to queries 1 and 3).

We say that protein 'B' matches a subset of peptides. Mascot Parser allows you to treat these subset matches in three separate ways:

  1. Display the proteins that matched a subset of the peptides 'under' the main protein. For the standard Mascot Server reports, this is implemented by specifying "ShowSubSets 1" in the Options section of mascot.dat. In Mascot Parser, specify MSRES_SHOW_SUBSETS when creating the ms_peptidesummary or ms_proteinsummary object.

  2. Discard the proteins that matched a subset of the peptides 'under' the main protein. For the standard Mascot Server reports, this is implemented by specifying "ShowSubSets 0" in the Options section of mascot.dat. In Mascot Parser, do not specify MSRES_SHOW_SUBSETS when creating the ms_peptidesummary or ms_proteinsummary object.

  3. Treat proteins that matched a subset of the peptides as separate, unique proteins with no relation to the main protein. In Mascot Parser, specify MSRES_SUBSETS_DIFF_PROT when creating the ms_peptidesummary or ms_proteinsummary object.

If you have a primary hit with (say) 100 peptide matches, you may be very interested in subset proteins with 99 matches, but not in ones that have 1 or 2 matches; these just clutter up the report if you use MSRES_SHOW_SUBSETS. On the other hand, if you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match. The function ms_mascotresults::setSubsetsThreshold() was introduced in Mascot 2.2 to facilitate including or removing these less interesting subset proteins.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Unassigned peptides list
[Mascot results file module]

Unassigned list in peptide summary reports

In standard Mascot Server peptide summary reports, there is an "unassigned list" at the bottom of the page - for example:

Unassigned queries: (no details means no match)
 Query  Observed Mr(expt) Mr(calc)   Delta  Miss Score  Rank   Peptide
  113   893.28   1784.54   1784.92   -0.37    0    65     1    VGAVAGNDWLIWDITR
  107   882.21   1762.40   1762.79   -0.38    0    62     1    LISWYDNEFGYSNR
  67    691.20   1380.39   1380.64   -0.24    0    61     1    ALEESNYELEGK
  70    695.73   1389.45   1389.67   -0.21    0    60     1    QSLEASLAETEGR

This is a list of MS-MS spectra that have had matches to peptides, but are not included in the main report because the proteins which they are found in have too low a score. If the list of proteins in the main report was not cut off, i.e. if all proteins were displayed, then there would be no unassigned list.

For example, if a query had the following matches, then it would not be in the unassigned list.

Rank | Pretty Rank | Score | Peptide | Protein
1 | 1 | 78 | ABCDEFG |
2 | 1 | 78 | ABCDEGF | gi|123456
3 | 1 | 78 | BACDEFG |
4 | 4 | 65 | ASDADSD |
5 | 4 | 65 | SDFSGSD |
6 | 6 | 12 | DFGHDFG |
7 | 7 | 8 | SSDFDFD |
8 | 8 | 7 | RTYRYRY |
9 | 9 | 4 | RTYRYRY |
10 | 10 | 2 | TYUTUTU |

Although there was no protein match the rank 1 peptide, the rank 2 peptide had the same score, so this is in effect treated as the top match for the query. The query will then be included under gi|123456.

Unassigned list in protein summary reports

An unassigned list can be created for a protein summary. This list is just the list of peptides that didn't get a match anywhere in the top 50 hits.

Creating the unassigned list

After creating an ms_peptidesummary object, the method createUnassignedList() needs to be called. The parameter is one of:

ms_mascotresults::QUERY

Sort the unassigned list by ascending query number. This is the same as ascending relative mass order.

ms_mascotresults::SCORE

Sort the unassigned list by descending score.

ms_mascotresults::INTENSITY

Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (pkl files, some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values.

Note that for a very large MS-MS file, this option can take some time to process unless there are qintensity values in the results file.

Getting the entries for the unassigned list

Once the unassigned list has been created, use getNumberOfUnassigned() to determine the number of items in the list. You can then retrieve peptide at index i with getUnassigned(i).

See also getUnassignedIsBold() and getUnassignedShowCheckbox().

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Treatment of duplicate peptides
[Mascot results file module]

Peptide match duplicates

Warning -- this is a complex issue that only applies to peptide summary reports, and only needs to be understood by advanced users. The default flag MSRES_DUPE_DEFAULT is suitable for most use cases.

Duplicate peptides arise from data

In a typical results file derived from an LC-MS-MS data set, the same peptide will appear multiple times. In a perfect system, identical peptides would rarely be seen. Ideally, peptides would be separated perfectly by chromatography, and even if that failed, peak detection software would combine similar peptides before the data were submitted to Mascot Server.

Back to reality... The standard Mascot Server reports display most 'duplicate' peptides, but the scores are shown with brackets (parentheses) to indicate that these peptides don't affect the total protein score. Mascot Parser has full flexibility to customise the treatment of such 'duplicate' peptides.

How Mascot Parser detects duplicate peptides

In peptide summary reports, each candidate protein contains one or more peptides. Some of these peptides will be duplicates of others, and these generally do not add to the confidence of the protein match, and therefore can optionally be ignored.

There are four possible situations that will cause Mascot Parser to mark a peptide as a duplicate:

  1. Same query number. For example, if a protein contains the two peptides ABCDIK and BACIDK, and query 3 matches both of these (possibly with different scores), then the two peptides are duplicates of each other. Alternatively, the same query could match the same peptide twice but with different modifications.

  2. Same peptide sequence. The peptide matches may or may not be from the same query. Also, they may or may not have the same start and end position in case there are repeated peptides in the protein.

    If the match is a crosslinked match, it can only be marked as a duplicate of another crosslinked match whose alpha and beta sequences are the same and alpha and beta peptides are in the same protein (an intralinked match).

  3. Same modifications. If the peptide sequences are different, then (to reduce permutations) the modifications are defined as being different.

  4. Same start and end positions in the protein sequence. Normally caused by repeats in the sequence. If the peptide sequences are different, then the start and end positions are defined as being different. (This is necessary because for a Unigene entry, the start and end positions could be the same for different peptides. Each Unigene entry is made up from different EST fragments.)

    If the match is a crosslinked match, and alpha and beta are in different proteins (an interlinked match), then their positions are always treated as different.

There are 4 rules to cover the cases above, which generates 16 possibilities. However, because of the definitions described above, only 9 are possible combinations:

Query | Sequence | Modifications | Position | Rule_ID
same | same | same | different | A
same | same | different | same | B
same | same | different | different | C
same | different | different | different | D
different | same | same | same | E
different | same | same | different | F
different | same | different | same | G
different | same | different | different | H
different | different | different | different | I

Use of the 'Rule ID' column is described below.

When the rules are applied

There are two flags that control how these rules are applied to the ms_mascotresults object:

MSRES_DUPE_REMOVE_[RULE_ID]

Each protein initially contains all possible matching peptides. If this flag is given to the constructor, duplicate peptides are then removed according to the specified rules.

A removed peptide will never be considered to be part of that protein -- so, for example, it won't be included in the score. In rare cases, this will also affect how proteins are grouped together. (See Grouping proteins together). If no duplicates are ever to be removed, specify MSRES_DUPE_REMOVE_NONE.

Crosslinked matches are subject to duplicate detection. Intralinked matches (alpha and beta in same protein) are removed according to the specified MSRES_DUPE_REMOVE_[RULE_ID]. Interlinked matches (alpha and beta in different proteins) may be flagged as duplicates but cannot be removed using any of the existing rule IDs. If you can think of a use case for suppressing or removing duplicate interlinked matches, please contact us at support@matrixscience.com!

MSRES_DUPE_INCL_IN_SCORE_[RULE_ID]

When calculating the protein score, it may be desireable to include some duplicates in the score. If this flag is given to the constructor, duplicates matching the rule will be included in protein scoring. These flags apply to standard Mascot protein scoring and not to MudPIT scoring.

For the standard Mascot Server reports, no duplicates are included when calculating the protein score. (And duplicates are shown in brackets.) Any peptides removed by MSRES_DUPE_REMOVE_[RULE_ID] have already been removed before protein scoring is performed, so it is pointless to try and override, for example, MSRES_DUPE_REMOVE_D by using MSRES_DUPE_INCL_IN_SCORE_D.

When displaying or storing a list of peptides, it may be desirable to inhibit the display of some duplicate peptides. ms_protein::getPeptideDuplicate() can be used to that end. Note that peptides that have been removed due the MSRES_DUPE_REMOVE_[RULE_ID] setting need never be specifically inhibited by client code, since they will not be present anyway.

ms_peptidesummary::getProteinsWithThisPepMatch() will return a list of all proteins that contained this peptide. The list only includes peptides that were not discarded due to the MSRES_DUPE_REMOVE_[RULE_ID] setting. There is currently no other override for this function.

Rules for standard Mascot reports

For Mascot 1.9 and Mascot 2.0, the default for MSRES_DUPE_REMOVE_[RULE_ID] is MSRES_DUPE_REMOVE_A | MSRES_DUPE_REMOVE_D. This means that peptides with

  • same query, same sequence, same mods, different position

or

  • same query, different sequence, different mods, different position

are not included in any proteins.

No duplicates are ever added into the score, so MSRES_DUPE_INCL_IN_SCORE_NONE needs to be specified. MSRES_DUPE_DEFAULT is defined as MSRES_DUPE_REMOVE_A | MSRES_DUPE_REMOVE_D | MSRES_DUPE_INCL_IN_SCORE_NONE.

Compatibility with previous versions

This functionality was introduced in Mascot Parser 1.2. No changes are required to client code that was used before Mascot Parser 1.02:

  • If no MSRES_DUPE_REMOVE_[RULE_ID] flags are supplied, then the default MSRES_DUPE_REMOVE_A | MSRES_DUPE_REMOVE_D is assumed. (In the unlikely event that it is required that no duplicates are ever to be removed, then MSRES_DUPE_REMOVE_NONE must be specified.)

  • The default is to never add duplicates to the protein score, so MSRES_DUPE_INCL_IN_SCORE_NONE needs to be specified. However, since this is defined as '0', it does not need to be passed to the ms_peptidesummary constructor.

Earlier client code would typically check the following before displaying peptides or adding them to a database:

    prot->getPeptideDuplicate(i) != ms_protein::DUPE_DuplicateSameQuery

This test is still required since generally peptides with the same query, same sequence and different modifications are not shown in the report, but would be seen in the yellow popup.

Chimeric duplicates

Warning -- this is a complex issue that only applies to peptide summary reports, and only needs to be understood by advanced users. It is best to always specify MSPEPSUM_REMOVE_CHIMERIC_DUPES or always use ms_mascotresfile::get_ms_mascotresults_params().

Mascot 2.5 added support for chimeric spectra. A chimeric spectrum contains MS/MS data from multiple precursors. Mascot divides each input spectrum with multiple precursor masses into a set of subsidiary queries, linked by the source index of the original spectrum. Each subsidiary query is matched separately, so that the number of output queries is the total number of precursor masses in the input file.

The subsidiary queries in each set can have duplicate matches, called chimeric duplicates. This is easiest to explain by example. Suppose we have a chimeric spectrum with two precursors, forming queries 1 and 2:

Query 1
Rank | Sequence | Delta |
1 | TVAGQDAVIVLLGTR | 0.002411 |
2 | ISMPDIDLNLTGPK | -0.916199 | (dupe)
3 | LLSENADLKKQVR | -0.992782 | (dupe)
4 | FLTGPLNLNDPDAK | -1.908081 | (dupe)
5 | AEAGLQDGISGPATAR | -0.883652 | (dupe)

Query 2
Rank | Sequence | Delta |
1 | TVAGQDAVIVLLGTR | 0.921411 | (dupe)
2 | ISMPDIDLNLTGPK | 0.002801 |
3 | LLSENADLKKQVR | -0.073782 |
4 | FLTGPLNLNDPDAK | -0.989081 |
5 | AEAGLQDGISGPATAR | 0.035348 |

The two queries originate from the same chimeric spectrum and have nearly the same precursor masses. (The precursor mass tolerance is quite wide in this example.) As a result, both queries match the same peptide sequences. However, all but the rank 1 match in the first query have a much larger mass delta than in query 2. This means the rank 2-5 matches in query 1 are all chimeric duplicates. Conversely, the rank 1 match in query 2 is a duplicate.

Parser removes chimeric duplicates from consideration if you open the results file as a peptide summary (ms_peptidesummary) and use the flag MSPEPSUM_REMOVE_CHIMERIC_DUPES. In the above case, you would only see one match in query 1 and four in query 2. Ranks are renumbered accordingly (e.g. query 2 rank 2 becomes query 2 rank 1 when the chimeric duplicate is removed). Chimeric duplicate removal is done at query level before protein grouping and before considering peptide match duplicates within protein hits.

Chimeric duplicates are removed by default if you use ms_mascotresfile::get_ms_mascotresults_params() to construct the default flags to ms_peptidesummary. Otherwise you need to specify the flag yourself when creating the peptide summary object.

Note that the flag has no effect if the results file was created by Mascot 2.4 or earlier, or if the results file has no chimeric spectra.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Detecting ambiguous peptide matches
[Mascot results file module]

Matches with same score are ambiguous

Mascot may give the same score to two or more matches in the same query. A typical case is an I/L difference in peptide sequences, say CIPALDSLTPANEDQK and CIPALDSITPANEDQK. Because leucine (L) and isoleucine (I) have exactly the same molecular weight, the calculated fragments for these two peptides are also exactly the same. The two matches get the same score when matched against the same spectrum.

Parser signals this ambiguity by pretty rank, accessible with ms_peptide::getPrettyRank(). Two peptides with the same score have the same pretty rank. For example, if CIPALDSLTPANEDQK and CIPALDSITPANEDQK are the rank 1 and rank 2 matches, both have pretty rank 1.

Note that score-level ambiguity has little to do with ms_peptide::getAmbiguityString(), which encodes residue substitutions based on ambiguous residues in protein sequences.

Ambiguity group IDs in integrated spectral library searches

Mascot 2.6 and later support Spectral libraries. Integrated spectral library searches may have ambiguity of a different kind. Within a query, two peptide matches are ambiguous if they have the same pretty rank (as above) or they have the same sequence but come from a different search engine. Ambiguous sequences are automatically taken into account during protein inference.

Consider the following matches to a query:

Rank | Sequence | Score | Source | Pretty rank | Ambiguity group
1 | CIPALDSLTPANEDQK | 524 | SL | 1 | 1
2 | CIPALDSLTPANEDQK | 399 | SL | 2 | 2
3 | CIPALDSLTPANEDQK | 51 | AA | 3 | 1
4 | CIPALDSITPANEDQK | 51 | AA | 3 | 1
5 | CIPALDSLTPANEDQK | 310 | SL | 4 | 3
6 | SLNNQIETLLTPEGSR | 250 | SL | 5 | 4

The rank 1 match starts ambiguity group numbering, exactly the same as in the pretty rank case.

The rank 2 match is in a different ambiguity group than rank 1. Although the sequences are the same, the matches have the same search engine (both from spectral library) but different score (they probably had different library spectra).

Rank 3 and 4 matches have the same pretty rank; they are the typical I/L case. Because the rank 3 match has the same sequence and different search engine than the rank 1 match, ranks 1, 3 and 4 belong to the same ambiguity group.

The rank 5 match is again in an ambiguity group of its own for the same reason as the rank 2 match.

Finally, the rank 6 match has a different sequence and different score from the rest, so it also is in its own ambiguity group.

Ambiguity grouping for a query is available with ms_peptidesummary::getAmbiguityRanks().

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Error tolerant searches
[Mascot results file module]

There are two types of error tolerant search and these are described at the Matrix Science website. In Mascot Parser documentation, these are referred to as the Error tolerant search and the Integrated error tolerant search. This section assumes familiarity with both types.

Original error tolerant search

In Mascot Server 1.8 and later, an error tolerant search may be run as a repeat search. In this case, one or more ACCESSIONs will have been specified, and the results file will just contain the error tolerant search results. The accessions in the search may be retrieved using ms_searchparams::getACCESSION().

In the peptide summary report, peptide matches are ignored if

  • the ions score is lower than the top match for this query in the original search; OR
  • the ions score is below the significance level.

Significance level is taken from the parameter ignoreIonsScoreBelow given to the ms_peptidesummary constructor. If this value is zero, then a default threshold of 1 in 20 is used.

The filename for the 'parent' non-error-tolerant search is saved in the parameters section as _errortolerantsearchparent, and can be accessed with ms_searchparams::getErrTolParentFilename(). It is not possible to use getINTERMEDIATE() because an error tolerant search can be performed as a repeat search from another error tolerant search. If MSRES_SHOW_ALL_FROM_ERR_TOL is not specified, and the file specified by _errortolerantsearchparent cannot be found, then the error ERR_NO_ERR_TOL_PARENT will be set, and the results will be shown as if MSRES_SHOW_ALL_FROM_ERR_TOL had been specified.

Always use standard protein grouping (MSRES_GROUP_PROTEINS) with manual error tolerant searches. If you enable protein clustering, the parent file is ignored and the results reported may be incorrect.

Integrated error tolerant search

In Mascot Server 2.2 and later, a single search can be performed which contains both the standard search results and the error tolerant search results. This is known as the integrated error tolerant search.

For an integrated error tolerant search, if MSRES_ERR_TOL is specified, then the results will just be taken from the error tolerant sections of the results file, and these results are handled in exactly the same way as for the Original error tolerant search. If MSRES_INTEGRATED_ERR_TOL is specifed, then the results will contain matches from both the standard and error tolerant sections. If neither of these flags are specified, then the results will just be derived from the standard peptides section.

When MSRES_INTEGRATED_ERR_TOL is specified, the results are first combined at the query level, so there will be up to 20 matches for each query. The methods ms_peptide::getRank() and ms_protein::getPeptideP() will therefore return a number in the range 1 to 20. This rank value can be used for any ms_peptidesummary method that requires a 'p' (rank) value. Use the method ms_peptide::getIsFromErrorTolerant() to find out if the results are from the standard results section or the error tolerant section.

Score thresholds and score filtering (Mascot Server 2.8 and later)

Error tolerant searches from Mascot Server 2.8 and later are subject to two kinds of filtering. If a query has a significant first pass match (score exceeds threshold), then ET matches in the query are suppressed. This is equivalent to only searching unassigned/unmatched queries in the error tolerant pass.

Secondly, ET matches are suppressed if they score lower than the rank 1 first pass match. The flag MSRES_SHOW_ALL_FROM_ERR_TOL can be used to override this behaviour.

First and second pass results may have different significance thresholds. If the search is a target-decoy search, and the constructor parameter TargetFDR is defined, Parser chooses independent first and second pass significance thresholds that yield the target FDR. If TargetFDR is not defined, or the search is not a target-decoy search, Parser uses the same significance threshold for both passes (by default, 0.05).

The score threshold for queries searched in the error tolerant pass is derived from the combined first and second pass identity threshold (number of trials, or qmatch). The expect value of an ET match is calculated in the same way as first pass matches. See ms_mascotresults::getPeptideExpectationValue().

Protein score is derived from the highest scoring non-error-tolerant match for each query, and this value can be found by calling ms_protein::getPeptideIonsScore().

Score thresholds and score filtering (Mascot Server 2.7 and earlier)

If the error tolerant search is from Mascot Server 2.7 or earlier, different rules apply.

An error tolerant match will be discarded if it has a score below the average identity threshold (getAvePeptideIdentityThreshold()) or below the maximum standard result for the query. This means that, in practice, it will be rare to get 20 matches for a particular query -- the requirement would be for all 10 error tolerant matches to be the top 10 scores, and all would need to be above the average peptide identity threshold. To show all matches, including those that would be discarded by default, the flag MSRES_SHOW_ALL_FROM_ERR_TOL needs to be used when constructing the ms_peptidesummary object.

The average identity threshold is calculated using the minProbability value passed to the ms_peptidesummary constructor. If a value of <= 0 or >= 0.1 is passed to the constructor, then a default of 1 in 20 is assumed for calculating the threshold. The flag MSRES_MAXHITS_OVERRIDES_MINPROB should normally be used so that the maxHitsToReport value is not overridden by the minProbability value.

Statistical significance of error tolerant matches is not defined, so ms_mascotresults::getPeptideExpectationValue() returns -1.

Useful functions for both type of search

To determine if a search is an error tolerant search, use ms_mascotresfile::isErrorTolerant().

The following functions can be used from both peptide and protein summary to get information about error tolerant modifications or residue substitutions.

  • ms_mascotresults::getErrTolModName()
  • ms_mascotresults::getErrTolModDelta()
  • ms_mascotresults::getErrTolModNeutralLoss()

See also ms_mascotresfile::getNumEtSeqsSearched().

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Crosslinked search results
[Mascot results file module]

Crosslinked search results

Mascot 2.7 and later can search for intact crosslinked peptides as well as peptides with cleavable crosslinks. A typical example of intact crosslinking is disuccinimidyl suberate (DSS), which chemically bonds lysines in two different peptides. An MS-cleavable linker like disuccinimidyl sulfoxide (DSSO) also links lysines but mostly cleaves during CID.

Intact crosslinked peptide matches consist of the alpha peptide sequence, the beta peptide sequence and the linker. The intact link can occasionally cleave during MS/MS, which leaves behind a linker fragment called the monolink. Monolinks are modelled as ordinary variable modifications.

Conversely, cleavable crosslinks are always modelled as monolinks. The alpha and beta peptides hold different ends of the linker fragment, and there is one peptide-spectrum match for alpha and another for beta. However, if cleaving efficiency is less than 100%, some of the links may survive MS or MS/MS intact, so the search results may still contain intact crosslinked peptide matches. The rules are defined in the crosslinking method.

A linker is often chemically quenched during sample processing when one end reacts with a non-peptide molecule. The distinction between quenched linkers and linker fragments is made in the neutral loss elements of the linker definition. Mascot treats both types simply as monolinks.

By default, Parser opens crosslinked search results in a backwards-compatible mode, where intact crosslinked matches are invisible. Adding support in client code is more involved than just setting a constructor flag. Many of the methods either take a new argument in Parser 2.7, or they interpret existing arguments differently.

Glossary of terminology and concepts

Term | Synonyms | Definition
linear peptide |  | a single peptide sequence without branches or cycles
(intact) crosslink | chemical crosslink; non-cleavable link | a link between two peptides that survives MS/MS (e.g. DSS/BS3, DST, ...)
cleavable crosslink |  | a link between two peptides that cleaves during CID or is cleaved by other means before MS/MS
monolink | type 0 modification; deadend link | a linear peptide with a linker fragment whose other end is unattached
looplinked peptide | type 1 modification; intrapeptide link; intramolecular link | a single peptide where two sites are linked, forming a loop
crosslinked peptide | type 2 modification; interpeptide link; intermolecular link | two linear peptides joined by the intact crosslink
alpha peptide, beta peptide | alpha chain, beta chain | the two linear peptides part of a crosslinked unit; alpha is the heavier or longer one
homo-crosslinked peptide |  | type 2 link where alpha and beta peptides have the same sequence
hetero-crosslinked peptide |  | type 2 link where alpha and beta peptides have different sequences
protein intralink |  | a protein where two non-overlapping peptides have an intact crosslink
protein interlink |  | two proteins with an intact crosslink (either homo-crosslinked or hetero-crosslinked proteins)
crosslinking method |  | a set of parameters and settings that define which types of links to search

Note that a looplinked peptide (type 1) is different from a homo-crosslinked peptide (type 2).

Note also that either or both of the alpha or beta peptide in a crosslinked pair may contain looplinks. For simplicity of terminology, a linear peptide denotes both a single peptide sequence (with or without looplinks) and the alpha or beta peptide in a crosslinked pair (with or without looplinks).

Detecting and opening crosslinked search results

To determine whether a results file might contain matches with intact crosslinks, looplinks or monolinks, use ms_mascotresfile::getCrosslinkingMethod(). If the search has a crosslinking method, some of the linear peptide matches in the 'peptides' section may contain monolinks or looplinks. There is currently no easy check to determine whether there are any matches with monolinks or looplinks, other than iterating through all peptide matches. No special constructor flags are needed for accessing linear peptide data.

To determine whether there actually are crosslinked matches, use ms_mascotresfile::anyPeptideSummaryMatches(). If the test returns true for SEC_CROSSLINK_PEPTIDES, then the results file has a non-empty section containing crosslinked matches and the file should be opened in integrated crosslink mode.

Three modes are available:

  1. Linear-only mode (no flag): The backwards-compatible default is to hide crosslinked matches.
    If the search contains only crosslinked matches, then opening the file in this mode means there are no matches available at all.
  2. Integrated crosslink mode (MSPEPSUM_CROSSLINK_INTEGRATED): Show matches from all sections of the results file.
  3. Crosslink-only mode (MSPEPSUM_CROSSLINK_ONLY): Hide linear matches (not recommended).

The helper function ms_mascotresfile::get_ms_mascotresults_params() does not set MSPEPSUM_CROSSLINK_INTEGRATED automatically. This means code written for Parser 2.6 and earlier always opens crosslinked search results in linear-only mode.

Parser 2.7 and Mascot 2.7 do not support the following search types in combination with crosslinking:

  • nucleic acid databases
  • decoy searching
  • error tolerant searching
  • Percolator
  • quantitation methods
  • spectral library searching

These restrictions may be lifted in a future release.

Opening the file in integrated mode

To open the file in integrated mode, pass the flag MSPEPSUM_CROSSLINK_INTEGRATED to the matrix_science::ms_peptidesummary constructor.

The integrated crosslink mode is similar to the integrated error tolerant mode (see Integrated error tolerant search) and the integrated spectral library mode (see Opening the file in integrated mode). A query can contain a mixture of up to 20 linear and intact crosslinked peptide matches (see ms_mascotresults::getMaxRankValue()).

The identity and homology thresholds are determined by pooling match data from both linear and crosslinked peptides. For example, the total number of trials (qmatch) is the sum of qmatch from the linear summary section and qmatch from the crosslinked summary section.

Integrated mode is the preferred mode for opening crosslinked search results.

Opening the file in crosslink-only mode

To open the file in crosslink-only mode, pass the flag MSPEPSUM_CROSSLINK_ONLY to the matrix_science::ms_peptidesummary constructor.

If the search contains only linear matches, then opening the file in this mode means there are no matches available at all. Using this mode is not recommended, because you will get misleading significance thresholds.

The crosslinking method

The crosslinking method defines the linkers used in the search as well as parameters like whether to search for protein intralinks or protein interlinks. See the Mascot help page for more detail.

Use ms_mascotresfile::getCrosslinkingMethod() or ms_peptidesummary::getCrosslinkingMethod() to access the crosslinking method object.

How crosslinked and looplinked match data are encoded

When Mascot parses the crosslinking method at the beginning of the search, it assigns a variable mod number to each linker specificity. For example, if the method defines linker specificities Xlink:DSS (Protein N-term) and Xlink:DSS (K), the first one could be varmod number 1 and the second varmod number 2. The linked sites are encoded in the variable mods string, and additionally in the linked_sites attribute.

Here is an example of a match with one intact link between alpha K4 (1:4:2) and beta K5 (2:5:2) and no variable modifications.

q9913_p1=-0.000397,11,66,16.87,1010001000200001201,0,0
q9913_p1_sequence_1=1,801.470831,NLGKVGSK,0000200000;"ALBU_HUMAN":0:453:460:1
q9913_p1_sequence_2=1,746.403463,ASSAKQR,000002000;"ALBU_HUMAN":0:215:221:1
q9913_p1_linked_sites=1:4:2,2:5:2

If a match has a monolink, the variable mod number of the linker is output in the variable mods string. The monolink string records the index of the corresponding neutral loss element in the linker definition. In the next example, the alpha peptide has a monolink at K8, and the intact link is between alpha K2 (1:2:2) and beta K5 (2:5:2). The monolink has neutral loss index 1, which (in this case) corresponds to monolink code [A]. NL index 0 (in this case) corresponds to the intact link [I]. The monolink string is only present if the peptide match has monolinks or looplinks.

q17957_p1=-0.000976,10,65,29.12,0010001011200001001,0,0
q17957_p1_sequence_1=2,1590.855163,LKCASLQKFGER,00200000200000;"ALBU_HUMAN":0:222:233:1
q17957_p1_sequence_2=1,746.403463,ASSAKQR,000002000;"ALBU_HUMAN":0:215:221:1
q17957_p1_linked_sites=1:2:2,2:5:2
q17957_p1_monolink_1=00000000100000
q17957_p1_monolink_2=000000000

If the match has a looplink, one end of the looplink is encoded exactly like a monolink. The other end can be inferred from the looplinked_sites attribute. Linear peptides may have monolinks and looplinks, as in the example below. The peptide has a looplink between K2 and K4. One end, K2, is encoded like a monolink, except its NL index corresponds to the intact link [I]. The peptide also has a normal monolink at K7.

q9022_p1=3,1599.934799,0.000313,8,HKPKATKEQLK,39,0020000200000,17.70,1000011012000002000,0,0;"ALBU_HUMAN":0:559:569:1
q9022_p1_monolink=0000000100000
q9022_p1_looplinked_sites=2:4

Finally, the most complicated case is a crosslinked peptide where the alpha and beta peptides have variable mods (like Oxidation (M)), monolinks and looplinks, and the variable mods additionally have fragment neutral losses. Matches this complicated are not commonly seen.

Parser API for accessing intact link, monolink and looplink data

ms_peptide methods for intact crosslinked peptide match

The ms_peptide class represents the peptide-spectrum match. The original API design assumes a linear peptide. Some interface changes have been made to allow fetching data specific to alpha and beta peptides without introducing a new class or a new set of methods.

Most ms_peptide methods take a new argument psmComponent of type ms_peptide::PSM. This is one of PSM_COMPLETE, PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA.

The rules for whether the parameter needs to be specified are:

  • If ms_peptide::getNumberOfLinkedPeptides() returns 0, the peptide match is linear. Leave psmComponent at its default value (PSM_COMPLETE) or omit the parameter.
  • Otherwise, set psmComponent to PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA to access the alpha or beta data, and PSM_COMPLETE to access match-level data.

In either case, the match may contain monolinks encoded as variable modifications, as well as looplinks.

In an intact crosslinked match, PSM_COMPLETE represents only the match-level data, such as match score. Where reasonable, methods may return data concatenated or summed from the alpha and beta peptides. For example, ms_peptide::getPeptideStr(true, ms_peptide::PSM_COMPLETE) returns a string where the alpha sequence is concatenated with the beta sequence. The two sequences are separated by "][", where the characters mark the alpha C-terminus and beta N-terminus, respectively. This ensures the concatenated variable mods string, primary NL string and related strings align correctly with the concatenated sequence string.

The table below summarises the return values when the match is an intact crosslinked peptide and the method depends on psmComponent. Methods that always return match-level data, like ms_peptide::getDelta() do not take a new parameter.

Method | Return value with PSM_COMPLETE | Return value with PSM_CROSSLINK_ALPHA | Return value with PSM_CROSSLINK_BETA
ms_peptide::getAmbiguityString() | "" | alpha string | beta string
ms_peptide::getAnyProteinTermination() | false, false | alpha values for isNterminus, isCterminus | beta value isNterminus, isCterminus
ms_peptide::getComponentStr() | alpha component if alpha component == beta component, otherwise "" | alpha component | beta component
ms_peptide::getLocalModsNlStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getLocalModsStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getLoopLinks() | alpha looplinks followed by beta looplinks | alpha looplinks | beta looplinks
ms_peptide::getMissedCleavages() | -1 if alpha/beta value is -1, otherwise alpha value + beta value | alpha value | beta value
ms_peptide::getMonoLinkStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getMrCalc() | alpha value + beta value + linker mass | alpha value | beta value
ms_peptide::getPeptideLength() | alpha length + length("][") + beta length | alpha length | beta length
ms_peptide::getPeptideStr() | alpha string + "][" + beta string | alpha string | beta string
ms_peptide::getPrimaryNlStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getSummedModsNlStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getSummedModsStr() | alpha string + beta string | alpha string | beta string
ms_peptide::getVarModsStr() | alpha string + beta string | alpha string | beta string

ms_peptide methods for linear peptide match

The table below summarises the return values when the match is a linear peptide and the method depends on psmComponent. The argument is ignored in all cases.

Method | Return value with PSM_COMPLETE, PSM_CROSSLINK_ALPHA, PSM_CROSSLINK_BETA
ms_peptide::getAmbiguityString() | ambiguity string
ms_peptide::getAnyProteinTermination() | isNterminus, isCterminus
ms_peptide::getComponentStr() | peptide component
ms_peptide::getLocalModsNlStr() | local mods NL string
ms_peptide::getLocalModsStr() | local mods string
ms_peptide::getLoopLinks() | looplinks
ms_peptide::getMissedCleavages() | missed cleavages
ms_peptide::getMonoLinkStr() | monolink string
ms_peptide::getMrCalc() | MrCalc
ms_peptide::getPeptideLength() | peptide sequence length
ms_peptide::getPeptideStr() | peptide sequence
ms_peptide::getPrimaryNlStr() | primary NL string
ms_peptide::getSummedModsNlStr() | summed mods NL string
ms_peptide::getSummedModsStr() | summed mods string
ms_peptide::getVarModsStr() | variable mods string

Procedure for differentiating between intact links, looplinks and monolinks

For backwards compatibility, the delta returned by ms_searchparams::getVarModsDelta() is the mass of the intact link. If you open crosslinked search results in Parser 2.6 or earlier, which are unaware of the new attributes, it will appear as if monolinks and looplinks all have the same delta. This is correct for looplinks but not for monolinks.

Determining the type of the variable mod number is a sequential procedure.

  1. Get the list of intact link positions from ms_peptide::getIntactLinks().
  2. Get the list of looplink positions from ms_peptide::getLoopLinks().
  3. When looping over the variable mods string, if the mod number is 0, there's no mod or linker at this position.
  4. Otherwise:
    1. Call intactLinks.getVarModIdxOfLinkedSite() to determine whether there is an intact link at this position.
    2. If not an intact link, call loopLinks.getVarModIdxOfLinkedSite() to determine whether there is looplink at this position.
    3. If not a looplink, extract the the monolink number from the monolink string, ms_peptide::getMonoLinkStr(), at the same position. Use the variable mod number and the monolink number as arguments to ms_mascotresfile::getMonoLinkModification(). If it returns a valid object, this position encodes a monolink.
    4. Otherwise, this position is an ordinary variable modification.

Processing intact link and looplink data is easiest in a separate loop. For intact links:

  1. Get the list of intact link positions from ms_peptide::getIntactLinks().
    This class encapsulates the linked_sites line.
  2. Loop over the contents of the ms_linker_site_vector:
    1. Access the linker start and end positions and the variable mod numbers using the ms_linker_site methods.
    2. Note that the PSM component is different at either end of the link.

Processing looplink data is the same, except it is typically easiest to do it separately for alpha and beta peptides:

  1. Get the list of intact link positions from ms_peptide::getLoopLinks(PSM_CROSSLINK_ALPHA).
    This class encapsulates the looplinked_sites line.
  2. Loop over the contents of the ms_linker_site_vector:
    1. Access the looplink start and end positions and the variable mod numbers using the ms_linker_site methods.
    2. Note that the PSM component is PSM_CROSSLINK_ALPHA at both ends of the link.
  3. Repeat for PSM_CROSSLINK_BETA.

Note that the monolink index zero could mean either lack of modification (if the variable mods string also has a zero) or the first monolink in the linker definition. It's important to check both the variable mods string and the monolink string.

The following C++ code illustrates processing the variable mods, intact links, looplinks and monolinks of a linear peptide match.

C++
std::string varModsStr = peptide.getVarModsStr();
std::string monoLinkStr = peptide.getMonoLinkStr();
ms_linker_site_vector intactLinks = peptide.getIntactLinks();
ms_linker_site_vector loopLinks = peptide.getLoopLinks(ms_peptide::PSM_COMPLETE);

for (int i = 0; i < varModsStr.length(); ++i) {
  int modNum = convertToInt(varModsStr[i]);
  int monoLinkNum = 0;

  // Monolink string could be empty -- check first.
  if (monoLinkStr.size() > 0)
    monoLinkNum = convertToInt(monoLinkStr[i]);

  if (modNum == 0)
    continue;

  // Is it an intact link?
  if (0 < intactLinks.getVarModIdxOfLinkedSite(ms_peptide::PSM_COMPLETE, i)) {
    // Yes, it's an intact link. Process in a separate loop as described above.
    continue;
  }

  // Is it a looplink in either PSM component?
  if (0 < loopLinks.getVarModIdxOfLinkedSite(ms_peptide::PSM_COMPLETE, i)) {
    // Yes, it's a looplink. Process in a separate loop as described above.
    continue;
  }

  // Is it a monolink?
  const ms_modification *monoLinkMod = resfile.getMonoLinkModification(modNum, monoLinkNum);
  if (monoLinkMod) {
    delta = monoLinkMod->getDelta(MASS_TYPE_MONO);
    continue;
  }

  // Not intact link, monolink or looplink, so it's a regular variable mod.
  delta = resfile.params().getVarModsDelta(modNum);
}

Processing the alpha or beta peptide in a crosslinked match is very similar; simply replace ms_peptide::PSM_COMPLETE with ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA where relevant.

Protein inference

Protein inference and the ms_protein API are not affected by the presence of monolinks or looplinks, since these are just variable modifications.

However, there are a few details to consider with intact crosslinked peptides. A peptide match is assigned to a protein hit when the alpha sequence, the beta sequence or both appear in the protein. Methods that return sequence-level data, such as ms_protein::getPeptideStart() now take a new parameter psmComponent. The change is analogous to ms_peptide methods for intact crosslinked peptide match. In fact, the easiest way to check whether psmComponent is assigned to the protein is by looking at the return value of getPeptideStart(): if it's -1, the psmComponent is not assigned to the protein hit.

The definition of duplicate peptide has been extended:

  • A crosslinked peptide and a linear peptide can never be duplicates of each other.
  • A crosslinked peptide can be a duplicate of another crosslinked peptide if their alpha sequences are the same, beta sequences are the same, alpha variable modifications, monolinks and looplinks are the same, beta variable modifications, monolinks and looplinks are the same and the linker positions and sites are the same.

No client code changes are needed; duplicate checking is done internally, as before. (For more details, see Peptide match duplicates.)

Protein inference is not affected by intact crosslinks. That is, the intact crosslink between two proteins is not enough to cluster them in the same protein family. Clustering requires sharing the same significant alpha or beta sequence.

If a protein has any crosslinked peptides, these are ignored when emPAI is calculated.

ms_protein methods for intact crosslinked peptide match

The table summarises the return values when at least one psmComponent is assigned to the protein hit.

Method | Return value with PSM_COMPLETE | Return value with PSM_CROSSLINK_ALPHA | Return value with PSM_CROSSLINK_BETA
ms_protein::getPeptideStart() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideEnd() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideMultiplicity() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideFrame() | -1 | alpha value (if alpha is in this protein) or -1 | beta value (if beta is in this protein) or -1
ms_protein::getPeptideResidueBefore() | '?' | alpha value (if alpha is in this protein) or '?' | beta value (if beta is in this protein) or '?'
ms_protein::getPeptideResidueAfter() | '?' | alpha value (if alpha is in this protein) or '?' | beta value (if beta is in this protein) or '?'

ms_protein methods for linear peptide match

When the peptide match assigned to the protein hit is a linear peptide, the psmComponent argument is ignored.

Method | Return value with PSM_COMPLETE, PSM_CROSSLINK_ALPHA, PSM_CROSSLINK_BETA
ms_protein::getPeptideStart() | start position
ms_protein::getPeptideEnd() | end position
ms_protein::getPeptideMultiplicity() | multiplicity
ms_protein::getPeptideFrame() | frame or -1
ms_protein::getPeptideResidueBefore() | residue before
ms_protein::getPeptideResidueAfter() | residue after

Fragmenting crosslinked and looplinked peptides

ms_aahelper::calcFragmentsEx() and related methods can fragment a crosslinked peptide. Fragmentation produces single-cleavage product ions. First, the beta sequence is treated as a modification attached to the alpha peptide, and the alpha sequence is fragmented as usual. Then the roles are reversed. The final list of fragments contains single-cleavage ions from alpha and single-cleavage ions from beta. There are no double-cleavage ions where the alpha and beta fragment simultaneously.

The ms_fragment class has two new methods: isFromAlpha() and isFromBeta(). Fragmenting a linear peptide produces ms_fragment objects where both methods return false. Fragmenting a crosslinked peptide produces fragments where one or the other flag is true. Because there are no double-cleavage ions, isFromAlpha() and isFromBeta() cannot both be true at the same time.

There is a helper method for linking two peptide objects: ms_aahelper::createCrosslinkedPeptide().

Fragmenting a peptide with looplinks the exactly the same as fragmenting a peptide without looplinks, apart from one exception. The looplink is assumed to be stronger than the peptide backbone. Thus, there are no fragments that start or end in the region spanned by a looplink. This includes regular series as well as internals.

Crosslinking changes in ms_peptidesummary

There is a new method that returns the number of discovered intact crosslinks and looplinks: ms_peptidesummary::getNumDiscoveredIntactLinks()

Because monolinks share the same variable mod number, ms_peptidesummary::getNumDiscoveredVariableMods() has been extended. The method returns the modification names and deltas as well as counts, positions and sites.

ms_peptidesummary::getAllProteinsWithThisPepMatch() has been extended to return the psmComponent assigned to the protein hit.

There are no changes to the parameters of ms_peptidesummary::findPeptides(). If you search for a peptide sequence with findPeptides(), it will compare the input string to both the alpha sequence and beta sequence. If either one is a match, findPeptides() adds it to the return vector.

Calling ms_peptidesummary::getReadableVarMods() without psmComponent produces a human-readable string of variable modifications, monolinks, looplinks and intact links contained in the peptide match.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Using the singleHit parameter to return a single protein
[Mascot results file module]

The singleHit parameter for ms_proteinsummary and ms_peptidesummary should only be used for retrieving the results for a single protein. The purpose of the parameter is to do the retrieval more quickly than by generating a full results file object. This is used, for example, in the Mascot Server protein view report.

Note that the value passed as the singleHit parameter will be different in these two cases. However, in both cases the single protein hit can be obtained using ms_mascotresults::getHit(1).

Getting a single hit from the protein summary

The parameters when creating an ms_proteinsummary object should be as follows:

  • resfile should be the ms_mascotresfile object.

  • flags should generally be set to MSRES_IGNORE_PMF_MIXTURE, because the return value from getProteinSummaryHit() is the hit number that corresponds to the protein summary with mixtures and grouping ignored.

    Obviously, if the protein is from the decoy section, then MSRES_DECOY also needs to be specified.

  • minProbability should be set to zero. If this is set to a higher value than the score for the requested protein, then no results will be returned.

  • maxHitsToReport should be set to 1 for clarity. Any value above one would still return only one protein. A value of zero would return no proteins.

  • unigeneIndexFile can be used as normal for a UniGene entry.

  • singleHit is the hit number as a string from the protein summary. This is the hit number in the results file, and hence is the same number as when the protein summary is used without grouping. The hit number can be obtained by creating an ms_proteinsummary object without the singleHit parameter and using getProteinSummaryHit().

Getting a single hit from the peptide summary

Mascot Server 2.3 introduced caching of results files for peptide summary reports. See Using the ms_peptidesummary cache file for protein_view.pl for details. If caching is enabled, opening the results file in the usual way is as fast as using the singleHit parameter.

For backwards compatibility, and when caching is disabled, you can still use the singleHit parameter. In that case, the parameters when creating an ms_peptidesummary object should be as follows:

  • resfile should be the ms_mascotresfile object.

  • flags can be set to 0. All of the flags are still processed and used as for a normal results object. However, since a single protein is being returned, flags relating to grouping are essentially ignored.

    MSRES_REQUIRE_BOLD_RED will have a limited meaning: every peptide will be 'bold' because it s the first time it has been reported.

    The MSRES_DUPE_INCL_ and MSRES_DUPE_REMOVE_ flags are treated as normal.

  • minProbability should be set to zero. If this is set to a higher value than the score for the requested protein, then no results will be returned.

  • maxHitsToReport should be set to 1 for clarity. Any value above one would still return only one protein. A value of zero would return no proteins.

  • unigeneIndexFile can be used as normal for a UniGene entry.

  • ignoreIonsScoreBelow should be set to the same value that you would normally use.

  • minPepLenInPepSummary should be set to the same value that you would normally use.

  • singleHit is the accession string for the protein that is to be retrieved. For new applications, the database ID should be specified in the string, followed by a colon. Example: "3:CH60_SHEON".

  • flags2 should be MSPEPSUM_SINGLE_HIT_DBIDX if the singleHit accession string starts with the database ID followed by a colon.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Automated repeating of searches
[Mascot results file module]

A common requirement is to repeat all searches with, for example, a different or updated database. The standard Mascot Server reports provide a button "Search Selected" or "Re-search all" to repeat a search, but it is tedious to do this manually for more than a few searches. Mascot Daemon also allows searches to be repeated as a follow on from a search using the original peak lists.

Repeating searches in a batch can easily be achieved using Mascot Parser. It is assumed you have access to a Mascot Server installation.

Overview

To repeat a search, nph-mascot.exe has to be run with command parameter 4 and the search data needs to be taken from a MIME format input file. The format of the input file is described in the Mascot Installation and Setup manual, chapter 8.

MIME Format File

In its simplest form, the MIME format file has the following structure:

    ----12345
    Content-Disposition: form-data; name="QUE"

    MASS=Monoisotopic
    CLE=Trypsin
    ...

    1234.012
    1567.086
    ----12345--

where MASS, CLE, etc. are the search parameters, and the two numbers are simply two masses for a peptide mass fingerprint search. Note the standard MIME format header and terminating line.

You can access the search parameters easily in Mascot Parser by using the params() method of the ms_mascotresfile object. Another way is to iterate through the keys using enumerateSectionKeys(), which avoids having to type all parameter names directly.

The following example prints all search parameters except DB, which is changed to another database. INTERMEDIATE and RULES are also skipped for reasons explained below.

C++
    ms_mascotresfile resfile = ms_mascotresfile(filename);

    if (!resfile.isValid()) {
        /* Error handling... */
    }

    int i = 1;
    std::string key = resfile.enumerateSectionKeys(ms_mascotresfile::SEC_PARAMETERS, i);

    while (!key.empty()) {
        std::string val = resfile.getSectionValueStr(
            ms_mascotresfile::SEC_PARAMETERS, key.c_str()
        );

        if (!val.empty() && key != "INTERMEDIATE" && key != "RULES" && key != "DB")
            std::cout << key << "=" << val << std::endl;

        key = resfile.enumerateSectionKeys(ms_mascotresfile::SEC_PARAMETERS, ++i);
    }

    std::cout << "DB=My_database" << std::endl;

Perl
    my $resfile = msparser::ms_mascotresfile->new($filename);

    if (not $resfile->isValid()) {
        # Error handling...
    }

    my $sec_params = $msparser::ms_mascotresfile::SEC_PARAMETERS;
    my $i = 1;
    my $key = $resfile->enumerateSectionKeys($sec_params, $i);

    while ($key ne '') {
        my $val = $resfile->getSectionValueStr($sec_params, $key);

        if ($val ne '' and $key ne "INTERMEDIATE" and $key ne "RULES" and $key ne "DB") {
            print $key, "=", $val, "\n";
        }

        $key = $resfile->enumerateSectionKeys($sec_params, ++$i);
    }

    print "DB=My_database\n";

Java
    ms_mascotresfile resfile = new ms_mascotresfile(filename);

    if (!resfile.isValid()) {
        /* Error handling... */
    }

    int i = 1;
    String key = resfile.enumerateSectionKeys(ms_mascotresfile.SEC_PARAMETERS, i);

    while (key != "") {
        String val = resfile.getSectionValueStr(ms_mascotresfile.SEC_PARAMETERS, key);

        if (val != "" && key != "INTERMEDIATE" && key != "RULES" && key != "DB")
            System.out.println(key + "=" + val);

        key = resfile.enumerateSectionKeys(ms_mascotresfile.SEC_PARAMETERS, ++i);
    }

    System.out.println("DB=My_database");

Python
    resfile = msparser.ms_mascotresfile(filename)

    if not resfile.isValid() :
        # Error handling...

    sec_params = msparser.ms_mascotresfile.SEC_PARAMETERS
    i = 1
    key = resfile.enumerateSectionKeys(sec_params, i)

    while len(key) > 0 :
        val = resfile.getSectionValueStr(sec_params, key)

        if len(val) > 0 and key != "INTERMEDIATE" and key != "RULES" and key != "DB" :
            print("%s=%s" % (key, val))

        i += 1
        key = resfile.enumerateSectionKeys(sec_params, i)

    print("DB=My_database")

C#
    ms_mascotresfile resfile = new ms_mascotresfile(filename);

    if (!resfile.isValid()) {
        /* Error handling... */
    }

    int i = 1;
    string key = resfile.enumerateSectionKeys(ms_mascotresfile.section.SEC_PARAMETERS, i);

    while (key != "") {
        String val = resfile.getSectionValueStr(ms_mascotresfile.section.SEC_PARAMETERS, key);

        if (val != "" && key != "INTERMEDIATE" && key != "RULES" && key != "DB")
            Console.WriteLine("{0} = {1}",key,val);

        key = resfile.enumerateSectionKeys(ms_mascotresfile.section.SEC_PARAMETERS, ++i);
    }
    Console.WriteLine("DB=My_database");

For MS-MS data, the complete set of ions peaks could be megabytes or even gigabytes of data, and it may make no sense to copy the data into the repeat search file. nph-mascot.exe supports a "query" statement for this purpose, which is returned by getRepeatSearchString():

C++
    for (int q=1; q != resfile.getNumQueries(); q++)
        std::cout << resfile.getRepeatSearchString(q) << std::endl;

Perl
    for my $q (1 .. $resfile->getNumQueries()) {
        print $resfile->getRepeatSearchString($q), "\n";
    }

Java
    for (int q = 1; q != resfile.getNumQueries(); q++)
        System.out.println(resfile.getRepeatSearchString(q));

Python
    for q in range(1, 1 + resfile.getNumQueries()) :
        print(resfile.getRepeatSearchString(q))

C#
    for (int q = 1; q != resfile.getNumQueries(); q++)
        Console.WriteLine(resfile.getRepeatSearchString(q));

When nph-mascot.exe reads in a query statement, it loads the original input data from the Mascot results (.dat) file. To this end, you also need to add the INTERMEDIATE parameter that points to the original results file:

C++
    std::cout << "INTERMEDIATE=" << filename << std::endl;

Perl
    print "INTERMEDIATE=", $filename, "\n";

Java
    System.out.println("INTERMEDIATE=" + filename);

Python
    print("INTERMEDIATE=%s" % filename)

C#
    Console.WriteLine("INTERMEDIATE={0}", filename);

Running the repeat search

In the example code, the search is run by calling nph-mascot.exe with two parameters, and the repeat search data is piped into the process' standard input:

    nph-mascot.exe 4 -commandline > tmp.txt

The 4 indicates that this is a repeat search. The -commandline parameter is used to prevent progress reports and HTML being written to standard out.

For a successful search, the output (e.g. tmp.txt) will be of the form:

    SUCCESS
    ../data/20031007/F001547.dat

where the data file name is output following the text "SUCCESS".

If an error occurs, the output will be of the form:

    FATAL_ERROR: M00027
    Sorry, the database (SwissProt) is not currently available for searching [M00027]

Comparing the results

The example code uses a simple approach to compare the old and new results. For searches with PMF data, the top protein hit from both searches are compared and if their scores differ by more than 10, then the difference is reported.

For searches with MS-MS data, peptide matches are compared, and a score difference of more than 10 will be reported.

It is more than likely that these comparison rules will need to be changed for optimum results.

Remember that if the searches were performed with a much older version of Mascot Server, then the scores may have changed a little because minor changes have been made to Mascot to optimize the scoring. However, a score difference of greater than 10 is likely to indicate a new protein sequence in the database.

Example Code

Example code is provided in various programming languages:

  • repeat_search.cpp
  • repeat_search.pl
  • repeat_search.java
  • repeat_search.py
  • repeat_search.cs

The sample program takes a single input file, repeats the search and compares results as above. To run the program on a whole directory of files, use 'find' under Unix, or a FOR loop in a batch/cmd file under Windows. For example, to repeat all searches from the year 2002 under Unix:

    # find ../data/2002???? -name \*.dat | xargs -n 1 repeat_search.pl

Remember that new results will go in 'todays' directory, so be sure not to include that directory with 'find' or the repeated searches will be repeated again and again and again...

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Target-decoy searches and false discovery rate
[Mascot results file module]

Decoy search results

In Mascot Server 2.2 and later, any search can be run against a decoy database generated on the fly. Each sequence in the database is randomised or reversed and then searched along with the original sequence. Results for matches against the original sequence are stored as normal, while results against the randomised sequence are saved in the decoy_summary, decoy_mixture and decoy_peptides sections. The decoy algorithm type is saved in the header section and can be retrieved with ms_mascotresfile::getDecoyTypeForDB.

It is easy to switch between the decoy results and the standard results. To view the decoy results, specify MSRES_DECOY when creating the ms_peptidesummary or ms_proteinsummary object.

The functions anyPeptideSummaryMatches() and getNumHits() have an optional section name parameter so that these can be used with decoy or error tolerant results.

Calculating the false discovery rate (FDR)

The false discovery rate is an estimate of the proportion of false discoveries (false positives) among all significant matches. The number of hits in the decoy database provides the estimated number of false positives. The FDR is then (number of decoy hits) / (number of target hits).

The following methods return the number of hits at different thresholds:

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

For a peptide summary, the number of hits is the number of peptide matches, while for a protein summary, the number of hits is the number of protein matches.

You can use ms_searchparams::getDECOY() to decide whether to display false discovery rates.

Automatically adjusting the significance threshold

You can use ms_mascotresults_params::setTargetFDR() to set a target FDR. Parser will choose a significance threshold that yields an FDR as close as possible to the target. The chosen significance threshold is available through ms_mascotresults::getProbabilityThreshold().

If the search is an error tolerant target-decoy search, the target FDR applies to both first and second pass matches; see Score thresholds and score filtering (Mascot Server 2.8 and later).

Another procedure available in Parser 2.7 and earlier was to use ms_mascotresults::getThresholdForFDRAboveIdentity or ms_mascotresults::getThresholdForFDRAboveHomology to automatically determine a significance threshold that yields the desired target FDR. This procedure is no longer recommended, because it requires creating an auxiliary ms_peptidesummary object.

  1. Create ms_mascotresfile as usual; call it resfile.
  2. Create ms_peptidesummary as usual; call it pepsum. The minProbability parameter can be the default (0.05).
  3. Decide on a target FDR, say 0.01, and get new minProbability with ms_mascotresults::getThresholdForFDRAboveHomology. You may want to check the return value and closestFDR, since it's not always possible to find a suitable FDR, especially in small searches.
  4. Create a new ms_peptidesummary object using the same resfile but new minProbability. The rest of the parameters can be the same as before. You don't need to keep the original pepsum object in memory. It's only needed for finding the desired significance threshold.

Note that the FDR is a global FDR and it applies to the whole search.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Using Percolator scores
[Mascot results file module]

In Mascot Server 2.3 and later, MS-MS searches can be run through Percolator. Percolator is produced by the MacCoss group at University of Washington. See e.g.

  • http://www.nature.com/nmeth/journal/v4/n11/abs/nmeth1113.html
  • http://noble.gs.washington.edu/proj/percolator
  • http://per-colator.com/

Percolator scores can be shown in Mascot Server reports instead of Mascot scores.

Workflow

Percolated results are available both for old and new searches. However, they are only available when a decoy search has been performed. The Mascot results file is not changed by Percolator, but additional files for each results file are created by running ms-createpip.exe and percolator.exe. The workflow is as follows:

  1. Run a Mascot search, making sure that the DECOY option is on.
  2. Check that there are sufficient queries in the search by comparing getNumQueries() with getPercolatorMinQueries().
  3. Check that there are sufficient sequences in the search by comparing getNumSeqsAfterTax() with getPercolatorMinSequences().
  4. Get the default Percolator features by calling getPercolatorFeatures().
  5. Get the filenames to be used by ms-createpip.exe by calling setPercolatorFeatures() and getPercolatorFileNames().
  6. Run ms-createpip.exe, specifying the output filename using the value from the step above.
  7. Run percolator.exe, getting the required parameters by calling getPercolatorExeFlags() .
  8. Specify MSPEPSUM_PERCOLATOR as part of the flags2 parameter when creating an ms_peptidesummary object.
  9. Optionally, specify target FDR with ms_mascotresults_params::setTargetFDR().

Steps 1 to 7 can be performed automatically after a search by specifying the appropriate options in getExecAfterSearch() .

There is also a static function, staticGetPercolatorFileNames() that can be called to get filenames without creating an ms_mascotresfile object.

Percolator Scores

A 'Percolator score' is calculated from the posterior error probability (PEP) by

    percolatorScore = -10 * log10(PEP)

Percolator processes only the rank 1 matches found by Mascot. Lower ranked peptides are scored by simply calculating

    rank2PercolatorScore = (rank2MascotIonsScore/rank1MascotIonsScore) * rank1Percolatorscore

If the PEP value for rank 1 is exactly 1, it is reset to 0.9999. This is to ensure that there is a tiny amount of spread in scores for lower ranking peptides.

The function ms_peptide::getPercolatorScores() returns the posterior error probability which is used by Mascot Parser. The internal percolator score and the qValue can also be obtained, but these are unused by Mascot Parser.

When the MSPEPSUM_PERCOLATOR flag is specified, all Mascot scores are replaced with percolator derived scores. The original Mascot ions score for a peptide is still available by calling getPercolatorScores(). The following table describes the how each of the existing Mascot functions have been changed to return Percolator values.

Mascot Parser Function | How value is calculated
ms_peptide::getIonsScore() | -10 * log10( posterior error probability )
ms_protein::getPeptideIonsScore() | Same value as getIonsScore() above, except a minor correction for large proteins is applied in the same way as for the Mascot Score.
ms_protein::getScore() | Calculated using the percolator scores rather than Mascot scores. Same rules for MudPIT and standard scoring apply.
ms_protein::getNonMudpitScore() | Calculated using the percolator scores rather than Mascot scores. Same rules for MudPIT scoring apply.
ms_mascotresults::getPeptideIdentityThreshold() | Calculated by taking -10log10(p), so a value of 0.05 gives a threshold score of ~13
ms_mascotresults::getAvePeptideIdentityThreshold() | With Percolator, the threshold is the same for every query, so this is exactly the same as getPeptideIdentityThreshold() above.
ms_mascotresults::getMaxPeptideIdentityThreshold() | With Percolator, the threshold is the same for every query, so this is exactly the same as getPeptideIdentityThreshold() above.
ms_mascotresults::getHomologyThreshold() | With Percolator, there is no homology threshold, so this always returns 0.
ms_mascotresults::getHomologyThresholdForHistogram() | With Percolator, there is no homology threshold, so this always returns 0.
ms_mascotresults::getPeptideExpectationValue() | Return the posterior error probability by calculating it back from the score using 10 ^ score/-10. The same value can also be obtained by calling ms_peptide::getPercolatorScores() and retrieving the posterior error probability value.
ms_mascotresults::getProbFromScore() | Calls getPeptideExpectationValue() as above.
ms_mascotresults::getIonsScoreHistogram() | Returns a vector of Percolator scores rather than Mascot scores.
ms_mascotresults::getProteinScoreForHistogram() | Returns the Percolator protein score rather than Mascot protein score
ms_mascotresults::getNumHitsAboveIdentity() | Any peptide with a posterior error probability less than the significance value specified will be counted.
ms_mascotresults::getNumDecoyHitsAboveIdentity() | Any peptide with a posterior error probability less than the significance value specified will be counted.
ms_mascotresults::getNumHitsAboveHomology() | No homology thresholds, so always returns the same number as getNumHitsAboveIdentity().
ms_mascotresults::getNumDecoyHitsAboveHomology() | No homology thresholds, so always returns the same number as getNumDecoyHitsAboveIdentity().

You cannot specify MSPEPSUM_PERCOLATOR with an Integrated error tolerant search.

The following configuration functions are relevant:

  • ms_mascotoptions::isPercolator()
  • ms_mascotoptions::getPercolatorFeatures()
  • ms_mascotoptions::getPercolatorMinQueries()
  • ms_mascotoptions::getPercolatorMinSequences()
  • ms_mascotoptions::isPercolatorUseProteins()
  • ms_mascotoptions::isPercolatorUseRT()
  • ms_mascotoptions::getPercolatorExeFlags()
  • ms_mascotoptions::getExecAfterSearch()
  • ms_mascotresfile::staticGetPercolatorFileNames()
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Caching Mascot Results
[Mascot results file module]

Mascot Parser 2.3 and later support the use of cache files to speed up access to huge results files.

Two types of cache file are supported, and typically both will be created when processing a single results file:

  • A cache for the results file itself (ms_mascotresfile), i.e. the .dat file.
  • A cache for the protein and peptide data, i.e. the results (ms_mascotresults/ms_peptidesummary).

The first one is an index to different sections and raw lines of the results file itself, and only needs to be rebuilt if the file changes.

The second contains processed and grouped protein hits and peptide data. Without an ms_peptidesummary cache, protein grouping needs to be done anew every time an ms_peptidesummary object is created. With caching, the grouped data can be stored in the cache file, and subsequent file access can skip protein grouping entirely.

Specifying cache file directory

In a standard Mascot Server setup, cache files are located in a directory specified by the CacheDirectory value in the options section of mascot.dat. If CacheDirectory specifies a relative directory, then it is relative to the current working directory of the calling program. The function ms_mascotoptions::getCacheDirectory() can be used to retrieve the cache directory from mascot.dat. In all Mascot Server scripts, the return value from this function is passed to the ms_mascotresfile constructor.

Cache files for a specific results file are put into their own directory under the directory specified by CacheDirectory. The name of the directory is constructed by calling getMD5Sum() and passing a string comprising the .dat filename (or filenames if combining multiple results files; see Combining multiple .dat files), file size and last modified date. The function ms_mascotresfile::getCacheDirectory() can be used to retrieve the directory used for cache files for a specific results file.

A number of special 'tokens' can be used to split the potentially large number of files/directories into more convenient subdirectories. The 'tokens' are generated using the strftime function using the last modified date of .dat file. Whilst the strftime function has a large number of options, the ones most likely to be useful are:

  • %d - The day of the month as a decimal number (range 01 to 31)
  • %m - The month as a decimal number (range 01 to 12)
  • %y - The year as a decimal number without a century (range 00 to 99)
  • %Y - The year as a decimal number including the century

Other tokens accepted by strftime are documented here: http://www.cplusplus.com/reference/clibrary/ctime/strftime/

The default value is "../data/cache/%Y/%m" which specifies a new directory for each month. For example, for a file dated the 3rd February 2010, the files would be in a directory ../data/cache/2010/02.

Mascot Parser will try to create a cache directory if it doesn't exist. If necessary, it will create the whole directory tree.

Using the ms_mascotresfile cache files

The default constructor for ms_mascotresfile has the flag RESFILE_NOFLAG, which means that when a results file is opened, no cache will be used. Simply specify RESFILE_USE_CACHE to use a cache.

Most errors relating to the cache files are 'soft'. For example, if two applications both try and create a cache file at the same time, then the first will succeed in creating the cache file, and the second one will carry on without using a cache. If an application crashes in the middle of creating a file, then the next application to try and use the cache will re-create it. If an application fails to create the cache for any reason, it will carry on without the cache.

A cache file may be recreated under some conditions, even when it already exists:

  • If the size or last modified date of a results file has changed since the cache was created, then the cache will be rebuilt.
  • An internal version number for the cache is saved within the file. If Matrix Science need to change the format of the cache file, then this will cause the cache to be rebuilt.

The cache files have a maximum size of 4Gb. In general, the ms_mascotresfile cache file is about 10% of the size of the results file.

The static function ms_mascotresfile::willCreateCache() can be called before creating an ms_mascotresfile object to determine if a cache file will be created. This is useful in checking whether creating the object will take a long time.

The function ms_mascotresfile::getCacheFileName() can be called to retrieve the full or relative path to the cache file.

Using the ms_peptidesummary cache

Specify MSPEPSUM_USE_CACHE when creating the ms_peptidesummary object to enable caching.

If the cache file doesn't exist, then it will be created. If it exists, then the ms_peptidesummary constructor will return without extra delay. Calling getHit() and getPeptide() will load data from the cache file on demand. This means that after the cache file has been created once, you will need much less memory to access data in the file, as the whole file does not need to be read into memory.

What is cached?

The following values and data is stored in the cache file:

  • Protein grouping and family links, most common fields (except description)
  • ms_mascotresults::isNA()
  • ms_mascotresults::getProteinScoreForHistogram()
  • ms_mascotresults::getAvePeptideIdentityThreshold()
  • ms_mascotresults::getIonsScoreHistogram()
  • For results using a UniGene index, the date, time and size of the UniGene file are cached.
  • For a decoy search, calls to the following methods when using the default minProbability value:
    • getNumHitsAboveIdentity()
    • getNumHitsAboveHomology()
    • getNumDecoyHitsAboveIdentity()
    • getNumDecoyHitsAboveHomology()
  • The unassigned list. It may still be slow to sort the unassigned list by intensity, as the intensity values are not cached.

Assuming MSRES_DECOY is not specified, no actual decoy matches will be saved. The same is true in reverse: when using MSRES_DECOY, protein hits from the standard search are not cached.

If a UniGene index is in use and the UniGene file changes, the cache will be rebuilt.

Performance issues when creating the cache

If you use the cache for an ms_mascotresfile object, and then create a new ms_peptidesummary object, caching will typically take 1.5 to 3 times longer than without an ms_mascotresfile cache.

The static function matrix_science::ms_peptidesummary::willCreateCache() can be called before creating an ms_peptidesummary object to determine if there will be a delay while a cache file is created.

Performance issues with ms_protein objects

Once a cache file has been created, it should take less than a second to create a new ms_peptidesummary object. Calling matrix_science::ms_mascotresults::getHit() should also be very fast as this just loads data from the cache file. However, only basic information for each matrix_science::ms_protein object is loaded at this time. The first call for any particular ms_protein object to a function that takes a pepNumber argument (for example: matrix_science::ms_protein::getPeptideIonsScore() ) will be slow because this will cause a reload of data from multiple parts of the results file. Subsequent calls to any function for that ms_protein object will be fast, until matrix_science::ms_mascotresults::freeHit() is called.

Some applications just need a list of query/rank values for each protein so these values are cached separately for each top level protein and family member protein. Therefore, the first call to matrix_science::ms_protein::getPeptideQuery() or matrix_science::ms_protein::getPeptideP() will be reasonbly fast compared will calls to the other functions that take a pepNumber.

Performance issues when using non-default arguments

Calls to any function that takes a OneInXprobRnd argument will be slow if 1) caching is in use and 2) the argument is not the same as when the cache file was created. Typically, this argument is 1 / results.getProbabilityThreshold(). The value is compared to what is saved in the cache file (within a certain precision), and if the argument differs, this may trigger an expensive loop over all queries.

The affected functions are:

  • getHomologyThresholdForHistogram
  • getAvePeptideIdentityThreshold
  • getNumHitsAboveIdentity
  • getNumHitsAboveHomology
  • getNumDecoyHitsAboveIdentity
  • getNumDecoyHitsAboveHomology
  • getPeptideIdentityThreshold
  • getHomologyThreshold
  • getProteinThreshold

Other potentially slow function calls in cache mode

Parser is backwards compatible with cache files from a number of previous versions. New functionality often necessitates adding more data to new cache files to improve performance. If this data is not present in the current cache file (e.g. the cache file is from one or two versions before the current version), it is read directly from the results file or calculated on the fly.

The enum ms_peptidesummary::BUGFIX_NUM maintains a list of new functionality and performance improvements where this may be the case. If you use cache files created by a previous version of Parser, it is good practice to call ms_peptidesummary::isDataCached() with the relevant bug number to discover whether the data needed by the method you use is indeed present in the cache file. If it isn't, you can avoid the function call, prepare a progress feedback screen or recreate the cache files.

Filenames for the ms_mascotresults/ms_peptidesummary cache files

The cache filename format is

    F01234.dat.[a-z0-9]*.cdb

where [a-z0-9] will be replaced by exactly 26 numbers or lower-case letters created by calling getMD5Sum() on a string created using all parameters passed to the ms_peptidesummary constructor, including the UniGene index file path.

If, for example, two reports are created for the same results file, one with a probability threshold of 0.05 and another with a threshold of 0.001, then separate cache files with unique filenames will be created, making it fast to switch between the two reports. Separate cache files are necessary, because changing any of the constructor parameters may change protein and peptide scoring, grouping, cut-off thresholds, etc.

The following flags do not affect the contents of the cache file and therefore are not included in the MD5Sum for the name:

  • matrix_science::ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE
  • matrix_science::ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

The function ms_peptidesummary::getCacheFileName() can be called to retrieve the full or relative path to the cache file.

How a script should decide whether to use a cache

There are two lines in the options section of mascot.dat which specify what each script should do:

    ResfileCache master_results.pl,master_results_2.pl,peptide_view.pl...
    ResultsCache master_results.pl,master_results_2.pl,peptide_view.pl...

Each script should see if it is listed in ResfileCache, and if so, it should specify RESFILE_USE_CACHE when creating the ms_mascotresfile object. The value can be retrieved from the Options section of mascot.dat by calling ms_mascotoptions::getResfileCache().

Each script should see if it is listed in ResultsCache, and if so, it should specify MSPEPSUM_USE_CACHE when creating the ms_mascotresults object. The value can be retrieved from the Options section of mascot.dat by calling ms_mascotoptions::getResultsCache().

Using the ms_peptidesummary cache file for protein_view.pl

To quickly load details for a single protein (e.g. for protein_view.pl), applications prior to Mascot Parser 2.3 would generally use the singleHit parameter. However, it is faster to use a cache file if it exists.

For ms_proteinsummary, no peptide summary cache is available, so continue to follow the instructions as in Getting a single hit from the protein summary.

For ms_peptidesummary, the fastest method of loading details for a single protein is to use the cache if it already exists. For protein_view.pl, it is likely that a cache has already been created by master_results.pl or master_results_2.pl. So, as long as the exact same flags and parameters for the ms_peptidesummary constructor are used, access will be fast.

Protocol:

  • Check to see if protein_view.pl (or whatever application/script) is to use a cache file as described above.
  • Create the new ms_peptidesummary without the singleHit parameter and using the same flags and parameters as in master_results.pl or master_results_2.pl to make sure an existing cache file is used. Make sure that MSPEPSUM_USE_CACHE is specified.
  • Use getProtein() to get the single protein hit.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Combining multiple .dat files
[Mascot results file module]

Overview

Mascot Parser 2.3.03 and later support combining multiple results files. This is useful, for example when two searches have been performed one with ETD data and another with CID, but you want to combine the results to give a new single ms_peptidesummary.

To combine multiple files, simply create an ms_mascoresfile object for the first .dat file, and then call appendResfile() to add each of the subsequent files to the first file. Then create a new ms_peptidesummary object just for the first .dat file object. For example (but excluding any error handling!):

C++
   ms_mascotresfile resfile1 = ms_mascotresfile("F0001.dat");
   resfile1.appendResfile("F0002.dat");
   resfile1.appendResfile("F0003.dat");
   ms_peptidesummary pepsum = ms_peptidesummary(resfile1,...

Perl
   my $resfile1 = new msparser::ms_mascotresfile("F0001.dat");
   $resfile1->appendResfile("F0002.dat");
   $resfile1->appendResfile("F0003.dat");
   my $pepsum = new msparser::ms_peptidesummary($resfile1,...

Java and C#
   ms_mascotresfile resfile1 = new ms_mascotresfile("F0001.dat");
   resfile1.appendResfile("F0002.dat");
   resfile1.appendResfile("F0003.dat");
   ms_peptidesummary pepsum = new ms_peptidesummary(resfile1,...

Python
   resfile1 = msparser.ms_mascotresfile("F0001.dat")
   resfile1.appendResfile("F0002.dat")
   resfile1.appendResfile("F0003.dat")
   pepsum = msparser.ms_peptidesummary(resfile1,...

Query numbers for the second file are 'renumbered' to start at one greater than the number of queries in the first file. This is all dealt with internally in Mascot Parser at the lowest level. So, it is safe for example, to call getSectionValueStr() with a key "q1000_p1" on the primary resfile even though this query may be in the second resfile.

If you need access to the appended results files, use getResfile(). You may also need to use getSrcQueryAndFileIdForMultiFile() to return a query number in the original resfile.

The appended objects are deleted when the parent ms_mascotresfile object is deleted.

Limitations

Trying to combine results where any of the following differ will result in an error:

  • ITOL
  • ITOLU
  • ENZYME
  • PFA
  • MASS
  • Residue and terminus masses
  • Incompatible methods as returned by isMethodCompatible
  • MODS (fixed)
  • IT_MODS (variable)
  • DECOY
  • TAXONOMY
  • PEP_ISOTOPE_ERROR
  • ERRORTOLERANT
  • databases

Currently, all variable modifications must be the same, and in the same order in each file. This restriction may be changed in a future release.

Combining integrated error tolerant searches (see Integrated error tolerant search) is fully supported. Combining old-style error tolerant searches is not supported.

A combined protein summary is not supported. After calling appendResfile(), the function getNumHits() will return -1. A side effect of this is that getProteinMass() and getProteinDescription() will only work if there is an entry in a protein section in one of this files -- it won't look in the summary sections.

Percolator is not currently supported for combined results files.

Changed and additional API

Additional functions:

  • matrix_science::ms_mascotresfile::appendResfile
  • matrix_science::ms_mascotresfile::getResfile
  • matrix_science::ms_mascotresfile::getNumberOfResfiles
  • matrix_science::ms_mascotresfile::getSrcQueryAndFileIdForMultiFile
  • matrix_science::ms_mascotresfile::getMultiFileQueryNumber

Changed functions:

  • matrix_science::ms_mascotresfile::getNumQueries() -- now takes an optional ID.
  • matrix_science::ms_mascotresfile::getJobNumber() -- now takes an optional ID.
  • matrix_science::ms_mascotresfile::getFileName() -- now takes an optional ID.
  • matrix_science::ms_mascotresfile::anyPeptideSummaryMatches() -- looks through all files.

Cache Files

Using the ms_mascotresfile cache files gives details of how to use the 'resfile cache'. When a call is made to the primary ms_mascotresfile object that requires it to look in another results file, it will use the cache if that was specified for the second results file when calling appendResfile().

The ms_peptidesummary cache is slightly more complex, but still works. See Filenames for the ms_mascotresults/ms_peptidesummary cache files. The base part of the cache filename will be the primary results file, but the 26 character hash uses the names of all the subsequent files added using matrix_science::ms_mascotresfile::appendResfile. This ensures that different cache files will be used for opening a results file and a results file with appended files. The name of the cache file is dependent on the order that the additional results files are added.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Query-level modifications
[Mascot results file module]

Accessing query-level modification information

This section describes accessing and handling of query-level modifications in Mascot 2.5 and later results files. Query-level modifications were handled as part of the master variable modification list in Mascot 2.4 and earlier, so this information is only useful if you use query-level modifications in Mascot 2.5 or later. See also the section on backwards compatibility.

For simplicity, we will refer to variable modifications specified at search form level or in the quantitation method as form-level modifications, and variable modifications specified in an individual query as query-level or local modifications.

1. Extracting variable modifications of a match

Suppose the search has form-level modifications IT_MODS=Oxidation (M),Acetyl (N-term), and that there is a peptide match to query 1, which has the query-level modifications IT_MODS=Phospho (ST). The form-level modification numbers are 1=Oxidation (M) and 2=Acetyl (N-term), while the query-level modifications of query 1 have 1=Phospho (ST).

To find the modifications of the peptide match, fetch the peptide's variable mods string getVarModsStr() and the query-level mods string getLocalModsStr(). In this case, the variable mods string could be 20100000 and the query-level mods string 00001000. We can decode the strings in two steps:

  1. Using each non-zero digit in the variable mods string 2010000, look up the modification name using ms_searchparams::getVarModsName(). We find the peptide is acetylated at the N-terminus and oxidised at the second residue.
  2. Using each non-zero digit in the query-level mods string 00001000, look up the modification name using ms_inputquery::getLocalVarModName(). We find the peptide is phosphorylated at the fourth residue.

Points to note:

  • Query-level modification numbering is independent of both form-level modifications and other queries. That is, query-level modification numbers are 1-based, starting at 1, no matter how many form-level modifications there are.
  • Form-level modification names are stored in the masses section of the results file, accessible via ms_searchparams, as in Mascot 2.4 and earlier.
  • All versions of Mascot since 2.2 save query-level modification names as the IT_MODS parameter in the query section, which can be accessed with ms_inputquery::getIT_MODS(). Parser 2.5 and later parse the value of IT_MODS and make it available via ms_inputquery::getLocalVarModName(). In Parser 2.4 and earlier, you would need to split the unescaped IT_MODS manually to find the query-level modification names.
  • The local mods string getLocalModsStr() can be empty in Mascot 2.4 and earlier results files, and it can consist of only zeroes. If you need to test whether a peptide match uses query-level modifications, test that the string is non-empty and contains at least one non-zero digit.

In general, modification number for a residue can be non-zero only in one mods string at a time; that is, a residue cannot have a modification in both the variable mods string and the local mods string. The only exception is when support for multiple modifications on the same site is explicitly enabled, as described in section 3 below.

2. Extracting neutral losses

The neutral loss information of form-level and query-level modifications is encoded in two strings: ms_peptide::getPrimaryNlStr() and ms_peptide::getLocalModsNlStr(). The data format and numbering is analogous to variable modifications.

For form-level mods, use ms_searchparams::getVarModsNeutralLosses() to load the neutral loss vector of the variable modification. If a digit in getPrimaryNlStr() is non-zero, it refers to an element in the neutral loss vector. The vector is 0-based, so digit 2, for example, is the second element, at index 1.

For query-level mods, you need to locate the modification object first; see getLocalModsStr() for an example workflow. The correct neutral loss vector can then be loaded with ms_modification::getNeutralLoss(). As above, the non-zero digits in getLocalModsNlStr() refer to elements in the neutral loss vector.

3. More than one modification on the same site when MULTI_SITE_MODS=1

Mascot 2.4 added support for Multiple modifications for the same site in certain quantitation configurations, which is triggered when the search is run with the MULTI_SITE_MODS=1 parameter. In this mode, getVarModsStr() describes the exclusive modifications defined in the quantitation method, and getSummedModsStr() describes variable modifications occuring at the same sites as the exclusive modifications.

For example, suppose you have a results file using the SILAC quantitation method, which specifies Label:13C(6)15N(2) (K) as an exclusive modification. Suppose you also specify variable modification Acetyl (K) in the search form, so that the form-level modifications are 1=Acetyl (K) and 2=Label:13C(6)15N(2) (K). When MULTI_SITE_MODS=1, a peptide match could have getVarModsStr() == 00020000 and getSummedModsStr() == 00010000 That is, the former contains the (exclusive) SILAC label on K and the latter the variable modification (acetylation) on the same residue.

Now suppose the input query has also the query-level modifications IT_MODS=Methyl (KR), so that 1=Methyl (KR). Peptide matches to the query could have the following combinations of mods strings:

 | Rank 1 | Rank 2 | Rank 3 |
getVarModsStr() | 00020000 | 00020000 | 00020000 | exclusive mods
getSummedModsStr() | 00010000 | 00000000 | 00010000 | variable mods
getLocalModsStr() | 00000000 | 00010000 | 00000010 | variable mods
 | 123456 | 123456 | 123456 | (residue number)

In this case, the rank 1 match has acetylation and SILAC label on K (residue 3), while the rank 2 match has methylation and SILAC label on K (residue 3). The rank 3 match has acetylation and SILAC label on K (residue 3), and methylation on K or R at the C terminus (residue 6). Observe that in the rank 2 match, the summed mods string is empty and both the variable mods string and the local mods string contain a non-zero value for the third residue. This is the only case where getVarModsStr() and getLocalModsStr() can report a non-zero digit at the same site.

As a mnemonic, the summed and local modifications are always in addition to ("summed with") the exclusive modifications, which are recorded in getVarModsStr().

4. Using ms_aahelper to fragment peptide matches with query-level modifications

ms_aahelper::calcFragments() and ms_aahelper::calcFragmentsEx() are used for generating the fragment masses of a peptide match. The functions take an ms_peptide object as the first argument.

The peptide match object can have query-level modifications (a non-empty getLocalModsStr()). In this case, the query-level modifications are only included in fragment mass calculation if the peptide object is directly related to the results file with which the ms_aahelper object was initialised. That is, to calculate the right fragments for peptide matches with query-level modifications:

  1. Open the results file using ms_mascotresfile.
  2. Create an ms_aahelper object using the ms_mascotresfile object.
  3. Create an ms_peptidesummary object using the same ms_mascotresfile object.
  4. Find the peptide you want to fragment using e.g. ms_peptidesummary::getPeptide().
  5. Pass the peptide object to ms_aahelper::calcFragmentsEx().

If the peptide object comes from a different file or if you initialise ms_aahelper without a results file, fragmentation will not take query-level modifications into account and some of the fragment masses will be incorrect.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Spectral libraries
[Mascot results file module]

Spectral library search results

Mascot 2.6 and later can search spectral libraries in parallel with a FASTA database. This page deals with opening spectral library search results using the standard Parser interface. If you need to read spectral library files (in MSP format), see Classes for reading and writing spectral libraries.

By default, Parser opens spectral library results in backwards-compatible mode, where spectral library matches are invisible. Enabling spectral library support in code using Parser is more involved than just setting a constructor flag. Please study the list of methods under Spectral library API summary. Many of the methods listed either take a new argument in Parser 2.6 to differentiate between FASTA and library matches, or they interpret existing arguments differently depending on mode.

For example, ms_peptidesummary::getPeptideThreshold() takes an optional rank parameter. You should always specify it, because Mascot and library matches have different score thresholds. If you don't give a rank to the method, it will choose the score threshold based on the rank 1 match.

Detecting and opening spectral library results

To detect whether a results file contains spectral library matches, the easiest test is ms_mascotresfile::anyPeptideSummaryMatches(). If the test returns true for SEC_LIBRARYPEPTIDES, the results file has a non-empty section containing spectral library matches and the file can be opened as a spectral library search.

Three modes are available:

  1. FASTA-only mode (no flag): The backwards-compatible default is to hide spectral library matches.
    If the search contains only spectral library matches, then opening the file in this mode means there are no matches available at all.
  2. SL-only mode (MSPEPSUM_SL_ONLY): Show only spectral library matches.
    If the search contains only FASTA matches, then opening the file in this mode means there are no matches available at all.
  3. Integrated mode (MSPEPSUM_SL_INTEGRATED): The integrated library mode is similar to the integrated error tolerant mode (see Integrated error tolerant search). A query can contain a mixture of up to 20 FASTA and library matches, and protein accessions can come from both the FASTA file and the spectral library (or its reference database -- see Protein inference in spectral library searches).
    If the search contains only FASTA matches or only spectral library matches, the integrated mode is equivalent to the FASTA-only or SL-only mode, respectively.

The helper function ms_mascotresfile::get_ms_mascotresults_params() does not set MSPEPSUM_SL_ONLY or MSPEPSUM_SL_INTEGRATED automatically. This means code written for Parser 2.5 and earlier always opens spectral library search results in FASTA-only mode.

Parser 2.6 and Mascot 2.6 do not support the following search types in combination with spectral libraries:

  • decoy searching
  • error tolerant searching
  • Percolator
  • quantitation methods(*)

(*) Reporter quantitation may work; it depends on spectral library matches having the correct set of modifications (see How modifications are encoded). Other types of quantitation will not work with library matches.

Opening the file in SL-only mode

To open the file in SL-only mode, pass the flag MSPEPSUM_SL_ONLY to the matrix_science::ms_peptidesummary constructor.

The default value for minProbability, 0.05, corresponds to a score threshold of 300 (see Library scores and thresholds). To convert a raw score to a value suitable as minProbability, see ms_peptidesummary::getMinProbabilityForSLScore().

Opening the file in integrated mode

To open the file in integrated mode, pass the flag MSPEPSUM_SL_INTEGRATED to the matrix_science::ms_peptidesummary constructor. Observe the following points:

  • As in integrated error tolerant mode, each query can have up to ms_mascotresults::getMaxRankValue() matches. Matches within a query are sorted by expect value.
  • Library score threshold is determined from matching the mean and standard deviation of FASTA and library scores in queries where there is a significant top rank FASTA match and top rank library match to the same sequence (see below).
  • Protein inference prefers FASTA accessions over library accessions (see Protein inference in spectral library searches).

Library scores and thresholds

In Mascot 2.6, the spectral library search tool is the NIST MSPepSearch. Library scores range from 0 to 1000, with 0 meaning the observed spectrum and the library match are entirely dissimilar, and 1000 meaning they are identical. Library scores are obviously on a very different scale from Mascot scores, which have no particular upper limit (although a score of a couple hundred is extremely unusual). FASTA matches and library matches must have different score thresholds.

If a query contains both FASTA and library matches, and you open the file in integrated mode, there are three thresholds of interest:

  • the Mascot identity threshold
  • the Mascot homology threshold
  • the library score threshold

The library score threshold is global -- it applies to all queries in the search -- whereas Mascot thresholds are specific to a query. However, in order to retain a compatible API, functions that return the identity threshold may return either the Mascot identity or the library score threshold, depending on function arguments. Functions that return the homology threshold will always return zero for spectral library matches.

For example, the following functions take a new argument that determines which threshold is of interest:

  • matrix_science::ms_mascotresults::getAvePeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getHomologyThresholdForHistogram
  • matrix_science::ms_mascotresults::getIonsScoreHistogram
  • matrix_science::ms_mascotresults::getMaxPeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getPeptideIdentityThreshold

The type of the score returned by ms_peptide::getIonsScore() depends on the type of the match. Use ms_peptide::getIsFromLibrary() to find out.

The expect value of a spectral library match is a function of its score and threshold, as usual.

For details on how the library score threshold is derived, see Advanced reading: calculating the spectral library score threshold.

Protein inference in spectral library searches

Protein inference in SL-only or integrated mode uses the same rules as in FASTA-only mode and previous versions of Parser. The main differences are the source of protein data for spectral library matches, and the treatment of "ties" between otherwise equivalent accessions, e.g., when choosing a representative family member or sameset protein.

During a library search, a library match can be mapped to a FASTA accession, library accession or both. FASTA accession in this context means an accession from a FASTA database that is part of the same search. Library accession means an accession from the reference database of the spectral library, or an accession from the MSP file if the sequence was not found in the reference database; see the Mascot help for more information on reference databases.

The search can be opened in integrated or SL-only mode. In SL-only mode, spectral library matches appear only under library accessions. It is as if the FASTA database was not searched at all, so protein inference is the same as in a single database search.

In integrated mode, a spectral library match can be mapped to a FASTA accession or a library accession or both. There are therefore potentially many more sameset and subset proteins. The situation is more even complicated if the spectral library has a reference database that is not part of the search.

Database number and type

Here are some of the possible database, library and reference database combinations:

A. One library (getNumberOfDatabases() == 1)
  1. NIST_S.cerevesiae_IonTrap (SL)
  2. SwissProt (SLREF of 1)
B. One library, one FASTA; FASTA is not reference db (getNumberOfDatabases() == 2)
  1. NIST_S.cerevisiae_IonTrap (SL)
  2. UniProt_Yeast (AA)
  3. SwissProt (SLREF of 1)
C. Two libraries with same reference db (getNumberOfDatabases() == 2)
  1. NIST_S.cerevisiae_IonTrap (SL)
  2. PRIDE_Contaminants (SL)
  3. SwissProt (SLREF of 1 and 2)
D. Two libraries, one FASTA that is a reference db (getNumberOfDatabases() == 3)
  1. NIST_S.cerevisiae_IonTrap (SL)
  2. PRIDE_S.cerevisiae (SL)
  3. SwissProt (AA, also ref of 1)
  4. UniProt_Yeast (SLREF of 2)

The string in parentheses (AA, SL, SLREF) is the database type. The numbers refer to the database number. This is normally in the interval 1..ms_searchparams::getNumberOfDatabases(), except that reference databases have index numbers after this range. It is possible for a FASTA database to be both part of the search and a spectral library's reference database.

Parser assigns reference accessions the database number of the relevant spectral library, so most of the time you do not need to worry about the difference. For example, in case C of two libraries with the same reference database, an accession from SwissProt (e.g., KPYK1_YEAST) can appear under either database number, "1::KPYK1_YEAST" and "2::KPYK2_YEAST". Matches from the first library searched appear under "1::KPYK1_YEAST", and matches from the second under "2::KPYK2_YEAST". (Protein inference may of course make one a subset of the other.) Database numbers above ms_searchparams::getNumberOfDatabases() do not appear in ms_protein::getDB().

You can access the database type and the mapping between spectral library index and reference database index with ms_mascotresfile::getDatabaseType(), ms_mascotresfile::getReferenceDatabaseNumberOfSL() and ms_mascotresfile::getSLDatabaseNumbersOfReference().

FASTA accessions are preferred over reference and library accessions

Parser prioritises FASTA accessions over reference accessions and reference accessions over MSP accessions in protein inference. For example, if a FASTA accession and a reference accession have the same set of significant sequences, Parser will choose the FASTA accession as the representative protein and relegate the reference accession to sameset status. If a FASTA accession is the superset protein of a library accession (of either kind), the library accession is removed entirely. This prioritisation is necessary to simplify the output of protein inference and remove redundancies.

Reference database name matters in external lookups

The mass and description of reference accessions are not saved in the results file. This means ms_mascotresults::getProteinDescription() returns the empty string for reference accessions. The description of an MSP accession may or may not be available, depending on what the MSP file contained at the time of the search.

When you need to look up a protein attribute like mass, description, pI or taxonomy information from an external source, you need to know what the correct source database is. If the protein comes from a FASTA file (database type AA or NA), the source database is the FASTA file. But if the protein comes from a spectral library (database type SL), you need to target the query at the reference database. You can find the reference database number with ms_mascotresfile::getReferenceDatabaseNumberOfSL() and the reference database name with ms_searchparams::getDB().

How modifications are encoded

Modifications are encoded differently between FASTA matches and spectral library matches. In a FASTA-only search, you can specify both fixed and variable modifications, as well as have query-level modifications and modifications as part of a quantitation method. In an SL-only or integrated library search, none of these modifications are used for spectral library matches.

Spectral library matches can contain their own modifications, which you can access with ms_mascotresults::getLibraryModString(). The modifications originate from the spectral library entry. The results file contains a list of all possible library modifications in the spectral libraries searched; see ms_searchparams::getLibraryModName(). It is possible for fixed and variable modifications to have the same name as a library modification, and vice versa. Whether they are the same modification depends entirely on how the spectral library was created.

Other attributes specific to spectral libraries

The results file contains a back reference for each spectral library match that allows you to look up the corresponding library entry from the spectral library file. See ms_peptidesummary::getLibraryEntryId() for more details.

Spectral library API summary

For more details on spectral library specific behaviour, see the following classes and functions:

ms_searchparams
  • matrix_science::ms_searchparams::getDB
  • matrix_science::ms_searchparams::getLibraryModName
  • matrix_science::ms_searchparams::getLibraryModDelta
  • matrix_science::ms_searchparams::getNumberOfLibraryMods
  • matrix_science::ms_searchparams::getLIBRARY_SEARCH

ms_mascotresfile
  • matrix_science::ms_mascotresfile::anyPeptideSummaryMatches
  • matrix_science::ms_mascotresfile::getDatabaseType
  • matrix_science::ms_mascotresfile::getFastaPath
  • matrix_science::ms_mascotresfile::getFastaVer
  • matrix_science::ms_mascotresfile::getNumLibraryEntries
  • matrix_science::ms_mascotresfile::getReferenceDatabaseNumberOfSL
  • matrix_science::ms_mascotresfile::getSLDatabaseNumbersOfReference
  • matrix_science::ms_mascotresfile::isDatabaseTypeAvailable
  • matrix_science::ms_mascotresfile::SEC_LIBRARYPEPTIDES
  • matrix_science::ms_mascotresfile::SEC_SPECTRAL_LIBRARY
  • matrix_science::ms_mascotresfile::SEC_LIBRARYSUMMARY
  • matrix_science::ms_mascotresfile::getSLFragmentTolerance
  • matrix_science::ms_mascotresfile::getSLFragmentToleranceUnit

ms_mascotresults
  • matrix_science::ms_mascotresults::getAvePeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getHomologyThresholdForHistogram
  • matrix_science::ms_mascotresults::getIonsScoreHistogram
  • matrix_science::ms_mascotresults::getLibraryModString
  • matrix_science::ms_mascotresults::getMaxPeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getMaxRankValue
  • matrix_science::ms_mascotresults::getNumDecoyHitsAboveHomology
  • matrix_science::ms_mascotresults::getNumDecoyHitsAboveIdentity
  • matrix_science::ms_mascotresults::getNumDiscoveredLibraryMods
  • matrix_science::ms_mascotresults::getNumHitsAboveHomology
  • matrix_science::ms_mascotresults::getNumHitsAboveIdentity
  • matrix_science::ms_mascotresults::getPeptideIdentityThreshold
  • matrix_science::ms_mascotresults::getPeptideExpectationValue
  • matrix_science::ms_mascotresults::getProteinDescription
  • matrix_science::ms_mascotresults::getQmatch
  • matrix_science::ms_mascotresults::getThresholdForFDRAboveHomology
  • matrix_science::ms_mascotresults::getThresholdForFDRAboveIdentity

ms_peptidesummary
  • matrix_science::ms_peptidesummary::getLibraryEntryId
  • matrix_science::ms_peptidesummary::getMinProbabilityForSLScore
  • matrix_science::ms_peptidesummary::getPeptideThreshold
  • matrix_science::ms_peptidesummary::getSLThresholdFromMinProbability
  • matrix_science::ms_peptidesummary::MSPEPSUM_SL_INTEGRATED
  • matrix_science::ms_peptidesummary::MSPEPSUM_SL_ONLY

ms_peptide
  • matrix_science::ms_peptide::getExpectationValue
  • matrix_science::ms_peptide::getIonsScore
  • matrix_science::ms_peptide::getIsFromLibrary

ms_libraryoptions
  • matrix_science::ms_libraryoptions

ms_spectral_lib_file
  • matrix_science::ms_spectral_lib_file

ms_spectral_lib_entry
  • matrix_science::ms_spectral_lib_entry

ms_spectral_lib_peak
  • matrix_science::ms_spectral_lib_peak

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Spectral library score threshold (advanced reading)
[Mascot results file module]

Advanced reading: calculating the spectral library score threshold

Warning: The details of how the spectral library score threshold is calculated is not required reading. The API is described in section Spectral library search results. The sections below are intended for reference only.

Score excess over threshold

The expect value, library match "significance" and library score contribution to protein score all use the basic concept of score excess over threshold. This is simply score - thr: the higher the excess, the lower the expect value and vice versa. A match score exactly at the threshold has excess zero. Similarly, only library matches with excess above zero contribute to the protein score.

Score excess is used in a similar way with Mascot scores and FASTA matches. The main difference is that Mascot score threshold is specific to a query.

The library score excess is calculated differently depending on which mode is active, integrated mode or SL-only mode. However, since the model in both cases is not a true statistical model, the phrase "library score is significant" should be interpreted very loosely. It simply means the score is above threshold (score excess is positive).

Score excess, threshold and expect value in integrated mode

In integrated mode, the library score excess is derived from matching the mean and standard deviation of library scores to the mean and standard deviation of Mascot score excess. This yields a formula for converting raw library scores to values equivalent to the Mascot score excess:

    excess(s) = mascot.mean + mascot.stdev * (s - library.mean) / library.stdev

The formula simply standardises library scores, then rescales them. Here s is the raw library score. The values for mascot.mean, mascot.stdev, library.mean and library.stdev are calculated from queries where the FASTA and library matches have the same sequence and the Mascot match is significant:

  1. Iterate over all queries. If a query contains a significant rank 1 FASTA match and a library match at rank 2 with the same sequence, add the paired score (mascot.excess, library.score) to the list. mascot.excess = mascot.score - mascot.thr is the score excess over threshold for the rank 1 match.
  2. Calculate the mean and standard deviation of mascot.excess in this list; store in mascot.mean and mascot.stdev.
  3. Calculate the mean and standard deviation of library.score in this list; store in library.mean and library.stdev.

The procedure can be justified if you look at the paired score distribution in large integrated library searches. Queries that match the same peptide sequence in both the protein sequence database and the spectral library show high correlation between Mascot score and library score. The shapes of the Mascot score distribution and the library score distribution are also quite similar, although the similarity breaks down in small searches or searches with few matches from one or the other search engine.

The formula is valid for all library scores in the search, not just those used in the above calculation. This is because MSPepSearch scores are on an absolute scale with a finite range, and scores between different spectra seem to be very well calibrated.

Now that we can compute the equivalent score excess for library matches, the expect value can be calculated using the same formula as for Mascot scores, namely

    E(s) = minProbability * 10 ** (-excess(s)/10)

Here minProbability is the significance threshold argument given to the ms_peptidesummary constructor. An excess of zero gives E(s) = minProbability, while high excess gives low expect value.

The library score threshold is now easy to calculate: it is the score s for which score excess is zero. Equivalently, it is the score s for which E(s) = minProbability. Note that unlike with Mascot scores, the library score threshold is calculated after expect values are already known.

The score excess is also used in calculating protein scores; see Protein scores below.

As a small numerical example, suppose the search contains ten queries with the following matches:

Query | Rank | Match | Source
1 | (no matches)
2 | 1 | CIPALDSLTPANEDQK, score = 51, thr = 13 | AA
 | 2 | CIPALDSLTPANEDQK, score = 524 | SL
3 | 1 | SLNNQIETLLTPEGSR, score = 21, thr = 33 | AA
4 | (no matches)
5 | 1 | ENNEQLR, score = 22, thr = 20 | AA
 | 2 | ENNEQLR, score = 300 | SL
6 | 1 | NIHMWCAMR, score = 101 | SL
7 | 1 | TLNDELEIIEGMOK, score = 40, thr = 25 | AA
7 | 2 | TLNDELELIEGMOK, score = 255 | SL
8 | 1 | NSGGNNNTTDLK, score = 39, thr = 16 | AA
 | 2 | NSGGNNNTTDLK, score = 428 | SL
9 | (no matches)
10 | 1 | LYGTDDNTQEVEAVTNK, score = 61, thr = 36 | AA
 | 2 | LYGTDDNTQEVEAVTNK, score = 384 | SL

Queries 1, 4 and 9 contribute nothing, since they have no matches.

Queries 3 and 6 don't contribute, since either the FASTA or the library match is missing. In query 3, another problem is that the FASTA match is below threshold, so not significant.

Query 7 doesn't contribute, since there is no library match to the same sequence (the match is to a slightly different sequence).

From the remaining queries, the data set is the pairs of scores from query 2 (38, 524), query 5 (2, 300), query 8 (23, 428) and query 10 (25, 384). The statistics will not be meaningful with such a small sample, but for the sake of completeness, we get mascot.mean = 22, mascot.stdev = 14.9, library.mean = 409 and library.stdev = 93.3. The transformed library score excess for the matches in queries 2, 5, 6, 7, 8 and 10 are excess(524) = 40.4, excess(300) = 4.6, excess(101) = -27.2, excess(255) = -2.6, excess(428) = 25.0 and excess(384) = 18.0. The score excess is similar to the Mascot score excess, which is a feature of many real-life data sets as well.

Score excess, threshold and expect value in SL-only mode

In SL-only mode, there are no Mascot scores, so there is no reference point based on an existing model. We discovered during the development of Mascot 2.6 that library score 300 is a rough but consistent estimate of a "universal" score threshold in MS/MS searches at approximately 5% level of significance. This observation might not be valid for small spectral libraries or small searches.

Unlike in integrated mode, score excess and the effective threshold are calculated from the following expect value formula:

  E(s) = 0.05 * 10 ** (-(s - 300)/100)

Here s is the raw library score. Note especially that minProbability does not appear in the formula.

The library score threshold is the value of s for which E(s) = minProbability; this is the same criterion as in the integrated case. If minProbability is the default 0.05, then library score threshold is 300. Note that again the expect value is known before the library score threshold, which is the same as in the integrated case but different from FASTA-only searches.

The library score excess is simple: find the library score threshold thr, and let excess = score - thr. The excess is on the library score scale rather than a scale equivalent to Mascot score excess.

The score excess is used in calculating protein scores; see Protein scores below.

Protein scores

It's recommended to use MudPIT scoring with spectral library searches. The calculation is explained in ms_protein::getScore(). In SL-only mode, the contribution of a match is the raw library score excess. In integrated mode, the contribution is the Mascot-equivalent score excess (see excess(s) in Score excess, threshold and expect value in integrated mode).

Note that even if you select standard scoring, the protein score calculation always uses the uncorrected match score; there is no multiplicity correction.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_inputquery
Public Member Functions

ms_inputquery Class Reference
[Mascot results file module]

This class encapsulates the input data in the mascot results file. More...

#include <ms_inputquery.hpp>

Collaboration diagram for ms_inputquery:
[legend]

List of all members.

Public Member Functions

ms_inputquery (const ms_mascotresfile &resfile, const int q)
Use this contructor to create an object to get the input data.
std::string | getCharge () const
Returns a string that represents the supplied charge for the query.
std::string | getComp (int comp_no) const
Returns a string that represents one of the sequence queries.
int | getIndex () const
Returns the zero based index of the peak list in an MGF, PKL or DTA file.
std::string | getINSTRUMENT (const bool unescaped=true) const
Returns an INSTRUMENT string if this has been specified at the query level.
double | getIntMax () const
Returns the maximum intensity of any ion.
double | getIntMin () const
Returns the minimum intensity of any ion.
double | getIonMobility () const
Returns the ion mobility of any ion.
std::string | getIT_MODS (const bool unescaped=true) const
Returns the names of variable modifications if such have been specified at the query level.
std::string | getLocalVarModName (const int num) const
Returns the query-level modification name by 1-based index.
std::string | getLocus () const
Returns the locus specified in the MGF file using the LOCUS= line.
double | getMassMax () const
Returns the maximum mass of any ion.
double | getMassMin () const
Returns the minimum mass of any ion.
double | getMaxInternalMass () const
Returns the maximum mass to be considered for internal fragments if an INSTRUMENT has been specified at the query level.
double | getMinInternalMass () const
Returns the minimum mass to be considered for internal fragemnts if an INSTRUMENT has been specified at the query level.
int | getNumberOfLocalVarMods () const
Returns the name of query-level variable modifications.
int | getNumberOfPeaks (const int ions)
Returns the number of ions peaks in an ms-ms spectrum.
int | getNumUsed () const
Returns the number of ions used for matching - value no longer available.
int | getNumVals () const
Returns the number of ions.
double | getPeakIntensity (const int ions, const int peakNo)
Returns the intensity of a particular ions peak.
std::vector< std::pair< double,
double > > 		getPeakList (const int ions)
Returns a list of ions peaks for a query.
double | getPeakMass (const int ions, const int peakNo)
Returns the mass of a particular ions peak.
double | getPepTol () const
Returns the peptide tolerance for this query.
std::string | getPepTolString () const
Returns the peptol string .
std::string | getPepTolUnits () const
Returns the peptide tolerance units for this query.
std::string | getRawfile () const
Returns the rawfile specified in the MGF file using the RAWFILE= line.
void | getRawScans (std::vector< int > &index, std::vector< std::string > &rawscans) const
Returns all rawscan numbers that were used to generate this peak list.
std::string | getRawScans (const int rawFileIdx=-1) const
Returns the rawscan number(s) that were used to generate this peak list.
std::string | getRetentionTimes (const int rawFileIdx=-1) const
Returns the retention time(s) in seconds of the scans that were used to generate this peak list.
void | getRetentionTimes (std::vector< int > &index, std::vector< std::string > &times) const
Returns all retention times in seconds of the scans that were used to generate this peak list.
std::string | getRULES () const
Returns the instrument rules if this has been specified at the query level.
void | getScanNumbers (std::vector< int > &index, std::vector< std::string > &scans) const
Returns all scan numbers that were used to generate this peak list.
std::string | getScanNumbers (const int rawFileIdx=-1) const
Returns the scan number(s) that were used to generate this peak list.
std::string | getSeq (int seq_no) const
Returns a string that represents one of the sequence queries..
std::string | getStringIons1 (bool includeCharges=false)
Returns the peak list for the ions as a string.
std::string | getStringIons2 (bool includeCharges=false)
Returns the peak list for the ions as a string.
std::string | getStringIons3 (bool includeCharges=false)
Returns the peak list for the ions as a string.
std::string | getStringTitle (bool unescaped) const
Returns the title for the ms-ms data (if any).
std::string | getTag (int tag_no) const
Returns a string that represents one of the sequence tag queries.
double | getTotalIonsIntensity ()
Returns the sum of all the ions intensities.

Detailed Description

This class encapsulates the input data in the mascot results file.

Although all these parameters could be obtained using the lower level functions such as ms_mascotresfile::getQuerySectionValue it is generally more convenient to use this object.

Examples:

resfile_input.cpp.

Constructor & Destructor Documentation

ms_inputquery | ( | const ms_mascotresfile & | resfile,
 |  | const int | q
 | ) |  |

Use this contructor to create an object to get the input data.

Constructor for ms_inputquery.

See Maintaining object references: two rules of thumb.

Parameters:
resfile | Must be a valid ms_mascotresfile object.
q | is the query number and must be in the range 1 to ms_mascotresfile::getNumQueries().

Member Function Documentation

std::string getCharge ( ) const

Returns a string that represents the supplied charge for the query.

This value will only be present if a charge was specified at the query level in the input (MGF, PKL, mzData, DTA) file. It will normally be one of the following strings:

  • '8-'
  • '7-'
  • '6-'
  • '5-'
  • '4-'
  • '3-'
  • '2- and 3-'
  • '2-'
  • '1-, 2- and 3-'
  • '1-'
  • 'Mr'
  • '1+'
  • '1+, 2+ and 3+'
  • '2+'
  • '2+ and 3+'
  • '3+'
  • '4+'
  • '5+'
  • '6+'
  • '7+'
  • '8+'

The charge can also be any comma separated list of charge states.

See also:
http://www.matrixscience.com/help/search_field_help.html#TWO for further information.

The default charge states are available from ms_searchparams::getCHARGE. Use ms_peptide::getCharge to return the actual charge state that was used for a peptide match.

Returns:
The charge(s) as a string.
std::string getComp ( int comp_no ) const

Returns a string that represents one of the sequence queries.

Up to 20 sets of composition data can be entered for each peptide mass.

See also:
http://www.matrixscience.com/help/search_field_help.html#QUE for further information.
Parameters:
comp_no is an index for the comp() command. The input data is available as COMP1, COMP2 COMP3 etc. To get all composition data, call this function with numbers from 1 to 20.
Returns:
the comp() command as a string
int getIndex ( ) const

Returns the zero based index of the peak list in an MGF, PKL or DTA file.

In Mascot 2.3 and later, the index of each spectrum is saved as an index= value in each query section. This can be useful, because the query numbers are not the same as the index into the text file, and if there are non-unique titles, then it is hard to get back from the query to the original spectrum in the MGF, PKL or DTA file

The index is stored in mzIdentML files using the CV term:

   [Term]
   id: MS:1000774
   name: multiple peak list nativeID format
   def: "index=xsd:nonNegativeInteger" [PSI:MS]
   comment: Used for conversion of peak list files with multiple spectra, i.e. MGF, PKL, merged DTA files. Index is the spectrum number in the file, starting from 0.
   is_a: MS:1000767 ! native spectrum identifier format
Returns:
A zero based index, or -1 if the value is not available.
std::string getINSTRUMENT ( const bool unescaped = true ) const

Returns an INSTRUMENT string if this has been specified at the query level.

This string will always be empty for versions of Mascot prior to 2.2.

A value is only returned when INSTRUMENT is specified in the MGF file. For example:

     BEGIN IONS
     PEPMASS=1234
     INSTRUMENT=ETD_TRAP
     50 1
     100 3
     400 5
     END IONS

The value is obtained from the INSTRUMENT= line in the relevant query section of the results file. If there is no instrument specified at the query level, then the INSTRUMENT specified in the search form is used. This can be retrieved using ms_searchparams::getINSTRUMENT().

See also ms_inputquery::getRULES(). It is preferable to use the rules rather than this name to determine which ions series were searched since the user can change the definition of the instrument name.

See also:
http://www.matrixscience.com/help/search_field_help.html#INSTRUMENT for further information.
Parameters:
unescaped has to be TRUE for human-readable instrument name and FALSE for generating input for a mascot search.
Returns:
The INSTRUMENT string, or an empty string if no instrument was specified at the query level.
double getIntMax ( ) const

Returns the maximum intensity of any ion.

Returns:
The maximum intensity. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the maximum intensity of any ion.
double getIntMin ( ) const

Returns the minimum intensity of any ion.

Returns:
The minimum intensity. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the minimum intensity of any ion.
double getIonMobility ( ) const

Returns the ion mobility of any ion.

Returns:
The ion mobility.
std::string getIT_MODS ( const bool unescaped = true ) const

Returns the names of variable modifications if such have been specified at the query level.

This string will always be empty for versions of Mascot prior to 2.2.

A value is only returned when variable modifications are specified in the MGF file. For example:

     BEGIN IONS
     PEPMASS=1234
     IT_MODS=Phospho (STY)
     50 1
     100 3
     400 5
     END IONS

The value is obtained from the IT_MODS= line in the relevant query section of the results file. If there are no modifications specified at the query level, then the IT_MODS specified in the search parameters are used. These can be retrieved using ms_searchparams::getIT_MODS().

See also:
http://www.matrixscience.com/help/search_field_help.html#MODS
Parameters:
unescaped has to be TRUE for human readable modification names and FALSE for generating input for a mascot search.
Returns:
The IT_MODS string, or an empty string if no local modifications were specified.
std::string getLocalVarModName ( const int num ) const

Returns the query-level modification name by 1-based index.

This method returns unescaped modification names as returned by getIT_MODS(), but accessible with a 1-based numerical index. You can produce the same vector of modification titles by splitting the return value of getIT_MODS(true) on comma ",".

Parameters:
num Index of the query-level modification between 1 and getNumberOfLocalVarMods().
Returns:
The modification name, or the empty string if num is outside the index range.
std::string getLocus ( ) const

Returns the locus specified in the MGF file using the LOCUS= line.

LOCUS is an optional attribute for an MS-MS peak list in an MGF file.

LOCUS was introduced in Mascot 2.4

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Returns:
The locus= value in the query section.
double getMassMax ( ) const

Returns the maximum mass of any ion.

Returns:
The maximum mass. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the maximum mass of any ion.
double getMassMin ( ) const

Returns the minimum mass of any ion.

Returns:
The minimum mass. Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the minimum mass of any ion.
double getMaxInternalMass ( ) const

Returns the maximum mass to be considered for internal fragments if an INSTRUMENT has been specified at the query level.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section of the results file as INTERNALS=min,max. If there is no INTERNALS= line, the default value of 700.0 is returned. A different instrument can be specified for each MS-MS spectrum, in which case the values are returned using this function and ms_inputquery::getMinInternalMass

See also:
getMinInternalMass(), getRULES() and getINSTRUMENT()
Returns:
The maximum internal mass considered for this spectrum in this search If no instrument was specified at the query level, then this function will return -1.
double getMinInternalMass ( ) const

Returns the minimum mass to be considered for internal fragemnts if an INSTRUMENT has been specified at the query level.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section of the results file as INTERNALS=min,max. A different instrument can be specified for each MS-MS spectrum, in which case the values are returned using this function and ms_inputquery::getMaxInternalMass.

See also:
ms_searchparams::getMinInternalMass(), ms_searchparams::getMaxInternalMass()
Returns:
The minimum internal mass considered for this spectrum in this search. If no instrument was specified at the query level, then this function will return -1.
int getNumberOfLocalVarMods ( ) const

Returns the name of query-level variable modifications.

Returns:
The number of unescaped modification names from getIT_MODS().
int getNumberOfPeaks ( const int ions )

Returns the number of ions peaks in an ms-ms spectrum.

See also:
getPeakList(), getPeakMass() and getPeakIntensity()

The 'ions' value will normally be '1'. For ms-ms data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series -- see http://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as ions1, ions2 and ions3 in the results file. For data uploaded from a file, only ions1 values will be found.

The ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
ions will be a value of 1..3.
Returns:
The number of peaks in the peak list.
int getNumUsed ( ) const

Returns the number of ions used for matching - value no longer available.

This value is always saved as '-1' in the results files, so this function always returns -1. To find the number of ions peaks used for scoring, see ms_peptide::getPeaksUsedFromIons1, ms_peptide::getPeaksUsedFromIons2 and ms_peptide::getPeaksUsedFromIons3.

Returns:
-1
int getNumVals ( ) const

Returns the number of ions.

This is retrieved from the num_vals= line of the query section.

Even if ions are entered as ions(b- ...), ions(y-...) and ions(...), this function returns the number of all ions.

Returns:
The number of ions.
double getPeakIntensity | ( | const int | ions,
 |  | const int | peakNo
 | ) |  |

Returns the intensity of a particular ions peak.

See also:
getPeakList(), getNumberOfPeaks() and getPeakMass()

The 'ions' value will normally be '1'. For ms-ms data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series -- see http://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as ions1, ions2 and ions3 in the results file. For data uploaded from a file, only ions1 values will be found.

The ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
ions | will be a value of 1..3.
peakNo | should be in the range 1.. getNumberOfPeaks().
Returns:
If there is no peak information, then the return value will be 0.
std::vector< std::pair< double, double > > getPeakList ( const int ions )

Returns a list of ions peaks for a query.

This function only works from C++

For other languages, Use getNumberOfPeaks(), getPeakMass() and getPeakIntensity() instead.

The 'ions' value will normally be '1'. For MS-MS data entered via the sequence query, it is possible to specify that values are part of a b-series, y-series or either series -- see http://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as ions1, ions2 and ions3 in the results file. For data uploaded from a file, only ions1 values will be found.

The ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
ions ions value, can be 1, 2 or 3
Returns:
The peak list.
double getPeakMass | ( | const int | ions,
 |  | const int | peakNo
 | ) |  |

Returns the mass of a particular ions peak.

See also:
getPeakList(), getNumberOfPeaks() and getPeakIntensity()

The 'ions' value will normally be '1'. For ms-ms data entered via the sequence query, it is possible to specify that values are part of b-series, y-series or either series -- see http://www.matrixscience.com/help/sq_help.html#IONS.

If all three types of ions are entered, then the separate values will be saved as ions1, ions2 and ions3 in the results file. For data uploaded from a file, only ions1 values will be found.

The ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
ions | will be a value of 1..3.
peakNo | should be in the range 1.. getNumberOfPeaks().
Returns:
If there is no peak information, then the return value will be 0.
double getPepTol ( ) const

Returns the peptide tolerance for this query.

peptol(tolerance,unit) may be used to specify a mass tolerance for an individual query, over-riding the search form default. For example, peptol(10,%) or peptol(2,Da).

Returns:
Will return 0 if there is no peptide tolerance override for this query.
std::string getPepTolString ( ) const

Returns the peptol string .

Returns, for example, peptol(2.01,Da). The number is always returned in 'fixed' notation. Trailing zeros apart from the one (if any) after the decimal are removed.

This function is intended to be used to create a sequence query string rather than for use to display in a report.

See also:
getPepTolUnits(), getPepTol()
Returns:
Will return an empty string if there is no peptide tolerance override for this query.
std::string getPepTolUnits ( ) const

Returns the peptide tolerance units for this query.

In the search form, the command peptol(tolerance,unit) may be used override the default mass tolerance for an individual query. For example, peptol(10,%) or peptol(2,Da).

The units will be one of:

%%
fraction expressed as a percentage
mmu
absolute milli-mass units, i.e. units of .001 Da
Da
absolute units of Da
ppm
fraction expressed as parts per million
Da
absolute units of Da
Returns:
Will return an empty string if there is no peptide tolerance override for this query.
std::string getRawfile ( ) const

Returns the rawfile specified in the MGF file using the RAWFILE= line.

RAWFILE is an optional attribute for an MS-MS peak list in an MGF file.

RAWFILE was introduced in Mascot 2.4.

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Returns:
The rawfile= value in the query section.
std::string getRawScans ( const int rawFileIdx = -1 ) const

Returns the rawscan number(s) that were used to generate this peak list.

RAWSCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rawscans" with no brackets or zero or more "rawscans[i]" lines.

If rawFileIdx is -1, this method returns the unbracketed value. Otherwise, an individual bracketed line is retrieved.

To retrieve all unbracketed and bracketed values, use ms_inputquery::getRawScans(std::vector<int>&, std::vector<std::string>&).

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters:
rawFileIdx is the raw file index for MGF files that were created from multiple raw files.
Returns:
The scan number(s) in the form a[[-b][,c[-d]]]
void getRawScans | ( | std::vector< int > & | index,
 |  | std::vector< std::string > & | rawscans
 | ) |  | const

Returns all rawscan numbers that were used to generate this peak list.

RAWSCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rawscans" with no brackets or zero or more "rawscans[i]" lines.

This method returns all rawscans lines, bracketed or not. The elements returned in index are the indices, and the corresponding elements in scans are the values. For example, if the query section has

 rawscans=sn13

then both index and times will have one element. index[0] will be -1 (unbracketed) and rawscans[0] will be sn13. If the query section instead has

 rawscans[3]=sn13
 rawscans[5]=sn24

then index[0] == 3, index[1] == 5 and rawscans[0] == "sn13", rawscans[1] == "sn24".

If you already know which lines are present in the query section, you can use ms_inputquery::getRawScans(const int) to access the individual lines.

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters:
[out] | index | Vector of index numbers for corresponding "rawscans" lines. Unbracketed line has index -1, and the other indices start from 0.
[out] | rawscans | Vector of values from the "rawscans" lines in the same order as the index vector.
void getRetentionTimes | ( | std::vector< int > & | index,
 |  | std::vector< std::string > & | times
 | ) |  | const

Returns all retention times in seconds of the scans that were used to generate this peak list.

RTINSECONDS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rtinseconds" with no brackets or zero or more "rtinseconds[i]" lines.

This method returns all rtinseconds lines, bracketed or not. The elements returned in index are the indices, and the corresponding elements in scans are the values. For example, if the query section has

 rtinseconds=1234.0

then both index and times will have one element. index[0] will be -1 (unbracketed) and times[0] will be 1234.0. If the query section instead has

 rtinseconds[3]=1234.0
 rtinseconds[5]=1244.0

then index[0] == 3, index[1] == 5 and times[0] == 1234.0, times[1] == 1244.0.

If you already know which lines are present in the query section, you can use ms_inputquery::getRetentionTimes(const int) to access the individual lines.

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters:
[out] | index | Vector of index numbers for corresponding "rtinseconds" lines. Unbracketed line has index -1, and the other indices start from 0.
[out] | times | Vector of values from the "rtinseconds" lines in the same order as the index vector.
std::string getRetentionTimes ( const int rawFileIdx = -1 ) const

Returns the retention time(s) in seconds of the scans that were used to generate this peak list.

RTINSECONDS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "rtinseconds" with no brackets or zero or more "rtinseconds[i]" lines.

If rawFileIdx is -1, this method returns the unbracketed value. Otherwise, an individual bracketed line is retrieved.

To retrieve all unbracketed and bracketed values, use ms_inputquery::getRetentionTimes(std::vector<int>&, std::vector<std::string>&).

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters:
rawFileIdx is the raw file index for MGF files that were created from multiple raw files.
Returns:
The retention time(s) in the form v[[-w][,x[-y]]].
std::string getRULES ( ) const

Returns the instrument rules if this has been specified at the query level.

This string will always be empty for versions of Mascot prior to 2.2.

A value is only returned when INSTRUMENT is specified in the MGF file. For example:

     BEGIN IONS
     PEPMASS=1234
     INSTRUMENT=ETD_TRAP
     50 1
     100 3
     400 5
     END IONS

The value is obtained from the RULES= line in the relevant query section of the results file. If there is no instrument specified at the query level, then RULES specified in the search form, and the rules for this query are the global rules which can be retrieved using ms_searchparams::getRULES().

It is preferable to use the rules rather than the instrument name to determine which ions series were searched since the user can change the definition of the instrument name.

See also:
getINSTRUMENT()
Returns:
The RULES string, or an empty string if no instrument was specified. See ms_searchparams::getRULES() for a full definition of the rules.
std::string getScanNumbers ( const int rawFileIdx = -1 ) const

Returns the scan number(s) that were used to generate this peak list.

SCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "scans" with no brackets or zero or more "scans[i]" lines.

If rawFileIdx is -1, this method returns the unbracketed value. Otherwise, an individual bracketed line is retrieved.

To retrieve all unbracketed and bracketed values, use ms_inputquery::getScanNumbers(std::vector<int>&, std::vector<std::string>&).

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters:
rawFileIdx is the raw file index for MGF files that were created from multiple raw files.
Returns:
The scan number(s) in the form a[[-b][,c[-d]]].
void getScanNumbers | ( | std::vector< int > & | index,
 |  | std::vector< std::string > & | scans
 | ) |  | const

Returns all scan numbers that were used to generate this peak list.

SCANS is an optional attribute for an MS-MS peak list in an MGF file.

Separate values for multiple raw files were introduced in Mascot 2.3. The results file may contain "scans" with no brackets or zero or more "scans[i]" lines.

This method returns all scans lines, bracketed or not. The elements returned in index are the indices, and the corresponding elements in scans are the values. For example, if the query section has

 scans=1

then both index and scans will have one element. index[0] will be -1 (unbracketed) and scans[0] will be 1. If the query section instead has

 scans[3]=13
 scans[5]=26

then index[0] == 3, index[1] == 5 and scans[0] == 13, scans[1] == 26.

If you already know which lines are present in the query section, you can use ms_inputquery::getScanNumbers(const int) to access the individual lines.

See also:
http://www.matrixscience.com/help/data_file_help.html#PARAMS
Parameters:
[out] | index | Vector of index numbers for corresponding "scans" lines. Unbracketed line has index -1, and the other indices start from 0.
[out] | scans | Vector of values from the "scans" lines in the same order as the index vector.
std::string getSeq ( int seq_no ) const

Returns a string that represents one of the sequence queries..

Up to 20 sets of sequence information can be entered for each peptide mass.

See also:
http://www.matrixscience.com/help/search_field_help.html#QUE for further information.
Parameters:
seq_no is an index for the seq() command. The input data is available as SEQ1, SEQ2 SEQ3 etc. To get all sequence data, call this function with numbers from 1 to 20.
Returns:
the seq() command as a string.
std::string getStringIons1 ( bool includeCharges = false )

Returns the peak list for the ions as a string.

The ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
includeCharges will add any supplied charges to the returned string, so the format will be: m/z[:intensity[:charge]], m/z[:intensity[:charge]]... if no intensities were applied initially, then the string returned will be the same as if this parameter was false
Returns:
The ions1= value in the form: 136.070000:42.95,175.110000:133.1,299.060000:710.1,415.030000:144.6 . . .
std::string getStringIons2 ( bool includeCharges = false )

Returns the peak list for the ions as a string.

The ions2= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
includeCharges will add any supplied charges to the returned string, so the format will be: m/z[:intensity[:charge]], m/z[:intensity[:charge]]... if no intensities were applied initially, then the string returned will be the same as if this parameter was false
Returns:
The ions2= value in the form: 136.070000:42.95,175.110000:133.1,299.060000:710.1,415.030000:144.6 . . .
std::string getStringIons3 ( bool includeCharges = false )

Returns the peak list for the ions as a string.

The ions3= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Parameters:
includeCharges will add any supplied charges to the returned string, so the format will be: m/z[:intensity[:charge]], m/z[:intensity[:charge]]... if no intensities were applied initially, then the string returned will be the same as if this parameter was false
Returns:
The ions3= value in the form: 136.070000:42.95,175.110000:133.1,299.060000:710.1,415.030000:144.6 . . .
std::string getStringTitle ( bool unescaped ) const

Returns the title for the ms-ms data (if any).

The string will have a maximum length of 30k characters. It might for example be:

1: Scan 2443 (rt=1651.36) [P:\\service\\on_campus\\Nunari\\Laura\\ft20061020.RAW]
Parameters:
unescaped - If this is false, then any non alpha-numeric characters in the string will be converted to %xx where the xx are the hex representation of the character.
Returns:
The title string.
std::string getTag ( int tag_no ) const

Returns a string that represents one of the sequence tag queries.

Up to 20 tag/etag commands can be entered for each peptide mass.

See also:
http://www.matrixscience.com/help/search_field_help.html#QUE for further information.
Parameters:
tag_no is an index for the tag() command. The input data is available as TAG1, TAG2 TAG3 etc. To get all tags, call this function with numbers from 1 to 20.
Returns:
the tag() command as a string in the format e,977.4,[Q|K][Q|K][Q|K]EE,1619.7 where the first character will be 'e' for etag and 't' for tag.
double getTotalIonsIntensity ( )

Returns the sum of all the ions intensities.

See also ms_mascotresfile::getObservedIntensity. If the precursor intensity wasn't supplied in the input file, this function can be called instead. Processing this function for a large number of spectra may take some time since it will need to load the ions1= values from disk and sum all the intensities.

See also ms_peptide::getIonsIntensity which just calls this function.

The ions1= value is read from file 'on demand', so execution of this function can take a while. The data is cached on the first call of one of the following functions:

  • getStringIons1()
  • getStringIons2()
  • getStringIons3()
  • getPeakList()
  • getPeakMass()
  • getPeakIntensity()
  • getNumberOfPeaks()
  • getTotalIonsIntensity()
Returns:
Will return 0 if there is no MS-MS data.
The documentation for this class was generated from the following files:
  • ms_inputquery.hpp
  • ms_inputquery.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_linker_site
Public Member Functions

ms_linker_site Class Reference
[Mascot results file module]

Position of an intact link between alpha and beta peptide or a looplink. More...

#include <ms_linker_site.hpp>

List of all members.

Public Member Functions

ms_linker_site ()
Create a nil linker site.
ms_linker_site (ms_peptide::PSM linkFrom, ms_peptide::PSM linkTo, int siteFrom, int siteTo, int varModIdxFrom, int varModIdxTo, double linkerMass)
Create a linker site.
ms_linker_site (const ms_linker_site &src)
Copying constructor.
~ms_linker_site ()
Destructor.
void | copyFrom (const ms_linker_site *right)
Copies all content from another instance of this class.
double | getLinkerMass () const
Linker mass (Mr).
ms_peptide::PSM | getLinkFrom () const
Source peptide type.
ms_peptide::PSM | getLinkTo () const
Target peptide type.
int | getSiteFrom () const
Linker site index in source peptide.
int | getSiteTo () const
Linker site index in target peptide.
int | getVarModIdxFrom () const
Varmod index at the source site.
int | getVarModIdxTo () const
Varmod index at the target site.
ms_linker_site & | operator= (const ms_linker_site &right)
C++ assignment operator.

Detailed Description

Position of an intact link between alpha and beta peptide or a looplink.

The ms_linker_site class encapsulates the position of an intact link between the alpha and beta peptides, and looplinks in general. The link end points ("from" and "to") may have different variable mod numbers if the sites require different specificities. For example, one end could be a lysine with Xlink:DSS (K) and the other could be N-term with Xlink:DSS (Protein N-term).

Member Function Documentation

double getLinkerMass ( ) const

Linker mass (Mr).

Returns:
Mass of the linker molecule. There is only one mass even if getVarModIdxFrom() and getVarModIdxTo() differ.
ms_peptide::PSM getLinkFrom ( ) const

Source peptide type.

Returns:
ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA
ms_peptide::PSM getLinkTo ( ) const

Target peptide type.

Returns:
ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA
int getSiteFrom ( ) const

Linker site index in source peptide.

Returns:
Integer index between 0 and n+1, where n is the source peptide sequence length.
int getSiteTo ( ) const

Linker site index in target peptide.

Returns:
Integer index between 0 and m+1, where m is the target peptide sequence length.
int getVarModIdxFrom ( ) const

Varmod index at the source site.

The variable mods index could be different between the from and to ends of the link if they have different specificities. For example, getVarModIdxFrom() could be index 1 (Xlink:DSS (K)) and getVarModIdxTo() could be index 3 (Xlink:DSS (Protein N-term)).

Returns:
Varmod index of the linker at the source site.
int getVarModIdxTo ( ) const

Varmod index at the target site.

The variable mods index could be different between the from and to ends of the link if they have different specificities. For example, getVarModIdxFrom() could be index 1 (Xlink:DSS (K)) and getVarModIdxTo() could be index 3 (Xlink:DSS (Protein N-term)).

Returns:
Varmod index of the linker at the target site.
The documentation for this class was generated from the following files:
  • ms_linker_site.hpp
  • ms_linker_site.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_linker_site_vector
Public Member Functions

ms_linker_site_vector Class Reference
[Mascot results file module]

A vector of linker sites. More...

#include <ms_linker_site_vector.hpp>

List of all members.

Public Member Functions

ms_linker_site_vector ()
Create an empty linker site vector.
ms_linker_site_vector (const std::vector< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen)
Create a linker site vector from an STL vector.
ms_linker_site_vector (const ms_linker_site_vector &src)
Copying constructor.
ms_linker_site_vector (const std::list< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen)
Create a linker site vector from an STL list.
~ms_linker_site_vector ()
Destructor.
void | append (const ms_linker_site_vector &src)
Appends all content from another instance of the class.
void | clear ()
Clear the vector.
bool | containsVarModIdx (int idx) const
Return true if the vector contains a link with the given variable mod index.
void | copyFrom (const ms_linker_site_vector *src)
Copies all content from another instance of the class.
bool | empty () const
Boolean test: is the vector empty?
ms_linker_site | get (int idx) const
Return the linker site at the given index.
int | getAlphaVarModsStrLength () const
Return the alpha peptide sequence length.
int | getBetaVarModsStrLength () const
Return the beta peptide sequence length.
int | getVarModIdxOfLinkedSite (const ms_peptide::PSM psmComponent, const int i) const
Return the variable mod index if the PSM component has a link at position i.
ms_linker_site_vector & | operator= (const ms_linker_site_vector &right)
C++ assignment operator.
ms_linker_site pop ()
Pop a value from the end of the vector.
void | push (const ms_linker_site &linkerSite)
Push a new linker site at the end of the vector.
void | set (int idx, const ms_linker_site &linkerSite)
Set the value at the given index.
int | size () const
Return the size of the container.
void | swap (ms_linker_site_vector &right)
Swap the contents with another linker site vector.
const std::vector
< ms_linker_site > & 		toVector () const
C++ conversion to std::vector.

Detailed Description

A vector of linker sites.

ms_linker_site_vector is a wrapper around the C++ vector class std::vector, specialised to contain ms_linker_site objects. The ms_peptide class returns such vectors.

The interface to this class follows that of vectori and vectorString, as described in Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Constructor & Destructor Documentation

ms_linker_site_vector | ( | const std::vector< ms_linker_site > & | v,
 |  | const int | alphaVarModsLen,
 |  | const int | betaVarModsLen
 | ) |  |

Create a linker site vector from an STL vector.

Note:
This constructor can only be used from C++.

The alpha and beta variable mods string lengths are not optional, but one or both can be set to zero. See getVarModIdxOfLinkedSite().

Parameters:
v | STL vector to initialise with.
alphaVarModsLen | length of the alpha peptide variable mods string.
betaVarModsLen | length of the beta peptide variable mods string.
ms_linker_site_vector | ( | const std::list< ms_linker_site > & | v,
 |  | const int | alphaVarModsLen,
 |  | const int | betaVarModsLen
 | ) |  |

Create a linker site vector from an STL list.

Note:
This constructor can only be used from C++.

The alpha and beta variable mods string lengths are not optional, but one or both can be set to zero. See getVarModIdxOfLinkedSite().

Parameters:
v | STL list to initialise with.
alphaVarModsLen | length of the alpha peptide variable mods string.
betaVarModsLen | length of the beta peptide variable mods string.

Member Function Documentation

void append ( const ms_linker_site_vector & src )

Appends all content from another instance of the class.

This method does not change getAlphaVarModsStrLength() or getBetaVarModsStrLength().

Parameters:
src is another ms_linker_site_vector to append the sites from.
void clear ( )

Clear the vector.

After clear, the vector will be empty. Alpha and beta variable mods string lengths are set to zero.

bool containsVarModIdx ( int idx ) const

Return true if the vector contains a link with the given variable mod index.

Parameters:
idx Variable mod index.
Returns:
True if any linker object uses idx at either end of the link.
bool empty ( ) const

Boolean test: is the vector empty?

Returns:
True if the vector is empty (has size 0); false otherwise.
ms_linker_site get ( int idx ) const

Return the linker site at the given index.

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception.

Parameters:
idx The element index, 0..size()-1.
Returns:
The element at the corresponding index.
int getAlphaVarModsStrLength ( ) const

Return the alpha peptide sequence length.

Returns:
Length of the alpha variable mods string, or 0 if not set.
int getBetaVarModsStrLength ( ) const

Return the beta peptide sequence length.

Returns:
Length of the beta variablem mods string, or 0 if not set.
int getVarModIdxOfLinkedSite | ( | const ms_peptide::PSM | psmComponent,
 |  | const int | i
 | ) |  | const

Return the variable mod index if the PSM component has a link at position i.

There are two use cases.

If psmComponent is ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA, the position i indexes the alpha or the beta variable mods string returned by ms_peptide::getVarModsStr(psmComponent). This method returns a non-zero variable mod number if there is a link in the given psmComponent at position i.

If psmComponent is ms_peptide::PSM_COMPLETE, the position i indexes the concatenated variable mods string returned by ms_peptide::getVarModsStr(PSM_COMPLETE). A simple calculation is done to determine whether i is a position in the alpha or the beta peptide:

  • If (0 <= i and i < alphaVarModsLen), then set pos = i and psmComponent = ms_peptide::PSM_CROSSLINK_ALPHA.
  • If (alphaLen <= i and i < alphaVarModsLen + betaVarModsLen), then set pos = (i - alphaVarModsLen) and psmComponent = ms_peptide::PSM_CROSSLINK_BETA.

One or both of alpha or beta variable mods string lengths can be zero.

Parameters:
psmComponent | One of ms_peptide::PSM.
i | Position within the variable mods string.
Returns:
Variable mod index if the there is a link at position i. If there is no link, returns 0.
ms_linker_site pop ( )

Pop a value from the end of the vector.

Note that the vector must be nonempty (it must contain at least one element). If it doesn't, the method throws an exception.

Returns:
The value popped from the end of the vector.
void push ( const ms_linker_site & linkerSite )

Push a new linker site at the end of the vector.

Parameters:
linkerSite Linker site to append to the vector.
void set | ( | int | idx,
 |  | const ms_linker_site & | linkerSite
 | ) |  |

Set the value at the given index.

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception. If you need to extend the vector, use push().

Parameters:
idx | The element index, 0..size()-1.
linkerSite | The new value to be set at that index.
int size ( ) const

Return the size of the container.

Returns:
The number of elements in the vector, or 0 if the vector is empty.
void swap ( ms_linker_site_vector & src )

Swap the contents with another linker site vector.

After this method returns, the data of src is stored inside this object, and src stores the old contents of this object.

This method swaps getAlphaVarModsStrLength() and getBetaVarModsStrLength() with src.

Parameters:
src Linker site vector to swap contents with.
const std::vector< ms_linker_site > & toVector ( ) const

C++ conversion to std::vector.

Note:
This method can only be used from C++.
Returns:
A copy of the linker site vector as an STL vector.
The documentation for this class was generated from the following files:
  • ms_linker_site_vector.hpp
  • ms_linker_site.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_mascotresfile
Public Types | Public Member Functions | Static Public Member Functions

ms_mascotresfile Class Reference
[Mascot results file module]

The first requirement before using any other functions or classes is to create an ms_mascotresfile object. More...

#include <ms_mascotresfile.hpp>

Inheritance diagram for ms_mascotresfile:
[legend]
Collaboration diagram for ms_mascotresfile:
[legend]

List of all members.

Public Types

enum err {
ERR_NO_ERROR = 0x0000,
ERR_NOMEM = 0x0001,
ERR_NOSUCHFILE = 0x0002,
ERR_READINGFILE = 0x0003,
ERR_QUERYOUTOFRANGE = 0x0004,
ERR_MISSINGENTRY = 0x0005,
ERR_PEPSUMMPEPGET = 0x0006,
ERR_PEPTIDESTR = 0x0007,
ERR_ACCINPEPTIDESTR = 0x0008,
ERR_PROTSUMM = 0x0009,
ERR_PROTSUMMPEP = 0x000A,
ERR_ADDPEPTIDES = 0x000B,
ERR_MISSINGHIT = 0x000C,
ERR_MISSINGSECTION = 0x000D,
ERR_MISSINGSECTIONEND = 0x000E,
ERR_MALFORMED_ERR_TOL = 0x000F,
ERR_NO_ERR_TOL_PARENT = 0x0010,
ERR_NULL_ACC_PEP_SUM = 0x0011,
ERR_NULL_ACC_PROT_SUM = 0x0012,
ERR_DUPE_ACCESSION = 0x0013,
ERR_UNASSIGNED_PROG = 0x0014,
ERR_UNASSIGNED_RANGE = 0x0015,
ERR_UNASSIGNED_UNK = 0x0016,
ERR_NO_UNIGENE_FILE = 0x0017,
ERR_DUPLICATE_KEY = 0x0018,
ERR_OLDRESULTSFILE = 0x0019,
ERR_MALFORMED_TAG = 0x001A,
ERR_MALFORMED_DRANGE = 0x001B,
ERR_INVALID_NUMQUERIES = 0x001C,
ERR_MALFORMED_TERMS = 0x001D,
ERR_INVALID_RESFILE = 0x001E,
ERR_INVALID_PROTDB = 0x001F,
ERR_UNIGENE_MULTIDB = 0x0020,
ERR_INVALID_CACHE_DIR = 0x0021,
ERR_FAIL_OPEN_DAT_FILE = 0x0022,
ERR_MISSING_CDB_FILE = 0x0023,
ERR_FAIL_MK_CACHE_DIR = 0x0024,
ERR_FAIL_MK_CDB_FILE = 0x0025,
ERR_FAIL_CLOSE_FILE = 0x0026,
ERR_FAIL_CDB_INIT = 0x0027,
ERR_INVALID_CDB_FILE = 0x0028,
ERR_WRITE_CDB_FILE = 0x0029,
ERR_CDB_TOO_LARGE = 0x002A,
ERR_NEED_64_BIT = 0x002B,
ERR_CDB_64_BIT_REMAKE = 0x002C,
ERR_CDB_OLD_VER_RETRY = 0x002D,
ERR_CDB_OLD_VER_NO_RETRY = 0x002E,
ERR_CDB_INCOMPLETE_RETRY = 0x002F,
ERR_CDB_INCOMPLETE_NO_RETRY = 0x0030,
ERR_CDB_BEING_CREATED = 0x0031,
ERR_CDB_FAIL_REMOVE = 0x0032,
ERR_CDB_FAIL_LOCK = 0x0033,
ERR_CDB_FAIL_UNLOCK = 0x0034,
ERR_CDB_SOURCE_CHANGE_RETRY = 0x0035,
ERR_CDB_SOURCE_CHANGE_NO_RETRY = 0x0036,
ERR_MISSING_PERCOLATOR_FILE = 0x0037,
ERR_CANNOT_APPEND_RESFILE = 0x0038,
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039,
ERR_RESULTS_NOT_CREATED = 0x003A
}

Definitions for error numbers.

More...
enum FLAGS {
RESFILE_NOFLAG = 0x00000000,
RESFILE_USE_CACHE = 0x00000001,
RESFILE_CACHE_IGNORE_ACC_DUPES = 0x00000002,
RESFILE_USE_PARENT_PARAMS = 0x00000004,
RESFILE_CACHE_IGNORE_DATE_CHANGE = 0x00000008
}

Flags for opening the results file.

More...
enum KA_TASK {
KA_CREATEINDEX_CI = 0,
KA_READFILE_RF = 1,
KA_ASSIGNPROTEINS_AP = 2,
KA_GROUPPROTEINS_GP = 3,
KA_UNASSIGNEDLIST_UL = 4,
KA_QUANTITATION = 5,
KA_CREATECACHE_CC = 6,
KA_THRESHFORFDR_FDR = 7,
KA_LAST = 8
}

Processing some results files is computationally intensive. These are the tasks that can be performed.

More...
enum PERCOLATOR_FILE_NAMES {
PERCOLATOR_INPUT_FILE = 0,
PERCOLATOR_OUTPUT_TARGET = 1,
PERCOLATOR_OUTPUT_DECOY = 2
}

Offsets into a vector of Percolator filenames.

More...
enum section {
SEC_PARAMETERS,
SEC_HEADER,
SEC_MASSES,
SEC_SUMMARY,
SEC_MIXTURE,
SEC_PEPTIDES,
SEC_PROTEINS,
SEC_QUERY1,
SEC_QUANTITATION,
SEC_UNIMOD,
SEC_ENZYME,
SEC_TAXONOMY,
SEC_DECOYSUMMARY,
SEC_DECOYMIXTURE,
SEC_DECOYPEPTIDES,
SEC_DECOYPROTEINS,
SEC_ERRTOLSUMMARY,
SEC_ERRTOLPEPTIDES,
SEC_SPECTRAL_LIBRARY,
SEC_LIBRARYPEPTIDES,
SEC_LIBRARYSUMMARY,
SEC_CROSSLINK_SUMMARY,
SEC_CROSSLINK_PEPTIDES,
SEC_CROSSLINKING,
SEC_UNIMOD_XL,
SEC_ERRTOLDECOYSUMMARY,
SEC_ERRTOLDECOYPEPTIDES,
SEC_INDEX,
SEC_NUMSECTIONS
}

Section names in the standard mascot results files.

More...
enum XML_SCHEMA {
XML_SCHEMA_QUANTITATION = 0,
XML_SCHEMA_UNIMOD = 1,
XML_SCHEMA_DIRECTORY = 2,
XML_SCHEMA_CROSSLINKING = 3,
XML_SCHEMA_LAST = 4
}

The results file contains sections in XML format and these need to be validated against a schema.

More...

Public Member Functions

ms_mascotresfile (const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0)
Constructor to open a Mascot results file.
bool | anyMSMS () const
Returns true if any of the queries in the search contain ions data.
bool | anyPeptideSummaryMatches (const section sec=SEC_PEPTIDES) const
Returns true if there is a peptides section, and if there are any results in it.
bool | anyPMF () const
Returns true if any of the queries in the search just contain a single peptide mass.
bool | anySQ () const
Returns true if any of the queries in the search contain seq or comp commands.
bool | anyTag () const
Returns true if any of the queries in the search contain tag or etag commands.
void | appendErrors (ms_errs &errs)
Used internally.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
int | appendResfile (const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0)
Multiple results files can be summed together and treated as 'one'.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | doesSectionExist (const section sec) const
Returns true if there is an entry for the passed section.
std::string | enumerateQuerySectionKeys (const int query, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const
Get the key name for each item in a query section.
std::string | enumerateSectionKeys (const section sec, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const
Get the key name for each item in a section.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const
[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | get_ms_mascotresults_params (const ms_mascotoptions &opts, ms_mascotresults_params &params) const
Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.
std::string | getCacheDirectory (bool processed=true) const
Returns the directory being used for cache files (if any).
std::string | getCacheFileName () const
Returns the filename of the cache file.
bool | getCrosslinkingMethod (ms_crosslinking_method *method) const
Return the crosslinking method object from the crosslinking section of the results file.
DATABASE_TYPE | getDatabaseType (const int idx) const
Return database type if available.
int | getDate () const
Returns the date and time of the search in seconds since midnight January 1st 1970.
ms_mascotoptions::DECOY_ALGORITHM | getDecoyTypeForDB (const int idx=1) const
Returns the decoy algorithm type for a given database.
bool | getEnzyme (ms_enzymefile *efile, const char *enzymeFileName=0) const
Returns an object that represents enzyme-section as a reduced enzymes file.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getErrorNumber (const int num=-1) const
Return a specific error number - or ms_mascotresfile::ERR_NO_ERROR.
std::string | getErrorString (const int num) const
Return a specific error as a string.
int | getExecTime () const
Returns the time taken for the search.
std::string | getFastaPath (int idx=1) const
Returns the path to the FASTA file used.
std::string | getFastaVer (int idx=1) const
Returns the FASTA file version.
std::string | getFileName (const int id=1) const
Returns the name of the results file passed into the constructor.
int | getJobNumber (const int resfileID=1) const
Return the job number for this file - obtained from the file name.
void | getKeepAlive (KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const
Return the progress indicators used by the keepAlive functions.
int | getLastError () const
Return the last error number - or ms_mascotresfile::ERR_NO_ERROR.
std::string | getLastErrorString () const
Return the last error number - or an empty string.
std::string | getMascotVer () const
Returns the version of Mascot used to perform the search.
bool | getMasses (ms_masses *masses) const
Returns an ms_masses object from the mass values in the results file.
const ms_modification * | getMonoLinkModification (const int modNum, const int monoLink) const
Returns an ms_modification object that represents a monolink variable modification.
std::string | getMSParserVersion () const
Returns the version number of the Mascot Parser library.
int | getMultiFileQueryNumber (const int localQuery, const int fileId) const
Return the multi-file query number from the local query number in an appended file.
int | getNumberOfErrors () const
Return the number of errors since the last call to clearAllErrors.
int | getNumberOfResfiles () const
Multiple results files can be summed together and treated as 'one'.
int | getNumEtSeqsSearched (const int idx=0) const
Returns the number of sequences searched in the second pass of an integrated error tolerant search.
int | getNumHits (const section sec=SEC_SUMMARY) const
Returns the maximum number of hits possible for a protein summary.
int | getNumLibraryEntries (const int idx=0) const
Returns the number of entries in the spectral library searched.
int | getNumQueries (const int resfileID=0) const
Returns the number of queries (peptide masses or ms-ms spectra).
double | getNumResidues (const int idx=0) const
Returns the number of residues in the FASTA file(s) searched.
int | getNumSeqs (const int idx=0) const
Returns the number of sequences in the FASTA file(s) searched.
int | getNumSeqsAfterTax (const int idx=0) const
Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
int | getObservedCharge (const int query, const bool decoy=false) const
The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.
double | getObservedIntensity (const int query) const
Returns the experimental intensity for the peptide.
double | getObservedMass (const int query) const
Returns the experimental mass value as entered by the user.
double | getObservedMrValue (const int query, const bool decoy=false) const
Returns the experimental mass value (as a relative mass) as entered by the user.
std::vector< std::string > | getPercolatorFileNames () const
Retrieve the filenames use for percolator input and output.
ms_progress_info * | getProgressInfo (bool forPeptideSummary=false) const
If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.
bool | getQuantitation (ms_quant_configfile *qfile) const
Returns an object that represents the quantitation section as a reduced quantitation.xml file.
bool | getQuantitationMethod (ms_quant_method *qmethod) const
Return the quantitation method object from the quantitation section of the results file.
int | getQuerySectionValue (const int query, const char *key, char *str, int maxLen) const
Return the string value from a query in the results file.
double | getQuerySectionValueDouble (const int query, const char *key) const
Return the floating point value from a query in the results file.
int | getQuerySectionValueInt (const int query, const char *key) const
Return the integer value from a query in the results file.
std::string | getQuerySectionValueStr (const int query, const char *key) const
Return the string value from a query in the results file.
int | getReferenceDatabaseNumberOfSL (const int idx) const
Return the database number of the reference database of a spectral library.
std::string | getRepeatSearchString (const int query, const bool fullQuery=false) const
To perform a repeat search need to build up appropriate string.
const ms_mascotresfile * | getResfile (int id) const
Returns a pointer to the resfile created by calling appendResfile.
int | getSectionValue (const section sec, const char *key, char *str, int maxLen) const
Return the string value from any line in the results file.
double | getSectionValueDouble (const section sec, const char *key) const
Return the floating point value from any line in the results file.
int | getSectionValueInt (const section sec, const char *key) const
Return the integer value from any line in the results file.
std::string | getSectionValueStr (const section sec, const char *key) const
Return the string value from any line in the results file.
std::vector< int > | getSLDatabaseNumbersOfReference (const int idx) const
Return the database numbers of the spectral libraries whose reference database is at the given index.
double | getSLFragmentTolerance (int idx=1) const
Returns the effective spectral library fragment tolerance.
std::string | getSLFragmentToleranceUnit (int idx=1) const
Returns the unit of the effective spectral library fragment tolerance.
bool | getSrcQueryAndFileIdForMultiFile (const int q, int &gsqNewQuery, int &gsqFileId) const
Return the query number and file ID in the source .dat file.
bool | getTaxonomy (ms_taxonomyfile *tfile) const
Returns an object that represents taxonomy-section as a reduced taxonomy file.
bool | getUnimod (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const
Returns an object that represents unimod-section as a reduced unimod_2.xml file.
bool | getUnimodXL (ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const
Returns an object that represents unimod_xl-section as a reduced unimod_xl.xml file.
std::string | getUniqueTaskID () const
Returns the unique task ID used by Mascot Daemon.
std::string | getXMLschemaFilePath (XML_SCHEMA XMLschema) const
Gets the XML schema to be used by functions using quantitation or unimod.
bool | isDatabaseTypeAvailable () const
Check whether database types are available.
bool | isErrorTolerant () const
Returns true if the search was an error tolerant search.
bool | isMSMS () const
Returns true if the search was an MSMS search (SEARCH=MIS).
bool | isPMF () const
Returns true if the search was a PMF search (SEARCH=PMF).
bool | isSQ () const
Returns true if the search was a sequence query search (SEARCH=SQ).
bool | isValid () const
Call this function to determine if there have been any errors.
bool | outputKeepAlive () const
Outputs the "keep-alive" string during time-consuming operations.
ms_searchparams & | params () const
Returns a reference to the search parameters class.
void | resetKeepAlive (const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false)
Replace the existing keepAlive values with new values.
void | setPercolatorFeatures (const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes)
Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).
void | setPercolatorFeatures (const ms_mascotoptions &options, const char *additionalFeatures)
Set Percolator features before creating an ms_peptidesummary with Percolator scoring.
bool | setXMLschemaFilePath (XML_SCHEMA XMLschema, const char *path)
Sets the XML schema to be used by functions using quantitation or unimod.
bool | versionGreaterOrEqual (int major, int minor, int revision) const
Compare the value returned by getMascotVer() with the passed version number.

Static Public Member Functions

static const char * | getSectionName (const section sec)
Return the section name as a string given the enum value.
static bool | staticGetPercolatorFileNames (const char *szDatFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file (deprecated).
static bool | staticGetPercolatorFileNames (const char *szDatFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, std::vector< std::string > &filenames, std::vector< bool > &exists)
Returns a list of the Percolator input and output files for the specified data file.
static bool | willCreateCache (const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus)
Returns true if a cache file will be created when the ms_mascotresfile constructor is called.
static bool | willCreateCache (const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName)
Returns true if a cache file will be created when the ms_mascotresfile constructor is called.

Detailed Description

The first requirement before using any other functions or classes is to create an ms_mascotresfile object.

You must create an object of this class before anything else. The constructor takes the file name as a parameter. Note that all key names are case insensitive.

Examples:

peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, resfile_info.cpp, resfile_input.cpp, resfile_params.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum err

Definitions for error numbers.

See Using enumerated values and static const ints in Perl, Java, Python and C#. Messages are classified as fatal errors [F] or warnings [W]. A warning will not cause ms_mascotresfile::isValid() to return false.

Deprecated:
  • use ms_errs::err instead
Enumerator:
ERR_NO_ERROR

[W] Success

ERR_NOMEM

[F] Failed to allocate memory to load the file

ERR_NOSUCHFILE

[F] The file passed in the constructor does not exist

ERR_READINGFILE

[F] Opened the file successfully, but failed to read from it

ERR_QUERYOUTOFRANGE

[F] Set if query < 1 or query > getNumQueries

ERR_MISSINGENTRY

[F] Set if there is no qexp value in the file

ERR_PEPSUMMPEPGET

[F] Value of q, p or h out of range, so cannot get peptide info

ERR_PEPTIDESTR

[F] The string in the peptides block is not valid

ERR_ACCINPEPTIDESTR

[F] Could not parse an item for a given accession in the peptide section

ERR_PROTSUMM

[F] Error parsing a line in the protein summary

ERR_PROTSUMMPEP

[F] Couldn't parse peptide information from the protein summary section

ERR_ADDPEPTIDES

[F] Failed to add peptides when creating the peptide summary

ERR_MISSINGHIT

[F] Missing hit in the summary section

ERR_MISSINGSECTION

[F] Complete missing section in the file

ERR_MISSINGSECTIONEND

[F] Missing end of section in the file

ERR_MALFORMED_ERR_TOL

[W] Expecting a line of format: q1_p2_et_mods=0.984020,0.000000,Citrullination

ERR_NO_ERR_TOL_PARENT

[F] No parent search file. See Error tolerant searches

ERR_NULL_ACC_PEP_SUM

[W] An empty accession string has been found. Possible problem in database

ERR_NULL_ACC_PROT_SUM

[W] An empty accession string has been found. Possible problem in database

ERR_DUPE_ACCESSION

[W] A possible duplicate accession string has been found. Possible problem in database.

ERR_UNASSIGNED_PROG

[F] Programming error! Calling getNumberOfUnassigned() or getUnassigned() before createUnassignedList()

ERR_UNASSIGNED_RANGE

[F] Calling ms_mascotresults::getUnassigned() with out of range number

ERR_UNASSIGNED_UNK

[F] Calling ms_mascotresults::getUnassigned() - unable to retrieve value

ERR_NO_UNIGENE_FILE

[F] Failed to open the UniGene file specified

ERR_DUPLICATE_KEY

[W] Duplicate entries with the same key in the named section.

ERR_OLDRESULTSFILE

[F] Very old results file (last century!). Parser requires 1.02 or later

ERR_MALFORMED_TAG

[W] Expecting a line in format: q1_p2_tag=1:3:5:6,2:4:12:6,...

ERR_MALFORMED_DRANGE

[W] Expecting a line in format: q1_p2_drange=0,256

ERR_INVALID_NUMQUERIES

[W] Invalid number of queries in results file has been corrected.

ERR_MALFORMED_TERMS

[W] Expecting a line in format: q1_p2_terms=A,B:-,I:...

ERR_INVALID_RESFILE

[F] Invalid results file format - missing or corrupt headers

ERR_INVALID_PROTDB

[W] Invalid h1_db-string format. Expecting an integer number.

ERR_UNIGENE_MULTIDB

[W] UniGene index is not supported in multi-database search

ERR_INVALID_CACHE_DIR

[F] Must specify a cache directory if using CDB cache files

ERR_FAIL_OPEN_DAT_FILE

[F] Failed to open the results file for reading

ERR_MISSING_CDB_FILE

[W] Cache file is missing or cannot be opened

ERR_FAIL_MK_CACHE_DIR

[F] Failed to create cache directory for cache files

ERR_FAIL_MK_CDB_FILE

[W] Failed to create an cache file

ERR_FAIL_CLOSE_FILE

[W] Failed to close file

ERR_FAIL_CDB_INIT

[W] Failed to initialise cache file (%s). Error code %d.

ERR_INVALID_CDB_FILE

[W] Value in cdb cache file (%s) is corrupt: %s

ERR_WRITE_CDB_FILE

[W] Failed to write to the cache file (%s). Error %d (%s)

ERR_CDB_TOO_LARGE

[W] Cannot use cache file (s) which exceeded max size of s. Try deleting the cache file and retrying

ERR_NEED_64_BIT

[F] This results file (%s) is too large for 32 bit Mascot Parser. Please upgrade to 64 bit.

ERR_CDB_64_BIT_REMAKE

[W] Re-creating %s. Was too large for 32 bit, but may succeed with 64 bit

ERR_CDB_OLD_VER_RETRY

[W] Cache file %s is an old version. Creating new cache file

ERR_CDB_OLD_VER_NO_RETRY

[W] Cache file %s is an old version. Continuing without cache

ERR_CDB_INCOMPLETE_RETRY

[W] Cache file %s was not complete. Re-creating the cache file

ERR_CDB_INCOMPLETE_NO_RETRY

[W] Cache file %s was not complete. Continuing without cache

ERR_CDB_BEING_CREATED

[W] Cache file %s being created by another task. Continuing without cache

ERR_CDB_FAIL_REMOVE

[W] Failed to remove old cache file %s - error %s. Continuing without cache

ERR_CDB_FAIL_LOCK

[W] Failed to lock cache file %s. Error code: %d

ERR_CDB_FAIL_UNLOCK

[W] Failed to unlock cache file %s. Error code: %d

ERR_CDB_SOURCE_CHANGE_RETRY

[W] %s changed. %s (was %s), %s bytes (was %s). Re-creating the cache file

ERR_CDB_SOURCE_CHANGE_NO_RETRY

[W] %s changed. %s (was %s), %s bytes (was %s). Continuing without cache

ERR_MISSING_PERCOLATOR_FILE

[F] Percolator file %s is missing. Cannot continue

ERR_CANNOT_APPEND_RESFILE

[F] The file %s cannot be appended to %s because %s values are different

ERR_CANNOT_APPEND_RESFILE_NO_FNAMES

[F] The file cannot be appended because %s values are different

ERR_RESULTS_NOT_CREATED

[W] Attempting to call function %s before createSummary() has completed.

enum FLAGS

Flags for opening the results file.

See Using enumerated values and static const ints in Perl, Java, Python and C# and Caching Mascot Results.

Enumerator:
RESFILE_NOFLAG

The standard original functionality. Read the whole file into memory.

RESFILE_USE_CACHE

Create the cache if it doesn't already exist. Use the cache rather than reading the whole .dat file into memory.

RESFILE_CACHE_IGNORE_ACC_DUPES

When creating a cache file, don't check for duplicate accessions in the SEC_PROTEINS and SEC_DECOYPROTEINS sections which can save some time. Strongly recommend that this flag is never used unless performance becomes a real issue and it is known that ms_mascotoptions::getIgnoreDupeAccession was not defined for the relevant database(s) when they were compressed.

RESFILE_USE_PARENT_PARAMS

For use when Combining multiple .dat files. The flags and parameters are then inherited from the parent search.

RESFILE_CACHE_IGNORE_DATE_CHANGE

Opening the resfile cache CDB file should ignore the last modified timestamp on the .dat file.

enum KA_TASK

Processing some results files is computationally intensive. These are the tasks that can be performed.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getKeepAlive(), but also see outputKeepAlive()

Enumerator:
KA_CREATEINDEX_CI

Creating a cache file when Using the ms_mascotresfile cache files.

KA_READFILE_RF

Reading the results file into memory when not using a cache.

KA_ASSIGNPROTEINS_AP

Assigning peptides to proteins to get a list of all possible proteins.

KA_GROUPPROTEINS_GP

Grouping proteins using ms_mascotresults::MSRES_GROUP_PROTEINS or ms_mascotresults::MSRES_CLUSTER_PROTEINS.

KA_UNASSIGNEDLIST_UL

Creating the unassigned list - see ms_mascotresults::createUnassignedList.

KA_QUANTITATION

Calculating quantitation values for reporter and multiplex protocols.

KA_CREATECACHE_CC

Creating a cache file when Using the ms_peptidesummary cache.

KA_THRESHFORFDR_FDR

Calls to ms_mascotresults::getThresholdForFDRAboveHomology can be slow.

KA_LAST

Placeholder that is equal to the number of possible tasks.

enum PERCOLATOR_FILE_NAMES

Offsets into a vector of Percolator filenames.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Used with getPercolatorFileNames().

Enumerator:
PERCOLATOR_INPUT_FILE

This file is created by ms-createpip.exe and read by percolator.

PERCOLATOR_OUTPUT_TARGET

From std::out of percolator.exe.

PERCOLATOR_OUTPUT_DECOY

Specified using the -B flag when calling percolator.

enum section

Section names in the standard mascot results files.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
SEC_PARAMETERS

parameters section

SEC_HEADER

header section

SEC_MASSES

masses section

SEC_SUMMARY

summary section

SEC_MIXTURE

mixture section (pmf mixture)

SEC_PEPTIDES

peptides section

SEC_PROTEINS

proteins section

SEC_QUERY1

query1 section. Don't use, see getQuerySectionValueStr() etc.

SEC_QUANTITATION

quantitation section

SEC_UNIMOD

unimod section

SEC_ENZYME

enzyme section

SEC_TAXONOMY

taxonomy section

SEC_DECOYSUMMARY

decoy_summary section. See also Target-decoy searches and false discovery rate.

SEC_DECOYMIXTURE

decoy_mixture section. See also Target-decoy searches and false discovery rate.

SEC_DECOYPEPTIDES

decoy_peptides section. See also Target-decoy searches and false discovery rate.

SEC_DECOYPROTEINS

decoy_proteins section. See also Target-decoy searches and false discovery rate.

SEC_ERRTOLSUMMARY

error tolerant summary section. See also Error tolerant searches.

SEC_ERRTOLPEPTIDES

error tolerant peptides section. See also Error tolerant searches.

SEC_SPECTRAL_LIBRARY

spectral library section. See also Spectral libraries.

SEC_LIBRARYPEPTIDES

spectral library peptides section. See also Spectral libraries.

SEC_LIBRARYSUMMARY

spectral library summary section. See also Spectral libraries.

SEC_CROSSLINK_SUMMARY

crosslink_summary section. See also Crosslinked search results.

SEC_CROSSLINK_PEPTIDES

crosslink_peptides section. See also Crosslinked search results.

SEC_CROSSLINKING

crosslinking section

SEC_UNIMOD_XL

unimod_xl section

SEC_ERRTOLDECOYSUMMARY

error tolerant decoy summary section. See also Error tolerant searches.

SEC_ERRTOLDECOYPEPTIDES

error tolerant decoy peptides section. See also Error tolerant searches.

SEC_INDEX

index section

SEC_NUMSECTIONS

!!don't use - place holder

enum XML_SCHEMA

The results file contains sections in XML format and these need to be validated against a schema.

This is the list of schema that can be set using setXMLschemaFilePath() and getXMLschemaFilePath()

Enumerator:
XML_SCHEMA_QUANTITATION

From the "quantation" mime section of the file. Valid aliases are: "http://www.matrixscience.com/xmlns/schema/quantitation_1" and "http://www.matrixscience.com/xmlns/schema/quantitation_2".

XML_SCHEMA_UNIMOD

From the "unimod" mime section of the file. Valid alias is: http://www.unimod.org/xmlns/schema/unimod_2.

XML_SCHEMA_DIRECTORY

From the value of XMLschemaDirectory passed into the ms_mascotresfile constructor.

XML_SCHEMA_CROSSLINKING

From the "crosslinking" mime section of the file. Valid alias is: http://www.matrixscience.com/xmlns/schema/crosslinking_1.

XML_SCHEMA_LAST

Placeholder that is equal to the number of possible schema.

Constructor & Destructor Documentation

ms_mascotresfile | ( | const char * | szFileName,
 |  | const int | keepAliveInterval = 0,
 |  | const char * | keepAliveText = "<!-- %d seconds -->\n",
 |  | const unsigned int | flags = RESFILE_NOFLAG,
 |  | const char * | cacheDirectory = "../data/cache/%Y/%m",
 |  | const char * | XMLschemaDirectory = 0,
 |  | ms_progress_info * | progressMonitor = 0
 | ) |  |

Constructor to open a Mascot results file.

If the ms_mascotresfile::RESFILE_NOFLAG flag is specified, then the constructor reads the whole file into memory, and makes an in memory index of all the keys for fast lookup later. This was the default (and only) behaviour for Mascot Parser versions 2.2 and earlier.

If the ms_mascotresfile::RESFILE_USE_CACHE flag is specified, then the file is not read into memory, but a separate cache file containing offsets is used to read each line in the results file when requested. This is considerably faster if just a few lines of the results file need to be accessed and also takes less memory. The filenames for the cache file will be created by extracting the filename part from the path supplied in szFileName and appending '.cdb'. So, typically the cache filenames will be of the form Fxxxxx.dat.cdb. See Caching Mascot Results.

For HTML reports with large result files it is sometimes necessary to output HTML fragments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText). See outputKeepAlive() for more details.

The functions isValid() or getLastError() should be called after creating the object to determine if the file was valid and loaded properly.

Possible error values:

  • ms_mascotresfile::ERR_NOMEM
  • ms_mascotresfile::ERR_NOSUCHFILE
  • ms_mascotresfile::ERR_MISSINGSECTION
  • ms_mascotresfile::ERR_MISSINGSECTIONEND
  • ms_mascotresfile::ERR_READINGFILE
  • ms_mascotresfile::ERR_INVALID_CACHE_DIR
  • ms_mascotresfile::ERR_FAIL_OPEN_DAT_FILE
  • ms_mascotresfile::ERR_FAIL_MK_CACHE_DIR
  • ms_mascotresfile::ERR_FAIL_CDB_INIT
  • ms_mascotresfile::ERR_MISSING_CDB_FILE
  • ms_mascotresfile::ERR_INVALID_NUMQUERIES
  • ms_mascotresfile::ERR_INVALID_RESFILE
  • ms_mascotresfile::ERR_FAIL_MK_CDB_FILE
  • ms_mascotresfile::ERR_FAIL_CLOSE_FILE
Parameters:
szFileName | is the path to a valid Mascot results file
keepAliveInterval | is the interval in seconds between each time the keepAliveText is output to stdout. If a value of zero is specified, then no keep alive text will be output.
keepAliveText | is output every keepAliveInterval seconds while the file is being loaded. See outputKeepAlive() for further details.
flags | are created by bitwise ORing the ms_mascotresfile::FLAGS
cacheDirectory | is the location where any cache files are stored. See Specifying cache file directory. If cacheDirectory is null or empty and RESFILE_USE_CACHE is specified, then ERR_INVALID_CACHE_DIR will be set and the object will be invalid. Most applications should get this value from ms_mascotoptions::getCacheDirectory().
XMLschemaDirectory | is the location where the xml schema files are located. Some sections of the results file are encoded in XML, and Mascot Parser needs to verify that these are in the correct format using 'xsd' schema files. The required files are supplied with Mascot Parser in the config directory. Either supply the path to that directory, or copy the .xsd files from it to another directory and supply the path to that (only the xsd files from that directory are required). If this parameter is 0 (the default), then it is assumed that the software is running on the Mascot Server and that the files are located in separate directories under ../html/xmlns/schema as defined in setXMLschemaFilePath(). The constructor does not check that the schema files exist, but subsequent calls to functions such as getUnimod() and getQuantitationMethod() will fail if the schema is not available. The function setXMLschemaFilePath() may be called to override this value passed in the constructor for individual schema files.
progressMonitor | is an optional parameter that can be used to track progress of the creation of this object. It can also be used (from another thread) to cancel the creation of the object by calling ms_progress_info::setBreak. If the passed progressMonitor has a subTask, created by calling ms_progress_info::addSubtask("Creating peptide summary", 100), then that subtask will be used when creating the ms_peptidesummary object. If the subtask doesn't exist, then one is created. Both pointers can be obtained by calling ms_mascotresfile::getProgressInfo(). Make sure that the calling function does not delete the object pointed to by this paramater until after the ms_mascotresfile object has been deleted. See: Maintaining object references: two rules of thumb

Member Function Documentation

bool anyMSMS ( ) const

Returns true if any of the queries in the search contain ions data.

See also the isMSMS() member, although this function is the preferred one.

Returns:
true if any queries contain MS-MS fragment masses
Examples:
resfile_info.cpp.
bool anyPeptideSummaryMatches ( const section sec = SEC_PEPTIDES ) const

Returns true if there is a peptides section, and if there are any results in it.

If no parameter is passed to this function, information is returned about the standard peptides section.

This function is useful if, for example, you want to know if there is a peptides, decoy_peptides or et_peptides section in the results file. Very early versions of Mascot didn't have a peptides section for MS-MS searches, and the decoy and error tolerant peptides sections were added in Mascot 2.2, so it is safest to check that this function returns true before creating an ms_peptidesummary report. If this function returns false, consider creating an ms_proteinsummary instead.

This function will also return false if there is a peptides section that doesn't contain any results.

Even if this function returns true, it is possible that an ms_peptidesummary object created from the file will be empty if, for example, all the matches have ions scores below the specified minimum ions score.

Parameters:
sec Can be one of ms_mascotresfile::SEC_PEPTIDES, ms_mascotresfile::SEC_DECOYPEPTIDES, ms_mascotresfile::SEC_ERRTOLPEPTIDES, ms_mascotresfile::SEC_ERRTOLDECOYPEPTIDES, ms_mascotresfile::SEC_LIBRARYPEPTIDES, ms_mascotresfile::SEC_CROSSLINK_PEPTIDES
Returns:
True if the section exists and contains any results in the specified section
Examples:
resfile_info.cpp.
bool anyPMF ( ) const

Returns true if any of the queries in the search just contain a single peptide mass.

See also the isPMF() member, although this function is the preferred one.

Returns:
true if any queries contain no MS-MS values
Examples:
repeat_search.cpp, and resfile_info.cpp.
bool anySQ ( ) const

Returns true if any of the queries in the search contain seq or comp commands.

See also the isSQ() member, although this function is the preferred one.

Returns:
true if any queries contain seq or comp commands
Examples:
resfile_info.cpp.
bool anyTag ( ) const

Returns true if any of the queries in the search contain tag or etag commands.

See also anySQ(), anyPMF() and anyMSMS()

Returns:
true if any queries contain tag or etag commands
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
int appendResfile | ( | const char * | filename,
 |  | int | flags = RESFILE_USE_PARENT_PARAMS,
 |  | const char * | cacheDirectory = 0
 | ) |  |

Multiple results files can be summed together and treated as 'one'.

See Combining multiple .dat files.

Attempts to load the specifed results file and append to the existing file.

Any warning or error messages in the file are also appended to the existing object. If isValid() for the new file returns false, it is not appended and this function returns 0.

ms_mascotresfile::ERR_CANNOT_APPEND_RESFILE_NO_FNAMES and ms_mascotresfile::ERR_CANNOT_APPEND_RESFILE will be set if the file cannot be appended because of different parameters, such as a different enzyme.

Parameters:
filename | is the path to the results file to append.
flags | are one of the ms_mascotresfile::FLAGS. If RESFILE_USE_PARENT_PARAMS is specified, then the flags, keepAlive and cache directory are copied from the parent object.
cacheDirectory | is the directory for the cache files if RESFILE_USE_CACHE has been specified. If RESFILE_USE_PARENT_PARAMS is specified and cacheDirectory is null or an empty string, then the cache directory for the parent object is used.
Returns:
0 on error, or the id number of the new file. The id can be used with getNumQueries(), getJobNumber(), getFileName() or getResfile(). The return value from the first successful call to this function will be 2.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
bool doesSectionExist ( const section sec ) const

Returns true if there is an entry for the passed section.

This function is useful if, for example, you want to know if there is a peptides section in the results file. Very early versions of Mascot didn't have a peptides section for MS-MS searches.

Parameters:
sec is the section number
Returns:
True if the section exists
Examples:
resfile_info.cpp.
std::string enumerateQuerySectionKeys | ( | const int | query,
 |  | const int | num,
 |  | int * | pPreviousNum = 0,
 |  | OFFSET64_T * | pPreviousOffset = 0
 | ) |  | const

Get the key name for each item in a query section.

Enumerate through all the entries in a section. It returns the key name (not value) for a single item.

In version of Mascot Parser prior to version 2.3, the items are returned in alphabetical order. In Mascot Parser version 2.3 and later, the items are returned in the order in the results file.

See ms_searchparams::getAllUSERParams for an example of using this method.

Note:
When using this method in a programming language other than C++, you can not use the optional parameters pPreviousNum and pPreviousOffset.
Parameters:
query | should be in the range 1..getNumQueries().
num | is the line number (1..n) of the line in the required section.
pPreviousNum | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousOffset should also be passed.
pPreviousOffset | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousNum should also be passed.
Returns:
The key name. An empty string is returned when num is greater than the number of items in the section or is less than 1.
std::string enumerateSectionKeys | ( | const section | sec,
 |  | const int | num,
 |  | int * | pPreviousNum = 0,
 |  | OFFSET64_T * | pPreviousOffset = 0
 | ) |  | const

Get the key name for each item in a section.

Enumerate through all the entries in a section. It returns the key name (not value) for a single item.

In version of Mascot Parser prior to version 2.3, the items are returned in alphabetical order. In Mascot Parser version 2.3 and later, the items are returned in the order in the results file.

See ms_searchparams::getAllUSERParams for an example of using this method.

Note:
When using this method in a programming language other than C++, you can not use the optional parameters pPreviousNum and pPreviousOffset.
Parameters:
sec | can be any section number that contains value= lines This function will not work for sections that contain embedded XML such as the unimod section.
num | is the line number (1..n) of the line in the required section.
pPreviousNum | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousOffset should also be passed.
pPreviousOffset | is an optional parameter to speed up iterating through a large section when using cached files. If this value is not null, then the pPreviousNum should also be passed.
Returns:
The key name. An empty string is returned when num is greater than the number of items in the section or is less than 1.
std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | ms_mascotresults_params & | resParams
 | ) |  | const

Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function sets the values and flags required to pass to the constructor in the passed ms_mascotresults_params object.

Parameters:
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | resParams | the values and flags required to pass to the peptide or protein summary object are set to this ms_mascotresults_params object, overwriting any values which were already set.
Returns:
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.
std::string get_ms_mascotresults_params | ( | const ms_mascotoptions & | opts,
 |  | unsigned int * | gpFlags,
 |  | double * | gpMinProbability,
 |  | int * | gpMaxHitsToReport,
 |  | double * | gpIgnoreIonsScoreBelow,
 |  | unsigned int * | gpMinPepLenInPepSummary,
 |  | bool * | gpUsePeptideSummary,
 |  | unsigned int * | gpFlags2
 | ) |  | const

[Deprecated] Return default flags and parameters for creating an ms_peptidesummary or ms_proteinsummary object.

Deprecated:
This function is deprecated. All new code should use ms_mascotresfile::get_ms_mascotresults_params(const ms_mascotoptions &, ms_mascotresults_params &) instead, as all the parameters are encapsulated in the ms_mascotresults_params class.

A number of optional flags and parameters can be passed to the ms_proteinsummary or ms_peptide summary constructors. For an application or script running on the Mascot server, the default values for some of these parameters should normally be taken from the mascot.dat file. This function returns the values and flags required to pass to the constructor.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | opts | contains the options stored in mascot.dat. Call the ms_datfile construction and then ms_datfile::getMascotOptions() to obtain this value.
[out] | gpFlags | will return the flags that are to be passed as the second parameter to the ms_proteinsummary or ms_peptidesummary object.
[out] | gpMinProbability | is the third parameter to be passed to the ms_proteinsummary or ms_peptidesummary objects. This return value will nomally be equal to the value returned from ms_mascotoptions::getSigThreshold().
[out] | gpMaxHitsToReport | this return value will normally be the one returned by ms_searchparams::getREPORT().
[out] | gpIgnoreIonsScoreBelow | this return value will be the one returned by ms_mascotoptions::getIgnoreIonsScoreBelow().
[out] | gpMinPepLenInPepSummary | this return value will be the one returned by ms_mascotoptions::getMinPepLenInPepSummary.
[out] | gpUsePeptideSummary | will be false is the file doesn't contain any anyMSMS (as returned by the anyMSMS() function). In this case, you should create an ms_proteinsummary. If gpUsePeptideSummary is true, you should create an ms_peptidesummary object.
[out] gpFlags2 is only required for an ms_peptidesummary. If gpUsePeptideSummary is true, gpFlags2 will have the following bits set.

  • ms_peptidesummary::MSPEPSUM_PERCOLATOR if all of the following apply:
    • the number of queries is >= ms_mascotoptions::getPercolatorMinQueries;
    • the number of sequences searched >= ms_mascotoptions::getPercolatorMinSequences;
    • this is a decoy search;
    • ms_mascotoptions::isPercolator() returns true;
  • ms_peptidesummary::MSPEPSUM_USE_CACHE if the script name that the function will return is in the string specified by ms_mascotoptions::getResultsCache().
  • ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH if the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch.
  • ms_peptidesummary::MSPEPSUM_REMOVE_CHIMERIC_DUPES if the results file comes from Mascot 2.5 or later.
Returns:
If the search contains MS-MS data and the number of queries >= ms_mascotoptions::getProteinFamilySwitch, then the returned script name will be ms_mascotoptions::getResultsPerlScript_2, otherwise it will be ms_mascotoptions::getResultsPerlScript.
std::string getCacheDirectory ( bool processed = true ) const

Returns the directory being used for cache files (if any).

The cacheDirectory supplied to the constructor ms_mascotresfile::ms_mascotresfile may contain a number of '%' flags which get substituted by Mascot Parser.

This function returns either an absolute directory, or a directory relative to the current working directory.

See Caching Mascot Results and ms_mascotoptions::getCacheDirectory

Parameters:
processed if true (the default), then the returned directory is relative to the current directory and will have any '%' flags replaced with the relevant directory. If processed is false, then the directory returned will be identical to the one passed to the constructor.
Returns:
The cache directory
std::string getCacheFileName ( ) const

Returns the filename of the cache file.

If the cacheDirectory supplied to the ms_mascotresfile::ms_mascotresfile constructor is not empty, then a filename will be returned. This does not guarantee that the file exists, or is being used.

See Caching Mascot Results.

Returns:
The filename for the cache file.
bool getCrosslinkingMethod ( ms_crosslinking_method * method ) const

Return the crosslinking method object from the crosslinking section of the results file.

This method returns true if all of the following apply:

  • the crosslinking section exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the crosslinking section validates against the schema;
  • the crosslinking method named in the CROSSLINKING parameter exists;
  • the crosslinking method can be loaded.

Otherwise the method returns false.

If the CROSSLINKING parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_CROSSLINKING_FAILEDLOAD.

Parameters:
method A pointer to crosslinking method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns:
True if the method was loaded; false otherwise.
DATABASE_TYPE getDatabaseType ( const int idx ) const

Return database type if available.

Mascot 2.6 and later save the type of the searched database(s) in the results file, as db_typeX= lines in the header section. These types are AA (amino acid), NA (nucleic acid) or SL (spectral library). The number of databases is ms_searchparams::getNumberOfDatabases(), so idx should be between 1 and getNumberOfDatabases().

Spectral libraries must have a reference database. If the reference database is not part of the actual search, protein accessions mapped to it have a database number above ms_searchparams::getNumberOfDatabases(). For example, if the search contains one AA database and one spectral library, getNumberOfDatabases() is 2 and the types returned by getDatabaseType() are AA (idx = 1) and SL (idx = 2). The reference database is at index 3 with type SLREF.

To find the number of the reference database of a spectral library, see ms_mascotresfile::geReferenceDatabaseNumberOfSL().

Parameters:
idx index of the database; must normally be between 1 and ms_searchparams::getNumberOfDatabases(), or a valid database number returned by ms_mascotresfile::getReferenceDatabaseNumberOfSL()
Returns:
database type if available. If idx is out of range or isDatabaseTypeAvailable() is false, returns AA.
int getDate ( ) const [inline]

Returns the date and time of the search in seconds since midnight January 1st 1970.

Obtained from the date= line in the header section of the file. Can be converted to day, month, year etc. using gmtime or similar functions.

Returns:
the date and time of the search in seconds since midnight January 1st 1970.
Examples:
resfile_info.cpp.
ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB ( const int idx = 1 ) const

Returns the decoy algorithm type for a given database.

Decoy algorithm type is saved as decoy_type= or decoy_typeX= in the header section, depending on Mascot version.

If idx = 1, the method returns the value of decoy_type=. If idx > 1, the method returns the corresponding decoy_typeX= line, or if one doesn't exist, falls back on decoy_type=.

If there is no suitable value in the file or idx is outside its range, the method returns ms_mascotoptions::DECOY_ALGORITHM_NONE.

Parameters:
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns:
the decoy algorithm type, or ms_mascotoptions::DECOY_ALGORITHM_NONE.
bool getEnzyme | ( | ms_enzymefile * | efile,
 |  | const char * | enzymeFileName = 0
 | ) |  | const

Returns an object that represents enzyme-section as a reduced enzymes file.

For data files created with Mascot 2.2 and later, the full definition of the enzyme used is included in the Mascot results file. For earlier versions of Mascot, just the name is recorded. This function attempts to read the definition from the results file. If the definition is not present in the results file and a path to the enzymes file has been passed, then this function reads the enzymes file and removes all entries from the list in memory apart from the one with the name specified in the results file.

To determine whether the content has been parsed successfully call ms_enzymefile::isValid.

See Object initialising functions in Perl, Java, Python and C#.

Parameters:
efile | a pointer to enzymes-file object that will accept the content from the section or the enzymes file if necessary. If successful, the enzyme itself can be retrieved by passing an index of zero to ms_enzymefile::getEnzymeByNumber()
enzymeFileName | is only used for results files prior to Mascot 2.2
Returns:
True if the section exists in the results file or if the enzyme specified in the results file can be loaded from the enzymes file.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getErrorNumber ( const int num = -1 ) const

Return a specific error number - or ms_mascotresfile::ERR_NO_ERROR.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

See Error Handling.

See also:
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()

In Mascot Parser 2.5 and later, this is implemented by calling: ms_errs::getErrorNumber()

Parameters:
num is the error number in the range 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or ERR_NO_ERROR. If an invalid number is passed, ERR_NO_ERROR will be returned (and no error will be added to the list of errors!).
Returns:
the error number
Examples:
resfile_error.cpp, and resfile_summary.cpp.
std::string getErrorString ( const int num ) const

Return a specific error as a string.

All errors are accumulated into a list in this object, until clearAllErrors() is called. To return a particular error, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or an empty string. If an invalid number is passed an empty string will be returned (and no error will be added to the list of errors!).

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

In Mascot Parser 2.5 and later, this is implemented by calling ms_errs::getErrorString but functionality is identical to previous versions.

See Error Handling.

See also:
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Parameters:
num 1 to number of errors, or -1
Returns:
error string for the given number, or the last error for -1, empty string if none
Examples:
resfile_error.cpp, and resfile_summary.cpp.
int getExecTime ( ) const [inline]

Returns the time taken for the search.

Obtained from the exec_time= line in the header section. This is the 'wall clock' time, not the CPU time.

Returns:
execution time in seconds
Examples:
resfile_info.cpp.
std::string getFastaPath ( int idx = 1 ) const

Returns the path to the FASTA file used.

Available in Mascot 2.2 and later.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfile::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the FASTA file path is obtained from the library_reference_fastafile line in the header section of the results file.

Parameters:
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfile::getReferenceDatabaseNumberOfSL().
Returns:
The full path to the database or library file used in the search.
std::string getFileName ( const int id = 1 ) const

Returns the name of the results file passed into the constructor.

Parameters:
id a 1 based index. Unless appendResfile() has been called, this value must be '1'.
Returns:
the file name (or file path) of the results file.
Examples:
repeat_search.cpp.
int getJobNumber ( const int resfileID = 1 ) const

Return the job number for this file - obtained from the file name.

The library can only 'guess' at this since the value is not in the results file. To perform this function, it retrieves the job number from the file name, so be warned about changing file names. The function returns 0 if it cannot determine the job number.

Parameters:
resfileID is the the 1 based id of the results file. If multiple files have been merged together with appendResfile(), use the file ID returned by appendResfile() or getSrcFileIdForMultiFile() to access the job number of the appended files.
Returns:
the derived job number.
void getKeepAlive | ( | KA_TASK & | kaTask,
 |  | int & | kaPercentage,
 |  | std::string & | kaAccession,
 |  | int & | kaHit,
 |  | int & | kaQuery,
 |  | std::string & | kaText
 | ) |  | const

Return the progress indicators used by the keepAlive functions.

See Multiple return values in Perl, Java, Python and C# although there may be issues with some languages and the kaTask parameter.

It is normally easier for client applications to call ms_mascotresults::getCreateSummaryProgress() or outputKeepAlive() than to call this function.

Parameters:
kaTask | is the task currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and kaPercentage will be 100
kaPercentage | is the percentage (0..100) complete for the current kaTask.
kaAccession | is the current 'accession' being processed. See outputKeepAlive() for details of which tasks set this value
kaHit | is the current hit being processed. See outputKeepAlive() for details of which tasks set this value
kaQuery | is the current 'query' being processed. See outputKeepAlive() for details of which tasks set this value
kaText | is the text that would be output by outputKeepAlive()
int getLastError ( ) const

Return the last error number - or ms_mascotresfile::ERR_NO_ERROR.

Same as calling getErrorNumber() with -1 as a parameter.

Returns:
error number

Reimplemented from ms_errors.

Examples:
peptide_list.cpp, resfile_error.cpp, and resfile_summary.cpp.
std::string getLastErrorString ( ) const

Return the last error number - or an empty string.

Same as calling getErrorString() with -1 as a parameter.

Returns:
last error string

Reimplemented from ms_errors.

Examples:
peptide_list.cpp, and resfile_error.cpp.
std::string getMascotVer ( ) const [inline]

Returns the version of Mascot used to perform the search.

Obtained from the version= entry in the header section of the file.

See also:
versionGreaterOrEqual
Returns:
the version of Mascot used to perform the search.
Examples:
resfile_info.cpp.
bool getMasses ( ms_masses * masses ) const

Returns an ms_masses object from the mass values in the results file.

For results files from Mascot 2.2 and later, this function simply calls

    if (getUnimod(&umodConfigFile) && umodConfigFile.isValid())
    {
        masses->copyFrom(&umodConfigFile);
    }

For earlier results files, it reads the residue mass values from the masses section of the file. Since this section either contains average or monoisotopic masses (but not both), the resulting ms_masses object will only have one set of masses.

See Object initialising functions in Perl, Java, Python and C#.

Parameters:
masses a pointer to a valid masses object that will accept the content from the section.
Returns:
true always.
const ms_modification * getMonoLinkModification | ( | const int | modNum,
 |  | const int | monoLink
 | ) |  | const

Returns an ms_modification object that represents a monolink variable modification.

The method performs the following steps:

  • Fetch the unimod_xl section (ms_mascotresfile::getUnimodXL()).
  • Fetch the linker name (ms_searchparams::getVarModName()) of modNum.
  • Find the corresponding ms_umod_modification entry in the unimod_xl section.
  • Wrap the correct neutral loss element as an ms_modification.

The ms_modification object contains the following fields:

  • ms_modification::getTitle() returns the modfile-style name, like "Xlink:DSS (K)".
  • ms_modification::getCode() returns the monolink code.
  • ms_modification::getMonoLinkTitle() returns a modfile-style title containing the monolink code in square brackets, like "Xlink:DSS[W] (K)".
  • ms_modification::getDelta() returns the monolink delta corresponding to the monolink code (linker delta - monolink NL).
  • ms_modification::getPairsWith() returns the code or codes this monolink pairs with, or empty string if not defined.
  • ms_modification::isGeneratedMonoLinker() returns true.
  • ms_modification::isLoopLinker() returns true if the monolink NL is zero; otherwise false.
  • The neutral loss list is empty.
Parameters:
modNum | Variable mod index in range 1..32. Usually this comes from the peptide's variable mods string.
monoLink | Index of the neutral loss element. Usually this comes from the peptide's monolink string.
Returns:
a pointer, or null if this isn't a linker or the monolink index is invalid.
std::string getMSParserVersion ( ) const

Returns the version number of the Mascot Parser library.

This version information is also available:

  • In Windows from the Mascot Parser DLL in the version 'tab'
  • From Perl using perl -Mmsparser -e "print msparser->VERSION()"
  • From Java using:
        JarFile jar = new JarFile(new File(jarName));
    Manifest jarManifest = jar.getManifest();
    Attributes mainAttributes = jarManifest.getMainAttributes();
    String version = (String) mainAttributes.get(Attributes.Name.IMPLEMENTATION_VERSION);
Returns:
the version number as a string.
int getMultiFileQueryNumber | ( | const int | localQuery,
 |  | const int | fileId
 | ) |  | const

Return the multi-file query number from the local query number in an appended file.

See Multiple return values in Perl, Java, Python and C#.

Needs to be called on the 'primary' file object rather than on a ms_mascotresfile object returned by the getResfile() function.

See Combining multiple .dat files.

Example: Assume that the primary .dat file as 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

localQuery | fileId | returned query
6 | 1 | 6
11 | 2 | 21
1 | 3 | 31

See also: getSrcQueryAndFileIdForMultiFile() for the 'inverse' function

Parameters:
localQuery | is the query number which should be a value between 1 and getNumQueries() for the ms_mascotresfile specified by fileId.
fileId | is a 1 based index to the source .dat file.
Returns:
the query number that should be used for the primary .dat file, or -1 if an invalid localQuery / fileId parameter combination is passed.
int getNumberOfErrors ( ) const

Return the number of errors since the last call to clearAllErrors.

This will be zero if there has been no error.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

Errors in other classes are accumulated here. If, for example, there is an error when creating a peptide summary, the errors need to be accessed through this class.

From version 2.5, implemented by calling getErrorHandler()->getNumberOfErrors()

See Error Handling.

See also:
getNumberOfErrors(), clearAllErrors(), getErrorNumber(), getErrorString()
Returns:
number of errors
Examples:
resfile_error.cpp, and resfile_summary.cpp.
int getNumberOfResfiles ( ) const

Multiple results files can be summed together and treated as 'one'.

See Combining multiple .dat files.

Returns:
the number of results files that have been combined together. If appendResfile() has not been called then this function will return a value of 1.
int getNumEtSeqsSearched ( const int idx = 0 ) const

Returns the number of sequences searched in the second pass of an integrated error tolerant search.

Obtained from the et_sequences= or et_sequencesX= line in the header section of the file.

See also:
getNumSeqs(), getNumSeqsAfterTax() getNumResidues()

See Integrated error tolerant search . This function will return -1 for the Original error tolerant search and for searches prior to Mascot 2.4.1

Parameters:
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is -1.
Returns:
the number of sequences that were searched in the second pass of an Integrated error tolerant search
int getNumHits ( const section sec = SEC_SUMMARY ) const

Returns the maximum number of hits possible for a protein summary.

If no parameter is passed to this function, information is returned about the standard 'summary' section.

This function returns the number of hits contained in the summary, decoy_summary, et_summary or et_decoy_summary section of the results file. The value returned by ms_proteinsummary::getNumberOfHits will generally be more useful. The number of hits recorded in the summary section sec could be zero even if there are peptide matches in the corresponding peptides section.

If appendResfile() has been called (see Combining multiple .dat files) then this value will return -1 because the protein summary is not supported for multiple dat files.

Parameters:
sec Can be one of ms_mascotresfile::SEC_SUMMARY, ms_mascotresfile::SEC_DECOYSUMMARY, ms_mascotresfile::SEC_ERRTOLSUMMARY, ms_mascotresfile::SEC_ERRTOLDECOYSUMMARY.
Returns:
The value of num_hits= in the specified section or -1 if an invalid section is passed of if the object is a multifile results file.
Examples:
resfile_info.cpp.
int getNumLibraryEntries ( const int idx = 0 ) const

Returns the number of entries in the spectral library searched.

Obtained from the library_entriesX= line in the header section of the file. Spectral library support was added in Mascot 2.6.

Parameters:
idx index of the database. Specifying a value of 0 (the default) will return the sum of all library entries searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is not a spectral library, the value returned is -1.
Returns:
the number of entries in the spectral library.
int getNumQueries ( const int resfileID = 0 ) const

Returns the number of queries (peptide masses or ms-ms spectra).

Obtained from the queries= line in the header section of the file.

Parameters:
resfileID is the the 1 based id of the results file. When the default value of 0 is used for a single .dat file, this is number of queries in the file. For Combining multiple .dat files supplying a value of zero returns the total number of queries in all the results files that have been combined. Use a value of 1 to get the number of queries just in the first .dat file.
Returns:
the number of queries or -1 if resfileID is invalid
Examples:
peptide_list.cpp, repeat_search.cpp, resfile_error.cpp, and resfile_info.cpp.
double getNumResidues ( const int idx = 0 ) const

Returns the number of residues in the FASTA file(s) searched.

Obtained from the residues= or residuesX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

See also:
getNumSeqs(), getNumSeqsAfterTax()
Parameters:
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns:
the number of residues in the FASTA file searched.
Examples:
resfile_info.cpp.
int getNumSeqs ( const int idx = 0 ) const

Returns the number of sequences in the FASTA file(s) searched.

Obtained from the sequences= or sequencesX= in the header section of the file. Multiple FASTA file support was added in Mascot 2.3

See also:
getNumSeqsAfterTax(), getNumResidues(), getNumLibraryEntries()
Parameters:
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns:
the number of sequences in the FASTA file(s).
Examples:
resfile_info.cpp.
int getNumSeqsAfterTax ( const int idx = 0 ) const

Returns the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.

Obtained from the sequences_after_tax= or sequences_after_taxX= line in the header section of the file. Multiple FASTA file support was added in Mascot 2.3.

See also:
getNumSeqs(), getNumResidues(), getNumLibraryEntries()
Parameters:
idx index of the database. Specifying a value of 0 (the default) will return the sum of all sequences after taxonomy in all FASTA files searched. Otherwise, the value should be in the range from 1 to ms_searchparams::getNumberOfDatabases(). Specifying a value outside the range of 0..ms_searchparams::getNumberOfDatabases() will result in -1 being returned. If the database at index idx is a spectral library, the value returned is 0.
Returns:
the number of sequences that passed the taxonomy filter in the FASTA file(s) searched.
Examples:
resfile_info.cpp.
int getObservedCharge | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

This is obtained from the qexp[query] value. It will come from the SEC_SUMMARY section unless decoy is set to true in which case it is obtained from the SEC_DECOYSUMMARY section.

The 'charge' returned will be 0 for Mr, otherwise it will be 1, -1, 2, -2, 3, -3 etc. and -100 for an error.

Possible error values:

  • ms_mascotresfile::ERR_MISSINGENTRY
  • ms_mascotresfile::ERR_QUERYOUTOFRANGE

If an 'ambiguous' charge state is specified for the whole search or for a specific query, then Mascot just records matches for the highest scoring charge state, and it is this charge state that is returned from this function. For example, the search may have been performed with "2+, 3+ or 4+" and ms_inputquery::getCharge() will return "2+, 3+ or 4+". If the highest scoring peptide match for a particular query was to charge state 4+, then all top 10 matches for that query will be for 4+ and this function will return '4'.

It is therefore not impossible to get different charge values from the decoy and standard sections of the results files.

This method can only read charge from the 'summary' and 'decoy_summary' sections. If the search is error tolerant or intact crosslink search, the 'et_summary' and 'crosslink_summary' sections can report charge states different from the 'summary' section. It's best to use ms_peptide::getCharge().

The functions getObservedIntensity() and getObservedMass() do not require the decoy parameter as the values will be identical from the SEC_SUMMARY and the SEC_DECOYSUMMARY sections.

See also:
getObservedMrValue
Parameters:
query | is a number in the range 1..getNumQueries()
decoy | should be false for SEC_SUMMARY and true for SEC_DECOYSUMMARY.
Returns:
the observed charge for the peptide
Examples:
resfile_error.cpp.
double getObservedIntensity ( const int query ) const

Returns the experimental intensity for the peptide.

This is obtained from SEC_SUMMARY - qintensity[query]. This value is not always available and does not need to be supplied by the end user.

Returns 0 if the query cannot be found and sets the error ms_mascotresfile::ERR_QUERYOUTOFRANGE.

Parameters:
query is a number in the range 1..getNumQueries()
Returns:
0 if the intensity value is not available.
double getObservedMass ( const int query ) const

Returns the experimental mass value as entered by the user.

This is obtained from SEC_SUMMARY - qexp[query].

Returns 0 if the value cannot be found and sets the error ms_mascotresfile::ERR_QUERYOUTOFRANGE.

Parameters:
query query number
Returns:
the observed peptide mass
double getObservedMrValue | ( | const int | query,
 |  | const bool | decoy = false
 | ) |  | const

Returns the experimental mass value (as a relative mass) as entered by the user.

This is obtained from the qmass[query] value. It will come from the SEC_SUMMARY section unless decoy is set to true in which case it is obtained from the SEC_DECOYSUMMARY section.

See also:
getObservedCharge

Returns 0 if the value cannot be found and sets the error ms_mascotresfile::ERR_QUERYOUTOFRANGE.

Parameters:
query | is a number in the range 1..getNumQueries()
decoy | should only be set to true if ms_searchparams::getDECOY returns true.
Returns:
the relative mass of the observed peptide
std::vector< std::string > getPercolatorFileNames ( ) const

Retrieve the filenames use for percolator input and output.

This function will return an empty vector unless setPercolatorFeatures() has been called before calling this.

The offsets into the return array are defined by ms_mascotresfile::PERCOLATOR_FILE_NAMES.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also:
staticGetPercolatorFileNames()
Returns:
the list of files.
ms_progress_info * getProgressInfo ( bool forPeptideSummary = false ) const

If a matrix_science::ms_progress_info object is passed to the constructor, this is returned here.

Parameters:
forPeptideSummary should be set to true to get the progress object used when creating the ms_peptidesummary, or false to return the object used when creating the ms_mascotresfile
Returns:
a pointer to the progress information. This will be null if no progressMonitor is passed in the constructor
bool getQuantitation ( ms_quant_configfile * qfile ) const

Returns an object that represents the quantitation section as a reduced quantitation.xml file.

The return value indicates that the section exists. Call ms_quant_configfile::isValid to determine whether the XML part has been parsed successfully.

For quantitation_2 and later, the contents of the file are validated against a schema by default. For quantitation_1, to explicitly validate against a schema, use ms_quant_configfile::setSchemaFileName() to choose a schema, and then use ms_quant_configfile::validateDocument() to validate.

See Object initialising functions in Perl, Java, Python and C#.

Deprecated:
See getQuantitationMethod() which is generally easier to use.
Parameters:
qfile a pointer to quantitation file object. This must be a valid pointer to a valid object, which should normally be created using the default constructor: ms_quant_configfile::ms_quant_configfile
Returns:
true if section exists and false if it doesn't
bool getQuantitationMethod ( ms_quant_method * qm ) const

Return the quantitation method object from the quantitation section of the results file.

This method returns true if all of the following apply:

  • the quantitation section exists;
  • a valid schema file location has been set using the XMLschemaDirectory parameter in the constructor or the file exists in the default location;
  • the quantitation section validates against the schema;
  • the quantitation method named in the QUANTITATION parameter exists;
  • the quantitation method can be loaded.

Otherwise the method returns false.

If the QUANTITATION parameter is empty or equals "none", then the method simply returns false. Otherwise, on failure, the method sets the warning ms_errors::ERR_MSP_QUANT_FAILEDLOAD.

Parameters:
qm A pointer to quantitation method object. This must be a valid pointer to a valid object, which should normally be created using the default constructor ms_quant_method::ms_quant_method.
Returns:
True if the method was loaded; false otherwise.
int getQuerySectionValue | ( | const int | query,
 |  | const char * | key,
 |  | char * | str,
 |  | int | maxLen
 | ) |  | const

Return the string value from a query in the results file.

Returns a string from the query section. It is generally easier to use the ms_inputquery class rather than use this lower level function.

Note:
You cannot use this method in programming languages other than C++. Use ms_inputquery instead.
Parameters:
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
str | is a pointer to a buffer to receive the string.
maxLen | is the length of the buffer (including a null terminator).
Returns:
The number of bytes in the returned, null terminated string.
double getQuerySectionValueDouble | ( | const int | query,
 |  | const char * | key
 | ) |  | const

Return the floating point value from a query in the results file.

Gets the number from the query section of the results file if it exists.

Parameters:
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
Returns:
0.0 if the value is not found. It is generally easier to use the ms_inputquery class rather than use this lower level function.
int getQuerySectionValueInt | ( | const int | query,
 |  | const char * | key
 | ) |  | const

Return the integer value from a query in the results file.

Gets the number from the query section of the results file if it exists.

Parameters:
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
Returns:
0 if the value is not found. It is generally easier to use the ms_inputquery class rather than use this lower level function.
std::string getQuerySectionValueStr | ( | const int | query,
 |  | const char * | key
 | ) |  | const

Return the string value from a query in the results file.

Gets the string from the query section of the results file if it exists. It is generally easier to use the ms_inputquery class rather than use this lower level function.

Parameters:
query | is a number in the range 1..getNumQueries()
key | is case insensitive.
Returns:
an empty string if the value is not present in the file
int getReferenceDatabaseNumberOfSL ( const int idx ) const

Return the database number of the reference database of a spectral library.

The reference database of a spectral library is either one of the databases searched -- if the reference database was part of the actual search -- or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). In the first case, getReferenceDatabaseNumberOfSL() returns a database number between 1 and ms_searchparams::getNumberOfDatabases(). In the second case, the number is above getNumberOfDatabases().

If idx does not refer to a spectral library, the method returns -1.

Parameters:
idx Database number of the spectral library of interest, between 1 and ms_searchparams::getNumberOfDatabases() and whose type is SL (see getDatabaseType())
Returns:
Database number of the reference database of the spectral library, or -1 if idx is not a spectral library.
std::string getRepeatSearchString | ( | const int | query,
 |  | const bool | fullQuery = false
 | ) |  | const

To perform a repeat search need to build up appropriate string.

If the 'fullQuery' parameter is false (the default) then the format will be:

mr from(observed, charge) query(querynum) etc.

If the 'fullQuery' parameter is true then the format will be:

mr from(observer, charge1, charge2...) ions() etc.

where 'etc' will be one or more of the following (split onto several lines here for readability):

   intensity(value) peptol(value, units) seq() comp()  tag() etag()
   title() instrument() it_mods() index() rtinseconds() rtinseconds[x]()
   scans scans[x]() rawscans rawscans[x]()
  • from contains the observed mass, and the charge found in the original search. If the fullQuery parameter is true, then the charge parameter may be a list of charge states to consider, in which case the mr value is for the first charge.
  • intensity will be returned if an intensity for the peptide was entered.
  • peptol will be returned if there is a specific tolerance override for this query. It is taken from the PepTol= line in the queryx section of the results file.
  • seq() will be returned if there was a sequence query. It is the exact text that was entered by the user, and comes from seq1= line in the queryx section of the results file. If there were multiple seq() commands in the original search, then these will be in the results file as seq1=, seq2= etc., and will be returned as seq(...) seq(...).
  • comp() will be returned if there was a composition query. It is the exact text that was entered by the user, and comes from comp1= line in the queryx section of the results file. If there were multiple comp() commands in the original search, then these will be in the results file as comp1=, comp2= etc., and will be returned as comp(...) comp(...).
  • tag() will be returned if there was a tag query. It is the exact text that was entered by the user, and comes from tag1=t line in the queryx section of the results file. If there were multiple tag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as tag(...) tag(...).
  • etag() will be returned if there was a etag query. It is the exact text that was entered by the user, and comes from tag1=e line in the queryx section of the results file. If there were multiple etag() commands in the original search, then these will be in the results file as tag1=, tag2= etc., and will be returned as etag(...) etag(...).
  • title will be returned if there was a title for the particular MS-MS spectrum. The title is returned as an escaped string.
  • instrument will be returned if there was an instrument defined at the query level in the original search. It is returned as an escaped string.
  • it_mods will be returned if modifications were defined at the query level in the original search. If there was more than modification, these will be returned as a comma separated list.
  • index will be returned if there was an index defined at the query level in the original search which will be the case for all searches in Mascot 2.3 and later. See ms_inputquery::getIndex.
  • scans or scans[x] will be returned if these were defined at the query level in the original search. They will have the format scans(29-34, 43) or scans[0](29-34) scans[1](43).
  • rtinseconds or rtinseconds[x] will be returned if these were defined at the query level in the original search. They will have the format rtinseconds(10-20, 25) or rtinseconds[0](10-20) rtinseconds[1](25).
  • rawscans or rawscans[x] will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawscans[0](pd0cy1ex1:pd0cy1ex3) rawscans[1](fn2ix1).
  • rawfile will be returned if these were defined at the query level in the original search. They will have the format, for example, of: rawfile(c:/data/rawfile.raw).
  • locus will be returned if these were defined at the query level in the original search. They will have the format, for example, of: locus(2.1.1.24.1).
  • query is only used for MS-MS spectra. To save data transfer with a repeat search, this command is used instead of resubmitting all the MS-MS ions values. When nph-mascot.exe comes to the query(x) command it gets the ions vales from the original .dat file
  • ions will be used to give a list of peaks.

Returns 0 if the value cannot be found and sets the error ms_mascotresfile::ERR_QUERYOUTOFRANGE.

See Automated repeating of searches.

Parameters:
query | is a number in the range 1..getNumQueries()
fullQuery | If true, then a complete and self contained sequence query will be returned. See above for details
Returns:
repeat search string
Examples:
resfile_input.cpp.
const ms_mascotresfile * getResfile ( int resfileID ) const

Returns a pointer to the resfile created by calling appendResfile.

See Combining multiple .dat files and Maintaining object references: two rules of thumb.

Parameters:
resfileID is the the 1 based id of the results file and must be in the range 1..getNumberOfResfiles(). A value of 1 will (not particularly usefully!) return a pointer to the ms_mascotresfile that was originally created. A value of 2 will return ms_mascotresfile created in the first successful call to appendResfile(), and so on.
Returns:
a pointer to the ms_mascotresfile object, or 0 if the parameter is invalid.
const char * getSectionName ( const section sec ) [static]

Return the section name as a string given the enum value.

The section name is intended for printing in error or log messages.

Parameters:
sec One of the values in ms_mascotresfile::section.
Returns:
Section name as string, or "(unknown)" if the enum cannot be stringified.
int getSectionValue | ( | const section | sec,
 |  | const char * | key,
 |  | char * | str,
 |  | int | maxLen
 | ) |  | const

Return the string value from any line in the results file.

Note:
You cannot use this method in programming languages other than C++. Use getSectionValueStr() instead.

Function to return a string (into the passed str value) from the results file without using STL. It is generally easier to use getSectionValueStr() which returns a std::string.

Gets the requested string from the results file if it exists. Use the enumeration to choose which section. Returns the number of characters copied into 'str' which will not be greater than maxLen. E.g.

   char s[1024];
   f.getSectionValue(ms_mascotresfile::SEC_PARAMETERS,"MODS",s,1024);
Parameters:
sec | can be any section number
key | is case insensitive.
str | is a pointer to a buffer to receive the string
maxLen | is the length of the buffer (including a null terminator)
Returns:
The number of bytes in the returned, null terminated string.
double getSectionValueDouble | ( | const section | sec,
 |  | const char * | key
 | ) |  | const

Return the floating point value from any line in the results file.

Parameters:
sec | can be any section number
key | is case insensitive.
Returns:
0.0 if the value is not found or is not a number.
int getSectionValueInt | ( | const section | sec,
 |  | const char * | key
 | ) |  | const

Return the integer value from any line in the results file.

A value of -1 will be returned if there is no corresponding entry in the results file.

A value of zero will be returned if the entry contains a value that isn't a number.

If the correct value is out of the range of representable values, INT_MAX or INT_MIN is returned.

Parameters:
sec | can be any section number
key | is case insensitive.
Returns:
the value is not found.
std::string getSectionValueStr | ( | const section | sec,
 |  | const char * | key
 | ) |  | const

Return the string value from any line in the results file.

Gets the requested string from the results file if it exists. Use the enumeration to choose which section. E.g.

    std::string s;
    s = file.getSectionValue(ms_mascotresfile::SEC_PARAMETERS, "MODS");
Parameters:
sec | can be any section number
key | is case insensitive.
Returns:
an empty string if the value is not present in the file.
std::vector< int > getSLDatabaseNumbersOfReference ( const int idx ) const

Return the database numbers of the spectral libraries whose reference database is at the given index.

The reference database of a spectral library is either one of the databases searched -- if the reference database was part of the actual search -- or a virtual database whose number is above ms_searchparams::getNumberOfDatabases(). The same database can be the reference database of multiple spectral libraries.

If idx does not refer to a reference database, the method returns the empty vector.

Parameters:
idx Database number of the reference database of interest.
Returns:
A vector of database numbers of spectral libraries whose reference database idx is. This vector can be empty.
double getSLFragmentTolerance ( int idx = 1 ) const

Returns the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance unit can be retrieved with getSLFragmentToleranceUnit().

In Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

If idx is outside its range, the method returns 0.0.

Parameters:
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns:
the effective fragment tolerance.
std::string getSLFragmentToleranceUnit ( int idx = 1 ) const

Returns the unit of the effective spectral library fragment tolerance.

When a search is run against a spectral library, the effective fragment tolerance is calculated from the user-configured library fragment tolerance and the tolerance specified in the search parameters. This may be different from ms_searchparams::getITOL() and ms_searchparams::getITOLU().

The tolerance can be retrieved with getSLFragmentTolerance().

In Mascot 2.6.01 and later, the effective tolerance value and unit are saved in the header section of the results file as sl_itolX=. For files created by Mascot 2.6.00, the value is parsed from the sl_exec_commandX= line if present.

If idx is outside its range, the method returns 0.0.

Parameters:
idx index of the database from 1 to ms_searchparams::getNumberOfDatabases().
Returns:
the tolerance unit.
bool getSrcQueryAndFileIdForMultiFile | ( | const int | q,
 |  | int & | gsqNewQuery,
 |  | int & | gsqFileId
 | ) |  | const

Return the query number and file ID in the source .dat file.

See Multiple return values in Perl, Java, Python and C#.

Useful for combining multiple results files (see Combining multiple .dat files) but also returns valid values for a single file.

Example: Assume that the primary .dat file as 10 queries, file 2 has 20 queries and file 3 has 30 queries. This function will return the following:

q | newQuery | fileId
6 | 6 | 1
21 | 11 | 2
31 | 1 | 3

See also: getMultiFileQueryNumber() for the 'inverse' function

Parameters:
q | is the query number which should be a value between 1 and getNumQueries().
gsqNewQuery | is used to return the query number in the specified source file.
gsqFileId | is a 1 based index to the source .dat file.
Returns:
true if the query is in the range 1..getNumQueries().
bool getTaxonomy ( ms_taxonomyfile * tfile ) const

Returns an object that represents taxonomy-section as a reduced taxonomy file.

The return value only indicates that the section exists. If you want to find out whether the content has been parsed successfully, call the methods of matrix_science::ms_taxonomyfile.

See Object initialising functions in Perl, Java, Python and C#.

Parameters:
tfile a pointer to taxonomy file object that will accept the content from the section.
Returns:
true if section exists and false if it doesn't.
bool getUnimod | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const

Returns an object that represents unimod-section as a reduced unimod_2.xml file.

The return value only indicates that the section exists. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters:
ufile | a pointer to unimod file object that will accept the content from the section.
useSchemaFromResfile | determines where the location of the xml schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. This parameter was added in Parser 2.5, and the default value is false to ensure that it is backward compatible with previous versions.
Returns:
true if section exists and false if it doesn't.
bool getUnimodXL | ( | ms_umod_configfile * | ufile,
 |  | bool | useSchemaFromResfile = false
 | ) |  | const

Returns an object that represents unimod_xl-section as a reduced unimod_xl.xml file.

The return value only indicates that the section exists. If you want to find out whether the XML part has been parsed successfully, call ms_umod_configfile::isValid

See Object initialising functions in Perl, Java, Python and C#.

Parameters:
ufile | a pointer to unimod file object that will accept the content from the section.
useSchemaFromResfile | determines where the location of the xml schema is defined. If 'true', then the schema location should have been defined by specifying XMLschemaDirectory in the constructor. If 'false', then ms_umod_configfile::setSchemaFileName must have been called on ufile before calling this function. ms_mascotresfile::getUnimodXL uses the same schema as ms_mascotresfile::getUnimod.
Returns:
true if section exists and false if it doesn't.
std::string getUniqueTaskID ( ) const

Returns the unique task ID used by Mascot Daemon.

Although this value is a number, it is a 64 bit integer. Some languages on some platforms cannot deal with 64 bit integers properly, so the value is returned as a string. For searches with no taskid, an empty string is returned.

Returns:
unique task id as a string
std::string getXMLschemaFilePath ( XML_SCHEMA XMLschema ) const

Gets the XML schema to be used by functions using quantitation or unimod.

See also:
setXMLschemaFilePath
Parameters:
XMLschema The XML_SCHEMA enumeration value of the required xml schema file.
Returns:
The requested xml schema value or an empty string if it has not been set.
bool isDatabaseTypeAvailable ( ) const

Check whether database types are available.

Mascot 2.6 and later save the type of the database(s) in the results file, as db_typeX= lines in the header section. If the types are not available, the database or databases searched could be AA or NA.

Returns:
If the lines exist, this method returns true; otherwise it returns false.
bool isErrorTolerant ( ) const

Returns true if the search was an error tolerant search.

Obtained from the ERRORTOLERANT value in the parameters section. In Mascot versions 1.8 and later, an error tolerant search can be run as a repeat search. In this case, one or more ACCESSIONs (which may be retrieved using ms_searchparams::getACCESSION ) must have been specified, and the results file will just contain the error tolerant search results. In Mascot 2.2 and later, a single search can be performed which contains both the standard search results and the error tolerant search results of automatically selected proteins. In this case, ms_searchparams::getACCESSION will return an empty string.

See Error tolerant searches.

See also:
http://www.matrixscience.com/help/error_tolerant_help.html
Returns:
true is the result file is from an error tolerant search, false otherwise
Examples:
resfile_info.cpp.
bool isMSMS ( ) const

Returns true if the search was an MSMS search (SEARCH=MIS).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyMSMS() member.

Returns:
true if SEARCH=MIS in the parameters section of the file.
Examples:
peptide_list.cpp, and resfile_info.cpp.
bool isPMF ( ) const

Returns true if the search was a PMF search (SEARCH=PMF).

Since all types of search may be entered as a sequence query, it may be more useful to use the anyPMF() member.

Returns:
true if SEARCH=PMF in the parameters section of the file.
Examples:
resfile_info.cpp.
bool isSQ ( ) const

Returns true if the search was a sequence query search (SEARCH=SQ).

Since all types of search may be entered as a sequence query, it may be more useful to use the anySQ() member.

Returns:
true if SEARCH=SQ in the parameters section of the file.
Examples:
resfile_info.cpp.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool outputKeepAlive ( ) const

Outputs the "keep-alive" string during time-consuming operations.

For HTML reports with large result files it is sometimes necessary to output HTML comments to keep the connection alive. This can be done by specifying the interval at which the text is output (keepAliveInterval) and the text that should be output (keepAliveText) as parameters to the ms_mascotresfile::ms_mascotresfile() constructor.

If the value of keepAliveInterval passed to ms_mascotresfile::ms_mascotresfile is not 0, then the text specfied by keepAliveText will be output approximately every keepAliveInterval seconds. A 'd' in the keepAliveText will be replaced by the number of seconds since the process started.

This functionality is implemented by calling this function 'often', rather than by using a separate thread. This means that the times between calls will not be accurate. A computationally intensive application that uses Mascot Parser can also call this function as required.

From version 2.3 onwards, the keepAliveText can contain tags that allow different text to be output for different lengthy tasks. The tags are:

  • ci= - output when creating a cache file.
  • rf= - output when reading the .dat file.
  • ap= - output when assigning peptides to proteins.
  • gp= - output when grouping proteins.
  • ul= - output when calling ms_peptidesummary::createUnassignedList()
  • qu= - output when calculating quantitation intensities for reporter or multiplex protocols.
  • cc= - output when creating a cache file as part of calling ms_peptidesummary::ms_peptidesummary
  • fd= - output when calling ms_mascotresults::getThresholdForFDRAboveIdentity or ms_mascotresults::getThresholdForFDRAboveHomology.

The text can also include the following tags which are substituted by values:

  • %d - The time elapsed since the initial call to ms-mascotresfile.
  • %p - The percentage complete for the current task.
  • %h - The hit number.
  • %q - The query number.
  • %a - The accession string for the current protein being processed.
  • %f - The filename of the .dat file being processed. May be useful for the ci= value with Combining multiple .dat files

The following table indicates which values are available for which tasks:

 | ci= | rf= | ap= | gp= | ul= | cc= | fd=
%d | X | X | X | X | X | X | X
%p | X | X | X | X | X | X | X
%h |  |  | X | X |  | X |
%q |  |  | X | X | X | X |
%a |  |  | X | X |  | X |
%f | X | X | X | X | X | X |

The %a and %h values for cc= are not output for the second half of caching.

A 'complete' example string might be: ' ul=Creating unassigned list (%p% complete)\n qu=Calculating quantitation component intensities (%p% complete)\ ci=Creating cache file (%p% complete)\n rf=Reading results file (%p% complete)\n ap=Assigning peptides to proteins (%p% complete) hit=%h, time=%d\n gp=Found protein group: %a, hit=%h, %p% complete, %d seconds\n cc=Caching results (%p% complete)\n fd=Calculating false discovery rate (%p% complete)\n '

Any text before the first tag will be used as a default for cases where text isn't supplied for a particular task. For example:

Processing: %p% complete gp=Grouping %a

would output the text:

Processing 23% complete

for all tasks except the protein grouping which would output:

Grouping gi|12345

Returns:
true if the work is complete, false otherwise
ms_searchparams& params ( ) const [inline]

Returns a reference to the search parameters class.

For C# only, params is a keyword, so this function is renamed to _params.

Returns:
reference to the ms_searchparams object
void resetKeepAlive | ( | const int | keepAliveInterval,
 |  | const char * | keepAliveText,
 |  | const bool | propagateToAppended = true,
 |  | const bool | resetStartTime = false
 | ) |  |

Replace the existing keepAlive values with new values.

KeepAlive values are passed when creating the ms_mascotresfile object, but it can be useful to change these at a later time.

See outputKeepAlive() for further details.

Parameters:
keepAliveInterval | is the new interval in seconds. Specify a value of -1 to keep the old value, or 0 to stop outputting keepAliveText.
keepAliveText | is the text to output every keepAliveInterval seconds while the file is being loaded, or while other tasks are in progress.
propagateToAppended | only has meaning if additional files have been appended by calling appendResfile().
resetStartTime | can be set to true to reset the "%d" value to zero. See outputKeepAlive() for details.
void setPercolatorFeatures | ( | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures
 | ) |  |

Set Percolator features before creating an ms_peptidesummary with Percolator scoring.

The names (and contents!) of the percolator files depend on the features that have been enabled. This means that, say, turning on an additional feature will cause a new file to be created, but the old file will still be available if the feature is removed again

Parameters:
options | contains the options stored in mascot.dat It is used to access the percolator features
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default
void setPercolatorFeatures | ( | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes
 | ) |  |

Set Percolator features before creating an ms_peptidesummary with Percolator scoring (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfile::setPercolatorFeatures(const ms_mascotoptions&, const char*).

The names (and contents!) of the percolator files depend on the features that have been enabled. This means that, say, turning on an additional feature will cause a new file to be created, but the old file will still be available if the feature is removed again

Parameters:
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures().
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe. This value is normally retrieved by calling ms_mascotoptions::isPercolatorUseRT()
bool setXMLschemaFilePath | ( | XML_SCHEMA | XMLschema,
 |  | const char * | path
 | ) |  |

Sets the XML schema to be used by functions using quantitation or unimod.

It is generally easier to pass a directory as the XMLschemaDirectory parameter to the constructor rather than calling this function for each of the required schema.

Warning:
if a relative path for the xsd is specified, then this will be relative to the document and not relative to the current working directory.

Example:

   std::string qs;
   qs  = "http://www.matrixscience.com/xmlns/schema/quantitation_1 ";
   qs += "C:/myfiles/quant_schema_1.xsd ";
   qs += "http://www.matrixscience.com/xmlns/schema/quantitation_2 ";
   qs += "../schema%20files/quantitation_2.xsd";
   setXMLschemaFilePath(XML_SCHEMA_QUANTITATION, qs.c_str());
 *

The default values used in cases where this function has not been called and no parameter is passed to the constructor are the values suitable for scripts and programs running on the Mascot Server. These values are:

 XML_SCHEMA_QUANTITATION :
     http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd
     http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd

 XML_SCHEMA_UNIMOD :
     http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd

 XML_SCHEMA_CROSSLINKING :
     http://www.matrixscience.com/xmlns/schema/crosslinking_1 ../html/xmlns/schema/crosslinking_1/crosslinking_1.xsd
Parameters:
XMLschema | must be one of the valid XML_SCHEMA values
path | should be a list of pairs "_schema_alias_ SPACE _file_path_", where SPACE is the space character. See XML_SCHEMA for the supported _scheama_alias_ values for each type of schema
Returns:
true if the XMLschema value is valid
bool staticGetPercolatorFileNames | ( | const char * | szDatFileName,
 |  | const char * | cacheDirectory,
 |  | const char * | percolatorFeatures,
 |  | const char * | additionalFeatures,
 |  | const bool | useRetentionTimes,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  | [static]

Returns a list of the Percolator input and output files for the specified data file (deprecated).

Deprecated:
This function is deprecated and has been replaced with matrix_science::ms_mascotresfile::staticGetPercolatorFileNames(const char*, const char*, const ms_mascotoptions&, const char *, std::vector<std::string>&, std::vector<bool>&).

This static function can be called without creating an ms_mascotresfile object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames()

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

The offsets into the arrays are defined by ms_mascotresfile::PERCOLATOR_FILE_NAMES

Parameters:
szDatFileName | is the absolute or relative path to the results file
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory
percolatorFeatures | is normally retrieved by calling ms_mascotoptions::getPercolatorFeatures(). The filenames encode the features so that there is no conflict
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored.
useRetentionTimes | is a flag to indicate whether retention time information is used by percolator.exe
filenames | returns the list of files
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The first value in the vector corresponds to the first value in the filename vector.
Returns:
true if all files exist
bool staticGetPercolatorFileNames | ( | const char * | szDatFileName,
 |  | const char * | cacheDirectory,
 |  | const ms_mascotoptions & | options,
 |  | const char * | additionalFeatures,
 |  | std::vector< std::string > & | filenames,
 |  | std::vector< bool > & | exists
 | ) |  | [static]

Returns a list of the Percolator input and output files for the specified data file.

This static function can be called without creating an ms_mascotresfile object, and can be used in advance of creating an object to see if the percolator files will need to be created. If an object has already been created, it is normally easier to call setPercolatorFeatures() and then getPercolatorFileNames()

Make sure you set PercolatorExeFlags in options based on whether the results file has any queries with a retention time. Otherwise, this method may generate a filename different from setPercolatorFeatures().

    bool anyRT = (whether any query has RTINSECONDS);
    std::string percolatorFlags = options.getPercolatorRtFlags(anyRT, options.isPercolatorUseRT());
    options.setPercolatorExeFlags(percolatorFlags.c_str());

See Using Percolator scores and Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

The offsets into the arrays are defined by ms_mascotresfile::PERCOLATOR_FILE_NAMES

Parameters:
szDatFileName | is the absolute or relative path to the results file
cacheDirectory | will normally be the value returned from ms_mascotoptions::getCacheDirectory
options | contains the options stored in mascot.dat It is used to access the relevant options to generate the file names
additionalFeatures | is normally a string passed to ms-createpip.exe For example, "-a numUniqPeps -r varmods" would add numUniqPeps and remove varmods from the default. Any other parameters except -a and -r are ignored.
filenames | returns the list of files
exists | is a boolean vector which will return flags indicating if the Percolator files exists. The first value in the vector corresponds to the first value in the filename vector.
Returns:
true if all files exist
bool versionGreaterOrEqual | ( | int | major,
 |  | int | minor,
 |  | int | revision
 | ) |  | const

Compare the value returned by getMascotVer() with the passed version number.

Utility function to perform easy comparison. For example, to test if a results file could have taxonomy information, use:

if (versionGreaterOrEqual(2, 4, 0)) then ...

Note:
Versions 2.3.1 to 2.4.0 of Mascot Parser returned the incorrect value. This was fixed in 2.4.1
Parameters:
major | is the major version to be compared with
minor | is the minor version to be compared with
revision | is the minor revision to be compared with
Returns:
Will return true if the version of the file is greater than or equal to the passed value
bool willCreateCache | ( | const char * | szFileName,
 |  | const ms_mascotoptions & | opts,
 |  | const char * | applicationName,
 |  | std::string & | resfileCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  | [static]

Returns true if a cache file will be created when the ms_mascotresfile constructor is called.

This static function can be called without creating an ms_mascotresfile object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s).

The purpose of this method is to get the status of the cache in addition of whether the cache will be created or not.

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters:
[in] | szFileName | is the absolute or relative path to the Fxxxxx.dat file
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[in] | applicationName | is the name of the application or script that is calling this function. The applicationName is searched for in the return value from ms_mascotoptions::getResultsCache and ms_mascotoptions::getResfileCache to determine if the application should be using cache files. If it is not found then the function returns false and sets the cacheStatus to ms_peptidesummary::RESFILE_CACHE_DISABLED_IN_OPTIONS. If null, or an empty string is passed, no check is made.
[out] | resfileCacheFileName | returns the name of the ms_mascotresfile cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns:
true if either of the cache files will be (re-)created because they does not exist or are not complete or not up to date. It will return false if the options specify that the applicationName shouldn't create or use cache files.
bool willCreateCache | ( | const char * | szFileName,
 |  | const unsigned int | flags,
 |  | const char * | cacheDirectory,
 |  | std::string * | cacheFileName
 | ) |  | [static]

Returns true if a cache file will be created when the ms_mascotresfile constructor is called.

This static function can be called without creating an ms_mascotresfile object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the same parameters as the ms_mascotresfile constructor - see the documentation for that function for details

See Static functions in Perl, Java, Python and C#

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | szFileName | - see ms_mascotresfile::ms_mascotresfile
[in] | flags | - see ms_mascotresfile::ms_mascotresfile
[in] | cacheDirectory | - see ms_mascotresfile::ms_mascotresfile
[out] | cacheFileName | - the full path name of the cache file. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns:
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the RESFILE_USE_CACHE flag has not been specified, it will always return false
The documentation for this class was generated from the following files:
  • ms_mascotresfile.hpp
  • ms_mascotresfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_mascotresults
Public Types | Public Member Functions | Protected Member Functions

ms_mascotresults Class Reference
[Mascot results file module]

Abstract class for either ms_peptidesummary or ms_proteinsummary. More...

#include <ms_mascotresults.hpp>

Inheritance diagram for ms_mascotresults:
[legend]
Collaboration diagram for ms_mascotresults:
[legend]

List of all members.

Public Types

enum DB_MATCH_TYPE {
DM_FASTA = 0,
DM_SPECTRAL_LIBRARY = 1,
DM_BOTH = 2,
DM_FASTA_FIRST_PASS = 3,
DM_FASTA_SECOND_PASS = 4
}

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

More...
enum DECOY_STATS_COUNT_TYPE {
DS_COUNT_PSM = 0,
DS_COUNT_SEQUENCE = 1
}

Type of object counted by getNumHitsAboveIdentity() and friends.

More...
enum FIND_COMPARE_FLAGS {
FC_COMPLETESTR = 0x00000001,
FC_SUBSTR = 0x00000002,
FC_STARTSTR = 0x00000003,
FC_STRTOK = 0x00000004,
FC_MASK_STR_PART = 0x0000000F,
FC_CASE_INSENSITIVE = 0x00000000,
FC_CASE_SENSITIVE = 0x00000010,
FC_MASK_CASE = 0x000000F0,
FC_FORWARD = 0x00000000,
FC_REVERSE = 0x00000100,
FC_MASK_DIRECTION = 0x00000F00,
FC_RESTRICT_TO_HIT = 0x00001000,
FC_LOOP_INTO_UNASSIGNED = 0x00002000,
FC_LOOP_FROM_UNASSIGNED = 0x00004000,
FC_UNASSIGNED_MASK = 0x00006000,
FC_SEARCH_ALL_RANKS = 0x00008000,
FC_ALL_PEPTIDES = 0x00000000,
FC_ALL_PEPTITDES = 0x00000000,
FC_SIGNIFICANT_PEPTIDES = 0x00010000,
FC_SEARCH_IGNORED_RANKS = 0x00020000,
FC_SCORING_MASK = 0x000F0000,
FC_PROTEIN_IGN_SAMESETS = 0x00100000,
FC_PROTEIN_IGN_SUBSETS = 0x00200000,
FC_PROTEIN_IGN_FAMILY = 0x00400000,
FC_PROTEIN_IGN_MASK = 0x00F00000,
FC_PROTEIN_INC_ALT_ACC = 0x01000000
}

Flags to specify how comparisons are performed in the find functions.

More...
enum FIND_FLAGS {
FT_PEPTIDE_EXP_MZ = 0x00000001,
FT_PEPTIDE_EXP_MR = 0x00000002,
FT_PEPTIDE_CALC_MZ = 0x00000004,
FT_PEPTIDE_CALC_MR = 0x00000008,
FT_PEPTIDE_STRING = 0x00000010,
FT_PEPTIDE_QUERY = 0x00000020,
FT_PEPTIDE_VARMOD = 0x00000040,
FT_PEPTIDE_FIXMOD = 0x00000080,
FT_PEPTIDE_ETMOD = 0x00000100,
FT_PEPTIDE_SLMOD = 0x00000200,
FT_PEPTIDE_VARMOD_BYNAME = 0x00000400,
FT_PEPTIDE_FIND_MASK = 0x00000FFF,
FT_PROTEIN_ACCESSION = 0x00001000,
FT_PROTEIN_DESCRIPTION = 0x00002000
}

Flags for findPeptides() and findProteins().

More...
enum FLAGS {
MSRES_NOFLAG = 0x00000000,
MSRES_GROUP_PROTEINS = 0x00000001,
MSRES_SHOW_SUBSETS = 0x00000002,
MSRES_SUBSETS_DIFF_PROT = 0x00000004,
MSRES_REQUIRE_BOLD_RED = 0x00000008,
MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010,
MSRES_IGNORE_PMF_MIXTURE = 0x00000020,
MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040,
MSRES_DECOY = 0x00000080,
MSRES_INTEGRATED_ERR_TOL = 0x00000100,
MSRES_ERR_TOL = 0x00000200,
MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400,
MSRES_CLUSTER_PROTEINS = 0x00000800,
MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000,
MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000,
MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000,
MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000,
MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000,
MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000,
MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000,
MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000,
MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000,
MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000,
MSRES_DUPE_REMOVE_NONE = 0x00400000,
MSRES_DUPE_REMOVE_A = 0x00800000,
MSRES_DUPE_REMOVE_B = 0x01000000,
MSRES_DUPE_REMOVE_C = 0x02000000,
MSRES_DUPE_REMOVE_D = 0x04000000,
MSRES_DUPE_REMOVE_E = 0x08000000,
MSRES_DUPE_REMOVE_F = 0x10000000,
MSRES_DUPE_REMOVE_G = 0x20000000,
MSRES_DUPE_REMOVE_H = 0x40000000,
MSRES_DUPE_REMOVE_I = 0x80000000,
MSRES_DUPE_DEFAULT = 0x04800000
}

Flags for the type of results.

More...
enum HOMOLOGY_THRESHOLD_SOURCE { ,
HOMTHR_FASTA = -1,
HOMTHR_SL = -2
}

Flags for getHomologyThreshold()

More...
enum IONS_HISTOGRAM {
IH_INCLUDE_TOP_MATCHES = 0x0000,
IH_INCLUDE_TOP_10_MATCHES = 0x0001
}

Flags for getIonsScoreHistogram().

More...
enum QUANT_COMPONENT_STATUS {
QCS_OK,
QCS_OK_NO_MATCH,
QCS_ERROR_NO_METHOD,
QCS_ERROR_NO_COMPONENTS,
QCS_ERROR_BAD_COMPONENT_NAME,
QCS_OK_MULTIPLE_MATCHES
}

Return codes for getQuantitationComponentForPeptide().

More...
enum sortBy {
QUERY,
SCORE,
INTENSITY
}

Flags for createUnassignedList().

More...
enum THRESHOLD_TYPE {
TT_HOMOLOGY = 0x0000,
TT_IDENTITY = 0x0001,
TT_PEPSUM_DEFAULT = 0x0002
}

Flags for getPeptideThreshold()

More...
enum TREE_CLUSTER_METHOD { ,
TCM_PAIRWISE_SINGLE = 0x0001,
TCM_PAIRWISE_MAXIMUM = 0x0002,
TCM_PAIRWISE_AVERAGE = 0x0003
}

Flags for getTreeClusterNodes().

More...
enum UNIQUE_PEP_RULES {
UPR_WITHIN_FAMILY = 0x0001,
UPR_WITHIN_FAMILY_MEMBER = 0x0002,
UPR_IGNORE_SUBSET_PROTEINS = 0x0004,
UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
}

Flags for isPeptideUnique().

More...

Public Member Functions

ms_mascotresults (const ms_mascotresfile &resfile, const ms_mascotresults_params &params)
ms_mascotresults is an abstract class; use ms_peptidesummary::ms_peptidesummary or ms_proteinsummary::ms_proteinsummary.
virtual bool | anyEmPAI () const
Return true if any emPAI values are available.
virtual bool | anyNumDiscoveredMods () const
Return true if modification discovery statistics are available.
void | cancelCreateSummary (bool newValue=true)
Cancel the call to createSummary()
virtual bool | createSummary ()
Create the summary after the ms_mascotresults object has been created.
bool | createUnassignedList (sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
virtual int | findPeptides (const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const =0
Find the next hit that contains peptides with the specified attribute.
virtual int | findProteins (const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified attributes.
virtual int | findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified accession.
virtual int | findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0
Find the next hit that contains proteins with the specified description.
virtual void | freeHit (const int hit)
Frees any memory associated with the passed hit number.
virtual int | getAllFamilyMembersWithThisPepMatch (const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const =0
Return a list of (top level) family proteins that have a match to the specified q and p.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const =0
Return a complete list of proteins that contain this same peptide match.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const =0
Return a complete list of proteins that contain this same peptide match.
virtual int | getAvePeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the average threshold value for all MS-MS data sets.
virtual bool | getComponentIntensity (const int q, const int p, const std::string &componentName, double &value, double &rawValue) const =0
Returns the component intensity for reporter or multiplex methods.
virtual const ms_protein * | getComponentProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
virtual std::string | getComponentString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0
Return q1_p2_comp string value; for h1_q2 this string is always empty.
bool | getCreateSummaryProgress (int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const
Return progress for the createSummary() call.
virtual std::vector< double > | getDiscoveredErrTolModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all error tolerant modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredErrTolModNames () const
Return the names of all error tolerant modifications discovered in this search.
virtual std::vector< double > | getDiscoveredLocalModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all query-level modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredLocalModNames () const
Return the names of all query-level modifications discovered in this search.
virtual double | getErrTolModDelta (const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const
Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModMasterNeutralLoss (const int q, const int p) const
Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModMasterString (const int q, const int p) const =0
Return the error tolerant mod primary neutral loss string from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModName (const int q, const int p, std::string *modString=NULL) const
Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolModNeutralLoss (const int q, const int p) const
Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::string | getErrTolModPepString (const int q, const int p) const =0
Return the error tolerant mod peptide neutral loss string from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::vector< double > | getErrTolModReqPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::string | getErrTolModReqPepString (const int q, const int p) const =0
Return the error tolerant mod required peptide neutral loss string from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::vector< double > | getErrTolModSlaveNeutralLoss (const int q, const int p) const
Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModSlaveString (const int q, const int p) const =0
Return the error tolerant mod slave neutral loss string from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModString (const int q, const int p) const =0
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolProbabilityThreshold () const
Return the probability threshold used for error tolerant peptides.
unsigned int | getFlags () const
Returns the flags value passed to the constructor.
unsigned int | getFlags2 () const
Return the flags2 value passed to the ms_peptidesummary constructor.
virtual ms_protein * | getHit (const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
virtual int | getHomologyThreshold (const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
virtual int | getHomologyThresholdForHistogram (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns the value for the 'yellow section' in the histogram.
virtual double | getIonsScore (const int q, const int p, const bool decoy) const =0
Returns an ions score quickly without having to load an ms_peptide object.
virtual std::vector< int > | getIonsScoreHistogram (IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns a list of counts for binned ions scores.
virtual std::string | getLibraryModString (const int q, const int p) const =0
Return the modification string of the spectral library match from q1_p1_SLmod.
virtual int | getMaxPeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the max threshold value for all MS-MS data sets.
virtual int | getMaxRankValue () const
Returns the maximum 'rank' or 'hit' or 'p' value.
int | getMinPepLenInPepSummary () const
Peptides shorter than this are ignored when putting proteins into groups.
virtual ms_protein * | getNextFamilyProtein (const int masterHit, const int id) const
Find the next protein in the family masterHit.
virtual ms_protein * | getNextSimilarProtein (const int masterHit, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSimilarProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProtein (const int masterHit, const int id, const bool searchWholeFamily=true) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual int | getNumberOfFamilyMembers () const
Return the total number of family members.
virtual int | getNumberOfHits () const
Returns the number of hits in the results.
int | getNumberOfUnassigned () const
Return the number of peptides in the unassigned list.
virtual long | getNumDecoyHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the homology threshold.
virtual long | getNumDecoyHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the identity threshold.
virtual std::vector< int > | getNumDiscoveredErrTolMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of error tolerant modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredFixedMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of fixed modifications discovered in this search.
std::vector< int > | getNumDiscoveredIntactLinks (std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const
Return the count of intact crosslinks in this search.
std::vector< int > | getNumDiscoveredLibraryMods (const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of library modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredLocalMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of query-level modifications discovered in this search.
virtual int | getNumDiscoveredNonSpecCleavage () const
Return the count of non-specific cleavages in an error tolerant search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const
Return the count of variable modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of variable modifications discovered in this search.
virtual long | getNumHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the homology threshold.
virtual long | getNumHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the identity threshold.
virtual std::vector< int > | getPepsWithSameScore (const int q, const int p) const =0
Returns a list of 'p' values for peptides with the same score.
virtual bool | getPeptide (const int q, const int p, ms_peptide *&pep) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).
virtual ms_peptide | getPeptide (const int q, const int p) const =0
Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).
virtual double | getPeptideExpectationValue (const double score, const int query, const int rank=0) const
Returns the expectation value for the given peptide score and query.
virtual int | getPeptideIdentityThreshold (const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
double | getPeptideThreshold (const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const
Return either the identity or the homology threshold.
virtual double | getProbabilityThreshold () const
Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.
virtual int | getProbFromScore (const double score) const
Returns a probability value given a score.
virtual double | getProbOfPepBeingRandomMatch (const double score, const int query) const
virtual double | getProbOfProteinBeingRandomMatch (const double score) const
virtual const ms_protein * | getProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
std::string | getProteinDescription (const char *accession, const int dbIdx=1) const
Return protein description if available.
virtual double | getProteinEmPAI (const char *accession, const int dbIdx=1, const int length=-1) const
Return protein emPAI if available.
virtual double | getProteinExpectationValue (const double score) const
Returns the expectation value for the given protein score.
double | getProteinMass (const char *accession, const int dbIdx=1) const
Return protein mass if available.
virtual int | getProteinScoreCutoff (double OneInXprobRnd) const =0
Return the 'protein' score value for cutting off results (different for peptide and protein summary).
virtual double | getProteinScoreForHistogram (const int num) const
Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.
virtual std::string | getProteinsWithThisPepMatch (const int q, const int p, const bool quotes=false)=0
Return a partial list of proteins that matched the same peptide.
void | getProteinTaxonomyIDs (const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const
Return the taxonomy ID(s), if any, from the results file.
virtual int | getProteinThreshold (double OneInXprobRnd) const
Return a threshold value for the protein summary report.
virtual int | getQmatch (const int query) const
Return the number of peptides with masses that matched this query.
virtual int | getQmatch (const int query, const ms_mascotresfile::section sec) const
Return the number of peptides with masses that matched this query.
virtual QUANT_COMPONENT_STATUS | getQuantitationComponentForPeptide (const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const =0
Get the component in the quantitation method that matches the peptide.
virtual std::string | getReadableVarMods (const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
const ms_mascotresfile & | getResfile () const
Return a reference to the resfile.
ms_mascotresults_params getResultsParameters ()
Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.
double | getSequenceMass (const char *seq) const
Return the mass of a sequence (protein or peptide).
virtual int | getTagDeltaRangeEnd (const int q, const int p) const =0
Return the second number from h1_q2_drange=0,256.
virtual int | getTagDeltaRangeStart (const int q, const int p) const =0
Return the first number from h1_q2_drange=0,256.
virtual int | getTagEnd (const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagSeries (const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagStart (const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual std::string | getTagString (const int q, const int p) const =0
Return the complete tag string from h1_q2_tag or q1_p1_tag.
virtual std::string | getTerminalResiduesString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0
Return the complete terminal residue string from h1_q1_terms or q1_p1_terms.
bool | getThresholdForFDRAboveHomology (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveHomology (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.
double | getToleranceInDalton (bool &needMass, const double *const pMass=NULL) const
Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.
virtual bool | getTreeClusterNodes (const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const
Return distances and structure suitable for a dendrogram plot.
ms_peptide | getUnassigned (const int num) const
Need to call createUnassignedList() before calling this.
bool | getUnassignedIsBold (const int num) const
Returns true if the item indexed by num in the assigned list should be bold.
bool | getUnassignedShowCheckbox (const int num) const
Returns true if the item indexed by num in the assigned list should have a check box next to it.
bool | isEmPAIallowed () const
Return true if emPAI could be calculated using data in this results file.
bool | isNA () const
Returns TRUE for a search against a nucelic acid database.
virtual bool | isPeptideUnique (const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const =0
Returns true if this peptide match is unique to one protein or one protein family.
virtual void | setSubsetsThreshold (const double scoreFraction)
Specifies which subset proteins should be reported.

Protected Member Functions

double | getIonsScoreCorrected (const double ionsScore, const long multiplicity) const
virtual double | getPepIdentThreshProtected (const int query, double OneInXprobRnd, ms_mascotresfile::section sec, DB_MATCH_TYPE dbType, double *pQmatch=0) const
Return the threshold value for this ms-ms data being a random match.

Detailed Description

Abstract class for either ms_peptidesummary or ms_proteinsummary.

The following functions provide threshold values:

  • getPeptideIdentityThreshold()
  • getAvePeptideIdentityThreshold()
  • getMaxPeptideIdentityThreshold()
  • getPeptideThreshold()
  • getProteinThreshold()
  • getHomologyThreshold()
  • getHomologyThresholdForHistogram()
  • getProbFromScore()
  • getProbOfPepBeingRandomMatch()
  • double getProbOfProteinBeingRandomMatch()
Examples:

peptide_list.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum DB_MATCH_TYPE

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

Enumerator:
DM_FASTA

Mascot matches to FASTA sequences. This is the default.

DM_SPECTRAL_LIBRARY

Matches to spectral library entries. This was introduced in Parser 2.6.

DM_BOTH

Only valid for count of matches (getNumHitsAboveIdentity() and friends): the combined count for FASTA and spectral library entries.

DM_FASTA_FIRST_PASS

Mascot matches to FASTA sequences, first pass only.

DM_FASTA_SECOND_PASS

Mascot matches to FASTA sequences, second pass only (e.g. error tolerant).

enum DECOY_STATS_COUNT_TYPE

Type of object counted by getNumHitsAboveIdentity() and friends.

Enumerator:
DS_COUNT_PSM

Count peptide-spectrum matches (PSMs). This is the default.

DS_COUNT_SEQUENCE

Count distinct peptide sequences. This was introduced in Parser 2.6.

enum FIND_COMPARE_FLAGS

Flags to specify how comparisons are performed in the find functions.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These flags are used in findProteins(), findPeptides() and the deprecated functions: findProteinsByAccession() and findProteinsByDescription(). The flags are used to specify how the comparison is performed and whether it should be a forward or reverse seach. Typically, three values will be combined together, using an OR operator; however, any default values do not need to be specifically specified.

  • Choose 1 of: FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK
  • Choose 1 of: FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE
  • Choose 1 of: FC_FORWARD, FC_REVERSE
  • Optionally choose FC_RESTRICT_TO_HIT or (FC_LOOP_INTO_UNASSIGNED and/or FC_LOOP_FROM_UNASSIGNED)
  • Optionally choose FC_SEARCH_ALL_RANKS
  • Optionally choose FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES
  • Optionally choose one or more of the FC_PROTEIN_IGN_ flags when calling findProteins()
Enumerator:
FC_COMPLETESTR

Search for the complete string. If search item is a decimal number then match the number exactly.

FC_SUBSTR

Search for any substring. Not valid if search item is a decimal number.

FC_STARTSTR

String must match to start of target string. If search item is a decimal number then match to the same decimal precision of the filter value but rounded. For example a filter value of 1234.56 will return items with values in the range (1234.555 >= value < 1234.565).

FC_STRTOK

Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a peptide sequence.

FC_MASK_STR_PART

Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified.

FC_CASE_INSENSITIVE

Case insensitive search (default).

FC_CASE_SENSITIVE

Case sensitive search.

FC_MASK_CASE

Bit mask to extract which one of FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE has been specified.

FC_FORWARD

Forward search. The returned hit number will be the same as or higher than the start hit number. (default).

FC_REVERSE

Reverse search. The returned hit number will be the same as or lower than the start hit number.

FC_MASK_DIRECTION

Bit mask to extract which one of FC_FORWARD, FC_REVERSE has been specified.

FC_RESTRICT_TO_HIT

Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_LOOP_INTO_UNASSIGNED

If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.

FC_LOOP_FROM_UNASSIGNED

If the passed hit number is 0, and no match is found in the unassigned list, then start searching at 1 if FC_FORWARD is specified or start searching at 'numHits' if FC_REVERSE is specified.

FC_UNASSIGNED_MASK

Bit mask to extract FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_SEARCH_ALL_RANKS

For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assigned to a protein hit. Use this flag to search all ranks in such queries instead.

FC_ALL_PEPTIDES

Search all peptides regardless of score (default).

FC_ALL_PEPTITDES
Deprecated:
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
FC_SIGNIFICANT_PEPTIDES

Only search peptides above identitity or homology threshold.

FC_SEARCH_IGNORED_RANKS

In integrated library mode, also search peptides that are part of a family member's list of ignored peptides.

FC_SCORING_MASK

Bit mask to extract FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES.

FC_PROTEIN_IGN_SAMESETS

Ignore sameset proteins - only used for findProteins()

FC_PROTEIN_IGN_SUBSETS

Ignore subset proteins - only used for findProteins()

FC_PROTEIN_IGN_FAMILY

Ignore family member proteins - only used for findProteins()

FC_PROTEIN_IGN_MASK

Ignore proteins flags.

FC_PROTEIN_INC_ALT_ACC

For use with findProteins() only. If protein entries in the database are representative (i.e. contain multiple accessions) and those accessions are saved in the results file (Mascot 2.4 or later), setting this flag will search all accessions of each protein entry, not just the first accession.

enum FIND_FLAGS

Flags for findPeptides() and findProteins().

Details what needs to be searched for. Any of the FT_PEPTIDE_ flags may be used for either findPeptides() or findProteins(), but the FT_PROTEIN flags may only be used for findProteins()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
FT_PEPTIDE_EXP_MZ

Find an experimental m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_EXP_MR

Find an experimental relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_CALC_MZ

Find a calculated m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_CALC_MR

Find a calculated relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_STRING

Find a peptide string.

FT_PEPTIDE_QUERY

Find a query number.

FT_PEPTIDE_VARMOD

Find a variable modification. Specifiy the modification 'number' as the string.

FT_PEPTIDE_FIXMOD

Find a fixed modification. Specifiy the modification 'number' as the string.

FT_PEPTIDE_ETMOD

Find an error tolerant modification. Specifiy a delta mass as the string.

FT_PEPTIDE_SLMOD

Find a spectral library modification. Specifiy any substring of the mod name as the string.

FT_PEPTIDE_VARMOD_BYNAME

Find a variable or query level modification. Specify any substring of the mod name as the string.

FT_PEPTIDE_FIND_MASK

Bit mask for any of the peptide values to be found.

FT_PROTEIN_ACCESSION

Find an accession - findProteins() only.

FT_PROTEIN_DESCRIPTION

Find a description - findProteins() only.

enum FLAGS

Flags for the type of results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Not all of the flags applicable for protein summary (e.g. MSRES_REQUIRE_BOLD_RED); see ms_proteinsummary.

Enumerator:
MSRES_NOFLAG

Does nothing.

MSRES_GROUP_PROTEINS

Group proteins with same peptide matches. See Grouping proteins together.

MSRES_SHOW_SUBSETS

Show proteins that only match a subset of peptides. See Grouping proteins together.

MSRES_SUBSETS_DIFF_PROT

Proteins that contain a subset of peptides are treated as a unique protein. See Grouping proteins together.

MSRES_REQUIRE_BOLD_RED

Only proteins that have a top scoring peptide not seen before will be returned.

MSRES_SHOW_ALL_FROM_ERR_TOL

If this flag is set, then all hits from error tolerant search are shown. See Error tolerant searches.

MSRES_IGNORE_PMF_MIXTURE

If this flag is set, then PMF mixtures are ignored. See Peptide mass fingerprint mixtures.

MSRES_MUDPIT_PROTEIN_SCORE

Protein scoring for the peptide summary was changed at Mascot 2.0 for large (MudPIT) searches. See ms_protein::getScore().

MSRES_DECOY

If this flag is set, then use the results from searching against the decoy database. See Target-decoy searches and false discovery rate.

MSRES_INTEGRATED_ERR_TOL

If this flag is set, then create a ms_peptidesummary object that contains results from the summary and et_summary section. See Error tolerant searches.

MSRES_ERR_TOL

If this flag is set, then create a ms_peptidesummary object that contains results from the et_summary section. See Error tolerant searches.

MSRES_MAXHITS_OVERRIDES_MINPROB

If minProbability and maxHitsToReport are both non zero, then minProbability is ignored when determining the number of proteins to be displayed. See ms_mascotresults::ms_mascotresults.

MSRES_CLUSTER_PROTEINS

Protein clustering introduced in Mascot 2.3. See Using MSRES_CLUSTER_PROTEINS.

MSRES_DUPE_INCL_IN_SCORE_NONE

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_A

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_B

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_C

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_D

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_E

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_F

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_G

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_H

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_I

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_NONE

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_A

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_B

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_C

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_D

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_E

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_F

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_G

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_H

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_I

See Treatment of duplicate peptides.

MSRES_DUPE_DEFAULT

Default parameter for treatment of duplicates. See Treatment of duplicate peptides.

enum HOMOLOGY_THRESHOLD_SOURCE

Flags for getHomologyThreshold()

The method getHomologyThreshold() accepts either a rank argument or one of the special enumerated values listed here. For backwards compatibility, the integers 1-20 have their own enumerated values.

Enumerator:
HOMTHR_FASTA

Retrieve the homology threshold for FASTA matches.

HOMTHR_SL

Retrieve the homology threshold for spectral library matches.

enum IONS_HISTOGRAM

Flags for getIonsScoreHistogram().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
IH_INCLUDE_TOP_MATCHES

The default. Just include the top match to each spectrum.

IH_INCLUDE_TOP_10_MATCHES

Instead of just the top match, use the top 10 matches to each spectrum.

enum QUANT_COMPONENT_STATUS

Return codes for getQuantitationComponentForPeptide().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
QCS_OK

The component was retrieved successfully.

QCS_OK_NO_MATCH

The quantitation method's components were searched successfully, no matching component was found.

QCS_ERROR_NO_METHOD

There is no quantitation method available (e.g. for protein summary).

QCS_ERROR_NO_COMPONENTS

There are no components specified in the quantitation method (e.g. for non-precursor method).

QCS_ERROR_BAD_COMPONENT_NAME

The peptide's component name in the Mascot results does not match any component in the quantitation method.

QCS_OK_MULTIPLE_MATCHES

The quantitation method's components were searched successfully, multiple matching components were found.

enum sortBy

Flags for createUnassignedList().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
QUERY

Sort the unassigned list by ascending query number - this is the same as ascending relative mass order.

SCORE

Sort the unassigned list by descending score.

INTENSITY

Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (from PKL files, or some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values. For a very large MS-MS file, this option can take some time to process unless there are qintensity value in the results file.

enum THRESHOLD_TYPE

Flags for getPeptideThreshold()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TT_HOMOLOGY

Homology threshold.

TT_IDENTITY

Identity threshold.

TT_PEPSUM_DEFAULT

If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor, then this will resolve to TT_HOMOLOGY, otherwise it will resolve to TT_IDENTITY.

enum TREE_CLUSTER_METHOD

Flags for getTreeClusterNodes().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TCM_PAIRWISE_SINGLE

's': pairwise single-linkage clustering.

TCM_PAIRWISE_MAXIMUM

'm': pairwise maximum- (or complete-) linkage clustering.

TCM_PAIRWISE_AVERAGE

'a': pairwise average-linkage clustering.

enum UNIQUE_PEP_RULES

Flags for isPeptideUnique().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Choose UPR_WITHIN_FAMILY or UPR_WITHIN_FAMILY_MEMBER and then optionally 'or' UPR_IGNORE_SUBSET_PROTEINS

Enumerator:
UPR_WITHIN_FAMILY

The peptide is unique if it occurs in proteins that are part of a single family.

UPR_WITHIN_FAMILY_MEMBER

The peptide is unique if it occurs in proteins that just belong to a single family member.

UPR_IGNORE_SUBSET_PROTEINS

Ignore any susbset proteins that contain the match when deciding if a peptide is unique. However, if the peptide just belongs to subset proteins for the same hit, then it is still considered to be unique.

UPR_DEFAULT

Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.

Constructor & Destructor Documentation

ms_mascotresults | ( | const ms_mascotresfile & | resfile,
 |  | const ms_mascotresults_params & | params
 | ) |  |

ms_mascotresults is an abstract class; use ms_peptidesummary::ms_peptidesummary or ms_proteinsummary::ms_proteinsummary.

Creating an ms_mascotresults object (or any derived class object, e.g. ms_proteinsummary or ms_peptidesummary) may take some time for a very large file with a large number of protein hits.

Parameters:
resfile | An ms_mascotresfile object. See Maintaining object references: two rules of thumb.
params | Constructor parameters encapsulatedas ms_mascotresults_params.

Member Function Documentation

bool anyEmPAI ( ) const [virtual]

Return true if any emPAI values are available.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns:
true if above conditions are true and at least one protein has a non-zero emPAI value.

Reimplemented in ms_peptidesummary.

bool anyNumDiscoveredMods ( ) const [virtual]

Return true if modification discovery statistics are available.

Modification discovery counts for fixed and variable modifications (and error tolerant modifications in an error tolerant search) are only available if the results file contains a Unimod section. Since only significant rank 1 peptide matches assigned to a protein hit are inspected for modification counting purposes, it is possible for the counts to be zero even when a Unimod section exists.

Returns:
True if number of modifications could be counted and there is at least one modification with a non-zero count; false otherwise.
void cancelCreateSummary ( bool newValue = true )

Cancel the call to createSummary()

It is normally recommended that an application should delete the ms_peptidesummary object after calling this function because some objects will still be in memory (no cleanup is performed).

Cancelling may not occur immediately, and the calling application needs to wait for the createSummary() call to return.

See also getCreateSummaryProgress() and ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

Parameters:
newValue should be set to true to cancel the createSummary call
bool createSummary ( ) [virtual]

Create the summary after the ms_mascotresults object has been created.

Creating an ms_peptidesummary object for a large results file can take a considerable amount of time. The standard Mascot reports do not have an option to 'cancel' the creation of the report and rely on the ms_mascotresfile::outputKeepAlive() function to provide progress reports and keep the connection alive. This is not so desireable for a client application that doesn't want to redirect stdout, and wants to allow the user to cancel a long operation. Specify the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag when creating the ms_peptidesummary object, and then use one thread to call this function and a separate thread to call getCreateSummaryProgress() and report progress to the end user.

This function is called directly by the ms_mascotresults constructor unless the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag is specified. If that flag is specified, then the constructor returns 'immediately' and this function must be called by the client code. Until this function returns, the client code in the separate thread can only reliably call the getCreateSummaryProgress(), ms_mascotresfile::outputKeepAlive() or cancelCreateSummary() functions. Calling any other function for the ms_mascotresults object may result in undefined behaviour and cause the ms_mascotresfile::ERR_RESULTS_NOT_CREATED error to be set.

This function should not be called for a ms_proteinsummary.

Returns:
true if successful

Reimplemented in ms_peptidesummary.

bool createUnassignedList ( sortBy s = QUERY )

To have a list of unassigned peptides, need to call this first.

See Unassigned peptides list for details of creating an unassigned list.

Parameters:
s order to sort the unassigned list
Returns:
Currently always returns true unless createSummary() has not completed
Examples:
resfile_summary.cpp.
int findPeptides | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const [pure virtual]

Find the next hit that contains peptides with the specified attribute.

Note:
For a protein summary, this function always returns -1.

Can be used to find peptide-spectrum matches with a specified query number, sequence, mass, or fixed or variable modification. Returns the protein hit number and a list of q,p values that contains one or more string matches to the input string.

In crosslinked searches, both alpha and beta peptides are compared to the search criteria. Only one needs to match the input string.

All subset, sameset and family member proteins are searched, and it is possible that the returned q and p values only correspond to peptides in a single subset protein. The FC_PROTEIN_IGN_SAMESETS, FC_PROTEIN_IGN_SUBSETS and FC_PROTEIN_IGN_FAMILY flags cannot be used with this function. To find proteins which contain particular peptide matches, or to control which proteins to search, see findProteins().

For FT_PEPTIDE_VARMOD , str should contain the modification 'number' as passed to ms_searchparams::getVarModsName(). Modification numbers between 1 and 9 correspond to strings "1" through "9", and numbers between 10 and 32 correspond to "A" through "W". To find all error tolerant modifications, specify "X" and then use ms_peptidesummary::getErrTolModName() to retrieve the name of the modification.

For FT_PEPTIDE_FIXMOD, str should contain the modification 'number' as passed to ms_searchparams::getFixedModsName(). This will be in the range 1-20.

For both types of modification searches, str should only contain a single character. The value for compareFlags should include FC_SUBSTR, because this function is implemented by searching the return value from ms_peptide::getVarModsStr(). Specifying incorrect flags does not generate an error and results in undefined behaviour.

There is an alternative way to search for fixed mods: specify FT_PEPTIDE_STRING and FC_STRTOK as item and compareFlags, respectively, and pass the return value of ms_searchparams::getFixedModsResidues() as the string to search for, str. Although this may seem equivalent to the combination FT_PEPTIDE_FIXMOD and FC_SUBSTR, there are two corner cases where the latter works while the former doesn't:

  • ms_searchparams::getFixedModsResidues() can return "N_term" or "C_term", which are clearly not strings of amino acids.
  • The case where a fixed mod is 'replaced' with a variable mod. For example, if Carbamidomethyl (C) is specified as a fixed mod and Propionamide (C) as variable mod, then it is not sufficient to just check if a peptide contains a cysteine.
Parameters:
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1. To search the unassigned list, pass a value of 0.
str | is the string to be matched.
item | is the peptide item to be found (for example, the peptide sequence or mass). Any of the FT_PEPTIDE_ values may be used.
compareFlags | specifies whether the str value is required to match all or just part of the target string. It can also be used to specify a reverse search.
q | is a vector of query values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
p | is a vector of corresponding rank values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned matched items, or 0 if the match is in the unassigned list, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

int findProteins | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [pure virtual]

Find the next hit that contains proteins with the specified attributes.

Note:
For a protein summary, this function always returns -1.

Used to find accessions, protein descriptions or proteins that have peptide matches with a specified query number, sequence, mass, or fixed or variable modification. Any of the FIND_FLAGS may be used.

The findPeptides() function does not return any information about which subset/sameset/family proteins in a hit contain the found matches. findProteins(), however, returns a list of the protein accessions that contained a peptide match that fits the search criteria, and also allows the searched proteins to exclude samesets (FC_PROTEIN_IGN_SAMESETS), subsets (FC_PROTEIN_IGN_SUBSETS or family members (FC_PROTEIN_IGN_FAMILY).

If protein entries in the database are representative (i.e. contain multiple accessions), by default only the first accession will be considered when FT_PROTEIN_ACCESSION is specified as a search item. If alternative accessions are saved in the results file (Mascot 2.4 or later), setting FC_PROTEIN_INC_ALT_ACC will search all accessions of each protein entry. Note that this will make the search slower.

Parameters:
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the string to be matched and depends on the value of item. If item is FT_PROTEIN_ACCESSION, then str will be the accession (or part of one) to be matched. If item is one of the FT_PEPTIDE_ values, then see FIND_FLAGS and findPeptides() for operational details.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
item | is the accession, description or peptide item to be found. For example, return all proteins with a given peptide sequence or mass.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains the matches, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

int findProteinsByAccession | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [pure virtual]

Find the next hit that contains proteins with the specified accession.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Note:
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with accessions that match to the the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Parameters:
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

int findProteinsByDescription | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [pure virtual]

Find the next hit that contains proteins with the specified description.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Note:
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with descriptions that match the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Descriptions are just those included in the results file. See getProteinDescription() for details of what is loaded into the results.

Parameters:
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
compareFlags | specifies whether the str value is required to match all or just part of the description. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implemented in ms_peptidesummary, and ms_proteinsummary.

void freeHit ( const int hit ) [virtual]

Frees any memory associated with the passed hit number.

Has no effect except when Using the ms_peptidesummary cache. This function frees the ms_protein objects for the specified hit. The return values from getHit(), getNextFamilyProtein(), getNextSimilarProtein(), getNextSimilarProteinOf(), getNextSubsetProtein() etc. for this hit will then point to deleted objects and hence should not be used.

In addition, any ms_peptide objects loaded into memory using the getPeptide(const int, const int, ms_peptide *&)const function will 'unloaded' if the ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE has been specified. This function has no effect on the ms_peptide objects returned from the alternative getPeptide(const int, const int)const function.

Parameters:
hit should be in the range 1.. getNumberOfHits().

Reimplemented in ms_peptidesummary.

int getAllFamilyMembersWithThisPepMatch | ( | const int | hit,
 |  | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | db,
 |  | std::vector< std::string > & | acc,
 |  | std::vector< int > & | dupe_status
 | ) |  | const [pure virtual]

Return a list of (top level) family proteins that have a match to the specified q and p.

Only the top level proteins are returned by this function, that is, the proteins that would be returned by getHit() and getNextFamilyProtein(). It will be considerably faster than calling ms_protein::getPeptideQuery() and related functions, because that involves loading more information from the cache and from the .dat file.

This function will return the values rapidly when caching is enabled; see Using the ms_peptidesummary cache. It also functions correctly when not using the cache.

The returned vectors are all guaranteed to have the same number of elements. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use them from programming languages other than C++.

See also:
getAllProteinsWithThisPepMatch() and getProteinsWithThisPepMatch()
Parameters:
hit | Should be in the range 1.. getNumberOfHits().
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
db | is a vector of database IDs.
acc | is the corresponding vector of accessions.
dupe_status | is the corresponding vector of ms_protein::DUPLICATE values for the returned proteins. Note that ms_protein::DUPE_Ignored will only appear in integrated library searches where the peptide match was removed due to IgnoreIonsScoreBelow.
Returns:
The number of proteins in the db/acc/dupe_status vectors.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db
 | ) |  | const [pure virtual]

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

Crosslink searches only: If you need to know whether the accessions come from the alpha or beta peptide, use the 10-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also:
getProteinsWithThisPepMatch()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues -- one for each accession
end | Returns a vector of the end residues -- one for each accession
pre | Returns a vector of the residue before the peptide -- one for each accession
post | Returns a vector of the residue after the peptide -- one for each accession
frame | Returns a vector of the frames -- one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities -- one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
Returns:
A list of all the accessions that contained the peptide matched by this result.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db,
 |  | std::vector< int > & | psmComponent
 | ) |  | const [pure virtual]

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

This method was added in Parser 2.7 for crosslinking support. If you don't need to know whether the accessions come from the alpha or beta peptide, you can use the 9-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also:
getProteinsWithThisPepMatch()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues -- one for each accession
end | Returns a vector of the end residues -- one for each accession
pre | Returns a vector of the residue before the peptide -- one for each accession
post | Returns a vector of the residue after the peptide -- one for each accession
frame | Returns a vector of the frames -- one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities -- one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
psmComponent | Returns a vector of psmComponent markers (ms_peptide::PSM) -- one for each accession. For a crosslinked match, this will be one of ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA. In all other types of match, it will always be ms_peptide::PSM_COMPLETE.
Returns:
A list of all the accessions that contained the peptide matched by this result.

Implemented in ms_peptidesummary, and ms_proteinsummary.

int getAvePeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual]

Return the average threshold value for all MS-MS data sets.

The average value is calculated by taking the mean value from calling getPeptideIdentityThreshold() for each query. This is the value that is used to be shown at the top of the standard Mascot reports in versions before Mascot 2.0. For example, threshold in the following string could be calculated by calling getAvePeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot score threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The average score threshold. If there was no MS-MS data then -1 will be returned.
bool getComponentIntensity | ( | const int | q,
 |  | const int | p,
 |  | const std::string & | componentName,
 |  | double & | value,
 |  | double & | rawValue
 | ) |  | const [pure virtual]

Returns the component intensity for reporter or multiplex methods.

This function will only succeed for MS2 based quantitation methods such as "reporter" and "multiplex" where the required data is in the .dat file. It is up to the calling application to check that this is the case using ms_mascotresfile::getQuantitationMethod and ms_quant_method::getProtocol

This function was added in Mascot Parser 2.5. If the calling application is Using the ms_peptidesummary cache and the cache files were created with Mascot Parser 2.4 or earlier, then this function will calculate the intensities on demand. The first call to this function causes values for the whole file to be calculated, which may be slow. With new cache files, all the values are saved in the cache file.

This function will only calculate values for cases where ms_quant_helper::isPeptideQuantifiable returns ms_quant_helper::PEPTIDE_IS_QUANTIFIABLE

For a particular q,p pair there will always be values for all components or for no components. There can never be a case where there is just a value available for a subset of the components.

Parameters:
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue(). For "reporter" protocols, this must be 1.
componentName | is the name of the component as defined in the method. For example, for iTRAQ this might be "114", and for one of the SILAC methods this might be "Heavy".
[out] | value | is the corrected intensity value. Corrections are applied as specified in the method included in the results file.
[out] | rawValue | is the uncorrected intensity value.
Returns:
false if the method is unable to calculate or determine an intensity value for the specified q and p values

Implemented in ms_peptidesummary, and ms_proteinsummary.

const ms_protein * getComponentProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [virtual]

Return a pointer to the protein entry given an accession.

Only use this function for the "components" of a UniGene search. It will generally be more convenient for client applications to call ms_protein::getComponent() to get an ms_protein object, both in UniGene searches and PMF mixture searches.

Parameters:
accession | is the accession string.
dbIdx | a database index (1..ms_searchparams::getNumberOfDatabases()).
Returns:
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

std::string getComponentString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [pure virtual]

Return q1_p2_comp string value; for h1_q2 this string is always empty.

Note:
This function will always return the empty string for a protein summary.

The entry in the results file might be, for example:

   q1_p2_comp=light

For a crosslinked match, the results file line is q1_p1_comp_1= or q1_p1_comp_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

See also ms_peptide::getComponentStr().

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | is the 'rank' number, which should be in the range 1..10.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns:
the full component string for a peptide summary, and the empty string for a protein summary.

Implemented in ms_peptidesummary, and ms_proteinsummary.

bool getCreateSummaryProgress | ( | int * | cspTotalPercentComplete,
 |  | unsigned int * | cspCurrTask,
 |  | int * | cspCurrTaskPercentageComplete,
 |  | std::string * | cspAccession,
 |  | int * | cspHit,
 |  | int * | cspQuery,
 |  | std::string * | cspKeepAliveText
 | ) |  | const

Return progress for the createSummary() call.

See Multiple return values in Perl, Java, Python and C#.

This function is most useful when using the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag and calling createSummary() from a separate thread. The ms_mascotresfile::outputKeepAlive() outputs progress text to stdout, and this may not be convenient for some applications.

Any of the passed parameters may be null.

Parameters:
[out] | cspTotalPercentComplete | is simply calculated from: 100 * cspCurrTask / ms_mascotresfile::KA_LAST + cspCurrTask / ms_mascotresfile::KA_LAST
[out] | cspCurrTask | is the ms_mascotresfile::KA_TASK currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and cspCurrTaskPercentageComplete will be 100
[out] | cspCurrTaskPercentageComplete | is the percentage (0..100) complete for the current cspCurrTask.
[out] | cspAccession | is the current 'accession' being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value. For languages other than C++, this will be a reference rather than a pointer to a std::string.
[out] | cspHit | is the current hit being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value
[out] | cspQuery | is the current 'query' being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value
[out] | cspKeepAliveText | is the text that would be output by ms_mascotresfile::outputKeepAlive(). To use this, specify a suitable keepAliveText to the ms_mascotresfile constructor but set keepAliveInterval to zero to prevent any output to stdout. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns:
true if the createSummary() call has completed.
std::vector< double > getDiscoveredErrTolModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const [virtual]

Return the deltas of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification deltas. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

The list of error tolerant modification deltas is most useful when used in combination with getNumDiscoveredErrTolMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredErrTolModNames()

Nucleic acid insertion, deletion and substitution whose special names are NA_INSERTION, NA_DELETION and NA_SUBSTITUTION have a delta of 0.0.

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns:
A vector of error tolerant modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< std::string > getDiscoveredErrTolModNames ( ) const [virtual]

Return the names of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification names. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted. Nucleic acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

The list of error tolerant modification names is most useful when used in combination with getNumDiscoveredErrTolMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
A vector of error tolerant modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< double > getDiscoveredLocalModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const [virtual]

Return the deltas of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredLocalModNames()

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns:
A vector of query-level modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< std::string > getDiscoveredLocalModNames ( ) const [virtual]

Return the names of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
A vector of query-level modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
double getErrTolModDelta | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL,
 |  | std::string * | deltaAsString = NULL
 | ) |  | const [virtual]

Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification delta will be 0.984020. In general, modification delta could be any valid floating point number, including 0.0.

See also:
getErrTolModName(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the delta directly
deltaAsString
Returns:
The modification delta.
std::vector< double > getErrTolModMasterNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p1_et_mods_master might be

   q1_p1_et_mods_master=1.0,2.0

The returned list will not contain the dominant neutral loss -- that can be retrieved using getErrTolModNeutralLoss().

See also:
getErrTolModSlaveNeutralLoss() and getErrTolModNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification additional primary neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModMasterString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the error tolerant mod primary neutral loss string from h1_q2_et_mods_master or q1_p1_et_mods_master.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_master might be
       q1_p2_et_mods_master=1.0,2.0
  • The entry in h1_q2_et_mods_master might be
       h1_q2_et_mods_master=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModMasterNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant master neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::string getErrTolModName | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL
 | ) |  | const [virtual]

Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification name will be Citrullination.

See also:
getErrTolModDelta(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the name directly
Returns:
The modification name, or empty string if this match has no ET modification.
double getErrTolModNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than 10 of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods might be

   q1_p1_et_mods=79.966330,97.976898,Phospho (STY)

where the highest scoring modification neutral loss, returned by this function is 97.976898.

See also:
getErrTolModName(), getErrTolModDelta(), getReadableVarMods(), getErrTolModMasterNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification neutral loss value.
std::vector< double > getErrTolModPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Some modifications specify one or more peptide neutral losses. PepNeutralLoss allows a neutral loss from the precursor to be specified so that this peak is not treated as a noise peak when being scored by Mascot. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_pep might be

   q1_p1_et_mods_pep=97.976896, 79.966330
See also:
getErrTolModReqPepNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification peptide neutral loss values as a vector of doubles See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the error tolerant mod peptide neutral loss string from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_pep might be
       q1_p2_et_mods_pep=1.0,2.0
  • The entry in h1_q2_et_mods_pep might be
       h1_q2_et_mods_pep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModPepNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant peptide neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::vector< double > getErrTolModReqPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Some modifications specify one or more required peptide neutral losses. ReqPepNeutralLoss performs the same function as PepNeutralLoss but with the additional condition that the peak must be present in the spectrum. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_reqpep might be

   q1_p1_et_mods_reqpep=97.976896, 79.966330
See also:
getErrTolModPepNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification required peptide neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModReqPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the error tolerant mod required peptide neutral loss string from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_reqpep might be
       q1_p2_et_mods_reqpep=1.0,2.0
  • The entry in h1_q2_et_mods_reqpep might be
       h1_q2_et_mods_reqpep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModReqPepNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant required peptide neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::vector< double > getErrTolModSlaveNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_slave might be

   q1_p2_et_mods_slave=1.0,2.0
See also:
getErrTolModMasterNeutralLoss(), getErrTolModNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification slave neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModSlaveString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the error tolerant mod slave neutral loss string from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_slave might be
       q1_p2_et_mods_slave=1.0,2.0
  • The entry in h1_q2_et_mods_slave might be
       h1_q2_et_mods_slave=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModSlaveNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant slave neutral loss string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::string getErrTolModString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods might be
       q1_p2_et_mods=0.984020,0.000000,Citrullination
  • The entry in h1_q2_et_mods might be
       h1_q2_et_mods=0.984020,0.000000,Citrullination

This function returns the complete string value. More useful functions are

  • ms_mascotresults::getErrTolModName(),
  • ms_mascotresults::getErrTolModDelta(),
  • ms_mascotresults::getErrTolModNeutralLoss() and
  • ms_mascotresults::getReadableVarMods(),

all of which will work for both the protein summary and the peptide summary.

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant modification string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

double getErrTolProbabilityThreshold ( ) const [virtual]

Return the probability threshold used for error tolerant peptides.

For a protein summary, this method always returns the same value as getProbabilityThreshold().

Error tolerant matches in an integrated error tolerant search can have a different probability threshold (significance threshold) from first pass peptide matches. The first pass matches always use getProbabilityThreshold() as the significance threshold, and second pass matches always use getErrTolProbabilityThreshold().

The error tolerant significance threshold is determined using ms_mascotresults_params::getTargetFDR(). If a target FDR is specified and the search is an error tolerant target-decoy search, the probability threshold is chosen such that error tolerant matches have false discovery rate (FDR) equal to the target or as close as feasible. If the search is not a target-decoy search or target FDR is not specified, the error tolerant significance threshold is the same as the first pass significance threshold.

See also:
getProbabilityThreshold(), Error tolerant searches
Returns:
probability threshold for error tolerant matches.
unsigned int getFlags ( ) const [inline]

Returns the flags value passed to the constructor.

Returns:
the ms_mascotresults::FLAGS value.
unsigned int getFlags2 ( ) const [inline]

Return the flags2 value passed to the ms_peptidesummary constructor.

For an ms_proteinsummary, will always return 0 as there is no option to set the flags2 value.

Returns:
the ms_peptidesummary::MSPEPSUM value.
ms_protein * getHit | ( | const int | hit,
 |  | const int | memberNumber = 0
 | ) |  | const [virtual]

Return the ms_protein hit - returns null if hit > number of hits.

Parameters:
hit | should be in the range 1.. getNumberOfHits().
memberNumber | Should be 1 or less for a main protein or one not in a family, or 2 or more for later sibling proteins in the hit family. If this number is greater than the number of proteins in the hit family then the function returns a null value.
Returns:
If the hit number is outside the range above, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

Examples:
peptide_list.cpp, and resfile_summary.cpp.
int getHomologyThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1
 | ) |  | const [virtual]

Returns the 'homology' threshold.

For MS-MS data only, this returns a threshold value for significant homology rather than identity. This value appears in the yellow popup box for an MS-MS result: Score greater than XX indicates homology.

The return value will be zero if the threshold is not available. The value cannot be determined if the query contains error tolerant matches, or if the query contains a tag or etag, or if the value of qmatch is less than or equal to 100.

The value returned will not be higher than the identity threshold.

In versions prior to 2.2, the homology threshold was not affected by OneInXprobRnd -- this was corrected in version 2.2.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. You can either pass ms_peptide::getRank() as the rank parameter, or use one of the enumerated values for HOMOLOGY_THRESHOLD_SOURCE. The rank determines the data source.

In an integrated spectral library search:

  • If rank = HOMTHR_FASTA, the method returns the FASTA homology threshold.
  • If the peptide at the given rank is from a FASTA database and is not a library match, the method returns the FASTA homology threshold.
  • If rank = HOMTHR_SL, the method returns zero (since library searches don't have a homology threshold).
  • If the peptide at the given rank is from a spectral library, the method returns zero.

In an integrated error tolerant search, behaviour depends on Mascot version. If the results file is from Mascot 2.8 or later:

  • If the query was selected for the second pass search, the method returns zero regardless of the rank argument.
  • If the query was only searched in the first pass, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().

If the integrated error tolerant search is from Mascot 2.7 or earlier:

  • If rank = HOMTHR_FASTA, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().
  • If the peptide at the given rank is a first pass match, the method returns the first pass homology threshold.
  • If the peptide at the given rank is an ET match, the method returns 0.
Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
Returns:
The homology threshold. If there was no MS-MS data for this query then 0 will be returned.
Examples:
resfile_summary.cpp.
int getHomologyThresholdForHistogram | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual]

Returns the value for the 'yellow section' in the histogram.

For MS-MS data only, this returns a homology (rather than identity) threshold value that is shown at the top of the report: Individual ions scores > 19 indicate peptides with significant homology (p<0.05).

The yellow area on the histogram also corresponds to this value.

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot homology threshold. If dbType is DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The homology threshold. Note that this value is only available for an MS-MS search with just one MS-MS data set, otherwise the return value will be zero.
double getIonsScore | ( | const int | q,
 |  | const int | p,
 |  | const bool | decoy
 | ) |  | const [pure virtual]

Returns an ions score quickly without having to load an ms_peptide object.

If other values are required from the ms_peptide object, then it is normally faster to call getPeptide() and then ms_peptide::getIonsScore

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
decoy | is a flag to indicate if the score should be taken from the decoy section. This should only be set to true for searches with decoy matches.
Returns:
the score, or 0 if there was no score for these q / p values.

Implemented in ms_peptidesummary, and ms_proteinsummary.

double getIonsScoreCorrected | ( | const double | ionsScore,
 |  | const long | multiplicity
 | ) |  | const [protected]
Note:
It shouldn't be necessary to call this function from outside the library.

This function is required here rather than as part of the ms_peptide object because one ms_peptide object can be used from many different proteins -- each with a different multiplicity factor.

This function subtracts the factor:

  • -10 * log(multiplicity) * $tolFact / log(10); where
  • tolFact = sqrt(ITOL * ITOL + 0.0625);
Parameters:
ionsScore | Is the uncorrected ions score.
multiplicity | can be obtained from ms_protein::getPeptideMultiplicity.
Returns:
The corrected value..
std::vector< int > getIonsScoreHistogram | ( | IONS_HISTOGRAM | flags = IH_INCLUDE_TOP_MATCHES,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual]

Returns a list of counts for binned ions scores.

  • The first element of the array returns the count of matches with a score between 0 and 1.
  • The second element of the array returns the count of matches with a score between 1 and 2.
  • The third element of the array returns the count of matches with a score between 2 and 3. etc. etc.
Parameters:
flags | Currently only IH_INCLUDE_TOP_MATCHES and IH_INCLUDE_TOP_10_MATCHES are supported.
dbType | If given, should be DM_FASTA for Mascot scores and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, empty vector is returned.)
Returns:
a vector of integers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getLibraryModString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the modification string of the spectral library match from q1_p1_SLmod.

The modification string has the format

 q1_p1_SLmod=position:mod,position:mod,...

where position is a 1-based index into the peptide sequence and mod is a numeric index into the spectral_library section of the results file. The modification name and delta can be found with ms_searchparams::getLibraryModName() and ms_searchparams::getLibraryModDelta().

Note that position 1 is the first residue of the peptide sequence, which is the same convention as with ms_peptide::getVarModsStr(). However, MSPepSearch reports terminal modifications as modifications on the first and last residue. Positions 0 and N+1 (if sequence length is N) are reserved for future use.

For Mascot matches, the library modification string is empty.

In protein summary, this method always returns the empty string.

See also:
Spectral libraries.
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | is the rank number.
Returns:
modification string of the match if it is a spectral library match and has modifications, and empty string otherwise.

Implemented in ms_peptidesummary, and ms_proteinsummary.

int getMaxPeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual]

Return the max threshold value for all MS-MS data sets.

The maximum value is calculated by taking the maximum value returned by calling getPeptideIdentityThreshold() for each query. This is the value that is shown at the top of the standard Mascot peptide summary report (version 2.0 and later). For example, threshold in the following string could be calculated by calling getMaxPeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Versions of Mascot prior to 2.0 displayed the equivalent of getAvePeptideIdentityThreshold().

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The maximum score threshold. If there was no MS-MS data then -1 will be returned.
int getMaxRankValue ( ) const [virtual]

Returns the maximum 'rank' or 'hit' or 'p' value.

For functions such as getPeptide(), a 'rank' or 'hit' value is required. The allowable range for this values depends on whether it is a protein summary or peptide summary.

For a peptide summary the value returned will normally be 10, but for an integrated error tolerant search, integrated spectral library search and integrated crosslinked search, this can be in the range 1..20.

For a protein summary the return value will be ms_mascotresfile::getNumHits() -- with the appropriate parameter passed for the case of a decoy or error tolerant search.

Returns:
max rank value
int getMinPepLenInPepSummary ( ) const

Peptides shorter than this are ignored when putting proteins into groups.

minPepLenInPepSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins together.

Specify this value when creating an ms_peptidesummary::ms_peptidesummary object. This value will always be zero for ms_proteinsummary.

Returns:
The minimum peptide length considered when creating the peptide summary.
ms_protein * getNextFamilyProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const [virtual]

Find the next protein in the family masterHit.

Call this function multiple times for each masterHit, incrementing id each time. When there are no more protein families this function will return a null value.

The main protein for the hit should be obtained by calling ms_mascotresults::getHit()

See Using MSRES_CLUSTER_PROTEINS for further information.

See also:
ms_protein::GROUP
Parameters:
masterHit | is the id for the main hit (1..n).
id | is a 'one based' number.
Returns:
The next protein family or a null value if there is no such group. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
ms_protein * getNextSimilarProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const [virtual]

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP
Parameters:
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
Returns:
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
ms_protein * getNextSimilarProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const [virtual]

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP
Parameters:
masterAccession | is the accession for the main hit.
masterDB | is the database (FASTA) ID for the main hit.
id | is a 'one based' number.
Returns:
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
ms_protein * getNextSubsetProtein | ( | const int | masterHit,
 |  | const int | id,
 |  | const bool | searchWholeFamily = true
 | ) |  | const [virtual]

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP, getNextSubsetProteinOf()
Parameters:
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
searchWholeFamily | only has meaning when MSRES_CLUSTER_PROTEINS is specified. See Using MSRES_CLUSTER_PROTEINS.
Returns:
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
ms_protein * getNextSubsetProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const [virtual]

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information.

Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP, getNextSubsetProtein()
Parameters:
masterAccession | is the accession for the master hit or a family hit.
masterDB | is the database (fasta) ID for the main hit.
id | is a 'one based' number.
Returns:
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
int getNumberOfFamilyMembers ( ) const [virtual]

Return the total number of family members.

Returns:
This function returns the number of 'top level' hits and family members, not taking into account any proteins that are identical or subsets of these hits. The value will be identical to that returned by getNumberOfHits() unless the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag has been specified. In that case the number of values returned by getNextFamilyProtein() will be included.
int getNumberOfHits ( ) const [virtual]

Returns the number of hits in the results.

Returns:
This function returns the number of 'top level' hits -- not taking into account any proteins that are identical or subsets of the 'top level' hits. ms_mascotresults::getHit() can be called with any number from 1 to the value returned by this function.
int getNumberOfUnassigned ( ) const

Return the number of peptides in the unassigned list.

See Unassigned peptides list for details of creating and using an unassigned list.

If there is no cache file for the results, then createUnassignedList() must be called before calling this function or the ms_mascotresfile::ERR_UNASSIGNED_PROG error will be set, and this function will return 0.

If a cache file has been created, then there is no requirement to call createUnassignedList() before calling this function.

Returns:
the number of peptides in the unassigned list, or 0 in the case of an error.
Examples:
resfile_summary.cpp.
long getNumDecoyHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual]

Return the number of hits from the decoy search with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold(). These values may be slightly different from the threshold for the non-decoy matches.

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

y* The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of decoy hits with a score at or above the homology threshold.
long getNumDecoyHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual]

Return the number of hits from the decoy search with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold(). This value may be slightly different from the threshold for the non-decoy matches.

For a protein summary, the number of hits is the number of protein matches. This number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of decoy hits with a score at or above the identity threshold.
std::vector< int > getNumDiscoveredErrTolMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual]

Return the count of error tolerant modifications discovered in this search.

The number of times an error tolerant modification has been discovered in the search is the number of times it appears in rank 1 matches in the search results. Since the number and kind of error tolerant modifications is (practically) unlimited, you should call getDiscoveredErrTolModNames() first to find out which error tolerant modifications appear in the search. (The count of error tolerant modifications that do not appear in the search is, of course, zero.) Amino acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

Only significant rank 1 matches assigned to a protein hit are counted. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the error tolerant modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modName | Error tolerant modification name (as returned by getDiscoveredErrTolModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the error tolerant modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredFixedMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual]

Return the count of fixed modifications discovered in this search.

The number of times a fixed modification has been discovered in the search is the number of times the terminus or residue matching its specificity appears in significant rank 1 matches assigned to a protein hit in the search results. For example, if Carbamidomethyl (C) is specified as a fixed modification, then the number of times it has been discovered in the search is the number of C residues in peptide sequences in significant rank 1 matches assigned to a protein hit.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the fixed modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a fixed modification with two different specificities in the search, discovery counts will be returned separately. For example, if fixed modification 1 is Carbamidomethyl (C) and 2 is Carbamidomethyl (N-term), then calling getNumDiscoveredFixedMods() with num = 1 returns the Carbamidomethyl count for specificity "Anywhere" and "C", while num = 2 returns the count for specificity "Any N-term" and "N-term". In both cases each vector contains a single item.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
num | Fixed modification number (same value as passed to ms_searchparams::getFixedModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the fixed modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredIntactLinks | ( | std::vector< int > & | varModNum1,
 |  | std::vector< std::string > & | position1,
 |  | std::vector< std::string > & | site1,
 |  | std::vector< int > & | varModNum2,
 |  | std::vector< std::string > & | position2,
 |  | std::vector< std::string > & | site2,
 |  | std::vector< int > & | numLinkedPeptides
 | ) |  | const

Return the count of intact crosslinks in this search.

The number of times an intact crosslink has been discovered in the search is the number of times it appears as the intact link in significant rank 1 matches assigned to a protein hit.

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the link occurred, while varModNum1, position1 and site1 have the variable mod number, position and site of the first end of the link and varModNum2, position2 and site2 have the second end.

For example, if the ith specificity is N-terminal K, the ith element of alphaPositions would be "Any N-term" and the ith element of alphaSites would be "K".

In the simplest case, there is one linker with one specificity, say Xlink:DSS (K). All the vectors have just one element. If the linker has two specificities, like Xlink:DSS (K) and Xlink:DSS (Protein N-term), there will be three site pairs: (K, K), (K, Protein N-term) and (Protein N-term, Protein N-term). The pair (Protein N-term, K) is collated with (K, Protein N-term).

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
varModNum1 | Variable modification number for the first end of link.
position1 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site1 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
varModNum2 | Variable modification number for the second end of link.
position2 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site2 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
numLinkedPeptides | A vector containing the number of linked peptides corresponding to each count. Looplinked counts have 1 peptide, while crosslinked counts have 2 peptides.
Returns:
The number of times the intact link was observed in significant rank 1 matches assigned to a protein hit.
std::vector< int > getNumDiscoveredLibraryMods | ( | const int | modId,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const

Return the count of library modifications discovered in this search.

The number of times a library modification has been discovered in the search is the number of times it appears in the library mods string in significant rank 1 spectral library matches assigned to a protein hit in the search results.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the library modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that modifications are part of the metadata of spectral library entries. Unlike in database searches, they are not specified as part of the search parameters. Some caveats apply:

  • A library modification may have the same name as a variable or fixed modification in the database search, and they may well be the same modification -- but you need to know how the library was constructed to conclude either way.
  • Library modification name is usually a free-text string, which may or may not be a Unimod modification name.
  • The MSP format for spectral libraries does not support specifities in the same way as Mascot. The "position" of the modification is not encoded in the library and is thus unknown; it will always be Anywhere.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modId | modification ID, same as passed to ms_searchparams::getLibraryModName(). Must be in range 1..ms_searchparams::getNumberOfLibraryMods().
positions | A vector of positions, always "Anywhere".
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the library modification was observed in significant rank 1 spectral library matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredLocalMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual]

Return the count of query-level modifications discovered in this search.

The number of times a query-level modification has been discovered in the search is the number of times it appears in significant rank 1 matches assigned to a protein hit in the search results.

Query-level modifications are counted separately from variable modifications (specified at search form level), because each individual query may contain up to 32 query-level variable modifications. This means the search as a whole may contain more than 32 different query-level modifications. You should call getDiscoveredLocalModNames() first to find out which query-level modifications appear in the search.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the query-level modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that only significant rank 1 matches assigned to a protein hit are counted.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modName | Query-level modification name (as returned by getDiscoveredLocalModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the query-level modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
int getNumDiscoveredNonSpecCleavage ( ) const [virtual]

Return the count of non-specific cleavages in an error tolerant search.

An error tolerant match is the product of non-specific cleavage when the residue before or after the peptide terminal residue does not match the cleavage specificity of the enzyme. For example, trypsin cleaves at C-term K or R (unless followed by P), so all tryptic peptide sequences have K or R as the (N-term) residue before the sequence. An error tolerant match with non-specific cleavage would have a residue other than K or R at N-terminus.

Only significant rank 1 matches assigned to a protein hit contribute towards the count of non-specific cleavages. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the match is not counted.

Returns:
The number of times non-specific cleavage occurred in significant rank 1 matches assigned to a protein hit, or -1 for non-error tolerant search.
std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites,
 |  | std::vector< double > & | deltas,
 |  | std::vector< std::string > & | names
 | ) |  | const [virtual]

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

The ith element in the deltas and names vectors defines the delta and name of the modification, respectively. If the search has no crosslinking method, these two parameters can be ignored. When the modification number num refers to a crosslinker, the the deltas and names vectors contain values for all monolinks represented by the entry.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
deltas | A vector of deltas.
names | A vector of names.
Returns:
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual]

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also:
getNumDiscoveredVariableMods(const int, std::vector<std::string>&, std::vector<std::string>&, std::vector<delta>&, std::vector<std::string>&) const
Parameters:
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
long getNumHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual]

Return the number of hits with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold().

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of hits with a score at or above the homology threshold.
long getNumHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual]

Return the number of hits with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold().

For a protein summary, the number of hits is the number of protein matches. The number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions make take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of hits with a score at or above the identity threshold.
std::vector< int > getPepsWithSameScore | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Returns a list of 'p' values for peptides with the same score.

Peptides with the same score will have the same pretty rank. See ms_peptide::getPrettyRank() for details.

It is preferable to call this function rather than to loop through all the ranks calling getPeptide() for each one because the cached index stores the pretty ranks and this should therefore be faster.

For a protein summary, the returned list always contains a single value that is the same as the passed p value.

Parameters:
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue().
Returns:
a list of the ranks that have the same pretty value. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Implemented in ms_peptidesummary, and ms_proteinsummary.

ms_peptide getPeptide | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfile::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters:
q is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Returns:
an ms_peptide object.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples:
peptide_list.cpp, and resfile_summary.cpp.
bool getPeptide | ( | const int | q,
 |  | const int | p,
 |  | ms_peptide *& | pep
 | ) |  | const [pure virtual]

Return the ms_peptide object given the query and either the rank (ms_peptidesummary) or the hit (ms_proteinsummary).

Note:
This function can not be used in programming languages other than C++.

To get the q and p values for a peptide in an ms_protein, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfile::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries()
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
pep | is reference to a pointer to an ms_peptide object that will be returned.
Returns:
true if the peptide exists.

Implemented in ms_peptidesummary, and ms_proteinsummary.

double getPeptideExpectationValue | ( | const double | score,
 |  | const int | query,
 |  | const int | rank = 0
 | ) |  | const [virtual]

Returns the expectation value for the given peptide score and query.

Returns the number of peptides that you would expect to get this score or higher from this database. This value is displayed as the expectation value in Mascot 2.0 and later reports. When the value is below 1, it approximates the p-value corrected for multiple testing.

For Mascot matches, the expectation value is calculated from

    E = Pthreshold * (10 ** ((Sthreshold - score) / 10))

For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

The Sthreshold value is the value returned by getHomologyThreshold() if ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specifed in the ms_peptidesummary constructor, otherwise the value used is the one returned from getPeptideIdentityThreshold().

Parser 2.8 and later can calculate expectation values for Mascot error tolerant matches. The value is based on the combined first and second pass identity threshold. If rank is zero, getPeptideExpectationValue() assumes the score is a first pass match score and calculates the value from the first pass identity or homology threshold. If rank is non-zero, the correct threshold is chosen based on the match at rank rank in this query.

ET expectation value is only available if the results file is from Mascot 2.8 and later. When you open results from Mascot 2.7 and earlier, expectation value for ET matches is -1. Note that Parser 2.7 and earlier returned a non-negative but incorrect number for ET matches.

For spectral library matches, the expectation value formula depends on report mode.

  • In integrated mode (MSPEPSUM_SL_INTEGRATED), library scores are scaled internally so that their mean and standard deviation match the mean and standard deviation of significant rank 1 Mascot matches with the same sequence in the same query. See Library scores and thresholds.
  • In SL-only mode (MSPEPSUM_SL_ONLY), the expect value formula is
     E = 0.05 * 10 ** (-(s - 300)/100).
    For example, E = 0.05 for score 300.

Spectral library support was added in Mascot Parser 2.6. If rank is zero, which is the default in Parser 2.5 and earlier, the score is assumed to be a Mascot ions score. If rank is non-zero, the correct formula is chosen based on the type of the match at rank rank in this query.

See also:
getProteinExpectationValue()
Parameters:
score | is the Mascot score to be converted.
query | specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
rank | is the rank of the match of interest in this query.
Returns:
The number of peptides that you would expect to get this score or higher from this database, or -1 if it cannot be calculated.
int getPeptideIdentityThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual]

Return the threshold value for this ms-ms data being a random match.

See also:
getAvePeptideIdentityThreshold()
Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType | If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
A score threshold. If query is < 1 or > ms_mascotresfile::getNumQueries() then -1 will be returned. If there was no MS-MS data or no match for this query, then -1 will be returned.
Examples:
peptide_list.cpp, and resfile_summary.cpp.
double getPeptideThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1,
 |  | const THRESHOLD_TYPE | thresholdType = TT_PEPSUM_DEFAULT
 | ) |  | const

Return either the identity or the homology threshold.

The default is to use identity thresholds for the original Peptide Summary and Select Summary reports. For the Family Summary grouping, homology thresholds are used, and this needs to be specified by using the ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH flag. (This flag is automatically set when using the ms_mascotresfile::get_ms_mascotresults_params helper function).

This function calls getPeptideIdentityThreshold() or getHomologyThreshold() as appropriate. If it calls getHomologyThreshold() and this returns 0, then the identity threshold is returned.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. See getHomologyThreshold().

If the peptide match at rank rank is an ET match, and the results file is from Mascot Server 2.7 or earlier, then getPeptideIdentityThreshold() returns -1 and getPeptideThreshold() returns -1.

Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries()
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
thresholdType | can be any one of the ms_mascotresults::THRESHOLD_TYPE values
Returns:
the threshold.
double getProbabilityThreshold ( ) const [virtual]

Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.

In a protein summary, the probability threshold specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

In a peptide summary, the identity and homology thresholds of a peptide match are calculated from the probability threshold (significance threshold). This is the value of "Significance threshold p&lt;" shown in Mascot search reports.

getProbabilityThreshold() returns the currently active first pass significance threshold. The value may differ from the minProbability constructor argument if a target FDR has been specified. See ms_mascotresults_params::getTargetFDR().

If target FDR has not been specified, and if a value of <= 1e-18 or >= 1 is passed to the constructor, then a value of 1/20 (0.05) will be returned by this function. Otherwise it will just return the value passed to the ms_mascotresults::ms_mascotresults constructor.

In an error tolerant search, getProbabilityThreshold() may differ from the significance threshold used during the search, which was the basis for protein selection for the second pass. This is recorded as the first_pass_threshold= line in the results file header.

Error tolerant matches use an independent significance threshold, getErrTolProbabilityThreshold().

Returns:
probability threshold for peptide matches.
int getProbFromScore ( const double score ) const [virtual]

Returns a probability value given a score.

Warning:
Do not use this without fully understanding what the function returns. It is more likely that you will want to use getPeptideExpectationValue() or getProteinExpectationValue().
Parameters:
score is the Mascot score.
Returns:
probability calculated from p = pow(10.0, (score/10.0)).
double getProbOfPepBeingRandomMatch | ( | const double | score,
 |  | const int | query
 | ) |  | const [virtual]
Deprecated:
Use getPeptideExpectationValue().

Returns the inverse of getPeptideExpectationValue(). If, for example, the identity threshold (p<0.05) for a particular query is 30, and a value of 30 is passed to this function, then the return value will be 1/0.05. If, for the same search, a peptide of interest gets a score of 50, then this function will return a value of 1 / 0.00067 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getProbOfProteinBeingRandomMatch()
Parameters:
score | is the Mascot score
query | specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
Returns:
The probability.
Examples:
resfile_summary.cpp.
double getProbOfProteinBeingRandomMatch ( const double score ) const [virtual]
Deprecated:
Use getProteinExpectationValue().

Returns the inverse of getProteinExpectationValue(). If, for example, the identity threshold (p<0.05) for a PMF search is 56, and a value of 56 is passed to this function, then the return value will be 1/0.05. If, for the same search, a protein of interest gets a score of 90, then this function will return a value of 1 / 0.000025 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getProbOfPepBeingRandomMatch()
Parameters:
score is the Mascot score to be converted.
Returns:
The inverse of getProteinExpectationValue().
const ms_protein * getProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [virtual]

Return a pointer to the protein entry given an accession.

Parameters:
accession is the accession string.
dbIdx is the database index (1..ms_searchparams::getNumberOfDatabases()).

  • For a PMF mixture in protein summary (see Peptide mass fingerprint mixtures), use the default value of 1 even if the component proteins are all from other databases.
Returns:
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

std::string getProteinDescription | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const

Return protein description if available.

This method attempts to return the 'description line' for the given accession. The description line originated from the FASTA file that was searched. An empty string will be returned if the protein is not listed in the proteins section or the summary section of the results file.

Format in the proteins section is, for example:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search all, protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

The alternative way to get the description line is to call

     ms-getseq.exe [db] [accession] title

when nothing is returned by getProteinDescription(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

If the 'protein' is actually a UniGene entry, then the description line is taken by concatenating the Gene and the Title line for the relevant entry.

If the protein is a PMF mixture, then the description line will be of the format:

 * Mixture from proteins:"gi|1234","gi|5432","gi|9999"

If the protein comes from the reference database of a spectral library, then its description is not saved in the results file and this method returns the empty string. If the protein comes from the spectral library, it may or may not have a description, depending on how the library was created.

For a search against a decoy database, if the result is from the decoy section, then the description is prefixed with "Random sequence, was ", or if there is no description in the file, "Random sequence.". Depending on the configuration of the search, Random may also be Reversed or Shuffled.

Parameters:
accession | is the accession string.
dbIdx | database index used for the search.
Returns:
The description line or an empty string.
Examples:
resfile_summary.cpp.
double getProteinEmPAI | ( | const char * | accession,
 |  | const int | dbIdx = 1,
 |  | const int | length = -1
 | ) |  | const [virtual]

Return protein emPAI if available.

The Exponentially Modified Protein Abundance Index (emPAI) offers approximate, label-free, relative quantitation of the proteins in a mixture based on protein coverage by the peptide matches in a database search result. The key publication is

Ishihama, Y., et al.: Exponentially modified protein abundance index (emPAI) for estimation of absolute protein amount in proteomics by the number of sequenced peptides per protein (2005). Molecular & Cellular Proteomics 4:1265-1272.

The number of observed peptides is determined using the function ms_protein::getNumObservedForEmPAI().

Protein sequence length is needed for emPAI calculation. You have two options:

  1. Give the sequence length as an argument to this method. You will need to fetch it with e.g. ms-getseq.exe on the Mascot Server machine.
  2. Give no argument to the method. If the protein has a mass in the results file, the mass will be used to calculate an approximate sequence length.

If no sequence length is given and the protein has no mass in the results file, the method returns -1. If you know the mass of the protein but not its sequence length, you can use the following approximate formula:

length = floor(0.5 + mass / 111)

Here 111 Da is the average mass of an amino acid residue.

If ms_mascotresults::isEmPAIallowed() is false, this method returns -1.

Parameters:
accession | Protein accession.
dbIdx | Protein database index number.
length | Protein sequence length (optional). If the length is not given, protein mass from the results file will be used to approximate it. If protein mass is not available, the method returns -1.
Returns:
emPAI or -1, as described above.

Reimplemented in ms_peptidesummary.

double getProteinExpectationValue ( const double score ) const [virtual]

Returns the expectation value for the given protein score.

Returns the number of proteins that you would expect to get this score or higher from random matches for this search. For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getPeptideExpectationValue()
Parameters:
score is the Mascot protein score to be converted.
Returns:
The expectation value.
double getProteinMass | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const

Return protein mass if available.

This method attempts to return the mass for the given accession. The protein mass is calculated during the Mascot search, and some, but not all, of these masses are saved in the results file. A value of zero will be returned if the protein is not listed in the proteins section or the summary section of the results file.

The format in the proteins section is, for example, for a protein of mass 79480.13 daltons:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search, all protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines and masses in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines and masses are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

If a mass of zero is returned by this function, then the alternative way to get the mass is to call

     ms-getseq.exe [db] [accession] seq

to get the sequence, and then call getSequenceMass(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

Parameters:
accession | is the accession string.
dbIdx | database number (1..ms_searchparams::getNumberOfDatabases()).
Returns:
The protein mass or 0.0.
Examples:
resfile_summary.cpp.
int getProteinScoreCutoff ( double OneInXprobRnd ) const [pure virtual]

Return the 'protein' score value for cutting off results (different for peptide and protein summary).

The protein probability cutoff is calculated differently for a protein summary and a peptide summary.

  • For a peptide summary, we want to display any proteins that contain even one significant peptide, which means the threshold is the same as getAvePeptideIdentityThreshold().

    For MudPIT scoring, any protein with a score greater than zero must have one or more peptides above the homology threshold, so this function returns a value of 1.

  • For a protein summary, we simply use the protein score that corresponds to the threshold.
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns:
The protein score cutoff threshold.

Implemented in ms_peptidesummary, and ms_proteinsummary.

double getProteinScoreForHistogram ( const int num ) const [virtual]

Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.

The 'well known' green and red histogram at the top of the Mascot reports is created from the top 50 protein scores in the results. However, if the number of hits requested for a peptide or protein summary is 'AUTO' or is less than 50, then there won't be 50 hits in the ms_mascotresults object so it won't be possible to create the histogram.

This simple method can reliably be used to return the score for a hit number between 1 and 50, regardless of the number of entries in the protein or peptide summary. To create the histogram, it will be necessary to call this method 50 times - with num being 1..50.

In the rare case of there being less than 50 proteins in the results file, a value of -1 will be returned for values of num that have no protein hit. If a protein is rejected because it only has peptides shorter than minPepLenInPepSummary or because the MSRES_REQUIRE_BOLD_RED is set, then this protein will not be included in the list.

Parameters:
num Is a value in the range 1..50.
Returns:
The score.
std::string getProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | const bool | quotes = false
 | ) |  | [pure virtual]

Return a partial list of proteins that matched the same peptide.

The returned string is of the following form:

    1:Q9XZJ2  2:100K_RAT  3:AAF55150

The list is the hit number / accession of all proteins that matched the same peptide. There is no indication of which database the hit is from, but this can of course be determined by calling getHit().

In ms_peptidesummary, this is taken from the list of accessions on the q1_p1= line. The returned string only includes proteins that are in the current peptide summary. This means for example that if you choose to only see the top 5 hits, and this query/rank is for a peptide that occurs in protein 6, then protein number 6 will not appear in the resulting string.

In ms_proteinsummary, the string is also constructed from the list of accessions on the q1_h1= line. There's an additional check that the query number is the same, and that the peptide is the same string.

If you want a list of accession strings rather than a single concatenated string, use the function getAllProteinsWithThisPepMatch().

Parameters:
q is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' number (in ms_proteinsummary) or 'rank' number (in ms_proteinsummary).

  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence h must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
quotes specifies whether the accessions will be quoted, which should allow accesions with spaces and colons. If true, the string returned would then be

1:"Q9XZJ2" 2:"100K_RAT" 3:"AAF55150"
Returns:
list of proteins matching the peptide, as a string

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples:
peptide_list.cpp, and resfile_summary.cpp.
void getProteinTaxonomyIDs | ( | const char * | accession,
 |  | const int | dbIdx,
 |  | std::vector< int > & | gpt_ids,
 |  | std::vector< std::string > & | gpt_accessions
 | ) |  | const

Return the taxonomy ID(s), if any, from the results file.

In Mascot 2.4.0 and later, taxonomy IDs are saved in the proteins section of the results files in the form:

   [DB::]"accession"_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

In Mascot 2.4.1 and later, taxonomy IDs are also saved in the summary section of the results files in the form:

   hN_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

For example, for a single database, with a single accession/taxonomy:

   "gi|209490801"_tax=87229

   h1=gi|209490801, ...
   h1_tax=87229

and for a multi-database search, with a single accession/taxonomy:

   02::"gi|209490801"_tax=87229

   h1_db=2
   h1=gi|209490801, ...
   h1_tax=87229

and for a single database, with multiple accession/taxonomy:

   "gi|182438931"_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

   h1=gi|182438931, ...
   h1_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

If none of the databases used for the search contain taxonomy information, then no _tax lines will be output.

If any of the databases used for the search contain taxonomy information, then a _tax line will be output for all relevant proteins. This is governed by the same rules that determine for which proteins to output the mass and description lines. If a protein has no taxonomy information (for example, the database has no taxonomy), -1 will be used as the taxonomy ID.

Therefore, to determine if taxonomy information is available in the results file, simply take any protein in the proteins section, and see if there is a corresponding _tax entry.

For most FASTA files, there is a single accession and taxonomy for each sequence entry. For the NCBInr database, identical sequences are only stored once, but there are multiple accession/description lines separated by a "Control-A" character. Each accession may have a different taxonomy. This function returns the list of taxonomy IDs and corresponding accessions. For the last example shown above, this function will return the arrays of IDs

  [455632, 649189, 455632, 649189]

and accessions

  ["gi|182438931", "gi|282872348", "gi|178467447", "gi|282574201"]

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
accession | is the primary accession
dbIdx | is the 1 based database ID
gpt_ids | the taxonomy IDs
gpt_accessions | the list of accessions
int getProteinThreshold ( double OneInXprobRnd ) const [virtual]

Return a threshold value for the protein summary report.

This is simply calculated by using:

   10.0 * log10(seqsAfterTax * OneInXprobRnd)

where seqsAfterTax is obtained from ms_mascotresfile::getNumSeqsAfterTax().

The threshold value is displayed at the top of the protein summary report: Protein scores greater than 72 are significant (p<0.05).

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns:
The protein threshold.
int getQmatch ( const int query ) const [virtual]

Return the number of peptides with masses that matched this query.

See also:
getPeptideIdentityThreshold()
getQmatch(const int, const ms_mascotresfile::section) const

If the value is greater than INT_MAX, then INT_MAX will be returned.

This function calls the getQmatch(query, section) function with the 'relevant' section which will normally be SEC_SUMMARY.

If the MSRES_DECOY flag was specified in the constructor, then the 'relevant' section will be SEC_DECOYSUMMARY. If the search is an error tolerant search, then the 'relevant' section will be SEC_ERRTOLPEPTIDES, and analogously for crosslinked searches (SEC_CROSSLINK_PEPTIDES).

However, to get the spectral library qmatch values, it is necessary to explicitly call: getQmatch(query, ms_mascotresfile::SEC_LIBRARYSUMMARY)

Parameters:
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
Returns:
the number of peptides with masses that matched this query
int getQmatch | ( | const int | query,
 |  | const ms_mascotresfile::section | sec
 | ) |  | const [virtual]

Return the number of peptides with masses that matched this query.

See also:
getQmatch(const int) const

If the value is greater than INT_MAX, then INT_MAX will be returned.

Parameters:
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
sec is the section number and can be one of:

  • ms_mascotresfile::SEC_SUMMARY
  • ms_mascotresfile::SEC_DECOYSUMMARY
  • ms_mascotresfile::SEC_ERRTOLSUMMARY
  • ms_mascotresfile::SEC_ERRTOLDECOYSUMMARY
  • ms_mascotresfile::SEC_LIBRARYSUMMARY
  • ms_mascotresfile::SEC_CROSSLINK_SUMMARY
Returns:
the number of peptides with masses that matched this query. If the specified sec doesn't exist, then 0 will be returned.
int getQuantitationComponentForPeptide | ( | const matrix_science::ms_peptide & | peptide,
 |  | matrix_science::ms_quant_component & | component,
 |  | const matrix_science::ms_quant_method * | method = NULL
 | ) |  | const [pure virtual]

Get the component in the quantitation method that matches the peptide.

If the component name has already been determined (see ms_peptide::getComponentStr()) then that component is retrieved from the method.

If the component name has not yet been determined for the peptide, each component in the method is checked in turn to determine if it is the correct component for the peptide (see ms_peptidesummary::isPeptideComponentMatch()). A component only matches the peptide if every modification group of the component matches the peptide.

This is only applicable if there is a quantitation method, the method uses the Precursor protocol and the method has components defined. If an error occurs then an error message is appended to the matrix_science::ms_mascotresfile and a matching status code is returned.

Parameters:
peptide | The peptide to find the component for.
component | This is set to the first matching component found, if any.
method | An optional parameter that overrides the quantitation method used to look for matching components. If no method is specified here then the method from the ms_mascotresfile is used.
Returns:
One of the return status codes in ms_mascotresults::QUANT_COMPONENT_STATUS.

Implemented in ms_peptidesummary, and ms_proteinsummary.

std::string getReadableVarMods | ( | const int | q,
 |  | const int | p,
 |  | const int | numDecimalPlaces = 2,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual]

Return a 'human readable' string with the variable, summed and error tolerant mods.

This function creates a string of the form

2 Oxidation (M); Phosphorylation (ST)

It works by getting the variable mods string, e.g. 0110030, using ms_peptide::getVarModsStr(). It then converts the string to a human readable form. Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W.

This function will work whether or not there are variable and/or error tolerant mods, and can be called for either the peptide or the protein summary. Variable modification names are obtained using ms_searchparams::getVarModsName() and error tolerant modification names are found using ms_mascotresults::getErrTolModName(). Library modification names, in peptide summary, are found using ms_searchparams::getLibraryModName(). See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Error tolerant mods are shown with the delta in square brackets after the modification or substitution. For example:

   R->G [-99.08]

The delta is shown to numDecimalPlaces.

If the match is an intact crosslinked match, the returned string contains a short description of the linked sites and what they are linked with. For example:

   Xlink:DSS (K) in alpha crosslinked with Xlink:DSS (K) in beta

Use ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA as the psmComponent argument to inspect the alpha and beta mods separately. In this case, the intact linker is described like "intact Xlink:DSS (K)".

Summed mods, from ms_peptide::getSummedModsStr(), and query-level mods, from ms_peptide::getLocalModsStr(), are also included in the returned string.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10.
numDecimalPlaces | (optional) Used for the display of modification deltas.
psmComponent | (optional) Either ms_peptide::PSM_COMPLETE for the match as a whole, or ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA to get components of a crosslinked match.
Returns:
The formatted string.
Examples:
resfile_summary.cpp.
const ms_mascotresfile & getResfile ( ) const

Return a reference to the resfile.

Returns:
A reference to the resfile given in the constructor.
ms_mascotresults_params getResultsParameters ( )

Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.

Returns:
An ms_mascotresults_params object containing the parameter and flag values used to generate the report.
double getSequenceMass ( const char * seq ) const

Return the mass of a sequence (protein or peptide).

The sequence mass is calculated by summing the mass of each residue, using ms_searchparams::getResidueMass, and adding terminus masses using ms_searchparams::getCTermMass and ms_searchparams::getNTermMass.

The mass is therefore the 'Mr' (uncharged) mass, and is calculated using any static modifications.

Parameters:
seq is the protein sequence.
Returns:
The relative mass of the sequence.
int getTagDeltaRangeEnd | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the second number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
the second number from the string or -1 if there is no tag match.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples:
resfile_summary.cpp.
int getTagDeltaRangeStart | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the first number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
the first number from the string or -1 if there is no tag match.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples:
resfile_summary.cpp.
int getTagEnd | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual]

Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagStart(), getTagSeries()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The residue end position of the tag.
Examples:
resfile_summary.cpp.
int getTagSeries | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual]

Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagStart(), getTagEnd()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The series that contained a match to the tag. Possible ion series numbers are
  • -1 means no matches for the tag
  • 0 "a" series (single charge)
  • 1 "a-NH3" series (single charge)
  • 2 "a" series (double charge)
  • 3 "b" series (single charge)
  • 4 "b-NH3" series (single charge)
  • 5 "b" series (double charge)
  • 6 "y" series (single charge)
  • 7 "y-NH3" series (single charge)
  • 8 "y" series (double charge)
  • 9 "c" series (single charge)
  • 10 "c" series (double charge)
  • 11 "x" series (single charge)
  • 12 "x" series (double charge)
  • 13 "z" series (single charge)
  • 14 "z" series (double charge)
  • 15 "a-H2O" series (single charge)
  • 16 "a-H2O" series (double charge)
  • 17 "b-H2O" series (single charge)
  • 18 "b-H2O" series (double charge)
  • 19 "y-H2O" series (single charge)
  • 20 "y-H2O" series (double charge)
  • 21 "a-NH3" series (double charge)
  • 22 "b-NH3" series (double charge)
  • 23 "y-NH3" series (double charge)
  • 25 "internal yb" series (single charge)
  • 26 "internal ya" series (single charge)
  • 27 "z+1" series (single charge)
  • 28 "z+1" series (double charge)
  • 29 high-enrgy "d" and "d'" series (single charge)
  • 31 high-enrgy "v" series (single charge)
  • 32 high-enrgy "w" and "w'" series (single charge)
  • 33 "z+2" series (single charge)
  • 34 "z+2" series (double charge)
Examples:
resfile_summary.cpp.
int getTagStart | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual]

Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagEnd(), getTagSeries()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The residue start position of the tag.
Examples:
resfile_summary.cpp.
std::string getTagString | ( | const int | q,
 |  | const int | p
 | ) |  | const [pure virtual]

Return the complete tag string from h1_q2_tag or q1_p1_tag.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_tag might be
       q1_p2_tag=1:10:12:6,3:1:12:1,...
  • The entry in h1_q2_tag might be
       h1_q2_tag=1:10:12:6,3:1:12:1,...

This function returns the complete string value. Every group of four numbers between commas is tagNumber:startPos:endPos:series.

More useful functions are

  • ms_mascotresults::getTagStart(),
  • ms_mascotresults::getTagEnd() and
  • ms_mascotresults::getTagSeries(),

all of which will work for both the protein summary and the peptide summary.

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete tag string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

Examples:
resfile_summary.cpp.
std::string getTerminalResiduesString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [pure virtual]

Return the complete terminal residue string from h1_q1_terms or q1_p1_terms.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in the results file might be
       q1_p2_terms=-,A:K,I:-,-:Q,-:@,R:...
  • The entry in the results file might be
       h1_q2_terms=A,Q

This function returns the complete string value. More useful functions are ms_protein::getPeptideResidueBefore() and ms_protein::getPeptideResidueAfter(), which will work for both the protein summary and the peptide summary.

ms_peptidesummary only: For a crosslinked match, the results file line is q1_p1_terms_1= or q1_p1_terms_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns:
the full terminal residues string.

Implemented in ms_peptidesummary, and ms_proteinsummary.

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.

For example, to find out which probability threshold gives 1% FDR above identity or homology threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the * minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveHomology() and getNumDecoyHitsAboveHomology().

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

Otherwise functionality is the same as getThresholdForFRDAboveIdentity(double, double*, double*, int*, int*).

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFRDAboveHomology(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.

For example, to find out which probability threshold gives 1% FDR above identity threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveIdentity() and getNumDecoyHitsAboveIdentity().

The function returns a value that maximises the number of peptide-spectrum matches while giving an FDR below the targetFDR value. In some cases, it would be possible to get an FDR closer to the supplied targetFDR, but with fewer target matches.

For a large file, this function can take some time to return. Feedback can be obtained by using ms_mascotresfile::outputKeepAlive with the fd= tag.

This function was first introduced in version 2.4.0 and the method for calculating the value was changed between version 2.4.0 and 2.4.1.

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If this function returns false, there are several possibilities:

  • The function is being called for a ms_proteinsummary object
  • The supplied targetFDR is 0, or negative
  • It is not possible to get an FDR less than the targetFDR. In this case, the lowest possible FDR is given
  • The function is being called for an error tolerant search

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  |

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFRDAboveIdentity(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
double getToleranceInDalton | ( | bool & | needMass,
 |  | const double *const | pMass = NULL
 | ) |  | const

Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.

Returns the tolerance of the result file in dalton.

Parameters:
needMass | Reference to a boolean to determine if the mass is needed to calculate the delta, namely when the tolerance unit is in % or ppm
pMass | Optional parameter to calculate the tolerance from the mass for % and ppm
Returns:
The tolerance in dalton
bool getTreeClusterNodes | ( | const int | hit,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | TREE_CLUSTER_METHOD | tcm = TCM_PAIRWISE_MAXIMUM,
 |  | double *** | reserved1 = 0,
 |  | unsigned int * | reserved2 = 0
 | ) |  | const [virtual]

Return distances and structure suitable for a dendrogram plot.

The 'distances' between each protein in the family are calculated using a tree clustering routine which, by default, implements pairwise maximum (or complete) linkage clustering. It is used for the dendrogram display in the reports introduced in Mascot 2.3.

The vectors returned by this function only contain values when MSRES_CLUSTER_PROTEINS has been specified and where there are at least two family members.

The code uses the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

A value of 0 returned in the left or right vector corresponds to the lead protein as returned by getHit(). To find the protein associated with a positive node value returned in the left or right vector, call getNextFamilyProtein() with the id value set to the value in the vector.

The distances passed to the cluster algorithm are calculated by determining which peptides need to be excluded to make one protein a subset of another. Each unique peptide sequence is considered in turn, and the distance is calculated by taking the maximum difference between the score and the value returned by getPeptideThreshold(). Additionally, where a query has matches to different peptides above threshold in each protein, the delta of the scores is added to the distance.

For details of how to use the left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
hit | is the hit number for the lead protein.
left | returns a vector of 'left' values.
right | returns a vector of 'right' values.
distance | returns a vector of 'distance' values.
tcm | is the method to be used. See documentation referenced above
reserved1 | is for Matrix Science use only
reserved2 | is for Matrix Science use only
Returns:
true unless the code causes an out of memory error.

Reimplemented in ms_peptidesummary.

ms_peptide getUnassigned ( const int num ) const

Need to call createUnassignedList() before calling this.

See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return an empty ms_peptide.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
Examples:
resfile_summary.cpp.
bool getUnassignedIsBold ( const int num ) const

Returns true if the item indexed by num in the assigned list should be bold.

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return true.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return true.
bool getUnassignedShowCheckbox ( const int num ) const

Returns true if the item indexed by num in the assigned list should have a check box next to it.

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return false.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
bool isEmPAIallowed ( ) const

Return true if emPAI could be calculated using data in this results file.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns:
true if emPAI is allowed.
bool isNA ( ) const

Returns TRUE for a search against a nucelic acid database.

There is no specific information in the results file for this. It is implemented by looking to see if there is a frame number that is non-zero in any result. If there are no matches to any query, then this method will return false and therefore may be wrong. (However, if there are no matches then it is unlikely that the outcome of this function is important!)

In versions prior to 2.3.01, this was determined by looking in protein matches. In version 2.3.01 and later, this is determined by looking in all peptide matches, regardless of score.

Returns:
True if the search was against a nucleic acid database.
bool isPeptideUnique | ( | const int | q,
 |  | const int | p,
 |  | const UNIQUE_PEP_RULES | rules = UPR_DEFAULT
 | ) |  | const [pure virtual]

Returns true if this peptide match is unique to one protein or one protein family.

Note:
This function currently returns false for ms_proteinsummary. This function is only likely to be useful for a peptide summary.

This function is used, for example, in quantitation to only report ratios for peptide sequences that are unique to one protein hit. This can be specified as part of a Mascot quantitation method; see ms_quant_quality::isUniquePepseq().

No attempt is made to collapse peptides that just differ by, for example, I or L.

The specified q and p values must be for a peptide that has a protein match in the current report, i.e. not in the unassigned list. The function searches all proteins and not just those in the current report. For example, if peptide 'ABCDEFK' appears in protein hit one and protein hit 100, then it will return false even if only the top 10 hits have been requested.

If grouping is not selected when creating the ms_peptidesummary, (i.e. neither ms_mascotresults::MSRES_GROUP_PROTEINS nor ms_mascotresults::MSRES_CLUSTER_PROTEINS), then it is likely that this function will return false for most peptides.

At version 2.3, this function did not have the optional third parameter and the default value was the same as using ms_mascotresults::UPR_WITHIN_FAMILY, which is not the default value in version 2.4 and later. At version 2.3, the function would therefore return true for all peptides with a score above the homology threshold when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the * range 1 to 50.
rules | should passed appropriate ms_mascotresults::UNIQUE_PEP_RULES flags to specify what rules are to be used for considerering when a peptide is unique.
Returns:
true if the peptide match is unique. Always false in ms_proteinsummary.

Implemented in ms_peptidesummary, and ms_proteinsummary.

void setSubsetsThreshold ( const double scoreFraction ) [virtual]

Specifies which subset proteins should be reported.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A scoreFraction of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported. The flag MSRES_SHOW_SUBSETS must have been specified if a value > 0 is used, or no subsets will be shown.

See also:
getNextSubsetProtein(), getNextSubsetProteinOf()
Parameters:
scoreFraction is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-scoreFraction). The default value is 1.0.
The documentation for this class was generated from the following files:
  • ms_mascotresults.hpp
  • ms_mascotresults.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_mascotresults_params
Public Member Functions

ms_mascotresults_params Class Reference
[Mascot results file module]

Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary. More...

#include <ms_mascotresults_params.hpp>

List of all members.

Public Member Functions

ms_mascotresults_params (const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.05, int maxHitsToReport=0, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=0)
Call this method once to create the ms_mascotresults_params.
ms_mascotresults_params (const ms_mascotresults_params &src)
Copying constructor.
void | copyFrom (const ms_mascotresults_params *right)
Copies all data from another instance of the class.
unsigned int | getFlags () const
Returns the value of the flags parameter if available.
unsigned int | getFlags2 () const
Returns the value of the flags2 parameter if available.
double | getIgnoreIonsScoreBelow () const
Returns the value of the ignoreIonsScoreBelow parameter if available.
int | getMaxHitsToReport () const
Returns the maximum number of protein hits to report.
int | getMinNumSigUniqueSequences () const
Returns the value of the MinNumSigUniqueSequences parameter.
int | getMinPepLenInPeptideSummary () const
Returns the minimum length of peptide match to use when generating a peptide summary report.
double | getMinProbability () const
Returns the significance threshold.
std::string | getSingleHit () const
Returns the optional single hit parameter used to get the results for a single hit quickly.
double | getTargetFDR () const
Returns the target FDR, if any.
ms_mascotresults::DECOY_STATS_COUNT_TYPE | getTargetFDRType () const
Returns the target FDR type.
std::string | getUnigeneIndexFile () const
Optional file path to a UniGene Index file.
bool | isUsePeptideSummary () const
Returns a hint as to whether a peptide or protein summary should be created.
ms_mascotresults_params & | operator= (const ms_mascotresults_params &right)
Assignment operator.
void | setFlag (const ms_mascotresults::FLAGS flag, bool enabled)
Toggles the value of an individual flag for use in the ms_mascotresults constructor.
void | setFlag2 (const ms_peptidesummary::MSPEPSUM flag, bool enabled)
Toggles the value of an individual flag used in the ms_peptidesummary constructor.
void | setFlags (const unsigned int flags)
Sets the value of the flags parameter for use in the ms_mascotresults constructor.
void | setFlags2 (const unsigned int flags2)
Sets the value of the flags2 parameter used in the ms_peptidesummary constructor.
void | setIgnoreIonsScoreBelow (const double ignoreIonsScoreBelow)
Sets the value of the ignoreIonsScoreBelow parameter.
void | setMaxHitsToReport (const int maxHitsToReport)
Sets the maximum number of protein hits to report.
void | setMinNumSigUniqueSequences (const int n)
Sets the value of the MinNumSigUniqueSequences parameter.
void | setMinPepLenInPeptideSummary (const int minPepLenInPeptideSummary)
Sets the minimum length of peptide match to use when generating a peptide summary report.
void | setMinProbability (const double minProbability)
Sets the significance threshold.
void | setSingleHit (const char *singleHit)
Sets the optional single hit parameter.
void | setTargetFDR (double fdr)
Sets the target FDR.
void | setTargetFDRType (ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType)
Sets the target FDR type.
void | setUnigeneIndexFile (const char *unigeneIndexFile)
Sets the optional file path to a UniGene Index file.
void | setUsePeptideSummary (const bool usePeptideSummary)
Set the hint as to whether a peptide or protein summary should be created.

Detailed Description

Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary.

Constructor & Destructor Documentation

ms_mascotresults_params | ( | const unsigned int | flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
 |  | double | minProbability = 0.05,
 |  | int | maxHitsToReport = 0,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = 0
 | ) |  |

Call this method once to create the ms_mascotresults_params.

This object has fields for all of the flags and parameters required to create peptide and protein summary result objects. Both ms_peptidesummary and ms_proteinsummary have constructors which will accept an ms_mascotresults_params object.

You do not need to supply any of the parameter values when creating an ms_mascotresults_params object as all of the parameters have setter methods, allowing you to update their values. You can also set all of the required parameters for a result by calling the get_ms_mascotresults_params method of ms_mascotresfile.

Parameters:
flags | can be one or more of the ms_mascotresults::FLAGS values OR'ed together
minProbability | specifies the significance threshold. See getMinProbability(). See also getTargetFDR().
maxHitsToReport | is a maximum value of protein hits to report. See getMaxHitsToReport().
unigeneIndexFile is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.

  • From programming languages other than C++, pass an empty string object to specify no UniGene index file.
ignoreIonsScoreBelow | is an optional flag for the peptide summary only. See getIgnoreIonsScoreBelow().
minPepLenInPepSummary | is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).
singleHit | should only be used for getting the results for a single protein quickly. See setSingleHit().
flags2 | should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'd together
ms_mascotresults_params ( const ms_mascotresults_params & src )

Copying constructor.

Parameters:
src is the source to initialise from

Member Function Documentation

void copyFrom ( const ms_mascotresults_params * right )

Copies all data from another instance of the class.

Parameters:
right is the source to initialise from
unsigned int getFlags ( ) const

Returns the value of the flags parameter if available.

The value of the flags parameter should be one or more of the ms_mascotresults::FLAGS values OR'ed together.

Returns:
The value of the flags parameter used by the ms_peptidesummary and ms_proteinsummary constructors
unsigned int getFlags2 ( ) const

Returns the value of the flags2 parameter if available.

Flags2 is an optional parameter for the peptide summary only. It's value should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'ed together.

Returns:
The value of the flags2 parameter used by the ms_peptidesummary constructor.
double getIgnoreIonsScoreBelow ( ) const

Returns the value of the ignoreIonsScoreBelow parameter if available.

ignoreIonsScoreBelow is an optional flag for the peptide summary only. Any peptides with a score less than this will be ignored. If the value is greater than 0 and less than 1 then this is assumed to to be a probability rather than an absolute score; the reciprocal of this value is passed to ms_peptidesummary::getPeptideThreshold() to determine the score cutoff.

A value of -1 is treated as equivalent to minProbability. This is the most convenient setting if you want to filter out non-significant matches.

If the search is an error tolerant search, any non-zero value is treated as equal to -1. That is, specifying IgnoreIonsScoreBelow = 0.0 will display all matches, and specifying any other value will display only significant matches.

Returns:
The value of ignoreIonsScoreBelow to use in the ms_peptidesummary constructor
int getMaxHitsToReport ( ) const

Returns the maximum number of protein hits to report.

This is a maximum value. There may be fewer than this number if minProbability is low (or > 1 and high), or if there are insufficient results.

  • If the ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB flag is set, then the minProbability value is ignored when determining the number of hits to display.
  • With versions of parser before Mascot 2.2, this flag was not available so a value of 0 was passed as minProbability in the standard Mascot results reports. Also, if this flag is specified, a value of zero can be used for maxHitsToReport and the cutoff is then specified by minProbability.
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins -- the similar and subset proteins are not included in the count.
Returns:
The maximum number of protein hits to report.
int getMinNumSigUniqueSequences ( ) const

Returns the value of the MinNumSigUniqueSequences parameter.

MinNumSigUniqueSequences is an optional flag for the peptide summary only. A protein hit must have at least as many significant unique sequences to be reported as a hit. A peptide sequence is significant if it has at least one peptide match above significance threshold, and it is unique if it appears in no other protein hit.

The default is 1. The value range is between 1 and 5, inclusive.

Returns:
The value of MinNumSigUniqueSequences to use in the ms_peptidesummary constructor
int getMinPepLenInPeptideSummary ( ) const

Returns the minimum length of peptide match to use when generating a peptide summary report.

This is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).

Returns:
the minimum peptide length used to differentiate different proteins.
double getMinProbability ( ) const

Returns the significance threshold.

minProbability is applied to both peptide matches and protein hits.

Peptide matches:

  • A peptide match (PSM) is significant if its expect value is below minProbability.
  • minProbability can be overriden by getTargetFDR().

Protein hits if ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB is active:

  • If ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB is set, minProbability is ignored. Instead, up to getMaxHitsToReport() proteins are reported.

Protein hits if MSRES_MAXHITS_OVERRIDES_MINPROB is not active:

  • A value of 0 indicates no cutoff - report getMaxHitsToReport() proteins, whatever the protein scores.
  • A value between 0 and 1 is used to calculate a protein score cut-off based on peptide match expect values. With standard protein scoring, 0.05 would discard all proteins with a score less the average score of a peptide with an expect value of 0.05. With MudPIT protein scoring, 0.05 would be the peptide expect value threshold used for calculating the protein scores, and only proteins with non-zero scores are reported.
  • A value greater than 1 indicates an absolute score cutoff for proteins, but this is not valid for an Integrated error tolerant search and is not permitted in the standard Mascot Search reports, so is not recommended.
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins - the similar and subset proteins are not 'cutoff' by this value.
  • The cutoff point is the lower of maxHitsToReport and this value. With versions of parser before Mascot 2.2, MSRES_MAXHITS_OVERRIDES_MINPROB was not available so AUTO in the standard Mascot results reports was implemented by setting this probability to a (user) defined value and setting getMaxHitsToReport() to a very large number.

Other points to note:

  • A value of less than 0 is not permitted and will be replaced with the default of 0.05.
  • In Mascot Parser 2.2 and earlier, a value between 0.1 and 1.0 was replaced with the default value of 0.05. In Mascot Parser 2.3, any value between 1e-18 and 1.0 is acceptable.
Returns:
The value of the minProbability parameter used in the ms_peptidesummary and ms_proteinsummary constructors
std::string getSingleHit ( ) const

Returns the optional single hit parameter used to get the results for a single hit quickly.

Should only be used for getting the results for a single protein quickly. See setSingleHit().

Returns:
The single hit parameter value if available.
double getTargetFDR ( ) const

Returns the target FDR, if any.

Target FDR is only valid with ms_peptidesummary. Target FDR type is PSM by default, which can be overriden using setTargetFDRType().

If target FDR is 0 (default), it is interpreted as "not set". ms_peptidesummary uses getMinProbability() as the significance threshold.

Target FDR is a value between 0 and 1. If the search is a target-decoy search, ms_peptidesummary tries to calibrate minProbability to a value that yields the target FDR (either PSM FDR or sequence FDR). If the search is not a target-decoy search, or ms_peptidesummary fails to reach the target, then getMinProbability() is used as the fallback value.

If the search is a target-decoy, integrated error tolerant, ms_peptidesummary has two independent significance thresholds, one for first pass matches and one for second pass matches. If target FDR is non-zero, ms_peptidesummary tries to calibrate both sets of matches to the same target FDR.

Mascot Server 2.8 and later may output a first_pass_threshold= value in the header section of the results file. This is the minProbability used at the end of the first pass of an integrated error tolerant search.

Mascot Server 2.8 and later accept a TARGET_FDR_PERCENT= search parameter, which is stored in the parameters section of the results file.

ms_mascotresfile::get_ms_mascotresults_params() follows this protocol:

  • Use ms_mascotresfile::getSectionValueDouble() to get first_pass_threshold=.
  • If it's non-zero, pass it to setMinProbability().
  • Use ms_searchparams::getTARGET_FDR_PERCENT(). Divide by 100 and pass to setTargetFDR().
  • Set FDR type to the default (ms_mascotresults::DS_COUNT_PSM).
Returns:
target FDR, or 0 if not set.
ms_mascotresults::DECOY_STATS_COUNT_TYPE getTargetFDRType ( ) const

Returns the target FDR type.

Target FDR type can be either PSM (default) or sequence.

PSM FDR is calculated from the number of decoy PSMs and target PSMs.

Sequence FDR is calculated from the number of distinct decoy peptide sequences and distinct target peptide sequences, where each distinct peptide sequence has at least one PSM.

See getTargetFDR() for more details.

Returns:
target FDR type.
std::string getUnigeneIndexFile ( ) const

Optional file path to a UniGene Index file.

This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.

Returns:
The unigene index file parameter if available.
bool isUsePeptideSummary ( ) const

Returns a hint as to whether a peptide or protein summary should be created.

The parameter is set when you call get_ms_mascotresults_params to populate the ms_mascotresults_params object. The value returned by this function is not used by any of the ms_peptidesummary or ms_proteinsummary constructors.

Returns:
True if the ms_mascotresfile contains any MS/MS data, false if not.
ms_mascotresults_params & operator= ( const ms_mascotresults_params & right )

Assignment operator.

Parameters:
right is the source to initialise from
Returns:
reference to the current object
void setFlag | ( | const ms_mascotresults::FLAGS | flag,
 |  | bool | enabled
 | ) |  |

Toggles the value of an individual flag for use in the ms_mascotresults constructor.

Parameters:
flag | Should be one of the ms_mascotresults::FLAGS values.
enabled | Choose true to set the flag and false to unset.
void setFlag2 | ( | const ms_peptidesummary::MSPEPSUM | flag,
 |  | bool | enabled
 | ) |  |

Toggles the value of an individual flag used in the ms_peptidesummary constructor.

Parameters:
flag | Should be one of the ms_peptidesummary::MSPEPSUM values.
enabled | Choose true to set the flag and false to unset.
void setFlags ( const unsigned int flags )

Sets the value of the flags parameter for use in the ms_mascotresults constructor.

Parameters:
flags Should be one or more of the ms_mascotresults::FLAGS values OR'ed together.
void setFlags2 ( const unsigned int flags2 )

Sets the value of the flags2 parameter used in the ms_peptidesummary constructor.

Flags2 is an optional parameter for the peptide summary only.

Parameters:
flags2 Should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'ed together.
void setIgnoreIonsScoreBelow ( const double ignoreIonsScoreBelow )

Sets the value of the ignoreIonsScoreBelow parameter.

Parameters:
ignoreIonsScoreBelow is an optional flag for the peptide summary only. Any peptides with a score less than this will be ignored. If the value is greater than 0 and less than 1 then this is assumed to to be a probability rather than an absolute score; the reciprocal of this value is passed to ms_peptidesummary::getPeptideThreshold() to determine the score cutoff. If the value is -1, it is treated as equivalent to minProbability.
void setMaxHitsToReport ( const int maxHitsToReport )

Sets the maximum number of protein hits to report.

For details, see getMaxHitsToReport().

Parameters:
maxHitsToReport is the new maximum value.
void setMinNumSigUniqueSequences ( const int n )

Sets the value of the MinNumSigUniqueSequences parameter.

For details, see getMinNumSigUniqueSequences().

Parameters:
n New value between 1 and 5, inclusive. If n is outside this range, it's set to 1.
void setMinPepLenInPeptideSummary ( const int minPepLenInPeptideSummary )

Sets the minimum length of peptide match to use when generating a peptide summary report.

Parameters:
minPepLenInPeptideSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).
void setMinProbability ( const double minProbability )

Sets the significance threshold.

For details, see getMinProbability() and getTargetFDR().

Parameters:
minProbability specifies the significance threshold.
void setSingleHit ( const char * singleHit )

Sets the optional single hit parameter.

Parameters:
singleHit should only be used for getting the results for a single protein quickly. This is used for example by the the protein view report in Mascot, which just shows the matches for a single protein. See Using the singleHit parameter to return a single protein.

  • From programming languages other than C++, pass an empty string object to specify that all proteins should be used.
  • For Mascot 2.3 and later, a database index needs to be specified because the search may have been against multiple fasta files. If the database index is to be specified, the string must be of the form: "3:CH60_SHEON" and the ms_peptidesummary::MSPEPSUM_SINGLE_HIT_DBIDX must be specified in flags2. Othersise, at database index of 1 is assumed.
void setTargetFDR ( double fdr )

Sets the target FDR.

Target FDR is a value between 0 and 1. Zero means "not set" and is the default. Target FDR type is set with setTargetFDRType().

See getTargetFDR() for details.

Parameters:
fdr target FDR. If outside the valid range, target FDR is set to 0.
void setTargetFDRType ( ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType )

Sets the target FDR type.

Target FDR type can be either PSM (default) or sequence.

See getTargetFDRType() for details.

Parameters:
fdrType new type.
void setUnigeneIndexFile ( const char * unigeneIndexFile )

Sets the optional file path to a UniGene Index file.

Parameters:
unigeneIndexFile is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.

  • From programming languages other than C++, pass an empty string object to specify no UniGene index file.
void setUsePeptideSummary ( const bool usePeptideSummary )

Set the hint as to whether a peptide or protein summary should be created.

The parameter is set when you call get_ms_mascotresults_params to populate the ms_mascotresults_params object. The value returned by this function is not used by any of the ms_peptidesummary or ms_proteinsummary constructors.

Parameters:
usePeptideSummary Pass in true if the result file contains MS/MS data, false if not
The documentation for this class was generated from the following files:
  • ms_mascotresults_params.hpp
  • ms_mascotresults_params.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_peptide
Public Types | Public Member Functions

ms_peptide Class Reference
[Mascot results file module]

This class encapsulates a peptide from the mascot results file. More...

#include <ms_mascotrespeptide.hpp>

List of all members.

Public Types

enum PSM {
PSM_COMPLETE = 0,
PSM_CROSSLINK_ALPHA = 1,
PSM_CROSSLINK_BETA = 2
}

Type of data to return from accessor methods.

More...

Public Member Functions

ms_peptide ()
Default constructor.
ms_peptide (int query, int rank, int missedCleavages, double mrCalc, double delta, double observed, int charge, int numIonsMatched, std::string peptideStr, int peaksUsedFromIons1, std::string varModsStr, double ionsScore, std::string seriesUsedStr, int peaksUsedFromIons2, int peaksUsedFromIons3, const ms_mascotresults *pResults=0, bool storeReloadableInfo=true)
Constructor to initialise most commonly used values.
ms_peptide (const int query, const int rank, const SEARCH_PHASE searchPhase, const double delta, const double observed, const int charge, const int numIonsMatched, const int peaksUsedFromIons1, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site &linkerSite, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true)
Constructor to initialise a crosslinked peptide.
ms_peptide (const ms_peptide &src)
Copying constructor.
ms_peptide (const int query, const int rank, const SEARCH_PHASE searchPhase, const int missedCleavages, const double mrCalc, const double delta, const double observed, const int charge, const int numIonsMatched, const std::string &peptideStr, const int peaksUsedFromIons1, const std::string &varModsStr, const std::string &summedModsStr, const std::string &localModsStr, const std::string &monoLinkStr, const ms_linker_site_vector &loopLinks, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const std::string &primaryNlStr, const std::string &summedModsNlStr, const std::string &localModsNlStr, const std::string &substStr, const std::string &componentStr, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true)
Constructor to initialise all values.
~ms_peptide ()
Destructor.
bool | anyPercolatorResults () const
Return true if there are percolator results for this peptide.
bool | clearReloadableInfo ()
To save on memory, may need to call this function.
void | copyFrom (const ms_peptide *src)
Copies all content from another instance of the class.
std::string | getAmbiguityString (const PSM psmComponent=PSM_COMPLETE) const
Used for X, B and Z residues in source databases where Mascot then substitutes for a residue.
bool | getAnyMatch () const
Returns true if there was a peptide match to this spectrum.
void | getAnyProteinTermination (bool &isNterminus, bool &isCterminus, const PSM psmComponent=PSM_COMPLETE) const
Determines if the Mascot search matched the peptide as a C or N terminus.
int | getCharge () const
Returns the charge state for the parent mass.
std::string | getComponentStr (const PSM psmComponent=PSM_COMPLETE) const
Returns the quantitation method component name used for the peptide match.
double | getDelta () const
Returns the difference between the calculated and experimental relative masses.
double | getExpectationValue () const
Returns the expectation value.
int | getFirstProtAppearedIn () const
Returns the hit numberof the first protein that contains this peptide.
void | getIntactLinks (ms_linker_site_vector &vec) const
Returns a vector of links between crosslinked peptides.
ms_linker_site_vector | getIntactLinks () const
Returns a vector of links between crosslinked peptides.
double | getIonsIntensity () const
Returns the total intensity of all of the ions in the spectrum.
double | getIonsScore () const
Returns the ions score.
bool | getIsFromErrorTolerant () const
Returns true if this peptide came from the error tolerant search.
bool | getIsFromLibrary () const
Returns true if this peptide came from the library search.
bool | getLessThanMinPepLen () const
Returns true if the length of the peptide sequence is less than the minimum used for grouping.
std::string | getLocalModsNlStr (const PSM psmComponent=PSM_COMPLETE) const
Returns neutral loss information associated with any query-level modification for the peptide.
std::string | getLocalModsStr (const PSM psmComponent=PSM_COMPLETE) const
Query-level variable modifications as a string of digits.
ms_linker_site_vector | getLoopLinks (const PSM psmComponent=PSM_COMPLETE) const
Returns a vector of looplinks.
void | getLoopLinks (ms_linker_site_vector &vec, const PSM psmComponent=PSM_COMPLETE) const
Returns a vector of looplinks.
int | getMissedCleavages (const PSM psmComponent=PSM_COMPLETE) const
Returns the number of missed cleavages.
std::string | getMonoLinkStr (const PSM psmComponent=PSM_COMPLETE) const
Returns monolink information associated with a linker used as a variable modification.
double | getMrCalc (const PSM psmComponent=PSM_COMPLETE) const
Returns the calculated relative mass for this peptide .
double | getMrExperimental () const
Returns the observed mz value as a relative mass.
int | getNum13C (const double tol, const std::string tolu, const std::string mass_type) const
Returns the number of 13C peaks offset required to get a match with the supplied tolerance.
int | getNumberOfLinkedPeptides () const
Returns the number of peptides in this peptide-spectrum match.
int | getNumIonsMatched () const
Returns the number of ions matched.
int | getNumProteins () const
Returns the number of proteins that contains this peptide.
double | getObserved () const
Returns the observed mass / charge value.
int | getPeaksUsedFromIons1 () const
Returns number of peaks used from ions1.
int | getPeaksUsedFromIons2 () const
Returns number of peaks used from ions2.
int | getPeaksUsedFromIons3 () const
Returns number of peaks used from ions3.
int | getPeptideLength (const PSM psmComponent=PSM_COMPLETE) const
Returns the length in residues of the sequence found for the peptide.
std::string | getPeptideStr (bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const
Returns the sequence found for the peptide.
void | getPercolatorScores (double *posteriorErrorProbability, double *qValue, double *internalPercolatorScore, double *mascotIonsScore) const
Returns the percolator scores and original Mascot ions score.
int | getPrettyRank () const
Similar to getRank() except that equivalent scores get the same rank.
std::string | getPrimaryNlStr (const PSM psmComponent=PSM_COMPLETE) const
Returns neutral loss information associated with any modification for the peptide.
const ms_protein * | getProtein (int num) const
Returns a pointer to a protein that contains this peptide.
const std::vector< int > | getProteins () const
Return a list of hit numbers for the proteins that contain this peptide.
int | getQuery () const
Each peptide is associate with a query.
int | getRank () const
Return the 'rank' of the peptide match.
std::string | getSeriesUsedStr () const
Returns the series used as a string.
std::string | getSummedModsNlStr (const PSM psmComponent=PSM_COMPLETE) const
Returns neutral loss information associated with any summed modification for the peptide.
std::string | getSummedModsStr (const PSM psmComponent=PSM_COMPLETE) const
Summed variable modifications as a string of digits.
std::string | getVarModsStr (const PSM psmComponent=PSM_COMPLETE) const
Variable modifications as a string of digits.
bool | isSamePeptideStr (ms_peptide *peptide, bool substituteAmbiguous=true) const
Returns true if the two peptides are identical.
bool | isSameSummedModsStr (ms_peptide *peptide) const
Returns true if the two summed variable modifications are identical.
bool | isSameVarModsStr (ms_peptide *peptide) const
Returns true if the two variable modifications are identical.
ms_peptide & | operator= (const ms_peptide &right)
C++ assignment operator.
void | setLocalModsStr (const std::string str, const PSM psmComponent=PSM_COMPLETE)
Query-level variable modifications as a string of digits.
void | setSummedModsStr (const std::string str, const PSM psmComponent=PSM_COMPLETE)
Summed variable modifications as a string of digits.
void | setVarModsStr (const std::string str, const PSM psmComponent=PSM_COMPLETE)
Variable modifications as a string of digits.

Detailed Description

This class encapsulates a peptide from the mascot results file.

This class is used for protein summary and peptide summary results. There is generally no need to create an object of this class. Simply open the results file as ms_proteinsummary or ms_peptidesummary and call ms_proteinsummary::getPeptide() or ms_peptidesummary::getPeptide().

To create an ms_peptide object that is not in a Mascot results file, use ms_aahelper::createPeptide().

Examples:

peptide_list.cpp, repeat_search.cpp, resfile_summary.cpp, and tools_aahelper.cpp.

Member Enumeration Documentation

enum PSM

Type of data to return from accessor methods.

Mascot 2.7 and later can identify intact crosslinked peptides. The ms_peptide object contains data for both the peptide sequence(s) and the spectrum match.

The PSM flag specifies the type of data returned from accessor methods. It is used as an optional argument with, for example, getPeptideStr().

See Using enumerated values and static const ints in Perl, Java, Python and C# and Crosslinked search results.

Enumerator:
PSM_COMPLETE

Peptide-spectrum match, also linear peptide in a non-crosslinked match.

PSM_CROSSLINK_ALPHA

Alpha peptide in a crosslinked match.

PSM_CROSSLINK_BETA

Beta peptide in a crosslinked match.

Constructor & Destructor Documentation

ms_peptide ( )

Default constructor.

The constructor should generally only be used from within the library.

ms_peptide | ( | int | query,
 |  | int | rank,
 |  | int | missedCleavages,
 |  | double | mrCalc,
 |  | double | delta,
 |  | double | observed,
 |  | int | charge,
 |  | int | numIonsMatched,
 |  | std::string | peptideStr,
 |  | int | peaksUsedFromIons1,
 |  | std::string | varModsStr,
 |  | double | ionsScore,
 |  | std::string | seriesUsedStr,
 |  | int | peaksUsedFromIons2,
 |  | int | peaksUsedFromIons3,
 |  | const ms_mascotresults * | pResults = 0,
 |  | bool | storeNonPersistantInfo = true
 | ) |  |

Constructor to initialise most commonly used values.

This constructor should generally only used from within the library.

Not all values can be initialised from this constructor, but this constructor will remain available in future versions of the library.

Consider using ms_aahelper::createPeptide or ms_mascotresults::getPeptide(const int, const int) const instead of this constructor.

Parameters:
query | is the query number in the range 1..ms_mascotresfile::getNumQueries()
rank | is the rank number. See getRank() for details
missedCleavages | is the number of missed cleavages, or -1 if there was no match
mrCalc | is the relative mass of the peptide. See getMrCalc()
delta | is the difference between the calculated and experimental relative masses
observed | is the observed mass / charge value. See getObserved()
charge | is the charge state for the parent mass
numIonsMatched | is the number of ions matched. See getNumIonsMatched()
peptideStr | is the peptide sequence
peaksUsedFromIons1 | is the number of peaks used from ions1. See getPeaksUsedFromIons1()
varModsStr | is the variable modifications as a string of digits. See getVarModsStr()
ionsScore | is the ions score. See getIonsScore()
seriesUsedStr | is the ions series used as a string. See getSeriesUsedStr()
peaksUsedFromIons2 | is the number of peaks used from ions2. See getPeaksUsedFromIons2()
peaksUsedFromIons3 | is the number of peaks used from ions2. See getPeaksUsedFromIons3()
pResults | is a pointer to the results object and should be supplied where possible
storeNonPersistantInfo | should be set to true
~ms_peptide ( )

Destructor.

Note that this is not 'virtual' to conserve on memory. For a large results file, ms_mascotresults can create 1,000,000 ms_peptides so the overhead can be considerable (compiler dependent).

Member Function Documentation

bool anyPercolatorResults ( ) const

Return true if there are percolator results for this peptide.

See Using Percolator scores for further information.

Returns:
Should always return true if ms_peptidesummary::MSPEPSUM_PERCOLATOR has been specified.
std::string getAmbiguityString ( const PSM psmComponent = PSM_COMPLETE ) const

Used for X, B and Z residues in source databases where Mascot then substitutes for a residue.

Mascot 2.0 and later will try and substitute ambiguous 'residues' with a residue to get a match. Specifically:

  • 'X' can be substituted with any residue
  • 'B' can be substituted with an Asparagine (N) or Aspartic acid (D)
  • 'Z' can be substituted with a Glutamic acid (E) or a Glutamine(Q)

This string is read from the h1_q1_subst= line of the results file for the protein summary, and from the q1_p1_subst line of the results file for the peptide summary.

Calling getPeptideStr(true) will return the substituted string.

Calling this function will return a string with the format:

   pos1,ambig1,matched1...,posn,ambigm,matchedn

For example:

  • getAmbiguityString() returns 3,B,N,4,X,A
  • getPeptideStr(false) returns AFBXK
  • getPeptideStr(true) returns AFNAK

If the peptide match is a crosslinked peptide, you must specify psmComponent. PSM_CROSSLINK_ALPHA returns the alpha peptide ambiguity string, and PSM_CROSSLINK_BETA returns the beta peptide ambiguity string. If you pass PSM_COMPLETE, the method returns the empty string.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
ambiguity string for this peptide
bool getAnyMatch ( ) const

Returns true if there was a peptide match to this spectrum.

Internally (and in the results file) this is signified by the first value on the line, which is the number of missed cleavages. See also getMissedCleavages().

Returns:
true if there was a peptide match to this spectrum.
Examples:
resfile_summary.cpp.
void getAnyProteinTermination | ( | bool & | isNterminus,
 |  | bool & | isCterminus,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  | const

Determines if the Mascot search matched the peptide as a C or N terminus.

This is determined from the residues string . The residues string is a series of residues sepearated by colons (':'). If an individual residue starts with a hyphen ('-') then the peptide is an N-terminus for a protein. If an individual residue ends with a one ('1') then the peptide is a C-terminus for a protein.

If the peptide match is a crosslinked peptide, you must specify psmComponent. PSM_CROSSLINK_ALPHA returns the values for the alpha peptide, and PSM_CROSSLINK_BETA for the beta peptide. If you pass PSM_COMPLETE, the returned values are false.

Parameters:
isNterminus | Set to true if the peptide was matched as an N-terminus, otherwise false.
isCterminus | Set to true if the peptide was matched as a C-terminus, otherwise false.
psmComponent | Type of data to return: complete molecule, alpha peptide or beta peptide.
int getCharge ( ) const

Returns the charge state for the parent mass.

This will be 0 for an Mr value, or 1,2,3,4 etc. If an error has occurred, then the charge will be -100.

Returns:
The charge state for the parent mass.
Examples:
resfile_summary.cpp.
std::string getComponentStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the quantitation method component name used for the peptide match.

If a search was performed using a 'precursor' quantitation method, then peptide hits may have a quantitation method component name associated with them.

The entry in the results file might be, for example:

   q1_p2_comp=light

Component strings are only saved in the results file for methods with 'Isotopes' defined. For example, with the 15N Metabolic [MD] method. In other cases, for example with the SILAC methods, the component needs to be determined from the modifications assigned to the peptide.

To determine if a method has isotopes, use the following code (error handling omitted to make it more readable):

 my $resfile = msparser::ms_mascotresfile->new($filename);
 my $qfile = new msparser::ms_quant_configfile;
 $qfile->setSchemaFileName(
        "http://www.matrixscience.com/xmlns/schema/quantitation_2"
        . " ../html/xmlns/schema/quantitation_2/quantitation_2.xsd"
        . " http://www.matrixscience.com/xmlns/schema/quantitation_1"
        . " ../html/xmlns/schema/quantitation_1/quantitation_1.xsd"
 );

 my $numIsotopes = 0;
 if ($resfile->getQuantitation($qfile)) {
   my $method = $qfile->getMethodByNumber(0);
   for (my $idx= 0; $idx < $method->getNumberOfComponents(); $idx++) {
     my $comp = $method->getComponentByNumber($idx);
     $numIsotopes += $comp->getNumberOfIsotopes();
   }
 }
 if ($numIsotopes > 0) {
   ... expect getComponentStr to return values...
 }

See also ms_mascotresults::getComponentString

If the match is an intact crosslinked peptide, you must specify psmComponent. PSM_CROSSLINK_ALPHA returns the alpha component and PSM_CROSSLINK_BETA the beta component. If you pass PSM_COMPLETE, the method returns either the alpha component (if alpha component == beta component) or the empty string.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
a component name or an empty string.
double getDelta ( ) const

Returns the difference between the calculated and experimental relative masses.

Returns:
The delta in daltons.
Examples:
resfile_summary.cpp.
double getExpectationValue ( ) const

Returns the expectation value.

Returns:
The expectation value.
int getFirstProtAppearedIn ( ) const

Returns the hit numberof the first protein that contains this peptide.

Returns:
The hit number (1..n) or 0 if the peptide is not in any of the proteins in the ms_peptidesummary list.
void getIntactLinks ( ms_linker_site_vector & vec ) const

Returns a vector of links between crosslinked peptides.

In Mascot 2.7, the number of links between crosslinked peptides is limited to 1.

Parameters:
vec is vector of links, or the empty vector if getNumberOfLinkedPeptides() == 0.
ms_linker_site_vector getIntactLinks ( ) const

Returns a vector of links between crosslinked peptides.

In Mascot 2.7, the number of links between crosslinked peptides is limited to 1.

Returns:
A vector of links, or the empty vector if getNumberOfLinkedPeptides() == 0.
double getIonsIntensity ( ) const

Returns the total intensity of all of the ions in the spectrum.

This value is only guaranteed to be valid for ms_peptidesummary when sorting unassigned by intensity and using the ms_peptide object returned by the ms_mascotresults::getUnassigned() function.

The same value is returned by ms_inputquery::getTotalIonsIntensity()

Returns:
The total intensity of all of the ions in the spectrum.
double getIonsScore ( ) const

Returns the ions score.

Note that ms_protein::getPeptideIonsScore() returns the ions score in the context of the protein match and will generally be slightly lower than the return value from this function. The Mascot results pages display the score returned from this function because results from similar proteins are displayed together.

Returns:
The ions score.
Examples:
peptide_list.cpp, repeat_search.cpp, and resfile_summary.cpp.
bool getIsFromErrorTolerant ( ) const

Returns true if this peptide came from the error tolerant search.

This peptide may have been found as a result of a standard error tolerant or an integrated error tolerant search. See Error tolerant searches.

Returns:
true if this peptide is from an error tolerant search
bool getIsFromLibrary ( ) const

Returns true if this peptide came from the library search.

This peptide may have been found as a result of a library or an integrated library search. See Spectral libraries.

Returns:
true if this peptide is from a spectral library search
bool getLessThanMinPepLen ( ) const

Returns true if the length of the peptide sequence is less than the minimum used for grouping.

If the function returns true, this peptide has not been considered when grouping proteins.

In a crosslinked search, if the match is crosslinked, either alpha or beta sequence must be longer than MinPepLenInPepSummary for the match to be considered in protein grouping. The test for a standard (linear) match is to compare its sequence length, as before.

See also:
ms_mascotresults::getMinPepLenInPepSummary()
Returns:
true if the peptide length is less than the minimum specified in MinPepLenInPepSummary in the options section of mascot.dat.
std::string getLocalModsNlStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns neutral loss information associated with any query-level modification for the peptide.

Neutral loss information is encoded in the same way as variable modification neutral losses (getPrimaryNlStr()). The neutral loss string is a string of digits, one digit for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, while numbers from 1 onwards are indices to the neutral loss vector of the modification, ms_modification::getNeutralLoss().

For example, suppose the peptide match has a query-level modification at residue 6, so that the query-level mods string is 000000100 and the neutral loss string is 000000200. To find the value of neutral loss 2, load the query-level modification object 1 (see getLocalModsStr()) and get the neutral loss vector with ms_modification::getNeutralLoss(). The neutral loss vector is 0-based, so neutral loss 2 is the second element of the vector, at index 1.

See also:
getLocalModsStr()
Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
A string with neutral loss information, or an empty string.
std::string getLocalModsStr ( const PSM psmComponent = PSM_COMPLETE ) const

Query-level variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, while digits and letters 1..9 and A..W indicate the corresponding modification in the IT_MODS array of the input query. The digits can be used to look up the modification name using ms_inputquery::getLocalVarModName().

For example, suppose the query-level mods string of a peptide match is 000000100 (residue 6 modified). To load the modification object:

  1. Look up the name with ms_inputquery::getLocalVarModName(1).
  2. Load the Unimod section of the results file with ms_mascotresfile::getUnimod()
  3. Populate the ms_modification object from the Unimod section with ms_modification::getFromUnimod().

Note that query-level modifications can never include error tolerant modifications, so the string never contains an 'X'.

See also:
ms_mascotresults::getReadableVarMods()
Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
Query-level variable modifications as a string of digits.
ms_linker_site_vector getLoopLinks ( const PSM psmComponent = PSM_COMPLETE ) const

Returns a vector of looplinks.

If this is a linear peptide match, psmComponent is ignored.

If this is a crosslinked peptide match, psmComponent chooses between the alpha or the beta peptide. If psmComponent is PSM_COMPLETE, looplinks for both peptides are returned.

Parameters:
psmComponent One of ms_peptide::PSM.
Returns:
A vector of looplinks, which could be empty.
void getLoopLinks | ( | ms_linker_site_vector & | vec,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  | const

Returns a vector of looplinks.

If this is a linear peptide match, psmComponent is ignored.

If this is a crosslinked peptide match, psmComponent chooses between the alpha or the beta peptide. If psmComponent is PSM_COMPLETE, looplinks for both peptides are returned.

Parameters:
vec | is vector of looplinks, which could remain empty.
psmComponent | One of ms_peptide::PSM.
int getMissedCleavages ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the number of missed cleavages.

See also getAnyMatch().

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta).

The psmComponent argument is optional in a non-crosslinked search. For a crosslinked match, it chooses the type of data to return. With PSM_COMPLETE, the method returns -1 if alpha or beta value is -1, and otherwise returns alpha missed cleavages + beta missed cleavages. With PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA, the method returns the alpha or beta value, respectively.

See Crosslinked search results.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
Will be -1 if there was no match. Will always be 0 for a no enzyme search.
Examples:
resfile_summary.cpp.
std::string getMonoLinkStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns monolink information associated with a linker used as a variable modification.

Monolink information is encoded in a similar way to variable modifications. If the variable modification at position i is a linker (e.g. Xlink:DSS), the value at position i of the monolink string records the index of the monolink (e.g. "neutral loss" element 1 of Xlink:DSS (K)).

Use the relevant number from this function as an argument to ms_mascotresfile::getMonoLinkModification() to determine the monolink delta used for scoring.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
A string with monolink index information, or an empty string if no monolinks were searched.
double getMrCalc ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the calculated relative mass for this peptide .

Takes into account any modifications.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta).

The psmComponent argument is optional in a non-crosslinked search. For a crosslinked match, it chooses the type of data to return. With PSM_COMPLETE, the method returns the mass of the intact molecule: alpha Mr + beta Mr + linker mass. With PSM_CROSSLINK_ALPHA or PSM_CROSSLINK_BETA, the method returns the alpha or beta value, respectively, without the linker.

See Crosslinked search results.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
The relative mass.
Examples:
resfile_summary.cpp.
double getMrExperimental ( ) const

Returns the observed mz value as a relative mass.

This is equal to getMrCalc() + getDelta(), so note that this will be zero if there was no match because there is no calculated value and no delta. It is generally recommended that you call ms_mascotresfile::getObservedMrValue() since it will always return the relative mass, even for no match.

Returns:
The observed mz value as a relative mass.
Examples:
resfile_summary.cpp.
int getNum13C | ( | const double | tol,
 |  | const std::string | tolu,
 |  | const std::string | mass_type
 | ) |  | const

Returns the number of 13C peaks offset required to get a match with the supplied tolerance.

Sometimes, peak detection chooses the 13C peak rather than the 12C. In extreme cases, it may pick the 13C2 peak. The normal test for a precursor match is

tol > absolute(exp - calc)

Assuming the mass values and tolerance are in Da, and the PEP_ISOTOPE_ERROR field is set to 1, the test will also succeed for

tol > absolute(exp - calc - 1)

If the PEP_ISOTOPE_ERROR field is set to 2, the test will succeed for the above two conditions, plus

tol > absolute(exp - calc - 2)

This means that you can use a tight mass tolerance and still get a match to a 13C peak. If you are using a very high accuracy instrument, note that the precise shifts are the carbon isotope spacings of 1.0033548 and 2.0067096, rather than 1 and 2. However, if average rather than isotopic masses are specified in the search, the values will be 0.9926548 and 1.9853096

Parameters:
tol | Is the tolerance for the search. The return value from matrix_science::ms_searchparams::getTOL() may be used.
tolu | Is the units of the tolerance supplied when performing the search. The return value from matrix_science::ms_searchparams::getTOLU() may be used.
mass_type | will either be Monoisotopic or Average. The return value from matrix_science::ms_searchparams::getMASS() may be used.
Returns:
  • 0 if the delta is within the applied tolerance;
  • 1 if the delta minus 1.0033548is within the tolerance;
  • 2 if the delta minus 2.0067096 is within the tolerance;
  • -1 if there was no match (i.e. getAnyMatch() returns 0) or if invalid tolerance units are supplied or if the delta is outside any of the above ranges.
int getNumberOfLinkedPeptides ( ) const

Returns the number of peptides in this peptide-spectrum match.

In Mascot 2.7, there are two possible return values:

  • 0 (no crosslinking)
  • 2 (crosslinked alpha and beta peptide)
Returns:
The number of peptides in this peptide-spectrum match.
int getNumIonsMatched ( ) const

Returns the number of ions matched.

Mascot begins by selecting a small number of experimental peaks on the basis of normalised intensity. It calculates a probability based score according to the number of matches. It then increases the number of selected peaks and recalculates the score. It continues to iterate until it is clear that the score can only get worse. It then reports the best score it found, which should correspond to an optimum selection, taking mostly real peaks and leaving behind mostly noise.

Mascot is not trying to find all possible matches in the spectrum. Many spectra have "peak at every mass" noise, and can match any ion series from any sequence if there is no intensity discrimination. So, you may look at a peptide view report and see obvious matches that are unlabelled. However, if the peak selection was to be extended to include these additional matches, it would also have to include a number of additional noise peaks, and the score would decrease.

Returns:
The number of ions matched in order to get the highest score.
Examples:
resfile_summary.cpp.
int getNumProteins ( ) const

Returns the number of proteins that contains this peptide.

See also:
getProtein(), ms_mascotresults::getAllProteinsWithThisPepMatch()
Returns:
The number of proteins in the current results set that contained this peptide.
double getObserved ( ) const

Returns the observed mass / charge value.

Returns:
The observed mass / charge value.
Examples:
resfile_summary.cpp.
int getPeaksUsedFromIons1 ( ) const

Returns number of peaks used from ions1.

It is possible, but unusual, to specify which ions series particular ions come from: http://www.matrixscience.com/help/sq_help.html#IONS

If a search specifies that some ions are from the b series, some are from the y series and that some are from any series then these will be stored separately in Ions1, Ions2 and Ions3. The number of matches to each set of ions is avaible using getPeaksUsedFromIons1(), getPeaksUsedFromIons2() and getPeaksUsedFromIons3().

For most searches, getPeaksUsedFromIons1() is the only function that needs to be used.

See also:
getNumIonsMatched()
Returns:
The number of peaks used from ions1.
Examples:
resfile_summary.cpp.
int getPeaksUsedFromIons2 ( ) const

Returns number of peaks used from ions2.

It is possible, but unusual, to specify which ions series particular ions come from: http://www.matrixscience.com/help/sq_help.html#IONS

If a search specifies that some ions are from the b series, some are from the y series and that some are from any series then these will be stored separately in Ions1, Ions2 and Ions3. The number of matches to each set of ions is avaible using getPeaksUsedFromIons1(), getPeaksUsedFromIons2() and getPeaksUsedFromIons3().

For most searches, getPeaksUsedFromIons1() is the only function that needs to be used.

See also:
getNumIonsMatched()
Returns:
The number of peaks used from ions2.
Examples:
resfile_summary.cpp.
int getPeaksUsedFromIons3 ( ) const

Returns number of peaks used from ions3.

It is possible, but unusual, to specify which ions series particular ions come from: http://www.matrixscience.com/help/sq_help.html#IONS

If a search specifies that some ions are from the b series, some are from the y series and that some are from any series then these will be stored separately in Ions1, Ions2 and Ions3. The number of matches to each set of ions is avaible using getPeaksUsedFromIons1(), getPeaksUsedFromIons2() and getPeaksUsedFromIons3().

For most searches, getPeaksUsedFromIons1() is the only function that needs to be used.

See also:
getNumIonsMatched()
Returns:
The number of peaks used from ions3.
Examples:
resfile_summary.cpp.
int getPeptideLength ( const PSM psmComponent = PSM_COMPLETE ) const

Returns the length in residues of the sequence found for the peptide.

This should be faster than calling getPeptideStr() and determining the length of the returned string.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
Returns the length in residues of the sequence found for the peptide.
std::string getPeptideStr | ( | bool | substituteAmbiguous = true,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  | const

Returns the sequence found for the peptide.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to return. If you pass PSM_COMPLETE, the method returns a concatenated sequence: alpha sequence + "][" + beta sequence. The characters "][" represent the alpha C-terminus and beta N-terminus.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters:
substituteAmbiguous | If true, and if there were any ambiguous residues, then the returned result will have the substituted residues rather than an 'X', 'B' or 'Z'.
psmComponent | Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
The peptide sequence -- will be the empty string if there was no match.
Examples:
peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void getPercolatorScores | ( | double * | posteriorErrorProbability,
 |  | double * | qValue,
 |  | double * | internalPercolatorScore,
 |  | double * | mascotIonsScore
 | ) |  | const

Returns the percolator scores and original Mascot ions score.

See Using Percolator scores for further information and Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | posteriorErrorProbability | is the probability that individual match with this Percolator score is random match.
[out] | qValue | is equivalent to the FDR if all matches with this Percolator score or higher were accepted
[out] | internalPercolatorScore | is not used in Mascot Parser. See Percolator documentation.
[out] | mascotIonsScore | is the ions score that Mascot originally assigned.
int getPrettyRank ( ) const

Similar to getRank() except that equivalent scores get the same rank.

For a peptide summary, the top 10 peptide matches for each query are saved. These are scored with rank 1 to 10, and the rank can be obtained using the getRank() function. However, if say, the top three matches are the same, it is generally better to say (in a report) that these are all rank 1. The following table shows an example:

Rank | Pretty Rank | Score | Peptide | Protein
1 | 1 | 78 | ABCDEFG |
2 | 1 | 78 | ABCDEGF | gi|123456
3 | 1 | 78 | BACDEFG |
4 | 4 | 65 | ASDADSD |
5 | 4 | 65 | SDFSGSD |
6 | 6 | 12 | DFGHDFG |
7 | 7 | 8 | SSDFDFD |
8 | 8 | 7 | RTYRYRY |
9 | 9 | 4 | RTYRYRY |
10 | 10 | 2 | TYUTUTU |

For a protein summary, getPrettyRank() will always return the same as getRank().

Returns:
The 'pretty rank'.
Examples:
resfile_summary.cpp.
std::string getPrimaryNlStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns neutral loss information associated with any modification for the peptide.

Neutral loss information is encoded in a similar way to variable modifications. Use the relevant number from this function as an offset into the array returned from ms_searchparams::getVarModsNeutralLosses() to determine the neutral loss used for scoring.

The neutral loss string is a string of digits, one digit for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates NeutralLoss1, 2 indicates NeutralLoss2 etc., in the masses section.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
A string with neutral loss information, or an empty string.
const ms_protein * getProtein ( int num ) const

Returns a pointer to a protein that contains this peptide.

It is normally better to use ms_mascotresults::getAllProteinsWithThisPepMatch() than this function.

This function returns all the proteins that are seen in the top level report that contain this peptide. If grouping is enabled, it will only return proteins that are returned from ms_mascotresults::getHit -- it will not return proteins that would be returned from ms_mascotresults::getNextSimilarProtein().

The function will only return proteins up to the number of hits that were requested when creating the ms_mascotresults object.

See Maintaining object references: two rules of thumb.

Parameters:
num should be in the range 1.. getNumProteins() or this function will return a null value.
Returns:
A pointer to protein if found, or a null value if not found.
const std::vector< int > getProteins ( ) const

Return a list of hit numbers for the proteins that contain this peptide.

See also:
getProtein()
Returns:
a vector of protein hit numbers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
int getQuery ( ) const

Each peptide is associate with a query.

Returns:
The query number in the range 1..ms_mascotresfile::getNumQueries().
Examples:
resfile_summary.cpp.
int getRank ( ) const

Return the 'rank' of the peptide match.

Each spectrum will match to a number of different peptides. The best (highest scoring) match will have a rank value of 1.

In a peptide summary, this will be in the range 1..10.

In a protein summary, this will be the hit number (1..50).

See also:
ms_mascotresults::getMaxRankValue()
Returns:
The rank.
Examples:
resfile_summary.cpp.
std::string getSeriesUsedStr ( ) const

Returns the series used as a string.

The string is a set of 0s and 1s and 2s.

  • 0 - no significant match
  • 1 - significant match, but not used in score
  • 2 - significant match, used for scoring

The 'position' in the string is used to indicate which series:

  • 01 - A series
  • 02 - placeholder (was A - NH3 series in older versions of Mascot)
  • 03 - A++ series
  • 04 - B series
  • 05 - placeholder (was B - NH3 series in older versions of Mascot)
  • 06 - B++ series
  • 07 - Y series
  • 08 - placeholder (was Y - NH3 series in older versions of Mascot)
  • 09 - Y++ series
  • 10 - C series
  • 11 - C++ series
  • 12 - X series
  • 13 - X++ series
  • 14 - Z series
  • 15 - Z++ series
  • 16 - Z+H series
  • 17 - Z+H++ series
  • 18 - Z+2H series
  • 19 - Z+2H++ series

For example, 00020010000000000 would indicate b series used for scoring, and y series significant, but not used for scoring. Note that earlier versions of Mascot did not look for all these ions series, so the string will not necessarily be 17 characters long.

Returns:
series used
Examples:
resfile_summary.cpp.
std::string getSummedModsNlStr ( const PSM psmComponent = PSM_COMPLETE ) const

Returns neutral loss information associated with any summed modification for the peptide.

Neutral loss information is encoded in a similar way to summed modifications. Use the relevant number from this function as an offset into the array returned from ms_searchparams::getVarModsNeutralLosses() to determine the neutral loss used for scoring.

The neutral loss string is a string of digits, one digit for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates NeutralLoss1, 2 indicates NeutralLoss2 etc., in the masses section.

See also:
getSummedModsStr()
Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
A string with neutral loss information, or an empty string.
std::string getSummedModsStr ( const PSM psmComponent = PSM_COMPLETE ) const

Summed variable modifications as a string of digits.

When two modifications occur at the same site, the extra modification is stored in the q1_p1_summed_mods= string in the results file. Summed mods are only supported when using quantitation methods with exclusive modifications. The exclusive modification will always be returned by getVarModsStr(), while getSummedModsStr() is used for post translational modifications to the same site.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also:
Multiple modifications for the same site
ms_peptide::getVarModsStr()
ms_mascotresults::getReadableVarMods()
ms_searchparams::getMULTI_SITE_MODS
Increase in the number of variable modifications.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to return.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
Summed variable modifications as a string of digits.
std::string getVarModsStr ( const PSM psmComponent = PSM_COMPLETE ) const

Variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also Increase in the number of variable modifications.

See also:
ms_mascotresults::getReadableVarMods()

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to return.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters:
psmComponent Type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
Variable modifications as a string of digits.
Examples:
resfile_summary.cpp.
bool isSamePeptideStr | ( | ms_peptide * | peptide,
 |  | bool | substituteAmbiguous = true
 | ) |  | const

Returns true if the two peptides are identical.

Calling this function may be faster than calling getPeptideStr() twice and doing the compare on the returned peptide.

Parameters:
peptide | is a pointer to the peptide object with the sequence to compare.
substituteAmbiguous | should be set to true to compare sequences after substituting any X for the residue used to get a match.
Returns:
true if the peptides are the same.
bool isSameSummedModsStr ( ms_peptide * peptide ) const

Returns true if the two summed variable modifications are identical.

Calling this function may be faster than calling getSummedModsStr() twice and doing the compare on the returned peptide.

Parameters:
peptide is a pointer to the peptide object with the summed mods string to compare.
Returns:
True if the summed variable modifications for the two peptides are the same.
bool isSameVarModsStr ( ms_peptide * peptide ) const

Returns true if the two variable modifications are identical.

Calling this function may be faster than calling getVarModsStr() twice and doing the compare on the returned peptide.

Parameters:
peptide is a pointer to the peptide object with the mods string to compare.
Returns:
True if the variable modifications for the two peptides are the same.
void setLocalModsStr | ( | const std::string | str,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  |

Query-level variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, while digits and letters 1..9 and A..W indicate the corresponding modification in the IT_MODS array of the input query.

Note that query-level modifications can never include error tolerant modifications, so the string never contains an 'X'.

See also:
ms_mascotresults::getReadableVarMods()

Setting the string does not cause a re-calculation of the peptide mass -- this needs to be done manually.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to set. The caller is responsible for data consistency between PSM_COMPLETE, PSM_CROSSLINK_ALPHA and PSM_CROSSLINK_BETA.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters:
str | is the new query-level variable modifications as a string of digits.
psmComponent | Type of data to set: complete molecule, alpha peptide or beta peptide.
void setSummedModsStr | ( | const std::string | str,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  |

Summed variable modifications as a string of digits.

When two modifications occur at the same site, the extra modification is stored in the q1_p1_summed_mods= string in the results file. Summed mods are only supported when using quantitation methods with exclusive modifications. The exclusive modification will always be returned by getVarModsStr(), while getSummedModsStr() is used for post translational modifications to the same site.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also Increase in the number of variable modifications.

See also:
ms_mascotresults::getReadableVarMods()

Setting the string does not cause a re-calculation of the peptide mass -- this needs to be done manually.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to set. The caller is responsible for data consistency between PSM_COMPLETE, PSM_CROSSLINK_ALPHA and PSM_CROSSLINK_BETA.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters:
str | is the new variable modifications as a string of digits.
psmComponent | Type of data to set: complete molecule, alpha peptide or beta peptide.
void setVarModsStr | ( | const std::string | str,
 |  | const PSM | psmComponent = PSM_COMPLETE
 | ) |  |

Variable modifications as a string of digits.

One digit is used for the N terminus, one for each residue and one for the C terminus. Each digit specifies the modification used to obtain the match: 0 indicates no modification, 1 indicates delta1, 2 indicates delta2 etc., in the masses section. An 'X' is used to indicate an error tolerant modification that can be retrieved using matrix_science::ms_peptidesummary::getErrTolModName().

To support numbers greater than 9, the letters A..W are permitted, with A being 10 and W being 32.

See also Increase in the number of variable modifications.

See also:
ms_mascotresults::getReadableVarMods()

Setting the string does not cause a re-calculation of the peptide mass -- this needs to be done manually.

In a crosslinked search, the peptide-spectrum match may contain one linear peptide or the complete crosslinked peptide (alpha and beta). The psmComponent argument chooses the type of data to set. The caller is responsible for data consistency between PSM_COMPLETE, PSM_CROSSLINK_ALPHA and PSM_CROSSLINK_BETA.

The psmComponent argument is optional in a non-crosslinked search.

See Crosslinked search results.

Parameters:
str | is the new variable modifications as a string of digits.
psmComponent | Type of data to set: complete molecule, alpha peptide or beta peptide.
The documentation for this class was generated from the following files:
  • ms_mascotrespeptide.hpp
  • ms_mascotrespeptide.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_peptidesummary
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions

ms_peptidesummary Class Reference
[Mascot results file module]

Use this class to get peptide summary results. More...

#include <ms_mascotrespeptidesum.hpp>

Inheritance diagram for ms_peptidesummary:
[legend]
Collaboration diagram for ms_peptidesummary:
[legend]

List of all members.

Public Types

enum BUGFIX_NUM {
BUGFIX_10780 = 10780,
BUGFIX_10995 = 10995,
BUGFIX_11002 = 11002,
BUGFIX_11018 = 11018,
BUGFIX_11235 = 11235,
BUGFIX_11254 = 11254,
BUGFIX_11344 = 11344,
BUGFIX_11411 = 11411,
BUGFIX_11425 = 11425,
BUGFIX_11438 = 11438,
BUGFIX_11483 = 11483,
BUGFIX_11499 = 11499,
BUGFIX_11856 = 11856,
BUGFIX_12123 = 12123,
BUGFIX_12317 = 12317,
BUGFIX_11481 = 11481,
BUGFIX_12538 = 12538,
BUGFIX_12729 = 12729,
BUGFIX_12740 = 12740,
BUGFIX_13324 = 13324,
BUGFIX_12447 = 12447,
BUGFIX_13759 = 13759
}

bugNum values for isDataCached().

More...
enum CACHE_STATUS {
CACHE_MISSING_RESFILE = 0x10000,
RESFILE_CACHE_FILE_NOT_PRESENT = 0x00001,
RESFILE_CACHE_BEING_CREATED = 0x00002,
RESFILE_CACHE_DISABLED_IN_OPTIONS = 0x00004,
RESFILE_CACHE_VALID = 0x00008,
RESFILE_CACHE_CAN_CREATE = 0x00010,
PEPSUMMARY_CACHE_FILE_NOT_PRESENT = 0x00100,
PEPSUMMARY_CACHE_BEING_CREATED = 0x00200,
PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS = 0x00400,
PEPSUMMARY_CACHE_VALID = 0x00800,
PEPSUMMARY_CACHE_CAN_CREATE = 0x01000,
PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE = 0x02000,
PEPSUMMARY_CACHE_NOT_FOR_PMF = 0x04000
}

Returned by the willCreateCache function.

More...
enum DB_MATCH_TYPE {
DM_FASTA = 0,
DM_SPECTRAL_LIBRARY = 1,
DM_BOTH = 2,
DM_FASTA_FIRST_PASS = 3,
DM_FASTA_SECOND_PASS = 4
}

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

More...
enum DECOY_STATS_COUNT_TYPE {
DS_COUNT_PSM = 0,
DS_COUNT_SEQUENCE = 1
}

Type of object counted by getNumHitsAboveIdentity() and friends.

More...
enum FIND_COMPARE_FLAGS {
FC_COMPLETESTR = 0x00000001,
FC_SUBSTR = 0x00000002,
FC_STARTSTR = 0x00000003,
FC_STRTOK = 0x00000004,
FC_MASK_STR_PART = 0x0000000F,
FC_CASE_INSENSITIVE = 0x00000000,
FC_CASE_SENSITIVE = 0x00000010,
FC_MASK_CASE = 0x000000F0,
FC_FORWARD = 0x00000000,
FC_REVERSE = 0x00000100,
FC_MASK_DIRECTION = 0x00000F00,
FC_RESTRICT_TO_HIT = 0x00001000,
FC_LOOP_INTO_UNASSIGNED = 0x00002000,
FC_LOOP_FROM_UNASSIGNED = 0x00004000,
FC_UNASSIGNED_MASK = 0x00006000,
FC_SEARCH_ALL_RANKS = 0x00008000,
FC_ALL_PEPTIDES = 0x00000000,
FC_ALL_PEPTITDES = 0x00000000,
FC_SIGNIFICANT_PEPTIDES = 0x00010000,
FC_SEARCH_IGNORED_RANKS = 0x00020000,
FC_SCORING_MASK = 0x000F0000,
FC_PROTEIN_IGN_SAMESETS = 0x00100000,
FC_PROTEIN_IGN_SUBSETS = 0x00200000,
FC_PROTEIN_IGN_FAMILY = 0x00400000,
FC_PROTEIN_IGN_MASK = 0x00F00000,
FC_PROTEIN_INC_ALT_ACC = 0x01000000
}

Flags to specify how comparisons are performed in the find functions.

More...
enum FIND_FLAGS {
FT_PEPTIDE_EXP_MZ = 0x00000001,
FT_PEPTIDE_EXP_MR = 0x00000002,
FT_PEPTIDE_CALC_MZ = 0x00000004,
FT_PEPTIDE_CALC_MR = 0x00000008,
FT_PEPTIDE_STRING = 0x00000010,
FT_PEPTIDE_QUERY = 0x00000020,
FT_PEPTIDE_VARMOD = 0x00000040,
FT_PEPTIDE_FIXMOD = 0x00000080,
FT_PEPTIDE_ETMOD = 0x00000100,
FT_PEPTIDE_SLMOD = 0x00000200,
FT_PEPTIDE_VARMOD_BYNAME = 0x00000400,
FT_PEPTIDE_FIND_MASK = 0x00000FFF,
FT_PROTEIN_ACCESSION = 0x00001000,
FT_PROTEIN_DESCRIPTION = 0x00002000
}

Flags for findPeptides() and findProteins().

More...
enum FLAGS {
MSRES_NOFLAG = 0x00000000,
MSRES_GROUP_PROTEINS = 0x00000001,
MSRES_SHOW_SUBSETS = 0x00000002,
MSRES_SUBSETS_DIFF_PROT = 0x00000004,
MSRES_REQUIRE_BOLD_RED = 0x00000008,
MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010,
MSRES_IGNORE_PMF_MIXTURE = 0x00000020,
MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040,
MSRES_DECOY = 0x00000080,
MSRES_INTEGRATED_ERR_TOL = 0x00000100,
MSRES_ERR_TOL = 0x00000200,
MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400,
MSRES_CLUSTER_PROTEINS = 0x00000800,
MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000,
MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000,
MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000,
MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000,
MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000,
MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000,
MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000,
MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000,
MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000,
MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000,
MSRES_DUPE_REMOVE_NONE = 0x00400000,
MSRES_DUPE_REMOVE_A = 0x00800000,
MSRES_DUPE_REMOVE_B = 0x01000000,
MSRES_DUPE_REMOVE_C = 0x02000000,
MSRES_DUPE_REMOVE_D = 0x04000000,
MSRES_DUPE_REMOVE_E = 0x08000000,
MSRES_DUPE_REMOVE_F = 0x10000000,
MSRES_DUPE_REMOVE_G = 0x20000000,
MSRES_DUPE_REMOVE_H = 0x40000000,
MSRES_DUPE_REMOVE_I = 0x80000000,
MSRES_DUPE_DEFAULT = 0x04800000
}

Flags for the type of results.

More...
enum HOMOLOGY_THRESHOLD_SOURCE { ,
HOMTHR_FASTA = -1,
HOMTHR_SL = -2
}

Flags for getHomologyThreshold()

More...
enum IONS_HISTOGRAM {
IH_INCLUDE_TOP_MATCHES = 0x0000,
IH_INCLUDE_TOP_10_MATCHES = 0x0001
}

Flags for getIonsScoreHistogram().

More...
enum MSPEPSUM {
MSPEPSUM_NONE = 0x0000,
MSPEPSUM_PERCOLATOR = 0x0001,
MSPEPSUM_USE_CACHE = 0x0002,
MSPEPSUM_SINGLE_HIT_DBIDX = 0x0004,
MSPEPSUM_USE_HOMOLOGY_THRESH = 0x0008,
MSPEPSUM_NO_PROTEIN_GROUPING = 0x0010,
MSPEPSUM_DISCARD_RELOADABLE = 0x0020,
MSPEPSUM_DEFERRED_CREATE = 0x0040,
MSPEPSUM_CACHE_IGNORE_DATE_CHANGE = 0x0080,
MSPEPSUM_REMOVE_CHIMERIC_DUPES = 0x0100,
MSPEPSUM_SL_INTEGRATED = 0x0200,
MSPEPSUM_SL_ONLY = 0x0400,
MSPEPSUM_CROSSLINK_INTEGRATED = 0x0800,
MSPEPSUM_CROSSLINK_ONLY = 0x1000
}

flags2 for ms_peptidesummary introduced in Mascot Parser 2.3.

More...
enum QL_FLAG { ,
QL_ALL = 0x0000,
QL_UNASSIGNED = 0x0001,
QL_BELOW_IDENTITY = 0x0002,
QL_BELOW_HOMOLOGY = 0x0003,
QL_IGNORE_IONS_SCORE_BELOW = 0x0004,
QL_LAST = 0x0004
}

Flags for getQueryList().

More...
enum QUANT_COMPONENT_STATUS {
QCS_OK,
QCS_OK_NO_MATCH,
QCS_ERROR_NO_METHOD,
QCS_ERROR_NO_COMPONENTS,
QCS_ERROR_BAD_COMPONENT_NAME,
QCS_OK_MULTIPLE_MATCHES
}

Return codes for getQuantitationComponentForPeptide().

More...
enum sortBy {
QUERY,
SCORE,
INTENSITY
}

Flags for createUnassignedList().

More...
enum THRESHOLD_TYPE {
TT_HOMOLOGY = 0x0000,
TT_IDENTITY = 0x0001,
TT_PEPSUM_DEFAULT = 0x0002
}

Flags for getPeptideThreshold()

More...
enum TREE_CLUSTER_METHOD { ,
TCM_PAIRWISE_SINGLE = 0x0001,
TCM_PAIRWISE_MAXIMUM = 0x0002,
TCM_PAIRWISE_AVERAGE = 0x0003
}

Flags for getTreeClusterNodes().

More...
enum UNIQUE_PEP_RULES {
UPR_WITHIN_FAMILY = 0x0001,
UPR_WITHIN_FAMILY_MEMBER = 0x0002,
UPR_IGNORE_SUBSET_PROTEINS = 0x0004,
UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
}

Flags for isPeptideUnique().

More...

Public Member Functions

ms_peptidesummary (const ms_mascotresfile &resfile, const unsigned int flags=MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE)
[Deprecated] Call this constructor once to create peptide summary results.
ms_peptidesummary (const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters)
Call this constructor once to create peptide summary results.
virtual bool | anyEmPAI () const
virtual bool | anyNumDiscoveredMods () const
Return true if modification discovery statistics are available.
void | cancelCreateSummary (bool newValue=true)
Cancel the call to createSummary()
virtual bool | createSummary ()
Create the summary using a separate call after the ms_peptidesummary object has been created.
bool | createUnassignedList (sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
bool | dumpCDB (const std::string dumpFileName)
virtual int | findPeptides (const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const
Find the next hit that contains peptides with the specified attribute.
virtual int | findProteins (const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified attributes.
virtual int | findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified accession.
virtual int | findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified description.
virtual void | freeHit (const int hit)
Frees any memory associated with the passed hit number.
virtual int | getAllFamilyMembersWithThisPepMatch (const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const
Return a list of (top level) family proteins that have a match to the specified q and p.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const
Returns a complete list of all the accessions that contained the peptide matched by this result.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const
Returns a complete list of all the accessions that contained the peptide matched by this result.
virtual int | getAvePeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the average threshold value for all MS-MS data sets.
std::string | getCacheFileName () const
Returns the filename of the cache file.
virtual bool | getComponentIntensity (const int q, const int p, const std::string &componentName, double &value, double &rawValue) const
Returns the component intensity for reporter or multiplex methods.
virtual const ms_protein * | getComponentProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
virtual std::string | getComponentString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return q1_p2_comp string value.
bool | getCreateSummaryProgress (int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const
Return progress for the createSummary() call.
const ms_crosslinking_method * | getCrosslinkingMethod () const
Returns the crosslinking method from the results file.
virtual std::vector< double > | getDiscoveredErrTolModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all error tolerant modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredErrTolModNames () const
Return the names of all error tolerant modifications discovered in this search.
virtual std::vector< double > | getDiscoveredLocalModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all query-level modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredLocalModNames () const
Return the names of all query-level modifications discovered in this search.
virtual double | getErrTolModDelta (const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const
Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModMasterNeutralLoss (const int q, const int p) const
Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModMasterString (const int q, const int p) const
Return the complete error tolerant mod master neutral loss string from q1_p1_et_mods_master.
virtual std::string | getErrTolModName (const int q, const int p, std::string *modString=NULL) const
Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolModNeutralLoss (const int q, const int p) const
Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::string | getErrTolModPepString (const int q, const int p) const
Return the complete error tolerant mod peptide neutral loss string from q1_p1_et_mods_pep.
virtual std::vector< double > | getErrTolModReqPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::string | getErrTolModReqPepString (const int q, const int p) const
Return the complete error tolerant mod required peptide neutral loss string from q1_p1_et_mods_reqpep.
virtual std::vector< double > | getErrTolModSlaveNeutralLoss (const int q, const int p) const
Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModSlaveString (const int q, const int p) const
Return the complete error tolerant mod slave neutral loss string from q1_p1_et_mods_slave.
virtual std::string | getErrTolModString (const int q, const int p) const
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolProbabilityThreshold () const
Return the probability threshold used for error tolerant peptides.
unsigned int | getFlags () const
Returns the flags value passed to the constructor.
unsigned int | getFlags2 () const
Return the flags2 value passed to the ms_peptidesummary constructor.
virtual ms_protein * | getHit (const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
virtual int | getHomologyThreshold (const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
virtual int | getHomologyThresholdForHistogram (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns the value for the 'yellow section' in the histogram.
virtual double | getIonsScore (const int q, const int p, const bool decoy) const
Returns an ions score quickly without having to load an ms_peptide object.
virtual std::vector< int > | getIonsScoreHistogram (IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns a list of counts for binned ions scores.
void | getLibraryEntryId (const int q, const int p, std::vector< int > &dbIdx, std::vector< int > &offset, std::vector< std::string > &checksum, std::vector< std::string > &mods) const
Return the database number, MSP file offset, checksum and modifications of the matched spectral library entry.
virtual std::string | getLibraryModString (const int q, const int p) const
Return the modification string of the spectral library match from q1_p1_SLmod.
virtual int | getMaxPeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the max threshold value for all MS-MS data sets.
virtual int | getMaxRankValue () const
Returns the maximum 'rank' or 'hit' or 'p' value.
int | getMinPepLenInPepSummary () const
Peptides shorter than this are ignored when putting proteins into groups.
virtual ms_protein * | getNextFamilyProtein (const int masterHit, const int id) const
Find the next protein in the family masterHit.
virtual ms_protein * | getNextSimilarProtein (const int masterHit, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSimilarProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProtein (const int masterHit, const int id, const bool searchWholeFamily=true) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
std::vector< int > | getNumberOfAccessionDBTypes (int q, int p) const
Return a count of protein accessions by database type of all the accessions that contained the peptide match.
std::vector< int > | getNumberOfFamilyAccessionDBTypes (int hit, int q, int p, bool includeSamesets=true) const
Return a count of protein accessions by database type of all the family members that contained the peptide match.
virtual int | getNumberOfFamilyMembers () const
Return the total number of family members.
virtual int | getNumberOfHits () const
Returns the number of hits in the results.
int | getNumberOfUnassigned () const
Return the number of peptides in the unassigned list.
virtual long | getNumDecoyHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the homology threshold.
virtual long | getNumDecoyHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the identity threshold.
virtual std::vector< int > | getNumDiscoveredErrTolMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of error tolerant modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredFixedMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of fixed modifications discovered in this search.
std::vector< int > | getNumDiscoveredIntactLinks (std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const
Return the count of intact crosslinks in this search.
std::vector< int > | getNumDiscoveredLibraryMods (const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of library modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredLocalMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of query-level modifications discovered in this search.
virtual int | getNumDiscoveredNonSpecCleavage () const
Return the count of non-specific cleavages in an error tolerant search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of variable modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const
Return the count of variable modifications discovered in this search.
virtual long | getNumHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the homology threshold.
virtual long | getNumHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the identity threshold.
virtual std::vector< int > | getPepsWithSameScore (const int q, const int p) const
Returns a list of 'p' values for peptides with the same score.
virtual ms_peptide | getPeptide (const int q, const int p) const
Return a peptide object for the specified query / rank.
virtual bool | getPeptide (const int q, const int p, ms_peptide *&pep) const
Return a peptide object for the specified query / rank.
std::vector< int > | getPeptideAmbiguityRanks (const int q, const int p)
Return a vector of ranks that have the same ambiguity group.
virtual double | getPeptideExpectationValue (const double score, const int query, const int rank=0) const
Returns the expectation value for the given peptide score and query.
virtual int | getPeptideIdentityThreshold (const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
double | getPeptideThreshold (const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const
Return either the identity or the homology threshold.
virtual double | getProbabilityThreshold () const
Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.
virtual int | getProbFromScore (const double score) const
Returns a probability value given a score.
virtual double | getProbOfPepBeingRandomMatch (const double score, const int query) const
virtual double | getProbOfProteinBeingRandomMatch (const double score) const
virtual const ms_protein * | getProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
std::string | getProteinDescription (const char *accession, const int dbIdx=1) const
Return protein description if available.
virtual double | getProteinEmPAI (const char *accession, const int dbIdx=1, const int length=-1) const
Return protein emPAI if available.
virtual double | getProteinExpectationValue (const double score) const
Returns the expectation value for the given protein score.
double | getProteinMass (const char *accession, const int dbIdx=1) const
Return protein mass if available.
virtual int | getProteinScoreCutoff (double OneInXprobRnd) const
Return the 'protein' score value for cutting off results. Different for peptide and protein summary.
virtual double | getProteinScoreForHistogram (const int num) const
Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.
virtual std::string | getProteinsWithThisPepMatch (const int q, const int p, const bool quotes=false)
Return a partial list of proteins that matched the same peptide.
void | getProteinTaxonomyIDs (const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const
Return the taxonomy ID(s), if any, from the results file.
virtual int | getProteinThreshold (double OneInXprobRnd) const
Return a threshold value for the protein summary report.
virtual int | getQmatch (const int query) const
Return the number of peptides with masses that matched this query.
virtual int | getQmatch (const int query, const ms_mascotresfile::section sec) const
Return the number of peptides with masses that matched this query.
virtual QUANT_COMPONENT_STATUS | getQuantitationComponentForPeptide (const ms_peptide &peptide, ms_quant_component &component, const ms_quant_method *method=NULL) const
Get the component in the quantitation method that matches the peptide.
const ms_quant_method * | getQuantMethod () const
Returns the quantitation method from the results file.
std::string | getQueryList (QL_FLAG flag, bool outputListOfQueries=true)
Returns a list of query numbers that can be used for a repeat search.
virtual std::string | getReadableVarMods (const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
const ms_mascotresfile & | getResfile () const
Return a reference to the resfile.
ms_mascotresults_params getResultsParameters ()
Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.
double | getSequenceMass (const char *seq) const
Return the mass of a sequence (protein or peptide).
int | getSrcRank (int q, int p) const
Returns the 'source' rank for a given peptide match.
ms_mascotresfile::section | getSrcSection (int q, int p) const
Returns the 'source' section for a given peptide match.
virtual int | getTagDeltaRangeEnd (const int q, const int p) const
Return the second number from q1_p2_drange=0,256.
virtual int | getTagDeltaRangeStart (const int q, const int p) const
Return the first number from q1_p2_drange=0,256.
virtual int | getTagEnd (const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagSeries (const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagStart (const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual std::string | getTagString (const int q, const int p) const
Return the complete tag string from q1_p1_tag.
virtual std::string | getTerminalResiduesString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the complete terminal residue string from q1_p1_terms.
bool | getThresholdForFDRAboveHomology (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveHomology (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.
double | getToleranceInDalton (bool &needMass, const double *const pMass=NULL) const
Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.
virtual bool | getTreeClusterNodes (const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const
Return distances and structure suitable for a dendrogram plot.
ms_peptide | getUnassigned (const int num) const
Need to call createUnassignedList() before calling this.
bool | getUnassignedIsBold (const int num) const
Returns true if the item indexed by num in the assigned list should be bold.
bool | getUnassignedShowCheckbox (const int num) const
Returns true if the item indexed by num in the assigned list should have a check box next to it.
bool | hasCrosslinkingMethod () const
Returns true if the results file has a crosslinking method.
bool | hasQuantMethod () const
Returns true if the results file has a quantitation method.
bool | isDataCached (BUGFIX_NUM bugNum) const
Returns true if the cache file contains data relevant to the given bug number.
bool | isEmPAIallowed () const
Return true if emPAI could be calculated using data in this results file.
bool | isNA () const
Returns TRUE for a search against a nucelic acid database.
bool | isPeptideComponentMatch (const ms_quant_component &component, const ms_peptide &peptide) const
Tests whether the peptide is a match for all the modifications of the quantitation component.
bool | isPeptideModificationMatch (const ms_quant_modgroup &group, const ms_peptide &peptide) const
Tests whether the peptide is a match for the quantitation modification group.
virtual bool | isPeptideUnique (const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const
Returns true if this peptide match is unique to one protein or one protein family.
const ms_mascotresfile & | mascotresfile () const
Return the attached results file.
virtual void | setSubsetsThreshold (const double scoreFraction)
Specifies which subset proteins should be reported.

Static Public Member Functions

static std::string | getCacheFilename (const ms_mascotresfile &resfile, const unsigned int flags, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE)
[Deprecated] Call this to retrieve the name of the file that the peptide summary will use for its cache.
static std::string | getCacheFilename (const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters)
Call this to retrieve the name of the file that the peptide summary will use for its cache.
static double | getMinProbabilityForSLScore (double score)
Return the minProbability value that sets library score threshold to the given value in SL-only mode.
static double | getSLThresholdFromMinProbability (double minProbability)
Return the library score threshold in SL-only mode corresponding to the given value of minProbability.
static bool | willCreateCache (const char *resultsFileName, const ms_mascotoptions &opts, const char *unigeneIndexFile, const char *singleHit, const char *applicationName, std::string &resfileCacheFileName, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus)
[Deprecated] Returns true if either cache file will be created when the ms_mascotresfile and ms_peptidesummary objects are created
static bool | willCreateCache (const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters)
Returns true if a cache file will be created when the ms_peptidesummary constructor is called.
static bool | willCreateCache (const ms_mascotresfile &resfile, const unsigned int flags=MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE)
[Deprecated] Returns true if a cache file will be created when the ms_peptidesummary constructor is called.
static bool | willCreateCache (const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters, const ms_mascotoptions &opts, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus)
Returns true if either cache file will be created when the ms_mascotresfile and ms_peptidesummary objects are created.

Protected Member Functions

double | getIonsScoreCorrected (const double ionsScore, const long multiplicity) const
virtual double | getPepIdentThreshProtected (const int query, double OneInXprobRnd, ms_mascotresfile::section sec, DB_MATCH_TYPE dbType, double *pQmatch=0) const
Return the threshold value for this ms-ms data being a random match.

Detailed Description

Use this class to get peptide summary results.

The following functions provide threshold values:

  • getPeptideIdentityThreshold()
  • getAvePeptideIdentityThreshold()
  • getMaxPeptideIdentityThreshold()
  • getPeptideThreshold()
  • getProteinThreshold()
  • getHomologyThreshold()
  • getHomologyThresholdForHistogram()
  • getProbFromScore()
  • getProbOfPepBeingRandomMatch()
  • double getProbOfProteinBeingRandomMatch()

This class inherits from ms_mascotresults, and all the class functions except for getPeptide() are documented in ms_mascotresults.

Examples:

peptide_list.cpp, repeat_search.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum BUGFIX_NUM

bugNum values for isDataCached().

If caching is in use and the cache file has been created with a previous version of Parser, then the cache file may not contain data for later improvements. While this does not affect functionality, it may impact performance. For example, the addition of getProteinEmPAI() (bug 11235) causes the number of observed peptides to be saved in new cache files. If the numbers are missing from the cache file, they are computed on the fly, which may be slow with very large cache files.

See Using enumerated values and static const ints in Perl, Java, Python and C# and ms_peptidesummary::isDataCached(), and also Caching Mascot Results.

Enumerator:
BUGFIX_10780

The definition of peptide uniqueness changed in Parser 2.4.0. If isDataCached() returns false, isPeptideUnique() may be slower than expected when using the default setting UPR_DEFAULT.

BUGFIX_10995

Since Parser 2.4.1, score thresholds never drop below 13. If isDataCached() returns false, score thresholds below 13 may be observed.

BUGFIX_11002

Parser 2.4.1 filters out proteins whose longest significant peptide match is less than MinPepLenInPepSummary. If isDataCached() returns false, families may contain proteins with significant peptide matches shorter than MinPepLenInPepSummary.

BUGFIX_11018

The scores of rank 1 matches have been saved in the cache file since Parser 2.4.01. If isDataCached() returns false, ms_mascotresults::getThresholdForFDRAboveIdentity() and ms_mascotresults::getThresholdForFDRAboveHomology() may be slower than expected.

BUGFIX_11235

emPAI calculation was moved to Parser in version 2.5.0, which includes saving the number of observed peptides for each protein in the cache file. If isDataCached() returns false, ms_mascotresults::getProteinEmPAI() may be slower than expected.

BUGFIX_11254

Parser 2.5.0 introduced modification discovery statistics (getNumDiscoveredVariableMods() et al.). If isDataCached() returns false, these statistics are computed by iterating over all queries in the file, which may be slow with large files.

BUGFIX_11344

Reporter and Multiplex quantitation were moved to Parser in version 2.5.0. If isDataCached() returns false, component intensities will be extracted from queries on the fly, which may make ms_ms2quantitation and ms_mascotresults::getComponentIntensity() slower than expected.

BUGFIX_11411

Parser 2.5.0 saves the qmatch and qplughole values of each match in new cache files. If isDataCached() returns false, peptide threshold calculation may be slower than expected.

BUGFIX_11425

Parser 2.5.0 introduced ms_mascotresults::getIonsScore() for fetching match scores without a peptide object. If isDataCached() returns false, the cache file does not contain the saved scores and getIonsScore() and ms_ms2quantitation may be slower than expected.

BUGFIX_11438

Parser 2.5.0 saves the charge of each query in new cache files. If isDataCached() returns false, ms_mascotresfile::getObservedCharge() and ms_ms2quantitation may be slower than expected.

BUGFIX_11483

The number of unique sequences per protein are saved in new cache files since Parser 2.5.0. If isDataCached() returns false, ms_protein::getNumDistinctPeptides() may be slower than expected when using the DPF_UNIQUE flag.

BUGFIX_11499

Parser 2.5.0 started saving the number of hits above identity and homology for all searches, not just decoy searches. If the numbers are not available, getNumHitsAboveIdentity() and getNumHitsAboveHomology() can be slow, especially in large files.

BUGFIX_11856

Parser 2.5.0 getNumDiscoveredErrTolMods() excluded some error tolerant modifications when the queries were below requested probability threshold. If using isDataCached() then use BUGFIX_11254 enumeration. Refer to bug 11254 above for more information.

BUGFIX_12123

Parser 2.6 added two new types of decoy statistics: counting peptide sequences, and counting library matches. If isDataCached() returns false, only counts for PSMs in FASTA sequences are saved in the cache file. Otherwise, all counts are cached. See getNumHitsAboveIdentity() for information about the different count types.

BUGFIX_12317

Parser 2.6 also bug 12430, average identity threshold must be calculated with a number of qmatches of at least 20.

BUGFIX_11481

Parser 2.6 decoy peptide strings added to cache so that they can be accessed in a non-decoy summary environment.

BUGFIX_12538

Parser 2.6.1 ambiguity group id for peptides added to cache to speed up report loading.

BUGFIX_12729

Improved protein inference for multi-library searches with only one reference database; fixed in Parser 2.6.1.

BUGFIX_12740

Parser 2.6.0 supports reranking matches when Percolator is enabled, based on the new Percolated scores. Some attributes required for reranking were not being written correctly in the cache file. This is fixed in Parser 2.6.1.

BUGFIX_13324

In Parser 2.6, ms_peptidesummary::getDiscoveredErrTolModDeltas() returned ET mod deltas in sorted order. Parser 2.7 and later return deltas in the same order as the names in getDiscoveredErrTolModNames(). If caching is enabled, deltas are only available when reading a 2.7 or later cache file.

BUGFIX_12447

Mascot Server 2.8 reports expect values for ET matches and supports fusion ET decoy searching. If caching is in use and the cache file was created by Parser 2.7 or earlier, ET expect values and false discovery rate are not available. It's best to recreate the cache file.

BUGFIX_13759

Target FDR can be specified as ms_peptidesummary constructor argument in Parser 2.8. If caching is in use and the cache file was created by Parser 2.7 or earlier, the target FDR argument is ignored.

enum CACHE_STATUS

Returned by the willCreateCache function.

See Using enumerated values and static const ints in Perl, Java, Python and C# and Caching Mascot Results

The function may bitwise OR multiple values together

Enumerator:
CACHE_MISSING_RESFILE

Either the results file is missing or an empty string is passed to the function.

RESFILE_CACHE_FILE_NOT_PRESENT

The ms_mascotresfile cache file is not present and is not being created.

RESFILE_CACHE_BEING_CREATED

The ms_mascotresfile cache file is being created.

RESFILE_CACHE_DISABLED_IN_OPTIONS

Use of the ms_mascotresfile cache file is disabled in the options section of mascot.dat.

RESFILE_CACHE_VALID

The ms_mascotresfile cache file has already been created and is valid.

RESFILE_CACHE_CAN_CREATE

The ms_mascotresfile cache file can be (re-)created. It either doesn't exist or is out of date or invalid for some reason.

PEPSUMMARY_CACHE_FILE_NOT_PRESENT

The ms_peptidesummary cache file is not present and is not being created.

PEPSUMMARY_CACHE_BEING_CREATED

The ms_peptidesummary cache file is being created.

PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS

Use of the ms_peptidesummary cache file is disabled in the options section of mascot.dat.

PEPSUMMARY_CACHE_VALID

The ms_peptidesummary cache file has already been created and is valid.

PEPSUMMARY_CACHE_CAN_CREATE

The ms_peptidesummary cache file can be (re-)created. It either doesn't exist or is out of date or invalid for some reason.

PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE

If the ms_mascotresfile cache file is not present, then no attempt is made to find out about the ms_peptidesummary cache file.

PEPSUMMARY_CACHE_NOT_FOR_PMF

A ms_peptidesummary cache file is not created if the results file just contains PMF matches.

enum DB_MATCH_TYPE [inherited]

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

Enumerator:
DM_FASTA

Mascot matches to FASTA sequences. This is the default.

DM_SPECTRAL_LIBRARY

Matches to spectral library entries. This was introduced in Parser 2.6.

DM_BOTH

Only valid for count of matches (getNumHitsAboveIdentity() and friends): the combined count for FASTA and spectral library entries.

DM_FASTA_FIRST_PASS

Mascot matches to FASTA sequences, first pass only.

DM_FASTA_SECOND_PASS

Mascot matches to FASTA sequences, second pass only (e.g. error tolerant).

enum DECOY_STATS_COUNT_TYPE [inherited]

Type of object counted by getNumHitsAboveIdentity() and friends.

Enumerator:
DS_COUNT_PSM

Count peptide-spectrum matches (PSMs). This is the default.

DS_COUNT_SEQUENCE

Count distinct peptide sequences. This was introduced in Parser 2.6.

enum FIND_COMPARE_FLAGS [inherited]

Flags to specify how comparisons are performed in the find functions.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These flags are used in findProteins(), findPeptides() and the deprecated functions: findProteinsByAccession() and findProteinsByDescription(). The flags are used to specify how the comparison is performed and whether it should be a forward or reverse seach. Typically, three values will be combined together, using an OR operator; however, any default values do not need to be specifically specified.

  • Choose 1 of: FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK
  • Choose 1 of: FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE
  • Choose 1 of: FC_FORWARD, FC_REVERSE
  • Optionally choose FC_RESTRICT_TO_HIT or (FC_LOOP_INTO_UNASSIGNED and/or FC_LOOP_FROM_UNASSIGNED)
  • Optionally choose FC_SEARCH_ALL_RANKS
  • Optionally choose FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES
  • Optionally choose one or more of the FC_PROTEIN_IGN_ flags when calling findProteins()
Enumerator:
FC_COMPLETESTR

Search for the complete string. If search item is a decimal number then match the number exactly.

FC_SUBSTR

Search for any substring. Not valid if search item is a decimal number.

FC_STARTSTR

String must match to start of target string. If search item is a decimal number then match to the same decimal precision of the filter value but rounded. For example a filter value of 1234.56 will return items with values in the range (1234.555 >= value < 1234.565).

FC_STRTOK

Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a peptide sequence.

FC_MASK_STR_PART

Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified.

FC_CASE_INSENSITIVE

Case insensitive search (default).

FC_CASE_SENSITIVE

Case sensitive search.

FC_MASK_CASE

Bit mask to extract which one of FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE has been specified.

FC_FORWARD

Forward search. The returned hit number will be the same as or higher than the start hit number. (default).

FC_REVERSE

Reverse search. The returned hit number will be the same as or lower than the start hit number.

FC_MASK_DIRECTION

Bit mask to extract which one of FC_FORWARD, FC_REVERSE has been specified.

FC_RESTRICT_TO_HIT

Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_LOOP_INTO_UNASSIGNED

If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.

FC_LOOP_FROM_UNASSIGNED

If the passed hit number is 0, and no match is found in the unassigned list, then start searching at 1 if FC_FORWARD is specified or start searching at 'numHits' if FC_REVERSE is specified.

FC_UNASSIGNED_MASK

Bit mask to extract FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_SEARCH_ALL_RANKS

For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assigned to a protein hit. Use this flag to search all ranks in such queries instead.

FC_ALL_PEPTIDES

Search all peptides regardless of score (default).

FC_ALL_PEPTITDES
Deprecated:
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
FC_SIGNIFICANT_PEPTIDES

Only search peptides above identitity or homology threshold.

FC_SEARCH_IGNORED_RANKS

In integrated library mode, also search peptides that are part of a family member's list of ignored peptides.

FC_SCORING_MASK

Bit mask to extract FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES.

FC_PROTEIN_IGN_SAMESETS

Ignore sameset proteins - only used for findProteins()

FC_PROTEIN_IGN_SUBSETS

Ignore subset proteins - only used for findProteins()

FC_PROTEIN_IGN_FAMILY

Ignore family member proteins - only used for findProteins()

FC_PROTEIN_IGN_MASK

Ignore proteins flags.

FC_PROTEIN_INC_ALT_ACC

For use with findProteins() only. If protein entries in the database are representative (i.e. contain multiple accessions) and those accessions are saved in the results file (Mascot 2.4 or later), setting this flag will search all accessions of each protein entry, not just the first accession.

enum FIND_FLAGS [inherited]

Flags for findPeptides() and findProteins().

Details what needs to be searched for. Any of the FT_PEPTIDE_ flags may be used for either findPeptides() or findProteins(), but the FT_PROTEIN flags may only be used for findProteins()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
FT_PEPTIDE_EXP_MZ

Find an experimental m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_EXP_MR

Find an experimental relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_CALC_MZ

Find a calculated m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_CALC_MR

Find a calculated relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_STRING

Find a peptide string.

FT_PEPTIDE_QUERY

Find a query number.

FT_PEPTIDE_VARMOD

Find a variable modification. Specifiy the modification 'number' as the string.

FT_PEPTIDE_FIXMOD

Find a fixed modification. Specifiy the modification 'number' as the string.

FT_PEPTIDE_ETMOD

Find an error tolerant modification. Specifiy a delta mass as the string.

FT_PEPTIDE_SLMOD

Find a spectral library modification. Specifiy any substring of the mod name as the string.

FT_PEPTIDE_VARMOD_BYNAME

Find a variable or query level modification. Specify any substring of the mod name as the string.

FT_PEPTIDE_FIND_MASK

Bit mask for any of the peptide values to be found.

FT_PROTEIN_ACCESSION

Find an accession - findProteins() only.

FT_PROTEIN_DESCRIPTION

Find a description - findProteins() only.

enum FLAGS [inherited]

Flags for the type of results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Not all of the flags applicable for protein summary (e.g. MSRES_REQUIRE_BOLD_RED); see ms_proteinsummary.

Enumerator:
MSRES_NOFLAG

Does nothing.

MSRES_GROUP_PROTEINS

Group proteins with same peptide matches. See Grouping proteins together.

MSRES_SHOW_SUBSETS

Show proteins that only match a subset of peptides. See Grouping proteins together.

MSRES_SUBSETS_DIFF_PROT

Proteins that contain a subset of peptides are treated as a unique protein. See Grouping proteins together.

MSRES_REQUIRE_BOLD_RED

Only proteins that have a top scoring peptide not seen before will be returned.

MSRES_SHOW_ALL_FROM_ERR_TOL

If this flag is set, then all hits from error tolerant search are shown. See Error tolerant searches.

MSRES_IGNORE_PMF_MIXTURE

If this flag is set, then PMF mixtures are ignored. See Peptide mass fingerprint mixtures.

MSRES_MUDPIT_PROTEIN_SCORE

Protein scoring for the peptide summary was changed at Mascot 2.0 for large (MudPIT) searches. See ms_protein::getScore().

MSRES_DECOY

If this flag is set, then use the results from searching against the decoy database. See Target-decoy searches and false discovery rate.

MSRES_INTEGRATED_ERR_TOL

If this flag is set, then create a ms_peptidesummary object that contains results from the summary and et_summary section. See Error tolerant searches.

MSRES_ERR_TOL

If this flag is set, then create a ms_peptidesummary object that contains results from the et_summary section. See Error tolerant searches.

MSRES_MAXHITS_OVERRIDES_MINPROB

If minProbability and maxHitsToReport are both non zero, then minProbability is ignored when determining the number of proteins to be displayed. See ms_mascotresults::ms_mascotresults.

MSRES_CLUSTER_PROTEINS

Protein clustering introduced in Mascot 2.3. See Using MSRES_CLUSTER_PROTEINS.

MSRES_DUPE_INCL_IN_SCORE_NONE

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_A

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_B

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_C

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_D

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_E

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_F

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_G

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_H

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_I

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_NONE

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_A

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_B

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_C

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_D

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_E

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_F

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_G

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_H

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_I

See Treatment of duplicate peptides.

MSRES_DUPE_DEFAULT

Default parameter for treatment of duplicates. See Treatment of duplicate peptides.

enum HOMOLOGY_THRESHOLD_SOURCE [inherited]

Flags for getHomologyThreshold()

The method getHomologyThreshold() accepts either a rank argument or one of the special enumerated values listed here. For backwards compatibility, the integers 1-20 have their own enumerated values.

Enumerator:
HOMTHR_FASTA

Retrieve the homology threshold for FASTA matches.

HOMTHR_SL

Retrieve the homology threshold for spectral library matches.

enum IONS_HISTOGRAM [inherited]

Flags for getIonsScoreHistogram().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
IH_INCLUDE_TOP_MATCHES

The default. Just include the top match to each spectrum.

IH_INCLUDE_TOP_10_MATCHES

Instead of just the top match, use the top 10 matches to each spectrum.

enum MSPEPSUM

flags2 for ms_peptidesummary introduced in Mascot Parser 2.3.

See Using enumerated values and static const ints in Perl, Java, Python and C# and ms_peptidesummary::ms_peptidesummary.

Enumerator:
MSPEPSUM_NONE

Default.

MSPEPSUM_PERCOLATOR

See Using Percolator scores for details.

MSPEPSUM_USE_CACHE

See Using the ms_peptidesummary cache.

MSPEPSUM_SINGLE_HIT_DBIDX

The singleHit parameter string must start with a database index and a colon, e.g. 3:CH60_SHEON. See Using the singleHit parameter to return a single protein.

MSPEPSUM_USE_HOMOLOGY_THRESH

Expect values and cutoffs will use homology thresholds rather than identity thresholds.

MSPEPSUM_NO_PROTEIN_GROUPING

Used for when a ms_peptidesummary object it required, but no protein grouping is needed. ms_peptidesummary::getNumberOfHits() will return zero. The only functions that are guaranteed to work are ms_peptidesummary::getPeptide(), ms_peptidesummary::getAllProteinsWithThisPepMatch(), ms_peptidesummary::getQmatch(). Will not work with error tolerant searches.

MSPEPSUM_DISCARD_RELOADABLE

Specify this flag to use less memory. However, calls to getPeptide() will be slower because the data wll always be loaded again from the results file.

MSPEPSUM_DEFERRED_CREATE

Useful if it is necessary to be able to cancel creation of a ms_peptidesummary() object (which can take a long time). Call createSummary() manually after creating the ms_peptidesummary object.

MSPEPSUM_CACHE_IGNORE_DATE_CHANGE

Opening the peptide summary cache CDB file should ignore the last modified timestamp on the .dat file.

MSPEPSUM_REMOVE_CHIMERIC_DUPES

Specify this flag to remove duplicate matches from chimeric spectra (spectra with more than one precursor mass). See Chimeric duplicates.

MSPEPSUM_SL_INTEGRATED

Merge spectral library matches with Mascot matches, if any exist in the results file. If the flag is not specified, only Mascot matches are available.

MSPEPSUM_SL_ONLY

Use only the spectral library match sections and ignore Mascot matches.

MSPEPSUM_CROSSLINK_INTEGRATED

Merge crosslinked matches with standard, linear matches, if any exist in the results file. If the flag is not specified, only standard, linear matches are available.

MSPEPSUM_CROSSLINK_ONLY

Use only the crosslinked match sections.

enum QL_FLAG

Flags for getQueryList().

See Using enumerated values and static const ints in Perl, Java, Python and C# and getQueryList().

Enumerator:
QL_ALL

Returns "All" .

QL_UNASSIGNED

Returns a comma separated list of the query numbers in the unassigned list. If createUnassignedList() has not been called, getQueryList() function will call it, possibly causing some delay.

QL_BELOW_IDENTITY

Returns a comma separated list of the query numbers which have scores below the identity threshold calculated using the minProbability threshold specified in the ms_peptidesummary constructor. If minProbability <= 0 or >= 1, then an empty string is returned.

QL_BELOW_HOMOLOGY

Returns a comma separated list of the query numbers which have scores below the homology threshold calculated using the minProbability threshold specified in the ms_peptidesummary constructor. If minProbability <= 0 or >= 1, then an empty string is returned.

QL_IGNORE_IONS_SCORE_BELOW

Uses the threshold specified by the ignoreIonsScoreBelow parameter. If ignoreIonsScoreBelow is zero, then an empty string is returned.

QL_LAST

For looping through all possible values.

enum QUANT_COMPONENT_STATUS [inherited]

Return codes for getQuantitationComponentForPeptide().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
QCS_OK

The component was retrieved successfully.

QCS_OK_NO_MATCH

The quantitation method's components were searched successfully, no matching component was found.

QCS_ERROR_NO_METHOD

There is no quantitation method available (e.g. for protein summary).

QCS_ERROR_NO_COMPONENTS

There are no components specified in the quantitation method (e.g. for non-precursor method).

QCS_ERROR_BAD_COMPONENT_NAME

The peptide's component name in the Mascot results does not match any component in the quantitation method.

QCS_OK_MULTIPLE_MATCHES

The quantitation method's components were searched successfully, multiple matching components were found.

enum sortBy [inherited]

Flags for createUnassignedList().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
QUERY

Sort the unassigned list by ascending query number - this is the same as ascending relative mass order.

SCORE

Sort the unassigned list by descending score.

INTENSITY

Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (from PKL files, or some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values. For a very large MS-MS file, this option can take some time to process unless there are qintensity value in the results file.

enum THRESHOLD_TYPE [inherited]

Flags for getPeptideThreshold()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TT_HOMOLOGY

Homology threshold.

TT_IDENTITY

Identity threshold.

TT_PEPSUM_DEFAULT

If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor, then this will resolve to TT_HOMOLOGY, otherwise it will resolve to TT_IDENTITY.

enum TREE_CLUSTER_METHOD [inherited]

Flags for getTreeClusterNodes().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TCM_PAIRWISE_SINGLE

's': pairwise single-linkage clustering.

TCM_PAIRWISE_MAXIMUM

'm': pairwise maximum- (or complete-) linkage clustering.

TCM_PAIRWISE_AVERAGE

'a': pairwise average-linkage clustering.

enum UNIQUE_PEP_RULES [inherited]

Flags for isPeptideUnique().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Choose UPR_WITHIN_FAMILY or UPR_WITHIN_FAMILY_MEMBER and then optionally 'or' UPR_IGNORE_SUBSET_PROTEINS

Enumerator:
UPR_WITHIN_FAMILY

The peptide is unique if it occurs in proteins that are part of a single family.

UPR_WITHIN_FAMILY_MEMBER

The peptide is unique if it occurs in proteins that just belong to a single family member.

UPR_IGNORE_SUBSET_PROTEINS

Ignore any susbset proteins that contain the match when deciding if a peptide is unique. However, if the peptide just belongs to subset proteins for the same hit, then it is still considered to be unique.

UPR_DEFAULT

Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.

Constructor & Destructor Documentation

ms_peptidesummary | ( | const ms_mascotresfile & | resfile,
 |  | const unsigned int | flags = MSRES_GROUP_PROTEINS,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = MSPEPSUM_NONE
 | ) |  |

[Deprecated] Call this constructor once to create peptide summary results.

Note:
This constructor is deprecated in favour of ms_peptidesummary(const ms_mascotresfile&, const ms_mascotresults_params&). All new code should use the new constructor.

Creating an ms_peptidesummary object may take some time for a very large file with a large number of protein hits.

Parameters:
resfile | An ms_mascotresfile object. See Maintaining object references: two rules of thumb.
flags | can be one or more of the ms_mascotresults::FLAGS values OR'ed together
minProbability | specifies the significance threshold. See ms_mascotresults_params::getMinProbability(). See also ms_mascotresults_params::getTargetFDR().
maxHitsToReport | is a maximum value of protein hits to report. See ms_mascotresults_params::getMaxHitsToReport().
unigeneIndexFile is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.

  • From programming languages other than C++, pass an empty string object to specify no UniGene index file.
ignoreIonsScoreBelow | is an optional flag for the peptide summary only. See ms_mascotresults_params::getIgnoreIonsScoreBelow().
minPepLenInPepSummary | is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins (see Grouping proteins together).
singleHit | should only be used for getting the results for a single protein quickly. See ms_mascotresults_params::setSingleHit().
flags2 | should be one or more of the ms_peptidesummary::MSPEPSUM flags OR'd together
ms_peptidesummary | ( | const ms_mascotresfile & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  |

Call this constructor once to create peptide summary results.

Creating an ms_peptidesummary object may take some time for a very large file with a large number of protein hits.

Parameters:
resfile | An ms_mascotresfile object. See Maintaining object references: two rules of thumb.
parameters | An ms_mascotresults_params object which should contain all of the required values and flags to generate the peptide summary.

Member Function Documentation

bool anyEmPAI ( ) const [virtual]

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns:
true if above conditions are true and at least one protein has a non-zero emPAI value.

Reimplemented from ms_mascotresults.

bool anyNumDiscoveredMods ( ) const [virtual, inherited]

Return true if modification discovery statistics are available.

Modification discovery counts for fixed and variable modifications (and error tolerant modifications in an error tolerant search) are only available if the results file contains a Unimod section. Since only significant rank 1 peptide matches assigned to a protein hit are inspected for modification counting purposes, it is possible for the counts to be zero even when a Unimod section exists.

Returns:
True if number of modifications could be counted and there is at least one modification with a non-zero count; false otherwise.
void cancelCreateSummary ( bool newValue = true ) [inherited]

Cancel the call to createSummary()

It is normally recommended that an application should delete the ms_peptidesummary object after calling this function because some objects will still be in memory (no cleanup is performed).

Cancelling may not occur immediately, and the calling application needs to wait for the createSummary() call to return.

See also getCreateSummaryProgress() and ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

Parameters:
newValue should be set to true to cancel the createSummary call
bool createSummary ( ) [virtual]

Create the summary using a separate call after the ms_peptidesummary object has been created.

Creating an ms_peptidesummary object for a large results file can take a considerable amount of time. The standard Mascot reports do not have an option to 'cancel' the creation of the report and rely on the ms_mascotresfile::outputKeepAlive() function to provide progress reports and keep the connection alive. This is not so desireable for a client application that doesn't want to redirect stdout, and wants to allow the user to cancel a long operation. Specify the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag when creating the ms_peptidesummary object, and then use one thread to call this function and a separate thread to call getCreateSummaryProgress() and report progress to the end user.

This function is called directly by the ms_mascotresults constructor unless the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag is specified. If that flag is specified, then the constructor returns 'immediately' and this function must be called by the client code. Until this function returns, the client code in the separate thread can only reliably call the getCreateSummaryProgress(), ms_mascotresfile::outputKeepAlive() or cancelCreateSummary() functions. Calling any other function for the ms_mascotresults object may result in undefined behaviour and cause the ms_mascotresfile::ERR_RESULTS_NOT_CREATED error to be set.

This function should not be called for a ms_proteinsummary.

Returns:
true if successful

Reimplemented from ms_mascotresults.

bool createUnassignedList ( sortBy s = QUERY ) [inherited]

To have a list of unassigned peptides, need to call this first.

See Unassigned peptides list for details of creating an unassigned list.

Parameters:
s order to sort the unassigned list
Returns:
Currently always returns true unless createSummary() has not completed
Examples:
resfile_summary.cpp.
bool dumpCDB ( const std::string dumpFileName )

Debugging aid. Exports the cdb file as text.

Parameters:
dumpFileName is the path of the text file to dump information to .
Returns:
true if the file can be created and written to.
int findPeptides | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const [virtual]

Find the next hit that contains peptides with the specified attribute.

Note:
For a protein summary, this function always returns -1.

Can be used to find peptide-spectrum matches with a specified query number, sequence, mass, or fixed or variable modification. Returns the protein hit number and a list of q,p values that contains one or more string matches to the input string.

In crosslinked searches, both alpha and beta peptides are compared to the search criteria. Only one needs to match the input string.

All subset, sameset and family member proteins are searched, and it is possible that the returned q and p values only correspond to peptides in a single subset protein. The FC_PROTEIN_IGN_SAMESETS, FC_PROTEIN_IGN_SUBSETS and FC_PROTEIN_IGN_FAMILY flags cannot be used with this function. To find proteins which contain particular peptide matches, or to control which proteins to search, see findProteins().

For FT_PEPTIDE_VARMOD , str should contain the modification 'number' as passed to ms_searchparams::getVarModsName(). Modification numbers between 1 and 9 correspond to strings "1" through "9", and numbers between 10 and 32 correspond to "A" through "W". To find all error tolerant modifications, specify "X" and then use ms_peptidesummary::getErrTolModName() to retrieve the name of the modification.

For FT_PEPTIDE_FIXMOD, str should contain the modification 'number' as passed to ms_searchparams::getFixedModsName(). This will be in the range 1-20.

For both types of modification searches, str should only contain a single character. The value for compareFlags should include FC_SUBSTR, because this function is implemented by searching the return value from ms_peptide::getVarModsStr(). Specifying incorrect flags does not generate an error and results in undefined behaviour.

There is an alternative way to search for fixed mods: specify FT_PEPTIDE_STRING and FC_STRTOK as item and compareFlags, respectively, and pass the return value of ms_searchparams::getFixedModsResidues() as the string to search for, str. Although this may seem equivalent to the combination FT_PEPTIDE_FIXMOD and FC_SUBSTR, there are two corner cases where the latter works while the former doesn't:

  • ms_searchparams::getFixedModsResidues() can return "N_term" or "C_term", which are clearly not strings of amino acids.
  • The case where a fixed mod is 'replaced' with a variable mod. For example, if Carbamidomethyl (C) is specified as a fixed mod and Propionamide (C) as variable mod, then it is not sufficient to just check if a peptide contains a cysteine.
Parameters:
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1. To search the unassigned list, pass a value of 0.
str | is the string to be matched.
item | is the peptide item to be found (for example, the peptide sequence or mass). Any of the FT_PEPTIDE_ values may be used.
compareFlags | specifies whether the str value is required to match all or just part of the target string. It can also be used to specify a reverse search.
q | is a vector of query values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
p | is a vector of corresponding rank values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned matched items, or 0 if the match is in the unassigned list, or -1 if there is no match found.

Implements ms_mascotresults.

int findProteins | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [virtual]

Find the next hit that contains proteins with the specified attributes.

Note:
For a protein summary, this function always returns -1.

Used to find accessions, protein descriptions or proteins that have peptide matches with a specified query number, sequence, mass, or fixed or variable modification. Any of the FIND_FLAGS may be used.

The findPeptides() function does not return any information about which subset/sameset/family proteins in a hit contain the found matches. findProteins(), however, returns a list of the protein accessions that contained a peptide match that fits the search criteria, and also allows the searched proteins to exclude samesets (FC_PROTEIN_IGN_SAMESETS), subsets (FC_PROTEIN_IGN_SUBSETS or family members (FC_PROTEIN_IGN_FAMILY).

If protein entries in the database are representative (i.e. contain multiple accessions), by default only the first accession will be considered when FT_PROTEIN_ACCESSION is specified as a search item. If alternative accessions are saved in the results file (Mascot 2.4 or later), setting FC_PROTEIN_INC_ALT_ACC will search all accessions of each protein entry. Note that this will make the search slower.

Parameters:
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the string to be matched and depends on the value of item. If item is FT_PROTEIN_ACCESSION, then str will be the accession (or part of one) to be matched. If item is one of the FT_PEPTIDE_ values, then see FIND_FLAGS and findPeptides() for operational details.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
item | is the accession, description or peptide item to be found. For example, return all proteins with a given peptide sequence or mass.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains the matches, or -1 if there is no match found.

Implements ms_mascotresults.

int findProteinsByAccession | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [virtual]

Find the next hit that contains proteins with the specified accession.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Note:
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with accessions that match to the the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Parameters:
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

int findProteinsByDescription | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [virtual]

Find the next hit that contains proteins with the specified description.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Note:
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with descriptions that match the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Descriptions are just those included in the results file. See getProteinDescription() for details of what is loaded into the results.

Parameters:
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
compareFlags | specifies whether the str value is required to match all or just part of the description. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

void freeHit ( const int hit ) [virtual]

Frees any memory associated with the passed hit number.

Has no effect except when Using the ms_peptidesummary cache. This function frees the ms_protein objects for the specified hit. The return values from getHit(), getNextFamilyProtein(), getNextSimilarProtein(), getNextSimilarProteinOf(), getNextSubsetProtein() etc. for this hit will then point to deleted objects and hence should not be used.

In addition, any ms_peptide objects loaded into memory using the getPeptide(const int, const int, ms_peptide *&)const function will 'unloaded' if the ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE has been specified. This function has no effect on the ms_peptide objects returned from the alternative getPeptide(const int, const int)const function.

Parameters:
hit should be in the range 1.. getNumberOfHits().

Reimplemented from ms_mascotresults.

int getAllFamilyMembersWithThisPepMatch | ( | const int | hit,
 |  | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | db,
 |  | std::vector< std::string > & | acc,
 |  | std::vector< int > & | dupe_status
 | ) |  | const [virtual]

Return a list of (top level) family proteins that have a match to the specified q and p.

Only the top level proteins are returned by this function, that is, the proteins that would be returned by getHit() and getNextFamilyProtein(). It will be considerably faster than calling ms_protein::getPeptideQuery() and related functions, because that involves loading more information from the cache and from the .dat file.

This function will return the values rapidly when caching is enabled; see Using the ms_peptidesummary cache. It also functions correctly when not using the cache.

The returned vectors are all guaranteed to have the same number of elements. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use them from programming languages other than C++.

See also:
getAllProteinsWithThisPepMatch() and getProteinsWithThisPepMatch()
Parameters:
hit | Should be in the range 1.. getNumberOfHits().
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
db | is a vector of database IDs.
acc | is the corresponding vector of accessions.
dupe_status | is the corresponding vector of ms_protein::DUPLICATE values for the returned proteins. Note that ms_protein::DUPE_Ignored will only appear in integrated library searches where the peptide match was removed due to IgnoreIonsScoreBelow.
Returns:
The number of proteins in the db/acc/dupe_status vectors.

Implements ms_mascotresults.

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db
 | ) |  | const [virtual]

Returns a complete list of all the accessions that contained the peptide matched by this result.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

Crosslink searches only: If you need to know whether the accessions come from the alpha or beta peptide, use the 10-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also:
getProteinsWithThisPepMatch()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues -- one for each accession
end | Returns a vector of the end residues -- one for each accession
pre | Returns a vector of the residue before the peptide -- one for each accession
post | Returns a vector of the residue after the peptide -- one for each accession
frame | Returns a vector of the frames -- one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities -- one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
Returns:
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db,
 |  | std::vector< int > & | psmComponent
 | ) |  | const [virtual]

Returns a complete list of all the accessions that contained the peptide matched by this result.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

This method was added in Parser 2.7 for crosslinking support. If you don't need to know whether the accessions come from the alpha or beta peptide, you can use the 9-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also:
getProteinsWithThisPepMatch()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues -- one for each accession
end | Returns a vector of the end residues -- one for each accession
pre | Returns a vector of the residue before the peptide -- one for each accession
post | Returns a vector of the residue after the peptide -- one for each accession
frame | Returns a vector of the frames -- one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities -- one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
psmComponent | Returns a vector of psmComponent markers (ms_peptide::PSM) -- one for each accession. For a crosslinked match, this will be one of ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA. In all other types of match, it will always be ms_peptide::PSM_COMPLETE.
Returns:
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

int getAvePeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Return the average threshold value for all MS-MS data sets.

The average value is calculated by taking the mean value from calling getPeptideIdentityThreshold() for each query. This is the value that is used to be shown at the top of the standard Mascot reports in versions before Mascot 2.0. For example, threshold in the following string could be calculated by calling getAvePeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot score threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The average score threshold. If there was no MS-MS data then -1 will be returned.
std::string getCacheFilename | ( | const ms_mascotresfile & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  | [static]

Call this to retrieve the name of the file that the peptide summary will use for its cache.

Parameters:
resfile | The ms_mascotresfile for the project
parameters | The processing parameters passed to the constructor.
Returns:
cache file name
std::string getCacheFilename | ( | const ms_mascotresfile & | resfile,
 |  | const unsigned int | flags,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = MSPEPSUM_NONE
 | ) |  | [static]

[Deprecated] Call this to retrieve the name of the file that the peptide summary will use for its cache.

Note:
This method is deprecated in favour of getCacheFileName(const ms_mascotresfile&, const ms_mascotresults_params&). All new code should use the new method.
Parameters:
resfile | The ms_mascotresfile for the project
flags | collection of values, bitwise or-ed together, from the FLAGS enumeration of ms_mascotresults.
minProbability | The minimum significance probability threshold
maxHitsToReport | The number of protein hits to include in the results
unigeneIndexFile | path to the Unigene index file
ignoreIonsScoreBelow | The score cutoff threshold value
minPepLenInPepSummary | The minimum peptide length used to differentiate different proteins
singleHit | The accession string to retrieve a single protein
flags2 | collection of values, bitwise or-ed together, from the MSPEPSUM enumeration of ms_peptidesummary.
Returns:
cache file name
std::string getCacheFileName ( ) const

Returns the filename of the cache file.

If the cacheDirectory supplied to the ms_mascotresfile::ms_mascotresfile constructor is not empty, then a filename will be returned. This does not guarantee that the file exists, or is being used.

See also Caching Mascot Results.

Returns:
The filename for the cache file.
bool getComponentIntensity | ( | const int | q,
 |  | const int | p,
 |  | const std::string & | componentName,
 |  | double & | value,
 |  | double & | rawValue
 | ) |  | const [virtual]

Returns the component intensity for reporter or multiplex methods.

This function will only succeed for MS2 based quantitation methods such as "reporter" and "multiplex" where the required data is in the .dat file. It is up to the calling application to check that this is the case using ms_mascotresfile::getQuantitationMethod and ms_quant_method::getProtocol

This function was added in Mascot Parser 2.5. If the calling application is Using the ms_peptidesummary cache and the cache files were created with Mascot Parser 2.4 or earlier, then this function will calculate the intensities on demand. The first call to this function causes values for the whole file to be calculated, which may be slow. With new cache files, all the values are saved in the cache file.

This function will only calculate values for cases where ms_quant_helper::isPeptideQuantifiable returns ms_quant_helper::PEPTIDE_IS_QUANTIFIABLE

For a particular q,p pair there will always be values for all components or for no components. There can never be a case where there is just a value available for a subset of the components.

Parameters:
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue(). For "reporter" protocols, this must be 1.
componentName | is the name of the component as defined in the method. For example, for iTRAQ this might be "114", and for one of the SILAC methods this might be "Heavy".
[out] | value | is the corrected intensity value. Corrections are applied as specified in the method included in the results file.
[out] | rawValue | is the uncorrected intensity value.
Returns:
false if the method is unable to calculate or determine an intensity value for the specified q and p values

Implements ms_mascotresults.

const ms_protein * getComponentProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [virtual]

Return a pointer to the protein entry given an accession.

Only use this function for the "components" of a UniGene search. It will generally be more convenient for client applications to call ms_protein::getComponent() to get an ms_protein object, both in UniGene searches and PMF mixture searches.

Parameters:
accession | is the accession string.
dbIdx | a database index (1..ms_searchparams::getNumberOfDatabases()).
Returns:
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented from ms_mascotresults.

std::string getComponentString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual]

Return q1_p2_comp string value.

Note:
This function will always return the empty string for a protein summary.

The entry in the results file might be, for example:

   q1_p2_comp=light

For a crosslinked match, the results file line is q1_p1_comp_1= or q1_p1_comp_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

See also ms_peptide::getComponentStr().

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | is the 'rank' number, which should be in the range 1..10.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns:
the full component string for a peptide summary, and the empty string for a protein summary.

Implements ms_mascotresults.

bool getCreateSummaryProgress | ( | int * | cspTotalPercentComplete,
 |  | unsigned int * | cspCurrTask,
 |  | int * | cspCurrTaskPercentageComplete,
 |  | std::string * | cspAccession,
 |  | int * | cspHit,
 |  | int * | cspQuery,
 |  | std::string * | cspKeepAliveText
 | ) |  | const [inherited]

Return progress for the createSummary() call.

See Multiple return values in Perl, Java, Python and C#.

This function is most useful when using the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag and calling createSummary() from a separate thread. The ms_mascotresfile::outputKeepAlive() outputs progress text to stdout, and this may not be convenient for some applications.

Any of the passed parameters may be null.

Parameters:
[out] | cspTotalPercentComplete | is simply calculated from: 100 * cspCurrTask / ms_mascotresfile::KA_LAST + cspCurrTask / ms_mascotresfile::KA_LAST
[out] | cspCurrTask | is the ms_mascotresfile::KA_TASK currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and cspCurrTaskPercentageComplete will be 100
[out] | cspCurrTaskPercentageComplete | is the percentage (0..100) complete for the current cspCurrTask.
[out] | cspAccession | is the current 'accession' being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value. For languages other than C++, this will be a reference rather than a pointer to a std::string.
[out] | cspHit | is the current hit being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value
[out] | cspQuery | is the current 'query' being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value
[out] | cspKeepAliveText | is the text that would be output by ms_mascotresfile::outputKeepAlive(). To use this, specify a suitable keepAliveText to the ms_mascotresfile constructor but set keepAliveInterval to zero to prevent any output to stdout. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns:
true if the createSummary() call has completed.
const matrix_science::ms_crosslinking_method * getCrosslinkingMethod ( ) const

Returns the crosslinking method from the results file.

Returns:
The crosslinking method from the ms_mascotresfile object if any, otherwise 0.
std::vector< double > getDiscoveredErrTolModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const [virtual, inherited]

Return the deltas of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification deltas. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

The list of error tolerant modification deltas is most useful when used in combination with getNumDiscoveredErrTolMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredErrTolModNames()

Nucleic acid insertion, deletion and substitution whose special names are NA_INSERTION, NA_DELETION and NA_SUBSTITUTION have a delta of 0.0.

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns:
A vector of error tolerant modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< std::string > getDiscoveredErrTolModNames ( ) const [virtual, inherited]

Return the names of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification names. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted. Nucleic acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

The list of error tolerant modification names is most useful when used in combination with getNumDiscoveredErrTolMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
A vector of error tolerant modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< double > getDiscoveredLocalModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const [virtual, inherited]

Return the deltas of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredLocalModNames()

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns:
A vector of query-level modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< std::string > getDiscoveredLocalModNames ( ) const [virtual, inherited]

Return the names of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
A vector of query-level modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
double getErrTolModDelta | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL,
 |  | std::string * | deltaAsString = NULL
 | ) |  | const [virtual, inherited]

Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification delta will be 0.984020. In general, modification delta could be any valid floating point number, including 0.0.

See also:
getErrTolModName(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the delta directly
deltaAsString
Returns:
The modification delta.
std::vector< double > getErrTolModMasterNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p1_et_mods_master might be

   q1_p1_et_mods_master=1.0,2.0

The returned list will not contain the dominant neutral loss -- that can be retrieved using getErrTolModNeutralLoss().

See also:
getErrTolModSlaveNeutralLoss() and getErrTolModNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification additional primary neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModMasterString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod master neutral loss string from q1_p1_et_mods_master.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_master might be
       q1_p2_et_mods_master=1.0,2.0
  • The entry in h1_q2_et_mods_master might be
       h1_q2_et_mods_master=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModMasterNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant master neutral loss string.

Implements ms_mascotresults.

std::string getErrTolModName | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL
 | ) |  | const [virtual, inherited]

Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification name will be Citrullination.

See also:
getErrTolModDelta(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the name directly
Returns:
The modification name, or empty string if this match has no ET modification.
double getErrTolModNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than 10 of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods might be

   q1_p1_et_mods=79.966330,97.976898,Phospho (STY)

where the highest scoring modification neutral loss, returned by this function is 97.976898.

See also:
getErrTolModName(), getErrTolModDelta(), getReadableVarMods(), getErrTolModMasterNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification neutral loss value.
std::vector< double > getErrTolModPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Some modifications specify one or more peptide neutral losses. PepNeutralLoss allows a neutral loss from the precursor to be specified so that this peak is not treated as a noise peak when being scored by Mascot. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_pep might be

   q1_p1_et_mods_pep=97.976896, 79.966330
See also:
getErrTolModReqPepNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification peptide neutral loss values as a vector of doubles See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod peptide neutral loss string from q1_p1_et_mods_pep.

ms_mascotresults::getErrTolModPepString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
complete error tolerant peptide neutral loss string

Implements ms_mascotresults.

std::vector< double > getErrTolModReqPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Some modifications specify one or more required peptide neutral losses. ReqPepNeutralLoss performs the same function as PepNeutralLoss but with the additional condition that the peak must be present in the spectrum. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_reqpep might be

   q1_p1_et_mods_reqpep=97.976896, 79.966330
See also:
getErrTolModPepNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification required peptide neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModReqPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod required peptide neutral loss string from q1_p1_et_mods_reqpep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_reqpep might be
       q1_p2_et_mods_reqpep=1.0,2.0
  • The entry in h1_q2_et_mods_reqpep might be
       h1_q2_et_mods_reqpep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModReqPepNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant required peptide neutral loss string.

Implements ms_mascotresults.

std::vector< double > getErrTolModSlaveNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_slave might be

   q1_p2_et_mods_slave=1.0,2.0
See also:
getErrTolModMasterNeutralLoss(), getErrTolModNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification slave neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModSlaveString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod slave neutral loss string from q1_p1_et_mods_slave.

ms_mascotresults::getErrTolModSlaveString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
complete error tolerant slave neutral loss string

Implements ms_mascotresults.

std::string getErrTolModString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.

ms_mascotresults::getErrTolModString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
complete error tolerant modification string.

Implements ms_mascotresults.

double getErrTolProbabilityThreshold ( ) const [virtual, inherited]

Return the probability threshold used for error tolerant peptides.

For a protein summary, this method always returns the same value as getProbabilityThreshold().

Error tolerant matches in an integrated error tolerant search can have a different probability threshold (significance threshold) from first pass peptide matches. The first pass matches always use getProbabilityThreshold() as the significance threshold, and second pass matches always use getErrTolProbabilityThreshold().

The error tolerant significance threshold is determined using ms_mascotresults_params::getTargetFDR(). If a target FDR is specified and the search is an error tolerant target-decoy search, the probability threshold is chosen such that error tolerant matches have false discovery rate (FDR) equal to the target or as close as feasible. If the search is not a target-decoy search or target FDR is not specified, the error tolerant significance threshold is the same as the first pass significance threshold.

See also:
getProbabilityThreshold(), Error tolerant searches
Returns:
probability threshold for error tolerant matches.
unsigned int getFlags ( ) const [inline, inherited]

Returns the flags value passed to the constructor.

Returns:
the ms_mascotresults::FLAGS value.
unsigned int getFlags2 ( ) const [inline, inherited]

Return the flags2 value passed to the ms_peptidesummary constructor.

For an ms_proteinsummary, will always return 0 as there is no option to set the flags2 value.

Returns:
the ms_peptidesummary::MSPEPSUM value.
ms_protein * getHit | ( | const int | hit,
 |  | const int | memberNumber = 0
 | ) |  | const [virtual]

Return the ms_protein hit - returns null if hit > number of hits.

If MSPEPSUM_USE_CACHE is set, this function will load the hit results 'on demand'.

If MSRES_GROUP_PROTEINS is specifed when creating the ms_peptidesummary, then memberNumber should be set to 1 (or 0) and the 'main' hit is returned.

If MSRES_CLUSTER_PROTEINS is specifed when creating the ms_peptidesummary, then there may be multiple members for each family. See Using MSRES_CLUSTER_PROTEINS for more details.

Parameters:
hit | Must be in the range 1.. getNumberOfHits().
memberNumber | Should be 1 (or 0) for a protein not in a family or for the main protein in a hit family. It should be 2 or more for subsequent proteins in the family. If this number is greater than the number of proteins in the family then the function returns a null value.
Returns:
If the hit number is outside the range above, then this function will return a null value. See Maintaining object references: two rules of thumb.

Reimplemented from ms_mascotresults.

int getHomologyThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1
 | ) |  | const [virtual, inherited]

Returns the 'homology' threshold.

For MS-MS data only, this returns a threshold value for significant homology rather than identity. This value appears in the yellow popup box for an MS-MS result: Score greater than XX indicates homology.

The return value will be zero if the threshold is not available. The value cannot be determined if the query contains error tolerant matches, or if the query contains a tag or etag, or if the value of qmatch is less than or equal to 100.

The value returned will not be higher than the identity threshold.

In versions prior to 2.2, the homology threshold was not affected by OneInXprobRnd -- this was corrected in version 2.2.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. You can either pass ms_peptide::getRank() as the rank parameter, or use one of the enumerated values for HOMOLOGY_THRESHOLD_SOURCE. The rank determines the data source.

In an integrated spectral library search:

  • If rank = HOMTHR_FASTA, the method returns the FASTA homology threshold.
  • If the peptide at the given rank is from a FASTA database and is not a library match, the method returns the FASTA homology threshold.
  • If rank = HOMTHR_SL, the method returns zero (since library searches don't have a homology threshold).
  • If the peptide at the given rank is from a spectral library, the method returns zero.

In an integrated error tolerant search, behaviour depends on Mascot version. If the results file is from Mascot 2.8 or later:

  • If the query was selected for the second pass search, the method returns zero regardless of the rank argument.
  • If the query was only searched in the first pass, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().

If the integrated error tolerant search is from Mascot 2.7 or earlier:

  • If rank = HOMTHR_FASTA, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().
  • If the peptide at the given rank is a first pass match, the method returns the first pass homology threshold.
  • If the peptide at the given rank is an ET match, the method returns 0.
Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
Returns:
The homology threshold. If there was no MS-MS data for this query then 0 will be returned.
Examples:
resfile_summary.cpp.
int getHomologyThresholdForHistogram | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Returns the value for the 'yellow section' in the histogram.

For MS-MS data only, this returns a homology (rather than identity) threshold value that is shown at the top of the report: Individual ions scores > 19 indicate peptides with significant homology (p<0.05).

The yellow area on the histogram also corresponds to this value.

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot homology threshold. If dbType is DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The homology threshold. Note that this value is only available for an MS-MS search with just one MS-MS data set, otherwise the return value will be zero.
double getIonsScore | ( | const int | q,
 |  | const int | p,
 |  | const bool | decoy
 | ) |  | const [virtual]

Returns an ions score quickly without having to load an ms_peptide object.

If other values are required from the ms_peptide object, then it is normally faster to call getPeptide() and then ms_peptide::getIonsScore

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
decoy | is a flag to indicate if the score should be taken from the decoy section. This should only be set to true for searches with decoy matches.
Returns:
the score, or 0 if there was no score for these q / p values.

Implements ms_mascotresults.

double getIonsScoreCorrected | ( | const double | ionsScore,
 |  | const long | multiplicity
 | ) |  | const [protected, inherited]
Note:
It shouldn't be necessary to call this function from outside the library.

This function is required here rather than as part of the ms_peptide object because one ms_peptide object can be used from many different proteins -- each with a different multiplicity factor.

This function subtracts the factor:

  • -10 * log(multiplicity) * $tolFact / log(10); where
  • tolFact = sqrt(ITOL * ITOL + 0.0625);
Parameters:
ionsScore | Is the uncorrected ions score.
multiplicity | can be obtained from ms_protein::getPeptideMultiplicity.
Returns:
The corrected value..
std::vector< int > getIonsScoreHistogram | ( | IONS_HISTOGRAM | flags = IH_INCLUDE_TOP_MATCHES,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Returns a list of counts for binned ions scores.

  • The first element of the array returns the count of matches with a score between 0 and 1.
  • The second element of the array returns the count of matches with a score between 1 and 2.
  • The third element of the array returns the count of matches with a score between 2 and 3. etc. etc.
Parameters:
flags | Currently only IH_INCLUDE_TOP_MATCHES and IH_INCLUDE_TOP_10_MATCHES are supported.
dbType | If given, should be DM_FASTA for Mascot scores and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, empty vector is returned.)
Returns:
a vector of integers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
void getLibraryEntryId | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | dbIdx,
 |  | std::vector< int > & | offset,
 |  | std::vector< std::string > & | checksum,
 |  | std::vector< std::string > & | mods
 | ) |  | const

Return the database number, MSP file offset, checksum and modifications of the matched spectral library entry.

If the peptide match q,p is a spectral library match, this method returns the source database index, an offset into the MSP file that was searched, a checksum of the peak list of the library entry and the modifications in the library entry. Typically each of the dbIdx, offset and checksum vectors contains only one element -- the library entry that matched the query. However, under some circumstances Mascot may merge matches from different library entries or libraries in the same peptide match (for example, if it has same sequence, same mods and same score). In that case, the vectors may contain multiple elements, but each vector is guaranteed to have the same number of elements. Mascot 2.6 does not merge library matches.

The datatabase index, offset, checksum and mods can be used for looking up the correct library entry; see example code in ms_spectral_lib_file::findEntries(). Once the correct entry is found, you can access its attributes, peak list, etc. with the corresponding methods in ms_spectral_lib_entry.

Note that the library ID returned by MSPepSearch is not stored in the Mascot results file, as the NIST library compression tool can renumber library entries arbitrarily if the MSP file changes.

If q,p is not a spectral library match, the returned vectors are empty.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
q | query number of the spectral library match, in range 1..ms_mascotresfile::getNumQueries().
p | rank of the spectral library match, in range 1..getMaxRankValue().
dbIdx | returns a list of database indices.
offset | returns a list of integer offsets.
checksum | returns a list of peak list checksums.
mods | returns a list of the modifications for each entry. The format of the mods is as described in ms_spectral_lib_entry::getMods() and can be passed verbatim to ms_spectral_lib_file::findEntries().
std::string getLibraryModString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the modification string of the spectral library match from q1_p1_SLmod.

ms_mascotresults::getLibraryModString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
modification string of the match if it is a spectral library match and has modifications, an empty string otherwise.

Implements ms_mascotresults.

int getMaxPeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Return the max threshold value for all MS-MS data sets.

The maximum value is calculated by taking the maximum value returned by calling getPeptideIdentityThreshold() for each query. This is the value that is shown at the top of the standard Mascot peptide summary report (version 2.0 and later). For example, threshold in the following string could be calculated by calling getMaxPeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Versions of Mascot prior to 2.0 displayed the equivalent of getAvePeptideIdentityThreshold().

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The maximum score threshold. If there was no MS-MS data then -1 will be returned.
int getMaxRankValue ( ) const [virtual, inherited]

Returns the maximum 'rank' or 'hit' or 'p' value.

For functions such as getPeptide(), a 'rank' or 'hit' value is required. The allowable range for this values depends on whether it is a protein summary or peptide summary.

For a peptide summary the value returned will normally be 10, but for an integrated error tolerant search, integrated spectral library search and integrated crosslinked search, this can be in the range 1..20.

For a protein summary the return value will be ms_mascotresfile::getNumHits() -- with the appropriate parameter passed for the case of a decoy or error tolerant search.

Returns:
max rank value
int getMinPepLenInPepSummary ( ) const [inherited]

Peptides shorter than this are ignored when putting proteins into groups.

minPepLenInPepSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins together.

Specify this value when creating an ms_peptidesummary::ms_peptidesummary object. This value will always be zero for ms_proteinsummary.

Returns:
The minimum peptide length considered when creating the peptide summary.
double getMinProbabilityForSLScore ( double score ) [static]

Return the minProbability value that sets library score threshold to the given value in SL-only mode.

The significance threshold (minProbability parameter) that corresponds to the library score threshold score is calculated from the expect value formula:

 E(s) = 0.05 * 10 ** (-(s - 300)/100)

This method should only be used in SL-only mode (MSPEPSUM_SL_ONLY). In integrated mode (MSPEPSUM_SL_INTEGRATED), library score significance is calculated based on Mascot matches; see getPeptideExpectationValue().

Note that due to how library scores are converted to expect values, the maximum minProbability (1.0) corresponds to score 170. If you give a score less than 170 as argument, the function returns just a bit less than 1.0.

Parameters:
score Desired library score threshold. If it is not within the range (0, 1000), the function returns 0.05.
Returns:
Value for the minProbability parameter that sets library score threshold to score in SL-only mode.
ms_protein * getNextFamilyProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Find the next protein in the family masterHit.

Call this function multiple times for each masterHit, incrementing id each time. When there are no more protein families this function will return a null value.

The main protein for the hit should be obtained by calling ms_mascotresults::getHit()

See Using MSRES_CLUSTER_PROTEINS for further information.

See also:
ms_protein::GROUP
Parameters:
masterHit | is the id for the main hit (1..n).
id | is a 'one based' number.
Returns:
The next protein family or a null value if there is no such group. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
ms_protein * getNextSimilarProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP
Parameters:
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
Returns:
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
ms_protein * getNextSimilarProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP
Parameters:
masterAccession | is the accession for the main hit.
masterDB | is the database (FASTA) ID for the main hit.
id | is a 'one based' number.
Returns:
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
ms_protein * getNextSubsetProtein | ( | const int | masterHit,
 |  | const int | id,
 |  | const bool | searchWholeFamily = true
 | ) |  | const [virtual, inherited]

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP, getNextSubsetProteinOf()
Parameters:
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
searchWholeFamily | only has meaning when MSRES_CLUSTER_PROTEINS is specified. See Using MSRES_CLUSTER_PROTEINS.
Returns:
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
ms_protein * getNextSubsetProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information.

Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP, getNextSubsetProtein()
Parameters:
masterAccession | is the accession for the master hit or a family hit.
masterDB | is the database (fasta) ID for the main hit.
id | is a 'one based' number.
Returns:
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
std::vector< int > getNumberOfAccessionDBTypes | ( | int | q,
 |  | int | p
 | ) |  | const

Return a count of protein accessions by database type of all the accessions that contained the peptide match.

For the full list of data about protein accessions, see getAllProteinsWithThisPepMatch(). This method only counts the number of times each type of database (AA, NA, SL, SLREF) appears in the list of protein accessions.

Crosslinked searches only: in a crosslinked match, if alpha and beta are assigned to the same protein hit, the protein's database is counted twice.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | is the 'hit' or 'rank' number. For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) or an integrated spectral library search, this can be in the range 1 to 20.
Returns:
A vector of counts by database type. The vector has four elements, where the indices are AA (0), NA (1), SL (2) and SLREF (3).
std::vector< int > getNumberOfFamilyAccessionDBTypes | ( | int | hit,
 |  | int | q,
 |  | int | p,
 |  | bool | includeSamesets = true
 | ) |  | const

Return a count of protein accessions by database type of all the family members that contained the peptide match.

For the full list of data about family members, see getAllFamilyMembersWithThisPepMatch(). This method only counts the number of times each type of database (AA, NA, SL, SLREF) appears in the list of protein accessions.

What is counted: family members and optionally their samesets.

What is not counted: subset and intersection proteins and their samesets.

Parameters:
hit | Should be in the range 1.. getNumberOfHits().
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | is the 'hit' or 'rank' number. For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) or an integrated spectral library search, this can be in the range 1 to 20.
includeSamesets | If true (default), include samesets of family members in the counts. Otherwise count only lead proteins of family members.
Returns:
A vector of counts by database type. The vector has four elements, where the indices are AA (0), NA (1), SL (2) and SLREF (3).
int getNumberOfFamilyMembers ( ) const [virtual, inherited]

Return the total number of family members.

Returns:
This function returns the number of 'top level' hits and family members, not taking into account any proteins that are identical or subsets of these hits. The value will be identical to that returned by getNumberOfHits() unless the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag has been specified. In that case the number of values returned by getNextFamilyProtein() will be included.
int getNumberOfHits ( ) const [virtual, inherited]

Returns the number of hits in the results.

Returns:
This function returns the number of 'top level' hits -- not taking into account any proteins that are identical or subsets of the 'top level' hits. ms_mascotresults::getHit() can be called with any number from 1 to the value returned by this function.
int getNumberOfUnassigned ( ) const [inherited]

Return the number of peptides in the unassigned list.

See Unassigned peptides list for details of creating and using an unassigned list.

If there is no cache file for the results, then createUnassignedList() must be called before calling this function or the ms_mascotresfile::ERR_UNASSIGNED_PROG error will be set, and this function will return 0.

If a cache file has been created, then there is no requirement to call createUnassignedList() before calling this function.

Returns:
the number of peptides in the unassigned list, or 0 in the case of an error.
Examples:
resfile_summary.cpp.
long getNumDecoyHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits from the decoy search with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold(). These values may be slightly different from the threshold for the non-decoy matches.

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

y* The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of decoy hits with a score at or above the homology threshold.
long getNumDecoyHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits from the decoy search with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold(). This value may be slightly different from the threshold for the non-decoy matches.

For a protein summary, the number of hits is the number of protein matches. This number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of decoy hits with a score at or above the identity threshold.
std::vector< int > getNumDiscoveredErrTolMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of error tolerant modifications discovered in this search.

The number of times an error tolerant modification has been discovered in the search is the number of times it appears in rank 1 matches in the search results. Since the number and kind of error tolerant modifications is (practically) unlimited, you should call getDiscoveredErrTolModNames() first to find out which error tolerant modifications appear in the search. (The count of error tolerant modifications that do not appear in the search is, of course, zero.) Amino acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

Only significant rank 1 matches assigned to a protein hit are counted. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the error tolerant modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modName | Error tolerant modification name (as returned by getDiscoveredErrTolModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the error tolerant modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredFixedMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of fixed modifications discovered in this search.

The number of times a fixed modification has been discovered in the search is the number of times the terminus or residue matching its specificity appears in significant rank 1 matches assigned to a protein hit in the search results. For example, if Carbamidomethyl (C) is specified as a fixed modification, then the number of times it has been discovered in the search is the number of C residues in peptide sequences in significant rank 1 matches assigned to a protein hit.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the fixed modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a fixed modification with two different specificities in the search, discovery counts will be returned separately. For example, if fixed modification 1 is Carbamidomethyl (C) and 2 is Carbamidomethyl (N-term), then calling getNumDiscoveredFixedMods() with num = 1 returns the Carbamidomethyl count for specificity "Anywhere" and "C", while num = 2 returns the count for specificity "Any N-term" and "N-term". In both cases each vector contains a single item.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
num | Fixed modification number (same value as passed to ms_searchparams::getFixedModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the fixed modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredIntactLinks | ( | std::vector< int > & | varModNum1,
 |  | std::vector< std::string > & | position1,
 |  | std::vector< std::string > & | site1,
 |  | std::vector< int > & | varModNum2,
 |  | std::vector< std::string > & | position2,
 |  | std::vector< std::string > & | site2,
 |  | std::vector< int > & | numLinkedPeptides
 | ) |  | const [inherited]

Return the count of intact crosslinks in this search.

The number of times an intact crosslink has been discovered in the search is the number of times it appears as the intact link in significant rank 1 matches assigned to a protein hit.

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the link occurred, while varModNum1, position1 and site1 have the variable mod number, position and site of the first end of the link and varModNum2, position2 and site2 have the second end.

For example, if the ith specificity is N-terminal K, the ith element of alphaPositions would be "Any N-term" and the ith element of alphaSites would be "K".

In the simplest case, there is one linker with one specificity, say Xlink:DSS (K). All the vectors have just one element. If the linker has two specificities, like Xlink:DSS (K) and Xlink:DSS (Protein N-term), there will be three site pairs: (K, K), (K, Protein N-term) and (Protein N-term, Protein N-term). The pair (Protein N-term, K) is collated with (K, Protein N-term).

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
varModNum1 | Variable modification number for the first end of link.
position1 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site1 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
varModNum2 | Variable modification number for the second end of link.
position2 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site2 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
numLinkedPeptides | A vector containing the number of linked peptides corresponding to each count. Looplinked counts have 1 peptide, while crosslinked counts have 2 peptides.
Returns:
The number of times the intact link was observed in significant rank 1 matches assigned to a protein hit.
std::vector< int > getNumDiscoveredLibraryMods | ( | const int | modId,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [inherited]

Return the count of library modifications discovered in this search.

The number of times a library modification has been discovered in the search is the number of times it appears in the library mods string in significant rank 1 spectral library matches assigned to a protein hit in the search results.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the library modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that modifications are part of the metadata of spectral library entries. Unlike in database searches, they are not specified as part of the search parameters. Some caveats apply:

  • A library modification may have the same name as a variable or fixed modification in the database search, and they may well be the same modification -- but you need to know how the library was constructed to conclude either way.
  • Library modification name is usually a free-text string, which may or may not be a Unimod modification name.
  • The MSP format for spectral libraries does not support specifities in the same way as Mascot. The "position" of the modification is not encoded in the library and is thus unknown; it will always be Anywhere.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modId | modification ID, same as passed to ms_searchparams::getLibraryModName(). Must be in range 1..ms_searchparams::getNumberOfLibraryMods().
positions | A vector of positions, always "Anywhere".
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the library modification was observed in significant rank 1 spectral library matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredLocalMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of query-level modifications discovered in this search.

The number of times a query-level modification has been discovered in the search is the number of times it appears in significant rank 1 matches assigned to a protein hit in the search results.

Query-level modifications are counted separately from variable modifications (specified at search form level), because each individual query may contain up to 32 query-level variable modifications. This means the search as a whole may contain more than 32 different query-level modifications. You should call getDiscoveredLocalModNames() first to find out which query-level modifications appear in the search.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the query-level modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that only significant rank 1 matches assigned to a protein hit are counted.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modName | Query-level modification name (as returned by getDiscoveredLocalModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the query-level modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
int getNumDiscoveredNonSpecCleavage ( ) const [virtual, inherited]

Return the count of non-specific cleavages in an error tolerant search.

An error tolerant match is the product of non-specific cleavage when the residue before or after the peptide terminal residue does not match the cleavage specificity of the enzyme. For example, trypsin cleaves at C-term K or R (unless followed by P), so all tryptic peptide sequences have K or R as the (N-term) residue before the sequence. An error tolerant match with non-specific cleavage would have a residue other than K or R at N-terminus.

Only significant rank 1 matches assigned to a protein hit contribute towards the count of non-specific cleavages. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the match is not counted.

Returns:
The number of times non-specific cleavage occurred in significant rank 1 matches assigned to a protein hit, or -1 for non-error tolerant search.
std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites,
 |  | std::vector< double > & | deltas,
 |  | std::vector< std::string > & | names
 | ) |  | const [virtual, inherited]

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

The ith element in the deltas and names vectors defines the delta and name of the modification, respectively. If the search has no crosslinking method, these two parameters can be ignored. When the modification number num refers to a crosslinker, the the deltas and names vectors contain values for all monolinks represented by the entry.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
deltas | A vector of deltas.
names | A vector of names.
Returns:
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also:
getNumDiscoveredVariableMods(const int, std::vector<std::string>&, std::vector<std::string>&, std::vector<delta>&, std::vector<std::string>&) const
Parameters:
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
long getNumHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold().

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of hits with a score at or above the homology threshold.
long getNumHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold().

For a protein summary, the number of hits is the number of protein matches. The number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions make take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of hits with a score at or above the identity threshold.
std::vector< int > getPepsWithSameScore | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Returns a list of 'p' values for peptides with the same score.

Peptides with the same score will have the same pretty rank. See ms_peptide::getPrettyRank() for details.

It is preferable to call this function rather than to loop through all the ranks calling getPeptide() for each one because the cached index stores the pretty ranks and this should therefore be faster.

For a protein summary, the returned list always contains a single value that is the same as the passed p value.

Parameters:
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue().
Returns:
a list of the ranks that have the same pretty value. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Implements ms_mascotresults.

ms_peptide getPeptide | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return a peptide object for the specified query / rank.

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfile::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters:
q is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Returns:
an ms_peptide object.

Implements ms_mascotresults.

bool getPeptide | ( | const int | q,
 |  | const int | p,
 |  | ms_peptide *& | pep
 | ) |  | const [virtual]

Return a peptide object for the specified query / rank.

Note:
This function can not be used in programming languages other than C++.

To get the q and p values for a peptide in an ms_protein, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfile::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries()
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
pep | is reference to a pointer to an ms_peptide object that will be returned.
Returns:
true if the peptide exists.

Implements ms_mascotresults.

std::vector< int > getPeptideAmbiguityRanks | ( | const int | q,
 |  | const int | p
 | ) |  |

Return a vector of ranks that have the same ambiguity group.

Ambiguity group ids start at 1 Two peptides are in the same ambiguity group when either 1) they have the same query and same pretty rank 2) or they have the same query, same sequence and different search engine

Note: q and p have to be within limits, otherwise an empty vector is returned Additional note: these values are in the cache file only from ms_peptidesummary::BUGFIX_12538 Calling this method with an older cache may be considerably slower

Parameters:
q | query number
p | rank number
Returns:
A vector of ranks that have the same ambiguity group id.
double getPeptideExpectationValue | ( | const double | score,
 |  | const int | query,
 |  | const int | rank = 0
 | ) |  | const [virtual, inherited]

Returns the expectation value for the given peptide score and query.

Returns the number of peptides that you would expect to get this score or higher from this database. This value is displayed as the expectation value in Mascot 2.0 and later reports. When the value is below 1, it approximates the p-value corrected for multiple testing.

For Mascot matches, the expectation value is calculated from

    E = Pthreshold * (10 ** ((Sthreshold - score) / 10))

For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

The Sthreshold value is the value returned by getHomologyThreshold() if ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specifed in the ms_peptidesummary constructor, otherwise the value used is the one returned from getPeptideIdentityThreshold().

Parser 2.8 and later can calculate expectation values for Mascot error tolerant matches. The value is based on the combined first and second pass identity threshold. If rank is zero, getPeptideExpectationValue() assumes the score is a first pass match score and calculates the value from the first pass identity or homology threshold. If rank is non-zero, the correct threshold is chosen based on the match at rank rank in this query.

ET expectation value is only available if the results file is from Mascot 2.8 and later. When you open results from Mascot 2.7 and earlier, expectation value for ET matches is -1. Note that Parser 2.7 and earlier returned a non-negative but incorrect number for ET matches.

For spectral library matches, the expectation value formula depends on report mode.

  • In integrated mode (MSPEPSUM_SL_INTEGRATED), library scores are scaled internally so that their mean and standard deviation match the mean and standard deviation of significant rank 1 Mascot matches with the same sequence in the same query. See Library scores and thresholds.
  • In SL-only mode (MSPEPSUM_SL_ONLY), the expect value formula is
     E = 0.05 * 10 ** (-(s - 300)/100).
    For example, E = 0.05 for score 300.

Spectral library support was added in Mascot Parser 2.6. If rank is zero, which is the default in Parser 2.5 and earlier, the score is assumed to be a Mascot ions score. If rank is non-zero, the correct formula is chosen based on the type of the match at rank rank in this query.

See also:
getProteinExpectationValue()
Parameters:
score | is the Mascot score to be converted.
query | specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
rank | is the rank of the match of interest in this query.
Returns:
The number of peptides that you would expect to get this score or higher from this database, or -1 if it cannot be calculated.
int getPeptideIdentityThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Return the threshold value for this ms-ms data being a random match.

See also:
getAvePeptideIdentityThreshold()
Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType | If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
A score threshold. If query is < 1 or > ms_mascotresfile::getNumQueries() then -1 will be returned. If there was no MS-MS data or no match for this query, then -1 will be returned.
Examples:
peptide_list.cpp, and resfile_summary.cpp.
double getPeptideThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1,
 |  | const THRESHOLD_TYPE | thresholdType = TT_PEPSUM_DEFAULT
 | ) |  | const [inherited]

Return either the identity or the homology threshold.

The default is to use identity thresholds for the original Peptide Summary and Select Summary reports. For the Family Summary grouping, homology thresholds are used, and this needs to be specified by using the ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH flag. (This flag is automatically set when using the ms_mascotresfile::get_ms_mascotresults_params helper function).

This function calls getPeptideIdentityThreshold() or getHomologyThreshold() as appropriate. If it calls getHomologyThreshold() and this returns 0, then the identity threshold is returned.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. See getHomologyThreshold().

If the peptide match at rank rank is an ET match, and the results file is from Mascot Server 2.7 or earlier, then getPeptideIdentityThreshold() returns -1 and getPeptideThreshold() returns -1.

Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries()
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
thresholdType | can be any one of the ms_mascotresults::THRESHOLD_TYPE values
Returns:
the threshold.
double getProbabilityThreshold ( ) const [virtual, inherited]

Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.

In a protein summary, the probability threshold specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

In a peptide summary, the identity and homology thresholds of a peptide match are calculated from the probability threshold (significance threshold). This is the value of "Significance threshold p&lt;" shown in Mascot search reports.

getProbabilityThreshold() returns the currently active first pass significance threshold. The value may differ from the minProbability constructor argument if a target FDR has been specified. See ms_mascotresults_params::getTargetFDR().

If target FDR has not been specified, and if a value of <= 1e-18 or >= 1 is passed to the constructor, then a value of 1/20 (0.05) will be returned by this function. Otherwise it will just return the value passed to the ms_mascotresults::ms_mascotresults constructor.

In an error tolerant search, getProbabilityThreshold() may differ from the significance threshold used during the search, which was the basis for protein selection for the second pass. This is recorded as the first_pass_threshold= line in the results file header.

Error tolerant matches use an independent significance threshold, getErrTolProbabilityThreshold().

Returns:
probability threshold for peptide matches.
int getProbFromScore ( const double score ) const [virtual, inherited]

Returns a probability value given a score.

Warning:
Do not use this without fully understanding what the function returns. It is more likely that you will want to use getPeptideExpectationValue() or getProteinExpectationValue().
Parameters:
score is the Mascot score.
Returns:
probability calculated from p = pow(10.0, (score/10.0)).
double getProbOfPepBeingRandomMatch | ( | const double | score,
 |  | const int | query
 | ) |  | const [virtual, inherited]
Deprecated:
Use getPeptideExpectationValue().

Returns the inverse of getPeptideExpectationValue(). If, for example, the identity threshold (p<0.05) for a particular query is 30, and a value of 30 is passed to this function, then the return value will be 1/0.05. If, for the same search, a peptide of interest gets a score of 50, then this function will return a value of 1 / 0.00067 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getProbOfProteinBeingRandomMatch()
Parameters:
score | is the Mascot score
query | specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
Returns:
The probability.
Examples:
resfile_summary.cpp.
double getProbOfProteinBeingRandomMatch ( const double score ) const [virtual, inherited]
Deprecated:
Use getProteinExpectationValue().

Returns the inverse of getProteinExpectationValue(). If, for example, the identity threshold (p<0.05) for a PMF search is 56, and a value of 56 is passed to this function, then the return value will be 1/0.05. If, for the same search, a protein of interest gets a score of 90, then this function will return a value of 1 / 0.000025 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getProbOfPepBeingRandomMatch()
Parameters:
score is the Mascot score to be converted.
Returns:
The inverse of getProteinExpectationValue().
const ms_protein * getProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [virtual]

Return a pointer to the protein entry given an accession.

Parameters:
accession is the accession string.
dbIdx is the database index (1..ms_searchparams::getNumberOfDatabases()).

  • For a PMF mixture in protein summary (see Peptide mass fingerprint mixtures), use the default value of 1 even if the component proteins are all from other databases.
Returns:
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented from ms_mascotresults.

std::string getProteinDescription | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [inherited]

Return protein description if available.

This method attempts to return the 'description line' for the given accession. The description line originated from the FASTA file that was searched. An empty string will be returned if the protein is not listed in the proteins section or the summary section of the results file.

Format in the proteins section is, for example:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search all, protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

The alternative way to get the description line is to call

     ms-getseq.exe [db] [accession] title

when nothing is returned by getProteinDescription(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

If the 'protein' is actually a UniGene entry, then the description line is taken by concatenating the Gene and the Title line for the relevant entry.

If the protein is a PMF mixture, then the description line will be of the format:

 * Mixture from proteins:"gi|1234","gi|5432","gi|9999"

If the protein comes from the reference database of a spectral library, then its description is not saved in the results file and this method returns the empty string. If the protein comes from the spectral library, it may or may not have a description, depending on how the library was created.

For a search against a decoy database, if the result is from the decoy section, then the description is prefixed with "Random sequence, was ", or if there is no description in the file, "Random sequence.". Depending on the configuration of the search, Random may also be Reversed or Shuffled.

Parameters:
accession | is the accession string.
dbIdx | database index used for the search.
Returns:
The description line or an empty string.
Examples:
resfile_summary.cpp.
double getProteinEmPAI | ( | const char * | accession,
 |  | const int | dbIdx = 1,
 |  | const int | length = -1
 | ) |  | const [virtual]

Return protein emPAI if available.

The Exponentially Modified Protein Abundance Index (emPAI) offers approximate, label-free, relative quantitation of the proteins in a mixture based on protein coverage by the peptide matches in a database search result. The key publication is

Ishihama, Y., et al.: Exponentially modified protein abundance index (emPAI) for estimation of absolute protein amount in proteomics by the number of sequenced peptides per protein (2005). Molecular & Cellular Proteomics 4:1265-1272.

The number of observed peptides is determined using the function ms_protein::getNumObservedForEmPAI().

Protein sequence length is needed for emPAI calculation. You have two options:

  1. Give the sequence length as an argument to this method. You will need to fetch it with e.g. ms-getseq.exe on the Mascot Server machine.
  2. Give no argument to the method. If the protein has a mass in the results file, the mass will be used to calculate an approximate sequence length.

If no sequence length is given and the protein has no mass in the results file, the method returns -1. If you know the mass of the protein but not its sequence length, you can use the following approximate formula:

length = floor(0.5 + mass / 111)

Here 111 Da is the average mass of an amino acid residue.

If ms_mascotresults::isEmPAIallowed() is false, this method returns -1.

Parameters:
accession | Protein accession.
dbIdx | Protein database index number.
length | Protein sequence length (optional). If the length is not given, protein mass from the results file will be used to approximate it. If protein mass is not available, the method returns -1.
Returns:
emPAI or -1, as described above.

Reimplemented from ms_mascotresults.

double getProteinExpectationValue ( const double score ) const [virtual, inherited]

Returns the expectation value for the given protein score.

Returns the number of proteins that you would expect to get this score or higher from random matches for this search. For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getPeptideExpectationValue()
Parameters:
score is the Mascot protein score to be converted.
Returns:
The expectation value.
double getProteinMass | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [inherited]

Return protein mass if available.

This method attempts to return the mass for the given accession. The protein mass is calculated during the Mascot search, and some, but not all, of these masses are saved in the results file. A value of zero will be returned if the protein is not listed in the proteins section or the summary section of the results file.

The format in the proteins section is, for example, for a protein of mass 79480.13 daltons:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search, all protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines and masses in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines and masses are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

If a mass of zero is returned by this function, then the alternative way to get the mass is to call

     ms-getseq.exe [db] [accession] seq

to get the sequence, and then call getSequenceMass(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

Parameters:
accession | is the accession string.
dbIdx | database number (1..ms_searchparams::getNumberOfDatabases()).
Returns:
The protein mass or 0.0.
Examples:
resfile_summary.cpp.
int getProteinScoreCutoff ( double OneInXprobRnd ) const [virtual]

Return the 'protein' score value for cutting off results. Different for peptide and protein summary.

The protein probability cutoff is calculated differently for a protein summary and a peptide summary.

  • For a peptide summary, we want to display any proteins that contain even one significant peptide, which means the threshold is the same as getAvePeptideIdentityThreshold().

    For MudPIT scoring, any protein with a score greater than zero must have one or more peptides above the homology threshold, so this function returns a value of 1.

  • For a protein summary, we simply use the protein score that corresponds to the threshold.
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns:
The protein score cutoff threshold.

Implements ms_mascotresults.

double getProteinScoreForHistogram ( const int num ) const [virtual, inherited]

Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.

The 'well known' green and red histogram at the top of the Mascot reports is created from the top 50 protein scores in the results. However, if the number of hits requested for a peptide or protein summary is 'AUTO' or is less than 50, then there won't be 50 hits in the ms_mascotresults object so it won't be possible to create the histogram.

This simple method can reliably be used to return the score for a hit number between 1 and 50, regardless of the number of entries in the protein or peptide summary. To create the histogram, it will be necessary to call this method 50 times - with num being 1..50.

In the rare case of there being less than 50 proteins in the results file, a value of -1 will be returned for values of num that have no protein hit. If a protein is rejected because it only has peptides shorter than minPepLenInPepSummary or because the MSRES_REQUIRE_BOLD_RED is set, then this protein will not be included in the list.

Parameters:
num Is a value in the range 1..50.
Returns:
The score.
std::string getProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | const bool | quotes = false
 | ) |  | [virtual]

Return a partial list of proteins that matched the same peptide.

The returned string is of the following form:

    1:Q9XZJ2  2:100K_RAT  3:AAF55150

The list is the hit number / accession of all proteins that matched the same peptide. There is no indication of which database the hit is from, but this can of course be determined by calling getHit().

In ms_peptidesummary, this is taken from the list of accessions on the q1_p1= line. The returned string only includes proteins that are in the current peptide summary. This means for example that if you choose to only see the top 5 hits, and this query/rank is for a peptide that occurs in protein 6, then protein number 6 will not appear in the resulting string.

In ms_proteinsummary, the string is also constructed from the list of accessions on the q1_h1= line. There's an additional check that the query number is the same, and that the peptide is the same string.

If you want a list of accession strings rather than a single concatenated string, use the function getAllProteinsWithThisPepMatch().

Parameters:
q is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' number (in ms_proteinsummary) or 'rank' number (in ms_proteinsummary).

  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence h must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
quotes specifies whether the accessions will be quoted, which should allow accesions with spaces and colons. If true, the string returned would then be

1:"Q9XZJ2" 2:"100K_RAT" 3:"AAF55150"
Returns:
list of proteins matching the peptide, as a string

Implements ms_mascotresults.

void getProteinTaxonomyIDs | ( | const char * | accession,
 |  | const int | dbIdx,
 |  | std::vector< int > & | gpt_ids,
 |  | std::vector< std::string > & | gpt_accessions
 | ) |  | const [inherited]

Return the taxonomy ID(s), if any, from the results file.

In Mascot 2.4.0 and later, taxonomy IDs are saved in the proteins section of the results files in the form:

   [DB::]"accession"_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

In Mascot 2.4.1 and later, taxonomy IDs are also saved in the summary section of the results files in the form:

   hN_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

For example, for a single database, with a single accession/taxonomy:

   "gi|209490801"_tax=87229

   h1=gi|209490801, ...
   h1_tax=87229

and for a multi-database search, with a single accession/taxonomy:

   02::"gi|209490801"_tax=87229

   h1_db=2
   h1=gi|209490801, ...
   h1_tax=87229

and for a single database, with multiple accession/taxonomy:

   "gi|182438931"_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

   h1=gi|182438931, ...
   h1_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

If none of the databases used for the search contain taxonomy information, then no _tax lines will be output.

If any of the databases used for the search contain taxonomy information, then a _tax line will be output for all relevant proteins. This is governed by the same rules that determine for which proteins to output the mass and description lines. If a protein has no taxonomy information (for example, the database has no taxonomy), -1 will be used as the taxonomy ID.

Therefore, to determine if taxonomy information is available in the results file, simply take any protein in the proteins section, and see if there is a corresponding _tax entry.

For most FASTA files, there is a single accession and taxonomy for each sequence entry. For the NCBInr database, identical sequences are only stored once, but there are multiple accession/description lines separated by a "Control-A" character. Each accession may have a different taxonomy. This function returns the list of taxonomy IDs and corresponding accessions. For the last example shown above, this function will return the arrays of IDs

  [455632, 649189, 455632, 649189]

and accessions

  ["gi|182438931", "gi|282872348", "gi|178467447", "gi|282574201"]

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
accession | is the primary accession
dbIdx | is the 1 based database ID
gpt_ids | the taxonomy IDs
gpt_accessions | the list of accessions
int getProteinThreshold ( double OneInXprobRnd ) const [virtual, inherited]

Return a threshold value for the protein summary report.

This is simply calculated by using:

   10.0 * log10(seqsAfterTax * OneInXprobRnd)

where seqsAfterTax is obtained from ms_mascotresfile::getNumSeqsAfterTax().

The threshold value is displayed at the top of the protein summary report: Protein scores greater than 72 are significant (p<0.05).

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns:
The protein threshold.
int getQmatch | ( | const int | query,
 |  | const ms_mascotresfile::section | sec
 | ) |  | const [virtual, inherited]

Return the number of peptides with masses that matched this query.

See also:
getQmatch(const int) const

If the value is greater than INT_MAX, then INT_MAX will be returned.

Parameters:
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
sec is the section number and can be one of:

  • ms_mascotresfile::SEC_SUMMARY
  • ms_mascotresfile::SEC_DECOYSUMMARY
  • ms_mascotresfile::SEC_ERRTOLSUMMARY
  • ms_mascotresfile::SEC_ERRTOLDECOYSUMMARY
  • ms_mascotresfile::SEC_LIBRARYSUMMARY
  • ms_mascotresfile::SEC_CROSSLINK_SUMMARY
Returns:
the number of peptides with masses that matched this query. If the specified sec doesn't exist, then 0 will be returned.
int getQmatch ( const int query ) const [virtual, inherited]

Return the number of peptides with masses that matched this query.

See also:
getPeptideIdentityThreshold()
getQmatch(const int, const ms_mascotresfile::section) const

If the value is greater than INT_MAX, then INT_MAX will be returned.

This function calls the getQmatch(query, section) function with the 'relevant' section which will normally be SEC_SUMMARY.

If the MSRES_DECOY flag was specified in the constructor, then the 'relevant' section will be SEC_DECOYSUMMARY. If the search is an error tolerant search, then the 'relevant' section will be SEC_ERRTOLPEPTIDES, and analogously for crosslinked searches (SEC_CROSSLINK_PEPTIDES).

However, to get the spectral library qmatch values, it is necessary to explicitly call: getQmatch(query, ms_mascotresfile::SEC_LIBRARYSUMMARY)

Parameters:
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
Returns:
the number of peptides with masses that matched this query
ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide | ( | const ms_peptide & | peptide,
 |  | matrix_science::ms_quant_component & | component,
 |  | const ms_quant_method * | method = NULL
 | ) |  | const [virtual]

Get the component in the quantitation method that matches the peptide.

If the component name has already been determined (see ms_peptide::getComponentStr()) then that component is retrieved from the method.

If the component name has not yet been determined for the peptide, each component in the method is checked in turn to determine if it is the correct component for the peptide (see ms_peptidesummary::isPeptideComponentMatch()). A component only matches the peptide if every modification group of the component matches the peptide.

This is only applicable if there is a quantitation method, the method uses the Precursor protocol and the method has components defined. If an error occurs then an error message is appended to the matrix_science::ms_mascotresfile and a matching status code is returned.

Parameters:
peptide | The peptide to find the component for.
component | This is set to the first matching component found, if any.
method | An optional parameter that overrides the quantitation method used to look for matching components. If no method is specified here then the method from the ms_mascotresfile is used.
Returns:
One of the return status codes in ms_mascotresults::QUANT_COMPONENT_STATUS.

Implements ms_mascotresults.

const matrix_science::ms_quant_method * getQuantMethod ( ) const

Returns the quantitation method from the results file.

Returns:
The quantitation method from the ms_mascotresfile object if any, otherwise 0.
std::string getQueryList | ( | QL_FLAG | flag,
 |  | bool | outputListOfQueries = true
 | ) |  |

Returns a list of query numbers that can be used for a repeat search.

The list returned by this function should be used as the querylist parameter in a repeat search in Mascot 2.3 or later.

Parameters:
flag | See the ms_peptidesummary::QL_FLAG definition for a description of the different values.
outputListOfQueries | is used to specify whether a comma separated list of values is returned, or an encoded short string that will be interpreted by nph-mascot. Setting this value to false is not supported in Mascot 2.3.
Returns:
A string that can be used for the querylist value when repeating a search.
std::string getReadableVarMods | ( | const int | q,
 |  | const int | p,
 |  | const int | numDecimalPlaces = 2,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual, inherited]

Return a 'human readable' string with the variable, summed and error tolerant mods.

This function creates a string of the form

2 Oxidation (M); Phosphorylation (ST)

It works by getting the variable mods string, e.g. 0110030, using ms_peptide::getVarModsStr(). It then converts the string to a human readable form. Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W.

This function will work whether or not there are variable and/or error tolerant mods, and can be called for either the peptide or the protein summary. Variable modification names are obtained using ms_searchparams::getVarModsName() and error tolerant modification names are found using ms_mascotresults::getErrTolModName(). Library modification names, in peptide summary, are found using ms_searchparams::getLibraryModName(). See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Error tolerant mods are shown with the delta in square brackets after the modification or substitution. For example:

   R->G [-99.08]

The delta is shown to numDecimalPlaces.

If the match is an intact crosslinked match, the returned string contains a short description of the linked sites and what they are linked with. For example:

   Xlink:DSS (K) in alpha crosslinked with Xlink:DSS (K) in beta

Use ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA as the psmComponent argument to inspect the alpha and beta mods separately. In this case, the intact linker is described like "intact Xlink:DSS (K)".

Summed mods, from ms_peptide::getSummedModsStr(), and query-level mods, from ms_peptide::getLocalModsStr(), are also included in the returned string.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10.
numDecimalPlaces | (optional) Used for the display of modification deltas.
psmComponent | (optional) Either ms_peptide::PSM_COMPLETE for the match as a whole, or ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA to get components of a crosslinked match.
Returns:
The formatted string.
Examples:
resfile_summary.cpp.
const ms_mascotresfile & getResfile ( ) const [inherited]

Return a reference to the resfile.

Returns:
A reference to the resfile given in the constructor.
ms_mascotresults_params getResultsParameters ( ) [inherited]

Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.

Returns:
An ms_mascotresults_params object containing the parameter and flag values used to generate the report.
double getSequenceMass ( const char * seq ) const [inherited]

Return the mass of a sequence (protein or peptide).

The sequence mass is calculated by summing the mass of each residue, using ms_searchparams::getResidueMass, and adding terminus masses using ms_searchparams::getCTermMass and ms_searchparams::getNTermMass.

The mass is therefore the 'Mr' (uncharged) mass, and is calculated using any static modifications.

Parameters:
seq is the protein sequence.
Returns:
The relative mass of the sequence.
double getSLThresholdFromMinProbability ( double minProbability ) [static]

Return the library score threshold in SL-only mode corresponding to the given value of minProbability.

This is the inverse of getMinProbabilityForSLScore(). Note that due to how library scores are converted to expect values, the minimum value returned by this function is 170, for minProbability >= 1.0.

Parameters:
minProbability between 0 (exclusive) and 1 (exclusive).
Returns:
score The library score threshold.
int getSrcRank | ( | int | q,
 |  | int | p
 | ) |  | const

Returns the 'source' rank for a given peptide match.

When ms_mascotresults::MSRES_INTEGRATED_ERR_TOL is specified for an integrated error tolerant search (see Integrated error tolerant search), the results from the ms_mascotresfile::SEC_PEPTIDES and ms_mascotresfile::SEC_ERRTOLPEPTIDES sections are combined at the query level, so there will be up to 20 matches for each query. ms_peptide::getRank() or ms_protein::getPeptideP() will therefore return a number in the range 1 to 20. This rank value can be used for any ms_peptidesummary function that requires a 'p' (rank) value. If you want to access data directly from the results file using functions like me_mascotresfile::getQuerySectionValueStr(), then you need to call this function and getSrcSection() to determine which entry to retrieve.

For any search other than an integrated error tolerant search, the return value from this function will be identical to the passed p value.

Parameters:
q | is the query number.
p | is the rank number.
Returns:
the rank number in the results file.
ms_mascotresfile::section getSrcSection | ( | int | q,
 |  | int | p
 | ) |  | const

Returns the 'source' section for a given peptide match.

This function returns the peptide section that the peptide, specified by q and p, is obtained from. It will be one of:

  • ms_mascotresfile::SEC_PEPTIDES
  • ms_mascotresfile::SEC_DECOYPEPTIDES
  • ms_mascotresfile::SEC_ERRTOLPEPTIDES
  • ms_mascotresfile::SEC_ERRTOLDECOYPEPTIDES
  • ms_mascotresfile::SEC_LIBRARYPEPTIDES
  • ms_mascotresfile::SEC_CROSSLINK_PEPTIDES

When ms_mascotresults::MSRES_INTEGRATED_ERR_TOL is specified for an integrated error tolerant search (see Integrated error tolerant search), the results from the ms_mascotresfile::SEC_PEPTIDES and ms_mascotresfile::SEC_ERRTOLPEPTIDES sections are combined at the query level, so there will be up to 20 matches for each query. ms_peptide::getRank() or ms_protein::getPeptideP() will therefore return a number in the range 1 to 20. This rank value can be used for any ms_peptidesummary function that requires a 'p' (rank) value. If you want to access data directly from the results file using functions like me_mascotresfile::getQuerySectionValueStr(), then you need to call this function and getSrcSection() to determine which entry to retrieve.

Parameters:
q | is the query number.
p | is the rank number.
Returns:
the section in the results file.
int getTagDeltaRangeEnd | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the second number from q1_p2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
the second number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

int getTagDeltaRangeStart | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the first number from q1_p2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
the first number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

int getTagEnd | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual, inherited]

Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagStart(), getTagSeries()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The residue end position of the tag.
Examples:
resfile_summary.cpp.
int getTagSeries | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual, inherited]

Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagStart(), getTagEnd()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The series that contained a match to the tag. Possible ion series numbers are
  • -1 means no matches for the tag
  • 0 "a" series (single charge)
  • 1 "a-NH3" series (single charge)
  • 2 "a" series (double charge)
  • 3 "b" series (single charge)
  • 4 "b-NH3" series (single charge)
  • 5 "b" series (double charge)
  • 6 "y" series (single charge)
  • 7 "y-NH3" series (single charge)
  • 8 "y" series (double charge)
  • 9 "c" series (single charge)
  • 10 "c" series (double charge)
  • 11 "x" series (single charge)
  • 12 "x" series (double charge)
  • 13 "z" series (single charge)
  • 14 "z" series (double charge)
  • 15 "a-H2O" series (single charge)
  • 16 "a-H2O" series (double charge)
  • 17 "b-H2O" series (single charge)
  • 18 "b-H2O" series (double charge)
  • 19 "y-H2O" series (single charge)
  • 20 "y-H2O" series (double charge)
  • 21 "a-NH3" series (double charge)
  • 22 "b-NH3" series (double charge)
  • 23 "y-NH3" series (double charge)
  • 25 "internal yb" series (single charge)
  • 26 "internal ya" series (single charge)
  • 27 "z+1" series (single charge)
  • 28 "z+1" series (double charge)
  • 29 high-enrgy "d" and "d'" series (single charge)
  • 31 high-enrgy "v" series (single charge)
  • 32 high-enrgy "w" and "w'" series (single charge)
  • 33 "z+2" series (single charge)
  • 34 "z+2" series (double charge)
Examples:
resfile_summary.cpp.
int getTagStart | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual, inherited]

Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagEnd(), getTagSeries()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The residue start position of the tag.
Examples:
resfile_summary.cpp.
std::string getTagString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete tag string from q1_p1_tag.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_tag might be
       q1_p2_tag=1:10:12:6,3:1:12:1,...
  • The entry in h1_q2_tag might be
       h1_q2_tag=1:10:12:6,3:1:12:1,...

This function returns the complete string value. Every group of four numbers between commas is tagNumber:startPos:endPos:series.

More useful functions are

  • ms_mascotresults::getTagStart(),
  • ms_mascotresults::getTagEnd() and
  • ms_mascotresults::getTagSeries(),

all of which will work for both the protein summary and the peptide summary.

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete tag string.

Implements ms_mascotresults.

std::string getTerminalResiduesString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual]

Return the complete terminal residue string from q1_p1_terms.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in the results file might be
       q1_p2_terms=-,A:K,I:-,-:Q,-:@,R:...
  • The entry in the results file might be
       h1_q2_terms=A,Q

This function returns the complete string value. More useful functions are ms_protein::getPeptideResidueBefore() and ms_protein::getPeptideResidueAfter(), which will work for both the protein summary and the peptide summary.

ms_peptidesummary only: For a crosslinked match, the results file line is q1_p1_terms_1= or q1_p1_terms_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns:
the full terminal residues string.

Implements ms_mascotresults.

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFRDAboveHomology(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.

For example, to find out which probability threshold gives 1% FDR above identity or homology threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the * minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveHomology() and getNumDecoyHitsAboveHomology().

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

Otherwise functionality is the same as getThresholdForFRDAboveIdentity(double, double*, double*, int*, int*).

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.

For example, to find out which probability threshold gives 1% FDR above identity threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveIdentity() and getNumDecoyHitsAboveIdentity().

The function returns a value that maximises the number of peptide-spectrum matches while giving an FDR below the targetFDR value. In some cases, it would be possible to get an FDR closer to the supplied targetFDR, but with fewer target matches.

For a large file, this function can take some time to return. Feedback can be obtained by using ms_mascotresfile::outputKeepAlive with the fd= tag.

This function was first introduced in version 2.4.0 and the method for calculating the value was changed between version 2.4.0 and 2.4.1.

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If this function returns false, there are several possibilities:

  • The function is being called for a ms_proteinsummary object
  • The supplied targetFDR is 0, or negative
  • It is not possible to get an FDR less than the targetFDR. In this case, the lowest possible FDR is given
  • The function is being called for an error tolerant search

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFRDAboveIdentity(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
double getToleranceInDalton | ( | bool & | needMass,
 |  | const double *const | pMass = NULL
 | ) |  | const [inherited]

Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.

Returns the tolerance of the result file in dalton.

Parameters:
needMass | Reference to a boolean to determine if the mass is needed to calculate the delta, namely when the tolerance unit is in % or ppm
pMass | Optional parameter to calculate the tolerance from the mass for % and ppm
Returns:
The tolerance in dalton
bool getTreeClusterNodes | ( | const int | hit,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | TREE_CLUSTER_METHOD | tcm = TCM_PAIRWISE_MAXIMUM,
 |  | double *** | reserved1 = 0,
 |  | unsigned int * | reserved2 = 0
 | ) |  | const [virtual]

Return distances and structure suitable for a dendrogram plot.

The 'distances' between each protein in the family are calculated using a tree clustering routine which, by default, implements pairwise maximum (or complete) linkage clustering. It is used for the dendrogram display in the reports introduced in Mascot 2.3.

The vectors returned by this function only contain values when MSRES_CLUSTER_PROTEINS has been specified and where there are at least two family members.

The code uses the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

A value of 0 returned in the left or right vector corresponds to the lead protein as returned by getHit(). To find the protein associated with a positive node value returned in the left or right vector, call getNextFamilyProtein() with the id value set to the value in the vector.

The distances passed to the cluster algorithm are calculated by determining which peptides need to be excluded to make one protein a subset of another. Each unique peptide sequence is considered in turn, and the distance is calculated by taking the maximum difference between the score and the value returned by getPeptideThreshold(). Additionally, where a query has matches to different peptides above threshold in each protein, the delta of the scores is added to the distance.

For details of how to use the left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
hit | is the hit number for the lead protein.
left | returns a vector of 'left' values.
right | returns a vector of 'right' values.
distance | returns a vector of 'distance' values.
tcm | is the method to be used. See documentation referenced above
reserved1 | is for Matrix Science use only
reserved2 | is for Matrix Science use only
Returns:
true unless the code causes an out of memory error.

Reimplemented from ms_mascotresults.

ms_peptide getUnassigned ( const int num ) const [inherited]

Need to call createUnassignedList() before calling this.

See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return an empty ms_peptide.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
Examples:
resfile_summary.cpp.
bool getUnassignedIsBold ( const int num ) const [inherited]

Returns true if the item indexed by num in the assigned list should be bold.

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return true.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return true.
bool getUnassignedShowCheckbox ( const int num ) const [inherited]

Returns true if the item indexed by num in the assigned list should have a check box next to it.

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return false.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
bool hasCrosslinkingMethod ( ) const

Returns true if the results file has a crosslinking method.

Returns:
True if there is crosslinking method, otherwise false.
bool hasQuantMethod ( ) const

Returns true if the results file has a quantitation method.

Returns:
True if there is quantitation method, otherwise false.
bool isDataCached ( BUGFIX_NUM bugNum ) const

Returns true if the cache file contains data relevant to the given bug number.

If caching is in use and the cache file exists, it may have been created with a previous version of Parser. Parser does not always recreate the cache file when new features are added, which means that if newer versions would save more data in the cache file, some of this data may need to be computed on the fly when using an old cache file.

If caching is in use and the cache file contains data relevant to bugNum, the method returns true. Otherwise it returns false. If caching is not in use, the method always returns true, as the data related to the given bug number will always be computed on the fly.

See also Caching Mascot Results.

Parameters:
bugNum Bug number of the relevant feature or bugfix.
Returns:
True if data related to the bug number is available in the cache file or if caching is not in use. False otherwise.
bool isEmPAIallowed ( ) const [inherited]

Return true if emPAI could be calculated using data in this results file.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns:
true if emPAI is allowed.
bool isNA ( ) const [inherited]

Returns TRUE for a search against a nucelic acid database.

There is no specific information in the results file for this. It is implemented by looking to see if there is a frame number that is non-zero in any result. If there are no matches to any query, then this method will return false and therefore may be wrong. (However, if there are no matches then it is unlikely that the outcome of this function is important!)

In versions prior to 2.3.01, this was determined by looking in protein matches. In version 2.3.01 and later, this is determined by looking in all peptide matches, regardless of score.

Returns:
True if the search was against a nucleic acid database.
bool isPeptideComponentMatch | ( | const ms_quant_component & | component,
 |  | const ms_peptide & | peptide
 | ) |  | const

Tests whether the peptide is a match for all the modifications of the quantitation component.

Test whether the peptide is a match for all modification groups in the component using isPeptideModificationMatch().

Parameters:
component | The component to check for a match to the peptide.
peptide | The peptide to check for a match to the component.
Returns:
True if all modification groups are matched, or there are no modification groups.
bool isPeptideModificationMatch | ( | const ms_quant_modgroup & | group,
 |  | const ms_peptide & | peptide
 | ) |  | const

Tests whether the peptide is a match for the quantitation modification group.

The peptide matches the modification group if, and only if, the peptide has each and every applicable variable modification within the group.

Whether the Mascot search is constrained or not makes no difference to the modification matching.

Modification groups have a mode that can be 'exclusive' or 'variable'. Each modification is tested in turn until one is found that does is not match, or they have all been checked.

Modifications within the group are only applicable if the peptide has the type of site specified (e.g. "n-term (k)". If the peptide has no sites specified by any of the individual modifications, then it will still match the group if the group is not required . If the group is required then a peptide that has none of the specified sites will not be a match.

An individual modification is matched if the peptide has the modification at every specified site (e.g. every R, the N-terminus) in the peptide string. If the peptide string contains the type of site specified but does not have the modification at that site then the peptide does not match the modification group.

Parameters:
group | The group the peptide is checked against.
peptide | The peptide to check for a match to the group.
Returns:
True if all modifications in the group are matched, and if required then at least one modification site was found.
bool isPeptideUnique | ( | const int | q,
 |  | const int | p,
 |  | const UNIQUE_PEP_RULES | rules = UPR_DEFAULT
 | ) |  | const [virtual]

Returns true if this peptide match is unique to one protein or one protein family.

Note:
This function currently returns false for ms_proteinsummary. This function is only likely to be useful for a peptide summary.

This function is used, for example, in quantitation to only report ratios for peptide sequences that are unique to one protein hit. This can be specified as part of a Mascot quantitation method; see ms_quant_quality::isUniquePepseq().

No attempt is made to collapse peptides that just differ by, for example, I or L.

The specified q and p values must be for a peptide that has a protein match in the current report, i.e. not in the unassigned list. The function searches all proteins and not just those in the current report. For example, if peptide 'ABCDEFK' appears in protein hit one and protein hit 100, then it will return false even if only the top 10 hits have been requested.

If grouping is not selected when creating the ms_peptidesummary, (i.e. neither ms_mascotresults::MSRES_GROUP_PROTEINS nor ms_mascotresults::MSRES_CLUSTER_PROTEINS), then it is likely that this function will return false for most peptides.

At version 2.3, this function did not have the optional third parameter and the default value was the same as using ms_mascotresults::UPR_WITHIN_FAMILY, which is not the default value in version 2.4 and later. At version 2.3, the function would therefore return true for all peptides with a score above the homology threshold when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the * range 1 to 50.
rules | should passed appropriate ms_mascotresults::UNIQUE_PEP_RULES flags to specify what rules are to be used for considerering when a peptide is unique.
Returns:
true if the peptide match is unique. Always false in ms_proteinsummary.
(const int, const int, const UNIQUE_PEP_RULES rules = UPR_DEFAULT) const

Implements ms_mascotresults.

const ms_mascotresfile & mascotresfile ( ) const

Return the attached results file.

Returns:
The ms_mascotresfile object passed in the constructor.
void setSubsetsThreshold ( const double scoreFraction ) [virtual, inherited]

Specifies which subset proteins should be reported.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A scoreFraction of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported. The flag MSRES_SHOW_SUBSETS must have been specified if a value > 0 is used, or no subsets will be shown.

See also:
getNextSubsetProtein(), getNextSubsetProteinOf()
Parameters:
scoreFraction is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-scoreFraction). The default value is 1.0.
bool willCreateCache | ( | const char * | resultsFileName,
 |  | const ms_mascotoptions & | opts,
 |  | const char * | unigeneIndexFile,
 |  | const char * | singleHit,
 |  | const char * | applicationName,
 |  | std::string & | resfileCacheFileName,
 |  | std::string & | peptideSummaryCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  | [static]

[Deprecated] Returns true if either cache file will be created when the ms_mascotresfile and ms_peptidesummary objects are created

Note:
This method is deprecated in favour of calling ms_mascotresfile::willCreateCache(const char*, const ms_mascotoptions&, const char *, std::string &, unsigned int&) then populating a ms_mascotoptions object, a ms_mascotresults_params object, and calling willCreateCache(const ms_mascotresfile&, const ms_mascotresults_params&, const ms_mascotoptions&, std::string&, unsigned int&) All new code should use the new methods.

This static function can be called without creating an ms_mascotresfile or an ms_peptidesummary object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s). The function has the some of the same parameters as the ms_peptidesummary constructor, but takes a pointer to the options section of the mascot.dat file which will have the default parameters for reports.

The function may be more convenient than calling ms_mascotresfile::willCreateCache and then creating an ms_mascotresfile object and then calling the other willCreateCache

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters:
[in] | resultsFileName | is the absolute or relative path to the Fxxxxx.dat file
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[in] | unigeneIndexFile | See ms_peptidesummary::ms_peptidesummary
[in] | singleHit | See ms_peptidesummary::ms_peptidesummary
[in] | applicationName | is the name of the application or script that is calling this function. The applicationName is searched for in the return value from ms_mascotoptions::getResultsCache and ms_mascotoptions::getResfileCache to determine if the application should be using cache files. If it is not found then the function returns false and sets the cacheStatus to ms_peptidesummary::RESFILE_CACHE_DISABLED_IN_OPTIONS and/or ms_peptidesummary::PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS. If null, or an empty string is passed, no check is made.
[out] | resfileCacheFileName | returns the name of the ms_mascotresfile cache file if one exists or would be created
[out] | peptideSummaryCacheFileName | returns the name of the ms_peptidesummary cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns:
true if either of the cache files will be (re-)created because they does not exist or are not complete or not up to date. It will return false if the options specify that the applicationName shouldn't create or use cache files.
bool willCreateCache | ( | const ms_mascotresfile & | resfile,
 |  | const ms_mascotresults_params & | parameters,
 |  | const ms_mascotoptions & | opts,
 |  | std::string & | peptideSummaryCacheFileName,
 |  | unsigned int & | cacheStatus
 | ) |  | [static]

Returns true if either cache file will be created when the ms_mascotresfile and ms_peptidesummary objects are created.

This static function can be called without creating an ms_peptidesummary object. It can be used in advance of creating the object to see if there will be a delay while (re)creating the cache file(s).

The purpose of this method is to be able to provide a ms_mascotresults_params object as well as to get the status of the cache.

See Multiple return values in Perl, Java, Python and C#

See Static functions in Perl, Java, Python and C#

Parameters:
[in] | resfile | -- see ms_peptidesummary::ms_peptidesummary
[in] | parameters | -- see ms_peptidesummary::ms_peptidesummary
[in] | opts | normally loaded from the mascot.dat file using ms_datfile::getMascotOptions()
[out] | peptideSummaryCacheFileName | returns the name of the ms_peptidesummary cache file if one exists or would be created
[out] | cacheStatus | is the ms_peptidesummary::CACHE_STATUS enumeration which gives more details about why the cache file may or may not be created. Multiple values may be bitwise OR'd toegether.
Returns:
true if the ms_peptidesummary cache file will be (re-)created because it does not exist or is not complete or not up to date.
bool willCreateCache | ( | const ms_mascotresfile & | resfile,
 |  | const unsigned int | flags = MSRES_GROUP_PROTEINS,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | double | ignoreIonsScoreBelow = 0.0,
 |  | int | minPepLenInPepSummary = 0,
 |  | const char * | singleHit = 0,
 |  | const unsigned int | flags2 = MSPEPSUM_NONE
 | ) |  | [static]

[Deprecated] Returns true if a cache file will be created when the ms_peptidesummary constructor is called.

Note:
This method is deprecated in favour of willCreateCache(const ms_mascotresfile&, const ms_mascotresults_params&). All new code should use the new method.

This static function can be called without creating an ms_peptidesummary object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the exact same parameters as the ms_peptidesummary constructor -- see the documentation for ms_peptidesummary::ms_peptidesummary for details.

Parameters:
resfile | -- see ms_peptidesummary::ms_peptidesummary
flags | -- see ms_peptidesummary::ms_peptidesummary
minProbability | -- see ms_peptidesummary::ms_peptidesummary
maxHitsToReport | -- see ms_peptidesummary::ms_peptidesummary
unigeneIndexFile | -- see ms_peptidesummary::ms_peptidesummary
ignoreIonsScoreBelow | -- see ms_peptidesummary::ms_peptidesummary
minPepLenInPepSummary | -- see ms_peptidesummary::ms_peptidesummary
singleHit | -- see ms_peptidesummary::ms_peptidesummary
flags2 | -- see ms_peptidesummary::ms_peptidesummary
Returns:
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the MSPEPSUM_USE_CACHE flag has not been specified, it will always return false.
bool willCreateCache | ( | const ms_mascotresfile & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  | [static]

Returns true if a cache file will be created when the ms_peptidesummary constructor is called.

This static function can be called without creating an ms_peptidesummary object, and can be used in advance of creating an object to see if there will be a delay while (re)creating a cache file. The function has the exact same parameters as the ms_peptidesummary constructor -- see the documentation for ms_peptidesummary::ms_peptidesummary for details.

Parameters:
resfile | -- see ms_peptidesummary::ms_peptidesummary
parameters | -- see ms_peptidesummary::ms_peptidesummary
Returns:
true if the cache file will be (re-)created because it does not exist or is not complete or not up to date. If the MSPEPSUM_USE_CACHE flag has not been specified, it will always return false.
The documentation for this class was generated from the following files:
  • ms_mascotrespeptidesum.hpp
  • ms_mascotrespeptidesum.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_protein
Public Types | Public Member Functions | Friends

ms_protein Class Reference
[Mascot results file module]

This class encapsulates a protein in the mascot results file. More...

#include <ms_mascotresprotein.hpp>

Collaboration diagram for ms_protein:
[legend]

List of all members.

Public Types

enum DISTINCT_PEPTIDE_FLAGS {
DPF_SEQUENCE = 0x0001,
DPF_CHARGE = 0x0002,
DPF_MODS = 0x0004,
DPF_UNIQUE = 0x0008,
DPF_NODUPSAMEQUERY = 0x0010
}

Enum for getNumDistinctPeptides().

More...
enum DUPLICATE {
DUPE_NotDuplicate,
DUPE_Duplicate,
DUPE_DuplicateSameQuery,
DUPE_HighestScoringDuplicate,
DUPE_Ignored
}

Enum for the each peptide in the protein to indicate if it is a duplicate.

More...
enum GROUP {
GROUP_UNKNOWN,
GROUP_NO,
GROUP_SUBSET,
GROUP_COMPLETE,
GROUP_FAMILY
}

Enum to say if a protein is similar to another higher scoring protein.

More...
enum MASS_FLAGS {
MASS_NON_SELECT_NON_MATCH = 0x0001,
MASS_SELECT_NON_MATCH = 0x0010,
MASS_NON_SELECT_MATCH = 0x0100,
MASS_SELECT_MATCH = 0x1000
}

enum for each protein to specify what masses to select.

More...

Public Member Functions

ms_protein (const double score, const std::string accession, const bool updateScoreFromPepScores, const int proteinSummaryHit=0)
Constructors - used from ms_proteinsummary and ms_peptidesummary.
ms_protein (const ms_protein &src)
Copying constructor.
~ms_protein ()
Destructor - called automatically - don't call explicitly from Perl or Java.
bool | anyBoldRedPeptides (const ms_mascotresults &results) const
Returns true if any of the peptides in the match were top scoring and not seen before.
bool | anyMatchToQuery (const int query) const
See if any match to this query.
bool | anyMatchToQueryAndP (const int query, const int P) const
See if any match to this query and 'P' (rank / hit).
void | copyFrom (const ms_protein *src)
Copies all content from another instance of the class.
std::string | getAccession () const
Return the accession string for a protein.
const ms_protein * | getComponent (const int componentNumber) const
For UniGene and PMF mixture return the 'component' protein.
long | getCoverage () const
Return the number of residues covered.
int | getDB () const
Return the index of the database where the sequence is found.
ms_peptide | getDistinctPeptide (int distinctIndex, int repeatIndex=1, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const
Return the peptide repeat of the distinct peptide in the protein's peptide matches.
int | getFrame () const
Returns the frame number for the protein.
GROUP | getGrouping () const
Returns a flag which shows if this protein only contain the same peptides as those in another protein.
int | getHitNumber () const
Returns the hit number in the results list.
void | getIgnoredQPs (std::vector< int > &q, std::vector< int > &p) const
Return a list of queries and ranks that would have been part of this protein hit had they not been removed by IgnoreIonsScoreBelow.
int | getLongestPeptideLen () const
Return the length (in residues) of the longest peptide in the protein.
int | getLongestSigPeptideLen () const
Return the length (in residues) of the longest significant peptide in the protein.
std::string | getMasses (ms_mascotresfile &resfile, const ms_proteinsummary &summary, const unsigned int flags=MASS_SELECT_MATCH, const int numDecimalPlaces=2) const
Return a list of comma separated experimental masses according to a specified filter.
int | getMemberNumber () const
Returns the member number within a family in the results list.
double | getNonMudpitScore () const
Will only return a different score from getScore() if the MSRES_MUDPIT_PROTEIN_SCORE flag has been specified.
int | getNumComponents () const
For UniGene and PMF mixture, return number of 'component' proteins.
int | getNumDisplayPeptides (bool aboveThreshold=false) const
Return the number of peptides excluding those that with duplicate matches to same query.
int | getNumDistinctPeptideRepeats (int distinctIndex, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const
Return the number of repeats of the distinct peptide in the protein's peptide matches.
int | getNumDistinctPeptides (bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const
Return the number of distinct peptides in the protein sequence.
int | getNumObservedForEmPAI () const
Return the number of peptides 'observed' for emPAI quantitation calculation.
int | getNumPeptides () const
Return the number of peptides that had a match in this protein.
int | getPepNumber (const int q, const int p) const
Return the pepNumber given query and rank.
int | getPeptideComponentID (const int pepNumber) const
Returns 0 except for a UniGene entry or a PMF mixture entry.
DUPLICATE | getPeptideDuplicate (const int pepNumber, const bool allowErrTolDuplicate=true) const
Return the DUPLICATE status given the peptide 'number'.
long | getPeptideEnd (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the peptide end residue given the peptide 'number'.
int | getPeptideFrame (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the frame number given the peptide 'number'.
double | getPeptideIonsScore (const int pepNumber) const
Return the ions score within this protein context given the peptide 'number'.
bool | getPeptideIsBold (const int pepNumber) const
Returns true if this peptide should be displayed in bold in a Mascot report.
long | getPeptideMultiplicity (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the number of precursor matches in this protein for the specified peptide 'number'.
int | getPeptideP (const int pepNumber) const
Return the 'rank' number given the peptide 'number'.
int | getPeptideQuery (const int pepNumber) const
Return the query number given the peptide 'number'.
char | getPeptideResidueAfter (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Returns the residue immediately after the peptide.
char | getPeptideResidueBefore (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Returns the residue immediately before the peptide.
bool | getPeptideShowCheckbox (const int pepNumber) const
Returns true if a check box for repeat searches should be shown in a Mascot report.
long | getPeptideStart (const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the peptide start residue given the peptide 'number'.
int | getProteinSummaryHit () const
For a protein from the protein summary only.
double | getRMSDeltas (const ms_mascotresults &results) const
Return the RMS value of the deltas between the calculated and experimental value.
double | getScore () const
Return the protein score for this protein.
double | getScoreWithET () const
Return the protein score including ET matches for this protein.
int | getSimilarProteinDB () const
Return the database index of a protein that contains the same set (or a superset of) of the peptides in this protein.
std::string | getSimilarProteinName () const
Return the accession of a protein that contains the same set (or a superset of) of the peptides in this protein.
int | getSimilarProteins (std::vector< std::string > &accessions, std::vector< int > &dbIdxs) const
Return a list of proteins that that contains the same set (or a superset of) of the peptides in this protein.
std::string | getUnmatchedMasses (ms_mascotresfile &resfile, const int numDecimalPlaces=2) const
Return a list of comma separated experimental masses that don't match.
bool | isASimilarProtein (const ms_protein *prot, const ms_mascotresults *results, const bool groupByQueryNumber=false)
Find a protein in the results.
bool | isPMFMixture () const
Returns true if the 'protein' is actually a PMF mixture.
bool | isSimilarProtein (const std::string &acc, const int dbIdx) const
Returns true if the specified protein has the sameset or a superset of peptides that this protein has.
bool | isUnigene () const
Returns true if the 'protein' is actually a UniGene entry.
ms_protein & | operator= (const ms_protein &right)
C++ assignment operator.
void | setDB (int dbIdx)
Set database index.
void | setPeptideIsBold (const int pepNumber)
void | setPeptideShowCheckbox (const int pepNumber)
void | sortPeptides (const ms_mascotresults &results, bool keepAlive=false, int keepAlivePercent=0, const char *keepAliveAccession="", int keepAliveCount=0)
Sorts the peptides into ascending query number.

Friends

bool | operator< (const ms_protein &lhs, const ms_protein &rhs)
Protein objects perform a simple sort of themselves by database ID and then accession.

Detailed Description

This class encapsulates a protein in the mascot results file.

Pointers to ms_protein objects are returned from ms_peptidesummary::getHit() or ms_proteinsummary::getHit(), so there should be no need to create one of these from outside the library.

Examples:

peptide_list.cpp, repeat_search.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum DISTINCT_PEPTIDE_FLAGS

Enum for getNumDistinctPeptides().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

There are several possible defintions for 'distinct'!

One of more of these flags can be combined using a bitwise 'OR' operator to determine which peptide matches are treated as distinct matches when counting up matches. Imagine a protein that has the following matches

  • AGCMK - Charge state 2
  • AGCMK - Charge state 3
  • AGCMK - Charge state 2, Oxidised methionine
  • HSMTMR - Charge state 2
  • HSMTMR - Charge state 2
  • HSMTMR - Charge state 2, Oxidised methionine

In this case:

  • If DPF_SEQUENCE is specified, getNumDistinctPeptides() will return 2.
  • If DPF_SEQUENCE .OR. DPF_CHARGE is specified, getNumDistinctPeptides() will return 3.
  • If DPF_SEQUENCE .OR. DPF_MODS is specified, getNumDistinctPeptides() will return 4.
  • If DPF_SEQUENCE .OR. DPF_CHARGE .OR. DPF_MODS is specified, getNumDistinctPeptides() will return 5.

For completeness, getNumDisplayPeptides() will return a count of 6 and getNumPeptides() could return a count of 6 or could return 7 if HSM*TMR and HSMTM*R (where the asterisk indicates the oxidised methioine) both appear in the top 10 matches to the final query. (Some of these functions apply a threshold to the match scores, so this example assumes either no threshold is used or all matches are above threshold.)

A further complication is uniqueness within the whole database search. A peptide sequence that is distinct in one protein hit may also appear in another protein hit in the search. If you specify the flag DPF_UNIQUE, then only peptide matches that are unique within the whole search are counted, subject to the other flags. For example, if DPF_SEQUENCE .OR. DPF_UNIQUE is specified in the example above, then getNumDistinctPeptides() may return 0, 1 or 2, depending on which other protein hits contain the distinct peptide sequences assigned to the current protein hit.

The MCP guidelines require a count of "the total number of peptides assigned to the protein. To compute this number, multiple matches to peptides with the same primary sequence count as one, even if they represent different charge states or modification states". Specify DPF_SEQUENCE by itself to obtain this value.

A flags value that does not include DPF_SEQUENCE is unlikely to give a useful return value from getNumDistinctPeptides().

Enumerator:
DPF_SEQUENCE

Peptide matches must have different primary sequences to be counted as distinct matches.

DPF_CHARGE

Peptide matches must have different charge states to be counted as distinct matches.

DPF_MODS

Peptide matches must have different modification states to be counted as distinct matches.

DPF_UNIQUE

Peptide matches must be unique in the whole search to be counted as distinct matches.

DPF_NODUPSAMEQUERY

Duplicate peptide matches from the same query should be excluded (see DUPE_DuplicateSameQuery ).

enum DUPLICATE

Enum for the each peptide in the protein to indicate if it is a duplicate.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

A protein match is made up of one or more peptides. Duplicate peptides don't increase the coverage of the protein. They also do not increase the score except for MudPIT scoring.

Enumerator:
DUPE_NotDuplicate

There are no other peptides with the same sequence in this protein - from this query or other queries.

DUPE_Duplicate

Another peptide from a different query with the same sequence as this got a higher score.

DUPE_DuplicateSameQuery

Another match for the same query with the same peptide string got a higher score (different mods).

DUPE_HighestScoringDuplicate

There is at least one other peptide the same as this with a lower score.

DUPE_Ignored

The peptide match was ignored due to IgnoreIonsScoreBelow.

enum GROUP

Enum to say if a protein is similar to another higher scoring protein.

See Grouping proteins together and Using enumerated values and static const ints in Perl, Java, Python and C#.

Note that if there are say 3 proteins with the same 4 peptide matches, then the highest scoring protein will have GROUP_NO, and the other two will have GROUP_COMPLETE. Calling getSimilarProteinName() on the highest scoring protein will return an empty string. Calling it for the other two proteins will return the accession for the highest scoring protein.

See also:
ms_mascotresults::getNextSimilarProtein(), ms_mascotresults::getNextSubsetProteinOf()
Enumerator:
GROUP_UNKNOWN

No information about grouping.

GROUP_NO

Does not contain same set (or subset) of peptides as another proteins. A 'lead' protein.

GROUP_SUBSET

Contains a subset of peptides in one ore more other proteins.

GROUP_COMPLETE

Contains an identical set of peptides to one or more other proteins.

GROUP_FAMILY

Second or subsequent family member when using new family grouping introduced in Mascot 2.3.

enum MASS_FLAGS

enum for each protein to specify what masses to select.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Only a subset of all masses is used for scoring proteins. However, all matching masses are usually reported for each protein. Using these flags one can specify more precisely what sub-set of masses one is interested in. The flags can be combined with binary OR ("|"-operator in C++).

Enumerator:
MASS_NON_SELECT_NON_MATCH

Only masses that are not selected and couldn't match.

MASS_SELECT_NON_MATCH

Only masses that are selected but do not match.

MASS_NON_SELECT_MATCH

Only masses that are not selected but otherwise would match.

MASS_SELECT_MATCH

Only masses that are selected and do match.

Constructor & Destructor Documentation

ms_protein ( const ms_protein & src )

Copying constructor.

Calling this function ensures that all the data is loaded into memory in the case where ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE is specified.

Parameters:
src is the ms_protein object that will be copied.

Member Function Documentation

bool anyMatchToQuery ( const int query ) const

See if any match to this query.

This could be useful if you need to give a list of unmatched queries for a given protein.

Parameters:
query Query number
Returns:
true if any match was found, false otherwise
bool anyMatchToQueryAndP | ( | const int | query,
 |  | const int | P
 | ) |  | const

See if any match to this query and 'P' (rank / hit).

This is useful for finding if this protein matched an identical peptide to another protein.

Parameters:
query | query number
P | rank number
Returns:
true if any match was found, false otherwise
void copyFrom ( const ms_protein * src )

Copies all content from another instance of the class.

Calling this function ensures that all the data is loaded into memory in the case where ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE is specified.

Parameters:
src is a pointer to the source object
std::string getAccession ( ) const

Return the accession string for a protein.

This will always be available, for every protein.

Returns:
accession string of the protein
Examples:
resfile_summary.cpp.
const ms_protein * getComponent ( const int componentNumber ) const

For UniGene and PMF mixture return the 'component' protein.

For Unigene and PMF mixture, each 'protein' is made up of a number of components. Call this method to get the protein 'components' that were used to make up this 'pseudo' protein.

See Peptide mass fingerprint mixtures and Maintaining object references: two rules of thumb.

Parameters:
componentNumber must be in the range 1..getNumComponents(), or a null value will be returned. No error message is generated for an out of range call.
Returns:
A protein object if the componentNumber is valid, or a null value if there is an error.
long getCoverage ( ) const

Return the number of residues covered.

If two peptides overlap, then the overlapped ones are only counted once. Getting the coverage as a percentage is not possible from the results file because the length of the protein is not stored in the file. An approximate value could be calculated using ms_mascotresults::getProteinMass() and dividing by 110.

This function currently returns '0' for a PMF mixture and for a UniGene entry.

Returns:
coverage of the protein
Examples:
resfile_summary.cpp.
int getDB ( ) const

Return the index of the database where the sequence is found.

Use ms_searchparams::getDB() to retrieve the database name using the index returned by this function.

Returns:
A number in the range 1..ms_searchparams::getNumberOfDatabases(), except for a UniGene or protein mixture where the returned number will be zero.
Examples:
resfile_summary.cpp.
ms_peptide getDistinctPeptide | ( | int | distinctIndex,
 |  | int | repeatIndex = 1,
 |  | bool | aboveThreshold = false,
 |  | DISTINCT_PEPTIDE_FLAGS | flags = DPF_SEQUENCE
 | ) |  | const

Return the peptide repeat of the distinct peptide in the protein's peptide matches.

getNumDistinctPeptides() and getNumDistinctPeptideRepeats() indicate how many distinct peptides the protein has and how often they recur.

The individual ocurrences of the peptide are sorted by their ions scores in decreasing order. The first one (repeatIndex = 1) is the occurrence with the highest score.

When determining the valid ranges for the indexes, the same values should be passed for the aboveThreshold and flags parameters.

This can be used to retrieve the peptides to construct a tree as seen on the Mascot Search Results report or the Mascot Distiller protein tab.

To create a tree that matches the Mascot Search Results report, set aboveThreshold to false and use flags DPF_SEQUENCE, DPF_CHARGE, DPF_MODS and DPF_NODUPSAMEQUERY.

To create a tree that matches the Mascot Distiller protein tab, set aboveThreshold to false and use flags DPF_SEQUENCE, DPF_MODS and DPF_NODUPSAMEQUERY.

The distinct peptides are ordered into increasing molecular weight (see ms_peptide::getMrCalc()). The lowest Mr(calc) is the first peptide (distinctIndex = 1).

The repeats are ordered into decreasing score (see ms_peptide::getIonsScore()). The highest score is always the first repeat (repeatIndex = 1).

Parameters:
distinctIndex | Index into a list of distinct peptides, 1..getNumDistinctPeptides().
repeatIndex | Index into a list of repeats of the distinct peptide, 1..getNumDistinctPeptideRepeats(). Set this to 1 to get the primary (highest score) instance of the distinct peptide.
aboveThreshold | If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
flags | - see ms_protein::DISTINCT_PEPTIDE_FLAGS for details.
Returns:
The chosen repeat of the chosen distinct peptide.
int getFrame ( ) const

Returns the frame number for the protein.

A value of -1 will be returned if the peptides come from different frames. For a protein database, a value of zero will be returned. Frames 1 to 3 are the 'forward' strand, and 4 to 6 are the 'reverse' strand.

Returns:
frame of the protein
Examples:
resfile_summary.cpp.
ms_protein::GROUP getGrouping ( ) const

Returns a flag which shows if this protein only contain the same peptides as those in another protein.

See Grouping proteins together.

Returns:
The group flag.
int getHitNumber ( ) const

Returns the hit number in the results list.

For a protein that is a subset, the value returned is the hit number of the 'main' protein.

Returns:
hit number of the protein
void getIgnoredQPs | ( | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const

Return a list of queries and ranks that would have been part of this protein hit had they not been removed by IgnoreIonsScoreBelow.

Note that this method is only useful when the search is an integrated spectral library search, the results file has been opened in integrated library mode (ms_peptidesummary::MSPEPSUM_SL_INTEGRATED) and IgnoreIonsScoreBelow is set to a non-zero value.

When all the requirements are met, this method returns the queries and ranks (q,p) of the peptide matches removed due to IgnoreIonsScoreBelow but which would have been part of this protein hit otherwise. The q,p values are needed when iterating over all peptide matches assigned to this protein hit, because evidence for a peptide sequence can come from either search engine.

For example, suppose query 4339 has two matches to the same sequence: significant rank 1 match from the FASTA file and non-significant rank 2 match from the spectral library. Let the rank 1 match be in FASTA accession FAS1 and the rank 2 match in library accession LIB1. Since the matches have the same sequence, the rank 1 match provides evidence for it (it is significant) and the sequence is used in protein grouping. FAS1 and LIB1 end up in the same family, since they match the same significant sequence.

Suppose the rank 2 match is now hidden due to IgnoreIonsScoreBelow. Suppose further that FAS1 ends up as a subset of LIB1. If you iterate over the visible peptide matches of LIB1, query 4339 is nowhere to be seen, because it's hidden. But FAS1 might not appear anywhere either, since it's a subset protein. Query 4339 won't be in the unassigned list, because its rank 1 match was used as peptide evidence in protein grouping.

The only way to discover query 4339 is by iterating over the ignored matches in LIB1. There, query 4339 has the rank 2 match, and you can inspect the other ranks in the query to discover the rank 1 match.

See also:
Spectral libraries.
Parameters:
[out] | q | Vector in which the list of queries is returned.
[out] | p | Vector in which the list of ranks is returned.
int getLongestPeptideLen ( ) const

Return the length (in residues) of the longest peptide in the protein.

Returns:
The length of the longest peptide in the protein
int getLongestSigPeptideLen ( ) const

Return the length (in residues) of the longest significant peptide in the protein.

The threshold can be the identity or the homology threshold and is determined using ms_mascotresults::getPeptideThreshold()

Returns:
the length of the longest peptide with a score greater than the relevant threshold.
std::string getMasses | ( | ms_mascotresfile & | resfile,
 |  | const ms_proteinsummary & | summary,
 |  | const unsigned int | flags = MASS_SELECT_MATCH,
 |  | const int | numDecimalPlaces = 2
 | ) |  | const

Return a list of comma separated experimental masses according to a specified filter.

This is useful for selecting and displaying the list of observed mass values that satisfy the selection criteria. A number of different flag combinations can produce various sets of masses. An incomplete list of possible combinations follows:

  • peaks selected for scoring that match: MASS_SELECT_MATCH
  • peaks selected for scoring that don't match: MASS_SELECT_NON_MATCH
  • peaks not used for scoring that could match: MASS_NON_SELECT_MATCH
  • peaks not used for scoring that wouldn't match: NON_SEL_NON_MATCH
  • all peaks that could match: MASS_SELECT_MATCH | MASS_NON_SELECT_MATCH
  • all peaks that wouldn't match: MASS_NON_SELECT_NON_MATCH | MASS_SELECT_NON_MATCH

See Maintaining object references: two rules of thumb.

Parameters:
resfile | file object to extract information from.
summary | summary-object to extract information from.
flags | controls what masses should be returned (see ms_protein::MASS_FLAGS for the complete list of possible values).
numDecimalPlaces | number of decimal places for a formatted mass.
Returns:
string of concatenated observer masses separated by commas
int getMemberNumber ( ) const

Returns the member number within a family in the results list.

For a protein that is not in a family, the value returned is 0. For a 'main' protein in a family, the value returned is 1. For other members of a family, the value returned is 2 or more.

Returns:
member number of the protain
double getNonMudpitScore ( ) const

Will only return a different score from getScore() if the MSRES_MUDPIT_PROTEIN_SCORE flag has been specified.

For a protein summary, this will be the same as returned by getScore().

For a peptide summary, if the ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE has been specified as a flag when creating the ms_peptidesummary object, then the protein score will be calculated differently to offset some artifacts created when the number of spectra approaches the number of sequences in the database (e.g. for MudPIT data sets). See getScore() for details.

If the MUDPIT flag was specified, then the old score can be obtained using this function.

For a peptide summary where ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE was not specified, this function will return the same value as getScore().

Returns:
non mudpit score of the protein
int getNumComponents ( ) const

For UniGene and PMF mixture, return number of 'component' proteins.

For UniGene and PMF mixture, each 'protein' is made up of a number of components. Call this method to see how many 'components' were used to make up this 'pseudo' protein. Then call getComponent() to get each of the proteins in turn.

For a 'real' protein (i.e not a mixture or UniGene entry), this method will return zero.

See Peptide mass fingerprint mixtures.

Returns:
The number of components.
int getNumDisplayPeptides ( bool aboveThreshold = false ) const

Return the number of peptides excluding those that with duplicate matches to same query.

There can be multiple matches to a peptide from the same query; this will occur when there are matches with different mods or mods in different locations. In this case, it is normal to display them using the following loop:

 for (int i=1; i <= prot->getNumPeptides(); i++)
 {
   int query = prot->getPeptideQuery(i);
   int p     = prot->getPeptideP(i);

   if (p != -1
   && query != -1
   && prot->getPeptideDuplicate(i) != ms_protein::DUPE_DuplicateSameQuery)
   {
       // Display peptide match
   }
 }

For an error tolerant search, if the top match to a query is an error tolerant match, then the query does not contribute to the number of matches above the threshold even if the rank 2 match for the query is above the threshold.

Parameters:
aboveThreshold If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
Returns:
the number of peptides that would be displayed.
Examples:
resfile_summary.cpp.
int getNumDistinctPeptideRepeats | ( | int | distinctIndex,
 |  | bool | aboveThreshold = false,
 |  | DISTINCT_PEPTIDE_FLAGS | flags = DPF_SEQUENCE
 | ) |  | const

Return the number of repeats of the distinct peptide in the protein's peptide matches.

getNumDistinctPeptides() returns the number of distinct peptides (distinct as defined by the calling parameters). Each distinct peptide may occur more than once in the complete set of peptide matches for the protein.

This returns the number of times the distinct peptide occurs. The individual occurrences can then be accessed with getDistinctPeptide().

When determining the valid ranges for the index, the same values should be passed for the aboveThreshold and flags parameters.

Parameters:
distinctIndex | Index into a list of distinct peptides, 1..getNumDistinctPeptides()
aboveThreshold | If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
flags | - see ms_protein::DISTINCT_PEPTIDE_FLAGS for details.
Returns:
the count of the number of repeats of the chosen distinct peptide.
int getNumDistinctPeptides | ( | bool | aboveThreshold = false,
 |  | DISTINCT_PEPTIDE_FLAGS | flags = DPF_SEQUENCE
 | ) |  | const

Return the number of distinct peptides in the protein sequence.

Useful, for example, for MCP reports.

Parameters:
aboveThreshold | If true, the function will only count the number of peptides above the threshold. The threshold used will be ms_mascotresults::getPeptideIdentityThreshold() unless ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specified in the ms_peptidesummary constructor in which case the threshold is returned by ms_peptidesummary::getHomologyThreshold().
flags | - see ms_protein::DISTINCT_PEPTIDE_FLAGS for details.
Returns:
the count of the number of distinct peptides.
int getNumObservedForEmPAI ( ) const

Return the number of peptides 'observed' for emPAI quantitation calculation.

This function should not normally be called directly but is called by ms_mascotresults::getProteinEmPAI

The count of observed peptides only includes peptide matches with scores at or above the homology threshold, or the identity threshold, if there is no homology threshold. Ishihama et. al. obtained best proportionality for a standard protein mixture by counting unique parent ions, including different charge states from the same peptide sequence. This function counts the number of unique parent ions ignoring charge state, which produces better results when the number of charge states is large (e.g. 2+, 3+, 4+, 5+, 6+ and 7+). The differences are negligible when the data are only singly or doubly charged.

This function will still return a value even if ms_mascotresults::isEmPAIallowed() returns false.

If the protein contains any intact crosslinks, the emPAI assumptions are no longer valid, so the count of peptides returned is 0.

The value returned is stored in the cache file when Using the ms_peptidesummary cache

Returns:
the count of peptides used for the emPAI value. Will be 0 if no peptides are above the specified threshold
int getNumPeptides ( ) const

Return the number of peptides that had a match in this protein.

This includes peptides that are duplicates. See also getNumDisplayPeptides().

Returns:
number of peptides in the protein
Examples:
resfile_summary.cpp.
int getPepNumber | ( | const int | q,
 |  | const int | p
 | ) |  | const

Return the pepNumber given query and rank.

A matched protein contains a number of peptides. Further information about the peptide in the context of the protein can be obtained by calling getPeptideFrame(), getPeptideStart(), getPeptideEnd() etc. These functions all require a pepNumber, and this may be found using this function in cases where only q and p are readily available.

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p | is the 'rank' number. For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. See ms_peptidesummary::getMaxRankValue() and ms_proteinsummary::getMaxRankValue().
Returns:
pepNumber will be -1 if there is no matching peptide with these q and p values. Otherwise it will be in the range 1 to getNumPeptides().
int getPeptideComponentID ( const int pepNumber ) const

Returns 0 except for a UniGene entry or a PMF mixture entry.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

If this protein is really just a UniGene entry, or a PMF mixture entry then it is not a 'real' protein but just a container for a number of component proteins. In this case, each peptide originates from one of the components. The 'real' protein that corresponds to each component can be found using getComponent().

In the case of the same peptide being found in multiple components, the ID returned will be any one of these components.

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
Returns:
component id for the peptide whose index is passed
ms_protein::DUPLICATE getPeptideDuplicate | ( | const int | pepNumber,
 |  | const bool | allowErrTolDuplicate = true
 | ) |  | const

Return the DUPLICATE status given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, duplicate peptides could possibly be different for different proteins, so this value is not available in the ms_peptide object, but can be found in here in the protein object.

The allowErrTolDuplicate parameter controls duplicate checking behaviour in error tolerant searches. When true (default), the peptide pepNum is compared to all first pass and second pass (ET) matches. If the peptide is flagged as a duplicate, it may be a duplicate of a first or a second pass match.

When allowErrTolDuplicate is false, the peptide pepNum is only compared to first pass matches. This special case is used during protein inference.

Parameters:
pepNumber | must be in the range 1 to getNumPeptides().
allowErrTolDuplicate | is true by default. See above for behaviour when set to false.
Returns:
duplicate status for peptide whose index is passed in parameter
Examples:
resfile_summary.cpp.
long getPeptideEnd | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the peptide end residue given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, the same peptide sequence may occur in different places in different proteins, so the start and end residue information is not available in the ms_peptide object, but can be found in here using this function and getPeptideStart(). The returned number is 1 based.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide end or beta peptide end. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters:
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
end of the peptide whose index is passed in parameter
int getPeptideFrame | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the frame number given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, the same peptide sequence may occur in different frames in different proteins, so the frame information is not available in the ms_peptide object, but can be found in here in the protein object.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide frame or beta peptide frame. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters:
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
frame of the peptide whose index is passed in parameter
double getPeptideIonsScore ( const int pepNumber ) const

Return the ions score within this protein context given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, there are minor corrections to the score for each peptide depending on the protein that it is found in.

The Mascot results pages display the score returned from ms_peptide::getIonsScore() because results from similar proteins are displayed together. For ms_proteinsummary results, the return values from ms_peptide::getIonsScore() and ms_protein::getPeptideIonsScore() will be identical.

For an integrated error tolerant search where ms_mascotresults::MSRES_INTEGRATED_ERR_TOL is specified, the protein score is derived from the highest scoring non error tolerant match for each query, and this is the value returned by this function.

In an integrated spectral library search, if the peptide at pepNumber is a library match, the return values from ms_peptide::getIonsScore() and ms_protein::getPeptideIonsScore() will be identical. Library scores are not affected by multiplicity correction.

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
Returns:
the peptide ions score as used in the protein score.
bool getPeptideIsBold ( const int pepNumber ) const

Returns true if this peptide should be displayed in bold in a Mascot report.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See also ms_peptide::getFirstProtAppearedIn().

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
Returns:
whether the peptide whose index is passed in parameter is bold
Examples:
resfile_summary.cpp.
long getPeptideMultiplicity | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the number of precursor matches in this protein for the specified peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

The multiplicity value is the number of times that the precursor mass for the specified peptide got a match in this protein. With a tight tolerance and no variable modifications, this will normally be a small number. For a large protein, with no enzyme specificity and a large number of modifications (or an error tolerant search), this can be a large number.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide multiplicity or beta peptide multiplicity. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

This value is used internally for standard protein scoring and is not normally required outside Mascot Parser.

See also:
ms_mascotresults::getIonsScoreCorrected() and getScore() for details of how this value is used for protein scoring.
Parameters:
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
The number of matches to the precursor in this protein.
int getPeptideP ( const int pepNumber ) const

Return the 'rank' number given the peptide 'number'.

A matched protein contains a number of peptides. These peptides all originate from a 'query'. For peptide summary information, the top 10 scoring results are kept. This is the 'rank' number.

For protein summary information, 'P' refers to the protein hit number.

To get an ms_peptide object, call ms_mascotresults::getPeptide() using the return value from this function and the 'query' from ms_protein::getPeptideQuery().

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
Returns:
rank number for the peptide whose index is passed in parameter
Examples:
resfile_summary.cpp.
int getPeptideQuery ( const int pepNumber ) const

Return the query number given the peptide 'number'.

A matched protein contains a number of peptides. These peptides all originate from a 'query'. The query number is returned by this function.

To get an ms_peptide object, call ms_mascotresults::getPeptide() using the return value from this function and the 'p' value from ms_protein::getPeptideP().

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
Returns:
query number for the peptide whose index is passed in parameter
Examples:
resfile_summary.cpp.
char getPeptideResidueAfter | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Returns the residue immediately after the peptide.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

The residue before and after are only saved in the results files for Mascot 2.1 and later. For files created with earlier versions of Mascot, a '?' will be returned.

If the peptide is an C terminal peptide, then this function will return '-'.

If the search was against nucleic acid data and the peptide is just before a stop codon, then this function will return '@'.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide residue or beta peptide residue. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is '?'.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters:
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
residue after the peptide whose index is passed in parameter
char getPeptideResidueBefore | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Returns the residue immediately before the peptide.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

The residue before and after are only saved in the results files for Mascot 2.1 and later. For files created with earlier versions of Mascot, a '?' will be returned.

If the peptide is an N terminal peptide, then this function will return '-'.

If the search was against nucleic acid data and the peptide is just after a stop codon, then this function will return '@'.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide residue or beta peptide residue. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is '?'.

If the peptide match is not crosslinked, psmComponent is ignored.

Parameters:
pepNumber must be in the range 1 to getNumPeptides()
psmComponent is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
residue before the peptide whose index is passed in parameter
bool getPeptideShowCheckbox ( const int pepNumber ) const

Returns true if a check box for repeat searches should be shown in a Mascot report.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box.

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
Returns:
whether a check box is displayed the peptide whose index is passed in parameter
Examples:
resfile_summary.cpp.
long getPeptideStart | ( | const int | pepNumber,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const

Return the peptide start residue given the peptide 'number'.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

However, the same peptide sequence may occur in different places in different proteins, so the start and end residue information is not available in the ms_peptide object, but can be found in here using this function and getPeptideEnd(). The returned number is 1 based.

The psmComponent argument is only meaningful in a crosslinked search. If the peptide match has an intact crosslink, psmComponent specifies the type of data to return — alpha peptide start or beta peptide start. If alpha or beta is in a different protein, or if you pass PSM_COMPLETE, the return value is -1.

If the peptide match is not crosslinked, psmComponent is ignored.

A value of -1 is returned if there is an error.

Parameters:
pepNumber | must be in the range 1 to getNumPeptides().
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide.
Returns:
start of the peptide whose index is passed in parameter
int getProteinSummaryHit ( ) const

For a protein from the protein summary only.

There should be no real reason to use this method outside the library, apart from when determining a value to pass as the singleHit parameter when calling ms_proteinsummary::ms_proteinsummary().

If the protein came from the summary section (or mixture section) then this will return the hit number. For a protein that came from a ms_peptidesummary, this will return zero.

Used within the library for getting the sort order for a PMF the same as in the results file (only an issue for proteins with a similar score).

Returns:
hit number of the protein in the protein summary
double getRMSDeltas ( const ms_mascotresults & results ) const

Return the RMS value of the deltas between the calculated and experimental value.

The value is returned in ppm.

Parameters:
results reference to an ms_mascotresults object
Returns:
RMS value of all deltas in the protein
double getScore ( ) const

Return the protein score for this protein.

Two protein scoring algorithms are available: MudPIT scoring (recommended) and standard scoring. For a protein summary, only standard scoring is supported.

MudPIT Scoring (recommended)

If the flag ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE is specified, protein score is calculated by:

  Protein score = 0
  For each peptide match {
    If there is a homology threshold and ions score > homology threshold
    {
      Protein score += ions score - homology threshold
    } else if ions score > identity threshold {
      Protein score += ions score - identity threshold
    }
  }
  Protein score += 1 * average of all the subtracted thresholds

In spectral library searches (Parser 2.6 and later), the algorithm is the same but the score excess over threshold has a different form depending on library mode:

  • In SL-only mode, proteins contain only spectral library matches, so MudPIT score is calculated as above using the raw library scores and library score threshold.
  • In integrated library mode, proteins can contain a mixture of FASTA and library matches. Library scores are first converted to a score excess on the same scale as Mascot scores. (For a detailed discussion, see Advanced reading: calculating the spectral library score threshold.)

In versions prior to 2.2, the thresholds were not affected by the minProbability parameter of the ms_peptidesummary constructor; a default value of 1 in 20 was always used.

Standard Scoring

The standard protein score is the sum of ions scores for each match. For duplicate peptides, just the highest score is taken.

The standard score can be lower than the sum of the ions scores, particularly when the protein is large. This is because a correction is applied to compensate for the accumulation of random ions scores from random matches. The difference is more substantial when doing a no-enzyme search, because there are orders of magnitude more random matches. See the function ms_mascotresults::getIonsScoreCorrected() for details of how the correction is calculated. If the correction causes the ions score to become negative, then this ions score is ignored when calculating the protein score.

Note that the match score correction is only used with standard scoring. MudPIT scoring always uses the uncorrected score.

See also:
getNonMudpitScore(), ms_mascotoptions::getMudpitSwitch()
Returns:
score of the protein
Examples:
repeat_search.cpp, and resfile_summary.cpp.
double getScoreWithET ( ) const

Return the protein score including ET matches for this protein.

Returns the score of the protein including ET matches This is used mainly for Family grouping, to differentiate between between two otherwise identical proteins

Returns:
score of the protein including error tolerant matches
int getSimilarProteinDB ( ) const

Return the database index of a protein that contains the same set (or a superset of) of the peptides in this protein.

Deprecated:
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.

This function returns a single protein database ID. When using the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag, a subset protein may be a subset of more than one parent protein. To find the complete list of proteins that it is a subset of, call getSimilarProteins(). This function just returns the 'first' protein in the list of superset proteins. There will only be a multiple 'similar' proteins in cases where ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified and where this protein is a GROUP_SUBSET. There will only be a single 'similar' protein where this protein is GROUP_COMPLETE.

See Grouping proteins together, getGrouping() and getSimilarProteinName().

Returns:
the database ID for the sameset or superset protein.
std::string getSimilarProteinName ( ) const

Return the accession of a protein that contains the same set (or a superset of) of the peptides in this protein.

Deprecated:
Use ms_protein::getSimilarProteins(), ms_mascotresults::getNextSimilarProtein() or ms_mascotresults::getNextSimilarProteinOf() instead.

This function returns a single protein accession string. When using the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag, a subset protein may be a subset of more than one parent protein. To find the complete list of proteins that it is a subset of, call getSimilarProteins(). This function just returns the 'first' protein in the list of superset proteins. There will only be a multiple 'similar' proteins in cases where ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified and where this protein is a GROUP_SUBSET. There will only be a single 'similar' protein where this protein is GROUP_COMPLETE.

See Grouping proteins together, getGrouping() and getSimilarProteinDB().

Returns:
the accession for the sameset or superset protein.
int getSimilarProteins | ( | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIdxs
 | ) |  | const

Return a list of proteins that that contains the same set (or a superset of) of the peptides in this protein.

See Using MSRES_CLUSTER_PROTEINS.

Parameters:
accessions | Is the list of accessions for which this protein is a sameset or a subset. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIdxs | Is the corresponding list of databases for the accessions. This array will be the same size as the accessions array. For a search against a single database, all the IDs will be 1. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
The number of accessions and database IDs returned in the vectors.
std::string getUnmatchedMasses | ( | ms_mascotresfile & | resfile,
 |  | const int | numDecimalPlaces = 2
 | ) |  | const

Return a list of comma separated experimental masses that don't match.

This is useful for displaying the list of observed mass values that failed to get a match to a protein hit in a PMF (listed at end of each hit in a protein summary report).

Parameters:
resfile | reference to a ms_mascotresfile object
numDecimalPlaces | decimal precision
Returns:
string of concatenate observed masses separated by commas
bool isASimilarProtein | ( | const ms_protein * | prot,
 |  | const ms_mascotresults * | results,
 |  | const bool | groupByQueryNumber = false
 | ) |  |

Find a protein in the results.

Note:
This function should not need to be called from outside Mascot Parser.

The function looks to see if 'self' contains the same set or a subset of matching peptides as the passed 'prot'. If it does, then it sets its group to be GROUP_COMPLETE or GROUP_SUBSET and also sets the similar protein accession.

Parameters:
prot | Is the protein to compare.
results | Need to be passed for access to the peptide information.
groupByQueryNumber | Is used to determine whether peptide similarity is just by query number (for PMF) or by peptide string for MS-MS.
Returns:
TRUE if the proteins are similar.
bool isPMFMixture ( ) const

Returns true if the 'protein' is actually a PMF mixture.

To find out what 'component' proteins were used to get this entry, see getComponent() and Peptide mass fingerprint mixtures.

Returns:
true if the protein originates from a PMF mixture, false otherwise
void setDB ( int idx )

Set database index.

Parameters:
idx database index from 1 to ms_searchparams::getNumberOfDatabases().
void setPeptideIsBold ( const int pepNumber )
Note:
This function should normally only be used internally.

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

Parameters:
pepNumber must be in the range 1 to getNumPeptides().
void setPeptideShowCheckbox ( const int pepNumber )

A matched protein contains a number of peptides. Further information about the peptide can be obtained by getting an ms_peptide object using getPeptideQuery(), getPeptideP() and ms_mascotresults::getPeptide().

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box.

Parameters:
pepNumber must be in the range 1 to getNumPeptides().

Friends And Related Function Documentation

bool operator< | ( | const ms_protein & | lhs,
 |  | const ms_protein & | rhs
 | ) |  | [friend]

Protein objects perform a simple sort of themselves by database ID and then accession.

Note:
This method can only be used by C++ programs.

Final sorting for proteins by score and then accession is more complex.

Parameters:
lhs | left element to compare
rhs | right element to compare
The documentation for this class was generated from the following files:
  • ms_mascotresprotein.hpp
  • ms_mascotresprotein.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_proteinsummary
Public Types | Public Member Functions | Protected Member Functions

ms_proteinsummary Class Reference
[Mascot results file module]

#include <ms_mascotresproteinsum.hpp>

Inheritance diagram for ms_proteinsummary:
[legend]
Collaboration diagram for ms_proteinsummary:
[legend]

List of all members.

Public Types

enum DB_MATCH_TYPE {
DM_FASTA = 0,
DM_SPECTRAL_LIBRARY = 1,
DM_BOTH = 2,
DM_FASTA_FIRST_PASS = 3,
DM_FASTA_SECOND_PASS = 4
}

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

More...
enum DECOY_STATS_COUNT_TYPE {
DS_COUNT_PSM = 0,
DS_COUNT_SEQUENCE = 1
}

Type of object counted by getNumHitsAboveIdentity() and friends.

More...
enum FIND_COMPARE_FLAGS {
FC_COMPLETESTR = 0x00000001,
FC_SUBSTR = 0x00000002,
FC_STARTSTR = 0x00000003,
FC_STRTOK = 0x00000004,
FC_MASK_STR_PART = 0x0000000F,
FC_CASE_INSENSITIVE = 0x00000000,
FC_CASE_SENSITIVE = 0x00000010,
FC_MASK_CASE = 0x000000F0,
FC_FORWARD = 0x00000000,
FC_REVERSE = 0x00000100,
FC_MASK_DIRECTION = 0x00000F00,
FC_RESTRICT_TO_HIT = 0x00001000,
FC_LOOP_INTO_UNASSIGNED = 0x00002000,
FC_LOOP_FROM_UNASSIGNED = 0x00004000,
FC_UNASSIGNED_MASK = 0x00006000,
FC_SEARCH_ALL_RANKS = 0x00008000,
FC_ALL_PEPTIDES = 0x00000000,
FC_ALL_PEPTITDES = 0x00000000,
FC_SIGNIFICANT_PEPTIDES = 0x00010000,
FC_SEARCH_IGNORED_RANKS = 0x00020000,
FC_SCORING_MASK = 0x000F0000,
FC_PROTEIN_IGN_SAMESETS = 0x00100000,
FC_PROTEIN_IGN_SUBSETS = 0x00200000,
FC_PROTEIN_IGN_FAMILY = 0x00400000,
FC_PROTEIN_IGN_MASK = 0x00F00000,
FC_PROTEIN_INC_ALT_ACC = 0x01000000
}

Flags to specify how comparisons are performed in the find functions.

More...
enum FIND_FLAGS {
FT_PEPTIDE_EXP_MZ = 0x00000001,
FT_PEPTIDE_EXP_MR = 0x00000002,
FT_PEPTIDE_CALC_MZ = 0x00000004,
FT_PEPTIDE_CALC_MR = 0x00000008,
FT_PEPTIDE_STRING = 0x00000010,
FT_PEPTIDE_QUERY = 0x00000020,
FT_PEPTIDE_VARMOD = 0x00000040,
FT_PEPTIDE_FIXMOD = 0x00000080,
FT_PEPTIDE_ETMOD = 0x00000100,
FT_PEPTIDE_SLMOD = 0x00000200,
FT_PEPTIDE_VARMOD_BYNAME = 0x00000400,
FT_PEPTIDE_FIND_MASK = 0x00000FFF,
FT_PROTEIN_ACCESSION = 0x00001000,
FT_PROTEIN_DESCRIPTION = 0x00002000
}

Flags for findPeptides() and findProteins().

More...
enum FLAGS {
MSRES_NOFLAG = 0x00000000,
MSRES_GROUP_PROTEINS = 0x00000001,
MSRES_SHOW_SUBSETS = 0x00000002,
MSRES_SUBSETS_DIFF_PROT = 0x00000004,
MSRES_REQUIRE_BOLD_RED = 0x00000008,
MSRES_SHOW_ALL_FROM_ERR_TOL = 0x00000010,
MSRES_IGNORE_PMF_MIXTURE = 0x00000020,
MSRES_MUDPIT_PROTEIN_SCORE = 0x00000040,
MSRES_DECOY = 0x00000080,
MSRES_INTEGRATED_ERR_TOL = 0x00000100,
MSRES_ERR_TOL = 0x00000200,
MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400,
MSRES_CLUSTER_PROTEINS = 0x00000800,
MSRES_DUPE_INCL_IN_SCORE_NONE = 0x00000000,
MSRES_DUPE_INCL_IN_SCORE_A = 0x00002000,
MSRES_DUPE_INCL_IN_SCORE_B = 0x00004000,
MSRES_DUPE_INCL_IN_SCORE_C = 0x00008000,
MSRES_DUPE_INCL_IN_SCORE_D = 0x00010000,
MSRES_DUPE_INCL_IN_SCORE_E = 0x00020000,
MSRES_DUPE_INCL_IN_SCORE_F = 0x00040000,
MSRES_DUPE_INCL_IN_SCORE_G = 0x00080000,
MSRES_DUPE_INCL_IN_SCORE_H = 0x00100000,
MSRES_DUPE_INCL_IN_SCORE_I = 0x00200000,
MSRES_DUPE_REMOVE_NONE = 0x00400000,
MSRES_DUPE_REMOVE_A = 0x00800000,
MSRES_DUPE_REMOVE_B = 0x01000000,
MSRES_DUPE_REMOVE_C = 0x02000000,
MSRES_DUPE_REMOVE_D = 0x04000000,
MSRES_DUPE_REMOVE_E = 0x08000000,
MSRES_DUPE_REMOVE_F = 0x10000000,
MSRES_DUPE_REMOVE_G = 0x20000000,
MSRES_DUPE_REMOVE_H = 0x40000000,
MSRES_DUPE_REMOVE_I = 0x80000000,
MSRES_DUPE_DEFAULT = 0x04800000
}

Flags for the type of results.

More...
enum HOMOLOGY_THRESHOLD_SOURCE { ,
HOMTHR_FASTA = -1,
HOMTHR_SL = -2
}

Flags for getHomologyThreshold()

More...
enum IONS_HISTOGRAM {
IH_INCLUDE_TOP_MATCHES = 0x0000,
IH_INCLUDE_TOP_10_MATCHES = 0x0001
}

Flags for getIonsScoreHistogram().

More...
enum QUANT_COMPONENT_STATUS {
QCS_OK,
QCS_OK_NO_MATCH,
QCS_ERROR_NO_METHOD,
QCS_ERROR_NO_COMPONENTS,
QCS_ERROR_BAD_COMPONENT_NAME,
QCS_OK_MULTIPLE_MATCHES
}

Return codes for getQuantitationComponentForPeptide().

More...
enum sortBy {
QUERY,
SCORE,
INTENSITY
}

Flags for createUnassignedList().

More...
enum THRESHOLD_TYPE {
TT_HOMOLOGY = 0x0000,
TT_IDENTITY = 0x0001,
TT_PEPSUM_DEFAULT = 0x0002
}

Flags for getPeptideThreshold()

More...
enum TREE_CLUSTER_METHOD { ,
TCM_PAIRWISE_SINGLE = 0x0001,
TCM_PAIRWISE_MAXIMUM = 0x0002,
TCM_PAIRWISE_AVERAGE = 0x0003
}

Flags for getTreeClusterNodes().

More...
enum UNIQUE_PEP_RULES {
UPR_WITHIN_FAMILY = 0x0001,
UPR_WITHIN_FAMILY_MEMBER = 0x0002,
UPR_IGNORE_SUBSET_PROTEINS = 0x0004,
UPR_DEFAULT = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
}

Flags for isPeptideUnique().

More...

Public Member Functions

ms_proteinsummary (const ms_mascotresfile &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS|ms_mascotresults::MSRES_SHOW_SUBSETS, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, const char *singleHit=0)
Call this constructor once to create protein summary results.
ms_proteinsummary (const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters)
Call this constructor once to create protein summary results.
virtual bool | anyEmPAI () const
Return true if any emPAI values are available.
virtual bool | anyNumDiscoveredMods () const
Return true if modification discovery statistics are available.
void | cancelCreateSummary (bool newValue=true)
Cancel the call to createSummary()
virtual bool | createSummary ()
Create the summary after the ms_mascotresults object has been created.
bool | createUnassignedList (sortBy s=QUERY)
To have a list of unassigned peptides, need to call this first.
virtual void | freeHit (const int hit)
Frees any memory associated with the passed hit number.
virtual int | getAllFamilyMembersWithThisPepMatch (const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const
Return a list of (top level) family proteins that have a match to the specified q and p.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const
Return a complete list of proteins that contain this same peptide match.
virtual std::vector< std::string > | getAllProteinsWithThisPepMatch (const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const
Return a complete list of proteins that contain this same peptide match.
virtual int | getAvePeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the average threshold value for all MS-MS data sets.
virtual bool | getComponentIntensity (const int q, const int p, const std::string &componentName, double &value, double &rawValue) const
Returns the component intensity for reporter or multiplex methods.
virtual const ms_protein * | getComponentProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
virtual std::string | getComponentString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return an empty string.
bool | getCreateSummaryProgress (int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const
Return progress for the createSummary() call.
virtual std::vector< double > | getDiscoveredErrTolModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all error tolerant modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredErrTolModNames () const
Return the names of all error tolerant modifications discovered in this search.
virtual std::vector< double > | getDiscoveredLocalModDeltas (std::vector< std::string > *vecDeltaStrings=NULL) const
Return the deltas of all query-level modifications discovered in this search.
virtual std::vector< std::string > | getDiscoveredLocalModNames () const
Return the names of all query-level modifications discovered in this search.
virtual double | getErrTolModDelta (const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const
Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModMasterNeutralLoss (const int q, const int p) const
Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.
virtual std::string | getErrTolModMasterString (const int q, const int p) const
Return the complete error tolerant mod primary neutral loss string from h1_q1_et_mods_primary.
virtual std::string | getErrTolModName (const int q, const int p, std::string *modString=NULL) const
Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolModNeutralLoss (const int q, const int p) const
Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.
virtual std::vector< double > | getErrTolModPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.
virtual std::string | getErrTolModPepString (const int q, const int p) const
Return the complete error tolerant mod peptide neutral loss string from h1_q1_et_mods_pep.
virtual std::vector< double > | getErrTolModReqPepNeutralLoss (const int q, const int p) const
Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.
virtual std::string | getErrTolModReqPepString (const int q, const int p) const
Return the complete error tolerant mod required peptide neutral loss string from h1_q1_et_mods_reqpep.
virtual std::vector< double > | getErrTolModSlaveNeutralLoss (const int q, const int p) const
Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.
virtual std::string | getErrTolModSlaveString (const int q, const int p) const
Return the complete error tolerant mod slave neutral loss string from h1_q1_et_mods_slave.
virtual std::string | getErrTolModString (const int q, const int p) const
Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.
virtual double | getErrTolProbabilityThreshold () const
Return the probability threshold used for error tolerant peptides.
unsigned int | getFlags () const
Returns the flags value passed to the constructor.
unsigned int | getFlags2 () const
Return the flags2 value passed to the ms_peptidesummary constructor.
virtual ms_protein * | getHit (const int hit, const int memberNumber=0) const
Return the ms_protein hit - returns null if hit > number of hits.
virtual int | getHomologyThreshold (const int query, double OneInXprobRnd, const int rank=1) const
Returns the 'homology' threshold.
virtual int | getHomologyThresholdForHistogram (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns the value for the 'yellow section' in the histogram.
virtual double | getIonsScore (const int q, const int p, const bool decoy) const
Returns an ions score quickly without having to load an ms_peptide object.
virtual std::vector< int > | getIonsScoreHistogram (IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const
Returns a list of counts for binned ions scores.
virtual std::string | getLibraryModString (const int q, const int p) const
Return the modification string of the spectral library match from q1_p1_SLmod.
virtual int | getMaxPeptideIdentityThreshold (double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the max threshold value for all MS-MS data sets.
virtual int | getMaxRankValue () const
Returns the maximum 'rank' or 'hit' or 'p' value.
int | getMinPepLenInPepSummary () const
Peptides shorter than this are ignored when putting proteins into groups.
virtual ms_protein * | getNextFamilyProtein (const int masterHit, const int id) const
Find the next protein in the family masterHit.
virtual ms_protein * | getNextSimilarProtein (const int masterHit, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSimilarProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains all the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProtein (const int masterHit, const int id, const bool searchWholeFamily=true) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual ms_protein * | getNextSubsetProteinOf (const char *masterAccession, const int masterDB, const int id) const
Return the next protein that contains some of the peptides in the 'master' protein.
virtual int | getNumberOfFamilyMembers () const
Return the total number of family members.
virtual int | getNumberOfHits () const
Returns the number of hits in the results.
int | getNumberOfUnassigned () const
Return the number of peptides in the unassigned list.
virtual long | getNumDecoyHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the homology threshold.
virtual long | getNumDecoyHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits from the decoy search with a score at or above the identity threshold.
virtual std::vector< int > | getNumDiscoveredErrTolMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of error tolerant modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredFixedMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of fixed modifications discovered in this search.
std::vector< int > | getNumDiscoveredIntactLinks (std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const
Return the count of intact crosslinks in this search.
std::vector< int > | getNumDiscoveredLibraryMods (const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of library modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredLocalMods (const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of query-level modifications discovered in this search.
virtual int | getNumDiscoveredNonSpecCleavage () const
Return the count of non-specific cleavages in an error tolerant search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const
Return the count of variable modifications discovered in this search.
virtual std::vector< int > | getNumDiscoveredVariableMods (const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const
Return the count of variable modifications discovered in this search.
virtual long | getNumHitsAboveHomology (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the homology threshold.
virtual long | getNumHitsAboveIdentity (double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA)
Return the number of hits with a score at or above the identity threshold.
int | getNumPmfQueriesUsed () const
Returns number of queries (masses) used when calculating PMF protein scores.
virtual std::vector< int > | getPepsWithSameScore (const int q, const int p) const
Returns a list of 'p' values for peptides with the same score.
virtual ms_peptide | getPeptide (const int q, const int p) const
Return a peptide object for the specified query / hit.
virtual bool | getPeptide (const int q, const int p, ms_peptide *&pep) const
Return a peptide object for the specified query / hit.
virtual double | getPeptideExpectationValue (const double score, const int query, const int rank=0) const
Returns the expectation value for the given peptide score and query.
virtual int | getPeptideIdentityThreshold (const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const
Return the threshold value for this ms-ms data being a random match.
double | getPeptideThreshold (const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const
Return either the identity or the homology threshold.
virtual double | getProbabilityThreshold () const
Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.
virtual int | getProbFromScore (const double score) const
Returns a probability value given a score.
virtual double | getProbOfPepBeingRandomMatch (const double score, const int query) const
virtual double | getProbOfProteinBeingRandomMatch (const double score) const
virtual const ms_protein * | getProtein (const char *accession, const int dbIdx=1) const
Return a pointer to the protein entry given an accession.
std::string | getProteinDescription (const char *accession, const int dbIdx=1) const
Return protein description if available.
virtual double | getProteinEmPAI (const char *accession, const int dbIdx=1, const int length=-1) const
Return protein emPAI if available.
virtual double | getProteinExpectationValue (const double score) const
Returns the expectation value for the given protein score.
double | getProteinMass (const char *accession, const int dbIdx=1) const
Return protein mass if available.
virtual int | getProteinScoreCutoff (double OneInXprobRnd) const
Return the 'protein' score value for cutting off results. Different for peptide and protein summary.
virtual double | getProteinScoreForHistogram (const int num) const
Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.
virtual std::string | getProteinsWithThisPepMatch (const int q, const int p, const bool quotes=false)
Return a partial list of proteins that matched the same peptide.
void | getProteinTaxonomyIDs (const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const
Return the taxonomy ID(s), if any, from the results file.
virtual int | getProteinThreshold (double OneInXprobRnd) const
Return a threshold value for the protein summary report.
virtual int | getQmatch (const int query) const
Return the number of peptides with masses that matched this query.
virtual int | getQmatch (const int query, const ms_mascotresfile::section sec) const
Return the number of peptides with masses that matched this query.
virtual QUANT_COMPONENT_STATUS | getQuantitationComponentForPeptide (const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const
Get the component in the quantitation method that matches the peptide.
virtual std::string | getReadableVarMods (const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return a 'human readable' string with the variable, summed and error tolerant mods.
const ms_mascotresfile & | getResfile () const
Return a reference to the resfile.
ms_mascotresults_params getResultsParameters ()
Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.
double | getSequenceMass (const char *seq) const
Return the mass of a sequence (protein or peptide).
virtual int | getTagDeltaRangeEnd (const int q, const int p) const
Return the second number from h1_q2_drange=0,256.
virtual int | getTagDeltaRangeStart (const int q, const int p) const
Return the first number from h1_q2_drange=0,256.
virtual int | getTagEnd (const int q, const int p, const int tagNumber) const
Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagSeries (const int q, const int p, const int tagNumber) const
Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.
virtual int | getTagStart (const int q, const int p, const int tagNumber) const
Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.
virtual std::string | getTagString (const int q, const int p) const
Return the complete tag string from h1_q2_tag or q1_p1_tag.
virtual std::string | getTerminalResiduesString (const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const
Return the complete terminal residue string from h1_q1_terms.
bool | getThresholdForFDRAboveHomology (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveHomology (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.
bool | getThresholdForFDRAboveIdentity (double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0)
Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.
double | getToleranceInDalton (bool &needMass, const double *const pMass=NULL) const
Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.
virtual bool | getTreeClusterNodes (const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const
Return distances and structure suitable for a dendrogram plot.
ms_peptide | getUnassigned (const int num) const
Need to call createUnassignedList() before calling this.
bool | getUnassignedIsBold (const int num) const
Returns true if the item indexed by num in the assigned list should be bold.
bool | getUnassignedShowCheckbox (const int num) const
Returns true if the item indexed by num in the assigned list should have a check box next to it.
bool | isEmPAIallowed () const
Return true if emPAI could be calculated using data in this results file.
bool | isNA () const
Returns TRUE for a search against a nucelic acid database.
virtual bool | isPeptideUnique (const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const
Returns true if this peptide match is unique to one protein or one protein family.
bool | isPmfQueryUsed (const int queryIdx) const
Indicates whether a mass value was used when calculating PMF protein scores.
virtual void | setSubsetsThreshold (const double scoreFraction)
Specifies which subset proteins should be reported.

Protected Member Functions

virtual int | findPeptides (const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const
Find the next hit that contains peptides with the specified attribute.
virtual int | findProteins (const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified attributes.
virtual int | findProteinsByAccession (const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified accession.
virtual int | findProteinsByDescription (const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const
Find the next hit that contains proteins with the specified description.
double | getIonsScoreCorrected (const double ionsScore, const long multiplicity) const
virtual double | getPepIdentThreshProtected (const int query, double OneInXprobRnd, ms_mascotresfile::section sec, DB_MATCH_TYPE dbType, double *pQmatch=0) const
Return the threshold value for this ms-ms data being a random match.

Detailed Description

Use this class to get protein summary results.

The following functions provide threshold values:

  • getPeptideIdentityThreshold()
  • getAvePeptideIdentityThreshold()
  • getMaxPeptideIdentityThreshold()
  • getPeptideThreshold()
  • getProteinThreshold()
  • getHomologyThreshold()
  • getHomologyThresholdForHistogram()
  • getProbFromScore()
  • getProbOfPepBeingRandomMatch()
  • double getProbOfProteinBeingRandomMatch()

This class inherits from ms_mascotresults, and all the class functions except for getPeptide() are documented in ms_mascotresults.

Examples:

repeat_search.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum DB_MATCH_TYPE [inherited]

Type of matches counted by getNumHitsAboveIdentity() and friends, and type of score for getIonsScoreHistogram().

Enumerator:
DM_FASTA

Mascot matches to FASTA sequences. This is the default.

DM_SPECTRAL_LIBRARY

Matches to spectral library entries. This was introduced in Parser 2.6.

DM_BOTH

Only valid for count of matches (getNumHitsAboveIdentity() and friends): the combined count for FASTA and spectral library entries.

DM_FASTA_FIRST_PASS

Mascot matches to FASTA sequences, first pass only.

DM_FASTA_SECOND_PASS

Mascot matches to FASTA sequences, second pass only (e.g. error tolerant).

enum DECOY_STATS_COUNT_TYPE [inherited]

Type of object counted by getNumHitsAboveIdentity() and friends.

Enumerator:
DS_COUNT_PSM

Count peptide-spectrum matches (PSMs). This is the default.

DS_COUNT_SEQUENCE

Count distinct peptide sequences. This was introduced in Parser 2.6.

enum FIND_COMPARE_FLAGS [inherited]

Flags to specify how comparisons are performed in the find functions.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These flags are used in findProteins(), findPeptides() and the deprecated functions: findProteinsByAccession() and findProteinsByDescription(). The flags are used to specify how the comparison is performed and whether it should be a forward or reverse seach. Typically, three values will be combined together, using an OR operator; however, any default values do not need to be specifically specified.

  • Choose 1 of: FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK
  • Choose 1 of: FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE
  • Choose 1 of: FC_FORWARD, FC_REVERSE
  • Optionally choose FC_RESTRICT_TO_HIT or (FC_LOOP_INTO_UNASSIGNED and/or FC_LOOP_FROM_UNASSIGNED)
  • Optionally choose FC_SEARCH_ALL_RANKS
  • Optionally choose FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES
  • Optionally choose one or more of the FC_PROTEIN_IGN_ flags when calling findProteins()
Enumerator:
FC_COMPLETESTR

Search for the complete string. If search item is a decimal number then match the number exactly.

FC_SUBSTR

Search for any substring. Not valid if search item is a decimal number.

FC_STARTSTR

String must match to start of target string. If search item is a decimal number then match to the same decimal precision of the filter value but rounded. For example a filter value of 1234.56 will return items with values in the range (1234.555 >= value < 1234.565).

FC_STRTOK

Supplied string is a set of tokens, for example "STY" could be used to search for S or T or Y in a peptide sequence.

FC_MASK_STR_PART

Bit mask to extract which one of FC_COMPLETESTR, FC_SUBSTR, FC_STARTSTR, FC_STRTOK has been specified.

FC_CASE_INSENSITIVE

Case insensitive search (default).

FC_CASE_SENSITIVE

Case sensitive search.

FC_MASK_CASE

Bit mask to extract which one of FC_CASE_INSENSITIVE, FC_CASE_SENSITIVE has been specified.

FC_FORWARD

Forward search. The returned hit number will be the same as or higher than the start hit number. (default).

FC_REVERSE

Reverse search. The returned hit number will be the same as or lower than the start hit number.

FC_MASK_DIRECTION

Bit mask to extract which one of FC_FORWARD, FC_REVERSE has been specified.

FC_RESTRICT_TO_HIT

Don't search beyond the specified hit number. Cannot be used with FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_LOOP_INTO_UNASSIGNED

If no matches are found in the passed hit, or any subsequent hit, then search the unassigned list.

FC_LOOP_FROM_UNASSIGNED

If the passed hit number is 0, and no match is found in the unassigned list, then start searching at 1 if FC_FORWARD is specified or start searching at 'numHits' if FC_REVERSE is specified.

FC_UNASSIGNED_MASK

Bit mask to extract FC_LOOP_INTO_UNASSIGNED or FC_LOOP_FROM_UNASSIGNED.

FC_SEARCH_ALL_RANKS

For use with findPeptides() only. Ordinarily only those queries and ranks are searched that are assigned to a protein hit. Use this flag to search all ranks in such queries instead.

FC_ALL_PEPTIDES

Search all peptides regardless of score (default).

FC_ALL_PEPTITDES
Deprecated:
Unfortunate spelling error, please use FC_ALL_PEPTIDES which has an identical value.
FC_SIGNIFICANT_PEPTIDES

Only search peptides above identitity or homology threshold.

FC_SEARCH_IGNORED_RANKS

In integrated library mode, also search peptides that are part of a family member's list of ignored peptides.

FC_SCORING_MASK

Bit mask to extract FC_ALL_PEPTIDES or FC_SIGNIFICANT_PEPTIDES.

FC_PROTEIN_IGN_SAMESETS

Ignore sameset proteins - only used for findProteins()

FC_PROTEIN_IGN_SUBSETS

Ignore subset proteins - only used for findProteins()

FC_PROTEIN_IGN_FAMILY

Ignore family member proteins - only used for findProteins()

FC_PROTEIN_IGN_MASK

Ignore proteins flags.

FC_PROTEIN_INC_ALT_ACC

For use with findProteins() only. If protein entries in the database are representative (i.e. contain multiple accessions) and those accessions are saved in the results file (Mascot 2.4 or later), setting this flag will search all accessions of each protein entry, not just the first accession.

enum FIND_FLAGS [inherited]

Flags for findPeptides() and findProteins().

Details what needs to be searched for. Any of the FT_PEPTIDE_ flags may be used for either findPeptides() or findProteins(), but the FT_PROTEIN flags may only be used for findProteins()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
FT_PEPTIDE_EXP_MZ

Find an experimental m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_EXP_MR

Find an experimental relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_CALC_MZ

Find a calculated m/z value. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_CALC_MR

Find a calculated relative mass. Refer to FIND_COMPARE_FLAGS for comparison behaviour of decimal numbers.

FT_PEPTIDE_STRING

Find a peptide string.

FT_PEPTIDE_QUERY

Find a query number.

FT_PEPTIDE_VARMOD

Find a variable modification. Specifiy the modification 'number' as the string.

FT_PEPTIDE_FIXMOD

Find a fixed modification. Specifiy the modification 'number' as the string.

FT_PEPTIDE_ETMOD

Find an error tolerant modification. Specifiy a delta mass as the string.

FT_PEPTIDE_SLMOD

Find a spectral library modification. Specifiy any substring of the mod name as the string.

FT_PEPTIDE_VARMOD_BYNAME

Find a variable or query level modification. Specify any substring of the mod name as the string.

FT_PEPTIDE_FIND_MASK

Bit mask for any of the peptide values to be found.

FT_PROTEIN_ACCESSION

Find an accession - findProteins() only.

FT_PROTEIN_DESCRIPTION

Find a description - findProteins() only.

enum FLAGS [inherited]

Flags for the type of results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Not all of the flags applicable for protein summary (e.g. MSRES_REQUIRE_BOLD_RED); see ms_proteinsummary.

Enumerator:
MSRES_NOFLAG

Does nothing.

MSRES_GROUP_PROTEINS

Group proteins with same peptide matches. See Grouping proteins together.

MSRES_SHOW_SUBSETS

Show proteins that only match a subset of peptides. See Grouping proteins together.

MSRES_SUBSETS_DIFF_PROT

Proteins that contain a subset of peptides are treated as a unique protein. See Grouping proteins together.

MSRES_REQUIRE_BOLD_RED

Only proteins that have a top scoring peptide not seen before will be returned.

MSRES_SHOW_ALL_FROM_ERR_TOL

If this flag is set, then all hits from error tolerant search are shown. See Error tolerant searches.

MSRES_IGNORE_PMF_MIXTURE

If this flag is set, then PMF mixtures are ignored. See Peptide mass fingerprint mixtures.

MSRES_MUDPIT_PROTEIN_SCORE

Protein scoring for the peptide summary was changed at Mascot 2.0 for large (MudPIT) searches. See ms_protein::getScore().

MSRES_DECOY

If this flag is set, then use the results from searching against the decoy database. See Target-decoy searches and false discovery rate.

MSRES_INTEGRATED_ERR_TOL

If this flag is set, then create a ms_peptidesummary object that contains results from the summary and et_summary section. See Error tolerant searches.

MSRES_ERR_TOL

If this flag is set, then create a ms_peptidesummary object that contains results from the et_summary section. See Error tolerant searches.

MSRES_MAXHITS_OVERRIDES_MINPROB

If minProbability and maxHitsToReport are both non zero, then minProbability is ignored when determining the number of proteins to be displayed. See ms_mascotresults::ms_mascotresults.

MSRES_CLUSTER_PROTEINS

Protein clustering introduced in Mascot 2.3. See Using MSRES_CLUSTER_PROTEINS.

MSRES_DUPE_INCL_IN_SCORE_NONE

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_A

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_B

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_C

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_D

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_E

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_F

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_G

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_H

See Treatment of duplicate peptides.

MSRES_DUPE_INCL_IN_SCORE_I

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_NONE

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_A

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_B

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_C

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_D

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_E

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_F

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_G

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_H

See Treatment of duplicate peptides.

MSRES_DUPE_REMOVE_I

See Treatment of duplicate peptides.

MSRES_DUPE_DEFAULT

Default parameter for treatment of duplicates. See Treatment of duplicate peptides.

enum HOMOLOGY_THRESHOLD_SOURCE [inherited]

Flags for getHomologyThreshold()

The method getHomologyThreshold() accepts either a rank argument or one of the special enumerated values listed here. For backwards compatibility, the integers 1-20 have their own enumerated values.

Enumerator:
HOMTHR_FASTA

Retrieve the homology threshold for FASTA matches.

HOMTHR_SL

Retrieve the homology threshold for spectral library matches.

enum IONS_HISTOGRAM [inherited]

Flags for getIonsScoreHistogram().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
IH_INCLUDE_TOP_MATCHES

The default. Just include the top match to each spectrum.

IH_INCLUDE_TOP_10_MATCHES

Instead of just the top match, use the top 10 matches to each spectrum.

enum QUANT_COMPONENT_STATUS [inherited]

Return codes for getQuantitationComponentForPeptide().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
QCS_OK

The component was retrieved successfully.

QCS_OK_NO_MATCH

The quantitation method's components were searched successfully, no matching component was found.

QCS_ERROR_NO_METHOD

There is no quantitation method available (e.g. for protein summary).

QCS_ERROR_NO_COMPONENTS

There are no components specified in the quantitation method (e.g. for non-precursor method).

QCS_ERROR_BAD_COMPONENT_NAME

The peptide's component name in the Mascot results does not match any component in the quantitation method.

QCS_OK_MULTIPLE_MATCHES

The quantitation method's components were searched successfully, multiple matching components were found.

enum sortBy [inherited]

Flags for createUnassignedList().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
QUERY

Sort the unassigned list by ascending query number - this is the same as ascending relative mass order.

SCORE

Sort the unassigned list by descending score.

INTENSITY

Sort the unassigned list by descending intensity. Intensity values are taken from the qintensity value in the results file if they are available (from PKL files, or some MGF files). If these values are not available, then the intensity is calculated from the sum of all the ions values. For a very large MS-MS file, this option can take some time to process unless there are qintensity value in the results file.

enum THRESHOLD_TYPE [inherited]

Flags for getPeptideThreshold()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TT_HOMOLOGY

Homology threshold.

TT_IDENTITY

Identity threshold.

TT_PEPSUM_DEFAULT

If ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH is specified in the constructor, then this will resolve to TT_HOMOLOGY, otherwise it will resolve to TT_IDENTITY.

enum TREE_CLUSTER_METHOD [inherited]

Flags for getTreeClusterNodes().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TCM_PAIRWISE_SINGLE

's': pairwise single-linkage clustering.

TCM_PAIRWISE_MAXIMUM

'm': pairwise maximum- (or complete-) linkage clustering.

TCM_PAIRWISE_AVERAGE

'a': pairwise average-linkage clustering.

enum UNIQUE_PEP_RULES [inherited]

Flags for isPeptideUnique().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Choose UPR_WITHIN_FAMILY or UPR_WITHIN_FAMILY_MEMBER and then optionally 'or' UPR_IGNORE_SUBSET_PROTEINS

Enumerator:
UPR_WITHIN_FAMILY

The peptide is unique if it occurs in proteins that are part of a single family.

UPR_WITHIN_FAMILY_MEMBER

The peptide is unique if it occurs in proteins that just belong to a single family member.

UPR_IGNORE_SUBSET_PROTEINS

Ignore any susbset proteins that contain the match when deciding if a peptide is unique. However, if the peptide just belongs to subset proteins for the same hit, then it is still considered to be unique.

UPR_DEFAULT

Set to UPR_WITHIN_FAMILY_MEMBER | UPR_IGNORE_SUBSET_PROTEINS.

Constructor & Destructor Documentation

ms_proteinsummary | ( | const ms_mascotresfile & | resfile,
 |  | const unsigned int | flags = ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS,
 |  | double | minProbability = 0.0,
 |  | int | maxHitsToReport = 50,
 |  | const char * | unigeneIndexFile = 0,
 |  | const char * | singleHit = 0
 | ) |  |

Call this constructor once to create protein summary results.

Creating an ms_proteinsummary object may take some time for a very large file with a large number of protein hits.

Parameters:
resfile | An ms_mascotresfile object. See Maintaining object references: two rules of thumb.
flags | can be one or more of the ms_mascotresults::FLAGS values OR'ed together
minProbability specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

  • A value of 0 indicates no cutoff - report maxHitsToReport proteins, whatever the protein scores.
  • A value between 0 and 1 is used to calculate a protein score cut-off based on peptide match expect values. With standard protein scoring, 0.05 would discard all proteins with a score less the average score of a peptide with an expect value of 0.05. With MudPIT protein scoring, 0.05 would be the peptide expect value threshold used for calculating the protein scores, and only proteins with non-zero scores are reported. This value is also used to select proteins for an Integrated error tolerant search.
  • A value of less than 0 is not permitted and will be replaced with the default of 0.05.
  • In Mascot Parser 2.2 and earlier, a value between 0.1 and 1.0 was replaced with the default value of 0.05. In Mascot Parser 2.3, any value between 1e-18 and 1.0 is acceptable.
  • A value greater than 1 indicates an absolute score cutoff for proteins, but this is not valid for an Integrated error tolerant search and is not permitted in the standard Mascot Search reports, so is not recommended.

Other points to note:

  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins - the similar and subset proteins are not 'cutoff' by this value.
  • The cutoff point is the lower of maxHitsToReport and this value, unless the ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB flag is set. With versions of parser before Mascot 2.2, this flag was not available so AUTO in the standard Mascot results reports was implemented by setting this probablility to a (user) defined value and setting maxHitsToReport to a very large number.
maxHitsToReport is a maximum value. There may be fewer hits than this number if minProbability is high, or if there are insufficient results.

  • If the ms_mascotresults::MSRES_MAXHITS_OVERRIDES_MINPROB flag is set, then the minProbability value is ignored when determining the number of hits to display. With versions of parser before Mascot 2.2, this flag was not available so a value of 0 was passed as minProbability in the standard Mascot results reports.
  • If the flag ms_mascotresults::MSRES_GROUP_PROTEINS is set, then this value applies to the top level proteins - the similar and subset proteins are not included in the count.
unigeneIndexFile | is an optional file path to a UniGene Index file. This only makes sense if ms_mascotresults::MSRES_GROUP_PROTEINS is set.
singleHit should only be used for getting the results for a single protein quickly. This is used for example by the the protein view report in Mascot, which just shows the matches for a single protein. For the protein summary, pass, for example "3" to get hit 3. See Using the singleHit parameter to return a single protein.

  • From programming languages other than C++, pass an empty string object to specify that all proteins should be used.
ms_proteinsummary | ( | const ms_mascotresfile & | resfile,
 |  | const ms_mascotresults_params & | parameters
 | ) |  |

Call this constructor once to create protein summary results.

Creating an ms_proteinsummary object may take some time for a very large file with a large number of protein hits.

Parameters:
resfile | An ms_mascotresfile object. See Maintaining object references: two rules of thumb.
parameters | An ms_mascotresults_params object which should contain all of the required values and flags to generate the protein summary.

Member Function Documentation

bool anyEmPAI ( ) const [virtual, inherited]

Return true if any emPAI values are available.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns:
true if above conditions are true and at least one protein has a non-zero emPAI value.

Reimplemented in ms_peptidesummary.

bool anyNumDiscoveredMods ( ) const [virtual, inherited]

Return true if modification discovery statistics are available.

Modification discovery counts for fixed and variable modifications (and error tolerant modifications in an error tolerant search) are only available if the results file contains a Unimod section. Since only significant rank 1 peptide matches assigned to a protein hit are inspected for modification counting purposes, it is possible for the counts to be zero even when a Unimod section exists.

Returns:
True if number of modifications could be counted and there is at least one modification with a non-zero count; false otherwise.
void cancelCreateSummary ( bool newValue = true ) [inherited]

Cancel the call to createSummary()

It is normally recommended that an application should delete the ms_peptidesummary object after calling this function because some objects will still be in memory (no cleanup is performed).

Cancelling may not occur immediately, and the calling application needs to wait for the createSummary() call to return.

See also getCreateSummaryProgress() and ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE

Parameters:
newValue should be set to true to cancel the createSummary call
bool createSummary ( ) [virtual, inherited]

Create the summary after the ms_mascotresults object has been created.

Creating an ms_peptidesummary object for a large results file can take a considerable amount of time. The standard Mascot reports do not have an option to 'cancel' the creation of the report and rely on the ms_mascotresfile::outputKeepAlive() function to provide progress reports and keep the connection alive. This is not so desireable for a client application that doesn't want to redirect stdout, and wants to allow the user to cancel a long operation. Specify the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag when creating the ms_peptidesummary object, and then use one thread to call this function and a separate thread to call getCreateSummaryProgress() and report progress to the end user.

This function is called directly by the ms_mascotresults constructor unless the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag is specified. If that flag is specified, then the constructor returns 'immediately' and this function must be called by the client code. Until this function returns, the client code in the separate thread can only reliably call the getCreateSummaryProgress(), ms_mascotresfile::outputKeepAlive() or cancelCreateSummary() functions. Calling any other function for the ms_mascotresults object may result in undefined behaviour and cause the ms_mascotresfile::ERR_RESULTS_NOT_CREATED error to be set.

This function should not be called for a ms_proteinsummary.

Returns:
true if successful

Reimplemented in ms_peptidesummary.

bool createUnassignedList ( sortBy s = QUERY ) [inherited]

To have a list of unassigned peptides, need to call this first.

See Unassigned peptides list for details of creating an unassigned list.

Parameters:
s order to sort the unassigned list
Returns:
Currently always returns true unless createSummary() has not completed
Examples:
resfile_summary.cpp.
int findPeptides | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< int > & | q,
 |  | std::vector< int > & | p
 | ) |  | const [protected, virtual]

Find the next hit that contains peptides with the specified attribute.

Note:
For a protein summary, this function always returns -1.

Can be used to find peptide-spectrum matches with a specified query number, sequence, mass, or fixed or variable modification. Returns the protein hit number and a list of q,p values that contains one or more string matches to the input string.

In crosslinked searches, both alpha and beta peptides are compared to the search criteria. Only one needs to match the input string.

All subset, sameset and family member proteins are searched, and it is possible that the returned q and p values only correspond to peptides in a single subset protein. The FC_PROTEIN_IGN_SAMESETS, FC_PROTEIN_IGN_SUBSETS and FC_PROTEIN_IGN_FAMILY flags cannot be used with this function. To find proteins which contain particular peptide matches, or to control which proteins to search, see findProteins().

For FT_PEPTIDE_VARMOD , str should contain the modification 'number' as passed to ms_searchparams::getVarModsName(). Modification numbers between 1 and 9 correspond to strings "1" through "9", and numbers between 10 and 32 correspond to "A" through "W". To find all error tolerant modifications, specify "X" and then use ms_peptidesummary::getErrTolModName() to retrieve the name of the modification.

For FT_PEPTIDE_FIXMOD, str should contain the modification 'number' as passed to ms_searchparams::getFixedModsName(). This will be in the range 1-20.

For both types of modification searches, str should only contain a single character. The value for compareFlags should include FC_SUBSTR, because this function is implemented by searching the return value from ms_peptide::getVarModsStr(). Specifying incorrect flags does not generate an error and results in undefined behaviour.

There is an alternative way to search for fixed mods: specify FT_PEPTIDE_STRING and FC_STRTOK as item and compareFlags, respectively, and pass the return value of ms_searchparams::getFixedModsResidues() as the string to search for, str. Although this may seem equivalent to the combination FT_PEPTIDE_FIXMOD and FC_SUBSTR, there are two corner cases where the latter works while the former doesn't:

  • ms_searchparams::getFixedModsResidues() can return "N_term" or "C_term", which are clearly not strings of amino acids.
  • The case where a fixed mod is 'replaced' with a variable mod. For example, if Carbamidomethyl (C) is specified as a fixed mod and Propionamide (C) as variable mod, then it is not sufficient to just check if a peptide contains a cysteine.
Parameters:
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1. To search the unassigned list, pass a value of 0.
str | is the string to be matched.
item | is the peptide item to be found (for example, the peptide sequence or mass). Any of the FT_PEPTIDE_ values may be used.
compareFlags | specifies whether the str value is required to match all or just part of the target string. It can also be used to specify a reverse search.
q | is a vector of query values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
p | is a vector of corresponding rank values for peptides that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned matched items, or 0 if the match is in the unassigned list, or -1 if there is no match found.

Implements ms_mascotresults.

int findProteins | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_FLAGS | item,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [protected, virtual]

Find the next hit that contains proteins with the specified attributes.

Note:
For a protein summary, this function always returns -1.

Used to find accessions, protein descriptions or proteins that have peptide matches with a specified query number, sequence, mass, or fixed or variable modification. Any of the FIND_FLAGS may be used.

The findPeptides() function does not return any information about which subset/sameset/family proteins in a hit contain the found matches. findProteins(), however, returns a list of the protein accessions that contained a peptide match that fits the search criteria, and also allows the searched proteins to exclude samesets (FC_PROTEIN_IGN_SAMESETS), subsets (FC_PROTEIN_IGN_SUBSETS or family members (FC_PROTEIN_IGN_FAMILY).

If protein entries in the database are representative (i.e. contain multiple accessions), by default only the first accession will be considered when FT_PROTEIN_ACCESSION is specified as a search item. If alternative accessions are saved in the results file (Mascot 2.4 or later), setting FC_PROTEIN_INC_ALT_ACC will search all accessions of each protein entry. Note that this will make the search slower.

Parameters:
startHit | is the hit number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the string to be matched and depends on the value of item. If item is FT_PROTEIN_ACCESSION, then str will be the accession (or part of one) to be matched. If item is one of the FT_PEPTIDE_ values, then see FIND_FLAGS and findPeptides() for operational details.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
item | is the accession, description or peptide item to be found. For example, return all proteins with a given peptide sequence or mass.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains the matches, or -1 if there is no match found.

Implements ms_mascotresults.

int findProteinsByAccession | ( | const int | startHit,
 |  | const std::string & | str,
 |  | const int | dbIdx,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [protected, virtual]

Find the next hit that contains proteins with the specified accession.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_ACCESSION flag.
Note:
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with accessions that match to the the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Parameters:
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
dbIdx | is the database ID to be matched. To search all databases, pass a value of -1. Note that the value 0 corresponds to a UniGene database.
compareFlags | specifies whether the str value is required to match all or just part of the accession. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

int findProteinsByDescription | ( | const int | startHit,
 |  | const std::string & | str,
 |  | FIND_COMPARE_FLAGS | compareFlags,
 |  | std::vector< std::string > & | accessions,
 |  | std::vector< int > & | dbIndexes
 | ) |  | const [protected, virtual]

Find the next hit that contains proteins with the specified description.

Deprecated:
See findProteins() with the ms_mascotresults::FT_PROTEIN_DESCRIPTION flag.
Note:
For a protein summary, this function always returns -1.

Return the hit number and a list of proteins with descriptions that match the passed string. If protein grouping has been specified, then multiple proteins within the same hit may match, and these are all returned.

Descriptions are just those included in the results file. See getProteinDescription() for details of what is loaded into the results.

Parameters:
startHit | is the number at which to start searching. To start searching at the first hit, pass a value of 1.
str | is the accession (or part of accession) to be matched.
compareFlags | specifies whether the str value is required to match all or just part of the description. It can also be used to specify a reverse search.
accessions | is a vector of protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
dbIndexes | is a symmetric vector of database indexes for the protein accessions that match. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the single hit number that contains all the returned proteins, or -1 if there is no match found.

Implements ms_mascotresults.

void freeHit ( const int hit ) [virtual, inherited]

Frees any memory associated with the passed hit number.

Has no effect except when Using the ms_peptidesummary cache. This function frees the ms_protein objects for the specified hit. The return values from getHit(), getNextFamilyProtein(), getNextSimilarProtein(), getNextSimilarProteinOf(), getNextSubsetProtein() etc. for this hit will then point to deleted objects and hence should not be used.

In addition, any ms_peptide objects loaded into memory using the getPeptide(const int, const int, ms_peptide *&)const function will 'unloaded' if the ms_peptidesummary::MSPEPSUM_DISCARD_RELOADABLE has been specified. This function has no effect on the ms_peptide objects returned from the alternative getPeptide(const int, const int)const function.

Parameters:
hit should be in the range 1.. getNumberOfHits().

Reimplemented in ms_peptidesummary.

int getAllFamilyMembersWithThisPepMatch | ( | const int | hit,
 |  | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | db,
 |  | std::vector< std::string > & | acc,
 |  | std::vector< int > & | dupe_status
 | ) |  | const [virtual]

Return a list of (top level) family proteins that have a match to the specified q and p.

Only the top level proteins are returned by this function, that is, the proteins that would be returned by getHit() and getNextFamilyProtein(). It will be considerably faster than calling ms_protein::getPeptideQuery() and related functions, because that involves loading more information from the cache and from the .dat file.

This function will return the values rapidly when caching is enabled; see Using the ms_peptidesummary cache. It also functions correctly when not using the cache.

The returned vectors are all guaranteed to have the same number of elements. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use them from programming languages other than C++.

See also:
getAllProteinsWithThisPepMatch() and getProteinsWithThisPepMatch()
Parameters:
hit | Should be in the range 1.. getNumberOfHits().
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
db | is a vector of database IDs.
acc | is the corresponding vector of accessions.
dupe_status | is the corresponding vector of ms_protein::DUPLICATE values for the returned proteins. Note that ms_protein::DUPE_Ignored will only appear in integrated library searches where the peptide match was removed due to IgnoreIonsScoreBelow.
Returns:
The number of proteins in the db/acc/dupe_status vectors.

Implements ms_mascotresults.

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db
 | ) |  | const [virtual]

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

Crosslink searches only: If you need to know whether the accessions come from the alpha or beta peptide, use the 10-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also:
getProteinsWithThisPepMatch()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues -- one for each accession
end | Returns a vector of the end residues -- one for each accession
pre | Returns a vector of the residue before the peptide -- one for each accession
post | Returns a vector of the residue after the peptide -- one for each accession
frame | Returns a vector of the frames -- one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities -- one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
Returns:
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

std::vector< std::string > getAllProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | std::vector< int > & | start,
 |  | std::vector< int > & | end,
 |  | std::vector< std::string > & | pre,
 |  | std::vector< std::string > & | post,
 |  | std::vector< int > & | frame,
 |  | std::vector< int > & | multiplicity,
 |  | std::vector< int > & | db,
 |  | std::vector< int > & | psmComponent
 | ) |  | const [virtual]

Return a complete list of proteins that contain this same peptide match.

In a peptide summary, this function returns the complete list of proteins in the q1_p1= line of the peptides, et_peptides, or decoy_peptides or crosslink_peptides section as appropriate.

In a protein summary, the return value contains the complete list of proteins that had the same peptide match to the one specified in the h1_q1= line.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C# how to use the parameters start, end, pre, post, frame, multiplicity, db, psmComponent.

This method was added in Parser 2.7 for crosslinking support. If you don't need to know whether the accessions come from the alpha or beta peptide, you can use the 9-parameter method instead. In either case, the accession list may contain duplicates if the alpha and beta are assigned to the same protein hit.

See also:
getProteinsWithThisPepMatch()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
start | Returns a vector of the start residues -- one for each accession
end | Returns a vector of the end residues -- one for each accession
pre | Returns a vector of the residue before the peptide -- one for each accession
post | Returns a vector of the residue after the peptide -- one for each accession
frame | Returns a vector of the frames -- one for each accession. For a protein sequence, the frame will always be 0
multiplicity | Returns a vector of the multiplicities -- one for each accession. This is the number of precursor matches for each accession
db | Returns a vector of the database index numbers for searches against multiple databases. For searches against a single database, these values will always be 1.
psmComponent | Returns a vector of psmComponent markers (ms_peptide::PSM) -- one for each accession. For a crosslinked match, this will be one of ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA. In all other types of match, it will always be ms_peptide::PSM_COMPLETE.
Returns:
A list of all the accessions that contained the peptide matched by this result.

Implements ms_mascotresults.

int getAvePeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Return the average threshold value for all MS-MS data sets.

The average value is calculated by taking the mean value from calling getPeptideIdentityThreshold() for each query. This is the value that is used to be shown at the top of the standard Mascot reports in versions before Mascot 2.0. For example, threshold in the following string could be calculated by calling getAvePeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot score threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The average score threshold. If there was no MS-MS data then -1 will be returned.
bool getComponentIntensity | ( | const int | q,
 |  | const int | p,
 |  | const std::string & | componentName,
 |  | double & | value,
 |  | double & | rawValue
 | ) |  | const [virtual]

Returns the component intensity for reporter or multiplex methods.

This function will only succeed for MS2 based quantitation methods such as "reporter" and "multiplex" where the required data is in the .dat file. It is up to the calling application to check that this is the case using ms_mascotresfile::getQuantitationMethod and ms_quant_method::getProtocol

This function was added in Mascot Parser 2.5. If the calling application is Using the ms_peptidesummary cache and the cache files were created with Mascot Parser 2.4 or earlier, then this function will calculate the intensities on demand. The first call to this function causes values for the whole file to be calculated, which may be slow. With new cache files, all the values are saved in the cache file.

This function will only calculate values for cases where ms_quant_helper::isPeptideQuantifiable returns ms_quant_helper::PEPTIDE_IS_QUANTIFIABLE

For a particular q,p pair there will always be values for all components or for no components. There can never be a case where there is just a value available for a subset of the components.

Parameters:
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue(). For "reporter" protocols, this must be 1.
componentName | is the name of the component as defined in the method. For example, for iTRAQ this might be "114", and for one of the SILAC methods this might be "Heavy".
[out] | value | is the corrected intensity value. Corrections are applied as specified in the method included in the results file.
[out] | rawValue | is the uncorrected intensity value.
Returns:
false if the method is unable to calculate or determine an intensity value for the specified q and p values

Implements ms_mascotresults.

const ms_protein * getComponentProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [virtual, inherited]

Return a pointer to the protein entry given an accession.

Only use this function for the "components" of a UniGene search. It will generally be more convenient for client applications to call ms_protein::getComponent() to get an ms_protein object, both in UniGene searches and PMF mixture searches.

Parameters:
accession | is the accession string.
dbIdx | a database index (1..ms_searchparams::getNumberOfDatabases()).
Returns:
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

std::string getComponentString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual]

Return an empty string.

Note:
This function will always return the empty string for a protein summary.

The entry in the results file might be, for example:

   q1_p2_comp=light

For a crosslinked match, the results file line is q1_p1_comp_1= or q1_p1_comp_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

See also ms_peptide::getComponentStr().

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | is the 'rank' number, which should be in the range 1..10.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns:
the full component string for a peptide summary, and the empty string for a protein summary.

Implements ms_mascotresults.

bool getCreateSummaryProgress | ( | int * | cspTotalPercentComplete,
 |  | unsigned int * | cspCurrTask,
 |  | int * | cspCurrTaskPercentageComplete,
 |  | std::string * | cspAccession,
 |  | int * | cspHit,
 |  | int * | cspQuery,
 |  | std::string * | cspKeepAliveText
 | ) |  | const [inherited]

Return progress for the createSummary() call.

See Multiple return values in Perl, Java, Python and C#.

This function is most useful when using the ms_peptidesummary::MSPEPSUM_DEFERRED_CREATE flag and calling createSummary() from a separate thread. The ms_mascotresfile::outputKeepAlive() outputs progress text to stdout, and this may not be convenient for some applications.

Any of the passed parameters may be null.

Parameters:
[out] | cspTotalPercentComplete | is simply calculated from: 100 * cspCurrTask / ms_mascotresfile::KA_LAST + cspCurrTask / ms_mascotresfile::KA_LAST
[out] | cspCurrTask | is the ms_mascotresfile::KA_TASK currently being performed by Mascot Parser. If Parser is doing nothing, then this will be the last task that was completed and cspCurrTaskPercentageComplete will be 100
[out] | cspCurrTaskPercentageComplete | is the percentage (0..100) complete for the current cspCurrTask.
[out] | cspAccession | is the current 'accession' being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value. For languages other than C++, this will be a reference rather than a pointer to a std::string.
[out] | cspHit | is the current hit being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value
[out] | cspQuery | is the current 'query' being processed. See ms_mascotresfile::outputKeepAlive() for details of which tasks set this value
[out] | cspKeepAliveText | is the text that would be output by ms_mascotresfile::outputKeepAlive(). To use this, specify a suitable keepAliveText to the ms_mascotresfile constructor but set keepAliveInterval to zero to prevent any output to stdout. For languages other than C++, this will be a reference rather than a pointer to a std::string.
Returns:
true if the createSummary() call has completed.
std::vector< double > getDiscoveredErrTolModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const [virtual, inherited]

Return the deltas of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification deltas. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

The list of error tolerant modification deltas is most useful when used in combination with getNumDiscoveredErrTolMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredErrTolModNames()

Nucleic acid insertion, deletion and substitution whose special names are NA_INSERTION, NA_DELETION and NA_SUBSTITUTION have a delta of 0.0.

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns:
A vector of error tolerant modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< std::string > getDiscoveredErrTolModNames ( ) const [virtual, inherited]

Return the names of all error tolerant modifications discovered in this search.

Only significant rank 1 matches assigned to a protein hit contribute towards the list of error tolerant modification names. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted. Nucleic acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

The list of error tolerant modification names is most useful when used in combination with getNumDiscoveredErrTolMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
A vector of error tolerant modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< double > getDiscoveredLocalModDeltas ( std::vector< std::string > * vecDeltaStrings = NULL ) const [virtual, inherited]

Return the deltas of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

The order of the elements in the return or parameter vector is the same as in the vector returned by getDiscoveredLocalModNames()

Note that this is not available if the cache file was created with Parser 2.5 or 2.6. Recreating the cache file makes this available.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
vecDeltaStrings Pointer to a vector of strings to retrieve the deltas as strings instead of as doubles, if this pointer is valid then the returned vector is empty
Returns:
A vector of query-level modification deltas discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
std::vector< std::string > getDiscoveredLocalModNames ( ) const [virtual, inherited]

Return the names of all query-level modifications discovered in this search.

The list of query-level modification names is most useful when used in combination with getNumDiscoveredLocalMods().

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
A vector of query-level modification names discovered in significant rank 1 matches assigned to a protein hit in this search. The vector could be empty.
double getErrTolModDelta | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL,
 |  | std::string * | deltaAsString = NULL
 | ) |  | const [virtual, inherited]

Return the error tolerant mod delta from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification delta will be 0.984020. In general, modification delta could be any valid floating point number, including 0.0.

See also:
getErrTolModName(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the delta directly
deltaAsString
Returns:
The modification delta.
std::vector< double > getErrTolModMasterNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod additional primary neutral losses from h1_q2_et_mods_master or q1_p1_et_mods_master.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p1_et_mods_master might be

   q1_p1_et_mods_master=1.0,2.0

The returned list will not contain the dominant neutral loss -- that can be retrieved using getErrTolModNeutralLoss().

See also:
getErrTolModSlaveNeutralLoss() and getErrTolModNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification additional primary neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModMasterString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod primary neutral loss string from h1_q1_et_mods_primary.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_master might be
       q1_p2_et_mods_master=1.0,2.0
  • The entry in h1_q2_et_mods_master might be
       h1_q2_et_mods_master=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModMasterNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant master neutral loss string.

Implements ms_mascotresults.

std::string getErrTolModName | ( | const int | q,
 |  | const int | p,
 |  | std::string * | modString = NULL
 | ) |  | const [virtual, inherited]

Return the error tolerant mod name from h1_q2_et_mods or q1_p1_et_mods.

The entry in, for example, q1_p2_et_mods might be

   q1_p2_et_mods=0.984020,0.000000,Citrullination

where the modification name will be Citrullination.

See also:
getErrTolModDelta(), getErrTolModNeutralLoss() and getReadableVarMods()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
modString | Optional pointer to a modString, if it is NULL or empty the modString is looked up in the result file, if the pointed string is empty its value is set from the result file, if it is already set to a value, this value is used to retrieve the name directly
Returns:
The modification name, or empty string if this match has no ET modification.
double getErrTolModNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod neutral loss from h1_q2_et_mods or q1_p1_et_mods.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than 10 of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods might be

   q1_p1_et_mods=79.966330,97.976898,Phospho (STY)

where the highest scoring modification neutral loss, returned by this function is 97.976898.

See also:
getErrTolModName(), getErrTolModDelta(), getReadableVarMods(), getErrTolModMasterNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification neutral loss value.
std::vector< double > getErrTolModPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_pep or q1_p1_et_mods_pep.

Some modifications specify one or more peptide neutral losses. PepNeutralLoss allows a neutral loss from the precursor to be specified so that this peak is not treated as a noise peak when being scored by Mascot. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_pep might be

   q1_p1_et_mods_pep=97.976896, 79.966330
See also:
getErrTolModReqPepNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification peptide neutral loss values as a vector of doubles See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod peptide neutral loss string from h1_q1_et_mods_pep.

ms_mascotresults::getErrTolModPepString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
complete error tolerant peptide neutral loss string

Implements ms_mascotresults.

std::vector< double > getErrTolModReqPepNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod peptide neutral losses from h1_q2_et_mods_reqpep or q1_p1_et_mods_reqpep.

Some modifications specify one or more required peptide neutral losses. ReqPepNeutralLoss performs the same function as PepNeutralLoss but with the additional condition that the peak must be present in the spectrum. The ability to specify peptide neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_reqpep might be

   q1_p1_et_mods_reqpep=97.976896, 79.966330
See also:
getErrTolModPepNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification required peptide neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModReqPepString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod required peptide neutral loss string from h1_q1_et_mods_reqpep.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_et_mods_reqpep might be
       q1_p2_et_mods_reqpep=1.0,2.0
  • The entry in h1_q2_et_mods_reqpep might be
       h1_q2_et_mods_reqpep=1.0,2.0

This function returns the complete string value. A more useful function is ms_mascotresults::getErrTolModReqPepNeutralLoss().

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete error tolerant required peptide neutral loss string.

Implements ms_mascotresults.

std::vector< double > getErrTolModSlaveNeutralLoss | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual, inherited]

Return the error tolerant mod slave neutral losses from h1_q2_et_mods_slave or q1_p1_et_mods_slave.

Some modifications specify one or more neutral losses. These can be specified as 'master' or 'slave' neutral losses. If there are multiple neutral losses, then at least one and less than ten of the definitions must be masters.

During a search, Mascot iterates through the master neutral losses. The one that gives the highest score is chosen, and all the other neutral losses are treated as slaves. If a slave neutral loss gives a match to a peak, that peak is removed from the list of noise peaks, which further enhances the score. The ability to specify multiple neutral losses was introduced in Mascot 2.1.

The entry in, for example, q1_p2_et_mods_slave might be

   q1_p2_et_mods_slave=1.0,2.0
See also:
getErrTolModMasterNeutralLoss(), getErrTolModNeutralLoss()
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
The modification slave neutral loss values as a vector of doubles. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getErrTolModSlaveString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod slave neutral loss string from h1_q1_et_mods_slave.

ms_mascotresults::getErrTolModSlaveString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
complete error tolerant slave neutral loss string

Implements ms_mascotresults.

std::string getErrTolModString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete error tolerant mod string from h1_q2_et_mods or q1_p1_et_mods.

ms_mascotresults::getErrTolModString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
complete error tolerant modification string.

Implements ms_mascotresults.

double getErrTolProbabilityThreshold ( ) const [virtual, inherited]

Return the probability threshold used for error tolerant peptides.

For a protein summary, this method always returns the same value as getProbabilityThreshold().

Error tolerant matches in an integrated error tolerant search can have a different probability threshold (significance threshold) from first pass peptide matches. The first pass matches always use getProbabilityThreshold() as the significance threshold, and second pass matches always use getErrTolProbabilityThreshold().

The error tolerant significance threshold is determined using ms_mascotresults_params::getTargetFDR(). If a target FDR is specified and the search is an error tolerant target-decoy search, the probability threshold is chosen such that error tolerant matches have false discovery rate (FDR) equal to the target or as close as feasible. If the search is not a target-decoy search or target FDR is not specified, the error tolerant significance threshold is the same as the first pass significance threshold.

See also:
getProbabilityThreshold(), Error tolerant searches
Returns:
probability threshold for error tolerant matches.
unsigned int getFlags ( ) const [inline, inherited]

Returns the flags value passed to the constructor.

Returns:
the ms_mascotresults::FLAGS value.
unsigned int getFlags2 ( ) const [inline, inherited]

Return the flags2 value passed to the ms_peptidesummary constructor.

For an ms_proteinsummary, will always return 0 as there is no option to set the flags2 value.

Returns:
the ms_peptidesummary::MSPEPSUM value.
ms_protein * getHit | ( | const int | hit,
 |  | const int | memberNumber = 0
 | ) |  | const [virtual, inherited]

Return the ms_protein hit - returns null if hit > number of hits.

Parameters:
hit | should be in the range 1.. getNumberOfHits().
memberNumber | Should be 1 or less for a main protein or one not in a family, or 2 or more for later sibling proteins in the hit family. If this number is greater than the number of proteins in the hit family then the function returns a null value.
Returns:
If the hit number is outside the range above, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

Examples:
peptide_list.cpp, and resfile_summary.cpp.
int getHomologyThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1
 | ) |  | const [virtual, inherited]

Returns the 'homology' threshold.

For MS-MS data only, this returns a threshold value for significant homology rather than identity. This value appears in the yellow popup box for an MS-MS result: Score greater than XX indicates homology.

The return value will be zero if the threshold is not available. The value cannot be determined if the query contains error tolerant matches, or if the query contains a tag or etag, or if the value of qmatch is less than or equal to 100.

The value returned will not be higher than the identity threshold.

In versions prior to 2.2, the homology threshold was not affected by OneInXprobRnd -- this was corrected in version 2.2.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. You can either pass ms_peptide::getRank() as the rank parameter, or use one of the enumerated values for HOMOLOGY_THRESHOLD_SOURCE. The rank determines the data source.

In an integrated spectral library search:

  • If rank = HOMTHR_FASTA, the method returns the FASTA homology threshold.
  • If the peptide at the given rank is from a FASTA database and is not a library match, the method returns the FASTA homology threshold.
  • If rank = HOMTHR_SL, the method returns zero (since library searches don't have a homology threshold).
  • If the peptide at the given rank is from a spectral library, the method returns zero.

In an integrated error tolerant search, behaviour depends on Mascot version. If the results file is from Mascot 2.8 or later:

  • If the query was selected for the second pass search, the method returns zero regardless of the rank argument.
  • If the query was only searched in the first pass, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().

If the integrated error tolerant search is from Mascot 2.7 or earlier:

  • If rank = HOMTHR_FASTA, the method returns the first pass homology threshold. The OneInXprobRnd argument is ignored; the homology threshold is calculated using 1 / getProbabilityThreshold().
  • If the peptide at the given rank is a first pass match, the method returns the first pass homology threshold.
  • If the peptide at the given rank is an ET match, the method returns 0.
Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
Returns:
The homology threshold. If there was no MS-MS data for this query then 0 will be returned.
Examples:
resfile_summary.cpp.
int getHomologyThresholdForHistogram | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Returns the value for the 'yellow section' in the histogram.

For MS-MS data only, this returns a homology (rather than identity) threshold value that is shown at the top of the report: Individual ions scores > 19 indicate peptides with significant homology (p<0.05).

The yellow area on the histogram also corresponds to this value.

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot homology threshold. If dbType is DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The homology threshold. Note that this value is only available for an MS-MS search with just one MS-MS data set, otherwise the return value will be zero.
double getIonsScore | ( | const int | q,
 |  | const int | p,
 |  | const bool | decoy
 | ) |  | const [virtual]

Returns an ions score quickly without having to load an ms_peptide object.

If other values are required from the ms_peptide object, then it is normally faster to call getPeptide() and then ms_peptide::getIonsScore

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
decoy | is a flag to indicate if the score should be taken from the decoy section. This should only be set to true for searches with decoy matches.
Returns:
the score, or 0 if there was no score for these q / p values.

Implements ms_mascotresults.

double getIonsScoreCorrected | ( | const double | ionsScore,
 |  | const long | multiplicity
 | ) |  | const [protected, inherited]
Note:
It shouldn't be necessary to call this function from outside the library.

This function is required here rather than as part of the ms_peptide object because one ms_peptide object can be used from many different proteins -- each with a different multiplicity factor.

This function subtracts the factor:

  • -10 * log(multiplicity) * $tolFact / log(10); where
  • tolFact = sqrt(ITOL * ITOL + 0.0625);
Parameters:
ionsScore | Is the uncorrected ions score.
multiplicity | can be obtained from ms_protein::getPeptideMultiplicity.
Returns:
The corrected value..
std::vector< int > getIonsScoreHistogram | ( | IONS_HISTOGRAM | flags = IH_INCLUDE_TOP_MATCHES,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Returns a list of counts for binned ions scores.

  • The first element of the array returns the count of matches with a score between 0 and 1.
  • The second element of the array returns the count of matches with a score between 1 and 2.
  • The third element of the array returns the count of matches with a score between 2 and 3. etc. etc.
Parameters:
flags | Currently only IH_INCLUDE_TOP_MATCHES and IH_INCLUDE_TOP_10_MATCHES are supported.
dbType | If given, should be DM_FASTA for Mascot scores and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, empty vector is returned.)
Returns:
a vector of integers. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getLibraryModString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the modification string of the spectral library match from q1_p1_SLmod.

ms_mascotresults::getLibraryModString(const int, const int) const

Parameters:
q | query
p | rank
Returns:
modification string of the match if it is a spectral library match and has modifications, an empty string otherwise.

Implements ms_mascotresults.

int getMaxPeptideIdentityThreshold | ( | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Return the max threshold value for all MS-MS data sets.

The maximum value is calculated by taking the maximum value returned by calling getPeptideIdentityThreshold() for each query. This is the value that is shown at the top of the standard Mascot peptide summary report (version 2.0 and later). For example, threshold in the following string could be calculated by calling getMaxPeptideIdentityThreshold(20):

Individual ions scores > 47 indicate identity or extensive homology (p<0.05).

Versions of Mascot prior to 2.0 displayed the equivalent of getAvePeptideIdentityThreshold().

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
The maximum score threshold. If there was no MS-MS data then -1 will be returned.
int getMaxRankValue ( ) const [virtual, inherited]

Returns the maximum 'rank' or 'hit' or 'p' value.

For functions such as getPeptide(), a 'rank' or 'hit' value is required. The allowable range for this values depends on whether it is a protein summary or peptide summary.

For a peptide summary the value returned will normally be 10, but for an integrated error tolerant search, integrated spectral library search and integrated crosslinked search, this can be in the range 1..20.

For a protein summary the return value will be ms_mascotresfile::getNumHits() -- with the appropriate parameter passed for the case of a decoy or error tolerant search.

Returns:
max rank value
int getMinPepLenInPepSummary ( ) const [inherited]

Peptides shorter than this are ignored when putting proteins into groups.

minPepLenInPepSummary is an optional flag for the peptide summary only. Any peptides shorter than this will be ignored when grouping proteins together.

Specify this value when creating an ms_peptidesummary::ms_peptidesummary object. This value will always be zero for ms_proteinsummary.

Returns:
The minimum peptide length considered when creating the peptide summary.
ms_protein * getNextFamilyProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Find the next protein in the family masterHit.

Call this function multiple times for each masterHit, incrementing id each time. When there are no more protein families this function will return a null value.

The main protein for the hit should be obtained by calling ms_mascotresults::getHit()

See Using MSRES_CLUSTER_PROTEINS for further information.

See also:
ms_protein::GROUP
Parameters:
masterHit | is the id for the main hit (1..n).
id | is a 'one based' number.
Returns:
The next protein family or a null value if there is no such group. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
ms_protein * getNextSimilarProtein | ( | const int | masterHit,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP
Parameters:
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
Returns:
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
ms_protein * getNextSimilarProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Return the next protein that contains all the peptides in the 'master' protein.

Find the next protein that contains exactly the same set of peptides as the 'master' one. See Grouping proteins together for further information. Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP
Parameters:
masterAccession | is the accession for the main hit.
masterDB | is the database (FASTA) ID for the main hit.
id | is a 'one based' number.
Returns:
The next protein with the same set of peptides as the masterAccession or a null value if there are no such proteins. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
ms_protein * getNextSubsetProtein | ( | const int | masterHit,
 |  | const int | id,
 |  | const bool | searchWholeFamily = true
 | ) |  | const [virtual, inherited]

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information. Call this function multiple times for each masterHit, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP, getNextSubsetProteinOf()
Parameters:
masterHit | is a 'one based' number for the main hit.
id | is a 'one based' number.
searchWholeFamily | only has meaning when MSRES_CLUSTER_PROTEINS is specified. See Using MSRES_CLUSTER_PROTEINS.
Returns:
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
ms_protein * getNextSubsetProteinOf | ( | const char * | masterAccession,
 |  | const int | masterDB,
 |  | const int | id
 | ) |  | const [virtual, inherited]

Return the next protein that contains some of the peptides in the 'master' protein.

Find the next protein that contains a subset of same peptides as the 'master' one. See Grouping proteins together and setSubsetsThreshold() for further information.

Call this function multiple times for each masterAccession, incrementing id each time. When there are no more proteins containing the same set of peptides, this function will return a null value.

See also:
ms_protein::GROUP, getNextSubsetProtein()
Parameters:
masterAccession | is the accession for the master hit or a family hit.
masterDB | is the database (fasta) ID for the main hit.
id | is a 'one based' number.
Returns:
A protein that contains a subset of peptides in the master protein, or a null value if there is no such protein. See Maintaining object references: two rules of thumb.
Examples:
resfile_summary.cpp.
int getNumberOfFamilyMembers ( ) const [virtual, inherited]

Return the total number of family members.

Returns:
This function returns the number of 'top level' hits and family members, not taking into account any proteins that are identical or subsets of these hits. The value will be identical to that returned by getNumberOfHits() unless the ms_mascotresults::MSRES_CLUSTER_PROTEINS flag has been specified. In that case the number of values returned by getNextFamilyProtein() will be included.
int getNumberOfHits ( ) const [virtual, inherited]

Returns the number of hits in the results.

Returns:
This function returns the number of 'top level' hits -- not taking into account any proteins that are identical or subsets of the 'top level' hits. ms_mascotresults::getHit() can be called with any number from 1 to the value returned by this function.
int getNumberOfUnassigned ( ) const [inherited]

Return the number of peptides in the unassigned list.

See Unassigned peptides list for details of creating and using an unassigned list.

If there is no cache file for the results, then createUnassignedList() must be called before calling this function or the ms_mascotresfile::ERR_UNASSIGNED_PROG error will be set, and this function will return 0.

If a cache file has been created, then there is no requirement to call createUnassignedList() before calling this function.

Returns:
the number of peptides in the unassigned list, or 0 in the case of an error.
Examples:
resfile_summary.cpp.
long getNumDecoyHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits from the decoy search with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold(). These values may be slightly different from the threshold for the non-decoy matches.

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

y* The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of decoy hits with a score at or above the homology threshold.
long getNumDecoyHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits from the decoy search with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold(). This value may be slightly different from the threshold for the non-decoy matches.

For a protein summary, the number of hits is the number of protein matches. This number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of decoy hits with a score at or above the identity threshold.
std::vector< int > getNumDiscoveredErrTolMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of error tolerant modifications discovered in this search.

The number of times an error tolerant modification has been discovered in the search is the number of times it appears in rank 1 matches in the search results. Since the number and kind of error tolerant modifications is (practically) unlimited, you should call getDiscoveredErrTolModNames() first to find out which error tolerant modifications appear in the search. (The count of error tolerant modifications that do not appear in the search is, of course, zero.) Amino acid insertion, deletion and substitution have the usual special names NA_INSERTION, NA_DELETION and NA_SUBSTITUTION. Otherwise error tolerant modification names follow Unimod names.

Only significant rank 1 matches assigned to a protein hit are counted. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the error tolerant modification of that match is not counted.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the error tolerant modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modName | Error tolerant modification name (as returned by getDiscoveredErrTolModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the error tolerant modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredFixedMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of fixed modifications discovered in this search.

The number of times a fixed modification has been discovered in the search is the number of times the terminus or residue matching its specificity appears in significant rank 1 matches assigned to a protein hit in the search results. For example, if Carbamidomethyl (C) is specified as a fixed modification, then the number of times it has been discovered in the search is the number of C residues in peptide sequences in significant rank 1 matches assigned to a protein hit.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the fixed modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a fixed modification with two different specificities in the search, discovery counts will be returned separately. For example, if fixed modification 1 is Carbamidomethyl (C) and 2 is Carbamidomethyl (N-term), then calling getNumDiscoveredFixedMods() with num = 1 returns the Carbamidomethyl count for specificity "Anywhere" and "C", while num = 2 returns the count for specificity "Any N-term" and "N-term". In both cases each vector contains a single item.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
num | Fixed modification number (same value as passed to ms_searchparams::getFixedModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the fixed modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredIntactLinks | ( | std::vector< int > & | varModNum1,
 |  | std::vector< std::string > & | position1,
 |  | std::vector< std::string > & | site1,
 |  | std::vector< int > & | varModNum2,
 |  | std::vector< std::string > & | position2,
 |  | std::vector< std::string > & | site2,
 |  | std::vector< int > & | numLinkedPeptides
 | ) |  | const [inherited]

Return the count of intact crosslinks in this search.

The number of times an intact crosslink has been discovered in the search is the number of times it appears as the intact link in significant rank 1 matches assigned to a protein hit.

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the link occurred, while varModNum1, position1 and site1 have the variable mod number, position and site of the first end of the link and varModNum2, position2 and site2 have the second end.

For example, if the ith specificity is N-terminal K, the ith element of alphaPositions would be "Any N-term" and the ith element of alphaSites would be "K".

In the simplest case, there is one linker with one specificity, say Xlink:DSS (K). All the vectors have just one element. If the linker has two specificities, like Xlink:DSS (K) and Xlink:DSS (Protein N-term), there will be three site pairs: (K, K), (K, Protein N-term) and (Protein N-term, Protein N-term). The pair (Protein N-term, K) is collated with (K, Protein N-term).

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
varModNum1 | Variable modification number for the first end of link.
position1 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site1 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
varModNum2 | Variable modification number for the second end of link.
position2 | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
site2 | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
numLinkedPeptides | A vector containing the number of linked peptides corresponding to each count. Looplinked counts have 1 peptide, while crosslinked counts have 2 peptides.
Returns:
The number of times the intact link was observed in significant rank 1 matches assigned to a protein hit.
std::vector< int > getNumDiscoveredLibraryMods | ( | const int | modId,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [inherited]

Return the count of library modifications discovered in this search.

The number of times a library modification has been discovered in the search is the number of times it appears in the library mods string in significant rank 1 spectral library matches assigned to a protein hit in the search results.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the library modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that modifications are part of the metadata of spectral library entries. Unlike in database searches, they are not specified as part of the search parameters. Some caveats apply:

  • A library modification may have the same name as a variable or fixed modification in the database search, and they may well be the same modification -- but you need to know how the library was constructed to conclude either way.
  • Library modification name is usually a free-text string, which may or may not be a Unimod modification name.
  • The MSP format for spectral libraries does not support specifities in the same way as Mascot. The "position" of the modification is not encoded in the library and is thus unknown; it will always be Anywhere.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modId | modification ID, same as passed to ms_searchparams::getLibraryModName(). Must be in range 1..ms_searchparams::getNumberOfLibraryMods().
positions | A vector of positions, always "Anywhere".
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the library modification was observed in significant rank 1 spectral library matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredLocalMods | ( | const std::string | modName,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of query-level modifications discovered in this search.

The number of times a query-level modification has been discovered in the search is the number of times it appears in significant rank 1 matches assigned to a protein hit in the search results.

Query-level modifications are counted separately from variable modifications (specified at search form level), because each individual query may contain up to 32 query-level variable modifications. This means the search as a whole may contain more than 32 different query-level modifications. You should call getDiscoveredLocalModNames() first to find out which query-level modifications appear in the search.

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the query-level modification occurred at specificity i. The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that only significant rank 1 matches assigned to a protein hit are counted.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
modName | Query-level modification name (as returned by getDiscoveredLocalModNames()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the query-level modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
int getNumDiscoveredNonSpecCleavage ( ) const [virtual, inherited]

Return the count of non-specific cleavages in an error tolerant search.

An error tolerant match is the product of non-specific cleavage when the residue before or after the peptide terminal residue does not match the cleavage specificity of the enzyme. For example, trypsin cleaves at C-term K or R (unless followed by P), so all tryptic peptide sequences have K or R as the (N-term) residue before the sequence. An error tolerant match with non-specific cleavage would have a residue other than K or R at N-terminus.

Only significant rank 1 matches assigned to a protein hit contribute towards the count of non-specific cleavages. This means that if the error tolerant match is not the rank 1 match (e.g. the same query had a higher scoring regular peptide match), then the match is not counted.

Returns:
The number of times non-specific cleavage occurred in significant rank 1 matches assigned to a protein hit, or -1 for non-error tolerant search.
std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites,
 |  | std::vector< double > & | deltas,
 |  | std::vector< std::string > & | names
 | ) |  | const [virtual, inherited]

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in five vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

The ith element in the deltas and names vectors defines the delta and name of the modification, respectively. If the search has no crosslinking method, these two parameters can be ignored. When the modification number num refers to a crosslinker, the the deltas and names vectors contain values for all monolinks represented by the entry.

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
deltas | A vector of deltas.
names | A vector of names.
Returns:
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
std::vector< int > getNumDiscoveredVariableMods | ( | const int | num,
 |  | std::vector< std::string > & | positions,
 |  | std::vector< std::string > & | sites
 | ) |  | const [virtual, inherited]

Return the count of variable modifications discovered in this search.

The number of times a variable modification has been discovered in the search is the number of times it appears in the variable mods string in significant rank 1 matches assigned to a protein hit in the search results.

Note that error tolerant matches are not included in these counts; see getNumDiscoveredErrTolMods(). Query-level variable modifications are counted separately as well; see getNumDiscoveredLocalMods().

Count data is returned in three vectors of equal length. The ith element in the returned vector of integers is the number of times the variable modification occurred at specificity i.

The ith element in the positions and sites vectors defines the position and site of the ith specificity. For example, if the ith specificity is N-terminal K, the ith element of positions would be "Any N-term" and the ith element of sites would be "K".

If caching is in use and the cache file contains modification counts, then the count data is loaded straight from the cache. Otherwise the first call to anyNumDiscoveredMods(), getNumDiscoveredFixedMods(), getNumDiscoveredVariableMods(), getNumDiscoveredLocalMods(), getNumDiscoveredLibraryMods(), getNumDiscoveredIntactLinks(), getNumDiscoveredErrTolMods() or getNumDiscoveredNonSpecCleavage() causes a loop over all queries to be run and modifications to be counted, which may be slow if the search results are very large.

Note that if the same modification is specified as a variable modification with two different specificities in the search, discovery counts will be returned separately. For example, if variable modification 1 is Phospho (ST) and 2 is Phospho (Y), then calling getNumDiscoveredVariableMods() with num = 1 returns the Phospho counts for specificities "Anywhere" "S" and "Anywhere" "T", while num = 2 returns the count for specificity "Anywhere" "Y".

Note also that since error tolerant modifications are not included in counts of variable modifications, it is possible (though unlikely) for a modification to appear both as variable (specified explicitly in the search) and as error tolerant, especially if the two instances have different specificities.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

See also:
getNumDiscoveredVariableMods(const int, std::vector<std::string>&, std::vector<std::string>&, std::vector<delta>&, std::vector<std::string>&) const
Parameters:
num | Variable modification number (same value as passed to ms_searchparams::getVarModsName()).
positions | A vector of positions ("Anywhere", "Any N-term", "Any C-term", "Protein N-term", "Protein C-term") giving the position part of the count specificity.
sites | A vector of sites (amino acids A-W, "N-term", "C-term") giving the site part of the count specificity.
Returns:
The number of times the variable modification was observed in significant rank 1 matches assigned to a protein hit in this search at each specificity, returned in positions and sites.
long getNumHitsAboveHomology | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits with a score at or above the homology threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The homology threshold is retrieved using getPeptideHomologyThreshold(). If there is no homology threshold, then the identity threshold is used, which is retrieved using getPeptideIdentityThreshold().

For a protein summary, this function will always return -1 because there is never a homology threshold for the protein summary.

The first call to any of the following functions may take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of hits with a score at or above the homology threshold.
long getNumHitsAboveIdentity | ( | double | OneInXprobRnd,
 |  | DECOY_STATS_COUNT_TYPE | countType = DS_COUNT_PSM,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | [virtual, inherited]

Return the number of hits with a score at or above the identity threshold.

For a peptide summary, the number of hits is the number of peptide matches. The value is not affected by ignoreIonsScoreBelow and the count only includes rank 1 peptides. The returned value will be affected by the minProbability value passed to the ms_peptidesummary constructor. The identity threshold is retrieved using getPeptideIdentityThreshold().

For a protein summary, the number of hits is the number of protein matches. The number includes the number of protein mixture matches plus the number of single protein matches. The returned value will be affected by the minProbability value passed to the ms_proteinsummary constructor. A value of -1 will be returned if the search contained any MS-MS, sequence query or tag data. The identity threshold is retrieved using getProteinThreshold().

The first call to any of the following functions make take some time as the values are not calculated when the ms_peptidesummary or ms_proteinsummary object is created. All four values are cached when the first call is made.

  • getNumHitsAboveIdentity()
  • getNumDecoyHitsAboveIdentity()
  • getNumHitsAboveHomology()
  • getNumDecoyHitsAboveHomology()

However, calling a function with a different probability threshold will cause the cached values to be re-calculated.

The false discovery rate (FDR) can be calculated from

   getNumDecoyHitsAboveIdentity() / getNumHitsAboveIdentity()

or

   getNumDecoyHitsAboveHomology() / getNumHitsAboveHomology()
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
countType | In peptide summary, type of object to count, either peptide-spectrum matches (PSMs) or distinct peptide sequences. The default, DS_COUNT_PSM, is the only mode available in Parser 2.5 and earlier. In protein summary, the argument is ignored.
dbType | In peptide summary, source of peptides being counted, either Mascot matches in FASTA sequences or spectral library matches. The default is DM_FASTA, which is the only mode available in Parser 2.5 and earlier. In an integrated ET search, DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return counts for first pass and second pass only, while DM_FASTA returns counts for both passes. In protein summary, the argument is ignored.
Returns:
The number of hits with a score at or above the identity threshold.
int getNumPmfQueriesUsed ( ) const

Returns number of queries (masses) used when calculating PMF protein scores.

See isPmfQueryUsed() for a detailed explanation.

Returns:
The number queries (masses) used for calculating protein scores.
std::vector< int > getPepsWithSameScore | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Returns a list of 'p' values for peptides with the same score.

Peptides with the same score will have the same pretty rank. See ms_peptide::getPrettyRank() for details.

It is preferable to call this function rather than to loop through all the ranks calling getPeptide() for each one because the cached index stores the pretty ranks and this should therefore be faster.

For a protein summary, the returned list always contains a single value that is the same as the passed p value.

Parameters:
q | is the query number.
p | is the 'hit' or 'rank' number in the range 1.. getMaxRankValue().
Returns:
a list of the ranks that have the same pretty value. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Implements ms_mascotresults.

bool getPeptide | ( | const int | q,
 |  | const int | p,
 |  | ms_peptide *& | pep
 | ) |  | const [virtual]

Return a peptide object for the specified query / hit.

Note:
This function can not be used in programming languages other than C++.

To get the q and p values for a peptide in an ms_protein, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfile::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries()
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
pep | is reference to a pointer to an ms_peptide object that will be returned.
Returns:
true if the peptide exists.

Implements ms_mascotresults.

ms_peptide getPeptide | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return a peptide object for the specified query / hit.

To get the q and p values for a peptide in an ms_protein object, call ms_protein::getPeptideQuery() and ms_protein::getPeptideP().

An 'empty' peptide object will be returned if

  • q or p are invalid (the error ms_mascotresfile::ERR_PEPSUMMPEPGET will also be set) or
  • there was no match to this peptide.

To test for an 'empty' peptide, use ms_peptide::getAnyMatch().

Parameters:
q is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence p must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
Returns:
an ms_peptide object.

Implements ms_mascotresults.

double getPeptideExpectationValue | ( | const double | score,
 |  | const int | query,
 |  | const int | rank = 0
 | ) |  | const [virtual, inherited]

Returns the expectation value for the given peptide score and query.

Returns the number of peptides that you would expect to get this score or higher from this database. This value is displayed as the expectation value in Mascot 2.0 and later reports. When the value is below 1, it approximates the p-value corrected for multiple testing.

For Mascot matches, the expectation value is calculated from

    E = Pthreshold * (10 ** ((Sthreshold - score) / 10))

For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

The Sthreshold value is the value returned by getHomologyThreshold() if ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH was specifed in the ms_peptidesummary constructor, otherwise the value used is the one returned from getPeptideIdentityThreshold().

Parser 2.8 and later can calculate expectation values for Mascot error tolerant matches. The value is based on the combined first and second pass identity threshold. If rank is zero, getPeptideExpectationValue() assumes the score is a first pass match score and calculates the value from the first pass identity or homology threshold. If rank is non-zero, the correct threshold is chosen based on the match at rank rank in this query.

ET expectation value is only available if the results file is from Mascot 2.8 and later. When you open results from Mascot 2.7 and earlier, expectation value for ET matches is -1. Note that Parser 2.7 and earlier returned a non-negative but incorrect number for ET matches.

For spectral library matches, the expectation value formula depends on report mode.

  • In integrated mode (MSPEPSUM_SL_INTEGRATED), library scores are scaled internally so that their mean and standard deviation match the mean and standard deviation of significant rank 1 Mascot matches with the same sequence in the same query. See Library scores and thresholds.
  • In SL-only mode (MSPEPSUM_SL_ONLY), the expect value formula is
     E = 0.05 * 10 ** (-(s - 300)/100).
    For example, E = 0.05 for score 300.

Spectral library support was added in Mascot Parser 2.6. If rank is zero, which is the default in Parser 2.5 and earlier, the score is assumed to be a Mascot ions score. If rank is non-zero, the correct formula is chosen based on the type of the match at rank rank in this query.

See also:
getProteinExpectationValue()
Parameters:
score | is the Mascot score to be converted.
query | specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
rank | is the rank of the match of interest in this query.
Returns:
The number of peptides that you would expect to get this score or higher from this database, or -1 if it cannot be calculated.
int getPeptideIdentityThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | DB_MATCH_TYPE | dbType = DM_FASTA
 | ) |  | const [virtual, inherited]

Return the threshold value for this ms-ms data being a random match.

See also:
getAvePeptideIdentityThreshold()
Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
dbType | If given, should be DM_FASTA for Mascot identity threshold and DM_SPECTRAL_LIBRARY for spectral library threshold. DM_FASTA_FIRST_PASS and DM_FASTA_SECOND_PASS return the same threshold as DM_FASTA. (DM_BOTH is nonsensical; if given, -1 is returned.)
Returns:
A score threshold. If query is < 1 or > ms_mascotresfile::getNumQueries() then -1 will be returned. If there was no MS-MS data or no match for this query, then -1 will be returned.
Examples:
peptide_list.cpp, and resfile_summary.cpp.
double getPeptideThreshold | ( | const int | query,
 |  | double | OneInXprobRnd,
 |  | const int | rank = 1,
 |  | const THRESHOLD_TYPE | thresholdType = TT_PEPSUM_DEFAULT
 | ) |  | const [inherited]

Return either the identity or the homology threshold.

The default is to use identity thresholds for the original Peptide Summary and Select Summary reports. For the Family Summary grouping, homology thresholds are used, and this needs to be specified by using the ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH flag. (This flag is automatically set when using the ms_mascotresfile::get_ms_mascotresults_params helper function).

This function calls getPeptideIdentityThreshold() or getHomologyThreshold() as appropriate. If it calls getHomologyThreshold() and this returns 0, then the identity threshold is returned.

The rank parameter is mandatory in an integrated error tolerant (ET) search and integrated spectral library (SL) search. See getHomologyThreshold().

If the peptide match at rank rank is an ET match, and the results file is from Mascot Server 2.7 or earlier, then getPeptideIdentityThreshold() returns -1 and getPeptideThreshold() returns -1.

Parameters:
query | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries()
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20. It's easiest to always pass 1 / getProbabilityThreshold() as OneInXprobRnd.

  • This parameter is ignored in error tolerant search results. If the query was searched in the error tolerant pass, its significance is determined using 1 / getErrTolProbabilityThreshold(); otherwise using 1 / getProbabilityThreshold().
rank | Specifies the rank of the match of interest.
thresholdType | can be any one of the ms_mascotresults::THRESHOLD_TYPE values
Returns:
the threshold.
double getProbabilityThreshold ( ) const [virtual, inherited]

Return the minProbability value passed to the ms_mascotresults::ms_mascotresults constructor.

In a protein summary, the probability threshold specifies a cutoff point for protein scores, a cutoff for an Integrated error tolerant search and a threshold for calculating MudPIT scores.

In a peptide summary, the identity and homology thresholds of a peptide match are calculated from the probability threshold (significance threshold). This is the value of "Significance threshold p&lt;" shown in Mascot search reports.

getProbabilityThreshold() returns the currently active first pass significance threshold. The value may differ from the minProbability constructor argument if a target FDR has been specified. See ms_mascotresults_params::getTargetFDR().

If target FDR has not been specified, and if a value of <= 1e-18 or >= 1 is passed to the constructor, then a value of 1/20 (0.05) will be returned by this function. Otherwise it will just return the value passed to the ms_mascotresults::ms_mascotresults constructor.

In an error tolerant search, getProbabilityThreshold() may differ from the significance threshold used during the search, which was the basis for protein selection for the second pass. This is recorded as the first_pass_threshold= line in the results file header.

Error tolerant matches use an independent significance threshold, getErrTolProbabilityThreshold().

Returns:
probability threshold for peptide matches.
int getProbFromScore ( const double score ) const [virtual, inherited]

Returns a probability value given a score.

Warning:
Do not use this without fully understanding what the function returns. It is more likely that you will want to use getPeptideExpectationValue() or getProteinExpectationValue().
Parameters:
score is the Mascot score.
Returns:
probability calculated from p = pow(10.0, (score/10.0)).
double getProbOfPepBeingRandomMatch | ( | const double | score,
 |  | const int | query
 | ) |  | const [virtual, inherited]
Deprecated:
Use getPeptideExpectationValue().

Returns the inverse of getPeptideExpectationValue(). If, for example, the identity threshold (p<0.05) for a particular query is 30, and a value of 30 is passed to this function, then the return value will be 1/0.05. If, for the same search, a peptide of interest gets a score of 50, then this function will return a value of 1 / 0.00067 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getProbOfProteinBeingRandomMatch()
Parameters:
score | is the Mascot score
query | specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
Returns:
The probability.
Examples:
resfile_summary.cpp.
double getProbOfProteinBeingRandomMatch ( const double score ) const [virtual, inherited]
Deprecated:
Use getProteinExpectationValue().

Returns the inverse of getProteinExpectationValue(). If, for example, the identity threshold (p<0.05) for a PMF search is 56, and a value of 56 is passed to this function, then the return value will be 1/0.05. If, for the same search, a protein of interest gets a score of 90, then this function will return a value of 1 / 0.000025 which is the (inverse of) the p value corresponding to that score.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getProbOfPepBeingRandomMatch()
Parameters:
score is the Mascot score to be converted.
Returns:
The inverse of getProteinExpectationValue().
const ms_protein * getProtein | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [virtual, inherited]

Return a pointer to the protein entry given an accession.

Parameters:
accession is the accession string.
dbIdx is the database index (1..ms_searchparams::getNumberOfDatabases()).

  • For a PMF mixture in protein summary (see Peptide mass fingerprint mixtures), use the default value of 1 even if the component proteins are all from other databases.
Returns:
If the protein cannot be found in the results, then a null value is returned. See Maintaining object references: two rules of thumb.

Reimplemented in ms_peptidesummary.

std::string getProteinDescription | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [inherited]

Return protein description if available.

This method attempts to return the 'description line' for the given accession. The description line originated from the FASTA file that was searched. An empty string will be returned if the protein is not listed in the proteins section or the summary section of the results file.

Format in the proteins section is, for example:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search all, protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

The alternative way to get the description line is to call

     ms-getseq.exe [db] [accession] title

when nothing is returned by getProteinDescription(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

If the 'protein' is actually a UniGene entry, then the description line is taken by concatenating the Gene and the Title line for the relevant entry.

If the protein is a PMF mixture, then the description line will be of the format:

 * Mixture from proteins:"gi|1234","gi|5432","gi|9999"

If the protein comes from the reference database of a spectral library, then its description is not saved in the results file and this method returns the empty string. If the protein comes from the spectral library, it may or may not have a description, depending on how the library was created.

For a search against a decoy database, if the result is from the decoy section, then the description is prefixed with "Random sequence, was ", or if there is no description in the file, "Random sequence.". Depending on the configuration of the search, Random may also be Reversed or Shuffled.

Parameters:
accession | is the accession string.
dbIdx | database index used for the search.
Returns:
The description line or an empty string.
Examples:
resfile_summary.cpp.
double getProteinEmPAI | ( | const char * | accession,
 |  | const int | dbIdx = 1,
 |  | const int | length = -1
 | ) |  | const [virtual, inherited]

Return protein emPAI if available.

The Exponentially Modified Protein Abundance Index (emPAI) offers approximate, label-free, relative quantitation of the proteins in a mixture based on protein coverage by the peptide matches in a database search result. The key publication is

Ishihama, Y., et al.: Exponentially modified protein abundance index (emPAI) for estimation of absolute protein amount in proteomics by the number of sequenced peptides per protein (2005). Molecular & Cellular Proteomics 4:1265-1272.

The number of observed peptides is determined using the function ms_protein::getNumObservedForEmPAI().

Protein sequence length is needed for emPAI calculation. You have two options:

  1. Give the sequence length as an argument to this method. You will need to fetch it with e.g. ms-getseq.exe on the Mascot Server machine.
  2. Give no argument to the method. If the protein has a mass in the results file, the mass will be used to calculate an approximate sequence length.

If no sequence length is given and the protein has no mass in the results file, the method returns -1. If you know the mass of the protein but not its sequence length, you can use the following approximate formula:

length = floor(0.5 + mass / 111)

Here 111 Da is the average mass of an amino acid residue.

If ms_mascotresults::isEmPAIallowed() is false, this method returns -1.

Parameters:
accession | Protein accession.
dbIdx | Protein database index number.
length | Protein sequence length (optional). If the length is not given, protein mass from the results file will be used to approximate it. If protein mass is not available, the method returns -1.
Returns:
emPAI or -1, as described above.

Reimplemented in ms_peptidesummary.

double getProteinExpectationValue ( const double score ) const [virtual, inherited]

Returns the expectation value for the given protein score.

Returns the number of proteins that you would expect to get this score or higher from random matches for this search. For a score that is exactly on the default significance threshold, (p<0.05), the expectation value is also 0.05.

This value is displayed as the expectation value in Mascot 2.0 reports.

See also:
getPeptideExpectationValue()
Parameters:
score is the Mascot protein score to be converted.
Returns:
The expectation value.
double getProteinMass | ( | const char * | accession,
 |  | const int | dbIdx = 1
 | ) |  | const [inherited]

Return protein mass if available.

This method attempts to return the mass for the given accession. The protein mass is calculated during the Mascot search, and some, but not all, of these masses are saved in the results file. A value of zero will be returned if the protein is not listed in the proteins section or the summary section of the results file.

The format in the proteins section is, for example, for a protein of mass 79480.13 daltons:

   "gi|4838561"=79480.13,"(AF144646) heat shock protein 70 [Crassostrea gigas]"

When multiple databases are used for the search, all protein entries, except those from the first database, will have a database index as a prefix:

   "02::gi|483561"=...

Format in the summary section is, for example:

   h1=gi|4838561,1.89e+002,1.00,79480.13
   h1_db=01
   h1_text=(AF144646) heat shock protein 70 [Crassostrea gigas]

Again the protein entry will include the database index if there are more than one databases.

With the default settings, Mascot only saves description lines and masses in the proteins section for accessions that are most likely to be used in a report. If description lines for all proteins with a match were saved, then the results files could potentially be huge. You can control which description lines and masses are put into the proteins section by changing the entry for

ProteinsInResultsFile

in the options section of mascot.dat (see chapter 6 of the Mascot installation and setup manual).

If a mass of zero is returned by this function, then the alternative way to get the mass is to call

     ms-getseq.exe [db] [accession] seq

to get the sequence, and then call getSequenceMass(). See chapter 7 of the Mascot installation and setup manual for details of calling ms-getseq.exe.

Parameters:
accession | is the accession string.
dbIdx | database number (1..ms_searchparams::getNumberOfDatabases()).
Returns:
The protein mass or 0.0.
Examples:
resfile_summary.cpp.
int getProteinScoreCutoff ( double OneInXprobRnd ) const [virtual]

Return the 'protein' score value for cutting off results. Different for peptide and protein summary.

The protein probability cutoff is calculated differently for a protein summary and a peptide summary.

  • For a peptide summary, we want to display any proteins that contain even one significant peptide, which means the threshold is the same as getAvePeptideIdentityThreshold().

    For MudPIT scoring, any protein with a score greater than zero must have one or more peptides above the homology threshold, so this function returns a value of 1.

  • For a protein summary, we simply use the protein score that corresponds to the threshold.
Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns:
The protein score cutoff threshold.

Implements ms_mascotresults.

double getProteinScoreForHistogram ( const int num ) const [virtual, inherited]

Returns scores for top 50 proteins, even if less in the peptidesummary or proteinsummary.

The 'well known' green and red histogram at the top of the Mascot reports is created from the top 50 protein scores in the results. However, if the number of hits requested for a peptide or protein summary is 'AUTO' or is less than 50, then there won't be 50 hits in the ms_mascotresults object so it won't be possible to create the histogram.

This simple method can reliably be used to return the score for a hit number between 1 and 50, regardless of the number of entries in the protein or peptide summary. To create the histogram, it will be necessary to call this method 50 times - with num being 1..50.

In the rare case of there being less than 50 proteins in the results file, a value of -1 will be returned for values of num that have no protein hit. If a protein is rejected because it only has peptides shorter than minPepLenInPepSummary or because the MSRES_REQUIRE_BOLD_RED is set, then this protein will not be included in the list.

Parameters:
num Is a value in the range 1..50.
Returns:
The score.
std::string getProteinsWithThisPepMatch | ( | const int | q,
 |  | const int | p,
 |  | const bool | quotes = false
 | ) |  | [virtual]

Return a partial list of proteins that matched the same peptide.

The returned string is of the following form:

    1:Q9XZJ2  2:100K_RAT  3:AAF55150

The list is the hit number / accession of all proteins that matched the same peptide. There is no indication of which database the hit is from, but this can of course be determined by calling getHit().

In ms_peptidesummary, this is taken from the list of accessions on the q1_p1= line. The returned string only includes proteins that are in the current peptide summary. This means for example that if you choose to only see the top 5 hits, and this query/rank is for a peptide that occurs in protein 6, then protein number 6 will not appear in the resulting string.

In ms_proteinsummary, the string is also constructed from the list of accessions on the q1_h1= line. There's an additional check that the query number is the same, and that the peptide is the same string.

If you want a list of accession strings rather than a single concatenated string, use the function getAllProteinsWithThisPepMatch().

Parameters:
q is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' number (in ms_proteinsummary) or 'rank' number (in ms_proteinsummary).

  • For a protein summary, a maximum of 50 protein hits are saved are saved and hence h must be in the range 1..50. It is safest to call getMaxRankValue() to find the maximum value.
  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
quotes specifies whether the accessions will be quoted, which should allow accesions with spaces and colons. If true, the string returned would then be

1:"Q9XZJ2" 2:"100K_RAT" 3:"AAF55150"
Returns:
list of proteins matching the peptide, as a string

Implements ms_mascotresults.

void getProteinTaxonomyIDs | ( | const char * | accession,
 |  | const int | dbIdx,
 |  | std::vector< int > & | gpt_ids,
 |  | std::vector< std::string > & | gpt_accessions
 | ) |  | const [inherited]

Return the taxonomy ID(s), if any, from the results file.

In Mascot 2.4.0 and later, taxonomy IDs are saved in the proteins section of the results files in the form:

   [DB::]"accession"_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

In Mascot 2.4.1 and later, taxonomy IDs are also saved in the summary section of the results files in the form:

   hN_tax=taxId[:"accession",taxID[:"accession",taxID[:...]]]

For example, for a single database, with a single accession/taxonomy:

   "gi|209490801"_tax=87229

   h1=gi|209490801, ...
   h1_tax=87229

and for a multi-database search, with a single accession/taxonomy:

   02::"gi|209490801"_tax=87229

   h1_db=2
   h1=gi|209490801, ...
   h1_tax=87229

and for a single database, with multiple accession/taxonomy:

   "gi|182438931"_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

   h1=gi|182438931, ...
   h1_tax=455632:"gi|282872348",649189:gi|178467447,455632:gi|282574201,649189

If none of the databases used for the search contain taxonomy information, then no _tax lines will be output.

If any of the databases used for the search contain taxonomy information, then a _tax line will be output for all relevant proteins. This is governed by the same rules that determine for which proteins to output the mass and description lines. If a protein has no taxonomy information (for example, the database has no taxonomy), -1 will be used as the taxonomy ID.

Therefore, to determine if taxonomy information is available in the results file, simply take any protein in the proteins section, and see if there is a corresponding _tax entry.

For most FASTA files, there is a single accession and taxonomy for each sequence entry. For the NCBInr database, identical sequences are only stored once, but there are multiple accession/description lines separated by a "Control-A" character. Each accession may have a different taxonomy. This function returns the list of taxonomy IDs and corresponding accessions. For the last example shown above, this function will return the arrays of IDs

  [455632, 649189, 455632, 649189]

and accessions

  ["gi|182438931", "gi|282872348", "gi|178467447", "gi|282574201"]

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
accession | is the primary accession
dbIdx | is the 1 based database ID
gpt_ids | the taxonomy IDs
gpt_accessions | the list of accessions
int getProteinThreshold ( double OneInXprobRnd ) const [virtual, inherited]

Return a threshold value for the protein summary report.

This is simply calculated by using:

   10.0 * log10(seqsAfterTax * OneInXprobRnd)

where seqsAfterTax is obtained from ms_mascotresfile::getNumSeqsAfterTax().

The threshold value is displayed at the top of the protein summary report: Protein scores greater than 72 are significant (p<0.05).

Parameters:
OneInXprobRnd For a 1 in 20 probability, this should be 20. This value must be greater than 1, or it will be set to the default of 20.
Returns:
The protein threshold.
int getQmatch ( const int query ) const [virtual, inherited]

Return the number of peptides with masses that matched this query.

See also:
getPeptideIdentityThreshold()
getQmatch(const int, const ms_mascotresfile::section) const

If the value is greater than INT_MAX, then INT_MAX will be returned.

This function calls the getQmatch(query, section) function with the 'relevant' section which will normally be SEC_SUMMARY.

If the MSRES_DECOY flag was specified in the constructor, then the 'relevant' section will be SEC_DECOYSUMMARY. If the search is an error tolerant search, then the 'relevant' section will be SEC_ERRTOLPEPTIDES, and analogously for crosslinked searches (SEC_CROSSLINK_PEPTIDES).

However, to get the spectral library qmatch values, it is necessary to explicitly call: getQmatch(query, ms_mascotresfile::SEC_LIBRARYSUMMARY)

Parameters:
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
Returns:
the number of peptides with masses that matched this query
int getQmatch | ( | const int | query,
 |  | const ms_mascotresfile::section | sec
 | ) |  | const [virtual, inherited]

Return the number of peptides with masses that matched this query.

See also:
getQmatch(const int) const

If the value is greater than INT_MAX, then INT_MAX will be returned.

Parameters:
query Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
sec is the section number and can be one of:

  • ms_mascotresfile::SEC_SUMMARY
  • ms_mascotresfile::SEC_DECOYSUMMARY
  • ms_mascotresfile::SEC_ERRTOLSUMMARY
  • ms_mascotresfile::SEC_ERRTOLDECOYSUMMARY
  • ms_mascotresfile::SEC_LIBRARYSUMMARY
  • ms_mascotresfile::SEC_CROSSLINK_SUMMARY
Returns:
the number of peptides with masses that matched this query. If the specified sec doesn't exist, then 0 will be returned.
ms_mascotresults::QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide | ( | const matrix_science::ms_peptide & | peptide,
 |  | matrix_science::ms_quant_component & | component,
 |  | const matrix_science::ms_quant_method * | method = NULL
 | ) |  | const [virtual]

Get the component in the quantitation method that matches the peptide.

If the component name has already been determined (see ms_peptide::getComponentStr()) then that component is retrieved from the method.

If the component name has not yet been determined for the peptide, each component in the method is checked in turn to determine if it is the correct component for the peptide (see ms_peptidesummary::isPeptideComponentMatch()). A component only matches the peptide if every modification group of the component matches the peptide.

This is only applicable if there is a quantitation method, the method uses the Precursor protocol and the method has components defined. If an error occurs then an error message is appended to the matrix_science::ms_mascotresfile and a matching status code is returned.

Parameters:
peptide | The peptide to find the component for.
component | This is set to the first matching component found, if any.
method | An optional parameter that overrides the quantitation method used to look for matching components. If no method is specified here then the method from the ms_mascotresfile is used.
Returns:
One of the return status codes in ms_mascotresults::QUANT_COMPONENT_STATUS.

Implements ms_mascotresults.

std::string getReadableVarMods | ( | const int | q,
 |  | const int | p,
 |  | const int | numDecimalPlaces = 2,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual, inherited]

Return a 'human readable' string with the variable, summed and error tolerant mods.

This function creates a string of the form

2 Oxidation (M); Phosphorylation (ST)

It works by getting the variable mods string, e.g. 0110030, using ms_peptide::getVarModsStr(). It then converts the string to a human readable form. Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W.

This function will work whether or not there are variable and/or error tolerant mods, and can be called for either the peptide or the protein summary. Variable modification names are obtained using ms_searchparams::getVarModsName() and error tolerant modification names are found using ms_mascotresults::getErrTolModName(). Library modification names, in peptide summary, are found using ms_searchparams::getLibraryModName(). See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Error tolerant mods are shown with the delta in square brackets after the modification or substitution. For example:

   R->G [-99.08]

The delta is shown to numDecimalPlaces.

If the match is an intact crosslinked match, the returned string contains a short description of the linked sites and what they are linked with. For example:

   Xlink:DSS (K) in alpha crosslinked with Xlink:DSS (K) in beta

Use ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA as the psmComponent argument to inspect the alpha and beta mods separately. In this case, the intact linker is described like "intact Xlink:DSS (K)".

Summed mods, from ms_peptide::getSummedModsStr(), and query-level mods, from ms_peptide::getLocalModsStr(), are also included in the returned string.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10.
numDecimalPlaces | (optional) Used for the display of modification deltas.
psmComponent | (optional) Either ms_peptide::PSM_COMPLETE for the match as a whole, or ms_peptide::PSM_CROSSLINK_ALPHA or ms_peptide::PSM_CROSSLINK_BETA to get components of a crosslinked match.
Returns:
The formatted string.
Examples:
resfile_summary.cpp.
const ms_mascotresfile & getResfile ( ) const [inherited]

Return a reference to the resfile.

Returns:
A reference to the resfile given in the constructor.
ms_mascotresults_params getResultsParameters ( ) [inherited]

Returns an ms_mascotresults_params object containing the parameter and flag settings used to generate the report.

Returns:
An ms_mascotresults_params object containing the parameter and flag values used to generate the report.
double getSequenceMass ( const char * seq ) const [inherited]

Return the mass of a sequence (protein or peptide).

The sequence mass is calculated by summing the mass of each residue, using ms_searchparams::getResidueMass, and adding terminus masses using ms_searchparams::getCTermMass and ms_searchparams::getNTermMass.

The mass is therefore the 'Mr' (uncharged) mass, and is calculated using any static modifications.

Parameters:
seq is the protein sequence.
Returns:
The relative mass of the sequence.
int getTagDeltaRangeEnd | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the second number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
the second number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

int getTagDeltaRangeStart | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the first number from h1_q2_drange=0,256.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_drange might be
       q1_p2_drange=0,256
  • The entry in h1_q2_drange might be
       h1_q2_drange=0,256
Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
the first number from the string or -1 if there is no tag match.

Implements ms_mascotresults.

int getTagEnd | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual, inherited]

Return the end position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagStart(), getTagSeries()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The residue end position of the tag.
Examples:
resfile_summary.cpp.
int getTagSeries | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual, inherited]

Return the series ID for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagStart(), getTagEnd()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The series that contained a match to the tag. Possible ion series numbers are
  • -1 means no matches for the tag
  • 0 "a" series (single charge)
  • 1 "a-NH3" series (single charge)
  • 2 "a" series (double charge)
  • 3 "b" series (single charge)
  • 4 "b-NH3" series (single charge)
  • 5 "b" series (double charge)
  • 6 "y" series (single charge)
  • 7 "y-NH3" series (single charge)
  • 8 "y" series (double charge)
  • 9 "c" series (single charge)
  • 10 "c" series (double charge)
  • 11 "x" series (single charge)
  • 12 "x" series (double charge)
  • 13 "z" series (single charge)
  • 14 "z" series (double charge)
  • 15 "a-H2O" series (single charge)
  • 16 "a-H2O" series (double charge)
  • 17 "b-H2O" series (single charge)
  • 18 "b-H2O" series (double charge)
  • 19 "y-H2O" series (single charge)
  • 20 "y-H2O" series (double charge)
  • 21 "a-NH3" series (double charge)
  • 22 "b-NH3" series (double charge)
  • 23 "y-NH3" series (double charge)
  • 25 "internal yb" series (single charge)
  • 26 "internal ya" series (single charge)
  • 27 "z+1" series (single charge)
  • 28 "z+1" series (double charge)
  • 29 high-enrgy "d" and "d'" series (single charge)
  • 31 high-enrgy "v" series (single charge)
  • 32 high-enrgy "w" and "w'" series (single charge)
  • 33 "z+2" series (single charge)
  • 34 "z+2" series (double charge)
Examples:
resfile_summary.cpp.
int getTagStart | ( | const int | q,
 |  | const int | p,
 |  | const int | tagNumber
 | ) |  | const [virtual, inherited]

Return the start position for the tag-match from h1_q2_tag or q1_p1_tag.

The entry in, for example, h1_q2_tag might be

   h1_q2_tag=1:10:12:6,3:1:12:1,...

Every group of four numbers between commas is tagNumber:startPos:endPos:series.

See also:
getTagEnd(), getTagSeries()
Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p | Should be in the range 1..10 for a peptide summary.
tagNumber | Is a one based value.
Returns:
The residue start position of the tag.
Examples:
resfile_summary.cpp.
std::string getTagString | ( | const int | q,
 |  | const int | p
 | ) |  | const [virtual]

Return the complete tag string from h1_q2_tag or q1_p1_tag.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in q1_p2_tag might be
       q1_p2_tag=1:10:12:6,3:1:12:1,...
  • The entry in h1_q2_tag might be
       h1_q2_tag=1:10:12:6,3:1:12:1,...

This function returns the complete string value. Every group of four numbers between commas is tagNumber:startPos:endPos:series.

More useful functions are

  • ms_mascotresults::getTagStart(),
  • ms_mascotresults::getTagEnd() and
  • ms_mascotresults::getTagSeries(),

all of which will work for both the protein summary and the peptide summary.

Parameters:
q Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
Returns:
complete tag string.

Implements ms_mascotresults.

std::string getTerminalResiduesString | ( | const int | q,
 |  | const int | p,
 |  | const ms_peptide::PSM | psmComponent = ms_peptide::PSM_COMPLETE
 | ) |  | const [virtual]

Return the complete terminal residue string from h1_q1_terms.

Consider the following two examples for peptide summary and protein summary, respectively:

  • The entry in the results file might be
       q1_p2_terms=-,A:K,I:-,-:Q,-:@,R:...
  • The entry in the results file might be
       h1_q2_terms=A,Q

This function returns the complete string value. More useful functions are ms_protein::getPeptideResidueBefore() and ms_protein::getPeptideResidueAfter(), which will work for both the protein summary and the peptide summary.

ms_peptidesummary only: For a crosslinked match, the results file line is q1_p1_terms_1= or q1_p1_terms_2=, depending on the psmComponent parameter. If the parameter is ms_peptide::PSM_COMPLETE, the method returns the empty string. Use ms_peptide::getNumberOfLinkedPeptides() to decide which value is needed.

Parameters:
q | Specifies the query number. This should be in the range 1 .. ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, p should be in the range 1..10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the range 1 to 50, so it is safest to call getMaxRankValue() to find the maximum value.
psmComponent | is the type of data to return: complete molecule, alpha peptide or beta peptide. Leave as default if the search is not a crosslinked search.
Returns:
the full terminal residues string.

Implements ms_mascotresults.

bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR, return the probability threshold that gives the desired FDR using the homology threshold.

For example, to find out which probability threshold gives 1% FDR above identity or homology threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the * minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveHomology() and getNumDecoyHitsAboveHomology().

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

Otherwise functionality is the same as getThresholdForFRDAboveIdentity(double, double*, double*, int*, int*).

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveHomology | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the homology threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFRDAboveHomology(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR, return the probability threshold that gives the desired FDR using the identity threshold.

For example, to find out which probability threshold gives 1% FDR above identity threshold, call this function with targetFDR = 0.01, and feed the returned threshold as the minProbability parameter to the constructor. The FDR can be calculated as described in getNumHitsAboveIdentity() and getNumDecoyHitsAboveIdentity().

The function returns a value that maximises the number of peptide-spectrum matches while giving an FDR below the targetFDR value. In some cases, it would be possible to get an FDR closer to the supplied targetFDR, but with fewer target matches.

For a large file, this function can take some time to return. Feedback can be obtained by using ms_mascotresfile::outputKeepAlive with the fd= tag.

This function was first introduced in version 2.4.0 and the method for calculating the value was changed between version 2.4.0 and 2.4.1.

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If this function returns false, there are several possibilities:

  • The function is being called for a ms_proteinsummary object
  • The supplied targetFDR is 0, or negative
  • It is not possible to get an FDR less than the targetFDR. In this case, the lowest possible FDR is given
  • The function is being called for an error tolerant search

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
bool getThresholdForFDRAboveIdentity | ( | double | targetFDR,
 |  | DECOY_STATS_COUNT_TYPE | countType,
 |  | DB_MATCH_TYPE | dbType,
 |  | double * | closestFDR,
 |  | double * | minProbability,
 |  | int * | numTargetMatches = 0,
 |  | int * | numDecoyMatches = 0
 | ) |  | [inherited]

Given a target FDR for PSMs or sequences, return the probability threshold that gives the desired FDR using the identity threshold.

In Parser 2.5 and earlier, the FDR was calculated based on peptide-spectrum matches (PSMs). Parser 2.6 and later support calculating the FDR based on distinct peptide sequences. You can choose between PSMs and sequences with countType. The default, when countType is not given, is to count PSMs.

Parser 2.6 also added support for spectral libraries. However, there is no support for decoy spectral libraries, and thus there is no support for library FDR. If dbType is not DM_FASTA, the method returns false.

Otherwise functionality is the same as getThresholdForFRDAboveIdentity(double, double*, double*, int*, int*).

From version 2.8.0, it is possible to set target FDR directly as a constructor argument. See ms_mascotresults_params::setTargetFDR(). If the search is an error tolerant target-decoy search, use the constructor argument to set target FDR.

If calling from outside C++, see Multiple return values in Perl, Java, Python and C#. For C#, numTargetMatches and numDecoyMatches must be supplied.

Parameters:
[in] | targetFDR | an FDR to aim for.
[in] | countType | whether to count PSMs or sequences.
[in] | dbType | must be DM_FASTA.
[out] | closestFDR | an FDR closest to the target value, or -1 if FDR cannot be calculated.
[out] | minProbability | the probability threshold that gives closestFDR, or -1 if FDR cannot be calculated.
[out] | numTargetMatches | returns the number of target matches at this FDR, or -1 if the FDR cannot be calculated.
[out] | numDecoyMatches | returns the number of decoy matches at this FDR, or -1 if the FDR cannot be calculated.
Returns:
true if the FDR was reached, false otherwise.
double getToleranceInDalton | ( | bool & | needMass,
 |  | const double *const | pMass = NULL
 | ) |  | const [inherited]

Returns the tolerance in dalton, and whether a mass is needed if the unit is in % or ppm.

Returns the tolerance of the result file in dalton.

Parameters:
needMass | Reference to a boolean to determine if the mass is needed to calculate the delta, namely when the tolerance unit is in % or ppm
pMass | Optional parameter to calculate the tolerance from the mass for % and ppm
Returns:
The tolerance in dalton
bool getTreeClusterNodes | ( | const int | hit,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | TREE_CLUSTER_METHOD | tcm = TCM_PAIRWISE_MAXIMUM,
 |  | double *** | reserved1 = 0,
 |  | unsigned int * | reserved2 = 0
 | ) |  | const [virtual, inherited]

Return distances and structure suitable for a dendrogram plot.

The 'distances' between each protein in the family are calculated using a tree clustering routine which, by default, implements pairwise maximum (or complete) linkage clustering. It is used for the dendrogram display in the reports introduced in Mascot 2.3.

The vectors returned by this function only contain values when MSRES_CLUSTER_PROTEINS has been specified and where there are at least two family members.

The code uses the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

A value of 0 returned in the left or right vector corresponds to the lead protein as returned by getHit(). To find the protein associated with a positive node value returned in the left or right vector, call getNextFamilyProtein() with the id value set to the value in the vector.

The distances passed to the cluster algorithm are calculated by determining which peptides need to be excluded to make one protein a subset of another. Each unique peptide sequence is considered in turn, and the distance is calculated by taking the maximum difference between the score and the value returned by getPeptideThreshold(). Additionally, where a query has matches to different peptides above threshold in each protein, the delta of the scores is added to the distance.

For details of how to use the left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
hit | is the hit number for the lead protein.
left | returns a vector of 'left' values.
right | returns a vector of 'right' values.
distance | returns a vector of 'distance' values.
tcm | is the method to be used. See documentation referenced above
reserved1 | is for Matrix Science use only
reserved2 | is for Matrix Science use only
Returns:
true unless the code causes an out of memory error.

Reimplemented in ms_peptidesummary.

ms_peptide getUnassigned ( const int num ) const [inherited]

Need to call createUnassignedList() before calling this.

See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return an empty ms_peptide.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
Examples:
resfile_summary.cpp.
bool getUnassignedIsBold ( const int num ) const [inherited]

Returns true if the item indexed by num in the assigned list should be bold.

This function returns true if this peptide should be displayed in bold in a Mascot report. Bold is used for the first time a query is shown in a report. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return true.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return true.
bool getUnassignedShowCheckbox ( const int num ) const [inherited]

Returns true if the item indexed by num in the assigned list should have a check box next to it.

A check box is displayed if this is the first rank 1 match that has been displayed for this query. See also ms_peptide::getRank() and ms_peptide::getPrettyRank().

By definition, all unassigned queries will need a check box. See Unassigned peptides list for details of creating and using an unassigned list.

If this function is called before createUnassignedList() then an error ms_mascotresfile::ERR_UNASSIGNED_PROG will be set, and this function will return false.

Parameters:
num Must be in the range 1..getNumberOfUnassigned().
Returns:
If num is outside the range ..getNumberOfUnassigned(), then an error ms_mascotresfile::ERR_UNASSIGNED_RANGE will be set, and this function will return an empty ms_peptide.
bool isEmPAIallowed ( ) const [inherited]

Return true if emPAI could be calculated using data in this results file.

emPAI is not available unless all of the following are true:

  • Results file has MS/MS data.
  • Results file is not an old-style error tolerant search.
  • Results file has not been opened in decoy mode (ms_mascotresults::MSRES_DECOY).
  • There are at least 100 queries.
Returns:
true if emPAI is allowed.
bool isNA ( ) const [inherited]

Returns TRUE for a search against a nucelic acid database.

There is no specific information in the results file for this. It is implemented by looking to see if there is a frame number that is non-zero in any result. If there are no matches to any query, then this method will return false and therefore may be wrong. (However, if there are no matches then it is unlikely that the outcome of this function is important!)

In versions prior to 2.3.01, this was determined by looking in protein matches. In version 2.3.01 and later, this is determined by looking in all peptide matches, regardless of score.

Returns:
True if the search was against a nucleic acid database.
bool isPeptideUnique | ( | const int | q,
 |  | const int | p,
 |  | const UNIQUE_PEP_RULES | rules = UPR_DEFAULT
 | ) |  | const [virtual]

Returns true if this peptide match is unique to one protein or one protein family.

Note:
This function currently returns false for ms_proteinsummary. This function is only likely to be useful for a peptide summary.

This function is used, for example, in quantitation to only report ratios for peptide sequences that are unique to one protein hit. This can be specified as part of a Mascot quantitation method; see ms_quant_quality::isUniquePepseq().

No attempt is made to collapse peptides that just differ by, for example, I or L.

The specified q and p values must be for a peptide that has a protein match in the current report, i.e. not in the unassigned list. The function searches all proteins and not just those in the current report. For example, if peptide 'ABCDEFK' appears in protein hit one and protein hit 100, then it will return false even if only the top 10 hits have been requested.

If grouping is not selected when creating the ms_peptidesummary, (i.e. neither ms_mascotresults::MSRES_GROUP_PROTEINS nor ms_mascotresults::MSRES_CLUSTER_PROTEINS), then it is likely that this function will return false for most peptides.

At version 2.3, this function did not have the optional third parameter and the default value was the same as using ms_mascotresults::UPR_WITHIN_FAMILY, which is not the default value in version 2.4 and later. At version 2.3, the function would therefore return true for all peptides with a score above the homology threshold when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameters:
q | is the query number in the range 1 to ms_mascotresfile::getNumQueries().
p is the 'hit' or 'rank' number.

  • For a peptide summary, the top 10 matches are saved and hence p would normally be in the range 1 to 10. For an integrated error tolerant search (see Integrated error tolerant search) this can be in the range 1 to 20.
  • For a protein summary, this will be in the * range 1 to 50.
rules | should passed appropriate ms_mascotresults::UNIQUE_PEP_RULES flags to specify what rules are to be used for considerering when a peptide is unique.
Returns:
true if the peptide match is unique. Always false in ms_proteinsummary.

Implements ms_mascotresults.

bool isPmfQueryUsed ( const int queryIdx ) const

Indicates whether a mass value was used when calculating PMF protein scores.

When submitting a PMF search with intensity values, some masses with low intensities (often noise peaks) may be ignored when calculating scores. Mascot iterates through the intensity values to determine the best score. The total number of masses (queries) used for the best match, and hence used to calculate the score of every protein, can be obtained by calling getNumPmfQueriesUsed().

Use this function to test if a particular query was in the set of masses that obtained the best score.

If no query intensities are supplied, or if all queries have the same intensity, then every query will be used for the search.

Parameters:
queryIdx a query number from 1 to ms_mascotresfile::getNumQueries().
Returns:
true if the query was used when calculating scores.
void setSubsetsThreshold ( const double scoreFraction ) [virtual, inherited]

Specifies which subset proteins should be reported.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A scoreFraction of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported. The flag MSRES_SHOW_SUBSETS must have been specified if a value > 0 is used, or no subsets will be shown.

See also:
getNextSubsetProtein(), getNextSubsetProteinOf()
Parameters:
scoreFraction is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-scoreFraction). The default value is 1.0.
The documentation for this class was generated from the following files:
  • ms_mascotresproteinsum.hpp
  • ms_mascotresproteinsum.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_searchparams
Public Types | Public Member Functions

ms_searchparams Class Reference
[Mascot results file module]

This class encapsulates the search parameters in the mascot results file. More...

#include <ms_mascotresparams.hpp>

List of all members.

Public Types

enum MULTI_SITE_MODS {
MSM_NOT_PERMITTED = 0x0000,
MSM_EXCLUSIVE_PLUS_VARIABLE = 0x0001
}

Possible values for MULTI_SITE_MODS.

More...

Public Member Functions

ms_searchparams (const ms_mascotresfile &resfile)
Either explicitily create an object using this constructor or call ms_mascotresfile.params().
~ms_searchparams ()
Should never need to call this destructor directly.
std::string | getACCESSION ()
This function returns a comma separated list of accession strings.
std::string | getAllUSERParams () const
Returns all the 'user defined' parameters.
double | getCarbonMass () const
Returns the mass of carbon as specified in the mascot/config/masses file.
std::string | getCHARGE ()
Returns the charge state of the peptide masses entered.
std::string | getCLE ()
Returns the name of the enzyme used for the search.
std::string | getCOM ()
This is the comment or "Search title" entered by the user in the search form.
std::string | getCROSSLINKING () const
Returns the name of the crosslinking method used.
double | getCTermMass ()
Returns the C terminus mass.
std::string | getDATAURL ()
Returns the URL of the uploaded file (if any).
std::string | getDB (int idx=1)
Returns one of the database names used for the search.
int | getDECOY () const
Returns a value showing if a decoy database has been searched.
double | getElectronMass () const
Returns the mass of an electron as specified in the mascot/config/masses file.
bool | getERRORTOLERANT ()
Returns 'true' for an error tolerant search.
std::string | getErrTolParentFilename ()
Returns the filename of the 'parent' search for an error tolerant search.
std::string | getFILENAME ()
Returns the name of the uploaded file (if any).
double | getFixedModsDelta (int num)
Returns the delta mass for a fixed modification.
std::string | getFixedModsName (int num) const
double | getFixedModsNeutralLoss (int num)
Returns the neutral loss value for the specified fixed modification.
std::string | getFixedModsResidues (int num) const
Returns the residues modified for the specified fixed modification.
std::string | getFORMAT ()
Returns the file format type selected by the user.
std::string | getFORMVER ()
Returns the version of the form used to submit the search.
double | getHydrogenMass () const
Returns the mass of nitrogen as specified in the mascot/config/masses file.
bool | getICAT ()
Returns true if the user selected the ICAT button on the search form.
std::string | getINSTRUMENT ()
Returns the instrument name that the user selected.
std::string | getINTERMEDIATE ()
For a repeat search, it may be necessary to know the "parent" search.
std::string | getIT_MODS ()
Returns a comma separated list of the variable modifications used in a search.
double | getITOL ()
Returns the tolerance for msms ions.
std::string | getITOLU ()
Returns the units that the ions tolerance is specified in.
int | getLIBRARY_SEARCH () const
Returns a value showing if a spectral library has been searched.
double | getLibraryModDelta (int num) const
Returns the delta mass of the specified spectral library modification.
std::string | getLibraryModName (int num) const
Returns the name of the specified spectral library modification.
std::string | getLICENSE ()
Returns the Mascot license string.
std::string | getMASS ()
Returns whether monoisotopic or average masses have been specified.
MASS_TYPE getMassType ()
Returns either MASS_TYPE_MONO or MASS_TYPE_AVE.
double | getMaxInternalMass ()
Returns the maximum mass to be considered for internal fragments.
double | getMinInternalMass ()
Returns the minimum mass to be considered for internal fragments.
std::string | getMODS ()
Returns a comma separated list of the fixed modifications used in a search.
unsigned int | getMULTI_SITE_MODS () const
Returns a flag showing what MULTI_SITE_MODS options were selected.
double | getNitrogenMass () const
Returns the mass of nitrogen as specified in the mascot/config/masses file.
double | getNTermMass ()
Returns the N terminus mass.
int | getNumberOfDatabases ()
Returns total number of databases used for the search.
int | getNumberOfLibraryMods () const
Return the number of modifications in the spectral libraries searched.
bool | getOVERVIEW ()
Returns true if the user selected the option to show the overview table.
double | getOxygenMass () const
Returns the mass of oxygen as specified in the mascot/config/masses file.
int | getPEP_ISOTOPE_ERROR () const
Returns a value showing how a peak detection error is handled.
int | getPFA ()
Returns the number of missed cleavage points allowed for in a search.
double | getPRECURSOR ()
Returns the precursor mass for an MS-MS query.
std::string | getQUANTITATION () const
Returns the name of the quantitation method used.
std::string | getQUE ()
Currently returns an empty string.
int | getREPORT ()
Returns the number of results to show in the report.
std::string | getREPTYPE ()
Returns the type of report requested by the user.
double | getResidueMass (char residue)
Returns the mass of the specified residue (must be uppercase letter A-Z).
std::string | getRULES ()
Returns as a comma separated list, the rules / ions series used for a search.
std::string | getSEARCH ()
Returns the type of search -- this will be PMF, SQ, MIS.
int | getSEG ()
Returns the segment or protein mass.
int | getSUBCLUSTER ()
Returns the sub cluster number.
double | getTARGET_FDR_PERCENT () const
Returns the target FDR specified as a search parameter.
std::string | getTAXONOMY ()
Returns the name of the taxonomy selection.
double | getTOL ()
Returns the peptide tolerance for the search.
std::string | getTOLU ()
Returns the peptide tolerance units for the search.
std::string | getUSEREMAIL ()
Returns the user's email address (if any) as entered in the search form.
std::string | getUSERField (int num)
Returns the user fields USER00, USER01, USER02 ... USER12.
int | getUSERID ()
Returns the user's USERID.
std::string | getUSERNAME ()
Returns the user name (if any) as entered in the search form.
double | getVarModsDelta (int num)
Returns the delta mass for a variable modification.
std::string | getVarModsName (int num) const
double | getVarModsNeutralLoss (int num)
Returns the first neutral loss value for the specified variable modification.
std::vector< double > | getVarModsNeutralLosses (int num) const
Returns all the neutral loss values for the specified variable modification.
std::vector< double > | getVarModsPepNeutralLoss (int num)
Returns the peptide neutral loss value(s) for the specified variable modification.
std::vector< double > | getVarModsReqPepNeutralLoss (int num)
Returns the required peptide neutral loss value(s) for the specified variable modification.

Detailed Description

This class encapsulates the search parameters in the mascot results file.

Although all these parameters could be obtained using the lower level functions in the ms_mascotresfile class, it is generally more convenient to use this object.

Examples:

resfile_params.cpp.

Member Enumeration Documentation

enum MULTI_SITE_MODS

Possible values for MULTI_SITE_MODS.

See Using enumerated values and static const ints in Perl, Java, Python and C#. The return value from getMULTI_SITE_MODS() is one or more of these values OR'd together.

Currently only has one permitted value, but could be extended in future.

Enumerator:
MSM_NOT_PERMITTED

The default value. Only one variable or exclusive mod per residue.

MSM_EXCLUSIVE_PLUS_VARIABLE

An exclusive mod and one or more variable mod may be specified for the same residue.

Constructor & Destructor Documentation

ms_searchparams ( const ms_mascotresfile & resfile )

Either explicitily create an object using this constructor or call ms_mascotresfile.params().

Search parameters can be obtained either by creating a search params object or by using the object created when the results file is created:

C++
   ms_mascotresfile resfile(filename);

   // Option 1:
   ms_searchparams *params = new ms_searchparams(resfile);
   // Option 2:
   ms_searchparams params = resfile.params();
Perl
   my $resfile = msparser::ms_mascotresfile->new($filename);

   # Option 1:
   my $params = msparser::ms_searchparams->new($resfile);
   # Option 2:
   my $params = $resfile->params();
Java
   ms_mascotresfile resfile = new ms_mascotresfile(filename);

   // Option 1:
   ms_searchparams params = new ms_searchparams(resfile);
   // Option 2:
   ms_searchparams params = resfile.params();
Python
   resfile = msparser.ms_mascotresfile(filename)

   # Option 1:
   params = msparser.ms_searchparams(resfile)
   # Option 2:
   params = resfile.params()

See Maintaining object references: two rules of thumb.

Parameters:
resfile result file object

Member Function Documentation

std::string getACCESSION ( )

This function returns a comma separated list of accession strings.

For an error tolerant search, the user typically specifies a list of accession "numbers" to be searched. This function returns a comma separated list of accession strings -- each will have double quotes around it. The string is obtained from the ACCESSION= line in the parameters section of the results file.

Returns:
comma separated list of accession strings
std::string getAllUSERParams ( ) const

Returns all the 'user defined' parameters.

Returns a string of all the entries in the 'parameters' section that have a leading underscore. Each item is separated by a newline character. Note that if there are two user parameters with the same key (differing only by case), then the second one of these will be discarded.

Returns:
all the user defined parameters
double getCarbonMass ( ) const

Returns the mass of carbon as specified in the mascot/config/masses file.

This is obtained from the carbon= line in the masses section of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

Returns:
mass of carbon as specified in the mascot/config/masses file
std::string getCHARGE ( )

Returns the charge state of the peptide masses entered.

This is obtained from the CHARGE= line in the parameters section of the results file. Use ms_peptide::getCharge to return the actual charge state that was used for a peptide match.

This is the default charge state that was used when running the search. It can be overridden by charge states in an uploaded file; see ms_inputquery::getCharge().

If the search was submitted from the standard Mascot search form, then it will be one of the following strings:

  • '8-'
  • '7-'
  • '6-'
  • '5-'
  • '4-'
  • '3-'
  • '2- and 3-'
  • '2-'
  • '1-, 2- and 3-'
  • '1-'
  • 'Mr'
  • '1+'
  • '1+, 2+ and 3+'
  • '2+'
  • '2+ and 3+'
  • '3+'
  • '4+'
  • '5+'
  • '6+'
  • '7+'
  • '8+'

The charge can also be any comma separated list of charge states.

See also:
http://www.matrixscience.com/help/search_field_help.html#TWO
Returns:
The default charge(s) as a string.
std::string getCLE ( )

Returns the name of the enzyme used for the search.

This is obtained from the CLE= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#CLE
Returns:
name of the enzyme used for the search
std::string getCOM ( )

This is the comment or "Search title" entered by the user in the search form.

This is obtained from the COM= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#COM
Returns:
comment or "Search title" entered by the user in the search form
std::string getCROSSLINKING ( ) const

Returns the name of the crosslinking method used.

Available in Mascot 2.7 and later.

See also:
http://www.matrixscience.com/help/search_field_help.html#CROSSLINKING
Returns:
If no crosslinking is specified, an empty string or "None". Otherwise return the name of the crosslinking method from the CROSSLINKING= value in the parameters section of the results file.
double getCTermMass ( )

Returns the C terminus mass.

This is obtained from the C_term= line in the masses section of the results file.

The mass value will depend on whether monoisotopic or average masses were selected by the user (see getMASS()). Additionally, any fixed (but not variable) modifications are included in this mass. If no C terminus mods are specified, this value should be the same as getOxygenMass() + getHydrogenMass().

These values originate from the mascot/config/masses file, and are therefore user definable.

Returns:
C terminus mass
std::string getDATAURL ( )

Returns the URL of the uploaded file (if any).

This is obtained from the DATAURL= line in the parameters section of the results file.

Returns:
URL of the uploaded file
std::string getDB ( int idx = 1 )

Returns one of the database names used for the search.

This is normally obtained from the DB= line in the parameters section of the results file.

It is not possible to find the database file name and path directly from its name. The get the path to the database file used in the search, use ms_mascotresfile::getFastaPath(), or you will need to manually parse the Databases section of mascot.dat and search for the line starting with the name returned by getDB(). Replace the last part of the path with the return value from the ms_mascotresfile::getFastaVer() function to complete the file name.

Mascot 2.6 and later support spectral libraries. Each spectral library must have a reference database into which found peptide sequences are mapped at the end of the search. The "effective" reference database could be one of the protein sequence databases searched, or it could be a separate database used only for lookup purposes. You can find the database number of the reference database with ms_mascotresfile::getReferenceDatabaseNumberOfSL(). If this is larger than getNumberOfDatabases(), the database name is obtained from the library_reference_DB line in the header section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#DB
Parameters:
idx index of the database from 1 to getNumberOfDatabases() for databases or libraries searched, or an index returned by ms_mascotresfile::getReferenceDatabaseNumberOfSL().
Returns:
one of the database names used for the search
int getDECOY ( ) const

Returns a value showing if a decoy database has been searched.

Available in Mascot 2.2 and later.

See also:
http://www.matrixscience.com/help/decoy_help.html#AUTO

The value is obtained from the DECOY= line in the parameters section of the results file. If there is no such line, this method returns -1. Otherwise, the method returns 0 if DECOY is off and 1 if DECOY is on.

Returns:
-1, 0 or 1.
double getElectronMass ( ) const

Returns the mass of an electron as specified in the mascot/config/masses file.

This is obtained from the Electron= line in the masses section of the results file.

Results files produced by Mascot versions prior to 1.9 do not have this entry. For those files, the returned value will be zero.

Returns:
mass of an electron as specified in the mascot/config/masses file
bool getERRORTOLERANT ( )

Returns 'true' for an error tolerant search.

This is obtained from the ERRORTOLERANT= line in the parameters section of the results file.

Use getACCESSION() to get the list of accession numbers that are used for an error tolerant search.

See also:
http://www.matrixscience.com/help/error_tolerant_help.html
Returns:
true if the search is error tolerant, false otherwise
std::string getErrTolParentFilename ( )

Returns the filename of the 'parent' search for an error tolerant search.

Most programs should not need to call this function - it is used within the Mascot Parser.

An error tolerant search is normally performed as a repeat search. The filename for the 'parent' non error tolerant search is saved in the parameters section as _errortolerantsearchparent, and can be accessed using this function.

It is not possible to use getINTERMEDIATE(), because an error tolerant search can be performed as a repeat search from another error tolerant search.

See Error tolerant searches for further details.

Returns:
relative path to the parent error tolerant file
std::string getFILENAME ( )

Returns the name of the uploaded file (if any).

This is obtained from the FILE= line in the parameters section of the results file.

Returns:
name of the uploaded file
double getFixedModsDelta ( int num )

Returns the delta mass for a fixed modification.

This value is obtained from the FixedMod[num]= line in the masses section of the results file.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters:
num is the modification number. This number is not referenced elsewhere in the results file.
Returns:
The delta, or a value of zero if no delta is found.
std::string getFixedModsName ( int num ) const

This value is obtained from the FixedMod[num]= line in the masses section of the results file.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters:
num is the modification number. This number is not referenced elsewhere in the results file.
Returns:
The modification name, or an empty string if no name is found.
double getFixedModsNeutralLoss ( int num )

Returns the neutral loss value for the specified fixed modification.

This value is obtained from the FixedModNeutralLoss[num]= line in the masses section of the results file.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters:
num is the modification number. This number is not referenced elsewhere in the results file.
Returns:
The neutral loss delta, or zero if no neutral loss is found. Only a single neutral loss is permitted for a fixed modifcation.
std::string getFixedModsResidues ( int num ) const

Returns the residues modified for the specified fixed modification.

This value is obtained from the FixedModResidues[num]= line in the masses section of the results file.

Any number of fixed modifications can be applied during a search as long as multiple modifications don't affect the same residue/terminus. Information about fixed modifications can be found using these functions:

  • getFixedModsName(int num)
  • getFixedModsDelta(int num)
  • getFixedModsNeutralLoss(int num)
  • getFixedModsResidues(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about fixed modifications.

Parameters:
num is the modification number. This number is not referenced elsewhere in the results file.
Returns:
The string representing which residues/terminus are modified. It will be of the form [A-Z]|C_term|N_term. Multiple residues will be listed as, for example, STY.
std::string getFORMAT ( )

Returns the file format type selected by the user.

This is obtained from the FORMAT= line in the parameters section of the results file.

Currently supported formats:
  • Mascot generic
  • Sequest (.DTA)
  • Finnigan (.ASC)
  • Micromass (.PKL)
  • PerSeptive (.PKS)
  • Sciex API III
  • Bruker (.XML)
  • mzData (.XML)
  • mzML (.XML)
See also:
http://www.matrixscience.com/help/data_file_help.html
Returns:
file format type selected by the user
std::string getFORMVER ( )

Returns the version of the form used to submit the search.

This is obtained from the FORMVER= line in the parameters section of the results file.

This is currently 1.01.

Returns:
version of the form used to submit the search
double getHydrogenMass ( ) const

Returns the mass of nitrogen as specified in the mascot/config/masses file.

This is obtained from the hydrogen= line in the masses section of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

Returns:
mass of nitrogen as specified in the mascot/config/masses file
bool getICAT ( )

Returns true if the user selected the ICAT button on the search form.

This is obtained from the ICAT= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#ICAT
Returns:
If the value in the results file is (case insensitive) ON or 1, this will return true.
std::string getINSTRUMENT ( )

Returns the instrument name that the user selected.

This is obtained from the INSTRUMENT= line in the parameters section of the results file.

This string will be NULL for versions of Mascot prior to 1.8.

See also getRULES(). It is preferable to use the rules rather than this name to determine which ions series were searched since the user can change the definition of the name.

See also:
http://www.matrixscience.com/help/search_field_help.html#INSTRUMENT
Returns:
instrument name that the user selected
std::string getINTERMEDIATE ( )

For a repeat search, it may be necessary to know the "parent" search.

This is obtained from the INTERMEDIATE= line in the parameters section of the results file.

This function returns the file name for the results file of the 'parent' search.

Returns:
file name of the parent search result file
std::string getIT_MODS ( )

Returns a comma separated list of the variable modifications used in a search.

This is obtained from the IT_MODS= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#MODS
Returns:
comma separated list of the variable modifications used in a search
double getITOL ( )

Returns the tolerance for msms ions.

This is obtained from the ITOL= line in the parameters section of the results file.

See also:
getITOLU()
http://www.matrixscience.com/help/search_field_help.html#ITOL
Returns:
tolerance for MS/MS ions
std::string getITOLU ( )

Returns the units that the ions tolerance is specified in.

This is obtained from the ITOLU= line in the parameters section of the results file.

The units will be one of:

mmu
absolute milli-mass units, i.e. units of .001 Da
Da
absolute units of Da
See also:
getITOL()
http://www.matrixscience.com/help/search_field_help.html#ITOL
Returns:
unit that the ions tolerance is specified in
int getLIBRARY_SEARCH ( ) const

Returns a value showing if a spectral library has been searched.

Available in Mascot 2.6 and later.

See also:
http://www.matrixscience.com/help/spectral_library.html

The value is obtained from the LIBRARY_SEARCH= line in the parameters section of the results file. If there is no such line, this method returns -1. Otherwise, the method returns 0 if LIBRARY_SEARCH is off and 1 if LIBRARY_SEARCH is on.

Returns:
-1, 0 or 1.
double getLibraryModDelta ( int num ) const

Returns the delta mass of the specified spectral library modification.

Library modifications are stored in the spectral_library section of the results file. These are all the modifications contained in the spectral libraries selected for searching. Individual spectral library matches, if they have modifications, refer to modification index numbers in this list.

The modification only has a delta mass if its name was in the Unimod configuration file at the time of the search. Otherwise only its name is recorded in the spectral_library section. It is better to look up the modification by name from the Unimod configuration file than rely on the delta mass being present.

Note that the list of modifications in actual matches in the search is different. See ms_peptidesummary::getNumDiscoveredLibraryMods().

Parameters:
num is library modification index. See ms_peptidesummary::getLibraryModString(). The index should be between 1 and getNumberOfLibraryMods().
Returns:
modification delta mass, or 0.0 if not available.
std::string getLibraryModName ( int num ) const

Returns the name of the specified spectral library modification.

Library modifications are stored in the spectral_library section of the results file. These are all the modifications contained in the spectral libraries selected for searching. Individual spectral library matches, if they have modifications, refer to modification index numbers in this list.

Note that the list of modifications in actual matches in the search is different. See ms_peptidesummary::getNumDiscoveredLibraryMods().

Parameters:
num is library modification index. See ms_peptidesummary::getLibraryModString(). The index should be between 1 and getNumberOfLibraryMods().
Returns:
modification name. The name may be a Unimod name, or it may be a free-text string; this depends on how the library was constructed.
std::string getLICENSE ( )

Returns the Mascot license string.

This string is the one in the license file, and is printed out during a Mascot search. This is obtained from the LICENSE= line in the parameters section of the results file.

Returns:
Mascot license string
std::string getMASS ( )

Returns whether monoisotopic or average masses have been specified.

This is obtained from the MASS= line in the parameters section of the results file. The returned text will be "Monoisotopic" or "Average" -- even if the text in the results file is, for example, all upper case.

See also:
getMassType() which may be a more useful function.
http://www.matrixscience.com/help/search_field_help.html#MASS
Returns:
"Monoisotopic" or "Average"
MASS_TYPE getMassType ( )

Returns either MASS_TYPE_MONO or MASS_TYPE_AVE.

The value is obtained from the MASS= line in the parameters section of the results file.

See also:
getMASS()
Returns:
MASS_TYPE_MONO or MASS_TYPE_AVE
double getMaxInternalMass ( )

Returns the maximum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section of the results file as INTERNALS=min,max. If there is no INTERNALS= line, the default value of 700.0 is returned.

A different instrument can be specified for each spectrum, in which case the values can be found using ms_inputquery::getMinInternalMass and ms_inputquery::getMaxInternalMass

See also:
getRULES(), getINSTRUMENT()
Returns:
The maximum internal mass considered in this search.
double getMinInternalMass ( )

Returns the minimum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

The value specified for the instrument is saved in the parameters section of the results file as INTERNALS=min,max. If there is no INTERNALS= line, the default value of 0 is returned.

A different instrument can be specified for each spectrum, in which case the values can be found using ms_inputquery::getMinInternalMass and ms_inputquery::getMaxInternalMass.

See also:
getRULES() getINSTRUMENT()
Returns:
The minimum internal mass considered in this search.
std::string getMODS ( )

Returns a comma separated list of the fixed modifications used in a search.

This is obtained from the MODS= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#MODS
Returns:
comma separated list of the fixed modifications used in a search
unsigned int getMULTI_SITE_MODS ( ) const

Returns a flag showing what MULTI_SITE_MODS options were selected.

Available in Mascot 2.4 and later.

See also:
ms_peptide::getSummedModsStr
Multiple modifications for the same site
Returns:
the value of MULTI_SITE_MODS in the paramters section of the results file. This will be one or more ms_searchparams::MULTI_SITE_MODS values OR'ed together. If there is no MULTI_SITE_MODS in the results file, then ms_searchparams::MSM_NOT_PERMITTED will be returned.
double getNitrogenMass ( ) const

Returns the mass of nitrogen as specified in the mascot/config/masses file.

This is obtained from the nitrogen= line in the masses section of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

Returns:
mass of nitrogen as specified in the mascot/config/masses file
double getNTermMass ( )

Returns the N terminus mass.

This is obtained from the N_term= line in the masses section of the results file.

The mass value will depend on whether monoisotopic or average masses were selected by the user (see getMASS()). Additionally, any fixed (but not variable) modifications are included in this mass. If no N terminus mods are specified, this value should be the same as getHydrogenMass().

These values originate from the mascot/config/masses file, and are therefore user definable.

Returns:
N terminus mass
int getNumberOfDatabases ( )

Returns total number of databases used for the search.

This method is used in conjunction with getDB() to find out the total number of databases used in the search.

Mascot 2.6 and later support spectral libraries. The total number of databases searched includes the protein sequence and nucleic acid databases and spectral libraries, but does not include any reference databases of spectral libraries.

Returns:
The number of databases and libraries used in the search.
int getNumberOfLibraryMods ( ) const

Return the number of modifications in the spectral libraries searched.

Library modifications are stored in the spectral_library section of the results file. These are all the modifications contained in the spectral libraries selected for searching. Individual spectral library matches, if they have modifications, refer to modification index numbers in this list.

Note that the list of modifications in actual matches in the search is different. See ms_peptidesummary::getNumDiscoveredLibraryMods().

Returns:
the number of entries in the spectral_library section, which equals the last non-empty index X in the ModX= lines.
bool getOVERVIEW ( )

Returns true if the user selected the option to show the overview table.

This is obtained from the OVERVIEW= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#OVERVIEW
Returns:
True if the value is (case insensitive) ON or 1.
double getOxygenMass ( ) const

Returns the mass of oxygen as specified in the mascot/config/masses file.

This is obtained from the oxygen= line in the masses section of the results file.

The mass will also depend on whether monoisotopic or average masses were selected by the user. See getMASS().

Returns:
mass of oxygen as specified in the mascot/config/masses file
int getPEP_ISOTOPE_ERROR ( ) const

Returns a value showing how a peak detection error is handled.

Available in Mascot 2.2 and later.

See also:
http://www.matrixscience.com/help/search_field_help.html#PEP_ISOTOPE_ERROR

Normal test for a peptide match is

exp > calc-tol  && exp < calc+tol

If PEP_ISOTOPE_ERROR >= 1, also test for

exp > calc+1.003+tol && exp < calc+1.003-tol

If PEP_ISOTOPE_ERROR >= 2, also test for

exp > calc+2.007+tol && exp < calc+2.007-tol
Returns:
The value of PEP_ISOTOPE_ERROR in the parameters section of the results file. If there is no PEP_ISOTOPE_ERROR value in the results file, then -1 is returned.
int getPFA ( )

Returns the number of missed cleavage points allowed for in a search.

This is obtained from the PFA= line in the parameters section of the results file

See also:
http://www.matrixscience.com/help/search_field_help.html#PFA
Returns:
number of missed cleavage points allowed for in a search
double getPRECURSOR ( )

Returns the precursor mass for an MS-MS query.

This is obtained from the PRECURSOR= line in the parameters section of the results file.

Three data file formats, SCIEX API III and PerSeptive (.PKS) and Bruker (.XML), do not include m/z information for the precursor peptide. For these formats only, the Precursor field is used to specify the m/z value of the parent peptide.

See also:
http://www.matrixscience.com/help/search_field_help.html#PRECURSOR
Returns:
precursor mass for an MS-MS query
std::string getQUANTITATION ( ) const

Returns the name of the quantitation method used.

Available in Mascot 2.2 and later.

See also:
http://www.matrixscience.com/help/search_field_help.html#QUANTITATION
Returns:
If no quantitation is specified, an empty string or "None". Otherwise return the name of the quantitation method from the QUANTITATION= value in the parameters section of the results file.
std::string getQUE ( )

Currently returns an empty string.

This is obtained from the QUE= line in the parameters section of the results file.

Returns:
QUE
int getREPORT ( )

Returns the number of results to show in the report.

This is obtained from the REPORT= line in the parameters section of the results file. For 'AUTO' a value of 0 is returned.

See also:
http://www.matrixscience.com/help/search_field_help.html#REPORT
Returns:
number of results to show in the report
std::string getREPTYPE ( )

Returns the type of report requested by the user.

This is obtained from the REPTYPE= line in the parameters section of the results file

This will be one of:

  • concise
  • peptide
  • protein
See also:
http://www.matrixscience.com/help/results_help.html
Returns:
type of report requested by the user
double getResidueMass ( char residue )

Returns the mass of the specified residue (must be uppercase letter A-Z).

This is obtained from the A=,B= etc. line in the masses section of the results file.

The mass value will depend on whether monoisotopic or average masses were selected by the user (see getMASS()). Additionally, any fixed (but not variable) modifications are included in this mass.

Parameters:
residue uppercase letter A-Z
Returns:
mass of the specified residue
std::string getRULES ( )

Returns as a comma separated list, the rules / ions series used for a search.

This is obtained from the RULES= line in the parameters section of the results file.

The numbers in the comma separated list have the following meanings:

   1 = singly charged
   2 = doubly charged if precursor 2+ or higher (not internal or immonium)
   3 = doubly charged if precursor 3+ or higher (not internal or immonium)
   4 = immonium
   5 = a series
   6 = a - NH3 if a significant and fragment includes RKNQ
   7 = a - H2O if a significant and fragment includes STED
   8 = b series
   9 = b - NH3 if b significant and fragment includes RKNQ
   10= b - H2O if b significant and fragment includes STED
   11= c series
   12= x series
   13= y series
   14= y - NH3 if y significant and fragment includes RKNQ
   15= y - H2O if y significant and fragment includes STED
   16= z series
   17= internal yb < 700 Da
   18= internal ya < 700 Da
   19= y or y++ must be significant
   20= y or y++ must be highest scoring series
   21= z+1 series
   22= d and d' series
   23= v series
   24= w and w' series
   25= z+2 series
See also:
getINSTRUMENT() to find the descriptive name of the selected instrument.
http://www.matrixscience.com/help/search_field_help.html#INSTRUMENT
Returns:
comma separated list, the rules / ions series used for a search
std::string getSEARCH ( )

Returns the type of search -- this will be PMF, SQ, MIS.

This is obtained from the SEARCH= line in the parameters section of the results file.

Rather than using this value directly, it is generally easier to use the functions ms_mascotresfile::isMSMS(), ms_mascotresfile::isPMF() or ms_mascotresfile::isSQ(), and it is normally safer to use ms_mascotresfile::anyMSMS(), ms_mascotresfile::anyPMF() and ms_mascotresfile::anySQ().

Returns:
type of the search
int getSEG ( )

Returns the segment or protein mass.

This is obtained from the SEG= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#SEG
Returns:
segment or protein mass
int getSUBCLUSTER ( )

Returns the sub cluster number.

This is obtained from the SUBCLUSTER= line in the parameters section of the results file.

For a large cluster, split up into multiple sub clusters, this returns the sub cluster number.

Returns:
The subcluster number.
double getTARGET_FDR_PERCENT ( ) const

Returns the target FDR specified as a search parameter.

Available in Mascot 2.8 and later.

See also:
http://www.matrixscience.com/help/decoy_help.html#AUTO

The value is obtained from the TARGET_FDR_PERCENT= line in the parameters section of the results file. If there is no such line, or the value is not a floating point number, this method returns 0.0.

Returns:
0.0, or target FDR specified as a percentage.
std::string getTAXONOMY ( )

Returns the name of the taxonomy selection.

This is obtained from the TAXONOMY= line in the parameters section of the results file.

To find out exactly which taxa were included and excluded from the search, the 'taxonomy' file in the mascot/config directory needs to be parsed.

See also:
http://www.matrixscience.com/help/search_field_help.html#TAXONOMY
Returns:
name of the taxonomy selection
double getTOL ( )

Returns the peptide tolerance for the search.

This is obtained from the TOL= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#TOL
Returns:
peptide tolerance for the search
std::string getTOLU ( )

Returns the peptide tolerance units for the search.

This is obtained from the TOLU= line in the parameters section of the results file.

The units will be one of:

%%
fraction expressed as a percentage
mmu
absolute milli-mass units, i.e. units of .001 Da
Da
absolute units of Da
ppm
fraction expressed as parts per million
See also:
http://www.matrixscience.com/help/search_field_help.html#TOL
Returns:
peptide tolerance units for the search
std::string getUSEREMAIL ( )

Returns the user's email address (if any) as entered in the search form.

This is obtained from the USERMAIL= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#NAME
Returns:
user email
std::string getUSERField ( int num )

Returns the user fields USER00, USER01, USER02 ... USER12.

Parameters:
num must be in the range 0..12.
Returns:
user fields
int getUSERID ( )

Returns the user's USERID.

This is obtained from the USERID= line in the parameters section of the results file. This value is the users id if Mascot security is enabled.

Searches prior to version 2.1 will not have this parameter in which case it will return 0. For searches with Mascot 2.1 or later, where security is not enabled, this function will also return 0.

See Mascot security and authentication module

Returns:
user id
std::string getUSERNAME ( )

Returns the user name (if any) as entered in the search form.

This is obtained from the USERNAME= line in the parameters section of the results file.

See also:
http://www.matrixscience.com/help/search_field_help.html#NAME
Returns:
user name as entered in the search form
double getVarModsDelta ( int num )

Returns the delta mass for a variable modification.

This value is obtained from the delta[num]= line in the masses section of the results file.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters:
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns:
delta mass for a variable modification
std::string getVarModsName ( int num ) const

This value is obtained from the delta[num]= line in the masses section of the results file.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters:
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns:
name of the specified variable modification selected by the user
double getVarModsNeutralLoss ( int num )

Returns the first neutral loss value for the specified variable modification.

Note:
This function is deprecated, since it only returns a single neutral loss value. This function has been replaced with getVarModsNeutralLosses() which returns multiple neutral losses

The value is obtained from the NeutralLoss[num]= line in the masses section of the results file.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters:
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns:
first neutral loss value for the specified variable modification.
std::vector< double > getVarModsNeutralLosses ( int num ) const

Returns all the neutral loss values for the specified variable modification.

The first neutral loss is obtained from the NeutralLoss[num]= line in the masses section of the results file. Subsequent neutral losses considered (if any) are obtained from the NeutralLoss[num]_master= line; the first value on the comma separated line would be for neutralLossNum=2, the second for neutralLossNum=3 etc.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters:
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns:
neutral loss values for the specified variable modification
std::vector< double > getVarModsPepNeutralLoss ( int num )

Returns the peptide neutral loss value(s) for the specified variable modification.

This value is obtained from the PepNeutralLoss[num]= line in the masses section of the results file.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters:
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns:
peptide neutral loss value(s) for the specified variable modification
std::vector< double > getVarModsReqPepNeutralLoss ( int num )

Returns the required peptide neutral loss value(s) for the specified variable modification.

These value is obtained from the ReqPepNeutralLoss[num]= line in the masses section of the results file.

Each variable modification is assigned a number 1 to 32 (up to 32 variable modifications are allowed). In the results, a string is assigned for each matched peptide, and each character in the string will be 0..9A..W (0 for no modification). Information about the modification can be found using these functions:

  • getVarModsName(int num)
  • getVarModsDelta(int num)
  • getVarModsNeutralLoss(int num)
  • getVarModsNeutralLosses(int num)
  • ms_mascotresults::getReadableVarMods()
  • getVarModsPepNeutralLoss(int num)
  • getVarModsReqPepNeutralLoss(int num)

See the Mascot installation and setup manual (configuration and log files chapter) for more information about variable modifications.

Parameters:
num is the modification number. See ms_peptide::getVarModsStr for details of how to obtain this number.
Returns:
required peptide neutral loss value(s) for the specified variable modification
The documentation for this class was generated from the following files:
  • ms_mascotresparams.hpp
  • ms_mascotresparams.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_unigene
Public Member Functions

ms_unigene Class Reference
[Mascot results file module]

This class encapsulates a complete unigene file. More...

#include <ms_mascotresunigene.hpp>

Collaboration diagram for ms_unigene:
[legend]

List of all members.

Public Member Functions

ms_unigene (const ms_mascotresfile &resfile, const char *filename)
The constructor for a unigene object.
~ms_unigene ()
Destructor.
const ms_unigene_entry * | findEntry (const char *id)
Given an accession, return a pointer to the relevant unigene entry.
std::string | getUnigeneForAccession (const std::string accession, const int index)
Return the Unigene 'accession' (ID) for a given EST accession.

Detailed Description

This class encapsulates a complete unigene file.

Creating one of these objects reads in the unigene file, creating a number of ms_unigene_entry objects. The gi and EMBL accessions are all indexed.

Constructor & Destructor Documentation

ms_unigene | ( | const ms_mascotresfile & | resfile,
 |  | const char * | filename
 | ) |  |

The constructor for a unigene object.

This is used from within the library but can also be called directly.

For details of how Unigene is configured within Mascot, see: http://www.matrixscience.com/help/seq_db_setup_EMBLEST.html

If a cache directory is specified for the ms_mascotresfile object, as returned by ms_mascotresfile::getCacheDirectory(), then this constructor will attempt to use a cache file for fast indexing. See Specifying cache file directory for details of the cache file location which will typically be in the same directory tree as the results cache files. The size and last modified date/time of the unigene file are used to determine if a new cache file needs to be produced. The cache filename for example, for Mm.data will be Mm.data.cdb. If the cache file does not exist and the constructor is unable to create the cache directory, then it will report the error: ms_mascotresfile::ERR_FAIL_MK_CACHE_DIR and continue without the cache.

If cache files are not used, the constructor loads the whole file into memory.

Parameters:
resfile | is required for error reporting. Any errors are added to the resfile object. The cache directory (if any) is obtained by calling ms_mascotresfile::getCacheDirectory()
filename | is the path to the unigene file.

Member Function Documentation

const ms_unigene_entry * findEntry ( const char * id )

Given an accession, return a pointer to the relevant unigene entry.

Parameters:
id is the unigene id - for example Hs.1234
Returns:
A pointer to the unigene entry or a NULL pointer if no match is found. The returned object will be deleted when the ms_unigene object is deleted so it should not be deleted by the client application.
std::string getUnigeneForAccession | ( | const std::string | accession,
 |  | const int | index
 | ) |  |

Return the Unigene 'accession' (ID) for a given EST accession.

Each accession can belong to zero or more unigene entries. This function must be called multiple times to return all the unigene entries that contain the accession.

The returned string can be passed to findEntry() to return the complete unigene entry.

Parameters:
accession | is the gi number or EBI accession
index | is a 1 based index. Increment this value until the function returns an empty string.
Returns:
the 'id' for the Unigene entry - e.g. Hs.1234 or an empty string if index is out of range
The documentation for this class was generated from the following files:
  • ms_mascotresunigene.hpp
  • ms_mascotresunigene.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_unigene_entry
Public Member Functions

ms_unigene_entry Class Reference
[Mascot results file module]

This class encapsulates a single entry from a unigene file. More...

#include <ms_mascotresunigene.hpp>

List of all members.

Public Member Functions

ms_unigene_entry (FILE *f, ms_unigene &unigene)
This constructor should only be called from within the library.
ms_unigene_entry (const std::string &id, const std::string &title, const std::string &gene, const std::string &cytoBand, const std::string &locusLink, const std::string &express, const long chromosome, const int numAccessions, const OFFSET64_T fileOffset)
This constructor should only be called from within the library.
~ms_unigene_entry ()
Destructor.
long | getChromosome () const
Return the chromosome that contains the unignene entry.
std::string | getCytoBand () const
Return the CYTOBAND - e.g. 4q21-q23.
std::string | getExpress () const
Return the EXPRESS entry. Can be very long - 5000 bytes.
OFFSET64_T | getFileOffset () const
Return the offset into the unigene data file for this entry.
std::string | getGene () const
Return the gene name for this entry - e.g. "ADH1B".
std::string | getID () const
Return the 'ID' of this entry - e.g. Hs.4.
std::string | getLocusLink () const
Return the LocusLink - e.g. 125.
int | getNumAccessions () const
Return the number of accessions (gi numbers or EMBL accessions) that comprise this entry.
std::string | getTitle () const
Return the 'title' of this entry - e.g. "alcohol dehydrogenase...".

Detailed Description

This class encapsulates a single entry from a unigene file.

A number of objects of this class will be created when a ms_unigene object is created.

Constructor & Destructor Documentation

ms_unigene_entry | ( | FILE * | f,
 |  | ms_unigene & | unigene
 | ) |  |

This constructor should only be called from within the library.

Reads lines in the file up to the next // and fills the object.

If the id_ value is empty, (use getID()) or the number of accessions (use getNumAccessions()) then the object has not been initialised correcty

Parameters:
f | is a file pointer returned by the 'C' fopen() function
unigene | is the object that stores all the accession -> id mappings.
ms_unigene_entry | ( | const std::string & | id,
 |  | const std::string & | title,
 |  | const std::string & | gene,
 |  | const std::string & | cytoBand,
 |  | const std::string & | locusLink,
 |  | const std::string & | express,
 |  | const long | chromosome,
 |  | const int | numAccessions,
 |  | const OFFSET64_T | fileOffset
 | ) |  |

This constructor should only be called from within the library.

Parameters:
id | is the unigene id as returned by the getID() function.
title | is the unigene title as returned by the getTitle() function.
gene | is the gene name as returned by the getGene() function.
cytoBand | is the CYTOBAND as returned by the getCytoBand() function.
locusLink | is the LocusLink as returned by the getLocusLink() function.
express | is EXPRESS entry as returned by the getExpress() function.
chromosome | is the chromosome that contains the unignene entry as returned by the getChromosome() function.
numAccessions | is the number of accessions that comprise this unigene entry.
fileOffset | is the byte offset into the .data file for this unigene entry.

Member Function Documentation

long getChromosome ( ) const [inline]

Return the chromosome that contains the unignene entry.

Returns:
the chromosome number
std::string getCytoBand ( ) const [inline]

Return the CYTOBAND - e.g. 4q21-q23.

Returns:
the CYTOBAND
std::string getExpress ( ) const [inline]

Return the EXPRESS entry. Can be very long - 5000 bytes.

For example, can be of the form:

               adipose tissue| blood| bone marrow| brain| connective tissue| dorsal
Returns:
the express entry string.
OFFSET64_T getFileOffset ( ) const [inline]

Return the offset into the unigene data file for this entry.

This function returns quickly if an index file has been created.

Returns:
the number of bytes into the file where this entry starts
std::string getGene ( ) const [inline]

Return the gene name for this entry - e.g. "ADH1B".

Returns:
the gene name
std::string getID ( ) const [inline]

Return the 'ID' of this entry - e.g. Hs.4.

Returns:
the ID (also called accession) for the entry
std::string getLocusLink ( ) const [inline]

Return the LocusLink - e.g. 125.

Seems to be identical to the gene number in most cases?

Returns:
int getNumAccessions ( ) const [inline]

Return the number of accessions (gi numbers or EMBL accessions) that comprise this entry.

The accessions themselves cannot be returned from this object. See ms_unigene::findEntry

Returns:
The number of accessions
std::string getTitle ( ) const [inline]

Return the 'title' of this entry - e.g. "alcohol dehydrogenase...".

Returns:
a readable name for the entry.
The documentation for this class was generated from the following files:
  • ms_mascotresunigene.hpp
  • ms_mascotresunigene.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Mascot configuration files module

Classes

class | ms_clusterparams
An instance of this class represents all the parameters specified in the Cluster section of mascot.dat. More...
class | ms_computeraddress
The class serves as a container for computer address parameters for cluster mode. More...
class | ms_cronjob
Represents a single entry from the cron section of mascot.dat. More...
class | ms_cronoptions
Contains parameters from the cron section of mascot.dat. More...
class | ms_crosslinking_accession
Accession element in crosslinking.xml More...
class | ms_crosslinking_accessions
Accessions element in crosslinking.xml More...
class | ms_crosslinking_configfile
This class represents the file crosslinking.xml. More...
class | ms_crosslinking_does_not_pair_with
mxm:does_not_pair_with element in crosslinking.xml More...
class | ms_crosslinking_filters
Filters element in crosslinking.xml More...
class | ms_crosslinking_linker
Linker element in crosslinking.xml More...
class | ms_crosslinking_linkers
Linkers element in crosslinking.xml More...
class | ms_crosslinking_method
Represents a method object in crosslinking.xml More...
class | ms_crosslinking_monolink
Monolink element in crosslinking.xml More...
class | ms_crosslinking_parameter
Parameter name and value pair. More...
class | ms_crosslinking_parameters
A class that represents base parametersType in crosslinking_1.xsd. More...
class | ms_crosslinking_scope
Scope element in crosslinking.xml More...
class | ms_crosslinking_settings
Settings element in crosslinking.xml More...
class | ms_databaseoptions
An instance of this class represents a single database definition from the Databases section of mascot.dat. More...
class | ms_databases
An instance of this class represents the Databases section of mascot.dat. More...
class | ms_datfile
Encapsulates the mascot.dat file that contains the most important parameters. More...
class | ms_dbprocessors
Represent a single dabatase entry in the Processors section. More...
class | ms_enzyme
Represent a single entry in the enzymes file. More...
class | ms_enzymefile
Reads and parses the enzymes file that contains multiple enzyme definitions. More...
class | ms_fragmentationrules
This class encapsulates a single entry (an instrument) from a fragmentation_rules file. More...
class | ms_fragrulesfile
This class encapsulates a complete fragmentation_rules file. More...
class | ms_libraryoptions
Represents the LibraryOptions section of mascot.dat. More...
class | ms_license
The class provides access license details in read-only mode. More...
class | ms_mascotfiles
An instance of this class contains configuration files paths (except for mascot.dat). More...
class | ms_mascotoptions
An instance of this class represents all the parameters specified in the Options section of mascot.dat. More...
class | ms_masses
Reads and parses the masses file with residue and atom masses. More...
class | ms_modfile
Use this class in order to read in the amino acid modification file. More...
class | ms_modification
The class represents a single modification-entry in mod_file. More...
class | ms_modvector
General usage class for creating lists of modifications to be passed as parameters. More...
class | ms_obofile
The class provides simplified access to ontology files in the .obo format. More...
class | ms_parseoptions
Represents the PARSE section of mascot.dat. More...
class | ms_parserule
Represents a single regular expression parsing rule. More...
class | ms_parserule_plus
Represents regular expression parse rule plus some additional parameters. More...
class | ms_processoroptions
An instance of this class represents all the parameters specified in the Processors section of mascot.dat. More...
class | ms_processors
This class is designed to retrieve current CPU configuration on the computer and set affinity. More...
class | ms_quant_average
An object of this class represent a single "average" element in quantitation.xml. More...
class | ms_quant_component
An object of this class represent a single component element in quantitation.xml. More...
class | ms_quant_composition
Describes the compositionType type in quantitation.xml. More...
class | ms_quant_configfile
Use this class in order to read/write quantitation.xml. More...
class | ms_quant_correction
Represents a correction element. More...
class | ms_quant_element
The element sub-element of compositionType in quantitation.xml. More...
class | ms_quant_integration
An object of this class represent a single integration element in quantitation.xml. More...
class | ms_quant_isotope
Represents an isotope element. More...
class | ms_quant_localdef
Represents a local_definition element. More...
class | ms_quant_method
An object of this class represent a single quantitation method from quantitation.xml. More...
class | ms_quant_modgroup
An object of this class represent a single modification group element in quantitation.xml. More...
class | ms_quant_moverz
Parameter name and value pair. More...
class | ms_quant_multiplex
An object of this class represent a multiplex element in quantitation.xml. More...
class | ms_quant_neutralloss
A neutral loss for the sequence ions, e.g. loss of phosphate. More...
class | ms_quant_normalisation
An object of this class represent a single normalisation element in quantitation.xml. More...
class | ms_quant_normalisation_peptide
An object of this class represent a single peptide element in quantitation.xml. More...
class | ms_quant_normalisation_peptides
An object of this class represent a collection of peptide elements in quantitation.xml. More...
class | ms_quant_normalisation_protein
An object of this class represent a single protein element in quantitation.xml. More...
class | ms_quant_normalisation_proteins
An object of this class represent a collection of peptide elements in quantitation.xml. More...
class | ms_quant_numerator
Represent numerator_component and denominator_component elements. More...
class | ms_quant_outliers
An object of this class represent a single OUTLIERS element in quantitation.xml. More...
class | ms_quant_parameter
Parameter name and value pair. More...
class | ms_quant_parameters
A class that represents base parametersType in quantitation.xml. More...
class | ms_quant_pepneutralloss
A neutral loss from the precursor. More...
class | ms_quant_precursor
An object of this class represent a single precursor element in quantitation.xml. More...
class | ms_quant_protocol
An object of this class represent a protocol element in quantitation.xml. More...
class | ms_quant_quality
An object of this class represent a single quality element in quantitation.xml. More...
class | ms_quant_ratio
Represents the ratioType type for the report_ratio element in quantitation.xml. More...
class | ms_quant_replicate
An object of this class represent a single replicate element in quantitation.xml. More...
class | ms_quant_reporter
An object of this class represents a single reporter element in quantitation.xml. More...
class | ms_quant_satellite
An object of this class represent a single satellite element in quantitation.xml. More...
class | ms_quant_specificity
Describes a specificity element in quantitation.xml (Unimod style specificity). More...
class | ms_quant_unmodified
Describes an unmodified element in quantitation.xml. More...
class | ms_taxnodesfiles
Filenames and formats for taxonomy nodes or genetic codes files. More...
class | ms_taxonomychoice
The class represents a single taxonomy choice entry in the taxonomy file. More...
class | ms_taxonomyfile
Use this class in order to read in a taxonomy file. More...
class | ms_taxonomyrules
This class represents a single Taxonomy_XXX section in mascot.dat. More...
class | ms_taxonomytree
The complete taxonomy tree as built from one or more files such as nodes.dmp. More...
class | ms_taxspeciesfiles
An instance of this class describes one entry of taxonomy species files. More...
class | ms_umod_aminoacid
Represents an "amino acid" object in unimod.xml. More...
class | ms_umod_composition
Represents the composition type in unimod.xml. More...
class | ms_umod_configfile
This class represents the file unimod.xml. More...
class | ms_umod_element
Represents an element object in unimod.xml. More...
class | ms_umod_elemref
Represents the elemref_t type in unimod.xml. More...
class | ms_umod_modbrick
Represents a modification brick object in unimod.xml. More...
class | ms_umod_modification
Represents a modif object in unimod.xml. More...
class | ms_umod_neutralloss
Represents NeutralLoss and PepNeutralLoss objects in unimod.xml. More...
class | ms_umod_specificity
Represents modification specificity objects in unimod.xml. More...
class | ms_umod_xref
Represents the cross references objects in unimod.xml. More...
class | ms_unigeneoptions
An instance of this class represents all the parameters specified in UniGene section of mascot.dat. More...
class | ms_wwwentry
Represent a single entry in the WWW section of mascot.dat. More...
class | ms_wwwoptions
Represents the whole WWW section. More...
class | ms_xml_parameter
Parameter name and value pair. More...
class | ms_xml_parameters
A class that represents a base parametersType. More...

Modules

Configuration files
Examples for the configuration files module
Fixed values for quantitation.xml
Fixed values for crosslinking.xml

Enumerations

enum | { MAX_VAR_MODS = 'W' -'A' + 10 }

Maximum number of variable mods.

More...
enum DATABASE_TYPE {
AA = 0,
NA = 1,
SL = 2,
SLREF = 3
}
enum MASS_TYPE {
MASS_TYPE_MONO = 0x0000,
MASS_TYPE_AVE = 0x0001
}

All possible mass types.

More...
enum MOD_TYPES {
MOD_TYPE_RESIDUE = 0,
MOD_TYPE_N_TERM = 1,
MOD_TYPE_C_TERM = 2,
MOD_TYPE_N_PROTEIN = 3,
MOD_TYPE_C_PROTEIN = 4,
MOD_TYPE_N_TERM_RESIDUE = 5,
MOD_TYPE_C_TERM_RESIDUE = 6,
MOD_TYPE_N_PROTEIN_RESIDUE = 7,
MOD_TYPE_C_PROTEIN_RESIDUE = 8
}
enum OPERATING_SYS {
_OS_UNKNOWN = 0,
_OS_WINDOWS_NT = 1,
_OS_LINUX = 2,
_OS_NUM_OPERATING_SYS = 3
}
enum TAX_NODE_FORMAT {
TAX_NODE_NCBI,
TAX_NODE_GENCODE
}
enum TAX_SPECIES_FORMAT {
TAX_SPECIES_NCBI,
TAX_SPECIES_SWISSPROT,
TAX_SPECIES_PDB,
TAX_SPECIES_GI2TAXID,
TAX_SPECIES_ACC2TAXID,
TAX_SPECIES_EXPLICIT
}
enum WWW_TYPE {
WWW_SEQ = 0,
WWW_REP = 1
}

Detailed Description

The Mascot configuration files module is used to simplify retrieving and saving information to the configuration files.

Enumeration Type Documentation

anonymous enum

Maximum number of variable mods.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
MAX_VAR_MODS

The results file uses 1..9 and A..W (1..32).

enum DATABASE_TYPE

Definition of all supported database types.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
AA

Protein sequence database (FASTA file, amino acid)

NA

NA sequence database (FASTA file, nucleic acid)

SL

Spectral Library (MSP file)

SLREF

FASTA reference database of a Spectral Library.

enum MASS_TYPE

All possible mass types.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
MASS_TYPE_MONO

monoisotopic mass index

MASS_TYPE_AVE

average mass index

Examples:
config_masses.cs, and tools_aahelper.cs.
enum MOD_TYPES

Definitions for possible modification types.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
MOD_TYPE_RESIDUE

Applies to specific residues, independent of position within the peptide.

MOD_TYPE_N_TERM

Applies to the peptide N-terminus, independent of residue identity.

MOD_TYPE_C_TERM

Applies to the peptide C-terminus, independent of residue identity.

MOD_TYPE_N_PROTEIN

Applies to the protein N-terminus, independent of residue identity.

MOD_TYPE_C_PROTEIN

Applies to the protein C-terminus, independent of residue identity.

MOD_TYPE_N_TERM_RESIDUE

Applies to a specific residue only when that residue is at N-terminus.

MOD_TYPE_C_TERM_RESIDUE

Applies to a specific residue only when that residue is at C-terminus.

MOD_TYPE_N_PROTEIN_RESIDUE

Applies to a specific residue only when that residue is at N-terminus of a protein.

MOD_TYPE_C_PROTEIN_RESIDUE

Applies to a specific residue only when that residue is at C-terminus of a protein.

enum OPERATING_SYS

List of all supported operating systems (past and present)

Mascot runs on a number of different operating systems. The following are currently supported.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
_OS_UNKNOWN

Unknown OS.

_OS_WINDOWS_NT

WindowsXXX.

_OS_LINUX

Linux.

_OS_NUM_OPERATING_SYS

Placeholder.

enum TAX_NODE_FORMAT

Possible formats for the nodes.dmp and gencode.dmp files.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TAX_NODE_NCBI

NCBI nodes.dmp format.

TAX_NODE_GENCODE

NCBI gencode.dmp format.

enum TAX_SPECIES_FORMAT

All possible taxonomy species file formats.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TAX_SPECIES_NCBI

NCBI names.dmp taxonomy species files.

TAX_SPECIES_SWISSPROT

SwissProt.

TAX_SPECIES_PDB

PDB.

TAX_SPECIES_GI2TAXID

GI2TAXID.

TAX_SPECIES_ACC2TAXID

Simple 'accession taxID' (any whitespace).

TAX_SPECIES_EXPLICIT

No lookup required, because the ID is given in the description line. For example: >IPI:IPI00000001.2 Tax_Id=9606 Double-stranded RNA ...

enum WWW_TYPE

All supported types of entries in the WWW section.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
WWW_SEQ

Sequence string source.

WWW_REP

Full text report source.

Examples:
config_mascotdat.cs.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Configuration files
[Mascot configuration files module]

Mascot configuration files are represented by library classes and can be dealt with programmatically from programs written in the supported languages.

Configuration file classes

The following configuration files are supported:

mascot.dat

Main configuration file represented by the ms_datfile class and divided into several sections. Each section is, in turn, represented by a corresponding class.

enzymes

List of available enzymes. The corresponding class is ms_enzymefile.

fragmentation_rules

Information about available instruments for MS/MS searches; represented by ms_fragrulesfile.

mascot.license

Software license file that can only be local read-only file. The corresponding class ms_license allows checking the validity of the license and to obtain some additional information. Please note the ms_license class will only work with license files from Mascot release 2.3 or earlier.

masses

Chemical elements and amino acid masses. Can be read/written with ms_masses.

mod_file and substitutions

Modifications for regular and error-tolerant searches, respectively. The single class ms_modfile can process both of them.

unimod.xml

Protein modifications; can be accessed in read-only mode on http://www.unimod.org using either ms_modfile or ms_umod_configfile.

quantitation.xml
Configuration parameters for quantitation experiments; represented by ms_quant_configfile.

One additional class, ms_processors, doesn't correspond to any file but can be used to obtain information about available CPUs in the system.

All files except for mascot.license and unimod.xml can be read and written locally in text format. ms_modfile can import the unimod.xml file and then store all configuration information in a local text file, but not vice versa. ms_umod_configfile allows changing the content and saving unimod.xml in XML-format locally.

Each configuration file class provides a range of get/set methods for accessing individual properties. Instances of the classes can be used even without accessing a physical or remote file; default values are provided where appropriate. However, classes that represent configuration files with many entries (enzymes, instruments, modifications, etc.) will by default contain empty lists of entries.

In general, all files except for mascot.license can be accessed remotely via Internet, altered and then stored locally (if needed). These operations are described in more detail below.

Reading from and writing to configuration files

Reading from a configuration file can be done in two ways. The easiest way is to use an immediate-action constructor that accepts a string file name as a parameter:

C++
    matrix_science::ms_datfile datFile("../config/mascot.dat");

    if ( datFile.isValid() )
    {
        // extract some properties here
        // ...
    }

Perl
    my $datFile = msparser::ms_datfile->new("../config/mascot.dat");

    if ($datFile->isValid()) {
        # extract some properties here
        # ...
    }

Java and C#
    ms_datfile datFile = new ms_datfile("../config/mascot.dat");

    if (datFile.isValid())
    {
        // extract some properties here
        // ...
    }

Python
    ms_datfile = msparser.ms_datfile("../config/mascot.dat")

    if datFile.isValid() :
        # extract some properties here
        # ...

As shown in the last example, an object has to be tested for the presence of any fatal errors before continuing any work with it. Possible errors include a missing or inaccessible file as well as wrong file format or inconsistent values. Every class representing a configuration file is derived from ms_errors; please refer to Error Handling for details.

Another way to read from a file is to create an instance of representing class, set a file name and call the read_file() method:

C++
    ms_enzymefile enzFile();
    enzFile.setFileName("../config/enzymes");
    enzFile.read_file();

    if (enzFile.isValid())
    {
        // obtain information here
        // ...
    }

Perl
    my $enzFile = new msparser::ms_enzymefile();
    $enzFile->setFileName("../config/enzymes");
    $enzFile->read_file();

    if ($enzFile->isValid()) {
        # obtain information here
        # ...
    }

Java and C#
    ms_enzymefile enzFile = new ms_enzymefile();
    enzFile.setFileName("../config/enzymes");
    enzFile.read_file();

    if (enzFile.isValid())
    {
        // obtain information here
        // ...
    }

Python
    enzFile = msparser.ms_enzymefile()
    enzFile.setFileName("../config/enzymes")
    enzFile.read_file()

    if enzFile.isValid() :
        # obtain information here
        # ...

One exception to these examples is ms_quant_configfile, which requires a local path to an XML schema file in addition to the quantitation.xml file name and path. You can submit the schema path to either the constructor or by using the setSchemaFileName() method:

C++
    // Here we access the file remotely (see below for more information), but
    // a local file name can also be used. However, the schema file should be
    // stored locally.
    ms_quant_configfile quantFile("http://localhost/mascot/cgi", "C:\quantitation_1.xsd");

    if (quantFile.isValid()) {
        // obtain information here
        // ...
    }

Perl
    # Here we access the file remotely (see below for more information), but
    # a local file name can also be used. However, the schema file should be
    # stored locally.
    my $quantFile = new msparser::ms_quant_configfile(
        "http://localhost/mascot/cgi", "C:\quantitation_1.xsd"
    );

    if ($quantFile->isValid()) {
        # obtain information here
        # ...
    }

Java and C#
    // Here we access the file remotely (see below for more information), but
    // a local file name can also be used. However, the schema file should be
    // stored locally.
    ms_quant_configfile quantFile = new ms_quant_configfile(
        "http://localhost/mascot/cgi", "C:\quantitation_1.xsd"
    );

    if (quantFile.isValid()) {
        // obtain information here
        // ...
    }

Python
    # Here we access the file remotely (see below for more information), but
    # a local file name can also be used. However, the schema file should be
    # stored locally.
    quantFile = msparser.ms_quant_configfile(
        "http://localhost/mascot/cgi", "C:\quantitation_1.xsd"
        )

    if quantFile.isValid() :
        # obtain information here
        # ...

The quantitation schema file is distributed as part of Mascot Parser and should not be changed to avoid parsing problems.

Writing to files is only allowed on local files (on a hard disc or in a local network). Writing can be done via using the save_file() method. You can use setFileName() to change the file name and path if you need to save the file in a new location.

XML-format configuration files

unimod.xml can be opened with ms_modfile; supply it with the full file name (absolute or relative) that has a proper extension '.xml'. Files with any other extension will be treated as being in a text format.

ms_modfile cannot be used to save data in unimod.xml. If the content is initially imported from it, then it can only be stored as a new text file with a different name. One of the reasons for this restriction lies in inevitable loss of information while importing Unimod files. ms_umod_configfile was designed to overcome this limitation.

Remote file location

All configuration files except for mascot.license can be accessed remotely in the same way as they are read from local files. The mandatory prefix "http://" has to be used to indicate the remote location. Configuration files are accessed though the get_params.pl script on Mascot Server, which is in the mascot/cgi directory. Example URL:

   http://your-server/mascot/cgi

The configuration file class adds /get_params.pl?Show=xxxx to the end of the URL.

The Unimod file can only be accessed at an explicit location (usually http://www.unimod.org/xml/unimod.xml).

A proxy server may have to be defined before downloading files from the Intranet/Internet. This can be done in one of two possible ways:

C++
    // Setting the proxy server explicitly:
    ms_datfile::setProxyServer("proxy_server_name");
    ms_datfile::setProxyUsername("user_name");
    ms_datfile::setProxyPassword("user_password");
    // Now we can download safely.
    ms_fragrulesfile fragRules("http://host_name/mascot/cgi");

    // Retrieving proxy settings from mascot.dat:
    ms_datfile datFile("../config/mascot.dat");
    // Now we can download safely.
    ms_umod_configfile unimodFile("http://www.unimod.org/xml/unimod.xml");

Perl
    # Setting the proxy server explicitly:
    msparser::ms_datfile::setProxyServer("proxy_server_name");
    msparser::ms_datfile::setProxyUsername("user_name");
    msparser::ms_datfile::setProxyPassword("user_password");
    # Now we can download safely.
    my $fragRules = msparser::ms_fragrulesfile->new("http://host_name/mascot/cgi");

    # Retrieving proxy settings from mascot.dat:
    my $datFile = msparser::ms_datfile->new("../config/mascot.dat");
    # Now we can download safely.
    my $unimodFile = msparser::ms_umod_configfile->new("http://www.unimod.org/xml/unimod.xml");

Java and C#
    // Setting the proxy server explicitly:
    ms_datfile.setProxyServer("proxy_server_name");
    ms_datfile.setProxyUsername("user_name");
    ms_datfile.setProxyPassword("user_password");
    // Now we can download safely.
    ms_fragrulesfile fragRules = new ms_fragrulesfile("http://host_name/mascot/cgi");

    // Retrieving proxy settings from mascot.dat:
    ms_datfile datFile = new ms_datfile("../config/mascot.dat");
    // Now we can download safely.
    ms_umod_configfile unimodFile = new ms_umod_configfile("http://www.unimod.org/xml/unimod.xml");

Python
    # Setting the proxy server explicitly:
    msparser.ms_datfile.setProxyServer("proxy_server_name")
    msparser.ms_datfile.setProxyUsername("user_name")
    msparser.ms_datfile.setProxyPassword("user_password")
    # Now we can download safely.
    fragRules = msparser.ms_fragrulesfile("http://host_name/mascot/cgi")

    # Retrieving proxy settings from mascot.dat:
    datFile = msparser.ms_datfile("../config/mascot.dat")
    # Now we can download safely.
    unimodFile = msparser.ms_umod_configfile("http://www.unimod.org/xml/unimod.xml")
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Examples for the configuration files module
[Mascot configuration files module]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
Reading the mascot.dat file | config_mascotdat.pl | config_mascotdat.cpp | config_mascotdat.java | config_mascotdat.py | config_mascotdat.cs
Reading the enzymes file | config_enzymes.pl | config_enzymes.cpp | config_enzymes.java | config_enzymes.py | config_enzymes.cs
Reading the fragmentation rules file | config_fragrules.pl | config_fragrules.cpp | config_fragrules.java | config_fragrules.py | config_fragrules.cs
Reading the mascot.license file | config_license.pl | config_license.cpp | config_license.java | config_license.py | -
Reading the masses file | config_masses.pl | config_masses.cpp | config_masses.java | config_masses.py | config_masses.cs
Reading the modifications from mod_file | config_modfile.pl | config_modfile.cpp | config_modfile.java | config_modfile.py | config_modfile.cs
Determining the computer CPU configuration | config_procs.pl | config_procs.cpp | config_procs.java | config_procs.py | config_procs.cs
Reading the taxonomy file | config_taxonomy.pl | config_taxonomy.cpp | config_taxonomy.java | config_taxonomy.py | config_taxonomy.cs
Reading the quantitation.xml file | config_quantitation.pl | config_quantitation.cpp | config_quantitation.java | config_quantitation.py | config_quantitation.cs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Fixed values for quantitation.xml
[Mascot configuration files module]

Some attributes and element values in quantitation.xml are restrictions of the string-type and can accept one of the fixed values defined in a special enumeration-list.

Type mqm:calcType

How to calculate a ratio for a protein
List of values

Value | Description
median | Protein ratio is the median of the peptide ratios
average | Protein ratio is the unweighted average of the peptide ratios
weighted | For each component, the intensity values are summed over the set of peptides and the protein ratio is calculated from the summed values

Type mqm:correctionTypeType

Isotope correction factor
List of values

Value | Description
AB certificate | Percentage isotopic impurities for each reagent as tabulated on a Certificate of Analysis.
averagine | Mass dependent isotope overlap. Isotope purity specified using element attribute of correction
impurity | Isotope under-enrichment

Type mqm:integrationMethodType

Integration method
List of values

Value | Description
none | No integration
simpsons | Numerical integration using Simpsons rule
trapezium | Numerical integration using the trapezium rule

Type mqm:ionSeriesType

Symbols for sequence ion series
List of values

Value | Description
a | a series fragment ions
b | b series fragment ions
c | c series fragment ions
x | x series fragment ions
y | y series fragment ions
z | z series fragment ions
z+1 | -
z+2 | -

Type mqm:modeType

Specificity for a group of modifications
List of values

Value | Description
fixed | Quantitative modification
variable | Non-quantitative modification
exclusive | A given peptide may carry one or the other set of modifications, but never a mixture of both

Type mqm:normaliseType

normalisation method
List of values

Value | Description
none | No normalisation
sum | (Reporter protocol only) The total intensity of each reporter ion, summed across all MS/MS spectra, is made equal
average | For each ratio, the geometric mean of all reported values for peptide matches is made unity
median | For each ratio, the median of all reported values for peptide matches is made unity

Type mqm:outlierType

method of detecting outliers
List of values

Value | Description
none | No outlier removal
dixons | Detect and remove outliers using Dixon's method
auto | Detect and remove outliers using Dixon's method or Rosner's method according to the number of values
grubbs | Detect and remove outliers using Grubb's method
rosners | Detect and remove outliers using Rosner's method

Type mqm:positionType

Unimod position
List of values

Value | Description
Anywhere | Unrestricted
Any N-term | Modification only if residue or terminus is at peptide N-term
Any C-term | Modification only if residue or terminus is at peptide C-term
Protein N-term | Modification only if residue or terminus is at N-term of intact protein
Protein C-term | Modification only if residue or terminus is at C-term of intact protein

Type mqm:proteinScoreType

Mascot protein score method
List of values

Value | Description
standard | Use Mascot standard protein scoring
mudpit | Use Mascot mudpit protein scoring

Type mqm:scanType

Data source for integration
List of values

Value | Description
survey | Precursor peak area from survey scan
zoom | Precursor peak area from zoom scan
header | XIC value taken from file header
fragments | Sum of fragment peak areas from MS/MS scan
mrm | Multiple reaction monitoring

Type mqm:siteType

Unimod site
List of values

Value | Description
A | Alanine
C | Cysteine
D | Aspartic acid
E | Glutamic acid
F | Phenylalanine
G | Glycine
H | Histidine
I | Isoleucine
J | Unassigned
K | Lysine
L | Leucine
M | Methionine
N | Asparagine
O | Unassigned
P | Proline
Q | Glutamine
R | Arginine
S | Serine
T | Threonine
U | Selenocysteine
V | Valine
W | Tryptophan
Y | Tyrosine
N-term | Amino terminus
C-term | Carboxy terminus

Type mqm:thresholdType

Significance threshold for peptide matches
List of values

Value | Description
minimum score | Significance threshold for peptide matches is a minimum score
maximum expect | Significance threshold for peptide matches is a maximum expectation value
at least identity | Significance threshold for peptide matches is score at or above identity threshold
at least homology | Significance threshold for peptide matches is score at or above homology threshold

Type mqm:timeUnitType

time units
List of values

Value | Description
seconds | seconds
minutes | minutes
% | Fraction expressed as parts per 100
ppm | Fraction expressed as parts per million

Type mqm:averageSelectionType

List of allowed values for selection-attribute
List of values

Value | Description
unique_sequence | Peptides to be used for quantitation are required to be unique sequences
unique_mr | Accept different modification states of same sequence
unique_mz | Accept peptides with same sequence and modifications in different charge states

Type mqm:reporterTolUnitType

Units for reporter_tol
List of values

Value | Description
Da | Daltons
ppm | ppm
mmu | mmu
% | %
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Fixed values for crosslinking.xml
[Mascot configuration files module]

Some attributes and element values in crosslinking.xml are restrictions of the string-type and can accept one of the fixed values defined in a special enumeration-list.

Type mxm:strategyNameType

Strategy used when identifying peptides or pairs of peptides with crosslinks
List of values

Value | Description
None | No crosslinking
Brute-force | Find intact crosslinks among all pairs of peptides
CID-ETD-MS2 | Attempt to match CID and ETD scans using pairs of candidate peptides
CID-MS2-MS3-hybrid | Attempt to match MS2 scans using pairs of candidate peptides and MS3 scans using individual candidate peptides
CID-MS3 | Attempt to match MS3 scans using individual candidate peptides
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_clusterparams
Public Types | Public Member Functions

ms_clusterparams Class Reference
[Mascot configuration files module]

An instance of this class represents all the parameters specified in the Cluster section of mascot.dat. More...

#include <ms_clusterparams.hpp>

Inheritance diagram for ms_clusterparams:
[legend]
Collaboration diagram for ms_clusterparams:
[legend]

List of all members.

Public Types

enum | { NUM_PROCESSORS_AUTO_DETECT = -1 }

Value used to indicate that the number of processors in the first SubClusterSet should be automatically determined at runtime.

More...

Public Member Functions

ms_clusterparams ()
Default constructor.
ms_clusterparams (const ms_clusterparams &src)
Copying constructor.
~ms_clusterparams ()
Destructor.
void | appendSubCluster (const int id, const int maxCPUs)
Add a new SubClusterSet entry.
void | clearSubClusters ()
Erases information about all sub clusters.
void | copyFrom (const ms_clusterparams *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
int | getCheckNodesAliveFreq () const
Returns the value of CheckNodesAliveFreq.
std::string | getDefaultNodeHomeDir () const
Returns the value of DefaultNodeHomeDir.
std::string | getDefaultNodeHomeDirFromMaster () const
Returns the value of DefaultNodeHomeDirFromMaster.
OPERATING_SYS | getDefaultNodeOS () const
Returns value of DefaultNodeOS as one of the enumeration members.
int | getDefaultPort () const
Returns the value of DefaultPort.
std::string | getIPCLogfile () const
Returns the value of IPCLogfile.
int | getIPCLogging () const
Returns value of IPCLogging.
int | getIPCTimeout () const
Returns the value of IPCTimeout.
std::string | getMascotNodeRebootScript () const
Returns the value of MascotNodeRebootScript.
std::string | getMascotNodeScript () const
Returns the value of MascotNodeScript.
const ms_computeraddress * | getMasterComputer () const
Returns an instance of ms_computeraddress created for MasterComputerName.
std::string | getNodeSequenceDatabaseDir () const
Returns the value of NodeSequenceDatabaseDir.
int | getNumberOfSubClusters () const
Returns the number of SubClusterSet parameter entries, which is a total number of sub-clusters.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
int | getSecsToWaitForNodeAtStartup () const
Returns the value of SecsToWaitForNodeAtStartup.
int | getSubClusterID (const int index) const
Returns sub-cluster ID by its index.
int | getSubClusterMaxCPU (const int index) const
Returns the Y part of SubClusterSet.
bool | isEnabled () const
Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_clusterparams & | operator= (const ms_clusterparams &right)
Assignment operator for C++ client applications.
void | setCheckNodesAliveFreq (const int value)
Change CheckNodesAliveFreq.
void | setDefaultNodeHomeDir (const char *str)
Change DefaultNodeHomeDir.
void | setDefaultNodeHomeDirFromMaster (const char *str)
Change DefaultNodeHomeDirFromMaster.
void | setDefaultNodeOS (const OPERATING_SYS value)
Change DefaultNodeOS.
void | setDefaultPort (const int value)
Change DefaultPort.
void | setEnabled (const bool flag)
Change Enabled.
void | setIPCLogfile (const char *str)
Change IPCLogfile.
void | setIPCLogging (const int value)
Change IPCLogging.
void | setIPCTimeout (const int value)
Change IPCTimeout.
void | setMascotNodeRebootScript (const char *str)
Change MascotNodeRebootScript.
void | setMascotNodeScript (const char *str)
Change MascotNodeScript.
void | setMasterComputer (const ms_computeraddress *value)
Change MasterComputerName.
void | setNodeSequenceDatabaseDir (const char *str)
Change NodeSequenceDatabaseDir.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSecsToWaitForNodeAtStartup (const int value)
Change SecsToWaitForNodeAtStartup.
void | setSectionAvailable (const bool value)
Change availability of the section, i.e. if it should be saved in a file.

Detailed Description

An instance of this class represents all the parameters specified in the Cluster section of mascot.dat.

An instance of this class is created and polulated in ms_datfile. It can also be created separately and initialized with default values. One can create an instance of the class or copy from another instance in order to pass it then as an parameters-containing object. For detailed information on any of the options please consult Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_mascotdat.cpp.

Member Enumeration Documentation

anonymous enum

Value used to indicate that the number of processors in the first SubClusterSet should be automatically determined at runtime.

The value assigned will be identical to the number of 'processors' licensed.

See also:
getSubClusterMaxCPU().

(Defined as an enum rather than static const int to support VC6)

Enumerator:
NUM_PROCESSORS_AUTO_DETECT

Value used to indicate that the number of processors in the first SubClusterSet should be automatically determined at runtime.

Member Function Documentation

void appendSubCluster | ( | const int | id,
 |  | const int | maxCPUs
 | ) |  |

Add a new SubClusterSet entry.

See getNumberOfSubClusters() for more information.

Parameters:
id | unique ID identifying a sub-cluster (from 0 to 49) to set number of CPUs for.
maxCPUs | maximum number of CPUs for the specified sub-cluster (from 0 to 1024*64).
void clearSubClusters ( )

Erases information about all sub clusters.

One entry (0,0) for "this subcluster" stays in the list forever.

int getCheckNodesAliveFreq ( ) const

Returns the value of CheckNodesAliveFreq.

The CheckNodesAliveFreq parameter specifies the interval in seconds between 'health checks' on the nodes. Default value is 30 sec.

Returns:
Frequency to check if nodes are alive
std::string getDefaultNodeHomeDir ( ) const

Returns the value of DefaultNodeHomeDir.

If no specific home directory is specified for a particular node in nodelist.txt, then the value of the DefaultNodeHomeDir parameter is used. To override this setting for a particular node, enter the directory on the node line in nodelist.txt.

Default is the /MascotNode folder.

See also:
getDefaultPort()
Returns:
Default node home directory
std::string getDefaultNodeHomeDirFromMaster ( ) const

Returns the value of DefaultNodeHomeDirFromMaster.

This is the directory on the node as seen from the master. For a Windows cluster, this must be present and specified as a UNC name. For a Unix cluster, this parameter must be commented out.

Default is

\\<host_name>\c$\mascotnode
Returns:
Default node home directory from master
OPERATING_SYS getDefaultNodeOS ( ) const

Returns value of DefaultNodeOS as one of the enumeration members.

If no OS is defined for a particular node, then this parameter value is assumed as the OS. See OPERATING_SYS for a list of possible values.

Default is _OS_WINDOWS_NT (2).

Returns:
Default node OS
int getDefaultPort ( ) const

Returns the value of DefaultPort.

If no port number is specified for a node in nodelist.txt, then this port number will be used.

Default is 5001.

See also:
getDefaultNodeHomeDir()
Returns:
Default port
std::string getIPCLogfile ( ) const

Returns the value of IPCLogfile.

The IPCLogfile parameter specifies a relative path to the inter-process communication log file.

Default is ../logs/IPC.log.

See also:
getIPCTimeout()
Returns:
IPC log file name
int getIPCLogging ( ) const

Returns value of IPCLogging.

IPCLogging specifies logging level for inter-process communications. It has the followings possible values:

  • 0 for no logging of inter-process communication
  • 1 for for minimal logging
  • 2 for for verbose logging

Default is 0.

See also:
getIPCTimeout()
Returns:
IPC logging level
int getIPCTimeout ( ) const

Returns the value of IPCTimeout.

The IPCTimeout parameter is the timeout in seconds for inter-process communication.

Default is 10 seconds.

See also:
getIPCLogging(), getIPCLogfile()
Returns:
IPC timeout value
std::string getMascotNodeRebootScript ( ) const

Returns the value of MascotNodeRebootScript.

MascotNodeRebootScript is the name of an optional script to re-boot a cluster node. If this parameter is defined, then there will be a link at the bottom of each Mascot Cluster Node status page. When this link is clicked, ms-monitor will run the defined script on the master. The host name of the specified node will be passed to the script as a parameter.

By default this is empty.

Returns:
Mascot node reboot script
std::string getMascotNodeScript ( ) const

Returns the value of MascotNodeScript.

The MascotNodeScript parameter specifies a script name which is run for each node with different parameters described in Mascot manual.

By default this is empty.

Returns:
Mascot node script
const ms_computeraddress * getMasterComputer ( ) const

Returns an instance of ms_computeraddress created for MasterComputerName.

The MasterComputerName parameter contains a host name for the master computer and, optionally, the IP address separated by a comma. See ms_computeraddress for information about its parameters and default values.

Returns:
Pointer to the master computer object
std::string getNodeSequenceDatabaseDir ( ) const

Returns the value of NodeSequenceDatabaseDir.

Specify the sequence database directory to be used by to all cluster nodes. This can be a relative path to the node bin directory or an absolute path. Default is the ../sequence sub folder.

Returns:
Node sequence database directory
int getNumberOfSubClusters ( ) const

Returns the number of SubClusterSet parameter entries, which is a total number of sub-clusters.

Large clusters can be divided into sub-clusters. There might be several SubClusterSet parameter entries on separate lines in the configuration file. Each parameter line has the following format:

SubClusterSet X Y

X is a unique integer value (0-based) used to identify the sub-cluster (from 0 to 49 inclusively).

Y is the maximum number of processors in the sub-cluster.

A single cluster must have a single entry with X set to 0. If no such entries are present in the file, one subcluster is assumed - default entry (0,0). Therefore, default value returned by this function is 1.

Use getSubClusterID() and getSubClusterMaxCPU() to retrieve the entries.

Returns:
Number of sub clusters
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
int getSecsToWaitForNodeAtStartup ( ) const

Returns the value of SecsToWaitForNodeAtStartup.

The SecsToWaitForNodeAtStartup parameter specifies a timeout. At startup, if a node is not available within this time, the system will continue to startup without that node. If the value is set to 0, then the system will wait indefinitely.

This timeout is also used if a node fails while the system is running. The system will wait for this number of seconds before re-initialising ms-monitor.exe. This means that a short-lived interruption in network communication doesn't create a major service interruption.

Default is 60 sec.

Returns:
Seconds to wait for node at startup
int getSubClusterID ( const int index ) const

Returns sub-cluster ID by its index.

Parameters:
index a number between 0 and (getNumberOfSubClusters()-1).
Returns:
integer number which serves as a sub-cluster ID.
int getSubClusterMaxCPU ( const int index ) const

Returns the Y part of SubClusterSet.

See getNumberOfSubClusters() for more detailed explanations.

Parameters:
index a number in the list (from 0 to (getNumberOfSubClusters()-1)).
Returns:
maximum number of CPUs for the specified sub-cluster (0 by default).
bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the Options section is unavailable until it has been set to a different state.

Returns:
true is the section is available
Examples:
config_mascotdat.cpp.
void setCheckNodesAliveFreq ( const int value )

Change CheckNodesAliveFreq.

See getCheckNodesAliveFreq() for more information.

Parameters:
value Frequency to check if nodes are alive
void setDefaultNodeHomeDir ( const char * str )

Change DefaultNodeHomeDir.

See getDefaultNodeHomeDir() for more information.

Parameters:
str default node home directory
void setDefaultNodeHomeDirFromMaster ( const char * str )

Change DefaultNodeHomeDirFromMaster.

See getDefaultNodeHomeDirFromMaster() for more information.

Parameters:
str default mode home directory from master
void setDefaultNodeOS ( const OPERATING_SYS value )

Change DefaultNodeOS.

See getDefaultNodeOS() for more information.

Parameters:
value default node OS
void setDefaultPort ( const int value )

Change DefaultPort.

See getDefaultPort() for more information.

Parameters:
value Default port
void setEnabled ( const bool flag )

Change Enabled.

See isEnabled() for more information.

Parameters:
flag Enabled
void setIPCLogfile ( const char * str )

Change IPCLogfile.

See getIPCLogfile() for more information.

Parameters:
str IPC log file
void setIPCLogging ( const int value )

Change IPCLogging.

See getIPCLogging() for more information.

Parameters:
value IPC logging level
void setIPCTimeout ( const int value )

Change IPCTimeout.

See getIPCTimeout() for more information.

Parameters:
value IPC timeout
void setMascotNodeRebootScript ( const char * str )

Change MascotNodeRebootScript.

See getMascotNodeRebootScript() for more information.

Parameters:
str mascot mode reboot script
void setMascotNodeScript ( const char * str )

Change MascotNodeScript.

See getMascotNodeScript() for more information.

Parameters:
str Mascot node script
void setMasterComputer ( const ms_computeraddress * value )

Change MasterComputerName.

See getMasterComputer() for more information.

Parameters:
value Pointer to a valid ms_computeraddress object
void setNodeSequenceDatabaseDir ( const char * str )

Change NodeSequenceDatabaseDir.

See getNodeSequenceDatabaseDir() for more information.

Parameters:
str node sequence database directory
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setSecsToWaitForNodeAtStartup ( const int value )

Change SecsToWaitForNodeAtStartup.

See getSecsToWaitForNodeAtStartup() for more information.

Parameters:
value seconds to wait for node at startup
void setSectionAvailable ( const bool value )

Change availability of the section, i.e. if it should be saved in a file.

Value of 1 is to enable cluster mode, whereas 0 is to enable single server mode.

Default is 0.

Parameters:
value Boolean whether the section is available
The documentation for this class was generated from the following files:
  • ms_clusterparams.hpp
  • ms_clusterparams.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_computeraddress
Public Member Functions

ms_computeraddress Class Reference
[Mascot configuration files module]

The class serves as a container for computer address parameters for cluster mode. More...

#include <ms_computeraddress.hpp>

List of all members.

Public Member Functions

ms_computeraddress ()
Default constructor.
ms_computeraddress (const ms_computeraddress &src)
Copying constructor.
~ms_computeraddress ()
Destructor.
void | copyFrom (const ms_computeraddress *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getHostName () const
Returns the host name.
std::string | getInetAddress () const
Returns IP address of the host.
unsigned int | getPort () const
Returns the port number for the host.
ms_computeraddress & | operator= (const ms_computeraddress &right)
Assignment operator for C++ client applications.
void | setHostName (const char *name)
Change the host name.
void | setInetAddress (const char *address)
Change the IP address of the host.
void | setPort (const unsigned int value)
Change the port number for the host.

Detailed Description

The class serves as a container for computer address parameters for cluster mode.

Member Function Documentation

std::string getHostName ( ) const

Returns the host name.

Default is localhost.

Returns:
Host name
std::string getInetAddress ( ) const

Returns IP address of the host.

Default is "127.0.0.1".

Returns:
IP address
unsigned int getPort ( ) const

Returns the port number for the host.

Default is 0.

Returns:
Port number
void setHostName ( const char * name )

Change the host name.

Parameters:
name New host name to set
void setInetAddress ( const char * address )

Change the IP address of the host.

Parameters:
address New address to set
void setPort ( const unsigned int value )

Change the port number for the host.

Parameters:
value New port number to set
The documentation for this class was generated from the following files:
  • ms_computeraddress.hpp
  • ms_computeraddress.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_cronjob
Public Member Functions

ms_cronjob Class Reference
[Mascot configuration files module]

Represents a single entry from the cron section of mascot.dat. More...

#include <ms_cronoptions.hpp>

List of all members.

Public Member Functions

ms_cronjob ()
Default constructor.
ms_cronjob (const ms_cronjob &src)
Copying constructor.
~ms_cronjob ()
Default destructor.
void | copyFrom (const ms_cronjob *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getCommandStr () const
Returns a string that is executed by the shell (command prompt) at the specified times.
bool | isDayOfMonth (const int day) const
Returns TRUE for a valid day number, FALSE otherwise.
bool | isDayOfWeek (const int day) const
Returns TRUE for a valid day of week number, FALSE otherwise.
bool | isEnabled () const
Returns true if the cron job is enabled.
bool | isHour (const int hour) const
Returns TRUE for a valid hour number, FALSE otherwise.
bool | isMinute (const int min) const
Returns TRUE for a valid minute number, FALSE otherwise.
bool | isMonthOfYear (const int month) const
Returns TRUE for a valid month number, FALSE otherwise.
ms_cronjob & | operator= (const ms_cronjob &right)
Assignment operator for C++ client applications.
void | setCommandStr (const char *str)
Set the command that is executed by the shell (command prompt) at the specified times.
void | setDayOfMonth (const int day, const bool value)
Set valid/illegal days.
void | setDayOfWeek (const int day, const bool value)
Set valid/illegal days.
void | setEnabled (const bool enabled)
Set the flag for determining if the cron job is enabled or disabled.
void | setHour (const int hour, const bool value)
Set valid/illegal hours.
void | setMinute (const int min, const bool value)
Set valid/illegal minutes.
void | setMonthOfYear (const int month, const bool value)
Set valid/illegal months.

Detailed Description

Represents a single entry from the cron section of mascot.dat.

Instances of this class can be stored in ms_cronoptions.

Member Function Documentation

std::string getCommandStr ( ) const

Returns a string that is executed by the shell (command prompt) at the specified times.

By default this is empty.

Returns:
the command to be run.
Examples:
config_mascotdat.cpp.
bool isDayOfMonth ( const int day ) const

Returns TRUE for a valid day number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'day' part of this specification.

Parameters:
day a day number (1..31).
Returns:
By default FALSE is returned for all days.
bool isDayOfWeek ( const int day ) const

Returns TRUE for a valid day of week number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'day of week' part of this specification.

Parameters:
day a day of week number (0..6, 0=Sunday).
Returns:
By default FALSE is returned for all days.
bool isEnabled ( ) const

Returns true if the cron job is enabled.

A cron job entry in the configuration file specifies time to run a command. The entry can be disabled by putting a comments symbol # at the start of the line

Returns:
true if the cron job is enabled.
bool isHour ( const int hour ) const

Returns TRUE for a valid hour number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'hour' part of this specification.

Parameters:
hour an hour number (0..23).
Returns:
By default FALSE is returned for all hours.
bool isMinute ( const int min ) const

Returns TRUE for a valid minute number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'minute' part of this specification.

Parameters:
min a minute number (0..59).
Returns:
By default FALSE is returned for all minutes.
bool isMonthOfYear ( const int month ) const

Returns TRUE for a valid month number, FALSE otherwise.

A cron job entry in the configuration file specifies time to run a command. Use this function to retrieve the 'month' part of this specification.

Parameters:
month a month number (1..12).
Returns:
By default FALSE is returned for all months.
void setCommandStr ( const char * str )

Set the command that is executed by the shell (command prompt) at the specified times.

Parameters:
str is the new command to be run.
void setDayOfMonth | ( | const int | day,
 |  | const bool | value
 | ) |  |

Set valid/illegal days.

See also:
isDayOfMonth()
Parameters:
day | an hour number (1..31).
value | a new boolean flag for the given day.
void setDayOfWeek | ( | const int | day,
 |  | const bool | value
 | ) |  |

Set valid/illegal days.

See also:
isDayOfWeek()
Parameters:
day | a day of week number (0..6, 0=Sunday).
value | a new boolean flag for the given day.
void setEnabled ( const bool enabled )

Set the flag for determining if the cron job is enabled or disabled.

A cron job entry in the configuration file specifies time to run a command. The entry can be disabled by putting a comments symbol # at the start of the line

Parameters:
enabled true if the cron job is enabled.
void setHour | ( | const int | hour,
 |  | const bool | value
 | ) |  |

Set valid/illegal hours.

See also:
isHour()
Parameters:
hour | an hour number (0..23).
value | a new boolean flag for the given hour.
void setMinute | ( | const int | min,
 |  | const bool | value
 | ) |  |

Set valid/illegal minutes.

See also:
isMinute()
Parameters:
min | a minute number (0..59)
value | a new boolean flag for the given minute
void setMonthOfYear | ( | const int | month,
 |  | const bool | value
 | ) |  |

Set valid/illegal months.

See also:
isMonthOfYear()
Parameters:
month | a month number (1..12).
value | a new boolean flag for the given month.
The documentation for this class was generated from the following files:
  • ms_cronoptions.hpp
  • ms_cronoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_cronoptions
Public Member Functions

ms_cronoptions Class Reference
[Mascot configuration files module]

Contains parameters from the cron section of mascot.dat. More...

#include <ms_cronoptions.hpp>

Inheritance diagram for ms_cronoptions:
[legend]
Collaboration diagram for ms_cronoptions:
[legend]

List of all members.

Public Member Functions

ms_cronoptions ()
Default constructor.
ms_cronoptions (const ms_cronoptions &src)
Copying constructor.
~ms_cronoptions ()
Destructor.
void | appendCronJob (const ms_cronjob *job)
Add a new job entry at the end of the list.
void | clearCronJobs ()
Delete all cron-job entries.
void | copyFrom (const ms_cronoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
bool | deleteCronJob (const int idx)
Delete a single cron job.
const ms_cronjob | getCronJob (const int idx) const
Returns an object describing a single cron job by its number.
std::string | getLogFileName () const
Returns the path to the log file.
int | getLoggingLevel () const
Returns the current logging level.
int | getNumberOfCronJobs () const
Returns the total number of cron-jobs configured.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
bool | isCronEnabled () const
Returns true if parameter CronEnabled is set to 1 and false otherwise.
bool | isSectionAvailable () const
Returns TRUE if the section was actually read from a file.
ms_cronoptions & | operator= (const ms_cronoptions &right)
Assignment operator for C++ client applications.
void | setCronEnabled (const bool value)
Change CronEnabled.
bool | setCronJob (const int idx, const ms_cronjob job)
Replace the current definition of a cron job.
bool | setLogFileName (const std::string &fileName)
Sets the path to the log file.
bool | setLoggingLevel (const int level)
Sets a new logging level.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSectionAvailable (const bool value)
Changes availability of the section, meaning whether it should be stored in a file.

Detailed Description

Contains parameters from the cron section of mascot.dat.

On Unix systems, cron can be used to automate routine procedures such as the overnight updating of sequence database files. Windows 2000 and later include an equivalent utility called Scheduled Tasks. The Mascot ms-monitor.exe service/daemon runs the cron jobs listed in mascot.dat

In Mascot 2.4 and later, the Database Manager uses the cron job to download and update fasta database files.

For detailed information on any of the cron parameters please consult the Mascot manual.

See ms_datfile::getCronOptions() and ms_datfile::setCronOptions()

The base class ms_customproperty can be used to facilitate the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_mascotdat.cpp.

Constructor & Destructor Documentation

ms_cronoptions ( )

Default constructor.

The ms_cronoptions object will normally be created using ms_datfile::getCronOptions().

ms_cronoptions ( const ms_cronoptions & src )

Copying constructor.

Parameters:
src is a reference to the object to copy from.
~ms_cronoptions ( )

Destructor.

Frees all memory. Pointers returned by getCronJob() are no longer valid.

Member Function Documentation

void appendCronJob ( const ms_cronjob * job )

Add a new job entry at the end of the list.

Parameters:
job is a pointer to the new job
void clearCronJobs ( )

Delete all cron-job entries.

This does not change the log file settings or the 'enabled' value.

void defaultValues ( )

Initialises the instance with default values.

Clears the list of cron jobs, sets the 'enabled' flag to false.

Reimplemented from ms_customproperty.

bool deleteCronJob ( const int idx )

Delete a single cron job.

Parameters:
idx a number from 0 to (getNumberOfCronJobs()-1).
Returns:
true if idx is a valid index.
const ms_cronjob getCronJob ( const int idx ) const

Returns an object describing a single cron job by its number.

All cron jobs are assigned consecutive ID numbers (0 based).

To make changes to the returned ms_cronjob permanent, call setCronJob() followed by ms_datfile::setCronOptions

Note:
In versions of Mascot Parser prior to 2.4.1, this function returned a const pointer to the ms_conjob object rather than a copy of the object.
Parameters:
idx a number from 0 to (getNumberOfCronJobs()-1)
Returns:
instance of ms_cronjob class describing the corresponding entry.
Examples:
config_mascotdat.cpp.
std::string getLogFileName ( ) const

Returns the path to the log file.

The filename can be a relative or absolute path.

Parameter | Logfile
Permitted values | A non empty string
Default (if no parameter in mascot.dat) | "../logs/cron.log"
Value in mascot.dat | "../logs/cron.log"
Returns:
the logging file name.
int getLoggingLevel ( ) const

Returns the current logging level.

The value specifies the level of logging. Messages are put into the file specified by getLogFileName()

Parameter | Logging
Permitted values 0..3 where:
  • 0 - No logging
  • 1 - Log successful commands (return code 0)
  • 2 - Log unsuccessful commands (return code not 0)
  • 3 - Log successful and unsuccessful commands
Default
(if no parameter in mascot.dat) 		3
Value in mascot.dat | 3
Returns:
the logging level
int getNumberOfCronJobs ( ) const

Returns the total number of cron-jobs configured.

Every line (except the first one) in the cron section represents a cron-job. This function returns a number of such lines (except commented out).

Returns:
the number of cron jobs.
Examples:
config_mascotdat.cpp.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
bool isCronEnabled ( ) const

Returns true if parameter CronEnabled is set to 1 and false otherwise.

The first parameter in the cron section of mascot.dat is always CronEnabled parameter. The rest is a list of cron-jobs. See getNumberOfCronJobs() for more information about them.

CronEnable should be set to 1 to enable cron functionality, 0 to disable. By default it is disabled.

Returns:
true if the cron functionality is enabled
Examples:
config_mascotdat.cpp.
void setCronEnabled ( const bool value )

Change CronEnabled.

See isCronEnabled() for more information.

Parameters:
value should be true or false
bool setCronJob | ( | const int | idx,
 |  | const ms_cronjob | job
 | ) |  |

Replace the current definition of a cron job.

Parameters:
idx | a number from 0 to (getNumberOfCronJobs()-1).
job | is the new definition for the job.
Returns:
true if job is not a null pointer and idx is a valid index.
bool setLogFileName ( const std::string & fileName )

Sets the path to the log file.

The filename can be a relative or absolute path.

Parameter | Logfile
Permitted values | A non empty string
Default (if no parameter in mascot.dat) | "../logs/cron.log"
Value in mascot.dat | "../logs/cron.log"
Parameters:
fileName is the logging file name.
Returns:
true if fileName is not an empty string.
bool setLoggingLevel ( const int level )

Sets a new logging level.

The value specifies the level of logging. Messages are put into the file specified by getLogFileName()

Parameter | Logging
Permitted values 0..3 where:
  • 0 - No logging
  • 1 - Log successful commands (return code 0)
  • 2 - Log unsuccessful commands (return code not 0)
  • 3 - Log successful and unsuccessful commands
Default
(if no parameter in mascot.dat) 		3
Value in mascot.dat | 3
Parameters:
level is the new logging level, a value 0..3.
Returns:
true if a valid logging level is supplied.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
The documentation for this class was generated from the following files:
  • ms_cronoptions.hpp
  • ms_cronoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_accession
Public Member Functions

ms_crosslinking_accession Class Reference
[Mascot configuration files module]

Accession element in crosslinking.xml More...

#include <ms_crosslinking_accession.hpp>

List of all members.

Public Member Functions

ms_crosslinking_accession ()
Default constructor.
ms_crosslinking_accession (const ms_crosslinking_accession &src)
Copying constructor.
virtual | ~ms_crosslinking_accession ()
Destructor.
void | copyFrom (const ms_crosslinking_accession *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDatabaseName ()
Delete the DatabaseName attribute.
void | dropValue ()
Delete the custom text.
std::string | getDatabaseName () const
Returns the value of the DatabaseName attribute.
std::string | getDatabaseNameSchemaType () const
Obtain a symbolic name for the DatabaseName attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the text of the node.
std::string | getValueSchemaType () const
Obtain a symbolic name for the text node schema type.
bool | haveDatabaseName () const
Indicates presence of the DatabaseName attribute.
bool | haveValue () const
Returns the text of the node.
ms_crosslinking_accession & | operator= (const ms_crosslinking_accession &right)
C++ style assignment operator.
void | setDatabaseName (const char *value)
Set a custom value for the DatabaseName attribute.
void | setValue (const char *value)
Set a custom text.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Accession element in crosslinking.xml

Accessions may come from different databases. If an accession has no DatabaseName attribute, the accession is looked up in all databases selected for the search.

Constructor & Destructor Documentation

ms_crosslinking_accession ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_accession ( const ms_crosslinking_accession & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_accession * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropDatabaseName ( )

Delete the DatabaseName attribute.

Deletes the attribute until is re-set.

std::string getDatabaseName ( ) const

Returns the value of the DatabaseName attribute.

Returns:
current value of the attribute.
std::string getDatabaseNameSchemaType ( ) const

Obtain a symbolic name for the DatabaseName attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").
std::string getValue ( ) const

Returns the text of the node.

Returns:
current value text.
std::string getValueSchemaType ( ) const

Obtain a symbolic name for the text node schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveDatabaseName ( ) const

Indicates presence of the DatabaseName attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_crosslinking_accession & operator= ( const ms_crosslinking_accession & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setDatabaseName ( const char * value )

Set a custom value for the DatabaseName attribute.

Parameters:
value a new value for the attribute.
void setValue ( const char * value )

Set a custom text.

Parameters:
value a new value text.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_accession.hpp
  • ms_crosslinking_accession.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_accessions
Public Member Functions

ms_crosslinking_accessions Class Reference
[Mascot configuration files module]

Accessions element in crosslinking.xml More...

#include <ms_crosslinking_accessions.hpp>

List of all members.

Public Member Functions

ms_crosslinking_accessions ()
Default constructor.
ms_crosslinking_accessions (const ms_crosslinking_accessions &src)
Copying constructor.
virtual | ~ms_crosslinking_accessions ()
Destructor.
void | appendAccession (const ms_crosslinking_accession *item)
Adds a new accession code at the end of the list.
void | clearAccessions ()
Deletes all accession codes from the list.
void | copyFrom (const ms_crosslinking_accessions *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteAccessionByNumber (const int idx)
Remove a accession code from the list in memory by its index.
const ms_crosslinking_accession * | getAccessionByNumber (const int idx) const
Returns a accession code object by its number.
std::string | getAccessionSchemaType () const
Obtain a symbolic name for the accession element schema type.
int | getNumberOfAccessions () const
Returns the number of accession.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_accessions & | operator= (const ms_crosslinking_accessions &right)
C++ style assignment operator.
bool | updateAccessionByNumber (const int idx, const ms_crosslinking_accession *accession)
Update the information for a specific accession code refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Accessions element in crosslinking.xml

The list of accessions limits the search space of crosslinked peptides to just the named ones. If no accessions are defined, search space is unrestricted.

Constructor & Destructor Documentation

ms_crosslinking_accessions ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_accessions ( const ms_crosslinking_accessions & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendAccession ( const ms_crosslinking_accession * item )

Adds a new accession code at the end of the list.

Creates a new accession code object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters:
item an instance of a accession object to copy content from.
void copyFrom ( const ms_crosslinking_accessions * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteAccessionByNumber ( const int idx )

Remove a accession code from the list in memory by its index.

Parameters:
idx number of the accession code for deletion from 0 to (getNumberOfAccessions() - 1).
Returns:
TRUE if the accession code has been found and successfully deleted and FALSE otherwise.
const ms_crosslinking_accession * getAccessionByNumber ( const int idx ) const

Returns a accession code object by its number.

Parameters:
idx number of the accession code from 0 to (getNumberOfAccessions() - 1).
Returns:
a read-only pointer to a accession object. See Maintaining object references: two rules of thumb.
std::string getAccessionSchemaType ( ) const

Obtain a symbolic name for the accession element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfAccessions ( ) const

Returns the number of accession.

Returns:
total number of monolink codes.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
ms_crosslinking_accessions & operator= ( const ms_crosslinking_accessions & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateAccessionByNumber | ( | const int | idx,
 |  | const ms_crosslinking_accession * | accession
 | ) |  |

Update the information for a specific accession code refering to it by its index.

Parameters:
idx | number of the accession code for updating from 0 to (getNumberOfAccessions() - 1).
accession | an object to copy the content from.
Returns:
TRUE if the accession code has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_accessions.hpp
  • ms_crosslinking_accessions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_configfile
Public Member Functions | Static Public Member Functions

ms_crosslinking_configfile Class Reference
[Mascot configuration files module]

This class represents the file crosslinking.xml. More...

#include <ms_crosslinking_configfile.hpp>

Inheritance diagram for ms_crosslinking_configfile:
[legend]
Collaboration diagram for ms_crosslinking_configfile:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_configfile ()
Default constructor.
ms_crosslinking_configfile (const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true)
Immediate action constructor that reads the XML file with the given name.
ms_crosslinking_configfile (const ms_crosslinking_configfile &right)
Copying constructor.
virtual | ~ms_crosslinking_configfile ()
Desctructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendMethod (const ms_crosslinking_method *elem)
Adds a new method at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearMethods ()
Deletes all methods from the list.
void | copyFrom (const ms_crosslinking_configfile *right)
Copies all the information from another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual void | defaultValues ()
Re-initialises the instance.
bool | deleteMethodByName (const char *name)
Remove an method from the list in memory.
bool | deleteMethodByNumber (const int idx)
Remove an method from the list in memory.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the current file name.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMajorVersion () const
Returns major document schema version as read from the file, otherwise the latest.
const ms_crosslinking_method * | getMethodByName (const char *name) const
Returns an method object by its name or NULL in case of not found.
const ms_crosslinking_method * | getMethodByNumber (const int idx) const
Returns an method object by its number.
std::string | getMinorVersion () const
Returns minor document schema version as read from the file, otherwise the latest.
int | getNumberOfMethods () const
Returns a number of methods currently held in memory.
std::string | getSchemaFileName () const
Returns the current schema file name that is used to validate the XML file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_crosslinking_configfile & | operator= (const ms_crosslinking_configfile &right)
Assignment operator for C++ applications.
void | read_buffer (const char *buffer)
Reads configuration information from a string buffer.
void | read_file ()
Reads configuration information from the XML file.
std::string | save_buffer (bool validateAgainstSchema=true)
Creates a string representation of the XML document with all the content of the object.
void | save_file ()
Saves configuration information in the XML file (not mod_file).
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Changes the file name for subsequent read/write operations.
void | setSchemaFileName (const char *name)
Call this member to specify a custom schema file name for validating the XML file.
bool | updateMethodByName (const char *name, const ms_crosslinking_method *method)
Update the information for a specific method.
bool | updateMethodByNumber (const int idx, const ms_crosslinking_method *method)
Update the information for a specific method.
std::string | validateDocument () const
Validates the whole document against schema and returns errors as a string.

Static Public Member Functions

static std::string | getDefaultSchemaFileName ()
Returns the default schema filename (no path)

Detailed Description

This class represents the file crosslinking.xml.

The crosslinking configuration file contains definitions for crosslinking methods. The method comprises settings such as intact vs cleavable linker, which protein accessions to intralink or interlink and various method-specific filters and settings. The file can be created from scratch, read from a disk file or retrieved from a remote location (HTTP).

After reading a file and before using the object check validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid. Similarly, after writing out the file, isValid() can be used to check if the file has been created correctly and is valid for further use.

Constructor & Destructor Documentation

ms_crosslinking_configfile | ( | const char * | fileName,
 |  | const char * | schemaFileName,
 |  | const ms_connection_settings * | cs = 0,
 |  | bool | useSchema = true
 | ) |  |

Immediate action constructor that reads the XML file with the given name.

An instance of this class is normally created using this form of the constructor.

Parameters:
fileName | represents either local file name (for example, "C:/crosslinking.xml") or a fully formed URL such as http://www.matrixscience.com/cgi . The filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
schemaFileName | is a local file name for the schema (for example, "C:/crosslinking_2.xsd"). The schema must be a local file -- it cannot be accessed using HTTP. The schema filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
cs | a connection settings object for downloading the file from a Mascot server. This should contain a sessionID and optionally the proxy server settings. For a local file cs is not required and will be ignored.
useSchema | specify whether it should use a xsd schema validator, true by default
ms_crosslinking_configfile ( const ms_crosslinking_configfile & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void appendMethod ( const ms_crosslinking_method * elem )

Adds a new method at the end of the list.

Creates a new method object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters:
elem an instance of the method object to copy content from.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_crosslinking_configfile * right )

Copies all the information from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void defaultValues ( ) [virtual]

Re-initialises the instance.

After calling this method, all internal values will be reset to their defaults, as if the object had been freshly created with the default constructor.

This method, however, doesn't change file name, schema location and connection settings. If a complete cleanup is required, you need to do three additional calls:

   crosslinking_configfile.setFileName("");
   crosslinking_configfile.setSchemaFileName("");
   crosslinking_configfile.setConnectionSetting(ms_connection_settings());
bool deleteMethodByName ( const char * name )

Remove an method from the list in memory.

Parameters:
name name of the method for deletion.
Returns:
TRUE if the method has been found and successfully deleted and FALSE otherwise.
bool deleteMethodByNumber ( const int idx )

Remove an method from the list in memory.

Parameters:
idx number of the method for deletion from 0 to (getNumberOfMethods() - 1).
Returns:
TRUE if the method has been found and successfully deleted and FALSE otherwise.
std::string getDefaultSchemaFileName ( ) [static]

Returns the default schema filename (no path)

Static method to return the filename of the currently used schema

Returns:
Returns "crosslinking_2.xsd" (at version 2.6.1)
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns the current file name.

Returns:
currently set file location (not necessarily the location from which the current content has been read).
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
const ms_crosslinking_method * getMethodByName ( const char * name ) const

Returns an method object by its name or NULL in case of not found.

Parameters:
name a unique name of the method.
Returns:
a read-only pointer to an method object. See Maintaining object references: two rules of thumb.
const ms_crosslinking_method * getMethodByNumber ( const int idx ) const

Returns an method object by its number.

Parameters:
idx number of the method from 0 to (getNumberOfMethods() - 1).
Returns:
a read-only pointer to an method object. See Maintaining object references: two rules of thumb.
int getNumberOfMethods ( ) const

Returns a number of methods currently held in memory.

Returns:
total number of methods in the configuration file.
std::string getSchemaFileName ( ) const

Returns the current schema file name that is used to validate the XML file.

Returns:
currently set file location (not necessarily the location from which the current content has been read).
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_crosslinking_configfile & operator= ( const ms_crosslinking_configfile & right )

Assignment operator for C++ applications.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void read_buffer ( const char * buffer )

Reads configuration information from a string buffer.

This method is useful when reading configuration information from a mascor result file. Old content of the object will be removed and substituted with the information read from the buffer.

Parameters:
buffer string buffer that contains a valid xml-document. It can be a document with just one modification in it, or only with amino acid masses.
void read_file ( )

Reads configuration information from the XML file.

Downloads the file if necessary from the Crosslinking web site and parses it. Check for errors before using any other methods for retrieving content.

std::string save_buffer ( bool validateAgainstSchema = true )

Creates a string representation of the XML document with all the content of the object.

Creates a valid XML document and returns it as a string which can be used, for example, for writing out configuration information to mascot result file.

To produce a 'file' that validates against the schema, it is not sufficient to add, for example, just a modification because this will be missing keyrefs to elements and termini building 'bricks'.

If you choose not to validate against the schema, then it is sufficient to just output, say, a single modification.

Parameters:
validateAgainstSchema specifies whether to validate against the schema. If true and the schema file exists and the resulting XML fails to validate, then an empty string will be returned and the errors will indicate why it failed to validate.
Returns:
XML document with the object content.
void save_file ( )

Saves configuration information in the XML file (not mod_file).

Check for errors after calling this method to see if the operation has been successful or to get any schema validation errors. If the document is not valid it is going to be saved anyway unless there are other problems.

If you want to validate document without actually saving it use validateDocument().

void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setFileName ( const char * name )

Changes the file name for subsequent read/write operations.

Calling this method does not mean an immediate update on disk. Use either read_file() or save_file() for that.

Parameters:
name a new file location.
void setSchemaFileName ( const char * name )

Call this member to specify a custom schema file name for validating the XML file.

Parameters:
name a new file location (if empty default value will be assigned).
bool updateMethodByName | ( | const char * | name,
 |  | const ms_crosslinking_method * | method
 | ) |  |

Update the information for a specific method.

Parameters:
name | name of the method for updating.
method | an object to copy the content from.
Returns:
TRUE if the method has been found and successfully updated and FALSE otherwise.
bool updateMethodByNumber | ( | const int | idx,
 |  | const ms_crosslinking_method * | method
 | ) |  |

Update the information for a specific method.

Parameters:
idx | number of the method for updating from 0 to (getNumberOfMethods() - 1).
method | an object to copy the content from.
Returns:
TRUE if the method has been found and successfully updated and FALSE otherwise.
std::string validateDocument ( ) const

Validates the whole document against schema and returns errors as a string.

This method doesn't attempt to store the document anywhere and doesn't make the object invalid. Also, no errors are stored. Therefore, this method can be called as many times as necessary without any consequences.

All validation errors will be returned back as a string. However, the XML parser will describe errors in terms of row and column numbers as if the document was actually saved in a file.

Returns:
validation errors as a string or an empty string if there are no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_configfile.hpp
  • ms_crosslinking_configfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_does_not_pair_with
Public Member Functions

ms_crosslinking_does_not_pair_with Class Reference
[Mascot configuration files module]

mxm:does_not_pair_with element in crosslinking.xml More...

#include <ms_crosslinking_does_not_pair_with.hpp>

List of all members.

Public Member Functions

ms_crosslinking_does_not_pair_with ()
Default constructor.
ms_crosslinking_does_not_pair_with (const ms_crosslinking_does_not_pair_with &src)
Copying constructor.
virtual | ~ms_crosslinking_does_not_pair_with ()
Destructor.
void | copyFrom (const ms_crosslinking_does_not_pair_with *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropModFileName ()
Delete the ModFileName attribute.
std::string | getModFileName () const
Returns the value of the ModFileName attribute.
std::string | getModFileNameSchemaType () const
Obtain a symbolic name for the ModFileName attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveModFileName () const
Indicates presence of the ModFileName attribute.
ms_crosslinking_does_not_pair_with & | operator= (const ms_crosslinking_does_not_pair_with &right)
C++ style assignment operator.
void | setModFileName (const char *value)
Set a custom value for the ModFileName attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

mxm:does_not_pair_with element in crosslinking.xml

Constructor & Destructor Documentation

ms_crosslinking_does_not_pair_with ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_does_not_pair_with ( const ms_crosslinking_does_not_pair_with & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_does_not_pair_with * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropModFileName ( )

Delete the ModFileName attribute.

Deletes the attribute until it is re-set.

std::string getModFileName ( ) const

Returns the value of the ModFileName attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getModFileNameSchemaType ( ) const

Obtain a symbolic name for the ModFileName attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").
bool haveModFileName ( ) const

Indicates presence of the ModFileName attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_crosslinking_does_not_pair_with & operator= ( const ms_crosslinking_does_not_pair_with & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setModFileName ( const char * value )

Set a custom value for the ModFileName attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_does_not_pair_with.hpp
  • ms_crosslinking_does_not_pair_with.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_filters
Public Member Functions

ms_crosslinking_filters Class Reference
[Mascot configuration files module]

Filters element in crosslinking.xml More...

#include <ms_crosslinking_filters.hpp>

Inheritance diagram for ms_crosslinking_filters:
[legend]
Collaboration diagram for ms_crosslinking_filters:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_filters ()
Default constructor.
ms_crosslinking_filters (const ms_crosslinking_filters &src)
Copying constructor.
virtual | ~ms_crosslinking_filters ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_crosslinking_filters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_filters & | operator= (const ms_crosslinking_filters &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Filters element in crosslinking.xml

The filters section contains a list of parameters. These specify which spectra are excluded from crosslinked matching.

In Mascot 2.7, available filters are:

  • MinPrecursorMr: minimum relative precursor mass (Da)
  • MinLen: minimum length of the shortest peptide in the pair
  • MinCharge: minimum precursor charge (absolute value). For example, specify "4" to exclude charge states -3, -2, -1, +1, +2 and +3.

Constructor & Destructor Documentation

ms_crosslinking_filters ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_filters ( const ms_crosslinking_filters & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_filters * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_crosslinking_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Reimplemented from ms_crosslinking_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").

Reimplemented from ms_crosslinking_parameters.

ms_crosslinking_filters & operator= ( const ms_crosslinking_filters & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

The documentation for this class was generated from the following files:
  • ms_crosslinking_filters.hpp
  • ms_crosslinking_filters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_linker
Public Member Functions

ms_crosslinking_linker Class Reference
[Mascot configuration files module]

Linker element in crosslinking.xml More...

#include <ms_crosslinking_linker.hpp>

List of all members.

Public Member Functions

ms_crosslinking_linker ()
Default constructor.
ms_crosslinking_linker (const ms_crosslinking_linker &src)
Copying constructor.
virtual | ~ms_crosslinking_linker ()
Destructor.
void | appendDoesNotPairWith (const ms_crosslinking_does_not_pair_with *item)
Adds a new does_not_pair_with restriction at the end of the list.
void | appendMonoLink (const ms_crosslinking_monolink *item)
Adds a new monolink code at the end of the list.
void | clearDoesNotPairWiths ()
Deletes all does_not_pair_with restrictions from the list.
void | clearMonoLinks ()
Deletes all monolink codes from the list.
void | copyFrom (const ms_crosslinking_linker *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteDoesNotPairWithByNumber (const int idx)
Remove a does_not_pair_with restriction from the list in memory by its index.
bool | deleteMonoLinkByNumber (const int idx)
Remove a monolink code from the list in memory by its index.
void | dropModFileName ()
Delete the ModFileName attribute.
const
ms_crosslinking_does_not_pair_with * 		getDoesNotPairWithByNumber (const int idx) const
Returns a does_not_pair_with restriction object by its number.
std::string | getDoesNotPairWithSchemaType () const
Obtain a symbolic name for the does_not_pair_with element schema type.
std::string | getModFileName () const
Returns the value of the ModFileName attribute.
std::string | getModFileNameSchemaType () const
Obtain a symbolic name for the ModFileName attribute schema type.
const ms_crosslinking_monolink * | getMonoLinkByNumber (const int idx) const
Returns a monolink code object by its number.
std::string | getMonoLinkSchemaType () const
Obtain a symbolic name for the monolink element schema type.
int | getNumberOfDoesNotPairWiths () const
Returns the number of does_not_pair_with restrictions.
int | getNumberOfMonoLinks () const
Returns the number of monolink codes.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveModFileName () const
Indicates presence of the ModFileName attribute.
ms_crosslinking_linker & | operator= (const ms_crosslinking_linker &right)
C++ style assignment operator.
void | setModFileName (const char *value)
Set a custom value for the ModFileName attribute.
bool | updateDoesNotPairWithByNumber (const int idx, const ms_crosslinking_does_not_pair_with *does_not_pair_with)
Update the information for a specific does_not_pair_with restriction refering to it by its index.
bool | updateMonoLinkByNumber (const int idx, const ms_crosslinking_monolink *monolink)
Update the information for a specific monolink code refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Linker element in crosslinking.xml

The linker element specifies the modfile-style name of the linker molecule. A modfile-style name consists of the Unimod title of the linker (like "Xlink:DSS") followed by a specificity (like "Protein N-term"), e.g. "Xlink:DSS (Protein N-term)".

The linker element may list monolink definitions that should be tried as variable modifications during the search. Each monolink node is a one-letter code that identifies a "neutral loss" element in its definition.

The linker element may list does_not_pair_with restrictions. If there are no restrictions, the linker may pair with any other linker in the method. Otherwise, does_not_pair_with can be used to restrict the pairings.

Constructor & Destructor Documentation

ms_crosslinking_linker ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_linker ( const ms_crosslinking_linker & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendDoesNotPairWith ( const ms_crosslinking_does_not_pair_with * item )

Adds a new does_not_pair_with restriction at the end of the list.

Creates a new does_not_pair_with restriction object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
item an instance of a does_not_pair_with object to copy content from.
void appendMonoLink ( const ms_crosslinking_monolink * item )

Adds a new monolink code at the end of the list.

Creates a new monolink code object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
item an instance of a monolink object to copy content from.
void copyFrom ( const ms_crosslinking_linker * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteDoesNotPairWithByNumber ( const int idx )

Remove a does_not_pair_with restriction from the list in memory by its index.

Parameters:
idx number of the does_not_pair_with restriction for deletion from 0 to (getNumberOfDoesNotPairWiths() - 1).
Returns:
TRUE if the does_not_pair_with restriction has been found and successfully deleted and FALSE otherwise.
bool deleteMonoLinkByNumber ( const int idx )

Remove a monolink code from the list in memory by its index.

Parameters:
idx number of the monolink code for deletion from 0 to (getNumberOfMonoLinks() - 1).
Returns:
TRUE if the monolink code has been found and successfully deleted and FALSE otherwise.
void dropModFileName ( )

Delete the ModFileName attribute.

Deletes the attribute until it is re-set.

const ms_crosslinking_does_not_pair_with * getDoesNotPairWithByNumber ( const int idx ) const

Returns a does_not_pair_with restriction object by its number.

Parameters:
idx number of the does_not_pair_with restriction from 0 to (getNumberOfDoesNotPairWiths() - 1).
Returns:
a read-only pointer to a does_not_pair_with object. See Maintaining object references: two rules of thumb.
std::string getDoesNotPairWithSchemaType ( ) const

Obtain a symbolic name for the does_not_pair_with element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getModFileName ( ) const

Returns the value of the ModFileName attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getModFileNameSchemaType ( ) const

Obtain a symbolic name for the ModFileName attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_crosslinking_monolink * getMonoLinkByNumber ( const int idx ) const

Returns a monolink code object by its number.

Parameters:
idx number of the monolink code from 0 to (getNumberOfMonoLinks() - 1).
Returns:
a read-only pointer to a monolink object. See Maintaining object references: two rules of thumb.
std::string getMonoLinkSchemaType ( ) const

Obtain a symbolic name for the monolink element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfDoesNotPairWiths ( ) const

Returns the number of does_not_pair_with restrictions.

Returns:
total number of does_not_pair_with restrictions.
int getNumberOfMonoLinks ( ) const

Returns the number of monolink codes.

Returns:
total number of monolink codes.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
bool haveModFileName ( ) const

Indicates presence of the ModFileName attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_crosslinking_linker & operator= ( const ms_crosslinking_linker & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setModFileName ( const char * value )

Set a custom value for the ModFileName attribute.

Parameters:
value a new value for the attribute.
bool updateDoesNotPairWithByNumber | ( | const int | idx,
 |  | const ms_crosslinking_does_not_pair_with * | does_not_pair_with
 | ) |  |

Update the information for a specific does_not_pair_with restriction refering to it by its index.

Parameters:
idx | number of the does_not_pair_with restriction for updating from 0 to (getNumberOfDoesNotPairWiths() - 1).
does_not_pair_with | an object to copy the content from.
Returns:
TRUE if the does_not_pair_with restriction has been found and successfully updated and FALSE otherwise.
bool updateMonoLinkByNumber | ( | const int | idx,
 |  | const ms_crosslinking_monolink * | monolink
 | ) |  |

Update the information for a specific monolink code refering to it by its index.

Parameters:
idx | number of the monolink code for updating from 0 to (getNumberOfMonoLinks() - 1).
monolink | an object to copy the content from.
Returns:
TRUE if the monolink code has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_linker.hpp
  • ms_crosslinking_linker.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_linkers
Public Member Functions

ms_crosslinking_linkers Class Reference
[Mascot configuration files module]

Linkers element in crosslinking.xml More...

#include <ms_crosslinking_linkers.hpp>

List of all members.

Public Member Functions

ms_crosslinking_linkers ()
Default constructor.
ms_crosslinking_linkers (const ms_crosslinking_linkers &src)
Copying constructor.
virtual | ~ms_crosslinking_linkers ()
Destructor.
void | appendLinker (const ms_crosslinking_linker *item)
Adds a new linker code at the end of the list.
void | clearLinkers ()
Deletes all linker codes from the list.
void | copyFrom (const ms_crosslinking_linkers *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteLinkerByNumber (const int idx)
Remove a linker code from the list in memory by its index.
const ms_crosslinking_linker * | getLinkerByNumber (const int idx) const
Returns a linker code object by its number.
std::string | getLinkerSchemaType () const
Obtain a symbolic name for the linker element schema type.
int | getNumberOfLinkers () const
Returns the number of linker.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_linkers & | operator= (const ms_crosslinking_linkers &right)
C++ style assignment operator.
bool | updateLinkerByNumber (const int idx, const ms_crosslinking_linker *linker)
Update the information for a specific linker code refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Linkers element in crosslinking.xml

The linkers element groups together specificities of a single linker.

In Mascot 2.7, the restrictions are:

  • At most one linkers element
  • The linkers group can contain multiple specificities of a single linker

For example, it is possible to specify Xlink:DSS (K) and Xlink:DSS (Protein N-term) for searching, as it is a single linker with two specificities. It is not possible to select two different linkers, like Xlink:DSS and Xlink:DSSO.

Constructor & Destructor Documentation

ms_crosslinking_linkers ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_linkers ( const ms_crosslinking_linkers & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendLinker ( const ms_crosslinking_linker * item )

Adds a new linker code at the end of the list.

Creates a new linker code object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters:
item an instance of a linker object to copy content from.
void copyFrom ( const ms_crosslinking_linkers * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteLinkerByNumber ( const int idx )

Remove a linker code from the list in memory by its index.

Parameters:
idx number of the linker code for deletion from 0 to (getNumberOfLinkers() - 1).
Returns:
TRUE if the linker code has been found and successfully deleted and FALSE otherwise.
const ms_crosslinking_linker * getLinkerByNumber ( const int idx ) const

Returns a linker code object by its number.

Parameters:
idx number of the linker code from 0 to (getNumberOfLinkers() - 1).
Returns:
a read-only pointer to a linker object. See Maintaining object references: two rules of thumb.
std::string getLinkerSchemaType ( ) const

Obtain a symbolic name for the linker element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfLinkers ( ) const

Returns the number of linker.

Returns:
total number of monolink codes.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
ms_crosslinking_linkers & operator= ( const ms_crosslinking_linkers & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateLinkerByNumber | ( | const int | idx,
 |  | const ms_crosslinking_linker * | linker
 | ) |  |

Update the information for a specific linker code refering to it by its index.

Parameters:
idx | number of the linker code for updating from 0 to (getNumberOfLinkers() - 1).
linker | an object to copy the content from.
Returns:
TRUE if the linker code has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_linkers.hpp
  • ms_crosslinking_linkers.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_method
Public Member Functions

ms_crosslinking_method Class Reference
[Mascot configuration files module]

Represents a method object in crosslinking.xml More...

#include <ms_crosslinking_method.hpp>

Collaboration diagram for ms_crosslinking_method:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_method ()
Default constructor.
ms_crosslinking_method (const ms_crosslinking_method &src)
Copying constructor.
virtual | ~ms_crosslinking_method ()
Destructor.
void | copyFrom (const ms_crosslinking_method *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAccessions ()
Delete the accessions element.
void | dropDescription ()
Delete the description attribute.
void | dropFilters ()
Delete the filters element.
void | dropLinkers ()
Delete the linkers element.
void | dropName ()
Delete the name attribute.
void | dropScope ()
Delete the scope element.
void | dropSettings ()
Delete the settings element.
void | dropStrategy ()
Delete the strategy attribute.
const ms_crosslinking_accessions * | getAccessions () const
Returns a pointer to the accessions element.
std::string | getAccessionsSchemaType () const
Obtain a symbolic name for the accessions element schema type.
std::string | getDescription () const
Returns the value of the description attribute.
std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
const ms_crosslinking_filters * | getFilters () const
Returns a pointer to the filters element.
std::string | getFiltersSchemaType () const
Obtain a symbolic name for the filters element schema type.
const ms_crosslinking_linkers * | getLinkers () const
Returns a pointer to the linkers element.
std::string | getLinkersSchemaType () const
Obtain a symbolic name for the linkers element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the "name attribute" schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_crosslinking_scope * | getScope () const
Returns a pointer to the scope element.
std::string | getScopeSchemaType () const
Obtain a symbolic name for the scope element schema type.
const ms_crosslinking_settings * | getSettings () const
Returns a pointer to the settings element.
std::string | getSettingsSchemaType () const
Obtain a symbolic name for the settings element schema type.
std::string | getStrategy () const
Returns the value of the strategy attribute.
std::string | getStrategySchemaType () const
Obtain a symbolic name for the strategy attribute schema type.
bool | haveAccessions () const
Returns TRUE if a accessions element exists.
bool | haveDescription () const
Indicates whether the description attribute is present.
bool | haveFilters () const
Returns TRUE if a filters element exists.
bool | haveLinkers () const
Returns TRUE if a linkers element exists.
bool | haveName () const
Indicates whether the name attribute is present.
bool | haveScope () const
Returns TRUE if a scope element exists.
bool | haveSettings () const
Returns TRUE if a settings element exists.
bool | haveStrategy () const
Indicates whether the strategy attribute is present.
ms_crosslinking_method & | operator= (const ms_crosslinking_method &right)
C++ style assignment operator.
void | setAccessions (const ms_crosslinking_accessions *accessions)
Supply custom content for the accessions element.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setFilters (const ms_crosslinking_filters *filters)
Supply custom content for the filters element.
void | setLinkers (const ms_crosslinking_linkers *linkers)
Supply custom content for the linkers element.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setScope (const ms_crosslinking_scope *scope)
Supply custom content for the scope element.
void | setSettings (const ms_crosslinking_settings *settings)
Supply custom content for the settings element.
void | setStrategy (const char *value)
Set a custom value for the strategy attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a method object in crosslinking.xml

A crosslinking method is a set of parameters that define and constrain the search space. See Crosslinked search results for a full description.

Constructor & Destructor Documentation

ms_crosslinking_method ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_method ( const ms_crosslinking_method & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_method * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropAccessions ( )

Delete the accessions element.

Deletes the element until it is re-set.

void dropDescription ( )

Delete the description attribute.

Deletes the attribute until it is re-set.

void dropFilters ( )

Delete the filters element.

Deletes the element until it is re-set.

void dropLinkers ( )

Delete the linkers element.

Deletes the element until it is re-set.

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

void dropScope ( )

Delete the scope element.

Deletes the element until it is re-set.

void dropSettings ( )

Delete the settings element.

Deletes the element until it is re-set.

void dropStrategy ( )

Delete the strategy attribute.

Deletes the attribute until it is re-set.

const ms_crosslinking_accessions * getAccessions ( ) const

Returns a pointer to the accessions element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getAccessionsSchemaType ( ) const

Obtain a symbolic name for the accessions element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getDescription ( ) const

Returns the value of the description attribute.

Returns:
a descriptive description that will appear in drop down lists, etc.
std::string getDescriptionSchemaType ( ) const

Obtain a symbolic name for the description attribute schema type.

The obtained type description can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type description for the element.
const ms_crosslinking_filters * getFilters ( ) const

Returns a pointer to the filters element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getFiltersSchemaType ( ) const

Obtain a symbolic name for the filters element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_crosslinking_linkers * getLinkers ( ) const

Returns a pointer to the linkers element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getLinkersSchemaType ( ) const

Obtain a symbolic name for the linkers element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getName ( ) const

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const

Obtain a symbolic name for the "name attribute" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
const ms_crosslinking_scope * getScope ( ) const

Returns a pointer to the scope element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getScopeSchemaType ( ) const

Obtain a symbolic name for the scope element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_crosslinking_settings * getSettings ( ) const

Returns a pointer to the settings element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getSettingsSchemaType ( ) const

Obtain a symbolic name for the settings element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getStrategy ( ) const

Returns the value of the strategy attribute.

Returns:
a descriptive strategy that will appear in drop down lists, etc.
std::string getStrategySchemaType ( ) const

Obtain a symbolic name for the strategy attribute schema type.

The obtained type strategy can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type strategy for the element.
bool haveAccessions ( ) const

Returns TRUE if a accessions element exists.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveDescription ( ) const

Indicates whether the description attribute is present.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveFilters ( ) const

Returns TRUE if a filters element exists.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveLinkers ( ) const

Returns TRUE if a linkers element exists.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveName ( ) const

Indicates whether the name attribute is present.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveScope ( ) const

Returns TRUE if a scope element exists.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveSettings ( ) const

Returns TRUE if a settings element exists.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveStrategy ( ) const

Indicates whether the strategy attribute is present.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_crosslinking_method & operator= ( const ms_crosslinking_method & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAccessions ( const ms_crosslinking_accessions * accessions )

Supply custom content for the accessions element.

Parameters:
accessions a new content for the element.
void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters:
value a new value for the attribute.
void setFilters ( const ms_crosslinking_filters * filters )

Supply custom content for the filters element.

Parameters:
filters a new content for the element.
void setLinkers ( const ms_crosslinking_linkers * linkers )

Supply custom content for the linkers element.

Parameters:
linkers a new content for the element.
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
void setScope ( const ms_crosslinking_scope * scope )

Supply custom content for the scope element.

Parameters:
scope a new content for the element.
void setSettings ( const ms_crosslinking_settings * settings )

Supply custom content for the settings element.

Parameters:
settings a new content for the element.
void setStrategy ( const char * value )

Set a custom value for the strategy attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_method.hpp
  • ms_crosslinking_method.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_monolink
Public Member Functions

ms_crosslinking_monolink Class Reference
[Mascot configuration files module]

Monolink element in crosslinking.xml More...

#include <ms_crosslinking_monolink.hpp>

List of all members.

Public Member Functions

ms_crosslinking_monolink ()
Default constructor.
ms_crosslinking_monolink (const ms_crosslinking_monolink &src)
Copying constructor.
virtual | ~ms_crosslinking_monolink ()
Destructor.
void | copyFrom (const ms_crosslinking_monolink *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the text of the node.
std::string | getValueSchemaType () const
Obtain a symbolic name for the text node schema type.
ms_crosslinking_monolink & | operator= (const ms_crosslinking_monolink &right)
C++ style assignment operator.
void | setValue (const char *value)
Set a custom text.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Monolink element in crosslinking.xml

Constructor & Destructor Documentation

ms_crosslinking_monolink ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_monolink ( const ms_crosslinking_monolink & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_monolink * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").
std::string getValue ( ) const

Returns the text of the node.

Returns:
current value text.
std::string getValueSchemaType ( ) const

Obtain a symbolic name for the text node schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
ms_crosslinking_monolink & operator= ( const ms_crosslinking_monolink & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setValue ( const char * value )

Set a custom text.

Parameters:
value a new value text.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_monolink.hpp
  • ms_crosslinking_monolink.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_parameter
Public Member Functions

ms_crosslinking_parameter Class Reference
[Mascot configuration files module]

Parameter name and value pair. More...

#include <ms_crosslinking_parameters.hpp>

Inheritance diagram for ms_crosslinking_parameter:
[legend]
Collaboration diagram for ms_crosslinking_parameter:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_parameter ()
Default constructor.
ms_crosslinking_parameter (const ms_crosslinking_parameter &src)
Copying constructor.
virtual | ~ms_crosslinking_parameter ()
Destructor.
void | copyFrom (const ms_crosslinking_parameter *right)
Copies all content from another instance.
void | copyFrom (const ms_xml_parameter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDescription ()
Delete the description attribute.
void | dropName ()
Delete the name attribute.
std::string | getDescription () const
Returns the value of the description attribute.
virtual std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
std::string | getName () const
Returns the value of the name attribute.
virtual std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the value of the value attribute.
virtual std::string | getValueSchemaType () const
Obtain a symbolic name for the value attribute schema type.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_crosslinking_parameter & | operator= (const ms_crosslinking_parameter &right)
C++ style assignment operator.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setValue (const char *value)
Set a custom value for the value attribute.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

Constructor & Destructor Documentation

ms_crosslinking_parameter ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_parameter ( const ms_crosslinking_parameter & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_parameter * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_xml_parameter * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void dropDescription ( ) [inherited]

Delete the description attribute.

Deletes the attribute until is re-set.

void dropName ( ) [inherited]

Delete the name attribute.

Deletes the attribute until is re-set.

std::string getDescription ( ) const [inherited]

Returns the value of the description attribute.

Returns:
a free text description of this parameter.
std::string getDescriptionSchemaType ( ) const [virtual]

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameter.

std::string getName ( ) const [inherited]

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const [virtual]

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameter.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Implements ms_xml_parameter.

std::string getValue ( ) const [inherited]

Returns the value of the value attribute.

Returns:
a string value of this parameter.
std::string getValueSchemaType ( ) const [virtual]

Obtain a symbolic name for the value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameter.

bool haveDescription ( ) const [inherited]

Indicates presence of the description attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveName ( ) const [inherited]

Indicates presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_crosslinking_parameter & operator= ( const ms_crosslinking_parameter & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setDescription ( const char * value ) [inherited]

Set a custom value for the description attribute.

Parameters:
value a new value for the attribute.
void setName ( const char * value ) [inherited]

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
void setValue ( const char * value ) [inherited]

Set a custom value for the value attribute.

Parameters:
value a new string value for the parameter.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_crosslinking_parameters.hpp
  • ms_crosslinking_parameters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_parameters
Public Member Functions

ms_crosslinking_parameters Class Reference
[Mascot configuration files module]

A class that represents base parametersType in crosslinking_1.xsd. More...

#include <ms_crosslinking_parameters.hpp>

Inheritance diagram for ms_crosslinking_parameters:
[legend]
Collaboration diagram for ms_crosslinking_parameters:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_parameters ()
Default constructor.
ms_crosslinking_parameters (const ms_crosslinking_parameters &src)
Copying constructor.
virtual | ~ms_crosslinking_parameters ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_parameters & | operator= (const ms_crosslinking_parameters &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A class that represents base parametersType in crosslinking_1.xsd.

Holds a list of arbitrary parameters.

Constructor & Destructor Documentation

ms_crosslinking_parameters ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_parameters ( const ms_crosslinking_parameters & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_parameters * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_xml_parameters.

Reimplemented in ms_crosslinking_filters, ms_crosslinking_scope, and ms_crosslinking_settings.

bool deleteParameterByName ( const char * name ) [virtual]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

int getNumberOfParameters ( ) const [virtual]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

Reimplemented in ms_crosslinking_filters, ms_crosslinking_scope, and ms_crosslinking_settings.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").

Implements ms_xml_parameters.

Reimplemented in ms_crosslinking_filters, ms_crosslinking_scope, and ms_crosslinking_settings.

ms_crosslinking_parameters & operator= ( const ms_crosslinking_parameters & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

The documentation for this class was generated from the following files:
  • ms_crosslinking_parameters.hpp
  • ms_crosslinking_parameters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_scope
Public Member Functions

ms_crosslinking_scope Class Reference
[Mascot configuration files module]

Scope element in crosslinking.xml More...

#include <ms_crosslinking_scope.hpp>

Inheritance diagram for ms_crosslinking_scope:
[legend]
Collaboration diagram for ms_crosslinking_scope:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_scope ()
Default constructor.
ms_crosslinking_scope (const ms_crosslinking_scope &src)
Copying constructor.
virtual | ~ms_crosslinking_scope ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_crosslinking_scope *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_scope & | operator= (const ms_crosslinking_scope &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Scope element in crosslinking.xml

The scope section contains a list of parameters. These define the type of links to look for.

In Mascot 2.7, scope parameters are:

  • MaxProteins: maximum number of proteins to consider for interlinking
  • InterLink: look for links between proteins ("True" or "False")
  • IntraLink: look for links within proteins ("True" or "False")
  • LoopLink: look for links within peptides ("True" or "False")

Constructor & Destructor Documentation

ms_crosslinking_scope ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_scope ( const ms_crosslinking_scope & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_scope * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_crosslinking_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Reimplemented from ms_crosslinking_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").

Reimplemented from ms_crosslinking_parameters.

ms_crosslinking_scope & operator= ( const ms_crosslinking_scope & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

The documentation for this class was generated from the following files:
  • ms_crosslinking_scope.hpp
  • ms_crosslinking_scope.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_crosslinking_settings
Public Member Functions

ms_crosslinking_settings Class Reference
[Mascot configuration files module]

Settings element in crosslinking.xml More...

#include <ms_crosslinking_settings.hpp>

Inheritance diagram for ms_crosslinking_settings:
[legend]
Collaboration diagram for ms_crosslinking_settings:
[legend]

List of all members.

Public Member Functions

ms_crosslinking_settings ()
Default constructor.
ms_crosslinking_settings (const ms_crosslinking_settings &src)
Copying constructor.
virtual | ~ms_crosslinking_settings ()
Destructor.
void | appendParameter (const ms_crosslinking_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_crosslinking_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_crosslinking_settings *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_crosslinking_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_crosslinking_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_crosslinking_settings & | operator= (const ms_crosslinking_settings &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_crosslinking_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Settings element in crosslinking.xml

The settings section contains a list of parameters. These define the "business logic" for the crosslinking strategy.

These settings are intended for upstream (downstream) processing before (after) the spectrum has been matched:

  • AssumeLinear: fragments with this charge or less are assumed not to include linked peptide (absolute value)
  • AssumeLinked: fragments with this charge or more are assumed to include linked peptide (absolute value)
  • SignatureScan: identifier(s) for scans to be inspected for signature peaks (see below)
  • SignatureType: one of "reporter", "doublet", "triplet", "quadruplet"
  • SignatureComp: depends on SignatureType, and specified as an elemental composition. The signature could be a single delta, multiple deltas or one or more reporter peaks.
  • SignatureSN: minimum S/N for signature peak(s)
  • SignatureStringency: one of "low", "medium", "high"
  • SignatureTop: number of the most intense peaks that are candidates to be signature peaks
  • MatchPair: identifier(s) for scans that may include fragments from both peptides in a pair (see below)
  • MatchSingle: identifier(s) for scans that may include fragments from one peptide only (see below)

Scan identifier format for SignatureScan, MatchPair and MatchSingle is a comma-separated list of tokens from:

  • CID
  • ETD
  • MS1
  • MS2
  • MS3

Constructor & Destructor Documentation

ms_crosslinking_settings ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_crosslinking_settings ( const ms_crosslinking_settings & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_crosslinking_settings * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_crosslinking_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_crosslinking_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_crosslinking_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Reimplemented from ms_crosslinking_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mxm:nameType").

Reimplemented from ms_crosslinking_parameters.

ms_crosslinking_settings & operator= ( const ms_crosslinking_settings & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateParameterByName | ( | const char * | name,
 |  | const ms_crosslinking_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_crosslinking_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

The documentation for this class was generated from the following files:
  • ms_crosslinking_settings.hpp
  • ms_crosslinking_settings.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_databaseoptions
Public Types | Public Member Functions

ms_databaseoptions Class Reference
[Mascot configuration files module]

An instance of this class represents a single database definition from the Databases section of mascot.dat. More...

#include <ms_databaseoptions.hpp>

List of all members.

Public Types

enum | { NUM_THREADS_AUTO_DETECT = -1 }

Value used to indicate that the number of threads to be used should be automatically determined at runtime.

More...

Public Member Functions

ms_databaseoptions ()
Default constructor.
ms_databaseoptions (const ms_databaseoptions &src)
Copying constructor.
~ms_databaseoptions ()
Destructor.
void | copyFrom (const ms_databaseoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
int | getAccessionParseRuleIndex () const
Returns the value of AccessionParseRuleIndex.
int | getAccessionRefParseRuleIndex () const
Returns the value of AccessionRefParseRuleIndex.
int | getDBType () const
Return the database type.
int | getDescriptionParseRuleIndex () const
Returns the value of DescriptionParseRuleIndex.
std::string | getName () const
Returns the value of Name.
int | getNumberOfThreads () const
Returns the value of Threads.
std::string | getPath () const
Return the value of Path.
const std::string & | getPreceedingComments () const
Get the comment preceding this database entry.
int | getTaxonomyParseRuleIndex () const
Returns the value of TaxonomyParseRuleIndex.
bool | isActive () const
Returns true if the database definition is active and false otherwise.
bool | isLocalRefFile () const
Returns TRUE if LocalRefFile flag is set to 1 and FALSE otherwise.
bool | isLockMemory () const
Returns TRUE if MemLock flag is set to 1 and FALSE otherwise.
bool | isMemoryMapFiles () const
Returns the value of MemMap.
ms_databaseoptions & | operator= (const ms_databaseoptions &right)
Assignment operator for C++ client applications.
void | setAccessionParseRuleIndex (const int index)
Change AccessionParseRuleIndex.
void | setAccessionRefParseRuleIndex (const int index)
Change AccessionRefParseRuleIndex.
void | setActive (const bool value)
Set the definition as active or inactive.
void | setDBType (const int type)
Change the database type.
void | setDescriptionParseRuleIndex (const int index)
Change DescriptionParseRuleIndex.
void | setLocalRefFile (const bool flag)
Change LocalRefFile.
void | setLockMemory (const bool flag)
Change MemLock.
void | setMemoryMapFiles (const bool flag)
Change MemMap.
void | setName (const char *name)
Change Name.
void | setNumberOfThreads (const int number)
Change Threads.
void | setPath (const char *path)
Change Path.
void | setPreceedingComments (const std::string &str)
Set the comments preceding this database entry.
void | setTaxonomyParseRuleIndex (const int index)
Change TaxonomyParseRuleIndex.

Detailed Description

An instance of this class represents a single database definition from the Databases section of mascot.dat.

An instance of this class can be normally created within ms_datfile. Before using a definition you must check whether it is active or not (with isActive()). An inactive database definition is allowed to have invalid properties and, therefore, must be ignored for database searches/maintenance. An inactive definition can be made active with setActive(). Before doing so, make sure all the properties are valid.

Instances of the class can be stored in ms_databases.

Member Enumeration Documentation

anonymous enum

Value used to indicate that the number of threads to be used should be automatically determined at runtime.

See ms_processors::getAutoDetectNumThreads() and getNumberOfThreads().

(Defined as an enum rather than static const int to support VC6)

Enumerator:
NUM_THREADS_AUTO_DETECT

Value used to indicate that the number of threads to be used should be automatically determined at runtime.

Member Function Documentation

int getAccessionParseRuleIndex ( ) const

Returns the value of AccessionParseRuleIndex.

Index of the regular expression in the PARSE section that can be used to parse an accession string from a FASTA file title line.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
the index for the parse rule.
int getAccessionRefParseRuleIndex ( ) const

Returns the value of AccessionRefParseRuleIndex.

Index of the regular expression in the PARSE section that can be used to parse an accession string from a local full text reference file. If there is no local reference file, this value is ignored.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
the index for the parse rule.
int getDBType ( ) const

Return the database type.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
One of the DATABASE_TYPE enumeration values. Note that the returned type is never SLREF.
int getDescriptionParseRuleIndex ( ) const

Returns the value of DescriptionParseRuleIndex.

Index of the regular expression in the PARSE section that can be used to parse a description string from a FASTA file title line.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
the index for the parse rule.
std::string getName ( ) const

Returns the value of Name.

Each database must have a unique case-sensitive name that is displayed in the search form

The name does not need to be the same as or even similar to the filename of the actual FASTA file.

Do not use spaces, punctuation, or control characters in names.

By default this is empty.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
the name of the database
Examples:
config_mascotdat.cpp.
int getNumberOfThreads ( ) const

Returns the value of Threads.

A Mascot search can use multiple threads. If you are running in cluster mode, Threads should be set to 1. Otherwise, specify the same number of threads as processors in your system.

A value of -1 is 'AUTO' which means that the number of threads is set to the maximum possible depending on the number of cores avaiable and the size of the license.

This value has no meaning for spectral libraries

Default, from version 2.6 onwards is -1.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns:
the number of threads
std::string getPath ( ) const

Return the value of Path.

FASTA database files must be on a local disk. Mascot creates its compressed files in the same directory as the original FASTA file. The location of the FASTA file is defined in the Path field. This must be the fully qualified path to the FASTA file, with a wild card in the filename. The delimiters between directories must always be forward slashes, even if Mascot is running on a Windows system.

By default this is empty.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
the path with wild card
int getTaxonomyParseRuleIndex ( ) const

Returns the value of TaxonomyParseRuleIndex.

Index of the taxonomy rule block to be used to parse taxonomy information. If taxonomy information is not available, or is not to be used, this value should be set to 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N

Default is 0.

Returns:
Index of the taxonony rule
bool isActive ( ) const

Returns true if the database definition is active and false otherwise.

Inactive definitions represent the entries that can be made active by the database manager utility. In the mascot.dat file, they are simply commented out entries.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | Y
Returns:
true if the database definition is active
Examples:
config_mascotdat.cpp.
bool isLocalRefFile ( ) const

Returns TRUE if LocalRefFile flag is set to 1 and FALSE otherwise.

Flag to indicate whether a local reference file is available (1) or not (0). For certain databases (MSDB, OWL, and SwissProt), it is possible to have a local reference file, from which full text information can be taken for a Protein View report.

Default is 0.

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns:
true if the database has a local reference file
bool isLockMemory ( ) const

Returns TRUE if MemLock flag is set to 1 and FALSE otherwise.

Flag to indicate whether a memory mapped database file should be locked in memory (1) or not (0).

Default is 0.

See also:
isMemoryMapFiles()

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns:
true if the database should be locked in memory
bool isMemoryMapFiles ( ) const

Returns the value of MemMap.

This flag is to indicate whether the database file should be memory mapped (1) or not (0). Database files should always be memory mapped. Unlike memory locking, this does not consume physical RAM.

Default is 1.

See also:
isLockMemory()

Applies to:

Amino acid fasta | Nucleic acid fasta | Spectral library
Y | Y | N
Returns:
true if the database is to be memory mapped
void setAccessionParseRuleIndex ( const int index )

Change AccessionParseRuleIndex.

See getAccessionParseRuleIndex() for more information.

Parameters:
index is the new value
void setAccessionRefParseRuleIndex ( const int index )

Change AccessionRefParseRuleIndex.

See getAccessionRefParseRuleIndex() for more information.

Parameters:
index is the new value
void setActive ( const bool value )

Set the definition as active or inactive.

See isActive() for more information.

Parameters:
value is the new value
void setDBType ( const int type )

Change the database type.

See getDBType() for more information.

Parameters:
type should be one of the DATABASE_TYPE enumeration values. Note that SLREF is not a supported database type for this purpose.
void setDescriptionParseRuleIndex ( const int index )

Change DescriptionParseRuleIndex.

See getDescriptionParseRuleIndex() for more information.

Parameters:
index is the new value
void setLocalRefFile ( const bool flag )

Change LocalRefFile.

See isLocalRefFile() for more information.

Parameters:
flag is the new value
void setLockMemory ( const bool flag )

Change MemLock.

See isLockMemory() for more information.

Parameters:
flag is the new value
void setMemoryMapFiles ( const bool flag )

Change MemMap.

See isMemoryMapFiles() for more information.

Parameters:
flag is the new value
void setName ( const char * name )

Change Name.

See getName() for more information.

Parameters:
name is the new value
void setNumberOfThreads ( const int number )

Change Threads.

See getNumberOfThreads() for more information.

Parameters:
number is the new value
void setPath ( const char * path )

Change Path.

See getPath() for more information.

Parameters:
path is the new value
void setTaxonomyParseRuleIndex ( const int index )

Change TaxonomyParseRuleIndex.

See getTaxonomyParseRuleIndex() for more information.

Parameters:
index is the new value
The documentation for this class was generated from the following files:
  • ms_databaseoptions.hpp
  • ms_databaseoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_databases
Public Member Functions

ms_databases Class Reference
[Mascot configuration files module]

An instance of this class represents the Databases section of mascot.dat. More...

#include <ms_databaseoptions.hpp>

Inheritance diagram for ms_databases:
[legend]
Collaboration diagram for ms_databases:
[legend]

List of all members.

Public Member Functions

ms_databases ()
Default constructor.
ms_databases (const ms_databases &src)
Copying constructor.
~ms_databases ()
Destructor.
void | appendDatabase (const ms_databaseoptions *item)
Add one more database definition at the end of the list.
void | clearDatabases ()
Deletes all database definitions.
void | copyFrom (const ms_databases *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
bool | deleteDatabaseByName (const char *name)
Remove a database from the list in memory.
bool | deleteDatabaseByNumber (const int num)
Remove a database from the list in memory.
int | findDatabase (const char *dbName, const bool searchInactive=false) const
Finds a database with the specified name and returns its number to access.
const ms_databaseoptions * | getDatabase (const int index) const
Returns a database definition by its number.
int | getNumberOfDatabases () const
Returns the total number of database definitions including inactive (commented out) databases.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
bool | isSectionAvailable () const
Check if the section has been actually read form the file or have to be saved.
ms_databases & | operator= (const ms_databases &right)
Assignment operator for C++ client applications.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in the file.
bool | updateDatabaseByName (const char *name, const ms_databaseoptions db)
Update the information for a specific database.
bool | updateDatabaseByNumber (const int num, const ms_databaseoptions db)
Update the information for a specific database.

Detailed Description

An instance of this class represents the Databases section of mascot.dat.

An instance is created and populated with database entries within ms_datfile class. It contains active database definitions as well as inactive ones. When traversing the list of database with getNumberOfDatabases() and getDatabase() members, don't forget to check each entry for being active. Otherwise one or all database parameters might be invalid and, therefore, must be ignored. In a text-based configuration file a database definition can be made inactive by commenting it out.

For detailed information on any of the options please consult Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • retrieving an unsupported property
  • retrieving raw/text/xml property representation
  • checking for existence of a certain property rather than dealing with its default value
  • accessing commented lines in a section

More functionality is described in details in the documentation for the class.

Examples:

config_mascotdat.cpp.

Member Function Documentation

void appendDatabase ( const ms_databaseoptions * item )

Add one more database definition at the end of the list.

Parameters:
item valid pointer to a ms_databaseoptions object
bool deleteDatabaseByName ( const char * name )

Remove a database from the list in memory.

If the database name is specified incorrectly FALSE value is returned and no action is performed.

Parameters:
name the database name.
Returns:
TRUE if the database has been found and deleted and FALSE otherwise.
bool deleteDatabaseByNumber ( const int num )

Remove a database from the list in memory.

If the database index is specified incorrectly FALSE value is returned and no action is performed.

Parameters:
num zero-based database index.
Returns:
TRUE if the database has been deleted and FALSE otherwise.
int findDatabase | ( | const char * | dbName,
 |  | const bool | searchInactive = false
 | ) |  | const

Finds a database with the specified name and returns its number to access.

Note that only active database will be returned (unless searchInactive is set to TRUE). If no database have been found the returning value will be -1.

Parameters:
dbName | a database name to find.
searchInactive | set this parameter to TRUE if you want to search both active and inactive databases.
Returns:
the database index if found and -1 if not.
const ms_databaseoptions * getDatabase ( const int index ) const

Returns a database definition by its number.

Use this member to retrieve a database definition with index from 0 to (getNumberOfDatabases()-1).

Parameters:
index number of database to look for
Returns:
pointer to a ms_databaseoptions object
Examples:
config_mascotdat.cpp.
int getNumberOfDatabases ( ) const

Returns the total number of database definitions including inactive (commented out) databases.

By default the list of database is empty unless explicitly populated.

Returns:
Number of databases
Examples:
config_mascotdat.cpp.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
bool updateDatabaseByName | ( | const char * | name,
 |  | const ms_databaseoptions | db
 | ) |  |

Update the information for a specific database.

If a database with the supplied name cannot be found no database will be updated and the returning value will be FALSE.

Parameters:
name | a database name to find.
db | a database object to copy the content from.
Returns:
TRUE if the database has been successfully found and updated and FALSE otherwise.
bool updateDatabaseByNumber | ( | const int | num,
 |  | const ms_databaseoptions | db
 | ) |  |

Update the information for a specific database.

If the index is out of bounds no database will be updated and the returning value will be FALSE.

Parameters:
num | a zero-based index of the database to update.
db | a database object to copy the content from.
Returns:
TRUE if the database index indicates a valid database in the internal list and FALSE otherwise.
The documentation for this class was generated from the following files:
  • ms_databaseoptions.hpp
  • ms_databaseoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_datfile
Public Types | Public Member Functions

ms_datfile Class Reference
[Mascot configuration files module]

Encapsulates the mascot.dat file that contains the most important parameters. More...

#include <ms_datfile.hpp>

Inheritance diagram for ms_datfile:
[legend]
Collaboration diagram for ms_datfile:
[legend]

List of all members.

Public Types

enum INST_FLAGS {
IFLG_UPDATETAXONOMY = 0x00000001,
IFLG_UPDATEPARSERULES = 0x00000002,
IFLG_UPDATESWISSPROT = 0x00000004,
IFLG_UPDATECLUSTER = 0x00000008,
IFLG_UPDATEESTTAX = 0x00000010,
IFLG_ADDMISSINGOPTIONS = 0x00000020,
IFLG_ADDREPORTAUTO = 0x00000040,
IFLG_UPDATEAPACHEFORKOPT = 0x00000080,
IFLG_ADDPERCOLATOROPT = 0x00000100,
IFLG_UPDATENCBIHTTPS = 0x00000200,
IFLG_UPDATEPRIDECONTAMINANTS = 0x00000400,
IFLG_UPDATEDBMANAGERPERLPATH = 0x00000800,
IFLG_UPDATEMSPEPSEARCHOPTS = 0x00001000,
IFLG_UPDATEEXECAFTERSEARCH = 0x00002000,
IFLG_UPDATEPERCOLATORFEATS = 0x00004000,
IFLG_UPDATEPROTFAMILYSWITCH = 0x00008000,
IFLG_DEFAULTNEWINSTALL,
IFLG_DEFAULTUPGRADE
}

Flags for the updateForInstaller() function.

More...
enum SEQDB_INSTALL {
SEQDB_INSTALL_SHOULD_QUERY_USER = 0x0000FFFF,
SEQDB_INSTALL_CUSTOMISED = 0x00000001,
SEQDB_INSTALL_INACTIVE = 0x00000002,
SEQDB_INSTALL_INVALID_CONFIG = 0x00000004,
SEQDB_INSTALL_EXISTING_LARGER = 0x00000010,
SEQDB_INSTALL_INVALID_DBNAME = 0x00000000,
SEQDB_INSTALL_MUST_UPDATE_CFG = 0x000F000F,
SEQDB_INSTALL_MISSING_CONFIG = 0x00010000,
SEQDB_INSTALL_OLD_RULES = 0x00020000,
SEQDB_INSTALL_WRONG_WILDCARD = 0x00040000,
SEQDB_INSTALL_CURRENT_RULES = 0x01000000
}

Flags for checkSeqDBInstallRequest().

More...
enum WST {
WST_APACHE = 0,
WST_IIS = 1
}

Web server type for the updateForInstaller() function.

More...

Public Member Functions

ms_datfile ()
Default constructor.
ms_datfile (const ms_datfile &src)
Copying constructor.
ms_datfile (const char *filename, const int timeoutSec=0, const matrix_science::ms_connection_settings *cs=0)
Immediate action constructor.
~ms_datfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
unsigned int | checkSeqDBInstallRequest (const std::string &dbName, const double newFastaSize) const
Utility function for the installation program.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_datfile *right)
Use this member to make a copy of another instance.
void | defaultValues ()
Can be used for initialising an instance with default values.
bool | editedByDatabaseManager () const
This function returns true if Database Manager has edited the mascot.dat file.
const ms_clusterparams * | getClusterParams () const
Returns an instance of the class representing the Cluster section.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_cronoptions * | getCronOptions () const
Returns an instance of the class representing the Cron section.
const ms_databases * | getDatabases () const
Returns an instance of the class representing the Databases section.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a path to the file that was set explicitly or the default file name.
int | getFindFileTimeout () const
Returns current time out value in seconds for open file operation.
std::string | getHeaderComments () const
Returns comment lines at the start of mascot.dat.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
const ms_libraryoptions * | getLibraryOptions () const
Returns an instance of the class representing the LibraryOptions section.
const ms_mascotfiles * | getMascotFiles () const
Returns an instance of the class containing location of other configuration files.
const ms_mascotoptions * | getMascotOptions () const
Returns an instance of the class representing the Options section.
int | getMaxTaxonomyRules () const
Returns a maximum possible Taxonomy section number that can be used to retrieve/set the section content.
const ms_parseoptions * | getParseOptions () const
Returns an instance of the class representing the PARSE section.
const ms_processoroptions * | getProcessors () const
Returns an instance of the class representing the Processors section.
const ms_taxonomyrules * | getTaxonomyRules (const int idx) const
Returns an instance of the class representing one of the Taxonomy_XXX sections.
const ms_unigeneoptions * | getUniGeneOptions () const
Returns an instance of the class representing the UniGene section.
const ms_wwwoptions * | getWWWOptions () const
Returns an instance of the class representing the WWW section.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_datfile & | operator= (const ms_datfile &right)
C++ style assignment operator.
void | read_file ()
Call this method in order to read the configuration information from the file.
void | save_file ()
Saves the content in the file.
void | setClusterParams (const ms_clusterparams *params)
Update the content of the Cluster section.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setCronOptions (const ms_cronoptions *options)
Update the content of the Cron section.
void | setDatabases (const ms_databases *dbs)
Update the content of the Databases section.
void | setFileName (const char *name)
Set the file name explicitly, before saving or loading.
void | setFindFileTimeout (const int seconds)
Sets the time out for local file search.
void | setHeaderComments (const std::string headerComments)
Sets comment lines at the start of mascot.dat.
void | setLibraryOptions (const ms_libraryoptions *spectralLibraryOptions)
Update the content of the LibraryOptions section.
void | setMascotFiles (const ms_mascotfiles *src)
Update the location of other configuration files.
void | setMascotOptions (const ms_mascotoptions *opt)
Update the content of the Options section.
void | setParseOptions (const ms_parseoptions *rules)
Update the content of the PARSE section.
void | setProcessors (const ms_processoroptions *info)
Update the content of the Processors section.
void | setTaxonomyRules (const int idx, const ms_taxonomyrules *rules)
Update or create an existing the Taxonomy_XXX section.
void | setUniGeneOptions (const ms_unigeneoptions *uoptions)
Update the content of the UniGene section.
void | setWWWOptions (const ms_wwwoptions *www)
Update the content of the WWW section.
bool | updateForInstaller (ms_errs &log, const char *not_mascot_dat_path, const char *mascot_dat_path, const char *licenseFilePath, const char *pathToMascot, const char *mascotURL, const char *sequenceDatabases, const bool clusterEnable, const WST wst, const char *NTGuestName, const char *NTAdminName, const unsigned int flags)
Creates and updates mascot.dat for the Mascot Installation programs.

Detailed Description

Encapsulates the mascot.dat file that contains the most important parameters.

The file is divided into several sections. Each section has corresponding accessor methods (getXXX/setXXX).

The path to mascot.dat can be specified explicitly. However, several default locations will be tried if the object is used without setting a file name. Before obtaining any section content check the object for any errors that might occur using isValid() method.

Examples:

common_error.cpp, config_mascotdat.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum INST_FLAGS

Flags for the updateForInstaller() function.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
IFLG_UPDATETAXONOMY

Inserts missing taxonomy sections.

IFLG_UPDATEPARSERULES

Inserts missing parse rules.

IFLG_UPDATESWISSPROT

Add an entry for SwissProt if it doesn't exist, or update it if parse rules are wrong.

IFLG_UPDATECLUSTER

Update the cluster section.

IFLG_UPDATEESTTAX

Update EST_human, EST_mouse if very old taxonomy.

IFLG_ADDMISSINGOPTIONS

Add entries missing options from the default values in not.mascot.dat.

IFLG_ADDREPORTAUTO

Add AUTO to the list in ReportNumberChoices if it isn't already present.

IFLG_UPDATEAPACHEFORKOPT

Update ForkForUnixApache using the value specified by the wst parameter. From Parser 2.5.2 onwards, under Windows, the value in wst is ignored and it is assumed to be WST_IIS.

IFLG_ADDPERCOLATOROPT

Add -U to the flags in PercolatorExeFlags if it doesn't already exist.

IFLG_UPDATENCBIHTTPS

Change TaxBrowserUrl http://www.ncbi... to TaxBrowserUrl https://www.ncbi...

IFLG_UPDATEPRIDECONTAMINANTS

Add an entry for PRIDE_Contaminants if it doesn't exist, or update it if parse rules are wrong.

IFLG_UPDATEDBMANAGERPERLPATH

If the path to perl for the dbman_process_tasks.pl script in the cron section is missing, or wrong, then insert ot replace.

IFLG_UPDATEMSPEPSEARCHOPTS

If the LibrarySearch line in the Options section of mascot.dat contains ' m G ' then change this to ' m a P '. Also, if it contains " /HITS 100 " change this to " /HITS 10 ".

IFLG_UPDATEEXECAFTERSEARCH

Update ExecAfterSearch_* lines and remove ms-createpip.exe from it.

IFLG_UPDATEPERCOLATORFEATS

Update Percolator features set.

IFLG_UPDATEPROTFAMILYSWITCH

Update ProteinFamilySwitch.

IFLG_DEFAULTNEWINSTALL

Default flags for a new installation. Just the IFLG_UPDATECLUSTER and IFLG_UPDATEAPACHEFORKOPT flag.

IFLG_DEFAULTUPGRADE

Default flags for an upgrade. All flags except IFLG_UPDATECLUSTER, IFLG_UPDATESWISSPROT and IFLG_UPDATEPRIDECONTAMINANTS.

enum SEQDB_INSTALL

Flags for checkSeqDBInstallRequest().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

These values may be bitwise 'ORd' together.

Enumerator:
SEQDB_INSTALL_SHOULD_QUERY_USER

Bitwise 'and' the return value from checkSeqDBInstallRequest() with this value to determine if an update of the fasta files may be unwise.

SEQDB_INSTALL_CUSTOMISED

User has an unrecognised configuration, possibly with a customised SwissProt, so installing an update may be unwise.

SEQDB_INSTALL_INACTIVE

User has an existing configuration, but it is disabled.

SEQDB_INSTALL_INVALID_CONFIG

User has an invalid configuration. For example, missing parse rules or specifying to use accession from the fasta and ID from the .dat.

SEQDB_INSTALL_EXISTING_LARGER

User has an existing fasta file larger (and presumably later) than the one on the installer CD.

SEQDB_INSTALL_INVALID_DBNAME

An unsupported dbName was passed to the function.

SEQDB_INSTALL_MUST_UPDATE_CFG

The configuration must be updated if the newer fasta files are to be installed.

SEQDB_INSTALL_MISSING_CONFIG

There is no configuration for the database. Installing should not give any conflict.

SEQDB_INSTALL_OLD_RULES

For example, the rules for SwissProt are for version 51 to version 55.

SEQDB_INSTALL_WRONG_WILDCARD

For example, could be Sprot_*.fasta rather than SwissProt_*.fasta.

SEQDB_INSTALL_CURRENT_RULES

Currently set if the rules for SwissProt are for version 56 to version ...

enum WST

Web server type for the updateForInstaller() function.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
WST_APACHE

Apache. From Parser 2.5.2 onwards, under Windows, this value is ignored when setting ForkForUnixApache and it is assumed to be WST_IIS.

WST_IIS

Microsoft IIS (Internet Information Services)

Constructor & Destructor Documentation

ms_datfile ( )

Default constructor.

The default constructor can be used to create a new ms_datfile programmatically.

ms_datfile ( const ms_datfile & src )

Copying constructor.

Note:
Do not use this constructor in programming languages other than C++.

Create a new copy of the object from an existing one.

Parameters:
src is the datfile to copy from.
ms_datfile | ( | const char * | filename,
 |  | const int | timeoutSec = 0,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Immediate action constructor.

Parameters:
filename | The file name parameter can be either a local file path or a Mascot server URL. It cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi.
timeoutSec | timeout for open operation. For more information, see setFindFileTimeout().
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.
~ms_datfile ( )

Destructor.

Releases all memory. Called automatically from all supported languages.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
unsigned int checkSeqDBInstallRequest | ( | const std::string & | dbName,
 |  | const double | newFastaSize
 | ) |  | const

Utility function for the installation program.

This function is called by an installer to determine whether it is 'safe' to update a particular database. The return value is an integer that comprises one or more flags, bitwise ANDed together.

After calling this function, any errors can be found by calling isValid() and getLastErrorString().

The return value should be OR'd with ms_datfile::SEQDB_INSTALL_SHOULD_QUERY_USER to determine whether to ask the end user to confirm that they wish to continue with the installation/update of the specified database.

Parameters:
dbName | Currently only "SwissProt" and "PRIDE_Contaminants" are supported. Passing any other string will result in ms_datfile::SEQDB_INSTALL_INVALID_DBNAME being returned.
newFastaSize | is the size in bytes of the new fasta file. This is passed as a double because there is no guarantee of 64 bit integer support in Perl.
Returns:
One or more ms_datfile::SEQDB_INSTALL values, ORd together.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_datfile * right )

Use this member to make a copy of another instance.

C++: use the copy constructor instead.

Parameters:
right is the object to copy from.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void defaultValues ( )

Can be used for initialising an instance with default values.

All existing settings, apart from the filename, are lost.

bool editedByDatabaseManager ( ) const

This function returns true if Database Manager has edited the mascot.dat file.

If Database Manager is being used, then most sections of the file should not be edited in a text editor or by using this Mascot Parser class. See comments at the top of the mascot.dat file for further information.

Returns:
true if the line
#  WARNING: Do not edit this file to make changes to        #
is found near the top of the file
const ms_clusterparams * getClusterParams ( ) const

Returns an instance of the class representing the Cluster section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setClusterParams().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_clusterparams object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
const ms_cronoptions * getCronOptions ( ) const

Returns an instance of the class representing the Cron section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setCronOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_cronoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
const ms_databases * getDatabases ( ) const

Returns an instance of the class representing the Databases section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setDatabases().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_databases object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns a path to the file that was set explicitly or the default file name.

The filename should include the complete or relative path, or it can be a URL to a Mascot server.

Returns:
the current filename for mascot.dat.
int getFindFileTimeout ( ) const

Returns current time out value in seconds for open file operation.

This may be useful for the file that is being periodically updated or downloaded by another application. During file-copying operations the file might be inacessible. The library will still try to open it during the specified period of time.

By default, the timeout is set to zero meaning no further attempts are made to find and open the file.

Returns:
Time in seconds.
std::string getHeaderComments ( ) const

Returns comment lines at the start of mascot.dat.

Multiple lines are separated by \n

The first section in the mascot.dat file is the Databases section and this must exist.

Comments before sections other than the databases section can be returned using ms_customproperty::getPreceedingComments(). The ms_databases class inherits from ms_customproperty, but due to historical reasons the comments preceding it are stored separately.

Returns:
the comment lines at the start of mascot.dat
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
const ms_libraryoptions * getLibraryOptions ( ) const

Returns an instance of the class representing the LibraryOptions section.

Returns:
an instance of the class representing the LibraryOptions section.
const ms_mascotfiles * getMascotFiles ( ) const

Returns an instance of the class containing location of other configuration files.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setMascotFiles().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_mascotfiles object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
const ms_mascotoptions * getMascotOptions ( ) const

Returns an instance of the class representing the Options section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setMascotOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_mascotoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
int getMaxTaxonomyRules ( ) const

Returns a maximum possible Taxonomy section number that can be used to retrieve/set the section content.

There are multiple taxonomy rules sections in mascot.dat: Taxonomy_1, Taxonomy_2, etc. This value is the maximum number that can be used for a taxonomy section.

See also:
getTaxonomyRules(), setTaxonomyRules()
Returns:
The maximum value for a taxonomy section in mascot.dat.
Examples:
config_mascotdat.cpp.
const ms_parseoptions * getParseOptions ( ) const

Returns an instance of the class representing the PARSE section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setParseOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_parseoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
const ms_processoroptions * getProcessors ( ) const

Returns an instance of the class representing the Processors section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setProcessors().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_processoroptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
const ms_taxonomyrules * getTaxonomyRules ( const int idx ) const

Returns an instance of the class representing one of the Taxonomy_XXX sections.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setTaxonomyRules().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Taxonomy rules sections can be listed in mascot.dat in a random order and with gaps between numbers. Therefore, it is essential that the return value is checked to be not null before accessing its properties. A NULL value indicates 'no such taxonomy section'.

Parameters:
idx is the ID of the taxonomy rules section. There are multiple taxonomy rules sections mascot.dat: Taxonomy_1, Taxonomy_2 etc. The value should be in the range 1 to getMaxTaxonomyRules().
Returns:
a const pointer to the ms_taxonomyrules object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
const ms_unigeneoptions * getUniGeneOptions ( ) const

Returns an instance of the class representing the UniGene section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setUniGeneOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_unigeneoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
const ms_wwwoptions * getWWWOptions ( ) const

Returns an instance of the class representing the WWW section.

This function returns a pointer to the object held internally in the ms_datfile object. A pointer, rather than a copy of the object is returned for performance reasons.

C++: The pointer returned is 'const' so the contents cannot be altered by a C++ application. To update a mascot.dat file, create a copy of the object returned from this function using the supplied copy constructor, make the modifications and then call setWWWOptions().

Other languages: Any change to the parameters returned by this function will be 'global' to the ms_datfile object.

Returns:
a const pointer to the ms_wwwoptions object held internally in the ms_datfile object. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_datfile & operator= ( const ms_datfile & right )

C++ style assignment operator.

Note:
This operator can only be used in C++.
Parameters:
right is the object to copy from.
Returns:
a reference to 'this'.
void read_file ( )

Call this method in order to read the configuration information from the file.

It shouldn't normally be necessary to call this function as it will be called automatically from the constructor. See ms_datfile::ms_datfile for further information.

Examples:
common_error.cpp.
void save_file ( )

Saves the content in the file.

Saves the file using the current filename. Can only be saved as a local file.

void setClusterParams ( const ms_clusterparams * params )

Update the content of the Cluster section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getClusterParams()
Parameters:
params is a pointer to the new ms_clusterparams.
void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setCronOptions ( const ms_cronoptions * options )

Update the content of the Cron section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getCronOptions()
Parameters:
options is a pointer to the new ms_cronoptions.
void setDatabases ( const ms_databases * dbs )

Update the content of the Databases section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getDatabases()
Parameters:
dbs is a pointer to the new ms_databases.
void setFileName ( const char * name )

Set the file name explicitly, before saving or loading.

The filename should include the complete or relative path, or it can be a URL to a Mascot server.

Parameters:
name is the new filename for mascot.dat.
Examples:
common_error.cpp.
void setFindFileTimeout ( const int seconds )

Sets the time out for local file search.

This may be useful for the file that is being periodically updated or downloaded by another application. During file-copying operations the file might be inacessible. The library will still try to open it during the specified period of time.

By default, the timeout is set to zero meaning no further attempts are made to find and open the file.

Parameters:
seconds is the time in seconds.
void setHeaderComments ( const std::string headerComments )

Sets comment lines at the start of mascot.dat.

Multiple lines are separated by \n

The first section in the mascot.dat file is the Databases section and this must exist.

Comments before sections other than the databases section can be set using ms_customproperty::setPreceedingComments(). The ms_databases class inherits from ms_customproperty, but due to historical reasons the comments preceding it are stored separately.

Parameters:
headerComments are new comments to replace the old ones.
void setLibraryOptions ( const ms_libraryoptions * spectralLibraryOptions )

Update the content of the LibraryOptions section.

call ms_datfile::save_file() after calling this function.

Parameters:
spectralLibraryOptions is the new LibraryOptions section.
void setMascotFiles ( const ms_mascotfiles * src )

Update the location of other configuration files.

The ms_datfile object is updated with a copy of the data passed.

See also:
getMascotFiles()
Parameters:
src is a pointer to the new ms_mascotfiles.
void setMascotOptions ( const ms_mascotoptions * opt )

Update the content of the Options section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getMascotOptions()
Parameters:
opt is a pointer to the new ms_mascotoptions.
void setParseOptions ( const ms_parseoptions * rules )

Update the content of the PARSE section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getParseOptions()
Parameters:
rules is a pointer to the new ms_parseoptions.
void setProcessors ( const ms_processoroptions * info )

Update the content of the Processors section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getProcessors()
Parameters:
info is a pointer to the new ms_processoroptions.
void setTaxonomyRules | ( | const int | idx,
 |  | const ms_taxonomyrules * | rules
 | ) |  |

Update or create an existing the Taxonomy_XXX section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getTaxonomyRules()
Parameters:
idx | is the ID of the taxonomy rules section. There are multiple taxonomy rules sections in mascot.dat: Taxonomy_1, Taxonomy_2 etc. The value should be in the range 1 to getMaxTaxonomyRules().
rules | is a pointer to the new ms_taxonomyrules. In order to erase an existing section submit NULL as this parameter.
void setUniGeneOptions ( const ms_unigeneoptions * uoptions )

Update the content of the UniGene section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getUniGeneOptions()
Parameters:
uoptions is a pointer to the new ms_unigeneoptions.
void setWWWOptions ( const ms_wwwoptions * www )

Update the content of the WWW section.

The ms_datfile object is updated with a copy of the data passed.

See also:
getWWWOptions()
Parameters:
www is a pointer to the new ms_wwwoptions.
bool updateForInstaller | ( | ms_errs & | log,
 |  | const char * | not_mascot_dat_path,
 |  | const char * | mascot_dat_path,
 |  | const char * | licenseFilePath,
 |  | const char * | pathToMascot,
 |  | const char * | mascotURL,
 |  | const char * | sequenceDatabasePath,
 |  | const bool | clusterEnable,
 |  | const WST | wst,
 |  | const char * | NTGuestName,
 |  | const char * | NTAdminName,
 |  | const unsigned int | flags
 | ) |  |

Creates and updates mascot.dat for the Mascot Installation programs.

To use, first create a new ms_datfile using the default constructor. Then, create an ms_errs object and call ms_errs::setLoggingLevel() to set the severity level to ms_errs::sev_info. After calling updateForInstaller(), call isValid() on the passed ms_errs object, to check for any errors. If there are no errors, then call setFileName() followed by save_file(). Finally, call the isValid() function (on this object) to check that the file has been saved without error.

For a new installation, the passed mascot_dat_path must be null/empty.

The following actions are performed for both installation and upgrades:

  • The not.mascot.dat file is read.
  • In the options section, NTIUserGroup is changed to the passed value. If null or an empty string is passed, then the setting is not changed.
  • In the options section, NTIMonitorGroup is changed to the passed value. If null or an empty string is passed, then the setting is not changed.
  • In the databases section, ###ROOT###/sequence is replaced with the value passed in sequenceDatabasePath.
  • Other occurrences of ###ROOT### are replaced with pathToMascot.
  • ###HOSTNAME### is replaced with the computer hostname.
  • ###URL### is replaced with mascotURL.

The following actions are performed for a new install:

  • The contents of not.mascot.dat are copied to this instance of ms_datfile.
  • The number of threads for each database is replaced with the value: ms_databaseoptions::NUM_THREADS_AUTO_DETECT.

The following actions are performed for an upgrade:

  • The contents of mascot.dat are loaded into this instance of ms_datfile.

The following actions are performed depending on the passed flags:

  • ms_datfile::IFLG_UPDATETAXONOMY: Any missing taxonomy sections are added.
  • ms_datfile::IFLG_UPDATEPARSERULES: Any missing parse rules are added. For example, if there is no RULE_32 in mascot.dat, but there is a RULE_32 in not.mascot.dat, then RULE_32 is added. From version 2.5.1 onwards, this flag is ignored if the file has been editedByDatabaseManager() because database manager will add extra parse rules when required and it gets upset if the parse rules in the mascot.dat file aren't the same as those in its 'source' xml file.
  • ms_datfile::IFLG_UPDATECLUSTER: The clusterEnable flag is used to enable or disable cluster mode.
    • If there are no SubClusterSet lines, then a single SubClusterSet 0 line is added with the number of processors set to: ms_clusterparams::NUM_PROCESSORS_AUTO_DETECT.
    • If the DefaultNodeOS value is not correct, then this is set correctly and the DefaultNodeHomeDir is set to either "C:/MascotNode" or "/usr/local/mascotnode"
    • For Windows, if DefaultNodeHomeDirFromMaster is commented, then it is uncommented.
    • For Windows, if MascotNodeScript is uncommented, then it is commented.
    • For Linux, if DefaultNodeHomeDirFromMaster is uncommented, then it is commented.
    • For Linux, if MascotNodeScript is commented, then it is uncommented.
  • ms_datfile::IFLG_UPDATESWISSPROT: The following actions are only performed if the return value of checkSeqDBInstallRequest() has the ms_datfile::SEQDB_INSTALL_MUST_UPDATE_CFG bits set.
    • The three parse rules required for SwissProt are added if necessary. This may require that new rules are added with different numbers.
    • If there is no entry for the SwissProt database, then add the relevant lines from not.mascot.dat, changing ###ROOT###/sequence with the value passed in sequenceDatabasePath, and possibly changing the rule numbers as appropriate.
    • The wildcard part of the path is set to SwissProt_*.fasta.
  • ms_datfile::IFLG_UPDATEPRIDECONTAMINANTS: The following actions are only performed if the return value of checkSeqDBInstallRequest() has the ms_datfile::SEQDB_INSTALL_MUST_UPDATE_CFG bits set.
    • The three parse rules required for PRIDE_Contaminants are added if necessary. This may require that new rules are added with different numbers.
    • If there is no entry for the PRIDE_Contaminants database, then add the relevant lines from not.mascot.dat, changing ###ROOT###/sequence with the value passed in sequenceDatabasePath, and possibly changing the rule numbers as appropriate.
    • The wildcard part of the path is set to PRIDE_Contaminants_*.msp.
  • ms_datfile::IFLG_UPDATEESTTAX: If the EST_human database has taxonomy rule 0, and a Taxonomy_10 section was added, then change the rule to Taxonomy_10.
  • ms_datfile::IFLG_UPDATEESTTAX: If the EST_mouse database has taxonomy rule 0, and a Taxonomy_11 section was added, then change the rule to Taxonomy_11.
  • ms_datfile::IFLG_ADDMISSINGOPTIONS: Add entries missing in the options section from the default values in not.mascot.dat.
  • ms_datfile::IFLG_ADDMISSINGOPTIONS: If an upgrade, the config/db_manager/global.conf file is read if it exists, and proxy settings copied over. If mascot.dat already contains proxy settings, the global.conf file is ignored.
  • ms_datfile::IFLG_ADDREPORTAUTO: If there is no AUTO in ReportNumberChoices, then this is added.
  • ms_datfile::IFLG_ADDPERCOLATOROPT: If there is no -U in PercolatorExeFlags, then this is added.
  • ms_datfile::IFLG_UPDATENCBIHTTPS:
    • If the TaxBrowserUrl setting in Options starts with http://www.ncbi.nlm.nih.gov/ then change this to https://...
    • In the www section, look for any cases where ms_wwwentry::getHostName() contains "eutils.ncbi.nlm". If ms_wwwentry::getPortNumber() returns 80 then call ms_wwwentry::setPortNumber(443). However, this will only be done if the file has not been editedByDatabaseManager()
  • ms_datfile::IFLG_UPDATEMSPEPSEARCHOPTS:
    • If LibrarySearch contains " m G " (the 2.6 option) then replace this with " m a P ". See ms_mascotoptions::getPepSearchTool for further details.
    • If LibrarySearch contains " /HITS 100 " (the 2.6 option) then replace this with " /HITS 10 ".

Possible error messages:

  • Any read/parse errors for mascot.dat or not.mascot.dat will be reported.
  • ms_errs::ERR_MSP_INST_FAILADDPARSERULE will be reported if all 255 available parse rules have been used, and the rules required for SwissProt cannot be added.

All other issues are treated as warnings.

Parameters:
log | is used to collect errors and information messages.
not_mascot_dat_path | The file must exist or an error will be reported.
mascot_dat_path | may be null (or an empty string) for a clean installation where there is no existing mascot.dat If specified, the file must exist.
licenseFilePath | not used in Parser version 2.4.1 and later. The number of threads to use for each database is set to an 'auto' value in Mascot 2.4 and later.
pathToMascot | is used for when mascot_dat_path is null, and is used to replace ###ROOT###. Any backslashes will be replaced with forward slashes. The caller is responsible for ensuring that the string doesn't contain any spaces.
mascotURL | is used to replace ###URL###. It doesn't matter if the URL ends with a '/' or not. This parameter is also used to explicitly update ResultsFullURL to mascotURL/cgi/master_results.pl unless a null pointer or an empty string is passed. It is not used to update ResultsFullURL_2 because this may have been manually set to master_results.pl because a user does not like the family reports.
sequenceDatabasePath | is used to replace ###ROOT###/sequence. Any backslashes will be replaced with forward slashes. The caller is responsible for ensuring that the string doesn't contain any spaces.
clusterEnable | should be set to true to enable cluster mode. If IFLG_UPDATECLUSTER is not set, this flag is ignored.
wst | Should be set to WST_APACHE or WST_IIS.
NTGuestName | Should be set to the guest group name (Windows only). Should only be passed for a new installation.
NTAdminName | Should be set to Administrators group name (Windows only). Should only be passed for a new installation.
flags | Specifies which actions to take. See ms_datfile::INST_FLAGS for further information. Most common values to use are ms_datfile::IFLG_DEFAULTNEWINSTALL or ms_datfile::IFLG_DEFAULTUPGRADE.
Returns:
false if the hostname is missing, or if not.mascot.dat or the result file is not valid, true otherwise
The documentation for this class was generated from the following files:
  • ms_datfile.hpp
  • ms_datfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_dbprocessors
Public Member Functions

ms_dbprocessors Class Reference
[Mascot configuration files module]

Represent a single dabatase entry in the Processors section. More...

#include <ms_processoroptions.hpp>

List of all members.

Public Member Functions

ms_dbprocessors ()
Default constructor.
ms_dbprocessors (const ms_dbprocessors &src)
Copying constructor.
~ms_dbprocessors ()
Destructor.
void | appendThreadProcessorID (const int proccessorID)
Adds a new thread with a processor ID to the list.
void | clearThreads ()
Deletes all threads (processor IDs) from the entry.
void | copyFrom (const ms_dbprocessors *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getName () const
Return database name for the entry.
int | getNumberOfThreads () const
Returns a number of values (threads/processor IDs) specified for the database.
int | getThreadProcessorID (const int threadIndex) const
Returns a single processor ID by its index from 0 to (getNumberOfThreads()-1).
ms_dbprocessors & | operator= (const ms_dbprocessors &right)
Assinment operator for C++ client applications.
void | setName (const char *str)
Change the database name of the entry.

Detailed Description

Represent a single dabatase entry in the Processors section.

The documentation for this class was generated from the following files:
  • ms_processoroptions.hpp
  • ms_processoroptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_enzyme
Public Types | Public Member Functions

ms_enzyme Class Reference
[Mascot configuration files module]

Represent a single entry in the enzymes file. More...

#include <ms_enzyme.hpp>

Inheritance diagram for ms_enzyme:
[legend]
Collaboration diagram for ms_enzyme:
[legend]

List of all members.

Public Types

enum cuttertype {
UNDEFINED_CUTTER = 0x0000,
NTERM_CUTTER = 0x0001,
CTERM_CUTTER = 0x0002
}

Definitions for types of cutter.

More...

Public Member Functions

ms_enzyme ()
Default constructor.
ms_enzyme (const ms_enzyme &src)
Copying constructor.
~ms_enzyme ()
Destructor.
void | addCutter (const cuttertype type, const char *cleaveAtStr, const char *restrictStr)
Adds an cutter to the enzyme.
bool | canCleave (const int cutterNum, const char leftResidue, const char rightResidue) const
Returns TRUE if the cutter can cut between the two residues.
void | clearAllCutters ()
Deletes all cutters from the list.
void | copyFrom (const ms_enzyme *right)
Can be used to create a clone.
void | defaultValues ()
Use this member to re-initialise an instance to default values.
std::string | getCleave (const int cutterNum) const
Returns the list of cleavage points for a cutter.
ms_enzyme::cuttertype | getCutterType (const int cutterNum) const
Return the number of cutters that make up the enzyme definition.
int | getNumberOfCutters () const
Returns the number of cutters.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getRestrict (const int cutterNum) const
Returns the list of restriction points for a cutter.
std::string | getTitle () const
Returns a name of the enzyme as appears in the file.
bool | isIndependent () const
Check whether multiple enzymes have been applied independently.
bool | isSemiSpecific () const
Returns TRUE if the enzyme is semi-specific.
bool | isValid () const
Use this method to do basic check on a newly created object.
ms_enzyme & | operator= (const ms_enzyme &right)
C++ style operator= for copying.
void | setIndependent (const bool bit)
Sets the flag that specifies whether multiple enzymes have been applied independently.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSemiSpecific (const bool value)
Sets a new value for the semi specific flag.
void | setTitle (const char *str)
Sets a new title for the enzyme.
bool | verifyEnzyme (ms_errs *errObj) const
Tries to detect any inconsistencies in the enzyme definition.

Detailed Description

Represent a single entry in the enzymes file.

An instance of this class is normally be created by calling matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName() and should then only be used in 'read-only' mode.

As well as 'simple' enzymes, the following cases are supported:

  • semi-specific enzymes (isSemiSpecific())
  • mixed cutters (C-term and N-term)
  • independent cutters (isIndependent())

In case of independent enzymes an instance contains several enzyme definitions that can be iterated through. Otherwise several enzymes with mixed-term cutting are combined together.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_enzymes.cpp, and tools_aahelper.cpp.

Member Enumeration Documentation

enum cuttertype

Definitions for types of cutter.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
UNDEFINED_CUTTER

Undefined - normally due to an invalid parameter when calling a function.

NTERM_CUTTER

N Terminus cutter - cuts before the specified residue(s).

CTERM_CUTTER

C Terminus cutter - cuts after the specified residue(s).

Constructor & Destructor Documentation

ms_enzyme ( )

Default constructor.

An enzyme object should normally be created using matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName().

ms_enzyme ( const ms_enzyme & src )

Copying constructor.

Note:
You cannot use this constructor in programming languages other than C++.
Parameters:
src is the enzyme to make a copy of.
~ms_enzyme ( )

Destructor.

Called automatically from C++ and other languages.

Member Function Documentation

void addCutter | ( | const cuttertype | type,
 |  | const char * | cleaveAtStr,
 |  | const char * | restrictStr
 | ) |  |

Adds an cutter to the enzyme.

This function doesn't perform any checks for valid residues etc, so the verifyEnzyme() function should be called after adding a cutter.

Parameters:
type | is either ms_enzyme::NTERM_CUTTER or ms_enzyme::CTERM_CUTTER.
cleaveAtStr | One or more residue letters which are the potential cleavage points.
restrictStr | Zero or more residue letters that are restriction points.
bool canCleave | ( | const int | cutterNum,
 |  | const char | leftResidue,
 |  | const char | rightResidue
 | ) |  | const

Returns TRUE if the cutter can cut between the two residues.

Gives an answer for the question: Will the enzyme cut at the this position or not?

This function doesn't take into account the semi specific flag.

Parameters:
cutterNum | must be in the range 0..getNumberOfCutters()-1.
leftResidue | amino acid letter representing a residue before the cutting point.
rightResidue | amino acid letter representing a residue after the cutting point.
Returns:
True if the enzyme can cleave at this point.
void clearAllCutters ( )

Deletes all cutters from the list.

Only useful when defining enzymes 'on the fly'.

void copyFrom ( const ms_enzyme * right )

Can be used to create a clone.

Simply create an instance of the class using the default constructor and call this method.

Parameters:
right pointer to another instance to copy from.
void defaultValues ( )

Use this member to re-initialise an instance to default values.

The default values are no cutters, no title, independent = false and semiSpecific = false.

Reimplemented from ms_customproperty.

std::string getCleave ( const int cutterNum ) const

Returns the list of cleavage points for a cutter.

Returns the residues after which an enzyme may cut (for a CTERM_CUTTER) or before which an enzyme may cut (for an NTERM_CUTTER).

See also:
getRestrict()
Parameters:
cutterNum must be in the range 0..getNumberOfCutters()-1.
Returns:
A string of possible cleaveage points.
Examples:
config_enzymes.cpp.
ms_enzyme::cuttertype getCutterType ( const int cutterNum ) const

Return the number of cutters that make up the enzyme definition.

Parameters:
cutterNum must be in the range 0..getNumberOfCutters()-1.
Returns:
ms_enzyme::NTERM_CUTTER, or ms_enzyme::CTERM_CUTTER or ms_enzyme::UNDEFINED_CUTTER if cutterNum is an invalid value.
Examples:
config_enzymes.cpp.
int getNumberOfCutters ( ) const

Returns the number of cutters.

For most enzymes, there will be just one cutter. See isIndependent() for details of multiple cutters in an enzyme.

The limit of 5 cutters per enzyme was raised to a limit of 20 cutters per enzyme in Parser 2.3.01.

Returns:
The number of cutters.
Examples:
config_enzymes.cpp.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
std::string getRestrict ( const int cutterNum ) const

Returns the list of restriction points for a cutter.

Returns the residues after which an enzyme may cut (for a CTERM_CUTTER) or before which an enzyme may cut (for an NTERM_CUTTER).

See also:
getCleave()
Parameters:
cutterNum must be in the range 0..getNumberOfCutters()-1.
Returns:
A string of possible cleaveage points.
Examples:
config_enzymes.cpp.
bool isIndependent ( ) const

Check whether multiple enzymes have been applied independently.

In cases where a single enzyme has been used, the 'independent' flag has no meaning and would normally be set to false. Where multiple enzymes are used on a single sample, these can have been applied in two different ways:

  • Independent = true indicates that the specificities should be treated as if independent digests had been performed on separate sample aliquots and the resulting peptide mixtures combined. Thus, any given peptide will conform to the specificity of one cleavage type only. In the case of CNBr+Trypsin, if Independent was true, you would not find any peptides resulting from cleavage after K or R at one end, and cleavage after M at the other.
  • Independent = false indicates that the specificities are combined, as if the reagents had been applied simultaneously or serially to a single sample aliquot.
See also:
getNumberOfCutters()
Returns:
True if the cutters are applied independently.
bool isSemiSpecific ( ) const

Returns TRUE if the enzyme is semi-specific.

Enzymes don't function perfectly all the time. In most cases where they fail to cut at the specified cleavage point, this only affects one terminus. In Mascot, when a semi specific enzyme is defined, peptides only need to conform to the cleavage specificity at one end.

All enzymes represented by the entry have to be either semi-specific or not.

Returns:
True if the enzyme is semi specific.
bool isValid ( ) const

Use this method to do basic check on a newly created object.

This function calls verifyEnzyme() and is merely provided to give a consistently available function interface to the object. To determine the cause of any inconsistencies or errors, call verifyEnzyme() with an error object.

Returns:
False if there are any errors in the enzyme definition.
ms_enzyme & operator= ( const ms_enzyme & right )

C++ style operator= for copying.

Note:
This operator is only available in C++.

Acts identically to copyFrom().

Parameters:
right is the enzyme definition to copy from.
Returns:
reference to the current object
void setIndependent ( const bool bit )

Sets the flag that specifies whether multiple enzymes have been applied independently.

In cases where a single enzyme has been used, the 'independent' flag has no meaning and would normally be set to false. Where multiple enzymes are used on a single sample, these can have been applied in two different ways:

  • Independent = true indicates that the specificities should be treated as if independent digests had been performed on separate sample aliquots and the resulting peptide mixtures combined. Thus, any given peptide will conform to the specificity of one cleavage type only. In the case of CNBr+Trypsin, if Independent was true, you would not find any peptides resulting from cleavage after K or R at one end, and cleavage after M at the other.
  • Independent = false indicates that the specificities are combined, as if the reagents had been applied simultaneously or serially to a single sample aliquot.
See also:
getNumberOfCutters()
Parameters:
bit is the new value.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setSemiSpecific ( const bool value )

Sets a new value for the semi specific flag.

C++ If you load an enzyme using matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName(), you will not be able to call this member because those functions return a const pointer.

Calling this function will not affect the enzymes file. See ms_enzymefile::updateByNumber() and ms_enzymefile::updateByName().

Enzymes don't function perfectly all the time. In most cases where they fail to cut at the specified cleavage point, this only affects one terminus. In Mascot, when a semi specific enzyme is defined, peptides only need to conform to the cleavage specificity at one end.

All enzymes represented by the entry have to be either semi-specific or not.

Parameters:
value is the new flag to specify if the enzyme is semi specific.
Examples:
config_enzymes.cpp.
void setTitle ( const char * str )

Sets a new title for the enzyme.

C++: If you load an enzyme using matrix_science::ms_enzymefile::getEnzymeByNumber() or matrix_science::ms_enzymefile::getEnzymeByName(), you will not be able to call this member because those functions return a const pointer.

Calling this will not affect the enzymes file. See ms_enzymefile::updateByNumber() and ms_enzymefile::updateByName().

Parameters:
str is the new name for the enzyme.
bool verifyEnzyme ( ms_errs * errObj ) const

Tries to detect any inconsistencies in the enzyme definition.

If errors are found in the enzyme definition, the ms_errs::ERR_MSP_ENZYME_DEFINITION_PROBLEM error will be set, once for each error. Each error message will also include one of following additional text strings.

The reason or method required to 'fix' the error are the following:

  • "empty title" - Need to call setTitle().
  • "no cutting rules" - Need to call addCutter() at least once.
  • "more restrict than cleave rules for C-term" - probably an internal parser error.
  • "more restrict than cleave rules for N-term" - probably an internal parser error.
  • "no cleavage residues for a cutter" - addCutter() has been called with an empty or invalid cleaveAtStr().
  • "too many cleavage residues specified" - all residues have been specified for cleaving at.
  • "too many restricting residues specified" - all residues have been specified as restriction, meaning that the enzyme won't cut anywhere.
  • "cleavage residues must be uppercase A-Z" - a lower case letter or a non alphabetic character has been specified.
  • "restrict residues must be uppercase A-Z" - a lower case letter or a non alphabetic character has been specified.
Parameters:
errObj passed error-object to store error messages.
Returns:
true if the enzyme definition is valid.
The documentation for this class was generated from the following files:
  • ms_enzyme.hpp
  • ms_enzyme.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_enzymefile
Public Member Functions

ms_enzymefile Class Reference
[Mascot configuration files module]

Reads and parses the enzymes file that contains multiple enzyme definitions. More...

#include <ms_enzyme.hpp>

Inheritance diagram for ms_enzymefile:
[legend]
Collaboration diagram for ms_enzymefile:
[legend]

List of all members.

Public Member Functions

ms_enzymefile ()
Default constructor.
ms_enzymefile (const ms_enzymefile &src)
Copying constructor.
ms_enzymefile (const char *filename, const matrix_science::ms_connection_settings *cs=0)
This constructor may be used in order to read the given file immediately on construction.
~ms_enzymefile ()
Destructor.
void | appendEnzyme (const ms_enzyme *item)
Adds a copy of given enzyme at the end of the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearEnzymes ()
Deletes all enzymes from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_enzymefile *right)
Call this member to copy all the information from another instance.
void | defaultValues ()
Use this member to re-initialise the instance.
bool | deleteEnzymeByName (const char *name)
Remove an enzyme from the list in memory.
bool | deleteEnzymeByNumber (const int num)
Remove an enzyme from the list in memory.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_enzyme * | getEnzymeByName (const char *name) const
Finds an enzyme with the specified name (case insensitive).
const ms_enzyme * | getEnzymeByNumber (const int num) const
Returns a pointer to an internally stored enzyme.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name previously set or a default one used to read the file.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfEnzymes () const
Returns a number of enzymes successfully read from the file.
bool | isNoneFound () const
Returns TRUE if an entry with name "NONE" has been found in the file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_enzymefile & | operator= (const ms_enzymefile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads and parses an in-memory null-terminated buffer instead of a disk file.
void | read_file ()
Reads and parses the file.
void | save_file ()
Stores enzyme definitions in a file.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Call this member before reading the file if you want to specify a non-default name.
bool | updateEnzymeByName (const char *name, const ms_enzyme enzyme)
Update the information for a specific enzyme.
bool | updateEnzymeByNumber (const int num, const ms_enzyme enzyme)
Update the information for a specific enzyme.

Detailed Description

Reads and parses the enzymes file that contains multiple enzyme definitions.

Proteolytic enzymes and specific chemical cleavage agents are defined in ../config/enzymes .

Usage is simple:

  • Create an instance of this class.
  • Set a file name if needed, otherwise a default name will be used.
  • Call read_file().
  • Check for errors with isValid().
  • Iterate thourgh enzyme list using getNumberOfEnzymes() and getEnzymeByNumber().
  • Alternatively, one can find an enzyme by name (if known) with getEnzymeByName().
Examples:

config_enzymes.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

ms_enzymefile ( )

Default constructor.

Creates an empty list of enzymes in memory. A file is not created.

ms_enzymefile ( const ms_enzymefile & src )

Copying constructor.

Note:
This constructor can only be used from C++.
Parameters:
src is the ms_enzymefile to make a copy of.
ms_enzymefile | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

This constructor may be used in order to read the given file immediately on construction.

Equivalent to the following call sequence:

  • default contructor ms_enzymefile();
  • setFileName();
  • setConnectionSettings();
  • read_file().
Parameters:
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a an optional pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.
~ms_enzymefile ( )

Destructor.

Called automatically from C++ and other languages.

Member Function Documentation

void appendEnzyme ( const ms_enzyme * item )

Adds a copy of given enzyme at the end of the list.

Parameters:
item is the new item to add to the end of the list of enzymes.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void clearEnzymes ( )

Deletes all enzymes from the list.

Similar to calling defaultValues() except that this function doesn't clear all the comments from the file.

void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_enzymefile * right )

Call this member to copy all the information from another instance.

Simply create an instance of the class using the default constructor and call this method.

Parameters:
right Pointer to another instance to copy from.
void defaultValues ( )

Use this member to re-initialise the instance.

Note that this member doesn't clear the file name; that has to be re-set explicitly if needed.

bool deleteEnzymeByName ( const char * name )

Remove an enzyme from the list in memory.

Parameters:
name must be a valid enzyme name.
Returns:
True if the enyzme name is valid.
Examples:
config_enzymes.cpp.
bool deleteEnzymeByNumber ( const int num )

Remove an enzyme from the list in memory.

Parameters:
num must be in the range 0..getNumberOfEnzymes()-1.
Returns:
True if the enyzme number is valid.
matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns:
The current connection settings.
const ms_enzyme * getEnzymeByName ( const char * name ) const

Finds an enzyme with the specified name (case insensitive).

The special entry "NONE" being found also generates NULL as an outcome. For more information on this see isNoneFound().

Parameters:
name name of the enzyme to look for
Returns:
a pointer to the found one or NULL otherwise. See Maintaining object references: two rules of thumb.
const ms_enzyme * getEnzymeByNumber ( const int num ) const

Returns a pointer to an internally stored enzyme.

Parameters:
num Must be in the range 0..getNumberOfEnzymes()-1.
Returns:
A pointer to an ms_enzyme object. If num is out of range, then the return value is a null object.
Examples:
config_enzymes.cpp.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns a file name previously set or a default one used to read the file.

Returns:
The filename (if any) as set in a previous call to setFileName() or as specified in the constructor.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getNumberOfEnzymes ( ) const

Returns a number of enzymes successfully read from the file.

Returns:
The current number of enzymes in the list.
Examples:
config_enzymes.cpp.
bool isNoneFound ( ) const

Returns TRUE if an entry with name "NONE" has been found in the file.

The standard enzymes files has an entry "None" which is used to specify a no enzyme search. This special entry never represents a real enzyme and therefore all properties of the entry are meaningless. Therefore, calling getEnzymeByName() with "None" as a parameter will always return NULL.

Returns:
True if there is an entry for "None" in the file.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_enzymefile & operator= ( const ms_enzymefile & right )

C++ style assignment operator.

Note:
This operator can only be used in C++.

Acts identically to copyFrom() member.

Parameters:
right is the enzymefile definition to copy from.
Returns:
reference to the current object
void read_buffer ( const char * buffer )

Reads and parses an in-memory null-terminated buffer instead of a disk file.

Check for possible errors after calling this functions with isValid(). In case of any errors it keeps all of the already read entries that can still be accessed in a usual way.

Parameters:
buffer a null-terminated string with enzymes definitions.
void read_file ( )

Reads and parses the file.

Check for possible errors after calling this functions with isValid(). In case of any errors it keeps all of the already read entries that can still be accessed in a usual way.

void save_file ( )

Stores enzyme definitions in a file.

Don't forget to check for errors after this function call. The filename used to save the file is specified by setFileName().

Examples:
config_enzymes.cpp.
void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setFileName ( const char * filename )

Call this member before reading the file if you want to specify a non-default name.

Parameters:
filename is the name of the file to be saved using save_file() or read using read_file().
Examples:
config_enzymes.cpp.
bool updateEnzymeByName | ( | const char * | name,
 |  | const ms_enzyme | enzyme
 | ) |  |

Update the information for a specific enzyme.

Parameters:
name | title of the enzyme to retrieve.
enzyme | is a pointer to the new definition of the enzyme.
Returns:
true if the name can be found, false otherwise
bool updateEnzymeByNumber | ( | const int | num,
 |  | const ms_enzyme | enzyme
 | ) |  |

Update the information for a specific enzyme.

Parameters:
num | must be in the range 0..getNumberOfEnzymes()-1.
enzyme | Is a pointer to the new definition of the enzyme.
Returns:
true if num param is in range, false otherwise
Examples:
config_enzymes.cpp.
The documentation for this class was generated from the following files:
  • ms_enzyme.hpp
  • ms_enzyme.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_fragmentationrules
Public Types | Public Member Functions | Static Public Member Functions

ms_fragmentationrules Class Reference
[Mascot configuration files module]

This class encapsulates a single entry (an instrument) from a fragmentation_rules file. More...

#include <ms_fragmentationrules.hpp>

Inheritance diagram for ms_fragmentationrules:
[legend]
Collaboration diagram for ms_fragmentationrules:
[legend]

List of all members.

Public Types

enum FRAG_SERIES_TYPE {
FRAG_IMMONIUM = 4,
FRAG_A_SERIES = 5,
FRAG_A_MINUS_NH3 = 6,
FRAG_A_MINUS_H2O = 7,
FRAG_B_SERIES = 8,
FRAG_B_MINUS_NH3 = 9,
FRAG_B_MINUS_H2O = 10,
FRAG_C_SERIES = 11,
FRAG_X_SERIES = 12,
FRAG_Y_SERIES = 13,
FRAG_Y_MINUS_NH3 = 14,
FRAG_Y_MINUS_H2O = 15,
FRAG_Z_SERIES = 16,
FRAG_INTERNAL_YB = 17,
FRAG_INTERNAL_YA = 18,
FRAG_Z_PLUS_1 = 21,
FRAG_D_SERIES = 22,
FRAG_V_SERIES = 23,
FRAG_W_SERIES = 24,
FRAG_Z_PLUS_2 = 25
}

Definitions for ID-constants for series used.

More...

Public Member Functions

ms_fragmentationrules ()
Default constructor is used to create an empty object.
ms_fragmentationrules (const ms_fragmentationrules &src)
Copying constructor.
~ms_fragmentationrules ()
Destructor.
bool | anyNLseriesUsed (const int series) const
Will return true if any 'neutral loss' series is specified for this series.
void | clearSeries ()
Deletes all series usage information.
void | copyFrom (const ms_fragmentationrules *right)
Copies all information from another instance of the class.
void | defaultValues ()
Initialises the instance with default values.
double | getMaxInternalMass () const
Returns the maximum mass to be considered for internal fragments.
double | getMinInternalMass () const
Returns the minimum mass to be considered for internal fragments.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getTitle () const
Returns the title of the instrument.
bool | isCharged2Plus () const
Returns true if the 'doubly charged 2+' fragmentation rule is specified.
bool | isCharged3Plus () const
Returns true if the 'doubly charged 3+' fragmentation rule is specified.
bool | isSeriesUsed (const int series) const
Returns true if a given series is specified for the instrument.
bool | isSinglyCharged () const
Returns true if the 'singly charged' fragmentation rule is specified.
bool | isValid () const
Use this method to do a basic check on a newly created object.
ms_fragmentationrules & | operator= (const ms_fragmentationrules &right)
Assignment operator.
void | setCharged2Plus (const bool value)
Change the availability the of 'doubly charged 2+' fragmentation rule.
void | setCharged3Plus (const bool value)
Change the availability the of 'doubly charged 3+' fragmentation rule.
void | setMaxInternalMass (const double mass)
Sets the maximum mass to be considered for internal fragments.
void | setMinInternalMass (const double mass)
Set the minimum mass to be considered for internal fragments.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSeriesUsed (const int series, const bool val)
Sets availability on a given series.
void | setSinglyCharged (const bool value)
Change the availability of the 'singly charged' fragmentation rule.
void | setTitle (const char *title)
Assigns a new title to the rule.
bool | verifyRule (ms_errs *err_, const bool tryToFix)
Tries to detect any inconsistencies in the instrument definition.

Static Public Member Functions

static int | getFirstSerie ()
The lowest series number that can be used.
static int | getFirstSeries ()
The lowest series number that can be used.
static int | getLastSerie ()
The highest series number that can be used.
static int | getLastSeries ()
The highest series number that can be used.
static std::string | getSeriesDescription (const int series)
Returns a description string for a given series.
static std::string | getSeriesName (const int series)
Returns a short series name.
static int | getTotalSeriesOutput ()
Returns the length of the series string output in a Mascot results file.
static bool | isBackboneSeries (const int series)
Returns true if the series is a 'backbone' fragment.
static bool | isNeutralLossSeries (const int series)
Returns true if the series is a 'neutral loss' series.

Detailed Description

This class encapsulates a single entry (an instrument) from a fragmentation_rules file.

Objects of this class are normally created by loading a file using the ms_fragrulesfile class.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_fragrules.cpp.

Member Enumeration Documentation

enum FRAG_SERIES_TYPE

Definitions for ID-constants for series used.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See http://www.matrixscience.com/help/fragmentation_help.html for details of ions types.

Enumerator:
FRAG_IMMONIUM

Immonium ions.

FRAG_A_SERIES

A series ions.

FRAG_A_MINUS_NH3

Referred to as a* in Mascot reports.

FRAG_A_MINUS_H2O

Referred to as ao in Mascot reports.

FRAG_B_SERIES

B series ions.

FRAG_B_MINUS_NH3

Referred to as b* in Mascot reports.

FRAG_B_MINUS_H2O

Referred to as bo in Mascot reports.

FRAG_C_SERIES

C series ions.

FRAG_X_SERIES

X series ions.

FRAG_Y_SERIES

Y series ions.

FRAG_Y_MINUS_NH3

Referred to as y* in Mascot reports.

FRAG_Y_MINUS_H2O

Referred to as yo in Mascot reports.

FRAG_Z_SERIES

Z series ions.

FRAG_INTERNAL_YB

Internal series, caused by double backbone cleavage. Combination of b type and y type cleavage.

FRAG_INTERNAL_YA

Internal series, caused by double backbone cleavage. Combination of a type and y type cleavage.

FRAG_Z_PLUS_1

Z+1 series.

FRAG_D_SERIES

D Satellite Ions. A series partial side chain. Collision induced dissociation of ions at keV energies.

FRAG_V_SERIES

V Satellite Ions. Y series partial side chain. Collision induced dissociation of ions at keV energies.

FRAG_W_SERIES

W Satellite Ions. Z series partial side chain. Collision induced dissociation of ions at keV energies.

FRAG_Z_PLUS_2

Z+2 series.

Constructor & Destructor Documentation

ms_fragmentationrules ( )

Default constructor is used to create an empty object.

Use member functions to fill up the list of allowed series.

~ms_fragmentationrules ( )

Destructor.

Frees all memory allocated for the object.

Member Function Documentation

bool anyNLseriesUsed ( const int series ) const

Will return true if any 'neutral loss' series is specified for this series.

Parameters:
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns:
true if the passed series
  • is A and A with loss of water or NH3 is also specified, or
  • is B and B with loss of water or NH3 is also specified, or
  • is Y and Y with loss of water or NH3 is also specified.
Otherwise returns false.
void clearSeries ( )

Deletes all series usage information.

All series are set to be unused, but the instrument title is retained.

void copyFrom ( const ms_fragmentationrules * right )

Copies all information from another instance of the class.

Parameters:
right is the fragmentation rules to copy from.
void defaultValues ( )

Initialises the instance with default values.

Sets all series to be unused.

Reimplemented from ms_customproperty.

int getFirstSerie ( ) [static]

The lowest series number that can be used.

Deprecated:
Use getFirstSeries().
Returns:
The first usable series number. Series numbers '1', '2' and '3' relate to allowed charge states rather than real series.
int getFirstSeries ( ) [static]

The lowest series number that can be used.

See also:
ms_fragmentationrules::getLastSeries()
Returns:
The first usable series number. Series numbers '1', '2' and '3' relate to allowed charge states rather than real series.
int getLastSerie ( ) [static]

The highest series number that can be used.

Deprecated:
Use getLastSeries().
Returns:
The last usable series number. More series may be added in later versions of Mascot, and using this function may allow code to be made 'future proof'.
int getLastSeries ( ) [static]

The highest series number that can be used.

See also:
ms_fragmentationrules::getFirstSeries()
Returns:
The last usable series number. More series may be added in later versions of Mascot, and using this function may allow code to be made 'future proof'.
double getMaxInternalMass ( ) const

Returns the maximum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Returns:
The maximum internal mass to be considered for this instrument.
double getMinInternalMass ( ) const

Returns the minimum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Returns:
The minimum internal mass to be considered for this instrument.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
std::string getSeriesDescription ( const int series ) [static]

Returns a description string for a given series.

Parameters:
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns:
series description
std::string getSeriesName ( const int series ) [static]

Returns a short series name.

Parameters:
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns:
series name
std::string getTitle ( ) const

Returns the title of the instrument.

This is obtained from the

title:

line in the fragmentation_rules file.

Returns:
The title.
int getTotalSeriesOutput ( ) [static]

Returns the length of the series string output in a Mascot results file.

See also:
ms_peptide::getVarModsStr()
Returns:
the number of series that output for each peptide in the Mascot results file.
bool isBackboneSeries ( const int series ) [static]

Returns true if the series is a 'backbone' fragment.

Parameters:
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns:
true if the series is A, B, Y, C, X, Z, Z+1, Z+2 or loss of water or NH3 from A,B or Y.
bool isCharged2Plus ( ) const

Returns true if the 'doubly charged 2+' fragmentation rule is specified.

Returns:
true if rule 2, doubly charged if precursor 2+ or higher is specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.
bool isCharged3Plus ( ) const

Returns true if the 'doubly charged 3+' fragmentation rule is specified.

Returns:
true if rule 3, doubly charged if precursor 3+ or higher is specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.
bool isNeutralLossSeries ( const int series ) [static]

Returns true if the series is a 'neutral loss' series.

Parameters:
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns:
true if the series is loss of water or NH3 from A,B or Y.
bool isSeriesUsed ( const int series ) const

Returns true if a given series is specified for the instrument.

Currently supported series are (FRAG_SERIES_TYPE):

  • 4 - immonium ions
  • 5 - 'a' ions
  • 6 - 'a-NH3' or 'a*' ions
  • 7 - 'a-H2O' or 'a0' ions
  • 8 - 'b' ions
  • 9 - 'b-NH3' or 'b*' ions
  • 10 - 'b-H2O' or 'b0' ions
  • 11 - 'c' ions
  • 12 - 'x' ions
  • 13 - 'y' ions
  • 14 - 'y-NH3' or 'y*' ions
  • 15 - 'y-H2O' or 'y0' ions
  • 16 - 'z' ions
  • 17 - internal fragments 'yb'
  • 18 - internal fragments 'ya'
  • 21 - 'z+1' ions
  • 22 - high-energy 'd' ions
  • 23 - high-energy 'v' ions
  • 24 - high-energy 'w' ions
  • 25 - 'z+2' ions

In addition, two more rules may be specified:

  • 19 - 'y' or 'y++' series presense must be significant
  • 20 - 'y' or 'y++' must be highest scoring series
Parameters:
series must be a number between getFirstSeries() and getLastSeries() inclusive.
Returns:
true if the series if used, false otherwise
bool isSinglyCharged ( ) const

Returns true if the 'singly charged' fragmentation rule is specified.

Returns:
true if rule 1 singly charged ions is specified and therefore 1+ ions, for the specified series are to be considered.
bool isValid ( ) const

Use this method to do a basic check on a newly created object.

The verifyRule() function will generally be more useful.

Returns:
true if the series and masses are consistent, false otherwise
ms_fragmentationrules & operator= ( const ms_fragmentationrules & right )

Assignment operator.

Parameters:
right is the fragmentation rules to copy from.
Returns:
reference to the current object
void setCharged2Plus ( const bool value )

Change the availability the of 'doubly charged 2+' fragmentation rule.

Parameters:
value should be set to true if rule 2, doubly charged if precursor 2+ or higher is to be specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.
void setCharged3Plus ( const bool value )

Change the availability the of 'doubly charged 3+' fragmentation rule.

Parameters:
value should be set to true if rule 3, doubly charged if precursor 3+ or higher is to be specified and therefore 2+ ions, for the specified series (not internal or immonium) are to be considered.
void setMaxInternalMass ( const double mass )

Sets the maximum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Parameters:
mass The new maximum internal mass to be considered for this instrument.
void setMinInternalMass ( const double mass )

Set the minimum mass to be considered for internal fragments.

Introduced in Mascot 2.2, the values for minimum and maximum internal masses are specified in the fragmentation_rules file as

   minInternalMass 0.0
   maxInternalMass 700.0

These are the masses used for the FRAG_INTERNAL_YB and FRAG_INTERNAL_YA series.

Parameters:
mass The new minimum internal mass to be considered for this instrument.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setSeriesUsed | ( | const int | series,
 |  | const bool | val
 | ) |  |

Sets availability on a given series.

See isSeriesUsed() for a list of available series.

Parameters:
series | must be a number between getFirstSeries() and getLastSeries() inclusive.
val | is a boolean value to specify whether the series should be considered.
Examples:
config_fragrules.cpp.
void setSinglyCharged ( const bool value )

Change the availability of the 'singly charged' fragmentation rule.

Parameters:
value should be set to true if rule 1 (singly charged ions) are to be considered.
void setTitle ( const char * title )

Assigns a new title to the rule.

Parameters:
title is the new title.
bool verifyRule | ( | ms_errs * | errObj,
 |  | const bool | tryToFix
 | ) |  |

Tries to detect any inconsistencies in the instrument definition.

This method tries to detect any inconsistencies and to fix some of them.

When tryToFix is set to true will force the method to try and fix the instrument definition and return a success code. In this case, error descriptions for the problems detected (and fixed) will be accumulated in errObj.

For example, if the FRAG_A_MINUS_NH3 series is specified, and FRAG_A_SERIES isn't specified, then, if tryToFix is specified, FRAG_A_SERIES will be added, and the ms_errs::ERR_MSP_FRAGMENTATION_RULES error will be added to the errObj list.

Parameters:
errObj | error-object to store error messages.
tryToFix | if true, try to fix any problems encountered.
Returns:
always true, errors are set if something is wrong
The documentation for this class was generated from the following files:
  • ms_fragmentationrules.hpp
  • ms_fragmentationrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_fragrulesfile
Public Member Functions

ms_fragrulesfile Class Reference
[Mascot configuration files module]

This class encapsulates a complete fragmentation_rules file. More...

#include <ms_fragmentationrules.hpp>

Inheritance diagram for ms_fragrulesfile:
[legend]
Collaboration diagram for ms_fragrulesfile:
[legend]

List of all members.

Public Member Functions

ms_fragrulesfile ()
Default constructor.
ms_fragrulesfile (const char *filename, const matrix_science::ms_connection_settings *cs=0)
Immediate-action constructor that reads the given file.
ms_fragrulesfile (const ms_fragrulesfile &src)
Copying constructor.
~ms_fragrulesfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendInstrument (const ms_fragmentationrules *item)
Adds a new instrument definition at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearInstruments ()
Deletes all instruments definitions.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_fragrulesfile *right)
Can be used to make a copy of another instance.
void | defaultValues ()
Re-initialises the list of fragmentation rules, so the instance can be re-used.
bool | deleteInstrumentByName (const char *name)
Remove an instrument from the list in memory.
bool | deleteInstrumentByNumber (const int num)
Remove an instrument from the list in memory.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Get the currently used file name.
const ms_fragmentationrules * | getInstrumentByName (const char *name) const
Returns a configuration for an instrument by name.
const ms_fragmentationrules * | getInstrumentByNumber (const int instrumentNum) const
Returns a configuration for an instrument by its number from 0 to (getNumberOfInstruments()-1).
std::string | getInstrumentName (const int instrumentNum) const
Returns an instrument name by its number from 0 to (getNumberOfInstruments()-1).
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfInstruments () const
Returns a number of instruments configured.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_fragrulesfile & | operator= (const ms_fragrulesfile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads and parses the string, populates the list of instruments.
void | read_file ()
Reads and parses the file, populates the list of instruments.
void | save_file ()
Stores instrument definitions in a file.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Use this member to set a non-default file name.
bool | updateInstrumentByName (const char *name, const ms_fragmentationrules item)
Update the information for a specific instrument.
bool | updateInstrumentByNumber (const int num, const ms_fragmentationrules item)
Update the information for a specific instrument.

Detailed Description

This class encapsulates a complete fragmentation_rules file.

Usage of this class is simple. Just create an instance, set an explicit file name if necessary, call read_file()-member, check for errors (isValid()) and retrieve an instrument by its name or number.

Examples:

config_fragrules.cpp.

Constructor & Destructor Documentation

ms_fragrulesfile ( )

Default constructor.

Not generally useful. The filename is set to ../config/fragmentation_rules, but the file is not read.

ms_fragrulesfile | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Immediate-action constructor that reads the given file.

Parameters:
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.
~ms_fragrulesfile ( )

Destructor.

Frees all memory allocated for the object.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void appendInstrument ( const ms_fragmentationrules * item )

Adds a new instrument definition at the end of the list.

Typically, the file would be saved after doing this.

Parameters:
item is the the new instrument definition to be added.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void clearInstruments ( )

Deletes all instruments definitions.

All instruments are removed.

void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_fragrulesfile * right )

Can be used to make a copy of another instance.

Parameters:
right is the fragmentation rules file to copy values from.
void defaultValues ( )

Re-initialises the list of fragmentation rules, so the instance can be re-used.

Clears the list of instruments and comments. Clears all errors.

bool deleteInstrumentByName ( const char * name )

Remove an instrument from the list in memory.

Parameters:
name must be a valid instrument name.
Returns:
True if the instrument name is valid and the instrument is removed.
Examples:
config_fragrules.cpp.
bool deleteInstrumentByNumber ( const int num )

Remove an instrument from the list in memory.

Parameters:
num must be in the range 0..getNumberOfInstruments()-1.
Returns:
True if the instrument number is valid.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Get the currently used file name.

Returns:
The new file name or URL.
const ms_fragmentationrules * getInstrumentByName ( const char * name ) const

Returns a configuration for an instrument by name.

Parameters:
name is the name of the instrument as specified in the title line in the fragmentation_rules file.
Returns:
The rules specified for the given instrument.
Examples:
config_fragrules.cpp.
const ms_fragmentationrules * getInstrumentByNumber ( const int instrumentNum ) const

Returns a configuration for an instrument by its number from 0 to (getNumberOfInstruments()-1).

Parameters:
instrumentNum is the number of the instrument and should be between zero and getNumberOfInstruments()-1.
Returns:
The rules specified for the given instrument.
std::string getInstrumentName ( const int instrumentNum ) const

Returns an instrument name by its number from 0 to (getNumberOfInstruments()-1).

Parameters:
instrumentNum is the number of the instrument and should be between zero and getNumberOfInstruments()-1.
Returns:
The name of the instrument from the title: line in the fragmentation_rules file.
Examples:
config_fragrules.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getNumberOfInstruments ( ) const

Returns a number of instruments configured.

Returns:
the number of instrument types with assigned settings.
Examples:
config_fragrules.cpp.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_fragrulesfile & operator= ( const ms_fragrulesfile & right )

C++ style assignment operator.

Parameters:
right is the fragmentation rules file to copy values from.
Returns:
reference to the current object
void read_buffer ( const char * buffer )

Reads and parses the string, populates the list of instruments.

Check for possible errors with isValid()-function and retrieve errors descriptions (if any) after calling this function. If an error occurs during reading the buffer it will still contain some of the instruments that have been successfully read from the file.

Parameters:
buffer buffer to read
void read_file ( )

Reads and parses the file, populates the list of instruments.

Check for possible errors with isValid()-function and retrieve errors descriptions (if any) after calling this function. If an error occurs during reading the file it will still contain some of the instruments that have been successfully read from the file.

void save_file ( )

Stores instrument definitions in a file.

Don't forget to check for errors after this function call.

Examples:
config_fragrules.cpp.
void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setFileName ( const char * filename )

Use this member to set a non-default file name.

Parameters:
filename is the new file name or URL.
Examples:
config_fragrules.cpp.
bool updateInstrumentByName | ( | const char * | name,
 |  | const ms_fragmentationrules | item
 | ) |  |

Update the information for a specific instrument.

Parameters:
name | must be a valid Instrument name.
item | is a pointer to the new definition of the instrument.
Returns:
true if the instrument was found and was updated.
Examples:
config_fragrules.cpp.
bool updateInstrumentByNumber | ( | const int | num,
 |  | const ms_fragmentationrules | item
 | ) |  |

Update the information for a specific instrument.

Parameters:
num | must be in the range 0..getNumberOfInstruments()-1.
item | is a pointer to the new definition of the instrument definition.
Returns:
true if the instrument was found and was updated.
The documentation for this class was generated from the following files:
  • ms_fragmentationrules.hpp
  • ms_fragmentationrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_libraryoptions
Public Member Functions

ms_libraryoptions Class Reference
[Mascot configuration files module]

Represents the LibraryOptions section of mascot.dat. More...

#include <ms_libraryoptions.hpp>

Inheritance diagram for ms_libraryoptions:
[legend]
Collaboration diagram for ms_libraryoptions:
[legend]

List of all members.

Public Member Functions

ms_libraryoptions ()
Default constructor.
ms_libraryoptions (const ms_libraryoptions &src)
Copying constructor.
~ms_libraryoptions ()
Destructor.
void | copyFrom (const ms_libraryoptions *right)
Can be used to copy content from another instance.
void | defaultValues ()
Initializes the instance.
void | dropSpectralLibrary (const char *spectralLibraryName)
Remove all references to the specified spectral library.
std::string | getLibraryName (const int num) const
Return the name of the library.
int | getNumberOfLibraries () const
Return the number of libraries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getReferenceFasta (const char *spectralLibraryName) const
Returns the name of the Fasta database used as a reference for accessions for the spectral library.
std::string | getReferenceFastaTaxonomyTitle (const char *spectralLibraryName) const
Returns the title of the taxonomy to use for the reference database.
double | getToleranceInDa (const char *spectralLibraryName) const
Returns the tolerance of the data in spectral library.
double | getToleranceInPPM (const char *spectralLibraryName) const
Returns the tolerance of the data in spectral library.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_libraryoptions & | operator= (const ms_libraryoptions &right)
Assignment operator for C++ client applications.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setReferenceFasta (const char *spectralLibraryName, const char *fastaDatabaseName, const char *taxonomyTitle)
Sets the name of the Fasta database used as a reference for accessions for the spectral library.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
void | setToleranceInDa (const char *spectralLibraryName, double tolerance)
Sets the tolerance of the data in spectral library.
void | setToleranceInPPM (const char *spectralLibraryName, double tolerance)
Sets the tolerance of the data in spectral library.

Detailed Description

Represents the LibraryOptions section of mascot.dat.

See : ms_datfile::getLibraryOptions and ms_datfile::setLibraryOptions

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Constructor & Destructor Documentation

ms_libraryoptions ( )

Default constructor.

Create an object with no options

ms_libraryoptions ( const ms_libraryoptions & src )

Copying constructor.

C++ only. Use copyFrom from other languages.

Parameters:
src is the source options to copy into the new object
~ms_libraryoptions ( )

Destructor.

Frees any memory

Member Function Documentation

void copyFrom ( const ms_libraryoptions * right )

Can be used to copy content from another instance.

Copy all the parameter for the libraries from right into the object

Parameters:
right is the source library options
void defaultValues ( )

Initializes the instance.

Remove details for all the libraries

Reimplemented from ms_customproperty.

void dropSpectralLibrary ( const char * spectralLibraryName )

Remove all references to the specified spectral library.

Parameters:
spectralLibraryName is the (short) name of the library
std::string getLibraryName ( const int num ) const

Return the name of the library.

Parameters:
num must be in the range 0 to getNumberOfLibraries() -1
Returns:
the name of the library which can be used in other functions such as getReferenceFasta()
int getNumberOfLibraries ( ) const

Return the number of libraries.

Returns:
The number of libraries with parameters in the section
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
std::string getReferenceFasta ( const char * spectralLibraryName ) const

Returns the name of the Fasta database used as a reference for accessions for the spectral library.

A Spectral library is essentially a peptide library and will often not contain meaningful accessions. To get useful protein grouping in Mascot reports, it is recommended that users specify a 'reference' database. When a reference database is used, Mascot tries to find the peptide sequence from the library in the reference fasta, and if it is found then it adds the accession for that protein sequence to the search results.

See also:
getReferenceFastaTaxonomyTitle()
Parameters:
spectralLibraryName is the (short) name of the library
Returns:
the (short) name of the reference fasta
std::string getReferenceFastaTaxonomyTitle ( const char * spectralLibraryName ) const

Returns the title of the taxonomy to use for the reference database.

The reference database may contain protein accessions from multiple taxa. If a suitable taxonomy index is configured, you can define the taxon to use for reference accessions. The returned value is the title string of an entry in the taxonomy configuration file (typically mascot/config/taxonomy).

See also:
getReferenceFasta()
Parameters:
spectralLibraryName is the (short) name of the library
Returns:
the title of the taxon, or the empty string if not set.
double getToleranceInDa ( const char * spectralLibraryName ) const

Returns the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, getToleranceInPPM(), setToleranceInPPM() and setToleranceInDa()

If spectralLibraryName does not exist, returns the default (0.6 Da)

Parameters:
spectralLibraryName is the (short) name of the library
Returns:
the tolerance of the data in the library
double getToleranceInPPM ( const char * spectralLibraryName ) const

Returns the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, setToleranceInPPM(), getToleranceInDa() and setToleranceInDa()

If spectralLibraryName does not exist, returns the default (500ppm)

Parameters:
spectralLibraryName is the (short) name of the library
Returns:
the tolerance of the data in the library
bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the LibraryOptions section is unavailable until it has been set to a different state.

The section does not have to exist in the mascot.dat file

Returns:
true if the section exists
ms_libraryoptions & operator= ( const ms_libraryoptions & right )

Assignment operator for C++ client applications.

C++ only

Parameters:
right is the source library options
Returns:
a reference to 'this'
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setReferenceFasta | ( | const char * | spectralLibraryName,
 |  | const char * | fastaDatabaseName,
 |  | const char * | taxonomyTitle
 | ) |  |

Sets the name of the Fasta database used as a reference for accessions for the spectral library.

A Spectral library is essentially a peptide library and will often not contain meaningful accessions. To get useful protein grouping in Mascot reports, it is recommended that users specify a 'reference' database. When a reference database is used, Mascot tries to find the peptide sequence from the library in the reference fasta. If it is found, Mascot adds the accession for that protein sequence to the search results.

The reference database may contain protein accessions from multiple taxa. To restrict accesions to a particular taxon, give its title as the third argument. Titles typically come from the taxonomy configuration file (mascot/config/taxonomy). If left empty, there is no restriction.

Parameters:
spectralLibraryName | is the (short) name of the library
fastaDatabaseName | is the (short) name of the reference database
taxonomyTitle | is the title of the taxon to use, or the empty string.
void setSectionAvailable ( const bool value )

Changes availability of the section, i.e. whether it should be saved in a file.

The section does not have to exist in the mascot.dat file

Parameters:
value set to true if the section exists
void setToleranceInDa | ( | const char * | spectralLibraryName,
 |  | double | tolerance
 | ) |  |

Sets the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, getToleranceInPPM(), setToleranceInPPM() and getToleranceInDa()

If spectralLibraryName does not exist, returns the default (500ppm)

Parameters:
spectralLibraryName | is the (short) name of the library
tolerance | is the new tolerance for spectralLibraryName
void setToleranceInPPM | ( | const char * | spectralLibraryName,
 |  | double | tolerance
 | ) |  |

Sets the tolerance of the data in spectral library.

A spectral library is created using an instrument with a known tolerance and this tolerance is specified by the user when they enable the use of the library in Mascot. When the library is searched, the tolerance used is the square root of the sum of the squares of the data being searched and this value.

The tolerance of the library is specified in Da and ppm since the user may choose either units when they submit a search.

See also, getToleranceInPPM(), getToleranceInDa() and setToleranceInDa()

If spectralLibraryName does not exist, this adds a new entry for the library and sets a default value for other parameters for the library

Parameters:
spectralLibraryName | is the (short) name of the library
tolerance | is the new tolerance for spectralLibraryName
The documentation for this class was generated from the following files:
  • ms_libraryoptions.hpp
  • ms_libraryoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_license
Public Member Functions

ms_license Class Reference
[Mascot configuration files module]

The class provides access license details in read-only mode. More...

#include <ms_license.hpp>

Inheritance diagram for ms_license:
[legend]
Collaboration diagram for ms_license:
[legend]

List of all members.

Public Member Functions

ms_license ()
Default constructor.
ms_license (const ms_license &src)
Copying constructor.
ms_license (const char *filename)
Immediate action constructor.
~ms_license ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_license *right)
Copies all information from another instance.
void | defaultValues ()
Can be called before re-using the instance in order to erase the previous license details.
std::string | getDistributor () const
Returns Mascot distributor information.
std::string | getEndDate () const
Returns a date the license is valid until as a string.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFeatures () const
Returns a string which encodes feature information.
std::string | getFileName () const
Returns a file name being used as a license.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getLicensee () const
Returns a name of the licensee.
std::string | getLicenseString () const
Returns a compound license string that can be used for displaying license information.
std::string | getLicenseVersion () const
Returns a license version as a string.
int | getNumProcessorsLicensed () const
Returns a number of processors licensed.
std::string | getStartDate () const
Returns a date the license is valid from as a string.
bool | isLicenseValid () const
Returns TRUE if the license has been sucessfully read, parsed and checked.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_license & | operator= (const ms_license &right)
Assignment operator for C++ client applications.
void | read_file ()
Main method that reads in the license file.
void | setFileName (const char *filename)
Set the license file name explicitly rather than use a default location.

Detailed Description

The class provides access license details in read-only mode.

This class doesn't contain functions to create a new license or read details of why a license may be invalid.

Please note the ms_license class will only work with license files from Mascot release 2.3 or earlier.

To use this class:

  • Create an instance of this class.
  • Set an explicit file name if needed.
  • Call read_file().
  • Check for possible file reading errors with isValid().
  • Check license validity with isLicenseValid().
  • If the license is valid, then access individual license properties.
  • Re-use the instance (if you need to read multiple licenses) after calling defaultValues().
Examples:

config_license.cpp.

Constructor & Destructor Documentation

ms_license ( )

Default constructor.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

This doesn't read a license file.

ms_license ( const char * filename )

Immediate action constructor.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Loads the license file into memory. Call isValid() and isLicenseValid() to checks that it is a valid license file.

Parameters:
filename is a full or relative path to mascot.license

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
std::string getDistributor ( ) const

Returns Mascot distributor information.

The distributor will be one of:

  • Unknown
  • Direct
  • Bruker
  • Infocom
  • Kratos
  • Applied Biosystems
  • Mass Solutions Ltd Taiwan
Returns:
the distributor as a string.
std::string getEndDate ( ) const

Returns a date the license is valid until as a string.

Returns:
the license end date as a string in the format YYYYMMDD.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFeatures ( ) const

Returns a string which encodes feature information.

Returns:
a numerically encoded string.
std::string getFileName ( ) const

Returns a file name being used as a license.

Returns:
The license filename -- full or relative path.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getLicensee ( ) const

Returns a name of the licensee.

The licensee name will be up to 80 characters long.

Returns:
the licensee as a string.
std::string getLicenseString ( ) const

Returns a compound license string that can be used for displaying license information.

This will be of the following format:

   Licensed to: xxx, (yy processors).

For a temporary license:

    Licensed to: xxx, (yy processors). Demo version expires: zzzz
Returns:
the license string.
Examples:
config_license.cpp.
std::string getLicenseVersion ( ) const

Returns a license version as a string.

The license version number is not directly related to the Mascot version number. It is incremented each time new functionality (and hence extra lines) are added to the license file.

Returns:
The license version number as a string.
int getNumProcessorsLicensed ( ) const

Returns a number of processors licensed.

Returns:
the number of processors licensed.
std::string getStartDate ( ) const

Returns a date the license is valid from as a string.

Returns:
the license start date as a string in the format YYYYMMDD.
bool isLicenseValid ( ) const

Returns TRUE if the license has been sucessfully read, parsed and checked.

If the license is not valid, some information may be available by calling getLastErrorString() or getLastError().

Returns:
true if the license is valid.
Examples:
config_license.cpp.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void read_file ( )

Main method that reads in the license file.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

Called by the constructor if a filename is passed.

void setFileName ( const char * filename )

Set the license file name explicitly rather than use a default location.

Deprecated:
Warning: This class just reads licenses for Mascot version 2.4.x and earlier

A default location for the license file is ../config/mascot.license. Call this member to change this file name before calling read_file().

Parameters:
filename The license filename -- full or relative path.
The documentation for this class was generated from the following files:
  • ms_license.hpp
  • ms_license.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_mascotfiles
Public Member Functions

ms_mascotfiles Class Reference
[Mascot configuration files module]

An instance of this class contains configuration files paths (except for mascot.dat). More...

#include <ms_mascotfiles.hpp>

Inheritance diagram for ms_mascotfiles:
[legend]
Collaboration diagram for ms_mascotfiles:
[legend]

List of all members.

Public Member Functions

ms_mascotfiles ()
Default constructor.
ms_mascotfiles (const ms_mascotfiles &src)
Copying constructor.
~ms_mascotfiles ()
Destructor.
void | copyFrom (const ms_mascotfiles *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getEnzymes () const
Returns enzymes path.
std::string | getFrequencies () const
Returns freqs.dat path.
std::string | getModifications () const
Returns mod_file path.
std::string | getNodeListFile () const
Returns nodelist.txt path.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
ms_mascotfiles & | operator= (const ms_mascotfiles &right)
Assignment operator for C++ client application.
void | setEnzymes (const char *filename)
Change enzymes path.
void | setFrequencies (const char *filename)
Change freqs.dat path.
void | setModifications (const char *filename)
Change mod_file path.
void | setNodeListFile (const char *filename)
Change nodelist.txt path.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.

Detailed Description

An instance of this class contains configuration files paths (except for mascot.dat).

An instance of this class is normally created and populated within ms_datfile. It contains filepaths for mod_file, enzymes, frequencies and nodelist.txt.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Member Function Documentation

std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
The documentation for this class was generated from the following files:
  • ms_mascotfiles.hpp
  • ms_mascotfiles.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_mascotoptions
Public Types | Public Member Functions

ms_mascotoptions Class Reference
[Mascot configuration files module]

An instance of this class represents all the parameters specified in the Options section of mascot.dat. More...

#include <ms_mascotoptions.hpp>

Inheritance diagram for ms_mascotoptions:
[legend]
Collaboration diagram for ms_mascotoptions:
[legend]

List of all members.

Public Types

enum DECOY_ALGORITHM {
DECOY_ALGORITHM_NONE = 0,
DECOY_PROTEIN_REVERSE = 1,
DECOY_PEPTIDE_REVERSE = 2,
DECOY_PROTEIN_RANDOM = 3,
DECOY_PEPTIDE_RANDOM = 4,
DECOY_PROTEIN_RANDOM_DIPEP = 5,
DECOY_PEPTIDE_RANDOM_DIPEP = 6,
DECOY_PROTEIN_SHUFFLE = 7,
DECOY_PEPTIDE_SHUFFLE = 8,
DECOY_PROTEIN_BASED_MASK = 0x0001
}

Definitions for how the decoy sequences are generated.

More...
enum | EXEC_AFTER_SEARCH { MAX_EXEC_AFTER_SEARCH = 10 }

Definitions for the ExecAfterSearch_XXX lines in the Options section of mascot.dat.

More...
enum MS_REVIEW_COL {
MS_REVIEW_COL_JOB = 0x0000,
MS_REVIEW_COL_PID = 0x0001,
MS_REVIEW_COL_DATABASE = 0x0002,
MS_REVIEW_COL_USERNAME = 0x0003,
MS_REVIEW_COL_USEREMAIL = 0x0004,
MS_REVIEW_COL_TITLE = 0x0005,
MS_REVIEW_COL_RESULTS_FILE = 0x0006,
MS_REVIEW_COL_START_TIME = 0x0007,
MS_REVIEW_COL_DURATION = 0x0008,
MS_REVIEW_COL_STATUS = 0x0009,
MS_REVIEW_COL_PRIORITY = 0x000A,
MS_REVIEW_COL_SEARCHTYPE = 0x000B,
MS_REVIEW_COL_ENZYMEUSED = 0x000C,
MS_REVIEW_COL_IPADDRESS = 0x000D,
MS_REVIEW_COL_USERID = 0x000E,
MS_REVIEW_COL_PEAKLISTDATAFILE = 0x000F,
MS_REVIEW_COL____LAST___ = 0x0010
}

Definitions for columns in ms-review.exe for use with getReviewColWidth() and getReviewColDisplay().

More...
enum | NUMERICAL_VALUE_STORAGE { MASS_DECIMAL_PLACES = 6 }

Definitions for storage of numerical values in files.

More...
enum PERC_EXE_RT {
PERC_EXE_RT_USE_DEFAULT = 1,
PERC_EXE_RT_FORCE_ON = 2,
PERC_EXE_RT_FORCE_OFF = 3
}

Definitions for retention time override when calling getPercolatorExeFlags().

More...

Public Member Functions

ms_mascotoptions ()
Default constructor.
ms_mascotoptions (const ms_mascotoptions &src)
Copying constructor.
~ms_mascotoptions ()
Destructor.
void | appendIgnoreDupeAccession (const std::string value)
Appends a database to the list databases that shouldn't be checked for duplicate accessions.
void | appendReportNumberChoice (const int value)
Append a value to the ReportNumberChoices list.
void | appendTargetFDRPercentage (const double value, const bool makeDefault=false)
Append a value to the TargetFDRPercentages list.
void | clearIgnoreDupeAccessions ()
Clears the list of databases that shouldn't be checked for duplicate accessions.
void | clearReportNumberChoices ()
Deletes all ReportNumberChoices values from the list.
void | clearTargetFDRPercentages ()
Deletes all TargetFDRPercentages values from the list.
void | copyFrom (const ms_mascotoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getCacheDirectory () const
Returns the value of CacheDirectory.
double | getCentroidWidth () const
Returns the value of CentroidWidth.
int | getCentroidWidthCount () const
Returns the value of CentroidWidthCount.
std::string | getCompressToolAA () const
Returns the value of CompressTool_AA.
std::string | getCompressToolCommandLineFasta (DATABASE_TYPE dbType, const std::string &dbname, const std::string &dbpath) const
Get command line to compress fasta, eg ms-compress.exe.
std::string | getCompressToolCommandLineLibrary (const std::string &logfilepath, const std::string &inputfile, const std::string &outputdirectory) const
Get command line to compress library, eg lib2nistcl.exe.
std::string | getCompressToolNA () const
Returns the value of CompressTool_NA.
std::string | getCompressToolSL () const
Returns the value of CompressTool_NA.
int | getCrawlerNumPeaksPer100Da () const
Returns the number of peaks to output in each 100 Da window for the library crawler.
int | getCreatePipThreadBlockSize () const
Returns the value of CreatePipThreadBlockSize.
int | getCreatePipThreads () const
Returns the value of CreatePipThreads.
int | getDechargeFragmentPeaks () const
Return the maximum fragment ion charge state to be decharged.
int | getDecoyTypeNoEnzyme () const
Returns the value of DecoyTypeNoEnzyme.
int | getDecoyTypeSpecific () const
Returns the value of DecoyTypeSpecific.
int | getDisplayNonSignificantMatches () const
Returns the value of DisplayNonSignificantMatches.
std::string | getEmailFromTextName () const
Returns the value of EmailFromTextName.
std::string | getEmailFromUser () const
Returns the value of EmailFromUser.
std::string | getEmailPassword () const
Returns the value of EmailPassword.
std::string | getEmailProfile () const
Returns the value of EmailProfile.
std::string | getEmailService () const
Returns the value of EmailService.
int | getEmailTimeOutPeriod () const
Returns the value of EmailTimeOutPeriod.
std::string | getErrMessageEmailTo () const
Returns the value of ErrMessageEmailTo.
std::string | getErrorLogFile () const
Returns the value of ErrorLogFile.
int | getErrTolMaxAccessions () const
Returns the value of ErrTolMaxAccessions.
int | getExecAfterSearch (const char *szResultsFilePath, std::vector< std::string > &commands, std::vector< std::string > &titles, std::vector< int > &waitfor, std::vector< int > &logging, std::vector< std::string > &additionalFlags, const char *sessionID=0, const char *taskID=0) const
Returns the values of the ExecAfterSearch_XXX parameters.
int | getFeatureTableLength () const
Returns the value of FeatureTableLength.
double | getFeatureTableMinScore () const
Returns the value of FeatureTableMinScore.
std::string | getFormVersion () const
Returns the value of FormVersion.
const ms_blastaccession * | getGetSeqBlastAccession () const
Returns GetSeqBlastAccession.
std::string | getGetSeqJobIdFile () const
Returns the value of GetSeqJobIdFile.
std::string | getICATFilter () const
Returns the value of ICATFilter.
std::string | getICATHeavy () const
Returns the value of ICATHeavy.
std::string | getICATLight () const
Returns the value of ICATLight.
std::string | getICATQuantitationMethod () const
Returns the value of name of the ICATQuantitationMethod.
std::string | getIgnoreDupeAccession (const unsigned int index) const
Returns one of the list databases that shouldn't be checked for duplicate accessions.
double | getIgnoreIonsScoreBelow () const
Returns the value of IgnoreIonsScoreBelow.
int | getIntensitySigFigs () const
Returns the value of IntensitySigFigs.
std::string | getInterFileBasePath () const
Returns the value of InterFileBasePath.
std::string | getInterFileRelPath () const
Returns the value of InterFileRelPath.
int | getIonsDecimalPlaces () const
Returns the value of IonsDecimalPlaces.
std::string | getLastQueryAscFile () const
Returns the value of LastQueryAscFile.
std::string | getLogoImageFile () const
Returns the value of LogoImageFile.
std::string | getMailTempFile () const
Returns the value of MailTempFile.
int | getMailTransport () const
Returns the value of MailTransport.
std::string | getMascNodeCtrlFile () const
Returns the value of MascotNodeControlFile.
std::string | getMascotCmdLine () const
Returns the value of MascotCmdLine.
std::string | getMascotControlFile () const
Returns the value of MascotControlFile.
int | getMascotFileProcessingThreads () const
Returns the value of MascotFileProcessingThreads.
std::string | getMascotJobIdFile () const
Returns the value of MascotJobIdFile.
std::string | getMascotMessage () const
Returns the value of MascotMessage.
int | getMassDecimalPlaces () const
Returns the value of MassDecimalPlaces.
int | getMaxConcurrentSearches () const
Returns the value of MaxConcurrentSearches.
int | getMaxDatabases () const
Returns the value of MaxDatabases.
int | getMaxDescriptionLen () const
Returns the value of MaxDescriptionLen.
double | getMaxEtagMassDelta () const
Returns the value of MaxEtagMassDelta.
int | getMaxEtVarMods () const
Returns the value of MaxEtVarMods.
int | getMaxIntactCrosslinkPeptides () const
Returns the value of MaxIntactCrosslinkPeptides.
int | getMaxNumOfReportBuilderColumnArrangements () const
Returns the maximum number of column arrangements allowed.
int | getMaxNumPeptides () const
Returns the value of MaxNumPeptides.
int | getMaxPepModArrangements () const
Returns the value of MaxPepModArrangements.
int | getMaxPepNumModifiedSites () const
Returns value of the MaxPepNumModifiedSites.
int | getMaxPepNumVarMods () const
Returns value of the MaxPepNumVarMods.
int | getMaxQueries () const
Returns the value of MaxQueries.
int | getMaxSearchesPerUser () const
Returns the value of MaxSearchesPerUser.
int | getMaxSequenceLen () const
Returns the value of MaxSequenceLen.
int | getMaxVarMods () const
Returns the value of MaxVarMods.
double | getMinEtagMassDelta () const
Returns the value of MinEtagMassDelta.
int | getMinPepLenInPepSummary () const
Returns the value of MinPepLenInPepSummary.
int | getMinPepLenInSearch () const
Returns value of the MinPepLenInSearch.
int | getMonitorEmailCheckFreq () const
Returns the value of MonitorEmailCheckFreq.
std::string | getMonitorLogFile () const
Returns the value of MonitorLogFile.
std::string | getMonitorPidFile () const
Returns the value of MonitorPidFile.
int | getMonitorTestTimeout () const
Returns the value of MonitorTestTimeout.
int | getMudpit () const
Returns the value of Mudpit.
double | getMudpitSwitch () const
Returns the value of MudpitSwitch.
std::string | getNoResultsScript () const
Returns the value of NoResultsScript.
std::string | getNTIUserGroup () const
Returns the value of NTIUserGroup.
std::string | getNTMonitorGroup () const
Returns the value of NTMonitorGroup.
unsigned int | getNumberOfIgnoreDupeAccessions () const
Returns the number of databases that shouldn't be checked for duplicate accessions.
int | getNumberOfReportNumberChoices () const
Returns the values of ReportNumberChoices.
int | getNumberOfTargetFDRPercentages () const
Returns the values of TargetFDRPercentages.
std::string | getPepSearchTool () const
Returns the value of LibrarySearch.
std::string | getPepSearchToolCommandLine (const std::string &peptideToleranceUnit, const double &peptideTolerance, const std::string &ionToleranceUnit, const double &ionTolerance, const std::string &libraryDirectoryPath, const std::string &inputFileRelativePath, const std::string &outputFileRelativePath) const
Get command line to search a library, eg MSPepSearch.exe.
std::string | getPercolatorExeFlags (bool anyRetentionTimes, const std::vector< std::string > percolatorFiles, const PERC_EXE_RT rt=PERC_EXE_RT_USE_DEFAULT) const
Returns the value of PercolatorExeFlags.
std::string | getPercolatorFeatures () const
Returns the value of PercolatorFeatures.
int | getPercolatorMinQueries () const
Returns the value of PercolatorMinQueries.
int | getPercolatorMinSequences () const
Returns the value of PercolatorMinSequences.
double | getPercolatorTargetRankRelativeThreshold () const
Returns the value of PercolatorTargetRankRelativeThreshold.
int | getPercolatorTargetRankScoreThreshold () const
Returns the value of PercolatorTargetRankScoreThreshold.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
double | getPrecursorCutOutLowerLimit () const
Gets the first PrecursorCutOut.
double | getPrecursorCutOutUpperLimit () const
Gets the second PrecursorCutOut.
int | getProteinFamilySwitch () const
Returns the value of ProteinFamilySwitch.
int | getProteinsInResultsFile () const
Returns the value of ProteinsInResultsFile.
std::string | getProxyPassword () const
Returns the value of proxy_password.
std::string | getProxyServer () const
Returns the value of proxy_server.
std::string | getProxyType () const
Returns the value of ProxyType.
std::string | getProxyUsername () const
Returns the value of proxy_username.
std::string | getReportBuilderColumnArrangement (const int index) const
Returns ReportBuilderColumnArrangement by number.
int | getReportNumberChoice (const int index) const
Returns an element of the ReportNumberChoices list by its number.
std::string | getResfileCache () const
Returns the value of ResfileCache.
std::string | getResultsCache () const
Returns the value of ResultsCache.
std::string | getResultsFileFormatVersion () const
Returns the value of ResultsFileFormatVersion.
std::string | getResultsFullURL () const
Returns the value of ResultsFullURL.
std::string | getResultsFullURL_2 () const
Returns the value of ResultsFullURL_2.
std::string | getResultsPerlScript () const
Returns the value of ResultsPerlScript.
std::string | getResultsPerlScript_2 () const
Returns the value of ResultsPerlScript_2.
bool | getReviewColDisplay (const MS_REVIEW_COL index) const
Returns ReviewColDisplay by number.
int | getReviewColWidth (const MS_REVIEW_COL index) const
Returns ReviewColWidths by number.
std::string | getSearchLogFile () const
Returns the value of SearchLogFile.
std::string | getSearchSubmitMode () const
Returns the Mascot search submission mode.
int | getSelectSwitch () const
Returns the value of SelectSwitch.
std::string | getSendmailPath () const
Returns the value of sendmailPath.
int | getSeparateLockMem () const
Returns the value of SeparateLockMem.
double | getShowSubsets () const
Returns the value of ShowSubSets.
double | getSigThreshold () const
Returns the value of SigThreshold.
double | getSiteAnalysisMD10Prob () const
Returns the value of SiteAnalysisMD10Prob.
std::string | getSortUnassigned () const
Returns the value of SortUnassigned.
int | getSpectraPerLibraryBlock () const
Returns the number of spectra in a spectral library block.
std::vector< std::string > | getSpectrumViewerColourSchemeNames () const
Returns the names of all colour schemes (SpectrumViewerColourScheme).
std::string | getSpectrumViewerColourSchemeString (const std::string &name) const
Returns SpectrumViewerColourScheme by name.
std::string | getSpectrumViewerDefaultColourSchemeName () const
Return the name of the default colour scheme (SpectrumViewerDefaultColourScheme).
int | getSplitDataFileSize () const
Returns the value of SplitDataFileSize.
int | getSplitNumberOfQueries () const
Returns the value of SplitNumberOfQueries.
int | getSVGSpectrumSwitch () const
Returns the value of SVGSpectrumSwitch.
double | getTargetFDRPercentage (const int index) const
Returns an element of the TargetFDRPercentages list by its number.
std::string | getTaxBrowserUrl () const
Returns value of the TaxBrowserUrl.
std::string | getTestDirectory () const
Returns the value of TestDirectory.
int | getUniqueJobStartNumber () const
Returns the value of UniqueJobStartNumber.
int | getUnixDirPerm () const
Returns the value of UnixDirPerm.
int | getUnixWebUserGroup () const
Returns the value of UnixWebUserGroup.
INT64 | getVmemory () const
Returns the value of Vmemory.
bool | isAutoSelectCharge () const
Returns the value of AutoSelectCharge.
bool | isDefaultTargetFDRPercentage (const int index) const
Returns true if the element of TargetFDRPercentages is a default value.
bool | isEmailErrorsEnabled () const
Returns the value of EmailErrorsEnabled.
bool | isEmailUsersEnabled () const
Returns the value of EmailUsersEnabled.
bool | isForkForUnixApache () const
Returns the value of ForkForUnixApache.
bool | isInIgnoreDupeAccessionList (const std::string value) const
Checks to see if the passed database name is in the list databases that shouldn't be checked for duplicate accessions.
bool | isIteratePMFIntensities () const
Returns value of the IteratePMFIntensities.
bool | isLabelAll () const
Returns the value of LabelAll.
bool | isMatchOppositeCrosslinkPairs () const
Returns the value of MatchOppositeCrosslinkPairs.
bool | isMoveOldDbToOldDir () const
Returns the value of MoveOldDbToOldDir.
bool | isPercolator () const
Returns the value of Percolator.
bool | isPercolatorUseProteins () const
Returns the value of PercolatorUseProteins.
bool | isPercolatorUseRT () const
Returns the value of PercolatorUseRT.
bool | isRemoveOldIndexFiles () const
Returns the value of RemoveOldIndexFiles.
bool | isRequireBoldRed () const
Returns the value of RequireBoldRed.
bool | isSaveEveryLastQueryAsc () const
Returns the value of SaveEveryLastQueryAsc.
bool | isSaveLastQueryAsc () const
Returns the value of SaveLastQueryAsc.
bool | isSectionAvailable () const
Indicates whether the section has been actually read from the file.
bool | isShowAllFromErrorTolerant () const
Returns the value of ShowAllFromErrorTolerant.
bool | isShowSubsets () const
Returns the value of ShowSubSets.
bool | isStoreModPermutations () const
Returns the value of StoreModPermutations.
bool | isUnixDirPermDefined () const
Returns true if the UnixDirPerm value is defined.
bool | isUseHTTPProxyForFTP () const
Returns the value of UseHTTPProxyForFTP.
bool | isUseHTTPProxyForHTTPS () const
Returns the value of UseHTTPProxyForHTTPS.
ms_mascotoptions & | operator= (const ms_mascotoptions &right)
C++ style assignment operator.
void | setAutoSelectCharge (const bool value)
Sets AutoSelectCharge.
void | setCacheDirectory (const char *value)
Sets CacheDirectory.
void | setCentroidWidth (const double value)
Sets CentroidWidth.
void | setCentroidWidthCount (const int value)
Sets CentroidWidthCount.
void | setCompressToolAA (const std::string value)
Sets CompressTool_AA.
void | setCompressToolNA (const std::string value)
Sets CompressTool_NA.
void | setCompressToolSL (const std::string value)
Sets CompressTool_NA.
void | setCrawlerNumPeaksPer100Da (const int value)
Sets the number of peaks to output in each 100 Da window for the library crawler.
void | setCreatePipThreadBlockSize (const int blockSize)
Sets CreatePipThreadBlockSize.
void | setCreatePipThreads (const int nThreads)
Sets CreatePipThreads.
void | setDechargeFragmentPeaks (const int maxCharge)
Sets the maximum fragment ion charge state to be decharged.
void | setDecoyTypeNoEnzyme (const int value)
Sets DecoyTypeNoEnzyme.
void | setDecoyTypeSpecific (const int value)
Sets DecoyTypeSpecific.
void | setDefaultTargetFDRPercentage (const int index)
Makes an element of TargetFDRPercentages at the given index the default value.
void | setDisplayNonSignificantMatches (const int value)
Sets DisplayNonSignificantMatches.
void | setEmailErrorsEnabled (const bool value)
Sets EmailErrorsEnabled.
void | setEmailFromTextName (const char *str)
Sets EmailFromTextName.
void | setEmailFromUser (const char *str)
Sets EmailFromUser.
void | setEmailPassword (const char *str)
Sets EmailPassword.
void | setEmailProfile (const char *str)
Sets EmailPassword.
void | setEmailService (const char *str)
Sets EmailService.
void | setEmailTimeOutPeriod (const int value)
Sets EmailTimeOutPeriod.
void | setEmailUsersEnabled (const bool value)
Sets EmailUsersEnabled.
void | setErrMessageEmailTo (const char *str)
Sets ErrMessageEmailTo.
void | setErrorLogFile (const char *str)
Sets ErrorLogFile path.
void | setErrTolMaxAccessions (const int value)
Sets ErrTolMaxAccessions.
void | setExecAfterSearch (const int num, std::string value)
Sets ExecAfterSearch_XXX.
void | setFeatureTableLength (const int value)
Sets FeatureTableLength.
void | setFeatureTableMinScore (const double value)
Sets FeatureTableMinScore.
void | setForkForUnixApache (const bool value)
Sets ForkForUnixApache.
void | setFormVersion (const char *str)
Sets FormVersion.
void | setGetSeqBlastAccession (const ms_blastaccession *value)
Sets GetSeqBlastAccession.
void | setGetSeqJobIdFile (const char *str)
Sets GetSeqJobIdFile.
void | setICATFilter (const char *filterString)
Sets ICATFilter.
void | setICATHeavy (const char *modName)
Sets ICATHeavy.
void | setICATLight (const char *modName)
Sets ICATLight.
void | setICATQuantitationMethod (const char *methodName)
Sets ICATQuantitationMethod.
void | setIgnoreDupeAccession (const unsigned int index, const std::string value)
Sets an item in the IgnoreDupeAccessions list by its index.
void | setIgnoreIonsScoreBelow (const double value)
Sets IgnoreIonsScoreBelow.
void | setIntensitySigFigs (const int value)
Sets IntensitySigFigs.
void | setInterFileBasePath (const char *str)
Sets InterFileBasePath.
void | setInterFileRelPath (const char *str)
Sets InterFileRelPath.
void | setIonsDecimalPlaces (const int value)
Sets IonsDecimalPlaces.
void | setIteratePMFIntensities (const bool value)
Sets IteratePMFIntensities.
void | setLabelAll (const bool value)
Sets LabelAll.
void | setLastQueryAscFile (const char *str)
Sets LastQueryAscFile to the passed value.
void | setLogoImageFile (const char *str)
Sets LogoImageFile.
void | setMailTempFile (const char *str)
Sets MailTempFile.
void | setMailTransport (const int value)
Sets MailTransport.
void | setMascNodeCtrlFile (const char *str)
Sets MascNodeCtrlFile.
void | setMascotCmdLine (const char *str)
Sets MascotCmdLine.
void | setMascotControlFile (const char *str)
Sets MascotControlFile.
void | setMascotFileProcessingThreads (const int value)
Sets MascotFileProcessingThreads.
void | setMascotJobIdFile (const char *str)
Sets MascotJobIdFile.
void | setMascotMessage (const char *str)
Sets MascotMessage.
void | setMassDecimalPlaces (const int value)
Sets MassDecimalPlaces.
void | setMatchOppositeCrosslinkPairs (const bool value)
Sets MatchOppositeCrosslinkPairs.
void | setMaxConcurrentSearches (const int value)
Sets MaxConcurrentSearches.
void | setMaxDatabases (const int value)
Sets MaxDatabases.
void | setMaxDescriptionLen (const int value)
Sets MaxDescriptionLen.
void | setMaxEtagMassDelta (const double value)
Sets MaxEtagMassDelta.
void | setMaxEtVarMods (const int value)
Sets MaxEtVarMods.
void | setMaxIntactCrosslinkPeptides (const int value)
Sets MaxIntactCrosslinkPeptides.
void | setMaxNumPeptides (const int value)
Sets MaxNumPeptides.
void | setMaxPepModArrangements (const int value)
Sets MaxPepModArrangements.
void | setMaxPepNumModifiedSites (const int value)
Sets MaxPepNumModifiedSites.
void | setMaxPepNumVarMods (const int value)
Sets MaxPepNumVarMods.
void | setMaxQueries (const int value)
Sets MaxQueries.
void | setMaxSearchesPerUser (const int value)
Sets MaxSearchesPerUser.
void | setMaxSequenceLen (const int value)
Sets MaxSequenceLen.
void | setMaxVarMods (const int value)
Sets MaxVarMods.
void | setMinEtagMassDelta (const double value)
Sets MinEtagMassDelta.
void | setMinPepLenInPepSummary (const int value)
Sets MinPepLenInPepSummary.
void | setMinPepLenInSearch (const int value)
Sets MinPepLenInSearch.
void | setMonitorEmailCheckFreq (const int value)
Sets MonitorEmailCheckFreq.
void | setMonitorLogFile (const char *str)
Sets MonitorLogFile.
void | setMonitorPidFile (const char *str)
Sets MonitorPidFile.
void | setMonitorTestTimeout (const int value)
Sets MonitorTestTimeout.
void | setMoveOldDbToOldDir (const bool value)
Sets MoveOldDbToOldDir.
void | setMudpit (const int value)
Sets Mudpit.
void | setMudpitSwitch (const double value)
Sets MudpitSwitch.
void | setNoResultsScript (const char *str)
Sets NoResultsScript.
void | setNTIUserGroup (const char *str)
Sets NTIUserGroup.
void | setNTMonitorGroup (const char *str)
Sets NTMonitorGroup.
void | setPepSearchTool (const std::string value)
Sets LibrarySearch.
void | setPercolator (const bool value)
Sets Percolator.
void | setPercolatorExeFlags (const char *value)
Sets PercolatorExeFlags.
void | setPercolatorFeatures (std::string value)
Sets PercolatorFeatures.
void | setPercolatorMinQueries (const int value)
Sets PercolatorMinQueries.
void | setPercolatorMinSequences (const int value)
Sets PercolatorMinSequences.
void | setPercolatorTargetRankRelativeThreshold (const double threshold)
Sets PercolatorTargetRankRelativeThreshold.
void | setPercolatorTargetRankScoreThreshold (const int threshold)
Sets PercolatorTargetRankScoreThreshold.
void | setPercolatorUseProteins (const bool value)
Sets PercolatorUseProteins.
void | setPercolatorUseRT (const bool value)
Sets PercolatorUseRT.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPrecursorCutOutLowerLimit (const double value)
Sets the first PrecursorCutOut.
void | setPrecursorCutOutUpperLimit (const double value)
Sets the second PrecursorCutOut.
void | setProteinFamilySwitch (const int value)
Sets ProteinFamilySwitch.
void | setProteinsInResultsFile (const int value)
Sets ProteinsInResultsFile.
void | setProxyPassword (const char *str)
Sets proxy_password.
void | setProxyServer (const char *str)
Sets proxy_server.
void | setProxyType (const std::string &value)
Sets ProxyType.
void | setProxyUsername (const char *str)
Sets proxy_username.
void | setRemoveOldIndexFiles (const bool value)
Sets RemoveOldIndexFiles.
void | setReportBuilderColumnArrangement (const int index, const std::string str)
Sets ReportBuilderColumnArrangement.
void | setReportNumberChoice (const int index, const int value)
Sets an element of the ReportNumberChoices list by its index.
void | setRequireBoldRed (const bool value)
Sets RequireBoldRed.
void | setResfileCache (const char *value)
Sets ResfileCache.
void | setResultsCache (const char *value)
Sets ResultsCache.
void | setResultsFileFormatVersion (const char *value)
Sets ResultsFileFormatVersion.
void | setResultsFullURL (const char *str)
Sets ResultsFullURL.
void | setResultsFullURL_2 (std::string value)
Sets ResultsFullURL_2.
void | setResultsPerlScript (const char *str)
Sets ResultsPerlScript.
void | setResultsPerlScript_2 (std::string value)
Sets ResultsPerlScript_2.
void | setReviewColDisplay (const MS_REVIEW_COL index, const bool value)
Sets ReviewColDisplay.
void | setReviewColWidth (const MS_REVIEW_COL index, const int value)
Sets ReviewColWidths.
void | setSaveEveryLastQueryAsc (const bool flag)
Sets SaveEveryLastQueryAsc to 1 or 0.
void | setSaveLastQueryAsc (const bool flag)
Sets SaveLastQueryAsc to 1 or 0.
void | setSearchLogFile (const char *str)
Sets SearchLogFile.
void | setSearchSubmitMode (const std::string value)
Sets the Mascot search submission mode.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
void | setSelectSwitch (const int value)
Sets SelectSwitch.
void | setSendmailPath (const char *str)
Sets sendmailPath.
void | setSeparateLockMem (const int value)
Sets SeparateLockMem.
void | setShowAllFromErrorTolerant (const bool value)
Sets ShowAllFromErrorTolerant.
void | setShowSubsets (const bool value)
Sets ShowSubSets.
void | setShowSubsets (const double value)
Sets ShowSubSets.
void | setSigThreshold (const double value)
Set the SigThreshold.
void | setSiteAnalysisMD10Prob (const double value)
Set the SiteAnalysisMD10Prob.
void | setSortUnassigned (const std::string newValue)
Sets SortUnassigned.
void | setSpectraPerLibraryBlock (const int value)
Sets the number of spectra in a spectral library block.
void | setSpectrumViewerColourSchemeString (const std::string &name, const std::string &str, bool doCheck=true)
Sets SpectrumViewerColourScheme.
void | setSpectrumViewerDefaultColourSchemeName (const std::string &name)
Sets the default colour scheme name (SpectrumViewerDefaultColourScheme).
void | setSplitDataFileSize (const int value)
Sets SplitDataFileSize.
void | setSplitNumberOfQueries (const int value)
Sets SplitNumberOfQueries.
void | setStoreModPermutations (const bool value)
Sets StoreModPermutations.
void | setSVGSpectrumSwitch (const int value)
Sets SVGSpectrumSwitch.
void | setTargetFDRPercentage (const int index, const double value, const bool makeDefault=false)
Sets an element of the TargetFDRPercentages list by its index.
void | setTaxBrowserUrl (const std::string value)
Sets TaxBrowserURL.
void | setTestDirectory (const char *str)
Sets TestDirectory.
void | setUniqueJobStartNumber (const int value)
Sets UniqueJobStartNumber.
void | setUnixDirPerm (const int value)
Sets UnixDirPerm.
void | setUnixWebUserGroup (const int value)
Sets UnixWebUserGroup.
void | setUseHTTPProxyForFTP (const bool value)
Sets UseHTTPProxyForFTP.
void | setUseHTTPProxyForHTTPS (const bool value)
Sets UseHTTPProxyForHTTPS.
void | setVmemory (const INT64 value)
Sets Vmemory.

Detailed Description

An instance of this class represents all the parameters specified in the Options section of mascot.dat.

An instance of this class is created and populated in ms_datfile.

It can also be created separately and initialized with default values. One can create an instance of the class or copy from another instance in order to pass it then as an options containing object.

For detailed information on any of the options please consult Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_mascotdat.cpp, and resfile_summary.cpp.

Member Enumeration Documentation

enum DECOY_ALGORITHM

Definitions for how the decoy sequences are generated.

In Mascot 2.4 and later, DecoyTypeSpecific and DecoyTypeNoEnzyme control how the decoy database is generated. The strategies are based on the classification by G. Wang, et al. (2009), "Decoy Methods for Assessing False Positives and False Discovery Rates in Shotgun Proteomics", Anal Chem. 81(1):146-159 (doi: 10.1021/ac801664q).

There are four protein based strategies and four peptide based strategies.

The peptide based strategies are not supported for getDecoyTypeNoEnzyme() and if specified in mascot.dat, the corresponding protein based strategy will be returned.

For the peptide based strategies, with a semi-specific search, the protein sequences are generated in the same way as if the search was fully specific, rather than preserving the terminii of the non-specific terminus. A similar rule is applied for missed cleavages: i.e. the two residues either side of the missed cleavage site will be the same as in the target sequence.

This value is returned by getDecoyTypeSpecific() and getDecoyTypeNoEnzyme() See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
DECOY_ALGORITHM_NONE

(0) No algorithm defined. An invalid value.

DECOY_PROTEIN_REVERSE

(1) Reverse the sequence of each protein entry. For a nucleic acid database, the bases are reversed before translation.

DECOY_PEPTIDE_REVERSE

(2) Digest each protein sequence into peptides, then reverse the resulting peptide sequences, but keep the same terminal residues.

DECOY_PROTEIN_RANDOM

(3) For each protein entry, generate a random sequence of the same length, with the composition based on the average composition of the whole database. This is the default in Mascot 2.3 and earlier. For nucleic acid databases, the randomised sequence is generated before translation.

DECOY_PEPTIDE_RANDOM

(4) Digest each protein sequence into peptides, then generate a random sequence for each peptide, as for DECOY_PROTEIN_RANDOM, but keep the same terminal residues and don't introduce new cutting sites. If this option is specified and a nucleic acid database is searched, DECOY_PROTEIN_RANDOM is used.

DECOY_PROTEIN_RANDOM_DIPEP

(5) Protein sequence randomization based on dipeptide frequency (randomDipep): for each protein, an amino acid is randomly chosen according to their frequency distribution as the N-terminal. Each amino acid generated thereafter is based on the occurrence frequency of each dipeptide that starts with its preceding neighboring amino acid. Decoy sequences created this way are expected to have similar amino acid composition and nearest-neighbor frequencies of the target database. (Not implemented in Mascot 2.4).

DECOY_PEPTIDE_RANDOM_DIPEP

(6) Digest each protein sequence into peptides, but generate random dipeptide sequences for each peptide as in DECOY_PROTEIN_RANDOM_DIPEP, keeping the same terminal residues. (Not implemented in Mascot 2.4).

DECOY_PROTEIN_SHUFFLE

(7) Randomise the order of amino acids in each protein sequence using the STL random_shuffle algorithm: http://www.cplusplus.com/reference/algorithm/random_shuffle/ .

DECOY_PEPTIDE_SHUFFLE

(8) Digest each protein sequence into peptides, but shuffle their sequence as in DECOY_PROTEIN_SHUFFLE, excluding the terminus residue.

DECOY_PROTEIN_BASED_MASK

If the value AND'ed with this is '1', then the algorithm is protein based. (Protein based strategies have value 1,3,5,7)

enum EXEC_AFTER_SEARCH

Definitions for the ExecAfterSearch_XXX lines in the Options section of mascot.dat.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
MAX_EXEC_AFTER_SEARCH

The maximum value for setExecAfterSearch () abd getExecAfterSearch()

enum MS_REVIEW_COL

Definitions for columns in ms-review.exe for use with getReviewColWidth() and getReviewColDisplay().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
MS_REVIEW_COL_JOB

The job number column.

MS_REVIEW_COL_PID

The process ID column.

MS_REVIEW_COL_DATABASE

The database name column.

MS_REVIEW_COL_USERNAME

The USERNAME column.

MS_REVIEW_COL_USEREMAIL

The USEREMAIL column.

MS_REVIEW_COL_TITLE

The search title (COM) column.

MS_REVIEW_COL_RESULTS_FILE

The results file name column.

MS_REVIEW_COL_START_TIME

The job start time and date column.

MS_REVIEW_COL_DURATION

The job duration column (seconds).

MS_REVIEW_COL_STATUS

The job status column - normally 'User read res'.

MS_REVIEW_COL_PRIORITY

The job priority column (0 = normal priority).

MS_REVIEW_COL_SEARCHTYPE

The job search type column (PMF, MIS or SQ).

MS_REVIEW_COL_ENZYMEUSED

The job enzyme used column (Yes or No).

MS_REVIEW_COL_IPADDRESS

The IP address from where the search was submitted.

MS_REVIEW_COL_USERID

The USERID of the user who submitted the search.

MS_REVIEW_COL_PEAKLISTDATAFILE

The name of the data file.

MS_REVIEW_COL____LAST___

Placeholder.

enum NUMERICAL_VALUE_STORAGE

Definitions for storage of numerical values in files.

Enumerator:
MASS_DECIMAL_PLACES

Decimal places used when storing mass values as strings in files.

enum PERC_EXE_RT

Definitions for retention time override when calling getPercolatorExeFlags().

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
PERC_EXE_RT_USE_DEFAULT

Use the default value in mascot.dat.

PERC_EXE_RT_FORCE_ON

Override the value in mascot.dat, forcing the use of retention times.

PERC_EXE_RT_FORCE_OFF

Override the value in mascot.dat, turning off the use of retention times.

Constructor & Destructor Documentation

ms_mascotoptions ( )

Default constructor.

See ms_datfile::getMascotOptions() for the most common way to create an ms_mascotoptions object.

ms_mascotoptions ( const ms_mascotoptions & src )

Copying constructor.

See ms_datfile::getMascotOptions() for the most common way to create an ms_mascotoptions object.

Parameters:
src reference to a valid ms_mascotoptions object

Member Function Documentation

void appendIgnoreDupeAccession ( const std::string value )

Appends a database to the list databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Add a database to the list.

Parameters:
value is the name of the database to add to the list.
void appendReportNumberChoice ( const int value )

Append a value to the ReportNumberChoices list.

See getReportNumberChoice() for more information. If the provided value is not valid, the existing value will be kept.

Parameters:
value is the value to be appended to the list.
void appendTargetFDRPercentage | ( | const double | value,
 |  | const bool | makeDefault = false
 | ) |  |

Append a value to the TargetFDRPercentages list.

See getTargetFDRPercentage() for more information. If the provided value is not valid, the list will be unchanged.

Parameters:
value | is the value to be appended to the list.
makeDefault | controls whether the new element should be made the default item in the list.
void clearIgnoreDupeAccessions ( )

Clears the list of databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

See also:
getNumberOfIgnoreDupeAccessions(), getIgnoreDupeAccession()
void clearReportNumberChoices ( )

Deletes all ReportNumberChoices values from the list.

See getNumberOfReportNumberChoices().

void clearTargetFDRPercentages ( )

Deletes all TargetFDRPercentages values from the list.

See getNumberOfTargetFDRPercentages().

std::string getCacheDirectory ( ) const

Returns the value of CacheDirectory.

See Caching Mascot Results.

The value returned by this function may have an 'encoded' string which requires interpretation by the calling application. For this reason, it is normally easier to call ms_mascotresfile::getCacheDirectory().

Parameter | CacheDirectory
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/cache/%Y/%m
Value in mascot.dat | ../data/cache/%Y/%m
Returns:
the directory.
double getCentroidWidth ( ) const

Returns the value of CentroidWidth.

The width in Daltons of the sliding window used for re-centroiding profile data.

Parameter | CentroidWidth
Permitted values | Floating point > 0 and less than 10.0
Default (if no parameter in mascot.dat) | 0.25
Value in mascot.dat | 0.25
Returns:
the width in Da.
int getCentroidWidthCount ( ) const

Returns the value of CentroidWidthCount.

Centroiding is applied to a scan when the number of peaks in the scan exceeds CentroidWidthCount.

Parameter | CentroidWidthCount
Permitted values | Positive integer > 0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | 1000
Returns:
the peak count threshold.
std::string getCompressToolAA ( ) const

Returns the value of CompressTool_AA.

Not implemented (at version 2.6)

See also:
getCompressToolSL(), getCompressToolNA() and getCompressToolCommandLineFasta()
Parameter | CompressTool_AA
Permitted values | Any non empty text string. Should contain $dbname and $dbpath
Default
(if no parameter in mascot.dat) 		"../bin/ms-compress.exe $dbname $dbpath"
Value in mascot.dat | "../bin/ms-compress.exe $dbname $dbpath"
Returns:
raw compress tool command line from mascot.dat
std::string getCompressToolCommandLineFasta | ( | DATABASE_TYPE | dbType,
 |  | const std::string & | dbname,
 |  | const std::string & | dbpath
 | ) |  | const

Get command line to compress fasta, eg ms-compress.exe.

CURRENTLY NOT IN USE

Parameters:
dbType | Database type, AA or NA
dbname | Name of the database
dbpath | Full path to the database file
Returns:
complete compress tool command line for a fasta
std::string getCompressToolCommandLineLibrary | ( | const std::string & | logfilepath,
 |  | const std::string & | inputfile,
 |  | const std::string & | outputdirectory
 | ) |  | const

Get command line to compress library, eg lib2nistcl.exe.

This function is called by ms-monitor.exe to get the command line required to compress (or otherwise prepare) a spectral library. It calls getCompressToolSL which contains a number of 'tags' which need to be replaced with search specific parameters. In theory, any tool could be used instead of lib2nistcl.exe . This function replaces the following tags with the corresponding variable passed to this function:

  • $logfile is replaced with logfilepath
  • $inputfile is replaced with inputfile
  • $outputdirectory is replaced with outputdirectory
See also:
getCompressToolSL()
Parameters:
logfilepath | full path to the log file that the tool will create. The contents of this file are inserted into the .stats file.
inputfile | full path to the input file. Typically an msp file, but could be any format supported by the tool.
outputdirectory | path to the output directory. For lib2nistcl, this is a directory, but it could be a filename.
Returns:
complete compress tool command line for a spectral library
std::string getCompressToolNA ( ) const

Returns the value of CompressTool_NA.

Not implemented (at version 2.6)

See also:
getCompressToolSL() and getCompressToolAA() and getCompressToolCommandLineFasta()
Parameter | CompressTool_NA
Permitted values | Any non empty text string. Should contain $dbname and $dbpath
Default
(if no parameter in mascot.dat) 		"../bin/ms-compress.exe $dbname $dbpath"
Value in mascot.dat | "../bin/ms-compress.exe $dbname $dbpath"
Returns:
raw compress tool command line from mascot.dat
std::string getCompressToolSL ( ) const

Returns the value of CompressTool_NA.

See also:
getCompressToolAA(), getCompressToolNA() and getCompressToolCommandLineLibrary
Parameter | CompressTool_SL
Permitted values | Any non empty text string. Should contain $logfile, $inputfile and $outputdirectory
Default
(if no parameter in mascot.dat) 		"../bin/NIST/lib2nistcl/lib2nistcl.exe -log9 $logfile -msp2peplib $inputfile $outputdirectory"
Value in mascot.dat | "../bin/NIST/lib2nistcl/lib2nistcl.exe -log9 $logfile -msp2peplib $inputfile $outputdirectory"
Returns:
raw compress tool command line from mascot.dat
int getCrawlerNumPeaksPer100Da ( ) const

Returns the number of peaks to output in each 100 Da window for the library crawler.

The number of highest-intensity peaks to choose from each 100 Da window of the observed spectrum when creating the library spectrum.

Parameter | CrawlerNumPeaksPer100Da
Permitted values | Any integer > 0.
Default (if no parameter in mascot.dat) | 100
Value in mascot.dat | 100
Returns:
the number of peaks to choose from each 100 Da window
int getCreatePipThreadBlockSize ( ) const

Returns the value of CreatePipThreadBlockSize.

Mascot 2.8 and later parallelises the calculation of the Percolator features. Each thread calculates the features in blocks of queries whose size is specified by this option. This option is not implemented in Mascot 2.7 and earlier.

See Using Percolator scores for further information.

Permitted values | An integer greater than 0
Default (if no parameter in mascot.dat) | 2000
Value in mascot.dat | 2000
Returns:
Number of queries processed by each thread.
int getCreatePipThreads ( ) const

Returns the value of CreatePipThreads.

Mascot 2.8 and later parallelises the calculation of the Percolator features. If the value of this option is set to -1, all available threads will be used. This option is not implemented in Mascot 2.7 and earlier.

See Using Percolator scores for further information.

Permitted values | Any iteger greater or equal to -1
Default (if no parameter in mascot.dat) | 4
Value in mascot.dat | 4
Returns:
Number of threads used in ms-createpip.exe.
int getDechargeFragmentPeaks ( ) const

Return the maximum fragment ion charge state to be decharged.

Fragment ion peak charges can be specified in Mascot Generic Format. Mascot Server only looks for 1+ and 2+ fragment ions, so higher charge states will not be matched unless they are de-charged.

If the charge specified for a particular fragment in the MGF file is less than or equal to the value returned by this function, then the m/z value will be decharged to the singly charged MH+ value before searching.

Some instruments will never produce very high charge states, but the peak detection software may incorrectly report a very high charge state. Setting this value to a sensible maximum charge state will prevent decharging of these fragment peaks. A value of zero will prevent any decharging.

Parameter | DechargeFragmentPeaks
Permitted values | Zero or a positive integer
Default (if no parameter in mascot.dat) | 10
Value in mascot.dat | 10
Returns:
currently defined value.
int getDecoyTypeNoEnzyme ( ) const

Returns the value of DecoyTypeNoEnzyme.

Mascot 2.2 introduced automatic decoy searches. Any search can be run simultaneously against a randomised decoy database, which is generated on the fly.

See ms_mascotoptions::DECOY_ALGORITHM for a description of the possible values. However, only PROTEIN based strategies are supported in Mascot 2.4

Only the following values are implemented in Mascot 2.4:

  • ms_mascotoptions::DECOY_PROTEIN_REVERSE (default)
  • ms_mascotoptions::DECOY_PROTEIN_RANDOM
  • ms_mascotoptions::DECOY_PROTEIN_SHUFFLE

The other values may be implemented in future versions of Mascot and are thus reserved values. Setting DecoyTypeNoEnzyme to any of them will select the default strategy (3).

For a search with an enzyme specified, see getDecoyTypeSpecific().

Parameter | DecoyTypeNoEnzyme
Permitted values | 1, 2, 3, 4, 5, 6, 7, 8
Default (if no parameter in mascot.dat) | 3
Value in mascot.dat | 3
Returns:
the decoy search type for a no-enzyme search.
int getDecoyTypeSpecific ( ) const

Returns the value of DecoyTypeSpecific.

Mascot 2.2 introduced automatic decoy searches. Any search can be run simultaneously against a randomised decoy database, which is generated on the fly.

See ms_mascotoptions::DECOY_ALGORITHM for a description of the possible values.

Only the following values are implemented in Mascot 2.4:

  • ms_mascotoptions::DECOY_PROTEIN_REVERSE (default)
  • ms_mascotoptions::DECOY_PEPTIDE_REVERSE
  • ms_mascotoptions::DECOY_PROTEIN_RANDOM
  • ms_mascotoptions::DECOY_PEPTIDE_RANDOM
  • ms_mascotoptions::DECOY_PROTEIN_SHUFFLE
  • ms_mascotoptions::DECOY_PEPTIDE_SHUFFLE

The other values may be implemented in future versions of Mascot and are thus reserved values. Setting DecoyTypeSpecific to any of them will select the default strategy (1).

For a search with no enzyme specified, see getDecoyTypeNoEnzyme().

Parameter | DecoyTypeSpecific
Permitted values | 1, 2, 3, 4, 5, 6, 7, 8
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 1
Returns:
the decoy search type for an ordinary search.
int getDisplayNonSignificantMatches ( ) const

Returns the value of DisplayNonSignificantMatches.

In Mascot 2.5 and earlier, the search reports show an input field for "Ignore ions score below". The control allows filtering out non-significant or uninteresting peptide matches by score or expect value.

In Mascot 2.6 and later, the search reports show either a checkbox for "Display non-significant matches" or the edit field from previous versions, depending on the value of DisplayNonSignificantMatches: if 0 or 1, display the checkbox, and if 2, display the edit field. Additionally, 0 means the checkbox is unchecked by default and 1 means checked.

Parameter | DisplayNonSignificantMatches
Permitted values | 0, 1, 2
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 0
Returns:
form control type for filtering out non-significant matches.
std::string getEmailFromTextName ( ) const

Returns the value of EmailFromTextName.

The EmailFromTextName value is the text name of the sender of all messages For example, if the email is from "Mascot Server <sender@somewhere.com>", then "Mascot Server" is the EmailFromTextName value. The default value of 'your_domain' in earlier versions of mascot.dat was somewhat confusing.

Used by all e-mail configurations.

See also:
getEmailFromUser(), getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailFromTextName
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | Mascot
Returns:
the name from which messages are sent.
std::string getEmailFromUser ( ) const

Returns the value of EmailFromUser.

EmailFromUser is the email address which will appear in the From field of the email message. Used by all e-mail configurations.

See also:
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailFromUser
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_id
Returns:
the email address from which messages are sent.
std::string getEmailPassword ( ) const

Returns the value of EmailPassword.

EmailPassword is the password (if any) required to log onto MAPI or CMC.

See also:
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailPassword
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_password
Returns:
the password for the email service.
std::string getEmailProfile ( ) const

Returns the value of EmailProfile.

EmailProfile is the MAPI profile name.

See also:
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailProfile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_profile
Returns:
the name for the MAPI email profile.
std::string getEmailService ( ) const

Returns the value of EmailService.

EmailService is the service name (CMC only).

See also:
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | EmailService
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | your_service
Returns:
the name of the CMC email service.
int getEmailTimeOutPeriod ( ) const

Returns the value of EmailTimeOutPeriod.

See isEmailUsersEnabled() for information on this parameter.

Parameter | EmailTimeOutPeriod
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 120
Value in mascot.dat | 120
Returns:
The timeout period in seconds.
std::string getErrMessageEmailTo ( ) const

Returns the value of ErrMessageEmailTo.

If EmailErrorsEnabled is set to 1, serious error messages will be emailed to ErrMessageEmailTo.

See also:
isEmailErrorsEnabled().
Parameter | ErrMessageEmailTo
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | administrator@your.domain
Returns:
the email address to which messages are sent.
std::string getErrorLogFile ( ) const

Returns the value of ErrorLogFile.

This defines where error messages should be stored.

Parameter | ErrorLogFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/errorlog.txt
Value in mascot.dat | [not defined]
Returns:
the full (or relative) path to the errorlog file.
int getErrTolMaxAccessions ( ) const

Returns the value of ErrTolMaxAccessions.

The maximum number of accessions allowed for an 'old style' error-tolerant search.

A value of zero indicates no limit

Parameter | ErrTolMaxAccessions
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns:
the maximum number of accessions.
int getExecAfterSearch | ( | const char * | szResultsFilePath,
 |  | std::vector< std::string > & | commands,
 |  | std::vector< std::string > & | titles,
 |  | std::vector< int > & | waitfor,
 |  | std::vector< int > & | logging,
 |  | std::vector< std::string > & | additionalFlags,
 |  | const char * | sessionID = 0,
 |  | const char * | taskID = 0
 | ) |  | const

Returns the values of the ExecAfterSearch_XXX parameters.

After each search, a number of 'user' programs can be run. For example, Percolator may be run after each search.

Parameter | ExecAfterSearch_XXX
Permitted values Text string of the format:
flag:num[;flag:num], title string, command
where
  • flag:num can be one or more of flag:value pairs from the table below
  • title string is the (optional) text output by nph-mascot while the process is running. For example "Percolating...". The title must not contain a comma!
  • command should be a unix/windows command string. It may contain one or more of tags as described below
Default
(if no parameter in mascot.dat) 		[empty]
Value in mascot.dat | ExecAfterSearch_2 waitfor:0;logging:0;percolator:1, Percolating, ../bin/percolator.exe $PercolatorExeFlags

The following flags may be specified:

flag | Acceptable 'num' | Description
waitfor | 0 or 1..10 | This command should not be run until the command specified by the waitfor has finished. A value of 0 indicates 'don't wait'.
logging 0..3 The values indicate the level of logging. Messages are put into errorlog.txt:
  • 0 - No logging
  • 1 - Log successful commands (return code 0)
  • 2 - Log unsuccessful commands (return code not 0)
  • 3 - Log successful and unsuccessful commands
percolator | 0 or 1 | This command will only be run if Percolator is set to 1 in mascot.dat and if the search meets the criteria to percolate results. See Using Percolator scores
cgienv | 0 or 1 | Default is 1. When nph-mascot.exe runs the command specified, it uses spawn/exec so all the same environment variables available to nph-mascot.exe are set. When this includes cgi environment variables, it can cause confusion and problems for some perl scripts such as export_dat.pl, where the script behaves differently when running as cgi process. Setting this flag to 0 ensures that all the cgi environment variables, such as =CONTENT_LENGTH= and =SCRIPT_NAME= are cleared before the process is run.

For consistency with staticGetPercolatorFileNames() and ms_mascotresfile::setPercolatorFeatures(), it is important to set PercolatorExeFlags correctly before calling this method. Otherwise, this method may generate a pip or pop filename different from setPercolatorFeatures().

    bool anyRT = (whether any query has RTINSECONDS);
    std::string percolatorFlags = options.getPercolatorRtFlags(anyRT, options.isPercolatorUseRT());
    options.setPercolatorExeFlags(percolatorFlags.c_str());

The following tags will be replaced. (Note that it would potentially be unsafe to add a tag for a value that can be entered by the user in a search form, e.g. a user could enter cat /etc/passwd as their username).

Tag | Replaced with
%resultfilepath | The passed szResultsFilePath
%resultfilename | The filename part of the passed szResultsFilePath
%percolator_pip | The input file from ms_mascotresfile::staticGetPercolatorFileNames()
%percolator_decoy_pop | The decoy output file from ms_mascotresfile::staticGetPercolatorFileNames()
%percolator_target_pop | The target output file from ms_mascotresfile::staticGetPercolatorFileNames()
%session_id | Is replaced by the passed sessionID parameter
%task_id | Is replaced by the passed taskID parameter
$PercolatorExeFlags | This flag is not replaced by this function! nph-mascot calls getPercolatorExeFlags() to replace it.

A set of vectors is returned from this function. Currently, each vector will have 10 entries, corresponding to ExecAfterSearch_1 ... ExecAfterSearch_10, but this value may be increased in future. The calling application should use the size of the vectors rather than hardcode the number 10. Note that many (or all) of the commands may be empty.

Parameters:
szResultsFilePath | is the path to the results file.
commands | is a vector, containing the list of commands to be run. the flags and titles will have been stripped from the command, and any tags in the commands will have been replaced by values as described above. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
titles | is a vector containing the text to be output will the process is running. For example: "Creating XML output....". See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
waitfor | is a vector of integers containing the dependency for each commands to be run. A value of 0 indicates that the command should be run immediately without waiting for another one to finish. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
logging | is a vector of integers containing the logging level for each commands to be run. A value of 0 indicates that no entries should be added to the errorlog.txt file. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
additionalFlags | is a vector of strings containing any flags apart from the waitfor or logging flag. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
sessionID | is the session identifier for the search. See ms_session::ms_session. This value is passed to the search engine using the --sessionID parameter.
taskID | is the task identifier for the search and is normally obtained by calling ms-searchcontrol.exe or client.pl. It is passed to nph-mascot.exe using the --taskID parameter.
Returns:
the total number of commands to be run. This is not the same as the size of the vectors as the vectors may contain empty values.
int getFeatureTableLength ( ) const

Returns the value of FeatureTableLength.

If a nucleic acid sequence is longer than FeatureTableLength parameter value, the protein view report will automatically switch to feature table mode and output the matches as a GenBank feature table.

Parameter | FeatureTableLength
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 30,000
Value in mascot.dat | [not defined]
Returns:
the length at which to switch to a feature table.
double getFeatureTableMinScore ( ) const

Returns the value of FeatureTableMinScore.

By default, only matches with significant scores (p < 0.05) are output. A different score threshold can be specified using the parameter FeatureTableMinScore.

Parameter | FeatureTableMinScore
Permitted values | Floating point > 0
Default (if no parameter in mascot.dat) | 13.0
Value in mascot.dat | [not defined]
Returns:
the minimum score to be shown in a feature table.
std::string getFormVersion ( ) const

Returns the value of FormVersion.

Mascot users may save search forms off-line, or submit searches using scripts or private forms. When the search engine is upgraded, there is the possibility that old scripts or forms may contain invalid or obsolete parameters. If a search is submitted to Mascot without a version number, or if the version number is lower than that specified by FormVersion, a warning will be included in the results file and in the master results report.

Parameter | FormVersion
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | 1.01
Value in mascot.dat | 1.01
Returns:
the form version.
std::string getGetSeqJobIdFile ( ) const

Returns the value of GetSeqJobIdFile.

GetSeqJobIdFile contains the next available job number for the ms-getseq.exe utility. These numbers wrap around at 999 and do not appear in the search logs. If this file is deleted, the next job number will be reset to 1 and a new jobId-file created automatically.

Parameter | GetSeqJobIdFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/getseq.job
Value in mascot.dat | ../data/getseq.job
Returns:
the path to the getseq.job file.
std::string getICATFilter ( ) const

Returns the value of ICATFilter.

Parameter ICATFilter gives a residue that ICAT modifications apply to.

Parameter | ICATFilter
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | "C"
Value in mascot.dat | [not defined]
Returns:
the filter string used as a comp command.
std::string getICATHeavy ( ) const

Returns the value of ICATHeavy.

The ICATHeavy parameter is the name of ICAT heavy modification. The full modification definition can be found in mod_file.

Parameter | ICATHeavy
Permitted values | Any text string
Default (if no parameter in mascot.dat) | ICAT_heavy
Value in mascot.dat | [not defined]
Returns:
the name of the heavy ICAT modification.
std::string getICATLight ( ) const

Returns the value of ICATLight.

The ICATLight parameter is the name of ICAT light modification. The full modification definition can be found in mod_file.

Parameter | ICATLight
Permitted values | Any text string
Default (if no parameter in mascot.dat) | ICAT_light
Value in mascot.dat | [not defined]
Returns:
the name of the light ICAT modification.
std::string getICATQuantitationMethod ( ) const

Returns the value of name of the ICATQuantitationMethod.

The ICATQuantitationMethod parameter is the name of the quantitation method to use if the old 'ICAT' checkbox is clicked for Mascot 2.2 and later. Just for backward compatibility.

Parameter | ICATQuantitationMethod
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ICAT
Value in mascot.dat | ICAT ABI Cleavable [MD]
Returns:
the name of quantitation method to use.
std::string getIgnoreDupeAccession ( const unsigned int index ) const

Returns one of the list databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Parameter | IgnoreDupeAccessions
Permitted values | text strings delimted by tab, space and comma
Default (if no parameter in mascot.dat) | EST_others
Value in mascot.dat | EST_others
Parameters:
index is a 0 based index into the list of databases.
Returns:
the database name.
double getIgnoreIonsScoreBelow ( ) const

Returns the value of IgnoreIonsScoreBelow.

Any ions score lower than this value will be set to zero and ignored. The parameter is a floating point number.

Parameter | IgnoreIonsScoreBelow
Permitted values | Any floating point >= 0.0
Default (if no parameter in mascot.dat) | 0.0
Value in mascot.dat | 0.0
Returns:
the minimum ions score to be considered when generating search reports.
int getIntensitySigFigs ( ) const

Returns the value of IntensitySigFigs.

The precision of intensity values written to the result file is determined by IntensitySigFigs.

The default in the mascot.dat suppplied with version 2.2 and later is 4.

Parameter | IntensitySigFigs
Permitted values | 1 to 20
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 4
Returns:
the number of significant figures to be used when saving values.
std::string getInterFileBasePath ( ) const

Returns the value of InterFileBasePath.

Mascot output files are written to a path given by:

   InterFileBasePath/InterFileRelPath/yyyymmdd/Fnnnnnn.dat

Here yyyymmdd is the current ISO date, and nnnnnn is a sequential job number. The path is split into a base path and a relative path as seen by the CGI scripts so that the search engine can pass a file path to (say) master_results.pl as:

   InterFileRelPath/yyyymmdd/Fnnnnnn.dat

Parameter | InterFileBasePath
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | C:/InetPub/Mascot/data for Windows and /usr/local/mascot/data for all other platforms
Value in mascot.dat | ###ROOT###/data
Returns:
the path to the Mascot output files.
std::string getInterFileRelPath ( ) const

Returns the value of InterFileRelPath.

One of the critical values that determine a location for storing intermediate files.

See getInterFileBasePath() for further information.

Parameter | InterFileRelPath
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data
Value in mascot.dat | ../data
Returns:
the relative path to Mascot results files.
int getIonsDecimalPlaces ( ) const

Returns the value of IonsDecimalPlaces.

Mascot calculates all masses to an accuracy of 1/65535 Daltons. By default, values are displayed to two decimal places, which is probably too few for most modern instruments. The default in the mascot.dat suppplied with version 2.2 and later is 4.

The displayed precision of fragment ion masses in reports can be altered by changing the values of IonsDecimalPlaces.

Parameter | IonsDecimalPlaces
Permitted values | 1 to 20
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 4
Returns:
the number of decimal places to be displayed.
std::string getLastQueryAscFile ( ) const

Returns the value of LastQueryAscFile.

See isSaveLastQueryAsc() for a detailed explanation.

Parameter | LastQueryAscFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/lastquery.asc
Value in mascot.dat | ../logs/lastquery.asc
Returns:
the full pathname of the file.
std::string getLogoImageFile ( ) const

Returns the value of LogoImageFile.

This is the URL of the Matrix Science logo, used at the top of a search progress report. You can customise this by substituting the URL of your own logo. For optimum appearance, the image should be 88 pixels wide and 31 pixels high.

Parameter | LogoImageFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../images/88x31_logo_white.gif
Value in mascot.dat | ../images/88x31_logo_white.gif
Returns:
the path to an image file.
std::string getMailTempFile ( ) const

Returns the value of MailTempFile.

See isEmailUsersEnabled() for information on this parameter.

Parameter | MailTempFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | C:/TEMP/MXXXXXX
Value in mascot.dat | /var/tmp/MXXXXXX
Returns:
the location of temp files created for sending emails.
int getMailTransport ( ) const

Returns the value of MailTransport.

MailTransport should be set to one of the following values:

  • 0 for CMC. See getEmailService(), getEmailPassword()
  • 1 for MAPI. See getEmailProfile(), getEmailPassword()
  • 2 for sendmail (Unix only). See getSendmailPath()
  • 3 for Blat. See getSendmailPath().

E-mail functionality has to be enabled by one of the following parameters: isEmailUsersEnabled(), isEmailErrorsEnabled().

Other parameters are common for all e-mail transports.

See also:
getEmailFromUser(), getEmailFromTextName(), getErrMessageEmailTo(), getMailTempFile().
Parameter | MailTransport
Permitted values | 0 to 3 inclusive
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 0
Returns:
a code defining the mail transport to be used.
std::string getMascNodeCtrlFile ( ) const

Returns the value of MascotNodeControlFile.

Parameter | MascotNodeControlFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/mascotnode.control
Value in mascot.dat | ../data/mascotnode.control
Returns:
the path to the mascotnode.control file.
std::string getMascotCmdLine ( ) const

Returns the value of MascotCmdLine.

Filepath to the mascot executable. This is used by ms-monitor.exe when running the test search.

Parameter | MascotCmdLine
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/nph-mascot.exe
Value in mascot.dat | ../cgi/nph-mascot.exe
Returns:
the absolute or relative patch to nph-mascot.exe.
Examples:
config_mascotdat.cpp.
std::string getMascotControlFile ( ) const

Returns the value of MascotControlFile.

MascotControlFile contains critical internal parameters. This file must be memory mapped and locked to provide interprocess communication between different Mascot components.

Parameter | MascotControlFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/mascot.control
Value in mascot.dat | ../data/mascot.control
Returns:
the path to the mascot.control file.
int getMascotFileProcessingThreads ( ) const

Returns the value of MascotFileProcessingThreads.

MascotFileProcessingThreads specifies the number of threads used for pre-processing the input data at the beginning of the search, and for file processing at the beginning and end of each chunk. This setting does not affect the number of threads used for the search proper, which is determined by the number of licensed CPUs.

Parameter | MascotFileProcessingThreads
Permitted values | Any integer > 0, or -1 for automatic.
Default (if no parameter in mascot.dat) | 4
Value in mascot.dat | [not defined]
Returns:
the number of threads to use to process files
std::string getMascotJobIdFile ( ) const

Returns the value of MascotJobIdFile.

MascotJobIdFile contains the next available job number. If this file is deleted, the next job number will be initialised to the value given by UniqueJobStartNumber, and a new jobId file created automatically.

Parameter | MascotJobIdFile
Permitted values | Any non empty text stringg
Default (if no parameter in mascot.dat) | ../data/mascot.job
Value in mascot.dat | ../data/mascot.job
Returns:
the path to the mascot.job file.
std::string getMascotMessage ( ) const

Returns the value of MascotMessage.

Displays the specified message while a search is running.

Parameter | MascotMessage
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [not defined]
Returns:
the message to be displayed for all searches.
int getMassDecimalPlaces ( ) const

Returns the value of MassDecimalPlaces.

Mascot calculates all masses to an accuracy of 1/65535 Daltons. By default, values are displayed to two decimal places, which is probably too few for most modern instruments. The default in the mascot.dat suppplied with version 2.2 and later is 4.

The displayed precision of peptide masses in reports can be altered by changing the values of MassDecimalPlaces.

Parameter | MassDecimalPlaces
Permitted values | 1 to 20
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | 4
Returns:
the number of decimal places to be displayed.
int getMaxConcurrentSearches ( ) const

Returns the value of MaxConcurrentSearches.

This parameter limits the maximum number of concurrent searches so as to avoid overloading the Mascot server.

See also ms_security_tasks::SECTASK_MAXCONCURRENTSEARCHES.

Parameter | MaxConcurrentSearches
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 10
Value in mascot.dat | 10
Returns:
the maximum number of concurrent searches.
int getMaxDatabases ( ) const

Returns the value of MaxDatabases.

Maximum number of databases that can be configured without re-starting monitor. Older versions of Mascot had a fixed limit of 64, which is a default value. Avoid specifying very large number as this will consume more physical memory and disk space unnecessarily.

Parameter | MaxDatabases
Permitted values | Any integer > 64
Default (if no parameter in mascot.dat) | 64
Value in mascot.dat | 256
Returns:
an integer value specifying the limit.
int getMaxDescriptionLen ( ) const

Returns the value of MaxDescriptionLen.

Long FASTA title (description) lines will be truncated at this number of characters.

Parameter | MaxDescriptionLen
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 100
Value in mascot.dat | 250
Returns:
the maximum length.
double getMaxEtagMassDelta ( ) const

Returns the value of MaxEtagMassDelta.

See also:
getMinEtagMassDelta()
Parameter | MaxEtagMassDelta
Permitted values | Any floating point number
Default (if no parameter in mascot.dat) | 1770.0
Value in mascot.dat | 1770.0
Returns:
The maximum delta to be considered for an error tolerant match.
int getMaxEtVarMods ( ) const

Returns the value of MaxEtVarMods.

The maximum number of variable modifications allowed in an error-tolerant search.

Parameter | MaxEtVarMods
Permitted values | Any integer in the range 0 to 31
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | [not defined]
Returns:
the maximum number of variable modifications for the first pass search.
int getMaxIntactCrosslinkPeptides ( ) const

Returns the value of MaxIntactCrosslinkPeptides.

The maximum number of intact crosslink peptides to consider for a crosslink search. All regular peptides are still considered in the search and are not affected by this parameter.

Parameter | MaxIntactCrosslinkPeptides
Permitted values | Any integer > 0.
Default (if no parameter in mascot.dat) | 1000000
Value in mascot.dat | 1000000
Returns:
the maximum number of crosslink peptides to consider for matching
int getMaxNumOfReportBuilderColumnArrangements ( ) const

Returns the maximum number of column arrangements allowed.

The maximum number of column arrangements defined in mascot.dat is limited. If security is enabled, each user can save additional column arrangements in user preferences.

Returns:
Maximum number of column arrangements.
int getMaxNumPeptides ( ) const

Returns the value of MaxNumPeptides.

The maximum number of peptides which can be expected from the enzymatic digest of a single entry.

If this value is not defined in mascot.dat than the value is calculated from getMaxSequenceLen() / 4

In general, this should not be defined in mascot.dat.

Parameter | MaxNumPeptides
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | [not defined]
Value in mascot.dat | [not defined]
Returns:
the maximum number of peptides to be considered in a search.
int getMaxPepModArrangements ( ) const

Returns the value of MaxPepModArrangements.

Mascot iterates over the variable modifications of a peptide in the following way:

  • Choose a (sub)set of variable modifications, up to a limit of MaxPepNumVarMods.
  • Choose the number of instances for each modification that fits the precursor mass within precursor tolerance. Total number of instances is limited by MaxPepNumModifiedSites.
  • Assign the selected modification instances on modifiable sites. Each assignment is an arrangement of the modification instances. Repeat until the arrangements are exhausted or MaxPepModArrangements is reached.

The number of arrangements for some peptides can be very large.

A value of zero indicates maximum.

This parameter is new in Mascot 2.7. Previous versions had no specific upper limit, although in many cases iteration ended before about 16-20 arrangements had been sampled.

Parameter | MaxModArrangements
Permitted values | Any integer >= 0 and <= 1000000
Default (if no parameter in mascot.dat) | 64
Value in mascot.dat | 64
Returns:
the maximum number of variable modification arrangements allowed for a single peptide.
int getMaxPepNumModifiedSites ( ) const

Returns value of the MaxPepNumModifiedSites.

Mascot iterates over the variable modifications of a peptide in the following way:

  • Choose a (sub)set of variable modifications, up to a limit of MaxPepNumVarMods.
  • Choose the number of instances for each modification that fits the precursor mass within precursor tolerance. Total number of instances is limited by MaxPepNumModifiedSites.
  • Assign the selected modification instances on modifiable sites. Each assignment is an arrangement of the modification instances. Repeat until the arrangements are exhausted or MaxPepModArrangements is reached.

A value of zero indicates maximum.

This parameter is new in Mascot 2.7. Previous versions had no configurable upper limit.

Parameter | MaxPepNumModifiedSites
Permitted values | Any integer >= 0 and <= 10000
Default (if no parameter in mascot.dat) | 5
Value in mascot.dat | 5
Returns:
the maximum number of modified sites in a peptide
int getMaxPepNumVarMods ( ) const

Returns value of the MaxPepNumVarMods.

Mascot iterates over the variable modifications of a peptide in the following way:

  • Choose a (sub)set of variable modifications, up to a limit of MaxPepNumVarMods.
  • Choose the number of instances for each modification that fits the precursor mass within precursor tolerance. Total number of instances is limited by MaxPepNumModifiedSites.
  • Assign the selected modification instances on modifiable sites. Each assignment is an arrangement of the modification instances. Repeat until the arrangements are exhausted or MaxPepModArrangements is reached.

A value of zero indicates maximum.

Parameter | MaxPepNumVarMods
Permitted values | Any integer >= 0 and <= 10000
Default (if no parameter in mascot.dat) | 3
Value in mascot.dat | 3
Returns:
the maximum number of modifications in one peptide.
int getMaxQueries ( ) const

Returns the value of MaxQueries.

The maximum number of mass values (PMF) or MS/MS spectra (MIS) allowed in a single search.

Parameter | MaxQueries
Permitted values | Integer >= 10
Default (if no parameter in mascot.dat) | 10000
Value in mascot.dat | 1000000
Returns:
the maximum number of queries per search.
int getMaxSearchesPerUser ( ) const

Returns the value of MaxSearchesPerUser.

Sets the maximum number of concurrent searches from a single IP-address.

A value of 0 means no limit.

Parameter | MaxSearchesPerUser
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns:
the maximum number of concurrent searches per user.
int getMaxSequenceLen ( ) const

Returns the value of MaxSequenceLen.

This parameters defines the maximum length of a database entry in characters, (bases for nucleic acids or residues for amino acids databases respectively).

Parameter | MaxSequenceLen
Permitted values | Any integer >= 100
Default (if no parameter in mascot.dat) | 80,000
Value in mascot.dat | 80,000
Returns:
the maximum sequence length.
int getMaxVarMods ( ) const

Returns the value of MaxVarMods.

The maximum number of variable modifications allowed in a standard search.

Parameter | MaxVarMods
Permitted values | Any integer in the range 0 to 32
Default (if no parameter in mascot.dat) | 9
Value in mascot.dat | [not defined]
Returns:
the maximum number of variable modifications.
double getMinEtagMassDelta ( ) const

Returns the value of MinEtagMassDelta.

See also:
getMaxEtagMassDelta()
Parameter | MinEtagMassDelta
Permitted values | Any floating point number
Default (if no parameter in mascot.dat) | -130.0
Value in mascot.dat | -130.0
Returns:
The minimum delta to be considered for an error tolerant match.
int getMinPepLenInPepSummary ( ) const

Returns the value of MinPepLenInPepSummary.

In a Peptide Summary report, two proteins are reported as distinct matches if the peptide matches to one protein are not identical to or a sub-set of the peptide matches to the other protein. Since matches to very short peptides are usually random, peptides shorter than MinPepLenInPepSummary are not considered in this comparison.

Parameter | MinPepLenInPepSummary
Permitted values | Any integer greater than zero
Default (if no parameter in mascot.dat) | 7
Value in mascot.dat | 7 (Was 5 in Mascot 2.3.02 and earlier)
Returns:
the minimum peptide length used to differentiate different proteins.
int getMinPepLenInSearch ( ) const

Returns value of the MinPepLenInSearch.

This parameter specifies the minimal length of a peptide to be accepted as a match to any query in all searches. Use this parameter if you see too many short peptides in a result file that constitute mostly meaningless matches.

Parameter | MinPepLenInSearch
Permitted values | Any non-negative integer
Default (if no parameter in mascot.dat) | 3
Value in mascot.dat | 5
Returns:
the minimum peptide length.
int getMonitorEmailCheckFreq ( ) const

Returns the value of MonitorEmailCheckFreq.

See isEmailUsersEnabled() for information on this parameter..

Parameter | MonitorEmailCheckFreq
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 300
Value in mascot.dat | 300
Returns:
the frequency to check for sending emails in seconds.
std::string getMonitorLogFile ( ) const

Returns the value of MonitorLogFile.

This path defines where monitor log file should be placed. The ms-monitor.exe service/daemon writes to this file.

Parameter | MonitorLogFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/monitor.log
Value in mascot.dat | [not defined]
Returns:
the relative or absolute path to the monitor log.
std::string getMonitorPidFile ( ) const

Returns the value of MonitorPidFile.

The name for the file which holds the process ID number for ms-monitor.exe. Unix only.

Parameter | MonitorPidFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../bin/monitor.pid
Value in mascot.dat | [not defined]
Returns:
monitor pid file name
int getMonitorTestTimeout ( ) const

Returns the value of MonitorTestTimeout.

A time-out is applied to the test searches used to validate a new database. If the test search on a new database does not produce a valid result within the number of seconds specified by MonitorTestTimeout, the problem is assumed to be with the new database, and the exchange process is halted.

Parameter | MonitorTestTimeout
Permitted values | Any positive integer
Default (if no parameter in mascot.dat) | 1200
Value in mascot.dat | 1200
Returns:
the timeout period in seconds.
int getMudpit ( ) const

Returns the value of Mudpit.

Deprecated:
For Mascot 2.2 and later, use getMudpitSwitch() and getSelectSwitch().

Gets the number of queries at which the protein scoring switches to MudPIT mode.

See also:
ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE
Parameter | Mudpit
Permitted values | Any integer>0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | [not defined]
Returns:
number of queries at which scoring switches to MudPIT mode
double getMudpitSwitch ( ) const

Returns the value of MudpitSwitch.

A ratio of the number of queries divided by the number of entries in the database is used to determine when to switch between the two methods of protein scoring. The default value for SelectSwitch is 0.001. If q/e < 0.001, then standard protein scoring is used. If it is higher than 0.001, then MudPIT protein scoring is used.

If the user never wants to see MudPIT scoring, then this should be set to a large value, e.g. 1000

In the standard reports, the _server_mudpit_switch flag can be passed as a url parameter to override this setting.

This parameter, and getSelectSwitch() replaced the single value returned by getMudpit() in Mascot 2.1 and earlier.

See also ms_protein::getScore() for a description of standard and MudPIT protein scoring.

Parameter | MudpitSwitch
Permitted values | Any floating point value > 0
Default (if no parameter in mascot.dat) | 0.001
Value in mascot.dat | 0.001
Returns:
The q/e value used to determine which protein scoring method to use.
std::string getNoResultsScript ( ) const

Returns the value of NoResultsScript.

See getResultsPerlScript() for more information.

Parameter | NoResultsScript
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/master_results.pl
Value in mascot.dat | ../cgi/master_results.pl
Returns:
the url for the no results script.
std::string getNTIUserGroup ( ) const

Returns the value of NTIUserGroup.

See getNTMonitorGroup() for information on this parameter.

The default in mascot.dat since mascot 2.3.0 is "Users". Earlier versions had the default as "Guests"

Parameter | NTIUserGroup
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | Guests
Value in mascot.dat | Users
Returns:
NTI user group
std::string getNTMonitorGroup ( ) const

Returns the value of NTMonitorGroup.

Under Windows NT, the Mascot service is generally run using the Local System account. It has to create, write and read the memory mapped files. The CGI scripts (such as nph-mascot.exe) are run by the Web server, and will be run using a different user name with different permissions from the service. These programs also need to be able to read and write to these files.

For example, with the Microsoft Web server (IIS), a new user with the name IUSR_<name_of_pc> is created when the server is installed, and the scripts are run using this user name. The installation program sets these values appropriately. Other Web servers may use different user names, with different permissions.

NTMonitorGroup is used to define one of the groups that the administrator belongs to. In most cases, this can be left at the default of Administrators.

NTIUserGroup is the name of one of the groups that the user name used to run the CGI scripts belongs to.

Parameter | NTMonitorGroup
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | Administrators
Value in mascot.dat | Administrators
Returns:
the name of the Administrators group.
unsigned int getNumberOfIgnoreDupeAccessions ( ) const

Returns the number of databases that shouldn't be checked for duplicate accessions.

When fasta files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Parameter | IgnoreDupeAccessions
Permitted values | text strings delimted by tab, space and comma
Default (if no parameter in mascot.dat) | EST_others
Value in mascot.dat | EST_others
Returns:
the number of items in the IgnoreDupeAccessions parameter.
int getNumberOfReportNumberChoices ( ) const

Returns the values of ReportNumberChoices.

If present, ReportNumberChoices list will define the choices provided in the search form Report top drop down list box. If not, this member will return zero.

getReportNumberChoice() member is used to retrieve individual elements of the list.

The default value in mascot.dat is AUTO,5,10,20,30,50,100,200, so this function would return 8 for that case.

Parameter | ReportNumberChoices
Permitted values | Any integer > 0, or -1.
Default (if no parameter in mascot.dat) | 5,10,20,30,40,50
Value in mascot.dat | AUTO,5,10,20,30,50,100,200
Returns:
the number of integers in the list.
int getNumberOfTargetFDRPercentages ( ) const

Returns the values of TargetFDRPercentages.

If present, the TargetFDRPercentages list will define the choices available in a Protein Family Summary report of a decoy search. Each item in the list is a percentage (e.g. 2.5 means 2.5% or 0.025). If the option is not present, this function will return 0.

An element in the list can be marked as the default value. Use getTargetFDRPercentage() to retrieve individual elements of the list, and isDefaultTargetFDRPercentage() to find out if an element is marked as the default element.

The default value in mascot.dat is 0.1, 0.2, 0.5, 1+, 2, 5, so this function would return 6 in the default case. The postfix "+" means that, in this case, 1 is the default value.

Parameter | TargetFDRPercentages
Permitted values | Any number >0
Default (if no parameter in mascot.dat) | 0.1, 0.2, 0.5, 1+, 2, 5
Value in mascot.dat | 0.1, 0.2, 0.5, 1+, 2, 5
Returns:
the number of integers in the list.
std::string getPepSearchTool ( ) const

Returns the value of LibrarySearch.

See also:
setPepSearchTool() and getPepSearchToolCommandLine()

Introduced in version 2.6.0.

In version 2.6.1, "m G" was replaced with "m a P" where:

MSPepSearch parameter | Meaning
m | precursor ion m/z within precursor ion m/z uncertainty
G | generic (no peak annotations or peptide peak weighting used)
a | alternative peak matching in computing match factors
P | peptide (use peak annotations and peak weighting)

And, in 2.6.1, we made sure that every library spectrum has properly annotated peaks, and not just a "?"

Also, in 2.6.1, "/HITS 100" was changed to "/HITS 10"

Parameter | LibrarySearch
Permitted values | Any non empty text string.
Default (if no parameter in mascot.dat) | ../bin/NIST/mspepsearch/MSPepSearch.exe m a P $peptidetoleranceunit $peptidetolerance $iontoleranceunit $iontolerance /LIB $libname /INP $inputfile /OUTTAB $outputfile /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum
Value in mascot.dat | ../bin/NIST/mspepsearch/MSPepSearch.exe m a P $peptidetoleranceunit $peptidetolerance $iontoleranceunit $iontolerance /LIB $libname /INP $inputfile /OUTTAB $outputfile /HITS 10 /MinMF 0 /NumCompared /OutPrecursorMz /OutDeltaPrecursorMz /OutSpecNum
Returns:
the value of LibrarySearch.
std::string getPepSearchToolCommandLine | ( | const std::string & | peptideToleranceUnit,
 |  | const double & | peptideTolerance,
 |  | const std::string & | ionToleranceUnit,
 |  | const double & | ionTolerance,
 |  | const std::string & | libraryDirectoryPath,
 |  | const std::string & | inputFileRelativePath,
 |  | const std::string & | outputFileRelativePath
 | ) |  | const

Get command line to search a library, eg MSPepSearch.exe.

This function is called by nph-mascot.exe to get the command line required to invoke the spectral library search tool. It calls getPepSearchTool which contains a number of 'tags' which need to be replaced with search specific parameters. In theory, any search tool that accepts an MGF file and outputs a CSV file could be used instead of MSPepSearch. This function replaces the following tags with the corresponding variable passed to this function:

  • $peptidetoleranceunit is replaced with peptideToleranceUnit
  • $peptidetolerance is replaced with peptideTolerance
  • $iontoleranceunit is replaced with ionToleranceUnit
  • $iontolerance is replaced with ionTolerance
  • $libname is replaced with libraryDirectoryPath
  • $inputfile is replaced with inputFileRelativePath
  • $outputfile is replaced with outputFileRelativePath
See also:
getPepSearchTool() and setPepSearchTool()
Parameters:
peptideToleranceUnit | will be Z or ZPPM, where 'Z' specifies Daltons.
peptideTolerance | tolerance in the unit above.
ionToleranceUnit | will be M or MPPM, where 'M' specifies Daltons.
ionTolerance | tolerance in the unit above.
libraryDirectoryPath | full path to the directory containing the spectral library 'database'.
inputFileRelativePath | path to the mgf file created by nph-mascot.exe.
outputFileRelativePath | is the path to the results file produced by the library search tool that will be read by nph-mascot.exe.
Returns:
complete pep search tool command line for the specified spectral library.
std::string getPercolatorExeFlags | ( | bool | anyRetentionTimes,
 |  | const std::vector< std::string > | percolatorFiles,
 |  | const PERC_EXE_RT | rt = PERC_EXE_RT_USE_DEFAULT
 | ) |  | const

Returns the value of PercolatorExeFlags.

See Using Percolator scores for further information.

Parameter | PercolatorExeFlags
Permitted values | any string
Default (if no parameter in mascot.dat) | -i 10 -D 14 -v 0
Value in mascot.dat | -i 10 -D 14 -v 0

This function will create a string of the form

  -i 10 -D 14 -v 0 -j [percolator_input_file] -B [percolator_decoy_file] -r [percolator_target_file]

If anyRetentionTimes is true and either forceUseRT or the return from isPercolatorUseRT() is true, then the -D [num] option will be retained, otherwise the -D [num] option will be removed from the PercolatorExeFlags parameters.

Parameters:
anyRetentionTimes | should be set to true if there are any retention times in the results file. It is normally safe to just check the first query and if ms_inputquery::getRetentionTimes() returns an empty string, then set this parameter to false.
percolatorFiles | is the parameter returned by ms_mascotresfile::getPercolatorFileNames().
rt | one of the ms_mascotoptions::PERC_EXE_RT enumerations may be specified to override the value in mascot.dat that is returned by calling isPercolatorUseRT().
Returns:
the flags and options to be used when calling percolator.exe.
std::string getPercolatorFeatures ( ) const

Returns the value of PercolatorFeatures.

Returns a list of features that should be considered when running percolator.

To see the list of available features, run ms-createpip.exe --help. See Using Percolator scores for further information.

Parameter | PercolatorFeatures
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | mScore,lgDScore, mrCalc, charge, dM, dMppm, absDM, absDMppm, isoDM, isoDMppm, mc, varmods, totInt, intMatchedTot,relIntMatchedTot
Value in mascot.dat | mScore,lgDScore, mrCalc, charge, dM, dMppm, absDM, absDMppm, isoDM, isoDMppm, mc, varmods, totInt, intMatchedTot,relIntMatchedTot
Returns:
the comma separated list of features.
int getPercolatorMinQueries ( ) const

Returns the value of PercolatorMinQueries.

Percolator requires a 'reasonable' number of ms-ms spectra to perform well, and this parameter specifies that minimum. If the number of queries is below this value, percolator results will not be made available.

See Using Percolator scores for further information.

Parameter | PercolatorMinQueries
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 750
Value in mascot.dat | 750 (was 100 for Mascot Server versions 2.3 to 2.5.0)
Returns:
the minimum number of queries required to display percolator results.
int getPercolatorMinSequences ( ) const

Returns the value of PercolatorMinSequences.

Percolator requires a 'reasonable' number of sequences to perform well, and this parameter specifies that minimum. If the number of sequences searched is below this value, percolator results will not be made available.

See Using Percolator scores for further information.

Parameter | PercolatorMinSequences
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 100
Value in mascot.dat | 100
Returns:
the minimum number of sequences.
double getPercolatorTargetRankRelativeThreshold ( ) const

Returns the value of PercolatorTargetRankRelativeThreshold.

For a description of this function, see getPercolatorTargetRankScoreThreshold().

See Using Percolator scores for further information.

Permitted values | A real number in [0, 1]
Default (if no parameter in mascot.dat) | 0.2
Value in mascot.dat | 0.2
Returns:
Minimum relative score difference with rank 1 match.
int getPercolatorTargetRankScoreThreshold ( ) const

Returns the value of PercolatorTargetRankScoreThreshold.

Mascot 2.8 and later exports rank 1 matches plus further ranks from target if score > PercolatorTargetRankScoreThreshold and the relative difference from rank 1 score < PercolatorTargetRankRelativeThreshold. This option is not implemented in Mascot 2.7 and earlier.

See Using Percolator scores for further information.

Parameter | PercolatorTargetRankScoreThreshold
Permitted values | Positive integers
Default (if no parameter in mascot.dat) | 20
Value in mascot.dat | 20
Returns:
Minimum score for matches whose rank is greater than 1.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
double getPrecursorCutOutLowerLimit ( ) const

Gets the first PrecursorCutOut.

This parameter defines boundaries for cut-out window for precursor m/z value. It consists of two numbers - the lower limit and the upper limit for precursor m/z window. If both numbers are the same (i.e. if the window is of zero-length) Mascot uses a "smart" mechanism for filtering out peptide m/z from MS-spectra.

Parameter | PrecursorCutOut
Permitted values | Any 2 comma separated floating point numbers
Default (if no parameter in mascot.dat) | "-1, -1"
Value in mascot.dat | "-1, -1"
Returns:
the first of the two values.
double getPrecursorCutOutUpperLimit ( ) const

Gets the second PrecursorCutOut.

This parameter defines boundaries for cut-out window for precursor m/z value. It consists of two numbers - the lower limit and the upper limit for precursor m/z window. If both numbers are the same (i.e. if the window is of zero-length) Mascot uses a "smart" mechanism for filtering out peptide m/z from MS-spectra.

Parameter | PrecursorCutOut
Permitted values | Any 2 comma separated floating point numbers
Default (if no parameter in mascot.dat) | "-1, -1"
Value in mascot.dat | "-1, -1"
Returns:
the second of the two values.
int getProteinFamilySwitch ( ) const

Returns the value of ProteinFamilySwitch.

For Mascot 2.3 and later, if a search has greater than or equal the number of MS-MS spectra defined by getProteinFamilySwitch(), then the script defined by getResultsPerlScript_2() is run.

Parameter | ProteinFamilySwitch
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 300
Value in mascot.dat | 300
Returns:
the number of MS-MS spectra required for displaying the Protein Family Summary report.
int getProteinsInResultsFile ( ) const

Returns the value of ProteinsInResultsFile.

Determines the number of protein title lines saved to each results file. Possible values are:

  • 1 - as in Mascot 1.7 and earlier, only proteins that appear in the Summary section will appear in the Proteins section.
  • 2 - include proteins with at least one top ranking peptide match to a peptide of length greater than or equal to MinPepLengthInPepSummary (see getMinPepLenInPepSummary()).
  • 3 - include all proteins.
Parameter | ProteinsInResultsFile
Permitted values | 1, 2 or 3
Default (if no parameter in mascot.dat) | 2
Value in mascot.dat | [not defined]
Returns:
a value defining which protein descriptions should be stored in the results file.
std::string getProxyPassword ( ) const

Returns the value of proxy_password.

See getProxyServer().

Parameter | proxy_password
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out]# proxy_password mypassword
Returns:
the password for the proxy server user.
std::string getProxyServer ( ) const

Returns the value of proxy_server.

This parameter allows a proxy server to be defined.

Other parameters defining proxy server are proxy_username (getProxyUsername()) and proxy_password (getProxyPassword()).

Parameter | proxy_server
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out]# proxy_server myserver
Returns:
the proxy server name.
std::string getProxyType ( ) const

Returns the value of ProxyType.

Proxy server settings can be specified in a number of ways depending on the operating system and local network policies. See ms_connection_settings::PROXY_TYPE for a description. The proxy type value in mascot.dat is case-insensitive; for example, all of none, None and NONE mean ms_connection_settings::PROXY_TYPE_NO_PROXY.

This parameter was introduced in Mascot Server 2.5. The default in Mascot Server 2.4 and earlier is equivalent to Specify. If proxy_server is not given in mascot.dat, the default in 2.4 is None.

Parameter | ProxyType
Permitted values | None, Registry, Specify, WPAD, Environment, Auto
Default (if no parameter in mascot.dat) | Auto
Value in mascot.dat | Auto
Returns:
A string matching one of the ms_connection_settings::PROXY_TYPE values.
std::string getProxyUsername ( ) const

Returns the value of proxy_username.

See getProxyServer().

Parameter | proxy_username
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out]# proxy_username myusername
Returns:
the username for proxy server.
std::string getReportBuilderColumnArrangement ( const int index ) const

Returns ReportBuilderColumnArrangement by number.

Set the column arrangement at the given index. Column arrangements are used by Report Builder (introduced in Mascot 2.4) to provide a default list of columns to show. These can be selected from a dropdown list in the report.

Each column arrangement is of the form

   Name:[columns]

where Name is the column arrangement name (e.g. Standard) and [columns] is a comma-separated list of column names, as used by Report Builder. The following is the standard list of column names, available in every report:

   family
   member
   db
   acc
   score
   mass
   matches
   matches-sig
   sequences
   sequences-sig
   empai
   frame
   desc

(frame will not be shown in the report if the search is against an amino acid database.) Quantitation methods add additional column names, but these are generated from the quantitation ratio names. The easiest way to create a column arrangement string is to arrange the columns in Report Builder, then "export" the column arrangement as a string and copy it into mascot.dat.

See also:
setReportBuilderColumnArrangement().
Parameter | ReportBuilderColumnArrangement_XXX
Permitted values | A name followed by colon followed by column arrangement string (see above)
Default (if no parameter in mascot.dat) | ReportBuilderColumnArrangement_1 Standard:family,member,db,acc,score,mass,matches,matches-sig,sequences,sequences-sig,empai,frame,desc
Value in mascot.dat | ReportBuilderColumnArrangement_1 Standard:family,member,db,acc,score,mass,matches,matches-sig,sequences,sequences-sig,empai,frame,desc
Parameters:
index A value between 1 and getMaxNumOfReportBuilderColumnArrangements(), inclusive.
Returns:
The column arrangement definition at that index, or the empty string if the arrangement does not exist.
int getReportNumberChoice ( const int index ) const

Returns an element of the ReportNumberChoices list by its number.

The function returns -1 in case of AUTO string. For more information on the ReportNumberChoices parameter see getNumberOfReportNumberChoices().

The default value in mascot.dat is AUTO,5,10,20,30,50,100,200, so this function would return 5 for an index value of 1

Parameter | ReportNumberChoices
Permitted values | Any integer > 0, or -1.
Default (if no parameter in mascot.dat) | 5,10,20,30,40,50
Value in mascot.dat | AUTO,5,10,20,30,50,100,200
Parameters:
index element number from 0 to (getNumberOfReportNumberChoices()-1).
Returns:
an element of the list that corresponds to the given index. Returns 0 if the provided index is not valid.
std::string getResfileCache ( ) const

Returns the value of ResfileCache.

See Caching Mascot Results.

This parameter is rather counter-intuitive! A script or application running on the Mascot server has a choice of whether or not to specify ms_mascotresfile::RESFILE_USE_CACHE. Each Mascot script calls this function which returns a comma separated list of scripts and executable programs. The script then searches for its own name, and if it finds it, then it will specify the ms_mascotresfile::RESFILE_USE_CACHE flag. Mascot parser does not use this parameter internally -- it is up to each script to use it.

A user can disable/enable the use of the cache for one or more scripts by adding them to the list in mascot.dat.

See also:
getResultsCache()
Parameter | ResfileCache
Permitted values | Comma, space or tab delimeted string. May be empty
Default (if no parameter in mascot.dat) | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,ms-createpip.exe,MSAnatomiser.class,mi_getpeaklist.pl,msms_gif.pl,nph-mascot.exe,ms-searchcontrol.exe,client.pl
Value in mascot.dat | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,ms-createpip.exe,MSAnatomiser.class,mi_getpeaklist.pl,msms_gif.pl,nph-mascot.exe,ms-searchcontrol.exe,client.pl
Returns:
a comma separated list of scripts that should specify ms_mascotresfile::RESFILE_USE_CACHE when creating a ms_mascotresfile object.
std::string getResultsCache ( ) const

Returns the value of ResultsCache.

See Caching Mascot Results.

This parameter is rather counter intuitive! A script or application running on the Mascot server has a choice of whether or not to specify ms_peptidesummary::MSPEPSUM_USE_CACHE. Each Mascot script calls this function which returns a comma separated list of scripts and executable programs. The script then searches for its own name, and if it finds it, then it will specify the ms_peptidesummary::MSPEPSUM_USE_CACHE flag. Mascot parser does not use this parameter internally -- it is up to each script to use it.

A user can disable/enable the use of the cache for one or more scripts by adding them to the list in mascot.dat.

See also:
getResfileCache()
Parameter | ResultsCache
Permitted values | Comma, space or tab delimeted string. May be empty
Default (if no parameter in mascot.dat) | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,MSAnatomiser.class,mi_getpeaklist.pl,nph-mascot.exe,ms-searchcontrol.exe
Value in mascot.dat | master_results.pl,master_results_2.pl,peptide_view.pl,protein_view.pl,export_dat.pl,export_dat_2.pl,MSAnatomiser.class,mi_getpeaklist.pl,nph-mascot.exe,ms-searchcontrol.exe
Returns:
a comma separated list of scripts that should specify ms_peptidesummary::MSPEPSUM_USE_CACHE when creating a ms_peptidesummary object.
std::string getResultsFileFormatVersion ( ) const

Returns the value of ResultsFileFormatVersion.

Currently only one value choice is supported: "2.1". Specifiying this value will force Mascot to produce result file compatible with ver. 2.1. An empty or any other value means current version result file format.

Be careful, however, when submitting to Mascot a search which explicitly requires new functionality. In this case Mascot will decide whether to output results in the requested or the current format.

Parameter | ResultsFileFormatVersion
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | [commented out] #ResultsFileFormatVersion 2.1
Returns:
the version string.
std::string getResultsFullURL ( ) const

Returns the value of ResultsFullURL.

The ResultsFullURL entry is used when results are emailed to a user. Since the email will probably be received on another system, the URL used needs to have the full name including the Web server.

Parameter | ResultsFullURL
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ###URL###/cgi/master_results.pl
Value in mascot.dat | http://www.matrixscience.com/cgi/master_results.pl
Returns:
the url.
std::string getResultsFullURL_2 ( ) const

Returns the value of ResultsFullURL_2.

For Mascot 2.3 and later, if a search has greater than or equal the number of MS-MS spectra defined by getProteinFamilySwitch(), then this URL is used to send results by email.

Parameter | ResultsFullURL_2
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | http://www.matrixscience.com/cgi/master_results_2.pl
Value in mascot.dat | http://www.matrixscience.com/cgi/master_results_2.pl
Returns:
the URL to use.
std::string getResultsPerlScript ( ) const

Returns the value of ResultsPerlScript.

There are URLs (not disk paths) of the scripts to be called by the search engine at the completion of a search. A successful search calls ResultsPerlScript, while a search that didn't find any hits calls NoResultsScript. In the scripts supplied with Mascot, for Mascot 2.2 and earlier, both eventualities are handled by a single script: master_results.pl.

Parameter | ResultsPerlScript
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/master_results.pl
Value in mascot.dat | ../cgi/master_results.pl
Returns:
the url for the results script.
std::string getResultsPerlScript_2 ( ) const

Returns the value of ResultsPerlScript_2.

For Mascot 2.3 and later, if a search has greater than or equal the number of MS-MS spectra defined by getProteinFamilySwitch(), this script is run.

Parameter | ResultsPerlScript_2
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../cgi/master_results_2.pl
Value in mascot.dat | ../cgi/master_results_2.pl
Returns:
the script to run.
bool getReviewColDisplay ( const MS_REVIEW_COL index ) const

Returns ReviewColDisplay by number.

End users can specify the display states in mascot.dat to suit their requirements, for example if they want to hide by default some columns.

See also:
setReviewColDisplay().
Parameter | ReviewColDisplay
Permitted values | 1 (true) for display, 0 (false) for hide
Default (if no parameter in mascot.dat) | 1, 1, 1, 1, 0, 0, 1, 1, 1, 1, 1, 1, 1, 0, 1, 1
Value in mascot.dat | 1, 1, 1, 1, 0, 0, 1, 1, 1, 1, 1, 1, 1, 0, 1, 1
Parameters:
index A value from the MS_REVIEW_COL enumeration.
Returns:
column display state for the given number
int getReviewColWidth ( const MS_REVIEW_COL index ) const

Returns ReviewColWidths by number.

End users can specify the widths in mascot.dat to suit their requirements, for example if they use long titles.

See also:
setReviewColWidth().
Parameter | ReviewColWidths
Permitted values | Positive integer >0
Default (if no parameter in mascot.dat) | 7, 8, 8, 27, 30, 100, 32, 25, 6, 13, 4, 4, 6, 16, 7, 32
Value in mascot.dat | 7, 8, 8, 27, 30, 100, 32, 25, 6, 13, 4, 4, 6, 16, 7, 32
Parameters:
index A value from the MS_REVIEW_COL enumeration.
Returns:
column width for the given number.
std::string getSearchLogFile ( ) const

Returns the value of SearchLogFile.

This path defines where search log file should be stored.

Parameter | SearchLogFile
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../logs/searches.log
Value in mascot.dat | [not defined]
Returns:
the relative or absolute path to the searches log.
std::string getSearchSubmitMode ( ) const

Returns the Mascot search submission mode.

In Mascot 2.5 and later, searches submitted through the search form report progress feedback asynchronously. Once the input file is uploaded, Mascot redirects from the search form to a separate search progress page.

If SearchSubmitMode is async, Mascot behaves as described above. If the value is direct, progress is reported directly by the nph-mascot.exe executable as in Mascot 2.4 and earlier. The downside of "direct" mode is that closing the web browser may kill the search.

Parameter | SearchSubmitMode
Permitted values | async or direct
Default (if no parameter in mascot.dat) | asynchronous
Value in mascot.dat | [not defined]
Returns:
currently defined value.
int getSelectSwitch ( ) const

Returns the value of SelectSwitch.

This function and getMudpitSwitch() replaced the single function getMudpit() in Mascot 2.1 and earlier.

Parameter | SelectSwitch
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | 1000
Returns:
The minimum number of queries for a select summary.
std::string getSendmailPath ( ) const

Returns the value of sendmailPath.

sendmailPath is the path to sendmail or BLAT programs.

See also:
getMailTransport(), isEmailUsersEnabled(), isEmailErrorsEnabled().
Parameter | sendmailPath
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | /usr/lib/sendmail
Value in mascot.dat | /usr/lib/sendmail
Returns:
the full or relative path to sendmail or BLAT.
int getSeparateLockMem ( ) const

Returns the value of SeparateLockMem.

Setting this value to 1 indicates that ms-monitor.exe will run a separate program (ms-lockmem.exe) that will lock the memory blocks.

A value greater than 1 specifies the block size in Mb. For example, if there is a 1.5 Gb *.s00 file, and this parameter is set to 750, then two instances of ms-lockmem.exe will be run.

Parameter | SeparateLockMem
Permitted values | Any integer >= 0
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
the parameter specifying how to use ms-lockmem.exe.
double getShowSubsets ( ) const

Returns the value of ShowSubSets.

If you have a primary hit with (say) 100 peptide matches, you are very interested in sub-set proteins with 99 matches but not if they only have 1 or 2 matches. These are the sub-set hits that clutter up the report if Show Sub-sets is checked in Mascot 2.1 and earlier. If you have a primary hit with (say) 2 peptide matches, you are more likely to be interested in sub-set proteins with just 1 match.

A value of 1 indicates that all proteins with a subset of matches should be reported. A value of 0 indicates that no subsets will be reported.

See also:
ms_mascotresults::setSubsetsThreshold()
Parameter | ShowSubSets
Permitted values | Floating point in range 0 to 1 inclusive
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns:
The fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1 - getShowSubsets()).
double getSigThreshold ( ) const

Returns the value of SigThreshold.

Significance threshold used in results reports.

This global default can be overridden on an individual report URL be appending &_sigthreshold=X, where X is the significance threshold.

Parameter | SigThreshold
Permitted values | Floating point 1e-18 to 1.0
Default (if no parameter in mascot.dat) | 0.05
Value in mascot.dat | 0.05
Returns:
the significance threshold.
double getSiteAnalysisMD10Prob ( ) const

Returns the value of SiteAnalysisMD10Prob.

SiteAnalysisMD10Prob is used in calculating relative probabilities of modification assignments in Peptide View. It defines the factor in probability that a peptide score difference of 10 corresponds to. The default is 0.1, which means a score difference of 10 corresponds to a factor of 10 in probability. Similarly, 0.05 corresponds to a factor of 20.

Parameter | SiteAnalysisMD10Prob
Permitted values | Floating point 1e-18 to 1.0
Default (if no parameter in mascot.dat) | 0.1
Value in mascot.dat | 0.1
Returns:
the MD10Score value.
std::string getSortUnassigned ( ) const

Returns the value of SortUnassigned.

Parameter | SortUnassigned
Permitted values | "scoredown", "queryup" or "intdown"
Default (if no parameter in mascot.dat) | scoredown
Value in mascot.dat | [not defined]
Returns:
The returned value will be one of:
  • scoredown - descending score
  • queryup - query order
  • intdown - intensity order
int getSpectraPerLibraryBlock ( ) const

Returns the number of spectra in a spectral library block.

The NIST spectral library tools have a limit of about 600k spectra. Mascot deals with larger files by splitting them up into chunks each with the maximum number of spectra specified by this value.

Parameter | SpectraPerLibraryBlock
Permitted values | Any integer > 0.
Default (if no parameter in mascot.dat) | 500000
Value in mascot.dat | 500000
Returns:
the maximum number of spectra before splitting into separate blocks
std::vector< std::string > getSpectrumViewerColourSchemeNames ( ) const

Returns the names of all colour schemes (SpectrumViewerColourScheme).

See also:
getSpectrumViewerColourSchemeString()
Returns:
A vector of colour scheme names defined in mascot.dat.
std::string getSpectrumViewerColourSchemeString ( const std::string & name ) const

Returns SpectrumViewerColourScheme by name.

Spectrum Viewer colour schemes were added in Mascot 2.6, and they allow you to choose different peak colours in Peptide View.

Colour scheme name must contain ASCII letters and numbers only; no special characters are allowed.

Each colour scheme is a comma-separated list of key=value pairs, where the key is a peak class and value is either a colour name or an RGB value. The permitted peak classes are:

  • unmatched
  • internal_ion
  • immonium_ion
  • terminal_series_ion
  • terminal_series_ion_nl
  • library_peak

The colour is either one of the 16 HTML 4.01 colour names:

  • white
  • silver
  • gray
  • black
  • red
  • maroon
  • yellow
  • olive
  • lime
  • green
  • aqua
  • teal
  • blue
  • navy
  • fuchsia
  • purple
  • orange

Or an RGB value in standard CSS format, #rrggbb. For example, pure red is #ff0000. Letter case does not matter in colour names or hexadecimal digits.

Note that "orange" is not an HTML 4.01 colour name. It is accepted as a special exception, since it is a valid colour name in CSS 2.1.

Parameter | SpectrumViewerColourScheme_XXX
Permitted values | A comma-separated list of key=value pairs (see above)
Default (if no parameter in mascot.dat) | SpectrumViewerColourScheme_screen unmatched=black,internal_ion=orange,immonium_ion=orange,terminal_series_ion=red,terminal_series_ion_nl=orange,library_peak=blue
Value in mascot.dat | SpectrumViewerColourScheme_screen unmatched=black,internal_ion=orange,immonium_ion=orange,terminal_series_ion=red,terminal_series_ion_nl=orange,library_peak=blue
Parameters:
name Colour scheme name; the defined names are returned by getSpectrumViewerColourSchemeNames().
Returns:
The colour scheme string, or the empty string if the colour scheme does not exist.
std::string getSpectrumViewerDefaultColourSchemeName ( ) const

Return the name of the default colour scheme (SpectrumViewerDefaultColourScheme).

The colour scheme used in Peptide View by default is the scheme named here.

See also:
getSpectrumViewerColourSchemeString()
Parameter | SpectrumViewerDefaultColourScheme
Permitted values | colour scheme name
Default (if no parameter in mascot.dat) | screen
Value in mascot.dat | screen
Returns:
The name of the default colour scheme.
int getSplitDataFileSize ( ) const

Returns the value of SplitDataFileSize.

See getSplitNumberOfQueries() for a description.

Parameter | SplitDataFileSize
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 10000000
Value in mascot.dat | 10000000
Returns:
the maximum size (bytes) of each chunk.
int getSplitNumberOfQueries ( ) const

Returns the value of SplitNumberOfQueries.

Used in conjunction with SplitDataFileSize parameter. When large amount of spectra is submitted the input file is split into several chunks. Each chunk contains no more than SplitNumberOfQueries queries and no more than SplitDataFileSize bytes long.

Parameter | SplitNumberOfQueries
Permitted values | Any integer > 0
Default (if no parameter in mascot.dat) | 1000
Value in mascot.dat | 1000
Returns:
the maximum number of queries in each chunk.
int getSVGSpectrumSwitch ( ) const

Returns the value of SVGSpectrumSwitch.

Mascot 2.5 introduced SVG-based graphics in Peptide View. Since the graphics is rendered in the browser, spectra with a large number of peaks may cause Peptide View to load much slower than in Mascot 2.4 and ealier.

SVGSpectrumSwitch is the cut-off point where Peptide View reverts to the static spectrum graphic used in Mascot 2.4 and earlier. If the spectrum has more peaks than SVGSpectrumSwitch, the old graphic is used; otherwise the new SVG-based graphic is shown. In particular, if you set SVGSpectrumSwitch to 0, the new SVG-based graphic is never shown. If you set it to the maximum value (100000), the SVG-based graphic is always shown.

Parameter | SVGSpectrumSwitch
Permitted values | 0-100000
Default (if no parameter in mascot.dat) | 2000
Value in mascot.dat | 2000
Returns:
cut-off point where Peptide View reverts to the static spectrum graphic
double getTargetFDRPercentage ( const int index ) const

Returns an element of the TargetFDRPercentages list by its number.

For more information on the TargetFDRPercentages parameter see getNumberOfTargetFDRPercentages().

Parameters:
index element number from 0 to (getNumberOfTargetFDRPercentages()-1).
Returns:
an element of the list that corresponds to the given index. Returns 0 if the index is not valid.
std::string getTaxBrowserUrl ( ) const

Returns value of the TaxBrowserUrl.

The URL used in reports to retrieve taxonomy information for a Protein View report.

Parameter | TaxBrowserUrl
Permitted values | Any text string
Default (if no parameter in mascot.dat) | [empty]
Value in mascot.dat | http://www.ncbi.nlm.nih.gov/Taxonomy/Browser/wwwtax.cgi?lvl=0&id=#TAXID#
Returns:
the URL.
std::string getTestDirectory ( ) const

Returns the value of TestDirectory.

TestDirectory contains the input files used by Monitor to test new sequence databases.

Parameter | TestDirectory
Permitted values | Any non empty text string
Default (if no parameter in mascot.dat) | ../data/test
Value in mascot.dat | ../data/test
Returns:
the test directory.
int getUniqueJobStartNumber ( ) const

Returns the value of UniqueJobStartNumber.

See getMascotJobIdFile() for explanations on usage of this parameter.

Parameter | UniqueJobStartNumber
Permitted values | Integer >= 0
Default (if no parameter in mascot.dat) | 1234
Value in mascot.dat | 1234
Returns:
the start job number to be used if the job id file does not exist.
int getUnixDirPerm ( ) const

Returns the value of UnixDirPerm.

Specify the Unix permissions for the 'daily' result file directories and the logs directory. For example, 775 makes each directory world readable but not writeable.

See also:
getUnixWebUserGroup()
Parameter | UnixDirPerm
Permitted values | Any integer in octal format
Default (if no parameter in mascot.dat) | 777 (octal)
Value in mascot.dat | [not defined]
Returns:
the permissions flag.
int getUnixWebUserGroup ( ) const

Returns the value of UnixWebUserGroup.

The paramater UnixWebUserGroup, if present, will restrict access to the files created by ms-monitor.exe, and hence improve system security. UnixWebUserGroup parameter value is the id of the group used by the web server to run CGI programs.

With Apache, the group name will generally be nobody or apache and you will need to ascertain the group number from the group file. For other Web servers, check the documentation that comes with the server to find out which user name is used for running CGI programs.

A value of -2 can be used if the same user name is used to run Web server scripts as runs ms-monitor.exe. In this case, the files created by ms-monitor.exe will not be world accessible, and chown is not used on the files to change ownership.

Parameter | UnixWebUserGroup
Permitted values | Any text string
Default (if no parameter in mascot.dat) | -1
Value in mascot.dat | [not defined]
Returns:
the id of the group.
INT64 getVmemory ( ) const

Returns the value of Vmemory.

Alpha Tru64 only. When setting resource limits for address space, this is the maximum number of bytes requested. If a value of -1 is specified, then the maximum system value is requested.

Parameter | Vmemory
Permitted values | 64 bit integer >= -1
Default (if no parameter in mascot.dat) | -1
Value in mascot.dat | [not defined]
Returns:
the vmemory limit.
bool isAutoSelectCharge ( ) const

Returns the value of AutoSelectCharge.

When this parameter is set to 1 only the charge state that gives the best ion score is reported for each query. Otherwise, each query will be transformed and split into several queries (one for each possible charge state).

Parameter | AutoSelectCharge
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 1
Returns:
true if the auto selection of charge is enabled.
bool isDefaultTargetFDRPercentage ( const int index ) const

Returns true if the element of TargetFDRPercentages is a default value.

For more information on the TargetFDRPercentages parameter see getNumberOfTargetFDRPercentages().

Parameters:
index element number from 0 to (getNumberOfTargetFDRPercentages()-1).
Returns:
true if the element is marked as a default value.
bool isEmailErrorsEnabled ( ) const

Returns the value of EmailErrorsEnabled.

Serious error messages can be emailed to an administrator. This facility can be enabled by setting EmailErrorsEnabled to 1 or disabled by setting it to 0.

Error messages that are considered serious are identified in the file errors.html. This file can be found in the root directory of the installation CD-ROM.

A number of other parameters are required to send e-mail messages. See isEmailUsersEnabled(), getErrMessageEmailTo(), and getMailTransport() for more information.

Parameter | EmailErrorsEnabled
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if error messages should be emailed to the Mascot server administrator.
bool isEmailUsersEnabled ( ) const

Returns the value of EmailUsersEnabled.

When the search engine executes as a CGI application, email can be used to send the results of a search to a user who accidentally or deliberately disconnected before the search was complete. This facility can be enabled by setting EmailUsersEnabled to 1 or disabled by setting it to 0.

If EmailUsersEnabled is set to 1, search results will be emailed to a user if their web browser does not respond within the number of seconds specified in EmailTimeOutPeriod following the completion of a search. See getEmailTimeOutPeriod().

Email messages can be sent in batches at intervals specified by MonitorEmailCheckFreq (in seconds). See getMonitorEmailCheckFreq().

MailTempFile is the name of the temporary file used to store email messages until they can be sent. See getMailTempFile().

A number of other parameters are used to define how email should be sent. You can find some more information about other parameters in the the Mascot installation and setup manual.

See also:
getMailTransport()
Parameter | EmailUsersEnabled
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
the flag indicating if emails with a link to results should be sent.
bool isForkForUnixApache ( ) const

Returns the value of ForkForUnixApache.

If a user presses Stop or goes to another page in their browser when a search is running, then the intended behaviour is that the search should continue, and the user be emailed with their results.

However, when running some versions of Apache under Unix, the search is terminated by Apache when the connection to the browser is lost. To stop this from happening, set this value to 1.

Windows versions of Mascot prior to 2.5.1 also used this parameter and attempted to emulate a 'fork' after the search started. However, with Windows 7 and later versions, this was very unreliable and the functionality was removed from the Windows version of nph-mascot.exe in Mascot Server version 2.5.1. However, this Mascot Parser function still returns the value in mascot.dat for both Windows and Linux.

Parameter | ForkForUnixApache
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if the nph-mascot.exe process should be forked at startup
bool isInIgnoreDupeAccessionList ( const std::string value ) const

Checks to see if the passed database name is in the list databases that shouldn't be checked for duplicate accessions.

When FASTA files are compressed, they are checked to ensure that there are no duplicate accession strings. For a large EST database with many millions of entries, this can take up a lot of memory. Adding a database to the list of values for the IgnoreDupeAccessions entry in mascot.dat prevents this database from being tested.

Parameter | IgnoreDupeAccessions
Permitted values | text strings delimted by tab, space and comma
Default (if no parameter in mascot.dat) | EST_others
Value in mascot.dat | EST_others
Parameters:
value is the name of the databases to check.
Returns:
true if the database is in the list.
bool isIteratePMFIntensities ( ) const

Returns value of the IteratePMFIntensities.

The IteratePMFIntensities parameter is used in order to switch off iterative PMF scoring. If the parameter is set to 1 mascot will try to use only as many queries for scoring as necessary to achieve the best PMF score.

Parameter | IteratePMFIntensities
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 1
Returns:
TRUE if the parameter is set to 1 and FALSE otherwise.
bool isLabelAll ( ) const

Returns the value of LabelAll.

If LabelAll is set to 1, the initial display in Peptide View is the one in which all peaks that match a calculated mass value are labelled.

Parameter | LabelAll
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if if all peaks that match a calculated mass value should be labelled in Peptide View.
bool isMatchOppositeCrosslinkPairs ( ) const

Returns the value of MatchOppositeCrosslinkPairs.

Mascot 2.7 and later support intact crosslinking. Normally Mascot only stores a match to the alpha-beta pair, where the alpha has the higher Mr, longer sequence or is alphabetically first (in this order).

If this setting is 1, both alpha-beta and beta-alpha matches are stored in the results file. Enabling the setting is only useful for debugging purposes.

Parameter | MatchOppositeCrosslinkPairs
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns:
true if for each crosslink pair, the opposite combination should also be considered for matching
bool isMoveOldDbToOldDir ( ) const

Returns the value of MoveOldDbToOldDir.

After a successful database swap, the old fasta file and old reference file are moved to the ../old directory unless this is set to 0 in which case the files are simply deleted.

Parameter | MoveOldDbToOldDir
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | [not defined]
Returns:
true if old fasta and reference files are moved to the old directory
bool isPercolator ( ) const

Returns the value of Percolator.

Returns true if percolated results should be opened by default.

See Using Percolator scores for further information.

Parameter | Percolator
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 1
Returns:
true if percolated results should be opened by default.
bool isPercolatorUseProteins ( ) const

Returns the value of PercolatorUseProteins.

Percolator can use the assignment of proteins to peptides to improve specificity. However, this is risky in some situations so can be switched off.

Currently not supported

See Using Percolator scores for further information.

Parameter | PercolatorUseProteins
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if percolator should use protein features.
bool isPercolatorUseRT ( ) const

Returns the value of PercolatorUseRT.

Percolator can use retention times of peptides to improve specificity. However, this is risky in some situations so can be switched off.

See Using Percolator scores for further information.

Parameter | PercolatorUseRT
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if percolator should use retention times.
bool isRemoveOldIndexFiles ( ) const

Returns the value of RemoveOldIndexFiles.

After a successful database swap, the compressed files in the current directory are deleted unless this is set to 0.

Parameter | RemoveOldIndexFiles
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | [not defined]
Returns:
true if compressed files in the current directory are deleted after a swap
bool isRequireBoldRed ( ) const

Returns the value of RequireBoldRed.

If RequireBoldRed is set to 1 in a Peptide Summary report, only protein matches which have one or more 'bold red' peptide matches will be listed. That is, proteins that include at least one top ranking peptide match that has not already appeared in the report.

Not used for the Protein Family Summary report and when ms_mascotresults::MSRES_CLUSTER_PROTEINS is specified.

Parameter | RequireBoldRed
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if all proteins must contain a bold red peptide.
bool isSaveEveryLastQueryAsc ( ) const

Returns the value of SaveEveryLastQueryAsc.

If set to 1, the Mascot input file will be saved for any search that fails to complete because it generates a fatal error. The name of the output file follows the same naming convention as a normal Mascot output file, except for the additional suffix .inp. If a search goes to completion, this file is deleted as soon as the normal output file has been written to disk.

See also:
isSaveLastQueryAsc(), getLastQueryAscFile().
Parameter | SaveEveryLastQueryAsc
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | 0
Returns:
true if the value in the file is '1'.
bool isSaveLastQueryAsc ( ) const

Returns the value of SaveLastQueryAsc.

SaveLastQueryAsc is a flag which controls whether the most recent input file to Mascot (i.e. the MIME format file containing MS data and search parameters) should be saved to disk (1) or not (0). This can be a useful debugging tool when writing scripts or forms to submit searches to Mascot.

If SaveLastQueryAsc is set to 1, the name of the file is determined by LastQueryAscFile.

Each new search overwrites this file.

See also:
isSaveEveryLastQueryAsc(), getLastQueryAscFile().
Parameter | SaveLastQueryAsc
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if the value in the file is '1'.
bool isSectionAvailable ( ) const

Indicates whether the section has been actually read from the file.

The Options section is unavailable until it has been read from the file. This function doesn't normally need to be used by client applications.

Returns:
true if the seciton is available.
Examples:
config_mascotdat.cpp.
bool isShowAllFromErrorTolerant ( ) const

Returns the value of ShowAllFromErrorTolerant.

If ShowAllFromErrorTolerant is set to 0, result resports of manual error tolerant searches show only those matches that satisfy two criteria: (i) the score must be at least as high as the match for the same query in the original "parent" search, (ii) the score equals or exceeds the identity threshold for the same query in the original "parent" search. Setting ShowAllFromErrorTolerant to 1 causes all matches to be displayed.

Parameter | ShowAllFromErrorTolerant
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if all matches should be displayed in manual error tolerant searches.
bool isShowSubsets ( ) const

Returns the value of ShowSubSets.

Deprecated:
See getShowSubsets().
Parameter | ShowSubSets
Permitted values | Floating point in range 0 to 1 inclusive
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | [not defined]
Returns:
true if the return from getShowSubsets is greater than 0.
bool isStoreModPermutations ( ) const

Returns the value of StoreModPermutations.

If set to 0, only the highest scoring permutation of variable modifications for each unique peptide sequence is retained in the list of the top 10 ions scores. If set to 1, then different permutations of variable modifications are treated as independent matches, creating the possibility that all 10 top ions scores correspond to the same primary sequence.

Parameter | StoreModPermutations
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 1
Value in mascot.dat | [not defined]
Returns:
true if peptides with different modification permuatation should be stored.
bool isUnixDirPermDefined ( ) const

Returns true if the UnixDirPerm value is defined.

See getUnixDirPerm().

Parameter | UnixDirPerm
Permitted values | Any integer in octal format
Default (if no parameter in mascot.dat) | 777 (octal)
Value in mascot.dat | [not defined]
Returns:
true if there is a value in mascot.dat.
bool isUseHTTPProxyForFTP ( ) const

Returns the value of UseHTTPProxyForFTP.

This parameter allows making FTP requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

The default is false. You should only alter the setting if FTP requests fail.

Parameter | UseHTTPProxyForFTP
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if FTP requests should use the HTTP proxy server.

This option is ignored on Windows if auto proxy configuration is enabled.

bool isUseHTTPProxyForHTTPS ( ) const

Returns the value of UseHTTPProxyForHTTPS.

This parameter allows making HTTPS requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

The default is false. You should only alter the setting if HTTPS requests fail.

Parameter | UseHTTPProxyForHTTPS
Permitted values | 0 or 1
Default (if no parameter in mascot.dat) | 0
Value in mascot.dat | 0
Returns:
true if HTTPS requests should use the HTTP proxy server.

This option is ignored on Windows if auto proxy configuration is enabled.

void setAutoSelectCharge ( const bool value )

Sets AutoSelectCharge.

For a description of this function, see isAutoSelectCharge().

Parameters:
value is the new setting.
void setCacheDirectory ( const char * value )

Sets CacheDirectory.

For a description of this function, see getCacheDirectory(). If the provided value is null, the existing value will be kept.

Parameters:
value is the new cache directory.
void setCentroidWidth ( const double value )

Sets CentroidWidth.

For a description of this function, see getCentroidWidth(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new centroid width.
void setCentroidWidthCount ( const int value )

Sets CentroidWidthCount.

For a description of this function, see getCentroidWidthCount(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new peak count threshold.
void setCompressToolAA ( const std::string value )

Sets CompressTool_AA.

For a description of this function, see getCompressToolAA() If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting
void setCompressToolNA ( const std::string value )

Sets CompressTool_NA.

For a description of this function, see getCompressToolNA() If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting
void setCompressToolSL ( const std::string value )

Sets CompressTool_NA.

For a description of this function, see getCompressToolSL() If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting
void setCrawlerNumPeaksPer100Da ( const int value )

Sets the number of peaks to output in each 100 Da window for the library crawler.

Sets the number of peaks to output in each 100 Da window for the library crawler If the provided value is not valid, the existing value will be kept.

Parameters:
value must be a number greater than zero
void setCreatePipThreadBlockSize ( const int blockSize )

Sets CreatePipThreadBlockSize.

For a description of this function, see getCreatePipThreadBlockSize(). If the provided value is not valid, the existing value will be kept.

Parameters:
blockSize is .
void setCreatePipThreads ( const int nThreads )

Sets CreatePipThreads.

For a description of this function, see getCreatePipThreads(). If the provided value is not valid, the existing value will be kept.

Parameters:
nThreads is the number of threads used to generate the Percolator input file.
void setDechargeFragmentPeaks ( const int maxCharge )

Sets the maximum fragment ion charge state to be decharged.

For a description of this function, see getDechargeFragmentPeaks(). If the provided value is not valid, the existing value will be kept.

Parameters:
maxCharge must be zero or a positive integer
void setDecoyTypeNoEnzyme ( const int value )

Sets DecoyTypeNoEnzyme.

For a description of this function, see getDecoyTypeNoEnzyme(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting.
void setDecoyTypeSpecific ( const int value )

Sets DecoyTypeSpecific.

For a description of this function, see getDecoyTypeSpecific(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting.
void setDefaultTargetFDRPercentage ( const int index )

Makes an element of TargetFDRPercentages at the given index the default value.

See getTargetFDRPercentage() for more information. If the provided index is not valid, the existing value will be kept.

Parameters:
index is the index of the item to set. index must be between 0 and getNumberOfTargetFDRPercentages()-1.
void setDisplayNonSignificantMatches ( const int value )

Sets DisplayNonSignificantMatches.

For a description of this function, see getDisplayNonSignificantMatches().

Parameters:
value is the new setting. If it is not one of the permitted values, the setting remains unchanged.
void setEmailErrorsEnabled ( const bool value )

Sets EmailErrorsEnabled.

For a description of this function, see isEmailErrorsEnabled().

Parameters:
value specified whether errors should be emailed.
void setEmailFromTextName ( const char * str )

Sets EmailFromTextName.

For a description of this function, see getEmailFromTextName(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new name of the user from which email appears to come.
void setEmailFromUser ( const char * str )

Sets EmailFromUser.

For a description of this function, see getEmailFromUser(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new email address of the user from which email appears to come.
void setEmailPassword ( const char * str )

Sets EmailPassword.

For a description of this function, see getEmailPassword(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new email password.
void setEmailProfile ( const char * str )

Sets EmailPassword.

For a description of this function, see getEmailProfile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the email profile.
void setEmailService ( const char * str )

Sets EmailService.

For a description of this function, see getEmailService(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new email service name.
void setEmailTimeOutPeriod ( const int value )

Sets EmailTimeOutPeriod.

For a description of this function, see getEmailTimeOutPeriod(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new timeout period.
void setEmailUsersEnabled ( const bool value )

Sets EmailUsersEnabled.

For a description of this function, see isEmailUsersEnabled().

Parameters:
value specifies whether users should be emailed.
void setErrMessageEmailTo ( const char * str )

Sets ErrMessageEmailTo.

For a description of this function, see getErrMessageEmailTo(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new name of the person to send errors to.
void setErrorLogFile ( const char * str )

Sets ErrorLogFile path.

For a description of this function, see getErrorLogFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the errorlog file.
void setErrTolMaxAccessions ( const int value )

Sets ErrTolMaxAccessions.

For a description of this function, see getErrTolMaxAccessions(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum.
void setExecAfterSearch | ( | const int | num,
 |  | std::string | value
 | ) |  |

Sets ExecAfterSearch_XXX.

For a description of this function, see getExecAfterSearch(). If the provided value is not valid, the existing value will be kept.

Parameters:
num | is the 1 based number for the ExecAfterSearch_[num] parameter.
value | is the command to be run.
void setFeatureTableLength ( const int value )

Sets FeatureTableLength.

For a description of this function, see getFeatureTableLength(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new length.
void setFeatureTableMinScore ( const double value )

Sets FeatureTableMinScore.

For a description of this function, see getFeatureTableMinScore(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum score.
void setForkForUnixApache ( const bool value )

Sets ForkForUnixApache.

For a description of this function, see isForkForUnixApache().

Parameters:
value specifies whether the fork command should be used.
void setFormVersion ( const char * str )

Sets FormVersion.

For a description of this function, see getFormVersion(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new version string.
void setGetSeqBlastAccession ( const ms_blastaccession * value )

Sets GetSeqBlastAccession.

For a description of this function, see getGetSeqBlastAccession(). If the provided value is null, the existing value will be kept.

Parameters:
value is the new setting.
void setGetSeqJobIdFile ( const char * str )

Sets GetSeqJobIdFile.

For a description of this function, see getGetSeqJobIdFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the job id file.
void setICATFilter ( const char * filterString )

Sets ICATFilter.

For a description of this function, see getICATFilter(). If the provided value is not valid, the existing value will be kept.

Parameters:
filterString is the new name of the ICAT filter.
void setICATHeavy ( const char * modName )

Sets ICATHeavy.

For a description of this function, see getICATHeavy(). If the provided value is null, the existing value will be kept.

Parameters:
modName is the new name of the heavy ICAT mod.
void setICATLight ( const char * modName )

Sets ICATLight.

For a description of this function, see getICATLight(). If the provided value is null, the existing value will be kept.

Parameters:
modName is the new name of the light ICAT mod.
void setICATQuantitationMethod ( const char * methodName )

Sets ICATQuantitationMethod.

For a description of this function, see getICATQuantitationMethod(). If the provided value is not valid, the existing value will be kept.

Parameters:
methodName is the new name of the quantitation method.
void setIgnoreDupeAccession | ( | const unsigned int | index,
 |  | const std::string | value
 | ) |  |

Sets an item in the IgnoreDupeAccessions list by its index.

See getIgnoreDupeAccession() and isInIgnoreDupeAccessionList() for details.

This method sets the value at the given index.

Parameters:
index | is the index of the value to set. index must be between 0 and getNumberOfIgnoreDupeAccessions()-1.
value | is the value to set (the name of the database).
void setIgnoreIonsScoreBelow ( const double value )

Sets IgnoreIonsScoreBelow.

For a description of this function, see getIgnoreIonsScoreBelow(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum.
void setIntensitySigFigs ( const int value )

Sets IntensitySigFigs.

For a description of this function, see getIntensitySigFigs(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new number of significant figures.
void setInterFileBasePath ( const char * str )

Sets InterFileBasePath.

For a description of this function, see getInterFileBasePath(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new path.
void setInterFileRelPath ( const char * str )

Sets InterFileRelPath.

For a description of this function, see getInterFileRelPath(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new path.
void setIonsDecimalPlaces ( const int value )

Sets IonsDecimalPlaces.

For a description of this function, see getIonsDecimalPlaces(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new number of decimal places.
void setIteratePMFIntensities ( const bool value )

Sets IteratePMFIntensities.

For a description of this function, see isIteratePMFIntensities().

Parameters:
value is the new setting.
void setLabelAll ( const bool value )

Sets LabelAll.

For a description of this function, see isLabelAll().

Parameters:
value specifies if all peaks that match a calculated mass value should be labelled in Peptide View.
void setLastQueryAscFile ( const char * filename )

Sets LastQueryAscFile to the passed value.

For a description of this function, see isSaveLastQueryAsc(). If the provided value is not valid, the existing value will be kept.

Parameters:
filename is the new name of the lastqueryasc file.
void setLogoImageFile ( const char * str )

Sets LogoImageFile.

For a description of this function, see getLogoImageFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new logo image file.
void setMailTempFile ( const char * str )

Sets MailTempFile.

For a description of this function, see getMailTempFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the temp file.
void setMailTransport ( const int value )

Sets MailTransport.

For a description of this function, see getMailTransport(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new mail transport option.
void setMascNodeCtrlFile ( const char * str )

Sets MascNodeCtrlFile.

For a description of this function, see getMascNodeCtrlFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the node control file.
void setMascotCmdLine ( const char * str )

Sets MascotCmdLine.

For a description of this function, see getMascotCmdLine(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new path.
void setMascotControlFile ( const char * str )

Sets MascotControlFile.

For a description of this function, see getMascotControlFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the control file.
void setMascotFileProcessingThreads ( const int value )

Sets MascotFileProcessingThreads.

For a description of this function, see getMascotFileProcessingThreads() If the provided value is not valid, the existing value will be kept.

Parameters:
value must be a number greater than zero or -1
void setMascotJobIdFile ( const char * str )

Sets MascotJobIdFile.

For a description of this function, see getMascotJobIdFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the job id file.
void setMascotMessage ( const char * str )

Sets MascotMessage.

For a description of this function, see getMascotMessage(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new message.
void setMassDecimalPlaces ( const int value )

Sets MassDecimalPlaces.

For a description of this function, see getMassDecimalPlaces(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new number of decimal places.
void setMatchOppositeCrosslinkPairs ( const bool value )

Sets MatchOppositeCrosslinkPairs.

For a description of this function, see isMatchOppositeCrosslinkPairs().

Parameters:
value is the new setting.
void setMaxConcurrentSearches ( const int value )

Sets MaxConcurrentSearches.

For a description of this function, see getMaxConcurrentSearches(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum value.
void setMaxDatabases ( const int value )

Sets MaxDatabases.

For a description of this function, see getMaxDatabases(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum number of databases.
void setMaxDescriptionLen ( const int value )

Sets MaxDescriptionLen.

For a description of this function, see getMaxDescriptionLen(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum length.
void setMaxEtagMassDelta ( const double value )

Sets MaxEtagMassDelta.

For a description of this function, see getMaxEtagMassDelta().

Parameters:
value is the new maximum delta.
void setMaxEtVarMods ( const int value )

Sets MaxEtVarMods.

For a description of this function, see getMaxEtVarMods()

Parameters:
value is the new maximum in the range 0 to 31.
void setMaxIntactCrosslinkPeptides ( const int value )

Sets MaxIntactCrosslinkPeptides.

For a description of this function, see getMaxIntactCrosslinkPeptides() If the provided value is not valid, the existing value will be kept.

Parameters:
value must be a number greater than zero
void setMaxNumPeptides ( const int value )

Sets MaxNumPeptides.

For a description of this function, see getMaxNumPeptides().

Parameters:
value is the new maximum value.
void setMaxPepModArrangements ( const int value )

Sets MaxPepModArrangements.

For a description of this function, see getMaxPepModArrangements() If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum.
void setMaxPepNumModifiedSites ( const int value )

Sets MaxPepNumModifiedSites.

For a description of this function, see getMaxPepNumModifiedSites(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum number of modified sites.
void setMaxPepNumVarMods ( const int value )

Sets MaxPepNumVarMods.

For a description of this function, see getMaxPepNumVarMods(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum number of modifications.
void setMaxQueries ( const int value )

Sets MaxQueries.

For a description of this function, see getMaxQueries(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum number of queries.
void setMaxSearchesPerUser ( const int value )

Sets MaxSearchesPerUser.

For a description of this function, see getMaxSearchesPerUser(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the maximum value.
void setMaxSequenceLen ( const int value )

Sets MaxSequenceLen.

For a description of this function, see getMaxSequenceLen(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new maximum length.
void setMaxVarMods ( const int value )

Sets MaxVarMods.

For a description of this function, see getMaxVarMods().

Parameters:
value is the new maximum in the range 0 to 32.
void setMinEtagMassDelta ( const double value )

Sets MinEtagMassDelta.

For a description of this function, see getMinEtagMassDelta().

Parameters:
value is the new minimum delta.
void setMinPepLenInPepSummary ( const int value )

Sets MinPepLenInPepSummary.

For a description of this function, see getMinPepLenInPepSummary(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum length.
void setMinPepLenInSearch ( const int value )

Sets MinPepLenInSearch.

For a description of this function, see getMinPepLenInSearch(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum setting.
void setMonitorEmailCheckFreq ( const int value )

Sets MonitorEmailCheckFreq.

For a description of this function, see getMonitorEmailCheckFreq(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new time period.
void setMonitorLogFile ( const char * str )

Sets MonitorLogFile.

For a description of this function, see getMonitorLogFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the monitor log.
void setMonitorPidFile ( const char * str )

Sets MonitorPidFile.

For a description of this function, see getMonitorPidFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the pid file.
void setMonitorTestTimeout ( const int value )

Sets MonitorTestTimeout.

For a description of this function, see getMonitorTestTimeout(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new timeout period.
void setMoveOldDbToOldDir ( const bool value )

Sets MoveOldDbToOldDir.

For a description of this function, see isMoveOldDbToOldDir().

Parameters:
value is the new setting.
void setMudpit ( const int value )

Sets Mudpit.

For a description of this function, see getMudpit(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting.
void setMudpitSwitch ( const double value )

Sets MudpitSwitch.

For a description of this function, see getMudpitSwitch(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new q/e value used to determine which protein scoring method to use.
void setNoResultsScript ( const char * str )

Sets NoResultsScript.

For a description of this function, see getNoResultsScript(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the script.
void setNTIUserGroup ( const char * str )

Sets NTIUserGroup.

For a description of this function, see getNTIUserGroup(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the web user group.
void setNTMonitorGroup ( const char * str )

Sets NTMonitorGroup.

For a description of this function, see getNTMonitorGroup(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the group used by ms-monitor.exe.
void setPepSearchTool ( const std::string value )

Sets LibrarySearch.

For a description of this function, see getPepSearchTool() If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting
void setPercolator ( const bool value )

Sets Percolator.

For a description of this function, see isPercolator().

Parameters:
value True if percolated results should be opened by default.
void setPercolatorExeFlags ( const char * value )

Sets PercolatorExeFlags.

For a description of this function, see getPercolatorExeFlags(). If the provided value is null, the existing value will be kept.

Parameters:
value is the new flags.
void setPercolatorFeatures ( std::string value )

Sets PercolatorFeatures.

For a description of this function, see getPercolatorFeatures(). If the provided value is empty, the existing value will be kept.

Parameters:
value is the new list of features.
void setPercolatorMinQueries ( const int value )

Sets PercolatorMinQueries.

For a description of this function, see getPercolatorMinQueries(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum number of queries.
void setPercolatorMinSequences ( const int value )

Sets PercolatorMinSequences.

For a description of this function, see getPercolatorMinSequences(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum number of sequences.
void setPercolatorTargetRankRelativeThreshold ( const double threshold )

Sets PercolatorTargetRankRelativeThreshold.

For a description of this function, see getPercolatorTargetRankScoreThreshold(). If the provided value is not valid, the existing value will be kept.

Parameters:
threshold is the minimum relative score difference with rank 1 match.
void setPercolatorTargetRankScoreThreshold ( const int threshold )

Sets PercolatorTargetRankScoreThreshold.

For a description of this function, see getPercolatorTargetRankScoreThreshold(). If the provided value is not valid, the existing value will be kept.

Parameters:
threshold is the minimum score to include a match in the pip file.
void setPercolatorUseProteins ( const bool value )

Sets PercolatorUseProteins.

For a description of this function, see isPercolatorUseProteins().

Parameters:
value is the new flag.
void setPercolatorUseRT ( const bool value )

Sets PercolatorUseRT.

For a description of this function, see isPercolatorUseRT().

Parameters:
value is the new flag.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setPrecursorCutOutLowerLimit ( const double value )

Sets the first PrecursorCutOut.

For a description of this function, see getPrecursorCutOutLowerLimit().

Parameters:
value is the new lower limit.
void setPrecursorCutOutUpperLimit ( const double value )

Sets the second PrecursorCutOut.

For a description of this function, see getPrecursorCutOutUpperLimit().

Parameters:
value is the new upper limit.
void setProteinFamilySwitch ( const int value )

Sets ProteinFamilySwitch.

For a description of this function, see getProteinFamilySwitch(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum number of spectra.
void setProteinsInResultsFile ( const int value )

Sets ProteinsInResultsFile.

For a description of this function, see getProteinsInResultsFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting.
void setProxyPassword ( const char * str )

Sets proxy_password.

For a description of this function, see getProxyPassword(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new password.
void setProxyServer ( const char * str )

Sets proxy_server.

For a description of this function, see getProxyServer. If the provided value is null, the existing value will be kept.

Parameters:
str is the new proxy server address/name.
void setProxyType ( const std::string & value )

Sets ProxyType.

For a description of this function, see getProxyServer.

Parameters:
value A case-insensitive string matching one of the ms_connection_settings::PROXY_TYPE values. If value matches none of them, proxy type is set to Auto.
void setProxyUsername ( const char * str )

Sets proxy_username.

For a description of this function, see getProxyUsername(). If the provided value is null, the existing value will be kept.

Parameters:
str is the new proxy user name.
void setRemoveOldIndexFiles ( const bool value )

Sets RemoveOldIndexFiles.

For a description of this function, see isRemoveOldIndexFiles().

Parameters:
value is the new setting.
void setReportBuilderColumnArrangement | ( | const int | index,
 |  | const std::string | str
 | ) |  |

Sets ReportBuilderColumnArrangement.

Set the column arrangement string at index to the given value. If str is the empty string, the column arrangement at that index will be deleted.

For details, see getReportBuilderColumnArrangement(). If the provided index or value is not valid, the list will be unchanged.

Parameters:
index | A value between 1 and getMaxNumOfReportBuilderColumnArrangements, inclusive.
str | Name, followed by colon, followed by comma-separated column arrangement string, e.g. "Mini:family,member,db,acc,score,mass,desc"
void setReportNumberChoice | ( | const int | index,
 |  | const int | value
 | ) |  |

Sets an element of the ReportNumberChoices list by its index.

See getReportNumberChoice() for more information. If the provided index or value is not valid, the existing value will be kept.

Parameters:
index | is the index of the item to set. index must be between 0 and getNumberOfReportNumberChoices()-1.
value | is the value it should be set to.
void setRequireBoldRed ( const bool value )

Sets RequireBoldRed.

For a description of this function, see isRequireBoldRed().

Parameters:
value specifies if proteins need a bold red peptide.
void setResfileCache ( const char * value )

Sets ResfileCache.

For a description of this function, see getResfileCache(). If the provided value is null, the existing value will be kept.

Parameters:
value a comma separated list of scripts that should specify ms_mascotresfile::RESFILE_USE_CACHE when creating a ms_mascotresfile object.
void setResultsCache ( const char * value )

Sets ResultsCache.

For a description of this function, see getResultsCache(). If the provided value is null, the existing value will be kept.

Parameters:
value a comma separated list of scripts that should specify ms_peptidesummary::MSPEPSUM_USE_CACHE when creating a ms_peptidesummary object.
void setResultsFileFormatVersion ( const char * value )

Sets ResultsFileFormatVersion.

For a description of this function, see getResultsFileFormatVersion(). If the provided value is null, the existing value will be kept.

Parameters:
value is the new version string.
void setResultsFullURL ( const char * str )

Sets ResultsFullURL.

For a description of this function, see getResultsFullURL(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new URL.
void setResultsFullURL_2 ( std::string value )

Sets ResultsFullURL_2.

For a description of this function, see getResultsFullURL_2(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new perl script.
void setResultsPerlScript ( const char * str )

Sets ResultsPerlScript.

For a description of this function, see getResultsPerlScript(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the script.
void setResultsPerlScript_2 ( std::string value )

Sets ResultsPerlScript_2.

For a description of this function, see getResultsPerlScript_2(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new perl script.
void setReviewColDisplay | ( | const MS_REVIEW_COL | index,
 |  | const bool | value
 | ) |  |

Sets ReviewColDisplay.

End users can specify the display states in mascot.dat to suit their requirements, for example if they want to hide some columns by default.

See also:
getReviewColDisplay(). If the provided index is not valid, the list will be unchanged.
Parameters:
index | is a value from the MS_REVIEW_COL enumeration.
value | is the new display state to set.
void setReviewColWidth | ( | const MS_REVIEW_COL | index,
 |  | const int | value
 | ) |  |

Sets ReviewColWidths.

End users can specify the widths in mascot.dat to suit their requirements, for example if they use long titles.

See also:
getReviewColWidth(). If the provided index or value is not valid, the list will be unchanged.
Parameters:
index | is a value from the MS_REVIEW_COL enumeration.
value | is the new width to set.
void setSaveEveryLastQueryAsc ( const bool flag )

Sets SaveEveryLastQueryAsc to 1 or 0.

For a description of this function, see isSaveEveryLastQueryAsc().

Parameters:
flag is a boolean flag that corresponds to 1 (true) or 0 (false).
void setSaveLastQueryAsc ( const bool flag )

Sets SaveLastQueryAsc to 1 or 0.

For a description of this function, see isSaveLastQueryAsc().

Parameters:
flag is a boolean flag that corresponds to 1 (true) or 0 (false).
void setSearchLogFile ( const char * str )

Sets SearchLogFile.

For a description of this function, see getSearchLogFile(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the search log.
void setSearchSubmitMode ( const std::string value )

Sets the Mascot search submission mode.

For a description of this function, see getSearchSubmitMode(). If the provided value is not valid, the existing value will be kept.

Parameters:
value must be either "asynchronous" or "direct".
void setSelectSwitch ( const int value )

Sets SelectSwitch.

For a description of this function, see getSelectSwitch(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new minimum number of queries for a select summary.
void setSendmailPath ( const char * str )

Sets sendmailPath.

For a description of this function, see getSendmailPath(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new name of the sendmail program.
void setSeparateLockMem ( const int value )

Sets SeparateLockMem.

For a description of this function, see getSeparateLockMem(). If the provided value is not valid, the existing value will be kept.

Parameters:
value specifies whether ms-lockmem.exe should be called.
void setShowAllFromErrorTolerant ( const bool value )

Sets ShowAllFromErrorTolerant.

For a description of this function, see isShowAllFromErrorTolerant().

Parameters:
value specifies if all matches should be displayed in manual error tolerant searches.
void setShowSubsets ( const bool value )

Sets ShowSubSets.

Deprecated:
See setShowSubsets(const double).

Simply calls setShowSubsets(const double) with a value of 0.0 or 1.0.

Parameters:
value if set to true, 1.0 is used, otherwise 0.0 is used
void setShowSubsets ( const double value )

Sets ShowSubSets.

See getShowSubsets().

Parameters:
value is the fractional score required for a protein to be counted as a subset. Its score must be greater than or equal to main_protein_score * (1-getShowSubsets()). A value between 0 and 1 (inclusive) is required and the default value is 0.
void setSigThreshold ( const double value )

Set the SigThreshold.

For a description of this function, see getSigThreshold(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new default threshold value.
void setSiteAnalysisMD10Prob ( const double value )

Set the SiteAnalysisMD10Prob.

For a description of this function, see getSiteAnalysisMD10Prob(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new default MD10Prob value.
void setSortUnassigned ( const std::string value )

Sets SortUnassigned.

For a description of this function, see getSortUnassigned(). If the provided value is not valid, the existing value will be kept.

Parameters:
value should be one of:

  • scoredown - descending score
  • queryup - query order
  • intdown - intensity order
void setSpectraPerLibraryBlock ( const int value )

Sets the number of spectra in a spectral library block.

For a description of this function, see getSpectraPerLibraryBlock() If the provided value is not valid, the existing value will be kept.

Parameters:
value must be a number greater than zero
void setSpectrumViewerColourSchemeString | ( | const std::string & | name,
 |  | const std::string & | str,
 |  | bool | doCheck = true
 | ) |  |

Sets SpectrumViewerColourScheme.

If str is the empty string, the named colour scheme will be deleted.

For details, see getSpectrumViewerColourSchemeString(). If the provided name or value is not valid, the list will be unchanged.

Parameters:
name | Colour scheme name; the defined names are returned by getSpectrumViewerColourSchemeNames().
str | Colour scheme specification as defined in getSpectrumViewerColourSchemeString(), or the empty string.
doCheck | Whether the method should check if the colour scheme is of the correct format, default to true.
void setSpectrumViewerDefaultColourSchemeName ( const std::string & name )

Sets the default colour scheme name (SpectrumViewerDefaultColourScheme).

For a description of this function, see getSpectrumViewerDefaultColourSchemeName(). If the provided default name is not in the list of current names, the value will not be changed.

Parameters:
name Colour scheme name, typically one of getSpectrumViewerColourSchemeNames().
void setSplitDataFileSize ( const int value )

Sets SplitDataFileSize.

For a description of this function, see getSplitDataFileSize(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new file size to split at.
void setSplitNumberOfQueries ( const int value )

Sets SplitNumberOfQueries.

For a description of this function, see getSplitNumberOfQueries(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new number of queries.
void setStoreModPermutations ( const bool value )

Sets StoreModPermutations.

For a description of this function, see isStoreModPermutations().

Parameters:
value is the new setting.
void setSVGSpectrumSwitch ( const int value )

Sets SVGSpectrumSwitch.

For a description of this function, see getSVGSpectrumSwitch(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new setting.
void setTargetFDRPercentage | ( | const int | index,
 |  | const double | value,
 |  | const bool | makeDefault = false
 | ) |  |

Sets an element of the TargetFDRPercentages list by its index.

See getTargetFDRPercentage() for more information. If the provided index or value is not valid, the list will be unchanged.

Parameters:
index | is the index of the item to set. index must be between 0 and getNumberOfTargetFDRPercentages()-1.
value | is the value it should be set to.
makeDefault | controls whether the new element should be made the default item in the list.
void setTaxBrowserUrl ( const std::string value )

Sets TaxBrowserURL.

For a description of this function, see getTaxBrowserUrl().

Parameters:
value is the URL.
void setTestDirectory ( const char * str )

Sets TestDirectory.

For a description of this function, see getTestDirectory(). If the provided value is not valid, the existing value will be kept.

Parameters:
str is the new path.
void setUniqueJobStartNumber ( const int value )

Sets UniqueJobStartNumber.

For a description of this function, see getUniqueJobStartNumber(). If the provided value is negative, the existing value will be kept.

Parameters:
value is the new job start number.
void setUnixDirPerm ( const int value )

Sets UnixDirPerm.

For a description of this function, see getUnixDirPerm(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new permissions.
void setUnixWebUserGroup ( const int value )

Sets UnixWebUserGroup.

For a description of this function, see getUnixWebUserGroup().

Parameters:
value is the new setting for the web user group.
void setUseHTTPProxyForFTP ( const bool value )

Sets UseHTTPProxyForFTP.

For a description of this function, see isUseHTTPProxyForFTP.

Parameters:
value True if FTP requests should use HTTP proxy settings; false otherwise.
void setUseHTTPProxyForHTTPS ( const bool value )

Sets UseHTTPProxyForHTTPS.

For a description of this function, see isUseHTTPProxyForHTTPS.

Parameters:
value True if HTTPS requests should use HTTP proxy settings; false otherwise.
void setVmemory ( const INT64 value )

Sets Vmemory.

For a description of this function, see getVmemory(). If the provided value is not valid, the existing value will be kept.

Parameters:
value is the new value.
The documentation for this class was generated from the following files:
  • ms_mascotoptions.hpp
  • ms_mascotoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_masses
Public Member Functions

ms_masses Class Reference
[Mascot configuration files module]

Reads and parses the masses file with residue and atom masses. More...

#include <ms_masses.hpp>

Inheritance diagram for ms_masses:
[legend]
Collaboration diagram for ms_masses:
[legend]

List of all members.

Public Member Functions

ms_masses ()
Default constructor.
ms_masses (const ms_masses &src)
Copying constructor.
ms_masses (const ms_umod_configfile &src, const ms_quant_component &quantComp)
Constructor for prepared isotope-substituted version of masses.
ms_masses (const char *filename, const matrix_science::ms_connection_settings *cs=0)
Reads the file immediately after the construction.
ms_masses (const ms_umod_configfile &src, bool addMissingResidueMasses=true)
Copying constructor.
~ms_masses ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
ms_modvector | applyFixedMods (const ms_modvector *mods, ms_errs *err)
Change residue masses according to the list of fixed modifications.
void | applyIsotopes (const ms_umod_configfile *umodFile, const ms_quant_component *quantComp)
Update masses of amino-acids with isotope substitution.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_masses *right)
Copies masses from another instance.
void | copyFrom (const ms_umod_configfile *right, bool addMissingResidueMasses=true)
Copies masses from a Unimod file.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | defaultValues (bool useDefaultResidueMasses=true)
Use this member to re-initialise internal members.
double | getCarbonMass (const matrix_science::MASS_TYPE massType) const
Returns a carbon(C) atom mass for a given mass type (MONO or AVE).
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
double | getCtermDelta (const matrix_science::MASS_TYPE massType) const
Returns C-term modification delta if there is a correspondent fixed modification applied.
double | getCterminalMass (const matrix_science::MASS_TYPE massType) const
Returns C-terminal group mass (i.e. fixed modification delta or OH-mass).
double | getCtermNeutralLoss (const matrix_science::MASS_TYPE massType) const
Returns C-term neutral loss value if there is a correspondent fixed modification applied.
double | getElectronMass () const
Returns an electron mass.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name set before or by default.
double | getFragResidueMass (const matrix_science::MASS_TYPE massType, const char residue) const
Returns a residue mass with neutral loss after applying fixed modifications.
double | getHydrogenMass (const matrix_science::MASS_TYPE massType) const
Returns a hydrogen (H) atom mass for a given mass type (MONO or AVE).
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
double | getNitrogenMass (const matrix_science::MASS_TYPE massType) const
Returns a nitrogen (N) atom mass for a given mass type (MONO or AVE).
double | getNtermDelta (const matrix_science::MASS_TYPE massType) const
Returns N-term modification delta if there is a correspondent fixed modification applied.
double | getNterminalMass (const matrix_science::MASS_TYPE massType) const
Returns N-terminal group mass (i.e. fixed modification delta or H-mass).
double | getNtermNeutralLoss (const matrix_science::MASS_TYPE massType) const
Returns N-term neutral loss value if there is a correspondent fixed modification applied.
double | getOxygenMass (const matrix_science::MASS_TYPE massType) const
Returns a oxygen (O) atom mass for a given mass type (MONO or AVE).
double | getResidueMass (const matrix_science::MASS_TYPE massType, const char residue) const
Returns a mass for a given amino acid.
bool | isResidueModified (const char residue) const
Returns true for residues modified by fixed modifications.
bool | isSame (const ms_masses &other, const MASS_TYPE massType) const
Return true if other ms_masses is the same as this one.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_masses & | operator= (const ms_masses &right)
C++ style assignment operator.
void | read_file ()
Reads the configuration file, parses it and fill the mass arrays.
void | save_file ()
Saves the information back to the file.
void | setCarbonMass (const double massMono, const double massAve)
Changes carbon mass values.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setCtermModification (const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0)
Set C-term modification.
void | setElectronMass (const double mass)
Changes oxygen mass values.
void | setFileName (const char *name)
Set a custom file name instead of ../config/masses.
void | setHydrogenMass (const double massMono, const double massAve)
Changes hydrogen mass values.
void | setNitrogenMass (const double massMono, const double massAve)
Changes nitrogen mass values.
void | setNtermModification (const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0)
Set N-term modification.
void | setOxygenMass (const double massMono, const double massAve)
Changes oxygen mass values.
void | setResidueMasses (const char residue, const double massMono, const double massAve)
Changes mass values for a single residue.
void | setResidueModification (const double monoDelta, const double aveDelta, const double monoNeutralLoss, const double aveNeutralLoss, const char *residues)
Applies a single residue modification.

Detailed Description

Reads and parses the masses file with residue and atom masses.

After reading a file and before using the object, check its validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid.

A class instance can be used even if the configuration file has been read with problems or not read at all. Default values will be given to all members in that case.

Examples:

config_masses.cpp, config_modfile.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

ms_masses ( )

Default constructor.

Sets default mass values for all residues

ms_masses ( const ms_masses & src )

Copying constructor.

Parameters:
src is the source object to copy masses from
ms_masses | ( | const ms_umod_configfile & | src,
 |  | bool | addMissingResidueMasses = true
 | ) |  |

Copying constructor.

Implemented by calling copyFrom(const ms_umod_configfile *, bool)

Parameters:
src | has the residue and elemental masses that are used to initialise the masses
addMissingResidueMasses | is used to specify whether residue masses missing from the src should be set to zero or set to the default masses. If true, then default masses are used and if false, then any missing masses are just set to zero.
ms_masses | ( | const ms_umod_configfile & | src,
 |  | const ms_quant_component & | quantComp
 | ) |  |

Constructor for prepared isotope-substituted version of masses.

Masses of amino-acids are re-calculated with a different isotope applied (for example, 13C instead of C).

Parameters:
src | a Unimod file object containing the composition of amino acids and original masses.
quantComp | a quantitation component containing isotope substitutions used in the quantitation experiment. This object can be created from scratch without reading its content from a file, but normally it should be taken from the quantitation method selected by a user. An alternative way to apply isotope substition is to use applyIsotopes() method.
ms_masses | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Reads the file immediately after the construction.

Parameters:
filename | can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
ms_modvector applyFixedMods | ( | const ms_modvector * | mods,
 |  | ms_errs * | err
 | ) |  |

Change residue masses according to the list of fixed modifications.

If you want to get the original (unmodified) masses of amino acids, load them from a file or obtain from another instance of the class.

Fixed modifications can also be applied separately using setNtermModification(), setCtermModification() and setResidueModification().

Parameters:
mods | is the vector of modifications to apply
err | is used to collect the errors. To add any errors to the ms_masses object, pass this->getErrorHandler()
Returns:
the new list of modifications
void applyIsotopes | ( | const ms_umod_configfile * | umodFile,
 |  | const ms_quant_component * | quantComp
 | ) |  |

Update masses of amino-acids with isotope substitution.

Call this method explictly in order to re-calculate all amino acid masses according to a selected quantitation method. However, the quantitation component object can also be created on the fly with any custom isotope substitution. All applied fixed modifications are cancelled and should be re-applied if necessary with applyFixedMods() method.

Parameters:
umodFile | a Unimod file object containing chemical composition of amino acids and element masses.
quantComp | a quantitation component object with isotope substitution information. If the object doesn't have any isotope elements in it no action will be taken.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_masses * right )

Copies masses from another instance.

Parameters:
right is the source masses object
void copyFrom | ( | const ms_umod_configfile * | right,
 |  | bool | addMissingResidueMasses = true
 | ) |  |

Copies masses from a Unimod file.

Parameters:
right | a pointer to unimod file object to copy the masses from.
addMissingResidueMasses | is used to specify whether residue masses missing from right should be set to zero or set to the default masses. If true, then default masses are used and if false, then any missing masses are just set to zero.
void defaultValues ( bool useDefaultResidueMasses = true )

Use this member to re-initialise internal members.

Called internally, but may also be used by other applications

Parameters:
useDefaultResidueMasses should be set to true if the residue masses are to be initialised with default values. Otherwise they will all be set to mass zero.
double getCarbonMass ( const matrix_science::MASS_TYPE massType ) const

Returns a carbon(C) atom mass for a given mass type (MONO or AVE).

Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the mass of carbon
matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns:
The current connection settings.
double getCtermDelta ( const matrix_science::MASS_TYPE massType ) const

Returns C-term modification delta if there is a correspondent fixed modification applied.

See also:
getCterminalMass()
Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the delta compared to an unmodified C terminus mass
double getCterminalMass ( const matrix_science::MASS_TYPE massType ) const

Returns C-terminal group mass (i.e. fixed modification delta or OH-mass).

See also:
getCtermDelta()
Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the C terminus mass, including any applied modification
double getCtermNeutralLoss ( const matrix_science::MASS_TYPE massType ) const

Returns C-term neutral loss value if there is a correspondent fixed modification applied.

See also:
getCterminalMass()
Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the delta compared to an unmodified C terminus mass
double getElectronMass ( ) const

Returns an electron mass.

Returns:
the mass of an electron
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns a file name set before or by default.

See also:
setFileName()
Returns:
the name of the masses file
double getFragResidueMass | ( | const matrix_science::MASS_TYPE | massType,
 |  | const char | residue
 | ) |  | const

Returns a residue mass with neutral loss after applying fixed modifications.

Parameters:
massType | one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
residue | a single letter encoding an amino acid in the range a..z or A..Z.
Returns:
an absolute fragment for the amino acid.
double getHydrogenMass ( const matrix_science::MASS_TYPE massType ) const

Returns a hydrogen (H) atom mass for a given mass type (MONO or AVE).

Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the mass of hydrogen
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
double getNitrogenMass ( const matrix_science::MASS_TYPE massType ) const

Returns a nitrogen (N) atom mass for a given mass type (MONO or AVE).

Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the mass of nitrogen
double getNtermDelta ( const matrix_science::MASS_TYPE massType ) const

Returns N-term modification delta if there is a correspondent fixed modification applied.

See also:
getNterminalMass()
Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the delta compared to an unmodified N terminus mass
double getNterminalMass ( const matrix_science::MASS_TYPE massType ) const

Returns N-terminal group mass (i.e. fixed modification delta or H-mass).

See also:
getNtermDelta()
Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the N terminus mass, including any applied modification
double getNtermNeutralLoss ( const matrix_science::MASS_TYPE massType ) const

Returns N-term neutral loss value if there is a correspondent fixed modification applied.

Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
any neutral loss on the N terminus
double getOxygenMass ( const matrix_science::MASS_TYPE massType ) const

Returns a oxygen (O) atom mass for a given mass type (MONO or AVE).

Parameters:
massType one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
Returns:
the mass of oxygen
double getResidueMass | ( | const matrix_science::MASS_TYPE | massType,
 |  | const char | residue
 | ) |  | const

Returns a mass for a given amino acid.

Parameters:
massType | one of two mass types (MASS_TYPE_MONO or MASS_TYPE_AVE).
residue | a single letter encoding an amino acid in the range a..z or A..Z.
Returns:
an absolute mass for the amino acid.
Examples:
config_masses.cpp.
bool isResidueModified ( const char residue ) const

Returns true for residues modified by fixed modifications.

Parameters:
residue a single letter encoding an amino acid in the range a..z or A..Z.
Returns:
true for residues modified by fixed modifications.
bool isSame | ( | const ms_masses & | right,
 |  | const MASS_TYPE | massType
 | ) |  | const

Return true if other ms_masses is the same as this one.

Parameters:
right | is the object to test against
massType | specifies whether to compare monoisotopic or average masses.
Returns:
true if all the masses are the same
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_masses & operator= ( const ms_masses & right )

C++ style assignment operator.

Only available for C++

Parameters:
right is the source object
Returns:
a reference to 'this'
void read_file ( )

Reads the configuration file, parses it and fill the mass arrays.

Called from the constructor: ms_masses(const char*, const ms_connection_settings*)

void save_file ( )

Saves the information back to the file.

See also:
setFileName() If the file cannot be opened for writing, an ms_errs::ERR_MSP_FAILED_TO_OPEN_FILE error is added.

Other errors in saving the file use ms_errs::ERR_MSP_FAILED_TO_WRITE_FILE

void setCarbonMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes carbon mass values.

Parameters:
massMono | is the new monoisotopic mass of carbon
massAve | is the new average mass of carbon
void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setCtermModification | ( | const double | monoDelta,
 |  | const double | aveDelta,
 |  | const double | monoNeutralLoss = 0.0,
 |  | const double | aveNeutralLoss = 0.0
 | ) |  |

Set C-term modification.

Warning:
The name of this function and the name of the first two parameters are potentially misleading.
Parameters:
monoDelta | is the mass of the CTerminus. If there is no fixed modification, the value passed should be the monoisotopic mass of hydrogen plus the monoisotopic mass of oxygen.
aveDelta | is the mass of the CTerminus. If there is no fixed modification, the value passed should be the average mass of hydrogen plus the average mass of oxygen.
monoNeutralLoss | is the neutral loss of any fixed C terminus modification.
aveNeutralLoss | is the neutral loss of any fixed C terminusmodification.
void setElectronMass ( const double mass )

Changes oxygen mass values.

Parameters:
mass is the new monoisotopic mass of an electron
void setFileName ( const char * name )

Set a custom file name instead of ../config/masses.

Does not re-read the file, just saves the new name

See also:
getFileName()
read_file()
Parameters:
name is the new file name
void setHydrogenMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes hydrogen mass values.

Parameters:
massMono | is the new monoisotopic mass of hydrogen
massAve | is the new average mass of hydrogen
void setNitrogenMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes nitrogen mass values.

Parameters:
massMono | is the new monoisotopic mass of nitrogen
massAve | is the new average mass of nitrogen
void setNtermModification | ( | const double | monoDelta,
 |  | const double | aveDelta,
 |  | const double | monoNeutralLoss = 0.0,
 |  | const double | aveNeutralLoss = 0.0
 | ) |  |

Set N-term modification.

Warning:
The name of this function and the name of the first two parameters are potentially misleading.
Parameters:
monoDelta | is the mass of the NTerminus. If there is no fixed modification, the value passed should be the monoisotopic mass of hydrogen.
aveDelta | is the mass of the NTerminus. If there is no fixed modification, the value passed should be the average mass of hydrogen.
monoNeutralLoss | is the neutral loss of any fixed N terminus modification.
aveNeutralLoss | is the neutral loss of any fixed N terminus modification.
void setOxygenMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes oxygen mass values.

Parameters:
massMono | is the new monoisotopic mass of oxygen
massAve | is the new average mass of oxygen
void setResidueMasses | ( | const char | residue,
 |  | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes mass values for a single residue.

Parameters:
residue | a single letter encoding an amino acid in the range a..z or A..Z.
massMono | is the new monoisotopic mass for the residue
massAve | is the new average mass for the residue
void setResidueModification | ( | const double | monoDelta,
 |  | const double | aveDelta,
 |  | const double | monoNeutralLoss,
 |  | const double | aveNeutralLoss,
 |  | const char * | residues
 | ) |  |

Applies a single residue modification.

Parameters:
monoDelta | is the delta in daltons for monoisotopic masses
aveDelta | is the delta in daltons for average masses
monoNeutralLoss | is the neutral loss for monoisotopic masses (typically zero)
aveNeutralLoss | is the neutral loss for average masses (typically zero)
residues | is a null terminated string with one or more letters which encoding amino acids in the range a..z or A..Z.
The documentation for this class was generated from the following files:
  • ms_masses.hpp
  • ms_masses.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_modfile
Public Member Functions

ms_modfile Class Reference
[Mascot configuration files module]

Use this class in order to read in the amino acid modification file. More...

#include <ms_modfile.hpp>

Inheritance diagram for ms_modfile:
[legend]
Collaboration diagram for ms_modfile:
[legend]

List of all members.

Public Member Functions

ms_modfile ()
Default constructor.
ms_modfile (const ms_modfile &src)
Copying constructor.
ms_modfile (const char *filename, const ms_masses *massFile, const bool fromSubstitutions=false, const ms_connection_settings *cs=0)
Immediate-action constructor that reads the given file on construction.
ms_modfile (const ms_umod_configfile &src, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL)
Copying constructor that accepts unimod-file object.
~ms_modfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendModification (const ms_modification *item)
Adds a new modification at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearModifications ()
Deletes all modifications from the list.
void | copyFrom (const ms_umod_configfile *right, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL)
Copies all content from unimod-file object.
void | copyFrom (const ms_modfile *right)
Copies all content from another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteModificationByName (const char *name)
Remove a modification from the list in memory.
bool | deleteModificationByNumber (const int num)
Remove a modification from the list in memory.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name that is used to read configuration information.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
const ms_masses * | getMassFile () const
Returns previously set ms_masses class instance.
const ms_modification * | getModificationByName (const char *nameMod) const
Returns a modification object by its name or NULL in case of not found.
const ms_modification * | getModificationByNumber (const int numMod) const
Returns a modification object by its number.
int | getNumberOfModifications () const
Returns a number of modifications currently held in memory.
bool | isFromSubstitutions () const
Returns TRUE if reading is done from the substitutions file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_modfile & | operator= (const ms_modfile &right)
C++ style assignment operator.
void | read_file ()
Reads configuration information from the file.
void | save_file ()
Stores modification information in the file.
void | saveToString (std::string &modfileAsStr)
Stores modification information in the string supplied.
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *name)
Call this member to set a custom file name to read from a different location.
void | setFromSubstitutions (const bool value)
Sets internal flag telling which file should be used for extracting modifications.
void | setMassFile (const ms_masses *massFile)
Set the atom masses to use when generating fragmentation mass deltas.
void | sortModifications ()
Re-orders mods by their names.
bool | updateModificationByName (const char *name, const ms_modification mod)
Update the information for a specific modification.
bool | updateModificationByNumber (const int num, const ms_modification mod)
Update the information for a specific modification.

Detailed Description

Use this class in order to read in the amino acid modification file.

Amino acid modifications are defined in two files: mod_file and substitutions. An instance of this class can be used to read a file with any other name. Otherwise, the default name ../config/mod_file is used. Just create an instance of the class and call read_file()-member.

Alternatively, you can call setFileName() to supply a custom file name. It is also recommended to read in the atom masses configuration file with ms_masses and call setMassFile() before calling read_file().

After reading a file and before using the object, check its by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid.

Examples:

config_modfile.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

ms_modfile | ( | const ms_umod_configfile & | src,
 |  | const unsigned int | flags = ms_umod_configfile::MODFILE_FLAGS_ALL
 | ) |  |

Copying constructor that accepts unimod-file object.

Parameters:
src | a Unimod file object to extract modifications from.
flags | can be one or more of the ms_umod_configfile::MODFILE_FLAGS values OR'ed together.
ms_modfile | ( | const char * | filename,
 |  | const ms_masses * | massFile,
 |  | const bool | fromSubstitutions = false,
 |  | const ms_connection_settings * | cs = 0
 | ) |  |

Immediate-action constructor that reads the given file on construction.

Parameters:
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
massFile | In order to use default masses, use a null value.
fromSubstitutions | is an optional parameter is only used when the first parameter is a Mascot Server URL. Use FALSE or (leave the parameter out) to open the mod_file, and use TRUE to open the substitutions file.
cs | connection settings to use when accessing remote files. This should contain a sessionID and optionally the proxy server settings. If security is enabled on the session and visibility control files are present in a unimod subdirectory then private modifications will not be loaded.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom | ( | const ms_umod_configfile * | right,
 |  | const unsigned int | flags = ms_umod_configfile::MODFILE_FLAGS_ALL
 | ) |  |

Copies all content from unimod-file object.

Parameters:
right | unimod file object to extract modifications from.
flags | can be one or more of the ms_umod_configfile::MODFILE_FLAGS values OR'ed together.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
bool deleteModificationByName ( const char * name )

Remove a modification from the list in memory.

Parameters:
name must be a valid modification name.
Returns:
True if the modification name is valid and the modification was removed.
Examples:
config_modfile.cpp.
bool deleteModificationByNumber ( const int num )

Remove a modification from the list in memory.

Parameters:
num must be in the range 0..getNumberOfModifications()-1.
Returns:
True if the modification number is valid.
matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns:
The current connection settings.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
const ms_modification * getModificationByNumber ( const int numMod ) const

Returns a modification object by its number.

Parameters:
numMod is the modification number greater than or equal to zero and less than getNumberOfModifications().
Returns:
The modification object, or a null value if an invalid numMod value is passed. See Maintaining object references: two rules of thumb.
Examples:
config_modfile.cpp.
bool isFromSubstitutions ( ) const

Returns TRUE if reading is done from the substitutions file.

This flag is important only when downloading the file from a remote host since the URL doesn't contain the file name -- only the location. See setFromSubstitutions() and read_file().

Returns:
true if the subtitutions file is used to extract modifications, false if the mod file is used
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void read_file ( )

Reads configuration information from the file.

The function uses the file name supplied in setFileName() for reading.

void saveToString ( std::string & modfileAsStr )

Stores modification information in the string supplied.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] modfileAsStr is the complete file as a string
void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setFileName ( const char * name )

Call this member to set a custom file name to read from a different location.

The file name passed as the parameter can be either full/relative path to a local file or URL of the web-site to download it from. In case of URL, the parameter should specify only web-site address. The file name will be chosen depending on whether the file is substitutions or a regular one. Call setFromSubstitutions() before calling read_file() if you want to obtain substitutions configurations rather than regular modifications.

Parameters:
name The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
Examples:
config_modfile.cpp.
void setFromSubstitutions ( const bool value )

Sets internal flag telling which file should be used for extracting modifications.

In case of remote URL it is necessary to tell which file (mod_file or substitutions) should be used for extracting modifications. By default all modifications are read from mod_file either locally or remotely.

See read_file() for more information.

Parameters:
value set whether the mod file or the substutitions file is used to extract modifications
bool updateModificationByName | ( | const char * | name,
 |  | const ms_modification | mod
 | ) |  |

Update the information for a specific modification.

Parameters:
name | must be a valid modification name.
mod | is the new definition of the modification.
Returns:
true if the modification was found and updated.
Examples:
config_modfile.cpp.
bool updateModificationByNumber | ( | const int | num,
 |  | const ms_modification | mod
 | ) |  |

Update the information for a specific modification.

Parameters:
num | must be in the range 0..(getNumberOfModifications() - 1).
mod | is the new definition of the modification.
Returns:
true if the modification was found and updated.
The documentation for this class was generated from the following files:
  • ms_modfile.hpp
  • ms_modfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_modification
Public Member Functions

ms_modification Class Reference
[Mascot configuration files module]

The class represents a single modification-entry in mod_file. More...

#include <ms_modfile.hpp>

Inheritance diagram for ms_modification:
[legend]
Collaboration diagram for ms_modification:
[legend]

List of all members.

Public Member Functions

ms_modification (const ms_masses *massFile=NULL)
Default constructor.
ms_modification (const ms_modification &src)
Copying constructor.
~ms_modification ()
Destructor.
void | appendIgnoreMass (const double massMono, const double massAve)
Appends a new ignore mass pair.
void | appendModifiedResidue (const char residue, const double massMono, const double massAve)
Adds one more residue that can be modified together with its new mass.
void | clearIgnoreMasses ()
Deletes all ignore-masses.
void | clearModifiedResidues ()
Deletes all residues modified together with their masses and deltas.
void | copyFrom (const ms_modification *src)
Copies modification configuration from another instance.
void | copyMassFile (const ms_masses *massFile)
void | defaultValues ()
Re-initialises the object.
std::string | getCode () const
Return the monolink code.
double | getCTerminusMass (const MASS_TYPE massType) const
Returns the mass of modified C-terminus.
double | getDelta (const MASS_TYPE massType) const
Returns delta (in Da) value for the given mass type.
bool | getFromUnimod (const char *modName, const ms_umod_configfile *umod_file)
Retrieves modification from the Unimod file object by its mod_file-style name.
double | getIgnoreMass (const MASS_TYPE massType, const int idx) const
Returns the value of the ith ignore mass. See getNumberOfIgnoreMasses() for more explanations.
const ms_masses * | getMassFile () const
Returns a pointer to ms_masses instance held internally.
int | getModificationType () const
Returns the type (or class) of modification.
char | getModifiedResidue (const int n) const
Traverse the modified residues list.
std::string | getMonoLinkTitle () const
Return the modification title with monolink code appended.
ms_vectorDouble | getNeutralLoss (const MASS_TYPE massType) const
Return neutral loss delta.
ms_vectorBool | getNeutralLossRequired () const
Returns a vector of boolean values (required/not required) for each neutral loss value.
double | getNTerminusMass (const MASS_TYPE massType) const
Returns the mass of modified N-terminus.
int | getNumberOfIgnoreMasses () const
Returns the number of masses to be ignored.
int | getNumberOfModifiedResidues () const
Returns a total number of modified residue for a residue-specific modification.
std::string | getPairsWith () const
Return the monolink codes this monolink pairs with.
ms_vectorDouble | getPepNeutralLoss (const MASS_TYPE massType) const
Returns a vector of PepNeutralLoss-values.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
ms_vectorDouble | getReqPepNeutralLoss (const MASS_TYPE massType) const
Returns a vector of RepPepNeutralLoss-values.
double | getResidueMass (const MASS_TYPE massType, const char residue) const
Returns a mass of modified residue.
std::string | getTitle () const
Returns the modification title.
bool | inErrorTolerant () const
Returns whether this modification should be used in error tolerant searches.
bool | inLongList () const
Returns whether this modification is flagged to appear in the search form long list.
bool | inShortList () const
Returns whether this modification is flagged to appear in the search form short list.
bool | isGeneratedMonoLinker () const
Return true if this is a monolink modification.
bool | isHidden () const
Returns value of the Hidden parameter.
bool | isLoopLinker () const
Return true if this is a monolink modification whose delta corresponds to the intact link mass.
bool | isResidueModified (const char residue) const
Check a single residue.
bool | isSubstitution () const
Returns TRUE if the modification is derived from the substitutions file.
ms_modification & | operator= (const ms_modification &right)
C++ style assignment operator.
void | setCTerminusMass (const double massMono, const double massAve)
Sets the mass of modified C-terminus.
void | setDelta (const double massMono, const double massAve)
Changes delta value for the given mass type.
void | setHidden (const bool value)
Sets the value of Hidden parameter.
void | setInErrorTolerant (const bool value)
Sets whether this modification should be used in error tolerant searches.
void | setInLongList (const bool value)
Sets whether this modification is flagged to appear in the search form long list.
void | setInShortList (const bool value)
Sets whether this modification is flagged to appear in the search form short list.
void | setMassFile (const ms_masses *massFile)
Stores pointer to the external ms_masses object to refer later.
void | setModificationType (const int type)
Sets the modification type parameter into the supplied value.
void | setNeutralLoss (const ms_vectorDouble massMono, const ms_vectorDouble massAve, const ms_vectorBool required)
Returns a vector of corresponding frequencies for each neutral loss value.
void | setNTerminusMass (const double massMono, const double massAve)
Sets the mass of modified N-terminus.
void | setPepNeutralLoss (const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve)
Set the vector of PepNeutralLoss-values.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setReqPepNeutralLoss (const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve)
Set the vector of RepPepNeutralLoss-values.
void | setTitle (const char *value)
Change the title for the modification.
void | setTitleSource (const char *unimodName, const char *specString)

Detailed Description

The class represents a single modification-entry in mod_file.

Instances of this class are created in ms_modfile when parsing mod_file. It should be used in read-only mode. But if you really want to create a custom modification from scratch then specify modification type and supply the mass file object first and set residue masses or deltas second.

Modifications that only apply to a specific residue at a specific terminus need to be handled with care. An example is the conversion of Methionine to Homoserine lactone. This is defined in mod_file as follows:

   Title:Hse_lact (C-term M)
   ResiduesCterm:M -31.000631 -31.1002

These mods are always processed as variable mods, even if they were originally specified as fixed mods. Mascot Parser implicitly treats them as terminal group mods, so that the return values from Mascot Parser for this modification are as follows:

     ms_modification::getResidueMass(matrix_science::MASS_TYPE_MONO, "M") returns 0
     ms_modification::getDelta(matrix_science::MASS_TYPE_MONO) returns -48.003370665
     ms_modification::isResidueModified("M") returns TRUE
     ms_modification::getCTerminusMass(matrix_science::MASS_TYPE_MONO) returns -31.000631
     ms_masses::getResidueMass(matrix_science::MASS_TYPE_MONO, "M") returns 131.04048
     ms_masses::isResidueModified("M") returns FALSE
     ms_masses::getCtermDelta(matrix_science::MASS_TYPE_MONO) returns 0
     ms_masses::getCterminalMass(matrix_science::MASS_TYPE_MONO) returns 17.002739665

When writing code, you may wish to categorise such cases as residue mods. If so, in the case of Hse_lact, the mass of the modified residue would be the sum of the return values from ms_modification::getDelta() and ms_masses::getResidueMass().

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_modfile.cpp, and tools_aahelper.cpp.

Constructor & Destructor Documentation

ms_modification ( const ms_masses * massFile = NULL )

Default constructor.

Not normally called from client applications.

Parameters:
massFile Optional parameter to specify the source file for this modification.
ms_modification ( const ms_modification & src )

Copying constructor.

Not normally called from client applications.

Parameters:
src reference to an ms_modification object

Member Function Documentation

void appendIgnoreMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Appends a new ignore mass pair.

See also:
getNumberOfIgnoreMasses(), getIgnoreMass(), clearIgnoreMasses()
Parameters:
massMono | is the mono-isotopic mass of the fragment to be ignored.
massAve | is the average mass of the fragment to be ignored.
void appendModifiedResidue | ( | const char | residue,
 |  | const double | massMono,
 |  | const double | massAve
 | ) |  |

Adds one more residue that can be modified together with its new mass.

If you call this method for terminal residue modifications, the supplied masses are ignored, only the modified flag for the residue will be set and the total number of residues will be increased. However, if you need to set modified terminal masses for terminal modifications (residue-specific or not) use setNTerminusMass() and setCTerminusMass().

Parameters:
residue | needs to be a residue A-Z (or a-z).
massMono | is the mono-isotopic mass of the modified residue.
massAve | is the average mass of the modified residue.
void clearIgnoreMasses ( )

Deletes all ignore-masses.

See also:
getNumberOfIgnoreMasses(), getIgnoreMass(), appendIgnoreMass()
void clearModifiedResidues ( )

Deletes all residues modified together with their masses and deltas.

Values returned by getDelta() and getNeutralLoss() are not cleared.

void copyFrom ( const ms_modification * src )

Copies modification configuration from another instance.

Parameters:
src is the source modification to be copied.
void copyMassFile ( const ms_masses * massFile )
Deprecated:
Do not use.
Parameters:
massFile pointer to a ms_masses object
void defaultValues ( )

Re-initialises the object.

Call this member if you want to re-use the instance by resetting all values to defaults.

Reimplemented from ms_customproperty.

std::string getCode ( ) const

Return the monolink code.

The monolink code is a single letter identifier, like A or W.

See also:
ms_mascotresfile::getMonoLinkModification
Returns:
Empty string if no code is defined, or a string containing one letter.
double getCTerminusMass ( const MASS_TYPE massType ) const

Returns the mass of modified C-terminus.

Call this method only for terminal modifications (irrespective of whether it is residue-specific or not). Residue modifications will always return zero.

Parameters:
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns:
mass of C-Terminus
double getDelta ( const MASS_TYPE massType ) const

Returns delta (in Da) value for the given mass type.

By default all values are equal to zero.

Parameters:
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns:
difference between unmodified and modified mass.
bool getFromUnimod | ( | const char * | modName,
 |  | const ms_umod_configfile * | umod_file
 | ) |  |

Retrieves modification from the Unimod file object by its mod_file-style name.

Parameters:
modName | modification name in a mod_file style, such as "Acetyl (C)".
umod_file | a pointer to a Unimod file object where the modification is retrieved from.
Returns:
TRUE if the modification is successfully retrieved and FALSE if it is not found in the the Unimod file.
double getIgnoreMass | ( | const MASS_TYPE | massType,
 |  | const int | idx
 | ) |  | const

Returns the value of the ith ignore mass. See getNumberOfIgnoreMasses() for more explanations.

See also:
getNumberOfIgnoreMasses(), clearIgnoreMasses(), appendIgnoreMass()
Parameters:
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
idx | index of the mass to be ignored and can be one of 0..(getNumberOfIgnoreMasses()-1).
Returns:
The mass in Daltons.
const ms_masses * getMassFile ( ) const

Returns a pointer to ms_masses instance held internally.

See also:
setMassFile()
Returns:
A pointer to the ms_masses object used. See Maintaining object references: two rules of thumb.
int getModificationType ( ) const

Returns the type (or class) of modification.

By default this is a residue modification.

Returns:
One of the enumeration MOD_TYPES values.
char getModifiedResidue ( const int n ) const

Traverse the modified residues list.

Parameters:
n residue number that can be one of 0..(getNumberOfModifiedResidues()-1).
Returns:
a letter encoding an amino acid.
std::string getMonoLinkTitle ( ) const

Return the modification title with monolink code appended.

The monolink title consists of the Unimod name followed by the monolink code in square brackets. For example, the W monolink of Xlink:DSS (K) has monolink title "Xlink:DSS[W] (K)".

If this object is not a monolink (isGeneratedMonoLink() returns false), or if the modification was not generated from a Unimod entry, the monolink title is the same as ms_modification::getTitle().

Returns:
modification title containing the monolink code, in modfile-style format.
ms_vectorDouble getNeutralLoss ( const MASS_TYPE massType ) const

Return neutral loss delta.

By default there is no neutral loss for the modification (zero).

Parameters:
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns:
A vector of neutral loss values. For example, for phosphorylation three different netutral loss values may be specified.
ms_vectorBool getNeutralLossRequired ( ) const

Returns a vector of boolean values (required/not required) for each neutral loss value.

Returns:
The values in the vector have a one to one correspondence with the values returned by in getNeutralLoss().
double getNTerminusMass ( const MASS_TYPE massType ) const

Returns the mass of modified N-terminus.

Call this method only for terminal modifications (irrespective of whether it is residue-specific or not). Residue modifications will always return zero.

Parameters:
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns:
mass of N-Terminus
int getNumberOfIgnoreMasses ( ) const

Returns the number of masses to be ignored.

If a modification gives rise to intense, predictable non-sequence ion peaks, Mascot can be instructed to ignore these artefacts by means of "ignore masses". Initially, there is no ignore-masses in the list.

Returns:
The number of masses in the 'ignore' list.
int getNumberOfModifiedResidues ( ) const

Returns a total number of modified residue for a residue-specific modification.

By default the internal list of residues is empty.

Returns:
The number of modified residues.
std::string getPairsWith ( ) const

Return the monolink codes this monolink pairs with.

The pairsWith attribute is a string of single letter identifiers. These are typically used when pairing up peptide matches with MS-cleavable linkers.

See also:
ms_mascotresfile::getMonoLinkModification
Returns:
Empty string if no codes are defined, or a string containing one or more letters.
ms_vectorDouble getPepNeutralLoss ( const MASS_TYPE massType ) const

Returns a vector of PepNeutralLoss-values.

Parameters:
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns:
vector of PepNeutralLoss values
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
ms_vectorDouble getReqPepNeutralLoss ( const MASS_TYPE massType ) const

Returns a vector of RepPepNeutralLoss-values.

Parameters:
massType should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
Returns:
vector of RepPepNeutralLoss values
double getResidueMass | ( | const MASS_TYPE | massType,
 |  | const char | residue
 | ) |  | const

Returns a mass of modified residue.

Only modified residues will have non-zero mass. So, the default value returned by this function is zero.

Parameters:
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
residue | a letter encoding an amino acid.
Returns:
modification delta + absolute mass of the residue, in Daltons, or 0 if the residue is not modified.
std::string getTitle ( ) const

Returns the modification title.

A text string that is used to identify the modification in forms and reports. By default this is empty.

Returns:
The title.
Examples:
config_modfile.cpp, and tools_aahelper.cpp.
bool isGeneratedMonoLinker ( ) const

Return true if this is a monolink modification.

A Unimod linker definition encodes monolinks as neutral losses. A monolink modification has the same title as the linker, but the delta is (linker mass - monolink NL).

See also:
ms_mascotresfile::getMonoLinkModification
Returns:
whether this modification is a monolink generated from a linker definition.
bool isHidden ( ) const

Returns value of the Hidden parameter.

If you wish to include modifications in mod_file without having them appear in a search form, the property Hidden should be set to TRUE.

By default this is not hidden.

Returns:
TRUE is the modification is hidden.
bool isLoopLinker ( ) const

Return true if this is a monolink modification whose delta corresponds to the intact link mass.

A Unimod linker definition encodes monolinks as neutral losses. A looplink modification is like a monolink modification, except its delta is the same as the intact linker mass.

See also:
ms_mascotresfile::getMonoLinkModification
Returns:
whether this modification is a looplink generated from a linker definition.
bool isResidueModified ( const char residue ) const

Check a single residue.

By default FALSE is returned for each residue, meaning "residue not modified".

Parameters:
residue a letter encoding an amino acid.
Returns:
TRUE if the residue is modified.
bool isSubstitution ( ) const

Returns TRUE if the modification is derived from the substitutions file.

If the modification is AA-substitution then this method will return TRUE.

Returns:
true if the modification is from substitution
ms_modification & operator= ( const ms_modification & right )

C++ style assignment operator.

Parameters:
right is the source modification to be copied.
Returns:
reference to the current object
void setCTerminusMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Sets the mass of modified C-terminus.

The method only has an effect for c-terminus modifications. This method will also override the delta value depending on the terminus mass supplied with the mass file object. However, if the mass file object has some fixed modifications applied, the delta will reflect this fact (not the terminus mass itself).

Parameters:
massMono | mass mono-isotopic
massAve | average mass
void setDelta | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Changes delta value for the given mass type.

By default all values are equal to zero.

Parameters:
massMono | is the delta using 12C monoisotopic masses.
massAve | is the delta using average masses.
void setHidden ( const bool value )

Sets the value of Hidden parameter.

If you wish to include modifications in mod_file without having them appear in a search form, the property Hidden should be set to TRUE.

By default this is not hidden.

Parameters:
value should be set to TRUE if the modification is to be hidden.
Examples:
config_modfile.cpp.
void setMassFile ( const ms_masses * massFile )

Stores pointer to the external ms_masses object to refer later.

If no external ms_masses instance is supplied, then the modification object will create an internal ms_masses instance filled with default values. Create an instance of ms_masses class, call its ms_masses::read_file() member and then call this function to supply the instance as a parameter. Alternatively, you can use copyMassFile() for content copying instead of pointer-copying.

Remember to keep massFile in memory for as long as you use this class object. See Memory management conventions.

Parameters:
massFile must be a valid pointer to an ms_masses object. See Maintaining object references: two rules of thumb.
void setModificationType ( const int type )

Sets the modification type parameter into the supplied value.

Parameters:
type should be one of the MOD_TYPES values.
void setNeutralLoss | ( | const ms_vectorDouble | massMono,
 |  | const ms_vectorDouble | massAve,
 |  | const ms_vectorBool | required
 | ) |  |

Returns a vector of corresponding frequencies for each neutral loss value.

Change neutral loss delta.

All three arrays must be the same length or the function will fail.

Parameters:
massMono | is an array of mono-isotopic mass neutral losses.
massAve | is an array of average mass neutral losses.
required | is an array of booleans to specify if fragments with the loss must be seen for the series to be scored.
void setNTerminusMass | ( | const double | massMono,
 |  | const double | massAve
 | ) |  |

Sets the mass of modified N-terminus.

The method only has an effect for n-terminus modifications. This method will also override the delta value depending on the terminus mass supplied with the mass file object. However, if the mass file object has some fixed modifications applied, the delta will reflect this fact (not the terminus mass itself).

Parameters:
massMono | mass mono-isotopic
massAve | average mass
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setTitle ( const char * value )

Change the title for the modification.

See getTitle() for more information.

Parameters:
value is a string value for the new title.
void setTitleSource | ( | const char * | unimodName,
 |  | const char * | specString
 | ) |  |
Parameters:
unimodName | is the Unimod name of the source definition.
specString | is the specification string with a leading space, e.g. " (K)".
The documentation for this class was generated from the following files:
  • ms_modfile.hpp
  • ms_modfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_modvector
Public Member Functions

ms_modvector Class Reference
[Mascot configuration files module]

General usage class for creating lists of modifications to be passed as parameters. More...

#include <ms_modfile.hpp>

List of all members.

Public Member Functions

ms_modvector ()
Default constructor.
ms_modvector (const ms_modvector &src)
Copying constructor.
ms_modvector (const ms_umod_modification &src, const ms_umod_configfile &umod_file)
Copying constructor that takes a Unimod file object as a source.
~ms_modvector ()
Destructor.
void | appendModification (const ms_modification *item)
Adds a new modification at the end of the vector.
void | appendModifications (ms_modvector &right)
Adds copies of modifications at the end of the vector.
void | clearModifications ()
Deletes all modifications from the vector.
void | copyFrom (const ms_modvector *right)
Copies all content from another instance.
void | copyFrom (const ms_umod_modification *right, const ms_umod_configfile *umod_file)
Copies all content from a Unimod modification object.
const ms_modification * | getModificationByName (const std::string &name) const
Returns a modification object by its name.
const ms_modification * | getModificationByNumber (const int numMod) const
Returns a modification object by its number.
int | getNumberOfModifications () const
Returns the number of modifications currently held in the vector.
ms_modvector & | operator= (const ms_modvector &right)
C++ style assignment operator.

Detailed Description

General usage class for creating lists of modifications to be passed as parameters.

Examples:

tools_aahelper.cpp.

Constructor & Destructor Documentation

ms_modvector | ( | const ms_umod_modification & | src,
 |  | const ms_umod_configfile & | umod_file
 | ) |  |

Copying constructor that takes a Unimod file object as a source.

Each modificationbelement in Unimod consists of one or more specificities that can be grouped by their specGroup value. Therefore, each modification element can be converted to one or more mod_file style modifications.

Parameters:
src | a Unimod object to copy the content from.
umod_file | an instance of a Unimod file object from which to extract element masses.

Member Function Documentation

void copyFrom | ( | const ms_umod_modification * | right,
 |  | const ms_umod_configfile * | umod_file
 | ) |  |

Copies all content from a Unimod modification object.

Every modification object in a Unimod file consits of one or more specificities. Specificities can be grouped or merged by their specificity group ID. Therefore, we can potentially obtain a vector of specificity groups out of any modification in a Unimod file. Such specificity groups can be converted into mod_file style modifications directly.

Parameters:
right | a Unimod style modification object to copy the content from.
umod_file | Unimod file object from which to get masses of elements and amino-acids.
const ms_modification * getModificationByName ( const std::string & nameMod ) const

Returns a modification object by its name.

Parameters:
nameMod is the modification name to match.
Returns:
The modification object, or a null value if a non-existent nameMod value is passed.
const ms_modification * getModificationByNumber ( const int numMod ) const

Returns a modification object by its number.

Parameters:
numMod is the modification number greater than or equal to zero and less than getNumberOfModifications().
Returns:
The modification object, or a null value if an invalid numMod value is passed. See Maintaining object references: two rules of thumb.
Examples:
tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_modfile.hpp
  • ms_modfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_obofile
Public Member Functions

ms_obofile Class Reference
[Mascot configuration files module]

The class provides simplified access to ontology files in the .obo format. More...

#include <ms_obofile.hpp>

Inheritance diagram for ms_obofile:
[legend]
Collaboration diagram for ms_obofile:
[legend]

List of all members.

Public Member Functions

ms_obofile ()
Default constructor - not generally useful.
ms_obofile (const char *oboFileName)
Constructor which loads the obo file from a local file.
ms_obofile (const ms_obofile &right)
Copying constructor.
~ms_obofile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_obofile *right)
Copies all data from another instance of the class.
void | defaultValues ()
Initialises the object.
std::string | findIDFromTagValue (const char *tag, const char *value) const
Find the ontology term with an exact match to the passed tag/value pair.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::vector< std::string > | getItemFromId (const char *id) const
Returns the vector of tag, value, comment strings for the specified ontology item.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfEntries () const
Returns the number of entries .
bool | isValid () const
Call this function to determine if there have been any errors.
ms_obofile & | operator= (const ms_obofile &right)
Assignment operator.
void | parseLine (const std::string str, std::string &tag, std::string &value, std::string &comment) const
Retrieves the tag, value and any comments from a line in the obo file.

Detailed Description

The class provides simplified access to ontology files in the .obo format.

The file format for the ontology files is described in http://www.geneontology.org/GO.format.obo-1_2.shtml .

This class provides limited read only access to OBO files. The aim of the class is to allow scripts using Mascot Parser to easily look up an ID for a given term in a local .obo file.

Constructor & Destructor Documentation

ms_obofile ( )

Default constructor - not generally useful.

Create a default empty ontology.

ms_obofile ( const char * oboFileName )

Constructor which loads the obo file from a local file.

Loads ontology from a local file. The file format will be:

 [Term]
 id: PI:00000
 name: protein informatics cv
 def: "Collection of terms for PSI Proteome Informatics standards." [PSI:PI]

 [Term]
 . . .

The ID of each term is indexed for fast access.

After loading, use the isValid() function to determine if there were any errors.

Parameters:
oboFileName is the file name of the local file.
ms_obofile ( const ms_obofile & src )

Copying constructor.

Note:
This constructor can only be used in C++.
Parameters:
src is the original OBO file.
~ms_obofile ( )

Destructor.

No need to call this directly. Frees the complete ontology.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_obofile * right )

Copies all data from another instance of the class.

Parameters:
right is the original object to copy to the new one.
void defaultValues ( )

Initialises the object.

Reset all values to their defaults.

std::string findIDFromTagValue | ( | const char * | tag,
 |  | const char * | value
 | ) |  | const

Find the ontology term with an exact match to the passed tag/value pair.

This function is only useful for retrieving items where you expect the tag value to be unique -- for example the "name" field.

Parameters:
tag | is the name of the tag. For example, "name", "is_a", "property_value".
value | is the value to be found.
Returns:
An empty string if there is no match, or the term ID if successful.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::vector< std::string > getItemFromId ( const char * id ) const

Returns the vector of tag, value, comment strings for the specified ontology item.

Returns all the lines in the [Term] for the specified ID.

Parameters:
id is the ID of the term. For example, "PI:00171".
Returns:
vector of lines
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getNumberOfEntries ( ) const

Returns the number of entries .

Each [Term] section is considered to be a single entry.

Returns:
The number of terms in the ontology.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_obofile & operator= ( const ms_obofile & right )

Assignment operator.

Parameters:
right is the original object to copy to the new one.
Returns:
reference to the current object
void parseLine | ( | const std::string | str,
 |  | std::string & | tag,
 |  | std::string & | value,
 |  | std::string & | comment
 | ) |  | const

Retrieves the tag, value and any comments from a line in the obo file.

Note:
This function can only be used from C++.

For example, for the following line, the tag would be "is_a", the value returned would be "PI:00153" and the comment would be "search engine specific score":

   is_a: PI:00153 ! search engine specific score
Parameters:
str | is the input string.
tag | is the name of the tag in the input line.
value | is the value of the tag in the input line.
comment | is any comment (after the ! in the input line).
The documentation for this class was generated from the following files:
  • ms_obofile.hpp
  • ms_obofile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_parseoptions
Public Member Functions

ms_parseoptions Class Reference
[Mascot configuration files module]

Represents the PARSE section of mascot.dat. More...

#include <ms_parserule.hpp>

Inheritance diagram for ms_parseoptions:
[legend]
Collaboration diagram for ms_parseoptions:
[legend]

List of all members.

Public Member Functions

ms_parseoptions ()
Default constructor.
ms_parseoptions (const ms_parseoptions &src)
Copying constructor.
~ms_parseoptions ()
Destructor.
void | clearParseRules ()
Makes all rules unavailable.
void | copyFrom (const ms_parseoptions *right)
Can be used to copy content from another instance.
void | defaultValues ()
Initializes the instance.
void | dropParseRule (const int index)
Makes a parse rule with the specified index unavailable.
int | getNumberOfParseRules () const
Can be used to get upper limit for a parse rule number.
const ms_parserule * | getParseRule (const int index) const
Returns a parse rule by number.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_parseoptions & | operator= (const ms_parseoptions &right)
Assignment operator for C++ client applications.
void | setParseRule (const int index, const ms_parserule *rule)
Set a new parse rule for a given number.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.

Detailed Description

Represents the PARSE section of mascot.dat.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_mascotdat.cpp.

Member Function Documentation

void dropParseRule ( const int index )

Makes a parse rule with the specified index unavailable.

Unavailable rules are not shown in the file any more and are not valid entries. In order to make it available again, create a new rule and put it in using setParseRule() member.

Parameters:
index of rule to drop
int getNumberOfParseRules ( ) const

Can be used to get upper limit for a parse rule number.

The limit is currently hard-coded. Use this function to retrieve its value.

Returns:
max number of parse rules
Examples:
config_mascotdat.cpp.
const ms_parserule * getParseRule ( const int index ) const

Returns a parse rule by number.

Parse rules are not not stored consecutively. They are stored according to their numbers explicitly specified in the file. So, not every number will yield an available rule. See ms_parserule::isAvailable().

Parameters:
index a number from 0 to (getNumberOfParseRules()-1).
Returns:
an instance of ms_parserule class representing a rule. See Maintaining object references: two rules of thumb.
Examples:
config_mascotdat.cpp.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the PARSE section is unavailable until it has been set to a different state.

Returns:
true if the section is available, false otherwise
Examples:
config_mascotdat.cpp.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
The documentation for this class was generated from the following files:
  • ms_parserule.hpp
  • ms_parserule.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_parserule
Public Member Functions

ms_parserule Class Reference
[Mascot configuration files module]

Represents a single regular expression parsing rule. More...

#include <ms_parserule.hpp>

List of all members.

Public Member Functions

ms_parserule ()
Default constructor.
ms_parserule (const ms_parserule &src)
Copying constructor.
~ms_parserule ()
Destructor.
void | copyFrom (const ms_parserule *right)
Copies all contents from another instance.
void | defaultValues ()
Initialises the instance.
std::string | getRuleStr () const
Returns a string representing the rule.
bool | isAvailable () const
Call this member to check if this rule has been specified in the file or just a placeholder.
ms_parserule & | operator= (const ms_parserule &right)
Assignment operator for C++ client applications.
void | setAvailable (const bool value)
Change the availability of the rule.
void | setRuleStr (const char *str)
Change the rule string.

Detailed Description

Represents a single regular expression parsing rule.

Instances of this class can be stored in ms_parseoptions as a list of parse rules specified in PARSE section of mascot.dat.

Member Function Documentation

bool isAvailable ( ) const

Call this member to check if this rule has been specified in the file or just a placeholder.

Parse rules in the PARSE section are specified in arbitrary order with their unique numbers. There might be gaps and unspecified rules. Therefore, it is recommended to check if the rule is actually available in the file before retrieving its properties.

By default this returns FALSE.

Returns:
true is the rule is available, false otherwise
Examples:
config_mascotdat.cpp.
void setAvailable ( const bool value )

Change the availability of the rule.

See isAvailable() for more information.

Parameters:
value boolean whether the rule is available or not
The documentation for this class was generated from the following files:
  • ms_parserule.hpp
  • ms_parserule.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_parserule_plus
Public Types | Public Member Functions

ms_parserule_plus Class Reference
[Mascot configuration files module]

Represents regular expression parse rule plus some additional parameters. More...

#include <ms_taxonomyrules.hpp>

Collaboration diagram for ms_parserule_plus:
[legend]

List of all members.

Public Types

typedef unsigned int | TAX_CHOP_SRC
Data type used for the parameter specifying how to chop a source line. This will be zero or more of the ms_parserule_plus::TAX_CHOP_TYPES values OR'ed together.
enum TAX_CHOP_TYPES {
TAX_CHOP_PREFIX = 0x0001,
TAX_CHOP_SUFFIX = 0x0002,
TAX_CHOP_WORDS = 0x0004
}

Constants used for combining TAX_CHOP_SRC values.

More...

Public Member Functions

ms_parserule_plus ()
Default constructor.
ms_parserule_plus (const ms_parserule_plus &src)
Copying constructor.
~ms_parserule_plus ()
Destructor.
void | copyFrom (const ms_parserule_plus *right)
Can be used to create a copy of another instance.
void | defaultValues ()
Initialises the instance.
TAX_CHOP_SRC | getChopSource () const
Returns additional parameter specifying how to chop a source line.
TAX_SPECIES_FORMAT | getFileTypeToSearch () const
Returns the file format.
std::string | getNameOfDB () const
Returns the database name.
const ms_parserule * | getRule () const
Returns the regular expression-based parse rule.
ms_parserule_plus & | operator= (const ms_parserule_plus &right)
Assignment operator for C++ client applications.
void | setChopSource (const TAX_CHOP_SRC value)
Change the parameter specifying how to a chop source line.
void | setFileTypeToSearch (const TAX_SPECIES_FORMAT value)
Change the file format.
void | setNameOfDB (const char *name)
Change the database name.
void | setRule (const ms_parserule *src)
Set a new parse rule.

Detailed Description

Represents regular expression parse rule plus some additional parameters.

Member Enumeration Documentation

enum TAX_CHOP_TYPES

Constants used for combining TAX_CHOP_SRC values.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TAX_CHOP_PREFIX

Remove all words at the start of the text specified in the PrefixRemoves section. See ms_taxonomyrules::getPrefixRemove().

TAX_CHOP_SUFFIX

Remove all words at the end of the text specified in the SuffixRemoves section. See ms_taxonomyrules::getSuffixRemove().

TAX_CHOP_WORDS

Remove one word at a time from the end of the text and try to get a taxonomy match again.

Member Function Documentation

ms_parserule_plus::TAX_CHOP_SRC getChopSource ( ) const

Returns additional parameter specifying how to chop a source line.

Parsing taxonomy information from a reference file or fasta file can not always be performed reliably using simple regular expressions. The 'CHOP' rules allow prefixes and suffixes to be removed and for 'words' to be extracted. For example:

   DefaultRule         NCBI, CHOP:WP   "\(.*\)"    # Everything!
   PrefixRemoves       C;Species: and mitochondrion chloroplast plastid endogenous

species that any of the listed prefixes are removed, and if that fails, it should remove one word at a time from the end of the text and try to get a match.

Returns:
Will be zero or more of the ms_parserule_plus::TAX_CHOP_TYPES OR'ed together.
void setChopSource ( const TAX_CHOP_SRC value )

Change the parameter specifying how to a chop source line.

Parsing taxonomy information from a reference file or fasta file can not always be performed reliably using simple regular expressions. The 'CHOP' rules allow prefixes and suffixes to be removed and for 'words' to be extracted. For example:

   DefaultRule         NCBI, CHOP:WP   "\(.*\)"    # Everything!
   PrefixRemoves       C;Species: and mitochondrion chloroplast plastid endogenous

species that any of the listed prefixes are removed, and if that fails, it should remove one word at a time from the end of the text and try to get a match.

Parameters:
value Should be zero or more of the ms_parserule_plus::TAX_CHOP_TYPES values OR'ed together.
The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_processoroptions
Public Member Functions

ms_processoroptions Class Reference
[Mascot configuration files module]

An instance of this class represents all the parameters specified in the Processors section of mascot.dat. More...

#include <ms_processoroptions.hpp>

Inheritance diagram for ms_processoroptions:
[legend]
Collaboration diagram for ms_processoroptions:
[legend]

List of all members.

Public Member Functions

ms_processoroptions ()
Default constructor.
ms_processoroptions (const ms_processoroptions &src)
Copying constructor.
~ms_processoroptions ()
Destructor.
void | appendDatabase (const ms_dbprocessors *db)
Adds a new database to the list.
void | appendProcessor (const int processorID)
Adds a new processor to the list for the ProcessorSet parameter.
void | clearDatabases ()
Deletes all database entries.
void | clearProcessors ()
Deletes all processors from the ProcessorSet list.
void | copyFrom (const ms_processoroptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
const ms_dbprocessors * | getDatabase (const int index) const
Returns an individual database entry.
int | getNumberOfDatabases () const
Returns number of individual database entries in the section.
int | getNumberOfProcessors () const
Returns a number of processors specified in the ProcessorSet parameter.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
int | getProcessor (const int index) const
Returns a single processor ID by its index.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_processoroptions & | operator= (const ms_processoroptions &right)
Assignment operator for C++ client applications.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.

Detailed Description

An instance of this class represents all the parameters specified in the Processors section of mascot.dat.

An instance of this class is created and populated in ms_datfile. It can also be created separately and initialized with default values. You can create an instance of the class or copy from another instance in order to pass it then as an parameters-containing object. For detailed information on any of the options please consult Mascot manual.

Most of the parameters here can be accessed using a dabatase number, which corresponds to database indices in ms_databases.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_mascotdat.cpp.

Member Function Documentation

int getNumberOfDatabases ( ) const

Returns number of individual database entries in the section.

Each of the lines corresponds to a certain database. All CPU numbers are listed in the same database entry and correspond to threads. A number of CPUs listed for the database must be the same as number of threads specified for the database in Databases section of mascot.dat. Also, all CPUs listed here must belong to the set of CPUs specified by ProcessorSet parameter.

By default the list of databases is empty.

Returns:
number of databases
int getNumberOfProcessors ( ) const

Returns a number of processors specified in the ProcessorSet parameter.

The ProcessorSet line specifies the complete set of processors to be used. The number in this list must be less than or equal to the number processors licensed, or the system will not run.

There can be up to 64 CPUs specified in the bit mask. Each bit can be set either to 1 or 0 for a listed CPU or not listed one respectively. Following this parameter, the processors to be used for each database are specified in mascot.dat. These numbers must be a subset of the numbers in the ProcessorSet, and there must be the same number of values as the number of threads specified earlier in the database section.

See also:
ms_processors::getWhichForDB(), ms_processors::getDBValSetInMascotDat()

By default the list is empty.

Returns:
number of processors
Examples:
config_mascotdat.cpp.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the Processors section is unavailable until it has been set to a different state.

Returns:
true if the section is available, false otherwise
Examples:
config_mascotdat.cpp.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
The documentation for this class was generated from the following files:
  • ms_processoroptions.hpp
  • ms_processoroptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_processors
Public Types | Public Member Functions

ms_processors Class Reference
[Mascot configuration files module]

This class is designed to retrieve current CPU configuration on the computer and set affinity. More...

#include <ms_processors.hpp>

Inheritance diagram for ms_processors:
[legend]
Collaboration diagram for ms_processors:
[legend]

List of all members.

Public Types

enum | { DEPRECATED_MAX_CORES_PER_LICENSE = 4 }

The maximum number of cores that may be used for a single 'cpu' license.

More...
enum HYPERTHREADING {
HT_NOT_CAPABLE = 0,
HT_ENABLED = 1,
HT_DISABLED = 2,
HT_SUPPORTED_NOT_ENABLED = 3,
HT_CANNOT_DETECT = 4
}

Hyper-threading status for the CPUs.

More...

Public Member Functions

ms_processors (bool checkLinuxHT, int unused)
Retrieves all CPU information immediately.
ms_processors (const ms_processors &src)
Copying constructor.
~ms_processors ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_processors *right)
Allows to make a copy of another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
int | getAutoDetectNumThreads (const int numLicensed, const int numCoresPerCpuLicense) const
Return the 'optimal' number of threads for the license.
int | getCoreFromLogical (const int cpu) const
For multi-core processors, returns the core number for the give logical CPU.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getHT_IDFromLogical (const int cpu) const
For Intel processors, return an ID corresponding to the logical processors hyper-threading state.
UINT64 | getHyperThreadedCPUsMask () const
HYPERTHREADING | getHyperThreadingState () const
Returns the hyper-threading state as best as can be detected .
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMultithreadedName () const
Returns a string that describes multithreading or multi-core capabilities.
int | getNumAvailableToProcess () const
Returns the number of logical CPUs that a process can use.
int | getNumCores (const int packageID=-1) const
Returns the number of cores on the processor specified by the physical CPU number.
int | getNumLogicalPerPhysical (const int packageID=0) const
Returns the number of 'logical' CPUs per physical processor.
int | getNumOnSystem () const
Returns the number of logical CPUs installed in the system.
int | getNumPhysicalOnSystem () const
Return the number of physical CPUs on a system.
int | getNumProcessorGroups () const
Return the number of processor groups.
int | getPhysicalFromLogical (const int cpu) const
Returns the physical CPU number for a given logical CPU number.
std::string | getProcessorName () const
Returns a string that describes the processor.
UINT64 | getWhichAvailableForMascot () const
std::vector< int > | getWhichAvailableForMascot2 () const
Returns a vector of logical CPU numbers available for Mascot (or any other process).
bool | isLogicalCPUAvailableForMascot (const int cpu) const
Returns true if the numbered logical CPU is available to Mascot (or any other process).
bool | isPrimaryLogicalProcessor (const int cpu) const
Supersedes getHyperThreadedCPUsMask.
bool | isProcessAffinitySupported () const
Returns true if process affinity is supported by the OS and false if only thread affinity is supported.
bool | isThreadedLogicalProcessor (const int cpu) const
Supersedes getHyperThreadedCPUsMask.
bool | isUseProcessesNotThreads () const
Returns a flag which indicates if the platform supports pinning threads to a processor.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_processors & | operator= (const ms_processors &right)
Assignment operator for C++ client applications.

Detailed Description

This class is designed to retrieve current CPU configuration on the computer and set affinity.

Just create an instance and then read necessary values using other members. Check for validity (if necessary) and report any errors (if any) after reading the configuration.

In this class, a logical processsor number is a zero based contiguous index. Under Windows 7/Server 2008 R2 and later, more than 64 'cores' are supported, and in this case, they are split into processor groups, and there may be gaps in the numbering. For example, on a system with 2 x 48core processors, group 0 will have 0-47, and group 1 will have numbers 64-111.

Examples:

config_procs.cpp.

Member Enumeration Documentation

anonymous enum

The maximum number of cores that may be used for a single 'cpu' license.

Warning:
This value should no longer be used as the number of cores per cpu is now specified in the license.

Note that the cores may be spread over multiple physical processors and that 'threaded' (e.g. hyperthreaded) units are not included

(Defined as an enum rather than static const int to support VC6)

Enumerator:
DEPRECATED_MAX_CORES_PER_LICENSE

The maximum number of cores that may be used for a single 'cpu' license.

enum HYPERTHREADING

Hyper-threading status for the CPUs.

This is currently only relevant for Intel Pentium processors and Power 5 processors under AIX. It will be HT_NOT_CAPABLE for AMD dual processor systems.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
HT_NOT_CAPABLE

For older Intel chips, and all other processors.

HT_ENABLED

Intel processor that supports hyper-threading and has it enabled in the BIOS.

HT_DISABLED

Pentium P4 (non Xeon) that has hyper-threading 'cobbled' so it cannot be used.

HT_SUPPORTED_NOT_ENABLED

Pentium P4 (Xeon) and later that has hyper-threading turned off in the BIOS.

HT_CANNOT_DETECT

Pentium P4, but OS limitation prevents detection of HT.

Constructor & Destructor Documentation

ms_processors | ( | bool | checkLinuxHT,
 |  | int | unused
 | ) |  |

Retrieves all CPU information immediately.

Parameters:
checkLinuxHT | is now ignored and always assumed to be 'true'. (It was required for 2.4 kernels where detection was slow)
unused | was only used for Intel Linux when checkLinuxHT is set to false so is also now ignored.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_processors * right )

Allows to make a copy of another instance.

Called by the copy constructor in C++.

Parameters:
right pointer to a valid ms_processors object
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int getAutoDetectNumThreads | ( | const int | numLicensed,
 |  | const int | numCoresPerCpuLicense
 | ) |  | const

Return the 'optimal' number of threads for the license.

For Mascot 2.3 up to Mascot 2.6 (inclusive), each license can be used for up to 4 cores. If the processor supports hyperthreading, then these are added 'for free'.

For Mascot 2.7 and later, the number of cores per cpu is defined in the license file, and that value will be passed to this function

The code to calculate this value is:

    int threadedFactor  = getNumLogicalPerPhysical() / getNumCores();
    int maxLicensable   = numLicensed * \a numCoresPerCpuLicense * threadedFactor;

    if (maxLicensable <= getNumAvailableToProcess()) {
        return maxLicensable;
    } else {
        return getNumAvailableToProcess();
    }

For example, consider a 6 core processor with Intel hyperthreading. The processor will have 12 'virtual cpus'. If numLicensed is 1, then this function will return 8.

If the number of threads in mascot.dat is specified as ms_databaseoptions::NUM_THREADS_AUTO_DETECT, then this function is called by nph-mascot.exe to determine the number of threads to use.

Parameters:
numLicensed | is the value of the "CPU units" licence feature.
numCoresPerCpuLicense | is the value of the "Cores per CPU units" licence feature.
Returns:
The number of threads that should be created.
int getCoreFromLogical ( const int cpu ) const

For multi-core processors, returns the core number for the give logical CPU.

If getNumCores() is 1, then this will return -1 for each CPU. Note that the core ID returned has no real significance -- it is just a number. To use it, for example to see which logical IDs correspong to hyper-threading / cool threads on the same core, you need to see if one or more logical ID's have the same core ID and same physical ID, and then 'group' these together.

See also:
getPhysicalFromLogical()
Parameters:
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns:
The ID of the core that corresponds to the logical CPU.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getHT_IDFromLogical ( const int cpu ) const

For Intel processors, return an ID corresponding to the logical processors hyper-threading state.

Only currently supported for Intel .

Note that the ID returned has no real significance -- it is just a number, and will currently be either 0 or 1. To use it, for example to see which logical IDs share the same core on a CPU, you need to see if one or more logical ID's have the same core ID and same physical ID, and then 'group' these together.

See also:
getPhysicalFromLogical(), getCoreFromLogical()
Parameters:
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns:
The hyper-threading ID that corresponds to the logical CPU.
UINT64 getHyperThreadedCPUsMask ( ) const
Deprecated:
Use isPrimaryLogicalProcessor(), getCoreFromLogical() and getPhysicalFromLogical() instead.

Returns a 'mask' with the bit set for each logical CPU number that is hyper-threaded. The return value is a 64 bit integer, so the maximum number of logical cpus per system that is supported by this function will be 64.

This function is now poorly named - for HyperThreaded read HyperThreadedOrMultiCored, because it doesn't differentiate between a hyper-threaded CPU and a multi-cored CPU.

The 'primary' logical CPU for each physical CPU will not have this bit set. For example, on a dual CPU (single core) Intel system with hyper-threading enabled, the low 8 bits of this flag would be 00001100, indicating that CPU numbers 2 and 3 were the hyper-threaded ones.

The assignment of primary and secondary is totally artificial as both are generally equal.

Returns:
A mask indicating which logical CPU numbers refer to 'threads' or second/subsequent cores on each physical processor.
ms_processors::HYPERTHREADING getHyperThreadingState ( ) const

Returns the hyper-threading state as best as can be detected .

See also:
getMultithreadedName(), getNumPhysicalOnSystem(), getNumOnSystem(), getNumLogicalPerPhysical()
Returns:
Whether the system supports some type of multi-threading.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getMultithreadedName ( ) const

Returns a string that describes multithreading or multi-core capabilities.

  • For AMD processors, this will either be "single core", "dual core", "quad core" or "xx core".

  • For Intel processors, this will potentially be made up of two parts, separated by a comma. The first part specifies the hyper-threading state and will be

    • "No hyper-threading in cpu"
    • "hyper-threading enabled"
    • "hyper-threading disabled in cpu"
    • "hyper-threading disabled in bios"
    • "Cannot detect hyper-threading"

    The second part will either be "single core", "dual core", "quad core" or "xx core".

Returns:
The name of the multithreading supported on the processor.
int getNumAvailableToProcess ( ) const

Returns the number of logical CPUs that a process can use.

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system. In this case, this function will return a smaller value than getNumOnSystem. Currently, this function always returns the same value as getNumOnSystem()

See also:
getNumPhysicalOnSystem(), getWhichAvailableForMascot().
Returns:
The number of logical CPUs that a process can use.
int getNumCores ( const int packageID = -1 ) const

Returns the number of cores on the processor specified by the physical CPU number.

The returned number does not include hyper-threaded CPUs. For example, for a dual core Xeon processor with hyper-threading, this function will return 2, but getNumLogicalPerPhysical() will return 4.

Parameters:
packageID is the number of the physical CPU as returned by getPhysicalFromLogical(). Prior to December 2017, all supported systems except Solaris were required to have the same number of cores on each processor, so this parameter was ignored. The default value of -1 is used to specify the physical processor ID for the first logical processor. The safe way to get this parameter is to initially find a logical cpu number using getWhichAvailableForMascot2() and then to call getPhysicalFromLogical() with this logical CPU number.
Returns:
the number of cores on the specfied physical CPU.
int getNumLogicalPerPhysical ( const int packageID = 0 ) const

Returns the number of 'logical' CPUs per physical processor.

Most processors now have multiple cores and some also provide multiple threading (known as hyper-threading).

For example, a dual core Intel processor with hyper-threading, this function will return 4.

Parameters:
packageID is the zero based number of the physical processor
Returns:
The number of logical processors running on each physical processor.
int getNumOnSystem ( ) const

Returns the number of logical CPUs installed in the system.

The number of logical CPUs may be different from the number of physical CPUs, for example with Intel Hyper-threading or AMD multi-core.

See also:
getNumPhysicalOnSystem(), getNumAvailableToProcess(), getWhichAvailableForMascot().
Returns:
The number of logical CPUs installed in the system.
Examples:
config_procs.cpp.
int getNumPhysicalOnSystem ( ) const

Return the number of physical CPUs on a system.

The number of logical CPUs may be different from the number of physical CPUs, for example with Intel hyper-threading or multi-core processors.

See also:
getNumOnSystem(), getNumAvailableToProcess(), getWhichAvailableForMascot().
Returns:
The number of physical CPUs on a system.
int getNumProcessorGroups ( ) const

Return the number of processor groups.

Returns:
1 for Linux, and >= 1 for Windows
int getPhysicalFromLogical ( const int cpu ) const

Returns the physical CPU number for a given logical CPU number.

If getNumLogicalPerPhysical() is 1, this will return -1 for each CPU. Note that the physical ID returned has no real significance -- it is just a number. To use it, need to see if one or more logical ID's have the same physical ID, and then 'group' these together.

Parameters:
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns:
The physical ID of the CPU.
std::string getProcessorName ( ) const

Returns a string that describes the processor.

Will return an empty string or one of the following:

  • Intel

  • AMD

Returns:
processor name
UINT64 getWhichAvailableForMascot ( ) const
Deprecated:
Use isLogicalCPUAvailableForMascot() instead.
Deprecated:
Use getWhichAvailableForMascot2

Returns a 64 bit mask of the logical CPUs available to Mascot (or any other process). The return value is a 64 bit integer, so the maximum number of logical CPUs per system that is supported will be 64.

This function returns a mask of the CPUs available to Mascot. So, if the least significant bit is set, the processor 0 is available to Mascot etc. These bits indicate logical CPUs and not physical CPUs.

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system. In this case, the returned mask will have 'holes'.

Returns:
A 64 bit mask indicating which CPUs are online.
std::vector< int > getWhichAvailableForMascot2 ( ) const

Returns a vector of logical CPU numbers available for Mascot (or any other process).

This function supersedes getWhichAvailableForMascot() which is limited to a maximum of 64 processors per system.

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system, so a system with 6 cpus may not have numbers 0..5.

See also:
isLogicalCPUAvailableForMascot() which may be more convenient.
Returns:
A vector of the processors available for Mascot. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
bool isLogicalCPUAvailableForMascot ( const int cpu ) const

Returns true if the numbered logical CPU is available to Mascot (or any other process).

See also getWhichAvailableForMascot2().

On some systems with processor sets or other resource management, it is possible to prevent a user or process from having access to all of the CPUs on the system, so a system with 6 CPUs may not have numbers 0..5.

Parameters:
cpu is the logical CPU number
Returns:
True if the numbered logical CPU is available to Mascot (or any other process).
bool isPrimaryLogicalProcessor ( const int cpu ) const

Supersedes getHyperThreadedCPUsMask.

The 'primary' logical CPU for each physical CPU is the first logical CPU for each physical CPU. Subsequent cores/threading logical CPUs on the same physical processor will return false from this function.

The Mascot Database status screen lists non 'primary' processors in italics.

Parameters:
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns:
False for each logical CPU numbers which is a second of subsequent core or 'thread'.
bool isProcessAffinitySupported ( ) const

Returns true if process affinity is supported by the OS and false if only thread affinity is supported.

Mascot Server uses process affinity where possible.

For Linux, this always returns true.

For Microsoft Windows, this returns true if there is only one processor set, otherwise it returns false.

Returns:
True if process affinity is supported by the OS and false if only thread affinity is supported.
bool isThreadedLogicalProcessor ( const int cpu ) const

Supersedes getHyperThreadedCPUsMask.

The 'primary' logical cpu for each physical CPU is the first logical cpu for each physical CPU. Subsequent logical CPUs that are on the same core on the same physical processors as a previous logical CPU are described by Mascot Parser as 'threaded', and will return true from this function.

Parameters:
cpu is the number of the logical CPU. To test if this is a valid logical CPU number, check that the return value from isLogicalCPUAvailableForMascot() is true.
Returns:
the opposite of isPrimaryLogicalProcessor().
bool isUseProcessesNotThreads ( ) const

Returns a flag which indicates if the platform supports pinning threads to a processor.

Now returns false for all platforms because all platforms support POSIX threads.

Returns:
Will always return false.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_processors.hpp
  • ms_processors.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_average
Public Member Functions

ms_quant_average Class Reference
[Mascot configuration files module]

An object of this class represent a single "average" element in quantitation.xml. More...

#include <ms_quant_average.hpp>

Inheritance diagram for ms_quant_average:
[legend]
Collaboration diagram for ms_quant_average:
[legend]

List of all members.

Public Member Functions

ms_quant_average ()
Default constructor.
ms_quant_average (const ms_quant_average &src)
Copying constructor.
virtual | ~ms_quant_average ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_average *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropNumPeptides ()
Delete the num_peptides attribute.
void | dropReferenceAccession ()
Delete the reference_accession attribute.
void | dropReferenceAmount ()
Delete the reference_amount attribute.
void | dropReferenceDatabase ()
Delete the reference_database attribute.
void | dropSelection ()
Delete the selection attribute.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
int | getNumPeptides () const
Returns the value of the num_peptides attribute.
std::string | getNumPeptidesSchemaType () const
Obtain a symbolic name for the num_peptides attribute schema type.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getReferenceAccession () const
Returns the value of the reference_accession attribute.
std::string | getReferenceAccessionSchemaType () const
Obtain a symbolic name for the reference_accession attribute schema type.
std::string | getReferenceAmount () const
Returns the value of the reference_amount attribute.
std::string | getReferenceAmountSchemaType () const
Obtain a symbolic name for the reference_amount attribute schema type.
std::string | getReferenceDatabase () const
Returns the value of the reference_database attribute.
std::string | getReferenceDatabaseSchemaType () const
Obtain a symbolic name for the reference_database attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSelection () const
Returns the value of the selection attribute.
std::string | getSelectionSchemaType () const
Obtain a symbolic name for the selection attribute schema type.
bool | haveNumPeptides () const
Indicates presence of the num_peptides attribute.
bool | haveReferenceAccession () const
Indicates presence of the reference_accession attribute.
bool | haveReferenceAmount () const
Indicates presence of the reference_amount attribute.
bool | haveReferenceDatabase () const
Indicates presence of the reference_database attribute.
bool | haveSelection () const
Indicates presence of the selection attribute.
ms_quant_average & | operator= (const ms_quant_average &right)
C++ style assignment operator.
void | setNumPeptides (int value)
Set a custom value for the num_peptides attribute.
void | setReferenceAccession (const char *value)
Set a custom value for the reference_accession attribute.
void | setReferenceAmount (const char *value)
Set a custom value for the reference_amount attribute.
void | setReferenceDatabase (const char *value)
Set a custom value for the reference_database attribute.
void | setSelection (const char *value)
Set a custom value for the selection attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single "average" element in quantitation.xml.

Serves as a possible sub-element of the "protocol" element.

Constructor & Destructor Documentation

ms_quant_average ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_average ( const ms_quant_average & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_average * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropNumPeptides ( )

Delete the num_peptides attribute.

Disables the attribute until it is re-set.

void dropReferenceAccession ( )

Delete the reference_accession attribute.

Disables the attribute until it is re-set.

void dropReferenceAmount ( )

Delete the reference_amount attribute.

Disables the attribute until it is re-set.

void dropReferenceDatabase ( )

Delete the reference_database attribute.

Disables the attribute until it is re-set.

void dropSelection ( )

Delete the selection attribute.

Disables the attribute until it is re-set.

int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

int getNumPeptides ( ) const

Returns the value of the num_peptides attribute.

Number of peptides per protein to be used for quantitation.

Returns:
current value of "num_peptides" attribute.
std::string getNumPeptidesSchemaType ( ) const

Obtain a symbolic name for the num_peptides attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getReferenceAccession ( ) const

Returns the value of the reference_accession attribute.

Database accession for reference protein.

Returns:
current value of the "reference_accession" attribute.
std::string getReferenceAccessionSchemaType ( ) const

Obtain a symbolic name for the reference_accession attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getReferenceAmount ( ) const

Returns the value of the reference_amount attribute.

Amount of reference protein.

Returns:
current value of the "reference_amount" attribute.
std::string getReferenceAmountSchemaType ( ) const

Obtain a symbolic name for the reference_amount attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getReferenceDatabase ( ) const

Returns the value of the reference_database attribute.

Database database for reference protein.

Returns:
current value of the "reference_database" attribute.
std::string getReferenceDatabaseSchemaType ( ) const

Obtain a symbolic name for the reference_database attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

std::string getSelection ( ) const

Returns the value of the selection attribute.

Whether to require the peptides to be used for quantitation to be unique sequences, or to accept different modification states of same sequence (unique_mr), or even accept peptides with same sequence and modifications in different charge states (unique_mz).

Returns:
current value of the "selection" attribute.
std::string getSelectionSchemaType ( ) const

Obtain a symbolic name for the selection attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveNumPeptides ( ) const

Indicates presence of the num_peptides attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveReferenceAccession ( ) const

Indicates presence of the reference_accession attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveReferenceAmount ( ) const

Indicates presence of the reference_amount attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveReferenceDatabase ( ) const

Indicates presence of the reference_database attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveSelection ( ) const

Indicates presence of the selection attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
ms_quant_average & operator= ( const ms_quant_average & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setNumPeptides ( int value )

Set a custom value for the num_peptides attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropNumPeptides().

Parameters:
value a new value for the attribute.
void setReferenceAccession ( const char * value )

Set a custom value for the reference_accession attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReferenceAccession().

Parameters:
value a new value for the attribute.
void setReferenceAmount ( const char * value )

Set a custom value for the reference_amount attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReferenceAmount().

Parameters:
value a new value for the attribute.
void setReferenceDatabase ( const char * value )

Set a custom value for the reference_database attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReferenceDatabase().

Parameters:
value a new value for the attribute.
void setSelection ( const char * value )

Set a custom value for the selection attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropSelection().

Parameters:
value a new value for the attribute.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_average.hpp
  • ms_quant_average.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_component
Public Member Functions

ms_quant_component Class Reference
[Mascot configuration files module]

An object of this class represent a single component element in quantitation.xml. More...

#include <ms_quant_component.hpp>

Collaboration diagram for ms_quant_component:
[legend]

List of all members.

Public Member Functions

ms_quant_component ()
Default constructor.
ms_quant_component (const ms_quant_component &src)
Copying constructor.
virtual | ~ms_quant_component ()
Destructor.
void | appendCorrection (const ms_quant_correction *correction)
Adds a new correction element at the end of the list.
void | appendIsotope (const ms_quant_isotope *isotope)
Adds a new isotope element at the end of the list.
void | appendModificationGroup (const ms_quant_modgroup *item)
Adds a new modification group at the end of the list.
void | clearCorrections ()
Deletes all correction elements from the list.
void | clearIsotopes ()
Deletes all isotope elements from the list.
void | clearModificationGroups ()
Deletes all modification groups from the list.
void | copyFrom (const ms_quant_component *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteCorrection (const int idx)
Remove a correction element from the list.
bool | deleteIsotope (const int idx)
Remove a isotope element from the list.
bool | deleteModificationGroupByName (const char *name)
Remove a modification group from the list in memory by its unique name.
bool | deleteModificationGroupByNumber (const int idx)
Remove a modification group from the list in memory by its index.
void | dropFileIndex ()
Delete the file_index element.
void | dropMoverz ()
Delete the moverz element.
void | dropName ()
Delete the name attribute.
void | dropSatellite ()
Delete the satellite element.
const ms_quant_correction * | getCorrection (const int idx) const
Returns a correction element object by its number.
std::string | getCorrectionSchemaType () const
Obtain a symbolic name for the correction element schema type.
int | getFileIndex () const
Returns the value of the file_index element.
std::string | getFileIndexSchemaType () const
Obtain a symbolic name for the file_index element schema type.
const ms_quant_isotope * | getIsotope (const int idx) const
Returns a isotope element object by its number.
std::string | getIsotopeSchemaType () const
Obtain a symbolic name for the isotope element schema type.
const ms_quant_modgroup * | getModificationGroupByName (const char *name) const
Returns a modification group object by its name or a null value in case it is not found.
const ms_quant_modgroup * | getModificationGroupByNumber (const int idx) const
Returns a modification group object by its number.
std::string | getModificationGroupSchemaType () const
Obtain a symbolic name for the modification_group element schema type.
const ms_quant_moverz * | getMoverz () const
Returns the value of the moverz element.
std::string | getMoverzSchemaType () const
Obtain a symbolic name for the moverz element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
int | getNumberOfCorrections () const
Returns the number of correction elements held.
int | getNumberOfIsotopes () const
Returns the number of isotope elements held.
int | getNumberOfModificationGroups () const
Returns the number of nested modification groups.
const ms_quant_satellite * | getSatellite () const
Returns the value of the satellite element.
std::string | getSatelliteSchemaType () const
Obtain a symbolic name for the satellite element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveFileIndex () const
Check for presence of the file_index element.
bool | haveMoverz () const
Check for presence of the moverz element.
bool | haveName () const
Check for presence of the name attribute.
bool | haveSatellite () const
Check for presence of the satellite element.
ms_quant_component & | operator= (const ms_quant_component &right)
C++ style assignment operator.
void | setFileIndex (const int file_index)
Supply a custom content for the file_index element.
void | setMoverz (const ms_quant_moverz *moverz)
Supply a custom content for the moverz element.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setSatellite (const ms_quant_satellite *satellite)
Supply a custom content for the satellite element.
bool | updateCorrection (const int idx, const ms_quant_correction *isotope)
Update the information for a specific correction element.
bool | updateIsotope (const int idx, const ms_quant_isotope *isotope)
Update the information for a specific isotope element.
bool | updateModificationGroupByName (const char *name, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its unique name.
bool | updateModificationGroupByNumber (const int idx, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single component element in quantitation.xml.

Identifies a component used to calculate a ratio.

Constructor & Destructor Documentation

ms_quant_component ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_component ( const ms_quant_component & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendCorrection ( const ms_quant_correction * correction )

Adds a new correction element at the end of the list.

Parameters:
correction an instance to copy the content into the newly added element from.
void appendIsotope ( const ms_quant_isotope * isotope )

Adds a new isotope element at the end of the list.

Parameters:
isotope an instance to copy the content into the newly added element from.
void appendModificationGroup ( const ms_quant_modgroup * item )

Adds a new modification group at the end of the list.

Creates a new modification group object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters:
item an instance of modification group object to copy content from.
void clearCorrections ( )

Deletes all correction elements from the list.

Deletes all nested correction elements.

void copyFrom ( const ms_quant_component * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteCorrection ( const int idx )

Remove a correction element from the list.

Parameters:
idx a zero-based index of the element to delete.
Returns:
TRUE if the element has been successfully deleted and FALSE otherwise.
bool deleteIsotope ( const int idx )

Remove a isotope element from the list.

Parameters:
idx a zero-based index of the element to delete.
Returns:
TRUE if the element has been successfully deleted and FALSE otherwise.
bool deleteModificationGroupByName ( const char * name )

Remove a modification group from the list in memory by its unique name.

Parameters:
name name of the modification group for deletion.
Returns:
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.
bool deleteModificationGroupByNumber ( const int idx )

Remove a modification group from the list in memory by its index.

Parameters:
idx number of the modification group for deletion from 0 to (getNumberOfModificationGroups() - 1).
Returns:
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.
void dropFileIndex ( )

Delete the file_index element.

Deletes the element until it is re-set.

void dropMoverz ( )

Delete the moverz element.

Deletes the element until it is re-set.

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

void dropSatellite ( )

Delete the satellite element.

Deletes the element until it is re-set.

const ms_quant_correction * getCorrection ( const int idx ) const

Returns a correction element object by its number.

Parameters:
idx a zero-based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getCorrectionSchemaType ( ) const

Obtain a symbolic name for the correction element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getFileIndex ( ) const

Returns the value of the file_index element.

The file_index element is a data file identifier (replicate).

Returns:
current element content.
std::string getFileIndexSchemaType ( ) const

Obtain a symbolic name for the file_index element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_isotope * getIsotope ( const int idx ) const

Returns a isotope element object by its number.

Element for non-SILAC metabolic labelling. Applies to residues only.

Parameters:
idx a zero-based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getIsotopeSchemaType ( ) const

Obtain a symbolic name for the isotope element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_modgroup * getModificationGroupByName ( const char * name ) const

Returns a modification group object by its name or a null value in case it is not found.

Parameters:
name name of the modification group to find.
Returns:
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.
const ms_quant_modgroup * getModificationGroupByNumber ( const int idx ) const

Returns a modification group object by its number.

Parameters:
idx number of the modification group from 0 to (getNumberOfModificationGroups() - 1).
Returns:
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.
std::string getModificationGroupSchemaType ( ) const

Obtain a symbolic name for the modification_group element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_moverz * getMoverz ( ) const

Returns the value of the moverz element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getMoverzSchemaType ( ) const

Obtain a symbolic name for the moverz element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getName ( ) const

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfCorrections ( ) const

Returns the number of correction elements held.

Returns:
total number of correction elements held.
int getNumberOfIsotopes ( ) const

Returns the number of isotope elements held.

Returns:
total number of isotope elements held.
int getNumberOfModificationGroups ( ) const

Returns the number of nested modification groups.

Returns:
total number of nested modification groups.
const ms_quant_satellite * getSatellite ( ) const

Returns the value of the satellite element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getSatelliteSchemaType ( ) const

Obtain a symbolic name for the satellite element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
bool haveFileIndex ( ) const

Check for presence of the file_index element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveMoverz ( ) const

Check for presence of the moverz element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveName ( ) const

Check for presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveSatellite ( ) const

Check for presence of the satellite element.

Returns:
TRUE if the element is present and FALSE otherwise.
ms_quant_component & operator= ( const ms_quant_component & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setFileIndex ( const int file_index )

Supply a custom content for the file_index element.

Parameters:
file_index a new content for the element.
void setMoverz ( const ms_quant_moverz * moverz )

Supply a custom content for the moverz element.

Parameters:
moverz a new content for the element.
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
void setSatellite ( const ms_quant_satellite * satellite )

Supply a custom content for the satellite element.

Parameters:
satellite a new content for the element.
bool updateCorrection | ( | const int | idx,
 |  | const ms_quant_correction * | correction
 | ) |  |

Update the information for a specific correction element.

Parameters:
idx | a zero-based index of the element to update.
correction | an instance to copy the content from.
Returns:
TRUE if the element has been successfully updated and FALSE otherwise.
bool updateIsotope | ( | const int | idx,
 |  | const ms_quant_isotope * | isotope
 | ) |  |

Update the information for a specific isotope element.

Parameters:
idx | a zero-based index of the element to update.
isotope | an instance to copy the content from.
Returns:
TRUE if the element has been successfully updated and FALSE otherwise.
bool updateModificationGroupByName | ( | const char * | name,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its unique name.

Parameters:
name | name of the modification group for updating.
modgroup | an object to copy the content from.
Returns:
TRUE if the modification group has been found and successfully updated and FALSE otherwise.
bool updateModificationGroupByNumber | ( | const int | idx,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its index.

Parameters:
idx | number of the modification group for updating from 0 to (getNumberOfModificationGroups() - 1).
modgroup | an object to copy the content from.
Returns:
TRUE if the modification group has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_component.hpp
  • ms_quant_component.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_composition
Public Member Functions

ms_quant_composition Class Reference
[Mascot configuration files module]

Describes the compositionType type in quantitation.xml. More...

#include <ms_quant_composition.hpp>

Inheritance diagram for ms_quant_composition:
[legend]

List of all members.

Public Member Functions

ms_quant_composition ()
Default constructor.
ms_quant_composition (const ms_quant_composition &src)
Copying constructor.
virtual | ~ms_quant_composition ()
Destructor.
void | appendElement (const ms_quant_element *element)
Adds a new element at the end of the list.
void | clearElements ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_composition *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElement (const int idx)
Remove an element from the list.
const ms_quant_element * | getElement (const int idx) const
Returns an element object by its number.
std::string | getElementSchemaType () const
Obtain a symbolic name for the element's schema type.
int | getNumberOfElements () const
Returns a number of elements held.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_composition & | operator= (const ms_quant_composition &right)
C++ style assignment operator.
bool | updateElement (const int idx, const ms_quant_element *element)
Update the information for a specific element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Describes the compositionType type in quantitation.xml.

Objects of this type host a list of nested element elements.

Constructor & Destructor Documentation

ms_quant_composition ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_composition ( const ms_quant_composition & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendElement ( const ms_quant_element * element )

Adds a new element at the end of the list.

Parameters:
element an instance of element object to copy content from.
void copyFrom ( const ms_quant_composition * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

bool deleteElement ( const int idx )

Remove an element from the list.

Parameters:
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
const ms_quant_element * getElement ( const int idx ) const

Returns an element object by its number.

Parameters:
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns:
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.
std::string getElementSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElements ( ) const

Returns a number of elements held.

Returns:
total number of elements in the list.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

ms_quant_composition & operator= ( const ms_quant_composition & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateElement | ( | const int | idx,
 |  | const ms_quant_element * | element
 | ) |  |

Update the information for a specific element.

Parameters:
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns:
TRUE if the element has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_neutralloss, and ms_quant_pepneutralloss.

The documentation for this class was generated from the following files:
  • ms_quant_composition.hpp
  • ms_quant_composition.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_configfile
Public Member Functions

ms_quant_configfile Class Reference
[Mascot configuration files module]

Use this class in order to read/write quantitation.xml. More...

#include <ms_quant_configfile.hpp>

Inheritance diagram for ms_quant_configfile:
[legend]
Collaboration diagram for ms_quant_configfile:
[legend]

List of all members.

Public Member Functions

ms_quant_configfile ()
Default constructor.
ms_quant_configfile (const ms_quant_configfile &src)
Copying constructor.
ms_quant_configfile (const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0)
Cconstructor that reads the given file on construction.
~ms_quant_configfile ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendMethod (const ms_quant_method *item)
Adds a new quantitation method at the end of the list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearMethods ()
Deletes all quantitation methods from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_quant_configfile *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteMethodByName (const char *name)
Remove a quantitation method from the list in memory.
bool | deleteMethodByNumber (const int idx)
Remove a quantitation method from the list in memory.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name that is used to read configuration information.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMajorVersion () const
Returns major document schema version as read from the file, otherwise the latest.
const ms_quant_method * | getMethodByName (const char *name) const
Returns a quantitation method object by its name or a null value in case it is not found.
const ms_quant_method * | getMethodByNumber (const int idx) const
Returns a quantitation method object by its number.
std::string | getMinorVersion () const
Returns minor document schema version as read from the file, otherwise the latest.
int | getNumberOfMethods () const
Returns a number of quantitation methods currently held in memory.
std::string | getSchemaDirectory () const
Returns the schema directory name.
std::string | getSchemaFileName () const
Returns the current schema file name that is used to validate XML file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_quant_configfile & | operator= (const ms_quant_configfile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads configuration information from a buffer.
void | read_file ()
Reads configuration information from the file.
std::string | save_buffer ()
Creates a string representation of the XML document with all the content of the object.
void | save_file ()
Stores modification information in the file.
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *name)
Call this member to set a custom file name to read from a different location.
void | setSchemaDirectory (const char *dir)
Sets common location for all versions of schema files.
void | setSchemaFileName (const char *name)
Call this member to specify a custom schema file name for validating XML file.
bool | updateMethodByName (const char *name, const ms_quant_method *mod)
Update the information for a specific quantitation method.
bool | updateMethodByNumber (const int idx, const ms_quant_method *mod)
Update the information for a specific quantitation method.
std::string | validateDocument () const
Validates the whole document against the schema and return errors as a string.

Detailed Description

Use this class in order to read/write quantitation.xml.

This file defines all necessary configuration information for performing quantitation experiments with Mascot.

After reading a file and before using the object check validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid. Similarly, after writing out the file, isValid() can be used to check if the file has been created correctly and is valid for further use.

Examples:

config_quantitation.cpp.

Constructor & Destructor Documentation

ms_quant_configfile ( )

Default constructor.

The default constructor just sets the current filename and schema name to be the defaults. Use this function to create an empty object before calling ms_mascotresfile::getQuantitation().

ms_quant_configfile ( const ms_quant_configfile & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.
ms_quant_configfile | ( | const char * | fileName,
 |  | const char * | schemaFileName,
 |  | const ms_connection_settings * | cs = 0
 | ) |  |

Cconstructor that reads the given file on construction.

An instance of this class is normally be created using this form of the constructor.

Parameters:
fileName | string that represents either local file name (for example, "C:/quantitation.xml") or a fully formed URL such as http://www.matrixscience.com/cgi . The filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
schemaFileName | is a "schema location" string. See setSchemaFileName() for information on this parameter. To accept default schema location leave this parameter empty.
cs | a connection settings object for downloading the file from a Mascot server. This should contain a sessionID and optionally the proxy server settings. When reading a local file cs is not required and will be ignored.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void appendMethod ( const ms_quant_method * item )

Adds a new quantitation method at the end of the list.

Creates a new quantitation method object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters:
item an instance of method object to copy content from.
Examples:
config_quantitation.cpp.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_quant_configfile * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor. However, the file name, schema location or connection settings are not reset. You need three additional calls:

    quant_configfile.setFileName("");
    quant_configfile.setSchemaFileName("");
    quant_configfile.setConnectionSettings(ms_connection_settings());
bool deleteMethodByName ( const char * name )

Remove a quantitation method from the list in memory.

Parameters:
name name of the quantitation method for deletion.
Returns:
TRUE if the quantitation method has been found and successfully deleted and FALSE otherwise.
bool deleteMethodByNumber ( const int idx )

Remove a quantitation method from the list in memory.

Parameters:
idx number of the method for deletion from 0 to (getNumberOfMethods() - 1).
Returns:
TRUE if the quantitation method has been found and successfully deleted and FALSE otherwise.
ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns:
The current connection settings.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns a file name that is used to read configuration information.

Returns:
currently set file location, which may not be the location from which the current content has been read if setFileName() has been called after reading the file.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
const ms_quant_method * getMethodByName ( const char * name ) const

Returns a quantitation method object by its name or a null value in case it is not found.

Parameters:
name a unique name of the quantitation method.
Returns:
a read-only pointer to a method object. See Maintaining object references: two rules of thumb.
const ms_quant_method * getMethodByNumber ( const int idx ) const

Returns a quantitation method object by its number.

Parameters:
idx number of the method from 0 to (getNumberOfMethods() - 1).
Returns:
a read-only pointer to a method-object. See Maintaining object references: two rules of thumb.
Examples:
config_quantitation.cpp.
int getNumberOfMethods ( ) const

Returns a number of quantitation methods currently held in memory.

Returns:
total number of method elements in the configuration file.
Examples:
config_quantitation.cpp.
std::string getSchemaDirectory ( ) const

Returns the schema directory name.

Returns:
current schema directory value.
std::string getSchemaFileName ( ) const

Returns the current schema file name that is used to validate XML file.

Returns:
currently set schema file location.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_quant_configfile & operator= ( const ms_quant_configfile & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void read_buffer ( const char * buffer )

Reads configuration information from a buffer.

This method is used when reading configuration information from a Mascot result file. Any old content in the object will be removed and substituted with the information read from the buffer.

Parameters:
buffer string buffer that contains a valid quantitation XML document. Schema validation of the document is not performed.
void read_file ( )

Reads configuration information from the file.

Reads the file from the local disk, or downloads the file from a Mascot web site. Check for errors using isValid() before using any other methods for retrieving content.

std::string save_buffer ( )

Creates a string representation of the XML document with all the content of the object.

Creates a valid XML document and returns it as a string which can be used when writing out configuration information to a Mascot result file.

Returns:
XML document with the object content.
void save_file ( )

Stores modification information in the file.

Check for errors after calling this method using isValid() to see if the operation has been successful or to get any schema validation errors. If the document is not valid it will still be saved.

Examples:
config_quantitation.cpp.
void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setFileName ( const char * name )

Call this member to set a custom file name to read from a different location.

Calling this method does not cause an write to or read from disk. Use either read_file() or save_file() methods to read or write with the new file name.

Parameters:
name a new file location (if empty a default file name will be assigned).
Examples:
config_quantitation.cpp.
void setSchemaDirectory ( const char * dir )

Sets common location for all versions of schema files.

This method allows setting a universal location for all schema versions. Client applications needn't be modified each time a new major version is introduced. However, it requires that all schemas (current and future) be placed in the same folder.

Calling this method will clear the list of pairs (alias/path) that could have possibly be submitted using setSchemaFileName().

Parameters:
dir directory path for schema files.
void setSchemaFileName ( const char * name )

Call this member to specify a custom schema file name for validating XML file.

You should either supply the schema location explicitly for each version of schema or set the schema directory with setSchemaDirectory(). These two choices are mutualy exclusive and setting one of them will make another value empty.

Use this method to supply schema location as a list of pairs (alias/path) if all schemas you are using are potentially located in different folders. Essentially, it would require explicit path for each schema version and the list of pairs will have to be updated for each new major schema version.

An alternative would be to supply one common folder to retrieve any schemas that might potentially be introduced in future.

Deprecated usage: Old clients can supply a relative or an absolute file path (for example, "C:/quantitation_1.xsd") for schema version 1.

Newer clients have to submit a list of pairs "_schema_alias_ SPACE _file_path_", where SPACE is the space character. Currently supported aliases are "http://www.matrixscience.com/xmlns/schema/quantitation_1" and "http://www.matrixscience.com/xmlns/schema/quantitation_2".

Parameters:
name schema location string. It can be left empty to accept the default location; otherwise it specifies the disk file locations for schema files. In this case, all file paths have to be URL-escaped ("C:/My%20Documents/quantitation_1.xsd"). The default location for schema files is the appropriate folder in Mascot installation or in Mascot Parser installation. Calling this method with an empty string will reset the schema location to standard default paths. Examples of valid values:

  • "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../schema%20files/quantitation_2.xsd" -- schema for version 1 will be taken from default location (if needed).
  • "http://www.matrixscience.com/xmlns/schema/quantitation_1 C:/myfiles/quant_schema_1.xsd http://www.matrixscience.com/xmlns/schema/quantitation_2 ../schema%20files/quantitation_2.xsd"
bool updateMethodByName | ( | const char * | name,
 |  | const ms_quant_method * | mod
 | ) |  |

Update the information for a specific quantitation method.

Parameters:
name | name of the quantitation method for updating.
mod | an object to copy the content from.
Returns:
TRUE if the quantitation method has been found and successfully updated and FALSE otherwise.
bool updateMethodByNumber | ( | const int | idx,
 |  | const ms_quant_method * | mod
 | ) |  |

Update the information for a specific quantitation method.

Parameters:
idx | number of the method for updating from 0 to (getNumberOfMethods() - 1).
mod | an object to copy the content from.
Returns:
TRUE if the quantitation method has been found and successfully updated and FALSE otherwise.
std::string validateDocument ( ) const

Validates the whole document against the schema and return errors as a string.

This method doesn't store the document and doesn't make the object invalid. Also, no errors are stored within the object. Therefore, this method can be called as many times as necessary without any consequences.

All validation errors will be returned back as a string. The XML parser will describe errors in terms of row and column numbers as if the document were actually saved in a file.

Returns:
validation errors as a string or an empty string if no errors are detected.
Examples:
config_quantitation.cpp.
The documentation for this class was generated from the following files:
  • ms_quant_configfile.hpp
  • ms_quant_configfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_correction
Public Member Functions

ms_quant_correction Class Reference
[Mascot configuration files module]

Represents a correction element. More...

#include <ms_quant_correction.hpp>

List of all members.

Public Member Functions

ms_quant_correction ()
Default constructor.
ms_quant_correction (const ms_quant_correction &src)
Copying constructor.
virtual | ~ms_quant_correction ()
Destructor.
void | copyFrom (const ms_quant_correction *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropElement ()
Delete the element attribute.
void | dropShift ()
Delete the shift attribute.
void | dropType ()
Delete the type attribute.
std::string | getContent () const
Returns string value of the element.
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getElement () const
Returns the value of the element attribute.
std::string | getElementSchemaType () const
Obtain a symbolic name for the the element attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
int | getShift () const
Returns the value of the shift attribute.
std::string | getShiftSchemaType () const
Obtain a symbolic name for the shift attribute schema type.
std::string | getType () const
Returns the value of the type attribute.
std::string | getTypeSchemaType () const
Obtain a symbolic name for the type attribute schema type.
bool | haveElement () const
Indicates presence of the element attribute.
bool | haveShift () const
Indicates presence of the shift attribute.
bool | haveType () const
Indicates presence of the type attribute.
ms_quant_correction & | operator= (const ms_quant_correction &right)
C++ style assignment operator.
void | setContent (const char *value)
Set a custom floating point number value as a string for the element content.
void | setElement (const char *value)
Set a custom value for the element attribute.
void | setShift (const int value)
Set a custom value for the shift attribute.
void | setType (const char *value)
Set a custom value for the type attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a correction element.

Constructor & Destructor Documentation

ms_quant_correction ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_correction ( const ms_quant_correction & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_correction * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropElement ( )

Delete the element attribute.

Deletes the attribute until is re-set.

void dropShift ( )

Delete the shift attribute.

Deletes the attribute until is re-set.

void dropType ( )

Delete the type attribute.

Deletes the attribute until is re-set.

std::string getContent ( ) const

Returns string value of the element.

Returns:
string value of the element content.
std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getElement ( ) const

Returns the value of the element attribute.

Returns:
current value of the attribute.
std::string getElementSchemaType ( ) const

Obtain a symbolic name for the the element attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
int getShift ( ) const

Returns the value of the shift attribute.

Returns:
for example, -1.
std::string getShiftSchemaType ( ) const

Obtain a symbolic name for the shift attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getType ( ) const

Returns the value of the type attribute.

Returns:
AB factor or linear combination coefficient.
std::string getTypeSchemaType ( ) const

Obtain a symbolic name for the type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveElement ( ) const

Indicates presence of the element attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveShift ( ) const

Indicates presence of the shift attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveType ( ) const

Indicates presence of the type attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_correction & operator= ( const ms_quant_correction & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setContent ( const char * value )

Set a custom floating point number value as a string for the element content.

Parameters:
value a new value for the content.
void setElement ( const char * value )

Set a custom value for the element attribute.

Parameters:
value a new value for the attribute.
void setShift ( const int value )

Set a custom value for the shift attribute.

Parameters:
value a new value for the attribute.
void setType ( const char * value )

Set a custom value for the type attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_correction.hpp
  • ms_quant_correction.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_element
Public Member Functions

ms_quant_element Class Reference
[Mascot configuration files module]

The element sub-element of compositionType in quantitation.xml. More...

#include <ms_quant_composition.hpp>

List of all members.

Public Member Functions

ms_quant_element ()
Default constructor.
ms_quant_element (const ms_quant_element &src)
Copying constructor.
virtual | ~ms_quant_element ()
Destructor.
void | copyFrom (const ms_quant_element *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropNumber ()
Deletes the number attribute.
void | dropSymbol ()
Deletes the symbol attribute.
int | getNumber () const
Returns the value of the number attribute.
std::string | getNumberSchemaType () const
Obtain a symbolic name for the number attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSymbol () const
Returns the value of the symbol attribute.
std::string | getSymbolSchemaType () const
Obtain a symbolic name for the symbol attribute schema type.
bool | haveNumber () const
Indicates presence of the number attribute.
bool | haveSymbol () const
Indicates presence of the symbol attribute.
ms_quant_element & | operator= (const ms_quant_element &right)
C++ style assignment operator.
void | setNumber (const int number)
Set a custom value for the number attribute.
void | setSymbol (const char *symbol)
Set a custom value for the symbol attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

The element sub-element of compositionType in quantitation.xml.

Constructor & Destructor Documentation

ms_quant_element ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_element ( const ms_quant_element & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_element * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropNumber ( )

Deletes the number attribute.

Deletes the attribute until is re-set.

void dropSymbol ( )

Deletes the symbol attribute.

Deletes the attribute until is re-set.

int getNumber ( ) const

Returns the value of the number attribute.

Count for the element or isotope. Can be negative.

Returns:
current value of the attribute.
std::string getNumberSchemaType ( ) const

Obtain a symbolic name for the number attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
std::string getSymbol ( ) const

Returns the value of the symbol attribute.

Chemical element or isotope.

Returns:
current value of the attribute.
std::string getSymbolSchemaType ( ) const

Obtain a symbolic name for the symbol attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveNumber ( ) const

Indicates presence of the number attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveSymbol ( ) const

Indicates presence of the symbol attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_element & operator= ( const ms_quant_element & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setNumber ( const int number )

Set a custom value for the number attribute.

Parameters:
number a new value for the attribute.
void setSymbol ( const char * symbol )

Set a custom value for the symbol attribute.

Parameters:
symbol a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_composition.hpp
  • ms_quant_composition.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_integration
Public Member Functions

ms_quant_integration Class Reference
[Mascot configuration files module]

An object of this class represent a single integration element in quantitation.xml. More...

#include <ms_quant_integration.hpp>

Inheritance diagram for ms_quant_integration:
[legend]
Collaboration diagram for ms_quant_integration:
[legend]

List of all members.

Public Member Functions

ms_quant_integration ()
Default constructor.
ms_quant_integration (const ms_quant_integration &src)
Copying constructor.
virtual | ~ms_quant_integration ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_integration *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropAllChargeStates ()
Delete the all_charge_states attribute.
void | dropAllChargeStatesThreshold ()
Delete the all_charge_states_threshold attribute.
void | dropAllowElutionShift ()
Delete the allow_elution_shift attribute.
void | dropElutionProfileCorrelationThreshold ()
Delete the elution_profile_correlation_threshold attribute.
void | dropElutionTimeDelta ()
Delete the elution_time_delta attribute.
void | dropElutionTimeDeltaUnit ()
Delete the elution_time_delta_unit attribute.
void | dropMassDelta ()
void | dropMassDeltaUnit ()
void | dropMatchedRho ()
Delete the matched_rho attribute.
void | dropMethod ()
Delete the method attribute.
void | dropPrecursorRange ()
void | dropProcessingOptions ()
void | dropSimpleRatio ()
Delete the simple_ratio attribute.
void | dropSource ()
Delete the source attribute.
void | dropXicMaxWidth ()
Delete the xic_max_width attribute.
void | dropXicSmoothing ()
Delete the xic_smoothing attribute.
void | dropXicThreshold ()
Delete the xic_threshold attribute.
std::string | getAllChargeStatesSchemaType () const
Obtain a symbolic name for the all_charge_states attribute schema type.
std::string | getAllChargeStatesThreshold () const
Returns the value of the all_charge_states_threshold attribute.
std::string | getAllChargeStatesThresholdSchemaType () const
Obtain a symbolic name for the all_charge_states_threshold attribute schema type.
std::string | getAllowElutionShiftSchemaType () const
Obtain a symbolic name for the allow_elution_shift attribute schema type.
std::string | getElutionProfileCorrelationThreshold () const
Returns the value of the elution_profile_correlation_threshold attribute.
std::string | getElutionProfileCorrelationThresholdSchemaType () const
Obtain a symbolic name for the elution_profile_correlation_threshold attribute schema type.
std::string | getElutionTimeDelta () const
Returns the value of the elution_time_delta attribute.
std::string | getElutionTimeDeltaSchemaType () const
Obtain a symbolic name for the elution_time_delta attribute schema type.
std::string | getElutionTimeDeltaUnit () const
Returns the value of the elution_time_delta_unit attribute.
std::string | getElutionTimeDeltaUnitSchemaType () const
Obtain a symbolic name for the elution_time_delta_unit attribute schema type.
std::string | getMassDelta () const
std::string | getMassDeltaSchemaType () const
std::string | getMassDeltaUnit () const
std::string | getMassDeltaUnitSchemaType () const
std::string | getMatchedRho () const
Returns the value of the matched_rho attribute.
std::string | getMatchedRhoSchemaType () const
Obtain a symbolic name for the matched_rho attribute schema type.
std::string | getMethod () const
Returns the value of the method attribute.
std::string | getMethodSchemaType () const
Obtain a symbolic name for the method attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getPrecursorRange () const
std::string | getPrecursorRangeSchemaType () const
std::string | getProcessingOptions () const
std::string | getProcessingOptionsSchemaType () const
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSimpleRatioSchemaType () const
Obtain a symbolic name for the simple_ratio attribute schema type.
std::string | getSource () const
Returns the value of the source attribute.
std::string | getSourceSchemaType () const
Obtain a symbolic name for the source attribute schema type.
int | getXicMaxWidth () const
Returns the value of the xic_max_width attribute.
std::string | getXicMaxWidthSchemaType () const
Obtain a symbolic name for the "xic_max_width" schema type.
int | getXicSmoothing () const
Returns the value of the xic_smoothing attribute.
std::string | getXicSmoothingSchemaType () const
Obtain a symbolic name for the xic_smoothing attribute schema type.
std::string | getXicThreshold () const
Returns the value of the xic_threshold attribute.
std::string | getXicThresholdSchemaType () const
Obtain a symbolic name for the xic_threshold attribute schema type.
bool | haveAllChargeStates () const
Indicates presence of the all_charge_states attribute.
bool | haveAllChargeStatesThreshold () const
Indicates presence of the all_charge_states_threshold attribute.
bool | haveAllowElutionShift () const
Indicates presence of the allow_elution_shift attribute.
bool | haveElutionProfileCorrelationThreshold () const
Indicates presence of the elution_profile_correlation_threshold attribute.
bool | haveElutionTimeDelta () const
Indicates presence of the elution_time_delta attribute.
bool | haveElutionTimeDeltaUnit () const
Indicates presence of the elution_time_delta_unit attribute.
bool | haveMassDelta () const
bool | haveMassDeltaUnit () const
bool | haveMatchedRho () const
Indicates presence of the matched_rho attribute.
bool | haveMethod () const
Indicates presence of the method attribute.
bool | havePrecursorRange () const
bool | haveProcessingOptions () const
bool | haveSimpleRatio () const
Indicates presence of the simple_ratio attribute.
bool | haveSource () const
Indicates presence of the source attribute.
bool | haveXicMaxWidth () const
Indicates presence of the xic_max_width attribute.
bool | haveXicSmoothing () const
Indicates presence of the xic_smoothing attribute.
bool | haveXicThreshold () const
Indicates presence of the xic_threshold attribute.
bool | isAllChargeStates () const
Returns the value of the all_charge_states attribute.
bool | isAllowElutionShift () const
Returns the value of the allow_elution_shift attribute.
bool | isSimpleRatio () const
Returns the value of the simple_ratio attribute.
ms_quant_integration & | operator= (const ms_quant_integration &right)
C++ style assignment operator.
void | setAllChargeStates (const bool value)
Set a custom value for the all_charge_states attribute.
void | setAllChargeStatesThreshold (const char *value)
Set a custom value for the all_charge_states_threshold attribute.
void | setAllowElutionShift (const bool value)
Set a custom value for the allow_elution_shift attribute.
void | setElutionProfileCorrelationThreshold (const char *value)
Set a custom value for the elution_profile_correlation_threshold attribute.
void | setElutionTimeDelta (const char *value)
Set a custom value for the elution_time_delta attribute.
void | setElutionTimeDeltaUnit (const char *value)
Set a custom value for the elution_time_delta_unit attribute.
void | setMassDelta (const char *value)
void | setMassDeltaUnit (const char *value)
void | setMatchedRho (const char *value)
Set a custom value for the matched_rho attribute.
void | setMethod (const char *value)
Set a custom value for the method attribute.
void | setPrecursorRange (const char *value)
void | setProcessingOptions (const std::string value)
void | setSimpleRatio (const bool value)
Set a custom value for the simple_ratio attribute.
void | setSource (const char *value)
Set a custom value for the source attribute.
void | setXicMaxWidth (int value)
Set a custom value for the xic_max_width attribute.
void | setXicSmoothing (int value)
Set a custom value for the xic_smoothing attribute.
void | setXicThreshold (const char *value)
Set a custom value for the xic_threshold attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single integration element in quantitation.xml.

Specifies the method and parameters to be used to integrate precursor over time.

Constructor & Destructor Documentation

ms_quant_integration ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_integration ( const ms_quant_integration & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_integration * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropAllChargeStates ( )

Delete the all_charge_states attribute.

Disables the attribute until it is re-set.

void dropAllChargeStatesThreshold ( )

Delete the all_charge_states_threshold attribute.

Disables the attribute until it is re-set.

void dropAllowElutionShift ( )

Delete the allow_elution_shift attribute.

Disables the attribute until it is re-set.

void dropElutionProfileCorrelationThreshold ( )

Delete the elution_profile_correlation_threshold attribute.

Disables the attribute until it is re-set.

void dropElutionTimeDelta ( )

Delete the elution_time_delta attribute.

Disables the attribute until it is re-set.

void dropElutionTimeDeltaUnit ( )

Delete the elution_time_delta_unit attribute.

Disables the attribute until it is re-set.

void dropMassDelta ( )
Deprecated:
Not in use.
void dropMassDeltaUnit ( )
Deprecated:
Not in use.
void dropMatchedRho ( )

Delete the matched_rho attribute.

Disables the attribute until it is re-set.

void dropMethod ( )

Delete the method attribute.

Disables the attribute until it is re-set.

void dropPrecursorRange ( )
Deprecated:
Do not use.
void dropProcessingOptions ( )
Deprecated:
Do not use.
void dropSimpleRatio ( )

Delete the simple_ratio attribute.

Disables the attribute until it is re-set.

void dropSource ( )

Delete the source attribute.

Disables the attribute until it is re-set.

void dropXicMaxWidth ( )

Delete the xic_max_width attribute.

Disables the attribute until it is re-set.

void dropXicSmoothing ( )

Delete the xic_smoothing attribute.

Disables the attribute until it is re-set.

void dropXicThreshold ( )

Delete the xic_threshold attribute.

Disables the attribute until it is re-set.

std::string getAllChargeStatesSchemaType ( ) const

Obtain a symbolic name for the all_charge_states attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getAllChargeStatesThreshold ( ) const

Returns the value of the all_charge_states_threshold attribute.

When all_charge_states is true, additional contiguous charge states are included in quantitation if their intensity exceeds this fraction of the the most intense charge state for which there is a database match.

Returns:
current value of the all_charge_states_threshold attribute.
std::string getAllChargeStatesThresholdSchemaType ( ) const

Obtain a symbolic name for the all_charge_states_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getAllowElutionShiftSchemaType ( ) const

Obtain a symbolic name for the allow_elution_shift attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getElutionProfileCorrelationThreshold ( ) const

Returns the value of the elution_profile_correlation_threshold attribute.

Threshold on the standard error for a straight line fit of the component intensities from each of the scans in the XIC peak.

Returns:
current value of the elution_profile_correlation_threshold attribute.
std::string getElutionProfileCorrelationThresholdSchemaType ( ) const

Obtain a symbolic name for the elution_profile_correlation_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getElutionTimeDelta ( ) const

Returns the value of the elution_time_delta attribute.

Elution time difference allowed when trying to pair up components.

Returns:
current value of the elution_time_delta attribute.
std::string getElutionTimeDeltaSchemaType ( ) const

Obtain a symbolic name for the elution_time_delta attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getElutionTimeDeltaUnit ( ) const

Returns the value of the elution_time_delta_unit attribute.

Units for the elution_time_delta attribute.

Returns:
current value of the elution_time_delta_unit attribute.
std::string getElutionTimeDeltaUnitSchemaType ( ) const

Obtain a symbolic name for the elution_time_delta_unit attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMassDelta ( ) const
Deprecated:
Not in use.
Returns:
mass delta
std::string getMassDeltaSchemaType ( ) const
Deprecated:
Not in use.
Returns:
mass delta schema type
std::string getMassDeltaUnit ( ) const
Deprecated:
Not in use.
Returns:
mass delta unit
std::string getMassDeltaUnitSchemaType ( ) const
Deprecated:
Not in use.
Returns:
mass delta unit schema type
std::string getMatchedRho ( ) const

Returns the value of the matched_rho attribute.

Threshold on the correlation coefficient between the predicted and observed precursor isotope distributions.

Returns:
current value of the matched_rho attribute.
std::string getMatchedRhoSchemaType ( ) const

Obtain a symbolic name for the matched_rho attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMethod ( ) const

Returns the value of the method attribute.

The method attribute specifies an integration algorithm.

Returns:
current value of the method attribute.
std::string getMethodSchemaType ( ) const

Obtain a symbolic name for the method attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getPrecursorRange ( ) const
Deprecated:
Do not use.
Returns:
precursor range
std::string getPrecursorRangeSchemaType ( ) const
Deprecated:
Do not use.
Returns:
precursor range schema type
std::string getProcessingOptions ( ) const
Deprecated:
Do not use.
Returns:
processing options
std::string getProcessingOptionsSchemaType ( ) const
Deprecated:
Do not use.
Returns:
processing options schema type
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

std::string getSimpleRatioSchemaType ( ) const

Obtain a symbolic name for the simple_ratio attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSource ( ) const

Returns the value of the source attribute.

Scan type containing data to be integrated.

Returns:
current value of the source attribute.
std::string getSourceSchemaType ( ) const

Obtain a symbolic name for the source attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getXicMaxWidth ( ) const

Returns the value of the xic_max_width attribute.

Upper limit on the number of survey scans in an XIC peak.

Returns:
current value of the xic_max_width attribute.
std::string getXicMaxWidthSchemaType ( ) const

Obtain a symbolic name for the "xic_max_width" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getXicSmoothing ( ) const

Returns the value of the xic_smoothing attribute.

XIC peak is smoothed by a set of 2n+1 Savitzky-Golay convolution integers, where n is this value (0 corresponds to no smoothing).

Returns:
current value of the xic_smoothing attribute.
std::string getXicSmoothingSchemaType ( ) const

Obtain a symbolic name for the xic_smoothing attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getXicThreshold ( ) const

Returns the value of the xic_threshold attribute.

The start and end of an XIC peak are where the intensity drops to this fraction of the intensity of the XIC peak maximum.

Returns:
current value of the xic_threshold attribute.
std::string getXicThresholdSchemaType ( ) const

Obtain a symbolic name for the xic_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveAllChargeStates ( ) const

Indicates presence of the all_charge_states attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveAllChargeStatesThreshold ( ) const

Indicates presence of the all_charge_states_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveAllowElutionShift ( ) const

Indicates presence of the allow_elution_shift attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveElutionProfileCorrelationThreshold ( ) const

Indicates presence of the elution_profile_correlation_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveElutionTimeDelta ( ) const

Indicates presence of the elution_time_delta attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveElutionTimeDeltaUnit ( ) const

Indicates presence of the elution_time_delta_unit attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveMassDelta ( ) const
Deprecated:
Not in use.
Returns:
true if mass delta is set, false otherwise
bool haveMassDeltaUnit ( ) const
Deprecated:
Not in use.
Returns:
true if mass delta unit is set, false otherwise
bool haveMatchedRho ( ) const

Indicates presence of the matched_rho attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveMethod ( ) const

Indicates presence of the method attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool havePrecursorRange ( ) const
Deprecated:
Do not use.
Returns:
true if precusor range is set, false otherwise
bool haveProcessingOptions ( ) const
Deprecated:
Do not use.
Returns:
true if processing options is set, false otherwise
bool haveSimpleRatio ( ) const

Indicates presence of the simple_ratio attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveSource ( ) const

Indicates presence of the source attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveXicMaxWidth ( ) const

Indicates presence of the xic_max_width attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveXicSmoothing ( ) const

Indicates presence of the xic_smoothing attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveXicThreshold ( ) const

Indicates presence of the xic_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool isAllChargeStates ( ) const

Returns the value of the all_charge_states attribute.

All charge states extends the mass and time matching to cover contiguous charge states. In other words, if there is a positive match on 2+, the software will look for 1+ and 3+. It will not look for 4+ unless 3+ is found, etc.

Returns:
current attribute value.
bool isAllowElutionShift ( ) const

Returns the value of the allow_elution_shift attribute.

Returns:
current attribute value.
bool isSimpleRatio ( ) const

Returns the value of the simple_ratio attribute.

Returns:
current attribute value.
ms_quant_integration & operator= ( const ms_quant_integration & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAllChargeStates ( const bool value )

Set a custom value for the all_charge_states attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllChargeStates().

Parameters:
value a new value for the attribute.
void setAllChargeStatesThreshold ( const char * value )

Set a custom value for the all_charge_states_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllChargeStatesThreshold().

Parameters:
value a new value for the attribute.
void setAllowElutionShift ( const bool value )

Set a custom value for the allow_elution_shift attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllowElutionShift().

Parameters:
value a new value for the attribute.
void setElutionProfileCorrelationThreshold ( const char * value )

Set a custom value for the elution_profile_correlation_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropElutionProfileCorrelationThreshold().

Parameters:
value a new value for the attribute.
void setElutionTimeDelta ( const char * value )

Set a custom value for the elution_time_delta attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropElutionTimeDelta().

Parameters:
value a new value for the attribute.
void setElutionTimeDeltaUnit ( const char * value )

Set a custom value for the elution_time_delta_unit attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropElutionTimeDeltaUnit().

Parameters:
value a new value for the attribute.
void setMassDelta ( const char * value )
Deprecated:
Not in use.
Parameters:
value mass delta
void setMassDeltaUnit ( const char * value )
Deprecated:
Not in use.
Parameters:
value mass delta unit
void setMatchedRho ( const char * value )

Set a custom value for the matched_rho attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMatchedRho().

Parameters:
value a new value for the attribute.
void setMethod ( const char * value )

Set a custom value for the method attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMethod().

Parameters:
value a new value for the attribute.
void setPrecursorRange ( const char * value )
Deprecated:
Do not use.
Parameters:
value precursor range
void setProcessingOptions ( const std::string value )
Deprecated:
Do not use.
Parameters:
value processing options
void setSimpleRatio ( const bool value )

Set a custom value for the simple_ratio attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropSimpleRatio().

Parameters:
value a new value for the attribute.
void setSource ( const char * value )

Set a custom value for the source attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropSource().

Parameters:
value a new value for the attribute.
void setXicMaxWidth ( int value )

Set a custom value for the xic_max_width attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropXicMaxWidth().

Parameters:
value a new value for the attribute.
void setXicSmoothing ( int value )

Set a custom value for the xic_smoothing attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropXicSmoothing().

Parameters:
value a new value for the attribute.
void setXicThreshold ( const char * value )

Set a custom value for the xic_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropXicThreshold().

Parameters:
value a new value for the attribute.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_integration.hpp
  • ms_quant_integration.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_isotope
Public Member Functions

ms_quant_isotope Class Reference
[Mascot configuration files module]

Represents an isotope element. More...

#include <ms_quant_isotope.hpp>

List of all members.

Public Member Functions

ms_quant_isotope ()
Default constructor.
ms_quant_isotope (const ms_quant_isotope &src)
Copying constructor.
virtual | ~ms_quant_isotope ()
Destructor.
void | copyFrom (const ms_quant_isotope *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropNew ()
Delete the new element.
void | dropOld ()
Delete the old element.
std::string | getNew () const
Returns the value of the new element.
std::string | getNewSchemaType () const
Obtain a symbolic name for the new element schema type.
std::string | getOld () const
Returns the value of the old element.
std::string | getOldSchemaType () const
Obtain a symbolic name for the old element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveNew () const
Indicates presence of the new element.
bool | haveOld () const
Indicates presence of the old element.
ms_quant_isotope & | operator= (const ms_quant_isotope &right)
C++ style assignment operator.
void | setNew (const char *value)
Set a custom value for the new element.
void | setOld (const char *value)
Set a custom value for the old element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents an isotope element.

Constructor & Destructor Documentation

ms_quant_isotope ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_isotope ( const ms_quant_isotope & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_isotope * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropNew ( )

Delete the new element.

Deletes the element until is re-set.

void dropOld ( )

Delete the old element.

Deletes the element until is re-set.

std::string getNew ( ) const

Returns the value of the new element.

The new element represents isotope label.

Returns:
a particular isotope to use instead of a standard element.
std::string getNewSchemaType ( ) const

Obtain a symbolic name for the new element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getOld ( ) const

Returns the value of the old element.

The old element specifies isotope to be replaced, usually the most abundant natural isotope of the element.

Returns:
for example, "N".
std::string getOldSchemaType ( ) const

Obtain a symbolic name for the old element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
bool haveNew ( ) const

Indicates presence of the new element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveOld ( ) const

Indicates presence of the old element.

Returns:
TRUE if the element is present and FALSE otherwise.
ms_quant_isotope & operator= ( const ms_quant_isotope & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setNew ( const char * value )

Set a custom value for the new element.

Parameters:
value a new value for the element.
void setOld ( const char * value )

Set a custom value for the old element.

Parameters:
value a new value for the element.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_isotope.hpp
  • ms_quant_isotope.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_localdef
Public Member Functions

ms_quant_localdef Class Reference
[Mascot configuration files module]

Represents a local_definition element. More...

#include <ms_quant_localdef.hpp>

Collaboration diagram for ms_quant_localdef:
[legend]

List of all members.

Public Member Functions

ms_quant_localdef ()
Default constructor.
ms_quant_localdef (const ms_quant_localdef &src)
Copying constructor.
virtual | ~ms_quant_localdef ()
Destructor.
void | appendIgnore (const ms_quant_composition *ignore)
Adds a new Ignore element at the end of the list.
void | appendSpecificity (const ms_quant_specificity *specificity)
Adds a new specificity element at the end of the list.
void | clearIgnores ()
Deletes all Ignore elements from the list.
void | clearSpecificities ()
Deletes all specificity elements from the list.
void | copyFrom (const ms_quant_localdef *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteIgnore (const int idx)
Remove an Ignore element from the list.
bool | deleteSpecificity (const int idx)
Remove a specificity element from the list.
void | dropDelta ()
Deletes the delta element.
void | dropTitle ()
Deletes the title attribute.
const ms_quant_composition * | getDelta () const
Returns a pointer to the delta element.
std::string | getDeltaSchemaType () const
Obtain a symbolic name for the delta element schema type.
const ms_quant_composition * | getIgnore (const int idx) const
Returns an Ignore element object by its number.
std::string | getIgnoreSchemaType () const
Obtain a symbolic name for the Ignore element schema type.
int | getNumberOfIgnores () const
Returns the number of Ignore elements held.
int | getNumberOfSpecificities () const
Returns the number of specificity elements held.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_quant_specificity * | getSpecificity (const int idx) const
Returns a specificity element object by its number.
std::string | getSpecificitySchemaType () const
Obtain a symbolic name for the specificity element schema type.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveDelta () const
Check presence of the delta element.
bool | haveTitle () const
Check presence of the title attribute.
ms_quant_localdef & | operator= (const ms_quant_localdef &right)
C++ style assignment operator.
void | setDelta (const ms_quant_composition *delta)
Supply custom content for the delta element.
void | setTitle (const char *value)
Set a custom value for the title attribute.
bool | updateIgnore (const int idx, const ms_quant_composition *ignore)
Update the information for a specific Ignore element.
bool | updateSpecificity (const int idx, const ms_quant_specificity *specificity)
Update the information for a specific specificity element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a local_definition element.

Constructor & Destructor Documentation

ms_quant_localdef ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_localdef ( const ms_quant_localdef & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendIgnore ( const ms_quant_composition * ignore )

Adds a new Ignore element at the end of the list.

Parameters:
ignore an instance to copy the content into the newly added element from.
void appendSpecificity ( const ms_quant_specificity * specificity )

Adds a new specificity element at the end of the list.

Parameters:
specificity an instance to copy the content into the newly added element from.
void copyFrom ( const ms_quant_localdef * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteIgnore ( const int idx )

Remove an Ignore element from the list.

Parameters:
idx a zero-based index of the element to delete.
Returns:
TRUE if the element has been successfully deleted and FALSE otherwise.
bool deleteSpecificity ( const int idx )

Remove a specificity element from the list.

Parameters:
idx a zero-based index of the element to delete.
Returns:
TRUE if the element has been successfully deleted and FALSE otherwise.
void dropDelta ( )

Deletes the delta element.

Disables the element until it is re-set.

void dropTitle ( )

Deletes the title attribute.

Disables the attribute until it is re-set.

const ms_quant_composition * getDelta ( ) const

Returns a pointer to the delta element.

Returns:
a read-only pointer to the current content. See Maintaining object references: two rules of thumb.
std::string getDeltaSchemaType ( ) const

Obtain a symbolic name for the delta element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_composition * getIgnore ( const int idx ) const

Returns an Ignore element object by its number.

Parameters:
idx a zero-based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getIgnoreSchemaType ( ) const

Obtain a symbolic name for the Ignore element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfIgnores ( ) const

Returns the number of Ignore elements held.

Returns:
total number of Ignore elements held.
int getNumberOfSpecificities ( ) const

Returns the number of specificity elements held.

Returns:
total number of specificity elements held.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
const ms_quant_specificity * getSpecificity ( const int idx ) const

Returns a specificity element object by its number.

Parameters:
idx a zero-based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getSpecificitySchemaType ( ) const

Obtain a symbolic name for the specificity element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getTitle ( ) const

Returns the value of the title attribute.

Returns:
current value of the attribute.
std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveDelta ( ) const

Check presence of the delta element.

Returns:
TRUE if the element is available.
bool haveTitle ( ) const

Check presence of the title attribute.

Returns:
TRUE if the attribute is available.
ms_quant_localdef & operator= ( const ms_quant_localdef & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setDelta ( const ms_quant_composition * delta )

Supply custom content for the delta element.

Calling this method makes the sub-element automatically available in the current element.

Parameters:
delta a new content for the element.
void setTitle ( const char * title )

Set a custom value for the title attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters:
title a new value for the attribute.
bool updateIgnore | ( | const int | idx,
 |  | const ms_quant_composition * | ignore
 | ) |  |

Update the information for a specific Ignore element.

Parameters:
idx | a zero-based index of the element to update.
ignore | an instance to copy the content from.
Returns:
TRUE if the element has been successfully updated and FALSE otherwise.
bool updateSpecificity | ( | const int | idx,
 |  | const ms_quant_specificity * | specificity
 | ) |  |

Update the information for a specific specificity element.

Parameters:
idx | a zero-based index of the element to update.
specificity | an instance to copy the content from.
Returns:
TRUE if the element has been successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_localdef.hpp
  • ms_quant_localdef.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_method
Public Types | Public Member Functions

ms_quant_method Class Reference
[Mascot configuration files module]

An object of this class represent a single quantitation method from quantitation.xml. More...

#include <ms_quant_method.hpp>

List of all members.

Public Types

enum METHOD_COMPATIBLE {
COMPATIBLE,
COMPATIBLE_DIFF_PROTOCOL,
COMPATIBLE_DIFF_NUM_COMPONENTS,
COMPATIBLE_MISSING_COMPONENT,
COMPATIBLE_DIFF_NUM_MOD_GROUPS,
COMPATIBLE_MISSING_MOD_GROUP,
COMPATIBLE_DIFF_NUM_LOCAL_MODS,
COMPATIBLE_DIFF_LOCAL_MOD,
COMPATIBLE_DIFF_NUM_MODS,
COMPATIBLE_MISSING_MOD,
COMPATIBLE_MISSING_INTEGRATION,
COMPATIBLE_MISSING_INTEGRATION_PARAM,
COMPATIBLE_DIFF_INTEGRATION_PARAM,
COMPATIBLE_DIFF_NUM_ISOTOPES
}

Enum used by isMethodCompatible()

More...

Public Member Functions

ms_quant_method ()
Default constructor.
ms_quant_method (const ms_quant_method &src)
Copying constructor.
virtual | ~ms_quant_method ()
Destructor.
void | appendComponent (const ms_quant_component *item)
Adds a new component at the end of the list.
void | appendExclusion (const char *exclusion)
Adds a new exclusion element at the end of the list.
void | appendModificationGroup (const ms_quant_modgroup *item)
Adds a new modification group at the end of the list.
void | appendReportRatio (const ms_quant_ratio *ratio)
Adds a new report_ratio element at the end of the list.
void | appendSeq (const char *seq)
Adds a new seq element at the end of the list.
void | clearComponents ()
Deletes all components from the list.
void | clearExclusions ()
Deletes all exclusion elements from the list.
void | clearModificationGroups ()
Deletes all modification groups from the list.
void | clearReportRatios ()
Deletes all report_ratio elements from the list.
void | clearSeqs ()
Deletes all seq elements from the list.
void | copyFrom (const ms_quant_method *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteComponentByName (const char *name)
Remove a component from the list in memory by its unique name.
bool | deleteComponentByNumber (const int idx)
Remove a component from the list in memory by its index.
bool | deleteExclusion (const int idx)
Remove a exclusion element from the list in memory by its index.
bool | deleteModificationGroupByName (const char *name)
Remove a modification group from the list in memory by its unique name.
bool | deleteModificationGroupByNumber (const int idx)
Remove a modification group from the list in memory by its index.
bool | deleteReportRatioByName (const char *name)
Remove a report_ratio element from the list in memory by its unique name.
bool | deleteReportRatioByNumber (const int idx)
Remove a report_ratio element from the list in memory by its index.
bool | deleteSeq (const int idx)
Remove a seq element from the list in memory by its index.
void | dropComp ()
Delete the comp element.
void | dropConstrainSearch ()
Delete the constrain_search attribute.
void | dropDescription ()
Delete the description attribute.
void | dropIntegration ()
Delete the integration element.
void | dropMinNumPeptides ()
Delete the min_num_peptides attribute.
void | dropName ()
Delete the name attribute.
void | dropNormalisation ()
Delete the normalisation element.
void | dropOutliers ()
Delete the outliers element.
void | dropProteinRatioType ()
Delete the protein_ratio_type attribute.
void | dropProtocol ()
Delete the protocol element.
void | dropProtScoreType ()
Delete the prot_score_type attribute.
void | dropQuality ()
Delete the quality element.
void | dropReportDetail ()
Delete the report_detail attribute.
void | dropRequireBoldRed ()
Delete the require_bold_red attribute.
void | dropShowSubSets ()
Delete the show_sub_sets attribute.
void | dropSigThresholdValue ()
Delete the sig_threshold_value attribute.
std::string | getComp () const
Returns the value of the comp element.
const ms_quant_component * | getComponentByName (const char *name) const
Returns a component object by its name or a null value in case of not found.
const ms_quant_component * | getComponentByNumber (const int idx) const
Returns a component object by its number (0..n-1).
std::string | getComponentSchemaType () const
Obtain a symbolic name for the component element schema type.
std::string | getCompSchemaType () const
Obtain a symbolic name for the comp element schema type.
std::string | getConstrainSearchSchemaType () const
Obtain a symbolic name for the constrain_search attribute schema type.
std::string | getDescription () const
Returns the value of the description attribute.
std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
std::string | getExclusion (const int idx) const
Returns a exclusion element object by its number.
std::string | getExclusionSchemaType () const
Obtain a symbolic name for the exclusion element schema type.
const ms_quant_integration * | getIntegration () const
Returns a pointer to the integration element.
std::string | getIntegrationSchemaType () const
Obtain a symbolic name for the integration element schema type.
void | getLocalModifications (std::vector< const ms_quant_localdef * > &localDefVector)
Returns all local modification definitions within method and components.
int | getMinNumPeptides () const
Returns the value of the min_num_peptides attribute.
std::string | getMinNumPeptidesSchemaType () const
Obtain a symbolic name for the min_num_peptides attribute schema type.
const ms_quant_modgroup * | getModificationGroupByName (const char *name) const
Returns a modification group object by its name or a null value in case of not found.
const ms_quant_modgroup * | getModificationGroupByNumber (const int idx) const
Returns a modification group object by its number.
std::string | getModificationGroupSchemaType () const
Obtain a symbolic name for the modification group element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the "name attribute" schema type.
const ms_quant_normalisation * | getNormalisation () const
Returns a pointer to the normalisation element.
std::string | getNormalisationSchemaType () const
Obtain a symbolic name for the normalisation element schema type.
int | getNumberOfComponents () const
Returns the number of nested components.
int | getNumberOfExclusions () const
Returns the number of nested exclusion elements.
int | getNumberOfModificationGroups () const
Returns the number of nested modification groups.
int | getNumberOfReportRatios () const
Returns the number of nested report_ratio elements.
int | getNumberOfSeqs () const
Returns the number of nested seq elements.
const ms_quant_outliers * | getOutliers () const
Returns a pointer to the outliers element.
std::string | getOutliersSchemaType () const
Obtain a symbolic name for the outliers element schema type.
std::string | getProteinRatioType () const
Returns the value of the protein_ratio_type attribute.
std::string | getProteinRatioTypeSchemaType () const
Obtain a symbolic name for the protein_ratio_type attribute schema type.
const ms_quant_protocol * | getProtocol () const
Returns a pointer to the protocol element.
std::string | getProtocolSchemaType () const
Obtain a symbolic name for the protocol element schema type.
std::string | getProtScoreType () const
Returns the value of the prot_score_type attribute.
std::string | getProtScoreTypeSchemaType () const
Obtain a symbolic name for the prot_score_type attribute schema type.
const ms_quant_quality * | getQuality () const
Returns a pointer to the quality element.
std::string | getQualitySchemaType () const
Obtain a symbolic name for the quality element schema type.
std::string | getReportDetailSchemaType () const
Obtain a symbolic name for the report_detail attribute schema type.
const ms_quant_ratio * | getReportRatioByName (const char *name) const
Returns a report_ratio element object by its name or a null value in case of not found.
const ms_quant_ratio * | getReportRatioByNumber (const int idx) const
Returns a report_ratio element object by its number.
std::string | getReportRatioSchemaType () const
Obtain a symbolic name for the report_ratio element schema type.
std::string | getRequireBoldRedSchemaType () const
Obtain a symbolic name for the require_bold_red attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSeq (const int idx) const
Returns a seq element object by its number.
std::string | getSeqSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getShowSubSets () const
Returns the value of the show_sub_sets attribute.
std::string | getShowSubSetsSchemaType () const
Obtain a symbolic name for the show_sub_sets attribute schema type.
std::string | getSigThresholdValue () const
Returns the value of the sig_threshold_value attribute.
std::string | getSigThresholdValueSchemaType () const
Obtain a symbolic name for the sig_threshold_value attribute schema type.
bool | haveComp () const
Indicates whether the comp element is present.
bool | haveConstrainSearch () const
Indicates whether the constrain_search attribute is present.
bool | haveDescription () const
Indicates whether the description attribute is present.
bool | haveIntegration () const
Indicates whether the integration element is present.
bool | haveMinNumPeptides () const
Indicates whether the min_num_peptides attribute is present.
bool | haveName () const
Indicates whether the name attribute is present.
bool | haveNormalisation () const
Indicates whether the normalisation element is present.
bool | haveOutliers () const
Indicates whether the outliers element is present.
bool | haveProteinRatioType () const
Indicates whether the protein_ratio_type attribute is present.
bool | haveProtocol () const
Indicates whether the protocol element is present.
bool | haveProtScoreType () const
Indicates whether the prot_score_type attribute is present.
bool | haveQuality () const
Indicates whether the quality element is present.
bool | haveReportDetail () const
Indicates whether the report_detail attribute is present.
bool | haveRequireBoldRed () const
Indicates whether the require_bold_red attribute is present.
bool | haveShowSubSets () const
Indicates whether the show_sub_sets attribute is present.
bool | haveSigThresholdValue () const
Indicates whether the sig_threshold_value attribute is present.
bool | isConstrainSearch () const
Returns the value of the constrain_search attribute.
int | isMethodCompatible (const ms_quant_method &other, std::string &reasonStrRef) const
Methods are compatible if the protocol and selected other values are identical.
bool | isReportDetail () const
Returns the value of the report_detail attribute.
bool | isRequireBoldRed () const
Returns the value of the require_bold_red attribute.
ms_quant_method & | operator= (const ms_quant_method &right)
C++ style assignment operator.
void | setComp (const char *value)
Set a custom value for the comp element.
void | setConstrainSearch (const bool value)
Set a custom value for the constrain_search attribute.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setIntegration (const ms_quant_integration *integration)
Supply custom content for the integration element.
void | setMinNumPeptides (const int value)
Set a custom value for the min_num_peptides attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setNormalisation (const ms_quant_normalisation *normalisation)
Supply custom content for the normalisation element.
void | setOutliers (const ms_quant_outliers *outliers)
Supply custom content for the outliers element.
void | setProteinRatioType (const char *value)
Set a custom value for the protein_ratio_type attribute.
void | setProtocol (const ms_quant_protocol *protocol)
Supply custom content for the protocol element.
void | setProtScoreType (const char *value)
Set a custom value for the prot_score_type attribute.
void | setQuality (const ms_quant_quality *quality)
Supply custom content for the quality element.
void | setReportDetail (const bool value)
Set a custom value for the report_detail attribute.
void | setRequireBoldRed (const bool value)
Set a custom value for the require_bold_red attribute.
void | setShowSubSets (const char *value)
Set a custom value for the show_sub_sets attribute.
void | setSigThresholdValue (const char *value)
Set a custom value for the sig_threshold_value attribute.
bool | updateComponentByName (const char *name, const ms_quant_component *comp)
Update the information for a specific component refering to it by its unique name.
bool | updateComponentByNumber (const int idx, const ms_quant_component *comp)
Update the information for a specific component refering to it by its index.
bool | updateExclusion (const int idx, const char *exclusion)
Update the information for a specific exclusion element refering to it by its index.
bool | updateModificationGroupByName (const char *name, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its unique name.
bool | updateModificationGroupByNumber (const int idx, const ms_quant_modgroup *modgroup)
Update the information for a specific modification group refering to it by its index.
bool | updateReportRatioByName (const char *name, const ms_quant_ratio *ratio)
Update the information for a specific report_ratio element refering to it by its unique name.
bool | updateReportRatioByNumber (const int idx, const ms_quant_ratio *ratio)
Update the information for a specific report_ratio element refering to it by its index.
bool | updateSeq (const int idx, const char *seq)
Update the information for a specific seq element refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single quantitation method from quantitation.xml.

Examples:

config_quantitation.cpp.

Member Enumeration Documentation

enum METHOD_COMPATIBLE

Enum used by isMethodCompatible()

See Using enumerated values and static const ints in Perl, Java, Python and C#. The description for each of the enums is the human readable text for each of the 'error' codes

Enumerator:
COMPATIBLE

Methods are compatible.

COMPATIBLE_DIFF_PROTOCOL

Methods 'x' and 'y' are incompatible: Different protocols ('p1' and 'p2') for the methods.

COMPATIBLE_DIFF_NUM_COMPONENTS

Methods 'x' and 'y' are incompatible: Different number of components ('c1' and 'c2').

COMPATIBLE_MISSING_COMPONENT

Methods 'x' and 'y' are incompatible: Component 'c1' is missing from method 'y'.

COMPATIBLE_DIFF_NUM_MOD_GROUPS

Methods 'x' and 'y' are incompatible: Different number of modification groups ('mg1' and 'mg2') for component/method 'Z'.

COMPATIBLE_MISSING_MOD_GROUP

Methods 'x' and 'y' are incompatible: Modification group mg is missing from component 'c'.

COMPATIBLE_DIFF_NUM_LOCAL_MODS

Methods 'x' and 'y' are incompatible: Different number of local modification definitions ('mg1' and 'mg2') for modification group 'mg'.

COMPATIBLE_DIFF_LOCAL_MOD

Methods 'x' and 'y' are incompatible: Local modification 'lm' definition differs.

COMPATIBLE_DIFF_NUM_MODS

Methods 'x' and 'y' are incompatible: Different number of modifications ('mg1' and 'mg2') for modification group 'mg'.

COMPATIBLE_MISSING_MOD

Methods 'x' and 'y' are incompatible: Modification 'mod' is missing from modification group 'mg'.

COMPATIBLE_MISSING_INTEGRATION

Methods 'x' and 'y' are incompatible: One method has integration parameters and the other has none.

COMPATIBLE_MISSING_INTEGRATION_PARAM

Methods 'x' and 'y' are incompatible: "Method 'x' has integration parameter 'p' but method 'y' does not.

COMPATIBLE_DIFF_INTEGRATION_PARAM

Methods 'x' and 'y' are incompatible: Method 'x' has integration parameter 'p1'='v1' but method 'y' has 'p2'='v2'.

COMPATIBLE_DIFF_NUM_ISOTOPES

Methods 'x' and 'y' are incompatible: Different number of isotopes ('mg1' and 'mg2') for component 'c1'.

Constructor & Destructor Documentation

ms_quant_method ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_method ( const ms_quant_method & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendComponent ( const ms_quant_component * item )

Adds a new component at the end of the list.

Creates a new component object, copies all content from the object supplied as a parameter and adds it at the end of the components list.

Parameters:
item an instance of component object to copy content from.
void appendExclusion ( const char * exclusion )

Adds a new exclusion element at the end of the list.

Creates a new exclusion element object and adds it at the end of the exclusion elements list.

Parameters:
exclusion an string value for the element.
void appendModificationGroup ( const ms_quant_modgroup * item )

Adds a new modification group at the end of the list.

Creates a new modification group object, copies all content from the object supplied as a parameter and adds it at the end of the methods list.

Parameters:
item an instance of modification group object to copy content from.
void appendReportRatio ( const ms_quant_ratio * item )

Adds a new report_ratio element at the end of the list.

Creates a new report_ratio element object, copies all content from the object supplied as a parameter and adds it at the end of the "report_ratio" elements list.

Parameters:
item an instance of report_ratio element object to copy content from.
void appendSeq ( const char * seq )

Adds a new seq element at the end of the list.

Creates a new seq element object and adds it at the end of the "seq" elements list.

Parameters:
seq an string value for the element.
void copyFrom ( const ms_quant_method * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteComponentByName ( const char * name )

Remove a component from the list in memory by its unique name.

Parameters:
name name of the component for deletion.
Returns:
TRUE if the component has been found and successfully deleted and FALSE otherwise.
bool deleteComponentByNumber ( const int idx )

Remove a component from the list in memory by its index.

Parameters:
idx number of the component for deletion from 0 to (getNumberOfComponents() - 1).
Returns:
TRUE if the component has been found and successfully deleted and FALSE otherwise.
bool deleteExclusion ( const int idx )

Remove a exclusion element from the list in memory by its index.

Parameters:
idx number of the exclusion element for deletion from 0 to (getNumberOfExclusions() - 1).
Returns:
TRUE if the exclusion element has been found and successfully deleted and FALSE otherwise.
bool deleteModificationGroupByName ( const char * name )

Remove a modification group from the list in memory by its unique name.

Parameters:
name name of the modification group for deletion.
Returns:
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.
bool deleteModificationGroupByNumber ( const int idx )

Remove a modification group from the list in memory by its index.

Parameters:
idx number of the modification group for deletion from 0 to (getNumberOfModificationGroups() - 1).
Returns:
TRUE if the modification group has been found and successfully deleted and FALSE otherwise.
bool deleteReportRatioByName ( const char * name )

Remove a report_ratio element from the list in memory by its unique name.

Parameters:
name name of the report_ratio element for deletion.
Returns:
TRUE if the report_ratio element has been found and successfully deleted and FALSE otherwise.
bool deleteReportRatioByNumber ( const int idx )

Remove a report_ratio element from the list in memory by its index.

Parameters:
idx number of the report_ratio element for deletion from 0 to (getNumberOfReportRatios() - 1).
Returns:
TRUE if the report_ratio element has been found and successfully deleted and FALSE otherwise.
bool deleteSeq ( const int idx )

Remove a seq element from the list in memory by its index.

Parameters:
idx number of the seq element for deletion from 0 to (getNumberOfSeqs() - 1).
Returns:
TRUE if the seq element has been found and successfully deleted and FALSE otherwise.
void dropComp ( )

Delete the comp element.

Disables the element until it is re-set.

void dropConstrainSearch ( )

Delete the constrain_search attribute.

Disables the attribute until it is re-set.

void dropDescription ( )

Delete the description attribute.

Disables the attribute until it is re-set.

void dropIntegration ( )

Delete the integration element.

Deletes the element until it is re-set.

void dropMinNumPeptides ( )

Delete the min_num_peptides attribute.

Disables the attribute until it is re-set.

void dropName ( )

Delete the name attribute.

Disables the attribute until it is re-set.

void dropNormalisation ( )

Delete the normalisation element.

Deletes the element until it is re-set.

void dropOutliers ( )

Delete the outliers element.

Deletes the element until it is re-set.

void dropProteinRatioType ( )

Delete the protein_ratio_type attribute.

Disables the attribute until it is re-set.

void dropProtocol ( )

Delete the protocol element.

Deletes the element until it is re-set.

void dropProtScoreType ( )

Delete the prot_score_type attribute.

Disables the attribute until it is re-set.

void dropQuality ( )

Delete the quality element.

Deletes the element until it is re-set.

void dropReportDetail ( )

Delete the report_detail attribute.

Disables the attribute until it is re-set.

void dropRequireBoldRed ( )

Delete the require_bold_red attribute.

Disables the attribute until it is re-set.

void dropShowSubSets ( )

Delete the show_sub_sets attribute.

Disables the attribute until it is re-set.

void dropSigThresholdValue ( )

Delete the sig_threshold_value attribute.

Disables the attribute until it is re-set.

std::string getComp ( ) const

Returns the value of the comp element.

See haveComp() method for more information on how to use this.

Returns:
a composition qualifier in Mascot notation, e.g. *[C].
const ms_quant_component * getComponentByName ( const char * name ) const

Returns a component object by its name or a null value in case of not found.

Parameters:
name name of the component to find.
Returns:
a read-only pointer to a component object. See Maintaining object references: two rules of thumb.
const ms_quant_component * getComponentByNumber ( const int idx ) const

Returns a component object by its number (0..n-1).

Parameters:
idx number of the component from 0 to (getNumberOfComponents() - 1).
Returns:
a read-only pointer to a component object. See Maintaining object references: two rules of thumb.
std::string getComponentSchemaType ( ) const

Obtain a symbolic name for the component element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getCompSchemaType ( ) const

Obtain a symbolic name for the comp element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getConstrainSearchSchemaType ( ) const

Obtain a symbolic name for the constrain_search attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getDescription ( ) const

Returns the value of the description attribute.

Returns:
free text string for description.
std::string getDescriptionSchemaType ( ) const

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getExclusion ( const int idx ) const

Returns a exclusion element object by its number.

Parameters:
idx number of the exclusion element from 0 to (getNumberOfExclusions() - 1).
Returns:
a string copy of the exclusion element.
std::string getExclusionSchemaType ( ) const

Obtain a symbolic name for the exclusion element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_integration * getIntegration ( ) const

Returns a pointer to the integration element.

See haveIntegration() for more information.

Returns:
a pointer to the object that represents theintegration" element (or a null value if not present). See Maintaining object references: two rules of thumb.
std::string getIntegrationSchemaType ( ) const

Obtain a symbolic name for the integration element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
void getLocalModifications ( std::vector< const ms_quant_localdef * > & localDefVector )

Returns all local modification definitions within method and components.

Method currently only valid for C++ due to vector of object pointers.

Parameters:
localDefVector vector to fill with ms_quant_localdef* object pointers.
int getMinNumPeptides ( ) const

Returns the value of the min_num_peptides attribute.

Minimum number of peptide matches for reporting quantitation at protein level.

Returns:
minimum number of peptide matches
std::string getMinNumPeptidesSchemaType ( ) const

Obtain a symbolic name for the min_num_peptides attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_modgroup * getModificationGroupByName ( const char * name ) const

Returns a modification group object by its name or a null value in case of not found.

Parameters:
name name of the modification group to find.
Returns:
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.
const ms_quant_modgroup * getModificationGroupByNumber ( const int idx ) const

Returns a modification group object by its number.

Parameters:
idx number of the modification group from 0 to (getNumberOfModificationGroups() - 1).
Returns:
a read-only pointer to a modification group object. See Maintaining object references: two rules of thumb.
std::string getModificationGroupSchemaType ( ) const

Obtain a symbolic name for the modification group element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getName ( ) const

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
Examples:
config_quantitation.cpp.
std::string getNameSchemaType ( ) const

Obtain a symbolic name for the "name attribute" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_normalisation * getNormalisation ( ) const

Returns a pointer to the normalisation element.

See haveNormalisation() for more information.

Returns:
a pointer to the object that represents the normalisation element (or a null value if not present). See Maintaining object references: two rules of thumb.
std::string getNormalisationSchemaType ( ) const

Obtain a symbolic name for the normalisation element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfComponents ( ) const

Returns the number of nested components.

Returns:
total number of nested components.
int getNumberOfExclusions ( ) const

Returns the number of nested exclusion elements.

Exclude peptides from quantitation if they contain modifications from this group.

Returns:
total number of nested exclusion elements.
int getNumberOfModificationGroups ( ) const

Returns the number of nested modification groups.

Returns:
total number of nested modification groups.
int getNumberOfReportRatios ( ) const

Returns the number of nested report_ratio elements.

Returns:
total number of nested report_ratio elements.
int getNumberOfSeqs ( ) const

Returns the number of nested seq elements.

Sequence qualifier in Mascot notation, e.g. *-TSL.

Returns:
total number of nested seq elements.
const ms_quant_outliers * getOutliers ( ) const

Returns a pointer to the outliers element.

See haveOutliers() for more information.

Returns:
a pointer to the object that represents theoutliers" element (or a null value if not present). See Maintaining object references: two rules of thumb.
std::string getOutliersSchemaType ( ) const

Obtain a symbolic name for the outliers element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getProteinRatioType ( ) const

Returns the value of the protein_ratio_type attribute.

Method of calculating the ratio for the protein from the individual peptide ratios.

Returns:
protein ratio type
std::string getProteinRatioTypeSchemaType ( ) const

Obtain a symbolic name for the protein_ratio_type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_protocol * getProtocol ( ) const

Returns a pointer to the protocol element.

See haveProtocol() for more information.

Returns:
a pointer to the object that represents the protocol element (or a null value if not present). See Maintaining object references: two rules of thumb.
std::string getProtocolSchemaType ( ) const

Obtain a symbolic name for the protocol element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getProtScoreType ( ) const

Returns the value of the prot_score_type attribute.

Returns:
either "standard" or "mudpit" type.
std::string getProtScoreTypeSchemaType ( ) const

Obtain a symbolic name for the prot_score_type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_quality * getQuality ( ) const

Returns a pointer to the quality element.

See haveQuality() for more information.

Returns:
a pointer to the object that represents thequality" element (or a null value if not present). See Maintaining object references: two rules of thumb.
std::string getQualitySchemaType ( ) const

Obtain a symbolic name for the quality element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getReportDetailSchemaType ( ) const

Obtain a symbolic name for the report_detail attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_ratio * getReportRatioByName ( const char * name ) const

Returns a report_ratio element object by its name or a null value in case of not found.

Parameters:
name name of the report_ratio element to find.
Returns:
a read-only pointer to a report_ratio element object. See Maintaining object references: two rules of thumb.
const ms_quant_ratio * getReportRatioByNumber ( const int idx ) const

Returns a report_ratio element object by its number.

Parameters:
idx number of the report_ratio element from 0 to (getNumberOfReportRatios() - 1).
Returns:
a read-only pointer to a report_ratio element object. See Maintaining object references: two rules of thumb.
std::string getReportRatioSchemaType ( ) const

Obtain a symbolic name for the report_ratio element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getRequireBoldRedSchemaType ( ) const

Obtain a symbolic name for the require_bold_red attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
std::string getSeq ( const int idx ) const

Returns a seq element object by its number.

Parameters:
idx number of the seq element from 0 to (getNumberOfSeqs() - 1).
Returns:
a string copy of the seq element.
std::string getSeqSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getShowSubSets ( ) const

Returns the value of the show_sub_sets attribute.

Returns:
A floating point number (represented as a string) between 0 and 1 showing how many subset proteins to display. See also ms_mascotresults::setSubsetsThreshold().
std::string getShowSubSetsSchemaType ( ) const

Obtain a symbolic name for the show_sub_sets attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSigThresholdValue ( ) const

Returns the value of the sig_threshold_value attribute.

Mascot score significance threshold as a probabliltiy, default 0.05.

Returns:
significant threshold
std::string getSigThresholdValueSchemaType ( ) const

Obtain a symbolic name for the sig_threshold_value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveComp ( ) const

Indicates whether the comp element is present.

The comp element can be missing for the current method object. In order to be qualified as valid composition qualifier it must be at least 4 characters long. Therefore, an empty string returned by getComp() is not a valid value for the element. Always check whether the comp element is present in the document before retrieving its value.

Returns:
TRUE if present and FALSE otherwise.
bool haveConstrainSearch ( ) const

Indicates whether the constrain_search attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveDescription ( ) const

Indicates whether the description attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveIntegration ( ) const

Indicates whether the integration element is present.

The integration element describes method and parameters to be used to integrate precursor over time. If missing, no integration is performed.

Returns:
TRUE if present and FALSE if missing.
bool haveMinNumPeptides ( ) const

Indicates whether the min_num_peptides attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveName ( ) const

Indicates whether the name attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveNormalisation ( ) const

Indicates whether the normalisation element is present.

Method of normailising ratios for a complete data set. If missing, no normalisation is performed.

Returns:
TRUE if present and FALSE otherwise.
bool haveOutliers ( ) const

Indicates whether the outliers element is present.

Method and parameters to be used to remove outliers. If missing, no outlier removal is performed.

Returns:
TRUE if present and FALSE otherwise.
bool haveProteinRatioType ( ) const

Indicates whether the protein_ratio_type attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveProtocol ( ) const

Indicates whether the protocol element is present.

The protocol element describes how the quantitative information is obtained.

Returns:
TRUE if present and FALSE otherwise.
bool haveProtScoreType ( ) const

Indicates whether the prot_score_type attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveQuality ( ) const

Indicates whether the quality element is present.

This element specifies quality thresholds for selecting individual spectra or matches.

Returns:
TRUE if present and FALSE otherwise.
bool haveReportDetail ( ) const

Indicates whether the report_detail attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveRequireBoldRed ( ) const

Indicates whether the require_bold_red attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveShowSubSets ( ) const

Indicates whether the show_sub_sets attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool haveSigThresholdValue ( ) const

Indicates whether the sig_threshold_value attribute is present.

Returns:
TRUE if present and FALSE otherwise.
bool isConstrainSearch ( ) const

Returns the value of the constrain_search attribute.

If any modification group specifies exclusive mode, then apply this constraint during the search so that only matches that can be used for quantitation will be returned.

Returns:
true if constraint applies to the search, false otherwise
int isMethodCompatible | ( | const ms_quant_method & | other,
 |  | std::string & | reasonStrRef
 | ) |  | const

Methods are compatible if the protocol and selected other values are identical.

Result files with 'compatible' quantitation methods can be combined. It is also possible to apply a modified method to an existing results file when creating an ms_ms2quantitation object as long as the methods are 'compatible'.

See ms_quant_method::METHOD_COMPATIBLE for a list of reasons why the methods may not be compatible.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | other | is the other method to compare with this one.
[out] | reasonStrRef | is set to a human readable string if the methods are not compatible.
Returns:
ms_quant_method::COMPATIBLE if the quantitation methods are compatible otherwise returns one of the error codes.
bool isReportDetail ( ) const

Returns the value of the report_detail attribute.

This attribute defines whether to display quantitation results at the peptide match level.

Returns:
true if quantitation results are displayed, false otherwise
bool isRequireBoldRed ( ) const

Returns the value of the require_bold_red attribute.

Returns:
TRUE if only show proteins that contain a least one "bold red" peptide match.
ms_quant_method & operator= ( const ms_quant_method & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setComp ( const char * value )

Set a custom value for the comp element.

Parameters:
value a new value for the element.
void setConstrainSearch ( const bool value )

Set a custom value for the constrain_search attribute.

Parameters:
value a new value for the attribute.
void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters:
value a new value for the attribute.
void setIntegration ( const ms_quant_integration * integration )

Supply custom content for the integration element.

Parameters:
integration an object to copy the content from.
void setMinNumPeptides ( const int value )

Set a custom value for the min_num_peptides attribute.

Parameters:
value a new value for the attribute.
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
Examples:
config_quantitation.cpp.
void setNormalisation ( const ms_quant_normalisation * normalisation )

Supply custom content for the normalisation element.

Parameters:
normalisation an object to copy the content from.
void setOutliers ( const ms_quant_outliers * outliers )

Supply custom content for the outliers element.

Parameters:
outliers an object to copy the content from.
void setProteinRatioType ( const char * value )

Set a custom value for the protein_ratio_type attribute.

Parameters:
value a new value for the attribute.
void setProtocol ( const ms_quant_protocol * protocol )

Supply custom content for the protocol element.

Parameters:
protocol an object to copy the content from.
void setProtScoreType ( const char * value )

Set a custom value for the prot_score_type attribute.

Parameters:
value a new value for the attribute.
void setQuality ( const ms_quant_quality * quality )

Supply custom content for the quality element.

Parameters:
quality an object to copy the content from.
void setReportDetail ( const bool value )

Set a custom value for the report_detail attribute.

Parameters:
value a new value for the attribute.
void setRequireBoldRed ( const bool value )

Set a custom value for the require_bold_red attribute.

Parameters:
value a new value for the attribute.
void setShowSubSets ( const char * value )

Set a custom value for the show_sub_sets attribute.

Parameters:
value a new value for the attribute.
void setSigThresholdValue ( const char * value )

Set a custom value for the sig_threshold_value attribute.

Parameters:
value a new value for the attribute.
bool updateComponentByName | ( | const char * | name,
 |  | const ms_quant_component * | comp
 | ) |  |

Update the information for a specific component refering to it by its unique name.

Parameters:
name | name of the component for updating.
comp | an object to copy the content from.
Returns:
TRUE if the component has been found and successfully updated and FALSE otherwise.
bool updateComponentByNumber | ( | const int | idx,
 |  | const ms_quant_component * | comp
 | ) |  |

Update the information for a specific component refering to it by its index.

Parameters:
idx | number of the component for updating from 0 to (getNumberOfComponents() - 1).
comp | an object to copy the content from.
Returns:
TRUE if the component has been found and successfully updated and FALSE otherwise.
bool updateExclusion | ( | const int | idx,
 |  | const char * | exclusion
 | ) |  |

Update the information for a specific exclusion element refering to it by its index.

Parameters:
idx | number of the exclusion element for updating from 0 to (getNumberOfExclusions() - 1).
exclusion | new string value for the element.
Returns:
TRUE if the exclusion element has been successfully updated and FALSE otherwise.
bool updateModificationGroupByName | ( | const char * | name,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its unique name.

Parameters:
name | name of the modification group for updating.
modgroup | an object to copy the content from.
Returns:
TRUE if the modification group has been found and successfully updated and FALSE otherwise.
bool updateModificationGroupByNumber | ( | const int | idx,
 |  | const ms_quant_modgroup * | modgroup
 | ) |  |

Update the information for a specific modification group refering to it by its index.

Parameters:
idx | number of the modification group for updating from 0 to (getNumberOfModificationGroups() - 1).
modgroup | an object to copy the content from.
Returns:
TRUE if the modification group has been found and successfully updated and FALSE otherwise.
bool updateReportRatioByName | ( | const char * | name,
 |  | const ms_quant_ratio * | ratio
 | ) |  |

Update the information for a specific report_ratio element refering to it by its unique name.

Parameters:
name | name of the report_ratio element for updating.
ratio | an object to copy the content from.
Returns:
TRUE if the report_ratio element has been found and successfully updated and FALSE otherwise.
bool updateReportRatioByNumber | ( | const int | idx,
 |  | const ms_quant_ratio * | ratio
 | ) |  |

Update the information for a specific report_ratio element refering to it by its index.

Parameters:
idx | number of the report_ratio element for updating from 0 to (getNumberOfReportRatios() - 1).
ratio | an object to copy the content from.
Returns:
TRUE if the report_ratio element has been found and successfully updated and FALSE otherwise.
bool updateSeq | ( | const int | idx,
 |  | const char * | seq
 | ) |  |

Update the information for a specific seq element refering to it by its index.

Parameters:
idx | number of the seq element for updating from 0 to (getNumberOfSeqs() - 1).
seq | a new string value for the element.
Returns:
TRUE if the seq element has been successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
Examples:
config_quantitation.cpp.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
Examples:
config_quantitation.cpp.
The documentation for this class was generated from the following files:
  • ms_quant_method.hpp
  • ms_quant_method.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_modgroup
Public Member Functions

ms_quant_modgroup Class Reference
[Mascot configuration files module]

An object of this class represent a single modification group element in quantitation.xml. More...

#include <ms_quant_modgroup.hpp>

List of all members.

Public Member Functions

ms_quant_modgroup ()
Default constructor.
ms_quant_modgroup (const ms_quant_modgroup &src)
Copying constructor.
virtual | ~ms_quant_modgroup ()
Destructor.
void | appendLocalDefinition (const ms_quant_localdef *localdef)
Adds a new local_definition element at the end of the list.
void | appendModFile (const char *mod)
Adds a new mod_file at the end of the list.
void | appendUnmodified (const ms_quant_unmodified *unmodified)
Adds a new unmodified element at the end of the list.
void | clearLocalDefinitions ()
Deletes all local_definition elements from the list.
void | clearModFiles ()
Deletes all mod_file elements from the list.
void | clearUnmodified ()
Deletes all unmodified elements from the list.
void | copyFrom (const ms_quant_modgroup *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteLocalDefinition (const int idx)
Removes a local_definition element from the list.
bool | deleteModFile (const int idx)
Removes mod_file element from the list.
bool | deleteUnmodified (const int idx)
Removes an unmodified element from the list.
void | dropMode ()
Delete the mode attribute.
void | dropName ()
Delete the name attribute.
void | dropRequired ()
Delete the required attribute.
int | findModFile (const char *mod) const
Return zero-based index of a mod_file if it is found in the list, -1 otherwise.
const ms_quant_localdef * | getLocalDefinition (const int idx) const
Returns a local_definition element object by its number.
std::string | getLocalDefinitionSchemaType () const
Obtain a symbolic name for the local_definition element schema type.
std::string | getMode () const
Returns the value of the mode attribute.
std::string | getModeSchemaType () const
Obtain a symbolic name for the mode attribute schema type.
std::string | getModFile (const int idx) const
Returns mod_file element content by its number.
std::string | getModFileSchemaType () const
Obtain a symbolic name for the mod_file element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
int | getNumberOfLocalDefinitions () const
Returns the number of nested local_definition elements.
int | getNumberOfModFiles () const
Returns the number of nested mod_file elements.
int | getNumberOfUnmodified () const
Returns the number of nested unmodified elements.
std::string | getRequiredSchemaType () const
Obtain a symbolic name for the required attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_quant_unmodified * | getUnmodified (const int idx) const
Returns an unmodified element object by its number.
std::string | getUnmodifiedSchemaType () const
Obtain a symbolic name for the unmodified element schema type.
bool | haveMode () const
Indicates presence of the mode attribute.
bool | haveName () const
Check for presence of the name attribute.
bool | haveRequired () const
Indicates presence of the required attribute.
bool | isRequired () const
Returns the value of the required attribute.
ms_quant_modgroup & | operator= (const ms_quant_modgroup &right)
C++ style assignment operator.
void | setMode (const char *value)
Set a custom value for the mode attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setRequired (bool value)
Set a custom value for the required attribute.
bool | updateLocalDefinition (const int idx, const ms_quant_localdef *localdef)
Supply new content for one of the local_definition elements in the list.
bool | updateUnmodified (const int idx, const ms_quant_unmodified *unmodified)
Supply new content for one of the unmodified elements in the list.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single modification group element in quantitation.xml.

Grouping to enable mode constraint (e.g. exclusive) to apply to a set of modifications.

Constructor & Destructor Documentation

ms_quant_modgroup ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_modgroup ( const ms_quant_modgroup & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendLocalDefinition ( const ms_quant_localdef * localdef )

Adds a new local_definition element at the end of the list.

Parameters:
localdef a new element to be added to the list.
void appendModFile ( const char * mod )

Adds a new mod_file at the end of the list.

Parameters:
mod a title from the Mascot mod_file.
void appendUnmodified ( const ms_quant_unmodified * unmodified )

Adds a new unmodified element at the end of the list.

Parameters:
unmodified a new element to be added to the list.
void copyFrom ( const ms_quant_modgroup * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteLocalDefinition ( const int idx )

Removes a local_definition element from the list.

Parameters:
idx a zero based index of the local_definition element to delete from the list.
Returns:
true if the index is in rage, false otherwise
bool deleteModFile ( const int idx )

Removes mod_file element from the list.

Parameters:
idx zero based index of the element to remove.
Returns:
TRUE if the element has been successfully removed and FALSE otherwise.
bool deleteUnmodified ( const int idx )

Removes an unmodified element from the list.

Parameters:
idx a zero based index of the unmodified element to delete from the list.
Returns:
true if the index is in range, false otherwise
void dropMode ( )

Delete the mode attribute.

Disables the attribute until it is re-set.

void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

void dropRequired ( )

Delete the required attribute.

Disables the attribute until it is re-set.

int findModFile ( const char * mod ) const

Return zero-based index of a mod_file if it is found in the list, -1 otherwise.

Parameters:
mod a title from the Mascot mod_file.
Returns:
zero-based index of a mod_file if it is found in the list, otherwise -1.
const ms_quant_localdef * getLocalDefinition ( const int idx ) const

Returns a local_definition element object by its number.

Parameters:
idx a zero based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getLocalDefinitionSchemaType ( ) const

Obtain a symbolic name for the local_definition element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMode ( ) const

Returns the value of the mode attribute.

"Mode" is one of fixed, variable or exclusive. Applies to all the modifications in the group.

Returns:
current value of the mode attribute.
std::string getModeSchemaType ( ) const

Obtain a symbolic name for the mode attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getModFile ( const int idx ) const

Returns mod_file element content by its number.

Parameters:
idx zero based index of the mod_file element.
Returns:
mod_file element content.
std::string getModFileSchemaType ( ) const

Obtain a symbolic name for the mod_file element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getName ( ) const

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfLocalDefinitions ( ) const

Returns the number of nested local_definition elements.

Returns:
total number of nested local_definition elements.
int getNumberOfModFiles ( ) const

Returns the number of nested mod_file elements.

Returns:
total number of nested mod_file elements.
int getNumberOfUnmodified ( ) const

Returns the number of nested unmodified elements.

Returns:
total number of nested unmodified elements.
std::string getRequiredSchemaType ( ) const

Obtain a symbolic name for the required attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
const ms_quant_unmodified * getUnmodified ( const int idx ) const

Returns an unmodified element object by its number.

Parameters:
idx a zero based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getUnmodifiedSchemaType ( ) const

Obtain a symbolic name for the unmodified element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveMode ( ) const

Indicates presence of the mode attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveName ( ) const

Check for presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveRequired ( ) const

Indicates presence of the required attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool isRequired ( ) const

Returns the value of the required attribute.

Modification required for a peptide to be part of a component. Does not affect the Mascot search.

Returns:
current value of the required attribute.
ms_quant_modgroup & operator= ( const ms_quant_modgroup & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setMode ( const char * value )

Set a custom value for the mode attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMode().

Parameters:
value a new value for the attribute.
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
void setRequired ( bool value )

Set a custom value for the required attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropRequired().

Parameters:
value a new value for the attribute.
bool updateLocalDefinition | ( | const int | idx,
 |  | const ms_quant_localdef * | localdef
 | ) |  |

Supply new content for one of the local_definition elements in the list.

Parameters:
idx | a zero based index of the element to update.
localdef | a source to copy the content from.
Returns:
TRUE if the element has been successfully updated.
bool updateUnmodified | ( | const int | idx,
 |  | const ms_quant_unmodified * | unmodified
 | ) |  |

Supply new content for one of the unmodified elements in the list.

Parameters:
idx | a zero based index of the element to update.
unmodified | a source to copy the content from.
Returns:
TRUE if the element has been successfully updated.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_modgroup.hpp
  • ms_quant_modgroup.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_moverz
Public Member Functions

ms_quant_moverz Class Reference
[Mascot configuration files module]

Parameter name and value pair. More...

#include <ms_quant_moverz.hpp>

List of all members.

Public Member Functions

ms_quant_moverz ()
Default constructor.
ms_quant_moverz (const ms_quant_moverz &src)
Copying constructor.
virtual | ~ms_quant_moverz ()
Destructor.
void | copyFrom (const ms_quant_moverz *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAverage ()
Delete the average attribute.
void | dropMonoisotopic ()
Delete the monoisotopic attribute.
std::string | getAverage () const
Returns the value of the average attribute.
std::string | getAverageSchemaType () const
Obtain a symbolic name for the average attribute schema type.
std::string | getMonoisotopic () const
Returns the value of the monoisotopic attribute.
std::string | getMonoisotopicSchemaType () const
Obtain a symbolic name for the monoisotopic attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAverage () const
Indicates presence of the average attribute.
bool | haveMonoisotopic () const
Indicates presence of the monoisotopic attribute.
ms_quant_moverz & | operator= (const ms_quant_moverz &right)
C++ style assignment operator.
void | setAverage (const char *value)
Set a custom value for the average attribute.
void | setMonoisotopic (const char *value)
Set a custom value for the monoisotopic attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

Constructor & Destructor Documentation

ms_quant_moverz ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_moverz ( const ms_quant_moverz & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_moverz * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropAverage ( )

Delete the average attribute.

Deletes the attribute until is re-set.

void dropMonoisotopic ( )

Delete the monoisotopic attribute.

Deletes the attribute until is re-set.

std::string getAverage ( ) const

Returns the value of the average attribute.

Returns:
current value of the attribute.
std::string getAverageSchemaType ( ) const

Obtain a symbolic name for the average attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMonoisotopic ( ) const

Returns the value of the monoisotopic attribute.

Returns:
current attribute value.
std::string getMonoisotopicSchemaType ( ) const

Obtain a symbolic name for the monoisotopic attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
bool haveAverage ( ) const

Indicates presence of the average attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMonoisotopic ( ) const

Indicates presence of the monoisotopic attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_moverz & operator= ( const ms_quant_moverz & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAverage ( const char * value )

Set a custom value for the average attribute.

Parameters:
value a new value for the attribute.
void setMonoisotopic ( const char * value )

Set a custom value for the monoisotopic attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_moverz.hpp
  • ms_quant_moverz.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_multiplex
Public Member Functions

ms_quant_multiplex Class Reference
[Mascot configuration files module]

An object of this class represent a multiplex element in quantitation.xml. More...

#include <ms_quant_multiplex.hpp>

Inheritance diagram for ms_quant_multiplex:
[legend]
Collaboration diagram for ms_quant_multiplex:
[legend]

List of all members.

Public Member Functions

ms_quant_multiplex ()
Default constructor.
ms_quant_multiplex (const ms_quant_multiplex &src)
Copying constructor.
virtual | ~ms_quant_multiplex ()
Destructor.
void | appendIonSeries (const std::string ionSeries)
Adds a new ion_series element at the end of the list.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
void | clearIonSeries ()
Deletes all ions_series elements from the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_multiplex *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteIonSeries (const int idx)
Remove an ion_series element from the list in memory by its index.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropExcludeInternalLabel ()
Delete the exclude_internal_label attribute.
void | dropExcludeIsobaricFragments ()
Delete the exclude_isobaric_fragments attribute.
void | dropIonIntensityThreshold ()
Delete the ion_intensity_threshold attribute.
void | dropIonSeries ()
Delete the ion_series element.
void | dropMinIonPairs ()
Delete the min_ion_pairs attribute.
std::string | getExcludeInternalLabelSchemaType () const
Obtain a symbolic name for the exclude_internal_label element schema type.
std::string | getExcludeIsobaricFragmentsSchemaType () const
Obtain a symbolic name for the exclude_isobaric_fragments attribute schema type.
std::string | getIonIntensityThreshold () const
Returns the value of the ion_intensity_threshold attribute.
std::string | getIonIntensityThresholdSchemaType () const
Obtain a symbolic name for the ion_intensity_threshold attribute schema type.
const std::string | getIonSeries (const int idx=0) const
Returns a ion_series element object by its number.
std::string | getIonSeriesSchemaType () const
Obtain a symbolic name for the ion_series element schema type.
int | getMinIonPairs () const
Returns the value of the min_ion_pairs attribute.
std::string | getMinIonPairsSchemaType () const
Obtain a symbolic name for the min_ion_pairs attribute schema type.
int | getNumberOfIonSeries () const
Returns the number of ions series.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveExcludeInternalLabel () const
Indicates presence of the exclude_internal_label attribute.
bool | haveExcludeIsobaricFragments () const
Indicates presence of the exclude_isobaric_fragments attribute.
bool | haveIonIntensityThreshold () const
Indicates presence of the ion_intensity_threshold attribute.
bool | haveIonSeries () const
Check for presence of the ion_series element.
bool | haveMinIonPairs () const
Indicates presence of the min_ion_pairs attribute.
bool | isExcludeInternalLabel () const
Returns the value of the exclude_internal_label attribute value.
bool | isExcludeIsobaricFragments () const
Returns the value of the exclude_isobaric_fragments attribute.
ms_quant_multiplex & | operator= (const ms_quant_multiplex &right)
C++ style assignment operator.
void | setExcludeInternalLabel (const bool value)
Set a custom value for the exclude_internal_label attribute.
void | setExcludeIsobaricFragments (const bool value)
Set a custom value for the exclude_isobaric_fragments attribute.
void | setIonIntensityThreshold (const char *value)
Set a custom value for the ion_intensity_threshold attribute.
void | setIonSeries (const std::string ionSeries)
Supply custom content for the ion_series element.
void | setMinIonPairs (const int value)
Set a custom value for the min_ion_pairs attribute.
bool | updateIonSeries (const int idx, const std::string ionSeries)
Update the information for a specific ion_series element refering to it by its index.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a multiplex element in quantitation.xml.

Use intensities of sequence ion fragment peaks within an MS/MS spectrum.

Constructor & Destructor Documentation

ms_quant_multiplex ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_multiplex ( const ms_quant_multiplex & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendIonSeries ( const std::string ionSeries )

Adds a new ion_series element at the end of the list.

In quantitation_1, only a single ions series was allowed for multiplex. This function supersedes setIonSeries().

Parameters:
ionSeries is the value to append.
void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void clearIonSeries ( )

Deletes all ions_series elements from the list.

In quantitation_1, only a single ions series was allowed for multiplex. This function supersedes dropIonSeries().

void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_multiplex * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteIonSeries ( const int idx )

Remove an ion_series element from the list in memory by its index.

Parameters:
idx should be in the range 0..getNumberOfIonSeries()-1.
Returns:
true if idx is in the correct range.
bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropExcludeInternalLabel ( )

Delete the exclude_internal_label attribute.

Disables the attribute until it is re-set.

void dropExcludeIsobaricFragments ( )

Delete the exclude_isobaric_fragments attribute.

Disables the attribute until it is re-set.

void dropIonIntensityThreshold ( )

Delete the ion_intensity_threshold attribute.

Disables the attribute until it is re-set.

void dropIonSeries ( )

Delete the ion_series element.

Deprecated:
Replaced with clearIonSeries().

In quantitation_1, only a single ions series was allowed for multiplex. This function has the same effect as calling clearIonSeries().

void dropMinIonPairs ( )

Delete the min_ion_pairs attribute.

Disables the attribute until it is re-set.

std::string getExcludeInternalLabelSchemaType ( ) const

Obtain a symbolic name for the exclude_internal_label element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getExcludeIsobaricFragmentsSchemaType ( ) const

Obtain a symbolic name for the exclude_isobaric_fragments attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getIonIntensityThreshold ( ) const

Returns the value of the ion_intensity_threshold attribute.

Specifies fragment ion intensity threshold as fraction of base peak.

Returns:
current value of the ion_intensity_threshold attribute.
std::string getIonIntensityThresholdSchemaType ( ) const

Obtain a symbolic name for the ion_intensity_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const std::string getIonSeries ( const int idx = 0 ) const

Returns a ion_series element object by its number.

In quantitation_1, only a single ions series was permitted. This function returns the first ions series if no index is specified.

Parameters:
idx should be in the range 0..getNumberOfIonSeries()-1.
Returns:
current element content.
std::string getIonSeriesSchemaType ( ) const

Obtain a symbolic name for the ion_series element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getMinIonPairs ( ) const

Returns the value of the min_ion_pairs attribute.

Specifies whether to exclude fragment ions which have a potential isobaric interferences.

Returns:
current value of the min_ion_pairs attribute.
std::string getMinIonPairsSchemaType ( ) const

Obtain a symbolic name for the min_ion_pairs attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfIonSeries ( ) const

Returns the number of ions series.

In quantitation_1, only a single ions series was allowed for multiplex.

Returns:
the number of ions series specified.
int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

bool haveExcludeInternalLabel ( ) const

Indicates presence of the exclude_internal_label attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveExcludeIsobaricFragments ( ) const

Indicates presence of the exclude_isobaric_fragments attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveIonIntensityThreshold ( ) const

Indicates presence of the ion_intensity_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveIonSeries ( ) const

Check for presence of the ion_series element.

In quantitation_1, only a single ions series was allowed for multiplex.

Returns:
TRUE if one or more ion series are specified.
bool haveMinIonPairs ( ) const

Indicates presence of the min_ion_pairs attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool isExcludeInternalLabel ( ) const

Returns the value of the exclude_internal_label attribute value.

TRUE value means label is allowed at terminus only.

Returns:
current value of the exclude_internal_label attribute.
bool isExcludeIsobaricFragments ( ) const

Returns the value of the exclude_isobaric_fragments attribute.

Specifies whether to exclude fragment ions which have a potential isobaric interferences.

Returns:
current value of the exclude_isobaric_fragments attribute.
ms_quant_multiplex & operator= ( const ms_quant_multiplex & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setExcludeInternalLabel ( const bool value )

Set a custom value for the exclude_internal_label attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropExcludeInternalLabel().

Parameters:
value a new value for the attribute.
void setExcludeIsobaricFragments ( const bool value )

Set a custom value for the exclude_isobaric_fragments attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropExcludeIsobaricFragments().

Parameters:
value a new value for the attribute.
void setIonIntensityThreshold ( const char * value )

Set a custom value for the ion_intensity_threshold attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropIonIntensityThreshold().

Parameters:
value a new value for the attribute.
void setIonSeries ( const std::string ionSeries )

Supply custom content for the ion_series element.

Deprecated:
Replaced with appendIonSeries().

In quantitation_1, only a single ions series was allowed for multiplex. This function now clears the list of ions series and replaces the list with a single new value.

Parameters:
ionSeries a new content for the element.
void setMinIonPairs ( const int value )

Set a custom value for the min_ion_pairs attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMinIonPairs().

Parameters:
value a new value for the attribute.
bool updateIonSeries | ( | const int | idx,
 |  | const std::string | ionSeries
 | ) |  |

Update the information for a specific ion_series element refering to it by its index.

Parameters:
idx | should be in the range 0..getNumberOfIonSeries()-1.
ionSeries | is the new ions series value.
Returns:
true if idx is in the correct range.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_multiplex.hpp
  • ms_quant_multiplex.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_neutralloss
Public Member Functions

ms_quant_neutralloss Class Reference
[Mascot configuration files module]

A neutral loss for the sequence ions, e.g. loss of phosphate. More...

#include <ms_quant_neutralloss.hpp>

Inheritance diagram for ms_quant_neutralloss:
[legend]
Collaboration diagram for ms_quant_neutralloss:
[legend]

List of all members.

Public Member Functions

ms_quant_neutralloss ()
Default constructor.
ms_quant_neutralloss (const ms_quant_neutralloss &src)
Copying constructor.
virtual | ~ms_quant_neutralloss ()
Destructor.
void | appendElement (const ms_quant_element *element)
Adds a new element at the end of the list.
void | clearElements ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_neutralloss *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_composition *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElement (const int idx)
Remove an element from the list.
void | dropFlag ()
Deletes the flag attribute.
const ms_quant_element * | getElement (const int idx) const
Returns an element object by its number.
std::string | getElementSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFlagSchemaType () const
Obtain a symbolic name for the flag attribute schema type.
int | getNumberOfElements () const
Returns a number of elements held.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveFlag () const
Indicates presence of the flag attribute.
bool | isFlag () const
Returns the value of the flag attribute.
ms_quant_neutralloss & | operator= (const ms_quant_neutralloss &right)
C++ style assignment operator.
void | setFlag (const bool flag)
Set a custom value for the flag attribute.
bool | updateElement (const int idx, const ms_quant_element *element)
Update the information for a specific element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A neutral loss for the sequence ions, e.g. loss of phosphate.

Constructor & Destructor Documentation

ms_quant_neutralloss ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_neutralloss ( const ms_quant_neutralloss & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendElement ( const ms_quant_element * element ) [inherited]

Adds a new element at the end of the list.

Parameters:
element an instance of element object to copy content from.
void copyFrom ( const ms_quant_neutralloss * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_composition * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_composition.

bool deleteElement ( const int idx ) [inherited]

Remove an element from the list.

Parameters:
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
void dropFlag ( )

Deletes the flag attribute.

Deletes the attribute until is re-set.

const ms_quant_element * getElement ( const int idx ) const [inherited]

Returns an element object by its number.

Parameters:
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns:
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.
std::string getElementSchemaType ( ) const [inherited]

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getFlagSchemaType ( ) const

Obtain a symbolic name for the flag attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElements ( ) const [inherited]

Returns a number of elements held.

Returns:
total number of elements in the list.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_composition.

bool haveFlag ( ) const

Indicates presence of the flag attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool isFlag ( ) const

Returns the value of the flag attribute.

Neutral losses can be potentially a scoring series (FALSE) or non-scoring satellite peaks (TRUE).

Returns:
current value of the attribute.
ms_quant_neutralloss & operator= ( const ms_quant_neutralloss & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setFlag ( const bool flag )

Set a custom value for the flag attribute.

Parameters:
flag a new value for the attribute.
bool updateElement | ( | const int | idx,
 |  | const ms_quant_element * | element
 | ) |  | [inherited]

Update the information for a specific element.

Parameters:
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns:
TRUE if the element has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

The documentation for this class was generated from the following files:
  • ms_quant_neutralloss.hpp
  • ms_quant_neutralloss.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_normalisation
Public Member Functions

ms_quant_normalisation Class Reference
[Mascot configuration files module]

An object of this class represent a single normalisation element in quantitation.xml. More...

#include <ms_quant_normalisation.hpp>

Inheritance diagram for ms_quant_normalisation:
[legend]
Collaboration diagram for ms_quant_normalisation:
[legend]

List of all members.

Public Member Functions

ms_quant_normalisation ()
Default constructor.
ms_quant_normalisation (const ms_quant_normalisation &src)
Copying constructor.
virtual | ~ms_quant_normalisation ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_normalisation *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropMethod ()
Delete the method attribute.
void | dropPeptides ()
Delete the peptides element.
void | dropProteins ()
Delete the proteins element.
std::string | getMethod () const
Returns the value of the method attribute.
std::string | getMethodSchemaType () const
Obtain a symbolic name for the method attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
const
ms_quant_normalisation_peptides * 		getPeptides () const
Returns a pointer to the peptides element.
std::string | getPeptidesSchemaType () const
Obtain a symbolic name for the peptides element schema type.
const
ms_quant_normalisation_proteins * 		getProteins () const
Returns a pointer to the proteins element.
std::string | getProteinsSchemaType () const
Obtain a symbolic name for the proteins element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveMethod () const
Indicates presence of the method attribute.
bool | havePeptides () const
Indicates presence of the peptides element.
bool | haveProteins () const
Indicates presence of the proteins element.
ms_quant_normalisation & | operator= (const ms_quant_normalisation &right)
C++ style assignment operator.
void | setMethod (const char *value)
Set a custom value for the method attribute.
void | setPeptides (const ms_quant_normalisation_peptides *peptides)
Supply custom content for peptides element.
void | setProteins (const ms_quant_normalisation_proteins *proteins)
Supply custom content for the proteins element.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single normalisation element in quantitation.xml.

Method of normalising ratios for a complete data set.

Constructor & Destructor Documentation

ms_quant_normalisation ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_normalisation ( const ms_quant_normalisation & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_normalisation * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropMethod ( )

Delete the method attribute.

Disables the attribute until it is re-set.

void dropPeptides ( )

Delete the peptides element.

Deletes the element until it is re-set.

void dropProteins ( )

Delete the proteins element.

Deletes the element until it is re-set.

std::string getMethod ( ) const

Returns the value of the method attribute.

  • Average: For each ratio, the geometric mean of all reported values for peptide matches is made unity.
  • Median: For each ratio, the median of all reported values for peptide matches is made unity.
  • Sum: (Reporter protocol only) The total intensity of each reporter ion, summed across all MS/MS spectra, is made equal.

Sum is only available for reporter protocol; average and median are only available when all protein hits are processed (i.e. REPORT=AUTO).

Returns:
current value of the method attribute.
std::string getMethodSchemaType ( ) const

Obtain a symbolic name for the method attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

const ms_quant_normalisation_peptides * getPeptides ( ) const

Returns a pointer to the peptides element.

List of peptide sequences to be used for normalisation.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getPeptidesSchemaType ( ) const

Obtain a symbolic name for the peptides element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_normalisation_proteins * getProteins ( ) const

Returns a pointer to the proteins element.

List of protein accessions to be used for normalisation.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getProteinsSchemaType ( ) const

Obtain a symbolic name for the proteins element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

bool haveMethod ( ) const

Indicates presence of the method attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool havePeptides ( ) const

Indicates presence of the peptides element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveProteins ( ) const

Indicates presence of the proteins element.

Returns:
TRUE if the element is present and FALSE otherwise.
ms_quant_normalisation & operator= ( const ms_quant_normalisation & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setMethod ( const char * value )

Set a custom value for the method attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMethod().

Parameters:
value a new value for the attribute.
void setPeptides ( const ms_quant_normalisation_peptides * peptides )

Supply custom content for peptides element.

Parameters:
peptides a new content for the element.
void setProteins ( const ms_quant_normalisation_proteins * proteins )

Supply custom content for the proteins element.

Parameters:
proteins a new content for the element.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_normalisation.hpp
  • ms_quant_normalisation.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_normalisation_peptide
Public Member Functions

ms_quant_normalisation_peptide Class Reference
[Mascot configuration files module]

An object of this class represent a single peptide element in quantitation.xml. More...

#include <ms_quant_normalisation_peptide.hpp>

List of all members.

Public Member Functions

ms_quant_normalisation_peptide ()
Default constructor.
ms_quant_normalisation_peptide (const ms_quant_normalisation_peptide &src)
Copying constructor.
virtual | ~ms_quant_normalisation_peptide ()
Destructor.
void | copyFrom (const ms_quant_normalisation_peptide *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropSequence ()
Delete the sequence attribute.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSequence () const
Returns the value of the sequence attribute.
std::string | getSequenceSchemaType () const
Obtain a symbolic name for the sequence attribute schema type.
bool | haveSequence () const
Check for presence of the sequence attribute.
ms_quant_normalisation_peptide & | operator= (const ms_quant_normalisation_peptide &right)
C++ style assignment operator.
void | setSequence (const char *value)
Supply custom content for sequence attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single peptide element in quantitation.xml.

Identifies a peptide sequence to be used for normalisation.

Constructor & Destructor Documentation

ms_quant_normalisation_peptide ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_normalisation_peptide ( const ms_quant_normalisation_peptide & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_normalisation_peptide * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropSequence ( )

Delete the sequence attribute.

Deletes the attribute until it is re-set.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
std::string getSequence ( ) const

Returns the value of the sequence attribute.

Returns:
peptide sequence string.
std::string getSequenceSchemaType ( ) const

Obtain a symbolic name for the sequence attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveSequence ( ) const

Check for presence of the sequence attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_normalisation_peptide & operator= ( const ms_quant_normalisation_peptide & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setSequence ( const char * value )

Supply custom content for sequence attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_peptide.hpp
  • ms_quant_normalisation_peptide.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_normalisation_peptides
Public Member Functions

ms_quant_normalisation_peptides Class Reference
[Mascot configuration files module]

An object of this class represent a collection of peptide elements in quantitation.xml. More...

#include <ms_quant_normalisation_peptide.hpp>

List of all members.

Public Member Functions

ms_quant_normalisation_peptides ()
Default constructor.
ms_quant_normalisation_peptides (const ms_quant_normalisation_peptides &src)
Copying constructor.
virtual | ~ms_quant_normalisation_peptides ()
Destructor.
void | appendPeptide (const ms_quant_normalisation_peptide *pep)
Adds a new peptide element at the end of the list.
void | clearPeptides ()
Deletes all peptide elements from the list.
void | copyFrom (const ms_quant_normalisation_peptides *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deletePeptide (const int idx)
Removes peptide element from the list.
int | getNumberOfPeptides () const
Returns the number of nested peptide elements.
const
ms_quant_normalisation_peptide * 		getPeptide (const int idx) const
Returns the value of the peptide element object by its number.
std::string | getPeptideSchemaType () const
Obtain a symbolic name for the peptide element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_normalisation_peptides & | operator= (const ms_quant_normalisation_peptides &right)
C++ style assignment operator.
bool | updatePeptide (const int idx, const ms_quant_normalisation_peptide *pep)
Supply new content for one of the peptide elements in the list.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a collection of peptide elements in quantitation.xml.

Constructor & Destructor Documentation

ms_quant_normalisation_peptides ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_normalisation_peptides ( const ms_quant_normalisation_peptides & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendPeptide ( const ms_quant_normalisation_peptide * pep )

Adds a new peptide element at the end of the list.

Parameters:
pep a new element to be added to the list.
void copyFrom ( const ms_quant_normalisation_peptides * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deletePeptide ( const int idx )

Removes peptide element from the list.

Parameters:
idx a zero based index of the peptide element to delete from the list.
Returns:
true if the index is in range, false otherwise
int getNumberOfPeptides ( ) const

Returns the number of nested peptide elements.

Returns:
total number of nested peptide elements.
const ms_quant_normalisation_peptide * getPeptide ( const int idx ) const

Returns the value of the peptide element object by its number.

Parameters:
idx a zero based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getPeptideSchemaType ( ) const

Obtain a symbolic name for the peptide element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
ms_quant_normalisation_peptides & operator= ( const ms_quant_normalisation_peptides & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updatePeptide | ( | const int | idx,
 |  | const ms_quant_normalisation_peptide * | pep
 | ) |  |

Supply new content for one of the peptide elements in the list.

Parameters:
idx | a zero based index of the element to update.
pep | a source to copy the content from.
Returns:
TRUE if the element has been successfully updated.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_peptide.hpp
  • ms_quant_normalisation_peptide.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_normalisation_protein
Public Member Functions

ms_quant_normalisation_protein Class Reference
[Mascot configuration files module]

An object of this class represent a single protein element in quantitation.xml. More...

#include <ms_quant_normalisation_protein.hpp>

List of all members.

Public Member Functions

ms_quant_normalisation_protein ()
Default constructor.
ms_quant_normalisation_protein (const ms_quant_normalisation_protein &src)
Copying constructor.
virtual | ~ms_quant_normalisation_protein ()
Destructor.
void | copyFrom (const ms_quant_normalisation_protein *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAccession ()
Delete the accession attribute.
std::string | getAccession () const
Returns the value of the accession attribute.
std::string | getAccessionSchemaType () const
Obtain a symbolic name for the accession attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAccession () const
Check for presence of the accession attribute.
ms_quant_normalisation_protein & | operator= (const ms_quant_normalisation_protein &right)
C++ style assignment operator.
void | setAccession (const char *value)
Supply a custom content for accession attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single protein element in quantitation.xml.

Identifies a protein to be used for normalisation.

Constructor & Destructor Documentation

ms_quant_normalisation_protein ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_normalisation_protein ( const ms_quant_normalisation_protein & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_normalisation_protein * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropAccession ( )

Delete the accession attribute.

Deletes the attribute until it is re-set.

std::string getAccession ( ) const

Returns the value of the accession attribute.

Returns:
protein accession string.
std::string getAccessionSchemaType ( ) const

Obtain a symbolic name for the accession attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
bool haveAccession ( ) const

Check for presence of the accession attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_normalisation_protein & operator= ( const ms_quant_normalisation_protein & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAccession ( const char * value )

Supply a custom content for accession attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_protein.hpp
  • ms_quant_normalisation_protein.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_normalisation_proteins
Public Member Functions

ms_quant_normalisation_proteins Class Reference
[Mascot configuration files module]

An object of this class represent a collection of peptide elements in quantitation.xml. More...

#include <ms_quant_normalisation_protein.hpp>

List of all members.

Public Member Functions

ms_quant_normalisation_proteins ()
Default constructor.
ms_quant_normalisation_proteins (const ms_quant_normalisation_proteins &src)
Copying constructor.
virtual | ~ms_quant_normalisation_proteins ()
Destructor.
void | appendProtein (const ms_quant_normalisation_protein *protein)
Adds a new protein element at the end of the list.
void | clearProteins ()
Deletes all protein elements from the list.
void | copyFrom (const ms_quant_normalisation_proteins *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteProtein (const int idx)
Removes a protein element from the list.
int | getNumberOfProteins () const
Returns a number of nested protein elements.
const
ms_quant_normalisation_protein * 		getProtein (const int idx) const
Returns the value of the protein element object by its number.
std::string | getProteinSchemaType () const
Obtain a symbolic name for the protein element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_normalisation_proteins & | operator= (const ms_quant_normalisation_proteins &right)
C++ style assignment operator.
bool | updateProtein (const int idx, const ms_quant_normalisation_protein *protein)
Supply new content for one of the protein elements in the list.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a collection of peptide elements in quantitation.xml.

Constructor & Destructor Documentation

ms_quant_normalisation_proteins ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_normalisation_proteins ( const ms_quant_normalisation_proteins & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendProtein ( const ms_quant_normalisation_protein * protein )

Adds a new protein element at the end of the list.

Parameters:
protein a new element to be added to the list.
void copyFrom ( const ms_quant_normalisation_proteins * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteProtein ( const int idx )

Removes a protein element from the list.

Parameters:
idx a zero based index of the protein element to delete from the list.
Returns:
true if the index is in range, false otherwise
int getNumberOfProteins ( ) const

Returns a number of nested protein elements.

Returns:
total number of nested protein elements.
const ms_quant_normalisation_protein * getProtein ( const int idx ) const

Returns the value of the protein element object by its number.

Parameters:
idx a zero based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getProteinSchemaType ( ) const

Obtain a symbolic name for the protein element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
ms_quant_normalisation_proteins & operator= ( const ms_quant_normalisation_proteins & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateProtein | ( | const int | idx,
 |  | const ms_quant_normalisation_protein * | protein
 | ) |  |

Supply new content for one of the protein elements in the list.

Parameters:
idx | a zero based index of the element to update.
protein | a source to copy the content from.
Returns:
TRUE if the element has been successfully updated.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_normalisation_protein.hpp
  • ms_quant_normalisation_protein.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_numerator
Public Member Functions

ms_quant_numerator Class Reference
[Mascot configuration files module]

Represent numerator_component and denominator_component elements. More...

#include <ms_quant_numerator.hpp>

List of all members.

Public Member Functions

ms_quant_numerator ()
Default constructor.
ms_quant_numerator (const ms_quant_numerator &src)
Copying constructor.
virtual | ~ms_quant_numerator ()
Destructor.
void | copyFrom (const ms_quant_numerator *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropCoefficient ()
Delete the coefficient attribute.
void | dropName ()
Delete the name attribute.
std::string | getCoefficient () const
Returns the value of the coefficient attribute.
std::string | getCoefficientSchemaType () const
Obtain a symbolic name for the coefficient attribute schema type.
std::string | getContent () const
Returns string value of the element.
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveCoefficient () const
Indicates presence of the coefficient attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_quant_numerator & | operator= (const ms_quant_numerator &right)
C++ style assignment operator.
void | setCoefficient (const char *value)
Set a custom value for the coefficient attribute.
void | setContent (const char *value)
Set a custom value for the the element.
void | setName (const char *value)
Set a custom value for the name attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represent numerator_component and denominator_component elements.

Constructor & Destructor Documentation

ms_quant_numerator ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_numerator ( const ms_quant_numerator & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_numerator * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropCoefficient ( )

Delete the coefficient attribute.

Deletes the attribute until is re-set.

void dropName ( )

Delete the name attribute.

Deletes the attribute until is re-set.

std::string getCoefficient ( ) const

Returns the value of the coefficient attribute.

Returns:
coefficient used to form linear combination of values.
std::string getCoefficientSchemaType ( ) const

Obtain a symbolic name for the coefficient attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getContent ( ) const

Returns string value of the element.

Returns:
string value of the element content.
std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
bool haveCoefficient ( ) const

Indicates presence of the coefficient attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveName ( ) const

Indicates presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_numerator & operator= ( const ms_quant_numerator & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setCoefficient ( const char * value )

Set a custom value for the coefficient attribute.

Parameters:
value a new value for the attribute.
void setContent ( const char * value )

Set a custom value for the the element.

Parameters:
value a new string value for the content.
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_numerator.hpp
  • ms_quant_numerator.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_outliers
Public Member Functions

ms_quant_outliers Class Reference
[Mascot configuration files module]

An object of this class represent a single OUTLIERS element in quantitation.xml. More...

#include <ms_quant_outliers.hpp>

Inheritance diagram for ms_quant_outliers:
[legend]
Collaboration diagram for ms_quant_outliers:
[legend]

List of all members.

Public Member Functions

ms_quant_outliers ()
Default constructor.
ms_quant_outliers (const ms_quant_outliers &src)
Copying constructor.
virtual | ~ms_quant_outliers ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_outliers *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropMethod ()
Delete the method attribute.
std::string | getMethod () const
Returns the value of the method attribute.
std::string | getMethodSchemaType () const
Obtain a symbolic name for the method attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveMethod () const
Indicates presence of the method attribute.
ms_quant_outliers & | operator= (const ms_quant_outliers &right)
C++ style assignment operator.
void | setMethod (const char *value)
Set a custom value for the method attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single OUTLIERS element in quantitation.xml.

Method and parameters to be used to remove outliers. If missing, no outlier removal is performed.

Constructor & Destructor Documentation

ms_quant_outliers ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_outliers ( const ms_quant_outliers & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_outliers * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropMethod ( )

Delete the method attribute.

Disables the attribute until it is re-set.

std::string getMethod ( ) const

Returns the value of the method attribute.

The method attribute specifies the outlier detection algorithm.

Returns:
current value of the method attribute.
std::string getMethodSchemaType ( ) const

Obtain a symbolic name for the method attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

bool haveMethod ( ) const

Indicates presence of the method attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
ms_quant_outliers & operator= ( const ms_quant_outliers & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setMethod ( const char * value )

Set a custom value for the method attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropMethod().

Parameters:
value a new value for the attribute.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_outliers.hpp
  • ms_quant_outliers.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_parameter
Public Member Functions

ms_quant_parameter Class Reference
[Mascot configuration files module]

Parameter name and value pair. More...

#include <ms_quant_parameters.hpp>

Inheritance diagram for ms_quant_parameter:
[legend]
Collaboration diagram for ms_quant_parameter:
[legend]

List of all members.

Public Member Functions

ms_quant_parameter ()
Default constructor.
ms_quant_parameter (const ms_quant_parameter &src)
Copying constructor.
virtual | ~ms_quant_parameter ()
Destructor.
void | copyFrom (const ms_quant_parameter *right)
Copies all content from another instance.
void | copyFrom (const ms_xml_parameter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDescription ()
Delete the description attribute.
void | dropName ()
Delete the name attribute.
std::string | getDescription () const
Returns the value of the description attribute.
virtual std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
std::string | getName () const
Returns the value of the name attribute.
virtual std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the value of the value attribute.
virtual std::string | getValueSchemaType () const
Obtain a symbolic name for the value attribute schema type.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_quant_parameter & | operator= (const ms_quant_parameter &right)
C++ style assignment operator.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setValue (const char *value)
Set a custom value for the value attribute.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

Constructor & Destructor Documentation

ms_quant_parameter ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_parameter ( const ms_quant_parameter & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_parameter * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_xml_parameter * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( ) [inherited]

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented in ms_crosslinking_parameter.

void dropDescription ( ) [inherited]

Delete the description attribute.

Deletes the attribute until is re-set.

void dropName ( ) [inherited]

Delete the name attribute.

Deletes the attribute until is re-set.

std::string getDescription ( ) const [inherited]

Returns the value of the description attribute.

Returns:
a free text description of this parameter.
std::string getDescriptionSchemaType ( ) const [virtual]

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameter.

std::string getName ( ) const [inherited]

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const [virtual]

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameter.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Implements ms_xml_parameter.

std::string getValue ( ) const [inherited]

Returns the value of the value attribute.

Returns:
a string value of this parameter.
std::string getValueSchemaType ( ) const [virtual]

Obtain a symbolic name for the value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameter.

bool haveDescription ( ) const [inherited]

Indicates presence of the description attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveName ( ) const [inherited]

Indicates presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_parameter & operator= ( const ms_quant_parameter & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setDescription ( const char * value ) [inherited]

Set a custom value for the description attribute.

Parameters:
value a new value for the attribute.
void setName ( const char * value ) [inherited]

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
void setValue ( const char * value ) [inherited]

Set a custom value for the value attribute.

Parameters:
value a new string value for the parameter.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_parameters.hpp
  • ms_quant_parameters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_parameters
Public Member Functions

ms_quant_parameters Class Reference
[Mascot configuration files module]

A class that represents base parametersType in quantitation.xml. More...

#include <ms_quant_parameters.hpp>

Inheritance diagram for ms_quant_parameters:
[legend]
Collaboration diagram for ms_quant_parameters:
[legend]

List of all members.

Public Member Functions

ms_quant_parameters ()
Default constructor.
ms_quant_parameters (const ms_quant_parameters &src)
Copying constructor.
virtual | ~ms_quant_parameters ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_parameters & | operator= (const ms_quant_parameters &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A class that represents base parametersType in quantitation.xml.

Holds a list of parameters.

Constructor & Destructor Documentation

ms_quant_parameters ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_parameters ( const ms_quant_parameters & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item )

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_parameters * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_xml_parameters.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

bool deleteParameterByName ( const char * name ) [virtual]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

int getNumberOfParameters ( ) const [virtual]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Implements ms_xml_parameters.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

ms_quant_parameters & operator= ( const ms_quant_parameters & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  |

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [inherited]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

The documentation for this class was generated from the following files:
  • ms_quant_parameters.hpp
  • ms_quant_parameters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_pepneutralloss
Public Member Functions

ms_quant_pepneutralloss Class Reference
[Mascot configuration files module]

A neutral loss from the precursor. More...

#include <ms_quant_pepneutralloss.hpp>

Inheritance diagram for ms_quant_pepneutralloss:
[legend]
Collaboration diagram for ms_quant_pepneutralloss:
[legend]

List of all members.

Public Member Functions

ms_quant_pepneutralloss ()
Default constructor.
ms_quant_pepneutralloss (const ms_quant_pepneutralloss &src)
Copying constructor.
virtual | ~ms_quant_pepneutralloss ()
Destructor.
void | appendElement (const ms_quant_element *element)
Adds a new element at the end of the list.
void | clearElements ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_pepneutralloss *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_composition *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElement (const int idx)
Remove an element from the list.
void | dropRequired ()
Deletes the required attribute.
const ms_quant_element * | getElement (const int idx) const
Returns an element object by its number.
std::string | getElementSchemaType () const
Obtain a symbolic name for the element's schema type.
int | getNumberOfElements () const
Returns a number of elements held.
std::string | getRequiredSchemaType () const
Obtain a symbolic name for the required attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveRequired () const
Indicates presence of the required attribute.
bool | isRequired () const
Returns the value of the required attribute.
ms_quant_pepneutralloss & | operator= (const ms_quant_pepneutralloss &right)
C++ style assignment operator.
void | setRequired (const bool required)
Set a custom value for the required attribute.
bool | updateElement (const int idx, const ms_quant_element *element)
Update the information for a specific element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A neutral loss from the precursor.

Constructor & Destructor Documentation

ms_quant_pepneutralloss ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_pepneutralloss ( const ms_quant_pepneutralloss & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendElement ( const ms_quant_element * element ) [inherited]

Adds a new element at the end of the list.

Parameters:
element an instance of element object to copy content from.
void copyFrom ( const ms_quant_pepneutralloss * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_composition * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_composition.

bool deleteElement ( const int idx ) [inherited]

Remove an element from the list.

Parameters:
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
void dropRequired ( )

Deletes the required attribute.

Deletes the attribute until is re-set.

const ms_quant_element * getElement ( const int idx ) const [inherited]

Returns an element object by its number.

Parameters:
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns:
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.
std::string getElementSchemaType ( ) const [inherited]

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElements ( ) const [inherited]

Returns a number of elements held.

Returns:
total number of elements in the list.
std::string getRequiredSchemaType ( ) const

Obtain a symbolic name for the required attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_composition.

bool haveRequired ( ) const

Indicates presence of the required attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool isRequired ( ) const

Returns the value of the required attribute.

TRUE if this is a required neutral loss.

Returns:
current value of the attribute.
ms_quant_pepneutralloss & operator= ( const ms_quant_pepneutralloss & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setRequired ( const bool required )

Set a custom value for the required attribute.

Parameters:
required a new value for the attribute.
bool updateElement | ( | const int | idx,
 |  | const ms_quant_element * | element
 | ) |  | [inherited]

Update the information for a specific element.

Parameters:
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns:
TRUE if the element has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_quant_composition.

The documentation for this class was generated from the following files:
  • ms_quant_pepneutralloss.hpp
  • ms_quant_pepneutralloss.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_precursor
Public Member Functions

ms_quant_precursor Class Reference
[Mascot configuration files module]

An object of this class represent a single precursor element in quantitation.xml. More...

#include <ms_quant_precursor.hpp>

Inheritance diagram for ms_quant_precursor:
[legend]
Collaboration diagram for ms_quant_precursor:
[legend]

List of all members.

Public Member Functions

ms_quant_precursor ()
Default constructor.
ms_quant_precursor (const ms_quant_precursor &src)
Copying constructor.
virtual | ~ms_quant_precursor ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_precursor *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropAllChargeStates ()
void | dropAllowElutionShift ()
void | dropAllowMassTimeMatch ()
Delete the allow_mass_time_match attribute.
std::string | getAllChargeStatesSchemaType () const
std::string | getAllowElutionShiftSchemaType () const
std::string | getAllowMassTimeMatchSchemaType () const
Obtain a symbolic name for the allow_mass_time_match attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAllChargeStates () const
bool | haveAllowElutionShift () const
bool | haveAllowMassTimeMatch () const
Indicates presence of the allow_mass_time_match attribute.
bool | isAllChargeStates () const
bool | isAllowElutionShift () const
bool | isAllowMassTimeMatch () const
Returns the value of the allow_mass_time_match attribute.
ms_quant_precursor & | operator= (const ms_quant_precursor &right)
C++ style assignment operator.
void | setAllowMassTimeMatch (const bool value)
Set a custom value for the allow_mass_time_match attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single precursor element in quantitation.xml.

Serves as a possible sub-element of "protocol" element

Constructor & Destructor Documentation

ms_quant_precursor ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_precursor ( const ms_quant_precursor & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_precursor * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropAllChargeStates ( )
Deprecated:
Moved to ms_quant_integration.

This function is no longer available in Parser 2.3 See ms_quant_integration::setAllChargeStates(). param value new value

Deprecated:
Moved to ms_quant_integration.
void dropAllowElutionShift ( )
Deprecated:
Moved to ms_quant_integration.

This function is no longer available in Parser 2.3 See ms_quant_integration::setAllowElutionShift(). param value new value

Deprecated:
Moved to ms_quant_integration.
void dropAllowMassTimeMatch ( )

Delete the allow_mass_time_match attribute.

Disables the attribute until it is re-set.

std::string getAllChargeStatesSchemaType ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns:
all charge states schema type
std::string getAllowElutionShiftSchemaType ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns:
allow elution shift schema type
std::string getAllowMassTimeMatchSchemaType ( ) const

Obtain a symbolic name for the allow_mass_time_match attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

bool haveAllChargeStates ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns:
true if all charge states is set, false otherwise
bool haveAllowElutionShift ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns:
true if allow elution shift is set, false otherwise
bool haveAllowMassTimeMatch ( ) const

Indicates presence of the allow_mass_time_match attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool isAllChargeStates ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns:
true if all charge states is set, false otherwise
bool isAllowElutionShift ( ) const
Deprecated:
Moved to ms_quant_integration.
Returns:
true if allow elution shift is set, false otherwise
bool isAllowMassTimeMatch ( ) const

Returns the value of the allow_mass_time_match attribute.

If false, we only report a ratio if we have peptide matches to both components. Also, if false, then all_charge_states treated as false, even if true in method. Almost always set true in practice.

Returns:
TRUE/FALSE.
ms_quant_precursor & operator= ( const ms_quant_precursor & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAllowMassTimeMatch ( const bool value )

Set a custom value for the allow_mass_time_match attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropAllowMassTimeMatch().

Parameters:
value a new value for the attribute.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_precursor.hpp
  • ms_quant_precursor.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_protocol
Public Member Functions

ms_quant_protocol Class Reference
[Mascot configuration files module]

An object of this class represent a protocol element in quantitation.xml. More...

#include <ms_quant_protocol.hpp>

List of all members.

Public Member Functions

ms_quant_protocol ()
Default constructor.
ms_quant_protocol (const ms_quant_protocol &src)
Copying constructor.
virtual | ~ms_quant_protocol ()
Destructor.
void | copyFrom (const ms_quant_protocol *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
const ms_quant_average * | getAverage () const
Returns the average element or a null value if not available.
std::string | getAverageSchemaType () const
Obtain a symbolic name for the average element schema type.
const ms_quant_multiplex * | getMultiplex () const
Returns the multiplex element or a null value if not available.
std::string | getMultiplexSchemaType () const
Obtain a symbolic name for the multiplex element schema type.
const ms_quant_precursor * | getPrecursor () const
Returns the precursor element or a null value if not available.
std::string | getPrecursorSchemaType () const
Obtain a symbolic name for the precursor element schema type.
const ms_quant_replicate * | getReplicate () const
Returns the replicate element or a null value if not available.
std::string | getReplicateSchemaType () const
Obtain a symbolic name for the replicate element schema type.
const ms_quant_reporter * | getReporter () const
Returns the reporter element or a null value if not available.
std::string | getReporterSchemaType () const
Obtain a symbolic name for the reporter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getType () const
Call this method first to determine which sub element to retrieve.
ms_quant_protocol & | operator= (const ms_quant_protocol &right)
C++ style assignment operator.
void | setAverage (const ms_quant_average *average)
Override content with another average element.
void | setMultiplex (const ms_quant_multiplex *multiplex)
Override content with another multiplex element.
void | setNull ()
Sets content of the protocol element to a null value and deletes all previously held information.
void | setPrecursor (const ms_quant_precursor *precursor)
Override content with another precursor element.
void | setReplicate (const ms_quant_replicate *replicate)
Override content with another replicate element.
void | setReporter (const ms_quant_reporter *reporter)
Override content with another reporter element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a protocol element in quantitation.xml.

6 different protocols are currently supported, and an object of this class is a container for exactly one of those protocols. The getType() function returns a string which contains the protocol for the current quantitation method. Use the return value from it to determine which of the functions to call to get further protocol details.

Constructor & Destructor Documentation

ms_quant_protocol ( const ms_quant_protocol & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_protocol * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

const ms_quant_average * getAverage ( ) const

Returns the average element or a null value if not available.

Call this method only if getType() returns average.

Returns:
an average element object. See Maintaining object references: two rules of thumb.
std::string getAverageSchemaType ( ) const

Obtain a symbolic name for the average element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_multiplex * getMultiplex ( ) const

Returns the multiplex element or a null value if not available.

Call this method only if getType() returns "multiplex".

Returns:
a multiplex element object. See Maintaining object references: two rules of thumb.
std::string getMultiplexSchemaType ( ) const

Obtain a symbolic name for the multiplex element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_precursor * getPrecursor ( ) const

Returns the precursor element or a null value if not available.

Call this method only if getType() returns "precursor".

Returns:
a precursor element object. See Maintaining object references: two rules of thumb.
std::string getPrecursorSchemaType ( ) const

Obtain a symbolic name for the precursor element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_replicate * getReplicate ( ) const

Returns the replicate element or a null value if not available.

Call this method only if getType() returns "replicate".

Returns:
a replicate element object. See Maintaining object references: two rules of thumb.
std::string getReplicateSchemaType ( ) const

Obtain a symbolic name for the replicate element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_reporter * getReporter ( ) const

Returns the reporter element or a null value if not available.

Call this method only if getType() returns "reporter".

Returns:
a reporter element object. See Maintaining object references: two rules of thumb.
std::string getReporterSchemaType ( ) const

Obtain a symbolic name for the reporter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
std::string getType ( ) const

Call this method first to determine which sub element to retrieve.

This table describes possible return values and which function to then call.

String returned | Function to call required
reporter | getReporter()
average | getAverage()
precursor | getPrecursor()
multiplex | getMultiplex()
replicate | getReplicate()
null | Indicates that the object is not initialised

If, for example, getReporter() is called when the return value from this function is "average", then a null value will be returned.

Calling one of the setXXX()-methods will change the protocol type returned by this method.

Returns:
type of the protocol.
ms_quant_protocol & operator= ( const ms_quant_protocol & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAverage ( const ms_quant_average * average )

Override content with another average element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters:
average a new value for the average element.
void setMultiplex ( const ms_quant_multiplex * multiplex )

Override content with another multiplex element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters:
multiplex a new value for the multiplex element.
void setNull ( )

Sets content of the protocol element to a null value and deletes all previously held information.

Call this to clear the content and set sub-element as "null".

void setPrecursor ( const ms_quant_precursor * precursor )

Override content with another precursor element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters:
precursor a new value for the precursor element.
void setReplicate ( const ms_quant_replicate * replicate )

Override content with another replicate element.

Calling this method with a null value as a parameter will set the protocol type to "null".

Parameters:
replicate a new value for the replicate element.
void setReporter ( const ms_quant_reporter * reporter )

Override content with another reporter element.

Calling this method with a null value as a parameter will set the protocol type to "null"

Parameters:
reporter a new value for the reporter element.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_protocol.hpp
  • ms_quant_protocol.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_quality
Public Member Functions

ms_quant_quality Class Reference
[Mascot configuration files module]

An object of this class represent a single quality element in quantitation.xml. More...

#include <ms_quant_quality.hpp>

Inheritance diagram for ms_quant_quality:
[legend]
Collaboration diagram for ms_quant_quality:
[legend]

List of all members.

Public Member Functions

ms_quant_quality ()
Default constructor.
ms_quant_quality (const ms_quant_quality &src)
Copying constructor.
virtual | ~ms_quant_quality ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_quality *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropIsolatedPrecursor ()
Delete the isolated_precursor attribute.
void | dropIsolatedPrecursorThreshold ()
Delete the isolated_precursor_threshold attribute.
void | dropMinimumA1 ()
Delete the minimum_a1 attribute.
void | dropMinPrecursorCharge ()
Delete the min_precursor_charge attribute.
void | dropPepThresholdType ()
Delete the pep_threshold_type attribute.
void | dropPepThresholdValue ()
Delete the pep_threshold_value attribute.
void | dropTotalIntensity ()
Delete the total_intensity attribute.
void | dropTotalIntensityThreshold ()
Delete the total_intensity_threshold attribute.
void | dropUniquePepseq ()
Delete the unique_pepseq attribute.
std::string | getIsolatedPrecursorSchemaType () const
Obtain a symbolic name for the isolated_precursor attribute schema type.
std::string | getIsolatedPrecursorThreshold () const
Returns the value of the isolated_precursor_threshold attribute.
std::string | getIsolatedPrecursorThresholdSchemaType () const
Obtain a symbolic name for the isolated_precursor_threshold attribute schema type.
std::string | getMinimumA1 () const
Returns the value of the minimum_a1 attribute.
std::string | getMinimumA1SchemaType () const
Obtain a symbolic name for the minimum_a1 attribute schema type.
int | getMinPrecursorCharge () const
Returns the value of the min_precursor_charge attribute.
std::string | getMinPrecursorChargeSchemaType () const
Obtain a symbolic name for the min_precursor_charge attribute schema type.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getPepThresholdType () const
Returns the value of the pep_threshold_type attribute.
std::string | getPepThresholdTypeSchemaType () const
Obtain a symbolic name for the pep_threshold_type attribute schema type.
std::string | getPepThresholdValue () const
Returns the value of the pep_threshold_value attribute.
std::string | getPepThresholdValueSchemaType () const
Obtain a symbolic name for the "pep_threshold_value" schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTotalIntensitySchemaType () const
Obtain a symbolic name for the total_intensity attribute schema type.
std::string | getTotalIntensityThreshold () const
Returns the value of the total_intensity_threshold attribute.
std::string | getTotalIntensityThresholdSchemaType () const
Obtain a symbolic name for the total_intensity_threshold attribute schema type.
std::string | getUniquePepseqSchemaType () const
Obtain a symbolic name for the unique_pepseq attribute schema type.
bool | haveIsolatedPrecursor () const
Indicates presence of the isolated_precursor attribute.
bool | haveIsolatedPrecursorThreshold () const
Indicates presence of the isolated_precursor_threshold attribute.
bool | haveMinimumA1 () const
Indicates presence of the minimum_a1 attribute.
bool | haveMinPrecursorCharge () const
Indicates presence of the min_precursor_charge attribute.
bool | havePepThresholdType () const
Indicates presence of the pep_threshold_type attribute.
bool | havePepThresholdValue () const
Indicates presence of the pep_threshold_value attribute.
bool | haveTotalIntensity () const
Indicates presence of the total_intensity attribute.
bool | haveTotalIntensityThreshold () const
Indicates presence of the total_intensity_threshold attribute.
bool | haveUniquePepseq () const
Indicates presence of the unique_pepseq attribute.
bool | isIsolatedPrecursor () const
Returns the value of the isolated_precursor attribute.
bool | isTotalIntensity () const
Returns the value of the total_intensity attribute.
bool | isUniquePepseq () const
Returns the value of the unique_pepseq attribute.
ms_quant_quality & | operator= (const ms_quant_quality &right)
C++ style assignment operator.
void | setIsolatedPrecursor (const bool value)
Set a custom value for the isolated_precursor attribute.
void | setIsolatedPrecursorThreshold (const char *value)
Set a custom value for the isolated_precursor_threshold attribute.
void | setMinimumA1 (const char *value)
Set a custom value for the minimum_a1 attribute.
void | setMinPrecursorCharge (const int value)
Set a custom value for the min_precursor_charge attribute.
void | setPepThresholdType (const char *value)
Set a custom value for the pep_threshold_type attribute.
void | setPepThresholdValue (const char *value)
Set a custom value for the pep_threshold_value attribute.
void | setTotalIntensity (bool value)
Set a custom value for the total_intensity attribute.
void | setTotalIntensityThreshold (std::string value)
Set a custom value for the total_intensity_threshold attribute.
void | setUniquePepseq (bool value)
Set a custom value for the unique_pepseq attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single quality element in quantitation.xml.

Constructor & Destructor Documentation

ms_quant_quality ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_quality ( const ms_quant_quality & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_quality * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropIsolatedPrecursor ( )

Delete the isolated_precursor attribute.

Disables the attribute until it is re-set.

void dropIsolatedPrecursorThreshold ( )

Delete the isolated_precursor_threshold attribute.

Disables the attribute until it is re-set.

void dropMinimumA1 ( )

Delete the minimum_a1 attribute.

Disables the attribute until it is re-set.

void dropMinPrecursorCharge ( )

Delete the min_precursor_charge attribute.

Disables the attribute until it is re-set.

void dropPepThresholdType ( )

Delete the pep_threshold_type attribute.

Disables the attribute until it is re-set.

void dropPepThresholdValue ( )

Delete the pep_threshold_value attribute.

Disables the attribute until it is re-set.

void dropTotalIntensity ( )

Delete the total_intensity attribute.

Disables the attribute until it is re-set.

void dropTotalIntensityThreshold ( )

Delete the total_intensity_threshold attribute.

Disables the attribute until it is re-set.

void dropUniquePepseq ( )

Delete the unique_pepseq attribute.

Disables the attribute until it is re-set.

std::string getIsolatedPrecursorSchemaType ( ) const

Obtain a symbolic name for the isolated_precursor attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getIsolatedPrecursorThreshold ( ) const

Returns the value of the isolated_precursor_threshold attribute.

Threshold on the fraction of the peak area in the precursor region accounted for by the components.

Returns:
current value of the isolated_precursor_threshold attribute.
std::string getIsolatedPrecursorThresholdSchemaType ( ) const

Obtain a symbolic name for the isolated_precursor_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMinimumA1 ( ) const

Returns the value of the minimum_a1 attribute.

See Hsu, J. L., et al.: "Beyond quantitative proteomics: Signal enhancement of the a(1) ion as a mass tag for peptide sequencing using dimethyl labeling". Journal of Proteome Research 4 101-108 (2005).

Returns:
current value of the minimum_a1 attribute.
std::string getMinimumA1SchemaType ( ) const

Obtain a symbolic name for the minimum_a1 attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getMinPrecursorCharge ( ) const

Returns the value of the min_precursor_charge attribute.

Unsigned integer, corresponding to abs(charge), in case anyone is using negative ions.

Returns:
current value of the min_precursor_charge attribute.
std::string getMinPrecursorChargeSchemaType ( ) const

Obtain a symbolic name for the min_precursor_charge attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getPepThresholdType ( ) const

Returns the value of the pep_threshold_type attribute.

Type of significance threshold for peptide matches.

Returns:
current value of the pep_threshold_type attribute.
std::string getPepThresholdTypeSchemaType ( ) const

Obtain a symbolic name for the pep_threshold_type attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getPepThresholdValue ( ) const

Returns the value of the pep_threshold_value attribute.

Value of significance threshold for peptide matches (only used by certain threshold types).

Returns:
current value of the pep_threshold_value attribute.
std::string getPepThresholdValueSchemaType ( ) const

Obtain a symbolic name for the "pep_threshold_value" schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

std::string getTotalIntensitySchemaType ( ) const

Obtain a symbolic name for the total_intensity attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getTotalIntensityThreshold ( ) const

Returns the value of the total_intensity_threshold attribute.

If TRUE, only report ratios for peptide sequences where the the totalIntensity of fitted peaks across the XIC peak exceeds the value of the total_intensity_threshold attribute.

Returns:
current value of the total_intensity_threshold attribute.
std::string getTotalIntensityThresholdSchemaType ( ) const

Obtain a symbolic name for the total_intensity_threshold attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getUniquePepseqSchemaType ( ) const

Obtain a symbolic name for the unique_pepseq attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveIsolatedPrecursor ( ) const

Indicates presence of the isolated_precursor attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveIsolatedPrecursorThreshold ( ) const

Indicates presence of the isolated_precursor_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveMinimumA1 ( ) const

Indicates presence of the minimum_a1 attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveMinPrecursorCharge ( ) const

Indicates presence of the min_precursor_charge attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool havePepThresholdType ( ) const

Indicates presence of the pep_threshold_type attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool havePepThresholdValue ( ) const

Indicates presence of the pep_threshold_value attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveTotalIntensity ( ) const

Indicates presence of the total_intensity attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveTotalIntensityThreshold ( ) const

Indicates presence of the total_intensity_threshold attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveUniquePepseq ( ) const

Indicates presence of the unique_pepseq attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool isIsolatedPrecursor ( ) const

Returns the value of the isolated_precursor attribute.

Determines whether to perform test for matched_fraction.

Returns:
current value of the isolated_precursor attribute.
bool isTotalIntensity ( ) const

Returns the value of the total_intensity attribute.

Determines whether to apply the test for totalIntensity

Returns:
current value of the total_intensity attribute.
bool isUniquePepseq ( ) const

Returns the value of the unique_pepseq attribute.

If TRUE, only report ratios for peptide sequences that are unique to one protein hit (which may be a family containing multiple proteins).

Returns:
current value of the unique_pepseq attribute.
ms_quant_quality & operator= ( const ms_quant_quality & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setIsolatedPrecursor ( const bool value )

Set a custom value for the isolated_precursor attribute.

Parameters:
value a new value for the attribute.
void setIsolatedPrecursorThreshold ( const char * value )

Set a custom value for the isolated_precursor_threshold attribute.

Parameters:
value a new value for the attribute.
void setMinimumA1 ( const char * value )

Set a custom value for the minimum_a1 attribute.

Parameters:
value a new value for the attribute.
void setMinPrecursorCharge ( const int value )

Set a custom value for the min_precursor_charge attribute.

Parameters:
value a new value for the attribute.
void setPepThresholdType ( const char * value )

Set a custom value for the pep_threshold_type attribute.

Parameters:
value a new value for the attribute.
void setPepThresholdValue ( const char * value )

Set a custom value for the pep_threshold_value attribute.

Parameters:
value a new value for the attribute.
void setTotalIntensity ( bool value )

Set a custom value for the total_intensity attribute.

Parameters:
value a new value for the attribute.
void setTotalIntensityThreshold ( std::string value )

Set a custom value for the total_intensity_threshold attribute.

Parameters:
value a new value for the attribute.
void setUniquePepseq ( bool value )

Set a custom value for the unique_pepseq attribute.

Parameters:
value a new value for the attribute.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_quality.hpp
  • ms_quant_quality.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_ratio
Public Member Functions

ms_quant_ratio Class Reference
[Mascot configuration files module]

Represents the ratioType type for the report_ratio element in quantitation.xml. More...

#include <ms_quant_ratio.hpp>

List of all members.

Public Member Functions

ms_quant_ratio ()
Default constructor.
ms_quant_ratio (const ms_quant_ratio &src)
Copying constructor.
virtual | ~ms_quant_ratio ()
Destructor.
void | appendDenominator (const ms_quant_numerator *denominator)
Adds a new denominator at the end of the list.
void | appendNumerator (const ms_quant_numerator *numerator)
Adds a new numerator at the end of the list.
void | clearDenominators ()
Deletes all denominators from the list.
void | clearNumerators ()
Deletes all numerators from the list.
void | copyFrom (const ms_quant_ratio *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteDenominatorByName (const char *name)
Remove a denominator from the list in memory by its unique name.
bool | deleteDenominatorByNumber (const int idx)
Remove a denominator from the list in memory by its index.
bool | deleteNumeratorByName (const char *name)
Remove a numerator from the list in memory by its unique name.
bool | deleteNumeratorByNumber (const int idx)
Remove a numerator from the list in memory by its index.
void | dropName ()
Delete the name attribute.
const ms_quant_numerator * | getDenominatorByName (const char *name) const
Returns a denominator object by its name or a null value in case of not found.
const ms_quant_numerator * | getDenominatorByNumber (const int idx) const
Returns a denominator object by its number or a null value in case of not found.
std::string | getDenominatorSchemaType () const
Obtain a symbolic name for the denominator element schema type.
std::string | getName () const
Returns the value of the name attribute.
std::string | getNameSchemaType () const
Obtain a symbolic name for the name attribute schema type.
int | getNumberOfDenominators () const
Returns a number of nested denominators.
int | getNumberOfNumerators () const
Returns the number of nested numerators.
const ms_quant_numerator * | getNumeratorByName (const char *name) const
Returns a numerator object by its name or a null value in case of not found.
const ms_quant_numerator * | getNumeratorByNumber (const int idx) const
Returns a numerator object by its number or a null value in case of not found.
std::string | getNumeratorSchemaType () const
Obtain a symbolic name for the numerator element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveName () const
Indicates presence of the name attribute.
ms_quant_ratio & | operator= (const ms_quant_ratio &right)
C++ style assignment operator.
void | setName (const char *value)
Set a custom value for the name attribute.
bool | updateDenominatorByName (const char *name, const ms_quant_numerator *denominator)
Update the information for a specific denominator refering to it by its unique name.
bool | updateDenominatorByNumber (const int idx, const ms_quant_numerator *denominator)
Update the information for a specific denominator refering to it by its index.
bool | updateNumeratorByName (const char *name, const ms_quant_numerator *numerator)
Update the information for a specific numerator refering to it by its unique name.
bool | updateNumeratorByNumber (const int idx, const ms_quant_numerator *numerator)
Update the information for a specific numerator refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the ratioType type for the report_ratio element in quantitation.xml.

Constructor & Destructor Documentation

ms_quant_ratio ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_ratio ( const ms_quant_ratio & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendDenominator ( const ms_quant_numerator * denominator )

Adds a new denominator at the end of the list.

Creates a new denominator object, copies all content from the object supplied as a parameter and adds it at the end of the denominators list.

Parameters:
denominator an instance of denominator object to copy content from.
void appendNumerator ( const ms_quant_numerator * numerator )

Adds a new numerator at the end of the list.

Creates a new numerator object, copies all content from the object supplied as a parameter and adds it at the end of the numerators list.

Parameters:
numerator an instance of numerator object to copy content from.
void copyFrom ( const ms_quant_ratio * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteDenominatorByName ( const char * name )

Remove a denominator from the list in memory by its unique name.

Parameters:
name name of the denominator for deletion.
Returns:
TRUE if the denominator has been found and successfully deleted and FALSE otherwise.
bool deleteDenominatorByNumber ( const int idx )

Remove a denominator from the list in memory by its index.

Parameters:
idx number of the denominator for deletion from 0 to (getNumberOfDenominators() - 1).
Returns:
TRUE if the denominator has been found and successfully deleted and FALSE otherwise.
bool deleteNumeratorByName ( const char * name )

Remove a numerator from the list in memory by its unique name.

Parameters:
name name of the numerator for deletion.
Returns:
TRUE if the numerator has been found and successfully deleted and FALSE otherwise.
bool deleteNumeratorByNumber ( const int idx )

Remove a numerator from the list in memory by its index.

Parameters:
idx number of the numerator for deletion from 0 to (getNumberOfNumerators() - 1).
Returns:
TRUE if the numerator has been found and successfully deleted and FALSE otherwise.
void dropName ( )

Delete the name attribute.

Deletes the attribute until it is re-set.

const ms_quant_numerator * getDenominatorByName ( const char * name ) const

Returns a denominator object by its name or a null value in case of not found.

Parameters:
name name of the denominator to find.
Returns:
a read-only pointer to a denominator object. See Maintaining object references: two rules of thumb.
const ms_quant_numerator * getDenominatorByNumber ( const int idx ) const

Returns a denominator object by its number or a null value in case of not found.

Parameters:
idx number of the denominator from 0 to (getNumberOfDenominators() - 1).
Returns:
a read-only pointer to a denominator object. See Maintaining object references: two rules of thumb.
std::string getDenominatorSchemaType ( ) const

Obtain a symbolic name for the denominator element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getName ( ) const

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_numerator * getNumeratorByName ( const char * name ) const

Returns a numerator object by its name or a null value in case of not found.

Parameters:
name name of the numerator to find.
Returns:
a read-only pointer to a numerator object. See Maintaining object references: two rules of thumb.
const ms_quant_numerator * getNumeratorByNumber ( const int idx ) const

Returns a numerator object by its number or a null value in case of not found.

Parameters:
idx number of the numerator from 0 to (getNumberOfNumerators() - 1).
Returns:
a read-only pointer to a numerator object. See Maintaining object references: two rules of thumb.
std::string getNumeratorSchemaType ( ) const

Obtain a symbolic name for the numerator element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
bool haveName ( ) const

Indicates presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_quant_ratio & operator= ( const ms_quant_ratio & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
bool updateDenominatorByName | ( | const char * | name,
 |  | const ms_quant_numerator * | denominator
 | ) |  |

Update the information for a specific denominator refering to it by its unique name.

Parameters:
name | name of the denominator for updating.
denominator | an object to copy the content from.
Returns:
TRUE if the denominator has been found and successfully updated and FALSE otherwise.
bool updateDenominatorByNumber | ( | const int | idx,
 |  | const ms_quant_numerator * | denominator
 | ) |  |

Update the information for a specific denominator refering to it by its index.

Parameters:
idx | number of the denominator for updating from 0 to (getNumberOfDenominators() - 1).
denominator | an object to copy the content from.
Returns:
TRUE if the denominator has been found and successfully updated and FALSE otherwise.
bool updateNumeratorByName | ( | const char * | name,
 |  | const ms_quant_numerator * | numerator
 | ) |  |

Update the information for a specific numerator refering to it by its unique name.

Parameters:
name | name of the numerator for updating.
numerator | an object to copy the content from.
Returns:
TRUE if the numerator has been found and successfully updated and FALSE otherwise.
bool updateNumeratorByNumber | ( | const int | idx,
 |  | const ms_quant_numerator * | numerator
 | ) |  |

Update the information for a specific numerator refering to it by its index.

Parameters:
idx | number of the numerator for updating from 0 to (getNumberOfNumerators() - 1).
numerator | an object to copy the content from.
Returns:
TRUE if the numerator has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_ratio.hpp
  • ms_quant_ratio.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_replicate
Public Member Functions

ms_quant_replicate Class Reference
[Mascot configuration files module]

An object of this class represent a single replicate element in quantitation.xml. More...

#include <ms_quant_replicate.hpp>

Inheritance diagram for ms_quant_replicate:
[legend]
Collaboration diagram for ms_quant_replicate:
[legend]

List of all members.

Public Member Functions

ms_quant_replicate ()
Default constructor.
ms_quant_replicate (const ms_quant_replicate &src)
Copying constructor.
virtual | ~ms_quant_replicate ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_replicate *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
ms_quant_replicate & | operator= (const ms_quant_replicate &right)
C++ style assignment operator.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single replicate element in quantitation.xml.

Serves as a possible sub-element of the protocol element.

Constructor & Destructor Documentation

ms_quant_replicate ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_replicate ( const ms_quant_replicate & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_replicate * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

ms_quant_replicate & operator= ( const ms_quant_replicate & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_replicate.hpp
  • ms_quant_replicate.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_reporter
Public Member Functions

ms_quant_reporter Class Reference
[Mascot configuration files module]

An object of this class represents a single reporter element in quantitation.xml. More...

#include <ms_quant_reporter.hpp>

Inheritance diagram for ms_quant_reporter:
[legend]
Collaboration diagram for ms_quant_reporter:
[legend]

List of all members.

Public Member Functions

ms_quant_reporter ()
Default constructor.
ms_quant_reporter (const ms_quant_reporter &src)
Copying constructor.
virtual | ~ms_quant_reporter ()
Destructor.
void | appendParameter (const ms_quant_parameter *item)
Adds a new parameter at the end of the list.
virtual void | clearParameters ()
Deletes all parameters from the list.
void | copyFrom (const ms_quant_parameters *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_reporter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)
Remove a parameter from the list in memory by its index.
void | dropReporterTol ()
Delete the reporter_tol attribute.
void | dropReporterTolUnit ()
Delete the reporter_tol_unit attribute.
virtual int | getNumberOfParameters () const
Returns the number of parameters held.
const ms_quant_parameter * | getParameterByName (const char *name) const
Returns a parameter object by its name or a null value in case of not found.
const ms_quant_parameter * | getParameterByNumber (const int idx) const
Returns a parameter object by its number.
virtual std::string | getParameterSchemaType () const
Obtain a symbolic name for the parameter element schema type.
std::string | getReporterTol () const
Returns the value of the reporter_tol attribute.
std::string | getReporterTolSchemaType () const
Obtain a symbolic name for the reporter_tol attribute schema type.
std::string | getReporterTolUnit () const
Returns the value of the reporter_tol_unit attribute.
std::string | getReporterTolUnitSchemaType () const
Obtain a symbolic name for the reporter_tol_unit attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveReporterTol () const
Indicates presence of the reporter_tol attribute.
bool | haveReporterTolUnit () const
Indicates presence of the reporter_tol_unit attribute.
ms_quant_reporter & | operator= (const ms_quant_reporter &right)
C++ style assignment operator.
void | setReporterTol (const char *value)
Set a custom value for the reporter_tol attribute.
void | setReporterTolUnit (const char *value)
Set a custom value for the reporter_tol_unit attribute.
bool | updateParameterByName (const char *name, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its unique name.
bool | updateParameterByNumber (const int idx, const ms_quant_parameter *param)
Update the information for a specific parameter refering to it by its index.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represents a single reporter element in quantitation.xml.

Serves as a possible sub-element of the protocol element.

Constructor & Destructor Documentation

ms_quant_reporter ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_reporter ( const ms_quant_reporter & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendParameter ( const ms_quant_parameter * item ) [inherited]

Adds a new parameter at the end of the list.

Parameters:
item an instance of parameter object to copy content from.
void copyFrom ( const ms_quant_parameters * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_reporter * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_quant_parameters.

bool deleteParameterByName ( const char * name ) [virtual, inherited]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

bool deleteParameterByNumber ( const int idx ) [virtual, inherited]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implements ms_xml_parameters.

void dropReporterTol ( )

Delete the reporter_tol attribute.

Disables the attribute until it is re-set.

void dropReporterTolUnit ( )

Delete the reporter_tol_unit attribute.

Disables the attribute until it is re-set.

int getNumberOfParameters ( ) const [virtual, inherited]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implements ms_xml_parameters.

const ms_quant_parameter * getParameterByName ( const char * name ) const [inherited]

Returns a parameter object by its name or a null value in case of not found.

Parameters:
name name of the parameter to find.
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
const ms_quant_parameter * getParameterByNumber ( const int idx ) const [inherited]

Returns a parameter object by its number.

Parameters:
idx number of the parameter from 0 to (getNumberOfParameters() - 1).
Returns:
a read-only pointer to a parameter object. See Maintaining object references: two rules of thumb.
std::string getParameterSchemaType ( ) const [virtual, inherited]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implements ms_xml_parameters.

std::string getReporterTol ( ) const

Returns the value of the reporter_tol attribute.

Mass tolerance to be used for matching reporter ion peaks.

Returns:
current value of the reporter_tol attribute.
std::string getReporterTolSchemaType ( ) const

Obtain a symbolic name for the reporter_tol attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getReporterTolUnit ( ) const

Returns the value of the reporter_tol_unit attribute.

Units for reporter_tol (Da ppm mmu %).

Returns:
current value of the reporter_tol_unit attribute.
std::string getReporterTolUnitSchemaType ( ) const

Obtain a symbolic name for the reporter_tol_unit attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Reimplemented from ms_quant_parameters.

bool haveReporterTol ( ) const

Indicates presence of the reporter_tol attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
bool haveReporterTolUnit ( ) const

Indicates presence of the reporter_tol_unit attribute.

You should always check for the presence of an attribute before retrieving its actual value.

Returns:
TRUE if the attribute is present in current element and FALSE otherwise.
ms_quant_reporter & operator= ( const ms_quant_reporter & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setReporterTol ( const char * value )

Set a custom value for the reporter_tol attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReporterTol().

Parameters:
value a new value for the attribute.
void setReporterTolUnit ( const char * value )

Set a custom value for the reporter_tol_unit attribute.

An attribute becomes present after it is value has been set at least once. To disable it again call dropReporterTolUnit().

Parameters:
value a new value for the attribute.
bool updateParameterByName | ( | const char * | name,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its unique name.

Parameters:
name | name of the parameter for updating.
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
bool updateParameterByNumber | ( | const int | idx,
 |  | const ms_quant_parameter * | param
 | ) |  | [inherited]

Update the information for a specific parameter refering to it by its index.

Parameters:
idx | number of the parameter for updating from 0 to (getNumberOfParameters() - 1).
param | an object to copy the content from.
Returns:
TRUE if the parameter has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_xml_parameters.

The documentation for this class was generated from the following files:
  • ms_quant_reporter.hpp
  • ms_quant_reporter.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_satellite
Public Member Functions

ms_quant_satellite Class Reference
[Mascot configuration files module]

An object of this class represent a single satellite element in quantitation.xml. More...

#include <ms_quant_satellite.hpp>

Collaboration diagram for ms_quant_satellite:
[legend]

List of all members.

Public Member Functions

ms_quant_satellite ()
Default constructor.
ms_quant_satellite (const ms_quant_satellite &src)
Copying constructor.
virtual | ~ms_quant_satellite ()
Destructor.
void | copyFrom (const ms_quant_satellite *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropModifications ()
Delete the modifications element.
const ms_quant_modgroup * | getModifications () const
Returns the value of the modifications element.
std::string | getModificationsSchemaType () const
Obtain a symbolic name for the modifications element schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveModifications () const
Check for presence of the modifications element.
ms_quant_satellite & | operator= (const ms_quant_satellite &right)
C++ style assignment operator.
void | setModifications (const ms_quant_modgroup *moverz)
Supply a custom content for modifications element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

An object of this class represent a single satellite element in quantitation.xml.

Modification group that defines satellite peaks to be summed into the heaviest component to correct for Arg-Pro conversion of SILAC label.

Constructor & Destructor Documentation

ms_quant_satellite ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_satellite ( const ms_quant_satellite & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_satellite * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropModifications ( )

Delete the modifications element.

Deletes the element until it is re-set.

const ms_quant_modgroup * getModifications ( ) const

Returns the value of the modifications element.

Returns:
a read-only pointer to an object with the current element content. See Maintaining object references: two rules of thumb.
std::string getModificationsSchemaType ( ) const

Obtain a symbolic name for the modifications element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType").
bool haveModifications ( ) const

Check for presence of the modifications element.

Returns:
TRUE if the element is present and FALSE otherwise.
ms_quant_satellite & operator= ( const ms_quant_satellite & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setModifications ( const ms_quant_modgroup * mods )

Supply a custom content for modifications element.

Modification group that defines satellite peaks to be summed into the heaviest component to correct for Arg-Pro conversion of SILAC label.

Parameters:
mods a new content for the element.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_satellite.hpp
  • ms_quant_satellite.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_specificity
Public Member Functions

ms_quant_specificity Class Reference
[Mascot configuration files module]

Describes a specificity element in quantitation.xml (Unimod style specificity). More...

#include <ms_quant_specificity.hpp>

List of all members.

Public Member Functions

ms_quant_specificity ()
Default constructor.
ms_quant_specificity (const ms_quant_specificity &src)
Copying constructor.
virtual | ~ms_quant_specificity ()
Destructor.
void | appendNeutralLoss (const ms_quant_neutralloss *neutralloss)
Adds a new NeutralLoss element at the end of the list.
void | appendPepNeutralLoss (const ms_quant_pepneutralloss *neutralloss)
Adds a new PepNeutralLoss element at the end of the list.
void | clearNeutralLosses ()
Deletes all elements from the list.
void | clearPepNeutralLosses ()
Deletes all elements from the list.
void | copyFrom (const ms_quant_specificity *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteNeutralLoss (const int idx)
Remove a NeutralLoss element from the list.
bool | deletePepNeutralLoss (const int idx)
Remove a PepNeutralLoss element from the list.
void | dropPosition ()
Deletes the position attribute.
void | dropSite ()
Deletes the site attribute.
const ms_quant_neutralloss * | getNeutralLoss (const int idx) const
Returns a NeutralLoss element object by its number.
std::string | getNeutralLossSchemaType () const
Obtain a symbolic name for the NeutralLoss element schema type.
int | getNumberOfNeutralLosses () const
Returns the number of NeutralLoss elements held.
int | getNumberOfPepNeutralLosses () const
Returns the number of PepNeutralLoss elements held.
const ms_quant_pepneutralloss * | getPepNeutralLoss (const int idx) const
Returns a pointer to the PepNeutralLoss element by its number.
std::string | getPepNeutralLossSchemaType () const
Obtain a symbolic name for the PepNeutralLoss element schema type.
std::string | getPosition () const
Returns the value of the position attribute.
std::string | getPositionSchemaType () const
Obtain a symbolic name for the position attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSite () const
Returns the value of the site attribute.
std::string | getSiteSchemaType () const
Obtain a symbolic name for the site attribute schema type.
bool | havePosition () const
Indicates whether the position attribute is present or not.
bool | haveSite () const
Indicates whether the site attribute is present or not.
ms_quant_specificity & | operator= (const ms_quant_specificity &right)
C++ style assignment operator.
void | setPosition (const char *position)
Set a custom value for the position attribute.
void | setSite (const char *site)
Set a custom value for the site attribute.
bool | updateNeutralLoss (const int idx, const ms_quant_neutralloss *neutralloss)
Update the information for a specific neutral loss.
bool | updatePepNeutralLoss (const int idx, const ms_quant_pepneutralloss *neutralloss)
Update the information for a specific peptide neutral loss.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Describes a specificity element in quantitation.xml (Unimod style specificity).

Objects of this type host a list of nested NeutralLoss elements.

Constructor & Destructor Documentation

ms_quant_specificity ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_specificity ( const ms_quant_specificity & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendNeutralLoss ( const ms_quant_neutralloss * neutralloss )

Adds a new NeutralLoss element at the end of the list.

Parameters:
neutralloss an instance to copy the content into the newly added element from.
void appendPepNeutralLoss ( const ms_quant_pepneutralloss * pepneutralloss )

Adds a new PepNeutralLoss element at the end of the list.

Parameters:
pepneutralloss an instance to copy the content into the newly added element from.
void copyFrom ( const ms_quant_specificity * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteNeutralLoss ( const int idx )

Remove a NeutralLoss element from the list.

Parameters:
idx a zero-based index of the element to delete.
Returns:
TRUE if the element has been successfully deleted and FALSE otherwise.
bool deletePepNeutralLoss ( const int idx )

Remove a PepNeutralLoss element from the list.

Parameters:
idx a zero-based index of the element to delete.
Returns:
TRUE if the element has been successfully deleted and FALSE otherwise.
void dropPosition ( )

Deletes the position attribute.

Disables the attribute until it is re-set.

void dropSite ( )

Deletes the site attribute.

Disables the attribute until it is re-set.

const ms_quant_neutralloss * getNeutralLoss ( const int idx ) const

Returns a NeutralLoss element object by its number.

Parameters:
idx a zero-based index of the element to retrieve.
Returns:
a read-only pointer to the retrieved element. See Maintaining object references: two rules of thumb.
std::string getNeutralLossSchemaType ( ) const

Obtain a symbolic name for the NeutralLoss element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_quant_pepneutralloss * getPepNeutralLoss ( const int idx ) const

Returns a pointer to the PepNeutralLoss element by its number.

Parameters:
idx a zero-based index of the element to obtain.
Returns:
a read-only pointer to the current content. See Maintaining object references: two rules of thumb.
std::string getPepNeutralLossSchemaType ( ) const

Obtain a symbolic name for the PepNeutralLoss element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getPosition ( ) const

Returns the value of the position attribute.

Returns:
current value of the position attribute.
std::string getPositionSchemaType ( ) const

Obtain a symbolic name for the position attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
std::string getSite ( ) const

Returns the value of the site attribute.

Returns:
current value of the site attribute.
std::string getSiteSchemaType ( ) const

Obtain a symbolic name for the site attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool havePosition ( ) const

Indicates whether the position attribute is present or not.

Returns:
TRUE if the attribute is available.
bool haveSite ( ) const

Indicates whether the site attribute is present or not.

Returns:
TRUE if the attribute is available.
ms_quant_specificity & operator= ( const ms_quant_specificity & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setPosition ( const char * position )

Set a custom value for the position attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters:
position a new value for the position attribute.
void setSite ( const char * site )

Set a custom value for the site attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters:
site a new value for the site attribute.
bool updateNeutralLoss | ( | const int | idx,
 |  | const ms_quant_neutralloss * | neutralloss
 | ) |  |

Update the information for a specific neutral loss.

Parameters:
idx | a zero-based index of the element to update.
neutralloss | an instance to copy the content from.
Returns:
TRUE if the element has been successfully updated and FALSE otherwise.
bool updatePepNeutralLoss | ( | const int | idx,
 |  | const ms_quant_pepneutralloss * | pepneutralloss
 | ) |  |

Update the information for a specific peptide neutral loss.

Parameters:
idx | a zero-based index of the element to update.
pepneutralloss | an instance to copy the content from.
Returns:
TRUE if the element has been successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_specificity.hpp
  • ms_quant_specificity.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_unmodified
Public Member Functions

ms_quant_unmodified Class Reference
[Mascot configuration files module]

Describes an unmodified element in quantitation.xml. More...

#include <ms_quant_unmodified.hpp>

List of all members.

Public Member Functions

ms_quant_unmodified ()
Default constructor.
ms_quant_unmodified (const ms_quant_unmodified &src)
Copying constructor.
virtual | ~ms_quant_unmodified ()
Destructor.
void | copyFrom (const ms_quant_unmodified *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropPosition ()
Deletes the position attribute.
void | dropSite ()
Deletes the site attribute.
std::string | getContent () const
Returns string value of the element.
std::string | getContentSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getPosition () const
Returns the value of the position attribute.
std::string | getPositionSchemaType () const
Obtain a symbolic name for the position attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSite () const
Returns the value of the site attribute.
std::string | getSiteSchemaType () const
Obtain a symbolic name for the site attribute schema type.
bool | havePosition () const
Indicates whether the position attribute is present or not.
bool | haveSite () const
Indicates whether the site attribute is present or not.
ms_quant_unmodified & | operator= (const ms_quant_unmodified &right)
C++ style assignment operator.
void | setContent (const char *value)
Set a custom value for the the element.
void | setPosition (const char *position)
Set a custom value for the position attribute.
void | setSite (const char *site)
Set a custom value for the site attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Describes an unmodified element in quantitation.xml.

Constructor & Destructor Documentation

ms_quant_unmodified ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_quant_unmodified ( const ms_quant_unmodified & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_quant_unmodified * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropPosition ( )

Deletes the position attribute.

Disables the attribute until it is re-set.

void dropSite ( )

Deletes the site attribute.

Disables the attribute until it is re-set.

std::string getContent ( ) const

Returns string value of the element.

Returns:
string content of the element.
std::string getContentSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getPosition ( ) const

Returns the value of the position attribute.

Returns:
current value of the position attribute.
std::string getPositionSchemaType ( ) const

Obtain a symbolic name for the position attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").
std::string getSite ( ) const

Returns the value of the site attribute.

Returns:
current value of the site attribute.
std::string getSiteSchemaType ( ) const

Obtain a symbolic name for the site attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool havePosition ( ) const

Indicates whether the position attribute is present or not.

Returns:
TRUE if the attribute is available.
bool haveSite ( ) const

Indicates whether the site attribute is present or not.

Returns:
TRUE if the attribute is available.
ms_quant_unmodified & operator= ( const ms_quant_unmodified & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setContent ( const char * value )

Set a custom value for the the element.

Parameters:
value new content for the element.
void setPosition ( const char * position )

Set a custom value for the position attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters:
position a new value for the position attribute.
void setSite ( const char * site )

Set a custom value for the site attribute.

Calling this method makes the attribute automatically available in the current element.

Parameters:
site a new value for the site attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_quant_unmodified.hpp
  • ms_quant_unmodified.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_taxnodesfiles
Public Member Functions

ms_taxnodesfiles Class Reference
[Mascot configuration files module]

Filenames and formats for taxonomy nodes or genetic codes files. More...

#include <ms_taxonomyrules.hpp>

List of all members.

Public Member Functions

ms_taxnodesfiles ()
Default constructor.
ms_taxnodesfiles (const ms_taxnodesfiles &src)
Copying constructor.
~ms_taxnodesfiles ()
Destructor.
void | copyFrom (const ms_taxnodesfiles *right)
Can be used to create a copy of another instance.
void | defaultValues ()
Initialises the instance.
std::string | getFileName () const
Returns the file name.
TAX_NODE_FORMAT | getFormat () const
Returns format identifier of the file.
ms_taxnodesfiles & | operator= (const ms_taxnodesfiles &right)
Assignment operator for C++ client applications.
void | setFileName (const char *name)
Change the file name.
void | setFormat (const TAX_NODE_FORMAT value)
Change the format property.

Detailed Description

Filenames and formats for taxonomy nodes or genetic codes files.

See also ms_taxonomytree which provides functionality for the taxonomy nodes files.

The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_taxonomychoice
Public Member Functions

ms_taxonomychoice Class Reference
[Mascot configuration files module]

The class represents a single taxonomy choice entry in the taxonomy file. More...

#include <ms_taxonomyfile.hpp>

Inheritance diagram for ms_taxonomychoice:
[legend]
Collaboration diagram for ms_taxonomychoice:
[legend]

List of all members.

Public Member Functions

ms_taxonomychoice ()
Default constructor.
ms_taxonomychoice (const ms_taxonomychoice &src)
Copying constructor.
~ms_taxonomychoice ()
Destructor.
void | appendExcludeTaxonomy (const int id)
Adds one more taxonomy ID to the exclude list.
void | appendIncludeTaxonomy (const int id)
Adds one more taxonomy ID to the include list.
void | clearExcludeTaxonomies ()
Deletes all taxonomy IDs from the exclude list.
void | clearIncludeTaxonomies ()
Deletes all taxonomy IDs from the include list.
void | copyFrom (const ms_taxonomychoice *src)
Copies modification configuration from another instance.
void | defaultValues ()
Re-initialises the object.
int | getExcludeTaxonomy (const int n) const
Traverse the excluded taxonomy IDs.
int | getIncludeTaxonomy (const int n) const
Traverse the included taxonomy IDs.
int | getNumberOfExcludeTaxonomies () const
Returns a total number of excluded taxonomy IDs.
int | getNumberOfIncludeTaxonomies () const
Returns a total number of included taxonomy IDs.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getTitle () const
Returns the taxonomy choice title.
ms_taxonomychoice & | operator= (const ms_taxonomychoice &right)
C++ style assignment operator.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setTitle (const char *value)
Change the title for taxonomy choice.

Detailed Description

The class represents a single taxonomy choice entry in the taxonomy file.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Member Function Documentation

std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
The documentation for this class was generated from the following files:
  • ms_taxonomyfile.hpp
  • ms_taxonomyfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_taxonomyfile
Public Member Functions

ms_taxonomyfile Class Reference
[Mascot configuration files module]

Use this class in order to read in a taxonomy file. More...

#include <ms_taxonomyfile.hpp>

Inheritance diagram for ms_taxonomyfile:
[legend]
Collaboration diagram for ms_taxonomyfile:
[legend]

List of all members.

Public Member Functions

ms_taxonomyfile ()
Default constructor.
ms_taxonomyfile (const ms_taxonomyfile &src)
Copying constructor.
ms_taxonomyfile (const char *filename, const matrix_science::ms_connection_settings *cs=0)
Immediate-action constructor that reads the given file on construction.
~ms_taxonomyfile ()
Destructor.
void | appendEntry (const ms_taxonomychoice *item)
Adds a new taxonomy choice at the end of the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearEntries ()
Deletes all taxonomy choices from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_taxonomyfile *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
matrix_science::ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
ms_taxonomychoice * | getEntryByName (const char *name)
Returns a taxonomy choice entry by its name or NULL in case of not found.
const ms_taxonomychoice * | getEntryByNumber (const int index) const
Returns a taxonomy choice entry by its number.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns a file name that is used to read the file.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfEntries () const
Returns a number of taxonomy choices currently held in memory.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_taxonomyfile & | operator= (const ms_taxonomyfile &right)
C++ style assignment operator.
void | read_buffer (const char *buffer)
Reads and parses an in-memory null-terminated buffer instead of a disk file.
void | read_file ()
Reads configuration information from the file.
void | save_file ()
Stores modification information in the file.
void | setConnectionSettings (const matrix_science::ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an http transfer.
void | setFileName (const char *name)
Call this member to set a custom file name to read from a different location.

Detailed Description

Use this class in order to read in a taxonomy file.

The list of taxonomy choices in the search form is taken from the taxonomy file. The file consists of several entries. The first line of each entry must start with the Title: keyword, followed by a text string that is used to identify the species in forms and reports. The definition should be short and self-explanatory.

To show the tree structure, indentation can be used. Unfortunately, it is not possible to use tabs or multiple spaces for indentation in an HTML form, so a full stop (period) and a space are used to indent the list. Internal spaces are significant, and there should never be two or more spaces together.

This should be followed with a definition line starting with the Include: keyword, followed by one or more numbers separated with commas. With the supplied MSDB database, and supplied taxonomy files, these numbers should be the NCBI taxonomy ID.

This should be followed with a definition line starting with the Exclude: keyword, followed by one or more numbers separated with commas. Any sequence with a taxonomy ID that passes the 'include' test may then be rejected by any entry in the exclude list.

Finally, each entry must end with a *.

Examples:

config_taxonomy.cpp.

Constructor & Destructor Documentation

ms_taxonomyfile | ( | const char * | filename,
 |  | const matrix_science::ms_connection_settings * | cs = 0
 | ) |  |

Immediate-action constructor that reads the given file on construction.

Parameters:
filename | The file name parameter can be either a local file path or a Mascot server URL, it cannot be an empty string or NULL pointer. If it is a URL it should be of the form http://your-server/mascot/cgi .
cs | is a pointer to the connection settings. This should contain a sessionID and optionally the proxy server settings.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
matrix_science::ms_connection_settings getConnectionSettings ( ) const

Returns the sessionID and proxy server for use with an HTTP transfer.

See also the constructor documentation and setConnectionSettings().

Returns:
The current connection settings.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void read_buffer ( const char * buffer )

Reads and parses an in-memory null-terminated buffer instead of a disk file.

Check for possible errors after calling this functions with isValid().

Parameters:
buffer a null-terminated string with taxonomies definitions.
void read_file ( )

Reads configuration information from the file.

Check for possible errors after calling this functions with isValid().

void setConnectionSettings ( const matrix_science::ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an http transfer.

This value would normally be passed in the constructor.

Parameters:
cs Is the new connection settings.
The documentation for this class was generated from the following files:
  • ms_taxonomyfile.hpp
  • ms_taxonomyfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_taxonomyrules
Public Member Functions

ms_taxonomyrules Class Reference
[Mascot configuration files module]

This class represents a single Taxonomy_XXX section in mascot.dat. More...

#include <ms_taxonomyrules.hpp>

Inheritance diagram for ms_taxonomyrules:
[legend]
Collaboration diagram for ms_taxonomyrules:
[legend]

List of all members.

Public Member Functions

ms_taxonomyrules ()
Default constructor.
ms_taxonomyrules (const ms_taxonomyrules &src)
Copying constructor.
~ms_taxonomyrules ()
Destructor.
void | appendGencodeFile (const ms_taxnodesfiles *item)
Adds an entry into the GencodeFiles list.
void | appendNoBreakDescLineIf (const char *str)
Adds an entry into the NoBreakDescLineIf list.
void | appendNodesFile (const ms_taxnodesfiles *item)
Adds an entry into the NodesFiles list.
void | appendPerDbSrcRule (const ms_parserule_plus *item)
Adds a new database source string into the list.
void | appendPrefixRemove (const char *item)
Adds an entry into the PrefixRemoves list.
void | appendSpeciesFile (const ms_taxspeciesfiles *item)
Adds an entry into the SpeciesFiles list.
void | appendStrFile (const ms_taxspeciesfiles *item)
void | appendSuffixRemove (const char *item)
Adds an entry into the SuffixRemoves list.
void | clearDBLevelTaxId ()
Deletes DBLevelTaxId; it will not be saved in the file.
void | clearGencodeFiles ()
Deletes all GencodeFiles entries.
void | clearNoBreakDescLineIf ()
Deletes all NoBreakDescLineIf entries.
void | clearNodesFiles ()
Deletes all NodesFiles entries.
void | clearPerDbSrcRules ()
Deletes all database source strings.
void | clearPrefixRemoves ()
Deletes all PrefixRemoves entries.
void | clearSpeciesFiles ()
Deletes all entries for SpeciesFiles.
void | clearSuffixRemoves ()
Deletes all SuffixRemoves entries.
void | copyFrom (const ms_taxonomyrules *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
const ms_parserule * | getAccFromSpeciesLine () const
Returns the value of AccFromSpeciesLine.
int | getDBLevelTaxId () const
Returns the value of DBLevelTaxId.
const ms_parserule_plus * | getDefaultRule () const
Returns the value of DefaultRule.
char | getDescriptionLineSep () const
Returns the value of DescriptionLineSep.
const ms_parserule * | getDoThisRuleFirst () const
Returns the value of DoThisRuleFirst.
int | getErrorLevel () const
Returns the value of ErrorLevel.
const ms_taxnodesfiles * | getGencodeFile (const int index) const
Returns an instance of ms_taxnodesfiles describing an entry in GencodeFiles.
std::string | getIdentifier () const
Returns the value of Identifier.
std::string | getNoBreakDescLineIf (const int index) const
Returns a NoBreakDescLineIf entry by its number.
const ms_taxnodesfiles * | getNodesFile (const int index) const
Returns an instance of ms_taxnodesfiles describing an entry in NodesFiles.
int | getNumberOfGencodeFiles () const
Returns the number of file names specified in GencodeFiles.
int | getNumberOfNoBreakDescLineIf () const
Returns the number of NoBreakDescLineIf entries.
int | getNumberOfNodesFiles () const
Returns the number of file names specified in NodesFiles.
int | getNumberOfPerDbSrcRules () const
Returns the number of database source strings.
int | getNumberOfPrefixRemoves () const
Returns the number of PrefixRemoves entries.
int | getNumberOfSpeciesFiles () const
Returns the number of file names specified in SpeciesFiles.
int | getNumberOfStrFiles () const
int | getNumberOfSuffixRemoves () const
Returns the number of SuffixRemoves entries.
const ms_parserule_plus * | getPerDbSrcRule (const int index) const
Returns a database source string by its number.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPrefixRemove (const int index) const
Returns the PrefixRemoves string by number.
std::string | getQuickRefSearch () const
Returns the value of QuickRefSearch.
const ms_taxspeciesfiles * | getSpeciesFile (const int index) const
Returns an instance of ms_taxspeciesfiles describing an entry in SpeciesFiles.
std::string | getSpeciesFormatRegex (const TAX_SPECIES_FORMAT format) const
Returns a regular expression, if any for the species format.
const ms_parserule * | getSrcDatabaseRule () const
Returns the value of SrcDatabaseRule.
const ms_taxspeciesfiles * | getStrFile (const int index) const
const ms_parserule_plus * | getStrRule () const
std::string | getSuffixRemove (const int index) const
Returns a SuffixRemoves string by number.
bool | isConcatRefFileLines () const
Returns TRUE if ConcatRefFileLines parameter is set to 1 and FALSE otherwise.
bool | isDBLevelTaxId () const
Returns TRUE if there is a database level taxonomy ID in the file.
bool | isEnabled () const
Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.
bool | isFromRefFile () const
Returns TRUE if FromRefFile parameter is set to 1 and FALSE otherwise.
bool | isMitochondrialTranslation () const
Returns TRUE if MitochondrialTranslation parameter is set to 1 and FALSE otherwise.
bool | isSectionAvailable () const
Checks whether the section has been actually read from the file.
ms_taxonomyrules & | operator= (const ms_taxonomyrules &right)
Assignment operator for C++ client applications.
void | setAccFromSpeciesLine (const ms_parserule *src)
Change the value of AccFromSpeciesLine.
void | setConcatRefFileLines (const bool flag)
Change the value of ConcatRefFileLines.
void | setDBLevelTaxId (const int value)
Change the value of DBLevelTaxId.
void | setDefaultRule (const ms_parserule_plus *src)
Change the value of DefaultRule.
void | setDescriptionLineSep (const char value)
Change the value of DescriptionLineSep.
void | setDoThisRuleFirst (const ms_parserule *src)
Change the value of DoThisRuleFirst.
void | setEnabled (const bool flag)
Change the value of Enabled.
void | setErrorLevel (const int value)
Change the value of ErrorLevel.
void | setFromRefFile (const bool flag)
Change the value of FromRefFile.
void | setIdentifier (const char *str)
Change the value of Identifier.
void | setMitochondrialTranslation (const bool flag)
Set the value of MitochondrialTranslation.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setQuickRefSearch (const char *str)
Change the value of QuickRefSearch.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.
void | setSpeciesFormatRegex (const TAX_SPECIES_FORMAT format, const std::string regex)
Set the regular expression, if any, for the species format.
void | setSrcDatabaseRule (const ms_parserule *src)
Change the value of SrcDatabaseRule.
void | setStrRule (const ms_parserule_plus *src)

Detailed Description

This class represents a single Taxonomy_XXX section in mascot.dat.

The Taxonomy section defines a set of taxonomy rules that can be selected for a database. Usage of taxonomy rules can be turned off by setting Enabled property to 0. See isEnabled() for more information.

Instances of this class are created in ms_datfile.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Member Function Documentation

void appendGencodeFile ( const ms_taxnodesfiles * item )

Adds an entry into the GencodeFiles list.

See getGencodeFile() for more information.

Parameters:
item an item to add a copy of into the list.
void appendNoBreakDescLineIf ( const char * str )

Adds an entry into the NoBreakDescLineIf list.

See getNoBreakDescLineIf() for more information.

Parameters:
str an item to add a copy of into the list.
void appendNodesFile ( const ms_taxnodesfiles * item )

Adds an entry into the NodesFiles list.

See getNodesFile() for more information.

Parameters:
item an item to add a copy of into the list.
void appendPerDbSrcRule ( const ms_parserule_plus * item )

Adds a new database source string into the list.

See getPerDbSrcRule() for more information.

Parameters:
item an item to add a copy of into the list
void appendPrefixRemove ( const char * item )

Adds an entry into the PrefixRemoves list.

See getPrefixRemove() for more information.

Parameters:
item an item to add a copy of into the list.
void appendSpeciesFile ( const ms_taxspeciesfiles * item )

Adds an entry into the SpeciesFiles list.

See getSpeciesFile() for more information.

Parameters:
item an item to add a copy of into the list.
void appendStrFile ( const ms_taxspeciesfiles * item )
Parameters:
item pointer to a taxonomy species file
void appendSuffixRemove ( const char * item )

Adds an entry into the SuffixRemoves list.

See getSuffixRemove() for more information.

Parameters:
item an item to add a copy of into the list.
void clearGencodeFiles ( )

Deletes all GencodeFiles entries.

See getGencodeFile() for more information.

void clearNoBreakDescLineIf ( )

Deletes all NoBreakDescLineIf entries.

See getNoBreakDescLineIf() for more information.

void clearNodesFiles ( )

Deletes all NodesFiles entries.

See getNodesFile() for more information.

void clearPerDbSrcRules ( )

Deletes all database source strings.

See getPerDbSrcRule() for more information.

void clearPrefixRemoves ( )

Deletes all PrefixRemoves entries.

See getPrefixRemove() for more information.

void clearSpeciesFiles ( )

Deletes all entries for SpeciesFiles.

See getSpeciesFile() for more information.

void clearSuffixRemoves ( )

Deletes all SuffixRemoves entries.

See getSuffixRemove() for more information.

const ms_parserule * getAccFromSpeciesLine ( ) const

Returns the value of AccFromSpeciesLine.

MSDB database explicitly associates each species line with the accession string of the primary database entry. A further rule, AccFromSpeciesLine, is used to extract this accession string.

Returns:
pointer to a parser rule
int getDBLevelTaxId ( ) const

Returns the value of DBLevelTaxId.

Database level taxonomy ID can be specified in order to find proper NA translation table without names.dmp and nodes.dmp files usage.

Default is -1, which is not a valid taxonomy ID.

Returns:
database level taxonomy id
const ms_parserule_plus * getDefaultRule ( ) const

Returns the value of DefaultRule.

The DefaultRule describes how to find the species name in the line of text in the reference file. The string in quotes is a regular expression. All words in the PrefixRemoves and SuffixRemoves keywords should be removed before trying to do a match. For more detailed information on how to specify this parameter consult Mascot manual.

If specified, DoThisRuleFirst is applied first, and the default rule would only be used if this failed.

See also:
getQuickRefSearch(), getDoThisRuleFirst(), getAccFromSpeciesLine()
Returns:
pointer to a parser rule
char getDescriptionLineSep ( ) const

Returns the value of DescriptionLineSep.

The line that contains the species IDs has multiple IDs, separated by a character, whose ASCII code is specified by DescriptionLineSep.

There is no default value for this parameter.

Returns:
description line separator for this taxonomy
const ms_parserule * getDoThisRuleFirst ( ) const

Returns the value of DoThisRuleFirst.

See getDefaultRule().

Returns:
a pointer to the parser rule for which to do this rule first
int getErrorLevel ( ) const

Returns the value of ErrorLevel.

ErrorLevel indicates the type of warnings or errors that are found when creating the taxonomy information. Possible values and their meanings:

  • 0 - an entry is put into the NoTaxonomyMatch.txt file for every sequence where no taxonomy information is found.
  • 1+ (severe) - an entry is put into the NoTaxonomyMatch.txt file for every sequence that had any accession string without a match. Since some sequences in NCBI will have up to 200 gi numbers (sources), there is a reasonable chance that some of these entries will not have species information, and this would cause the errors files to become very large.

Default is 1.

Returns:
error level
const ms_taxnodesfiles * getGencodeFile ( const int index ) const

Returns an instance of ms_taxnodesfiles describing an entry in GencodeFiles.

The GencodeFiles file is used to find a proper NA translation table for a given taxonomy. For more detailed information on how to configure this parameter consult Mascot manual and documentation for ms_taxnodesfiles.

By default the list of files is empty.

Parameters:
index file number from 0 to (getNumberOfGencodeFiles()-1).
Returns:
instance of ms_taxnodesfiles class describing one of the files specified in GencodeFiles parameter of the Taxonomy section.
std::string getIdentifier ( ) const

Returns the value of Identifier.

This parameter contains a symbolic name for the taxonomy specification as seen, for instance, in the database GUI utility.

By default this is empty.

Returns:
identifier of the taxonomy
Examples:
config_mascotdat.cpp.
std::string getNoBreakDescLineIf ( const int index ) const

Returns a NoBreakDescLineIf entry by its number.

NoBreakDescLineIf specifies keywords that prevent description line from being broken into separate words.

By default this is an empty list.

Parameters:
index number of entry from 0 to (getNumberOfNoBreakDescLineIf()-1).
Returns:
a string value.
const ms_taxnodesfiles * getNodesFile ( const int index ) const

Returns an instance of ms_taxnodesfiles describing an entry in NodesFiles.

The NodesFiles file is used to traverse taxonomy hierarchy. It contains taxonomy ID nodes together with their parents IDs. For more detailed information on how to configure this parameter consult Mascot manual and documentation for ms_taxnodesfiles.

By default the list of files is empty.

Parameters:
index file number from 0 to (getNumberOfNodesFiles()-1).
Returns:
instance of ms_taxnodesfiles class describing one of the files specified in NodesFiles parameter of the Taxonomy section.
int getNumberOfGencodeFiles ( ) const

Returns the number of file names specified in GencodeFiles.

See getGencodeFile() and documentation for ms_taxnodesfiles.

Returns:
number of gencode files
int getNumberOfNoBreakDescLineIf ( ) const

Returns the number of NoBreakDescLineIf entries.

See getNoBreakDescLineIf() for explanations.

Returns:
number of keywords which prevent breaking description lines
int getNumberOfNodesFiles ( ) const

Returns the number of file names specified in NodesFiles.

See getNodesFile() and documentation for ms_taxnodesfiles.

Returns:
number of nodes files
int getNumberOfPerDbSrcRules ( ) const

Returns the number of database source strings.

See getPerDbSrcRule() and documentation for ms_parserule_plus.

Returns:
number of database source strings
int getNumberOfPrefixRemoves ( ) const

Returns the number of PrefixRemoves entries.

See getPrefixRemove().

Returns:
number of prefix removes
int getNumberOfSpeciesFiles ( ) const

Returns the number of file names specified in SpeciesFiles.

See getSpeciesFile() and documentation for ms_taxspeciesfiles.

Returns:
number of species files
int getNumberOfStrFiles ( ) const
Returns:
number of taxonomy species files
int getNumberOfSuffixRemoves ( ) const

Returns the number of SuffixRemoves entries.

See getSuffixRemove().

Returns:
number of suffix removes
const ms_parserule_plus * getPerDbSrcRule ( const int index ) const

Returns a database source string by its number.

Database source strings contained in taxonomy section all look like RULE_XXX or OTHERRULE.

By default the list of rules is empty.

Parameters:
index database source string number from 0 to (getNumberOfPerDbSrcRules()-1).
Returns:
pointer to a parser rule
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
std::string getPrefixRemove ( const int index ) const

Returns the PrefixRemoves string by number.

See getDefaultRule() for information on this parameter.

By default the list of prefixes is empty.

Parameters:
index number of a string specified in the parameter from 0 to (getNumberOfPrefixRemoves()-1).
Returns:
one of the string specifed in the parameter.
std::string getQuickRefSearch ( ) const

Returns the value of QuickRefSearch.

The QuickRefSearch string is used to speed up the compressing of the database. Rather than use the regular expression for each line in the .ref file, this text is used for a fast compare to the string C;Species. Other lines are ignored.

By default this is empty.

Returns:
quick ref search for the taxonomy rule
const ms_taxspeciesfiles * getSpeciesFile ( const int index ) const

Returns an instance of ms_taxspeciesfiles describing an entry in SpeciesFiles.

The SpeciesFiles file is used to convert a species name to a taxonomy ID. For more detailed information on how to configure this parameter consult Mascot manual and documentation for ms_taxspeciesfiles.

By default the list is empty.

Parameters:
index file number from 0 to (getNumberOfSpeciesFiles()-1).
Returns:
instance of ms_taxspeciesfiles class describing one of the files specified in SpeciesFiles parameter of the Taxonomy section.
std::string getSpeciesFormatRegex ( const TAX_SPECIES_FORMAT format ) const

Returns a regular expression, if any for the species format.

Introduced in Mascot 2.4, allows the use of a regular expression for a species file. The regular expression needs to return two values: the 'accession' or 'id' and the taxonomy_id

For example, in the Taxonomy_X section of mascot.dat, there is, for example an entry:

 * SWISSPROTRegex "^\\([A-Z0-9]*\\) *[ABEV] *\\([0-9]*\\):"

which has two bracketed expressions intended to extract AADNV and 648330 from

 AADNV V 648330: N=Aedes albopictus densovirus (isolate Boublik/1994)

If there is no value for SWISSPROTRegex in the mascot.dat file, then the value returned is the default as shown above.

Parameters:
format can be any TAX_SPECIES_FORMAT value, although only TAX_SPECIES_SWISSPROT is currently supported in Mascot Server.
Returns:
the regular expression or an empty string.
const ms_parserule * getSrcDatabaseRule ( ) const

Returns the value of SrcDatabaseRule.

The parameter is used for finding database source string with regular expression.

See also:
getPerDbSrcRule()
Returns:
pointer to a parser rule
const ms_taxspeciesfiles * getStrFile ( const int index ) const
Parameters:
index file index to look for
Returns:
taxonomy species file
const ms_parserule_plus * getStrRule ( ) const
Returns:
pointer to a parser rule
std::string getSuffixRemove ( const int index ) const

Returns a SuffixRemoves string by number.

See getDefaultRule() for information on this parameter.

By default the list of suffixes is empty.

Parameters:
index number of a string specified in the parameter from 0 to (getNumberOfSuffixRemoves()-1).
Returns:
one of the string specifed in the parameter.
bool isConcatRefFileLines ( ) const

Returns TRUE if ConcatRefFileLines parameter is set to 1 and FALSE otherwise.

A value of 1 (default) means that there might be multiple lines in reference file describing the same entry of the database.

See also:
isFromRefFile(), getDescriptionLineSep().
Returns:
true is ConcatRefFileLines equals 1, false otherwise
bool isEnabled ( ) const

Returns TRUE if Enabled parameter is set to 1 and FALSE otherwise.

Set Enabled parameter to 0 to disable the taxonomy. Most of the other parameters will be ignored although the taxonomy will be available for a database to select in database maintenance utility.

Default is 0.

Returns:
true if taxonomy rules are enabled, false otherwise
bool isFromRefFile ( ) const

Returns TRUE if FromRefFile parameter is set to 1 and FALSE otherwise.

FromRefFile is set to 0 to indicate that the taxonomy should be found in the .fasta file rather than in a reference file.

Default is 0.

See also:
isConcatRefFileLines(), getDescriptionLineSep().
Returns:
true if the taxonomy should be found in the fasta file, false otherwise
bool isMitochondrialTranslation ( ) const

Returns TRUE if MitochondrialTranslation parameter is set to 1 and FALSE otherwise.

Two types of NA translation tables can be used: nuclear and mitochondrial. Setting this parameter to 0 indicates the first type whereas 1 indicates the second one.

Default is 0.

Returns:
true if NA translation tables used are mitochondrial, false if they are nuclear
bool isSectionAvailable ( ) const

Checks whether the section has been actually read from the file.

By default a Taxonomy section is unavailable until it has been set to a different state.

Returns:
true if the section has been set to available
void setAccFromSpeciesLine ( const ms_parserule * src )

Change the value of AccFromSpeciesLine.

See getAccFromSpeciesLine() for more information.

Parameters:
src pointer to a parser rule
void setConcatRefFileLines ( const bool flag )

Change the value of ConcatRefFileLines.

See isConcatRefFileLines() for more information.

Parameters:
flag boolean value to set whether there might be multiple lines for the same entry
void setDefaultRule ( const ms_parserule_plus * src )

Change the value of DefaultRule.

See getDefaultRule().

Parameters:
src pointer to a parser rule
void setDescriptionLineSep ( const char value )

Change the value of DescriptionLineSep.

See getDescriptionLineSep() for more information.

Parameters:
value description line separator
void setDoThisRuleFirst ( const ms_parserule * src )

Change the value of DoThisRuleFirst.

See getDoThisRuleFirst().

Parameters:
src pointer to a parser rule for which it should do this rule first
void setEnabled ( const bool flag )

Change the value of Enabled.

See isEnabled() for more information.

Parameters:
flag whether the taxonomy rules are enabled or not
void setErrorLevel ( const int value )

Change the value of ErrorLevel.

See getErrorLevel() for more information.

Parameters:
value error level
void setFromRefFile ( const bool flag )

Change the value of FromRefFile.

See isFromRefFile() for more information.

Parameters:
flag boolean value to define if the taxonomy should be found in the fasta file
void setIdentifier ( const char * str )

Change the value of Identifier.

For more information see getIdentifier().

Parameters:
str identifier for the taxonomy
void setMitochondrialTranslation ( const bool flag )

Set the value of MitochondrialTranslation.

See isMitochondrialTranslation().

Parameters:
flag true if NA translation tables used are mitochondrial, false if they are nuclear
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setQuickRefSearch ( const char * str )

Change the value of QuickRefSearch.

See getQuickRefSearch().

Parameters:
str string used to speed up database compression
void setSpeciesFormatRegex | ( | const TAX_SPECIES_FORMAT | format,
 |  | const std::string | regex
 | ) |  |

Set the regular expression, if any, for the species format.

Instroduced in Mascot 2.4, allows the use of a regular expression for a species file. The regular expression needs to return two values: the 'accession' or 'id' and the taxonomy_id

For example, in the Taxonomy_X section of mascot.dat, there is, for example an entry:

 * SWISSPROTRegex "^\\([A-Z0-9]*\\) *[ABEV] *\\([0-9]*\\):"

which has two bracketed expressions intended to extract AADNV and 648330 from

 AADNV V 648330: N=Aedes albopictus densovirus (isolate Boublik/1994)
Parameters:
format | can be any TAX_SPECIES_FORMAT value, although only TAX_SPECIES_SWISSPROT is currently supported in Mascot Server.
regex | is the new regular expression or an empty string.
void setSrcDatabaseRule ( const ms_parserule * src )

Change the value of SrcDatabaseRule.

See getSrcDatabaseRule().

Parameters:
src pointer to a parser rule
void setStrRule ( const ms_parserule_plus * src )
Parameters:
src pointer to a parser str rule
The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_taxonomytree
Public Member Functions

ms_taxonomytree Class Reference
[Mascot configuration files module]

The complete taxonomy tree as built from one or more files such as nodes.dmp. More...

#include <ms_taxonomyrules.hpp>

Inheritance diagram for ms_taxonomytree:
[legend]
Collaboration diagram for ms_taxonomytree:
[legend]

List of all members.

Public Member Functions

ms_taxonomytree (const ms_taxonomyrules *taxonomyRules, const char *taxonomyDirectory="../taxonomy", const bool useIndex=true, const bool createList=false, const char *preparingDirectory="../taxonomy/preparing", const char *oldDirectory="../taxonomy/old")
Create a taxonomy tree based on the rules specified in mascot.dat.
ms_taxonomytree (const ms_taxonomytree &src)
Copying constructor.
~ms_taxonomytree ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_taxonomytree *right)
Can be used to create a copy of another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getParent (const int id, int &ttParent, int &ttGenTable) const
Return the parent id and translation table id for a species.
TAX_TREE_NODES * | getTaxIDArray ()
Return a raw array of TAX_TREE_NODE values, with the array index being the id.
bool | isIncludedIn (const int id, const ms_taxonomychoice *choice) const
Return true if the taxonomy id is included in the choice.
bool | isSpeciesDescendantOf (const int parentID, const int id) const
Determine if a particular id is a child of the parentID.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_taxonomytree & | operator= (const ms_taxonomytree &right)
Assignment operator for C++ client applications.

Detailed Description

The complete taxonomy tree as built from one or more files such as nodes.dmp.

Used for determining the taxonomy lineage. This class is used to load all of the files specified in a specified taxonomy section in mascot.dat, for example:

     NodesFiles          NCBI:nodes.dmp, NCBI:merged.dmp

Index files are created using ms_tinycdb to improve performance in cases where a moderate number of parent id's are required. Index files are created in the same directory as the text files, with an additional 'extension' of ".cdb". Error or warning messages in ms_tinycdb are concatenated into the ms_taxonomytree object. If, for example, the process does not have write access to the directory with the taxonomy files , then an error ms_errs:: is generated, but the object is still valid and will continue with just the text files.

Other possible errors include: ms_errs::ERR_MSP_TAXONOMY_CONFLICT_PARENTS ms_errs::ERR_MSP_TAXONOMY_INVALID_NODE_FILE ms_errs::ERR_MSP_TAXONOMY_MISSING_NODE_FILE

The nodes.dmp file also contains the genetic code translation table id to be used when translating from nucleic acid to protein.

Example code to see if Homo Sapiens (9606) are mammals (40674):

     my $datfile = new msparser::ms_datfile("../config/mascot.dat");
     my $taxonomy_rules = $datfile->getTaxonomyRules(3);
     my $tree = new msparser::ms_taxonomytree($taxonomy_rules);
     if ($tree->isValid()) {
       my $human = 9606;
       my $mammalia = 40674;
       if ($tree->isSpeciesDescendantOf($mammalia, $human)) {
         print "Indeed, we are mammals\n";
       }
     }

Constructor & Destructor Documentation

ms_taxonomytree | ( | const ms_taxonomyrules * | taxonomyRules,
 |  | const char * | taxonomyDirectory = "../taxonomy",
 |  | const bool | useIndex = true,
 |  | const bool | createList = false,
 |  | const char * | preparingDirectory = "../taxonomy/preparing",
 |  | const char * | oldDirectory = "../taxonomy/old"
 | ) |  |

Create a taxonomy tree based on the rules specified in mascot.dat.

The complete taxonomy tree as built from one or more files such as nodes.dmp

Parameters:
taxonomyRules | contains the list of NodesFiles specified in the taxonomy section of mascot.dat. These files are all loaded by this constructor. The names are retrieved using ms_taxonomyrules::getNodesFile
taxonomyDirectory | specifies the directory to look in for the files. The names in mascot.dat do not normally include path information since the files are generally in the ../taxonomy directory
useIndex | will normally be set to true. If just a handful of 'parent ids' are required, then it is most efficient to use the index files. See getTaxIDArray() for a situation where this should be set to false.
createList | will normally be set to false. It is used to create the list of nodes in memory even if the cache file is used.
preparingDirectory | optional parameter to specify a directory to look for new files and create temporary index files. Once the index files have been created, the new file and the created index files are moved to taxonomyDirectory. If this parameter is an empty string, or if there are no taxonomy files in this directory, new files will be looked for in taxonomyDirectory instead, and the index files will be created directly in taxonomyDirectory.
oldDirectory | optional parameter to archive existing files once index files have been created for a new file. If this parameter is an empty string, no archiving will be done.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_taxonomytree * right )

Can be used to create a copy of another instance.

Useful from Perl or scripting languages

Parameters:
right is the object to copy from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getParent | ( | const int | id,
 |  | int & | ttParent,
 |  | int & | ttGenTable
 | ) |  | const

Return the parent id and translation table id for a species.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | id | is the NCBI taxonomy id for which to find the parent and translation table.
[out] | ttParent | is the parent id. This will be set to 0 if an entry is not found for id.
[out] | ttGenTable | is the genetic code translation table to be used for converting nucleic acid sequences to protein sequences.
Returns:
false if the id is < 1 or greater than the number of entries or if the id is not found in any of the tables.
ms_taxonomytree::TAX_TREE_NODES * getTaxIDArray ( )

Return a raw array of TAX_TREE_NODE values, with the array index being the id.

This function will only return a non zero value if the useIndex value passed to the constructor is set to false.

The calling function should not call delete on the pointer. The vector is deleted when the ms_taxonomytree object is deleted.

Returns:
a pointer to the taxonomy tree nodes or NULL
bool isIncludedIn | ( | const int | id,
 |  | const ms_taxonomychoice * | choice
 | ) |  | const

Return true if the taxonomy id is included in the choice.

For example, take the definition of "Other Mammalia":

   Title:. . . . . . . . . . . . . . Other mammalia
   Include: 40674
   Exclude: 9443, 9989

If you pass 9606 (Human) and a choice of "Other Mammalia", this function would return false, because in this case, 9606 is part of 9443 (Primates).

Parameters:
id | is the taxonomy id
choice | is the return from calling ms_taxonomyfile::getEntryByName
Returns:
true if taxonomy id is included in taxonomy choice, false otherwise
bool isSpeciesDescendantOf | ( | const int | parentID,
 |  | const int | id
 | ) |  | const

Determine if a particular id is a child of the parentID.

Parameters:
parentID | is the taxonomy id of the parent
id | is the taxonomy id to be tested
Returns:
true if the taxonomy is a descendent of the parentID
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_taxonomytree & operator= ( const ms_taxonomytree & right )

Assignment operator for C++ client applications.

Cannot be used from scripting languages

Parameters:
right is the object to copy from
Returns:
a reference to 'this'
The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_taxspeciesfiles
Public Member Functions

ms_taxspeciesfiles Class Reference
[Mascot configuration files module]

An instance of this class describes one entry of taxonomy species files. More...

#include <ms_taxonomyrules.hpp>

List of all members.

Public Member Functions

ms_taxspeciesfiles ()
Default constructor.
ms_taxspeciesfiles (const ms_taxspeciesfiles &src)
Copying constructor.
~ms_taxspeciesfiles ()
Destructor.
void | copyFrom (const ms_taxspeciesfiles *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance.
std::string | getFileName () const
Returns the file name.
TAX_SPECIES_FORMAT | getFormat () const
Returns a format identifier for the entry.
ms_taxspeciesfiles & | operator= (const ms_taxspeciesfiles &right)
Assignment operator for C++ client applications.
void | setFileName (const char *name)
Change the file name.
void | setFormat (const TAX_SPECIES_FORMAT value)
Change the format of the entry.

Detailed Description

An instance of this class describes one entry of taxonomy species files.

The documentation for this class was generated from the following files:
  • ms_taxonomyrules.hpp
  • ms_taxonomyrules.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_aminoacid
Public Member Functions

ms_umod_aminoacid Class Reference
[Mascot configuration files module]

Represents an "amino acid" object in unimod.xml. More...

#include <ms_umod_aminoacid.hpp>

List of all members.

Public Member Functions

ms_umod_aminoacid ()
Default constructor.
ms_umod_aminoacid (const ms_umod_aminoacid &src)
Copying constructor.
virtual | ~ms_umod_aminoacid ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_umod_aminoacid *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropFullName ()
Delete the full_name attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropThreeLetter ()
Delete the three_letter attribute.
void | dropTitle ()
Delete the title attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFullName () const
Returns the value of the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns a number of element reference objects currently held in memory.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getThreeLetter () const
Returns the value of the three_letter attribute.
std::string | getThreeLetterSchemaType () const
Obtain a symbolic name for the three_letter attribute schema type.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | haveThreeLetter () const
Indicates presence of the three_letter attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
ms_umod_aminoacid & | operator= (const ms_umod_aminoacid &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
void | setThreeLetter (const char *value)
Set a custom value for the three_letter attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents an "amino acid" object in unimod.xml.

Constructor & Destructor Documentation

ms_umod_aminoacid ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_aminoacid ( const ms_umod_aminoacid & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendElemRef ( const ms_umod_elemref * elemref )

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
elemref an instance of element reference object to copy the content from.
void clearElemRefs ( )

Deletes all element reference objects from the list.

Deletes all element references from the list

void copyFrom ( const ms_umod_aminoacid * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteElemRef ( const int idx )

Remove an element reference object from the list in memory.

Parameters:
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns:
TRUE if the object has been found and successfully deleted and FALSE otherwise.
void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until it is re-set.

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

void dropThreeLetter ( )

Delete the three_letter attribute.

Deletes the attribute until it is re-set.

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until it is re-set.

double getAvgeMass ( ) const

Returns the value of the avge_mass attribute.

Average mass for the amino acid.

Returns:
current value of the attribute.
std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_elemref * getElemRef ( const int idx ) const

Returns a read-only pointer to an element reference object by its number.

Retrieves an element reference object from the list by its number.

Parameters:
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getElemRefSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getFullName ( ) const

Returns the value of the full_name attribute.

A full name for the amino acid.

Returns:
current value of the attribute.
std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
double getMonoMass ( ) const

Returns the value of the mono_mass attribute.

Monoisotopic mass for the amino acid.

Returns:
current value of the attribute.
std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElemRefs ( ) const

Returns a number of element reference objects currently held in memory.

Returns:
total number of chemical element references in the modification object
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType").
std::string getThreeLetter ( ) const

Returns the value of the three_letter attribute.

A three-letter name for the amino acid.

Returns:
current value of the attribute.
std::string getThreeLetterSchemaType ( ) const

Obtain a symbolic name for the three_letter attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the amino acid.

Returns:
current value of the attribute.
std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveThreeLetter ( ) const

Indicates presence of the three_letter attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_umod_aminoacid & operator= ( const ms_umod_aminoacid & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAvgeMass ( const double value )

Set a custom value for the avge_mass attribute.

Parameters:
value a new value for the attribute.
void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters:
value a new value for the attribute.
void setMonoMass ( const double value )

Set a custom value for the mono_mass attribute.

Parameters:
value a new value for the attribute.
void setThreeLetter ( const char * value )

Set a custom value for the three_letter attribute.

Parameters:
value a new value for the attribute.
void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters:
value a new value for the attribute.
bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |

Update the information for a particular element reference object.

Parameters:
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns:
TRUE if the element reference has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_aminoacid.hpp
  • ms_umod_aminoacid.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_composition
Public Member Functions

ms_umod_composition Class Reference
[Mascot configuration files module]

Represents the composition type in unimod.xml. More...

#include <ms_umod_composition.hpp>

Inheritance diagram for ms_umod_composition:
[legend]

List of all members.

Public Member Functions

ms_umod_composition ()
Default constructor.
ms_umod_composition (const ms_umod_composition &src)
Copying constructor.
ms_umod_composition (const ms_quant_composition &src, const ms_umod_configfile &umodFile)
Copying constructor.
virtual | ~ms_umod_composition ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_quant_composition *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_umod_composition *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropCompositionString ()
Delete the composition attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
std::string | getCompositionString () const
Returns the value of the composition attribute.
std::string | getCompositionStringSchemaType () const
Obtain a symbolic name for the composition attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns the number of element reference objects currently held in memory.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveCompositionString () const
Indicates presence of the composition attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | isSameAs (const ms_umod_composition &right) const
Returns true if instances contain the same information.
ms_umod_composition & | operator= (const ms_umod_composition &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setCompositionString (const char *value)
Set a custom value for the composition attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
void | updateMasses (const ms_umod_configfile &umodFile, const ms_quant_component &quantComp)
Recalculates all deltas with isotope substitution according to selected component in quantification.xml.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the composition type in unimod.xml.

This type is used for modification delta and ignore elements in unimod.xml.

Constructor & Destructor Documentation

ms_umod_composition ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_composition ( const ms_umod_composition & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.
ms_umod_composition | ( | const ms_quant_composition & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor.

Parameters:
src | another object to copy the content from.
umodFile | an instance of a Unimod file object to extract element masses.

Member Function Documentation

void appendElemRef ( const ms_umod_elemref * elemref )

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
elemref an instance of element reference object to copy the content from.
void copyFrom ( const ms_umod_composition * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom | ( | const ms_quant_composition * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from another object.

Parameters:
right | another object to copy the content from.
umodFile | a Unimod file object to obtain element masses from.
void defaultValues ( )

Call this member if you want to start again.

This will reset all internal values to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented in ms_umod_neutralloss.

bool deleteElemRef ( const int idx )

Remove an element reference object from the list in memory.

Parameters:
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns:
TRUE if the object has been found and successfully deleted and FALSE otherwise.
void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

void dropCompositionString ( )

Delete the composition attribute.

Deletes the attribute until it is re-set.

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

double getAvgeMass ( ) const

Returns the value of the avge_mass attribute.

Average mass for the object.

Returns:
current value of the attribute.
std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getCompositionString ( ) const

Returns the value of the composition attribute.

A composition string for the object.

Returns:
current value of the attribute.
std::string getCompositionStringSchemaType ( ) const

Obtain a symbolic name for the composition attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_elemref * getElemRef ( const int idx ) const

Returns a read-only pointer to an element reference object by its number.

Retrieves an element reference object from the list by its number.

Parameters:
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getElemRefSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
double getMonoMass ( ) const

Returns the value of the mono_mass attribute.

Monoisotopic mass for the object.

Returns:
current value of the attribute.
std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElemRefs ( ) const

Returns the number of element reference objects currently held in memory.

Returns:
total number of chemical element references in the composition object.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType").

Reimplemented in ms_umod_neutralloss.

bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveCompositionString ( ) const

Indicates presence of the composition attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool isSameAs ( const ms_umod_composition & right ) const

Returns true if instances contain the same information.

Compares the element symbols and number of symbols that make up the composition regardless of storage order. Element symbols may be specified in the composition but have a count of zero and so do not affect the total mass values.

Parameters:
right another instance of this class to compare.
Returns:
true if the two compositions are equivalent.
ms_umod_composition & operator= ( const ms_umod_composition & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAvgeMass ( const double value )

Set a custom value for the avge_mass attribute.

Parameters:
value a new value for the attribute.
void setCompositionString ( const char * value )

Set a custom value for the composition attribute.

Parameters:
value a new value for the attribute.
void setMonoMass ( const double value )

Set a custom value for the mono_mass attribute.

Parameters:
value a new value for the attribute.
bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |

Update the information for a particular element reference object.

Parameters:
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns:
TRUE if the element reference has been found and successfully updated and FALSE otherwise.
void updateMasses | ( | const ms_umod_configfile & | umodFile,
 |  | const ms_quant_component & | quantComp
 | ) |  |

Recalculates all deltas with isotope substitution according to selected component in quantification.xml.

The method updates masses according to the selected isotope substitution. Masses are recalculated only in the current modification object, not in the whole Unimod file object umodFile. The Unimod file object is used only to retrieve masses of elements and their isotopes.

Parameters:
umodFile | Unimod file object.
quantComp | component object from quantitation.xml.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_umod_neutralloss.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_umod_neutralloss.

The documentation for this class was generated from the following files:
  • ms_umod_composition.hpp
  • ms_umod_composition.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_configfile
Public Types | Public Member Functions | Static Public Member Functions

ms_umod_configfile Class Reference
[Mascot configuration files module]

This class represents the file unimod.xml. More...

#include <ms_umod_configfile.hpp>

Inheritance diagram for ms_umod_configfile:
[legend]
Collaboration diagram for ms_umod_configfile:
[legend]

List of all members.

Public Types

enum MODFILE_FLAGS {
MODFILE_FLAGS_EMPTY = 0x00000000,
MODFILE_FLAGS_REGULAR = 0x00000001,
MODFILE_FLAGS_HIDDEN = 0x00000002,
MODFILE_FLAGS_AASUBST = 0x00000004,
MODFILE_FLAGS_ALL = 0x7FFFFFFF
}

Flags for the type of modifications to retrieve.

More...

Public Member Functions

ms_umod_configfile ()
Default constructor.
ms_umod_configfile (const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true)
Immediate action constructor that reads the XML file with the given name.
ms_umod_configfile (const ms_umod_configfile &right)
Copying constructor.
virtual | ~ms_umod_configfile ()
Desctructor.
void | appendAminoAcid (const ms_umod_aminoacid *aa)
Adds a new amino acid at the end of the list.
void | appendElement (const ms_umod_element *elem)
Adds a new element at the end of the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | appendModBrick (const ms_umod_modbrick *brick)
Adds a new modification brick at the end of the list.
void | appendModification (const ms_umod_modification *mod)
Adds a new modification at the end of the list.
void | applyVisibility (const ms_session *session)
If visibility settings are present for this file and session then apply to the currently loaded list of modifications.
void | applyVisibility (const std::vector< int > &groupIds)
If visibility settings are present for this file and these group ids, then apply to the currently loaded list of modifications.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearAminoAcids ()
Deletes all amino acids from the list.
void | clearElements ()
Deletes all elements from the list.
void | clearModBricks ()
Deletes all modification bricks from the list.
void | clearModifications ()
Deletes all modifications from the list.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_umod_configfile *right)
Copies all the information from another instance.
virtual void | defaultValues ()
Re-initialises the instance.
bool | deleteAminoAcidByName (const char *name)
Remove an amino acid from the list in memory.
bool | deleteAminoAcidByNumber (const int idx)
Remove an amino acid from the list in memory.
bool | deleteElementByName (const char *name)
Remove an element from the list in memory.
bool | deleteElementByNumber (const int idx)
Remove an element from the list in memory.
bool | deleteModBrickByName (const char *name)
Remove a modification brick from the list in memory.
bool | deleteModBrickByNumber (const int idx)
Remove a modification brick from the list in memory.
bool | deleteModificationByName (const char *name)
Remove a modification from the list in memory.
bool | deleteModificationByNumber (const int idx)
Remove a modification from the list in memory.
int | findModFileName (const char *modFileName) const
Returns modification index by its mod_file-style name (like "Acetyl (K)").
int | findModification (const char *modName) const
Retrieves modification index by its plain name.
const ms_umod_aminoacid * | getAminoAcidByName (const char *name) const
Returns an amino acid object by its name or NULL in case of not found.
const ms_umod_aminoacid * | getAminoAcidByNumber (const int idx) const
Returns an amino acid object by its number.
ms_connection_settings | getConnectionSettings () const
Returns the sessionID and proxy server for use with an HTTP transfer.
const ms_umod_element * | getElementByName (const char *name) const
Returns an element object by its name or NULL in case of not found.
const ms_umod_element * | getElementByNumber (const int idx) const
Returns an element object by its number.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the current file name.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getMajorVersion () const
Returns major document schema version as read from the file, otherwise the latest.
std::string | getMinorVersion () const
Returns minor document schema version as read from the file, otherwise the latest.
const ms_umod_modbrick * | getModBrickByName (const char *name) const
Returns a modification brick object by its name or NULL in case of not found.
const ms_umod_modbrick * | getModBrickByNumber (const int idx) const
Returns an modification brick object by its number.
std::vector< std::string > | getModFileList (const unsigned int flags=MODFILE_FLAGS_ALL) const
Returns an ordered list of modification names in mod_file-style, i.e. "Acetyl (K)" instead of "Acetyl".
const ms_umod_modification * | getModificationByName (const char *name) const
Returns a modification object by its name or NULL in case of not found.
const ms_umod_modification * | getModificationByNumber (const int idx) const
Returns a modification object by its number.
int | getNumberOfAminoAcids () const
Returns a number of amino acids currently held in memory.
int | getNumberOfElements () const
Returns a number of elements currently held in memory.
int | getNumberOfModBricks () const
Returns a number of modification bricks currently held in memory.
int | getNumberOfModifications () const
Returns a number of modifications currently held in memory.
std::string | getSchemaFileName () const
Returns the current schema file name that is used to validate the XML file.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_umod_configfile & | operator= (const ms_umod_configfile &right)
Assignment operator for C++ applications.
void | read_buffer (const char *buffer)
Reads configuration information from a string buffer.
void | read_file ()
Reads configuration information from the XML file.
std::string | save_buffer (bool validateAgainstSchema=true)
Creates a string representation of the XML document with all the content of the object.
void | save_file ()
Saves configuration information in the XML file (not mod_file).
void | setConnectionSettings (const ms_connection_settings &cs)
Sets the sessionID and proxy server for use with an HTTP transfer.
void | setFileName (const char *filename)
Changes the file name for subsequent read/write operations (do not use it for saving in a mod_file!).
void | setMajorVersion (const std::string &version)
Update the major document schema version.
void | setMinorVersion (const std::string &version)
Update the minor document schema version.
void | setSchemaFileName (const char *name)
Call this member to specify a custom schema file name for validating the XML file.
bool | updateAminoAcidByName (const char *name, const ms_umod_aminoacid *aa)
Update the information for a specific amino acid.
bool | updateAminoAcidByNumber (const int idx, const ms_umod_aminoacid *aa)
Update the information for a specific amino acid.
bool | updateElementByName (const char *name, const ms_umod_element *element)
Update the information for a specific element.
bool | updateElementByNumber (const int idx, const ms_umod_element *element)
Update the information for a specific element.
void | updateMasses ()
Recalculates all masses derived from elements (brick masses, modification deltas etc.).
bool | updateModBrickByName (const char *name, const ms_umod_modbrick *brick)
Update the information for a specific modification brick.
bool | updateModBrickByNumber (const int idx, const ms_umod_modbrick *brick)
Update the information for a specific modification brick.
bool | updateModificationByName (const char *name, const ms_umod_modification *mod)
Update the information for a specific modification.
bool | updateModificationByNumber (const int idx, const ms_umod_modification *mod)
Update the information for a specific modification.
std::string | validateDocument () const
Validates the whole document against schema and returns errors as a string.

Static Public Member Functions

static std::string | getDefaultSchemaFileName ()
Returns the default schema filename (no path)

Detailed Description

This class represents the file unimod.xml.

The Unimod file comprises chemical elements, amino-acids and modifications. The file can be created from scratch, read from a disk file or retrieved from a remote location (HTTP) and then saved as a mod_file or another unimod.xml.

After reading a file and before using the object check validity by calling isValid() and retrieve error descriptions with getLastErrorString() if not valid. Similarly, after writing out the file, isValid() can be used to check if the file has been created correctly and is valid for further use.

Member Enumeration Documentation

enum MODFILE_FLAGS

Flags for the type of modifications to retrieve.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

The result of combining these flags is a union of modifications sets.

Enumerator:
MODFILE_FLAGS_EMPTY

Default behaviour (regular modifications only).

MODFILE_FLAGS_REGULAR

Non-hidden modifications which are not AA-substitutions.

MODFILE_FLAGS_HIDDEN

Hidden modifications which are not AA-substitutions.

MODFILE_FLAGS_AASUBST

AA substitutions.

MODFILE_FLAGS_ALL

Get all modifications.

Constructor & Destructor Documentation

ms_umod_configfile | ( | const char * | fileName,
 |  | const char * | schemaFileName,
 |  | const ms_connection_settings * | cs = 0,
 |  | bool | useSchema = true
 | ) |  |

Immediate action constructor that reads the XML file with the given name.

An instance of this class is normally created using this form of the constructor.

Parameters:
fileName | represents either local file name (for example, "C:/unimod.xml") or a fully formed URL such as http://www.matrixscience.com/cgi . The filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
schemaFileName | is a local file name for the schema (for example, "C:/unimod_2.xsd"). The schema must be a local file -- it cannot be accessed using HTTP. The schema filename may use backslashes or forward slashes on Windows and spaces in file or directory names are allowed.
cs | a connection settings object for downloading the file from a Mascot server. This should contain a sessionID and optionally the proxy server settings. For a local file cs is not required and will be ignored.
useSchema | specify whether it should use a xsd schema validator, true by default
ms_umod_configfile ( const ms_umod_configfile & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendAminoAcid ( const ms_umod_aminoacid * aa )

Adds a new amino acid at the end of the list.

Creates a new amino acid object, copies all content from the object supplied as a parameter and adds it at the end of the amino acids list.

Parameters:
aa an instance of the amino acid object to copy content from.
void appendElement ( const ms_umod_element * elem )

Adds a new element at the end of the list.

Creates a new element object, copies all content from the object supplied as a parameter and adds it at the end of the elements list.

Parameters:
elem an instance of the element object to copy content from.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void appendModBrick ( const ms_umod_modbrick * brick )

Adds a new modification brick at the end of the list.

Creates a new modification brick object, copies all content from the object supplied as a parameter and adds it at the end of the modification bricks list.

Parameters:
brick an instance of the modification brick object to copy content from.
void appendModification ( const ms_umod_modification * mod )

Adds a new modification at the end of the list.

Creates a new modification object, copies all content from the object supplied as a parameter and adds it at the end of the modifications list.

Parameters:
mod an instance of the modification object to copy content from.
void applyVisibility ( const ms_session * session )

If visibility settings are present for this file and session then apply to the currently loaded list of modifications.

If visibility settings are present for this file and session then apply to the currently loaded list of modifications.

Parameters:
session Optional session object used to apply user security restrictions. Can be NULL or not supplied.
void applyVisibility ( const std::vector< int > & groupIds )

If visibility settings are present for this file and these group ids, then apply to the currently loaded list of modifications.

If visibility settings are present for this file and group ids then apply to the currently loaded list of modifications.

Parameters:
groupIds vector of group ids to apply visibility for
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_umod_configfile * right )

Copies all the information from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void defaultValues ( ) [virtual]

Re-initialises the instance.

After calling this method, all internal values will be reset to their defaults, as if the object had been freshly created with the default constructor.

This method, however, doesn't change file name, schema location and connection settings. If a complete cleanup is required, you need to do three additional calls:

   umod_configfile.setFileName("");
   umod_configfile.setSchemaFileName("");
   umod_configfile.setConnectionSetting(ms_connection_settings());
bool deleteAminoAcidByName ( const char * name )

Remove an amino acid from the list in memory.

Parameters:
name name of the amino acid for deletion.
Returns:
TRUE if the amino acid has been found and successfully deleted and FALSE otherwise.
bool deleteAminoAcidByNumber ( const int idx )

Remove an amino acid from the list in memory.

Parameters:
idx number of the amino acid for deletion from 0 to (getNumberOfAminoAcids() - 1).
Returns:
TRUE if the amino acid has been found and successfully deleted and FALSE otherwise.
bool deleteElementByName ( const char * name )

Remove an element from the list in memory.

Parameters:
name name of the element for deletion.
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
bool deleteElementByNumber ( const int idx )

Remove an element from the list in memory.

Parameters:
idx number of the element for deletion from 0 to (getNumberOfElements() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
bool deleteModBrickByName ( const char * name )

Remove a modification brick from the list in memory.

Parameters:
name name of the modification brick for deletion.
Returns:
TRUE if the modification brick has been found and successfully deleted and FALSE otherwise.
bool deleteModBrickByNumber ( const int idx )

Remove a modification brick from the list in memory.

Parameters:
idx number of the modification brick for deletion from 0 to (getNumberOfModBricks() - 1).
Returns:
TRUE if the modification brick has been found and successfully deleted and FALSE otherwise.
bool deleteModificationByName ( const char * name )

Remove a modification from the list in memory.

Parameters:
name name of the modification for deletion.
Returns:
TRUE if the modification has been found and successfully deleted and FALSE otherwise.
bool deleteModificationByNumber ( const int idx )

Remove a modification from the list in memory.

Parameters:
idx number of the modification for deletion from 0 to (getNumberOfModifications() - 1).
Returns:
TRUE if the modification has been found and successfully deleted and FALSE otherwise.
int findModFileName ( const char * modFileName ) const

Returns modification index by its mod_file-style name (like "Acetyl (K)").

Parameters:
modFileName modification string name.
Returns:
modification zero-based index or -1 (if not found).
int findModification ( const char * modName ) const

Retrieves modification index by its plain name.

Tries to find modification by its name (not mod_file-style name).

Parameters:
modName modification string name.
Returns:
modification zero-based index if the modification is found and -1 otherwise.
const ms_umod_aminoacid * getAminoAcidByName ( const char * name ) const

Returns an amino acid object by its name or NULL in case of not found.

Parameters:
name a unique name of the amino acid.
Returns:
a read-only pointer to an amino acid object. See Maintaining object references: two rules of thumb.
const ms_umod_aminoacid * getAminoAcidByNumber ( const int idx ) const

Returns an amino acid object by its number.

Parameters:
idx number of the amino acid from 0 to (getNumberOfAminoAcids() - 1).
Returns:
a read-only pointer to an amino acid object.
std::string getDefaultSchemaFileName ( ) [static]

Returns the default schema filename (no path)

Static method to return the filename of the currently used schema

Returns:
Returns "unimod_2.xsd" (at version 2.6.1)
const ms_umod_element * getElementByName ( const char * name ) const

Returns an element object by its name or NULL in case of not found.

Parameters:
name a unique name of the element.
Returns:
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.
const ms_umod_element * getElementByNumber ( const int idx ) const

Returns an element object by its number.

Parameters:
idx number of the element from 0 to (getNumberOfElements() - 1).
Returns:
a read-only pointer to an element object. See Maintaining object references: two rules of thumb.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns the current file name.

Returns:
currently set file location (not necessarily the location from which the current content has been read).
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
const ms_umod_modbrick * getModBrickByName ( const char * name ) const

Returns a modification brick object by its name or NULL in case of not found.

Parameters:
name a unique name of the modification brick.
Returns:
a read-only pointer to a modification brick object. See Maintaining object references: two rules of thumb.
const ms_umod_modbrick * getModBrickByNumber ( const int idx ) const

Returns an modification brick object by its number.

Parameters:
idx number of the modification brick from 0 to (getNumberOfModBricks() - 1).
Returns:
a read-only pointer to a modification brick object.
std::vector< std::string > getModFileList ( const unsigned int flags = MODFILE_FLAGS_ALL ) const

Returns an ordered list of modification names in mod_file-style, i.e. "Acetyl (K)" instead of "Acetyl".

Parameters:
flags can be one or more of the ms_umod_configfile::MODFILE_FLAGS values OR'ed together.
Returns:
an ordered modification names list.
const ms_umod_modification * getModificationByName ( const char * name ) const

Returns a modification object by its name or NULL in case of not found.

Parameters:
name a unique name of the modification.
Returns:
a read-only pointer to a modification object. See Maintaining object references: two rules of thumb.
const ms_umod_modification * getModificationByNumber ( const int idx ) const

Returns a modification object by its number.

Parameters:
idx number of the modification from 0 to (getNumberOfModifications() - 1).
Returns:
a read-only pointer to a modification-object. See Maintaining object references: two rules of thumb.
int getNumberOfAminoAcids ( ) const

Returns a number of amino acids currently held in memory.

Returns:
total number of amino acids in the configuration file.
int getNumberOfElements ( ) const

Returns a number of elements currently held in memory.

Returns:
total number of elements in the configuration file.
int getNumberOfModBricks ( ) const

Returns a number of modification bricks currently held in memory.

Returns:
total number of modification bricks in the configuration file.
int getNumberOfModifications ( ) const

Returns a number of modifications currently held in memory.

Returns:
total number of modifications in the configuration file.
std::string getSchemaFileName ( ) const

Returns the current schema file name that is used to validate the XML file.

Returns:
currently set file location (not necessarily the location from which the current content has been read).
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_umod_configfile & operator= ( const ms_umod_configfile & right )

Assignment operator for C++ applications.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void read_buffer ( const char * buffer )

Reads configuration information from a string buffer.

This method is useful when reading configuration information from a mascor result file. Old content of the object will be removed and substituted with the information read from the buffer.

Parameters:
buffer string buffer that contains a valid xml-document. It can be a document with just one modification in it, or only with amino acid masses.
void read_file ( )

Reads configuration information from the XML file.

Downloads the file if necessary from the Unimod web site and parses it. Check for errors before using any other methods for retrieving content.

std::string save_buffer ( bool validateAgainstSchema = true )

Creates a string representation of the XML document with all the content of the object.

Creates a valid XML document and returns it as a string which can be used, for example, for writing out configuration information to mascot result file.

To produce a 'file' that validates against the schema, it is not sufficient to add, for example, just a modification because this will be missing keyrefs to elements and termini building 'bricks'.

If you choose not to validate against the schema, then it is sufficient to just output, say, a single modification.

Parameters:
validateAgainstSchema specifies whether to validate against the schema. If true and the schema file exists and the resulting XML fails to validate, then an empty string will be returned and the errors will indicate why it failed to validate.
Returns:
XML document with the object content.
void save_file ( )

Saves configuration information in the XML file (not mod_file).

Check for errors after calling this method to see if the operation has been successful or to get any schema validation errors. If the document is not valid it is going to be saved anyway unless there are other problems.

If you want to validate document without actually saving it use validateDocument().

void setConnectionSettings ( const ms_connection_settings & cs )

Sets the sessionID and proxy server for use with an HTTP transfer.

This value would normally be passed in the constructor.

Parameters:
cs is the new connection settings.
void setFileName ( const char * name )

Changes the file name for subsequent read/write operations (do not use it for saving in a mod_file!).

Calling this method does not mean an immediate update on disk. Use either read_file() or save_file() for that.

Parameters:
name a new file location.
void setSchemaFileName ( const char * name )

Call this member to specify a custom schema file name for validating the XML file.

Parameters:
name a new file location (if empty default value will be assigned).
bool updateAminoAcidByName | ( | const char * | name,
 |  | const ms_umod_aminoacid * | aa
 | ) |  |

Update the information for a specific amino acid.

Parameters:
name | name of the amino acid for updating.
aa | an object to copy the content from.
Returns:
TRUE if the amino acid has been found and successfully updated and FALSE otherwise.
bool updateAminoAcidByNumber | ( | const int | idx,
 |  | const ms_umod_aminoacid * | aa
 | ) |  |

Update the information for a specific amino acid.

Parameters:
idx | number of the amino acid for updating from 0 to (getNumberOfAminoAcids() - 1).
aa | an object to copy the content from.
Returns:
TRUE if the amino acid has been found and successfully updated and FALSE otherwise.
bool updateElementByName | ( | const char * | name,
 |  | const ms_umod_element * | element
 | ) |  |

Update the information for a specific element.

Parameters:
name | name of the element for updating.
element | an object to copy the content from.
Returns:
TRUE if the element has been found and successfully updated and FALSE otherwise.
bool updateElementByNumber | ( | const int | idx,
 |  | const ms_umod_element * | element
 | ) |  |

Update the information for a specific element.

Parameters:
idx | number of the element for updating from 0 to (getNumberOfElements() - 1).
element | an object to copy the content from.
Returns:
TRUE if the element has been found and successfully updated and FALSE otherwise.
bool updateModBrickByName | ( | const char * | name,
 |  | const ms_umod_modbrick * | brick
 | ) |  |

Update the information for a specific modification brick.

Parameters:
name | name of the modification brick for updating.
brick | an object to copy the content from.
Returns:
TRUE if the modification brick has been found and successfully updated and FALSE otherwise.
bool updateModBrickByNumber | ( | const int | idx,
 |  | const ms_umod_modbrick * | brick
 | ) |  |

Update the information for a specific modification brick.

Parameters:
idx | number of the modification brick for updating from 0 to (getNumberOfModBricks() - 1).
brick | an object to copy the content from.
Returns:
TRUE if the modification brick has been found and successfully updated and FALSE otherwise.
bool updateModificationByName | ( | const char * | name,
 |  | const ms_umod_modification * | mod
 | ) |  |

Update the information for a specific modification.

Parameters:
name | name of the modification for updating.
mod | an object to copy the content from.
Returns:
TRUE if the modification has been found and successfully updated and FALSE otherwise.
bool updateModificationByNumber | ( | const int | idx,
 |  | const ms_umod_modification * | mod
 | ) |  |

Update the information for a specific modification.

Parameters:
idx | number of the modification for updating from 0 to (getNumberOfModifications() - 1).
mod | an object to copy the content from.
Returns:
TRUE if the modification has been found and successfully updated and FALSE otherwise.
std::string validateDocument ( ) const

Validates the whole document against schema and returns errors as a string.

This method doesn't attempt to store the document anywhere and doesn't make the object invalid. Also, no errors are stored. Therefore, this method can be called as many times as necessary without any consequences.

All validation errors will be returned back as a string. However, the XML parser will describe errors in terms of row and column numbers as if the document was actually saved in a file.

Returns:
validation errors as a string or an empty string if there are no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_configfile.hpp
  • ms_umod_configfile.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_element
Public Member Functions

ms_umod_element Class Reference
[Mascot configuration files module]

Represents an element object in unimod.xml. More...

#include <ms_umod_element.hpp>

List of all members.

Public Member Functions

ms_umod_element ()
Default constructor.
ms_umod_element (const ms_umod_element &src)
Copying constructor.
virtual | ~ms_umod_element ()
Destructor.
void | copyFrom (const ms_umod_element *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropFullName ()
Delete the full_name attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropTitle ()
Delete the title attribute.
std::string | getAvgeMass () const
Returns the value of the avge_mass attribute as a string.
double | getAvgeMassAsNumber () const
Returns the value of the avge_mass attribute as a floating point number.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
std::string | getFullName () const
Returns the value of the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
std::string | getMonoMass () const
Returns the value of the mono_mass attribute as a string.
double | getMonoMassAsNumber () const
Returns the value of the mono_mass attribute as a floating point number.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
ms_umod_element & | operator= (const ms_umod_element &right)
C++ style assignment operator.
bool | setAvgeMass (const char *value, ms_errs *err=NULL)
Set a custom string value for the avge_mass attribute.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
bool | setMonoMass (const char *value, ms_errs *err=NULL)
Set a custom string value for the mono_mass attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents an element object in unimod.xml.

Constructor & Destructor Documentation

ms_umod_element ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_element ( const ms_umod_element & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_umod_element * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

After calling this method, internal values are reset to defaults, as if the object had been freshly created with the default constructor.

void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until is re-set.

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until is re-set.

std::string getAvgeMass ( ) const

Returns the value of the avge_mass attribute as a string.

Average mass for the chemical element or an isotope.

Returns:
current string value of the attribute.
double getAvgeMassAsNumber ( ) const

Returns the value of the avge_mass attribute as a floating point number.

Average mass for the chemical element or an isotope.

Returns:
current floating point number value of the attribute.
std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getFullName ( ) const

Returns the value of the full_name attribute.

A full name for the chemical element or an isotope (for example, 'Hydrogen').

Returns:
current value of the attribute.
std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMonoMass ( ) const

Returns the value of the mono_mass attribute as a string.

Monoisotopic mass for the chemical element or an isotope.

Returns:
current string value of the attribute.
double getMonoMassAsNumber ( ) const

Returns the value of the mono_mass attribute as a floating point number.

Monoisotopic mass for the chemical element or an isotope.

Returns:
current floating point number value of the attribute.
std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType").
std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the chemical element or an isotope (for example, 'N15').

Returns:
current value of the attribute.
std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_umod_element & operator= ( const ms_umod_element & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
bool setAvgeMass | ( | const char * | value,
 |  | ms_errs * | err = NULL
 | ) |  |

Set a custom string value for the avge_mass attribute.

The method is trying to parse the string value as a floating point number first. It it fails it reports an error and returns FALSE leaving the old value unchanged.

Parameters:
value | a new string value for the attribute.
err | an error object to return possible error messages.
Returns:
TRUE if the value has been parsed successfully and FALSE otherwise.
void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters:
value a new value for the attribute.
bool setMonoMass | ( | const char * | value,
 |  | ms_errs * | err = NULL
 | ) |  |

Set a custom string value for the mono_mass attribute.

The method is trying to parse the string value as a floating point number first. It it fails it reports an error and returns FALSE leaving the old value unchanged.

Parameters:
value | a new string value for the attribute.
err | an error object to return possible error messages.
Returns:
TRUE if the value has been parsed successfully and FALSE otherwise.
void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_element.hpp
  • ms_umod_element.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_elemref
Public Member Functions

ms_umod_elemref Class Reference
[Mascot configuration files module]

Represents the elemref_t type in unimod.xml. More...

#include <ms_umod_elemref.hpp>

List of all members.

Public Member Functions

ms_umod_elemref ()
Default constructor.
ms_umod_elemref (const ms_umod_elemref &src)
Copying constructor.
ms_umod_elemref (const ms_quant_element &src)
Copying constructor.
virtual | ~ms_umod_elemref ()
Destructor.
void | copyFrom (const ms_umod_elemref *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_element *right)
Copies all content from another object.
void | defaultValues ()
Call this member if you want to start again.
void | dropNumber ()
Delete the number attribute.
void | dropSymbol ()
Delete the symbol attribute.
int | getNumber () const
Returns the value of the number attribute.
std::string | getNumberSchemaType () const
Obtain a symbolic name for the number attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSymbol () const
Returns the value of the symbol attribute.
std::string | getSymbolSchemaType () const
Obtain a symbolic name for the symbol attribute schema type.
bool | haveNumber () const
Indicates presence of the number attribute.
bool | haveSymbol () const
Indicates presence of the symbol attribute.
ms_umod_elemref & | operator= (const ms_umod_elemref &right)
C++ style assignment operator.
void | setNumber (const int value)
Set a custom value for the number attribute.
void | setSymbol (const char *value)
Set a custom value for the symbol attribute.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the elemref_t type in unimod.xml.

This type is used for compositions in order to specify number of each chemical element used in a composition.

Constructor & Destructor Documentation

ms_umod_elemref ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_elemref ( const ms_umod_elemref & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.
ms_umod_elemref ( const ms_quant_element & src )

Copying constructor.

Parameters:
src another object to copy the content from.

Member Function Documentation

void copyFrom ( const ms_umod_elemref * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom ( const ms_quant_element * right )

Copies all content from another object.

Parameters:
right another object to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropNumber ( )

Delete the number attribute.

Deletes the attribute until it is re-set.

void dropSymbol ( )

Delete the symbol attribute.

Deletes the attribute until it is re-set.

int getNumber ( ) const

Returns the value of the number attribute.

Returns:
current value of the attribute.
std::string getNumberSchemaType ( ) const

Obtain a symbolic name for the number attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
std::string getSymbol ( ) const

Returns the value of the symbol attribute.

Returns:
current value of the attribute.
std::string getSymbolSchemaType ( ) const

Obtain a symbolic name for the symbol attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveNumber ( ) const

Indicates presence of the number attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveSymbol ( ) const

Indicates presence of the symbol attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_umod_elemref & operator= ( const ms_umod_elemref & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setNumber ( const int value )

Set a custom value for the number attribute.

Parameters:
value a new value for the attribute.
void setSymbol ( const char * value )

Set a custom value for the symbol attribute.

Parameters:
value a new value for the attribute.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_elemref.hpp
  • ms_umod_elemref.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_modbrick
Public Member Functions

ms_umod_modbrick Class Reference
[Mascot configuration files module]

Represents a modification brick object in unimod.xml. More...

#include <ms_umod_modbrick.hpp>

List of all members.

Public Member Functions

ms_umod_modbrick ()
Default constructor.
ms_umod_modbrick (const ms_umod_modbrick &src)
Copying constructor.
virtual | ~ms_umod_modbrick ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_umod_modbrick *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropFullName ()
Delete the full_name attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropTitle ()
Delete the title attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFullName () const
Returns the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns the number of element reference objects currently held in memory.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
ms_umod_modbrick & | operator= (const ms_umod_modbrick &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a modification brick object in unimod.xml.

Constructor & Destructor Documentation

ms_umod_modbrick ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_modbrick ( const ms_umod_modbrick & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void appendElemRef ( const ms_umod_elemref * elemref )

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
elemref an instance of element reference object to copy the content from.
void copyFrom ( const ms_umod_modbrick * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteElemRef ( const int idx )

Remove an element reference object from the list in memory.

Parameters:
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns:
TRUE if the object has been found and successfully deleted and FALSE otherwise.
void dropAvgeMass ( )

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until it is re-set.

void dropMonoMass ( )

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until it is re-set.

double getAvgeMass ( ) const

Returns the value of the avge_mass attribute.

Average mass for the modification brick.

Returns:
current value of the attribute.
std::string getAvgeMassSchemaType ( ) const

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_elemref * getElemRef ( const int idx ) const

Returns a read-only pointer to an element reference object by its number.

Parameters:
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns:
a read-only pointer to the retrieved object.
std::string getElemRefSchemaType ( ) const

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getFullName ( ) const

Returns the full_name attribute.

A full name for the modification brick.

Returns:
current value of the attribute.
std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
double getMonoMass ( ) const

Returns the value of the mono_mass attribute.

Monoisotopic mass for the modification brick.

Returns:
current value of the attribute.
std::string getMonoMassSchemaType ( ) const

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElemRefs ( ) const

Returns the number of element reference objects currently held in memory.

Returns:
total number of chemical element references in the modification brick object.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the modification brick.

Returns:
current value of the attribute.
std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveAvgeMass ( ) const

Indicates presence of the avge_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMonoMass ( ) const

Indicates presence of the mono_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_umod_modbrick & operator= ( const ms_umod_modbrick & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAvgeMass ( const double value )

Set a custom value for the avge_mass attribute.

Parameters:
value a new value for the attribute.
void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters:
value a new value for the attribute.
void setMonoMass ( const double value )

Set a custom value for the mono_mass attribute.

Parameters:
value a new value for the attribute.
void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters:
value a new value for the attribute.
bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  |

Update the information for a particular element reference object.

Parameters:
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns:
TRUE if the element reference has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_modbrick.hpp
  • ms_umod_modbrick.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_modification
Public Member Functions

ms_umod_modification Class Reference
[Mascot configuration files module]

Represents a modif object in unimod.xml. More...

#include <ms_umod_modification.hpp>

Collaboration diagram for ms_umod_modification:
[legend]

List of all members.

Public Member Functions

ms_umod_modification ()
Default constructor.
ms_umod_modification (const ms_umod_modification &src)
Copying constructor.
ms_umod_modification (const ms_quant_unmodified &src)
Copying constructor that copies the content from a quantitation.xml object.
ms_umod_modification (const ms_quant_localdef &src, const ms_umod_configfile &umodFile)
Copying constructor that copies the content from a quantitation.xml object.
virtual | ~ms_umod_modification ()
Destructor.
void | appendAltName (const char *alt_name)
Adds a new alt_name element at the end of the list.
void | appendIgnore (const ms_umod_composition *ignore)
Adds a new Ignore object at the end of the list.
void | appendSpecificity (const ms_umod_specificity *specificity)
Adds a new specificity at the end of the list.
void | appendXref (const ms_umod_xref *xref)
Adds a new 'xref' object at the end of the list.
void | clearAltNames ()
Deletes all alt_name elements from the list.
void | clearIgnores ()
Deletes all Ignore elements from the list.
void | clearSpecificities ()
Deletes all specificities from the list.
void | clearXrefs ()
Deletes all xref elements from the list.
void | copyFrom (const ms_umod_modification *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_localdef *right, const ms_umod_configfile &umodFile)
Copies all content from a quantitation.xml object.
void | copyFrom (const ms_quant_unmodified *right)
Copies all content from a quantitation.xml object.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteAltName (const int idx)
Remove an alt_name element from the list in memory.
bool | deleteIgnore (const int idx)
Remove an Ignore element from the list in memory.
bool | deleteSpecificity (const int idx)
Remove a specificity from the list in memory.
bool | deleteXref (const int idx)
Remove an xref element from the list in memory.
void | dropApproved ()
Delete the approved attribute.
void | dropDateTimeModified ()
Delete the date_time_modified attribute.
void | dropDateTimePosted ()
Delete the date_time_posted attribute.
void | dropDelta ()
Delete all information about the currently held delta element.
void | dropFullName ()
Delete the full_name attribute.
void | dropGroupOfPoster ()
Delete the group_of_poster attribute.
void | dropMiscNotes ()
Delete the misc_notes element.
void | dropRecordID ()
Delete the record_id attribute.
void | dropTitle ()
Delete the title attribute.
void | dropUsernameOfPoster ()
Delete the username_of_poster attribute.
int | findSpecGroup (const char *modFileName) const
Retrieves specificity group ID for mod_file-style modification name.
std::string | getAltName (const int idx) const
Returns an alt_name element by its number.
std::string | getAltNameSchemaType () const
Obtain a symbolic name for the alt_name element schema type.
std::string | getApprovedSchemaType () const
Obtain a symbolic name for the approved attribute schema type.
std::string | getDateTimeModified () const
Returns the value of the date_time_modified attribute.
std::string | getDateTimeModifiedSchemaType () const
Obtain a symbolic name for the date_time_modified attribute schema type.
std::string | getDateTimePosted () const
Returns the value of the date_time_posted attribute.
std::string | getDateTimePostedSchemaType () const
Obtain a symbolic name for the date_time_posted attribute schema type.
const ms_umod_composition * | getDelta () const
Returns a read-only pointer to the object representing delta element.
std::string | getDeltaSchemaType () const
Obtain a symbolic name for the delta element schema type.
std::string | getFullName () const
Returns the value of the full_name attribute.
std::string | getFullNameSchemaType () const
Obtain a symbolic name for the full_name attribute schema type.
std::string | getGroupOfPoster () const
Returns the value of the group_of_poster attribute.
std::string | getGroupOfPosterSchemaType () const
Obtain a symbolic name for the group_of_poster attribute schema type.
const ms_umod_composition * | getIgnore (const int idx) const
Returns an Ignore object by its number.
std::string | getIgnoreSchemaType () const
Obtain a symbolic name for the Ignore element schema type.
std::string | getMiscNotes () const
Returns the misc_notes element or an empty string if not set.
std::string | getMiscNotesSchemaType () const
Obtain a symbolic name for the misc_notes element schema type.
std::vector< std::string > | getModFileList (const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) const
Returns an ordered list of modification names in mod_file-style, i.e. "Acetyl (K)" instead of "Acetyl".
int | getNumberOfAltNames () const
Returns the number of alt_name elements currently held in memory.
int | getNumberOfIgnores () const
Returns the number of Ignore objects currently held in memory.
int | getNumberOfSpecificities () const
Returns the number of specificities currently held in memory.
int | getNumberOfXrefs () const
Returns the number of xref elements currently held in memory.
std::string | getRecordID () const
Returns the value of the record_id attribute.
std::string | getRecordIDSchemaType () const
Obtain a symbolic name for the record_id attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
const ms_umod_specificity * | getSpecificity (const int idx) const
Returns a specificity object by its number.
const ms_umod_specificity * | getSpecificityBySite (const char *site) const
Returns a specificity object by its site name.
const ms_umod_specificity * | getSpecificityBySiteAndPosition (const char *site, const char *position) const
Returns a specificity object by its site name and position.
std::string | getSpecificitySchemaType () const
Obtain a symbolic name for the specificity element schema type.
std::string | getTitle () const
Returns the value of the title attribute.
std::string | getTitleSchemaType () const
Obtain a symbolic name for the title attribute schema type.
std::string | getUsernameOfPoster () const
Returns the value of the username_of_poster attribute.
std::string | getUsernameOfPosterSchemaType () const
Obtain a symbolic name for the username_of_poster attribute schema type.
const ms_umod_xref * | getXref (const int idx) const
Returns a read-only pointer to xref element by its number.
std::string | getXrefSchemaType () const
Obtain a symbolic name for the xref element schema type.
bool | haveApproved () const
Indicates presence of the approved attribute.
bool | haveDateTimeModified () const
Indicates presence of the date_time_modified attribute.
bool | haveDateTimePosted () const
Indicates presence of the date_time_posted attribute.
bool | haveDelta () const
Indicates presence of the delta element.
bool | haveFullName () const
Indicates presence of the full_name attribute.
bool | haveGroupOfPoster () const
Indicates presence of the group_of_poster attribute.
bool | haveMiscNotes () const
Indicates presence of the misc_notes element.
bool | haveRecordID () const
Indicates presence of the record_id attribute.
bool | haveTitle () const
Indicates presence of the title attribute.
bool | haveUsernameOfPoster () const
Indicates presence of the username_of_poster attribute.
bool | isApproved () const
Returns the value of the approved attribute.
bool | isPrivacyEnabled () const
Indicates whether privacy settings are enabled for this modification.
bool | isPrivate () const
Indicates whether this modification is private and so cannot be viewed or used. Only valid if privacy is enabled.
bool | isSameAs (const ms_umod_modification &right_mod) const
Returns true if instances contain the same information.
ms_umod_modification & | operator= (const ms_umod_modification &right)
C++ style assignment operator.
void | setApproved (const bool value)
Set a custom value for the approved attribute.
void | setDateTimeModified (const char *value)
Set a custom value for the date_time_modified attribute.
void | setDateTimePosted (const char *value)
Set a custom value for the date_time_posted attribute.
void | setDelta (const ms_umod_composition *delta)
Supply new content for the delta element.
void | setFullName (const char *value)
Set a custom value for the full_name attribute.
void | setGroupOfPoster (const char *value)
Set a custom value for the group_of_poster attribute.
void | setMiscNotes (const char *value)
Set a custom value for the misc_notes element.
void | setPrivacyEnabled (bool b)
Sets whether privacy settings are enabled for this modification.
void | setPrivate (bool b)
Sets whether this modification is private.
void | setRecordID (const char *value)
Set a custom value for the record_id attribute.
void | setTitle (const char *value)
Set a custom value for the title attribute.
void | setUsernameOfPoster (const char *value)
Set a custom value for the username_of_poster attribute.
bool | updateAltName (const int idx, const char *alt_name)
Update the string for a particular alt_name element.
bool | updateIgnore (const int idx, const ms_umod_composition *ignore)
Update the information for a particular Ignore element.
void | updateMasses (const ms_umod_configfile &umodFile, const ms_quant_component &quantComp)
Recalculates all deltas with isotope-substitution according to selected component in quantification.xml.
bool | updateSpecificity (const int idx, const ms_umod_specificity *specificity)
Update the information for a particular specificity.
bool | updateXref (const int idx, const ms_umod_xref *xref)
Update the information for a particular xref element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents a modif object in unimod.xml.

Constructor & Destructor Documentation

ms_umod_modification ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_modification ( const ms_umod_modification & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.
ms_umod_modification | ( | const ms_quant_localdef & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor that copies the content from a quantitation.xml object.

Parameters:
src | a quantitation.xml object to copy the content from.
umodFile | an instance of a Unimod file object to extract element masses.
ms_umod_modification ( const ms_quant_unmodified & src )

Copying constructor that copies the content from a quantitation.xml object.

Parameters:
src a quantitation.xml object to copy the content from.

Member Function Documentation

void appendAltName ( const char * alt_name )

Adds a new alt_name element at the end of the list.

Creates a new alt_name element, sets it to the supplied string value and adds it at the end of the alt_name elements list.

Parameters:
alt_name a string value for the new element.
void appendIgnore ( const ms_umod_composition * ignore )

Adds a new Ignore object at the end of the list.

Creates a new Ignore element, copies all content from the object supplied as a parameter and adds it at the end of the ignores list.

Parameters:
ignore an Ignore object to copy the content from.
void appendSpecificity ( const ms_umod_specificity * specificity )

Adds a new specificity at the end of the list.

Creates a new specificity object, copies all content from the object supplied as a parameter and adds it at the end of the specificities list.

Parameters:
specificity an instance of specificity object to copy the content from.
void appendXref ( const ms_umod_xref * xref )

Adds a new 'xref' object at the end of the list.

Creates a new xref element, copies all content from the object supplied as a parameter and adds it at the end of the xref elements list.

Parameters:
xref an xref object to copy the content from.
void copyFrom | ( | const ms_quant_localdef * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from a quantitation.xml object.

Parameters:
right | a quantitation object to copy the content from.
umodFile | a Unimod file object to extract element masses from.
void copyFrom ( const ms_quant_unmodified * right )

Copies all content from a quantitation.xml object.

Parameters:
right a quantitation object to copy the content from.
void copyFrom ( const ms_umod_modification * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteAltName ( const int idx )

Remove an alt_name element from the list in memory.

Parameters:
idx number of the alt_name element for deletion from 0 to (getNumberOfAltNames() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
bool deleteIgnore ( const int idx )

Remove an Ignore element from the list in memory.

Parameters:
idx number of the Ignore element for deletion from 0 to (getNumberOfIgnores() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
bool deleteSpecificity ( const int idx )

Remove a specificity from the list in memory.

Parameters:
idx number of the specificity for deletion from 0 to (getNumberOfSpecificities() - 1).
Returns:
TRUE if the specificity has been found and successfully deleted and FALSE otherwise.
bool deleteXref ( const int idx )

Remove an xref element from the list in memory.

Parameters:
idx number of the xref element for deletion from 0 to (getNumberOfXrefs() - 1).
Returns:
TRUE if the element has been found and successfully deleted and FALSE otherwise.
void dropApproved ( )

Delete the approved attribute.

Deletes the attribute until it is re-set.

void dropDateTimeModified ( )

Delete the date_time_modified attribute.

Deletes the attribute until it is re-set.

void dropDateTimePosted ( )

Delete the date_time_posted attribute.

Deletes the attribute until it is re-set.

void dropDelta ( )

Delete all information about the currently held delta element.

Deletes the element until it is re-set.

void dropFullName ( )

Delete the full_name attribute.

Deletes the attribute until it is re-set.

void dropGroupOfPoster ( )

Delete the group_of_poster attribute.

Deletes the attribute until it is re-set.

void dropMiscNotes ( )

Delete the misc_notes element.

Deletes the element until it is re-set.

void dropRecordID ( )

Delete the record_id attribute.

Deletes the attribute until it is re-set.

void dropTitle ( )

Delete the title attribute.

Deletes the attribute until it is re-set.

void dropUsernameOfPoster ( )

Delete the username_of_poster attribute.

Deletes the attribute until it is re-set.

int findSpecGroup ( const char * modFileName ) const

Retrieves specificity group ID for mod_file-style modification name.

As each modification from unimod.xml can be converted into several mod_file-style modifications, we have to be able to find the right specificity group for a given mod_file-style name.

Parameters:
modFileName mod_file-style modification name (like 'Acetyl (K)').
Returns:
specificity group ID which can be used to extract just a single mod_file-style modification from a Unimod-style modification. If the specificity not found -1 will be returned.
std::string getAltName ( const int idx ) const

Returns an alt_name element by its number.

Retrieves an alt_name element from the list by its number.

Parameters:
idx number of the alt_name element from 0 to (getNumberOfAltNames() - 1).
Returns:
the retrieved string value.
std::string getAltNameSchemaType ( ) const

Obtain a symbolic name for the alt_name element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getApprovedSchemaType ( ) const

Obtain a symbolic name for the approved attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getDateTimeModified ( ) const

Returns the value of the date_time_modified attribute.

Returns:
current value of the attribute.
std::string getDateTimeModifiedSchemaType ( ) const

Obtain a symbolic name for the date_time_modified attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getDateTimePosted ( ) const

Returns the value of the date_time_posted attribute.

Returns:
current value of the attribute.
std::string getDateTimePostedSchemaType ( ) const

Obtain a symbolic name for the date_time_posted attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_composition * getDelta ( ) const

Returns a read-only pointer to the object representing delta element.

Modification delta which is represented as a composition of chemical elements.

Returns:
read-only pointer to the 'delta' object. See Maintaining object references: two rules of thumb.
std::string getDeltaSchemaType ( ) const

Obtain a symbolic name for the delta element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getFullName ( ) const

Returns the value of the full_name attribute.

A full name for the modification.

Returns:
current value of the attribute.
std::string getFullNameSchemaType ( ) const

Obtain a symbolic name for the full_name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getGroupOfPoster ( ) const

Returns the value of the group_of_poster attribute.

Returns:
current value of the attribute.
std::string getGroupOfPosterSchemaType ( ) const

Obtain a symbolic name for the group_of_poster attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_composition * getIgnore ( const int idx ) const

Returns an Ignore object by its number.

Parameters:
idx number of the Ignore element from 0 to (getNumberOfIgnores() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getIgnoreSchemaType ( ) const

Obtain a symbolic name for the Ignore element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMiscNotes ( ) const

Returns the misc_notes element or an empty string if not set.

Returns:
current string value of the element.
std::string getMiscNotesSchemaType ( ) const

Obtain a symbolic name for the misc_notes element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfSpecificities ( ) const

Returns the number of specificities currently held in memory.

Returns:
total number of specificities in the modification object.
std::string getRecordID ( ) const

Returns the value of the record_id attribute.

The unique and stable record ID for the unimod record. Added in Mascot Parser version 2.3.01.

Note that in previous versions of parser, this attribute was not loaded or saved from files. This means that files created by the Mascot Server 2.2 configuration editor strip out the record ID. It also means that the Unimod fragments contained in the Mascot results files from version 2.2 do not contain the record ID.

Returns:
current value of the attribute.
std::string getRecordIDSchemaType ( ) const

Obtain a symbolic name for the record_id attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
const ms_umod_specificity * getSpecificity ( const int idx ) const

Returns a specificity object by its number.

Parameters:
idx number of the specificity from 0 to (getNumberOfSpecificities() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
const ms_umod_specificity * getSpecificityBySite ( const char * site ) const

Returns a specificity object by its site name.

Multiple specificities may exist for a given site with differing position definitions. This method returns the first specificity found with the same site definition. Use ms_umod_modification::getSpecificityBySiteAndPosition to obtain a specificity by bot site and position.

Parameters:
site Name of the specificity to return. String that should be one of the Type mqm:siteType values.
Returns:
a read-only pointer to the retrieved object, can be NULL if specificity for the site is not yet defined. See Maintaining object references: two rules of thumb.
const ms_umod_specificity * getSpecificityBySiteAndPosition | ( | const char * | site,
 |  | const char * | position
 | ) |  | const

Returns a specificity object by its site name and position.

Multiple specificities may exist for a given site with differing position definitions.

Parameters:
site | Name of the specificity to return. String that should be one of the Type mqm:siteType values.
position | Position of the specificity to return. String that should be one of the Type mqm:positionType values.
Returns:
a read-only pointer to the retrieved object, can be NULL if specificity for the site is not yet defined. See Maintaining object references: two rules of thumb.
std::string getSpecificitySchemaType ( ) const

Obtain a symbolic name for the specificity element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getTitle ( ) const

Returns the value of the title attribute.

A unique name for the modification object.

Returns:
current value of the attribute.
std::string getTitleSchemaType ( ) const

Obtain a symbolic name for the title attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getUsernameOfPoster ( ) const

Returns the value of the username_of_poster attribute.

Returns:
current value of the attribute.
std::string getUsernameOfPosterSchemaType ( ) const

Obtain a symbolic name for the username_of_poster attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_xref * getXref ( const int idx ) const

Returns a read-only pointer to xref element by its number.

Parameters:
idx number of the 'xref' element from 0 to (getNumberOfXrefs() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getXrefSchemaType ( ) const

Obtain a symbolic name for the xref element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveApproved ( ) const

Indicates presence of the approved attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveDateTimeModified ( ) const

Indicates presence of the date_time_modified attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveDateTimePosted ( ) const

Indicates presence of the date_time_posted attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveDelta ( ) const

Indicates presence of the delta element.

Returns:
TRUE if the element 'delta' is present and FALSE otherwise.
bool haveFullName ( ) const

Indicates presence of the full_name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveGroupOfPoster ( ) const

Indicates presence of the group_of_poster attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMiscNotes ( ) const

Indicates presence of the misc_notes element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveRecordID ( ) const

Indicates presence of the record_id attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveTitle ( ) const

Indicates presence of the title attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveUsernameOfPoster ( ) const

Indicates presence of the username_of_poster attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool isApproved ( ) const

Returns the value of the approved attribute.

Returns:
current value of the attribute.
bool isPrivacyEnabled ( ) const

Indicates whether privacy settings are enabled for this modification.

Returns:
true if this modification has privacy enabled. Note: Not part of the Unimod schema file.
bool isPrivate ( ) const

Indicates whether this modification is private and so cannot be viewed or used. Only valid if privacy is enabled.

Returns:
true if this modification is private and so cannot be viewed or used. Only valid if privacy is enabled. Note: Not part of the Unimod schema file.
bool isSameAs ( const ms_umod_modification & right_mod ) const

Returns true if instances contain the same information.

Compares all data members except modified date, posted date and user.

Parameters:
right_mod another instance of this class to compare.
Returns:
true if objects contain same information.
ms_umod_modification & operator= ( const ms_umod_modification & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setApproved ( const bool value )

Set a custom value for the approved attribute.

Parameters:
value a new value for the attribute.
void setDateTimeModified ( const char * value )

Set a custom value for the date_time_modified attribute.

Parameters:
value a new value for the attribute.
void setDateTimePosted ( const char * value )

Set a custom value for the date_time_posted attribute.

Parameters:
value a new value for the attribute.
void setDelta ( const ms_umod_composition * delta )

Supply new content for the delta element.

Parameters:
delta new content for the 'delta' object. If a NULL pointer is supplied instead of an object, the current content will be deleted and the 'delta' element will be dropped.
void setFullName ( const char * value )

Set a custom value for the full_name attribute.

Parameters:
value a new value for the attribute.
void setGroupOfPoster ( const char * value )

Set a custom value for the group_of_poster attribute.

Parameters:
value a new value for the attribute.
void setMiscNotes ( const char * value )

Set a custom value for the misc_notes element.

Parameters:
value a new value for the element.
void setPrivacyEnabled ( bool b )

Sets whether privacy settings are enabled for this modification.

Parameters:
b sets if this modification has privacy enabled.
void setPrivate ( bool b )

Sets whether this modification is private.

Parameters:
b sets if this modification is private.
void setRecordID ( const char * value )

Set a custom value for the record_id attribute.

Parameters:
value a new value for the attribute.
void setTitle ( const char * value )

Set a custom value for the title attribute.

Parameters:
value a new value for the attribute.
void setUsernameOfPoster ( const char * value )

Set a custom value for the username_of_poster attribute.

Parameters:
value a new value for the attribute.
bool updateAltName | ( | const int | idx,
 |  | const char * | alt_name
 | ) |  |

Update the string for a particular alt_name element.

Parameters:
idx | number of the alt_name element for updating from 0 to (getNumberOfAltNames() - 1).
alt_name | an object to copy the content from.
Returns:
TRUE if the element has been found and successfully updated and FALSE otherwise.
bool updateIgnore | ( | const int | idx,
 |  | const ms_umod_composition * | ignore
 | ) |  |

Update the information for a particular Ignore element.

Parameters:
idx | number of the Ignore element for updating from 0 to (getNumberOfIgnores() - 1).
ignore | an object to copy the content from.
Returns:
TRUE if the object has been found and successfully updated and FALSE otherwise.
void updateMasses | ( | const ms_umod_configfile & | umodFile,
 |  | const ms_quant_component & | quantComp
 | ) |  |

Recalculates all deltas with isotope-substitution according to selected component in quantification.xml.

The method updates all deltas, neutral losses and ignore masses according to the selected isotope substitution. Masses are recalculated only in the current modification object, not in the whole Unimod file object umodFile. The Unimod file object is used only to retrieve masses of elements and their isotopes.

Parameters:
umodFile | a Unimod file object.
quantComp | a component object from the quantitation.xml file.
bool updateSpecificity | ( | const int | idx,
 |  | const ms_umod_specificity * | specificity
 | ) |  |

Update the information for a particular specificity.

Parameters:
idx | number of the specificity for updating from 0 to (getNumberOfSpecificities() - 1).
specificity | an object to copy the content from.
Returns:
TRUE if the specificity has been found and successfully updated and FALSE otherwise.
bool updateXref | ( | const int | idx,
 |  | const ms_umod_xref * | xref
 | ) |  |

Update the information for a particular xref element.

Parameters:
idx | number of the xref element for updating from 0 to (getNumberOfXrefs() - 1)
xref | an object to copy the content from.
Returns:
TRUE if the object has been found and successfully updated and FALSE otherwise.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_modification.hpp
  • ms_umod_modification.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_neutralloss
Public Member Functions

ms_umod_neutralloss Class Reference
[Mascot configuration files module]

Represents NeutralLoss and PepNeutralLoss objects in unimod.xml. More...

#include <ms_umod_neutralloss.hpp>

Inheritance diagram for ms_umod_neutralloss:
[legend]
Collaboration diagram for ms_umod_neutralloss:
[legend]

List of all members.

Public Member Functions

ms_umod_neutralloss ()
Default constructor.
ms_umod_neutralloss (const ms_umod_neutralloss &src)
Copying constructor.
ms_umod_neutralloss (const ms_quant_pepneutralloss &src, const ms_umod_configfile &umodFile)
Copying constructor.
ms_umod_neutralloss (const ms_quant_neutralloss &src, const ms_umod_configfile &umodFile)
Copying constructor.
virtual | ~ms_umod_neutralloss ()
Destructor.
void | appendElemRef (const ms_umod_elemref *elemref)
Adds a new element reference object at the end of the list.
void | clearElemRefs ()
Deletes all element reference objects from the list.
void | copyFrom (const ms_quant_neutralloss *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_umod_composition *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_composition *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_quant_pepneutralloss *right, const ms_umod_configfile &umodFile)
Copies all content from another object.
void | copyFrom (const ms_umod_neutralloss *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteElemRef (const int idx)
Remove an element reference object from the list in memory.
void | dropAvgeMass ()
Delete the avge_mass attribute.
void | dropCode ()
Delete the code attribute.
void | dropCompositionString ()
Delete the composition attribute.
void | dropDescription ()
Delete the description attribute.
void | dropFlag ()
Delete the flag attribute.
void | dropMonoMass ()
Delete the mono_mass attribute.
void | dropPairsWith ()
Delete the pairs_with attribute.
double | getAvgeMass () const
Returns the value of the avge_mass attribute.
std::string | getAvgeMassSchemaType () const
Obtain a symbolic name for the avge_mass attribute schema type.
std::string | getCode () const
Returns the value of the code attribute.
std::string | getCodeSchemaType () const
Obtain a symbolic name for the code attribute schema type.
std::string | getCompositionString () const
Returns the value of the composition attribute.
std::string | getCompositionStringSchemaType () const
Obtain a symbolic name for the composition attribute schema type.
std::string | getDescription () const
Returns the value of the description attribute.
std::string | getDescriptionSchemaType () const
Obtain a symbolic name for the description attribute schema type.
const ms_umod_elemref * | getElemRef (const int idx) const
Returns a read-only pointer to an element reference object by its number.
std::string | getElemRefSchemaType () const
Obtain a symbolic name for the element's schema type.
std::string | getFlagSchemaType () const
Obtain a symbolic name for the flag attribute schema type.
double | getMonoMass () const
Returns the value of the mono_mass attribute.
std::string | getMonoMassSchemaType () const
Obtain a symbolic name for the mono_mass attribute schema type.
int | getNumberOfElemRefs () const
Returns the number of element reference objects currently held in memory.
std::string | getPairsWith () const
Returns the value of the pairs_with attribute.
std::string | getPairsWithSchemaType () const
Obtain a symbolic name for the pairs_with attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
bool | haveAvgeMass () const
Indicates presence of the avge_mass attribute.
bool | haveCode () const
Indicates presence of the code attribute.
bool | haveCompositionString () const
Indicates presence of the composition attribute.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveFlag () const
Indicates presence of the flag attribute.
bool | haveMonoMass () const
Indicates presence of the mono_mass attribute.
bool | havePairsWith () const
Indicates presence of the pairs_with attribute.
bool | isFlag () const
Returns the value of the flag attribute.
bool | isSameAs (const ms_umod_composition &right) const
Returns true if instances contain the same information.
ms_umod_neutralloss & | operator= (const ms_umod_neutralloss &right)
C++ style assignment operator.
void | setAvgeMass (const double value)
Set a custom value for the avge_mass attribute.
void | setCode (const char *value)
Set a custom value for the code attribute.
void | setCompositionString (const char *value)
Set a custom value for the composition attribute.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setFlag (const bool value)
Set a custom value for the flag attribute.
void | setMonoMass (const double value)
Set a custom value for the mono_mass attribute.
void | setPairsWith (const char *value)
Set a custom value for the pairs_with attribute.
bool | updateElemRef (const int idx, const ms_umod_elemref *elemref)
Update the information for a particular element reference object.
void | updateMasses (const ms_umod_configfile &umodFile, const ms_quant_component &quantComp)
Recalculates all deltas with isotope substitution according to selected component in quantification.xml.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents NeutralLoss and PepNeutralLoss objects in unimod.xml.

The only difference between a composition object and this object is the attribute 'flag' (which can be the required attribute for the PepNeutralLoss element).

Constructor & Destructor Documentation

ms_umod_neutralloss ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_neutralloss ( const ms_umod_neutralloss & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.
ms_umod_neutralloss | ( | const ms_quant_neutralloss & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor.

Parameters:
src | another object to copy the content from.
umodFile | a Unimod file object to extract element masses from.
ms_umod_neutralloss | ( | const ms_quant_pepneutralloss & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor.

Parameters:
src | another object to copy the content from.
umodFile | a Unimod file object to extract element masses from.

Member Function Documentation

void appendElemRef ( const ms_umod_elemref * elemref ) [inherited]

Adds a new element reference object at the end of the list.

Creates a new element reference object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
elemref an instance of element reference object to copy the content from.
void copyFrom ( const ms_umod_neutralloss * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom | ( | const ms_quant_pepneutralloss * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from another object.

Parameters:
right | another object to copy the content from.
umodFile | a Unimod file object to obtain chemical element masses from.
void copyFrom | ( | const ms_quant_neutralloss * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from another object.

Parameters:
right | another object to copy the content from.
umodFile | a Unimod file object to obtain chemical element masses from.
void copyFrom ( const ms_umod_composition * right ) [inherited]

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom | ( | const ms_quant_composition * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  | [inherited]

Copies all content from another object.

Parameters:
right | another object to copy the content from.
umodFile | a Unimod file object to obtain element masses from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented from ms_umod_composition.

bool deleteElemRef ( const int idx ) [inherited]

Remove an element reference object from the list in memory.

Parameters:
idx number of the element reference for deletion from 0 to (getNumberOfElemRefs() - 1).
Returns:
TRUE if the object has been found and successfully deleted and FALSE otherwise.
void dropAvgeMass ( ) [inherited]

Delete the avge_mass attribute.

Deletes the attribute until is re-set.

void dropCode ( )

Delete the code attribute.

Deletes the attribute until it is re-set.

void dropCompositionString ( ) [inherited]

Delete the composition attribute.

Deletes the attribute until it is re-set.

void dropDescription ( )

Delete the description attribute.

Deletes the attribute until it is re-set.

void dropFlag ( )

Delete the flag attribute.

Deletes the attribute until it is re-set.

void dropMonoMass ( ) [inherited]

Delete the mono_mass attribute.

Deletes the attribute until is re-set.

void dropPairsWith ( )

Delete the pairs_with attribute.

Deletes the attribute until it is re-set.

double getAvgeMass ( ) const [inherited]

Returns the value of the avge_mass attribute.

Average mass for the object.

Returns:
current value of the attribute.
std::string getAvgeMassSchemaType ( ) const [inherited]

Obtain a symbolic name for the avge_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getCode ( ) const

Returns the value of the code attribute.

The single-letter code for the fragment of the monolink.

Returns:
current value of the attribute.
std::string getCodeSchemaType ( ) const

Obtain a symbolic name for the code attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getCompositionString ( ) const [inherited]

Returns the value of the composition attribute.

A composition string for the object.

Returns:
current value of the attribute.
std::string getCompositionStringSchemaType ( ) const [inherited]

Obtain a symbolic name for the composition attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getDescription ( ) const

Returns the value of the description attribute.

The partner codes for the monolink.

Returns:
current value of the attribute.
std::string getDescriptionSchemaType ( ) const

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_elemref * getElemRef ( const int idx ) const [inherited]

Returns a read-only pointer to an element reference object by its number.

Retrieves an element reference object from the list by its number.

Parameters:
idx number of the reference from 0 to (getNumberOfElemRefs() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getElemRefSchemaType ( ) const [inherited]

Obtain a symbolic name for the element's schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getFlagSchemaType ( ) const

Obtain a symbolic name for the flag attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
double getMonoMass ( ) const [inherited]

Returns the value of the mono_mass attribute.

Monoisotopic mass for the object.

Returns:
current value of the attribute.
std::string getMonoMassSchemaType ( ) const [inherited]

Obtain a symbolic name for the mono_mass attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfElemRefs ( ) const [inherited]

Returns the number of element reference objects currently held in memory.

Returns:
total number of chemical element references in the composition object.
std::string getPairsWith ( ) const

Returns the value of the pairs_with attribute.

The partner codes for the monolink.

Returns:
current value of the attribute.
std::string getPairsWithSchemaType ( ) const

Obtain a symbolic name for the pairs_with attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")

Reimplemented from ms_umod_composition.

bool haveAvgeMass ( ) const [inherited]

Indicates presence of the avge_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveCode ( ) const

Indicates presence of the code attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveCompositionString ( ) const [inherited]

Indicates presence of the composition attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveDescription ( ) const

Indicates presence of the description attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveFlag ( ) const

Indicates presence of the flag attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMonoMass ( ) const [inherited]

Indicates presence of the mono_mass attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool havePairsWith ( ) const

Indicates presence of the pairs_with attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool isFlag ( ) const

Returns the value of the flag attribute.

Returns:
current value of the attribute.
bool isSameAs ( const ms_umod_composition & right ) const [inherited]

Returns true if instances contain the same information.

Compares the element symbols and number of symbols that make up the composition regardless of storage order. Element symbols may be specified in the composition but have a count of zero and so do not affect the total mass values.

Parameters:
right another instance of this class to compare.
Returns:
true if the two compositions are equivalent.
ms_umod_neutralloss & operator= ( const ms_umod_neutralloss & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setAvgeMass ( const double value ) [inherited]

Set a custom value for the avge_mass attribute.

Parameters:
value a new value for the attribute.
void setCode ( const char * value )

Set a custom value for the code attribute.

Parameters:
value a new value for the attribute.
void setCompositionString ( const char * value ) [inherited]

Set a custom value for the composition attribute.

Parameters:
value a new value for the attribute.
void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters:
value a new value for the attribute.
void setFlag ( const bool value )

Set a custom value for the flag attribute.

Parameters:
value a new value for the attribute.
void setMonoMass ( const double value ) [inherited]

Set a custom value for the mono_mass attribute.

Parameters:
value a new value for the attribute.
void setPairsWith ( const char * value )

Set a custom value for the pairs_with attribute.

Parameters:
value a new value for the attribute.
bool updateElemRef | ( | const int | idx,
 |  | const ms_umod_elemref * | elemref
 | ) |  | [inherited]

Update the information for a particular element reference object.

Parameters:
idx | number of the element reference for updating from 0 to (getNumberOfElemRefs() - 1).
elemref | an object to copy the content from.
Returns:
TRUE if the element reference has been found and successfully updated and FALSE otherwise.
void updateMasses | ( | const ms_umod_configfile & | umodFile,
 |  | const ms_quant_component & | quantComp
 | ) |  | [inherited]

Recalculates all deltas with isotope substitution according to selected component in quantification.xml.

The method updates masses according to the selected isotope substitution. Masses are recalculated only in the current modification object, not in the whole Unimod file object umodFile. The Unimod file object is used only to retrieve masses of elements and their isotopes.

Parameters:
umodFile | Unimod file object.
quantComp | component object from quantitation.xml.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_umod_composition.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented from ms_umod_composition.

The documentation for this class was generated from the following files:
  • ms_umod_neutralloss.hpp
  • ms_umod_neutralloss.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_specificity
Public Member Functions

ms_umod_specificity Class Reference
[Mascot configuration files module]

Represents modification specificity objects in unimod.xml. More...

#include <ms_umod_specificity.hpp>

List of all members.

Public Member Functions

ms_umod_specificity ()
Default constructor.
ms_umod_specificity (const ms_umod_specificity &src)
Copying constructor.
ms_umod_specificity (const ms_quant_specificity &src, const ms_umod_configfile &umodFile)
Copying constructor that takes an object from quantitation.xml.
virtual | ~ms_umod_specificity ()
Destructor.
void | appendNeutralLoss (const ms_umod_neutralloss *nl)
Adds a new 'NeutralLoss' element at the end of the list.
void | appendPepNeutralLoss (const ms_umod_neutralloss *pnl)
Adds a new 'PepNeutralLoss' element at the end of the list.
void | clearNeutralLosses ()
Deletes all 'NeutralLoss' elements from the list.
void | clearPepNeutralLosses ()
Deletes all 'PepNeutralLoss' elements from the list.
void | copyFrom (const ms_umod_specificity *right)
Copies all content from another instance.
void | copyFrom (const ms_quant_specificity *right, const ms_umod_configfile &umodFile)
Copies all content from an object of quantitation.xml.
void | defaultValues ()
Call this member if you want to start again.
bool | deleteNeutralLoss (const int idx)
Remove a 'NeutralLoss' element from the list in memory.
bool | deletePepNeutralLoss (const int idx)
Remove a 'PepNeutralLoss' element object from the list in memory.
void | dropClassification ()
Delete the classification attribute.
void | dropHidden ()
Delete the hidden attribute.
void | dropMiscNotes ()
Delete the misc_notes element.
void | dropPosition ()
Delete the position attribute.
void | dropSite ()
Delete the site attribute.
void | dropSpecGroup ()
Delete the spec_group attribute.
std::string | getClassification () const
Returns the value of the classification attribute.
std::string | getClassificationSchemaType () const
Obtain a symbolic name for the classification attribute schema type.
std::string | getHiddenSchemaType () const
Obtain a symbolic name for the hidden attribute schema type.
std::string | getMiscNotes () const
Returns the value of the misc_notes element.
std::string | getMiscNotesSchemaType () const
Obtain a symbolic name for the misc_notes element schema type.
const ms_umod_neutralloss * | getNeutralLoss (const int idx) const
Returns a read-only pointer to a 'NeutralLoss' element by its number.
std::string | getNeutralLossSchemaType () const
Obtain a symbolic name for the 'NeutralLoss' element schema type.
int | getNumberOfNeutralLosses () const
Returns the number of 'NeutralLoss' elements currently held in memory.
int | getNumberOfPepNeutralLosses () const
Returns the number of 'PepNeutralLoss' elements currently held in memory.
const ms_umod_neutralloss * | getPepNeutralLoss (const int idx) const
Returns a read-only pointer to a 'PepNeutralLoss' element object by its number.
std::string | getPepNeutralLossSchemaType () const
Obtain a symbolic name for the 'NeutralLoss' element schema type.
std::string | getPosition () const
Returns the value of the position attribute.
std::string | getPositionSchemaType () const
Obtain a symbolic name for the position attribute schema type.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSite () const
Returns the value of the site attribute.
std::string | getSiteSchemaType () const
Obtain a symbolic name for the site attribute schema type.
int | getSpecGroup () const
Returns the value of the spec_group attribute.
std::string | getSpecGroupSchemaType () const
Obtain a symbolic name for the spec_group attribute schema type.
bool | haveClassification () const
Indicates presence of the classification attribute.
bool | haveHidden () const
Indicates presence of the hidden attribute.
bool | haveMiscNotes () const
Indicates presence of the misc_notes element.
bool | havePosition () const
Indicates presence of the position attribute.
bool | haveSite () const
Indicates presence of the site attribute.
bool | haveSpecGroup () const
Indicates presence of the spec_group attribute.
bool | inErrorTolerant () const
bool | inLongList () const
Indicates whether this specificity is in the full list on the Mascot search form.
bool | inShortList () const
Indicates whether this specificity is in the short list on the Mascot search form.
bool | isHidden () const
Returns the value of the hidden attribute.
bool | isSameAs (const ms_umod_specificity &right) const
Returns true if instances contain the same information.
ms_umod_specificity & | operator= (const ms_umod_specificity &right)
C++ style assignment operator.
void | setClassification (const char *value)
Set a custom value for the classification attribute.
void | setHidden (const bool value)
Set a custom value for the hidden attribute.
void | setMiscNotes (const char *value)
Set a custom value for the misc_notes element.
void | setPosition (const char *value)
Set a custom value for the position attribute.
void | setSite (const char *value)
Set a custom value for the site attribute.
void | setSpecGroup (const int value)
Set a custom value for the spec_group attribute.
void | showInLongList (bool b)
void | showInShortList (bool b)
bool | updateNeutralLoss (const int idx, const ms_umod_neutralloss *nl)
Update the information for a particular 'NeutralLoss' element.
bool | updatePepNeutralLoss (const int idx, const ms_umod_neutralloss *pnl)
Update the information for a particular 'PepNeutralLoss' element.
void | useInErrorTolerant (bool b)
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents modification specificity objects in unimod.xml.

Constructor & Destructor Documentation

ms_umod_specificity ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_specificity ( const ms_umod_specificity & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.
ms_umod_specificity | ( | const ms_quant_specificity & | src,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copying constructor that takes an object from quantitation.xml.

Parameters:
src | an instance of quantitation.xml class to copy the content from.
umodFile | a Unimod file object to extract element masses from.

Member Function Documentation

void appendNeutralLoss ( const ms_umod_neutralloss * nl )

Adds a new 'NeutralLoss' element at the end of the list.

Creates a new neutral loss object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
nl an instance of neutral loss object to copy the content from.
void appendPepNeutralLoss ( const ms_umod_neutralloss * pnl )

Adds a new 'PepNeutralLoss' element at the end of the list.

Creates a new peptide neutral loss object, copies all content from the object supplied as a parameter and adds it at the end of the list.

Parameters:
pnl an instance of peptide neutral loss object to copy the content from.
void copyFrom ( const ms_umod_specificity * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void copyFrom | ( | const ms_quant_specificity * | right,
 |  | const ms_umod_configfile & | umodFile
 | ) |  |

Copies all content from an object of quantitation.xml.

Parameters:
right | an instance of a quantitation.xml class.
umodFile | a Unimod file object to extract element masses from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

bool deleteNeutralLoss ( const int idx )

Remove a 'NeutralLoss' element from the list in memory.

Parameters:
idx number of the neutral loss for deletion from 0 to (getNumberOfNeutralLosses() - 1).
Returns:
TRUE if the object has been found and successfully deleted and FALSE otherwise.
bool deletePepNeutralLoss ( const int idx )

Remove a 'PepNeutralLoss' element object from the list in memory.

Parameters:
idx number of the peptide neutral loss for deletion from 0 to (getNumberOfPepNeutralLosses() - 1).
Returns:
TRUE if the object has been found and successfully deleted and FALSE otherwise.
void dropClassification ( )

Delete the classification attribute.

Deletes the attribute until is re-set.

void dropHidden ( )

Delete the hidden attribute.

Deletes the attribute until is re-set.

void dropMiscNotes ( )

Delete the misc_notes element.

Deletes the element until it is re-set.

void dropPosition ( )

Delete the position attribute.

Deletes the attribute until is re-set.

void dropSite ( )

Delete the site attribute.

Deletes the attribute until is re-set.

void dropSpecGroup ( )

Delete the spec_group attribute.

Deletes the attribute until is re-set.

std::string getClassification ( ) const

Returns the value of the classification attribute.

Returns:
current value of the attribute.
std::string getClassificationSchemaType ( ) const

Obtain a symbolic name for the classification attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getHiddenSchemaType ( ) const

Obtain a symbolic name for the hidden attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getMiscNotes ( ) const

Returns the value of the misc_notes element.

Returns:
current value of the element.
std::string getMiscNotesSchemaType ( ) const

Obtain a symbolic name for the misc_notes element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
const ms_umod_neutralloss * getNeutralLoss ( const int idx ) const

Returns a read-only pointer to a 'NeutralLoss' element by its number.

Parameters:
idx number of the neutral loss from 0 to (getNumberOfNeutralLosses() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getNeutralLossSchemaType ( ) const

Obtain a symbolic name for the 'NeutralLoss' element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getNumberOfNeutralLosses ( ) const

Returns the number of 'NeutralLoss' elements currently held in memory.

Returns:
total number of neutral losses in the specificity.
int getNumberOfPepNeutralLosses ( ) const

Returns the number of 'PepNeutralLoss' elements currently held in memory.

Returns:
total number of peptide neutral losses in the specificity.
const ms_umod_neutralloss * getPepNeutralLoss ( const int idx ) const

Returns a read-only pointer to a 'PepNeutralLoss' element object by its number.

Parameters:
idx number of the peptide neutral loss from 0 to (getNumberOfPepNeutralLosses() - 1).
Returns:
a read-only pointer to the retrieved object. See Maintaining object references: two rules of thumb.
std::string getPepNeutralLossSchemaType ( ) const

Obtain a symbolic name for the 'NeutralLoss' element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getPosition ( ) const

Returns the value of the position attribute.

Returns:
Position of the specificity that should be one of the Type mqm:positionType values.
std::string getPositionSchemaType ( ) const

Obtain a symbolic name for the position attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
std::string getSite ( ) const

Returns the value of the site attribute.

Returns:
Site string that should be one of the Type mqm:siteType values.
std::string getSiteSchemaType ( ) const

Obtain a symbolic name for the site attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
int getSpecGroup ( ) const

Returns the value of the spec_group attribute.

Returns:
current value of the attribute.
std::string getSpecGroupSchemaType ( ) const

Obtain a symbolic name for the spec_group attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveClassification ( ) const

Indicates presence of the classification attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveHidden ( ) const

Indicates presence of the hidden attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveMiscNotes ( ) const

Indicates presence of the misc_notes element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool havePosition ( ) const

Indicates presence of the position attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveSite ( ) const

Indicates presence of the site attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveSpecGroup ( ) const

Indicates presence of the spec_group attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool inErrorTolerant ( ) const
Returns:
true if this specificity is included in error tolerant searches in mascot.
bool inLongList ( ) const

Indicates whether this specificity is in the full list on the Mascot search form.

Returns:
true if this specificity is required in the mascot search form full list.
bool inShortList ( ) const

Indicates whether this specificity is in the short list on the Mascot search form.

Returns:
true if this specificity is required in the mascot search form short list.
bool isHidden ( ) const

Returns the value of the hidden attribute.

Returns:
current value of the attribute.
bool isSameAs ( const ms_umod_specificity & right ) const

Returns true if instances contain the same information.

Parameters:
right another instance of this class to compare.
Returns:
true if the specificities are equivalent.
ms_umod_specificity & operator= ( const ms_umod_specificity & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setClassification ( const char * value )

Set a custom value for the classification attribute.

Parameters:
value a new value for the attribute.
void setHidden ( const bool value )

Set a custom value for the hidden attribute.

Parameters:
value a new value for the attribute.
void setMiscNotes ( const char * value )

Set a custom value for the misc_notes element.

Parameters:
value a new value for the element.
void setPosition ( const char * value )

Set a custom value for the position attribute.

Parameters:
value Position of the specificity that should be one of the Type mqm:positionType values.
void setSite ( const char * value )

Set a custom value for the site attribute.

Parameters:
value that should be one of the Type mqm:siteType values.
void setSpecGroup ( const int value )

Set a custom value for the spec_group attribute.

Parameters:
value a new value for the attribute.
void showInLongList ( bool b )
Parameters:
b sets if this specificity is required in the mascot search form full list.
void showInShortList ( bool b )
Parameters:
b sets if this specificity is required in the mascot search form short list.
bool updateNeutralLoss | ( | const int | idx,
 |  | const ms_umod_neutralloss * | nl
 | ) |  |

Update the information for a particular 'NeutralLoss' element.

Parameters:
idx | number of the neutral loss object for updating from 0 to (getNumberOfNeutralLosses() - 1).
nl | an object to copy the content from.
Returns:
TRUE if the neutral loss has been found and successfully updated and FALSE otherwise.
bool updatePepNeutralLoss | ( | const int | idx,
 |  | const ms_umod_neutralloss * | pnl
 | ) |  |

Update the information for a particular 'PepNeutralLoss' element.

Parameters:
idx | number of the peptide neutral loss object for updating from 0 to (getNumberOfPepNeutralLosses() - 1).
pnl | an object to copy the content from.
Returns:
TRUE if the peptide neutral loss has been found and successfully updated and FALSE otherwise.
void useInErrorTolerant ( bool b )
Parameters:
b sets if this specificity is required in error tolerant searches.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_specificity.hpp
  • ms_umod_specificity.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_umod_xref
Public Member Functions

ms_umod_xref Class Reference
[Mascot configuration files module]

Represents the cross references objects in unimod.xml. More...

#include <ms_umod_xref.hpp>

List of all members.

Public Member Functions

ms_umod_xref ()
Default constructor.
ms_umod_xref (const ms_umod_xref &src)
Copying constructor.
virtual | ~ms_umod_xref ()
Destructor.
void | copyFrom (const ms_umod_xref *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropSource ()
Delete the source element.
void | dropText ()
Delete the text element.
void | dropUrl ()
Delete the url element.
virtual std::string | getSchemaType () const
Returns name of the schema type that can be used to validate this element.
std::string | getSource () const
Returns the value of the source element.
std::string | getSourceSchemaType () const
Obtain a symbolic name for the source element schema type.
std::string | getText () const
Returns the value of the text element.
std::string | getTextSchemaType () const
Obtain a symbolic name for the text element schema type.
std::string | getUrl () const
Returns the value of the url element.
std::string | getUrlSchemaType () const
Obtain a symbolic name for the url element schema type.
bool | haveSource () const
Indicates presence of the source element.
bool | haveText () const
Indicates presence of the text element.
bool | haveUrl () const
Indicates presence of the url element.
bool | isSameAs (const ms_umod_xref &right) const
Returns true if instances contain the same information.
ms_umod_xref & | operator= (const ms_umod_xref &right)
C++ style assignment operator.
void | setSource (const char *value)
Set a custom value for the source element.
void | setText (const char *value)
Set a custom value for the text element.
void | setUrl (const char *value)
Set a custom value for the url element.
virtual std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
virtual std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Represents the cross references objects in unimod.xml.

Constructor & Destructor Documentation

ms_umod_xref ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_umod_xref ( const ms_umod_xref & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_umod_xref * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

void dropSource ( )

Delete the source element.

Deletes the element until it is re-set.

void dropText ( )

Delete the text element.

Deletes the element until it is re-set.

void dropUrl ( )

Delete the url element.

Deletes the element until it is re-set.

std::string getSchemaType ( ) const [virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "umod:nameType")
std::string getSource ( ) const

Returns the value of the source element.

Returns:
current value of the element.
std::string getSourceSchemaType ( ) const

Obtain a symbolic name for the source element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getText ( ) const

Returns the value of the text element.

Returns:
current value of the element.
std::string getTextSchemaType ( ) const

Obtain a symbolic name for the text element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
std::string getUrl ( ) const

Returns the value of the url element.

Returns:
current value of the element.
std::string getUrlSchemaType ( ) const

Obtain a symbolic name for the url element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.
bool haveSource ( ) const

Indicates presence of the source element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveText ( ) const

Indicates presence of the text element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool haveUrl ( ) const

Indicates presence of the url element.

Returns:
TRUE if the element is present and FALSE otherwise.
bool isSameAs ( const ms_umod_xref & right ) const

Returns true if instances contain the same information.

Ignores carriage return characters when comparing the text.

Parameters:
right another instance of this class to compare.
Returns:
true if the two instances are equivalent.
ms_umod_xref & operator= ( const ms_umod_xref & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setSource ( const char * value )

Set a custom value for the source element.

Parameters:
value a new value for the element.
void setText ( const char * value )

Set a custom value for the text element.

Parameters:
value a new value for the element.
void setUrl ( const char * value )

Set a custom value for the url element.

Parameters:
value a new value for the element.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const [virtual]

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_umod_xref.hpp
  • ms_umod_xref.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_unigeneoptions
Public Member Functions

ms_unigeneoptions Class Reference
[Mascot configuration files module]

An instance of this class represents all the parameters specified in UniGene section of mascot.dat. More...

#include <ms_unigeneoptions.hpp>

Inheritance diagram for ms_unigeneoptions:
[legend]
Collaboration diagram for ms_unigeneoptions:
[legend]

List of all members.

Public Member Functions

ms_unigeneoptions ()
Default constructor.
ms_unigeneoptions (const ms_unigeneoptions &src)
Copying constructor.
virtual | ~ms_unigeneoptions ()
Destructor.
void | copyFrom (const ms_unigeneoptions *right)
Can be used to create a copy of another object.
virtual void | defaultValues ()
Initialises the instance with default values.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
bool | isSectionAvailable () const
Indicates whether the section has been actually read from the file.
ms_unigeneoptions & | operator= (const ms_unigeneoptions &right)
C++ style assignment operator.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. should it be saved in a file.

Detailed Description

An instance of this class represents all the parameters specified in UniGene section of mascot.dat.

An instance of this class is created and populated in ms_datfile and is available by calling ms_datfile::getUniGeneOptions(). It can also be created separately and initialised with default values. You can create an instance of the class or copy from another instance in order to pass it then as an options-containing object.

For detailed information on any of the options please consult Mascot manual.

Currently, access to the values is only provided through the ms_customproperty class, from which this class is derived. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Constructor & Destructor Documentation

ms_unigeneoptions ( )

Default constructor.

Note:
Not normally called from outside Mascot Parser.
ms_unigeneoptions ( const ms_unigeneoptions & src )

Copying constructor.

Note:
Not normally called from outside Mascot Parser.
Parameters:
src unigene options object
~ms_unigeneoptions ( ) [virtual]

Destructor.

Note:
Not normally called from outside Mascot Parser.

Member Function Documentation

void copyFrom ( const ms_unigeneoptions * right )

Can be used to create a copy of another object.

Note:
Not normally called from outside Mascot Parser.
Parameters:
right is the source to be copied.
void defaultValues ( ) [virtual]

Initialises the instance with default values.

Note:
Not normally called from outside Mascot Parser.

Reimplemented from ms_customproperty.

std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
bool isSectionAvailable ( ) const

Indicates whether the section has been actually read from the file.

By default the UniGene section is unavailable until it has been set to a different state.

Returns:
true if the section is available.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setSectionAvailable ( const bool value )

Changes availability of the section, i.e. should it be saved in a file.

Parameters:
value should be true to make the section available.
The documentation for this class was generated from the following files:
  • ms_unigeneoptions.hpp
  • ms_unigeneoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_wwwentry
Public Member Functions

ms_wwwentry Class Reference
[Mascot configuration files module]

Represent a single entry in the WWW section of mascot.dat. More...

#include <ms_wwwoptions.hpp>

List of all members.

Public Member Functions

ms_wwwentry ()
Default constructor.
ms_wwwentry (const ms_wwwentry &src)
Copying constructor.
~ms_wwwentry ()
Destructor.
void | copyFrom (const ms_wwwentry *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
std::string | getHostName () const
Returns a host name used to retrieve reports from.
std::string | getName () const
Returns the name of the database the entry refers to.
int | getParseRule () const
Returns a parse rule number for the entry that corresponds to one of the parse rules specified in the PARSE section of mascot.dat.
std::string | getPath () const
Returns a path to the executable and parameters.
int | getPortNumber () const
Returns a port number for the host used as the information source.
WWW_TYPE | getType () const
Returns the name of the database the entry refers to.
ms_wwwentry & | operator= (const ms_wwwentry &right)
Assignment operator for C++ client applications.
void | setHostName (const char *value)
Change the host name parameter.
void | setName (const char *value)
Set the database name for the entry.
void | setParseRule (const int value)
Change the parse rule number for the entry.
void | setPath (const char *value)
Change the path.
void | setPortNumber (const int value)
Change the port number.
void | setType (const WWW_TYPE value)
Change the entry type.

Detailed Description

Represent a single entry in the WWW section of mascot.dat.

Instances of this class can be stored in in ms_wwwoptions to represent the whole section. Consult the Mascot manual if you are unsure how to configure an entry. It defines an information source where CGI scripts look for the information needed to compile a results report.

Member Function Documentation

std::string getHostName ( ) const

Returns a host name used to retrieve reports from.

For ms-getseq.exe or a similar local executable, this attribute should contain localhost. The word localhost is used to determine whether the application is a command line executable or a CGI application. If you want to specify a CGI application on the local server, just specify the hostname in some other way, for example 127.0.0.1).

For a remote source, or a local source that will be queried as a CGI application, this should be the hostname.

Default is localhost.

See also:
getPortNumber()
Returns:
host name
std::string getName ( ) const

Returns the name of the database the entry refers to.

Note that database name is case sensitive.

The name should be one of those specified in the Databases section. Every name can be associated with more than one entry in the WWW section as different entry types are supported. In order to retrieve the entry type use getType().

By default this is an empty string.

Returns:
name
Examples:
config_mascotdat.cpp.
int getParseRule ( ) const

Returns a parse rule number for the entry that corresponds to one of the parse rules specified in the PARSE section of mascot.dat.

The index of a rule in the PARSE section that can be used to extract the information required.

Default is -1, which is an invalid rule number.

Returns:
parse rule number
std::string getPath ( ) const

Returns a path to the executable and parameters.

A string containing the path to the executable and parameters, some of which are variables.

By default this is empty.

Returns:
path
int getPortNumber ( ) const

Returns a port number for the host used as the information source.

In most cases it should be left as 80, which is the default value.

See also:
getHostName()
Returns:
port number
WWW_TYPE getType ( ) const

Returns the name of the database the entry refers to.

Several entry types are supported. For the complete list of types, see the enumeration values in WWW_TYPE.

There is no default value for this parameter.

Returns:
type
Examples:
config_mascotdat.cpp.
void setHostName ( const char * value )

Change the host name parameter.

See getHostName() for more information.

Parameters:
value new host name
void setName ( const char * value )

Set the database name for the entry.

See getName() for more information.

Parameters:
value new name
void setParseRule ( const int value )

Change the parse rule number for the entry.

See getParseRule() for more information.

Parameters:
value new parse rule number
void setPath ( const char * value )

Change the path.

See getPath() for more information.

Parameters:
value path
void setPortNumber ( const int value )

Change the port number.

See getPortNumber() for more information.

Parameters:
value new port number
void setType ( const WWW_TYPE value )

Change the entry type.

See getType() for more information.

Parameters:
value new type
The documentation for this class was generated from the following files:
  • ms_wwwoptions.hpp
  • ms_wwwoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_wwwoptions
Public Member Functions

ms_wwwoptions Class Reference
[Mascot configuration files module]

Represents the whole WWW section. More...

#include <ms_wwwoptions.hpp>

Inheritance diagram for ms_wwwoptions:
[legend]
Collaboration diagram for ms_wwwoptions:
[legend]

List of all members.

Public Member Functions

ms_wwwoptions ()
Default constructor.
ms_wwwoptions (const ms_wwwoptions &src)
Copying constructor.
~ms_wwwoptions ()
Destructor.
void | appendEntry (const ms_wwwentry *item)
Append a new entry which is a copy of the only parameter.
void | clearEntries ()
Deletes all entries from the list.
void | copyFrom (const ms_wwwoptions *right)
Can be used to create a copy of another object.
void | defaultValues ()
Initialises the instance with default values.
void | dropEntry (const int index)
Make the entry at the given index unavailable.
const ms_wwwentry * | getEntry (const int index) const
Returns an entry by its index.
int | getNumberOfEntries () const
Returns the total number of entries in the section.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
const ms_wwwentry * | getRepEntryByName (const char *dbName) const
Searches the entries list for the given name and type of REP.
const ms_wwwentry * | getSeqEntryByName (const char *dbName) const
Searches the entries list for the given name and type of SEQ.
bool | isSectionAvailable () const
Check whether the section has been actually read from the file.
ms_wwwoptions & | operator= (const ms_wwwoptions &right)
Assignment operator for C++ client applications.
void | setEntry (const int index, const ms_wwwentry *item)
Update the entry at the given index.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setSectionAvailable (const bool value)
Changes availability of the section, i.e. whether it should be saved in a file.

Detailed Description

Represents the whole WWW section.

The WWW section defines where CGI scripts look for the information needed to compile a results report. At least one entry is required for each database, to define the source from which the sequence string of a database entry can be obtained. A second line can optionally define the source from which the full text report of an entry can be obtained. The syntax is very similar in both cases, independent of whether the information originates locally or on a remote system.

An instance of this class holds a list of entries (see ms_wwwentry) that can be obtained and dealt with individually. By default the list is empty.

For detailed information on any of the options please consult the Mascot manual.

Also get yourselves acquainted with the base class ms_customproperty. It facilitates the following tasks:

  • Retrieving an unsupported property.
  • Retrieving a raw/text/XML property representation.
  • Checking for existence of a certain property rather than dealing with its default value.
  • Accessing commented lines in a section.

More functionality is described in the documentation for ms_customproperty.

Examples:

config_mascotdat.cpp.

Member Function Documentation

void dropEntry ( const int index )

Make the entry at the given index unavailable.

This is achieved by deleting the corresponding line from the mascot.dat file. This does not affect the indices of other entries in this instance of the object. In other words, dropping an entry will reset the value at that index to a default, and the gap is plugged the next time the file is loaded.

Parameters:
index The index of the entry to delete, between 0 and getNumberOfEntries()-1.
const ms_wwwentry * getEntry ( const int index ) const

Returns an entry by its index.

See getNumberOfEntries() for more information.

Parameters:
index The entry to return, between 0 and getNumberOfEntries()-1.
Returns:
pointer to an entry
Examples:
config_mascotdat.cpp.
int getNumberOfEntries ( ) const

Returns the total number of entries in the section.

Note that there might be several entries associated with each database. Therefore, total number of entries differs with the number of databases in Databases section.

The entries are not ordered and are represented as is. Use specific functions such as getSeqEntryByName() and getRepEntryByName() to retrieve the entry by name, or getEntry() by the entry index.

Returns:
number of entries
Examples:
config_mascotdat.cpp.
std::string getPreceedingComments ( ) const [inherited]

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
const ms_wwwentry * getRepEntryByName ( const char * dbName ) const

Searches the entries list for the given name and type of REP.

If an entry is not found, a null value is returned. Note that database names are case sensitive.

Parameters:
dbName name to get entry from
Returns:
pointer to an entry whose name is in parameter
const ms_wwwentry * getSeqEntryByName ( const char * dbName ) const

Searches the entries list for the given name and type of SEQ.

If an entry is not found, a null value is returned. Note that database names are case sensitive.

Parameters:
dbName name to get entry from
Returns:
pointer to an entry whose name is in parameter
bool isSectionAvailable ( ) const

Check whether the section has been actually read from the file.

By default the WWW section is unavailable until it has been set to a different state.

Returns:
true if the section has been set to available, false otherwise
Examples:
config_mascotdat.cpp.
void setEntry | ( | const int | index,
 |  | const ms_wwwentry * | item
 | ) |  |

Update the entry at the given index.

Parameters:
index | The index of the entry to update, between 0 and getNumberOfEntries()-1.
item | The data to update with. Member fields of item will copied to the underlying object.
void setPreceedingComments ( const std::string & comments ) [inherited]

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
The documentation for this class was generated from the following files:
  • ms_wwwoptions.hpp
  • ms_wwwoptions.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_xml_parameter
Public Member Functions

ms_xml_parameter Class Reference
[Mascot configuration files module]

Parameter name and value pair. More...

#include <ms_xml_parameters.hpp>

Inheritance diagram for ms_xml_parameter:
[legend]

List of all members.

Public Member Functions

ms_xml_parameter ()
Default constructor.
ms_xml_parameter (const ms_xml_parameter &src)
Copying constructor.
virtual | ~ms_xml_parameter ()
Destructor.
void | copyFrom (const ms_xml_parameter *right)
Copies all content from another instance.
void | defaultValues ()
Call this member if you want to start again.
void | dropDescription ()
Delete the description attribute.
void | dropName ()
Delete the name attribute.
std::string | getDescription () const
Returns the value of the description attribute.
virtual std::string | getDescriptionSchemaType () const =0
Obtain a symbolic name for the description attribute schema type.
std::string | getName () const
Returns the value of the name attribute.
virtual std::string | getNameSchemaType () const =0
Obtain a symbolic name for the name attribute schema type.
virtual std::string | getSchemaType () const =0
Returns name of the schema type that can be used to validate this element.
std::string | getValue () const
Returns the value of the value attribute.
virtual std::string | getValueSchemaType () const =0
Obtain a symbolic name for the value attribute schema type.
bool | haveDescription () const
Indicates presence of the description attribute.
bool | haveName () const
Indicates presence of the name attribute.
ms_xml_parameter & | operator= (const ms_xml_parameter &right)
C++ style assignment operator.
void | setDescription (const char *value)
Set a custom value for the description attribute.
void | setName (const char *value)
Set a custom value for the name attribute.
void | setValue (const char *value)
Set a custom value for the value attribute.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

Parameter name and value pair.

The Mascot configuration files quantitation.xml and crosslinking.xml use a common node structure for a set of key-value pairs. ms_xml_parameter is a base class for a single parameter element.

Constructor & Destructor Documentation

ms_xml_parameter ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_xml_parameter ( const ms_xml_parameter & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void copyFrom ( const ms_xml_parameter * right )

Copies all content from another instance.

Parameters:
right another instance of this class to copy the content from.
void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented in ms_crosslinking_parameter.

void dropDescription ( )

Delete the description attribute.

Deletes the attribute until is re-set.

void dropName ( )

Delete the name attribute.

Deletes the attribute until is re-set.

std::string getDescription ( ) const

Returns the value of the description attribute.

Returns:
a free text description of this parameter.
std::string getDescriptionSchemaType ( ) const [pure virtual]

Obtain a symbolic name for the description attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

std::string getName ( ) const

Returns the value of the name attribute.

Returns:
a descriptive name that will appear in drop down lists, etc.
std::string getNameSchemaType ( ) const [pure virtual]

Obtain a symbolic name for the name attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

std::string getSchemaType ( ) const [pure virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

std::string getValue ( ) const

Returns the value of the value attribute.

Returns:
a string value of this parameter.
std::string getValueSchemaType ( ) const [pure virtual]

Obtain a symbolic name for the value attribute schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implemented in ms_crosslinking_parameter, and ms_quant_parameter.

bool haveDescription ( ) const

Indicates presence of the description attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
bool haveName ( ) const

Indicates presence of the name attribute.

Returns:
TRUE if the attribute is present and FALSE otherwise.
ms_xml_parameter & operator= ( const ms_xml_parameter & right )

C++ style assignment operator.

Parameters:
right another instance of this class to copy the content from.
Returns:
reference to the current object
void setDescription ( const char * value )

Set a custom value for the description attribute.

Parameters:
value a new value for the attribute.
void setName ( const char * value )

Set a custom value for the name attribute.

Parameters:
value a new value for the attribute.
void setValue ( const char * value )

Set a custom value for the value attribute.

Parameters:
value a new string value for the parameter.
std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.
The documentation for this class was generated from the following files:
  • ms_xml_parameters.hpp
  • ms_xml_parameters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_xml_parameters
Public Member Functions

ms_xml_parameters Class Reference
[Mascot configuration files module]

A class that represents a base parametersType. More...

#include <ms_xml_parameters.hpp>

Inheritance diagram for ms_xml_parameters:
[legend]

List of all members.

Public Member Functions

ms_xml_parameters ()
Default constructor.
ms_xml_parameters (const ms_xml_parameters &src)
Copying constructor.
virtual | ~ms_xml_parameters ()
Destructor.
virtual void | clearParameters ()=0
Deletes all parameters from the list.
void | defaultValues ()
Call this member if you want to start again.
virtual bool | deleteParameterByName (const char *name)=0
Remove a parameter from the list in memory by its unique name.
virtual bool | deleteParameterByNumber (const int idx)=0
Remove a parameter from the list in memory by its index.
virtual int | getNumberOfParameters () const =0
Returns the number of parameters held.
virtual std::string | getParameterSchemaType () const =0
Obtain a symbolic name for the parameter element schema type.
virtual std::string | getSchemaType () const =0
Returns name of the schema type that can be used to validate this element.
std::string | validateDeep (const ms_xml_schema *pSchemaFileObj) const
Performs validation of all child elements in addition to 'shallow' validation.
std::string | validateShallow (const ms_xml_schema *pSchemaFileObj) const
Performs simple validation of the top-level elements only.

Detailed Description

A class that represents a base parametersType.

The Mascot configuration files quantitation.xml and crosslinking.xml use a common node structure for a set of key-value pairs. ms_xml_parameters is a base class for ms_quant_parameters and ms_crosslinking_parameters, because the parameter sets share the same API.

Constructor & Destructor Documentation

ms_xml_parameters ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_xml_parameters ( const ms_xml_parameters & src )

Copying constructor.

Parameters:
src another instance of this class to copy the content from.

Member Function Documentation

void defaultValues ( )

Call this member if you want to start again.

All internal values are reset to their defaults, as if the object had been freshly created with the default constructor.

Reimplemented in ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_parameters, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

bool deleteParameterByName ( const char * name ) [pure virtual]

Remove a parameter from the list in memory by its unique name.

Parameters:
name name of the parameter for deletion.
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implemented in ms_crosslinking_parameters, and ms_quant_parameters.

bool deleteParameterByNumber ( const int idx ) [pure virtual]

Remove a parameter from the list in memory by its index.

Parameters:
idx number of the parameter for deletion from 0 to (getNumberOfParameters() - 1).
Returns:
TRUE if the parameter has been found and successfully deleted and FALSE otherwise.

Implemented in ms_crosslinking_parameters, and ms_quant_parameters.

int getNumberOfParameters ( ) const [pure virtual]

Returns the number of parameters held.

Returns:
total number of parameters in the list.

Implemented in ms_crosslinking_parameters, and ms_quant_parameters.

std::string getParameterSchemaType ( ) const [pure virtual]

Obtain a symbolic name for the parameter element schema type.

The obtained type name can be used to get a corresponding type description object from ms_xml_schema.

Returns:
symbolic type name for the element.

Implemented in ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, and ms_quant_parameters.

std::string getSchemaType ( ) const [pure virtual]

Returns name of the schema type that can be used to validate this element.

Additional information about the current object can be retrieved from the associated XML schema file. Every element in an XML document is defined with a named type, which you can use to find out what kind of limits (numerical or otherwise) are defined for values of that type.

See also:
validateShallow(), validateDeep()
Returns:
a symbolic fully qualified type name (for example, "mqm:nameType").

Implemented in ms_crosslinking_filters, ms_crosslinking_parameters, ms_crosslinking_scope, ms_crosslinking_settings, ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_parameters, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateDeep ( const ms_xml_schema * pSchemaFileObj ) const

Performs validation of all child elements in addition to 'shallow' validation.

The current object can be checked against an XML schema. When using this method all possible checks are performed. However, this is not a substitute for the schema: some schema-defined constraint are not applied (unique fields, foreign keys etc.).

In order to make sure that current object is free from all syntax errors validate it as a part of the whole document.

See also:
validateShallow(), getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

std::string validateShallow ( const ms_xml_schema * pSchemaFileObj ) const

Performs simple validation of the top-level elements only.

The current object can be checked against some basic constraints in a schema without looking at children element types. When using this method only the current object and children derived from standard types (for example, restrictions with enumerations) are checked. For more thorough validation, use validateDeep().

See also:
getSchemaType()
Parameters:
pSchemaFileObj a valid schema object instance to validate against.
Returns:
user-friendly description of any errors found during validation or an empty string if no errors detected.

Reimplemented in ms_quant_average, ms_quant_integration, ms_quant_multiplex, ms_quant_normalisation, ms_quant_outliers, ms_quant_precursor, ms_quant_quality, ms_quant_replicate, and ms_quant_reporter.

The documentation for this class was generated from the following files:
  • ms_xml_parameters.hpp
  • ms_xml_parameters.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Mascot security and authentication module

Classes

class | ms_group
This class will normally only be used by Mascot Security Administration applications. More...
class | ms_security
The main security class to be used by the administration application. More...
class | ms_security_options
Options for the Mascot security system. More...
class | ms_security_task
Each group has permission to do one or more tasks. This class defines an individual task. More...
class | ms_security_tasks
Each group has permission to do one or more tasks. This class defines a collection of tasks. More...
class | ms_session
Use this class to determine if a user is logged in and if they have 'permission' to perform tasks. More...
class | ms_user
This class will normally only be used by Mascot Security Administration applications. More...

Modules

Using the Mascot security module
Examples for the Mascot security module

Detailed Description

The security module is used to determine who is logged in and what access rights they have

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Using the Mascot security module
[Mascot security and authentication module]

Introduction

The design goals of the Mascot security module include the following:

  • Restrict access to results files and sequence databases based on group and user definitions.
  • Allow authorised users to change Mascot server configuration files in a secure and traceable manner using thin client web based GUI tools that are supplied with Mascot Server.
  • Prevent un-authorised changes of Mascot server configuration files.
  • Standard 'session' support (with time-outs) so users do not need to re-enter passwords.
  • Restrict access to Mascot server based utilities that allow deletion of searches and other job control functions.

Mascot security from a fat client application

A client application can perform most tasks using the login.pl script that is installed in the mascot/cgi directory. A copy is supplied with Mascot Parser and the available commands can be seen at the start of the file.

Calls to most applications on Mascot server require a sessionID parameter. To see if security is disabled, use the login.pl script:

    http://mascot_server/mascot/cgi/login.pl?action=issecuritydisabled&display=nothing

If this returns a valid sessionID, then the sessionID can (but doesn't need to be) passed to any of the applications that accepts a sessionID.

If this call returns an error (and hence doesn't return a sessionID), then try:

    http://mascot_server/mascot/cgi/login.pl?action=webauthentication&display=nothing

If this succeeds, then either the Mascot web server is set up to use IIS integrated authentication, or a user name and password have to be specified in the URL. You can use the returned sessionID as above. If the call returns an error (and hence doesn't return a sessionID), then try

    http://mascot_server/mascot/cgi/login.pl?action=guestlogin&display=nothing

If this succeeds, then an interface should be provided to allow the user to log into the system as a different user with more rights. By default, the guest account is disabled on Mascot servers.

If this also fails (or if you choose not to call it), then the user must be prompted for a user name and password. Pass the username and password to the login.pl script:

    http://mascot_server/mascot/cgi/login.pl?action=login&username=xxx&password=yyy&display=nothing

If this returns an error, you should display the errorstring= value to the end user and prompt once again for the user name and password. Possible errors are listed in the documentation for ms_session().

A special case of ERR_MSP_SECURITY_PASSWORDEXPIRED can be handled by asking for the old and new passwords, and then calling login.pl with the appropriate parameters. Alternatively, a poor solution is to suggest that the user logs into Mascot using a browser and updates their password there.

The sessionID should be passed to daemon.pl and nph-mascot.exe. See documentation for those applications for further details.

Using the ms_session class from a CGI application

For most CGI applications, the only requirement is to create an ms_session object, check that it is valid (isValid()), and then use the methods isPermitted(), isPermitted_long(), etc.

If isValid() returns false, then the error should be treated as described in the ms_session constructor.

Using custom parameters

ms_session, ms_user and ms_group objects can store and retrieve custom string parameters using the methods saveStringParam() and getStringParam(), and the corresponding methods for integers, doubles and booleans. In each case, the key/value pairs are saved in a <mss:custom_parameters> section of the relevant XML files; for example, ms_user custom parameters are saved in user.xml. Custom parameters for ms_user and ms_group were added in Mascot Parser 2.4.1.

Custom parameters are typically used with a temporary session object, which is independent of users and Mascot security and is created with the ms_session(const int, const std::string) constructor. However, it is also possible to use custom parameters with a user session, which is created when a user logs in to Mascot. The rest of this section deals with user sessions.

User sessions can contain three types of custom parameters: parameters saved in the session (ms_session), parameters saved in group.xml (ms_group) and parameters saved in user.xml (ms_user). ms_session custom parameters in user session files are lost when the session file is rewritten. A rewrite may occur, for example, after editing user settings in Mascot Configuration Editor. Both ms_user and ms_group custom parameters survive a rewrite.

Custom ms_user and ms_group parameters are copied to the relevant user session files when ms_security::updateUser or ms_security::updateGroup are called. It is of course possible for ms_user and ms_group objects to contain custom parameters with the same name. Only one value will be saved in the user session file, and parameters from ms_user override parameters from ms_group.

Advanced

The administration utility uses the ms_security class to add users (addNewUser()) and groups (addNewGroup()). Refer to the class documentation for further details.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Examples for the Mascot security module
[Mascot security and authentication module]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation

The most comprehensive example for the security module is the administration tool supplied with Mascot 2.1

Description | Perl | C++ | Java | Python | C#
Checking the 'current' session | security_session.pl | - | security_session.java | - | -
Login to the security system | login.pl | - | - | - | -
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_group
Public Types | Public Member Functions

ms_group Class Reference
[Mascot security and authentication module]

This class will normally only be used by Mascot Security Administration applications. More...

#include <ms_security_group.hpp>

Collaboration diagram for ms_group:
[legend]

List of all members.

Public Types

enum systemids {
GROUPID_GUESTS = 0x0001,
GROUPID_ADMINISTRATORS = 0x0002,
GROUPID_POWERUSERS = 0x0003,
GROUPID_DAEMONS = 0x0004,
GROUPID_INTEGRA_SYSTEM = 0x0005,
GROUPID_LAST = 0x0006
}

Definitions for predefined groups.

More...

Public Member Functions

ms_group ()
Create a new ms_group.
ms_group (const int groupID, const std::string groupName)
Create a new ms_group.
void | addPermittedTask (const matrix_science::ms_security_task &task)
Each group has one or more permitted tasks. Use this function to add to the list.
bool | addUser (const int userID)
Each group has one or more users. Use this function to add a user.
bool | clearParam (const std::string name)
Remove an additional user parameter associated with the group.
bool | deleteUser (const int userID)
Each group has one or more users. Use this function to delete a user.
std::vector< int > | getAllUserIDs (const void *const security=NULL, const int voidSortby=1) const
Return a list of user ids in the group.
int | getID () const
Return the unique group ID.
std::string | getName () const
Return the name of the group.
matrix_science::ms_security_tasks | getPermittedTasks () const
Return the list of permitted tasks.
bool | getStringParam (const std::string name, std::string &param) const
Return a custom parameter for the group.
std::string | getStringParam (const std::string name) const
Return a custom parameter for the group.
bool | isUserInGroup (const int userID) const
Returns true if the user is a member of the group.
bool | removePermittedTask (const int taskID)
Each group has one or more permitted tasks. Use this function to remove one from the list.
bool | saveStringParam (const std::string name, const std::string param)
Save an additional 'string' parameter for the group.
void | setID (int newVal)
Set the unique group ID.
void | setName (const std::string newVal)
Set the name of the group.
void | setPermittedTasks (matrix_science::ms_security_tasks &tasks)
Sets the list of permitted tasks.

Detailed Description

This class will normally only be used by Mascot Security Administration applications.

Member Enumeration Documentation

enum systemids

Definitions for predefined groups.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
GROUPID_GUESTS

The guests group. By default, the matrix_science::ms_user::USERID_GUEST user belongs to this group.

GROUPID_ADMINISTRATORS

The Administrators group. By default, the matrix_science::ms_user::USERID_ADMINISTRATOR user belongs to this group.

GROUPID_POWERUSERS

An example group for users who need access to almost everything.

GROUPID_DAEMONS

Mascot Daemon needs to be set up with a user to run searches. By default, the matrix_science::ms_user::USERID_DAEMON user belongs to this group.

GROUPID_INTEGRA_SYSTEM
Deprecated:
The Mascot Integra system group, only member is normally USERID_INTEGRA_SYSTEM. Users will never be able to log in as this user - it is only used from the Integra server.
GROUPID_LAST

Placeholder.

Member Function Documentation

void addPermittedTask ( const matrix_science::ms_security_task & task )

Each group has one or more permitted tasks. Use this function to add to the list.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters:
task The new task, which should be obtained by calling ms_security::getTasks(), to get a list of all possible tasks, and then calling ms_security::tasks::getTask() or ms_security::tasks::getTaskFromID() to get the particular task. If additional parameters are required for the task, (e.g. for maximum number of MS-MS spectra), then this data should be added using one of the addXXXParam functions (e.g. ms_security_task::addLongParam()) before calling this function.
bool addUser ( const int userID )

Each group has one or more users. Use this function to add a user.

Add the user to this group. Since a user ID remains constant, but the user name can be altered, it is the userID that is associated with the group rather than the name. After adding a user to a group call ms_security::updateGroup().

Parameters:
userID The unique ID of the user to be added to the group.
Returns:
true if the userID is at least zero and if insertion succeeds, false otherwise
bool clearParam ( const std::string name )

Remove an additional user parameter associated with the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

Use this function when you no longer want a value associated with a key name for a group.

To make the changes permanent, use ms_security::updateGroup().

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
boolean value to indicate if the value was successfully removed.
bool deleteUser ( const int userID )

Each group has one or more users. Use this function to delete a user.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters:
userID Must be a valid userID for a user that belongs to the group.
Returns:
True if the user is found, and can be deleted.
std::vector< int > getAllUserIDs | ( | const void *const | security = NULL,
 |  | const int | voidSortby = 1
 | ) |  | const

Return a list of user ids in the group.

To get information about each of the userIDs returned, call ms_security::getUserFromID() to return a matrix_science::ms_user object.

Parameters:
security | Should be a valid pointer to an ms_security object, by default it is NULL
voidSortby | Should be a valid ms_security::USERID_SORTBY, by default it is 1
Returns:
A vector of userIDs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getName ( ) const

Return the name of the group.

Each group will have a unique name, and a unique ID.

Returns:
The name of this group.
std::string getStringParam ( const std::string name ) const

Return a custom parameter for the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

If an empty string is returned, it is not possible to determine if this is because there is no key value or if an empty string was set for the key.

See also:
saveStringParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
Is the value of the parameter associated with the key name or an empty string if there is no key.
bool getStringParam | ( | const std::string | name,
 |  | std::string & | param
 | ) |  | const

Return a custom parameter for the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

Note:
This function should not be used from programming languages other than C++. Use getStringParam(const std::string) const instead.
See also:
saveStringParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
bool isUserInGroup ( const int userID ) const

Returns true if the user is a member of the group.

Parameters:
userID Should be a valid userID.
Returns:
True if the user is found.
bool removePermittedTask ( const int taskID )

Each group has one or more permitted tasks. Use this function to remove one from the list.

Parameters:
taskID Must be a task ID for a task currently assigned to the group.
Returns:
True if the task was removed.
bool saveStringParam | ( | const std::string | name,
 |  | const std::string | param
 | ) |  |

Save an additional 'string' parameter for the group.

Additional custom data for a group are saved in a <mss:custom_parameters> section in the group.xml file.

The value can be retrieved using getStringParam().

To make the changes permanent, use ms_security::updateGroup().

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
void setID ( int newVal )

Set the unique group ID.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters:
newVal Is the new ID for the group. This function does not normally need to be called by an application. New groups should be added by calling ms_security::addNewGroup().
void setName ( const std::string newVal )

Set the name of the group.

Each group will have a unique name, and a unique ID.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters:
newVal The new name of this group.
void setPermittedTasks ( matrix_science::ms_security_tasks & tasks )

Sets the list of permitted tasks.

The function ms_security::updateGroup() should be called after this function to save the change permanently.

Parameters:
tasks a list of tasks to copy from.
The documentation for this class was generated from the following files:
  • ms_security_group.hpp
  • ms_security_group.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_security
Public Types | Public Member Functions

ms_security Class Reference
[Mascot security and authentication module]

The main security class to be used by the administration application. More...

#include <ms_security.hpp>

Inheritance diagram for ms_security:
[legend]
Collaboration diagram for ms_security:
[legend]

List of all members.

Public Types

enum USERID_SORTBY {
USERID_SORTBY_ID = 1,
USERID_SORTBY_LOGINNAME = 2,
USERID_SORTBY_FULLNAME = 3
}

Sorting criterion to retrieve all users.

More...

Public Member Functions

ms_security ()
The constructor loads all the groups and users information from the ../config directory.
bool | addNewGroup (const std::string sessionID, const int groupID, const std::string groupName)
Add a new group to the current list of groups.
bool | addNewUser (const std::string sessionID, const int userID, const std::string userName, const std::string password, const time_t passwordExpiry, const std::string fullName, const std::string emailAddress, const ms_user::usertype userType, const bool enabled)
Add a new user to the current list of users.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | createDefaults (const std::string sessionID="")
Create default users, groups and sessions.
bool | deleteGroup (const std::string sessionID, const std::string groupName)
Delete a group from the system.
bool | deleteUser (const std::string sessionID, const std::string userName)
Delete a user from the system.
ms_user::customParams_t | getAllCustomParamsForUser (const ms_user &user) const
Return a 'map' of all the custom parameters for a user.
std::vector< int > | getAllGroupIDs () const
Return a list of all group IDs.
std::vector< int > | getAllUserIDs (const USERID_SORTBY sortby=USERID_SORTBY_ID) const
Return a list of all user IDs.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
ms_group | getGroup (const std::string groupName) const
Return a group given the name .
ms_group | getGroupFromID (const int groupID) const
Return a group given the ID.
std::vector< std::string > | getIntegraUsers () const
Returns a list of Integra users.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_security_options | getMascotSecurityOptions () const
Return the security options.
ms_security_tasks | getPermittedTasksForUser (const std::string name) const
Return a list of the tasks permitted for the user.
ms_security_tasks | getTasks () const
Return the complete list of possible tasks available.
ms_user | getUser (const std::string userName) const
Return a user given the name.
ms_user | getUserFromID (const int userID) const
Return a user given the ID.
bool | isTaskExists (const int taskID) const
Return true if a security task with the given ID exists.
bool | isUserExists (const int userID) const
Return true if a user with this ID exists.
bool | isValid () const
Call this function to determine if there have been any errors.
std::vector< int > | sortUsers (std::vector< ms_user * > &vecUsers, const USERID_SORTBY sortby) const
Sort a list of users and return a list of user IDs.
bool | updateAllSessionFiles (bool deleteOnly=false)
Update all the session files after making a change to parameters.
bool | updateGroup (const std::string sessionID, const ms_group &group)
Call this after updating any details for a group.
bool | updatePassword (const std::string sessionID, const std::string userName, const std::string oldPassword, const std::string newPassword)
Update the password for an existing user.
bool | updateUser (const std::string sessionID, const ms_user user)
Update an existing user int the system.

Detailed Description

The main security class to be used by the administration application.

Other applications should just need to use ms_session.

When an object of this class is created, it loads all the users, groups tasks and options into memory.

Member Enumeration Documentation

enum USERID_SORTBY

Sorting criterion to retrieve all users.

Enumerator:
USERID_SORTBY_ID

Sort the list of users id by id.

USERID_SORTBY_LOGINNAME

Sort the list of users id by login name (its displayed name)

USERID_SORTBY_FULLNAME

Sort the list of users id by full name.

Constructor & Destructor Documentation

ms_security ( )

The constructor loads all the groups and users information from the ../config directory.

The administration program should use this constructor to load all users, groups and tasks. New users and groups should be added through this interface.

Member Function Documentation

bool addNewGroup | ( | const std::string | sessionID,
 |  | const int | groupID,
 |  | const std::string | groupName
 | ) |  |

Add a new group to the current list of groups.

To add a new group, call this function first. If the function returns true, then get the group using getGroup(), add users and tasks to the group and then call updateGroup().

Parameters:
sessionID | This is the session id for the administrator who is adding the user. A valid session ID with administrator rights is required, and all additions of users and groups are logged using the details in the session ID.
groupID | Can be set to -1 in which case the system provides a new unique ID. If a value is provided, and there is already a group with this ID, then the function will return false and the error ms_errs::ERR_MSP_SECURITY_DUPE_GROUP_ID.
groupName Is the name of the new group to be added. This must not contain spaces or any of the following characters:

><\\/`;,+*"

If there is already a group with this name, then the function will return false and set the error ms_errs::ERR_MSP_SECURITY_DUPE_GROUP_NAME.

Returns:
True if the function succeeds. The function will fail if the session is invalid, or doesn't have administrator rights. The function will also fail if there is a group with a the same name or the same ID.
bool addNewUser | ( | const std::string | sessionID,
 |  | const int | userID,
 |  | const std::string | userName,
 |  | const std::string | password,
 |  | const time_t | passwordExpiry,
 |  | const std::string | fullName,
 |  | const std::string | emailAddress,
 |  | const ms_user::usertype | userType,
 |  | const bool | enabled
 | ) |  |

Add a new user to the current list of users.

Use this function, rather than ms_user::ms_user to add a new user to the system.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_USERID_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_DISABLE_ADMIN
  • ms_errs::ERR_MSP_SECURITY_DUPE_USER_NAME_U
  • ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT
  • ms_errs::ERR_MSP_SECURITY_BAD_USER_NAME
Parameters:
sessionID | This is the session id for the administrator who is adding the user. A valid session ID with administrator rights is required, and all additions of users and groups are logged using the details in the session ID.
userID | Can be set to -1 in which case the system provides a new unique ID. If a value is provided, and there is already a user with this ID, then the function will return false and set the error ms_errs::ERR_MSP_SECURITY_DUPE_USER_ID.
userName The user name must not contain spaces or any of the following characters:

><\\/`;,+*"

If there is already a user with this name, then the function will return false and set the error ms_errs::ERR_MSP_SECURITY_DUPE_USER_NAME.

password | The password length must be greater than or equal to ms_security_options::getMinimumPasswordLength() unless the passwordExpiry parameter is set to 1, in which case the user will be prompted for a new password when they log in.
passwordExpiry | is the time in seconds since Jan 1, 1970 when the password will expire. See ms_security_options::getDefaultPasswordExpiryTime() for details. A value of '0'is used to indicate that the password should never expire. A value of 'now' or 1 can be used to force the user to change their password next time they log in.
fullName | Can be any number of characters, but ideally should not be left blank.
emailAddress | Can be any number of characters, but ideally should not be left blank. No error checking is performed in this function.
userType must be ascertained correctly by the calling application, since there is no error checking in this function. Normally, this function should only be called with one of

  • ms_user::USER_NORMAL
  • ms_user::USER_COMPUTER_NAME
  • ms_user::USER_IP_ADDRESS
  • ms_user::USER_AGENT_STRING or
  • ms_user::USER_WEBAUTH

The type should never be ms_user::USER_SECURITY_DISABLED

enabled | Should normally be set to true to allow the user to login.
Returns:
True if successful.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
bool createDefaults ( const std::string sessionID = "" )

Create default users, groups and sessions.

This function should be called by the installation program to create all the default users, default groups, default sessions etc. if they don't already exist.

This function creates:

  • An 'admin' user with ID: ms_user::USERID_ADMINISTRATOR.
  • A 'guest' user with ID: ms_user::USERID_GUEST. This user account is however disabled.
  • An 'Administrators' group with ID: ms_group::GROUPID_ADMINISTRATORS. The admin user is added to this group, which also has ms_security_tasks::SECTASK_ADMINPAGES, ms_security_tasks::SECTASK_KILLALLTASK, ms_security_tasks::SECTASK_ACCESSDBSETUP, and ms_security_tasks::SECTASK_VIEWCONFIGUSINGMSSTATUS rights assigned.
  • A 'Guests' group with the ID: ms_group::GROUPID_GUESTS. The guest user is added, along with a few minimal access rights.
Parameters:
sessionID Will generally be the built in command line session that is automatically created for any programs not being run from the web server.
Returns:
True if the function succeeds. Possible errors are: ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID, ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION and all errors that can be set from calling addNewUser() and addNewGroup().
bool deleteGroup | ( | const std::string | sessionID,
 |  | const std::string | groupName
 | ) |  |

Delete a group from the system.

Possible error values are:

  • ms_errs::ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_DEL_SPECIAL_GROUP
Parameters:
sessionID | This is the session id for the administrator who is deleting the group. A valid session ID with administrator rights is required, and all deletions of users and groups are logged using the details in the session ID.
groupName | Needs to be a valid user name.
Returns:
Will return true if the function succeeds in deleting the group. Otherwise, it will return false and set just one of the above errors.
bool deleteUser | ( | const std::string | sessionID,
 |  | const std::string | userName
 | ) |  |

Delete a user from the system.

Possible error values are:

  • ms_errs::ERR_MSP_SECURITY_USERNAME_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_DEL_SPECIAL_USER
Parameters:
sessionID | This is the session id for the administrator who is deleting the user. A valid session ID with administrator rights is required, and all deletions of users and groups are logged using the details in the session ID.
userName | Needs to be a valid user name.
Returns:
Will return true if the function succeeds in deleting the user Otherwise, it will return false and set just one of the above errors.
ms_user::customParams_t getAllCustomParamsForUser ( const ms_user & user ) const

Return a 'map' of all the custom parameters for a user.

If an invalid user object is passed, then the returned object will be empty

Customer parameters for a user can originate from the user or group settings. Values at the user level overwrite values at the group level. See Using custom parameters

Parameters:
user Needs to be a valid user object.
Returns:
a 'map' of custom parameters and values.
std::vector< int > getAllGroupIDs ( ) const

Return a list of all group IDs.

To find details of each group, call getGroupFromID().

Returns:
An array of user IDs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::vector< int > getAllUserIDs ( const USERID_SORTBY sortby = USERID_SORTBY_ID ) const

Return a list of all user IDs.

To find details of each user, call getUserFromID().

Parameters:
sortby The field on which to sort the users whose IDs are returned, by default they are sorted by id
Returns:
An array of user IDs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
ms_group getGroup ( const std::string groupName ) const

Return a group given the name .

If an invalid group name is passed, then for the returned object, ms_group::getID() will return -1.

Parameters:
groupName Needs to be a valid group name.
Returns:
an ms_group object.
ms_group getGroupFromID ( const int groupID ) const

Return a group given the ID.

If an invalid group ID is passed, then for the returned object, ms_group::getUserID() will return -1.

Parameters:
groupID Needs to be a valid group ID.
Returns:
an ms_group object.
std::vector< std::string > getIntegraUsers ( ) const

Returns a list of Integra users.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Will return an empty list if there is no local Mascot Integra system or the definitions in the option file are not correct. These users have not neccessarily been added to the list of Mascot users.

Returns:
An array of Integra user names. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
ms_security_options getMascotSecurityOptions ( ) const

Return the security options.

If an ms_security object is available, it is faster to call this than creating a new matrix_science::ms_security_options object because there will be no need to load the options file from disk.

Note that this function returns a copy of the security options, so changing the options will have no effect on the ms_security object. To have the changes take effect, a new ms_security object will have to be created.

Returns:
The security options. If the configuration file is not present, defaults will be used.
ms_security_tasks getPermittedTasksForUser ( const std::string name ) const

Return a list of the tasks permitted for the user.

If an invalid user name is passed, then for the returned object, ms_security_tasks::getNumberOfTasks() will return 0.

Parameters:
name Needs to be a valid user name.
Returns:
A ms_security_tasks object.
ms_security_tasks getTasks ( ) const

Return the complete list of possible tasks available.

The administration module will use this function to display a list of possible tasks to the end user.

Returns:
The complete list of tasks.
ms_user getUser ( const std::string userName ) const

Return a user given the name.

If an invalid user name is passed, then for the returned object, ms_user::getID() will return -1.

Parameters:
userName Needs to be a valid user name.
Returns:
an ms_user object.
ms_user getUserFromID ( const int userID ) const

Return a user given the ID.

If an invalid user ID is passed, then for the returned object, ms_user::getUserID() will return -1.

Parameters:
userID Needs to be a valid user ID.
Returns:
an ms_user object.
bool isTaskExists ( const int taskID ) const

Return true if a security task with the given ID exists.

Parameters:
taskID Task ID to check.
Returns:
true if a task with this ID exists; false otherwise.
bool isUserExists ( const int userID ) const

Return true if a user with this ID exists.

Parameters:
userID User ID to check.
Returns:
true if a user with this ID exists; false otherwise.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
std::vector< int > sortUsers | ( | std::vector< ms_user * > & | vecUsers,
 |  | const USERID_SORTBY | sortby
 | ) |  | const

Sort a list of users and return a list of user IDs.

Sorts a list of users by the given field

Parameters:
vecUsers | A vector of users to sort
sortby | The field on which to sort the users whose IDs are returned
Returns:
An array of user IDs sorted by id, login name or full name
bool updateAllSessionFiles ( bool deleteOnly = false )

Update all the session files after making a change to parameters.

This function is called by addNewUser(), deleteUser(), updateUser(), addNewGroup(), deleteGroup() and updateGroup().

Parameters:
deleteOnly is set to true when this function is called from ms-monitor.exe. This prevents session files from being created with the incorrect file permissions.
Returns:
always returns true
bool updateGroup | ( | const std::string | sessionID,
 |  | const ms_group & | group
 | ) |  |

Call this after updating any details for a group.

Groups can be changed by adding/deleting users, changing the name or adding/deleting tasks. To make any of these changes, call getGroup() or getGroupFromID() to get the group and then make changes using the ms_group member functions. Finally, call this function to make the changes permanent. Do not change the groupID, or this function will fail.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_GROUPID_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_DUPE_GROUP_NAME_U
  • ms_errs::ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP
  • ms_errs::ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS
Parameters:
sessionID | This is the session id for the administrator who is updating the group. A valid session ID with administrator rights is required, and all updates of users and groups are logged using the details in the session ID.
group | The group returned from getGroup() or getGroupFromID().
Returns:
True if the group already exists and has been successfully updated.
bool updatePassword | ( | const std::string | sessionID,
 |  | const std::string | userName,
 |  | const std::string | oldPassword,
 |  | const std::string | newPassword
 | ) |  |

Update the password for an existing user.

If the old password is empty, or is supplied, then anyone can call this function. If the sessionID is for a valid session with Administrator privileges, then the old password is not required.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_OLD_PW_INVALID
  • ms_errs::ERR_MSP_SECURITY_USERNAME_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_NO_GUEST_PWD
  • ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT
  • ms_errs::ERR_MSP_SECURITY_SAMEPASSWORD
Parameters:
sessionID | Is the session ID for a session with Administrator permissions or a session for the named user.
userName | Needs to be an existing user name.
oldPassword | The old password must be correct.
newPassword | The password will be updated with the new value.
Returns:
Will return true if the password has been updated successfully.
bool updateUser | ( | const std::string | sessionID,
 |  | const ms_user | user
 | ) |  |

Update an existing user int the system.

Most properties of a user account can be changed -- for example the login name, or the full name or email address. The ID cannot be changed. The password must be changed using updatePassword(). To change which groups a user belongs to, see updateGroup().

To call this function, the session must either have ms_security_tasks::SECTASK_ADMINPAGES or ms_security_tasks::SECTASK_MODIFYOWNPROFILE rights. In the latter case, the user to be updated must be the same as the session user, and the only things that can be changed are the full name and the email address.

Possible errors are:

  • ms_errs::ERR_MSP_SECURITY_INVALID_SESSION_ID
  • ms_errs::ERR_MSP_SECURITY_NOT_ADMIN_SESSION
  • ms_errs::ERR_MSP_SECURITY_USERID_NOT_FOUND
  • ms_errs::ERR_MSP_SECURITY_DISABLE_ADMIN
  • ms_errs::ERR_MSP_SECURITY_DUPE_USER_NAME_U
  • ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT
  • ms_errs::ERR_MSP_SECURITY_BAD_USER_NAME
Parameters:
sessionID | Is the session ID for a session with Administrator permissions.
user | Needs to be an existing user. All details will be reset with the passed information, including the password.
Returns:
Will return false and set ms_errs::ERR_MSP_SECURITY_USERNAME_NOT_FOUND if the named user cannot be found.
The documentation for this class was generated from the following files:
  • ms_security.hpp
  • ms_security.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_security_options
Public Member Functions

ms_security_options Class Reference
[Mascot security and authentication module]

Options for the Mascot security system. More...

#include <ms_security_options.hpp>

Inheritance diagram for ms_security_options:
[legend]
Collaboration diagram for ms_security_options:
[legend]

List of all members.

Public Member Functions

ms_security_options ()
Loads the options file into memory.
ms_security_options (const ms_security_options &src)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_security_options *right)
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
time_t | getDefaultPasswordExpiryTime () const
Returns the time in days before a password expires.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getIntegraAppServerURL () const
Returns the URL to the Integra Application server host.
std::string | getIntegraDatabaseName () const
Returns the name of the Integra database.
std::string | getIntegraOracleServerName () const
Returns the name of the oracle server for Mascot Integra.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getLogFileName ()
Returns the log file name.
matrix_science::ms_errs::msg_sev | getLoggingLevel () const
Returns the logging level.
unsigned int | getMinimumPasswordLength () const
Returns the minimum password length.
time_t | getSessionTimeout () const
Returns the time in seconds before a user is logged out.
bool | getUseSessionCookies () const
Returns true if session (rather than file) cookies are to be used.
bool | getVerifySessionIPAddress () const
Returns true if a session will be invalid if used from a different IP address from the original session request.
bool | isSecurityEnabled () const
Will return true if the Mascot security system is enabled.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_security_options & | operator= (const ms_security_options &right)
void | setDefaultPasswordExpiryTime (time_t newVal)
Sets the time in days before a password expires.
void | setIntegraAppServerURL (std::string newVal)
Sets the URL to the Integra Application server host.
void | setIntegraDatabaseName (std::string newVal)
Sets the name of the Integra database.
void | setIntegraOracleServerName (std::string newVal)
Sets the name of the oracle server for Mascot Integra.
void | setLogFileName (std::string newVal)
Sets the log file name.
void | setLoggingLevel (ms_errs::msg_sev newVal)
Sets the logging level.
void | setMinimumPasswordLength (unsigned int newVal)
Sets the minimum password length.
void | setSecurityEnabled (bool newVal)
Enables the Mascot security system.
void | setSessionTimeout (time_t newVal)
Sets the time in seconds before a user is logged out.
void | setUseSessionCookies (bool newVal)
Set whether session or file cookies should be used.
void | setVerifySessionIPAddress (bool newVal)
Set if a session will be invalid if used from a different IP address from the original session request.

Detailed Description

Options for the Mascot security system.

This class will generally only be used by the security administration utility. It is used by the ms_security and ms_session classes.

Constructor & Destructor Documentation

ms_security_options ( )

Loads the options file into memory.

If the file cannot be found, the following defaults are set:

Security enabled
false
Session timeout
21,600 seconds (6 hours)
Default password expiry time
365 (days)
Minimum password length
5 characters
Use session cookies
false
Verify IP address for sessions
false
Mascot Integra application server URL
"http://integra:8080/topaz"
Mascot Integra database name
"integra"
Mascot Integra Oracle server name
Integra

It will often be faster to call ms_security::getMascotSecurityOptions() if a ms_security object is already available.

ms_security_options ( const ms_security_options & src )
Parameters:
src is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_security_options * right )
Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
time_t getDefaultPasswordExpiryTime ( ) const

Returns the time in days before a password expires.

When a new user is created using ms_security::addNewUser(), the password expiry is explicity set using that function. A value of 1 will typically be passed to that function to force the user to choose a new password when they first log in. However, the administration utility could take the current time, and add this default value to set the new expiry time.

This default value is used to set the expiry time for the password when ms_security::updatePassword() is called. If the default expiry time is zero, then the user's password will be set to never expire.

See also:
ms_user::getPasswordExpiry(), setDefaultPasswordExpiryTime()
Returns:
The expiry time in days.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getIntegraAppServerURL ( ) const

Returns the URL to the Integra Application server host.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the URL to the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be of the form http://integra:8080/topaz.

See also:
setIntegraAppServerURL()
Returns:
The URL for Mascot Integra server.
std::string getIntegraDatabaseName ( ) const

Returns the name of the Integra database.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the database name on the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also:
setIntegraDatabaseName()
Returns:
The Mascot Integra database name.
std::string getIntegraOracleServerName ( ) const

Returns the name of the oracle server for Mascot Integra.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the location of the Oracle server used by Mascot Integra, which may not be on the same system as Mascot Integra. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also:
setIntegraOracleServerName().
Returns:
The Mascot Integra Oracle database server name.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getLogFileName ( )

Returns the log file name.

Any changes to security settings are logged in the log file.

Returns:
The log file name.
ms_errs::msg_sev getLoggingLevel ( ) const

Returns the logging level.

Any changes to security settings are logged in the log file. The number of messages depends on the logging level.

Returns:
The logging level.
unsigned int getMinimumPasswordLength ( ) const

Returns the minimum password length.

A value of zero can be used to indicate that passwords are not required. This value is checked when ms_security::addNewUser() or ms_security::updatePassword() are called. If the entered password is less than this length, then the error ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT will be generated.

See also:
setMinimumPasswordLength()
Returns:
The minimum password length.
time_t getSessionTimeout ( ) const

Returns the time in seconds before a user is logged out.

Accessing a session using ms_session (normally done viewing any page that uses the session) will start the clock ticking again for that session. Session timeouts are not used for guest sessions, or if the user type is one of

  • ms_user::USER_INTEGRA,
  • ms_user::USER_COMPUTER_NAME,
  • ms_user::USER_IP_ADDRESS,
  • ms_user::USER_AGENT_STRING or
  • ms_user::USER_WEBAUTH.
See also:
setSessionTimeout()
Returns:
The session timeout value in seconds which will be in the range 60 to 31,449,600 (one year).
bool getUseSessionCookies ( ) const

Returns true if session (rather than file) cookies are to be used.

A session, or non persistent cookie is not saved on the end users disk, and just lasts for the time that the browser is open. A file or persistent cookie is saved on the end users disk so that it will be available when the browser is opened again.

The name of the cookie that saves the session ID should be MascotSessionID -- see ms_session::ms_session() for details of how the cookie is used.

The only time that a cookie should be set is when the user logs in. If this option to use session cookies is set, then the 'expires' value must not be set. See also setUseSessionCookies().

Returns:
True if session rather than persistent cookies should be used.
bool getVerifySessionIPAddress ( ) const

Returns true if a session will be invalid if used from a different IP address from the original session request.

When a session is created, the IP address of the originator and the value of this flag is saved in the session file. If this flag is set to true, and there is a request to open the session from a different IP address, then that request will be denied with the error ms_errs::ERR_MSP_SECURITY_DIFFERENTIPADDR. Guest users, or any user with the type ms_user::USER_WEBAUTH will never generate that error.

See also:
setVerifySessionIPAddress(), ms_session::getIPAddress()
Returns:
True if IP addresses should be checked.
bool isSecurityEnabled ( ) const

Will return true if the Mascot security system is enabled.

Most applications will not need to call this function, since they will need to create a ms_session object anyway, and can then use the ms_session::isSecurityEnabled() function.

Returns:
True if security is enabled.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_security_options & operator= ( const ms_security_options & right )
Parameters:
right is the source to initialise from
Returns:
reference to the current object
void setDefaultPasswordExpiryTime ( time_t newVal )

Sets the time in days before a password expires.

When a new user is created using ms_security::addNewUser(), the password expiry is explicity set using that function. A value of 1 will typically be passed to that function to force the user to choose a new password when they first log in. However, the administration utility could take the current time, and add this default value to set the new expiry time.

This default value is used to set the expiry time for the password when ms_security::updatePassword is called. If the default expiry time is zero, then the user's password will be set to never expire.

See also:
ms_user::getPasswordExpiry(), getDefaultPasswordExpiryTime()
Parameters:
newVal is the new expiry time in days.
void setIntegraAppServerURL ( std::string newVal )

Sets the URL to the Integra Application server host.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the URL to the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be of the form http://integra:8080/topaz.

See also:
getIntegraAppServerURL()
Parameters:
newVal The URL for Mascot Integra server.
void setIntegraDatabaseName ( std::string newVal )

Sets the name of the Integra database.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the database name on the Mascot Integra system. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also:
setIntegraDatabaseName()
Parameters:
newVal The Mascot Integra database name.
void setIntegraOracleServerName ( std::string newVal )

Sets the name of the oracle server for Mascot Integra.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

Mascot Integra users should be able to use the same login for the Mascot search engine and Mascot Integra. This is the location of the Oracle server used by Mascot Integra, which may not be on the same system as Mascot Integra. Should be blank where there is no local Mascot Integra installation. It will typically be 'integra'.

See also:
getIntegraOracleServerName()
Parameters:
newVal The Mascot Integra Oracle database server name.
void setLogFileName ( std::string newVal )

Sets the log file name.

Any changes to security settings are logged in the log file.

Parameters:
newVal The new log file name.
void setLoggingLevel ( ms_errs::msg_sev newVal )

Sets the logging level.

Any changes to security settings are logged in the log file. (../logs/security.log). The number of messages depends on the logging level:

  • 1 - Errors
  • 2 - Warnings
  • 3 - Information (Default)
  • 4 - Debug level 1
  • 5 - Debug level 2
  • 6 - Debug level 3
Parameters:
newVal The new logging level.
void setMinimumPasswordLength ( unsigned int newVal )

Sets the minimum password length.

A value of zero can be used to indicate that passwords are not required. This value is checked when ms_security::addNewUser() or ms_security::updatePassword() are called. If the entered password is less than this length, then the error ms_errs::ERR_MSP_SECURITY_PASSWORD_TOO_SHORT will be generated.

See also:
getMinimumPasswordLength()
Parameters:
newVal is the new minimum password length.
void setSecurityEnabled ( bool newVal )

Enables the Mascot security system.

Used by the security administration utility. See also isSecurityEnabled().

Parameters:
newVal Should be set to true to enable security or false to disable it.
void setSessionTimeout ( time_t newVal )

Sets the time in seconds before a user is logged out.

Viewing any page that uses the session timeout will start the clock ticking again. Session timeouts are not used for guest sessions, or if the user type is one of

  • ms_user::USER_INTEGRA,
  • ms_user::USER_COMPUTER_NAME,
  • ms_user::USER_IP_ADDRESS,
  • ms_user::USER_AGENT_STRING or
  • ms_user::USER_WEBAUTH.
See also:
getSessionTimeout()
Parameters:
newVal is the new session timeout in seconds. It must be in the range 60 to 31,449,600 (one year).
void setUseSessionCookies ( bool newVal )

Set whether session or file cookies should be used.

A session, or non persistent cookie is not saved on the end users disk, and just lasts for the time that the browser is open. A file or persistent cookie is saved on the end users disk so that it will be available when the browser is opened again.

The name of the cookie that saves the session ID should be MascotSessionID -- see ms_session::ms_session() for details of how the cookie is used.

The only time that a cookie should be set is when the user logs in. If this option to use session cookies is set, then the 'expires' value must not be set. See also getUseSessionCookies().

Parameters:
newVal Should be set to true to specify that session rather than persistent cookies should be used.
void setVerifySessionIPAddress ( bool newVal )

Set if a session will be invalid if used from a different IP address from the original session request.

When a session is created, the IP address of the originator and the value of this flag is saved in the session file. If this flag is set to true, and there is a request to open the session from a different IP address, then that request will be denied with the error ms_errs::ERR_MSP_SECURITY_DIFFERENTIPADDR. Guest users, or any user with the type ms_user::USER_WEBAUTH will never generate that error.

See also:
setVerifySessionIPAddress(), ms_session::getIPAddress()
Parameters:
newVal Should be set to true if IP addresses should be checked.
The documentation for this class was generated from the following files:
  • ms_security_options.hpp
  • ms_security_options.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_security_task
Public Types | Public Member Functions

ms_security_task Class Reference
[Mascot security and authentication module]

Each group has permission to do one or more tasks. This class defines an individual task. More...

#include <ms_security_task.hpp>

List of all members.

Public Types

enum paramType {
TYPE_BOOL = 0x0000,
TYPE_EQ_LONG = 0x0001,
TYPE_LTE_LONG = 0x0002,
TYPE_GTE_LONG = 0x0003,
TYPE_LONG_ARRAY = 0x0004,
TYPE_EQ_DOUBLE = 0x0005,
TYPE_LTE_DOUBLE = 0x0006,
TYPE_GTE_DOUBLE = 0x0007,
TYPE_DOUBLE_ARRAY = 0x0008,
TYPE_EQ_STRING = 0x0009,
TYPE_STRING_ARRAY = 0x000A,
TYPE_USERS_ARRAY = 0x000B,
TYPE_ALL_USERS_ARRAY = 0x000C
}

Definitions for parameter type.

More...

Public Member Functions

ms_security_task ()
Create a new empty object - not particularly useful.
~ms_security_task ()
Destructor of the class.
bool | addDoubleParam (const double value)
Add a floating point parameter to the task.
bool | addLongParam (const long value)
Add a long parameter to the task.
bool | addStringParam (const std::string value)
Add a string parameter to the task.
void | clearParams ()
Clears all parameters.
std::string | getAllParamsAsString () const
Return all the parameters as a comma separated string.
std::string | getConstantName () const
Returns the 'constant definition name' for the task.
std::string | getDescription () const
Returns a single line description for the task.
std::vector< double > | getDoubleParams () const
Get the list of long parameters for the task.
int | getID () const
Returns the unique ID for the task.
std::vector< long > | getLongParams () const
Get the list of long parameters for the task.
std::string | getNotes () const
Returns any notes applied to the task.
std::vector< std::string > | getStringParams () const
Get the list of string parameters for the task.
paramType | getType () const
Returns the 'type' of the parameter for a task.
bool | isPermitted () const
See if the task is permitted.
bool | isPermitted_double (const double value) const
See if the value is in the floating point parameter list.
bool | isPermitted_long (const long value) const
See if the value is in the long integer parameter list.
bool | isPermitted_string (const std::string value) const
See if the value is in the string parameter list.
void | setParams (const std::string value)
Set all parameters, regardless of type.

Detailed Description

Each group has permission to do one or more tasks. This class defines an individual task.

There is currently no programmatic interface for saving task information, since this should normally only be done by developers.

Tasks are loaded from the file config/security_tasks.xml.

Parameters, for example, the maximum number of queries for a group, or the databases that can be used by a group are not saved in config/security_tasks.xml, but are saved as part of the group information. However, the type of the parameter is saved in config/security_tasks.xml.

Member Enumeration Documentation

enum paramType

Definitions for parameter type.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Each task has one or more parameters associated with it. For example, "Access to administration pages" would have a boolean value. Other tasks such as "Maximum execution time" need a single number to determine the limit.

Enumerator:
TYPE_BOOL

The default - A single boolean parameter that is always 'true'.

TYPE_EQ_LONG

Single extra long integer parameter. The 'test' value must equal the stored value for this task to be permitted.

TYPE_LTE_LONG

Single extra long integer parameter. The 'test' value must be less than or equal to the stored value for this task to be permitted.

TYPE_GTE_LONG

Single extra long integer parameter. The 'test' value must be greater than or equal to the stored value for this task to be permitted.

TYPE_LONG_ARRAY

Array of extra long integer parameters. The test value must equal one of these values for the task to be permitted.

TYPE_EQ_DOUBLE

Single extra floating point parameter. The 'test' value must equal the stored value for this task to be permitted.

TYPE_LTE_DOUBLE

Single extra floating point parameter. The 'test' value must be less than or equal to the stored value for this task to be permitted.

TYPE_GTE_DOUBLE

Single extra floating point parameter. The 'test' value must be greater than or equal to the stored value for this task to be permitted.

TYPE_DOUBLE_ARRAY

Array of extra floating point parameters. The test value must equal one of these values for the task to be permitted.

TYPE_EQ_STRING

Single extra string parameter. The 'test' value must equal the stored value for this task to be permitted.

TYPE_STRING_ARRAY

Array of extra string parameters. The test value must equal one of these values for the task to be permitted.

TYPE_USERS_ARRAY

Array of user IDs, similar to TYPE_LONG_ARRAY. When this type of task is assigned to a group, it is automatically filled with all user IDs in the group.

TYPE_ALL_USERS_ARRAY

Array of user IDs, similar to TYPE_LONG_ARRAY. When this type of task is assigned to a group, it is automatically filled with the user IDs of all users that are in any group that the user belongs to.

Constructor & Destructor Documentation

ms_security_task ( )

Create a new empty object - not particularly useful.

Default constructor does nothing. Need to call loadFromFile() or addTask() to assign tasks to the list.

~ms_security_task ( )

Destructor of the class.

The destructor is never called directly.

Member Function Documentation

bool addDoubleParam ( const double value )

Add a floating point parameter to the task.

This function will generally only be called by Administration utilities.

See also addLongParam() for an example.

Parameters:
value
  • If the param type is ms_security_task::TYPE_EQ_DOUBLE then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_LTE_DOUBLE then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_GTE_DOUBLE then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_DOUBLE_ARRAY then value will be added to the list of values.
Returns:
true for any of the valid types above, otherwise return false because the expected parameter type is not correct.
bool addLongParam ( const long value )

Add a long parameter to the task.

This function will generally only be called by Administration utilities. For example, this could be the maximum number of spectra permitted for a search.

See also isPermitted_long() which might be called by other applications to determine if a user has rights to run, for example, a search with 1000 spectra.

Parameters:
value
  • If the param type is ms_security_task::TYPE_EQ_LONG then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_LTE_LONG then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_GTE_LONG then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_LONG_ARRAY then value will be added to the list of values.
  • If the param type is ms_security_task::TYPE_USERS_ARRAY then value will be added to the list of values.
  • If the param type is ms_security_task::TYPE_ALL_USERS_ARRAY then value will be added to the list of values.
Returns:
true for any of the valid types above, otherwise return false because the expected parameter type is not correct.
bool addStringParam ( const std::string value )

Add a string parameter to the task.

This function will generally only be called by Administration utilities. For example, this could be a list of databases that may be searched.

See also isPermitted_string() which might be called by other applications to determine if a user has rights to run, for example, a search agains EST_others.

Parameters:
value
  • If the param type is ms_security_task::TYPE_EQ_STRING then value will replace the existing parameter.
  • If the param type is ms_security_task::TYPE_STRING_ARRAY then value will be added to the list of values.
Returns:
true for any of the valid types above, otherwise return false because the expected parameter type is not correct.
void clearParams ( )

Clears all parameters.

These parameters are not saved in the tasks file, but in the individual groups files.

std::string getAllParamsAsString ( ) const

Return all the parameters as a comma separated string.

This function is mostly useful for debugging, or possibly for an administration application.

Returns:
A comma separated string of values.
std::string getConstantName ( ) const

Returns the 'constant definition name' for the task.

Each task that has been predefined by Matrix Science will have a definition that can be used by applications calling Mascot Parser instead of just using the number (available from getID()). Any additional tasks added by end users will have a constant name, but this cannot be used in the calling code because it will not be embedded into the library.

Returns:
constant name of the task
std::string getDescription ( ) const

Returns a single line description for the task.

This should describe the task sufficiently well for an administrator.

Returns:
description of the task
std::vector< double > getDoubleParams ( ) const

Get the list of long parameters for the task.

If the task type is one of the following, then the function will return a single long value in the array:

  • ms_security_task::TYPE_EQ_DOUBLE
  • ms_security_task::TYPE_LTE_DOUBLE
  • ms_security_task::TYPE_GTE_DOUBLE

If the task type is ms_security_task::TYPE_DOUBLE_ARRAY then the function will return an array of long values.

For all other task types, the return value will be an empty array.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
vector of double param values, can be empty
int getID ( ) const

Returns the unique ID for the task.

IDs up to 1000 are reserved for use by Matrix Science. Values above 1000 may be used by other applications.

Returns:
id of the task
std::vector< long > getLongParams ( ) const

Get the list of long parameters for the task.

If the task type is one of the following, then the function will return a single long value in the array:

  • ms_security_task::TYPE_EQ_LONG
  • ms_security_task::TYPE_LTE_LONG
  • ms_security_task::TYPE_GTE_LONG

If the task type is ms_security_task::TYPE_LONG_ARRAY or TYPE_USERS_ARRAY or TYPE_ALL_USERS_ARRAY then the function will return an array of long values.

For all other task types, the return value will be an empty array.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
vector of long param values, can be empty
std::string getNotes ( ) const

Returns any notes applied to the task.

Optional notes to describe the values. Could be displayed by an administration utility for providing further help.

Returns:
notes of the task
std::vector< std::string > getStringParams ( ) const

Get the list of string parameters for the task.

If the task type is one of the following, then the function will return a single long value in the array:

  • ms_security_task::TYPE_EQ_STRING
  • ms_security_task::TYPE_LTE_STRING
  • ms_security_task::TYPE_GTE_STRING

If the task type is ms_security_task::TYPE_STRING_ARRAY then the function will return an array of long values.

For all other task types, the return value will be an empty array.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Returns:
vector of string param values, can be empty
bool isPermitted ( ) const

See if the task is permitted.

For example, this could called by an application to determine if a user has rights to access administration screens.

This function should only be called if the parameter type is ms_security_task::TYPE_BOOL in which case it will return true.

Returns:
true if the parameter type is ms_security_task::TYPE_BOOL, otherwise it will return false.
bool isPermitted_double ( const double value ) const

See if the value is in the floating point parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra (except this would use LONG rather than DOUBLE).

Parameters:
value
  • If the param type is ms_security_task::TYPE_EQ_DOUBLE and value is equal to the saved value, then this function will return true.
  • If the param type is ms_security_task::TYPE_LTE_DOUBLE and value is less than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_GTE_DOUBLE and value is greater than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_DOUBLE_ARRAY and value matches one of the values in the list of stored values, then function will return true.
Returns:
true if one of the conditions above is met, otherwise it will return false.
bool isPermitted_long ( const long value ) const

See if the value is in the long integer parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra.

Parameters:
value
  • If the param type is ms_security_task::TYPE_EQ_LONG and value is equal to the saved value, then this function will return true.
  • If the param type is ms_security_task::TYPE_LTE_LONG and value is less than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_GTE_LONG and value is greater than or equal to the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_LONG_ARRAY and value matches one of the values in the list of stored values, then function will return true.
  • If the param type is ms_security_task::TYPE_USERS_ARRAY and value matches one of the values in the list of stored values, then function will return true.
  • If the param type is ms_security_task::TYPE_ALL_USERS_ARRAY and value matches one of the values in the list of stored values, then function will return true.
Returns:
true if one of the conditions above is met, otherwise it will return false.
bool isPermitted_string ( const std::string value ) const

See if the value is in the string parameter list.

For example, this function could be called by an application to determine if a user has rights to run, for example, a search against EST_others.

Parameters:
value
  • If the param type is ms_security_task::TYPE_EQ_STRING and value matches the stored value, then this function will return true.
  • If the param type is ms_security_task::TYPE_STRING_ARRAY and value matches one of the stored values, then this function will return true.
Returns:
true if one of the conditions above is met, otherwise it will return false.
void setParams ( const std::string value )

Set all parameters, regardless of type.

This function will generally only be called by Administration utilities. It is useful when setting parameters from a general edit box. The text is parsed and if a list is expected, this will be split at commas or spaces.

Parameters:
value parameter value to set, can be a comma or space separated list
The documentation for this class was generated from the following files:
  • ms_security_task.hpp
  • ms_security_task.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_security_tasks
Public Types | Public Member Functions

ms_security_tasks Class Reference
[Mascot security and authentication module]

Each group has permission to do one or more tasks. This class defines a collection of tasks. More...

#include <ms_security_tasks.hpp>

Inheritance diagram for ms_security_tasks:
[legend]
Collaboration diagram for ms_security_tasks:
[legend]

List of all members.

Public Types

enum TASKID {
SECTASK_ALLOWPMF = 1,
SECTASK_ALLOWMSMS = 2,
SECTASK_ALLOWMSMSNOENZYME = 3,
SECTASK_ALLOWPMFNOENZYME = 4,
SECTASK_MAXCONCURRENTSEARCHES = 5,
SECTASK_MAXJOBPRIORITY = 6,
SECTASK_MAXQUERIES = 7,
SECTASK_MAXEXECUTIONTIME = 8,
SECTASK_ALLFASTA = 9,
SECTASK_NAMEDFASTA = 10,
SECTASK_MAXVARMODS = 11,
SECTASK_MAXETVARMODS = 12,
SECTASK_SEESEARCHINGROUP = 13,
SECTASK_SEEALLSEARCHESWITHUSERID = 14,
SECTASK_SEEOLDSEARCHES = 15,
SECTASK_USEMSREVIEWEXE = 16,
SECTASK_VIEWCONFIGUSINGMSSTATUS = 17,
SECTASK_MODIFYOWNPROFILE = 18,
SECTASK_DAEMONCLIENT = 19,
SECTASK_DISTILLERCLIENT = 20,
SECTASK_ALLOWSPOOFOTHERUSER = 22,
SECTASK_INTEGRASYSTEMACCOUNT = 23,
SECTASK_BIOTOOLSBATCH = 24,
SECTASK_SPOOFNAMEDGROUPSONLY = 25,
SECTASK_DOWNLOAD_DISTILLER_XML = 26,
SECTASK_UPLOAD_DISTILLER_XML = 27,
SECTASK_ADMINPAGES = 30,
SECTASK_ACCESSDBSETUP = 31,
SECTASK_USEMSSTATUSEXE = 32,
SECTASK_MSSTATUSEXECLUSTER = 33,
SECTASK_MSSTATUSEXERETRYDB = 34,
SECTASK_KILLTASKINGROUP = 35,
SECTASK_KILLALLTASK = 36,
SECTASK_VIEWCONFIG = 37,
SECTASK_EDITCONFIG = 38,
SECTASK_MAXETACCESSIONS = 50,
SECTASK_MAXNOENZQUERIES = 51,
SECTASK_MAXFASTAFILES = 52,
SECTASK_DENYQUANT = 53,
SECTASK_DATAURLPROTOCOLS = 54,
SECTASK_DATAURLMAXSIZE = 55,
SECTASK_SEESEARCHINANYGROUP = 60,
MISECTASK_ACCESS = 100,
MISECTASK_PROTEINAPPROVAL = 101,
MISECTASK_ADDIMPORTFILTER = 102,
MISECTASK_ADMIN = 103,
MISECTASK_ADDCUSTOMREPORT = 104,
MISECTASK_DELETECUSTOMREPORT = 105,
MISECTASK_ADDEXCLUSIONFILE = 106,
MISECTASK_DELETEEXCLUSIONFILE = 107,
MISECTASK_SENDNOTIFICATION = 108
}

Definitions for TASKID.

More...

Public Member Functions

ms_security_tasks ()
Create an empty list of tasks.
ms_security_tasks (const char *filename)
Load the list of tasks from file.
~ms_security_tasks ()
Destructor of the class.
bool | addTask (const ms_security_task &task)
Add a task to the list.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::string | getDiffsAsText (const ms_security_tasks &old)
Returns differences between the two task lists as text.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumberOfTasks () const
Returns the number of tasks in the collection.
ms_security_task | getTask (const int num) const
Returns a particular task.
ms_security_task | getTaskFromID (const int taskID) const
Returns a particular task.
bool | isFastaPermitted (const std::string database) const
See if a particular fasta file can be accessed.
bool | isPermitted (const int taskID) const
See if the task is permitted.
bool | isPermitted_double (const int taskID, const double value) const
See if the value is in the floating point parameter list.
bool | isPermitted_long (const int taskID, const long value) const
See if the value is in the long integer parameter list.
bool | isPermitted_string (const int taskID, const std::string value) const
See if the value is in the string parameter list.
bool | isTaskExists (const int taskID) const
Returns true if a task with this ID exists.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadFromFile (const char *filename)
Load definitions either from security_tasks.xml or from a group file.
void | removeAllTasks ()
Remove all tasks from the list.
bool | removeTask (const int taskID)
Remove a task from the list.
bool | saveToFile (const char *filename)
Save definitions either to the security_tasks.xml file or to a group file.
bool | updateTask (const ms_security_task &task)
Updates a task in the list with new parameters.

Detailed Description

Each group has permission to do one or more tasks. This class defines a collection of tasks.

There is currently no programmatic interface for saving task information, since this should normally only be done by developers.

Tasks are loaded from the file security_tasks.xml.

Parameters, for example, the maximum number of queries for a group, or the databases that can be used by a group are not saved in security_tasks.xml, but are saved as part of the group file. However, the type of the parameter is saved in security_tasks.xml.

Member Enumeration Documentation

enum TASKID

Definitions for TASKID.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Each task has one or more parameters associated with it. For example, "Access to administration pages" would have a boolean value. Other tasks such as "Maximum execution time" need a single number to determine the limit. security_tasks.xml has further information about each task.

Enumerator:
SECTASK_ALLOWPMF

SEARCH: Allow PMF searches.

SECTASK_ALLOWMSMS

SEARCH: Allow MS-MS (and SQ) searches.

SECTASK_ALLOWMSMSNOENZYME

SEARCH: Allow no-enzyme MSMS searche.

SECTASK_ALLOWPMFNOENZYME

SEARCH: Allow no-enzyme PMF searches.

SECTASK_MAXCONCURRENTSEARCHES

SEARCH: Maximum number of concurrent searches per user.

SECTASK_MAXJOBPRIORITY

SEARCH: Maximum mascot search job priority.

SECTASK_MAXQUERIES

SEARCH: Maximum number of queries per search.

SECTASK_MAXEXECUTIONTIME

SEARCH: Maximum execution time.

SECTASK_ALLFASTA

SEARCH: Allow all fasta databases to be searched.

SECTASK_NAMEDFASTA

SEARCH: Special fasta databases that override the default setting.

SECTASK_MAXVARMODS

SEARCH: Maximum number of variable modifications allowed for a standard search.

SECTASK_MAXETVARMODS

SEARCH: Maximum number of variable modifications allowed in an error tolerant search.

SECTASK_SEESEARCHINGROUP

VIEW: See search results from other people in your own group.

SECTASK_SEEALLSEARCHESWITHUSERID

VIEW: See all search results with a USERID.

SECTASK_SEEOLDSEARCHES

VIEW: See search results without USERID field.

SECTASK_USEMSREVIEWEXE

VIEW: Allow user to view the search log.

SECTASK_VIEWCONFIGUSINGMSSTATUS

GENERAL: View config files using ms-status.

SECTASK_MODIFYOWNPROFILE

GENERAL: Allow user to modify their own profile.

SECTASK_DAEMONCLIENT

CLIENT: Mascot Daemon is allowed to submit searches.

SECTASK_DISTILLERCLIENT

CLIENT: Mascot Distiller is allowed to submit searches.

SECTASK_ALLOWSPOOFOTHERUSER

CLIENT: For Mascot Daemon, allow spoofing of another user.

SECTASK_INTEGRASYSTEMACCOUNT
Deprecated:
CLIENT: Integra system account.
SECTASK_BIOTOOLSBATCH

CLIENT: Bruker BioTools batch searches.

SECTASK_SPOOFNAMEDGROUPSONLY

CLIENT: For Mascot Daemon, restrict spoofing to the named group(s).

SECTASK_DOWNLOAD_DISTILLER_XML

CLIENT: Client is allowed to download Distiller XML files.

SECTASK_UPLOAD_DISTILLER_XML

CLIENT: Client is allowed to upload Distiller XML files.

SECTASK_ADMINPAGES

ADMIN: Use the security administration utility.

SECTASK_ACCESSDBSETUP

ADMIN: Access to the Database Maintenance application.

SECTASK_USEMSSTATUSEXE

ADMIN: Allow use of Database Status application.

SECTASK_MSSTATUSEXECLUSTER

ADMIN: Allow user to see cluster pages in ms-status.exe.

SECTASK_MSSTATUSEXERETRYDB

ADMIN: Allow user to retry a failed database or recompress files using ms-status.exe.

SECTASK_KILLTASKINGROUP

ADMIN: Kill / pause / change priority of searches from own group.

SECTASK_KILLALLTASK

ADMIN: Kill / pause / change priority of searches from other groups.

SECTASK_VIEWCONFIG

ADMIN: Access to the configuration editor to view configuration files.

SECTASK_EDITCONFIG

ADMIN: Access to the configuration editor to edit configuration files.

SECTASK_MAXETACCESSIONS

SEARCH: Maximum number of accessions allowed in an old style error tolerant search.

SECTASK_MAXNOENZQUERIES

SEARCH: Maximum number of queries for a no enzyme search. If not specified, SECTASK_MAXQUERIES will be used.

SECTASK_MAXFASTAFILES

SEARCH: Maximum number of fasta files in a single search.

SECTASK_DENYQUANT

SEARCH: Prevent the use of quantitation methods in a search.

SECTASK_DATAURLPROTOCOLS

SEARCH: Allow submitting searches with DATAURL parameter.

SECTASK_DATAURLMAXSIZE

SEARCH: Maximum number of bytes to download for DATAURL.

SECTASK_SEESEARCHINANYGROUP

VIEW: See search results from any user in any group you belong to.

MISECTASK_ACCESS

INSIGHT: Access to Mascot Insight.

MISECTASK_PROTEINAPPROVAL

INSIGHT: Protein approval in Mascot Insight.

MISECTASK_ADDIMPORTFILTER

INSIGHT: Add import assignment filter.

MISECTASK_ADMIN

INSIGHT: Mascot Insight administration functions.

MISECTASK_ADDCUSTOMREPORT

INSIGHT: Add custom report to Mascot Insight.

MISECTASK_DELETECUSTOMREPORT

INSIGHT: Delete custom report Mascot Insight.

MISECTASK_ADDEXCLUSIONFILE

INSIGHT: Add BlastCluster exclusion file.

MISECTASK_DELETEEXCLUSIONFILE

INSIGHT: Delete BlastCluster exclusion file.

MISECTASK_SENDNOTIFICATION

INSIGHT: Send notification.

Constructor & Destructor Documentation

ms_security_tasks ( )

Create an empty list of tasks.

Default constructor does nothing. Need to call loadFromFile() or addTask() to assign tasks to the list.

~ms_security_tasks ( )

Destructor of the class.

The destructor is never called directly.

Member Function Documentation

bool addTask ( const ms_security_task & task )

Add a task to the list.

If there is already a task with this ID, then the two will be 'combined'. For example, assume that the task SECTASK_ALLOWNAMEDFASTA is already in the list with NCBInr as a parameter. If this function is called with the same task, but MSDB as a parameter, then the resulting task will have MSDB and NCBInr as parameters.

Similarly, if the task SECTASK_MAXQUERIES is already in the list with a value of 300, and a new task is added with a value of 1000, then the value 1000 will be used. For the types ms_security_task::TYPE_EQ_LONG, ms_security_task::TYPE_EQ_DOUBLE and ms_security_task::TYPE_EQ_STRING, the parameter for the new task being added will replace the existing task parameter.

Parameters:
task is the new task to be added to the list.
Returns:
True if the function succeeds. The function should not normally fail.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
std::string getDiffsAsText ( const ms_security_tasks & old )

Returns differences between the two task lists as text.

Primarily used for logging.

Parameters:
old ms_security_tasks object to diff
Returns:
all differences as a string
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getNumberOfTasks ( ) const

Returns the number of tasks in the collection.

Use this value when trying to retrieve all tasks using getTask().

Returns:
number of tasks
ms_security_task getTask ( const int num ) const

Returns a particular task.

Parameters:
num should be in the range 0.. getNumberOfTasks() -1
Returns:
an ms_security_task object. If there was an error, the id for this security object will be -1.
ms_security_task getTaskFromID ( const int taskID ) const

Returns a particular task.

Find a task in the collection given its ID.

Parameters:
taskID should be a valid taskID.
Returns:
an ms_security_task object. If there was an error, the id for this security object will be -1.
bool isFastaPermitted ( const std::string database ) const

See if a particular fasta file can be accessed.

Check if a user has rights to search against a particular database This is a special case because SECTASK_NAMEDFASTA is the only 'negative' task (and only if SECTASK_ALLFASTA is set), so this specific call makes end user programs simpler.

Parameters:
database is the database name -- for example MSDB.
Returns:
True if the user has rights to search this database.
bool isPermitted ( const int taskID ) const

See if the task is permitted.

For example, this could called by an application to determine if a user has rights to access administration screens.

This function should only be called if the parameter type of taskID is ms_security_task::TYPE_BOOL.

Parameters:
taskID The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_ADMINPAGES.
Returns:
true if the parameter type is ms_security_task::TYPE_BOOL, and the specified task in the list of tasks otherwise it will return false.
bool isPermitted_double | ( | const int | taskID,
 |  | const double | value
 | ) |  | const

See if the value is in the floating point parameter list.

See also:
ms_security_task::isPermitted_double()
Parameters:
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns:
True if the tasks is permitted.
bool isPermitted_long | ( | const int | taskID,
 |  | const long | value
 | ) |  | const

See if the value is in the long integer parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra.

See also:
ms_security_task::isPermitted_long()
Parameters:
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns:
True if the tasks is permitted.
bool isPermitted_string | ( | const int | taskID,
 |  | const std::string | value
 | ) |  | const

See if the value is in the string parameter list.

For example, this could called by an application to determine if a user has rights to run a search against the MSDB database.

See also:
isFastaPermitted(), ms_security_task::isPermitted_string()
Parameters:
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_NAMEDFASTA.
value | Is the value for comparison.
Returns:
True if the tasks is permitted.
bool isTaskExists ( const int taskID ) const

Returns true if a task with this ID exists.

Parameters:
taskID Task ID to check.
Returns:
true if a task with this ID exists; false otherwise.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void removeAllTasks ( )

Remove all tasks from the list.

The result will then be an empty list.

bool removeTask ( const int taskID )

Remove a task from the list.

Parameters:
taskID Should be a valid task ID.
Returns:
True if the task was in the list and was deleted.
bool updateTask ( const ms_security_task & task )

Updates a task in the list with new parameters.

Parameters:
task Replace the definition for a task in the list with this.
Returns:
True if the task was already in the list.
The documentation for this class was generated from the following files:
  • ms_security_tasks.hpp
  • ms_security_tasks.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_session
Public Member Functions

ms_session Class Reference
[Mascot security and authentication module]

Use this class to determine if a user is logged in and if they have 'permission' to perform tasks. More...

#include <ms_security_session.hpp>

Inheritance diagram for ms_session:
[legend]
Collaboration diagram for ms_session:
[legend]

List of all members.

Public Member Functions

ms_session (const std::string session_id="")
Use this constructor to open the current session.
ms_session (const std::string userName, const std::string userPassword)
Use this constructor to start a new secure session.
ms_session (const int timeout, const std::string prefix)
Use this constructor to start a new session independent of users and Mascot security.
ms_session (const std::string userName, const std::string connectionID, const std::string database)
This constructor is used by Mascot integra to login to Mascot.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
bool | canResultsFileBeViewed (const int userID) const
Check if a results file with the passed user ID can be viewed.
void | clearAllErrors ()
Remove all errors from the current list of errors.
bool | clearParam (const std::string name)
Remove a custom parameter from the session file.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | destroy ()
Destroy the current session. Should be called when a user logs out.
bool | getBoolParam (const std::string name, bool &param) const
Return a custom 'bool' parameter from the session file.
bool | getDoubleParam (const std::string name, double &param) const
Return a custom 'double' parameter from the session file.
double | getDoubleParam (const std::string name) const
Return a custom 'double' parameter from the session file.
std::string | getEmailAddress () const
Return the email address for the currently logged in user.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFullUserName () const
Return the full name for the currently logged in user.
std::string | getID () const
Return the sessionID for this session file.
bool | getIntParam (const std::string name, int &param) const
Return a custom 'integer' parameter from the session file.
int | getIntParam (const std::string name) const
Return a custom 'integer' parameter from the session file.
std::string | getIPAddress () const
Return ip address of the currently logged in user.
time_t | getLastAccessed () const
Returns the time that the session was last updated.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getLongParam (const std::string name, long &param) const
Return a custom 'long' parameter from the session file.
long | getLongParam (const std::string name) const
Return a custom 'long' parameter from the session file.
std::map< std::string,
std::string > 		getParams () const
Returns a list of all the parameters saved in the session file.
matrix_science::ms_security_tasks | getPermittedTasks () const
Returns the permitted tasks for the currently logged in user.
std::vector< int > | getSpoofableUsers () const
Returns a list of user IDs that can be spoofed.
std::string | getStringParam (const std::string name) const
Return a custom 'string' parameter from the session file.
bool | getStringParam (const std::string name, std::string &param) const
Return a custom 'string' parameter from the session file.
time_t | getTimeout () const
Returns the time when the session times out.
bool | getTimeParam (const std::string name, time_t &param) const
Return a custom 'time' parameter from the session file.
time_t | getTimeParam (const std::string name) const
Return a custom 'time' parameter from the session file.
int | getUserID () const
Return the unique userid for the currently logged in user.
std::string | getUserName () const
Return the user 'login' name for the currently logged in user.
matrix_science::ms_user::usertype | getUserType () const
Returns the type of user.
bool | isFastaPermitted (const std::string database) const
Check if a particular fasta file can be accessed.
bool | isPermitted (const int taskID) const
Check if the task is permitted.
bool | isPermitted_double (const int taskID, const double value) const
Check if the value is in the floating point parameter list.
bool | isPermitted_long (const int taskID, const long value) const
Check if the value is in the long integer parameter list.
bool | isPermitted_string (const int taskID, const std::string value) const
Check if the value is in the string parameter list.
bool | isSecurityEnabled () const
Return true if the security system is enabled.
bool | isTimedOut () const
Returns true if the current session has timed out.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | saveBoolParam (const std::string name, bool param)
Save a custom 'bool' parameter in the session file.
bool | saveDoubleParam (const std::string name, double param)
Save a custom 'double' parameter in the session file.
bool | saveIntParam (const std::string name, int param)
Save a custom 'integer' parameter in the session file.
bool | saveLongParam (const std::string name, long param)
Save a custom 'long integer' parameter in the session file.
bool | saveStringParam (const std::string name, const std::string param)
Save a custom 'string' parameter in the session file.
bool | saveTimeParam (const std::string name, time_t param)
Save a custom 'time' parameter in the session file.
bool | setPermittedTasks (const matrix_science::ms_security_tasks &val)
Sets the permitted tasks for the currently logged in user.
bool | update (const ms_security &sec)
Only needs to be called by administration applications after user rights have changed.

Detailed Description

Use this class to determine if a user is logged in and if they have 'permission' to perform tasks.

This is the only security class that most applications will need to use. This class should be used even if security is disabled because the underlying structure deals with this. If security is disabled, then isValid() and isPermitted() will both return true.

Session information is saved in files in the ../sessions directory. The session files have the same name as the session id which will be of the general form 'username_uniquenumber'. The unique number is assigned by the system and the username is the login name.

Special cases are as follows:

Session Name | Description
[username]_[random_number] | Session name for a normal user.
[username]_webserverauth | Session name for a user logged in using web authentication. This session file is created/modified when the user is modified. It is not possible to use this session id unless the user is 'logged into' the web server using the name 'username'
all_secdisabledsession | The Mascot security system is not enabled. This session file will only exist if security is disabled. Attempts to use it when security is enabled will fail.
cmd_cmdlinesession | Any applications run directly from a shell or command prompt will use this session id. Any script run directly as a cgi application (or chained from a cgi script) will not be able to use this session id.
guest_guestsession | Any user who is logged in as 'guest'. If the guest account is not enabled, this session will not be available
[name]_computername | for 3rd party applications that have not implemented Mascot security, it is possible to specify a computer name rather than a login name and password.
[ipaddr]_computeripaddress | For 3rd party applications that have not implemented Mascot security, it is possible to specify an ip address rather than a login name and password.
[string]_agentstring | Agent string such as 'Mozilla'. Will only be used a last resort by third party applications.
integradb@name_session | Mascot integra user. The integradb is the value returned by: ms_security_options::getIntegraDatabaseName(). Internally, this session id will be translated into a Mascot Integra session string by replacing the @ with a pipe symbol, and removing the underscore between the name and the session. The Mascot cookie will be this session id, and not the Integra connection string. There is a special case of the user being (system).

Constructor & Destructor Documentation

ms_session ( const std::string session_id = "" )

Use this constructor to open the current session.

Call isValid() to check that a session was opened. If isValid() returns false, then getLastError() should be called to determine an appropriate action, such as asking a user to login.

A successful call to this constructor will cause the last accessed time to be updated (for ms_user::USER_NORMAL only).

If the session_id parameter is empty, then this constructor will try the following in turn:

  • Try to find the session_id from a cookie (MASCOT_SESSION=).
  • If the program is being run from the command line (no REMOTE_USER environment variable set) use cmd_cmdlinesession, with all access rights.
  • If security is disabled, then a disabled security session will be created.
  • If integrated web server authentication is enabled, check REMOTE_USER -- if that fails, try guest.
  • If a computer name/IP address has been specified as a work-around for 3rd party applications, try that.
  • If a guest account has been enabled use that.

isPermitted() should be then be called as required to determine if the user can perform certain actions.

Possible errors, and suitable actions for an interactive application, are:

  • ms_errs::ERR_MSP_SECURITY_NOTLOGGEDIN - ask the user to login.
  • ms_errs::ERR_MSP_SECURITY_DIFFERENTIPADDR - display an error message and ask user to login again.
  • ms_errs::ERR_MSP_SECURITY_TIMEDOUT - ask the user to login again.
  • ms_errs::ERR_MSP_SECURITY_MISSINGSESSIONFILE - similar to timeout, so ask the user to login again.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT1 - ask the user to try again, and if this fails contact their Administrator.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT2 - ask the user to try again, and if this fails contact their Administrator.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT3 - ask the user to try again, and if this fails contact their Administrator.
  • ms_errs::ERR_MSP_SECURITY_SPOOFATTEMPT4 - ask the user to try again, and if this fails contact their Administrator.
Parameters:
session_id If session_id is empty, then this constructor will try to find session_id from a cookie (MASCOT_SESSION=).
ms_session | ( | const std::string | userName,
 |  | const std::string | userPassword
 | ) |  |

Use this constructor to start a new secure session.

The value from getID() should the be saved in a cookie.

Possible errors, and suitable actions for an interactive application, are:

  • ms_errs::ERR_MSP_SECURITY_NOT_ENABLED - no action.
  • ms_errs::ERR_MSP_SECURITY_INVALIDUSER - ask the user to try again.
  • ms_errs::ERR_MSP_SECURITY_INVALIDPASSWORD - ask the user to try again.
  • ms_errs::ERR_MSP_SECURITY_PASSWORDEXPIRED - put up a screen with old password, new password and then call ms_security::updatePassword().
  • ms_errs::ERR_MSP_SECURITY_ACCOUNT_DISABLED - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_NOTNORMALUSER - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_SAVESESSIONFILE - ask the user to contact the administrator.
  • (deprecated) ms_errs::ERR_MSP_SECURITY_FAILGETINTEGRAURL - ask the user to check the Mascot Integra server.
  • (deprecated) ms_errs::ERR_MSP_SECURITY_NO_INTEGRA_LOGIN - ask the user to login from Mascot Integra.
Parameters:
userName | is the user name entered by the user.
userPassword | is the unencrypted password.
ms_session | ( | const std::string | userName,
 |  | const std::string | connectionID,
 |  | const std::string | database
 | ) |  |

This constructor is used by Mascot integra to login to Mascot.

Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.

This constructor should only be used from Mascot Integra, or an application running in the Integra environment. The Integra application will have access to the currently logged in user name, and also to the Integra connectionID.

Possible errors, and suitable actions for an interactive application, are:

  • ms_errs::ERR_MSP_SECURITY_INVALIDUSER - add this user to the Mascot security.
  • ms_errs::ERR_MSP_SECURITY_ACCOUNT_DISABLED - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_SAVESESSIONFILE - ask the user to contact the administrator.
  • ms_errs::ERR_MSP_SECURITY_FAILGETINTEGRAURL - ask the user to check the Mascot Integra server.
  • ms_errs::ERR_MSP_SECURITY_NOT_INTEGRA_USER - The 'type' of user needs to be changed to a Mascot Integra user using the Mascot security administration application.

If this function succeeds, it will set session_id to a session variable of the form database@userName_connectionID.

Parameters:
userName | is the Integra user name.
connectionID | is the Integra connection string.
database | is the name of the Mascot integra database.
ms_session | ( | const int | timeout,
 |  | const std::string | prefix
 | ) |  |

Use this constructor to start a new session independent of users and Mascot security.

Parameters:
timeout | is the inactivity time in seconds before the session becomes timed out. A value of zero indicates it will never time out.
prefix | is a prefix to be used as the session id: will be of the form prefix_randomnumber.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
bool canResultsFileBeViewed ( const int userID ) const

Check if a results file with the passed user ID can be viewed.

This is a helper function to make end user programs simpler.

Parameters:
userID is the USERID value from the results file. Old results files don't have this value, in which case ms_searchparams::getUSERID() will return 0.
Returns:
True if the user has rights to view this results file.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
bool clearParam ( const std::string name )

Remove a custom parameter from the session file.

Use this function when you no longer want a value associated with a key name.

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
boolean value to indicate if the value was successfully removed.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
bool destroy ( )

Destroy the current session. Should be called when a user logs out.

The session file is deleted and all user parameters are removed. Don't attempt to use the object after calling destroy().

Returns:
True if the session was deleted. An attempt to delete the session file for a guest user, command line session, or authentication disabled will fail and return false.
bool getBoolParam | ( | const std::string | name,
 |  | bool & | param
 | ) |  | const

Return a custom 'bool' parameter from the session file.

Note:
This function should not be used from programming languages other than C++. Use getBoolParam(const std::string) const instead.
See also:
saveBoolParam()

See also Using custom parameters

Parameters:
name | name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
double getDoubleParam ( const std::string name ) const

Return a custom 'double' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also:
saveDoubleParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
The value of the parameter associated with the key name.
bool getDoubleParam | ( | const std::string | name,
 |  | double & | param
 | ) |  | const

Return a custom 'double' parameter from the session file.

Note:
This function should not be used from programming languages other than C++. Use getDoubleParam(const std::string) const instead.
See also:
saveDoubleParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
The value of the parameter associated with the key name.
std::string getEmailAddress ( ) const

Return the email address for the currently logged in user.

Note that there is no guarantee that this is a valid email address.

Returns:
email address for this session
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFullUserName ( ) const

Return the full name for the currently logged in user.

See also:
getUserName()
Returns:
full user name for this session
std::string getID ( ) const

Return the sessionID for this session file.

This the same as the session filename. If isValid() returns false, this will return an empty string. System session ids are described in ms_session::ms_session.

Returns:
id of the session
bool getIntParam | ( | const std::string | name,
 |  | int & | param
 | ) |  | const

Return a custom 'integer' parameter from the session file.

Note:
This function should not be used from programming languages other than C++. Use getIntParam(const std::string) const instead.
See also:
saveIntParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
int getIntParam ( const std::string name ) const

Return a custom 'integer' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also:
saveIntParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
The value of the parameter associated with the key name.
std::string getIPAddress ( ) const

Return ip address of the currently logged in user.

Will be 'UNKNOWN' if authentication is turned off and for the guest account.

Returns:
IP address
time_t getLastAccessed ( ) const

Returns the time that the session was last updated.

Note that this time is not valid if authentication is turned off or the guest account is in use.

Returns:
last access time
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getLongParam | ( | const std::string | name,
 |  | long & | param
 | ) |  | const

Return a custom 'long' parameter from the session file.

Note:
This function should not be used from programming languages other than C++. Use getLongParam(const std::string) const instead.
See also:
saveLongParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
long getLongParam ( const std::string name ) const

Return a custom 'long' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also:
saveLongParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
The value of the parameter associated with the key name.
std::map< std::string, std::string > getParams ( ) const

Returns a list of all the parameters saved in the session file.

Note:
Do not use this function from programming languages other than C++.
Returns:
array of key, value pairs.
ms_security_tasks getPermittedTasks ( ) const

Returns the permitted tasks for the currently logged in user.

Returns:
A 'list' of the tasks that can be performed by the user.
std::vector< int > getSpoofableUsers ( ) const

Returns a list of user IDs that can be spoofed.

This will return an empty list if ms_security_tasks::SECTASK_ALLOWSPOOFOTHERUSER has not been specified.

If ms_security_tasks::SECTASK_SPOOFNAMEDGROUPSONLY is not specified, then this function returns all users by calling ms_security::getAllUserIDs().

If ms_security_tasks::SECTASK_SPOOFNAMEDGROUPSONLY is specified, then only users belonging to the names groups will be returned. This could be an empty list if the named groups don't contain any users or if there is no list of groups.

When ms-status.exe (or get_params.pl) is called with the parameter Show=MS_USERS, this function is called to create a list of users. The output format from these programs is:

   "username","user id","user type","full name","email address"

For example:

    C:\Inetpub\mascot\x-cgi>ms-status.exe Show=MS_USERS
    Content-type: text/plain

    "guest","1","1","Guest user","guest@localhost"
    "admin","2","1","Administrator","admin@localhost"
    "daemon","4","1","Mascot Daemon","daemon@localhost"
    "(system)","6","2","Mascot Integra system account","integra@localhost"
Returns:
a vector of IDs that can be spoofed, sorted by login names. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
bool getStringParam | ( | const std::string | name,
 |  | std::string & | param
 | ) |  | const

Return a custom 'string' parameter from the session file.

Note:
This function should not be used from programming languages other than C++. Use getStringParam(const std::string) const instead.
See also:
saveStringParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
std::string getStringParam ( const std::string name ) const

Return a custom 'string' parameter from the session file.

If an empty string is returned, it is not possible to determine if this is because there is no key value or if an empty string was set for the key.

See also:
saveStringParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
Is the value of the parameter associated with the key name or an empty string if there is no key.
time_t getTimeout ( ) const

Returns the time when the session times out.

Note that the timeout is not valid if authentication is turned off or the guest account is in use.

A value of zero indicates it will never time out.

Note also that the timeout is set globally in the security settings, so the return value of this function is the same as calling ms_security_options::getSessionTimeout() . The only case where the two can differ is if 1) the user logs in and 2) the session timeout is changed globally after that.

Returns:
timeout
time_t getTimeParam ( const std::string name ) const

Return a custom 'time' parameter from the session file.

If a value of 0 is returned, it is not possible to determine if this is because there is no key value or if a value of zero was set for the key.

See also:
saveTimeParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
The value of the parameter associated with the key name.
bool getTimeParam | ( | const std::string | name,
 |  | time_t & | param
 | ) |  | const

Return a custom 'time' parameter from the session file.

Note:
This function should not be used from programming languages other than C++. Use getTimeParam(const std::string) const instead.
See also:
saveTimeParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
int getUserID ( ) const

Return the unique userid for the currently logged in user.

Returns:
The unique user id of the person logged in. There are several predefined IDs - see ms_user::systemids. Returns -1 if there is an error.
std::string getUserName ( ) const

Return the user 'login' name for the currently logged in user.

Note that this will not include spaces. The full user name is available by calling: getFullUserName().

Returns:
user name for this session
ms_user::usertype getUserType ( ) const

Returns the type of user.

Returns:
The user type as defined by the administrator using the administration utility.
bool isFastaPermitted ( const std::string database ) const

Check if a particular fasta file can be accessed.

Check if a user has rights to search against a particular database This is a special case because SECTASK_NAMEDFASTA is the only 'negative' task (and only if SECTASK_ALLFASTA is set), so this specific call makes end user programs simpler.

See also:
ms_security_tasks::isFastaPermitted()
Parameters:
database is the database name -- for example MSDB.
Returns:
True if the user has rights to search this database.
bool isPermitted ( const int taskID ) const

Check if the task is permitted.

Returns true if the user is allowed to perform the task. If security is disabled, then this always returns true.

Parameters:
taskID Task IDs are stored in security_tasks.xml file.
Returns:
true if the user can accomplish the given task
bool isPermitted_double | ( | const int | taskID,
 |  | const double | value
 | ) |  | const

Check if the value is in the floating point parameter list.

See also:
ms_security_task::isPermitted_double()
Parameters:
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns:
True if the tasks is permitted.
bool isPermitted_long | ( | const int | taskID,
 |  | const long | value
 | ) |  | const

Check if the value is in the long integer parameter list.

For example, this could called by an application to determine if a user has rights to run a search with 1000 spectra.

See also:
ms_security_task::isPermitted_long()
Parameters:
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_MAXQUERIES.
value | is the value for comparison.
Returns:
True if the tasks is permitted.
bool isPermitted_string | ( | const int | taskID,
 |  | const std::string | value
 | ) |  | const

Check if the value is in the string parameter list.

For example, this could called by an application to determine if a user has rights to run a search against the MSDB database.

See also:
ms_security_task::isPermitted_string()
Parameters:
taskID | The taskID normally from the matrix_science::ms_security_tasks::TASKID enumeration -- for example, matrix_science::ms_security_tasks::SECTASK_NAMEDFASTA.
value | is the value for comparison.
Returns:
True if the tasks is permitted.
bool isSecurityEnabled ( ) const

Return true if the security system is enabled.

If this returns false, then isPermitted() will also always return true.

Returns:
true if security is enabled, false otherwise
bool isTimedOut ( ) const

Returns true if the current session has timed out.

Some sessions such as the commandline session will never time out.

Returns:
boolean value to indicate if the session has timed out.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool saveBoolParam | ( | const std::string | name,
 |  | bool | param
 | ) |  |

Save a custom 'bool' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getBoolParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
bool saveDoubleParam | ( | const std::string | name,
 |  | double | param
 | ) |  |

Save a custom 'double' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getDoubleParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
bool saveIntParam | ( | const std::string | name,
 |  | int | param
 | ) |  |

Save a custom 'integer' parameter in the session file.

This can be useful for saving additional information that will be available to a CGI program later on in the same session. The value can be retrieved using getIntParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
bool saveLongParam | ( | const std::string | name,
 |  | long | param
 | ) |  |

Save a custom 'long integer' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getLongParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
bool saveStringParam | ( | const std::string | name,
 |  | const std::string | param
 | ) |  |

Save a custom 'string' parameter in the session file.

This can be useful for saving additional information that will be available to a CGI program later on in the same session. The value can be retrieved using getStringParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
bool saveTimeParam | ( | const std::string | name,
 |  | time_t | param
 | ) |  |

Save a custom 'time' parameter in the session file.

This can be useful for saving additional information that will be available to a cgi program later on in the same session. The value can be retrieved using getTimeParam().

This function will fail if isValid() is false.

There is just one list of parameters saved in the session for all types, so the same name shouldn't be used for say both integer and string values.

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
bool setPermittedTasks ( const matrix_science::ms_security_tasks & val )

Sets the permitted tasks for the currently logged in user.

This function is called by the administration utility so that it can save a list of tasks in a temporary session. It shouldn't normally be called by other applications.

Parameters:
val is the 'list' of the tasks that can be performed by the user.
Returns:
true if everything is valid and no error occurred, false otherwise
The documentation for this class was generated from the following files:
  • ms_security_session.hpp
  • ms_security_session.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_user
Public Types | Public Member Functions

ms_user Class Reference
[Mascot security and authentication module]

This class will normally only be used by Mascot Security Administration applications. More...

#include <ms_security_user.hpp>

List of all members.

Public Types

enum systemids {
USERID_SECURITY_DISABLED = 0x0000,
USERID_GUEST = 0x0001,
USERID_ADMINISTRATOR = 0x0002,
USERID_CMDLINE = 0x0003,
USERID_DAEMON = 0x0004,
USERID_PUBLIC_SEARCHES = 0x0005,
USERID_INTEGRA_SYSTEM = 0x0006,
USERID_LAST = 0x0007
}

Definitions for predefined users.

More...
enum usertype {
USER_SECURITY_DISABLED = 0x0000,
USER_NORMAL = 0x0001,
USER_INTEGRA = 0x0002,
USER_COMPUTER_NAME = 0x0003,
USER_IP_ADDRESS = 0x0004,
USER_AGENT_STRING = 0x0005,
USER_WEBAUTH = 0x0006
}

Definitions for types of user.

More...

Public Member Functions

ms_user (const int userID, const std::string userName, const std::string password, const long passwordExpiry, const std::string fullName, const std::string emailAddress, const usertype userType, const bool enabled)
Create a new user.
ms_user ()
Create a new 'empty' user with no name, password, ID.
bool | clearParam (const std::string name)
Remove an additional user parameter associated with the user.
std::string | getEmailAddress () const
Returns the email address of the user.
std::string | getEncryptedPassword () const
Returns the encrypted password.
std::string | getFullName () const
Return the full user name.
int | getID () const
Return the unique user ID.
std::string | getName () const
Return the user login name.
time_t | getPasswordExpiry () const
Returns the time that the password will expire.
bool | getStringParam (const std::string name, std::string &param) const
Return a custom parameter for the user.
std::string | getStringParam (const std::string name) const
Return a custom parameter for the user.
usertype | getUserType () const
Return the 'type' of user.
bool | hasPasswordExpired () const
Returns true if the password has expired.
bool | isAccountEnabled () const
Return true if the account is enabled.
bool | saveStringParam (const std::string name, const std::string param)
Save an additional 'string' parameter for the user.
void | setAccountEnabled (bool newVal)
Pass true to enable the account.
void | setEmailAddress (std::string newVal)
Sets the email address of the user.
void | setEncryptedPassword (std::string newVal)
Update the encrypted password - details are saved immediately.
void | setFullName (std::string newVal)
Update the full user name -- details are saved immediately.
void | setID (int newVal)
Set the unique user ID.
void | setName (std::string newVal)
Set the user login name.
void | setPassword (std::string barePassword)
Encrypt and save the passed password.
void | setPasswordExpiry (time_t newVal)
Set the password expiry time.
void | setUserType (usertype newVal)
Update the user type -- details are saved immediately.
bool | validatePassword (const std::string pwd, int &errorFlag) const
Checks to see if the password is correct for the user.

Detailed Description

This class will normally only be used by Mascot Security Administration applications.

Call ms_security::addNewUser() to create a new user or ms_security::getUser() or ms_security::getUserFromID() to get an existing user, and then use the ms_user member functions to query or modify the ms_user object.

To make the changes permanent, use ms_security::updateUser().

Member Enumeration Documentation

enum systemids

Definitions for predefined users.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
USERID_SECURITY_DISABLED

Only valid if security is disabled.

USERID_GUEST

The built in guest user. Note that this accound is disabled by default.

USERID_ADMINISTRATOR

The built in administrator account. Cannot be deleted or disabled.

USERID_CMDLINE

Applications run from the command line rather than as a cgi application use this by default.

USERID_DAEMON

Mascot Daemon will use this user to run searches.

USERID_PUBLIC_SEARCHES

Example files use this user id. matrix_science::ms_session::canResultsFileBeViewed always returns true for this ID.

USERID_INTEGRA_SYSTEM
Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later.
USERID_LAST

Placeholder.

enum usertype

Definitions for types of user.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
USER_SECURITY_DISABLED

Not a real user, but the USERID if security is disabled.

USER_NORMAL

A 'normal' Mascot user, that doesn't fit into any of the other categories below.

USER_INTEGRA
Deprecated:
Mascot Integra is not supported in Mascot Parser 2.5 and later. Login etc. is done through Mascot Insight.
USER_COMPUTER_NAME

This type of user is defined by a computer name. Should only be used for 3rd party applications.

USER_IP_ADDRESS

This type of user is defined by an IP address. Should only be used for 3rd party applications.

USER_AGENT_STRING

This type of user is defined by a client agent string. Should only be used for 3rd party applications as a last resort.

USER_WEBAUTH

The configuration is to use web server authentication, so this user has no password.

Member Function Documentation

bool clearParam ( const std::string name )

Remove an additional user parameter associated with the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

Use this function when you no longer want a value associated with a key name for a user.

To make the changes permanent, use ms_security::updateUser().

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
boolean value to indicate if the value was successfully removed.
std::string getEmailAddress ( ) const

Returns the email address of the user.

This is not a required field, which means the return value may be the empty string.

Returns:
email address
std::string getEncryptedPassword ( ) const

Returns the encrypted password.

Unlikely to be useful for most applications. It is not possible to retrieve the unencrypted password from the system, and the value returned from this function will not be the same as the value passed to ms_user::setPassword().

Returns:
The encrypted password.
std::string getFullName ( ) const

Return the full user name.

Useful for displaying the full name in reports etc.

Returns:
The current full (long) user name.
int getID ( ) const

Return the unique user ID.

The unique user ID for the user. This should never be changed, since all searches are saved with the USERID equal to this value. Special user IDs are the same as the values in ms_user::systemids.

Returns:
The current user ID.
time_t getPasswordExpiry ( ) const

Returns the time that the password will expire.

The time in seconds since January 1st 1970. A value of '0'is used to indicate that the password should never expire.

Returns:
The current password expiry date.
bool getStringParam | ( | const std::string | name,
 |  | std::string & | param
 | ) |  | const

Return a custom parameter for the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

Note:
This function should not be used from programming languages other than C++. Use getStringParam(const std::string) const instead.
See also:
saveStringParam()

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | Is the value of the parameter associated with the key name.
Returns:
boolean value to indicate if the value was successfully retrieved.
std::string getStringParam ( const std::string name ) const

Return a custom parameter for the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

If an empty string is returned, it is not possible to determine if this is because there is no key value or if an empty string was set for the key.

See also:
saveStringParam()

See also Using custom parameters

Parameters:
name Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
Returns:
Is the value of the parameter associated with the key name or an empty string if there is no key.
ms_user::usertype getUserType ( ) const

Return the 'type' of user.

See also:
ms_user::setUserType().
Returns:
user type
bool hasPasswordExpired ( ) const

Returns true if the password has expired.

If the password expiry value is zero, the password will never expire. An expiry value of 1 may be used to indicate that the user should change their password when they first log in.

Returns:
True if the password has expired.
bool saveStringParam | ( | const std::string | name,
 |  | const std::string | param
 | ) |  |

Save an additional 'string' parameter for the user.

Additional custom data for a user are saved in a <mss:custom_parameters> section in the user.xml file.

The value can be retrieved using getStringParam().

To make the changes permanent, use ms_security::updateUser().

See also Using custom parameters

Parameters:
name | Name of the key value. Do not use an name with a leading underscore as these are reserved for system values.
param | The value to be assigned to the key.
Returns:
true if the value is successfully saved.
void setAccountEnabled ( bool newVal )

Pass true to enable the account.

To make the changes permanent, use ms_security::updateUser().

Parameters:
newVal Set to true to enable the account, and false to disable the account.
void setEmailAddress ( std::string newVal )

Sets the email address of the user.

To make the changes permanent, use ms_security::updateUser().

Parameters:
newVal is the new email address of the user.
void setFullName ( std::string newVal )

Update the full user name -- details are saved immediately.

Useful for displaying the full name in reports etc.

To make the changes permanent, use ms_security::updateUser().

Parameters:
newVal is the new full (long) name for the user.
void setID ( int newVal )

Set the unique user ID.

The unique user ID for the user. This should never be changed, since all searches are saved with the USERID equal to this value. Special user IDs are the same as the values in ms_user::systemids.

To make the changes permanent, use ms_security::updateUser().

Parameters:
newVal is the new user ID.
void setName ( std::string newVal )

Set the user login name.

The login name for a user. It is safe to change this for an existing user (as long as the user ID is not changed).

To make the changes permanent, use ms_security::updateUser().

Parameters:
newVal is the new login name for the user.
void setPasswordExpiry ( time_t newVal )

Set the password expiry time.

The time in seconds since January 1st 1970. A value of '0' is used to indicate that the password should never expire.

To make the changes permanent, use ms_security::updateUser().

Parameters:
newVal Is the new date for the password expiry.
void setUserType ( ms_user::usertype newVal )

Update the user type -- details are saved immediately.

See ms_user::ms_user for restrictions on setting the user type. To make the changes permanent, use ms_security::updateUser().

See also:
ms_user::setUserType()
Parameters:
newVal is the new user type.
bool validatePassword | ( | const std::string | pwd,
 |  | int & | errorFlag
 | ) |  | const

Checks to see if the password is correct for the user.

Parameters:
pwd | is the the unencrypted password to be checked against the encrypted password saved in the user's file.
errorFlag | will contain 0 if the function returns true. If the function returns false, then a value of 1 indicates an incorrect password and a value of 2 indicates an internal problem with the seed value.
Returns:
Will return true if the password is correct, or if there is no saved password.
The documentation for this class was generated from the following files:
  • ms_security_user.hpp
  • ms_security_user.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Mascot utilities and tools module

Classes

class | ms_fileutilities
This utility class mainly contains static members. More...
class | ms_matrix
A two-dimensional matrix of numbers. More...
class | ms_spectral_lib_entry
This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file. More...
class | ms_spectral_lib_file
This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file. More...
class | ms_spectral_lib_peak
This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file. More...
class | ms_spectral_lib_peak_list
This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file. More...
class | ms_tinycdb
Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev. More...
class | ms_treecluster
This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/. More...
class | ms_zip
Utility class for compressing and decompressing data in compress format, and compressing in gzip format. More...

Namespaces

namespace | matrix_science::ms_spectral_lib

Modules

Examples for the Mascot tools module
Spectral library Classes

Detailed Description

Tools for creating CDB files, zipping files, file manipulation and clustering

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Examples for the Mascot tools module
[Mascot utilities and tools module]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
For using the tinycdb index files | tools_tinycdb.pl |  |  | tools_tinycdb.py | tools_tinycdb.cs
For using the ms_treecluster class | tools_treecluster.pl |  |  | tools_treecluster.py | tools_treecluster.cs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Spectral library Classes
[Mascot utilities and tools module]

Classes for reading and writing spectral libraries

Mascot 2.6 and later support searching spectral libraries in parallel with a FASTA database.

See: Spectral library search on the Matrix Science public web site for an overview.

For help on reading spectral library results from Mascot Results files, see Spectral libraries

The classes described in this section are used for reading, parsing and writing spectral library files. These classes are not used for performing the library search, which is done by third party tools.

ms_spectral_lib_file is used to open and read a spectral library. The third parameter is used to specify whether to use and create an index file which will improve performance with searching for particular spectra within the library. See ms_spectral_lib_file::findEntries for details of how to lookup entries in the library.

When a spectral library is added to Mascot Server for searching, it converts the library to the NIST format using: ms_spectral_lib_file::saveAs function. It also sets the replaceProteinName parameter to 'true'. Mascot Server saves the spectrum peaklist checksum in results files so that the findEntries function can be used to lookup the spectrum reliably.

ms_spectral_lib_file::getEntryFromNumber can be used to return one ms_spectral_lib_entry object

Supported Spectral Library Formats

Mascot Parser Supports the following formats:

The NIST MSP format

The National Institute of Standards and Technology, NIST in the United States provides a number of libraries to be used with their search tool, MSPepSearch. They provide libraries in a binary format, and also in a text 'MSP' format. Mascot Parser can read and write libraries in MSP format. The format is documented here.

PRIDE files are essentially .msp files, but without any peak annotation. When the file is saved in NIST format, a "?" is added as peak annotation otherwise MSPepSearch can fail to find matches.

The ISB SpectraST format

These files typically have a .sptxt extension. The format is slightly different from the NIST MSP format. There are some details here.

  • The Name field can include a modification delta, for example: Name: K.AADQADESSPLLS[167]PS[167]NSNHPSEHPQQDLNNK.S/4
  • The PeakList entries are a slightly different format.
  • The line specifying the number of peaks is Num peaks: in an MSP file, but NumPeaks: in a SpectraST file.
  • There are normally comment lines at the top of the file.

X! Hunter Annotated Spectrum Library (ASL)

The format is described here

These files are converted to NIST MSP format before being submitted to MSPepSearch.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_spectral_lib
Enumerations

matrix_science::ms_spectral_lib Namespace Reference
[Mascot utilities and tools module]

Enumerations

enum FILE_FORMAT {
FORMAT_UNKNOWN,
FORMAT_NIST_MSP,
FORMAT_SPECTRAST,
FORMAT_MGF,
FORMAT_XHUNTER
}

Detailed Description

The ms_spectral_lib namespace currently just contains one enum used for the ms_spectral_lib_xxx classes

Enumeration Type Documentation

enum FILE_FORMAT

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Spectral libraries are available in a number of formats. All the formats obviously have m/z and intensity and intensity pairs, but there are different annotation formats, and different header formats.

Enumerator:
FORMAT_UNKNOWN

Unknown format.

FORMAT_NIST_MSP

NIST MSP formt.

FORMAT_SPECTRAST

Institute for Systems Biology (ISB) SpectraST format.

FORMAT_MGF

Mascot Generic Format. Only suitable for output.

FORMAT_XHUNTER

X!HUNTER ASL MGF file format (2007.06.01)

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_fileutilities
Public Types | Public Member Functions | Static Public Member Functions

ms_fileutilities Class Reference
[Mascot utilities and tools module]

This utility class mainly contains static members. More...

#include <ms_fileutilities.hpp>

List of all members.

Public Types

enum CMD_ARGUMENT_PARSE_RESULT {
CMD_ARGUMENT_PARSE_OK = 0,
CMD_ARGUMENT_PARSE_UNBALANCED = -1,
CMD_ARGUMENT_PARSE_COLLISION = -2,
CMD_ARGUMENT_PARSE_INVALIDCHAR = -3
}

Return status from parseCommandLineArgumentString().

More...
enum compareXMLFiles_flags {
CMPXML_NO_FLAG = 0x0000,
CMPXML_IGN_DBL_IDENTICAL = 0x0001,
CMPXML_IGN_DBL_DIFF_100_PPM = 0x0002,
CMPXML_IGN_DBL_DIFF_10_PPM = 0x0004,
CMPXML_IGN_DBL_DIFF_1_PPM = 0x0008 ,
CMPXML_STRIP_TRAILING_ZEROS = 0x0010,
CMPXML_IGN_COL_SIZE_EQ_ONE = 0x0020,
CMPXML_IGN_TODAY_DATE = 0x0040,
CMPXML_IGN_INF_999999 = 0x0080,
CMPXML_IGN_FILE_URL = 0x0100,
CMPXML_IGN_RAWFILE_NAME = 0x0200
}

Flags for the compareXmlFiles() function.

More...
enum err_sar {
SAR_SUCCESS,
SAR_FAIL_CHMOD,
SAR_FAIL_GET_NAMED_SECURITY_INFO,
SAR_FAIL_SET_ENTRIES_IN_ACL,
SAR_FAIL_SET_NAMED_SECURITY_INFO,
SAR_FAIL_CHOWN
}

setAccessRights() return value.

More...

Public Member Functions

ms_fileutilities ()
Default constructor.
void | findClose ()
Functions to search for all files that match a wildcard.
bool | findNext (std::string &fileName)
Functions to search for all files that match a wildcard.
bool | findOpen (const std::string directory, const std::string wildcard)
Functions to search for all files that match a wildcard.
unsigned long | getSARExtendedErrorCode () const
err_sar | setAccessRights (const char *filename, const bool bWrite, const bool bExecute, const bool isFile, const ms_mascotoptions &Options, const bool avoid_reapply=false)
Sets access rights for a file according to settings in mascot.dat.

Static Public Member Functions

static bool | compareXmlFiles (const std::string &filePath1, const std::string &filePath2, const std::string &schemaPath, const int flags, const std::vector< std::string > &ignoreElements, const std::vector< std::string > &ignoreAttributes, ms_errs &errs, std::string &differences, std::string &lhsOnly, std::string &rhsOnly)
Compare 2 XML files.
static int | createDirectory (const std::string &directory, std::string &errorDirectory)
Create a directory or directory tree.
static int | deleteDirectory (const std::string &directory, const bool bDeleteSubdirectories=true)
Delete a directory or directory tree.
static bool | doesFileExist (const char *filename)
Returns true if the specified file exists, false otherwise.
static std::string | findMascotDat (const char *szMascotDatFilename, ms_errs *err=NULL, const int timeoutSec=0)
Returns a correct path to mascot.dat if it can be found in one of the default places.
static UINT64 | getFileSize (const char *filename, ms_errs *err=NULL)
Returns the size of the file.
static time_t | getLastModificationTime (const char *filename, ms_errs *err=NULL)
Returns the last file modification time.
static std::string | getMD5Sum (const std::string &str, const bool b32bitEncoding=true)
Return an MD5 sum of a string.
static bool | isDirectory (const char *path)
Determine if the passed path is a directory or a file.
static bool | isFileWritable (const char *filePath)
static int | parseCommandLineArgumentString (const std::string &command, std::vector< std::string > &components)
Split a command-line argument string into components.
static void | setLastModificationTime (const char *filename, time_t modificationTime, ms_errs *err=NULL)
Sets the last file modification time.
static std::string | stripLastFolder (const std::string pathname)
Returns a pathname without last token, i.e. makes "C:\myfolder" from "C:\myfolder\XXX".

Detailed Description

This utility class mainly contains static members.

For static members, creating an instance of this class is not required.

See Static functions in Perl, Java, Python and C#

Member Enumeration Documentation

enum CMD_ARGUMENT_PARSE_RESULT

Return status from parseCommandLineArgumentString().

Enumerator:
CMD_ARGUMENT_PARSE_OK

Command line parsed successfully.

CMD_ARGUMENT_PARSE_UNBALANCED

Command line contains an unbalanced quote.

CMD_ARGUMENT_PARSE_COLLISION

Command line contains a starting (ending) quote preceded (followed) by a non-whitespace character.

CMD_ARGUMENT_PARSE_INVALIDCHAR

Command line contains invalid characters, such as linebreaks.

enum compareXMLFiles_flags

Flags for the compareXmlFiles() function.

Enumerator:
CMPXML_NO_FLAG

No specific options.

CMPXML_IGN_DBL_IDENTICAL

For example 0.2000 and 0.2 would be considered identical if the schema type for the value is double.

CMPXML_IGN_DBL_DIFF_100_PPM

Ignore differences of 100 ppm (1/10,000) between floating point values if the schema type for the value is double.

CMPXML_IGN_DBL_DIFF_10_PPM

Ignore differences of 10 ppm (1/100,000) between floating point values if the schema type for the value is double.

CMPXML_IGN_DBL_DIFF_1_PPM

Ignore differences of 1 ppm (1/1,000,000) between floating point values if the schema type for the value is double.

CMPXML_STRIP_TRAILING_ZEROS

For example 0.2000 and 0.2 would be considered identical even if the schema type is not double

CMPXML_IGN_COL_SIZE_EQ_ONE

For distiller_quantitation_2 where Distiller 2.7 has zero rows (and hence zero columns) but records: <calcMoverZ col_size="1" row_size="0"/>

CMPXML_IGN_TODAY_DATE

If the XML has todays date, it's likely that it won't compare with when the baseline was written. Date is of the form val="Wed Apr 18 16:06:24 2018".

CMPXML_IGN_INF_999999

Double values of "INF" and "999999999999999970000000000000000000000000000000000000000000000000000000000000000000000000000000000.000000" will compare.

CMPXML_IGN_FILE_URL

Text strings starting with "file:///" will ignore directory differences and only compare the filename part. For example: "file:///c:/tmp/filename.txt" will compare OK with "file:///server/mytestdir/tmp/filename.txt" but not with "file:///c:/tmp/AnotherFile.txt".

CMPXML_IGN_RAWFILE_NAME

Text strings for an attribute named "val" in element "info" which has parent element "rawfile" will ignore directory differences and only compare the filename part. For example: val="e:%5cbuildserver%5cfilename.wiff" will compare OK with val="C:%5cbackedup%5cgit%5cfilename.wiff".

enum err_sar

setAccessRights() return value.

Enumerator:
SAR_SUCCESS

Success!

SAR_FAIL_CHMOD

Error returned by call to chmod().

SAR_FAIL_GET_NAMED_SECURITY_INFO

Error returned by call to GetNamedSecurityInfo().

SAR_FAIL_SET_ENTRIES_IN_ACL

Error returned by call to SetEntriesInAcl().

SAR_FAIL_SET_NAMED_SECURITY_INFO

Error returned by call to SetNamedSecurityInfo().

SAR_FAIL_CHOWN

Error returned by call to chown().

Constructor & Destructor Documentation

ms_fileutilities ( )

Default constructor.

Creating an instance of this class is not required.

Member Function Documentation

bool compareXmlFiles | ( | const std::string & | filePath1,
 |  | const std::string & | filePath2,
 |  | const std::string & | schemaPath,
 |  | const int | flags,
 |  | const std::vector< std::string > & | ignoreElements,
 |  | const std::vector< std::string > & | ignoreAttributes,
 |  | ms_errs & | errs,
 |  | std::string & | differences,
 |  | std::string & | lhsOnly,
 |  | std::string & | rhsOnly
 | ) |  | [static]

Compare 2 XML files.

See Multiple return values in Perl, Java, Python and C#.

Warning:
if a relative path for the xsd is specified, then this will be relative to the documents and not relative to the current working directory. This means that if the files to be compared are in different directories, then absolute path(s) will be required in the schemaPath
Parameters:
[in] | filePath1 | is the path for the first (or left) file.
[in] | filePath2 | is the path for the first (or right) file.
[in] | schemaPath | must be valid and must have space separated pairs of "namespace" "path_to_xsd". See the example in ms_mascotresfile::setXMLschemaFilePath.
[in] | flags | is one or more ms_fileutilities::compareXMLFiles_flags bitwise OR'd together.
[in] | ignoreElements | is a vector of element names for which the element values will be ignored. Any attributes and child elements for the specified elements will still be compared. The full path to the element should be specified, e.g. "<quantitationResults><peptideMatch><partner><xic><intensity>" See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
[in] | ignoreAttributes | is a vector of string of attribute names to be ignored in the comparison. If a value contains an '=', then it will only be ignored if the attribute (in either file) is equal to the specified value. For example, 'minorVersion' would ignore all 'minorVersion' attributes, but 'minorVersion="2"' will only ignore if either side has a value of "2" See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
[out] | errs | is used to return a list of any XML parsing errors
[out] | differences | is used to return a list of attribute and value differences for elements that appear in both input files.
[out] | lhsOnly | is used to return a list of elements that only appear in file1
[out] | rhsOnly | is used to return a list of elements that only appear in file2
Returns:
true if the files could be read and validated against the schema file
int createDirectory | ( | const std::string & | directory,
 |  | std::string & | errorDirectory
 | ) |  | [static]

Create a directory or directory tree.

See Static functions in Perl, Java, Python and C#

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | directory | is the path of the directory to be created.
[out] | errorDirectory | is the path of the first directory that it fails to create if the function fails.
Returns:
0 for success, or errno if there is an error.
int deleteDirectory | ( | const std::string & | directory,
 |  | const bool | bDeleteSubdirectories = true
 | ) |  | [static]

Delete a directory or directory tree.

See Static functions in Perl, Java, Python and C#

Deletes the contents and subdirectories of a tree.

Parameters:
[in] | directory | is the path of the directory to be deleted.
[in] | bDeleteSubdirectories | is a flag to specify if subdirectories should be deleted
Returns:
0 for success, or errno/Windows Error code if there is an error.
bool doesFileExist ( const char * filename ) [static]

Returns true if the specified file exists, false otherwise.

See Static functions in Perl, Java, Python and C#

Parameters:
filename is the file to check
Returns:
true if file exists
void findClose ( )

Functions to search for all files that match a wildcard.

To use findOpen(), findNext() and findClose() :

  • Create an ms_fileutilities object.
  • Call findOpen() and check return value.
  • Call findNext() repeatedly until it returns false.
  • Call findClose()

These functions cannot currently be called from any language apart from C++

Do not call findOpen() for a second directory on any ms_fileutilities object until findClose() has been called for the first directory.

std::string findMascotDat | ( | const char * | szMascotDatFilename,
 |  | ms_errs * | err = NULL,
 |  | const int | timeout = 0
 | ) |  | [static]

Returns a correct path to mascot.dat if it can be found in one of the default places.

See Static functions in Perl, Java, Python and C#

Parameters:
szMascotDatFilename | is an optional filename. If an empty string or a null pointer is passed, default values are used depending on the platform.
err | is a pointer to an error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
timeout | is the time in seconds to look for the file. If the file is being edited, it may not exist for a short period, so rather than erroring, this function will wait.
Returns:
path to file mascot.dat
bool findNext ( std::string & fileName )

Functions to search for all files that match a wildcard.

To use findOpen(), findNext() and findClose() :

  • Create an ms_fileutilities object.
  • Call findOpen() and check return value.
  • Call findNext() repeatedly until it returns false.
  • Call findClose()

These functions cannot currently be called from any language apart from C++

Do not call findOpen() for a second directory on any ms_fileutilities object until findClose() has been called for the first directory.

Parameters:
fileName is the name of the found file.
Returns:
true if a file was found.
bool findOpen | ( | const std::string | directory,
 |  | const std::string | wildcard
 | ) |  |

Functions to search for all files that match a wildcard.

To use findOpen(), findNext() and findClose() :

  • Create an ms_fileutilities object.
  • Call findOpen() and check return value.
  • Call findNext() repeatedly until it returns false.
  • Call findClose()

These functions cannot currently be called from any language apart from C++

Do not call findOpen() for a second directory on any ms_fileutilities object until findClose() has been called for the first directory.

Parameters:
directory | is the directory to find files.
wildcard | is a wildcard pattern. For example "*.dat".
Returns:
true if the function succeeds
UINT64 getFileSize | ( | const char * | filename,
 |  | ms_errs * | err = NULL
 | ) |  | [static]

Returns the size of the file.

See Static functions in Perl, Java, Python and C#

Parameters:
filename | is the relative or absolute path to the file
err | is a pointer to an optional error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
Returns:
0 if the function fails
time_t getLastModificationTime | ( | const char * | filename,
 |  | ms_errs * | err = NULL
 | ) |  | [static]

Returns the last file modification time.

See Static functions in Perl, Java, Python and C#

Parameters:
filename | is the relative or absolute path to the file
err | is a pointer to an optional error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
Returns:
0 if the function fails
std::string getMD5Sum | ( | const std::string & | str,
 |  | const bool | b32bitEncoding = true
 | ) |  | [static]

Return an MD5 sum of a string.

See Static functions in Perl, Java, Python and C#

Useful for creating a unique filename from, for example, a long pathname or a set of options.

For 64 bit encoding the returned text is base 64 Encoded with a URL and Filename Safe Alphabet; see http://tools.ietf.org/html/rfc3548#section-4.

For 32 bit encoding, the returned text is base 32 bit encoded (except that lower case rather than upper case letters are used); see http://tools.ietf.org/html/rfc3548#section-5.

Parameters:
str | is the string (of any length) than needs to be converted. If a zero length string is passed, a zero length string will be returned.
b32bitEncoding | should be set to true to give 32 bit encoded string (essential for file systems where an upper case filename and a lower case filename are considered to be the same. If this value is false, then 64 bit encoding is used.
Returns:
the MD5 sum of the string.
unsigned long getSARExtendedErrorCode ( ) const

This can be called if setAccessRights() returns one of the following:

  • SAR_FAIL_GET_NAMED_SECURITY_INFO
  • SAR_FAIL_SET_ENTRIES_IN_ACL
  • SAR_FAIL_SET_NAMED_SECURITY_INFO

The value will be zero for any other errors and is used to return an error code for Windows only.

Returns:
An optional extra errorCode if setAccessRights failed.
bool isDirectory ( const char * path ) [static]

Determine if the passed path is a directory or a file.

See Static functions in Perl, Java, Python and C#

Parameters:
path Path to a directory or file
Returns:
True if the path specifies a directory, otherwise returns false. If the path doesn't exist, the function will also return false.
bool isFileWritable ( const char * filePath ) [static]

See Static functions in Perl, Java, Python and C#

Parameters:
filePath is the file to check
Returns:
true if the file is writable
int parseCommandLineArgumentString | ( | const std::string & | command,
 |  | std::vector< std::string > & | components
 | ) |  | [static]

Split a command-line argument string into components.

A command-line argument string consists of an executable name or filepath followed by a list of zero or more arguments. The executable and arguments are separated by one or more whitespace character. Here are some examples at increasing levels of complexity:

   dir
   cd "C:/Program Files"
   "C:/Program Files/Perl64/bin/perl.exe" C:/inetpub/mascot/bin/dbman_download.pl SwissProt

Any of the components can include spaces, including the executable name; in this case, the component with spaces must be delimited by quotes ("). If the command string does include quotes, the quotes must be balanced, in the sense that an opening quote must follow a closing quote. Further, an opening quote must be preceded by whitespace and a closing quote followed by whitespace. Otherwise the method indicates a syntax error (as such strings are ambiguous). This means the following are all syntax errors and cause the method to return a non-OK status:

    "dir
    cd"C:/Program Files"
    "C:/Program Files/Perl64/bin/perl.exe"C:/inetpub/mascot/bin/dbman_download.pl SwissProt

Note that any of the components, including the executable name, can be the empty string, e.g.

    dir ""
    "" SwissProt

You need to check each item in components before processing further, even if the command string is parsed without error.

If you pass in the empty string in command, you will get an OK status and an empty vector out.

This method does not interpret the components in any way. In particular, it does not check that the first component is an executable filepath or that it exists on disk.

Parameters:
command | The command-line style string.
components | Components parsed from command, with quotes stripped out.
Returns:
Status indicating success or failure, one of ms_fileutilities::CMD_ARGUMENT_PARSE_RESULT.
ms_fileutilities::err_sar setAccessRights | ( | const char * | filename,
 |  | const bool | bWrite,
 |  | const bool | bExecute,
 |  | const bool | bIsFile,
 |  | const ms_mascotoptions & | Options,
 |  | const bool | avoid_reapply = false
 | ) |  |

Sets access rights for a file according to settings in mascot.dat.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Windows:

The bWrite flag is ignored.

The bExecute flag is ignored.

  • Always does a chmod(filename, _S_IREAD | _S_IWRITE)
  • If the filename is a directory, and this is running on NT4, nothing further is done
  • A security descriptor is constructed using the name specified by ms_mascotoptions::getNTIUserGroup() With NT4, Service Pack 4, it isn't possible to add a group to existing groups Q242510, so in this case only, the existing security is replaced with the NTIUserGroup name and the name specified by ms_mascotoptions::getNTMonitorGroup()
  • For a memory mapped object (where bIsFile is false), STANDARD_RIGHTS_ALL | SPECIFIC_RIGHTS_ALL are added to the current rights for the group specified above.
  • For a file or directory (where bIsFile is true), FILE_ALL_ACCESS rights are added to the current rights for the group specified above.

Unix:

The bIsFile parameter is ignored.

If the filename passed is for a file rather than a directory, then chmod is called with the following flags:

  • S_IRUSR (Read access for user)
  • S_IWUSR (Write access for user)
  • S_IXUSR (Execute access for user) - but only if the bExecute flag is set
  • S_IRGRP (Read access for group)
  • S_IWGRP (Write access for group) - but only if the bWrite flag is set
  • S_IXGRP (Execute access for group) - but only if the bExecute flag is set
  • S_IROTH (Read access for others) - but only if ms_mascotoptions::getUnixWebUserGroup() is -1
  • S_IWOTH (Write access for others) - but only if ms_mascotoptions::getUnixWebUserGroup() is -1 and if the bWrite flag is set
  • S_IXOTH (Execute access for others) - but only if ms_mascotoptions::getUnixWebUserGroup() is -1 and if the bExecute flag is set

If the filename passed is for a directory, then chmod is called with the flags above unless ms_mascotoptions::getUnixDirPerm() is defined, in which case the permission used are defined by that entry in mascot.dat.

If ms_mascotoptions::getUnixWebUserGroup() is not -1 and is not -2, then a chown will be performed using the group id specified by ms_mascotoptions::getUnixWebUserGroup().

Parameters:
filename | is the name of the file, or memory mapped object that will be changed by this function.
bWrite | should be set to true if the file should be set to be writeable by the group and others.
bExecute | should be set to true for executable files or directories.
bIsFile | should be set to true for files and directories, and false for for memory mapped file objects.
Options | is the options section of mascot.dat.
avoid_reapply | should be set to true if it should avoid applying the rights if the files already have the desired access configuration. Windows only, false by default.
Returns:
Will return SAR_SUCCESS if it succeeds. See also getSARExtendedErrorCode().
void setLastModificationTime | ( | const char * | filename,
 |  | time_t | modificationTime,
 |  | ms_errs * | err = NULL
 | ) |  | [static]

Sets the last file modification time.

See Static functions in Perl, Java, Python and C#

Parameters:
filename | is the relative or absolute path to the file
modificationTime | is the time to be applied as the file's last write time
err | is a pointer to an optional error object which can be used to return detailed errors. See Passing objects to functions in Perl, Java, Python and C#
std::string stripLastFolder ( const std::string pathname ) [static]

Returns a pathname without last token, i.e. makes "C:\myfolder" from "C:\myfolder\XXX".

See Static functions in Perl, Java, Python and C#

Parameters:
pathname of the filepath to strip.
Returns:
stripped folder name
The documentation for this class was generated from the following files:
  • ms_fileutilities.hpp
  • ms_fileutilities.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_matrix
Public Member Functions | Static Public Member Functions

ms_matrix Class Reference
[Mascot utilities and tools module]

A two-dimensional matrix of numbers. More...

#include <ms_matrix.hpp>

List of all members.

Public Member Functions

ms_matrix ()
Construct empty matrix.
ms_matrix (const matrix_t &m)
Construct a copy of a matrix.
ms_matrix (size_t si, size_t sj, double v=0.0)
Construct a rectangular matrix.
const matrix_t & | data () const
Get the internal constant matrix data.
double | getCR (size_t i, size_t j) const
Get the value for the specified row and column.
double | getRC (size_t i, size_t j) const
Get the value for the specified row and column.
bool | isZero () const
Return true if all values are zero.
void | logContents (ms_errs &errs, const char *description) const
Dump the contents of the matrix to the log.
double | multiplyByRow (const std::vector< double > &column, size_t row) const
Multiply the column matrix by the selected row matrix and return the resulting value. The column must be the same size as a row (getNumColumns) in the matrix.
bool | operator!= (const ms_matrix &m) const
Compare two matrices; size and all values.
ms_matrix | operator* (const ms_matrix &m) const
Multiply two matrices to produce a product matrix.
bool | operator== (const ms_matrix &m) const
Compare two matrices.
column_vector_t & | operator[] (size_t i)
Get a single column as a vector.
const column_vector_t & | operator[] (size_t i) const
Get a single column as a constant vector.
void | resize (size_t si, size_t sj, double v=0.0)
Change the size of the matrix, growing or shrinking as required. If grown then the data will be retained.
void | setColumnDown (size_t row, size_t col, const std::vector< double > &vec)
Copies the values in the passed vector into the column specified, starting at the passed row.
void | setColumnUp (size_t row, size_t col, const std::vector< double > &vec)
Copies the values in the passed vector into the column specified, starting at the passed row.
void | setCR (size_t i, size_t j, double value)
Set the value for the specified row and column.
void | setRC (size_t i, size_t j, double value)
Set the value for the specified row and column.
size_t | sizei () const
Return the number of columns in the matrix.
size_t | sizej () const
Return the number of rows in the matrix.
void | transpose ()
Transpose the matrix in place.

Static Public Member Functions

static ms_matrix | columnMatrix (const std::vector< double > &v)
Returns a matrix with a single column.
static ms_matrix | diagonalMatrix (size_t s, double v)
Returns a square, diagonal matrix.
static ms_matrix | identityMatrix (size_t s)
Returns a square, identity matrix.
static ms_matrix | rowMatrix (const std::vector< double > &v)
Returns a matrix with a single row.

Detailed Description

A two-dimensional matrix of numbers.

The size of a matrix is defined by the number of rows and columns that it contains.

The entry in the j-th row and i-th column of a matrix A is accessed as A[i][j]. Note that this is the opposite of the conventional mathematical notation, where the j-th row of the i-th column of a matrix A is referred to as A[j,i].

The row and column indexes are zero-based (0 to n-1). Note that this differs from the conventional mathematical notation where indexes are one-based (1 to n).

Constructor & Destructor Documentation

ms_matrix ( )

Construct empty matrix.

No rows and no columns.

ms_matrix ( const matrix_t & m )

Construct a copy of a matrix.

Parameters:
m The matrix to copy.

Member Function Documentation

ms_matrix columnMatrix ( const std::vector< double > & v ) [static]

Returns a matrix with a single column.

The column size will be the number of values given.

Parameters:
v The values placed in the column.
Returns:
The column matrix.
const ms_matrix::matrix_t & data ( ) const

Get the internal constant matrix data.

Returns:
The internal representation of the matrix values.
ms_matrix diagonalMatrix | ( | size_t | s,
 |  | double | v
 | ) |  | [static]

Returns a square, diagonal matrix.

All values are zero except for the diagonal values.

Parameters:
s | The size of a row or column; the number of columns and rows.
v | The value placed in every diagonal entry in the matrix.
Returns:
The diagonal matrix.
double getCR | ( | size_t | i,
 |  | size_t | j
 | ) |  | const

Get the value for the specified row and column.

Parameters:
i | The number of the column to retrieve from (0 .. m-1).
j | The number of the row to retrieve from (0 .. n-1).
Returns:
The value of the selected entry.
ms_matrix identityMatrix ( size_t s ) [static]

Returns a square, identity matrix.

All values are zero except for 1.0 in all the diagonal values.

Parameters:
s The size of a row or column; the number of columns and rows.
Returns:
The identity matrix.
bool isZero ( ) const

Return true if all values are zero.

Returns:
True if all entries are zero. False if any entry is non-zero.
void logContents | ( | ms_errs & | errs,
 |  | const char * | description
 | ) |  | const

Dump the contents of the matrix to the log.

Outputs to the log if the logging level is high enough for message: ms_log::LOGMSG_MATRIX_OUTPUT_VALS

Parameters:
errs | is the error handler
description | should be used to describe the matrix
bool operator!= ( const ms_matrix & m ) const

Compare two matrices; size and all values.

Parameters:
m reference to a valid ms_matrix object
Returns:
True if either size or any entry is not identical.
ms_matrix operator* ( const ms_matrix & m ) const

Multiply two matrices to produce a product matrix.

The number of columns in the left-hand matrix must equal the number of rows in the right hand matrix.

The product matrix has a number of rows equal to the number of rows in the left-hand matrix and a number of columns equal to the number of columns in the right-hand matrix.

For example, a 2x3 matrix A can be mutlipled by a 4x2 matrix B, C=A*B, to produce a 4x3 matrix.but not the other way around, C=B*A.) (e.g. a 2x3 matrix multiplied by a 4x2 matrix would have a size of 4x3.)

Parameters:
m reference to a valid ms_matrix object
Returns:
new object of type ms_matrix
bool operator== ( const ms_matrix & m ) const

Compare two matrices.

Parameters:
m reference to a valid ms_matrix object
Returns:
True if the size and all entries are identical.
const ms_matrix::column_vector_t & operator[] ( size_t i ) const

Get a single column as a constant vector.

Parameters:
i The number of the column to retrieve (0 .. m-1).
Returns:
The selected column.
ms_matrix::column_vector_t & operator[] ( size_t i )

Get a single column as a vector.

Parameters:
i The number of the column to retrieve (0 .. m-1).
Returns:
The selected column.
void resize | ( | size_t | si,
 |  | size_t | sj,
 |  | double | v = 0.0
 | ) |  |

Change the size of the matrix, growing or shrinking as required. If grown then the data will be retained.

Parameters:
si | The new number of columns.
sj | The new number of the rows.
v | The value to place in new entries.
ms_matrix rowMatrix ( const std::vector< double > & v ) [static]

Returns a matrix with a single row.

The row size will be the number of values given.

Parameters:
v The values placed in the row.
Returns:
The row matrix.
void setColumnDown | ( | size_t | row,
 |  | size_t | col,
 |  | const std::vector< double > & | vec
 | ) |  |

Copies the values in the passed vector into the column specified, starting at the passed row.

The first value in vec is copied into row, col
The second value in vec is copied into row+1, col
etc.

If vec is larger than the size of the matrix, then the copying stops at the final row in the matrix.

Parameters:
row | is the zero based row to start copying
col | is the column to be filled with values
vec | contains the values to be copied
void setColumnUp | ( | size_t | row,
 |  | size_t | col,
 |  | const std::vector< double > & | vec
 | ) |  |

Copies the values in the passed vector into the column specified, starting at the passed row.

The last value in vec is copied into row, col
The second last value in vec is copied into row-1, col
etc.

If vec is larger than the size of the matrix, then the copying stops at the first row in the matrix.

Parameters:
row | is the zero based row to start copying
col | is the column to be filled with values
vec | contains the values to be copied
void setCR | ( | size_t | i,
 |  | size_t | j,
 |  | double | value
 | ) |  |

Set the value for the specified row and column.

Parameters:
i | The number of the column to retrieve from (0 .. m-1).
j | The number of the row to retrieve from (0 .. n-1).
value | The number to be stored in the specified matrix element.
size_t sizei ( ) const

Return the number of columns in the matrix.

Returns:
The size of a row.
size_t sizej ( ) const

Return the number of rows in the matrix.

Returns:
The size of a column.
void transpose ( )

Transpose the matrix in place.

Reflects the matrix over its main diagonal (which runs from top-left to bottom-right) to obtain its inverse.

The documentation for this class was generated from the following files:
  • ms_matrix.hpp
  • ms_matrix.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_spectral_lib_entry
Public Types | Public Member Functions

ms_spectral_lib_entry Class Reference
[Mascot utilities and tools module]

This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file. More...

#include <ms_spectral_lib_entry.hpp>

Inheritance diagram for ms_spectral_lib_entry:
[legend]
Collaboration diagram for ms_spectral_lib_entry:
[legend]

List of all members.

Public Types

enum WHAT_TO_ANNOTATE {
ANNOTATE_NONE,
ANNOTATE_REPLACE_ALL,
ANNOTATE_REPLACE_QUESTION_MARKS,
ANNOTATE_REPLACE_IF_ALL_EMPTY
}

Used by annotatePeaks to specify if existing annotation should be overwritten.

More...

Public Member Functions

ms_spectral_lib_entry ()
Default constructor.
ms_spectral_lib_entry (const ms_spectral_lib_entry &src)
Copying constructor.
ms_spectral_lib_entry (const std::vector< std::string > &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format)
Constructor.
ms_spectral_lib_entry (const std::string &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format)
Constructor.
virtual | ~ms_spectral_lib_entry ()
Destructor.
bool | annotatePeaks (const WHAT_TO_ANNOTATE whatToAnnotate, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, const ms_umod_configfile *unimod=0)
If there is no existing annotation for any of the peaks in the peak list, then try to annotate using sequence string and modifications.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearAnnotation ()
Removes all annotation from all peaks.
void | copyFrom (const ms_spectral_lib_entry *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const std::string | get () const
Returns the whole entry, in the original format.
int | getCharge () const
Returns the charge state.
std::string | getComment () const
Returns the whole comment line.
std::string | getCommentField (const char *fieldName) const
Returns a particular field entry from the comment line.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the filename where the entry was loaded from.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getLine (const char *key) const
Returns the line for a given key.
int | getMods (std::vector< std::string > &names, std::vector< int > &positions) const
Returns the modifications.
double | getMW () const
Returns the molecular weight.
std::string | getName () const
Returns the Name which is normally the sequence followed by /[CHARGE].
int | getNumPeaks () const
Returns the number of peaks in the spectrum.
std::vector< std::string > | getPeakList (bool convertToNISTformat=false) const
Returns the peak list.
std::string | getPeakListChecksum () const
Returns an MD5 checksum for the peak list.
matrix_science::ms_spectral_lib_peak_list | getPeakListObject () const
Returns the peak list object.
double | getPrecursorMZ () const
Return the 'best available' precursor m/z value.
std::string | getSequence () const
Returns the sequence.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_spectral_lib_entry & | operator= (const ms_spectral_lib_entry &right)
C++ style assignment operator.

Detailed Description

This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file.

Support for spectral library searches was added in Mascot Server 2.6 and Mascot Parser 2.6. Although external NIST software is used for the spectral library search itself, there is a requirement to process the msp files which are plain text.

The ms_spectral_lib_file class is used to open an msp file, and an individual entry can be returned using ms_spectral_lib_file::getEntryFromNumber

The format of the msp file is multiple lines, each with a [param][colon][space][value]. For example,

 Name: AAAAAAAAAAAAAAAGAGAGAK/3
 MW: 1598.861
 Comment: Spec=Consensus Pep=Tryp
 Num peaks: 150

followed by, in this case, 150 lines of peak data, followed by a blank line.

The format is defined here.

The SpectraST files (.sptxt) have minor differences, for example additional lines and a different format for the peak list. See ms_spectral_lib_file::saveAs() for details.

The code in this class allows additional parameter value lines in case of future extension. However, the Name: Comment: and Num peaks: parameters above are required, or an error will be generated.

See Spectral libraries for related information.

Member Enumeration Documentation

enum WHAT_TO_ANNOTATE

Used by annotatePeaks to specify if existing annotation should be overwritten.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See also ms_spectral_lib_file::saveAs

Enumerator:
ANNOTATE_NONE

Don't perform any annotation.

ANNOTATE_REPLACE_ALL

Replace all existing annotation.

ANNOTATE_REPLACE_QUESTION_MARKS

Only annotate if ms_spectral_lib_peak_list::getPeakAnnotationLevel returns ms_spectral_lib_peak_list::ANNOT_LVL_QUESTION_MARKS.

ANNOTATE_REPLACE_IF_ALL_EMPTY

Only annotate if ms_spectral_lib_peak_list::getPeakAnnotationLevel returns ms_spectral_lib_peak_list::ANNOT_LVL_NONE.

Constructor & Destructor Documentation

ms_spectral_lib_entry ( )

Default constructor.

An ms_spectral_lib_entry object is normally created using ms_spectral_lib_file::getEntryFromNumber

ms_spectral_lib_entry ( const ms_spectral_lib_entry & src )

Copying constructor.

Parameters:
src is the source to initialise from
ms_spectral_lib_entry | ( | const std::string & | entry,
 |  | const std::string & | fileName,
 |  | const ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor.

An ms_spectral_lib_entry object is normally created using ms_spectral_lib_file::getEntryFromNumber

Parameters:
entry | is a string containing multiple lines from an msp file.
fileName | is the path of the file where the entry was read from. It is saved as a convenience, and also for error reporting.
format | is the format of the entry. Should be an enum, of the type ms_spectral_lib_file::FILE_FORMAT
ms_spectral_lib_entry | ( | const std::vector< std::string > & | entry,
 |  | const std::string & | fileName,
 |  | const ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor.

An ms_spectral_lib_entry object is normally created using ms_spectral_lib_file::getEntryFromNumber

Parameters:
entry | is a string containing multiple lines from an msp file.
fileName | is the path of the file where the entry was read from. It is saved as a convenience, and also for error reporting.
format | is the format of the entry. Should be an enum, of the type ms_spectral_lib_file::FILE_FORMAT

Member Function Documentation

bool annotatePeaks | ( | const WHAT_TO_ANNOTATE | whatToAnnotate,
 |  | const double | fragmentToleranceValue,
 |  | const std::string | fragmentToleranceUnit,
 |  | const ms_umod_configfile * | unimod = 0
 | ) |  |

If there is no existing annotation for any of the peaks in the peak list, then try to annotate using sequence string and modifications.

Annotate peaks for this one entry.

For Spectral libraries on Mascot Server, the user needs to specify a tolerance in ppm or Daltons. See ms_libraryoptions::getToleranceInDa and ms_libraryoptions::getToleranceInPPM

Parameters:
whatToAnnotate | is used to specify whether existing annotation should be replaced.
fragmentToleranceValue | is the value in the units specified, for matching to the calculated data. Only peaks within this tolerance will be annotated. Other peaks will be annotated with a "?"
fragmentToleranceUnit | must be "Da", "mmu" or "ppm".
unimod | is required if the entry has any modifications that are just specified by name. Otherwise, there is no way to calculate the fragment ion masses.
Returns:
true if annotation was performed.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_spectral_lib_entry * right )

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int getCharge ( ) const

Returns the charge state.

Each spectrum begins with the line in the format:

 Name: [peptide sequence]/[charge]

for example

 Name: AAAAAAGAGPEM(O)VR/2

where each amino acid in the [peptide sequence] is represented by the usual (upper case) letter sequence and [charge] is the positive charge on the peptide. The only modification explicitly shown is oxidized methionine as M(O).

The charge is taken from the end of this line.

Returns:
the charge
std::string getComment ( ) const

Returns the whole comment line.

The third line for each entry contains annotation information for the peptide, its origin and its spectrum It has the format:

 Comments: field1=value [field2=value ]...

Comments are composed of a series of space delimited field=value pairs, where values may be embedded within double quotes. All field names are described in Table 3 of this document. There is one mandatory field, namely Parent=<m/z>, which is the precursor ion m/z required for searching

Returns:
the whole comment line
std::string getCommentField ( const char * fieldName ) const

Returns a particular field entry from the comment line.

The third line for each entry contains annotation information for the peptide, its origin and its spectrum It has the format:

 Comments: field1=value [field2=value ]...

Comments are composed of a series of space delimited field=value pairs, where values may be embedded within double quotes. All field names are described in Table 3 of this document. There is one mandatory field, namely Parent=<m/z>, which is the precursor ion m/z required for searching

Parameters:
fieldName should not contain the =. For example, specify "Parent". The fieldName is case sensitive.
Returns:
The value for the key. If the value is in quotes, then these are stripped. An empty string is returned if the parameter is not found.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns the filename where the entry was loaded from.

Each entry keeps a copy of the filename, which can be useful for error reporting

Returns:
the library filename
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getMods | ( | std::vector< std::string > & | names,
 |  | std::vector< int > & | positions
 | ) |  | const

Returns the modifications.

Peptide modifications are specified in the comment line (see getComment()) and are given in the following format:

 Mods=#/n,aa,tag/n,aa,tag...

Where

  • # is the number of modifications, with modifications separated by a forward slash "/" . Hence, Mods=0 denotes no modifications. Modifications are arranged in order of amino acid position and, if multiple modifications occur at a single position, they are arranged alphabetically by tag.
  • n is the position of the substituted amino acid, starting from 0
  • aa is the modified amino acid symbol
  • tag is the name of the modification. Ideally, this is the name defined in Unimod, but some library files may use a different convention.

For example:

 Mods=2/0,A,Acetyl/8,M,Oxidation

Or files from NIST after 2017 had a different format:

 Mods=1(7,C,CAM)
 Mods=2(19,C,CAM)(20,C,CAM)

Or files generated by certain versions of Mascot Server:

 Mods="2/0,G,Succinyl/11,K,IMID_2H(4)_NL (C-term K)"
 Mods="3/6,N,2-succinyl (C)/10,N,2-succinyl (C)/12,Q,2-succinyl (C)"

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

Parameters:
[out] | names | are the names of the modifications.
[out] | positions | is zero based positions of the modifications.
Returns:
the number of modifications.
double getMW ( ) const

Returns the molecular weight.

Taken from

 MW: [exact molar mass of the peptide ion]

This is used for compatibility with electron-ionization spectra and is not used in the peptide library search; this line may be omitted.

Returns:
the molecular weight
std::string getName ( ) const

Returns the Name which is normally the sequence followed by /[CHARGE].

Each spectrum begins with the line in the format:

 Name: [peptide sequence]/[charge]

for example

 Name: AAAAAAGAGPEM(O)VR/2

where each amino acid in the [peptide sequence] is represented by the usual (upper case) letter sequence and [charge] is the positive charge on the peptide. The only modification explicitly shown is oxidized methionine as M(O).

For SpectraST files, a modification delta can be shown, for example:

 Name: AAADALS[167]DLEIKDSK/2
 Name: K.AADQADESSPLLS[167]PS[167]NSNHPSEHPQQDLNNK.S/4
Returns:
name of the spectrum
int getNumPeaks ( ) const

Returns the number of peaks in the spectrum.

To get the peak list itself, call getPeakList

Returns:
the number of peaks in the spectrum
std::vector< std::string > getPeakList ( bool convertToNISTformat = false ) const

Returns the peak list.

The format of the peak list is described in detail in this document.

Each peak is represented as a line divided into three tab separated fields:

 [m/z][tab][relative abundance][tab]"[peak annotation(s)]"

For example:

 196.1   41   "b3-18/-0.01 60/90 0.2"

For a SpectraST file, the format is slightly different:

 311.0524        341.7   b4-18/-0.08     83/60 0.0981|0.54
 325.1383        302.1   ?       67/60 0.0788|0.56

See also getPeakListObject()

MSPepsearch.exe does not return any results if there is no annotation on any peaks. If the input file had no annotation, and convertToNISTformat is true, then each peak is annotated with a "?"

For finer control over the format of the peak list, call getPeakListObject and then ms_spectral_lib_peak_list::asText

Parameters:
convertToNISTformat determines the format. If this flag is false, then the string returned will be the same format as the text in the .msp or .sptxt file. If 'true', then the format is converted to the NIST format as described above.
Returns:
the peak list in text format. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#
std::string getPeakListChecksum ( ) const

Returns an MD5 checksum for the peak list.

All spaces, tabs, newlines, carriage returns and quotation marks are removed before calculating the checksum

This is the checksum of the original 'file' entry before any annotations have been added, or format changes made.

For example: aj5r7ovt6b6q4wr7btazzd4s6i

Returns:
the checksum as a string
ms_spectral_lib_peak_list getPeakListObject ( ) const

Returns the peak list object.

Returns:
the peak list as a ms_spectral_lib_peak_list
double getPrecursorMZ ( ) const

Return the 'best available' precursor m/z value.

Returns:
the "Mz_exact" value in the comment field if that exist, otherwise return the "Parent" value in the comment field. If neither are present, return 0.0
std::string getSequence ( ) const

Returns the sequence.

Each spectrum begins with the line in the format:

 Name: [peptide sequence]/[charge]

for example

 Name: AAAAAAGAGPEM(O)VR/2

where each amino acid in the [peptide sequence] is represented by the usual (upper case) letter sequence and [charge] is the positive charge on the peptide. The only modification explicitly shown is oxidized methionine as M(O).

For SpectraST files, a modification delta can be shown, for example:

 Name: AAADALS[167]DLEIKDSK/2
 Name: K.AADQADESSPLLS[167]PS[167]NSNHPSEHPQQDLNNK.S/4

The charge is stripped from the end of this line, and all (O) and other mods are removed.

Returns:
the sequence
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_spectral_lib_entry & operator= ( const ms_spectral_lib_entry & right )

C++ style assignment operator.

Parameters:
right is the source to initialise from
Returns:
reference to the current object
The documentation for this class was generated from the following files:
  • ms_spectral_lib_entry.hpp
  • ms_spectral_lib_entry.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_spectral_lib_file
Public Member Functions

ms_spectral_lib_file Class Reference
[Mascot utilities and tools module]

This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file. More...

#include <ms_spectral_lib_file.hpp>

Inheritance diagram for ms_spectral_lib_file:
[legend]
Collaboration diagram for ms_spectral_lib_file:
[legend]

List of all members.

Public Member Functions

ms_spectral_lib_file (const char *fileName, const char *regexForAccession, const char *cdbFileName=0)
Constructor.
ms_spectral_lib_file (const char *fileName, const char *regexForAccession, const char *cdbFileName, const std::map< std::string, std::string > &modificationAliases)
Constructor just for C++, accepting a list of modification aliases.
~ms_spectral_lib_file ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
std::vector< int > | findEntries (const char *sequence, const char *checksum=0, const char *accession=0, const char *mods=0) const
Returns a list of entries that match the parameters.
std::string | getAccessionFromNumber (const int number) const
Returns the accession given the offset into the file.
std::vector< std::string > | getAllMods () const
Returns the complete list of mods named in the file.
std::string | getChecksumFromNumber (const int number) const
Returns the spectrum checksum given the offset into the file.
ms_spectral_lib_entry | getEntryFromNumber (const int number) const
Returns the individual spectrum from the msp file.
std::vector< std::string > | getEntryFromNumberAsText (const int number) const
Returns the individual spectrum from the msp file as a vector of strings.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
std::string | getFileName () const
Returns the full file path passed to the constructor.
ms_spectral_lib::FILE_FORMAT | getFormat () const
Returns the format of the file specified in the constructor.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getModsFromNumber (const int number) const
Returns the mods given the offset into the file.
int | getNumEntries () const
Returns the number of spectra in the msp file.
int | getNumResidues () const
Returns the number of residues in the msp file.
int | getPrecursorChargeFromNumber (const int number) const
Returns the precursor charge given the offset into the file.
double | getPrecursorMZFromNumber (const int number) const
Returns the precursor m/z value given the offset into the file.
long | getQmatch (double minMz, double maxMz) const
Return the number of spectra in the library with a precursor mass within the passed m/z range.
std::string | getSequenceFromNumber (const int number) const
Returns the spectrum peptide sequence given the offset into the file.
std::string | getStatsInformation () const
Returns some unstructured text giving some statistics for the file.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | saveAs (const char *fileName, const bool replaceProteinName=true, ms_spectral_lib::FILE_FORMAT fileFormat=ms_spectral_lib::FORMAT_NIST_MSP, const int startNumber=1, const int endNumber=-1, const ms_spectral_lib_entry::WHAT_TO_ANNOTATE whatToAnnotate=ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS, const double annotateTol=0.6, const char *annotateTolu="Da", const ms_umod_configfile *unimod=0) const
Save a copy of the file in the specified format.
bool | verifyThatModsAreInUnimod (const ms_umod_configfile &unimod)
The modifications listed should all be in the passed unimod file.

Detailed Description

This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file.

Support for spectral library searches was added in Mascot Server 2.6 and Mascot Parser 2.6. Although external NIST software is used for the spectral library search itself, there is a requirement to process the msp and SpectraST files which are plain text.

This class is used to open an msp file, and an individual entries can be obtained using ms_spectral_lib_file::getEntryFromNumber

The format of the msp file is multiple lines, each with a [param][colon][space][value]. For example,

 Name: AAAAAAAAAAAAAAAGAGAGAK/3
 MW: 1598.861
 Comment: Spec=Consensus Pep=Tryp
 Num peaks: 150

followed by, in this case, 150 lines of peak data, followed by a blank line.

The format is defined here.

The SpectraST files (.sptxt) have minor differences, for example additional lines and a different format for the peak list. See saveAs() for details.

The X!Hunter ASL MGF format is described here.

See Spectral libraries for related information.

Constructor & Destructor Documentation

ms_spectral_lib_file | ( | const char * | fileName,
 |  | const char * | regexForAccession,
 |  | const char * | cdbFileName = 0
 | ) |  |

Constructor.

Commonly used constructor.

The use of a cdb index file is optional. If one is specified in the constructor, and the file doesn't exist, or is incompatible, then the whole spectral library will be read and the index (re-) created during this constructor call. If no cdbFileName is specified, then the spectral library file will be opened, but only read on demand. For example, calling getNumEntries() obviously requires the whole file to be read, but calling getEntryFromNumber(1) only requires the first entry to be read.

The cdb index contains a lookup for the accessions found in the spectral library, and so is dependent on the regexForAccession. This means that if you try and create a ms_spectral_lib_file with a different regular expression, then the cdb file will be automatically re-created.

Parameters:
fileName | is the full path to the spectral library file
regexForAccession | is the regular expression used to extract the accession from the protein description. If a regular expression is not defined, then it is not possible to search for or return an accession. If the regexForAccession is of the incorrect format, then ms_errs::ERR_MSP_COMPILE_PARSE_RULE errors will be raised.
cdbFileName | is the full path to the cdb index file for the library file.
ms_spectral_lib_file | ( | const char * | fileName,
 |  | const char * | regexForAccession,
 |  | const char * | cdbFileName,
 |  | const std::map< std::string, std::string > & | modificationAliases
 | ) |  |

Constructor just for C++, accepting a list of modification aliases.

Constructor for C++

The use of a cdb index file is optional. If one is specified in the constructor, and the file doesn't exist, or is incompatible, then the whole spectral library will be read and the index (re-) created during this constructor call. If no cdbFileName is specified, then the spectral library file will be opened, but only read on demand. For example, calling getNumEntries() obviously requires the whole file to be read, but calling getEntryFromNumber(1) only requires the first entry to be read.

The cdb index contains a lookup for the accessions found in the spectral library, and so is dependent on the regexForAccession. This means that if you try and create a ms_spectral_lib_file with a different regular expression, then the cdb file will be automatically re-created.

Parameters:
fileName | is the full path to the spectral library file
regexForAccession | is the regular expression used to extract the accession from the protein description. If a regular expression is not defined, then it is not possible to search for or return an accession. If the regexForAccession is of the incorrect format, then ms_errs::ERR_MSP_COMPILE_PARSE_RULE errors will be raised.
cdbFileName | is the full path to the cdb index file for the library file.
modificationAliases | are a map of modification aliases, such as "CAM" => "Carbamidomethyl". In Mascot Server, these are read from the library_mod_aliases file. The modification aliases are used in the created CDB file and when saveAs() is called.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
std::vector< int > findEntries | ( | const char * | sequence,
 |  | const char * | checksum = 0,
 |  | const char * | accession = 0,
 |  | const char * | mods = 0
 | ) |  | const

Returns a list of entries that match the parameters.

The library may contain multiple spectra for the same sequence and/or multiple spectra with the same checksum.

The function 'ands' all the parameters, so if sequence, checksum, accession and mods are all supplied, it will only return spectra which match all four parameters.

If a cdb index file has been created, then the lookup will be fast because an index is saved in the cdb file.

Use getEntryFromNumber() with each value from the returned list to get the relevant ms_spectral_lib_entry objects.

See also:
ms_peptidesummary::getLibraryEntryId

Example code:

        matrix_science::ms_peptidesummary pepsum(...);
        std::vector<int> dbIdx, offset;
        std::vector<std::string> checksum, mods;
        pepsum.getLibraryEntryId(query, p, dbIdx, offset, checksum, mods);

        if (!dbIdx.empty()) {
            matrix_science::ms_peptide *pep;
            if (pepsum.getPeptide(query, 1, pep)) {
                std::vector<int> found = SLFile.findEntries(pep->getPeptideStr().c_str(), checksum[0].c_str(), 0, mods[0].c_str());

                // If the spectral library file has not changed since the search
                // was run then the 'offset' value[s] obtained from the results
                // file will be the same as those returned from the findEntries call.
                // However, if the spectral library file has changed since the
                // search was run, but the original spectrum is still present in the
                // updated spectral library file, but at a different offset,
                // then it will be successfully returned using this
                // ms_spectral_lib_file::findEntries() call

                // Now, get the entry for each one (normally only one)
                SLFile.getEntryFromNumber(found[x]);
            }
        }
Parameters:
sequence | is the peptide sequence to find. It should just contain upper case A-Z
checksum | is the string that would be returned by ms_spectral_lib_entry::getPeakListChecksum()
accession | is matched to the accession retrieved from the Protein= entry in the comment line. The accession is extracted from the protein using the regular expression passed to the constructor
mods | is in the form exactly as in the spectral library file and as described in ms_spectral_lib_entry::getMods
Returns:
a vector of 'numbers'. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
std::string getAccessionFromNumber ( const int number ) const

Returns the accession given the offset into the file.

The accession retrived from the Protein= entry in the comment line. The accession is extracted from the protein using the regular expression passed to the constructor The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
accession for the spectrum number passed in parameter
std::vector< std::string > getAllMods ( ) const

Returns the complete list of mods named in the file.

The order of the names is just the order that they appear in the file and there will be no duplicate names.

See ms_spectral_lib_entry::getMods for a description of the format in the msp file

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#

Returns:
the list of modification names
std::string getChecksumFromNumber ( const int number ) const

Returns the spectrum checksum given the offset into the file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
checksum for the spectrum number passed in parameter
ms_spectral_lib_entry getEntryFromNumber ( const int number ) const

Returns the individual spectrum from the msp file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe. Either iterate through the whole file, using number = 1..getNumEntries() or use findEntries() to get the number.

If the function fails to load the entry, then a fatal error: ms_errs::ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY or ms_errs::ERR_MSP_NIST_INDEX_OUT_OF_RANGE is set in the returned ms_spectral_lib_entry object. Call ms_spectral_lib_entry::isValid() on the returned object to determine if it is safe to use it.

See also getEntryFromNumberAsText()

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
an ms_spectral_lib_entry object
std::vector< std::string > getEntryFromNumberAsText ( const int number ) const

Returns the individual spectrum from the msp file as a vector of strings.

The number supplied has no relation to spectrum id returned by mspepsearch.exe. Either iterate through the whole file, using number = 1..getNumEntries() or use findEntries() to get the number.

If the function fails to load the entry, then a fatal error: ms_errs::ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY or ms_errs::ERR_MSP_NIST_INDEX_OUT_OF_RANGE is set in this object. Call isValid() to determine if it is safe to use the returned vector of strings.

See also getEntryFromNumber()

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
a vector of strings
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getFileName ( ) const

Returns the full file path passed to the constructor.

Returns:
the file path.
ms_spectral_lib::FILE_FORMAT getFormat ( ) const

Returns the format of the file specified in the constructor.

The file format of the file specified in the constructor is auto detected

Returns:
the auto detected file format
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getModsFromNumber ( const int number ) const

Returns the mods given the offset into the file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

See ms_spectral_lib_entry::getMods for a description of the format in the msp file

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
mods for the spectrum number passed in parameter
int getNumEntries ( ) const

Returns the number of spectra in the msp file.

This value is retrieved from the cdb file if possible, or if no cdb file is specified, then the whole msp file will have to be parsed.

Returns:
the number of spectra in the file.
int getNumResidues ( ) const

Returns the number of residues in the msp file.

This value is retrieved from the cdb file if possible, or if no cdb file is specified, then the whole msp file will have to be parsed.

This is a slightly confusing number! It is the count of all of the residues in each sequence in the library. Just used because at the end of each Mascot search, we report the number of sequences and residues searched.

Returns:
the number of residues in the file.
int getPrecursorChargeFromNumber ( const int number ) const

Returns the precursor charge given the offset into the file.

For MSP files, the charge is taken from the Name: line

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
the precursor charge for the spectrum
double getPrecursorMZFromNumber ( const int number ) const

Returns the precursor m/z value given the offset into the file.

There are several possible values in the Comment line to use for the precursor mz: Parent=865.409, Mz_exact=865.4092, Mz_av=865.898

This function returns the Mz_exact value if it exists, otherwise it returns the Parent= value.

In .sptxt files, there is also a separate PrecursorMZ: line, but this is currently not used.

See also getQmatch()

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
the precursor m/z value for the spectrum
long getQmatch | ( | double | minMz,
 |  | double | maxMz
 | ) |  | const

Return the number of spectra in the library with a precursor mass within the passed m/z range.

This function calls getPrecursorMZFromNumber() to find the number of matches within a precursor mass range.

Parameters:
minMz | Is the lower limit to consider
maxMz | Is the upper limit to consider
Returns:
the number of entries in the library with a precursor mass between minMz and maxMz
std::string getSequenceFromNumber ( const int number ) const

Returns the spectrum peptide sequence given the offset into the file.

The number supplied has no relation to spectrum id returned by mspepsearch.exe and is normally obtained using findEntries()

Parameters:
number must be in the range of 1..getNumEntries()
Returns:
sequence for the spectrum number passed in parameter
std::string getStatsInformation ( ) const

Returns some unstructured text giving some statistics for the file.

Returns:
a free form multi-line text string
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool saveAs | ( | const char * | fileName,
 |  | const bool | replaceProteinName = true,
 |  | ms_spectral_lib::FILE_FORMAT | fileFormat = ms_spectral_lib::FORMAT_NIST_MSP,
 |  | const int | startNumber = 1,
 |  | const int | endNumber = -1,
 |  | const ms_spectral_lib_entry::WHAT_TO_ANNOTATE | whatToAnnotate = ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS,
 |  | const double | annotateTol = 0.6,
 |  | const char * | annotateTolu = "Da",
 |  | const ms_umod_configfile * | unimod = 0
 | ) |  | const

Save a copy of the file in the specified format.

SpectraST format files can be converted to files that will be read by NIST tools using this function

SpectraST and NIST (MSP) files differ in the following ways:

  • SpectraST files commonly have comments at the top. These are never written if the format is FORMAT_NIST_MSP
  • MSP files have the line: "Num peaks:" while SpectraST files have the line "NumPeaks:"
  • The peak list, following the "Num peaks:" or "NumPeaks:" in each entry has a different format
    • MSP files have 3 columns. The first column for m/z, the second for intensity and the third, in double quotes, is used for quoted annotations.
    • SpectraST files have 4 columns. The first two are idenctical to MSP files, but there are then two further columns for peak annotations that are unquoted.
Parameters:
fileName | is the file to write to
replaceProteinName specifies if the Protein="..." field in the comment section should be replaced with Protein="[1..n]:checksum" where

  • 1..n is just the spectrum number offset in the file, and can be used with the getEntryFromNumber() function
  • checksum is the checksum of the spectrum as returned by ms_spectral_lib_entry::getPeakListChecksum
fileFormat | specifies the format as described above
startNumber | is the (index) number of the first spectrum to be saved. and should be in the range 1..getNumEntries(). The default value is 1
endNumber | is the (index) number of the last spectrum to be saved. and should be greater that startNumber and in the range 1..getNumEntries(). A value of -1 (the default) is used to specify that it should go the end of the file.
whatToAnnotate | is used to specify whether existing annotation should be replaced.
annotateTol | is the value in the units specified, for matching to the calculated data. Only peaks within this tolerance will be annotated. Other peaks will be annotated with a "?"
annotateTolu | must be "Da", "mmu" or "ppm".
unimod | is required if any entry has any modifications that are just specified by name. Otherwise, there is no way to calculate the fragment ion masses.
Returns:
true if the file can be saved, false otherwise.
bool verifyThatModsAreInUnimod ( const ms_umod_configfile & unimod )

The modifications listed should all be in the passed unimod file.

If any mods are not found, then a warning ms_errs::ERR_MSP_NIST_MODIFICATION_NOT_FOUND is added

Parameters:
unimod is a reference to the unimod file
Returns:
true if all modifications are listed in the passed unimod list
The documentation for this class was generated from the following files:
  • ms_spectral_lib_file.hpp
  • ms_spectral_lib_file.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_spectral_lib_peak
Public Member Functions | Static Public Member Functions

ms_spectral_lib_peak Class Reference
[Mascot utilities and tools module]

This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file. More...

#include <ms_spectral_lib_peak.hpp>

List of all members.

Public Member Functions

ms_spectral_lib_peak (const std::string &text, ms_spectral_lib::FILE_FORMAT format, matrix_science::ms_errs &errs)
Preferred constructor.
ms_spectral_lib_peak (const double mz, const double intensity, const std::string &annotation, ms_spectral_lib::FILE_FORMAT format)
Constructor.
ms_spectral_lib_peak (const ms_spectral_lib_peak &src)
Copying constructor.
std::string | asText (ms_spectral_lib::FILE_FORMAT format) const
Returns a 'line' with the peak m/z, intensity and annotation as text.
void | clearAnnotation ()
Clear any annotation for the peak.
void | copyFrom (const ms_spectral_lib_peak *right)
Use this member to make a copy of another instance.
std::string | getAnnotation (ms_spectral_lib::FILE_FORMAT format=ms_spectral_lib::FORMAT_NIST_MSP) const
Return annotations for the peak.
bool | getConsensusData (int *numerator, int *denominator, double *medianDeviation) const
For experamental data taken from a number of spectra, some statistics are available.
double | getDelta () const
Return the difference between the calculated and experimental value for the peak.
double | getIntensity () const
Return the intensity for the peak.
double | getMz () const
Return the mass over charge value for the peak.
bool | isMatchedToCalculatedPeak () const
Some peaks appear in spectra, but are no matching expected fragment is found.
bool | isSuspectAssignment () const
Returns true if the assignment to a calculated peak is not uncertain.
bool | isValid () const
Return true if the peak contains valid data.
ms_spectral_lib_peak & | operator= (const ms_spectral_lib_peak &right)
C++ style assignment operator.
void | setAnnotation (const std::string &annotation, ms_spectral_lib::FILE_FORMAT format)
Set annotations for the peak.

Static Public Member Functions

static std::string | getUnmatchedAnnotationStr (ms_spectral_lib::FILE_FORMAT format)
Static function to return the string used to indicate that a peak wasn't matched when the library entry was generated.

Detailed Description

This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file.

Constructor & Destructor Documentation

ms_spectral_lib_peak | ( | const std::string & | text,
 |  | ms_spectral_lib::FILE_FORMAT | format,
 |  | matrix_science::ms_errs & | errs
 | ) |  |

Preferred constructor.

The advantage of using this constructor is that when asText() is called, the returned line will contain m/z and intensity with exactly the same number of decimal places.

Each peak is represented as a line divided into three tab separated fields:

 [m/z][tab][relative abundance][tab]"[peak annotation(s)]"

Tabs or spaces are suitable separators.

If the m/z and intensity cannot be read, then isValid() will return false.

Parameters:
text | is the input line in the above format
format | is one of the ms_spectral_lib::FILE_FORMAT values.
errs | is used to add any error found if the text is not of the correct format
ms_spectral_lib_peak | ( | const double | mz,
 |  | const double | intensity,
 |  | const std::string & | annotation,
 |  | ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor.

An ms_spectral_lib_peak object is normally created by calling ms_spectral_lib_peak_list::getPeak()

Parameters:
mz | is the fragment m/z value
intensity | is the fragment intensity
annotation | is the fragment annotation. See getAnnotation() for details.
format | is one of the ms_spectral_lib::FILE_FORMAT values. It format is ms_spectral_lib::FORMAT_NIST_MSP then annotation should be in quotes.
ms_spectral_lib_peak ( const ms_spectral_lib_peak & src )

Copying constructor.

Parameters:
src is the source to initialise from

Member Function Documentation

std::string asText ( ms_spectral_lib::FILE_FORMAT format ) const

Returns a 'line' with the peak m/z, intensity and annotation as text.

For ms_spectral_lib::FORMAT_MGF and ms_spectral_lib::FORMAT_XHUNTER there will be no annotation text.

See also:
getAnnotation()
Parameters:
format is one of the ms_spectral_lib::FILE_FORMAT formats
Returns:
the line of text
void clearAnnotation ( )

Clear any annotation for the peak.

Does not change the file format associated with the peak

void copyFrom ( const ms_spectral_lib_peak * right )

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
std::string getAnnotation ( ms_spectral_lib::FILE_FORMAT format = ms_spectral_lib::FORMAT_NIST_MSP ) const

Return annotations for the peak.

This function can, in theory, return the annotation data in any available format. However, there is a current limitation that it will only return in the format that it was saved in. Specifically, it cannot convert between ms_spectral_lib::FORMAT_NIST_MSP and ms_spectral_lib::FORMAT_SPECTRAST

The ms_spectral_lib::FORMAT_NIST_MSP format includes double quotes round the returned string

NIST MSP Format

Examples:

  "b2i/1.03 12/21 0.1"
  "b2/0.03,b4-44^2/0.03 21/21 1.3"
  "p-46/-0.12 60/100 4.0"
  "? 31/61 0.4"
  "Int/AC/0.1 11/12 0.2"

The first character(s) denote the type, and will be one of the following:

  • y or b or a are the ion types. These are followeded by a number denoting the position in the peptide.
  • p is used to denote the peak is a precursor peak.
  • ? is used to denote that the mass cannot be assigned to a known fragment type.
  • Int is used to denote internal ions. In this case, the sequence is denoted by /SEQ
  • I is used to denote immonium ions. This is followed by XY where 'X' is the parent amino acid and Y are letters A,B,C.. used to distinguish different immonium products of the amino acid X.

Following the first character, and before the '/' there are additional options:

  • A neutral loss is indicated by a '-' followed by the loss. For example: y6-18 specifies loss of water on y ion at residue 6.
  • 13C peaks are denoted with a following i
  • A * is appended if the peak assignment is suspect
  • ^c denotes a charge > 1, where c is the charge

There is then a / followed by the difference between measured m/z and theoretical (exact) m/z. For unknown fragments, there is obviously no delta.

If a second assignment is possible, a second, comma-separated full assignment is given as in an example above.

For consensus spectra, a space follows the assignment(s), after which is given the number of replicate spectra having that peak and the minimum number of spectra required for that peak to have been reported � these numbers are separated by a �/�. A space follows, after which the median deviation of m/z (in 1/100th of an m/z) of the peaks in the original spectra used to create that peak.

SpectraST format

Examples:

 b5/-0.07
 y9-17^2/-0.08,y9-18^2/0.41
 [y26^3/-0.1236]

Described here as:

SpectraST's syntax to annotate a fragment follows the scheme proposed by Roepstorff and Fohlman.

An annotation tag starts with the assigned ion type (a,b,c,x,y or z) and is followed by the number of amino acid residues present in the fragment. This number is possibly followed by a signed integer value, indicating a modification. Please note that besides post-translational modifications also loss of water (-18) and loss of ammonia (-17), e.g., are taken into account. The caret symbol '^' followed by an integer value depicts the charge state of the fragment. Its absence indicates a singly charged fragment ion. An additional 'i' at the end of the annotation tag implies that the mass value does not correspond to the expected mass value of the monoisotopic peak, but can be assigned to a different isotopic peak of the fragment. Finally, the annotation pattern contains the average mass deviation (in Da) from the theoretically expected mass. A slash '/' preceds this number.

The list of possible annotations is ordered by ascending charge states, where ties are broken by ascending mass deviations.

Annotation tags can be enclosed by square brackets, indicating that several peaks could be assigned the same particular ion. Usually, SpectraST would resolve such a situation by annotating only one of the ions and leaving the other ones blank. If data is not (sufficiently) centroided, this strategy might lead to a buch of unresolved peaks, which might in turn cause quality filters to fail. To circumvent this problem, if there are additional intense peaks that look to be the same ion, a bracketed annotation will be given to them.

Besides annotations following the Roepstorff/Fohlman notation SpectraST also assigns immonium ions. The corresponding tag consists of 3 capital letters, always starting with an 'I' (for immonium), followed by the amino acid and an additional letter to designate different residue-specific ions from that amino acid.

ms_spectral_lib::FORMAT_MGF and ms_spectral_lib::FORMAT_XHUNTER

This will return an empty string.

Parameters:
format is one of the ms_spectral_lib::FILE_FORMAT formats
Returns:
annotation
double getDelta ( ) const

Return the difference between the calculated and experimental value for the peak.

If isMatchedToCalculatedPeak() returns false, then the returned value will be -999.0 as there can be no calculated delta. In other cases, no delta is provided in the file, for example:

 1022.3 [tab] 340 [tab] "Int-18/AFTECCQAAD/ 46/53 1.7"

and -999 is also returned in this case.

Returns:
the delta in m/z
double getIntensity ( ) const

Return the intensity for the peak.

Returns:
the intensity of the the peak
double getMz ( ) const

Return the mass over charge value for the peak.

Returns:
the mass over charge value for the peak
std::string getUnmatchedAnnotationStr ( ms_spectral_lib::FILE_FORMAT format ) [static]

Static function to return the string used to indicate that a peak wasn't matched when the library entry was generated.

For ms_spectral_lib::FORMAT_NIST_MSP this returns "?" (quotes are included)

Parameters:
format is one of the ms_spectral_lib::FILE_FORMAT values.
Returns:
"?" for ms_spectral_lib::FORMAT_NIST_MSP and ? for ms_spectral_lib::FORMAT_SPECTRAST
bool isMatchedToCalculatedPeak ( ) const

Some peaks appear in spectra, but are no matching expected fragment is found.

If a peak was matched to a calculated fragment, then this will return true. If the string returned from getAnnotation() is empty or contains a '?' then no match was found, and this function will return false.

Returns:
true if the peak matched to a calculated match.
bool isSuspectAssignment ( ) const

Returns true if the assignment to a calculated peak is not uncertain.

Returns true if the annotation contains a '*' or if there is no annotation. The NIST documentation is not entirely clear on the meaning of this flag, since a ? may or may not be followed by a '*'

Returns:
true if annotation is not empty and contains *, false otherwise
bool isValid ( ) const

Return true if the peak contains valid data.

Returns:
false if the constructor taking a text string contains a string that cannot be parsed. Otherwise, it will return true;
ms_spectral_lib_peak & operator= ( const ms_spectral_lib_peak & right )

C++ style assignment operator.

Parameters:
right is the source to initialise from
Returns:
reference to the current object
void setAnnotation | ( | const std::string & | annotation,
 |  | ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Set annotations for the peak.

For ms_spectral_lib::FORMAT_NIST_MSP the annotation string should include the double quotes

Parameters:
annotation | annotation to set
format | is the ms_spectral_lib::FILE_FORMAT
The documentation for this class was generated from the following files:
  • ms_spectral_lib_peak.hpp
  • ms_spectral_lib_peak.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_spectral_lib_peak_list
Public Types | Public Member Functions

ms_spectral_lib_peak_list Class Reference
[Mascot utilities and tools module]

This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file. More...

#include <ms_spectral_lib_peak_list.hpp>

Inheritance diagram for ms_spectral_lib_peak_list:
[legend]
Collaboration diagram for ms_spectral_lib_peak_list:
[legend]

List of all members.

Public Types

enum PEAK_ANNOTATION_LEVEL {
ANNOT_LVL_NONE,
ANNOT_LVL_QUESTION_MARKS,
ANNOT_LVL_SOME_PEAKS,
ANNOT_LVL_CANNOT_ANNOTATE
}

Amount of annotation as returned by getAnnotationLevel()

More...

Public Member Functions

ms_spectral_lib_peak_list ()
Constructor.
ms_spectral_lib_peak_list (const ms_spectral_lib_peak_list &src)
Copying constructor.
ms_spectral_lib_peak_list (std::vector< std::string > input, ms_spectral_lib::FILE_FORMAT format)
Constructor from a peak list in NIST format.
~ms_spectral_lib_peak_list ()
Destructor.
void | addPeaks (const std::vector< double > &vecMz, const std::vector< double > &vecIntensity)
add peaks from masses and intensities
void | annotatePeaks (const ms_fragmentvector *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz)
annotate peaks for the given tolerance.
void | annotatePeaks (const std::vector< ms_fragment > *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz)
annotate peaks for the given tolerance, from a C++ vector.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
std::vector< std::string > | asText (ms_spectral_lib::FILE_FORMAT format) const
Return the whole peak list as an array of strings.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearAnnotation ()
Removes all annotation from all peaks.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_spectral_lib_peak_list *right)
Use this member to make a copy of another instance.
std::string | getChecksum () const
Return the 'checksum' for the original peak list before any calls to annotatePeaks.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumPeaks () const
Returns the number of peaks in the peak list.
const ms_spectral_lib_peak * | getPeak (const int pkNum) const
Return a single peak.
PEAK_ANNOTATION_LEVEL | getPeakAnnotationLevel () const
Return information about the amount of peak annotation - i.e. what experimental peaks matched to calculated peaks.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_spectral_lib_peak_list & | operator= (const ms_spectral_lib_peak_list &right)
C++ style assignment operator.
void | setAnnotationLevel (PEAK_ANNOTATION_LEVEL level)

Detailed Description

This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file.

Member Enumeration Documentation

enum PEAK_ANNOTATION_LEVEL

Amount of annotation as returned by getAnnotationLevel()

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See ms_spectral_lib_peak::getAnnotation for a description of the annotation format.

Most files supplied by NIST have annotation, but PRIDE files don't have any annotation.

Enumerator:
ANNOT_LVL_NONE

None of the peaks have any annotation.

ANNOT_LVL_QUESTION_MARKS

In Parser 2.6.0, when calling ms_spectral_lib_file::saveAs(), the resulting file adds "?" to each peak without annotation. At least one peak has a question mark, and none have any 'matching' annotation.

ANNOT_LVL_SOME_PEAKS

One or more peaks have annotation that is not just a "?".

ANNOT_LVL_CANNOT_ANNOTATE

A call to ms_spectral_lib_entry::annotatePeaks() or ms_spectral_lib_peak_list::annotatePeaks() failed to annotate the peak list.

Constructor & Destructor Documentation

ms_spectral_lib_peak_list | ( | std::vector< std::string > | input,
 |  | ms_spectral_lib::FILE_FORMAT | format
 | ) |  |

Constructor from a peak list in NIST format.

An ms_spectral_lib_peak_list object is nomally created by calling ms_spectral_lib_entry::getPeakListObject rather than calling this constructor which simply creates the ms_spectral_lib_peak objects using this constructor.

Leading and trailing white space is removed from each line.

Any format errors will be set in this object and isValid() will then return false.

Parameters:
input | is a vector or raw strings from the .msp file.
format | is one of the ms_spectral_lib::FILE_FORMAT values.
ms_spectral_lib_peak_list ( const ms_spectral_lib_peak_list & src )

Copying constructor.

Parameters:
src is the source to initialise from

Member Function Documentation

void addPeaks | ( | const std::vector< double > & | vecMz,
 |  | const std::vector< double > & | vecIntensity
 | ) |  |

add peaks from masses and intensities

Note that both vectors MUST have the same size.

Existing peaks are not removed.

Parameters:
vecMz | vector of m/z values
vecIntensity | vector of intensity values
void annotatePeaks | ( | const ms_fragmentvector * | fragments,
 |  | const double | fragmentToleranceValue,
 |  | const std::string | fragmentToleranceUnit,
 |  | double | precursorMz
 | ) |  |

annotate peaks for the given tolerance.

See also:
annotatePeaks(const std::vector<ms_fragment> *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz)
Parameters:
fragments | to a vector of fragments to be used for annotation
fragmentToleranceValue | fragment tolerance as a double
fragmentToleranceUnit | fragment tolerance unit (ppm, %, mmu or Da)
precursorMz | m/z value of the precursor, used to annotate a peak with a p class (p for precursor)
void annotatePeaks | ( | const std::vector< ms_fragment > * | fragments,
 |  | const double | fragmentToleranceValue,
 |  | const std::string | fragmentToleranceUnit,
 |  | double | precursorMz
 | ) |  |

annotate peaks for the given tolerance, from a C++ vector.

Annotate the peaks stored in the object according to the NIST format, if the provided format is different, the NIST format will still be used. The existing annotation on peaks is overriden. All annotations are between double quotes.

Note that default values are used for the mass of Nitrogen, Helium, Oxygen and Carbon, the mono-isotopic type of these values are used. If a peak cannot be encoded in MSP format (for example for w ion series), or if there is no matching fragment, the annotation of the peak will be "?". Ion series c, x and z are not accepted in the MSP format; ion series b, y and y are respectively used instead with a differential neutral loss.

Parameters:
fragments | to a vector of fragments to be used for annotation, it doesn't have to be sorted
fragmentToleranceValue | fragment tolerance as a double
fragmentToleranceUnit | fragment tolerance unit (ppm, %, mmu or Da)
precursorMz | m/z value of the precursor, used to annotate a peak with a p class (p for precursor)
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void clearAnnotation ( )

Removes all annotation from all peaks.

Does not change the file format associated with each peak.

See also ms_spectral_lib_peak::clearAnnotation

void copyFrom ( const ms_spectral_lib_peak_list * right )

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
std::string getChecksum ( ) const

Return the 'checksum' for the original peak list before any calls to annotatePeaks.

All spaces, tabs, newlines, carriage returns and quotation marks are removed before calculating the checksum

This is the checksum of the original 'file' entry before any annotations have been added, or format changes made.

For example: aj5r7ovt6b6q4wr7btazzd4s6i

Returns:
the checksum as a string
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getNumPeaks ( ) const

Returns the number of peaks in the peak list.

Returns:
the number of peaks in the list
const ms_spectral_lib_peak * getPeak ( const int pkNum ) const

Return a single peak.

Parameters:
pkNum must be in the range 1..getNumPeaks()
Returns:
a pointer to the peak object, or 0 if pkNum is out of range
ms_spectral_lib_peak_list::PEAK_ANNOTATION_LEVEL getPeakAnnotationLevel ( ) const

Return information about the amount of peak annotation - i.e. what experimental peaks matched to calculated peaks.

Returns:
one of the ms_spectral_lib_peak_list::PEAK_ANNOTATION_LEVEL values
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_spectral_lib_peak_list & operator= ( const ms_spectral_lib_peak_list & right )

C++ style assignment operator.

Parameters:
right is the source to initialise from
Returns:
reference to the current object
void setAnnotationLevel ( PEAK_ANNOTATION_LEVEL level )
Parameters:
level is the new annotation level
The documentation for this class was generated from the following files:
  • ms_spectral_lib_peak_list.hpp
  • ms_spectral_lib_peak_list.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_tinycdb
Public Member Functions

ms_tinycdb Class Reference
[Mascot utilities and tools module]

Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev. More...

#include <ms_tinycdb.hpp>

Inheritance diagram for ms_tinycdb:
[legend]
Collaboration diagram for ms_tinycdb:
[legend]

List of all members.

Public Member Functions

ms_tinycdb (const char *indexFileName, const char *versionNumber, const char *sourceFileName)
Constructor for creating or reading a CDB index file.
~ms_tinycdb ()
Destructor closes any files and frees memory.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | closeIndexFile ()
Close index file.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
bool | finishCreate ()
Finish creating the index file and open it for reading.
std::vector< std::string > | getAllValuesFromKey (const std::string &keyName)
Returns the text values for a key associated with the key name.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
OFFSET64_T | getFileOffsetFromKey (const std::string &keyName)
A useful function for returning file indexes.
std::string | getIndexFileName () const
Return the full path to index file.
int | getIntFromKey (const std::string &keyName)
Return an integer value associated with a key.
int | getIntFromKey (const std::string &keyName, bool &found)
Return an integer value associated with a key and flag to indicate if the value was found in the CDB file.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
std::string | getValueFromKey (const std::string &keyName, const int count=0)
Returns the text value of a key associated with the key name.
bool | isCreating () const
Return true if the file is open for writing.
bool | isOpenForReading () const
Check to see that the file is valid and open for reading.
bool | isPossibleToCreate () const
Check to see if the index file can be created.
bool | isValid () const
Call this function to determine if there have been any errors.
int | makeExists (const char *key) const
See if a key exists while making the file.
bool | openIndexFile (const bool mayRetryBuilding)
Open, or try to open an index file.
bool | prepareToCreate ()
Start creating the index file.
bool | saveFileOffsetForKey (const std::string &keyName, OFFSET64_T offset)
A useful function for storing file indexes.
bool | saveIntForKey (const std::string &keyName, int value)
Store an integer value associated with a key.
bool | saveValueForKey (const char *keyName, const char *value, const unsigned int keyNameLen=0, const unsigned int valueLen=0)
Add a key/value pair to the file.
void | setIndexFileName (const char *filename)
Set the index file name.

Detailed Description

Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev.

ms_tinycdb is a utility for creating and using a 'static' or 'constant' (read-only) database of arbitrary key/value pairs.

After creating the ms_tinycdb object, call openIndexFile(). If this returns true, then the index file exists, is complete, and values can be retrieved by calling the getValueFromKey() function.

If openIndexFile() returns false, it is because the index file does not exist, is incomplete, out of date or corrupt. To determine the reason, call getLastError() or getLastErrorString(). If the file exists, but for example is incomplete, it is possible that it is worth trying to create it again. The function isPossibleToCreate() will return true if it is worth trying to (re-)create the file. See the documentation for openIndexFile() for a full list of errors.

To create an index file, call prepareToCreate() first, and then call saveValueForKey(), saveFileOffsetForKey() or saveIntForKey() to to save all the key/value pairs that are required. Finally, call finishCreate() to close the index file. Once finishCreate() has been called, the file is then automatically opened again for reading.

The keyName values can be any text, except values starting with =0. which are reserved for internal use:

  • =0.1 : For duplicate accessions with .cdb files created for Mascot results files.
  • =0.2 : The version string (if any) supplied to the constructor.
  • =0.3 : Used for cases where the CDB file is larger than the maximum allowed.
  • =0.4 : The 'source' file size.
  • =0.5 : The 'source' file date.

These values can be retrieved, for example by passing a value of "=0.2" to getValueFromKey().

Pseudo code for opening/creaing a file with just one value:

     create new ms_tinycdb
     if !tinycdb->openIndexFile() then
       if tinycdb->getLastError() ==  ERR_CDB_BEING_CREATED) then
         print "Another task is creating the index file, try again later"
       else if tinycdb->isPossibleToCreate() then
         print "(Re)-creating index file because : " . tinycdb->getLastErrorString()
         if tinycdb->prepareToCreate()
           tinycdb->saveValueForKey("MyKey", "MyValue");
           tinycdb->finishCreate()
         else
           print "Cannot create index file because : " . tinycdb->getLastErrorString()
       else
         print "Cannot create index file because : " . tinycdb->getLastErrorString()
     end if

     # We've either just created the index file or it was created some time ago
     if tinycdb->isValid() then
       print "My value = " . tinycdb->getValueFromKey("MyKey");
     end if

See also the Examples for the Mascot tools module.

Constructor & Destructor Documentation

ms_tinycdb | ( | const char * | indexFileName,
 |  | const char * | versionNumber,
 |  | const char * | sourceFileName
 | ) |  |

Constructor for creating or reading a CDB index file.

The constructor does not attempt to open or create an index file. The constructor will only fail if it is run on a big endian system, so there is currently no need to call isValid() after creating the object.

Parameters:
indexFileName | is the full path to the index file. If it isn't specified here, then call setIndexFileName() before calling openIndexFile() or prepareToCreate().
versionNumber | is a string that defines the version of the index file. This value should be changed whenever the calling application changes the indexes saved in the file in a way that is not backward compatible. If an empty string is passed, then the the version number will not be saved in the index file and there will be no check for consistency.
sourceFileName | is an optional path to the 'source' of the index. If an index is based on a particular file (e.g. a Mascot results file), it may be useful to check if the file has changed size or date, because the index probably then needs to be rebuilt. If the size and date of the files differ, then the ms_errs::ERR_CDB_SOURCE_CHANGE_RETRY or ms_errs::ERR_CDB_SOURCE_CHANGE_NO_RETRY error will be set. If this parameter is an empty string, then no checking will be performed.
~ms_tinycdb ( )

Destructor closes any files and frees memory.

The index file is left open for reading until the destructor is called. In version 2.3.2 and earlier, the whole file is memory mapped, which can require a significant address space overhead for the calling application. In version 2.3.3 and later, the memory required is reduced to a few kB.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void closeIndexFile ( )

Close index file.

This function is called when the object is destroyed. You may wish to call it from an application if, for example, you load a file and then find the file is invalid when you test a user defined key. This means that it is only necessary to call isOpenForReading() in your client code.

void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
bool finishCreate ( )

Finish creating the index file and open it for reading.

Returns:
Currently always returns true
std::vector< std::string > getAllValuesFromKey ( const std::string & keyName )

Returns the text values for a key associated with the key name.

See also:
getValueFromKey()
Parameters:
keyName is the name of the key. It should not start with =0. as this is used for the version number and other internal values.
Returns:
values as a vector of strings for the given key. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
OFFSET64_T getFileOffsetFromKey ( const std::string & keyName )

A useful function for returning file indexes.

This function is useful for accessing file indexes that have been stored in a CDB file. To provide a quick look up into a source file (for example a Mascot results file), keys are used to store a byte offset into the file. The advantage of using these functions is that the offset is saved as a binary value and is always more compact than saving it in text format. One disadvantage of these functions is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

Perl: 64 bit integer support is not available in all versions of Perl, so the saveIntForKey() and getIntFromKey() functions take 32 bit offsets on 32 bit versions of Perl. If used for file offsets, the file size limit is then 2Gb when using those functions.

Parameters:
keyName is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
Returns:
the offset, or 0 if it is not found.
int getIntFromKey | ( | const std::string & | keyName,
 |  | bool & | found
 | ) |  |

Return an integer value associated with a key and flag to indicate if the value was found in the CDB file.

This function is useful for retrieving an integer value from a CDB file. See also getFileOffsetFromKey() for using 64 bit integer values.

The advantage of using this function rather than getValueFromKey() is that the value is saved as a binary value and is always more compact than saving it in text format. One disadvantage of this function is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

See also:
saveIntForKey()
Parameters:
keyName | is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
found | will be set to true if the value is found in the CDB file and false if it is not found.
Returns:
the offset, or 0 if it is not found.
int getIntFromKey ( const std::string & keyName )

Return an integer value associated with a key.

This function is useful for retrieving an integer value from a CDB file. See also getFileOffsetFromKey() for using 64 bit integer values.

The advantage of using this function rather than getValueFromKey() is that the value is saved as a binary value and is always more compact than saving it in text format. One disadvantage of this function is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

See also:
saveIntForKey()
Parameters:
keyName is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
Returns:
the offset, or 0 if it is not found.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getValueFromKey | ( | const std::string & | keyName,
 |  | const int | count = 0
 | ) |  |

Returns the text value of a key associated with the key name.

Note, if you want to call this method with a high value for count, it is advised to use getAllValuesFromKey() instead, which is much more efficient.

See also:
saveValueForKey()
getAllValuesFromKey()
Parameters:
keyName | is the name of the key. It should not start with =0. as this is used for the version number and other internal values.
count | should be zero unless multiple occurrences of the key are expected in the file.
Returns:
value as a string for the given key
bool isCreating ( ) const

Return true if the file is open for writing.

If prepareToCreate() returns true, then the file is open for writing

Returns:
true if the cdb file is open for writing.
bool isOpenForReading ( ) const

Check to see that the file is valid and open for reading.

Returns:
true if the index is useable.
bool isPossibleToCreate ( ) const

Check to see if the index file can be created.

This function will return true unless one of the following errors have occurred:

  • ms_errs::ERR_CDB_BEING_CREATED
  • ms_errs::ERR_CDB_TOO_LARGE
  • ms_errs::ERR_CDB_FAIL_REMOVE
Returns:
True if the calling application should try and (re)build the index file.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
int makeExists ( const char * keyName ) const

See if a key exists while making the file.

Should only be called while creating an index file.

Parameters:
keyName is the name of the key for the key/value pair.
Returns:
A value of 1 if the key already exists.
bool openIndexFile ( const bool mayRetryBuilding )

Open, or try to open an index file.

After creating an ms_tinycdb object, call this function to try and open the file. If the file is opened successfully, the function will return true. If it returns false, one or more of the following errors will be set and can be retrieved using getLastError().

ms_errs::ERR_MISSING_CDB_FILE:

The file does not exist or cannot be opened.

ms_errs::ERR_CDB_FAIL_LOCK and ms_errs::ERR_CDB_BEING_CREATED:

The index file is locked, probably because another process is writing to it. The calling application can decide to wait before retrying or to continue without the index if that is possible.

ms_errs::ERR_FAIL_CDB_INIT:

Normally because the index file is incomplete.

ms_errs::ERR_CDB_INCOMPLETE_RETRY or ms_errs::ERR_CDB_INCOMPLETE_NO_RETRY:

If a versionNumber has been specified in the constructor, but there is no key/value pair for the version (using the reserved internal key "=0.2"), then one of these errors is set. Which of the two errors is reported, depends on the mayRetryBuilding parameter.

ms_errs::ERR_CDB_OLD_VER_RETRY or ms_errs::ERR_CDB_OLD_VER_NO_RETRY:

If a versionNumber has been specified in the constructor, and there is a key/value pair for the version (using the reserved internal key "=0.2"), and the version string is different, then one of these errors is set. Which of the two errors is reported, depends on the mayRetryBuilding parameter.

ms_errs::ERR_CDB_SOURCE_CHANGE_RETRY or ms_errs::ERR_CDB_SOURCE_CHANGE_NO_RETRY:

If a sourceFileName has been specified in the constructor then the size and last modified date are compared with the key/value pairs in the index file using the reserved keys "=0.4" and "=0.5". If the values differ, one of these errors is reported. Which of the two errors is reported, depends on the mayRetryBuilding parameter.

ms_errs::ERR_CDB_TOO_LARGE or ms_errs::ERR_CDB_64_BIT_REMAKE:
The maximum size of an index file in Mascot Parser 2.3.3 and earlier was 2GB for a 32 bit application and 4GB for a 64 bit application because the offsets stored in the file were 32 bit. If the index file approaches this size then a value is saved in the partially complete file using the reservered key "=0.3" and this error is set. The maximum file size for Mascot Parser 2.4.1 and later is 256TB. If the file was originally created using an earlier version of Mascot Parser then it is worth trying to re-create the file. If the mayRetryBuilding flag is set then the second error is reported.
Parameters:
mayRetryBuilding should be set to true if an attempt may be made to rebuild the index file if it is incomplete or if it is the wrong version. This just effects the errors put into the ms_errs object. For example, it would use ms_errs::ERR_CDB_OLD_VER_RETRY rather than ms_errs::ERR_CDB_OLD_VER_NO_RETRY.
Returns:
true if the file was opened successfully.
bool prepareToCreate ( )

Start creating the index file.

To create an index file, call this function first, and then call saveValueForKey(), saveFileOffsetForKey() or saveIntForKey() to to save all the key/value pairs that are required. Finally, call finishCreate() to close the index file and open it again for reading.

Returns:
true if the file is created successfully.
bool saveFileOffsetForKey | ( | const std::string & | keyName,
 |  | OFFSET64_T | offset
 | ) |  |

A useful function for storing file indexes.

This function is useful for accessing file indexes that have been stored in a CDB file. To provide a quick look up into a source file (for example a Mascot results file), keys are used to store a byte offset into the file. The advantage of using these functions is that the offset is saved as a binary value and is always more compact than saving it in text format. One disadvantage of these functions is that there is currently no conversion between little endian and big endian format, so index files could not be moved between little endian and big endian systems.

Perl: 64 bit integer support is not available in all versions of Perl, so the saveIntForKey() and getIntFromKey() functions take 32 bit offsets on 32 bit versions of Perl. If used for file offsets, the file size limit is then 2Gb when using those functions.

Parameters:
keyName | is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
offset | is the file offset to be associated with keyName.
Returns:
True if the function succeeds.
bool saveIntForKey | ( | const std::string & | keyName,
 |  | int | value
 | ) |  |

Store an integer value associated with a key.

This function is useful for storing an integer value in a CDB file. See also saveFileOffsetFromKey() for using 64 bit integer values.

The advantage of using this function rather than saveValueForKey is that the value is saved as a binary value and is always more compact than saving it in text format. One disadvantage of this function is that there is currently no conversion between little endian and big endian format,so index files could not be moved between little endian and big endian systems.

See also:
saveIntForKey()
Parameters:
keyName | is the name of the key. In C++, this key value may contain binary information. In other languages, it must be standard text.
value | is the integer value to be associated with keyName.
Returns:
True if the function succeeds.
bool saveValueForKey | ( | const char * | keyName,
 |  | const char * | value,
 |  | const unsigned int | keyNameLen = 0,
 |  | const unsigned int | valueLen = 0
 | ) |  |

Add a key/value pair to the file.

The prepareToCreate() function must have been called prior to calling this function.

C++: The keyName and value parameters will normally point to null terminated text strings. To use a binary data (in either the key or the value or both), specify the length of the data in the keyNameLen and the valLen parameters.

Parameters:
keyName | is the name of the key. It should not start with =0. as this is used for the version number and other internal values.
value | is the value of the key to be stored.
keyNameLen | is the length of the data pointed to by the keyName parameter. If keyNameLen is 0 (the default), then it is assumed that the keyName is a null terminated string.
valueLen | is the length of the data pointed to by the value parameter. If valueLen is 0 (the default), then it is assumed that the value is a null terminated string.
Returns:
true if the key/value pair is saved. It will fail if this would make the file too large, in which case the ms_errs::ERR_CDB_TOO_LARGE error will be set. It will also fail with the error ms_errs::ERR_WRITE_CDB_FILE if the file cannot be written to. Finally, it will fail without an error if the prepareToCreate() function has not been called.
void setIndexFileName ( const char * filename )

Set the index file name.

Parameters:
filename The full path to the index file.
The documentation for this class was generated from the following files:
  • ms_tinycdb.hpp
  • ms_tinycdb.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_treecluster
Public Types | Public Member Functions

ms_treecluster Class Reference
[Mascot utilities and tools module]

This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/. More...

#include <ms_treecluster.hpp>

Inheritance diagram for ms_treecluster:
[legend]
Collaboration diagram for ms_treecluster:
[legend]

List of all members.

Public Types

enum TREE_CLUSTER_DISTANCE {
TCD_CORRELATION,
TCD_ABS_CORRELATION,
TCD_UNCENTERED_CORRELATION,
TCD_ABS_UNCENTERED_CORRELATION,
TCD_SPEARMANS_RANK_CORRELATION,
TCD_KENDALLS_TAU_CORRELATION,
TCD_EUCLIDEAN,
TCD_CITY_BLOCK
}

Flags for cluster().

More...

Public Member Functions

ms_treecluster (int rows, int columns)
Constructor.
ms_treecluster (const ms_treecluster &right)
Copying constructor.
~ms_treecluster ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
bool | cluster (TREE_CLUSTER_DISTANCE tcd, ms_mascotresults::TREE_CLUSTER_METHOD tcm, const std::vector< double > &weight, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, bool transpose=false)
Perform the clustering and populate the left, right and distance vectors with the results.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_treecluster *right)
Copies all data from another instance of the class.
void | defaultValues ()
Initialises the instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_treecluster & | operator= (const ms_treecluster &right)
Assignment operator.
bool | setRow (int row, std::vector< double > datarow, std::vector< int > maskrow)
Sets the values for the specified row in the data and mask arrays.

Detailed Description

This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/.

The License agreement for using this excellent Open Source code is included with Mascot Parser; see C Clustering library.

  • To use this function, create an ms_treecluster object with the required number of rows and columns.
  • Call ms_treecluster::setRow() for each row.
  • Call ms_treecluster::cluster()
  • Access the nodes and distances from the 'returned' left, right and distance parameters

Member Enumeration Documentation

enum TREE_CLUSTER_DISTANCE

Flags for cluster().

In order to cluster data into groups we need to define what exactly we mean by similar. In the C Clustering Library, eight distance functions are available to measure similarity, or conversely, distance.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
TCD_CORRELATION

'c': Pearson correlation coefficient

TCD_ABS_CORRELATION

'a': Absolute value of the Pearson correlation coefficient

TCD_UNCENTERED_CORRELATION

'u': Uncentered Pearson correlation (equivalent to the cosine of the angle between two data vectors)

TCD_ABS_UNCENTERED_CORRELATION

'x': Absolute uncentered Pearson correlation

TCD_SPEARMANS_RANK_CORRELATION

's': Spearman�s rank correlation;

TCD_KENDALLS_TAU_CORRELATION

'k': Kendall tau rank correlation coefficient

TCD_EUCLIDEAN

'e': Euclidean distance

TCD_CITY_BLOCK

'b': City-block distance

Constructor & Destructor Documentation

ms_treecluster | ( | int | rows,
 |  | int | columns
 | ) |  |

Constructor.

Parameters:
rows | is the number of rows in the data
columns | is the number of columns in the data

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
bool cluster | ( | TREE_CLUSTER_DISTANCE | tcd,
 |  | ms_mascotresults::TREE_CLUSTER_METHOD | tcm,
 |  | const std::vector< double > & | weight,
 |  | std::vector< int > & | left,
 |  | std::vector< int > & | right,
 |  | std::vector< double > & | distance,
 |  | bool | transpose = false
 | ) |  |

Perform the clustering and populate the left, right and distance vectors with the results.

Call this function after making rows calls to setRow()

For details of how to use the weight, left, right and distance parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

The function returns a list of items, nodes and distances in the left, right and distance vectors.

The original elements are numbered {0, . . . , nelements-1} and the nodes are numbered {-1, . . . , -(nelements-1)}.

The left, right and distance vectors are guaranteed to have the same number of elements, and for example, left[2], right[2], distance[2] all correspond to the same 'node'.

Element 0 from each of the three vectors corresponds to node -1, element 1 to node -2, element 2 to node -3 etc.

See also ms_peptidesummary::getTreeClusterNodes

Parameters:
[in] | tcd | is used to define which method should be used as a measure of the distance between data items. See ms_treecluster::TREE_CLUSTER_DISTANCE.
[in] | tcm | Specifies which type of hierarchical clustering is used. See ms_mascotresults::TREE_CLUSTER_METHOD
[in] | weight | Dimension: columns (as passed to the constructor) if transpose is false, or rows (as passed to the constructor) if transpose is true. A zero length array is also accepted, in which case this is replaced by an array of 1s - i.e. all the same weight
[out] | left | returns an array, size rows -1 (as passed to the constructor) of element and node numbers
[out] | right | returns an array, size rows -1 (as passed to the constructor) of element and node numbers.
[out] | distance | returns an array, size rows -1 (as passed to the constructor) of distances between the elements/nodes
[in] | transpose | indicates whether row-wise or column-wise clustering is being performed. If transpose is false, rows are being clustered. Otherwise, columns are being clustered.
Returns:
false if the weight array is not of the correct size and false if there is insufficient memory for the arrays.
void copyFrom ( const ms_treecluster * right )

Copies all data from another instance of the class.

Called by copy constructor, or may be called directly.

Parameters:
right is the object to copy values from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void defaultValues ( )

Initialises the instance.

Allocates internal memory based on the number of rows and columns passed to the constructor

const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_treecluster & operator= ( const ms_treecluster & right )

Assignment operator.

Used from C++

Parameters:
right is the object to copy values from
Returns:
reference to the current object
bool setRow | ( | int | row,
 |  | std::vector< double > | datarow,
 |  | std::vector< int > | maskrow
 | ) |  |

Sets the values for the specified row in the data and mask arrays.

For details of how to use the datarow and maskrow parameters, see Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
row | is the zero based row number. Must be in the range 0..rows-1 passed to the constructor
datarow | is an array of the data points for the specified row. The length of the datarow array must be the same as columns passed to the constructor.
maskrow | is an array which specifies which elements in the data array, (if any), are missing. If mask[i][j]==0, then data[i][j] is missing. An empty array may be passed to show that no elements in the data array are missing. However, if a non empty array is passed, then the length of the maskrow array must be the same as columns passed to the constructor.
Returns:
The function will return false if any of the following are true:
  • the row value is less than 0 or greater than or equal the rows value passed to the constructor.
  • the number of values in the datarow parameter is not the same as the columns parameter passed to the constructor.
  • the number of values in the maskrow parameter is not the same as the rows parameter passed to the constructor or is zero.
  • there was an out of memory error.
The documentation for this class was generated from the following files:
  • ms_treecluster.hpp
  • ms_treecluster.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_zip
Public Member Functions

ms_zip Class Reference
[Mascot utilities and tools module]

Utility class for compressing and decompressing data in compress format, and compressing in gzip format. More...

#include <ms_zip.hpp>

Inheritance diagram for ms_zip:
[legend]
Collaboration diagram for ms_zip:
[legend]

List of all members.

Public Member Functions

ms_zip (const bool isZipped, const unsigned char *buffer, const unsigned long len)
Buffer mode constructor (only for C++).
ms_zip (const bool isZipped, const std::string &buffer)
Buffer mode constructor.
ms_zip (const ms_zip &src)
Copying constructor.
ms_zip (const bool isZipped)
Streaming mode constructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
std::string | compressMore (const std::string &dataIn)
Feed more data to the compressor and retrieve the next chunk of compressed data.
void | compressMore (const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen)
Feed more data to the compressor and retrieve the next chunk of compressed data.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_zip *right)
Call this member to copy all the information from another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
unsigned long | getUnZipped (unsigned char *buffer, const unsigned long len) const
Return the uncompressed buffer.
std::string | getUnZipped () const
Return the uncompressed buffer.
unsigned long | getUnZippedLen () const
Return the length of the uncompressed buffer.
unsigned long | getZipped (unsigned char *buffer, const unsigned long len) const
Return the compressed buffer.
std::string | getZipped () const
Return the compressed buffer.
unsigned long | getZippedLen () const
Return the length of the compressed buffer.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_zip & | operator= (const ms_zip &right)
C++ style assignment operator.

Detailed Description

Utility class for compressing and decompressing data in compress format, and compressing in gzip format.

Constructor & Destructor Documentation

ms_zip | ( | const bool | isZipped,
 |  | const unsigned char * | buffer,
 |  | const unsigned long | len
 | ) |  |

Buffer mode constructor (only for C++).

ms_zip can be used to compress and uncompress a small amount of data (less than 10 MB) in a buffer, or in streaming compression mode. When decompressing, the only supported data format is data compressed by ms_zip.

In buffer mode, the first four bytes of the compressed buffer are used to store the length of the uncompressed data as an unsigned 32 bit integer (little endian) format. No other headers are written. The object will hold a copy of both the compressed and uncompressed data, so it is not suitable for use with large amounts of data. After creating the object, call isValid() to determine if there are any errors. The errors can be retrieved using getLastErrorString().

Possible errors are:

  • ms_errs::ERR_MSP_ZIP_ENDIAN
  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_INVALIDDATA
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
  • ms_errs::ERR_MSP_ZIP_LENGTHDIFFERS
  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_ZEROLENGTH
Parameters:
isZipped | should be true if the passed buffer contains compressed data.
buffer | is a pointer to the compressed or uncompressed data. If it is uncompressed, there is no assumption that the data is null terminated.
len | is the length of the passed buffer.
ms_zip | ( | const bool | isZipped,
 |  | const std::string & | buffer
 | ) |  |

Buffer mode constructor.

ms_zip can be used to compress and uncompress a small amount of data (less than 10 MB) in a buffer, or in streaming compression mode. When decompressing, the only supported data format is data compressed by ms_zip.

In buffer mode, the first four bytes of the compressed buffer are used to store the length of the uncompressed data as an unsigned 32 bit integer (little endian) format. No other headers are written. The object will hold a copy of both the compressed and uncompressed data, so it is not suitable for use with large amounts of data. After creating the object, call isValid() to determine if there are any errors. The errors can be retrieved using getLastErrorString().

Possible errors are:

  • ms_errs::ERR_MSP_ZIP_ENDIAN
  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_INVALIDDATA
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
  • ms_errs::ERR_MSP_ZIP_LENGTHDIFFERS
  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_ZEROLENGTH
Parameters:
isZipped | should be true if the passed buffer contains compressed data.
buffer | is a string that contains the compressed or uncompressed data. If it is uncompressed, there is no assumption that the data is null terminated. C++ programmers should be aware that a std::string constructor needs to be passed the length parameter when creating a std::string that contains binary data or a 'zero' in the data will be considered to be a null terminator for a string.
ms_zip ( const bool isZipped ) [explicit]

Streaming mode constructor.

ms_zip can be used to compress and uncompress a small amount of data (less than 10 MB) in a buffer, or in streaming compression mode. When decompressing, the only supported data format is data compressed by ms_zip.

In streaming compression mode, the compressed data stream will start with a minimal gzip header, followed by the compressed data. The constructor does not take any input data as a parameter, unlike in buffer mode. Instead, input data is fed to the object using ms_zip::compressMore(), which returns compressed data. End of input data is indicated by passing the empty string to ms_zip::compressMore().

No streaming decompression mode is supported in this version.

If the underlying zlib library cannot be initialised, the following errors are possible:

  • ms_errs::ERR_MSP_ZIP_OUTOFMEMORY
  • ms_errs::ERR_MSP_ZIP_VERSIONERROR
Parameters:
isZipped must always be false for compression mode.
ms_zip ( const ms_zip & src )

Copying constructor.

Generally only used from C++, but will be called indirectly from other languages.

Parameters:
src is the ms_zip to make a copy of.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void compressMore | ( | const unsigned char * | dataIn,
 |  | const unsigned long | inputLen,
 |  | unsigned char * | dataOut,
 |  | unsigned long * | outputLen
 | ) |  |

Feed more data to the compressor and retrieve the next chunk of compressed data.

You may need to call ms_zip::compressMore() a few times with more input data until the compressed stream starts, which is indicated by returning a non-empty string.

Both the input and output strings are bounded: inputLen and outputLen must not exceed 10 MB, and outputLen must always exceed 0. If any of these conditions fail, a corresponding error will be set.

End of input data is indicated by calling ms_zip::compressMore() with inputLen equal to 0 (dataIn can be NULL). The compressor will flush the output and return the last compressed bytes. If there are more bytes to return than outputLen, you must call the method again (with inputLen equal to 0). When there is no more data to be flushed, outputLen will equal 0.

If this method is called in non-streaming mode, outputLen will be set to 0 and the error ms_errs::ERR_MSP_ZIP_NOTSTREAMING set.

Other possible error conditions:

  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_BUFTOOSMALL
  • ms_errs::ERR_MSP_ZIP_STREAMERROR
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters:
dataIn | Pointer to raw binary data to append to the compressed stream. The data is not assumed to be null terminated.
inputLen | Length of data in dataIn.
dataOut | Pointer to the memory location where compressed data should be written.
outputLen | Maximum length of data to output. outputLen will be set to the actual length of dataOut on successful return.
std::string compressMore ( const std::string & dataIn )

Feed more data to the compressor and retrieve the next chunk of compressed data.

You may need to call ms_zip::compressMore() a few times with more input data until the compressed stream starts, which is indicated by returning a non-empty string.

Both the input and output strings are bounded: the input string length must not exceed 10 MB and the output string length will never exceed 10 MB.

End of input data is indicated by calling ms_zip::compressMore() with the empty string (length 0). The compressor will flush the output and return the last compressed bytes. If there are more bytes to return than the internal buffer allows, you must call the method again with the empty string. When there is no more data to be flushed, the returned string will be empty itself.

If this method is called in non-streaming mode, an empty string object will be returned and the error ms_errs::ERR_MSP_ZIP_NOTSTREAMING set.

Other possible error conditions:

  • ms_errs::ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG
  • ms_errs::ERR_MSP_ZIP_STREAMERROR
  • ms_errs::ERR_MSP_ZIP_UNKNOWN
Parameters:
dataIn Raw binary data to append to the compressed stream. The data need not be null terminated. C++ programmers should be aware that a std::string constructor needs to be passed the length parameter when creating a std::string that contains binary data or a 'zero' in the data will be considered to be a null terminator for a string.
Returns:
A string (possibly empty) of raw compressed binary data.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_zip * right )

Call this member to copy all the information from another instance.

Simply create an instance of the class using the default constructor and call this method.

Parameters:
right is a pointer to another instance to copy from.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getUnZipped ( ) const

Return the uncompressed buffer.

In buffer mode, return the uncompressed data; in streaming compression mode, return the most recent input value to ms_zip::compressMore().

Note:
In C++, the string will not be null terminated, so you should use the std::string::length function to determing the length of the data.
Note:
In Perl, the length function can also be used on the returned string. The uncompressed data may be binary or text.
Returns:
uncompressed data as a string
unsigned long getUnZipped | ( | unsigned char * | buffer,
 |  | const unsigned long | len
 | ) |  | const

Return the uncompressed buffer.

In buffer mode, return the uncompressed data; in streaming compression mode, return the most recent input value to ms_zip::compressMore().

Parameters:
buffer | is the location where the uncompressed data will be copied to. The calling application should make sure that the buffer is long enough. Use getUnZippedLen() to find the length of the uncompressed data.
len | is the length of the passed buffer.
Returns:
The number of bytes copied to the buffer.
unsigned long getUnZippedLen ( ) const

Return the length of the uncompressed buffer.

Returns:
The length, in bytes of the uncompressed data
std::string getZipped ( ) const

Return the compressed buffer.

In buffer mode, return the compressed data; in streaming compression mode, return the most recent value from ms_zip::compressMore().

Note:
In C++, the string will not be null terminated, so you should use the std::string::length function to determing the length of the data.
Note:
In Perl, the length function can be used on the returned string.
Returns:
compressed data as a string
unsigned long getZipped | ( | unsigned char * | buffer,
 |  | const unsigned long | len
 | ) |  | const

Return the compressed buffer.

In buffer mode, return the compressed data; in streaming compression mode, return the most recent value from ms_zip::compressMore().

Parameters:
buffer | is the location where the compressed data will be copied to. The calling application should make sure that the buffer is long enough. Use getZippedLen() to find the length of the compressed data.
len | is the length of the passed buffer.
Returns:
The number of bytes copied to the buffer.
unsigned long getZippedLen ( ) const

Return the length of the compressed buffer.

Returns:
The length, in bytes of the compressed data
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_zip.hpp
  • ms_zip.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Error handling and logging

Classes

class | ms_buffer_logger
Concrete class which implements ms_logger and stores log text in memory. More...
class | ms_errors
This class is used as a base class for several Mascot Parser classes. More...
class | ms_errs
All errors are collected in an instance of this class. More...
class | ms_file_logger
Concrete class which implements ms_logger and outputs log text to the specified file. More...
class | ms_log
Definitions for logging messages. More...
class | ms_logger
Abstract class which provides the interface used by ms_logging monitor to delegate logging events. More...
class | ms_loggingmonitor
Monitor class to delegate logging events generated from multiple sources. More...
class | ms_stdout_logger
Concrete class which implements ms_logger and outputs log text to standard out. More...

Modules

Error Handling
Logging using ms_loggingmonitor
Examples for error handling in Mascot Parser modules

Detailed Description

Error handling and logging classes used by Mascot Parser classes.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Error Handling
[Error handling and logging]

Error handling

Mascot Parser 2.0 introduced configuration files and authentication functionality along with a more generic approach to error handling. The following classes are now derived from ms_errors, and provide the same interface to error handling.

  • ms_aahelper
  • ms_datfile
  • ms_enzymefile
  • ms_fragrulesfile
  • ms_license
  • ms_masses
  • ms_modfile
  • ms_obofile
  • ms_processors
  • ms_quant_configfile
  • ms_security
  • ms_security_options
  • ms_security_tasks
  • ms_session
  • ms_taxonomyfile
  • ms_tinycdb
  • ms_umod_configfile
  • ms_zip

The general recipe is:

  1. Check validity with isValid().
  2. If not valid, get the last error description with getLastErrorString().
  3. Reset error status with clearAllErrors().

If this functionality is not enough, you can call getErrorHandler() to obtain a pointer to the error object (ms_errs) that holds a list of all errors for the object in question.

ms_mascotresfile supports an identical error handling interface. The only difference to ms_errors is the list of supported error codes.

For the complete and up to date list of possible error codes, see ms_errs::err.

For example code, see Examples for error handling in Mascot Parser modules.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Logging using ms_loggingmonitor
[Error handling and logging]

Logging using ms_loggingmonitor

Using setLoggingFile in Parser 2.5 and earlier (deprecated)

Mascot Parser 2.5 and earlier provided a function: ms_errs::setLoggingFile which saved error and logging messages to the specified file. The problem with this approach is that it's necessary to call this for every Mascot Parser object that is created because there is no global handler. Also, any logging that occurs in the constructor would not go into the log file.

ms_loggingmonitor was introduced in Mascot Parser 2.6. This can be used when an application wants to log its own messages and Parser messages to a single file, rather then to multiple log files.

Class diagram for logging classes:

Simple logging with Parser 2.6 and later

The following is an example of how to redirect all logging from msparser to a specified file and how to specify the logging level.

  1. In the program's main function, create a file logger:
    ms_file_logger fileLogger("C:/tmp/log.txt", ms_logger::COL_LOGGER_DEFAULTS );
    specifying whatever columns you want from the list in ms_logger::LogOutputColumns_e
  2. Add the file logger handler to the default monitor:
    ms_loggingmonitor::getDefaultMonitor() . addLogEventsHandler (fileLogger)
  3. Set the logging level, either to be the same for all event sources or different for each one, by calling, for example:
    ms_loggingmonitor::Level_e logLevel = ms_loggingmonitor::LVL_ERROR | ms_loggingmonitor::LVL_WARNING;
    ms_loggingmonitor::getDefaultMonitor().setLogMask(logLevel, ms_loggingmonitor::SRC_ALL);
  4. msparser messages will now all be logged to the specified log file
  5. Call ms_loggingmonitor::logMessage to log messages from your own application

Custom logging

For more complex cases, a custom logger can also be created:

class MyLogger : public matrix_science::ms_logger
{
public:
    MyLogger(const std::string & logFile, const unsigned int colsToOutput) : ms_logger(colsToOutput)
    {
        ofs.open(logFile.c_str());
    }
    void  onLogMessage(matrix_science::ms_loggingmonitor::Level_e eSeverity,
                       matrix_science::ms_loggingmonitor::Source_e eSource,
                       long lMsgId, const std::string &text, long lContextId = 0) {
        ofs << "0x" << std::hex << std::setw(4) << std::setfill('0') << lMsgId
            << " " << matrix_science::ms_loggingmonitor::severityAsText(eSeverity)
            << " " << matrix_science::ms_loggingmonitor::messageSourceAsText(eSource)
            << " " << text << std::endl;

        // Or could call
        matrix_science::ms_logger::formatMessage(eSeverity, eSource, lMsgId, text, lContextId);
    }
private:
    std::ofstream ofs;
};

int main()
{
    matrix_science::ms_loggingmonitor & loggingMonitor = matrix_science::ms_loggingmonitor::getDefaultMonitor();
    MyLogger logger("C:/tmp/log.txt",
                    matrix_science::ms_logger::COL_ASC_TIME | matrix_science::ms_logger::COL_MSG);
    loggingMonitor.addLogEventsHandler(logger);
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Examples for error handling in Mascot Parser modules
[Error handling and logging]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
For general error handling | common_error.pl | common_error.cpp | - | common_error.py | common_error.cs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_buffer_logger
Public Types | Public Member Functions

ms_buffer_logger Class Reference
[Error handling and logging]

Concrete class which implements ms_logger and stores log text in memory. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_buffer_logger:
[legend]
Collaboration diagram for ms_buffer_logger:
[legend]

List of all members.

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001,
COL_ISO8601_TIME = 0x0002,
COL_IP_ADDRESS = 0x0004,
COL_MSG_NUM_DEC = 0x0008,
COL_MSG_NUM_HEX = 0x0010,
COL_SEVERITY_NUM = 0x0020,
COL_SEVERITY_TXT = 0x0040,
COL_MSG_SOURCE_TXT = 0x0080,
COL_SRC_FILE = 0x0100,
COL_SRC_LINENUM = 0x0200,
COL_THREAD_ID = 0x0400,
COL_MSG = 0x0800,
COL_TSV = 0x1000,
COL_QUOTES = 0x2000,
COL_HEADERS = 0x4000,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}

Logging output columns.

More...

Public Member Functions

ms_buffer_logger (unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS)
Constructor, sets columns to report.
virtual | ~ms_buffer_logger ()
Destructor.
std::vector< std::string > | flush ()
Clear and return all messages from the buffer.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)
Format and store the passed message in memory.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Concrete class which implements ms_logger and stores log text in memory.

Member Enumeration Documentation

enum LogOutputColumns_e [inherited]

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
COL_ASC_TIME

[ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"

COL_ISO8601_TIME

[*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.

COL_IP_ADDRESS

[ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.

COL_MSG_NUM_DEC

[ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_MSG_NUM_HEX

[*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_SEVERITY_NUM

[ ] Output the ms_loggingmonitor::Level_e severity as a number.

COL_SEVERITY_TXT

[*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .

COL_MSG_SOURCE_TXT

[*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText

COL_SRC_FILE

[*] Output the source code file name.

COL_SRC_LINENUM

[*] Ouput the line number in the source file.

COL_THREAD_ID

[ ] Output the current thread ID as a hexadecimal number.

COL_MSG

[*] Output the formatted message text.

COL_TSV

[ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab

COL_QUOTES

[ ] Put quotes around every field

COL_HEADERS

[*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this

COL_LOGGER_DEFAULTS

[ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

ms_buffer_logger ( unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS )

Constructor, sets columns to report.

ms_logger implementation which stores log messages in memory.

Parameters:
colsToOutput is used to specify the cols to include in the log and also the format

Member Function Documentation

std::vector< std::string > flush ( )

Clear and return all messages from the buffer.

Returns:
A vector of formatted log message strings. The strings may contain newlines.
std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const [inherited]

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns:
the formatted string.
unsigned int getColsToOutput ( ) const [virtual, inherited]

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns:
the value set in the constructor or by calling ms_logger::setColsToOutput
std::string getHeaderLine ( ) const [inherited]

Returns the header line based on the specified column names.

Returns:
a string that contains the column names
void onLogMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId = 0
 | ) |  | [virtual]

Format and store the passed message in memory.

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message

Implements ms_logger.

void setColsToOutput ( const unsigned int colsToOutput ) [virtual, inherited]

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters:
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_errors
Public Member Functions

ms_errors Class Reference
[Error handling and logging]

This class is used as a base class for several Mascot Parser classes. More...

#include <ms_errors.hpp>

Inheritance diagram for ms_errors:
[legend]
Collaboration diagram for ms_errors:
[legend]

List of all members.

Public Member Functions

ms_errors ()
Default constructor.
~ms_errors ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | isValid () const
Call this function to determine if there have been any errors.

Detailed Description

This class is used as a base class for several Mascot Parser classes.

Examples:

common_error.cpp.

Member Function Documentation

void appendErrors ( const ms_errors & src )

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( )

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right )

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool isValid ( ) const

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_errors.hpp
  • ms_errors.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_errs
Public Types | Public Member Functions | Static Public Member Functions | Static Public Attributes

ms_errs Class Reference
[Error handling and logging]

All errors are collected in an instance of this class. More...

#include <ms_errors.hpp>

Inheritance diagram for ms_errs:
[legend]
Collaboration diagram for ms_errs:
[legend]

List of all members.

Public Types

typedef msg_num_t | err
Definitions for error numbers.
typedef int | msg_num_t
Typedef for log and error message numbers.
enum msg_sev {
sev_fatal = 1,
sev_warn = 2,
sev_info = 3,
sev_debug1 = 4,
sev_debug2 = 5,
sev_debug3 = 6
}

Message severity levels.

More...

Public Member Functions

ms_errs (msg_sev loglevel=sev_warn, bool combineRepeats=true, ms_loggingmonitor::Source_e api=ms_loggingmonitor::SRC_MSPARSER)
Constructor.
virtual | ~ms_errs ()
Destructor.
void | addToCatalog (const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages)
Add messages to the fast lookup map.
void | appendErrors (const ms_errs &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | forwardToParentInstance (ms_errs *parent)
Enable all messages from one object to be forwarded to another.
bool | getCombineRepeats () const
Get the flag for whether to merge repeated error messages.
int | getErrorNumber (const int num=-1) const
Return a specific error number or ERR_NO_ERROR.
int | getErrorRepeats (const int num=-1) const
Returns a number of times the specified error has been repeated.
msg_sev | getErrorSeverity (const int num=-1) const
Returns the severity of the specified error, warning, information or debug message.
std::string | getErrorString (const int num) const
Returns a specific error as a string.
int | getLastError () const
Return the last error number or ERR_NO_ERROR if no errors.
std::string | getLastErrorString () const
Return the last error number or an empty string.
std::string | getLoggingFileName () const
Return the name of the logging file.
virtual msg_sev | getLoggingLevel () const
Get the logging level.
ms_loggingmonitor::Source_e | getMessageSource (const ms_log::msg_num_t msgNum) const
Return the component (library/application) that generated the specified log message.
int | getNumberOfErrors () const
Return the number of errors since the last call to clearAllErrors().
bool | isValid () const
Returns TRUE if no errors occurred, FALSE otherwise.
void | setAPI (ms_loggingmonitor::Source_e api)
Sets the source API for the messages.
void | setCombineRepeats (const bool flag)
Set the flag for whether to merge repeated error messages.
void | setLoggingFile (const std::string filename, const msg_sev level)
Set the logging file.
void | setLoggingLevel (const msg_sev level)
Set the logging level.
bool | willMessageBeLogged (const msg_num_t msgNum) const
Check to see if the message will be logged to a file or recorded anywhere.
bool | willMessageBeLogged (const ms_errs::err errorNum) const
Check to see if the message will be logged to a file or recorded anywhere.

Static Public Member Functions

static ms_errs::msg_sev | convertFromLogLevel (ms_loggingmonitor::Level_e logLevel)
Convert the ms_loggingmonitor level to an ms_errs severity.
static ms_loggingmonitor::Level_e | convertToLogLevel (ms_errs::msg_sev severity)
Convert the ms_errs severity level to a ms_loggingmonitor level.

Static Public Attributes

static const err | ERR_ACCINPEPTIDESTR = 0x0008
[F] Could not parse an item for a given accession in the peptide section.
static const err | ERR_ADDPEPTIDES = 0x000B
[F] Failed to add peptides when creating the peptide summary.
static const err | ERR_CANNOT_APPEND_RESFILE = 0x0038
[F] The file %s cannot be appended to %s because %s values are different.
static const err | ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039
[F] The file cannot be appended because %s values are different.
static const err | ERR_CDB_64_BIT_REMAKE = 0x002C
[W] Re-creating %s. Was too large for 32 bit, but may succeed with 64 bit.
static const err | ERR_CDB_BEING_CREATED = 0x0031
[W] Cache file %% being created by another task. Continuing without cache.
static const err | ERR_CDB_FAIL_LOCK = 0x0033
[W] Failed to lock cache file %s. Error code: %d.
static const err | ERR_CDB_FAIL_REMOVE = 0x0032
[W] Failed to remove old cache file %s - error %s. Continuing without cache.
static const err | ERR_CDB_FAIL_UNLOCK = 0x0034
[W] Failed to unlock cache file %s. Error code: %d.
static const err | ERR_CDB_INCOMPLETE_NO_RETRY = 0x0030
[W] Cache file %s was not complete. Continuing without cache.
static const err | ERR_CDB_INCOMPLETE_RETRY = 0x002F
[W] Cache file %s was not complete. Re-creating the cache file.
static const err | ERR_CDB_OLD_VER_NO_RETRY = 0x002E
[W] Cache file %s is an old version. Continuing without cache.
static const err | ERR_CDB_OLD_VER_RETRY = 0x002D
[W] Cache file %s is an old version. Creating new cache file.
static const err | ERR_CDB_SOURCE_CHANGE_NO_RETRY = 0x0036
[W] %s changed. %s (was %s), %s bytes (was %s). Continuing without cache.
static const err | ERR_CDB_SOURCE_CHANGE_RETRY = 0x0035
[W] %s changed. %s (was %s), %s bytes (was %s). Re-creating the cache file.
static const err | ERR_CDB_TOO_LARGE = 0x002A
[W] Cannot use cache file (s) which exceeded max size of s. Try deleting the cache file and retrying.
static const err | ERR_DUPE_ACCESSION = 0x0013
[W] A possible duplicate accession string has been found. Possible problem in database.
static const err | ERR_DUPLICATE_KEY = 0x0018
[W] Duplicate entries with the same key in the named section.
static const err | ERR_FAIL_CDB_INIT = 0x0027
[W] Failed to initialise cache file (%s). Error code %d.
static const err | ERR_FAIL_CLOSE_FILE = 0x0026
[W] Failed to close file.
static const err | ERR_FAIL_MK_CACHE_DIR = 0x0024
[F] Failed to create cache directory for cache files.
static const err | ERR_FAIL_MK_CDB_FILE = 0x0025
[W] Failed to create an cache file.
static const err | ERR_FAIL_OPEN_DAT_FILE = 0x0022
[F] Failed to open the results file for reading.
static const err | ERR_INVALID_CACHE_DIR = 0x0021
[F] Must specify a cache directory if using CDB cache files.
static const err | ERR_INVALID_CDB_FILE = 0x0028
[W] Value in cdb cache file (%s) is corrupt: %s.
static const err | ERR_INVALID_NUMQUERIES = 0x001C
[W] Invalid number of queries in results file has been corrected.
static const err | ERR_INVALID_PROTDB = 0x001F
[W] Invalid h1_db-string format. Expecting an integer number.
static const err | ERR_INVALID_RESFILE = 0x001E
[F] Invalid results file format -- missing or corrupt headers.
static const err | ERR_MALFORMED_DRANGE = 0x001B
[W] Expecting a line in format q1_p2_drange=0,256.
static const err | ERR_MALFORMED_ERR_TOL = 0x000F
[W] Expecting a line of format q1_p2_et_mods=0.984020,0.000000,Citrullination.
static const err | ERR_MALFORMED_TAG = 0x001A
[W] Expecting a line in format q1_p2_tag=1:3:5:6,2:4:12:6,....
static const err | ERR_MALFORMED_TERMS = 0x001D
[W] Expecting a line in format q1_p2_terms=A,B:-,I:....
static const err | ERR_MISSING_CDB_FILE = 0x0023
[W] Cache file is missing or cannot be opened.
static const err | ERR_MISSING_PERCOLATOR_FILE = 0x0037
[F] Percolator file %s is missing. Cannot continue.
static const err | ERR_MISSINGENTRY = 0x0005
[F] Set if there is no qexp value in the file.
static const err | ERR_MISSINGHIT = 0x000C
[F] Missing hit in the summary section.
static const err | ERR_MISSINGSECTION = 0x000D
[F] Complete missing section in the file.
static const err | ERR_MISSINGSECTIONEND = 0x000E
[F] Missing end of section in the file.
static const err | ERR_MSP_BIND_INVALID_CPU = 0x0152
[W] Warning: Failed to bind invalid processor number: d.
static const err | ERR_MSP_CACHE_DATAOFFSETINVALID = 0x1B05
[F] Cache file meta data offset is invalid. 'filename'.
static const err | ERR_MSP_CACHE_DUPLICATESTREAMID = 0x1B0A
[F] Duplicate stream id detected: 'filename'.
static const err | ERR_MSP_CACHE_FILESEEKFAILED = 0x1B06
[F] Failed to open cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_INVALIDFORMAT = 0x1B03
[F] File format no longer supported. 'filename'.
static const err | ERR_MSP_CACHE_INVALIDSTREAMID = 0x1B08
[F] Stream ID is invalid: [id] 'filename'.
static const err | ERR_MSP_CACHE_INVALIDSTREAMPOSITION = 0x1B09
[F] Stream position is invalid: [position] 'filename'.
static const err | ERR_MSP_CACHE_INVALIDVERSION = 0x1B07
[F] File version is invalid: [version] 'filename'.
static const err | ERR_MSP_CACHE_MODIFYCLOSED = 0x1B0F
[F] Attempted to modify cache file while closed: 'filename'.
static const err | ERR_MSP_CACHE_MODIFYREADONLYMODE = 0x1B0E
[F] Attempted to modify cache file opened for read-only mode: 'filename'.
static const err | ERR_MSP_CACHE_OPENFAILED = 0x1B01
[F] Failed to open cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD = 0x1B12
[W] Protein "[accession]" expected [num] peptides, but read [num] from the cache file
static const err | ERR_MSP_CACHE_READFAILED = 0x1B02
[F] Failed to read cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_SIGNATUREINVALID = 0x1B04
[F] Cache file signature is invalid. 'filename'.
static const err | ERR_MSP_CACHE_SLREF_UPDATE = 0x1B11
[W] Cache file for spectral library search was created by Parser 2.6.0, but the treatment of reference accessions changed in Parser 2.6.1. Re-creating the cache file.
static const err | ERR_MSP_CACHE_STREAMNOTFOUND = 0x1B0C
[F] Failed to find stream in cache file: [streamID] 'filename'.
static const err | ERR_MSP_CACHE_UNINITIALISEDSTREAM = 0x1B10
[F] Attempted to access uninitialised stream.
static const err | ERR_MSP_CACHE_WRITEFAILED = 0x1B0B
[F] Failed to write cache file: [code] 'filename'.
static const err | ERR_MSP_CACHE_WRITETRUNCATED = 0x1B0D
[F] Write to cache file was truncated: 'filename'.
static const err | ERR_MSP_CLOSEST_FDR_FOR_ET = 0x1F04
[W] Target FDR s g%% could not be reached for error tolerant matches. Using closest s FDR g%% with minProbability = g.
static const err | ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS = 0x1F07
[W] Target FDR s g%% could not be reached. Using closest s FDR g%% with minProbability = g.
static const err | ERR_MSP_COLOURSCHEME_INVALID = 0x0629
[W] Colour scheme must be a comma-separated list of key=value pairs where keys and values have a specified format: s
static const err | ERR_MSP_COMPILE_PARSE_RULE = 0x0603
[W] Error while compiling a parse rule with regex.
static const err | ERR_MSP_CONFLICT_BETWEEN_MODS = 0x0A01
[F] A conflict between two or more modifications detected.
static const err | ERR_MSP_CRON_INVALID_CHAR = 0x0614
[W] Invalid character in Cron section.
static const err | ERR_MSP_CRON_INVALID_NUMBER = 0x0615
[W] Invalid number in Cron section.
static const err | ERR_MSP_CRON_INVALID_STAR = 0x0616
[W] Invalid star-character in Cron section.
static const err | ERR_MSP_CRON_NO_NUM_BEFORE_COMMA = 0x0617
[W] Expecting number before comma (,) in Cron section.
static const err | ERR_MSP_CRON_NO_NUM_BEFORE_MINUS = 0x0618
[W] Expecting number before dash (-) in Cron section.
static const err | ERR_MSP_CRON_TOO_MANY_JOBS = 0x0609
[W] Too many cron jobs.
static const err | ERR_MSP_CROSSLINKING_FAILEDLOAD = 0x2100
[W] Failed to load crosslinking.xml file.
static const err | ERR_MSP_CROSSLINKING_FAILEDSAVE = 0x2101
[W] Failed to save crosslinking.xml file.
static const err | ERR_MSP_CROSSLINKING_INVALID_LINK = 0x0A11
[F] Invalid link between peptides (link from = d, link to = d, site from = d, site to = d).
static const err | ERR_MSP_CROSSLINKING_MULTI_LINKS = 0x0A10
[F] Fragmenting with d links between peptides is not implemented.
static const err | ERR_MSP_CROSSLINKING_MULTI_PEPTIDE = 0x0A09
[F] Fragmenting of d linked peptides is not implemented.
static const err | ERR_MSP_CROSSLINKING_VARMOD_CONFLICT = 0x0A12
[F] Linker site contains a variable modification (peptide = s, position = d).
static const err | ERR_MSP_CUSTQUANT_FAILEDINIT = 0x1450
[E] Failed to initialise ms_customquantitation: %s .
static const err | ERR_MSP_CUSTQUANT_PROTR_UNIM = 0x1451
[W] Protein ratio type %s is not implemented; resetting to median.
static const err | ERR_MSP_DB_USES_MISSING_RULE = 0x0602
[W] A database uses non-existent rule.
static const err | ERR_MSP_DIFFERENT_1ST_PASS_THR_ET = 0x1F05
[W] Significance threshold has been changed from the original target value used to select proteins for the second pass search. Original first pass threshold = g, current threshold = g.
static const err | ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED = 0x0A05
[F] Double charged ions are not allowed on this series.
static const err | ERR_MSP_DUP_TAXONOMYRULE = 0x061F
[W] A taxonomy rule with duplicate number has been encountered.
static const err | ERR_MSP_DUPLICATE_MOD = 0x0400
[F] Duplicate modification names in mod_file.
static const err | ERR_MSP_EMPTY_MOD = 0x0A07
[F] A modification is missing or incomplete (perhaps it was not found in the configuration files).
static const err | ERR_MSP_ENZYME_DEFINITION_PROBLEM = 0x0502
[F] Invalid enzyme definition.
static const err | ERR_MSP_ENZYME_FILE_FORMAT = 0x0500
[F] Error in enzymes file.
static const err | ERR_MSP_ENZYME_TOO_MANY_RULES = 0x0503
[F] Too many cleavage rules for enzyme.
static const err | ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS = 0x0622
[W] ExecAfterSearch has waitfor %d, but no %d command.
static const err | ERR_MSP_EXEC_AFTER_SEARCH_INVALID = 0x0621
[W] ExecAfterSearch must start with waitforX, where 0 <= X <= 10.
static const err | ERR_MSP_EXEC_AFTER_SEARCH_LOGGING = 0x0623
[W] ExecAfterSearch has an invalid logging level (should be 0..3).
static const err | ERR_MSP_FAIL_GET_PROCESS_AFFINITY = 0x0105
[F] Failed to find information about number of processors available: s.
static const err | ERR_MSP_FAIL_GET_SYSINFO = 0x0107
[F] Failed to obtain system information.
static const err | ERR_MSP_FAIL_HWLOC_INIT = 0x0150
[F] Failed to determine details about processors. (Call to hwloc_topology_init failed).
static const err | ERR_MSP_FAIL_HWLOC_LOAD = 0x0151
[F] Failed to determine details about processors. (Call to hwloc_topology_load failed).
static const err | ERR_MSP_FAIL_PROCESSOR_BIND = 0x0153
[W] Warning: Failed to bind process to set of processors (s). Return d, errno d.
static const err | ERR_MSP_FAIL_STAT = 0x0102
[W] OS-specific API-function stat() failed.
static const err | ERR_MSP_FAIL_THREAD_BIND = 0x0154
[W] Warning: Failed to bind thread d to processor d. Return d, errno d.
static const err | ERR_MSP_FAIL_UTIME = 0x0109
[W] Failed calling function utime() on file '%s'.
static const err | ERR_MSP_FAILED_TO_CLOSE_FILE = 0x0101
[W] Can happen everywhere.
static const err | ERR_MSP_FAILED_TO_OPEN_FILE = 0x0100
[F] Error when opening file.
static const err | ERR_MSP_FAILED_TO_WRITE_FILE = 0x0108
[F] Failed to write to file '%s' (file not open or disk full).
static const err | ERR_MSP_FILE_DOESNT_EXIST = 0x0104
[F] Cannot open file because it doesn't exist.
static const err | ERR_MSP_FRAGMENTATION_RULES = 0x0200
[F] Error when parsing fragmentation_rules file.
static const err | ERR_MSP_GET_VOLUME_INFO = 0x0103
[W] Failed to get volume information.
static const err | ERR_MSP_HTTP_ABORTEDBYUSER = 0x1A0E
[F] HTTP request aborted by user.
static const err | ERR_MSP_HTTP_BADHTTPSTATUS = 0x1A16
[F] HTTP status is [httpCode] 'httpText'.
static const err | ERR_MSP_HTTP_CHANGEPASSWORDDISABLED = 0x190B
[F] Change password failed: security is disabled.
static const err | ERR_MSP_HTTP_CLOSECONNECTIONFAILED = 0x1A0C
[F] Failed to close HTTP connection [code] 'text'.
static const err | ERR_MSP_HTTP_CLOSEREQUESTFAILED = 0x1A0D
[F] Failed to close HTTP request [code] 'text'.
static const err | ERR_MSP_HTTP_CLOSESESSIONFAILED = 0x1A0B
[F] Failed to close HTTP session [code] 'text'.
static const err | ERR_MSP_HTTP_DOWNLOADFAILED = 0x1A1B
[W] Unable to complete download of [s] to the local file [s] due to the following error: [s]. Check network and proxy settings or the local file permissions and try again.";
static const err | ERR_MSP_HTTP_ERROR = 0x1A17
[F] 'httpText'.
static const err | ERR_MSP_HTTP_GETPROXYFAILED = 0x1A15
[F] Failed to get HTTP proxy
static const err | ERR_MSP_HTTP_GETRESULTSFILENAME = 0x1A1A
[W] The http call client.pl?result_file_name&task_id=[taskID] returned [text]
static const err | ERR_MSP_HTTP_HEADERFAILED = 0x1A1C
[W] Unable to access [s] due to the following error: [s]. Check network and proxy settings and try again.
static const err | ERR_MSP_HTTP_INVALID_URL = 0x0902
[F] Invalid web-address.
static const err | ERR_MSP_HTTP_LOGINERROR = 0x1909
[F] Mascot server login.pl=[command] error: [code].
static const err | ERR_MSP_HTTP_LOGINERRORINT = 0x190A
[F] Mascot server login.pl=[command(param)] error: [code].
static const err | ERR_MSP_HTTP_LOGINPARSERERROR = 0x1905
[F] Mascot server login.pl=[command] parser error: [code].
static const err | ERR_MSP_HTTP_LOGINPARSERERRORINT = 0x1906
[F] Mascot server login.pl=[command(param)] parser error: [code].
static const err | ERR_MSP_HTTP_LOGINSERVERERROR = 0x1907
[F] Mascot server login.pl=[command] server error.
static const err | ERR_MSP_HTTP_LOGINSERVERERRORINT = 0x1908
[F] Mascot server login.pl=[command(param)] server error.
static const err | ERR_MSP_HTTP_MAXCONECTIONS10FAILED = 0x1A10
[W] Failed to set maximum connections per 1.0 server
static const err | ERR_MSP_HTTP_MAXCONECTIONSFAILED = 0x1A0F
[W] Failed to set maximum connections per server
static const err | ERR_MSP_HTTP_MISSINGLOGINERROR = 0x1903
[F] Mascot server login.pl is not present.
static const err | ERR_MSP_HTTP_MISSINGLOGININFO = 0x1904
[I] Mascot server login.pl is not present; security is disabled.
static const err | ERR_MSP_HTTP_NORESPONSE = 0x1A08
[F] Failed to receive HTTP response
static const err | ERR_MSP_HTTP_OPENCONNECTIONFAILED = 0x1A0C
[F] Failed to open HTTP connection
static const err | ERR_MSP_HTTP_OPENOUTPUTFILEFAILED = 0x190C
[F] Failed to open file for writing: [code] 'text'.
static const err | ERR_MSP_HTTP_OPENREQUESTFAILED = 0x1A0D
[F] Failed to open HTTP request
static const err | ERR_MSP_HTTP_OPENSESSIONFAILED = 0x1A0B
[F] Failed to open HTTP session
static const err | ERR_MSP_HTTP_QUERYDATAFAILED = 0x1A13
[F] Failed to query data status
static const err | ERR_MSP_HTTP_QUERYSTATUSFAILED = 0x1A0A
[F] Failed to query HTTP status
static const err | ERR_MSP_HTTP_READDATAFAILED = 0x1A14
[F] Failed to read data
static const err | ERR_MSP_HTTP_READRESPONSEFAILED = 0x1A11
[F] Failed to read HTTP response: [code] 'text'.
static const err | ERR_MSP_HTTP_RELOGINFAILED = 0x190E
[F] Failed to relogin to the Mascot server: [code] '[text]'.
static const err | ERR_MSP_HTTP_SENDREQUESTFAILED = 0x1A12
[F] Failed to send HTTP request
static const err | ERR_MSP_HTTP_SESSIONALREADYOPEN = 0x1A18
[F] A session is already open.
static const err | ERR_MSP_HTTP_SETHTTPPASSWORDFAILED = 0x1A05
[F] Failed to set HTTP password
static const err | ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED = 0x1A04
[F] Failed to set HTTP username
static const err | ERR_MSP_HTTP_SETPROXYFAILED = 0x1A01
[F] Failed to set HTTP proxy
static const err | ERR_MSP_HTTP_SETPROXYPASSWORDFAILED = 0x1A03
[F] Failed to set HTTP proxy password
static const err | ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED = 0x1A02
[F] Failed to set HTTP proxy username
static const err | ERR_MSP_HTTP_SETREDIRECTFAILED = 0x1A06
[F] Failed to set redirect policy
static const err | ERR_MSP_HTTP_TRANSMISSION_FAILED = 0x0901
[F] Http-transmission failed.
static const err | ERR_MSP_HTTP_VERSIONERROR = 0x1902
[F] Mascot version error: s.
static const err | ERR_MSP_HTTP_WEBAUTHERROR = 0x1901
[F] Mascot login error: could not determine if web authentication is enabled.
static const err | ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED = 0x190D
[F] Failed to write to file: [code].
static const err | ERR_MSP_HTTP_XMLUPLOADFAILED = 0x1C01
[F] Failed to upload XML data: 'text'.
static const err | ERR_MSP_IN_CLUSTER_SECTION = 0x0607
[W] Error in CLUSTER section.
static const err | ERR_MSP_IN_MASCOT_DAT_DB_SECT = 0x0605
[W] Error in Databases section.
static const err | ERR_MSP_IN_MASSES_FILE = 0x0300
[F] Error when parsing "masses" file.
static const err | ERR_MSP_IN_MODS_FILE = 0x0404
[F] Error in mod file.
static const err | ERR_MSP_IN_OPTIONS_SECTION = 0x0606
[W] Error in OPTIONS section.
static const err | ERR_MSP_IN_TAXONOMY_SECTION = 0x060F
[W] Error in Taxonomy section.
static const err | ERR_MSP_INCOMPATIBLE_TAX_RULES = 0x0610
[W] Incompatible taxonomy rules.
static const err | ERR_MSP_INST_CANTGETHOSTNAME = 0x1803
[F] Failed to determine the hostname.
static const err | ERR_MSP_INST_FAILADDPARSERULE = 0x1802
[F] Failed to added parse rule required for SwissProt - too many rules already in mascot.dat?
static const err | ERR_MSP_INST_INVALIDCPUINFO = 0x1800
[W] Failed to get CPU information. Assuming single core and no hyper-threading.
static const err | ERR_MSP_INST_MISSINGDATABASE = 0x1801
[W] No entry for s found in not.mascot.dat.
static const err | ERR_MSP_INVALID_CPU_PACKAGE_NUM = 0x0156
[W] Warning: Request for information about invalid cpu package number: d at line: d.
static const err | ERR_MSP_INVALID_LOGICAL_CPU_NUM = 0x0155
[W] Warning: Request for information about invalid logical cpu number: d at line: d.
static const err | ERR_MSP_INVALID_MASS_IN_MASSES_FILE = 0x0301
[F] Invalid mass in "masses" file.
static const err | ERR_MSP_INVALID_NUM_LICENSED = 0x0157
[W] Warning: Request for number of CPUs to run on returns 0 because number licesed is d.
static const err | ERR_MSP_INVALID_PARSE_RULE = 0x060A
[W] Invalid parsing rule.
static const err | ERR_MSP_INVALID_PARSE_RULE_NO = 0x060B
[W] Parsing rule with invalid number.
static const err | ERR_MSP_INVALID_PROCESSOR_LINE = 0x0619
[W] Invalid line in mascot.dat.
static const err | ERR_MSP_LICENSE_DES_CHECKSUM = 0x0701
[F] Check sum in the license file is invalid.
static const err | ERR_MSP_LICENSE_EXPIRED = 0x0704
[F] The license has already expired.
static const err | ERR_MSP_LICENSE_INTERNAL_CONFIG = 0x0705
[F] Internal configuration error when reading a license file.
static const err | ERR_MSP_LICENSE_LINE_CHECKSUM = 0x0702
[F] Check sum in the license file is invalid.
static const err | ERR_MSP_LICENSE_LINE_INVALID = 0x0706
[F] Line [line number] of the license file is corrupt or this is not a license file.
static const err | ERR_MSP_LICENSE_NOT_YET_AVAIL = 0x0703
[F] Start date has not come yet.
static const err | ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED = 0x0A08
[F] Fragmenting of looplinked peptides is not implemented.
static const err | ERR_MSP_MALFORMED_PEPTIDE = 0x0A04
[F] Empty or inconsistent peptide: s
static const err | ERR_MSP_MASCOT_NOT_RUNNING = 0x0903
[F] The Mascot service is not running. Unable to retrieve configuration file.
static const err | ERR_MSP_MAX_PREFIX_REMOVES = 0x0611
[W] Maximum number of prefixes is exceeded in Taxonomy section.
static const err | ERR_MSP_MAX_SUFFIX_REMOVES = 0x0612
[W] Maximum number of suffices is exceeded in Taxonomy section.
static const err | ERR_MSP_MAX_TAX_NO_BREAKS = 0x0613
[W] Maximum number of breaks is exceeded in Taxonomy section.
static const err | ERR_MSP_MISSING_DEFINITION_END = 0x0405
[F] Missing end of modification definition.
static const err | ERR_MSP_MISSING_ENZYME_TITLE = 0x0501
[F] Non-comment line encountered while searching for a title.
static const err | ERR_MSP_MISSING_ET_MOD = 0x0A13
[F] Error tolerant modification lookup failed: s
static const err | ERR_MSP_MISSING_MASCOT_DAT = 0x0601
[F] Missing mascot.dat file.
static const err | ERR_MSP_MISSING_MONOLINK_MOD = 0x0A15
[F] Monolink modification lookup failed: s
static const err | ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE = 0x060D
[W] Missing quote character in a parse rule.
static const err | ERR_MSP_MISSING_SECTION = 0x0626
[W] There is no \'s\' section in the file: s
static const err | ERR_MSP_MISSING_SL_MOD = 0x0A14
[F] Spectral library modification lookup failed: s
static const err | ERR_MSP_MOD_MUST_BE_VAR = 0x0A03
[F] This modification can only be variable.
static const err | ERR_MSP_MS1QUANTITATION_FAILEDINIT = 0x1472
[E] Failed to initialise ms_ms1quantitation: %s
static const err | ERR_MSP_MS1QUANTITATION_HITREF_DROP = 0x1471
[W] Protein hit not found for protein [accession] at reference [oldhit.member]
static const err | ERR_MSP_MS1QUANTITATION_HITREF_NEW = 0x1470
[D2] Protein hit reference has changed for protein [accession] from [oldhit.member] to [newhit.member]
static const err | ERR_MSP_MS2QUANTITATION_COMPONENTS = 0x1435
[W] Different number of raw and corrected MS2 quantitation component intensities for q:d, p:%
static const err | ERR_MSP_MS2QUANTITATION_FAILEDINIT = 0x1430
[E] Failed to initialise ms_ms2quantitation: %s
static const err | ERR_MSP_MS2QUANTITATION_NORM_NO_SUM = 0x1431
[W] Sum normalisation is only implemented in Reporter (current protocol is %s); ignoring normalisation type
static const err | ERR_MSP_MS2QUANTITATION_NORM_UNIMP = 0x1432
[W] Unknown normalisation type %s; ignoring
static const err | ERR_MSP_MS2QUANTITATION_PROTR_UNIM = 0x1434
[W] Protein ratio type %s is not implemented; resetting to median
static const err | ERR_MSP_MS2QUANTITATION_PROTWEIGH = 0x1433
[W] Protein ratio type 'Summed intensities' is only implemented in Reporter (current protocol is %s); resetting to median
static const err | ERR_MSP_MS2QUANTITATION_QUERY_SECS = 0x1436
[W] Cannot provide quantitation information because there is no ms-ms data in this file
static const err | ERR_MSP_NEED_1_EXP_IN_PARSE_RULE = 0x0604
[W] Only one subexpression is allowed per parse rule.
static const err | ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK = 0x1D09
[W] Ion series '[text]' is not valid in NIST format and cannot be used to annotate peaks
static const err | ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY = 0x1D06
[F] Failed to load entry number [text] from [file]. Error [text]
static const err | ERR_MSP_NIST_INDEX_OUT_OF_RANGE = 0x1D0A
[F] Requesting an invalid spectrum number (d) in the msp file: 's' which has d entries
static const err | ERR_MSP_NIST_MODIFICATION_NOT_FOUND = 0x1D0C
[W] The spectral library file contains one or more references to modification: [name] which are not present in unimod. Consider adding to the library_mod_aliases file if appropriate.
static const err | ERR_MSP_NIST_MSP_INCONSISTENT_MODS = 0x1D05
[W] The msp file: 'filename' has an inconsistent mods entry: [text]
static const err | ERR_MSP_NIST_MSP_INVALID_LINE = 0x1D01
[W] The msp file: 'filename' has an unexpected line: 'line'
static const err | ERR_MSP_NIST_MSP_MISSING_PARAMETER = 0x1D02
[W] Missing 'key' in msp file: 'filename'.
static const err | ERR_MSP_NIST_MSP_NO_CREATE_CDB = 0x1D04
[W] Cannot create index file: for msp file: because . Will continue without index
static const err | ERR_MSP_NIST_MSP_NO_SPECTRA = 0x1D03
[F] 'filename' doesn't appear to be an msp file: no lines starting with Name: or no precursor m/z values specified
static const err | ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM = 0x1D08
[W] The msp file: '[file]' contains a spectrum with no peaks. First line is: '[text]'
static const err | ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE = 0x1D0B
[W] The spectral library file: '[file]' contains a spectrum with no precursor m/z value. First line for spectrum is: '[text]'
static const err | ERR_MSP_NIST_SAVE_ZERO_SPECTRA = 0x1D07
[W] Calling ms_spectral_lib_file::saveAs([file]), with start=[value] and end=[value], so file not saved
static const err | ERR_MSP_NO_COMMAS_IN_MOD_NAME = 0x0403
[F] Comma is not allowed in mod name.
static const err | ERR_MSP_NO_ENZYME_SET = 0x0A06
[F] Cannot iterate peptides without enzyme specificity.
static const err | ERR_MSP_NO_LICENSE_FILE = 0x0700
[F] License file cannot be found or invalid.
static const err | ERR_MSP_NO_REGEX_MATCH = 0x0627
[W] Could not find description / accession number in s using rule: s
static const err | ERR_MSP_NO_SUCH_MOD = 0x0406
[F] Cannot find a modification.
static const err | ERR_MSP_PARSE_LEN_EXCEED = 0x060E
[W] Parse rule length exceeds the limit.
static const err | ERR_MSP_PROCESSOR_NOT_IN_SET = 0x061A
[W] Processor specified is not in the ProcessorSet.
static const err | ERR_MSP_QUANT_ACCESSION_NOT_FOUND = 0x2005
[W] Passed accession value [accession] is not present in the search results. The Average reference protein will not be updated
static const err | ERR_MSP_QUANT_CDB_MATCH_STREAM = 0x2000
[F] Failed to load the quantitation match stream, or failed on bytes available check. Cache file name: [text], cdb file name: [text], key: [text]"
static const err | ERR_MSP_QUANT_CDB_MISSING_KEY = 0x2001
[F] No data from cdb for key. Cdb file name: [text], key: [text]
static const err | ERR_MSP_QUANT_EMPTY_REF_ACCESSION = 0x2004
[W] Passed accession value is empty. The Average reference protein will not be updated
static const err | ERR_MSP_QUANT_FAIL_LOAD_MATCH = 0x2007
[W] Quantitation error: failed to load match [value]
static const err | ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE = 0x2003
[F] Failed to load peptide at index [number]
static const err | ERR_MSP_QUANT_FAILEDLOAD = 0x1400
[W] Failed to load quantitation configuration file.
static const err | ERR_MSP_QUANT_FAILEDSAVE = 0x1401
[W] Failed to save quantitation configuration file.
static const err | ERR_MSP_QUANT_HELPER_FAILEDINIT = 0x1410
[E] Failed to initialise ms_quant_helper: %s
static const err | ERR_MSP_QUANT_INVALID_REF_AMOUNT = 0x2006
[W] The passed reference amount value '[value]' is invalid. The reference amount will be set to the default of 1
static const err | ERR_MSP_QUANT_MISSING_COMPONENT = 0x2002
[W] Component number [number] is missing from match [number]
static const err | ERR_MSP_QUANTITATION_BADCOMPONENT = 0x1423
[W] The component name 's' does not exist in the quantitation mehod
static const err | ERR_MSP_QUANTITATION_BADMETHOD = 0x1422
[W] The quantitation method protocol s is not supported for function s
static const err | ERR_MSP_QUANTITATION_FAILEDINIT = 0x1420
[E] Failed to initialise ms_quantitation: %s
static const err | ERR_MSP_QUANTITATION_NOMETHOD = 0x1421
[W] No quantitation method is specified in the results file
static const err | ERR_MSP_REGEX_ERROR = 0x0628
[W] Error s finding description / accession number using rule: s
static const err | ERR_MSP_REPORTBUILDERCOLARR_INVALID = 0x0624
[W] ReportBuilderColumnArrangement must be of the form Name:[columns] where [columns] is a comma-separated string of column names.
static const err | ERR_MSP_RESIDUE_AND_TERMINUS_MOD = 0x0401
[F] Bad mod combination.
static const err | ERR_MSP_RULE_NO_ALREADY_DEFINED = 0x060C
[W] Parsing rule has been defined twice.
static const err | ERR_MSP_SECURITY_ACCOUNT_DISABLED = 0x110E
[F] Cannot login, your account (%s) has been disabled.
static const err | ERR_MSP_SECURITY_ADDGROUP = 0x1204
[I] Add group: name=%s, id=%d.
static const err | ERR_MSP_SECURITY_ADDUSER = 0x1200
[I] Add user: name=%s, id=%d, type=%d, enabled=%d.
static const err | ERR_MSP_SECURITY_BAD_GROUP_NAME = 0x1009
[W] Invalid group name - names cannot contain the following characters:
static const err | ERR_MSP_SECURITY_BAD_USER_NAME = 0x1004
[W] Invalid user name - names cannot contain the following characters:
static const err | ERR_MSP_SECURITY_CMDLINE_CGI = 0x111F
[F] Cannot use command-line session while running in CGI environment.
static const err | ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP = 0x1013
[W] The administrator user cannot be removed from the administrator group.
static const err | ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS = 0x1012
[W] The administrator rights cannot be removed from the administrator group.
static const err | ERR_MSP_SECURITY_DEL_SPECIAL_GROUP = 0x100F
[W] The special system group 's' cannot be deleted.
static const err | ERR_MSP_SECURITY_DEL_SPECIAL_USER = 0x1010
[W] The The special system user 's' cannot be deleted.
static const err | ERR_MSP_SECURITY_DELETEGROUP = 0x1205
[I] Delete group: name=%s, id=%d.
static const err | ERR_MSP_SECURITY_DELUSER = 0x1201
[I] Delete user: name=%s, id=%d.
static const err | ERR_MSP_SECURITY_DIFFERENTIPADDR = 0x1106
[F] The option to check IP address is enabled and this is an attempt to open this session from a different ip address.
static const err | ERR_MSP_SECURITY_DISABLE_ADMIN = 0x1011
[W] The administrator user cannot be disabled.
static const err | ERR_MSP_SECURITY_DUPE_GROUP_ID = 0x1007
[W] Attempt to add a group with the same ID as an existing group.
static const err | ERR_MSP_SECURITY_DUPE_GROUP_NAME = 0x1008
[W] Attempt to add a group with the same name as an existing group.
static const err | ERR_MSP_SECURITY_DUPE_GROUP_NAME_U = 0x1014
[W] Failed to update group -- the name has been changed, and there is already another group with this name.
static const err | ERR_MSP_SECURITY_DUPE_USER_ID = 0x1002
[W] Attempt to add a user with the same ID as an existing user.
static const err | ERR_MSP_SECURITY_DUPE_USER_NAME = 0x1003
[W] Attempt to add a user with the same name as an existing user.
static const err | ERR_MSP_SECURITY_DUPE_USER_NAME_U = 0x1015
[W] Failed to update user -- the name has been changed, and there is already another user with this name.
static const err | ERR_MSP_SECURITY_FAIL_LOAD_GROUP = 0x100E
[W] Failed to load the group information for group.
static const err | ERR_MSP_SECURITY_FAIL_LOAD_SEC = 0x100C
[W] Failed to load the main security configuration files.
static const err | ERR_MSP_SECURITY_FAIL_LOAD_USER = 0x100D
[W] Failed to load the user information for user.
static const err | ERR_MSP_SECURITY_FAIL_SAVE_SEC = 0x1019
[W] Failed to save the main security configuration files.
static const err | ERR_MSP_SECURITY_FAILGETINTEGRA = 0x1116
[W] Failed to get any integra users - return from Integra server was: %s.
static const err | ERR_MSP_SECURITY_FAILGETINTEGRAURL = 0x1115
[W] Failed to contact Integra server. See previous error in log file.
static const err | ERR_MSP_SECURITY_GETALLGROUPIDS = 0x1300
[D3] Called getAllGroupIDs - list of %d ids returned.
static const err | ERR_MSP_SECURITY_GETALLUSERIDS = 0x1307
[D3] Called ms_security::getAllUserIDs - list of %d ids returned.
static const err | ERR_MSP_SECURITY_GETGROUPFAIL = 0x1302
[D3] Called ms_security::getGroup(%s) - group not found.
static const err | ERR_MSP_SECURITY_GETGROUPFROMIDFAIL = 0x1309
[D3] Called ms_security::getGroupFromID('%d') - group id not found.
static const err | ERR_MSP_SECURITY_GETGROUPFROMIDOK = 0x1308
[D3] Called ms_security::getGroupFromID('%d') - returned group (%s) successfully.
static const err | ERR_MSP_SECURITY_GETGROUPOK = 0x1301
[D3] Called ms_security::getGroup(%s) - returned successfully.
static const err | ERR_MSP_SECURITY_GETINTEGRAUSERS1 = 0x130D
[D3] Called ms_security::getIntegraUsers - url %s.
static const err | ERR_MSP_SECURITY_GETINTEGRAUSERS2 = 0x130E
[D3] Called ms_security::getIntegraUsers - return string from URL is: %s.
static const err | ERR_MSP_SECURITY_GETINTEGRAUSERS3 = 0x130F
[D3] Called ms_security::getIntegraUsers - list of %d ids returned.
static const err | ERR_MSP_SECURITY_GETPERMTASKSFAIL = 0x130B
[D3] Called ms_security::getPermittedTasksForUser('%s') - user name not found.
static const err | ERR_MSP_SECURITY_GETPERMTASKSOK = 0x130A
[D3] Called ms_security::getPermittedTasksForUser('%s') - user name found, %d tasks returned.
static const err | ERR_MSP_SECURITY_GETUSERFAIL = 0x1304
[D3] Called ms_security::getUser('%s') - user not found.
static const err | ERR_MSP_SECURITY_GETUSERFROMIDFAIL = 0x1306
[D3] Called ms_security::getUserFromID('%d') - user id not found..
static const err | ERR_MSP_SECURITY_GETUSERFROMIDOK = 0x1305
[D3] Called ms_security::getUserFromID('%d') - returned user (%s) successfully.
static const err | ERR_MSP_SECURITY_GETUSEROK = 0x1303
[D3] Called ms_security::getUser('%s') - returned successfully.
static const err | ERR_MSP_SECURITY_GROUPID_NOT_FOUND = 0x100B
[W] Group ID not found.
static const err | ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND = 0x100A
[W] Group name not found.
static const err | ERR_MSP_SECURITY_INTEGRACONNFORMAT = 0x1117
[F] Integra connection id (%s) is not of the format expected.
static const err | ERR_MSP_SECURITY_INTEGRAINVALIDCO = 0x1119
[F] Integra connection id has probably timed out. Error return is: %s
static const err | ERR_MSP_SECURITY_INTEGRAINVALIDPW = 0x1118
[F] Integra password is probably invalid. Error return is: %s
static const err | ERR_MSP_SECURITY_INVALID_SESSION_ID = 0x1000
[W] An invalid session ID was passed to a function.
static const err | ERR_MSP_SECURITY_INVALIDPASSWORD = 0x1102
[F] You have entered an invalid password, %s - please try again [ec=%d].
static const err | ERR_MSP_SECURITY_INVALIDSESSION = 0x1109
[F] The current session is invalid, but an attempt has been made to save parameters.
static const err | ERR_MSP_SECURITY_INVALIDUSER = 0x1101
[F] No such user.
static const err | ERR_MSP_SECURITY_LOADINGSESS = 0x1332
[D3] Loading session (%s).
static const err | ERR_MSP_SECURITY_LOADSESSIONFILE = 0x111A
[F] The session file exists but we can't load it.
static const err | ERR_MSP_SECURITY_MISSINGSESSIONFILE = 0x1103
[F] Can't find the session file requested.
static const err | ERR_MSP_SECURITY_MSSESSCOOKIE = 0x1331
[D3] Cookie from ms_session::ms_session() = %s.
static const err | ERR_MSP_SECURITY_MSSESSINTEGRA = 0x1334
[I] Called ms_session::ms_session(%s,[connectionID],%s).
static const err | ERR_MSP_SECURITY_MSSESSIONCTOR = 0x1330
[D3] Called ms_session::ms_session(%s).
static const err | ERR_MSP_SECURITY_MSSESSLOGIN = 0x1333
[I] Called ms_session::ms_session(%s,[password]).
static const err | ERR_MSP_SECURITY_MSSESSRESULTSPERM = 0x1335
[D3] Called ms_session::canResultsFileBeViewed(%d - return %d).
static const err | ERR_MSP_SECURITY_NO_GUEST_PWD = 0x1017
[W] You cannot set a password for the guest user.
static const err | ERR_MSP_SECURITY_NO_INTEGRA_LOGIN = 0x111D
[F] You cannot login from this screen. Please login to Mascot Integra first, and access the Mascot Home Page from there.
static const err | ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR = 0x101A
[W] Insufficient acccess rights to update user profile for %s.
static const err | ERR_MSP_SECURITY_NOCREATEGUEST = 0x110C
[F] Unable to create a guest session.
static const err | ERR_MSP_SECURITY_NOSAVEPARAMS = 0x110A
[F] Cannot save parameters in this type of sessin (e.g. guest user, no authentication enabled).
static const err | ERR_MSP_SECURITY_NOT_ADMIN_SESSION = 0x1001
[W] Administrator rights are required to add, delete or change users or groups.
static const err | ERR_MSP_SECURITY_NOT_ENABLED = 0x111C
[F] There is no need to login to this server - Mascot security is not enabled.
static const err | ERR_MSP_SECURITY_NOT_INTEGRA_USER = 0x111B
[F] The 'type' of user (%s) needs to be changed to a Mascot Integra user using the Mascot security administration application.
static const err | ERR_MSP_SECURITY_NOTLOGGEDIN = 0x1108
[F] User is not logged in, so could not create a session.
static const err | ERR_MSP_SECURITY_NOTNORMALUSER = 0x110F
[F] Cannot login as this user (%s) because the user type is not a 'normal' or 'integra' user.
static const err | ERR_MSP_SECURITY_OLD_PW_INVALID = 0x1016
[W] The old password is not correct and you don't have administrator rights. Password not changed.
static const err | ERR_MSP_SECURITY_PASSWORD_TOO_SHORT = 0x1018
[W] The password entered is too short. Minimum length required is defined in the options.
static const err | ERR_MSP_SECURITY_PASSWORDEXPIRED = 0x1107
[F] Your password has expired, %s - please enter a new password.
static const err | ERR_MSP_SECURITY_SAMEPASSWORD = 0x1110
[F] Cannot change your password to the same as the previous password.
static const err | ERR_MSP_SECURITY_SAVESESSIONFILE = 0x1104
[F] Can't save a new session file.
static const err | ERR_MSP_SECURITY_SESSIONDESTROYED = 0x110B
[D1]The session has been terminated and is therefore no longer valid.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT1 = 0x1111
[F] Trying to use session %s from computer with ip address %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT2 = 0x1112
[F] Trying to use session %s when logged into the web server as %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT3 = 0x1113
[F] Trying to use session %s (USER_AGENT_STRING) when agent string is actually %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_SPOOFATTEMPT4 = 0x1114
[F] Trying to use command line session %s from a cgi application at ip address %s - please contact your administrator.
static const err | ERR_MSP_SECURITY_TIMEDOUT = 0x1105
[F] Session has timed out.
static const err | ERR_MSP_SECURITY_UPDATEALLSESSFILES = 0x130C
[D3] Called ms_security::updateAllSessionFiles - %d files potentially updated.
static const err | ERR_MSP_SECURITY_UPDATEGROUP = 0x1206
[I] Updated group: id=%d, old name=%s, new name=%s, added users=%s, deleted users=%s. Changed tasks=%s.
static const err | ERR_MSP_SECURITY_UPDATEPW = 0x1203
[I] Update user password for user id %d, name %s. Old p/w expiry=%ld. New p/w expiry=%ld.
static const err | ERR_MSP_SECURITY_UPDATESESS = 0x110D
[F] Unable to update session %s. Error %s.
static const err | ERR_MSP_SECURITY_UPDATEUSER = 0x1202
[I] Update user %d: [old,new]. Name=[%s,%s], FullName=[%s,%s], pw_exp=[%ld,%ld], type=[%d,%d], email=[%s,%s], enabled=[%d,%d].
static const err | ERR_MSP_SECURITY_USERID_NOT_FOUND = 0x1006
[W] User ID not found.
static const err | ERR_MSP_SECURITY_USERNAME_NOT_FOUND = 0x1005
[W] User name not found.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRACO1 = 0x1313
[D3] Called ms_security_session::verifyIntegraConnection - url %s.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRACO2 = 0x1314
[D3] Called ms_security_session::verifyIntegraConnection - OK.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 = 0x1310
[D3] Called ms_security_session::validateIntegraPassword - url %s.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 = 0x1311
[D3] Called ms_security_session::validateIntegraPassword - return string from URL is: %s.
static const err | ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 = 0x1312
[D3] Called ms_security_session::validateIntegraPassword - OK.
static const err | ERR_MSP_SESSION_UTIME_FAIL = 0x111E
[W] Failed to update last modified time for s. Error: s
static const err | ERR_MSP_SL_SCORING_MODEL_FAIL = 0x1F01
[W] Failed to fit spectral library scoring model, so using a default threshold. Reason: s
static const err | ERR_MSP_SL_SCORING_MODEL_WARN = 0x1F02
[W] Spectral library threshold may not be optimal: s
static const err | ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR = 0x061B
[W] ProcessorSet specifies unavailable processor.
static const err | ERR_MSP_SYSMP_FAIL = 0x0106
[F] Failed call to sysmp() for multi-processor support.
static const err | ERR_MSP_TARGET_FDR_FAILED_FOR_ET = 0x1F03
[W] Target FDR s g%% could not be reached for error tolerant matches. Using first pass sigthreshold for error tolerant matches.
static const err | ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS = 0x1F06
[W] Target FDR s g%% could not be reached. Using minProbability = g.
static const err | ERR_MSP_TAXONOMY_CONFLICT_PARENTS = 0x0B05
[W] The parent for taxonomy id d in s conflicts with parent specified in files: s
static const err | ERR_MSP_TAXONOMY_DEFINITION_END = 0x0B04
[F] Missing end of taxonomy choice definition.
static const err | ERR_MSP_TAXONOMY_INVALID_NODE_FILE = 0x0B06
[F] Invalid line [%s] in the node file [%s].
static const err | ERR_MSP_TAXONOMY_MISSING_NODE_FILE = 0x0B07
[F] The taxonomy node file [%s] is missing.
static const err | ERR_MSP_TAXONOMY_NO_COMMAS = 0x0B02
[F] Comma is not allowed in taxonomy choice title.
static const err | ERR_MSP_TAXONOMY_NO_TITLE = 0x0B01
[F] The first non-empty line is expected to be Title:....
static const err | ERR_MSP_TAXONOMY_WRONG_LINE = 0x0B03
[F] Line cannot be parsed.
static const err | ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE = 0x0402
[W] Too many modification have been loaded from file(s).
static const err | ERR_MSP_TOO_MANY_PROCESSORS = 0x061C
[W] More processors specified than licensed.
static const err | ERR_MSP_TOO_MANY_TH_PROCESSORS = 0x061D
[W] Too many processors named for a smaller number of threads for a database.
static const err | ERR_MSP_UMOD_FAILEDLOAD = 0x1500
[W] Failed to load unimod.xml file.
static const err | ERR_MSP_UMOD_FAILEDSAVE = 0x1501
[W] Failed to save unimod.xml file.
static const err | ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT = 0x0625
[W] Expecting a comment or section name, but found "%s" in the file: s
static const err | ERR_MSP_WRONG_ICAT_FILTER = 0x0620
[W] Empty ICAT filter is not allowed.
static const err | ERR_MSP_WRONG_MOD_VECTOR = 0x0A02
[F] Variable mods vector cannot be applied to the peptide.
static const err | ERR_MSP_WWW_SECTION = 0x061E
[W] Error in WWW section.
static const err | ERR_MSP_XHUNTER_WRONG_FORMAT = 0x1D20
[W] Mods= line '[text]' is not in valid XHunter format.
static const err | ERR_MSP_XML_ELEMENT_NOT_FOUND = 0x0807
[F] Cannot find element with the supplied name.
static const err | ERR_MSP_XML_FAILEDLOAD = 0x0809
[F] Failed to load xml file 's'. Reason: 's'.
static const err | ERR_MSP_XML_FAILEDSAVE = 0x0810
[F] Failed to save xml file 's'.
static const err | ERR_MSP_XML_FIELD_NOTFOUND = 0x0804
[F] Records in a table doesn't have the required field.
static const err | ERR_MSP_XML_INVALID_FIELD_FORMAT = 0x0805
[F] Field of a record contains data in wrong format.
static const err | ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED = 0x0806
[F] Cannot store XML-schema file locally.
static const err | ERR_MSP_XML_MEMORY_ERROR = 0x0808
[F] Memory allocation failed when working with XML.
static const err | ERR_MSP_XML_NO_ROOT_ELEMENT = 0x0802
[F] XML document doesn't contain a root element.
static const err | ERR_MSP_XML_SYSTEM_FAILED = 0x0801
[F] XML-library failure.
static const err | ERR_MSP_XML_TABLE_NOTFOUND = 0x0803
[F] Table with a specific name is not found amongst children of the current node.
static const err | ERR_MSP_XMLSCHEMA_FAILEDLOAD = 0x1600
[W] Failed to load xml schema file.
static const err | ERR_MSP_XMLSCHEMA_FAILEDSAVE = 0x1601
[W] Failed to save xml schema file.
static const err | ERR_MSP_ZIP_BUFTOOSMALL = 0x1702
[F] Buffer too small - [value].
static const err | ERR_MSP_ZIP_ENDIAN = 0x1700
[W] Failed to determine endian - assuming little endian.
static const err | ERR_MSP_ZIP_INVALIDDATA = 0x1703
[F] Compressed data is invalid.
static const err | ERR_MSP_ZIP_LENGTHDIFFERS = 0x1705
[F] Expected length of uncompressed data ([value]) differs from actual length [value].
static const err | ERR_MSP_ZIP_NOTSTREAMING = 0x1709
[F] Streaming mode not initalised
static const err | ERR_MSP_ZIP_OUTOFMEMORY = 0x1701
[F] Insufficient memory to compress/decompress the data.
static const err | ERR_MSP_ZIP_STREAMERROR = 0x1710
[F] Cannot compress: [reason]
static const err | ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG = 0x1706
[F] Uncompressed data longer ([value]) than maximum permitted ([value]).
static const err | ERR_MSP_ZIP_UNKNOWN = 0x1704
[F] Unknown zip error
static const err | ERR_MSP_ZIP_VERSIONERROR = 0x1708
[F] Invalid zlib version: [reason]
static const err | ERR_MSP_ZIP_ZEROLENGTH = 0x1707
[F] Cannot compress zero length data.
static const err | ERR_NEED_64_BIT = 0x002B
[F] This results file (%s) is too large for 32 bit Mascot Parser. Please upgrade to 64 bit.
static const err | ERR_NO_ERR_TOL_PARENT = 0x0010
[F] No parent search file. See Error tolerant searches.
static const err | ERR_NO_ERROR = 0x0000
[W] Success.
static const err | ERR_NO_UNIGENE_FILE = 0x0017
[F] Failed to open the UniGene file specified.
static const err | ERR_NOMEM = 0x0001
[F] Failed to allocate memory to load the file.
static const err | ERR_NOSUCHFILE = 0x0002
[F] The file passed in the constructor does not exist.
static const err | ERR_NULL_ACC_PEP_SUM = 0x0011
[W] An empty accession string has been found. Possible problem in database.
static const err | ERR_NULL_ACC_PROT_SUM = 0x0012
[W] An empty accession string has been found. Possible problem in database.
static const err | ERR_OLDRESULTSFILE = 0x0019
[F] Very old results file (last century!). Parser requires 1.02 or later.
static const err | ERR_PEPSUMMPEPGET = 0x0006
[F] Value of q, p or h out of range, so cannot get peptide info.
static const err | ERR_PEPTIDESTR = 0x0007
[F] The string in the peptides block is not valid.
static const err | ERR_PROTSUMM = 0x0009
[F] Error parsing a line in the protein summary.
static const err | ERR_PROTSUMMPEP = 0x000A
[F] Couldn't parse peptide information from the protein summary section..
static const err | ERR_QUERYOUTOFRANGE = 0x0004
[F] Set if query < 1 or query > getNumQueries.
static const err | ERR_READINGFILE = 0x0003
[F] Opened the file successfully, but failed to read from it.
static const err | ERR_RESFILE_INVALID_DB_TYPE = 0x1E01
[W] Invalid database type 's'. Forcing to AA.
static const err | ERR_RESFILE_LINKED_SITES = 0x1E02
[W] Could not read s from qd_pd_linked_sites in section s
static const err | ERR_RESFILE_LOOPLINKED_SITES = 0x1E03
[W] Could not read s from qd_pd_looplinked_sites in section s
static const err | ERR_RESFILE_MISSING_QEXP = 0x1E04
[W] Could not read s from section s in s
static const err | ERR_RESULTS_NOT_CREATED = 0x003A
[W] Attempting to call Mascot Parser function %s before createSummary() has completed.
static const err | ERR_UNASSIGNED_PROG = 0x0014
[F] Programming error! Calling getNumberOfUnassigned() or getUnassigned() before createUnassignedList().
static const err | ERR_UNASSIGNED_RANGE = 0x0015
[F] Calling ms_mascotresults::getUnassigned() with out of range number.
static const err | ERR_UNASSIGNED_UNK = 0x0016
[F] Calling ms_mascotresults::getUnassigned() -- unable to retrieve value.
static const err | ERR_UNIGENE_MULTIDB = 0x0020
[W] UniGene index is not supported in multi-database search.
static const err | ERR_WRITE_CDB_FILE = 0x0029
[W] Failed to write to the cache file (%s). Error %d (%s).
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED = 0x0001060F
[D2] Iteration for seriesID=[num] stops at index=[num] and mass=[mass]: limit is [mass]
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES = 0x00010610
[D2] Skipping d' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE = 0x00010611
[D2] Skipping d residue because it doesn't match /[ITV]/ or /[CDEKLMNPQRS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE = 0x00010612
[D2] Skipping v residue because it doesn't match /[ARDNCQEHILKMFPSTWYV]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES = 0x00010613
[D2] Skipping w' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE = 0x00010614
[D2] Skipping w residue because it doesn't match /[ITV]/ or /[RDNCQELKMPS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER = 0x0001061D
[D3] PSM component [num] position i=[num] has intact link, modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK = 0x0001061E
[D3] PSM component [num] position i=[num] has monolink modnum=[num] monoLinkNum=[num] title=[name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK = 0x0001061F
[D1] PSM component [num] column i=[num] is ignored because there is a looplink at sites [num]-[num], modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MASSES_VALUE = 0x0001061B
[D2] Active ms_masses: [name]=[value]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE = 0x0001061C
[D1] Modification at site i=[num] is [name] with delta=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS = 0x00010600
[D1] Calculated [num] fragments for psmComponent=[num], seriesID=[num], fragCharge=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass]
static const msg_num_t | LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT = 0x0001061A
[D1] cfr: Initialising isotopes and fixed mods from quant component [name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_START_FRAGMENTS = 0x00010618
[D1] cfr(psmComponent=[num], seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass])
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_END = 0x00010619
[D1] calcCrosslinkedFragments: returning [num] alpha and [num] beta fragments
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_START = 0x00010609
[D1] calcCrosslinkedFragments(seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num]); mass of linker + alpha = [mass]; linker + beta = [mass]
static const msg_num_t | LOGMSG_AAHELPER_CUMULATIVE_MASS_NL = 0x0001060D
[D2] Cumulative mass and NL at i=[num] residue=[char]: m[i]=[mass], nl[i]=[mass]
static const msg_num_t | LOGMSG_AAHELPER_ETMOD_LOOKUP = 0x00010615
[D1] lookupErrorTolerantModification(q=[num], p=[num], residue=[char]) --> raw name=[string], raw delta=[string], mod name=[name], mod delta=[mass], is mod?=[num], nl=[mass]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_ADD = 0x00010606
[D2] Added immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_REJECT = 0x00010605
[D2] Rejected immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_ADD = 0x00010608
[D2] Added internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_REJECT = 0x00010607
[D2] Rejected internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_MASTER_NL_VALS = 0x0001060B
[D2] Master neutral loss=[array]
static const msg_num_t | LOGMSG_AAHELPER_MULTINL_INDICES = 0x0001060A
[D1] Currently active multi NL indices=[array]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_ADD = 0x00010602
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_REJECT = 0x00010601
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD = 0x00010604
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT = 0x00010603
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_SERIES_PARAMS = 0x0001060E
[D1] Parameters for seriesID=[num]: delta=[mass], start=[num], end=[num], forward=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG = 0x00010617
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) --> anyChange=[num], modNum=[num], oldStyleModName=[string], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT = 0x00010616
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) --> modNum=[num], idx=[num], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_TOTAL_NL_VALS = 0x0001060C
[D2] Currently active multi NL neutral loss=[array]
static const msg_num_t | LOGMSG_CUSTQUANT_ADD_QUANT_KEY = 0x00010400
[D2] Adding quantitation key id d to protein s .
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_ALL_KEY = 0x00010401
[D2] Removing quantitation key d from any proteins.
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_KEY = 0x00010402
[D2] Removed quantitation key d from protein s.
static const msg_num_t | LOGMSG_DBG1_NUM_PROCESSOR_GROUPS = 0x00010160
[D1] Debug: Number of processor groups : %d.
static const msg_num_t | LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS = 0x00010178
[D2] Debug: Number of cores per physical cpu : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_GETAUTODETECT = 0x00010179
[D2] Debug: getAutoDetectNumThreads(1,4) : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS = 0x00010177
[D2] Debug: Number of logical cpus / physical cpu: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_NAME = 0x0001017A
[D2] Debug: Multi-threaded name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_STATUS = 0x0001017B
[D2] Debug: Hyper/multi threading status : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NAME = 0x00010173
[D2] Debug: Processor name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_AVAIL = 0x00010171
[D2] Debug: Logical number of cpus available : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_GROUPS = 0x00010172
[D2] Debug: Number of processor groups : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_ON_SYS = 0x00010170
[D2] Debug: Logical number of cpus on the system : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL = 0x00010176
[D2] Debug: Physical number of cpus on the system: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_PROC_AFFINITY = 0x00010174
[D2] Debug: Process Affinity supported : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_LINE = 0x0001017D
[D2] Debug: 3d : 2d / 5d / 5d / %s / %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_TITLE = 0x0001017C
[D2] Debug: logical : physical id / core id / ht id / is primary / is threaded:
static const msg_num_t | LOGMSG_DBG2_CPU_INF_USE_PROCESSES = 0x00010175
[D2] Debug: Use processes instead of threads : %s
static const msg_num_t | LOGMSG_DBG2_NUM_CONFIG_MISMATCH = 0x00010168
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d configured processors.
static const msg_num_t | LOGMSG_DBG2_NUM_ONLINE_MISMATCH = 0x00010169
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d online processors.
static const msg_num_t | LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD = 0x00010163
[D3] Debug: getAutoDetectNumThreads. logicalPerPhysical: %d, numCores: %d, numLicensed: %d, numCoresPerCpuLicense: %d, maxLicensable: %d, numAvailableToProcess: %d.
static const msg_num_t | LOGMSG_DBG3_BINDING_PROCESSORS = 0x00010166
[D3] Debug: binding processors %s.
static const msg_num_t | LOGMSG_DBG3_BINDING_THREAD = 0x00010167
[D3] Debug: binding thread p to logical processor %d.
static const msg_num_t | LOGMSG_DBG3_CALL_GET_CHIP_MFCTR = 0x00010164
[D3] Debug: about to call getChipManufacturer()
static const msg_num_t | LOGMSG_DBG3_HWLOC_GROUPS = 0x00010162
[D2] Debug: hwloc reports %d processor groups.
static const msg_num_t | LOGMSG_DBG3_HWLOC_TREE = 0x00010161
[D3] Debug: iterateHwlocChildren: %-8s, logical: %d, depth: %d, packageID: %d, coreID: %d.
static const msg_num_t | LOGMSG_DBG3_PROCESSOR_NAME = 0x00010165
[D2] Debug: processor name: %s, hyperthreading: %s.
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND = 0x00010A05
[D2] getThresholdForFDR: found a new minimum at i=d, fdr_min=g, target_min=d, decoy_min=d, expect_min=g
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_START = 0x00010A03
[D2] getThresholdForFDR: i=d, expect=g, target=d, decoy=d, target_count=d, decoy_count=d, fdr=g, too_few=d
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT = 0x00010A04
[D2] getThresholdForFDR: target or decoy count dropped to zero at i=d, target_count=d, decoy_count=d
static const msg_num_t | LOGMSG_GET_THR_REACH_COND = 0x00010A06
[D2] getThresholdForFDR: Result FDR reached; minimum seen at fdr_min=g, expect_min=g, target_min=d, decoy_min=d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET = 0x00010A02
[D1] getThresholdForFDR(g, s, DM_FASTA_SECOND_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR = 0x00010A01
[D1] getThresholdForFDR(g, s, DM_FASTA_FIRST_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_HTTP_GETRETURNSTRING = 0x00010304
[I] The http GET returned '[text]'.
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONS10FAILED = 0x00010303
[I] Failed to set maximum connections per 1.0 server
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONSFAILED = 0x00010302
[I] Failed to set maximum connections per server
static const msg_num_t | LOGMSG_HTTP_QUERYSTATUSRESULT = 0x00010301
[I] HTTP status is [httpCode] 'httpText'.
static const msg_num_t | LOGMSG_HTTP_URLSTRING = 0x00010300
[I] Sending HTTP [httpMethod] to [url] for action [command].
static const msg_num_t | LOGMSG_INST_ADDINGDATABASE = 0x00010205
[I] Adding entry for s to mascot.dat.
static const msg_num_t | LOGMSG_INST_ADDOPTIONSSECTION = 0x00010208
[I] Added [value] to the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_APPENDPARSERULE = 0x00010207
[I] Added parse rule number [value].
static const msg_num_t | LOGMSG_INST_APPENDTAXONOMY = 0x00010204
[I] Appended taxonomy section [value].
static const msg_num_t | LOGMSG_INST_CHANGEDBTAXONOMY = 0x00010206
[I] Changed taxonomy entry for [database].
static const msg_num_t | LOGMSG_INST_CHANGEPARSERULE = 0x0001020C
[I] Changed [value] parse rule from rule [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPERCOLATORFEATS = 0x00010210
[I] Changed PercolatorFeatures section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPROTFAMILYSWITCH = 0x00010211
[I] Changed ProteinFamilySwitch section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CLUSTERSECTION = 0x0001020A
[I] Set the value of [name] to [value] in the cluster section of mascot.dat.
static const msg_num_t | LOGMSG_INST_FAILSAVEPOSTINSTALLFILE = 0x0001020E
[I] Failed to save Post Install File [name]. Error [value]
static const msg_num_t | LOGMSG_INST_LOGICALPERPHYSICALCPU = 0x00010200
[I] Detected %d logical processors per physical CPU.
static const msg_num_t | LOGMSG_INST_MASCOTDATOK = 0x00010203
[I] Successfully loaded existing mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NOSUBCLUSTERSET = 0x0001020B
[I] No SubClusterSet entry in mascot.dat.
static const msg_num_t | LOGMSG_INST_NOTMASCOTDATOK = 0x00010202
[I] Successfully loaded not.mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NUMTHREADS = 0x00010201
[I] Setting number of threads to [value].
static const msg_num_t | LOGMSG_INST_REMOVEOPTIONSSECTION = 0x0001020F
[I] Removed [value] from the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_SAVEDPOSTINSTALLFILE = 0x0001020D
[I] Saved line ([text]) in Post Install File [name] for Database Manager
static const msg_num_t | LOGMSG_INST_SETOPTIONSSECTION = 0x00010209
[I] Set the value of [name] to [value] in the options section of mascot.dat.
static const msg_num_t | LOGMSG_MATRIX_OUTPUT_VALS = 0x00010500
[D3] s. d rows and d columns
s
static const msg_num_t | LOGMSG_PEPSUM_GETHIT = 0x00010729
[D3] [function]: [string], [string], [string]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP = 0x00010713
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => keep
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_START = 0x00010710
[D1] choose_next_free_protein(): lead_proteins are [list]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY = 0x00010711
[D2] choose_next_free_protein(): free_count of "[accession]" is [num] but no superset found in lead_proteins; keeping for now
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST = 0x00010712
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => move to subset_list with parents [list]
static const msg_num_t | LOGMSG_PROTINFER_CLUSTER_FROM_ACC = 0x00010726
[D1] sortByScore(): Starting point for cluster in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO = 0x0001070D
[D2] eliminate_intersections() : ran out of unused_proteins (all free counts are zero)
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT = 0x0001070E
[D2] eliminate_intersections() : next unused protein to try to add is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST = 0x0001070F
[D2] eliminate_intersections() : fix-up of supersetlist for "[accession]", [changed lists]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_END = 0x00010704
[D1] findFamily() end for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_QUEUE = 0x00010701
[D1] findFamily(): "[accession]" has [num] PSMs above threshold ([num] PSMs below), [num] homologous proteins, in_queue size=[num], queue size=[num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS = 0x00010702
[D1] findFamily(): "[accession]" has the following [num] representative sequences: [list]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_START = 0x00010700
[D1] findFamily() start for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END = 0x00010725
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START = 0x00010723
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START = 0x00010724
[D2] findMatchesForThisProteinAndChildren(): Subset accession: [accession]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST = 0x00010708
[D2] groupFamily(): discardedSLProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION = 0x00010709
[D1] groupFamily(): eliminate_intersections. lead_proteins size = [num], subset_proteins size = [num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST = 0x0001070B
[D1] groupFamily(): leadProteins after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST = 0x0001070A
[D1] groupFamily(): family members after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST = 0x0001070C
[D1] groupFamily(): "[accession]" has parent "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN = 0x0001072B
[D1] homologous_proteins(): "[accession]" shares q[num]_p[num] with "[accession]" => pull it in to the family
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST = 0x00010707
[D2] groupFamily(): samesetLeadProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST = 0x00010706
[D2] groupFamily(): samesetParents: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_START = 0x00010705
[D1] groupFamily() for "[accession]": samesetLeadProteins=[num], samesetParents=[num], discardedSLProteins=[num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FROM_ACC = 0x00010727
[D1] sortByScore(): Starting point for group in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY = 0x0001072A
[D2] findFamily(): Family [num] has [num] peptide matches with keepingThisOne=[boolean]
static const msg_num_t | LOGMSG_PROTINFER_PEPTIDE_MATRIX = 0x00010703
[D2] findFamily(): [type] peptide matrix (transposed)
[matrix]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD = 0x00010716
[D2] remove_conflicting_proteins(): lead protein "[accession]" has free count n < minNumSigUniqueSeqs (n = [num], minNumSiqUniqueSeqs = [num]) => move to subset list with parents [accessions]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP = 0x00010715
[D2] remove_conflicting_proteins(): lead protein "[accession]" does not overlap with any current lead protein => keep
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_START = 0x00010714
[D2] remove_conflicting_proteins([list])
static const msg_num_t | LOGMSG_PROTINFER_SINGLETON_FROM_ACC = 0x00010728
[D1] sortByScore(): No grouping; hit [num] is just "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE = 0x00010718
[D2] sortByScore(): About to create sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED = 0x00010719
[D2] sortByScore(): Finished creating sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_DONE = 0x00010722
[D1] sortByScore(): reached the end of sorted_, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN = 0x00010721
[D1] sortByScore(): next accession in sorted_ with significant rank 1 peptide is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS = 0x0001071A
[D1] sortByScore(): proteins_ is empty, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD = 0x00010720
[D1] sortByScore(): Removing "[accession]" because setBoldAndCheckBoxItems() returned false
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN = 0x0001071D
[D1] sortByScore(): Removing "[accession]" because longestPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN = 0x0001071E
[D1] sortByScore(): Removing "[accession]" because longestSigPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS = 0x0001071C
[D1] sortByScore(): Removing "[accession]" because numProteins [num] >= maxHitsToReport [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE = 0x0001071B
[D1] sortByScore(): Removing "[accession]" because its score [num] is less than minProteinScore [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_START = 0x00010717
[D1] sortByScore(): Num proteins: [num], num peptides: [num], hitToAdd: [num]
static const msg_num_t | LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT = 0x0001071F
[D2] sortByScore(): Protein "[accession]" is a subset in hit [num]. Because MSRES_SUBSETS_DIFF_PROT is active, it will now start hit [num]
static const msg_num_t | LOGMSG_QUANT_ADDED_PROTEIN_HIT = 0x00010417
[D2] Added quantitation protein hit [accession] to match [value] with sequence [text]
static const msg_num_t | LOGMSG_QUANT_ADDING_PROTEIN_HIT = 0x00010416
[D2] Adding quantitation protein hit [accession]
static const msg_num_t | LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED = 0x0001040F
[D2] Calling calc_complete() on merged dataset
static const msg_num_t | LOGMSG_QUANT_CLOSING_CACHE_FILE = 0x00010419
[D2] Closing quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE = 0x00010411
[D2] Excluding peptide for query: [value], rank: [value] because [string]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN = 0x00010413
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] > [value]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN = 0x00010412
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] < [value]
static const msg_num_t | LOGMSG_QUANT_FINISH_CALC_COMPLETE = 0x00010406
[D2] Finished calc_complete() call
static const msg_num_t | LOGMSG_QUANT_FINISH_LOAD_CDB = 0x00010409
[D2] Finished loadCdbFile() call
static const msg_num_t | LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE = 0x0001041B
[D1] Finished reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES = 0x00010404
[D2] Finished updating protein matches
static const msg_num_t | LOGMSG_QUANT_HELPER_TEST_REQUIRED = 0x00010800
[D3] testRequiredMods(): sorted required mods="[string]", sequence="[string]", mods="[string]", iter=[char]
static const msg_num_t | LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES = 0x0001040A
[D2] Loading all peptide status values
static const msg_num_t | LOGMSG_QUANT_LOADING_MATCHES = 0x0001040B
[D2] Loading quantitation matches
static const msg_num_t | LOGMSG_QUANT_OPENING_CACHE_FILE = 0x00010418
[D2] Opening quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_REAPPLY_THRESHOLDS = 0x0001040D
[D2] Reapplying quantitation quality thresholds
static const msg_num_t | LOGMSG_QUANT_REMATCHING_INFERRED = 0x00010410
[D2] Rematching [value] inferred matches
static const msg_num_t | LOGMSG_QUANT_REMOVE_INFERRED_MATCH = 0x00010415
[D1] Removing inferred quantitation match [value] - [value] < [value]
static const msg_num_t | LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE = 0x00010414
[D1] Removing quantitation match [value] - no remaining evidence
static const msg_num_t | LOGMSG_QUANT_START_CALC_COMPLETE = 0x00010405
[D2] Calling calc_complete()
static const msg_num_t | LOGMSG_QUANT_START_LOAD_CDB = 0x00010408
[D2] Start of loadCdbFile() call. Cdb file: [filename], cache file: [filename]
static const msg_num_t | LOGMSG_QUANT_START_REORDER_AFTER_MERGE = 0x0001041A
[D1] Starting reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_START_UPDATE_PROT_MATCHES = 0x00010403
[D2] Starting to update protein matches
static const msg_num_t | LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES = 0x0001040E
[D2] Updating excluded matches
static const msg_num_t | LOGMSG_QUANT_UPDATING_PEP_EVIDENCE = 0x0001040C
[D2] Updating Peptide Evidence
static const msg_num_t | LOGMSG_REPORT_FUNCTION_CALLED_BY = 0x00010900
[D3] [function], called by [string]
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY = 0x00010901
[D3] [function] entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 = 0x00010902
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 = 0x00010903
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 = 0x00010904
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 = 0x00010905
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT = 0x00010910
[D3] [function] exited
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT_WITH = 0x00010911
[D3] [function] exited with [string]
static const msg_num_t | LOGMSG_RESFILE_APPEND = 0x00010A00
[D2] [string] numQueries=[num] cachedExpValues=[num]

Detailed Description

All errors are collected in an instance of this class.

Examples:

common_error.cpp, and tools_aahelper.cpp.

Member Typedef Documentation

typedef int msg_num_t [inherited]

Typedef for log and error message numbers.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Logging messages are classified as:

  • [I] information
  • [D1] Debug level 1 message
  • [D2] Debug level 2 message
  • [D3] Debug level 3 message

Ranges:

Product | Classification | First | Last
Parser | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00010000 | 0x0001FFFF
MSQuantlib | sev_fatal, sev_warn | 0x00020000 | 0x0002FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00030000 | 0x0003FFFF
Purifier API | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00040000 | 0x0004FFFF
Purifier | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00050000 | 0x0005FFFF
Mascot Server | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00060000 | 0x0006FFFF
MDRO | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x4C020000 | 0x4C03FFFF

Member Enumeration Documentation

enum msg_sev [inherited]

Message severity levels.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See also: ms_loggingmonitor::Level_e

Enumerator:
sev_fatal

A fatal error that results in the object being 'invalid'.

sev_warn

A warning message.

sev_info

Information message.

sev_debug1

Debug level 1 message.

sev_debug2

Debug level 2 message.

sev_debug3

Debug level 3 message.

Constructor & Destructor Documentation

ms_errs | ( | msg_sev | loglevel = sev_warn,
 |  | bool | combineRepeats = true,
 |  | ms_loggingmonitor::Source_e | api = ms_loggingmonitor::SRC_MSPARSER
 | ) |  |

Constructor.

This constructor is generally for Matrix Science use only.

Parameters:
loglevel | should specify the maximum level of logging for this object. A different level can be specified for ms_loggingmonitor, so ms_log::sev_fatal or ms_log::sev_warn is normally sufficient here.
combineRepeats | should be set to true to avoid multiple occurences of the same message appearing in the list of messages.
api | needs to be specified when using this class inside an api or application other than Mascot Parser.

Member Function Documentation

void addToCatalog | ( | const msg_catalog_t | catalog[],
 |  | size_t | numEntries,
 |  | ms_loggingmonitor::Source_e | src,
 |  | errorOrLogMessages_e | errorOrLogMessages
 | ) |  | [inherited]

Add messages to the fast lookup map.

Parameters:
catalog | is a pointer to an array of messages and severities
numEntries | is the number of entries in catalog
src | is used to check if the messages have already been added to the static catalog_ map.
errorOrLogMessages | is used, with src to check if the messages have already been added to the static catalog_ map.
void appendErrors ( const ms_errs & src )

Copies all errors from another instance and appends them at the end of own list.

Mostly used internally, but can be useful for appending errors from one object into another object

Parameters:
src is the error list to copy from.
void clearAllErrors ( )

Remove all errors from the current list of errors.

All errors, warnings, information and debug messages are accumulated into a list in this object, until this function is called.

See also:
getNumberOfErrors()
Examples:
tools_aahelper.cpp.
ms_errs::msg_sev convertFromLogLevel ( ms_loggingmonitor::Level_e logLevel ) [static]

Convert the ms_loggingmonitor level to an ms_errs severity.

Note that this function will not work with a mask that is created by bitwise ORing these enums together.

See also:
ms_errs::convertToLogLevel
Parameters:
logLevel is the logging level
Returns:
the original Parser severity message level
ms_loggingmonitor::Level_e convertToLogLevel ( ms_errs::msg_sev severity ) [static]

Convert the ms_errs severity level to a ms_loggingmonitor level.

See also:
ms_errs::convertFromLogLevel
Parameters:
severity will be sev_fatal, sev_warn etc
Returns:
the ms_loggingmonitor level that can be bitwise or'ed used with the return from ms_loggingmonitor::getLogMask()
void forwardToParentInstance ( ms_errs * parent )

Enable all messages from one object to be forwarded to another.

When a parser object that uses ms_errs creates another object that uses a different ms_errs instance, it either has to call appendErrors() after calling any methods in the created object or it can just call this function on the created object to get all errors just recorded in the 'parent' object.

The ms_errs destructor tidies up the links between the two (or more) objects.

As many objects as required can use the same instance.

Parameters:
parent is the object that messages will be stored in. If a value of zero is passed, this just removes any existing references.
bool getCombineRepeats ( ) const

Get the flag for whether to merge repeated error messages.

The default is to combine repeated error messages.

Returns:
Will be true if identical error messages are combined into a single message.
int getErrorNumber ( const int num = -1 ) const

Return a specific error number or ERR_NO_ERROR.

To return a particular error, warnings, information or debug messages from the list of messages, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or ERR_NO_ERROR.

Parameters:
num should be a value in the range 1..getNumberOfErrors()
Returns:
the error number for item num in the list. If an invalid number is passed, ERR_NO_ERROR will be returned.
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getErrorRepeats ( const int num = -1 ) const

Returns a number of times the specified error has been repeated.

Parameters:
num should be a value in the range 1..getNumberOfErrors()
Returns:
The number of times the specified message was repeated or 0 if there are no messages in the list.
Examples:
common_error.cpp, and http_helper_getstring.cpp.
ms_errs::msg_sev getErrorSeverity ( const int num = -1 ) const

Returns the severity of the specified error, warning, information or debug message.

Parameters:
num should be a value in the range 1..getNumberOfErrors()
Returns:
The severity level. If an invalid number is passed, or if there are no messages or errors in the list then ms_errs::sev_warn is returned.
std::string getErrorString ( const int num ) const

Returns a specific error as a string.

To return a particular error, warnings, information or debug messages from the list of messages, call this function with a number 1..getNumberOfErrors(). Passing a value of -1 will return the last error, or an empty string.

Parameters:
num should be a value in the range 1..getNumberOfErrors() If an invalid number is passed, an empty string will be returned.
Returns:
The specified error, warning, information or debug message string
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const

Return the last error number or ERR_NO_ERROR if no errors.

This function returns the last error, warning, information or debug message from the list of messages in this object.

This function is implemented by calling: getErrorNumber(-1)

Returns:
the Error number for the last message in the list of messages
std::string getLastErrorString ( ) const

Return the last error number or an empty string.

This function returns the last error, warning, information or debug message from the list of messages in this object

Same as calling getErrorString() with -1 as a parameter.

Returns:
The most recent error, warning, information or debug message
Examples:
tools_aahelper.cpp.
std::string getLoggingFileName ( ) const

Return the name of the logging file.

Returns:
the name of the file where fatal errors, warning, informational and debugging messages are accumulated. If there is no log file, this string will be empty
ms_errs::msg_sev getLoggingLevel ( ) const [virtual]

Get the logging level.

The default logging level is ms_errs::sev_warn, so any messages with ms_errs::sev_info, ms_errs::sev_debug1, ms_errs::sev_debug2 or ms_errs::sev_debug3 will not be logged.

The same level is applied to messages stored internally in the list and to to the messages being written to the file specified using setLoggingFile()..

Returns:
level is the current logging level.

Implements ms_log.

ms_loggingmonitor::Source_e getMessageSource ( const ms_log::msg_num_t msgNum ) const [inherited]

Return the component (library/application) that generated the specified log message.

The return value is based on the message number and determined from the table shown for msg_num_t above. If the value isn't in one of the above ranges, then ms_loggingmonitor::SRC_ALL will be returned.

Parameters:
msgNum Numeric code of the messaged to be logged
Returns:
the ms_loggingmonitor::Source_e value.
int getNumberOfErrors ( ) const

Return the number of errors since the last call to clearAllErrors().

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

If the logging level has been set to, for example ms_errs::sev_debug3 using setLoggingLevel(), then this function may return a positive number greater than zero even if isValid() returns true.

All errors are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
clearAllErrors(), getErrorNumber() and getErrorString()
Returns:
the number of errors, warnings, or other messages in the list.
Examples:
common_error.cpp, and http_helper_getstring.cpp.
bool isValid ( ) const

Returns TRUE if no errors occurred, FALSE otherwise.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages. This function will return true unless there are messages which have the severity level of ms_errs::sev_fatal

Returns:
true unless there have been and fatal error messages
Examples:
tools_aahelper.cpp.
void setAPI ( ms_loggingmonitor::Source_e api )

Sets the source API for the messages.

The ms_errs class is primarily used by Mascot Parser, but it may also be used by other Matrix Science APIs, such as MSQuantlib. Any other API should call this function, so that logging messages are recorded as coming from the correct API

Parameters:
api is one of the ms_loggingmonitor::Source_e values
void setCombineRepeats ( const bool flag )

Set the flag for whether to merge repeated error messages.

The default is to combine repeated error messages

Parameters:
flag should be set to true to enable identical error message to be combined into a single message.
void setLoggingFile | ( | const std::string | filename,
 |  | const msg_sev | level
 | ) |  |

Set the logging file.

It is generally easier to use Logging using ms_loggingmonitor than to use this function.

Parameters:
filename | should be set to a valid filename, or an empty string to disable also saving to a log file.
level | is the logging level. See also getLoggingLevel() and setLoggingLevel(). The same level is applied to messages stored internally in the list and to to the messages being written to the specified filename.
void setLoggingLevel ( const msg_sev level )

Set the logging level.

The default logging level is ms_errs::sev_warn, so any messages with ms_errs::sev_info, ms_errs::sev_debug1, ms_errs::sev_debug2 or ms_errs::sev_debug3 will not be logged.

This logging level is quite separate from the one used by ms_loggingmonitor. Call ms_loggingmonitor::setLogMask to enable a different level of logging. For example, you would normally only want ms_errs::sev_fatal and possibly ms_errs::sev_warn messages in any parser object so that you can report errors back to the user. You wouldn't want to fill the object with logging and information messages.

See also getLoggingLevel()

Parameters:
level is the logging level. The same level is applied to messages stored internally in the list and to to the messages being written to the file specified when calling setLoggingFile
bool willMessageBeLogged ( const msg_num_t msgNum ) const [inherited]

Check to see if the message will be logged to a file or recorded anywhere.

If the code to format a log message might take some time to run, it is worth calling this function first to see if the message will be logged or used anywhere.

Parameters:
msgNum must be a valid error number
Returns:
true if the message will be logged, or returned by getErrorString()
bool willMessageBeLogged ( const ms_errs::err errorNum ) const

Check to see if the message will be logged to a file or recorded anywhere.

If the code to format a log message might take some time to run, it is worth calling this function first to see if the message will be logged or used anywhere.

Parameters:
errorNum must be a valid error number
Returns:
true if the message will be logged, or returned by getErrorString()

Member Data Documentation

const err ERR_MSP_SECURITY_BAD_GROUP_NAME = 0x1009 [static]

[W] Invalid group name - names cannot contain the following characters:

><\\/`;,+*"
const err ERR_MSP_SECURITY_BAD_USER_NAME = 0x1004 [static]

[W] Invalid user name - names cannot contain the following characters:

><\\/`;,+*"
The documentation for this class was generated from the following files:
  • ms_errors.hpp
  • ms_errors.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_file_logger
Public Types | Public Member Functions

ms_file_logger Class Reference
[Error handling and logging]

Concrete class which implements ms_logger and outputs log text to the specified file. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_file_logger:
[legend]
Collaboration diagram for ms_file_logger:
[legend]

List of all members.

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001,
COL_ISO8601_TIME = 0x0002,
COL_IP_ADDRESS = 0x0004,
COL_MSG_NUM_DEC = 0x0008,
COL_MSG_NUM_HEX = 0x0010,
COL_SEVERITY_NUM = 0x0020,
COL_SEVERITY_TXT = 0x0040,
COL_MSG_SOURCE_TXT = 0x0080,
COL_SRC_FILE = 0x0100,
COL_SRC_LINENUM = 0x0200,
COL_THREAD_ID = 0x0400,
COL_MSG = 0x0800,
COL_TSV = 0x1000,
COL_QUOTES = 0x2000,
COL_HEADERS = 0x4000,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}

Logging output columns.

More...

Public Member Functions

ms_file_logger (const std::string logFileName, unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS)
Constructor, sets the logfilename and columns to report.
virtual | ~ms_file_logger ()
Destructor.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
std::string | getLogFilename ()
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)
Logs the passed message to the logfile.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Concrete class which implements ms_logger and outputs log text to the specified file.

Member Enumeration Documentation

enum LogOutputColumns_e [inherited]

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
COL_ASC_TIME

[ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"

COL_ISO8601_TIME

[*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.

COL_IP_ADDRESS

[ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.

COL_MSG_NUM_DEC

[ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_MSG_NUM_HEX

[*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_SEVERITY_NUM

[ ] Output the ms_loggingmonitor::Level_e severity as a number.

COL_SEVERITY_TXT

[*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .

COL_MSG_SOURCE_TXT

[*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText

COL_SRC_FILE

[*] Output the source code file name.

COL_SRC_LINENUM

[*] Ouput the line number in the source file.

COL_THREAD_ID

[ ] Output the current thread ID as a hexadecimal number.

COL_MSG

[*] Output the formatted message text.

COL_TSV

[ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab

COL_QUOTES

[ ] Put quotes around every field

COL_HEADERS

[*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this

COL_LOGGER_DEFAULTS

[ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

ms_file_logger | ( | const std::string | logFileName,
 |  | unsigned int | colsToOutput = ms_logger::COL_LOGGER_DEFAULTS
 | ) |  |

Constructor, sets the logfilename and columns to report.

ms_logger implementation which logs to a specified file. The file is appended to and is never overwritten.

Parameters:
logFileName | the full path to the log file to use
colsToOutput | is used to specify the cols to include in the log and also the format

Member Function Documentation

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const [inherited]

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns:
the formatted string.
unsigned int getColsToOutput ( ) const [virtual, inherited]

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns:
the value set in the constructor or by calling ms_logger::setColsToOutput
std::string getHeaderLine ( ) const [inherited]

Returns the header line based on the specified column names.

Returns:
a string that contains the column names
std::string getLogFilename ( )
Returns:
the specified path to the current log file
void onLogMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId = 0
 | ) |  | [virtual]

Logs the passed message to the logfile.

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message

Implements ms_logger.

void setColsToOutput ( const unsigned int colsToOutput ) [virtual, inherited]

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters:
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_log
Public Types | Public Member Functions | Static Public Attributes

ms_log Class Reference
[Error handling and logging]

Definitions for logging messages. More...

#include <ms_log.hpp>

Inheritance diagram for ms_log:
[legend]

List of all members.

Public Types

typedef int | msg_num_t
Typedef for log and error message numbers.
enum msg_sev {
sev_fatal = 1,
sev_warn = 2,
sev_info = 3,
sev_debug1 = 4,
sev_debug2 = 5,
sev_debug3 = 6
}

Message severity levels.

More...

Public Member Functions

ms_log ()
Constructor.
virtual | ~ms_log ()
Destructor.
void | addToCatalog (const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages)
Add messages to the fast lookup map.
virtual msg_sev | getLoggingLevel () const =0
Get the logging level.
ms_loggingmonitor::Source_e | getMessageSource (const ms_log::msg_num_t msgNum) const
Return the component (library/application) that generated the specified log message.
bool | willMessageBeLogged (const msg_num_t msgNum) const
Check to see if the message will be logged to a file or recorded anywhere.

Static Public Attributes

static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED = 0x0001060F
[D2] Iteration for seriesID=[num] stops at index=[num] and mass=[mass]: limit is [mass]
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES = 0x00010610
[D2] Skipping d' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE = 0x00010611
[D2] Skipping d residue because it doesn't match /[ITV]/ or /[CDEKLMNPQRS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE = 0x00010612
[D2] Skipping v residue because it doesn't match /[ARDNCQEHILKMFPSTWYV]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES = 0x00010613
[D2] Skipping w' residue because it doesn't match /[I]/ or /[T]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE = 0x00010614
[D2] Skipping w residue because it doesn't match /[ITV]/ or /[RDNCQELKMPS]/ (seriesID=[num], pos=[num], residue=[char])
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER = 0x0001061D
[D3] PSM component [num] position i=[num] has intact link, modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK = 0x0001061E
[D3] PSM component [num] position i=[num] has monolink modnum=[num] monoLinkNum=[num] title=[name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK = 0x0001061F
[D1] PSM component [num] column i=[num] is ignored because there is a looplink at sites [num]-[num], modnum=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MASSES_VALUE = 0x0001061B
[D2] Active ms_masses: [name]=[value]
static const msg_num_t | LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE = 0x0001061C
[D1] Modification at site i=[num] is [name] with delta=[num]
static const msg_num_t | LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS = 0x00010600
[D1] Calculated [num] fragments for psmComponent=[num], seriesID=[num], fragCharge=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass]
static const msg_num_t | LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT = 0x0001061A
[D1] cfr: Initialising isotopes and fixed mods from quant component [name]
static const msg_num_t | LOGMSG_AAHELPER_CFR_START_FRAGMENTS = 0x00010618
[D1] cfr(psmComponent=[num], seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num], linkerColumn=[num], linkerMassOffset=[mass])
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_END = 0x00010619
[D1] calcCrosslinkedFragments: returning [num] alpha and [num] beta fragments
static const msg_num_t | LOGMSG_AAHELPER_CROSSLINKED_START = 0x00010609
[D1] calcCrosslinkedFragments(seriesID=[num], fragCharge=[num], minMass=[mass], maxMass=[mass], massType=[num], fragNlType=[num]); mass of linker + alpha = [mass]; linker + beta = [mass]
static const msg_num_t | LOGMSG_AAHELPER_CUMULATIVE_MASS_NL = 0x0001060D
[D2] Cumulative mass and NL at i=[num] residue=[char]: m[i]=[mass], nl[i]=[mass]
static const msg_num_t | LOGMSG_AAHELPER_ETMOD_LOOKUP = 0x00010615
[D1] lookupErrorTolerantModification(q=[num], p=[num], residue=[char]) --> raw name=[string], raw delta=[string], mod name=[name], mod delta=[mass], is mod?=[num], nl=[mass]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_ADD = 0x00010606
[D2] Added immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_IMMONIUM_ION_REJECT = 0x00010605
[D2] Rejected immonium ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], residue=[char], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_ADD = 0x00010608
[D2] Added internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_INTERNAL_ION_REJECT = 0x00010607
[D2] Rejected internal ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], start=[num], end=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_MASTER_NL_VALS = 0x0001060B
[D2] Master neutral loss=[array]
static const msg_num_t | LOGMSG_AAHELPER_MULTINL_INDICES = 0x0001060A
[D1] Currently active multi NL indices=[array]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_ADD = 0x00010602
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_ION_REJECT = 0x00010601
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num], column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD = 0x00010604
[D2] Added regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num]
static const msg_num_t | LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT = 0x00010603
[D2] Rejected regular ion mass=[mass], nl=[mass], psmComponent=[num], seriesID=[num] ([name]), column=[num], fragCharge=[num], because it is outside the range [[mass], [mass]]
static const msg_num_t | LOGMSG_AAHELPER_SERIES_PARAMS = 0x0001060E
[D1] Parameters for seriesID=[num]: delta=[mass], start=[num], end=[num], forward=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG = 0x00010617
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) --> anyChange=[num], modNum=[num], oldStyleModName=[string], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT = 0x00010616
[D1] setupFromPre2_2ResultsFile(peptide=[string], varmods=[string]) --> modNum=[num], idx=[num], modType=[num]
static const msg_num_t | LOGMSG_AAHELPER_TOTAL_NL_VALS = 0x0001060C
[D2] Currently active multi NL neutral loss=[array]
static const msg_num_t | LOGMSG_CUSTQUANT_ADD_QUANT_KEY = 0x00010400
[D2] Adding quantitation key id d to protein s .
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_ALL_KEY = 0x00010401
[D2] Removing quantitation key d from any proteins.
static const msg_num_t | LOGMSG_CUSTQUANT_REMOVE_KEY = 0x00010402
[D2] Removed quantitation key d from protein s.
static const msg_num_t | LOGMSG_DBG1_NUM_PROCESSOR_GROUPS = 0x00010160
[D1] Debug: Number of processor groups : %d.
static const msg_num_t | LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS = 0x00010178
[D2] Debug: Number of cores per physical cpu : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_GETAUTODETECT = 0x00010179
[D2] Debug: getAutoDetectNumThreads(1,4) : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS = 0x00010177
[D2] Debug: Number of logical cpus / physical cpu: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_NAME = 0x0001017A
[D2] Debug: Multi-threaded name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_MT_STATUS = 0x0001017B
[D2] Debug: Hyper/multi threading status : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NAME = 0x00010173
[D2] Debug: Processor name : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_AVAIL = 0x00010171
[D2] Debug: Logical number of cpus available : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_GROUPS = 0x00010172
[D2] Debug: Number of processor groups : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_ON_SYS = 0x00010170
[D2] Debug: Logical number of cpus on the system : %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL = 0x00010176
[D2] Debug: Physical number of cpus on the system: %d
static const msg_num_t | LOGMSG_DBG2_CPU_INF_PROC_AFFINITY = 0x00010174
[D2] Debug: Process Affinity supported : %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_LINE = 0x0001017D
[D2] Debug: 3d : 2d / 5d / 5d / %s / %s
static const msg_num_t | LOGMSG_DBG2_CPU_INF_TABLE_TITLE = 0x0001017C
[D2] Debug: logical : physical id / core id / ht id / is primary / is threaded:
static const msg_num_t | LOGMSG_DBG2_CPU_INF_USE_PROCESSES = 0x00010175
[D2] Debug: Use processes instead of threads : %s
static const msg_num_t | LOGMSG_DBG2_NUM_CONFIG_MISMATCH = 0x00010168
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d configured processors.
static const msg_num_t | LOGMSG_DBG2_NUM_ONLINE_MISMATCH = 0x00010169
[D2] Debug: Processor configuration detection mismatch: hwloc detects %d and system detects %d online processors.
static const msg_num_t | LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD = 0x00010163
[D3] Debug: getAutoDetectNumThreads. logicalPerPhysical: %d, numCores: %d, numLicensed: %d, numCoresPerCpuLicense: %d, maxLicensable: %d, numAvailableToProcess: %d.
static const msg_num_t | LOGMSG_DBG3_BINDING_PROCESSORS = 0x00010166
[D3] Debug: binding processors %s.
static const msg_num_t | LOGMSG_DBG3_BINDING_THREAD = 0x00010167
[D3] Debug: binding thread p to logical processor %d.
static const msg_num_t | LOGMSG_DBG3_CALL_GET_CHIP_MFCTR = 0x00010164
[D3] Debug: about to call getChipManufacturer()
static const msg_num_t | LOGMSG_DBG3_HWLOC_GROUPS = 0x00010162
[D2] Debug: hwloc reports %d processor groups.
static const msg_num_t | LOGMSG_DBG3_HWLOC_TREE = 0x00010161
[D3] Debug: iterateHwlocChildren: %-8s, logical: %d, depth: %d, packageID: %d, coreID: %d.
static const msg_num_t | LOGMSG_DBG3_PROCESSOR_NAME = 0x00010165
[D2] Debug: processor name: %s, hyperthreading: %s.
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND = 0x00010A05
[D2] getThresholdForFDR: found a new minimum at i=d, fdr_min=g, target_min=d, decoy_min=d, expect_min=g
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_START = 0x00010A03
[D2] getThresholdForFDR: i=d, expect=g, target=d, decoy=d, target_count=d, decoy_count=d, fdr=g, too_few=d
static const msg_num_t | LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT = 0x00010A04
[D2] getThresholdForFDR: target or decoy count dropped to zero at i=d, target_count=d, decoy_count=d
static const msg_num_t | LOGMSG_GET_THR_REACH_COND = 0x00010A06
[D2] getThresholdForFDR: Result FDR reached; minimum seen at fdr_min=g, expect_min=g, target_min=d, decoy_min=d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET = 0x00010A02
[D1] getThresholdForFDR(g, s, DM_FASTA_SECOND_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR = 0x00010A01
[D1] getThresholdForFDR(g, s, DM_FASTA_FIRST_PASS) returned success = d, closestFDR = g, minProbability = g, numTargetMatches = d, numDecoyMatches = d
static const msg_num_t | LOGMSG_HTTP_GETRETURNSTRING = 0x00010304
[I] The http GET returned '[text]'.
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONS10FAILED = 0x00010303
[I] Failed to set maximum connections per 1.0 server
static const msg_num_t | LOGMSG_HTTP_MAXCONECTIONSFAILED = 0x00010302
[I] Failed to set maximum connections per server
static const msg_num_t | LOGMSG_HTTP_QUERYSTATUSRESULT = 0x00010301
[I] HTTP status is [httpCode] 'httpText'.
static const msg_num_t | LOGMSG_HTTP_URLSTRING = 0x00010300
[I] Sending HTTP [httpMethod] to [url] for action [command].
static const msg_num_t | LOGMSG_INST_ADDINGDATABASE = 0x00010205
[I] Adding entry for s to mascot.dat.
static const msg_num_t | LOGMSG_INST_ADDOPTIONSSECTION = 0x00010208
[I] Added [value] to the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_APPENDPARSERULE = 0x00010207
[I] Added parse rule number [value].
static const msg_num_t | LOGMSG_INST_APPENDTAXONOMY = 0x00010204
[I] Appended taxonomy section [value].
static const msg_num_t | LOGMSG_INST_CHANGEDBTAXONOMY = 0x00010206
[I] Changed taxonomy entry for [database].
static const msg_num_t | LOGMSG_INST_CHANGEPARSERULE = 0x0001020C
[I] Changed [value] parse rule from rule [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPERCOLATORFEATS = 0x00010210
[I] Changed PercolatorFeatures section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CHANGEPROTFAMILYSWITCH = 0x00010211
[I] Changed ProteinFamilySwitch section of mascot.dat from [value] to [value].
static const msg_num_t | LOGMSG_INST_CLUSTERSECTION = 0x0001020A
[I] Set the value of [name] to [value] in the cluster section of mascot.dat.
static const msg_num_t | LOGMSG_INST_FAILSAVEPOSTINSTALLFILE = 0x0001020E
[I] Failed to save Post Install File [name]. Error [value]
static const msg_num_t | LOGMSG_INST_LOGICALPERPHYSICALCPU = 0x00010200
[I] Detected %d logical processors per physical CPU.
static const msg_num_t | LOGMSG_INST_MASCOTDATOK = 0x00010203
[I] Successfully loaded existing mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NOSUBCLUSTERSET = 0x0001020B
[I] No SubClusterSet entry in mascot.dat.
static const msg_num_t | LOGMSG_INST_NOTMASCOTDATOK = 0x00010202
[I] Successfully loaded not.mascot.dat from [path].
static const msg_num_t | LOGMSG_INST_NUMTHREADS = 0x00010201
[I] Setting number of threads to [value].
static const msg_num_t | LOGMSG_INST_REMOVEOPTIONSSECTION = 0x0001020F
[I] Removed [value] from the options section of mascot.dat.
static const msg_num_t | LOGMSG_INST_SAVEDPOSTINSTALLFILE = 0x0001020D
[I] Saved line ([text]) in Post Install File [name] for Database Manager
static const msg_num_t | LOGMSG_INST_SETOPTIONSSECTION = 0x00010209
[I] Set the value of [name] to [value] in the options section of mascot.dat.
static const msg_num_t | LOGMSG_MATRIX_OUTPUT_VALS = 0x00010500
[D3] s. d rows and d columns
s
static const msg_num_t | LOGMSG_PEPSUM_GETHIT = 0x00010729
[D3] [function]: [string], [string], [string]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP = 0x00010713
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => keep
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_START = 0x00010710
[D1] choose_next_free_protein(): lead_proteins are [list]
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY = 0x00010711
[D2] choose_next_free_protein(): free_count of "[accession]" is [num] but no superset found in lead_proteins; keeping for now
static const msg_num_t | LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST = 0x00010712
[D2] choose_next_free_protein(): free count of "[accession]" is [num] => move to subset_list with parents [list]
static const msg_num_t | LOGMSG_PROTINFER_CLUSTER_FROM_ACC = 0x00010726
[D1] sortByScore(): Starting point for cluster in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO = 0x0001070D
[D2] eliminate_intersections() : ran out of unused_proteins (all free counts are zero)
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT = 0x0001070E
[D2] eliminate_intersections() : next unused protein to try to add is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST = 0x0001070F
[D2] eliminate_intersections() : fix-up of supersetlist for "[accession]", [changed lists]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_END = 0x00010704
[D1] findFamily() end for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_QUEUE = 0x00010701
[D1] findFamily(): "[accession]" has [num] PSMs above threshold ([num] PSMs below), [num] homologous proteins, in_queue size=[num], queue size=[num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS = 0x00010702
[D1] findFamily(): "[accession]" has the following [num] representative sequences: [list]
static const msg_num_t | LOGMSG_PROTINFER_FIND_FAMILY_START = 0x00010700
[D1] findFamily() start for accession "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END = 0x00010725
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START = 0x00010723
[D2] findMatchesForThisProteinAndChildren(): Accession: [accession], size of qp = [num]
static const msg_num_t | LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START = 0x00010724
[D2] findMatchesForThisProteinAndChildren(): Subset accession: [accession]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST = 0x00010708
[D2] groupFamily(): discardedSLProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION = 0x00010709
[D1] groupFamily(): eliminate_intersections. lead_proteins size = [num], subset_proteins size = [num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST = 0x0001070B
[D1] groupFamily(): leadProteins after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST = 0x0001070A
[D1] groupFamily(): family members after elimination: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST = 0x0001070C
[D1] groupFamily(): "[accession]" has parent "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN = 0x0001072B
[D1] homologous_proteins(): "[accession]" shares q[num]_p[num] with "[accession]" => pull it in to the family
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST = 0x00010707
[D2] groupFamily(): samesetLeadProteins: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST = 0x00010706
[D2] groupFamily(): samesetParents: [list]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FAMILY_START = 0x00010705
[D1] groupFamily() for "[accession]": samesetLeadProteins=[num], samesetParents=[num], discardedSLProteins=[num]
static const msg_num_t | LOGMSG_PROTINFER_GROUP_FROM_ACC = 0x00010727
[D1] sortByScore(): Starting point for group in hit [num] is [accession]
static const msg_num_t | LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY = 0x0001072A
[D2] findFamily(): Family [num] has [num] peptide matches with keepingThisOne=[boolean]
static const msg_num_t | LOGMSG_PROTINFER_PEPTIDE_MATRIX = 0x00010703
[D2] findFamily(): [type] peptide matrix (transposed)
[matrix]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD = 0x00010716
[D2] remove_conflicting_proteins(): lead protein "[accession]" has free count n < minNumSigUniqueSeqs (n = [num], minNumSiqUniqueSeqs = [num]) => move to subset list with parents [accessions]
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP = 0x00010715
[D2] remove_conflicting_proteins(): lead protein "[accession]" does not overlap with any current lead protein => keep
static const msg_num_t | LOGMSG_PROTINFER_REMOVE_CONFLICTING_START = 0x00010714
[D2] remove_conflicting_proteins([list])
static const msg_num_t | LOGMSG_PROTINFER_SINGLETON_FROM_ACC = 0x00010728
[D1] sortByScore(): No grouping; hit [num] is just "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE = 0x00010718
[D2] sortByScore(): About to create sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED = 0x00010719
[D2] sortByScore(): Finished creating sorted_
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_DONE = 0x00010722
[D1] sortByScore(): reached the end of sorted_, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN = 0x00010721
[D1] sortByScore(): next accession in sorted_ with significant rank 1 peptide is "[accession]"
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS = 0x0001071A
[D1] sortByScore(): proteins_ is empty, so it's all done
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD = 0x00010720
[D1] sortByScore(): Removing "[accession]" because setBoldAndCheckBoxItems() returned false
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN = 0x0001071D
[D1] sortByScore(): Removing "[accession]" because longestPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN = 0x0001071E
[D1] sortByScore(): Removing "[accession]" because longestSigPeptideLen [num] < minPepLenInPepSummary [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS = 0x0001071C
[D1] sortByScore(): Removing "[accession]" because numProteins [num] >= maxHitsToReport [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE = 0x0001071B
[D1] sortByScore(): Removing "[accession]" because its score [num] is less than minProteinScore [num]
static const msg_num_t | LOGMSG_PROTINFER_SORT_BY_SCORE_START = 0x00010717
[D1] sortByScore(): Num proteins: [num], num peptides: [num], hitToAdd: [num]
static const msg_num_t | LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT = 0x0001071F
[D2] sortByScore(): Protein "[accession]" is a subset in hit [num]. Because MSRES_SUBSETS_DIFF_PROT is active, it will now start hit [num]
static const msg_num_t | LOGMSG_QUANT_ADDED_PROTEIN_HIT = 0x00010417
[D2] Added quantitation protein hit [accession] to match [value] with sequence [text]
static const msg_num_t | LOGMSG_QUANT_ADDING_PROTEIN_HIT = 0x00010416
[D2] Adding quantitation protein hit [accession]
static const msg_num_t | LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED = 0x0001040F
[D2] Calling calc_complete() on merged dataset
static const msg_num_t | LOGMSG_QUANT_CLOSING_CACHE_FILE = 0x00010419
[D2] Closing quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE = 0x00010411
[D2] Excluding peptide for query: [value], rank: [value] because [string]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN = 0x00010413
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] > [value]
static const msg_num_t | LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN = 0x00010412
[D2] Excluding peptide for query: [value], rank: [value] because [string]. [value] < [value]
static const msg_num_t | LOGMSG_QUANT_FINISH_CALC_COMPLETE = 0x00010406
[D2] Finished calc_complete() call
static const msg_num_t | LOGMSG_QUANT_FINISH_LOAD_CDB = 0x00010409
[D2] Finished loadCdbFile() call
static const msg_num_t | LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE = 0x0001041B
[D1] Finished reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES = 0x00010404
[D2] Finished updating protein matches
static const msg_num_t | LOGMSG_QUANT_HELPER_TEST_REQUIRED = 0x00010800
[D3] testRequiredMods(): sorted required mods="[string]", sequence="[string]", mods="[string]", iter=[char]
static const msg_num_t | LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES = 0x0001040A
[D2] Loading all peptide status values
static const msg_num_t | LOGMSG_QUANT_LOADING_MATCHES = 0x0001040B
[D2] Loading quantitation matches
static const msg_num_t | LOGMSG_QUANT_OPENING_CACHE_FILE = 0x00010418
[D2] Opening quantitation cache file [filename]
static const msg_num_t | LOGMSG_QUANT_REAPPLY_THRESHOLDS = 0x0001040D
[D2] Reapplying quantitation quality thresholds
static const msg_num_t | LOGMSG_QUANT_REMATCHING_INFERRED = 0x00010410
[D2] Rematching [value] inferred matches
static const msg_num_t | LOGMSG_QUANT_REMOVE_INFERRED_MATCH = 0x00010415
[D1] Removing inferred quantitation match [value] - [value] < [value]
static const msg_num_t | LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE = 0x00010414
[D1] Removing quantitation match [value] - no remaining evidence
static const msg_num_t | LOGMSG_QUANT_START_CALC_COMPLETE = 0x00010405
[D2] Calling calc_complete()
static const msg_num_t | LOGMSG_QUANT_START_LOAD_CDB = 0x00010408
[D2] Start of loadCdbFile() call. Cdb file: [filename], cache file: [filename]
static const msg_num_t | LOGMSG_QUANT_START_REORDER_AFTER_MERGE = 0x0001041A
[D1] Starting reordering of peptide matches after merge
static const msg_num_t | LOGMSG_QUANT_START_UPDATE_PROT_MATCHES = 0x00010403
[D2] Starting to update protein matches
static const msg_num_t | LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES = 0x0001040E
[D2] Updating excluded matches
static const msg_num_t | LOGMSG_QUANT_UPDATING_PEP_EVIDENCE = 0x0001040C
[D2] Updating Peptide Evidence
static const msg_num_t | LOGMSG_REPORT_FUNCTION_CALLED_BY = 0x00010900
[D3] [function], called by [string]
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY = 0x00010901
[D3] [function] entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 = 0x00010902
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 = 0x00010903
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 = 0x00010904
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 = 0x00010905
[D3] [function]([args]) entered
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT = 0x00010910
[D3] [function] exited
static const msg_num_t | LOGMSG_REPORT_FUNCTION_EXIT_WITH = 0x00010911
[D3] [function] exited with [string]
static const msg_num_t | LOGMSG_RESFILE_APPEND = 0x00010A00
[D2] [string] numQueries=[num] cachedExpValues=[num]

Detailed Description

Definitions for logging messages.

Member Typedef Documentation

typedef int msg_num_t

Typedef for log and error message numbers.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Logging messages are classified as:

  • [I] information
  • [D1] Debug level 1 message
  • [D2] Debug level 2 message
  • [D3] Debug level 3 message

Ranges:

Product | Classification | First | Last
Parser | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00010000 | 0x0001FFFF
MSQuantlib | sev_fatal, sev_warn | 0x00020000 | 0x0002FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00030000 | 0x0003FFFF
Purifier API | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00040000 | 0x0004FFFF
Purifier | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00050000 | 0x0005FFFF
Mascot Server | sev_fatal, sev_warn | 0x00000000 | 0x0000FFFF
 | sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x00060000 | 0x0006FFFF
MDRO | sev_fatal, sev_warn, sev_info, sev_debug1, sev_debug2, sev_debug3 | 0x4C020000 | 0x4C03FFFF

Member Enumeration Documentation

enum msg_sev

Message severity levels.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

See also: ms_loggingmonitor::Level_e

Enumerator:
sev_fatal

A fatal error that results in the object being 'invalid'.

sev_warn

A warning message.

sev_info

Information message.

sev_debug1

Debug level 1 message.

sev_debug2

Debug level 2 message.

sev_debug3

Debug level 3 message.

Constructor & Destructor Documentation

ms_log ( )

Constructor.

Initialisation by adding the message text and severity to a lookup

~ms_log ( ) [virtual]

Destructor.

Nothing to delete, but a virtual destructor needs to be defined as we have virtual methods

Member Function Documentation

void addToCatalog | ( | const msg_catalog_t | catalog[],
 |  | size_t | numEntries,
 |  | ms_loggingmonitor::Source_e | src,
 |  | errorOrLogMessages_e | errorOrLogMessages
 | ) |  |

Add messages to the fast lookup map.

Parameters:
catalog | is a pointer to an array of messages and severities
numEntries | is the number of entries in catalog
src | is used to check if the messages have already been added to the static catalog_ map.
errorOrLogMessages | is used, with src to check if the messages have already been added to the static catalog_ map.
ms_loggingmonitor::Source_e getMessageSource ( const ms_log::msg_num_t msgNum ) const

Return the component (library/application) that generated the specified log message.

The return value is based on the message number and determined from the table shown for msg_num_t above. If the value isn't in one of the above ranges, then ms_loggingmonitor::SRC_ALL will be returned.

Parameters:
msgNum Numeric code of the messaged to be logged
Returns:
the ms_loggingmonitor::Source_e value.
bool willMessageBeLogged ( const msg_num_t msgNum ) const

Check to see if the message will be logged to a file or recorded anywhere.

If the code to format a log message might take some time to run, it is worth calling this function first to see if the message will be logged or used anywhere.

Parameters:
msgNum must be a valid error number
Returns:
true if the message will be logged, or returned by getErrorString()
The documentation for this class was generated from the following files:
  • ms_log.hpp
  • ms_log.cpp
  • ms_log_impl.hpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_logger
Public Types | Public Member Functions

ms_logger Class Reference
[Error handling and logging]

Abstract class which provides the interface used by ms_logging monitor to delegate logging events. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_logger:
[legend]

List of all members.

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001,
COL_ISO8601_TIME = 0x0002,
COL_IP_ADDRESS = 0x0004,
COL_MSG_NUM_DEC = 0x0008,
COL_MSG_NUM_HEX = 0x0010,
COL_SEVERITY_NUM = 0x0020,
COL_SEVERITY_TXT = 0x0040,
COL_MSG_SOURCE_TXT = 0x0080,
COL_SRC_FILE = 0x0100,
COL_SRC_LINENUM = 0x0200,
COL_THREAD_ID = 0x0400,
COL_MSG = 0x0800,
COL_TSV = 0x1000,
COL_QUOTES = 0x2000,
COL_HEADERS = 0x4000,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}

Logging output columns.

More...

Public Member Functions

ms_logger (const unsigned int colsToOutput=COL_MSG)
Constructor.
virtual | ~ms_logger ()
Destructor.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)=0
Processes and handles the passed logging message.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Abstract class which provides the interface used by ms_logging monitor to delegate logging events.

See also ms_stdout_logger and ms_file_logger which inherit from this class

See Logging using ms_loggingmonitor for examples on using this class

Member Enumeration Documentation

enum LogOutputColumns_e

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
COL_ASC_TIME

[ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"

COL_ISO8601_TIME

[*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.

COL_IP_ADDRESS

[ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.

COL_MSG_NUM_DEC

[ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_MSG_NUM_HEX

[*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_SEVERITY_NUM

[ ] Output the ms_loggingmonitor::Level_e severity as a number.

COL_SEVERITY_TXT

[*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .

COL_MSG_SOURCE_TXT

[*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText

COL_SRC_FILE

[*] Output the source code file name.

COL_SRC_LINENUM

[*] Ouput the line number in the source file.

COL_THREAD_ID

[ ] Output the current thread ID as a hexadecimal number.

COL_MSG

[*] Output the formatted message text.

COL_TSV

[ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab

COL_QUOTES

[ ] Put quotes around every field

COL_HEADERS

[*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this

COL_LOGGER_DEFAULTS

[ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

ms_logger ( const unsigned int colsToOutput = COL_MSG )

Constructor.

ms_logger is an abstract class, so this is called from ms_stdout_logger, ms_file_logger and should be called from any other inherited classes.

See Logging using ms_loggingmonitor for examples on using this class

Parameters:
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values

Member Function Documentation

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns:
the formatted string.
unsigned int getColsToOutput ( ) const [virtual]

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns:
the value set in the constructor or by calling ms_logger::setColsToOutput
std::string getHeaderLine ( ) const

Returns the header line based on the specified column names.

Returns:
a string that contains the column names
void setColsToOutput ( const unsigned int colsToOutput ) [virtual]

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters:
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_loggingmonitor
Public Types | Public Member Functions | Static Public Member Functions

ms_loggingmonitor Class Reference
[Error handling and logging]

Monitor class to delegate logging events generated from multiple sources. More...

#include <ms_logging.hpp>

Collaboration diagram for ms_loggingmonitor:
[legend]

List of all members.

Public Types

enum Level_e {
LVL_NONE = 0,
LVL_ERROR = 1,
LVL_WARNING = 2,
LVL_INFO = 4,
LVL_DEBUG1 = 8,
LVL_DEBUG2 = 16,
LVL_DEBUG3 = 32
}

Logging severity levels.

More...
enum Source_e {
SRC_APPLICATION = 1,
SRC_MASCOTSERVER = 2,
SRC_MSPARSER = 3,
SRC_MDRO = 4,
SRC_MSQUANTLIB = 5,
SRC_PURIFIERAPI = 6,
SRC_PURIFIERAPP = 7,
SRC_DENOVOLIB = 8,
SRC_VENDORSTART = 100,
SRC_ALL = 0xFFFF
}

Logging event source.

More...

Public Member Functions

ms_loggingmonitor ()
Constructor.
virtual | ~ms_loggingmonitor ()
Destructor.
virtual int | addLogEventsHandler (ms_logger &logger)
Registers the passed ms_logger with the ms_loggingmonitor.
virtual ms_logger * | getLogEventsHandler (const int uid)
Returns the ms_logger object associated with the passed uid, or null if the specified uid is invalid.
virtual long | getLogMask (unsigned source=SRC_ALL)
Returns the current logging events mask.
virtual int | getNumLogEventsHandlers () const
Returns the number of events handlers.
virtual void | logMessage (Level_e eSeverity, Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) const
Logs the passed message with all registered ms_logger objects.
virtual bool | removeLogEventsHandler (const int uid)
Deregisters the specified ms_logger from the ms_loggingmonitor.
virtual void | setLogMask (long newVal, unsigned source=SRC_ALL)
Sets the current logging events mask.

Static Public Member Functions

static
matrix_science::ms_loggingmonitor & 		getDefaultMonitor ()
Returns the global ms_loggingmonitor used by msparser.
static std::string | messageSourceAsText (Source_e eSource)
Returns a Source_e enum value as a text string.
static void | setDefaultMonitor (ms_loggingmonitor &loggingMonitor)
Sets the global ms_loggingmonitor to be used by msparser.
static std::string | severityAsText (Level_e eSeverity)
Returns a severity enum value as a text string.

Detailed Description

Monitor class to delegate logging events generated from multiple sources.

See Logging using ms_loggingmonitor for details.

Member Enumeration Documentation

enum Level_e

Logging severity levels.

These have the same meaning as ms_errs::msg_sev, but do not have the same values. See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
LVL_NONE

Logging disabled.

LVL_ERROR

A fatal error that results in the object being 'invalid'.

LVL_WARNING

A warning message.

LVL_INFO

Information message. Not available by default unless setLoggingMask() called.

LVL_DEBUG1

Debug level 1 message. Not available by default unless setLoggingMask() called .

LVL_DEBUG2

Debug level 2 message. Not available by default unless setLoggingMask() called.

LVL_DEBUG3

Debug level 3 message. Not available by default unless setLoggingMask() called.

enum Source_e

Logging event source.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
SRC_APPLICATION

Logging event raised by the current application.

SRC_MASCOTSERVER

Logging event raised by Mascot server.

SRC_MSPARSER

Logging event raised by the msparser library.

SRC_MDRO

Logging event raised by the MDRO library.

SRC_MSQUANTLIB

Logging event raised by the msquantlib library.

SRC_PURIFIERAPI

Logging event raised by the purifierapi library.

SRC_PURIFIERAPP

Logging event raised by the Purifier application.

SRC_DENOVOLIB

Logging event raised by the Denovo library.

SRC_VENDORSTART

Use this value for third party applications.

SRC_ALL

Use this with setLogMask() and getLogMask()

Member Function Documentation

int addLogEventsHandler ( ms_logger & logger ) [virtual]

Registers the passed ms_logger with the ms_loggingmonitor.

See also:
Maintaining object references: two rules of thumb
Parameters:
logger is the ms_logger object to add
Returns:
the uid of the logger object in the ms_loggingmonitor, or -1 if it is already registered
ms_loggingmonitor & getDefaultMonitor ( ) [static]

Returns the global ms_loggingmonitor used by msparser.

To add a custom ms_logger to the default ms_logging monitor, call getDefaultMonitor().addLogEventsHandler()

Returns:
the global ms_loggingmonitor object used to handle all logging events from msparser
ms_logger * getLogEventsHandler ( const int uid ) [virtual]

Returns the ms_logger object associated with the passed uid, or null if the specified uid is invalid.

Parameters:
uid the uid of the ms_logger to retrieve
Returns:
the ms_logger associated with the passed uid or NULL if not found
long getLogMask ( unsigned source = SRC_ALL ) [virtual]

Returns the current logging events mask.

The default log mask value is Level_e::LVL_ERROR | Level_e::LVL_WARNING, so only messages with a severity level of Level_e::LVL_ERROR or Level_e::LVL_WARNING will be logged

Parameters:
source should be one of the Source_e values. See setLogMask for details.
Returns:
the current logging events mask.
int getNumLogEventsHandlers ( ) const [virtual]

Returns the number of events handlers.

Returns:
will be zero if there are no handlers, so there is no point in sending any messages to the logging monitor
std::string messageSourceAsText ( Source_e eSource ) [static]

Returns a Source_e enum value as a text string.

Useful for writing a human readable log file, this method returns the message source as text:

  • SRC_APPLICATION : "APPLICATION_"
  • SRC_MASCOTSERVER : "MASCOTSERVER"
  • SRC_MSPARSER : "MSPARSER_API"
  • SRC_MDRO : "MDRO_LIB_API"
  • SRC_MSQUANTLIB : "QUANTLIB_API"
  • SRC_PURIFIERAPI : "PURIFIER_API"
  • SRC_PURIFIERAPP : "PURIFIER_APP"
  • SRC_DENOVOLIB : "MSDENOVO_API"
  • SRC_VENDORSTART : "VENDOR_START"
  • SRC_ALL : "ALL_SOURCES_"
  • Any other number : "UNKNOWN_SRC_"
Parameters:
eSource should be on of the ms_loggingmonitor::Source_e enum values
Returns:
One of 12 character strings above.
bool removeLogEventsHandler ( const int uid ) [virtual]

Deregisters the specified ms_logger from the ms_loggingmonitor.

Parameters:
uid the uid of the ms_logger to removed
Returns:
true if the specified ms_logger was removed, false if it was not found
void setDefaultMonitor ( ms_loggingmonitor & loggingMonitor ) [static]

Sets the global ms_loggingmonitor to be used by msparser.

It is normally sufficient to add ms_logger objects to the default ms_loggingmonitor using getDefaultMonitor()

Parameters:
loggingMonitor the ms_loggingmonitor to use
void setLogMask | ( | long | newVal,
 |  | unsigned | source = SRC_ALL
 | ) |  | [virtual]

Sets the current logging events mask.

Parameters:
newVal | the new log mask value to set. Bitwise Or the relevant ms_loggingmonitor::Level_e values
source | should be one of the Source_e values. For most applications, the same mask (logging level) can be used for all the components, so the default of SRC_ALL can be used. If different levels are required, then call this function multiple times, firstly with SRC_ALL to set the default, and then with, for example SRC_MDRO to set a higher or lower level for MDRO logging. When called with SRC_ALL, all previous values for specific components are removed.
std::string severityAsText ( Level_e eSeverity ) [static]

Returns a severity enum value as a text string.

Useful for writing a human readable log file, this method returns the message severity as text:

  • LVL_ERROR : "LVL_ERROR "
  • LVL_WARNING : "LVL_WARNING"
  • LVL_INFO : "LVL_INFO "
  • LVL_DEBUG1 : "LVL_DEBUG1 "
  • LVL_DEBUG2 : "LVL_DEBUG2 "
  • LVL_DEBUG3 : "LVL_DEBUG3 "
  • Unrecognised : "LVL_UNKNOWN"
Parameters:
eSeverity should be on of the ms_loggingmonitor::Level_e enum values
Returns:
One of 11 character strings above.
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_stdout_logger
Public Types | Public Member Functions

ms_stdout_logger Class Reference
[Error handling and logging]

Concrete class which implements ms_logger and outputs log text to standard out. More...

#include <ms_logging.hpp>

Inheritance diagram for ms_stdout_logger:
[legend]
Collaboration diagram for ms_stdout_logger:
[legend]

List of all members.

Public Types

enum LogOutputColumns_e {
COL_ASC_TIME = 0x0001,
COL_ISO8601_TIME = 0x0002,
COL_IP_ADDRESS = 0x0004,
COL_MSG_NUM_DEC = 0x0008,
COL_MSG_NUM_HEX = 0x0010,
COL_SEVERITY_NUM = 0x0020,
COL_SEVERITY_TXT = 0x0040,
COL_MSG_SOURCE_TXT = 0x0080,
COL_SRC_FILE = 0x0100,
COL_SRC_LINENUM = 0x0200,
COL_THREAD_ID = 0x0400,
COL_MSG = 0x0800,
COL_TSV = 0x1000,
COL_QUOTES = 0x2000,
COL_HEADERS = 0x4000,
COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
}

Logging output columns.

More...

Public Member Functions

ms_stdout_logger (unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS)
Constructor.
virtual | ~ms_stdout_logger ()
Destructor.
std::string | formatMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const
Returns a string with formatting based on the columns requested to be output.
virtual unsigned int | getColsToOutput () const
Return the value which specifies which columns should be output by the logger.
std::string | getHeaderLine () const
Returns the header line based on the specified column names.
virtual void | onLogMessage (ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)
Logs the passed message directly to standard out.
virtual void | setColsToOutput (const unsigned int colsToOutput)
Set the value to specify which columns should be output by the logger.

Detailed Description

Concrete class which implements ms_logger and outputs log text to standard out.

Member Enumeration Documentation

enum LogOutputColumns_e [inherited]

Logging output columns.

These flags determine which columns are output by ms_stdout_logger and ms_file_logger.

The only way to change the order of the columns is to override the onLogMessage() function.

Enums with a [*] in the description are included in COL_LOGGER_DEFAULTS

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
COL_ASC_TIME

[ ] Output the time in the format: "Sat Jan 6 11:35:22 2018"

COL_ISO8601_TIME

[*] Output the time in the format: "2018-05-28T08:26:34-01:00". If the local time is the same as UTC, then the format would be: "2018-05-28T08:26:34Z " with 5 trailing spaces.

COL_IP_ADDRESS

[ ] Output the IP address of the calling getenv("REMOTE_ADDR"). If this is empty, "localhost" is output. Most useful for cgi applications.

COL_MSG_NUM_DEC

[ ] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_MSG_NUM_HEX

[*] Output the message number, will either be an ms_log::log_msg or a ms_errs::err value.

COL_SEVERITY_NUM

[ ] Output the ms_loggingmonitor::Level_e severity as a number.

COL_SEVERITY_TXT

[*] Output the ms_loggingmonitor::Level_e severity as text by calling ms_loggingmonitor::severityAsText .

COL_MSG_SOURCE_TXT

[*] Output the source of the message. See ms_loggingmonitor::messageSourceAsText

COL_SRC_FILE

[*] Output the source code file name.

COL_SRC_LINENUM

[*] Ouput the line number in the source file.

COL_THREAD_ID

[ ] Output the current thread ID as a hexadecimal number.

COL_MSG

[*] Output the formatted message text.

COL_TSV

[ ] By default, the output format is CSV - with each field in quotes. If this flag is used, then the column separator will be a tab

COL_QUOTES

[ ] Put quotes around every field

COL_HEADERS

[*] For ms_file_logger, this will ouput column headers if the file is empty and for ms_stdout_logger the constructor will output this

COL_LOGGER_DEFAULTS

[ ] Default columns used by Matrix Science Applications, includes values marked with [*] above.

Constructor & Destructor Documentation

ms_stdout_logger ( unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS )

Constructor.

Parameters:
colsToOutput is used to specify the cols to include in the log and also the format

Member Function Documentation

std::string formatMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId
 | ) |  | const [inherited]

Returns a string with formatting based on the columns requested to be output.

Called by ms_stdout_logger::onLogMessage and ms_file_logger::onLogMessage to return a formatted string based on the ms_logger::LogOutputColumns_e flags returned by getColsToOutput().

This function can obviously also be called by any custom ms_logger

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)
Returns:
the formatted string.
unsigned int getColsToOutput ( ) const [virtual, inherited]

Return the value which specifies which columns should be output by the logger.

The value returned is one or more ms_logger::LogOutputColumns_e values bitwise ORed together. formatMessage uses this value to determine which columns to return.

Returns:
the value set in the constructor or by calling ms_logger::setColsToOutput
std::string getHeaderLine ( ) const [inherited]

Returns the header line based on the specified column names.

Returns:
a string that contains the column names
void onLogMessage | ( | ms_loggingmonitor::Level_e | eSeverity,
 |  | ms_loggingmonitor::Source_e | eSource,
 |  | long | lMsgId,
 |  | const std::string & | text,
 |  | const char * | srcFileName,
 |  | const int | srcFileLineNum,
 |  | long | lContextId = 0
 | ) |  | [virtual]

Logs the passed message directly to standard out.

Parameters:
eSeverity | the severity level of the message
eSource | the source of the message
lMsgId | the message id or error code
text | the message text
srcFileName | will normally be supplied using __FILE__
srcFileLineNum | will normally be supplied using __LINE__
lContextId | the contextid of the message (from MDRO)

Implements ms_logger.

void setColsToOutput ( const unsigned int colsToOutput ) [virtual, inherited]

Set the value to specify which columns should be output by the logger.

formatMessage uses this value to determine which columns to return.

Parameters:
colsToOutput is formed by bitwise ORing one or more ms_logger::LogOutputColumns_e values
The documentation for this class was generated from the following files:
  • ms_logging.hpp
  • ms_logging.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Quantitation analysis for Mascot Server and Distiller

Classes

class | ms_customquantitation
Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings. More...
class | ms_distiller_data
Distiller project parameters. More...
class | ms_distiller_data_quant
The details of a Distiller search. More...
class | ms_distiller_data_search
The details of a Distiller search. More...
class | ms_distiller_master_project
Data for a Distiller master project, includes a list of the subprojects. More...
class | ms_distiller_master_search
The details of a Distiller multifile search. More...
class | ms_distiller_search_status
A Mascot search status from a Distiller project file. More...
class | ms_distiller_search_status_list
A list of Mascot search status values, typically stored in a Distiller project file. More...
class | ms_distiller_sub_project
The details of a Distiller multifile subproject. More...
class | ms_distiller_subsearch
The details of a Distiller multifile subsearch. More...
class | ms_fitexy_result
Parameters and results from least squares fit with errors in both co-ordinates. More...
class | ms_ms1quant_average_results
Results specific to an 'average' type quantitation method. More...
class | ms_ms1quant_charge_state
A result from a charge state calculation. More...
class | ms_ms1quant_match
A peptide that has been matched, in quantitation, to a protein hit. More...
class | ms_ms1quant_match_component
A component within a match. More...
class | ms_ms1quant_match_range
A range for a component of a peptide match. More...
class | ms_ms1quant_match_ratio
The status resulting ratio for a peptide found in a match. More...
class | ms_ms1quant_peptide_status
An individual peptide's quantitation status. More...
class | ms_ms1quantitation
The result of quantitation calculations applied to peptide summary. More...
class | ms_ms2quantitation
Peptide and protein quantitation in a Reporter or Multiplex Mascot results file. More...
class | ms_peptide_quant_key
Feature key identifying a peptide ratio. More...
class | ms_peptide_quant_key_vector
A vector of peptide quant keys. More...
class | ms_peptide_quant_ratio
Peptide abundance in one component relative to another in a quantitation experiment. More...
class | ms_progress_info
Contains information of the current progress of a task being performed. More...
class | ms_protein_quant_ratio
Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios. More...
class | ms_quant_helper
Helper routines for peptide quantitation. More...
class | ms_quant_stats
Mathematical and statistical routines for peptide and protein quantitation. More...
class | ms_quantitation
Base class for peptide and protein quantitation. More...
class | ms_shapiro_wilk
The Shapiro-Wilk W test. More...
class | ms_xic
An eXtracted Ion Chromatogram (XIC). More...
class | ms_xic_point
A single point from a matrix_science::ms_xic object. More...

Modules

Peptide and protein quantitation
Accessing Distiller Quantitation Results
Accessing Distiller Multi-file Quantitation Results
Extracting quantitation results with the Distiller toolkit
Source code for the Shapiro-Wilk W test algorithm
Examples for the Mascot Parser quantitation module

Detailed Description

Classes for handling the quantitation configuration files are in Mascot configuration files module

The statistics modules are used for the quantitation functions in both Mascot server and Mascot Distiller.

Source code for the Shapiro-Wilk W test algorithm

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Peptide and protein quantitation
[Quantitation analysis for Mascot Server and Distiller]

Overview

Mascot Server (since version 2.2) supports five labelled and label-free quantitation protocols. The protocols are Reporter, Precursor, Multiplex, Replicate and Average, and they are described in full on the Matrix Science website. Reporter and Multiplex work off of reporter ions or fragment peaks in the MS/MS spectrum, which means peptide and protein ratios can be calculated directly from the results file. Precursor, Replicate and Average require additional information from the raw data file.

In Mascot 2.2, 2.3 and 2.4, quantitation ratios for Reporter and Multiplex were calculated by the Mascot report scripts. In Mascot 2.5, and Parser 2.5, the calculation has been integrated as part of the Parser results file interface. The interface has some support for Precursor, Replicate and Average quantitation data as well, although you will need to extract component intensities from the raw data first, for example using Mascot Distiller.

If the results file has been downloaded from the Mascot Server using the cgi/client.pl script with the result_file_mime2 parameter, then note that the results file will not contain the query sections that contain the ms-ms data, so it won't be possible to get quantitation ratios for reporter and multiplex data.

Mascot also supports the Exponentially Modified Protein Abundance Index (emPAI), which is an approximate, relative quantitation method based on protein sequence coverage. In Mascot 2.2, 2.3 and 2.4, emPAI calculation was part of the Mascot report scripts. In Mascot 2.5 and Parser 2.5, the calculation is implemented in ms_mascotresults::getProteinEmPAI(). Since emPAI uses only protein sequence coverage, not MS/MS or raw data, it is essentially "always on" when the search results contain enough input queries, and no special initialisation needs to be done. The rest of the document describes the five other quantitation protocols. Please refer to the documentation for ms_mascotresults::getProteinEmPAI() for more details on emPAI.

From Reporter or Multiplex results file to protein ratios: ms_ms2quantitation

Initialising quantitation data

If you have a Mascot results file with Reporter or Multiplex data, and you used the correct quantitation method when submitting the search, then it is straightforward to extract peptide and protein ratios from the file using ms_ms2quantitation. Open the results file using ms_mascotresfile and ms_peptidesummary as described in Getting protein information; let the objects be resfile and pepsum, respectively. The following example code extracts component intensities and calculate peptide ratios in a single step, using the default quantitation method parameters:

quant = msparser.ms_ms2quantitation(pepsum);

if not quant.isValid():
    # report quant.getLastErrorString()
    return

# Data is now available in quant

(Small examples such as the one above are given in Python. A more complete example is given in other programming languages at the end of the section.)

Data normalisation

ms_ms2quantitation supports three kinds of normalisation: the normalisation constants can be calculated from the set of all peptide ratios, a set of peptide sequences (peptide ratios associated with the sequences) or a set of protein accessions (peptide ratios associated with the accessions). The normalisation constant for each report ratio, say 115/114 in an iTRAQ file, is the median or geometric mean of the selected 115/114 peptide ratios.

Normalisation does not happen automatically, because it may require calculating peptide ratios for all peptide matches in the results file. If normalisation is configured, you can cause the normalisation constants to be computed using normalisePeptideRatios(). The individual normalisation constants can be read out with getPeptideRatioNormalisationBase(). Note that changing quantitation method parameters (especially normalisation settings) or editing report ratios will reset the normalisation constants, for consistency.

If normalisation is not configured, then normalisePeptideRatios() simply returns without doing anything. This means that normally you always want to call normalisePeptideRatios() after creating an ms_ms2quantitation object, just to ensure the values match the quantitation method configuration. This is what we do in the following code examples.

If you already know the normalisation constants, or if you want to use your own values, you can use setPeptideRatioNormalisationBase() and skip the potentially time-consuming computation.

ms_ms2quantitation has limited support for normalisation at component intensity level. If your data is Reporter, you can enable the "sum" normalisation in the quantitation method settings and call normaliseIntensities() to cause the intensity-level normalisation constants to be computed. The method is exactly analogous to normalisePeptideRatios(), so same caveats apply.

Data caching

ms_ms2quantitation supports caching, but does not create a cache file itself. If the results file is Reporter or Multiplex, and caching is enabled, then ms_mascotresults will automatically extract and cache component intensities in the results cache file. ms_ms2quantitation will then read component intensities directly from it.

If the results cache file was created by an older version of Parser without full quantitation support, or if caching isn't in use, then component intensities are extracted from spectra as they are needed. In this case, the larger the file, the longer the ms_ms2quantitation constructor will take to run; the class needs to load component intensities for all quantifiable peptide matches to enable ratio normalisation.

Component intensity values can be accessed directly using ms_mascotresults::getComponentIntensity() and ms_ms2quantitation::getComponentIntensities().

Accessing peptide and protein ratios

Once you have an ms_ms2quantitation object, you can access peptide and protein ratios using getPeptideRatio() and getProteinRatio(), respectively. The following example prints the ratios of hit 1:

qm = quant.getQuantitationMethod()
ratioNames = []

for i in range(qm.getNumberOfReportRatios()):
    r = qm.getReportRatioByNumber(i)
    ratioNames[i] = r.getName()

hit = pepsum.getHit(1)

print("%s :" % hit.getAccession())

for ratioName in ratioNames:
    r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName)

    if r.isMissing():
        print("     %s = (undefined)" % r.getRatioName())
    else if r.isInfinite():
        print("     %s = infinite" % r.getRatioName())
    else:
        print("     %s = %s (n = %d stderr = %s)" % (r.getRatioName(), r.getValue(), r.getSampleSize(), r.getStandardError()))

You can access the component intensities of each peptide ratio with getComponentIntensities().

Changing quantitation method parameters

A number of parameters change how peptide and protein ratios are calculated. These are encapsulated in the quantitation method object, ms_quant_method.

In the default workflow above, quantitation method parameters are read directly from the results file using the default XML schema. Certain parameters can be changed after the ms_ms2quantitation object has been created. These are normalisation, outlier detection, protein ratio calculation and including or excluding particular peptide ratios from protein ratio calculation. For example, you can change outlier detection in the following way:

qo = msparser.ms_quant_outliers()
qo.setMethod("dixons")

quant.setQuantOutliers(qo)

Changes take effect immediately; for example, values from getProteinRatio() may change after changing outlier detection, as some peptides may be excluded from protein ratio calculation.

It is not possible to change peptide quality settings in this way. (Quality settings determine which input queries are read from the results file, and changing the settings after the fact would require re-reading the results file.) You can use the default quantitation method as base configuration, alter the peptide-level settings, and then give the new method as argument to the constructor as follows:

embeddedQm = resfile.getQuantitationMethod()

if not qm:
    # not a quant results file
    return

# Note that we must create a copy, as embeddedQm is supposed to be const:
qm = msparser.ms_quant_method(embeddedQm)

qm.getQuality().setMinPrecursorCharge(2)

quant = msparser.ms_ms2quantitation(pepsum, qm)

if not quant.isValid():
    # report quant.getLastErrorString()
    return

quant.normalisePeptideRatios()

You can alter nearly all quantitation method settings this way. There are only two exceptions:

  1. Protocol must be identical (you cannot open a Multiplex file with a Reporter method).
  2. Components must be identical (e.g. you cannot define a new reporter ion for iTRAQ results without re-searching the data).

Please refer to the quantitation configuration help for more details on quantitation method parameters and how they affect ratio calculation.

Nearly complete example of ms_ms2quantitation

The example below shows how you can create an ms_ms2quantitation object, then change the default parameters and print the report ratios of the first protein hit. The example is given in the four programming languages supported by Parser:

C++
    const ms_quant_method *embeddedQm = resfile.getQuantitationMethod();

    if (!embeddedQm) {
        // not a quant results file
        return;
    }

    ms_quant_method qm = *embeddedQm;

    // Change a peptide quality setting:
    qm.getQuality()->setMinPrecursorCharge(2);

    ms_ms2quantitation quant = ms_ms2quantitation(pepsum, qm);

    if (!quant.isValid()) {
        // report quant.getLastErrorString()
        return;
    }

    // Change a peptide ratio outlier setting (could be done before quant is
    // created):
    ms_quant_outliers qo = qm.getOutliers() ? qm.getOutliers() : ms_quant_outliers();
    qo.setMethod("dixons");

    quant.setQuantOutliers(qo);

    // Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios();

    const ms_quant_method *currentQm = quant.getQuantitationMethod();
    std::vector<std::string> ratioNames;

    for (int i = 0; i != currentQm->getNumberOfReportRatios(); i++) {
        const ms_quant_ratio *r = currentQm->getReportRatioByNumber(i);
        ratioNames.push_back(r->getName());
    }

    const ms_protein *hit = pepsum.getHit(1);

    std::cout << hit->getAccession() << ":" << std::endl;

    for (std::vector<std::string>::size_type i = 0; i != ratioNames.size(); i++) {
        ms_protein_quant_ratio r = quant.getProteinRatio(hit->getAccession(), hit->getDB(), ratioNames[i]);

        if (r.isMissing()) {
            std::cout << "    " << r.getRatioName() << " = (undefined)" << std::endl;
        } else if (r.isInfinite()) {
            std::cout << "    " << r.getRatioName() << " = infinite" << std::endl;
        } else {
            std::cout << "    " << r.getRatioName() << " = " << r.getValue()
                << " (n = " << r.getSampleSize() << " stderr = " << r.getStandardError() << ")"
                << std::endl;
        }
    }

Perl
    my $embeddedQm = $resfile->getQuantitationMethod();

    if (not $embeddedQm) {
        # not a quant results file
        return;
    }

    my $qm = new msparser::ms_quant_method($embeddedQm);

    # Change a peptide quality setting:
    $qm->getQuality()->setMinPrecursorCharge(2);

    my $quant = new ms_ms2quantitation($pepsum, $qm);

    if (not $quant->isValid()) {
        # report $quant->getLastErrorString()
        return;
    }

    # Change a peptide ratio outlier setting (could be done before quant is
    # created):
    my $qo = $qm->getOutliers() ? $qm->getOutliers() : new msparser::ms_quant_outliers();
    $qo->setMethod("dixons");

    $quant->setQuantOutliers($qo);

    # Then normalise, if normalisation is enabled.
    $quant->normalisePeptideRatios();

    my $currentQm = $quant->getQuantitationMethod();
    my @ratioNames = ();

    for my $i (0 .. $currentQm->getNumberOfReportRatios()-1) {
        my $r = $currentQm->getReportRatioByNumber($i);
        push @ratioNames, $r->getName();
    }

    my $hit = $pepsum->getHit(1);

    print $hit->getAccession(), ":\n";

    for my $ratioName (@ratioNames) {
        my $r = $quant->getProteinRatio($hit->getAccession(), $hit->getDB(), $ratioName);

        if ($r->isMissing()) {
            print "    ", $r->getRatioName(), " = (undefined)\n";
        } elsif ($r->isInfinite()) {
            print "    ", $r->getRatioName(), " = infinite\n";
        } else {
            print "    ", $r->getRatioName(), " = ", $r->getValue(),
                " (n = ", $r->getSampleSize(), " stderr = ", $r->getStandardError(), ")",
                "\n"
                ;
        }
    }

Java
    ms_quant_method embeddedQm = resfile.getQuantitationMethod();

    if (embeddedQm == null) {
        // not a quant results file
        return;
    }

    // Change a peptide quality setting:
    ms_quant_method qm = new ms_quant_method(embeddedQm);

    qm.getQuality().setMinPrecursorCharge(2);

    ms_ms2quantitation quant = new ms_ms2quantitation(pepsum, qm);

    if (!quant.isValid()) {
        // report quant.getLastErrorString()
        return;
    }

    // Change a peptide ratio outlier setting (could be done before quant is
    // created):
    ms_quant_outliers qo = qm.getOutliers() ? qm.getOutliers() : new ms_quant_outliers();
    qo.setMethod("dixons");

    quant.setQuantOutliers(qo);

    // Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios();

    ms_quant_method currentQm = quant.getQuantitationMethod();
    Vector<String> ratioNames;

    for (int i = 0; i != currentQm.getNumberOfReportRatios(); i++) {
        ms_quant_ratio r = currentQm.getReportRatioByNumber(i);
        ratioNames.add(r.getName());
    }

    ms_protein hit = pepsum.getHit(1);

    System.out.println(hit.getAccession() + ":");

    for (String ratioName: ratioNames) {
        ms_protein_quant_ratio r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName);

        if (r.isMissing()) {
            System.out.println("    " + r.getRatioName() + " = (undefined)");
        } else if (r.isInfinite()) {
            System.out.println("    " + r.getRatioName() + " = infinite");
        } else {
            System.out.println("    " + r.getRatioName() + " = " + r.getValue()
                + " (n = " + r.getSampleSize() + " stderr = " + r.getStandardError() + ")"
            );
        }
    }
Python
    embeddedQm = resfile.getQuantitationMethod()

    if not embeddedQm:
        # not a quant results file
        return

    qm = msparser.ms_quant_method(embeddedQm)

    # Change a peptide quality setting:
    qm.getQuality().setMinPrecursorCharge(2)

    quant = msparser.ms_ms2quantitation(pepsum, qm)

    if not quant.isValid():
        # report quant.getLastErrorString()
        return

    # Change a peptide ratio outlier setting (could be done before quant is
    # created):
    qo = qm.getOutliers() ? qm.getOutliers() : msparser.ms_quant_outliers()
    qo.setMethod("dixons")

    quant.setQuantOutliers(qo)

    # Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios()

    currentQm = quant.getQuantitationMethod()
    ratioNames = []

    for i in range(currentQm.getNumberOfReportRatios()):
        r = currentQm.getReportRatioByNumber(i)
        ratioNames[i] = r.getName()

    hit = pepsum.getHit(1)

    print("%s:" % hit.getAccession())

    for ratioName in ratioNames:
        r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName)

        if r.isMissing():
            print("     %s = (undefined)" % r.getRatioName())
        else if r.isInfinite():
            print("     %s = infinite" % r.getRatioName())
        else:
            print("     %s = %d (n= %d stderr = %s)" % (r.getRatioName(), r.getValue(), r.getSampleSize(), r.getStandardError()))
C#
    ms_quant_method embeddedQm = new ms_quant_method();
    bool bQuant = resfile.getQuantitationMethod(embeddedQm);

    if (!bQuant) {
        // not a quant results file
        return;
    }

    // Change a peptide quality setting:
    ms_quant_method qm = new ms_quant_method(embeddedQm);

    qm.getQuality().setMinPrecursorCharge(2);

    ms_ms2quantitation quant = new ms_ms2quantitation(pepsum, qm);

    if (!quant.isValid()) {
        // report quant.getLastErrorString()
        return;
    }

    // Change a peptide ratio outlier setting (could be done before quant is
    // created):
    ms_quant_outliers qo = qm.haveOutliers() ? qm.getOutliers() : new ms_quant_outliers();
    qo.setMethod("dixons");

    quant.setQuantOutliers(qo);

    // Then normalise, if normalisation is enabled.
    quant.normalisePeptideRatios();

    ms_quant_method currentQm = quant.getQuantitationMethod();
    List<string> ratioNames = new List<string>();

    for (int i = 0; i != currentQm.getNumberOfReportRatios(); i++) {
        ms_quant_ratio r = currentQm.getReportRatioByNumber(i);
        ratioNames.Add(r.getName());
    }

    ms_protein hit = pepsum.getHit(1);

    Console.WriteLine("{0}:", hit.getAccession());

    foreach (string ratioName in ratioNames) {
        ms_protein_quant_ratio r = quant.getProteinRatio(hit.getAccession(), hit.getDB(), ratioName);

        if (r.isMissing()) {
            Console.WriteLine("    {0} = (undefined)", r.getRatioName());
        } else {
            Console.WriteLine("    {0} = {1} (n = {0} stderr = {0})", r.getRatioName(), r.getValue(), r.getSampleSize(), r.getStandardError());
        }
    }

Combined results files and merging ratios

It is possible to use ms_ms2quantitation with combined results files, as long as all files have identical settings and search parameters. (They cannot be combined otherwise; see Combining multiple .dat files). After creating the ms_ms2quantitation object, you can change quantitation method settings and access peptide and protein ratios as above.

There is an additional problem, though: peptide ratio definitions may differ between files. For example, suppose you have combined two iTRAQ 4-plex results files. The first file contains ratios "115/114", "116/114" and "117/114", while the second one contains "114/115", "116/115" and "117/115" -- that is, a different channel is used as the reference component.

What should happen now? The ms_ms2quantitation class merges together ratio definitions with the same name. Imagine peptide ratios arranged in a table such that a row contains the report ratios for a particular peptide (q,p), and the columns are the ratios themselves ("115/114", "116/114", "117/114"). Merging in this context simply means peptide ratios with the same name appear in the same column, regardless of which file it comes from. Since the ratio names differ between files, the combined table will have six columns. Peptides from the first file will have a null value for ratios defined in the second file, and vice versa.

A similar problem exists even when ratio names are identical. For example, "115/114" in the first file may be the control, while the control in the second file is actually "116/114".

The solution to the first problem is to redefine the report ratio formulas in the second file, while the second problem is solved by renaming the ratios (e.g. "Control" for "115/114" in the first file and "Control" for "116/114" in the second file). Both can be accomplished using ms_ms2quantitation::setCombinedReportRatio(). Report ratio definition changes take effect immediately; no recalculation needs to be done. After changing the ratios, getPeptideRatio() and getProteinRatio() will return values according to the new definitions. You can enumerate the combined list of ratio names using ms_ms2quantitation::getCombinedReportRatioNames().

Using other protocols: ms_customquantitation

From custom peptide ratios to protein ratios

If your results file uses the Precursor, Replicate or Average protocols, or if you have a custom protocol that doesn't fit neatly in any category, you can't use ms_ms2quantitation, because the class expects to extract Reporter or Multiplex component intensities from the MS/MS data. Precursor, Replicate and Average require data from the original raw file, and there is no mechanism to feed in the raw file in Parser.

If you need this level of functionality, you need to use e.g. Mascot Distiller. Mascot Distiller quantitation results from these protocols can be extracted using Mascot Parser, see Accessing Distiller Quantitation Results.

If you have calculated peptide ratios in some way (e.g. by extracting component intensities from XICs), then you can use ms_customquantitation, which is the sibling class to ms_ms2quantitation. The class shares much of the same interface. In particular, both classes implement the same protein ratio calculation and significance testing, while ms_customquantitation allows greater control over peptide ratios.

In Reporter and Multiplex protocols, each peptide ratio is associated with a single peptide match (MS/MS spectrum). This is not necessarily the case with other protocols, where the peptide ratio can be calculated from a combination of features. In custom quantitation, each peptide ratio is associated with a peptide quant key, which fully identifies the ratio. The peptide quant key can be, for example, the query and rank of an identified peptide (in Reporter and Multiplex) or it can be any unique string value.

You will need to define a mapping from protein accessions to peptide quant keys for protein ratio calculation purposes; that is, you need to define which peptide ratios should be used in calculating a protein ratio. When you call getProteinRatio(), the class will look up all unique peptide ratios associated with the peptide quant keys associated with the protein accession, and use that set of ratios to calculate the protein ratio (the algorithm is the same as in ms_ms2quantitation). For this to work, you also need to configure protein ratio calculation settings in the quantitation method, or define outlier, normalisation and other settings after creating the ms_customquantitation object.

Bird's eye view to ms_customquantitation

ms_customquantitation can be used in a number of ways, and the right way depends on problem context. An example is sketched out below, using Python-like pseudocode syntax:

qm = resfile.getQuantitationMethod(...);

if not qm:
    return;

qm.getNormalisation().setMethod("none");
qm.getOutliers().setMethod("none");
qm.setMinNumPeptides(2);
qm.setProteinRatioType("average");

quant = msparser.ms_customquantitation(qm);

if not quant.isValid():
    # report quant.getLastErrorString()
    return;

# Set normalisation constants here if needed:
#quant.setNormalisationBase(..., ...);

for (loop over some data):
    q = ...;
    p = ...;
    ratioName = ...;
    value = ...;
    key = msparser.ms_peptide_quant_key(q, p)
    r = msparser.ms_peptide_quant_ratio(key, ratioName, value);

    # Add peptide ratio:
    quant.addPeptideRatio(r);

    accession = ...;
    dbIdx = ...;

    # Push it to the protein-peptide mapping:
    quant.addPeptideQuantKey(accession, dbIdx, key);

If you have a Mascot results file and open it as ms_peptidesummary, you can give the object as a parameter to ms_customquantitation, which will initialise the peptide-protein mappings directly from the results file. This saves quite a bit of work, and you are still able to edit the mappings later. For example:

# This also pulls the quantitation method from the results file.
quant = msparser.ms_customquantitation(pepsum);

if not quant.isValid():
    # report quant.getLastErrorString()
    return;

# Alter default settings:

qo = msparser.ms_quant_outliers();
qo.setMethod("none");

quant.setQuantOutliers(qo);

quant.setMinNumPeptides(2);
quant.setProteinRatioType("average");

# Set normalisation constants here if needed:
#quant.setNormalisationBase(..., ...);

for (loop over some data):
    q = ...;
    p = ...;
    ratioName = ...;
    value = ...;
    key = msparser.ms_peptide_quant_key(q, p)
    r = msparser.ms_peptide_quant_ratio(q, p, ratioName, value);

    # No need to use addPeptideQuantKey() -- mapping is already there.

Peptide quality control

If you are using ms_customquantitation, you may need to determine whether a peptide match is worth quantitating (for example, it may not be a statistically significant match). The ms_quant_helper class provides two methods to this end. The process is as follows, assuming qm is a quantitation method object that defines both peptide quality settings and the components:

umodfile = msparser.ms_umod_configfile();

if (!resfile.getUnimod(umodfile, true)):
    # log reason
    return;

qhelp = msparser.ms_quant_helper(pepsum, qm, umodfile);

if (!qhelp.isValid()):
    # log reason
    return;

for (loop over queries q and ranks p to quantitate):
    (qres, reason) = qhelp.isPeptideQuantifiable(q, p)

    if qres != msparser.ms_quant_helper.PEPTIDE_IS_QUANTIFIABLE:
        # log reason and skip peptide
        continue;

    (qualres, reason) = qhelp.isPeptideQualityOK(q, p)

    if qualres != msparser.ms_quant_helper.PEPTIDE_QUALITY_IS_OK:
        # log reason and skip peptide
        continue;

    # Add additional tests here if needed; otherwise the peptide contains the
    # required modifications (if specified in this protocol) needed for
    # quantitation and passes the score thresholds (if defined in quality
    # settings), so it can be quantified.

Additional tests can be, for example, testing the peptide sequence for uniqueness with ms_mascotresults::isPeptideUnique().

Special case: Reporter and Multiplex - converting ms_ms2quantitation to ms_customquantitation

If you have an ms_ms2quantitation object, you can use it also as an argument to the constructor. The constructor will pull all quantitation method settings, peptide-protein mappings and peptide ratios from the object and store them internally. You can then edit the peptide ratios or peptide-protein mappings if needed. The constructor documentation gives more details.

Note that ms_customquantitation does not support caching of any kind, as it is very difficult to define what goes in the cache file and what does not. If you need to cache data, you can use ms_tinycdb to read and write cache files.

Special case: peptide and protein data in the Average protocol

The Average protocol differs from the other four. First of all, the concept of peptide ratio has no meaning in the protocol. Protein ratios are instead calculated directly from the top three (or top N) peptide intensities assigned to the protein hit.

Second, only one protein ratio type is supported: average. The average protein ratio type has special meaning when protocol is Average, in that the protein ratio is simply the sum of its top N peptide intensities, divided by the sum of the top N peptide intensities of a named reference protein. In other protocols, average means the geometric mean of peptide ratios.

Third, outlier testing has no meaning in the Average protocol. It is not possible to use any other setting for outlier removal than none.

We suggest the following workflow for using Average with ms_customquantitation:

  1. Create a fresh ms_customquantitation object with a quantitation method object configured for the Average protocol.
  2. Add all peptide intensities in ms_peptide_quant_ratio objects: let the single ratio name be "intensity" and its value simply the raw intensity.
  3. Add peptide-protein mappings, linking specific peptide quant keys with protein accessions.
  4. Use setAverageReferenceProtein() to select a protein accession as the reference protein, if one has not yet been set in the quantitation method.
  5. Read off protein ratios with getProteinRatio(), where the ratio name is "intensity". The values will be relative to the intensity of the reference protein, taking the configured reference amount into account.

Note that peptide and protein ratio normalisation is meaningless in the Average protocol.

Further protein ratio statistics

Statistical routines used by other quantitation classes are collected in ms_quant_stats. The class is used internally by ms_ms2quantitation and ms_customquantitation to determine peptide ratio outliers and calculate the protein ratio p-value and statistical significance. You can use the class to calculate protein ratios manually in the following way, assuming quant contains an ms_quantitation object or one of its child classes (ms_ms2quantitation, ms_customquantitation):

keys = quant.getPeptideQuantKeys(accession, dbIdx);
ratioName = ...; # the ratio we're interested in

rawRatios = [];

for i in range(0, keys.size()-1):
    if not quant.hasPeptideRatio(keys.get(i), ratioName):
        continue;

    r = quant.getPeptideRatio(keys.get(i), ratioName);

    if not r.isInfinite():
        rawRatios.append(r.getValue());

outlierIndices = msparser.ms_quant_stats.detectOutliers(rawRatios, "auto");

ratios = [];

for i in range(0, len(rawRatios)-1):
    is_outlier = false;

    for j in range(0, len(outlierIndices)-1):
        if i == outlierIndices[j]:
            is_outlier = true;
            break;

    if is_outlier:
        continue;

    ratios.append(rawRatios[i]);

median = msparser.ms_quant_stats.unsortedMedian(ratios);

logratios = msparser.ms_quant_stats.logTransform(ratios);
logmean = msparser.ms_quant_stats.arithmeticMean(logratios);
logstdev = msparser.ms_quant_stats.arithmeticStandardDeviation(logratios, logmean);
logstderr = msparser.ms_quant_stats.arithmeticStandardErrorOfMedian(logstdev, len(ratios));
stderr = exp(logstderr)

ms_quant_stats also contains functions for calculating the cumulative distribution function and critical values of a few commonly used distributions. Please consult the class documentation for more details.

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Accessing Distiller Quantitation Results
[Quantitation analysis for Mascot Server and Distiller]

Note: This describes the structure of a single-file project. Projects with multiple files have a different, more complex structure, see Accessing Distiller Multi-file Quantitation Results.

Single-file Quantitation Overview

Distiller stores its parameters and results in a Distiller project (.rov) file.

The project file has the same internal format as a .ZIP file. You can view the contents by opening it with a .ZIP file viewer (e.g. by renaming the file to have a .zip extension and opening as usual for a .ZIP file).

The data can also be extracted using the Mascot Distiller SDK (MDRO), see Distiller projects and the toolkit.

Project file streams

The project file contains a number of streams:

name | format | contents
mdro_search_status | XML | A search status list detailing all of the result sets in the project.
mdro_search_status+N | MIME | The Mascot results data to be used to construct a ms_mascotresfile. N is the id attribute from the search status.
rover_data | XML | The Distiller project parameters to be used to create a ms_distiller_data.
rover_data+(cac0+N) | MIME | The peptide summary cache to be used to construct a ms_peptidesummary. N is the id attribute from the search status.
rover_data+(1f40+M) | binary | The quantitation results file used to populate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.
rover_data+(bb8+M) | binary | The quantitation cache file used to populate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.

Distiller project parameters

The Distiller project parameters are held in the stream rover_data.

The stream name can be retrieved directly from matrix_science::ms_distiller_search_status_list.

std::string projectStreamName = matrix_science::ms_distiller_data::getDistillerProjectStreamName();

This data should be loaded into an ms_distiller_data.

matrix_science::ms_distiller_data distillerData;
std::string roverXmlFilename = zipExtractPath + projectStreamName;
bool optionsLoadedFomXmlOk = distillerData.loadXmlFile(mascotXmlSchemaFolder.c_str(), roverXmlFilename);

It contains a number of parameters required for the ms_peptidesummary and also a list of searches and a list of quantitation results. The schema for this is in distiller_data_1.xsd.

Search list

The search list is held in the stream mdro_search_status.

This list is in XML format. The schema for this XML is in the file mdro_search_status_1.xsd.

The search list is used to determine the id of the results file stream to be loaded (at XPath /mdroMascotSearchStatusStream/searchStatusList/searchStatus/@id ).

There are other attributes that may be of interest; for example the search task id and title.

ms_distiller_search_status_list can be used to parse the file.

std::string searchFilename = zipExtractPath + matrix_science::ms_distiller_search_status_list::getSearchStatusListStreamName();
matrix_science::ms_distiller_search_status_list searchList;
bool ok = searchList.loadXml(searchFilename);

The schema for this is in mdro_search_status_1.xsd.

Mascot results

The mascot results are held in the stream mdro_search_status+N, where N is the id of the search status; for example "mdro_search_status+1". If the id is greater than 9 then it is expressed in lower-case hexadecimal, e.g. an id of 13 would have a stream name of "mdro_search_status+d".

The results file stream name can be retrieved directly from the search status.

std::string resfileStreamName = searchList.getSearch(1).getResfileStreamName();

This file should be loaded by the ms_mascotresfile.

The cache files for the results and the peptide summary will be placed in a folder located in the temporary file folder specified to the ms_mascotresfile constructor. The name of this sub-folder varies with the last update time attribute of the results file and is determined at the time the ms_mascotresfile is constructed. These cache files are not deleted by Parser after creation. In order to discourage unnecessary disk usage by an ever expanding number of files, you should set the last-write-time of the results file. Distiller sets it to 00:00:00 1/1/2010.

time_t time = matrix_science::ms_distiller_data::distillerResfileTimestamp;
matrix_science::ms_fileutilities::setLastModificationTime(pathnameResfile.c_str(), time);

When creating the ms_mascotresfile, the cache should be enabled (to speed up access) and the timestamp within the cache file should be ignored (to avoid timezone issues, this does not affect generation of the folder used for cache files).

int resFileFlags = matrix_science::ms_mascotresfile::RESFILE_USE_CACHE
        | matrix_science::ms_mascotresfile::RESFILE_CACHE_IGNORE_DATE_CHANGE;
matrix_science::ms_mascotresfile * resfile = new matrix_science::ms_mascotresfile(
        pathnameResfile.c_str(),
        0, // keepAliveInterval
        "<!-- %d seconds -->\n", // keepAliveText
        resFileFlags,
        temporaryFileFolder.c_str(),
        mascotXmlSchemaFolder.c_str());

Peptide summary cache

The peptide summary loads a cache file in order to improve access times and ensure consistent results across different versions of Mascot Parser.

The same parameters, available from the Distiller project parameters, are used in the generation of the peptide summary cache filename as are used in the creation of the peptide summary itself, so the same values should be used when invoking each of the two functions.

This is stored in the project file, in the stream rover_data+cac0 + N where N is the id of the search from the search status list; for example "rover_data+cac1". The stream name can be retrieved from the search.

std::string summaryStreamName = searchList.getSearch(1).getPeptideSummaryCacheStreamName();

The peptide summary cache data should be copied to the correct file location for use.

std::string pathnameCachefile = matrix_science::ms_peptidesummary::getCacheFilename(
        *resfile,
        distillerData,
        1); // first search in the list

Once the peptide summary cache file has been copied into position, the peptide summary should be created using exactly the same parameters as were used to generate the filename.

matrix_science::ms_peptidesummary * peptideSummary = new matrix_science::ms_peptidesummary(
        *resfile,
        distillerData,
        1);

Quantitation results

The quantitation data is stored in two streams of the Distiller project file.

The stream number offset is obtained from the first ms_distiller_data_quant in the list in the ms_distiller_data. This offset is added to 3000 for the quantitation data stream number and to 8000 to get the cache stream number. These should then be converted to hexadecimal to give the actual names of the streams; for example, a streamNumber of 2 would give stream names of "rover_data+bba" and "rover_data+1f42".

The quantitation results stream names can be retrieved directly.

std::string cdbStreamName = distillerData.getQuant(1).getResultsStreamName();
std::string cacheStreamName = distillerData.getQuant(1).getCacheStreamName();

These files can then be used to create a ms_ms1quantitation. The quantitation method required for the constructor is available from the Distiller project parameters.

matrix_science::ms_quant_method quantMethod = distillerData.quantMethod;
matrix_science::ms_ms1quantitation quant(peptideSummary, quantMethod);
quant.loadCdbFile(zipExtractPath + cdbStreamName, zipExtractPath + cacheStreamName);
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Accessing Distiller Multi-file Quantitation Results
[Quantitation analysis for Mascot Server and Distiller]

Note: This describes the structure of a multi-file project. Projects with a single file have a different, simpler structure, see Extracting quantitation results with the Distiller toolkit.

Multi-file Quantitation Overview

Distiller stores its results are stored in a Distiller project (.rov) file.

The project file is the same format as a .ZIP file. You can view the contents by opening it with a .ZIP file viewer.

The data can also be extracted using the Mascot Distiller SDK (MDRO), see Distiller projects and the toolkit.

Project and subproject files

The master file for the Distiller multi-file project contains references to the subprojects.

The subproject files are held in a sub-folder with a name formed by appending ".files" to the name of the master file (without the ".rov" extension). For example, the master project file "Triple2.rov" would have a subfolder called "Triple2.files", in the same folder as the master file, to hold the subproject files.

Master project file streams

The master project file contains a number of streams.

name | format | contents
rover_data+2 | XML | The master project containing lists of the subprojects, searches and sub-searches.
rover_data | XML | The Distiller project to be used to create a ms_distiller_data.
rover_data+(cac0+N) | MIME | The combined peptide summary cache to be used to construct a ms_peptidesummary. N is the id attribute from the search in the master project lists.
rover_data+(1f40+M) | binary | The combined quantitation results file used to poulate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.
rover_data+(bb8+M) | binary | The combined quantitation cache file used to poulate a ms_ms1quantitation. M is the projectStream attribute from the Distiller project.

subproject file streams

Each subproject file contains a number of streams.

name | format | contents
mdro_search_status | XML | A search status list of the search results in the subproject.
mdro_search_status+N | MIME | The Mascot search results to be used in the combined ms_mascotresfile. N is the id attribute from the search status.

Master project lists

The lists of subprojects and searches are held in XML format in the stream rover_data+2 of the master project file. The presence of this stream indicates that this is the master file for a multi-file project.

This stream holds the list of subprojects in the master project (at XPath /MasterProject/SubProject).

It also holds the id used to generate the name of the combined peptide summary cache stream (at XPath /MasterProject/Searches/Search/@id).

The name of the stream is available from ms_distiller_master_project.

std::string masterProjectStreamName = matrix_science::ms_distiller_master_project::getMasterProjectStreamName();

This data should be loaded into an ms_distiller_master_project.

matrix_science::ms_distiller_master_project masterProject;
masterProject.loadXmlFile(xmlSchemaDirectory, masterProjectPathname);

The schema for this is in distiller_master_project_1.xsd.

Distiller project parameters

The Distiller project parameters are held in the stream rover_data.

This data has the same format as that for single file Distiller project parameters.

Mascot results

The Mascot results are combined from the mdro_search_status+N stream from each of the subproject files, where N is the id from the search status in the subproject. Each subproject has its own Mascot results stream. See Search list and Mascot results for a single file Distiller project.

For a multi-file project, instead of creating a ms_mascotresfile for each subproject, the ms_mascotresfile is created from the Mascot results of each subproject in turn. The first subproject is used for the constructor and then the subsequent ones are each appended.

The last update time attribute of the first results file is used by Parser when determining the name of the subfolder used for the peptide summary cache file; see Mascot results.

std::vector<std::string> resfilePathnames;

... // extract subproject results files and poluate filenames

matrix_science::ms_mascotresfile * resfile = new matrix_science::ms_mascotresfile(
        resfilePathnames[0].c_str(),
        0, // keepAliveInterval
        "<!-- %d seconds -->\n", // keepAliveText
        matrix_science::ms_mascotresfile::RESFILE_NOFLAG,
        cacheDirectory.c_str(),
        xmlSchemaDirectory);
for (int iResult = 1; iResult < resfilePathnames.size(); ++iResult)
{
    resfile->appendResfile(resfilePathnames[iResult].c_str());
}

Combined peptide summary cache

The peptide summary cache for the combined results files is in the stream rover_data+cac0 + N of the master project file, where N is the id of the search from the master project; for example "rover_data+cac1".

The ms_distiller_master_project should be used to retrieve the name of the stream containing the combined peptide summary cache file.

std::string pepsumStreamName = masterProject.getSearch(1).getCombinedPeptideSummaryCacheStreamName();

The ms_distiller_data from the master project should be used for the settings when creating the peptide summary filename and again when creating the peptide summary.

std::string pepsumFilename = matrix_science::ms_peptidesummary::getCacheFilename(
        *resfile,
        distillerData,
        1); // first search in the list

The peptide summary cache data should be copied to the correct file location before constructing the peptide summary, see Peptide summary cache for a single file Distiller project.

matrix_science::ms_peptidesummary * peptideSummary = new matrix_science::ms_peptidesummary(
        *resfile,
        distillerData,
        1);

Quantitation results

The combined (from all subprojects) quantitation data is stored in two streams of the master project file.

The stream names are obtained from the ms_distiller_data of the master project file. This is the same as for a single file project, see the single file Quantitation results.

matrix_science::ms_quant_method quantMethod = distillerData.quantMethod;
matrix_science::ms_ms1quantitation quant(peptideSummary, quantMethod);
std::string cdbStreamName = distillerData.getQuant(1).getResultsStreamName();
std::string cacheStreamName = distillerData.getQuant(1).getCacheStreamName();

... // extract the streams

quant.loadCdbFile(zipExtractPath + cdbStreamName, zipExtractPath + cacheStreamName);
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Extracting quantitation results with the Distiller toolkit
[Quantitation analysis for Mascot Server and Distiller]

Distiller projects and the toolkit

The Distiller project file can be accessed using the Mascot Distiller SDK. This library includes files for opening and reading Distiller project files and raw spectrographic data files.

Note -- This method of automatic extraction of data from a Distiller project (.rov) file requires the use of the Mascot Distiller SDK (MDRO). The Mascot Distiller SDK is a Windows-only product and is not included in the Mascot Parser Toolkit and is not free.

Project file and search status

All the Distiller data is stored in a project file. By default, this has a '.rov' file extention.

The project is accessed by first creating a project manager. The file is then opened to get a project interface.

mdroapi::IMDROProjectManagerPtr iProjectManager;
HRESULT hr = iProjectManager.CreateInstance( __uuidof(mdroapi::MDROProjectManager) );
mdroapi::IMDROProjectPtr iProject;
hr = iProjectManager->raw_Open(
        _bstr_t(rovfilePathname.c_str()),
        mdroapi::mdroProjectFlagReadOnly,
        vtMissing,
        &iProject );

This can then be used to access the collection of search statuses: The collection may contain multiple search statuses. The data streams for the Mascot results and the peptide summary are accessed using the search status.

mdroapi::IMascotSearchStatusCollectionPtr iSearchStatusCollection;
mdroapi::IMDROProjectIOStreamPtr ISearchStatusStm;
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmSearchStatus,
        vtMissing,
        &ISearchStatusStm );
hr = iSearchStatusCollection.CreateInstance( __uuidof(mdroapi::MascotSearchStatusCollection) );
hr = iSearchStatusCollection->LoadFromStream( ISearchStatusStm );
long sCount = iSearchStatusCollection->Count;
int searchIndex = 1; // select required search, usually only one
mdroapi::IMascotSearchStatusPtr iSearchStatus = iSearchStatusCollection->GetItem(searchIndex);

Mascot results

The search status summary stream is used to extract the mascot results. It should be saved to a file to be re-loaded by the ms_mascotresfile.

mdroapi::IMDROProjectIOStreamPtr iSummaryStm;
hr = iSearchStatus->raw_OpenSummaryStream(mdroapi::mdroProjectStmFlagRead, iProject, &iSummaryStm);
bool ok = SaveIoStreamToFile(iSummaryStm, pathnameResfile);
iSummaryStm->Close();

The cache files for the results and the peptide summary will be placed in a folder located in the temporary file folder specified to the ms_mascotresfile constructor. The name of this sub-folder varies with the last update time attribute of the results file. In order to discourage unnecessary disk usage by an ever expanding number of files, you should set the last-write-time of the results file. Distiller sets it to 00:00:00 1/1/2010.

time_t time = matrix_science::ms_distiller_data::distillerResfileTimestamp;
matrix_science::ms_fileutilities::setLastModificationTime(pathnameResfile.c_str(), time);

When creating the ms_mascotresfile, the cache should be enabled (to speed up access) and the timestamp within the cache file should be ignored (to avoid timezone issues, this does not affect generation of the folder used for cache files).

int resFileFlags = matrix_science::ms_mascotresfile::RESFILE_USE_CACHE
        | matrix_science::ms_mascotresfile::RESFILE_CACHE_IGNORE_DATE_CHANGE;
matrix_science::ms_mascotresfile * resfile = new matrix_science::ms_mascotresfile(
        pathnameResfile.c_str(),
        0, // keepAliveInterval
        "<!-- %d seconds -->\n", // keepAliveText
        resFileFlags,
        temporaryFileFolder.c_str(),
        mascotXmlSchemaFolder.c_str());

Distiller project

The project data shoud be loaded into an ms_distiller_data.

This contains the stream number offset used in the name of the quantitation results streams.

matrix_science::ms_distiller_data distillerData;
std::string roverXml = GetIoStreamString(iProject, mdroapi::mdroProjectStmRover, 0);
distillerData.loadXml(mascotXmlSchemaFolder.c_str(), roverXml);
int quantStreamNumber = distillerData.getQuant(1).getStreamNumber();

Peptide summary cache

The peptide summary loads a cache file in order to improve access times. The name of this cache file is dependent on the parameters passed to the constructor. A function is available from matrix_science::ms_peptidesummary to allow the name of the cache file to be determined in advance so that it can be created.

std::string pathnameCachefile = matrix_science::ms_peptidesummary::getCacheFilename(
        *resfile,
        distillerData,
        1); // first search in the list

mdroapi::IMDROProjectIOStreamPtr iCacheStm;
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmRover,
        _variant_t(0xCAC0 + iSearchStatus->StatusId),
        &iCacheStm );
SaveIoStreamToFile(iCacheStm, pathnameCachefile);
iCacheStm->Close();

matrix_science::ms_peptidesummary * peptideSummary = new matrix_science::ms_peptidesummary(
        *resfile,
        distillerData,
        1); // first search in the list

Quantitation results

The quantitation data is stored in two streams of the Distiller project file. These should be extracted and saved to temporary files. There is no special requirement on the naming of these files.

The stream number, within the project, is obtained from the dataset quantitation result information. There may be multiple quantitation results sets in the project, each with a different stream number. The stream number will not necessarily be the same as the index into the quantitation results sets.

const long QUANTRESULT_OFFSET = 3000;
const long QUANTRESULT_CACHE_OFFSET = 8000;
int quantStreamNumber = distillerData.getQuant(1).getStreamNumber();
mdroapi::IMDROProjectIOStreamPtr iStream;
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmRover,
        _variant_t(QUANTRESULT_OFFSET + quantStreamNumber),
        &iStream );
SaveIoStreamToFile(iStream, cdbFilename);
iStream->Close();
hr = iProject->raw_OpenStream(
        mdroapi::mdroProjectStmFlagRead,
        mdroapi::mdroProjectStmRover,
        _variant_t(QUANTRESULT_CACHE_OFFSET + quantStreamNumber),
        &iStream );
SaveIoStreamToFile(iStream, cacheFilename);
iStream->Close();

The quantitation method is available from the mascot results.

These files can then be used to create a ms_ms1quantitation.

matrix_science::ms_quant_method quantMethod;
resfile->getQuantitationMethod(&quantMethod);
matrix_science::ms_ms1quantitation quant(peptideSummary, quantMethod);
quant.loadCdbFile(cdbFilename, cacheFilename);

Reading a project stream

Reading the data of a Distiller stream is can be accomplished by repeatedly reading it in chunks into SAFEARRAY. The data can be concatentated in memory, if it is going to be small enough, or written to a file.

Saving to a string

std::string GetIoStreamString(mdroapi::IMDROProjectIOStreamPtr IDistillerStm)
{
    std::string data;
    stmobjapi::IByteStreamSignalPtr ISignal = IDistillerStm;
    ISignal->BeginStreamOp(stmobjapi::stmobjStreamOpFlagRead);
    SAFEARRAYBOUND safeArrayBounds[1] = { 1024 * 1024, 0 };
    SAFEARRAY * safeArray = SafeArrayCreate(VT_UI1, 1, safeArrayBounds);
    stmobjapi::IByteStreamIOPtr IInStream = IDistillerStm;
    while (true)
    {
        long readCount = IInStream->ReadBytes(&safeArray);
        if (readCount == 0)
        {
            break;
        }
        const void * readBytes = safeArray->pvData;
        data.append((const char *)readBytes, ((const char *)readBytes) + readCount);
    }
    ISignal->EndStreamOp(VARIANT_TRUE);
    SafeArrayDestroy(safeArray);
    return data;
}

Saving to a file

void SaveIoStreamToFile(mdroapi::IMDROProjectIOStreamPtr iDistillerStm, const std::string & filename)
{
    std::ofstream file;
    file.open(filename.c_str(), std::ios_base::out|std::ios_base::binary);
    stmobjapi::IByteStreamSignalPtr iSignal = iDistillerStream;
    iSignal->BeginStreamOp(stmobjapi::stmobjStreamOpFlagRead);
    SAFEARRAYBOUND safeArrayBounds[1] = { 1024 * 1024, 0 };
    SAFEARRAY * safeArray = SafeArrayCreate(VT_UI1, 1, safeArrayBounds);
    stmobjapi::IByteStreamIOPtr iInStream = iDistillerStream;
    while (true)
    {
        long readCount = iInStream->ReadBytes(&safeArray);
        if (readCount == 0)
        {
            break;
        }
        const char * readBytes = (const char *)safeArray->pvData;
        file.write(readBytes, readCount);
    }
    iSignal->EndStreamOp(VARIANT_TRUE);
    SafeArrayDestroy(safeArray);
    file.close();
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Source code for the Shapiro-Wilk W test algorithm
[Quantitation analysis for Mascot Server and Distiller]

/*
##############################################################################
# File: ms_shapiro_wilk.cpp                                                  #
# Mascot Parser toolkit                                                      #
# Source file for Shapiro-Wilk W test                                        #
##############################################################################
#    $Source$
#    $Author$
#      $Date$
#  $Revision$
##############################################################################
*/
/*
##############################################################################
# Applied Statistics algorithms                                              #
#                                                                            #
# Translated and adapted from routines that originally appeared in the       #
# Journal of the Royal Statistical Society Series C (Applied Statistics)     #
# and made available through StatLib http://lib.stat.cmu.edu/                #
#                                                                            #
# The implementation and source code for this algorithm is available as a    #
# free download from http://www.matrixscience.com/msparser.html              #
# to conform with the requirement that no fee is charged for their use       #
##############################################################################
*/

// STDAFX.H includes windows.h, msparser.hpp and other commonly used headers
#include "stdafx.h"

#include <cmath>
#include <limits>
#include <algorithm>

using namespace matrix_science;

ms_shapiro_wilk::ms_shapiro_wilk()
    :w_(0)
    ,pw_(0)
    ,ifault_(0)
{
}

ms_shapiro_wilk::ms_shapiro_wilk(std::deque<std::pair<size_t,double> > x,
                                 long n,
                                 long n1,
                                 long n2)
    :w_(0)
    ,pw_(0)
    ,ifault_(0)
{
    swilk(false, x, n, n1, n2, a_, w_, pw_, ifault_);
}

ms_shapiro_wilk::~ms_shapiro_wilk()
{
}

double ms_shapiro_wilk::getResult() const
{
    return w_;
}

double ms_shapiro_wilk::getPValue() const
{
    return pw_;
}

double ms_shapiro_wilk::getErrorCode() const
{
    return ifault_;
}

void ms_shapiro_wilk::appendSampleValue(double x) {
    std::deque<std::pair<size_t,double> >::size_type idx = x_.size();
    x_.push_back(std::make_pair(idx, x));
    w_      = 0;
    pw_     = 0;
    ifault_ = 0;
}

void ms_shapiro_wilk::clearSampleValues() {
    x_.clear();
    w_      = 0;
    pw_     = 0;
    ifault_ = 0;
}

void ms_shapiro_wilk::calculate(long n, long n1, long n2) {
    swilk(false, x_, n, n1, n2, a_, w_, pw_, ifault_);
}

void ms_shapiro_wilk::swilk(bool init,
                            std::deque<std::pair<size_t,double> > x,
                            long n,
                            long n1,
                            long n2,
                            std::deque<double> &a,
                            double &w,
                            double &pw,
                            int &ifault) {
    /* Algorithm AS R94, Journal of the Royal Statistical Society Series C
     * (Applied Statistics) vol. 44, no. 4, pp. 547-551 (1995).
     */

    w = 0; // stop the behaviour change 'feature'
    pw = 0;
    ifault = 0;

    /* Initialized data */
    static const double zero = 0.0;
    static const double one = 1.0;
    static const double two = 2.0;
    static const double three = 3.0;

    static const double z90 = 1.2816;
    static const double z95 = 1.6449;
    static const double z99 = 2.3263;
    static const double zm = 1.7509;
    static const double zss = 0.56268;
    static const double bf1 = 0.8378;
    static const double xx90 = 0.556;
    static const double xx95 = 0.622;
    static const double sqrth = 0.70711;/* sqrt(1/2) = .7071068 */
    static const double small_value = 1e-19;
    static const double pi6 = 1.909859;
    static const double stqr = 1.047198;

    /* polynomial coefficients */
    static const double g[2] = { -2.273,.459 };
    static const double c1[6] = { 0.,.221157,-.147981,-2.07119, 4.434685, -2.706056 },
                     c2[6] = { 0.,.042981,-.293762,-1.752461,5.682633, -3.582633 };
    static const double c3[4] = { .544,-.39978,.025054,-6.714e-4 };
    static const double c4[4] = { 1.3822,-.77857,.062767,-.0020322 };
    static const double c5[4] = { -1.5861,-.31082,-.083751,.0038915 };
    static const double c6[3] = { -.4803,-.082676,.0030302 };
    static const double c7[2] = { .164,.533 };
    static const double c8[2] = { .1736,.315 };
    static const double c9[2] = { .256,-.00635 };

    /* System generated locals */
    double r__1;

    a.resize(n, 0.0);

    /*
     * Auxiliary routines : poly()  {below}
     */

    /* Local variables */
    int i, j, ncens, i1, nn2;

    double zbar, ssassx, summ2, ssumm2, gamma, delta, range;
    double a1, a2, an, bf, ld, m, s, sa, xi, sx, xx, y, w1;
    double fac, asa, an25, ssa, z90f, sax, zfm, z95f, zsd, z99f, rsn, ssx, xsx;

    /* Parameter adjustments */
    pw = 1.0;
    ifault = 0;
    if (w >= 0.0) {
        w = 1.0;
    }
    an = (double) (n);
    nn2 = n / 2;
    if (n2 < nn2) {
        ifault = 3;
        return;
    }
    if (n < 3) {
        ifault = 1;
        return;
    }

    /*  If INIT is false, calculate coefficients a[] for the test */
    if (! (init)) {
        if (n==3) {
                a[0] = sqrth;
        } else {
            an25 = an + .25;
            summ2 = zero;
            for (i = 1; i <= n2; ++i) {
                a[i-1] = (double) ppnd7((i - .375f) / an25, ifault);
                if (ifault) {
                    ifault = 8;
                    return;
                }
                summ2 += (a[i-1] * a[i-1]);
            }
            summ2 *= two;
            ssumm2 = std::sqrt(summ2);
            rsn = one / std::sqrt(an);
            a1 = poly(c1, 6, rsn) - a[0] / ssumm2;

            /* Normalize a[] */
            if (n > 5) {
                i1 = 3;
                a2 = -a[1] / ssumm2 + poly(c2, 6, rsn);
                fac = std::sqrt((summ2 - two * a[0] * a[0] - two * a[1] * a[1])
                            / (one - two * a1 * a1 - two * a2 * a2));
                a[1] = a2;
            } else {
                i1 = 2;
                fac = std::sqrt((summ2 - two * a[0] * a[0]) / ( one  - two * a1 * a1));
            }
            a[0] = a1;
            for (i = i1; i <= nn2; ++i) a[i-1] /= - fac;
        }
        init = true;
    }
    if (n1 < 3) {
        ifault = 1;
        return;
    }
    ncens = n - n1;
    if (ncens < 0 || (ncens > 0 && n < 20)) {
        ifault = 4;
        return;
    }
    delta = (double) ncens / an;
    if (delta > 0.8) {
        ifault = 5;
        return;
    }

    /*  If W input as negative, calculate significance level of -W */
    if (w < zero) {
        w1 = 1. + w;
        ifault = 0;
        goto L70;
    }

    /*  Check for zero range */
    range = x[n1 - 1].second - x[0].second;
    if (range < small_value) {
        ifault = 6;
        return;
    }

    /*  Check for correct sort order on range - scaled X */

    /* *ifault = 7; <-- a no-op, since it is set 0, below, in ANY CASE! */
    ifault = 0;
    xx = x[0].second / range;
    sx = xx;
    sa = -a[0];
    j = n - 1;
    for (i = 2; i <= n1; ++i) {
        xi = x[i-1].second / range;
        if (xx - xi > small_value) {
            /* Fortran had:  print *, "ANYTHING"
            * but do NOT; it *does* happen with sorted x (on Intel GNU/linux):
            *  shapiro.test(c(-1.7, -1,-1,-.73,-.61,-.5,-.24, .45,.62,.81,1))
            */
            ifault = 7;
            return;
        }
        sx += xi;
        if (i != j) sa += sign(1,i - j) * a[std::min(i,j)-1];
        xx = xi;
        --j;
    }
    if (n > 5000) {
        ifault = 2;
    }

/*  Calculate W statistic as squared correlation
    between data and coefficients */

    sa /= n1;
    sx /= n1;
    ssa = ssx = sax = zero;
    j = n;
    for (i = 1; i <= n1; ++i, --j) {
        if (i != j)
            asa = sign(1,i - j) * a[std::min(i,j)-1] - sa;
        else
            asa = -sa;
        xsx = x[i-1].second / range - sx;
        ssa += asa * asa;
        ssx += xsx * xsx;
        sax += asa * xsx;
    }

/*  W1 equals (1-W) claculated to avoid excessive rounding error
    for W very near 1 (a potential problem in very large samples) */

    ssassx = std::sqrt(ssa * ssx);
    w1 = (ssassx - sax) * (ssassx + sax) / (ssa * ssx);
L70:
    w = 1. - w1;

/*  Calculate significance level for W */

    if (n == 3) {/* exact P value : */
        pw = pi6 * (std::asin(std::sqrt(w)) - stqr);
        return;
    }
    y = std::log(w1);
    xx = std::log(an);
    m = zero;
    s = one;
    if (n <= 11) {
        gamma = poly(g, 2, an);
        if (y >= gamma) {
            pw = small_value;/* FIXME: rather use an even small_valueer value, or NA ? */
            return;
        }
        y = -std::log(gamma - y);
        m = poly(c3, 4, an);
        s = std::exp(poly(c4, 4, an));
    } else {/* n >= 12 */
        m = poly(c5, 4, xx);
        s = std::exp(poly(c6, 3, xx));
    }
    /*DBG printf("c(w1=%g, w=%g, y=%g, m=%g, s=%g)\n",w1,*w,y,m,s); */

    if (ncens > 0) {/* <==>  n > n1 */
    /*  Censoring by proportion NCENS/N.
        Calculate mean and sd of normal equivalent deviate of W. */

        ld = -std::log(delta);
        bf = one + xx * bf1;
        r__1 = pow(xx90, (double) xx);
        z90f = z90 + bf * std::pow(poly(c7, 2, r__1), (double) ld);
        r__1 = pow(xx95, (double) xx);
        z95f = z95 + bf * std::pow(poly(c8, 2, r__1), (double) ld);
        z99f = z99 + bf * std::pow(poly(c9, 2, xx), (double)ld);

        /* Regress Z90F,...,Z99F on normal deviates Z90,...,Z99 to get
         * pseudo-mean and pseudo-sd of z as the slope and intercept
         */

        zfm = (z90f + z95f + z99f) / three;
        zsd = (z90 * (z90f - zfm) +
                    z95 * (z95f - zfm) + z99 * (z99f - zfm)) / zss;
        zbar = zfm - zsd * zm;
        m += zbar * s;
        s *= zsd;
    }
    pw = alnorm((y-m)/s, true);
    /*  = alnorm_(dble((Y - M)/S), 1); */

    // Results are returned in w, pw and ifault
    return;
} /* swilk */

double ms_shapiro_wilk::poly(const double *cc, int nord, double x)
{
    /* Auxiliary procedure in algorithm AS 181, Journal of the Royal
     * Statistical Society Series C (Applied Statistics) vol. 31, no. 2,
     * pp. 176-180 (1982).
     */

    /* Local variables */

    int n2,j;
    double ret_val = cc[0];
    if (nord == 1) return ret_val;
    double p = x * cc[nord-1];
    if (nord != 2) {
        n2 = nord - 2;
        j = n2 + 1;
        for (int i=1;i<=n2;i++) {
            p = (p + cc[j-1])*x;
            j--;
        }
    }
    ret_val = ret_val + p;
    return ret_val;
} /* poly */

double ms_shapiro_wilk::ppnd7(double p, int &ifault) {
    /* Algorithm AS 241, Journal of the Royal Statistical Society Series C
     * (Applied Statistics) vol. 26, no. 3, pp. 118-121 (1977).
     */

    static const double zero = 0.0;
    static const double one = 1.0;
    static const double half = 0.5;
    static const double split1 = 0.425;
    static const double split2 = 5.0;
    static const double const1 = 0.180625;
    static const double const2 = 1.6;
    static const double a0 = 3.3871327179E+00;
    static const double a1 = 5.0434271938E+01;
    static const double a2 = 1.5929113202E+02;
    static const double a3 = 5.9109374720E+01;
    static const double b1 = 1.7895169469E+01;
    static const double b2 = 7.8757757664E+01;
    static const double b3 = 6.7187563600E+01;
    static const double c0 = 1.4234372777E+00;
    static const double c1 = 2.7568153900E+00;
    static const double c2 = 1.3067284816E+00;
    static const double c3 = 1.7023821103E-01;
    static const double d1 = 7.3700164250E-01;
    static const double d2 = 1.2021132975E-01;
    static const double e0 = 6.6579051150E+00;
    static const double e1 = 3.0812263860E+00;
    static const double e2 = 4.2868294337E-01;
    static const double e3 = 1.7337203997E-02;
    static const double f1 = 2.4197894225E-01;
    static const double f2 = 1.2258202635E-02;

    double normal_dev;
    double q;
    double r;

    ifault = 0;
    q = p - half;
    if (std::abs(q) <= split1) {
        r = const1 - q * q;
        normal_dev = q * (((a3 * r + a2) * r + a1) * r + a0) /
                     (((b3 * r + b2) * r + b1) * r + one);
        return normal_dev;
    } else {
        if (q < zero) {
            r = p;
        } else {
            r = one - p;
        }
        if (r <= zero) {
            ifault = 1;
            normal_dev = zero;
            return normal_dev;
        }
        r = std::sqrt(-std::log(r));
        if (r <= split2) {
            r = r - const2;
            normal_dev = (((c3 * r + c2) * r + c1) * r + c0) / ((d2 * r + d1) * r + one);
        } else {
            r = r - split2;
            normal_dev = (((e3 * r + e2) * r + e1) * r + e0) / ((f2 * r + f1) * r + one);
        }
        if (q < zero) { normal_dev = - normal_dev; }
        return normal_dev;
    }
}

double ms_shapiro_wilk::alnorm(double x,bool upper) {
    /* Algorithm AS 66, Journal of the Royal Statistical Society Series C
     * (Applied Statistics) vol. 22, pp. 424-427 (1973).
     */

    static const double zero = 0;
    static const double one = 1;
    static const double half = 0.5;
    static const double con = 1.28;
    static const double ltone = 7.0;
    static const double utzero = 18.66;
    static const double p = 0.398942280444;
    static const double q = 0.39990348504;
    static const double r = 0.398942280385;
    static const double a1 = 5.75885480458;
    static const double a2 = 2.62433121679;
    static const double a3 = 5.92885724438;
    static const double b1 = -29.8213557807;
    static const double b2 = 48.6959930692;
    static const double c1 = -3.8052E-8;
    static const double c2 = 3.98064794E-4;
    static const double c3 = -0.151679116635;
    static const double c4 = 4.8385912808;
    static const double c5 = 0.742380924027;
    static const double c6 = 3.99019417011;
    static const double d1 = 1.00000615302;
    static const double d2 = 1.98615381364;
    static const double d3 = 5.29330324926;
    static const double d4 = -15.1508972451;
    static const double d5 = 30.789933034;

    double alnorm;
    double z;
    double y;
    bool up = upper;
    z = x;
    if (z < zero){
        up = !up;
        z = -z;
    }
    if (z <= ltone || (up && z <= utzero)) {
        y = half * z * z;
        if (z > con) {
            alnorm = r * std::exp(-y) / (z + c1 + d1 / (z + c2 + d2 / (z + c3 + d3
                    / (z + c4 + d4 / (z + c5 + d5 / (z + c6))))));
        } else {
            alnorm = half - z * (p - q * y/(y + a1 + b1 /(y + a2 + b2/(y + a3))));
        }
    } else {
        alnorm = zero;
    }

    if(!up) { alnorm = one - alnorm; }
    return alnorm;
}

long ms_shapiro_wilk::sign(long x,long y) {
    if (y<0)
        return -std::labs(x);
    else
        return std::labs(x);
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Examples for the Mascot Parser quantitation module
[Quantitation analysis for Mascot Server and Distiller]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
Testing peptides for quantifiability | tools_quant_helper.pl |  |  | tools_quant_helper.py | tools_quant_helper.cs
For using statistical routines | tools_stats.pl |  |  | tools_stats.py | tools_stats.cs
For calculating the Shapiro-Wilk W test | tools_shapiro_wilk.pl |  |  | tools_shapiro_wilk.py | tools_shapiro_wilk.cs
Extracting peptide ratios from a Reporter or Multiplex file | resfile_ms2quantitation.pl | - | resfile_ms2quantitation.java | resfile_ms2quantitation.py | resfile_ms2quantitation.cs
Converting ms_ms2quantitation to ms_customquantitation | resfile_ms2quant_to_custom.pl | - | - | resfile_ms2quant_to_custom.py | resfile_ms2quant_to_custom.cs
Basic usage of ms_customquantitation | resfile_customquantitation.pl | - | resfile_customquantitation.java | resfile_customquantitation.py | resfile_customquantitation.cs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_customquantitation
Public Member Functions | Protected Member Functions | Protected Attributes

ms_customquantitation Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings. More...

#include <ms_customquantitation.hpp>

Inheritance diagram for ms_customquantitation:
[legend]
Collaboration diagram for ms_customquantitation:
[legend]

List of all members.

Public Member Functions

ms_customquantitation (const ms_quant_method &qm)
Default constructor: given a quantitation method with protein ratio settings, prepare for data insertion.
ms_customquantitation (const ms_peptidesummary &initFrom)
Given a results file, initialise peptide-protein mappings and the quantitation method from it.
ms_customquantitation (const ms_ms2quantitation &copyFrom)
Given an ms_ms2quantitation object, copy the peptide-protein mappings, quantitation method and peptide ratios from it.
ms_customquantitation (const ms_peptidesummary &initFrom, const ms_quant_method &qm)
Given a results file, initialise peptide-protein mappings from it, and prepare for data insertion using the given quantitation method.
virtual | ~ms_customquantitation ()
Destructor.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
void | addPeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Associate a protein accession with a peptide quant key.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideRatio (const ms_peptide_quant_ratio &ratio)
Add a new peptide ratio.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearPeptideQuantKeys (const std::string &accession, int dbIdx)
Clear all peptide quant key associations for a given protein.
void | clearPeptideRatios ()
Remove all peptide ratios.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const
Given the protein accession, database ID and ratio name, return the protein ratio data.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const
Calculate the unnormalised average of selected peptide quant keys.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType) const
Calculate the unnormalised average peptide ratio.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const
Calculate the unnormalised average of peptide quant keys of a protein accession.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
void | removePeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Deassociate a peptide quant key from the given protein.
void | removePeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName)
Remove a particular peptide ratio.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)
Set the protein ratio type.
virtual void | setQuantOutliers (const ms_quant_outliers *)
Set new peptide ratio outlier settings.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t | proteinKeys_
Protein-to-peptide mapping.

Detailed Description

Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings.

ms_customquantitation provides full read and write access to peptide ratios and protein-peptide mappings.

Protein ratios are calculated using the same algorithm as in ms_ms2quantitation. There are three types of ratio: median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is the weighted geometric mean. The weighting factor of each peptide ratio must be specified when the peptide ratio is added to the class, and it can not depend on which protein the peptide ratio is associated with.

Note that the weighted ratio type is not the same as in ms_ms2quantitation, where the weights are derived automatically from the input query. In ms_customquantitation, any peptide ratio can have any user-specified weighting factor.

Choosing the right constructor reduces the amount of work you need to do. There are three general use cases:

  1. You have a Mascot results file with Reporter or Multiplex data, and would like to have more control over peptide ratios: create an ms_ms2quantitation object and use ms_customquantitation(const ms_ms2quantitation&).
  2. You have a Mascot results file and need to use peptide ratios from an external source, or need to calculate ratios manually: use ms_customquantitation(const ms_peptidesummary&, const char*) or ms_customquantitation(const ms_peptidesummary&, const ms_quant_method&).
  3. You don't have a Mascot results file, or you want to start completely from scratch: use ms_customquantitation(const ms_quant_method&).

(In the third case, the quantitation method need not correspond to any method defined in a Mascot Server installation.)

The three use cases are listed in order of increasing amount of work you need to do before getProteinRatio() returns useful values. There are two main steps: adding peptide ratios (addPeptideRatio()) and creating protein-peptide mappings (addPeptideQuantKeys()). Both steps are done for you in use case 1, only the second step is done for you in use case 2, and neither is done in use case 3.

The protein-related methods take two arguments to identify the protein: accession and database index. If your protein accessions come from a Mascot results file, use the database index returned by ms_protein::getDB() as database index.

If your data comes from somewhere else (e.g. an mzIdentML file), you can use any suitable integer for database index, as long as you are consistent with your choice. For example, if you know that all of your accessions are unique, you can simply use 0 as the database index.

ms_customquantitation supports normalisation, but it is less automatic than in ms_ms2quantitation. Normalisation settings in the quantitation method are ignored. Instead, you can set the normalisation factor of each ratio name with setPeptideRatioNormalisationBase(), with which peptide ratios associated with that ratio name are divided before returned by getPeptideRatio() or used in protein ratio calculation. To this end, you can use getUnnormalisedAveragePeptideRatio() to compute the mean or median of a given set of peptide ratios, peptide ratios associated with a protein hit, or all peptide ratios currently stored in the object.

Constructor & Destructor Documentation

ms_customquantitation ( const ms_quant_method & qm ) [explicit]

Default constructor: given a quantitation method with protein ratio settings, prepare for data insertion.

The quantitation method does not need to contain protocol settings, component definitions or peptide quality settings. (This is different from ms_ms2quantitation.) Only the following settings will be used by this class:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are defined, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Note that all normalisation settings are ignored, although the configuration is copied in the current quantitation method object. See setPeptideRatioNormalisationBase().

After the object has been created, you need to add peptide ratios and protein-peptide mappings before protein ratios can be calculated. See addPeptideRatio() and addPeptideQuantKey().

Using the Average protocol: If quantitation protocol is Average, neither outlier removal nor normalisation are supported. If either one is configured in the quantitation method object, the constructor will terminate with an error. Use isValid() after creating the object to check for an error condition.

Parameters:
qm Full or partial quantitation method describing how protein ratios are to be calculated.
ms_customquantitation ( const ms_peptidesummary & initFrom ) [explicit]

Given a results file, initialise peptide-protein mappings and the quantitation method from it.

This is done in two steps. First, the following quantitation method settings are loaded from the results file, if available:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are available in the results file, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Note that all normalisation settings are ignored, although the configuration is copied in the current quantitation method object. See setPeptideRatioNormalisationBase().

In the second step, the constructor iterates through all protein hits and creates a mapping from protein accessions to its peptide matches (peptide quant keys). After this, you need to add peptide ratios using addPeptideRatio(). Protein ratios can then be accessed with getProteinRatio().

Using the Average protocol: If quantitation protocol is Average, neither outlier removal nor normalisation are supported. If either one is configured in the embedded quantitation method object, the constructor will terminate with an error. Use isValid() after creating the object to check for an error condition.

Parameters:
initFrom Mascot results to initialise from. Before creating the ms_peptidesummary object from the ms_mascotresfile object, call ms_mascotresfile::setXMLschemaFilePath() to set the locations of the XML schema to validate the embedded quantitation XML file against.
ms_customquantitation | ( | const ms_peptidesummary & | initFrom,
 |  | const ms_quant_method & | qm
 | ) |  |

Given a results file, initialise peptide-protein mappings from it, and prepare for data insertion using the given quantitation method.

The quantitation method does not need to contain protocol settings, component definitions or peptide quality settings. (This is different from ms_ms2quantitation.) Only the following settings will be used by this class:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are defined, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Note that all normalisation settings are ignored. See setPeptideRatioNormalisationBase().

Note also that the protocol or component definitions of qm need not match those embedded in the results file, unlike in ms_ms2quantitation.

After initialising quantitation method settings, the constructor iterates through all protein hits and creates a mapping from protein accessions to its peptide matches (peptide quant keys). The peptide quant key for each peptide match is its q,p value; that is, the peptide quant keys are constructed with ms_peptide_quant_key(int q, int p).

You will need to add peptide ratios using addPeptideRatio(). Protein ratios can then be accessed with getProteinRatio().

Using the Average protocol: If quantitation protocol is Average, neither outlier removal nor normalisation are supported. If either one is configured in the quantitation method object, the constructor will terminate with an error. Use isValid() after creating the object to check for an error condition.

Parameters:
initFrom | Mascot results file to initialise peptide-protein mappings from.
qm | Full or partial quantitation method describing how protein ratios are to be calculated.
ms_customquantitation ( const ms_ms2quantitation & copyFrom ) [explicit]

Given an ms_ms2quantitation object, copy the peptide-protein mappings, quantitation method and peptide ratios from it.

The full quantitation method will be copied, although only the following values will be used by this class:

  • Protein ratio type, minimum number of peptides.
  • Protein ratio normalisation settings.
  • Outlier settings.

If none of these settings are defined, sensible defaults are used: ratio type "median", minimum number of peptides 1, no normalisation or outlier detection.

Two things are copied over from copyFrom: protein-peptide mappings for all toplevel protein accessions, and peptide ratios for all peptide quant keys associated with a protein hit. This means peptide ratios in the unassigned list will not be copied over. Copying is followed by setting peptide ratio normalisation to the correct values. You can access and change the values with getPeptideRatioNormalisationBase() and setPeptideRatioNormalisationBase() afterwards.

The peptide ratio and protein-peptide mapping peptide quant keys are constructed using ms_peptide_quant_key(int q, int p), and protein ratios are identified by the same accessions and database indices as in the source object.

The protein ratio type has one difference. Both classes implement median and average in the same way, but the weighted ratio type differs. If copyFrom contains Reporter data and specifies a weighted protein ratio, then protein ratio type is reset to median and the weights are not copied over. You can alter peptide ratio weighting factors later by overwriting the existing one with addPeptideRatio().

If copyFrom is not valid (ms_ms2quantitation::isValid() returns false), then no data importing will take place, and it is as if you called the parameterless constructor ms_customquantitation().

Parameters:
copyFrom Fully initialised ms_ms2quantitation object to copy data from.

Member Function Documentation

void addPeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |

Associate a protein accession with a peptide quant key.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

If key is already associated with this protein, no changes are made.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.
void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::vector< ms_peptide_quant_key > & | keys
 | ) |  |

Associate a protein accession with particular peptide quant keys.

Note:
This method can only be used from C++. Use addPeptideQuantKeys(std::string, int, const ms_peptide_quant_key_vector) from other programming languages instead.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.
void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  |

Associate a protein accession with particular peptide quant keys.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.
void addPeptideRatio ( const ms_peptide_quant_ratio & ratio )

Add a new peptide ratio.

If an existing peptide ratio exists with the same query, rank and ratio name as ratio.getQuery(), ratio.getRank() and ratio.getRatioName(), it will be replaced with the new data.

If ratio represents an undefined ("missing") value, the peptide ratio will be removed, as if you had called removePeptideRatio() instead.

Parameters:
ratio Peptide ratio to add.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.
ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void clearPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  |

Clear all peptide quant key associations for a given protein.

After this, getProteinRatio() will return a ratio with state isMissing() when given accession, dbIdx and any ratio name.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
void clearPeptideRatios ( )

Remove all peptide ratios.

This method also removes all q,p aliases of peptide ratios. However, the peptide-protein mapping will not be changed.

void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const [virtual, inherited]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.

Reimplemented in ms_ms1quantitation, and ms_ms2quantitation.

int countDistinctPeptides ( const ms_peptide_quant_key_vector & activeKeys ) const [virtual, inherited]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

This function just calls countDistinctPeptides(const ms_peptide_quant_key_vector &) (which should call the relevant ms_ms1quantitation or ms_ms2quantitation version.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getMinNumPeptides ( ) const [protected, inherited]

Get the minimum number of peptides needed for protein ratio calculation.

Returns:
The minimum number of peptides needed for protein ratio calculation.
ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const [inherited]

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
Returns:
A vector of peptide quant keys associated with the protein.
ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implements ms_quantitation.

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const [inherited]

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName Peptide ratio name.
Returns:
The current peptide ratio normalisation base, or 1 if it hasn't been set.
const matrix_science::ms_progress_info & getProgressInfo ( ) [inherited]

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns:
Progress information about the most recent long operation.
ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const [virtual]

Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.

The protein ratio is calculated as described in getProteinRatio(const std::string &, int, const std::string &) const, but the two peptide quant key vectors includeKeys and excludeKeys can be used to override default decisions about globally excluded and outlier peptide ratios. The rules are as follows:

  1. If a peptide quant key is globally excluded with setPeptideRatioExcluded(), then giving the peptide quant key in includeKeys causes the peptide quant key to be included regardless ("undo global exclusion").
  2. If a peptide quant key is given in excludeKeys, then the peptide quant key will be always excluded ("exclude locally").

If the peptide quant key is in both includeKeys and excludeKeys, the latter takes precedence and the peptide quant key is excluded.

Note that if outlier detection is enabled, then a peptide quant key determined to be an outlier cannot be included back using includeKeys, i.e. the inclusion mechanism does not undo outlier removal. You can disable outlier removal entirely before calling getProteinRatio() if you do not want peptide quant keys to be removed.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, then the effect of excludeKeys depends on whether the peptide quant key describes a "top N" peptide intensity. If the peptide intensity is one of the top N intensities assigned to this protein, then excluding it means the next highest outside the top N intensities will take its place. No peptide quant keys will ever be excluded automatically as outliers, since outlier removal has no meaning in this protocol.

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
includeKeys | Peptide quant keys to always include, even if they are globally excluded or would be marked as outliers.
excludeKeys | Peptide quant keys to always exclude, even if they are not outliers.
Returns:
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implements ms_quantitation.

Reimplemented in ms_ms1quantitation.

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Given the protein accession, database ID and ratio name, return the protein ratio data.

Protein ratios are calculated on demand from the current protein-peptide mapping using the current quantitation method and taking peptide exclusion into account. You can exclude peptides from protein ratio calculation by using setPeptideRatioExcluded(). The current outlier detection method may also change which peptide ratios are used for any given protein.

For ms_ms2quantitation, the protein-peptide mapping is immutable. There are three types of protein ratio, which can be changed with setProteinRatioType(): median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is a weighted mean of peptide ratios, where the weights are channel intensities. The weighted ratio type is only available for Reporter data.

For ms_customquantitation, you can change the protein-peptide mapping by associating different peptide quant keys with the protein accession; see ms_customquantitation::addPeptideQuantKey() for details. There are three types of protein ratio: median, average and weighted. Median and average are the same as in ms_ms2quantitation, except in the Average protocol (see below). Weighted is the weighted geometric mean, where the weighting factor of each peptide ratio must be specified when the peptide ratio is added to the class. This is not the same weighting as in ms_ms2quantitation.

ms1, ms2 and custom protein ratios are calculated using:

  • median - See ms_quant_stats::sortedMedian
  • average - See ms_quant_stats::geometricMean
  • weighted - See ms_quant_stats::weightedArithmeticMean

It is possible for the protein ratio to be undefined ("missing") even when it has associated peptide ratios, if there are not enough peptide ratios (setMinNumPeptides()), if all of them are marked excluded, or if too many of them are infinite.

If quantitation protocol is Reporter, Multiplex, Replicate or Precursor, the returned protein ratio object contains two p-values: the normality test value and the null hypothesis value.

The log-transformed peptide ratios are assumed normally distributed, and this hypothesis is tested using the Shapiro-Wilk W test. The normality p-value is -1 when the test could not be run (e.g. too few peptide ratios) and otherwise a positive number between 0 and 1. In the latter case, a value of less than 0.05 (or similar threshold) is usually taken as evidence that the log-transformed peptide ratios are not normally distributed, or equivalently that the peptide ratios are not log-normally distributed.

If outlier removal is configured, then outliers will be removed before normality testing. If this makes the normality p-value fall below 0.05, then the outliers will be restored. In this case the original sample was likely not normal to start with, and the normality p-value is calculated based on the original sample. If outlier removal is successful, then the normality p-value is based on the sample from which outliers have been removed, and it always exceeds 0.05.

The second p-value is for the null hypothesis. The null hypothesis is that the protein ratio equals 1.0 (component intensities have equal values). The p-value is -1 if there is only one peptide ratio, and otherwise a positive number between 0 and 1. The test is conducted after outlier removal, if any.

Note that the hypothesis test is done regardless of the p-value of the normality test. This means that you need to decide first if you accept peptide ratio normality before deciding whether to reject or not reject the null hypothesis. If normality is violated, then the hypothesis p-value is meaningless.

You can inspect which peptide quant keys were used in protein ratio calculation and which were ignored, due to being excluded or being outliers, with ms_protein_quant_ratio::getActiveKeys(), ms_protein_quant_ratio::getExcludedKeys() and ms_protein_quant_ratio::getOutlierKeys(). You can "move" peptide quant keys between the last two categories and the first by using the method getProteinRatio(const std::string &, int, const std::string &, const ms_peptide_quant_key_vector &, const ms_peptide_quant_key_vector &) const.

Note about weighted protein ratios: Parser 2.5 and 2.6 do not calculate the standard deviation, standard error or p-values when protein ratio type is weighted in Reporter data. The values are set to -1 ("unavailable"); see ms_protein_quant_ratio::getStandardDeviation(). The values are available in ms_customquantitation, which uses a different weighting formula.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average", which does not mean a geometric average. Rather, the protein ratio is the sum of the "top N" peptide intensities, divided by the sum of the top N peptide intensities of the reference protein (see ms_customquantitation::setAverageReferenceProtein()). Neither outlier removal nor normalisation have any meaning in this protocol, which means no significance tests are done and the returned protein ratio object will not contain any p-values.

For more details on configuring other aspects of protein ratio calculation, please consult the quantitation help pages.

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
Returns:
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implements ms_quantitation.

Reimplemented in ms_ms1quantitation.

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const [protected, inherited]

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.
const ms_quant_method & getQuantitationMethod ( ) const [inherited]

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns:
The current quantitation method.
void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const [protected, virtual]

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters:
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implements ms_quantitation.

double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType
 | ) |  | const

Calculate the unnormalised average peptide ratio.

All peptide ratios currently stored in the object are used in calculation. If there are no peptide ratios associated with the ratio name, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters:
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
Returns:
The average of all peptide ratios currently stored in the object, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.
double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  | const

Calculate the unnormalised average of selected peptide quant keys.

All peptide ratios matching ratioName and whose peptide quant key is in keys are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters:
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
keys | Peptide quant keys of peptide ratios to use in calculation.
Returns:
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.
double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const

Calculate the unnormalised average of peptide quant keys of a protein accession.

All peptide ratios matching ratioName and associated with the protein accession and database index are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored. You can alter the protein-peptide mapping with addPeptideQuantKey().

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters:
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
accession | Protein accession.
dbIdx | Protein database index.
Returns:
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.
bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio exists; false otherwise.

Implements ms_quantitation.

bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  | [protected, inherited]

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters:
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns:
True.
bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implements ms_quantitation.

bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void removePeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |

Deassociate a peptide quant key from the given protein.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.
void removePeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  |

Remove a particular peptide ratio.

However, the protein-peptide mapping related to the peptide quant key will not be changed.

Parameters:
key | Peptide quant key.
ratioName | Ratio name.
void removePeptideRatioNormalisationBase ( const std::string & ratioName ) [inherited]

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters:
ratioName Ratio name whose normalisation base is to be reset.
void removePeptideRatioNormalisationBases ( ) [inherited]

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

void setMinNumPeptides ( int value ) [inherited]

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters:
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.
void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [virtual]

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [virtual]

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  | [inherited]

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.
void setProteinRatioType ( const char * value ) [virtual]

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median".

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters:
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implements ms_quantitation.

void setQuantOutliers ( const ms_quant_outliers * qo ) [virtual]

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters:
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implements ms_quantitation.

The documentation for this class was generated from the following files:
  • ms_customquantitation.hpp
  • ms_customquantitation.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_data
Public Member Functions | Static Public Member Functions

ms_distiller_data Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Distiller project parameters. More...

#include <ms_distiller_data.hpp>

Inheritance diagram for ms_distiller_data:
[legend]
Collaboration diagram for ms_distiller_data:
[legend]

List of all members.

Public Member Functions

ms_distiller_data (const ms_distiller_data &copy)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_distiller_data *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual ms_mascotresults_params | get_ms_mascotresults_params (const int searchIndex) const
Return default flags and parameters for creating an ms_peptidesummary object.
virtual const ms_datfile & | getDatfile () const
Return the Mascot data file used for the project.
virtual std::string | getDistillerVersion () const
Return the version number of Distiller used to generate the distiller_data xml file.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
virtual const ms_fragrulesfile & | getFragRulesFile () const
Return the fragmentation rules file used for the project.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
virtual int | getLoadedSearchIndex () const
Return the index (index 1..getSearchCount) of the currently loaded search.
virtual const
ms_distiller_data_quant & 		getQuant (int index) const
Return the information the selected quantitation result (index 1..getQuantCount).
virtual int | getQuantCount () const
Return the number of quantitation results in the project.
virtual const
ms_distiller_data_quant * 		getQuantForSearch (const std::string &taskId) const
Return the information the quantitation result associated with the selected search.
virtual const ms_quant_method & | getQuantMethod () const
Return the quantitation method used for the project.
virtual const
ms_distiller_data_search & 		getSearch (int index) const
Return the information the selected search (index 1..getSearchCount).
virtual int | getSearchCount () const
Return the number of searches in the project.
bool | isValid () const
Call this function to determine if there have been any errors.
virtual bool | loadXml (const char *xmlSchemaPath, const std::string &xmlText)
Load Distiller data from the supplied XML text.
virtual bool | loadXmlFile (const char *xmlSchemaPath, const std::string &xmlFilename)
Load Distiller data from the XML in the named file.
virtual bool | loadXmlStream (const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream)
Load Distiller data from a stream.
const ms_distiller_data & | operator= (const ms_distiller_data &copy)

Static Public Member Functions

static std::string | getDistillerProjectStreamName ()
Return the name of the stream, within the project file, used for the Distiller project parameters.
static time_t | getDistillerResfileTimestamp ()
Return the 'standard' Distiller results file timestamp; 2010/1/1 00:00:00.
static std::vector< std::string > | getRequiredSchemaFileNames ()
Return a list of the filenames of the schema that will be required when loading ms_distiller_data.

Detailed Description

Distiller project parameters.

Stored in a Distiller project file (.rov) in the stream "rover_data".

Constructor & Destructor Documentation

ms_distiller_data ( const ms_distiller_data & copy )
Parameters:
copy is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_distiller_data * right )

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
matrix_science::ms_mascotresults_params get_ms_mascotresults_params ( const int searchIndex ) const [virtual]

Return default flags and parameters for creating an ms_peptidesummary object.

Parameters:
searchIndex The index number (1..n) of the search in the Distiller data.
Returns:
the values and flags required to pass to the peptide summary object.
const matrix_science::ms_datfile & getDatfile ( ) const [virtual]

Return the Mascot data file used for the project.

Returns:
The server configuration's ms_datfile.
std::string getDistillerProjectStreamName ( ) [static]

Return the name of the stream, within the project file, used for the Distiller project parameters.

Returns:
The name of the stream containing the Distiller project parameters.
time_t getDistillerResfileTimestamp ( ) [static]

Return the 'standard' Distiller results file timestamp; 2010/1/1 00:00:00.

The timestamp on the Distiller results file is used to determine the name of the subfolder that is used to hold the results file and peptide summary cache files. It is also stored in the results cache file to check if the results file and the cache can be used together.

Setting the last update timestamp on the results file to a fixed time means that the cache file location can be controlled and so the file re-used. This saves time when loading and can help prevent wasted disk space by duplicated files.

Returns:
The 'standard' time Distiller time; 2010/1/1 00:00:00.
std::string getDistillerVersion ( ) const [virtual]

Return the version number of Distiller used to generate the distiller_data xml file.

Returns:
The Distiller version number.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
const matrix_science::ms_fragrulesfile & getFragRulesFile ( ) const [virtual]

Return the fragmentation rules file used for the project.

Returns:
The server configuration's ms_fragrulesfile.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getLoadedSearchIndex ( ) const [virtual]

Return the index (index 1..getSearchCount) of the currently loaded search.

Returns:
The current search index, or zero if no search is currently selected.
const matrix_science::ms_distiller_data_quant & getQuant ( int index ) const [virtual]

Return the information the selected quantitation result (index 1..getQuantCount).

Parameters:
index An index (1..getQuantCount()) into the quantitation results int the project.
Returns:
The selected quantitation result.
int getQuantCount ( ) const [virtual]

Return the number of quantitation results in the project.

Returns:
The number of quantitation results in the project file.
const matrix_science::ms_distiller_data_quant * getQuantForSearch ( const std::string & taskId ) const [virtual]

Return the information the quantitation result associated with the selected search.

Parameters:
taskId The task identifier of the Mascot search.
Returns:
The search's quantitation result.
const matrix_science::ms_quant_method & getQuantMethod ( ) const [virtual]

Return the quantitation method used for the project.

Returns:
The quantitation method used.
std::vector< std::string > getRequiredSchemaFileNames ( ) [static]

Return a list of the filenames of the schema that will be required when loading ms_distiller_data.

This function can be used for checking that the required schema files are present before an error is raised.

Returns:
a list of the filenames of the schema that will be required when loading ms_distiller_data, ms_distiller_master_project and ms_distiller_search_status_list from xml / project files
const matrix_science::ms_distiller_data_search & getSearch ( int index ) const [virtual]

Return the information the selected search (index 1..getSearchCount).

Parameters:
index An index (1..getSearchCount()) into the search results int the project.
Returns:
The selected search.
int getSearchCount ( ) const [virtual]

Return the number of searches in the project.

Returns:
The number of searches in the project file.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool loadXml | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlText
 | ) |  | [virtual]

Load Distiller data from the supplied XML text.

Parameters:
xmlSchemaPath | The folder where the quantitation XML schema files (XSD) can be found.
xmlText | The XML data to load.
Returns:
True if the XML file was parsed and loaded successfully.
bool loadXmlFile | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlFilename
 | ) |  | [virtual]

Load Distiller data from the XML in the named file.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters:
xmlSchemaPath | The folder where the quantitation XML schema files (XSD) can be found.
xmlFilename | The path and filename of the XML file to load.
Returns:
True if the XML file was parsed and loaded successfully.
bool loadXmlStream | ( | const char * | xmlSchemaPath,
 |  | matrix_science::ms_input_string_stream * | xmlStream
 | ) |  | [virtual]

Load Distiller data from a stream.

Parameters:
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlStream | The stream interface offering the data.
Returns:
True if the data was parsed and loaded successfully.
const ms_distiller_data & operator= ( const ms_distiller_data & copy )
Parameters:
copy is the source to initialise from
Returns:
reference to the current object
The documentation for this class was generated from the following files:
  • ms_distiller_data.hpp
  • ms_distiller_data.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_data_quant
Public Member Functions

ms_distiller_data_quant Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The details of a Distiller search. More...

#include <ms_distiller_data_quant.hpp>

List of all members.

Public Member Functions

std::string | getCacheStreamName () const
Return the name of the stream, within the project file, used for the quantitation cache file.
std::string | getResultsStreamName () const
Return the name of the stream, within the project file, used for the quantitation results file.
int | getStreamNumber () const
Return the number of the stream, within the project file, used to generate both the quantitation results and cache filenames.
std::string | getTaskId () const
Return the task ID of the search used in the quantitation results.

Detailed Description

The details of a Distiller search.

A list of these is stored in XML in the Distiller project file.

Member Function Documentation

std::string getCacheStreamName ( ) const

Return the name of the stream, within the project file, used for the quantitation cache file.

Returns:
The name of the stream containing the quantitation cache data.
std::string getResultsStreamName ( ) const

Return the name of the stream, within the project file, used for the quantitation results file.

Returns:
The name of the stream containing the quantitation result data.
int getStreamNumber ( ) const

Return the number of the stream, within the project file, used to generate both the quantitation results and cache filenames.

Returns:
The number used to generate the stream names for the quantitation results and chache data.
std::string getTaskId ( ) const

Return the task ID of the search used in the quantitation results.

If there are multiple search result sets used in the quantitation then the task ID returned is that of the first search.

Returns:
The task ID of the search the quantitation resultswere created from.
The documentation for this class was generated from the following files:
  • ms_distiller_data_quant.hpp
  • ms_distiller_data_quant.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_data_search
Public Types | Public Member Functions

ms_distiller_data_search Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The details of a Distiller search. More...

#include <ms_distiller_data_search.hpp>

List of all members.

Public Types

enum eGrouping {
eGroupAuto = 0,
eGroupStandard = 1,
eGroupFamily = 2
}

Setting to control how proteins are grouped.

More...
enum eScoring {
eAuto = 0,
eMudpit = 1,
eStandard = 99999999
}

Determine whether to use MudPIT or standard (pre-Mascot 2.2) scoring.

More...
enum eSpectralLibrary {
eUnknown = -1,
eFASTA = 0,
eLibrary = 1,
eIntegrated = 2
}

For integrated FASTA and Spectral Library search, determines the default result display option.

More...

Public Member Functions

ms_distiller_data_search ()
Default constructor.
ms_distiller_data_search (const std::string &taskId, bool isLoaded, const std::string &cacheFileName, const std::string &quantMethodXml, const std::string &mascotServerURL, const std::string &mascotServerVersion, unsigned int flags, unsigned int flags2, bool requireBoldRed, bool showSameset, double showSubset, bool loadUnassigned, double significanceThreshold, eScoring scoring, int reporttop, bool errTolPeptide, eGrouping proteinGrouping, bool percolator, double scoreExpectCutOff, bool showSamesetFamily, bool showSubsetFamily, eSpectralLibrary libraryDisplayOption, bool percolatorUseProteins, bool percolatorUseRT, int minPepLenInPepSummary)
Constructor with all values.
std::string | getCacheFileName () const
Return the name of the cache file used by Parser.
bool | getErrTolPeptide () const
Return true if the peptide search used error tolerant matching.
bool | getLoaded () const
Returns true if the search data was currently loaded when the Distiller data was saved.
bool | getLoadUnassigned () const
Return true if the unassigned list should be loaded when opening the result.
std::string | getMascotSearchURL (const std::string &resultsFilePath) const
Return the URL for the search on the Mascot Server.
std::string | getMascotServerURL () const
The URL for the Mascot Server.
int | getMinPepLenInPepSummary () const
Return the minimum length of a peptide to be shown in a peptide summary.
unsigned int | getPeptideSummaryFlags () const
Return the default flags values to pass to the peptide summary constructor (as used in Distiller).
unsigned | getPeptideSummaryFlags2 () const
Return the default flags2 values to pass to the peptide summary constructor (as used in Distiller).
bool | getPercolator () const
Return true if the percolator is in use.
bool | getPercolatorUseProteins () const
Return true if percolator is set to set proteins for 'scoring'.
bool | getPercolatorUseRT () const
Return true if percolator will calculate and use retention times.
eGrouping | getProteinGrouping () const
Return the method of protein grouping that was used.
std::string | getQuantMethodXml () const
The XML text for the quantitation method, if any.
int | getReporttop () const
Return the number of protein hits to include in the results.
bool | getRequireBoldRed () const
Return true if bold, red font should be used.
double | getScoreExpectCutOff () const
Return the score cutoff threshold value.
eScoring | getScoring () const
Return the method of scoring that was used.
bool | getShowSamesets () const
Return true if same set matches should be shown for peptide and protein summary reports.
bool | getShowSamesetsFamily () const
Return true if same set matches should be shown for protein family summary reports.
double | getShowSubset () const
Return the threshold used to determine if a subset should be shown.
bool | getShowSubsetFamily () const
Return true if family subsets should be shown.
double | getSignificanceThreshold () const
Return the minimum probabilty threshold in use.
eSpectralLibrary | getSpectralLibraryDisplayOption () const
Returns the spectral library display option for the report.
std::string | getTaskId () const
The task ID of the Mascot search.
bool | serverVersionNewerOrSameAs (int major, int minor, int patch) const
Compare the version of the Mascot Server with the specified values.

Detailed Description

The details of a Distiller search.

A list of these is stored in XML in the rover_data file in the Distiller project file. The data comes from the relevant <MascotSearch> section inside the <mascotsearches> section. Call ms_distiller_data::getSearch to get an instance of this object

Member Enumeration Documentation

enum eGrouping

Setting to control how proteins are grouped.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
eGroupAuto

Grouping automatically determined when grouping begins, this value never appears in results.

eGroupStandard

Standard grouped protein list using parsimony / Occam’s razor.

eGroupFamily

Protein family grouping using Hierarchical Clustering.

enum eScoring

Determine whether to use MudPIT or standard (pre-Mascot 2.2) scoring.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
eAuto

Use MudPIT when the ratio of the number of spectra to the number of entries in the database is greater than the threshold.

eMudpit

Always use MudPIT.

eStandard

Never use MudPIT.

enum eSpectralLibrary

For integrated FASTA and Spectral Library search, determines the default result display option.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
eUnknown

Attribute was not set.

eFASTA

Display FASTA search results only.

eLibrary

Display spectral library results only.

eIntegrated

Display integrated results report.

Constructor & Destructor Documentation

ms_distiller_data_search | ( | const std::string & | taskId,
 |  | bool | isLoaded,
 |  | const std::string & | cacheFileName,
 |  | const std::string & | quantMethodXml,
 |  | const std::string & | mascotServerURL,
 |  | const std::string & | mascotServerVersion,
 |  | unsigned int | flags,
 |  | unsigned int | flags2,
 |  | bool | requireBoldRed,
 |  | bool | showSameset,
 |  | double | showSubset,
 |  | bool | loadUnassigned,
 |  | double | significanceThreshold,
 |  | eScoring | scoring,
 |  | int | reporttop,
 |  | bool | errTolPeptide,
 |  | eGrouping | proteinGrouping,
 |  | bool | percolator,
 |  | double | scoreExpectCutOff,
 |  | bool | showSamesetFamily,
 |  | bool | showSubsetFamily,
 |  | eSpectralLibrary | libraryDisplayOption,
 |  | bool | percolatorUseProteins,
 |  | bool | percolatorUseRT,
 |  | int | minPepLenInPepSummary
 | ) |  |

Constructor with all values.

Parameters:
taskId | comes from the TaskID attribute in the <MascotSearch> element
isLoaded | comes from the Loaded attribute in the <MascotSearch> element
cacheFileName | comes from the cacheFileName attribute in the <MascotSearch> element
quantMethodXml | comes from the quantMethod attribute in the <MascotImportOptions> element
mascotServerURL | comes from the URL attribute in the <Server> element for the 'Default' server in the <MascotServers> element
mascotServerVersion | comes from the Version attribute in the <Server> element for the 'Default' server in the <MascotServers> element
flags | are the ms_mascotresults::FLAGS that would be passed to a ms_peptidesummary constructor
flags2 | are the ms_peptidesummary::MSPEPSUM flags that would be passed to a ms_peptidesummary constructor
requireBoldRed | comes from the requireBoldRed attribute in the <blueOptions>
showSameset | comes from the showSameset attribute in the <blueOptions>
showSubset | comes from the showSubset attribute in the <blueOptions>
loadUnassigned | comes from the loadUnassignedList attribute in the <blueOptions>
significanceThreshold | comes from the significanceThresholdStr attribute in the <blueOptions>
scoring | comes from the scoringType attribute in the <blueOptions>
reporttop | comes from the reportTop attribute in the <blueOptions>
errTolPeptide | comes from the ErrTolPeptide attribute in the <blueOptions>
proteinGrouping | comes from the proteinGrouping attribute in the <blueOptions>
percolator | comes from the percolator attribute in the <blueOptions>
scoreExpectCutOff | comes from the ScoreExpectCutOff attribute in the <blueOptions>
showSamesetFamily | comes from the showSamesetFamily attribute in the <blueOptions>
showSubsetFamily | comes from the showSubsetFamily attribute in the <blueOptions>
libraryDisplayOption | comes from the spectralLibraryDisplayOption attribute in the <blueOptions>
percolatorUseProteins | comes from the percolatorUseProteins attribute in the <blueOptions>
percolatorUseRT | comes from the percolatorUseRT attribute in the <blueOptions>
minPepLenInPepSummary | comes from the minPepLenInPepSummary attribute in the <blueOptions>

Member Function Documentation

std::string getCacheFileName ( ) const

Return the name of the cache file used by Parser.

Default value: empty string

Obtained from the cacheFileName attribute in the <MascotSearch> element.

Returns:
The name of the cache file used by Parser.
bool getErrTolPeptide ( ) const

Return true if the peptide search used error tolerant matching.

Default value: false

Obtained from the ErrTolPeptide attribute in the <blueoptions> element.

Returns:
True if the peptide result was generated by an error tolerant Mascot search.
bool getLoaded ( ) const

Returns true if the search data was currently loaded when the Distiller data was saved.

Default value: false

Obtained from the Loaded attribute in the <MascotSearch> element.

Returns:
True if the search was loaded when the Distiller data was saved.
bool getLoadUnassigned ( ) const

Return true if the unassigned list should be loaded when opening the result.

Default value: false

Obtained from the loadUnassignedList attribute in the <blueoptions> element.

Returns:
True if the unassigned list should be loaded, false if not.
std::string getMascotSearchURL ( const std::string & resultsFilePath ) const

Return the URL for the search on the Mascot Server.

Default value: empty string

Built up on the fly from all the settings.

The URL will always specify master_results_2.pl rather than master_results.pl, even for a PMF

Parameters:
resultsFilePath is, for example: "../data/2018010/F0012345.dat"
Returns:
the URL for the search on the Mascot Server
int getMinPepLenInPepSummary ( ) const

Return the minimum length of a peptide to be shown in a peptide summary.

Default value: 5

Obtained from the minPepLenInPepSummary attribute in the <blueoptions> element which was added in Parser 2.7

Returns:
the minimum length of a peptide to be shown in a peptide summary
unsigned int getPeptideSummaryFlags ( ) const

Return the default flags values to pass to the peptide summary constructor (as used in Distiller).

The flags settings are a collection of values, bitwise or-ed together, from the FLAGS enumeration of ms_mascotresults.

Ideally, this function would call ms_mascotresfile::get_ms_mascotresults_params but we don't have a ms_mascotresfile object available.

Returns:
The peptide summary flags settings.
unsigned int getPeptideSummaryFlags2 ( ) const

Return the default flags2 values to pass to the peptide summary constructor (as used in Distiller).

The flags2 settings are a collection of values, bitwise or-ed together, from the MSPEPSUM enumeration of ms_peptidesummary.

Returns:
The peptide summary flags2 settings.
bool getPercolator ( ) const

Return true if the percolator is in use.

Default value: false

Obtained from the percolator attribute in the <blueoptions> element.

Returns:
True if percolator re-scoring was used.
bool getPercolatorUseProteins ( ) const

Return true if percolator is set to set proteins for 'scoring'.

Default value: false

Obtained from the percolatorUseProteins attribute in the <blueoptions> element which was added in Parser 2.7

Returns:
true if percolator is set to set proteins for 'scoring'
bool getPercolatorUseRT ( ) const

Return true if percolator will calculate and use retention times.

Default value: false

Obtained from the percolatorUseRT attribute in the <blueoptions> element which was added in Parser 2.7

Returns:
true if percolator will calculate and use retention times.
ms_distiller_data_search::eGrouping getProteinGrouping ( ) const

Return the method of protein grouping that was used.

Default value: ms_distiller_data_search::eGroupAuto

Obtained from the proteinGrouping attribute in the <blueoptions> element.

Returns:
The method of protein grouping that was used.
std::string getQuantMethodXml ( ) const

The XML text for the quantitation method, if any.

Default value: empty string

Obtained from the quantMethod attribute in the <MascotImportOptions> element.

This text can be loaded into a ms_quant_configfile using ms_quant_configfile::read_buffer().

Returns:
The XML text containing the quantitation method, if any.
int getReporttop ( ) const

Return the number of protein hits to include in the results.

Default value: 0

Obtained from the reportTop attribute in the <blueoptions> element.

Returns:
The number of protein hits to include in the results.
bool getRequireBoldRed ( ) const

Return true if bold, red font should be used.

Default value: false

Obtained from the requireBoldRed attribute in the <blueoptions> element.

Returns:
True if bold, red font should be used.
double getScoreExpectCutOff ( ) const

Return the score cutoff threshold value.

Default value: 0

Obtained from the ScoreExpectCutOff attribute in the <blueoptions> element.

Returns:
The score cutoff threshold value.
ms_distiller_data_search::eScoring getScoring ( ) const

Return the method of scoring that was used.

Default value: ms_distiller_data_search::eAuto

Obtained from the scoringType attribute in the <blueoptions> element.

Returns:
The method of scoring that was used.
bool getShowSamesets ( ) const

Return true if same set matches should be shown for peptide and protein summary reports.

Default value: true

Obtained from the showSameset attribute in the <blueoptions> element.

Returns:
True if same set protein matches should be displayed, false if not
bool getShowSamesetsFamily ( ) const

Return true if same set matches should be shown for protein family summary reports.

Default value: true

Obtained from the showSamesetFamily attribute in the <blueoptions> element.

Returns:
True if same set protein matches should be displayed, false if not
double getShowSubset ( ) const

Return the threshold used to determine if a subset should be shown.

Default value: 0

Obtained from the showSubset attribute in the <blueoptions> element. This value is base 64 eoncoded in the xml file.

Returns:
The threshold used to determine if a subset should be shown.
bool getShowSubsetFamily ( ) const

Return true if family subsets should be shown.

Default value: false

Obtained from the showSubsetFamily attribute in the <blueoptions> element.

Returns:
True if family subsets should be shown.
double getSignificanceThreshold ( ) const

Return the minimum probabilty threshold in use.

Default value:

Obtained from the significanceThreshold attribute in the <blueoptions> element which is a base 64 encoded value. If that isn't present, get the value from the significanceThresholdStr attribute.

Returns:
The minimum probability threshold setting.
ms_distiller_data_search::eSpectralLibrary getSpectralLibraryDisplayOption ( ) const

Returns the spectral library display option for the report.

Default value: ms_distiller_data_search::eUnknown

Obtained from the spectralLibraryDisplayOption attribute in the <blueoptions> element which was added in Parser 2.7.

The value in the XML should be one of: "fasta", "library" or "integrated".

Returns:
The spectral library results display option
std::string getTaskId ( ) const

The task ID of the Mascot search.

Default value: empty string

Obtained from the TaskID attribute in the <MascotSearch> element.

Returns:
The task ID of the Mascot search.
bool serverVersionNewerOrSameAs | ( | int | major,
 |  | int | minor,
 |  | int | patch
 | ) |  | const

Compare the version of the Mascot Server with the specified values.

Parameters:
major | is, for example 2 for version 2.5.1
minor | is, for example 5 for version 2.5.1
patch | is, for example 1 for version 2.5.1
Returns:
true if the version saved in this object is a newer version than the passed major and minor values passed
The documentation for this class was generated from the following files:
  • ms_distiller_data_search.hpp
  • ms_distiller_data_search.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_master_project
Public Member Functions | Static Public Member Functions

ms_distiller_master_project Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Data for a Distiller master project, includes a list of the subprojects. More...

#include <ms_distiller_master_project.hpp>

Inheritance diagram for ms_distiller_master_project:
[legend]
Collaboration diagram for ms_distiller_master_project:
[legend]

List of all members.

Public Member Functions

ms_distiller_master_project (const ms_distiller_master_project &src)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_distiller_master_project *right)
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
virtual int | getNumSearches () const
Return the number of searches in the master project.
virtual int | getNumSubprojects () const
Return the number of subprojects in the master project.
virtual const
ms_distiller_master_search & 		getSearch (int index) const
Return the selected search (index 1..n).
virtual const
ms_distiller_sub_project & 		getSubproject (int index) const
Return the selected subproject (index 1..n).
bool | isValid () const
Call this function to determine if there have been any errors.
virtual bool | loadXml (const char *xmlSchemaPath, std::string xmlText)
Load master project data from the supplied XML text.
virtual bool | loadXmlFile (const char *xmlSchemaPath, std::string xmlFilename)
Load master project data from the XML in the named file.
virtual bool | loadXmlStream (const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream)
Load master project data from a stream.
ms_distiller_master_project & | operator= (const ms_distiller_master_project &right)

Static Public Member Functions

static std::string | getMasterProjectStreamName ()
Return the name of the stream, within the project file, used for the master project list.

Detailed Description

Data for a Distiller master project, includes a list of the subprojects.

This is stored in XML in the 'rover_data+2' stream.

Constructor & Destructor Documentation

ms_distiller_master_project ( const ms_distiller_master_project & src )
Parameters:
src is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
void copyFrom ( const ms_distiller_master_project * right )
Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
std::string getMasterProjectStreamName ( ) [static]

Return the name of the stream, within the project file, used for the master project list.

Returns:
The name of the stream containing the master project data.
int getNumSearches ( ) const [virtual]

Return the number of searches in the master project.

Returns:
The number of searches in the master project.
int getNumSubprojects ( ) const [virtual]

Return the number of subprojects in the master project.

Returns:
The number of subprojects in the master project.
const matrix_science::ms_distiller_master_search & getSearch ( int index ) const [virtual]

Return the selected search (index 1..n).

Parameters:
index The search's index (1..getNumSearches()).
Returns:
The selected search.
const matrix_science::ms_distiller_sub_project & getSubproject ( int index ) const [virtual]

Return the selected subproject (index 1..n).

Parameters:
index The project's index (1..getNumSubprojects()).
Returns:
The selected project.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool loadXml | ( | const char * | xmlSchemaPath,
 |  | std::string | xmlText
 | ) |  | [virtual]

Load master project data from the supplied XML text.

Parameters:
xmlSchemaPath | The folder where the XML schema files (XSD) can be found.
xmlText | The XML data to load.
Returns:
True if the XML file was parsed and loaded successfully.
bool loadXmlFile | ( | const char * | xmlSchemaPath,
 |  | std::string | xmlFilename
 | ) |  | [virtual]

Load master project data from the XML in the named file.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters:
xmlSchemaPath | The folder where the XML schema files (XSD) can be found.
xmlFilename | The path and filename of the XML file to load.
Returns:
True if the XML file was parsed and loaded successfully.
bool loadXmlStream | ( | const char * | xmlSchemaPath,
 |  | matrix_science::ms_input_string_stream * | xmlStream
 | ) |  | [virtual]

Load master project data from a stream.

Parameters:
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlStream | The stream interface offering the data.
Returns:
True if the data was parsed and loaded successfully.
ms_distiller_master_project & operator= ( const ms_distiller_master_project & right )
Parameters:
right is the source to initialise from
Returns:
reference to the current object
The documentation for this class was generated from the following files:
  • ms_distiller_master_project.hpp
  • ms_distiller_master_project.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_master_search
Public Member Functions

ms_distiller_master_search Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The details of a Distiller multifile search. More...

#include <ms_distiller_master_search.hpp>

List of all members.

Public Member Functions

virtual std::string | getCacheFilename () const
Return the name of the cache file Distiller used.
virtual std::string | getCombinedPeptideSummaryCacheStreamName () const
Return the path and name of the peptide summary cache stream.
virtual int | getId () const
Return the identifier for the peptide summary cache stream in the master project file.
virtual int | getNumSubsearches () const
Return the number of subsearches in the master search.
virtual const
ms_distiller_subsearch & 		getSubsearch (int index) const
Return the selected search (index 1..n).

Detailed Description

The details of a Distiller multifile search.

A list of these is stored in XML in the Distiller master project file.

Member Function Documentation

std::string getCacheFilename ( ) const [virtual]

Return the name of the cache file Distiller used.

Returns:
The path and name of the file Distiller used to contain the peptide summary cache data.
std::string getCombinedPeptideSummaryCacheStreamName ( ) const [virtual]

Return the path and name of the peptide summary cache stream.

Returns:
The name of the stream containing the peptide summary cache data.
int getId ( ) const [virtual]

Return the identifier for the peptide summary cache stream in the master project file.

Returns:
The identifier for the peptide summary cache stream in the master project file.
int getNumSubsearches ( ) const [virtual]

Return the number of subsearches in the master search.

Returns:
The number of subsearches in the master search.
const matrix_science::ms_distiller_subsearch & getSubsearch ( int index ) const [virtual]

Return the selected search (index 1..n).

Parameters:
index The subsearch's index (1..getNumSubsearches()).
Returns:
The selected subsearch.
The documentation for this class was generated from the following files:
  • ms_distiller_master_search.hpp
  • ms_distiller_master_search.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_search_status
Public Member Functions

ms_distiller_search_status Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A Mascot search status from a Distiller project file. More...

#include <ms_distiller_search_status.hpp>

List of all members.

Public Member Functions

int | getError () const
Return the error message code, if any, received from the Mascot search.
int | getId () const
Return the id number used in the names of the results file stream and peptide summary cache stream.
std::string | getPeptideSummaryCacheStreamName () const
Return the name of the peptide summary cache stream.
std::string | getResfileStreamName () const
Return the name of the results file stream.
std::string | getResultsFile () const
Return the name on the Mascot server of the file containing the results.
std::string | getServer () const
Return the URL of the Mascot server.
std::string | getStatusMsg () const
Return the status message, if any, received from the Mascot search.
std::string | getSubmitTime () const
Return the time the search was submitted to the Mascot server.
std::string | getTaskId () const
Return the Mascot search task ID.
std::string | getTitle () const
Return the Mascot search title.

Detailed Description

A Mascot search status from a Distiller project file.

A list of these is stored in XML in the Distiller project file.

Member Function Documentation

int getError ( ) const

Return the error message code, if any, received from the Mascot search.

Returns:
The error code, if any, received from mascot server.
int getId ( ) const

Return the id number used in the names of the results file stream and peptide summary cache stream.

Returns:
The identifier for the search identifier within the Distiller project.
std::string getPeptideSummaryCacheStreamName ( ) const

Return the name of the peptide summary cache stream.

Returns:
The name of the stream containing the peptide summary data.
std::string getResfileStreamName ( ) const

Return the name of the results file stream.

Returns:
The name of the stream containing the results file data.
std::string getResultsFile ( ) const

Return the name on the Mascot server of the file containing the results.

Returns:
The name of the results file on the Mascot server.
std::string getServer ( ) const

Return the URL of the Mascot server.

Returns:
The URL of the Mascot server.
std::string getStatusMsg ( ) const

Return the status message, if any, received from the Mascot search.

Returns:
The text of the status message, if any, received from mascot server.
std::string getSubmitTime ( ) const

Return the time the search was submitted to the Mascot server.

Returns:
The time the search was submitted to the Mascot server.
std::string getTaskId ( ) const

Return the Mascot search task ID.

Returns:
The Mascot task identifier.
std::string getTitle ( ) const

Return the Mascot search title.

Returns:
The title of the Mascot search.
The documentation for this class was generated from the following files:
  • ms_distiller_search_status.hpp
  • ms_distiller_search_status.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_distiller_search_status_list
Public Member Functions | Static Public Member Functions

ms_distiller_search_status_list Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A list of Mascot search status values, typically stored in a Distiller project file. More...

#include <ms_distiller_search_status_list.hpp>

Inheritance diagram for ms_distiller_search_status_list:
[legend]
Collaboration diagram for ms_distiller_search_status_list:
[legend]

List of all members.

Public Member Functions

ms_distiller_search_status_list (const ms_distiller_search_status_list &src)
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_distiller_search_status_list *right)
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | getNumSearches () const
Return the number of searches in the search status list.
const ms_distiller_search_status & | getSearch (int index) const
Return the selected search status from the search status list.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadXml (const char *xmlSchemaPath, const std::string &xmlText)
Load the search status list from the supplied XML text.
bool | loadXmlFile (const char *xmlSchemaPath, const std::string &xmlFilename)
Load the search status list from the XML in the named file.
bool | loadXmlStream (const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream)
Load the search status list from a stream.
ms_distiller_search_status_list & | operator= (const ms_distiller_search_status_list &right)

Static Public Member Functions

static std::string | getSearchStatusListStreamName ()
Return the name of the stream, within the subproject file, used for the search list.

Detailed Description

A list of Mascot search status values, typically stored in a Distiller project file.

This is stored in XML in the 'mdro_search_status' stream.

Constructor & Destructor Documentation

ms_distiller_search_status_list ( const ms_distiller_search_status_list & src )
Parameters:
src is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_distiller_search_status_list * right )
Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getNumSearches ( ) const

Return the number of searches in the search status list.

Returns:
The number of search statuses in the list.
const matrix_science::ms_distiller_search_status & getSearch ( int index ) const

Return the selected search status from the search status list.

Parameters:
index The search status's index (1..getNumSearches()).
Returns:
The selected search status.
std::string getSearchStatusListStreamName ( ) [static]

Return the name of the stream, within the subproject file, used for the search list.

Returns:
The name of the stream containing the results list data.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool loadXml | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlText
 | ) |  |

Load the search status list from the supplied XML text.

Parameters:
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlText | The XML data to load.
Returns:
True if the XML file was parsed and loaded successfully.
bool loadXmlFile | ( | const char * | xmlSchemaPath,
 |  | const std::string & | xmlFilename
 | ) |  |

Load the search status list from the XML in the named file.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters:
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlFilename | The path and filename of the XML file to load.
Returns:
True if the XML file was parsed and loaded successfully.
bool loadXmlStream | ( | const char * | xmlSchemaPath,
 |  | matrix_science::ms_input_string_stream * | xmlStream
 | ) |  |

Load the search status list from a stream.

Parameters:
xmlSchemaPath | The path to the location of the XML schema (XSD) files.
xmlStream | The stream interface offering the data.
Returns:
True if the data was parsed and loaded successfully.
ms_distiller_search_status_list & operator= ( const ms_distiller_search_status_list & right )
Parameters:
right is the source to initialise from
Returns:
reference to the current object
The documentation for this class was generated from the following files:
  • ms_distiller_search_status_list.hpp
  • ms_distiller_search_status_list.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_distiller_sub_project
Public Member Functions | Static Public Member Functions

ms_distiller_sub_project Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The details of a Distiller multifile subproject. More...

#include <ms_distiller_sub_project.hpp>

List of all members.

Public Member Functions

virtual bool | getHavePeakList () const
Return true if the subproject has any peak lists.
virtual int | getId () const
Return the number, within the subproject file, used in the name of the search list stream.
virtual std::string | getName () const
Return the name of the subproject.
virtual std::string | getProjectRelativePath () const
Return the relative path and filename to the raw file in the subproject.
virtual std::string | getRawAbsolutePath () const
Return the absolute path and filename to the raw file in the subproject.
virtual int | getRawFormat () const
Return the format type of the raw files in the subproject.
virtual std::string | getRawRelativePath () const
Return the relative path and filename to the raw file in the subproject.
virtual int | getRawSampleNumber () const
Return the raw sample number of the subproject.
virtual std::string | getType () const
Return the type of data the subproject is created from.

Static Public Member Functions

static std::string | getResultsListStreamName ()
Return the name of the stream, within the subproject file, used for the search list.

Detailed Description

The details of a Distiller multifile subproject.

A list of these is stored in XML in the Distiller master project file.

Member Function Documentation

bool getHavePeakList ( ) const [virtual]

Return true if the subproject has any peak lists.

Returns:
True if the subproject has any peak lists.
int getId ( ) const [virtual]

Return the number, within the subproject file, used in the name of the search list stream.

Returns:
The number used in the name of the search list stream.
std::string getName ( ) const [virtual]

Return the name of the subproject.

Returns:
The name of the subproject.
std::string getProjectRelativePath ( ) const [virtual]

Return the relative path and filename to the raw file in the subproject.

Returns:
The relative path and filename to the raw file in the subproject.
std::string getRawAbsolutePath ( ) const [virtual]

Return the absolute path and filename to the raw file in the subproject.

Returns:
The absolute path and filename to the raw file in the subproject.
int getRawFormat ( ) const [virtual]

Return the format type of the raw files in the subproject.

Returns:
The format type of the raw files in the subproject.
std::string getRawRelativePath ( ) const [virtual]

Return the relative path and filename to the raw file in the subproject.

Returns:
The relative path and filename to the raw file in the subproject.
int getRawSampleNumber ( ) const [virtual]

Return the raw sample number of the subproject.

Returns:
The raw sample number of the subproject.
std::string getResultsListStreamName ( ) [static]

Return the name of the stream, within the subproject file, used for the search list.

Returns:
The name of the stream containing the results list data.
std::string getType ( ) const [virtual]

Return the type of data the subproject is created from.

Returns:
The type of data the subproject is created from, "project" or "raw".
The documentation for this class was generated from the following files:
  • ms_distiller_sub_project.hpp
  • ms_distiller_sub_project.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_distiller_subsearch
Public Member Functions

ms_distiller_subsearch Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The details of a Distiller multifile subsearch. More...

#include <ms_distiller_subsearch.hpp>

List of all members.

Public Member Functions

virtual std::string | getResultsFile () const
Return the name on the Mascot server of the file containing the results.
virtual std::string | getTaskId () const
Return the Mascot search task ID.
virtual std::string | getTitle () const
Return the Mascot search title.

Detailed Description

The details of a Distiller multifile subsearch.

A list of these is stored in XML in each search in the Distiller master project file.

Member Function Documentation

std::string getResultsFile ( ) const [virtual]

Return the name on the Mascot server of the file containing the results.

Returns:
The name of the results file on the Mascot server.
std::string getTaskId ( ) const [virtual]

Return the Mascot search task ID.

Returns:
The Mascot task identifier.
std::string getTitle ( ) const [virtual]

Return the Mascot search title.

Returns:
The title of the Mascot search.
The documentation for this class was generated from the following files:
  • ms_distiller_subsearch.hpp
  • ms_distiller_subsearch.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_fitexy_result
Public Member Functions

ms_fitexy_result Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Parameters and results from least squares fit with errors in both co-ordinates. More...

#include <ms_fitexy_result.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Member Functions

ms_fitexy_result ()
Default constructor.
double | getA () const
Get the a value.
double | getB () const
Get the b value.
double | getChi2 () const
Get the chi-squared value.
double | getQ () const
Get the chi squared probabilty. The larger the value, the better the fit.
double | getSigmaA () const
Get the a sigma.
double | getSigmaB () const
Get the b sigma.
double | getSigmaX () const
Get the x sigma.
double | getSigmaY () const
Get the y sigma.

Detailed Description

Parameters and results from least squares fit with errors in both co-ordinates.

Mascot Parser does not contain the code to calculate the fit. This class just returns the result of the fitting of a straight line: y = a + bx

The results are stored in XML in a "fitexy" entity.

Constructor & Destructor Documentation

ms_fitexy_result ( )

Default constructor.

Assigns reasonable default values to all internal members.

Member Function Documentation

double getA ( ) const

Get the a value.

The fitted line is y = a + bx

Returns:
The a value.
double getB ( ) const

Get the b value.

The fitted line is y = a + bx

Returns:
The b value.
double getChi2 ( ) const

Get the chi-squared value.

Returns:
The chi-squared value.
double getQ ( ) const

Get the chi squared probabilty. The larger the value, the better the fit.

The goodness of fit probability q that the fit would have getChi2() this large or larger

Returns:
The Q value.
double getSigmaA ( ) const

Get the a sigma.

The relative probable uncertanty of 'a'

Returns:
The a sigma.
double getSigmaB ( ) const

Get the b sigma.

The relative probable uncertanty of 'b'

Returns:
The b sigma.
double getSigmaX ( ) const

Get the x sigma.

The standard deviation of x data.

Returns:
The x sigma.
double getSigmaY ( ) const

Get the y sigma.

The standard deviation of y data.

Returns:
The y sigma.
The documentation for this class was generated from the following files:
  • ms_fitexy_result.hpp
  • ms_fitexy_result.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_ms1quant_average_results
Public Member Functions

ms_ms1quant_average_results Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Results specific to an 'average' type quantitation method. More...

#include <ms_ms1quant_average_results.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Member Functions

ms_ms1quant_average_results ()
Default constructor.
ms_ms1quant_average_results (const ms_ms1quant_average_results_body &body)
Populated constructor, linked to loaded data.
int | getReferenceHitId () const
The hit number of the selected reference protein.
int | getReferenceMemberNumber () const
The hit-family member number of the selected reference protein.
int | isReferenceUserSelected () const
The true if the user selected the reference.

Detailed Description

Results specific to an 'average' type quantitation method.

This is stored in a Distiller results XML in an "averageResult" entity.

This is stored in a Distiller results CDB file in an "AverageInfo" stream.

Constructor & Destructor Documentation

ms_ms1quant_average_results ( )

Default constructor.

The default hit identifier is -1.

ms_ms1quant_average_results ( const ms_ms1quant_average_results_body & body )

Populated constructor, linked to loaded data.

Parameters:
body The data loaded from the result file.

Member Function Documentation

int getReferenceHitId ( ) const

The hit number of the selected reference protein.

Returns:
The hit identifier of the reference protein.
int getReferenceMemberNumber ( ) const

The hit-family member number of the selected reference protein.

Returns:
The family member number of the reference protein.
int isReferenceUserSelected ( ) const

The true if the user selected the reference.

Returns:
True if the reference protein was selected by the user, false if it was selected automatically.
The documentation for this class was generated from the following files:
  • ms_ms1quant_average_results.hpp
  • ms_ms1quant_average_results.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quant_charge_state
Public Member Functions

ms_ms1quant_charge_state Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A result from a charge state calculation. More...

#include <ms_ms1quant_charge_state.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Member Functions

ms_ms1quant_charge_state ()
Default constructor.
ms_ms1quant_charge_state (const ms_ms1quant_charge_state_body &body)
Populated constructor.
bool | getBucket (int index, unsigned &scanId, double &area) const
Get a bucket scan number and intensity by its index (1..n).
double | getBucketWidth () const
Get the width of buckets used to collect peak area.
double | getCorrectedMaxSPPwidth () const
Get the maximum peak width used for final stage of peak detection.
double | getCorrectedMinSPPwidth () const
Get the minimum peak width used for final stage of peak detection.
double | getCorrectedSPPwidth () const
Get the expected peak width used for final stage of peak detection.
double | getMatchedFraction () const
Get the fitted peak area as a fraction of total peak area in XIC region. Value of 1.0 is perfect.
double | getMatchedRho () const
Get the correlation coefficient between calculated and experimental spectrum in XIC region. A value of 1.0 indicates a perfect fit.
double | getMaxAlignment () const
Get the offset required for optimum alignment of buckets with spectrum.
int | getNumberOfBuckets () const
Get the number of bucket scan areas.
double | getTotalIntensity () const
Get the peak area falling in all buckets summed over all scans in XIC peak.

Detailed Description

A result from a charge state calculation.

This is stored in XML in a "chargeStateData" entity.

Constructor & Destructor Documentation

ms_ms1quant_charge_state ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_ms1quant_charge_state ( const ms_ms1quant_charge_state_body & body )

Populated constructor.

Parameters:
body The data loaded from the result file.

Member Function Documentation

bool getBucket | ( | int | index,
 |  | unsigned & | scanId,
 |  | double & | area
 | ) |  | const

Get a bucket scan number and intensity by its index (1..n).

See Multiple return values in Perl, Java, Python and C#.

Peak area falling in a bucket for each scan in XIC peak.

Parameters:
[in] | index | The bucket scan identifier and area by its index (1..getNumberOfBuckets()).
[out] | scanId | Filled in with the scan identifier of the bucket.
[out] | area | Filled in with the area of the bucket.
Returns:
True if the index is in range and refers to a bucket.
double getBucketWidth ( ) const

Get the width of buckets used to collect peak area.

Returns:
The bucket width.
double getCorrectedMaxSPPwidth ( ) const

Get the maximum peak width used for final stage of peak detection.

Returns:
The corrected maximum SPP width.
double getCorrectedMinSPPwidth ( ) const

Get the minimum peak width used for final stage of peak detection.

Returns:
The corrected minimum SPP width.
double getCorrectedSPPwidth ( ) const

Get the expected peak width used for final stage of peak detection.

Returns:
The corrected SPP width.
double getMatchedFraction ( ) const

Get the fitted peak area as a fraction of total peak area in XIC region. Value of 1.0 is perfect.

Returns:
The matched fraction value.
double getMatchedRho ( ) const

Get the correlation coefficient between calculated and experimental spectrum in XIC region. A value of 1.0 indicates a perfect fit.

Returns:
The matched rho value.
double getMaxAlignment ( ) const

Get the offset required for optimum alignment of buckets with spectrum.

Returns:
The maximum alignment value.
int getNumberOfBuckets ( ) const

Get the number of bucket scan areas.

Returns:
The number of bucket scan areas.
double getTotalIntensity ( ) const

Get the peak area falling in all buckets summed over all scans in XIC peak.

Returns:
The total intensity.
The documentation for this class was generated from the following files:
  • ms_ms1quant_charge_state.hpp
  • ms_ms1quant_charge_state.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quant_match
Public Types | Public Member Functions | Static Public Member Functions

ms_ms1quant_match Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A peptide that has been matched, in quantitation, to a protein hit. More...

#include <ms_ms1quant_match.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Types

enum chargeType {
CHARGETYPE_ORIGINAL,
CHARGETYPE_ALL
}

Types of charge state used when matching.

More...

Public Member Functions

ms_ms1quant_match ()
Default constructor; for standard library collections.
ms_ms1quant_match (const ms_ms1quant_match_body &body)
Populated constructor, linked to loaded data.
ms_ms1quant_match_component * | addComponent (const matrix_science::ms_ms1quant_match_component &component)
Add a new component to the list. Must already have a component to base this one on.
ms_ms1quant_match_component * | addCreatedComponent (const std::string &componentName)
ms_ms1quant_match_component * | addCreatedComponent (const matrix_science::ms_ms1quant_match_component &component)
Add a new component to the list. Must already have a component to base this one on.
bool | allComponentsIdentified () const
Check if all the match components were identified by Mascot.
void | clearHitRatioExcluded (const std::string &ratioName, int hitId, int memberNumber)
Clear the match ratio from being excluded from a hit.
void | clearHitRatioOutlier (const std::string &ratioName, int hitId, int memberNumber)
Clear the match ratio from being an outlier for a hit.
int | getChargeState () const
Get the ion charge state.
ms_ms1quant_charge_state | getChargeStateData () const
Get the charge state data.
chargeType | getChargeType () const
Get whether this charge state has been extrapolated from the charge state of a Mascot match.
ms_ms1quant_match_component | getComponent (int index) const
Get a component associated with this match by its index (1..getNumComponents).
ms_ms1quant_match_component | getComponent (std::string componentName) const
Get a component of the matched peptide.
std::string | getConciseLabelFreeVarMods () const
Get the concise (un-numbered) readable variable modifications.
const ms_matrix & | getCorrectionMatrix () const
Get the correction matrix A, product of J (averagine) and I (impurity).
int | getDataSourceId () const
Get the data source identifier if processed independantly.
double | getDisplayIntensity () const
Get the total intensity of fitted peaks across the XIC peak.
int | getFirstXicScanId () const
Get the first scan of all the scans processed in the search for an XIC peak. Can be a wide region.
const ms_protein * | getHit (int index1) const
Get a protein hit associated with this match by its index (1..getNumHits).
matrix_science::ms_peptide_quant_key | getKey () const
Get a ms_peptide_quant_key code identifying the individual match.
std::string | getLabelFreeVarMods () const
Get the variable modification identifiers, with the labels removed.
int | getLastXicScanId () const
Get the last scan of all the scans processed in the search for an XIC peak. Can be a wide region..
int | getNumComponents () const
Get the number of components associated with this match.
int | getNumHits () const
Get the number of protein hits associated with this match.
int | getNumPeptideRatios () const
Get the number of peptide ratios associated with this match.
ms_ms1quant_match_ratio | getPeptideRatio (int index) const
Get a peptide ratio associated with this match by its index (0..getNumPeptideRatios-1).
ms_ms1quant_match_ratio | getPeptideRatio (const std::string &ratioName) const
Get a peptide ratio value for the ratio name.
std::string | getPeptideString () const
Get the peptide sequence in 1-letter code.
const ms_matrix & | getPerfectObservedMatrix () const
Get the predicted stick spectrum for measured amounts of each component.
const ms_matrix & | getPredictionMatrix () const
Get the predicted stick spectrum for equal amounts of each component.
std::string | getReadableLabelFreeVarMods () const
Get the readable variable modifications.
std::string | getVarMods () const
Get the variable modifications encoded as string of integers.
bool | hasComponent (std::string componentName) const
Returns true if the matched peptide has the component.
bool | hasIdentifiedComponent () const
Check if the match has any component that was identified by Mascot.
bool | hasPeptideRatio (const std::string &ratioName) const
Returns true if the match has a peptide ratio value for the ratio name.
bool | isHitRatioExcluded (const std::string &ratioName, int hitId, int memberNumber) const
Returns true if the match ratio is excluded from a hit.
bool | isHitRatioOutlier (const std::string &ratioName, int hitId, int memberNumber) const
Returns true if the match ratio is an outlier for a hit.
bool | isHitRatioUsedForAverage (const std::string &ratioName, int hitId, int memberNumber) const
Returns true if the match ratio is used in the average quantitation protocol for a hit.
bool | removeComponent (const std::string &componentName)
Primarily for replicate where we want to remove components that are found in other files.
void | setHitRatioExcluded (const std::string &ratioName, int hitId, int memberNumber)
Set the match ratio to be excluded from a hit.
void | setHitRatioOutlier (const std::string &ratioName, int hitId, int memberNumber)
Set the match ratio to be an outlier for a hit.

Static Public Member Functions

static chargeType | getCodeFromXml (std::string text)
Get the charge type code for an XML attribute value.
static std::string | getXmlCode (chargeType code)
Get the XML attribute value for a charge type code.

Detailed Description

A peptide that has been matched, in quantitation, to a protein hit.

Each protein can be matched to a number of peptides. The quantitation ratios of these peptides are used to determine the quantitaion ratio of the protein.

A peptide match can have a number of labelled components (such as 'heavy' and 'light') that are determined by the modifications.

This is stored in XML in a "peptideMatch" entity.

Member Enumeration Documentation

enum chargeType

Types of charge state used when matching.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
CHARGETYPE_ORIGINAL

Charge state found in result file.

CHARGETYPE_ALL

Match created in all charge states.

Constructor & Destructor Documentation

ms_ms1quant_match ( )

Default constructor; for standard library collections.

Assigns reasonable default values to all internal members.

ms_ms1quant_match ( const ms_ms1quant_match_body & body )

Populated constructor, linked to loaded data.

Parameters:
body The data loaded from the result file.

Member Function Documentation

ms_ms1quant_match_component * addComponent ( const matrix_science::ms_ms1quant_match_component & component )

Add a new component to the list. Must already have a component to base this one on.

Primarily for replicate. Take the first component for this match, make a copy of it and add it to the match, leving the it's origin unaltered

Parameters:
component is the new component to be added
Returns:
a pointer to the newly created component
ms_ms1quant_match_component * addCreatedComponent ( const matrix_science::ms_ms1quant_match_component & component )

Add a new component to the list. Must already have a component to base this one on.

Primarily for replicate. Take the first component for this match, make a copy of it and add it to the match, and set it's origin to be 'created'

Parameters:
component is the new component to be added
Returns:
a pointer to the newly created component
ms_ms1quant_match_component * addCreatedComponent ( const std::string & componentName )

Primarily for replicate. Take the first component for this match, make a copy of it and add it to the match

Parameters:
componentName is the name of the new component to be added
Returns:
a pointer to the newly created component
bool allComponentsIdentified ( ) const

Check if all the match components were identified by Mascot.

Tests to see if all the components were identified by Mascot. This method can return false event if hasIdentifiedComponent() returns true, as that method only requires one of the components to have been identified

See also:
hasIdentifiedComponent()
Returns:
True if all the components were identified by Mascot matches, false if not
void clearHitRatioExcluded | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Clear the match ratio from being excluded from a hit.

Clears any excluded status for the match in the specified protein ratio.

See also:
setHitRatioExcluded()
Parameters:
ratioName | The name of the ratio.
hitId | One based protein hit number.
memberNumber | One based family member number.
void clearHitRatioOutlier | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Clear the match ratio from being an outlier for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters:
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
int getChargeState ( ) const

Get the ion charge state.

Returns:
The ion charge state.
matrix_science::ms_ms1quant_charge_state getChargeStateData ( ) const

Get the charge state data.

Returns:
The charge state data.
ms_ms1quant_match::chargeType getChargeType ( ) const

Get whether this charge state has been extrapolated from the charge state of a Mascot match.

Returns:
CHARGETYPE_ORIGINAL if this charge state was found in the result file, otherwise CHARGETYPE_ALL as it has been extrapolated from the charge state of a Mascot match.
ms_ms1quant_match::chargeType getCodeFromXml ( std::string text ) [static]

Get the charge type code for an XML attribute value.

Parameters:
text The string used to encode the charge type in the XML file.
Returns:
The charge type corresponding to the XML encoded string.
ms_ms1quant_match_component getComponent ( int index ) const

Get a component associated with this match by its index (1..getNumComponents).

Parameters:
index An index (1..getNumComponents()) into the components associated with the peptide match.
Returns:
The component.
ms_ms1quant_match_component getComponent ( std::string componentName ) const

Get a component of the matched peptide.

Parameters:
componentName The name of component to be retrieved, e.g. "Heavy".
Returns:
The component.
std::string getConciseLabelFreeVarMods ( ) const

Get the concise (un-numbered) readable variable modifications.

For example: "Dimethyl (KR); Acetyl (K); Methyl (KR)".

Returns:
A semi-colon separated text string.
const matrix_science::ms_matrix & getCorrectionMatrix ( ) const

Get the correction matrix A, product of J (averagine) and I (impurity).

Returns:
The correction matrix
int getDataSourceId ( ) const

Get the data source identifier if processed independantly.

Returns:
The data source identifier, if processed independantly.
double getDisplayIntensity ( ) const

Get the total intensity of fitted peaks across the XIC peak.

Returns:
The total intensity of fitted peaks across the XIC peak.
int getFirstXicScanId ( ) const

Get the first scan of all the scans processed in the search for an XIC peak. Can be a wide region.

Returns:
The identifier of the first scan of all the scans processed in the search for an XIC peak. Can be a wide region.
const matrix_science::ms_protein * getHit ( int index1 ) const

Get a protein hit associated with this match by its index (1..getNumHits).

Parameters:
index1 An index (1..getNumHits()) into the protein hits associated with the peptide match.
Returns:
A protein hit, or null if the index is out of range.
matrix_science::ms_peptide_quant_key getKey ( ) const

Get a ms_peptide_quant_key code identifying the individual match.

Returns:
The identifier for the match within the quantitation results.
std::string getLabelFreeVarMods ( ) const

Get the variable modification identifiers, with the labels removed.

For example: "00000100000043000009a2000".

Returns:
A string of letters representing the modifications.
int getLastXicScanId ( ) const

Get the last scan of all the scans processed in the search for an XIC peak. Can be a wide region..

Returns:
The identifier of the last scan of all the scans processed in the search for an XIC peak. Can be a wide region.
int getNumComponents ( ) const

Get the number of components associated with this match.

Returns:
The number of components associated with the match.
int getNumHits ( ) const

Get the number of protein hits associated with this match.

Not all peptide matches are associated with every protein. This returns the number of proteins that are matched to this particular peptide and is typically less than the number of proteins in the peptide summary.

Returns:
The number of protein hits associated with the match.
int getNumPeptideRatios ( ) const

Get the number of peptide ratios associated with this match.

Returns:
The number of peptide ratios associated with the match.
matrix_science::ms_ms1quant_match_ratio getPeptideRatio ( int index ) const

Get a peptide ratio associated with this match by its index (0..getNumPeptideRatios-1).

Parameters:
index An index (0..getNumPeptideRatios()-1) into the peptide ratios associated with the match.
Returns:
The peptide ratio.
matrix_science::ms_ms1quant_match_ratio getPeptideRatio ( const std::string & ratioName ) const

Get a peptide ratio value for the ratio name.

Peptide ratio data that is independent of the assigned protein hit. To find out whether a match has been accepted or rejected under a particular protein hit, need to look under isHitRatioExcluded().

Parameters:
ratioName The name of ratio to be searched for, e.g. "H/L".
Returns:
The peptide match.
std::string getPeptideString ( ) const

Get the peptide sequence in 1-letter code.

Returns:
The peptide sequence as a series of 1-letter codes.
const matrix_science::ms_matrix & getPerfectObservedMatrix ( ) const

Get the predicted stick spectrum for measured amounts of each component.

Returns:
The perfect observed matrix.
const matrix_science::ms_matrix & getPredictionMatrix ( ) const

Get the predicted stick spectrum for equal amounts of each component.

Returns:
The prediction matrix
std::string getReadableLabelFreeVarMods ( ) const

Get the readable variable modifications.

For example: "(1) Dimethyl (KR); (6) Acetyl (K); (9) Methyl (KR)".

Returns:
A semi-colon separated text string.
std::string getVarMods ( ) const

Get the variable modifications encoded as string of integers.

Returns:
The variable modifications encoded as string of integers.
std::string getXmlCode ( ms_ms1quant_match::chargeType code ) [static]

Get the XML attribute value for a charge type code.

Some of the returned values include a substitution string of "%s" or "%d". These are replaced with a specific value in the created XML.

Parameters:
code The charge type to get the XML excoding string for.
Returns:
The string used to encode the charge type in the XML file.
bool hasComponent ( std::string componentName ) const

Returns true if the matched peptide has the component.

Parameters:
componentName The name of component to be searched for, e.g. "Heavy".
Returns:
True if the match has the component.
bool hasIdentifiedComponent ( ) const

Check if the match has any component that was identified by Mascot.

Returns:
True if any component of the match has been identified.
bool hasPeptideRatio ( const std::string & ratioName ) const

Returns true if the match has a peptide ratio value for the ratio name.

Parameters:
ratioName The name of ratio to be searched for, e.g. "H/L".
Returns:
True if the ratio exists for the peptide match.
bool isHitRatioExcluded | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Returns true if the match ratio is excluded from a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters:
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
Returns:
True if the match ratio is excluded from this hit.
bool isHitRatioOutlier | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Returns true if the match ratio is an outlier for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters:
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
Returns:
True if the match ratio is an outlier for the hit.
bool isHitRatioUsedForAverage | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Returns true if the match ratio is used in the average quantitation protocol for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters:
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
Returns:
True if the match ratio is used in the average protocol for this hit.
bool removeComponent ( const std::string & componentName )

Primarily for replicate where we want to remove components that are found in other files.

Parameters:
componentName is the name of the new component to be added
Returns:
true if the component was removed
void setHitRatioExcluded | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Set the match ratio to be excluded from a hit.

Data for a protein hit to which the peptide match is assigned.

See also:
clearHitRatioExcluded()
Parameters:
ratioName | The name of the ratio.
hitId | One based protein hit number.
memberNumber | One based family member number.
void setHitRatioOutlier | ( | const std::string & | ratioName,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  |

Set the match ratio to be an outlier for a hit.

Data for a protein hit to which the peptide match is assigned.

Parameters:
ratioName | The name of the ratio.
hitId | Protein hit number.
memberNumber | Family member number.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match.hpp
  • ms_ms1quant_match.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quant_match_component
Public Member Functions

ms_ms1quant_match_component Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A component within a match. More...

#include <ms_ms1quant_match_component.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Member Functions

ms_ms1quant_match_component ()
Default constructor.
ms_ms1quant_match_component (const ms_ms1quant_match_component_body &body)
Populated constructor.
double | getAbsoluteValue () const
Get the summed intensity values for this component across the XIC peak. Required for normalisation.
std::string | getComponent () const
Get the component.
double | getMoverz () const
Get the m/z value.
int | getNumPeptides () const
Get the number of related peptides.
int | getNumRanges () const
Get the number of ranges.
void | getPeptideKey (int index, int &q, int &p) const
Get a related peptide's feature key by its index (1..n).
ms_ms1quant_match_range | getRange (int index) const
Get a range value by its index (1..n).
double | getRelativeMass () const
Get the relative mass value.
std::string | getSummedModsStr () const
Returns the string for any 'summed' modifications for this particular match.
std::string | getVarModsStr () const
Returns the string for any 'variable' modifications for this particular match.
ms_xic | getXic () const
Get the extracted ion chromatogram (XIC).
bool | hasAbsoluteValue () const
Check if the absolute value is available.
bool | isComponentIdentified () const
Check if the component has been identified.

Detailed Description

A component within a match.

This is stored in XML in "partner" and "absoluteValue" entities.

Constructor & Destructor Documentation

ms_ms1quant_match_component ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_ms1quant_match_component ( const ms_ms1quant_match_component_body & body )

Populated constructor.

Parameters:
body The data loaded from the result file.

Member Function Documentation

double getAbsoluteValue ( ) const

Get the summed intensity values for this component across the XIC peak. Required for normalisation.

If ratio values not are absolute use total intensity as absolute value

Returns:
The absolute ratio value.
std::string getComponent ( ) const

Get the component.

Returns:
The name of the component (e.g. "Heavy").
double getMoverz ( ) const

Get the m/z value.

Returns:
The m/z value.
int getNumPeptides ( ) const

Get the number of related peptides.

Returns:
The number of related peptides.
int getNumRanges ( ) const

Get the number of ranges.

Returns:
The number of ranges.
void getPeptideKey | ( | int | index,
 |  | int & | q,
 |  | int & | p
 | ) |  | const

Get a related peptide's feature key by its index (1..n).

See Multiple return values in Perl, Java, Python and C#.

The returned keys can be used to get the ms_peptide using ms_mascotresults::getPeptide().

Parameters:
index | The index of the required peptide (1..getNumPeptides()).
q | The query number.
p | The rank.
matrix_science::ms_ms1quant_match_range getRange ( int index ) const

Get a range value by its index (1..n).

Parameters:
index The index of the required range (1..getNumRanges()).
Returns:
The ms_ms1quant_match_range.
double getRelativeMass ( ) const

Get the relative mass value.

Returns:
The relative mass value.
std::string getSummedModsStr ( ) const

Returns the string for any 'summed' modifications for this particular match.

See ms_peptide::getSummedModsStr for details of the format

Returns:
the encoded summed mods string
std::string getVarModsStr ( ) const

Returns the string for any 'variable' modifications for this particular match.

See ms_peptide::getVarModsStr for details of the format

Returns:
the encoded variable mods string
matrix_science::ms_xic getXic ( ) const

Get the extracted ion chromatogram (XIC).

Returns:
The ms_xic.
bool hasAbsoluteValue ( ) const

Check if the absolute value is available.

Returns:
True if the absolute value is available (some older datasets may not hold the value).
bool isComponentIdentified ( ) const

Check if the component has been identified.

Returns:
True if the component has been identified.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match_component.hpp
  • ms_ms1quant_match_component.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quant_match_range
Public Member Functions

ms_ms1quant_match_range Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A range for a component of a peptide match. More...

#include <ms_ms1quant_match_range.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Member Functions

ms_ms1quant_match_range ()
Default constructor.
ms_ms1quant_match_range (const ms_ms1quant_match_range_body &body)
Construct a populated ms_ms1quant_match_range.
ms_ms1quant_match_range (int scanId, double rt)
Construct a range including a single scan.
void | extend (int scanId, double rt)
Extend the range.
void | getRt (double &start, double &end) const
Get the retention times for the first and last scans.
void | getScan (int &start, int &end) const
Get the scan numbers for the first and last scans.

Detailed Description

A range for a component of a peptide match.

This is stored in XML in a "range" entity.

Constructor & Destructor Documentation

ms_ms1quant_match_range ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_ms1quant_match_range ( const ms_ms1quant_match_range_body & body )

Construct a populated ms_ms1quant_match_range.

Parameters:
body The data loaded from the result file.

Member Function Documentation

void getRt | ( | double & | start,
 |  | double & | end
 | ) |  | const

Get the retention times for the first and last scans.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | start | Filled in with the retention time of the start of the range.
[out] | end | Filled in with the retention time of the end of the range.
void getScan | ( | int & | start,
 |  | int & | end
 | ) |  | const

Get the scan numbers for the first and last scans.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | start | Filled in with the first scan identifier in the range.
[out] | end | Filled in with the last scan identifier in the range.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match_range.hpp
  • ms_ms1quant_match_range.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quant_match_ratio
Public Types | Public Member Functions | Static Public Member Functions

ms_ms1quant_match_ratio Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The status resulting ratio for a peptide found in a match. More...

#include <ms_ms1quant_match_ratio.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Types

enum ratioStatusCode {
RS_EMPTY = 0,
RS_OK = 1,
RS_ISOLATEDPRECURSORFAILED = 2,
RS_INTEFERENCEFAILED = 4,
RS_NODATA = 8,
RS_FITEXYSIGMA = 16,
RS_NEGATIVERATIO = 32,
RS_INFINITERATIO = 64,
RS_ZERORATIO = 128,
RS_DO_NOT_USE = 256,
RS_TOTALINTENSITYFAILED = 512
}

Status codes from fitting ratios.

More...

Public Member Functions

ms_ms1quant_match_ratio ()
Default constructor.
ms_ms1quant_match_ratio (const ms_ms1quant_match_ratio_body &body)
Populated constructor, linked to loaded data.
bool | getFitexy (ms_fitexy_result &value) const
Get the fitexy value. Returns true if a fitexy value is set.
double | getQuality () const
Get the quality of the match.
std::string | getRatioName () const
Returns the ratio name.
int | getStatus () const
Get the status composite value.
std::vector< ratioStatusCode > | getStatusList () const
Get the status values. Each status in the list is a single bit.
double | getValue () const
Return the numerical value of the ratio.
bool | isIncluded () const
Returns true if the item should be included in calculations.
bool | isSet () const
Returns true if the item has a value set.
bool | isUsedForAverage () const
Returns true if the item is used in the average protocol for quantitation.
bool | isValid () const
Returns true if the item has a valid value.

Static Public Member Functions

static ratioStatusCode | getCodeFromXml (std::string text)
Get the status code for an XML attribute value.
static bool | getCodeInfo (ratioStatusCode code, const ms_quant_method &method, double &info)
Return true if the status is associated with further information.
static std::string | getXmlCode (ratioStatusCode code)
Get the XML attribute value for a status code.

Detailed Description

The status resulting ratio for a peptide found in a match.

This is stored in XML in a "originalRatio" entity.

Member Enumeration Documentation

enum ratioStatusCode

Status codes from fitting ratios.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Note that RS_FITEXYSIGMA maps to "StdErrAboveTreshold" which has always been misspelt.

The "XML text" is returned by matrix_science::ms_ms1quant_match_ratio::getXmlCode

The statuses get set by matrix_science::ms_ms1quant_match::applyThresholds()

Enumerator:
RS_EMPTY

XML text: "". No status set.

RS_OK

XML text: "ok". OK.

RS_ISOLATEDPRECURSORFAILED

XML text: "AreaFractionBelowThreshold". Isolated precursor failed [extra information is option value 'isolated precursor threshold'].

RS_INTEFERENCEFAILED

XML text: "PeakCorrBelowThreshold". Inteference failed [extra information is option value 'matched rho'].

RS_NODATA

XML text: "RatioUndefined". No data.

RS_FITEXYSIGMA

XML text: "StdErrAboveTreshold". fitexy sigma [extra information is option value 'elution profile correlation threshold'].

RS_NEGATIVERATIO

XML text: "NegativeRatio". Negative ratio.

RS_INFINITERATIO

XML text: "InfiniteRatio". Infinite ratio.

RS_ZERORATIO

XML text: "ZeroRatio". Zero ratio.

RS_DO_NOT_USE

XML text: "". Do not use (outlier)

RS_TOTALINTENSITYFAILED

XML text: "TotalIntensityBelowThreshold" Total intensity failed [extra information is option value 'total intensity threshold'].

Constructor & Destructor Documentation

ms_ms1quant_match_ratio ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_ms1quant_match_ratio ( const ms_ms1quant_match_ratio_body & body )

Populated constructor, linked to loaded data.

Parameters:
body The data loaded from the result file.

Member Function Documentation

matrix_science::ms_ms1quant_match_ratio::ratioStatusCode getCodeFromXml ( std::string text ) [static]

Get the status code for an XML attribute value.

Parameters:
text The string used to encode the ratio status in the XML file.
Returns:
The ratio status corresponding to the XML encoded string.
bool getCodeInfo | ( | ratioStatusCode | code,
 |  | const ms_quant_method & | method,
 |  | double & | info
 | ) |  | [static]

Return true if the status is associated with further information.

Four status codes have further information associated with them:

  • RS_ISOLATEDPRECURSORFAILED: isolated precursor threshold.
  • RS_INTEFERENCEFAILED: matched rho.
  • RS_FITEXYSIGMA: elution profile correlation threshold.
  • RS_TOTALINTENSITYFAILED: total intensity threshold.
Parameters:
code | The ratio status for which extra information is wanted.
method | The quantitation method.
info | Filled in with the value of the extra information.
Returns:
True if there is extra information for this ratio status.
bool getFitexy ( matrix_science::ms_fitexy_result & value ) const

Get the fitexy value. Returns true if a fitexy value is set.

Parameters:
value Filled in with the ms_fitexy_result, if any.
Returns:
True if a fitexy value is set.
double getQuality ( ) const

Get the quality of the match.

Std. Err. = sigb / abs(b) from fitexy. Perfect fit is 0.0.

Returns:
The quality of the ratio.
std::string getRatioName ( ) const

Returns the ratio name.

Returns:
The ratio name.
int getStatus ( ) const

Get the status composite value.

Whether a peptide ratio is included or rejected when calculating a protein ratio.

These can be retrieved as a collection of separate values with getStatusList().

Returns:
A bitwise OR of any number of ratioStatusCode values.
std::vector< ms_ms1quant_match_ratio::ratioStatusCode > getStatusList ( ) const

Get the status values. Each status in the list is a single bit.

These can be retrieved as a single composite value with getStatus().

Returns:
A collection of the individual status values.
double getValue ( ) const

Return the numerical value of the ratio.

Returns:
The value of the ratio.
std::string getXmlCode ( ratioStatusCode code ) [static]

Get the XML attribute value for a status code.

Parameters:
code The ratio status to get the XML excoding string for.
Returns:
The string used to encode the ratio status in the XML file.
bool isIncluded ( ) const

Returns true if the item should be included in calculations.

Returns:
True if the item should be included in calculations.
bool isSet ( ) const

Returns true if the item has a value set.

Returns:
True if the item has a value set.
bool isUsedForAverage ( ) const

Returns true if the item is used in the average protocol for quantitation.

The Average protocol only uses a number of the the most intense peptides.

Returns:
True if the item has been used in the Average protocol calculations.
bool isValid ( ) const

Returns true if the item has a valid value.

Returns:
True if the item has a valid value.
The documentation for this class was generated from the following files:
  • ms_ms1quant_match_ratio.hpp
  • ms_ms1quant_match_ratio.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quant_peptide_status
Public Types | Public Member Functions | Static Public Member Functions

ms_ms1quant_peptide_status Class Reference
[Quantitation analysis for Mascot Server and Distiller]

An individual peptide's quantitation status. More...

#include <ms_ms1quant_peptide_status.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Types

enum peptideStatus {
PS_OK = 0,
PS_EXPECTGREATERTHAN = 1,
PS_LESSTHANIDENTITY = 2,
PS_MINCHARGE = 3,
PS_NOTUNIQUE = 4,
PS_SCORELESSHOMOLOGY = 5,
PS_SCORELESSIDENTITY_NOHOMO = 6,
PS_SCORELESSTHRESHOLD = 7,
PS_EXCLUDE_LOCALDEF = 8,
PS_EXCLUDE_MODFILE = 9,
PS_EXCLUDE_UNMODIFIED = 10,
PS_NOTPARTOFQUANTITATION = 11,
PS_DUPLICATESAMEQUERY = 12,
PS_MAX = 13
}

Status codes from fitting peptides.

More...

Public Member Functions

ms_ms1quant_peptide_status ()
Default constructor.
ms_ms1quant_peptide_status (const ms_ms1quant_peptide_status_body &body)
Populated constructor, linked to loaded data.
std::string | getComponent () const
Get the component for the peptide hit.
int | getQuery () const
Get the query for the peptide.
int | getRank () const
Get the rank for the peptide.
peptideStatus | getStatus () const
Get the status for the peptide hit.

Static Public Member Functions

static peptideStatus | getCodeFromXml (std::string str)
Get the status code for an XML attribute value.
static std::string | getXmlCode (peptideStatus code)
Get the XML attribute value for a status code.

Detailed Description

An individual peptide's quantitation status.

This is the status determined for the peptide during quantitation.

Member Enumeration Documentation

enum peptideStatus

Status codes from fitting peptides.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
PS_OK

No problem.

PS_EXPECTGREATERTHAN

The expectation is greater then 1.

PS_LESSTHANIDENTITY

The score is less than that required for identity.

PS_MINCHARGE

The charge state is less than the minimum required.

PS_NOTUNIQUE

The peptide is not unique.

PS_SCORELESSHOMOLOGY

The score is less than that required for homology.

PS_SCORELESSIDENTITY_NOHOMO

The score is less than that required for identity and there is no homology.

PS_SCORELESSTHRESHOLD

The score is less than the required threshold.

PS_EXCLUDE_LOCALDEF

The peptide is excluded due to a local definition.

PS_EXCLUDE_MODFILE

The peptide is excluded due to a modification file.

PS_EXCLUDE_UNMODIFIED

The peptide is excluded due to it being unmodified.

PS_NOTPARTOFQUANTITATION

The peptide is excluded because it is not part of quantitation.

PS_DUPLICATESAMEQUERY

The peptide is excluded because it is a duplicate in the same query.

PS_MAX

The number of values in this enumeration.

Constructor & Destructor Documentation

ms_ms1quant_peptide_status ( )

Default constructor.

Assigns reasonable default values to all internal members. The status is set to PS_NOTPARTOFQUANTITATION.

ms_ms1quant_peptide_status ( const ms_ms1quant_peptide_status_body & body )

Populated constructor, linked to loaded data.

Parameters:
body The data loaded from the result file.

Member Function Documentation

ms_ms1quant_peptide_status::peptideStatus getCodeFromXml ( std::string str ) [static]

Get the status code for an XML attribute value.

Some of the returned values include a substitution string of "%s" or "%d". The text is decoded based on the value up until the first substitution position.

Parameters:
str The string used to encode the status value in the XML file.
Returns:
The peptide status corresponding to the XML encoded string.
std::string getComponent ( ) const

Get the component for the peptide hit.

Returns:
The component (e.g. "Heavy") for the peptide component.
int getQuery ( ) const

Get the query for the peptide.

Returns:
The query number.
int getRank ( ) const

Get the rank for the peptide.

Returns:
The rank within the query.
matrix_science::ms_ms1quant_peptide_status::peptideStatus getStatus ( ) const

Get the status for the peptide hit.

Returns:
The status for the peptide hit.
std::string getXmlCode ( ms_ms1quant_peptide_status::peptideStatus code ) [static]

Get the XML attribute value for a status code.

Some of the returned values include a substitution string of "%s" or "%d". These are replaced with a specific value in the created XML.

Parameters:
code The peptide status to get the XML excoding string for.
Returns:
The string used to encode the status value in the XML file.
The documentation for this class was generated from the following files:
  • ms_ms1quant_peptide_status.hpp
  • ms_ms1quant_peptide_status.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms1quantitation
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes

ms_ms1quantitation Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The result of quantitation calculations applied to peptide summary. More...

#include <ms_ms1quantitation.hpp>

Inheritance diagram for ms_ms1quantitation:
[legend]
Collaboration diagram for ms_ms1quantitation:
[legend]

List of all members.

Public Types

enum MERGE_QUANT_RESULTS_FLAGS {
MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS = 0x0001,
MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH = 0x0002,
MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC = 0x0004,
MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE = 0x0008,
MERGE_QUANT_DEFAULT_PRECURSOR_METHOD = MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE,
MERGE_QUANT_DEFAULT_REPLICATE_METHOD = (MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS | MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH | MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC)
}

Enum for mergeQuantitationResults()

More...
enum | MS1QUANT_BUGFIX_NUM { BUGFIX_12409 = 12409 }

bugNum values for isDataCached().

More...

Public Member Functions

ms_ms1quantitation (const ms_peptidesummary &summary, const ms_quant_method &method)
Constructor: given a peptide summary and a quantitation method, prepare for data processing.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
matrix_science::ms_ms1quant_match | addMatchInferred (const ms_ms1quant_match &siblingMatch, int newCharge)
Add an inferred peptide match to the quantitation results.
void | addMatchPeptide (matrix_science::ms_protein *hit, matrix_science::ms_peptide *peptide, const matrix_science::ms_quant_component &component, const std::string &matchBelongsToComponent)
Add a quantitation peptide match to a protein hit.
void | addMatchStatus (matrix_science::ms_peptide *peptide, matrix_science::ms_ms1quant_peptide_status::peptideStatus status, matrix_science::ms_protein *hit=0)
Add the quantitation status for the protein-peptide match to the quantitation results.
void | addPeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Associate a protein accession with a peptide quant key.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideQuantKeys (const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys)
Associate a protein accession with particular peptide quant keys.
void | addPeptideRatio (const ms_peptide_quant_ratio &ratio)
Add a new peptide ratio.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearPeptideQuantKeys (const std::string &accession, int dbIdx)
Clear all peptide quant key associations for a given protein.
void | clearPeptideRatios ()
Remove all peptide ratios.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
bool | findMatch (matrix_science::ms_peptide_quant_key matchKey, ms_ms1quant_match *match) const
Get a match by its key.
bool | findPeptideStatus (int query, int rank, ms_ms1quant_peptide_status *peptideStatus) const
Get a peptide status in the quantitation results by the peptide's query and rank.
bool | getAveragePeptideIntensity (const std::string &accession, int dbIdx, double *averageIntensity, int *sampleSize, ms_peptide_quant_key_vector *includeKeys, ms_peptide_quant_key_vector *excludeKeys) const
Average protocol only: get the intensity of the protein based on its component peptide intensities.
const ms_ms1quant_average_results * | getAverageResults () const
Return the results from an 'average' protocol.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
ms_protein * | getHit (int index1) const
Get a quantitated protein.
std::string | getLabelFree (std::string peptideStr, std::string varMods, std::string summedMods, const matrix_science::ms_quant_component &comp) const
Get the label-free modifications string, combined from the variable mods and the summed mods.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_ms1quant_match | getMatch (int index) const
Get a match by its index (1..getNumMatches()).
ms_ms1quant_match | getMatch (const ms_peptide_quant_key &key) const
Get a match by its key.
ms_ms1quant_match | getMatchForHit (int index, int hitId, int memberNumber) const
Get a match for the specified hit protein (index is 1..numberOfMatchesForHit).
int | getNumGroups () const
Return the number of match groups
int | getNumHits () const
Get the number of quantitated proteins.
int | getNumMatches () const
Get the number of peptide matches for all quantitated proteins.
int | getNumMatchesForGroup (int groupIndex1) const
Return the number of matches for each group.
int | getNumMatchesForHit (int hitId, int memberNumber) const
Get the number of matches for the specified hit protein.
int | getNumPeptideStatuses () const
Get the number of peptide statuses.
int | getNumProteinFamilies () const
Get the number of protein families.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
ms_ms1quant_peptide_status | getPeptideStatus (int index) const
Get a peptide status by its index.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const
Overridden from ms_quantitation (via ms_customquantitation) base class.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
Overridden from ms_quantitation (via ms_customquantitation) base class.
std::vector< int > | getQuantitationDatasources () const
Get the datasource identifiers of every data source in use for quantitation.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
std::string | getReadableVarMods (std::string varmods)
Get the human-readable format of the given variable modifications.
std::string | getReadableVarModsConcise (std::string varmods)
Get the concise version of the human-readable format of the given variable modifications.
const ms_peptidesummary & | getSummary () const
The summary is needed to recover the proteins and peptides.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType) const
Calculate the unnormalised average peptide ratio.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const
Calculate the unnormalised average of selected peptide quant keys.
double | getUnnormalisedAveragePeptideRatio (const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const
Calculate the unnormalised average of peptide quant keys of a protein accession.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
void | initGroupChargeStates (std::set< int > *calc_chargestates, int iGroup1, int minCharge, int maxCharge)
Add inferred charge states to the group if specified in the method.
bool | isAverageProtocol () const
Return true if the quantitation method uses the Average protocol.
bool | isDataCached (MS1QUANT_BUGFIX_NUM bugNum) const
Returns true if the cache file contains data relevant to the given bug number.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadCdbFile (const std::string &cdbFilename, const std::string &cacheFilename, bool revalidateQualityThresholds=true)
Load the results from a matched pair of files.
bool | loadXmlFile (const std::string &filename, const std::string &xmlSchemaPath)
Load quantitation results from an XML file. The schema is loaded from the location known to the.
bool | mergeQuantitationResults (const std::vector< std::string > &xmlFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0)
Merges the quantitation results loaded from xml result files.
bool | mergeQuantitationResults (const std::vector< std::string > &cdbFilenames, const std::vector< std::string > &cacheFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const matrix_science::ms_quant_method *originalMethod=0)
Merges the quantitation results from matched pairs of cdb files.
void | removeMatch (matrix_science::ms_peptide_quant_key matchKey)
Remove the specified peptide match from the results.
void | removePeptideQuantKey (const std::string &accession, int dbIdx, const ms_peptide_quant_key &key)
Deassociate a peptide quant key from the given protein.
void | removePeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName)
Remove a particular peptide ratio.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
bool | saveCdbFile (const std::string &cdbFilename, const std::string &cacheFilename, bool createEmptyMissingComponents=false)
Save the results to a matched pair of files.
bool | saveXmlFile (const std::string &xmlFilename, bool completeReport)
Save the quantitation results to an XML file.
void | setAverageNumPeptides (unsigned int num=3)
Average protocol only: set the number of most intense peptide groups to use.
void | setAverageReferenceProtein (const char *accession, int dbIdx, bool isReferenceUserSelected)
Average protocol only: select a reference protein accession and database.
void | setAverageSelection (const char *value)
Average protocol only: set the method of grouping peptide ratios.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)
Set the protein ratio type.
virtual void | setQuantOutliers (const ms_quant_outliers *)
Set new peptide ratio outlier settings.

Static Public Member Functions

static
matrix_science::ms_ms1quantitation * 		openQuantitationCdbResults (const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &cdbFilename, const std::string &cacheFilename, const matrix_science::ms_quant_method *originalMethod=0)
Opens and loads quantitation results from a matched pair of cdb files.
static
matrix_science::ms_ms1quantitation * 		openQuantitationXmlResults (const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &filename, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0)
Opens and loads quantitation results from an xml result file.
static bool | readResultCounters (const std::string &cdbFile, int &numMatches, int &numHits, int &numPepGrp, int &numPeptideComponents)
Reads and returns the Counters information from the cdb result file.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t | proteinKeys_
Protein-to-peptide mapping.

Detailed Description

The result of quantitation calculations applied to peptide summary.

Each ms_protein hit from the ms_peptidesummary can have any number of peptide matches (ms_ms1quant_match) that contribute to its protein ratios.

Peptide ratios are identified by the index key (0..getNumMatches()-1) identifying the ms_ms1quant_match (ms_peptide_quant_key(int ID)).

Protein ratios are identified by protein accession and database index.

As the quantitation results are loading (loadCdbFile() or loadXmlFile()), the protein hits references to the quantitation peptide ratio results validated with the current ms_peptidesummary. These will normally match but may not if, for instance, the peptide summary has been re-calculated since the quantitation results were generated. If a protein has changed its hit reference in the peptide summary (but can still be found by its accession, in any database) a warning message is added to the ms_errors to indicate that the protein reference has been updated. If a protein is no longer present in the peptide summary then a warning message is added to the ms_errors to indicate that the protein was not found.

Example code to load quantitation results and list protein ratios:

void listProteins(const ms_peptidesummary & pepsum, const ms_quant_method & method, const char * cdbFilename, const char * cacheFilename)
{
    ms_ms1quantitation quant(pepsum, method);
    quant.loadCdbFile(cdbFilename, cacheFilename);
    for (int iHit = 1; iHit <= pepsum.getNumberOfHits(); ++iHit)
    {
        ms_protein * hit = pepsum.getHit(iHit);
        cout << endl << pepsum.getProteinDescription(hit->getAccession().c_str(), hit->getDB()) << endl;
        const std::vector<const matrix_science::ms_quant_ratio*> & proteinRatios = quant.getProtocol()->getProteinRatios();
        for (unsigned iRatio = 0; iRatio < proteinRatios.size(); ++iRatio)
        {
            std::string ratioName = proteinRatios[iRatio]->getName();
            ms_protein_quant_ratio rat = quant.getProteinRatio(hit->getAccession(), hit->getDB(), ratioName);
            if (!rat.isMissing())
            {
                cout << "    " << ratioName << " = " << rat.getValue() << endl;
            }
        }
    }
}

Member Enumeration Documentation

enum MERGE_QUANT_RESULTS_FLAGS

Enum for mergeQuantitationResults()

Enumerator:
MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS

For replicate, each subproject uses the merged results. (For precursor, each subproject uses its own search result)

MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH

For replicate, we create a component in one file, based on the match to the same query in another file. Merge these components into one ms_ms1quant_match.

MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC

For replicate, the XIC for a particular component is saved saved in the relevant file, available using ms_quant_component::getFileIndex(). For precursor, all components can be in one subproject file.

MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE

This shouldn't be done for replicate, because the ratios will all be incorrect until they are recalculated after calling mergeQuantitationResults()

MERGE_QUANT_DEFAULT_PRECURSOR_METHOD

Use this for any precursor method.

MERGE_QUANT_DEFAULT_REPLICATE_METHOD

Use this for any replicate method.

enum MS1QUANT_BUGFIX_NUM

bugNum values for isDataCached().

If loaded from a cdb file from Distiller 2.7 or earlier, then the cache file may not contain data for later improvements. While this does not affect functionality, it may impact performance. For example, bug#12409 means that unnormalised peptide ratios are saved in the cdb file, allowing for rapid disabling of normalisation without requiring requantitation

See Using enumerated values and static const ints in Perl, Java, Python and C# and ms_peptidesummary::isDataCached(),

Enumerator:
BUGFIX_12409

Distiller 2.7 or earlier save normalised peptide ratios to the cdb file. If this method returns false, the enabling and disabling normalisation is not possible from within msparser and requires the data to be requantitated.

Constructor & Destructor Documentation

ms_ms1quantitation | ( | const ms_peptidesummary & | summary,
 |  | const ms_quant_method & | method
 | ) |  |

Constructor: given a peptide summary and a quantitation method, prepare for data processing.

ms_ms1quantitation does not calculate the quantitation matches; it loads in previously calculated and stored matches but the peptide and protein ratios are re-calculated as required.

After contructing the ms_ms1quantitation, the quantitation results should be loaded using loadCdbFile() or loadXmlFile().

Parameters:
summary | Mascot results file to quantitate. Note that you must first validate the embedded XML sections of the results file. Either pass the schema directory to the ms_mascotresfile constructor or use ms_mascotresfile::setXMLschemaFilePath().
method | Quantitation method to use. If the results are being taken from a Distiller project file, then the quantitation method from the ms_distiller_data should be used.

Member Function Documentation

matrix_science::ms_ms1quant_match addMatchInferred | ( | const ms_ms1quant_match & | siblingMatch,
 |  | int | newCharge
 | ) |  |

Add an inferred peptide match to the quantitation results.

Parameters:
siblingMatch | The identified match the inferred match is derived from
newCharge | The charge state of the inferred match
Returns:
the newly created and added ms_ms1quant_match object
void addMatchPeptide | ( | matrix_science::ms_protein * | hit,
 |  | matrix_science::ms_peptide * | peptide,
 |  | const matrix_science::ms_quant_component & | component,
 |  | const std::string & | matchBelongsToComponent
 | ) |  |

Add a quantitation peptide match to a protein hit.

Parameters:
hit | The protein hit the peptide quantitation match is associated with
peptide | The peptide
component | The quantitation component the match is associated with
matchBelongsToComponent | is used to determine whether to call ms_ms1quant_match::addIdentifiedComponent() or ms_ms1quant_match::addCreatedComponent() because for MS1 label free we need a created component if there's no match in our file. Pass an empty string for protocols other than label free
void addMatchStatus | ( | matrix_science::ms_peptide * | peptide,
 |  | matrix_science::ms_ms1quant_peptide_status::peptideStatus | status,
 |  | matrix_science::ms_protein * | hit = 0
 | ) |  |

Add the quantitation status for the protein-peptide match to the quantitation results.

Adds the status of a peptide match assigned to the specified protein to the quantitation results

Parameters:
peptide | The peptide associated with the quantitation match
status | The peptide quantitation match status
hit | The protein hit the peptide match is associated with. Do not pass this parameter for unassigned peptide matches
void addPeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  | [inherited]

Associate a protein accession with a peptide quant key.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

If key is already associated with this protein, no changes are made.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.
void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::vector< ms_peptide_quant_key > & | keys
 | ) |  | [inherited]

Associate a protein accession with particular peptide quant keys.

Note:
This method can only be used from C++. Use addPeptideQuantKeys(std::string, int, const ms_peptide_quant_key_vector) from other programming languages instead.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.
void addPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  | [inherited]

Associate a protein accession with particular peptide quant keys.

A protein-peptide mapping is required for protein ratio calculation purposes. That is, each protein accession whose ratio you need must have at least one peptide quant key associated with it, and the peptide quant key must have a peptide ratio defined.

Values in keys already associated with the protein are skipped.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
keys | Peptide quant keys.
void addPeptideRatio ( const ms_peptide_quant_ratio & ratio ) [inherited]

Add a new peptide ratio.

If an existing peptide ratio exists with the same query, rank and ratio name as ratio.getQuery(), ratio.getRank() and ratio.getRatioName(), it will be replaced with the new data.

If ratio represents an undefined ("missing") value, the peptide ratio will be removed, as if you had called removePeptideRatio() instead.

Parameters:
ratio Peptide ratio to add.
void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.
ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void clearPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | [inherited]

Clear all peptide quant key associations for a given protein.

After this, getProteinRatio() will return a ratio with state isMissing() when given accession, dbIdx and any ratio name.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
void clearPeptideRatios ( ) [inherited]

Remove all peptide ratios.

This method also removes all q,p aliases of peptide ratios. However, the peptide-protein mapping will not be changed.

void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int countDistinctPeptides ( const ms_peptide_quant_key_vector & activeKeys ) const [virtual, inherited]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

This function just calls countDistinctPeptides(const ms_peptide_quant_key_vector &) (which should call the relevant ms_ms1quantitation or ms_ms2quantitation version.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.
int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const [virtual]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.

Reimplemented from ms_quantitation.

bool findMatch | ( | matrix_science::ms_peptide_quant_key | matchKey,
 |  | matrix_science::ms_ms1quant_match * | match
 | ) |  | const

Get a match by its key.

Parameters:
matchKey | The ms_peptide_quant_key to search for in the results' matches.
match | An ms_ms1quant_match to receive the found match information.
Returns:
True if a ms_ms1quant_match was found with a key matching matchKey.
bool findPeptideStatus | ( | int | query,
 |  | int | rank,
 |  | matrix_science::ms_ms1quant_peptide_status * | peptideStatus
 | ) |  | const

Get a peptide status in the quantitation results by the peptide's query and rank.

Parameters:
query | The query number of the peptide.
rank | The rank of the peptide within the query.
peptideStatus | An ms_ms1quant_peptide_status to receive the found peptide information.
Returns:
True if a peptide matching the search criteria was found in the quantitation data.
bool getAveragePeptideIntensity | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | double * | averageIntensity,
 |  | int * | sampleSize,
 |  | matrix_science::ms_peptide_quant_key_vector * | includeKeys,
 |  | matrix_science::ms_peptide_quant_key_vector * | excludeKeys
 | ) |  | const

Average protocol only: get the intensity of the protein based on its component peptide intensities.

The number of peptide intensities associated with a protein will typically not be the same as then number to be used for the Average protocol, see setAverageNumPeptides(). If there are insufficient peptide intensities then the sample size will still be set (less than the number required). If there are sufficient peptide intensities then the sample size is set to the total number and the average is set to the average of the peptide intensities used (typically not the entire sample).

The average returned is that of the grouped intensities. Each peptide ratio group is summed and then the average is taken of those sums.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | accession | The protein accession.
[in] | dbIdx | The protein database index.
[out] | averageIntensity | Returns the average of the peptide intenties that are selected.
[out] | sampleSize | Returns the number of different peptide groups available; after grouping by selection type.
[out] | includeKeys | The peptide quant ratio keys in the peptide groups that were selected; this may be greater than sampleSize.
[out] | excludeKeys | The peptide quant ratio keys in the peptide groups that were not selected.
Returns:
True if enough peptides (after grouping) are associated with the sample to calculate the average.
const matrix_science::ms_ms1quant_average_results * getAverageResults ( ) const

Return the results from an 'average' protocol.

Returns:
The results that are only applicable to an 'average' protocol, or null if the quantitation method type is not 'average'.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
matrix_science::ms_protein * getHit ( int index1 ) const

Get a quantitated protein.

Parameters:
index1 The quantitated protein's index (1..getNumHits()).
Returns:
The selected quantitated protein.
std::string getLabelFree | ( | std::string | peptideStr,
 |  | std::string | varMods,
 |  | std::string | summedMods,
 |  | const matrix_science::ms_quant_component & | comp
 | ) |  | const

Get the label-free modifications string, combined from the variable mods and the summed mods.

Mods are now encoded into two strings: varMods and summedMods. The use of two strings allows for the site of the label to also contain another mod. Having stripped the labels from the strings, there will only be one mod per site allowing the two strings to be merged into a single label-free mod string

Parameters:
peptideStr | The peptide sequence string.
varMods | The encoded variable modifications.
summedMods | The encoded summed modifications.
comp | The component defining all the modifications that are part of the labelling protocol and so should not be included in the label-free list of modifications.
Returns:
label-free string.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
ms_ms1quant_match getMatch ( const ms_peptide_quant_key & key ) const

Get a match by its key.

Parameters:
key The match's key
Returns:
The selected match, or an empty match if not found.
ms_ms1quant_match getMatch ( int index ) const

Get a match by its index (1..getNumMatches()).

Parameters:
index The match's index (1..getNumMatches()).
Returns:
The selected match.
ms_ms1quant_match getMatchForHit | ( | int | index,
 |  | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Get a match for the specified hit protein (index is 1..numberOfMatchesForHit).

Parameters:
index | The index (1..getNumMatches()) of the required match.
hitId | The protein hit's identifier.
memberNumber | The number of the hits within its family, or zero if it is not in a family.
Returns:
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.
int getMinNumPeptides ( ) const [protected, inherited]

Get the minimum number of peptides needed for protein ratio calculation.

Returns:
The minimum number of peptides needed for protein ratio calculation.
int getNumGroups ( ) const

Return the number of match groups

A single match group is all the matches with a unique datasourceId:peptideStr:labelFreeVarMods.

Returns:
the number of match groups
int getNumHits ( ) const

Get the number of quantitated proteins.

Returns:
The number of proteins included in the quantitation result.
int getNumMatches ( ) const

Get the number of peptide matches for all quantitated proteins.

Returns:
The number of matches in the quantitation result.
int getNumMatchesForGroup ( int groupIndex1 ) const

Return the number of matches for each group.

There will be one match group for each datasourceId:peptideStr:labelFreeVarMods that got a significant match. Each match group will contain one or more matches, one for each charge state that had a signficant PSM.

Parameters:
groupIndex1 should be in the range 1..getNumGroups()
Returns:
the number of matches for each group
int getNumMatchesForHit | ( | int | hitId,
 |  | int | memberNumber
 | ) |  | const

Get the number of matches for the specified hit protein.

Parameters:
hitId | The protein hit's identifier.
memberNumber | The number of the hits within its family, or zero if it is not in a family.
Returns:
The number of matches associated with the protein hit.
int getNumPeptideStatuses ( ) const

Get the number of peptide statuses.

Returns:
The number of peptides with a status in the quantitation result.
int getNumProteinFamilies ( ) const

Get the number of protein families.

This function can be removed when bug 13150 is fixed

Returns:
the number of protein fmailies that have been quantitated
ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const [inherited]

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
Returns:
A vector of peptide quant keys associated with the protein.
ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual, inherited]

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implements ms_quantitation.

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const [inherited]

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName Peptide ratio name.
Returns:
The current peptide ratio normalisation base, or 1 if it hasn't been set.
matrix_science::ms_ms1quant_peptide_status getPeptideStatus ( int index ) const

Get a peptide status by its index.

Parameters:
index The peptide status's index (1..getNumPeptideStatuses()).
Returns:
The selected peptide status.
const matrix_science::ms_progress_info & getProgressInfo ( ) [inherited]

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns:
Progress information about the most recent long operation.
matrix_science::ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const [virtual]

Overridden from ms_quantitation (via ms_customquantitation) base class.

The list of included and excluded keys are retrieved from the result before being passed to the base class for processing. These will override the lists of keys set by setPeptideRatioExcluded() and setPeptideRatioIncluded() so that the same result can be obtained as was set twhen the results were calculated. To override the lists of peptides from the stored result, call getProteinRatio() on the base class (ms_customquantitation).

Parameters:
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
includeKeys | The keys of peptide matches that are to be included in the protein ratio.
excludeKeys | The keys of peptide matches that are to be excluded in the protein ratio
Returns:
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

Reimplemented from ms_customquantitation.

matrix_science::ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Overridden from ms_quantitation (via ms_customquantitation) base class.

See ms_quantitation::getProteinRatio for further details of how the ratio is calculated

The list of included and excluded keys are retrieved from the result before being passed to the base class for processing. These will override the lists of keys set by setPeptideRatioExcluded() and setPeptideRatioIncluded() so that the same result can be obtained as was set twhen the results were calculated. To override the lists of peptides from the stored result, call getProteinRatio() on the base class (ms_customquantitation).

Parameters:
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
Returns:
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

Reimplemented from ms_customquantitation.

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const [protected, inherited]

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.
std::vector< int > getQuantitationDatasources ( ) const

Get the datasource identifiers of every data source in use for quantitation.

Returns:
A collection of all the datasource identifiers that are in use in all the quantitation matches.
const ms_quant_method & getQuantitationMethod ( ) const [inherited]

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns:
The current quantitation method.
std::string getReadableVarMods ( std::string varmods )

Get the human-readable format of the given variable modifications.

Parameters:
varmods The encoded variable modifications.
Returns:
The human-readable form of the variable modifications.
std::string getReadableVarModsConcise ( std::string varmods )

Get the concise version of the human-readable format of the given variable modifications.

Parameters:
varmods The encoded variable modifications.
Returns:
The concise version of the human-readable form of the variable modifications.
void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const [protected, virtual, inherited]

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters:
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implements ms_quantitation.

const matrix_science::ms_peptidesummary & getSummary ( ) const

The summary is needed to recover the proteins and peptides.

Returns:
The summary that was passed to the constructor.
double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType
 | ) |  | const [inherited]

Calculate the unnormalised average peptide ratio.

All peptide ratios currently stored in the object are used in calculation. If there are no peptide ratios associated with the ratio name, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters:
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
Returns:
The average of all peptide ratios currently stored in the object, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.
double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const [inherited]

Calculate the unnormalised average of peptide quant keys of a protein accession.

All peptide ratios matching ratioName and associated with the protein accession and database index are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored. You can alter the protein-peptide mapping with addPeptideQuantKey().

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters:
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
accession | Protein accession.
dbIdx | Protein database index.
Returns:
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.
double getUnnormalisedAveragePeptideRatio | ( | const std::string & | ratioName,
 |  | const std::string & | averageType,
 |  | const ms_peptide_quant_key_vector & | keys
 | ) |  | const [inherited]

Calculate the unnormalised average of selected peptide quant keys.

All peptide ratios matching ratioName and whose peptide quant key is in keys are chosen for calculation. If there are no such peptide ratios, the method returns 1.0. Negative and infinite values are ignored.

averageType determines the kind of average to compute. Allowed values are described in Type mqm:normaliseType, except that "sum" is not supported. If the kind is "none" or an unsupported value, the method returns 1.0.

Using the Average protocol: If quantitation protocol is average, normalisation has no meaning. It is still possible to get a geometric mean or median of all peptide intensities, but you should not use it for normalisation purposes.

Parameters:
ratioName | Peptide ratio name.
averageType | Peptide ratio normalisation type; one of Type mqm:normaliseType.
keys | Peptide quant keys of peptide ratios to use in calculation.
Returns:
The average of all selected peptide ratios, where averageType controls the kind of average to be calculated. Note that the return value may be 0.0 or very near 0.0.
bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual, inherited]

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio exists; false otherwise.

Implements ms_quantitation.

void initGroupChargeStates | ( | std::set< int > * | calc_chargestates,
 |  | int | iGroup1,
 |  | int | minCharge,
 |  | int | maxCharge
 | ) |  |

Add inferred charge states to the group if specified in the method.

Only called if ms_quant_integration::isAllChargeStates() returns true

This extends the mass and time matching to cover contiguous charge states. In other words, if there is a positive match on 2+, the software will look for 1+ and 3+. It will not look for 4+ unless 3+ is found, etc.

Parameters:
[out] | calc_chargestates | will contain the list of calculated charges added
[in] | iGroup1 | must be in the range 1..getNumGroups()
[in] | minCharge | will be the value in the quantitation method: ms_quant_quality::getMinPrecursorCharge
[in] | maxCharge | will normally be the MDRO processing option: MS->MaxPeakCharge
bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  | [protected, inherited]

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters:
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns:
True.
bool isAverageProtocol ( ) const

Return true if the quantitation method uses the Average protocol.

Returns:
True if the quantitation method uses the Average protocol.
bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual, inherited]

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implements ms_quantitation.

bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool loadCdbFile | ( | const std::string & | cdbFilename,
 |  | const std::string & | cacheFilename,
 |  | bool | revalidateQualityThresholds = true
 | ) |  |

Load the results from a matched pair of files.

Distiller stores these in a project file (*.rov) in streams 3000+n and 8000+n where n is the value in the projectStream attribute of the QuantResult from the Quantitation folder.

If the function fails, any errors are reported in the (base class) ms_errors object.

Parameters:
cdbFilename | The path and filename of the CDB file containing the quantitation results.
cacheFilename | The path and filename of the file containing the quantitation cache data.
revalidateQualityThresholds | If true, the MS/MS peptide match evidence will be retested against the method quality thresholds. If no settings have been changed, this parameter should be set to false as re-evaluating the thresholds can lose user selections. However, if this parameter is incorrectly set to false, then misleading quantitation results may be obtained. [default=true]
Returns:
True if the files were loaded successfully.
bool loadXmlFile | ( | const std::string & | filename,
 |  | const std::string & | xmlSchemaPath
 | ) |  |

Load quantitation results from an XML file. The schema is loaded from the location known to the.

This uses the ms_mascotresfile attached to the ms_peptidesummary supplied in the constructor. If no schema location was specified to the ms_mascotresfile then loading the XML file will fail.

If the function fails, any errors are reported in the (base class) ms_errors object.

A warning message is added to ms_errors to indicate whenever a protein reference has been changed or removed because the peptide summar results do not match the quantitation results.

If the schema path contains spaces, it should be prefixed with "file:///" and the spaces should be replaced with "%20"

Parameters:
filename | The path and filename of the file to load.
xmlSchemaPath | The folder where the quantitation XML schema files (XSD) can be found.
Returns:
True if the file was loaded successfully.
bool mergeQuantitationResults | ( | const std::vector< std::string > & | xmlFilenames,
 |  | const MERGE_QUANT_RESULTS_FLAGS | flags,
 |  | const std::string & | xmlSchemaPath = "",
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  |

Merges the quantitation results loaded from xml result files.

This helper method merges the passed xml result files into the current object.

To use it, create a new ms_ms1quantitation::ms_ms1quantitation() object, passing in the ms_peptidesummary object for the merged search results and the quantitation method for the new merged results.

If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then error details will be set and the method will return false. For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller.

Parameters:
xmlFilenames | Vector containing the paths and filenames of the Mascot Distiller quantitation result xml files to merge.
xmlSchemaPath | Path to the directory containing the Distiller quantitation results xml schema file.
flags | is one or more ms_ms1quantitation::MERGE_QUANT_RESULTS_FLAGS bitwise ORed together
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns:
true if successful. If false is returned, call getLastError() to see the error that was encountered.
bool mergeQuantitationResults | ( | const std::vector< std::string > & | cdbFilenames,
 |  | const std::vector< std::string > & | cacheFilenames,
 |  | const MERGE_QUANT_RESULTS_FLAGS | flags,
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  |

Merges the quantitation results from matched pairs of cdb files.

This method merges the passed pairs of cdb files into the current object.

To use it, create a new ms_ms1quantitation::ms_ms1quantitation() object, passing in the ms_peptidesummary object for the merged search results and the quantitation method for the new merged results.

If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then error details will be set and the method will return false. For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller.

Parameters:
cdbFilenames | Vector containing the paths and filenames of the Mascot Distiller quantitation results cdb files to merge.
cacheFilenames | Vector containing the paths and filenames of the Mascot Distiller quantitation cache cdb files to merge.
flags | is one or more ms_ms1quantitation::MERGE_QUANT_RESULTS_FLAGS bitwise ORed together
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns:
true if successful. If false is returned, call getLastError() to see the error that was encountered.
matrix_science::ms_ms1quantitation * openQuantitationCdbResults | ( | const matrix_science::ms_peptidesummary & | summary,
 |  | const matrix_science::ms_quant_method & | method,
 |  | const std::string & | cdbFilename,
 |  | const std::string & | cacheFilename,
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  | [static]

Opens and loads quantitation results from a matched pair of cdb files.

This helper method creates, loads and returns an ms_ms1quantitation object for a pair of matched cdb files. If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then the error details will be set on the returned ms_ms1quantitation object - For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller. Use the isValid() method of ms_ms1quantitation to check if the returned quantitation results object is valid.

Note: In unmanaged languages such as C++, this method returns a pointer to a new ms_ms1quantitation method. It is the responsibility of the calling code to delete this when the ms_ms1quantitation object has been finished with.

Parameters:
summary | The Mascot result peptide summary the quantitation results apply to.
method | The quantitation settings to generate the report using.
cdbFilename | The path and filename of the Mascot Distiller quantitation results cdb file to open.
cacheFilename | The path and filename of the Mascot Distiller quantitation cache file.
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns:
The calculated ms_ms1quantitation results. If errors were encountered, they will be set to the returned object. Check the value of isValid() and getLastError() to see if an error was encountered.
matrix_science::ms_ms1quantitation * openQuantitationXmlResults | ( | const matrix_science::ms_peptidesummary & | summary,
 |  | const matrix_science::ms_quant_method & | method,
 |  | const std::string & | filename,
 |  | const std::string & | xmlSchemaPath = "",
 |  | const matrix_science::ms_quant_method * | originalMethod = 0
 | ) |  | [static]

Opens and loads quantitation results from an xml result file.

This helper method creates, loads and returns an ms_ms1quantitation object from an exported Mascot Distiller quantitation results xml file. If you have changed the quantitation quality settings, you should pass in a pointer to the original quantitation settings. This method will then compare between the new and original settings. If the changed settings cause a change which cannot be handled within the ms_ms1quantitation class, then the error details will be set on the returned ms_ms1quantitation object - For example, if you enabled mass-time-matching when the original dataset has this setting disabled then additional matches would need quantification carrying out from within Mascot Distiller. Use the isValid() method of ms_ms1quantitation to check if the returned quantitation results object is valid.

Note: In unmanaged languages such as C++, this method returns a pointer to a new ms_ms1quantitation method. It is the responsibility of the calling code to delete this when the ms_ms1quantitation object has been finished with.

Parameters:
summary | The Mascot result peptide summary the quantitation results apply to.
method | The quantitation settings to generate the report using.
filename | The path and filename of the Mascot Distiller quantitation results xml file to open.
xmlSchemaPath | The path to the directory containing the Distiller quantitation results xml schema file.
originalMethod | Optional pointer to the original quantitation method. Set this only if the passed method is different.
Returns:
The calculated ms_ms1quantitation results. If errors were encountered, they will be set to the returned object. Check the value of isValid() and getLastError() to see if an error was encountered.
bool readResultCounters | ( | const std::string & | cdbFile,
 |  | int & | numMatches,
 |  | int & | numHits,
 |  | int & | numPepGrp,
 |  | int & | numPeptideComponents
 | ) |  | [static]

Reads and returns the Counters information from the cdb result file.

This helper method loads the Counters values from the passed cdbfile and sets the return values. See Multiple return values in Perl, Java, Python and C#.

Parameters:
cdbFile | The cdbfile to load the counters from
[out] | numMatches | The number of peptide quant matches is set to this parameter
[out] | numHits | The number of protein hits quantified
[out] | numPepGrp | The number of peptide groups
[out] | numPeptideComponents | The number of peptide components
Returns:
True if the counters have been read and the return values set, false if not
void removeMatch ( matrix_science::ms_peptide_quant_key matchKey )

Remove the specified peptide match from the results.

Parameters:
matchKey The identifier of the peptide quantitation match
void removePeptideQuantKey | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const ms_peptide_quant_key & | key
 | ) |  | [inherited]

Deassociate a peptide quant key from the given protein.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
key | Peptide quant key.
void removePeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [inherited]

Remove a particular peptide ratio.

However, the protein-peptide mapping related to the peptide quant key will not be changed.

Parameters:
key | Peptide quant key.
ratioName | Ratio name.
void removePeptideRatioNormalisationBase ( const std::string & ratioName ) [inherited]

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters:
ratioName Ratio name whose normalisation base is to be reset.
void removePeptideRatioNormalisationBases ( ) [inherited]

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

bool saveCdbFile | ( | const std::string & | cdbFilename,
 |  | const std::string & | cacheFilename,
 |  | bool | createEmptyMissingComponents = false
 | ) |  |

Save the results to a matched pair of files.

Distiller stores these in an MDRO project file (*.rov) in streams 3000+n and 8000+n where n is the value in the projectStream attribute of the QuantResult from the Quantitation folder.

If cdbFilename already exists and can be opened as a CDB file, then this function just returns true immediately.

Parameters:
cdbFilename | The path and filename of the CDB file to receive the quantitation results.
cacheFilename | The path and filename of the CDB file to receive the quantitation cache data.
createEmptyMissingComponents | should be set to true for cases like the replicate protocol where an individual raw file does not have the other components. The CDB file expects a component for each item component specified in the method.
Returns:
True if the file was saved successfully.
bool saveXmlFile | ( | const std::string & | xmlFilename,
 |  | bool | completeReport
 | ) |  |

Save the quantitation results to an XML file.

The schema for the XML file is: distiller_quantitation_2.xsd

Some ratios calculations will results in an 'invalid' number, for example, because of no data (NaN) or division by zero. In these cases, the XML will have additional element(s), with ms_ms1quant_match_ratio::ratioStatusCode to describe them.

To simplify code for consumers of the xml, the 'value' saved in the xml is converted to a finite value accordingly:

IEEE 754-2008 Value | Standard XML representation | Value output to XML | ratioStatusCode(s)
qNaN or sNaN | "NaN" | "0" | "RatioUndefined"
+infinity | "INF" | "999999999999999967336168804116691273849533185806555472917961779471295845921727862608739868455469056.000000" (this value is the text representation of 1e99) | "InfiniteRatio"
-infinity; | "-INF" | "999999999999999967336168804116691273849533185806555472917961779471295845921727862608739868455469056.000000" (this value is the text representation of 1e99) | "InfiniteRatio" and "NegativeRatio"
Parameters:
xmlFilename | The path and filename of the file to save.
completeReport | True if a complete report of all data is to be generated, or false to generate concise report data.
Returns:
True if the file was saved successfully.
void setAverageNumPeptides ( unsigned int num = 3 )

Average protocol only: set the number of most intense peptide groups to use.

This method only works when quantitation method protocol is Average. If protocol is not Average, calling the method has no effect.

In the Average protocol, protein intensities are calculated as the sum of the "top \a num" peptide intensities assigned to the protein hit. num is conventionally 3.

Parameters:
num The number of most intense peptide intensities to use in calculating protein intensities in the Average protocol. If 0, the value is reset to 3.
void setAverageReferenceProtein | ( | const char * | accession,
 |  | int | dbIdx,
 |  | bool | isReferenceUserSelected
 | ) |  |

Average protocol only: select a reference protein accession and database.

This method only works when quantitation method protocol is Average. If protocol is not Average, calling the method has no effect.

In the Average protocol, protein ratios are relative to a specified reference protein, identified by its accession and dbIdx The reference protein should be one that has peptide ratios (intensities) associated with it. If it does not, getProteinRatio() will simply return raw intensity values.

If the quantitation method doesn't specify an accession, then the calling software should find the first protein hit, pass the accession and dbIdx of that hit and pass isReferenceUserSelected as false.

Calling this method does not modify the current quantitation method.

Parameters:
accession | Accession of the reference protein. If null or an empty string, the warning matrix_science::ms_errs::ERR_MSP_QUANT_EMPTY_REF_ACCESSION will be set, and the function does nothing.
dbIdx | The database the protein is from. Must be correct! If the search results don't contain a protein matching the passed accession and dbIdx, then the warning matrix_science::ms_errs::ERR_MSP_QUANT_ACCESSION_NOT_FOUND is set
isReferenceUserSelected | should be set to true if the reference accession was specified in the method.
void setAverageSelection ( const char * mode )

Average protocol only: set the method of grouping peptide ratios.

This method only works when quantitation method protocol is Average. If protocol is not Average, calling the method has no effect.

In the Average protocol, protein intensities are calculated as the sum of the "top" peptide intensities assigned to the protein hit. If peptides are _identical_ then they all included but only count as one peptide for the purpose of determining the average. The selection mode determines how the peptides are compared to see if they should be treated as identical or not.

Whether to require the peptides to be used to be unique sequences (unique_sequence), or to accept different modification states of same sequence (unique_mr), or even accept peptides with same sequence and modifications in different charge states (unique_mz).

Parameters:
mode The way in which peptides are matched when selecting peptide intensities for the protein.
void setMinNumPeptides ( int value ) [inherited]

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters:
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.
void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [virtual, inherited]

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [virtual, inherited]

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  | [inherited]

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.
void setProteinRatioType ( const char * value ) [virtual, inherited]

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median".

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters:
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implements ms_quantitation.

void setQuantOutliers ( const ms_quant_outliers * qo ) [virtual, inherited]

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters:
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implements ms_quantitation.

The documentation for this class was generated from the following files:
  • ms_ms1quantitation.hpp
  • ms_ms1quantitation.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_ms2quantitation
Public Member Functions | Protected Member Functions | Protected Attributes

ms_ms2quantitation Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Peptide and protein quantitation in a Reporter or Multiplex Mascot results file. More...

#include <ms_ms2quantitation.hpp>

Inheritance diagram for ms_ms2quantitation:
[legend]
Collaboration diagram for ms_ms2quantitation:
[legend]

List of all members.

Public Member Functions

ms_ms2quantitation (const ms_peptidesummary &pepsum)
Default constructor: load the quantitation method from the results file and quantitate all peptides that pass the quality thresholds.
ms_ms2quantitation (const ms_peptidesummary &pepsum, const ms_quant_method &qm)
Quantitate all peptides that pass the quality thresholds using the given quantitation method.
virtual | ~ms_ms2quantitation ()
Destructor.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
void | excludeProteinPeptideRatioKeys (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &excludeKeys)
Excludes the passed peptide ratio values from the protein ratio calculation.
const ms_quant_ratio * | getCombinedReportRatio (const std::string &ratioName) const
Return a combined quantitation ratio matching the given name.
std::vector< std::string > | getCombinedReportRatioNames () const
Return a list of current combined report ratio names.
std::vector< double > | getComponentIntensities (const ms_peptide_quant_key &key, bool raw=false) const
Return the component intensities for the given peptide-spectrum match, if available.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
double | getIntensityNormalisationBase (const std::string &componentName) const
Get the intensity normalisation base of the given component name.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
const ms_quant_ratio * | getReportRatioFromFile (unsigned int fileNum, const std::string &ratioName) const
Return a quantitation ratio matching the given name in the given file.
std::vector< std::string > | getReportRatioNamesInFile (unsigned int fileNum) const
Return a list of current report ratio names in the given file.
bool | hasIntensityNormalisation () const
Return true if intensity normalisation is enabled and configured.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
bool | hasPeptideRatioNormalisation () const
Return true if peptide ratio normalisation is enabled and configured.
void | includeProteinPeptideRatioKeys (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys)
Includes the passed peptide ratio values in the protein ratio calculation.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
bool | loadCdbFile (const char *path)
Load user adjusted protein-peptide quantitation ratio settings from a cdb file.
bool | loadCdbFiles (const std::vector< std::string > &cdbFiles)
Merges the settings from multiple protein-peptide user selection cdbfiles.
void | normaliseIntensities ()
Normalise component intensities, or do nothing if intensity normalisation is disabled.
void | normalisePeptideRatios ()
Normalise peptide ratios, or do nothing if normalisation is disabled.
void | removeCombinedReportRatio (const std::string &ratioName)
Remove the combined quantitation ratio matching the given name from all files.
void | removeIntensityNormalisationBase (const std::string &componentName)
Reset the intensity normalisation base of the given ratio name.
void | removeIntensityNormalisationBases ()
Reset all Intensity normalisation bases.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
void | removeReportRatioInFile (unsigned int fileNum, const std::string &ratioName)
Remove the quantitation ratio matching the given name from the given file.
bool | saveCdbFile (const std::string &cdbFilename)
Save the user edited protein-peptide quantitation settings to a cdb file.
bool | saveXmlFile (const std::string &xmlFilename, bool completeReport)
Save the quantitation results to an XML file.
void | setCombinedReportRatio (const std::string &ratioName, const ms_quant_ratio &ratioDef)
Add or modify the combined quantitation ratio matching the given name in all files.
void | setIntensityNormalisationBase (const std::string &componentName, double b)
Set the intensity normalisation base of the given component name.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)
Set the protein ratio type.
void | setQuantNormalisation (const ms_quant_normalisation *norm)
Set new peptide and protein ratio normalisation settings.
virtual void | setQuantOutliers (const ms_quant_outliers *)
Set new peptide ratio outlier settings.
void | setReportRatioInFile (unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef)
Add or modify the quantitation ratio matching the given name in the given file.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t | proteinKeys_
Protein-to-peptide mapping.

Detailed Description

Peptide and protein quantitation in a Reporter or Multiplex Mascot results file.

ms_ms2quantitation implements a single use case: given a Mascot results file of a search whose quantitation protocol is Reporter (e.g. iTRAQ) or Multiplex (e.g. 18O), it will calculate, on demand, peptide and proteins ratios from component intensities extracted from the MS/MS spectra.

Peptide ratios are identified by q,p peptide quant keys (ms_peptide_quant_key(int q, int p)). Not all peptide matches in the results file have an associated peptide ratio; for example, the Reporter ions could be missing from the input query.

Protein ratios are identified by protein accession and database index. There are three types of ratio: median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is a weighted mean of peptide ratios, where the weights are channel intensities. The weighted ratio type is only available for Reporter data.

All values are read-only. If you need to edit anything, apart from protein ratio calculation settings, or if you need to use some other protocol, use ms_customquantitation instead.

The class supports all types of normalisation configurable in the quantitation method. However, you need to explicitly ask for the normalisation constants to be calculated (see normalisePeptideRatios()). This is because normalisation may require calculating peptide ratios for all quantifiable peptide matches in the results file, which can be a time-consuming operation. Thus, if you change parameters or ratio definitions, and normalisation is enabled, you will need to call normalisePeptideRatios() to recalculate the normalisation constants. (If normalisation is not enabled, there is no penalty in calling normalisePeptideRatios().)

You can skip the remainder of this section if you are not combining results files (see Combining multiple .dat files for background reading).

If the results file is a merged file, peptide ratios will be merged across the files in the following way. Imagine peptide ratios are arranged in a table, so that a row contains the report ratios for a particular peptide (q,p), and the columns are indexed by report ratio names. Each report ratio with a unique name becomes its own column. If a report ratio with the same name appears in more than one file, these are treated as the same column (regardless of whether the formulas are exactly the same).

There are three complications which you must address:

  1. Two report ratios with the same formula may not actually have the same name in different files (e.g. the iTRAQ 115/114 ratio is called "115/114" in one file but "Control" in another).
  2. Two report ratios with the same name may not actually have the same formulas in different files (e.g. the report ratio named "Control" in one file is not calculated the same way "Control" is in another).
  3. Two report ratios with the same name and same formula may mean different things in different files (e.g. "115/114" is control in one file, patient in another).

The solution is to modify report ratios in different files using setCombinedReportRatio(), so that the names, formulas and meanings match between files. Of course, if you want to keep ratios from different files separate, you need to rename ratios in each file (using setReportRatioInFile()) so that they are all different across all files.

Note the naming convention: methods with "InFile" (e.g. setReportRatioInFile()) modify report ratios in a single file (in the combined results file), while methods with "Combined" (e.g. setCombinedReportRatio()) modify report ratios across all files (in the combined results file).

Constructor & Destructor Documentation

ms_ms2quantitation ( const ms_peptidesummary & pepsum ) [explicit]

Default constructor: load the quantitation method from the results file and quantitate all peptides that pass the quality thresholds.

The constructor performs the following steps. If any of them fail, the corresponding error will be set and the object left in invalid state. Use isValid() to check for this and getLastErrorString() to fetch the error description:

  • Load the quantitation method from the results file. If the results file has no quantitation method, or it doesn't validate against the schema, the process ends here.
  • If protocol isn't Reporter or Multiplex, the process ends here. (Use ms_customquantitation instead, as outlined in Peptide and protein quantitation.)
  • Prepare combined report ratios, if the input file is a combined results file.

Note that the constructor will not normalise peptide ratios or component intensities automatically, even if normalisation is enabled and configured. You need to call normalisePeptideRatios() and normaliseIntensities().

Parameters:
pepsum Mascot results file to quantitate. Note that you must first validate the embedded XML sections of the results file. Either pass the schema directory to the ms_mascotresfile constructor or use ms_mascotresfile::setXMLschemaFilePath().
ms_ms2quantitation | ( | const ms_peptidesummary & | pepsum,
 |  | const ms_quant_method & | qm
 | ) |  |

Quantitate all peptides that pass the quality thresholds using the given quantitation method.

The constructor performs the following steps. If any of them fail, the corresponding error will be set and the object left in invalid state. Use isValid() to check for this and getLastErrorString() to fetch the error description:

  • Load the quantitation method from the results file. If the results file has no quantitation method, or it doesn't validate against the default quantitation schema, the process ends here.
  • If protocol isn't Reporter or Multiplex, the process ends here. (Use ms_customquantitation instead, as outlined in Peptide and protein quantitation.)
  • If the protocol or component definitions between the embedded quantitation method and qm do not match, as tested with ms_quant_method::isMethodCompatible(), the process ends here with an error.
  • Prepare combined report ratios, if the input file is a combined results file.

Note that the constructor will not normalise peptide ratios or component intensities automatically, even if normalisation is enabled and configured. You need to call normalisePeptideRatios() and normaliseIntensities().

Parameters:
pepsum | Mascot results file to quantitate. Note that you must first validate the embedded XML sections of the results file. Either pass the schema directory to the ms_mascotresfile constructor or use ms_mascotresfile::setXMLschemaFilePath().
qm | Quantitation method to use. The protocol and component definitions must match exactly those defined in the results file. It is best to use the return value from ms_mascotresfile::getQuantitationMethod() as the base and then alter peptide quality settings as needed.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.
ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected, inherited]

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const [virtual]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.

Reimplemented from ms_quantitation.

int countDistinctPeptides ( const ms_peptide_quant_key_vector & activeKeys ) const [virtual, inherited]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

This function just calls countDistinctPeptides(const ms_peptide_quant_key_vector &) (which should call the relevant ms_ms1quantitation or ms_ms2quantitation version.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.
void excludeProteinPeptideRatioKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  |

Excludes the passed peptide ratio values from the protein ratio calculation.

Sets the user excluded list of peptide ratio keys for the specified protein hit and ratio.

Parameters:
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
excludeKeys | The vector of peptide ratio keys to exclude
const ms_quant_ratio * getCombinedReportRatio ( const std::string & ratioName ) const

Return a combined quantitation ratio matching the given name.

Even if the report ratio formulas of ratio ratioName differ between the files, they are considered the same (merged in the same "column"), since they have the same name. This method returns the ratio definition from the first file (in numerical order) that has a definition with the name ratioName. You should always verify, using getReportRatioFromFile() and related methods, that the definitions with the same names are actually the same before relying on the return value of this method.

Parameters:
ratioName The name of the report ratio. This must match exactly (case sensitively) the desired report ratio name.
Returns:
If no such report ratio exists, this method returns NULL. Otherwise the corresponding object is returned.
std::vector< std::string > getCombinedReportRatioNames ( ) const

Return a list of current combined report ratio names.

This method returns the unique report ratio names across all files (i.e. the "columns" in the peptide ratio table).

Returns:
The list of combined report ratio names in the order they appear in each file. Duplicate ratio names are removed.
std::vector< double > getComponentIntensities | ( | const ms_peptide_quant_key & | key,
 |  | bool | raw = false
 | ) |  | const

Return the component intensities for the given peptide-spectrum match, if available.

In the Reporter protocol, component intensities are extracted from a given input spectrum q based on the presence of reporter ion peaks, regardless of which peptide was matched to the spectrum. In this case all peptide matches in the same query that pass the quality threshold will have the same component intensities.

In the Multiplex protocol, component intensity extraction requires both the input spectrum q and the peptide that was matched to it, identified by (q,p). In this case, if component intensity extraction succeeded, then you may get different component intensities (or none at all) for different values of p.

Parameters:
key | Peptide quant key created with ms_peptide_quant_key(int q, int p).
raw | (optional) If true, return raw intensities. Corrected intensities are returned by default. Note that if Reporter "sum" normalisation is in use, the corrected intensities will be normalised, whereas the raw intensities will not be.
Returns:
A vector of component intensities, in the same order as components are defined in the quantitation method. This can be empty if there is no component intensity data for the peptide-spectrum match or if it did not pass the quality thresholds.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
double getIntensityNormalisationBase ( const std::string & componentName ) const

Get the intensity normalisation base of the given component name.

Parameters:
componentName Name of one of the components defined in the quantitation method.
Returns:
The current intensity normalisation base, or 1 if it hasn't been set.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getMinNumPeptides ( ) const [protected, inherited]

Get the minimum number of peptides needed for protein ratio calculation.

Returns:
The minimum number of peptides needed for protein ratio calculation.
ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const [inherited]

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
Returns:
A vector of peptide quant keys associated with the protein.
ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implements ms_quantitation.

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const [inherited]

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName Peptide ratio name.
Returns:
The current peptide ratio normalisation base, or 1 if it hasn't been set.
const matrix_science::ms_progress_info & getProgressInfo ( ) [inherited]

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns:
Progress information about the most recent long operation.
ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const [virtual]

Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.

The protein ratio is calculated as described in getProteinRatio(const std::string &, int, const std::string &) const, but the two peptide quant key vectors includeKeys and excludeKeys can be used to override default decisions about globally excluded and outlier peptide ratios. The rules are as follows:

  1. If a peptide quant key is globally excluded with setPeptideRatioExcluded(), then giving the peptide quant key in includeKeys causes the peptide quant key to be included regardless ("undo global exclusion").
  2. If a peptide quant key is given in excludeKeys, then the peptide quant key will be always excluded ("exclude locally").

If the peptide quant key is in both includeKeys and excludeKeys, the latter takes precedence and the peptide quant key is excluded.

Note that if outlier detection is enabled, then a peptide quant key determined to be an outlier cannot be included back using includeKeys, i.e. the inclusion mechanism does not undo outlier removal. You can disable outlier removal entirely before calling getProteinRatio() if you do not want peptide quant keys to be removed.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, then the effect of excludeKeys depends on whether the peptide quant key describes a "top N" peptide intensity. If the peptide intensity is one of the top N intensities assigned to this protein, then excluding it means the next highest outside the top N intensities will take its place. No peptide quant keys will ever be excluded automatically as outliers, since outlier removal has no meaning in this protocol.

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
includeKeys | Peptide quant keys to always include, even if they are globally excluded or would be marked as outliers.
excludeKeys | Peptide quant keys to always exclude, even if they are not outliers.
Returns:
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implements ms_quantitation.

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

See ms_quantitation::getProteinRatio for further details of how the ratio is calculated

The list of any user included and excluded keys are retrieved from the result before being passed to the base class for processing. These will override the lists of keys set by setPeptideRatioExcluded() and setPeptideRatioIncluded() so that the same result can be obtained as was set when the results were calculated.

See also:
includeProteinPeptideRatioKeys()
excludeProteinPeptideRatioKeys()
Parameters:
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
Returns:
The match from the list of matches associated with the protein hit, or null if the index or match identifiers are invalid.

Implements ms_quantitation.

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const [protected, inherited]

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.
const ms_quant_method & getQuantitationMethod ( ) const [inherited]

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns:
The current quantitation method.
const ms_quant_ratio * getReportRatioFromFile | ( | unsigned int | fileNum,
 |  | const std::string & | ratioName
 | ) |  | const

Return a quantitation ratio matching the given name in the given file.

Parameters:
fileNum | Integer between 1 and ms_mascotresfile::getNumberOfResfiles().
ratioName | The name of the report ratio. This must match exactly (case sensitively) the desired report ratio name.
Returns:
If no such report ratio exists, this method returns NULL. Otherwise the corresponding object is returned.
std::vector< std::string > getReportRatioNamesInFile ( unsigned int fileNum ) const

Return a list of current report ratio names in the given file.

This method simply returns the names of the report ratios as defined in that file. This is the same order they are defined in the file's embedded quantitation method, unless the report ratios have been later changed with setReportRatioInFile() or setCombinedReportRatio().

Parameters:
fileNum Integer between 1 and ms_mascotresfile::getNumberOfResfiles().
Returns:
The list of report ratio names in file fileNum.
void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const [protected, virtual]

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters:
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implements ms_quantitation.

bool hasIntensityNormalisation ( ) const

Return true if intensity normalisation is enabled and configured.

You can enable and disable component intensity normalisation with setQuantNormalisation(). Note that only the "sum" normalisation is supported and only with the Reporter protocol.

If intensity normalisation is enabled, peptide ratio normalisation will be disabled, and vice versa.

Returns:
True if normalisation is enabled and configured, false otherwise.
bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio exists; false otherwise.

Implements ms_quantitation.

bool hasPeptideRatioNormalisation ( ) const

Return true if peptide ratio normalisation is enabled and configured.

You can enable and disable peptide ratio normalisation with setQuantNormalisation().

If intensity normalisation is enabled, peptide ratio normalisation will be disabled, and vice versa.

Returns:
True if normalisation is enabled and configured, false otherwise.
void includeProteinPeptideRatioKeys | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys
 | ) |  |

Includes the passed peptide ratio values in the protein ratio calculation.

Sets the user included list of peptide ratio keys for the specified protein hit and ratio.

Parameters:
accession | The accession of the protein.
dbIdx | The database the protein is from.
ratioName | The name of the ratio to calculate.
includeKeys | The vector of peptide ratio keys to include
bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  | [protected, inherited]

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters:
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns:
True.
bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [virtual]

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implements ms_quantitation.

bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool loadCdbFile ( const char * path )

Load user adjusted protein-peptide quantitation ratio settings from a cdb file.

Updates the user protein-peptide ratio inclusions and exclusions from the cdbfile, overwriting any selections already made. If there is a problem loading the file and the method returns false, check getLastError() for further details.

Parameters:
path The path to the cdbfile to load
Returns:
True if the cdbfile was valid and has been loaded, false if there was an error.
bool loadCdbFiles ( const std::vector< std::string > & cdbFiles )

Merges the settings from multiple protein-peptide user selection cdbfiles.

For multfile merged datasets, thie method will update the user protein-peptide ratio inclusions and exclusions from the cdbfiles, overwriting any selections already made. If there is a problem loading any of the cdb files, this method will return false. Check getLastError() for further details.

Parameters:
cdbFiles The paths of the cdb files to load
Returns:
True if all the cdb files were valid and have been loaded, false if there was an error.
void normaliseIntensities ( )

Normalise component intensities, or do nothing if intensity normalisation is disabled.

Component intensity normalisation will require loading query data for most or all queries in the file, which can be a time-consuming process. This is why normalisation is not performed automatically once the constructor finishes.

Note that if hasIntensityNormalisation() returns false, then this method does nothing.

void normalisePeptideRatios ( )

Normalise peptide ratios, or do nothing if normalisation is disabled.

Normalisation may require calculating all peptide ratios for all quantifiable peptide matches in the file, which can be a time-consuming process. This is why normalisation is not performed automatically once the constructor finishes. Automatic normalisation is also skipped when you change quantitation method parameters or report ratios, for the same reason.

Note that if hasPeptideRatioNormalisation() returns false, then this method does nothing.

void removeCombinedReportRatio ( const std::string & ratioName )

Remove the combined quantitation ratio matching the given name from all files.

The report ratio with name ratioName will be removed from all files where it is found. Other files remain unchanged.

Removing a combined report ratio does not alter normalisation constants, because the report ratio is removed from all files simultaneously (and because report ratios are independent of each other with respect to normalisation).

Parameters:
ratioName The name of the ratio to remove. If this is the empty string, nothing will be removed.
void removeIntensityNormalisationBase ( const std::string & componentName )

Reset the intensity normalisation base of the given ratio name.

Resetting means the component intensity normalisation constant is set to 1.0. This has the same effect as calling setIntensityNormalisationBase() with b = 1.

Resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normaliseIntensities() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters:
componentName Component name whose normalisation base is to be reset.
void removeIntensityNormalisationBases ( )

Reset all Intensity normalisation bases.

Resetting all intensity normalisation bases means all component intensities become unnormalised.

Resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normaliseIntensities() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

void removePeptideRatioNormalisationBase ( const std::string & ratioName ) [inherited]

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters:
ratioName Ratio name whose normalisation base is to be reset.
void removePeptideRatioNormalisationBases ( ) [inherited]

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

void removeReportRatioInFile | ( | unsigned int | fileNum,
 |  | const std::string & | ratioName
 | ) |  |

Remove the quantitation ratio matching the given name from the given file.

The report ratio with name ratioName will be removed from file fileNum, if it exists. Otherwise nothing is removed.

Removing a report ratio from one file resets its normalisation constant across the whole combined file. You will need to use normalisePeptideRatios() to (re)calculate it. If you are changing multiple report ratios at the same time, it is best to wait until all changes are done before calling normalisePeptideRatios(), as that way you only need to normalise once.

Parameters:
fileNum | Integer between 1 and ms_mascotresfile::getNumberOfResfiles().
ratioName | The name of the ratio to remove. If this is the empty string, nothing will be removed.
bool saveCdbFile ( const std::string & cdbFilename )

Save the user edited protein-peptide quantitation settings to a cdb file.

Distiller stores this in an MDRO project file (*.rov) in stream 0xC350+n where n is the value in the projectStream attribute of the QuantResult from the Quantitation folder.

The generated cdb file does not contain the complete quantitation report. It records only the details of any user selected or deselected protein-peptide quantitation ratios. If you wish to export the complete report, use the saveXmlFile() method instead.

Parameters:
cdbFilename The path and filename of the cdbfile to save
Returns:
True if the file was saved successfully.
bool saveXmlFile | ( | const std::string & | xmlFilename,
 |  | bool | completeReport
 | ) |  |

Save the quantitation results to an XML file.

Parameters:
xmlFilename | The path and filename of the file to save.
completeReport | True if a complete report of all data is to be generated, or false to generate concise report data.
Returns:
True if the file was saved successfully.
void setCombinedReportRatio | ( | const std::string & | ratioName,
 |  | const ms_quant_ratio & | ratioDef
 | ) |  |

Add or modify the combined quantitation ratio matching the given name in all files.

This method has does two things, in order:

  1. The report ratio with name ratioName is modified to match ratioDef in all files where it is found.
  2. A new report ratio will be added to files which don't have a report ratio with name ratioName.

Afterwards, all files will have a report ratio definition matching ratioDef, which will be merged in one "column" (since its name is the same in all files).

Note that the name defined in ratioDef can differ from ratioName. There are two use cases:

  1. Adding a new definition: set ratioName to the name of a report ratio that does not yet exist and ratioDef to the definition itself.
    • The name set in ratioDef is ignored.
  2. Updating, replacing and renaming a definition: set ratioName to the name of an existing report ratio and pass in ratioDef.
    • If ratioDef name is empty or equals ratioName, then the existing definition will be updated.
    • If ratioDef name differs from ratioName, then the existing definition will be replaced with ratioDef. (If the body of ratioDef is the same as before, this is a rename and otherwise a replace operation.)

Note that if ratioName is the empty string, this method does nothing and returns immediately.

Changing a combined report ratio resets all normalisation constants -- that is, peptide ratios become unnormalised. Use normalisePeptideRatios() to recalculate the normalisation constants.

Parameters:
ratioName | The name of the ratio to replace, or the name of the new ratio to add. If this is the empty string, a new report ratio will be added.
ratioDef | The ratio definition.
void setIntensityNormalisationBase | ( | const std::string & | componentName,
 |  | double | b
 | ) |  |

Set the intensity normalisation base of the given component name.

Setting component intensity normalisation to a particular value means all peptide ratios calculated from componentName will be affected. However, the underlying compnent intensities remain unaffected, which means this method will always return immediately without computing anything.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

You can always set b to 1 to disable component intensity componentName normalisation.

Parameters:
componentName | Component name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.
void setMinNumPeptides ( int value ) [inherited]

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters:
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.
void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [virtual]

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [virtual]

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implements ms_quantitation.

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  | [inherited]

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.
void setProteinRatioType ( const char * value ) [virtual]

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median".

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters:
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implements ms_quantitation.

void setQuantNormalisation ( const ms_quant_normalisation * norm )

Set new peptide and protein ratio normalisation settings.

Peptide and protein ratios can be normalised in several ways. Please consult the quantitation configuration help page for details. Changing ratio normalisation settings may involve a delay as the normalisation base is computed from ratio data.

Changing normalisation settings changes the current quantitation method. It does not alter the original quantitation method object.

Changing the settings resets all normalisation constants -- that is, peptide ratios become unnormalised. Use normalisePeptideRatios() to recalculate the normalisation constants.

Parameters:
norm A normalisation configuration object. If this is NULL, normalisation will be disabled (equivalent to "none").
void setQuantOutliers ( const ms_quant_outliers * qo ) [virtual]

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters:
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implements ms_quantitation.

void setReportRatioInFile | ( | unsigned int | fileNum,
 |  | const std::string & | ratioName,
 |  | const ms_quant_ratio & | ratioDef
 | ) |  |

Add or modify the quantitation ratio matching the given name in the given file.

This method does two things, in order:

  1. The report ratio with name ratioName in file fileNum is modified to match ratioDef, if it exists.
  2. Otherwise a new report ratio will be added to file fileNum.

The new report ratio will be merged with report ratios from other files if its name matches any other report ratio's name.

Note that the name defined in ratioDef can differ from ratioName. There are two use cases:

  1. Adding a new definition: set ratioName to the name of a report ratio that does not yet exist in this file and ratioDef to the definition itself.
    • The name set in ratioDef is ignored.
  2. Updating, replacing and renaming a definition: set ratioName to the name of an existing report ratio and pass in ratioDef.
    • If ratioDef name is empty or equals ratioName, then the existing definition will be updated.
    • If ratioDef name differs from ratioName, then the existing definition will be replaced with ratioDef. (If the body of ratioDef is the same as before, this is a rename and otherwise a replace operation.)

Note that if ratioName is the empty string, this method does nothing and returns immediately.

Changing a report ratio resets its normalisation constant across the whole combined file, while a fresh report ratio starts out with a constant of 1.0. You will need to use normalisePeptideRatios() to (re)calculate it. If you are changing multiple report ratios at the same time, it is best to wait until all changes are done before calling normalisePeptideRatios(), as that way you only need to normalise once.

Parameters:
fileNum | Integer between 1 and ms_mascotresfile::getNumberOfResfiles().
ratioName | The name of the ratio to replace, or the name of the new ratio to add. If this is the empty string, a new report ratio will be added.
ratioDef | The ratio definition.
The documentation for this class was generated from the following files:
  • ms_ms2quantitation.hpp
  • ms_ms2quantitation.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


  • matrix_science
  • ms_peptide_quant_key
Public Member Functions

ms_peptide_quant_key Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Feature key identifying a peptide ratio. More...

#include <ms_peptide_quant_key.hpp>

List of all members.

Public Member Functions

ms_peptide_quant_key ()
Create a nil peptide quant key.
ms_peptide_quant_key (int q, int p)
Create a peptide quant key corresponding to a peptide match.
ms_peptide_quant_key (int ID)
Create a peptide quant key corresponding to an integer ID.
ms_peptide_quant_key (const std::string &opaqueString)
Create a peptide quant key corresponding to an opaque string.
ms_peptide_quant_key (int q, int p, int charge)
Create a peptide quant key corresponding to a peptide match with a specified charge state.
ms_peptide_quant_key (const std::string &opaqueString, int ID)
Create a peptide quant key corresponding to an opaque string and an integer ID.
ms_peptide_quant_key (const ms_peptide_quant_key &src)
Copying constructor.
~ms_peptide_quant_key ()
Destructor.
bool | getCharge (int &charge) const
Return the charge of the peptide associated with this peptide quant key, if available.
bool | getID (int &ID) const
Return the integer ID of this peptide quant key, if available.
bool | getOpaqueString (std::string &opaqueStringRef) const
Return the opaque string of this peptide quant key, if available.
bool | getOpaqueStringAndID (std::string &opaqueStringRef, int &ID) const
Return the opaque string of this peptide quant key, if available.
bool | getQueryAndRank (int &q, int &p) const
Return the query number and rank of the peptide associated with this peptide quant key, if available.
bool | isNil () const
Return true if the peptide key is the nil key.
bool | operator!= (const ms_peptide_quant_key &right) const
C++ inequality.
bool | operator< (const ms_peptide_quant_key &right) const
C++ strict weak ordering.
bool | operator<= (const ms_peptide_quant_key &right) const
C++ strict weak ordering.
ms_peptide_quant_key & | operator= (const ms_peptide_quant_key &right)
C++ assignment operator.
bool | operator== (const ms_peptide_quant_key &right) const
C++ equality.
bool | operator> (const ms_peptide_quant_key &right) const
C++ strict weak ordering.
bool | operator>= (const ms_peptide_quant_key &right) const
C++ strict weak ordering.

Detailed Description

Feature key identifying a peptide ratio.

A peptide ratio is a ratio of component intensities. The components can be reporter ions, XICs from different runs, or something else depending on quantitation protocol. In each case, the peptide ratio is identified by a particular set of features, which are encapsulated in its peptide quant key.

Sometimes there is a one-to-one mapping between identified peptides and peptide ratios, such as in the Multiplex protocol (e.g. SILAC), or between input spectra and peptide ratios, such as the Reporter protocol (e.g. iTRAQ). In this case the peptide quant key can be the query number and peptide rank (ms_peptide_quant_key(int q, int p)).

In the general case, the peptide quant key can be a free-form string (ms_peptide_quant_key(const std::string &opaqueKey)) or any integer ID (ms_peptide_quant_key(int ID)). The string is not interpreted by the constructor; in other words it is considered opaque.

C++ only: The class specifies a full strict weak ordering, which means ms_peptide_quant_key objects can be used as STL map and set keys.

Perl and Python only: Ensure all parameters passed to the constructor are cast to the right type. Both Perl and Python tend to convert variables internally to strings, and even if the string value looks like a number, it may not be converted to an integer when the constructor is called. This is because the constructors differ only by type, and the string version tends to be chosen by default. For example, the Perl code

     my $key = msparser::ms_peptide_quant_key->new($q, $p);

can choose either ms_peptide_quant_key(int, int) or ms_peptide_quant_key(const std::string &, int), depending on whether $q has ever been used in string context. To use the correct q,p form, cast both arguments to integers:

     my $key = msparser::ms_peptide_quant_key->new(0+$q, 0+$p);

Constructor & Destructor Documentation

ms_peptide_quant_key ( )

Create a nil peptide quant key.

The nil peptide quant key is equivalent to the zero value. All other peptide quant keys are "larger" than the nil key.

ms_peptide_quant_key | ( | int | q,
 |  | int | p
 | ) |  |

Create a peptide quant key corresponding to a peptide match.

Use case: the peptide ratio is derived from a single peptide match, such as in Multiplex (e.g. SILAC) and Reporter (e.g. iTRAQ). The query and rank refer to the query and rank in a Mascot results file.

Parameters:
q | Peptide query.
p | Peptide rank.
ms_peptide_quant_key | ( | int | q,
 |  | int | p,
 |  | int | charge
 | ) |  |

Create a peptide quant key corresponding to a peptide match with a specified charge state.

Use case: the peptide ratio is linked to an identified peptide and a particular charge state.

Parameters:
q | Peptide query.
p | Peptide rank.
charge | Charge state.
ms_peptide_quant_key ( int ID ) [explicit]

Create a peptide quant key corresponding to an integer ID.

Use case: each peptide ratio has a unique integer ID.

Parameters:
ID The peptide ratio ID.
ms_peptide_quant_key ( const std::string & opaqueString ) [explicit]

Create a peptide quant key corresponding to an opaque string.

Use case: each peptide ratio has a unique string ID.

The string ID is opaque in the sense that this class will not try to parse it. This means that even if the string ID encoded query, rank or charge, the corresponding accessor methods will not return parsed values.

Parameters:
opaqueString The peptide ratio ID.
ms_peptide_quant_key | ( | const std::string & | opaqueString,
 |  | int | ID
 | ) |  | [explicit]

Create a peptide quant key corresponding to an opaque string and an integer ID.

Use case: each peptide ratio has a unique string and interger ID pair. This could be used for example when combining multiple Distiller XML files where the opaqueString might be the name of the Fxxxxx.dat file and the ID is the would be the id attribute value in the peptideMatch element. The combination of the two values will therefore be unique.

The string opaqueString is opaque in the sense that this class will not try to parse it.

Parameters:
opaqueString | with 'user defined' meaning.
ID | is a user defined integer.

Member Function Documentation

bool getCharge ( int & charge ) const

Return the charge of the peptide associated with this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

Charge is only available if the peptide quant key was constructed with the query, rank and charge constructor.

Parameters:
[out] charge Charge state.
Returns:
True if the peptide quant key is based on query, rank and charge; false otherwise. If this method returns false, then charge is set to -1.
bool getID ( int & ID ) const

Return the integer ID of this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

Integer ID is only available if the peptide quant key was constructed with the integer ID constructor.

Parameters:
[out] ID Integer ID of the peptide quant key.
Returns:
True if the peptide quant key is based on integer IDs; false otherwise. If this method returns false, then ID is set to -1.
bool getOpaqueString ( std::string & opaqueStringRef ) const

Return the opaque string of this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

String ID is only available if the peptide quant key was constructed with the string ID constructor.

Parameters:
[out] opaqueStringRef The opaque string on which the feature ID is based. When calling from Java, use a StringBuffer for this parameter.
Returns:
True if the peptide quant key is based on an opaque string; false otherwise. If this method returns false, opaqueStringRef is set to the empty string.
bool getOpaqueStringAndID | ( | std::string & | opaqueStringRef,
 |  | int & | ID
 | ) |  | const

Return the opaque string of this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

opaqueString and ID are only available if the peptide quant key was constructed with a constructor specifying the opaqueString and/or integer ID.

Parameters:
[out] | opaqueStringRef | The opaque string on which the feature ID is based. When calling from Java, use a StringBuffer for this parameter.
[out] | ID | is the integer ID on which the feature ID is based.
Returns:
True if the peptide quant key is based on an opaque string and/or an integer ID; false otherwise. If this method returns false, opaqueStringRef is set to the empty string and ID is set to -1.
bool getQueryAndRank | ( | int & | q,
 |  | int & | p
 | ) |  | const

Return the query number and rank of the peptide associated with this peptide quant key, if available.

See Multiple return values in Perl, Java, Python and C#.

Query and rank are only available if the peptide quant key was constructed with the query and rank constructor, or the query, rank and charge constructor.

Parameters:
[out] | q | Query number of the peptide quant key.
[out] | p | Rank of the peptide quant key.
Returns:
True if the peptide quant key is based on query and rank; false otherwise. If this method returns false, both q and p are set to -1.
The documentation for this class was generated from the following files:
  • ms_peptide_quant_key.hpp
  • ms_peptide_quant_key.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_peptide_quant_key_vector
Public Member Functions

ms_peptide_quant_key_vector Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A vector of peptide quant keys. More...

#include <ms_peptide_quant_key_vector.hpp>

List of all members.

Public Member Functions

ms_peptide_quant_key_vector ()
Create an empty peptide quant key vector.
ms_peptide_quant_key_vector (const std::vector< ms_peptide_quant_key > &v)
Create a peptide quant key vector from an STL vector.
ms_peptide_quant_key_vector (const ms_peptide_quant_key_vector &src)
Copying constructor.
ms_peptide_quant_key_vector (const std::list< ms_peptide_quant_key > &v)
Create a peptide quant key vector from an STL list.
~ms_peptide_quant_key_vector ()
Destructor.
void | append (const ms_peptide_quant_key_vector &src)
Appends all content from another instance of the class.
void | clear ()
Clear the vector.
void | copyFrom (const ms_peptide_quant_key_vector *src)
Copies all content from another instance of the class.
bool | empty () const
Boolean test: is the vector empty?
ms_peptide_quant_key | get (int idx) const
Return the peptide quant key at the given index.
ms_peptide_quant_key_vector & | operator= (const ms_peptide_quant_key_vector &right)
C++ assignment operator.
ms_peptide_quant_key pop ()
Pop a value from the end of the vector.
void | push (const ms_peptide_quant_key &key)
Push a new peptide quant key at the end of the vector.
void | set (int idx, const ms_peptide_quant_key &key)
Set the value at the given index.
int | size () const
Return the size of the container.
void | swap (ms_peptide_quant_key_vector &right)
Swap the contents with another peptide quant key vector.
const std::vector
< ms_peptide_quant_key > & 		toVector () const
C++ conversion to std::vector.

Detailed Description

A vector of peptide quant keys.

ms_peptide_quant_key_vector is a wrapper around the C++ vector class std::vector, specialised to contain ms_peptide_quant_key objects. The ms_quantitation and ms_protein_quant_ratio classes return such peptide quant key vectors.

The interface to this class follows that of vectori and vectorString, as described in Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Constructor & Destructor Documentation

ms_peptide_quant_key_vector ( const std::vector< ms_peptide_quant_key > & v ) [explicit]

Create a peptide quant key vector from an STL vector.

Note:
This constructor can only be used from C++.
Parameters:
v STL vector to initialise with.
ms_peptide_quant_key_vector ( const std::list< ms_peptide_quant_key > & v ) [explicit]

Create a peptide quant key vector from an STL list.

Note:
This constructor can only be used from C++.
Parameters:
v STL list to initialise with.

Member Function Documentation

void append ( const ms_peptide_quant_key_vector & src )

Appends all content from another instance of the class.

Parameters:
src is another ms_peptide_quant_key_vector to append the keys from.
void clear ( )

Clear the vector.

After clear, the vector will be empty.

bool empty ( ) const

Boolean test: is the vector empty?

Returns:
True if the vector is empty (has size 0); false otherwise.
ms_peptide_quant_key get ( int idx ) const

Return the peptide quant key at the given index.

To use this function from R, call getKey(int idx) instead

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception.

Parameters:
idx The element index, 0..size()-1.
Returns:
The element at the corresponding index.
ms_peptide_quant_key pop ( )

Pop a value from the end of the vector.

Note that the vector must be nonempty (it must contain at least one element). If it doesn't, the method throws an exception.

Returns:
The value popped from the end of the vector.
void push ( const ms_peptide_quant_key & key )

Push a new peptide quant key at the end of the vector.

Parameters:
key Key to append to the vector.
void set | ( | int | idx,
 |  | const ms_peptide_quant_key & | key
 | ) |  |

Set the value at the given index.

Note that idx must be within the 0-indexed range. Otherwise the method will throw an exception. If you need to extend the vector, use push().

Parameters:
idx | The element index, 0..size()-1.
key | The new value to be set at that index.
int size ( ) const

Return the size of the container.

Returns:
The number of elements in the vector, or 0 if the vector is empty.
void swap ( ms_peptide_quant_key_vector & src )

Swap the contents with another peptide quant key vector.

After this method returns, the data of src is stored inside this object, and src stores the old contents of this object.

Parameters:
src Peptide quant key vector to swap contents with.
const std::vector< ms_peptide_quant_key > & toVector ( ) const

C++ conversion to std::vector.

Note:
This method can only be used from C++.
Returns:
A copy of the peptide quant key vector as an STL vector.
The documentation for this class was generated from the following files:
  • ms_peptide_quant_key_vector.hpp
  • ms_peptide_quant_key.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_peptide_quant_ratio
Public Member Functions

ms_peptide_quant_ratio Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Peptide abundance in one component relative to another in a quantitation experiment. More...

#include <ms_peptide_quant_ratio.hpp>

Collaboration diagram for ms_peptide_quant_ratio:
[legend]

List of all members.

Public Member Functions

ms_peptide_quant_ratio (const ms_peptide_quant_key &key, const std::string &ratioName, bool isInfinite=false)
Default constructor: create an infinite or undefined ("missing") peptide ratio associated with a particular peptide quant key and a ratio name.
ms_peptide_quant_ratio (const ms_peptide_quant_key &key, const std::string &ratioName, double value, bool isExcluded=false, double weight=1.0)
Create a peptide ratio associated with a particular peptide quant key and ratio name.
ms_peptide_quant_ratio (const ms_peptide_quant_ratio &src)
Copying constructor.
~ms_peptide_quant_ratio ()
Destructor.
void | copyFrom (const ms_peptide_quant_ratio *src)
Copies all content from another instance of the class.
ms_peptide_quant_key | getKey () const
Return the peptide quant key associated with this peptide ratio.
std::string | getRatioName () const
Return the name of the peptide ratio.
double | getValue () const
Return the numerical value of the ratio.
double | getWeight () const
Return the weighting factor of the peptide ratio, or 1.0 if not set.
bool | isExcluded () const
Boolean flag: is this peptide ratio excluded from protein ratio calculation?
bool | isInfinite () const
Boolean flag: is this ratio infinite?
bool | isMissing () const
Boolean flag: is this ratio undefined ("missing")?
ms_peptide_quant_ratio & | operator= (const ms_peptide_quant_ratio &right)
C++ assignment operator.

Detailed Description

Peptide abundance in one component relative to another in a quantitation experiment.

Peptide ratios can be calculated in many different ways depending on quantitation protocol. This class is merely a container of numerical values. It does not contain information about the quantitation method, protocol or parameters used in deriving the component intensities or the calculating ratio.

Each peptide ratio must be associated with a particular peptide quant key. For Reporter, this is the query number; for Multiplex, the query and rank of the identified peptide; and for other protocols, the peptide quant key can be a combination of peptide features. Query and rank refer to the standard Mascot convention, where query is the index of an input spectrum and rank is the index of an identified peptide matching the input spectrum.

Each peptide ratio object is associated with a ratio name. The ratio name is the name of a report ratio in a particular quantitation experiment. This can be any free form text, for example "115/114" or "control/diseased".

A peptide ratio may have an optional weighting factor, which by default is 1.0. Weighting factors are used in protein ratio calculation by ms_customquantitation.

Constructor & Destructor Documentation

ms_peptide_quant_ratio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName,
 |  | bool | isInfinite = false
 | ) |  |

Default constructor: create an infinite or undefined ("missing") peptide ratio associated with a particular peptide quant key and a ratio name.

An infinite or undefined ("missing") ratio is always excluded from protein ratio calculations. The return value of getValue() is undefined.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio, e.g. "115/114".
isInfinite | If false (default), this peptide ratio is undefined ("missing"); if true, it is infinite. Use ms_peptide_quant_ratio(const ms_peptide_quant_key&, std::string, double, bool) to construct a finite peptide ratio.
ms_peptide_quant_ratio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName,
 |  | double | value,
 |  | bool | isExcluded = false,
 |  | double | weight = 1.0
 | ) |  |

Create a peptide ratio associated with a particular peptide quant key and ratio name.

If value is negative or 0, isExcluded will always be set to true, regardless of the argument value.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio, e.g. "115/114".
value | The numerical value of this ratio. Usually ratios should be positive, but it is possible to give 0 or a negative value. Interpretation of such values is the caller's responsibility.
isExcluded | (optional) If false (default for positive ratios), the peptide ratio can be included in protein ratio calculation; otherwise it should be excluded.
weight | (optional) Weighting factor to use in weighted protein ratio calculation.

Member Function Documentation

bool isExcluded ( ) const

Boolean flag: is this peptide ratio excluded from protein ratio calculation?

If isInfinite() or isMissing() is true, so is the return value of this function. Otherwise, for a finite ratio, exclusion can depend on e.g. if the ratio is an outlier.

Returns:
True if this peptide ratio should be excluded from protein ratio calculations.
bool isInfinite ( ) const

Boolean flag: is this ratio infinite?

Infinite ratios can arise if the denominator is zero. Note that an infinite ratio is considered defined (not "missing"); that is, isMissing() will return false, even if the value is infinite.

If this method returns true, the return value of getValue() is undefined.

Returns:
True if the ratio is infinite; false otherwise.
bool isMissing ( ) const

Boolean flag: is this ratio undefined ("missing")?

The ratio can be undefined ("missing") if there is not enough data to calculate it. If this method returns true, the values of isInfinite() and getValue() are undefined.

Returns:
True if the ratio is missing; false otherwise.
The documentation for this class was generated from the following files:
  • ms_peptide_quant_ratio.hpp
  • ms_quant_ratios.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_progress_info
Public Types | Public Member Functions

ms_progress_info Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Contains information of the current progress of a task being performed. More...

#include <ms_progress_info.hpp>

List of all members.

Public Types

enum STATUS {
S_NOT_STARTED,
S_RUNNING,
S_RUNNING_INDETERMINATE,
S_STOPPED_FAIL,
S_STOPPED_BREAK,
S_STOPPED_COMPLETE
}

Enum containing progress status information values.

More...

Public Member Functions

ms_progress_info ()
Default constructor; for standard library collections.
ms_progress_info (const std::string &description, size_t total)
Constructor.
~ms_progress_info ()
Destructor.
ms_progress_info * | addSubtask (const std::string &description, size_t total)
Adds a subtask with the specified description and total number of items.
void | addSubtask (const ms_progress_info *task)
Adds the passed ms_progress_info item as a subtask.
void | clear (const std::string &description="", size_t total=0)
Clear any existing progress information ready to start a new long running operation using the same process names.
const std::string & | getDescription () const
Returns the task description.
int | getNumberOfSubtasks () const
Returns the total number of child ms_progress_info objects associated directly with the ms_progress_info instance.
size_t | getProgress () const
Returns the number of work items currently completed by the process running the task.
STATUS | getStatus () const
Gets the current ms_progress_info::STATUS associated with the task.
const ms_progress_info * | getSubtaskProgress (int index) const
Returns the child ms_progress_info object at the specified index.
size_t | getTotal () const
Returns the total number of work items the task is expected to complete.
bool | isBreaking () const
Returns whether or not a break request has been made by the user/client software.
void | removeSubtask (int index)
Removes and deletes the child ms_progress_info object at the specified index.
void | setBreak () const
Sends a break/cancel request to this and all child ms_progress_info tasks.
void | updateBreak ()
Updates the status to a break state.
void | updateComplete ()
Updates the status to a completed state.
void | updateFail ()
Updates the status to a fail state.
void | updateIndeterminate ()
Updates the status to an indeterminate running state.
void | updateProgress (size_t progress, size_t total)
Updates the current progress and total number of work items with the passed values.

Detailed Description

Contains information of the current progress of a task being performed.

If there are sub-jobs that are carried out then these are represented as child objects.

Member Enumeration Documentation

enum STATUS

Enum containing progress status information values.

Enumerator:
S_NOT_STARTED

Task has not started.

S_RUNNING

Task is currently running.

S_RUNNING_INDETERMINATE

Task is running but progress is indeterminate.

S_STOPPED_FAIL

Task failed.

S_STOPPED_BREAK

Task was cancelled by the user.

S_STOPPED_COMPLETE

Task completed successfully.

Constructor & Destructor Documentation

ms_progress_info | ( | const std::string & | description,
 |  | size_t | total
 | ) |  |

Constructor.

Creates a new ms_progress_info object with the specified description and total number of items

Parameters:
description | The task description associated with the generated ms_progress_info object
total | The total number of jobs the task will complete
~ms_progress_info ( )

Destructor.

The desctrutor deletes all subtasks that it has created

If a subtask has been created by calling addSubtask(const std::string & description, size_t) then the object will be deleted here by the parent object.

If an ms_progress_info object was created separately, and then added as a subtask, by calling: addSubtask(const ms_progress_info *), then it won't be deleted in this destructor. It's up to the code that created it to perform the deletion after any object(s) it was added to have been deleted.

Member Function Documentation

const std::string & getDescription ( ) const

Returns the task description.

Returns:
The task description
int getNumberOfSubtasks ( ) const

Returns the total number of child ms_progress_info objects associated directly with the ms_progress_info instance.

Only the number of direct child items is returned.

Returns:
The number of child ms_progress_info objects
size_t getProgress ( ) const

Returns the number of work items currently completed by the process running the task.

See also:
getTotal()
Returns:
The number of items the task has completed.
ms_progress_info::STATUS getStatus ( ) const

Gets the current ms_progress_info::STATUS associated with the task.

Returns:
The current status of the task associated with the ms_progress_info object
const ms_progress_info * getSubtaskProgress ( int index ) const

Returns the child ms_progress_info object at the specified index.

See also:
getNumberOfSubtasks()
Parameters:
index The index of the subtask to return. Must be in the range 1 .. getNumberOfSubtasks()
Returns:
The ms_progress_info object at the specified index, or NULL is the passed value of index is invalid.
size_t getTotal ( ) const

Returns the total number of work items the task is expected to complete.

See also:
getProgress()
Returns:
The total number of items the task is expected to complete
void setBreak ( ) const

Sends a break/cancel request to this and all child ms_progress_info tasks.

Use from the client code to request that a long running process is cancelled. It is the responsibility of the process running the task to honour the break request.

The documentation for this class was generated from the following files:
  • ms_progress_info.hpp
  • ms_progress_info.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_protein_quant_ratio
Public Member Functions

ms_protein_quant_ratio Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios. More...

#include <ms_protein_quant_ratio.hpp>

List of all members.

Public Member Functions

ms_protein_quant_ratio (const std::string &accession, int dbIdx, const std::string &ratioName)
ms_protein_quant_ratio (const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, unsigned int sampleSize)
ms_protein_quant_ratio (const ms_protein_quant_ratio &src)
Copying constructor.
~ms_protein_quant_ratio ()
Destructor.
void | copyFrom (const ms_protein_quant_ratio *src)
Copies all content from another instance of the class.
std::string | getAccession () const
Return the protein accession associated with this ratio.
ms_peptide_quant_key_vector | getActiveKeys () const
Return the peptide quant keys used in calculating the protein ratio.
int | getDB () const
Return the protein database index associated with this ratio.
ms_peptide_quant_key_vector | getExcludedKeys () const
Return peptide quant keys associated with the protein accession that were skipped due to being excluded from protein ratio calculation.
double | getHypothesisPvalue () const
Return the p-value of this protein ratio under the null hypothesis.
double | getHypothesisPvalue (std::string &whyUnavailable) const
Return the p-value of this protein ratio under the null hypothesis.
double | getNormalityPvalue () const
Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.
double | getNormalityPvalue (std::string &whyUnavailable) const
Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.
ms_peptide_quant_key_vector | getOutlierKeys () const
Return peptide quant keys associated with the protein accession that were excluded due to being outliers.
std::string | getRatioName () const
Return the name of the ratio.
unsigned int | getSampleSize () const
Return the size of the sample of peptide ratios used in deriving this protein ratio.
ms_peptide_quant_key_vector | getSkippedKeys () const
Return peptide quant keys associated with the protein accession that were skipped due to being negative or infinite.
double | getStandardDeviation (std::string &whyUnavailable) const
Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.
double | getStandardDeviation () const
Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.
double | getStandardError () const
Return the standard error of the protein ratio, calculated from the standard deviation of the sample.
double | getStandardError (std::string &whyUnavailable) const
Return the standard error of the protein ratio, calculated from the standard deviation of the sample.
double | getValue () const
Return the numerical value of the ratio.
bool | isLogNormal (double threshold=0.05) const
Boolean flag: do the peptide ratios used in calculating this protein ratio appear to be (log)normally distributed?
bool | isMissing () const
Boolean flag: is this ratio defined?
bool | isSignificant (double threshold=0.05) const
Boolean flag: is the protein ratio statistically significantly different from the null hypothesis?
bool | operator!= (const ms_protein_quant_ratio &right) const
C++ inequality.
ms_protein_quant_ratio & | operator= (const ms_protein_quant_ratio &right)
C++ assignment operator.
bool | operator== (const ms_protein_quant_ratio &right) const
C++ equality.

Detailed Description

Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios.

A protein ratio in Mascot is calculated from a sample of peptide ratios, where the peptides form a subset of identified peptides associated with a given protein accession; not all identified peptides have ratios. Protein ratios are usually calculated by ms_quantitation and classes derived from it.

Each protein ratio must be associated with a particular protein accession, database index and ratio name. The database index refers to databases used in a Mascot search, and can be 0 if the protein accession does not arise from a Mascot search. The ratio name is the name of a report ratio in a particular quantitation experiment. This can be any free form text, for example "115/114" or "control/diseased", defined in the quantitation method.

This class is merely a container of numerical values. It does not contain information how the protein ratio was calculated from peptide ratios, nor what kind of statistical significance testing was done, if any.

The following conventions are followed:

  • If the ratio is undefined ("missing"), the value, sample size, standard deviation and p-values are meaningless. They will be set to 0 or false, whichever is appropriate.
  • If sample size is 1, standard deviation must be 0. (This is by definition of how standard deviation is calculated.) If standard deviation could not be calculated for some other reason, it must be -1.
  • A negative p-value means no hypothesis testing was conducted. A value of 0 is implausibly small and should be disregarded.

Constructor & Destructor Documentation

ms_protein_quant_ratio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  |
Parameters:
accession | The protein accession associated with this ratio.
dbIdx | The database index associated with this ratio, usually related to databases used in a Mascot search.
ratioName | The name of the ratio, e.g. "115/114".
ms_protein_quant_ratio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | double | value,
 |  | double | stdev,
 |  | double | stderror,
 |  | double | hypothesisPvalue,
 |  | double | normalityPvalue,
 |  | unsigned int | sampleSize
 | ) |  |
Parameters:
accession | The protein accession associated with this ratio.
dbIdx | The database index associated with this ratio, usually related to databases used in a Mascot search.
ratioName | The name of the ratio, e.g. "115/114".
value | The numerical value of this ratio. Usually ratios should be positive, but it is possible to give 0 or a negative value. Interpretation of such values is the caller's responsibility.
stdev | The sample standard deviation of the ratio, based on the peptide ratios. Use 0 if sample size is 1, and -1 if it is unavailable.
stderror | The standard error of the protein ratio, based on the standard deviation and sample size. Use 0 if sample size is 1, and -1 if it is unavailable.
hypothesisPvalue | The p-value of a hypothesis test about this protein ratio. Use -1 if it is unavailable.
normalityPvalue | The p-value that the peptide ratios appear to be normally (lognormally) distributed. Use -1 if it is unavailable.
sampleSize | The sample size, which must be at least 1. Use the constructor for the undefined ("missing") protein ratio if sample size is 0.

Member Function Documentation

ms_peptide_quant_key_vector getActiveKeys ( ) const

Return the peptide quant keys used in calculating the protein ratio.

Returns:
The vector of peptide quant keys used in calculating this protein ratio. The vector has either size zero or its size is the sample size, depending on which constructor was used to create the protein ratio object.
ms_peptide_quant_key_vector getExcludedKeys ( ) const

Return peptide quant keys associated with the protein accession that were skipped due to being excluded from protein ratio calculation.

A peptide ratio may be excluded manually from peptide ratio calculation, for reasons other than having negative value or being an outlier. For example, visual inspection may reveal the quality of a particular peptide ratio may be too poor, and that peptide ratio is excluded from all protein ratio calculation. The peptide quant key of the ratio would then appear here if it is associated with this protein ratio.

Returns:
vector of excluded keys
double getHypothesisPvalue ( ) const

Return the p-value of this protein ratio under the null hypothesis.

Note that you need to know how the protein ratio was calculated, what statistical assumptions have been made and what the null hypothesis is as well as what statistic the protein ratio is compared against, to interpret the meaning of the p-value.

Python: note that the name of this method in Python is getHypothesisPvalue_only().

Returns:
The p-value of this protein ratio under some hypothesis. A negative value (-1) means hypothesis testing was not conducted or the p-value could not be calculated.
double getHypothesisPvalue ( std::string & whyUnavailable ) const

Return the p-value of this protein ratio under the null hypothesis.

Same functionality as getHypothesisPvalue(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

     my $str = ''; # ensure the variable is defined
     my $pvalue = $ratio->getHypothesisPvalue($str);
Parameters:
whyUnavailable If p-value is unavailable, the reason is returned in this string argument.
Returns:
The p-value of this protein ratio under some hypothesis. A negative value (-1) means hypothesis testing was not conducted or the p-value could not be calculated.
double getNormalityPvalue ( std::string & whyUnavailable ) const

Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.

Same functionality as getNormalityPvalue(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

     my $str = ''; # ensure the variable is defined
     my $pvalue = $ratio->getNormalityPvalue($str);
Parameters:
whyUnavailable If p-value is unavailable, the reason is returned in this string argument.
Returns:
The p-value that the peptide ratios used in calculating this protein ratio seem log-normally distributed. A very low value, e.g. below 0.05, indicates non-normality. A negative value (-1) means sample size was too small for normality testing or the value could not be calculated..
double getNormalityPvalue ( ) const

Return the p-value of the hypothesis that the peptide ratios were (log)normally distributed.

Peptide ratios are multiplicative, and it is reasonable to assume they are log-normally distributed, that is, the log-transformed peptide ratios have normal distribution. Normality is usually required for outlier testing and hypothesis testing. The hypothesis p-value may be meaningless if the normality p-value is not below a threshold; the threshold value is up to you to decide.

Python: note that the name of this method in Python is getNormalityPvalue_only().

Returns:
The p-value that the peptide ratios used in calculating this protein ratio seem log-normally distributed. A very low value, e.g. below 0.05, indicates non-normality. A negative value (-1) means sample size was too small for normality testing or the value could not be calculated.
ms_peptide_quant_key_vector getOutlierKeys ( ) const

Return peptide quant keys associated with the protein accession that were excluded due to being outliers.

The vector of outlier peptide quant keys may be empty if outlier detection is disabled or there were no outliers. It may be possible to override this decision and manually include peptide quant keys that would otherwise be ignored as outliers.

Returns:
vector of outlier keys
unsigned int getSampleSize ( ) const

Return the size of the sample of peptide ratios used in deriving this protein ratio.

Returns:
The number of peptide ratios used in ratio calculation. This is the same size as getActiveKeys().
ms_peptide_quant_key_vector getSkippedKeys ( ) const

Return peptide quant keys associated with the protein accession that were skipped due to being negative or infinite.

The vector of skipped keys may be empty if there were no negative or infinite peptide ratios. It is never possible to include skipped keys in protein ratio calculation.

This collection will also include peptide ratios that were left out of the calculation of the ratio for the Average protocol because they were not one of the highest available peptide intentities.

Returns:
vector of skipped keys
double getStandardDeviation ( ) const

Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.

Sample standard deviation is usually calculated using the standard formula: compute the sample variance as variance = 1/(n-1) * sum( (x_i - avg)^2 ), where x_i are the log peptide ratios, i is iterated from 1 to n (the sample size) and avg is the sample mean, and then take the square root to get the standard deviation. The value returned by this function is transformed back from the log space: exp(sqrt(variance)).

A related but different quantity is the standard error of the protein ratio estimator; see getStandardError().

Python: note that the name of this method in Python is getStandardDeviation_only().

Returns:
The sample standard deviation of this protein ratio. Negative (-1) means the value is unavailable.
double getStandardDeviation ( std::string & whyUnavailable ) const

Return the sample standard deviation of the protein ratio, calculated from the sample of peptide ratios.

Same functionality as getStandardDeviation(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

     my $str = ''; # ensure the variable is defined
     my $stdev = $ratio->getStandardDeviation($str);
Parameters:
whyUnavailable If standard deviation is unavailable, the reason is returned in this string argument.
Returns:
The sample standard deviation of this protein ratio. Negative (-1) means the value is unavailable.
double getStandardError ( ) const

Return the standard error of the protein ratio, calculated from the standard deviation of the sample.

The standard error of the protein ratio estimate is a function of sample standard deviation and sample size. In the simplest case when the log protein ratio is the mean of log peptide ratios, the log standard error is s/sqrt(n), where s is the standard deviation and n is the sample size. In that case, the value returned by this function is transformed back from log space: exp(s/sqrt(n)).

The formula depends on the protein ratio type. For details of the calculation, see ms_quant_stats::arithmeticStandardErrorOfMean(), ms_quant_stats::arithmeticStandardErrorOfMedian(), and ms_quant_stats::weightedArithmeticStandardError().

Python: note that the name of this method in Python is getStandardError_only().

Returns:
The standard error of the protein ratio. Negative (-1) means the value is unavailable.
double getStandardError ( std::string & whyUnavailable ) const

Return the standard error of the protein ratio, calculated from the standard deviation of the sample.

Same functionality as getStandardError(), except that if the value is unavailable (negative), the reason is returned in the string argument.

See Multiple return values in Perl, Java, Python and C#.

Perl: note that this method does not return multiple values. If you want to receive the explanation string, give an empty string object as argument; for example

     my $str = ''; # ensure the variable is defined
     my $stderr = $ratio->getStandardError($str);
Parameters:
whyUnavailable If standard error is unavailable, the reason is returned in this string argument.
Returns:
The standard error of the protein ratio. Negative (-1) means the value is unavailable.
double getValue ( ) const

Return the numerical value of the ratio.

Note that you need to know the context and how the protein ratio has been calculated to interpret the value.

Returns:
The numerical value of this protein ratio.
bool isLogNormal ( double threshold = 0.05 ) const

Boolean flag: do the peptide ratios used in calculating this protein ratio appear to be (log)normally distributed?

The normality test hypothesis is that the peptide ratios are log-normally distributed, or equivalently that the log-transformed peptide ratios are normally distributed. If the p-value is below a threshold, say 0.05, then the hypothesis should be rejected. This method returns true if the p-value does not fall below threshold, which means you have no evidence to reject the normality hypothesis.

(Strictly speaking p above threshold is not enough evidence to explicitly accept the hypothesis, although that is what the method name implies.)

If the p-value is -1 (no testing was conducted), then there is no evidence against the hypothesis and the method returns true.

Parameters:
threshold The significance threshold; default 0.05.
Returns:
True if the normality p-value is not below the threshold; false otherwise. If the normality p-value is not available, the method returns false.
bool isMissing ( ) const

Boolean flag: is this ratio defined?

The ratio can be undefined ("missing") if there is not enough data to calculate it. If this method returns true, then the return values of other methods are undefined.

Returns:
True if the ratio is missing; false otherwise.
bool isSignificant ( double threshold = 0.05 ) const

Boolean flag: is the protein ratio statistically significantly different from the null hypothesis?

The null hypothesis depends on the context where the protein ratio was calculated. If the p-value is below threshold, then there is evidence against the hypothesis and this method returns true; in other words, the protein ratio differs from the hypothesised value in a "statistically significant" way.

If the p-value is -1 (no testing was conducted), then there is no evidence against the hypothesis and the method returns false.

Parameters:
threshold The significance threshold; default 0.05.
Returns:
True if the hypothesis p-value is below the threshold; false otherwise. If the p-value is not available, the method returns false.
The documentation for this class was generated from the following files:
  • ms_protein_quant_ratio.hpp
  • ms_quant_ratios.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


  • matrix_science
  • ms_quant_helper
Public Types | Public Member Functions

ms_quant_helper Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Helper routines for peptide quantitation. More...

#include <ms_quant_helper.hpp>

Inheritance diagram for ms_quant_helper:
[legend]
Collaboration diagram for ms_quant_helper:
[legend]

List of all members.

Public Types

enum PEPTIDE_QUALITY {
PEPTIDE_QUALITY_IS_OK = 0x0000,
PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN = 0x0001,
PEPTIDE_SCORE_BELOW_SCORE_THR = 0x0002,
PEPTIDE_EXPECT_ABOVE_THRESHOLD = 0x0003,
PEPTIDE_SCORE_BELOW_IDENTITY_THR = 0x0004,
PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM = 0x0005,
PEPTIDE_SCORE_BELOW_HOMOLOGY_THR = 0x0006,
PEPTIDE_NOT_UNIQUE = 0x0007,
PEPTIDE_QUALITY_UNAVAILABLE = 0xf000
}

Possible reasons why a peptide does not pass quality tests using a given quantitation method.

More...
enum PEPTIDE_QUANTIFIABILITY {
PEPTIDE_IS_QUANTIFIABLE = 0x0000,
PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD = 0x0001,
PEPTIDE_HAS_NO_REQUIRED_VARMOD = 0x0002,
PEPTIDE_HAS_EXCLUDED_FIXEDMOD = 0x0010,
PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD = 0x0011,
PEPTIDE_HAS_EXCLUDED_VARMOD = 0x0012,
PEPTIDE_HAS_UNMODIFIED_SITE = 0x0013,
PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD = 0x0014,
PEPTIDE_HAS_NO_EXCLUSIVE_MODS = 0x0015,
PEPTIDE_QUANTIFIABILITY_UNAVAILABLE = 0xf000
}

Possible reasons a peptide is not quantifiable using a given quantitation method.

More...

Public Member Functions

ms_quant_helper (const ms_peptidesummary &pepsum, const ms_quant_method &qm, const ms_umod_configfile &umodfile)
Default constructor.
~ms_quant_helper ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
int | createMissingComponents (matrix_science::ms_ms1quant_match *match) const
Create any missing components and return the number of new components created.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
int | isPeptideQualityOK (int q, int p, std::string &reasonStrRef) const
Given a peptide, test whether it passes the quality thresholds.
int | isPeptideQuantifiable (int q, int p, const ms_protein *protein, int peptideIndex, std::string &reasonStrRef) const
Given a peptide and the residues before and after, test whether it is quantifiable.
bool | isValid () const
Call this function to determine if there have been any errors.

Detailed Description

Helper routines for peptide quantitation.

Member Enumeration Documentation

enum PEPTIDE_QUALITY

Possible reasons why a peptide does not pass quality tests using a given quantitation method.

Enumerator:
PEPTIDE_QUALITY_IS_OK

Peptide passes quality thresholds.

PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN

Peptide charge is less than minimum precursor charge.

PEPTIDE_SCORE_BELOW_SCORE_THR

Peptide score is below threshold.

PEPTIDE_EXPECT_ABOVE_THRESHOLD

Peptide expect value exceeds threshold.

PEPTIDE_SCORE_BELOW_IDENTITY_THR

Peptide score is below identity threshold.

PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM

Peptide score is below identity threshold (no homology threshold available).

PEPTIDE_SCORE_BELOW_HOMOLOGY_THR

Peptide score is below homology threshold.

PEPTIDE_NOT_UNIQUE

Peptide is not unique.

PEPTIDE_QUALITY_UNAVAILABLE

Quality cannot be determined.

enum PEPTIDE_QUANTIFIABILITY

Possible reasons a peptide is not quantifiable using a given quantitation method.

Enumerator:
PEPTIDE_IS_QUANTIFIABLE

Peptide is quantifiable using the given quantitation method.

PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD

Peptide is missing a required fixed modification.

PEPTIDE_HAS_NO_REQUIRED_VARMOD

Peptide is missing a required variable modification.

PEPTIDE_HAS_EXCLUDED_FIXEDMOD

Peptide has an excluded fixed modification.

PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD

Peptide has an excluded fixed modification, defined in the local modification definitions.

PEPTIDE_HAS_EXCLUDED_VARMOD

Peptide has an excluded variable modification.

PEPTIDE_HAS_UNMODIFIED_SITE

Peptide has an unmodified site where required modification should be.

PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD

Peptide has an excluded variable modification, defined in the local modification definitions.

PEPTIDE_HAS_NO_EXCLUSIVE_MODS

Peptide has none of the exclusive modifications (only tested when constrain search is disabled).

PEPTIDE_QUANTIFIABILITY_UNAVAILABLE

Quantifiability cannot be determined.

Constructor & Destructor Documentation

ms_quant_helper | ( | const ms_peptidesummary & | pepsum,
 |  | const ms_quant_method & | qm,
 |  | const ms_umod_configfile & | umodfile
 | ) |  |

Default constructor.

The object should receive the full quantitation method, including, in particular, component definitions and peptide quality settings. If the quantitation method is missing either set of settings, the corresponding methods will return the status "unavailable".

The constructor creates a copy of the relevant bits of the quantitation method and stores those internally. If you change the quantitation method later, you must create a new ms_quant_helper object.

Parameters:
pepsum | Mascot results file whose peptide matches are to be tested.
qm | Quantitation method with component definitions, peptide quality settings and report ratio definitions.
umodfile | Unimod configuration file for looking up modification specificities.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int createMissingComponents ( matrix_science::ms_ms1quant_match * match ) const

Create any missing components and return the number of new components created.

Only supports the "precursor" protocol. Other protocols do nothing and return 0

For precursor, this will add the 'derived' matches. For example, if there is a peptide match to the light component, it will add an expected heavy match, even though there is no search ID for the heavy match.

Parameters:
match contains the peptide match to which new 'components' are to be added.
Returns:
the number of new components added to the match
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int isPeptideQualityOK | ( | int | q,
 |  | int | p,
 |  | std::string & | reasonStrRef
 | ) |  | const

Given a peptide, test whether it passes the quality thresholds.

The peptide identified by query q and rank p is tested against peptide quality settings in the quantitation method. If it does not pass all of the quality tests (e.g. score thresholds), the corresponding status is returned; see PEPTIDE_QUALITY for details.

The method defers loading the full peptide object until it is really needed, if at all. Significance tests and score and expect value thresholds can be conducted without loading the peptide object in its entirety. This means the method is fast both when caching is in use and without caching.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | q | Peptide query.
[in] | p | Peptide rank.
[out] | reasonStrRef | is a free-text description of the return status is assigned to the variable. If status is PEPTIDE_QUALITY_IS_OK, reasonStrRef will be the empty string. If status is PEPTIDE_QUALITY_UNAVAILABLE, reasonStrRef will not be changed by this method.
Returns:
Status describing whether the peptide meets all the requirements to be quantifiable using the quantitation method.
int isPeptideQuantifiable | ( | int | q,
 |  | int | p,
 |  | const ms_protein * | protein,
 |  | int | peptideIndex,
 |  | std::string & | reasonStrRef
 | ) |  | const

Given a peptide and the residues before and after, test whether it is quantifiable.

The method first loads the peptide with query q and rank p. The peptide is tested against component definitions in the quantitation method. If it is missing required modifications, or if it contains excluded modifications, the corresponding status is returned; see PEPTIDE_QUANTIFIABILITY for details.

If the quantitation method does not contain suitable component definitions, the return status is PEPTIDE_QUANTIFIABILITY_UNAVAILABLE.

See Multiple return values in Perl, Java, Python and C#

Parameters:
[in] | q | Peptide query.
[in] | p | Peptide rank.
[in] | protein | Protein hit to which the peptide match is assigned. This is only needed in the case where a quality parameter is specified to exclude an unmodified protein N- or C-terminus residue. In this case, this code needs to know if the flanking residue is the corresponding protein terminus. The same peptide may appear in multiple proteins, and may be at the terminus of just one of them, so if you need all peptides that may be quantifiable, pass 0 or NULL.
[in] | peptideIndex | Integer index of the peptide match in the protein hit, between 1 and protein->getNumPeptides(). If protein is null, use 0.
[out] | reasonStrRef | is a free-text description of the return status is assigned to the variable. If status is PEPTIDE_IS_QUANTIFIABLE, reasonStrRef will be the empty string. If status is PEPTIDE_QUANTIFIABILITY_UNAVAILABLE, reasonStrRef will not be changed by this method.
Returns:
Status describing whether the peptide meets all the requirements to be quantifiable using the quantitation method.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_quant_helper.hpp
  • ms_quant_helper.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quant_stats
Static Public Member Functions

ms_quant_stats Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Mathematical and statistical routines for peptide and protein quantitation. More...

#include <ms_quant_stats.hpp>

List of all members.

Static Public Member Functions

static double | arithmeticMean (const std::vector< double > &data)
Calculate the arithmetic mean.
static double | arithmeticStandardDeviation (const std::vector< double > &data, double arithmeticMean)
Calculate the arithmetic sample standard deviation.
static double | arithmeticStandardErrorOfMean (double arithmeticStdev, unsigned long sampleSize)
Calculate the standard error of the arithmetic sample mean.
static double | arithmeticStandardErrorOfMedian (double arithmeticStdev, unsigned long sampleSize)
Calculate the standard error of the sample median.
static double | binomialCoefficient (unsigned int n, unsigned int k)
Compute the binomial coefficient.
static double | calculateNormalMeanPvalue (double populationMean, double mean, double stdev, unsigned long sampleSize)
Calculate the p-value that the population mean is populationMean, given the sample statistics and assuming the population is normally distributed.
static double | calculateNormalMedianPvalue (double populationMedian, double median, double stdev, unsigned long sampleSize)
Calculate the p-value that the population median is populationMedian, given the sample statistics and assuming the population is normally distributed.
static double | calculateNormalWeightedPvalue (double populationMean, double weightedMean, const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize)
Calculate the p-value that the population mean is populationMean, given the weighted sample statistics and assuming the population is normally distributed.
static double | chisqLowerCriticalValue (unsigned int df, double sigLevel)
Return the lower critical value of the chi-square distribution at the given significance level.
static double | chisqUpperCriticalValue (unsigned int df, double sigLevel)
Return the upper critical value of the chi-square distribution at the given significance level.
static void | detectOutliers (const std::vector< double > &sample, std::string outlierMethod, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh)
Given a sample and an outlier method, return the number of outliers at low and high extreme at the given significance level.
static void | detectOutliers (const std::vector< double > &sample, std::string outlierMethod, unsigned int *const numLow, unsigned int *const numHigh)
Given a sample and an outlier method, return the number of outliers at low and high extreme at significance level 0.05.
static std::vector< double > | expTransform (const std::vector< double > &logData)
Antilog (exp) transform of the input data.
static double | geometricMean (const std::vector< double > &data)
Calculate the geometric mean.
static double | geometricStandardDeviation (const std::vector< double > &data, double geometricMean)
Calculate the geometric sample standard deviation.
static std::vector< double > | logTransform (const std::vector< double > &data)
Log transform of the input data.
static std::vector< double > | meanCentre (const std::vector< double > &data, double mean)
Centre the data values about the given mean.
static double | medianStandardErrorCorrection (unsigned long sampleSize)
Return the correction for the standard error of the median.
static double | normalCriticalValue (double p)
Return the critical value of the standard normal distribution at the given cumulative probability.
static double | normalCumulativeProbability (double x0)
Return the cumulative probability that the standard normal statistic is at most x0.
static double | poissonDensity (double lambda, unsigned int k)
Calculate the probability density of the Poisson distribution.
static double | snedecorsCriticalValue (unsigned int df1, unsigned int df2, double sigLevel)
Return the critical value of Snedecor's F distribution at the given significance level.
static double | sortedMedian (const std::vector< double > &data)
Find the median of a sorted data vector.
static double | sortedMedian (const std::deque< double > &data)
Find the median of a sorted data deque.
static double | studentsCriticalValue (unsigned int df, double sigLevel)
Return the critical value of Student's t distribution at the given significance level.
static double | sum (const std::vector< double > &data)
Calculate the sum of a sample vector.
static double | sumsq (const std::vector< double > &data)
Calculate the sum of squares of a sample vector.
static int | testDixonsN9 (unsigned long sampleSize, double min, double x2, double xn_1, double max, double sigLevel)
Apply Dixon's N9 (r11) outlier test to the sample.
static int | testGrubbsN2 (unsigned long sampleSize, double min, double mean, double max, double stdev, double sigLevel)
Apply Grubb's N2 outlier test to the sample statistics.
static void | testRosners (const std::vector< double > &sample, unsigned int maxOutliers, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh)
Apply the generalised extreme Studentised deviate (ESD) outlier test (aka Rosner's test) to the sample.
static bool | testShapiroWilkW (const std::vector< double > &sample, double *const W, double *const pValue)
Apply Shapiro-Wilk W normality test to the sample.
static double | unsortedMedian (const std::vector< double > &data)
Find the median of an unsorted data vector.
static double | weightedArithmeticMean (const std::vector< double > &data, const std::vector< double > &weights)
Calculate the weighted arithmetic mean.
static double | weightedArithmeticStandardDeviation (const std::vector< double > &data, const std::vector< double > &weights, double weightedMean)
Calculate the weighted arithmetic sample standard deviation.
static double | weightedArithmeticStandardError (const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize)
Calculate the standard error of the weighted arithmetic sample mean.
static double | weightedGeometricMean (const std::vector< double > &data, const std::vector< double > &weights)
Calculate the weighted geometric mean.
static double | weightedGeometricStandardDeviation (const std::vector< double > &data, const std::vector< double > &weights, double weightedMean)
Calculate the weighted geometric sample standard deviation.

Detailed Description

Mathematical and statistical routines for peptide and protein quantitation.

ms_quant_stats is a collection of mathematical and statistical routines used in peptide and protein quantitation by ms_ms2quantitation and ms_customquantitation. It is possible to use the routines outside this context, as they are not tied to either class.

The class contains only static class methods; it is impossible and meaningless to create instances of ms_quant_stats.

Member Function Documentation

double arithmeticMean ( const std::vector< double > & data ) [static]

Calculate the arithmetic mean.

The arithmetic mean is the usual average:

mean(data) = (1/N)sumi xi

where N is the number of elements in data and the summation is over all elements xi.

Parameters:
data Any vector of numbers.
Returns:
The arithmetic mean of data, or 0 if the vector is empty.
double arithmeticStandardDeviation | ( | const std::vector< double > & | data,
 |  | double | arithmeticMean
 | ) |  | [static]

Calculate the arithmetic sample standard deviation.

The arithmetic sample deviation is the square root of the arithmetic sample variance. The sample variance is the second sample moment about the sample mean, scaled by N - 1, where N is the sample size. That is,

var(data) = 1/(N - 1)sumi( (xi - arithmeticMean)2 )

where the sum is over all elements xi.

Parameters:
data | A sample of data.
arithmeticMean | Sample arithmetic mean.
Returns:
Sample standard deviation, or 0 if sample size is 0 or 1.
double arithmeticStandardErrorOfMean | ( | double | arithmeticStdev,
 |  | unsigned long | sampleSize
 | ) |  | [static]

Calculate the standard error of the arithmetic sample mean.

The standard error of the arithmetic sample mean in a normally distributed sample is simple: standard deviation divided by the square root of the sample size.

Parameters:
arithmeticStdev | Arithmetic standard deviation, for example from arithmeticStandardDeviation().
sampleSize | The sample size.
Returns:
Standard error of the mean. If sample size is 0 or 1, this function returns 0.
double arithmeticStandardErrorOfMedian | ( | double | arithmeticStdev,
 |  | unsigned long | sampleSize
 | ) |  | [static]

Calculate the standard error of the sample median.

The standard error of the sample median in a normally distributed sample is the same as the standard error of the sample mean, times a correction factor. The correction factor is documented in medianStandardErrorCorrection().

Parameters:
arithmeticStdev | Arithmetic standard deviation, for example from arithmeticStandardDeviation().
sampleSize | The sample size.
Returns:
Standard error of the mean. If sample size is 0 or 1, this function returns 0.
double binomialCoefficient | ( | unsigned int | n,
 |  | unsigned int | k
 | ) |  | [static]

Compute the binomial coefficient.

The method returns 1 in the following cases, by definition:

  • n = 0
  • k = 0
  • n < k

Note that although the binomial coefficient is an integer, the return value is double to allow values beyond about 4 billion on 32-bit systems. The value is exact up to about 74C37.

Parameters:
n | Population size.
k | Sample size.
Returns:
The binomial coefficient nCk or "n choose k".
double calculateNormalMeanPvalue | ( | double | populationMean,
 |  | double | mean,
 |  | double | stdev,
 |  | unsigned long | sampleSize
 | ) |  | [static]

Calculate the p-value that the population mean is populationMean, given the sample statistics and assuming the population is normally distributed.

Hypothesis: the population you are sampling from is normally distributed with mean populationMean and unknown variance.

Statistic: Student's t = (mean - populationMean)/(stdev/sqrt(sampleSize))

Assume the hypothesis is true. This method returns the probability (the p-value) that the statistic t could have a value as extreme (or more extreme) as the one observed. Low p-value means that either the hypothesis is wrong or the sample is exceptionally rare.

(Note that there is no alternative hypothesis. The p-value with this interpretation is part of Fisher's significance test, which does not decide between hypotheses. Recommended reading: Hubbard, R. et al. (2003): Confusion over Measures of Evidence (p's) versus Errors (alphas) in Classical Statistical Testing. The American Statistician 57(3):171-182.)

Parameters:
populationMean | Assumed population mean. (Population variance is assumed unknown.)
mean | Sample arithmetic mean.
stdev | Sample standard deviation. This must be positive.
sampleSize | Sample size. This must be at least 1.
Returns:
The p-value of the statistic under the hypothesis of normality.
double calculateNormalMedianPvalue | ( | double | populationMedian,
 |  | double | median,
 |  | double | stdev,
 |  | unsigned long | sampleSize
 | ) |  | [static]

Calculate the p-value that the population median is populationMedian, given the sample statistics and assuming the population is normally distributed.

Hypothesis: the population you are sampling from is normally distributed with median populationMedian and unknown variance. In particular, the population median is equal to the population mean.

Statistic: Student's t for sample median, t = 1/C*(median - populationMedian)/(stdev/sqrt(sampleSize))

Assume the hypothesis is true. This method returns the probability (the p-value) that the statistic t could have a value as extreme (or more extreme) as the one observed. Low p-value means that either the hypothesis is wrong or the sample is exceptionally rare.

(Note that there is no alternative hypothesis. The p-value with this interpretation is part of Fisher's significance test, which does not decide between hypotheses. Recommended reading: Hubbard, R. et al. (2003): Confusion over Measures of Evidence (p's) versus Errors (alphas) in Classical Statistical Testing. The American Statistician 57(3):171-182.)

The constant C is a correction to the standard error of the median, retrieved from medianStandardErrorCorrection().

Parameters:
populationMedian | Assumed population median. (Population variance is assumed unknown.)
median | Sample median.
stdev | Sample standard deviation. This must be positive.
sampleSize | Sample size. This must be at least 1.
Returns:
The p-value of the statistic under the hypothesis of normality.
double calculateNormalWeightedPvalue | ( | double | populationMean,
 |  | double | weightedMean,
 |  | const std::vector< double > & | weights,
 |  | double | weightedStdev,
 |  | unsigned long | sampleSize
 | ) |  | [static]

Calculate the p-value that the population mean is populationMean, given the weighted sample statistics and assuming the population is normally distributed.

Hypothesis: the population you are sampling from is normally distributed with mean populationMean and unknown variance.

Statistic: Student's t = (weightedMean - populationMean)/(stdev sqrt(W)/b)),

where stdev is the sample standard deviation, W is the sum of weights and b is the effective base, as defined in weightedArithmeticStandardError(). Note that this function takes as argument the weighted standard deviation and the weights, not stdev.

Assume the hypothesis is true. This method returns the probability (the p-value) that the statistic t could have a value as extreme (or more extreme) as the one observed. Low p-value means that either the hypothesis is wrong or the sample is exceptionally rare.

(Note that there is no alternative hypothesis. The p-value with this interpretation is part of Fisher's significance test, which does not decide between hypotheses. Recommended reading: Hubbard, R. et al. (2003): Confusion over Measures of Evidence (p's) versus Errors (alphas) in Classical Statistical Testing. The American Statistician 57(3):171-182.)

Parameters:
populationMean | Assumed population mean. (Population variance is assumed unknown.)
weightedMean | Weighted sample arithmetic mean.
weights | Positive weight for each datum. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than sampleSize, the weights of those elements are taken to be 1.0.
weightedStdev | Weighted sample standard deviation. This must be positive.
sampleSize | Sample size. This must be at least 1.
Returns:
The p-value of the statistic under the hypothesis of normality.
double chisqLowerCriticalValue | ( | unsigned int | df,
 |  | double | sigLevel
 | ) |  | [static]

Return the lower critical value of the chi-square distribution at the given significance level.

Suppose the random variable X has the chi-square distribution with df degrees of freedom. This routine returns the lower critical value x0 for which

P(X <= x0) = p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.025 < s <= 0.050 | 0.05
0.010 < s <= 0.025 | 0.025
0.001 < s <= 0.010 | 0.01
s <= 0.001 | 0.001

If sigLevel exceeds 0.100, it is truncated to 0.100.

Parameters:
df | The degrees of freedom between 1 and 100 inclusive.
sigLevel | Significance level. See the above table for supported values.
Returns:
The lower critical value x0.
double chisqUpperCriticalValue | ( | unsigned int | df,
 |  | double | sigLevel
 | ) |  | [static]

Return the upper critical value of the chi-square distribution at the given significance level.

Suppose the random variable X has the chi-square distribution with df degrees of freedom. This routine returns the upper critical value x0 for which

P(X <= x0) = 1 - p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.025 < s <= 0.050 | 0.05
0.010 < s <= 0.025 | 0.025
0.005 < s <= 0.010 | 0.01
0.001 < s <= 0.005 | 0.005
s <= 0.001 | 0.001

If sigLevel exceeds 0.100, it is truncated to 0.100.

Parameters:
df | The degrees of freedom between 1 and 100 inclusive.
sigLevel | Significance level. See the above table for supported values.
Returns:
The upper critical value x0.
void detectOutliers | ( | const std::vector< double > & | sample,
 |  | std::string | outlierMethod,
 |  | double | sigLevel,
 |  | unsigned int *const | numLow,
 |  | unsigned int *const | numHigh
 | ) |  | [static]

Given a sample and an outlier method, return the number of outliers at low and high extreme at the given significance level.

If outlierMethod is "none" or the empty string, or if outlierMethod is not listed in Type mqm:outlierType, then the method simply returns with 0 outliers. Otherwise the corresponding outlier test will be used to count the number of low and high outliers at the given significance level.

If outlierMethod is "auto", then the method uses Dixon's N9 if sample size is less than 25 and Rosner's test otherwise.

Note that not all tests support the same set of significance levels. The common values between all three tests are as follows:

sigLevel (s) | p
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.005 < s <= 0.010 | 0.01

If you specify a significance level that is outside these ranges, then the effective significance levels depends on which test is being used. Please refer to testDixonsN9(), testGrubbsN2() and testRosners() for more details.

Note that this method does not modify sample. You will need to remove the indicated outliers yourself if desired.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | sample | A sample of data sorted in increasing numerical order. If the sample size is not large enough for outlierMethod, both numLow and numHigh will be 0 and no testing will be done.
[in] | outlierMethod | Outlier method to use. Outlier methods are listed in Type mqm:outlierType. Note that the value is case sensitive.
[in] | sigLevel | Significance level to use in tests.
[out] | numLow | Number of outliers at the low end of sample; values at indices from 0 to numLow - 1 are outliers based on the chosen test. If numLow is 0, the sample has no outliers at the low end.
[out] | numHigh | Number of outliers at the high end of sample; values at indices from N - numHigh to N - 1 are outliers based on the chosen test (N is the size of sample). If numHigh is 0, the sample has no outliers at the high end.
void detectOutliers | ( | const std::vector< double > & | sample,
 |  | std::string | outlierMethod,
 |  | unsigned int *const | numLow,
 |  | unsigned int *const | numHigh
 | ) |  | [static]

Given a sample and an outlier method, return the number of outliers at low and high extreme at significance level 0.05.

If outlierMethod is "none" or the empty string, or if outlierMethod is not listed in Type mqm:outlierType, then the method simply returns with 0 outliers. Otherwise the corresponding outlier test will be used to count the number of low and high outliers at significance level 0.05. If you wish to specify a different significance level, use detectOutliers(const std::vector<double>&, std::string, double, unsigned int*const, unsigned int*const).

If outlierMethod is "auto", then the method uses Dixon's N9 if sample size is less than 25 and Rosner's test otherwise.

Note that this method does not modify sample. You will need to remove the indicated outliers yourself if desired.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | sample | A sample of data sorted in increasing numerical order. If the sample size is not large enough for outlierMethod, both numLow and numHigh will be 0 and no testing will be done.
[in] | outlierMethod | Outlier method to use. Outlier methods are listed in Type mqm:outlierType. Note that the value is case sensitive.
[out] | numLow | Number of outliers at the low end of sample; values at indices from 0 to numLow - 1 are outliers based on the chosen test. If numLow is 0, the sample has no outliers at the low end.
[out] | numHigh | Number of outliers at the high end of sample; values at indices from N - numHigh to N - 1 are outliers based on the chosen test (N is the size of sample). If numHigh is 0, the sample has no outliers at the high end.
std::vector< double > expTransform ( const std::vector< double > & logData ) [static]

Antilog (exp) transform of the input data.

Parameters:
logData Any vector of logarithms.
Returns:
The elementwise exp transform of the input vector.
double geometricMean ( const std::vector< double > & data ) [static]

Calculate the geometric mean.

The geometric mean is

geom(data) = (prodi xi)1/N

where N is the number of elements in data and the product is over all the elements xi. That is, the geometric mean is the Nth root of the product of all input values.

Equivalently, the logarithm of the geometric mean is equal to the arithmetic mean of the data in log space. This is actually how the mean is calculated by the method.

Parameters:
data Any vector of numbers.
Returns:
The geometric mean of data, or 1 if the vector is empty. If any of the data elements are 0 or negative, the mean is 0.
double geometricStandardDeviation | ( | const std::vector< double > & | data,
 |  | double | geometricMean
 | ) |  | [static]

Calculate the geometric sample standard deviation.

The geometric sample deviation is the square root of the geometric sample variance. The geometric sample variance is the second sample moment about the sample mean, scaled by N - 1, where N is the sample size. That is,

var(data) = e1/(N - 1)sumi( (log(xi) - log(geometricMean))2 )

where the sum is over all elements xi.

Equivalently, the logarithm of the geometric standard deviation is equal to the arithmetic standard deviation of the data in log space.

Parameters:
data | A sample of data.
geometricMean | Sample geometric mean.
Returns:
Sample standard deviation, or 0 if sample size is 0 or 1. If any data element is 0 or negative, or if the geometric mean is 0 or negative, then the standard deviation is 0.
std::vector< double > logTransform ( const std::vector< double > & data ) [static]

Log transform of the input data.

Parameters:
data Any vector of positive numbers.
Returns:
The elementwise log transform of the input vector. If any element is 0 or negative, its logarithm will be substituted with a large negative number (but not negative infinity).
std::vector< double > meanCentre | ( | const std::vector< double > & | data,
 |  | double | mean
 | ) |  | [static]

Centre the data values about the given mean.

Parameters:
data | Any vector of numbers.
mean | Sample mean.
Returns:
A mean centred vector of the same size as data.
double medianStandardErrorCorrection ( unsigned long sampleSize ) [static]

Return the correction for the standard error of the median.

The standard error of the median is the same as the standard error of the mean, times a correction factor. That is, the standard error of the mean is s/sqrt(n), where s is the estimated standard deviation of the sample and n is the sample size. The standard error of the median is C * s/sqrt(n), where the constant C is the correction factor returned by this function.

The correction factor C is a function of sample size and is always between 1 and about 1.25. The sample median is an unbiased estimator of the population mean, but it has larger sampling variance than the sample mean (it is less efficient). For a normal population, the ratio between the variance of the sample mean and sample median tends to pi/2 as the sample size tends to infinity, which means C = sqrt(pi/2).

If the sample size is small (below about 100), then the constant is less than sqrt(pi/2) and depends on whether the sample size is even or odd. This method uses exact values for sample size between 1 and 12, and an accurate polynomial approximation for sample sizes between 13 and 100. These numbers and the polynomial are described in the following two publications, respectively:

  • Hojo, T. and K. Pearson (1931): Distribution of the Median, Quartiles and Interquartile Distance in Samples From a Normal Population. Biometrika 23(3/4):315-363.
  • Cadwell, J. H. (1952): The Distribution of Quantiles of Small Samples. Biometrika 39(1/2):207-211.

(Lower efficiency means that although the median is a robust estimator, this statistic always has a less extreme value than if the sample mean had been used. In other words, the p-value will be higher than for calculateNormalMeanPvalue() for the same sample.)

Parameters:
sampleSize The sample size.
Returns:
Correction constant as described above.
double normalCriticalValue ( double p ) [static]

Return the critical value of the standard normal distribution at the given cumulative probability.

Suppose the random variable X has standard normal distribution. This routine returns the critical value x0 in the right tail such that

P(X <= abs(x0)) = p

where p is the desired cumulative probability.

Note that due to implementation reasons, the precision of the calculated critical value is limited to 3 decimal places. That is, the return value ranges from 0.000 to 4.090.

Parameters:
p The cumulative probability between 0.5 and 1.0. If you need critical values for the left tail, give 1 - p as the argument and negate the result.
Returns:
The critical value x0.
double normalCumulativeProbability ( double x0 ) [static]

Return the cumulative probability that the standard normal statistic is at most x0.

Suppose the random variable X has standard normal distribution. This routine returns the cumulative probability p such that

p = P(0 <= X <= abs(x0))

where abs is the absolute value function. That is, the routine calculates the cumulative probability in the right tail. Since the normal distribution is symmetric, this can be used to calculate any cumulative probability of the distribution. Refer to a standard text on statistics for details.

Note that due to implementation reasons, the precision of the calculated critical value is limited to 6 decimal places. That is, the return value ranges from 0.000000 to 0.500000.

Parameters:
x0 The critical value between 0.000 and 4.090, inclusive. Values beyond 4.090 are taken to be infinite (so cumulative probability is 0.50000), while the sign of negative value is changed to positive.
Returns:
The cumulative probability that 0 <= X <= abs(x0).
double poissonDensity | ( | double | lambda,
 |  | unsigned int | k
 | ) |  | [static]

Calculate the probability density of the Poisson distribution.

Poisson probability density is the probability of observing exactly k events, when the events occur at mean rate per unit lambda.

Parameters:
lambda | The rate parameter, which must be positive. If lambda is negative or zero, the function returns 0.
k | The number of events.
Returns:
The probability density, or 0 if lambda is not positive.
double snedecorsCriticalValue | ( | unsigned int | df1,
 |  | unsigned int | df2,
 |  | double | sigLevel
 | ) |  | [static]

Return the critical value of Snedecor's F distribution at the given significance level.

Suppose the random variable F has Snedecor's F distribution with df1 and df2 degrees of freedom. This routine returns the critical value f0 for which

P(F <= f0) = 1 - p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.010 < s <= 0.050 | 0.05
s <= 0.010 | 0.01

If sigLevel exceeds 0.100, it is truncated to 0.100.

Parameters:
df1 | The degrees of freedom for the "numerator" between 1 and 20, inclusive.
df2 | The degrees of freedom for the "denominator" between 1 and 100 inclusive.
sigLevel | Significance level. See the above table for supported values.
Returns:
The critical value f0.
double sortedMedian ( const std::vector< double > & data ) [static]

Find the median of a sorted data vector.

The median of a sorted input vector can be found very easily:

  • If the vector has an odd number of elements N, then the median is simply the element at index m = (N-1)/2.
  • If the vector has an even number of elements N, then the median is the mean between the two central elements m1 = floor((N-1)/2) = N/2 - 1 and m2 = ceil((N-1)/2) = N/2.

If data is empty the method returns zero.

Parameters:
data Any sorted vector of numbers.
Returns:
The median value of the input vector.
double sortedMedian ( const std::deque< double > & data ) [static]

Find the median of a sorted data deque.

The median of a sorted input deque can be found very easily:

  • If the deque has an odd number of elements N, then the median is simply the element at index m = (N-1)/2.
  • If the deque has an even number of elements N, then the median is the mean between the two central elements m1 = floor((N-1)/2) = N/2 - 1 and m2 = ceil((N-1)/2) = N/2.

If data is empty the method returns zero.

Parameters:
data Any sorted deque of numbers.
Returns:
The median value of the input deque.
double studentsCriticalValue | ( | unsigned int | df,
 |  | double | sigLevel
 | ) |  | [static]

Return the critical value of Student's t distribution at the given significance level.

Suppose the random variable t has Student's t distribution with df degrees of freedom. This routine returns the critical value t0 for which

P(t <= t0) = 1 - p

where p is the desired significance level. Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.050 < s <= 0.100 | 0.1
0.025 < s <= 0.050 | 0.05
0.010 < s <= 0.025 | 0.025
0.005 < s <= 0.010 | 0.01
0.001 < s <= 0.005 | 0.005
s <= 0.001 | 0.001

If sigLevel exceeds 0.100, it is truncated to 0.100.

If you need critical values for df exceeding 100, you can use the standard normal critical values as a good approximation; see normalCriticalValue().

Parameters:
df | The degrees of freedom. If df exceeds 100, it is taken to be infinite.
sigLevel | Significance level. See the above table for supported values.
Returns:
The critical value t0.
double sum ( const std::vector< double > & data ) [static]

Calculate the sum of a sample vector.

Parameters:
data Any vector of numbers.
Returns:
The sum of the elements of data.
double sumsq ( const std::vector< double > & data ) [static]

Calculate the sum of squares of a sample vector.

Parameters:
data Any vector of numbers.
Returns:
The sum of the squares of elements of data.
int testDixonsN9 | ( | unsigned long | sampleSize,
 |  | double | min,
 |  | double | x2,
 |  | double | xn_1,
 |  | double | max,
 |  | double | sigLevel
 | ) |  | [static]

Apply Dixon's N9 (r11) outlier test to the sample.

Dixon's N9 outlier test assumes that the data is normally distributed with unknown mean and variance, and that it could be contaminated by value(s) from another normal distribution with a different mean or variance. (For example, such contamination could result from gross measurement errors.) A related but different test is Grubbs N2; see testGrubbsN2().

Dixon's N9 is based on sample order statistics, which are used to estimate sample standard deviation. The test tries to remove one of two extremes: sample maximum or sample minimum. The extreme with the higher statistic will be chosen for possible removal. The method returns -1 or +1 if the chosen extreme is an outlier (statistic exceeds a critical value) and 0 otherwise. If you suspect the sample contains multiple outliers, use the test repeatedly until it returns 0, removing the corresponding outlier at each step. (Note that in sequential use, sigLevel is a significance level strictly speaking only for the first test.)

If your data is multiplicative, for example log-normal (such as peptide ratios), then you need to do a log transformation first before calling this method. See logTransform().

Description of the test procedure and critical values are presented in the following references:

  • Dixon, W. J. (1950): Analysis of Extreme Values. The Annals of Mathematical Statistics 21(4):488-506.
  • Dixon, W. J. (1951): Ratios Involving Extreme Values. The Annals of Mathematical Statistics 22(1):68-78.
  • Verma, S. P. and A. Quiroz-Ruiz (2006): Critical values for six Dixon tests for outliers in normal samples up to sizes 100, and applications in science and engineering. Revista Mexicana de Ciencias Geológicas 23(2):133-161.

Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.200 < s <= 0.300 | 0.3
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.005 < s <= 0.010 | 0.01
s <= 0.005 | 0.005

If sigLevel exceeds 0.300, it is truncated to 0.300.

Parameters:
sampleSize | Sample size. If this is not between 4 and 100, the method returns 0.
min | Minimum value in the sample.
x2 | Second smallest value in the sample.
xn_1 | Second largest value in the sample.
max | Maximum value in the sample.
sigLevel | Significance level. See the above table for supported values.
Returns:
One of three values: 0 if neither extreme is an outlier; -1 if min is an outlier; and +1 if max is an outlier.
int testGrubbsN2 | ( | unsigned long | sampleSize,
 |  | double | min,
 |  | double | mean,
 |  | double | max,
 |  | double | stdev,
 |  | double | sigLevel
 | ) |  | [static]

Apply Grubb's N2 outlier test to the sample statistics.

Grubbs N2 outlier test tries to remove one of two extremes: sample minimum or sample maximum. The data is assumed normally distributed with unknown mean and variance, and a statistic is computed for both extremes. The extreme with the higher statistic will be chosen for possible removal. The method returns -1 or +1 if the chosen extreme is an outlier (statistic exceeds a critical value) and 0 otherwise.

It is usually best to use a normal probability plot to assess whether outlier removal is needed and how many outliers there seem to be. The Grubbs N2 test assumes the data has at most one outlier, and may fail to remove the outlier if there are actually two or more outliers in the data (this is called masking). If you suspect more than one outlier, the generalised ESD test is more appropriate; see testRosners().

If your data is multiplicative, for example log-normal (such as peptide ratios), then you need to do a log transformation first before calling this method. See logTransform().

If you suspect the data is contaminated by values from another normal distribution with a different mean or variance, then Dixon's N9 test could be more appropriate. See testDixonsN9().

Details of the test procedure and critical values are presented in the following references:

  • Grubbs, F. E. (1969): Procedures for Detecting Outlying Observations in Samples. Technometrics 11:1-21.
  • Verma, S. P. and A. Quiroz-Ruiz (2006): Critical values for 22 discordancy test variants for outliers in normal samples up to sizes 100, and applications in science and engineering. Revista Mexicana de Ciencias Geológicas 23(3):302-319.
  • NIST/SEMATECH e-Handbook of Statistical Methods, section 1.3.5.17.1

Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.200 < s <= 0.300 | 0.3
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.005 < s <= 0.010 | 0.01
s <= 0.005 | 0.005

If sigLevel exceeds 0.300, it is truncated to 0.300.

Parameters:
sampleSize | Sample size. If this is not between 3 and 100, the method returns 0.
min | Minimum value in the sample.
mean | Sample arithmetic mean.
max | Maximum value in the sample.
stdev | Sample standard deviation. If stdev is not positive, the method returns 0.
sigLevel | Significance level. See the above table for supported values.
Returns:
One of three values: 0 if neither extreme is an outlier; -1 if min is an outlier; and +1 if max is an outlier.
void testRosners | ( | const std::vector< double > & | sample,
 |  | unsigned int | maxOutliers,
 |  | double | sigLevel,
 |  | unsigned int *const | numLow,
 |  | unsigned int *const | numHigh
 | ) |  | [static]

Apply the generalised extreme Studentised deviate (ESD) outlier test (aka Rosner's test) to the sample.

The generalised ESD test tries to remove at least 1 and up to maxOutliers outliers from the sample. If you suspect there is at most one outlier in the data, the Grubbs N2 test may be more appropriate; see testGrubbsN2().

The data is assumed normally distributed with unknown mean and variance. If your data is multiplicative, for example log-normal (such as peptide ratios), then you need to do a log transformation first before calling this method. See logTransform().

Description of the test procedure can be found in the following references:

  • Rosner, B. (1983): Percentage Points for a Generalized ESD Many-Outlier Procedure. Technometrics, 25(2):165-172.
  • NIST/SEMATECH e-Handbook of Statistical Methods, section 1.3.5.17.3

Significance level is determined by finding the smallest standard significance level that exceeds sigLevel:

sigLevel (s) | p
0.100 < s <= 0.200 | 0.2
0.050 < s <= 0.100 | 0.1
0.020 < s <= 0.050 | 0.05
0.010 < s <= 0.020 | 0.02
0.002 < s <= 0.010 | 0.01
s <= 0.002 | 0.002

If sigLevel exceeds 0.200, it is truncated to 0.200.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | sample | A sample of data sorted in increasing numerical order. Sample size must be at least 25 for meaningful results.
[in] | maxOutliers | Number between 1 and 10 (inclusive) indicating the maximum number of suspected outliers in the sample.
[in] | sigLevel | Significance level. See the above table for supported values.
[out] | numLow | Number of outliers at the low end of sample; values at indices from 0 to numLow - 1 are outliers based on the test. If numLow is 0, the sample has no outliers at the low end.
[out] | numHigh | Number of outliers at the high end of sample; values at indices from N - numHigh to the end of the vector are outliers based on the test (N is the size of sample). If numHigh is 0, the sample has no outliers at the high end.
bool testShapiroWilkW | ( | const std::vector< double > & | sample,
 |  | double *const | W,
 |  | double *const | pValue
 | ) |  | [static]

Apply Shapiro-Wilk W normality test to the sample.

See Multiple return values in Perl, Java, Python and C#.

See ms_shapiro_wilk for the test details. This method returns false if any of the following conditions apply:

  • Sample size is less than 3.
  • Sample range (max - min) is not positive.

In these cases the test is not conducted, and the values of W and pValue are not defined.

The number of right-censored values is assumed to be 0. If your sample contains censored values, use ms_shapiro_wilk directly.

Parameters:
[in] | sample | A sample of data sorted in increasing numerical order. The number of elements should be between 3 and 5000, inclusive. If sample size exceeds 5000, the test statistic and p-value will be calculated successfully, but the p-value is not guaranteed to be accurate.
[out] | W | The Shapiro-Wilk W statistic calculated from the data.
[out] | pValue | The p-value of W under the null hypothesis.
Returns:
True if the test was conducted; false otherwise.
double unsortedMedian ( const std::vector< double > & data ) [static]

Find the median of an unsorted data vector.

This method works for both sorted and unsorted input, although in the former case it is faster to call sortedMedian() instead.

The trivial implementation is to create a copy of the input data, sort and then call sortedMedian(). This method is slightly faster: If the input vector has an odd number of elements N, then the median would be at index m = (N-1)/2; otherwise the median is between elements m1 = floor((N-1)/2) and m2 = ceil((N-1)/2). The method uses partial sorting to find the mth element (or the m1st and m2nd elements) which means time complexity is slightly less than O(N log(N)) (which is the average time complexity of quicksort).

Parameters:
data Any vector of numbers.
Returns:
The median of data, or 0 if the vector is empty.
double weightedArithmeticMean | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights
 | ) |  | [static]

Calculate the weighted arithmetic mean.

The weighted arithmetic mean is

mean(data, weights) = (1/W)sumi wixi

where W is the sum of weights, wi is an individual weight, and the summation is over all elements xi.

Parameters:
data | Any vector of numbers.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the missing weights are taken to be 1.0.
Returns:
The weighted arithmetic mean of data, or 0 if the vector is empty.
double weightedArithmeticStandardDeviation | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights,
 |  | double | weightedMean
 | ) |  | [static]

Calculate the weighted arithmetic sample standard deviation.

The weighted arithmetic sample deviation is the square root of the weighted arithmetic sample variance. The weighted sample variance is

var(data,weights) = var(data)/b(weights)

where the effective base b is

b(weights) = (sumi wi)2/sumi(wi2)

Parameters:
data | A sample of data.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the weights of those elements are taken to be 1.0.
weightedMean | Sample weighted arithmetic mean.
Returns:
Sample standard deviation, or 0 if sample size is 0 or 1.
double weightedArithmeticStandardError | ( | const std::vector< double > & | weights,
 |  | double | weightedStdev,
 |  | unsigned long | sampleSize
 | ) |  | [static]

Calculate the standard error of the weighted arithmetic sample mean.

The standard error of the weighted arithmetic mean is slightly different from the standard error of the mean. Like the weighted standard deviation, the weights must be taken into account. The effective base b is

b(weights) = (sumi wi)2/sumi(wi2) = W2/S,

where W2 is the squared sum of the weights, and S is the sum of squared weights. As the weighted mean is

mean(data, weights) = (1/W)sumi wixi,

we can use the usual sample properties (independent, identically distributed random variables) to easily derive

var(mean) = sigma2/(b/W)

where sigma2 is the population variance. The sample estimate of the standard error is then

sqrt(W s2/b2) = sqrt(W) s/b,

which is the value returned by this function.

Parameters:
weights | Positive weight for each datum. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than sampleSize, the weights of those elements are taken to be 1.0.
weightedStdev | Sample weighted arithmetic standard deviation. It is recommended to use weightedArithmeticStandardDeviation() with the same weights.
sampleSize | The sample size.
Returns:
Weighted standard error, or 0 if sample size is 0 or 1.
double weightedGeometricMean | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights
 | ) |  | [static]

Calculate the weighted geometric mean.

The weighted geometric mean is

geom(data,weights) = (prodi xiwi)1/W

where W is the sum of weights, wi is an individual weight and the product is over all the elements xi. That is, the geometric mean is the Wth root of the product of the with roots of the input values.

Equivalently, the logarithm of the weighted geometric mean is equal to the weighted arithmetic mean of the data in log space. This is actually how the mean is calculated by the method.

Parameters:
data | Any vector of numbers.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the missing weights are taken to be 1.0.
Returns:
The weighted geometric mean of data, or 1 if the vector is empty. If any of the data elements are 0, the mean is 0.
double weightedGeometricStandardDeviation | ( | const std::vector< double > & | data,
 |  | const std::vector< double > & | weights,
 |  | double | weightedMean
 | ) |  | [static]

Calculate the weighted geometric sample standard deviation.

The weighted geometric sample deviation is the square root of the weighted geometric sample variance. The geometric sample variance is

var(logdata,weights) = evar(logdata)/b

where the effective base b is

b(weights) = (sumi wi)2/sumi(wi2)

and logdata is the log-transformed data.

Equivalently, the logarithm of the weighted geometric standard deviation is equal to the weighted arithmetic standard deviation of the data in log space.

Parameters:
data | A sample of data.
weights | Positive weight for each datum in data. Negative and zero weights are coerced to 1.0, and if weights has fewer elements than data, the weights of those elements are taken to be 1.0.
weightedMean | Sample weighted geometric mean.
Returns:
Sample standard deviation, or 0 if sample size is 0 or 1.
The documentation for this class was generated from the following files:
  • ms_quant_stats.hpp
  • ms_quant_stats.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_quantitation
Public Member Functions | Protected Member Functions | Protected Attributes

ms_quantitation Class Reference
[Quantitation analysis for Mascot Server and Distiller]

Base class for peptide and protein quantitation. More...

#include <ms_quantitation.hpp>

Inheritance diagram for ms_quantitation:
[legend]
Collaboration diagram for ms_quantitation:
[legend]

List of all members.

Public Member Functions

virtual | ~ms_quantitation ()=0
Destructor.
void | addHeaderField (const std::string &name, const std::string &value)
Adds an item of project or search header information.
void | addRawFileField (const unsigned int id, const std::string &name, const std::string &value)
Adds an item of raw file header information.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | clearHeaderFields ()
Clears any header information from the result.
void | clearRawFileFields ()
Clears any raw file header information from the result.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
virtual int | countDistinctPeptides (const std::vector< ms_peptide_quant_key > &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
virtual int | countDistinctPeptides (const ms_peptide_quant_key_vector &activeKeys) const
Get the number of distinct peptides in the list of active candidates.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
ms_peptide_quant_key_vector | getPeptideQuantKeys (const std::string &accession, int dbIdx) const
Look up peptide quant keys associated with a given protein, if any.
virtual ms_peptide_quant_ratio | getPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Given peptide quant key and ratio name, return the corresponding peptide ratio data.
double | getPeptideRatioNormalisationBase (const std::string &ratioName) const
Get the peptide ratio normalisation base of the given ratio name.
const ms_progress_info & | getProgressInfo ()
Get information about the progress of a currently running long operation (e.g. loading from a file).
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName) const =0
Given the protein accession, database ID and ratio name, return the protein ratio data.
virtual ms_protein_quant_ratio | getProteinRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const =0
Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.
const ms_quant_method & | getQuantitationMethod () const
Return the current quantitation method.
virtual bool | hasPeptideRatio (const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.
virtual bool | isPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName) const =0
Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?
bool | isValid () const
Call this function to determine if there have been any errors.
void | removePeptideRatioNormalisationBase (const std::string &ratioName)
Reset the peptide ratio normalisation base of the given ratio name.
void | removePeptideRatioNormalisationBases ()
Reset all peptide ratio normalisation bases.
void | setMinNumPeptides (int value)
Set the minimum number of peptides needed for protein ratio calculation.
virtual void | setPeptideRatioExcluded (const ms_peptide_quant_key &key, const std::string &ratioName)=0
Globally exclude a particular peptide ratio from protein ratio calculation.
virtual void | setPeptideRatioIncluded (const ms_peptide_quant_key &key, const std::string &ratioName)=0
Globally include a particular peptide ratio in protein ratio calculation.
void | setPeptideRatioNormalisationBase (const std::string &ratioName, double b)
Set the peptide ratio normalisation base of the given ratio name.
virtual void | setProteinRatioType (const char *value)=0
Set the protein ratio type.
virtual void | setQuantOutliers (const ms_quant_outliers *)=0
Set new peptide ratio outlier settings.

Protected Member Functions

ms_protein_quant_ratio | calculateGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the geometric mean and standard deviation.
ms_protein_quant_ratio | calculateMedianRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the median and standard deviation from the median.
ms_protein_quant_ratio | calculateWeightedGeometricMeanRatio (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const
Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.
int | getMinNumPeptides () const
Get the minimum number of peptides needed for protein ratio calculation.
void | getProteinRatioSample (const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const
Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.
virtual void | getSortedFinitePeptideRatioValues (const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKeys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const =0
Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.
bool | initialiseBaseSettings (const ms_quant_method &qmBase, const ms_quant_method &qmConfig)
Initialise quantitation method settings from the two method objects.

Protected Attributes

protein_to_peptide_quant_key_t | proteinKeys_
Protein-to-peptide mapping.

Detailed Description

Base class for peptide and protein quantitation.

ms_quantitation is an abstract class and cannot be instantiated. It provides shared read access methods for two child classes: ms_ms2quantitation and ms_customquantitation. See Peptide and protein quantitation and child class documentation for details and use cases.

You always need to define a quantitation method when creating an object of either kind. For ms_ms2quantitation, a full quantitation method definition is needed, including protocol settings, component definitions, peptide quality settings and protein ratio settings. Usually it is easiest to use the quantitation method from the Mascot results file and customise it as needed; see ms_mascotresfile::getQuantitationMethod() and the ms_ms2quantitation constructor for details.

For ms_customquantitation, the minimum the quantitation method needs to define is protein ratio settings. If you have a Mascot results file, it won't hurt to use the quantitation method from the results file as base configuration. However, the class will not use any component or peptide quality settings.

The input quantitation method needs to be distinguished from the current (or effective) quantitation method. The class will always create a copy of the quantitation method used as input, and allows changing some of its parameters later to alter how protein ratios are calculated or to change normalisation settings. You have read-only access to the current quantitation method with getQuantitationMethod().

The base class provides three kinds of functionality:

  1. Access peptide ratios:
    • hasPeptideRatio(const ms_peptide_quant_key&, const std::string &) const
    • getPeptideRatio(const ms_peptide_quant_key&, const std::string &) const
  2. Access protein ratios and associated peptide quant keys:
    • getProteinRatio(const std::string &, int, const std::string &) const
    • getProteinRatio(const std::string &, int, const std::string &, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const
    • getPeptideQuantKeys(const std::string &, int) const
  3. Access and modify quantitation method settings related to protein ratio calculation:
    • getQuantitationMethod() const
    • setPeptideRatioExcluded(const ms_peptide_quant_key &, const std::string &)
    • setQuantOutliers(const ms_quant_outliers *)
    • setMinNumPeptides(int value)
    • setProteinRatioType(const char *value)

Protein ratios are calculated from peptide ratios on demand, which means changing any of the protein ratio related quantitation method settings will take effect immediately. Depending on child class, peptide ratios are either extracted from a Mascot results file (ms_ms2quantitation) or constructed manually (ms_customquantitation).

Two kinds of indexing are used: peptide ratios are identified by the tuple (peptide quant key, ratio name) and protein ratios are identified by the triplet (accession, database index, ratio name). Ratio name refers to the name of report ratios defined in the quantitation method. For example, for iTRAQ 4-plex this could be "115/114", "116/114" and "117/114". You can find the ratio names from the quantitation method object using ms_quant_method::getReportRatioByNumber().

In ms_ms2quantitation, the mapping between peptide ratios and the peptide ID triplet is one-to-one; that is, each peptide ratio has a single associated query and rank (q,p value), from which its peptide quant key is constructed.

In ms_customquantitation, peptide quant keys are free-form.

In both cases, the protein database index is usually the return value of ms_protein::getDB() for Mascot search results, but need not be in ms_customquantitation. See the latter's documentation for details.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
ms_protein_quant_ratio calculateGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected]

Given a sample of peptide ratios, calculate the geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
ms_protein_quant_ratio calculateMedianRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected]

Given a sample of peptide ratios, calculate the median and standard deviation from the median.

See ms_quant_stats::sortedMedian for details of how this is calculated.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-values, if relevant.
ms_protein_quant_ratio calculateWeightedGeometricMeanRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< double > & | sample,
 |  | const std::vector< double > & | logSample,
 |  | const std::vector< double > & | weights,
 |  | const std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | const std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double | normalityPvalue
 | ) |  | const [protected]

Given a sample of peptide ratios, calculate the weighted geometric mean and standard deviation.

Parameters:
accession | Protein accession. This is returned verbatim in the returned object and not used otherwise.
dbIdx | Protein database index. This is returned verbatim in the returned object and not used otherwise.
ratioName | Ratio name. This is returned verbatim in the returned object and not used otherwise.
sample | Sample of peptide ratios in increasing numerical order. Sample size must be at least 1.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
normalityPvalue | The p-value that logSample looks normally distributed.
activeKeys | Peptide quant keys for which sample values are present.
inactiveKeys | Peptide quant keys ignored due to being skipped, excluded or detected as outliers.
Returns:
A protein ratio object encapsulating the calculated ratio, standard deviation and p-value, if relevant.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
int countDistinctPeptides ( const ms_peptide_quant_key_vector & activeKeys ) const [virtual]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

This function just calls countDistinctPeptides(const ms_peptide_quant_key_vector &) (which should call the relevant ms_ms1quantitation or ms_ms2quantitation version.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.
int countDistinctPeptides ( const std::vector< ms_peptide_quant_key > & activeKeys ) const [virtual]

Get the number of distinct peptides in the list of active candidates.

The base class ms_quantitation does not have enough infomation about the peptides associated with each ms_peptide_quant_key to determine if they are truly distinct. By default, the number of distinct peptides is the number of elements in activeKeys.

In ms_ms1quantitation and ms_ms2quantitation, peptides are treated as distinctly different only if they have a difference in their peptide string.

Parameters:
activeKeys Peptide quant keys that are included in the quantitation of a protein.
Returns:
The number of distinct peptides.

Reimplemented in ms_ms1quantitation, and ms_ms2quantitation.

const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getMinNumPeptides ( ) const [protected]

Get the minimum number of peptides needed for protein ratio calculation.

Returns:
The minimum number of peptides needed for protein ratio calculation.
ms_peptide_quant_key_vector getPeptideQuantKeys | ( | const std::string & | accession,
 |  | int | dbIdx
 | ) |  | const

Look up peptide quant keys associated with a given protein, if any.

In ms_ms2quantitation, the list of peptide quant keys associated with the given protein is immutable, as the keys are derived from q,p values in the Mascot results file. The list does not contain all q,p values, but only those that 1) have component intensities and 2) pass the quality thresholds. Unless the data quality is extremely good, this list will always have fewer elements than the actual peptide matches assigned to the protein hit.

In ms_customquantitation, the peptide-to-protein mapping can be altered with ms_customquantitation::addPeptideQuantKey() and ms_customquantitation::removePeptideQuantKey().

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
Returns:
A vector of peptide quant keys associated with the protein.
ms_peptide_quant_ratio getPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [pure virtual]

Given peptide quant key and ratio name, return the corresponding peptide ratio data.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

If hasPeptideRatio(const ms_peptide_quant_key&, std::string) const returns false for the given peptide quant key and ratio name, then the peptide ratio object returned by this method represents an undefined ("missing") value.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
The peptide ratio. If hasPeptideRatio() returns false, the field values of the object returned by this method are undefined.

Implemented in ms_customquantitation, and ms_ms2quantitation.

double getPeptideRatioNormalisationBase ( const std::string & ratioName ) const

Get the peptide ratio normalisation base of the given ratio name.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName Peptide ratio name.
Returns:
The current peptide ratio normalisation base, or 1 if it hasn't been set.
const matrix_science::ms_progress_info & getProgressInfo ( )

Get information about the progress of a currently running long operation (e.g. loading from a file).

Returns:
Progress information about the most recent long operation.
ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName
 | ) |  | const [pure virtual]

Given the protein accession, database ID and ratio name, return the protein ratio data.

Protein ratios are calculated on demand from the current protein-peptide mapping using the current quantitation method and taking peptide exclusion into account. You can exclude peptides from protein ratio calculation by using setPeptideRatioExcluded(). The current outlier detection method may also change which peptide ratios are used for any given protein.

For ms_ms2quantitation, the protein-peptide mapping is immutable. There are three types of protein ratio, which can be changed with setProteinRatioType(): median, average and weighted. Median is the median of all peptide ratios associated with the protein hit, and average is the geometric mean (equivalently, the arithmetic mean of log-transformed peptide ratios). Weighted is a weighted mean of peptide ratios, where the weights are channel intensities. The weighted ratio type is only available for Reporter data.

For ms_customquantitation, you can change the protein-peptide mapping by associating different peptide quant keys with the protein accession; see ms_customquantitation::addPeptideQuantKey() for details. There are three types of protein ratio: median, average and weighted. Median and average are the same as in ms_ms2quantitation, except in the Average protocol (see below). Weighted is the weighted geometric mean, where the weighting factor of each peptide ratio must be specified when the peptide ratio is added to the class. This is not the same weighting as in ms_ms2quantitation.

ms1, ms2 and custom protein ratios are calculated using:

  • median - See ms_quant_stats::sortedMedian
  • average - See ms_quant_stats::geometricMean
  • weighted - See ms_quant_stats::weightedArithmeticMean

It is possible for the protein ratio to be undefined ("missing") even when it has associated peptide ratios, if there are not enough peptide ratios (setMinNumPeptides()), if all of them are marked excluded, or if too many of them are infinite.

If quantitation protocol is Reporter, Multiplex, Replicate or Precursor, the returned protein ratio object contains two p-values: the normality test value and the null hypothesis value.

The log-transformed peptide ratios are assumed normally distributed, and this hypothesis is tested using the Shapiro-Wilk W test. The normality p-value is -1 when the test could not be run (e.g. too few peptide ratios) and otherwise a positive number between 0 and 1. In the latter case, a value of less than 0.05 (or similar threshold) is usually taken as evidence that the log-transformed peptide ratios are not normally distributed, or equivalently that the peptide ratios are not log-normally distributed.

If outlier removal is configured, then outliers will be removed before normality testing. If this makes the normality p-value fall below 0.05, then the outliers will be restored. In this case the original sample was likely not normal to start with, and the normality p-value is calculated based on the original sample. If outlier removal is successful, then the normality p-value is based on the sample from which outliers have been removed, and it always exceeds 0.05.

The second p-value is for the null hypothesis. The null hypothesis is that the protein ratio equals 1.0 (component intensities have equal values). The p-value is -1 if there is only one peptide ratio, and otherwise a positive number between 0 and 1. The test is conducted after outlier removal, if any.

Note that the hypothesis test is done regardless of the p-value of the normality test. This means that you need to decide first if you accept peptide ratio normality before deciding whether to reject or not reject the null hypothesis. If normality is violated, then the hypothesis p-value is meaningless.

You can inspect which peptide quant keys were used in protein ratio calculation and which were ignored, due to being excluded or being outliers, with ms_protein_quant_ratio::getActiveKeys(), ms_protein_quant_ratio::getExcludedKeys() and ms_protein_quant_ratio::getOutlierKeys(). You can "move" peptide quant keys between the last two categories and the first by using the method getProteinRatio(const std::string &, int, const std::string &, const ms_peptide_quant_key_vector &, const ms_peptide_quant_key_vector &) const.

Note about weighted protein ratios: Parser 2.5 and 2.6 do not calculate the standard deviation, standard error or p-values when protein ratio type is weighted in Reporter data. The values are set to -1 ("unavailable"); see ms_protein_quant_ratio::getStandardDeviation(). The values are available in ms_customquantitation, which uses a different weighting formula.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average", which does not mean a geometric average. Rather, the protein ratio is the sum of the "top N" peptide intensities, divided by the sum of the top N peptide intensities of the reference protein (see ms_customquantitation::setAverageReferenceProtein()). Neither outlier removal nor normalisation have any meaning in this protocol, which means no significance tests are done and the returned protein ratio object will not contain any p-values.

For more details on configuring other aspects of protein ratio calculation, please consult the quantitation help pages.

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
Returns:
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implemented in ms_customquantitation, ms_ms1quantitation, and ms_ms2quantitation.

ms_protein_quant_ratio getProteinRatio | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const ms_peptide_quant_key_vector & | includeKeys,
 |  | const ms_peptide_quant_key_vector & | excludeKeys
 | ) |  | const [pure virtual]

Given the protein accession, database ID and ratio name, return the protein ratio data, overriding the default inclusion and exclusion of the specified peptide quant keys.

The protein ratio is calculated as described in getProteinRatio(const std::string &, int, const std::string &) const, but the two peptide quant key vectors includeKeys and excludeKeys can be used to override default decisions about globally excluded and outlier peptide ratios. The rules are as follows:

  1. If a peptide quant key is globally excluded with setPeptideRatioExcluded(), then giving the peptide quant key in includeKeys causes the peptide quant key to be included regardless ("undo global exclusion").
  2. If a peptide quant key is given in excludeKeys, then the peptide quant key will be always excluded ("exclude locally").

If the peptide quant key is in both includeKeys and excludeKeys, the latter takes precedence and the peptide quant key is excluded.

Note that if outlier detection is enabled, then a peptide quant key determined to be an outlier cannot be included back using includeKeys, i.e. the inclusion mechanism does not undo outlier removal. You can disable outlier removal entirely before calling getProteinRatio() if you do not want peptide quant keys to be removed.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, then the effect of excludeKeys depends on whether the peptide quant key describes a "top N" peptide intensity. If the peptide intensity is one of the top N intensities assigned to this protein, then excluding it means the next highest outside the top N intensities will take its place. No peptide quant keys will ever be excluded automatically as outliers, since outlier removal has no meaning in this protocol.

Parameters:
accession | The protein accession.
dbIdx | The protein database index.
ratioName | The name of the ratio.
includeKeys | Peptide quant keys to always include, even if they are globally excluded or would be marked as outliers.
excludeKeys | Peptide quant keys to always exclude, even if they are not outliers.
Returns:
The protein ratio as calculated from peptide ratios associated with this protein accession. If the ratio could not be calculated (e.g. there are no associated peptide ratios), then the returned object will represent an undefined ("missing") value.

Implemented in ms_customquantitation, ms_ms1quantitation, and ms_ms2quantitation.

void getProteinRatioSample | ( | const std::string & | accession,
 |  | int | dbIdx,
 |  | const std::string & | ratioName,
 |  | const std::vector< ms_peptide_quant_key > & | includeKeys,
 |  | const std::vector< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | sample,
 |  | std::vector< double > & | logSample,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys,
 |  | double & | normalityPvalue
 | ) |  | const [protected]

Find the peptide quant keys associated with the protein, collect their unique peptide ratios, remove outliers (if desired) and return the values as the sample of peptide ratios.

This method uses getSortedFinitePeptideRatioValues() internally to collect the vector of peptide ratios. If there are no peptide quant keys associated with the protein, or if no peptide ratios are associated with with those peptide quant keys, then sample, logSample, activeKeys and inactiveKeys will be empty and normalityPvalue will have an undefined value.

Parameters:
accession | Protein accession.
dbIdx | Protein database index.
ratioName | Name of the ratio.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
sample | Peptide ratios associated with ratioName and the protein's peptide quant keys, in numerically increasing order.
logSample | Log transform of sample.
weights | Weighting factors corresponding to the order of sample (and logSample).
activeKeys | Peptide quant keys corresponding to the order of sample (and logSample).
inactiveKeys | Peptide quant keys marked as skipped, excluded or outlier.
normalityPvalue | The p-value that the sample appears to be normally distributed after outlier removal. If less than 0.05, no outliers will have been removed.
const ms_quant_method & getQuantitationMethod ( ) const

Return the current quantitation method.

The current (or effective) quantitation method is the original quantitation method given as argument to the constructor (or loaded from the Mascot results file), with possible later modifications, such as changing normalisation or outlier settings.

For ms_ms2quantitation, you cannot change the protocol settings, component definitions or peptide quality settings. You must create a new object with the new settings instead. You are free to change how protein ratios are calculated and set new normalisation parameters. These changes will be reflected in this method's output value.

For ms_customquantitation, same restrictions apply, although it makes little difference, as the class does not use any protocol settings, component definitions or peptide quality settings.

Returns:
The current quantitation method.
void getSortedFinitePeptideRatioValues | ( | const std::string & | ratioName,
 |  | const std::set< ms_peptide_quant_key > & | keys,
 |  | const std::set< ms_peptide_quant_key > & | includeKeys,
 |  | const std::set< ms_peptide_quant_key > & | excludeKeys,
 |  | std::vector< double > & | values,
 |  | std::vector< double > & | weights,
 |  | std::vector< ms_peptide_quant_key > & | activeKeys,
 |  | std::map< ms_peptide_quant_key, int > & | inactiveKeys
 | ) |  | const [protected, pure virtual]

Given a list of q,p values and ratio name, find the non-infinite peptide ratio values and return them in numerically increasing order.

The method looks up all peptide ratios associated with keys (ignoring duplicates) and returns them in numerically increasing order in values. Infinite and missing ratios are ignored. The vector activeKeys contains active peptide quant keys in the same order as values, and the map inactiveKeys contains peptide quant keys associated with the protein ratio but for indicated reasons not included in ratio calculation.

Parameters:
ratioName | The name of the peptide ratio.
keys | A list of (sorted or unsorted) peptide quant keys for which to look up the ratios.
includeKeys | Prevent these peptide quant keys from being excluded.
excludeKeys | Prevent these peptide quant keys from being included.
values | Peptide ratios associated with ratioName and the given peptide quant keys.
weights | Weighting factors of corresponding to the order of values.
activeKeys | Peptide quant keys corresponding to the order of values.
inactiveKeys | Peptide quant keys skipped or excluded.

Implemented in ms_customquantitation, and ms_ms2quantitation.

bool hasPeptideRatio | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [pure virtual]

Existence check: return true if a peptide ratio with the associated peptide quant key and ratio name exists.

Often, most peptide matches in a Mascot results file have no ratio data. For example, the peptide match could be non-significant or not quantitable (quality check fails); or with Reporter or Multiplex protocol, the MS/MS spectrum may not contain all component intensities required for ratio calculation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratios are interpreted as raw intensity values. It is usually meaningless to define more than one ratio name in this case.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio exists; false otherwise.

Implemented in ms_customquantitation, and ms_ms2quantitation.

bool initialiseBaseSettings | ( | const ms_quant_method & | qmBase,
 |  | const ms_quant_method & | qmConfig
 | ) |  | [protected]

Initialise quantitation method settings from the two method objects.

For any method settings which are not consistent between the passed qmBase and qmConfig, the values from qmConfig will be used.

Parameters:
qmBase | The base quantitation method as defined on the Mascot server.
qmConfig | The quantitation method to use to calculate quantitation results using.
Returns:
True.
bool isPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | const [pure virtual]

Boolean flag: is the given peptide ratio globally excluded from protein ratio calculation?

(This method is redundant; you could also look up the peptide ratio and use ms_peptide_quant_ratio::isExcluded().)

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.
Returns:
True if the peptide ratio should be excluded from protein ratio calculation; false otherwise.

Implemented in ms_customquantitation, and ms_ms2quantitation.

bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void removePeptideRatioNormalisationBase ( const std::string & ratioName )

Reset the peptide ratio normalisation base of the given ratio name.

Resetting means the report ratio normalisation constant is set to 1.0. This has the same effect as calling setPeptideRatioNormalisationBase() with b = 1.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

Parameters:
ratioName Ratio name whose normalisation base is to be reset.
void removePeptideRatioNormalisationBases ( )

Reset all peptide ratio normalisation bases.

Resetting all report ratio normalisation bases means all peptide and protein ratios become unnormalised.

In ms_ms2quantitation, resetting a normalisation constant is possible even if normalisation settings have been configured with setQuantNormalisation() and normalisePeptideRatios() has been called. It is generally not a good idea to reset normalisation bases, because it will lead to inconsistent peptide ratios.

void setMinNumPeptides ( int value )

Set the minimum number of peptides needed for protein ratio calculation.

Changing the minimum number of peptides changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: The Average protocol has two settings for minimum number of peptides. This setting defines how many peptide intensities are needed for a protein before its ratio can be calculated. It is usually meaningless to choose a value other than 1. Use ms_customquantitation::setAverageNumPeptides() to define how many intensities should be used in protein ratio calculation.

Parameters:
value The minimum number of peptide ratios (the sample size) a protein must have for protein ratio calculation purposes. Values less than 1 are interpreted as 1.
void setPeptideRatioExcluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [pure virtual]

Globally exclude a particular peptide ratio from protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implemented in ms_customquantitation, and ms_ms2quantitation.

void setPeptideRatioIncluded | ( | const ms_peptide_quant_key & | key,
 |  | const std::string & | ratioName
 | ) |  | [pure virtual]

Globally include a particular peptide ratio in protein ratio calculation.

All peptide matches associated with a protein ratio are used in calculating that protein's ratio, assuming the peptide ratio passes outlier testing (if used). This may not be desirable in some cases; for example, visual inspection could indicate the peptide match is incorrect. You can use setPeptideRatioExcluded() and setPeptideRatioIncluded() to globally exclude or include individual peptide ratios.

Parameters:
key | The peptide quant key of the peptide ratio.
ratioName | The name of the ratio.

Implemented in ms_customquantitation, and ms_ms2quantitation.

void setPeptideRatioNormalisationBase | ( | const std::string & | ratioName,
 |  | double | b
 | ) |  |

Set the peptide ratio normalisation base of the given ratio name.

Setting peptide ratio normalisation to a particular value means all peptide ratios with ratioName will be divided by b before they are returned by getPeptideRatio(). That is, the underlying peptide ratios remain unaffected, which means this method will always return immediately without computing anything.

In ms_ms2quantitation, normalisation constants can most easily be calculated with ms_ms2quantitation::normalisePeptideRatios(), if normalisation is enabled and configured in the quantitation method. You are free to override this, but keeping track of who calculated which constant is up to you.

It is not a good idea to define both peptide ratio normalisation and component intensity normalisation at the same time. In fact, you can only configure one or the other using setQuantNormalisation(), and neither normalisePeptideRatios() nor normaliseIntensities() will step on each other's toes.

It is possible, but not recommended, to manually set normalisation bases for both peptide ratios and component intensities. The resulting peptide ratios are most likely meaningless.

In ms_customquantitation, you can use ms_customquantitation::getUnnormalisedAveragePeptideRatio() to calculate the mean or median of peptide ratios currently stored in the class, for normalisation purposes.

You can always set b to 1 to disable peptide ratio ratioName normalisation.

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, peptide ratio normalisation has no meaning. It is strongly recommended to not set normalisation constants.

Parameters:
ratioName | Peptide ratio name to normalise.
b | New normalisation base. If it is zero, the old base will be kept. If this is the first time the base is set, a value of 0 means it is set to 1.0.
void setProteinRatioType ( const char * value ) [pure virtual]

Set the protein ratio type.

Changing the protein ratio type changes the current quantitation method. It does not alter the original quantitation method object.

ms_ms2quantitation supports "median", "average" and "weighted", and ms_customquantitation supports "median" and "average. If the ratio type is not implemented, it is set to "median".

Using the Average protocol in ms_customquantitation: If quantitation protocol is Average, the only supported protein ratio type is "average". Setting it to anything else will result in an error. You should inspect isValid() and use clearAllErrors() should you accidentally do so.

Parameters:
value Protein ratio type (e.g. median, average, weighted). Accepted values are defined in the quantitation XML schema.

Implemented in ms_customquantitation, and ms_ms2quantitation.

void setQuantOutliers ( const ms_quant_outliers * qo ) [pure virtual]

Set new peptide ratio outlier settings.

Peptide ratio outlier detection can be configured in several ways. Please consult the quantitation configuration help page for details.

Changing outlier settings changes the current quantitation method. It does not alter the original quantitation method object.

Using the Average protocol in ms_customquantitation: It is an error to define outlier removal if quantitation protocol is Average. You will need to inspect isValid() and clear the error with clearAllErrors() should you accidentally do so.

Parameters:
qo An outlier configuration object. If this is NULL, outlier detection will be disabled (equivalent to "none").

Implemented in ms_customquantitation, and ms_ms2quantitation.

The documentation for this class was generated from the following files:
  • ms_quantitation.hpp
  • ms_quantitation.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_shapiro_wilk
Public Member Functions | Static Public Member Functions

ms_shapiro_wilk Class Reference
[Quantitation analysis for Mascot Server and Distiller]

The Shapiro-Wilk W test. More...

#include <ms_shapiro_wilk.hpp>

List of all members.

Public Member Functions

ms_shapiro_wilk ()
ms_shapiro_wilk (std::deque< std::pair< size_t, double > > x, long n, long n1, long n2)
The Shapiro-Wilk W test.
void | appendSampleValue (double y)
Add a new sample value to the list to be tested.
void | calculate (long n, long n1, long n2)
Calculate results using values previously added using appendSampleValue().
void | clearSampleValues ()
Clear current vector of X values.
double | getErrorCode () const
Returns the error code for the Shapiro-Wilks W-statistic.
double | getPValue () const
Returns the P-value for the Shapiro-Wilks W-statistic.
double | getResult () const
Returns the Shapiro-Wilks W-statistic.

Static Public Member Functions

static void | swilk (bool init, std::deque< std::pair< size_t, double > > x, long n, long n1, long n2, std::deque< double > &a, double &w, double &pw, int &ifault)
AS R94: Calculate the Shapiro-Wilk W test statistic and p-value directly.

Detailed Description

The Shapiro-Wilk W test.

Testing for normality

Testing for outliers and reporting a standard deviation for the protein ratio can only be performed if the peptide ratios are consistent with a sample from a normal distribution (in log space). If the peptide ratios do not appear to be from a normal distribution, this may indicate that the values are meaningless, and something went systematically wrong with the the analysis. On the other hand, it may indicate something interesting, like the peptides have been mis-assigned and actually come from two proteins with very different ratios, so that the distribution is bimodal. Interpretation of test success or failure must be done on a case by case basis.

Shapiro-Wilk W test

In the Shapiro-Wilk W test, the null hypothesis is that the sample is taken from a normal distribution. This hypothesis is rejected if the critical value P for the test statistic W is less than 0.05. The routine used is valid for sample sizes between 3 and 2000.

Source code for the Shapiro-Wilk W test algorithm

References:

  1. Royston, J. P. (1982): An Extension of Shapiro and Wilk's W Test for Normality to Large Samples. Journal of the Royal Statistical Society Series C (Applied Statistics) 31(2):115-124.
  2. Royston, J. P. (1982): Algorithm AS 181: The W Test for Normality. Journal of the Royal Statistical Society Series C (Applied Statistics) 31(2):176-180.
  3. Royston, P. (1995): Remark AS R94: A Remark on Algorithm AS 181: The W-test for Normality. Journal of the Royal Statistical Society Series C (Applied Statistics) 44(4):547-551.
  4. Algorithms AS R94, AS 66 and AS 241 from StatLib: http://lib.stat.cmu.edu/

Constructor & Destructor Documentation

ms_shapiro_wilk ( )

Default constructor.

ms_shapiro_wilk | ( | std::deque< std::pair< size_t, double > > | x,
 |  | long | n,
 |  | long | n1,
 |  | long | n2
 | ) |  |

The Shapiro-Wilk W test.

Note:
This constructor can only be called from C++. For other languages, use the appendSampleValue() and calculate() functions.

After calling this constructor, check for any error using getErrorCode() and then check that getPValue() returns a value greater than 0.05 to determine if it is a normal distribution.

Parameters:
x | is a list of the sample values in increasing order. The first (optional) item in the pair is typically used for an index. This value is not used by the algorithm, but provided as a convenience. The second item in the pair is the sample value.
n | is the total sample size (including any right-censored values).
n1 | is the number of uncensored cases (n1 <= n).
n2 | is the integer part of n/2.

Member Function Documentation

void appendSampleValue ( double x )

Add a new sample value to the list to be tested.

Add a new sample value to the list to be tested when calling calculate(). Sample values must be added in increasing order.

Parameters:
x is the sample value to be added to the list.
void clearSampleValues ( )

Clear current vector of X values.

If multiple calls to calculate() are to be made for different sample values, then call this function before calling appendSampleValue().

double getErrorCode ( ) const

Returns the error code for the Shapiro-Wilks W-statistic.

Possible error codes are:

  • 0 for no error
  • 1 if n1 < 3
  • 2 if n > 5000 (a non-fatal error, but the accuracy of the p-value is not guaranteed in this case)
  • 3 if n2 < n/2
  • 4 if n1 > n or (n1 < n and n < 20).
  • 5 if the proportion censored (n - n1)/n > 0.8.
  • 6 if the data have zero range.
  • 7 if the sample values are not sorted in increasing order
  • 8 if error return from ppnd7 (which should never occur in normal operation)
Returns:
error code
void swilk | ( | bool | init,
 |  | std::deque< std::pair< size_t, double > > | x,
 |  | long | n,
 |  | long | n1,
 |  | long | n2,
 |  | std::deque< double > & | a,
 |  | double & | w,
 |  | double & | pw,
 |  | int & | ifault
 | ) |  | [static]

AS R94: Calculate the Shapiro-Wilk W test statistic and p-value directly.

Translated to C++ from the F77 version of AS R94 in StatLib.

Royston, P. (1995): Remark AS R94: A Remark on Algorithm AS 181: The W-test for Normality. Journal of the Royal Statistical Society Series C (Applied Statistics) 44(4):547-551.

In the F77 version of this function, the w parameter could be used to alter the function's behaviour. That feature has not been retained here.

Parameters:
[in] | init | If false, initialise the scratch vector a.
[in] | x | Sample values sorted in increasing order.
[in] | n | Total sample size (usually x.size() cast to long).
[in] | n1 | Sample size less censored cases (n1 <= n; often n1 = x.size()).
[in] | n2 | (long)(n/2)
[in,out] | a | Scratch vector used by the algorithm.
[out] | w | The Shapiro-Wilk W statistic calculated from the data.
[out] | pw | The P-value of the statistic under the null hypothesis.
[out] | ifault | Error code, documented in getErrorCode(). If 0 or 2, then both w and pw were calculated. Otherwise an error occurred.
The documentation for this class was generated from the following files:
  • ms_shapiro_wilk.hpp
  • ms_shapiro_wilk.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


  • matrix_science
  • ms_xic
Public Types | Public Member Functions | Static Public Member Functions

ms_xic Class Reference
[Quantitation analysis for Mascot Server and Distiller]

An eXtracted Ion Chromatogram (XIC). More...

#include <ms_xic.hpp>

Inherits matrix_science::ms_handle.

List of all members.

Public Types

enum peakState {
PEAK_STATE_UNKNOWN = 0,
PEAK_STATE_OK = 1,
PEAK_STATE_DISCARD = 3
}

Status codes from fitting peaks.

More...

Public Member Functions

ms_xic ()
Default constructor.
ms_xic (const ms_xic_body &body)
Populated constructor. Performs a deep copy of the passed object.
ms_xic (ms_xic_body *body)
Constructor that use the same pointer as passed.
void | copyFrom (const ms_xic *src)
Perform a deep copy of the contents.
void | defaultValues ()
Use this member to re-initialise internal members.
double | getElutionTimeShift () const
Get the elution time shift in seconds.
int | getEndIndex () const
Get the end index. Only valid if the XIC was processed separately.
int | getEndScanId () const
Get the id of the end scan.
int | getNumPoints () const
Get the number of points.
int | getPeakEndIndex () const
Get the end of the peak. Only valid if the XIC was processed separately.
int | getPeakEndScanId () const
Get the index of the peak end.
int | getPeakStartIndex () const
Get the start of the peak. Only valid if the XIC was processed separately.
int | getPeakStartScanId () const
Get the index of the peak start.
peakState | getPeakState () const
Get the state of the peak.
void | getPoint (int index, double &rt, int &scanId, double &intensity) const
Get a point's values; retention time, scan number and intensity (index 1..n).
int | getRegionEndIndex () const
Get the end of the region. Only valid if the XIC was processed separately.
int | getRegionEndScanId () const
Get the index of the region end.
int | getRegionStartIndex () const
Get the start of the region. Only valid if the XIC was processed separately.
int | getRegionStartScanId () const
Get the index of the region start.
double | getRtPeakEnd () const
Get the retention time of the peak end.
double | getRtPeakStart () const
Get the retention time of the peak start.
double | getRtRegionEnd () const
Get the retention time of the region end.
double | getRtRegionStart () const
Get the retention time of the region start.
int | getStartIndex () const
Get the start index. Only valid if the XIC was processed separately.
int | getStartScanId () const
Get the id of the start scan.
bool | getUseTimeShift () const
Returns true if XIC are aligned based on time instead of scans.
bool | hasIndexes () const
Return true if the functions that return indexes have valid data available to return.

Static Public Member Functions

static peakState | getCodeFromXml (std::string text)
Get the status code for an XML attribute value.
static std::string | getXmlCode (peakState code)
Get the XML attribute value for a status code.

Detailed Description

An eXtracted Ion Chromatogram (XIC).

This consists of a number of individual intensity values.

It also has start and end values and indices for the peaks, regions and the chromatogram itself

This is stored in XML in a "xic" entity.

Member Enumeration Documentation

enum peakState

Status codes from fitting peaks.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
PEAK_STATE_UNKNOWN

initial value

PEAK_STATE_OK

element is ok

PEAK_STATE_DISCARD

discard element from calc

Constructor & Destructor Documentation

ms_xic ( )

Default constructor.

Assigns reasonable default values to all internal members.

ms_xic ( const ms_xic_body & body ) [explicit]

Populated constructor. Performs a deep copy of the passed object.

Parameters:
body The data loaded from the result file.
ms_xic ( ms_xic_body * body ) [explicit]

Constructor that use the same pointer as passed.

Parameters:
body Is a pointer to existing data. The reference count for this will be incremented by this call.

Member Function Documentation

void defaultValues ( )

Use this member to re-initialise internal members.

Clears all values

ms_xic::peakState getCodeFromXml ( std::string text ) [static]

Get the status code for an XML attribute value.

Parameters:
text The string used to encode the peak state in the XML file.
Returns:
The peak state corresponding to the XML encoded string.
double getElutionTimeShift ( ) const

Get the elution time shift in seconds.

Returns:
The value of the elution time shift.
int getEndIndex ( ) const

Get the end index. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is typically a zero based index of MS1 scans (either Survey or zoom) that have been 'filtered out' from all scan types

Returns:
Index at which the the XIC ends.
int getEndScanId ( ) const

Get the id of the end scan.

Returns:
The scan identifier at which the XIC ends.
int getNumPoints ( ) const

Get the number of points.

Returns:
The number of points in the XIC.
int getPeakEndIndex ( ) const

Get the end of the peak. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns:
Index at which the peak ends.
int getPeakEndScanId ( ) const

Get the index of the peak end.

Returns:
The scan identifier at which the peak ends.
int getPeakStartIndex ( ) const

Get the start of the peak. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns:
Index at which the peak starts.
int getPeakStartScanId ( ) const

Get the index of the peak start.

Returns:
The scan identifier at which the peak starts.
ms_xic::peakState getPeakState ( ) const

Get the state of the peak.

Returns:
The peak state.
void getPoint | ( | int | index,
 |  | double & | rt,
 |  | int & | scanId,
 |  | double & | intensity
 | ) |  | const

Get a point's values; retention time, scan number and intensity (index 1..n).

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | index | The index of the point to be queried (1..number of points).
[out] | rt | Filled with the retention time of the point.
[out] | scanId | Filled with the scan identifier of the point.
[out] | intensity | Filled with the intensity of the point.
int getRegionEndIndex ( ) const

Get the end of the region. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns:
Index at which the region ends.
int getRegionEndScanId ( ) const

Get the index of the region end.

Returns:
The scan identifier at which the region ends.
int getRegionStartIndex ( ) const

Get the start of the region. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is a zero based index into the points array and should be 0..getNumPoints()

Returns:
Index at which the region starts.
int getRegionStartScanId ( ) const

Get the index of the region start.

Returns:
The scan identifier at which the region starts.
double getRtPeakEnd ( ) const

Get the retention time of the peak end.

Returns:
The retention time of the peak end.
double getRtPeakStart ( ) const

Get the retention time of the peak start.

Returns:
The retention time of the peak start.
double getRtRegionEnd ( ) const

Get the retention time of the region end.

Returns:
The retention time of the region end.
double getRtRegionStart ( ) const

Get the retention time of the region start.

Returns:
The retention time of the region start.
int getStartIndex ( ) const

Get the start index. Only valid if the XIC was processed separately.

If loaded from XML this may be -1. XML version 1 does not store this information and considerable recalculate would be required to reproduce it.

The index is typically a zero based index of MS1 scans (either Survey or zoom) that have been 'filtered out' from all scan types

Returns:
Index at which the the XIC starts.
int getStartScanId ( ) const

Get the id of the start scan.

Returns:
The scan identifier at which the XIC starts.
bool getUseTimeShift ( ) const

Returns true if XIC are aligned based on time instead of scans.

Returns:
True if the elution time shift should be used.
std::string getXmlCode ( ms_xic::peakState code ) [static]

Get the XML attribute value for a status code.

Parameters:
code The peak state to get the XML excoding string for.
Returns:
The string used to encode the peak state in the XML file.
bool hasIndexes ( ) const

Return true if the functions that return indexes have valid data available to return.

XML version 1 does not store this information and considerable recalculate would be required to reproduce it. And it's optional in the XML anyway.

Returns:
True if the XIC has all the index information, otherwise false.
The documentation for this class was generated from the following files:
  • ms_xic.hpp
  • ms_xic.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • matrix_science
  • ms_xic_point

ms_xic_point Class Reference
[Quantitation analysis for Mascot Server and Distiller]

A single point from a matrix_science::ms_xic object. More...

#include <ms_xic.hpp>

List of all members.

Detailed Description

A single point from a matrix_science::ms_xic object.

Contains, the retention time, scanId and intensity

The documentation for this class was generated from the following files:
  • ms_xic.hpp
  • ms_xic.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Classes for calculating masses of peptides and fragments.

Classes

class | ms_aahelper
This class facilitates creation of peptides and calculation of MS-fragment masses. More...
class | ms_fragment
Class representing a single peptide fragment. More...
class | ms_fragmentvector
Class for holding a list of ms_fragment objects. More...

Modules

Examples for the mass calculation module
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Examples for the mass calculation module
[Classes for calculating masses of peptides and fragments.]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
For calculating peptide and fragment masses | tools_aahelper.pl | tools_aahelper.cpp | tools_aahelper.java | tools_aahelper.py | tools_aahelper.cs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_aahelper
Public Types | Public Member Functions

ms_aahelper Class Reference
[Classes for calculating masses of peptides and fragments.]

This class facilitates creation of peptides and calculation of MS-fragment masses. More...

#include <ms_aahelper.hpp>

Inheritance diagram for ms_aahelper:
[legend]
Collaboration diagram for ms_aahelper:
[legend]

List of all members.

Public Types

enum FRAG_NL {
FRAG_NL_PRIMARY = 0x0001,
FRAG_NL_SECONDARY = 0x0010
}

Flag for controlling iteration over multiple neutral losses.

More...

Public Member Functions

ms_aahelper ()
Default constructor.
ms_aahelper (const ms_mascotresfile &resfile, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd")
Constructor from results file.
ms_aahelper (const ms_aahelper &right)
Copying constructor.
ms_aahelper (const ms_mascotresults &summary, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd")
Constructor from peptide summary or protein summary.
~ms_aahelper ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
std::vector< double > | calcFragments (const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
std::vector< double > | calcFragments (const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
bool | calcFragmentsEx (const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
bool | calcFragmentsEx (const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const
Returns a vector of ion masses for the given series and peptide.
double | calcPeptideMZ (const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > numThatMustBeModded, const int charge, const MASS_TYPE massType, ms_errs *err) const
Calculates and returns a peptide m/z (or Mr) value without specifying exact positions of modified residues.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_aahelper *right)
Copies all data from another instance of the class.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
ms_peptide | createCrosslinkedPeptide (const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site_vector &linkedSites, ms_errs *err) const
Creates and returns a crosslinked peptide object.
ms_peptide | createPeptide (const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const
Creates and returns a peptide object.
ms_peptide | createPeptide (const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const std::vector< int > summedMods, const std::vector< int > summedModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const
Creates and returns a peptide object.
void | defaultValues ()
Initialises the instance.
const ms_enzyme * | getEnzyme () const
Returns a pointer to the current enzyme.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
ms_modvector | getFixedMods () const
Returns a list of fixed modifications that have been successfully applied i.e. don't have conflicts.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
const ms_masses * | getMasses () const
Returns a pointer to the internal copy of the masses file.
int | getMissed () const
Returns number of missed cleavage sites for the current peptide.
bool | getNextPeptide ()
Call to iterate to the next peptide.
int | getPepEnd () const
Returns the last position of the current peptide.
int | getPepStart () const
Returns the first position of the current peptide.
ms_modvector | getVarMods () const
Returns a list of variable modifications that have no conflicts with fixed modifications.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_aahelper & | operator= (const ms_aahelper &right)
Assignment operator.
void | setAvailableModifications (const ms_modvector *fixedModVector, const ms_modvector *varModVector)
Applies fixed modifications to residue masses and stores variable modifications for later use.
void | setEnzyme (const ms_enzyme *enzyme)
Sets an enzyme to use.
void | setMasses (const ms_masses *masses)
Copies all residue and chemical element masses from the masses file instance.
void | startIteratePeptides (const char *sequenceProtein, const int sizeProtein, const int pfa)
Initialises internal members in preparation for generating peptides.
void | stopIteratePeptides ()
Stop iterating.

Detailed Description

This class facilitates creation of peptides and calculation of MS-fragment masses.

Examples:

tools_aahelper.cpp.

Member Enumeration Documentation

enum FRAG_NL

Flag for controlling iteration over multiple neutral losses.

If any modification has multiple neutral losses, ms_aahelper::calcFragments() and ms_aahelper::calcFragmentsEx() default to calculating fragments for the primary neutral loss. The primary NL choice is encoded in the peptide's neutral loss string (ms_peptide::getPrimaryNlStr()) -- or strings if the peptide has some combination of variable mods, summed mods, ET mods or local mods.

Enumerator:
FRAG_NL_PRIMARY

Calculate fragments for primary neutral loss.

FRAG_NL_SECONDARY

Calculate fragments for non-primary neutral losses.

Constructor & Destructor Documentation

ms_aahelper | ( | const ms_mascotresfile & | resfile,
 |  | const char * | enzymeFileName,
 |  | const char * | quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
 |  | const char * | unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd"
 | ) |  |

Constructor from results file.

This constructor extracts the enzyme information if available from the passed results file object. The masses information is loaded from the file using the matrix_science::ms_mascotresfile::getMasses() function. The modifications are read from the results file and added using setAvailableModifications().

Results files prior to Mascot 2.2 did not include specificity information. If the enzyme definition is not in the results file, the function attempts to load the enzymes file and find the correct enzyme defintion. It then calls the setEnzyme() function. Also, the modification information in the results file doesn't record specificities unambiguously, so these are derived when calcFragmentsEx() or similar are called.

The application should call isValid() after creating the object. If isValid() returns false, error messages are available, see Error Handling

Parameters:
resfile | needs to be a valid resfile object.
enzymeFileName | will only be used for Mascot results files from versions prior to Mascot 2.2 which don't have the specificities in the results file.
quantSchemaFilePath is required for when the results file contains a quantitation method that needs to be loaded and validated against a schema. There are three possible values for this function:

  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfile constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_quant_configfile::setSchemaFileName before calling ms_mascotresfile::getQuantitation(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd files. The quantitation_1.xsd and quantitation_2.xsd files are supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the paths for the .xsd files with the path of the installed xsd fils.
unimodSchemaFilePath is required for results files from Mascot 2.2 and later where the modification information is in the results file in XML format and needs a schema for validation. There are three possible values for this function:

  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfile constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_umod_configfile::setSchemaFileName before calling: ms_mascotresfile::getUnimod(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd file. The unimod_2.xsd file is supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the path for the .xsd with the path of the installed unimod_2.xsd file.
ms_aahelper | ( | const ms_mascotresults & | summary,
 |  | const char * | enzymeFileName,
 |  | const char * | quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
 |  | const char * | unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd"
 | ) |  |

Constructor from peptide summary or protein summary.

This constructor is similar to ms_aahelper(const ms_mascotresfile&, const char*, const char*, const char*), but additionally allows ms_aahelper::calcFragmentsEx() to look up error tolerant modifications and spectral library modifications from the results file.

The constructor extracts the enzyme information if available from the passed results file object. The masses information is loaded from the file using the matrix_science::ms_mascotresfile::getMasses() function. The modifications are read from the results file and added using setAvailableModifications().

Results files prior to Mascot 2.2 did not include specificity information. If the enzyme definition is not in the results file, the function attempts to load the enzymes file and find the correct enzyme defintion. It then calls the setEnzyme() function. Also, the modification information in the results file doesn't record specificities unambiguously, so these are derived when calcFragmentsEx() or similar are called.

The application should call isValid() after creating the object. If isValid() returns false, error messages are available, see Error Handling

Parameters:
summary | needs to be a valid ms_mascotresults object, either ms_peptidesummary or ms_proteinsummary.
enzymeFileName | will only be used for Mascot results files from versions prior to Mascot 2.2 which don't have the specificities in the results file.
quantSchemaFilePath is required for when the results file contains a quantitation method that needs to be loaded and validated against a schema. There are three possible values for this function:

  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfile constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_quant_configfile::setSchemaFileName before calling ms_mascotresfile::getQuantitation(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd files. The quantitation_1.xsd and quantitation_2.xsd files are supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the paths for the .xsd files with the path of the installed xsd fils.
unimodSchemaFilePath is required for results files from Mascot 2.2 and later where the modification information is in the results file in XML format and needs a schema for validation. There are three possible values for this function:

  • NULL or 0 - In this case, the schema directory must have been specified using the XMLschemaDirectory parameter in the ms_mascotresfile constructor. This is the easiest method to use, and is the preferred parameter for Mascot Parser 2.5 and later.
  • If not specified, the default is suitable for when Parser is being used on a Mascot Server.
  • Explicitly passing a string in the appropriate format. This is passed to ms_umod_configfile::setSchemaFileName before calling: ms_mascotresfile::getUnimod(). When using this function on a system where Mascot Server is not installed, it will be necessary to supply the xsd file. The unimod_2.xsd file is supplied with Mascot Parser and will need to be installed with any application that uses this function in Mascot Parser. The format of the string should be the same as the default parameter, just replace the path for the .xsd with the path of the installed unimod_2.xsd file.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
std::vector< double > calcFragments | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const bool | doubleCharged,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | std::vector< ms_fragment > * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

Note:
This method can only be used in C++. Use the other calcFragments() method from other programming languages.

For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters:
peptide | peptide object to generate ion masses for.
seriesID | series number from ms_fragmentationrules::FRAG_SERIES_TYPE.
doubleCharged | some ion series allow double charged fragment; supply TRUE if you want to get mass over charge values for double charged ions only. Otherwise single charged ions will be generated. If the given series doesn't allow double charged ions then an empty list will be returned and err will reflect the inconsistency.
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any existing items in the fragment vector will be overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns:
A vector of ions masses. Use of the return value is deprecated.
std::vector< double > calcFragments | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const bool | doubleCharged,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | ms_fragmentvector * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters:
peptide | peptide object to generate ion masses for.
seriesID | series number from ms_fragmentationrules::FRAG_SERIES_TYPE.
doubleCharged | some ion series allow double charged fragment; supply TRUE if you want to get mass over charge values for double charged ions only. Otherwise single charged ions will be generated. If the given series doesn't allow double charged ions then an empty list will be returned and err will reflect the inconsistency.
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any existing items in the fragment vector will be overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns:
A vector of ions masses. Use of the return value is deprecated.
Examples:
tools_aahelper.cpp.
bool calcFragmentsEx | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const int | fragCharge,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | ms_fragmentvector * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

The difference to calcFragments() is that you can specify explicitly what charge state should all the generated fragments be. The charge state of the peptide-object is ignored then completely. When you need to obtain fragment m/z values for several different charge states just call this method several times and merge the results. For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters:
peptide | peptide object to generate ion masses for.
seriesID | series number from: ms_fragmentationrules::FRAG_SERIES_TYPE.
fragCharge | explicit charge state of the fragments being generated (peptide charge is ignored), zero value for this parameter means "Mr".
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any items in the fragment vector are overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns:
TRUE if succeeded, FALSE if there are any errors.
Examples:
tools_aahelper.cpp.
bool calcFragmentsEx | ( | const ms_peptide * | peptide,
 |  | const int | seriesID,
 |  | const int | fragCharge,
 |  | const double | minMass,
 |  | const double | maxMass,
 |  | const MASS_TYPE | massType,
 |  | std::vector< ms_fragment > * | fragments,
 |  | ms_errs * | err,
 |  | const FRAG_NL | fragNlType = FRAG_NL_PRIMARY
 | ) |  | const

Returns a vector of ion masses for the given series and peptide.

Note:
This method can only be used in C++. Use the other calcFragmentsEx() method from other programming languages.

The difference to calcFragments() is that you can specify explicitly what charge state should all the generated fragments be. The charge state of the peptide-object is ignored then completely. When you need to obtain fragment m/z values for several different charge states just call this method several times and merge the results. For 'regular' sequence type ions, the final fragment mass (approximately the peptide mass less the terminus) will not be returned.

Note that this method does not take the peptide object's seriesUsedStr into account (see ms_peptide::getSeriesUsedStr()). The rules in Mascot state that fragments for neutral loss series (A_MINUS_NH3, A_MINUS_H2O, and corresponding series for B and Y) should only be generated if the peptide match has a statistically significant number of matches to the corresponding singly charged parent ion series (e.g. A_MINUS_NH3 requires enough matches to singly charged A series fragments). You can take this into account by testing whether seriesUsedStr contains 1 or 2 for the singly charged parent ion series. See ms_peptide::getSeriesUsedStr().

Parameters:
peptide | peptide object to generate ion masses for.
seriesID | series number from: ms_fragmentationrules::FRAG_SERIES_TYPE.
fragCharge | explicit charge state of the fragments being generated (peptide charge is ignored), zero value for this parameter means "Mr".
minMass | minimal possible mass value to return.
maxMass | maximal possible mass value to return.
massType | Specify matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
fragments | a vector of items with more detailed information about each peptide fragment. Any items in the fragment vector are overwritten by this function.
err | error object that accumulates messages without affecting the object validity.
fragNlType | (optional) Either ms_aahelper::FRAG_NL_PRIMARY or ms_aahelper::FRAG_NL_SECONDARY. Default is FRAG_NL_PRIMARY.
Returns:
TRUE if succeeded, FALSE if there are any errors.
double calcPeptideMZ | ( | const char * | proteinStr,
 |  | const int | proteinLen,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const std::vector< int > | numThatMustBeModded,
 |  | const int | charge,
 |  | const MASS_TYPE | massType,
 |  | ms_errs * | err
 | ) |  | const

Calculates and returns a peptide m/z (or Mr) value without specifying exact positions of modified residues.

This method can be called when only minimal (e.g. PMF search) information is available:

  • Terminus positions.
  • Fixed mods.
  • Number of modified residues , but not modified positions.

Before calling this function, call setAvailableModifications() to set up any modifications.

This function does not currently support Multiple modifications for the same site

numThatMustBeModded is a vector of integers. Each element of the vector corresponds to a variable modification. The first element corresponds to the first variable modification pushed onto the vector. So, pushing three values, 3,0,2 onto the vector would specify that 3 residues are modified by the first variable mod, and 2 residues are modified by the third variable mod. The size of this vector can be less than the number of available variable modifications - missing elements are assumed to be zeros.

The err object should be checked after calling this function to see if there are inconsistencies.

Parameters:
proteinStr | a protein sequence string. C++: it does not need to be null terminated.
proteinLen | protein sequence length.
startPos | the first peptide position. Specify 1 for the peptide to start at the first amino acid.
endPos | the last peptide position. For example, startPos=1 and endPos=3 would give a peptide 3 residues long.
numThatMustBeModded | is a vector of integers. See above, and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
charge | 0 for de-charged mass, n for n-charged peptides.
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
err | error object that accumulates messages without affecting the object validity
Returns:
The peptide m/z. If the charge specified was zero, then the relative mass (Mr) value will be returned.
Examples:
tools_aahelper.cpp.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
ms_peptide createCrosslinkedPeptide | ( | const ms_peptide & | pepAlpha,
 |  | const ms_peptide & | pepBeta,
 |  | const ms_linker_site_vector & | linkedSites,
 |  | ms_errs * | err
 | ) |  | const

Creates and returns a crosslinked peptide object.

The following conditions are checked. If any one is not satisfied, the method sets a corresponding error and returns an "empty" ms_peptide object.

  • pepAlpha must be a valid linear peptide (not crosslinked).
  • pepBeta must be a valid linear peptide (not crosslinked).
  • pepAlpha must not have a variable modification at the linker site.
  • pepBeta must not have a variable modification at the linker site.
  • linkedSites must contain exactly 1 element.
  • The linker site in alpha must be within the range 0..n, where n is the length of alpha's variable mods string.
  • The linker site in beta must be within the range 0..m, where m is the length of beta's variable mods string.

Standard terminology recommends that alpha should be the longer or heavier molecule than beta, but there is no check for this.

Linker mass can be positive, zero or negative, although typically it is positive.

Parameters:
pepAlpha | is the alpha peptide.
pepBeta | is the beta peptide.
linkedSites | is the vector of links between alpha and beta.
err | is an error object that accumulates messages without affecting the object validity.
Returns:
a crosslinked alpha-beta peptide.
ms_peptide createPeptide | ( | const char * | proteinStr,
 |  | const int | proteinLen,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const std::vector< int > | varMods,
 |  | const std::vector< int > | varModsWhichNl,
 |  | const int | charge,
 |  | const MASS_TYPE | massType,
 |  | ms_errs * | err
 | ) |  | const

Creates and returns a peptide object.

This method can be called if full peptide information is available. It creates and returns a peptide object instance that can then be passed to the calcFragments() method. Only available modifications will be applied

varMods is a vector of integers. It has the same content as modification strings in result files. The first element specifies how N-terminus of the peptide is modified. The next one corresponds to the first residue in the peptide etc. The last element refers to the C-terminus. Each element contain either '0' for non-modified positions or a variable modification number to apply. The size of this vector can also be less than (peptide length + 2) -- missing elements are assumed to be zeros.

varModsWhichNl is also a vector of integers. There is one entry in the vector for each terminus and each residue. For a residue not modified by a modification with neutral loss(es), the value should be zero. For a site modified by a modification with neutral loss(es), a one-based index of neutral loss value to use for this peptide should be supplied. If a value of 0 is specified for a modification with a neutral loss, then the first neutral loss is assumed.

The err object should be checked after calling this function to see if there are inconsistencies.

See also:
getVarMods(), setAvailableModifications()
Parameters:
proteinStr | a protein sequence string. C++: it does not need to be null-terminated.
proteinLen | protein sequence length .
startPos | the first peptide position. Specify 1 for the peptide to start at the first amino acid.
endPos | the last peptide position. For example, startPos=1 and endPos=3 would give a peptide 3 residues long.
varMods | is a vector of modified positions. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
varModsWhichNl | is a similar vector to varMods. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
charge | charge state of the peptide.
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
err | error object that accumulates messages without affecting the object validity
Returns:
An ms_peptide object that can be used with calcFragments().
Examples:
tools_aahelper.cpp.
ms_peptide createPeptide | ( | const char * | proteinStr,
 |  | const int | proteinLen,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const std::vector< int > | varMods,
 |  | const std::vector< int > | varModsWhichNl,
 |  | const std::vector< int > | summedMods,
 |  | const std::vector< int > | summedModsWhichNl,
 |  | const int | charge,
 |  | const MASS_TYPE | massType,
 |  | ms_errs * | err
 | ) |  | const

Creates and returns a peptide object.

This method can be called if full peptide information is available. It creates and returns a peptide object instance that can then be passed to the calcFragments() method. Only available modifications will be applied

varMods is a vector of integers. It has the same content as modification strings in result files. The first element specifies how N-terminus of the peptide is modified. The next one corresponds to the first residue in the peptide etc. The last element refers to the C-terminus. Each element contain either '0' for non-modified positions or a variable modification number to apply. The size of this vector can also be less than (peptide length + 2) -- missing elements are assumed to be zeros.

varModsWhichNl is also a vector of integers. There is one entry in the vector for each terminus and each residue. For a residue not modified by a modification with neutral loss(es), the value should be zero. For a site modified by a modification with neutral loss(es), a one-based index of neutral loss value to use for this peptide should be supplied. If a value of 0 is specified for a modification with a neutral loss, then the first neutral loss is assumed.

summedMods and summedModsWhichNl are identical to varMods and varModsWhichNl except that they apply to Multiple modifications for the same site

The err object should be checked after calling this function to see if there are inconsistencies.

See also:
getVarMods(), setAvailableModifications()
Parameters:
proteinStr | a protein sequence string. C++: it does not need to be null-terminated.
proteinLen | protein sequence length .
startPos | the first peptide position. Specify 1 for the peptide to start at the first amino acid.
endPos | the last peptide position. For example, startPos=1 and endPos=3 would give a peptide 3 residues long.
varMods | is a vector of modified positions. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
varModsWhichNl | is a similar vector to varMods. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
summedMods | is a vector of modified positions. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
summedModsWhichNl | is a similar vector to varMods. See above and also Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
charge | charge state of the peptide.
massType | should be matrix_science::MASS_TYPE_MONO or matrix_science::MASS_TYPE_AVE.
err | error object that accumulates messages without affecting the object validity
Returns:
An ms_peptide object that can be used with calcFragments().
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
ms_modvector getFixedMods ( ) const

Returns a list of fixed modifications that have been successfully applied i.e. don't have conflicts.

Every member of the vector returned is a non-empty modification object. All conflicting modifications have been rejected.

Returns:
Vector of the fixed modifications
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
int getMissed ( ) const

Returns number of missed cleavage sites for the current peptide.

This will return 0 if getNextPeptide() returned false or if stopIteratePeptides() has been called.

Returns:
Number of missed cleavages in the current peptide
bool getNextPeptide ( )

Call to iterate to the next peptide.

Finds a new unique peptide. Call getPepStart() and getPepEnd() to get the new peptide start and end positions.

Returns:
TRUE if successful and FALSE otherwise (e.g. when no more peptides are available).
Examples:
tools_aahelper.cpp.
int getPepEnd ( ) const

Returns the last position of the current peptide.

This will return -1 if getNextPeptide() returned false or if stopIteratePeptides() has been called.

Returns:
Last position of the current peptide
Examples:
tools_aahelper.cpp.
int getPepStart ( ) const

Returns the first position of the current peptide.

This will return -1 if getNextPeptide() returned false or if stopIteratePeptides() has been called.

Returns:
First position of the current peptide
Examples:
tools_aahelper.cpp.
ms_modvector getVarMods ( ) const

Returns a list of variable modifications that have no conflicts with fixed modifications.

The vector returned contains null pointers in place of conflicting modifications. The reason for that is to keep the original order of modifications.

Returns:
Vector of the variable modifications
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
void setAvailableModifications | ( | const ms_modvector * | fixedModVector,
 |  | const ms_modvector * | varModVector
 | ) |  |

Applies fixed modifications to residue masses and stores variable modifications for later use.

The object should be checked for validity after calling this method.

No checking for overlapping modifications is performed.

It is important to remember the order of modifications submitted here as all future calcPeptideMZ(), createPeptide() and calcFragments() method calls will refer to this original order. The modifications are numbered from 1 to n.

There is no need to call this function if an ms_mascotresfile object is passed to the relevant ms_aahelper constructor. When that constructor is called, the mapping of the numbers is exactly as in the deltaX lines of the masses section in the results file. To retrieve the relevant names, use ms_searchparams::getVarModsName() with num=X. The numbers in the strings returned from ms_peptide::getVarModsStr() then correspond to the modification numbers supplied to this function.

If a fixed modification and a variable modification are applied to the same residue or terminus, then the fixed modification is substituted with the variable modification.

Parameters:
fixedModVector | A valid pointer to a vector of fixed modifications
varModVector | A valid pointer to a vector of variable modifications
See also:
getFixedMods(), getVarMods()
Examples:
tools_aahelper.cpp.
void setMasses ( const ms_masses * masses )

Copies all residue and chemical element masses from the masses file instance.

An ms_umod_configfile object can also be used as a source of masses. In that case call the corresponding method ms_masses::copyFrom() and supply an ms_umod_configfile instance as a parameter.

Parameters:
masses A valid pointer to an ms_masses object
Examples:
tools_aahelper.cpp.
void startIteratePeptides | ( | const char * | sequenceProtein,
 |  | const int | sizeProtein,
 |  | const int | pfa
 | ) |  |

Initialises internal members in preparation for generating peptides.

The first peptide ends are not available after calling this method. You have to call getNextPeptide() and check its returned value before calling getPepStart(), getPepEnd(), getMissed().

Parameters:
sequenceProtein | protein sequence string (not null-terminated)
sizeProtein | length of the protein string
pfa | maximal number of missed cleavages
Examples:
tools_aahelper.cpp.
void stopIteratePeptides ( )

Stop iterating.

Call this method after you have finished retrieving peptides. All calls to getPepStart(), getPepEnd() will return -1 as invalid peptide ends, and getNextPeptide() will return only FALSE until the iteration mechanism is re-initiated with startIteratePeptides().

The documentation for this class was generated from the following files:
  • ms_aahelper.hpp
  • ms_aahelper.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_fragment
Public Types | Public Member Functions

ms_fragment Class Reference
[Classes for calculating masses of peptides and fragments.]

Class representing a single peptide fragment. More...

#include <ms_fragment.hpp>

List of all members.

Public Types

enum LABEL_FORMAT {
LABEL_FORMAT_TRADITIONAL = 0,
LABEL_FORMAT_PEPTIDE_VIEW = 1
}

Format of fragment labels returned by getLabel().

More...

Public Member Functions

ms_fragment ()
Default constructor (don't use it).
ms_fragment (const ms_fragment &src)
Copying constructor.
ms_fragment (const ms_peptide::PSM psmComponent, const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions of a crosslinked peptide.
ms_fragment (const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for internal series ions only.
ms_fragment (const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions.
ms_fragment (const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for internal series ions of a crosslinked peptide.
ms_fragment (const char residueName, const double massValue, const double nlValue, const int col=-1, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for immonium ion.
ms_fragment (const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions of a crosslinked peptide.
ms_fragment (const ms_peptide::PSM psmComponent, const char residueName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for immonium ion of a crosslinked peptide.
ms_fragment (const double massValue, const double nlValue, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for precursor neutral loss peak.
ms_fragment (const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0)
A constructor for regular series ions.
void | clearMatchedIon ()
Sets the fragment to be 'unmatched'.
void | copyFrom (const ms_fragment *src)
Copies the whole content of another instance.
int | getAllMatchedIons (std::vector< double > &masses, std::vector< double > &intensities) const
Returns the list of all experimental data that matched the calculated fragment mass.
int | getCharge () const
Returns the charge state (1, 2, 3 etc.) for the ion.
int | getColumn () const
Returns the 1-based position index in case of a regular series.
int | getEnd () const
Returns the 1-based last position in case of an internal fragment.
std::string | getLabel (const LABEL_FORMAT fmt=LABEL_FORMAT_TRADITIONAL) const
Returns a symbolic label like "a*(6)++".
double | getMass () const
Returns the ion mass (m/z) value.
double | getMatchedIonIntensity () const
Returns the intensity of an experimental peak that matched the calculated mass value.
double | getMatchedIonMass () const
Returns the m/z value of an experimental peak that matched the calculated mass value.
double | getNeutralLoss () const
Returns the neutral loss (m/z) values applied to the fragment.
std::string | getPeptideSubstring () const
Returns the peptide substring for internal fragments, residue name for immonium.
std::string | getSeriesName () const
Returns the ion series name.
int | getStart () const
Returns the 1-based start position within the peptide sequence.
bool | isCTerminal () const
Returns TRUE for y, v, w, x, z series, and FALSE for other series, internal ions and immonium ions.
bool | isFromAlpha () const
Returns TRUE if this fragment comes from the alpha peptide of a crosslinked match.
bool | isFromBeta () const
Returns TRUE if this fragment comes from the beta peptide of a crosslinked match.
bool | isImmonium () const
Returns TRUE for immonium ions.
bool | isInternal () const
Returns TRUE for internal fragments ya and yb.
bool | isNTerminal () const
Returns TRUE for a, b, c, d series, and FALSE for other series, internal ions and immonium ions.
bool | isPrecursorNL () const
Returns TRUE for precursor neutral loss peaks.
bool | isRegular () const
Returns TRUE for a, b, c, d, y, v, w, x, z series and their derivatives.
ms_fragment & | operator= (const ms_fragment &right)
Assignment operator for C++ programs.
void | setMatchedIon (const double mass, const double intensity)

Detailed Description

Class representing a single peptide fragment.

Examples:

tools_aahelper.cpp.

Member Enumeration Documentation

enum LABEL_FORMAT

Format of fragment labels returned by getLabel().

The traditional label format was introduced in Parser 2.2. It has three parts, in this order: fragment ID, charge state and neutral loss. NL is separated from charge state by a space. If NL is zero, there is no space. Fragment ID depends on the series:

  • Regular ion series: series name followed by column in parentheses, e.g. "a(1)" or "y(15)"
  • Immoniums: amino acid residue, e.g. "R" or "K"
  • Internal series: peptide substring, e.g. "LVIK" or "LV"
  • Precursor NL peaks: "M"

Examples of labels in traditional format: "b(3)++ -64", "LVIK -16", "a(1)++", "y(15)"

The Peptide View label format was introduced in Mascot 2.1. The format contains the same three parts as the traditional format, but the order is different: fragment ID, neutral loss, charge state. There is no space between the elements. Peptide View format supports negative doubly charged ions.

Examples of labels in Peptide View format: "b(3)-64++", "LVIK-16", "a(1)++", "y(15)", "b(3)-64--"

Enumerator:
LABEL_FORMAT_TRADITIONAL

Format introduced in Parser 2.2.

LABEL_FORMAT_PEPTIDE_VIEW

Format used by Peptide View since Mascot 2.1.

Constructor & Destructor Documentation

ms_fragment ( )

Default constructor (don't use it).

Initialises all values to defaults.

ms_fragment ( const ms_fragment & src )

Copying constructor.

Note:
This constructor can only be used from C++. Use copyFrom() from other programming languages.
Parameters:
src is the original fragment to base the new one on.
ms_fragment | ( | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions.

Parameters:
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions of a crosslinked peptide.

Parameters:
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const int, const double, const double, const int, const int, const double, const double).
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const char * | seriesName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions.

Parameters:
seriesName | ion series name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const char * | seriesName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for regular series ions of a crosslinked peptide.

Parameters:
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const char*, const double, const double, const int, const int, const double, const double).
seriesName | ion series name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const char * | peptideStr,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for internal series ions only.

Parameters:
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
peptideStr | peptide sequence string.
startPos | first position of the fragment.
endPos | last position of the fragment.
chargeState | for the internals ions series -- should be 1 or 2.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const int | seriesID,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const char * | peptideStr,
 |  | const int | startPos,
 |  | const int | endPos,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for internal series ions of a crosslinked peptide.

Parameters:
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const int, const double, const double, const char*, const int, const int, const int, const double, const double).
seriesID | ion series number. It must be one of the values in matrix_science::ms_fragmentationrules::FRAG_SERIES_TYPE.
massValue | ion mass value.
nlValue | neutral loss value.
peptideStr | peptide sequence string.
startPos | first position of the fragment.
endPos | last position of the fragment.
chargeState | for the internals ions series -- should be 1 or 2.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const char | residueName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col = -1,
 |  | const int | chargeState = 1,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for immonium ion.

This constructor is only used for immonium ions.

Parameters:
residueName | amino-acid name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const ms_peptide::PSM | psmComponent,
 |  | const char | residueName,
 |  | const double | massValue,
 |  | const double | nlValue,
 |  | const int | col,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for immonium ion of a crosslinked peptide.

This constructor is only used for immonium ions.

Parameters:
psmComponent | One of the values for ms_peptide::PSM. If ms_peptide::PSM_COMPLETE, the object is the same as if it had been constructed with ms_fragment(const char, const double, const double, const int, const int, const double, const double).
residueName | amino-acid name.
massValue | ion mass value.
nlValue | neutral loss value.
col | position index for the ion.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.
ms_fragment | ( | const double | massValue,
 |  | const double | nlValue,
 |  | const int | chargeState,
 |  | const double | matchedExptMass = 0,
 |  | const double | matchedExptIntensity = 0
 | ) |  |

A constructor for precursor neutral loss peak.

This constructor is only used for precursor neutral loss peaks. Normally massValue = (mrCalc - nlValue + protonMass * chargeState) / chargeState, where mrCalc is the relative precursor mass.

Parameters:
massValue | ion mass value.
nlValue | neutral loss value.
chargeState | charge state (1, 2, 3 etc.) of the ion.
matchedExptMass | is the m/z value of an experimental peak that matches this calculated fragment ion.
matchedExptIntensity | is the intensity of an experimental peak that matches this calculated fragment ion.

Member Function Documentation

void copyFrom ( const ms_fragment * src )

Copies the whole content of another instance.

Copy everything from src onto this fragment object.

Parameters:
src valid pointer to a ms_fragment object
int getAllMatchedIons | ( | std::vector< double > & | masses,
 |  | std::vector< double > & | intensities
 | ) |  | const

Returns the list of all experimental data that matched the calculated fragment mass.

See ms_fragmentvector::addExperimentalData().

Parameters:
masses | is used to return a vector of mass values. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
intensities | is used to return a corresponding vector of intensity values. Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
the number of mass/intensity values returned.
int getEnd ( ) const

Returns the 1-based last position in case of an internal fragment.

This will be -1 for a 'regular' series, immonium ions and precursor NL ions.

Returns:
end of the series
Examples:
tools_aahelper.cpp.
std::string getLabel ( const LABEL_FORMAT fmt = LABEL_FORMAT_TRADITIONAL ) const

Returns a symbolic label like "a*(6)++".

Parameters:
fmt Output format of the label. Default is ms_fragment::LABEL_FORMAT_TRADITIONAL.
Returns:
Formatted label; see ms_fragment::LABEL_FORMAT for examples.
Examples:
tools_aahelper.cpp.
double getMatchedIonIntensity ( ) const

Returns the intensity of an experimental peak that matched the calculated mass value.

See ms_fragmentvector::addExperimentalData().

Returns:
the intensity of the most intense experimental m/z value that matched the peak. This value will be zero if no peak matched.
double getMatchedIonMass ( ) const

Returns the m/z value of an experimental peak that matched the calculated mass value.

See ms_fragmentvector::addExperimentalData().

Returns:
the mass of the most intense experimental m/z value that matched the peak. This value will be zero if no peak matched.
std::string getSeriesName ( ) const

Returns the ion series name.

The ions series name will be one of:

  • a
  • a*
  • a0
  • b
  • b*
  • b0
  • c
  • x
  • y
  • y*
  • y0
  • z
  • z+1
  • d
  • v
  • w
  • z+2
  • ya
  • yb
  • immonium
  • precursor
Returns:
name of the series
Examples:
tools_aahelper.cpp.
int getStart ( ) const

Returns the 1-based start position within the peptide sequence.

Returns:
1-based position in case of an internal fragment, which will also be valid for a 'regular' series. Returns 0 if this is a precursor NL peak.
Examples:
tools_aahelper.cpp.
bool isFromAlpha ( ) const

Returns TRUE if this fragment comes from the alpha peptide of a crosslinked match.

Returns:
False if the fragment is from the beta peptide or from a linear (non-crosslinked) peptide. True otherwise.
bool isFromBeta ( ) const

Returns TRUE if this fragment comes from the beta peptide of a crosslinked match.

Returns:
False if the fragment is from the alpha peptide or from a linear (non-crosslinked) peptide. True otherwise.
ms_fragment & operator= ( const ms_fragment & right )

Assignment operator for C++ programs.

Parameters:
right is the original fragment to copy to the new one.
Returns:
reference to the current object
void setMatchedIon | ( | const double | mass,
 |  | const double | intensity
 | ) |  |

Sets the mass and intensity of experimental data that matched the calculated mass value.

See ms_fragmentvector::addExperimentalData().

These values will be zero if no peak matched.

Parameters:
mass | is the experimental m/z value that matched the peak.
intensity | is the experimental intensity value that matched the peak.
The documentation for this class was generated from the following files:
  • ms_fragment.hpp
  • ms_fragment.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_fragmentvector
Public Types | Public Member Functions | Static Public Member Functions

ms_fragmentvector Class Reference
[Classes for calculating masses of peptides and fragments.]

Class for holding a list of ms_fragment objects. More...

#include <ms_fragmentvector.hpp>

List of all members.

Public Types

enum MATCH_PEAKS {
MATCH_MOST_INTENSE_PEAK = 0x0000,
MATCH_CLOSEST_PEAK = 0x0001
}

Flags for matching experimental peaks to calculated peaks.

More...

Public Member Functions

ms_fragmentvector ()
Default constructor.
ms_fragmentvector (const ms_fragmentvector &src)
Copying constructor.
virtual | ~ms_fragmentvector ()
Destructor.
bool | addExperimentalData (const ms_mascotresfile *resfile, const int query, const int flags=MATCH_MOST_INTENSE_PEAK, const int peaksUsedFromIons1=-1, const int peaksUsedFromIons2=-1, const int peaksUsedFromIons3=-1)
Find matches to peaks lists from a Mascot results file.
bool | addExperimentalData (const std::string &peakList, const int numPeaks, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true)
Find matches to peak list.
bool | addExperimentalData (const peaklist_t &peakList, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true)
Find matches to peak list.
void | appendFragment (const ms_fragment *item)
Adds a new fragment to the end of the vector.
void | clearFragments ()
Deletes all fragments from the vector.
void | copyFrom (const ms_fragmentvector *right)
Copies all content from another instance.
const ms_fragment * | getFragmentByNumber (const unsigned int numFrag) const
Return a fragment object by its number.
int | getNumberOfFragments () const
Returns a number of fragments currently held in the vector.
const frag_vector * | getVector () const
Return a const pointer to the STL vector of ms_fragment objects.
frag_vector * | getVector ()
Return a pointer to the STL vector of ms_fragment objects.
ms_fragmentvector & | operator= (const ms_fragmentvector &right)
C++ style assignment operator.

Static Public Member Functions

static void | getMassesWithinTolerance (const double &fragmentMass, const double &fragmentToleranceValue, const TOLERANCE_UNIT &fragmentToleranceUnit, double &minMass, double &maxMass)

Detailed Description

Class for holding a list of ms_fragment objects.

This class is necessary when using Mascot Parser from programming language other than C++. It is used when calling ms_aahelper::calcFragments().

C++ users will generally just want to use a std::vector<ms_fragment> as it is easier.

Examples:

tools_aahelper.cpp.

Member Enumeration Documentation

enum MATCH_PEAKS

Flags for matching experimental peaks to calculated peaks.

Used as flags for addExperimentalData() when passing a ms_mascotresfile object.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
MATCH_MOST_INTENSE_PEAK

Match the most intense peak in the region.

MATCH_CLOSEST_PEAK

Match the peak with the closest m/z value (not currently supported).

Constructor & Destructor Documentation

ms_fragmentvector ( )

Default constructor.

Create a default empty list of fragments.

ms_fragmentvector ( const ms_fragmentvector & src )

Copying constructor.

Note:
This constructor can only be used from C++. Use copyFrom() from other programming languages.
Parameters:
src is the original list to base the new list on.
~ms_fragmentvector ( ) [virtual]

Destructor.

No need to call this directly. Frees the list of fragments.

Member Function Documentation

bool addExperimentalData | ( | const std::string & | peakList,
 |  | const int | numPeaks,
 |  | const double | tolerance,
 |  | const std::string & | toleranceUnits,
 |  | const bool | updateMatchList = true
 | ) |  |

Find matches to peak list.

This function matches the peakList to the calculated fragment matches. To find which peaks are matched, use ms_fragment::getMatchedIonMass() and ms_fragment::getMatchedIonIntensity().

Parameters:
peakList | will be of the form 136.070000:42.95,175.110000:133.1, 299.060000:710.1,415.030000:144.6 . and may be retrieved using ms_inputquery::getStringIons1().
numPeaks | is the number of peaks to be used from the list. If this is -1, then all peaks are used. To only match peaks used for matching by the search engine, pass ms_peptide::getPeaksUsedFromIons1().
tolerance | is the tolerance to be used for matching the ions. This can be found from ms_searchparams::getITOL().
toleranceUnits | must be "Da", "mmu" or "ppm". This can be found from ms_searchparams::getITOLU().
updateMatchList | should be set to true if you want to recalculate the list of matches. If this function is to be called multiple times, then set it to false except for the last call.
Returns:
indicates if the function was successful. It will only fail if toleranceUnits are invalid.
bool addExperimentalData | ( | const ms_mascotresfile * | resfile,
 |  | const int | query,
 |  | const int | flags = MATCH_MOST_INTENSE_PEAK,
 |  | const int | peaksUsedFromIons1 = -1,
 |  | const int | peaksUsedFromIons2 = -1,
 |  | const int | peaksUsedFromIons3 = -1
 | ) |  |

Find matches to peaks lists from a Mascot results file.

This function matches experimental data to the calculated fragment matches. To find which peaks are matched, use ms_fragment::getMatchedIonMass() and ms_fragment::getMatchedIonIntensity(). The peak list is extracted from the results file using the query number specified.

Parameters:
resfile | is the Mascot results file from which the fragments were initially calculated. The results file is used to find the peak list and the tolerances to be used for matching.
query | is the query number in the range 1..ms_mascotresfile::getNumQueries().
flags | is a MATCH_PEAKS value. Currently only MATCH_MOST_INTENSE_PEAK is supported.
peaksUsedFromIons1 | is the number of peaks from the peak list in the passed the results file to be used for matching. Use -1 to indicate all peaks. See also ms_peptide::getPeaksUsedFromIons1() and ms_inputquery::getStringIons1().
peaksUsedFromIons2 | is the number of peaks from the peak list in the passed the results file to be used for matching. Use -1 to indicate all peaks. See also ms_peptide::getPeaksUsedFromIons2() and ms_inputquery::getStringIons2().
peaksUsedFromIons3 | is the number of peaks from the peak list in the passed the results file to be used for matching. Use -1 to indicate all peaks. See also ms_peptide::getPeaksUsedFromIons3() and ms_inputquery::getStringIons3().
Returns:
indicates if the function was successful. It will only fail if the results file is invalid or if the query number is invalid.
void appendFragment ( const ms_fragment * item )

Adds a new fragment to the end of the vector.

A copy of the ms_fragment is made and added to the list, so there is no requirement to keep the original in memory.

Parameters:
item is a new item to add to the list.
Examples:
tools_aahelper.cpp.
void clearFragments ( )

Deletes all fragments from the vector.

After calling this, getNumberOfFragments() will return 0.

void copyFrom ( const ms_fragmentvector * right )

Copies all content from another instance.

Copy everything from right onto this fragment object.

Parameters:
right const pointer to a valid ms_fragmentvector object
Examples:
tools_aahelper.cpp.
const ms_fragment * getFragmentByNumber ( const unsigned int numFrag ) const

Return a fragment object by its number.

Parameters:
numFrag is the fragment to return. This must be in the range 0 to getNumberOfFragments() -1.
Returns:
A pointer to the ms_fragment object. See Maintaining object references: two rules of thumb.
Examples:
tools_aahelper.cpp.
void getMassesWithinTolerance | ( | const double & | fragmentMass,
 |  | const double & | fragmentToleranceValue,
 |  | const TOLERANCE_UNIT & | fragmentToleranceUnit,
 |  | double & | minMass,
 |  | double & | maxMass
 | ) |  | [static]
Parameters:
[in] | fragmentMass | is the mass of the fragment
[in] | fragmentToleranceValue | the tolerance in the units specified by fragmentToleranceUnit
[in] | fragmentToleranceUnit | any of the four ms_fragmentvector::TOLERANCE_UNIT values
[out] | minMass | Used to return the minimum mass in the range
[out] | maxMass | Used to return the maximum mass in the range
int getNumberOfFragments ( ) const

Returns a number of fragments currently held in the vector.

See also:
getFragmentByNumber().
Returns:
number of fragments
Examples:
tools_aahelper.cpp.
const ms_fragmentvector::frag_vector * getVector ( ) const

Return a const pointer to the STL vector of ms_fragment objects.

See also:
getVector()
Returns:
A pointer to the STL vector.
ms_fragmentvector::frag_vector * getVector ( )

Return a pointer to the STL vector of ms_fragment objects.

Note:
This function would only ever be of use in C++.

This class is just a wrapper for std::vector<ms_fragment> so it possible to get a pointer to the STL vector if required.

Returns:
A pointer to the STL vector.
ms_fragmentvector & operator= ( const ms_fragmentvector & right )

C++ style assignment operator.

Parameters:
right is the original list to copy to the new list.
Returns:
reference to the current object
The documentation for this class was generated from the following files:
  • ms_fragmentvector.hpp
  • ms_fragmentvector.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


Accessing a Mascot Server using HTTP

Classes

class | ms_connection_settings
Settings required to make an HTTP connection to a Mascot server. More...
class | ms_http_client
This class enables access to a Mascot server using HTTP. More...
class | ms_http_client_mime
The class eases the building of a MIME section. More...
class | ms_http_client_search
Used for submitting searches to a Mascot server and retrieving search results using HTTP. More...
class | ms_http_client_session
This gives access to a Mascot session so searches may be submitted. More...
class | ms_http_helper
The class provides HTTP, FTP and FILE protocol access to a server. More...
class | ms_http_helper_handles
The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request. More...
class | ms_http_helper_progress
This holds information on the progress of a running HTTP transfer. More...
class | ms_http_helper_return
Indicates any problem that may have occurred during a request to an ms_http_helper object. More...

Modules

HTTP Communication to a Mascot Server
Examples for the Mascot http client module
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


HTTP Communication to a Mascot Server
[Accessing a Mascot Server using HTTP]

HTTP Communication Overview

It is highly advisable to use HTTP for all communication with a Mascot server. One reason is that the HTTP API is uniform across different platforms (Windows, Linux). A second reason is that even if you are prepared to write platform-dependent code, direct access to the server by users may not be permitted by the IT department.

The HTTP Client classes provided a high level interface to allow access to the Mascot server.

There are three main levels at which to access the Mascot server:

HTTP Client
Remote access to the server is made available by ms_http_client. This holds the base URL to the server (e.g. "http://myserver/mascot/cgi/") that is the root address for all the server applications, typically ending in "/cgi/". Queries allow you to find out such things as the server version and operating system. This is also where you login to get a session.
HTTP Client Session
ms_http_client_session gives access to a single Mascot session. The client session is created by logging into the HTTP Client. You must login to create the session, even if security is not enabled on the server. The username and password can be left blank if security is disabled or the guest account is to be used. It holds the Mascot session ID and allows access to functions that require you to be logged into the server, such as submitting new searches or accessing old searches.
HTTP CLient Search
ms_http_client_search gives access to a single search on the Mascot server. With this new searches can be submitted, their progress monitored and results downloaded. The new search is created by submitting a search with the Client Session. An old search is accessed by creating a new ms_http_client_search using the Client Session and the search task id (the one used when the search was originally run).

Lower level access is available using ms_http_helper and its associated classes (ms_http_helper_handles, ms_http_helper_progress, ms_http_helper_response and ms_http_helper_return). The higher level HTTP client classes are implemented using these low level classes. On Windows, these low level classes are implemented using the WinHTTP 5.1 API and as such requires at least Windows 2000, Service Pack 3 or later.

Obtaining Parameter Lists

Some of the search parameters are chosen from controlled lists of terms that are server specific. For example, the name of the sequence database to be searched. Mascot is very configurable, and you should not make any assumptions about what choices will be available. It is possible for people to define their own databases, instrument types, modifications, and enzymes.

The most flexible way to obtain these lists is using Mascot Parser. The URL of the Mascot server is passed to the relevant constructor. See the example code in the Mascot Parser documentation for config_enzymes, config_fragrules, config_mascotdat, config_masses, config_config_modfile and config_taxonomy.

Creating Searches

The MIME format is described in Chapter 8 of the Mascot Installation and Setup manual and RFC's 2045 - 2049. A file of the required format is created automatically, when the search form is submitted. You can capture this output by setting the option SaveLastQueryAsc in mascot.dat to 1. See Chapter 6 of the manual for further information.

The data passed to the server is a concentenation of the prologue, the file and the epilogue. It is often more convenient to save just the peak list in a file. The prologue and epilogue can then be created for the search and sent directly to the server without having to save them to a file.

If the peak list is relatively small, then it can be stored in memory and passed in one parameter (e.g. as the prologue) along with all the other informaion. The other parameters (e.g. the file and epilogue) can be left blank.

When creating MIME format information (e.g. the prologue), a ms_http_client_mime provides a simple mechanism for formatting the data correctly.

Connect to a Server

Create a new ms_http_client, passing the base URL and suitable settings.

matrix_science::ms_connection_settings settings;
settings.setUserAgent("your_application_name");
matrix_science::ms_http_client server("http://your_mascot_server/mascot/cgi/", settings);

Get a Session

Login, passing a username and password if required, to obtain a new ms_http_client_session (not to be confused with ms_session, which is used locally on the server only and does not communicate via HTTP). If security has not been enabled, then the username and password can be blank.

matrix_science::ms_http_client_session session;
matrix_science::ms_http_client::LoginResultCode loginResult = server.userLogin("your_username", "your_password", session);
// ... check success

Create a Search

Get a new ms_http_client_search from the session.

std::string httpHeader = "Content-Type: multipart/mixed; boundary=---MascotDistillerMascotSearch";
matrix_science::ms_http_client_search search;
matrix_science::ms_http_helper_progress progress;
bool isOk = session->submitSearch(search, httpHeader, "", "your_source_mime_filename", "", progress);
// ... check success

Follow its Progress

Follow the progress of the search on the server until is is complete.

matrix_science::ms_http_client_search::SearchStatusCode code;
int progressPercent;
do {
    bool isOk = search.getStatus(code, progressPercent);
    // ... check success
    // ... waiting for search to complete
    double x = progressPercent;
} while (code == matrix_science::ms_http_client_search_status::TS_RUNNING);

Download the Results
Download the results.
bool isOk = search.downloadResultsFile("your_target_download_filename");
// ... check success

Previous Search Results

To retrieve the results from a previously run search you will need to know its search task identifier.

Connect to a Server

Create a new ms_http_client.

matrix_science::ms_connection_settings settings;
settings.setUserAgent("your_application_name");
matrix_science::ms_http_client server("http://your_mascot_server/mascot/cgi/", settings);

Get a Session

Login, passing a username and password if required, to obtain a new ms_http_client_session.

matrix_science::ms_http_client_session session;
matrix_science::ms_http_client::LoginResultCode loginResult = server.userLogin("your_username", "your_password", session);
// ... check success

Attach to the Search

Get a new ms_http_client_search using the ms_http_client_session and the task identifier.

matrix_science::ms_http_client_search search(session, "search_task_identifier");

Download the Results
Download the results.
bool isOk = search.downloadResultsFile("your_target_download_filename");
// ... check success

Sequence Retrieval using getseq.pl

To retrieve the sequence for a particular accession:

Connect to a Server

Create a server object, passing the base URL and suitable settings.

matrix_science::ms_connection_settings settings;
settings.setUserAgent("your_application_name");
matrix_science::ms_http_client server("http://your_mascot_server/mascot/cgi/", settings);

Get a Session

Login, passing a username and password if required, to obtain a session.

matrix_science::ms_http_client_session session;
matrix_science::ms_http_client::LoginResultCode loginResult = server.userLogin("your_username", "your_password", session);
// ... check success

Get sequence
Query the sequence data for an accession number (e.g. "041R_FRG3G") from the database (e.g. "SwissProt").
const std::vector<std::string> & accessionNames;
accessionNames.push_back("041R_FRG3G");
const std::vector<int> accessionFrames; // not using NA frames so leave empty
bool isOk = session.getSequenceFile("SwissProt", accessionNames, accessionFrames, "target_file_name");
// ... check success

Error handling and logging

All the classes inherit from ms_errors. A logging level and logging file can be set on the initial ms_http_client object, for example:

my $objHttpClient = new msparser::ms_http_client($url, $objSettings);
if ($objHttpClient->isValid) {
  $objHttpClient->getErrorHandler->setLoggingFile("log.txt", $msparser::ms_errs::sev_debug3);
}

When ms_http_client::userLogin is called, the logging values are copied to the ms_http_client_session object passed to the function.

When ms_http_client_session::submitSearch is called, the logging values are copied to the ms_http_client_search object passed to the function.

to HTTPS websites

It is possible to connect to websites using https on Linux or Windows systems. To do so, the target website must have a valid certificate. The certificate may be refused by Parser for three main reasons.

  • The certificate is valid and signed by a recognised authority, but Parser uses an outdated certificate bundle.
  • The certificate is self-signed, the root certificate of the target server must be added to Parser.
  • The certificate is missing or invalid, a valid connection cannot be established over https.

To update the list of certificates or to add a self-signed certificate on Linux, two methods are possible.

Note that on Linux, all certificates to be added must be in a valid PEM format. Namely, the certificates must be between -----BEGIN CERTIFICATE----- and -----END CERTIFICATE----- in the file. There are some tools to convert from other formats to the PEM format, for example on this website : https://www.sslshopper.com/ssl-converter.html, Linux packages also contain similar tools.

Add a root certificate to a Linux system

This method is preferred when it is required to update the system's bundle of certificates. For example, if it not possible to connect to https://www.google.com/, it may be due to the system's bundle. It is however not recommanded to use this method for a self-signed certificate, unless you want to grant access to this website for all other programs on your system.

An up-to-date list of certificates can be downloaded from any of the following links, either over http or https.

  • http://curl.haxx.se/ca/cacert.pem
  • https://raw.githubusercontent.com/bagder/ca-bundle/master/ca-bundle.crt

Debian and Ubuntu systems To add a root certificate to a Debian-based Linux system, type the following commands.

sudo cp newCertificate.crt /usr/local/share/ca-certificates/
sudo update-ca-certificates

Fedora, RedHat and CentOS systems To add a root certificate to a Fedora-based Linux system, type the following commands as root.

yum install ca-certificates
update-ca-trust force-enable
cp newCertificate.crt /etc/pki/ca-trust/source/anchors/
update-ca-trust extract

Add a certificate to Parser on Linux

This method is preferred for a self-signed certificate. To download the root certificate of a website, you can do so from your browser or ask its administrator, and convert it to PEM format as mentioned above. The extension of root certificates are usually .crt, although it does not matter for this method to work.

Once the certificate has been downloaded on your system, type the following commands, the access rights depend on your installation.

mkdir -p /usr/local/mascot/cert
chmod 755 /usr/local/mascot/cert
cp selfSignedCertificate.crt /usr/local/mascot/cert/
chmod 644 /usr/local/mascot/cert/selfSignedCertificate.crt

It is also possible to add a self-signed certificate on Windows. Note that, on Windows, the certificate must be in one of the following formats : .PFX, .P12, .P7B, .SST .

Add a certificate to a Windows system

To download the root certificate of a website, you can do so from your browser or ask its administrator, and make sure it is in a correct format as mentioned above.

Once the certificate has been downloaded on your system, do the following

Click Start, click the text box Search Program and files
Type mmc and type Enter
Click File -> Add/Remove Snap-in...
Click Certificates, click Add >, select Computer account, click Next, click Finish, click OK
On the left panel, Navigate to Console Root/Certificates (Local Computer)/Personal/Third-Party Root Certification Authorities, Certificates
Right click on Certificates, click on All tasks -> Import...
Click Next, click Browse..., change the file filter to match your file type, click your file, click Open, click Next, click Next, click Finish, click OK, close the Console.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Examples for the Mascot http client module
[Accessing a Mascot Server using HTTP]

The source code for these examples are in the 'examples' directory. For details on how to compile and run these examples see:

  • C++ toolkit installation
  • Perl toolkit installation
  • Java toolkit installation
  • Python toolkit installation
  • C# toolkit installation
Description | Perl | C++ | Java | Python | C#
Accessing a Mascot Server using http | http_client.pl |  |  | http_client.py | http_client.cs
Accessing any server using http(s) | http_helper_getstring.pl | http_helper_getstring.cpp |  | http_helper_getstring.py |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_connection_settings
Public Types | Public Member Functions | Static Public Member Functions

ms_connection_settings Class Reference
[Accessing a Mascot Server using HTTP]

Settings required to make an HTTP connection to a Mascot server. More...

#include <ms_connection_settings.hpp>

List of all members.

Public Types

enum HTTP_PROTOCOL {
HTTP_1_0 = 0x0000,
HTTP_1_1 = 0x0001,
HTTP_SYSTEM_DEFAULT = 0x0002
}
enum PROXY_TYPE {
PROXY_TYPE_NO_PROXY = 0x0000,
PROXY_TYPE_FROM_REGISTRY = 0x0001,
PROXY_TYPE_SPECIFY = 0x0002,
PROXY_TYPE_WPAD = 0x0003,
PROXY_TYPE_ENVIRONMENT = 0x0004,
PROXY_TYPE_AUTO = 0x0005
}

Definitions for types of setting.

More...
enum REDIRECT_POLICY {
REDIRECT_POLICY_ALWAYS = 0x0000,
REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP = 0x0001,
REDIRECT_POLICY_NEVER = 0x0002
}

Public Member Functions

ms_connection_settings ()
Default constructor used to create an ms_connection_settings object.
ms_connection_settings (const std::string sessionID, const std::string proxyServer, const std::string proxyUserName, const std::string proxyUserPassword)
Constructor to set some parameters.
~ms_connection_settings ()
Destructor.
void | copyFrom (const ms_connection_settings *right)
Call this member to copy all the information from another instance.
void | defaultValues ()
Called by the default constructor and may be called to re-initialise all values.
int | getConnectionTimeout () const
Returns the HTTP connection timeout.
std::string | getHttpPassword () const
Gets the password for an authenticated web server.
ms_connection_settings::HTTP_PROTOCOL | getHttpProtocol () const
Returns the version of HTTP protocol to be used.
std::string | getHttpUsername () const
Gets the username for an authenticated web server.
std::string | getProxyPassword () const
Gets the password for an authenticated proxy server.
std::string | getProxyServer () const
Gets the name of the proxy server.
ms_connection_settings::PROXY_TYPE | getProxyServerType () const
Returns how proxy server information will be obtained.
std::string | getProxyUserAndPassword () const
Get the combined username and password -- if any.
std::string | getProxyUsername () const
Gets the user name for an authenticated proxy server.
ms_connection_settings::REDIRECT_POLICY | getRedirectPolicy () const
Gets the policy for HTTP redirection.
std::string | getSessionID () const
Gets the sessionID to be used for the connection.
std::string | getUserAgent () const
Get the user agent string.
bool | isUseHTTPProxyForFTP () const
Return true if HTTP proxy settings should be used for FTP.
bool | isUseHTTPProxyForHTTPS () const
Return true if HTTP proxy settings should be used for HTTPS.
ms_connection_settings & | operator= (const ms_connection_settings &right)
C++ style assignment operator.
void | setConnectionTimeout (int timeout)
Sets the HTTP connection timeout.
void | setHttpPassword (const std::string httpPassword)
Sets the password for an authenticated web server.
void | setHttpProtocol (ms_connection_settings::HTTP_PROTOCOL httpProtocol)
Sets the version of the HTTP protocol to be used.
void | setHttpUsername (const std::string httpUsername)
Sets the username for an authenticated web server.
void | setProxyPassword (const std::string proxyUserPassword)
Sets the password for an authenticated proxy server.
void | setProxyServer (const std::string proxyServer)
Sets the name of the proxy server.
void | setProxyServerType (ms_connection_settings::PROXY_TYPE proxyType)
Specifies how proxy server information will be obtained.
void | setProxyUsername (const std::string proxyUserName)
Sets the user name for an authenticated proxy server.
void | setRedirectPolicy (ms_connection_settings::REDIRECT_POLICY redirectPolicy)
Sets the policy for HTTP redirection.
void | setSessionID (const std::string sessionID)
Sets the Mascot security sessionID to be used for the connection.
void | setUseHTTPProxyForFTP (bool value)
Enable or disable use of an HTTP proxy server for an FTP request.
void | setUseHTTPProxyForHTTPS (bool value)
Enable or disable use of an HTTP proxy server for an HTTPS request.
void | setUserAgent (const std::string userAgent)
Set the user agent string.

Static Public Member Functions

static int | proxyTypeStringToEnum (std::string str)
Convert proxy type string to PROXY_TYPE.
static std::string | proxyTypeToString (int type)
Convert PROXY_TYPE to canonical string.

Detailed Description

Settings required to make an HTTP connection to a Mascot server.

A sessionID parameter may be required if Mascot security is enabled.

This class holds these settings and is used from:

  • ms_datfile::ms_datfile(const char *filename, const int timeoutSec, const ms_connection_settings *cs)
  • ms_umod_configfile::ms_umod_configfile(const char *filename, const char *schemaFileName, const ms_connection_settings *cs)
  • ms_modfile::ms_modfile(const char *filename, const ms_masses *massFile, const bool fromSubstitutions, const ms_connection_settings *cs)
  • ms_masses::ms_masses(const char* filename, const ms_connection_settings *cs)
  • ms_fragrulesfile::ms_fragrulesfile(const char *filename, const ms_connection_settings *cs)
  • ms_taxonomyfile::ms_taxonomyfile(const char *filename, const ms_connection_settings *cs)
  • ms_enzymefile::ms_enzymefile(const char *filename, const ms_connection_settings *cs)
Examples:

config_enzymes.cpp, config_fragrules.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_quantitation.cpp, config_taxonomy.cpp, and http_helper_getstring.cpp.

Member Enumeration Documentation

enum HTTP_PROTOCOL

Definitions for HTTP protocol to use.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
HTTP_1_0

Use HTTP 1.0.

HTTP_1_1

Use HTTP 1.1.

HTTP_SYSTEM_DEFAULT

Use system default. For Windows, this is set in Internet Explorer or the Control Panel.

enum PROXY_TYPE

Definitions for types of setting.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
PROXY_TYPE_NO_PROXY

No proxy server will be used. For Windows, the INTERNET_OPEN_TYPE_DIRECT flag is specified in the InternetOpen call.

PROXY_TYPE_FROM_REGISTRY

Windows version of Mascot Parser only. The proxy server will be discovered using the WinHttpGetIEProxyConfigForCurrentUser call (the no proxy is used if no proxy is set in Internet Explorer).

PROXY_TYPE_SPECIFY

The proxy server must be specified using setProxyServer(). The INTERNET_OPEN_TYPE_PROXY flag is specified in the InternetOpen call.

PROXY_TYPE_WPAD

Windows version of Mascot Parser only. The proxy server will be discovered using the WinHttpGetProxyForUrl call (the default proxy is used if no proxy can be auto-discovered).

PROXY_TYPE_ENVIRONMENT

Proxy settings will be loaded from the system environment variables http_proxy and https_proxy, depending on protocol.

PROXY_TYPE_AUTO

The proxy server will be discovered automatically. This is the default. On Windows the order is PROXY_TYPE_FROM_REGISTRY, then PROXY_TYPE_WPAD and finally the system default proxy. On Linux, the order is PROXY_TYPE_ENVIRONMENT, PROXY_TYPE_SPECIFY and PROXY_TYPE_NONE.

enum REDIRECT_POLICY

Definitions for HTTP redirection policy.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
REDIRECT_POLICY_ALWAYS

All redirects are followed automatically.

REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP

All redirects are followed, except those that originate from a secure (https) URL to an unsecure (http) URL. This is the default setting.

REDIRECT_POLICY_NEVER

Redirects are never followed.

Constructor & Destructor Documentation

ms_connection_settings ( )

Default constructor used to create an ms_connection_settings object.

The values are all set to the defaults as detailed in defaultValues().

To set up the object correctly, it may be necessary to call one or more of the following functions, depending on the network environment.

  • setSessionID()
  • setProxyServerType()
  • setProxyServer()
  • setProxyUsername()
  • setProxyPassword()
  • setConnectionTimeout()
  • setHttpProtocol()
  • setHttpUsername()
  • setHttpPassword()
  • setRedirectPolicy()
  • setUseHTTPProxyForFTP()
  • setUseHTTPProxyForHTTPS()
  • setUserAgent()
ms_connection_settings | ( | const std::string | sessionID,
 |  | const std::string | proxyServer,
 |  | const std::string | proxyUserName,
 |  | const std::string | proxyUserPassword
 | ) |  |

Constructor to set some parameters.

It is generally easier and clearer to create an object using the default constructor and then set all of the required values.

For this constructor, values not passed are set by calling defaultValues())

Parameters:
sessionID | is the session ID string retrieved either from login.pl or from ms_session::ms_session().
proxyServer | is the URL of the proxy server, if any.
proxyUserName | is the user name for an authenticated proxy server.
proxyUserPassword | is the password for an authenticated proxy server.
~ms_connection_settings ( )

Destructor.

Called automatically.

Member Function Documentation

void copyFrom ( const ms_connection_settings * right )

Call this member to copy all the information from another instance.

Useful in cases where the language doesn't support copying objects.

Parameters:
right Valid pointer to a ms_connection_settings object
void defaultValues ( )

Called by the default constructor and may be called to re-initialise all values.

Sets all members to their default values:

  • sessionID is cleared.
  • connection timeout is set to 60 seconds.
  • proxy server settings are cleared.
  • proxy server type is set to ms_connection_settings::PROXY_TYPE_AUTO
  • For Windows, the http protocol is set to ms_connection_settings::HTTP_SYSTEM_DEFAULT
  • For Linux, the http protocol is set to ms_connection_settings::HTTP_1_1
  • For Windows, the user agent string is set to "MascotParser/[parser_version] winhttp/5.1".
  • For Linux, the user agent string is set to "MascotParser/[parser_version] curl/[curl version]."
  • The redirect policy is set to ms_connection_settings::REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP
int getConnectionTimeout ( ) const

Returns the HTTP connection timeout.

The default value is 60 seconds.

Returns:
The timeout in seconds before a connection will fail.
std::string getHttpPassword ( ) const

Gets the password for an authenticated web server.

Returns:
The HTTP password.
ms_connection_settings::HTTP_PROTOCOL getHttpProtocol ( ) const

Returns the version of HTTP protocol to be used.

The default value for Windows is HTTP_SYSTEM_DEFAULT and the default type for all the Unix platforms is HTTP_1_1.

Returns:
An enumerated value which specifies whether HTTP 1.0, 1.1 or the system default is used when connecting via HTTP to a Mascot Server.
std::string getHttpUsername ( ) const

Gets the username for an authenticated web server.

Returns:
The HTTP user name.
std::string getProxyPassword ( ) const

Gets the password for an authenticated proxy server.

When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will use the proxy server details when connecting to the Mascot server to retrieve the enzymes definitions.

Returns:
The Proxy server password.
std::string getProxyServer ( ) const

Gets the name of the proxy server.

When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will use the proxy server details when connecting to the Mascot server to retrieve the enzymes definitions.

This is the proxy server name specified to setProxyServer(). This is only valid if the proxy server type is PROXY_TYPE_SPECIFY. If the proxy server type is something other value then getProxyList() should be used.

Returns:
The specified proxy server name.
ms_connection_settings::PROXY_TYPE getProxyServerType ( ) const

Returns how proxy server information will be obtained.

The default value is PROXY_TYPE_AUTO. If setProxyServer() is called with a non zero length string, then this type is automatically set to PROXY_TYPE_SPECIFY.

See also:
setProxyServer()
Returns:
An enumerated value PROXY_TYPE which specifies the way in which information about the proxy server can be obtained.
std::string getProxyUserAndPassword ( ) const

Get the combined username and password -- if any.

Returns:
A string in the format username:password.
std::string getProxyUsername ( ) const

Gets the user name for an authenticated proxy server.

When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will use the proxy server details when connecting to the Mascot server to retrieve the enzymes definitions.

Returns:
The Proxy server user name.
ms_connection_settings::REDIRECT_POLICY getRedirectPolicy ( ) const

Gets the policy for HTTP redirection.

The default value for Windows is REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP.

Returns:
An enumerated value controls what types of redirection request are allowed.
std::string getSessionID ( ) const

Gets the sessionID to be used for the connection.

A session ID is used if Mascot Security is enabled; see Mascot security and authentication module. The sessionID is originally retrieved by the calling application either from login.pl or from ms_session::ms_session(). This is then set using setSessionID(). When, for example ms_enzymefile::ms_enzymefile(const char* filename, const ms_connection_settings * cs) is called, that function will get the sessionID and use it to retrieve the enzymes definitions from the Mascot server.

Returns:
The session ID string that has been set by calling setSessionID().
std::string getUserAgent ( ) const

Get the user agent string.

With HTTP, the identity of a client application is transmitted to the server via the User-Agent request header, as described by RFC 1945. For a browser, this might be:

  "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.6)"

For other applications, the unofficial 'standard' is to use pairs of space separated ApplicationName/version values. The default value for Mascot Parser version 2.3.4 and later is

  • "MascotParser/version wininet/version" for Windows and
  • "MascotParser/version curl/version" for Linux.

The default value for Mascot Parser version 2.3.3 and earlier is

  • "msparser wininet 1.0" for Windows and
  • "ms-parser (curllib) V1.0" for all the Unix platforms.

It is normally more useful to prepend this with the the name and version of the client application. For example, for Mascot Distiller, suitable code might be:

   setUserAgent("Mascot Distiller/2.3.0 " + getUserAgent());
Returns:
the current agent string.
Examples:
http_helper_getstring.cpp.
bool isUseHTTPProxyForFTP ( ) const

Return true if HTTP proxy settings should be used for FTP.

This setting allows making FTP requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Returns:
Enabled (true) or disabled (false).
bool isUseHTTPProxyForHTTPS ( ) const

Return true if HTTP proxy settings should be used for HTTPS.

This setting allows making HTTPS requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Returns:
Enabled (true) or disabled (false).
ms_connection_settings & operator= ( const ms_connection_settings & right )

C++ style assignment operator.

Note:
Only used by C++ programs, and internally.
Parameters:
right An ms_connection_settings object
Returns:
Reference to the ms_connection_settings instance.
int proxyTypeStringToEnum ( std::string str ) [static]

Convert proxy type string to PROXY_TYPE.

Parameters:
str Case-insensitive proxy type, one of "none", "auto", "specify", "registry", "wpad", "environment".
Returns:
The matching value in PROXY_TYPE, or -1 if str matches no known proxy type.
std::string proxyTypeToString ( int type ) [static]

Convert PROXY_TYPE to canonical string.

Parameters:
type One of the PROXY_TYPE values.
Returns:
String representation of the value, one of None, Auto, Registry, Specify, WPAD, Environment. If type does not match any known value, the function returns the empty string.
void setConnectionTimeout ( int timeout )

Sets the HTTP connection timeout.

The default value is 60 seconds.

Parameters:
timeout is the timeout in seconds before a connection will fail.
void setHttpPassword ( const std::string httpPassword )

Sets the password for an authenticated web server.

Parameters:
httpPassword is the password required to access an authenticated web server.
Examples:
http_helper_getstring.cpp.
void setHttpProtocol ( ms_connection_settings::HTTP_PROTOCOL httpProtocol )

Sets the version of the HTTP protocol to be used.

The default value for Windows is HTTP_SYSTEM_DEFAULT and the default type for all the Unix platforms is HTTP_1_1.

Parameters:
httpProtocol Specifies whether HTTP 1.0, 1.1 or the system default is used when connecting via HTTP to a Mascot Server.
void setHttpUsername ( const std::string httpUsername )

Sets the username for an authenticated web server.

Parameters:
httpUsername is the user name required to access an authenticated web server.
Examples:
http_helper_getstring.cpp.
void setProxyPassword ( const std::string proxyUserPassword )

Sets the password for an authenticated proxy server.

Parameters:
proxyUserPassword is the password required to access an authenticated proxy server.
void setProxyServer ( const std::string proxyServer )

Sets the name of the proxy server.

Calling this function with a non-zero length string will also set the proxy type to ms_connection_settings::PROXY_TYPE_SPECIFY.

See also:
setProxyServerType()
Parameters:
proxyServer is the URL of the proxy server.
void setProxyServerType ( ms_connection_settings::PROXY_TYPE proxyType )

Specifies how proxy server information will be obtained.

The default value is PROXY_TYPE_AUTO. If setProxyServer() is called with a non zero length string, then this type is automatically set to PROXY_TYPE_SPECIFY.

See also:
setProxyServer()
Parameters:
proxyType is the way in which information about the proxy server can be obtained.
void setProxyUsername ( const std::string proxyUserName )

Sets the user name for an authenticated proxy server.

Parameters:
proxyUserName is the user name required to access an authenticated proxy server.
void setRedirectPolicy ( ms_connection_settings::REDIRECT_POLICY redirectPolicy )

Sets the policy for HTTP redirection.

The default value for Windows is REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP.

Parameters:
redirectPolicy controls what types of redirection request are allowed.
void setSessionID ( const std::string sessionID )

Sets the Mascot security sessionID to be used for the connection.

A session ID is used if Mascot Security is enabled; see Mascot security and authentication module.

Parameters:
sessionID is the session ID string which can be retrieved using ms_session::ms_session() when running on the Mascot Server or, for an application using http, by calling ms_http_client::userLogin (which in turn calls the login.pl script on the Mascot Server.
Examples:
config_enzymes.cpp, config_fragrules.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_quantitation.cpp, and config_taxonomy.cpp.
void setUseHTTPProxyForFTP ( bool value )

Enable or disable use of an HTTP proxy server for an FTP request.

This setting allows making FTP requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Parameters:
value Enable (true) or disable (false).
void setUseHTTPProxyForHTTPS ( bool value )

Enable or disable use of an HTTP proxy server for an HTTPS request.

This setting allows making HTTPS requests through the HTTP proxy. Note that the HTTP proxy server must explicitly support such "tunneling".

Parameters:
value Enable (true) or disable (false).
void setUserAgent ( const std::string userAgent )

Set the user agent string.

With HTTP, the identity of a client application is transmitted to the server via the User-Agent request header, as described by RFC 1945. For a browser, this might be:

  "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.6)"

For other applications, the unofficial 'standard' is to use pairs of space separated ApplicationName/version values.

The default value for Mascot Parser version 2.5.0 and later is

  • "MascotParser/version winhttp/5.1" for Windows and
  • "MascotParser/version curl/version" for Linux.

The default value for Mascot Parser version 2.3.4 to 2.4.x is

  • "MascotParser/version wininet/version" for Windows and
  • "MascotParser/version curl/version" for Linux.

The default value for Mascot Parser version 2.3.3 and earlier is

  • "msparser wininet 1.0" for Windows and
  • "ms-parser (curllib) V1.0" for all the Unix platforms.

It is normally more useful to prepend this with the the name and version of the client application. For example, for Mascot Distiller, suitable code might be:

   setUserAgent("Mascot Distiller/2.3.0 " + getUserAgent());
Parameters:
userAgent is the new agent string.
Examples:
http_helper_getstring.cpp.
The documentation for this class was generated from the following files:
  • ms_connection_settings.hpp
  • ms_connection_settings.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_http_client
Public Types | Public Member Functions

ms_http_client Class Reference
[Accessing a Mascot Server using HTTP]

This class enables access to a Mascot server using HTTP. More...

#include <ms_http_client.hpp>

Inheritance diagram for ms_http_client:
[legend]
Collaboration diagram for ms_http_client:
[legend]

List of all members.

Public Types

enum ChangePasswordResultCode {
CP_SUCCESS,
CP_UNKNOWNUSER,
CP_INCORRECTPASSWORD,
CP_BADNEWPASSWORD,
CP_UNSPECIFIEDERROR
}

Definitions for the possible responses to an attempt to change a password.

More...
enum LoginResultCode {
L_SUCCESS,
L_SECURITYDISABLED,
L_UNKNOWNUSER,
L_INCORRECTPASSWORD,
L_PASSWORDEXPIRED,
L_WEBAUTHENTICATIONFAILED,
L_GUESTLOGINDISABLED,
L_UNSPECIFIEDERROR
}

Definitions for the types of response from the login program on the Mascot server.

More...

Public Member Functions

ms_http_client (const std::string &baseUrl, ms_connection_settings settings)
Constructor to provide access to the Mascot server.
ms_http_client (const ms_http_client &src)
virtual | ~ms_http_client ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
std::string | baseUrl () const
Returns the base URL for the Mascot server.
ChangePasswordResultCode | changePassword (const std::string &userName, const std::string &oldPassword, const std::string &newPassword)
Change the password for a user. The user's old password must be supplied.
void | clearAllErrors ()
Remove all errors from the current list of errors.
ms_connection_settings | connectionSettings () const
Returns the HTTP connection settings.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_client *right)
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
bool | getIsDatabaseActive (const std::string &databaseName, bool &returnIsActive)
Queries whether the specified database is available for searching. Returns true if successful.
bool | getIsSecurityEnabled (bool &returnIsSecurityEnabled, std::string &returnUnsecuredSessionId)
Determine if Mascot Security is enabled on the Mascot Server.
bool | getIsWebAuthenticationEnabled (bool &returnIsWebAuthenticationEnabled, std::string &returnWebAuthenticatedSessionId)
Determine if Mascot Security is setup to use Web Authentication.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getOsName (std::string &osname)
Queries the operating system running on the server. Returns true if successful.
bool | getVersion (int &major, int &minor, int &part3, int &part4)
Queries the version of Mascot running on the server. Returns true if successful.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_http_client & | operator= (const ms_http_client &right)
void | setBaseUrl (const std::string &baseUrl)
Sets the base URL for the Mascot server.
void | setConnectionSettings (const ms_connection_settings &settings)
Sets the HTTP connection settings.
LoginResultCode | userLogin (const std::string &username, const std::string &password, ms_http_client_session &returnSession)
Attempts to log into the Mascot server using the supplied credentials.

Detailed Description

This class enables access to a Mascot server using HTTP.

Creating an ms_http_client object establishes an HTTP connection to the Mascot Server and provides a number of utility functions:

  • Log in to Mascot Security
  • Determine the version of Mascot running on the server
  • Discover the OS being run on the server
  • Change the password of a Mascot user (if permitted)
  • Determine if a particular database is active

Once the userLogin function has been called, searches can be submitted and results retrieved using ms_http_client_search

Member Enumeration Documentation

enum ChangePasswordResultCode

Definitions for the possible responses to an attempt to change a password.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
CP_SUCCESS

The password was changed successfully.

CP_UNKNOWNUSER

The user ID was not recognised. No password was changed.

CP_INCORRECTPASSWORD

The old password supplied was incorrect. No password was changed.

CP_BADNEWPASSWORD

The new password could not be used (e.g. too short). No password was changed.

CP_UNSPECIFIEDERROR

An error occurred. No further information is available.

enum LoginResultCode

Definitions for the types of response from the login program on the Mascot server.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
L_SUCCESS

The function completed successfully.

L_SECURITYDISABLED

Security is disabled on the Mascot server.

L_UNKNOWNUSER

The user ID supplied was not recognised by the Mascot server.

L_INCORRECTPASSWORD

The password supplied for the specified user was incorrect.

L_PASSWORDEXPIRED

The password supplied for the specified user has expired.

L_WEBAUTHENTICATIONFAILED

Web authentication failed for the currently logged in user.

L_GUESTLOGINDISABLED

The guest login could not be accessed because it is disabled on the server.

L_UNSPECIFIEDERROR

An error occurred. No further information is available.

Constructor & Destructor Documentation

ms_http_client | ( | const std::string & | baseUrl,
 |  | ms_connection_settings | settings
 | ) |  |

Constructor to provide access to the Mascot server.

Make a connection to a Mascot Server using HTTP.

Parameters:
baseUrl | The URL of the Mascot server CGI directory. For example "http://your-server/mascot/cgi/". Must end with the /cgi/
settings | Settings that control the connection to the Mascot server.
~ms_http_client ( ) [virtual]

Destructor.

Called automatically.

ms_http_client ( const ms_http_client & src )
Parameters:
src is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
std::string baseUrl ( ) const

Returns the base URL for the Mascot server.

This typically ends with '/cgi/'.

Returns:
The URL of the Mascot server CGI directory. For example "http://your-server/mascot/cgi/".
ms_http_client::ChangePasswordResultCode changePassword | ( | const std::string & | username,
 |  | const std::string & | oldPassword,
 |  | const std::string & | newPassword
 | ) |  |

Change the password for a user. The user's old password must be supplied.

The function is implemented by calling ms_http_helper::httpGetString with the command:

login.pl?action=newpassword&username=username&password=oldPassword&newpw1=newPassword&newpw2=newPassword

Parameters:
username | The name of the user for whom the password is to be changed.
oldPassword | The current (before the change) password for the user.
newPassword | The new password that is to be set for the user.
Returns:
The final result of the attempt to change the password.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
ms_connection_settings connectionSettings ( ) const

Returns the HTTP connection settings.

Returns:
Settings that control the HTTP connection to the Mascot server.
void copyFrom ( const ms_http_client * right )
Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
bool getIsDatabaseActive | ( | const std::string & | databaseName,
 |  | bool & | returnIsActive
 | ) |  |

Queries whether the specified database is available for searching. Returns true if successful.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?db_active&db_name=databaseName

If the databaseName is not available for searching on the server, the function can still return true, but returnIsActive will be false.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | databaseName | The name of the database to look for on the Mascot server.
[out] | returnIsActive | Returns true if the named database is available on the Mascot server.
Returns:
True if the function completed successfully.
bool getIsSecurityEnabled | ( | bool & | returnIsSecurityEnabled,
 |  | std::string & | returnUnsecuredSessionId
 | ) |  |

Determine if Mascot Security is enabled on the Mascot Server.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

login.pl?action=issecuritydisabled

If security is disabled then the session ID 'all_secdisabledsession ' will be returned in returnUnsecuredSessionId. If security is enabled, then an empty string will be returned, even if the guest account is enabled. See matrix_science::ms_session for further information.

Many client applications will not need to call this function but it is useful for determining if it is necessary to prompt the user for a username and password.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | returnIsSecurityEnabled | Returns true if security is enabled. This is only valid if the function succeeds.
[out] | returnUnsecuredSessionId | Returns a session ID or an empty string. If security is disabled, this will return all_secdisabledsession This value is only valid if the function succeeds.
Returns:
True if the function completed successfully.
bool getIsWebAuthenticationEnabled | ( | bool & | returnIsWebAuthenticationEnabled,
 |  | std::string & | returnWebAuthenticatedSessionId
 | ) |  |

Determine if Mascot Security is setup to use Web Authentication.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

login.pl?action=webauthentication

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | returnIsWebAuthenticationEnabled | Returns true if web authentication is enabled for the user logged into the web server.
[out] | returnWebAuthenticatedSessionId | Returns a session ID that can be used, or blank if web authentication failed or is not enabled for this user. This is only valid if the function succeeds.
Returns:
True if the function completed successfully.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getOsName ( std::string & osname )

Queries the operating system running on the server. Returns true if successful.

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?osname

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] osname Returns name of the Mascot server's operating system; either 'linux' or 'MSWin32'
Returns:
True if the function completed successfully.
bool getVersion | ( | int & | major,
 |  | int & | minor,
 |  | int & | part3,
 |  | int & | part4
 | ) |  |

Queries the version of Mascot running on the server. Returns true if successful.

If the version returned by the Mascot server does not contain all four parts, the remaining parts are set to zero.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?version

If the function fails then the return value is false; error messages may be retrieved from the ms_errors base class.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | major | Returns the major version number. For example, version 2.4.1.24 would return 2.
[out] | minor | Returns the minor version number. For example, version 2.4.1.24 would return 4.
[out] | part3 | Returns part 3 of the version number. For example, version 2.4.1.24 would return 1.
[out] | part4 | Returns part 4 of the version number. For example, version 2.4.1.24 would return 24.
Returns:
True if the function completed successfully.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_http_client & operator= ( const ms_http_client & right )
Parameters:
right is the source to initialise from
Returns:
reference to the current object
void setBaseUrl ( const std::string & baseUrl )

Sets the base URL for the Mascot server.

This typically ends with '/cgi/'. The baseUrl would normally be passed in the constructor.

Parameters:
baseUrl The URL of the Mascot server CGI directory.
void setConnectionSettings ( const ms_connection_settings & settings )

Sets the HTTP connection settings.

The settings control the HTTP connection to the Mascot server.

Parameters:
settings The new settings for the server connection.
ms_http_client::LoginResultCode userLogin | ( | const std::string & | username,
 |  | const std::string & | password,
 |  | ms_http_client_session & | returnSession
 | ) |  |

Attempts to log into the Mascot server using the supplied credentials.

If security is disabled on the Mascot server (or the server version is 2.1 or earlier) then the supplied username and password are ignored and an anonymous session is created.

If a username is supplied then the username and password combination will be authenticated on the Mascot server before a session is created.

If no username is supplied, a session using web authentication will be attempted. This can only succeed if the user name supplied for web server authentication matches a user name configured in Mascot security as a web authenticated user.

If no username is supplied and web authentication fails, a session using the guest account will be attempted (however, the guest account may be disabled, in which case the function will fail).

The logging level and logging file (if any) in the returnSession are set to be the same as in the ms_http_client object. Any existing errors in returnSession are cleared.

The function is implemented by calling ms_http_helper::httpGetString with a number of different commands, for example:

login.pl?action=login&username=username&password=password

Parameters:
[in] | username | The name of the user to login with, or blank for a web authenticated or anonymous session.
[in] | password | The password associated with the user name.
[out] | returnSession | Returns a session if the login was successful. The ms_http_client_session object passed should be created using the default constructor and when calling from Perl, pass the object in the parameter list.
Returns:
The result of the Mascot login attempt.
The documentation for this class was generated from the following files:
  • ms_http_client.hpp
  • ms_http_client.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_client_mime
Public Member Functions | Static Public Member Functions

ms_http_client_mime Class Reference
[Accessing a Mascot Server using HTTP]

The class eases the building of a MIME section. More...

#include <ms_http_client_mime.hpp>

List of all members.

Public Member Functions

virtual | ~ms_http_client_mime ()
Destructor. HTTP Communication to a Mascot Server.
void | append (const std::string &name, const std::string &value)
Adds a name-value pair element to the end of the MIME string.
void | appendFile (const std::string &name, const std::string &filename, const std::string &contentType, const std::string &prefixData="")
Adds a name-value pair element with a filename attribute to the end of the MIME string.
void | erase (int oneBasedIndex)
Remove an element.
std::string | format (const std::string &boundary, matrix_science::ms_http_client_mime::Continuation continuation) const
Gets the complete MIME string.
int | getCount () const
Returns the number of items.
std::string | getFilename (int oneBasedIndex) const
Returns the filename attribute of an item.
std::string | getName (int oneBasedIndex) const
Returns the name of an item.
std::string | getValue (int oneBasedIndex) const
Returns the value of an item.
bool | hasFilename (int oneBasedIndex) const
Returns true if the item has a filename attribute.
void | setValue (int oneBasedIndex, const std::string &value)
Change the value of an element.
void | setValueWithFilename (int oneBasedIndex, const std::string &value, const std::string &filename, const std::string &contentType)
Change the value of an element and set a filename attribute on it.

Static Public Member Functions

static std::string | formatHeader (const std::string &boundary, ContentType contentType)
Gets the MIME header string.

Detailed Description

The class eases the building of a MIME section.

Each element can be added individually as a name-value pair. The MIME content text can then be retrieved.

The text can have a MIME terminator added, as required.

The boundary string can be changed if desired.

Constructor & Destructor Documentation

~ms_http_client_mime ( ) [virtual]

Destructor. HTTP Communication to a Mascot Server.

Called automatically.

Member Function Documentation

void append | ( | const std::string & | name,
 |  | const std::string & | value
 | ) |  |

Adds a name-value pair element to the end of the MIME string.

Parameters:
name | The name of the item.
value | The value of the item.
void appendFile | ( | const std::string & | name,
 |  | const std::string & | filename,
 |  | const std::string & | contentType,
 |  | const std::string & | prefixData = ""
 | ) |  |

Adds a name-value pair element with a filename attribute to the end of the MIME string.

Parameters:
name | The name of the item.
filename | The filename specified for the item.
contentType | The MIME type string for the type of content (e.g. "text/xml").
prefixData | The filename specified for the item. Data added to the start of the file. Optional.
void erase ( int oneBasedIndex )

Remove an element.

Parameters:
oneBasedIndex The index is 1..Count() inclusive (not zero based).
std::string format | ( | const std::string & | boundary,
 |  | matrix_science::ms_http_client_mime::Continuation | continuation
 | ) |  | const

Gets the complete MIME string.

Parameters:
boundary | The string to be used as a separator between MIME sections.
continuation | Indicates whether the MIME content will be continued after this section, or whether the MIME terminates here (and should have a terminator boundary appended).
Returns:
The formatted MIME text.
std::string formatHeader | ( | const std::string & | boundary,
 |  | ContentType | contentType
 | ) |  | [static]

Gets the MIME header string.

The header consists of a content type and a boundary.

For example, "Content-Type: multipart/mixed; boundary=----------MascotMimeContent"

Parameters:
boundary | The string to be used as a separator between MIME sections.
contentType | The type of content in the MIME; typically "multipart/form-data" or "multipart/mixed".
Returns:
formatted header
int getCount ( ) const

Returns the number of items.

Returns:
The number of items present.
std::string getFilename ( int oneBasedIndex ) const

Returns the filename attribute of an item.

Parameters:
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns:
file name from index
std::string getName ( int oneBasedIndex ) const

Returns the name of an item.

Parameters:
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns:
name from index
std::string getValue ( int oneBasedIndex ) const

Returns the value of an item.

Parameters:
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns:
value from index
bool hasFilename ( int oneBasedIndex ) const

Returns true if the item has a filename attribute.

Parameters:
oneBasedIndex The index is 1..Count() inclusive (not zero based).
Returns:
file name from index
void setValue | ( | int | oneBasedIndex,
 |  | const std::string & | value
 | ) |  |

Change the value of an element.

Parameters:
oneBasedIndex | The index is 1..Count() inclusive (not zero based).
value | The new value for the element.

Any filename attribute wil be removed.

void setValueWithFilename | ( | int | oneBasedIndex,
 |  | const std::string & | value,
 |  | const std::string & | filename,
 |  | const std::string & | contentType
 | ) |  |

Change the value of an element and set a filename attribute on it.

Parameters:
oneBasedIndex | The index is 1..Count() inclusive (not zero based).
value | The value of the element.
filename | The name to be given to the MIME file.
contentType | The MIME type string for the type of content (e.g. "text/xml").
The documentation for this class was generated from the following files:
  • ms_http_client_mime.hpp
  • ms_http_client_mime.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_client_search
Public Types | Public Member Functions

ms_http_client_search Class Reference
[Accessing a Mascot Server using HTTP]

Used for submitting searches to a Mascot server and retrieving search results using HTTP. More...

#include <ms_http_client_search.hpp>

Inheritance diagram for ms_http_client_search:
[legend]
Collaboration diagram for ms_http_client_search:
[legend]

List of all members.

Public Types

enum DownloadOption {
DO_NORMAL = 0,
DO_WITH_IONS = 1
}

Definitions for downloading results.

More...
enum ReportTopSpecialValues {
RT_auto = 0,
RT_file = -1
}

Definitions for special 'report top' values when requesting results in XML format.

More...
enum SearchStatusCode {
SS_UNKNOWN,
SS_ASSIGNED,
SS_QUEUED,
SS_RUNNING,
SS_COMPLETE,
SS_ERROR,
SS_SEARCH_CONTROL_ERROR
}

Definitions for the various states possible when querying about a running Mascot search.

More...
enum UploadResponseCode {
UR_SUCCESS,
UR_ACCESS_DENIED,
UR_INVALID_TASKID,
UR_NO_RESULT_FILENAME,
UR_NO_RESULT_FILE,
UR_FILE_ALREADY_EXISTS,
UR_ERROR
}

Definitions for the various responses possible when uploading data to Mascot.

More...

Public Member Functions

ms_http_client_search (ms_http_client_session &session, const std::string &searchTaskId)
Access previously run search results.
ms_http_client_search (const ms_http_client_search &src)
virtual | ~ms_http_client_search ()
Destructor;.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_client_search *right)
bool | downloadDaemonResultsFile (std::string filename, ms_http_helper_progress &progress)
Download the summary results of a search in the format used by Mascot Daemon.
bool | downloadPercolatorFile (std::string filename, ms_http_helper_progress &progress)
Download the Percolator inpput and output files for the associated search.
bool | downloadResultsFile (std::string filename, ms_http_helper_progress &progress, DownloadOption options=DO_WITH_IONS)
Download the results file (F*.dat).
bool | downloadXmlResultsFile (std::string filename, ms_http_helper_progress &progress, int reportTop=RT_auto)
Download the results of the search in XML format.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getResultsFileName (std::string &returnFileName)
Return the path to the result file on the server (usually relative to the cgi directory).
std::string | getSearchTaskID () const
Get the task ID of the associated Mascot search.
std::string | getSessionID () const
Get the associated session ID.
bool | getStatus (SearchStatusCode &returnCode, int &statusValue)
Return the current status of the search.
bool | isValid () const
Call this function to determine if there have been any errors.
ms_http_client_search & | operator= (const ms_http_client_search &right)
std::string | sessionId () const
Get the associated session ID.
bool | uploadDistillerXmlResultsFile (std::string filename, UploadResponseCode &responseCode, std::string &responseText)
Upload a Mascot Distiller quantitation XML file to the server.

Detailed Description

Used for submitting searches to a Mascot server and retrieving search results using HTTP.

Use ms_http_client_search to follow the progress of a new search as it runs on the Macot server and to retrieve the results from both new searches and old searches stored on the server.

The Mascot search must be run on the server within a Mascot session created by ms_http_client_session.

A previous search can be accessed by constructing a ms_http_client_search with a task identifier.

Member Enumeration Documentation

enum DownloadOption

Definitions for downloading results.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
DO_NORMAL

Downloads a compressed results file with the peak list sections removed. This is the normal download mode for Mascot Distiller, but most other applications should use DO_WITH_IONS.

DO_WITH_IONS

Download the complete results file. The file is downloaded as uncompressed text.

enum ReportTopSpecialValues

Definitions for special 'report top' values when requesting results in XML format.

Otherwise can use a small positive integer (eg 1..50) See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
RT_auto

Automatically determine the number of protein hits included in the report.

RT_file

Honour the number of hits specified when the search was submitted.

enum SearchStatusCode

Definitions for the various states possible when querying about a running Mascot search.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
SS_UNKNOWN

The search task ID was not recognised as a recent Mascot task.

SS_ASSIGNED

The search task has been assigned but no search has been submitted.

SS_QUEUED

The search has been submitted, but it has been queued .

SS_RUNNING

The search has started. The approximate percentage that has been completed is available.

SS_COMPLETE

The search has completed.

SS_ERROR

An error occurred when running the search. The Mascot error number is available from the getStatus call.

SS_SEARCH_CONTROL_ERROR

An error has occurred in the Mascot server application trying to get the search status. The error code is available and is documented in the Mascot Installation and Setup Manual (For example, ERR_TASKID_FAILOPEN = 1)

enum UploadResponseCode

Definitions for the various responses possible when uploading data to Mascot.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
UR_SUCCESS

The upload completed successfully.

UR_ACCESS_DENIED

The upload was not permitted by Mascot Security.

UR_INVALID_TASKID

The upload failed due to not having a task identifier.

UR_NO_RESULT_FILENAME

The upload failed due to not having a result file name.

UR_NO_RESULT_FILE

The upload failed due to the result file not existing.

UR_FILE_ALREADY_EXISTS

The upload failed because the file already exists.

UR_ERROR

The upload failed due to an unspecified error.

Constructor & Destructor Documentation

ms_http_client_search | ( | ms_http_client_session & | session,
 |  | const std::string & | searchTaskId
 | ) |  |

Access previously run search results.

This constructor does not validate the searchTaskId or session and does not call any scripts on the Mascot Server. It is recommended that getStatus() is called before calling other functions so that the searchTaskId and session can be validated.

Parameters:
session | The associated session object.
searchTaskId | The Mascot task identifier used for the associated search.
~ms_http_client_search ( ) [virtual]

Destructor;.

Called automatically.

ms_http_client_search ( const ms_http_client_search & src )
Parameters:
src is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_http_client_search * right )

The session object is copied, it is not created anew, cf the other constructors

Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
bool downloadDaemonResultsFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress
 | ) |  |

Download the summary results of a search in the format used by Mascot Daemon.

Parameters:
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
Returns:
Returns true if the function completed successfully.
bool downloadPercolatorFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress
 | ) |  |

Download the Percolator inpput and output files for the associated search.

Parameters:
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
Returns:
Returns true if the function completed successfully.
bool downloadResultsFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress,
 |  | DownloadOption | options = DO_WITH_IONS
 | ) |  |

Download the results file (F*.dat).

It is safest to call getStatus() before calling this function to validate the searchTaskId etc. because this function has more limited error reporting.

Parameters:
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
options | This contains the bit flags that controls how the file will be downloaded. It should be DO_NORMAL or a bitwise accumulation (boolean or operation) of the other flags.
Returns:
Returns true if the function completed successfully.
bool downloadXmlResultsFile | ( | std::string | filename,
 |  | ms_http_helper_progress & | progress,
 |  | int | reportTop = RT_auto
 | ) |  |

Download the results of the search in XML format.

Use of this function is deprecated. Use downloadResultsFile instead.

Parameters:
filename | The name of the local file for the results to be written to.
progress | The progress information is maintained as the data is downloaded from the server. The download may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
reportTop | The number of protein hits to include in the results.
Returns:
Returns true if the function completed successfully.
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getResultsFileName ( std::string & returnFileName )

Return the path to the result file on the server (usually relative to the cgi directory).

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?result_file_name&task_id=searchTaskId

If the function fails because an invalid searchTaskId has been set, then the function will return false, returnFileName will be empty and the ms_errs::ERR_MSP_HTTP_GETRESULTSFILENAME error will be set.

It is safest to call getStatus() before calling this function to validate the searchTaskId etc. because this function has more limited error reporting.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] returnFileName Returns the path to the result file on the server (usually relative to the cgi directory).
Returns:
Returns true if the function completed successfully.
std::string getSearchTaskID ( ) const

Get the task ID of the associated Mascot search.

Returns:
The Mascot task identifier used for the associated search.
std::string getSessionID ( ) const

Get the associated session ID.

Returns:
The associated Mascot Server session ID.
bool getStatus | ( | SearchStatusCode & | returnCode,
 |  | int & | statusValue
 | ) |  |

Return the current status of the search.

Can be called regularly while a submitted search is runing in order to determine status.

The function is implemented by calling ms_http_helper::httpGetString with the command:

client.pl?status&task_id=searchTaskId

The value returned in statusValue depends on the returnCode:

  • SS_UNKNOWN - statusValue will be 0
  • SS_ASSIGNED - statusValue will be 0
  • SS_ERROR -
    • a positive statusValue will be a Mascot Error code. A full list of value are available here
    • A statusValue of -1 indicates that the search crashed without an error.
    • A statusValue of -2 indicates that the search was terminated by a user.
  • SS_QUEUED - statusValue will be 0
  • SS_RUNNING - statusValue will be the percentage complete for the search.
  • SS_COMPLETE - statusValue will be 0
  • SS_SEARCH_CONTROL_ERROR - statusValue will be:
    • ERR_TASKID_NOERROR = 0
    • ERR_TASKID_FAILOPEN = 1
    • ERR_TASKID_FAILCREATE = 2
    • ERR_TASKID_FAILREAD = 3
    • ERR_TASKID_FAILWRITE = 4
    • ERR_TASKID_FAILCLOSE = 5
    • ERR_TASKID_CHANGEDRECORD = 6
    • ERR_TASKID_INVALIDMASCOTDAT = 7
    • ERR_TASKID_MISSINGRESULTSFILE = 8
    • ERR_TASKID_FILENAMETOOLONG = 9
    • ERR_TASKID_SESSIONTIMEDOUT = 10
    • ERR_TASKID_PERMISSIONDENIED = 11

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | returnCode | Returns the current status code of the search task.
[out] | statusValue | Returns an optional value depending on the returnCode.
Returns:
Returns true if the function completed successfully.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
ms_http_client_search & operator= ( const ms_http_client_search & right )
Parameters:
right is the source to initialise from
Returns:
reference to the current object
std::string sessionId ( ) const [inline]

Get the associated session ID.

Deprecated:
Use getSessionID()
Returns:
session id
bool uploadDistillerXmlResultsFile | ( | std::string | filename,
 |  | ms_http_client_search::UploadResponseCode & | responseCode,
 |  | std::string & | responseText
 | ) |  |

Upload a Mascot Distiller quantitation XML file to the server.

Uploads a Mascot Distiller quantitation XML file to the Mascot Server.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | filename | The path of the file to be uploaded.
[out] | responseCode | If the return value is true then this should be checked to see if the upload was accepted as valid.
[out] | responseText | The response from the Mascot server.
Returns:
Returns true if the file was uploaded, not whether the upload was accepted as valid.
The documentation for this class was generated from the following files:
  • ms_http_client_search.hpp
  • ms_http_client_search.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_client_session
Public Types | Public Member Functions

ms_http_client_session Class Reference
[Accessing a Mascot Server using HTTP]

This gives access to a Mascot session so searches may be submitted. More...

#include <ms_http_client_session.hpp>

Inheritance diagram for ms_http_client_session:
[legend]
Collaboration diagram for ms_http_client_session:
[legend]

List of all members.

Public Types

enum SequenceShowOptions {
SHOW_PI = 0x0001,
SHOW_TITLE = 0x0002,
SHOW_LENGTH = 0x0004,
SHOW_SEQUENCE = 0x0008,
SHOW_REFERENCE = 0x0010,
SHOW_NONE = 0,
SHOW_ALL = 0xFFFF
}

Information to include in a request for sequence data.

More...

Public Member Functions

ms_http_client_session ()
Create an empty session.
ms_http_client_session (const ms_http_helper connection, const std::string sessionId)
Construct a session object that can be used to access the Mascot Server.
ms_http_client_session (const ms_http_client_session &src)
virtual | ~ms_http_client_session ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
void | copyFrom (const ms_http_client_session *right)
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
bool | getIsPermitted (ms_security_tasks::TASKID taskType, bool &returnIsPermitted)
Returns true if the security token is allowed for this session.
bool | getIsXmlUploadedList (const std::vector< std::string > &taskIds, std::vector< int > &xmlUploaded)
Queries if the specified searches have had Mascot Distiller quantitation XML uploaded.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getSequenceFile (const std::string &database, const std::vector< std::string > &accessionNames, const std::vector< int > &accessionFrames, const std::string &filename, const SequenceShowOptions options=SHOW_ALL)
Download sequence information for a set of accessions.
std::string | getSessionID () const
Returns the Mascot session ID.
bool | isValid () const
Call this function to determine if there have been any errors.
bool | logout ()
Close the Mascot session.
ms_http_client_session & | operator= (const ms_http_client_session &right)
bool | submitSearch (ms_http_client_search &returnTask, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_progress &progress, bool batch=false)
Submit a search to the Mascot server.

Detailed Description

This gives access to a Mascot session so searches may be submitted.

Create an ms_http_client_session object by calling: ms_http_client::userLogin and this object can then be used to submit a search by calling ms_http_client_session::submitSearch

Multiple searches and data requests may be made using the same ms_http_client_session. When access to the Mascot Server is complete, call logout

Server side documentation for sessions is here

Member Enumeration Documentation

enum SequenceShowOptions

Information to include in a request for sequence data.

Add the flags together to include multiple data items per sequence. Pass the enum to getSequenceFile

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
SHOW_PI

Show the isoelectric point (as a pH).

SHOW_TITLE

Show the single-line title.

SHOW_LENGTH

Show the length of the sequence.

SHOW_SEQUENCE

Show the sequence itself.

SHOW_REFERENCE

Show the full entry annotation text.

SHOW_NONE

Show none of the information.

SHOW_ALL

Show all available information.

Constructor & Destructor Documentation

ms_http_client_session ( )

Create an empty session.

Create an empty session. This is normally passed to ms_http_client::userLogin to populate it.

ms_http_client_session | ( | const ms_http_helper | connection,
 |  | const std::string | sessionId
 | ) |  |

Construct a session object that can be used to access the Mascot Server.

This is used internally by ms_http_client and should not normally be called by a client application.

Parameters:
connection | The associated ms_http_helper.
sessionId | The Mascot Server session ID.
~ms_http_client_session ( ) [virtual]

Destructor.

This tidies up any HTTP connection that is still open by calling logout() if necessary.

ms_http_client_session ( const ms_http_client_session & src )
Parameters:
src is the source to initialise from

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
void copyFrom ( const ms_http_client_session * right )
Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
bool getIsPermitted | ( | ms_security_tasks::TASKID | taskType,
 |  | bool & | returnIsPermitted
 | ) |  |

Returns true if the security token is allowed for this session.

Permissions are set in the Mascot Security Administration pages.

The most relevant tokens for third party clients are:

  • SECTASK_ALLOWPMF - Allow pmf searches.
  • SECTASK_ALLOWMSMS - Allow ms/ms (and SQ) searches.
  • SECTASK_ALLOWMSMSNOENZYME - Allow ms/ms no enzyme searches.
  • SECTASK_ALLOWPMFNOENZYME - Allow no enzyme pmf searches.
  • SECTASK_ALLFASTA - Allow all fasta databases to be searched.
  • SECTASK_NAMEDFASTA - Special fasta databases that override the default setting.
  • SECTASK_DAEMONCLIENT - Mascot Daemon is allowed to submit searches.
  • SECTASK_DISTILLERCLIENT - Mascot Distiller is allowed to submit searches.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | taskType | The security token being queried.
[out] | returnIsPermitted | Returns true if the security task type is permitted on this session, false if not.
Returns:
Returns true if the function completed successfully.
bool getIsXmlUploadedList | ( | const std::vector< std::string > & | taskIds,
 |  | std::vector< int > & | xmlUploaded
 | ) |  |

Queries if the specified searches have had Mascot Distiller quantitation XML uploaded.

The query can be for any number of searches. If the number of searches is too large for a single query to the server then multiple queries will be made.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | taskIds | The task IDs of the searches.
[out] | xmlUploaded | Set to the same size as taskIds. Non-zero if Mascot Distiller quantitation XML has been uploaded for that search.
Returns:
True if the query completed successfully.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getSequenceFile | ( | const std::string & | database,
 |  | const std::vector< std::string > & | accessionNames,
 |  | const std::vector< int > & | accessionFrames,
 |  | const std::string & | filename,
 |  | const SequenceShowOptions | options = SHOW_ALL
 | ) |  |

Download sequence information for a set of accessions.

The retrieved file is in XML.

If the database is not active on the Mascot server then the body opf the XML document will be empty.

The frame number is used if the frames collection has an entry for a name and it is not -1.

See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

Parameters:
database | The name of the database on the Mascot server fromn which the data is to be retrieved.
accessionNames | A collection of accession names for the peptides or NA sequences to be retrieved.
accessionFrames | A collection of frames. This only has meaning for an NA database. 0 means return the NA sequence. A number between 1 and 6 means translate the NA sequence in that frame and return the AA sequence.
filename | The name of the local file to be populated with the retrieved information. S
options | The types of information to be included in the output file.
Returns:
Returns true if the function completed successfully.
std::string getSessionID ( ) const

Returns the Mascot session ID.

This may change during any call that accesses the Mascot server as the session on the server may have expired and a new one will be automatically created.

Returns:
the current session id
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
bool logout ( )

Close the Mascot session.

Called automatically by the destructor.

You must login again to create a new Mascot session in order to use the Mascot server again.

Returns:
The final result of the attempt to logout.
ms_http_client_session & operator= ( const ms_http_client_session & right )
Parameters:
right is the source to initialise from
Returns:
reference to the current object
bool submitSearch | ( | ms_http_client_search & | returnTask,
 |  | const std::string & | httpHeader,
 |  | const std::string & | prologue,
 |  | const std::string & | filename,
 |  | const std::string & | epilogue,
 |  | ms_http_helper_progress & | progress,
 |  | bool | batch = false
 | ) |  |

Submit a search to the Mascot server.

The search is submitted using a POST request to the search executable (normally nph-mascot.exe) on the Mascot Server.

This function makes http calls to the Mascot Server to create a unique taskID and this is returned in the ms_http_client_search object and can be accessed using ms_http_client_search::getSearchTaskID . The name of the search application in use on the Mascot server is also retrieved from the server as part of this process.

The search parameters and peak list are combined into a MIME format file using the prologue, filename and epilogue parameters.

This function normally only returns when all the data has been sent. If the abort submission function is called then it will stop sending data at a convenient point and return early.

The logging level and logging file (if any) in the returnTask are set to be the same as in the ms_http_client_session object. Any existing errors in returnTask are cleared.

Parameters:
returnTask | The search object that can be used to monitor progress and then retrieve results. See Maintaining object references: two rules of thumb.
httpHeader | The HTTP header line, specifying the content type and the MIME separator string. For example: "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH"
prologue | Text sent as the first part of the content of the HTTP POST. This will normally contain the search parameters. For an example, see http_client.pl
filename | The name of a file, the content of which is sent after the prologue text and before the epilogue text. This can be an MGF or other peak list data file.
epilogue | Text sent as the last part of the content of the HTTP POST. For example, "-----------FormBoundary4C9ByKKVofH--"
progress | The progress information is maintained as the data is uploaded to the server. The upload may be aborted by calling setAbort. See Maintaining object references: two rules of thumb.
batch | If true, the search will be submitted with the -batch switch, which will keep the search alive on IIS if the connection is broken. This can only be used with Mascot 2.5 or later, and will cause an error if set to true when submitting a search on an older version of Mascot [default=false].
Returns:
Returns true if the function completed successfully.
The documentation for this class was generated from the following files:
  • ms_http_client_session.hpp
  • ms_http_client_session.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_helper
Public Types | Public Member Functions | Static Public Member Functions

ms_http_helper Class Reference
[Accessing a Mascot Server using HTTP]

The class provides HTTP, FTP and FILE protocol access to a server. More...

#include <ms_http_helper.hpp>

Inheritance diagram for ms_http_helper:
[legend]
Collaboration diagram for ms_http_helper:
[legend]

List of all members.

Public Types

enum FileMode {
FM_binary,
FM_text
}

Definitions for types of file content transfer.

More...

Public Member Functions

ms_http_helper ()
C++ STL collection support.
ms_http_helper (const ms_http_helper &copy)
Copy constructor.
ms_http_helper (const std::string &baseUrl, const ms_connection_settings &settings)
Constructor for a connection to a server.
~ms_http_helper ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
const std::string & | baseUrl () const
Returns the base URL to the server.
void | clearAllErrors ()
Remove all errors from the current list of errors.
const ms_connection_settings & | connectionSettings () const
Returns the internet settings used for the HTTP connection.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
void | copyFrom (const ms_http_helper *right)
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getProxyConfig (std::vector< std::string > &proxyServers, std::vector< std::string > &proxyUsernames, std::vector< std::string > &proxyPasswords)
Get the proxy server configuration settings.
ms_http_helper_return httpBufferedClose ()
Closes the current buffered read session.
ms_http_helper_return | httpBufferedGetString (std::string &httpBuffer, unsigned long requiredSize)
Get available data from the open session. Writes data into the supplied buffer up to at least the required size.
ms_http_helper_return | httpBufferedOpen (const std::string &action)
Creates and opens a session for buffered reading from the supplied base URL and action.
ms_http_helper_return | httpGetFile (const std::string &action, const std::string &filename, ms_http_helper_progress &progress, FileMode fileMode=FM_binary)
Sends an HTTP GET message to the server and store the reply in a file.
ms_http_helper_return | httpGetHeader (const std::string &action, std::string &httpHeaderInfo)
Sends an HTTP HEAD message to the server and returns the header information separated with CR LF.
ms_http_helper_return | httpGetString (const std::string &action, std::string &httpGETString)
Sends an HTTP GET message to the server and returns the reply in a string.
ms_http_helper_return | httpPostFile (const std::string &action, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_handles &handles, ms_http_helper_progress &progress)
Sends an HTTP POST message to the server and returns handles to allow the HTTP connection to be managed.
bool | isValid () const
Call this function to determine if there have been any errors.
const ms_http_helper & | operator= (const ms_http_helper &copy)
Copy assignment.

Static Public Member Functions

static std::string | getHeaderValue (const std::string &name, const std::string &header)
Returns the value for a name-value pair in an http header.

Detailed Description

The class provides HTTP, FTP and FILE protocol access to a server.

The following tasks are supported:

  • Sending GET commands to an HTTP server and getting the response string.
  • Sending GET commands to an HTTP server and getting the response as a file.
  • POSTing a file to an HTTP server.
  • Sending GET commands to HTTP, FTP or FILE protocol based servers and buffering the response as strings. This is useful for large downloads into memory where the size is not known.
Examples:

http_helper_getstring.cpp.

Member Enumeration Documentation

enum FileMode

Definitions for types of file content transfer.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
FM_binary

Binary - the data is saved in exactly the form as it is received.

FM_text

Text - the data is translated to a more text friendly form (new lines become cariage return/line feed pairs).

Constructor & Destructor Documentation

ms_http_helper ( )

C++ STL collection support.

No network activity occurs during the constructor.

ms_http_helper ( const ms_http_helper & copy )

Copy constructor.

Required because there is a dynamically added data member.

Parameters:
copy reference to a ms_http_helper object
ms_http_helper | ( | const std::string & | baseUrl,
 |  | const ms_connection_settings & | settings
 | ) |  |

Constructor for a connection to a server.

No network activity occurs during the constructor.

Parameters:
baseUrl | The base URL of the target server. For example "http://www.matrixscience.com/cgi/".
settings | Settings that control the behaviour of the network link to the server.
~ms_http_helper ( )

Destructor.

Called automatically.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
const std::string & baseUrl ( ) const

Returns the base URL to the server.

The base URL cannot be altered once the HTTP connection has been created.

Typically, the base URL will have the form "http://server_name/optional_path/cgi/".

Returns:
The base URL of the target server and file location. For example "http://www.matrixscience.com/cgi/".
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
const matrix_science::ms_connection_settings & connectionSettings ( ) const

Returns the internet settings used for the HTTP connection.

The settings cannot be altered once the HTTP connection has been created.

Returns:
Settings that control the behaviour of the network link to the server.
void copyFrom ( const ms_http_helper * right )
Parameters:
right is the source to initialise from
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
std::string getHeaderValue | ( | const std::string & | name,
 |  | const std::string & | header
 | ) |  | [static]

Returns the value for a name-value pair in an http header.

Returns the value for a name-value pair in an http header.

Parameters:
name | Required name key of name value pair in header.
header | The header text seperated by CR LF.
Returns:
The value string if it exists otherwise empty.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getProxyConfig | ( | std::vector< std::string > & | proxyServers,
 |  | std::vector< std::string > & | proxyUsernames,
 |  | std::vector< std::string > & | proxyPasswords
 | ) |  |

Get the proxy server configuration settings.

If unsuccessful, no output parameters are altered.

On Windows and depending on the proxy type in the ms_connection_settings, this uses the WinHttpGetIEProxyConfigForCurrentUser and WinHttpGetProxyForUrl Windows API functions to retrieve the information. For details, see: http://msdn.microsoft.com/en-us/library/windows/desktop/aa384097.aspx and http://msdn.microsoft.com/en-us/library/windows/desktop/aa384096.aspx

On Windows, the proxy server list is typically either set explicitly or retrieved, by the operating system, using Web Proxy Autodiscovery Protocol (WPAD) or Proxy auto-config (PAC). These protocols allow for different proxies to be configured for different domains, paths, ports or schemes (although Windows may imposes restrictions that limit the scope of this functionality - only the domain name should be used to determine the proxy server). Some further information is available at http://findproxyforurl.com/

On Linux, autoconfiguration is of more rudimentary type: proxy settings are pulled from the system environment variables, then from ms_connection_settings::getProxyServer().

Within Parser, Windows only tries the first entry in the proxy server list, and does not 'roll over' to try the next entry when one proxy cannot be reached. On Linux, on the other hand, each proxy server is tried in turn. If they all fail, a no-proxy configuration is tried as the last alternative.

Parameters:
proxyServers is filled in with the list of proxy server URLs. See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.

  • The format of the proxy will be, for example, http://proxy:3128
  • On Windows, if the system specifies a direct connection for url, then proxyServers will be an empty array.
  • On Linux, if the system should try a no-proxy configuration, the last item in proxyServers will be the empty string.
  • The array will contain more than one item when a fall back system is in place, in which case the application should try the first proxy, and then if this fails, it should try the next etc.
proxyUsernames | is filled with usernames to be used with proxyServers. If a proxy server does not need authentication, the corresponding element will be the empty string. proxyUsernames.size() equals proxyServers.size(). See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
proxyPasswords | is filled with passwords to be used with proxyUsernames. If a proxy server does not need authentication or if a password is not needed, the corresponding element will be the empty string. proxyPasswords.size() equals proxyServers.size(). See Using STL vector classes vectori, vectord and VectorString in Perl, Java, Python and C#.
Returns:
Returns true if the function completed successfully.
matrix_science::ms_http_helper_return httpBufferedClose ( )

Closes the current buffered read session.

Closes a currently open buffered read session and connection. Refer to httpBufferedOpen() for example code and aditional information.

Returns:
Any errors detected during closing
Examples:
http_helper_getstring.cpp.
matrix_science::ms_http_helper_return httpBufferedGetString | ( | std::string & | httpBuffer,
 |  | unsigned long | requiredSize
 | ) |  |

Get available data from the open session. Writes data into the supplied buffer up to at least the required size.

Reads to at least the requiredSize (or until empty) from currently open buffered read session. Overwrites data in the supplied buffer. If no data read then the buffer will set to zero length. Refer to httpBufferedOpen() for example code and aditional information.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | httpBuffer | Receives any data read from the connection.
[in] | requiredSize | The method returns when the buffer is greater than or equal to this size or when no more data available.
Returns:
Any errors detected during reading.
Examples:
http_helper_getstring.cpp.
matrix_science::ms_http_helper_return httpBufferedOpen ( const std::string & action )

Creates and opens a session for buffered reading from the supplied base URL and action.

Opens a buffered read session using the current URL, action and connection settings. Allows data to be read in chunks and processed by using subsequent calls to httpBufferedGetString().

Support for HTTP, FTP and FILE protocols. HTTPS not currently supported.

Only one session for each ms_http_helper instance is supported at a time. Use the ms_connection_settings instance to setup any required proxy and security settings.

Parameters:
action The action string, appended to the base URL, to be sent to the server.

Example URL's:

  • "ftp://username:password@hostname/file.txt"
  • "file://hostname/file.txt"
  • "http://localhost/sitename/file.txt"

Example code:

 ms_connection_settings cs; // This uses default local security settings.
 ms_http_helper helper("http://localhost/sitename/", cs);
 if (helper.httpBufferedOpen("file.txt").isOk())
 {
     // Loop reading chunks of data until no more is available.
     while (true)
     {
         std::string buffer;
         // Reads at least 10000 bytes if available.
         ms_http_helper_return result = helper.httpBufferedGetString(buffer, 10000);
         // If the buffer size is empty then no more data is available.
         if (buffer.length() == 0 || !result.isOk())
             break;
         // Process buffer contents here.
     }
     helper.httpBufferedClose();
 }
Returns:
Returns any errors occurring during connection.
Examples:
http_helper_getstring.cpp.
matrix_science::ms_http_helper_return httpGetFile | ( | const std::string & | action,
 |  | const std::string & | filename,
 |  | matrix_science::ms_http_helper_progress & | progress,
 |  | FileMode | fileMode = FM_binary
 | ) |  |

Sends an HTTP GET message to the server and store the reply in a file.

The progress information is updated as the download proceeds. The total amount of data to be returned is not known until the end of the download and so the total field is left at zero. The percentage complete will keep moving upward but is not a valid indicator of how much download is still remaining.

Parameters:
action | The action string, appended to the base URL, to be sent to the server.
filename | The name of the file to write the downloaded reply to.
progress | An object to keep up-to-date with the current progress of request. See Maintaining object references: two rules of thumb.
fileMode | The mode (text or binary) in which to write the downloaded reply to the file.
Returns:
The final outcome of the HTTP GET request.
matrix_science::ms_http_helper_return httpGetHeader | ( | const std::string & | action,
 |  | std::string & | httpHeaderInfo
 | ) |  |

Sends an HTTP HEAD message to the server and returns the header information separated with CR LF.

Retrieves the HTTP header text if present for the current URL, action and connection settings.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | action | The action string, appended to the base URL, to be sent to the server.
[out] | httpHeaderInfo | The string to receive the header text. Each section is seperated with CR LF
Returns:
Returns any errors occurring during connection.
Examples:
http_helper_getstring.cpp.
matrix_science::ms_http_helper_return httpGetString | ( | const std::string & | action,
 |  | std::string & | httpGETString
 | ) |  |

Sends an HTTP GET message to the server and returns the reply in a string.

Called by many higher level functions.

This will log the ms_errs::ERR_MSP_HTTP_URLSTRING message.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[in] | action | The action string, appended to the base URL, to be sent to the server.
[out] | httpGETString | Returns the raw HTTP text received in reply from the server.
Returns:
The final outcome of the HTTP GET request.
Examples:
http_helper_getstring.cpp.
matrix_science::ms_http_helper_return httpPostFile | ( | const std::string & | action,
 |  | const std::string & | httpHeader,
 |  | const std::string & | prologue,
 |  | const std::string & | filename,
 |  | const std::string & | epilogue,
 |  | matrix_science::ms_http_helper_handles & | returnHandles,
 |  | matrix_science::ms_http_helper_progress & | progress
 | ) |  |

Sends an HTTP POST message to the server and returns handles to allow the HTTP connection to be managed.

The progress information is updated as the upload proceeds. The total amount of data to be determined before the upload begins and this is placed in the proess total field.

The POST message contains the data from the prologue string, the file contents and then the epilogue string.

This will log the ms_errs::ERR_MSP_HTTP_URLSTRING message.

The function returns when the upload is complete.

Parameters:
action | The action string, appended to the base URL, to be sent to the server.
httpHeader | The HTTP headers passed when creating a new query. Typically this identifies the content type and the MIME separator string.
prologue | Text sent as the first part of the content of the HTTP POST.
filename | The name of a file, the content of which is sent after the prologue text and before the epilogue text.
epilogue | Text sent as the last part of the content of the HTTP POST.
returnHandles | Returns handles that can be used to dowload the response from the server. See Maintaining object references: two rules of thumb.
progress | An object to keep up-to-date with the current progress of request. See Maintaining object references: two rules of thumb.
Returns:
Returns true if the function completed successfully.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
const ms_http_helper & operator= ( const ms_http_helper & copy )

Copy assignment.

Required because there is a dynamically added data member.

Parameters:
copy reference to a ms_http_helper object
Returns:
reference to the current object
The documentation for this class was generated from the following files:
  • ms_http_helper.hpp
  • ms_http_helper.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_helper_handles
Public Member Functions

ms_http_helper_handles Class Reference
[Accessing a Mascot Server using HTTP]

The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request. More...

#include <ms_http_helper_handles.hpp>

Inheritance diagram for ms_http_helper_handles:
[legend]
Collaboration diagram for ms_http_helper_handles:
[legend]

List of all members.

Public Member Functions

ms_http_helper_handles ()
Default constructor.
virtual | ~ms_http_helper_handles ()
Destructor.
void | appendErrors (const ms_errors &src)
Copies all errors from another instance and appends them at the end of own list.
void | clearAllErrors ()
Remove all errors from the current list of errors.
bool | closeHandles ()
Closes the HTTP handles.
void | copyFrom (const ms_errors *right)
Use this member to make a copy of another instance.
const ms_errs * | getErrorHandler () const
Retrive the error object using this function to get access to all errors and error parameters.
int | getLastError () const
Return the error description of the last error that occurred.
std::string | getLastErrorString () const
Return the error description of the last error that occurred.
bool | getRequestData (bool &isStillActive, std::string &requestDataRef)
Retrieves data from the HTTP reply and indicates whether the request is still active (and could produce more data).
bool | isValid () const
Call this function to determine if there have been any errors.

Detailed Description

The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request.

Mascot searches will terminate immediately if the HTTP request times out. It is important to keep the request alive by frequently checking for request data. The Mascot server sends occasional data packets that can be collected. Once the request has completed there could be several packets of uncollected data before the function indicates that the request is no longer active. Once it is inactive the handles can be closed. An object of this class is initialised by ms_http_helper::httpPostFile

Constructor & Destructor Documentation

~ms_http_helper_handles ( ) [virtual]

Destructor.

The handles will be automatically closed when there are no more handles object referencing them.

Called automatically.

Member Function Documentation

void appendErrors ( const ms_errors & src ) [inherited]

Copies all errors from another instance and appends them at the end of own list.

Parameters:
src The object to copy the errors across from. See Maintaining object references: two rules of thumb.
void clearAllErrors ( ) [inherited]

Remove all errors from the current list of errors.

The list of 'errors' can include fatal errors, warning messages, information messages and different levels of debugging messages.

All messages are accumulated into a list in this object, until clearAllErrors() is called.

See Error Handling.

See also:
isValid(), getLastError(), getLastErrorString(), getErrorHandler()
Examples:
common_error.cpp, resfile_error.cpp, and resfile_summary.cpp.
bool closeHandles ( )

Closes the HTTP handles.

On Windows IIS, closing the handles will terminate a search being done for that task on the Mascot server.

Returns:
True if the function completes successfully.
void copyFrom ( const ms_errors * right ) [inherited]

Use this member to make a copy of another instance.

Parameters:
right is the source to initialise from
const ms_errs * getErrorHandler ( ) const [inherited]

Retrive the error object using this function to get access to all errors and error parameters.

See Error Handling.

Returns:
Constant pointer to the error handler
See also:
isValid(), getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, and http_helper_getstring.cpp.
int getLastError ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

See Error Handling.

See also:
isValid(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Returns:
the error number of the last error, or 0 if there have been no errors.

Reimplemented in ms_mascotresfile.

std::string getLastErrorString ( ) const [inherited]

Return the error description of the last error that occurred.

All errors are accumulated into a list in this object, until clearAllErrors() is called. This function returns the last error that occurred.

Returns:
Most recent error, warning, information or debug message

See Error Handling.

See also:
isValid(), getLastError(), clearAllErrors(), getErrorHandler()

Reimplemented in ms_mascotresfile.

Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, and tools_aahelper.cpp.
bool getRequestData | ( | bool & | isStillActive,
 |  | std::string & | requestDataRef
 | ) |  |

Retrieves data from the HTTP reply and indicates whether the request is still active (and could produce more data).

The data is whatever is produced by the server as it progresses with the task. The function blocks until dat is available or the server task has finished.

The data from a Mascot server does not reflect any result of a search.

Use the ms_http_client_search::getStatus() function to monitor how the task is progressing.

See Multiple return values in Perl, Java, Python and C#.

Parameters:
[out] | isStillActive | True if any data was retrieved from the request.
[out] | requestDataRef | The data retrieved from the request.
Returns:
True if the function completed successfully.
bool isValid ( ) const [inherited]

Call this function to determine if there have been any errors.

This will return true unless there have been any fatal errors.

See Error Handling.

Returns:
True if no fatal error occured
See also:
getLastError(), getLastErrorString(), clearAllErrors(), getErrorHandler()
Examples:
common_error.cpp, config_enzymes.cpp, config_fragrules.cpp, config_license.cpp, config_mascotdat.cpp, config_masses.cpp, config_modfile.cpp, config_procs.cpp, config_quantitation.cpp, config_taxonomy.cpp, http_helper_getstring.cpp, peptide_list.cpp, resfile_summary.cpp, and tools_aahelper.cpp.
The documentation for this class was generated from the following files:
  • ms_http_helper_handles.hpp
  • ms_http_helper_handles.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_helper_progress
Public Member Functions

ms_http_helper_progress Class Reference
[Accessing a Mascot Server using HTTP]

This holds information on the progress of a running HTTP transfer. More...

#include <ms_http_helper_progress.hpp>

List of all members.

Public Member Functions

ms_http_helper_progress ()
C++ STL collection support.
UINT64 | getCurrentBytes () const
Returns the number of bytes sent or received.
double | getProportion () const
Returns a number from 0 to 1.0 that indicates how far the transaction has progressed.
UINT64 | getTotalBytes () const
Returns the total number of bytes that are due to be sent or received, or zero if the number is unknown.
bool | isAbortSet () const
Returns true if the transaction has been asked to abort.
bool | isComplete () const
Returns true if the transaction has run to completion (not terminated by error or abort).
bool | isStarted () const
Returns true if the transaction has started running.
void | setAbort ()
Cause the transaction to abort at the next available point.

Detailed Description

This holds information on the progress of a running HTTP transfer.

A progress object is passed to the connection when an extended transaction is started. The transaction updates the information as the transaction is going on.

Often, extended transacions are started on a worker thread so that other task (for example, the user interface) may continue to function while the transaction is in progress). An object of this class allows communication with the transaction while being processed on that thread.

This object can also be used to cancel the transaction prematurely if required.

Constructor & Destructor Documentation

ms_http_helper_progress ( )

C++ STL collection support.

STL collections, such as vector need a default constructor.

Member Function Documentation

UINT64 getCurrentBytes ( ) const

Returns the number of bytes sent or received.

This is the number of characters actually transferred so far.

Returns:
The number of characters transferred so far.
double getProportion ( ) const

Returns a number from 0 to 1.0 that indicates how far the transaction has progressed.

If the total amount to be transferred is unknown then the proportion value will change but does not represent any indication of the amount remaining.

Returns:
The proportion of the task that has been completed. Sero if the amount is unknown.
UINT64 getTotalBytes ( ) const

Returns the total number of bytes that are due to be sent or received, or zero if the number is unknown.

This is the size (in characters) of the file to be transferred.

For a download, te number of characters that are going to be sent by the server is not usually known until after the transfer is complete. In this case, this number remains zero.

Returns:
The number of characters to be transferred (including those already transferred).
bool isAbortSet ( ) const

Returns true if the transaction has been asked to abort.

This will return true after the setAbort() function has been called.

Returns:
True if the task is to be aborted at user request (i.e. setAbort() has been called).
bool isComplete ( ) const

Returns true if the transaction has run to completion (not terminated by error or abort).

If the transfer ended for any reason other than a successful transfer of all the data then this will continue to return false. The sumbit / download function will exit once the data transfer has ceased (for whatever reason).

Returns:
True if the task has completed.
bool isStarted ( ) const

Returns true if the transaction has started running.

Once the file transfer function has been called, there may be a delay before the transfer itself actually starts. This will only return true once the transfer of data has begun.

Returns:
True if the task has started (i.e. setStarted() has been called).
void setAbort ( )

Cause the transaction to abort at the next available point.

The file transfer, running on another thread, will continue until it gets to a suitable point and then exit.

The documentation for this class was generated from the following files:
  • ms_http_helper_progress.hpp
  • ms_http_helper_progress.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • matrix_science
  • ms_http_helper_return
Public Types | Public Member Functions | Static Public Member Functions

ms_http_helper_return Class Reference
[Accessing a Mascot Server using HTTP]

Indicates any problem that may have occurred during a request to an ms_http_helper object. More...

#include <ms_http_helper_return.hpp>

List of all members.

Public Types

enum ErrorTypeCode {
ERR_NONE,
ERR_ABORTEDBYUSER,
ERR_SYSTEM,
ERR_HTTP,
ERR_UNSPECIFIED
}

Definitions for types of problem that can be encountered.

More...

Public Member Functions

ms_http_helper_return ()
C++ STL collection support.
std::string | getErrorText () const
Returns the text, if any, associated with the error.
ErrorTypeCode | getErrorType () const
Returns type of any error that was encountered.
int | getHttpStatusCode () const
Returns the HTTP response code (if the type is ERR_http).
int | getSystemError () const
Returns the operating system error code for the problem (if the type is ERR_system).
bool | isOk () const
Returns true if no problem was encountered.
operator bool () const
Returns the same value as the IsOk function.

Static Public Member Functions

static ms_http_helper_return | abortedByUser ()
Creates an object to indicate that the operation has been aborted at the request of the user.
static ms_http_helper_return | httpError (int httpStatusCode, std::string errorText)
Creates an object with the specified HTTP response code (200 represents a success ).
static ms_http_helper_return | systemError (int systemError)
Creates an object with the specified system error code.
static ms_http_helper_return | unspecifiedError ()
Creates an error object with no specific cause.

Detailed Description

Indicates any problem that may have occurred during a request to an ms_http_helper object.

The soecific error information is returned to allow detailed or specific action to be taken in response. If no specific action is warranted then IsOk can be used to determine success or failure. Any failure will have been logged in the error handler for the ms_http_helper object.

Examples:

http_helper_getstring.cpp.

Member Enumeration Documentation

enum ErrorTypeCode

Definitions for types of problem that can be encountered.

See Using enumerated values and static const ints in Perl, Java, Python and C#.

Enumerator:
ERR_NONE

No problem was encountered; the operation completed successfully.

ERR_ABORTEDBYUSER

The operation was aborted prematurely at the request of the operator.

ERR_SYSTEM

A problem was found with one of the operating system functions.

ERR_HTTP

A problem was reported via the HTTP channel.

ERR_UNSPECIFIED

An error that was not categorised as one of the more specific types.

Constructor & Destructor Documentation

ms_http_helper_return ( )

C++ STL collection support.

STL collections, such as vector need a default constructor.

Member Function Documentation

ms_http_helper_return abortedByUser ( ) [static]

Creates an object to indicate that the operation has been aborted at the request of the user.

There is no text associated with this type of return.

Returns:
An object representing the fact that the task was aborted ath the request of the user.
std::string getErrorText ( ) const

Returns the text, if any, associated with the error.

The content depends on the type of error (see errorType()).

Returns:
The text for the error/reply represented.
Examples:
http_helper_getstring.cpp.
ms_http_helper_return::ErrorTypeCode getErrorType ( ) const

Returns type of any error that was encountered.

This can be ERR_NONE to indicate that there was no error.

Returns:
The type of return that this represents.
int getHttpStatusCode ( ) const

Returns the HTTP response code (if the type is ERR_http).

The meanings of HTTP status codes are defined by the Internet Engineering Task Force (IETF) (e.g. 200 = OK).

Returns:
The HTTP reply code encountered.
int getSystemError ( ) const

Returns the operating system error code for the problem (if the type is ERR_system).

The meaning of the return code depends on the underlying operating system (e.g. Windows, Linux).

Returns:
The system error code encountered.
ms_http_helper_return httpError | ( | int | httpStatusCode,
 |  | std::string | httpStatusText
 | ) |  | [static]

Creates an object with the specified HTTP response code (200 represents a success ).

The error text will contain the descriptive text returned in the HTTP reply.

Parameters:
httpStatusCode | The number of the HTTP error encountered.
httpStatusText | The text of the HTTP error encountered.
Returns:
An object representing the given HTTP error.
bool isOk ( ) const

Returns true if no problem was encountered.

If this returns false, then errorType() can be used to determine the cause.

Returns:
True if this does not represent any type of error.
Examples:
http_helper_getstring.cpp.
operator bool ( ) const

Returns the same value as the IsOk function.

If this returns false, then errorType() can be used to determine the cause.

Returns:
True if this does not represent any type of error.
ms_http_helper_return systemError ( int systemError ) [static]

Creates an object with the specified system error code.

The error text will contain the operating system provided description for the error.

Parameters:
systemError The number of the system error encountered.
Returns:
An object representing the given system error.
ms_http_helper_return unspecifiedError ( ) [static]

Creates an error object with no specific cause.

There is no diagnostic information available for this type of error.

Returns:
An object representing a non-specific error.
The documentation for this class was generated from the following files:
  • ms_http_helper_return.hpp
  • ms_http_helper_return.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • abortedByUser() : ms_http_helper_return
  • addComponent() : ms_ms1quant_match
  • addCreatedComponent() : ms_ms1quant_match
  • addCutter() : ms_enzyme
  • addDoubleParam() : ms_security_task
  • addExperimentalData() : ms_fragmentvector
  • addHeaderField() : ms_quantitation
  • addLogEventsHandler() : ms_loggingmonitor
  • addLongParam() : ms_security_task
  • addMatchInferred() : ms_ms1quantitation
  • addMatchPeptide() : ms_ms1quantitation
  • addMatchStatus() : ms_ms1quantitation
  • addNewGroup() : ms_security
  • addNewUser() : ms_security
  • addPeaks() : ms_spectral_lib_peak_list
  • addPeptideQuantKey() : ms_customquantitation
  • addPeptideQuantKeys() : ms_customquantitation
  • addPeptideRatio() : ms_customquantitation
  • addPermittedTask() : ms_group
  • addRawFileField() : ms_quantitation
  • addStringParam() : ms_security_task
  • addSubtask() : ms_progress_info
  • addTask() : ms_security_tasks
  • addToCatalog() : ms_log
  • addUser() : ms_group
  • allComponentsIdentified() : ms_ms1quant_match
  • ANNOT_LVL_CANNOT_ANNOTATE : ms_spectral_lib_peak_list
  • ANNOT_LVL_NONE : ms_spectral_lib_peak_list
  • ANNOT_LVL_QUESTION_MARKS : ms_spectral_lib_peak_list
  • ANNOT_LVL_SOME_PEAKS : ms_spectral_lib_peak_list
  • ANNOTATE_NONE : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_ALL : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_IF_ALL_EMPTY : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_QUESTION_MARKS : ms_spectral_lib_entry
  • annotatePeaks() : ms_spectral_lib_entry , ms_spectral_lib_peak_list
  • anyBoldRedPeptides() : ms_protein
  • anyEmPAI() : ms_peptidesummary , ms_mascotresults
  • anyMatchToQuery() : ms_protein
  • anyMatchToQueryAndP() : ms_protein
  • anyMSMS() : ms_mascotresfile
  • anyNLseriesUsed() : ms_fragmentationrules
  • anyNumDiscoveredMods() : ms_mascotresults
  • anyPeptideSummaryMatches() : ms_mascotresfile
  • anyPercolatorResults() : ms_peptide
  • anyPMF() : ms_mascotresfile
  • anySQ() : ms_mascotresfile
  • anyTag() : ms_mascotresfile
  • append() : ms_http_client_mime , ms_linker_site_vector , ms_peptide_quant_key_vector
  • appendAccession() : ms_crosslinking_accessions
  • appendAltName() : ms_umod_modification
  • appendAminoAcid() : ms_umod_configfile
  • appendComponent() : ms_quant_method
  • appendCorrection() : ms_quant_component
  • appendCronJob() : ms_cronoptions
  • appendDatabase() : ms_databases , ms_processoroptions
  • appendDenominator() : ms_quant_ratio
  • appendDoesNotPairWith() : ms_crosslinking_linker
  • appendElement() : ms_quant_composition , ms_umod_configfile
  • appendElemRef() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • appendEntry() : ms_taxonomyfile , ms_wwwoptions
  • appendEnzyme() : ms_enzymefile
  • appendErrors() : ms_mascotresfile , ms_errs , ms_errors
  • appendExcludeTaxonomy() : ms_taxonomychoice
  • appendExclusion() : ms_quant_method
  • appendFile() : ms_http_client_mime
  • appendFragment() : ms_fragmentvector
  • appendGencodeFile() : ms_taxonomyrules
  • appendIgnore() : ms_quant_localdef , ms_umod_modification
  • appendIgnoreDupeAccession() : ms_mascotoptions
  • appendIgnoreMass() : ms_modification
  • appendIncludeTaxonomy() : ms_taxonomychoice
  • appendInstrument() : ms_fragrulesfile
  • appendIonSeries() : ms_quant_multiplex
  • appendIsotope() : ms_quant_component
  • appendLinker() : ms_crosslinking_linkers
  • appendLocalDefinition() : ms_quant_modgroup
  • appendMethod() : ms_crosslinking_configfile , ms_quant_configfile
  • appendModBrick() : ms_umod_configfile
  • appendModFile() : ms_quant_modgroup
  • appendModification() : ms_umod_configfile , ms_modfile , ms_modvector
  • appendModificationGroup() : ms_quant_method , ms_quant_component
  • appendModifications() : ms_modvector
  • appendModifiedResidue() : ms_modification
  • appendMonoLink() : ms_crosslinking_linker
  • appendNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • appendNoBreakDescLineIf() : ms_taxonomyrules
  • appendNodesFile() : ms_taxonomyrules
  • appendNumerator() : ms_quant_ratio
  • appendParameter() : ms_crosslinking_parameters , ms_quant_parameters
  • appendPepNeutralLoss() : ms_umod_specificity , ms_quant_specificity
  • appendPeptide() : ms_quant_normalisation_peptides
  • appendPerDbSrcRule() : ms_taxonomyrules
  • appendPrefixRemove() : ms_taxonomyrules
  • appendProcessor() : ms_processoroptions
  • appendProperty() : ms_customproperty
  • appendProtein() : ms_quant_normalisation_proteins
  • appendReportNumberChoice() : ms_mascotoptions
  • appendReportRatio() : ms_quant_method
  • appendResfile() : ms_mascotresfile
  • appendSampleValue() : ms_shapiro_wilk
  • appendSeq() : ms_quant_method
  • appendSpeciesFile() : ms_taxonomyrules
  • appendSpecificity() : ms_quant_localdef , ms_umod_modification
  • appendStrFile() : ms_taxonomyrules
  • appendSubCluster() : ms_clusterparams
  • appendSuffixRemove() : ms_taxonomyrules
  • appendTargetFDRPercentage() : ms_mascotoptions
  • appendText() : ms_customproperty
  • appendThreadProcessorID() : ms_dbprocessors
  • appendUnmodified() : ms_quant_modgroup
  • appendXref() : ms_umod_modification
  • applyFixedMods() : ms_masses
  • applyIsotopes() : ms_masses
  • applyVisibility() : ms_umod_configfile
  • arithmeticMean() : ms_quant_stats
  • arithmeticStandardDeviation() : ms_quant_stats
  • arithmeticStandardErrorOfMean() : ms_quant_stats
  • arithmeticStandardErrorOfMedian() : ms_quant_stats
  • asText() : ms_spectral_lib_peak_list , ms_spectral_lib_peak
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Graphical Class Hierarchy

Go to the textual class hierarchy

Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Namespace List

Here is a list of all documented namespaces with brief descriptions:
matrix_science::ms_spectral_lib
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Enumerations
  • Enumerator
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • FILE_FORMAT : matrix_science::ms_spectral_lib
  • FORMAT_MGF : matrix_science::ms_spectral_lib
  • FORMAT_NIST_MSP : matrix_science::ms_spectral_lib
  • FORMAT_SPECTRAST : matrix_science::ms_spectral_lib
  • FORMAT_UNKNOWN : matrix_science::ms_spectral_lib
  • FORMAT_XHUNTER : matrix_science::ms_spectral_lib
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
ms_aahelper | This class facilitates creation of peptides and calculation of MS-fragment masses
ms_buffer_logger | Concrete class which implements ms_logger and stores log text in memory
ms_clusterparams | An instance of this class represents all the parameters specified in the Cluster section of mascot.dat
ms_computeraddress | The class serves as a container for computer address parameters for cluster mode
ms_connection_settings | Settings required to make an HTTP connection to a Mascot server
ms_cronjob | Represents a single entry from the cron section of mascot.dat
ms_cronoptions | Contains parameters from the cron section of mascot.dat
ms_crosslinking_accession | Accession element in crosslinking.xml
ms_crosslinking_accessions | Accessions element in crosslinking.xml
ms_crosslinking_configfile | This class represents the file crosslinking.xml
ms_crosslinking_does_not_pair_with | Mxm:does_not_pair_with element in crosslinking.xml
ms_crosslinking_filters | Filters element in crosslinking.xml
ms_crosslinking_linker | Linker element in crosslinking.xml
ms_crosslinking_linkers | Linkers element in crosslinking.xml
ms_crosslinking_method | Represents a method object in crosslinking.xml
ms_crosslinking_monolink | Monolink element in crosslinking.xml
ms_crosslinking_parameter | Parameter name and value pair
ms_crosslinking_parameters | A class that represents base parametersType in crosslinking_1.xsd
ms_crosslinking_scope | Scope element in crosslinking.xml
ms_crosslinking_settings | Settings element in crosslinking.xml
ms_customproperty | The class is used as a base for property-containing classes, such as ms_mascotoptions
ms_customquantitation | Peptide and protein quantitation using custom peptide ratios and protein-peptide mappings
ms_databaseoptions | An instance of this class represents a single database definition from the Databases section of mascot.dat
ms_databases | An instance of this class represents the Databases section of mascot.dat
ms_datfile | Encapsulates the mascot.dat file that contains the most important parameters
ms_dbprocessors | Represent a single dabatase entry in the Processors section
ms_distiller_data | Distiller project parameters
ms_distiller_data_quant | The details of a Distiller search
ms_distiller_data_search | The details of a Distiller search
ms_distiller_master_project | Data for a Distiller master project, includes a list of the subprojects
ms_distiller_master_search | The details of a Distiller multifile search
ms_distiller_search_status | A Mascot search status from a Distiller project file
ms_distiller_search_status_list | A list of Mascot search status values, typically stored in a Distiller project file
ms_distiller_sub_project | The details of a Distiller multifile subproject
ms_distiller_subsearch | The details of a Distiller multifile subsearch
ms_enzyme | Represent a single entry in the enzymes file
ms_enzymefile | Reads and parses the enzymes file that contains multiple enzyme definitions
ms_errors | This class is used as a base class for several Mascot Parser classes
ms_errs | All errors are collected in an instance of this class
ms_file_logger | Concrete class which implements ms_logger and outputs log text to the specified file
ms_fileutilities | This utility class mainly contains static members
ms_fitexy_result | Parameters and results from least squares fit with errors in both co-ordinates
ms_fragment | Class representing a single peptide fragment
ms_fragmentationrules | This class encapsulates a single entry (an instrument) from a fragmentation_rules file
ms_fragmentvector | Class for holding a list of ms_fragment objects
ms_fragrulesfile | This class encapsulates a complete fragmentation_rules file
ms_group | This class will normally only be used by Mascot Security Administration applications
ms_http_client | This class enables access to a Mascot server using HTTP
ms_http_client_mime | The class eases the building of a MIME section
ms_http_client_search | Used for submitting searches to a Mascot server and retrieving search results using HTTP
ms_http_client_session | This gives access to a Mascot session so searches may be submitted
ms_http_helper | The class provides HTTP, FTP and FILE protocol access to a server
ms_http_helper_handles | The class holds HTTP to allow a POST request to be kept alive and retrieve any output received from that request
ms_http_helper_progress | This holds information on the progress of a running HTTP transfer
ms_http_helper_return | Indicates any problem that may have occurred during a request to an ms_http_helper object
ms_inputquery | This class encapsulates the input data in the mascot results file
ms_libraryoptions | Represents the LibraryOptions section of mascot.dat
ms_license | The class provides access license details in read-only mode
ms_linker_site | Position of an intact link between alpha and beta peptide or a looplink
ms_linker_site_vector | A vector of linker sites
ms_log | Definitions for logging messages
ms_logger | Abstract class which provides the interface used by ms_logging monitor to delegate logging events
ms_loggingmonitor | Monitor class to delegate logging events generated from multiple sources
ms_mascotfiles | An instance of this class contains configuration files paths (except for mascot.dat)
ms_mascotoptions | An instance of this class represents all the parameters specified in the Options section of mascot.dat
ms_mascotresfile | The first requirement before using any other functions or classes is to create an ms_mascotresfile object
ms_mascotresults | Abstract class for either ms_peptidesummary or ms_proteinsummary
ms_mascotresults_params | Class which provides constructor parameters for either ms_peptidesummary or ms_proteinsummary
ms_masses | Reads and parses the masses file with residue and atom masses
ms_matrix | A two-dimensional matrix of numbers
ms_modfile | Use this class in order to read in the amino acid modification file
ms_modification | The class represents a single modification-entry in mod_file
ms_modvector | General usage class for creating lists of modifications to be passed as parameters
ms_ms1quant_average_results | Results specific to an 'average' type quantitation method
ms_ms1quant_charge_state | A result from a charge state calculation
ms_ms1quant_match | A peptide that has been matched, in quantitation, to a protein hit
ms_ms1quant_match_component | A component within a match
ms_ms1quant_match_range | A range for a component of a peptide match
ms_ms1quant_match_ratio | The status resulting ratio for a peptide found in a match
ms_ms1quant_peptide_status | An individual peptide's quantitation status
ms_ms1quantitation | The result of quantitation calculations applied to peptide summary
ms_ms2quantitation | Peptide and protein quantitation in a Reporter or Multiplex Mascot results file
ms_obofile | The class provides simplified access to ontology files in the .obo format
ms_parseoptions | Represents the PARSE section of mascot.dat
ms_parserule | Represents a single regular expression parsing rule
ms_parserule_plus | Represents regular expression parse rule plus some additional parameters
ms_peptide | This class encapsulates a peptide from the mascot results file
ms_peptide_quant_key | Feature key identifying a peptide ratio
ms_peptide_quant_key_vector | A vector of peptide quant keys
ms_peptide_quant_ratio | Peptide abundance in one component relative to another in a quantitation experiment
ms_peptidesummary | Use this class to get peptide summary results
ms_processoroptions | An instance of this class represents all the parameters specified in the Processors section of mascot.dat
ms_processors | This class is designed to retrieve current CPU configuration on the computer and set affinity
ms_progress_info | Contains information of the current progress of a task being performed
ms_protein | This class encapsulates a protein in the mascot results file
ms_protein_quant_ratio | Protein abundance in one component relative to another in a quantitation experiment, derived from a sample of peptide ratios
ms_proteinsummary |
ms_quant_average | An object of this class represent a single "average" element in quantitation.xml
ms_quant_component | An object of this class represent a single component element in quantitation.xml
ms_quant_composition | Describes the compositionType type in quantitation.xml
ms_quant_configfile | Use this class in order to read/write quantitation.xml
ms_quant_correction | Represents a correction element
ms_quant_element | The element sub-element of compositionType in quantitation.xml
ms_quant_helper | Helper routines for peptide quantitation
ms_quant_integration | An object of this class represent a single integration element in quantitation.xml
ms_quant_isotope | Represents an isotope element
ms_quant_localdef | Represents a local_definition element
ms_quant_method | An object of this class represent a single quantitation method from quantitation.xml
ms_quant_modgroup | An object of this class represent a single modification group element in quantitation.xml
ms_quant_moverz | Parameter name and value pair
ms_quant_multiplex | An object of this class represent a multiplex element in quantitation.xml
ms_quant_neutralloss | A neutral loss for the sequence ions, e.g. loss of phosphate
ms_quant_normalisation | An object of this class represent a single normalisation element in quantitation.xml
ms_quant_normalisation_peptide | An object of this class represent a single peptide element in quantitation.xml
ms_quant_normalisation_peptides | An object of this class represent a collection of peptide elements in quantitation.xml
ms_quant_normalisation_protein | An object of this class represent a single protein element in quantitation.xml
ms_quant_normalisation_proteins | An object of this class represent a collection of peptide elements in quantitation.xml
ms_quant_numerator | Represent numerator_component and denominator_component elements
ms_quant_outliers | An object of this class represent a single OUTLIERS element in quantitation.xml
ms_quant_parameter | Parameter name and value pair
ms_quant_parameters | A class that represents base parametersType in quantitation.xml
ms_quant_pepneutralloss | A neutral loss from the precursor
ms_quant_precursor | An object of this class represent a single precursor element in quantitation.xml
ms_quant_protocol | An object of this class represent a protocol element in quantitation.xml
ms_quant_quality | An object of this class represent a single quality element in quantitation.xml
ms_quant_ratio | Represents the ratioType type for the report_ratio element in quantitation.xml
ms_quant_replicate | An object of this class represent a single replicate element in quantitation.xml
ms_quant_reporter | An object of this class represents a single reporter element in quantitation.xml
ms_quant_satellite | An object of this class represent a single satellite element in quantitation.xml
ms_quant_specificity | Describes a specificity element in quantitation.xml (Unimod style specificity)
ms_quant_stats | Mathematical and statistical routines for peptide and protein quantitation
ms_quant_unmodified | Describes an unmodified element in quantitation.xml
ms_quantitation | Base class for peptide and protein quantitation
ms_searchparams | This class encapsulates the search parameters in the mascot results file
ms_security | The main security class to be used by the administration application
ms_security_options | Options for the Mascot security system
ms_security_task | Each group has permission to do one or more tasks. This class defines an individual task
ms_security_tasks | Each group has permission to do one or more tasks. This class defines a collection of tasks
ms_session | Use this class to determine if a user is logged in and if they have 'permission' to perform tasks
ms_shapiro_wilk | The Shapiro-Wilk W test
ms_spectral_lib_entry | This class is used to encapsulate a single entry, i.e. single spectrum from a NIST .msp file or SpectraST .sptxt file
ms_spectral_lib_file | This class is used to encapsulate a complete NIST .msp, SpectraST .sptxt or X!Hunter ASL MGF file
ms_spectral_lib_peak | This class is used to encapsulate a single fragment ion in a NIST .msp or a SpectraST .sptxt file
ms_spectral_lib_peak_list | This class is used to encapsulate a peak list from a single spectrum in a NIST .msp or a SpectraST .sptxt file
ms_stdout_logger | Concrete class which implements ms_logger and outputs log text to standard out
ms_taxnodesfiles | Filenames and formats for taxonomy nodes or genetic codes files
ms_taxonomychoice | The class represents a single taxonomy choice entry in the taxonomy file
ms_taxonomyfile | Use this class in order to read in a taxonomy file
ms_taxonomyrules | This class represents a single Taxonomy_XXX section in mascot.dat
ms_taxonomytree | The complete taxonomy tree as built from one or more files such as nodes.dmp
ms_taxspeciesfiles | An instance of this class describes one entry of taxonomy species files
ms_tinycdb | Wrapper for the public domain tinycdb package http://www.corpit.ru/mjt/tinycdb.html by Michael Tokarev
ms_treecluster | This class is an interface to the cluster algorithm described at http://bonsai.hgc.jp/~mdehoon/software/cluster/
ms_umod_aminoacid | Represents an "amino acid" object in unimod.xml
ms_umod_composition | Represents the composition type in unimod.xml
ms_umod_configfile | This class represents the file unimod.xml
ms_umod_element | Represents an element object in unimod.xml
ms_umod_elemref | Represents the elemref_t type in unimod.xml
ms_umod_modbrick | Represents a modification brick object in unimod.xml
ms_umod_modification | Represents a modif object in unimod.xml
ms_umod_neutralloss | Represents NeutralLoss and PepNeutralLoss objects in unimod.xml
ms_umod_specificity | Represents modification specificity objects in unimod.xml
ms_umod_xref | Represents the cross references objects in unimod.xml
ms_unigene | This class encapsulates a complete unigene file
ms_unigene_entry | This class encapsulates a single entry from a unigene file
ms_unigeneoptions | An instance of this class represents all the parameters specified in UniGene section of mascot.dat
ms_user | This class will normally only be used by Mascot Security Administration applications
ms_wwwentry | Represent a single entry in the WWW section of mascot.dat
ms_wwwoptions | Represents the whole WWW section
ms_xic | An eXtracted Ion Chromatogram (XIC)
ms_xic_point | A single point from a matrix_science::ms_xic object
ms_xml_parameter | Parameter name and value pair
ms_xml_parameters | A class that represents a base parametersType
ms_zip | Utility class for compressing and decompressing data in compress format, and compressing in gzip format
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Class Index

M
M
ms_distiller_subsearch (matrix_science) ms_matrix (matrix_science) ms_quant_integration (matrix_science) ms_shapiro_wilk (matrix_science)
ms_aahelper (matrix_science) | ms_enzyme (matrix_science) | ms_modfile (matrix_science) | ms_quant_isotope (matrix_science) | ms_spectral_lib_entry (matrix_science)
ms_buffer_logger (matrix_science) | ms_enzymefile (matrix_science) | ms_modification (matrix_science) | ms_quant_localdef (matrix_science) | ms_spectral_lib_file (matrix_science)
ms_clusterparams (matrix_science) | ms_errors (matrix_science) | ms_modvector (matrix_science) | ms_quant_method (matrix_science) | ms_spectral_lib_peak (matrix_science)
ms_computeraddress (matrix_science) | ms_errs (matrix_science) | ms_ms1quant_average_results (matrix_science) | ms_quant_modgroup (matrix_science) | ms_spectral_lib_peak_list (matrix_science)
ms_connection_settings (matrix_science) | ms_file_logger (matrix_science) | ms_ms1quant_charge_state (matrix_science) | ms_quant_moverz (matrix_science) | ms_stdout_logger (matrix_science)
ms_cronjob (matrix_science) | ms_fileutilities (matrix_science) | ms_ms1quant_match (matrix_science) | ms_quant_multiplex (matrix_science) | ms_taxnodesfiles (matrix_science)
ms_cronoptions (matrix_science) | ms_fitexy_result (matrix_science) | ms_ms1quant_match_component (matrix_science) | ms_quant_neutralloss (matrix_science) | ms_taxonomychoice (matrix_science)
ms_crosslinking_accession (matrix_science) | ms_fragment (matrix_science) | ms_ms1quant_match_range (matrix_science) | ms_quant_normalisation (matrix_science) | ms_taxonomyfile (matrix_science)
ms_crosslinking_accessions (matrix_science) | ms_fragmentationrules (matrix_science) | ms_ms1quant_match_ratio (matrix_science) | ms_quant_normalisation_peptide (matrix_science) | ms_taxonomyrules (matrix_science)
ms_crosslinking_configfile (matrix_science) | ms_fragmentvector (matrix_science) | ms_ms1quant_peptide_status (matrix_science) | ms_quant_normalisation_peptides (matrix_science) | ms_taxonomytree (matrix_science)
ms_crosslinking_does_not_pair_with (matrix_science) | ms_fragrulesfile (matrix_science) | ms_ms1quantitation (matrix_science) | ms_quant_normalisation_protein (matrix_science) | ms_taxspeciesfiles (matrix_science)
ms_crosslinking_filters (matrix_science) | ms_group (matrix_science) | ms_ms2quantitation (matrix_science) | ms_quant_normalisation_proteins (matrix_science) | ms_tinycdb (matrix_science)
ms_crosslinking_linker (matrix_science) | ms_http_client (matrix_science) | ms_obofile (matrix_science) | ms_quant_numerator (matrix_science) | ms_treecluster (matrix_science)
ms_crosslinking_linkers (matrix_science) | ms_http_client_mime (matrix_science) | ms_parseoptions (matrix_science) | ms_quant_outliers (matrix_science) | ms_umod_aminoacid (matrix_science)
ms_crosslinking_method (matrix_science) | ms_http_client_search (matrix_science) | ms_parserule (matrix_science) | ms_quant_parameter (matrix_science) | ms_umod_composition (matrix_science)
ms_crosslinking_monolink (matrix_science) | ms_http_client_session (matrix_science) | ms_parserule_plus (matrix_science) | ms_quant_parameters (matrix_science) | ms_umod_configfile (matrix_science)
ms_crosslinking_parameter (matrix_science) | ms_http_helper (matrix_science) | ms_peptide (matrix_science) | ms_quant_pepneutralloss (matrix_science) | ms_umod_element (matrix_science)
ms_crosslinking_parameters (matrix_science) | ms_http_helper_handles (matrix_science) | ms_peptide_quant_key (matrix_science) | ms_quant_precursor (matrix_science) | ms_umod_elemref (matrix_science)
ms_crosslinking_scope (matrix_science) | ms_http_helper_progress (matrix_science) | ms_peptide_quant_key_vector (matrix_science) | ms_quant_protocol (matrix_science) | ms_umod_modbrick (matrix_science)
ms_crosslinking_settings (matrix_science) | ms_http_helper_return (matrix_science) | ms_peptide_quant_ratio (matrix_science) | ms_quant_quality (matrix_science) | ms_umod_modification (matrix_science)
ms_customproperty (matrix_science) | ms_inputquery (matrix_science) | ms_peptidesummary (matrix_science) | ms_quant_ratio (matrix_science) | ms_umod_neutralloss (matrix_science)
ms_customquantitation (matrix_science) | ms_libraryoptions (matrix_science) | ms_processoroptions (matrix_science) | ms_quant_replicate (matrix_science) | ms_umod_specificity (matrix_science)
ms_databaseoptions (matrix_science) | ms_license (matrix_science) | ms_processors (matrix_science) | ms_quant_reporter (matrix_science) | ms_umod_xref (matrix_science)
ms_databases (matrix_science) | ms_linker_site (matrix_science) | ms_progress_info (matrix_science) | ms_quant_satellite (matrix_science) | ms_unigene (matrix_science)
ms_datfile (matrix_science) | ms_linker_site_vector (matrix_science) | ms_protein (matrix_science) | ms_quant_specificity (matrix_science) | ms_unigene_entry (matrix_science)
ms_dbprocessors (matrix_science) | ms_log (matrix_science) | ms_protein_quant_ratio (matrix_science) | ms_quant_stats (matrix_science) | ms_unigeneoptions (matrix_science)
ms_distiller_data (matrix_science) | ms_logger (matrix_science) | ms_proteinsummary (matrix_science) | ms_quant_unmodified (matrix_science) | ms_user (matrix_science)
ms_distiller_data_quant (matrix_science) | ms_loggingmonitor (matrix_science) | ms_quant_average (matrix_science) | ms_quantitation (matrix_science) | ms_wwwentry (matrix_science)
ms_distiller_data_search (matrix_science) | ms_mascotfiles (matrix_science) | ms_quant_component (matrix_science) | ms_searchparams (matrix_science) | ms_wwwoptions (matrix_science)
ms_distiller_master_project (matrix_science) | ms_mascotoptions (matrix_science) | ms_quant_composition (matrix_science) | ms_security (matrix_science) | ms_xic (matrix_science)
ms_distiller_master_search (matrix_science) | ms_mascotresfile (matrix_science) | ms_quant_configfile (matrix_science) | ms_security_options (matrix_science) | ms_xic_point (matrix_science)
ms_distiller_search_status (matrix_science) | ms_mascotresults (matrix_science) | ms_quant_correction (matrix_science) | ms_security_task (matrix_science) | ms_xml_parameter (matrix_science)
ms_distiller_search_status_list (matrix_science) | ms_mascotresults_params (matrix_science) | ms_quant_element (matrix_science) | ms_security_tasks (matrix_science) | ms_xml_parameters (matrix_science)
ms_distiller_sub_project (matrix_science) | ms_masses (matrix_science) | ms_quant_helper (matrix_science) | ms_session (matrix_science) | ms_zip (matrix_science)
M
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_aahelper Member List

This is the complete list of members for ms_aahelper, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
calcFragments(const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcFragments(const ms_peptide *peptide, const int seriesID, const bool doubleCharged, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcFragmentsEx(const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, ms_fragmentvector *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcFragmentsEx(const ms_peptide *peptide, const int seriesID, const int fragCharge, const double minMass, const double maxMass, const MASS_TYPE massType, std::vector< ms_fragment > *fragments, ms_errs *err, const FRAG_NL fragNlType=FRAG_NL_PRIMARY) const | ms_aahelper
calcPeptideMZ(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > numThatMustBeModded, const int charge, const MASS_TYPE massType, ms_errs *err) const | ms_aahelper
clearAllErrors() | ms_errors
copyFrom(const ms_aahelper *right) | ms_aahelper
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
createCrosslinkedPeptide(const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site_vector &linkedSites, ms_errs *err) const | ms_aahelper
createPeptide(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const | ms_aahelper
createPeptide(const char *proteinStr, const int proteinLen, const int startPos, const int endPos, const std::vector< int > varMods, const std::vector< int > varModsWhichNl, const std::vector< int > summedMods, const std::vector< int > summedModsWhichNl, const int charge, const MASS_TYPE massType, ms_errs *err) const | ms_aahelper
defaultValues() | ms_aahelper
FRAG_NL enum name | ms_aahelper
FRAG_NL_PRIMARY enum value | ms_aahelper
FRAG_NL_SECONDARY enum value | ms_aahelper
getEnzyme() const | ms_aahelper
getErrorHandler() const | ms_errors
getFixedMods() const | ms_aahelper
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMasses() const | ms_aahelper
getMissed() const | ms_aahelper
getNextPeptide() | ms_aahelper
getPepEnd() const | ms_aahelper
getPepStart() const | ms_aahelper
getVarMods() const | ms_aahelper
isValid() const | ms_errors
ms_aahelper() | ms_aahelper
ms_aahelper(const ms_mascotresfile &resfile, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd") | ms_aahelper
ms_aahelper(const ms_mascotresults &summary, const char *enzymeFileName, const char *quantSchemaFilePath="http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", const char *unimodSchemaFilePath="http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd") | ms_aahelper
ms_aahelper(const ms_aahelper &right) | ms_aahelper
ms_errors() | ms_errors
operator=(const ms_aahelper &right) | ms_aahelper
setAvailableModifications(const ms_modvector *fixedModVector, const ms_modvector *varModVector) | ms_aahelper
setEnzyme(const ms_enzyme *enzyme) | ms_aahelper
setMasses(const ms_masses *masses) | ms_aahelper
startIteratePeptides(const char *sequenceProtein, const int sizeProtein, const int pfa) | ms_aahelper
stopIteratePeptides() | ms_aahelper
~ms_aahelper() | ms_aahelper
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_buffer_logger Member List

This is the complete list of members for ms_buffer_logger, including all inherited members.
COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
flush() | ms_buffer_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | [virtual]
getHeaderLine() const | ms_logger |
LogOutputColumns_e enum name | ms_logger |
ms_buffer_logger(unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS) | ms_buffer_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) | ms_buffer_logger | [virtual]
setColsToOutput(const unsigned int colsToOutput) | ms_logger | [virtual]
~ms_buffer_logger() | ms_buffer_logger | [virtual]
~ms_logger() | ms_logger | [inline, virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_clusterparams Member List

This is the complete list of members for ms_clusterparams, including all inherited members.
appendSubCluster(const int id, const int maxCPUs) | ms_clusterparams
clearSubClusters() | ms_clusterparams
copyFrom(const ms_clusterparams *right) | ms_clusterparams
defaultValues() | ms_clusterparams
getCheckNodesAliveFreq() const | ms_clusterparams
getDefaultNodeHomeDir() const | ms_clusterparams
getDefaultNodeHomeDirFromMaster() const | ms_clusterparams
getDefaultNodeOS() const | ms_clusterparams
getDefaultPort() const | ms_clusterparams
getIPCLogfile() const | ms_clusterparams
getIPCLogging() const | ms_clusterparams
getIPCTimeout() const | ms_clusterparams
getMascotNodeRebootScript() const | ms_clusterparams
getMascotNodeScript() const | ms_clusterparams
getMasterComputer() const | ms_clusterparams
getNodeSequenceDatabaseDir() const | ms_clusterparams
getNumberOfSubClusters() const | ms_clusterparams
getPreceedingComments() const | ms_customproperty
getSecsToWaitForNodeAtStartup() const | ms_clusterparams
getSubClusterID(const int index) const | ms_clusterparams
getSubClusterMaxCPU(const int index) const | ms_clusterparams
isEnabled() const | ms_clusterparams
isSectionAvailable() const | ms_clusterparams
ms_clusterparams() | ms_clusterparams
ms_clusterparams(const ms_clusterparams &src) | ms_clusterparams
ms_customproperty() | ms_customproperty
NUM_PROCESSORS_AUTO_DETECT enum value | ms_clusterparams
operator=(const ms_clusterparams &right) | ms_clusterparams
setCheckNodesAliveFreq(const int value) | ms_clusterparams
setDefaultNodeHomeDir(const char *str) | ms_clusterparams
setDefaultNodeHomeDirFromMaster(const char *str) | ms_clusterparams
setDefaultNodeOS(const OPERATING_SYS value) | ms_clusterparams
setDefaultPort(const int value) | ms_clusterparams
setEnabled(const bool flag) | ms_clusterparams
setIPCLogfile(const char *str) | ms_clusterparams
setIPCLogging(const int value) | ms_clusterparams
setIPCTimeout(const int value) | ms_clusterparams
setMascotNodeRebootScript(const char *str) | ms_clusterparams
setMascotNodeScript(const char *str) | ms_clusterparams
setMasterComputer(const ms_computeraddress *value) | ms_clusterparams
setNodeSequenceDatabaseDir(const char *str) | ms_clusterparams
setPreceedingComments(const std::string &comments) | ms_customproperty
setSecsToWaitForNodeAtStartup(const int value) | ms_clusterparams
setSectionAvailable(const bool value) | ms_clusterparams
~ms_clusterparams() | ms_clusterparams
~ms_customproperty() | ms_customproperty
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_computeraddress Member List

This is the complete list of members for ms_computeraddress, including all inherited members.
copyFrom(const ms_computeraddress *right) | ms_computeraddress
defaultValues() | ms_computeraddress
getHostName() const | ms_computeraddress
getInetAddress() const | ms_computeraddress
getPort() const | ms_computeraddress
ms_computeraddress() | ms_computeraddress
ms_computeraddress(const ms_computeraddress &src) | ms_computeraddress
operator=(const ms_computeraddress &right) | ms_computeraddress
setHostName(const char *name) | ms_computeraddress
setInetAddress(const char *address) | ms_computeraddress
setPort(const unsigned int value) | ms_computeraddress
~ms_computeraddress() | ms_computeraddress
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_connection_settings Member List

This is the complete list of members for ms_connection_settings, including all inherited members.
copyFrom(const ms_connection_settings *right) | ms_connection_settings |
defaultValues() | ms_connection_settings |
getConnectionTimeout() const | ms_connection_settings |
getHttpPassword() const | ms_connection_settings |
getHttpProtocol() const | ms_connection_settings |
getHttpUsername() const | ms_connection_settings |
getProxyPassword() const | ms_connection_settings |
getProxyServer() const | ms_connection_settings |
getProxyServerType() const | ms_connection_settings |
getProxyUserAndPassword() const | ms_connection_settings |
getProxyUsername() const | ms_connection_settings |
getRedirectPolicy() const | ms_connection_settings |
getSessionID() const | ms_connection_settings |
getUserAgent() const | ms_connection_settings |
HTTP_1_0 enum value | ms_connection_settings |
HTTP_1_1 enum value | ms_connection_settings |
HTTP_PROTOCOL enum name | ms_connection_settings |
HTTP_SYSTEM_DEFAULT enum value | ms_connection_settings |
isUseHTTPProxyForFTP() const | ms_connection_settings |
isUseHTTPProxyForHTTPS() const | ms_connection_settings |
ms_connection_settings() | ms_connection_settings |
ms_connection_settings(const std::string sessionID, const std::string proxyServer, const std::string proxyUserName, const std::string proxyUserPassword) | ms_connection_settings |
operator=(const ms_connection_settings &right) | ms_connection_settings |
PROXY_TYPE enum name | ms_connection_settings |
PROXY_TYPE_AUTO enum value | ms_connection_settings |
PROXY_TYPE_ENVIRONMENT enum value | ms_connection_settings |
PROXY_TYPE_FROM_REGISTRY enum value | ms_connection_settings |
PROXY_TYPE_NO_PROXY enum value | ms_connection_settings |
PROXY_TYPE_SPECIFY enum value | ms_connection_settings |
PROXY_TYPE_WPAD enum value | ms_connection_settings |
proxyTypeStringToEnum(std::string str) | ms_connection_settings | [static]
proxyTypeToString(int type) | ms_connection_settings | [static]
REDIRECT_POLICY enum name | ms_connection_settings |
REDIRECT_POLICY_ALWAYS enum value | ms_connection_settings |
REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP enum value | ms_connection_settings |
REDIRECT_POLICY_NEVER enum value | ms_connection_settings |
setConnectionTimeout(int timeout) | ms_connection_settings |
setHttpPassword(const std::string httpPassword) | ms_connection_settings |
setHttpProtocol(ms_connection_settings::HTTP_PROTOCOL httpProtocol) | ms_connection_settings |
setHttpUsername(const std::string httpUsername) | ms_connection_settings |
setProxyPassword(const std::string proxyUserPassword) | ms_connection_settings |
setProxyServer(const std::string proxyServer) | ms_connection_settings |
setProxyServerType(ms_connection_settings::PROXY_TYPE proxyType) | ms_connection_settings |
setProxyUsername(const std::string proxyUserName) | ms_connection_settings |
setRedirectPolicy(ms_connection_settings::REDIRECT_POLICY redirectPolicy) | ms_connection_settings |
setSessionID(const std::string sessionID) | ms_connection_settings |
setUseHTTPProxyForFTP(bool value) | ms_connection_settings |
setUseHTTPProxyForHTTPS(bool value) | ms_connection_settings |
setUserAgent(const std::string userAgent) | ms_connection_settings |
~ms_connection_settings() | ms_connection_settings |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_cronjob Member List

This is the complete list of members for ms_cronjob, including all inherited members.
copyFrom(const ms_cronjob *right) | ms_cronjob
defaultValues() | ms_cronjob
getCommandStr() const | ms_cronjob
isDayOfMonth(const int day) const | ms_cronjob
isDayOfWeek(const int day) const | ms_cronjob
isEnabled() const | ms_cronjob
isHour(const int hour) const | ms_cronjob
isMinute(const int min) const | ms_cronjob
isMonthOfYear(const int month) const | ms_cronjob
ms_cronjob() | ms_cronjob
ms_cronjob(const ms_cronjob &src) | ms_cronjob
operator=(const ms_cronjob &right) | ms_cronjob
setCommandStr(const char *str) | ms_cronjob
setDayOfMonth(const int day, const bool value) | ms_cronjob
setDayOfWeek(const int day, const bool value) | ms_cronjob
setEnabled(const bool enabled) | ms_cronjob
setHour(const int hour, const bool value) | ms_cronjob
setMinute(const int min, const bool value) | ms_cronjob
setMonthOfYear(const int month, const bool value) | ms_cronjob
~ms_cronjob() | ms_cronjob
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_cronoptions Member List

This is the complete list of members for ms_cronoptions, including all inherited members.
appendCronJob(const ms_cronjob *job) | ms_cronoptions
clearCronJobs() | ms_cronoptions
copyFrom(const ms_cronoptions *right) | ms_cronoptions
defaultValues() | ms_cronoptions
deleteCronJob(const int idx) | ms_cronoptions
getCronJob(const int idx) const | ms_cronoptions
getLogFileName() const | ms_cronoptions
getLoggingLevel() const | ms_cronoptions
getNumberOfCronJobs() const | ms_cronoptions
getPreceedingComments() const | ms_customproperty
isCronEnabled() const | ms_cronoptions
isSectionAvailable() const | ms_cronoptions
ms_cronoptions() | ms_cronoptions
ms_cronoptions(const ms_cronoptions &src) | ms_cronoptions
ms_customproperty() | ms_customproperty
operator=(const ms_cronoptions &right) | ms_cronoptions
setCronEnabled(const bool value) | ms_cronoptions
setCronJob(const int idx, const ms_cronjob job) | ms_cronoptions
setLogFileName(const std::string &fileName) | ms_cronoptions
setLoggingLevel(const int level) | ms_cronoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setSectionAvailable(const bool value) | ms_cronoptions
~ms_cronoptions() | ms_cronoptions
~ms_customproperty() | ms_customproperty
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_accession Member List

This is the complete list of members for ms_crosslinking_accession, including all inherited members.
copyFrom(const ms_crosslinking_accession *right) | ms_crosslinking_accession |
defaultValues() | ms_crosslinking_accession |
dropDatabaseName() | ms_crosslinking_accession |
dropValue() | ms_crosslinking_accession |
getDatabaseName() const | ms_crosslinking_accession |
getDatabaseNameSchemaType() const | ms_crosslinking_accession |
getSchemaType() const | ms_crosslinking_accession | [virtual]
getValue() const | ms_crosslinking_accession |
getValueSchemaType() const | ms_crosslinking_accession |
haveDatabaseName() const | ms_crosslinking_accession |
haveValue() const | ms_crosslinking_accession |
ms_crosslinking_accession() | ms_crosslinking_accession |
ms_crosslinking_accession(const ms_crosslinking_accession &src) | ms_crosslinking_accession |
operator=(const ms_crosslinking_accession &right) | ms_crosslinking_accession |
setDatabaseName(const char *value) | ms_crosslinking_accession |
setValue(const char *value) | ms_crosslinking_accession |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accession | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accession | [virtual]
~ms_crosslinking_accession() | ms_crosslinking_accession | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_accessions Member List

This is the complete list of members for ms_crosslinking_accessions, including all inherited members.
appendAccession(const ms_crosslinking_accession *item) | ms_crosslinking_accessions |
clearAccessions() | ms_crosslinking_accessions |
copyFrom(const ms_crosslinking_accessions *right) | ms_crosslinking_accessions |
defaultValues() | ms_crosslinking_accessions |
deleteAccessionByNumber(const int idx) | ms_crosslinking_accessions |
getAccessionByNumber(const int idx) const | ms_crosslinking_accessions |
getAccessionSchemaType() const | ms_crosslinking_accessions |
getNumberOfAccessions() const | ms_crosslinking_accessions |
getSchemaType() const | ms_crosslinking_accessions | [virtual]
ms_crosslinking_accessions() | ms_crosslinking_accessions |
ms_crosslinking_accessions(const ms_crosslinking_accessions &src) | ms_crosslinking_accessions |
operator=(const ms_crosslinking_accessions &right) | ms_crosslinking_accessions |
updateAccessionByNumber(const int idx, const ms_crosslinking_accession *accession) | ms_crosslinking_accessions |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accessions | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_accessions | [virtual]
~ms_crosslinking_accessions() | ms_crosslinking_accessions | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_configfile Member List

This is the complete list of members for ms_crosslinking_configfile, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
appendMethod(const ms_crosslinking_method *elem) | ms_crosslinking_configfile |
clearAllErrors() | ms_errors |
clearMethods() | ms_crosslinking_configfile |
copyFrom(const ms_crosslinking_configfile *right) | ms_crosslinking_configfile |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
defaultValues() | ms_crosslinking_configfile | [virtual]
deleteMethodByName(const char *name) | ms_crosslinking_configfile |
deleteMethodByNumber(const int idx) | ms_crosslinking_configfile |
getConnectionSettings() const | ms_crosslinking_configfile |
getDefaultSchemaFileName() | ms_crosslinking_configfile | [static]
getErrorHandler() const | ms_errors |
getFileName() const | ms_crosslinking_configfile |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMajorVersion() const | ms_crosslinking_configfile |
getMethodByName(const char *name) const | ms_crosslinking_configfile |
getMethodByNumber(const int idx) const | ms_crosslinking_configfile |
getMinorVersion() const | ms_crosslinking_configfile |
getNumberOfMethods() const | ms_crosslinking_configfile |
getSchemaFileName() const | ms_crosslinking_configfile |
isValid() const | ms_errors |
ms_crosslinking_configfile() | ms_crosslinking_configfile |
ms_crosslinking_configfile(const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true) | ms_crosslinking_configfile |
ms_crosslinking_configfile(const ms_crosslinking_configfile &right) | ms_crosslinking_configfile |
ms_errors() | ms_errors |
operator=(const ms_crosslinking_configfile &right) | ms_crosslinking_configfile |
read_buffer(const char *buffer) | ms_crosslinking_configfile |
read_file() | ms_crosslinking_configfile |
save_buffer(bool validateAgainstSchema=true) | ms_crosslinking_configfile |
save_file() | ms_crosslinking_configfile |
setConnectionSettings(const ms_connection_settings &cs) | ms_crosslinking_configfile |
setFileName(const char *filename) | ms_crosslinking_configfile |
setSchemaFileName(const char *name) | ms_crosslinking_configfile |
updateMethodByName(const char *name, const ms_crosslinking_method *method) | ms_crosslinking_configfile |
updateMethodByNumber(const int idx, const ms_crosslinking_method *method) | ms_crosslinking_configfile |
validateDocument() const | ms_crosslinking_configfile |
~ms_crosslinking_configfile() | ms_crosslinking_configfile | [virtual]
~ms_errors() | ms_errors |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_does_not_pair_with Member List

This is the complete list of members for ms_crosslinking_does_not_pair_with, including all inherited members.
copyFrom(const ms_crosslinking_does_not_pair_with *right) | ms_crosslinking_does_not_pair_with |
defaultValues() | ms_crosslinking_does_not_pair_with |
dropModFileName() | ms_crosslinking_does_not_pair_with |
getModFileName() const | ms_crosslinking_does_not_pair_with |
getModFileNameSchemaType() const | ms_crosslinking_does_not_pair_with |
getSchemaType() const | ms_crosslinking_does_not_pair_with | [virtual]
haveModFileName() const | ms_crosslinking_does_not_pair_with |
ms_crosslinking_does_not_pair_with() | ms_crosslinking_does_not_pair_with |
ms_crosslinking_does_not_pair_with(const ms_crosslinking_does_not_pair_with &src) | ms_crosslinking_does_not_pair_with |
operator=(const ms_crosslinking_does_not_pair_with &right) | ms_crosslinking_does_not_pair_with |
setModFileName(const char *value) | ms_crosslinking_does_not_pair_with |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_does_not_pair_with | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_does_not_pair_with | [virtual]
~ms_crosslinking_does_not_pair_with() | ms_crosslinking_does_not_pair_with | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_filters Member List

This is the complete list of members for ms_crosslinking_filters, including all inherited members.
appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | [virtual]
copyFrom(const ms_crosslinking_filters *right) | ms_crosslinking_filters |
matrix_science::ms_crosslinking_parameters::copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_filters |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | [virtual]
getNumberOfParameters() const | ms_crosslinking_parameters | [virtual]
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_filters | [virtual]
getSchemaType() const | ms_crosslinking_filters | [virtual]
ms_crosslinking_filters() | ms_crosslinking_filters |
ms_crosslinking_filters(const ms_crosslinking_filters &src) | ms_crosslinking_filters |
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_filters &right) | ms_crosslinking_filters |
matrix_science::ms_crosslinking_parameters::operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_filters() | ms_crosslinking_filters | [virtual]
~ms_crosslinking_parameters() | ms_crosslinking_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_linker Member List

This is the complete list of members for ms_crosslinking_linker, including all inherited members.
appendDoesNotPairWith(const ms_crosslinking_does_not_pair_with *item) | ms_crosslinking_linker |
appendMonoLink(const ms_crosslinking_monolink *item) | ms_crosslinking_linker |
clearDoesNotPairWiths() | ms_crosslinking_linker |
clearMonoLinks() | ms_crosslinking_linker |
copyFrom(const ms_crosslinking_linker *right) | ms_crosslinking_linker |
defaultValues() | ms_crosslinking_linker |
deleteDoesNotPairWithByNumber(const int idx) | ms_crosslinking_linker |
deleteMonoLinkByNumber(const int idx) | ms_crosslinking_linker |
dropModFileName() | ms_crosslinking_linker |
getDoesNotPairWithByNumber(const int idx) const | ms_crosslinking_linker |
getDoesNotPairWithSchemaType() const | ms_crosslinking_linker |
getModFileName() const | ms_crosslinking_linker |
getModFileNameSchemaType() const | ms_crosslinking_linker |
getMonoLinkByNumber(const int idx) const | ms_crosslinking_linker |
getMonoLinkSchemaType() const | ms_crosslinking_linker |
getNumberOfDoesNotPairWiths() const | ms_crosslinking_linker |
getNumberOfMonoLinks() const | ms_crosslinking_linker |
getSchemaType() const | ms_crosslinking_linker | [virtual]
haveModFileName() const | ms_crosslinking_linker |
ms_crosslinking_linker() | ms_crosslinking_linker |
ms_crosslinking_linker(const ms_crosslinking_linker &src) | ms_crosslinking_linker |
operator=(const ms_crosslinking_linker &right) | ms_crosslinking_linker |
setModFileName(const char *value) | ms_crosslinking_linker |
updateDoesNotPairWithByNumber(const int idx, const ms_crosslinking_does_not_pair_with *does_not_pair_with) | ms_crosslinking_linker |
updateMonoLinkByNumber(const int idx, const ms_crosslinking_monolink *monolink) | ms_crosslinking_linker |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linker | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linker | [virtual]
~ms_crosslinking_linker() | ms_crosslinking_linker | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_linkers Member List

This is the complete list of members for ms_crosslinking_linkers, including all inherited members.
appendLinker(const ms_crosslinking_linker *item) | ms_crosslinking_linkers |
clearLinkers() | ms_crosslinking_linkers |
copyFrom(const ms_crosslinking_linkers *right) | ms_crosslinking_linkers |
defaultValues() | ms_crosslinking_linkers |
deleteLinkerByNumber(const int idx) | ms_crosslinking_linkers |
getLinkerByNumber(const int idx) const | ms_crosslinking_linkers |
getLinkerSchemaType() const | ms_crosslinking_linkers |
getNumberOfLinkers() const | ms_crosslinking_linkers |
getSchemaType() const | ms_crosslinking_linkers | [virtual]
ms_crosslinking_linkers() | ms_crosslinking_linkers |
ms_crosslinking_linkers(const ms_crosslinking_linkers &src) | ms_crosslinking_linkers |
operator=(const ms_crosslinking_linkers &right) | ms_crosslinking_linkers |
updateLinkerByNumber(const int idx, const ms_crosslinking_linker *linker) | ms_crosslinking_linkers |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linkers | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_linkers | [virtual]
~ms_crosslinking_linkers() | ms_crosslinking_linkers | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_method Member List

This is the complete list of members for ms_crosslinking_method, including all inherited members.
copyFrom(const ms_crosslinking_method *right) | ms_crosslinking_method |
defaultValues() | ms_crosslinking_method |
dropAccessions() | ms_crosslinking_method |
dropDescription() | ms_crosslinking_method |
dropFilters() | ms_crosslinking_method |
dropLinkers() | ms_crosslinking_method |
dropName() | ms_crosslinking_method |
dropScope() | ms_crosslinking_method |
dropSettings() | ms_crosslinking_method |
dropStrategy() | ms_crosslinking_method |
getAccessions() const | ms_crosslinking_method |
getAccessionsSchemaType() const | ms_crosslinking_method |
getDescription() const | ms_crosslinking_method |
getDescriptionSchemaType() const | ms_crosslinking_method |
getFilters() const | ms_crosslinking_method |
getFiltersSchemaType() const | ms_crosslinking_method |
getLinkers() const | ms_crosslinking_method |
getLinkersSchemaType() const | ms_crosslinking_method |
getName() const | ms_crosslinking_method |
getNameSchemaType() const | ms_crosslinking_method |
getSchemaType() const | ms_crosslinking_method | [virtual]
getScope() const | ms_crosslinking_method |
getScopeSchemaType() const | ms_crosslinking_method |
getSettings() const | ms_crosslinking_method |
getSettingsSchemaType() const | ms_crosslinking_method |
getStrategy() const | ms_crosslinking_method |
getStrategySchemaType() const | ms_crosslinking_method |
haveAccessions() const | ms_crosslinking_method |
haveDescription() const | ms_crosslinking_method |
haveFilters() const | ms_crosslinking_method |
haveLinkers() const | ms_crosslinking_method |
haveName() const | ms_crosslinking_method |
haveScope() const | ms_crosslinking_method |
haveSettings() const | ms_crosslinking_method |
haveStrategy() const | ms_crosslinking_method |
ms_crosslinking_method() | ms_crosslinking_method |
ms_crosslinking_method(const ms_crosslinking_method &src) | ms_crosslinking_method |
operator=(const ms_crosslinking_method &right) | ms_crosslinking_method |
setAccessions(const ms_crosslinking_accessions *accessions) | ms_crosslinking_method |
setDescription(const char *value) | ms_crosslinking_method |
setFilters(const ms_crosslinking_filters *filters) | ms_crosslinking_method |
setLinkers(const ms_crosslinking_linkers *linkers) | ms_crosslinking_method |
setName(const char *value) | ms_crosslinking_method |
setScope(const ms_crosslinking_scope *scope) | ms_crosslinking_method |
setSettings(const ms_crosslinking_settings *settings) | ms_crosslinking_method |
setStrategy(const char *value) | ms_crosslinking_method |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_method | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_method | [virtual]
~ms_crosslinking_method() | ms_crosslinking_method | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_monolink Member List

This is the complete list of members for ms_crosslinking_monolink, including all inherited members.
copyFrom(const ms_crosslinking_monolink *right) | ms_crosslinking_monolink |
defaultValues() | ms_crosslinking_monolink |
getSchemaType() const | ms_crosslinking_monolink | [virtual]
getValue() const | ms_crosslinking_monolink |
getValueSchemaType() const | ms_crosslinking_monolink |
ms_crosslinking_monolink() | ms_crosslinking_monolink |
ms_crosslinking_monolink(const ms_crosslinking_monolink &src) | ms_crosslinking_monolink |
operator=(const ms_crosslinking_monolink &right) | ms_crosslinking_monolink |
setValue(const char *value) | ms_crosslinking_monolink |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_monolink | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_crosslinking_monolink | [virtual]
~ms_crosslinking_monolink() | ms_crosslinking_monolink | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_parameter Member List

This is the complete list of members for ms_crosslinking_parameter, including all inherited members.
copyFrom(const ms_crosslinking_parameter *right) | ms_crosslinking_parameter |
matrix_science::ms_xml_parameter::copyFrom(const ms_xml_parameter *right) | ms_xml_parameter |
defaultValues() | ms_crosslinking_parameter |
dropDescription() | ms_xml_parameter |
dropName() | ms_xml_parameter |
getDescription() const | ms_xml_parameter |
getDescriptionSchemaType() const | ms_crosslinking_parameter | [virtual]
getName() const | ms_xml_parameter |
getNameSchemaType() const | ms_crosslinking_parameter | [virtual]
getSchemaType() const | ms_crosslinking_parameter | [virtual]
getValue() const | ms_xml_parameter |
getValueSchemaType() const | ms_crosslinking_parameter | [virtual]
haveDescription() const | ms_xml_parameter |
haveName() const | ms_xml_parameter |
ms_crosslinking_parameter() | ms_crosslinking_parameter |
ms_crosslinking_parameter(const ms_crosslinking_parameter &src) | ms_crosslinking_parameter |
ms_xml_parameter() | ms_xml_parameter |
ms_xml_parameter(const ms_xml_parameter &src) | ms_xml_parameter |
operator=(const ms_crosslinking_parameter &right) | ms_crosslinking_parameter |
matrix_science::ms_xml_parameter::operator=(const ms_xml_parameter &right) | ms_xml_parameter |
setDescription(const char *value) | ms_xml_parameter |
setName(const char *value) | ms_xml_parameter |
setValue(const char *value) | ms_xml_parameter |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
~ms_crosslinking_parameter() | ms_crosslinking_parameter | [virtual]
~ms_xml_parameter() | ms_xml_parameter | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_parameters Member List

This is the complete list of members for ms_crosslinking_parameters, including all inherited members.
appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | [virtual]
copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_parameters |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | [virtual]
getNumberOfParameters() const | ms_crosslinking_parameters | [virtual]
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_parameters | [virtual]
getSchemaType() const | ms_crosslinking_parameters | [virtual]
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_parameters() | ms_crosslinking_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_scope Member List

This is the complete list of members for ms_crosslinking_scope, including all inherited members.
appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | [virtual]
copyFrom(const ms_crosslinking_scope *right) | ms_crosslinking_scope |
matrix_science::ms_crosslinking_parameters::copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_scope |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | [virtual]
getNumberOfParameters() const | ms_crosslinking_parameters | [virtual]
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_scope | [virtual]
getSchemaType() const | ms_crosslinking_scope | [virtual]
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_crosslinking_scope() | ms_crosslinking_scope |
ms_crosslinking_scope(const ms_crosslinking_scope &src) | ms_crosslinking_scope |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_scope &right) | ms_crosslinking_scope |
matrix_science::ms_crosslinking_parameters::operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_parameters() | ms_crosslinking_parameters | [virtual]
~ms_crosslinking_scope() | ms_crosslinking_scope | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_crosslinking_settings Member List

This is the complete list of members for ms_crosslinking_settings, including all inherited members.
appendParameter(const ms_crosslinking_parameter *item) | ms_crosslinking_parameters |
clearParameters() | ms_crosslinking_parameters | [virtual]
copyFrom(const ms_crosslinking_settings *right) | ms_crosslinking_settings |
matrix_science::ms_crosslinking_parameters::copyFrom(const ms_crosslinking_parameters *right) | ms_crosslinking_parameters |
defaultValues() | ms_crosslinking_settings |
deleteParameterByName(const char *name) | ms_crosslinking_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_crosslinking_parameters | [virtual]
getNumberOfParameters() const | ms_crosslinking_parameters | [virtual]
getParameterByName(const char *name) const | ms_crosslinking_parameters |
getParameterByNumber(const int idx) const | ms_crosslinking_parameters |
getParameterSchemaType() const | ms_crosslinking_settings | [virtual]
getSchemaType() const | ms_crosslinking_settings | [virtual]
ms_crosslinking_parameters() | ms_crosslinking_parameters |
ms_crosslinking_parameters(const ms_crosslinking_parameters &src) | ms_crosslinking_parameters |
ms_crosslinking_settings() | ms_crosslinking_settings |
ms_crosslinking_settings(const ms_crosslinking_settings &src) | ms_crosslinking_settings |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_crosslinking_settings &right) | ms_crosslinking_settings |
matrix_science::ms_crosslinking_parameters::operator=(const ms_crosslinking_parameters &right) | ms_crosslinking_parameters |
updateParameterByName(const char *name, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param) | ms_crosslinking_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_crosslinking_parameters() | ms_crosslinking_parameters | [virtual]
~ms_crosslinking_settings() | ms_crosslinking_settings | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • matrix_science
  • ms_customproperty
Public Member Functions

ms_customproperty Class Reference

The class is used as a base for property-containing classes, such as ms_mascotoptions. More...

#include <ms_customproperty.hpp>

Inheritance diagram for ms_customproperty:
[legend]

List of all members.

Public Member Functions

ms_customproperty ()
Default constructor.
~ms_customproperty ()
Destructor.
void | appendProperty (const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false)
Adds a new property with the given parameters.
void | appendText (const char *line, const bool bFirstPlace=false)
Adds a new non-parsed property.
void | copyFrom (const ms_customproperty *src)
Copies all properties and comments from another instance.
void | defaultValues ()
Removes all property entries and comments.
void | delNonEmpty ()
Deletes all non-comment properties.
void | delProp (const char *name)
Deletes all properties with the specified name.
void | delPropByNumber (const int index)
Deletes a single property with the specified number only.
void | delPropStart (const char *nameBeginning)
Deletes all properties whose names start with the given string.
int | findProperty (const char *name, const int startFrom=0) const
Searches the list for a property with the given name.
int | findPropertyBeginning (const char *nameBeginning, const int startFrom=0) const
Searches the list for a property with the partially matching name.
std::string | getDefaultDelimiter () const
Return current default delimiter string used for parsing/storing properties.
std::string | getDelimiterByNumber (const int index) const
Returns a specific delimiter used for the property.
int | getNumberOfProperties () const
Returns a total number of property/comment entries.
std::string | getPreceedingComments () const
Returns any comments preceeding the section.
std::string | getPropertyName (const int index) const
Returns a property name for a given index.
std::string | getPropValStringByName (const char *name) const
Retrieves property value by name.
std::string | getPropValStringByNumber (const int index) const
Retrieves property raw text values by number.
void | setDefaultDelimiter (const char *delim)
Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.
void | setPreceedingComments (const std::string &comments)
Sets any comments preceeding the section.
void | setPropertyName (const int index, const char *name)
Changes name of the property with the given index.
void | setPropValBoolByName (const char *name, const bool value, const bool bFirstPlace=false)
Changes a boolean value of the first entry with the given name or creates a new property if it is not found.
void | setPropValCharByName (const char *name, const char value, const bool bFirstPlace=false)
Changes a single character value of the first entry with the given name or creates a new property if it is not found.
void | setPropValFloatByName (const char *name, const double value, const bool bFirstPlace=false)
Changes an floating point value of the first entry with the given name or creates a new property if it is not found.
void | setPropValInt64ByName (const char *name, const INT64 value, const bool bFirstPlace=false)
Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValIntByName (const char *name, const int value, const bool bFirstPlace=false)
Changes an integer value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByName (const char *name, const char *value, const bool bFirstPlace=false)
Changes a string value of the first entry with the given name or creates a new property if it is not found.
void | setPropValStringByNumber (const int index, const char *value)
Changes an string value of an existing property with the given index.
bool | uncommentProp (const int index, const char *delimeter=0)
Uncomments a line in the configuration file.

Detailed Description

The class is used as a base for property-containing classes, such as ms_mascotoptions.

This class functionality is designed to allow users store and retrieve specified and unspecified (custom) properties as well as comments.

Not every configuration file can hold custom properties and/or comments. Whether a configuration file can have custom properties or not depends on its format. For example, almost all sections of the main configuration file mascot.dat can have unspecified properties and comments, whereas Databases section of the same file cannot have either of them. Another example of non-supported custom properties is unimod.xml whose structure and syntax is defined in a corresponding xml-schema file and cannot be altered temporarily.

Normally, custom properties are used in the following cases:

  • future releases of software can introduce additional properties that can still be retrieved using old msparser-library;
  • when a client application needs to know exactly whether a certain property is explicitly specified in the configuration file or set to it's default value;
  • additional comments can be added/accessed programmatically and then stored in the disc file;
  • client application needs a raw text representation of a property instead of a set of parsed values.

Note that functionality related to comments is not particularly advanced. Comments are all treated uniformly like properties with empty names and can be retrieved only by number. New comments can be added only at the end of existing properties list using either appendText("# comment line preceded by a hash-character") or appendProperty("", "# comment line", ""). They can also be dropped/altered by number.

All properties in configuration files have three elements associated with them:

  • Name - an empty case-insensitive string in case of comments.
  • Value - raw text representation (comment line will normally start with # character).
  • Delimiter - a string between name and value in the configuration file. It can be a space character, comma, colon, tab or a combination of them. Delimiting characters are usually stripped out of property name and value and stored separately. When adding a new property without explicitly specified delimiter string a default one will be used.

Not necessarily all these elements are used and stored in a file -- consult the documentation of the particular configuration file format. An instance of the class rather serves as a container of properties only. It doesn't have any file reading/writing functionality.

Member Function Documentation

void appendProperty | ( | const char * | name,
 |  | const char * | value,
 |  | const char * | delimiter,
 |  | const bool | bFirstPlace = false
 | ) |  |

Adds a new property with the given parameters.

Parameters:
name | a property name to use.
value | a property value to use.
delimiter | a specific delimiter or an empty string for a default one to be used.
bFirstPlace | forces a new property to be put on top of the list.
void appendText | ( | const char * | l,
 |  | const bool | bFirstPlace = false
 | ) |  |

Adds a new non-parsed property.

All property elements will be retrieved from the first parameter. Before calling this method, a specific default delimiter can be set using setDefaultDelimiter().

Parameters:
l | raw text representation of the property to be parsed.
bFirstPlace | forces a new property to be put on top of the list.
void delProp ( const char * str )

Deletes all properties with the specified name.

Parameters:
str Property name to find a match and then delete.
void delPropStart ( const char * str )

Deletes all properties whose names start with the given string.

Parameters:
str Beginning a first part of the property name to delete.
int findProperty | ( | const char * | name,
 |  | const int | startFrom = 0
 | ) |  | const

Searches the list for a property with the given name.

If no property found with the given name -1 will be returned. There may be several property entries in the list with the same name.

Parameters:
name | a property name to be found.
startFrom | a minimal property index to start search from.
Returns:
a property index or -1 if no property found.
int findPropertyBeginning | ( | const char * | nameBeginning,
 |  | const int | startFrom = 0
 | ) |  | const

Searches the list for a property with the partially matching name.

If no property found with the given name part -1 will be returned. There may be several property entries in the list whose names start with the given string.

Parameters:
nameBeginning | first part of a property name to be found.
startFrom | a minimal property index to start search from.
Returns:
a property index or -1 if no property found.
std::string getDefaultDelimiter ( ) const

Return current default delimiter string used for parsing/storing properties.

Returns:
default delimiter
std::string getDelimiterByNumber ( const int index ) const

Returns a specific delimiter used for the property.

Parameters:
index Index for which to get a delimiter
Returns:
corresponding delimiter
int getNumberOfProperties ( ) const

Returns a total number of property/comment entries.

Returns:
Number of property/comment entries
std::string getPreceedingComments ( ) const

Returns any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
setPreceedingComments()
Returns:
any comments preceeding the section
std::string getPropertyName ( const int index ) const

Returns a property name for a given index.

Parameters:
index property number from 0 to (getNumberOfProperties()-1).
Returns:
Rroperty name of an empty string for comments.
std::string getPropValStringByName ( const char * name ) const

Retrieves property value by name.

Don't use this method for comments as they all have empty name. Also note that there might be several entries corresponding to the same name . -- only the first value will be returned. If in doubt use findProperty() and getPropValStringByNumber() instead.

Parameters:
name Name for which to get a property value
Returns:
corresponding property value
std::string getPropValStringByNumber ( const int index ) const

Retrieves property raw text values by number.

Parameters:
index Index for which to get a property value
Returns:
corresponding property value
void setDefaultDelimiter ( const char * delim )

Allows to set a specific delimiter string to be used when no property-specific delimiter is supplied.

Parameters:
delim String to set the default delimiter
void setPreceedingComments ( const std::string & comments )

Sets any comments preceeding the section.

Sections in the mascot.dat file may have comments preceeding them. In most cases, these comments need to stay 'attached' to the section.

Multiple line comments are supported by having a single string with newline characters

See also:
getPreceedingComments()
Parameters:
comments any comments preceeding the section
void setPropertyName | ( | const int | index,
 |  | const char * | name
 | ) |  |

Changes name of the property with the given index.

Parameters:
index | property number from 0 to (getNumberOfProperties()-1).
name | new name to be given to the property.
void setPropValBoolByName | ( | const char * | name,
 |  | const bool | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a boolean value of the first entry with the given name or creates a new property if it is not found.

A new value will be converted into 1 (for TRUE) or 0 (for FALSE) character.

Parameters:
name | a name of the property to find or add.
value | a new boolean value for the property.
bFirstPlace | if not found a new property can be put on top of the list.
void setPropValCharByName | ( | const char * | name,
 |  | const char | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a single character value of the first entry with the given name or creates a new property if it is not found.

Parameters:
name | a name of the property to find or add.
value | a new single character value for the property.
bFirstPlace | if not found a new property can be put on top of the list.
void setPropValFloatByName | ( | const char * | name,
 |  | const double | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes an floating point value of the first entry with the given name or creates a new property if it is not found.

Parameters:
name | a name of the property to find or add.
value | a new floating point value for the property.
bFirstPlace | if not found a new property can be put on top of the list.
void setPropValInt64ByName | ( | const char * | name,
 |  | const INT64 | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a long 64-bit integer value of the first entry with the given name or creates a new property if it is not found.

Parameters:
name | a name of the property to find or add.
value | a new long 64-bit integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.
void setPropValIntByName | ( | const char * | name,
 |  | const int | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes an integer value of the first entry with the given name or creates a new property if it is not found.

Parameters:
name | a name of the property to find or add.
value | a new integer value for the property.
bFirstPlace | if not found a new property can be put on top of the list.
void setPropValStringByName | ( | const char * | name,
 |  | const char * | value,
 |  | const bool | bFirstPlace = false
 | ) |  |

Changes a string value of the first entry with the given name or creates a new property if it is not found.

Parameters:
name | a name of the property to find or add.
value | a new string value for the property.
bFirstPlace | if not found a new property can be put on top of the list.
void setPropValStringByNumber | ( | const int | index,
 |  | const char * | str
 | ) |  |

Changes an string value of an existing property with the given index.

Parameters:
index | an index of an existing property.
str | String value for the property.
bool uncommentProp | ( | const int | index,
 |  | const char * | delimeter = 0
 | ) |  |

Uncomments a line in the configuration file.

Removes a # and any white space. Finds the delimeter and extracts the property name and value.

Parameters:
index | must be a value between 0 and getNumberOfProperties().
delimeter | will often be a space. If not supplied, the default delimeter will be used.
Returns:
true if the delimiter was found, false otherwise
The documentation for this class was generated from the following files:
  • ms_customproperty.hpp
  • ms_customproperty.cpp
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_customproperty Member List

This is the complete list of members for ms_customproperty, including all inherited members.
appendProperty(const char *name, const char *value, const char *delimiter, const bool bFirstPlace=false) | ms_customproperty
appendText(const char *line, const bool bFirstPlace=false) | ms_customproperty
copyFrom(const ms_customproperty *src) | ms_customproperty
defaultValues() | ms_customproperty
delNonEmpty() | ms_customproperty
delProp(const char *name) | ms_customproperty
delPropByNumber(const int index) | ms_customproperty
delPropStart(const char *nameBeginning) | ms_customproperty
findProperty(const char *name, const int startFrom=0) const | ms_customproperty
findPropertyBeginning(const char *nameBeginning, const int startFrom=0) const | ms_customproperty
getDefaultDelimiter() const | ms_customproperty
getDelimiterByNumber(const int index) const | ms_customproperty
getNumberOfProperties() const | ms_customproperty
getPreceedingComments() const | ms_customproperty
getPropertyName(const int index) const | ms_customproperty
getPropValStringByName(const char *name) const | ms_customproperty
getPropValStringByNumber(const int index) const | ms_customproperty
ms_customproperty() | ms_customproperty
setDefaultDelimiter(const char *delim) | ms_customproperty
setPreceedingComments(const std::string &comments) | ms_customproperty
setPropertyName(const int index, const char *name) | ms_customproperty
setPropValBoolByName(const char *name, const bool value, const bool bFirstPlace=false) | ms_customproperty
setPropValCharByName(const char *name, const char value, const bool bFirstPlace=false) | ms_customproperty
setPropValFloatByName(const char *name, const double value, const bool bFirstPlace=false) | ms_customproperty
setPropValInt64ByName(const char *name, const INT64 value, const bool bFirstPlace=false) | ms_customproperty
setPropValIntByName(const char *name, const int value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByName(const char *name, const char *value, const bool bFirstPlace=false) | ms_customproperty
setPropValStringByNumber(const int index, const char *value) | ms_customproperty
uncommentProp(const int index, const char *delimeter=0) | ms_customproperty
~ms_customproperty() | ms_customproperty
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_customquantitation Member List

This is the complete list of members for ms_customquantitation, including all inherited members.
addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addPeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys) | ms_customquantitation |
addPeptideRatio(const ms_peptide_quant_ratio &ratio) | ms_customquantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearPeptideQuantKeys(const std::string &accession, int dbIdx) | ms_customquantitation |
clearPeptideRatios() | ms_customquantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_quantitation | [virtual]
countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_quantitation | [virtual]
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMinNumPeptides() const | ms_quantitation | [protected]
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | [virtual]
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const | ms_customquantitation | [virtual]
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const | ms_customquantitation | [virtual]
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | [protected]
getQuantitationMethod() const | ms_quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const | ms_customquantitation | [protected, virtual]
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const | ms_customquantitation |
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | [virtual]
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | [protected]
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | [virtual]
isValid() const | ms_errors |
ms_customquantitation(const ms_quant_method &qm) | ms_customquantitation | [explicit]
ms_customquantitation(const ms_peptidesummary &initFrom) | ms_customquantitation | [explicit]
ms_customquantitation(const ms_peptidesummary &initFrom, const ms_quant_method &qm) | ms_customquantitation |
ms_customquantitation(const ms_ms2quantitation &copyFrom) | ms_customquantitation | [explicit]
ms_errors() | ms_errors |
proteinKeys_ | ms_quantitation | [protected]
removePeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
removePeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation |
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | [virtual]
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | [virtual]
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value) | ms_customquantitation | [virtual]
setQuantOutliers(const ms_quant_outliers *) | ms_customquantitation | [virtual]
~ms_customquantitation() | ms_customquantitation | [virtual]
~ms_errors() | ms_errors |
~ms_quantitation()=0 | ms_quantitation | [pure virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_databaseoptions Member List

This is the complete list of members for ms_databaseoptions, including all inherited members.
copyFrom(const ms_databaseoptions *right) | ms_databaseoptions
defaultValues() | ms_databaseoptions
getAccessionParseRuleIndex() const | ms_databaseoptions
getAccessionRefParseRuleIndex() const | ms_databaseoptions
getDBType() const | ms_databaseoptions
getDescriptionParseRuleIndex() const | ms_databaseoptions
getName() const | ms_databaseoptions
getNumberOfThreads() const | ms_databaseoptions
getPath() const | ms_databaseoptions
getPreceedingComments() const | ms_databaseoptions
getTaxonomyParseRuleIndex() const | ms_databaseoptions
isActive() const | ms_databaseoptions
isLocalRefFile() const | ms_databaseoptions
isLockMemory() const | ms_databaseoptions
isMemoryMapFiles() const | ms_databaseoptions
ms_databaseoptions() | ms_databaseoptions
ms_databaseoptions(const ms_databaseoptions &src) | ms_databaseoptions
NUM_THREADS_AUTO_DETECT enum value | ms_databaseoptions
operator=(const ms_databaseoptions &right) | ms_databaseoptions
setAccessionParseRuleIndex(const int index) | ms_databaseoptions
setAccessionRefParseRuleIndex(const int index) | ms_databaseoptions
setActive(const bool value) | ms_databaseoptions
setDBType(const int type) | ms_databaseoptions
setDescriptionParseRuleIndex(const int index) | ms_databaseoptions
setLocalRefFile(const bool flag) | ms_databaseoptions
setLockMemory(const bool flag) | ms_databaseoptions
setMemoryMapFiles(const bool flag) | ms_databaseoptions
setName(const char *name) | ms_databaseoptions
setNumberOfThreads(const int number) | ms_databaseoptions
setPath(const char *path) | ms_databaseoptions
setPreceedingComments(const std::string &str) | ms_databaseoptions
setTaxonomyParseRuleIndex(const int index) | ms_databaseoptions
~ms_databaseoptions() | ms_databaseoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_databases Member List

This is the complete list of members for ms_databases, including all inherited members.
appendDatabase(const ms_databaseoptions *item) | ms_databases
clearDatabases() | ms_databases
copyFrom(const ms_databases *right) | ms_databases
defaultValues() | ms_databases
deleteDatabaseByName(const char *name) | ms_databases
deleteDatabaseByNumber(const int num) | ms_databases
findDatabase(const char *dbName, const bool searchInactive=false) const | ms_databases
getDatabase(const int index) const | ms_databases
getNumberOfDatabases() const | ms_databases
getPreceedingComments() const | ms_customproperty
isSectionAvailable() const | ms_databases
ms_customproperty() | ms_customproperty
ms_databases() | ms_databases
ms_databases(const ms_databases &src) | ms_databases
operator=(const ms_databases &right) | ms_databases
setPreceedingComments(const std::string &comments) | ms_customproperty
setSectionAvailable(const bool value) | ms_databases
updateDatabaseByName(const char *name, const ms_databaseoptions db) | ms_databases
updateDatabaseByNumber(const int num, const ms_databaseoptions db) | ms_databases
~ms_customproperty() | ms_customproperty
~ms_databases() | ms_databases
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_datfile Member List

This is the complete list of members for ms_datfile, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
checkSeqDBInstallRequest(const std::string &dbName, const double newFastaSize) const | ms_datfile
clearAllErrors() | ms_errors
copyFrom(const ms_datfile *right) | ms_datfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_datfile
editedByDatabaseManager() const | ms_datfile
getClusterParams() const | ms_datfile
getConnectionSettings() const | ms_datfile
getCronOptions() const | ms_datfile
getDatabases() const | ms_datfile
getErrorHandler() const | ms_errors
getFileName() const | ms_datfile
getFindFileTimeout() const | ms_datfile
getHeaderComments() const | ms_datfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLibraryOptions() const | ms_datfile
getMascotFiles() const | ms_datfile
getMascotOptions() const | ms_datfile
getMaxTaxonomyRules() const | ms_datfile
getParseOptions() const | ms_datfile
getProcessors() const | ms_datfile
getTaxonomyRules(const int idx) const | ms_datfile
getUniGeneOptions() const | ms_datfile
getWWWOptions() const | ms_datfile
IFLG_ADDMISSINGOPTIONS enum value | ms_datfile
IFLG_ADDPERCOLATOROPT enum value | ms_datfile
IFLG_ADDREPORTAUTO enum value | ms_datfile
IFLG_DEFAULTNEWINSTALL enum value | ms_datfile
IFLG_DEFAULTUPGRADE enum value | ms_datfile
IFLG_UPDATEAPACHEFORKOPT enum value | ms_datfile
IFLG_UPDATECLUSTER enum value | ms_datfile
IFLG_UPDATEDBMANAGERPERLPATH enum value | ms_datfile
IFLG_UPDATEESTTAX enum value | ms_datfile
IFLG_UPDATEEXECAFTERSEARCH enum value | ms_datfile
IFLG_UPDATEMSPEPSEARCHOPTS enum value | ms_datfile
IFLG_UPDATENCBIHTTPS enum value | ms_datfile
IFLG_UPDATEPARSERULES enum value | ms_datfile
IFLG_UPDATEPERCOLATORFEATS enum value | ms_datfile
IFLG_UPDATEPRIDECONTAMINANTS enum value | ms_datfile
IFLG_UPDATEPROTFAMILYSWITCH enum value | ms_datfile
IFLG_UPDATESWISSPROT enum value | ms_datfile
IFLG_UPDATETAXONOMY enum value | ms_datfile
INST_FLAGS enum name | ms_datfile
isValid() const | ms_errors
ms_datfile() | ms_datfile
ms_datfile(const ms_datfile &src) | ms_datfile
ms_datfile(const char *filename, const int timeoutSec=0, const matrix_science::ms_connection_settings *cs=0) | ms_datfile
ms_errors() | ms_errors
operator=(const ms_datfile &right) | ms_datfile
read_file() | ms_datfile
save_file() | ms_datfile
SEQDB_INSTALL enum name | ms_datfile
SEQDB_INSTALL_CURRENT_RULES enum value | ms_datfile
SEQDB_INSTALL_CUSTOMISED enum value | ms_datfile
SEQDB_INSTALL_EXISTING_LARGER enum value | ms_datfile
SEQDB_INSTALL_INACTIVE enum value | ms_datfile
SEQDB_INSTALL_INVALID_CONFIG enum value | ms_datfile
SEQDB_INSTALL_INVALID_DBNAME enum value | ms_datfile
SEQDB_INSTALL_MISSING_CONFIG enum value | ms_datfile
SEQDB_INSTALL_MUST_UPDATE_CFG enum value | ms_datfile
SEQDB_INSTALL_OLD_RULES enum value | ms_datfile
SEQDB_INSTALL_SHOULD_QUERY_USER enum value | ms_datfile
SEQDB_INSTALL_WRONG_WILDCARD enum value | ms_datfile
setClusterParams(const ms_clusterparams *params) | ms_datfile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_datfile
setCronOptions(const ms_cronoptions *options) | ms_datfile
setDatabases(const ms_databases *dbs) | ms_datfile
setFileName(const char *name) | ms_datfile
setFindFileTimeout(const int seconds) | ms_datfile
setHeaderComments(const std::string headerComments) | ms_datfile
setLibraryOptions(const ms_libraryoptions *spectralLibraryOptions) | ms_datfile
setMascotFiles(const ms_mascotfiles *src) | ms_datfile
setMascotOptions(const ms_mascotoptions *opt) | ms_datfile
setParseOptions(const ms_parseoptions *rules) | ms_datfile
setProcessors(const ms_processoroptions *info) | ms_datfile
setTaxonomyRules(const int idx, const ms_taxonomyrules *rules) | ms_datfile
setUniGeneOptions(const ms_unigeneoptions *uoptions) | ms_datfile
setWWWOptions(const ms_wwwoptions *www) | ms_datfile
updateForInstaller(ms_errs &log, const char *not_mascot_dat_path, const char *mascot_dat_path, const char *licenseFilePath, const char *pathToMascot, const char *mascotURL, const char *sequenceDatabases, const bool clusterEnable, const WST wst, const char *NTGuestName, const char *NTAdminName, const unsigned int flags) | ms_datfile
WST enum name | ms_datfile
WST_APACHE enum value | ms_datfile
WST_IIS enum value | ms_datfile
~ms_datfile() | ms_datfile
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_dbprocessors Member List

This is the complete list of members for ms_dbprocessors, including all inherited members.
appendThreadProcessorID(const int proccessorID) | ms_dbprocessors
clearThreads() | ms_dbprocessors
copyFrom(const ms_dbprocessors *right) | ms_dbprocessors
defaultValues() | ms_dbprocessors
getName() const | ms_dbprocessors
getNumberOfThreads() const | ms_dbprocessors
getThreadProcessorID(const int threadIndex) const | ms_dbprocessors
ms_dbprocessors() | ms_dbprocessors
ms_dbprocessors(const ms_dbprocessors &src) | ms_dbprocessors
operator=(const ms_dbprocessors &right) | ms_dbprocessors
setName(const char *str) | ms_dbprocessors
~ms_dbprocessors() | ms_dbprocessors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_data Member List

This is the complete list of members for ms_distiller_data, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_distiller_data *right) | ms_distiller_data |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
get_ms_mascotresults_params(const int searchIndex) const | ms_distiller_data | [virtual]
getDatfile() const | ms_distiller_data | [virtual]
getDistillerProjectStreamName() | ms_distiller_data | [static]
getDistillerResfileTimestamp() | ms_distiller_data | [static]
getDistillerVersion() const | ms_distiller_data | [virtual]
getErrorHandler() const | ms_errors |
getFragRulesFile() const | ms_distiller_data | [virtual]
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getLoadedSearchIndex() const | ms_distiller_data | [virtual]
getQuant(int index) const | ms_distiller_data | [virtual]
getQuantCount() const | ms_distiller_data | [virtual]
getQuantForSearch(const std::string &taskId) const | ms_distiller_data | [virtual]
getQuantMethod() const | ms_distiller_data | [virtual]
getRequiredSchemaFileNames() | ms_distiller_data | [static]
getSearch(int index) const | ms_distiller_data | [virtual]
getSearchCount() const | ms_distiller_data | [virtual]
isValid() const | ms_errors |
loadXml(const char *xmlSchemaPath, const std::string &xmlText) | ms_distiller_data | [virtual]
loadXmlFile(const char *xmlSchemaPath, const std::string &xmlFilename) | ms_distiller_data | [virtual]
loadXmlStream(const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream) | ms_distiller_data | [virtual]
ms_distiller_data(const ms_distiller_data &copy) | ms_distiller_data |
ms_errors() | ms_errors |
operator=(const ms_distiller_data &copy) | ms_distiller_data |
~ms_errors() | ms_errors |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_data_quant Member List

This is the complete list of members for ms_distiller_data_quant, including all inherited members.
getCacheStreamName() const | ms_distiller_data_quant
getResultsStreamName() const | ms_distiller_data_quant
getStreamNumber() const | ms_distiller_data_quant
getTaskId() const | ms_distiller_data_quant
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_data_search Member List

This is the complete list of members for ms_distiller_data_search, including all inherited members.
eAuto enum value | ms_distiller_data_search
eFASTA enum value | ms_distiller_data_search
eGroupAuto enum value | ms_distiller_data_search
eGroupFamily enum value | ms_distiller_data_search
eGrouping enum name | ms_distiller_data_search
eGroupStandard enum value | ms_distiller_data_search
eIntegrated enum value | ms_distiller_data_search
eLibrary enum value | ms_distiller_data_search
eMudpit enum value | ms_distiller_data_search
eScoring enum name | ms_distiller_data_search
eSpectralLibrary enum name | ms_distiller_data_search
eStandard enum value | ms_distiller_data_search
eUnknown enum value | ms_distiller_data_search
getCacheFileName() const | ms_distiller_data_search
getErrTolPeptide() const | ms_distiller_data_search
getLoaded() const | ms_distiller_data_search
getLoadUnassigned() const | ms_distiller_data_search
getMascotSearchURL(const std::string &resultsFilePath) const | ms_distiller_data_search
getMascotServerURL() const | ms_distiller_data_search
getMinPepLenInPepSummary() const | ms_distiller_data_search
getPeptideSummaryFlags() const | ms_distiller_data_search
getPeptideSummaryFlags2() const | ms_distiller_data_search
getPercolator() const | ms_distiller_data_search
getPercolatorUseProteins() const | ms_distiller_data_search
getPercolatorUseRT() const | ms_distiller_data_search
getProteinGrouping() const | ms_distiller_data_search
getQuantMethodXml() const | ms_distiller_data_search
getReporttop() const | ms_distiller_data_search
getRequireBoldRed() const | ms_distiller_data_search
getScoreExpectCutOff() const | ms_distiller_data_search
getScoring() const | ms_distiller_data_search
getShowSamesets() const | ms_distiller_data_search
getShowSamesetsFamily() const | ms_distiller_data_search
getShowSubset() const | ms_distiller_data_search
getShowSubsetFamily() const | ms_distiller_data_search
getSignificanceThreshold() const | ms_distiller_data_search
getSpectralLibraryDisplayOption() const | ms_distiller_data_search
getTaskId() const | ms_distiller_data_search
ms_distiller_data_search() | ms_distiller_data_search
ms_distiller_data_search(const std::string &taskId, bool isLoaded, const std::string &cacheFileName, const std::string &quantMethodXml, const std::string &mascotServerURL, const std::string &mascotServerVersion, unsigned int flags, unsigned int flags2, bool requireBoldRed, bool showSameset, double showSubset, bool loadUnassigned, double significanceThreshold, eScoring scoring, int reporttop, bool errTolPeptide, eGrouping proteinGrouping, bool percolator, double scoreExpectCutOff, bool showSamesetFamily, bool showSubsetFamily, eSpectralLibrary libraryDisplayOption, bool percolatorUseProteins, bool percolatorUseRT, int minPepLenInPepSummary) | ms_distiller_data_search
serverVersionNewerOrSameAs(int major, int minor, int patch) const | ms_distiller_data_search
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_master_project Member List

This is the complete list of members for ms_distiller_master_project, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_distiller_master_project *right) | ms_distiller_master_project |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMasterProjectStreamName() | ms_distiller_master_project | [static]
getNumSearches() const | ms_distiller_master_project | [virtual]
getNumSubprojects() const | ms_distiller_master_project | [virtual]
getSearch(int index) const | ms_distiller_master_project | [virtual]
getSubproject(int index) const | ms_distiller_master_project | [virtual]
isValid() const | ms_errors |
loadXml(const char *xmlSchemaPath, std::string xmlText) | ms_distiller_master_project | [virtual]
loadXmlFile(const char *xmlSchemaPath, std::string xmlFilename) | ms_distiller_master_project | [virtual]
loadXmlStream(const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream) | ms_distiller_master_project | [virtual]
ms_distiller_master_project(const ms_distiller_master_project &src) | ms_distiller_master_project |
ms_errors() | ms_errors |
operator=(const ms_distiller_master_project &right) | ms_distiller_master_project |
~ms_errors() | ms_errors |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_master_search Member List

This is the complete list of members for ms_distiller_master_search, including all inherited members.
getCacheFilename() const | ms_distiller_master_search | [virtual]
getCombinedPeptideSummaryCacheStreamName() const | ms_distiller_master_search | [virtual]
getId() const | ms_distiller_master_search | [virtual]
getNumSubsearches() const | ms_distiller_master_search | [virtual]
getSubsearch(int index) const | ms_distiller_master_search | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_search_status Member List

This is the complete list of members for ms_distiller_search_status, including all inherited members.
getError() const | ms_distiller_search_status
getId() const | ms_distiller_search_status
getPeptideSummaryCacheStreamName() const | ms_distiller_search_status
getResfileStreamName() const | ms_distiller_search_status
getResultsFile() const | ms_distiller_search_status
getServer() const | ms_distiller_search_status
getStatusMsg() const | ms_distiller_search_status
getSubmitTime() const | ms_distiller_search_status
getTaskId() const | ms_distiller_search_status
getTitle() const | ms_distiller_search_status
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


ms_distiller_search_status_list Member List

This is the complete list of members for ms_distiller_search_status_list, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_distiller_search_status_list *right) | ms_distiller_search_status_list |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getNumSearches() const | ms_distiller_search_status_list |
getSearch(int index) const | ms_distiller_search_status_list |
getSearchStatusListStreamName() | ms_distiller_search_status_list | [static]
isValid() const | ms_errors |
loadXml(const char *xmlSchemaPath, const std::string &xmlText) | ms_distiller_search_status_list |
loadXmlFile(const char *xmlSchemaPath, const std::string &xmlFilename) | ms_distiller_search_status_list |
loadXmlStream(const char *xmlSchemaPath, matrix_science::ms_input_string_stream *xmlStream) | ms_distiller_search_status_list |
ms_distiller_search_status_list(const ms_distiller_search_status_list &src) | ms_distiller_search_status_list |
ms_errors() | ms_errors |
operator=(const ms_distiller_search_status_list &right) | ms_distiller_search_status_list |
~ms_errors() | ms_errors |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_distiller_sub_project Member List

This is the complete list of members for ms_distiller_sub_project, including all inherited members.
getHavePeakList() const | ms_distiller_sub_project | [virtual]
getId() const | ms_distiller_sub_project | [virtual]
getName() const | ms_distiller_sub_project | [virtual]
getProjectRelativePath() const | ms_distiller_sub_project | [virtual]
getRawAbsolutePath() const | ms_distiller_sub_project | [virtual]
getRawFormat() const | ms_distiller_sub_project | [virtual]
getRawRelativePath() const | ms_distiller_sub_project | [virtual]
getRawSampleNumber() const | ms_distiller_sub_project | [virtual]
getResultsListStreamName() | ms_distiller_sub_project | [static]
getType() const | ms_distiller_sub_project | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_distiller_subsearch Member List

This is the complete list of members for ms_distiller_subsearch, including all inherited members.
getResultsFile() const | ms_distiller_subsearch | [virtual]
getTaskId() const | ms_distiller_subsearch | [virtual]
getTitle() const | ms_distiller_subsearch | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_enzyme Member List

This is the complete list of members for ms_enzyme, including all inherited members.
addCutter(const cuttertype type, const char *cleaveAtStr, const char *restrictStr) | ms_enzyme
canCleave(const int cutterNum, const char leftResidue, const char rightResidue) const | ms_enzyme
clearAllCutters() | ms_enzyme
copyFrom(const ms_enzyme *right) | ms_enzyme
CTERM_CUTTER enum value | ms_enzyme
cuttertype enum name | ms_enzyme
defaultValues() | ms_enzyme
getCleave(const int cutterNum) const | ms_enzyme
getCutterType(const int cutterNum) const | ms_enzyme
getNumberOfCutters() const | ms_enzyme
getPreceedingComments() const | ms_customproperty
getRestrict(const int cutterNum) const | ms_enzyme
getTitle() const | ms_enzyme
isIndependent() const | ms_enzyme
isSemiSpecific() const | ms_enzyme
isValid() const | ms_enzyme
ms_customproperty() | ms_customproperty
ms_enzyme() | ms_enzyme
ms_enzyme(const ms_enzyme &src) | ms_enzyme
NTERM_CUTTER enum value | ms_enzyme
operator=(const ms_enzyme &right) | ms_enzyme
setIndependent(const bool bit) | ms_enzyme
setPreceedingComments(const std::string &comments) | ms_customproperty
setSemiSpecific(const bool value) | ms_enzyme
setTitle(const char *str) | ms_enzyme
UNDEFINED_CUTTER enum value | ms_enzyme
verifyEnzyme(ms_errs *errObj) const | ms_enzyme
~ms_customproperty() | ms_customproperty
~ms_enzyme() | ms_enzyme
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_enzymefile Member List

This is the complete list of members for ms_enzymefile, including all inherited members.
appendEnzyme(const ms_enzyme *item) | ms_enzymefile
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
clearEnzymes() | ms_enzymefile
copyFrom(const ms_enzymefile *right) | ms_enzymefile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_enzymefile
deleteEnzymeByName(const char *name) | ms_enzymefile
deleteEnzymeByNumber(const int num) | ms_enzymefile
getConnectionSettings() const | ms_enzymefile
getEnzymeByName(const char *name) const | ms_enzymefile
getEnzymeByNumber(const int num) const | ms_enzymefile
getErrorHandler() const | ms_errors
getFileName() const | ms_enzymefile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfEnzymes() const | ms_enzymefile
isNoneFound() const | ms_enzymefile
isValid() const | ms_errors
ms_enzymefile() | ms_enzymefile
ms_enzymefile(const ms_enzymefile &src) | ms_enzymefile
ms_enzymefile(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_enzymefile
ms_errors() | ms_errors
operator=(const ms_enzymefile &right) | ms_enzymefile
read_buffer(const char *buffer) | ms_enzymefile
read_file() | ms_enzymefile
save_file() | ms_enzymefile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_enzymefile
setFileName(const char *filename) | ms_enzymefile
updateEnzymeByName(const char *name, const ms_enzyme enzyme) | ms_enzymefile
updateEnzymeByNumber(const int num, const ms_enzyme enzyme) | ms_enzymefile
~ms_enzymefile() | ms_enzymefile
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_errors Member List

This is the complete list of members for ms_errors, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
isValid() const | ms_errors
ms_errors() | ms_errors
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_errs Member List

This is the complete list of members for ms_errs, including all inherited members.
addToCatalog(const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages) | ms_log |
appendErrors(const ms_errs &src) | ms_errs |
clearAllErrors() | ms_errs |
convertFromLogLevel(ms_loggingmonitor::Level_e logLevel) | ms_errs | [static]
convertToLogLevel(ms_errs::msg_sev severity) | ms_errs | [static]
err typedef | ms_errs |
ERR_ACCINPEPTIDESTR | ms_errs | [static]
ERR_ADDPEPTIDES | ms_errs | [static]
ERR_CANNOT_APPEND_RESFILE | ms_errs | [static]
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES | ms_errs | [static]
ERR_CDB_64_BIT_REMAKE | ms_errs | [static]
ERR_CDB_BEING_CREATED | ms_errs | [static]
ERR_CDB_FAIL_LOCK | ms_errs | [static]
ERR_CDB_FAIL_REMOVE | ms_errs | [static]
ERR_CDB_FAIL_UNLOCK | ms_errs | [static]
ERR_CDB_INCOMPLETE_NO_RETRY | ms_errs | [static]
ERR_CDB_INCOMPLETE_RETRY | ms_errs | [static]
ERR_CDB_OLD_VER_NO_RETRY | ms_errs | [static]
ERR_CDB_OLD_VER_RETRY | ms_errs | [static]
ERR_CDB_SOURCE_CHANGE_NO_RETRY | ms_errs | [static]
ERR_CDB_SOURCE_CHANGE_RETRY | ms_errs | [static]
ERR_CDB_TOO_LARGE | ms_errs | [static]
ERR_DUPE_ACCESSION | ms_errs | [static]
ERR_DUPLICATE_KEY | ms_errs | [static]
ERR_FAIL_CDB_INIT | ms_errs | [static]
ERR_FAIL_CLOSE_FILE | ms_errs | [static]
ERR_FAIL_MK_CACHE_DIR | ms_errs | [static]
ERR_FAIL_MK_CDB_FILE | ms_errs | [static]
ERR_FAIL_OPEN_DAT_FILE | ms_errs | [static]
ERR_INVALID_CACHE_DIR | ms_errs | [static]
ERR_INVALID_CDB_FILE | ms_errs | [static]
ERR_INVALID_NUMQUERIES | ms_errs | [static]
ERR_INVALID_PROTDB | ms_errs | [static]
ERR_INVALID_RESFILE | ms_errs | [static]
ERR_MALFORMED_DRANGE | ms_errs | [static]
ERR_MALFORMED_ERR_TOL | ms_errs | [static]
ERR_MALFORMED_TAG | ms_errs | [static]
ERR_MALFORMED_TERMS | ms_errs | [static]
ERR_MISSING_CDB_FILE | ms_errs | [static]
ERR_MISSING_PERCOLATOR_FILE | ms_errs | [static]
ERR_MISSINGENTRY | ms_errs | [static]
ERR_MISSINGHIT | ms_errs | [static]
ERR_MISSINGSECTION | ms_errs | [static]
ERR_MISSINGSECTIONEND | ms_errs | [static]
ERR_MSP_BIND_INVALID_CPU | ms_errs | [static]
ERR_MSP_CACHE_DATAOFFSETINVALID | ms_errs | [static]
ERR_MSP_CACHE_DUPLICATESTREAMID | ms_errs | [static]
ERR_MSP_CACHE_FILESEEKFAILED | ms_errs | [static]
ERR_MSP_CACHE_INVALIDFORMAT | ms_errs | [static]
ERR_MSP_CACHE_INVALIDSTREAMID | ms_errs | [static]
ERR_MSP_CACHE_INVALIDSTREAMPOSITION | ms_errs | [static]
ERR_MSP_CACHE_INVALIDVERSION | ms_errs | [static]
ERR_MSP_CACHE_MODIFYCLOSED | ms_errs | [static]
ERR_MSP_CACHE_MODIFYREADONLYMODE | ms_errs | [static]
ERR_MSP_CACHE_OPENFAILED | ms_errs | [static]
ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD | ms_errs | [static]
ERR_MSP_CACHE_READFAILED | ms_errs | [static]
ERR_MSP_CACHE_SIGNATUREINVALID | ms_errs | [static]
ERR_MSP_CACHE_SLREF_UPDATE | ms_errs | [static]
ERR_MSP_CACHE_STREAMNOTFOUND | ms_errs | [static]
ERR_MSP_CACHE_UNINITIALISEDSTREAM | ms_errs | [static]
ERR_MSP_CACHE_WRITEFAILED | ms_errs | [static]
ERR_MSP_CACHE_WRITETRUNCATED | ms_errs | [static]
ERR_MSP_CLOSEST_FDR_FOR_ET | ms_errs | [static]
ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS | ms_errs | [static]
ERR_MSP_COLOURSCHEME_INVALID | ms_errs | [static]
ERR_MSP_COMPILE_PARSE_RULE | ms_errs | [static]
ERR_MSP_CONFLICT_BETWEEN_MODS | ms_errs | [static]
ERR_MSP_CRON_INVALID_CHAR | ms_errs | [static]
ERR_MSP_CRON_INVALID_NUMBER | ms_errs | [static]
ERR_MSP_CRON_INVALID_STAR | ms_errs | [static]
ERR_MSP_CRON_NO_NUM_BEFORE_COMMA | ms_errs | [static]
ERR_MSP_CRON_NO_NUM_BEFORE_MINUS | ms_errs | [static]
ERR_MSP_CRON_TOO_MANY_JOBS | ms_errs | [static]
ERR_MSP_CROSSLINKING_FAILEDLOAD | ms_errs | [static]
ERR_MSP_CROSSLINKING_FAILEDSAVE | ms_errs | [static]
ERR_MSP_CROSSLINKING_INVALID_LINK | ms_errs | [static]
ERR_MSP_CROSSLINKING_MULTI_LINKS | ms_errs | [static]
ERR_MSP_CROSSLINKING_MULTI_PEPTIDE | ms_errs | [static]
ERR_MSP_CROSSLINKING_VARMOD_CONFLICT | ms_errs | [static]
ERR_MSP_CUSTQUANT_FAILEDINIT | ms_errs | [static]
ERR_MSP_CUSTQUANT_PROTR_UNIM | ms_errs | [static]
ERR_MSP_DB_USES_MISSING_RULE | ms_errs | [static]
ERR_MSP_DIFFERENT_1ST_PASS_THR_ET | ms_errs | [static]
ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED | ms_errs | [static]
ERR_MSP_DUP_TAXONOMYRULE | ms_errs | [static]
ERR_MSP_DUPLICATE_MOD | ms_errs | [static]
ERR_MSP_EMPTY_MOD | ms_errs | [static]
ERR_MSP_ENZYME_DEFINITION_PROBLEM | ms_errs | [static]
ERR_MSP_ENZYME_FILE_FORMAT | ms_errs | [static]
ERR_MSP_ENZYME_TOO_MANY_RULES | ms_errs | [static]
ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS | ms_errs | [static]
ERR_MSP_EXEC_AFTER_SEARCH_INVALID | ms_errs | [static]
ERR_MSP_EXEC_AFTER_SEARCH_LOGGING | ms_errs | [static]
ERR_MSP_FAIL_GET_PROCESS_AFFINITY | ms_errs | [static]
ERR_MSP_FAIL_GET_SYSINFO | ms_errs | [static]
ERR_MSP_FAIL_HWLOC_INIT | ms_errs | [static]
ERR_MSP_FAIL_HWLOC_LOAD | ms_errs | [static]
ERR_MSP_FAIL_PROCESSOR_BIND | ms_errs | [static]
ERR_MSP_FAIL_STAT | ms_errs | [static]
ERR_MSP_FAIL_THREAD_BIND | ms_errs | [static]
ERR_MSP_FAIL_UTIME | ms_errs | [static]
ERR_MSP_FAILED_TO_CLOSE_FILE | ms_errs | [static]
ERR_MSP_FAILED_TO_OPEN_FILE | ms_errs | [static]
ERR_MSP_FAILED_TO_WRITE_FILE | ms_errs | [static]
ERR_MSP_FILE_DOESNT_EXIST | ms_errs | [static]
ERR_MSP_FRAGMENTATION_RULES | ms_errs | [static]
ERR_MSP_GET_VOLUME_INFO | ms_errs | [static]
ERR_MSP_HTTP_ABORTEDBYUSER | ms_errs | [static]
ERR_MSP_HTTP_BADHTTPSTATUS | ms_errs | [static]
ERR_MSP_HTTP_CHANGEPASSWORDDISABLED | ms_errs | [static]
ERR_MSP_HTTP_CLOSECONNECTIONFAILED | ms_errs | [static]
ERR_MSP_HTTP_CLOSEREQUESTFAILED | ms_errs | [static]
ERR_MSP_HTTP_CLOSESESSIONFAILED | ms_errs | [static]
ERR_MSP_HTTP_DOWNLOADFAILED | ms_errs | [static]
ERR_MSP_HTTP_ERROR | ms_errs | [static]
ERR_MSP_HTTP_GETPROXYFAILED | ms_errs | [static]
ERR_MSP_HTTP_GETRESULTSFILENAME | ms_errs | [static]
ERR_MSP_HTTP_HEADERFAILED | ms_errs | [static]
ERR_MSP_HTTP_INVALID_URL | ms_errs | [static]
ERR_MSP_HTTP_LOGINERROR | ms_errs | [static]
ERR_MSP_HTTP_LOGINERRORINT | ms_errs | [static]
ERR_MSP_HTTP_LOGINPARSERERROR | ms_errs | [static]
ERR_MSP_HTTP_LOGINPARSERERRORINT | ms_errs | [static]
ERR_MSP_HTTP_LOGINSERVERERROR | ms_errs | [static]
ERR_MSP_HTTP_LOGINSERVERERRORINT | ms_errs | [static]
ERR_MSP_HTTP_MAXCONECTIONS10FAILED | ms_errs | [static]
ERR_MSP_HTTP_MAXCONECTIONSFAILED | ms_errs | [static]
ERR_MSP_HTTP_MISSINGLOGINERROR | ms_errs | [static]
ERR_MSP_HTTP_MISSINGLOGININFO | ms_errs | [static]
ERR_MSP_HTTP_NORESPONSE | ms_errs | [static]
ERR_MSP_HTTP_OPENCONNECTIONFAILED | ms_errs | [static]
ERR_MSP_HTTP_OPENOUTPUTFILEFAILED | ms_errs | [static]
ERR_MSP_HTTP_OPENREQUESTFAILED | ms_errs | [static]
ERR_MSP_HTTP_OPENSESSIONFAILED | ms_errs | [static]
ERR_MSP_HTTP_QUERYDATAFAILED | ms_errs | [static]
ERR_MSP_HTTP_QUERYSTATUSFAILED | ms_errs | [static]
ERR_MSP_HTTP_READDATAFAILED | ms_errs | [static]
ERR_MSP_HTTP_READRESPONSEFAILED | ms_errs | [static]
ERR_MSP_HTTP_RELOGINFAILED | ms_errs | [static]
ERR_MSP_HTTP_SENDREQUESTFAILED | ms_errs | [static]
ERR_MSP_HTTP_SESSIONALREADYOPEN | ms_errs | [static]
ERR_MSP_HTTP_SETHTTPPASSWORDFAILED | ms_errs | [static]
ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED | ms_errs | [static]
ERR_MSP_HTTP_SETPROXYFAILED | ms_errs | [static]
ERR_MSP_HTTP_SETPROXYPASSWORDFAILED | ms_errs | [static]
ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED | ms_errs | [static]
ERR_MSP_HTTP_SETREDIRECTFAILED | ms_errs | [static]
ERR_MSP_HTTP_TRANSMISSION_FAILED | ms_errs | [static]
ERR_MSP_HTTP_VERSIONERROR | ms_errs | [static]
ERR_MSP_HTTP_WEBAUTHERROR | ms_errs | [static]
ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED | ms_errs | [static]
ERR_MSP_HTTP_XMLUPLOADFAILED | ms_errs | [static]
ERR_MSP_IN_CLUSTER_SECTION | ms_errs | [static]
ERR_MSP_IN_MASCOT_DAT_DB_SECT | ms_errs | [static]
ERR_MSP_IN_MASSES_FILE | ms_errs | [static]
ERR_MSP_IN_MODS_FILE | ms_errs | [static]
ERR_MSP_IN_OPTIONS_SECTION | ms_errs | [static]
ERR_MSP_IN_TAXONOMY_SECTION | ms_errs | [static]
ERR_MSP_INCOMPATIBLE_TAX_RULES | ms_errs | [static]
ERR_MSP_INST_CANTGETHOSTNAME | ms_errs | [static]
ERR_MSP_INST_FAILADDPARSERULE | ms_errs | [static]
ERR_MSP_INST_INVALIDCPUINFO | ms_errs | [static]
ERR_MSP_INST_MISSINGDATABASE | ms_errs | [static]
ERR_MSP_INVALID_CPU_PACKAGE_NUM | ms_errs | [static]
ERR_MSP_INVALID_LOGICAL_CPU_NUM | ms_errs | [static]
ERR_MSP_INVALID_MASS_IN_MASSES_FILE | ms_errs | [static]
ERR_MSP_INVALID_NUM_LICENSED | ms_errs | [static]
ERR_MSP_INVALID_PARSE_RULE | ms_errs | [static]
ERR_MSP_INVALID_PARSE_RULE_NO | ms_errs | [static]
ERR_MSP_INVALID_PROCESSOR_LINE | ms_errs | [static]
ERR_MSP_LICENSE_DES_CHECKSUM | ms_errs | [static]
ERR_MSP_LICENSE_EXPIRED | ms_errs | [static]
ERR_MSP_LICENSE_INTERNAL_CONFIG | ms_errs | [static]
ERR_MSP_LICENSE_LINE_CHECKSUM | ms_errs | [static]
ERR_MSP_LICENSE_LINE_INVALID | ms_errs | [static]
ERR_MSP_LICENSE_NOT_YET_AVAIL | ms_errs | [static]
ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED | ms_errs | [static]
ERR_MSP_MALFORMED_PEPTIDE | ms_errs | [static]
ERR_MSP_MASCOT_NOT_RUNNING | ms_errs | [static]
ERR_MSP_MAX_PREFIX_REMOVES | ms_errs | [static]
ERR_MSP_MAX_SUFFIX_REMOVES | ms_errs | [static]
ERR_MSP_MAX_TAX_NO_BREAKS | ms_errs | [static]
ERR_MSP_MISSING_DEFINITION_END | ms_errs | [static]
ERR_MSP_MISSING_ENZYME_TITLE | ms_errs | [static]
ERR_MSP_MISSING_ET_MOD | ms_errs | [static]
ERR_MSP_MISSING_MASCOT_DAT | ms_errs | [static]
ERR_MSP_MISSING_MONOLINK_MOD | ms_errs | [static]
ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE | ms_errs | [static]
ERR_MSP_MISSING_SECTION | ms_errs | [static]
ERR_MSP_MISSING_SL_MOD | ms_errs | [static]
ERR_MSP_MOD_MUST_BE_VAR | ms_errs | [static]
ERR_MSP_MS1QUANTITATION_FAILEDINIT | ms_errs | [static]
ERR_MSP_MS1QUANTITATION_HITREF_DROP | ms_errs | [static]
ERR_MSP_MS1QUANTITATION_HITREF_NEW | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_COMPONENTS | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_FAILEDINIT | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_NORM_NO_SUM | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_NORM_UNIMP | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_PROTR_UNIM | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_PROTWEIGH | ms_errs | [static]
ERR_MSP_MS2QUANTITATION_QUERY_SECS | ms_errs | [static]
ERR_MSP_NEED_1_EXP_IN_PARSE_RULE | ms_errs | [static]
ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK | ms_errs | [static]
ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY | ms_errs | [static]
ERR_MSP_NIST_INDEX_OUT_OF_RANGE | ms_errs | [static]
ERR_MSP_NIST_MODIFICATION_NOT_FOUND | ms_errs | [static]
ERR_MSP_NIST_MSP_INCONSISTENT_MODS | ms_errs | [static]
ERR_MSP_NIST_MSP_INVALID_LINE | ms_errs | [static]
ERR_MSP_NIST_MSP_MISSING_PARAMETER | ms_errs | [static]
ERR_MSP_NIST_MSP_NO_CREATE_CDB | ms_errs | [static]
ERR_MSP_NIST_MSP_NO_SPECTRA | ms_errs | [static]
ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM | ms_errs | [static]
ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE | ms_errs | [static]
ERR_MSP_NIST_SAVE_ZERO_SPECTRA | ms_errs | [static]
ERR_MSP_NO_COMMAS_IN_MOD_NAME | ms_errs | [static]
ERR_MSP_NO_ENZYME_SET | ms_errs | [static]
ERR_MSP_NO_LICENSE_FILE | ms_errs | [static]
ERR_MSP_NO_REGEX_MATCH | ms_errs | [static]
ERR_MSP_NO_SUCH_MOD | ms_errs | [static]
ERR_MSP_PARSE_LEN_EXCEED | ms_errs | [static]
ERR_MSP_PROCESSOR_NOT_IN_SET | ms_errs | [static]
ERR_MSP_QUANT_ACCESSION_NOT_FOUND | ms_errs | [static]
ERR_MSP_QUANT_CDB_MATCH_STREAM | ms_errs | [static]
ERR_MSP_QUANT_CDB_MISSING_KEY | ms_errs | [static]
ERR_MSP_QUANT_EMPTY_REF_ACCESSION | ms_errs | [static]
ERR_MSP_QUANT_FAIL_LOAD_MATCH | ms_errs | [static]
ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE | ms_errs | [static]
ERR_MSP_QUANT_FAILEDLOAD | ms_errs | [static]
ERR_MSP_QUANT_FAILEDSAVE | ms_errs | [static]
ERR_MSP_QUANT_HELPER_FAILEDINIT | ms_errs | [static]
ERR_MSP_QUANT_INVALID_REF_AMOUNT | ms_errs | [static]
ERR_MSP_QUANT_MISSING_COMPONENT | ms_errs | [static]
ERR_MSP_QUANTITATION_BADCOMPONENT | ms_errs | [static]
ERR_MSP_QUANTITATION_BADMETHOD | ms_errs | [static]
ERR_MSP_QUANTITATION_FAILEDINIT | ms_errs | [static]
ERR_MSP_QUANTITATION_NOMETHOD | ms_errs | [static]
ERR_MSP_REGEX_ERROR | ms_errs | [static]
ERR_MSP_REPORTBUILDERCOLARR_INVALID | ms_errs | [static]
ERR_MSP_RESIDUE_AND_TERMINUS_MOD | ms_errs | [static]
ERR_MSP_RULE_NO_ALREADY_DEFINED | ms_errs | [static]
ERR_MSP_SECURITY_ACCOUNT_DISABLED | ms_errs | [static]
ERR_MSP_SECURITY_ADDGROUP | ms_errs | [static]
ERR_MSP_SECURITY_ADDUSER | ms_errs | [static]
ERR_MSP_SECURITY_BAD_GROUP_NAME | ms_errs | [static]
ERR_MSP_SECURITY_BAD_USER_NAME | ms_errs | [static]
ERR_MSP_SECURITY_CMDLINE_CGI | ms_errs | [static]
ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP | ms_errs | [static]
ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS | ms_errs | [static]
ERR_MSP_SECURITY_DEL_SPECIAL_GROUP | ms_errs | [static]
ERR_MSP_SECURITY_DEL_SPECIAL_USER | ms_errs | [static]
ERR_MSP_SECURITY_DELETEGROUP | ms_errs | [static]
ERR_MSP_SECURITY_DELUSER | ms_errs | [static]
ERR_MSP_SECURITY_DIFFERENTIPADDR | ms_errs | [static]
ERR_MSP_SECURITY_DISABLE_ADMIN | ms_errs | [static]
ERR_MSP_SECURITY_DUPE_GROUP_ID | ms_errs | [static]
ERR_MSP_SECURITY_DUPE_GROUP_NAME | ms_errs | [static]
ERR_MSP_SECURITY_DUPE_GROUP_NAME_U | ms_errs | [static]
ERR_MSP_SECURITY_DUPE_USER_ID | ms_errs | [static]
ERR_MSP_SECURITY_DUPE_USER_NAME | ms_errs | [static]
ERR_MSP_SECURITY_DUPE_USER_NAME_U | ms_errs | [static]
ERR_MSP_SECURITY_FAIL_LOAD_GROUP | ms_errs | [static]
ERR_MSP_SECURITY_FAIL_LOAD_SEC | ms_errs | [static]
ERR_MSP_SECURITY_FAIL_LOAD_USER | ms_errs | [static]
ERR_MSP_SECURITY_FAIL_SAVE_SEC | ms_errs | [static]
ERR_MSP_SECURITY_FAILGETINTEGRA | ms_errs | [static]
ERR_MSP_SECURITY_FAILGETINTEGRAURL | ms_errs | [static]
ERR_MSP_SECURITY_GETALLGROUPIDS | ms_errs | [static]
ERR_MSP_SECURITY_GETALLUSERIDS | ms_errs | [static]
ERR_MSP_SECURITY_GETGROUPFAIL | ms_errs | [static]
ERR_MSP_SECURITY_GETGROUPFROMIDFAIL | ms_errs | [static]
ERR_MSP_SECURITY_GETGROUPFROMIDOK | ms_errs | [static]
ERR_MSP_SECURITY_GETGROUPOK | ms_errs | [static]
ERR_MSP_SECURITY_GETINTEGRAUSERS1 | ms_errs | [static]
ERR_MSP_SECURITY_GETINTEGRAUSERS2 | ms_errs | [static]
ERR_MSP_SECURITY_GETINTEGRAUSERS3 | ms_errs | [static]
ERR_MSP_SECURITY_GETPERMTASKSFAIL | ms_errs | [static]
ERR_MSP_SECURITY_GETPERMTASKSOK | ms_errs | [static]
ERR_MSP_SECURITY_GETUSERFAIL | ms_errs | [static]
ERR_MSP_SECURITY_GETUSERFROMIDFAIL | ms_errs | [static]
ERR_MSP_SECURITY_GETUSERFROMIDOK | ms_errs | [static]
ERR_MSP_SECURITY_GETUSEROK | ms_errs | [static]
ERR_MSP_SECURITY_GROUPID_NOT_FOUND | ms_errs | [static]
ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND | ms_errs | [static]
ERR_MSP_SECURITY_INTEGRACONNFORMAT | ms_errs | [static]
ERR_MSP_SECURITY_INTEGRAINVALIDCO | ms_errs | [static]
ERR_MSP_SECURITY_INTEGRAINVALIDPW | ms_errs | [static]
ERR_MSP_SECURITY_INVALID_SESSION_ID | ms_errs | [static]
ERR_MSP_SECURITY_INVALIDPASSWORD | ms_errs | [static]
ERR_MSP_SECURITY_INVALIDSESSION | ms_errs | [static]
ERR_MSP_SECURITY_INVALIDUSER | ms_errs | [static]
ERR_MSP_SECURITY_LOADINGSESS | ms_errs | [static]
ERR_MSP_SECURITY_LOADSESSIONFILE | ms_errs | [static]
ERR_MSP_SECURITY_MISSINGSESSIONFILE | ms_errs | [static]
ERR_MSP_SECURITY_MSSESSCOOKIE | ms_errs | [static]
ERR_MSP_SECURITY_MSSESSINTEGRA | ms_errs | [static]
ERR_MSP_SECURITY_MSSESSIONCTOR | ms_errs | [static]
ERR_MSP_SECURITY_MSSESSLOGIN | ms_errs | [static]
ERR_MSP_SECURITY_MSSESSRESULTSPERM | ms_errs | [static]
ERR_MSP_SECURITY_NO_GUEST_PWD | ms_errs | [static]
ERR_MSP_SECURITY_NO_INTEGRA_LOGIN | ms_errs | [static]
ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR | ms_errs | [static]
ERR_MSP_SECURITY_NOCREATEGUEST | ms_errs | [static]
ERR_MSP_SECURITY_NOSAVEPARAMS | ms_errs | [static]
ERR_MSP_SECURITY_NOT_ADMIN_SESSION | ms_errs | [static]
ERR_MSP_SECURITY_NOT_ENABLED | ms_errs | [static]
ERR_MSP_SECURITY_NOT_INTEGRA_USER | ms_errs | [static]
ERR_MSP_SECURITY_NOTLOGGEDIN | ms_errs | [static]
ERR_MSP_SECURITY_NOTNORMALUSER | ms_errs | [static]
ERR_MSP_SECURITY_OLD_PW_INVALID | ms_errs | [static]
ERR_MSP_SECURITY_PASSWORD_TOO_SHORT | ms_errs | [static]
ERR_MSP_SECURITY_PASSWORDEXPIRED | ms_errs | [static]
ERR_MSP_SECURITY_SAMEPASSWORD | ms_errs | [static]
ERR_MSP_SECURITY_SAVESESSIONFILE | ms_errs | [static]
ERR_MSP_SECURITY_SESSIONDESTROYED | ms_errs | [static]
ERR_MSP_SECURITY_SPOOFATTEMPT1 | ms_errs | [static]
ERR_MSP_SECURITY_SPOOFATTEMPT2 | ms_errs | [static]
ERR_MSP_SECURITY_SPOOFATTEMPT3 | ms_errs | [static]
ERR_MSP_SECURITY_SPOOFATTEMPT4 | ms_errs | [static]
ERR_MSP_SECURITY_TIMEDOUT | ms_errs | [static]
ERR_MSP_SECURITY_UPDATEALLSESSFILES | ms_errs | [static]
ERR_MSP_SECURITY_UPDATEGROUP | ms_errs | [static]
ERR_MSP_SECURITY_UPDATEPW | ms_errs | [static]
ERR_MSP_SECURITY_UPDATESESS | ms_errs | [static]
ERR_MSP_SECURITY_UPDATEUSER | ms_errs | [static]
ERR_MSP_SECURITY_USERID_NOT_FOUND | ms_errs | [static]
ERR_MSP_SECURITY_USERNAME_NOT_FOUND | ms_errs | [static]
ERR_MSP_SECURITY_VALIDATEINTEGRACO1 | ms_errs | [static]
ERR_MSP_SECURITY_VALIDATEINTEGRACO2 | ms_errs | [static]
ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 | ms_errs | [static]
ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 | ms_errs | [static]
ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 | ms_errs | [static]
ERR_MSP_SESSION_UTIME_FAIL | ms_errs | [static]
ERR_MSP_SL_SCORING_MODEL_FAIL | ms_errs | [static]
ERR_MSP_SL_SCORING_MODEL_WARN | ms_errs | [static]
ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR | ms_errs | [static]
ERR_MSP_SYSMP_FAIL | ms_errs | [static]
ERR_MSP_TARGET_FDR_FAILED_FOR_ET | ms_errs | [static]
ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS | ms_errs | [static]
ERR_MSP_TAXONOMY_CONFLICT_PARENTS | ms_errs | [static]
ERR_MSP_TAXONOMY_DEFINITION_END | ms_errs | [static]
ERR_MSP_TAXONOMY_INVALID_NODE_FILE | ms_errs | [static]
ERR_MSP_TAXONOMY_MISSING_NODE_FILE | ms_errs | [static]
ERR_MSP_TAXONOMY_NO_COMMAS | ms_errs | [static]
ERR_MSP_TAXONOMY_NO_TITLE | ms_errs | [static]
ERR_MSP_TAXONOMY_WRONG_LINE | ms_errs | [static]
ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE | ms_errs | [static]
ERR_MSP_TOO_MANY_PROCESSORS | ms_errs | [static]
ERR_MSP_TOO_MANY_TH_PROCESSORS | ms_errs | [static]
ERR_MSP_UMOD_FAILEDLOAD | ms_errs | [static]
ERR_MSP_UMOD_FAILEDSAVE | ms_errs | [static]
ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT | ms_errs | [static]
ERR_MSP_WRONG_ICAT_FILTER | ms_errs | [static]
ERR_MSP_WRONG_MOD_VECTOR | ms_errs | [static]
ERR_MSP_WWW_SECTION | ms_errs | [static]
ERR_MSP_XHUNTER_WRONG_FORMAT | ms_errs | [static]
ERR_MSP_XML_ELEMENT_NOT_FOUND | ms_errs | [static]
ERR_MSP_XML_FAILEDLOAD | ms_errs | [static]
ERR_MSP_XML_FAILEDSAVE | ms_errs | [static]
ERR_MSP_XML_FIELD_NOTFOUND | ms_errs | [static]
ERR_MSP_XML_INVALID_FIELD_FORMAT | ms_errs | [static]
ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED | ms_errs | [static]
ERR_MSP_XML_MEMORY_ERROR | ms_errs | [static]
ERR_MSP_XML_NO_ROOT_ELEMENT | ms_errs | [static]
ERR_MSP_XML_SYSTEM_FAILED | ms_errs | [static]
ERR_MSP_XML_TABLE_NOTFOUND | ms_errs | [static]
ERR_MSP_XMLSCHEMA_FAILEDLOAD | ms_errs | [static]
ERR_MSP_XMLSCHEMA_FAILEDSAVE | ms_errs | [static]
ERR_MSP_ZIP_BUFTOOSMALL | ms_errs | [static]
ERR_MSP_ZIP_ENDIAN | ms_errs | [static]
ERR_MSP_ZIP_INVALIDDATA | ms_errs | [static]
ERR_MSP_ZIP_LENGTHDIFFERS | ms_errs | [static]
ERR_MSP_ZIP_NOTSTREAMING | ms_errs | [static]
ERR_MSP_ZIP_OUTOFMEMORY | ms_errs | [static]
ERR_MSP_ZIP_STREAMERROR | ms_errs | [static]
ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG | ms_errs | [static]
ERR_MSP_ZIP_UNKNOWN | ms_errs | [static]
ERR_MSP_ZIP_VERSIONERROR | ms_errs | [static]
ERR_MSP_ZIP_ZEROLENGTH | ms_errs | [static]
ERR_NEED_64_BIT | ms_errs | [static]
ERR_NO_ERR_TOL_PARENT | ms_errs | [static]
ERR_NO_ERROR | ms_errs | [static]
ERR_NO_UNIGENE_FILE | ms_errs | [static]
ERR_NOMEM | ms_errs | [static]
ERR_NOSUCHFILE | ms_errs | [static]
ERR_NULL_ACC_PEP_SUM | ms_errs | [static]
ERR_NULL_ACC_PROT_SUM | ms_errs | [static]
ERR_OLDRESULTSFILE | ms_errs | [static]
ERR_PEPSUMMPEPGET | ms_errs | [static]
ERR_PEPTIDESTR | ms_errs | [static]
ERR_PROTSUMM | ms_errs | [static]
ERR_PROTSUMMPEP | ms_errs | [static]
ERR_QUERYOUTOFRANGE | ms_errs | [static]
ERR_READINGFILE | ms_errs | [static]
ERR_RESFILE_INVALID_DB_TYPE | ms_errs | [static]
ERR_RESFILE_LINKED_SITES | ms_errs | [static]
ERR_RESFILE_LOOPLINKED_SITES | ms_errs | [static]
ERR_RESFILE_MISSING_QEXP | ms_errs | [static]
ERR_RESULTS_NOT_CREATED | ms_errs | [static]
ERR_UNASSIGNED_PROG | ms_errs | [static]
ERR_UNASSIGNED_RANGE | ms_errs | [static]
ERR_UNASSIGNED_UNK | ms_errs | [static]
ERR_UNIGENE_MULTIDB | ms_errs | [static]
ERR_WRITE_CDB_FILE | ms_errs | [static]
forwardToParentInstance(ms_errs *parent) | ms_errs |
getCombineRepeats() const | ms_errs |
getErrorNumber(const int num=-1) const | ms_errs |
getErrorRepeats(const int num=-1) const | ms_errs |
getErrorSeverity(const int num=-1) const | ms_errs |
getErrorString(const int num) const | ms_errs |
getLastError() const | ms_errs |
getLastErrorString() const | ms_errs |
getLoggingFileName() const | ms_errs |
getLoggingLevel() const | ms_errs | [virtual]
getMessageSource(const ms_log::msg_num_t msgNum) const | ms_log |
getNumberOfErrors() const | ms_errs |
isValid() const | ms_errs |
LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE | ms_log | [static]
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER | ms_log | [static]
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK | ms_log | [static]
LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK | ms_log | [static]
LOGMSG_AAHELPER_CFR_MASSES_VALUE | ms_log | [static]
LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE | ms_log | [static]
LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS | ms_log | [static]
LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT | ms_log | [static]
LOGMSG_AAHELPER_CFR_START_FRAGMENTS | ms_log | [static]
LOGMSG_AAHELPER_CROSSLINKED_END | ms_log | [static]
LOGMSG_AAHELPER_CROSSLINKED_START | ms_log | [static]
LOGMSG_AAHELPER_CUMULATIVE_MASS_NL | ms_log | [static]
LOGMSG_AAHELPER_ETMOD_LOOKUP | ms_log | [static]
LOGMSG_AAHELPER_IMMONIUM_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_IMMONIUM_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_INTERNAL_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_INTERNAL_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_MASTER_NL_VALS | ms_log | [static]
LOGMSG_AAHELPER_MULTINL_INDICES | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_SERIES_PARAMS | ms_log | [static]
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG | ms_log | [static]
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT | ms_log | [static]
LOGMSG_AAHELPER_TOTAL_NL_VALS | ms_log | [static]
LOGMSG_CUSTQUANT_ADD_QUANT_KEY | ms_log | [static]
LOGMSG_CUSTQUANT_REMOVE_ALL_KEY | ms_log | [static]
LOGMSG_CUSTQUANT_REMOVE_KEY | ms_log | [static]
LOGMSG_DBG1_NUM_PROCESSOR_GROUPS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_GETAUTODETECT | ms_log | [static]
LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_MT_NAME | ms_log | [static]
LOGMSG_DBG2_CPU_INF_MT_STATUS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NAME | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_AVAIL | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_GROUPS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_ON_SYS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL | ms_log | [static]
LOGMSG_DBG2_CPU_INF_PROC_AFFINITY | ms_log | [static]
LOGMSG_DBG2_CPU_INF_TABLE_LINE | ms_log | [static]
LOGMSG_DBG2_CPU_INF_TABLE_TITLE | ms_log | [static]
LOGMSG_DBG2_CPU_INF_USE_PROCESSES | ms_log | [static]
LOGMSG_DBG2_NUM_CONFIG_MISMATCH | ms_log | [static]
LOGMSG_DBG2_NUM_ONLINE_MISMATCH | ms_log | [static]
LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD | ms_log | [static]
LOGMSG_DBG3_BINDING_PROCESSORS | ms_log | [static]
LOGMSG_DBG3_BINDING_THREAD | ms_log | [static]
LOGMSG_DBG3_CALL_GET_CHIP_MFCTR | ms_log | [static]
LOGMSG_DBG3_HWLOC_GROUPS | ms_log | [static]
LOGMSG_DBG3_HWLOC_TREE | ms_log | [static]
LOGMSG_DBG3_PROCESSOR_NAME | ms_log | [static]
LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND | ms_log | [static]
LOGMSG_GET_THR_LOOP_BODY_START | ms_log | [static]
LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT | ms_log | [static]
LOGMSG_GET_THR_REACH_COND | ms_log | [static]
LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET | ms_log | [static]
LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR | ms_log | [static]
LOGMSG_HTTP_GETRETURNSTRING | ms_log | [static]
LOGMSG_HTTP_MAXCONECTIONS10FAILED | ms_log | [static]
LOGMSG_HTTP_MAXCONECTIONSFAILED | ms_log | [static]
LOGMSG_HTTP_QUERYSTATUSRESULT | ms_log | [static]
LOGMSG_HTTP_URLSTRING | ms_log | [static]
LOGMSG_INST_ADDINGDATABASE | ms_log | [static]
LOGMSG_INST_ADDOPTIONSSECTION | ms_log | [static]
LOGMSG_INST_APPENDPARSERULE | ms_log | [static]
LOGMSG_INST_APPENDTAXONOMY | ms_log | [static]
LOGMSG_INST_CHANGEDBTAXONOMY | ms_log | [static]
LOGMSG_INST_CHANGEPARSERULE | ms_log | [static]
LOGMSG_INST_CHANGEPERCOLATORFEATS | ms_log | [static]
LOGMSG_INST_CHANGEPROTFAMILYSWITCH | ms_log | [static]
LOGMSG_INST_CLUSTERSECTION | ms_log | [static]
LOGMSG_INST_FAILSAVEPOSTINSTALLFILE | ms_log | [static]
LOGMSG_INST_LOGICALPERPHYSICALCPU | ms_log | [static]
LOGMSG_INST_MASCOTDATOK | ms_log | [static]
LOGMSG_INST_NOSUBCLUSTERSET | ms_log | [static]
LOGMSG_INST_NOTMASCOTDATOK | ms_log | [static]
LOGMSG_INST_NUMTHREADS | ms_log | [static]
LOGMSG_INST_REMOVEOPTIONSSECTION | ms_log | [static]
LOGMSG_INST_SAVEDPOSTINSTALLFILE | ms_log | [static]
LOGMSG_INST_SETOPTIONSSECTION | ms_log | [static]
LOGMSG_MATRIX_OUTPUT_VALS | ms_log | [static]
LOGMSG_PEPSUM_GETHIT | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_START | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST | ms_log | [static]
LOGMSG_PROTINFER_CLUSTER_FROM_ACC | ms_log | [static]
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO | ms_log | [static]
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT | ms_log | [static]
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_END | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_QUEUE | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_START | ms_log | [static]
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END | ms_log | [static]
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START | ms_log | [static]
LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_START | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FROM_ACC | ms_log | [static]
LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY | ms_log | [static]
LOGMSG_PROTINFER_PEPTIDE_MATRIX | ms_log | [static]
LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD | ms_log | [static]
LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP | ms_log | [static]
LOGMSG_PROTINFER_REMOVE_CONFLICTING_START | ms_log | [static]
LOGMSG_PROTINFER_SINGLETON_FROM_ACC | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_DONE | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_START | ms_log | [static]
LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT | ms_log | [static]
LOGMSG_QUANT_ADDED_PROTEIN_HIT | ms_log | [static]
LOGMSG_QUANT_ADDING_PROTEIN_HIT | ms_log | [static]
LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED | ms_log | [static]
LOGMSG_QUANT_CLOSING_CACHE_FILE | ms_log | [static]
LOGMSG_QUANT_EXCLUDING_PEPTIDE | ms_log | [static]
LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN | ms_log | [static]
LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN | ms_log | [static]
LOGMSG_QUANT_FINISH_CALC_COMPLETE | ms_log | [static]
LOGMSG_QUANT_FINISH_LOAD_CDB | ms_log | [static]
LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE | ms_log | [static]
LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES | ms_log | [static]
LOGMSG_QUANT_HELPER_TEST_REQUIRED | ms_log | [static]
LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES | ms_log | [static]
LOGMSG_QUANT_LOADING_MATCHES | ms_log | [static]
LOGMSG_QUANT_OPENING_CACHE_FILE | ms_log | [static]
LOGMSG_QUANT_REAPPLY_THRESHOLDS | ms_log | [static]
LOGMSG_QUANT_REMATCHING_INFERRED | ms_log | [static]
LOGMSG_QUANT_REMOVE_INFERRED_MATCH | ms_log | [static]
LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE | ms_log | [static]
LOGMSG_QUANT_START_CALC_COMPLETE | ms_log | [static]
LOGMSG_QUANT_START_LOAD_CDB | ms_log | [static]
LOGMSG_QUANT_START_REORDER_AFTER_MERGE | ms_log | [static]
LOGMSG_QUANT_START_UPDATE_PROT_MATCHES | ms_log | [static]
LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES | ms_log | [static]
LOGMSG_QUANT_UPDATING_PEP_EVIDENCE | ms_log | [static]
LOGMSG_REPORT_FUNCTION_CALLED_BY | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_EXIT | ms_log | [static]
LOGMSG_REPORT_FUNCTION_EXIT_WITH | ms_log | [static]
LOGMSG_RESFILE_APPEND | ms_log | [static]
ms_errs(msg_sev loglevel=sev_warn, bool combineRepeats=true, ms_loggingmonitor::Source_e api=ms_loggingmonitor::SRC_MSPARSER) | ms_errs |
ms_log() | ms_log |
msg_num_t typedef | ms_log |
msg_sev enum name | ms_log |
setAPI(ms_loggingmonitor::Source_e api) | ms_errs |
setCombineRepeats(const bool flag) | ms_errs |
setLoggingFile(const std::string filename, const msg_sev level) | ms_errs |
setLoggingLevel(const msg_sev level) | ms_errs |
sev_debug1 enum value | ms_log |
sev_debug2 enum value | ms_log |
sev_debug3 enum value | ms_log |
sev_fatal enum value | ms_log |
sev_info enum value | ms_log |
sev_warn enum value | ms_log |
willMessageBeLogged(const ms_errs::err errorNum) const | ms_errs |
matrix_science::ms_log::willMessageBeLogged(const msg_num_t msgNum) const | ms_log |
~ms_errs() | ms_errs | [virtual]
~ms_log() | ms_log | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_file_logger Member List

This is the complete list of members for ms_file_logger, including all inherited members.
COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | [virtual]
getHeaderLine() const | ms_logger |
getLogFilename() | ms_file_logger |
LogOutputColumns_e enum name | ms_logger |
ms_file_logger(const std::string logFileName, unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS) | ms_file_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) | ms_file_logger | [virtual]
setColsToOutput(const unsigned int colsToOutput) | ms_logger | [virtual]
~ms_file_logger() | ms_file_logger | [virtual]
~ms_logger() | ms_logger | [inline, virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_fileutilities Member List

This is the complete list of members for ms_fileutilities, including all inherited members.
CMD_ARGUMENT_PARSE_COLLISION enum value | ms_fileutilities |
CMD_ARGUMENT_PARSE_INVALIDCHAR enum value | ms_fileutilities |
CMD_ARGUMENT_PARSE_OK enum value | ms_fileutilities |
CMD_ARGUMENT_PARSE_RESULT enum name | ms_fileutilities |
CMD_ARGUMENT_PARSE_UNBALANCED enum value | ms_fileutilities |
CMPXML_IGN_COL_SIZE_EQ_ONE enum value | ms_fileutilities |
CMPXML_IGN_DBL_DIFF_100_PPM enum value | ms_fileutilities |
CMPXML_IGN_DBL_DIFF_10_PPM enum value | ms_fileutilities |
CMPXML_IGN_DBL_DIFF_1_PPM enum value | ms_fileutilities |
CMPXML_IGN_DBL_IDENTICAL enum value | ms_fileutilities |
CMPXML_IGN_FILE_URL enum value | ms_fileutilities |
CMPXML_IGN_INF_999999 enum value | ms_fileutilities |
CMPXML_IGN_RAWFILE_NAME enum value | ms_fileutilities |
CMPXML_IGN_TODAY_DATE enum value | ms_fileutilities |
CMPXML_NO_FLAG enum value | ms_fileutilities |
CMPXML_STRIP_TRAILING_ZEROS enum value | ms_fileutilities |
compareXmlFiles(const std::string &filePath1, const std::string &filePath2, const std::string &schemaPath, const int flags, const std::vector< std::string > &ignoreElements, const std::vector< std::string > &ignoreAttributes, ms_errs &errs, std::string &differences, std::string &lhsOnly, std::string &rhsOnly) | ms_fileutilities | [static]
compareXMLFiles_flags enum name | ms_fileutilities |
createDirectory(const std::string &directory, std::string &errorDirectory) | ms_fileutilities | [static]
deleteDirectory(const std::string &directory, const bool bDeleteSubdirectories=true) | ms_fileutilities | [static]
doesFileExist(const char *filename) | ms_fileutilities | [static]
err_sar enum name | ms_fileutilities |
findClose() | ms_fileutilities |
findMascotDat(const char *szMascotDatFilename, ms_errs *err=NULL, const int timeoutSec=0) | ms_fileutilities | [static]
findNext(std::string &fileName) | ms_fileutilities |
findOpen(const std::string directory, const std::string wildcard) | ms_fileutilities |
getFileSize(const char *filename, ms_errs *err=NULL) | ms_fileutilities | [static]
getLastModificationTime(const char *filename, ms_errs *err=NULL) | ms_fileutilities | [static]
getMD5Sum(const std::string &str, const bool b32bitEncoding=true) | ms_fileutilities | [static]
getSARExtendedErrorCode() const | ms_fileutilities |
isDirectory(const char *path) | ms_fileutilities | [static]
isFileWritable(const char *filePath) | ms_fileutilities | [static]
ms_fileutilities() | ms_fileutilities |
parseCommandLineArgumentString(const std::string &command, std::vector< std::string > &components) | ms_fileutilities | [static]
SAR_FAIL_CHMOD enum value | ms_fileutilities |
SAR_FAIL_CHOWN enum value | ms_fileutilities |
SAR_FAIL_GET_NAMED_SECURITY_INFO enum value | ms_fileutilities |
SAR_FAIL_SET_ENTRIES_IN_ACL enum value | ms_fileutilities |
SAR_FAIL_SET_NAMED_SECURITY_INFO enum value | ms_fileutilities |
SAR_SUCCESS enum value | ms_fileutilities |
setAccessRights(const char *filename, const bool bWrite, const bool bExecute, const bool isFile, const ms_mascotoptions &Options, const bool avoid_reapply=false) | ms_fileutilities |
setLastModificationTime(const char *filename, time_t modificationTime, ms_errs *err=NULL) | ms_fileutilities | [static]
stripLastFolder(const std::string pathname) | ms_fileutilities | [static]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_fitexy_result Member List

This is the complete list of members for ms_fitexy_result, including all inherited members.
getA() const | ms_fitexy_result
getB() const | ms_fitexy_result
getChi2() const | ms_fitexy_result
getQ() const | ms_fitexy_result
getSigmaA() const | ms_fitexy_result
getSigmaB() const | ms_fitexy_result
getSigmaX() const | ms_fitexy_result
getSigmaY() const | ms_fitexy_result
ms_fitexy_result() | ms_fitexy_result
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_fragment Member List

This is the complete list of members for ms_fragment, including all inherited members.
clearMatchedIon() | ms_fragment
copyFrom(const ms_fragment *src) | ms_fragment
getAllMatchedIons(std::vector< double > &masses, std::vector< double > &intensities) const | ms_fragment
getCharge() const | ms_fragment
getColumn() const | ms_fragment
getEnd() const | ms_fragment
getLabel(const LABEL_FORMAT fmt=LABEL_FORMAT_TRADITIONAL) const | ms_fragment
getMass() const | ms_fragment
getMatchedIonIntensity() const | ms_fragment
getMatchedIonMass() const | ms_fragment
getNeutralLoss() const | ms_fragment
getPeptideSubstring() const | ms_fragment
getSeriesName() const | ms_fragment
getStart() const | ms_fragment
isCTerminal() const | ms_fragment
isFromAlpha() const | ms_fragment
isFromBeta() const | ms_fragment
isImmonium() const | ms_fragment
isInternal() const | ms_fragment
isNTerminal() const | ms_fragment
isPrecursorNL() const | ms_fragment
isRegular() const | ms_fragment
LABEL_FORMAT enum name | ms_fragment
LABEL_FORMAT_PEPTIDE_VIEW enum value | ms_fragment
LABEL_FORMAT_TRADITIONAL enum value | ms_fragment
ms_fragment() | ms_fragment
ms_fragment(const ms_fragment &src) | ms_fragment
ms_fragment(const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const char *seriesName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const int seriesID, const double massValue, const double nlValue, const char *peptideStr, const int startPos, const int endPos, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const char residueName, const double massValue, const double nlValue, const int col=-1, const int chargeState=1, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const ms_peptide::PSM psmComponent, const char residueName, const double massValue, const double nlValue, const int col, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
ms_fragment(const double massValue, const double nlValue, const int chargeState, const double matchedExptMass=0, const double matchedExptIntensity=0) | ms_fragment
operator=(const ms_fragment &right) | ms_fragment
setMatchedIon(const double mass, const double intensity) | ms_fragment
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_fragmentationrules Member List

This is the complete list of members for ms_fragmentationrules, including all inherited members.
anyNLseriesUsed(const int series) const | ms_fragmentationrules |
clearSeries() | ms_fragmentationrules |
copyFrom(const ms_fragmentationrules *right) | ms_fragmentationrules |
defaultValues() | ms_fragmentationrules |
FRAG_A_MINUS_H2O enum value | ms_fragmentationrules |
FRAG_A_MINUS_NH3 enum value | ms_fragmentationrules |
FRAG_A_SERIES enum value | ms_fragmentationrules |
FRAG_B_MINUS_H2O enum value | ms_fragmentationrules |
FRAG_B_MINUS_NH3 enum value | ms_fragmentationrules |
FRAG_B_SERIES enum value | ms_fragmentationrules |
FRAG_C_SERIES enum value | ms_fragmentationrules |
FRAG_D_SERIES enum value | ms_fragmentationrules |
FRAG_IMMONIUM enum value | ms_fragmentationrules |
FRAG_INTERNAL_YA enum value | ms_fragmentationrules |
FRAG_INTERNAL_YB enum value | ms_fragmentationrules |
FRAG_SERIES_TYPE enum name | ms_fragmentationrules |
FRAG_V_SERIES enum value | ms_fragmentationrules |
FRAG_W_SERIES enum value | ms_fragmentationrules |
FRAG_X_SERIES enum value | ms_fragmentationrules |
FRAG_Y_MINUS_H2O enum value | ms_fragmentationrules |
FRAG_Y_MINUS_NH3 enum value | ms_fragmentationrules |
FRAG_Y_SERIES enum value | ms_fragmentationrules |
FRAG_Z_PLUS_1 enum value | ms_fragmentationrules |
FRAG_Z_PLUS_2 enum value | ms_fragmentationrules |
FRAG_Z_SERIES enum value | ms_fragmentationrules |
getFirstSerie() | ms_fragmentationrules | [static]
getFirstSeries() | ms_fragmentationrules | [static]
getLastSerie() | ms_fragmentationrules | [static]
getLastSeries() | ms_fragmentationrules | [static]
getMaxInternalMass() const | ms_fragmentationrules |
getMinInternalMass() const | ms_fragmentationrules |
getPreceedingComments() const | ms_customproperty |
getSeriesDescription(const int series) | ms_fragmentationrules | [static]
getSeriesName(const int series) | ms_fragmentationrules | [static]
getTitle() const | ms_fragmentationrules |
getTotalSeriesOutput() | ms_fragmentationrules | [static]
isBackboneSeries(const int series) | ms_fragmentationrules | [static]
isCharged2Plus() const | ms_fragmentationrules |
isCharged3Plus() const | ms_fragmentationrules |
isNeutralLossSeries(const int series) | ms_fragmentationrules | [static]
isSeriesUsed(const int series) const | ms_fragmentationrules |
isSinglyCharged() const | ms_fragmentationrules |
isValid() const | ms_fragmentationrules |
ms_customproperty() | ms_customproperty |
ms_fragmentationrules() | ms_fragmentationrules |
ms_fragmentationrules(const ms_fragmentationrules &src) | ms_fragmentationrules |
operator=(const ms_fragmentationrules &right) | ms_fragmentationrules |
setCharged2Plus(const bool value) | ms_fragmentationrules |
setCharged3Plus(const bool value) | ms_fragmentationrules |
setMaxInternalMass(const double mass) | ms_fragmentationrules |
setMinInternalMass(const double mass) | ms_fragmentationrules |
setPreceedingComments(const std::string &comments) | ms_customproperty |
setSeriesUsed(const int series, const bool val) | ms_fragmentationrules |
setSinglyCharged(const bool value) | ms_fragmentationrules |
setTitle(const char *title) | ms_fragmentationrules |
verifyRule(ms_errs *err_, const bool tryToFix) | ms_fragmentationrules |
~ms_customproperty() | ms_customproperty |
~ms_fragmentationrules() | ms_fragmentationrules |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_fragmentvector Member List

This is the complete list of members for ms_fragmentvector, including all inherited members.
addExperimentalData(const std::string &peakList, const int numPeaks, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true) | ms_fragmentvector |
addExperimentalData(const ms_mascotresfile *resfile, const int query, const int flags=MATCH_MOST_INTENSE_PEAK, const int peaksUsedFromIons1=-1, const int peaksUsedFromIons2=-1, const int peaksUsedFromIons3=-1) | ms_fragmentvector |
addExperimentalData(const peaklist_t &peakList, const double tolerance, const std::string &toleranceUnits, const bool updateMatchList=true) | ms_fragmentvector |
appendFragment(const ms_fragment *item) | ms_fragmentvector |
clearFragments() | ms_fragmentvector |
copyFrom(const ms_fragmentvector *right) | ms_fragmentvector |
getFragmentByNumber(const unsigned int numFrag) const | ms_fragmentvector |
getMassesWithinTolerance(const double &fragmentMass, const double &fragmentToleranceValue, const TOLERANCE_UNIT &fragmentToleranceUnit, double &minMass, double &maxMass) | ms_fragmentvector | [static]
getNumberOfFragments() const | ms_fragmentvector |
getVector() | ms_fragmentvector |
getVector() const | ms_fragmentvector |
MATCH_CLOSEST_PEAK enum value | ms_fragmentvector |
MATCH_MOST_INTENSE_PEAK enum value | ms_fragmentvector |
MATCH_PEAKS enum name | ms_fragmentvector |
ms_fragmentvector() | ms_fragmentvector |
ms_fragmentvector(const ms_fragmentvector &src) | ms_fragmentvector |
operator=(const ms_fragmentvector &right) | ms_fragmentvector |
~ms_fragmentvector() | ms_fragmentvector | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_fragrulesfile Member List

This is the complete list of members for ms_fragrulesfile, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
appendInstrument(const ms_fragmentationrules *item) | ms_fragrulesfile
clearAllErrors() | ms_errors
clearInstruments() | ms_fragrulesfile
copyFrom(const ms_fragrulesfile *right) | ms_fragrulesfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_fragrulesfile
deleteInstrumentByName(const char *name) | ms_fragrulesfile
deleteInstrumentByNumber(const int num) | ms_fragrulesfile
getConnectionSettings() const | ms_fragrulesfile
getErrorHandler() const | ms_errors
getFileName() const | ms_fragrulesfile
getInstrumentByName(const char *name) const | ms_fragrulesfile
getInstrumentByNumber(const int instrumentNum) const | ms_fragrulesfile
getInstrumentName(const int instrumentNum) const | ms_fragrulesfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfInstruments() const | ms_fragrulesfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_fragrulesfile() | ms_fragrulesfile
ms_fragrulesfile(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_fragrulesfile
ms_fragrulesfile(const ms_fragrulesfile &src) | ms_fragrulesfile
operator=(const ms_fragrulesfile &right) | ms_fragrulesfile
read_buffer(const char *buffer) | ms_fragrulesfile
read_file() | ms_fragrulesfile
save_file() | ms_fragrulesfile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_fragrulesfile
setFileName(const char *filename) | ms_fragrulesfile
updateInstrumentByName(const char *name, const ms_fragmentationrules item) | ms_fragrulesfile
updateInstrumentByNumber(const int num, const ms_fragmentationrules item) | ms_fragrulesfile
~ms_errors() | ms_errors
~ms_fragrulesfile() | ms_fragrulesfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_group Member List

This is the complete list of members for ms_group, including all inherited members.
addPermittedTask(const matrix_science::ms_security_task &task) | ms_group
addUser(const int userID) | ms_group
clearParam(const std::string name) | ms_group
deleteUser(const int userID) | ms_group
getAllUserIDs(const void *const security=NULL, const int voidSortby=1) const | ms_group
getID() const | ms_group
getName() const | ms_group
getPermittedTasks() const | ms_group
getStringParam(const std::string name, std::string &param) const | ms_group
getStringParam(const std::string name) const | ms_group
GROUPID_ADMINISTRATORS enum value | ms_group
GROUPID_DAEMONS enum value | ms_group
GROUPID_GUESTS enum value | ms_group
GROUPID_INTEGRA_SYSTEM enum value | ms_group
GROUPID_LAST enum value | ms_group
GROUPID_POWERUSERS enum value | ms_group
isUserInGroup(const int userID) const | ms_group
ms_group() | ms_group
ms_group(const int groupID, const std::string groupName) | ms_group
removePermittedTask(const int taskID) | ms_group
saveStringParam(const std::string name, const std::string param) | ms_group
setID(int newVal) | ms_group
setName(const std::string newVal) | ms_group
setPermittedTasks(matrix_science::ms_security_tasks &tasks) | ms_group
systemids enum name | ms_group
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_client Member List

This is the complete list of members for ms_http_client, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
baseUrl() const | ms_http_client |
changePassword(const std::string &userName, const std::string &oldPassword, const std::string &newPassword) | ms_http_client |
ChangePasswordResultCode enum name | ms_http_client |
clearAllErrors() | ms_errors |
connectionSettings() const | ms_http_client |
copyFrom(const ms_http_client *right) | ms_http_client |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
CP_BADNEWPASSWORD enum value | ms_http_client |
CP_INCORRECTPASSWORD enum value | ms_http_client |
CP_SUCCESS enum value | ms_http_client |
CP_UNKNOWNUSER enum value | ms_http_client |
CP_UNSPECIFIEDERROR enum value | ms_http_client |
getErrorHandler() const | ms_errors |
getIsDatabaseActive(const std::string &databaseName, bool &returnIsActive) | ms_http_client |
getIsSecurityEnabled(bool &returnIsSecurityEnabled, std::string &returnUnsecuredSessionId) | ms_http_client |
getIsWebAuthenticationEnabled(bool &returnIsWebAuthenticationEnabled, std::string &returnWebAuthenticatedSessionId) | ms_http_client |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getOsName(std::string &osname) | ms_http_client |
getVersion(int &major, int &minor, int &part3, int &part4) | ms_http_client |
isValid() const | ms_errors |
L_GUESTLOGINDISABLED enum value | ms_http_client |
L_INCORRECTPASSWORD enum value | ms_http_client |
L_PASSWORDEXPIRED enum value | ms_http_client |
L_SECURITYDISABLED enum value | ms_http_client |
L_SUCCESS enum value | ms_http_client |
L_UNKNOWNUSER enum value | ms_http_client |
L_UNSPECIFIEDERROR enum value | ms_http_client |
L_WEBAUTHENTICATIONFAILED enum value | ms_http_client |
LoginResultCode enum name | ms_http_client |
ms_errors() | ms_errors |
ms_http_client(const std::string &baseUrl, ms_connection_settings settings) | ms_http_client |
ms_http_client(const ms_http_client &src) | ms_http_client |
operator=(const ms_http_client &right) | ms_http_client |
setBaseUrl(const std::string &baseUrl) | ms_http_client |
setConnectionSettings(const ms_connection_settings &settings) | ms_http_client |
userLogin(const std::string &username, const std::string &password, ms_http_client_session &returnSession) | ms_http_client |
~ms_errors() | ms_errors |
~ms_http_client() | ms_http_client | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_client_mime Member List

This is the complete list of members for ms_http_client_mime, including all inherited members.
append(const std::string &name, const std::string &value) | ms_http_client_mime |
appendFile(const std::string &name, const std::string &filename, const std::string &contentType, const std::string &prefixData="") | ms_http_client_mime |
erase(int oneBasedIndex) | ms_http_client_mime |
format(const std::string &boundary, matrix_science::ms_http_client_mime::Continuation continuation) const | ms_http_client_mime |
formatHeader(const std::string &boundary, ContentType contentType) | ms_http_client_mime | [static]
getCount() const | ms_http_client_mime |
getFilename(int oneBasedIndex) const | ms_http_client_mime |
getName(int oneBasedIndex) const | ms_http_client_mime |
getValue(int oneBasedIndex) const | ms_http_client_mime |
hasFilename(int oneBasedIndex) const | ms_http_client_mime |
setValue(int oneBasedIndex, const std::string &value) | ms_http_client_mime |
setValueWithFilename(int oneBasedIndex, const std::string &value, const std::string &filename, const std::string &contentType) | ms_http_client_mime |
~ms_http_client_mime() | ms_http_client_mime | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_client_search Member List

This is the complete list of members for ms_http_client_search, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_http_client_search *right) | ms_http_client_search |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
DO_NORMAL enum value | ms_http_client_search |
DO_WITH_IONS enum value | ms_http_client_search |
downloadDaemonResultsFile(std::string filename, ms_http_helper_progress &progress) | ms_http_client_search |
DownloadOption enum name | ms_http_client_search |
downloadPercolatorFile(std::string filename, ms_http_helper_progress &progress) | ms_http_client_search |
downloadResultsFile(std::string filename, ms_http_helper_progress &progress, DownloadOption options=DO_WITH_IONS) | ms_http_client_search |
downloadXmlResultsFile(std::string filename, ms_http_helper_progress &progress, int reportTop=RT_auto) | ms_http_client_search |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getResultsFileName(std::string &returnFileName) | ms_http_client_search |
getSearchTaskID() const | ms_http_client_search |
getSessionID() const | ms_http_client_search |
getStatus(SearchStatusCode &returnCode, int &statusValue) | ms_http_client_search |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_http_client_search(ms_http_client_session &session, const std::string &searchTaskId) | ms_http_client_search |
ms_http_client_search(const ms_http_client_search &src) | ms_http_client_search |
operator=(const ms_http_client_search &right) | ms_http_client_search |
ReportTopSpecialValues enum name | ms_http_client_search |
RT_auto enum value | ms_http_client_search |
RT_file enum value | ms_http_client_search |
SearchStatusCode enum name | ms_http_client_search |
sessionId() const | ms_http_client_search | [inline]
SS_ASSIGNED enum value | ms_http_client_search |
SS_COMPLETE enum value | ms_http_client_search |
SS_ERROR enum value | ms_http_client_search |
SS_QUEUED enum value | ms_http_client_search |
SS_RUNNING enum value | ms_http_client_search |
SS_SEARCH_CONTROL_ERROR enum value | ms_http_client_search |
SS_UNKNOWN enum value | ms_http_client_search |
uploadDistillerXmlResultsFile(std::string filename, UploadResponseCode &responseCode, std::string &responseText) | ms_http_client_search |
UploadResponseCode enum name | ms_http_client_search |
UR_ACCESS_DENIED enum value | ms_http_client_search |
UR_ERROR enum value | ms_http_client_search |
UR_FILE_ALREADY_EXISTS enum value | ms_http_client_search |
UR_INVALID_TASKID enum value | ms_http_client_search |
UR_NO_RESULT_FILE enum value | ms_http_client_search |
UR_NO_RESULT_FILENAME enum value | ms_http_client_search |
UR_SUCCESS enum value | ms_http_client_search |
~ms_errors() | ms_errors |
~ms_http_client_search() | ms_http_client_search | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_client_session Member List

This is the complete list of members for ms_http_client_session, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
copyFrom(const ms_http_client_session *right) | ms_http_client_session |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getIsPermitted(ms_security_tasks::TASKID taskType, bool &returnIsPermitted) | ms_http_client_session |
getIsXmlUploadedList(const std::vector< std::string > &taskIds, std::vector< int > &xmlUploaded) | ms_http_client_session |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getSequenceFile(const std::string &database, const std::vector< std::string > &accessionNames, const std::vector< int > &accessionFrames, const std::string &filename, const SequenceShowOptions options=SHOW_ALL) | ms_http_client_session |
getSessionID() const | ms_http_client_session |
isValid() const | ms_errors |
logout() | ms_http_client_session |
ms_errors() | ms_errors |
ms_http_client_session() | ms_http_client_session |
ms_http_client_session(const ms_http_helper connection, const std::string sessionId) | ms_http_client_session |
ms_http_client_session(const ms_http_client_session &src) | ms_http_client_session |
operator=(const ms_http_client_session &right) | ms_http_client_session |
SequenceShowOptions enum name | ms_http_client_session |
SHOW_ALL enum value | ms_http_client_session |
SHOW_LENGTH enum value | ms_http_client_session |
SHOW_NONE enum value | ms_http_client_session |
SHOW_PI enum value | ms_http_client_session |
SHOW_REFERENCE enum value | ms_http_client_session |
SHOW_SEQUENCE enum value | ms_http_client_session |
SHOW_TITLE enum value | ms_http_client_session |
submitSearch(ms_http_client_search &returnTask, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_progress &progress, bool batch=false) | ms_http_client_session |
~ms_errors() | ms_errors |
~ms_http_client_session() | ms_http_client_session | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_helper Member List

This is the complete list of members for ms_http_helper, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
baseUrl() const | ms_http_helper |
clearAllErrors() | ms_errors |
connectionSettings() const | ms_http_helper |
copyFrom(const ms_http_helper *right) | ms_http_helper |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
FileMode enum name | ms_http_helper |
FM_binary enum value | ms_http_helper |
FM_text enum value | ms_http_helper |
getErrorHandler() const | ms_errors |
getHeaderValue(const std::string &name, const std::string &header) | ms_http_helper | [static]
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getProxyConfig(std::vector< std::string > &proxyServers, std::vector< std::string > &proxyUsernames, std::vector< std::string > &proxyPasswords) | ms_http_helper |
httpBufferedClose() | ms_http_helper |
httpBufferedGetString(std::string &httpBuffer, unsigned long requiredSize) | ms_http_helper |
httpBufferedOpen(const std::string &action) | ms_http_helper |
httpGetFile(const std::string &action, const std::string &filename, ms_http_helper_progress &progress, FileMode fileMode=FM_binary) | ms_http_helper |
httpGetHeader(const std::string &action, std::string &httpHeaderInfo) | ms_http_helper |
httpGetString(const std::string &action, std::string &httpGETString) | ms_http_helper |
httpPostFile(const std::string &action, const std::string &httpHeader, const std::string &prologue, const std::string &filename, const std::string &epilogue, ms_http_helper_handles &handles, ms_http_helper_progress &progress) | ms_http_helper |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_http_helper() | ms_http_helper |
ms_http_helper(const ms_http_helper &copy) | ms_http_helper |
ms_http_helper(const std::string &baseUrl, const ms_connection_settings &settings) | ms_http_helper |
operator=(const ms_http_helper &copy) | ms_http_helper |
~ms_errors() | ms_errors |
~ms_http_helper() | ms_http_helper |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_helper_handles Member List

This is the complete list of members for ms_http_helper_handles, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
closeHandles() | ms_http_helper_handles |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getRequestData(bool &isStillActive, std::string &requestDataRef) | ms_http_helper_handles |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_http_helper_handles() | ms_http_helper_handles |
~ms_errors() | ms_errors |
~ms_http_helper_handles() | ms_http_helper_handles | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_helper_progress Member List

This is the complete list of members for ms_http_helper_progress, including all inherited members.
getCurrentBytes() const | ms_http_helper_progress
getProportion() const | ms_http_helper_progress
getTotalBytes() const | ms_http_helper_progress
isAbortSet() const | ms_http_helper_progress
isComplete() const | ms_http_helper_progress
isStarted() const | ms_http_helper_progress
ms_http_helper_progress() | ms_http_helper_progress
setAbort() | ms_http_helper_progress
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_http_helper_return Member List

This is the complete list of members for ms_http_helper_return, including all inherited members.
abortedByUser() | ms_http_helper_return | [static]
ERR_ABORTEDBYUSER enum value | ms_http_helper_return |
ERR_HTTP enum value | ms_http_helper_return |
ERR_NONE enum value | ms_http_helper_return |
ERR_SYSTEM enum value | ms_http_helper_return |
ERR_UNSPECIFIED enum value | ms_http_helper_return |
ErrorTypeCode enum name | ms_http_helper_return |
getErrorText() const | ms_http_helper_return |
getErrorType() const | ms_http_helper_return |
getHttpStatusCode() const | ms_http_helper_return |
getSystemError() const | ms_http_helper_return |
httpError(int httpStatusCode, std::string errorText) | ms_http_helper_return | [static]
isOk() const | ms_http_helper_return |
ms_http_helper_return() | ms_http_helper_return |
operator bool() const | ms_http_helper_return |
systemError(int systemError) | ms_http_helper_return | [static]
unspecifiedError() | ms_http_helper_return | [static]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_inputquery Member List

This is the complete list of members for ms_inputquery, including all inherited members.
getCharge() const | ms_inputquery
getComp(int comp_no) const | ms_inputquery
getIndex() const | ms_inputquery
getINSTRUMENT(const bool unescaped=true) const | ms_inputquery
getIntMax() const | ms_inputquery
getIntMin() const | ms_inputquery
getIonMobility() const | ms_inputquery
getIT_MODS(const bool unescaped=true) const | ms_inputquery
getLocalVarModName(const int num) const | ms_inputquery
getLocus() const | ms_inputquery
getMassMax() const | ms_inputquery
getMassMin() const | ms_inputquery
getMaxInternalMass() const | ms_inputquery
getMinInternalMass() const | ms_inputquery
getNumberOfLocalVarMods() const | ms_inputquery
getNumberOfPeaks(const int ions) | ms_inputquery
getNumUsed() const | ms_inputquery
getNumVals() const | ms_inputquery
getPeakIntensity(const int ions, const int peakNo) | ms_inputquery
getPeakList(const int ions) | ms_inputquery
getPeakMass(const int ions, const int peakNo) | ms_inputquery
getPepTol() const | ms_inputquery
getPepTolString() const | ms_inputquery
getPepTolUnits() const | ms_inputquery
getRawfile() const | ms_inputquery
getRawScans(const int rawFileIdx=-1) const | ms_inputquery
getRawScans(std::vector< int > &index, std::vector< std::string > &rawscans) const | ms_inputquery
getRetentionTimes(const int rawFileIdx=-1) const | ms_inputquery
getRetentionTimes(std::vector< int > &index, std::vector< std::string > &times) const | ms_inputquery
getRULES() const | ms_inputquery
getScanNumbers(const int rawFileIdx=-1) const | ms_inputquery
getScanNumbers(std::vector< int > &index, std::vector< std::string > &scans) const | ms_inputquery
getSeq(int seq_no) const | ms_inputquery
getStringIons1(bool includeCharges=false) | ms_inputquery
getStringIons2(bool includeCharges=false) | ms_inputquery
getStringIons3(bool includeCharges=false) | ms_inputquery
getStringTitle(bool unescaped) const | ms_inputquery
getTag(int tag_no) const | ms_inputquery
getTotalIonsIntensity() | ms_inputquery
ms_inputquery(const ms_mascotresfile &resfile, const int q) | ms_inputquery
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_libraryoptions Member List

This is the complete list of members for ms_libraryoptions, including all inherited members.
copyFrom(const ms_libraryoptions *right) | ms_libraryoptions
defaultValues() | ms_libraryoptions
dropSpectralLibrary(const char *spectralLibraryName) | ms_libraryoptions
getLibraryName(const int num) const | ms_libraryoptions
getNumberOfLibraries() const | ms_libraryoptions
getPreceedingComments() const | ms_customproperty
getReferenceFasta(const char *spectralLibraryName) const | ms_libraryoptions
getReferenceFastaTaxonomyTitle(const char *spectralLibraryName) const | ms_libraryoptions
getToleranceInDa(const char *spectralLibraryName) const | ms_libraryoptions
getToleranceInPPM(const char *spectralLibraryName) const | ms_libraryoptions
isSectionAvailable() const | ms_libraryoptions
ms_customproperty() | ms_customproperty
ms_libraryoptions() | ms_libraryoptions
ms_libraryoptions(const ms_libraryoptions &src) | ms_libraryoptions
operator=(const ms_libraryoptions &right) | ms_libraryoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setReferenceFasta(const char *spectralLibraryName, const char *fastaDatabaseName, const char *taxonomyTitle) | ms_libraryoptions
setSectionAvailable(const bool value) | ms_libraryoptions
setToleranceInDa(const char *spectralLibraryName, double tolerance) | ms_libraryoptions
setToleranceInPPM(const char *spectralLibraryName, double tolerance) | ms_libraryoptions
~ms_customproperty() | ms_customproperty
~ms_libraryoptions() | ms_libraryoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_license Member List

This is the complete list of members for ms_license, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_license *right) | ms_license
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_license
getDistributor() const | ms_license
getEndDate() const | ms_license
getErrorHandler() const | ms_errors
getFeatures() const | ms_license
getFileName() const | ms_license
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLicensee() const | ms_license
getLicenseString() const | ms_license
getLicenseVersion() const | ms_license
getNumProcessorsLicensed() const | ms_license
getStartDate() const | ms_license
isLicenseValid() const | ms_license
isValid() const | ms_errors
ms_errors() | ms_errors
ms_license() | ms_license
ms_license(const ms_license &src) | ms_license
ms_license(const char *filename) | ms_license
operator=(const ms_license &right) | ms_license
read_file() | ms_license
setFileName(const char *filename) | ms_license
~ms_errors() | ms_errors
~ms_license() | ms_license
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_linker_site Member List

This is the complete list of members for ms_linker_site, including all inherited members.
copyFrom(const ms_linker_site *right) | ms_linker_site
getLinkerMass() const | ms_linker_site
getLinkFrom() const | ms_linker_site
getLinkTo() const | ms_linker_site
getSiteFrom() const | ms_linker_site
getSiteTo() const | ms_linker_site
getVarModIdxFrom() const | ms_linker_site
getVarModIdxTo() const | ms_linker_site
ms_linker_site() | ms_linker_site
ms_linker_site(ms_peptide::PSM linkFrom, ms_peptide::PSM linkTo, int siteFrom, int siteTo, int varModIdxFrom, int varModIdxTo, double linkerMass) | ms_linker_site
ms_linker_site(const ms_linker_site &src) | ms_linker_site
operator=(const ms_linker_site &right) | ms_linker_site
~ms_linker_site() | ms_linker_site
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_linker_site_vector Member List

This is the complete list of members for ms_linker_site_vector, including all inherited members.
append(const ms_linker_site_vector &src) | ms_linker_site_vector
clear() | ms_linker_site_vector
containsVarModIdx(int idx) const | ms_linker_site_vector
copyFrom(const ms_linker_site_vector *src) | ms_linker_site_vector
empty() const | ms_linker_site_vector
get(int idx) const | ms_linker_site_vector
getAlphaVarModsStrLength() const | ms_linker_site_vector
getBetaVarModsStrLength() const | ms_linker_site_vector
getVarModIdxOfLinkedSite(const ms_peptide::PSM psmComponent, const int i) const | ms_linker_site_vector
ms_linker_site_vector() | ms_linker_site_vector
ms_linker_site_vector(const std::vector< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen) | ms_linker_site_vector
ms_linker_site_vector(const std::list< ms_linker_site > &v, const int alphaVarModsLen, const int betaVarModsLen) | ms_linker_site_vector
ms_linker_site_vector(const ms_linker_site_vector &src) | ms_linker_site_vector
operator=(const ms_linker_site_vector &right) | ms_linker_site_vector
pop() | ms_linker_site_vector
push(const ms_linker_site &linkerSite) | ms_linker_site_vector
set(int idx, const ms_linker_site &linkerSite) | ms_linker_site_vector
size() const | ms_linker_site_vector
swap(ms_linker_site_vector &right) | ms_linker_site_vector
toVector() const | ms_linker_site_vector
~ms_linker_site_vector() | ms_linker_site_vector
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_log Member List

This is the complete list of members for ms_log, including all inherited members.
addToCatalog(const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages) | ms_log |
getLoggingLevel() const =0 | ms_log | [pure virtual]
getMessageSource(const ms_log::msg_num_t msgNum) const | ms_log |
LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES | ms_log | [static]
LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE | ms_log | [static]
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER | ms_log | [static]
LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK | ms_log | [static]
LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK | ms_log | [static]
LOGMSG_AAHELPER_CFR_MASSES_VALUE | ms_log | [static]
LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE | ms_log | [static]
LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS | ms_log | [static]
LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT | ms_log | [static]
LOGMSG_AAHELPER_CFR_START_FRAGMENTS | ms_log | [static]
LOGMSG_AAHELPER_CROSSLINKED_END | ms_log | [static]
LOGMSG_AAHELPER_CROSSLINKED_START | ms_log | [static]
LOGMSG_AAHELPER_CUMULATIVE_MASS_NL | ms_log | [static]
LOGMSG_AAHELPER_ETMOD_LOOKUP | ms_log | [static]
LOGMSG_AAHELPER_IMMONIUM_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_IMMONIUM_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_INTERNAL_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_INTERNAL_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_MASTER_NL_VALS | ms_log | [static]
LOGMSG_AAHELPER_MULTINL_INDICES | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD | ms_log | [static]
LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT | ms_log | [static]
LOGMSG_AAHELPER_SERIES_PARAMS | ms_log | [static]
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG | ms_log | [static]
LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT | ms_log | [static]
LOGMSG_AAHELPER_TOTAL_NL_VALS | ms_log | [static]
LOGMSG_CUSTQUANT_ADD_QUANT_KEY | ms_log | [static]
LOGMSG_CUSTQUANT_REMOVE_ALL_KEY | ms_log | [static]
LOGMSG_CUSTQUANT_REMOVE_KEY | ms_log | [static]
LOGMSG_DBG1_NUM_PROCESSOR_GROUPS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_GETAUTODETECT | ms_log | [static]
LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_MT_NAME | ms_log | [static]
LOGMSG_DBG2_CPU_INF_MT_STATUS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NAME | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_AVAIL | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_GROUPS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_ON_SYS | ms_log | [static]
LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL | ms_log | [static]
LOGMSG_DBG2_CPU_INF_PROC_AFFINITY | ms_log | [static]
LOGMSG_DBG2_CPU_INF_TABLE_LINE | ms_log | [static]
LOGMSG_DBG2_CPU_INF_TABLE_TITLE | ms_log | [static]
LOGMSG_DBG2_CPU_INF_USE_PROCESSES | ms_log | [static]
LOGMSG_DBG2_NUM_CONFIG_MISMATCH | ms_log | [static]
LOGMSG_DBG2_NUM_ONLINE_MISMATCH | ms_log | [static]
LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD | ms_log | [static]
LOGMSG_DBG3_BINDING_PROCESSORS | ms_log | [static]
LOGMSG_DBG3_BINDING_THREAD | ms_log | [static]
LOGMSG_DBG3_CALL_GET_CHIP_MFCTR | ms_log | [static]
LOGMSG_DBG3_HWLOC_GROUPS | ms_log | [static]
LOGMSG_DBG3_HWLOC_TREE | ms_log | [static]
LOGMSG_DBG3_PROCESSOR_NAME | ms_log | [static]
LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND | ms_log | [static]
LOGMSG_GET_THR_LOOP_BODY_START | ms_log | [static]
LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT | ms_log | [static]
LOGMSG_GET_THR_REACH_COND | ms_log | [static]
LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET | ms_log | [static]
LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR | ms_log | [static]
LOGMSG_HTTP_GETRETURNSTRING | ms_log | [static]
LOGMSG_HTTP_MAXCONECTIONS10FAILED | ms_log | [static]
LOGMSG_HTTP_MAXCONECTIONSFAILED | ms_log | [static]
LOGMSG_HTTP_QUERYSTATUSRESULT | ms_log | [static]
LOGMSG_HTTP_URLSTRING | ms_log | [static]
LOGMSG_INST_ADDINGDATABASE | ms_log | [static]
LOGMSG_INST_ADDOPTIONSSECTION | ms_log | [static]
LOGMSG_INST_APPENDPARSERULE | ms_log | [static]
LOGMSG_INST_APPENDTAXONOMY | ms_log | [static]
LOGMSG_INST_CHANGEDBTAXONOMY | ms_log | [static]
LOGMSG_INST_CHANGEPARSERULE | ms_log | [static]
LOGMSG_INST_CHANGEPERCOLATORFEATS | ms_log | [static]
LOGMSG_INST_CHANGEPROTFAMILYSWITCH | ms_log | [static]
LOGMSG_INST_CLUSTERSECTION | ms_log | [static]
LOGMSG_INST_FAILSAVEPOSTINSTALLFILE | ms_log | [static]
LOGMSG_INST_LOGICALPERPHYSICALCPU | ms_log | [static]
LOGMSG_INST_MASCOTDATOK | ms_log | [static]
LOGMSG_INST_NOSUBCLUSTERSET | ms_log | [static]
LOGMSG_INST_NOTMASCOTDATOK | ms_log | [static]
LOGMSG_INST_NUMTHREADS | ms_log | [static]
LOGMSG_INST_REMOVEOPTIONSSECTION | ms_log | [static]
LOGMSG_INST_SAVEDPOSTINSTALLFILE | ms_log | [static]
LOGMSG_INST_SETOPTIONSSECTION | ms_log | [static]
LOGMSG_MATRIX_OUTPUT_VALS | ms_log | [static]
LOGMSG_PEPSUM_GETHIT | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_START | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY | ms_log | [static]
LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST | ms_log | [static]
LOGMSG_PROTINFER_CLUSTER_FROM_ACC | ms_log | [static]
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO | ms_log | [static]
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT | ms_log | [static]
LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_END | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_QUEUE | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS | ms_log | [static]
LOGMSG_PROTINFER_FIND_FAMILY_START | ms_log | [static]
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END | ms_log | [static]
LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START | ms_log | [static]
LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FAMILY_START | ms_log | [static]
LOGMSG_PROTINFER_GROUP_FROM_ACC | ms_log | [static]
LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY | ms_log | [static]
LOGMSG_PROTINFER_PEPTIDE_MATRIX | ms_log | [static]
LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD | ms_log | [static]
LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP | ms_log | [static]
LOGMSG_PROTINFER_REMOVE_CONFLICTING_START | ms_log | [static]
LOGMSG_PROTINFER_SINGLETON_FROM_ACC | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_DONE | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE | ms_log | [static]
LOGMSG_PROTINFER_SORT_BY_SCORE_START | ms_log | [static]
LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT | ms_log | [static]
LOGMSG_QUANT_ADDED_PROTEIN_HIT | ms_log | [static]
LOGMSG_QUANT_ADDING_PROTEIN_HIT | ms_log | [static]
LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED | ms_log | [static]
LOGMSG_QUANT_CLOSING_CACHE_FILE | ms_log | [static]
LOGMSG_QUANT_EXCLUDING_PEPTIDE | ms_log | [static]
LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN | ms_log | [static]
LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN | ms_log | [static]
LOGMSG_QUANT_FINISH_CALC_COMPLETE | ms_log | [static]
LOGMSG_QUANT_FINISH_LOAD_CDB | ms_log | [static]
LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE | ms_log | [static]
LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES | ms_log | [static]
LOGMSG_QUANT_HELPER_TEST_REQUIRED | ms_log | [static]
LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES | ms_log | [static]
LOGMSG_QUANT_LOADING_MATCHES | ms_log | [static]
LOGMSG_QUANT_OPENING_CACHE_FILE | ms_log | [static]
LOGMSG_QUANT_REAPPLY_THRESHOLDS | ms_log | [static]
LOGMSG_QUANT_REMATCHING_INFERRED | ms_log | [static]
LOGMSG_QUANT_REMOVE_INFERRED_MATCH | ms_log | [static]
LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE | ms_log | [static]
LOGMSG_QUANT_START_CALC_COMPLETE | ms_log | [static]
LOGMSG_QUANT_START_LOAD_CDB | ms_log | [static]
LOGMSG_QUANT_START_REORDER_AFTER_MERGE | ms_log | [static]
LOGMSG_QUANT_START_UPDATE_PROT_MATCHES | ms_log | [static]
LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES | ms_log | [static]
LOGMSG_QUANT_UPDATING_PEP_EVIDENCE | ms_log | [static]
LOGMSG_REPORT_FUNCTION_CALLED_BY | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 | ms_log | [static]
LOGMSG_REPORT_FUNCTION_EXIT | ms_log | [static]
LOGMSG_REPORT_FUNCTION_EXIT_WITH | ms_log | [static]
LOGMSG_RESFILE_APPEND | ms_log | [static]
ms_log() | ms_log |
msg_num_t typedef | ms_log |
msg_sev enum name | ms_log |
sev_debug1 enum value | ms_log |
sev_debug2 enum value | ms_log |
sev_debug3 enum value | ms_log |
sev_fatal enum value | ms_log |
sev_info enum value | ms_log |
sev_warn enum value | ms_log |
willMessageBeLogged(const msg_num_t msgNum) const | ms_log |
~ms_log() | ms_log | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_logger Member List

This is the complete list of members for ms_logger, including all inherited members.
COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | [virtual]
getHeaderLine() const | ms_logger |
LogOutputColumns_e enum name | ms_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0)=0 | ms_logger | [pure virtual]
setColsToOutput(const unsigned int colsToOutput) | ms_logger | [virtual]
~ms_logger() | ms_logger | [inline, virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_loggingmonitor Member List

This is the complete list of members for ms_loggingmonitor, including all inherited members.
addLogEventsHandler(ms_logger &logger) | ms_loggingmonitor | [virtual]
getDefaultMonitor() | ms_loggingmonitor | [static]
getLogEventsHandler(const int uid) | ms_loggingmonitor | [virtual]
getLogMask(unsigned source=SRC_ALL) | ms_loggingmonitor | [virtual]
getNumLogEventsHandlers() const | ms_loggingmonitor | [virtual]
Level_e enum name | ms_loggingmonitor |
logMessage(Level_e eSeverity, Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) const | ms_loggingmonitor | [virtual]
LVL_DEBUG1 enum value | ms_loggingmonitor |
LVL_DEBUG2 enum value | ms_loggingmonitor |
LVL_DEBUG3 enum value | ms_loggingmonitor |
LVL_ERROR enum value | ms_loggingmonitor |
LVL_INFO enum value | ms_loggingmonitor |
LVL_NONE enum value | ms_loggingmonitor |
LVL_WARNING enum value | ms_loggingmonitor |
messageSourceAsText(Source_e eSource) | ms_loggingmonitor | [static]
ms_loggingmonitor() | ms_loggingmonitor |
removeLogEventsHandler(const int uid) | ms_loggingmonitor | [virtual]
setDefaultMonitor(ms_loggingmonitor &loggingMonitor) | ms_loggingmonitor | [static]
setLogMask(long newVal, unsigned source=SRC_ALL) | ms_loggingmonitor | [virtual]
severityAsText(Level_e eSeverity) | ms_loggingmonitor | [static]
Source_e enum name | ms_loggingmonitor |
SRC_ALL enum value | ms_loggingmonitor |
SRC_APPLICATION enum value | ms_loggingmonitor |
SRC_DENOVOLIB enum value | ms_loggingmonitor |
SRC_MASCOTSERVER enum value | ms_loggingmonitor |
SRC_MDRO enum value | ms_loggingmonitor |
SRC_MSPARSER enum value | ms_loggingmonitor |
SRC_MSQUANTLIB enum value | ms_loggingmonitor |
SRC_PURIFIERAPI enum value | ms_loggingmonitor |
SRC_PURIFIERAPP enum value | ms_loggingmonitor |
SRC_VENDORSTART enum value | ms_loggingmonitor |
~ms_loggingmonitor() | ms_loggingmonitor | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_mascotfiles Member List

This is the complete list of members for ms_mascotfiles, including all inherited members.
copyFrom(const ms_mascotfiles *right) | ms_mascotfiles
defaultValues() | ms_mascotfiles
getEnzymes() const | ms_mascotfiles
getFrequencies() const | ms_mascotfiles
getModifications() const | ms_mascotfiles
getNodeListFile() const | ms_mascotfiles
getPreceedingComments() const | ms_customproperty
ms_customproperty() | ms_customproperty
ms_mascotfiles() | ms_mascotfiles
ms_mascotfiles(const ms_mascotfiles &src) | ms_mascotfiles
operator=(const ms_mascotfiles &right) | ms_mascotfiles
setEnzymes(const char *filename) | ms_mascotfiles
setFrequencies(const char *filename) | ms_mascotfiles
setModifications(const char *filename) | ms_mascotfiles
setNodeListFile(const char *filename) | ms_mascotfiles
setPreceedingComments(const std::string &comments) | ms_customproperty
~ms_customproperty() | ms_customproperty
~ms_mascotfiles() | ms_mascotfiles
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_mascotoptions Member List

This is the complete list of members for ms_mascotoptions, including all inherited members.
appendIgnoreDupeAccession(const std::string value) | ms_mascotoptions
appendReportNumberChoice(const int value) | ms_mascotoptions
appendTargetFDRPercentage(const double value, const bool makeDefault=false) | ms_mascotoptions
clearIgnoreDupeAccessions() | ms_mascotoptions
clearReportNumberChoices() | ms_mascotoptions
clearTargetFDRPercentages() | ms_mascotoptions
copyFrom(const ms_mascotoptions *right) | ms_mascotoptions
DECOY_ALGORITHM enum name | ms_mascotoptions
DECOY_ALGORITHM_NONE enum value | ms_mascotoptions
DECOY_PEPTIDE_RANDOM enum value | ms_mascotoptions
DECOY_PEPTIDE_RANDOM_DIPEP enum value | ms_mascotoptions
DECOY_PEPTIDE_REVERSE enum value | ms_mascotoptions
DECOY_PEPTIDE_SHUFFLE enum value | ms_mascotoptions
DECOY_PROTEIN_BASED_MASK enum value | ms_mascotoptions
DECOY_PROTEIN_RANDOM enum value | ms_mascotoptions
DECOY_PROTEIN_RANDOM_DIPEP enum value | ms_mascotoptions
DECOY_PROTEIN_REVERSE enum value | ms_mascotoptions
DECOY_PROTEIN_SHUFFLE enum value | ms_mascotoptions
defaultValues() | ms_mascotoptions
EXEC_AFTER_SEARCH enum name | ms_mascotoptions
getCacheDirectory() const | ms_mascotoptions
getCentroidWidth() const | ms_mascotoptions
getCentroidWidthCount() const | ms_mascotoptions
getCompressToolAA() const | ms_mascotoptions
getCompressToolCommandLineFasta(DATABASE_TYPE dbType, const std::string &dbname, const std::string &dbpath) const | ms_mascotoptions
getCompressToolCommandLineLibrary(const std::string &logfilepath, const std::string &inputfile, const std::string &outputdirectory) const | ms_mascotoptions
getCompressToolNA() const | ms_mascotoptions
getCompressToolSL() const | ms_mascotoptions
getCrawlerNumPeaksPer100Da() const | ms_mascotoptions
getCreatePipThreadBlockSize() const | ms_mascotoptions
getCreatePipThreads() const | ms_mascotoptions
getDechargeFragmentPeaks() const | ms_mascotoptions
getDecoyTypeNoEnzyme() const | ms_mascotoptions
getDecoyTypeSpecific() const | ms_mascotoptions
getDisplayNonSignificantMatches() const | ms_mascotoptions
getEmailFromTextName() const | ms_mascotoptions
getEmailFromUser() const | ms_mascotoptions
getEmailPassword() const | ms_mascotoptions
getEmailProfile() const | ms_mascotoptions
getEmailService() const | ms_mascotoptions
getEmailTimeOutPeriod() const | ms_mascotoptions
getErrMessageEmailTo() const | ms_mascotoptions
getErrorLogFile() const | ms_mascotoptions
getErrTolMaxAccessions() const | ms_mascotoptions
getExecAfterSearch(const char *szResultsFilePath, std::vector< std::string > &commands, std::vector< std::string > &titles, std::vector< int > &waitfor, std::vector< int > &logging, std::vector< std::string > &additionalFlags, const char *sessionID=0, const char *taskID=0) const | ms_mascotoptions
getFeatureTableLength() const | ms_mascotoptions
getFeatureTableMinScore() const | ms_mascotoptions
getFormVersion() const | ms_mascotoptions
getGetSeqBlastAccession() const | ms_mascotoptions
getGetSeqJobIdFile() const | ms_mascotoptions
getICATFilter() const | ms_mascotoptions
getICATHeavy() const | ms_mascotoptions
getICATLight() const | ms_mascotoptions
getICATQuantitationMethod() const | ms_mascotoptions
getIgnoreDupeAccession(const unsigned int index) const | ms_mascotoptions
getIgnoreIonsScoreBelow() const | ms_mascotoptions
getIntensitySigFigs() const | ms_mascotoptions
getInterFileBasePath() const | ms_mascotoptions
getInterFileRelPath() const | ms_mascotoptions
getIonsDecimalPlaces() const | ms_mascotoptions
getLastQueryAscFile() const | ms_mascotoptions
getLogoImageFile() const | ms_mascotoptions
getMailTempFile() const | ms_mascotoptions
getMailTransport() const | ms_mascotoptions
getMascNodeCtrlFile() const | ms_mascotoptions
getMascotCmdLine() const | ms_mascotoptions
getMascotControlFile() const | ms_mascotoptions
getMascotFileProcessingThreads() const | ms_mascotoptions
getMascotJobIdFile() const | ms_mascotoptions
getMascotMessage() const | ms_mascotoptions
getMassDecimalPlaces() const | ms_mascotoptions
getMaxConcurrentSearches() const | ms_mascotoptions
getMaxDatabases() const | ms_mascotoptions
getMaxDescriptionLen() const | ms_mascotoptions
getMaxEtagMassDelta() const | ms_mascotoptions
getMaxEtVarMods() const | ms_mascotoptions
getMaxIntactCrosslinkPeptides() const | ms_mascotoptions
getMaxNumOfReportBuilderColumnArrangements() const | ms_mascotoptions
getMaxNumPeptides() const | ms_mascotoptions
getMaxPepModArrangements() const | ms_mascotoptions
getMaxPepNumModifiedSites() const | ms_mascotoptions
getMaxPepNumVarMods() const | ms_mascotoptions
getMaxQueries() const | ms_mascotoptions
getMaxSearchesPerUser() const | ms_mascotoptions
getMaxSequenceLen() const | ms_mascotoptions
getMaxVarMods() const | ms_mascotoptions
getMinEtagMassDelta() const | ms_mascotoptions
getMinPepLenInPepSummary() const | ms_mascotoptions
getMinPepLenInSearch() const | ms_mascotoptions
getMonitorEmailCheckFreq() const | ms_mascotoptions
getMonitorLogFile() const | ms_mascotoptions
getMonitorPidFile() const | ms_mascotoptions
getMonitorTestTimeout() const | ms_mascotoptions
getMudpit() const | ms_mascotoptions
getMudpitSwitch() const | ms_mascotoptions
getNoResultsScript() const | ms_mascotoptions
getNTIUserGroup() const | ms_mascotoptions
getNTMonitorGroup() const | ms_mascotoptions
getNumberOfIgnoreDupeAccessions() const | ms_mascotoptions
getNumberOfReportNumberChoices() const | ms_mascotoptions
getNumberOfTargetFDRPercentages() const | ms_mascotoptions
getPepSearchTool() const | ms_mascotoptions
getPepSearchToolCommandLine(const std::string &peptideToleranceUnit, const double &peptideTolerance, const std::string &ionToleranceUnit, const double &ionTolerance, const std::string &libraryDirectoryPath, const std::string &inputFileRelativePath, const std::string &outputFileRelativePath) const | ms_mascotoptions
getPercolatorExeFlags(bool anyRetentionTimes, const std::vector< std::string > percolatorFiles, const PERC_EXE_RT rt=PERC_EXE_RT_USE_DEFAULT) const | ms_mascotoptions
getPercolatorFeatures() const | ms_mascotoptions
getPercolatorMinQueries() const | ms_mascotoptions
getPercolatorMinSequences() const | ms_mascotoptions
getPercolatorTargetRankRelativeThreshold() const | ms_mascotoptions
getPercolatorTargetRankScoreThreshold() const | ms_mascotoptions
getPreceedingComments() const | ms_customproperty
getPrecursorCutOutLowerLimit() const | ms_mascotoptions
getPrecursorCutOutUpperLimit() const | ms_mascotoptions
getProteinFamilySwitch() const | ms_mascotoptions
getProteinsInResultsFile() const | ms_mascotoptions
getProxyPassword() const | ms_mascotoptions
getProxyServer() const | ms_mascotoptions
getProxyType() const | ms_mascotoptions
getProxyUsername() const | ms_mascotoptions
getReportBuilderColumnArrangement(const int index) const | ms_mascotoptions
getReportNumberChoice(const int index) const | ms_mascotoptions
getResfileCache() const | ms_mascotoptions
getResultsCache() const | ms_mascotoptions
getResultsFileFormatVersion() const | ms_mascotoptions
getResultsFullURL() const | ms_mascotoptions
getResultsFullURL_2() const | ms_mascotoptions
getResultsPerlScript() const | ms_mascotoptions
getResultsPerlScript_2() const | ms_mascotoptions
getReviewColDisplay(const MS_REVIEW_COL index) const | ms_mascotoptions
getReviewColWidth(const MS_REVIEW_COL index) const | ms_mascotoptions
getSearchLogFile() const | ms_mascotoptions
getSearchSubmitMode() const | ms_mascotoptions
getSelectSwitch() const | ms_mascotoptions
getSendmailPath() const | ms_mascotoptions
getSeparateLockMem() const | ms_mascotoptions
getShowSubsets() const | ms_mascotoptions
getSigThreshold() const | ms_mascotoptions
getSiteAnalysisMD10Prob() const | ms_mascotoptions
getSortUnassigned() const | ms_mascotoptions
getSpectraPerLibraryBlock() const | ms_mascotoptions
getSpectrumViewerColourSchemeNames() const | ms_mascotoptions
getSpectrumViewerColourSchemeString(const std::string &name) const | ms_mascotoptions
getSpectrumViewerDefaultColourSchemeName() const | ms_mascotoptions
getSplitDataFileSize() const | ms_mascotoptions
getSplitNumberOfQueries() const | ms_mascotoptions
getSVGSpectrumSwitch() const | ms_mascotoptions
getTargetFDRPercentage(const int index) const | ms_mascotoptions
getTaxBrowserUrl() const | ms_mascotoptions
getTestDirectory() const | ms_mascotoptions
getUniqueJobStartNumber() const | ms_mascotoptions
getUnixDirPerm() const | ms_mascotoptions
getUnixWebUserGroup() const | ms_mascotoptions
getVmemory() const | ms_mascotoptions
isAutoSelectCharge() const | ms_mascotoptions
isDefaultTargetFDRPercentage(const int index) const | ms_mascotoptions
isEmailErrorsEnabled() const | ms_mascotoptions
isEmailUsersEnabled() const | ms_mascotoptions
isForkForUnixApache() const | ms_mascotoptions
isInIgnoreDupeAccessionList(const std::string value) const | ms_mascotoptions
isIteratePMFIntensities() const | ms_mascotoptions
isLabelAll() const | ms_mascotoptions
isMatchOppositeCrosslinkPairs() const | ms_mascotoptions
isMoveOldDbToOldDir() const | ms_mascotoptions
isPercolator() const | ms_mascotoptions
isPercolatorUseProteins() const | ms_mascotoptions
isPercolatorUseRT() const | ms_mascotoptions
isRemoveOldIndexFiles() const | ms_mascotoptions
isRequireBoldRed() const | ms_mascotoptions
isSaveEveryLastQueryAsc() const | ms_mascotoptions
isSaveLastQueryAsc() const | ms_mascotoptions
isSectionAvailable() const | ms_mascotoptions
isShowAllFromErrorTolerant() const | ms_mascotoptions
isShowSubsets() const | ms_mascotoptions
isStoreModPermutations() const | ms_mascotoptions
isUnixDirPermDefined() const | ms_mascotoptions
isUseHTTPProxyForFTP() const | ms_mascotoptions
isUseHTTPProxyForHTTPS() const | ms_mascotoptions
MASS_DECIMAL_PLACES enum value | ms_mascotoptions
MAX_EXEC_AFTER_SEARCH enum value | ms_mascotoptions
ms_customproperty() | ms_customproperty
ms_mascotoptions() | ms_mascotoptions
ms_mascotoptions(const ms_mascotoptions &src) | ms_mascotoptions
MS_REVIEW_COL enum name | ms_mascotoptions
MS_REVIEW_COL____LAST___ enum value | ms_mascotoptions
MS_REVIEW_COL_DATABASE enum value | ms_mascotoptions
MS_REVIEW_COL_DURATION enum value | ms_mascotoptions
MS_REVIEW_COL_ENZYMEUSED enum value | ms_mascotoptions
MS_REVIEW_COL_IPADDRESS enum value | ms_mascotoptions
MS_REVIEW_COL_JOB enum value | ms_mascotoptions
MS_REVIEW_COL_PEAKLISTDATAFILE enum value | ms_mascotoptions
MS_REVIEW_COL_PID enum value | ms_mascotoptions
MS_REVIEW_COL_PRIORITY enum value | ms_mascotoptions
MS_REVIEW_COL_RESULTS_FILE enum value | ms_mascotoptions
MS_REVIEW_COL_SEARCHTYPE enum value | ms_mascotoptions
MS_REVIEW_COL_START_TIME enum value | ms_mascotoptions
MS_REVIEW_COL_STATUS enum value | ms_mascotoptions
MS_REVIEW_COL_TITLE enum value | ms_mascotoptions
MS_REVIEW_COL_USEREMAIL enum value | ms_mascotoptions
MS_REVIEW_COL_USERID enum value | ms_mascotoptions
MS_REVIEW_COL_USERNAME enum value | ms_mascotoptions
NUMERICAL_VALUE_STORAGE enum name | ms_mascotoptions
operator=(const ms_mascotoptions &right) | ms_mascotoptions
PERC_EXE_RT enum name | ms_mascotoptions
PERC_EXE_RT_FORCE_OFF enum value | ms_mascotoptions
PERC_EXE_RT_FORCE_ON enum value | ms_mascotoptions
PERC_EXE_RT_USE_DEFAULT enum value | ms_mascotoptions
setAutoSelectCharge(const bool value) | ms_mascotoptions
setCacheDirectory(const char *value) | ms_mascotoptions
setCentroidWidth(const double value) | ms_mascotoptions
setCentroidWidthCount(const int value) | ms_mascotoptions
setCompressToolAA(const std::string value) | ms_mascotoptions
setCompressToolNA(const std::string value) | ms_mascotoptions
setCompressToolSL(const std::string value) | ms_mascotoptions
setCrawlerNumPeaksPer100Da(const int value) | ms_mascotoptions
setCreatePipThreadBlockSize(const int blockSize) | ms_mascotoptions
setCreatePipThreads(const int nThreads) | ms_mascotoptions
setDechargeFragmentPeaks(const int maxCharge) | ms_mascotoptions
setDecoyTypeNoEnzyme(const int value) | ms_mascotoptions
setDecoyTypeSpecific(const int value) | ms_mascotoptions
setDefaultTargetFDRPercentage(const int index) | ms_mascotoptions
setDisplayNonSignificantMatches(const int value) | ms_mascotoptions
setEmailErrorsEnabled(const bool value) | ms_mascotoptions
setEmailFromTextName(const char *str) | ms_mascotoptions
setEmailFromUser(const char *str) | ms_mascotoptions
setEmailPassword(const char *str) | ms_mascotoptions
setEmailProfile(const char *str) | ms_mascotoptions
setEmailService(const char *str) | ms_mascotoptions
setEmailTimeOutPeriod(const int value) | ms_mascotoptions
setEmailUsersEnabled(const bool value) | ms_mascotoptions
setErrMessageEmailTo(const char *str) | ms_mascotoptions
setErrorLogFile(const char *str) | ms_mascotoptions
setErrTolMaxAccessions(const int value) | ms_mascotoptions
setExecAfterSearch(const int num, std::string value) | ms_mascotoptions
setFeatureTableLength(const int value) | ms_mascotoptions
setFeatureTableMinScore(const double value) | ms_mascotoptions
setForkForUnixApache(const bool value) | ms_mascotoptions
setFormVersion(const char *str) | ms_mascotoptions
setGetSeqBlastAccession(const ms_blastaccession *value) | ms_mascotoptions
setGetSeqJobIdFile(const char *str) | ms_mascotoptions
setICATFilter(const char *filterString) | ms_mascotoptions
setICATHeavy(const char *modName) | ms_mascotoptions
setICATLight(const char *modName) | ms_mascotoptions
setICATQuantitationMethod(const char *methodName) | ms_mascotoptions
setIgnoreDupeAccession(const unsigned int index, const std::string value) | ms_mascotoptions
setIgnoreIonsScoreBelow(const double value) | ms_mascotoptions
setIntensitySigFigs(const int value) | ms_mascotoptions
setInterFileBasePath(const char *str) | ms_mascotoptions
setInterFileRelPath(const char *str) | ms_mascotoptions
setIonsDecimalPlaces(const int value) | ms_mascotoptions
setIteratePMFIntensities(const bool value) | ms_mascotoptions
setLabelAll(const bool value) | ms_mascotoptions
setLastQueryAscFile(const char *str) | ms_mascotoptions
setLogoImageFile(const char *str) | ms_mascotoptions
setMailTempFile(const char *str) | ms_mascotoptions
setMailTransport(const int value) | ms_mascotoptions
setMascNodeCtrlFile(const char *str) | ms_mascotoptions
setMascotCmdLine(const char *str) | ms_mascotoptions
setMascotControlFile(const char *str) | ms_mascotoptions
setMascotFileProcessingThreads(const int value) | ms_mascotoptions
setMascotJobIdFile(const char *str) | ms_mascotoptions
setMascotMessage(const char *str) | ms_mascotoptions
setMassDecimalPlaces(const int value) | ms_mascotoptions
setMatchOppositeCrosslinkPairs(const bool value) | ms_mascotoptions
setMaxConcurrentSearches(const int value) | ms_mascotoptions
setMaxDatabases(const int value) | ms_mascotoptions
setMaxDescriptionLen(const int value) | ms_mascotoptions
setMaxEtagMassDelta(const double value) | ms_mascotoptions
setMaxEtVarMods(const int value) | ms_mascotoptions
setMaxIntactCrosslinkPeptides(const int value) | ms_mascotoptions
setMaxNumPeptides(const int value) | ms_mascotoptions
setMaxPepModArrangements(const int value) | ms_mascotoptions
setMaxPepNumModifiedSites(const int value) | ms_mascotoptions
setMaxPepNumVarMods(const int value) | ms_mascotoptions
setMaxQueries(const int value) | ms_mascotoptions
setMaxSearchesPerUser(const int value) | ms_mascotoptions
setMaxSequenceLen(const int value) | ms_mascotoptions
setMaxVarMods(const int value) | ms_mascotoptions
setMinEtagMassDelta(const double value) | ms_mascotoptions
setMinPepLenInPepSummary(const int value) | ms_mascotoptions
setMinPepLenInSearch(const int value) | ms_mascotoptions
setMonitorEmailCheckFreq(const int value) | ms_mascotoptions
setMonitorLogFile(const char *str) | ms_mascotoptions
setMonitorPidFile(const char *str) | ms_mascotoptions
setMonitorTestTimeout(const int value) | ms_mascotoptions
setMoveOldDbToOldDir(const bool value) | ms_mascotoptions
setMudpit(const int value) | ms_mascotoptions
setMudpitSwitch(const double value) | ms_mascotoptions
setNoResultsScript(const char *str) | ms_mascotoptions
setNTIUserGroup(const char *str) | ms_mascotoptions
setNTMonitorGroup(const char *str) | ms_mascotoptions
setPepSearchTool(const std::string value) | ms_mascotoptions
setPercolator(const bool value) | ms_mascotoptions
setPercolatorExeFlags(const char *value) | ms_mascotoptions
setPercolatorFeatures(std::string value) | ms_mascotoptions
setPercolatorMinQueries(const int value) | ms_mascotoptions
setPercolatorMinSequences(const int value) | ms_mascotoptions
setPercolatorTargetRankRelativeThreshold(const double threshold) | ms_mascotoptions
setPercolatorTargetRankScoreThreshold(const int threshold) | ms_mascotoptions
setPercolatorUseProteins(const bool value) | ms_mascotoptions
setPercolatorUseRT(const bool value) | ms_mascotoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setPrecursorCutOutLowerLimit(const double value) | ms_mascotoptions
setPrecursorCutOutUpperLimit(const double value) | ms_mascotoptions
setProteinFamilySwitch(const int value) | ms_mascotoptions
setProteinsInResultsFile(const int value) | ms_mascotoptions
setProxyPassword(const char *str) | ms_mascotoptions
setProxyServer(const char *str) | ms_mascotoptions
setProxyType(const std::string &value) | ms_mascotoptions
setProxyUsername(const char *str) | ms_mascotoptions
setRemoveOldIndexFiles(const bool value) | ms_mascotoptions
setReportBuilderColumnArrangement(const int index, const std::string str) | ms_mascotoptions
setReportNumberChoice(const int index, const int value) | ms_mascotoptions
setRequireBoldRed(const bool value) | ms_mascotoptions
setResfileCache(const char *value) | ms_mascotoptions
setResultsCache(const char *value) | ms_mascotoptions
setResultsFileFormatVersion(const char *value) | ms_mascotoptions
setResultsFullURL(const char *str) | ms_mascotoptions
setResultsFullURL_2(std::string value) | ms_mascotoptions
setResultsPerlScript(const char *str) | ms_mascotoptions
setResultsPerlScript_2(std::string value) | ms_mascotoptions
setReviewColDisplay(const MS_REVIEW_COL index, const bool value) | ms_mascotoptions
setReviewColWidth(const MS_REVIEW_COL index, const int value) | ms_mascotoptions
setSaveEveryLastQueryAsc(const bool flag) | ms_mascotoptions
setSaveLastQueryAsc(const bool flag) | ms_mascotoptions
setSearchLogFile(const char *str) | ms_mascotoptions
setSearchSubmitMode(const std::string value) | ms_mascotoptions
setSectionAvailable(const bool value) | ms_mascotoptions
setSelectSwitch(const int value) | ms_mascotoptions
setSendmailPath(const char *str) | ms_mascotoptions
setSeparateLockMem(const int value) | ms_mascotoptions
setShowAllFromErrorTolerant(const bool value) | ms_mascotoptions
setShowSubsets(const bool value) | ms_mascotoptions
setShowSubsets(const double value) | ms_mascotoptions
setSigThreshold(const double value) | ms_mascotoptions
setSiteAnalysisMD10Prob(const double value) | ms_mascotoptions
setSortUnassigned(const std::string newValue) | ms_mascotoptions
setSpectraPerLibraryBlock(const int value) | ms_mascotoptions
setSpectrumViewerColourSchemeString(const std::string &name, const std::string &str, bool doCheck=true) | ms_mascotoptions
setSpectrumViewerDefaultColourSchemeName(const std::string &name) | ms_mascotoptions
setSplitDataFileSize(const int value) | ms_mascotoptions
setSplitNumberOfQueries(const int value) | ms_mascotoptions
setStoreModPermutations(const bool value) | ms_mascotoptions
setSVGSpectrumSwitch(const int value) | ms_mascotoptions
setTargetFDRPercentage(const int index, const double value, const bool makeDefault=false) | ms_mascotoptions
setTaxBrowserUrl(const std::string value) | ms_mascotoptions
setTestDirectory(const char *str) | ms_mascotoptions
setUniqueJobStartNumber(const int value) | ms_mascotoptions
setUnixDirPerm(const int value) | ms_mascotoptions
setUnixWebUserGroup(const int value) | ms_mascotoptions
setUseHTTPProxyForFTP(const bool value) | ms_mascotoptions
setUseHTTPProxyForHTTPS(const bool value) | ms_mascotoptions
setVmemory(const INT64 value) | ms_mascotoptions
~ms_customproperty() | ms_customproperty
~ms_mascotoptions() | ms_mascotoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:24


ms_mascotresfile Member List

This is the complete list of members for ms_mascotresfile, including all inherited members.
anyMSMS() const | ms_mascotresfile |
anyPeptideSummaryMatches(const section sec=SEC_PEPTIDES) const | ms_mascotresfile |
anyPMF() const | ms_mascotresfile |
anySQ() const | ms_mascotresfile |
anyTag() const | ms_mascotresfile |
appendErrors(ms_errs &errs) | ms_mascotresfile |
matrix_science::ms_errors::appendErrors(const ms_errors &src) | ms_errors |
appendResfile(const char *filename, int flags=RESFILE_USE_PARENT_PARAMS, const char *cacheDirectory=0) | ms_mascotresfile |
clearAllErrors() | ms_errors |
copyFrom(const ms_errors *right) | ms_errors |
doesSectionExist(const section sec) const | ms_mascotresfile |
enumerateQuerySectionKeys(const int query, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const | ms_mascotresfile |
enumerateSectionKeys(const section sec, const int num, int *pPreviousNum=0, OFFSET64_T *pPreviousOffset=0) const | ms_mascotresfile |
err enum name | ms_mascotresfile |
ERR_ACCINPEPTIDESTR enum value | ms_mascotresfile |
ERR_ADDPEPTIDES enum value | ms_mascotresfile |
ERR_CANNOT_APPEND_RESFILE enum value | ms_mascotresfile |
ERR_CANNOT_APPEND_RESFILE_NO_FNAMES enum value | ms_mascotresfile |
ERR_CDB_64_BIT_REMAKE enum value | ms_mascotresfile |
ERR_CDB_BEING_CREATED enum value | ms_mascotresfile |
ERR_CDB_FAIL_LOCK enum value | ms_mascotresfile |
ERR_CDB_FAIL_REMOVE enum value | ms_mascotresfile |
ERR_CDB_FAIL_UNLOCK enum value | ms_mascotresfile |
ERR_CDB_INCOMPLETE_NO_RETRY enum value | ms_mascotresfile |
ERR_CDB_INCOMPLETE_RETRY enum value | ms_mascotresfile |
ERR_CDB_OLD_VER_NO_RETRY enum value | ms_mascotresfile |
ERR_CDB_OLD_VER_RETRY enum value | ms_mascotresfile |
ERR_CDB_SOURCE_CHANGE_NO_RETRY enum value | ms_mascotresfile |
ERR_CDB_SOURCE_CHANGE_RETRY enum value | ms_mascotresfile |
ERR_CDB_TOO_LARGE enum value | ms_mascotresfile |
ERR_DUPE_ACCESSION enum value | ms_mascotresfile |
ERR_DUPLICATE_KEY enum value | ms_mascotresfile |
ERR_FAIL_CDB_INIT enum value | ms_mascotresfile |
ERR_FAIL_CLOSE_FILE enum value | ms_mascotresfile |
ERR_FAIL_MK_CACHE_DIR enum value | ms_mascotresfile |
ERR_FAIL_MK_CDB_FILE enum value | ms_mascotresfile |
ERR_FAIL_OPEN_DAT_FILE enum value | ms_mascotresfile |
ERR_INVALID_CACHE_DIR enum value | ms_mascotresfile |
ERR_INVALID_CDB_FILE enum value | ms_mascotresfile |
ERR_INVALID_NUMQUERIES enum value | ms_mascotresfile |
ERR_INVALID_PROTDB enum value | ms_mascotresfile |
ERR_INVALID_RESFILE enum value | ms_mascotresfile |
ERR_MALFORMED_DRANGE enum value | ms_mascotresfile |
ERR_MALFORMED_ERR_TOL enum value | ms_mascotresfile |
ERR_MALFORMED_TAG enum value | ms_mascotresfile |
ERR_MALFORMED_TERMS enum value | ms_mascotresfile |
ERR_MISSING_CDB_FILE enum value | ms_mascotresfile |
ERR_MISSING_PERCOLATOR_FILE enum value | ms_mascotresfile |
ERR_MISSINGENTRY enum value | ms_mascotresfile |
ERR_MISSINGHIT enum value | ms_mascotresfile |
ERR_MISSINGSECTION enum value | ms_mascotresfile |
ERR_MISSINGSECTIONEND enum value | ms_mascotresfile |
ERR_NEED_64_BIT enum value | ms_mascotresfile |
ERR_NO_ERR_TOL_PARENT enum value | ms_mascotresfile |
ERR_NO_ERROR enum value | ms_mascotresfile |
ERR_NO_UNIGENE_FILE enum value | ms_mascotresfile |
ERR_NOMEM enum value | ms_mascotresfile |
ERR_NOSUCHFILE enum value | ms_mascotresfile |
ERR_NULL_ACC_PEP_SUM enum value | ms_mascotresfile |
ERR_NULL_ACC_PROT_SUM enum value | ms_mascotresfile |
ERR_OLDRESULTSFILE enum value | ms_mascotresfile |
ERR_PEPSUMMPEPGET enum value | ms_mascotresfile |
ERR_PEPTIDESTR enum value | ms_mascotresfile |
ERR_PROTSUMM enum value | ms_mascotresfile |
ERR_PROTSUMMPEP enum value | ms_mascotresfile |
ERR_QUERYOUTOFRANGE enum value | ms_mascotresfile |
ERR_READINGFILE enum value | ms_mascotresfile |
ERR_RESULTS_NOT_CREATED enum value | ms_mascotresfile |
ERR_UNASSIGNED_PROG enum value | ms_mascotresfile |
ERR_UNASSIGNED_RANGE enum value | ms_mascotresfile |
ERR_UNASSIGNED_UNK enum value | ms_mascotresfile |
ERR_UNIGENE_MULTIDB enum value | ms_mascotresfile |
ERR_WRITE_CDB_FILE enum value | ms_mascotresfile |
FLAGS enum name | ms_mascotresfile |
get_ms_mascotresults_params(const ms_mascotoptions &opts, unsigned int *gpFlags, double *gpMinProbability, int *gpMaxHitsToReport, double *gpIgnoreIonsScoreBelow, unsigned int *gpMinPepLenInPepSummary, bool *gpUsePeptideSummary, unsigned int *gpFlags2) const | ms_mascotresfile |
get_ms_mascotresults_params(const ms_mascotoptions &opts, ms_mascotresults_params &params) const | ms_mascotresfile |
getCacheDirectory(bool processed=true) const | ms_mascotresfile |
getCacheFileName() const | ms_mascotresfile |
getCrosslinkingMethod(ms_crosslinking_method *method) const | ms_mascotresfile |
getDatabaseType(const int idx) const | ms_mascotresfile |
getDate() const | ms_mascotresfile | [inline]
getDecoyTypeForDB(const int idx=1) const | ms_mascotresfile |
getEnzyme(ms_enzymefile *efile, const char *enzymeFileName=0) const | ms_mascotresfile |
getErrorHandler() const | ms_errors |
getErrorNumber(const int num=-1) const | ms_mascotresfile |
getErrorString(const int num) const | ms_mascotresfile |
getExecTime() const | ms_mascotresfile | [inline]
getFastaPath(int idx=1) const | ms_mascotresfile |
getFastaVer(int idx=1) const | ms_mascotresfile |
getFileName(const int id=1) const | ms_mascotresfile |
getJobNumber(const int resfileID=1) const | ms_mascotresfile |
getKeepAlive(KA_TASK &kaTask, int &kaPercentage, std::string &kaAccession, int &kaHit, int &kaQuery, std::string &kaText) const | ms_mascotresfile |
getLastError() const | ms_mascotresfile |
getLastErrorString() const | ms_mascotresfile |
getMascotVer() const | ms_mascotresfile | [inline]
getMasses(ms_masses *masses) const | ms_mascotresfile |
getMonoLinkModification(const int modNum, const int monoLink) const | ms_mascotresfile |
getMSParserVersion() const | ms_mascotresfile |
getMultiFileQueryNumber(const int localQuery, const int fileId) const | ms_mascotresfile |
getNumberOfErrors() const | ms_mascotresfile |
getNumberOfResfiles() const | ms_mascotresfile |
getNumEtSeqsSearched(const int idx=0) const | ms_mascotresfile |
getNumHits(const section sec=SEC_SUMMARY) const | ms_mascotresfile |
getNumLibraryEntries(const int idx=0) const | ms_mascotresfile |
getNumQueries(const int resfileID=0) const | ms_mascotresfile |
getNumResidues(const int idx=0) const | ms_mascotresfile |
getNumSeqs(const int idx=0) const | ms_mascotresfile |
getNumSeqsAfterTax(const int idx=0) const | ms_mascotresfile |
getObservedCharge(const int query, const bool decoy=false) const | ms_mascotresfile |
getObservedIntensity(const int query) const | ms_mascotresfile |
getObservedMass(const int query) const | ms_mascotresfile |
getObservedMrValue(const int query, const bool decoy=false) const | ms_mascotresfile |
getPercolatorFileNames() const | ms_mascotresfile |
getProgressInfo(bool forPeptideSummary=false) const | ms_mascotresfile |
getQuantitation(ms_quant_configfile *qfile) const | ms_mascotresfile |
getQuantitationMethod(ms_quant_method *qmethod) const | ms_mascotresfile |
getQuerySectionValue(const int query, const char *key, char *str, int maxLen) const | ms_mascotresfile |
getQuerySectionValueDouble(const int query, const char *key) const | ms_mascotresfile |
getQuerySectionValueInt(const int query, const char *key) const | ms_mascotresfile |
getQuerySectionValueStr(const int query, const char *key) const | ms_mascotresfile |
getReferenceDatabaseNumberOfSL(const int idx) const | ms_mascotresfile |
getRepeatSearchString(const int query, const bool fullQuery=false) const | ms_mascotresfile |
getResfile(int id) const | ms_mascotresfile |
getSectionName(const section sec) | ms_mascotresfile | [static]
getSectionValue(const section sec, const char *key, char *str, int maxLen) const | ms_mascotresfile |
getSectionValueDouble(const section sec, const char *key) const | ms_mascotresfile |
getSectionValueInt(const section sec, const char *key) const | ms_mascotresfile |
getSectionValueStr(const section sec, const char *key) const | ms_mascotresfile |
getSLDatabaseNumbersOfReference(const int idx) const | ms_mascotresfile |
getSLFragmentTolerance(int idx=1) const | ms_mascotresfile |
getSLFragmentToleranceUnit(int idx=1) const | ms_mascotresfile |
getSrcQueryAndFileIdForMultiFile(const int q, int &gsqNewQuery, int &gsqFileId) const | ms_mascotresfile |
getTaxonomy(ms_taxonomyfile *tfile) const | ms_mascotresfile |
getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const | ms_mascotresfile |
getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile=false) const | ms_mascotresfile |
getUniqueTaskID() const | ms_mascotresfile |
getXMLschemaFilePath(XML_SCHEMA XMLschema) const | ms_mascotresfile |
isDatabaseTypeAvailable() const | ms_mascotresfile |
isErrorTolerant() const | ms_mascotresfile |
isMSMS() const | ms_mascotresfile |
isPMF() const | ms_mascotresfile |
isSQ() const | ms_mascotresfile |
isValid() const | ms_errors |
KA_ASSIGNPROTEINS_AP enum value | ms_mascotresfile |
KA_CREATECACHE_CC enum value | ms_mascotresfile |
KA_CREATEINDEX_CI enum value | ms_mascotresfile |
KA_GROUPPROTEINS_GP enum value | ms_mascotresfile |
KA_LAST enum value | ms_mascotresfile |
KA_QUANTITATION enum value | ms_mascotresfile |
KA_READFILE_RF enum value | ms_mascotresfile |
KA_TASK enum name | ms_mascotresfile |
KA_THRESHFORFDR_FDR enum value | ms_mascotresfile |
KA_UNASSIGNEDLIST_UL enum value | ms_mascotresfile |
ms_errors() | ms_errors |
ms_mascotresfile(const char *szFileName, const int keepAliveInterval=0, const char *keepAliveText="<!-- %d seconds -->\n", const unsigned int flags=RESFILE_NOFLAG, const char *cacheDirectory="../data/cache/%Y/%m", const char *XMLschemaDirectory=0, ms_progress_info *progressMonitor=0) | ms_mascotresfile |
outputKeepAlive() const | ms_mascotresfile |
params() const | ms_mascotresfile | [inline]
PERCOLATOR_FILE_NAMES enum name | ms_mascotresfile |
PERCOLATOR_INPUT_FILE enum value | ms_mascotresfile |
PERCOLATOR_OUTPUT_DECOY enum value | ms_mascotresfile |
PERCOLATOR_OUTPUT_TARGET enum value | ms_mascotresfile |
resetKeepAlive(const int keepAliveInterval, const char *keepAliveText, const bool propagateToAppended=true, const bool resetStartTime=false) | ms_mascotresfile |
RESFILE_CACHE_IGNORE_ACC_DUPES enum value | ms_mascotresfile |
RESFILE_CACHE_IGNORE_DATE_CHANGE enum value | ms_mascotresfile |
RESFILE_NOFLAG enum value | ms_mascotresfile |
RESFILE_USE_CACHE enum value | ms_mascotresfile |
RESFILE_USE_PARENT_PARAMS enum value | ms_mascotresfile |
SEC_CROSSLINK_PEPTIDES enum value | ms_mascotresfile |
SEC_CROSSLINK_SUMMARY enum value | ms_mascotresfile |
SEC_CROSSLINKING enum value | ms_mascotresfile |
SEC_DECOYMIXTURE enum value | ms_mascotresfile |
SEC_DECOYPEPTIDES enum value | ms_mascotresfile |
SEC_DECOYPROTEINS enum value | ms_mascotresfile |
SEC_DECOYSUMMARY enum value | ms_mascotresfile |
SEC_ENZYME enum value | ms_mascotresfile |
SEC_ERRTOLDECOYPEPTIDES enum value | ms_mascotresfile |
SEC_ERRTOLDECOYSUMMARY enum value | ms_mascotresfile |
SEC_ERRTOLPEPTIDES enum value | ms_mascotresfile |
SEC_ERRTOLSUMMARY enum value | ms_mascotresfile |
SEC_HEADER enum value | ms_mascotresfile |
SEC_INDEX enum value | ms_mascotresfile |
SEC_LIBRARYPEPTIDES enum value | ms_mascotresfile |
SEC_LIBRARYSUMMARY enum value | ms_mascotresfile |
SEC_MASSES enum value | ms_mascotresfile |
SEC_MIXTURE enum value | ms_mascotresfile |
SEC_NUMSECTIONS enum value | ms_mascotresfile |
SEC_PARAMETERS enum value | ms_mascotresfile |
SEC_PEPTIDES enum value | ms_mascotresfile |
SEC_PROTEINS enum value | ms_mascotresfile |
SEC_QUANTITATION enum value | ms_mascotresfile |
SEC_QUERY1 enum value | ms_mascotresfile |
SEC_SPECTRAL_LIBRARY enum value | ms_mascotresfile |
SEC_SUMMARY enum value | ms_mascotresfile |
SEC_TAXONOMY enum value | ms_mascotresfile |
SEC_UNIMOD enum value | ms_mascotresfile |
SEC_UNIMOD_XL enum value | ms_mascotresfile |
section enum name | ms_mascotresfile |
setPercolatorFeatures(const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes) | ms_mascotresfile |
setPercolatorFeatures(const ms_mascotoptions &options, const char *additionalFeatures) | ms_mascotresfile |
setXMLschemaFilePath(XML_SCHEMA XMLschema, const char *path) | ms_mascotresfile |
staticGetPercolatorFileNames(const char *szDatFileName, const char *cacheDirectory, const char *percolatorFeatures, const char *additionalFeatures, const bool useRetentionTimes, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfile | [static]
staticGetPercolatorFileNames(const char *szDatFileName, const char *cacheDirectory, const ms_mascotoptions &options, const char *additionalFeatures, std::vector< std::string > &filenames, std::vector< bool > &exists) | ms_mascotresfile | [static]
versionGreaterOrEqual(int major, int minor, int revision) const | ms_mascotresfile |
willCreateCache(const char *szFileName, const unsigned int flags, const char *cacheDirectory, std::string *cacheFileName) | ms_mascotresfile | [static]
willCreateCache(const char *szFileName, const ms_mascotoptions &opts, const char *applicationName, std::string &resfileCacheFileName, unsigned int &cacheStatus) | ms_mascotresfile | [static]
XML_SCHEMA enum name | ms_mascotresfile |
XML_SCHEMA_CROSSLINKING enum value | ms_mascotresfile |
XML_SCHEMA_DIRECTORY enum value | ms_mascotresfile |
XML_SCHEMA_LAST enum value | ms_mascotresfile |
XML_SCHEMA_QUANTITATION enum value | ms_mascotresfile |
XML_SCHEMA_UNIMOD enum value | ms_mascotresfile |
~ms_errors() | ms_errors |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_mascotresults Member List

This is the complete list of members for ms_mascotresults, including all inherited members.
anyEmPAI() const | ms_mascotresults | [virtual]
anyNumDiscoveredMods() const | ms_mascotresults | [virtual]
cancelCreateSummary(bool newValue=true) | ms_mascotresults |
createSummary() | ms_mascotresults | [virtual]
createUnassignedList(sortBy s=QUERY) | ms_mascotresults |
DB_MATCH_TYPE enum name | ms_mascotresults |
DECOY_STATS_COUNT_TYPE enum name | ms_mascotresults |
DM_BOTH enum value | ms_mascotresults |
DM_FASTA enum value | ms_mascotresults |
DM_FASTA_FIRST_PASS enum value | ms_mascotresults |
DM_FASTA_SECOND_PASS enum value | ms_mascotresults |
DM_SPECTRAL_LIBRARY enum value | ms_mascotresults |
DS_COUNT_PSM enum value | ms_mascotresults |
DS_COUNT_SEQUENCE enum value | ms_mascotresults |
FC_ALL_PEPTIDES enum value | ms_mascotresults |
FC_ALL_PEPTITDES enum value | ms_mascotresults |
FC_CASE_INSENSITIVE enum value | ms_mascotresults |
FC_CASE_SENSITIVE enum value | ms_mascotresults |
FC_COMPLETESTR enum value | ms_mascotresults |
FC_FORWARD enum value | ms_mascotresults |
FC_LOOP_FROM_UNASSIGNED enum value | ms_mascotresults |
FC_LOOP_INTO_UNASSIGNED enum value | ms_mascotresults |
FC_MASK_CASE enum value | ms_mascotresults |
FC_MASK_DIRECTION enum value | ms_mascotresults |
FC_MASK_STR_PART enum value | ms_mascotresults |
FC_PROTEIN_IGN_FAMILY enum value | ms_mascotresults |
FC_PROTEIN_IGN_MASK enum value | ms_mascotresults |
FC_PROTEIN_IGN_SAMESETS enum value | ms_mascotresults |
FC_PROTEIN_IGN_SUBSETS enum value | ms_mascotresults |
FC_PROTEIN_INC_ALT_ACC enum value | ms_mascotresults |
FC_RESTRICT_TO_HIT enum value | ms_mascotresults |
FC_REVERSE enum value | ms_mascotresults |
FC_SCORING_MASK enum value | ms_mascotresults |
FC_SEARCH_ALL_RANKS enum value | ms_mascotresults |
FC_SEARCH_IGNORED_RANKS enum value | ms_mascotresults |
FC_SIGNIFICANT_PEPTIDES enum value | ms_mascotresults |
FC_STARTSTR enum value | ms_mascotresults |
FC_STRTOK enum value | ms_mascotresults |
FC_SUBSTR enum value | ms_mascotresults |
FC_UNASSIGNED_MASK enum value | ms_mascotresults |
FIND_COMPARE_FLAGS enum name | ms_mascotresults |
FIND_FLAGS enum name | ms_mascotresults |
findPeptides(const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const =0 | ms_mascotresults | [pure virtual]
findProteins(const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0 | ms_mascotresults | [pure virtual]
findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0 | ms_mascotresults | [pure virtual]
findProteinsByDescription(const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const =0 | ms_mascotresults | [pure virtual]
FLAGS enum name | ms_mascotresults |
freeHit(const int hit) | ms_mascotresults | [virtual]
FT_PEPTIDE_CALC_MR enum value | ms_mascotresults |
FT_PEPTIDE_CALC_MZ enum value | ms_mascotresults |
FT_PEPTIDE_ETMOD enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MR enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MZ enum value | ms_mascotresults |
FT_PEPTIDE_FIND_MASK enum value | ms_mascotresults |
FT_PEPTIDE_FIXMOD enum value | ms_mascotresults |
FT_PEPTIDE_QUERY enum value | ms_mascotresults |
FT_PEPTIDE_SLMOD enum value | ms_mascotresults |
FT_PEPTIDE_STRING enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD_BYNAME enum value | ms_mascotresults |
FT_PROTEIN_ACCESSION enum value | ms_mascotresults |
FT_PROTEIN_DESCRIPTION enum value | ms_mascotresults |
getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const =0 | ms_mascotresults | [pure virtual]
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const =0 | ms_mascotresults | [pure virtual]
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const =0 | ms_mascotresults | [pure virtual]
getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const =0 | ms_mascotresults | [pure virtual]
getComponentProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | [virtual]
getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0 | ms_mascotresults | [pure virtual]
getCreateSummaryProgress(int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const | ms_mascotresults |
getDiscoveredErrTolModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | [virtual]
getDiscoveredErrTolModNames() const | ms_mascotresults | [virtual]
getDiscoveredLocalModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | [virtual]
getDiscoveredLocalModNames() const | ms_mascotresults | [virtual]
getErrTolModDelta(const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const | ms_mascotresults | [virtual]
getErrTolModMasterNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModMasterString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getErrTolModName(const int q, const int p, std::string *modString=NULL) const | ms_mascotresults | [virtual]
getErrTolModNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModPepNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModPepString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getErrTolModReqPepNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModReqPepString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getErrTolModSlaveNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModSlaveString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getErrTolModString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getErrTolProbabilityThreshold() const | ms_mascotresults | [virtual]
getFlags() const | ms_mascotresults | [inline]
getFlags2() const | ms_mascotresults | [inline]
getHit(const int hit, const int memberNumber=0) const | ms_mascotresults | [virtual]
getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const | ms_mascotresults | [virtual]
getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getIonsScore(const int q, const int p, const bool decoy) const =0 | ms_mascotresults | [pure virtual]
getIonsScoreCorrected(const double ionsScore, const long multiplicity) const | ms_mascotresults | [protected]
getIonsScoreHistogram(IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getLibraryModString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getMaxRankValue() const | ms_mascotresults | [virtual]
getMinPepLenInPepSummary() const | ms_mascotresults |
getNextFamilyProtein(const int masterHit, const int id) const | ms_mascotresults | [virtual]
getNextSimilarProtein(const int masterHit, const int id) const | ms_mascotresults | [virtual]
getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | [virtual]
getNextSubsetProtein(const int masterHit, const int id, const bool searchWholeFamily=true) const | ms_mascotresults | [virtual]
getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | [virtual]
getNumberOfFamilyMembers() const | ms_mascotresults | [virtual]
getNumberOfHits() const | ms_mascotresults | [virtual]
getNumberOfUnassigned() const | ms_mascotresults |
getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumDiscoveredErrTolMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredFixedMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredIntactLinks(std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const | ms_mascotresults |
getNumDiscoveredLibraryMods(const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults |
getNumDiscoveredLocalMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredNonSpecCleavage() const | ms_mascotresults | [virtual]
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const | ms_mascotresults | [virtual]
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getPepIdentThreshProtected(const int query, double OneInXprobRnd, ms_mascotresfile::section sec, DB_MATCH_TYPE dbType, double *pQmatch=0) const | ms_mascotresults | [protected, virtual]
getPepsWithSameScore(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getPeptide(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getPeptide(const int q, const int p, ms_peptide *&pep) const =0 | ms_mascotresults | [pure virtual]
getPeptideExpectationValue(const double score, const int query, const int rank=0) const | ms_mascotresults | [virtual]
getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const | ms_mascotresults |
getProbabilityThreshold() const | ms_mascotresults | [virtual]
getProbFromScore(const double score) const | ms_mascotresults | [virtual]
getProbOfPepBeingRandomMatch(const double score, const int query) const | ms_mascotresults | [virtual]
getProbOfProteinBeingRandomMatch(const double score) const | ms_mascotresults | [virtual]
getProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | [virtual]
getProteinDescription(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinEmPAI(const char *accession, const int dbIdx=1, const int length=-1) const | ms_mascotresults | [virtual]
getProteinExpectationValue(const double score) const | ms_mascotresults | [virtual]
getProteinMass(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinScoreCutoff(double OneInXprobRnd) const =0 | ms_mascotresults | [pure virtual]
getProteinScoreForHistogram(const int num) const | ms_mascotresults | [virtual]
getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false)=0 | ms_mascotresults | [pure virtual]
getProteinTaxonomyIDs(const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const | ms_mascotresults |
getProteinThreshold(double OneInXprobRnd) const | ms_mascotresults | [virtual]
getQmatch(const int query) const | ms_mascotresults | [virtual]
getQmatch(const int query, const ms_mascotresfile::section sec) const | ms_mascotresults | [virtual]
getQuantitationComponentForPeptide(const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const =0 | ms_mascotresults | [pure virtual]
getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_mascotresults | [virtual]
getResfile() const | ms_mascotresults |
getResultsParameters() | ms_mascotresults |
getSequenceMass(const char *seq) const | ms_mascotresults |
getTagDeltaRangeEnd(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getTagDeltaRangeStart(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getTagEnd(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagSeries(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagStart(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagString(const int q, const int p) const =0 | ms_mascotresults | [pure virtual]
getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const =0 | ms_mascotresults | [pure virtual]
getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getToleranceInDalton(bool &needMass, const double *const pMass=NULL) const | ms_mascotresults |
getTreeClusterNodes(const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const | ms_mascotresults | [virtual]
getUnassigned(const int num) const | ms_mascotresults |
getUnassignedIsBold(const int num) const | ms_mascotresults |
getUnassignedShowCheckbox(const int num) const | ms_mascotresults |
HOMOLOGY_THRESHOLD_SOURCE enum name | ms_mascotresults |
HOMTHR_FASTA enum value | ms_mascotresults |
HOMTHR_SL enum value | ms_mascotresults |
IH_INCLUDE_TOP_10_MATCHES enum value | ms_mascotresults |
IH_INCLUDE_TOP_MATCHES enum value | ms_mascotresults |
INTENSITY enum value | ms_mascotresults |
IONS_HISTOGRAM enum name | ms_mascotresults |
isEmPAIallowed() const | ms_mascotresults |
isNA() const | ms_mascotresults |
isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const =0 | ms_mascotresults | [pure virtual]
ms_mascotresults(const ms_mascotresfile &resfile, const ms_mascotresults_params &params) | ms_mascotresults |
MSRES_CLUSTER_PROTEINS enum value | ms_mascotresults |
MSRES_DECOY enum value | ms_mascotresults |
MSRES_DUPE_DEFAULT enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_A enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_B enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_C enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_D enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_E enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_F enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_G enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_H enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_I enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_NONE enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_A enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_B enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_C enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_D enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_E enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_F enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_G enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_H enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_I enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_NONE enum value | ms_mascotresults |
MSRES_ERR_TOL enum value | ms_mascotresults |
MSRES_GROUP_PROTEINS enum value | ms_mascotresults |
MSRES_IGNORE_PMF_MIXTURE enum value | ms_mascotresults |
MSRES_INTEGRATED_ERR_TOL enum value | ms_mascotresults |
MSRES_MAXHITS_OVERRIDES_MINPROB enum value | ms_mascotresults |
MSRES_MUDPIT_PROTEIN_SCORE enum value | ms_mascotresults |
MSRES_NOFLAG enum value | ms_mascotresults |
MSRES_REQUIRE_BOLD_RED enum value | ms_mascotresults |
MSRES_SHOW_ALL_FROM_ERR_TOL enum value | ms_mascotresults |
MSRES_SHOW_SUBSETS enum value | ms_mascotresults |
MSRES_SUBSETS_DIFF_PROT enum value | ms_mascotresults |
QCS_ERROR_BAD_COMPONENT_NAME enum value | ms_mascotresults |
QCS_ERROR_NO_COMPONENTS enum value | ms_mascotresults |
QCS_ERROR_NO_METHOD enum value | ms_mascotresults |
QCS_OK enum value | ms_mascotresults |
QCS_OK_MULTIPLE_MATCHES enum value | ms_mascotresults |
QCS_OK_NO_MATCH enum value | ms_mascotresults |
QUANT_COMPONENT_STATUS enum name | ms_mascotresults |
QUERY enum value | ms_mascotresults |
SCORE enum value | ms_mascotresults |
setSubsetsThreshold(const double scoreFraction) | ms_mascotresults | [virtual]
sortBy enum name | ms_mascotresults |
TCM_PAIRWISE_AVERAGE enum value | ms_mascotresults |
TCM_PAIRWISE_MAXIMUM enum value | ms_mascotresults |
TCM_PAIRWISE_SINGLE enum value | ms_mascotresults |
THRESHOLD_TYPE enum name | ms_mascotresults |
TREE_CLUSTER_METHOD enum name | ms_mascotresults |
TT_HOMOLOGY enum value | ms_mascotresults |
TT_IDENTITY enum value | ms_mascotresults |
TT_PEPSUM_DEFAULT enum value | ms_mascotresults |
UNIQUE_PEP_RULES enum name | ms_mascotresults |
UPR_DEFAULT enum value | ms_mascotresults |
UPR_IGNORE_SUBSET_PROTEINS enum value | ms_mascotresults |
UPR_WITHIN_FAMILY enum value | ms_mascotresults |
UPR_WITHIN_FAMILY_MEMBER enum value | ms_mascotresults |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_mascotresults_params Member List

This is the complete list of members for ms_mascotresults_params, including all inherited members.
copyFrom(const ms_mascotresults_params *right) | ms_mascotresults_params
getFlags() const | ms_mascotresults_params
getFlags2() const | ms_mascotresults_params
getIgnoreIonsScoreBelow() const | ms_mascotresults_params
getMaxHitsToReport() const | ms_mascotresults_params
getMinNumSigUniqueSequences() const | ms_mascotresults_params
getMinPepLenInPeptideSummary() const | ms_mascotresults_params
getMinProbability() const | ms_mascotresults_params
getSingleHit() const | ms_mascotresults_params
getTargetFDR() const | ms_mascotresults_params
getTargetFDRType() const | ms_mascotresults_params
getUnigeneIndexFile() const | ms_mascotresults_params
isUsePeptideSummary() const | ms_mascotresults_params
ms_mascotresults_params(const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS, double minProbability=0.05, int maxHitsToReport=0, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=0) | ms_mascotresults_params
ms_mascotresults_params(const ms_mascotresults_params &src) | ms_mascotresults_params
operator=(const ms_mascotresults_params &right) | ms_mascotresults_params
setFlag(const ms_mascotresults::FLAGS flag, bool enabled) | ms_mascotresults_params
setFlag2(const ms_peptidesummary::MSPEPSUM flag, bool enabled) | ms_mascotresults_params
setFlags(const unsigned int flags) | ms_mascotresults_params
setFlags2(const unsigned int flags2) | ms_mascotresults_params
setIgnoreIonsScoreBelow(const double ignoreIonsScoreBelow) | ms_mascotresults_params
setMaxHitsToReport(const int maxHitsToReport) | ms_mascotresults_params
setMinNumSigUniqueSequences(const int n) | ms_mascotresults_params
setMinPepLenInPeptideSummary(const int minPepLenInPeptideSummary) | ms_mascotresults_params
setMinProbability(const double minProbability) | ms_mascotresults_params
setSingleHit(const char *singleHit) | ms_mascotresults_params
setTargetFDR(double fdr) | ms_mascotresults_params
setTargetFDRType(ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType) | ms_mascotresults_params
setUnigeneIndexFile(const char *unigeneIndexFile) | ms_mascotresults_params
setUsePeptideSummary(const bool usePeptideSummary) | ms_mascotresults_params
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_masses Member List

This is the complete list of members for ms_masses, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
applyFixedMods(const ms_modvector *mods, ms_errs *err) | ms_masses
applyIsotopes(const ms_umod_configfile *umodFile, const ms_quant_component *quantComp) | ms_masses
clearAllErrors() | ms_errors
copyFrom(const ms_masses *right) | ms_masses
copyFrom(const ms_umod_configfile *right, bool addMissingResidueMasses=true) | ms_masses
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues(bool useDefaultResidueMasses=true) | ms_masses
getCarbonMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getConnectionSettings() const | ms_masses
getCtermDelta(const matrix_science::MASS_TYPE massType) const | ms_masses
getCterminalMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getCtermNeutralLoss(const matrix_science::MASS_TYPE massType) const | ms_masses
getElectronMass() const | ms_masses
getErrorHandler() const | ms_errors
getFileName() const | ms_masses
getFragResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const | ms_masses
getHydrogenMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNitrogenMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getNtermDelta(const matrix_science::MASS_TYPE massType) const | ms_masses
getNterminalMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getNtermNeutralLoss(const matrix_science::MASS_TYPE massType) const | ms_masses
getOxygenMass(const matrix_science::MASS_TYPE massType) const | ms_masses
getResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const | ms_masses
isResidueModified(const char residue) const | ms_masses
isSame(const ms_masses &other, const MASS_TYPE massType) const | ms_masses
isValid() const | ms_errors
ms_errors() | ms_errors
ms_masses() | ms_masses
ms_masses(const ms_masses &src) | ms_masses
ms_masses(const ms_umod_configfile &src, bool addMissingResidueMasses=true) | ms_masses
ms_masses(const ms_umod_configfile &src, const ms_quant_component &quantComp) | ms_masses
ms_masses(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_masses
operator=(const ms_masses &right) | ms_masses
read_file() | ms_masses
save_file() | ms_masses
setCarbonMass(const double massMono, const double massAve) | ms_masses
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_masses
setCtermModification(const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0) | ms_masses
setElectronMass(const double mass) | ms_masses
setFileName(const char *name) | ms_masses
setHydrogenMass(const double massMono, const double massAve) | ms_masses
setNitrogenMass(const double massMono, const double massAve) | ms_masses
setNtermModification(const double monoDelta, const double aveDelta, const double monoNeutralLoss=0.0, const double aveNeutralLoss=0.0) | ms_masses
setOxygenMass(const double massMono, const double massAve) | ms_masses
setResidueMasses(const char residue, const double massMono, const double massAve) | ms_masses
setResidueModification(const double monoDelta, const double aveDelta, const double monoNeutralLoss, const double aveNeutralLoss, const char *residues) | ms_masses
~ms_errors() | ms_errors
~ms_masses() | ms_masses
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_matrix Member List

This is the complete list of members for ms_matrix, including all inherited members.
columnMatrix(const std::vector< double > &v) | ms_matrix | [static]
data() const | ms_matrix |
diagonalMatrix(size_t s, double v) | ms_matrix | [static]
getCR(size_t i, size_t j) const | ms_matrix |
getRC(size_t i, size_t j) const | ms_matrix | [inline]
identityMatrix(size_t s) | ms_matrix | [static]
isZero() const | ms_matrix |
logContents(ms_errs &errs, const char *description) const | ms_matrix |
ms_matrix() | ms_matrix |
ms_matrix(const matrix_t &m) | ms_matrix |
ms_matrix(size_t si, size_t sj, double v=0.0) | ms_matrix |
multiplyByRow(const std::vector< double > &column, size_t row) const | ms_matrix |
operator!=(const ms_matrix &m) const | ms_matrix |
operator*(const ms_matrix &m) const | ms_matrix |
operator==(const ms_matrix &m) const | ms_matrix |
operator[](size_t i) | ms_matrix |
operator[](size_t i) const | ms_matrix |
resize(size_t si, size_t sj, double v=0.0) | ms_matrix |
rowMatrix(const std::vector< double > &v) | ms_matrix | [static]
setColumnDown(size_t row, size_t col, const std::vector< double > &vec) | ms_matrix |
setColumnUp(size_t row, size_t col, const std::vector< double > &vec) | ms_matrix |
setCR(size_t i, size_t j, double value) | ms_matrix |
setRC(size_t i, size_t j, double value) | ms_matrix | [inline]
sizei() const | ms_matrix |
sizej() const | ms_matrix |
transpose() | ms_matrix |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_modfile Member List

This is the complete list of members for ms_modfile, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
appendModification(const ms_modification *item) | ms_modfile
clearAllErrors() | ms_errors
clearModifications() | ms_modfile
copyFrom(const ms_modfile *right) | ms_modfile
copyFrom(const ms_umod_configfile *right, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) | ms_modfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_modfile
deleteModificationByName(const char *name) | ms_modfile
deleteModificationByNumber(const int num) | ms_modfile
getConnectionSettings() const | ms_modfile
getErrorHandler() const | ms_errors
getFileName() const | ms_modfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMassFile() const | ms_modfile
getModificationByName(const char *nameMod) const | ms_modfile
getModificationByNumber(const int numMod) const | ms_modfile
getNumberOfModifications() const | ms_modfile
isFromSubstitutions() const | ms_modfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_modfile() | ms_modfile
ms_modfile(const ms_modfile &src) | ms_modfile
ms_modfile(const ms_umod_configfile &src, const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) | ms_modfile
ms_modfile(const char *filename, const ms_masses *massFile, const bool fromSubstitutions=false, const ms_connection_settings *cs=0) | ms_modfile
operator=(const ms_modfile &right) | ms_modfile
read_file() | ms_modfile
save_file() | ms_modfile
saveToString(std::string &modfileAsStr) | ms_modfile
setConnectionSettings(const ms_connection_settings &cs) | ms_modfile
setFileName(const char *name) | ms_modfile
setFromSubstitutions(const bool value) | ms_modfile
setMassFile(const ms_masses *massFile) | ms_modfile
sortModifications() | ms_modfile
updateModificationByName(const char *name, const ms_modification mod) | ms_modfile
updateModificationByNumber(const int num, const ms_modification mod) | ms_modfile
~ms_errors() | ms_errors
~ms_modfile() | ms_modfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_modification Member List

This is the complete list of members for ms_modification, including all inherited members.
appendIgnoreMass(const double massMono, const double massAve) | ms_modification
appendModifiedResidue(const char residue, const double massMono, const double massAve) | ms_modification
clearIgnoreMasses() | ms_modification
clearModifiedResidues() | ms_modification
copyFrom(const ms_modification *src) | ms_modification
copyMassFile(const ms_masses *massFile) | ms_modification
defaultValues() | ms_modification
getCode() const | ms_modification
getCTerminusMass(const MASS_TYPE massType) const | ms_modification
getDelta(const MASS_TYPE massType) const | ms_modification
getFromUnimod(const char *modName, const ms_umod_configfile *umod_file) | ms_modification
getIgnoreMass(const MASS_TYPE massType, const int idx) const | ms_modification
getMassFile() const | ms_modification
getModificationType() const | ms_modification
getModifiedResidue(const int n) const | ms_modification
getMonoLinkTitle() const | ms_modification
getNeutralLoss(const MASS_TYPE massType) const | ms_modification
getNeutralLossRequired() const | ms_modification
getNTerminusMass(const MASS_TYPE massType) const | ms_modification
getNumberOfIgnoreMasses() const | ms_modification
getNumberOfModifiedResidues() const | ms_modification
getPairsWith() const | ms_modification
getPepNeutralLoss(const MASS_TYPE massType) const | ms_modification
getPreceedingComments() const | ms_customproperty
getReqPepNeutralLoss(const MASS_TYPE massType) const | ms_modification
getResidueMass(const MASS_TYPE massType, const char residue) const | ms_modification
getTitle() const | ms_modification
inErrorTolerant() const | ms_modification
inLongList() const | ms_modification
inShortList() const | ms_modification
isGeneratedMonoLinker() const | ms_modification
isHidden() const | ms_modification
isLoopLinker() const | ms_modification
isResidueModified(const char residue) const | ms_modification
isSubstitution() const | ms_modification
ms_customproperty() | ms_customproperty
ms_modification(const ms_masses *massFile=NULL) | ms_modification
ms_modification(const ms_modification &src) | ms_modification
operator=(const ms_modification &right) | ms_modification
setCTerminusMass(const double massMono, const double massAve) | ms_modification
setDelta(const double massMono, const double massAve) | ms_modification
setHidden(const bool value) | ms_modification
setInErrorTolerant(const bool value) | ms_modification
setInLongList(const bool value) | ms_modification
setInShortList(const bool value) | ms_modification
setMassFile(const ms_masses *massFile) | ms_modification
setModificationType(const int type) | ms_modification
setNeutralLoss(const ms_vectorDouble massMono, const ms_vectorDouble massAve, const ms_vectorBool required) | ms_modification
setNTerminusMass(const double massMono, const double massAve) | ms_modification
setPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve) | ms_modification
setPreceedingComments(const std::string &comments) | ms_customproperty
setReqPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve) | ms_modification
setTitle(const char *value) | ms_modification
setTitleSource(const char *unimodName, const char *specString) | ms_modification
~ms_customproperty() | ms_customproperty
~ms_modification() | ms_modification
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_modvector Member List

This is the complete list of members for ms_modvector, including all inherited members.
appendModification(const ms_modification *item) | ms_modvector
appendModifications(ms_modvector &right) | ms_modvector
clearModifications() | ms_modvector
copyFrom(const ms_modvector *right) | ms_modvector
copyFrom(const ms_umod_modification *right, const ms_umod_configfile *umod_file) | ms_modvector
getModificationByName(const std::string &name) const | ms_modvector
getModificationByNumber(const int numMod) const | ms_modvector
getNumberOfModifications() const | ms_modvector
ms_modvector() | ms_modvector
ms_modvector(const ms_modvector &src) | ms_modvector
ms_modvector(const ms_umod_modification &src, const ms_umod_configfile &umod_file) | ms_modvector
operator=(const ms_modvector &right) | ms_modvector
~ms_modvector() | ms_modvector
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_average_results Member List

This is the complete list of members for ms_ms1quant_average_results, including all inherited members.
getReferenceHitId() const | ms_ms1quant_average_results
getReferenceMemberNumber() const | ms_ms1quant_average_results
isReferenceUserSelected() const | ms_ms1quant_average_results
ms_ms1quant_average_results() | ms_ms1quant_average_results
ms_ms1quant_average_results(const ms_ms1quant_average_results_body &body) | ms_ms1quant_average_results
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_charge_state Member List

This is the complete list of members for ms_ms1quant_charge_state, including all inherited members.
getBucket(int index, unsigned &scanId, double &area) const | ms_ms1quant_charge_state
getBucketWidth() const | ms_ms1quant_charge_state
getCorrectedMaxSPPwidth() const | ms_ms1quant_charge_state
getCorrectedMinSPPwidth() const | ms_ms1quant_charge_state
getCorrectedSPPwidth() const | ms_ms1quant_charge_state
getMatchedFraction() const | ms_ms1quant_charge_state
getMatchedRho() const | ms_ms1quant_charge_state
getMaxAlignment() const | ms_ms1quant_charge_state
getNumberOfBuckets() const | ms_ms1quant_charge_state
getTotalIntensity() const | ms_ms1quant_charge_state
ms_ms1quant_charge_state() | ms_ms1quant_charge_state
ms_ms1quant_charge_state(const ms_ms1quant_charge_state_body &body) | ms_ms1quant_charge_state
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_match Member List

This is the complete list of members for ms_ms1quant_match, including all inherited members.
addComponent(const matrix_science::ms_ms1quant_match_component &component) | ms_ms1quant_match |
addCreatedComponent(const std::string &componentName) | ms_ms1quant_match |
addCreatedComponent(const matrix_science::ms_ms1quant_match_component &component) | ms_ms1quant_match |
allComponentsIdentified() const | ms_ms1quant_match |
chargeType enum name | ms_ms1quant_match |
CHARGETYPE_ALL enum value | ms_ms1quant_match |
CHARGETYPE_ORIGINAL enum value | ms_ms1quant_match |
clearHitRatioExcluded(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
clearHitRatioOutlier(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
getChargeState() const | ms_ms1quant_match |
getChargeStateData() const | ms_ms1quant_match |
getChargeType() const | ms_ms1quant_match |
getCodeFromXml(std::string text) | ms_ms1quant_match | [static]
getComponent(int index) const | ms_ms1quant_match |
getComponent(std::string componentName) const | ms_ms1quant_match |
getConciseLabelFreeVarMods() const | ms_ms1quant_match |
getCorrectionMatrix() const | ms_ms1quant_match |
getDataSourceId() const | ms_ms1quant_match |
getDisplayIntensity() const | ms_ms1quant_match |
getFirstXicScanId() const | ms_ms1quant_match |
getHit(int index1) const | ms_ms1quant_match |
getKey() const | ms_ms1quant_match |
getLabelFreeVarMods() const | ms_ms1quant_match |
getLastXicScanId() const | ms_ms1quant_match |
getNumComponents() const | ms_ms1quant_match |
getNumHits() const | ms_ms1quant_match |
getNumPeptideRatios() const | ms_ms1quant_match |
getPeptideRatio(int index) const | ms_ms1quant_match |
getPeptideRatio(const std::string &ratioName) const | ms_ms1quant_match |
getPeptideString() const | ms_ms1quant_match |
getPerfectObservedMatrix() const | ms_ms1quant_match |
getPredictionMatrix() const | ms_ms1quant_match |
getReadableLabelFreeVarMods() const | ms_ms1quant_match |
getVarMods() const | ms_ms1quant_match |
getXmlCode(chargeType code) | ms_ms1quant_match | [static]
hasComponent(std::string componentName) const | ms_ms1quant_match |
hasIdentifiedComponent() const | ms_ms1quant_match |
hasPeptideRatio(const std::string &ratioName) const | ms_ms1quant_match |
isHitRatioExcluded(const std::string &ratioName, int hitId, int memberNumber) const | ms_ms1quant_match |
isHitRatioOutlier(const std::string &ratioName, int hitId, int memberNumber) const | ms_ms1quant_match |
isHitRatioUsedForAverage(const std::string &ratioName, int hitId, int memberNumber) const | ms_ms1quant_match |
ms_ms1quant_match() | ms_ms1quant_match |
ms_ms1quant_match(const ms_ms1quant_match_body &body) | ms_ms1quant_match |
removeComponent(const std::string &componentName) | ms_ms1quant_match |
setHitRatioExcluded(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
setHitRatioOutlier(const std::string &ratioName, int hitId, int memberNumber) | ms_ms1quant_match |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_match_component Member List

This is the complete list of members for ms_ms1quant_match_component, including all inherited members.
getAbsoluteValue() const | ms_ms1quant_match_component
getComponent() const | ms_ms1quant_match_component
getMoverz() const | ms_ms1quant_match_component
getNumPeptides() const | ms_ms1quant_match_component
getNumRanges() const | ms_ms1quant_match_component
getPeptideKey(int index, int &q, int &p) const | ms_ms1quant_match_component
getRange(int index) const | ms_ms1quant_match_component
getRelativeMass() const | ms_ms1quant_match_component
getSummedModsStr() const | ms_ms1quant_match_component
getVarModsStr() const | ms_ms1quant_match_component
getXic() const | ms_ms1quant_match_component
hasAbsoluteValue() const | ms_ms1quant_match_component
isComponentIdentified() const | ms_ms1quant_match_component
ms_ms1quant_match_component() | ms_ms1quant_match_component
ms_ms1quant_match_component(const ms_ms1quant_match_component_body &body) | ms_ms1quant_match_component
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_match_range Member List

This is the complete list of members for ms_ms1quant_match_range, including all inherited members.
extend(int scanId, double rt) | ms_ms1quant_match_range
getRt(double &start, double &end) const | ms_ms1quant_match_range
getScan(int &start, int &end) const | ms_ms1quant_match_range
ms_ms1quant_match_range() | ms_ms1quant_match_range
ms_ms1quant_match_range(const ms_ms1quant_match_range_body &body) | ms_ms1quant_match_range
ms_ms1quant_match_range(int scanId, double rt) | ms_ms1quant_match_range
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_match_ratio Member List

This is the complete list of members for ms_ms1quant_match_ratio, including all inherited members.
getCodeFromXml(std::string text) | ms_ms1quant_match_ratio | [static]
getCodeInfo(ratioStatusCode code, const ms_quant_method &method, double &info) | ms_ms1quant_match_ratio | [static]
getFitexy(ms_fitexy_result &value) const | ms_ms1quant_match_ratio |
getQuality() const | ms_ms1quant_match_ratio |
getRatioName() const | ms_ms1quant_match_ratio |
getStatus() const | ms_ms1quant_match_ratio |
getStatusList() const | ms_ms1quant_match_ratio |
getValue() const | ms_ms1quant_match_ratio |
getXmlCode(ratioStatusCode code) | ms_ms1quant_match_ratio | [static]
isIncluded() const | ms_ms1quant_match_ratio |
isSet() const | ms_ms1quant_match_ratio |
isUsedForAverage() const | ms_ms1quant_match_ratio |
isValid() const | ms_ms1quant_match_ratio |
ms_ms1quant_match_ratio() | ms_ms1quant_match_ratio |
ms_ms1quant_match_ratio(const ms_ms1quant_match_ratio_body &body) | ms_ms1quant_match_ratio |
ratioStatusCode enum name | ms_ms1quant_match_ratio |
RS_DO_NOT_USE enum value | ms_ms1quant_match_ratio |
RS_EMPTY enum value | ms_ms1quant_match_ratio |
RS_FITEXYSIGMA enum value | ms_ms1quant_match_ratio |
RS_INFINITERATIO enum value | ms_ms1quant_match_ratio |
RS_INTEFERENCEFAILED enum value | ms_ms1quant_match_ratio |
RS_ISOLATEDPRECURSORFAILED enum value | ms_ms1quant_match_ratio |
RS_NEGATIVERATIO enum value | ms_ms1quant_match_ratio |
RS_NODATA enum value | ms_ms1quant_match_ratio |
RS_OK enum value | ms_ms1quant_match_ratio |
RS_TOTALINTENSITYFAILED enum value | ms_ms1quant_match_ratio |
RS_ZERORATIO enum value | ms_ms1quant_match_ratio |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quant_peptide_status Member List

This is the complete list of members for ms_ms1quant_peptide_status, including all inherited members.
getCodeFromXml(std::string str) | ms_ms1quant_peptide_status | [static]
getComponent() const | ms_ms1quant_peptide_status |
getQuery() const | ms_ms1quant_peptide_status |
getRank() const | ms_ms1quant_peptide_status |
getStatus() const | ms_ms1quant_peptide_status |
getXmlCode(peptideStatus code) | ms_ms1quant_peptide_status | [static]
ms_ms1quant_peptide_status() | ms_ms1quant_peptide_status |
ms_ms1quant_peptide_status(const ms_ms1quant_peptide_status_body &body) | ms_ms1quant_peptide_status |
peptideStatus enum name | ms_ms1quant_peptide_status |
PS_DUPLICATESAMEQUERY enum value | ms_ms1quant_peptide_status |
PS_EXCLUDE_LOCALDEF enum value | ms_ms1quant_peptide_status |
PS_EXCLUDE_MODFILE enum value | ms_ms1quant_peptide_status |
PS_EXCLUDE_UNMODIFIED enum value | ms_ms1quant_peptide_status |
PS_EXPECTGREATERTHAN enum value | ms_ms1quant_peptide_status |
PS_LESSTHANIDENTITY enum value | ms_ms1quant_peptide_status |
PS_MAX enum value | ms_ms1quant_peptide_status |
PS_MINCHARGE enum value | ms_ms1quant_peptide_status |
PS_NOTPARTOFQUANTITATION enum value | ms_ms1quant_peptide_status |
PS_NOTUNIQUE enum value | ms_ms1quant_peptide_status |
PS_OK enum value | ms_ms1quant_peptide_status |
PS_SCORELESSHOMOLOGY enum value | ms_ms1quant_peptide_status |
PS_SCORELESSIDENTITY_NOHOMO enum value | ms_ms1quant_peptide_status |
PS_SCORELESSTHRESHOLD enum value | ms_ms1quant_peptide_status |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms1quantitation Member List

This is the complete list of members for ms_ms1quantitation, including all inherited members.
addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addMatchInferred(const ms_ms1quant_match &siblingMatch, int newCharge) | ms_ms1quantitation |
addMatchPeptide(matrix_science::ms_protein *hit, matrix_science::ms_peptide *peptide, const matrix_science::ms_quant_component &component, const std::string &matchBelongsToComponent) | ms_ms1quantitation |
addMatchStatus(matrix_science::ms_peptide *peptide, matrix_science::ms_ms1quant_peptide_status::peptideStatus status, matrix_science::ms_protein *hit=0) | ms_ms1quantitation |
addPeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const std::vector< ms_peptide_quant_key > &keys) | ms_customquantitation |
addPeptideQuantKeys(const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys) | ms_customquantitation |
addPeptideRatio(const ms_peptide_quant_ratio &ratio) | ms_customquantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
BUGFIX_12409 enum value | ms_ms1quantitation |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearPeptideQuantKeys(const std::string &accession, int dbIdx) | ms_customquantitation |
clearPeptideRatios() | ms_customquantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_ms1quantitation | [virtual]
matrix_science::ms_customquantitation::countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_quantitation | [virtual]
findMatch(matrix_science::ms_peptide_quant_key matchKey, ms_ms1quant_match *match) const | ms_ms1quantitation |
findPeptideStatus(int query, int rank, ms_ms1quant_peptide_status *peptideStatus) const | ms_ms1quantitation |
getAveragePeptideIntensity(const std::string &accession, int dbIdx, double *averageIntensity, int *sampleSize, ms_peptide_quant_key_vector *includeKeys, ms_peptide_quant_key_vector *excludeKeys) const | ms_ms1quantitation |
getAverageResults() const | ms_ms1quantitation |
getErrorHandler() const | ms_errors |
getHit(int index1) const | ms_ms1quantitation |
getLabelFree(std::string peptideStr, std::string varMods, std::string summedMods, const matrix_science::ms_quant_component &comp) const | ms_ms1quantitation |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMatch(int index) const | ms_ms1quantitation |
getMatch(const ms_peptide_quant_key &key) const | ms_ms1quantitation |
getMatchForHit(int index, int hitId, int memberNumber) const | ms_ms1quantitation |
getMinNumPeptides() const | ms_quantitation | [protected]
getNumGroups() const | ms_ms1quantitation |
getNumHits() const | ms_ms1quantitation |
getNumMatches() const | ms_ms1quantitation |
getNumMatchesForGroup(int groupIndex1) const | ms_ms1quantitation |
getNumMatchesForHit(int hitId, int memberNumber) const | ms_ms1quantitation |
getNumPeptideStatuses() const | ms_ms1quantitation |
getNumProteinFamilies() const | ms_ms1quantitation |
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | [virtual]
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getPeptideStatus(int index) const | ms_ms1quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const | ms_ms1quantitation | [virtual]
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const | ms_ms1quantitation | [virtual]
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | [protected]
getQuantitationDatasources() const | ms_ms1quantitation |
getQuantitationMethod() const | ms_quantitation |
getReadableVarMods(std::string varmods) | ms_ms1quantitation |
getReadableVarModsConcise(std::string varmods) | ms_ms1quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const | ms_customquantitation | [protected, virtual]
getSummary() const | ms_ms1quantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const | ms_customquantitation |
getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const | ms_customquantitation |
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | [virtual]
initGroupChargeStates(std::set< int > *calc_chargestates, int iGroup1, int minCharge, int maxCharge) | ms_ms1quantitation |
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | [protected]
isAverageProtocol() const | ms_ms1quantitation |
isDataCached(MS1QUANT_BUGFIX_NUM bugNum) const | ms_ms1quantitation |
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_customquantitation | [virtual]
isValid() const | ms_errors |
loadCdbFile(const std::string &cdbFilename, const std::string &cacheFilename, bool revalidateQualityThresholds=true) | ms_ms1quantitation |
loadXmlFile(const std::string &filename, const std::string &xmlSchemaPath) | ms_ms1quantitation |
MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE enum value | ms_ms1quantitation |
MERGE_QUANT_DEFAULT_PRECURSOR_METHOD enum value | ms_ms1quantitation |
MERGE_QUANT_DEFAULT_REPLICATE_METHOD enum value | ms_ms1quantitation |
MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH enum value | ms_ms1quantitation |
MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS enum value | ms_ms1quantitation |
MERGE_QUANT_RESULTS_FLAGS enum name | ms_ms1quantitation |
MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC enum value | ms_ms1quantitation |
mergeQuantitationResults(const std::vector< std::string > &cdbFilenames, const std::vector< std::string > &cacheFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation |
mergeQuantitationResults(const std::vector< std::string > &xmlFilenames, const MERGE_QUANT_RESULTS_FLAGS flags, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation |
MS1QUANT_BUGFIX_NUM enum name | ms_ms1quantitation |
ms_customquantitation(const ms_quant_method &qm) | ms_customquantitation | [explicit]
ms_customquantitation(const ms_peptidesummary &initFrom) | ms_customquantitation | [explicit]
ms_customquantitation(const ms_peptidesummary &initFrom, const ms_quant_method &qm) | ms_customquantitation |
ms_customquantitation(const ms_ms2quantitation &copyFrom) | ms_customquantitation | [explicit]
ms_errors() | ms_errors |
ms_ms1quantitation(const ms_peptidesummary &summary, const ms_quant_method &method) | ms_ms1quantitation |
openQuantitationCdbResults(const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &cdbFilename, const std::string &cacheFilename, const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation | [static]
openQuantitationXmlResults(const matrix_science::ms_peptidesummary &summary, const matrix_science::ms_quant_method &method, const std::string &filename, const std::string &xmlSchemaPath="", const matrix_science::ms_quant_method *originalMethod=0) | ms_ms1quantitation | [static]
proteinKeys_ | ms_quantitation | [protected]
readResultCounters(const std::string &cdbFile, int &numMatches, int &numHits, int &numPepGrp, int &numPeptideComponents) | ms_ms1quantitation | [static]
removeMatch(matrix_science::ms_peptide_quant_key matchKey) | ms_ms1quantitation |
removePeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key) | ms_customquantitation |
removePeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation |
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
saveCdbFile(const std::string &cdbFilename, const std::string &cacheFilename, bool createEmptyMissingComponents=false) | ms_ms1quantitation |
saveXmlFile(const std::string &xmlFilename, bool completeReport) | ms_ms1quantitation |
setAverageNumPeptides(unsigned int num=3) | ms_ms1quantitation |
setAverageReferenceProtein(const char *accession, int dbIdx, bool isReferenceUserSelected) | ms_ms1quantitation |
setAverageSelection(const char *value) | ms_ms1quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | [virtual]
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_customquantitation | [virtual]
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value) | ms_customquantitation | [virtual]
setQuantOutliers(const ms_quant_outliers *) | ms_customquantitation | [virtual]
~ms_customquantitation() | ms_customquantitation | [virtual]
~ms_errors() | ms_errors |
~ms_quantitation()=0 | ms_quantitation | [pure virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_ms2quantitation Member List

This is the complete list of members for ms_ms2quantitation, including all inherited members.
addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_ms2quantitation | [virtual]
matrix_science::ms_quantitation::countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_quantitation | [virtual]
excludeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &excludeKeys) | ms_ms2quantitation |
getCombinedReportRatio(const std::string &ratioName) const | ms_ms2quantitation |
getCombinedReportRatioNames() const | ms_ms2quantitation |
getComponentIntensities(const ms_peptide_quant_key &key, bool raw=false) const | ms_ms2quantitation |
getErrorHandler() const | ms_errors |
getIntensityNormalisationBase(const std::string &componentName) const | ms_ms2quantitation |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMinNumPeptides() const | ms_quantitation | [protected]
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_ms2quantitation | [virtual]
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const | ms_ms2quantitation | [virtual]
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const | ms_ms2quantitation | [virtual]
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | [protected]
getQuantitationMethod() const | ms_quantitation |
getReportRatioFromFile(unsigned int fileNum, const std::string &ratioName) const | ms_ms2quantitation |
getReportRatioNamesInFile(unsigned int fileNum) const | ms_ms2quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKEys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const | ms_ms2quantitation | [protected, virtual]
hasIntensityNormalisation() const | ms_ms2quantitation |
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_ms2quantitation | [virtual]
hasPeptideRatioNormalisation() const | ms_ms2quantitation |
includeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys) | ms_ms2quantitation |
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | [protected]
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const | ms_ms2quantitation | [virtual]
isValid() const | ms_errors |
loadCdbFile(const char *path) | ms_ms2quantitation |
loadCdbFiles(const std::vector< std::string > &cdbFiles) | ms_ms2quantitation |
ms_errors() | ms_errors |
ms_ms2quantitation(const ms_peptidesummary &pepsum) | ms_ms2quantitation | [explicit]
ms_ms2quantitation(const ms_peptidesummary &pepsum, const ms_quant_method &qm) | ms_ms2quantitation |
normaliseIntensities() | ms_ms2quantitation |
normalisePeptideRatios() | ms_ms2quantitation |
proteinKeys_ | ms_quantitation | [protected]
removeCombinedReportRatio(const std::string &ratioName) | ms_ms2quantitation |
removeIntensityNormalisationBase(const std::string &componentName) | ms_ms2quantitation |
removeIntensityNormalisationBases() | ms_ms2quantitation |
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
removeReportRatioInFile(unsigned int fileNum, const std::string &ratioName) | ms_ms2quantitation |
saveCdbFile(const std::string &cdbFilename) | ms_ms2quantitation |
saveXmlFile(const std::string &xmlFilename, bool completeReport) | ms_ms2quantitation |
setCombinedReportRatio(const std::string &ratioName, const ms_quant_ratio &ratioDef) | ms_ms2quantitation |
setIntensityNormalisationBase(const std::string &componentName, double b) | ms_ms2quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_ms2quantitation | [virtual]
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) | ms_ms2quantitation | [virtual]
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value) | ms_ms2quantitation | [virtual]
setQuantNormalisation(const ms_quant_normalisation *norm) | ms_ms2quantitation |
setQuantOutliers(const ms_quant_outliers *) | ms_ms2quantitation | [virtual]
setReportRatioInFile(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef) | ms_ms2quantitation |
~ms_errors() | ms_errors |
~ms_ms2quantitation() | ms_ms2quantitation | [virtual]
~ms_quantitation()=0 | ms_quantitation | [pure virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_obofile Member List

This is the complete list of members for ms_obofile, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_obofile *right) | ms_obofile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_obofile
findIDFromTagValue(const char *tag, const char *value) const | ms_obofile
getErrorHandler() const | ms_errors
getItemFromId(const char *id) const | ms_obofile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfEntries() const | ms_obofile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_obofile() | ms_obofile
ms_obofile(const char *oboFileName) | ms_obofile
ms_obofile(const ms_obofile &right) | ms_obofile
operator=(const ms_obofile &right) | ms_obofile
parseLine(const std::string str, std::string &tag, std::string &value, std::string &comment) const | ms_obofile
~ms_errors() | ms_errors
~ms_obofile() | ms_obofile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_parseoptions Member List

This is the complete list of members for ms_parseoptions, including all inherited members.
clearParseRules() | ms_parseoptions
copyFrom(const ms_parseoptions *right) | ms_parseoptions
defaultValues() | ms_parseoptions
dropParseRule(const int index) | ms_parseoptions
getNumberOfParseRules() const | ms_parseoptions
getParseRule(const int index) const | ms_parseoptions
getPreceedingComments() const | ms_customproperty
isSectionAvailable() const | ms_parseoptions
ms_customproperty() | ms_customproperty
ms_parseoptions() | ms_parseoptions
ms_parseoptions(const ms_parseoptions &src) | ms_parseoptions
operator=(const ms_parseoptions &right) | ms_parseoptions
setParseRule(const int index, const ms_parserule *rule) | ms_parseoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setSectionAvailable(const bool value) | ms_parseoptions
~ms_customproperty() | ms_customproperty
~ms_parseoptions() | ms_parseoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_parserule Member List

This is the complete list of members for ms_parserule, including all inherited members.
copyFrom(const ms_parserule *right) | ms_parserule
defaultValues() | ms_parserule
getRuleStr() const | ms_parserule
isAvailable() const | ms_parserule
ms_parserule() | ms_parserule
ms_parserule(const ms_parserule &src) | ms_parserule
operator=(const ms_parserule &right) | ms_parserule
setAvailable(const bool value) | ms_parserule
setRuleStr(const char *str) | ms_parserule
~ms_parserule() | ms_parserule
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_parserule_plus Member List

This is the complete list of members for ms_parserule_plus, including all inherited members.
copyFrom(const ms_parserule_plus *right) | ms_parserule_plus
defaultValues() | ms_parserule_plus
getChopSource() const | ms_parserule_plus
getFileTypeToSearch() const | ms_parserule_plus
getNameOfDB() const | ms_parserule_plus
getRule() const | ms_parserule_plus
ms_parserule_plus() | ms_parserule_plus
ms_parserule_plus(const ms_parserule_plus &src) | ms_parserule_plus
operator=(const ms_parserule_plus &right) | ms_parserule_plus
setChopSource(const TAX_CHOP_SRC value) | ms_parserule_plus
setFileTypeToSearch(const TAX_SPECIES_FORMAT value) | ms_parserule_plus
setNameOfDB(const char *name) | ms_parserule_plus
setRule(const ms_parserule *src) | ms_parserule_plus
TAX_CHOP_PREFIX enum value | ms_parserule_plus
TAX_CHOP_SRC typedef | ms_parserule_plus
TAX_CHOP_SUFFIX enum value | ms_parserule_plus
TAX_CHOP_TYPES enum name | ms_parserule_plus
TAX_CHOP_WORDS enum value | ms_parserule_plus
~ms_parserule_plus() | ms_parserule_plus
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:25


ms_peptide Member List

This is the complete list of members for ms_peptide, including all inherited members.
anyPercolatorResults() const | ms_peptide
clearReloadableInfo() | ms_peptide
copyFrom(const ms_peptide *src) | ms_peptide
getAmbiguityString(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getAnyMatch() const | ms_peptide
getAnyProteinTermination(bool &isNterminus, bool &isCterminus, const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getCharge() const | ms_peptide
getComponentStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getDelta() const | ms_peptide
getExpectationValue() const | ms_peptide
getFirstProtAppearedIn() const | ms_peptide
getIntactLinks(ms_linker_site_vector &vec) const | ms_peptide
getIntactLinks() const | ms_peptide
getIonsIntensity() const | ms_peptide
getIonsScore() const | ms_peptide
getIsFromErrorTolerant() const | ms_peptide
getIsFromLibrary() const | ms_peptide
getLessThanMinPepLen() const | ms_peptide
getLocalModsNlStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getLocalModsStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getLoopLinks(ms_linker_site_vector &vec, const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getLoopLinks(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMissedCleavages(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMonoLinkStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMrCalc(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getMrExperimental() const | ms_peptide
getNum13C(const double tol, const std::string tolu, const std::string mass_type) const | ms_peptide
getNumberOfLinkedPeptides() const | ms_peptide
getNumIonsMatched() const | ms_peptide
getNumProteins() const | ms_peptide
getObserved() const | ms_peptide
getPeaksUsedFromIons1() const | ms_peptide
getPeaksUsedFromIons2() const | ms_peptide
getPeaksUsedFromIons3() const | ms_peptide
getPeptideLength(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getPeptideStr(bool substituteAmbiguous=true, const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getPercolatorScores(double *posteriorErrorProbability, double *qValue, double *internalPercolatorScore, double *mascotIonsScore) const | ms_peptide
getPrettyRank() const | ms_peptide
getPrimaryNlStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getProtein(int num) const | ms_peptide
getProteins() const | ms_peptide
getQuery() const | ms_peptide
getRank() const | ms_peptide
getSeriesUsedStr() const | ms_peptide
getSummedModsNlStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getSummedModsStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
getVarModsStr(const PSM psmComponent=PSM_COMPLETE) const | ms_peptide
isSamePeptideStr(ms_peptide *peptide, bool substituteAmbiguous=true) const | ms_peptide
isSameSummedModsStr(ms_peptide *peptide) const | ms_peptide
isSameVarModsStr(ms_peptide *peptide) const | ms_peptide
ms_peptide() | ms_peptide
ms_peptide(int query, int rank, int missedCleavages, double mrCalc, double delta, double observed, int charge, int numIonsMatched, std::string peptideStr, int peaksUsedFromIons1, std::string varModsStr, double ionsScore, std::string seriesUsedStr, int peaksUsedFromIons2, int peaksUsedFromIons3, const ms_mascotresults *pResults=0, bool storeReloadableInfo=true) | ms_peptide
ms_peptide(const int query, const int rank, const SEARCH_PHASE searchPhase, const int missedCleavages, const double mrCalc, const double delta, const double observed, const int charge, const int numIonsMatched, const std::string &peptideStr, const int peaksUsedFromIons1, const std::string &varModsStr, const std::string &summedModsStr, const std::string &localModsStr, const std::string &monoLinkStr, const ms_linker_site_vector &loopLinks, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const std::string &primaryNlStr, const std::string &summedModsNlStr, const std::string &localModsNlStr, const std::string &substStr, const std::string &componentStr, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true) | ms_peptide
ms_peptide(const int query, const int rank, const SEARCH_PHASE searchPhase, const double delta, const double observed, const int charge, const int numIonsMatched, const int peaksUsedFromIons1, const double ionsScore, const std::string &seriesUsedStr, const int peaksUsedFromIons2, const int peaksUsedFromIons3, const ms_peptide &pepAlpha, const ms_peptide &pepBeta, const ms_linker_site &linkerSite, const ms_mascotresults *pResults=0, const bool storeReloadableInfo=true) | ms_peptide
ms_peptide(const ms_peptide &src) | ms_peptide
operator=(const ms_peptide &right) | ms_peptide
PSM enum name | ms_peptide
PSM_COMPLETE enum value | ms_peptide
PSM_CROSSLINK_ALPHA enum value | ms_peptide
PSM_CROSSLINK_BETA enum value | ms_peptide
setLocalModsStr(const std::string str, const PSM psmComponent=PSM_COMPLETE) | ms_peptide
setSummedModsStr(const std::string str, const PSM psmComponent=PSM_COMPLETE) | ms_peptide
setVarModsStr(const std::string str, const PSM psmComponent=PSM_COMPLETE) | ms_peptide
~ms_peptide() | ms_peptide
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_peptide_quant_key Member List

This is the complete list of members for ms_peptide_quant_key, including all inherited members.
getCharge(int &charge) const | ms_peptide_quant_key |
getID(int &ID) const | ms_peptide_quant_key |
getOpaqueString(std::string &opaqueStringRef) const | ms_peptide_quant_key |
getOpaqueStringAndID(std::string &opaqueStringRef, int &ID) const | ms_peptide_quant_key |
getQueryAndRank(int &q, int &p) const | ms_peptide_quant_key |
isNil() const | ms_peptide_quant_key |
ms_peptide_quant_key() | ms_peptide_quant_key |
ms_peptide_quant_key(int q, int p) | ms_peptide_quant_key |
ms_peptide_quant_key(int q, int p, int charge) | ms_peptide_quant_key |
ms_peptide_quant_key(int ID) | ms_peptide_quant_key | [explicit]
ms_peptide_quant_key(const std::string &opaqueString) | ms_peptide_quant_key | [explicit]
ms_peptide_quant_key(const std::string &opaqueString, int ID) | ms_peptide_quant_key | [explicit]
ms_peptide_quant_key(const ms_peptide_quant_key &src) | ms_peptide_quant_key |
operator!=(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator<(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator<=(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator=(const ms_peptide_quant_key &right) | ms_peptide_quant_key |
operator==(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator>(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
operator>=(const ms_peptide_quant_key &right) const | ms_peptide_quant_key |
~ms_peptide_quant_key() | ms_peptide_quant_key |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_peptide_quant_key_vector Member List

This is the complete list of members for ms_peptide_quant_key_vector, including all inherited members.
append(const ms_peptide_quant_key_vector &src) | ms_peptide_quant_key_vector |
clear() | ms_peptide_quant_key_vector |
copyFrom(const ms_peptide_quant_key_vector *src) | ms_peptide_quant_key_vector |
empty() const | ms_peptide_quant_key_vector |
get(int idx) const | ms_peptide_quant_key_vector |
ms_peptide_quant_key_vector() | ms_peptide_quant_key_vector |
ms_peptide_quant_key_vector(const std::vector< ms_peptide_quant_key > &v) | ms_peptide_quant_key_vector | [explicit]
ms_peptide_quant_key_vector(const std::list< ms_peptide_quant_key > &v) | ms_peptide_quant_key_vector | [explicit]
ms_peptide_quant_key_vector(const ms_peptide_quant_key_vector &src) | ms_peptide_quant_key_vector |
operator=(const ms_peptide_quant_key_vector &right) | ms_peptide_quant_key_vector |
pop() | ms_peptide_quant_key_vector |
push(const ms_peptide_quant_key &key) | ms_peptide_quant_key_vector |
set(int idx, const ms_peptide_quant_key &key) | ms_peptide_quant_key_vector |
size() const | ms_peptide_quant_key_vector |
swap(ms_peptide_quant_key_vector &right) | ms_peptide_quant_key_vector |
toVector() const | ms_peptide_quant_key_vector |
~ms_peptide_quant_key_vector() | ms_peptide_quant_key_vector |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_peptide_quant_ratio Member List

This is the complete list of members for ms_peptide_quant_ratio, including all inherited members.
copyFrom(const ms_peptide_quant_ratio *src) | ms_peptide_quant_ratio
getKey() const | ms_peptide_quant_ratio
getRatioName() const | ms_peptide_quant_ratio
getValue() const | ms_peptide_quant_ratio
getWeight() const | ms_peptide_quant_ratio
isExcluded() const | ms_peptide_quant_ratio
isInfinite() const | ms_peptide_quant_ratio
isMissing() const | ms_peptide_quant_ratio
ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, bool isInfinite=false) | ms_peptide_quant_ratio
ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, double value, bool isExcluded=false, double weight=1.0) | ms_peptide_quant_ratio
ms_peptide_quant_ratio(const ms_peptide_quant_ratio &src) | ms_peptide_quant_ratio
operator=(const ms_peptide_quant_ratio &right) | ms_peptide_quant_ratio
~ms_peptide_quant_ratio() | ms_peptide_quant_ratio
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_peptidesummary Member List

This is the complete list of members for ms_peptidesummary, including all inherited members.
anyEmPAI() const | ms_peptidesummary | [virtual]
anyNumDiscoveredMods() const | ms_mascotresults | [virtual]
BUGFIX_10780 enum value | ms_peptidesummary |
BUGFIX_10995 enum value | ms_peptidesummary |
BUGFIX_11002 enum value | ms_peptidesummary |
BUGFIX_11018 enum value | ms_peptidesummary |
BUGFIX_11235 enum value | ms_peptidesummary |
BUGFIX_11254 enum value | ms_peptidesummary |
BUGFIX_11344 enum value | ms_peptidesummary |
BUGFIX_11411 enum value | ms_peptidesummary |
BUGFIX_11425 enum value | ms_peptidesummary |
BUGFIX_11438 enum value | ms_peptidesummary |
BUGFIX_11481 enum value | ms_peptidesummary |
BUGFIX_11483 enum value | ms_peptidesummary |
BUGFIX_11499 enum value | ms_peptidesummary |
BUGFIX_11856 enum value | ms_peptidesummary |
BUGFIX_12123 enum value | ms_peptidesummary |
BUGFIX_12317 enum value | ms_peptidesummary |
BUGFIX_12447 enum value | ms_peptidesummary |
BUGFIX_12538 enum value | ms_peptidesummary |
BUGFIX_12729 enum value | ms_peptidesummary |
BUGFIX_12740 enum value | ms_peptidesummary |
BUGFIX_13324 enum value | ms_peptidesummary |
BUGFIX_13759 enum value | ms_peptidesummary |
BUGFIX_NUM enum name | ms_peptidesummary |
CACHE_MISSING_RESFILE enum value | ms_peptidesummary |
CACHE_STATUS enum name | ms_peptidesummary |
cancelCreateSummary(bool newValue=true) | ms_mascotresults |
createSummary() | ms_peptidesummary | [virtual]
createUnassignedList(sortBy s=QUERY) | ms_mascotresults |
DB_MATCH_TYPE enum name | ms_mascotresults |
DECOY_STATS_COUNT_TYPE enum name | ms_mascotresults |
DM_BOTH enum value | ms_mascotresults |
DM_FASTA enum value | ms_mascotresults |
DM_FASTA_FIRST_PASS enum value | ms_mascotresults |
DM_FASTA_SECOND_PASS enum value | ms_mascotresults |
DM_SPECTRAL_LIBRARY enum value | ms_mascotresults |
DS_COUNT_PSM enum value | ms_mascotresults |
DS_COUNT_SEQUENCE enum value | ms_mascotresults |
dumpCDB(const std::string dumpFileName) | ms_peptidesummary |
FC_ALL_PEPTIDES enum value | ms_mascotresults |
FC_ALL_PEPTITDES enum value | ms_mascotresults |
FC_CASE_INSENSITIVE enum value | ms_mascotresults |
FC_CASE_SENSITIVE enum value | ms_mascotresults |
FC_COMPLETESTR enum value | ms_mascotresults |
FC_FORWARD enum value | ms_mascotresults |
FC_LOOP_FROM_UNASSIGNED enum value | ms_mascotresults |
FC_LOOP_INTO_UNASSIGNED enum value | ms_mascotresults |
FC_MASK_CASE enum value | ms_mascotresults |
FC_MASK_DIRECTION enum value | ms_mascotresults |
FC_MASK_STR_PART enum value | ms_mascotresults |
FC_PROTEIN_IGN_FAMILY enum value | ms_mascotresults |
FC_PROTEIN_IGN_MASK enum value | ms_mascotresults |
FC_PROTEIN_IGN_SAMESETS enum value | ms_mascotresults |
FC_PROTEIN_IGN_SUBSETS enum value | ms_mascotresults |
FC_PROTEIN_INC_ALT_ACC enum value | ms_mascotresults |
FC_RESTRICT_TO_HIT enum value | ms_mascotresults |
FC_REVERSE enum value | ms_mascotresults |
FC_SCORING_MASK enum value | ms_mascotresults |
FC_SEARCH_ALL_RANKS enum value | ms_mascotresults |
FC_SEARCH_IGNORED_RANKS enum value | ms_mascotresults |
FC_SIGNIFICANT_PEPTIDES enum value | ms_mascotresults |
FC_STARTSTR enum value | ms_mascotresults |
FC_STRTOK enum value | ms_mascotresults |
FC_SUBSTR enum value | ms_mascotresults |
FC_UNASSIGNED_MASK enum value | ms_mascotresults |
FIND_COMPARE_FLAGS enum name | ms_mascotresults |
FIND_FLAGS enum name | ms_mascotresults |
findPeptides(const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const | ms_peptidesummary | [virtual]
findProteins(const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_peptidesummary | [virtual]
findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_peptidesummary | [virtual]
findProteinsByDescription(const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_peptidesummary | [virtual]
FLAGS enum name | ms_mascotresults |
freeHit(const int hit) | ms_peptidesummary | [virtual]
FT_PEPTIDE_CALC_MR enum value | ms_mascotresults |
FT_PEPTIDE_CALC_MZ enum value | ms_mascotresults |
FT_PEPTIDE_ETMOD enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MR enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MZ enum value | ms_mascotresults |
FT_PEPTIDE_FIND_MASK enum value | ms_mascotresults |
FT_PEPTIDE_FIXMOD enum value | ms_mascotresults |
FT_PEPTIDE_QUERY enum value | ms_mascotresults |
FT_PEPTIDE_SLMOD enum value | ms_mascotresults |
FT_PEPTIDE_STRING enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD_BYNAME enum value | ms_mascotresults |
FT_PROTEIN_ACCESSION enum value | ms_mascotresults |
FT_PROTEIN_DESCRIPTION enum value | ms_mascotresults |
getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const | ms_peptidesummary | [virtual]
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const | ms_peptidesummary | [virtual]
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const | ms_peptidesummary | [virtual]
getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getCacheFilename(const ms_mascotresfile &resfile, const unsigned int flags, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE) | ms_peptidesummary | [static]
getCacheFilename(const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters) | ms_peptidesummary | [static]
getCacheFileName() const | ms_peptidesummary |
getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const | ms_peptidesummary | [virtual]
getComponentProtein(const char *accession, const int dbIdx=1) const | ms_peptidesummary | [virtual]
getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_peptidesummary | [virtual]
getCreateSummaryProgress(int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const | ms_mascotresults |
getCrosslinkingMethod() const | ms_peptidesummary |
getDiscoveredErrTolModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | [virtual]
getDiscoveredErrTolModNames() const | ms_mascotresults | [virtual]
getDiscoveredLocalModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | [virtual]
getDiscoveredLocalModNames() const | ms_mascotresults | [virtual]
getErrTolModDelta(const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const | ms_mascotresults | [virtual]
getErrTolModMasterNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModMasterString(const int q, const int p) const | ms_peptidesummary | [virtual]
getErrTolModName(const int q, const int p, std::string *modString=NULL) const | ms_mascotresults | [virtual]
getErrTolModNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModPepNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModPepString(const int q, const int p) const | ms_peptidesummary | [virtual]
getErrTolModReqPepNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModReqPepString(const int q, const int p) const | ms_peptidesummary | [virtual]
getErrTolModSlaveNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModSlaveString(const int q, const int p) const | ms_peptidesummary | [virtual]
getErrTolModString(const int q, const int p) const | ms_peptidesummary | [virtual]
getErrTolProbabilityThreshold() const | ms_mascotresults | [virtual]
getFlags() const | ms_mascotresults | [inline]
getFlags2() const | ms_mascotresults | [inline]
getHit(const int hit, const int memberNumber=0) const | ms_peptidesummary | [virtual]
getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const | ms_mascotresults | [virtual]
getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getIonsScore(const int q, const int p, const bool decoy) const | ms_peptidesummary | [virtual]
getIonsScoreCorrected(const double ionsScore, const long multiplicity) const | ms_mascotresults | [protected]
getIonsScoreHistogram(IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getLibraryEntryId(const int q, const int p, std::vector< int > &dbIdx, std::vector< int > &offset, std::vector< std::string > &checksum, std::vector< std::string > &mods) const | ms_peptidesummary |
getLibraryModString(const int q, const int p) const | ms_peptidesummary | [virtual]
getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getMaxRankValue() const | ms_mascotresults | [virtual]
getMinPepLenInPepSummary() const | ms_mascotresults |
getMinProbabilityForSLScore(double score) | ms_peptidesummary | [static]
getNextFamilyProtein(const int masterHit, const int id) const | ms_mascotresults | [virtual]
getNextSimilarProtein(const int masterHit, const int id) const | ms_mascotresults | [virtual]
getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | [virtual]
getNextSubsetProtein(const int masterHit, const int id, const bool searchWholeFamily=true) const | ms_mascotresults | [virtual]
getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | [virtual]
getNumberOfAccessionDBTypes(int q, int p) const | ms_peptidesummary |
getNumberOfFamilyAccessionDBTypes(int hit, int q, int p, bool includeSamesets=true) const | ms_peptidesummary |
getNumberOfFamilyMembers() const | ms_mascotresults | [virtual]
getNumberOfHits() const | ms_mascotresults | [virtual]
getNumberOfUnassigned() const | ms_mascotresults |
getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumDiscoveredErrTolMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredFixedMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredIntactLinks(std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const | ms_mascotresults |
getNumDiscoveredLibraryMods(const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults |
getNumDiscoveredLocalMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredNonSpecCleavage() const | ms_mascotresults | [virtual]
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const | ms_mascotresults | [virtual]
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getPepIdentThreshProtected(const int query, double OneInXprobRnd, ms_mascotresfile::section sec, DB_MATCH_TYPE dbType, double *pQmatch=0) const | ms_mascotresults | [protected, virtual]
getPepsWithSameScore(const int q, const int p) const | ms_peptidesummary | [virtual]
getPeptide(const int q, const int p) const | ms_peptidesummary | [virtual]
getPeptide(const int q, const int p, ms_peptide *&pep) const | ms_peptidesummary | [virtual]
getPeptideAmbiguityRanks(const int q, const int p) | ms_peptidesummary |
getPeptideExpectationValue(const double score, const int query, const int rank=0) const | ms_mascotresults | [virtual]
getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const | ms_mascotresults |
getProbabilityThreshold() const | ms_mascotresults | [virtual]
getProbFromScore(const double score) const | ms_mascotresults | [virtual]
getProbOfPepBeingRandomMatch(const double score, const int query) const | ms_mascotresults | [virtual]
getProbOfProteinBeingRandomMatch(const double score) const | ms_mascotresults | [virtual]
getProtein(const char *accession, const int dbIdx=1) const | ms_peptidesummary | [virtual]
getProteinDescription(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinEmPAI(const char *accession, const int dbIdx=1, const int length=-1) const | ms_peptidesummary | [virtual]
getProteinExpectationValue(const double score) const | ms_mascotresults | [virtual]
getProteinMass(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinScoreCutoff(double OneInXprobRnd) const | ms_peptidesummary | [virtual]
getProteinScoreForHistogram(const int num) const | ms_mascotresults | [virtual]
getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) | ms_peptidesummary | [virtual]
getProteinTaxonomyIDs(const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const | ms_mascotresults |
getProteinThreshold(double OneInXprobRnd) const | ms_mascotresults | [virtual]
getQmatch(const int query) const | ms_mascotresults | [virtual]
getQmatch(const int query, const ms_mascotresfile::section sec) const | ms_mascotresults | [virtual]
getQuantitationComponentForPeptide(const ms_peptide &peptide, ms_quant_component &component, const ms_quant_method *method=NULL) const | ms_peptidesummary | [virtual]
getQuantMethod() const | ms_peptidesummary |
getQueryList(QL_FLAG flag, bool outputListOfQueries=true) | ms_peptidesummary |
getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_mascotresults | [virtual]
getResfile() const | ms_mascotresults |
getResultsParameters() | ms_mascotresults |
getSequenceMass(const char *seq) const | ms_mascotresults |
getSLThresholdFromMinProbability(double minProbability) | ms_peptidesummary | [static]
getSrcRank(int q, int p) const | ms_peptidesummary |
getSrcSection(int q, int p) const | ms_peptidesummary |
getTagDeltaRangeEnd(const int q, const int p) const | ms_peptidesummary | [virtual]
getTagDeltaRangeStart(const int q, const int p) const | ms_peptidesummary | [virtual]
getTagEnd(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagSeries(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagStart(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagString(const int q, const int p) const | ms_peptidesummary | [virtual]
getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_peptidesummary | [virtual]
getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getToleranceInDalton(bool &needMass, const double *const pMass=NULL) const | ms_mascotresults |
getTreeClusterNodes(const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const | ms_peptidesummary | [virtual]
getUnassigned(const int num) const | ms_mascotresults |
getUnassignedIsBold(const int num) const | ms_mascotresults |
getUnassignedShowCheckbox(const int num) const | ms_mascotresults |
hasCrosslinkingMethod() const | ms_peptidesummary |
hasQuantMethod() const | ms_peptidesummary |
HOMOLOGY_THRESHOLD_SOURCE enum name | ms_mascotresults |
HOMTHR_FASTA enum value | ms_mascotresults |
HOMTHR_SL enum value | ms_mascotresults |
IH_INCLUDE_TOP_10_MATCHES enum value | ms_mascotresults |
IH_INCLUDE_TOP_MATCHES enum value | ms_mascotresults |
INTENSITY enum value | ms_mascotresults |
IONS_HISTOGRAM enum name | ms_mascotresults |
isDataCached(BUGFIX_NUM bugNum) const | ms_peptidesummary |
isEmPAIallowed() const | ms_mascotresults |
isNA() const | ms_mascotresults |
isPeptideComponentMatch(const ms_quant_component &component, const ms_peptide &peptide) const | ms_peptidesummary |
isPeptideModificationMatch(const ms_quant_modgroup &group, const ms_peptide &peptide) const | ms_peptidesummary |
isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const | ms_peptidesummary | [virtual]
mascotresfile() const | ms_peptidesummary |
ms_mascotresults(const ms_mascotresfile &resfile, const ms_mascotresults_params &params) | ms_mascotresults |
ms_peptidesummary(const ms_mascotresfile &resfile, const unsigned int flags=MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE) | ms_peptidesummary |
ms_peptidesummary(const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters) | ms_peptidesummary |
MSPEPSUM enum name | ms_peptidesummary |
MSPEPSUM_CACHE_IGNORE_DATE_CHANGE enum value | ms_peptidesummary |
MSPEPSUM_CROSSLINK_INTEGRATED enum value | ms_peptidesummary |
MSPEPSUM_CROSSLINK_ONLY enum value | ms_peptidesummary |
MSPEPSUM_DEFERRED_CREATE enum value | ms_peptidesummary |
MSPEPSUM_DISCARD_RELOADABLE enum value | ms_peptidesummary |
MSPEPSUM_NO_PROTEIN_GROUPING enum value | ms_peptidesummary |
MSPEPSUM_NONE enum value | ms_peptidesummary |
MSPEPSUM_PERCOLATOR enum value | ms_peptidesummary |
MSPEPSUM_REMOVE_CHIMERIC_DUPES enum value | ms_peptidesummary |
MSPEPSUM_SINGLE_HIT_DBIDX enum value | ms_peptidesummary |
MSPEPSUM_SL_INTEGRATED enum value | ms_peptidesummary |
MSPEPSUM_SL_ONLY enum value | ms_peptidesummary |
MSPEPSUM_USE_CACHE enum value | ms_peptidesummary |
MSPEPSUM_USE_HOMOLOGY_THRESH enum value | ms_peptidesummary |
MSRES_CLUSTER_PROTEINS enum value | ms_mascotresults |
MSRES_DECOY enum value | ms_mascotresults |
MSRES_DUPE_DEFAULT enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_A enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_B enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_C enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_D enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_E enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_F enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_G enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_H enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_I enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_NONE enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_A enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_B enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_C enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_D enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_E enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_F enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_G enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_H enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_I enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_NONE enum value | ms_mascotresults |
MSRES_ERR_TOL enum value | ms_mascotresults |
MSRES_GROUP_PROTEINS enum value | ms_mascotresults |
MSRES_IGNORE_PMF_MIXTURE enum value | ms_mascotresults |
MSRES_INTEGRATED_ERR_TOL enum value | ms_mascotresults |
MSRES_MAXHITS_OVERRIDES_MINPROB enum value | ms_mascotresults |
MSRES_MUDPIT_PROTEIN_SCORE enum value | ms_mascotresults |
MSRES_NOFLAG enum value | ms_mascotresults |
MSRES_REQUIRE_BOLD_RED enum value | ms_mascotresults |
MSRES_SHOW_ALL_FROM_ERR_TOL enum value | ms_mascotresults |
MSRES_SHOW_SUBSETS enum value | ms_mascotresults |
MSRES_SUBSETS_DIFF_PROT enum value | ms_mascotresults |
PEPSUMMARY_CACHE_BEING_CREATED enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_CAN_CREATE enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_FILE_NOT_PRESENT enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_NOT_FOR_PMF enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE enum value | ms_peptidesummary |
PEPSUMMARY_CACHE_VALID enum value | ms_peptidesummary |
QCS_ERROR_BAD_COMPONENT_NAME enum value | ms_mascotresults |
QCS_ERROR_NO_COMPONENTS enum value | ms_mascotresults |
QCS_ERROR_NO_METHOD enum value | ms_mascotresults |
QCS_OK enum value | ms_mascotresults |
QCS_OK_MULTIPLE_MATCHES enum value | ms_mascotresults |
QCS_OK_NO_MATCH enum value | ms_mascotresults |
QL_ALL enum value | ms_peptidesummary |
QL_BELOW_HOMOLOGY enum value | ms_peptidesummary |
QL_BELOW_IDENTITY enum value | ms_peptidesummary |
QL_FLAG enum name | ms_peptidesummary |
QL_IGNORE_IONS_SCORE_BELOW enum value | ms_peptidesummary |
QL_LAST enum value | ms_peptidesummary |
QL_UNASSIGNED enum value | ms_peptidesummary |
QUANT_COMPONENT_STATUS enum name | ms_mascotresults |
QUERY enum value | ms_mascotresults |
RESFILE_CACHE_BEING_CREATED enum value | ms_peptidesummary |
RESFILE_CACHE_CAN_CREATE enum value | ms_peptidesummary |
RESFILE_CACHE_DISABLED_IN_OPTIONS enum value | ms_peptidesummary |
RESFILE_CACHE_FILE_NOT_PRESENT enum value | ms_peptidesummary |
RESFILE_CACHE_VALID enum value | ms_peptidesummary |
SCORE enum value | ms_mascotresults |
setSubsetsThreshold(const double scoreFraction) | ms_mascotresults | [virtual]
sortBy enum name | ms_mascotresults |
TCM_PAIRWISE_AVERAGE enum value | ms_mascotresults |
TCM_PAIRWISE_MAXIMUM enum value | ms_mascotresults |
TCM_PAIRWISE_SINGLE enum value | ms_mascotresults |
THRESHOLD_TYPE enum name | ms_mascotresults |
TREE_CLUSTER_METHOD enum name | ms_mascotresults |
TT_HOMOLOGY enum value | ms_mascotresults |
TT_IDENTITY enum value | ms_mascotresults |
TT_PEPSUM_DEFAULT enum value | ms_mascotresults |
UNIQUE_PEP_RULES enum name | ms_mascotresults |
UPR_DEFAULT enum value | ms_mascotresults |
UPR_IGNORE_SUBSET_PROTEINS enum value | ms_mascotresults |
UPR_WITHIN_FAMILY enum value | ms_mascotresults |
UPR_WITHIN_FAMILY_MEMBER enum value | ms_mascotresults |
willCreateCache(const ms_mascotresfile &resfile, const unsigned int flags=MSRES_GROUP_PROTEINS, double minProbability=0.0, int maxHits=50, const char *unigeneIndexFile=0, double ignoreIonsScoreBelow=0.0, int minPepLenInPepSummary=0, const char *singleHit=0, const unsigned int flags2=MSPEPSUM_NONE) | ms_peptidesummary | [static]
willCreateCache(const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters) | ms_peptidesummary | [static]
willCreateCache(const char *resultsFileName, const ms_mascotoptions &opts, const char *unigeneIndexFile, const char *singleHit, const char *applicationName, std::string &resfileCacheFileName, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus) | ms_peptidesummary | [static]
willCreateCache(const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters, const ms_mascotoptions &opts, std::string &peptideSummaryCacheFileName, unsigned int &cacheStatus) | ms_peptidesummary | [static]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_processoroptions Member List

This is the complete list of members for ms_processoroptions, including all inherited members.
appendDatabase(const ms_dbprocessors *db) | ms_processoroptions
appendProcessor(const int processorID) | ms_processoroptions
clearDatabases() | ms_processoroptions
clearProcessors() | ms_processoroptions
copyFrom(const ms_processoroptions *right) | ms_processoroptions
defaultValues() | ms_processoroptions
getDatabase(const int index) const | ms_processoroptions
getNumberOfDatabases() const | ms_processoroptions
getNumberOfProcessors() const | ms_processoroptions
getPreceedingComments() const | ms_customproperty
getProcessor(const int index) const | ms_processoroptions
isSectionAvailable() const | ms_processoroptions
ms_customproperty() | ms_customproperty
ms_processoroptions() | ms_processoroptions
ms_processoroptions(const ms_processoroptions &src) | ms_processoroptions
operator=(const ms_processoroptions &right) | ms_processoroptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setSectionAvailable(const bool value) | ms_processoroptions
~ms_customproperty() | ms_customproperty
~ms_processoroptions() | ms_processoroptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_processors Member List

This is the complete list of members for ms_processors, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_processors *right) | ms_processors
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
DEPRECATED_MAX_CORES_PER_LICENSE enum value | ms_processors
getAutoDetectNumThreads(const int numLicensed, const int numCoresPerCpuLicense) const | ms_processors
getCoreFromLogical(const int cpu) const | ms_processors
getErrorHandler() const | ms_errors
getHT_IDFromLogical(const int cpu) const | ms_processors
getHyperThreadedCPUsMask() const | ms_processors
getHyperThreadingState() const | ms_processors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMultithreadedName() const | ms_processors
getNumAvailableToProcess() const | ms_processors
getNumCores(const int packageID=-1) const | ms_processors
getNumLogicalPerPhysical(const int packageID=0) const | ms_processors
getNumOnSystem() const | ms_processors
getNumPhysicalOnSystem() const | ms_processors
getNumProcessorGroups() const | ms_processors
getPhysicalFromLogical(const int cpu) const | ms_processors
getProcessorName() const | ms_processors
getWhichAvailableForMascot() const | ms_processors
getWhichAvailableForMascot2() const | ms_processors
HT_CANNOT_DETECT enum value | ms_processors
HT_DISABLED enum value | ms_processors
HT_ENABLED enum value | ms_processors
HT_NOT_CAPABLE enum value | ms_processors
HT_SUPPORTED_NOT_ENABLED enum value | ms_processors
HYPERTHREADING enum name | ms_processors
isLogicalCPUAvailableForMascot(const int cpu) const | ms_processors
isPrimaryLogicalProcessor(const int cpu) const | ms_processors
isProcessAffinitySupported() const | ms_processors
isThreadedLogicalProcessor(const int cpu) const | ms_processors
isUseProcessesNotThreads() const | ms_processors
isValid() const | ms_errors
ms_errors() | ms_errors
ms_processors(bool checkLinuxHT, int unused) | ms_processors
ms_processors(const ms_processors &src) | ms_processors
operator=(const ms_processors &right) | ms_processors
~ms_errors() | ms_errors
~ms_processors() | ms_processors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_progress_info Member List

This is the complete list of members for ms_progress_info, including all inherited members.
addSubtask(const std::string &description, size_t total) | ms_progress_info
addSubtask(const ms_progress_info *task) | ms_progress_info
clear(const std::string &description="", size_t total=0) | ms_progress_info
getDescription() const | ms_progress_info
getNumberOfSubtasks() const | ms_progress_info
getProgress() const | ms_progress_info
getStatus() const | ms_progress_info
getSubtaskProgress(int index) const | ms_progress_info
getTotal() const | ms_progress_info
isBreaking() const | ms_progress_info
ms_progress_info() | ms_progress_info
ms_progress_info(const std::string &description, size_t total) | ms_progress_info
removeSubtask(int index) | ms_progress_info
S_NOT_STARTED enum value | ms_progress_info
S_RUNNING enum value | ms_progress_info
S_RUNNING_INDETERMINATE enum value | ms_progress_info
S_STOPPED_BREAK enum value | ms_progress_info
S_STOPPED_COMPLETE enum value | ms_progress_info
S_STOPPED_FAIL enum value | ms_progress_info
setBreak() const | ms_progress_info
STATUS enum name | ms_progress_info
updateBreak() | ms_progress_info
updateComplete() | ms_progress_info
updateFail() | ms_progress_info
updateIndeterminate() | ms_progress_info
updateProgress(size_t progress, size_t total) | ms_progress_info
~ms_progress_info() | ms_progress_info
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_protein Member List

This is the complete list of members for ms_protein, including all inherited members.
anyBoldRedPeptides(const ms_mascotresults &results) const | ms_protein |
anyMatchToQuery(const int query) const | ms_protein |
anyMatchToQueryAndP(const int query, const int P) const | ms_protein |
copyFrom(const ms_protein *src) | ms_protein |
DISTINCT_PEPTIDE_FLAGS enum name | ms_protein |
DPF_CHARGE enum value | ms_protein |
DPF_MODS enum value | ms_protein |
DPF_NODUPSAMEQUERY enum value | ms_protein |
DPF_SEQUENCE enum value | ms_protein |
DPF_UNIQUE enum value | ms_protein |
DUPE_Duplicate enum value | ms_protein |
DUPE_DuplicateSameQuery enum value | ms_protein |
DUPE_HighestScoringDuplicate enum value | ms_protein |
DUPE_Ignored enum value | ms_protein |
DUPE_NotDuplicate enum value | ms_protein |
DUPLICATE enum name | ms_protein |
getAccession() const | ms_protein |
getComponent(const int componentNumber) const | ms_protein |
getCoverage() const | ms_protein |
getDB() const | ms_protein |
getDistinctPeptide(int distinctIndex, int repeatIndex=1, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const | ms_protein |
getFrame() const | ms_protein |
getGrouping() const | ms_protein |
getHitNumber() const | ms_protein |
getIgnoredQPs(std::vector< int > &q, std::vector< int > &p) const | ms_protein |
getLongestPeptideLen() const | ms_protein |
getLongestSigPeptideLen() const | ms_protein |
getMasses(ms_mascotresfile &resfile, const ms_proteinsummary &summary, const unsigned int flags=MASS_SELECT_MATCH, const int numDecimalPlaces=2) const | ms_protein |
getMemberNumber() const | ms_protein |
getNonMudpitScore() const | ms_protein |
getNumComponents() const | ms_protein |
getNumDisplayPeptides(bool aboveThreshold=false) const | ms_protein |
getNumDistinctPeptideRepeats(int distinctIndex, bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const | ms_protein |
getNumDistinctPeptides(bool aboveThreshold=false, DISTINCT_PEPTIDE_FLAGS flags=DPF_SEQUENCE) const | ms_protein |
getNumObservedForEmPAI() const | ms_protein |
getNumPeptides() const | ms_protein |
getPepNumber(const int q, const int p) const | ms_protein |
getPeptideComponentID(const int pepNumber) const | ms_protein |
getPeptideDuplicate(const int pepNumber, const bool allowErrTolDuplicate=true) const | ms_protein |
getPeptideEnd(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideFrame(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideIonsScore(const int pepNumber) const | ms_protein |
getPeptideIsBold(const int pepNumber) const | ms_protein |
getPeptideMultiplicity(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideP(const int pepNumber) const | ms_protein |
getPeptideQuery(const int pepNumber) const | ms_protein |
getPeptideResidueAfter(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideResidueBefore(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getPeptideShowCheckbox(const int pepNumber) const | ms_protein |
getPeptideStart(const int pepNumber, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_protein |
getProteinSummaryHit() const | ms_protein |
getRMSDeltas(const ms_mascotresults &results) const | ms_protein |
getScore() const | ms_protein |
getScoreWithET() const | ms_protein |
getSimilarProteinDB() const | ms_protein |
getSimilarProteinName() const | ms_protein |
getSimilarProteins(std::vector< std::string > &accessions, std::vector< int > &dbIdxs) const | ms_protein |
getUnmatchedMasses(ms_mascotresfile &resfile, const int numDecimalPlaces=2) const | ms_protein |
GROUP enum name | ms_protein |
GROUP_COMPLETE enum value | ms_protein |
GROUP_FAMILY enum value | ms_protein |
GROUP_NO enum value | ms_protein |
GROUP_SUBSET enum value | ms_protein |
GROUP_UNKNOWN enum value | ms_protein |
isASimilarProtein(const ms_protein *prot, const ms_mascotresults *results, const bool groupByQueryNumber=false) | ms_protein |
isPMFMixture() const | ms_protein |
isSimilarProtein(const std::string &acc, const int dbIdx) const | ms_protein |
isUnigene() const | ms_protein |
MASS_FLAGS enum name | ms_protein |
MASS_NON_SELECT_MATCH enum value | ms_protein |
MASS_NON_SELECT_NON_MATCH enum value | ms_protein |
MASS_SELECT_MATCH enum value | ms_protein |
MASS_SELECT_NON_MATCH enum value | ms_protein |
ms_protein(const double score, const std::string accession, const bool updateScoreFromPepScores, const int proteinSummaryHit=0) | ms_protein |
ms_protein(const ms_protein &src) | ms_protein |
operator<(const ms_protein &lhs, const ms_protein &rhs) | ms_protein | [friend]
operator=(const ms_protein &right) | ms_protein |
setDB(int dbIdx) | ms_protein |
setPeptideIsBold(const int pepNumber) | ms_protein |
setPeptideShowCheckbox(const int pepNumber) | ms_protein |
sortPeptides(const ms_mascotresults &results, bool keepAlive=false, int keepAlivePercent=0, const char *keepAliveAccession="", int keepAliveCount=0) | ms_protein |
~ms_protein() | ms_protein |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_protein_quant_ratio Member List

This is the complete list of members for ms_protein_quant_ratio, including all inherited members.
copyFrom(const ms_protein_quant_ratio *src) | ms_protein_quant_ratio
getAccession() const | ms_protein_quant_ratio
getActiveKeys() const | ms_protein_quant_ratio
getDB() const | ms_protein_quant_ratio
getExcludedKeys() const | ms_protein_quant_ratio
getHypothesisPvalue() const | ms_protein_quant_ratio
getHypothesisPvalue(std::string &whyUnavailable) const | ms_protein_quant_ratio
getNormalityPvalue() const | ms_protein_quant_ratio
getNormalityPvalue(std::string &whyUnavailable) const | ms_protein_quant_ratio
getOutlierKeys() const | ms_protein_quant_ratio
getRatioName() const | ms_protein_quant_ratio
getSampleSize() const | ms_protein_quant_ratio
getSkippedKeys() const | ms_protein_quant_ratio
getStandardDeviation() const | ms_protein_quant_ratio
getStandardDeviation(std::string &whyUnavailable) const | ms_protein_quant_ratio
getStandardError() const | ms_protein_quant_ratio
getStandardError(std::string &whyUnavailable) const | ms_protein_quant_ratio
getValue() const | ms_protein_quant_ratio
isLogNormal(double threshold=0.05) const | ms_protein_quant_ratio
isMissing() const | ms_protein_quant_ratio
isSignificant(double threshold=0.05) const | ms_protein_quant_ratio
ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName) | ms_protein_quant_ratio
ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, unsigned int sampleSize) | ms_protein_quant_ratio
ms_protein_quant_ratio(const ms_protein_quant_ratio &src) | ms_protein_quant_ratio
operator!=(const ms_protein_quant_ratio &right) const | ms_protein_quant_ratio
operator=(const ms_protein_quant_ratio &right) | ms_protein_quant_ratio
operator==(const ms_protein_quant_ratio &right) const | ms_protein_quant_ratio
~ms_protein_quant_ratio() | ms_protein_quant_ratio
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_proteinsummary Member List

This is the complete list of members for ms_proteinsummary, including all inherited members.
anyEmPAI() const | ms_mascotresults | [virtual]
anyNumDiscoveredMods() const | ms_mascotresults | [virtual]
cancelCreateSummary(bool newValue=true) | ms_mascotresults |
createSummary() | ms_mascotresults | [virtual]
createUnassignedList(sortBy s=QUERY) | ms_mascotresults |
DB_MATCH_TYPE enum name | ms_mascotresults |
DECOY_STATS_COUNT_TYPE enum name | ms_mascotresults |
DM_BOTH enum value | ms_mascotresults |
DM_FASTA enum value | ms_mascotresults |
DM_FASTA_FIRST_PASS enum value | ms_mascotresults |
DM_FASTA_SECOND_PASS enum value | ms_mascotresults |
DM_SPECTRAL_LIBRARY enum value | ms_mascotresults |
DS_COUNT_PSM enum value | ms_mascotresults |
DS_COUNT_SEQUENCE enum value | ms_mascotresults |
FC_ALL_PEPTIDES enum value | ms_mascotresults |
FC_ALL_PEPTITDES enum value | ms_mascotresults |
FC_CASE_INSENSITIVE enum value | ms_mascotresults |
FC_CASE_SENSITIVE enum value | ms_mascotresults |
FC_COMPLETESTR enum value | ms_mascotresults |
FC_FORWARD enum value | ms_mascotresults |
FC_LOOP_FROM_UNASSIGNED enum value | ms_mascotresults |
FC_LOOP_INTO_UNASSIGNED enum value | ms_mascotresults |
FC_MASK_CASE enum value | ms_mascotresults |
FC_MASK_DIRECTION enum value | ms_mascotresults |
FC_MASK_STR_PART enum value | ms_mascotresults |
FC_PROTEIN_IGN_FAMILY enum value | ms_mascotresults |
FC_PROTEIN_IGN_MASK enum value | ms_mascotresults |
FC_PROTEIN_IGN_SAMESETS enum value | ms_mascotresults |
FC_PROTEIN_IGN_SUBSETS enum value | ms_mascotresults |
FC_PROTEIN_INC_ALT_ACC enum value | ms_mascotresults |
FC_RESTRICT_TO_HIT enum value | ms_mascotresults |
FC_REVERSE enum value | ms_mascotresults |
FC_SCORING_MASK enum value | ms_mascotresults |
FC_SEARCH_ALL_RANKS enum value | ms_mascotresults |
FC_SEARCH_IGNORED_RANKS enum value | ms_mascotresults |
FC_SIGNIFICANT_PEPTIDES enum value | ms_mascotresults |
FC_STARTSTR enum value | ms_mascotresults |
FC_STRTOK enum value | ms_mascotresults |
FC_SUBSTR enum value | ms_mascotresults |
FC_UNASSIGNED_MASK enum value | ms_mascotresults |
FIND_COMPARE_FLAGS enum name | ms_mascotresults |
FIND_FLAGS enum name | ms_mascotresults |
findPeptides(const int startHit, const std::string &str, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< int > &q, std::vector< int > &p) const | ms_proteinsummary | [protected, virtual]
findProteins(const int startHit, const std::string &str, const int dbIdx, FIND_FLAGS item, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_proteinsummary | [protected, virtual]
findProteinsByAccession(const int startHit, const std::string &str, const int dbIdx, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_proteinsummary | [protected, virtual]
findProteinsByDescription(const int startHit, const std::string &str, FIND_COMPARE_FLAGS compareFlags, std::vector< std::string > &accessions, std::vector< int > &dbIndexes) const | ms_proteinsummary | [protected, virtual]
FLAGS enum name | ms_mascotresults |
freeHit(const int hit) | ms_mascotresults | [virtual]
FT_PEPTIDE_CALC_MR enum value | ms_mascotresults |
FT_PEPTIDE_CALC_MZ enum value | ms_mascotresults |
FT_PEPTIDE_ETMOD enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MR enum value | ms_mascotresults |
FT_PEPTIDE_EXP_MZ enum value | ms_mascotresults |
FT_PEPTIDE_FIND_MASK enum value | ms_mascotresults |
FT_PEPTIDE_FIXMOD enum value | ms_mascotresults |
FT_PEPTIDE_QUERY enum value | ms_mascotresults |
FT_PEPTIDE_SLMOD enum value | ms_mascotresults |
FT_PEPTIDE_STRING enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD enum value | ms_mascotresults |
FT_PEPTIDE_VARMOD_BYNAME enum value | ms_mascotresults |
FT_PROTEIN_ACCESSION enum value | ms_mascotresults |
FT_PROTEIN_DESCRIPTION enum value | ms_mascotresults |
getAllFamilyMembersWithThisPepMatch(const int hit, const int q, const int p, std::vector< int > &db, std::vector< std::string > &acc, std::vector< int > &dupe_status) const | ms_proteinsummary | [virtual]
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db) const | ms_proteinsummary | [virtual]
getAllProteinsWithThisPepMatch(const int q, const int p, std::vector< int > &start, std::vector< int > &end, std::vector< std::string > &pre, std::vector< std::string > &post, std::vector< int > &frame, std::vector< int > &multiplicity, std::vector< int > &db, std::vector< int > &psmComponent) const | ms_proteinsummary | [virtual]
getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getComponentIntensity(const int q, const int p, const std::string &componentName, double &value, double &rawValue) const | ms_proteinsummary | [virtual]
getComponentProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | [virtual]
getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_proteinsummary | [virtual]
getCreateSummaryProgress(int *cspTotalPercentComplete, unsigned int *cspCurrTask, int *cspCurrTaskPercentageComplete, std::string *cspAccession, int *cspHit, int *cspQuery, std::string *cspKeepAliveText) const | ms_mascotresults |
getDiscoveredErrTolModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | [virtual]
getDiscoveredErrTolModNames() const | ms_mascotresults | [virtual]
getDiscoveredLocalModDeltas(std::vector< std::string > *vecDeltaStrings=NULL) const | ms_mascotresults | [virtual]
getDiscoveredLocalModNames() const | ms_mascotresults | [virtual]
getErrTolModDelta(const int q, const int p, std::string *modString=NULL, std::string *deltaAsString=NULL) const | ms_mascotresults | [virtual]
getErrTolModMasterNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModMasterString(const int q, const int p) const | ms_proteinsummary | [virtual]
getErrTolModName(const int q, const int p, std::string *modString=NULL) const | ms_mascotresults | [virtual]
getErrTolModNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModPepNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModPepString(const int q, const int p) const | ms_proteinsummary | [virtual]
getErrTolModReqPepNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModReqPepString(const int q, const int p) const | ms_proteinsummary | [virtual]
getErrTolModSlaveNeutralLoss(const int q, const int p) const | ms_mascotresults | [virtual]
getErrTolModSlaveString(const int q, const int p) const | ms_proteinsummary | [virtual]
getErrTolModString(const int q, const int p) const | ms_proteinsummary | [virtual]
getErrTolProbabilityThreshold() const | ms_mascotresults | [virtual]
getFlags() const | ms_mascotresults | [inline]
getFlags2() const | ms_mascotresults | [inline]
getHit(const int hit, const int memberNumber=0) const | ms_mascotresults | [virtual]
getHomologyThreshold(const int query, double OneInXprobRnd, const int rank=1) const | ms_mascotresults | [virtual]
getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getIonsScore(const int q, const int p, const bool decoy) const | ms_proteinsummary | [virtual]
getIonsScoreCorrected(const double ionsScore, const long multiplicity) const | ms_mascotresults | [protected]
getIonsScoreHistogram(IONS_HISTOGRAM flags=IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getLibraryModString(const int q, const int p) const | ms_proteinsummary | [virtual]
getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getMaxRankValue() const | ms_mascotresults | [virtual]
getMinPepLenInPepSummary() const | ms_mascotresults |
getNextFamilyProtein(const int masterHit, const int id) const | ms_mascotresults | [virtual]
getNextSimilarProtein(const int masterHit, const int id) const | ms_mascotresults | [virtual]
getNextSimilarProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | [virtual]
getNextSubsetProtein(const int masterHit, const int id, const bool searchWholeFamily=true) const | ms_mascotresults | [virtual]
getNextSubsetProteinOf(const char *masterAccession, const int masterDB, const int id) const | ms_mascotresults | [virtual]
getNumberOfFamilyMembers() const | ms_mascotresults | [virtual]
getNumberOfHits() const | ms_mascotresults | [virtual]
getNumberOfUnassigned() const | ms_mascotresults |
getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumDiscoveredErrTolMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredFixedMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredIntactLinks(std::vector< int > &varModNum1, std::vector< std::string > &position1, std::vector< std::string > &site1, std::vector< int > &varModNum2, std::vector< std::string > &position2, std::vector< std::string > &site2, std::vector< int > &numLinkedPeptides) const | ms_mascotresults |
getNumDiscoveredLibraryMods(const int modId, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults |
getNumDiscoveredLocalMods(const std::string modName, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumDiscoveredNonSpecCleavage() const | ms_mascotresults | [virtual]
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites, std::vector< double > &deltas, std::vector< std::string > &names) const | ms_mascotresults | [virtual]
getNumDiscoveredVariableMods(const int num, std::vector< std::string > &positions, std::vector< std::string > &sites) const | ms_mascotresults | [virtual]
getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType=DS_COUNT_PSM, DB_MATCH_TYPE dbType=DM_FASTA) | ms_mascotresults | [virtual]
getNumPmfQueriesUsed() const | ms_proteinsummary |
getPepIdentThreshProtected(const int query, double OneInXprobRnd, ms_mascotresfile::section sec, DB_MATCH_TYPE dbType, double *pQmatch=0) const | ms_mascotresults | [protected, virtual]
getPepsWithSameScore(const int q, const int p) const | ms_proteinsummary | [virtual]
getPeptide(const int q, const int p) const | ms_proteinsummary | [virtual]
getPeptide(const int q, const int p, ms_peptide *&pep) const | ms_proteinsummary | [virtual]
getPeptideExpectationValue(const double score, const int query, const int rank=0) const | ms_mascotresults | [virtual]
getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType=DM_FASTA) const | ms_mascotresults | [virtual]
getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const | ms_mascotresults |
getProbabilityThreshold() const | ms_mascotresults | [virtual]
getProbFromScore(const double score) const | ms_mascotresults | [virtual]
getProbOfPepBeingRandomMatch(const double score, const int query) const | ms_mascotresults | [virtual]
getProbOfProteinBeingRandomMatch(const double score) const | ms_mascotresults | [virtual]
getProtein(const char *accession, const int dbIdx=1) const | ms_mascotresults | [virtual]
getProteinDescription(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinEmPAI(const char *accession, const int dbIdx=1, const int length=-1) const | ms_mascotresults | [virtual]
getProteinExpectationValue(const double score) const | ms_mascotresults | [virtual]
getProteinMass(const char *accession, const int dbIdx=1) const | ms_mascotresults |
getProteinScoreCutoff(double OneInXprobRnd) const | ms_proteinsummary | [virtual]
getProteinScoreForHistogram(const int num) const | ms_mascotresults | [virtual]
getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) | ms_proteinsummary | [virtual]
getProteinTaxonomyIDs(const char *accession, const int dbIdx, std::vector< int > &gpt_ids, std::vector< std::string > &gpt_accessions) const | ms_mascotresults |
getProteinThreshold(double OneInXprobRnd) const | ms_mascotresults | [virtual]
getQmatch(const int query) const | ms_mascotresults | [virtual]
getQmatch(const int query, const ms_mascotresfile::section sec) const | ms_mascotresults | [virtual]
getQuantitationComponentForPeptide(const matrix_science::ms_peptide &peptide, matrix_science::ms_quant_component &component, const matrix_science::ms_quant_method *method=NULL) const | ms_proteinsummary | [virtual]
getReadableVarMods(const int q, const int p, const int numDecimalPlaces=2, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_mascotresults | [virtual]
getResfile() const | ms_mascotresults |
getResultsParameters() | ms_mascotresults |
getSequenceMass(const char *seq) const | ms_mascotresults |
getTagDeltaRangeEnd(const int q, const int p) const | ms_proteinsummary | [virtual]
getTagDeltaRangeStart(const int q, const int p) const | ms_proteinsummary | [virtual]
getTagEnd(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagSeries(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagStart(const int q, const int p, const int tagNumber) const | ms_mascotresults | [virtual]
getTagString(const int q, const int p) const | ms_proteinsummary | [virtual]
getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent=ms_peptide::PSM_COMPLETE) const | ms_proteinsummary | [virtual]
getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int *numTargetMatches=0, int *numDecoyMatches=0) | ms_mascotresults |
getToleranceInDalton(bool &needMass, const double *const pMass=NULL) const | ms_mascotresults |
getTreeClusterNodes(const int hit, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, TREE_CLUSTER_METHOD tcm=TCM_PAIRWISE_MAXIMUM, double ***reserved1=0, unsigned int *reserved2=0) const | ms_mascotresults | [virtual]
getUnassigned(const int num) const | ms_mascotresults |
getUnassignedIsBold(const int num) const | ms_mascotresults |
getUnassignedShowCheckbox(const int num) const | ms_mascotresults |
HOMOLOGY_THRESHOLD_SOURCE enum name | ms_mascotresults |
HOMTHR_FASTA enum value | ms_mascotresults |
HOMTHR_SL enum value | ms_mascotresults |
IH_INCLUDE_TOP_10_MATCHES enum value | ms_mascotresults |
IH_INCLUDE_TOP_MATCHES enum value | ms_mascotresults |
INTENSITY enum value | ms_mascotresults |
IONS_HISTOGRAM enum name | ms_mascotresults |
isEmPAIallowed() const | ms_mascotresults |
isNA() const | ms_mascotresults |
isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules=UPR_DEFAULT) const | ms_proteinsummary | [virtual]
isPmfQueryUsed(const int queryIdx) const | ms_proteinsummary |
ms_mascotresults(const ms_mascotresfile &resfile, const ms_mascotresults_params &params) | ms_mascotresults |
ms_proteinsummary(const ms_mascotresfile &resfile, const unsigned int flags=ms_mascotresults::MSRES_GROUP_PROTEINS|ms_mascotresults::MSRES_SHOW_SUBSETS, double minProbability=0.0, int maxHitsToReport=50, const char *unigeneIndexFile=0, const char *singleHit=0) | ms_proteinsummary |
ms_proteinsummary(const ms_mascotresfile &resfile, const ms_mascotresults_params &parameters) | ms_proteinsummary |
MSRES_CLUSTER_PROTEINS enum value | ms_mascotresults |
MSRES_DECOY enum value | ms_mascotresults |
MSRES_DUPE_DEFAULT enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_A enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_B enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_C enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_D enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_E enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_F enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_G enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_H enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_I enum value | ms_mascotresults |
MSRES_DUPE_INCL_IN_SCORE_NONE enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_A enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_B enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_C enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_D enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_E enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_F enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_G enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_H enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_I enum value | ms_mascotresults |
MSRES_DUPE_REMOVE_NONE enum value | ms_mascotresults |
MSRES_ERR_TOL enum value | ms_mascotresults |
MSRES_GROUP_PROTEINS enum value | ms_mascotresults |
MSRES_IGNORE_PMF_MIXTURE enum value | ms_mascotresults |
MSRES_INTEGRATED_ERR_TOL enum value | ms_mascotresults |
MSRES_MAXHITS_OVERRIDES_MINPROB enum value | ms_mascotresults |
MSRES_MUDPIT_PROTEIN_SCORE enum value | ms_mascotresults |
MSRES_NOFLAG enum value | ms_mascotresults |
MSRES_REQUIRE_BOLD_RED enum value | ms_mascotresults |
MSRES_SHOW_ALL_FROM_ERR_TOL enum value | ms_mascotresults |
MSRES_SHOW_SUBSETS enum value | ms_mascotresults |
MSRES_SUBSETS_DIFF_PROT enum value | ms_mascotresults |
QCS_ERROR_BAD_COMPONENT_NAME enum value | ms_mascotresults |
QCS_ERROR_NO_COMPONENTS enum value | ms_mascotresults |
QCS_ERROR_NO_METHOD enum value | ms_mascotresults |
QCS_OK enum value | ms_mascotresults |
QCS_OK_MULTIPLE_MATCHES enum value | ms_mascotresults |
QCS_OK_NO_MATCH enum value | ms_mascotresults |
QUANT_COMPONENT_STATUS enum name | ms_mascotresults |
QUERY enum value | ms_mascotresults |
SCORE enum value | ms_mascotresults |
setSubsetsThreshold(const double scoreFraction) | ms_mascotresults | [virtual]
sortBy enum name | ms_mascotresults |
TCM_PAIRWISE_AVERAGE enum value | ms_mascotresults |
TCM_PAIRWISE_MAXIMUM enum value | ms_mascotresults |
TCM_PAIRWISE_SINGLE enum value | ms_mascotresults |
THRESHOLD_TYPE enum name | ms_mascotresults |
TREE_CLUSTER_METHOD enum name | ms_mascotresults |
TT_HOMOLOGY enum value | ms_mascotresults |
TT_IDENTITY enum value | ms_mascotresults |
TT_PEPSUM_DEFAULT enum value | ms_mascotresults |
UNIQUE_PEP_RULES enum name | ms_mascotresults |
UPR_DEFAULT enum value | ms_mascotresults |
UPR_IGNORE_SUBSET_PROTEINS enum value | ms_mascotresults |
UPR_WITHIN_FAMILY enum value | ms_mascotresults |
UPR_WITHIN_FAMILY_MEMBER enum value | ms_mascotresults |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_average Member List

This is the complete list of members for ms_quant_average, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_average *right) | ms_quant_average |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_average |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropNumPeptides() | ms_quant_average |
dropReferenceAccession() | ms_quant_average |
dropReferenceAmount() | ms_quant_average |
dropReferenceDatabase() | ms_quant_average |
dropSelection() | ms_quant_average |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getNumPeptides() const | ms_quant_average |
getNumPeptidesSchemaType() const | ms_quant_average |
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getReferenceAccession() const | ms_quant_average |
getReferenceAccessionSchemaType() const | ms_quant_average |
getReferenceAmount() const | ms_quant_average |
getReferenceAmountSchemaType() const | ms_quant_average |
getReferenceDatabase() const | ms_quant_average |
getReferenceDatabaseSchemaType() const | ms_quant_average |
getSchemaType() const | ms_quant_average | [virtual]
getSelection() const | ms_quant_average |
getSelectionSchemaType() const | ms_quant_average |
haveNumPeptides() const | ms_quant_average |
haveReferenceAccession() const | ms_quant_average |
haveReferenceAmount() const | ms_quant_average |
haveReferenceDatabase() const | ms_quant_average |
haveSelection() const | ms_quant_average |
ms_quant_average() | ms_quant_average |
ms_quant_average(const ms_quant_average &src) | ms_quant_average |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_average &right) | ms_quant_average |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setNumPeptides(int value) | ms_quant_average |
setReferenceAccession(const char *value) | ms_quant_average |
setReferenceAmount(const char *value) | ms_quant_average |
setReferenceDatabase(const char *value) | ms_quant_average |
setSelection(const char *value) | ms_quant_average |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_average | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_average | [virtual]
~ms_quant_average() | ms_quant_average | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_component Member List

This is the complete list of members for ms_quant_component, including all inherited members.
appendCorrection(const ms_quant_correction *correction) | ms_quant_component |
appendIsotope(const ms_quant_isotope *isotope) | ms_quant_component |
appendModificationGroup(const ms_quant_modgroup *item) | ms_quant_component |
clearCorrections() | ms_quant_component |
clearIsotopes() | ms_quant_component |
clearModificationGroups() | ms_quant_component |
copyFrom(const ms_quant_component *right) | ms_quant_component |
defaultValues() | ms_quant_component |
deleteCorrection(const int idx) | ms_quant_component |
deleteIsotope(const int idx) | ms_quant_component |
deleteModificationGroupByName(const char *name) | ms_quant_component |
deleteModificationGroupByNumber(const int idx) | ms_quant_component |
dropFileIndex() | ms_quant_component |
dropMoverz() | ms_quant_component |
dropName() | ms_quant_component |
dropSatellite() | ms_quant_component |
getCorrection(const int idx) const | ms_quant_component |
getCorrectionSchemaType() const | ms_quant_component |
getFileIndex() const | ms_quant_component |
getFileIndexSchemaType() const | ms_quant_component |
getIsotope(const int idx) const | ms_quant_component |
getIsotopeSchemaType() const | ms_quant_component |
getModificationGroupByName(const char *name) const | ms_quant_component |
getModificationGroupByNumber(const int idx) const | ms_quant_component |
getModificationGroupSchemaType() const | ms_quant_component |
getMoverz() const | ms_quant_component |
getMoverzSchemaType() const | ms_quant_component |
getName() const | ms_quant_component |
getNameSchemaType() const | ms_quant_component |
getNumberOfCorrections() const | ms_quant_component |
getNumberOfIsotopes() const | ms_quant_component |
getNumberOfModificationGroups() const | ms_quant_component |
getSatellite() const | ms_quant_component |
getSatelliteSchemaType() const | ms_quant_component |
getSchemaType() const | ms_quant_component | [virtual]
haveFileIndex() const | ms_quant_component |
haveMoverz() const | ms_quant_component |
haveName() const | ms_quant_component |
haveSatellite() const | ms_quant_component |
ms_quant_component() | ms_quant_component |
ms_quant_component(const ms_quant_component &src) | ms_quant_component |
operator=(const ms_quant_component &right) | ms_quant_component |
setFileIndex(const int file_index) | ms_quant_component |
setMoverz(const ms_quant_moverz *moverz) | ms_quant_component |
setName(const char *value) | ms_quant_component |
setSatellite(const ms_quant_satellite *satellite) | ms_quant_component |
updateCorrection(const int idx, const ms_quant_correction *isotope) | ms_quant_component |
updateIsotope(const int idx, const ms_quant_isotope *isotope) | ms_quant_component |
updateModificationGroupByName(const char *name, const ms_quant_modgroup *modgroup) | ms_quant_component |
updateModificationGroupByNumber(const int idx, const ms_quant_modgroup *modgroup) | ms_quant_component |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_component | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_component | [virtual]
~ms_quant_component() | ms_quant_component | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_composition Member List

This is the complete list of members for ms_quant_composition, including all inherited members.
appendElement(const ms_quant_element *element) | ms_quant_composition |
clearElements() | ms_quant_composition |
copyFrom(const ms_quant_composition *right) | ms_quant_composition |
defaultValues() | ms_quant_composition |
deleteElement(const int idx) | ms_quant_composition |
getElement(const int idx) const | ms_quant_composition |
getElementSchemaType() const | ms_quant_composition |
getNumberOfElements() const | ms_quant_composition |
getSchemaType() const | ms_quant_composition | [virtual]
ms_quant_composition() | ms_quant_composition |
ms_quant_composition(const ms_quant_composition &src) | ms_quant_composition |
operator=(const ms_quant_composition &right) | ms_quant_composition |
updateElement(const int idx, const ms_quant_element *element) | ms_quant_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_composition | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_composition | [virtual]
~ms_quant_composition() | ms_quant_composition | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_configfile Member List

This is the complete list of members for ms_quant_configfile, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
appendMethod(const ms_quant_method *item) | ms_quant_configfile
clearAllErrors() | ms_errors
clearMethods() | ms_quant_configfile
copyFrom(const ms_quant_configfile *right) | ms_quant_configfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_quant_configfile
deleteMethodByName(const char *name) | ms_quant_configfile
deleteMethodByNumber(const int idx) | ms_quant_configfile
getConnectionSettings() const | ms_quant_configfile
getErrorHandler() const | ms_errors
getFileName() const | ms_quant_configfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMajorVersion() const | ms_quant_configfile
getMethodByName(const char *name) const | ms_quant_configfile
getMethodByNumber(const int idx) const | ms_quant_configfile
getMinorVersion() const | ms_quant_configfile
getNumberOfMethods() const | ms_quant_configfile
getSchemaDirectory() const | ms_quant_configfile
getSchemaFileName() const | ms_quant_configfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_quant_configfile() | ms_quant_configfile
ms_quant_configfile(const ms_quant_configfile &src) | ms_quant_configfile
ms_quant_configfile(const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0) | ms_quant_configfile
operator=(const ms_quant_configfile &right) | ms_quant_configfile
read_buffer(const char *buffer) | ms_quant_configfile
read_file() | ms_quant_configfile
save_buffer() | ms_quant_configfile
save_file() | ms_quant_configfile
setConnectionSettings(const ms_connection_settings &cs) | ms_quant_configfile
setFileName(const char *name) | ms_quant_configfile
setSchemaDirectory(const char *dir) | ms_quant_configfile
setSchemaFileName(const char *name) | ms_quant_configfile
updateMethodByName(const char *name, const ms_quant_method *mod) | ms_quant_configfile
updateMethodByNumber(const int idx, const ms_quant_method *mod) | ms_quant_configfile
validateDocument() const | ms_quant_configfile
~ms_errors() | ms_errors
~ms_quant_configfile() | ms_quant_configfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_correction Member List

This is the complete list of members for ms_quant_correction, including all inherited members.
copyFrom(const ms_quant_correction *right) | ms_quant_correction |
defaultValues() | ms_quant_correction |
dropElement() | ms_quant_correction |
dropShift() | ms_quant_correction |
dropType() | ms_quant_correction |
getContent() const | ms_quant_correction |
getContentSchemaType() const | ms_quant_correction |
getElement() const | ms_quant_correction |
getElementSchemaType() const | ms_quant_correction |
getSchemaType() const | ms_quant_correction | [virtual]
getShift() const | ms_quant_correction |
getShiftSchemaType() const | ms_quant_correction |
getType() const | ms_quant_correction |
getTypeSchemaType() const | ms_quant_correction |
haveElement() const | ms_quant_correction |
haveShift() const | ms_quant_correction |
haveType() const | ms_quant_correction |
ms_quant_correction() | ms_quant_correction |
ms_quant_correction(const ms_quant_correction &src) | ms_quant_correction |
operator=(const ms_quant_correction &right) | ms_quant_correction |
setContent(const char *value) | ms_quant_correction |
setElement(const char *value) | ms_quant_correction |
setShift(const int value) | ms_quant_correction |
setType(const char *value) | ms_quant_correction |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_correction | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_correction | [virtual]
~ms_quant_correction() | ms_quant_correction | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_element Member List

This is the complete list of members for ms_quant_element, including all inherited members.
copyFrom(const ms_quant_element *right) | ms_quant_element |
defaultValues() | ms_quant_element |
dropNumber() | ms_quant_element |
dropSymbol() | ms_quant_element |
getNumber() const | ms_quant_element |
getNumberSchemaType() const | ms_quant_element |
getSchemaType() const | ms_quant_element | [virtual]
getSymbol() const | ms_quant_element |
getSymbolSchemaType() const | ms_quant_element |
haveNumber() const | ms_quant_element |
haveSymbol() const | ms_quant_element |
ms_quant_element() | ms_quant_element |
ms_quant_element(const ms_quant_element &src) | ms_quant_element |
operator=(const ms_quant_element &right) | ms_quant_element |
setNumber(const int number) | ms_quant_element |
setSymbol(const char *symbol) | ms_quant_element |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_element | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_element | [virtual]
~ms_quant_element() | ms_quant_element | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:26


ms_quant_helper Member List

This is the complete list of members for ms_quant_helper, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
createMissingComponents(matrix_science::ms_ms1quant_match *match) const | ms_quant_helper
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
isPeptideQualityOK(int q, int p, std::string &reasonStrRef) const | ms_quant_helper
isPeptideQuantifiable(int q, int p, const ms_protein *protein, int peptideIndex, std::string &reasonStrRef) const | ms_quant_helper
isValid() const | ms_errors
ms_errors() | ms_errors
ms_quant_helper(const ms_peptidesummary &pepsum, const ms_quant_method &qm, const ms_umod_configfile &umodfile) | ms_quant_helper
PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN enum value | ms_quant_helper
PEPTIDE_EXPECT_ABOVE_THRESHOLD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_FIXEDMOD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD enum value | ms_quant_helper
PEPTIDE_HAS_EXCLUDED_VARMOD enum value | ms_quant_helper
PEPTIDE_HAS_NO_EXCLUSIVE_MODS enum value | ms_quant_helper
PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD enum value | ms_quant_helper
PEPTIDE_HAS_NO_REQUIRED_VARMOD enum value | ms_quant_helper
PEPTIDE_HAS_UNMODIFIED_SITE enum value | ms_quant_helper
PEPTIDE_IS_QUANTIFIABLE enum value | ms_quant_helper
PEPTIDE_NOT_UNIQUE enum value | ms_quant_helper
PEPTIDE_QUALITY enum name | ms_quant_helper
PEPTIDE_QUALITY_IS_OK enum value | ms_quant_helper
PEPTIDE_QUALITY_UNAVAILABLE enum value | ms_quant_helper
PEPTIDE_QUANTIFIABILITY enum name | ms_quant_helper
PEPTIDE_QUANTIFIABILITY_UNAVAILABLE enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_HOMOLOGY_THR enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_IDENTITY_THR enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM enum value | ms_quant_helper
PEPTIDE_SCORE_BELOW_SCORE_THR enum value | ms_quant_helper
~ms_errors() | ms_errors
~ms_quant_helper() | ms_quant_helper
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_integration Member List

This is the complete list of members for ms_quant_integration, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_integration *right) | ms_quant_integration |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_integration |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropAllChargeStates() | ms_quant_integration |
dropAllChargeStatesThreshold() | ms_quant_integration |
dropAllowElutionShift() | ms_quant_integration |
dropElutionProfileCorrelationThreshold() | ms_quant_integration |
dropElutionTimeDelta() | ms_quant_integration |
dropElutionTimeDeltaUnit() | ms_quant_integration |
dropMassDelta() | ms_quant_integration |
dropMassDeltaUnit() | ms_quant_integration |
dropMatchedRho() | ms_quant_integration |
dropMethod() | ms_quant_integration |
dropPrecursorRange() | ms_quant_integration |
dropProcessingOptions() | ms_quant_integration |
dropSimpleRatio() | ms_quant_integration |
dropSource() | ms_quant_integration |
dropXicMaxWidth() | ms_quant_integration |
dropXicSmoothing() | ms_quant_integration |
dropXicThreshold() | ms_quant_integration |
getAllChargeStatesSchemaType() const | ms_quant_integration |
getAllChargeStatesThreshold() const | ms_quant_integration |
getAllChargeStatesThresholdSchemaType() const | ms_quant_integration |
getAllowElutionShiftSchemaType() const | ms_quant_integration |
getElutionProfileCorrelationThreshold() const | ms_quant_integration |
getElutionProfileCorrelationThresholdSchemaType() const | ms_quant_integration |
getElutionTimeDelta() const | ms_quant_integration |
getElutionTimeDeltaSchemaType() const | ms_quant_integration |
getElutionTimeDeltaUnit() const | ms_quant_integration |
getElutionTimeDeltaUnitSchemaType() const | ms_quant_integration |
getMassDelta() const | ms_quant_integration |
getMassDeltaSchemaType() const | ms_quant_integration |
getMassDeltaUnit() const | ms_quant_integration |
getMassDeltaUnitSchemaType() const | ms_quant_integration |
getMatchedRho() const | ms_quant_integration |
getMatchedRhoSchemaType() const | ms_quant_integration |
getMethod() const | ms_quant_integration |
getMethodSchemaType() const | ms_quant_integration |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getPrecursorRange() const | ms_quant_integration |
getPrecursorRangeSchemaType() const | ms_quant_integration |
getProcessingOptions() const | ms_quant_integration |
getProcessingOptionsSchemaType() const | ms_quant_integration |
getSchemaType() const | ms_quant_integration | [virtual]
getSimpleRatioSchemaType() const | ms_quant_integration |
getSource() const | ms_quant_integration |
getSourceSchemaType() const | ms_quant_integration |
getXicMaxWidth() const | ms_quant_integration |
getXicMaxWidthSchemaType() const | ms_quant_integration |
getXicSmoothing() const | ms_quant_integration |
getXicSmoothingSchemaType() const | ms_quant_integration |
getXicThreshold() const | ms_quant_integration |
getXicThresholdSchemaType() const | ms_quant_integration |
haveAllChargeStates() const | ms_quant_integration |
haveAllChargeStatesThreshold() const | ms_quant_integration |
haveAllowElutionShift() const | ms_quant_integration |
haveElutionProfileCorrelationThreshold() const | ms_quant_integration |
haveElutionTimeDelta() const | ms_quant_integration |
haveElutionTimeDeltaUnit() const | ms_quant_integration |
haveMassDelta() const | ms_quant_integration |
haveMassDeltaUnit() const | ms_quant_integration |
haveMatchedRho() const | ms_quant_integration |
haveMethod() const | ms_quant_integration |
havePrecursorRange() const | ms_quant_integration |
haveProcessingOptions() const | ms_quant_integration |
haveSimpleRatio() const | ms_quant_integration |
haveSource() const | ms_quant_integration |
haveXicMaxWidth() const | ms_quant_integration |
haveXicSmoothing() const | ms_quant_integration |
haveXicThreshold() const | ms_quant_integration |
isAllChargeStates() const | ms_quant_integration |
isAllowElutionShift() const | ms_quant_integration |
isSimpleRatio() const | ms_quant_integration |
ms_quant_integration() | ms_quant_integration |
ms_quant_integration(const ms_quant_integration &src) | ms_quant_integration |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_integration &right) | ms_quant_integration |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setAllChargeStates(const bool value) | ms_quant_integration |
setAllChargeStatesThreshold(const char *value) | ms_quant_integration |
setAllowElutionShift(const bool value) | ms_quant_integration |
setElutionProfileCorrelationThreshold(const char *value) | ms_quant_integration |
setElutionTimeDelta(const char *value) | ms_quant_integration |
setElutionTimeDeltaUnit(const char *value) | ms_quant_integration |
setMassDelta(const char *value) | ms_quant_integration |
setMassDeltaUnit(const char *value) | ms_quant_integration |
setMatchedRho(const char *value) | ms_quant_integration |
setMethod(const char *value) | ms_quant_integration |
setPrecursorRange(const char *value) | ms_quant_integration |
setProcessingOptions(const std::string value) | ms_quant_integration |
setSimpleRatio(const bool value) | ms_quant_integration |
setSource(const char *value) | ms_quant_integration |
setXicMaxWidth(int value) | ms_quant_integration |
setXicSmoothing(int value) | ms_quant_integration |
setXicThreshold(const char *value) | ms_quant_integration |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_integration | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_integration | [virtual]
~ms_quant_integration() | ms_quant_integration | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_isotope Member List

This is the complete list of members for ms_quant_isotope, including all inherited members.
copyFrom(const ms_quant_isotope *right) | ms_quant_isotope |
defaultValues() | ms_quant_isotope |
dropNew() | ms_quant_isotope |
dropOld() | ms_quant_isotope |
getNew() const | ms_quant_isotope |
getNewSchemaType() const | ms_quant_isotope |
getOld() const | ms_quant_isotope |
getOldSchemaType() const | ms_quant_isotope |
getSchemaType() const | ms_quant_isotope | [virtual]
haveNew() const | ms_quant_isotope |
haveOld() const | ms_quant_isotope |
ms_quant_isotope() | ms_quant_isotope |
ms_quant_isotope(const ms_quant_isotope &src) | ms_quant_isotope |
operator=(const ms_quant_isotope &right) | ms_quant_isotope |
setNew(const char *value) | ms_quant_isotope |
setOld(const char *value) | ms_quant_isotope |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_isotope | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_isotope | [virtual]
~ms_quant_isotope() | ms_quant_isotope | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_localdef Member List

This is the complete list of members for ms_quant_localdef, including all inherited members.
appendIgnore(const ms_quant_composition *ignore) | ms_quant_localdef |
appendSpecificity(const ms_quant_specificity *specificity) | ms_quant_localdef |
clearIgnores() | ms_quant_localdef |
clearSpecificities() | ms_quant_localdef |
copyFrom(const ms_quant_localdef *right) | ms_quant_localdef |
defaultValues() | ms_quant_localdef |
deleteIgnore(const int idx) | ms_quant_localdef |
deleteSpecificity(const int idx) | ms_quant_localdef |
dropDelta() | ms_quant_localdef |
dropTitle() | ms_quant_localdef |
getDelta() const | ms_quant_localdef |
getDeltaSchemaType() const | ms_quant_localdef |
getIgnore(const int idx) const | ms_quant_localdef |
getIgnoreSchemaType() const | ms_quant_localdef |
getNumberOfIgnores() const | ms_quant_localdef |
getNumberOfSpecificities() const | ms_quant_localdef |
getSchemaType() const | ms_quant_localdef | [virtual]
getSpecificity(const int idx) const | ms_quant_localdef |
getSpecificitySchemaType() const | ms_quant_localdef |
getTitle() const | ms_quant_localdef |
getTitleSchemaType() const | ms_quant_localdef |
haveDelta() const | ms_quant_localdef |
haveTitle() const | ms_quant_localdef |
ms_quant_localdef() | ms_quant_localdef |
ms_quant_localdef(const ms_quant_localdef &src) | ms_quant_localdef |
operator=(const ms_quant_localdef &right) | ms_quant_localdef |
setDelta(const ms_quant_composition *delta) | ms_quant_localdef |
setTitle(const char *value) | ms_quant_localdef |
updateIgnore(const int idx, const ms_quant_composition *ignore) | ms_quant_localdef |
updateSpecificity(const int idx, const ms_quant_specificity *specificity) | ms_quant_localdef |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_localdef | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_localdef | [virtual]
~ms_quant_localdef() | ms_quant_localdef | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_method Member List

This is the complete list of members for ms_quant_method, including all inherited members.
appendComponent(const ms_quant_component *item) | ms_quant_method |
appendExclusion(const char *exclusion) | ms_quant_method |
appendModificationGroup(const ms_quant_modgroup *item) | ms_quant_method |
appendReportRatio(const ms_quant_ratio *ratio) | ms_quant_method |
appendSeq(const char *seq) | ms_quant_method |
clearComponents() | ms_quant_method |
clearExclusions() | ms_quant_method |
clearModificationGroups() | ms_quant_method |
clearReportRatios() | ms_quant_method |
clearSeqs() | ms_quant_method |
COMPATIBLE enum value | ms_quant_method |
COMPATIBLE_DIFF_INTEGRATION_PARAM enum value | ms_quant_method |
COMPATIBLE_DIFF_LOCAL_MOD enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_COMPONENTS enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_ISOTOPES enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_LOCAL_MODS enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_MOD_GROUPS enum value | ms_quant_method |
COMPATIBLE_DIFF_NUM_MODS enum value | ms_quant_method |
COMPATIBLE_DIFF_PROTOCOL enum value | ms_quant_method |
COMPATIBLE_MISSING_COMPONENT enum value | ms_quant_method |
COMPATIBLE_MISSING_INTEGRATION enum value | ms_quant_method |
COMPATIBLE_MISSING_INTEGRATION_PARAM enum value | ms_quant_method |
COMPATIBLE_MISSING_MOD enum value | ms_quant_method |
COMPATIBLE_MISSING_MOD_GROUP enum value | ms_quant_method |
copyFrom(const ms_quant_method *right) | ms_quant_method |
defaultValues() | ms_quant_method |
deleteComponentByName(const char *name) | ms_quant_method |
deleteComponentByNumber(const int idx) | ms_quant_method |
deleteExclusion(const int idx) | ms_quant_method |
deleteModificationGroupByName(const char *name) | ms_quant_method |
deleteModificationGroupByNumber(const int idx) | ms_quant_method |
deleteReportRatioByName(const char *name) | ms_quant_method |
deleteReportRatioByNumber(const int idx) | ms_quant_method |
deleteSeq(const int idx) | ms_quant_method |
dropComp() | ms_quant_method |
dropConstrainSearch() | ms_quant_method |
dropDescription() | ms_quant_method |
dropIntegration() | ms_quant_method |
dropMinNumPeptides() | ms_quant_method |
dropName() | ms_quant_method |
dropNormalisation() | ms_quant_method |
dropOutliers() | ms_quant_method |
dropProteinRatioType() | ms_quant_method |
dropProtocol() | ms_quant_method |
dropProtScoreType() | ms_quant_method |
dropQuality() | ms_quant_method |
dropReportDetail() | ms_quant_method |
dropRequireBoldRed() | ms_quant_method |
dropShowSubSets() | ms_quant_method |
dropSigThresholdValue() | ms_quant_method |
getComp() const | ms_quant_method |
getComponentByName(const char *name) const | ms_quant_method |
getComponentByNumber(const int idx) const | ms_quant_method |
getComponentSchemaType() const | ms_quant_method |
getCompSchemaType() const | ms_quant_method |
getConstrainSearchSchemaType() const | ms_quant_method |
getDescription() const | ms_quant_method |
getDescriptionSchemaType() const | ms_quant_method |
getExclusion(const int idx) const | ms_quant_method |
getExclusionSchemaType() const | ms_quant_method |
getIntegration() const | ms_quant_method |
getIntegrationSchemaType() const | ms_quant_method |
getLocalModifications(std::vector< const ms_quant_localdef * > &localDefVector) | ms_quant_method |
getMinNumPeptides() const | ms_quant_method |
getMinNumPeptidesSchemaType() const | ms_quant_method |
getModificationGroupByName(const char *name) const | ms_quant_method |
getModificationGroupByNumber(const int idx) const | ms_quant_method |
getModificationGroupSchemaType() const | ms_quant_method |
getName() const | ms_quant_method |
getNameSchemaType() const | ms_quant_method |
getNormalisation() const | ms_quant_method |
getNormalisationSchemaType() const | ms_quant_method |
getNumberOfComponents() const | ms_quant_method |
getNumberOfExclusions() const | ms_quant_method |
getNumberOfModificationGroups() const | ms_quant_method |
getNumberOfReportRatios() const | ms_quant_method |
getNumberOfSeqs() const | ms_quant_method |
getOutliers() const | ms_quant_method |
getOutliersSchemaType() const | ms_quant_method |
getProteinRatioType() const | ms_quant_method |
getProteinRatioTypeSchemaType() const | ms_quant_method |
getProtocol() const | ms_quant_method |
getProtocolSchemaType() const | ms_quant_method |
getProtScoreType() const | ms_quant_method |
getProtScoreTypeSchemaType() const | ms_quant_method |
getQuality() const | ms_quant_method |
getQualitySchemaType() const | ms_quant_method |
getReportDetailSchemaType() const | ms_quant_method |
getReportRatioByName(const char *name) const | ms_quant_method |
getReportRatioByNumber(const int idx) const | ms_quant_method |
getReportRatioSchemaType() const | ms_quant_method |
getRequireBoldRedSchemaType() const | ms_quant_method |
getSchemaType() const | ms_quant_method | [virtual]
getSeq(const int idx) const | ms_quant_method |
getSeqSchemaType() const | ms_quant_method |
getShowSubSets() const | ms_quant_method |
getShowSubSetsSchemaType() const | ms_quant_method |
getSigThresholdValue() const | ms_quant_method |
getSigThresholdValueSchemaType() const | ms_quant_method |
haveComp() const | ms_quant_method |
haveConstrainSearch() const | ms_quant_method |
haveDescription() const | ms_quant_method |
haveIntegration() const | ms_quant_method |
haveMinNumPeptides() const | ms_quant_method |
haveName() const | ms_quant_method |
haveNormalisation() const | ms_quant_method |
haveOutliers() const | ms_quant_method |
haveProteinRatioType() const | ms_quant_method |
haveProtocol() const | ms_quant_method |
haveProtScoreType() const | ms_quant_method |
haveQuality() const | ms_quant_method |
haveReportDetail() const | ms_quant_method |
haveRequireBoldRed() const | ms_quant_method |
haveShowSubSets() const | ms_quant_method |
haveSigThresholdValue() const | ms_quant_method |
isConstrainSearch() const | ms_quant_method |
isMethodCompatible(const ms_quant_method &other, std::string &reasonStrRef) const | ms_quant_method |
isReportDetail() const | ms_quant_method |
isRequireBoldRed() const | ms_quant_method |
METHOD_COMPATIBLE enum name | ms_quant_method |
ms_quant_method() | ms_quant_method |
ms_quant_method(const ms_quant_method &src) | ms_quant_method |
operator=(const ms_quant_method &right) | ms_quant_method |
setComp(const char *value) | ms_quant_method |
setConstrainSearch(const bool value) | ms_quant_method |
setDescription(const char *value) | ms_quant_method |
setIntegration(const ms_quant_integration *integration) | ms_quant_method |
setMinNumPeptides(const int value) | ms_quant_method |
setName(const char *value) | ms_quant_method |
setNormalisation(const ms_quant_normalisation *normalisation) | ms_quant_method |
setOutliers(const ms_quant_outliers *outliers) | ms_quant_method |
setProteinRatioType(const char *value) | ms_quant_method |
setProtocol(const ms_quant_protocol *protocol) | ms_quant_method |
setProtScoreType(const char *value) | ms_quant_method |
setQuality(const ms_quant_quality *quality) | ms_quant_method |
setReportDetail(const bool value) | ms_quant_method |
setRequireBoldRed(const bool value) | ms_quant_method |
setShowSubSets(const char *value) | ms_quant_method |
setSigThresholdValue(const char *value) | ms_quant_method |
updateComponentByName(const char *name, const ms_quant_component *comp) | ms_quant_method |
updateComponentByNumber(const int idx, const ms_quant_component *comp) | ms_quant_method |
updateExclusion(const int idx, const char *exclusion) | ms_quant_method |
updateModificationGroupByName(const char *name, const ms_quant_modgroup *modgroup) | ms_quant_method |
updateModificationGroupByNumber(const int idx, const ms_quant_modgroup *modgroup) | ms_quant_method |
updateReportRatioByName(const char *name, const ms_quant_ratio *ratio) | ms_quant_method |
updateReportRatioByNumber(const int idx, const ms_quant_ratio *ratio) | ms_quant_method |
updateSeq(const int idx, const char *seq) | ms_quant_method |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_method | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_method | [virtual]
~ms_quant_method() | ms_quant_method | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_modgroup Member List

This is the complete list of members for ms_quant_modgroup, including all inherited members.
appendLocalDefinition(const ms_quant_localdef *localdef) | ms_quant_modgroup |
appendModFile(const char *mod) | ms_quant_modgroup |
appendUnmodified(const ms_quant_unmodified *unmodified) | ms_quant_modgroup |
clearLocalDefinitions() | ms_quant_modgroup |
clearModFiles() | ms_quant_modgroup |
clearUnmodified() | ms_quant_modgroup |
copyFrom(const ms_quant_modgroup *right) | ms_quant_modgroup |
defaultValues() | ms_quant_modgroup |
deleteLocalDefinition(const int idx) | ms_quant_modgroup |
deleteModFile(const int idx) | ms_quant_modgroup |
deleteUnmodified(const int idx) | ms_quant_modgroup |
dropMode() | ms_quant_modgroup |
dropName() | ms_quant_modgroup |
dropRequired() | ms_quant_modgroup |
findModFile(const char *mod) const | ms_quant_modgroup |
getLocalDefinition(const int idx) const | ms_quant_modgroup |
getLocalDefinitionSchemaType() const | ms_quant_modgroup |
getMode() const | ms_quant_modgroup |
getModeSchemaType() const | ms_quant_modgroup |
getModFile(const int idx) const | ms_quant_modgroup |
getModFileSchemaType() const | ms_quant_modgroup |
getName() const | ms_quant_modgroup |
getNameSchemaType() const | ms_quant_modgroup |
getNumberOfLocalDefinitions() const | ms_quant_modgroup |
getNumberOfModFiles() const | ms_quant_modgroup |
getNumberOfUnmodified() const | ms_quant_modgroup |
getRequiredSchemaType() const | ms_quant_modgroup |
getSchemaType() const | ms_quant_modgroup | [virtual]
getUnmodified(const int idx) const | ms_quant_modgroup |
getUnmodifiedSchemaType() const | ms_quant_modgroup |
haveMode() const | ms_quant_modgroup |
haveName() const | ms_quant_modgroup |
haveRequired() const | ms_quant_modgroup |
isRequired() const | ms_quant_modgroup |
ms_quant_modgroup() | ms_quant_modgroup |
ms_quant_modgroup(const ms_quant_modgroup &src) | ms_quant_modgroup |
operator=(const ms_quant_modgroup &right) | ms_quant_modgroup |
setMode(const char *value) | ms_quant_modgroup |
setName(const char *value) | ms_quant_modgroup |
setRequired(bool value) | ms_quant_modgroup |
updateLocalDefinition(const int idx, const ms_quant_localdef *localdef) | ms_quant_modgroup |
updateUnmodified(const int idx, const ms_quant_unmodified *unmodified) | ms_quant_modgroup |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_modgroup | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_modgroup | [virtual]
~ms_quant_modgroup() | ms_quant_modgroup | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_moverz Member List

This is the complete list of members for ms_quant_moverz, including all inherited members.
copyFrom(const ms_quant_moverz *right) | ms_quant_moverz |
defaultValues() | ms_quant_moverz |
dropAverage() | ms_quant_moverz |
dropMonoisotopic() | ms_quant_moverz |
getAverage() const | ms_quant_moverz |
getAverageSchemaType() const | ms_quant_moverz |
getMonoisotopic() const | ms_quant_moverz |
getMonoisotopicSchemaType() const | ms_quant_moverz |
getSchemaType() const | ms_quant_moverz | [virtual]
haveAverage() const | ms_quant_moverz |
haveMonoisotopic() const | ms_quant_moverz |
ms_quant_moverz() | ms_quant_moverz |
ms_quant_moverz(const ms_quant_moverz &src) | ms_quant_moverz |
operator=(const ms_quant_moverz &right) | ms_quant_moverz |
setAverage(const char *value) | ms_quant_moverz |
setMonoisotopic(const char *value) | ms_quant_moverz |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_moverz | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_moverz | [virtual]
~ms_quant_moverz() | ms_quant_moverz | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_multiplex Member List

This is the complete list of members for ms_quant_multiplex, including all inherited members.
appendIonSeries(const std::string ionSeries) | ms_quant_multiplex |
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearIonSeries() | ms_quant_multiplex |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_multiplex *right) | ms_quant_multiplex |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_multiplex |
deleteIonSeries(const int idx) | ms_quant_multiplex |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropExcludeInternalLabel() | ms_quant_multiplex |
dropExcludeIsobaricFragments() | ms_quant_multiplex |
dropIonIntensityThreshold() | ms_quant_multiplex |
dropIonSeries() | ms_quant_multiplex |
dropMinIonPairs() | ms_quant_multiplex |
getExcludeInternalLabelSchemaType() const | ms_quant_multiplex |
getExcludeIsobaricFragmentsSchemaType() const | ms_quant_multiplex |
getIonIntensityThreshold() const | ms_quant_multiplex |
getIonIntensityThresholdSchemaType() const | ms_quant_multiplex |
getIonSeries(const int idx=0) const | ms_quant_multiplex |
getIonSeriesSchemaType() const | ms_quant_multiplex |
getMinIonPairs() const | ms_quant_multiplex |
getMinIonPairsSchemaType() const | ms_quant_multiplex |
getNumberOfIonSeries() const | ms_quant_multiplex |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getSchemaType() const | ms_quant_multiplex | [virtual]
haveExcludeInternalLabel() const | ms_quant_multiplex |
haveExcludeIsobaricFragments() const | ms_quant_multiplex |
haveIonIntensityThreshold() const | ms_quant_multiplex |
haveIonSeries() const | ms_quant_multiplex |
haveMinIonPairs() const | ms_quant_multiplex |
isExcludeInternalLabel() const | ms_quant_multiplex |
isExcludeIsobaricFragments() const | ms_quant_multiplex |
ms_quant_multiplex() | ms_quant_multiplex |
ms_quant_multiplex(const ms_quant_multiplex &src) | ms_quant_multiplex |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_multiplex &right) | ms_quant_multiplex |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setExcludeInternalLabel(const bool value) | ms_quant_multiplex |
setExcludeIsobaricFragments(const bool value) | ms_quant_multiplex |
setIonIntensityThreshold(const char *value) | ms_quant_multiplex |
setIonSeries(const std::string ionSeries) | ms_quant_multiplex |
setMinIonPairs(const int value) | ms_quant_multiplex |
updateIonSeries(const int idx, const std::string ionSeries) | ms_quant_multiplex |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_multiplex | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_multiplex | [virtual]
~ms_quant_multiplex() | ms_quant_multiplex | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_neutralloss Member List

This is the complete list of members for ms_quant_neutralloss, including all inherited members.
appendElement(const ms_quant_element *element) | ms_quant_composition |
clearElements() | ms_quant_composition |
copyFrom(const ms_quant_neutralloss *right) | ms_quant_neutralloss |
matrix_science::ms_quant_composition::copyFrom(const ms_quant_composition *right) | ms_quant_composition |
defaultValues() | ms_quant_neutralloss |
deleteElement(const int idx) | ms_quant_composition |
dropFlag() | ms_quant_neutralloss |
getElement(const int idx) const | ms_quant_composition |
getElementSchemaType() const | ms_quant_composition |
getFlagSchemaType() const | ms_quant_neutralloss |
getNumberOfElements() const | ms_quant_composition |
getSchemaType() const | ms_quant_neutralloss | [virtual]
haveFlag() const | ms_quant_neutralloss |
isFlag() const | ms_quant_neutralloss |
ms_quant_composition() | ms_quant_composition |
ms_quant_composition(const ms_quant_composition &src) | ms_quant_composition |
ms_quant_neutralloss() | ms_quant_neutralloss |
ms_quant_neutralloss(const ms_quant_neutralloss &src) | ms_quant_neutralloss |
operator=(const ms_quant_neutralloss &right) | ms_quant_neutralloss |
matrix_science::ms_quant_composition::operator=(const ms_quant_composition &right) | ms_quant_composition |
setFlag(const bool flag) | ms_quant_neutralloss |
updateElement(const int idx, const ms_quant_element *element) | ms_quant_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_neutralloss | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_neutralloss | [virtual]
~ms_quant_composition() | ms_quant_composition | [virtual]
~ms_quant_neutralloss() | ms_quant_neutralloss | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_normalisation Member List

This is the complete list of members for ms_quant_normalisation, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_normalisation *right) | ms_quant_normalisation |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_normalisation |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropMethod() | ms_quant_normalisation |
dropPeptides() | ms_quant_normalisation |
dropProteins() | ms_quant_normalisation |
getMethod() const | ms_quant_normalisation |
getMethodSchemaType() const | ms_quant_normalisation |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getPeptides() const | ms_quant_normalisation |
getPeptidesSchemaType() const | ms_quant_normalisation |
getProteins() const | ms_quant_normalisation |
getProteinsSchemaType() const | ms_quant_normalisation |
getSchemaType() const | ms_quant_normalisation | [virtual]
haveMethod() const | ms_quant_normalisation |
havePeptides() const | ms_quant_normalisation |
haveProteins() const | ms_quant_normalisation |
ms_quant_normalisation() | ms_quant_normalisation |
ms_quant_normalisation(const ms_quant_normalisation &src) | ms_quant_normalisation |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_normalisation &right) | ms_quant_normalisation |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setMethod(const char *value) | ms_quant_normalisation |
setPeptides(const ms_quant_normalisation_peptides *peptides) | ms_quant_normalisation |
setProteins(const ms_quant_normalisation_proteins *proteins) | ms_quant_normalisation |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation | [virtual]
~ms_quant_normalisation() | ms_quant_normalisation | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_normalisation_peptide Member List

This is the complete list of members for ms_quant_normalisation_peptide, including all inherited members.
copyFrom(const ms_quant_normalisation_peptide *right) | ms_quant_normalisation_peptide |
defaultValues() | ms_quant_normalisation_peptide |
dropSequence() | ms_quant_normalisation_peptide |
getSchemaType() const | ms_quant_normalisation_peptide | [virtual]
getSequence() const | ms_quant_normalisation_peptide |
getSequenceSchemaType() const | ms_quant_normalisation_peptide |
haveSequence() const | ms_quant_normalisation_peptide |
ms_quant_normalisation_peptide() | ms_quant_normalisation_peptide |
ms_quant_normalisation_peptide(const ms_quant_normalisation_peptide &src) | ms_quant_normalisation_peptide |
operator=(const ms_quant_normalisation_peptide &right) | ms_quant_normalisation_peptide |
setSequence(const char *value) | ms_quant_normalisation_peptide |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptide | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptide | [virtual]
~ms_quant_normalisation_peptide() | ms_quant_normalisation_peptide | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_normalisation_peptides Member List

This is the complete list of members for ms_quant_normalisation_peptides, including all inherited members.
appendPeptide(const ms_quant_normalisation_peptide *pep) | ms_quant_normalisation_peptides |
clearPeptides() | ms_quant_normalisation_peptides |
copyFrom(const ms_quant_normalisation_peptides *right) | ms_quant_normalisation_peptides |
defaultValues() | ms_quant_normalisation_peptides |
deletePeptide(const int idx) | ms_quant_normalisation_peptides |
getNumberOfPeptides() const | ms_quant_normalisation_peptides |
getPeptide(const int idx) const | ms_quant_normalisation_peptides |
getPeptideSchemaType() const | ms_quant_normalisation_peptides |
getSchemaType() const | ms_quant_normalisation_peptides | [virtual]
ms_quant_normalisation_peptides() | ms_quant_normalisation_peptides |
ms_quant_normalisation_peptides(const ms_quant_normalisation_peptides &src) | ms_quant_normalisation_peptides |
operator=(const ms_quant_normalisation_peptides &right) | ms_quant_normalisation_peptides |
updatePeptide(const int idx, const ms_quant_normalisation_peptide *pep) | ms_quant_normalisation_peptides |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptides | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_peptides | [virtual]
~ms_quant_normalisation_peptides() | ms_quant_normalisation_peptides | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_normalisation_protein Member List

This is the complete list of members for ms_quant_normalisation_protein, including all inherited members.
copyFrom(const ms_quant_normalisation_protein *right) | ms_quant_normalisation_protein |
defaultValues() | ms_quant_normalisation_protein |
dropAccession() | ms_quant_normalisation_protein |
getAccession() const | ms_quant_normalisation_protein |
getAccessionSchemaType() const | ms_quant_normalisation_protein |
getSchemaType() const | ms_quant_normalisation_protein | [virtual]
haveAccession() const | ms_quant_normalisation_protein |
ms_quant_normalisation_protein() | ms_quant_normalisation_protein |
ms_quant_normalisation_protein(const ms_quant_normalisation_protein &src) | ms_quant_normalisation_protein |
operator=(const ms_quant_normalisation_protein &right) | ms_quant_normalisation_protein |
setAccession(const char *value) | ms_quant_normalisation_protein |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_protein | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_protein | [virtual]
~ms_quant_normalisation_protein() | ms_quant_normalisation_protein | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_normalisation_proteins Member List

This is the complete list of members for ms_quant_normalisation_proteins, including all inherited members.
appendProtein(const ms_quant_normalisation_protein *protein) | ms_quant_normalisation_proteins |
clearProteins() | ms_quant_normalisation_proteins |
copyFrom(const ms_quant_normalisation_proteins *right) | ms_quant_normalisation_proteins |
defaultValues() | ms_quant_normalisation_proteins |
deleteProtein(const int idx) | ms_quant_normalisation_proteins |
getNumberOfProteins() const | ms_quant_normalisation_proteins |
getProtein(const int idx) const | ms_quant_normalisation_proteins |
getProteinSchemaType() const | ms_quant_normalisation_proteins |
getSchemaType() const | ms_quant_normalisation_proteins | [virtual]
ms_quant_normalisation_proteins() | ms_quant_normalisation_proteins |
ms_quant_normalisation_proteins(const ms_quant_normalisation_proteins &src) | ms_quant_normalisation_proteins |
operator=(const ms_quant_normalisation_proteins &right) | ms_quant_normalisation_proteins |
updateProtein(const int idx, const ms_quant_normalisation_protein *protein) | ms_quant_normalisation_proteins |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_proteins | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_normalisation_proteins | [virtual]
~ms_quant_normalisation_proteins() | ms_quant_normalisation_proteins | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_numerator Member List

This is the complete list of members for ms_quant_numerator, including all inherited members.
copyFrom(const ms_quant_numerator *right) | ms_quant_numerator |
defaultValues() | ms_quant_numerator |
dropCoefficient() | ms_quant_numerator |
dropName() | ms_quant_numerator |
getCoefficient() const | ms_quant_numerator |
getCoefficientSchemaType() const | ms_quant_numerator |
getContent() const | ms_quant_numerator |
getContentSchemaType() const | ms_quant_numerator |
getName() const | ms_quant_numerator |
getNameSchemaType() const | ms_quant_numerator |
getSchemaType() const | ms_quant_numerator | [virtual]
haveCoefficient() const | ms_quant_numerator |
haveName() const | ms_quant_numerator |
ms_quant_numerator() | ms_quant_numerator |
ms_quant_numerator(const ms_quant_numerator &src) | ms_quant_numerator |
operator=(const ms_quant_numerator &right) | ms_quant_numerator |
setCoefficient(const char *value) | ms_quant_numerator |
setContent(const char *value) | ms_quant_numerator |
setName(const char *value) | ms_quant_numerator |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_numerator | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_numerator | [virtual]
~ms_quant_numerator() | ms_quant_numerator | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_outliers Member List

This is the complete list of members for ms_quant_outliers, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_outliers *right) | ms_quant_outliers |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_outliers |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropMethod() | ms_quant_outliers |
getMethod() const | ms_quant_outliers |
getMethodSchemaType() const | ms_quant_outliers |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getSchemaType() const | ms_quant_outliers | [virtual]
haveMethod() const | ms_quant_outliers |
ms_quant_outliers() | ms_quant_outliers |
ms_quant_outliers(const ms_quant_outliers &src) | ms_quant_outliers |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_outliers &right) | ms_quant_outliers |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setMethod(const char *value) | ms_quant_outliers |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_outliers | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_outliers | [virtual]
~ms_quant_outliers() | ms_quant_outliers | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_parameter Member List

This is the complete list of members for ms_quant_parameter, including all inherited members.
copyFrom(const ms_quant_parameter *right) | ms_quant_parameter |
matrix_science::ms_xml_parameter::copyFrom(const ms_xml_parameter *right) | ms_xml_parameter |
defaultValues() | ms_xml_parameter |
dropDescription() | ms_xml_parameter |
dropName() | ms_xml_parameter |
getDescription() const | ms_xml_parameter |
getDescriptionSchemaType() const | ms_quant_parameter | [virtual]
getName() const | ms_xml_parameter |
getNameSchemaType() const | ms_quant_parameter | [virtual]
getSchemaType() const | ms_quant_parameter | [virtual]
getValue() const | ms_xml_parameter |
getValueSchemaType() const | ms_quant_parameter | [virtual]
haveDescription() const | ms_xml_parameter |
haveName() const | ms_xml_parameter |
ms_quant_parameter() | ms_quant_parameter |
ms_quant_parameter(const ms_quant_parameter &src) | ms_quant_parameter |
ms_xml_parameter() | ms_xml_parameter |
ms_xml_parameter(const ms_xml_parameter &src) | ms_xml_parameter |
operator=(const ms_quant_parameter &right) | ms_quant_parameter |
matrix_science::ms_xml_parameter::operator=(const ms_xml_parameter &right) | ms_xml_parameter |
setDescription(const char *value) | ms_xml_parameter |
setName(const char *value) | ms_xml_parameter |
setValue(const char *value) | ms_xml_parameter |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
~ms_quant_parameter() | ms_quant_parameter | [virtual]
~ms_xml_parameter() | ms_xml_parameter | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_parameters Member List

This is the complete list of members for ms_quant_parameters, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_parameters |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getSchemaType() const | ms_quant_parameters | [virtual]
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_parameters &right) | ms_quant_parameters |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_pepneutralloss Member List

This is the complete list of members for ms_quant_pepneutralloss, including all inherited members.
appendElement(const ms_quant_element *element) | ms_quant_composition |
clearElements() | ms_quant_composition |
copyFrom(const ms_quant_pepneutralloss *right) | ms_quant_pepneutralloss |
matrix_science::ms_quant_composition::copyFrom(const ms_quant_composition *right) | ms_quant_composition |
defaultValues() | ms_quant_pepneutralloss |
deleteElement(const int idx) | ms_quant_composition |
dropRequired() | ms_quant_pepneutralloss |
getElement(const int idx) const | ms_quant_composition |
getElementSchemaType() const | ms_quant_composition |
getNumberOfElements() const | ms_quant_composition |
getRequiredSchemaType() const | ms_quant_pepneutralloss |
getSchemaType() const | ms_quant_pepneutralloss | [virtual]
haveRequired() const | ms_quant_pepneutralloss |
isRequired() const | ms_quant_pepneutralloss |
ms_quant_composition() | ms_quant_composition |
ms_quant_composition(const ms_quant_composition &src) | ms_quant_composition |
ms_quant_pepneutralloss() | ms_quant_pepneutralloss |
ms_quant_pepneutralloss(const ms_quant_pepneutralloss &src) | ms_quant_pepneutralloss |
operator=(const ms_quant_pepneutralloss &right) | ms_quant_pepneutralloss |
matrix_science::ms_quant_composition::operator=(const ms_quant_composition &right) | ms_quant_composition |
setRequired(const bool required) | ms_quant_pepneutralloss |
updateElement(const int idx, const ms_quant_element *element) | ms_quant_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_pepneutralloss | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_pepneutralloss | [virtual]
~ms_quant_composition() | ms_quant_composition | [virtual]
~ms_quant_pepneutralloss() | ms_quant_pepneutralloss | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_precursor Member List

This is the complete list of members for ms_quant_precursor, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_precursor *right) | ms_quant_precursor |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_precursor |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropAllChargeStates() | ms_quant_precursor |
dropAllowElutionShift() | ms_quant_precursor |
dropAllowMassTimeMatch() | ms_quant_precursor |
getAllChargeStatesSchemaType() const | ms_quant_precursor |
getAllowElutionShiftSchemaType() const | ms_quant_precursor |
getAllowMassTimeMatchSchemaType() const | ms_quant_precursor |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getSchemaType() const | ms_quant_precursor | [virtual]
haveAllChargeStates() const | ms_quant_precursor |
haveAllowElutionShift() const | ms_quant_precursor |
haveAllowMassTimeMatch() const | ms_quant_precursor |
isAllChargeStates() const | ms_quant_precursor |
isAllowElutionShift() const | ms_quant_precursor |
isAllowMassTimeMatch() const | ms_quant_precursor |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_precursor() | ms_quant_precursor |
ms_quant_precursor(const ms_quant_precursor &src) | ms_quant_precursor |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_precursor &right) | ms_quant_precursor |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setAllowMassTimeMatch(const bool value) | ms_quant_precursor |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_precursor | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_precursor | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_quant_precursor() | ms_quant_precursor | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_protocol Member List

This is the complete list of members for ms_quant_protocol, including all inherited members.
copyFrom(const ms_quant_protocol *right) | ms_quant_protocol |
defaultValues() | ms_quant_protocol |
getAverage() const | ms_quant_protocol |
getAverageSchemaType() const | ms_quant_protocol |
getMultiplex() const | ms_quant_protocol |
getMultiplexSchemaType() const | ms_quant_protocol |
getPrecursor() const | ms_quant_protocol |
getPrecursorSchemaType() const | ms_quant_protocol |
getReplicate() const | ms_quant_protocol |
getReplicateSchemaType() const | ms_quant_protocol |
getReporter() const | ms_quant_protocol |
getReporterSchemaType() const | ms_quant_protocol |
getSchemaType() const | ms_quant_protocol | [virtual]
getType() const | ms_quant_protocol |
ms_quant_protocol() | ms_quant_protocol |
ms_quant_protocol(const ms_quant_protocol &src) | ms_quant_protocol |
operator=(const ms_quant_protocol &right) | ms_quant_protocol |
setAverage(const ms_quant_average *average) | ms_quant_protocol |
setMultiplex(const ms_quant_multiplex *multiplex) | ms_quant_protocol |
setNull() | ms_quant_protocol |
setPrecursor(const ms_quant_precursor *precursor) | ms_quant_protocol |
setReplicate(const ms_quant_replicate *replicate) | ms_quant_protocol |
setReporter(const ms_quant_reporter *reporter) | ms_quant_protocol |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_protocol | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_protocol | [virtual]
~ms_quant_protocol() | ms_quant_protocol | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_quality Member List

This is the complete list of members for ms_quant_quality, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_quality *right) | ms_quant_quality |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_quality |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropIsolatedPrecursor() | ms_quant_quality |
dropIsolatedPrecursorThreshold() | ms_quant_quality |
dropMinimumA1() | ms_quant_quality |
dropMinPrecursorCharge() | ms_quant_quality |
dropPepThresholdType() | ms_quant_quality |
dropPepThresholdValue() | ms_quant_quality |
dropTotalIntensity() | ms_quant_quality |
dropTotalIntensityThreshold() | ms_quant_quality |
dropUniquePepseq() | ms_quant_quality |
getIsolatedPrecursorSchemaType() const | ms_quant_quality |
getIsolatedPrecursorThreshold() const | ms_quant_quality |
getIsolatedPrecursorThresholdSchemaType() const | ms_quant_quality |
getMinimumA1() const | ms_quant_quality |
getMinimumA1SchemaType() const | ms_quant_quality |
getMinPrecursorCharge() const | ms_quant_quality |
getMinPrecursorChargeSchemaType() const | ms_quant_quality |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getPepThresholdType() const | ms_quant_quality |
getPepThresholdTypeSchemaType() const | ms_quant_quality |
getPepThresholdValue() const | ms_quant_quality |
getPepThresholdValueSchemaType() const | ms_quant_quality |
getSchemaType() const | ms_quant_quality | [virtual]
getTotalIntensitySchemaType() const | ms_quant_quality |
getTotalIntensityThreshold() const | ms_quant_quality |
getTotalIntensityThresholdSchemaType() const | ms_quant_quality |
getUniquePepseqSchemaType() const | ms_quant_quality |
haveIsolatedPrecursor() const | ms_quant_quality |
haveIsolatedPrecursorThreshold() const | ms_quant_quality |
haveMinimumA1() const | ms_quant_quality |
haveMinPrecursorCharge() const | ms_quant_quality |
havePepThresholdType() const | ms_quant_quality |
havePepThresholdValue() const | ms_quant_quality |
haveTotalIntensity() const | ms_quant_quality |
haveTotalIntensityThreshold() const | ms_quant_quality |
haveUniquePepseq() const | ms_quant_quality |
isIsolatedPrecursor() const | ms_quant_quality |
isTotalIntensity() const | ms_quant_quality |
isUniquePepseq() const | ms_quant_quality |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_quality() | ms_quant_quality |
ms_quant_quality(const ms_quant_quality &src) | ms_quant_quality |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_quality &right) | ms_quant_quality |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setIsolatedPrecursor(const bool value) | ms_quant_quality |
setIsolatedPrecursorThreshold(const char *value) | ms_quant_quality |
setMinimumA1(const char *value) | ms_quant_quality |
setMinPrecursorCharge(const int value) | ms_quant_quality |
setPepThresholdType(const char *value) | ms_quant_quality |
setPepThresholdValue(const char *value) | ms_quant_quality |
setTotalIntensity(bool value) | ms_quant_quality |
setTotalIntensityThreshold(std::string value) | ms_quant_quality |
setUniquePepseq(bool value) | ms_quant_quality |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_quality | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_quality | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_quant_quality() | ms_quant_quality | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_ratio Member List

This is the complete list of members for ms_quant_ratio, including all inherited members.
appendDenominator(const ms_quant_numerator *denominator) | ms_quant_ratio |
appendNumerator(const ms_quant_numerator *numerator) | ms_quant_ratio |
clearDenominators() | ms_quant_ratio |
clearNumerators() | ms_quant_ratio |
copyFrom(const ms_quant_ratio *right) | ms_quant_ratio |
defaultValues() | ms_quant_ratio |
deleteDenominatorByName(const char *name) | ms_quant_ratio |
deleteDenominatorByNumber(const int idx) | ms_quant_ratio |
deleteNumeratorByName(const char *name) | ms_quant_ratio |
deleteNumeratorByNumber(const int idx) | ms_quant_ratio |
dropName() | ms_quant_ratio |
getDenominatorByName(const char *name) const | ms_quant_ratio |
getDenominatorByNumber(const int idx) const | ms_quant_ratio |
getDenominatorSchemaType() const | ms_quant_ratio |
getName() const | ms_quant_ratio |
getNameSchemaType() const | ms_quant_ratio |
getNumberOfDenominators() const | ms_quant_ratio |
getNumberOfNumerators() const | ms_quant_ratio |
getNumeratorByName(const char *name) const | ms_quant_ratio |
getNumeratorByNumber(const int idx) const | ms_quant_ratio |
getNumeratorSchemaType() const | ms_quant_ratio |
getSchemaType() const | ms_quant_ratio | [virtual]
haveName() const | ms_quant_ratio |
ms_quant_ratio() | ms_quant_ratio |
ms_quant_ratio(const ms_quant_ratio &src) | ms_quant_ratio |
operator=(const ms_quant_ratio &right) | ms_quant_ratio |
setName(const char *value) | ms_quant_ratio |
updateDenominatorByName(const char *name, const ms_quant_numerator *denominator) | ms_quant_ratio |
updateDenominatorByNumber(const int idx, const ms_quant_numerator *denominator) | ms_quant_ratio |
updateNumeratorByName(const char *name, const ms_quant_numerator *numerator) | ms_quant_ratio |
updateNumeratorByNumber(const int idx, const ms_quant_numerator *numerator) | ms_quant_ratio |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_ratio | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_ratio | [virtual]
~ms_quant_ratio() | ms_quant_ratio | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_replicate Member List

This is the complete list of members for ms_quant_replicate, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_replicate *right) | ms_quant_replicate |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_replicate |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getSchemaType() const | ms_quant_replicate | [virtual]
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_replicate() | ms_quant_replicate |
ms_quant_replicate(const ms_quant_replicate &src) | ms_quant_replicate |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_replicate &right) | ms_quant_replicate |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_replicate | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_replicate | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_quant_replicate() | ms_quant_replicate | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_reporter Member List

This is the complete list of members for ms_quant_reporter, including all inherited members.
appendParameter(const ms_quant_parameter *item) | ms_quant_parameters |
clearParameters() | ms_quant_parameters | [virtual]
copyFrom(const ms_quant_reporter *right) | ms_quant_reporter |
matrix_science::ms_quant_parameters::copyFrom(const ms_quant_parameters *right) | ms_quant_parameters |
defaultValues() | ms_quant_reporter |
deleteParameterByName(const char *name) | ms_quant_parameters | [virtual]
deleteParameterByNumber(const int idx) | ms_quant_parameters | [virtual]
dropReporterTol() | ms_quant_reporter |
dropReporterTolUnit() | ms_quant_reporter |
getNumberOfParameters() const | ms_quant_parameters | [virtual]
getParameterByName(const char *name) const | ms_quant_parameters |
getParameterByNumber(const int idx) const | ms_quant_parameters |
getParameterSchemaType() const | ms_quant_parameters | [virtual]
getReporterTol() const | ms_quant_reporter |
getReporterTolSchemaType() const | ms_quant_reporter |
getReporterTolUnit() const | ms_quant_reporter |
getReporterTolUnitSchemaType() const | ms_quant_reporter |
getSchemaType() const | ms_quant_reporter | [virtual]
haveReporterTol() const | ms_quant_reporter |
haveReporterTolUnit() const | ms_quant_reporter |
ms_quant_parameters() | ms_quant_parameters |
ms_quant_parameters(const ms_quant_parameters &src) | ms_quant_parameters |
ms_quant_reporter() | ms_quant_reporter |
ms_quant_reporter(const ms_quant_reporter &src) | ms_quant_reporter |
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
operator=(const ms_quant_reporter &right) | ms_quant_reporter |
matrix_science::ms_quant_parameters::operator=(const ms_quant_parameters &right) | ms_quant_parameters |
setReporterTol(const char *value) | ms_quant_reporter |
setReporterTolUnit(const char *value) | ms_quant_reporter |
updateParameterByName(const char *name, const ms_quant_parameter *param) | ms_quant_parameters |
updateParameterByNumber(const int idx, const ms_quant_parameter *param) | ms_quant_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_reporter | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_reporter | [virtual]
~ms_quant_parameters() | ms_quant_parameters | [virtual]
~ms_quant_reporter() | ms_quant_reporter | [virtual]
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_satellite Member List

This is the complete list of members for ms_quant_satellite, including all inherited members.
copyFrom(const ms_quant_satellite *right) | ms_quant_satellite |
defaultValues() | ms_quant_satellite |
dropModifications() | ms_quant_satellite |
getModifications() const | ms_quant_satellite |
getModificationsSchemaType() const | ms_quant_satellite |
getSchemaType() const | ms_quant_satellite | [virtual]
haveModifications() const | ms_quant_satellite |
ms_quant_satellite() | ms_quant_satellite |
ms_quant_satellite(const ms_quant_satellite &src) | ms_quant_satellite |
operator=(const ms_quant_satellite &right) | ms_quant_satellite |
setModifications(const ms_quant_modgroup *moverz) | ms_quant_satellite |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_satellite | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_satellite | [virtual]
~ms_quant_satellite() | ms_quant_satellite | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_specificity Member List

This is the complete list of members for ms_quant_specificity, including all inherited members.
appendNeutralLoss(const ms_quant_neutralloss *neutralloss) | ms_quant_specificity |
appendPepNeutralLoss(const ms_quant_pepneutralloss *neutralloss) | ms_quant_specificity |
clearNeutralLosses() | ms_quant_specificity |
clearPepNeutralLosses() | ms_quant_specificity |
copyFrom(const ms_quant_specificity *right) | ms_quant_specificity |
defaultValues() | ms_quant_specificity |
deleteNeutralLoss(const int idx) | ms_quant_specificity |
deletePepNeutralLoss(const int idx) | ms_quant_specificity |
dropPosition() | ms_quant_specificity |
dropSite() | ms_quant_specificity |
getNeutralLoss(const int idx) const | ms_quant_specificity |
getNeutralLossSchemaType() const | ms_quant_specificity |
getNumberOfNeutralLosses() const | ms_quant_specificity |
getNumberOfPepNeutralLosses() const | ms_quant_specificity |
getPepNeutralLoss(const int idx) const | ms_quant_specificity |
getPepNeutralLossSchemaType() const | ms_quant_specificity |
getPosition() const | ms_quant_specificity |
getPositionSchemaType() const | ms_quant_specificity |
getSchemaType() const | ms_quant_specificity | [virtual]
getSite() const | ms_quant_specificity |
getSiteSchemaType() const | ms_quant_specificity |
havePosition() const | ms_quant_specificity |
haveSite() const | ms_quant_specificity |
ms_quant_specificity() | ms_quant_specificity |
ms_quant_specificity(const ms_quant_specificity &src) | ms_quant_specificity |
operator=(const ms_quant_specificity &right) | ms_quant_specificity |
setPosition(const char *position) | ms_quant_specificity |
setSite(const char *site) | ms_quant_specificity |
updateNeutralLoss(const int idx, const ms_quant_neutralloss *neutralloss) | ms_quant_specificity |
updatePepNeutralLoss(const int idx, const ms_quant_pepneutralloss *neutralloss) | ms_quant_specificity |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_specificity | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_specificity | [virtual]
~ms_quant_specificity() | ms_quant_specificity | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_stats Member List

This is the complete list of members for ms_quant_stats, including all inherited members.
arithmeticMean(const std::vector< double > &data) | ms_quant_stats | [static]
arithmeticStandardDeviation(const std::vector< double > &data, double arithmeticMean) | ms_quant_stats | [static]
arithmeticStandardErrorOfMean(double arithmeticStdev, unsigned long sampleSize) | ms_quant_stats | [static]
arithmeticStandardErrorOfMedian(double arithmeticStdev, unsigned long sampleSize) | ms_quant_stats | [static]
binomialCoefficient(unsigned int n, unsigned int k) | ms_quant_stats | [static]
calculateNormalMeanPvalue(double populationMean, double mean, double stdev, unsigned long sampleSize) | ms_quant_stats | [static]
calculateNormalMedianPvalue(double populationMedian, double median, double stdev, unsigned long sampleSize) | ms_quant_stats | [static]
calculateNormalWeightedPvalue(double populationMean, double weightedMean, const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize) | ms_quant_stats | [static]
chisqLowerCriticalValue(unsigned int df, double sigLevel) | ms_quant_stats | [static]
chisqUpperCriticalValue(unsigned int df, double sigLevel) | ms_quant_stats | [static]
detectOutliers(const std::vector< double > &sample, std::string outlierMethod, unsigned int *const numLow, unsigned int *const numHigh) | ms_quant_stats | [static]
detectOutliers(const std::vector< double > &sample, std::string outlierMethod, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh) | ms_quant_stats | [static]
expTransform(const std::vector< double > &logData) | ms_quant_stats | [static]
geometricMean(const std::vector< double > &data) | ms_quant_stats | [static]
geometricStandardDeviation(const std::vector< double > &data, double geometricMean) | ms_quant_stats | [static]
logTransform(const std::vector< double > &data) | ms_quant_stats | [static]
meanCentre(const std::vector< double > &data, double mean) | ms_quant_stats | [static]
medianStandardErrorCorrection(unsigned long sampleSize) | ms_quant_stats | [static]
normalCriticalValue(double p) | ms_quant_stats | [static]
normalCumulativeProbability(double x0) | ms_quant_stats | [static]
poissonDensity(double lambda, unsigned int k) | ms_quant_stats | [static]
snedecorsCriticalValue(unsigned int df1, unsigned int df2, double sigLevel) | ms_quant_stats | [static]
sortedMedian(const std::vector< double > &data) | ms_quant_stats | [static]
sortedMedian(const std::deque< double > &data) | ms_quant_stats | [static]
studentsCriticalValue(unsigned int df, double sigLevel) | ms_quant_stats | [static]
sum(const std::vector< double > &data) | ms_quant_stats | [static]
sumsq(const std::vector< double > &data) | ms_quant_stats | [static]
testDixonsN9(unsigned long sampleSize, double min, double x2, double xn_1, double max, double sigLevel) | ms_quant_stats | [static]
testGrubbsN2(unsigned long sampleSize, double min, double mean, double max, double stdev, double sigLevel) | ms_quant_stats | [static]
testRosners(const std::vector< double > &sample, unsigned int maxOutliers, double sigLevel, unsigned int *const numLow, unsigned int *const numHigh) | ms_quant_stats | [static]
testShapiroWilkW(const std::vector< double > &sample, double *const W, double *const pValue) | ms_quant_stats | [static]
unsortedMedian(const std::vector< double > &data) | ms_quant_stats | [static]
weightedArithmeticMean(const std::vector< double > &data, const std::vector< double > &weights) | ms_quant_stats | [static]
weightedArithmeticStandardDeviation(const std::vector< double > &data, const std::vector< double > &weights, double weightedMean) | ms_quant_stats | [static]
weightedArithmeticStandardError(const std::vector< double > &weights, double weightedStdev, unsigned long sampleSize) | ms_quant_stats | [static]
weightedGeometricMean(const std::vector< double > &data, const std::vector< double > &weights) | ms_quant_stats | [static]
weightedGeometricStandardDeviation(const std::vector< double > &data, const std::vector< double > &weights, double weightedMean) | ms_quant_stats | [static]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quant_unmodified Member List

This is the complete list of members for ms_quant_unmodified, including all inherited members.
copyFrom(const ms_quant_unmodified *right) | ms_quant_unmodified |
defaultValues() | ms_quant_unmodified |
dropPosition() | ms_quant_unmodified |
dropSite() | ms_quant_unmodified |
getContent() const | ms_quant_unmodified |
getContentSchemaType() const | ms_quant_unmodified |
getPosition() const | ms_quant_unmodified |
getPositionSchemaType() const | ms_quant_unmodified |
getSchemaType() const | ms_quant_unmodified | [virtual]
getSite() const | ms_quant_unmodified |
getSiteSchemaType() const | ms_quant_unmodified |
havePosition() const | ms_quant_unmodified |
haveSite() const | ms_quant_unmodified |
ms_quant_unmodified() | ms_quant_unmodified |
ms_quant_unmodified(const ms_quant_unmodified &src) | ms_quant_unmodified |
operator=(const ms_quant_unmodified &right) | ms_quant_unmodified |
setContent(const char *value) | ms_quant_unmodified |
setPosition(const char *position) | ms_quant_unmodified |
setSite(const char *site) | ms_quant_unmodified |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_quant_unmodified | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_quant_unmodified | [virtual]
~ms_quant_unmodified() | ms_quant_unmodified | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_quantitation Member List

This is the complete list of members for ms_quantitation, including all inherited members.
addHeaderField(const std::string &name, const std::string &value) | ms_quantitation |
addRawFileField(const unsigned int id, const std::string &name, const std::string &value) | ms_quantitation |
appendErrors(const ms_errors &src) | ms_errors |
calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< double > &sample, const std::vector< double > &logSample, const std::vector< double > &weights, const std::vector< ms_peptide_quant_key > &activeKeys, const std::map< ms_peptide_quant_key, int > &inactiveKeys, double normalityPvalue) const | ms_quantitation | [protected]
clearAllErrors() | ms_errors |
clearHeaderFields() | ms_quantitation |
clearRawFileFields() | ms_quantitation |
copyFrom(const ms_errors *right) | ms_errors |
countDistinctPeptides(const std::vector< ms_peptide_quant_key > &activeKeys) const | ms_quantitation | [virtual]
countDistinctPeptides(const ms_peptide_quant_key_vector &activeKeys) const | ms_quantitation | [virtual]
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMinNumPeptides() const | ms_quantitation | [protected]
getPeptideQuantKeys(const std::string &accession, int dbIdx) const | ms_quantitation |
getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const =0 | ms_quantitation | [pure virtual]
getPeptideRatioNormalisationBase(const std::string &ratioName) const | ms_quantitation |
getProgressInfo() | ms_quantitation |
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const =0 | ms_quantitation | [pure virtual]
getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const =0 | ms_quantitation | [pure virtual]
getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector< ms_peptide_quant_key > &includeKeys, const std::vector< ms_peptide_quant_key > &excludeKeys, std::vector< double > &sample, std::vector< double > &logSample, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys, double &normalityPvalue) const | ms_quantitation | [protected]
getQuantitationMethod() const | ms_quantitation |
getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set< ms_peptide_quant_key > &keys, const std::set< ms_peptide_quant_key > &includeKeys, const std::set< ms_peptide_quant_key > &excludeKeys, std::vector< double > &values, std::vector< double > &weights, std::vector< ms_peptide_quant_key > &activeKeys, std::map< ms_peptide_quant_key, int > &inactiveKeys) const =0 | ms_quantitation | [protected, pure virtual]
hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const =0 | ms_quantitation | [pure virtual]
initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig) | ms_quantitation | [protected]
isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const =0 | ms_quantitation | [pure virtual]
isValid() const | ms_errors |
ms_errors() | ms_errors |
proteinKeys_ | ms_quantitation | [protected]
removePeptideRatioNormalisationBase(const std::string &ratioName) | ms_quantitation |
removePeptideRatioNormalisationBases() | ms_quantitation |
setMinNumPeptides(int value) | ms_quantitation |
setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName)=0 | ms_quantitation | [pure virtual]
setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName)=0 | ms_quantitation | [pure virtual]
setPeptideRatioNormalisationBase(const std::string &ratioName, double b) | ms_quantitation |
setProteinRatioType(const char *value)=0 | ms_quantitation | [pure virtual]
setQuantOutliers(const ms_quant_outliers *)=0 | ms_quantitation | [pure virtual]
~ms_errors() | ms_errors |
~ms_quantitation()=0 | ms_quantitation | [pure virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_searchparams Member List

This is the complete list of members for ms_searchparams, including all inherited members.
getACCESSION() | ms_searchparams |
getAllUSERParams() const | ms_searchparams |
getCarbonMass() const | ms_searchparams |
getCHARGE() | ms_searchparams |
getCLE() | ms_searchparams |
getCOM() | ms_searchparams |
getCROSSLINKING() const | ms_searchparams |
getCTermMass() | ms_searchparams |
getDATAURL() | ms_searchparams |
getDB(int idx=1) | ms_searchparams |
getDECOY() const | ms_searchparams |
getElectronMass() const | ms_searchparams |
getERRORTOLERANT() | ms_searchparams |
getErrTolParentFilename() | ms_searchparams |
getFILENAME() | ms_searchparams |
getFixedModsDelta(int num) | ms_searchparams |
getFixedModsName(int num) const | ms_searchparams |
getFixedModsNeutralLoss(int num) | ms_searchparams |
getFixedModsResidues(int num) const | ms_searchparams |
getFORMAT() | ms_searchparams |
getFORMVER() | ms_searchparams |
getHydrogenMass() const | ms_searchparams |
getICAT() | ms_searchparams |
getINSTRUMENT() | ms_searchparams |
getINTERMEDIATE() | ms_searchparams |
getIT_MODS() | ms_searchparams |
getITOL() | ms_searchparams |
getITOLU() | ms_searchparams |
getLIBRARY_SEARCH() const | ms_searchparams |
getLibraryModDelta(int num) const | ms_searchparams |
getLibraryModName(int num) const | ms_searchparams |
getLICENSE() | ms_searchparams |
getMASS() | ms_searchparams |
getMassType() | ms_searchparams |
getMaxInternalMass() | ms_searchparams |
getMinInternalMass() | ms_searchparams |
getMODS() | ms_searchparams |
getMULTI_SITE_MODS() const | ms_searchparams |
getNitrogenMass() const | ms_searchparams |
getNTermMass() | ms_searchparams |
getNumberOfDatabases() | ms_searchparams |
getNumberOfLibraryMods() const | ms_searchparams |
getOVERVIEW() | ms_searchparams |
getOxygenMass() const | ms_searchparams |
getPEP_ISOTOPE_ERROR() const | ms_searchparams |
getPFA() | ms_searchparams |
getPRECURSOR() | ms_searchparams |
getQUANTITATION() const | ms_searchparams |
getQUE() | ms_searchparams |
getREPORT() | ms_searchparams |
getREPTYPE() | ms_searchparams |
getResidueMass(char residue) | ms_searchparams |
getRULES() | ms_searchparams |
getSEARCH() | ms_searchparams |
getSEG() | ms_searchparams |
getSUBCLUSTER() | ms_searchparams |
getTARGET_FDR_PERCENT() const | ms_searchparams |
getTAXONOMY() | ms_searchparams |
getTOL() | ms_searchparams |
getTOLU() | ms_searchparams |
getUSEREMAIL() | ms_searchparams |
getUSERField(int num) | ms_searchparams |
getUSERID() | ms_searchparams |
getUSERNAME() | ms_searchparams |
getVarModsDelta(int num) | ms_searchparams |
getVarModsName(int num) const | ms_searchparams |
getVarModsNeutralLoss(int num) | ms_searchparams |
getVarModsNeutralLosses(int num) const | ms_searchparams |
getVarModsPepNeutralLoss(int num) | ms_searchparams |
getVarModsReqPepNeutralLoss(int num) | ms_searchparams |
ms_searchparams(const ms_mascotresfile &resfile) | ms_searchparams |
MSM_EXCLUSIVE_PLUS_VARIABLE enum value | ms_searchparams |
MSM_NOT_PERMITTED enum value | ms_searchparams |
MULTI_SITE_MODS enum name | ms_searchparams |
~ms_searchparams() | ms_searchparams | [inline]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_security Member List

This is the complete list of members for ms_security, including all inherited members.
addNewGroup(const std::string sessionID, const int groupID, const std::string groupName) | ms_security
addNewUser(const std::string sessionID, const int userID, const std::string userName, const std::string password, const time_t passwordExpiry, const std::string fullName, const std::string emailAddress, const ms_user::usertype userType, const bool enabled) | ms_security
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
createDefaults(const std::string sessionID="") | ms_security
deleteGroup(const std::string sessionID, const std::string groupName) | ms_security
deleteUser(const std::string sessionID, const std::string userName) | ms_security
getAllCustomParamsForUser(const ms_user &user) const | ms_security
getAllGroupIDs() const | ms_security
getAllUserIDs(const USERID_SORTBY sortby=USERID_SORTBY_ID) const | ms_security
getErrorHandler() const | ms_errors
getGroup(const std::string groupName) const | ms_security
getGroupFromID(const int groupID) const | ms_security
getIntegraUsers() const | ms_security
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getMascotSecurityOptions() const | ms_security
getPermittedTasksForUser(const std::string name) const | ms_security
getTasks() const | ms_security
getUser(const std::string userName) const | ms_security
getUserFromID(const int userID) const | ms_security
isTaskExists(const int taskID) const | ms_security
isUserExists(const int userID) const | ms_security
isValid() const | ms_errors
ms_errors() | ms_errors
ms_security() | ms_security
sortUsers(std::vector< ms_user * > &vecUsers, const USERID_SORTBY sortby) const | ms_security
updateAllSessionFiles(bool deleteOnly=false) | ms_security
updateGroup(const std::string sessionID, const ms_group &group) | ms_security
updatePassword(const std::string sessionID, const std::string userName, const std::string oldPassword, const std::string newPassword) | ms_security
updateUser(const std::string sessionID, const ms_user user) | ms_security
USERID_SORTBY enum name | ms_security
USERID_SORTBY_FULLNAME enum value | ms_security
USERID_SORTBY_ID enum value | ms_security
USERID_SORTBY_LOGINNAME enum value | ms_security
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_security_options Member List

This is the complete list of members for ms_security_options, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_security_options *right) | ms_security_options
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getDefaultPasswordExpiryTime() const | ms_security_options
getErrorHandler() const | ms_errors
getIntegraAppServerURL() const | ms_security_options
getIntegraDatabaseName() const | ms_security_options
getIntegraOracleServerName() const | ms_security_options
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLogFileName() | ms_security_options
getLoggingLevel() const | ms_security_options
getMinimumPasswordLength() const | ms_security_options
getSessionTimeout() const | ms_security_options
getUseSessionCookies() const | ms_security_options
getVerifySessionIPAddress() const | ms_security_options
isSecurityEnabled() const | ms_security_options
isValid() const | ms_errors
ms_errors() | ms_errors
ms_security_options() | ms_security_options
ms_security_options(const ms_security_options &src) | ms_security_options
operator=(const ms_security_options &right) | ms_security_options
setDefaultPasswordExpiryTime(time_t newVal) | ms_security_options
setIntegraAppServerURL(std::string newVal) | ms_security_options
setIntegraDatabaseName(std::string newVal) | ms_security_options
setIntegraOracleServerName(std::string newVal) | ms_security_options
setLogFileName(std::string newVal) | ms_security_options
setLoggingLevel(ms_errs::msg_sev newVal) | ms_security_options
setMinimumPasswordLength(unsigned int newVal) | ms_security_options
setSecurityEnabled(bool newVal) | ms_security_options
setSessionTimeout(time_t newVal) | ms_security_options
setUseSessionCookies(bool newVal) | ms_security_options
setVerifySessionIPAddress(bool newVal) | ms_security_options
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_security_task Member List

This is the complete list of members for ms_security_task, including all inherited members.
addDoubleParam(const double value) | ms_security_task
addLongParam(const long value) | ms_security_task
addStringParam(const std::string value) | ms_security_task
clearParams() | ms_security_task
getAllParamsAsString() const | ms_security_task
getConstantName() const | ms_security_task
getDescription() const | ms_security_task
getDoubleParams() const | ms_security_task
getID() const | ms_security_task
getLongParams() const | ms_security_task
getNotes() const | ms_security_task
getStringParams() const | ms_security_task
getType() const | ms_security_task
isPermitted() const | ms_security_task
isPermitted_double(const double value) const | ms_security_task
isPermitted_long(const long value) const | ms_security_task
isPermitted_string(const std::string value) const | ms_security_task
ms_security_task() | ms_security_task
paramType enum name | ms_security_task
setParams(const std::string value) | ms_security_task
TYPE_ALL_USERS_ARRAY enum value | ms_security_task
TYPE_BOOL enum value | ms_security_task
TYPE_DOUBLE_ARRAY enum value | ms_security_task
TYPE_EQ_DOUBLE enum value | ms_security_task
TYPE_EQ_LONG enum value | ms_security_task
TYPE_EQ_STRING enum value | ms_security_task
TYPE_GTE_DOUBLE enum value | ms_security_task
TYPE_GTE_LONG enum value | ms_security_task
TYPE_LONG_ARRAY enum value | ms_security_task
TYPE_LTE_DOUBLE enum value | ms_security_task
TYPE_LTE_LONG enum value | ms_security_task
TYPE_STRING_ARRAY enum value | ms_security_task
TYPE_USERS_ARRAY enum value | ms_security_task
~ms_security_task() | ms_security_task
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_security_tasks Member List

This is the complete list of members for ms_security_tasks, including all inherited members.
addTask(const ms_security_task &task) | ms_security_tasks
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getDiffsAsText(const ms_security_tasks &old) | ms_security_tasks
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfTasks() const | ms_security_tasks
getTask(const int num) const | ms_security_tasks
getTaskFromID(const int taskID) const | ms_security_tasks
isFastaPermitted(const std::string database) const | ms_security_tasks
isPermitted(const int taskID) const | ms_security_tasks
isPermitted_double(const int taskID, const double value) const | ms_security_tasks
isPermitted_long(const int taskID, const long value) const | ms_security_tasks
isPermitted_string(const int taskID, const std::string value) const | ms_security_tasks
isTaskExists(const int taskID) const | ms_security_tasks
isValid() const | ms_errors
loadFromFile(const char *filename) | ms_security_tasks
MISECTASK_ACCESS enum value | ms_security_tasks
MISECTASK_ADDCUSTOMREPORT enum value | ms_security_tasks
MISECTASK_ADDEXCLUSIONFILE enum value | ms_security_tasks
MISECTASK_ADDIMPORTFILTER enum value | ms_security_tasks
MISECTASK_ADMIN enum value | ms_security_tasks
MISECTASK_DELETECUSTOMREPORT enum value | ms_security_tasks
MISECTASK_DELETEEXCLUSIONFILE enum value | ms_security_tasks
MISECTASK_PROTEINAPPROVAL enum value | ms_security_tasks
MISECTASK_SENDNOTIFICATION enum value | ms_security_tasks
ms_errors() | ms_errors
ms_security_tasks() | ms_security_tasks
ms_security_tasks(const char *filename) | ms_security_tasks
removeAllTasks() | ms_security_tasks
removeTask(const int taskID) | ms_security_tasks
saveToFile(const char *filename) | ms_security_tasks
SECTASK_ACCESSDBSETUP enum value | ms_security_tasks
SECTASK_ADMINPAGES enum value | ms_security_tasks
SECTASK_ALLFASTA enum value | ms_security_tasks
SECTASK_ALLOWMSMS enum value | ms_security_tasks
SECTASK_ALLOWMSMSNOENZYME enum value | ms_security_tasks
SECTASK_ALLOWPMF enum value | ms_security_tasks
SECTASK_ALLOWPMFNOENZYME enum value | ms_security_tasks
SECTASK_ALLOWSPOOFOTHERUSER enum value | ms_security_tasks
SECTASK_BIOTOOLSBATCH enum value | ms_security_tasks
SECTASK_DAEMONCLIENT enum value | ms_security_tasks
SECTASK_DATAURLMAXSIZE enum value | ms_security_tasks
SECTASK_DATAURLPROTOCOLS enum value | ms_security_tasks
SECTASK_DENYQUANT enum value | ms_security_tasks
SECTASK_DISTILLERCLIENT enum value | ms_security_tasks
SECTASK_DOWNLOAD_DISTILLER_XML enum value | ms_security_tasks
SECTASK_EDITCONFIG enum value | ms_security_tasks
SECTASK_INTEGRASYSTEMACCOUNT enum value | ms_security_tasks
SECTASK_KILLALLTASK enum value | ms_security_tasks
SECTASK_KILLTASKINGROUP enum value | ms_security_tasks
SECTASK_MAXCONCURRENTSEARCHES enum value | ms_security_tasks
SECTASK_MAXETACCESSIONS enum value | ms_security_tasks
SECTASK_MAXETVARMODS enum value | ms_security_tasks
SECTASK_MAXEXECUTIONTIME enum value | ms_security_tasks
SECTASK_MAXFASTAFILES enum value | ms_security_tasks
SECTASK_MAXJOBPRIORITY enum value | ms_security_tasks
SECTASK_MAXNOENZQUERIES enum value | ms_security_tasks
SECTASK_MAXQUERIES enum value | ms_security_tasks
SECTASK_MAXVARMODS enum value | ms_security_tasks
SECTASK_MODIFYOWNPROFILE enum value | ms_security_tasks
SECTASK_MSSTATUSEXECLUSTER enum value | ms_security_tasks
SECTASK_MSSTATUSEXERETRYDB enum value | ms_security_tasks
SECTASK_NAMEDFASTA enum value | ms_security_tasks
SECTASK_SEEALLSEARCHESWITHUSERID enum value | ms_security_tasks
SECTASK_SEEOLDSEARCHES enum value | ms_security_tasks
SECTASK_SEESEARCHINANYGROUP enum value | ms_security_tasks
SECTASK_SEESEARCHINGROUP enum value | ms_security_tasks
SECTASK_SPOOFNAMEDGROUPSONLY enum value | ms_security_tasks
SECTASK_UPLOAD_DISTILLER_XML enum value | ms_security_tasks
SECTASK_USEMSREVIEWEXE enum value | ms_security_tasks
SECTASK_USEMSSTATUSEXE enum value | ms_security_tasks
SECTASK_VIEWCONFIG enum value | ms_security_tasks
SECTASK_VIEWCONFIGUSINGMSSTATUS enum value | ms_security_tasks
TASKID enum name | ms_security_tasks
updateTask(const ms_security_task &task) | ms_security_tasks
~ms_errors() | ms_errors
~ms_security_tasks() | ms_security_tasks
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_session Member List

This is the complete list of members for ms_session, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
canResultsFileBeViewed(const int userID) const | ms_session
clearAllErrors() | ms_errors
clearParam(const std::string name) | ms_session
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
destroy() | ms_session
getBoolParam(const std::string name, bool &param) const | ms_session
getDoubleParam(const std::string name, double &param) const | ms_session
getDoubleParam(const std::string name) const | ms_session
getEmailAddress() const | ms_session
getErrorHandler() const | ms_errors
getFullUserName() const | ms_session
getID() const | ms_session
getIntParam(const std::string name, int &param) const | ms_session
getIntParam(const std::string name) const | ms_session
getIPAddress() const | ms_session
getLastAccessed() const | ms_session
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getLongParam(const std::string name, long &param) const | ms_session
getLongParam(const std::string name) const | ms_session
getParams() const | ms_session
getPermittedTasks() const | ms_session
getSpoofableUsers() const | ms_session
getStringParam(const std::string name, std::string &param) const | ms_session
getStringParam(const std::string name) const | ms_session
getTimeout() const | ms_session
getTimeParam(const std::string name, time_t &param) const | ms_session
getTimeParam(const std::string name) const | ms_session
getUserID() const | ms_session
getUserName() const | ms_session
getUserType() const | ms_session
isFastaPermitted(const std::string database) const | ms_session
isPermitted(const int taskID) const | ms_session
isPermitted_double(const int taskID, const double value) const | ms_session
isPermitted_long(const int taskID, const long value) const | ms_session
isPermitted_string(const int taskID, const std::string value) const | ms_session
isSecurityEnabled() const | ms_session
isTimedOut() const | ms_session
isValid() const | ms_errors
ms_errors() | ms_errors
ms_session(const std::string session_id="") | ms_session
ms_session(const std::string userName, const std::string userPassword) | ms_session
ms_session(const std::string userName, const std::string connectionID, const std::string database) | ms_session
ms_session(const int timeout, const std::string prefix) | ms_session
saveBoolParam(const std::string name, bool param) | ms_session
saveDoubleParam(const std::string name, double param) | ms_session
saveIntParam(const std::string name, int param) | ms_session
saveLongParam(const std::string name, long param) | ms_session
saveStringParam(const std::string name, const std::string param) | ms_session
saveTimeParam(const std::string name, time_t param) | ms_session
setPermittedTasks(const matrix_science::ms_security_tasks &val) | ms_session
update(const ms_security &sec) | ms_session
~ms_errors() | ms_errors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_shapiro_wilk Member List

This is the complete list of members for ms_shapiro_wilk, including all inherited members.
appendSampleValue(double y) | ms_shapiro_wilk |
calculate(long n, long n1, long n2) | ms_shapiro_wilk |
clearSampleValues() | ms_shapiro_wilk |
getErrorCode() const | ms_shapiro_wilk |
getPValue() const | ms_shapiro_wilk |
getResult() const | ms_shapiro_wilk |
ms_shapiro_wilk() | ms_shapiro_wilk |
ms_shapiro_wilk(std::deque< std::pair< size_t, double > > x, long n, long n1, long n2) | ms_shapiro_wilk |
swilk(bool init, std::deque< std::pair< size_t, double > > x, long n, long n1, long n2, std::deque< double > &a, double &w, double &pw, int &ifault) | ms_shapiro_wilk | [static]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:27


ms_spectral_lib_entry Member List

This is the complete list of members for ms_spectral_lib_entry, including all inherited members.
ANNOTATE_NONE enum value | ms_spectral_lib_entry |
ANNOTATE_REPLACE_ALL enum value | ms_spectral_lib_entry |
ANNOTATE_REPLACE_IF_ALL_EMPTY enum value | ms_spectral_lib_entry |
ANNOTATE_REPLACE_QUESTION_MARKS enum value | ms_spectral_lib_entry |
annotatePeaks(const WHAT_TO_ANNOTATE whatToAnnotate, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, const ms_umod_configfile *unimod=0) | ms_spectral_lib_entry |
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
clearAnnotation() | ms_spectral_lib_entry |
copyFrom(const ms_spectral_lib_entry *right) | ms_spectral_lib_entry |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
get() const | ms_spectral_lib_entry |
getCharge() const | ms_spectral_lib_entry |
getComment() const | ms_spectral_lib_entry |
getCommentField(const char *fieldName) const | ms_spectral_lib_entry |
getErrorHandler() const | ms_errors |
getFileName() const | ms_spectral_lib_entry |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getLine(const char *key) const | ms_spectral_lib_entry |
getMods(std::vector< std::string > &names, std::vector< int > &positions) const | ms_spectral_lib_entry |
getMW() const | ms_spectral_lib_entry |
getName() const | ms_spectral_lib_entry |
getNumPeaks() const | ms_spectral_lib_entry |
getPeakList(bool convertToNISTformat=false) const | ms_spectral_lib_entry |
getPeakListChecksum() const | ms_spectral_lib_entry |
getPeakListObject() const | ms_spectral_lib_entry |
getPrecursorMZ() const | ms_spectral_lib_entry |
getSequence() const | ms_spectral_lib_entry |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_spectral_lib_entry() | ms_spectral_lib_entry |
ms_spectral_lib_entry(const ms_spectral_lib_entry &src) | ms_spectral_lib_entry |
ms_spectral_lib_entry(const std::string &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_entry |
ms_spectral_lib_entry(const std::vector< std::string > &entry, const std::string &fileName, const ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_entry |
operator=(const ms_spectral_lib_entry &right) | ms_spectral_lib_entry |
WHAT_TO_ANNOTATE enum name | ms_spectral_lib_entry |
~ms_errors() | ms_errors |
~ms_spectral_lib_entry() | ms_spectral_lib_entry | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_spectral_lib_file Member List

This is the complete list of members for ms_spectral_lib_file, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_errors *right) | ms_errors
findEntries(const char *sequence, const char *checksum=0, const char *accession=0, const char *mods=0) const | ms_spectral_lib_file
getAccessionFromNumber(const int number) const | ms_spectral_lib_file
getAllMods() const | ms_spectral_lib_file
getChecksumFromNumber(const int number) const | ms_spectral_lib_file
getEntryFromNumber(const int number) const | ms_spectral_lib_file
getEntryFromNumberAsText(const int number) const | ms_spectral_lib_file
getErrorHandler() const | ms_errors
getFileName() const | ms_spectral_lib_file
getFormat() const | ms_spectral_lib_file
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getModsFromNumber(const int number) const | ms_spectral_lib_file
getNumEntries() const | ms_spectral_lib_file
getNumResidues() const | ms_spectral_lib_file
getPrecursorChargeFromNumber(const int number) const | ms_spectral_lib_file
getPrecursorMZFromNumber(const int number) const | ms_spectral_lib_file
getQmatch(double minMz, double maxMz) const | ms_spectral_lib_file
getSequenceFromNumber(const int number) const | ms_spectral_lib_file
getStatsInformation() const | ms_spectral_lib_file
isValid() const | ms_errors
ms_errors() | ms_errors
ms_spectral_lib_file(const char *fileName, const char *regexForAccession, const char *cdbFileName=0) | ms_spectral_lib_file
ms_spectral_lib_file(const char *fileName, const char *regexForAccession, const char *cdbFileName, const std::map< std::string, std::string > &modificationAliases) | ms_spectral_lib_file
saveAs(const char *fileName, const bool replaceProteinName=true, ms_spectral_lib::FILE_FORMAT fileFormat=ms_spectral_lib::FORMAT_NIST_MSP, const int startNumber=1, const int endNumber=-1, const ms_spectral_lib_entry::WHAT_TO_ANNOTATE whatToAnnotate=ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS, const double annotateTol=0.6, const char *annotateTolu="Da", const ms_umod_configfile *unimod=0) const | ms_spectral_lib_file
verifyThatModsAreInUnimod(const ms_umod_configfile &unimod) | ms_spectral_lib_file
~ms_errors() | ms_errors
~ms_spectral_lib_file() | ms_spectral_lib_file
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_spectral_lib_peak Member List

This is the complete list of members for ms_spectral_lib_peak, including all inherited members.
asText(ms_spectral_lib::FILE_FORMAT format) const | ms_spectral_lib_peak |
clearAnnotation() | ms_spectral_lib_peak |
copyFrom(const ms_spectral_lib_peak *right) | ms_spectral_lib_peak |
getAnnotation(ms_spectral_lib::FILE_FORMAT format=ms_spectral_lib::FORMAT_NIST_MSP) const | ms_spectral_lib_peak |
getConsensusData(int *numerator, int *denominator, double *medianDeviation) const | ms_spectral_lib_peak |
getDelta() const | ms_spectral_lib_peak |
getIntensity() const | ms_spectral_lib_peak |
getMz() const | ms_spectral_lib_peak |
getUnmatchedAnnotationStr(ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak | [static]
isMatchedToCalculatedPeak() const | ms_spectral_lib_peak |
isSuspectAssignment() const | ms_spectral_lib_peak |
isValid() const | ms_spectral_lib_peak |
ms_spectral_lib_peak(const std::string &text, ms_spectral_lib::FILE_FORMAT format, matrix_science::ms_errs &errs) | ms_spectral_lib_peak |
ms_spectral_lib_peak(const double mz, const double intensity, const std::string &annotation, ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak |
ms_spectral_lib_peak(const ms_spectral_lib_peak &src) | ms_spectral_lib_peak |
operator=(const ms_spectral_lib_peak &right) | ms_spectral_lib_peak |
setAnnotation(const std::string &annotation, ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_spectral_lib_peak_list Member List

This is the complete list of members for ms_spectral_lib_peak_list, including all inherited members.
addPeaks(const std::vector< double > &vecMz, const std::vector< double > &vecIntensity) | ms_spectral_lib_peak_list
ANNOT_LVL_CANNOT_ANNOTATE enum value | ms_spectral_lib_peak_list
ANNOT_LVL_NONE enum value | ms_spectral_lib_peak_list
ANNOT_LVL_QUESTION_MARKS enum value | ms_spectral_lib_peak_list
ANNOT_LVL_SOME_PEAKS enum value | ms_spectral_lib_peak_list
annotatePeaks(const ms_fragmentvector *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz) | ms_spectral_lib_peak_list
annotatePeaks(const std::vector< ms_fragment > *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz) | ms_spectral_lib_peak_list
appendErrors(const ms_errors &src) | ms_errors
asText(ms_spectral_lib::FILE_FORMAT format) const | ms_spectral_lib_peak_list
clearAllErrors() | ms_errors
clearAnnotation() | ms_spectral_lib_peak_list
copyFrom(const ms_spectral_lib_peak_list *right) | ms_spectral_lib_peak_list
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getChecksum() const | ms_spectral_lib_peak_list
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumPeaks() const | ms_spectral_lib_peak_list
getPeak(const int pkNum) const | ms_spectral_lib_peak_list
getPeakAnnotationLevel() const | ms_spectral_lib_peak_list
isValid() const | ms_errors
ms_errors() | ms_errors
ms_spectral_lib_peak_list() | ms_spectral_lib_peak_list
ms_spectral_lib_peak_list(std::vector< std::string > input, ms_spectral_lib::FILE_FORMAT format) | ms_spectral_lib_peak_list
ms_spectral_lib_peak_list(const ms_spectral_lib_peak_list &src) | ms_spectral_lib_peak_list
operator=(const ms_spectral_lib_peak_list &right) | ms_spectral_lib_peak_list
PEAK_ANNOTATION_LEVEL enum name | ms_spectral_lib_peak_list
setAnnotationLevel(PEAK_ANNOTATION_LEVEL level) | ms_spectral_lib_peak_list
~ms_errors() | ms_errors
~ms_spectral_lib_peak_list() | ms_spectral_lib_peak_list
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_stdout_logger Member List

This is the complete list of members for ms_stdout_logger, including all inherited members.
COL_ASC_TIME enum value | ms_logger |
COL_HEADERS enum value | ms_logger |
COL_IP_ADDRESS enum value | ms_logger |
COL_ISO8601_TIME enum value | ms_logger |
COL_LOGGER_DEFAULTS enum value | ms_logger |
COL_MSG enum value | ms_logger |
COL_MSG_NUM_DEC enum value | ms_logger |
COL_MSG_NUM_HEX enum value | ms_logger |
COL_MSG_SOURCE_TXT enum value | ms_logger |
COL_QUOTES enum value | ms_logger |
COL_SEVERITY_NUM enum value | ms_logger |
COL_SEVERITY_TXT enum value | ms_logger |
COL_SRC_FILE enum value | ms_logger |
COL_SRC_LINENUM enum value | ms_logger |
COL_THREAD_ID enum value | ms_logger |
COL_TSV enum value | ms_logger |
formatMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId) const | ms_logger |
getColsToOutput() const | ms_logger | [virtual]
getHeaderLine() const | ms_logger |
LogOutputColumns_e enum name | ms_logger |
ms_logger(const unsigned int colsToOutput=COL_MSG) | ms_logger |
ms_stdout_logger(unsigned int colsToOutput=ms_logger::COL_LOGGER_DEFAULTS) | ms_stdout_logger |
onLogMessage(ms_loggingmonitor::Level_e eSeverity, ms_loggingmonitor::Source_e eSource, long lMsgId, const std::string &text, const char *srcFileName, const int srcFileLineNum, long lContextId=0) | ms_stdout_logger | [virtual]
setColsToOutput(const unsigned int colsToOutput) | ms_logger | [virtual]
~ms_logger() | ms_logger | [inline, virtual]
~ms_stdout_logger() | ms_stdout_logger | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_taxnodesfiles Member List

This is the complete list of members for ms_taxnodesfiles, including all inherited members.
copyFrom(const ms_taxnodesfiles *right) | ms_taxnodesfiles
defaultValues() | ms_taxnodesfiles
getFileName() const | ms_taxnodesfiles
getFormat() const | ms_taxnodesfiles
ms_taxnodesfiles() | ms_taxnodesfiles
ms_taxnodesfiles(const ms_taxnodesfiles &src) | ms_taxnodesfiles
operator=(const ms_taxnodesfiles &right) | ms_taxnodesfiles
setFileName(const char *name) | ms_taxnodesfiles
setFormat(const TAX_NODE_FORMAT value) | ms_taxnodesfiles
~ms_taxnodesfiles() | ms_taxnodesfiles
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_taxonomychoice Member List

This is the complete list of members for ms_taxonomychoice, including all inherited members.
appendExcludeTaxonomy(const int id) | ms_taxonomychoice
appendIncludeTaxonomy(const int id) | ms_taxonomychoice
clearExcludeTaxonomies() | ms_taxonomychoice
clearIncludeTaxonomies() | ms_taxonomychoice
copyFrom(const ms_taxonomychoice *src) | ms_taxonomychoice
defaultValues() | ms_taxonomychoice
getExcludeTaxonomy(const int n) const | ms_taxonomychoice
getIncludeTaxonomy(const int n) const | ms_taxonomychoice
getNumberOfExcludeTaxonomies() const | ms_taxonomychoice
getNumberOfIncludeTaxonomies() const | ms_taxonomychoice
getPreceedingComments() const | ms_customproperty
getTitle() const | ms_taxonomychoice
ms_customproperty() | ms_customproperty
ms_taxonomychoice() | ms_taxonomychoice
ms_taxonomychoice(const ms_taxonomychoice &src) | ms_taxonomychoice
operator=(const ms_taxonomychoice &right) | ms_taxonomychoice
setPreceedingComments(const std::string &comments) | ms_customproperty
setTitle(const char *value) | ms_taxonomychoice
~ms_customproperty() | ms_customproperty
~ms_taxonomychoice() | ms_taxonomychoice
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_taxonomyfile Member List

This is the complete list of members for ms_taxonomyfile, including all inherited members.
appendEntry(const ms_taxonomychoice *item) | ms_taxonomyfile
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
clearEntries() | ms_taxonomyfile
copyFrom(const ms_taxonomyfile *right) | ms_taxonomyfile
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_taxonomyfile
getConnectionSettings() const | ms_taxonomyfile
getEntryByName(const char *name) | ms_taxonomyfile
getEntryByNumber(const int index) const | ms_taxonomyfile
getErrorHandler() const | ms_errors
getFileName() const | ms_taxonomyfile
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getNumberOfEntries() const | ms_taxonomyfile
isValid() const | ms_errors
ms_errors() | ms_errors
ms_taxonomyfile() | ms_taxonomyfile
ms_taxonomyfile(const ms_taxonomyfile &src) | ms_taxonomyfile
ms_taxonomyfile(const char *filename, const matrix_science::ms_connection_settings *cs=0) | ms_taxonomyfile
operator=(const ms_taxonomyfile &right) | ms_taxonomyfile
read_buffer(const char *buffer) | ms_taxonomyfile
read_file() | ms_taxonomyfile
save_file() | ms_taxonomyfile
setConnectionSettings(const matrix_science::ms_connection_settings &cs) | ms_taxonomyfile
setFileName(const char *name) | ms_taxonomyfile
~ms_errors() | ms_errors
~ms_taxonomyfile() | ms_taxonomyfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_taxonomyrules Member List

This is the complete list of members for ms_taxonomyrules, including all inherited members.
appendGencodeFile(const ms_taxnodesfiles *item) | ms_taxonomyrules
appendNoBreakDescLineIf(const char *str) | ms_taxonomyrules
appendNodesFile(const ms_taxnodesfiles *item) | ms_taxonomyrules
appendPerDbSrcRule(const ms_parserule_plus *item) | ms_taxonomyrules
appendPrefixRemove(const char *item) | ms_taxonomyrules
appendSpeciesFile(const ms_taxspeciesfiles *item) | ms_taxonomyrules
appendStrFile(const ms_taxspeciesfiles *item) | ms_taxonomyrules
appendSuffixRemove(const char *item) | ms_taxonomyrules
clearDBLevelTaxId() | ms_taxonomyrules
clearGencodeFiles() | ms_taxonomyrules
clearNoBreakDescLineIf() | ms_taxonomyrules
clearNodesFiles() | ms_taxonomyrules
clearPerDbSrcRules() | ms_taxonomyrules
clearPrefixRemoves() | ms_taxonomyrules
clearSpeciesFiles() | ms_taxonomyrules
clearSuffixRemoves() | ms_taxonomyrules
copyFrom(const ms_taxonomyrules *right) | ms_taxonomyrules
defaultValues() | ms_taxonomyrules
getAccFromSpeciesLine() const | ms_taxonomyrules
getDBLevelTaxId() const | ms_taxonomyrules
getDefaultRule() const | ms_taxonomyrules
getDescriptionLineSep() const | ms_taxonomyrules
getDoThisRuleFirst() const | ms_taxonomyrules
getErrorLevel() const | ms_taxonomyrules
getGencodeFile(const int index) const | ms_taxonomyrules
getIdentifier() const | ms_taxonomyrules
getNoBreakDescLineIf(const int index) const | ms_taxonomyrules
getNodesFile(const int index) const | ms_taxonomyrules
getNumberOfGencodeFiles() const | ms_taxonomyrules
getNumberOfNoBreakDescLineIf() const | ms_taxonomyrules
getNumberOfNodesFiles() const | ms_taxonomyrules
getNumberOfPerDbSrcRules() const | ms_taxonomyrules
getNumberOfPrefixRemoves() const | ms_taxonomyrules
getNumberOfSpeciesFiles() const | ms_taxonomyrules
getNumberOfStrFiles() const | ms_taxonomyrules
getNumberOfSuffixRemoves() const | ms_taxonomyrules
getPerDbSrcRule(const int index) const | ms_taxonomyrules
getPreceedingComments() const | ms_customproperty
getPrefixRemove(const int index) const | ms_taxonomyrules
getQuickRefSearch() const | ms_taxonomyrules
getSpeciesFile(const int index) const | ms_taxonomyrules
getSpeciesFormatRegex(const TAX_SPECIES_FORMAT format) const | ms_taxonomyrules
getSrcDatabaseRule() const | ms_taxonomyrules
getStrFile(const int index) const | ms_taxonomyrules
getStrRule() const | ms_taxonomyrules
getSuffixRemove(const int index) const | ms_taxonomyrules
isConcatRefFileLines() const | ms_taxonomyrules
isDBLevelTaxId() const | ms_taxonomyrules
isEnabled() const | ms_taxonomyrules
isFromRefFile() const | ms_taxonomyrules
isMitochondrialTranslation() const | ms_taxonomyrules
isSectionAvailable() const | ms_taxonomyrules
ms_customproperty() | ms_customproperty
ms_taxonomyrules() | ms_taxonomyrules
ms_taxonomyrules(const ms_taxonomyrules &src) | ms_taxonomyrules
operator=(const ms_taxonomyrules &right) | ms_taxonomyrules
setAccFromSpeciesLine(const ms_parserule *src) | ms_taxonomyrules
setConcatRefFileLines(const bool flag) | ms_taxonomyrules
setDBLevelTaxId(const int value) | ms_taxonomyrules
setDefaultRule(const ms_parserule_plus *src) | ms_taxonomyrules
setDescriptionLineSep(const char value) | ms_taxonomyrules
setDoThisRuleFirst(const ms_parserule *src) | ms_taxonomyrules
setEnabled(const bool flag) | ms_taxonomyrules
setErrorLevel(const int value) | ms_taxonomyrules
setFromRefFile(const bool flag) | ms_taxonomyrules
setIdentifier(const char *str) | ms_taxonomyrules
setMitochondrialTranslation(const bool flag) | ms_taxonomyrules
setPreceedingComments(const std::string &comments) | ms_customproperty
setQuickRefSearch(const char *str) | ms_taxonomyrules
setSectionAvailable(const bool value) | ms_taxonomyrules
setSpeciesFormatRegex(const TAX_SPECIES_FORMAT format, const std::string regex) | ms_taxonomyrules
setSrcDatabaseRule(const ms_parserule *src) | ms_taxonomyrules
setStrRule(const ms_parserule_plus *src) | ms_taxonomyrules
~ms_customproperty() | ms_customproperty
~ms_taxonomyrules() | ms_taxonomyrules
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_taxonomytree Member List

This is the complete list of members for ms_taxonomytree, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
copyFrom(const ms_taxonomytree *right) | ms_taxonomytree
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getParent(const int id, int &ttParent, int &ttGenTable) const | ms_taxonomytree
getTaxIDArray() | ms_taxonomytree
isIncludedIn(const int id, const ms_taxonomychoice *choice) const | ms_taxonomytree
isSpeciesDescendantOf(const int parentID, const int id) const | ms_taxonomytree
isValid() const | ms_errors
ms_errors() | ms_errors
ms_taxonomytree(const ms_taxonomyrules *taxonomyRules, const char *taxonomyDirectory="../taxonomy", const bool useIndex=true, const bool createList=false, const char *preparingDirectory="../taxonomy/preparing", const char *oldDirectory="../taxonomy/old") | ms_taxonomytree
ms_taxonomytree(const ms_taxonomytree &src) | ms_taxonomytree
operator=(const ms_taxonomytree &right) | ms_taxonomytree
~ms_errors() | ms_errors
~ms_taxonomytree() | ms_taxonomytree
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_taxspeciesfiles Member List

This is the complete list of members for ms_taxspeciesfiles, including all inherited members.
copyFrom(const ms_taxspeciesfiles *right) | ms_taxspeciesfiles
defaultValues() | ms_taxspeciesfiles
getFileName() const | ms_taxspeciesfiles
getFormat() const | ms_taxspeciesfiles
ms_taxspeciesfiles() | ms_taxspeciesfiles
ms_taxspeciesfiles(const ms_taxspeciesfiles &src) | ms_taxspeciesfiles
operator=(const ms_taxspeciesfiles &right) | ms_taxspeciesfiles
setFileName(const char *name) | ms_taxspeciesfiles
setFormat(const TAX_SPECIES_FORMAT value) | ms_taxspeciesfiles
~ms_taxspeciesfiles() | ms_taxspeciesfiles
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_tinycdb Member List

This is the complete list of members for ms_tinycdb, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
closeIndexFile() | ms_tinycdb
copyFrom(const ms_errors *right) | ms_errors
finishCreate() | ms_tinycdb
getAllValuesFromKey(const std::string &keyName) | ms_tinycdb
getErrorHandler() const | ms_errors
getFileOffsetFromKey(const std::string &keyName) | ms_tinycdb
getIndexFileName() const | ms_tinycdb
getIntFromKey(const std::string &keyName) | ms_tinycdb
getIntFromKey(const std::string &keyName, bool &found) | ms_tinycdb
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
getValueFromKey(const std::string &keyName, const int count=0) | ms_tinycdb
isCreating() const | ms_tinycdb
isOpenForReading() const | ms_tinycdb
isPossibleToCreate() const | ms_tinycdb
isValid() const | ms_errors
makeExists(const char *key) const | ms_tinycdb
ms_errors() | ms_errors
ms_tinycdb(const char *indexFileName, const char *versionNumber, const char *sourceFileName) | ms_tinycdb
openIndexFile(const bool mayRetryBuilding) | ms_tinycdb
prepareToCreate() | ms_tinycdb
saveFileOffsetForKey(const std::string &keyName, OFFSET64_T offset) | ms_tinycdb
saveIntForKey(const std::string &keyName, int value) | ms_tinycdb
saveValueForKey(const char *keyName, const char *value, const unsigned int keyNameLen=0, const unsigned int valueLen=0) | ms_tinycdb
setIndexFileName(const char *filename) | ms_tinycdb
~ms_errors() | ms_errors
~ms_tinycdb() | ms_tinycdb
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_treecluster Member List

This is the complete list of members for ms_treecluster, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors
clearAllErrors() | ms_errors
cluster(TREE_CLUSTER_DISTANCE tcd, ms_mascotresults::TREE_CLUSTER_METHOD tcm, const std::vector< double > &weight, std::vector< int > &left, std::vector< int > &right, std::vector< double > &distance, bool transpose=false) | ms_treecluster
copyFrom(const ms_treecluster *right) | ms_treecluster
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors
defaultValues() | ms_treecluster
getErrorHandler() const | ms_errors
getLastError() const | ms_errors
getLastErrorString() const | ms_errors
isValid() const | ms_errors
ms_errors() | ms_errors
ms_treecluster(int rows, int columns) | ms_treecluster
ms_treecluster(const ms_treecluster &right) | ms_treecluster
operator=(const ms_treecluster &right) | ms_treecluster
setRow(int row, std::vector< double > datarow, std::vector< int > maskrow) | ms_treecluster
TCD_ABS_CORRELATION enum value | ms_treecluster
TCD_ABS_UNCENTERED_CORRELATION enum value | ms_treecluster
TCD_CITY_BLOCK enum value | ms_treecluster
TCD_CORRELATION enum value | ms_treecluster
TCD_EUCLIDEAN enum value | ms_treecluster
TCD_KENDALLS_TAU_CORRELATION enum value | ms_treecluster
TCD_SPEARMANS_RANK_CORRELATION enum value | ms_treecluster
TCD_UNCENTERED_CORRELATION enum value | ms_treecluster
TREE_CLUSTER_DISTANCE enum name | ms_treecluster
~ms_errors() | ms_errors
~ms_treecluster() | ms_treecluster
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_aminoacid Member List

This is the complete list of members for ms_umod_aminoacid, including all inherited members.
appendElemRef(const ms_umod_elemref *elemref) | ms_umod_aminoacid |
clearElemRefs() | ms_umod_aminoacid |
copyFrom(const ms_umod_aminoacid *right) | ms_umod_aminoacid |
defaultValues() | ms_umod_aminoacid |
deleteElemRef(const int idx) | ms_umod_aminoacid |
dropAvgeMass() | ms_umod_aminoacid |
dropFullName() | ms_umod_aminoacid |
dropMonoMass() | ms_umod_aminoacid |
dropThreeLetter() | ms_umod_aminoacid |
dropTitle() | ms_umod_aminoacid |
getAvgeMass() const | ms_umod_aminoacid |
getAvgeMassSchemaType() const | ms_umod_aminoacid |
getElemRef(const int idx) const | ms_umod_aminoacid |
getElemRefSchemaType() const | ms_umod_aminoacid |
getFullName() const | ms_umod_aminoacid |
getFullNameSchemaType() const | ms_umod_aminoacid |
getMonoMass() const | ms_umod_aminoacid |
getMonoMassSchemaType() const | ms_umod_aminoacid |
getNumberOfElemRefs() const | ms_umod_aminoacid |
getSchemaType() const | ms_umod_aminoacid | [virtual]
getThreeLetter() const | ms_umod_aminoacid |
getThreeLetterSchemaType() const | ms_umod_aminoacid |
getTitle() const | ms_umod_aminoacid |
getTitleSchemaType() const | ms_umod_aminoacid |
haveAvgeMass() const | ms_umod_aminoacid |
haveFullName() const | ms_umod_aminoacid |
haveMonoMass() const | ms_umod_aminoacid |
haveThreeLetter() const | ms_umod_aminoacid |
haveTitle() const | ms_umod_aminoacid |
ms_umod_aminoacid() | ms_umod_aminoacid |
ms_umod_aminoacid(const ms_umod_aminoacid &src) | ms_umod_aminoacid |
operator=(const ms_umod_aminoacid &right) | ms_umod_aminoacid |
setAvgeMass(const double value) | ms_umod_aminoacid |
setFullName(const char *value) | ms_umod_aminoacid |
setMonoMass(const double value) | ms_umod_aminoacid |
setThreeLetter(const char *value) | ms_umod_aminoacid |
setTitle(const char *value) | ms_umod_aminoacid |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_aminoacid |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_aminoacid | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_aminoacid | [virtual]
~ms_umod_aminoacid() | ms_umod_aminoacid | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_composition Member List

This is the complete list of members for ms_umod_composition, including all inherited members.
appendElemRef(const ms_umod_elemref *elemref) | ms_umod_composition |
clearElemRefs() | ms_umod_composition |
copyFrom(const ms_umod_composition *right) | ms_umod_composition |
copyFrom(const ms_quant_composition *right, const ms_umod_configfile &umodFile) | ms_umod_composition |
defaultValues() | ms_umod_composition |
deleteElemRef(const int idx) | ms_umod_composition |
dropAvgeMass() | ms_umod_composition |
dropCompositionString() | ms_umod_composition |
dropMonoMass() | ms_umod_composition |
getAvgeMass() const | ms_umod_composition |
getAvgeMassSchemaType() const | ms_umod_composition |
getCompositionString() const | ms_umod_composition |
getCompositionStringSchemaType() const | ms_umod_composition |
getElemRef(const int idx) const | ms_umod_composition |
getElemRefSchemaType() const | ms_umod_composition |
getMonoMass() const | ms_umod_composition |
getMonoMassSchemaType() const | ms_umod_composition |
getNumberOfElemRefs() const | ms_umod_composition |
getSchemaType() const | ms_umod_composition | [virtual]
haveAvgeMass() const | ms_umod_composition |
haveCompositionString() const | ms_umod_composition |
haveMonoMass() const | ms_umod_composition |
isSameAs(const ms_umod_composition &right) const | ms_umod_composition |
ms_umod_composition() | ms_umod_composition |
ms_umod_composition(const ms_umod_composition &src) | ms_umod_composition |
ms_umod_composition(const ms_quant_composition &src, const ms_umod_configfile &umodFile) | ms_umod_composition |
operator=(const ms_umod_composition &right) | ms_umod_composition |
setAvgeMass(const double value) | ms_umod_composition |
setCompositionString(const char *value) | ms_umod_composition |
setMonoMass(const double value) | ms_umod_composition |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_composition |
updateMasses(const ms_umod_configfile &umodFile, const ms_quant_component &quantComp) | ms_umod_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_composition | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_composition | [virtual]
~ms_umod_composition() | ms_umod_composition | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_configfile Member List

This is the complete list of members for ms_umod_configfile, including all inherited members.
appendAminoAcid(const ms_umod_aminoacid *aa) | ms_umod_configfile |
appendElement(const ms_umod_element *elem) | ms_umod_configfile |
appendErrors(const ms_errors &src) | ms_errors |
appendModBrick(const ms_umod_modbrick *brick) | ms_umod_configfile |
appendModification(const ms_umod_modification *mod) | ms_umod_configfile |
applyVisibility(const ms_session *session) | ms_umod_configfile |
applyVisibility(const std::vector< int > &groupIds) | ms_umod_configfile |
clearAllErrors() | ms_errors |
clearAminoAcids() | ms_umod_configfile |
clearElements() | ms_umod_configfile |
clearModBricks() | ms_umod_configfile |
clearModifications() | ms_umod_configfile |
copyFrom(const ms_umod_configfile *right) | ms_umod_configfile |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
defaultValues() | ms_umod_configfile | [virtual]
deleteAminoAcidByName(const char *name) | ms_umod_configfile |
deleteAminoAcidByNumber(const int idx) | ms_umod_configfile |
deleteElementByName(const char *name) | ms_umod_configfile |
deleteElementByNumber(const int idx) | ms_umod_configfile |
deleteModBrickByName(const char *name) | ms_umod_configfile |
deleteModBrickByNumber(const int idx) | ms_umod_configfile |
deleteModificationByName(const char *name) | ms_umod_configfile |
deleteModificationByNumber(const int idx) | ms_umod_configfile |
findModFileName(const char *modFileName) const | ms_umod_configfile |
findModification(const char *modName) const | ms_umod_configfile |
getAminoAcidByName(const char *name) const | ms_umod_configfile |
getAminoAcidByNumber(const int idx) const | ms_umod_configfile |
getConnectionSettings() const | ms_umod_configfile |
getDefaultSchemaFileName() | ms_umod_configfile | [static]
getElementByName(const char *name) const | ms_umod_configfile |
getElementByNumber(const int idx) const | ms_umod_configfile |
getErrorHandler() const | ms_errors |
getFileName() const | ms_umod_configfile |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getMajorVersion() const | ms_umod_configfile |
getMinorVersion() const | ms_umod_configfile |
getModBrickByName(const char *name) const | ms_umod_configfile |
getModBrickByNumber(const int idx) const | ms_umod_configfile |
getModFileList(const unsigned int flags=MODFILE_FLAGS_ALL) const | ms_umod_configfile |
getModificationByName(const char *name) const | ms_umod_configfile |
getModificationByNumber(const int idx) const | ms_umod_configfile |
getNumberOfAminoAcids() const | ms_umod_configfile |
getNumberOfElements() const | ms_umod_configfile |
getNumberOfModBricks() const | ms_umod_configfile |
getNumberOfModifications() const | ms_umod_configfile |
getSchemaFileName() const | ms_umod_configfile |
isValid() const | ms_errors |
MODFILE_FLAGS enum name | ms_umod_configfile |
MODFILE_FLAGS_AASUBST enum value | ms_umod_configfile |
MODFILE_FLAGS_ALL enum value | ms_umod_configfile |
MODFILE_FLAGS_EMPTY enum value | ms_umod_configfile |
MODFILE_FLAGS_HIDDEN enum value | ms_umod_configfile |
MODFILE_FLAGS_REGULAR enum value | ms_umod_configfile |
ms_errors() | ms_errors |
ms_umod_configfile() | ms_umod_configfile |
ms_umod_configfile(const char *fileName, const char *schemaFileName, const ms_connection_settings *cs=0, bool useSchema=true) | ms_umod_configfile |
ms_umod_configfile(const ms_umod_configfile &right) | ms_umod_configfile |
operator=(const ms_umod_configfile &right) | ms_umod_configfile |
read_buffer(const char *buffer) | ms_umod_configfile |
read_file() | ms_umod_configfile |
save_buffer(bool validateAgainstSchema=true) | ms_umod_configfile |
save_file() | ms_umod_configfile |
setConnectionSettings(const ms_connection_settings &cs) | ms_umod_configfile |
setFileName(const char *filename) | ms_umod_configfile |
setMajorVersion(const std::string &version) | ms_umod_configfile |
setMinorVersion(const std::string &version) | ms_umod_configfile |
setSchemaFileName(const char *name) | ms_umod_configfile |
updateAminoAcidByName(const char *name, const ms_umod_aminoacid *aa) | ms_umod_configfile |
updateAminoAcidByNumber(const int idx, const ms_umod_aminoacid *aa) | ms_umod_configfile |
updateElementByName(const char *name, const ms_umod_element *element) | ms_umod_configfile |
updateElementByNumber(const int idx, const ms_umod_element *element) | ms_umod_configfile |
updateMasses() | ms_umod_configfile |
updateModBrickByName(const char *name, const ms_umod_modbrick *brick) | ms_umod_configfile |
updateModBrickByNumber(const int idx, const ms_umod_modbrick *brick) | ms_umod_configfile |
updateModificationByName(const char *name, const ms_umod_modification *mod) | ms_umod_configfile |
updateModificationByNumber(const int idx, const ms_umod_modification *mod) | ms_umod_configfile |
validateDocument() const | ms_umod_configfile |
~ms_errors() | ms_errors |
~ms_umod_configfile() | ms_umod_configfile | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_element Member List

This is the complete list of members for ms_umod_element, including all inherited members.
copyFrom(const ms_umod_element *right) | ms_umod_element |
defaultValues() | ms_umod_element |
dropAvgeMass() | ms_umod_element |
dropFullName() | ms_umod_element |
dropMonoMass() | ms_umod_element |
dropTitle() | ms_umod_element |
getAvgeMass() const | ms_umod_element |
getAvgeMassAsNumber() const | ms_umod_element |
getAvgeMassSchemaType() const | ms_umod_element |
getFullName() const | ms_umod_element |
getFullNameSchemaType() const | ms_umod_element |
getMonoMass() const | ms_umod_element |
getMonoMassAsNumber() const | ms_umod_element |
getMonoMassSchemaType() const | ms_umod_element |
getSchemaType() const | ms_umod_element | [virtual]
getTitle() const | ms_umod_element |
getTitleSchemaType() const | ms_umod_element |
haveAvgeMass() const | ms_umod_element |
haveFullName() const | ms_umod_element |
haveMonoMass() const | ms_umod_element |
haveTitle() const | ms_umod_element |
ms_umod_element() | ms_umod_element |
ms_umod_element(const ms_umod_element &src) | ms_umod_element |
operator=(const ms_umod_element &right) | ms_umod_element |
setAvgeMass(const char *value, ms_errs *err=NULL) | ms_umod_element |
setFullName(const char *value) | ms_umod_element |
setMonoMass(const char *value, ms_errs *err=NULL) | ms_umod_element |
setTitle(const char *value) | ms_umod_element |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_element | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_element | [virtual]
~ms_umod_element() | ms_umod_element | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_elemref Member List

This is the complete list of members for ms_umod_elemref, including all inherited members.
copyFrom(const ms_umod_elemref *right) | ms_umod_elemref |
copyFrom(const ms_quant_element *right) | ms_umod_elemref |
defaultValues() | ms_umod_elemref |
dropNumber() | ms_umod_elemref |
dropSymbol() | ms_umod_elemref |
getNumber() const | ms_umod_elemref |
getNumberSchemaType() const | ms_umod_elemref |
getSchemaType() const | ms_umod_elemref | [virtual]
getSymbol() const | ms_umod_elemref |
getSymbolSchemaType() const | ms_umod_elemref |
haveNumber() const | ms_umod_elemref |
haveSymbol() const | ms_umod_elemref |
ms_umod_elemref() | ms_umod_elemref |
ms_umod_elemref(const ms_umod_elemref &src) | ms_umod_elemref |
ms_umod_elemref(const ms_quant_element &src) | ms_umod_elemref |
operator=(const ms_umod_elemref &right) | ms_umod_elemref |
setNumber(const int value) | ms_umod_elemref |
setSymbol(const char *value) | ms_umod_elemref |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_elemref | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_elemref | [virtual]
~ms_umod_elemref() | ms_umod_elemref | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_modbrick Member List

This is the complete list of members for ms_umod_modbrick, including all inherited members.
appendElemRef(const ms_umod_elemref *elemref) | ms_umod_modbrick |
clearElemRefs() | ms_umod_modbrick |
copyFrom(const ms_umod_modbrick *right) | ms_umod_modbrick |
defaultValues() | ms_umod_modbrick |
deleteElemRef(const int idx) | ms_umod_modbrick |
dropAvgeMass() | ms_umod_modbrick |
dropFullName() | ms_umod_modbrick |
dropMonoMass() | ms_umod_modbrick |
dropTitle() | ms_umod_modbrick |
getAvgeMass() const | ms_umod_modbrick |
getAvgeMassSchemaType() const | ms_umod_modbrick |
getElemRef(const int idx) const | ms_umod_modbrick |
getElemRefSchemaType() const | ms_umod_modbrick |
getFullName() const | ms_umod_modbrick |
getFullNameSchemaType() const | ms_umod_modbrick |
getMonoMass() const | ms_umod_modbrick |
getMonoMassSchemaType() const | ms_umod_modbrick |
getNumberOfElemRefs() const | ms_umod_modbrick |
getSchemaType() const | ms_umod_modbrick | [virtual]
getTitle() const | ms_umod_modbrick |
getTitleSchemaType() const | ms_umod_modbrick |
haveAvgeMass() const | ms_umod_modbrick |
haveFullName() const | ms_umod_modbrick |
haveMonoMass() const | ms_umod_modbrick |
haveTitle() const | ms_umod_modbrick |
ms_umod_modbrick() | ms_umod_modbrick |
ms_umod_modbrick(const ms_umod_modbrick &src) | ms_umod_modbrick |
operator=(const ms_umod_modbrick &right) | ms_umod_modbrick |
setAvgeMass(const double value) | ms_umod_modbrick |
setFullName(const char *value) | ms_umod_modbrick |
setMonoMass(const double value) | ms_umod_modbrick |
setTitle(const char *value) | ms_umod_modbrick |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_modbrick |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modbrick | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modbrick | [virtual]
~ms_umod_modbrick() | ms_umod_modbrick | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_modification Member List

This is the complete list of members for ms_umod_modification, including all inherited members.
appendAltName(const char *alt_name) | ms_umod_modification |
appendIgnore(const ms_umod_composition *ignore) | ms_umod_modification |
appendSpecificity(const ms_umod_specificity *specificity) | ms_umod_modification |
appendXref(const ms_umod_xref *xref) | ms_umod_modification |
clearAltNames() | ms_umod_modification |
clearIgnores() | ms_umod_modification |
clearSpecificities() | ms_umod_modification |
clearXrefs() | ms_umod_modification |
copyFrom(const ms_umod_modification *right) | ms_umod_modification |
copyFrom(const ms_quant_localdef *right, const ms_umod_configfile &umodFile) | ms_umod_modification |
copyFrom(const ms_quant_unmodified *right) | ms_umod_modification |
defaultValues() | ms_umod_modification |
deleteAltName(const int idx) | ms_umod_modification |
deleteIgnore(const int idx) | ms_umod_modification |
deleteSpecificity(const int idx) | ms_umod_modification |
deleteXref(const int idx) | ms_umod_modification |
dropApproved() | ms_umod_modification |
dropDateTimeModified() | ms_umod_modification |
dropDateTimePosted() | ms_umod_modification |
dropDelta() | ms_umod_modification |
dropFullName() | ms_umod_modification |
dropGroupOfPoster() | ms_umod_modification |
dropMiscNotes() | ms_umod_modification |
dropRecordID() | ms_umod_modification |
dropTitle() | ms_umod_modification |
dropUsernameOfPoster() | ms_umod_modification |
findSpecGroup(const char *modFileName) const | ms_umod_modification |
getAltName(const int idx) const | ms_umod_modification |
getAltNameSchemaType() const | ms_umod_modification |
getApprovedSchemaType() const | ms_umod_modification |
getDateTimeModified() const | ms_umod_modification |
getDateTimeModifiedSchemaType() const | ms_umod_modification |
getDateTimePosted() const | ms_umod_modification |
getDateTimePostedSchemaType() const | ms_umod_modification |
getDelta() const | ms_umod_modification |
getDeltaSchemaType() const | ms_umod_modification |
getFullName() const | ms_umod_modification |
getFullNameSchemaType() const | ms_umod_modification |
getGroupOfPoster() const | ms_umod_modification |
getGroupOfPosterSchemaType() const | ms_umod_modification |
getIgnore(const int idx) const | ms_umod_modification |
getIgnoreSchemaType() const | ms_umod_modification |
getMiscNotes() const | ms_umod_modification |
getMiscNotesSchemaType() const | ms_umod_modification |
getModFileList(const unsigned int flags=ms_umod_configfile::MODFILE_FLAGS_ALL) const | ms_umod_modification |
getNumberOfAltNames() const | ms_umod_modification |
getNumberOfIgnores() const | ms_umod_modification |
getNumberOfSpecificities() const | ms_umod_modification |
getNumberOfXrefs() const | ms_umod_modification |
getRecordID() const | ms_umod_modification |
getRecordIDSchemaType() const | ms_umod_modification |
getSchemaType() const | ms_umod_modification | [virtual]
getSpecificity(const int idx) const | ms_umod_modification |
getSpecificityBySite(const char *site) const | ms_umod_modification |
getSpecificityBySiteAndPosition(const char *site, const char *position) const | ms_umod_modification |
getSpecificitySchemaType() const | ms_umod_modification |
getTitle() const | ms_umod_modification |
getTitleSchemaType() const | ms_umod_modification |
getUsernameOfPoster() const | ms_umod_modification |
getUsernameOfPosterSchemaType() const | ms_umod_modification |
getXref(const int idx) const | ms_umod_modification |
getXrefSchemaType() const | ms_umod_modification |
haveApproved() const | ms_umod_modification |
haveDateTimeModified() const | ms_umod_modification |
haveDateTimePosted() const | ms_umod_modification |
haveDelta() const | ms_umod_modification |
haveFullName() const | ms_umod_modification |
haveGroupOfPoster() const | ms_umod_modification |
haveMiscNotes() const | ms_umod_modification |
haveRecordID() const | ms_umod_modification |
haveTitle() const | ms_umod_modification |
haveUsernameOfPoster() const | ms_umod_modification |
isApproved() const | ms_umod_modification |
isPrivacyEnabled() const | ms_umod_modification |
isPrivate() const | ms_umod_modification |
isSameAs(const ms_umod_modification &right_mod) const | ms_umod_modification |
ms_umod_modification() | ms_umod_modification |
ms_umod_modification(const ms_umod_modification &src) | ms_umod_modification |
ms_umod_modification(const ms_quant_localdef &src, const ms_umod_configfile &umodFile) | ms_umod_modification |
ms_umod_modification(const ms_quant_unmodified &src) | ms_umod_modification |
operator=(const ms_umod_modification &right) | ms_umod_modification |
setApproved(const bool value) | ms_umod_modification |
setDateTimeModified(const char *value) | ms_umod_modification |
setDateTimePosted(const char *value) | ms_umod_modification |
setDelta(const ms_umod_composition *delta) | ms_umod_modification |
setFullName(const char *value) | ms_umod_modification |
setGroupOfPoster(const char *value) | ms_umod_modification |
setMiscNotes(const char *value) | ms_umod_modification |
setPrivacyEnabled(bool b) | ms_umod_modification |
setPrivate(bool b) | ms_umod_modification |
setRecordID(const char *value) | ms_umod_modification |
setTitle(const char *value) | ms_umod_modification |
setUsernameOfPoster(const char *value) | ms_umod_modification |
updateAltName(const int idx, const char *alt_name) | ms_umod_modification |
updateIgnore(const int idx, const ms_umod_composition *ignore) | ms_umod_modification |
updateMasses(const ms_umod_configfile &umodFile, const ms_quant_component &quantComp) | ms_umod_modification |
updateSpecificity(const int idx, const ms_umod_specificity *specificity) | ms_umod_modification |
updateXref(const int idx, const ms_umod_xref *xref) | ms_umod_modification |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modification | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_modification | [virtual]
~ms_umod_modification() | ms_umod_modification | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_neutralloss Member List

This is the complete list of members for ms_umod_neutralloss, including all inherited members.
appendElemRef(const ms_umod_elemref *elemref) | ms_umod_composition |
clearElemRefs() | ms_umod_composition |
copyFrom(const ms_umod_neutralloss *right) | ms_umod_neutralloss |
copyFrom(const ms_quant_neutralloss *right, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
copyFrom(const ms_quant_pepneutralloss *right, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
matrix_science::ms_umod_composition::copyFrom(const ms_umod_composition *right) | ms_umod_composition |
matrix_science::ms_umod_composition::copyFrom(const ms_quant_composition *right, const ms_umod_configfile &umodFile) | ms_umod_composition |
defaultValues() | ms_umod_neutralloss |
deleteElemRef(const int idx) | ms_umod_composition |
dropAvgeMass() | ms_umod_composition |
dropCode() | ms_umod_neutralloss |
dropCompositionString() | ms_umod_composition |
dropDescription() | ms_umod_neutralloss |
dropFlag() | ms_umod_neutralloss |
dropMonoMass() | ms_umod_composition |
dropPairsWith() | ms_umod_neutralloss |
getAvgeMass() const | ms_umod_composition |
getAvgeMassSchemaType() const | ms_umod_composition |
getCode() const | ms_umod_neutralloss |
getCodeSchemaType() const | ms_umod_neutralloss |
getCompositionString() const | ms_umod_composition |
getCompositionStringSchemaType() const | ms_umod_composition |
getDescription() const | ms_umod_neutralloss |
getDescriptionSchemaType() const | ms_umod_neutralloss |
getElemRef(const int idx) const | ms_umod_composition |
getElemRefSchemaType() const | ms_umod_composition |
getFlagSchemaType() const | ms_umod_neutralloss |
getMonoMass() const | ms_umod_composition |
getMonoMassSchemaType() const | ms_umod_composition |
getNumberOfElemRefs() const | ms_umod_composition |
getPairsWith() const | ms_umod_neutralloss |
getPairsWithSchemaType() const | ms_umod_neutralloss |
getSchemaType() const | ms_umod_neutralloss | [virtual]
haveAvgeMass() const | ms_umod_composition |
haveCode() const | ms_umod_neutralloss |
haveCompositionString() const | ms_umod_composition |
haveDescription() const | ms_umod_neutralloss |
haveFlag() const | ms_umod_neutralloss |
haveMonoMass() const | ms_umod_composition |
havePairsWith() const | ms_umod_neutralloss |
isFlag() const | ms_umod_neutralloss |
isSameAs(const ms_umod_composition &right) const | ms_umod_composition |
ms_umod_composition() | ms_umod_composition |
ms_umod_composition(const ms_umod_composition &src) | ms_umod_composition |
ms_umod_composition(const ms_quant_composition &src, const ms_umod_configfile &umodFile) | ms_umod_composition |
ms_umod_neutralloss() | ms_umod_neutralloss |
ms_umod_neutralloss(const ms_umod_neutralloss &src) | ms_umod_neutralloss |
ms_umod_neutralloss(const ms_quant_neutralloss &src, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
ms_umod_neutralloss(const ms_quant_pepneutralloss &src, const ms_umod_configfile &umodFile) | ms_umod_neutralloss |
operator=(const ms_umod_neutralloss &right) | ms_umod_neutralloss |
matrix_science::ms_umod_composition::operator=(const ms_umod_composition &right) | ms_umod_composition |
setAvgeMass(const double value) | ms_umod_composition |
setCode(const char *value) | ms_umod_neutralloss |
setCompositionString(const char *value) | ms_umod_composition |
setDescription(const char *value) | ms_umod_neutralloss |
setFlag(const bool value) | ms_umod_neutralloss |
setMonoMass(const double value) | ms_umod_composition |
setPairsWith(const char *value) | ms_umod_neutralloss |
updateElemRef(const int idx, const ms_umod_elemref *elemref) | ms_umod_composition |
updateMasses(const ms_umod_configfile &umodFile, const ms_quant_component &quantComp) | ms_umod_composition |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_neutralloss | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_neutralloss | [virtual]
~ms_umod_composition() | ms_umod_composition | [virtual]
~ms_umod_neutralloss() | ms_umod_neutralloss | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_specificity Member List

This is the complete list of members for ms_umod_specificity, including all inherited members.
appendNeutralLoss(const ms_umod_neutralloss *nl) | ms_umod_specificity |
appendPepNeutralLoss(const ms_umod_neutralloss *pnl) | ms_umod_specificity |
clearNeutralLosses() | ms_umod_specificity |
clearPepNeutralLosses() | ms_umod_specificity |
copyFrom(const ms_umod_specificity *right) | ms_umod_specificity |
copyFrom(const ms_quant_specificity *right, const ms_umod_configfile &umodFile) | ms_umod_specificity |
defaultValues() | ms_umod_specificity |
deleteNeutralLoss(const int idx) | ms_umod_specificity |
deletePepNeutralLoss(const int idx) | ms_umod_specificity |
dropClassification() | ms_umod_specificity |
dropHidden() | ms_umod_specificity |
dropMiscNotes() | ms_umod_specificity |
dropPosition() | ms_umod_specificity |
dropSite() | ms_umod_specificity |
dropSpecGroup() | ms_umod_specificity |
getClassification() const | ms_umod_specificity |
getClassificationSchemaType() const | ms_umod_specificity |
getHiddenSchemaType() const | ms_umod_specificity |
getMiscNotes() const | ms_umod_specificity |
getMiscNotesSchemaType() const | ms_umod_specificity |
getNeutralLoss(const int idx) const | ms_umod_specificity |
getNeutralLossSchemaType() const | ms_umod_specificity |
getNumberOfNeutralLosses() const | ms_umod_specificity |
getNumberOfPepNeutralLosses() const | ms_umod_specificity |
getPepNeutralLoss(const int idx) const | ms_umod_specificity |
getPepNeutralLossSchemaType() const | ms_umod_specificity |
getPosition() const | ms_umod_specificity |
getPositionSchemaType() const | ms_umod_specificity |
getSchemaType() const | ms_umod_specificity | [virtual]
getSite() const | ms_umod_specificity |
getSiteSchemaType() const | ms_umod_specificity |
getSpecGroup() const | ms_umod_specificity |
getSpecGroupSchemaType() const | ms_umod_specificity |
haveClassification() const | ms_umod_specificity |
haveHidden() const | ms_umod_specificity |
haveMiscNotes() const | ms_umod_specificity |
havePosition() const | ms_umod_specificity |
haveSite() const | ms_umod_specificity |
haveSpecGroup() const | ms_umod_specificity |
inErrorTolerant() const | ms_umod_specificity |
inLongList() const | ms_umod_specificity |
inShortList() const | ms_umod_specificity |
isHidden() const | ms_umod_specificity |
isSameAs(const ms_umod_specificity &right) const | ms_umod_specificity |
ms_umod_specificity() | ms_umod_specificity |
ms_umod_specificity(const ms_umod_specificity &src) | ms_umod_specificity |
ms_umod_specificity(const ms_quant_specificity &src, const ms_umod_configfile &umodFile) | ms_umod_specificity |
operator=(const ms_umod_specificity &right) | ms_umod_specificity |
setClassification(const char *value) | ms_umod_specificity |
setHidden(const bool value) | ms_umod_specificity |
setMiscNotes(const char *value) | ms_umod_specificity |
setPosition(const char *value) | ms_umod_specificity |
setSite(const char *value) | ms_umod_specificity |
setSpecGroup(const int value) | ms_umod_specificity |
showInLongList(bool b) | ms_umod_specificity |
showInShortList(bool b) | ms_umod_specificity |
updateNeutralLoss(const int idx, const ms_umod_neutralloss *nl) | ms_umod_specificity |
updatePepNeutralLoss(const int idx, const ms_umod_neutralloss *pnl) | ms_umod_specificity |
useInErrorTolerant(bool b) | ms_umod_specificity |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_specificity | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_specificity | [virtual]
~ms_umod_specificity() | ms_umod_specificity | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_umod_xref Member List

This is the complete list of members for ms_umod_xref, including all inherited members.
copyFrom(const ms_umod_xref *right) | ms_umod_xref |
defaultValues() | ms_umod_xref |
dropSource() | ms_umod_xref |
dropText() | ms_umod_xref |
dropUrl() | ms_umod_xref |
getSchemaType() const | ms_umod_xref | [virtual]
getSource() const | ms_umod_xref |
getSourceSchemaType() const | ms_umod_xref |
getText() const | ms_umod_xref |
getTextSchemaType() const | ms_umod_xref |
getUrl() const | ms_umod_xref |
getUrlSchemaType() const | ms_umod_xref |
haveSource() const | ms_umod_xref |
haveText() const | ms_umod_xref |
haveUrl() const | ms_umod_xref |
isSameAs(const ms_umod_xref &right) const | ms_umod_xref |
ms_umod_xref() | ms_umod_xref |
ms_umod_xref(const ms_umod_xref &src) | ms_umod_xref |
operator=(const ms_umod_xref &right) | ms_umod_xref |
setSource(const char *value) | ms_umod_xref |
setText(const char *value) | ms_umod_xref |
setUrl(const char *value) | ms_umod_xref |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_umod_xref | [virtual]
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_umod_xref | [virtual]
~ms_umod_xref() | ms_umod_xref | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_unigene Member List

This is the complete list of members for ms_unigene, including all inherited members.
findEntry(const char *id) | ms_unigene
getUnigeneForAccession(const std::string accession, const int index) | ms_unigene
ms_unigene(const ms_mascotresfile &resfile, const char *filename) | ms_unigene
~ms_unigene() | ms_unigene
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_unigene_entry Member List

This is the complete list of members for ms_unigene_entry, including all inherited members.
getChromosome() const | ms_unigene_entry | [inline]
getCytoBand() const | ms_unigene_entry | [inline]
getExpress() const | ms_unigene_entry | [inline]
getFileOffset() const | ms_unigene_entry | [inline]
getGene() const | ms_unigene_entry | [inline]
getID() const | ms_unigene_entry | [inline]
getLocusLink() const | ms_unigene_entry | [inline]
getNumAccessions() const | ms_unigene_entry | [inline]
getTitle() const | ms_unigene_entry | [inline]
ms_unigene_entry(FILE *f, ms_unigene &unigene) | ms_unigene_entry |
ms_unigene_entry(const std::string &id, const std::string &title, const std::string &gene, const std::string &cytoBand, const std::string &locusLink, const std::string &express, const long chromosome, const int numAccessions, const OFFSET64_T fileOffset) | ms_unigene_entry |
~ms_unigene_entry() | ms_unigene_entry |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_unigeneoptions Member List

This is the complete list of members for ms_unigeneoptions, including all inherited members.
copyFrom(const ms_unigeneoptions *right) | ms_unigeneoptions |
defaultValues() | ms_unigeneoptions | [virtual]
getPreceedingComments() const | ms_customproperty |
isSectionAvailable() const | ms_unigeneoptions |
ms_customproperty() | ms_customproperty |
ms_unigeneoptions() | ms_unigeneoptions |
ms_unigeneoptions(const ms_unigeneoptions &src) | ms_unigeneoptions |
operator=(const ms_unigeneoptions &right) | ms_unigeneoptions |
setPreceedingComments(const std::string &comments) | ms_customproperty |
setSectionAvailable(const bool value) | ms_unigeneoptions |
~ms_customproperty() | ms_customproperty |
~ms_unigeneoptions() | ms_unigeneoptions | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_user Member List

This is the complete list of members for ms_user, including all inherited members.
clearParam(const std::string name) | ms_user
getEmailAddress() const | ms_user
getEncryptedPassword() const | ms_user
getFullName() const | ms_user
getID() const | ms_user
getName() const | ms_user
getPasswordExpiry() const | ms_user
getStringParam(const std::string name, std::string &param) const | ms_user
getStringParam(const std::string name) const | ms_user
getUserType() const | ms_user
hasPasswordExpired() const | ms_user
isAccountEnabled() const | ms_user
ms_user(const int userID, const std::string userName, const std::string password, const long passwordExpiry, const std::string fullName, const std::string emailAddress, const usertype userType, const bool enabled) | ms_user
ms_user() | ms_user
saveStringParam(const std::string name, const std::string param) | ms_user
setAccountEnabled(bool newVal) | ms_user
setEmailAddress(std::string newVal) | ms_user
setEncryptedPassword(std::string newVal) | ms_user
setFullName(std::string newVal) | ms_user
setID(int newVal) | ms_user
setName(std::string newVal) | ms_user
setPassword(std::string barePassword) | ms_user
setPasswordExpiry(time_t newVal) | ms_user
setUserType(usertype newVal) | ms_user
systemids enum name | ms_user
USER_AGENT_STRING enum value | ms_user
USER_COMPUTER_NAME enum value | ms_user
USER_INTEGRA enum value | ms_user
USER_IP_ADDRESS enum value | ms_user
USER_NORMAL enum value | ms_user
USER_SECURITY_DISABLED enum value | ms_user
USER_WEBAUTH enum value | ms_user
USERID_ADMINISTRATOR enum value | ms_user
USERID_CMDLINE enum value | ms_user
USERID_DAEMON enum value | ms_user
USERID_GUEST enum value | ms_user
USERID_INTEGRA_SYSTEM enum value | ms_user
USERID_LAST enum value | ms_user
USERID_PUBLIC_SEARCHES enum value | ms_user
USERID_SECURITY_DISABLED enum value | ms_user
usertype enum name | ms_user
validatePassword(const std::string pwd, int &errorFlag) const | ms_user
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_wwwentry Member List

This is the complete list of members for ms_wwwentry, including all inherited members.
copyFrom(const ms_wwwentry *right) | ms_wwwentry
defaultValues() | ms_wwwentry
getHostName() const | ms_wwwentry
getName() const | ms_wwwentry
getParseRule() const | ms_wwwentry
getPath() const | ms_wwwentry
getPortNumber() const | ms_wwwentry
getType() const | ms_wwwentry
ms_wwwentry() | ms_wwwentry
ms_wwwentry(const ms_wwwentry &src) | ms_wwwentry
operator=(const ms_wwwentry &right) | ms_wwwentry
setHostName(const char *value) | ms_wwwentry
setName(const char *value) | ms_wwwentry
setParseRule(const int value) | ms_wwwentry
setPath(const char *value) | ms_wwwentry
setPortNumber(const int value) | ms_wwwentry
setType(const WWW_TYPE value) | ms_wwwentry
~ms_wwwentry() | ms_wwwentry
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_wwwoptions Member List

This is the complete list of members for ms_wwwoptions, including all inherited members.
appendEntry(const ms_wwwentry *item) | ms_wwwoptions
clearEntries() | ms_wwwoptions
copyFrom(const ms_wwwoptions *right) | ms_wwwoptions
defaultValues() | ms_wwwoptions
dropEntry(const int index) | ms_wwwoptions
getEntry(const int index) const | ms_wwwoptions
getNumberOfEntries() const | ms_wwwoptions
getPreceedingComments() const | ms_customproperty
getRepEntryByName(const char *dbName) const | ms_wwwoptions
getSeqEntryByName(const char *dbName) const | ms_wwwoptions
isSectionAvailable() const | ms_wwwoptions
ms_customproperty() | ms_customproperty
ms_wwwoptions() | ms_wwwoptions
ms_wwwoptions(const ms_wwwoptions &src) | ms_wwwoptions
operator=(const ms_wwwoptions &right) | ms_wwwoptions
setEntry(const int index, const ms_wwwentry *item) | ms_wwwoptions
setPreceedingComments(const std::string &comments) | ms_customproperty
setSectionAvailable(const bool value) | ms_wwwoptions
~ms_customproperty() | ms_customproperty
~ms_wwwoptions() | ms_wwwoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_xic Member List

This is the complete list of members for ms_xic, including all inherited members.
copyFrom(const ms_xic *src) | ms_xic |
defaultValues() | ms_xic |
getCodeFromXml(std::string text) | ms_xic | [static]
getElutionTimeShift() const | ms_xic |
getEndIndex() const | ms_xic |
getEndScanId() const | ms_xic |
getNumPoints() const | ms_xic |
getPeakEndIndex() const | ms_xic |
getPeakEndScanId() const | ms_xic |
getPeakStartIndex() const | ms_xic |
getPeakStartScanId() const | ms_xic |
getPeakState() const | ms_xic |
getPoint(int index, double &rt, int &scanId, double &intensity) const | ms_xic |
getRegionEndIndex() const | ms_xic |
getRegionEndScanId() const | ms_xic |
getRegionStartIndex() const | ms_xic |
getRegionStartScanId() const | ms_xic |
getRtPeakEnd() const | ms_xic |
getRtPeakStart() const | ms_xic |
getRtRegionEnd() const | ms_xic |
getRtRegionStart() const | ms_xic |
getStartIndex() const | ms_xic |
getStartScanId() const | ms_xic |
getUseTimeShift() const | ms_xic |
getXmlCode(peakState code) | ms_xic | [static]
hasIndexes() const | ms_xic |
ms_xic() | ms_xic |
ms_xic(const ms_xic_body &body) | ms_xic | [explicit]
ms_xic(ms_xic_body *body) | ms_xic | [explicit]
PEAK_STATE_DISCARD enum value | ms_xic |
PEAK_STATE_OK enum value | ms_xic |
PEAK_STATE_UNKNOWN enum value | ms_xic |
peakState enum name | ms_xic |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_xic_point Member List

This is the complete list of members for ms_xic_point, including all inherited members.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_xml_parameter Member List

This is the complete list of members for ms_xml_parameter, including all inherited members.
copyFrom(const ms_xml_parameter *right) | ms_xml_parameter |
defaultValues() | ms_xml_parameter |
dropDescription() | ms_xml_parameter |
dropName() | ms_xml_parameter |
getDescription() const | ms_xml_parameter |
getDescriptionSchemaType() const =0 | ms_xml_parameter | [pure virtual]
getName() const | ms_xml_parameter |
getNameSchemaType() const =0 | ms_xml_parameter | [pure virtual]
getSchemaType() const =0 | ms_xml_parameter | [pure virtual]
getValue() const | ms_xml_parameter |
getValueSchemaType() const =0 | ms_xml_parameter | [pure virtual]
haveDescription() const | ms_xml_parameter |
haveName() const | ms_xml_parameter |
ms_xml_parameter() | ms_xml_parameter |
ms_xml_parameter(const ms_xml_parameter &src) | ms_xml_parameter |
operator=(const ms_xml_parameter &right) | ms_xml_parameter |
setDescription(const char *value) | ms_xml_parameter |
setName(const char *value) | ms_xml_parameter |
setValue(const char *value) | ms_xml_parameter |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameter |
~ms_xml_parameter() | ms_xml_parameter | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_xml_parameters Member List

This is the complete list of members for ms_xml_parameters, including all inherited members.
clearParameters()=0 | ms_xml_parameters | [pure virtual]
defaultValues() | ms_xml_parameters |
deleteParameterByName(const char *name)=0 | ms_xml_parameters | [pure virtual]
deleteParameterByNumber(const int idx)=0 | ms_xml_parameters | [pure virtual]
getNumberOfParameters() const =0 | ms_xml_parameters | [pure virtual]
getParameterSchemaType() const =0 | ms_xml_parameters | [pure virtual]
getSchemaType() const =0 | ms_xml_parameters | [pure virtual]
ms_xml_parameters() | ms_xml_parameters |
ms_xml_parameters(const ms_xml_parameters &src) | ms_xml_parameters |
validateDeep(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
validateShallow(const ms_xml_schema *pSchemaFileObj) const | ms_xml_parameters |
~ms_xml_parameters() | ms_xml_parameters | [virtual]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


ms_zip Member List

This is the complete list of members for ms_zip, including all inherited members.
appendErrors(const ms_errors &src) | ms_errors |
clearAllErrors() | ms_errors |
compressMore(const std::string &dataIn) | ms_zip |
compressMore(const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen) | ms_zip |
copyFrom(const ms_zip *right) | ms_zip |
matrix_science::ms_errors::copyFrom(const ms_errors *right) | ms_errors |
getErrorHandler() const | ms_errors |
getLastError() const | ms_errors |
getLastErrorString() const | ms_errors |
getUnZipped(unsigned char *buffer, const unsigned long len) const | ms_zip |
getUnZipped() const | ms_zip |
getUnZippedLen() const | ms_zip |
getZipped(unsigned char *buffer, const unsigned long len) const | ms_zip |
getZipped() const | ms_zip |
getZippedLen() const | ms_zip |
isValid() const | ms_errors |
ms_errors() | ms_errors |
ms_zip(const bool isZipped, const unsigned char *buffer, const unsigned long len) | ms_zip |
ms_zip(const bool isZipped, const std::string &buffer) | ms_zip |
ms_zip(const bool isZipped) | ms_zip | [explicit]
ms_zip(const ms_zip &src) | ms_zip |
operator=(const ms_zip &right) | ms_zip |
~ms_errors() | ms_errors |
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


common_error.cpp

Generic error handling example.

/*
##############################################################################
# file: common_error.cpp                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/common_error.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* Local functions                                                           */
/* Any configuration file class can be cast to ms_errorsorigin               */
/*****************************************************************************/
static void checkErrorHandler(ms_errors *obj);

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - the name of the .dat file      */
/*****************************************************************************/
int main(int argc, char * argv[])
{
    ms_datfile file;

    if (argc == 2)
    {
        file.setFileName(argv[1]);

    }
    else
    {
        file.setFileName("wrong_name.txt");
    }
    file.read_file();

    if (!file.isValid())
    {
        checkErrorHandler(&file);
    }
    else
    {
        std::cout   << "The file has been read and parsed successfully. Congratulations!"
                    << std::endl;
    }

    return 0;
}

/*****************************************************************************/
/* checkErrorHandler                                                         */
/* Outputs detailed information about all collected errors                   */
/*****************************************************************************/
static void checkErrorHandler(ms_errors *obj)
{
    std::cout << "Last error description                   "      << std::endl;
    std::cout << "========================================="      << std::endl;
    std::cout << "Error: " << obj->getLastErrorString()           << std::endl;
    std::cout << "========================================="      << std::endl;
    std::cout << "Testing the error handling...            "      << std::endl;
    std::cout << "========================================="      << std::endl;

    const ms_errs *err = obj->getErrorHandler();

    for (int i=1; i <= err->getNumberOfErrors(); i++)
    {
        std::cout << "Error number: "
                  << err->getErrorNumber(i)
                  << " ("
                  // one time happened and repeated after that zero or more times
                  << (err->getErrorRepeats(i)+1)
                  << " times) : "
                  << err->getErrorString(i)
                  << std::endl;
    }

    std::cout << std::endl;
    obj->clearAllErrors();
}

/*

will give the output:

# common_error.cpp

Last error description
=========================================
Error: Cannot find file 'mascot.dat'. It contains the most important configuration parameters
=========================================
Testing the error handling...
=========================================
Error number: 1537 (1 times) : [F] Cannot find file 'mascot.dat'. It contains the most important configuration parameters

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


common_error.cs

Generic error handling example.

/*
##############################################################################
# file: common_error.cs                                                      #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/common_error.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    class common_error
    {
        static void Main(string[] argv)
        {
            ms_datfile file = new ms_datfile();
            file.setFileName((argv.Length > 0 && argv[0].Length > 0) ? argv[0] : "wrong_name.txt");
            file.read_file();

            if (file.isValid())
            {
                Console.WriteLine("The file has been read and parsed successfully.  Congratulations!");
            }
            else
            {
                checkErrorHandler(file);
            }
        }

        private static void checkErrorHandler(ms_datfile file)
        {
            Console.WriteLine("Last error description                   ");
            Console.WriteLine("=========================================");
            Console.WriteLine("Error: {0}", file.getLastErrorString());
            Console.WriteLine("=========================================");
            Console.WriteLine("Testing the error handling...            ");
            Console.WriteLine("=========================================");

            ms_errs err = file.getErrorHandler();
            for (int i = 1; i <= err.getNumberOfErrors(); i++)
            {
                Console.WriteLine("Error number: {0} ({1} times) : {2}", err.getErrorNumber(i), err.getErrorRepeats(i) + 1, err.getErrorString(i));
            }
            Console.WriteLine();
            file.clearAllErrors();
        }
    }
}

/*
common_error.exe
Will give the following output:

Last error description
=========================================
Error: Cannot find Mascot configuration file 'wrong_name.txt'.
=========================================
Testing the error handling...
=========================================
Error number: 1537 (1 times) : Cannot find Mascot configuration file 'wrong_name.txt'.
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


common_error.pl

Generic error handling example.

#!/usr/local/bin/perl
##############################################################################
# file: common_error.pl                                                      #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/common_error.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

my $file = new msparser::ms_datfile;

$file->setFileName(defined($ARGV[0]) ? $ARGV[0] : 'wrong_name.txt');
$file->read_file();

if ($file->isValid) {
    print "The file has been read and parsed successfully. Congratulations!\n";
} else {
    checkErrorHandler($file);
}

sub checkErrorHandler {
    my ($obj) = @_;

    print "Last error description                   \n";
    print "=========================================\n";
    print "Error: ", $obj->getLastErrorString(), "\n";
    print "=========================================\n";
    print "Testing the error handling...            \n";
    print "=========================================\n";

    my $err = $obj->getErrorHandler();
    my $i;

    for my $i (1 .. $err->getNumberOfErrors) {
        print "Error number: ";
        print $err->getErrorNumber($i);
        print " (";
        print $err->getErrorRepeats($i) + 1;
        print " times) : ";
        print $err->getErrorString($i), "\n";
    }

    print "\n";

    $obj->clearAllErrors();
}

=pod

Running the program with no arguments, for example with

perl -I../bin common_error.pl

will give the output:

Last error description
=========================================
Error: Cannot find Mascot configuration file 'wrong_name.txt'.
=========================================
Testing the error handling...
=========================================
Error number: 1537 (1 times) : Cannot find Mascot configuration file 'wrong_name.txt'.

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


common_error.py

Generic error handling example.

#!/usr/bin/python
##############################################################################
# file: common_error.py                                                      #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/common_error.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

def main() :
    file = msparser.ms_datfile()

    if len(sys.argv) > 1 :
        file.setFileName(sys.argv[1])
    else :
        file.setFileName("wrong_name.txt")

    file.read_file()

    if file.isValid() :
        print("The file has been read and parsed successfully. Congratulations!")
    else :
        checkErrorHandler(file)

def checkErrorHandler(obj) :
    print("Last error description                   ")
    print("=========================================")
    print("Error: %s" % obj.getLastErrorString())
    print("=========================================")
    print("Testing the error handling...            ")
    print("=========================================")

    err = obj.getErrorHandler()
    for i in range(1 + err.getNumberOfErrors()) :
        print("Error number: %d (%d times): %s" % (
                err.getErrorNumber(i),
                err.getErrorRepeats(i) + 1,
                err.getErrorString(i)
                ))

    obj.clearAllErrors()

if __name__ == "__main__":
    sys.exit(main())

""" Running the program with no arguments, for example with

python common_error.py

will give the output:

Last error description
=========================================
Error: Cannot find Mascot configuration file 'wrong_name.txt'.
=========================================
Testing the error handling...
=========================================
Error number: 0 (1 times):
Error number: 1537 (1 times): Cannot find Mascot configuration file 'wrong_name.txt'.

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_enzymes.cpp

Read in the enzymes file.

/*
##############################################################################
# file: config_enzymes.cpp                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_enzymes.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "The location of enzymes file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the enzymes file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the second parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 2)
    {
        cs.setSessionID(argv[2]);
    }
    ms_enzymefile file(argv[1], &cs);

    if (!file.isValid())
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    // how many do we have in total?
    int n = file.getNumberOfEnzymes();
    std::cout << "There are " << n << " enzymes definitions available" << std::endl;

    // now get them all!
    int i;
    for(i=0; i < n ; i++)
    {
        const ms_enzyme * enzyme = file.getEnzymeByNumber(i);
        std::cout << enzyme->getTitle() <<  ": ";
        for (int c=0; c < enzyme->getNumberOfCutters(); c++) {
            if (enzyme->getCutterType(c) == matrix_science::ms_enzyme::NTERM_CUTTER) {
                std::cout << "nTerm - ";
            } else {
                std::cout << "cTerm - ";
            }
            std::cout << enzyme->getCleave(c) <<  "!" << enzyme->getRestrict(c);
            std::cout << "; ";
        }
        std::cout << std::endl;
    }

    // Now try updating the first one in the list to semi-specific
    ms_enzyme enzyme = *file.getEnzymeByNumber(0);
    enzyme.setSemiSpecific(true);
    file.updateEnzymeByNumber(0, enzyme);

    // And delete V8-DE
    if (file.deleteEnzymeByName("V8-DE")) {
        std::cout << "Deleted the enzyme V8-DE " << std::endl;
    }

    //Finally, save the file under a new name - but only if not http:
    if (strncmp("http:", argv[1], 5) != 0) {
        std::string filename = argv[1];
        filename +=  ".new";
        file.setFileName(filename.c_str());
        file.save_file();
    }

    std::cout << "There are now " << file.getNumberOfEnzymes() << " enzymes definitions available" << std::endl;
    return 0;
}

/*
will give the output:

# test.exe ../config/enzymes

There are 19 enzymes definitions available
Trypsin: cTerm - KR!P;
Arg-C: cTerm - R!P;
Asp-N: nTerm - BD!;
Asp-N_ambic: nTerm - DE!;
Chymotrypsin: cTerm - FLWY!P;
CNBr: cTerm - M!;
CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
Formic_acid: cTerm - D!;
Lys-C: cTerm - K!P;
Lys-C/P: cTerm - K!;
PepsinA: cTerm - FL!;
Tryp-CNBr: cTerm - KMR!P;
TrypChymo: cTerm - FKLRWY!P;
Trypsin/P: cTerm - KR!;
V8-DE: cTerm - BDEZ!P;
V8-E: cTerm - EZ!P;
semiTrypsin: cTerm - KR!P;
LysC+AspN: nTerm - BD!; cTerm - K!P;
None: cTerm - KR!P;
There are now 18 enzymes definitions available

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_enzymes.cs

Read in the enzymes file.

/*
##############################################################################
# file: config_enzymes.cs                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_enzymes.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.IO;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_enzymes
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                using (TextWriter errorWriter = Console.Error)
                {
                    errorWriter.WriteLine(@"The location of the enzymes file has to be specified as a parameter
The location should either be the full path to the enzymes file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
                    return;
                }
            }

            // A sessionID can optionally be passed as the second parameter
            // This will only be required if the 'file' is a URL
            ms_enzymefile file;
            if (argv.Length > 1)
            {
                ms_connection_settings cs = new ms_connection_settings();
                cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
                cs.setSessionID(argv[1]);
                file = new ms_enzymefile(argv[0], cs);
            }
            else file = new ms_enzymefile(argv[0]);

            if (!file.isValid())
            {
                using (TextWriter errorWriter = Console.Error)
                {
                    errorWriter.WriteLine("Error number: {0}", file.getLastError());
                    errorWriter.WriteLine("Error string: {0}", file.getLastErrorString());
                }
                return;
            }

            // how many enzymes do we have in total?
            int n = file.getNumberOfEnzymes();
            Console.WriteLine("There are {0} enzymes definitions available", n);

            // now get them all!
            for (int i = 0; i < n; i++)
            {
                ms_enzyme _enzyme = file.getEnzymeByNumber(i);
                Console.Write("{0}: ", _enzyme.getTitle());
                for (int c = 0; c < _enzyme.getNumberOfCutters(); c++)
                {
                    if (_enzyme.getCutterType(c) == ms_enzyme.cuttertype.NTERM_CUTTER)
                    {
                        Console.Write("nTerm - ");
                    }
                    else
                    {
                        Console.Write("cTerm - ");
                    }
                    Console.Write("{0}!{1}; ", _enzyme.getCleave(c), _enzyme.getRestrict(c));
                }
                Console.WriteLine();
                _enzyme = null;
            }

            // Now try updating the first one in the list to semi-specific
            ms_enzyme enzyme = file.getEnzymeByNumber(0);
            enzyme.setSemiSpecific(true);
            file.updateEnzymeByNumber(0, enzyme);

            // And delete V8-DE
            file.deleteEnzymeByName("V8-DE");

            // Finally, save the file under a new name
            if (argv[0].ToLower().StartsWith("http"))
            {
                file.setFileName("copy_enzymes.new");
            }
            else
            {
                //create a new file locally
                file.setFileName(argv[0] + ".new");
            }
            file.save_file();
            Console.WriteLine("Updated enzymes file saved to {0}", Path.GetFullPath(file.getFileName()));
            Console.WriteLine("There are now {0} enzymes definitions available", file.getNumberOfEnzymes());
        }
    }
}

/*
 * Running the program as
 *
 * config_enzymes.exe c:\inetpub\mascot\config\enzymes
 *
 * will give the following output under Mascot Server 2.5
 *
 * There are 22 enzymes definitions available
 * Trypsin: cTerm - KR!P;
 * Trypsin/P: cTerm - KR!;
 * Arg-C: cTerm - R!P;
 * Asp-N: nTerm - BD!;
 * Asp-N_ambic: nTerm - DE!;
 * Chymotrypsin: cTerm - FLWY!P;
 * CNBr: cTerm - M!;
 * CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
 * Formic_acid: nTerm - D!; cTerm - D!;
 * Lys-C: cTerm - K!P;
 * Lys-C/P: cTerm - K!;
 * LysC+AspN: nTerm - BD!; cTerm - K!P;
 * Lys-N: nTerm - K!;
 * PepsinA: cTerm - FL!;
 * semiTrypsin: cTerm - KR!P;
 * TrypChymo: cTerm - FKLRWY!P;
 * TrypsinMSIPI: nTerm - J!; cTerm - KR!P; cTerm - J!;
 * TrypsinMSIPI/P: nTerm - J!; cTerm - JKR!;
 * V8-DE: cTerm - BDEZ!P;
 * V8-E: cTerm - EZ!P;
 * NoCleave: cTerm - J!ABCDEFGHIJKLMNOPQRSTUVWXYZ;
 * None: cTerm - KR!P;
 * Updated enzymes file saved to c:\inetpub\mascot\config\enzymes.new
 * There are now 21 enzymes definitions available
 *
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_enzymes.java

Read in the enzymes file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_enzymes {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("The location of enzymes file has to be specified as a parameter");
            System.out.println("The location should either be the full path to the enzymes file");
            System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
            System.exit(0);
        }

        // A sessionID can optionally be passed as the second parameter
        // This will only be required if the 'file' is a URL
        ms_enzymefile file;
        if (argv.length > 1)
        {
            ms_connection_settings cs = new ms_connection_settings();
            cs.setSessionID(argv[1]);
            file = new ms_enzymefile(argv[0], cs);
        }
        else
        {
            file = new ms_enzymefile(argv[0]);
        }

        if (!file.isValid())
        {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }

        // how many do we have in total?
        int n = file.getNumberOfEnzymes();
        System.out.println("There are " + n + " enzymes definitions available");

        //now get them all!
        for (int i=0; i < n ; i++)
        {
            ms_enzyme enzyme = file.getEnzymeByNumber(i);
            System.out.print(enzyme.getTitle() + ": ");
            for (int c=0; c < enzyme.getNumberOfCutters(); c++)
            {
                if (enzyme.getCutterType(c) == ms_enzyme.NTERM_CUTTER)
                {
                    System.out.print("nTerm - ");
                }
                else
                {
                      System.out.print("cTerm - ");
                }
                System.out.print(enzyme.getCleave(c) + "!");
                System.out.print(enzyme.getRestrict(c));
                System.out.print("; ");
            }
            System.out.println("");
        }

        // Now try updating the first one in the list to semi-specific
        ms_enzyme enzyme = file.getEnzymeByNumber(0);
        enzyme.setSemiSpecific(true);
        file.updateEnzymeByNumber(0, enzyme);

        // And delete V8-DE
        file.deleteEnzymeByName("V8-DE");

        // Finally, save the file under a new name
        file.setFileName(argv[0] + ".new");
        file.save_file();

        System.out.println("There are now " + file.getNumberOfEnzymes() + " enzymes definitions available");
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_enzymes enzymes
There are 19 enzymes definitions available
Trypsin: cTerm - KR!P;
Arg-C: cTerm - R!P;
Asp-N: nTerm - BD!;
Asp-N_ambic: nTerm - DE!;
Chymotrypsin: cTerm - FLWY!P;
CNBr: cTerm - M!;
CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
Formic_acid: cTerm - D!;
Lys-C: cTerm - K!P;
Lys-C/P: cTerm - K!;
PepsinA: cTerm - FL!;
Tryp-CNBr: cTerm - KMR!P;
TrypChymo: cTerm - FKLRWY!P;
Trypsin/P: cTerm - KR!;
V8-DE: cTerm - BDEZ!P;
V8-E: cTerm - EZ!P;
semiTrypsin: cTerm - KR!P;
LysC+AspN: nTerm - BD!; cTerm - K!P;
None: cTerm - KR!P;
There are now 18 enzymes definitions available

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_enzymes.pl

Read in the enzymes file.

#!/usr/local/bin/perl
##############################################################################
# file: config_enzymes.pl                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_enzymes.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
The location of 'enzymes' file has to be specified as a parameter.
The location should either be the full path to the 'enzymes' file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[1]);
    $file = new msparser::ms_enzymefile($ARGV[0], $cs);
} else {
    $file = new msparser::ms_enzymefile($ARGV[0]);
}

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

my $n = $file->getNumberOfEnzymes();
print "There are ", $n, " enzyme definitions available\n";

for my $i (0 .. $n-1) {
    my $enzyme = $file->getEnzymeByNumber($i);
    print $enzyme->getTitle(), ": ";

    for my $c (0 .. $enzyme->getNumberOfCutters - 1) {
        if ($enzyme->getCutterType($c) == $msparser::ms_enzyme::NTERM_CUTTER) {
            print "nTerm - ";
        } else {
            print "cTerm - ";
        }

        print $enzyme->getCleave($c), "!", $enzyme->getRestrict($c);
        print "; ";
    }
    print "\n";
}

# Now try updating the first one in the list to semi-specific.
my $enzyme = $file->getEnzymeByNumber(0);
$enzyme->setSemiSpecific(1);
$file->updateEnzymeByNumber(0, $enzyme);

# And delete V8-DE.
$file->deleteEnzymeByName("V8-DE");

# Finally, save the file under a new name.
$file->setFileName($ARGV[0] . ".new");
$file->save_file;

if (!$file->isValid) {
    print "Failed to save: ", $file->getLastErrorString, "\n";
} else {
    print $ARGV[0], ".new now has ", $file->getNumberOfEnzymes, " enzyme definitions available\n";
}

=pod

Running the program as

perl -I../bin config_enzymes.pl ../config/enzymes

will give the following output under Mascot Server 2.3:

There are 21 enzyme definitions available
Trypsin: cTerm - KR!P;
Trypsin/P: cTerm - KR!;
Arg-C: cTerm - R!P;
Asp-N: nTerm - BD!;
Asp-N_ambic: nTerm - DE!;
Chymotrypsin: cTerm - FLWY!P;
CNBr: cTerm - M!;
CNBr+Trypsin: cTerm - M!; cTerm - KR!P;
Formic_acid: nTerm - D!; cTerm - D!;
Lys-C: cTerm - K!P;
Lys-C/P: cTerm - K!;
LysC+AspN: nTerm - BD!; cTerm - K!P;
Lys-N: nTerm - K!;
PepsinA: cTerm - FL!;
semiTrypsin: cTerm - KR!P;
TrypChymo: cTerm - FKLRWY!P;
TrypsinMSIPI: nTerm - J!; cTerm - KR!P; cTerm - J!;
TrypsinMSIPI/P: nTerm - J!; cTerm - JKR!;
V8-DE: cTerm - BDEZ!P;
V8-E: cTerm - EZ!P;
None: cTerm - KR!P;
../config/enzymes.new now has 20 enzyme definitions available

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_enzymes.py

Read in the enzymes file.

#!/usr/bin/python
##############################################################################
# file: config_enzymes.py                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_enzymes.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
The location of enzymes file has to be specified as a parameter.
The location should either be the full path to the enzymes file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")
    sys.exit(1)

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 2 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[2])
    file = msparser.ms_enzymefile(sys.argv[1], cs)
else :
    file = msparser.ms_enzymefile(sys.argv[1])

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

n = file.getNumberOfEnzymes()
print("There are " + str(n) + " enzyme definitions available")

for i in range(n) :
    enzyme = file.getEnzymeByNumber(i)
    defs = []

    for c in range(enzyme.getNumberOfCutters()) :
        if enzyme.getCutterType(c) == msparser.ms_enzyme.NTERM_CUTTER :
            term = "nTerm"
        else :
            term = "cTerm"

        defs.append("%s - %s!%s" % (term, enzyme.getCleave(c), enzyme.getRestrict(c)))

    print("%s: %s" % (enzyme.getTitle(), "; ".join(defs)))

# Now try updating the first one in the list to semi-specific.
enzyme = file.getEnzymeByNumber(0)
enzyme.setSemiSpecific(1)
file.updateEnzymeByNumber(0, enzyme)

# And delete V8-DE.
file.deleteEnzymeByName("V8-DE")

# Finally, save the file under a new name.
file.setFileName(sys.argv[1] + ".new")
file.save_file()

if not file.isValid() :
    print("Failed to save: %s" % file.getLastErrorString())
else :
    print("%s.new now has %d enzyme definitions available" % (sys.argv[1], file.getNumberOfEnzymes()))

""" Running the program as

python config_enzymes.pl /usr/local/mascot/config/enzymes

will give the following output under Mascot Server 2.3

There are 21 enzyme definitions available
Trypsin: cTerm - KR!P
Trypsin/P: cTerm - KR!
Arg-C: cTerm - R!P
Asp-N: nTerm - BD!
Asp-N_ambic: nTerm - DE!
Chymotrypsin: cTerm - FLWY!P
CNBr: cTerm - M!
CNBr+Trypsin: cTerm - M!; cTerm - KR!P
Formic_acid: nTerm - D!; cTerm - D!
Lys-C: cTerm - K!P
Lys-C/P: cTerm - K!
LysC+AspN: nTerm - BD!; cTerm - K!P
Lys-N: nTerm - K!
PepsinA: cTerm - FL!
semiTrypsin: cTerm - KR!P
TrypChymo: cTerm - FKLRWY!P
TrypsinMSIPI: nTerm - J!; cTerm - KR!P; cTerm - J!
TrypsinMSIPI/P: nTerm - J!; cTerm - JKR!
V8-DE: cTerm - BDEZ!P
V8-E: cTerm - EZ!P
None: cTerm - KR!P
/usr/local/mascot/config/enzymes.new now has 20 enzyme definitions available

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_fragrules.cpp

Read in the fragmentation_rules file.

/*
##############################################################################
# file: config_fragrules.cpp                                                 #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_fragrules.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "The location of fragmentation_rules file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the fragmentation_rules file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the second parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 2)
    {
        cs.setSessionID(argv[2]);
    }

    ms_fragrulesfile file(argv[1], &cs);

    if ( !file.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    int n = file.getNumberOfInstruments();
    std::cout << n << " instruments are configured:" << std::endl;

    int i;
    for(i=0; i < n; i++)
    {
        std::cout << file.getInstrumentName(i) << std::endl;
    }

    // Now change ESI-QUAD-TOF
    ms_fragmentationrules instrument = *file.getInstrumentByName("ESI-QUAD-TOF");
    instrument.setSeriesUsed(23, true);  // Add v series
    file.updateInstrumentByName("ESI-QUAD-TOF", instrument);

    // And delete MALDI-QIT-TOF
    file.deleteInstrumentByName("MALDI-QIT-TOF");

    //Finally, save the file under a new name - but only if not http:
    if (strncmp("http:", argv[1], 5) != 0) {
        std::string filename = argv[1];
        filename +=  ".new";
        file.setFileName(filename.c_str());
        file.save_file();
    }
    std::cout << "There are now " << file.getNumberOfInstruments() << " instruments configured." << std::endl;
    return 0;
}

/*
will give the output:

# config_fragrules.exe ../config/fragmentation_rules

11 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
MALDI-QUAD-TOF
LCQ
There are now 10 instruments configured.
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_fragrules.cs

Read in the fragmentation_rules file.

/*
##############################################################################
# file: config_fragrules.cs                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_fragrules.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.IO;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_fragrules
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.Error.WriteLine(@"The location of the 'fragmentation_rules' file has to be specified as a parameter
The location should either be the full path to the fragmentation_rules file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
                    return;
            }

            // A sessionID can optionally be passed as the second parameter
            // This will only be required if the 'file' is a URL
            ms_fragrulesfile file;
            if (argv.Length > 1)
            {
                ms_connection_settings cs = new ms_connection_settings();
                cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
                cs.setSessionID(argv[1]);
                file = new ms_fragrulesfile(argv[0], cs);
            }
            else file = new ms_fragrulesfile(argv[0]);

            if (!file.isValid())
            {
                Console.Error.WriteLine("Error number: {0}", file.getLastError());
                Console.Error.WriteLine("Error string: {0}", file.getLastErrorString());
                return;
            }

            int n = file.getNumberOfInstruments();
            Console.WriteLine("{0} instruments are configured:", n);

            for (int i = 0; i < n; i++)
            {
                Console.WriteLine(file.getInstrumentName(i));
            }

            // Now change ESI-QUAD-TOF
            ms_fragmentationrules instrument = file.getInstrumentByName("ESI-QUAD-TOF");
            instrument.setSeriesUsed(23, true);     // Add v series
            file.updateInstrumentByName("ESI-QUAD-TOF", instrument);

            // And delete MALDI-QIT-TOF
            file.deleteInstrumentByName("MALDI-QIT-TOF");

            // Finally, save the file under a new name
            if (argv[0].ToLower().StartsWith("http"))
            {
                file.setFileName("copy_enzymes.new");
            }
            else
            {
                //create a new file locally
                file.setFileName(argv[0] + ".new");
            }
            file.save_file();

            Console.WriteLine("There are now {0} instruments configured.  The updated configuration file was saved to {1}",
                file.getNumberOfInstruments(),
                Path.GetFullPath(file.getFileName()));
        }
    }
}

/*
Running the program as

config_fragrules.exe c:\inetpub\mascot\config\fragmentation_rules

Will give the output

14 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
ETD-TRAP
MALDI-QUAD-TOF
MALDI-QIT-TOF
MALDI-ISD
CID+ETD
There are now 13 instruments configured.  The updated configuration file was saved to c:\inetpub\mascot\config\fragmentation_rules.new
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_fragrules.java

Read in the fragmentation_rules file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_fragrules {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("The location of 'fragmentation_rules' file has to be specified as a parameter");
            System.out.println("The location should either be the full path to the fragmentation_rules file");
            System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
            System.exit(0);
        }

        // A sessionID can optionally be passed as the second parameter
        // This will only be required if the 'file' is a URL
        ms_fragrulesfile file;
        if (argv.length > 1)
        {
            ms_connection_settings cs = new ms_connection_settings();
            cs.setSessionID(argv[1]);
            file = new ms_fragrulesfile(argv[0], cs);
        }
        else
        {
            file = new ms_fragrulesfile(argv[0]);
        }

        if (!file.isValid())
        {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }

        int n = file.getNumberOfInstruments();
        System.out.println(n + " instruments are configured:");

        for(int i=0; i < n; i++)
        {
            System.out.println(file.getInstrumentName(i));
        }

        // Now change ESI-QUAD-TOF
        ms_fragmentationrules instrument = file.getInstrumentByName("ESI-QUAD-TOF");
        instrument.setSeriesUsed(23, true);  // Add v series
        file.updateInstrumentByName("ESI-QUAD-TOF", instrument);

        // And delete MALDI-QIT-TOF
        file.deleteInstrumentByName("MALDI-QIT-TOF");

        // Finally, save the file under a new name
        file.setFileName(argv[0] + ".new");
        file.save_file();

        System.out.println("There are now " + file.getNumberOfInstruments() + " instruments configured.");
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_fragrules fragmentation_rules

12 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
MALDI-QUAD-TOF
MALDI-QIT-TOF
ALL
There are now 11 instruments configured.

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_fragrules.pl

Read in the fragmentation_rules file.

#!/usr/local/bin/perl
##############################################################################
# file: config_fragrules.pl                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_fragrules.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
The location of 'fragmentation_rules' file has to be specified as a parameter.
The location should either be the full path to the 'fragmentation_rules' file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[1]);
    $file = new msparser::ms_fragrulesfile($ARGV[0], $cs);
} else {
    $file = new msparser::ms_fragrulesfile($ARGV[0]);
}

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

my $n = $file->getNumberOfInstruments;
print $n, " instruments are configured:\n";

for my $i (0 .. $n-1) {
    print $file->getInstrumentName($i), "\n";
}

# Now change ESI-QUAD-TOF.
my $instrument = $file->getInstrumentByName("ESI-QUAD-TOF");
$instrument->setSeriesUsed(23, 1);  # Add v series
$file->updateInstrumentByName("ESI-QUAD-TOF", $instrument);

# And delete MALDI-QIT-TOF
$file->deleteInstrumentByName("MALDI-QIT-TOF");

# Finally, save the file under a new name
$file->setFileName($ARGV[0] . ".new");
$file->save_file;

if (!$file->isValid) {
    print "Failed to save: ", $file->getLastErrorString, "\n";
} else {
    print $ARGV[0], ".new now has ", $file->getNumberOfInstruments(), " instruments configured.\n";
}

my $firstSeries = msparser::ms_fragmentationrules::getFirstSeries();
my $lastSeries  = msparser::ms_fragmentationrules::getLastSeries();

print "First series: ", $firstSeries, "\n";
print "Last series : ", $lastSeries , "\n";

for my $i ($firstSeries .. $lastSeries) {
    print "--------- $i ---------\n";
    print msparser::ms_fragmentationrules::getSeriesName($i), "\n";
    print msparser::ms_fragmentationrules::getSeriesDescription ($i), "\n";
}

=pod

Running the program as

perl -I../bin config_fragfules.pl ../config/fragmentation_rules

will give the following output under Mascot Server 2.3:

14 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
ETD-TRAP
MALDI-QUAD-TOF
MALDI-QIT-TOF
MALDI-ISD
CID+ETD
../config/fragmentation_rules.new now has 13 instruments configured
First series: 4
Last series : 25
--------- 4 ---------
immonium
immonium
--------- 5 ---------
a
a series
--------- 6 ---------
a*
a - NH3 if a significant and fragment includes RKNQ
--------- 7 ---------
a0
a - H2O if a significant and fragment includes STED
--------- 8 ---------
b
b series
--------- 9 ---------
b*
b - NH3 if b significant and fragment includes RKNQ
--------- 10 ---------
b0
b - H2O if b significant and fragment includes STED
--------- 11 ---------
c
c series
--------- 12 ---------
x
x series
--------- 13 ---------
y
y series
--------- 14 ---------
y*
y - NH3 if y significant and fragment includes RKNQ
--------- 15 ---------
y0
y - H2O if y significant and fragment includes STED
--------- 16 ---------
z
z series
--------- 17 ---------
yb
internal yb < 700 Da
--------- 18 ---------
ya
internal ya < 700 Da
--------- 19 ---------
y must be significant
y or y++ must be significant
--------- 20 ---------
y must be highest score
y or y++ must be highest scoring series
--------- 21 ---------
z+1
z+1 series
--------- 22 ---------
d
d and d' series
--------- 23 ---------
v
v series
--------- 24 ---------
w
w and w' series
--------- 25 ---------
z+2
z+2 series

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_fragrules.py

Read in the fragmentation_rules file.

#!/usr/bin/python
##############################################################################
# file: config_fragrules.py                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_fragrules.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
The location of 'fragmentation_rules' file has to be specified as a parameter.
The location should either be the full path to the 'fragmentation_rules' file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")

    sys.exit(1)

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 2 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[2])
    file = msparser.ms_fragrulesfile(sys.argv[1], cs)
else :
    file = msparser.ms_fragrulesfile(sys.argv[1])

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

n = file.getNumberOfInstruments()
print("%d instruments are configured:" % n)

for i in range(n) :
    print(file.getInstrumentName(i))

# Now change ESI-QUAD-TOF.
instrument = file.getInstrumentByName("ESI-QUAD-TOF")
instrument.setSeriesUsed(23, 1)  # Add v series
file.updateInstrumentByName("ESY-QUAD-TOF", instrument)

# And delete MALDI-QIT-TOF.
file.deleteInstrumentByName("MALDI-QIT-TOF")

# Finally, save the file under a new name.
file.setFileName(sys.argv[1] + ".new");
file.save_file();

if not file.isValid() :
    print("Failed to save: %s" % file.getLastErrorString())
else :
    print("%s.new now has %d instruments configured" % (sys.argv[1], file.getNumberOfInstruments()))

firstSeries = msparser.ms_fragmentationrules.getFirstSeries()

firstSeries = msparser.ms_fragmentationrules.getFirstSeries()
lastSeries  = msparser.ms_fragmentationrules.getLastSeries()

print("First series: %s" % firstSeries)
print("Last series : %s" % lastSeries)

for i in range(firstSeries, 1 + lastSeries) :
    print("--------- %d ---------" % i)
    print(msparser.ms_fragmentationrules.getSeriesName(i))
    print(msparser.ms_fragmentationrules.getSeriesDescription(i))

""" Running the program as

python config_fragfules.py /usr/local/mascot/config/fragmentation_rules

will give the following output under Mascot Server 2.3:

14 instruments are configured:
Default
ESI-QUAD-TOF
MALDI-TOF-PSD
ESI-TRAP
ESI-QUAD
ESI-FTICR
MALDI-TOF-TOF
ESI-4SECTOR
FTMS-ECD
ETD-TRAP
MALDI-QUAD-TOF
MALDI-QIT-TOF
MALDI-ISD
CID+ETD
/usr/local/mascot/config/fragmentation_rules.new now has 13 instruments configured
First series: 4
Last series : 25
--------- 4 ---------
immonium
immonium
--------- 5 ---------
a
a series
--------- 6 ---------
a*
a - NH3 if a significant and fragment includes RKNQ
--------- 7 ---------
a0
a - H2O if a significant and fragment includes STED
--------- 8 ---------
b
b series
--------- 9 ---------
b*
b - NH3 if b significant and fragment includes RKNQ
--------- 10 ---------
b0
b - H2O if b significant and fragment includes STED
--------- 11 ---------
c
c series
--------- 12 ---------
x
x series
--------- 13 ---------
y
y series
--------- 14 ---------
y*
y - NH3 if y significant and fragment includes RKNQ
--------- 15 ---------
y0
y - H2O if y significant and fragment includes STED
--------- 16 ---------
z
z series
--------- 17 ---------
yb
internal yb < 700 Da
--------- 18 ---------
ya
internal ya < 700 Da
--------- 19 ---------
y must be significant
y or y++ must be significant
--------- 20 ---------
y must be highest score
y or y++ must be highest scoring series
--------- 21 ---------
z+1
z+1 series
--------- 22 ---------
d
d and d' series
--------- 23 ---------
v
v series
--------- 24 ---------
w
w and w' series
--------- 25 ---------
z+2
z+2 series

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_license.cpp

Read in the mascot.license file.

/*
##############################################################################
# file: config_license.cpp                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_license.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "Location of 'mascot.license'-file has to be specified as a parameter" << std::endl;
        return 0;
    }

    ms_license file(argv[1]);

    if ( !file.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    if ( file.isLicenseValid() )
    {
        std::cout << "Mascot license is still valid. Other information:"   << std::endl;
        std::cout << file.getLicenseString()                               << std::endl;
    }
    else
    {
        std::cout << "Mascot license has either expired or been corrupted" << std::endl;
    }

    return 0;
}

/*

will give the output, for instance:

# config_license ../config/mascot.license

Mascot license has either expired or been corrupted

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_license.java

Read in the mascot.license file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_license {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("Location of 'mascot.license'-file has to be specified as a parameter");
            System.exit(0);
        }

        ms_license file = new ms_license(argv[0]);
        if (!file.isValid())
        {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }

        if (file.isLicenseValid())
        {
            System.out.println("Mascot license is still valid. Other information:");
            System.out.println(file.getLicenseString());
        }
        else
        {
            System.out.println("Mascot license has either expired or been corrupted");
        }
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_license mascot.license

Mascot license has either expired or been corrupted

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_license.pl

Read in the mascot.license file.

#!/usr/local/bin/perl
##############################################################################
# file: config_license.pl                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_license.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print "Location of 'mascot.license' file has to be specified as a parameter\n";
    exit 1;
}

my $file = new msparser::ms_license($ARGV[0]);

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

if ($file->isLicenseValid) {
    print "Mascot license is still valid. Other information:\n";
    print $file->getLicenseString(), "\n";
} else {
    print "Mascot license has either expired or been corrupted\n";
}

=pod

Running the program as

perl -I../bin config_license.pl mascot.license

will give, without a Mascot license file:

There are errors. Cannot continue. The last error description:
Missing license file: mascot.license.

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_license.py

Read in the mascot.license file.

#!/usr/bin/python
##############################################################################
# file: config_license.py                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_license.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("Location of 'mascot.license' file has to be specified as a parameter")
    sys.exit(1)

file = msparser.ms_license(sys.argv[1])

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

if file.isLicenseValid() :
    print("Mascot license is still valid. Other information:")
    print(file.getLicenseString())
else :
    print("Mascot license has either expired or been corrupted")

"""

Running the program as

python config_license.pl mascot.license

will give, without a Mascot license file:

There are errors. Cannot continue. The last error description:
Missing license file: mascot.license.

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_mascotdat.cpp

Read in the mascot.dat file.

/*
##############################################################################
# file: config_mascotdat.cpp                                                 #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_mascotdat.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "The location of mascot.dat file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the mascot.dat file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the second parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 2)
    {
        cs.setSessionID(argv[2]);
    }

    ms_datfile file(argv[1], 0, &cs);

    if ( !file.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    // retrieving Databases-section content
    const ms_databases* dbs = file.getDatabases();

    // check if there is 'Databases' section in the file actually
    if ( dbs->isSectionAvailable() )
    {
        int n = dbs->getNumberOfDatabases();
        std::cout << "There are " << n << " databases configured:" << std::endl;
        int i;
        for(i=0; i < n; i++)
        {
            std::cout << dbs->getDatabase(i)->getName() << " : ";
            std::cout << (dbs->getDatabase(i)->isActive() ? "active" : "inactive");
            std::cout << std::endl;
        }
    }
    else
    {
        std::cout << "Databases-section is missing" << std::endl;
    }
    std::cout << std::endl;

    // retrieving Parse-section content
    const ms_parseoptions* parseOptions = file.getParseOptions();

    // check if there is 'Parse' section in the file actually
    if ( parseOptions->isSectionAvailable() )
    {
        int n = parseOptions->getNumberOfParseRules();
        std::cout << "Parse rules configured:" << std::endl;
        int i;
        for(i=0; i < n; i++)
        {
            // not all of them can be specified
            if ( parseOptions->getParseRule(i)->isAvailable() )
            {
                std::cout << "Rule_" << i << " : ";
                std::cout << parseOptions->getParseRule(i)->getRuleStr();
                std::cout << std::endl;
            }
        }
    }
    else
    {
        std::cout << "Parse-section is missing" << std::endl;
    }
    std::cout << std::endl;

    // retrieving WWW-section content
    const ms_wwwoptions* wwwOptions = file.getWWWOptions();

    // check if there is 'WWW' section in the file actually
    if ( wwwOptions->isSectionAvailable() )
    {
        int n = wwwOptions->getNumberOfEntries();
        std::cout << "There are " << n << " sequence report sources configured:" << std::endl;
        int i;
        for(i=0; i < n; i++)
        {
            std::cout << wwwOptions->getEntry(i)->getName() << "_";
            std::cout << ((wwwOptions->getEntry(i)->getType() == WWW_SEQ) ? "SEQ" : "REP");
            std::cout << std::endl;
        }
    }
    else
    {
        std::cout << "WWW-section is missing" << std::endl;
    }
    std::cout << std::endl;

    // retrieving Taxonomy-sections
    std::cout << "Available taxonomy sources:" << std::endl;

    int maxtax =  file.getMaxTaxonomyRules();
    int taxind;
    for(taxind = 1; taxind <= maxtax; taxind++)
    {
        // check whether a certain taxonomy section exists
        if ( file.getTaxonomyRules(taxind) != NULL )
        {
            std::cout << "TAXONOMY_" << taxind;
            std::cout << file.getTaxonomyRules(taxind)->getIdentifier();
            std::cout << std::endl;
        }
    }
    std::cout << std::endl;

    // retrieving Cluster-section content
    const ms_clusterparams* clusterParams = file.getClusterParams();

    // check if there is 'Cluster' section in the file actually
    if ( clusterParams->isSectionAvailable() )
    {
        std::cout << "Cluster mode : ";
        std::cout << (clusterParams->isEnabled() ? "enabled" : "disabled");
        std::cout << std::endl;
    }
    else
    {
        std::cout << "Cluster-section is missing" << std::endl;
    }
    std::cout << std::endl;

    // retrieving Processor-section content
    const ms_processoroptions* procOptions = file.getProcessors();

    // check if there is 'Processor' section in the file actually
    if ( procOptions->isSectionAvailable() )
    {

        std::cout << procOptions->getNumberOfProcessors() << " CPU(s) configured";
        std::cout << std::endl;
    }
    else
    {
        std::cout << "Processor-section is missing" << std::endl;
    }
    std::cout << std::endl;

    // retrieving Options-section content
    const ms_mascotoptions* mascotOptions = file.getMascotOptions();

    // check if there is 'Options' section in the file actually
    if ( mascotOptions->isSectionAvailable() )
    {

        std::cout << "MascotCmdLine : ";
        std::cout << mascotOptions->getMascotCmdLine();
        std::cout << std::endl;
    }
    else
    {
        std::cout << "Options-section is missing" << std::endl;
    }
    std::cout << std::endl;

    // retrieving Cron-section content
    const ms_cronoptions* cronOptions = file.getCronOptions();

    // check if there is 'Cron' section in the file actually
    if ( cronOptions->isSectionAvailable() )
    {
        if ( cronOptions->isCronEnabled() )
        {
            int n = cronOptions->getNumberOfCronJobs();
            std::cout << "There are " << n << " cron-jobs configured:" << std::endl;
            int i;
            for(i=0; i < n; i++)
            {
                std::cout << cronOptions->getCronJob(i).getCommandStr() << std::endl;
            }
        }
        else
        {
            std::cout << "Cron functionality is disabled" << std::endl;
        }
    }
    else
    {
        std::cout << "Cron-section is missing" << std::endl;
    }
    std::cout << std::endl;

    return 0;
}

/*
will give the output:

# test.exe ../config/mascot.dat

There are 4 databases configured:
MSDB : active
NCBInr : active
EST_human : inactive
EST_mouse : inactive

Parse rules configured:
Rule_1 : >owl[^ ]*|\([^ ]*\)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\(.*\)
Rule_3 : >[A-Z][1-9];\([^ ]*\)
Rule_4 : >\([^ ]*\)
Rule_5 : >[^ ]* \(.*\)

There are 8 sequence report sources configured:
NCBInr_SEQ
NCBInr_REP
MSDB_SEQ
MSDB_REP
IPI_human_SEQ
IPI_human_REP
IPI_mouse_SEQ
IPI_mouse_REP

Available taxonomy sources:
TAXONOMY_1NCBI nr FASTA
TAXONOMY_2OWL REF
TAXONOMY_3Swiss-prot FASTA
TAXONOMY_4NCBI dbEST FASTA

Cluster mode : disabled

Processor-section is missing

MascotCmdLine : ../cgi/nph-mascot.exe

Cron functionality is disabled

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_mascotdat.cs

Read in the mascot.dat file.

/*
##############################################################################
# file: config_mascotdat.cs                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_mascotdat.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_mascotdat
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.Error.WriteLine(@"The location of the mascot.dat has to be specified as a parameter
The location should either be the full path to the mascot.dat file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
                    return;
            }

            // A sessionID can optionally be passed as the second parameter
            // This will only be required if the 'file' is a URL
            ms_datfile file;
            if (argv.Length > 1)
            {
                ms_connection_settings cs = new ms_connection_settings();
                cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
                cs.setSessionID(argv[1]);
                file = new ms_datfile(argv[0], 0, cs);
            } else file = new ms_datfile(argv[0]);

            if (!file.isValid())
            {
                Console.Error.WriteLine("There are errors. Cannot continue. The last error description:");
                Console.Error.WriteLine(file.getLastErrorString());
                return;
            }

            // retrieving Databases-section content
            ms_databases dbs = file.getDatabases();

            // check if there is actually a 'Databases' section in the file
            if (dbs.isSectionAvailable())
            {
                int n = dbs.getNumberOfDatabases();
                Console.WriteLine("There are {0} databases configured:", n);
                for (int i = 0; i < n; i++)
                {
                    Console.WriteLine("{0} : {1}", dbs.getDatabase(i).getName(), dbs.getDatabase(i).isActive() ? "active" : "inactive");
                }
            }
            else
            {
                Console.WriteLine("Databases-section is missing");
            }
            Console.WriteLine();

            // retrieving Parse-section content
            ms_parseoptions parseOptions = file.getParseOptions();

            // check if there is actually a 'Parse' section in the file
            if (parseOptions.isSectionAvailable())
            {
                int n = parseOptions.getNumberOfParseRules();
                Console.WriteLine("Parse rules configured:");
                for (int i = 0; i < n; i++)
                {
                    // not all of them can be specified
                    if (parseOptions.getParseRule(i).isAvailable())
                    {
                        Console.WriteLine("Rule_{0} : {1}", i, parseOptions.getParseRule(i).getRuleStr());
                    }
                }
            }
            else
            {
                Console.WriteLine("Parse-section is missing");
            }
            Console.WriteLine();

            // retrieving WWW-section content
            ms_wwwoptions wwwOptions = file.getWWWOptions();

            // check if there is actually a 'WWWW' section in the file
            if (wwwOptions.isSectionAvailable())
            {
                int n = wwwOptions.getNumberOfEntries();
                Console.WriteLine("There are {0} sequence report sources configured:", n);
                for (int i = 0; i < n; i++)
                {
                    Console.WriteLine("{0}_{1}", wwwOptions.getEntry(i).getName(),
                        wwwOptions.getEntry(i).getType() == WWW_TYPE.WWW_SEQ ? "SEQ" : "REP");
                }
            }
            else
            {
                Console.WriteLine("WWW-section is missing");
            }
            Console.WriteLine();

            // retrieving Taxonomy-sections
            Console.WriteLine("Available taxonomy sources:");
            int maxTax = file.getMaxTaxonomyRules();
            for (int taxInd = 1; taxInd <= maxTax; taxInd++)
            {
                // check whether a certain taxonomy section exists
                if (file.getTaxonomyRules(taxInd) != null)
                {
                    Console.WriteLine("TAXONOMY_{0} {1}", taxInd, file.getTaxonomyRules(taxInd).getIdentifier());
                }
            }
            Console.WriteLine();

            // retrieving Cluster-section content
            ms_clusterparams clusterParams = file.getClusterParams();

            // Check if there is a 'Cluster' section available
            if (clusterParams.isSectionAvailable())
            {
                Console.WriteLine("Cluster mode : {0}", clusterParams.isEnabled() ? "enabled" : "disabled");
            }
            else
            {
                Console.WriteLine("Cluster-section is missing");
            }
            Console.WriteLine();

            // retrieving Processor-section content
            ms_processoroptions procOptions = file.getProcessors();

            // check if the 'Processor' section is available
            if (procOptions.isSectionAvailable())
            {
                Console.WriteLine("{0} CPU(s) configured", procOptions.getNumberOfProcessors());
            }
            else
            {
                Console.WriteLine("Processor-section is missing");
            }
            Console.WriteLine();

            // retrieving Options-section content
            ms_mascotoptions mascotOptions = file.getMascotOptions();

            // check if there is actually an 'Options' section in the file
            if (mascotOptions.isSectionAvailable())
            {
                Console.WriteLine("MascotCmdLine : {0}", mascotOptions.getMascotCmdLine());
            }
            else
            {
                Console.WriteLine("Options-section is missing");
            }
            Console.WriteLine();

            // retrieving Cron-section content
            ms_cronoptions cronOptions = file.getCronOptions();
            if (cronOptions.isCronEnabled())
            {
                int n = cronOptions.getNumberOfCronJobs();
                Console.WriteLine("There are {0} cron-jobs configured:", n);
                for (int i = 0; i < n; i++)
                {
                    Console.WriteLine(cronOptions.getCronJob(i).getCommandStr());
                }
            }
            else
            {
                Console.WriteLine("Cron functionality is disabled");
            }
            Console.WriteLine();
        }
    }
}

/*
Running the program as

config_mascotdat.exe c:\inetpub\mascot\config\mascot.dat

Will give the output:

There are 18 databases configured:
B_subtilis : inactive
Bug_11795 : inactive
contaminants : active
cRAP : active
Human_NoIsoforms : active
IPI-human : active
IPI_human : active
IPI_human_decoy : active
Mixed_M_2013-02-07_TruncWithReverse4 : active
PRIDE_PXD0000001 : active
Proteome_EBV_B95.8_GenBank : inactive
SwissProt : active
UniProt_Arabidopsis : active
UniProt_Chlamydomonas_reinhardtii : active
UniProt_Human : active
UniProt_Papillomaviridae : active
UniProt_Pig : active
UniProt_Rat : active

Parse rules configured:
Rule_1 : >[^|]*|[ABCDEFGHIJKLMNOPQRSTUVWXYZ]\([^ |]*\)
Rule_2 : >[^ ]* [^ ]* \(.*\)
Rule_3 : \*\(.*\)>
Rule_4 : >\(gi|[0-9]*\)
Rule_5 : >[^ ]* \(.*\)
Rule_6 : >\([^ ]*\)
Rule_7 : >[^ ]* \(.*\)
Rule_8 : \*\(.*\)>
Rule_9 : >..|\([^|]*\)
Rule_10 : \(.*\)
Rule_11 : >..|[ABCDEFGHIJKLMNOPQRSTUVWXYZ]\([^|]*\)
Rule_12 : >IPI:\([^| ]*\)
Rule_13 : ^ID   \([^ .]*\)
Rule_14 : \*\(.*\)>
Rule_15 : \*.*\(ID   IPI[0-9.]* .*\)
Rule_16 : >IPI:\([^| .]*\)
Rule_17 : ^ID   \([^ .]*\)
Rule_18 : >[^ ]* \(.*\)
Rule_19 : \*\(.*\)>
Rule_20 : \*.*\(ID   IPI[0-9.]* .*\)
Rule_21 : >\([^|]*\)
Rule_22 : >\([^ ]*\)
Rule_23 : >\(.*\)
Rule_24 : >..|[^|]*|\([^ ]*\)
Rule_25 : ^ID   \([^ ]*\)
Rule_26 : >[^ ]* \(.*\)
Rule_27 : \*\(.*\)>
Rule_28 : \*.*\(ID   [-A-Z0-9_].*\)
Rule_29 : human  *release  *\([0-9.][0-9.]*\)
Rule_30 : Swiss-Prot  *.*Release  *\([0-9._][0-9._]*\)
Rule_31 : >IPI:\([^| .]*\)
Rule_32 : >[^|]*|\\w\([^ |]*\)
Rule_33 : >..|\\w\([^|]*\)
Rule_34 : human  *release  *\([0-9.][0-9.]*\)

There are 27 sequence report sources configured:
B_subtilis_SEQ
Bug_11795_SEQ
contaminants_SEQ
cRAP_SEQ
Human_NoIsoforms_SEQ
IPI-human_SEQ
IPI_human_SEQ
IPI_human_decoy_SEQ
Mixed_M_2013-02-07_TruncWithReverse4_SEQ
PRIDE_PXD0000001_SEQ
Proteome_EBV_B95.8_GenBank_SEQ
SwissProt_SEQ
UniProt_Arabidopsis_SEQ
UniProt_Chlamydomonas_reinhardtii_SEQ
UniProt_Human_SEQ
UniProt_Papillomaviridae_SEQ
UniProt_Pig_SEQ
UniProt_Rat_SEQ
IPI-human_REP
IPI_human_REP
SwissProt_REP
UniProt_Arabidopsis_REP
UniProt_Chlamydomonas_reinhardtii_REP
UniProt_Human_REP
UniProt_Papillomaviridae_REP
UniProt_Pig_REP
UniProt_Rat_REP

Available taxonomy sources:
TAXONOMY_1 All human with TaxID 9606
TAXONOMY_2 SwissProt FASTA
TAXONOMY_3 All human with TaxID 9606
TAXONOMY_4 All mouse with TaxID 10090
TAXONOMY_5 EMBL EST Fasta
TAXONOMY_6 HUPO PSI PEFF Format
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nucleotide FASTA using GI2TAXID
TAXONOMY_9 NCBI protein FASTA using GI2TAXID
TAXONOMY_10 OWL REF
TAXONOMY_11 Obsolete_1
TAXONOMY_12 Obsolete_2
TAXONOMY_13 Obsolete_3
TAXONOMY_14 Swiss-prot DAT
TAXONOMY_15 SwissProt FASTA
TAXONOMY_16 UniRef Fasta

Cluster mode : disabled

Processor-section is missing

MascotCmdLine : ../cgi/nph-mascot.exe

There are 5 cron-jobs configured:
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl SwissProt
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl UniProt_Chlamydomonas_reinhardtii
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl UniProt_Rat
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_add_task.pl UniProt_Pig
C:\Perl64\bin\perl.exe C:/inetpub/mascot/bin/dbman_process_tasks.pl
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_mascotdat.java

Read in the mascot.dat file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi  #
#     Author: yuryr  #
#       Date: 2006/02/06 17:53:44  #
#   Revision: 1.1  #
# NoKeywords::                                                             #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_mascotdat {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.err.println("Location of mascot.dat has to be specified as a parameter");
            System.err.println("The location should either be the full path to the enzymes file");
            System.err.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
            System.exit(0);
        }

        // A sessionID can optionally be passed as the second parameter
        // This will only be required if the 'file' is a URL
        ms_datfile file;
        if (argv.length > 1)
        {
            ms_connection_settings cs = new ms_connection_settings();
            cs.setSessionID(argv[1]);
            file = new ms_datfile(argv[0], 0, cs);
        }
        else
        {
            file = new ms_datfile(argv[0]);
        }

        if (!file.isValid())
        {
            System.err.println("There are errors. Cannot continue. The last error description:");
            System.err.println(file.getLastErrorString());
            System.exit(0);
        }

        // retrieving Databases-section content
        ms_databases dbs = file.getDatabases();

        // check if there is actually a 'Databases' section in the file
        if (dbs.isSectionAvailable())
        {
            int n = dbs.getNumberOfDatabases();
            System.out.println("There are " + n + " databases configured:");
            for(int i=0; i < n; i++)
            {
                System.out.print(dbs.getDatabase(i).getName() + " : ");
                if (dbs.getDatabase(i).isActive())
                {
                    System.out.println("active");
                }
                else
                {
                    System.out.println("inactive");
                }
            }
        }
        else
        {
            System.out.println("Databases-section is missing");
        }
        System.out.println("");

        // retrieving Parse-section content
        ms_parseoptions parseOptions = file.getParseOptions();

        // check if there is 'Parse' section in the file actually
        if (parseOptions.isSectionAvailable())
        {
            int n = parseOptions.getNumberOfParseRules();
            System.out.println("Parse rules configured:");
            for (int i=0; i < n; i++)
            {
                // not all of them can be specified
                if (parseOptions.getParseRule(i).isAvailable())
                {
                    System.out.print("Rule_" + i + " : ");
                    System.out.println(parseOptions.getParseRule(i).getRuleStr());
                }
            }
        }
        else
        {
            System.out.println("Parse-section is missing");
        }
        System.out.println();

        // retrieving WWW-section content
        ms_wwwoptions wwwOptions = file.getWWWOptions();

        // check if there is 'WWW' section in the file actually
        if (wwwOptions.isSectionAvailable())
        {
            int n = wwwOptions.getNumberOfEntries();
            System.out.println("There are " + n + " sequence report sources configured:");
            for(int i=0; i < n; i++)
            {
                System.out.print(wwwOptions.getEntry(i).getName() + "_");
                if (wwwOptions.getEntry(i).getType() == msparser.WWW_SEQ)
                {
                    System.out.println("SEQ");
                }
                else
                {
                    System.out.println("REP");
                }
            }
        }
        else
        {
            System.out.println("WWW-section is missing");
        }
        System.out.println();

        // retrieving Taxonomy-sections
        System.out.println("Available taxonomy sources:");
        int maxtax =  file.getMaxTaxonomyRules();
        for (int taxind = 1; taxind <= maxtax; taxind++)
        {
            // check whether a certain taxonomy section exists
            if (file.getTaxonomyRules(taxind) != null)
            {
                System.out.print("TAXONOMY_" + taxind + " ");
                System.out.println(file.getTaxonomyRules(taxind).getIdentifier());
            }
        }
        System.out.println();

        // retrieving Cluster-section content
        ms_clusterparams clusterParams = file.getClusterParams();

        // check if there is 'Cluster' section in the file actually
        if (clusterParams.isSectionAvailable())
        {
            System.out.print("Cluster mode : ");
            if (clusterParams.isEnabled())
            {
                System.out.println("enabled");
            }
            else
            {
                System.out.println("disabled");
            }
        }
        else
        {
            System.out.println("Cluster-section is missing");
        }
        System.out.println();

        // retrieving Processor-section content
        ms_processoroptions procOptions = file.getProcessors();

        // check if there is actually a 'Processor' section in the file
        if (procOptions.isSectionAvailable())
        {
            System.out.println(procOptions.getNumberOfProcessors()  + " CPU(s) configured");
        }
        else
        {
            System.out.println("Processor-section is missing");
        }
        System.out.println();

        // retrieving Options-section content
        ms_mascotoptions mascotOptions = file.getMascotOptions();

        // check if there is actually an 'Options' section in the file
        if (mascotOptions.isSectionAvailable())
        {
            System.out.print("MascotCmdLine : ");
            System.out.println(mascotOptions.getMascotCmdLine());
        }
        else
        {
            System.out.println("Options-section is missing");
        }
        System.out.println();

        // retrieving Cron-section content
        ms_cronoptions cronOptions = file.getCronOptions();

        // check if there is actually a 'Cron' section in the file
        if (cronOptions.isSectionAvailable())
        {
            if (cronOptions.isCronEnabled())
            {
                int n = cronOptions.getNumberOfCronJobs();
                System.out.println("There are " + n + " cron-jobs configured:");
                for (int i=0; i < n; i++)
                {
                    System.out.println(cronOptions.getCronJob(i).getCommandStr());
                }
            }
            else
            {
                System.out.println("Cron functionality is disabled");
            }
        }
        else
        {
            System.out.println("Cron-section is missing");
        }
        System.out.println();
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_mascotdat mascot.dat

There are 10 databases configured:
MSDB : active
NCBInr : active
EST_human : inactive
EST_mouse : inactive
EST_others : active
SwissProt : active
Trembl : inactive
IPI_human : inactive
IPI_mouse : inactive
yeastorfn : active

Parse rules configured:
Rule_1 : >owl[^ ]*|\([^ ]*\)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\(.*\)
Rule_3 : >[A-Z][0-9];\([^ ]*\)
Rule_4 : >\([^ ]*\)
Rule_5 : >[^ ]* \(.*\)
Rule_6 : >\(gi|[0-9]*\)
Rule_7 : >[^ ]* \(.*\)
Rule_8 : \*\(.*\)>
Rule_9 : \*.*\(>[A-Z][0-9];.*\)
Rule_10 : \(LOCUS .*\)ORIGIN
Rule_11 : \(LOCUS .*\)
Rule_12 : >\([^ ]*\)
Rule_13 : >[^ ]* \(.*\)
Rule_14 : <pre>\(.*\)</pre>
Rule_15 : ^AC   \([^ ;]*\)
Rule_16 : \*.*\(ID   [A-Z0-9]*_[A-Z0-9]* .*\)
Rule_17 : >\([^ ]*\)
Rule_18 : >[^ ]* \(.*\)
Rule_19 : >[A-Z][0-9];\([^ ]*\)[ ]*
Rule_20 : >\(.*\)
Rule_21 : >IPI:\([^| .]*\)
Rule_22 : \*.*\(ID   IPI[0-9]* .*\)
Rule_23 : \(.*\)
Rule_24 : \*.*\(ID   [-A-Z0-9_].*\)
Rule_25 : >[^(]*.\([^)]*\)
Rule_26 : ^AC   \([^ ;]*\)
Rule_27 : \*.*\(AC   [A-Z0-9]*;.*\)

There are 19 sequence report sources configured:
NCBInr_SEQ
NCBInr_REP
EST_human_SEQ
EST_human_REP
EST_mouse_SEQ
EST_mouse_REP
EST_others_SEQ
EST_others_REP
SwissProt_SEQ
SwissProt_REP
Trembl_SEQ
Trembl_REP
MSDB_SEQ
MSDB_REP
IPI_human_SEQ
IPI_human_REP
IPI_mouse_SEQ
IPI_mouse_REP
yeastorfn_SEQ

Available taxonomy sources:
TAXONOMY_1 NCBI nr FASTA
TAXONOMY_2 OWL REF
TAXONOMY_3 Swiss-prot FASTA
TAXONOMY_4 NCBI dbEST FASTA
TAXONOMY_5 Swiss-prot DAT
TAXONOMY_6 MSDB REF (pre 20000621)
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nr FASTA using GI2TAXID
TAXONOMY_9 dbEST FASTA using GI2TAXID
TAXONOMY_10 EST_human FASTA with TaxID
TAXONOMY_11 EST_mouse FASTA with TaxID

Cluster mode : disabled

Processor-section is missing

MascotCmdLine : ../cgi/nph-mascot.exe

Cron functionality is disabled

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_mascotdat.pl

Read in the mascot.dat file.

#!/usr/local/bin/perl
##############################################################################
# file: config_mascotdat.pl                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_mascotdat.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
Location of mascot.dat has to be specified as a parameter.
The location should either be the full path to the mascot.dat file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[1]);
    $file = new msparser::ms_datfile($ARGV[0], 0, $cs);
} else {
    $file = new msparser::ms_datfile($ARGV[0]);
}

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

# Retrieving section 'Databases' content.
my $dbs = $file->getDatabases;

# Check if there is actually a 'Databases' section in the file before
# continuing.
if ($dbs->isSectionAvailable) {
    my $n = $dbs->getNumberOfDatabases;
    print "There are ", $n, " databases configured:\n";

    for my $i (0 .. $n-1) {
        print $dbs->getDatabase($i)->getName, " : ";

        if ($dbs->getDatabase($i)->isActive()) {
            print "active\n";
        } else {
            print "inactive\n";
        }
    }
} else {
    print "Section 'Databases' is missing\n";
}

print "\n";

# Retrieving section 'Parse' content.
my $parseOptions = $file->getParseOptions();

# Check if there is a 'Parse' section in the file before continuing.
if ($parseOptions->isSectionAvailable) {
    my $n = $parseOptions->getNumberOfParseRules();
    print "There are ", $n, " parse rules in the file; the following are specified:\n";

    for my $i (0 .. $n-1) {
        # Not all of them need be specified in the file.
        if ($parseOptions->getParseRule($i)->isAvailable()) {
            print "Rule_", $i, " : ";
            print $parseOptions->getParseRule($i)->getRuleStr(), "\n";
        }
    }
} else {
    print "Section 'Parse' is missing\n";
}

print "\n";

# Retrieving section 'WWW' content.
my $wwwOptions = $file->getWWWOptions();

# Check if there is a 'WWW' section in the file before continuing.
if ($wwwOptions->isSectionAvailable) {
    my $n = $wwwOptions->getNumberOfEntries();
    print "There are ", $n, " sequence report sources configured:\n";

    for my $i (0 .. $n-1) {
        print $wwwOptions->getEntry($i)->getName(), "_";

        if ($wwwOptions->getEntry($i)->getType() == $msparser::WWW_SEQ) {
            print "SEQ\n";
        } else {
            print "REP\n";
        }
    }
} else {
    print "Section 'WWW' is missing\n";
}

print "\n";

# Retrieving section 'Taxonomy' content.
print "Available taxonomy sources:\n";

my $maxtax = $file->getMaxTaxonomyRules();
my $activetax = 0;

for my $taxind (1 .. $maxtax) {
    # Check whether the taxonomy section exists.
    if ($file->getTaxonomyRules($taxind)) {
        ++$activetax;
        print "TAXONOMY_", $taxind, " ";
        print $file->getTaxonomyRules($taxind)->getIdentifier(), "\n";
    }
}

if ($activetax == 0) {
    print "(none)\n";
}

print "\n";

# Retrieving section 'Cluster' content.
my $clusterParams = $file->getClusterParams();

# Check if there is a 'Cluster' section in the file before continuing.
if ($clusterParams->isSectionAvailable) {
    print "Cluster mode : ";

    if ($clusterParams->isEnabled) {
        print "enabled\n";
    } else {
        print "disabled\n";
    }
} else {
    print "Section 'Cluster' is missing\n";
}

print "\n";

# Retrieving section 'Processor' content.
my $procOptions = $file->getProcessors();

# Check if there is a 'Processor' section in the file before continuing.
if ($procOptions->isSectionAvailable) {
    print $procOptions->getNumberOfProcessors, " CPU(s) configured\n";
} else {
    print "Section 'Processor' is missing\n";
}

print "\n";

# Retrieving section 'Options' content.
my $mascotOptions = $file->getMascotOptions();

# Check if there is an 'Options' section in the file before continuing.
if ($mascotOptions->isSectionAvailable) {
    print "MascotCmdLine : ", $mascotOptions->getMascotCmdLine(), "\n";
} else {
    print "Section 'Options' is missing\n";
}

print "\n";

# Retrieving section 'Cron' content.
my $cronOptions = $file->getCronOptions();

# Check if there is a 'Cron' section in the file before continuing.
if ($cronOptions->isSectionAvailable)  {
    if ($cronOptions->isCronEnabled) {
        my $n = $cronOptions->getNumberOfCronJobs;

        if ($n == 0) {
            print "There are ", $n, " cron jobs configured\n";
        } else {
            print "There are ", $n, " cron jobs configured:\n";
        }

        for my $i (0 .. $n-1) {
            print $cronOptions->getCronJob($i)->getCommandStr(), "\n";
        }
    } else {
        print "Cron functionality is disabled\n";
    }
} else {
    print "Section 'Cron' is missing\n";
}

print "\n";

=pod

Running the program as

perl -I../bin config_mascotdat.pl ../config/mascot.dat

will give the following output under Mascot Server 2.3 (exact details depend
on how the server has been configured):

There are 29 databases configured:
contaminants : active
cRAP : active
EST_human : inactive
EST_mouse : inactive
EST_others : inactive
IPI_arabidopsis : inactive
IPI_bovine : inactive
IPI_chicken : inactive
IPI_human : inactive
IPI_mouse : inactive
IPI_rat : inactive
IPI_zebrafish : inactive
MSIPI_human : inactive
MSIPI_mouse : inactive
NCBInr : active
SwissProt : active
Trembl : inactive
UniRef100 : inactive
Environmental_EST : inactive
Fungi_EST : inactive
Human_EST : inactive
Invertebrates_EST : inactive
Mammals_EST : inactive
Mus_EST : inactive
Plants_EST : inactive
Prokaryotes_EST : inactive
Rodents_EST : inactive
Unclassified_EST : inactive
Vertebrates_EST : inactive

There are 256 parse rules in the file; the following are specified:
Rule_1 : >owl[^ ]*|\([^ ]*\)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\(.*\)
Rule_3 : >[A-Z][0-9];\([^ ]*\)
Rule_4 : >\([^ ]*\)
Rule_5 : >[^ ]* \(.*\)
Rule_6 : >\(gi|[0-9]*\)
Rule_7 : >[^ ]* \(.*\)
Rule_8 : \*\(.*\)>
Rule_9 : \*.*\(>[A-Z][0-9];.*\)
Rule_10 : \(LOCUS .*\)ORIGIN
Rule_11 : \(LOCUS .*\)
Rule_12 : >\([^ ]*\)
Rule_13 : >[^ ]* \(.*\)
Rule_14 : <pre>\(.*\)</pre>
Rule_15 : ^ID   \([^ ]*\)
Rule_16 : \*.*\(ID   [A-Z0-9]*_[A-Z0-9]* .*\)
Rule_17 : >\([^ ]*\)
Rule_18 : >[^ ]* \(.*\)
Rule_19 : >[A-Z][0-9];\([^ ]*\)[ ]*
Rule_20 : >\(.*\)
Rule_21 : >IPI:\([^| .]*\)
Rule_22 : \*.*\(ID   IPI[0-9]* .*\)
Rule_23 : \(.*\)
Rule_24 : \*.*\(ID   [-A-Z0-9_].*\)
Rule_25 : >[^(]*.\([^)]*\)
Rule_26 : ^AC   \([^ ;]*\)
Rule_27 : \*.*\(AC   \S.*\)
Rule_28 : ^ID   \([^ .]*\)
Rule_29 : \*.*\(ID   IPI[0-9.]* .*\)
Rule_30 : >UniRef100_\([^ ]*\)
Rule_31 : >[^|]*|\([^ ]*\)
Rule_32 : >\([^|]*\)
Rule_33 : >..|[^|]*|\([^ ]*\)
Rule_34 : >..|\([^|]*\)
Rule_35 : >sp|\([^|]*\)
Rule_36 : >IPI:CON_\([^|]*\)
Rule_37 : >MSIPI:s*p*|*\([^| .]*\)
Rule_38 : >EM_EST:\([A-Z0-9]*\);
Rule_39 : >EM_ENV:\([A-Z0-9]*\);

There are 56 sequence report sources configured:
contaminants_SEQ
cRAP_SEQ
EST_human_REP
EST_human_SEQ
EST_mouse_REP
EST_mouse_SEQ
EST_others_REP
EST_others_SEQ
IPI_arabidopsis_REP
IPI_arabidopsis_SEQ
IPI_bovine_REP
IPI_bovine_SEQ
IPI_chicken_REP
IPI_chicken_SEQ
IPI_human_REP
IPI_human_SEQ
IPI_mouse_REP
IPI_mouse_SEQ
IPI_rat_REP
IPI_rat_SEQ
IPI_zebrafish_REP
IPI_zebrafish_SEQ
MSIPI_human_REP
MSIPI_human_SEQ
MSIPI_mouse_REP
MSIPI_mouse_SEQ
NCBInr_REP
NCBInr_SEQ
SwissProt_REP
SwissProt_SEQ
Trembl_REP
Trembl_SEQ
UniRef100_REP
UniRef100_SEQ
Environmental_EST_SEQ
Environmental_EST_REP
Fungi_EST_SEQ
Fungi_EST_REP
Human_EST_SEQ
Human_EST_REP
Invertebrates_EST_SEQ
Invertebrates_EST_REP
Mammals_EST_SEQ
Mammals_EST_REP
Mus_EST_SEQ
Mus_EST_REP
Plants_EST_SEQ
Plants_EST_REP
Prokaryotes_EST_SEQ
Prokaryotes_EST_REP
Rodents_EST_SEQ
Rodents_EST_REP
Unclassified_EST_SEQ
Unclassified_EST_REP
Vertebrates_EST_SEQ
Vertebrates_EST_REP

Available taxonomy sources:
TAXONOMY_1 Obsolete
TAXONOMY_2 OWL REF
TAXONOMY_3 SwissProt FASTA
TAXONOMY_4 Obsolete
TAXONOMY_5 Swiss-prot DAT
TAXONOMY_6 MSDB REF (pre 20000621)
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nr FASTA using GI2TAXID
TAXONOMY_9 dbEST FASTA using GI2TAXID
TAXONOMY_10 EST_human FASTA with TaxID
TAXONOMY_11 EST_mouse FASTA with TaxID
TAXONOMY_12 UniRef Fasta
TAXONOMY_13 EMBL EST Fasta

Cluster mode : disabled

Section 'Processor' is missing

MascotCmdLine : ../cgi/nph-mascot.exe

Cron functionality is disabled

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_mascotdat.py

Read in the mascot.dat file.

#!/usr/bin/python
##############################################################################
# file: config_mascotdat.pl                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_mascotdat.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
Location of mascot.dat has to be specified as a parameter.
The location should either be the full path to the mascot.dat file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")
    sys.exit(1)

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 2 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[2])
    file = msparser.ms_datfile(sys.argv[1], 0, cs)
else :
    file = msparser.ms_datfile(sys.argv[1])

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

# Retrieving section 'Databases' content.
dbs = file.getDatabases()

# Check if there is actually a 'Databases' section in the file before
# continuing.
if dbs.isSectionAvailable() :
    n = dbs.getNumberOfDatabases()
    print("There are %d databases configured:" % n)

    for i in range(n) :
        database = dbs.getDatabase(i).getName()

        if dbs.getDatabase(i).isActive() :
            inuse = "active"
        else :
            inuse = "inactive"
        print('{:<20}'.format(database) + '{:<}'.format(inuse))
else :
    print("Section 'Databases' is missing")

print("")

# Retrieving section 'Parse' content.
parseOptions = file.getParseOptions()

# Check if there is a 'Parse' section in the file before continuing.
if parseOptions.isSectionAvailable() :
    n = parseOptions.getNumberOfParseRules()
    print("There are %d parse rules in the file; the following are specified:" % n)

    for i in range(n) :
        # Not all of them need be specified in the file.
        if parseOptions.getParseRule(i).isAvailable() :
            print("Rule_%d : %s" % (i, parseOptions.getParseRule(i).getRuleStr()))
else :
    print("Section 'Parse' is missing")

print("")

# Retrieving section 'WWW' content.
wwwOptions = file.getWWWOptions()

# Check if there is a 'WWW' section in the file before continuing.
if wwwOptions.isSectionAvailable() :
    n = wwwOptions.getNumberOfEntries()
    print("There are %d sequence report sources configured:" % n)

    for i in range(n) :
        if wwwOptions.getEntry(i).getType() == msparser.WWW_SEQ :
            type = "SEQ"
        else :
            type = "REP"

        print("%s_%s" % (wwwOptions.getEntry(i).getName(), type))
else :
    print("Section 'WWW' is missing")

print("")

# Retrieving section 'Taxonomy' content.
print("Available taxonomy sources:")

maxtax = file.getMaxTaxonomyRules()
activetax = 0

for taxind in range(1, 1 + maxtax) :
    # Check whether the taxonomy section exists.
    if file.getTaxonomyRules(taxind) :
        activetax += 1
        print("TAXONOMY_%d" % taxind)
        print(file.getTaxonomyRules(taxind).getIdentifier())

if activetax == 0 :
    print("(none)")

print("")

# Retrieving section 'Cluster' content.
clusterParams = file.getClusterParams()

# Check if there is a 'Cluster' section in the file before continuing.
if clusterParams.isSectionAvailable() :

    if clusterParams.isEnabled() :
        print("Cluster mode: enabled")
    else :
        print("Cluster mode: disabled")
else :
    print("Section 'Cluster' is missing")

print("")

# Retrieving section 'Processor' content.
procOptions = file.getProcessors()

# Check if there is a 'Processor' section in the file before continuing.
if procOptions.isSectionAvailable() :
    print("%d CPU(s) configured" % procOptions.getNumberOfProcessors())
else :
    print("Section 'Processor' is missing")

print("")

# Retrieving section 'Options' content.
mascotOptions = file.getMascotOptions()

# Check if there is an 'Options' section in the file before continuing.
if mascotOptions.isSectionAvailable() :
    print("MascotCmdLine: %s" % mascotOptions.getMascotCmdLine())
else :
    print("Section 'Options' is missing")

print("")

# Retrieving section 'Cron' content.
cronOptions = file.getCronOptions()

# Check if there is a 'Cron' section in the file before continuing.
if cronOptions.isSectionAvailable() :
    if cronOptions.isCronEnabled() :
        n = cronOptions.getNumberOfCronJobs()

        if n == 0 :
            print("There are %d cron jobs configured" % n)
        else :
            print("There are %d cron jobs configured:" % n)

        for i in range(n) :
            print(cronOptions.getCronJob(i).getCommandStr())
    else :
        print("Cron functionality is disabled")
else :
    print("Section 'Cron' is missing")

print("")

"""

Running the program as

python config_mascotdat.py /usr/local/mascot/config/mascot.dat

will give the following output under Mascot Server 2.3 (exact details depend
on how the server has been configured):

There are 29 databases configured:
contaminants : active
cRAP : active
EST_human : inactive
EST_mouse : inactive
EST_others : inactive
IPI_arabidopsis : inactive
IPI_bovine : inactive
IPI_chicken : inactive
IPI_human : inactive
IPI_mouse : inactive
IPI_rat : inactive
IPI_zebrafish : inactive
MSIPI_human : inactive
MSIPI_mouse : inactive
NCBInr : active
SwissProt : active
Trembl : inactive
UniRef100 : inactive
Environmental_EST : inactive
Fungi_EST : inactive
Human_EST : inactive
Invertebrates_EST : inactive
Mammals_EST : inactive
Mus_EST : inactive
Plants_EST : inactive
Prokaryotes_EST : inactive
Rodents_EST : inactive
Unclassified_EST : inactive
Vertebrates_EST : inactive

There are 256 parse rules in the file; the following are specified:
Rule_1 : >owl[^ ]*|\([^ ]*\)
Rule_2 : >owl[^ ]*|[^ ]*[ ]\(.*\)
Rule_3 : >[A-Z][0-9];\([^ ]*\)
Rule_4 : >\([^ ]*\)
Rule_5 : >[^ ]* \(.*\)
Rule_6 : >\(gi|[0-9]*\)
Rule_7 : >[^ ]* \(.*\)
Rule_8 : \*\(.*\)>
Rule_9 : \*.*\(>[A-Z][0-9];.*\)
Rule_10 : \(LOCUS .*\)ORIGIN
Rule_11 : \(LOCUS .*\)
Rule_12 : >\([^ ]*\)
Rule_13 : >[^ ]* \(.*\)
Rule_14 : <pre>\(.*\)</pre>
Rule_15 : ^ID   \([^ ]*\)
Rule_16 : \*.*\(ID   [A-Z0-9]*_[A-Z0-9]* .*\)
Rule_17 : >\([^ ]*\)
Rule_18 : >[^ ]* \(.*\)
Rule_19 : >[A-Z][0-9];\([^ ]*\)[ ]*
Rule_20 : >\(.*\)
Rule_21 : >IPI:\([^| .]*\)
Rule_22 : \*.*\(ID   IPI[0-9]* .*\)
Rule_23 : \(.*\)
Rule_24 : \*.*\(ID   [-A-Z0-9_].*\)
Rule_25 : >[^(]*.\([^)]*\)
Rule_26 : ^AC   \([^ ;]*\)
Rule_27 : \*.*\(AC   \S.*\)
Rule_28 : ^ID   \([^ .]*\)
Rule_29 : \*.*\(ID   IPI[0-9.]* .*\)
Rule_30 : >UniRef100_\([^ ]*\)
Rule_31 : >[^|]*|\([^ ]*\)
Rule_32 : >\([^|]*\)
Rule_33 : >..|[^|]*|\([^ ]*\)
Rule_34 : >..|\([^|]*\)
Rule_35 : >sp|\([^|]*\)
Rule_36 : >IPI:CON_\([^|]*\)
Rule_37 : >MSIPI:s*p*|*\([^| .]*\)
Rule_38 : >EM_EST:\([A-Z0-9]*\);
Rule_39 : >EM_ENV:\([A-Z0-9]*\);

There are 56 sequence report sources configured:
contaminants_SEQ
cRAP_SEQ
EST_human_REP
EST_human_SEQ
EST_mouse_REP
EST_mouse_SEQ
EST_others_REP
EST_others_SEQ
IPI_arabidopsis_REP
IPI_arabidopsis_SEQ
IPI_bovine_REP
IPI_bovine_SEQ
IPI_chicken_REP
IPI_chicken_SEQ
IPI_human_REP
IPI_human_SEQ
IPI_mouse_REP
IPI_mouse_SEQ
IPI_rat_REP
IPI_rat_SEQ
IPI_zebrafish_REP
IPI_zebrafish_SEQ
MSIPI_human_REP
MSIPI_human_SEQ
MSIPI_mouse_REP
MSIPI_mouse_SEQ
NCBInr_REP
NCBInr_SEQ
SwissProt_REP
SwissProt_SEQ
Trembl_REP
Trembl_SEQ
UniRef100_REP
UniRef100_SEQ
Environmental_EST_SEQ
Environmental_EST_REP
Fungi_EST_SEQ
Fungi_EST_REP
Human_EST_SEQ
Human_EST_REP
Invertebrates_EST_SEQ
Invertebrates_EST_REP
Mammals_EST_SEQ
Mammals_EST_REP
Mus_EST_SEQ
Mus_EST_REP
Plants_EST_SEQ
Plants_EST_REP
Prokaryotes_EST_SEQ
Prokaryotes_EST_REP
Rodents_EST_SEQ
Rodents_EST_REP
Unclassified_EST_SEQ
Unclassified_EST_REP
Vertebrates_EST_SEQ
Vertebrates_EST_REP

Available taxonomy sources:
TAXONOMY_1 Obsolete
TAXONOMY_2 OWL REF
TAXONOMY_3 SwissProt FASTA
TAXONOMY_4 Obsolete
TAXONOMY_5 Swiss-prot DAT
TAXONOMY_6 MSDB REF (pre 20000621)
TAXONOMY_7 MSDB REF
TAXONOMY_8 NCBI nr FASTA using GI2TAXID
TAXONOMY_9 dbEST FASTA using GI2TAXID
TAXONOMY_10 EST_human FASTA with TaxID
TAXONOMY_11 EST_mouse FASTA with TaxID
TAXONOMY_12 UniRef Fasta
TAXONOMY_13 EMBL EST Fasta

Cluster mode : disabled

Section 'Processor' is missing

MascotCmdLine : ../cgi/nph-mascot.exe

Cron functionality is disabled

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_masses.cpp

Read in the masses file.

/*
##############################################################################
# file: config_masses.cpp                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_masses.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "The location of masses file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the masses file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the second parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 2)
    {
        cs.setSessionID(argv[2]);
    }

    ms_masses file(argv[1], &cs);

    if ( !file.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    std::cout << "Average amino acid masses as read from 'masses' file:" << std::endl;
    int i;
    for(i='A'; i <= 'Z'; i++)
    {
        std::cout << (char)i << ": "  << file.getResidueMass(MASS_TYPE_AVE, i) << std::endl;
    }

    return 0;
}

/*

will give the output, for instance:

# config_masses ../config/masses

Average amino acid masses as read from 'masses' file:
A: 71.0788
B: 114.596
C: 103.139
D: 115.089
E: 129.116
F: 147.177
G: 57.052
H: 137.141
I: 113.159
J: 0
K: 128.172
L: 113.159
M: 131.193
N: 114.104
O: 0
P: 97.1167
Q: 128.131
R: 156.188
S: 87.0782
T: 101.105
U: 150.034
V: 99.1326
W: 186.213
X: 111
Y: 163.176
Z: 128.623

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_masses.cs

Read in the masses file.

/*
##############################################################################
# file: config_masses.cs                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_masses.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_masses
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.Error.WriteLine(@"The location of the masses file has to be specified as a parameter
The location should either be the full path to the masses file
or a URL to a Mascot server - e.g. http://mascot-searver/mascot/cgi
A Mascot security sessionID can optionally be passed as a second
parameter");
                return;
            }

            // A sessionID can optionally be passed as the second parameter
            // This will only be required if the 'file' is a URL
            ms_masses file;
            if (argv.Length > 1)
            {
                ms_connection_settings cs = new ms_connection_settings();
                cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
                cs.setSessionID(argv[1]);
                file = new ms_masses(argv[0], cs);
            }
            else
            {
                file = new ms_masses(argv[0]);
            }

            // unlike the other configuration files, it is possible to use ms_masses
            // without specifying the filename - in which case it defaults to '../config/masses'

            if (!file.isValid())
            {
                Console.Error.WriteLine("Error when reading file {0}", file.getFileName());
                checkErrorHandler(file);
                return;
            }

            Console.WriteLine("Name of the file: {0}", file.getFileName());
            Console.WriteLine("-------------------------------------------------------------");
            Console.WriteLine("---   Content of masses file                              ---");
            Console.WriteLine("-------------------------------------------------------------");
            Console.WriteLine("Amino acid masses (monoisotopic and average)");

            char res;
            for (res = 'A'; res <= 'Z'; res++)
            {
                Console.WriteLine("{0}:{1:#####.00000},{2:#####.00000}", res,
                    file.getResidueMass(MASS_TYPE.MASS_TYPE_MONO, res),
                    file.getResidueMass(MASS_TYPE.MASS_TYPE_AVE, res));
            }
            Console.WriteLine();
            Console.WriteLine("# Atomic masses used for terminus values");
            Console.WriteLine("HYDROGEN:{0:#####.00000},{1:#####.00000}",
                file.getHydrogenMass(MASS_TYPE.MASS_TYPE_MONO),
                file.getHydrogenMass(MASS_TYPE.MASS_TYPE_AVE));

            Console.WriteLine("CARBON:{0:#####.00000},{1:#####.00000}",
                file.getCarbonMass(MASS_TYPE.MASS_TYPE_MONO),
                file.getCarbonMass(MASS_TYPE.MASS_TYPE_AVE));

            Console.WriteLine("NITROGEN:{0:#####.00000},{1:#####.00000}",
                file.getNitrogenMass(MASS_TYPE.MASS_TYPE_MONO),
                file.getNitrogenMass(MASS_TYPE.MASS_TYPE_AVE));

            Console.WriteLine("OXYGEN:{0:#####.00000},{1:#####.00000}",
                file.getOxygenMass(MASS_TYPE.MASS_TYPE_MONO),
                file.getOxygenMass(MASS_TYPE.MASS_TYPE_AVE));

            Console.WriteLine("ELECTRON:{0:####0.00000}",
                file.getElectronMass());
        }

        private static void checkErrorHandler(ms_masses file)
        {
            Console.WriteLine("Testing the error handling...            ");
            Console.WriteLine("=========================================");
            Console.WriteLine("Error string: {0}", file.getLastErrorString());
            ms_errs errObject = file.getErrorHandler();
            int numErrors = errObject.getNumberOfErrors();
            Console.WriteLine("Number of errors: {0}", numErrors);
            for (int i = 1; i <= numErrors; i++)
            {
                Console.WriteLine("Error number {0}: {1}", i, errObject.getErrorString(i));
            }
            file.clearAllErrors();
            Console.WriteLine("Cleared all errors - should have no errors left: {0}", file.getLastErrorString());
        }
    }
}

/*
Running the program as

config_masses.exe c:\inetpub\mascot\config\masses

Will give the following output:

Name of the file: c:\inetpub\mascot\config\masses
-------------------------------------------------------------
---   Content of masses file                              ---
-------------------------------------------------------------
Amino acid masses (monoisotopic and average)
A:71.03711,71.07790
B:114.53494,114.59500
C:103.00919,103.14290
D:115.02694,115.08740
E:129.04259,129.11400
F:147.06841,147.17390
G:57.02146,57.05130
H:137.05891,137.13930
I:113.08406,113.15760
J:113.08406,113.15760
K:128.09496,128.17230
L:113.08406,113.15760
M:131.04049,131.19610
N:114.04293,114.10260
O:237.14773,237.29820
P:97.05276,97.11520
Q:128.05858,128.12920
R:156.10111,156.18570
S:87.03203,87.07730
T:101.04768,101.10390
U:150.95363,150.03790
V:99.06841,99.13110
W:186.07931,186.20990
X:111.00000,111.00000
Y:163.06333,163.17330
Z:128.55059,128.62160

# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00794
CARBON:12.00000,12.01070
NITROGEN:14.00307,14.00670
OXYGEN:15.99491,15.99940
ELECTRON:0.00055
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_masses.java

Read in the masses file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi  #
#     Author: yuryr  #
#       Date: 2006/02/06 17:53:44  #
#   Revision: 1.1  #
# NoKeywords::                                                             #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_masses {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        if (argv.length < 1)
        {
            System.out.println("The location of masses file has to be specified as a parameter");
            System.out.println("The location should either be the full path to the masses file");
            System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
            System.exit(0);
        }

        // A sessionID can optionally be passed as the second parameter
        // This will only be required if the 'file' is a URL
        ms_masses file;
        if (argv.length > 1)
        {
            ms_connection_settings cs = new ms_connection_settings();
            cs.setSessionID(argv[1]);
            file = new ms_masses(argv[0], cs);
        }
        else
        {
            file = new ms_masses(argv[0]);
        }

        // unlike the other configuration files, it is possible to use ms_masses
        // without specifying the filename - in which case it defaults to '../config/masses'\n";

        if (!file.isValid())
        {

            System.out.println("Error when reading file: " + file.getFileName());
            checkErrorHandler(file);
            System.exit(0);
        }

        System.out.println("Name of the file: " + file.getFileName());
        System.out.println("-------------------------------------------------------------");
        System.out.println("---   Content of masses file                              ---");
        System.out.println("-------------------------------------------------------------");
        System.out.println("Amino acid masses (monoisotopic and average)");

        // we need this object for outputting floating point numbers
        String doubleFormat = "#####.#####";
        java.text.DecimalFormat formatted = new java.text.DecimalFormat(doubleFormat);

        char res;
        for(res='A'; res <= 'Z'; res++)
        {
            System.out.print(res + ":");
            System.out.print(formatted.format(file.getResidueMass(msparser.MASS_TYPE_MONO, res)));
            System.out.print("," + formatted.format(file.getResidueMass(msparser.MASS_TYPE_AVE, res)));
            System.out.println();
        }

        System.out.println();
        System.out.println("# Atomic masses used for terminus values");

        System.out.println("HYDROGEN:"
            + formatted.format(file.getHydrogenMass(msparser.MASS_TYPE_MONO))
            + ","
            + formatted.format(file.getHydrogenMass(msparser.MASS_TYPE_AVE)));

        System.out.println("CARBON:"
            + formatted.format(file.getCarbonMass(msparser.MASS_TYPE_MONO))
        + ","
        + formatted.format(file.getCarbonMass(msparser.MASS_TYPE_AVE)));

        System.out.println("NITROGEN:"
            + formatted.format(file.getNitrogenMass(msparser.MASS_TYPE_MONO))
        + ","
        + formatted.format(file.getNitrogenMass(msparser.MASS_TYPE_AVE)));

        System.out.println("OXYGEN:"
            + formatted.format(file.getOxygenMass(msparser.MASS_TYPE_MONO))
        + ","
        + formatted.format(file.getOxygenMass(msparser.MASS_TYPE_AVE)));

        System.out.println("ELECTRON:"
            + formatted.format(file.getElectronMass()));

    }

    static void checkErrorHandler(ms_masses file)
    {
        System.out.println("Testing the error handling...            ");
        System.out.println("=========================================");
        System.out.println("Error string: " + file.getLastErrorString());
        ms_errs errObject = file.getErrorHandler();
        int numErrors = errObject.getNumberOfErrors();
        System.out.println("Number of errors: " + numErrors);
        int i;
        for(i=1; i <= numErrors; i++)
        {
            System.out.println("Error number " + i + ": " + errObject.getErrorString(i));
        }

        file.clearAllErrors();
        System.out.println("Cleared all errors - should have no errors left: " + file.getLastErrorString());
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_masses masses

Name of the file: ../config/masses
-------------------------------------------------------------
---   Content of masses file                              ---
-------------------------------------------------------------
Amino acid masses (monoisotopic and average)
A:71.03711,71.03711
B:114.53493,114.53493
C:103.00919,103.00919
D:115.02694,115.02694
E:129.04259,129.04259
F:147.06841,147.06841
G:57.02146,57.02146
H:137.05891,137.05891
I:113.08406,113.08406
J:0.00000,0.00000
K:128.09496,128.09496
L:113.08406,113.08406
M:131.04049,131.04049
N:114.04293,114.04293
O:0.00000,0.00000
P:97.05276,97.05276
Q:128.05858,128.05858
R:156.10111,156.10111
S:87.03203,87.03203
T:101.04768,101.04768
U:150.95364,150.95364
V:99.06841,99.06841
W:186.07931,186.07931
X:111.00000,111.00000
Y:163.06333,163.06333
Z:128.55059,128.55059

# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00783
CARBON:12.00000,12.00000
NITROGEN:14.00307,14.00307
OXYGEN:15.99491,15.99491
ELECTRON:0.0005490

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:15


config_masses.pl

Read in the masses file.

#!/usr/local/bin/perl
##############################################################################
# file: config_masses.pl                                                     #
# This file illustrates how to use ms_masses-class from the Mascot perl      #
# module 'msparser'                                                          #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_masses.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
The location of masses file has to be specified as a parameter.
The location should either be the full path to the masses file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[1]);
    $file = new msparser::ms_masses($ARGV[0], $cs);
} else {
    $file = new msparser::ms_masses($ARGV[0]);
}

# Unlike the other configuration files, it is possible to use ms_masses
# without specifying the filename - in which case it defaults to
# '../config/masses'.

if (!$file->isValid) {
    print "Error when reading file: ", $file->getFileName(), "\n";
    checkErrorHandler($file);
    exit(1);
}

print "Name of the file: ", $file->getFileName(), "\n";
print "-------------------------------------------------------------\n";
print "---   Content of masses file                              ---\n";
print "-------------------------------------------------------------\n";
print "# Amino acid masses (monoisotopic and average)\n";

for my $i (0 .. 25) {
    my $res = chr(ord('A') + $i);
    printf(
        "%1s:%5.5f,%5.5f\n",
        $res,
        $file->getResidueMass($msparser::MASS_TYPE_MONO, $res),
        $file->getResidueMass($msparser::MASS_TYPE_AVE, $res)
   );
}

print "\n";
print "# Atomic masses used for terminus values\n";

printf(
    "HYDROGEN:%5.5f,%5.5f\n",
    $file->getHydrogenMass($msparser::MASS_TYPE_MONO),
    $file->getHydrogenMass($msparser::MASS_TYPE_AVE)
);

printf(
    "CARBON:%5.5f,%5.5f\n",
    $file->getCarbonMass($msparser::MASS_TYPE_MONO),
    $file->getCarbonMass($msparser::MASS_TYPE_AVE)
);

printf(
    "NITROGEN:%5.5f,%5.5f\n",
    $file->getNitrogenMass($msparser::MASS_TYPE_MONO),
    $file->getNitrogenMass($msparser::MASS_TYPE_AVE)
);

printf(
    "OXYGEN:%5.5f,%5.5f\n",
    $file->getOxygenMass($msparser::MASS_TYPE_MONO),
    $file->getOxygenMass($msparser::MASS_TYPE_AVE)
);

printf(
    "ELECTRON:%5.7f\n",
    $file->getElectronMass()
);

sub checkErrorHandler {
    my ($obj) = @_;

    print "Last error description                   \n";
    print "=========================================\n";
    print "Error: ", $obj->getLastErrorString(), "\n";
    print "=========================================\n";
    print "Testing the error handling...            \n";
    print "=========================================\n";

    my $err = $obj->getErrorHandler();
    my $i;

    for my $i (1 .. $err->getNumberOfErrors) {
        print "Error number: ";
        print $err->getErrorNumber($i);
        print " (";
        print $err->getErrorRepeats($i) + 1;
        print " times) : ";
        print $err->getErrorString($i), "\n";
    }

    print "\n";

    $obj->clearAllErrors();
}

=pod

Running the program as

perl -I../bin config_masses.pl ../config/masses

will give the following output under Mascot Server 2.3:

Name of the file: ../config/masses
-------------------------------------------------------------
---   Content of masses file                              ---
-------------------------------------------------------------
# Amino acid masses (monoisotopic and average)
A:71.03711,71.07790
B:114.53494,114.59500
C:103.00919,103.14290
D:115.02694,115.08740
E:129.04259,129.11400
F:147.06841,147.17390
G:57.02146,57.05130
H:137.05891,137.13930
I:113.08406,113.15760
J:0.00000,0.00000
K:128.09496,128.17230
L:113.08406,113.15760
M:131.04048,131.19610
N:114.04293,114.10260
O:0.00000,0.00000
P:97.05276,97.11520
Q:128.05858,128.12920
R:156.10111,156.18570
S:87.03203,87.07730
T:101.04768,101.10390
U:150.95363,150.03790
V:99.06841,99.13110
W:186.07931,186.20990
X:111.00000,111.00000
Y:163.06333,163.17330
Z:128.55059,128.62160

# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00794
CARBON:12.00000,12.01070
NITROGEN:14.00307,14.00670
OXYGEN:15.99491,15.99940
ELECTRON:0.0005490

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_masses.py

Read in the masses file.

#!/usr/bin/python
##############################################################################
# file: config_masses.pl                                                     #
# This file illustrates how to use ms_masses-class from the Mascot perl      #
# module 'msparser'                                                          #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_masses.py $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
The location of masses file has to be specified as a parameter.
The location should either be the full path to the masses file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")
    sys.exit(1)

def checkErrorHandler(obj) :
    print("Last error description                   ")
    print("=========================================")
    print("Error: %s" % obj.getLastErrorString())
    print("=========================================")
    print("Testing the error handling...            ")
    print("=========================================")

    err = obj.getErrorHandler()

    for i in range(1, 1 + err.getNumberOfErrors()) :
        print("Error number: %d (%d times): %s" % (
            err.getErrorNumber(i),
            err.getErrorRepeats(i) + 1,
            err.getErrorString(i)
            ))

    print(" ")

    obj.clearAllErrors()

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 2 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[2])
    file = msparser.ms_masses(sys.argv[1], cs)
else :
    file = msparser.ms_masses(sys.argv[1])

# Unlike the other configuration files, it is possible to use ms_masses
# without specifying the filename - in which case it defaults to
# '../config/masses'.

if not file.isValid() :
    print("Error when reading file: %s" % file.getFileName())
    checkErrorHandler(file)
    sys.exit(1)

print("Name of the file: %s" % file.getFileName())
print("-------------------------------------------------------------")
print("---   Content of masses file                              ---")
print("-------------------------------------------------------------")
print("# Amino acid masses (monoisotopic and average)")

for i in range(0, 26) :
    res = chr(ord('A') + i)
    print("%1s:%5.5f,%5.5f" % (
        res,
        file.getResidueMass(msparser.MASS_TYPE_MONO, res),
        file.getResidueMass(msparser.MASS_TYPE_AVE, res)
        ))

print (" ")
print("# Atomic masses used for terminus values")

print("HYDROGEN:%5.5f,%5.5f" % (
    file.getHydrogenMass(msparser.MASS_TYPE_MONO),
    file.getHydrogenMass(msparser.MASS_TYPE_AVE)
    ))

print("CARBON:%5.5f,%5.5f" % (
    file.getCarbonMass(msparser.MASS_TYPE_MONO),
    file.getCarbonMass(msparser.MASS_TYPE_AVE)
    ))

print("NITROGEN:%5.5f,%5.5f" % (
    file.getNitrogenMass(msparser.MASS_TYPE_MONO),
    file.getNitrogenMass(msparser.MASS_TYPE_AVE)
    ))

print("OXYGEN:%5.5f,%5.5f" % (
    file.getOxygenMass(msparser.MASS_TYPE_MONO),
    file.getOxygenMass(msparser.MASS_TYPE_AVE)
    ))

print("ELECTRON:%5.7f" % (
    file.getElectronMass()
    ))

"""

Running the program as

python config_masses.pl /usr/local/mascot/config/masses

will give the following output under Mascot Server 2.3:

Name of the file: /usr/local/mascot/config/masses
-------------------------------------------------------------
---   Content of masses file                              ---
-------------------------------------------------------------
# Amino acid masses (monoisotopic and average)
A:71.03711,71.07790
B:114.53494,114.59500
C:103.00919,103.14290
D:115.02694,115.08740
E:129.04259,129.11400
F:147.06841,147.17390
G:57.02146,57.05130
H:137.05891,137.13930
I:113.08406,113.15760
J:0.00000,0.00000
K:128.09496,128.17230
L:113.08406,113.15760
M:131.04048,131.19610
N:114.04293,114.10260
O:0.00000,0.00000
P:97.05276,97.11520
Q:128.05858,128.12920
R:156.10111,156.18570
S:87.03203,87.07730
T:101.04768,101.10390
U:150.95363,150.03790
V:99.06841,99.13110
W:186.07931,186.20990
X:111.00000,111.00000
Y:163.06333,163.17330
Z:128.55059,128.62160

# Atomic masses used for terminus values
HYDROGEN:1.00783,1.00794
CARBON:12.00000,12.01070
NITROGEN:14.00307,14.00670
OXYGEN:15.99491,15.99940
ELECTRON:0.0005490

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_modfile.cpp

Read in the modifications file - modfile.

/*
##############################################################################
# file: config_modfile.cpp                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_modfile.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "The location of modifications file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the modifications file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the second parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 2)
    {
        cs.setSessionID(argv[2]);
    }

    // we need ms_masses class instance
    // in practice, it has to be also read from a disc file
    // but, for simplicity, we will use default masses
    ms_masses massesFile;

    ms_modfile file(argv[1], &massesFile, false, &cs);

    if ( !file.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    int n = file.getNumberOfModifications();
    std::cout << "There are " << n << " modifications configured:" << std::endl;

    // now get'em all!
    int i = 0;
    for(i=0; i < n; i++)
    {
        std::cout << file.getModificationByNumber(i)->getTitle() << std::endl;
    }

    // Now change Acetyl (K)
    ms_modification mod = *file.getModificationByName("Acetyl (K)");
    mod.setHidden(true);
    file.updateModificationByName("Acetyl (K)", mod);

    // And delete Methyl (R)
    file.deleteModificationByName("Methyl (R)");

    //Finally, save the file under a new name - but only if not http:
    if (strncmp("http:", argv[1], 5) != 0) {
        std::string filename = argv[1];
        filename +=  ".new";
        file.setFileName(filename.c_str());
        file.save_file();
    }
    std::cout << "There are now " << file.getNumberOfModifications() << " modifications configured:" << std::endl;

    return 0;
}

/*

will give the output, for instance:

# config_modfile ../config/mod_file

There are 12 modifications configured:
Acetyl (N-term)
Acetyl (K)
Acetyl/Methyl (K)
Propionyl/Methyl (K)
Methyl (R)
Dimethyl (R)
Succininyl (K)
Succininyl+Methyl (K)
Biotinylated (N-term)
Biotinylated (K)
Carbamidomethyl (C)
Carbamyl (N-term)

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_modfile.cs

Read in the modifications file - modfile.

/*
##############################################################################
# file: config_modfile.cs                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_modfile.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_modfile
    {

        public static void Main(string[] argv)
        {
            if (argv.Length < 1)
            {
                Console.WriteLine(@"The location of the mod_file has to be specified as a parameter
The location should either be the full path to the mod file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi.
A Mascot security sessionID can optionally be passed as a second
parameter");
                return;
            }

            // we need ms_masses class instance
            // in practive, it has to be also read from a disc file
            // but, for simplicity, we will use default masses
            ms_masses massesFile = new ms_masses();

            // A sessionID can optionally be passed as the second
            // parameter.  This will only be required if the 'file' is a URL
            ms_modfile file;
            if (argv.Length > 1)
            {
                ms_connection_settings cs = new ms_connection_settings();
                cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
                cs.setSessionID(argv[1]);
                file = new ms_modfile(argv[0], massesFile, false, cs);
            }
            else
            {
                file = new ms_modfile(argv[0], massesFile, false);
            }

            if (!file.isValid())
            {
                Console.WriteLine("There are errors. Cannot continue. The last error description:");
                Console.WriteLine(file.getLastErrorString());
                return;
            }

            int n = file.getNumberOfModifications();
            Console.WriteLine("There are {0} modifications configured:", n);

            // now get 'em all!
            for (int i = 0; i < n; i++)
            {
                Console.WriteLine(file.getModificationByNumber(i).getTitle());
            }

            // Now change Acetyl (K)
            ms_modification mod = file.getModificationByName("Acetyl (K)");
            mod.setHidden(true);
            file.updateModificationByName("Acetyl (K)", mod);

            // And delete Methyl
            file.deleteModificationByName("Methyl (R)");

            // Finally, save the file under a new name
            if (argv[0].ToLower().StartsWith("http"))
            {
                file.setFileName("copy_enzymes.new");
            }
            else
            {
                //create a new file locally
                file.setFileName(argv[0] + ".new");
            }
            file.save_file();

            Console.WriteLine("There are now " + file.getNumberOfModifications() + " modifications configured.");
        }

    }
}

/*
Running the program as:
config_modfile.exe c:\inetpub\mascot\config\mod_file
Will give the following output:

There are 1268 modifications configured:
2-dimethylsuccinyl (C)
2-monomethylsuccinyl (C)
2-nitrobenzyl (Y)
2-succinyl (C)
2HPG (R)
3-deoxyglucosone (R)
3-phosphoglyceryl (K)
3sulfo (N-term)
4-ONE (C)
4-ONE (H)
4-ONE (K)
4-ONE+Delta:H(-2)O(-1) (C)
4-ONE+Delta:H(-2)O(-1) (H)
4-ONE+Delta:H(-2)O(-1) (K)
4AcAllylGal (C)
a-type-ion (C-term)
AccQTag (K)
AccQTag (N-term)
Acetyl (C)
[...]
Xlink:B10621 (C)
Xlink:DMP (K)
Xlink:DMP (Protein N-term)
Xlink:DMP-de (K)
Xlink:DMP-de (Protein N-term)
Xlink:DMP-s (K)
Xlink:DMP-s (Protein N-term)
Xlink:DSS (K)
Xlink:DSS (Protein N-term)
Xlink:DST (K)
Xlink:DST (Protein N-term)
Xlink:DTSSP (K)
Xlink:DTSSP (Protein N-term)
Xlink:EGS (K)
Xlink:EGS (Protein N-term)
Xlink:EGScleaved (K)
Xlink:EGScleaved (Protein N-term)
Xlink:SMCC (C)
Xlink:SSD (K)
ZGB (K)
ZGB (N-term)
There are now 1267 modifications configured.
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_modfile.java

Read in the modifications file - modfile.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi  #
#     Author: yuryr  #
#       Date: 2006/02/06 17:53:44  #
#   Revision: 1.1  #
# NoKeywords::                                                             #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_modfile {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        if (argv.length < 1)
        {
            System.out.println("The location of mod_file has to be specified as a parameter");
            System.out.println("The location should either be the full path to the mod_file");
            System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
            System.exit(0);
        }

        // we need ms_masses class instance
        // in practice, it has to be also read from a disc file
        // but, for simplicity, we will use default masses
        ms_masses massesFile = new ms_masses();

        // A sessionID can optionally be passed as the second parameter
        // This will only be required if the 'file' is a URL
        ms_modfile file;
        if (argv.length > 1)
        {
            ms_connection_settings cs = new ms_connection_settings();
            cs.setSessionID(argv[1]);
            file = new ms_modfile(argv[0], massesFile, false, cs);
        }
        else
        {
            file = new ms_modfile(argv[0], massesFile, false);
        }

        if (!file.isValid())
        {
            System.out.println("There are errors. Cannot continue. The last error description:");
            System.out.println(file.getLastErrorString());
            System.exit(0);
        }

        int n = file.getNumberOfModifications();
        System.out.println("There are " + n + " modifications configured:");

        // now get'em all!
        for (int i=0; i < n; i++)
        {
            System.out.println(file.getModificationByNumber(i).getTitle());
        }

        // Now change Acetyl (K)
        ms_modification mod = file.getModificationByName("Acetyl (K)");
        mod.setHidden(true);
        file.updateModificationByName("Acetyl (K)", mod);

        // And delete Methyl (R)
        file.deleteModificationByName("Methyl (R)");

        // Finally, save the file under a new name
        file.setFileName(argv[0] + ".new");
        file.save_file();

        System.out.println("There are now " + file.getNumberOfModifications() + " modifications configured:");

    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_modfile mod_file

There are 12 modifications configured:
Acetyl (N-term)
Acetyl (K)
Acetyl/Methyl (K)
Propionyl/Methyl (K)
Methyl (R)
Dimethyl (R)
Succininyl (K)
Succininyl+Methyl (K)
Biotinylated (N-term)
Biotinylated (K)
Carbamidomethyl (C)
Carbamyl (N-term)
...
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_modfile.pl

Read in the modifications file - modfile.

#!/usr/local/bin/perl
##############################################################################
# file: config_modfile.pl                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_modfile.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
The location of mod_file has to be specified as a parameter.
The location should either be the full path to the mod_file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

# We need an ms_masses object. In practice, it has to be read from a file but
# for simplicity, we will use default masses.
my $massesFile = new msparser::ms_masses;

# Note: $cs and $massesFile must not be lexically scoped; you need to keep them
# in scope for as long as you use $file. See "Using the toolkit from Perl,
# Java and Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[1]);
    $file = new msparser::ms_modfile($ARGV[0], $massesFile, 0, $cs);
} else {
    $file = new msparser::ms_modfile($ARGV[0], $massesFile, 0);
}

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

my $n = $file->getNumberOfModifications();
print "There are ", $n, " modifications configured:\n";

for my $i (0 .. $n-1) {
    print $file->getModificationByNumber($i)->getTitle(), "\n";
}

# Now change Acetyl (K).
my $mod = $file->getModificationByName("Acetyl (K)");
$mod->setHidden(1);
$file->updateModificationByName("Acetyl (K)", $mod);

# And delete Methyl (R).
$file->deleteModificationByName("Methyl (R)");

# Finally, save the file under a new name.
$file->setFileName($ARGV[0] . ".new");
$file->save_file;

if (!$file->isValid) {
    print "Failed to save: ", $file->getLastErrorString, "\n";
} else {
    print $ARGV[0], ".new now has ", $file->getNumberOfModifications(), " modifications configured\n";
}

=pod

Running the program as

perl -I../bin config_modfile.pl ../config/mod_file

will give the following output under Mascot Server 2.3:

There are 886 modifications configured:
15dB-biotin (C)
2-succinyl (C)
2HPG (R)
3-deoxyglucosone (R)
3sulfo (N-term)
4-ONE (C)
4-ONE (H)
4-ONE (K)
4-ONE+Delta:H(-2)O(-1) (C)
4-ONE+Delta:H(-2)O(-1) (H)
4-ONE+Delta:H(-2)O(-1) (K)
4AcAllylGal (C)
a-type-ion (C-term)
AccQTag (K)
AccQTag (N-term)
Acetyl (C)
    [ ... ]
Xlink:B10621 (C)
Xlink:DMP (K)
Xlink:DMP (Protein N-term)
Xlink:DMP-s (K)
Xlink:DMP-s (Protein N-term)
Xlink:novobiocin (N-term)
Xlink:SSD (K)
ZGB (K)
ZGB (N-term)
../config/mod_file.new now has 885 modifications configured

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_modfile.py

Read in the modifications file - modfile.

#!/usr/bin/python
##############################################################################
# file: config_modfile.pl                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_modfile.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
The location of mod_file has to be specified as a parameter.
The location should either be the full path to the mod_file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")
    sys.exit(1)

# We need an ms_masses object. In practice, it has to be read from a file but
# for simplicity, we will use default masses.
massesFile = msparser.ms_masses()

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 2 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[2])
    file = msparser.ms_modfile(sys.argv[1], massesFile, 0, cs)
else :
    file = msparser.ms_modfile(sys.argv[1], massesFile, 0)

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

n = file.getNumberOfModifications()
print("There are %d modifications configured:" % n)

for i in range(n) :
    print(file.getModificationByNumber(i).getTitle())

# Now change Acetyl (K).
mod = file.getModificationByName("Acetyl (K)")
mod.setHidden(1)
file.updateModificationByName("Acetyl (K)", mod)

# And delete Methyl (R).
file.deleteModificationByName("Methyl (R)")

# Finally, save the file under a new name.
file.setFileName(sys.argv[1] + ".new")
file.save_file()

if not file.isValid() :
    print("Failed to save: %s" % file.getLastErrorString())
else :
    print("%s.new now has %d modifications configured" % (sys.argv[1], file.getNumberOfModifications()))

"""

Running the program as

python config_modfile.pl /usr/local/mascot/config/mod_file

will give the following output under Mascot Server 2.3:

There are 886 modifications configured:
15dB-biotin (C)
2-succinyl (C)
2HPG (R)
3-deoxyglucosone (R)
3sulfo (N-term)
4-ONE (C)
4-ONE (H)
4-ONE (K)
4-ONE+Delta:H(-2)O(-1) (C)
4-ONE+Delta:H(-2)O(-1) (H)
4-ONE+Delta:H(-2)O(-1) (K)
4AcAllylGal (C)
a-type-ion (C-term)
AccQTag (K)
AccQTag (N-term)
Acetyl (C)
    [...]
Xlink:B10621 (C)
Xlink:DMP (K)
Xlink:DMP (Protein N-term)
Xlink:DMP-s (K)
Xlink:DMP-s (Protein N-term)
Xlink:novobiocin (N-term)
Xlink:SSD (K)
ZGB (K)
ZGB (N-term)
/usr/local/mascot/config/mod_file.new now has 885 modifications configured

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_procs.cpp

Determine computer processor information.

/*
##############################################################################
# file: config_procs.cpp                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_procs.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{

    // Don't check for Linux hyperthreading, assume 4 cpu license
    ms_processors cpus(false, 1);

    if ( !cpus.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << cpus.getLastErrorString() << std::endl;
        return 1;
    }

    std::cout << "Number of CPUS available on the system: " << cpus.getNumOnSystem() << std::endl;

    return 0;
}

/*
will give the output, for instance:

# config_procs

Number of CPUS available on the system: 2

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_procs.cs

Determine computer processor information.

/*
##############################################################################
# file: config_modprocs.cs                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_procs.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_procs
    {
        public static void Main(string[] argv)
        {
            // Don't check for Linux hyperthreading
            ms_processors cpus = new ms_processors(false, 1);

            if (!cpus.isValid())
            {
                Console.WriteLine("There are errors.  Cannot continue.  The last error description:");
                Console.WriteLine(cpus.getLastErrorString());
                return;
            }
            Console.WriteLine("Number of CPUs available on the system: {0}", cpus.getNumOnSystem());

        }
    }
}

/*
Running the program as
config_procs.exe
On a dual core Microsoft Windows system with hyperthreading will give the following output:

Number of CPUs available on the system: 4
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_procs.java

Determine computer processor information.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi  #
#     Author: yuryr  #
#       Date: 2006/02/06 17:53:44  #
#   Revision: 1.1  #
# NoKeywords::                                                             #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_procs {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // Don't check for Linux hyperthreading
        ms_processors cpus = new ms_processors(false, 1);

        if (!cpus.isValid())
        {
            System.out.println("There are errors. Cannot continue. The last error description:");
            System.out.println(cpus.getLastErrorString());
            System.exit(0);
        }

        System.out.println("Number of CPUS available on the system: " + cpus.getNumOnSystem());
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_procs

Number of CPUS available on the system: 2

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_procs.pl

Determine computer processor information.

#!/usr/local/bin/perl
##############################################################################
# file: config_procs.pl                                                      #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_procs.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

# When running under Linux 2.4, don't set to 1 unless you are prepared to wait.
my $checkLinuxHT = 0;
my $numLicensed = 1;
my $cpus = new msparser::ms_processors($checkLinuxHT, $numLicensed);

if (!$cpus->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $cpus->getLastErrorString(), "\n";
    exit 1;
}

print "Number of CPUS available on the system: ", $cpus->getNumOnSystem(), "\n";

=pod

Running the program, for example with

perl -I../bin config_procs.pl

will give the following output (depending on the number of processors on your
system):

Number of CPUS available on the system: 4

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_procs.py

Determine computer processor information.

#!/usr/bin/python
##############################################################################
# file: config_procs.pl                                                      #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_procs.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords.                                                            $ #
##############################################################################

import msparser

# When running under Linux 2.4, don't set to 1 unless you are prepared to wait.
checkLinuxHT = 0
numLicensed = 1
cpus = msparser.ms_processors(checkLinuxHT, numLicensed)

if not cpus.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(cpus.getLastErrorString())
    sys.exit(1)

print("Number of CPUS available on the system: %d" % cpus.getNumOnSystem())

"""

Running the program, for example with

python config_procs.pl

will give the following output (depending on the number of processors on your
system):

Number of CPUS available on the system: 4

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_quantitation.cpp

Example program for reading and manipulating the quantitation.xml file.

/*
##############################################################################
# file: config_quantitation.cpp                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_quantitation.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 3 )
    {
        std::cout << "The location of quantitation.xml file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        std::cout << "The second parameter should specify schema file path, for instance C:\\quantitation_1.xsd" << std::endl;
        std::cout << "It should be either relative to the local quantitation.xml path or to the current folder" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the third parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 3)
    {
        cs.setSessionID(argv[3]);
    }
    ms_quant_configfile file(argv[1], argv[2], &cs);

    if (!file.isValid())
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    int n = file.getNumberOfMethods();
    std::cout << "There are " << n << " methods available:" << std::endl;

    // now get'em all!
    int i = 0;
    for(i=0; i < n; i++)
    {
        std::cout << file.getMethodByNumber(i)->getName() << std::endl;
    }

    // now try to retrieve typeinfo from the schema file
    ms_xml_schema schemaFile;
    schemaFile.setFileName(argv[2]);
    schemaFile.read_file();
    if (!schemaFile.isValid())
    {
        std::cout << "Errors while reading schema-file. The last error description:" << std::endl;
        std::cout << schemaFile.getLastErrorString() << std::endl;
        return 1;
    }

    // validate the original document
    std::string strValidationErrors = file.validateDocument();
    if ( !strValidationErrors.empty() )
    {
        printf("Initial document validation errors: %s\n", strValidationErrors.c_str());
    }

    // the document can be validated programmatically
    // but it is not schema-validation!!!
    for(i = 0; i < n; i++)
    {
        // Shallow validation: we check only presence of required attributes and elements
        const ms_quant_method *pMethod = file.getMethodByNumber(i);
        std::string strErrors = pMethod->validateShallow(&schemaFile); // pass the schema object as a parameter
        if ( !strErrors.empty() )
        {
            printf("Method %s\n", pMethod->getName().c_str());
            printf("Shallow validation errors: %s\n\n", strErrors.c_str());
        }

        // Deep validation: we check attributes and elements recursively applying basic constraints
        strErrors = pMethod->validateDeep(&schemaFile);
        if ( !strErrors.empty() )
        {
            printf("Method %s\n", pMethod->getName().c_str());
            printf("Deep validation errors: %s\n\n", strErrors.c_str());
        }
    }

    // create a new invalid document
    ms_quant_configfile configFileInvalid;

    // copy the first method from the original file (method "null")
    ms_quant_method myMethodInvalid(*file.getMethodByNumber(0));
    myMethodInvalid.setName(""); // invalid name with less than allowed string length

    // one way to validate an object
    // 1. shallow validation - only presence of attributes and elements is checked
    std::string strErr1 = myMethodInvalid.validateShallow(&schemaFile);
    printf("shallow validation of a method: %s\n", strErr1.c_str());

    // 2. deep validation - data types of attributes and elements are checked and a base type too
    std::string strErr2 = myMethodInvalid.validateDeep(&schemaFile);
    printf("deep validation of a method: %s\n", strErr2.c_str());

    // another way to validate an object - by using schema-object (not schema-document!!!)
    // the result is absolutely equivalent to the previous call
    std::string strErr3 = schemaFile.validateComplexObject(&myMethodInvalid, true); // "true" for deep validation
    printf("deep validation using schema-object: %s\n", strErr3.c_str());

    // one can validate an attribute separately
    // also methods validateSimpleInteger(), validateSimpleDouble() and validateSimpleBool() can be used
    std::string strErr4 = schemaFile.validateSimpleString(myMethodInvalid.getName().c_str(), // attribute value
                                                          myMethodInvalid.getNameSchemaType().c_str()); // attribute data type
    printf("attribute validation: %s\n", strErr4.c_str());

    // and finally, the whole document validation
    configFileInvalid.appendMethod(&myMethodInvalid);
    std::string errMethod = configFileInvalid.validateDocument();
    printf("document validation errors: %s\n", errMethod.c_str());

    // however, the config-file object itself stays valid
    if (!configFileInvalid.isValid())
    {
        std::cout << "Errors in config-file object. The last error description:" << std::endl;
        std::cout << configFileInvalid.getLastErrorString() << std::endl;
    }

    // file is going to be saved even if its invalid
    // but the errors will be stored in the config-file object and the object will become invalid
    configFileInvalid.setFileName("quantitation_temp.xml"); // give it another name
    configFileInvalid.save_file();
    if (!configFileInvalid.isValid())
    {
        std::cout << "Errors in config-file object. The last error description:" << std::endl;
        std::cout << configFileInvalid.getLastErrorString() << std::endl;
    }

    return 0;
}

/*

will give the output, for instance:

# config_quantitation ../config/quantitation.xml quantitation_1.xsd

There are 10 methods available:
None
iTRAQ
ICAT C+9
ICPL C+6 pre-digest
ICPL C+6 post-digest
SILAC K+6 R+10
18O corrected, single scan
18O simple, single scan
SILAC K+6 R+4 multiplex
15N Metabolic
shallow validation of a method:
deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
attribute validation: String is shorter than minLength-limit
document validation errors: XML library failure with error: quantitation.xml: line 4, col 240 - Datatype error: Type:InvalidDatatypeValueException, Message:Value '' with length '0' is less than minimum length facet of '1' .
Errors in config-file object. The last error description:
Failed to save quantitation configuration file

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_quantitation.cs

Example program for reading and manipulating the quantitation.xml file.

/*
##############################################################################
# file: config_quantitation.cs                                               #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_quantitation.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_quantitation
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 2)
            {
                Console.WriteLine("You must specify quantitation.xml location as the first parameter and the schema path as the second.");
                return;
            }

            ms_quant_configfile file = new ms_quant_configfile(argv[0], argv[1]);
            if (!file.isValid())
            {
                Console.WriteLine("Error number: {0}", file.getLastError());
                Console.WriteLine("Error string: {0}", file.getLastErrorString());
                return;
            }

            Console.WriteLine("There are {0} methods available", file.getNumberOfMethods());
            for (int i = 0; i < file.getNumberOfMethods(); i++)
            {
                Console.WriteLine(file.getMethodByNumber(i).getName());
            }

            // now try to retrieve typeinfo from the schema file
            ms_xml_schema schemaFile = new ms_xml_schema();
            schemaFile.setFileName(argv[1]);
            schemaFile.read_file();
            if (!schemaFile.isValid())
            {
                Console.WriteLine("Error while reading schema-file.  The last error description:");
                Console.WriteLine("Error string: {0}", schemaFile.getLastErrorString());
                return;
            }

            // validate the original document
            string strValidationErrors = file.validateDocument();
            if (strValidationErrors != null && strValidationErrors.Length > 0)
            {
                Console.WriteLine("Initial document validation errors: {0}", strValidationErrors);
            }

            // the document can be validated programmatically
            // but it is not schema-validation
            for (int i = 0; i < file.getNumberOfMethods(); i++)
            {
                // Shallow validation: we check on presence of required attributes and elements
                ms_quant_method pMethod = file.getMethodByNumber(i);
                String strErrors = pMethod.validateShallow(schemaFile);  // pass the schema object as a parameter
                if (strErrors != null && strErrors.Length > 0)
                {
                    Console.WriteLine("Method {0}", pMethod.getName());
                    Console.WriteLine("Shallow validation errors: {0}", strErrors);
                    Console.WriteLine();
                }

                // Deep validation: we check attributes and elements recursively applying basic constrains
                strErrors = pMethod.validateDeep(schemaFile);
                if (strErrors != null && strErrors.Length > 0)
                {
                    Console.WriteLine("Method {0}", pMethod.getName());
                    Console.WriteLine("Deep validation errors: {0}", strErrors);
                    Console.WriteLine();
                }

            }

            // create a new invalid document
            ms_quant_configfile configFileInvalid = new ms_quant_configfile();

            // copy the first method from original file
            ms_quant_method myMethodInvalid = new ms_quant_method(file.getMethodByNumber(0));
            myMethodInvalid.setName("");  // invalid name with less than allowed string length

            // one way to validate an object
            // 1. shallow validation - only presence of attributes and elements is checked
            string strErr1 = myMethodInvalid.validateShallow(schemaFile);
            Console.WriteLine("Shallow validation of a method: {0}", strErr1);

            // 2. deep validation  data type of attributes and elements are checked and a base type too
            string strErr2 = myMethodInvalid.validateDeep(schemaFile);
            Console.WriteLine("Deep validation of a method: {0}", strErr2);

            // another way to validate an object - by using schema-object (but not schema-document)
            // the result is absolutely equivalent to the previous call
            string strErr3 = schemaFile.validateComplexObject(myMethodInvalid, true);   // true for deep validation
            Console.WriteLine("Deep validation using schema-object: {0}", strErr3);

            // one can validate an attribute separately
            // also methods validateSimpleInteger(), validateSimpleDouble() and validateSimpleBool() can be used
            string strErr4 = schemaFile.validateSimpleString(myMethodInvalid.getName(), // attribute value,
                myMethodInvalid.getNameSchemaType()); // attribute data type
            Console.WriteLine("Attribute validation: {0}", strErr4);

            // and finally, the whole document validation
            configFileInvalid.appendMethod(myMethodInvalid);
            string errMethod = configFileInvalid.validateDocument();
            Console.WriteLine("Document validation errors: {0}", errMethod);

            // however, the config-file object itself stays valid
            if (!configFileInvalid.isValid())
            {
                Console.WriteLine("Errors in config-file object.  The last error description:");
                Console.WriteLine(configFileInvalid.getLastErrorString());
            }

            // file is going to be saved even if it is invalid
            // but the errors will be stored in the config-file object and the object will become invalid
            configFileInvalid.setFileName("quantitation_temp.xml"); // give it another name
            configFileInvalid.save_file();
            if (!configFileInvalid.isValid())
            {
                Console.WriteLine("Errors in config-file object.  The last error description:");
                Console.WriteLine(configFileInvalid.getLastErrorString());
            }
        }
    }
}

/*
config_quantitation.exe c:\inetpub\mascot\config\quantitation.xml c:\inetpub\mascot\html\xmlns\schema\quantitation_2\quantitation_2.xsd
Will give the output (depending on your configuration):

There are 32 methods available
None
iTRAQ 4plex
iTRAQ 4plex (protein)
iTRAQ 8plex
TMT 6plex
TMT 2plex
TMT 10plex
DiLeu 4plex
18O multiplex
SILAC K+6 R+6 multiplex
IPTL (Succinyl and IMID) multiplex
ICPL duplex pre-digest [MD]
ICPL duplex post-digest [MD]
ICPL triplex pre-digest [MD]
ICPL quadruplex pre-digest [MD]
18O corrected [MD]
15N Metabolic [MD]
15N + 13C Metabolic [MD]
SILAC K+6 R+10 [MD]
SILAC K+6 R+10 Arg-Pro [MD]
SILAC K+6 R+6 [MD]
SILAC R+6 R+10 [MD]
SILAC K+8 R+10 [MD]
SILAC K+4 K+8 R+6 R+10 [MD]
ICAT ABI Cleavable [MD]
ICAT D8 [MD]
Dimethylation [MD]
NBS Shimadzu [MD]
Acetylation [MD]
Label-free [MD]
Average [MD]
iTRAQ 8plex PXD001253
Shallow validation of a method:
Deep validation of a method: Attribute 'name' -> String is shorter than minLengt
h-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than
minLength-limit
Attribute validation: String is shorter than minLength-limit
Document validation errors:
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_quantitation.java

Example program for reading and manipulating the quantitation.xml file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_quantitation {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 2) {
            System.out.println("Must specify results quantitation.xml location as the first parameter and schema path as the second.");
            System.exit(0);
        }

        ms_quant_configfile file = new ms_quant_configfile(argv[0], argv[1]);
        if ( !file.isValid() )
        {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }

        System.out.print("There are " + file.getNumberOfMethods());
        System.out.println(" methods available");
        for (int i=0; i < file.getNumberOfMethods(); i++)
        {
            System.out.println(file.getMethodByNumber(i).getName());
        }

        // now try to retrieve typeinfo from the schema file
        ms_xml_schema schemaFile = new ms_xml_schema();
        schemaFile.setFileName(argv[1]);
        schemaFile.read_file();
        if ( !schemaFile.isValid() )
        {
            System.out.println("Errors while reading schema-file. The last error description:");
            System.out.println("Error string: " + schemaFile.getLastErrorString());
            System.exit(0);
        }

        // validate the original document
        String strValidationErrors = file.validateDocument();
        if ( (strValidationErrors != null) && (strValidationErrors.length() > 0) )
        {
            System.out.println("Initial document validation errors: " + strValidationErrors);
        }

        // the document can be validated programmatically
        // but it is not schema-validation!!!
        for(int i = 0; i < file.getNumberOfMethods(); i++)
        {
            // Shallow validation: we check only presence of required attributes and elements
            ms_quant_method pMethod = file.getMethodByNumber(i);
            String strErrors = pMethod.validateShallow(schemaFile); // pass the schema object as a parameter
            if ( (strErrors != null) && (strErrors.length() > 0) )
            {
                System.out.println("Method " + pMethod.getName());
                System.out.println("Shallow validation errors: " + strErrors);
                System.out.println();
            }

            // Deep validation: we check attributes and elements recursively applying basic constraints
            strErrors = pMethod.validateDeep(schemaFile);
            if ( (strErrors != null) && (strErrors.length() > 0) )
            {
                System.out.println("Method " + pMethod.getName());
                System.out.println("Deep validation errors: " + strErrors);
                System.out.println();
            }
        }

        // create a new invalid document
        ms_quant_configfile configFileInvalid = new ms_quant_configfile();

        // copy the first method from the original file (method "null")
        ms_quant_method myMethodInvalid = new ms_quant_method(file.getMethodByNumber(0));
        myMethodInvalid.setName(""); // invalid name with less than allowed string length

        // one way to validate an object
        // 1. shallow validation - only presence of attributes and elements is checked
        String strErr1 = myMethodInvalid.validateShallow(schemaFile);
        System.out.println("Shallow validation of a method: " + strErr1);

        // 2. deep validation - data types of attributes and elements are checked and a base type too
        String strErr2 = myMethodInvalid.validateDeep(schemaFile);
        System.out.println("Deep validation of a method: " + strErr2);

        // another way to validate an object - by using schema-object (not schema-document!!!)
        // the result is absolutely equivalent to the previous call
        String strErr3 = schemaFile.validateComplexObject(myMethodInvalid, true); // "true" for deep validation
        System.out.println("Deep validation using schema-object: " + strErr3);

        // one can validate an attribute separately
        // also methods validateSimpleInteger(), validateSimpleDouble() and validateSimpleBool() can be used
        String strErr4 = schemaFile.validateSimpleString(myMethodInvalid.getName(), // attribute value
            myMethodInvalid.getNameSchemaType()); // attribute data type

        System.out.println("Attribute validation: " + strErr4);

        // and finally, the whole document validation
        configFileInvalid.appendMethod(myMethodInvalid);
        String errMethod = configFileInvalid.validateDocument();
        System.out.println("Document validation errors: " + errMethod);

        // however, the config-file object itself stays valid
        if ( !configFileInvalid.isValid() )
        {
            System.out.println("Errors in config-file object. The last error description:");
            System.out.println(configFileInvalid.getLastErrorString());
        }

        // file is going to be saved even if its invalid
        // but the errors will be stored in the config-file object and the object will become invalid
        configFileInvalid.setFileName("quantitation_temp.xml"); // give it another name
        configFileInvalid.save_file();
        if ( !configFileInvalid.isValid() )
        {
            System.out.println("Errors in config-file object. The last error description:");
            System.out.println(configFileInvalid.getLastErrorString());
        }
    }

}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_quantitation quantitation.xml quantitation_1.xsd
There are 10 methods available
None
iTRAQ
ICAT C+9
ICPL C+6 pre-digest
ICPL C+6 post-digest
SILAC K+6 R+10
18O corrected, single scan
18O simple, single scan
SILAC K+6 R+4 multiplex
15N Metabolic
Shallow validation of a method:
Deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
Attribute validation: String is shorter than minLength-limit
Document validation errors: XML library failure with error: quantitation.xml: line 4, col 240 - Datatype error: Type:InvalidDatatypeValueException, Message:Value '' with length '0' is less than minimum length facet of '1' .
Errors in config-file object. The last error description:
Failed to save quantitation configuration file

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_quantitation.pl

Example program for reading and manipulating the quantitation.xml file.

#!/usr/local/bin/perl
##############################################################################
# file: config_quantitation.pl                                               #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_quantitation.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
The location of quantitation.xml file has to be specified as a parameter.
The location should either be the full path to the quantitation.xml file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

if (!defined($ARGV[1])) {
    print <<EOF;
The location of schema file quantitation_XXX.xsd has to be specified as the
second parameter. The location should only be a full or relative path to the
quantitation_XXX.xsd file.
EOF
    exit 1;
}

# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the third parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[2])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[2]);
    $file = new msparser::ms_quant_configfile($ARGV[0], $ARGV[1], $cs);
} else {
    $file = new msparser::ms_quant_configfile($ARGV[0], $ARGV[1]);
}

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

my $n = $file->getNumberOfMethods;
print "There are ", $n, " quantitation methods available:\n";

for my $i (0 .. $n-1) {
    print $file->getMethodByNumber($i)->getName(), "\n";
}

# Validate the original document.
if (my $errs = $file->validateDocument())
{
    print "Initial document validation errors:\n";
    print $errs, "\n";
}

# Now try to read in the schema file.
my $schemaFile = new msparser::ms_xml_schema;
$schemaFile->setFileName($ARGV[1]);
$schemaFile->read_file;

if (!$schemaFile->isValid) {
    print "Errors while reading schema-file. The last error description:\n";
    print $schemaFile->getLastErrorString(), "\n";
    exit 1;
}

# The document can be validated programmatically, but this is different from
# real validation against a schema. We'll validate each quantitation
# method separately.
for my $i (0 .. $n-1) {
    # Shallow validation: only check the presence of required attributes and
    # elements.
    my $pMethod = $file->getMethodByNumber($i);

    if (my $errs = $pMethod->validateShallow($schemaFile)) {
        print "Shallow validation errors (method ", $pMethod->getName, "): ";
        print $errs, "\n\n";
    }

    # Deep validation: check attributes and elements recursively applying basic
    # constraints.
    if (my $errs = $pMethod->validateDeep($schemaFile)) {
        print "Deep validation errors (method ", $pMethod->getName, "): ";
        print $errs, "\n\n";
    }
}

# We can validate objects as well. First, copy the first method from the
# original file (method "null").
my $myMethodInvalid = new msparser::ms_quant_method($file->getMethodByNumber(0));
# And set an invalid name with less than allowed string length.
$myMethodInvalid->setName("");

# First way: use shallow and deep validation as above.
if (my $errs = $myMethodInvalid->validateShallow($schemaFile)) {
    print "Shallow validation of a method: ", $errs, "\n";
}

if (my $errs = $myMethodInvalid->validateDeep($schemaFile)) {
    print "Deep validation of a method: ", $errs, "\n";
}

# Second way: use the schema object. This is equivalent to the previous
# two-step process as long as you pass 'true' as the second parameter
# for deep validation.

if (my $errs = $schemaFile->validateComplexObject($myMethodInvalid, 1)) {
    print "Deep validation using schema-object: ", $errs, "\n";
}

# Third way: validate an attribute separately. Available validation methods
# are validateSimpleInteger(), validateSimpleDouble(), validateSimpleBool()
# and validateSimpleString().
if (my $errs = $schemaFile->validateSimpleString($myMethodInvalid->getName(), $myMethodInvalid->getNameSchemaType())) {
    print "Attribute validation: ", $errs, "\n";
}

# Fourth way: validate an entire document. For this, we need to create
# a new document and append the invalid method definition.
my $configFileInvalid = new msparser::ms_quant_configfile;
$configFileInvalid->appendMethod($myMethodInvalid);

if (my $errs = $configFileInvalid->validateDocument()) {
    print "Document validation errors: ", $errs, "\n";
}

# The config file object itself stays valid, even if it has an invalid
# method definition.
if ( !$configFileInvalid->isValid() ) {
    # Control flow never comes here!
    print "Errors in config file object. The last error description:\n";
    print $configFileInvalid->getLastErrorString(), "\n";
}

# The file can be saved even if it has invalid definitions.
$configFileInvalid->setFileName("quantitation_temp.xml");
$configFileInvalid->save_file();

if ( !$configFileInvalid->isValid() ) {
    print "Failed to save: ", $configFileInvalid->getLastErrorString(), "\n";
}

=pod

Running the program as

perl -I../bin config_quantitation.pl ../config/quantitation.xml ../html/xmlns/schema/quantitation_2/quantitation_2.xsd

will give the following output under Mascot Server 2.3 (depending on how
quantitation methods have been configured):

There are 26 quantitation methods available:
None
iTRAQ 4plex
iTRAQ 8plex
TMT 6plex
TMT 2plex
18O multiplex
SILAC K+6 R+6 multiplex
IPTL (Succinyl and IMID) multiplex
ICPL duplex pre-digest [MD]
ICPL duplex post-digest [MD]
ICPL triplex pre-digest [MD]
18O corrected [MD]
15N Metabolic [MD]
15N + 13C Metabolic [MD]
SILAC K+6 R+10 [MD]
SILAC K+6 R+10 Arg-Pro [MD]
SILAC K+6 R+6 [MD]
SILAC R+6 R+10 [MD]
SILAC K+8 R+10 [MD]
SILAC K+4 K+8 R+6 R+10 [MD]
ICAT ABI Cleavable [MD]
ICAT D8 [MD]
Dimethylation [MD]
NBS Shimadzu [MD]
Label-free [MD]
Average [MD]
Deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
Attribute validation: String is shorter than minLength-limit

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_quantitation.py

Example program for reading and manipulating the quantitation.xml file.

#!/usr/bin/python
##############################################################################
# file: config_quantitation.py                                               #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_quantitation.py $  #
#     $Author: villek@matrixscience.com $                                                       #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
The location of quantitation.xml file has to be specified as a parameter.
The location should either be the full path to the quantitation.xml file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")
    sys.exit(1)

if len(sys.argv) < 3 :
    print("""
The location of schema file quantitation_XXX.xsd has to be specified as the
second parameter. The location should only be a full or relative path to the
quantitation_XXX.xsd file.
""")
    sys.exit(1)

# A sessionID can optionally be passed as the third parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 3 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[3])
    file = msparser.ms_quant_configfile(sys.argv[1], sys.argv[2], cs)
else :
    file = msparser.ms_quant_configfile(sys.argv[1], sys.argv[2])

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

n = file.getNumberOfMethods()
print("There are %d quantitation methods available:" % n)

for i in range(n) :
    print(file.getMethodByNumber(i).getName())

# Validate the original document.
errs = file.validateDocument()
if errs :
    print("Initial document validation errors: %s" % errs)

# Now try to read in the schema file.
schemaFile = msparser.ms_xml_schema()
schemaFile.setFileName(sys.argv[2])
schemaFile.read_file()

if not schemaFile.isValid() :
    print("Errors while reading schema-file. The last error description: %s" % schemaFile.getLastErrorString())
    sys.exit(1)

# The document can be validated programmatically, but this is different from
# real validation against a schema. We'll validate each quantitation
# method separately.
for i in range(n) :
    # Shallow validation: only check the presence of required attributes and
    # elements.
    pMethod = file.getMethodByNumber(i)

    errs = pMethod.validateShallow(schemaFile)
    if errs :
        print("Shallow validation errors (method %s): %s" % (pMethod.getName(), errs))

    # Deep validation: check attributes and elements recursively applying basic
    # constraints.
    errs = pMethod.validateDeep(schemaFile)
    if errs :
        print("Deep validation errors (method %s): %s" % (pMethod.getName(), errs))

# We can validate objects as well. First, copy the first method from the
# original file (method "null").
myMethodInvalid = msparser.ms_quant_method(file.getMethodByNumber(0))
# And set an invalid name with less than allowed string length.
myMethodInvalid.setName("")

# First way: use shallow and deep validation as above.
errs = myMethodInvalid.validateShallow(schemaFile)
if errs :
    print("Shallow validation of a method: %s" % errs)

errs = myMethodInvalid.validateDeep(schemaFile)
if errs :
    print("Deep validation of a method: %s" % errs)

# Second way: use the schema object. This is equivalent to the previous
# two-step process as long as you pass 'true' as the second parameter
# for deep validation.

errs = schemaFile.validateComplexObject(myMethodInvalid, 1)
if errs :
    print("Deep validation using schema-object: %s" % errs)

# Third way: validate an attribute separately. Available validation methods
# are validateSimpleInteger(), validateSimpleDouble(), validateSimpleBool()
# and validateSimpleString().
errs = schemaFile.validateSimpleString(myMethodInvalid.getName(), myMethodInvalid.getNameSchemaType())
if errs :
    print("Attribute validation: %s" % errs)

# Fourth way: validate an entire document. For this, we need to create
# a new document and append the invalid method definition.
configFileInvalid = msparser.ms_quant_configfile()
configFileInvalid.appendMethod(myMethodInvalid)

errs = configFileInvalid.validateDocument()
if errs :
    print("Document validation errors: %s" % errs)

# The config file object itself stays valid, even if it has an invalid
# method definition.
if not configFileInvalid.isValid() :
    # Control flow never comes here!
    print("Errors in config file object. The last error description: %s" % configFileInvalid.getLastErrorString())

# The file can be saved even if it has invalid definitions.
configFileInvalid.setFileName("quantitation_temp.xml")
configFileInvalid.save_file()

if not configFileInvalid.isValid() :
    print("Failed to save: %s" % configFileInvalid.getLastErrorString())

"""

Running the program as

python config_quantitation.pl /usr/local/mascot/config/quantitation.xml /usr/local/mascot/html/xmlns/schema/quantitation_2/quantitation_2.xsd

will give the following output under Mascot Server 2.3 (depending on how
quantitation methods have been configured):

There are 26 quantitation methods available:
None
iTRAQ 4plex
iTRAQ 8plex
TMT 6plex
TMT 2plex
18O multiplex
SILAC K+6 R+6 multiplex
IPTL (Succinyl and IMID) multiplex
ICPL duplex pre-digest [MD]
ICPL duplex post-digest [MD]
ICPL triplex pre-digest [MD]
18O corrected [MD]
15N Metabolic [MD]
15N + 13C Metabolic [MD]
SILAC K+6 R+10 [MD]
SILAC K+6 R+10 Arg-Pro [MD]
SILAC K+6 R+6 [MD]
SILAC R+6 R+10 [MD]
SILAC K+8 R+10 [MD]
SILAC K+4 K+8 R+6 R+10 [MD]
ICAT ABI Cleavable [MD]
ICAT D8 [MD]
Dimethylation [MD]
NBS Shimadzu [MD]
Label-free [MD]
Average [MD]
Deep validation of a method: Attribute 'name' -> String is shorter than minLength-limit
Deep validation using schema-object: Attribute 'name' -> String is shorter than minLength-limit
Attribute validation: String is shorter than minLength-limit

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_taxonomy.cpp

Read in the taxonomy file.

/*
##############################################################################
# file: config_taxonomy.cpp                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/config_taxonomy.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

int main(int argc, char * argv[])
{
    if ( argc < 2 )
    {
        std::cout << "The location of taxonomy file has to be specified as a parameter" << std::endl;
        std::cout << "The location should either be the full path to the taxonomy file" << std::endl;
        std::cout << "or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi" << std::endl;
        return 1;
    }

    // A sessionID can optionally be passed as the second parameter
    // This will only be required if the 'file' is a URL
    ms_connection_settings cs;
    if (argc > 2)
    {
        cs.setSessionID(argv[2]);
    }
    ms_taxonomyfile file(argv[1], &cs);

    if (!file.isValid())
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << file.getLastErrorString() << std::endl;
        return 1;
    }

    int n = file.getNumberOfEntries();
    std::cout << "There are " << n << " taxonomy choice entries configured:" << std::endl;

    // now get'em all!
    int i = 0;
    for(i=0; i < n; i++)
    {
        std::cout << file.getEntryByNumber(i)->getTitle() << std::endl;
        std::cout << "Include: ";
        int j;
        for(j=0; j < file.getEntryByNumber(i)->getNumberOfIncludeTaxonomies(); j++)
        {
            if ( j > 0 )
                std::cout << ",";
            std::cout << file.getEntryByNumber(i)->getIncludeTaxonomy(j);
        }
        std::cout << std::endl;
        std::cout << "Exclude: ";
        for(j=0; j < file.getEntryByNumber(i)->getNumberOfExcludeTaxonomies(); j++)
        {
            if ( j > 0 )
                std::cout << ",";
            std::cout << file.getEntryByNumber(i)->getExcludeTaxonomy(j);
        }
        std::cout << std::endl;
    }

    return 0;
}

/*

will give the output, for instance:

# config_taxonomy ../config/taxonomy

There are 64 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833

...

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_taxonomy.cs

Read in the taxonomy file.

/*
##############################################################################
# file: config_taxonomy.cs                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/config_taxonomy.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class config_taxonomy
    {
        public static void Main(string[] argv)
        {
            if (argv.Length < 1)
            {
                Console.WriteLine(@"The location of the taxonomy file has to be specified as a parameter
The location should either be the full path to the taxonomy file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi.
A Mascot security sessionID can optionally be passed as a second
parameter");
                return;
            }

            // A sessionID can optionally be passed as the second parameter
            // This will only be required if the 'file' is a URL
            ms_taxonomyfile file;
            if (argv.Length > 1)
            {
                ms_connection_settings cs = new ms_connection_settings();
                cs.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);
                cs.setSessionID(argv[1]);
                file = new ms_taxonomyfile(argv[0], cs);
            }
            else
            {
                file = new ms_taxonomyfile(argv[0]);
            }

            if (!file.isValid())
            {
                Console.WriteLine("There are errors. Cannot continue. The last error description:");
                Console.WriteLine(file.getLastErrorString());
                return;
            }

            int n = file.getNumberOfEntries();
            Console.WriteLine("There are {0} taxonomy choice entries configured:", n);

            // now get them all!
            for (int i = 0; i < n; i++)
            {
                Console.WriteLine(file.getEntryByNumber(i).getTitle());
                Console.Write("Include: ");
                for (int j = 0; j < file.getEntryByNumber(i).getNumberOfIncludeTaxonomies(); j++)
                {
                    if (j > 0) Console.Write(",");
                    Console.Write(file.getEntryByNumber(i).getIncludeTaxonomy(j));
                }
                Console.WriteLine();
                Console.Write("Exclude: ");
                for (int j = 0; j < file.getEntryByNumber(i).getNumberOfExcludeTaxonomies(); j++)
                {
                    if (j > 0) Console.Write(",");
                    Console.Write(file.getEntryByNumber(i).getExcludeTaxonomy(j));
                }
                Console.WriteLine();

            }
        }
    }
}

/*
config_taxonomy.exe c:\inetpub\mascot\config\taxonomy
Will give the following output:

There are 65 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833
[...]
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_taxonomy.java

Read in the taxonomy file.

/*
##############################################################################
# file: config_quantitation.java                                             #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi  #
#     Author: yuryr  #
#       Date: 2006/02/06 17:53:44  #
#   Revision: 1.1  #
# NoKeywords::                                                             #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class config_taxonomy
{
    static
    {
        try
        {
            System.loadLibrary("msparserj");
        }
        catch (UnsatisfiedLinkError e)
        {
            System.err.println("Native code library failed to load. "
                + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        if (argv.length < 1)
        {
            System.out.println("The location of taxonomy file has to be specified as a parameter");
            System.out.println("The location should either be the full path to the taxonomy file");
            System.out.println("or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi");
            System.exit(0);
        }

        // A sessionID can optionally be passed as the second parameter
        // This will only be required if the 'file' is a URL
        ms_taxonomyfile file;
        if (argv.length > 1)
        {
            ms_connection_settings cs = new ms_connection_settings();
            cs.setSessionID(argv[1]);
            file = new ms_taxonomyfile(argv[0], cs);
        }
        else
        {
            file = new ms_taxonomyfile(argv[0]);
        }

        if (!file.isValid())
        {
            System.out.println("There are errors. Cannot continue. The last error description:");
            System.out.println(file.getLastErrorString());;
            System.exit(0);
        }

        int n = file.getNumberOfEntries();
        System.out.println("There are " + n + " taxonomy choice entries configured:");

        // now get'em all!
        for (int i=0; i < n; i++)
        {
            System.out.println(file.getEntryByNumber(i).getTitle());
            System.out.print("Include: ");
            for (int j=0; j < file.getEntryByNumber(i).getNumberOfIncludeTaxonomies(); j++)
            {
                if (j > 0)
                {
                    System.out.print(",");
                }
                System.out.print(file.getEntryByNumber(i).getIncludeTaxonomy(j));
            }
            System.out.println();
            System.out.print("Exclude: ");
            for (int j=0; j < file.getEntryByNumber(i).getNumberOfExcludeTaxonomies(); j++)
            {
                if (j > 0)
                {
                    System.out.print(",");
                }
                System.out.print(file.getEntryByNumber(i).getExcludeTaxonomy(j));
            }
            System.out.println();

        }

    }
}
/*
will give the output:

C:>java -classpath .;../java/msparser.jar config_taxonomy taxonomy

There are 64 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833

...

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_taxonomy.pl

Read in the taxonomy file.

#!/usr/local/bin/perl
##############################################################################
# file: config_taxonomy.pl                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/config_taxonomy.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
    print <<EOF;
The location of taxonomy file has to be specified as a parameter.
The location should either be the full path to the taxonomy file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
EOF
    exit 1;
}

# Note: $cs must not be lexically scoped; you need to keep it in scope
# for as long as you use $file. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
my ($file, $cs);

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if (defined($ARGV[1])) {
    $cs = new msparser::ms_connection_settings;
    $cs->setSessionID($ARGV[1]);
    $file = new msparser::ms_taxonomyfile($ARGV[0], $cs);
} else {
    $file = new msparser::ms_taxonomyfile($ARGV[0]);
}

if (!$file->isValid) {
    print "There are errors. Cannot continue. The last error description:\n";
    print $file->getLastErrorString(), "\n";
    exit 1;
}

my $n = $file->getNumberOfEntries;
print "There are ", $n, " taxonomy choice entries configured:\n";

for my $i (0 .. $n-1) {
    my $entry = $file->getEntryByNumber($i);
    print $entry->getTitle() . "\n";

    print "Include: ";

    print join(', ',
        map { $entry->getIncludeTaxonomy($_) }
        0 .. $entry->getNumberOfIncludeTaxonomies - 1
    );

    print "\n";

    print "Exclude: ";

    print join(', ',
        map { $entry->getExcludeTaxonomy($_) }
        0 .. $entry->getNumberOfExcludeTaxonomies - 1
    );

    print "\n";
}

=pod

Running the program as

perl -I../bin config_taxonomy.pl ../config/taxonomy

will give the following output under Mascot Server 2.3:

There are 65 taxonomy choice entries configured:
All entries
Include: 1
Exclude: 0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
Include: 33630
Exclude: 5833
    [ ... ]

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


config_taxonomy.py

Read in the taxonomy file.

#!/usr/bin/python
##############################################################################
# file: config_taxonomy.py                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/config_taxonomy.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                        #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

if len(sys.argv) < 2 :
    print("""
The location of taxonomy file has to be specified as a parameter.
The location should either be the full path to the taxonomy file
or a URL to a Mascot server - e.g. http://mascot-server/mascot/cgi
""")
    sys.exit(1)

# A sessionID can optionally be passed as the second parameter.
# This will only be required if the 'file' is a URL.
if len(sys.argv) > 2 :
    cs = msparser.ms_connection_settings()
    cs.setSessionID(sys.argv[2])
    file = msparser.ms_taxonomyfile(sys.argv[1], cs)
else :
    file = msparser.ms_taxonomyfile(sys.argv[1])

if not file.isValid() :
    print("There are errors. Cannot continue. The last error description:")
    print(file.getLastErrorString())
    sys.exit(1)

n = file.getNumberOfEntries()
print("There are %d taxonomy choice entries configured:" % n)

for i in range(n) :
    entry = file.getEntryByNumber(i)
    print(entry.getTitle())

    tax = []
    for i in range(entry.getNumberOfIncludeTaxonomies()) :
        tax.append("%d" % entry.getIncludeTaxonomy(i))

    print("Include: " + ', '.join(tax))

    tax = []
    for i in range(entry.getNumberOfExcludeTaxonomies()) :
        tax.append("%d" % entry.getExcludeTaxonomy(i))

    print("Exclude: " + ', '.join(tax))

"""

Running the program as

python config_taxonomy.pl /usr/local/mascot/config/taxonomy

will give the following output under Mascot Server 2.3:

There are 65 taxonomy choice entries configured:
All entries
Include: 1
Exclude:  0
. . Archaea (Archaeobacteria)
Include: 2157
Exclude:
. . Eukaryota (eucaryotes)
Include: 2759
Exclude:
. . . . Alveolata (alveolates)
Include: 33630
Exclude:
. . . . . . Plasmodium falciparum (malaria parasite)
Include: 5833
Exclude:
. . . . . . Other Alveolata
    [ ... ]

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


create_mgf.cs

Create an mgf file from a Mascot results file.

/*
##############################################################################
# file: create_mgf.cs                                                        #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/create_mgf.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.IO;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class create_mgf
    {
        public static void Main(string[] argv)
        {
            if (argv.Length < 1)
            {
                usage();
                return;
            }
            createMGF(argv[0]);
        }

        private static void createMGF(string filename)
        {
            ms_mascotresfile resfile = new ms_mascotresfile(filename);
            if (!resfile.isValid())
            {
                Console.WriteLine("Cannot open results file {0}: {1}", filename, resfile.getLastErrorString());
                return;
            }

            string outputFilename = filename + ".mgf";
            // check if the mgf file already exists - do not overwrite if it does
            if (File.Exists(outputFilename))
            {
                Console.WriteLine("{0} already exists; will not overwrite", outputFilename);
                return;
            }

            // create the file

            using (TextWriter tw = new StreamWriter(outputFilename))
            {
                for (int q = 1; q <= resfile.getNumQueries(); q++)
                {
                    ms_inputquery inpQuery = new ms_inputquery(resfile, q);
                    if (inpQuery.getNumberOfPeaks(1) == 0)
                    {
                        // PMF - just the mass
                        tw.WriteLine(resfile.getObservedMass(q));
                        continue;
                    }

                    tw.WriteLine("BEGIN IONS");
                    tw.WriteLine("PEPMASS={0}", resfile.getObservedMass(q));

                    if (Math.Abs(resfile.getObservedCharge(q)) > 0)
                    {
                        tw.WriteLine("CHARGE={0}", resfile.getObservedCharge(q));
                    }
                    else
                    {
                        tw.WriteLine("CHARGE=Mr");
                    }

                    if (inpQuery.getStringTitle(true).Length > 0)
                    {
                        tw.WriteLine("TITLE={0}", inpQuery.getStringTitle(true));
                    }

                    for (int i = 1; i <= inpQuery.getNumberOfPeaks(1); i++)
                    {
                        tw.WriteLine("{0} {1}", inpQuery.getPeakMass(1, i), inpQuery.getPeakIntensity(1, i));
                    }

                    tw.WriteLine("END IONS");
                }
            }

        }

        private static void usage()
        {
            Console.WriteLine(@"Usage: create_mgf <results file>.

Given a mascot results file name, create an MGF file.  The MGF file
will be named <results file>.mgf in the same directory where <results file>
is located.");
        }
    }
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


create_mgf.pl

Create an mgf file from a Mascot results file.

#!/usr/local/bin/perl
##############################################################################
# file: create_mgf.pl                                                        #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/create_mgf.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) {
  usage();
  exit(1);
}

createMGF($ARGV[0]);

sub createMGF {
    my ($filename) = @_;

    my $resfile = new msparser::ms_mascotresfile($filename);

    if (!$resfile->isValid) {
        print STDERR "Cannot open results file ", $filename, ": ";
        print STDERR $resfile->getLastErrorString(), "\n";
        return;
    }

    my $output_filename = $filename.'.mgf';

    if (-e $output_filename) {
        print STDERR "$output_filename already exists; will not overwrite\n";
        return;
    }

    open(my $fh, '>', $output_filename)
        or die "Cannot open $output_filename for writing: $!";

    for my $q (1 .. $resfile->getNumQueries) {
        my $inp_query = new msparser::ms_inputquery($resfile, $q);

        if ($inp_query->getNumberOfPeaks(1) == 0) {
            # PMF - just the mass
            print $fh $resfile->getObservedMass($q), "\n";
            next;
        }

        print $fh "BEGIN_IONS\n";
        print $fh "PEPMASS=", $resfile->getObservedMass($q), "\n";

        if ($resfile->getObservedCharge($q) > 0) {
            print $fh "CHARGE=", $resfile->getObservedCharge($q), "+\n";
        } else {
            print $fh "CHARGE=Mr\n";
        }

        if ($inp_query->getStringTitle(1)) {
            print $fh "TITLE=", $inp_query->getStringTitle(1), "\n";
        }

        for my $i (1 .. $inp_query->getNumberOfPeaks(1)) {
            print $fh $inp_query->getPeakMass(1, $i), " ", $inp_query->getPeakIntensity(1, $i), "\n";
        }

        print $fh "END IONS\n\n";
    }
}

sub usage {
    print <<EOF;
Usage: create_mgf.pl <results file>

Given an mascot results file name, create an MGF file. The MGF file
will be named <results file>.mgf in the same directory where <results file>
is located.
EOF
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


create_mgf.py

Create an mgf file from a Mascot results file.

#!/usr/bin/python
##############################################################################
# file: create_mgf.py                                                        #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/create_mgf.py $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords:: $                                                          #
##############################################################################

import msparser
import sys
import os.path

def main() :
    if len(sys.argv) < 2 :
      usage()
      return 1

    createMGF(sys.argv[1])

def createMGF(filename) :
    resfile = msparser.ms_mascotresfile(filename)

    if not resfile.isValid() :
        print("Cannot open results file %s : %s" % (filename, resfile.getLastErrorString()))
        return

    output_filename = filename + '.mgf'

    if os.path.isfile(output_filename) :
        print("%s already exists; will not overwrite" % output_filename)
        return

    try :
        fh = open(output_filename, "w")

    except IOError as err:
        errno, strerror = err.args
        print("Cannot open output_filename for writing: I/O error(%d): %s" % (
                errno, strerror
                ))
        sys.exit(1)

    for q in range(1, 1 + resfile.getNumQueries()) :
        inp_query = msparser.ms_inputquery(resfile, q)

        if inp_query.getNumberOfPeaks(1) == 0 :
            # PMF - just the mass
            fh.write("%f\n" % resfile.getObservedMass(q))
            continue

        fh.write("BEGIN_IONS\n");
        fh.write("PEPMASS=%f\n" % resfile.getObservedMass(q))

        if resfile.getObservedCharge(q) > 0 :
            fh.write("CHARGE=%f+\n" % resfile.getObservedCharge(q))
        else :
            fh.write("CHARGE=Mr\n")

        if inp_query.getStringTitle(1) :
            fh.write("TITLE=%s\n" % inp_query.getStringTitle(1))

        for i in range(1, 1 + inp_query.getNumberOfPeaks(1)) :
            fh.write("%f %f\n" % (inp_query.getPeakMass(1, i), inp_query.getPeakIntensity(1, i)))

        fh.write("END IONS\n")

    fh.close()

def usage() :
    print("""
Usage: create_mgf.py <results file>

Given a mascot results file name, create an MGF file. The MGF file
will be named <results file>.mgf in the same directory where <results file>
is located.
""")

if __name__ == "__main__" :
    sys.exit(main())
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


Examples

Here is a list of all examples:
  • common_error.cpp
  • common_error.cs
  • common_error.pl
  • common_error.py
  • config_enzymes.cpp
  • config_enzymes.cs
  • config_enzymes.java
  • config_enzymes.pl
  • config_enzymes.py
  • config_fragrules.cpp
  • config_fragrules.cs
  • config_fragrules.java
  • config_fragrules.pl
  • config_fragrules.py
  • config_license.cpp
  • config_license.java
  • config_license.pl
  • config_license.py
  • config_mascotdat.cpp
  • config_mascotdat.cs
  • config_mascotdat.java
  • config_mascotdat.pl
  • config_mascotdat.py
  • config_masses.cpp
  • config_masses.cs
  • config_masses.java
  • config_masses.pl
  • config_masses.py
  • config_modfile.cpp
  • config_modfile.cs
  • config_modfile.java
  • config_modfile.pl
  • config_modfile.py
  • config_procs.cpp
  • config_procs.cs
  • config_procs.java
  • config_procs.pl
  • config_procs.py
  • config_quantitation.cpp
  • config_quantitation.cs
  • config_quantitation.java
  • config_quantitation.pl
  • config_quantitation.py
  • config_taxonomy.cpp
  • config_taxonomy.cs
  • config_taxonomy.java
  • config_taxonomy.pl
  • config_taxonomy.py
  • create_mgf.cs
  • create_mgf.pl
  • create_mgf.py
  • http_client.cs
  • http_client.pl
  • http_client.py
  • http_helper_getstring.cpp
  • http_helper_getstring.pl
  • http_helper_getstring.py
  • java_helper.pl
  • login.pl
  • msparser.pl
  • msparser_full.py
  • peptide_list.cpp
  • repeat_search.cpp
  • repeat_search.cs
  • repeat_search.java
  • repeat_search.pl
  • repeat_search.py
  • resfile_customquantitation.cs
  • resfile_customquantitation.java
  • resfile_customquantitation.pl
  • resfile_customquantitation.py
  • resfile_error.cpp
  • resfile_error.cs
  • resfile_error.java
  • resfile_error.pl
  • resfile_error.py
  • resfile_info.cpp
  • resfile_info.cs
  • resfile_info.java
  • resfile_info.pl
  • resfile_info.py
  • resfile_input.cpp
  • resfile_input.cs
  • resfile_input.java
  • resfile_input.pl
  • resfile_input.py
  • resfile_ms2quant_to_custom.cs
  • resfile_ms2quant_to_custom.pl
  • resfile_ms2quant_to_custom.py
  • resfile_ms2quantitation.cs
  • resfile_ms2quantitation.java
  • resfile_ms2quantitation.pl
  • resfile_ms2quantitation.py
  • resfile_params.cpp
  • resfile_params.cs
  • resfile_params.java
  • resfile_params.pl
  • resfile_params.py
  • resfile_summary.cpp
  • resfile_summary.cs
  • resfile_summary.java
  • resfile_summary.pl
  • resfile_summary.py
  • security_session.java
  • security_session.pl
  • tools_aahelper.cpp
  • tools_aahelper.cs
  • tools_aahelper.java
  • tools_aahelper.pl
  • tools_aahelper.py
  • tools_quant_helper.cs
  • tools_quant_helper.pl
  • tools_quant_helper.py
  • tools_shapiro_wilk.cs
  • tools_shapiro_wilk.pl
  • tools_shapiro_wilk.py
  • tools_stats.cs
  • tools_stats.pl
  • tools_stats.py
  • tools_tinycdb.cs
  • tools_tinycdb.pl
  • tools_tinycdb.py
  • tools_treecluster.cs
  • tools_treecluster.pl
  • tools_treecluster.py
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


File List

Here is a list of all documented files with brief descriptions:
ms_aahelper.hpp [code]
ms_body.hpp [code]
ms_cache_file.hpp [code]
ms_cache_stream.hpp [code]
ms_cdb_sharding.hpp [code]
ms_clusterparams.hpp [code]
ms_computeraddress.hpp [code]
ms_connection_settings.hpp [code]
ms_cronoptions.hpp [code]
ms_crosslinking_accession.hpp [code]
ms_crosslinking_accessions.hpp [code]
ms_crosslinking_configfile.hpp [code]
ms_crosslinking_does_not_pair_with.hpp [code]
ms_crosslinking_filters.hpp [code]
ms_crosslinking_linker.hpp [code]
ms_crosslinking_linkers.hpp [code]
ms_crosslinking_method.hpp [code]
ms_crosslinking_monolink.hpp [code]
ms_crosslinking_parameters.hpp [code]
ms_crosslinking_scope.hpp [code]
ms_crosslinking_settings.hpp [code]
ms_customproperty.hpp [code]
ms_customquantitation.hpp [code]
ms_databaseoptions.hpp [code]
ms_datfile.hpp [code]
ms_distiller_data.hpp [code]
ms_distiller_data_quant.hpp [code]
ms_distiller_data_search.hpp [code]
ms_distiller_master_project.hpp [code]
ms_distiller_master_search.hpp [code]
ms_distiller_search_status.hpp [code]
ms_distiller_search_status_list.hpp [code]
ms_distiller_sub_project.hpp [code]
ms_distiller_subsearch.hpp [code]
ms_enzyme.hpp [code]
ms_errors.hpp [code]
ms_fileutilities.hpp [code]
ms_fitexy_result.hpp [code]
ms_fitexy_result_body.hpp [code]
ms_fragment.hpp [code]
ms_fragmentationrules.hpp [code]
ms_fragmentvector.hpp [code]
ms_http_client.hpp [code]
ms_http_client_mime.hpp [code]
ms_http_client_search.hpp [code]
ms_http_client_session.hpp [code]
ms_http_helper.hpp [code]
ms_http_helper_handles.hpp [code]
ms_http_helper_handles_body.hpp [code]
ms_http_helper_progress.hpp [code]
ms_http_helper_response.hpp [code]
ms_http_helper_return.hpp [code]
ms_input_stream.hpp [code]
ms_inputquery.hpp [code]
ms_libraryoptions.hpp [code]
ms_license.hpp [code]
ms_linker_site.hpp [code]
ms_linker_site_vector.hpp [code]
ms_log.hpp [code]
ms_log_impl.hpp [code]
ms_logging.hpp [code]
ms_loggingmonitor_impl.hpp [code]
ms_mascotfiles.hpp [code]
ms_mascotoptions.hpp [code]
ms_mascotresfile.hpp [code]
ms_mascotresparams.hpp [code]
ms_mascotrespeptide.hpp [code]
ms_mascotrespeptidesum.hpp [code]
ms_mascotresprotein.hpp [code]
ms_mascotresproteinsum.hpp [code]
ms_mascotresults.hpp [code]
ms_mascotresults_params.hpp [code]
ms_mascotresunigene.hpp [code]
ms_masses.hpp [code]
ms_matrix.hpp [code]
ms_mod_visibility_helper.hpp [code]
ms_modfile.hpp [code]
ms_ms1quant_average_results.hpp [code]
ms_ms1quant_average_results_body.hpp [code]
ms_ms1quant_charge_state.hpp [code]
ms_ms1quant_charge_state_body.hpp [code]
ms_ms1quant_match.hpp [code]
ms_ms1quant_match_body.hpp [code]
ms_ms1quant_match_component.hpp [code]
ms_ms1quant_match_component_body.hpp [code]
ms_ms1quant_match_range.hpp [code]
ms_ms1quant_match_range_body.hpp [code]
ms_ms1quant_match_ratio.hpp [code]
ms_ms1quant_match_ratio_body.hpp [code]
ms_ms1quant_peptide_status.hpp [code]
ms_ms1quant_peptide_status_body.hpp [code]
ms_ms1quantitation.hpp [code]
ms_ms2quantitation.hpp [code]
ms_ms2ratiocalculator.hpp [code]
ms_obofile.hpp [code]
ms_parserule.hpp [code]
ms_peptide_impl.hpp [code]
ms_peptide_quant_key.hpp [code]
ms_peptide_quant_key_vector.hpp [code]
ms_peptide_quant_ratio.hpp [code]
ms_processoroptions.hpp [code]
ms_processors.hpp [code]
ms_processors_impl.hpp [code]
ms_progress_info.hpp [code]
ms_protein_match_data.hpp [code]
ms_protein_quant_ratio.hpp [code]
ms_quant_average.hpp [code]
ms_quant_component.hpp [code]
ms_quant_composition.hpp [code]
ms_quant_configfile.hpp [code]
ms_quant_correction.hpp [code]
ms_quant_extractors.hpp [code]
ms_quant_helper.hpp [code]
ms_quant_integration.hpp [code]
ms_quant_isotope.hpp [code]
ms_quant_localdef.hpp [code]
ms_quant_method.hpp [code]
ms_quant_mod_parsing.hpp [code]
ms_quant_modgroup.hpp [code]
ms_quant_moverz.hpp [code]
ms_quant_multiplex.hpp [code]
ms_quant_neutralloss.hpp [code]
ms_quant_normalisation.hpp [code]
ms_quant_normalisation_peptide.hpp [code]
ms_quant_normalisation_protein.hpp [code]
ms_quant_numerator.hpp [code]
ms_quant_outliers.hpp [code]
ms_quant_parameters.hpp [code]
ms_quant_pepneutralloss.hpp [code]
ms_quant_precursor.hpp [code]
ms_quant_protocol.hpp [code]
ms_quant_quality.hpp [code]
ms_quant_ratio.hpp [code]
ms_quant_replicate.hpp [code]
ms_quant_reporter.hpp [code]
ms_quant_satellite.hpp [code]
ms_quant_specificity.hpp [code]
ms_quant_stats.hpp [code]
ms_quant_unmodified.hpp [code]
ms_quantitation.hpp [code]
ms_security.hpp [code]
ms_security_group.hpp [code]
ms_security_options.hpp [code]
ms_security_session.hpp [code]
ms_security_task.hpp [code]
ms_security_tasks.hpp [code]
ms_security_user.hpp [code]
ms_shapiro_wilk.hpp [code]
ms_spectral_lib_entry.hpp [code]
ms_spectral_lib_file.hpp [code]
ms_spectral_lib_peak.hpp [code]
ms_spectral_lib_peak_list.hpp [code]
ms_taxonomyfile.hpp [code]
ms_taxonomyrules.hpp [code]
ms_tinycdb.hpp [code]
ms_treecluster.hpp [code]
ms_umod_aminoacid.hpp [code]
ms_umod_composition.hpp [code]
ms_umod_configfile.hpp [code]
ms_umod_element.hpp [code]
ms_umod_elemref.hpp [code]
ms_umod_modbrick.hpp [code]
ms_umod_modification.hpp [code]
ms_umod_neutralloss.hpp [code]
ms_umod_specificity.hpp [code]
ms_umod_xref.hpp [code]
ms_unigeneoptions.hpp [code]
ms_wwwoptions.hpp [code]
ms_xic.hpp [code]
ms_xic_body.hpp [code]
ms_xml_parameters.hpp [code]
ms_zip.hpp [code]
msparser.hpp [code]
msparser_lim.hpp [code]
numerical_recipes.hpp [code]
time_utils.hpp [code]
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KA_ASSIGNPROTEINS_AP : ms_mascotresfile
  • KA_CREATECACHE_CC : ms_mascotresfile
  • KA_CREATEINDEX_CI : ms_mascotresfile
  • KA_GROUPPROTEINS_GP : ms_mascotresfile
  • KA_LAST : ms_mascotresfile
  • KA_QUANTITATION : ms_mascotresfile
  • KA_READFILE_RF : ms_mascotresfile
  • KA_TASK : ms_mascotresfile
  • KA_THRESHFORFDR_FDR : ms_mascotresfile
  • KA_UNASSIGNEDLIST_UL : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • L_GUESTLOGINDISABLED : ms_http_client
  • L_INCORRECTPASSWORD : ms_http_client
  • L_PASSWORDEXPIRED : ms_http_client
  • L_SECURITYDISABLED : ms_http_client
  • L_SUCCESS : ms_http_client
  • L_UNKNOWNUSER : ms_http_client
  • L_UNSPECIFIEDERROR : ms_http_client
  • L_WEBAUTHENTICATIONFAILED : ms_http_client
  • LABEL_FORMAT : ms_fragment
  • LABEL_FORMAT_PEPTIDE_VIEW : ms_fragment
  • LABEL_FORMAT_TRADITIONAL : ms_fragment
  • Level_e : ms_loggingmonitor
  • loadCdbFile() : ms_ms1quantitation , ms_ms2quantitation
  • loadCdbFiles() : ms_ms2quantitation
  • loadFromFile() : ms_security_tasks
  • loadXml() : ms_distiller_data , ms_distiller_master_project , ms_distiller_search_status_list
  • loadXmlFile() : ms_distiller_data , ms_distiller_master_project , ms_distiller_search_status_list , ms_ms1quantitation
  • loadXmlStream() : ms_distiller_data , ms_distiller_master_project , ms_distiller_search_status_list
  • logContents() : ms_matrix
  • LoginResultCode : ms_http_client
  • logMessage() : ms_loggingmonitor
  • LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK : ms_log
  • LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK : ms_log
  • LOGMSG_AAHELPER_CFR_MASSES_VALUE : ms_log
  • LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE : ms_log
  • LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT : ms_log
  • LOGMSG_AAHELPER_CFR_START_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_END : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_START : ms_log
  • LOGMSG_AAHELPER_CUMULATIVE_MASS_NL : ms_log
  • LOGMSG_AAHELPER_ETMOD_LOOKUP : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_ADD : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_ADD : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_MASTER_NL_VALS : ms_log
  • LOGMSG_AAHELPER_MULTINL_INDICES : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_SERIES_PARAMS : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT : ms_log
  • LOGMSG_AAHELPER_TOTAL_NL_VALS : ms_log
  • LOGMSG_CUSTQUANT_ADD_QUANT_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_ALL_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_KEY : ms_log
  • LOGMSG_DBG1_NUM_PROCESSOR_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_GETAUTODETECT : ms_log
  • LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_STATUS : ms_log
  • LOGMSG_DBG2_CPU_INF_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_AVAIL : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_ON_SYS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL : ms_log
  • LOGMSG_DBG2_CPU_INF_PROC_AFFINITY : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_LINE : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_TITLE : ms_log
  • LOGMSG_DBG2_CPU_INF_USE_PROCESSES : ms_log
  • LOGMSG_DBG2_NUM_CONFIG_MISMATCH : ms_log
  • LOGMSG_DBG2_NUM_ONLINE_MISMATCH : ms_log
  • LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD : ms_log
  • LOGMSG_DBG3_BINDING_PROCESSORS : ms_log
  • LOGMSG_DBG3_BINDING_THREAD : ms_log
  • LOGMSG_DBG3_CALL_GET_CHIP_MFCTR : ms_log
  • LOGMSG_DBG3_HWLOC_GROUPS : ms_log
  • LOGMSG_DBG3_HWLOC_TREE : ms_log
  • LOGMSG_DBG3_PROCESSOR_NAME : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_START : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT : ms_log
  • LOGMSG_GET_THR_REACH_COND : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR : ms_log
  • LOGMSG_HTTP_GETRETURNSTRING : ms_log
  • LOGMSG_HTTP_MAXCONECTIONS10FAILED : ms_log
  • LOGMSG_HTTP_MAXCONECTIONSFAILED : ms_log
  • LOGMSG_HTTP_QUERYSTATUSRESULT : ms_log
  • LOGMSG_HTTP_URLSTRING : ms_log
  • LOGMSG_INST_ADDINGDATABASE : ms_log
  • LOGMSG_INST_ADDOPTIONSSECTION : ms_log
  • LOGMSG_INST_APPENDPARSERULE : ms_log
  • LOGMSG_INST_APPENDTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEDBTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEPARSERULE : ms_log
  • LOGMSG_INST_CHANGEPERCOLATORFEATS : ms_log
  • LOGMSG_INST_CHANGEPROTFAMILYSWITCH : ms_log
  • LOGMSG_INST_CLUSTERSECTION : ms_log
  • LOGMSG_INST_FAILSAVEPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_LOGICALPERPHYSICALCPU : ms_log
  • LOGMSG_INST_MASCOTDATOK : ms_log
  • LOGMSG_INST_NOSUBCLUSTERSET : ms_log
  • LOGMSG_INST_NOTMASCOTDATOK : ms_log
  • LOGMSG_INST_NUMTHREADS : ms_log
  • LOGMSG_INST_REMOVEOPTIONSSECTION : ms_log
  • LOGMSG_INST_SAVEDPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_SETOPTIONSSECTION : ms_log
  • LOGMSG_MATRIX_OUTPUT_VALS : ms_log
  • LOGMSG_PEPSUM_GETHIT : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_START : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_CLUSTER_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_END : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_QUEUE : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY : ms_log
  • LOGMSG_PROTINFER_PEPTIDE_MATRIX : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_START : ms_log
  • LOGMSG_PROTINFER_SINGLETON_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_DONE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_START : ms_log
  • LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT : ms_log
  • LOGMSG_QUANT_ADDED_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_ADDING_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED : ms_log
  • LOGMSG_QUANT_CLOSING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN : ms_log
  • LOGMSG_QUANT_FINISH_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_FINISH_LOAD_CDB : ms_log
  • LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_HELPER_TEST_REQUIRED : ms_log
  • LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES : ms_log
  • LOGMSG_QUANT_LOADING_MATCHES : ms_log
  • LOGMSG_QUANT_OPENING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_REAPPLY_THRESHOLDS : ms_log
  • LOGMSG_QUANT_REMATCHING_INFERRED : ms_log
  • LOGMSG_QUANT_REMOVE_INFERRED_MATCH : ms_log
  • LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE : ms_log
  • LOGMSG_QUANT_START_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_START_LOAD_CDB : ms_log
  • LOGMSG_QUANT_START_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_START_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES : ms_log
  • LOGMSG_QUANT_UPDATING_PEP_EVIDENCE : ms_log
  • LOGMSG_REPORT_FUNCTION_CALLED_BY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT_WITH : ms_log
  • LOGMSG_RESFILE_APPEND : ms_log
  • logout() : ms_http_client_session
  • LogOutputColumns_e : ms_logger
  • logTransform() : ms_quant_stats
  • LVL_DEBUG1 : ms_loggingmonitor
  • LVL_DEBUG2 : ms_loggingmonitor
  • LVL_DEBUG3 : ms_loggingmonitor
  • LVL_ERROR : ms_loggingmonitor
  • LVL_INFO : ms_loggingmonitor
  • LVL_NONE : ms_loggingmonitor
  • LVL_WARNING : ms_loggingmonitor
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • makeExists() : ms_tinycdb
  • mascotresfile() : ms_peptidesummary
  • MASS_DECIMAL_PLACES : ms_mascotoptions
  • MASS_FLAGS : ms_protein
  • MASS_NON_SELECT_MATCH : ms_protein
  • MASS_NON_SELECT_NON_MATCH : ms_protein
  • MASS_SELECT_MATCH : ms_protein
  • MASS_SELECT_NON_MATCH : ms_protein
  • MATCH_CLOSEST_PEAK : ms_fragmentvector
  • MATCH_MOST_INTENSE_PEAK : ms_fragmentvector
  • MATCH_PEAKS : ms_fragmentvector
  • MAX_EXEC_AFTER_SEARCH : ms_mascotoptions
  • meanCentre() : ms_quant_stats
  • medianStandardErrorCorrection() : ms_quant_stats
  • MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_PRECURSOR_METHOD : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_REPLICATE_METHOD : ms_ms1quantitation
  • MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH : ms_ms1quantitation
  • MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS : ms_ms1quantitation
  • MERGE_QUANT_RESULTS_FLAGS : ms_ms1quantitation
  • MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC : ms_ms1quantitation
  • mergeQuantitationResults() : ms_ms1quantitation
  • messageSourceAsText() : ms_loggingmonitor
  • METHOD_COMPATIBLE : ms_quant_method
  • MISECTASK_ACCESS : ms_security_tasks
  • MISECTASK_ADDCUSTOMREPORT : ms_security_tasks
  • MISECTASK_ADDEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_ADDIMPORTFILTER : ms_security_tasks
  • MISECTASK_ADMIN : ms_security_tasks
  • MISECTASK_DELETECUSTOMREPORT : ms_security_tasks
  • MISECTASK_DELETEEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_PROTEINAPPROVAL : ms_security_tasks
  • MISECTASK_SENDNOTIFICATION : ms_security_tasks
  • MODFILE_FLAGS : ms_umod_configfile
  • MODFILE_FLAGS_AASUBST : ms_umod_configfile
  • MODFILE_FLAGS_ALL : ms_umod_configfile
  • MODFILE_FLAGS_EMPTY : ms_umod_configfile
  • MODFILE_FLAGS_HIDDEN : ms_umod_configfile
  • MODFILE_FLAGS_REGULAR : ms_umod_configfile
  • MS1QUANT_BUGFIX_NUM : ms_ms1quantitation
  • ms_aahelper() : ms_aahelper
  • ms_buffer_logger() : ms_buffer_logger
  • ms_clusterparams() : ms_clusterparams
  • ms_computeraddress() : ms_computeraddress
  • ms_connection_settings() : ms_connection_settings
  • ms_cronjob() : ms_cronjob
  • ms_cronoptions() : ms_cronoptions
  • ms_crosslinking_accession() : ms_crosslinking_accession
  • ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ms_crosslinking_filters() : ms_crosslinking_filters
  • ms_crosslinking_linker() : ms_crosslinking_linker
  • ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ms_crosslinking_method() : ms_crosslinking_method
  • ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ms_crosslinking_scope() : ms_crosslinking_scope
  • ms_crosslinking_settings() : ms_crosslinking_settings
  • ms_customproperty() : ms_customproperty
  • ms_customquantitation() : ms_customquantitation
  • ms_databaseoptions() : ms_databaseoptions
  • ms_databases() : ms_databases
  • ms_datfile() : ms_datfile
  • ms_dbprocessors() : ms_dbprocessors
  • ms_distiller_data() : ms_distiller_data
  • ms_distiller_data_search() : ms_distiller_data_search
  • ms_distiller_master_project() : ms_distiller_master_project
  • ms_distiller_search_status_list() : ms_distiller_search_status_list
  • ms_enzyme() : ms_enzyme
  • ms_enzymefile() : ms_enzymefile
  • ms_errors() : ms_errors
  • ms_errs() : ms_errs
  • ms_file_logger() : ms_file_logger
  • ms_fileutilities() : ms_fileutilities
  • ms_fitexy_result() : ms_fitexy_result
  • ms_fragment() : ms_fragment
  • ms_fragmentationrules() : ms_fragmentationrules
  • ms_fragmentvector() : ms_fragmentvector
  • ms_fragrulesfile() : ms_fragrulesfile
  • ms_group() : ms_group
  • ms_http_client() : ms_http_client
  • ms_http_client_search() : ms_http_client_search
  • ms_http_client_session() : ms_http_client_session
  • ms_http_helper() : ms_http_helper
  • ms_http_helper_handles() : ms_http_helper_handles
  • ms_http_helper_progress() : ms_http_helper_progress
  • ms_http_helper_return() : ms_http_helper_return
  • ms_inputquery() : ms_inputquery
  • ms_libraryoptions() : ms_libraryoptions
  • ms_license() : ms_license
  • ms_linker_site() : ms_linker_site
  • ms_linker_site_vector() : ms_linker_site_vector
  • ms_log() : ms_log
  • ms_logger() : ms_logger
  • ms_loggingmonitor() : ms_loggingmonitor
  • ms_mascotfiles() : ms_mascotfiles
  • ms_mascotoptions() : ms_mascotoptions
  • ms_mascotresfile() : ms_mascotresfile
  • ms_mascotresults() : ms_mascotresults
  • ms_mascotresults_params() : ms_mascotresults_params
  • ms_masses() : ms_masses
  • ms_matrix() : ms_matrix
  • ms_modfile() : ms_modfile
  • ms_modification() : ms_modification
  • ms_modvector() : ms_modvector
  • ms_ms1quant_average_results() : ms_ms1quant_average_results
  • ms_ms1quant_charge_state() : ms_ms1quant_charge_state
  • ms_ms1quant_match() : ms_ms1quant_match
  • ms_ms1quant_match_component() : ms_ms1quant_match_component
  • ms_ms1quant_match_range() : ms_ms1quant_match_range
  • ms_ms1quant_match_ratio() : ms_ms1quant_match_ratio
  • ms_ms1quant_peptide_status() : ms_ms1quant_peptide_status
  • ms_ms1quantitation() : ms_ms1quantitation
  • ms_ms2quantitation() : ms_ms2quantitation
  • ms_obofile() : ms_obofile
  • ms_parseoptions() : ms_parseoptions
  • ms_parserule() : ms_parserule
  • ms_parserule_plus() : ms_parserule_plus
  • ms_peptide() : ms_peptide
  • ms_peptide_quant_key() : ms_peptide_quant_key
  • ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ms_peptidesummary() : ms_peptidesummary
  • ms_processoroptions() : ms_processoroptions
  • ms_processors() : ms_processors
  • ms_progress_info() : ms_progress_info
  • ms_protein() : ms_protein
  • ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ms_proteinsummary() : ms_proteinsummary
  • ms_quant_average() : ms_quant_average
  • ms_quant_component() : ms_quant_component
  • ms_quant_composition() : ms_quant_composition
  • ms_quant_configfile() : ms_quant_configfile
  • ms_quant_correction() : ms_quant_correction
  • ms_quant_element() : ms_quant_element
  • ms_quant_helper() : ms_quant_helper
  • ms_quant_integration() : ms_quant_integration
  • ms_quant_isotope() : ms_quant_isotope
  • ms_quant_localdef() : ms_quant_localdef
  • ms_quant_method() : ms_quant_method
  • ms_quant_modgroup() : ms_quant_modgroup
  • ms_quant_moverz() : ms_quant_moverz
  • ms_quant_multiplex() : ms_quant_multiplex
  • ms_quant_neutralloss() : ms_quant_neutralloss
  • ms_quant_normalisation() : ms_quant_normalisation
  • ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ms_quant_numerator() : ms_quant_numerator
  • ms_quant_outliers() : ms_quant_outliers
  • ms_quant_parameter() : ms_quant_parameter
  • ms_quant_parameters() : ms_quant_parameters
  • ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ms_quant_precursor() : ms_quant_precursor
  • ms_quant_protocol() : ms_quant_protocol
  • ms_quant_quality() : ms_quant_quality
  • ms_quant_ratio() : ms_quant_ratio
  • ms_quant_replicate() : ms_quant_replicate
  • ms_quant_reporter() : ms_quant_reporter
  • ms_quant_satellite() : ms_quant_satellite
  • ms_quant_specificity() : ms_quant_specificity
  • ms_quant_unmodified() : ms_quant_unmodified
  • MS_REVIEW_COL : ms_mascotoptions
  • MS_REVIEW_COL____LAST___ : ms_mascotoptions
  • MS_REVIEW_COL_DATABASE : ms_mascotoptions
  • MS_REVIEW_COL_DURATION : ms_mascotoptions
  • MS_REVIEW_COL_ENZYMEUSED : ms_mascotoptions
  • MS_REVIEW_COL_IPADDRESS : ms_mascotoptions
  • MS_REVIEW_COL_JOB : ms_mascotoptions
  • MS_REVIEW_COL_PEAKLISTDATAFILE : ms_mascotoptions
  • MS_REVIEW_COL_PID : ms_mascotoptions
  • MS_REVIEW_COL_PRIORITY : ms_mascotoptions
  • MS_REVIEW_COL_RESULTS_FILE : ms_mascotoptions
  • MS_REVIEW_COL_SEARCHTYPE : ms_mascotoptions
  • MS_REVIEW_COL_START_TIME : ms_mascotoptions
  • MS_REVIEW_COL_STATUS : ms_mascotoptions
  • MS_REVIEW_COL_TITLE : ms_mascotoptions
  • MS_REVIEW_COL_USEREMAIL : ms_mascotoptions
  • MS_REVIEW_COL_USERID : ms_mascotoptions
  • MS_REVIEW_COL_USERNAME : ms_mascotoptions
  • ms_searchparams() : ms_searchparams
  • ms_security() : ms_security
  • ms_security_options() : ms_security_options
  • ms_security_task() : ms_security_task
  • ms_security_tasks() : ms_security_tasks
  • ms_session() : ms_session
  • ms_shapiro_wilk() : ms_shapiro_wilk
  • ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ms_spectral_lib_file() : ms_spectral_lib_file
  • ms_spectral_lib_peak() : ms_spectral_lib_peak
  • ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ms_stdout_logger() : ms_stdout_logger
  • ms_taxnodesfiles() : ms_taxnodesfiles
  • ms_taxonomychoice() : ms_taxonomychoice
  • ms_taxonomyfile() : ms_taxonomyfile
  • ms_taxonomyrules() : ms_taxonomyrules
  • ms_taxonomytree() : ms_taxonomytree
  • ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ms_tinycdb() : ms_tinycdb
  • ms_treecluster() : ms_treecluster
  • ms_umod_aminoacid() : ms_umod_aminoacid
  • ms_umod_composition() : ms_umod_composition
  • ms_umod_configfile() : ms_umod_configfile
  • ms_umod_element() : ms_umod_element
  • ms_umod_elemref() : ms_umod_elemref
  • ms_umod_modbrick() : ms_umod_modbrick
  • ms_umod_modification() : ms_umod_modification
  • ms_umod_neutralloss() : ms_umod_neutralloss
  • ms_umod_specificity() : ms_umod_specificity
  • ms_umod_xref() : ms_umod_xref
  • ms_unigene() : ms_unigene
  • ms_unigene_entry() : ms_unigene_entry
  • ms_unigeneoptions() : ms_unigeneoptions
  • ms_user() : ms_user
  • ms_wwwentry() : ms_wwwentry
  • ms_wwwoptions() : ms_wwwoptions
  • ms_xic() : ms_xic
  • ms_xml_parameter() : ms_xml_parameter
  • ms_xml_parameters() : ms_xml_parameters
  • ms_zip() : ms_zip
  • msg_num_t : ms_log
  • msg_sev : ms_log
  • MSM_EXCLUSIVE_PLUS_VARIABLE : ms_searchparams
  • MSM_NOT_PERMITTED : ms_searchparams
  • MSPEPSUM : ms_peptidesummary
  • MSPEPSUM_CACHE_IGNORE_DATE_CHANGE : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_ONLY : ms_peptidesummary
  • MSPEPSUM_DEFERRED_CREATE : ms_peptidesummary
  • MSPEPSUM_DISCARD_RELOADABLE : ms_peptidesummary
  • MSPEPSUM_NO_PROTEIN_GROUPING : ms_peptidesummary
  • MSPEPSUM_NONE : ms_peptidesummary
  • MSPEPSUM_PERCOLATOR : ms_peptidesummary
  • MSPEPSUM_REMOVE_CHIMERIC_DUPES : ms_peptidesummary
  • MSPEPSUM_SINGLE_HIT_DBIDX : ms_peptidesummary
  • MSPEPSUM_SL_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_SL_ONLY : ms_peptidesummary
  • MSPEPSUM_USE_CACHE : ms_peptidesummary
  • MSPEPSUM_USE_HOMOLOGY_THRESH : ms_peptidesummary
  • MSRES_CLUSTER_PROTEINS : ms_mascotresults
  • MSRES_DECOY : ms_mascotresults
  • MSRES_DUPE_DEFAULT : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_A : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_B : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_C : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_D : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_E : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_F : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_G : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_H : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_I : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_NONE : ms_mascotresults
  • MSRES_DUPE_REMOVE_A : ms_mascotresults
  • MSRES_DUPE_REMOVE_B : ms_mascotresults
  • MSRES_DUPE_REMOVE_C : ms_mascotresults
  • MSRES_DUPE_REMOVE_D : ms_mascotresults
  • MSRES_DUPE_REMOVE_E : ms_mascotresults
  • MSRES_DUPE_REMOVE_F : ms_mascotresults
  • MSRES_DUPE_REMOVE_G : ms_mascotresults
  • MSRES_DUPE_REMOVE_H : ms_mascotresults
  • MSRES_DUPE_REMOVE_I : ms_mascotresults
  • MSRES_DUPE_REMOVE_NONE : ms_mascotresults
  • MSRES_ERR_TOL : ms_mascotresults
  • MSRES_GROUP_PROTEINS : ms_mascotresults
  • MSRES_IGNORE_PMF_MIXTURE : ms_mascotresults
  • MSRES_INTEGRATED_ERR_TOL : ms_mascotresults
  • MSRES_MAXHITS_OVERRIDES_MINPROB : ms_mascotresults
  • MSRES_MUDPIT_PROTEIN_SCORE : ms_mascotresults
  • MSRES_NOFLAG : ms_mascotresults
  • MSRES_REQUIRE_BOLD_RED : ms_mascotresults
  • MSRES_SHOW_ALL_FROM_ERR_TOL : ms_mascotresults
  • MSRES_SHOW_SUBSETS : ms_mascotresults
  • MSRES_SUBSETS_DIFF_PROT : ms_mascotresults
  • MULTI_SITE_MODS : ms_searchparams
  • multiplyByRow() : ms_matrix
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • normalCriticalValue() : ms_quant_stats
  • normalCumulativeProbability() : ms_quant_stats
  • normaliseIntensities() : ms_ms2quantitation
  • normalisePeptideRatios() : ms_ms2quantitation
  • NTERM_CUTTER : ms_enzyme
  • NUM_PROCESSORS_AUTO_DETECT : ms_clusterparams
  • NUM_THREADS_AUTO_DETECT : ms_databaseoptions
  • NUMERICAL_VALUE_STORAGE : ms_mascotoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • onLogMessage() : ms_logger , ms_stdout_logger , ms_buffer_logger , ms_file_logger
  • openIndexFile() : ms_tinycdb
  • openQuantitationCdbResults() : ms_ms1quantitation
  • openQuantitationXmlResults() : ms_ms1quantitation
  • operator bool() : ms_http_helper_return
  • operator!=() : ms_matrix , ms_peptide_quant_key , ms_protein_quant_ratio
  • operator*() : ms_matrix
  • operator< : ms_protein , ms_peptide_quant_key
  • operator<=() : ms_peptide_quant_key
  • operator=() : ms_umod_specificity , ms_umod_neutralloss , ms_umod_modification , ms_umod_modbrick , ms_umod_elemref , ms_umod_element , ms_umod_configfile , ms_umod_composition , ms_umod_aminoacid , ms_treecluster , ms_taxonomytree , ms_taxonomyrules , ms_parserule_plus , ms_taxnodesfiles , ms_xml_parameter , ms_aahelper , ms_taxonomychoice , ms_spectral_lib_peak_list , ms_spectral_lib_peak , ms_spectral_lib_entry , ms_security_options , ms_quant_unmodified , ms_quant_specificity , ms_crosslinking_parameters , ms_quant_reporter , ms_quant_replicate , ms_quant_ratio , ms_quant_quality , ms_quant_protocol , ms_quant_precursor , ms_obofile , ms_umod_xref , ms_quant_parameter , ms_quant_outliers , ms_quant_numerator , ms_quant_normalisation_proteins , ms_quant_normalisation_protein , ms_quant_normalisation_peptides , ms_quant_normalisation_peptide , ms_unigeneoptions , ms_quant_neutralloss , ms_quant_multiplex , ms_quant_moverz , ms_quant_modgroup , ms_quant_method , ms_quant_localdef , ms_quant_isotope , ms_parserule , ms_quant_correction , ms_quant_configfile , ms_quant_composition , ms_quant_element , ms_quant_component , ms_quant_average , ms_protein_quant_ratio , ms_crosslinking_scope , ms_processoroptions , ms_dbprocessors , ms_peptide_quant_ratio , ms_parseoptions , ms_peptide_quant_key , ms_clusterparams , ms_crosslinking_settings , ms_peptide_quant_key_vector , ms_modfile , ms_modvector , ms_modification , ms_masses , ms_mascotresults_params , ms_protein , ms_peptide , ms_taxspeciesfiles , ms_mascotfiles , ms_linker_site_vector , ms_linker_site , ms_quant_satellite , ms_libraryoptions , ms_http_helper , ms_http_client_session , ms_quant_pepneutralloss , ms_http_client , ms_fragmentvector , ms_fragrulesfile , ms_quant_normalisation , ms_fragment , ms_enzymefile , ms_enzyme , ms_quant_integration , ms_distiller_master_project , ms_distiller_data , ms_datfile , ms_databaseoptions , ms_computeraddress , ms_databases , ms_processors , ms_connection_settings , ms_crosslinking_parameter , ms_crosslinking_monolink , ms_crosslinking_method , ms_taxonomyfile , ms_crosslinking_linker , ms_license , ms_crosslinking_does_not_pair_with , ms_quant_parameters , ms_crosslinking_accessions , ms_fragmentationrules , ms_cronoptions , ms_zip , ms_cronjob , ms_distiller_search_status_list , ms_crosslinking_accession , ms_wwwoptions , ms_wwwentry , ms_mascotoptions , ms_crosslinking_filters , ms_crosslinking_configfile , ms_http_client_search , ms_crosslinking_linkers
  • operator==() : ms_matrix , ms_protein_quant_ratio , ms_peptide_quant_key
  • operator>() : ms_peptide_quant_key
  • operator>=() : ms_peptide_quant_key
  • operator[]() : ms_matrix
  • outputKeepAlive() : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~ms_aahelper() : ms_aahelper
  • ~ms_buffer_logger() : ms_buffer_logger
  • ~ms_clusterparams() : ms_clusterparams
  • ~ms_computeraddress() : ms_computeraddress
  • ~ms_connection_settings() : ms_connection_settings
  • ~ms_cronjob() : ms_cronjob
  • ~ms_cronoptions() : ms_cronoptions
  • ~ms_crosslinking_accession() : ms_crosslinking_accession
  • ~ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ~ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ~ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ~ms_crosslinking_filters() : ms_crosslinking_filters
  • ~ms_crosslinking_linker() : ms_crosslinking_linker
  • ~ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ~ms_crosslinking_method() : ms_crosslinking_method
  • ~ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ~ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ~ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ~ms_crosslinking_scope() : ms_crosslinking_scope
  • ~ms_crosslinking_settings() : ms_crosslinking_settings
  • ~ms_customproperty() : ms_customproperty
  • ~ms_customquantitation() : ms_customquantitation
  • ~ms_databaseoptions() : ms_databaseoptions
  • ~ms_databases() : ms_databases
  • ~ms_datfile() : ms_datfile
  • ~ms_dbprocessors() : ms_dbprocessors
  • ~ms_enzyme() : ms_enzyme
  • ~ms_enzymefile() : ms_enzymefile
  • ~ms_errors() : ms_errors
  • ~ms_errs() : ms_errs
  • ~ms_file_logger() : ms_file_logger
  • ~ms_fragmentationrules() : ms_fragmentationrules
  • ~ms_fragmentvector() : ms_fragmentvector
  • ~ms_fragrulesfile() : ms_fragrulesfile
  • ~ms_http_client() : ms_http_client
  • ~ms_http_client_mime() : ms_http_client_mime
  • ~ms_http_client_search() : ms_http_client_search
  • ~ms_http_client_session() : ms_http_client_session
  • ~ms_http_helper() : ms_http_helper
  • ~ms_http_helper_handles() : ms_http_helper_handles
  • ~ms_libraryoptions() : ms_libraryoptions
  • ~ms_license() : ms_license
  • ~ms_linker_site() : ms_linker_site
  • ~ms_linker_site_vector() : ms_linker_site_vector
  • ~ms_log() : ms_log
  • ~ms_logger() : ms_logger
  • ~ms_loggingmonitor() : ms_loggingmonitor
  • ~ms_mascotfiles() : ms_mascotfiles
  • ~ms_mascotoptions() : ms_mascotoptions
  • ~ms_masses() : ms_masses
  • ~ms_modfile() : ms_modfile
  • ~ms_modification() : ms_modification
  • ~ms_modvector() : ms_modvector
  • ~ms_ms2quantitation() : ms_ms2quantitation
  • ~ms_obofile() : ms_obofile
  • ~ms_parseoptions() : ms_parseoptions
  • ~ms_parserule() : ms_parserule
  • ~ms_parserule_plus() : ms_parserule_plus
  • ~ms_peptide() : ms_peptide
  • ~ms_peptide_quant_key() : ms_peptide_quant_key
  • ~ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ~ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ~ms_processoroptions() : ms_processoroptions
  • ~ms_processors() : ms_processors
  • ~ms_progress_info() : ms_progress_info
  • ~ms_protein() : ms_protein
  • ~ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ~ms_quant_average() : ms_quant_average
  • ~ms_quant_component() : ms_quant_component
  • ~ms_quant_composition() : ms_quant_composition
  • ~ms_quant_configfile() : ms_quant_configfile
  • ~ms_quant_correction() : ms_quant_correction
  • ~ms_quant_element() : ms_quant_element
  • ~ms_quant_helper() : ms_quant_helper
  • ~ms_quant_integration() : ms_quant_integration
  • ~ms_quant_isotope() : ms_quant_isotope
  • ~ms_quant_localdef() : ms_quant_localdef
  • ~ms_quant_method() : ms_quant_method
  • ~ms_quant_modgroup() : ms_quant_modgroup
  • ~ms_quant_moverz() : ms_quant_moverz
  • ~ms_quant_multiplex() : ms_quant_multiplex
  • ~ms_quant_neutralloss() : ms_quant_neutralloss
  • ~ms_quant_normalisation() : ms_quant_normalisation
  • ~ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ~ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ~ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ~ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ~ms_quant_numerator() : ms_quant_numerator
  • ~ms_quant_outliers() : ms_quant_outliers
  • ~ms_quant_parameter() : ms_quant_parameter
  • ~ms_quant_parameters() : ms_quant_parameters
  • ~ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ~ms_quant_precursor() : ms_quant_precursor
  • ~ms_quant_protocol() : ms_quant_protocol
  • ~ms_quant_quality() : ms_quant_quality
  • ~ms_quant_ratio() : ms_quant_ratio
  • ~ms_quant_replicate() : ms_quant_replicate
  • ~ms_quant_reporter() : ms_quant_reporter
  • ~ms_quant_satellite() : ms_quant_satellite
  • ~ms_quant_specificity() : ms_quant_specificity
  • ~ms_quant_unmodified() : ms_quant_unmodified
  • ~ms_quantitation() : ms_quantitation
  • ~ms_searchparams() : ms_searchparams
  • ~ms_security_task() : ms_security_task
  • ~ms_security_tasks() : ms_security_tasks
  • ~ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ~ms_spectral_lib_file() : ms_spectral_lib_file
  • ~ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ~ms_stdout_logger() : ms_stdout_logger
  • ~ms_taxnodesfiles() : ms_taxnodesfiles
  • ~ms_taxonomychoice() : ms_taxonomychoice
  • ~ms_taxonomyfile() : ms_taxonomyfile
  • ~ms_taxonomyrules() : ms_taxonomyrules
  • ~ms_taxonomytree() : ms_taxonomytree
  • ~ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ~ms_tinycdb() : ms_tinycdb
  • ~ms_treecluster() : ms_treecluster
  • ~ms_umod_aminoacid() : ms_umod_aminoacid
  • ~ms_umod_composition() : ms_umod_composition
  • ~ms_umod_configfile() : ms_umod_configfile
  • ~ms_umod_element() : ms_umod_element
  • ~ms_umod_elemref() : ms_umod_elemref
  • ~ms_umod_modbrick() : ms_umod_modbrick
  • ~ms_umod_modification() : ms_umod_modification
  • ~ms_umod_neutralloss() : ms_umod_neutralloss
  • ~ms_umod_specificity() : ms_umod_specificity
  • ~ms_umod_xref() : ms_umod_xref
  • ~ms_unigene() : ms_unigene
  • ~ms_unigene_entry() : ms_unigene_entry
  • ~ms_unigeneoptions() : ms_unigeneoptions
  • ~ms_wwwentry() : ms_wwwentry
  • ~ms_wwwoptions() : ms_wwwoptions
  • ~ms_xml_parameter() : ms_xml_parameter
  • ~ms_xml_parameters() : ms_xml_parameters
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • baseUrl() : ms_http_client , ms_http_helper
  • binomialCoefficient() : ms_quant_stats
  • BUGFIX_10780 : ms_peptidesummary
  • BUGFIX_10995 : ms_peptidesummary
  • BUGFIX_11002 : ms_peptidesummary
  • BUGFIX_11018 : ms_peptidesummary
  • BUGFIX_11235 : ms_peptidesummary
  • BUGFIX_11254 : ms_peptidesummary
  • BUGFIX_11344 : ms_peptidesummary
  • BUGFIX_11411 : ms_peptidesummary
  • BUGFIX_11425 : ms_peptidesummary
  • BUGFIX_11438 : ms_peptidesummary
  • BUGFIX_11481 : ms_peptidesummary
  • BUGFIX_11483 : ms_peptidesummary
  • BUGFIX_11499 : ms_peptidesummary
  • BUGFIX_11856 : ms_peptidesummary
  • BUGFIX_12123 : ms_peptidesummary
  • BUGFIX_12317 : ms_peptidesummary
  • BUGFIX_12409 : ms_ms1quantitation
  • BUGFIX_12447 : ms_peptidesummary
  • BUGFIX_12538 : ms_peptidesummary
  • BUGFIX_12729 : ms_peptidesummary
  • BUGFIX_12740 : ms_peptidesummary
  • BUGFIX_13324 : ms_peptidesummary
  • BUGFIX_13759 : ms_peptidesummary
  • BUGFIX_NUM : ms_peptidesummary
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CACHE_MISSING_RESFILE : ms_peptidesummary
  • CACHE_STATUS : ms_peptidesummary
  • calcFragments() : ms_aahelper
  • calcFragmentsEx() : ms_aahelper
  • calcPeptideMZ() : ms_aahelper
  • calculate() : ms_shapiro_wilk
  • calculateGeometricMeanRatio() : ms_quantitation
  • calculateMedianRatio() : ms_quantitation
  • calculateNormalMeanPvalue() : ms_quant_stats
  • calculateNormalMedianPvalue() : ms_quant_stats
  • calculateNormalWeightedPvalue() : ms_quant_stats
  • calculateWeightedGeometricMeanRatio() : ms_quantitation
  • cancelCreateSummary() : ms_mascotresults
  • canCleave() : ms_enzyme
  • canResultsFileBeViewed() : ms_session
  • changePassword() : ms_http_client
  • ChangePasswordResultCode : ms_http_client
  • chargeType : ms_ms1quant_match
  • CHARGETYPE_ALL : ms_ms1quant_match
  • CHARGETYPE_ORIGINAL : ms_ms1quant_match
  • checkSeqDBInstallRequest() : ms_datfile
  • chisqLowerCriticalValue() : ms_quant_stats
  • chisqUpperCriticalValue() : ms_quant_stats
  • clear() : ms_linker_site_vector , ms_peptide_quant_key_vector , ms_progress_info
  • clearAccessions() : ms_crosslinking_accessions
  • clearAllCutters() : ms_enzyme
  • clearAllErrors() : ms_errors , ms_errs
  • clearAltNames() : ms_umod_modification
  • clearAminoAcids() : ms_umod_configfile
  • clearAnnotation() : ms_spectral_lib_entry , ms_spectral_lib_peak , ms_spectral_lib_peak_list
  • clearComponents() : ms_quant_method
  • clearCorrections() : ms_quant_component
  • clearCronJobs() : ms_cronoptions
  • clearDatabases() : ms_databases , ms_processoroptions
  • clearDBLevelTaxId() : ms_taxonomyrules
  • clearDenominators() : ms_quant_ratio
  • clearDoesNotPairWiths() : ms_crosslinking_linker
  • clearElements() : ms_quant_composition , ms_umod_configfile
  • clearElemRefs() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • clearEntries() : ms_taxonomyfile , ms_wwwoptions
  • clearEnzymes() : ms_enzymefile
  • clearExcludeTaxonomies() : ms_taxonomychoice
  • clearExclusions() : ms_quant_method
  • clearFragments() : ms_fragmentvector
  • clearGencodeFiles() : ms_taxonomyrules
  • clearHeaderFields() : ms_quantitation
  • clearHitRatioExcluded() : ms_ms1quant_match
  • clearHitRatioOutlier() : ms_ms1quant_match
  • clearIgnoreDupeAccessions() : ms_mascotoptions
  • clearIgnoreMasses() : ms_modification
  • clearIgnores() : ms_umod_modification , ms_quant_localdef
  • clearIncludeTaxonomies() : ms_taxonomychoice
  • clearInstruments() : ms_fragrulesfile
  • clearIonSeries() : ms_quant_multiplex
  • clearIsotopes() : ms_quant_component
  • clearLinkers() : ms_crosslinking_linkers
  • clearLocalDefinitions() : ms_quant_modgroup
  • clearMatchedIon() : ms_fragment
  • clearMethods() : ms_crosslinking_configfile , ms_quant_configfile
  • clearModBricks() : ms_umod_configfile
  • clearModFiles() : ms_quant_modgroup
  • clearModificationGroups() : ms_quant_component , ms_quant_method
  • clearModifications() : ms_modvector , ms_modfile , ms_umod_configfile
  • clearModifiedResidues() : ms_modification
  • clearMonoLinks() : ms_crosslinking_linker
  • clearNeutralLosses() : ms_quant_specificity , ms_umod_specificity
  • clearNoBreakDescLineIf() : ms_taxonomyrules
  • clearNodesFiles() : ms_taxonomyrules
  • clearNumerators() : ms_quant_ratio
  • clearParam() : ms_group , ms_session , ms_user
  • clearParameters() : ms_crosslinking_parameters , ms_quant_parameters , ms_xml_parameters
  • clearParams() : ms_security_task
  • clearParseRules() : ms_parseoptions
  • clearPepNeutralLosses() : ms_quant_specificity , ms_umod_specificity
  • clearPeptideQuantKeys() : ms_customquantitation
  • clearPeptideRatios() : ms_customquantitation
  • clearPeptides() : ms_quant_normalisation_peptides
  • clearPerDbSrcRules() : ms_taxonomyrules
  • clearPrefixRemoves() : ms_taxonomyrules
  • clearProcessors() : ms_processoroptions
  • clearProteins() : ms_quant_normalisation_proteins
  • clearRawFileFields() : ms_quantitation
  • clearReloadableInfo() : ms_peptide
  • clearReportNumberChoices() : ms_mascotoptions
  • clearReportRatios() : ms_quant_method
  • clearSampleValues() : ms_shapiro_wilk
  • clearSeqs() : ms_quant_method
  • clearSeries() : ms_fragmentationrules
  • clearSpeciesFiles() : ms_taxonomyrules
  • clearSpecificities() : ms_quant_localdef , ms_umod_modification
  • clearSubClusters() : ms_clusterparams
  • clearSuffixRemoves() : ms_taxonomyrules
  • clearTargetFDRPercentages() : ms_mascotoptions
  • clearThreads() : ms_dbprocessors
  • clearUnmodified() : ms_quant_modgroup
  • clearXrefs() : ms_umod_modification
  • closeHandles() : ms_http_helper_handles
  • closeIndexFile() : ms_tinycdb
  • cluster() : ms_treecluster
  • CMD_ARGUMENT_PARSE_COLLISION : ms_fileutilities
  • CMD_ARGUMENT_PARSE_INVALIDCHAR : ms_fileutilities
  • CMD_ARGUMENT_PARSE_OK : ms_fileutilities
  • CMD_ARGUMENT_PARSE_RESULT : ms_fileutilities
  • CMD_ARGUMENT_PARSE_UNBALANCED : ms_fileutilities
  • CMPXML_IGN_COL_SIZE_EQ_ONE : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_100_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_10_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_1_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_IDENTICAL : ms_fileutilities
  • CMPXML_IGN_FILE_URL : ms_fileutilities
  • CMPXML_IGN_INF_999999 : ms_fileutilities
  • CMPXML_IGN_RAWFILE_NAME : ms_fileutilities
  • CMPXML_IGN_TODAY_DATE : ms_fileutilities
  • CMPXML_NO_FLAG : ms_fileutilities
  • CMPXML_STRIP_TRAILING_ZEROS : ms_fileutilities
  • COL_ASC_TIME : ms_logger
  • COL_HEADERS : ms_logger
  • COL_IP_ADDRESS : ms_logger
  • COL_ISO8601_TIME : ms_logger
  • COL_LOGGER_DEFAULTS : ms_logger
  • COL_MSG : ms_logger
  • COL_MSG_NUM_DEC : ms_logger
  • COL_MSG_NUM_HEX : ms_logger
  • COL_MSG_SOURCE_TXT : ms_logger
  • COL_QUOTES : ms_logger
  • COL_SEVERITY_NUM : ms_logger
  • COL_SEVERITY_TXT : ms_logger
  • COL_SRC_FILE : ms_logger
  • COL_SRC_LINENUM : ms_logger
  • COL_THREAD_ID : ms_logger
  • COL_TSV : ms_logger
  • columnMatrix() : ms_matrix
  • compareXmlFiles() : ms_fileutilities
  • compareXMLFiles_flags : ms_fileutilities
  • COMPATIBLE : ms_quant_method
  • COMPATIBLE_DIFF_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_DIFF_LOCAL_MOD : ms_quant_method
  • COMPATIBLE_DIFF_NUM_COMPONENTS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_ISOTOPES : ms_quant_method
  • COMPATIBLE_DIFF_NUM_LOCAL_MODS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MOD_GROUPS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MODS : ms_quant_method
  • COMPATIBLE_DIFF_PROTOCOL : ms_quant_method
  • COMPATIBLE_MISSING_COMPONENT : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_MISSING_MOD : ms_quant_method
  • COMPATIBLE_MISSING_MOD_GROUP : ms_quant_method
  • compressMore() : ms_zip
  • connectionSettings() : ms_http_client , ms_http_helper
  • containsVarModIdx() : ms_linker_site_vector
  • convertFromLogLevel() : ms_errs
  • convertToLogLevel() : ms_errs
  • copyFrom() : ms_quant_normalisation_peptides , ms_crosslinking_accessions , ms_crosslinking_linker , ms_quant_numerator , ms_peptide_quant_ratio , ms_quant_neutralloss , ms_umod_neutralloss , ms_quant_ratio , ms_quant_normalisation , ms_crosslinking_parameter , ms_quant_precursor , ms_quant_pepneutralloss , ms_umod_neutralloss , ms_customproperty , ms_umod_specificity , ms_quant_multiplex , ms_quant_normalisation_proteins , ms_distiller_data , ms_quant_parameter , ms_distiller_master_project , ms_quant_parameters , ms_taxonomytree , ms_datfile , ms_umod_modbrick , ms_crosslinking_scope , ms_fragmentationrules , ms_quant_specificity , ms_quant_localdef , ms_quant_satellite , ms_http_client_search , ms_umod_xref , ms_quant_unmodified , ms_processors , ms_license , ms_spectral_lib_peak , ms_spectral_lib_entry , ms_quant_protocol , ms_quant_replicate , ms_wwwentry , ms_umod_specificity , ms_protein , ms_masses , ms_taxspeciesfiles , ms_taxonomyfile , ms_http_helper , ms_modvector , ms_xic , ms_taxnodesfiles , ms_errors , ms_parserule , ms_umod_neutralloss , ms_taxonomyrules , ms_databases , ms_spectral_lib_peak_list , ms_crosslinking_parameters , ms_wwwoptions , ms_crosslinking_linkers , ms_quant_average , ms_umod_composition , ms_crosslinking_accession , ms_cronoptions , ms_quant_configfile , ms_aahelper , ms_processoroptions , ms_crosslinking_settings , ms_crosslinking_method , ms_zip , ms_crosslinking_monolink , ms_crosslinking_does_not_pair_with , ms_treecluster , ms_quant_moverz , ms_umod_composition , ms_umod_modification , ms_umod_configfile , ms_umod_modification , ms_computeraddress , ms_quant_normalisation_protein , ms_crosslinking_filters , ms_crosslinking_configfile , ms_umod_modification , ms_quant_outliers , ms_clusterparams , ms_unigeneoptions , ms_umod_aminoacid , ms_quant_isotope , ms_quant_modgroup , ms_umod_element , ms_dbprocessors , ms_umod_elemref , ms_fragment , ms_quant_integration , ms_http_client , ms_quant_reporter , ms_libraryoptions , ms_modfile , ms_mascotfiles , ms_security_options , ms_mascotresults_params , ms_xml_parameter , ms_modvector , ms_taxonomychoice , ms_obofile , ms_databaseoptions , ms_quant_quality , ms_parserule_plus , ms_protein_quant_ratio , ms_cronjob , ms_quant_composition , ms_quant_element , ms_quant_method , ms_umod_elemref , ms_quant_correction , ms_connection_settings , ms_quant_normalisation_peptide , ms_quant_component , ms_distiller_search_status_list , ms_mascotoptions , ms_modfile , ms_peptide_quant_key_vector , ms_parseoptions , ms_peptide , ms_fragrulesfile , ms_fragmentvector , ms_linker_site , ms_linker_site_vector , ms_modification , ms_masses , ms_enzyme , ms_http_client_session , ms_enzymefile
  • copyMassFile() : ms_modification
  • countDistinctPeptides() : ms_ms2quantitation , ms_ms1quantitation , ms_quantitation
  • CP_BADNEWPASSWORD : ms_http_client
  • CP_INCORRECTPASSWORD : ms_http_client
  • CP_SUCCESS : ms_http_client
  • CP_UNKNOWNUSER : ms_http_client
  • CP_UNSPECIFIEDERROR : ms_http_client
  • createCrosslinkedPeptide() : ms_aahelper
  • createDefaults() : ms_security
  • createDirectory() : ms_fileutilities
  • createMissingComponents() : ms_quant_helper
  • createPeptide() : ms_aahelper
  • createSummary() : ms_peptidesummary , ms_mascotresults
  • createUnassignedList() : ms_mascotresults
  • CTERM_CUTTER : ms_enzyme
  • cuttertype : ms_enzyme
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data() : ms_matrix
  • DB_MATCH_TYPE : ms_mascotresults
  • DECOY_ALGORITHM : ms_mascotoptions
  • DECOY_ALGORITHM_NONE : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PEPTIDE_REVERSE : ms_mascotoptions
  • DECOY_PEPTIDE_SHUFFLE : ms_mascotoptions
  • DECOY_PROTEIN_BASED_MASK : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PROTEIN_REVERSE : ms_mascotoptions
  • DECOY_PROTEIN_SHUFFLE : ms_mascotoptions
  • DECOY_STATS_COUNT_TYPE : ms_mascotresults
  • defaultValues() : ms_clusterparams , ms_crosslinking_scope , ms_quant_modgroup , ms_quant_moverz , ms_crosslinking_settings , ms_quant_multiplex , ms_quant_neutralloss , ms_computeraddress , ms_customproperty , ms_quant_normalisation , ms_quant_normalisation_peptide , ms_databaseoptions , ms_quant_normalisation_peptides , ms_quant_normalisation_protein , ms_connection_settings , ms_databases , ms_quant_normalisation_proteins , ms_quant_numerator , ms_datfile , ms_quant_outliers , ms_quant_parameters , ms_cronjob , ms_enzyme , ms_quant_pepneutralloss , ms_quant_precursor , ms_enzymefile , ms_quant_protocol , ms_quant_quality , ms_cronoptions , ms_fragmentationrules , ms_quant_ratio , ms_quant_replicate , ms_fragrulesfile , ms_quant_reporter , ms_quant_satellite , ms_crosslinking_accession , ms_libraryoptions , ms_quant_specificity , ms_quant_unmodified , ms_license , ms_taxonomychoice , ms_taxonomyfile , ms_crosslinking_accessions , ms_mascotfiles , ms_taxspeciesfiles , ms_taxnodesfiles , ms_mascotoptions , ms_parserule_plus , ms_taxonomyrules , ms_crosslinking_configfile , ms_masses , ms_treecluster , ms_umod_aminoacid , ms_modification , ms_umod_composition , ms_umod_configfile , ms_crosslinking_does_not_pair_with , ms_modfile , ms_umod_element , ms_umod_elemref , ms_obofile , ms_umod_modbrick , ms_umod_modification , ms_crosslinking_filters , ms_parserule , ms_umod_neutralloss , ms_umod_specificity , ms_parseoptions , ms_umod_xref , ms_unigeneoptions , ms_crosslinking_linker , ms_dbprocessors , ms_wwwentry , ms_wwwoptions , ms_processoroptions , ms_xic , ms_xml_parameter , ms_crosslinking_linkers , ms_quant_average , ms_xml_parameters , ms_quant_component , ms_crosslinking_method , ms_quant_element , ms_quant_composition , ms_crosslinking_monolink , ms_quant_configfile , ms_quant_correction , ms_aahelper , ms_crosslinking_parameter , ms_quant_integration , ms_quant_isotope , ms_crosslinking_parameters , ms_quant_localdef , ms_quant_method
  • deleteAccessionByNumber() : ms_crosslinking_accessions
  • deleteAltName() : ms_umod_modification
  • deleteAminoAcidByName() : ms_umod_configfile
  • deleteAminoAcidByNumber() : ms_umod_configfile
  • deleteComponentByName() : ms_quant_method
  • deleteComponentByNumber() : ms_quant_method
  • deleteCorrection() : ms_quant_component
  • deleteCronJob() : ms_cronoptions
  • deleteDatabaseByName() : ms_databases
  • deleteDatabaseByNumber() : ms_databases
  • deleteDenominatorByName() : ms_quant_ratio
  • deleteDenominatorByNumber() : ms_quant_ratio
  • deleteDirectory() : ms_fileutilities
  • deleteDoesNotPairWithByNumber() : ms_crosslinking_linker
  • deleteElement() : ms_quant_composition
  • deleteElementByName() : ms_umod_configfile
  • deleteElementByNumber() : ms_umod_configfile
  • deleteElemRef() : ms_umod_modbrick , ms_umod_aminoacid , ms_umod_composition
  • deleteEnzymeByName() : ms_enzymefile
  • deleteEnzymeByNumber() : ms_enzymefile
  • deleteExclusion() : ms_quant_method
  • deleteGroup() : ms_security
  • deleteIgnore() : ms_quant_localdef , ms_umod_modification
  • deleteInstrumentByName() : ms_fragrulesfile
  • deleteInstrumentByNumber() : ms_fragrulesfile
  • deleteIonSeries() : ms_quant_multiplex
  • deleteIsotope() : ms_quant_component
  • deleteLinkerByNumber() : ms_crosslinking_linkers
  • deleteLocalDefinition() : ms_quant_modgroup
  • deleteMethodByName() : ms_crosslinking_configfile , ms_quant_configfile
  • deleteMethodByNumber() : ms_crosslinking_configfile , ms_quant_configfile
  • deleteModBrickByName() : ms_umod_configfile
  • deleteModBrickByNumber() : ms_umod_configfile
  • deleteModFile() : ms_quant_modgroup
  • deleteModificationByName() : ms_modfile , ms_umod_configfile
  • deleteModificationByNumber() : ms_modfile , ms_umod_configfile
  • deleteModificationGroupByName() : ms_quant_component , ms_quant_method
  • deleteModificationGroupByNumber() : ms_quant_component , ms_quant_method
  • deleteMonoLinkByNumber() : ms_crosslinking_linker
  • deleteNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • deleteNumeratorByName() : ms_quant_ratio
  • deleteNumeratorByNumber() : ms_quant_ratio
  • deleteParameterByName() : ms_crosslinking_parameters , ms_quant_parameters , ms_xml_parameters
  • deleteParameterByNumber() : ms_crosslinking_parameters , ms_quant_parameters , ms_xml_parameters
  • deletePepNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • deletePeptide() : ms_quant_normalisation_peptides
  • deleteProtein() : ms_quant_normalisation_proteins
  • deleteReportRatioByName() : ms_quant_method
  • deleteReportRatioByNumber() : ms_quant_method
  • deleteSeq() : ms_quant_method
  • deleteSpecificity() : ms_quant_localdef , ms_umod_modification
  • deleteUnmodified() : ms_quant_modgroup
  • deleteUser() : ms_security , ms_group
  • deleteXref() : ms_umod_modification
  • delNonEmpty() : ms_customproperty
  • delProp() : ms_customproperty
  • delPropByNumber() : ms_customproperty
  • delPropStart() : ms_customproperty
  • DEPRECATED_MAX_CORES_PER_LICENSE : ms_processors
  • destroy() : ms_session
  • detectOutliers() : ms_quant_stats
  • diagonalMatrix() : ms_matrix
  • DISTINCT_PEPTIDE_FLAGS : ms_protein
  • DM_BOTH : ms_mascotresults
  • DM_FASTA : ms_mascotresults
  • DM_FASTA_FIRST_PASS : ms_mascotresults
  • DM_FASTA_SECOND_PASS : ms_mascotresults
  • DM_SPECTRAL_LIBRARY : ms_mascotresults
  • DO_NORMAL : ms_http_client_search
  • DO_WITH_IONS : ms_http_client_search
  • doesFileExist() : ms_fileutilities
  • doesSectionExist() : ms_mascotresfile
  • downloadDaemonResultsFile() : ms_http_client_search
  • DownloadOption : ms_http_client_search
  • downloadPercolatorFile() : ms_http_client_search
  • downloadResultsFile() : ms_http_client_search
  • downloadXmlResultsFile() : ms_http_client_search
  • DPF_CHARGE : ms_protein
  • DPF_MODS : ms_protein
  • DPF_NODUPSAMEQUERY : ms_protein
  • DPF_SEQUENCE : ms_protein
  • DPF_UNIQUE : ms_protein
  • dropAccession() : ms_quant_normalisation_protein
  • dropAccessions() : ms_crosslinking_method
  • dropAllChargeStates() : ms_quant_integration , ms_quant_precursor
  • dropAllChargeStatesThreshold() : ms_quant_integration
  • dropAllowElutionShift() : ms_quant_precursor , ms_quant_integration
  • dropAllowMassTimeMatch() : ms_quant_precursor
  • dropApproved() : ms_umod_modification
  • dropAverage() : ms_quant_moverz
  • dropAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • dropClassification() : ms_umod_specificity
  • dropCode() : ms_umod_neutralloss
  • dropCoefficient() : ms_quant_numerator
  • dropComp() : ms_quant_method
  • dropCompositionString() : ms_umod_composition
  • dropConstrainSearch() : ms_quant_method
  • dropDatabaseName() : ms_crosslinking_accession
  • dropDateTimeModified() : ms_umod_modification
  • dropDateTimePosted() : ms_umod_modification
  • dropDelta() : ms_quant_localdef , ms_umod_modification
  • dropDescription() : ms_quant_method , ms_crosslinking_method , ms_umod_neutralloss , ms_xml_parameter
  • dropElement() : ms_quant_correction
  • dropElutionProfileCorrelationThreshold() : ms_quant_integration
  • dropElutionTimeDelta() : ms_quant_integration
  • dropElutionTimeDeltaUnit() : ms_quant_integration
  • dropEntry() : ms_wwwoptions
  • dropExcludeInternalLabel() : ms_quant_multiplex
  • dropExcludeIsobaricFragments() : ms_quant_multiplex
  • dropFileIndex() : ms_quant_component
  • dropFilters() : ms_crosslinking_method
  • dropFlag() : ms_quant_neutralloss , ms_umod_neutralloss
  • dropFullName() : ms_umod_modbrick , ms_umod_element , ms_umod_modification , ms_umod_aminoacid
  • dropGroupOfPoster() : ms_umod_modification
  • dropHidden() : ms_umod_specificity
  • dropIntegration() : ms_quant_method
  • dropIonIntensityThreshold() : ms_quant_multiplex
  • dropIonSeries() : ms_quant_multiplex
  • dropIsolatedPrecursor() : ms_quant_quality
  • dropIsolatedPrecursorThreshold() : ms_quant_quality
  • dropLinkers() : ms_crosslinking_method
  • dropMassDelta() : ms_quant_integration
  • dropMassDeltaUnit() : ms_quant_integration
  • dropMatchedRho() : ms_quant_integration
  • dropMethod() : ms_quant_integration , ms_quant_outliers , ms_quant_normalisation
  • dropMinimumA1() : ms_quant_quality
  • dropMinIonPairs() : ms_quant_multiplex
  • dropMinNumPeptides() : ms_quant_method
  • dropMinPrecursorCharge() : ms_quant_quality
  • dropMiscNotes() : ms_umod_specificity , ms_umod_modification
  • dropMode() : ms_quant_modgroup
  • dropModFileName() : ms_crosslinking_linker , ms_crosslinking_does_not_pair_with
  • dropModifications() : ms_quant_satellite
  • dropMonoisotopic() : ms_quant_moverz
  • dropMonoMass() : ms_umod_element , ms_umod_aminoacid , ms_umod_modbrick , ms_umod_composition
  • dropMoverz() : ms_quant_component
  • dropName() : ms_quant_component , ms_quant_ratio , ms_xml_parameter , ms_quant_method , ms_crosslinking_method , ms_quant_modgroup , ms_quant_numerator
  • dropNew() : ms_quant_isotope
  • dropNormalisation() : ms_quant_method
  • dropNumber() : ms_quant_element , ms_umod_elemref
  • dropNumPeptides() : ms_quant_average
  • dropOld() : ms_quant_isotope
  • dropOutliers() : ms_quant_method
  • dropPairsWith() : ms_umod_neutralloss
  • dropParseRule() : ms_parseoptions
  • dropPepThresholdType() : ms_quant_quality
  • dropPepThresholdValue() : ms_quant_quality
  • dropPeptides() : ms_quant_normalisation
  • dropPosition() : ms_umod_specificity , ms_quant_specificity , ms_quant_unmodified
  • dropPrecursorRange() : ms_quant_integration
  • dropProcessingOptions() : ms_quant_integration
  • dropProteinRatioType() : ms_quant_method
  • dropProteins() : ms_quant_normalisation
  • dropProtocol() : ms_quant_method
  • dropProtScoreType() : ms_quant_method
  • dropQuality() : ms_quant_method
  • dropRecordID() : ms_umod_modification
  • dropReferenceAccession() : ms_quant_average
  • dropReferenceAmount() : ms_quant_average
  • dropReferenceDatabase() : ms_quant_average
  • dropReportDetail() : ms_quant_method
  • dropReporterTol() : ms_quant_reporter
  • dropReporterTolUnit() : ms_quant_reporter
  • dropRequireBoldRed() : ms_quant_method
  • dropRequired() : ms_quant_modgroup , ms_quant_pepneutralloss
  • dropSatellite() : ms_quant_component
  • dropScope() : ms_crosslinking_method
  • dropSelection() : ms_quant_average
  • dropSequence() : ms_quant_normalisation_peptide
  • dropSettings() : ms_crosslinking_method
  • dropShift() : ms_quant_correction
  • dropShowSubSets() : ms_quant_method
  • dropSigThresholdValue() : ms_quant_method
  • dropSimpleRatio() : ms_quant_integration
  • dropSite() : ms_quant_unmodified , ms_umod_specificity , ms_quant_specificity
  • dropSource() : ms_umod_xref , ms_quant_integration
  • dropSpecGroup() : ms_umod_specificity
  • dropSpectralLibrary() : ms_libraryoptions
  • dropStrategy() : ms_crosslinking_method
  • dropSymbol() : ms_umod_elemref , ms_quant_element
  • dropText() : ms_umod_xref
  • dropThreeLetter() : ms_umod_aminoacid
  • dropTitle() : ms_umod_modbrick , ms_umod_aminoacid , ms_umod_element , ms_quant_localdef , ms_umod_modification
  • dropTotalIntensity() : ms_quant_quality
  • dropTotalIntensityThreshold() : ms_quant_quality
  • dropType() : ms_quant_correction
  • dropUniquePepseq() : ms_quant_quality
  • dropUrl() : ms_umod_xref
  • dropUsernameOfPoster() : ms_umod_modification
  • dropValue() : ms_crosslinking_accession
  • dropXicMaxWidth() : ms_quant_integration
  • dropXicSmoothing() : ms_quant_integration
  • dropXicThreshold() : ms_quant_integration
  • DS_COUNT_PSM : ms_mascotresults
  • DS_COUNT_SEQUENCE : ms_mascotresults
  • dumpCDB() : ms_peptidesummary
  • DUPE_Duplicate : ms_protein
  • DUPE_DuplicateSameQuery : ms_protein
  • DUPE_HighestScoringDuplicate : ms_protein
  • DUPE_Ignored : ms_protein
  • DUPE_NotDuplicate : ms_protein
  • DUPLICATE : ms_protein
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • eAuto : ms_distiller_data_search
  • editedByDatabaseManager() : ms_datfile
  • eFASTA : ms_distiller_data_search
  • eGroupAuto : ms_distiller_data_search
  • eGroupFamily : ms_distiller_data_search
  • eGrouping : ms_distiller_data_search
  • eGroupStandard : ms_distiller_data_search
  • eIntegrated : ms_distiller_data_search
  • eLibrary : ms_distiller_data_search
  • empty() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • eMudpit : ms_distiller_data_search
  • enumerateQuerySectionKeys() : ms_mascotresfile
  • enumerateSectionKeys() : ms_mascotresfile
  • erase() : ms_http_client_mime
  • err : ms_mascotresfile , ms_errs
  • ERR_ABORTEDBYUSER : ms_http_helper_return
  • ERR_ACCINPEPTIDESTR : ms_errs , ms_mascotresfile
  • ERR_ADDPEPTIDES : ms_errs , ms_mascotresfile
  • ERR_CANNOT_APPEND_RESFILE : ms_errs , ms_mascotresfile
  • ERR_CANNOT_APPEND_RESFILE_NO_FNAMES : ms_errs , ms_mascotresfile
  • ERR_CDB_64_BIT_REMAKE : ms_errs , ms_mascotresfile
  • ERR_CDB_BEING_CREATED : ms_errs , ms_mascotresfile
  • ERR_CDB_FAIL_LOCK : ms_mascotresfile , ms_errs
  • ERR_CDB_FAIL_REMOVE : ms_errs , ms_mascotresfile
  • ERR_CDB_FAIL_UNLOCK : ms_errs , ms_mascotresfile
  • ERR_CDB_INCOMPLETE_NO_RETRY : ms_errs , ms_mascotresfile
  • ERR_CDB_INCOMPLETE_RETRY : ms_errs , ms_mascotresfile
  • ERR_CDB_OLD_VER_NO_RETRY : ms_errs , ms_mascotresfile
  • ERR_CDB_OLD_VER_RETRY : ms_errs , ms_mascotresfile
  • ERR_CDB_SOURCE_CHANGE_NO_RETRY : ms_errs , ms_mascotresfile
  • ERR_CDB_SOURCE_CHANGE_RETRY : ms_errs , ms_mascotresfile
  • ERR_CDB_TOO_LARGE : ms_errs , ms_mascotresfile
  • ERR_DUPE_ACCESSION : ms_errs , ms_mascotresfile
  • ERR_DUPLICATE_KEY : ms_errs , ms_mascotresfile
  • ERR_FAIL_CDB_INIT : ms_errs , ms_mascotresfile
  • ERR_FAIL_CLOSE_FILE : ms_errs , ms_mascotresfile
  • ERR_FAIL_MK_CACHE_DIR : ms_errs , ms_mascotresfile
  • ERR_FAIL_MK_CDB_FILE : ms_errs , ms_mascotresfile
  • ERR_FAIL_OPEN_DAT_FILE : ms_mascotresfile , ms_errs
  • ERR_HTTP : ms_http_helper_return
  • ERR_INVALID_CACHE_DIR : ms_errs , ms_mascotresfile
  • ERR_INVALID_CDB_FILE : ms_errs , ms_mascotresfile
  • ERR_INVALID_NUMQUERIES : ms_errs , ms_mascotresfile
  • ERR_INVALID_PROTDB : ms_errs , ms_mascotresfile
  • ERR_INVALID_RESFILE : ms_errs , ms_mascotresfile
  • ERR_MALFORMED_DRANGE : ms_errs , ms_mascotresfile
  • ERR_MALFORMED_ERR_TOL : ms_errs , ms_mascotresfile
  • ERR_MALFORMED_TAG : ms_errs , ms_mascotresfile
  • ERR_MALFORMED_TERMS : ms_errs , ms_mascotresfile
  • ERR_MISSING_CDB_FILE : ms_errs , ms_mascotresfile
  • ERR_MISSING_PERCOLATOR_FILE : ms_errs , ms_mascotresfile
  • ERR_MISSINGENTRY : ms_errs , ms_mascotresfile
  • ERR_MISSINGHIT : ms_errs , ms_mascotresfile
  • ERR_MISSINGSECTION : ms_errs , ms_mascotresfile
  • ERR_MISSINGSECTIONEND : ms_errs , ms_mascotresfile
  • ERR_MSP_BIND_INVALID_CPU : ms_errs
  • ERR_MSP_CACHE_DATAOFFSETINVALID : ms_errs
  • ERR_MSP_CACHE_DUPLICATESTREAMID : ms_errs
  • ERR_MSP_CACHE_FILESEEKFAILED : ms_errs
  • ERR_MSP_CACHE_INVALIDFORMAT : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMID : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMPOSITION : ms_errs
  • ERR_MSP_CACHE_INVALIDVERSION : ms_errs
  • ERR_MSP_CACHE_MODIFYCLOSED : ms_errs
  • ERR_MSP_CACHE_MODIFYREADONLYMODE : ms_errs
  • ERR_MSP_CACHE_OPENFAILED : ms_errs
  • ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD : ms_errs
  • ERR_MSP_CACHE_READFAILED : ms_errs
  • ERR_MSP_CACHE_SIGNATUREINVALID : ms_errs
  • ERR_MSP_CACHE_SLREF_UPDATE : ms_errs
  • ERR_MSP_CACHE_STREAMNOTFOUND : ms_errs
  • ERR_MSP_CACHE_UNINITIALISEDSTREAM : ms_errs
  • ERR_MSP_CACHE_WRITEFAILED : ms_errs
  • ERR_MSP_CACHE_WRITETRUNCATED : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_ET : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_COLOURSCHEME_INVALID : ms_errs
  • ERR_MSP_COMPILE_PARSE_RULE : ms_errs
  • ERR_MSP_CONFLICT_BETWEEN_MODS : ms_errs
  • ERR_MSP_CRON_INVALID_CHAR : ms_errs
  • ERR_MSP_CRON_INVALID_NUMBER : ms_errs
  • ERR_MSP_CRON_INVALID_STAR : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_COMMA : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_MINUS : ms_errs
  • ERR_MSP_CRON_TOO_MANY_JOBS : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDLOAD : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDSAVE : ms_errs
  • ERR_MSP_CROSSLINKING_INVALID_LINK : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_LINKS : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_PEPTIDE : ms_errs
  • ERR_MSP_CROSSLINKING_VARMOD_CONFLICT : ms_errs
  • ERR_MSP_CUSTQUANT_FAILEDINIT : ms_errs
  • ERR_MSP_CUSTQUANT_PROTR_UNIM : ms_errs
  • ERR_MSP_DB_USES_MISSING_RULE : ms_errs
  • ERR_MSP_DIFFERENT_1ST_PASS_THR_ET : ms_errs
  • ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED : ms_errs
  • ERR_MSP_DUP_TAXONOMYRULE : ms_errs
  • ERR_MSP_DUPLICATE_MOD : ms_errs
  • ERR_MSP_EMPTY_MOD : ms_errs
  • ERR_MSP_ENZYME_DEFINITION_PROBLEM : ms_errs
  • ERR_MSP_ENZYME_FILE_FORMAT : ms_errs
  • ERR_MSP_ENZYME_TOO_MANY_RULES : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_INVALID : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_LOGGING : ms_errs
  • ERR_MSP_FAIL_GET_PROCESS_AFFINITY : ms_errs
  • ERR_MSP_FAIL_GET_SYSINFO : ms_errs
  • ERR_MSP_FAIL_HWLOC_INIT : ms_errs
  • ERR_MSP_FAIL_HWLOC_LOAD : ms_errs
  • ERR_MSP_FAIL_PROCESSOR_BIND : ms_errs
  • ERR_MSP_FAIL_STAT : ms_errs
  • ERR_MSP_FAIL_THREAD_BIND : ms_errs
  • ERR_MSP_FAIL_UTIME : ms_errs
  • ERR_MSP_FAILED_TO_CLOSE_FILE : ms_errs
  • ERR_MSP_FAILED_TO_OPEN_FILE : ms_errs
  • ERR_MSP_FAILED_TO_WRITE_FILE : ms_errs
  • ERR_MSP_FILE_DOESNT_EXIST : ms_errs
  • ERR_MSP_FRAGMENTATION_RULES : ms_errs
  • ERR_MSP_GET_VOLUME_INFO : ms_errs
  • ERR_MSP_HTTP_ABORTEDBYUSER : ms_errs
  • ERR_MSP_HTTP_BADHTTPSTATUS : ms_errs
  • ERR_MSP_HTTP_CHANGEPASSWORDDISABLED : ms_errs
  • ERR_MSP_HTTP_CLOSECONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSEREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSESESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_DOWNLOADFAILED : ms_errs
  • ERR_MSP_HTTP_ERROR : ms_errs
  • ERR_MSP_HTTP_GETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_GETRESULTSFILENAME : ms_errs
  • ERR_MSP_HTTP_HEADERFAILED : ms_errs
  • ERR_MSP_HTTP_INVALID_URL : ms_errs
  • ERR_MSP_HTTP_LOGINERROR : ms_errs
  • ERR_MSP_HTTP_LOGINERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERRORINT : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONS10FAILED : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONSFAILED : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGINERROR : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGININFO : ms_errs
  • ERR_MSP_HTTP_NORESPONSE : ms_errs
  • ERR_MSP_HTTP_OPENCONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_OPENOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_OPENREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_OPENSESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYDATAFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYSTATUSFAILED : ms_errs
  • ERR_MSP_HTTP_READDATAFAILED : ms_errs
  • ERR_MSP_HTTP_READRESPONSEFAILED : ms_errs
  • ERR_MSP_HTTP_RELOGINFAILED : ms_errs
  • ERR_MSP_HTTP_SENDREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_SESSIONALREADYOPEN : ms_errs
  • ERR_MSP_HTTP_SETHTTPPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETREDIRECTFAILED : ms_errs
  • ERR_MSP_HTTP_TRANSMISSION_FAILED : ms_errs
  • ERR_MSP_HTTP_VERSIONERROR : ms_errs
  • ERR_MSP_HTTP_WEBAUTHERROR : ms_errs
  • ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_XMLUPLOADFAILED : ms_errs
  • ERR_MSP_IN_CLUSTER_SECTION : ms_errs
  • ERR_MSP_IN_MASCOT_DAT_DB_SECT : ms_errs
  • ERR_MSP_IN_MASSES_FILE : ms_errs
  • ERR_MSP_IN_MODS_FILE : ms_errs
  • ERR_MSP_IN_OPTIONS_SECTION : ms_errs
  • ERR_MSP_IN_TAXONOMY_SECTION : ms_errs
  • ERR_MSP_INCOMPATIBLE_TAX_RULES : ms_errs
  • ERR_MSP_INST_CANTGETHOSTNAME : ms_errs
  • ERR_MSP_INST_FAILADDPARSERULE : ms_errs
  • ERR_MSP_INST_INVALIDCPUINFO : ms_errs
  • ERR_MSP_INST_MISSINGDATABASE : ms_errs
  • ERR_MSP_INVALID_CPU_PACKAGE_NUM : ms_errs
  • ERR_MSP_INVALID_LOGICAL_CPU_NUM : ms_errs
  • ERR_MSP_INVALID_MASS_IN_MASSES_FILE : ms_errs
  • ERR_MSP_INVALID_NUM_LICENSED : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE_NO : ms_errs
  • ERR_MSP_INVALID_PROCESSOR_LINE : ms_errs
  • ERR_MSP_LICENSE_DES_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_EXPIRED : ms_errs
  • ERR_MSP_LICENSE_INTERNAL_CONFIG : ms_errs
  • ERR_MSP_LICENSE_LINE_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_LINE_INVALID : ms_errs
  • ERR_MSP_LICENSE_NOT_YET_AVAIL : ms_errs
  • ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED : ms_errs
  • ERR_MSP_MALFORMED_PEPTIDE : ms_errs
  • ERR_MSP_MASCOT_NOT_RUNNING : ms_errs
  • ERR_MSP_MAX_PREFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_SUFFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_TAX_NO_BREAKS : ms_errs
  • ERR_MSP_MISSING_DEFINITION_END : ms_errs
  • ERR_MSP_MISSING_ENZYME_TITLE : ms_errs
  • ERR_MSP_MISSING_ET_MOD : ms_errs
  • ERR_MSP_MISSING_MASCOT_DAT : ms_errs
  • ERR_MSP_MISSING_MONOLINK_MOD : ms_errs
  • ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE : ms_errs
  • ERR_MSP_MISSING_SECTION : ms_errs
  • ERR_MSP_MISSING_SL_MOD : ms_errs
  • ERR_MSP_MOD_MUST_BE_VAR : ms_errs
  • ERR_MSP_MS1QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_DROP : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_NEW : ms_errs
  • ERR_MSP_MS2QUANTITATION_COMPONENTS : ms_errs
  • ERR_MSP_MS2QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_NO_SUM : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_UNIMP : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTR_UNIM : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTWEIGH : ms_errs
  • ERR_MSP_MS2QUANTITATION_QUERY_SECS : ms_errs
  • ERR_MSP_NEED_1_EXP_IN_PARSE_RULE : ms_errs
  • ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK : ms_errs
  • ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY : ms_errs
  • ERR_MSP_NIST_INDEX_OUT_OF_RANGE : ms_errs
  • ERR_MSP_NIST_MODIFICATION_NOT_FOUND : ms_errs
  • ERR_MSP_NIST_MSP_INCONSISTENT_MODS : ms_errs
  • ERR_MSP_NIST_MSP_INVALID_LINE : ms_errs
  • ERR_MSP_NIST_MSP_MISSING_PARAMETER : ms_errs
  • ERR_MSP_NIST_MSP_NO_CREATE_CDB : ms_errs
  • ERR_MSP_NIST_MSP_NO_SPECTRA : ms_errs
  • ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM : ms_errs
  • ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE : ms_errs
  • ERR_MSP_NIST_SAVE_ZERO_SPECTRA : ms_errs
  • ERR_MSP_NO_COMMAS_IN_MOD_NAME : ms_errs
  • ERR_MSP_NO_ENZYME_SET : ms_errs
  • ERR_MSP_NO_LICENSE_FILE : ms_errs
  • ERR_MSP_NO_REGEX_MATCH : ms_errs
  • ERR_MSP_NO_SUCH_MOD : ms_errs
  • ERR_MSP_PARSE_LEN_EXCEED : ms_errs
  • ERR_MSP_PROCESSOR_NOT_IN_SET : ms_errs
  • ERR_MSP_QUANT_ACCESSION_NOT_FOUND : ms_errs
  • ERR_MSP_QUANT_CDB_MATCH_STREAM : ms_errs
  • ERR_MSP_QUANT_CDB_MISSING_KEY : ms_errs
  • ERR_MSP_QUANT_EMPTY_REF_ACCESSION : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_MATCH : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE : ms_errs
  • ERR_MSP_QUANT_FAILEDLOAD : ms_errs
  • ERR_MSP_QUANT_FAILEDSAVE : ms_errs
  • ERR_MSP_QUANT_HELPER_FAILEDINIT : ms_errs
  • ERR_MSP_QUANT_INVALID_REF_AMOUNT : ms_errs
  • ERR_MSP_QUANT_MISSING_COMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADCOMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADMETHOD : ms_errs
  • ERR_MSP_QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_QUANTITATION_NOMETHOD : ms_errs
  • ERR_MSP_REGEX_ERROR : ms_errs
  • ERR_MSP_REPORTBUILDERCOLARR_INVALID : ms_errs
  • ERR_MSP_RESIDUE_AND_TERMINUS_MOD : ms_errs
  • ERR_MSP_RULE_NO_ALREADY_DEFINED : ms_errs
  • ERR_MSP_SECURITY_ACCOUNT_DISABLED : ms_errs
  • ERR_MSP_SECURITY_ADDGROUP : ms_errs
  • ERR_MSP_SECURITY_ADDUSER : ms_errs
  • ERR_MSP_SECURITY_BAD_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_BAD_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_CMDLINE_CGI : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_GROUP : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_USER : ms_errs
  • ERR_MSP_SECURITY_DELETEGROUP : ms_errs
  • ERR_MSP_SECURITY_DELUSER : ms_errs
  • ERR_MSP_SECURITY_DIFFERENTIPADDR : ms_errs
  • ERR_MSP_SECURITY_DISABLE_ADMIN : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME_U : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME_U : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_GROUP : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_SEC : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_USER : ms_errs
  • ERR_MSP_SECURITY_FAIL_SAVE_SEC : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRA : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRAURL : ms_errs
  • ERR_MSP_SECURITY_GETALLGROUPIDS : ms_errs
  • ERR_MSP_SECURITY_GETALLUSERIDS : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETGROUPOK : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS1 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS2 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS3 : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSFAIL : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSOK : ms_errs
  • ERR_MSP_SECURITY_GETUSERFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETUSEROK : ms_errs
  • ERR_MSP_SECURITY_GROUPID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_INTEGRACONNFORMAT : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDCO : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDPW : ms_errs
  • ERR_MSP_SECURITY_INVALID_SESSION_ID : ms_errs
  • ERR_MSP_SECURITY_INVALIDPASSWORD : ms_errs
  • ERR_MSP_SECURITY_INVALIDSESSION : ms_errs
  • ERR_MSP_SECURITY_INVALIDUSER : ms_errs
  • ERR_MSP_SECURITY_LOADINGSESS : ms_errs
  • ERR_MSP_SECURITY_LOADSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MISSINGSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MSSESSCOOKIE : ms_errs
  • ERR_MSP_SECURITY_MSSESSINTEGRA : ms_errs
  • ERR_MSP_SECURITY_MSSESSIONCTOR : ms_errs
  • ERR_MSP_SECURITY_MSSESSLOGIN : ms_errs
  • ERR_MSP_SECURITY_MSSESSRESULTSPERM : ms_errs
  • ERR_MSP_SECURITY_NO_GUEST_PWD : ms_errs
  • ERR_MSP_SECURITY_NO_INTEGRA_LOGIN : ms_errs
  • ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR : ms_errs
  • ERR_MSP_SECURITY_NOCREATEGUEST : ms_errs
  • ERR_MSP_SECURITY_NOSAVEPARAMS : ms_errs
  • ERR_MSP_SECURITY_NOT_ADMIN_SESSION : ms_errs
  • ERR_MSP_SECURITY_NOT_ENABLED : ms_errs
  • ERR_MSP_SECURITY_NOT_INTEGRA_USER : ms_errs
  • ERR_MSP_SECURITY_NOTLOGGEDIN : ms_errs
  • ERR_MSP_SECURITY_NOTNORMALUSER : ms_errs
  • ERR_MSP_SECURITY_OLD_PW_INVALID : ms_errs
  • ERR_MSP_SECURITY_PASSWORD_TOO_SHORT : ms_errs
  • ERR_MSP_SECURITY_PASSWORDEXPIRED : ms_errs
  • ERR_MSP_SECURITY_SAMEPASSWORD : ms_errs
  • ERR_MSP_SECURITY_SAVESESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_SESSIONDESTROYED : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT1 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT2 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT3 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT4 : ms_errs
  • ERR_MSP_SECURITY_TIMEDOUT : ms_errs
  • ERR_MSP_SECURITY_UPDATEALLSESSFILES : ms_errs
  • ERR_MSP_SECURITY_UPDATEGROUP : ms_errs
  • ERR_MSP_SECURITY_UPDATEPW : ms_errs
  • ERR_MSP_SECURITY_UPDATESESS : ms_errs
  • ERR_MSP_SECURITY_UPDATEUSER : ms_errs
  • ERR_MSP_SECURITY_USERID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_USERNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 : ms_errs
  • ERR_MSP_SESSION_UTIME_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_WARN : ms_errs
  • ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR : ms_errs
  • ERR_MSP_SYSMP_FAIL : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_ET : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_TAXONOMY_CONFLICT_PARENTS : ms_errs
  • ERR_MSP_TAXONOMY_DEFINITION_END : ms_errs
  • ERR_MSP_TAXONOMY_INVALID_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_MISSING_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_NO_COMMAS : ms_errs
  • ERR_MSP_TAXONOMY_NO_TITLE : ms_errs
  • ERR_MSP_TAXONOMY_WRONG_LINE : ms_errs
  • ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE : ms_errs
  • ERR_MSP_TOO_MANY_PROCESSORS : ms_errs
  • ERR_MSP_TOO_MANY_TH_PROCESSORS : ms_errs
  • ERR_MSP_UMOD_FAILEDLOAD : ms_errs
  • ERR_MSP_UMOD_FAILEDSAVE : ms_errs
  • ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT : ms_errs
  • ERR_MSP_WRONG_ICAT_FILTER : ms_errs
  • ERR_MSP_WRONG_MOD_VECTOR : ms_errs
  • ERR_MSP_WWW_SECTION : ms_errs
  • ERR_MSP_XHUNTER_WRONG_FORMAT : ms_errs
  • ERR_MSP_XML_ELEMENT_NOT_FOUND : ms_errs
  • ERR_MSP_XML_FAILEDLOAD : ms_errs
  • ERR_MSP_XML_FAILEDSAVE : ms_errs
  • ERR_MSP_XML_FIELD_NOTFOUND : ms_errs
  • ERR_MSP_XML_INVALID_FIELD_FORMAT : ms_errs
  • ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED : ms_errs
  • ERR_MSP_XML_MEMORY_ERROR : ms_errs
  • ERR_MSP_XML_NO_ROOT_ELEMENT : ms_errs
  • ERR_MSP_XML_SYSTEM_FAILED : ms_errs
  • ERR_MSP_XML_TABLE_NOTFOUND : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDLOAD : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDSAVE : ms_errs
  • ERR_MSP_ZIP_BUFTOOSMALL : ms_errs
  • ERR_MSP_ZIP_ENDIAN : ms_errs
  • ERR_MSP_ZIP_INVALIDDATA : ms_errs
  • ERR_MSP_ZIP_LENGTHDIFFERS : ms_errs
  • ERR_MSP_ZIP_NOTSTREAMING : ms_errs
  • ERR_MSP_ZIP_OUTOFMEMORY : ms_errs
  • ERR_MSP_ZIP_STREAMERROR : ms_errs
  • ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG : ms_errs
  • ERR_MSP_ZIP_UNKNOWN : ms_errs
  • ERR_MSP_ZIP_VERSIONERROR : ms_errs
  • ERR_MSP_ZIP_ZEROLENGTH : ms_errs
  • ERR_NEED_64_BIT : ms_mascotresfile , ms_errs
  • ERR_NO_ERR_TOL_PARENT : ms_mascotresfile , ms_errs
  • ERR_NO_ERROR : ms_errs , ms_mascotresfile
  • ERR_NO_UNIGENE_FILE : ms_mascotresfile , ms_errs
  • ERR_NOMEM : ms_mascotresfile , ms_errs
  • ERR_NONE : ms_http_helper_return
  • ERR_NOSUCHFILE : ms_errs , ms_mascotresfile
  • ERR_NULL_ACC_PEP_SUM : ms_errs , ms_mascotresfile
  • ERR_NULL_ACC_PROT_SUM : ms_errs , ms_mascotresfile
  • ERR_OLDRESULTSFILE : ms_mascotresfile , ms_errs
  • ERR_PEPSUMMPEPGET : ms_errs , ms_mascotresfile
  • ERR_PEPTIDESTR : ms_errs , ms_mascotresfile
  • ERR_PROTSUMM : ms_errs , ms_mascotresfile
  • ERR_PROTSUMMPEP : ms_errs , ms_mascotresfile
  • ERR_QUERYOUTOFRANGE : ms_errs , ms_mascotresfile
  • ERR_READINGFILE : ms_mascotresfile , ms_errs
  • ERR_RESFILE_INVALID_DB_TYPE : ms_errs
  • ERR_RESFILE_LINKED_SITES : ms_errs
  • ERR_RESFILE_LOOPLINKED_SITES : ms_errs
  • ERR_RESFILE_MISSING_QEXP : ms_errs
  • ERR_RESULTS_NOT_CREATED : ms_errs , ms_mascotresfile
  • err_sar : ms_fileutilities
  • ERR_SYSTEM : ms_http_helper_return
  • ERR_UNASSIGNED_PROG : ms_errs , ms_mascotresfile
  • ERR_UNASSIGNED_RANGE : ms_errs , ms_mascotresfile
  • ERR_UNASSIGNED_UNK : ms_mascotresfile , ms_errs
  • ERR_UNIGENE_MULTIDB : ms_errs , ms_mascotresfile
  • ERR_UNSPECIFIED : ms_http_helper_return
  • ERR_WRITE_CDB_FILE : ms_mascotresfile , ms_errs
  • ErrorTypeCode : ms_http_helper_return
  • eScoring : ms_distiller_data_search
  • eSpectralLibrary : ms_distiller_data_search
  • eStandard : ms_distiller_data_search
  • eUnknown : ms_distiller_data_search
  • excludeProteinPeptideRatioKeys() : ms_ms2quantitation
  • EXEC_AFTER_SEARCH : ms_mascotoptions
  • expTransform() : ms_quant_stats
  • extend() : ms_ms1quant_match_range
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FC_ALL_PEPTIDES : ms_mascotresults
  • FC_ALL_PEPTITDES : ms_mascotresults
  • FC_CASE_INSENSITIVE : ms_mascotresults
  • FC_CASE_SENSITIVE : ms_mascotresults
  • FC_COMPLETESTR : ms_mascotresults
  • FC_FORWARD : ms_mascotresults
  • FC_LOOP_FROM_UNASSIGNED : ms_mascotresults
  • FC_LOOP_INTO_UNASSIGNED : ms_mascotresults
  • FC_MASK_CASE : ms_mascotresults
  • FC_MASK_DIRECTION : ms_mascotresults
  • FC_MASK_STR_PART : ms_mascotresults
  • FC_PROTEIN_IGN_FAMILY : ms_mascotresults
  • FC_PROTEIN_IGN_MASK : ms_mascotresults
  • FC_PROTEIN_IGN_SAMESETS : ms_mascotresults
  • FC_PROTEIN_IGN_SUBSETS : ms_mascotresults
  • FC_PROTEIN_INC_ALT_ACC : ms_mascotresults
  • FC_RESTRICT_TO_HIT : ms_mascotresults
  • FC_REVERSE : ms_mascotresults
  • FC_SCORING_MASK : ms_mascotresults
  • FC_SEARCH_ALL_RANKS : ms_mascotresults
  • FC_SEARCH_IGNORED_RANKS : ms_mascotresults
  • FC_SIGNIFICANT_PEPTIDES : ms_mascotresults
  • FC_STARTSTR : ms_mascotresults
  • FC_STRTOK : ms_mascotresults
  • FC_SUBSTR : ms_mascotresults
  • FC_UNASSIGNED_MASK : ms_mascotresults
  • FileMode : ms_http_helper
  • FIND_COMPARE_FLAGS : ms_mascotresults
  • FIND_FLAGS : ms_mascotresults
  • findClose() : ms_fileutilities
  • findDatabase() : ms_databases
  • findEntries() : ms_spectral_lib_file
  • findEntry() : ms_unigene
  • findIDFromTagValue() : ms_obofile
  • findMascotDat() : ms_fileutilities
  • findMatch() : ms_ms1quantitation
  • findModFile() : ms_quant_modgroup
  • findModFileName() : ms_umod_configfile
  • findModification() : ms_umod_configfile
  • findNext() : ms_fileutilities
  • findOpen() : ms_fileutilities
  • findPeptides() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findPeptideStatus() : ms_ms1quantitation
  • findProperty() : ms_customproperty
  • findPropertyBeginning() : ms_customproperty
  • findProteins() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findProteinsByAccession() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findProteinsByDescription() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findSpecGroup() : ms_umod_modification
  • finishCreate() : ms_tinycdb
  • FLAGS : ms_mascotresfile , ms_mascotresults
  • flush() : ms_buffer_logger
  • FM_binary : ms_http_helper
  • FM_text : ms_http_helper
  • format() : ms_http_client_mime
  • formatHeader() : ms_http_client_mime
  • formatMessage() : ms_logger
  • forwardToParentInstance() : ms_errs
  • FRAG_A_MINUS_H2O : ms_fragmentationrules
  • FRAG_A_MINUS_NH3 : ms_fragmentationrules
  • FRAG_A_SERIES : ms_fragmentationrules
  • FRAG_B_MINUS_H2O : ms_fragmentationrules
  • FRAG_B_MINUS_NH3 : ms_fragmentationrules
  • FRAG_B_SERIES : ms_fragmentationrules
  • FRAG_C_SERIES : ms_fragmentationrules
  • FRAG_D_SERIES : ms_fragmentationrules
  • FRAG_IMMONIUM : ms_fragmentationrules
  • FRAG_INTERNAL_YA : ms_fragmentationrules
  • FRAG_INTERNAL_YB : ms_fragmentationrules
  • FRAG_NL : ms_aahelper
  • FRAG_NL_PRIMARY : ms_aahelper
  • FRAG_NL_SECONDARY : ms_aahelper
  • FRAG_SERIES_TYPE : ms_fragmentationrules
  • FRAG_V_SERIES : ms_fragmentationrules
  • FRAG_W_SERIES : ms_fragmentationrules
  • FRAG_X_SERIES : ms_fragmentationrules
  • FRAG_Y_MINUS_H2O : ms_fragmentationrules
  • FRAG_Y_MINUS_NH3 : ms_fragmentationrules
  • FRAG_Y_SERIES : ms_fragmentationrules
  • FRAG_Z_PLUS_1 : ms_fragmentationrules
  • FRAG_Z_PLUS_2 : ms_fragmentationrules
  • FRAG_Z_SERIES : ms_fragmentationrules
  • freeHit() : ms_mascotresults , ms_peptidesummary
  • FT_PEPTIDE_CALC_MR : ms_mascotresults
  • FT_PEPTIDE_CALC_MZ : ms_mascotresults
  • FT_PEPTIDE_ETMOD : ms_mascotresults
  • FT_PEPTIDE_EXP_MR : ms_mascotresults
  • FT_PEPTIDE_EXP_MZ : ms_mascotresults
  • FT_PEPTIDE_FIND_MASK : ms_mascotresults
  • FT_PEPTIDE_FIXMOD : ms_mascotresults
  • FT_PEPTIDE_QUERY : ms_mascotresults
  • FT_PEPTIDE_SLMOD : ms_mascotresults
  • FT_PEPTIDE_STRING : ms_mascotresults
  • FT_PEPTIDE_VARMOD : ms_mascotresults
  • FT_PEPTIDE_VARMOD_BYNAME : ms_mascotresults
  • FT_PROTEIN_ACCESSION : ms_mascotresults
  • FT_PROTEIN_DESCRIPTION : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • geometricMean() : ms_quant_stats
  • geometricStandardDeviation() : ms_quant_stats
  • get() : ms_peptide_quant_key_vector , ms_spectral_lib_entry , ms_linker_site_vector
  • get_ms_mascotresults_params() : ms_mascotresfile , ms_distiller_data , ms_mascotresfile
  • getA() : ms_fitexy_result
  • getAbsoluteValue() : ms_ms1quant_match_component
  • getACCESSION() : ms_searchparams
  • getAccession() : ms_protein , ms_protein_quant_ratio , ms_quant_normalisation_protein
  • getAccessionByNumber() : ms_crosslinking_accessions
  • getAccessionFromNumber() : ms_spectral_lib_file
  • getAccessionParseRuleIndex() : ms_databaseoptions
  • getAccessionRefParseRuleIndex() : ms_databaseoptions
  • getAccessions() : ms_crosslinking_method
  • getAccessionSchemaType() : ms_crosslinking_accessions , ms_quant_normalisation_protein
  • getAccessionsSchemaType() : ms_crosslinking_method
  • getAccFromSpeciesLine() : ms_taxonomyrules
  • getActiveKeys() : ms_protein_quant_ratio
  • getAllChargeStatesSchemaType() : ms_quant_integration , ms_quant_precursor
  • getAllChargeStatesThreshold() : ms_quant_integration
  • getAllChargeStatesThresholdSchemaType() : ms_quant_integration
  • getAllCustomParamsForUser() : ms_security
  • getAllFamilyMembersWithThisPepMatch() : ms_mascotresults , ms_peptidesummary , ms_proteinsummary
  • getAllGroupIDs() : ms_security
  • getAllMatchedIons() : ms_fragment
  • getAllMods() : ms_spectral_lib_file
  • getAllowElutionShiftSchemaType() : ms_quant_integration , ms_quant_precursor
  • getAllowMassTimeMatchSchemaType() : ms_quant_precursor
  • getAllParamsAsString() : ms_security_task
  • getAllProteinsWithThisPepMatch() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getAllUserIDs() : ms_security , ms_group
  • getAllUSERParams() : ms_searchparams
  • getAllValuesFromKey() : ms_tinycdb
  • getAlphaVarModsStrLength() : ms_linker_site_vector
  • getAltName() : ms_umod_modification
  • getAltNameSchemaType() : ms_umod_modification
  • getAmbiguityString() : ms_peptide
  • getAminoAcidByName() : ms_umod_configfile
  • getAminoAcidByNumber() : ms_umod_configfile
  • getAnnotation() : ms_spectral_lib_peak
  • getAnyMatch() : ms_peptide
  • getAnyProteinTermination() : ms_peptide
  • getApprovedSchemaType() : ms_umod_modification
  • getAutoDetectNumThreads() : ms_processors
  • getAvePeptideIdentityThreshold() : ms_mascotresults
  • getAverage() : ms_quant_moverz , ms_quant_protocol
  • getAveragePeptideIntensity() : ms_ms1quantitation
  • getAverageResults() : ms_ms1quantitation
  • getAverageSchemaType() : ms_quant_moverz , ms_quant_protocol
  • getAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getAvgeMassAsNumber() : ms_umod_element
  • getAvgeMassSchemaType() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getB() : ms_fitexy_result
  • getBetaVarModsStrLength() : ms_linker_site_vector
  • getBoolParam() : ms_session
  • getBucket() : ms_ms1quant_charge_state
  • getBucketWidth() : ms_ms1quant_charge_state
  • getCacheDirectory() : ms_mascotoptions , ms_mascotresfile
  • getCacheFileName() : ms_distiller_data_search , ms_mascotresfile , ms_peptidesummary
  • getCacheFilename() : ms_distiller_master_search , ms_peptidesummary
  • getCacheStreamName() : ms_distiller_data_quant
  • getCarbonMass() : ms_searchparams , ms_masses
  • getCentroidWidth() : ms_mascotoptions
  • getCentroidWidthCount() : ms_mascotoptions
  • getCHARGE() : ms_searchparams
  • getCharge() : ms_fragment , ms_inputquery , ms_peptide , ms_peptide_quant_key , ms_spectral_lib_entry
  • getChargeState() : ms_ms1quant_match
  • getChargeStateData() : ms_ms1quant_match
  • getChargeType() : ms_ms1quant_match
  • getCheckNodesAliveFreq() : ms_clusterparams
  • getChecksum() : ms_spectral_lib_peak_list
  • getChecksumFromNumber() : ms_spectral_lib_file
  • getChi2() : ms_fitexy_result
  • getChopSource() : ms_parserule_plus
  • getChromosome() : ms_unigene_entry
  • getClassification() : ms_umod_specificity
  • getClassificationSchemaType() : ms_umod_specificity
  • getCLE() : ms_searchparams
  • getCleave() : ms_enzyme
  • getClusterParams() : ms_datfile
  • getCode() : ms_modification , ms_umod_neutralloss
  • getCodeFromXml() : ms_ms1quant_match , ms_ms1quant_match_ratio , ms_ms1quant_peptide_status , ms_xic
  • getCodeInfo() : ms_ms1quant_match_ratio
  • getCodeSchemaType() : ms_umod_neutralloss
  • getCoefficient() : ms_quant_numerator
  • getCoefficientSchemaType() : ms_quant_numerator
  • getColsToOutput() : ms_logger
  • getColumn() : ms_fragment
  • getCOM() : ms_searchparams
  • getCombinedPeptideSummaryCacheStreamName() : ms_distiller_master_search
  • getCombinedReportRatio() : ms_ms2quantitation
  • getCombinedReportRatioNames() : ms_ms2quantitation
  • getCombineRepeats() : ms_errs
  • getCommandStr() : ms_cronjob
  • getComment() : ms_spectral_lib_entry
  • getCommentField() : ms_spectral_lib_entry
  • getComp() : ms_inputquery , ms_quant_method
  • getComponent() : ms_protein , ms_ms1quant_match , ms_ms1quant_match_component , ms_ms1quant_peptide_status
  • getComponentByName() : ms_quant_method
  • getComponentByNumber() : ms_quant_method
  • getComponentIntensities() : ms_ms2quantitation
  • getComponentIntensity() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getComponentProtein() : ms_peptidesummary , ms_mascotresults
  • getComponentSchemaType() : ms_quant_method
  • getComponentStr() : ms_peptide
  • getComponentString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getCompositionString() : ms_umod_composition
  • getCompositionStringSchemaType() : ms_umod_composition
  • getCompressToolAA() : ms_mascotoptions
  • getCompressToolCommandLineFasta() : ms_mascotoptions
  • getCompressToolCommandLineLibrary() : ms_mascotoptions
  • getCompressToolNA() : ms_mascotoptions
  • getCompressToolSL() : ms_mascotoptions
  • getCompSchemaType() : ms_quant_method
  • getConciseLabelFreeVarMods() : ms_ms1quant_match
  • getConnectionSettings() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_umod_configfile
  • getConnectionTimeout() : ms_connection_settings
  • getConsensusData() : ms_spectral_lib_peak
  • getConstantName() : ms_security_task
  • getConstrainSearchSchemaType() : ms_quant_method
  • getContent() : ms_quant_correction , ms_quant_numerator , ms_quant_unmodified
  • getContentSchemaType() : ms_quant_correction , ms_quant_numerator , ms_quant_unmodified
  • getCoreFromLogical() : ms_processors
  • getCorrectedMaxSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedMinSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedSPPwidth() : ms_ms1quant_charge_state
  • getCorrection() : ms_quant_component
  • getCorrectionMatrix() : ms_ms1quant_match
  • getCorrectionSchemaType() : ms_quant_component
  • getCount() : ms_http_client_mime
  • getCoverage() : ms_protein
  • getCR() : ms_matrix
  • getCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • getCreatePipThreadBlockSize() : ms_mascotoptions
  • getCreatePipThreads() : ms_mascotoptions
  • getCreateSummaryProgress() : ms_mascotresults
  • getCronJob() : ms_cronoptions
  • getCronOptions() : ms_datfile
  • getCROSSLINKING() : ms_searchparams
  • getCrosslinkingMethod() : ms_mascotresfile , ms_peptidesummary
  • getCtermDelta() : ms_masses
  • getCterminalMass() : ms_masses
  • getCTerminusMass() : ms_modification
  • getCTermMass() : ms_searchparams
  • getCtermNeutralLoss() : ms_masses
  • getCurrentBytes() : ms_http_helper_progress
  • getCutterType() : ms_enzyme
  • getCytoBand() : ms_unigene_entry
  • getDatabase() : ms_databases , ms_processoroptions
  • getDatabaseName() : ms_crosslinking_accession
  • getDatabaseNameSchemaType() : ms_crosslinking_accession
  • getDatabases() : ms_datfile
  • getDatabaseType() : ms_mascotresfile
  • getDataSourceId() : ms_ms1quant_match
  • getDATAURL() : ms_searchparams
  • getDate() : ms_mascotresfile
  • getDateTimeModified() : ms_umod_modification
  • getDateTimeModifiedSchemaType() : ms_umod_modification
  • getDateTimePosted() : ms_umod_modification
  • getDateTimePostedSchemaType() : ms_umod_modification
  • getDatfile() : ms_distiller_data
  • getDB() : ms_searchparams , ms_protein , ms_protein_quant_ratio
  • getDBLevelTaxId() : ms_taxonomyrules
  • getDBType() : ms_databaseoptions
  • getDechargeFragmentPeaks() : ms_mascotoptions
  • getDECOY() : ms_searchparams
  • getDecoyTypeForDB() : ms_mascotresfile
  • getDecoyTypeNoEnzyme() : ms_mascotoptions
  • getDecoyTypeSpecific() : ms_mascotoptions
  • getDefaultDelimiter() : ms_customproperty
  • getDefaultMonitor() : ms_loggingmonitor
  • getDefaultNodeHomeDir() : ms_clusterparams
  • getDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • getDefaultNodeOS() : ms_clusterparams
  • getDefaultPasswordExpiryTime() : ms_security_options
  • getDefaultPort() : ms_clusterparams
  • getDefaultRule() : ms_taxonomyrules
  • getDefaultSchemaFileName() : ms_crosslinking_configfile , ms_umod_configfile
  • getDelimiterByNumber() : ms_customproperty
  • getDelta() : ms_peptide , ms_modification , ms_quant_localdef , ms_spectral_lib_peak , ms_umod_modification
  • getDeltaSchemaType() : ms_quant_localdef , ms_umod_modification
  • getDenominatorByName() : ms_quant_ratio
  • getDenominatorByNumber() : ms_quant_ratio
  • getDenominatorSchemaType() : ms_quant_ratio
  • getDescription() : ms_progress_info , ms_quant_method , ms_security_task , ms_umod_neutralloss , ms_xml_parameter , ms_crosslinking_method
  • getDescriptionLineSep() : ms_taxonomyrules
  • getDescriptionParseRuleIndex() : ms_databaseoptions
  • getDescriptionSchemaType() : ms_crosslinking_method , ms_crosslinking_parameter , ms_quant_method , ms_quant_parameter , ms_umod_neutralloss , ms_xml_parameter
  • getDiffsAsText() : ms_security_tasks
  • getDiscoveredErrTolModDeltas() : ms_mascotresults
  • getDiscoveredErrTolModNames() : ms_mascotresults
  • getDiscoveredLocalModDeltas() : ms_mascotresults
  • getDiscoveredLocalModNames() : ms_mascotresults
  • getDisplayIntensity() : ms_ms1quant_match
  • getDisplayNonSignificantMatches() : ms_mascotoptions
  • getDistillerProjectStreamName() : ms_distiller_data
  • getDistillerResfileTimestamp() : ms_distiller_data
  • getDistillerVersion() : ms_distiller_data
  • getDistinctPeptide() : ms_protein
  • getDistributor() : ms_license
  • getDoesNotPairWithByNumber() : ms_crosslinking_linker
  • getDoesNotPairWithSchemaType() : ms_crosslinking_linker
  • getDoThisRuleFirst() : ms_taxonomyrules
  • getDoubleParam() : ms_session
  • getDoubleParams() : ms_security_task
  • getElectronMass() : ms_searchparams , ms_masses
  • getElement() : ms_quant_composition , ms_quant_correction
  • getElementByName() : ms_umod_configfile
  • getElementByNumber() : ms_umod_configfile
  • getElementSchemaType() : ms_quant_composition , ms_quant_correction
  • getElemRef() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • getElemRefSchemaType() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • getElutionProfileCorrelationThreshold() : ms_quant_integration
  • getElutionProfileCorrelationThresholdSchemaType() : ms_quant_integration
  • getElutionTimeDelta() : ms_quant_integration
  • getElutionTimeDeltaSchemaType() : ms_quant_integration
  • getElutionTimeDeltaUnit() : ms_quant_integration
  • getElutionTimeDeltaUnitSchemaType() : ms_quant_integration
  • getElutionTimeShift() : ms_xic
  • getEmailAddress() : ms_session , ms_user
  • getEmailFromTextName() : ms_mascotoptions
  • getEmailFromUser() : ms_mascotoptions
  • getEmailPassword() : ms_mascotoptions
  • getEmailProfile() : ms_mascotoptions
  • getEmailService() : ms_mascotoptions
  • getEmailTimeOutPeriod() : ms_mascotoptions
  • getEncryptedPassword() : ms_user
  • getEnd() : ms_fragment
  • getEndDate() : ms_license
  • getEndIndex() : ms_xic
  • getEndScanId() : ms_xic
  • getEntry() : ms_wwwoptions
  • getEntryByName() : ms_taxonomyfile
  • getEntryByNumber() : ms_taxonomyfile
  • getEntryFromNumber() : ms_spectral_lib_file
  • getEntryFromNumberAsText() : ms_spectral_lib_file
  • getEnzyme() : ms_aahelper , ms_mascotresfile
  • getEnzymeByName() : ms_enzymefile
  • getEnzymeByNumber() : ms_enzymefile
  • getEnzymes() : ms_mascotfiles
  • getErrMessageEmailTo() : ms_mascotoptions
  • getError() : ms_distiller_search_status
  • getErrorCode() : ms_shapiro_wilk
  • getErrorHandler() : ms_errors
  • getErrorLevel() : ms_taxonomyrules
  • getErrorLogFile() : ms_mascotoptions
  • getErrorNumber() : ms_errs , ms_mascotresfile
  • getErrorRepeats() : ms_errs
  • getErrorSeverity() : ms_errs
  • getErrorString() : ms_errs , ms_mascotresfile
  • getErrorText() : ms_http_helper_return
  • getERRORTOLERANT() : ms_searchparams
  • getErrorType() : ms_http_helper_return
  • getErrTolMaxAccessions() : ms_mascotoptions
  • getErrTolModDelta() : ms_mascotresults
  • getErrTolModMasterNeutralLoss() : ms_mascotresults
  • getErrTolModMasterString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModName() : ms_mascotresults
  • getErrTolModNeutralLoss() : ms_mascotresults
  • getErrTolModPepNeutralLoss() : ms_mascotresults
  • getErrTolModPepString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModReqPepNeutralLoss() : ms_mascotresults
  • getErrTolModReqPepString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModSlaveNeutralLoss() : ms_mascotresults
  • getErrTolModSlaveString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolParentFilename() : ms_searchparams
  • getErrTolPeptide() : ms_distiller_data_search
  • getErrTolProbabilityThreshold() : ms_mascotresults
  • getExcludedKeys() : ms_protein_quant_ratio
  • getExcludeInternalLabelSchemaType() : ms_quant_multiplex
  • getExcludeIsobaricFragmentsSchemaType() : ms_quant_multiplex
  • getExcludeTaxonomy() : ms_taxonomychoice
  • getExclusion() : ms_quant_method
  • getExclusionSchemaType() : ms_quant_method
  • getExecAfterSearch() : ms_mascotoptions
  • getExecTime() : ms_mascotresfile
  • getExpectationValue() : ms_peptide
  • getExpress() : ms_unigene_entry
  • getFastaPath() : ms_mascotresfile
  • getFastaVer() : ms_mascotresfile
  • getFeatures() : ms_license
  • getFeatureTableLength() : ms_mascotoptions
  • getFeatureTableMinScore() : ms_mascotoptions
  • getFileIndex() : ms_quant_component
  • getFileIndexSchemaType() : ms_quant_component
  • getFilename() : ms_http_client_mime
  • getFILENAME() : ms_searchparams
  • getFileName() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_license , ms_mascotresfile , ms_masses , ms_modfile , ms_quant_configfile , ms_spectral_lib_entry , ms_spectral_lib_file , ms_taxonomyfile , ms_taxspeciesfiles , ms_taxnodesfiles , ms_umod_configfile
  • getFileOffset() : ms_unigene_entry
  • getFileOffsetFromKey() : ms_tinycdb
  • getFileSize() : ms_fileutilities
  • getFileTypeToSearch() : ms_parserule_plus
  • getFilters() : ms_crosslinking_method
  • getFiltersSchemaType() : ms_crosslinking_method
  • getFindFileTimeout() : ms_datfile
  • getFirstProtAppearedIn() : ms_peptide
  • getFirstSerie() : ms_fragmentationrules
  • getFirstSeries() : ms_fragmentationrules
  • getFirstXicScanId() : ms_ms1quant_match
  • getFitexy() : ms_ms1quant_match_ratio
  • getFixedMods() : ms_aahelper
  • getFixedModsDelta() : ms_searchparams
  • getFixedModsName() : ms_searchparams
  • getFixedModsNeutralLoss() : ms_searchparams
  • getFixedModsResidues() : ms_searchparams
  • getFlags() : ms_mascotresults , ms_mascotresults_params
  • getFlags2() : ms_mascotresults , ms_mascotresults_params
  • getFlagSchemaType() : ms_quant_neutralloss , ms_umod_neutralloss
  • getFORMAT() : ms_searchparams
  • getFormat() : ms_spectral_lib_file , ms_taxspeciesfiles , ms_taxnodesfiles
  • getFORMVER() : ms_searchparams
  • getFormVersion() : ms_mascotoptions
  • getFragmentByNumber() : ms_fragmentvector
  • getFragResidueMass() : ms_masses
  • getFragRulesFile() : ms_distiller_data
  • getFrame() : ms_protein
  • getFrequencies() : ms_mascotfiles
  • getFromUnimod() : ms_modification
  • getFullName() : ms_user , ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • getFullNameSchemaType() : ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • getFullUserName() : ms_session
  • getGencodeFile() : ms_taxonomyrules
  • getGene() : ms_unigene_entry
  • getGetSeqBlastAccession() : ms_mascotoptions
  • getGetSeqJobIdFile() : ms_mascotoptions
  • getGroup() : ms_security
  • getGroupFromID() : ms_security
  • getGrouping() : ms_protein
  • getGroupOfPoster() : ms_umod_modification
  • getGroupOfPosterSchemaType() : ms_umod_modification
  • getHavePeakList() : ms_distiller_sub_project
  • getHeaderComments() : ms_datfile
  • getHeaderLine() : ms_logger
  • getHeaderValue() : ms_http_helper
  • getHiddenSchemaType() : ms_umod_specificity
  • getHit() : ms_peptidesummary , ms_mascotresults , ms_ms1quant_match , ms_ms1quantitation
  • getHitNumber() : ms_protein
  • getHomologyThreshold() : ms_mascotresults
  • getHomologyThresholdForHistogram() : ms_mascotresults
  • getHostName() : ms_computeraddress , ms_wwwentry
  • getHT_IDFromLogical() : ms_processors
  • getHttpPassword() : ms_connection_settings
  • getHttpProtocol() : ms_connection_settings
  • getHttpStatusCode() : ms_http_helper_return
  • getHttpUsername() : ms_connection_settings
  • getHydrogenMass() : ms_searchparams , ms_masses
  • getHyperThreadedCPUsMask() : ms_processors
  • getHyperThreadingState() : ms_processors
  • getHypothesisPvalue() : ms_protein_quant_ratio
  • getICAT() : ms_searchparams
  • getICATFilter() : ms_mascotoptions
  • getICATHeavy() : ms_mascotoptions
  • getICATLight() : ms_mascotoptions
  • getICATQuantitationMethod() : ms_mascotoptions
  • getID() : ms_unigene_entry , ms_peptide_quant_key , ms_group , ms_session , ms_security_task , ms_user
  • getId() : ms_distiller_master_search , ms_distiller_search_status , ms_distiller_sub_project
  • getIdentifier() : ms_taxonomyrules
  • getIgnore() : ms_quant_localdef , ms_umod_modification
  • getIgnoredQPs() : ms_protein
  • getIgnoreDupeAccession() : ms_mascotoptions
  • getIgnoreIonsScoreBelow() : ms_mascotoptions , ms_mascotresults_params
  • getIgnoreMass() : ms_modification
  • getIgnoreSchemaType() : ms_quant_localdef , ms_umod_modification
  • getIncludeTaxonomy() : ms_taxonomychoice
  • getIndex() : ms_inputquery
  • getIndexFileName() : ms_tinycdb
  • getInetAddress() : ms_computeraddress
  • getINSTRUMENT() : ms_inputquery , ms_searchparams
  • getInstrumentByName() : ms_fragrulesfile
  • getInstrumentByNumber() : ms_fragrulesfile
  • getInstrumentName() : ms_fragrulesfile
  • getIntactLinks() : ms_peptide
  • getIntegraAppServerURL() : ms_security_options
  • getIntegraDatabaseName() : ms_security_options
  • getIntegraOracleServerName() : ms_security_options
  • getIntegration() : ms_quant_method
  • getIntegrationSchemaType() : ms_quant_method
  • getIntegraUsers() : ms_security
  • getIntensity() : ms_spectral_lib_peak
  • getIntensityNormalisationBase() : ms_ms2quantitation
  • getIntensitySigFigs() : ms_mascotoptions
  • getInterFileBasePath() : ms_mascotoptions
  • getInterFileRelPath() : ms_mascotoptions
  • getINTERMEDIATE() : ms_searchparams
  • getIntFromKey() : ms_tinycdb
  • getIntMax() : ms_inputquery
  • getIntMin() : ms_inputquery
  • getIntParam() : ms_session
  • getIonIntensityThreshold() : ms_quant_multiplex
  • getIonIntensityThresholdSchemaType() : ms_quant_multiplex
  • getIonMobility() : ms_inputquery
  • getIonsDecimalPlaces() : ms_mascotoptions
  • getIonSeries() : ms_quant_multiplex
  • getIonSeriesSchemaType() : ms_quant_multiplex
  • getIonsIntensity() : ms_peptide
  • getIonsScore() : ms_peptide , ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getIonsScoreCorrected() : ms_mascotresults
  • getIonsScoreHistogram() : ms_mascotresults
  • getIPAddress() : ms_session
  • getIPCLogfile() : ms_clusterparams
  • getIPCLogging() : ms_clusterparams
  • getIPCTimeout() : ms_clusterparams
  • getIsDatabaseActive() : ms_http_client
  • getIsFromErrorTolerant() : ms_peptide
  • getIsFromLibrary() : ms_peptide
  • getIsolatedPrecursorSchemaType() : ms_quant_quality
  • getIsolatedPrecursorThreshold() : ms_quant_quality
  • getIsolatedPrecursorThresholdSchemaType() : ms_quant_quality
  • getIsotope() : ms_quant_component
  • getIsotopeSchemaType() : ms_quant_component
  • getIsPermitted() : ms_http_client_session
  • getIsSecurityEnabled() : ms_http_client
  • getIsWebAuthenticationEnabled() : ms_http_client
  • getIsXmlUploadedList() : ms_http_client_session
  • getIT_MODS() : ms_inputquery , ms_searchparams
  • getItemFromId() : ms_obofile
  • getITOL() : ms_searchparams
  • getITOLU() : ms_searchparams
  • getJobNumber() : ms_mascotresfile
  • getKeepAlive() : ms_mascotresfile
  • getKey() : ms_ms1quant_match , ms_peptide_quant_ratio
  • getLabel() : ms_fragment
  • getLabelFree() : ms_ms1quantitation
  • getLabelFreeVarMods() : ms_ms1quant_match
  • getLastAccessed() : ms_session
  • getLastError() : ms_errs , ms_errors , ms_mascotresfile
  • getLastErrorString() : ms_errs , ms_errors , ms_mascotresfile
  • getLastModificationTime() : ms_fileutilities
  • getLastQueryAscFile() : ms_mascotoptions
  • getLastSerie() : ms_fragmentationrules
  • getLastSeries() : ms_fragmentationrules
  • getLastXicScanId() : ms_ms1quant_match
  • getLessThanMinPepLen() : ms_peptide
  • getLIBRARY_SEARCH() : ms_searchparams
  • getLibraryEntryId() : ms_peptidesummary
  • getLibraryModDelta() : ms_searchparams
  • getLibraryModName() : ms_searchparams
  • getLibraryModString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getLibraryName() : ms_libraryoptions
  • getLibraryOptions() : ms_datfile
  • getLICENSE() : ms_searchparams
  • getLicensee() : ms_license
  • getLicenseString() : ms_license
  • getLicenseVersion() : ms_license
  • getLine() : ms_spectral_lib_entry
  • getLinkerByNumber() : ms_crosslinking_linkers
  • getLinkerMass() : ms_linker_site
  • getLinkers() : ms_crosslinking_method
  • getLinkerSchemaType() : ms_crosslinking_linkers
  • getLinkersSchemaType() : ms_crosslinking_method
  • getLinkFrom() : ms_linker_site
  • getLinkTo() : ms_linker_site
  • getLoaded() : ms_distiller_data_search
  • getLoadedSearchIndex() : ms_distiller_data
  • getLoadUnassigned() : ms_distiller_data_search
  • getLocalDefinition() : ms_quant_modgroup
  • getLocalDefinitionSchemaType() : ms_quant_modgroup
  • getLocalModifications() : ms_quant_method
  • getLocalModsNlStr() : ms_peptide
  • getLocalModsStr() : ms_peptide
  • getLocalVarModName() : ms_inputquery
  • getLocus() : ms_inputquery
  • getLocusLink() : ms_unigene_entry
  • getLogEventsHandler() : ms_loggingmonitor
  • getLogFilename() : ms_file_logger
  • getLogFileName() : ms_cronoptions , ms_security_options
  • getLoggingFileName() : ms_errs
  • getLoggingLevel() : ms_cronoptions , ms_errs , ms_log , ms_security_options
  • getLogMask() : ms_loggingmonitor
  • getLogoImageFile() : ms_mascotoptions
  • getLongestPeptideLen() : ms_protein
  • getLongestSigPeptideLen() : ms_protein
  • getLongParam() : ms_session
  • getLongParams() : ms_security_task
  • getLoopLinks() : ms_peptide
  • getMailTempFile() : ms_mascotoptions
  • getMailTransport() : ms_mascotoptions
  • getMajorVersion() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • getMascNodeCtrlFile() : ms_mascotoptions
  • getMascotCmdLine() : ms_mascotoptions
  • getMascotControlFile() : ms_mascotoptions
  • getMascotFileProcessingThreads() : ms_mascotoptions
  • getMascotFiles() : ms_datfile
  • getMascotJobIdFile() : ms_mascotoptions
  • getMascotMessage() : ms_mascotoptions
  • getMascotNodeRebootScript() : ms_clusterparams
  • getMascotNodeScript() : ms_clusterparams
  • getMascotOptions() : ms_datfile
  • getMascotSearchURL() : ms_distiller_data_search
  • getMascotSecurityOptions() : ms_security
  • getMascotServerURL() : ms_distiller_data_search
  • getMascotVer() : ms_mascotresfile
  • getMass() : ms_fragment
  • getMASS() : ms_searchparams
  • getMassDecimalPlaces() : ms_mascotoptions
  • getMassDelta() : ms_quant_integration
  • getMassDeltaSchemaType() : ms_quant_integration
  • getMassDeltaUnit() : ms_quant_integration
  • getMassDeltaUnitSchemaType() : ms_quant_integration
  • getMasses() : ms_aahelper , ms_mascotresfile , ms_protein
  • getMassesWithinTolerance() : ms_fragmentvector
  • getMassFile() : ms_modification , ms_modfile
  • getMassMax() : ms_inputquery
  • getMassMin() : ms_inputquery
  • getMassType() : ms_searchparams
  • getMasterComputer() : ms_clusterparams
  • getMasterProjectStreamName() : ms_distiller_master_project
  • getMatch() : ms_ms1quantitation
  • getMatchedFraction() : ms_ms1quant_charge_state
  • getMatchedIonIntensity() : ms_fragment
  • getMatchedIonMass() : ms_fragment
  • getMatchedRho() : ms_ms1quant_charge_state , ms_quant_integration
  • getMatchedRhoSchemaType() : ms_quant_integration
  • getMatchForHit() : ms_ms1quantitation
  • getMaxAlignment() : ms_ms1quant_charge_state
  • getMaxConcurrentSearches() : ms_mascotoptions
  • getMaxDatabases() : ms_mascotoptions
  • getMaxDescriptionLen() : ms_mascotoptions
  • getMaxEtagMassDelta() : ms_mascotoptions
  • getMaxEtVarMods() : ms_mascotoptions
  • getMaxHitsToReport() : ms_mascotresults_params
  • getMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • getMaxInternalMass() : ms_fragmentationrules , ms_inputquery , ms_searchparams
  • getMaxNumOfReportBuilderColumnArrangements() : ms_mascotoptions
  • getMaxNumPeptides() : ms_mascotoptions
  • getMaxPepModArrangements() : ms_mascotoptions
  • getMaxPepNumModifiedSites() : ms_mascotoptions
  • getMaxPepNumVarMods() : ms_mascotoptions
  • getMaxPeptideIdentityThreshold() : ms_mascotresults
  • getMaxQueries() : ms_mascotoptions
  • getMaxRankValue() : ms_mascotresults
  • getMaxSearchesPerUser() : ms_mascotoptions
  • getMaxSequenceLen() : ms_mascotoptions
  • getMaxTaxonomyRules() : ms_datfile
  • getMaxVarMods() : ms_mascotoptions
  • getMD5Sum() : ms_fileutilities
  • getMemberNumber() : ms_protein
  • getMessageSource() : ms_log
  • getMethod() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • getMethodByName() : ms_crosslinking_configfile , ms_quant_configfile
  • getMethodByNumber() : ms_crosslinking_configfile , ms_quant_configfile
  • getMethodSchemaType() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • getMinEtagMassDelta() : ms_mascotoptions
  • getMinimumA1() : ms_quant_quality
  • getMinimumA1SchemaType() : ms_quant_quality
  • getMinimumPasswordLength() : ms_security_options
  • getMinInternalMass() : ms_fragmentationrules , ms_inputquery , ms_searchparams
  • getMinIonPairs() : ms_quant_multiplex
  • getMinIonPairsSchemaType() : ms_quant_multiplex
  • getMinNumPeptides() : ms_quant_method , ms_quantitation
  • getMinNumPeptidesSchemaType() : ms_quant_method
  • getMinNumSigUniqueSequences() : ms_mascotresults_params
  • getMinorVersion() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • getMinPepLenInPepSummary() : ms_distiller_data_search , ms_mascotoptions , ms_mascotresults
  • getMinPepLenInPeptideSummary() : ms_mascotresults_params
  • getMinPepLenInSearch() : ms_mascotoptions
  • getMinPrecursorCharge() : ms_quant_quality
  • getMinPrecursorChargeSchemaType() : ms_quant_quality
  • getMinProbability() : ms_mascotresults_params
  • getMinProbabilityForSLScore() : ms_peptidesummary
  • getMiscNotes() : ms_umod_modification , ms_umod_specificity
  • getMiscNotesSchemaType() : ms_umod_modification , ms_umod_specificity
  • getMissed() : ms_aahelper
  • getMissedCleavages() : ms_peptide
  • getModBrickByName() : ms_umod_configfile
  • getModBrickByNumber() : ms_umod_configfile
  • getMode() : ms_quant_modgroup
  • getModeSchemaType() : ms_quant_modgroup
  • getModFile() : ms_quant_modgroup
  • getModFileList() : ms_umod_configfile , ms_umod_modification
  • getModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • getModFileNameSchemaType() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • getModFileSchemaType() : ms_quant_modgroup
  • getModificationByName() : ms_modvector , ms_modfile , ms_umod_configfile
  • getModificationByNumber() : ms_modvector , ms_modfile , ms_umod_configfile
  • getModificationGroupByName() : ms_quant_component , ms_quant_method
  • getModificationGroupByNumber() : ms_quant_component , ms_quant_method
  • getModificationGroupSchemaType() : ms_quant_component , ms_quant_method
  • getModifications() : ms_mascotfiles , ms_quant_satellite
  • getModificationsSchemaType() : ms_quant_satellite
  • getModificationType() : ms_modification
  • getModifiedResidue() : ms_modification
  • getMODS() : ms_searchparams
  • getMods() : ms_spectral_lib_entry
  • getModsFromNumber() : ms_spectral_lib_file
  • getMonitorEmailCheckFreq() : ms_mascotoptions
  • getMonitorLogFile() : ms_mascotoptions
  • getMonitorPidFile() : ms_mascotoptions
  • getMonitorTestTimeout() : ms_mascotoptions
  • getMonoisotopic() : ms_quant_moverz
  • getMonoisotopicSchemaType() : ms_quant_moverz
  • getMonoLinkByNumber() : ms_crosslinking_linker
  • getMonoLinkModification() : ms_mascotresfile
  • getMonoLinkSchemaType() : ms_crosslinking_linker
  • getMonoLinkStr() : ms_peptide
  • getMonoLinkTitle() : ms_modification
  • getMonoMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getMonoMassAsNumber() : ms_umod_element
  • getMonoMassSchemaType() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getMoverz() : ms_ms1quant_match_component , ms_quant_component
  • getMoverzSchemaType() : ms_quant_component
  • getMrCalc() : ms_peptide
  • getMrExperimental() : ms_peptide
  • getMSParserVersion() : ms_mascotresfile
  • getMudpit() : ms_mascotoptions
  • getMudpitSwitch() : ms_mascotoptions
  • getMULTI_SITE_MODS() : ms_searchparams
  • getMultiFileQueryNumber() : ms_mascotresfile
  • getMultiplex() : ms_quant_protocol
  • getMultiplexSchemaType() : ms_quant_protocol
  • getMultithreadedName() : ms_processors
  • getMW() : ms_spectral_lib_entry
  • getMz() : ms_spectral_lib_peak
  • getName() : ms_crosslinking_method , ms_databaseoptions , ms_distiller_sub_project , ms_http_client_mime , ms_dbprocessors , ms_quant_component , ms_quant_method , ms_quant_modgroup , ms_quant_numerator , ms_quant_ratio , ms_group , ms_user , ms_spectral_lib_entry , ms_wwwentry , ms_xml_parameter
  • getNameOfDB() : ms_parserule_plus
  • getNameSchemaType() : ms_crosslinking_method , ms_crosslinking_parameter , ms_quant_component , ms_quant_method , ms_quant_modgroup , ms_quant_numerator , ms_quant_parameter , ms_quant_ratio , ms_xml_parameter
  • getNeutralLoss() : ms_fragment , ms_modification , ms_quant_specificity , ms_umod_specificity
  • getNeutralLossRequired() : ms_modification
  • getNeutralLossSchemaType() : ms_quant_specificity , ms_umod_specificity
  • getNew() : ms_quant_isotope
  • getNewSchemaType() : ms_quant_isotope
  • getNextFamilyProtein() : ms_mascotresults
  • getNextPeptide() : ms_aahelper
  • getNextSimilarProtein() : ms_mascotresults
  • getNextSimilarProteinOf() : ms_mascotresults
  • getNextSubsetProtein() : ms_mascotresults
  • getNextSubsetProteinOf() : ms_mascotresults
  • getNitrogenMass() : ms_searchparams , ms_masses
  • getNoBreakDescLineIf() : ms_taxonomyrules
  • getNodeListFile() : ms_mascotfiles
  • getNodeSequenceDatabaseDir() : ms_clusterparams
  • getNodesFile() : ms_taxonomyrules
  • getNonMudpitScore() : ms_protein
  • getNoResultsScript() : ms_mascotoptions
  • getNormalisation() : ms_quant_method
  • getNormalisationSchemaType() : ms_quant_method
  • getNormalityPvalue() : ms_protein_quant_ratio
  • getNotes() : ms_security_task
  • getNtermDelta() : ms_masses
  • getNterminalMass() : ms_masses
  • getNTerminusMass() : ms_modification
  • getNTermMass() : ms_searchparams
  • getNtermNeutralLoss() : ms_masses
  • getNTIUserGroup() : ms_mascotoptions
  • getNTMonitorGroup() : ms_mascotoptions
  • getNum13C() : ms_peptide
  • getNumAccessions() : ms_unigene_entry
  • getNumAvailableToProcess() : ms_processors
  • getNumber() : ms_quant_element , ms_umod_elemref
  • getNumberOfAccessionDBTypes() : ms_peptidesummary
  • getNumberOfAccessions() : ms_crosslinking_accessions
  • getNumberOfAltNames() : ms_umod_modification
  • getNumberOfAminoAcids() : ms_umod_configfile
  • getNumberOfBuckets() : ms_ms1quant_charge_state
  • getNumberOfComponents() : ms_quant_method
  • getNumberOfCorrections() : ms_quant_component
  • getNumberOfCronJobs() : ms_cronoptions
  • getNumberOfCutters() : ms_enzyme
  • getNumberOfDatabases() : ms_databases , ms_searchparams , ms_processoroptions
  • getNumberOfDenominators() : ms_quant_ratio
  • getNumberOfDoesNotPairWiths() : ms_crosslinking_linker
  • getNumberOfElements() : ms_quant_composition , ms_umod_configfile
  • getNumberOfElemRefs() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • getNumberOfEntries() : ms_obofile , ms_taxonomyfile , ms_wwwoptions
  • getNumberOfEnzymes() : ms_enzymefile
  • getNumberOfErrors() : ms_errs , ms_mascotresfile
  • getNumberOfExcludeTaxonomies() : ms_taxonomychoice
  • getNumberOfExclusions() : ms_quant_method
  • getNumberOfFamilyAccessionDBTypes() : ms_peptidesummary
  • getNumberOfFamilyMembers() : ms_mascotresults
  • getNumberOfFragments() : ms_fragmentvector
  • getNumberOfGencodeFiles() : ms_taxonomyrules
  • getNumberOfHits() : ms_mascotresults
  • getNumberOfIgnoreDupeAccessions() : ms_mascotoptions
  • getNumberOfIgnoreMasses() : ms_modification
  • getNumberOfIgnores() : ms_quant_localdef , ms_umod_modification
  • getNumberOfIncludeTaxonomies() : ms_taxonomychoice
  • getNumberOfInstruments() : ms_fragrulesfile
  • getNumberOfIonSeries() : ms_quant_multiplex
  • getNumberOfIsotopes() : ms_quant_component
  • getNumberOfLibraries() : ms_libraryoptions
  • getNumberOfLibraryMods() : ms_searchparams
  • getNumberOfLinkedPeptides() : ms_peptide
  • getNumberOfLinkers() : ms_crosslinking_linkers
  • getNumberOfLocalDefinitions() : ms_quant_modgroup
  • getNumberOfLocalVarMods() : ms_inputquery
  • getNumberOfMethods() : ms_crosslinking_configfile , ms_quant_configfile
  • getNumberOfModBricks() : ms_umod_configfile
  • getNumberOfModFiles() : ms_quant_modgroup
  • getNumberOfModificationGroups() : ms_quant_component , ms_quant_method
  • getNumberOfModifications() : ms_modvector , ms_modfile , ms_umod_configfile
  • getNumberOfModifiedResidues() : ms_modification
  • getNumberOfMonoLinks() : ms_crosslinking_linker
  • getNumberOfNeutralLosses() : ms_quant_specificity , ms_umod_specificity
  • getNumberOfNoBreakDescLineIf() : ms_taxonomyrules
  • getNumberOfNodesFiles() : ms_taxonomyrules
  • getNumberOfNumerators() : ms_quant_ratio
  • getNumberOfParameters() : ms_xml_parameters , ms_crosslinking_parameters , ms_quant_parameters
  • getNumberOfParseRules() : ms_parseoptions
  • getNumberOfPeaks() : ms_inputquery
  • getNumberOfPepNeutralLosses() : ms_umod_specificity , ms_quant_specificity
  • getNumberOfPeptides() : ms_quant_normalisation_peptides
  • getNumberOfPerDbSrcRules() : ms_taxonomyrules
  • getNumberOfPrefixRemoves() : ms_taxonomyrules
  • getNumberOfProcessors() : ms_processoroptions
  • getNumberOfProperties() : ms_customproperty
  • getNumberOfProteins() : ms_quant_normalisation_proteins
  • getNumberOfReportNumberChoices() : ms_mascotoptions
  • getNumberOfReportRatios() : ms_quant_method
  • getNumberOfResfiles() : ms_mascotresfile
  • getNumberOfSeqs() : ms_quant_method
  • getNumberOfSpeciesFiles() : ms_taxonomyrules
  • getNumberOfSpecificities() : ms_quant_localdef , ms_umod_modification
  • getNumberOfStrFiles() : ms_taxonomyrules
  • getNumberOfSubClusters() : ms_clusterparams
  • getNumberOfSubtasks() : ms_progress_info
  • getNumberOfSuffixRemoves() : ms_taxonomyrules
  • getNumberOfTargetFDRPercentages() : ms_mascotoptions
  • getNumberOfTasks() : ms_security_tasks
  • getNumberOfThreads() : ms_databaseoptions , ms_dbprocessors
  • getNumberOfUnassigned() : ms_mascotresults
  • getNumberOfUnmodified() : ms_quant_modgroup
  • getNumberOfXrefs() : ms_umod_modification
  • getNumberSchemaType() : ms_quant_element , ms_umod_elemref
  • getNumComponents() : ms_ms1quant_match , ms_protein
  • getNumCores() : ms_processors
  • getNumDecoyHitsAboveHomology() : ms_mascotresults
  • getNumDecoyHitsAboveIdentity() : ms_mascotresults
  • getNumDiscoveredErrTolMods() : ms_mascotresults
  • getNumDiscoveredFixedMods() : ms_mascotresults
  • getNumDiscoveredIntactLinks() : ms_mascotresults
  • getNumDiscoveredLibraryMods() : ms_mascotresults
  • getNumDiscoveredLocalMods() : ms_mascotresults
  • getNumDiscoveredNonSpecCleavage() : ms_mascotresults
  • getNumDiscoveredVariableMods() : ms_mascotresults
  • getNumDisplayPeptides() : ms_protein
  • getNumDistinctPeptideRepeats() : ms_protein
  • getNumDistinctPeptides() : ms_protein
  • getNumEntries() : ms_spectral_lib_file
  • getNumeratorByName() : ms_quant_ratio
  • getNumeratorByNumber() : ms_quant_ratio
  • getNumeratorSchemaType() : ms_quant_ratio
  • getNumEtSeqsSearched() : ms_mascotresfile
  • getNumGroups() : ms_ms1quantitation
  • getNumHits() : ms_mascotresfile , ms_ms1quant_match , ms_ms1quantitation
  • getNumHitsAboveHomology() : ms_mascotresults
  • getNumHitsAboveIdentity() : ms_mascotresults
  • getNumIonsMatched() : ms_peptide
  • getNumLibraryEntries() : ms_mascotresfile
  • getNumLogEventsHandlers() : ms_loggingmonitor
  • getNumLogicalPerPhysical() : ms_processors
  • getNumMatches() : ms_ms1quantitation
  • getNumMatchesForGroup() : ms_ms1quantitation
  • getNumMatchesForHit() : ms_ms1quantitation
  • getNumObservedForEmPAI() : ms_protein
  • getNumOnSystem() : ms_processors
  • getNumPeaks() : ms_spectral_lib_peak_list , ms_spectral_lib_entry
  • getNumPeptideRatios() : ms_ms1quant_match
  • getNumPeptides() : ms_quant_average , ms_protein , ms_ms1quant_match_component
  • getNumPeptidesSchemaType() : ms_quant_average
  • getNumPeptideStatuses() : ms_ms1quantitation
  • getNumPhysicalOnSystem() : ms_processors
  • getNumPmfQueriesUsed() : ms_proteinsummary
  • getNumPoints() : ms_xic
  • getNumProcessorGroups() : ms_processors
  • getNumProcessorsLicensed() : ms_license
  • getNumProteinFamilies() : ms_ms1quantitation
  • getNumProteins() : ms_peptide
  • getNumQueries() : ms_mascotresfile
  • getNumRanges() : ms_ms1quant_match_component
  • getNumResidues() : ms_spectral_lib_file , ms_mascotresfile
  • getNumSearches() : ms_distiller_master_project , ms_distiller_search_status_list
  • getNumSeqs() : ms_mascotresfile
  • getNumSeqsAfterTax() : ms_mascotresfile
  • getNumSubprojects() : ms_distiller_master_project
  • getNumSubsearches() : ms_distiller_master_search
  • getNumUsed() : ms_inputquery
  • getNumVals() : ms_inputquery
  • getObserved() : ms_peptide
  • getObservedCharge() : ms_mascotresfile
  • getObservedIntensity() : ms_mascotresfile
  • getObservedMass() : ms_mascotresfile
  • getObservedMrValue() : ms_mascotresfile
  • getOld() : ms_quant_isotope
  • getOldSchemaType() : ms_quant_isotope
  • getOpaqueString() : ms_peptide_quant_key
  • getOpaqueStringAndID() : ms_peptide_quant_key
  • getOsName() : ms_http_client
  • getOutlierKeys() : ms_protein_quant_ratio
  • getOutliers() : ms_quant_method
  • getOutliersSchemaType() : ms_quant_method
  • getOVERVIEW() : ms_searchparams
  • getOxygenMass() : ms_searchparams , ms_masses
  • getPairsWith() : ms_modification , ms_umod_neutralloss
  • getPairsWithSchemaType() : ms_umod_neutralloss
  • getParameterByName() : ms_crosslinking_parameters , ms_quant_parameters
  • getParameterByNumber() : ms_crosslinking_parameters , ms_quant_parameters
  • getParameterSchemaType() : ms_crosslinking_filters , ms_crosslinking_parameters , ms_crosslinking_scope , ms_quant_parameters , ms_xml_parameters , ms_crosslinking_settings
  • getParams() : ms_session
  • getParent() : ms_taxonomytree
  • getParseOptions() : ms_datfile
  • getParseRule() : ms_parseoptions , ms_wwwentry
  • getPasswordExpiry() : ms_user
  • getPath() : ms_databaseoptions , ms_wwwentry
  • getPeak() : ms_spectral_lib_peak_list
  • getPeakAnnotationLevel() : ms_spectral_lib_peak_list
  • getPeakEndIndex() : ms_xic
  • getPeakEndScanId() : ms_xic
  • getPeakIntensity() : ms_inputquery
  • getPeakList() : ms_spectral_lib_entry , ms_inputquery
  • getPeakListChecksum() : ms_spectral_lib_entry
  • getPeakListObject() : ms_spectral_lib_entry
  • getPeakMass() : ms_inputquery
  • getPeakStartIndex() : ms_xic
  • getPeakStartScanId() : ms_xic
  • getPeakState() : ms_xic
  • getPeaksUsedFromIons1() : ms_peptide
  • getPeaksUsedFromIons2() : ms_peptide
  • getPeaksUsedFromIons3() : ms_peptide
  • getPEP_ISOTOPE_ERROR() : ms_searchparams
  • getPepEnd() : ms_aahelper
  • getPepIdentThreshProtected() : ms_mascotresults
  • getPepNeutralLoss() : ms_modification , ms_quant_specificity , ms_umod_specificity
  • getPepNeutralLossSchemaType() : ms_quant_specificity , ms_umod_specificity
  • getPepNumber() : ms_protein
  • getPepSearchTool() : ms_mascotoptions
  • getPepSearchToolCommandLine() : ms_mascotoptions
  • getPepStart() : ms_aahelper
  • getPepsWithSameScore() : ms_peptidesummary , ms_mascotresults , ms_proteinsummary
  • getPepThresholdType() : ms_quant_quality
  • getPepThresholdTypeSchemaType() : ms_quant_quality
  • getPepThresholdValue() : ms_quant_quality
  • getPepThresholdValueSchemaType() : ms_quant_quality
  • getPeptide() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults , ms_quant_normalisation_peptides , ms_proteinsummary
  • getPeptideAmbiguityRanks() : ms_peptidesummary
  • getPeptideComponentID() : ms_protein
  • getPeptideDuplicate() : ms_protein
  • getPeptideEnd() : ms_protein
  • getPeptideExpectationValue() : ms_mascotresults
  • getPeptideFrame() : ms_protein
  • getPeptideIdentityThreshold() : ms_mascotresults
  • getPeptideIonsScore() : ms_protein
  • getPeptideIsBold() : ms_protein
  • getPeptideKey() : ms_ms1quant_match_component
  • getPeptideLength() : ms_peptide
  • getPeptideMultiplicity() : ms_protein
  • getPeptideP() : ms_protein
  • getPeptideQuantKeys() : ms_quantitation
  • getPeptideQuery() : ms_protein
  • getPeptideRatio() : ms_customquantitation , ms_ms1quant_match , ms_ms2quantitation , ms_quantitation
  • getPeptideRatioNormalisationBase() : ms_quantitation
  • getPeptideResidueAfter() : ms_protein
  • getPeptideResidueBefore() : ms_protein
  • getPeptides() : ms_quant_normalisation
  • getPeptideSchemaType() : ms_quant_normalisation_peptides
  • getPeptideShowCheckbox() : ms_protein
  • getPeptidesSchemaType() : ms_quant_normalisation
  • getPeptideStart() : ms_protein
  • getPeptideStatus() : ms_ms1quantitation
  • getPeptideStr() : ms_peptide
  • getPeptideString() : ms_ms1quant_match
  • getPeptideSubstring() : ms_fragment
  • getPeptideSummaryCacheStreamName() : ms_distiller_search_status
  • getPeptideSummaryFlags() : ms_distiller_data_search
  • getPeptideSummaryFlags2() : ms_distiller_data_search
  • getPeptideThreshold() : ms_mascotresults
  • getPepTol() : ms_inputquery
  • getPepTolString() : ms_inputquery
  • getPepTolUnits() : ms_inputquery
  • getPercolator() : ms_distiller_data_search
  • getPercolatorExeFlags() : ms_mascotoptions
  • getPercolatorFeatures() : ms_mascotoptions
  • getPercolatorFileNames() : ms_mascotresfile
  • getPercolatorMinQueries() : ms_mascotoptions
  • getPercolatorMinSequences() : ms_mascotoptions
  • getPercolatorScores() : ms_peptide
  • getPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • getPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • getPercolatorUseProteins() : ms_distiller_data_search
  • getPercolatorUseRT() : ms_distiller_data_search
  • getPerDbSrcRule() : ms_taxonomyrules
  • getPerfectObservedMatrix() : ms_ms1quant_match
  • getPermittedTasks() : ms_group , ms_session
  • getPermittedTasksForUser() : ms_security
  • getPFA() : ms_searchparams
  • getPhysicalFromLogical() : ms_processors
  • getPoint() : ms_xic
  • getPort() : ms_computeraddress
  • getPortNumber() : ms_wwwentry
  • getPosition() : ms_quant_specificity , ms_quant_unmodified , ms_umod_specificity
  • getPositionSchemaType() : ms_quant_specificity , ms_quant_unmodified , ms_umod_specificity
  • getPreceedingComments() : ms_customproperty , ms_databaseoptions
  • getPRECURSOR() : ms_searchparams
  • getPrecursor() : ms_quant_protocol
  • getPrecursorChargeFromNumber() : ms_spectral_lib_file
  • getPrecursorCutOutLowerLimit() : ms_mascotoptions
  • getPrecursorCutOutUpperLimit() : ms_mascotoptions
  • getPrecursorMZ() : ms_spectral_lib_entry
  • getPrecursorMZFromNumber() : ms_spectral_lib_file
  • getPrecursorRange() : ms_quant_integration
  • getPrecursorRangeSchemaType() : ms_quant_integration
  • getPrecursorSchemaType() : ms_quant_protocol
  • getPredictionMatrix() : ms_ms1quant_match
  • getPrefixRemove() : ms_taxonomyrules
  • getPrettyRank() : ms_peptide
  • getPrimaryNlStr() : ms_peptide
  • getProbabilityThreshold() : ms_mascotresults
  • getProbFromScore() : ms_mascotresults
  • getProbOfPepBeingRandomMatch() : ms_mascotresults
  • getProbOfProteinBeingRandomMatch() : ms_mascotresults
  • getProcessingOptions() : ms_quant_integration
  • getProcessingOptionsSchemaType() : ms_quant_integration
  • getProcessor() : ms_processoroptions
  • getProcessorName() : ms_processors
  • getProcessors() : ms_datfile
  • getProgress() : ms_progress_info
  • getProgressInfo() : ms_mascotresfile , ms_quantitation
  • getProjectRelativePath() : ms_distiller_sub_project
  • getPropertyName() : ms_customproperty
  • getProportion() : ms_http_helper_progress
  • getPropValStringByName() : ms_customproperty
  • getPropValStringByNumber() : ms_customproperty
  • getProtein() : ms_quant_normalisation_proteins , ms_peptide , ms_mascotresults , ms_peptidesummary
  • getProteinDescription() : ms_mascotresults
  • getProteinEmPAI() : ms_peptidesummary , ms_mascotresults
  • getProteinExpectationValue() : ms_mascotresults
  • getProteinFamilySwitch() : ms_mascotoptions
  • getProteinGrouping() : ms_distiller_data_search
  • getProteinMass() : ms_mascotresults
  • getProteinRatio() : ms_ms1quantitation , ms_ms2quantitation , ms_customquantitation , ms_ms1quantitation , ms_quantitation , ms_ms2quantitation
  • getProteinRatioSample() : ms_quantitation
  • getProteinRatioType() : ms_quant_method
  • getProteinRatioTypeSchemaType() : ms_quant_method
  • getProteins() : ms_quant_normalisation , ms_peptide
  • getProteinSchemaType() : ms_quant_normalisation_proteins
  • getProteinScoreCutoff() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getProteinScoreForHistogram() : ms_mascotresults
  • getProteinsInResultsFile() : ms_mascotoptions
  • getProteinsSchemaType() : ms_quant_normalisation
  • getProteinSummaryHit() : ms_protein
  • getProteinsWithThisPepMatch() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getProteinTaxonomyIDs() : ms_mascotresults
  • getProteinThreshold() : ms_mascotresults
  • getProtocol() : ms_quant_method
  • getProtocolSchemaType() : ms_quant_method
  • getProtScoreType() : ms_quant_method
  • getProtScoreTypeSchemaType() : ms_quant_method
  • getProxyConfig() : ms_http_helper
  • getProxyPassword() : ms_connection_settings , ms_mascotoptions
  • getProxyServer() : ms_connection_settings , ms_mascotoptions
  • getProxyServerType() : ms_connection_settings
  • getProxyType() : ms_mascotoptions
  • getProxyUserAndPassword() : ms_connection_settings
  • getProxyUsername() : ms_connection_settings , ms_mascotoptions
  • getPValue() : ms_shapiro_wilk
  • getQ() : ms_fitexy_result
  • getQmatch() : ms_spectral_lib_file , ms_mascotresults
  • getQuality() : ms_ms1quant_match_ratio , ms_quant_method
  • getQualitySchemaType() : ms_quant_method
  • getQuant() : ms_distiller_data
  • getQuantCount() : ms_distiller_data
  • getQuantForSearch() : ms_distiller_data
  • getQUANTITATION() : ms_searchparams
  • getQuantitation() : ms_mascotresfile
  • getQuantitationComponentForPeptide() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getQuantitationDatasources() : ms_ms1quantitation
  • getQuantitationMethod() : ms_mascotresfile , ms_quantitation
  • getQuantMethod() : ms_peptidesummary , ms_distiller_data
  • getQuantMethodXml() : ms_distiller_data_search
  • getQUE() : ms_searchparams
  • getQuery() : ms_peptide , ms_ms1quant_peptide_status
  • getQueryAndRank() : ms_peptide_quant_key
  • getQueryList() : ms_peptidesummary
  • getQuerySectionValue() : ms_mascotresfile
  • getQuerySectionValueDouble() : ms_mascotresfile
  • getQuerySectionValueInt() : ms_mascotresfile
  • getQuerySectionValueStr() : ms_mascotresfile
  • getQuickRefSearch() : ms_taxonomyrules
  • getRange() : ms_ms1quant_match_component
  • getRank() : ms_peptide , ms_ms1quant_peptide_status
  • getRatioName() : ms_peptide_quant_ratio , ms_protein_quant_ratio , ms_ms1quant_match_ratio
  • getRawAbsolutePath() : ms_distiller_sub_project
  • getRawfile() : ms_inputquery
  • getRawFormat() : ms_distiller_sub_project
  • getRawRelativePath() : ms_distiller_sub_project
  • getRawSampleNumber() : ms_distiller_sub_project
  • getRawScans() : ms_inputquery
  • getRC() : ms_matrix
  • getReadableLabelFreeVarMods() : ms_ms1quant_match
  • getReadableVarMods() : ms_ms1quantitation , ms_mascotresults
  • getReadableVarModsConcise() : ms_ms1quantitation
  • getRecordID() : ms_umod_modification
  • getRecordIDSchemaType() : ms_umod_modification
  • getRedirectPolicy() : ms_connection_settings
  • getReferenceAccession() : ms_quant_average
  • getReferenceAccessionSchemaType() : ms_quant_average
  • getReferenceAmount() : ms_quant_average
  • getReferenceAmountSchemaType() : ms_quant_average
  • getReferenceDatabase() : ms_quant_average
  • getReferenceDatabaseNumberOfSL() : ms_mascotresfile
  • getReferenceDatabaseSchemaType() : ms_quant_average
  • getReferenceFasta() : ms_libraryoptions
  • getReferenceFastaTaxonomyTitle() : ms_libraryoptions
  • getReferenceHitId() : ms_ms1quant_average_results
  • getReferenceMemberNumber() : ms_ms1quant_average_results
  • getRegionEndIndex() : ms_xic
  • getRegionEndScanId() : ms_xic
  • getRegionStartIndex() : ms_xic
  • getRegionStartScanId() : ms_xic
  • getRelativeMass() : ms_ms1quant_match_component
  • getRepeatSearchString() : ms_mascotresfile
  • getRepEntryByName() : ms_wwwoptions
  • getReplicate() : ms_quant_protocol
  • getReplicateSchemaType() : ms_quant_protocol
  • getREPORT() : ms_searchparams
  • getReportBuilderColumnArrangement() : ms_mascotoptions
  • getReportDetailSchemaType() : ms_quant_method
  • getReporter() : ms_quant_protocol
  • getReporterSchemaType() : ms_quant_protocol
  • getReporterTol() : ms_quant_reporter
  • getReporterTolSchemaType() : ms_quant_reporter
  • getReporterTolUnit() : ms_quant_reporter
  • getReporterTolUnitSchemaType() : ms_quant_reporter
  • getReportNumberChoice() : ms_mascotoptions
  • getReportRatioByName() : ms_quant_method
  • getReportRatioByNumber() : ms_quant_method
  • getReportRatioFromFile() : ms_ms2quantitation
  • getReportRatioNamesInFile() : ms_ms2quantitation
  • getReportRatioSchemaType() : ms_quant_method
  • getReporttop() : ms_distiller_data_search
  • getREPTYPE() : ms_searchparams
  • getReqPepNeutralLoss() : ms_modification
  • getRequestData() : ms_http_helper_handles
  • getRequireBoldRed() : ms_distiller_data_search
  • getRequireBoldRedSchemaType() : ms_quant_method
  • getRequiredSchemaFileNames() : ms_distiller_data
  • getRequiredSchemaType() : ms_quant_pepneutralloss , ms_quant_modgroup
  • getResfile() : ms_mascotresults , ms_mascotresfile
  • getResfileCache() : ms_mascotoptions
  • getResfileStreamName() : ms_distiller_search_status
  • getResidueMass() : ms_masses , ms_modification , ms_searchparams
  • getRestrict() : ms_enzyme
  • getResult() : ms_shapiro_wilk
  • getResultsCache() : ms_mascotoptions
  • getResultsFile() : ms_distiller_subsearch , ms_distiller_search_status
  • getResultsFileFormatVersion() : ms_mascotoptions
  • getResultsFileName() : ms_http_client_search
  • getResultsFullURL() : ms_mascotoptions
  • getResultsFullURL_2() : ms_mascotoptions
  • getResultsListStreamName() : ms_distiller_sub_project
  • getResultsParameters() : ms_mascotresults
  • getResultsPerlScript() : ms_mascotoptions
  • getResultsPerlScript_2() : ms_mascotoptions
  • getResultsStreamName() : ms_distiller_data_quant
  • getRetentionTimes() : ms_inputquery
  • getReviewColDisplay() : ms_mascotoptions
  • getReviewColWidth() : ms_mascotoptions
  • getRMSDeltas() : ms_protein
  • getRt() : ms_ms1quant_match_range
  • getRtPeakEnd() : ms_xic
  • getRtPeakStart() : ms_xic
  • getRtRegionEnd() : ms_xic
  • getRtRegionStart() : ms_xic
  • getRule() : ms_parserule_plus
  • getRULES() : ms_searchparams , ms_inputquery
  • getRuleStr() : ms_parserule
  • getSampleSize() : ms_protein_quant_ratio
  • getSARExtendedErrorCode() : ms_fileutilities
  • getSatellite() : ms_quant_component
  • getSatelliteSchemaType() : ms_quant_component
  • getScan() : ms_ms1quant_match_range
  • getScanNumbers() : ms_inputquery
  • getSchemaDirectory() : ms_quant_configfile
  • getSchemaFileName() : ms_crosslinking_configfile , ms_umod_configfile , ms_quant_configfile
  • getSchemaType() : ms_umod_aminoacid , ms_quant_normalisation_peptide , ms_crosslinking_accessions , ms_crosslinking_filters , ms_xml_parameter , ms_crosslinking_monolink , ms_crosslinking_settings , ms_quant_composition , ms_xml_parameters , ms_quant_localdef , ms_crosslinking_parameters , ms_umod_modification , ms_quant_multiplex , ms_quant_normalisation , ms_quant_normalisation_peptides , ms_quant_outliers , ms_umod_neutralloss , ms_umod_specificity , ms_umod_composition , ms_quant_replicate , ms_umod_modbrick , ms_quant_unmodified , ms_umod_elemref , ms_umod_element , ms_quant_satellite , ms_quant_protocol , ms_quant_specificity , ms_quant_quality , ms_quant_reporter , ms_quant_ratio , ms_quant_parameters , ms_quant_normalisation_protein , ms_quant_pepneutralloss , ms_quant_precursor , ms_quant_normalisation_proteins , ms_quant_parameter , ms_quant_numerator , ms_quant_method , ms_quant_modgroup , ms_quant_moverz , ms_quant_integration , ms_quant_average , ms_quant_neutralloss , ms_quant_isotope , ms_quant_component , ms_quant_correction , ms_quant_element , ms_crosslinking_linker , ms_crosslinking_scope , ms_crosslinking_linkers , ms_crosslinking_parameter , ms_crosslinking_method , ms_crosslinking_does_not_pair_with , ms_umod_xref , ms_crosslinking_accession
  • getScope() : ms_crosslinking_method
  • getScopeSchemaType() : ms_crosslinking_method
  • getScore() : ms_protein
  • getScoreExpectCutOff() : ms_distiller_data_search
  • getScoreWithET() : ms_protein
  • getScoring() : ms_distiller_data_search
  • getSearch() : ms_distiller_master_project , ms_distiller_data , ms_distiller_search_status_list
  • getSEARCH() : ms_searchparams
  • getSearchCount() : ms_distiller_data
  • getSearchLogFile() : ms_mascotoptions
  • getSearchStatusListStreamName() : ms_distiller_search_status_list
  • getSearchSubmitMode() : ms_mascotoptions
  • getSearchTaskID() : ms_http_client_search
  • getSecsToWaitForNodeAtStartup() : ms_clusterparams
  • getSectionName() : ms_mascotresfile
  • getSectionValue() : ms_mascotresfile
  • getSectionValueDouble() : ms_mascotresfile
  • getSectionValueInt() : ms_mascotresfile
  • getSectionValueStr() : ms_mascotresfile
  • getSEG() : ms_searchparams
  • getSelection() : ms_quant_average
  • getSelectionSchemaType() : ms_quant_average
  • getSelectSwitch() : ms_mascotoptions
  • getSendmailPath() : ms_mascotoptions
  • getSeparateLockMem() : ms_mascotoptions
  • getSeq() : ms_quant_method , ms_inputquery
  • getSeqEntryByName() : ms_wwwoptions
  • getSeqSchemaType() : ms_quant_method
  • getSequence() : ms_spectral_lib_entry , ms_quant_normalisation_peptide
  • getSequenceFile() : ms_http_client_session
  • getSequenceFromNumber() : ms_spectral_lib_file
  • getSequenceMass() : ms_mascotresults
  • getSequenceSchemaType() : ms_quant_normalisation_peptide
  • getSeriesDescription() : ms_fragmentationrules
  • getSeriesName() : ms_fragmentationrules , ms_fragment
  • getSeriesUsedStr() : ms_peptide
  • getServer() : ms_distiller_search_status
  • getSessionID() : ms_http_client_session , ms_http_client_search , ms_connection_settings
  • getSessionTimeout() : ms_security_options
  • getSettings() : ms_crosslinking_method
  • getSettingsSchemaType() : ms_crosslinking_method
  • getShift() : ms_quant_correction
  • getShiftSchemaType() : ms_quant_correction
  • getShowSamesets() : ms_distiller_data_search
  • getShowSamesetsFamily() : ms_distiller_data_search
  • getShowSubset() : ms_distiller_data_search
  • getShowSubsetFamily() : ms_distiller_data_search
  • getShowSubsets() : ms_mascotoptions
  • getShowSubSets() : ms_quant_method
  • getShowSubSetsSchemaType() : ms_quant_method
  • getSigmaA() : ms_fitexy_result
  • getSigmaB() : ms_fitexy_result
  • getSigmaX() : ms_fitexy_result
  • getSigmaY() : ms_fitexy_result
  • getSignificanceThreshold() : ms_distiller_data_search
  • getSigThreshold() : ms_mascotoptions
  • getSigThresholdValue() : ms_quant_method
  • getSigThresholdValueSchemaType() : ms_quant_method
  • getSimilarProteinDB() : ms_protein
  • getSimilarProteinName() : ms_protein
  • getSimilarProteins() : ms_protein
  • getSimpleRatioSchemaType() : ms_quant_integration
  • getSingleHit() : ms_mascotresults_params
  • getSite() : ms_quant_unmodified , ms_quant_specificity , ms_umod_specificity
  • getSiteAnalysisMD10Prob() : ms_mascotoptions
  • getSiteFrom() : ms_linker_site
  • getSiteSchemaType() : ms_umod_specificity , ms_quant_specificity , ms_quant_unmodified
  • getSiteTo() : ms_linker_site
  • getSkippedKeys() : ms_protein_quant_ratio
  • getSLDatabaseNumbersOfReference() : ms_mascotresfile
  • getSLFragmentTolerance() : ms_mascotresfile
  • getSLFragmentToleranceUnit() : ms_mascotresfile
  • getSLThresholdFromMinProbability() : ms_peptidesummary
  • getSortedFinitePeptideRatioValues() : ms_ms2quantitation , ms_quantitation , ms_customquantitation
  • getSortUnassigned() : ms_mascotoptions
  • getSource() : ms_umod_xref , ms_quant_integration
  • getSourceSchemaType() : ms_quant_integration , ms_umod_xref
  • getSpecGroup() : ms_umod_specificity
  • getSpecGroupSchemaType() : ms_umod_specificity
  • getSpeciesFile() : ms_taxonomyrules
  • getSpeciesFormatRegex() : ms_taxonomyrules
  • getSpecificity() : ms_umod_modification , ms_quant_localdef
  • getSpecificityBySite() : ms_umod_modification
  • getSpecificityBySiteAndPosition() : ms_umod_modification
  • getSpecificitySchemaType() : ms_quant_localdef , ms_umod_modification
  • getSpectralLibraryDisplayOption() : ms_distiller_data_search
  • getSpectraPerLibraryBlock() : ms_mascotoptions
  • getSpectrumViewerColourSchemeNames() : ms_mascotoptions
  • getSpectrumViewerColourSchemeString() : ms_mascotoptions
  • getSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • getSplitDataFileSize() : ms_mascotoptions
  • getSplitNumberOfQueries() : ms_mascotoptions
  • getSpoofableUsers() : ms_session
  • getSrcDatabaseRule() : ms_taxonomyrules
  • getSrcQueryAndFileIdForMultiFile() : ms_mascotresfile
  • getSrcRank() : ms_peptidesummary
  • getSrcSection() : ms_peptidesummary
  • getStandardDeviation() : ms_protein_quant_ratio
  • getStandardError() : ms_protein_quant_ratio
  • getStart() : ms_fragment
  • getStartDate() : ms_license
  • getStartIndex() : ms_xic
  • getStartScanId() : ms_xic
  • getStatsInformation() : ms_spectral_lib_file
  • getStatus() : ms_http_client_search , ms_progress_info , ms_ms1quant_match_ratio , ms_ms1quant_peptide_status
  • getStatusList() : ms_ms1quant_match_ratio
  • getStatusMsg() : ms_distiller_search_status
  • getStrategy() : ms_crosslinking_method
  • getStrategySchemaType() : ms_crosslinking_method
  • getStreamNumber() : ms_distiller_data_quant
  • getStrFile() : ms_taxonomyrules
  • getStringIons1() : ms_inputquery
  • getStringIons2() : ms_inputquery
  • getStringIons3() : ms_inputquery
  • getStringParam() : ms_session , ms_user , ms_group , ms_user , ms_group , ms_session
  • getStringParams() : ms_security_task
  • getStringTitle() : ms_inputquery
  • getStrRule() : ms_taxonomyrules
  • getSUBCLUSTER() : ms_searchparams
  • getSubClusterID() : ms_clusterparams
  • getSubClusterMaxCPU() : ms_clusterparams
  • getSubmitTime() : ms_distiller_search_status
  • getSubproject() : ms_distiller_master_project
  • getSubsearch() : ms_distiller_master_search
  • getSubtaskProgress() : ms_progress_info
  • getSuffixRemove() : ms_taxonomyrules
  • getSummary() : ms_ms1quantitation
  • getSummedModsNlStr() : ms_peptide
  • getSummedModsStr() : ms_peptide , ms_ms1quant_match_component
  • getSVGSpectrumSwitch() : ms_mascotoptions
  • getSymbol() : ms_umod_elemref , ms_quant_element
  • getSymbolSchemaType() : ms_umod_elemref , ms_quant_element
  • getSystemError() : ms_http_helper_return
  • getTag() : ms_inputquery
  • getTagDeltaRangeEnd() : ms_mascotresults , ms_proteinsummary , ms_peptidesummary
  • getTagDeltaRangeStart() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getTagEnd() : ms_mascotresults
  • getTagSeries() : ms_mascotresults
  • getTagStart() : ms_mascotresults
  • getTagString() : ms_peptidesummary , ms_mascotresults , ms_proteinsummary
  • getTARGET_FDR_PERCENT() : ms_searchparams
  • getTargetFDR() : ms_mascotresults_params
  • getTargetFDRPercentage() : ms_mascotoptions
  • getTargetFDRType() : ms_mascotresults_params
  • getTask() : ms_security_tasks
  • getTaskFromID() : ms_security_tasks
  • getTaskId() : ms_distiller_search_status , ms_distiller_data_quant , ms_distiller_subsearch , ms_distiller_data_search
  • getTasks() : ms_security
  • getTaxBrowserUrl() : ms_mascotoptions
  • getTaxIDArray() : ms_taxonomytree
  • getTaxonomy() : ms_mascotresfile
  • getTAXONOMY() : ms_searchparams
  • getTaxonomyParseRuleIndex() : ms_databaseoptions
  • getTaxonomyRules() : ms_datfile
  • getTerminalResiduesString() : ms_proteinsummary , ms_peptidesummary , ms_mascotresults
  • getTestDirectory() : ms_mascotoptions
  • getText() : ms_umod_xref
  • getTextSchemaType() : ms_umod_xref
  • getThreadProcessorID() : ms_dbprocessors
  • getThreeLetter() : ms_umod_aminoacid
  • getThreeLetterSchemaType() : ms_umod_aminoacid
  • getThresholdForFDRAboveHomology() : ms_mascotresults
  • getThresholdForFDRAboveIdentity() : ms_mascotresults
  • getTimeout() : ms_session
  • getTimeParam() : ms_session
  • getTitle() : ms_umod_aminoacid , ms_umod_modbrick , ms_quant_localdef , ms_unigene_entry , ms_distiller_search_status , ms_umod_element , ms_distiller_subsearch , ms_fragmentationrules , ms_taxonomychoice , ms_modification , ms_enzyme , ms_umod_modification
  • getTitleSchemaType() : ms_umod_element , ms_umod_modification , ms_quant_localdef , ms_umod_aminoacid , ms_umod_modbrick
  • getTOL() : ms_searchparams
  • getToleranceInDa() : ms_libraryoptions
  • getToleranceInDalton() : ms_mascotresults
  • getToleranceInPPM() : ms_libraryoptions
  • getTOLU() : ms_searchparams
  • getTotal() : ms_progress_info
  • getTotalBytes() : ms_http_helper_progress
  • getTotalIntensity() : ms_ms1quant_charge_state
  • getTotalIntensitySchemaType() : ms_quant_quality
  • getTotalIntensityThreshold() : ms_quant_quality
  • getTotalIntensityThresholdSchemaType() : ms_quant_quality
  • getTotalIonsIntensity() : ms_inputquery
  • getTotalSeriesOutput() : ms_fragmentationrules
  • getTreeClusterNodes() : ms_peptidesummary , ms_mascotresults
  • getType() : ms_quant_correction , ms_quant_protocol , ms_security_task , ms_wwwentry , ms_distiller_sub_project
  • getTypeSchemaType() : ms_quant_correction
  • getUnassigned() : ms_mascotresults
  • getUnassignedIsBold() : ms_mascotresults
  • getUnassignedShowCheckbox() : ms_mascotresults
  • getUnigeneForAccession() : ms_unigene
  • getUnigeneIndexFile() : ms_mascotresults_params
  • getUniGeneOptions() : ms_datfile
  • getUnimod() : ms_mascotresfile
  • getUnimodXL() : ms_mascotresfile
  • getUniqueJobStartNumber() : ms_mascotoptions
  • getUniquePepseqSchemaType() : ms_quant_quality
  • getUniqueTaskID() : ms_mascotresfile
  • getUnixDirPerm() : ms_mascotoptions
  • getUnixWebUserGroup() : ms_mascotoptions
  • getUnmatchedAnnotationStr() : ms_spectral_lib_peak
  • getUnmatchedMasses() : ms_protein
  • getUnmodified() : ms_quant_modgroup
  • getUnmodifiedSchemaType() : ms_quant_modgroup
  • getUnnormalisedAveragePeptideRatio() : ms_customquantitation
  • getUnZipped() : ms_zip
  • getUnZippedLen() : ms_zip
  • getUrl() : ms_umod_xref
  • getUrlSchemaType() : ms_umod_xref
  • getUser() : ms_security
  • getUserAgent() : ms_connection_settings
  • getUSEREMAIL() : ms_searchparams
  • getUSERField() : ms_searchparams
  • getUserFromID() : ms_security
  • getUserID() : ms_session
  • getUSERID() : ms_searchparams
  • getUserName() : ms_session
  • getUSERNAME() : ms_searchparams
  • getUsernameOfPoster() : ms_umod_modification
  • getUsernameOfPosterSchemaType() : ms_umod_modification
  • getUserType() : ms_session , ms_user
  • getUseSessionCookies() : ms_security_options
  • getUseTimeShift() : ms_xic
  • getValue() : ms_xml_parameter , ms_crosslinking_accession , ms_protein_quant_ratio , ms_peptide_quant_ratio , ms_ms1quant_match_ratio , ms_crosslinking_monolink , ms_http_client_mime
  • getValueFromKey() : ms_tinycdb
  • getValueSchemaType() : ms_crosslinking_monolink , ms_xml_parameter , ms_crosslinking_parameter , ms_crosslinking_accession , ms_quant_parameter
  • getVarModIdxFrom() : ms_linker_site
  • getVarModIdxOfLinkedSite() : ms_linker_site_vector
  • getVarModIdxTo() : ms_linker_site
  • getVarMods() : ms_ms1quant_match , ms_aahelper
  • getVarModsDelta() : ms_searchparams
  • getVarModsName() : ms_searchparams
  • getVarModsNeutralLoss() : ms_searchparams
  • getVarModsNeutralLosses() : ms_searchparams
  • getVarModsPepNeutralLoss() : ms_searchparams
  • getVarModsReqPepNeutralLoss() : ms_searchparams
  • getVarModsStr() : ms_peptide , ms_ms1quant_match_component
  • getVector() : ms_fragmentvector
  • getVerifySessionIPAddress() : ms_security_options
  • getVersion() : ms_http_client
  • getVmemory() : ms_mascotoptions
  • getWeight() : ms_peptide_quant_ratio
  • getWhichAvailableForMascot() : ms_processors
  • getWhichAvailableForMascot2() : ms_processors
  • getWWWOptions() : ms_datfile
  • getXic() : ms_ms1quant_match_component
  • getXicMaxWidth() : ms_quant_integration
  • getXicMaxWidthSchemaType() : ms_quant_integration
  • getXicSmoothing() : ms_quant_integration
  • getXicSmoothingSchemaType() : ms_quant_integration
  • getXicThreshold() : ms_quant_integration
  • getXicThresholdSchemaType() : ms_quant_integration
  • getXmlCode() : ms_ms1quant_peptide_status , ms_ms1quant_match , ms_xic , ms_ms1quant_match_ratio
  • getXMLschemaFilePath() : ms_mascotresfile
  • getXref() : ms_umod_modification
  • getXrefSchemaType() : ms_umod_modification
  • getZipped() : ms_zip
  • getZippedLen() : ms_zip
  • GROUP : ms_protein
  • GROUP_COMPLETE : ms_protein
  • GROUP_FAMILY : ms_protein
  • GROUP_NO : ms_protein
  • GROUP_SUBSET : ms_protein
  • GROUP_UNKNOWN : ms_protein
  • GROUPID_ADMINISTRATORS : ms_group
  • GROUPID_DAEMONS : ms_group
  • GROUPID_GUESTS : ms_group
  • GROUPID_INTEGRA_SYSTEM : ms_group
  • GROUPID_LAST : ms_group
  • GROUPID_POWERUSERS : ms_group
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • hasAbsoluteValue() : ms_ms1quant_match_component
  • hasComponent() : ms_ms1quant_match
  • hasCrosslinkingMethod() : ms_peptidesummary
  • hasFilename() : ms_http_client_mime
  • hasIdentifiedComponent() : ms_ms1quant_match
  • hasIndexes() : ms_xic
  • hasIntensityNormalisation() : ms_ms2quantitation
  • hasPasswordExpired() : ms_user
  • hasPeptideRatio() : ms_customquantitation , ms_ms1quant_match , ms_ms2quantitation , ms_quantitation
  • hasPeptideRatioNormalisation() : ms_ms2quantitation
  • hasQuantMethod() : ms_peptidesummary
  • haveAccession() : ms_quant_normalisation_protein
  • haveAccessions() : ms_crosslinking_method
  • haveAllChargeStates() : ms_quant_integration , ms_quant_precursor
  • haveAllChargeStatesThreshold() : ms_quant_integration
  • haveAllowElutionShift() : ms_quant_integration , ms_quant_precursor
  • haveAllowMassTimeMatch() : ms_quant_precursor
  • haveApproved() : ms_umod_modification
  • haveAverage() : ms_quant_moverz
  • haveAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • haveClassification() : ms_umod_specificity
  • haveCode() : ms_umod_neutralloss
  • haveCoefficient() : ms_quant_numerator
  • haveComp() : ms_quant_method
  • haveCompositionString() : ms_umod_composition
  • haveConstrainSearch() : ms_quant_method
  • haveDatabaseName() : ms_crosslinking_accession
  • haveDateTimeModified() : ms_umod_modification
  • haveDateTimePosted() : ms_umod_modification
  • haveDelta() : ms_quant_localdef , ms_umod_modification
  • haveDescription() : ms_crosslinking_method , ms_quant_method , ms_umod_neutralloss , ms_xml_parameter
  • haveElement() : ms_quant_correction
  • haveElutionProfileCorrelationThreshold() : ms_quant_integration
  • haveElutionTimeDelta() : ms_quant_integration
  • haveElutionTimeDeltaUnit() : ms_quant_integration
  • haveExcludeInternalLabel() : ms_quant_multiplex
  • haveExcludeIsobaricFragments() : ms_quant_multiplex
  • haveFileIndex() : ms_quant_component
  • haveFilters() : ms_crosslinking_method
  • haveFlag() : ms_quant_neutralloss , ms_umod_neutralloss
  • haveFullName() : ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • haveGroupOfPoster() : ms_umod_modification
  • haveHidden() : ms_umod_specificity
  • haveIntegration() : ms_quant_method
  • haveIonIntensityThreshold() : ms_quant_multiplex
  • haveIonSeries() : ms_quant_multiplex
  • haveIsolatedPrecursor() : ms_quant_quality
  • haveIsolatedPrecursorThreshold() : ms_quant_quality
  • haveLinkers() : ms_crosslinking_method
  • haveMassDelta() : ms_quant_integration
  • haveMassDeltaUnit() : ms_quant_integration
  • haveMatchedRho() : ms_quant_integration
  • haveMethod() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • haveMinimumA1() : ms_quant_quality
  • haveMinIonPairs() : ms_quant_multiplex
  • haveMinNumPeptides() : ms_quant_method
  • haveMinPrecursorCharge() : ms_quant_quality
  • haveMiscNotes() : ms_umod_modification , ms_umod_specificity
  • haveMode() : ms_quant_modgroup
  • haveModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • haveModifications() : ms_quant_satellite
  • haveMonoisotopic() : ms_quant_moverz
  • haveMonoMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • haveMoverz() : ms_quant_component
  • haveName() : ms_crosslinking_method , ms_quant_component , ms_quant_method , ms_quant_modgroup , ms_quant_numerator , ms_quant_ratio , ms_xml_parameter
  • haveNew() : ms_quant_isotope
  • haveNormalisation() : ms_quant_method
  • haveNumber() : ms_quant_element , ms_umod_elemref
  • haveNumPeptides() : ms_quant_average
  • haveOld() : ms_quant_isotope
  • haveOutliers() : ms_quant_method
  • havePairsWith() : ms_umod_neutralloss
  • havePepThresholdType() : ms_quant_quality
  • havePepThresholdValue() : ms_quant_quality
  • havePeptides() : ms_quant_normalisation
  • havePosition() : ms_quant_unmodified , ms_quant_specificity , ms_umod_specificity
  • havePrecursorRange() : ms_quant_integration
  • haveProcessingOptions() : ms_quant_integration
  • haveProteinRatioType() : ms_quant_method
  • haveProteins() : ms_quant_normalisation
  • haveProtocol() : ms_quant_method
  • haveProtScoreType() : ms_quant_method
  • haveQuality() : ms_quant_method
  • haveRecordID() : ms_umod_modification
  • haveReferenceAccession() : ms_quant_average
  • haveReferenceAmount() : ms_quant_average
  • haveReferenceDatabase() : ms_quant_average
  • haveReportDetail() : ms_quant_method
  • haveReporterTol() : ms_quant_reporter
  • haveReporterTolUnit() : ms_quant_reporter
  • haveRequireBoldRed() : ms_quant_method
  • haveRequired() : ms_quant_pepneutralloss , ms_quant_modgroup
  • haveSatellite() : ms_quant_component
  • haveScope() : ms_crosslinking_method
  • haveSelection() : ms_quant_average
  • haveSequence() : ms_quant_normalisation_peptide
  • haveSettings() : ms_crosslinking_method
  • haveShift() : ms_quant_correction
  • haveShowSubSets() : ms_quant_method
  • haveSigThresholdValue() : ms_quant_method
  • haveSimpleRatio() : ms_quant_integration
  • haveSite() : ms_quant_unmodified , ms_umod_specificity , ms_quant_specificity
  • haveSource() : ms_quant_integration , ms_umod_xref
  • haveSpecGroup() : ms_umod_specificity
  • haveStrategy() : ms_crosslinking_method
  • haveSymbol() : ms_quant_element , ms_umod_elemref
  • haveText() : ms_umod_xref
  • haveThreeLetter() : ms_umod_aminoacid
  • haveTitle() : ms_umod_element , ms_umod_aminoacid , ms_quant_localdef , ms_umod_modification , ms_umod_modbrick
  • haveTotalIntensity() : ms_quant_quality
  • haveTotalIntensityThreshold() : ms_quant_quality
  • haveType() : ms_quant_correction
  • haveUniquePepseq() : ms_quant_quality
  • haveUrl() : ms_umod_xref
  • haveUsernameOfPoster() : ms_umod_modification
  • haveValue() : ms_crosslinking_accession
  • haveXicMaxWidth() : ms_quant_integration
  • haveXicSmoothing() : ms_quant_integration
  • haveXicThreshold() : ms_quant_integration
  • HOMOLOGY_THRESHOLD_SOURCE : ms_mascotresults
  • HOMTHR_FASTA : ms_mascotresults
  • HOMTHR_SL : ms_mascotresults
  • HT_CANNOT_DETECT : ms_processors
  • HT_DISABLED : ms_processors
  • HT_ENABLED : ms_processors
  • HT_NOT_CAPABLE : ms_processors
  • HT_SUPPORTED_NOT_ENABLED : ms_processors
  • HTTP_1_0 : ms_connection_settings
  • HTTP_1_1 : ms_connection_settings
  • HTTP_PROTOCOL : ms_connection_settings
  • HTTP_SYSTEM_DEFAULT : ms_connection_settings
  • httpBufferedClose() : ms_http_helper
  • httpBufferedGetString() : ms_http_helper
  • httpBufferedOpen() : ms_http_helper
  • httpError() : ms_http_helper_return
  • httpGetFile() : ms_http_helper
  • httpGetHeader() : ms_http_helper
  • httpGetString() : ms_http_helper
  • httpPostFile() : ms_http_helper
  • HYPERTHREADING : ms_processors
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • identityMatrix() : ms_matrix
  • IFLG_ADDMISSINGOPTIONS : ms_datfile
  • IFLG_ADDPERCOLATOROPT : ms_datfile
  • IFLG_ADDREPORTAUTO : ms_datfile
  • IFLG_DEFAULTNEWINSTALL : ms_datfile
  • IFLG_DEFAULTUPGRADE : ms_datfile
  • IFLG_UPDATEAPACHEFORKOPT : ms_datfile
  • IFLG_UPDATECLUSTER : ms_datfile
  • IFLG_UPDATEDBMANAGERPERLPATH : ms_datfile
  • IFLG_UPDATEESTTAX : ms_datfile
  • IFLG_UPDATEEXECAFTERSEARCH : ms_datfile
  • IFLG_UPDATEMSPEPSEARCHOPTS : ms_datfile
  • IFLG_UPDATENCBIHTTPS : ms_datfile
  • IFLG_UPDATEPARSERULES : ms_datfile
  • IFLG_UPDATEPERCOLATORFEATS : ms_datfile
  • IFLG_UPDATEPRIDECONTAMINANTS : ms_datfile
  • IFLG_UPDATEPROTFAMILYSWITCH : ms_datfile
  • IFLG_UPDATESWISSPROT : ms_datfile
  • IFLG_UPDATETAXONOMY : ms_datfile
  • IH_INCLUDE_TOP_10_MATCHES : ms_mascotresults
  • IH_INCLUDE_TOP_MATCHES : ms_mascotresults
  • includeProteinPeptideRatioKeys() : ms_ms2quantitation
  • inErrorTolerant() : ms_modification , ms_umod_specificity
  • initGroupChargeStates() : ms_ms1quantitation
  • initialiseBaseSettings() : ms_quantitation
  • inLongList() : ms_modification , ms_umod_specificity
  • inShortList() : ms_modification , ms_umod_specificity
  • INST_FLAGS : ms_datfile
  • INTENSITY : ms_mascotresults
  • IONS_HISTOGRAM : ms_mascotresults
  • isAbortSet() : ms_http_helper_progress
  • isAccountEnabled() : ms_user
  • isActive() : ms_databaseoptions
  • isAllChargeStates() : ms_quant_integration , ms_quant_precursor
  • isAllowElutionShift() : ms_quant_integration , ms_quant_precursor
  • isAllowMassTimeMatch() : ms_quant_precursor
  • isApproved() : ms_umod_modification
  • isASimilarProtein() : ms_protein
  • isAutoSelectCharge() : ms_mascotoptions
  • isAvailable() : ms_parserule
  • isAverageProtocol() : ms_ms1quantitation
  • isBackboneSeries() : ms_fragmentationrules
  • isBreaking() : ms_progress_info
  • isCharged2Plus() : ms_fragmentationrules
  • isCharged3Plus() : ms_fragmentationrules
  • isComplete() : ms_http_helper_progress
  • isComponentIdentified() : ms_ms1quant_match_component
  • isConcatRefFileLines() : ms_taxonomyrules
  • isConstrainSearch() : ms_quant_method
  • isCreating() : ms_tinycdb
  • isCronEnabled() : ms_cronoptions
  • isCTerminal() : ms_fragment
  • isDatabaseTypeAvailable() : ms_mascotresfile
  • isDataCached() : ms_peptidesummary , ms_ms1quantitation
  • isDayOfMonth() : ms_cronjob
  • isDayOfWeek() : ms_cronjob
  • isDBLevelTaxId() : ms_taxonomyrules
  • isDefaultTargetFDRPercentage() : ms_mascotoptions
  • isDirectory() : ms_fileutilities
  • isEmailErrorsEnabled() : ms_mascotoptions
  • isEmailUsersEnabled() : ms_mascotoptions
  • isEmPAIallowed() : ms_mascotresults
  • isEnabled() : ms_clusterparams , ms_cronjob , ms_taxonomyrules
  • isErrorTolerant() : ms_mascotresfile
  • isExcluded() : ms_peptide_quant_ratio
  • isExcludeInternalLabel() : ms_quant_multiplex
  • isExcludeIsobaricFragments() : ms_quant_multiplex
  • isFastaPermitted() : ms_session , ms_security_tasks
  • isFileWritable() : ms_fileutilities
  • isFlag() : ms_quant_neutralloss , ms_umod_neutralloss
  • isForkForUnixApache() : ms_mascotoptions
  • isFromAlpha() : ms_fragment
  • isFromBeta() : ms_fragment
  • isFromRefFile() : ms_taxonomyrules
  • isFromSubstitutions() : ms_modfile
  • isGeneratedMonoLinker() : ms_modification
  • isHidden() : ms_modification , ms_umod_specificity
  • isHitRatioExcluded() : ms_ms1quant_match
  • isHitRatioOutlier() : ms_ms1quant_match
  • isHitRatioUsedForAverage() : ms_ms1quant_match
  • isHour() : ms_cronjob
  • isImmonium() : ms_fragment
  • isIncluded() : ms_ms1quant_match_ratio
  • isIncludedIn() : ms_taxonomytree
  • isIndependent() : ms_enzyme
  • isInfinite() : ms_peptide_quant_ratio
  • isInIgnoreDupeAccessionList() : ms_mascotoptions
  • isInternal() : ms_fragment
  • isIsolatedPrecursor() : ms_quant_quality
  • isIteratePMFIntensities() : ms_mascotoptions
  • isLabelAll() : ms_mascotoptions
  • isLicenseValid() : ms_license
  • isLocalRefFile() : ms_databaseoptions
  • isLockMemory() : ms_databaseoptions
  • isLogicalCPUAvailableForMascot() : ms_processors
  • isLogNormal() : ms_protein_quant_ratio
  • isLoopLinker() : ms_modification
  • isMatchedToCalculatedPeak() : ms_spectral_lib_peak
  • isMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • isMemoryMapFiles() : ms_databaseoptions
  • isMethodCompatible() : ms_quant_method
  • isMinute() : ms_cronjob
  • isMissing() : ms_peptide_quant_ratio , ms_protein_quant_ratio
  • isMitochondrialTranslation() : ms_taxonomyrules
  • isMonthOfYear() : ms_cronjob
  • isMoveOldDbToOldDir() : ms_mascotoptions
  • isMSMS() : ms_mascotresfile
  • isNA() : ms_mascotresults
  • isNeutralLossSeries() : ms_fragmentationrules
  • isNil() : ms_peptide_quant_key
  • isNoneFound() : ms_enzymefile
  • isNTerminal() : ms_fragment
  • isOk() : ms_http_helper_return
  • isOpenForReading() : ms_tinycdb
  • isPeptideComponentMatch() : ms_peptidesummary
  • isPeptideModificationMatch() : ms_peptidesummary
  • isPeptideQualityOK() : ms_quant_helper
  • isPeptideQuantifiable() : ms_quant_helper
  • isPeptideRatioExcluded() : ms_customquantitation , ms_ms2quantitation , ms_quantitation
  • isPeptideUnique() : ms_peptidesummary , ms_mascotresults , ms_proteinsummary
  • isPercolator() : ms_mascotoptions
  • isPercolatorUseProteins() : ms_mascotoptions
  • isPercolatorUseRT() : ms_mascotoptions
  • isPermitted() : ms_session , ms_security_task , ms_security_tasks
  • isPermitted_double() : ms_security_task , ms_security_tasks , ms_session
  • isPermitted_long() : ms_session , ms_security_task , ms_security_tasks
  • isPermitted_string() : ms_session , ms_security_task , ms_security_tasks
  • isPMF() : ms_mascotresfile
  • isPMFMixture() : ms_protein
  • isPmfQueryUsed() : ms_proteinsummary
  • isPossibleToCreate() : ms_tinycdb
  • isPrecursorNL() : ms_fragment
  • isPrimaryLogicalProcessor() : ms_processors
  • isPrivacyEnabled() : ms_umod_modification
  • isPrivate() : ms_umod_modification
  • isProcessAffinitySupported() : ms_processors
  • isReferenceUserSelected() : ms_ms1quant_average_results
  • isRegular() : ms_fragment
  • isRemoveOldIndexFiles() : ms_mascotoptions
  • isReportDetail() : ms_quant_method
  • isRequireBoldRed() : ms_mascotoptions , ms_quant_method
  • isRequired() : ms_quant_pepneutralloss , ms_quant_modgroup
  • isResidueModified() : ms_masses , ms_modification
  • isSame() : ms_masses
  • isSameAs() : ms_umod_composition , ms_umod_modification , ms_umod_specificity , ms_umod_xref
  • isSamePeptideStr() : ms_peptide
  • isSameSummedModsStr() : ms_peptide
  • isSameVarModsStr() : ms_peptide
  • isSaveEveryLastQueryAsc() : ms_mascotoptions
  • isSaveLastQueryAsc() : ms_mascotoptions
  • isSectionAvailable() : ms_unigeneoptions , ms_cronoptions , ms_processoroptions , ms_libraryoptions , ms_wwwoptions , ms_mascotoptions , ms_parseoptions , ms_databases , ms_clusterparams , ms_taxonomyrules
  • isSecurityEnabled() : ms_session , ms_security_options
  • isSemiSpecific() : ms_enzyme
  • isSeriesUsed() : ms_fragmentationrules
  • isSet() : ms_ms1quant_match_ratio
  • isShowAllFromErrorTolerant() : ms_mascotoptions
  • isShowSubsets() : ms_mascotoptions
  • isSignificant() : ms_protein_quant_ratio
  • isSimilarProtein() : ms_protein
  • isSimpleRatio() : ms_quant_integration
  • isSinglyCharged() : ms_fragmentationrules
  • isSpeciesDescendantOf() : ms_taxonomytree
  • isSQ() : ms_mascotresfile
  • isStarted() : ms_http_helper_progress
  • isStoreModPermutations() : ms_mascotoptions
  • isSubstitution() : ms_modification
  • isSuspectAssignment() : ms_spectral_lib_peak
  • isTaskExists() : ms_security , ms_security_tasks
  • isThreadedLogicalProcessor() : ms_processors
  • isTimedOut() : ms_session
  • isTotalIntensity() : ms_quant_quality
  • isUnigene() : ms_protein
  • isUniquePepseq() : ms_quant_quality
  • isUnixDirPermDefined() : ms_mascotoptions
  • isUsedForAverage() : ms_ms1quant_match_ratio
  • isUseHTTPProxyForFTP() : ms_mascotoptions , ms_connection_settings
  • isUseHTTPProxyForHTTPS() : ms_connection_settings , ms_mascotoptions
  • isUsePeptideSummary() : ms_mascotresults_params
  • isUseProcessesNotThreads() : ms_processors
  • isUserExists() : ms_security
  • isUserInGroup() : ms_group
  • isValid() : ms_ms1quant_match_ratio , ms_errors , ms_spectral_lib_peak , ms_errs , ms_fragmentationrules , ms_enzyme
  • isZero() : ms_matrix
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • params() : ms_mascotresfile
  • paramType : ms_security_task
  • parseCommandLineArgumentString() : ms_fileutilities
  • parseLine() : ms_obofile
  • PEAK_ANNOTATION_LEVEL : ms_spectral_lib_peak_list
  • PEAK_STATE_DISCARD : ms_xic
  • PEAK_STATE_OK : ms_xic
  • PEAK_STATE_UNKNOWN : ms_xic
  • peakState : ms_xic
  • PEPSUMMARY_CACHE_BEING_CREATED : ms_peptidesummary
  • PEPSUMMARY_CACHE_CAN_CREATE : ms_peptidesummary
  • PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • PEPSUMMARY_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • PEPSUMMARY_CACHE_NOT_FOR_PMF : ms_peptidesummary
  • PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE : ms_peptidesummary
  • PEPSUMMARY_CACHE_VALID : ms_peptidesummary
  • PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN : ms_quant_helper
  • PEPTIDE_EXPECT_ABOVE_THRESHOLD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_EXCLUSIVE_MODS : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_UNMODIFIED_SITE : ms_quant_helper
  • PEPTIDE_IS_QUANTIFIABLE : ms_quant_helper
  • PEPTIDE_NOT_UNIQUE : ms_quant_helper
  • PEPTIDE_QUALITY : ms_quant_helper
  • PEPTIDE_QUALITY_IS_OK : ms_quant_helper
  • PEPTIDE_QUALITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_HOMOLOGY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_SCORE_THR : ms_quant_helper
  • peptideStatus : ms_ms1quant_peptide_status
  • PERC_EXE_RT : ms_mascotoptions
  • PERC_EXE_RT_FORCE_OFF : ms_mascotoptions
  • PERC_EXE_RT_FORCE_ON : ms_mascotoptions
  • PERC_EXE_RT_USE_DEFAULT : ms_mascotoptions
  • PERCOLATOR_FILE_NAMES : ms_mascotresfile
  • PERCOLATOR_INPUT_FILE : ms_mascotresfile
  • PERCOLATOR_OUTPUT_DECOY : ms_mascotresfile
  • PERCOLATOR_OUTPUT_TARGET : ms_mascotresfile
  • poissonDensity() : ms_quant_stats
  • pop() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • prepareToCreate() : ms_tinycdb
  • proteinKeys_ : ms_quantitation
  • PROXY_TYPE : ms_connection_settings
  • PROXY_TYPE_AUTO : ms_connection_settings
  • PROXY_TYPE_ENVIRONMENT : ms_connection_settings
  • PROXY_TYPE_FROM_REGISTRY : ms_connection_settings
  • PROXY_TYPE_NO_PROXY : ms_connection_settings
  • PROXY_TYPE_SPECIFY : ms_connection_settings
  • PROXY_TYPE_WPAD : ms_connection_settings
  • proxyTypeStringToEnum() : ms_connection_settings
  • proxyTypeToString() : ms_connection_settings
  • PS_DUPLICATESAMEQUERY : ms_ms1quant_peptide_status
  • PS_EXCLUDE_LOCALDEF : ms_ms1quant_peptide_status
  • PS_EXCLUDE_MODFILE : ms_ms1quant_peptide_status
  • PS_EXCLUDE_UNMODIFIED : ms_ms1quant_peptide_status
  • PS_EXPECTGREATERTHAN : ms_ms1quant_peptide_status
  • PS_LESSTHANIDENTITY : ms_ms1quant_peptide_status
  • PS_MAX : ms_ms1quant_peptide_status
  • PS_MINCHARGE : ms_ms1quant_peptide_status
  • PS_NOTPARTOFQUANTITATION : ms_ms1quant_peptide_status
  • PS_NOTUNIQUE : ms_ms1quant_peptide_status
  • PS_OK : ms_ms1quant_peptide_status
  • PS_SCORELESSHOMOLOGY : ms_ms1quant_peptide_status
  • PS_SCORELESSIDENTITY_NOHOMO : ms_ms1quant_peptide_status
  • PS_SCORELESSTHRESHOLD : ms_ms1quant_peptide_status
  • PSM : ms_peptide
  • PSM_COMPLETE : ms_peptide
  • PSM_CROSSLINK_ALPHA : ms_peptide
  • PSM_CROSSLINK_BETA : ms_peptide
  • push() : ms_peptide_quant_key_vector , ms_linker_site_vector
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QCS_ERROR_BAD_COMPONENT_NAME : ms_mascotresults
  • QCS_ERROR_NO_COMPONENTS : ms_mascotresults
  • QCS_ERROR_NO_METHOD : ms_mascotresults
  • QCS_OK : ms_mascotresults
  • QCS_OK_MULTIPLE_MATCHES : ms_mascotresults
  • QCS_OK_NO_MATCH : ms_mascotresults
  • QL_ALL : ms_peptidesummary
  • QL_BELOW_HOMOLOGY : ms_peptidesummary
  • QL_BELOW_IDENTITY : ms_peptidesummary
  • QL_FLAG : ms_peptidesummary
  • QL_IGNORE_IONS_SCORE_BELOW : ms_peptidesummary
  • QL_LAST : ms_peptidesummary
  • QL_UNASSIGNED : ms_peptidesummary
  • QUANT_COMPONENT_STATUS : ms_mascotresults
  • QUERY : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • ratioStatusCode : ms_ms1quant_match_ratio
  • read_buffer() : ms_crosslinking_configfile , ms_fragrulesfile , ms_quant_configfile , ms_enzymefile , ms_taxonomyfile , ms_umod_configfile
  • read_file() : ms_crosslinking_configfile , ms_taxonomyfile , ms_umod_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_license , ms_masses , ms_modfile , ms_quant_configfile
  • readResultCounters() : ms_ms1quantitation
  • REDIRECT_POLICY : ms_connection_settings
  • REDIRECT_POLICY_ALWAYS : ms_connection_settings
  • REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP : ms_connection_settings
  • REDIRECT_POLICY_NEVER : ms_connection_settings
  • removeAllTasks() : ms_security_tasks
  • removeCombinedReportRatio() : ms_ms2quantitation
  • removeComponent() : ms_ms1quant_match
  • removeIntensityNormalisationBase() : ms_ms2quantitation
  • removeIntensityNormalisationBases() : ms_ms2quantitation
  • removeLogEventsHandler() : ms_loggingmonitor
  • removeMatch() : ms_ms1quantitation
  • removePeptideQuantKey() : ms_customquantitation
  • removePeptideRatio() : ms_customquantitation
  • removePeptideRatioNormalisationBase() : ms_quantitation
  • removePeptideRatioNormalisationBases() : ms_quantitation
  • removePermittedTask() : ms_group
  • removeReportRatioInFile() : ms_ms2quantitation
  • removeSubtask() : ms_progress_info
  • removeTask() : ms_security_tasks
  • ReportTopSpecialValues : ms_http_client_search
  • resetKeepAlive() : ms_mascotresfile
  • RESFILE_CACHE_BEING_CREATED : ms_peptidesummary
  • RESFILE_CACHE_CAN_CREATE : ms_peptidesummary
  • RESFILE_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • RESFILE_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • RESFILE_CACHE_IGNORE_ACC_DUPES : ms_mascotresfile
  • RESFILE_CACHE_IGNORE_DATE_CHANGE : ms_mascotresfile
  • RESFILE_CACHE_VALID : ms_peptidesummary
  • RESFILE_NOFLAG : ms_mascotresfile
  • RESFILE_USE_CACHE : ms_mascotresfile
  • RESFILE_USE_PARENT_PARAMS : ms_mascotresfile
  • resize() : ms_matrix
  • rowMatrix() : ms_matrix
  • RS_DO_NOT_USE : ms_ms1quant_match_ratio
  • RS_EMPTY : ms_ms1quant_match_ratio
  • RS_FITEXYSIGMA : ms_ms1quant_match_ratio
  • RS_INFINITERATIO : ms_ms1quant_match_ratio
  • RS_INTEFERENCEFAILED : ms_ms1quant_match_ratio
  • RS_ISOLATEDPRECURSORFAILED : ms_ms1quant_match_ratio
  • RS_NEGATIVERATIO : ms_ms1quant_match_ratio
  • RS_NODATA : ms_ms1quant_match_ratio
  • RS_OK : ms_ms1quant_match_ratio
  • RS_TOTALINTENSITYFAILED : ms_ms1quant_match_ratio
  • RS_ZERORATIO : ms_ms1quant_match_ratio
  • RT_auto : ms_http_client_search
  • RT_file : ms_http_client_search
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • S_NOT_STARTED : ms_progress_info
  • S_RUNNING : ms_progress_info
  • S_RUNNING_INDETERMINATE : ms_progress_info
  • S_STOPPED_BREAK : ms_progress_info
  • S_STOPPED_COMPLETE : ms_progress_info
  • S_STOPPED_FAIL : ms_progress_info
  • SAR_FAIL_CHMOD : ms_fileutilities
  • SAR_FAIL_CHOWN : ms_fileutilities
  • SAR_FAIL_GET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_FAIL_SET_ENTRIES_IN_ACL : ms_fileutilities
  • SAR_FAIL_SET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_SUCCESS : ms_fileutilities
  • save_buffer() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • save_file() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_umod_configfile
  • saveAs() : ms_spectral_lib_file
  • saveBoolParam() : ms_session
  • saveCdbFile() : ms_ms1quantitation , ms_ms2quantitation
  • saveDoubleParam() : ms_session
  • saveFileOffsetForKey() : ms_tinycdb
  • saveIntForKey() : ms_tinycdb
  • saveIntParam() : ms_session
  • saveLongParam() : ms_session
  • saveStringParam() : ms_group , ms_session , ms_user
  • saveTimeParam() : ms_session
  • saveToFile() : ms_security_tasks
  • saveToString() : ms_modfile
  • saveValueForKey() : ms_tinycdb
  • saveXmlFile() : ms_ms1quantitation , ms_ms2quantitation
  • SCORE : ms_mascotresults
  • SearchStatusCode : ms_http_client_search
  • SEC_CROSSLINK_PEPTIDES : ms_mascotresfile
  • SEC_CROSSLINK_SUMMARY : ms_mascotresfile
  • SEC_CROSSLINKING : ms_mascotresfile
  • SEC_DECOYMIXTURE : ms_mascotresfile
  • SEC_DECOYPEPTIDES : ms_mascotresfile
  • SEC_DECOYPROTEINS : ms_mascotresfile
  • SEC_DECOYSUMMARY : ms_mascotresfile
  • SEC_ENZYME : ms_mascotresfile
  • SEC_ERRTOLDECOYPEPTIDES : ms_mascotresfile
  • SEC_ERRTOLDECOYSUMMARY : ms_mascotresfile
  • SEC_ERRTOLPEPTIDES : ms_mascotresfile
  • SEC_ERRTOLSUMMARY : ms_mascotresfile
  • SEC_HEADER : ms_mascotresfile
  • SEC_INDEX : ms_mascotresfile
  • SEC_LIBRARYPEPTIDES : ms_mascotresfile
  • SEC_LIBRARYSUMMARY : ms_mascotresfile
  • SEC_MASSES : ms_mascotresfile
  • SEC_MIXTURE : ms_mascotresfile
  • SEC_NUMSECTIONS : ms_mascotresfile
  • SEC_PARAMETERS : ms_mascotresfile
  • SEC_PEPTIDES : ms_mascotresfile
  • SEC_PROTEINS : ms_mascotresfile
  • SEC_QUANTITATION : ms_mascotresfile
  • SEC_QUERY1 : ms_mascotresfile
  • SEC_SPECTRAL_LIBRARY : ms_mascotresfile
  • SEC_SUMMARY : ms_mascotresfile
  • SEC_TAXONOMY : ms_mascotresfile
  • SEC_UNIMOD : ms_mascotresfile
  • SEC_UNIMOD_XL : ms_mascotresfile
  • SECTASK_ACCESSDBSETUP : ms_security_tasks
  • SECTASK_ADMINPAGES : ms_security_tasks
  • SECTASK_ALLFASTA : ms_security_tasks
  • SECTASK_ALLOWMSMS : ms_security_tasks
  • SECTASK_ALLOWMSMSNOENZYME : ms_security_tasks
  • SECTASK_ALLOWPMF : ms_security_tasks
  • SECTASK_ALLOWPMFNOENZYME : ms_security_tasks
  • SECTASK_ALLOWSPOOFOTHERUSER : ms_security_tasks
  • SECTASK_BIOTOOLSBATCH : ms_security_tasks
  • SECTASK_DAEMONCLIENT : ms_security_tasks
  • SECTASK_DATAURLMAXSIZE : ms_security_tasks
  • SECTASK_DATAURLPROTOCOLS : ms_security_tasks
  • SECTASK_DENYQUANT : ms_security_tasks
  • SECTASK_DISTILLERCLIENT : ms_security_tasks
  • SECTASK_DOWNLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_EDITCONFIG : ms_security_tasks
  • SECTASK_INTEGRASYSTEMACCOUNT : ms_security_tasks
  • SECTASK_KILLALLTASK : ms_security_tasks
  • SECTASK_KILLTASKINGROUP : ms_security_tasks
  • SECTASK_MAXCONCURRENTSEARCHES : ms_security_tasks
  • SECTASK_MAXETACCESSIONS : ms_security_tasks
  • SECTASK_MAXETVARMODS : ms_security_tasks
  • SECTASK_MAXEXECUTIONTIME : ms_security_tasks
  • SECTASK_MAXFASTAFILES : ms_security_tasks
  • SECTASK_MAXJOBPRIORITY : ms_security_tasks
  • SECTASK_MAXNOENZQUERIES : ms_security_tasks
  • SECTASK_MAXQUERIES : ms_security_tasks
  • SECTASK_MAXVARMODS : ms_security_tasks
  • SECTASK_MODIFYOWNPROFILE : ms_security_tasks
  • SECTASK_MSSTATUSEXECLUSTER : ms_security_tasks
  • SECTASK_MSSTATUSEXERETRYDB : ms_security_tasks
  • SECTASK_NAMEDFASTA : ms_security_tasks
  • SECTASK_SEEALLSEARCHESWITHUSERID : ms_security_tasks
  • SECTASK_SEEOLDSEARCHES : ms_security_tasks
  • SECTASK_SEESEARCHINANYGROUP : ms_security_tasks
  • SECTASK_SEESEARCHINGROUP : ms_security_tasks
  • SECTASK_SPOOFNAMEDGROUPSONLY : ms_security_tasks
  • SECTASK_UPLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_USEMSREVIEWEXE : ms_security_tasks
  • SECTASK_USEMSSTATUSEXE : ms_security_tasks
  • SECTASK_VIEWCONFIG : ms_security_tasks
  • SECTASK_VIEWCONFIGUSINGMSSTATUS : ms_security_tasks
  • section : ms_mascotresfile
  • SEQDB_INSTALL : ms_datfile
  • SEQDB_INSTALL_CURRENT_RULES : ms_datfile
  • SEQDB_INSTALL_CUSTOMISED : ms_datfile
  • SEQDB_INSTALL_EXISTING_LARGER : ms_datfile
  • SEQDB_INSTALL_INACTIVE : ms_datfile
  • SEQDB_INSTALL_INVALID_CONFIG : ms_datfile
  • SEQDB_INSTALL_INVALID_DBNAME : ms_datfile
  • SEQDB_INSTALL_MISSING_CONFIG : ms_datfile
  • SEQDB_INSTALL_MUST_UPDATE_CFG : ms_datfile
  • SEQDB_INSTALL_OLD_RULES : ms_datfile
  • SEQDB_INSTALL_SHOULD_QUERY_USER : ms_datfile
  • SEQDB_INSTALL_WRONG_WILDCARD : ms_datfile
  • SequenceShowOptions : ms_http_client_session
  • serverVersionNewerOrSameAs() : ms_distiller_data_search
  • sessionId() : ms_http_client_search
  • set() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • setAbort() : ms_http_helper_progress
  • setAccession() : ms_quant_normalisation_protein
  • setAccessionParseRuleIndex() : ms_databaseoptions
  • setAccessionRefParseRuleIndex() : ms_databaseoptions
  • setAccessions() : ms_crosslinking_method
  • setAccessRights() : ms_fileutilities
  • setAccFromSpeciesLine() : ms_taxonomyrules
  • setAccountEnabled() : ms_user
  • setActive() : ms_databaseoptions
  • setAllChargeStates() : ms_quant_integration
  • setAllChargeStatesThreshold() : ms_quant_integration
  • setAllowElutionShift() : ms_quant_integration
  • setAllowMassTimeMatch() : ms_quant_precursor
  • setAnnotation() : ms_spectral_lib_peak
  • setAnnotationLevel() : ms_spectral_lib_peak_list
  • setAPI() : ms_errs
  • setApproved() : ms_umod_modification
  • setAutoSelectCharge() : ms_mascotoptions
  • setAvailable() : ms_parserule
  • setAvailableModifications() : ms_aahelper
  • setAverage() : ms_quant_moverz , ms_quant_protocol
  • setAverageNumPeptides() : ms_ms1quantitation
  • setAverageReferenceProtein() : ms_ms1quantitation
  • setAverageSelection() : ms_ms1quantitation
  • setAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • setBaseUrl() : ms_http_client
  • setBreak() : ms_progress_info
  • setCacheDirectory() : ms_mascotoptions
  • setCarbonMass() : ms_masses
  • setCentroidWidth() : ms_mascotoptions
  • setCentroidWidthCount() : ms_mascotoptions
  • setCharged2Plus() : ms_fragmentationrules
  • setCharged3Plus() : ms_fragmentationrules
  • setCheckNodesAliveFreq() : ms_clusterparams
  • setChopSource() : ms_parserule_plus
  • setClassification() : ms_umod_specificity
  • setClusterParams() : ms_datfile
  • setCode() : ms_umod_neutralloss
  • setCoefficient() : ms_quant_numerator
  • setColsToOutput() : ms_logger
  • setColumnDown() : ms_matrix
  • setColumnUp() : ms_matrix
  • setCombinedReportRatio() : ms_ms2quantitation
  • setCombineRepeats() : ms_errs
  • setCommandStr() : ms_cronjob
  • setComp() : ms_quant_method
  • setCompositionString() : ms_umod_composition
  • setCompressToolAA() : ms_mascotoptions
  • setCompressToolNA() : ms_mascotoptions
  • setCompressToolSL() : ms_mascotoptions
  • setConcatRefFileLines() : ms_taxonomyrules
  • setConnectionSettings() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_http_client , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_umod_configfile
  • setConnectionTimeout() : ms_connection_settings
  • setConstrainSearch() : ms_quant_method
  • setContent() : ms_quant_correction , ms_quant_numerator , ms_quant_unmodified
  • setCR() : ms_matrix
  • setCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • setCreatePipThreadBlockSize() : ms_mascotoptions
  • setCreatePipThreads() : ms_mascotoptions
  • setCronEnabled() : ms_cronoptions
  • setCronJob() : ms_cronoptions
  • setCronOptions() : ms_datfile
  • setCTerminusMass() : ms_modification
  • setCtermModification() : ms_masses
  • setDatabaseName() : ms_crosslinking_accession
  • setDatabases() : ms_datfile
  • setDateTimeModified() : ms_umod_modification
  • setDateTimePosted() : ms_umod_modification
  • setDayOfMonth() : ms_cronjob
  • setDayOfWeek() : ms_cronjob
  • setDB() : ms_protein
  • setDBLevelTaxId() : ms_taxonomyrules
  • setDBType() : ms_databaseoptions
  • setDechargeFragmentPeaks() : ms_mascotoptions
  • setDecoyTypeNoEnzyme() : ms_mascotoptions
  • setDecoyTypeSpecific() : ms_mascotoptions
  • setDefaultDelimiter() : ms_customproperty
  • setDefaultMonitor() : ms_loggingmonitor
  • setDefaultNodeHomeDir() : ms_clusterparams
  • setDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • setDefaultNodeOS() : ms_clusterparams
  • setDefaultPasswordExpiryTime() : ms_security_options
  • setDefaultPort() : ms_clusterparams
  • setDefaultRule() : ms_taxonomyrules
  • setDefaultTargetFDRPercentage() : ms_mascotoptions
  • setDelta() : ms_modification , ms_quant_localdef , ms_umod_modification
  • setDescription() : ms_crosslinking_method , ms_quant_method , ms_umod_neutralloss , ms_xml_parameter
  • setDescriptionLineSep() : ms_taxonomyrules
  • setDescriptionParseRuleIndex() : ms_databaseoptions
  • setDisplayNonSignificantMatches() : ms_mascotoptions
  • setDoThisRuleFirst() : ms_taxonomyrules
  • setElectronMass() : ms_masses
  • setElement() : ms_quant_correction
  • setElutionProfileCorrelationThreshold() : ms_quant_integration
  • setElutionTimeDelta() : ms_quant_integration
  • setElutionTimeDeltaUnit() : ms_quant_integration
  • setEmailAddress() : ms_user
  • setEmailErrorsEnabled() : ms_mascotoptions
  • setEmailFromTextName() : ms_mascotoptions
  • setEmailFromUser() : ms_mascotoptions
  • setEmailPassword() : ms_mascotoptions
  • setEmailProfile() : ms_mascotoptions
  • setEmailService() : ms_mascotoptions
  • setEmailTimeOutPeriod() : ms_mascotoptions
  • setEmailUsersEnabled() : ms_mascotoptions
  • setEnabled() : ms_clusterparams , ms_cronjob , ms_taxonomyrules
  • setEncryptedPassword() : ms_user
  • setEntry() : ms_wwwoptions
  • setEnzyme() : ms_aahelper
  • setEnzymes() : ms_mascotfiles
  • setErrMessageEmailTo() : ms_mascotoptions
  • setErrorLevel() : ms_taxonomyrules
  • setErrorLogFile() : ms_mascotoptions
  • setErrTolMaxAccessions() : ms_mascotoptions
  • setExcludeInternalLabel() : ms_quant_multiplex
  • setExcludeIsobaricFragments() : ms_quant_multiplex
  • setExecAfterSearch() : ms_mascotoptions
  • setFeatureTableLength() : ms_mascotoptions
  • setFeatureTableMinScore() : ms_mascotoptions
  • setFileIndex() : ms_quant_component
  • setFileName() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_license , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_taxspeciesfiles , ms_taxnodesfiles , ms_umod_configfile
  • setFileTypeToSearch() : ms_parserule_plus
  • setFilters() : ms_crosslinking_method
  • setFindFileTimeout() : ms_datfile
  • setFlag() : ms_mascotresults_params , ms_quant_neutralloss , ms_umod_neutralloss
  • setFlag2() : ms_mascotresults_params
  • setFlags() : ms_mascotresults_params
  • setFlags2() : ms_mascotresults_params
  • setForkForUnixApache() : ms_mascotoptions
  • setFormat() : ms_taxspeciesfiles , ms_taxnodesfiles
  • setFormVersion() : ms_mascotoptions
  • setFrequencies() : ms_mascotfiles
  • setFromRefFile() : ms_taxonomyrules
  • setFromSubstitutions() : ms_modfile
  • setFullName() : ms_user , ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • setGetSeqBlastAccession() : ms_mascotoptions
  • setGetSeqJobIdFile() : ms_mascotoptions
  • setGroupOfPoster() : ms_umod_modification
  • setHeaderComments() : ms_datfile
  • setHidden() : ms_modification , ms_umod_specificity
  • setHitRatioExcluded() : ms_ms1quant_match
  • setHitRatioOutlier() : ms_ms1quant_match
  • setHostName() : ms_computeraddress , ms_wwwentry
  • setHour() : ms_cronjob
  • setHttpPassword() : ms_connection_settings
  • setHttpProtocol() : ms_connection_settings
  • setHttpUsername() : ms_connection_settings
  • setHydrogenMass() : ms_masses
  • setICATFilter() : ms_mascotoptions
  • setICATHeavy() : ms_mascotoptions
  • setICATLight() : ms_mascotoptions
  • setICATQuantitationMethod() : ms_mascotoptions
  • setID() : ms_group , ms_user
  • setIdentifier() : ms_taxonomyrules
  • setIgnoreDupeAccession() : ms_mascotoptions
  • setIgnoreIonsScoreBelow() : ms_mascotoptions , ms_mascotresults_params
  • setIndependent() : ms_enzyme
  • setIndexFileName() : ms_tinycdb
  • setInErrorTolerant() : ms_modification
  • setInetAddress() : ms_computeraddress
  • setInLongList() : ms_modification
  • setInShortList() : ms_modification
  • setIntegraAppServerURL() : ms_security_options
  • setIntegraDatabaseName() : ms_security_options
  • setIntegraOracleServerName() : ms_security_options
  • setIntegration() : ms_quant_method
  • setIntensityNormalisationBase() : ms_ms2quantitation
  • setIntensitySigFigs() : ms_mascotoptions
  • setInterFileBasePath() : ms_mascotoptions
  • setInterFileRelPath() : ms_mascotoptions
  • setIonIntensityThreshold() : ms_quant_multiplex
  • setIonsDecimalPlaces() : ms_mascotoptions
  • setIonSeries() : ms_quant_multiplex
  • setIPCLogfile() : ms_clusterparams
  • setIPCLogging() : ms_clusterparams
  • setIPCTimeout() : ms_clusterparams
  • setIsolatedPrecursor() : ms_quant_quality
  • setIsolatedPrecursorThreshold() : ms_quant_quality
  • setIteratePMFIntensities() : ms_mascotoptions
  • setLabelAll() : ms_mascotoptions
  • setLastModificationTime() : ms_fileutilities
  • setLastQueryAscFile() : ms_mascotoptions
  • setLibraryOptions() : ms_datfile
  • setLinkers() : ms_crosslinking_method
  • setLocalModsStr() : ms_peptide
  • setLocalRefFile() : ms_databaseoptions
  • setLockMemory() : ms_databaseoptions
  • setLogFileName() : ms_cronoptions , ms_security_options
  • setLoggingFile() : ms_errs
  • setLoggingLevel() : ms_cronoptions , ms_errs , ms_security_options
  • setLogMask() : ms_loggingmonitor
  • setLogoImageFile() : ms_mascotoptions
  • setMailTempFile() : ms_mascotoptions
  • setMailTransport() : ms_mascotoptions
  • setMajorVersion() : ms_umod_configfile
  • setMascNodeCtrlFile() : ms_mascotoptions
  • setMascotCmdLine() : ms_mascotoptions
  • setMascotControlFile() : ms_mascotoptions
  • setMascotFileProcessingThreads() : ms_mascotoptions
  • setMascotFiles() : ms_datfile
  • setMascotJobIdFile() : ms_mascotoptions
  • setMascotMessage() : ms_mascotoptions
  • setMascotNodeRebootScript() : ms_clusterparams
  • setMascotNodeScript() : ms_clusterparams
  • setMascotOptions() : ms_datfile
  • setMassDecimalPlaces() : ms_mascotoptions
  • setMassDelta() : ms_quant_integration
  • setMassDeltaUnit() : ms_quant_integration
  • setMasses() : ms_aahelper
  • setMassFile() : ms_modification , ms_modfile
  • setMasterComputer() : ms_clusterparams
  • setMatchedIon() : ms_fragment
  • setMatchedRho() : ms_quant_integration
  • setMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • setMaxConcurrentSearches() : ms_mascotoptions
  • setMaxDatabases() : ms_mascotoptions
  • setMaxDescriptionLen() : ms_mascotoptions
  • setMaxEtagMassDelta() : ms_mascotoptions
  • setMaxEtVarMods() : ms_mascotoptions
  • setMaxHitsToReport() : ms_mascotresults_params
  • setMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • setMaxInternalMass() : ms_fragmentationrules
  • setMaxNumPeptides() : ms_mascotoptions
  • setMaxPepModArrangements() : ms_mascotoptions
  • setMaxPepNumModifiedSites() : ms_mascotoptions
  • setMaxPepNumVarMods() : ms_mascotoptions
  • setMaxQueries() : ms_mascotoptions
  • setMaxSearchesPerUser() : ms_mascotoptions
  • setMaxSequenceLen() : ms_mascotoptions
  • setMaxVarMods() : ms_mascotoptions
  • setMemoryMapFiles() : ms_databaseoptions
  • setMethod() : ms_quant_outliers , ms_quant_integration , ms_quant_normalisation
  • setMinEtagMassDelta() : ms_mascotoptions
  • setMinimumA1() : ms_quant_quality
  • setMinimumPasswordLength() : ms_security_options
  • setMinInternalMass() : ms_fragmentationrules
  • setMinIonPairs() : ms_quant_multiplex
  • setMinNumPeptides() : ms_quant_method , ms_quantitation
  • setMinNumSigUniqueSequences() : ms_mascotresults_params
  • setMinorVersion() : ms_umod_configfile
  • setMinPepLenInPepSummary() : ms_mascotoptions
  • setMinPepLenInPeptideSummary() : ms_mascotresults_params
  • setMinPepLenInSearch() : ms_mascotoptions
  • setMinPrecursorCharge() : ms_quant_quality
  • setMinProbability() : ms_mascotresults_params
  • setMinute() : ms_cronjob
  • setMiscNotes() : ms_umod_modification , ms_umod_specificity
  • setMitochondrialTranslation() : ms_taxonomyrules
  • setMode() : ms_quant_modgroup
  • setModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • setModifications() : ms_mascotfiles , ms_quant_satellite
  • setModificationType() : ms_modification
  • setMonitorEmailCheckFreq() : ms_mascotoptions
  • setMonitorLogFile() : ms_mascotoptions
  • setMonitorPidFile() : ms_mascotoptions
  • setMonitorTestTimeout() : ms_mascotoptions
  • setMonoisotopic() : ms_quant_moverz
  • setMonoMass() : ms_umod_element , ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • setMonthOfYear() : ms_cronjob
  • setMoveOldDbToOldDir() : ms_mascotoptions
  • setMoverz() : ms_quant_component
  • setMudpit() : ms_mascotoptions
  • setMudpitSwitch() : ms_mascotoptions
  • setMultiplex() : ms_quant_protocol
  • setName() : ms_group , ms_quant_method , ms_crosslinking_method , ms_databaseoptions , ms_dbprocessors , ms_quant_component , ms_quant_modgroup , ms_quant_numerator , ms_quant_ratio , ms_user , ms_wwwentry , ms_xml_parameter
  • setNameOfDB() : ms_parserule_plus
  • setNeutralLoss() : ms_modification
  • setNew() : ms_quant_isotope
  • setNitrogenMass() : ms_masses
  • setNodeListFile() : ms_mascotfiles
  • setNodeSequenceDatabaseDir() : ms_clusterparams
  • setNoResultsScript() : ms_mascotoptions
  • setNormalisation() : ms_quant_method
  • setNTerminusMass() : ms_modification
  • setNtermModification() : ms_masses
  • setNTIUserGroup() : ms_mascotoptions
  • setNTMonitorGroup() : ms_mascotoptions
  • setNull() : ms_quant_protocol
  • setNumber() : ms_quant_element , ms_umod_elemref
  • setNumberOfThreads() : ms_databaseoptions
  • setNumPeptides() : ms_quant_average
  • setOld() : ms_quant_isotope
  • setOutliers() : ms_quant_method
  • setOxygenMass() : ms_masses
  • setPairsWith() : ms_umod_neutralloss
  • setParams() : ms_security_task
  • setParseOptions() : ms_datfile
  • setParseRule() : ms_wwwentry , ms_parseoptions
  • setPassword() : ms_user
  • setPasswordExpiry() : ms_user
  • setPath() : ms_wwwentry , ms_databaseoptions
  • setPepNeutralLoss() : ms_modification
  • setPepSearchTool() : ms_mascotoptions
  • setPepThresholdType() : ms_quant_quality
  • setPepThresholdValue() : ms_quant_quality
  • setPeptideIsBold() : ms_protein
  • setPeptideRatioExcluded() : ms_quantitation , ms_customquantitation , ms_ms2quantitation
  • setPeptideRatioIncluded() : ms_customquantitation , ms_ms2quantitation , ms_quantitation
  • setPeptideRatioNormalisationBase() : ms_quantitation
  • setPeptides() : ms_quant_normalisation
  • setPeptideShowCheckbox() : ms_protein
  • setPercolator() : ms_mascotoptions
  • setPercolatorExeFlags() : ms_mascotoptions
  • setPercolatorFeatures() : ms_mascotoptions , ms_mascotresfile
  • setPercolatorMinQueries() : ms_mascotoptions
  • setPercolatorMinSequences() : ms_mascotoptions
  • setPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • setPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • setPercolatorUseProteins() : ms_mascotoptions
  • setPercolatorUseRT() : ms_mascotoptions
  • setPermittedTasks() : ms_group , ms_session
  • setPort() : ms_computeraddress
  • setPortNumber() : ms_wwwentry
  • setPosition() : ms_umod_specificity , ms_quant_specificity , ms_quant_unmodified
  • setPreceedingComments() : ms_customproperty , ms_databaseoptions
  • setPrecursor() : ms_quant_protocol
  • setPrecursorCutOutLowerLimit() : ms_mascotoptions
  • setPrecursorCutOutUpperLimit() : ms_mascotoptions
  • setPrecursorRange() : ms_quant_integration
  • setPrivacyEnabled() : ms_umod_modification
  • setPrivate() : ms_umod_modification
  • setProcessingOptions() : ms_quant_integration
  • setProcessors() : ms_datfile
  • setPropertyName() : ms_customproperty
  • setPropValBoolByName() : ms_customproperty
  • setPropValCharByName() : ms_customproperty
  • setPropValFloatByName() : ms_customproperty
  • setPropValInt64ByName() : ms_customproperty
  • setPropValIntByName() : ms_customproperty
  • setPropValStringByName() : ms_customproperty
  • setPropValStringByNumber() : ms_customproperty
  • setProteinFamilySwitch() : ms_mascotoptions
  • setProteinRatioType() : ms_ms2quantitation , ms_customquantitation , ms_quant_method , ms_quantitation
  • setProteins() : ms_quant_normalisation
  • setProteinsInResultsFile() : ms_mascotoptions
  • setProtocol() : ms_quant_method
  • setProtScoreType() : ms_quant_method
  • setProxyPassword() : ms_mascotoptions , ms_connection_settings
  • setProxyServer() : ms_connection_settings , ms_mascotoptions
  • setProxyServerType() : ms_connection_settings
  • setProxyType() : ms_mascotoptions
  • setProxyUsername() : ms_connection_settings , ms_mascotoptions
  • setQuality() : ms_quant_method
  • setQuantNormalisation() : ms_ms2quantitation
  • setQuantOutliers() : ms_quantitation , ms_customquantitation , ms_ms2quantitation
  • setQuickRefSearch() : ms_taxonomyrules
  • setRC() : ms_matrix
  • setRecordID() : ms_umod_modification
  • setRedirectPolicy() : ms_connection_settings
  • setReferenceAccession() : ms_quant_average
  • setReferenceAmount() : ms_quant_average
  • setReferenceDatabase() : ms_quant_average
  • setReferenceFasta() : ms_libraryoptions
  • setRemoveOldIndexFiles() : ms_mascotoptions
  • setReplicate() : ms_quant_protocol
  • setReportBuilderColumnArrangement() : ms_mascotoptions
  • setReportDetail() : ms_quant_method
  • setReporter() : ms_quant_protocol
  • setReporterTol() : ms_quant_reporter
  • setReporterTolUnit() : ms_quant_reporter
  • setReportNumberChoice() : ms_mascotoptions
  • setReportRatioInFile() : ms_ms2quantitation
  • setReqPepNeutralLoss() : ms_modification
  • setRequireBoldRed() : ms_mascotoptions , ms_quant_method
  • setRequired() : ms_quant_modgroup , ms_quant_pepneutralloss
  • setResfileCache() : ms_mascotoptions
  • setResidueMasses() : ms_masses
  • setResidueModification() : ms_masses
  • setResultsCache() : ms_mascotoptions
  • setResultsFileFormatVersion() : ms_mascotoptions
  • setResultsFullURL() : ms_mascotoptions
  • setResultsFullURL_2() : ms_mascotoptions
  • setResultsPerlScript() : ms_mascotoptions
  • setResultsPerlScript_2() : ms_mascotoptions
  • setReviewColDisplay() : ms_mascotoptions
  • setReviewColWidth() : ms_mascotoptions
  • setRow() : ms_treecluster
  • setRule() : ms_parserule_plus
  • setRuleStr() : ms_parserule
  • setSatellite() : ms_quant_component
  • setSaveEveryLastQueryAsc() : ms_mascotoptions
  • setSaveLastQueryAsc() : ms_mascotoptions
  • setSchemaDirectory() : ms_quant_configfile
  • setSchemaFileName() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • setScope() : ms_crosslinking_method
  • setSearchLogFile() : ms_mascotoptions
  • setSearchSubmitMode() : ms_mascotoptions
  • setSecsToWaitForNodeAtStartup() : ms_clusterparams
  • setSectionAvailable() : ms_cronoptions , ms_libraryoptions , ms_parseoptions , ms_wwwoptions , ms_processoroptions , ms_taxonomyrules , ms_unigeneoptions , ms_mascotoptions , ms_databases , ms_clusterparams
  • setSecurityEnabled() : ms_security_options
  • setSelection() : ms_quant_average
  • setSelectSwitch() : ms_mascotoptions
  • setSemiSpecific() : ms_enzyme
  • setSendmailPath() : ms_mascotoptions
  • setSeparateLockMem() : ms_mascotoptions
  • setSequence() : ms_quant_normalisation_peptide
  • setSeriesUsed() : ms_fragmentationrules
  • setSessionID() : ms_connection_settings
  • setSessionTimeout() : ms_security_options
  • setSettings() : ms_crosslinking_method
  • setShift() : ms_quant_correction
  • setShowAllFromErrorTolerant() : ms_mascotoptions
  • setShowSubsets() : ms_mascotoptions
  • setShowSubSets() : ms_quant_method
  • setSigThreshold() : ms_mascotoptions
  • setSigThresholdValue() : ms_quant_method
  • setSimpleRatio() : ms_quant_integration
  • setSingleHit() : ms_mascotresults_params
  • setSinglyCharged() : ms_fragmentationrules
  • setSite() : ms_umod_specificity , ms_quant_specificity , ms_quant_unmodified
  • setSiteAnalysisMD10Prob() : ms_mascotoptions
  • setSortUnassigned() : ms_mascotoptions
  • setSource() : ms_umod_xref , ms_quant_integration
  • setSpecGroup() : ms_umod_specificity
  • setSpeciesFormatRegex() : ms_taxonomyrules
  • setSpectraPerLibraryBlock() : ms_mascotoptions
  • setSpectrumViewerColourSchemeString() : ms_mascotoptions
  • setSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • setSplitDataFileSize() : ms_mascotoptions
  • setSplitNumberOfQueries() : ms_mascotoptions
  • setSrcDatabaseRule() : ms_taxonomyrules
  • setStoreModPermutations() : ms_mascotoptions
  • setStrategy() : ms_crosslinking_method
  • setStrRule() : ms_taxonomyrules
  • setSubsetsThreshold() : ms_mascotresults
  • setSummedModsStr() : ms_peptide
  • setSVGSpectrumSwitch() : ms_mascotoptions
  • setSymbol() : ms_umod_elemref , ms_quant_element
  • setTargetFDR() : ms_mascotresults_params
  • setTargetFDRPercentage() : ms_mascotoptions
  • setTargetFDRType() : ms_mascotresults_params
  • setTaxBrowserUrl() : ms_mascotoptions
  • setTaxonomyParseRuleIndex() : ms_databaseoptions
  • setTaxonomyRules() : ms_datfile
  • setTestDirectory() : ms_mascotoptions
  • setText() : ms_umod_xref
  • setThreeLetter() : ms_umod_aminoacid
  • setTitle() : ms_umod_modification , ms_enzyme , ms_modification , ms_fragmentationrules , ms_umod_aminoacid , ms_taxonomychoice , ms_umod_modbrick , ms_quant_localdef , ms_umod_element
  • setTitleSource() : ms_modification
  • setToleranceInDa() : ms_libraryoptions
  • setToleranceInPPM() : ms_libraryoptions
  • setTotalIntensity() : ms_quant_quality
  • setTotalIntensityThreshold() : ms_quant_quality
  • setType() : ms_wwwentry , ms_quant_correction
  • setUnigeneIndexFile() : ms_mascotresults_params
  • setUniGeneOptions() : ms_datfile
  • setUniqueJobStartNumber() : ms_mascotoptions
  • setUniquePepseq() : ms_quant_quality
  • setUnixDirPerm() : ms_mascotoptions
  • setUnixWebUserGroup() : ms_mascotoptions
  • setUrl() : ms_umod_xref
  • setUseHTTPProxyForFTP() : ms_connection_settings , ms_mascotoptions
  • setUseHTTPProxyForHTTPS() : ms_connection_settings , ms_mascotoptions
  • setUsePeptideSummary() : ms_mascotresults_params
  • setUserAgent() : ms_connection_settings
  • setUsernameOfPoster() : ms_umod_modification
  • setUserType() : ms_user
  • setUseSessionCookies() : ms_security_options
  • setValue() : ms_http_client_mime , ms_crosslinking_monolink , ms_xml_parameter , ms_crosslinking_accession
  • setValueWithFilename() : ms_http_client_mime
  • setVarModsStr() : ms_peptide
  • setVerifySessionIPAddress() : ms_security_options
  • setVmemory() : ms_mascotoptions
  • setWWWOptions() : ms_datfile
  • setXicMaxWidth() : ms_quant_integration
  • setXicSmoothing() : ms_quant_integration
  • setXicThreshold() : ms_quant_integration
  • setXMLschemaFilePath() : ms_mascotresfile
  • sev_debug1 : ms_log
  • sev_debug2 : ms_log
  • sev_debug3 : ms_log
  • sev_fatal : ms_log
  • sev_info : ms_log
  • sev_warn : ms_log
  • severityAsText() : ms_loggingmonitor
  • SHOW_ALL : ms_http_client_session
  • SHOW_LENGTH : ms_http_client_session
  • SHOW_NONE : ms_http_client_session
  • SHOW_PI : ms_http_client_session
  • SHOW_REFERENCE : ms_http_client_session
  • SHOW_SEQUENCE : ms_http_client_session
  • SHOW_TITLE : ms_http_client_session
  • showInLongList() : ms_umod_specificity
  • showInShortList() : ms_umod_specificity
  • size() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • sizei() : ms_matrix
  • sizej() : ms_matrix
  • snedecorsCriticalValue() : ms_quant_stats
  • sortBy : ms_mascotresults
  • sortedMedian() : ms_quant_stats
  • sortModifications() : ms_modfile
  • sortPeptides() : ms_protein
  • sortUsers() : ms_security
  • Source_e : ms_loggingmonitor
  • SRC_ALL : ms_loggingmonitor
  • SRC_APPLICATION : ms_loggingmonitor
  • SRC_DENOVOLIB : ms_loggingmonitor
  • SRC_MASCOTSERVER : ms_loggingmonitor
  • SRC_MDRO : ms_loggingmonitor
  • SRC_MSPARSER : ms_loggingmonitor
  • SRC_MSQUANTLIB : ms_loggingmonitor
  • SRC_PURIFIERAPI : ms_loggingmonitor
  • SRC_PURIFIERAPP : ms_loggingmonitor
  • SRC_VENDORSTART : ms_loggingmonitor
  • SS_ASSIGNED : ms_http_client_search
  • SS_COMPLETE : ms_http_client_search
  • SS_ERROR : ms_http_client_search
  • SS_QUEUED : ms_http_client_search
  • SS_RUNNING : ms_http_client_search
  • SS_SEARCH_CONTROL_ERROR : ms_http_client_search
  • SS_UNKNOWN : ms_http_client_search
  • startIteratePeptides() : ms_aahelper
  • staticGetPercolatorFileNames() : ms_mascotresfile
  • STATUS : ms_progress_info
  • stopIteratePeptides() : ms_aahelper
  • stripLastFolder() : ms_fileutilities
  • studentsCriticalValue() : ms_quant_stats
  • submitSearch() : ms_http_client_session
  • sum() : ms_quant_stats
  • sumsq() : ms_quant_stats
  • swap() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • swilk() : ms_shapiro_wilk
  • systemError() : ms_http_helper_return
  • systemids : ms_user , ms_group
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TASKID : ms_security_tasks
  • TAX_CHOP_PREFIX : ms_parserule_plus
  • TAX_CHOP_SRC : ms_parserule_plus
  • TAX_CHOP_SUFFIX : ms_parserule_plus
  • TAX_CHOP_TYPES : ms_parserule_plus
  • TAX_CHOP_WORDS : ms_parserule_plus
  • TCD_ABS_CORRELATION : ms_treecluster
  • TCD_ABS_UNCENTERED_CORRELATION : ms_treecluster
  • TCD_CITY_BLOCK : ms_treecluster
  • TCD_CORRELATION : ms_treecluster
  • TCD_EUCLIDEAN : ms_treecluster
  • TCD_KENDALLS_TAU_CORRELATION : ms_treecluster
  • TCD_SPEARMANS_RANK_CORRELATION : ms_treecluster
  • TCD_UNCENTERED_CORRELATION : ms_treecluster
  • TCM_PAIRWISE_AVERAGE : ms_mascotresults
  • TCM_PAIRWISE_MAXIMUM : ms_mascotresults
  • TCM_PAIRWISE_SINGLE : ms_mascotresults
  • testDixonsN9() : ms_quant_stats
  • testGrubbsN2() : ms_quant_stats
  • testRosners() : ms_quant_stats
  • testShapiroWilkW() : ms_quant_stats
  • THRESHOLD_TYPE : ms_mascotresults
  • toVector() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • transpose() : ms_matrix
  • TREE_CLUSTER_DISTANCE : ms_treecluster
  • TREE_CLUSTER_METHOD : ms_mascotresults
  • TT_HOMOLOGY : ms_mascotresults
  • TT_IDENTITY : ms_mascotresults
  • TT_PEPSUM_DEFAULT : ms_mascotresults
  • TYPE_ALL_USERS_ARRAY : ms_security_task
  • TYPE_BOOL : ms_security_task
  • TYPE_DOUBLE_ARRAY : ms_security_task
  • TYPE_EQ_DOUBLE : ms_security_task
  • TYPE_EQ_LONG : ms_security_task
  • TYPE_EQ_STRING : ms_security_task
  • TYPE_GTE_DOUBLE : ms_security_task
  • TYPE_GTE_LONG : ms_security_task
  • TYPE_LONG_ARRAY : ms_security_task
  • TYPE_LTE_DOUBLE : ms_security_task
  • TYPE_LTE_LONG : ms_security_task
  • TYPE_STRING_ARRAY : ms_security_task
  • TYPE_USERS_ARRAY : ms_security_task
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • uncommentProp() : ms_customproperty
  • UNDEFINED_CUTTER : ms_enzyme
  • UNIQUE_PEP_RULES : ms_mascotresults
  • unsortedMedian() : ms_quant_stats
  • unspecifiedError() : ms_http_helper_return
  • update() : ms_session
  • updateAccessionByNumber() : ms_crosslinking_accessions
  • updateAllSessionFiles() : ms_security
  • updateAltName() : ms_umod_modification
  • updateAminoAcidByName() : ms_umod_configfile
  • updateAminoAcidByNumber() : ms_umod_configfile
  • updateBreak() : ms_progress_info
  • updateComplete() : ms_progress_info
  • updateComponentByName() : ms_quant_method
  • updateComponentByNumber() : ms_quant_method
  • updateCorrection() : ms_quant_component
  • updateDatabaseByName() : ms_databases
  • updateDatabaseByNumber() : ms_databases
  • updateDenominatorByName() : ms_quant_ratio
  • updateDenominatorByNumber() : ms_quant_ratio
  • updateDoesNotPairWithByNumber() : ms_crosslinking_linker
  • updateElement() : ms_quant_composition
  • updateElementByName() : ms_umod_configfile
  • updateElementByNumber() : ms_umod_configfile
  • updateElemRef() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • updateEnzymeByName() : ms_enzymefile
  • updateEnzymeByNumber() : ms_enzymefile
  • updateExclusion() : ms_quant_method
  • updateFail() : ms_progress_info
  • updateForInstaller() : ms_datfile
  • updateGroup() : ms_security
  • updateIgnore() : ms_quant_localdef , ms_umod_modification
  • updateIndeterminate() : ms_progress_info
  • updateInstrumentByName() : ms_fragrulesfile
  • updateInstrumentByNumber() : ms_fragrulesfile
  • updateIonSeries() : ms_quant_multiplex
  • updateIsotope() : ms_quant_component
  • updateLinkerByNumber() : ms_crosslinking_linkers
  • updateLocalDefinition() : ms_quant_modgroup
  • updateMasses() : ms_umod_composition , ms_umod_configfile , ms_umod_modification
  • updateMethodByName() : ms_crosslinking_configfile , ms_quant_configfile
  • updateMethodByNumber() : ms_crosslinking_configfile , ms_quant_configfile
  • updateModBrickByName() : ms_umod_configfile
  • updateModBrickByNumber() : ms_umod_configfile
  • updateModificationByName() : ms_modfile , ms_umod_configfile
  • updateModificationByNumber() : ms_modfile , ms_umod_configfile
  • updateModificationGroupByName() : ms_quant_component , ms_quant_method
  • updateModificationGroupByNumber() : ms_quant_component , ms_quant_method
  • updateMonoLinkByNumber() : ms_crosslinking_linker
  • updateNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • updateNumeratorByName() : ms_quant_ratio
  • updateNumeratorByNumber() : ms_quant_ratio
  • updateParameterByName() : ms_crosslinking_parameters , ms_quant_parameters
  • updateParameterByNumber() : ms_crosslinking_parameters , ms_quant_parameters
  • updatePassword() : ms_security
  • updatePepNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • updatePeptide() : ms_quant_normalisation_peptides
  • updateProgress() : ms_progress_info
  • updateProtein() : ms_quant_normalisation_proteins
  • updateReportRatioByName() : ms_quant_method
  • updateReportRatioByNumber() : ms_quant_method
  • updateSeq() : ms_quant_method
  • updateSpecificity() : ms_quant_localdef , ms_umod_modification
  • updateTask() : ms_security_tasks
  • updateUnmodified() : ms_quant_modgroup
  • updateUser() : ms_security
  • updateXref() : ms_umod_modification
  • uploadDistillerXmlResultsFile() : ms_http_client_search
  • UploadResponseCode : ms_http_client_search
  • UPR_DEFAULT : ms_mascotresults
  • UPR_IGNORE_SUBSET_PROTEINS : ms_mascotresults
  • UPR_WITHIN_FAMILY : ms_mascotresults
  • UPR_WITHIN_FAMILY_MEMBER : ms_mascotresults
  • UR_ACCESS_DENIED : ms_http_client_search
  • UR_ERROR : ms_http_client_search
  • UR_FILE_ALREADY_EXISTS : ms_http_client_search
  • UR_INVALID_TASKID : ms_http_client_search
  • UR_NO_RESULT_FILE : ms_http_client_search
  • UR_NO_RESULT_FILENAME : ms_http_client_search
  • UR_SUCCESS : ms_http_client_search
  • useInErrorTolerant() : ms_umod_specificity
  • USER_AGENT_STRING : ms_user
  • USER_COMPUTER_NAME : ms_user
  • USER_INTEGRA : ms_user
  • USER_IP_ADDRESS : ms_user
  • USER_NORMAL : ms_user
  • USER_SECURITY_DISABLED : ms_user
  • USER_WEBAUTH : ms_user
  • USERID_ADMINISTRATOR : ms_user
  • USERID_CMDLINE : ms_user
  • USERID_DAEMON : ms_user
  • USERID_GUEST : ms_user
  • USERID_INTEGRA_SYSTEM : ms_user
  • USERID_LAST : ms_user
  • USERID_PUBLIC_SEARCHES : ms_user
  • USERID_SECURITY_DISABLED : ms_user
  • USERID_SORTBY : ms_security
  • USERID_SORTBY_FULLNAME : ms_security
  • USERID_SORTBY_ID : ms_security
  • USERID_SORTBY_LOGINNAME : ms_security
  • userLogin() : ms_http_client
  • usertype : ms_user
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • validateDeep() : ms_crosslinking_accession , ms_crosslinking_accessions , ms_crosslinking_linker , ms_quant_average , ms_quant_method , ms_quant_ratio , ms_quant_replicate , ms_quant_modgroup , ms_quant_reporter , ms_quant_satellite , ms_quant_component , ms_quant_moverz , ms_quant_specificity , ms_quant_unmodified , ms_quant_multiplex , ms_umod_aminoacid , ms_umod_composition , ms_crosslinking_linkers , ms_quant_element , ms_quant_neutralloss , ms_umod_element , ms_umod_elemref , ms_quant_normalisation , ms_umod_modbrick , ms_umod_modification , ms_quant_composition , ms_quant_normalisation_peptide , ms_umod_neutralloss , ms_umod_specificity , ms_quant_normalisation_peptides , ms_umod_xref , ms_xml_parameter , ms_crosslinking_does_not_pair_with , ms_crosslinking_method , ms_quant_correction , ms_quant_normalisation_protein , ms_xml_parameters , ms_quant_normalisation_proteins , ms_quant_integration , ms_quant_numerator , ms_quant_outliers , ms_crosslinking_monolink , ms_quant_isotope , ms_quant_pepneutralloss , ms_quant_precursor , ms_quant_localdef , ms_quant_protocol , ms_quant_quality
  • validateDocument() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • validatePassword() : ms_user
  • validateShallow() : ms_crosslinking_accession , ms_quant_normalisation_peptide , ms_umod_aminoacid , ms_umod_xref , ms_quant_neutralloss , ms_quant_correction , ms_quant_numerator , ms_quant_outliers , ms_quant_precursor , ms_quant_protocol , ms_quant_replicate , ms_quant_reporter , ms_quant_specificity , ms_quant_unmodified , ms_umod_elemref , ms_umod_modbrick , ms_umod_neutralloss , ms_umod_specificity , ms_xml_parameters , ms_quant_integration , ms_quant_isotope , ms_xml_parameter , ms_quant_component , ms_quant_element , ms_crosslinking_method , ms_crosslinking_linker , ms_crosslinking_accessions , ms_quant_modgroup , ms_quant_multiplex , ms_quant_normalisation , ms_quant_normalisation_proteins , ms_quant_pepneutralloss , ms_quant_ratio , ms_quant_satellite , ms_umod_element , ms_quant_method , ms_umod_composition , ms_umod_modification , ms_quant_average , ms_quant_composition , ms_quant_localdef , ms_quant_moverz , ms_quant_normalisation_protein , ms_quant_normalisation_peptides , ms_quant_quality , ms_crosslinking_does_not_pair_with , ms_crosslinking_monolink , ms_crosslinking_linkers
  • verifyEnzyme() : ms_enzyme
  • verifyRule() : ms_fragmentationrules
  • verifyThatModsAreInUnimod() : ms_spectral_lib_file
  • versionGreaterOrEqual() : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • weightedArithmeticMean() : ms_quant_stats
  • weightedArithmeticStandardDeviation() : ms_quant_stats
  • weightedArithmeticStandardError() : ms_quant_stats
  • weightedGeometricMean() : ms_quant_stats
  • weightedGeometricStandardDeviation() : ms_quant_stats
  • WHAT_TO_ANNOTATE : ms_spectral_lib_entry
  • willCreateCache() : ms_mascotresfile , ms_peptidesummary , ms_mascotresfile
  • willMessageBeLogged() : ms_log , ms_errs
  • WST : ms_datfile
  • WST_APACHE : ms_datfile
  • WST_IIS : ms_datfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • XML_SCHEMA : ms_mascotresfile
  • XML_SCHEMA_CROSSLINKING : ms_mascotresfile
  • XML_SCHEMA_DIRECTORY : ms_mascotresfile
  • XML_SCHEMA_LAST : ms_mascotresfile
  • XML_SCHEMA_QUANTITATION : ms_mascotresfile
  • XML_SCHEMA_UNIMOD : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- b -

  • BUGFIX_NUM : ms_peptidesummary

- c -

  • CACHE_STATUS : ms_peptidesummary
  • ChangePasswordResultCode : ms_http_client
  • chargeType : ms_ms1quant_match
  • CMD_ARGUMENT_PARSE_RESULT : ms_fileutilities
  • compareXMLFiles_flags : ms_fileutilities
  • cuttertype : ms_enzyme

- d -

  • DB_MATCH_TYPE : ms_mascotresults
  • DECOY_ALGORITHM : ms_mascotoptions
  • DECOY_STATS_COUNT_TYPE : ms_mascotresults
  • DISTINCT_PEPTIDE_FLAGS : ms_protein
  • DownloadOption : ms_http_client_search
  • DUPLICATE : ms_protein

- e -

  • eGrouping : ms_distiller_data_search
  • err : ms_mascotresfile
  • err_sar : ms_fileutilities
  • ErrorTypeCode : ms_http_helper_return
  • eScoring : ms_distiller_data_search
  • eSpectralLibrary : ms_distiller_data_search
  • EXEC_AFTER_SEARCH : ms_mascotoptions

- f -

  • FileMode : ms_http_helper
  • FIND_COMPARE_FLAGS : ms_mascotresults
  • FIND_FLAGS : ms_mascotresults
  • FLAGS : ms_mascotresults , ms_mascotresfile
  • FRAG_NL : ms_aahelper
  • FRAG_SERIES_TYPE : ms_fragmentationrules

- g -

  • GROUP : ms_protein

- h -

  • HOMOLOGY_THRESHOLD_SOURCE : ms_mascotresults
  • HTTP_PROTOCOL : ms_connection_settings
  • HYPERTHREADING : ms_processors

- i -

  • INST_FLAGS : ms_datfile
  • IONS_HISTOGRAM : ms_mascotresults

- k -

  • KA_TASK : ms_mascotresfile

- l -

  • LABEL_FORMAT : ms_fragment
  • Level_e : ms_loggingmonitor
  • LoginResultCode : ms_http_client
  • LogOutputColumns_e : ms_logger

- m -

  • MASS_FLAGS : ms_protein
  • MATCH_PEAKS : ms_fragmentvector
  • MERGE_QUANT_RESULTS_FLAGS : ms_ms1quantitation
  • METHOD_COMPATIBLE : ms_quant_method
  • MODFILE_FLAGS : ms_umod_configfile
  • MS1QUANT_BUGFIX_NUM : ms_ms1quantitation
  • MS_REVIEW_COL : ms_mascotoptions
  • msg_sev : ms_log
  • MSPEPSUM : ms_peptidesummary
  • MULTI_SITE_MODS : ms_searchparams

- n -

  • NUMERICAL_VALUE_STORAGE : ms_mascotoptions

- p -

  • paramType : ms_security_task
  • PEAK_ANNOTATION_LEVEL : ms_spectral_lib_peak_list
  • peakState : ms_xic
  • PEPTIDE_QUALITY : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY : ms_quant_helper
  • peptideStatus : ms_ms1quant_peptide_status
  • PERC_EXE_RT : ms_mascotoptions
  • PERCOLATOR_FILE_NAMES : ms_mascotresfile
  • PROXY_TYPE : ms_connection_settings
  • PSM : ms_peptide

- q -

  • QL_FLAG : ms_peptidesummary
  • QUANT_COMPONENT_STATUS : ms_mascotresults

- r -

  • ratioStatusCode : ms_ms1quant_match_ratio
  • REDIRECT_POLICY : ms_connection_settings
  • ReportTopSpecialValues : ms_http_client_search

- s -

  • SearchStatusCode : ms_http_client_search
  • section : ms_mascotresfile
  • SEQDB_INSTALL : ms_datfile
  • SequenceShowOptions : ms_http_client_session
  • sortBy : ms_mascotresults
  • Source_e : ms_loggingmonitor
  • STATUS : ms_progress_info
  • systemids : ms_group , ms_user

- t -

  • TASKID : ms_security_tasks
  • TAX_CHOP_TYPES : ms_parserule_plus
  • THRESHOLD_TYPE : ms_mascotresults
  • TREE_CLUSTER_DISTANCE : ms_treecluster
  • TREE_CLUSTER_METHOD : ms_mascotresults

- u -

  • UNIQUE_PEP_RULES : ms_mascotresults
  • UploadResponseCode : ms_http_client_search
  • USERID_SORTBY : ms_security
  • usertype : ms_user

- w -

  • WHAT_TO_ANNOTATE : ms_spectral_lib_entry
  • WST : ms_datfile

- x -

  • XML_SCHEMA : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- a -

  • ANNOT_LVL_CANNOT_ANNOTATE : ms_spectral_lib_peak_list
  • ANNOT_LVL_NONE : ms_spectral_lib_peak_list
  • ANNOT_LVL_QUESTION_MARKS : ms_spectral_lib_peak_list
  • ANNOT_LVL_SOME_PEAKS : ms_spectral_lib_peak_list
  • ANNOTATE_NONE : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_ALL : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_IF_ALL_EMPTY : ms_spectral_lib_entry
  • ANNOTATE_REPLACE_QUESTION_MARKS : ms_spectral_lib_entry
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- k -

  • KA_ASSIGNPROTEINS_AP : ms_mascotresfile
  • KA_CREATECACHE_CC : ms_mascotresfile
  • KA_CREATEINDEX_CI : ms_mascotresfile
  • KA_GROUPPROTEINS_GP : ms_mascotresfile
  • KA_LAST : ms_mascotresfile
  • KA_QUANTITATION : ms_mascotresfile
  • KA_READFILE_RF : ms_mascotresfile
  • KA_THRESHFORFDR_FDR : ms_mascotresfile
  • KA_UNASSIGNEDLIST_UL : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- l -

  • L_GUESTLOGINDISABLED : ms_http_client
  • L_INCORRECTPASSWORD : ms_http_client
  • L_PASSWORDEXPIRED : ms_http_client
  • L_SECURITYDISABLED : ms_http_client
  • L_SUCCESS : ms_http_client
  • L_UNKNOWNUSER : ms_http_client
  • L_UNSPECIFIEDERROR : ms_http_client
  • L_WEBAUTHENTICATIONFAILED : ms_http_client
  • LABEL_FORMAT_PEPTIDE_VIEW : ms_fragment
  • LABEL_FORMAT_TRADITIONAL : ms_fragment
  • LVL_DEBUG1 : ms_loggingmonitor
  • LVL_DEBUG2 : ms_loggingmonitor
  • LVL_DEBUG3 : ms_loggingmonitor
  • LVL_ERROR : ms_loggingmonitor
  • LVL_INFO : ms_loggingmonitor
  • LVL_NONE : ms_loggingmonitor
  • LVL_WARNING : ms_loggingmonitor
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- m -

  • MASS_DECIMAL_PLACES : ms_mascotoptions
  • MASS_NON_SELECT_MATCH : ms_protein
  • MASS_NON_SELECT_NON_MATCH : ms_protein
  • MASS_SELECT_MATCH : ms_protein
  • MASS_SELECT_NON_MATCH : ms_protein
  • MATCH_CLOSEST_PEAK : ms_fragmentvector
  • MATCH_MOST_INTENSE_PEAK : ms_fragmentvector
  • MAX_EXEC_AFTER_SEARCH : ms_mascotoptions
  • MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_PRECURSOR_METHOD : ms_ms1quantitation
  • MERGE_QUANT_DEFAULT_REPLICATE_METHOD : ms_ms1quantitation
  • MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH : ms_ms1quantitation
  • MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS : ms_ms1quantitation
  • MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC : ms_ms1quantitation
  • MISECTASK_ACCESS : ms_security_tasks
  • MISECTASK_ADDCUSTOMREPORT : ms_security_tasks
  • MISECTASK_ADDEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_ADDIMPORTFILTER : ms_security_tasks
  • MISECTASK_ADMIN : ms_security_tasks
  • MISECTASK_DELETECUSTOMREPORT : ms_security_tasks
  • MISECTASK_DELETEEXCLUSIONFILE : ms_security_tasks
  • MISECTASK_PROTEINAPPROVAL : ms_security_tasks
  • MISECTASK_SENDNOTIFICATION : ms_security_tasks
  • MODFILE_FLAGS_AASUBST : ms_umod_configfile
  • MODFILE_FLAGS_ALL : ms_umod_configfile
  • MODFILE_FLAGS_EMPTY : ms_umod_configfile
  • MODFILE_FLAGS_HIDDEN : ms_umod_configfile
  • MODFILE_FLAGS_REGULAR : ms_umod_configfile
  • MS_REVIEW_COL____LAST___ : ms_mascotoptions
  • MS_REVIEW_COL_DATABASE : ms_mascotoptions
  • MS_REVIEW_COL_DURATION : ms_mascotoptions
  • MS_REVIEW_COL_ENZYMEUSED : ms_mascotoptions
  • MS_REVIEW_COL_IPADDRESS : ms_mascotoptions
  • MS_REVIEW_COL_JOB : ms_mascotoptions
  • MS_REVIEW_COL_PEAKLISTDATAFILE : ms_mascotoptions
  • MS_REVIEW_COL_PID : ms_mascotoptions
  • MS_REVIEW_COL_PRIORITY : ms_mascotoptions
  • MS_REVIEW_COL_RESULTS_FILE : ms_mascotoptions
  • MS_REVIEW_COL_SEARCHTYPE : ms_mascotoptions
  • MS_REVIEW_COL_START_TIME : ms_mascotoptions
  • MS_REVIEW_COL_STATUS : ms_mascotoptions
  • MS_REVIEW_COL_TITLE : ms_mascotoptions
  • MS_REVIEW_COL_USEREMAIL : ms_mascotoptions
  • MS_REVIEW_COL_USERID : ms_mascotoptions
  • MS_REVIEW_COL_USERNAME : ms_mascotoptions
  • MSM_EXCLUSIVE_PLUS_VARIABLE : ms_searchparams
  • MSM_NOT_PERMITTED : ms_searchparams
  • MSPEPSUM_CACHE_IGNORE_DATE_CHANGE : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_CROSSLINK_ONLY : ms_peptidesummary
  • MSPEPSUM_DEFERRED_CREATE : ms_peptidesummary
  • MSPEPSUM_DISCARD_RELOADABLE : ms_peptidesummary
  • MSPEPSUM_NO_PROTEIN_GROUPING : ms_peptidesummary
  • MSPEPSUM_NONE : ms_peptidesummary
  • MSPEPSUM_PERCOLATOR : ms_peptidesummary
  • MSPEPSUM_REMOVE_CHIMERIC_DUPES : ms_peptidesummary
  • MSPEPSUM_SINGLE_HIT_DBIDX : ms_peptidesummary
  • MSPEPSUM_SL_INTEGRATED : ms_peptidesummary
  • MSPEPSUM_SL_ONLY : ms_peptidesummary
  • MSPEPSUM_USE_CACHE : ms_peptidesummary
  • MSPEPSUM_USE_HOMOLOGY_THRESH : ms_peptidesummary
  • MSRES_CLUSTER_PROTEINS : ms_mascotresults
  • MSRES_DECOY : ms_mascotresults
  • MSRES_DUPE_DEFAULT : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_A : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_B : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_C : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_D : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_E : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_F : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_G : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_H : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_I : ms_mascotresults
  • MSRES_DUPE_INCL_IN_SCORE_NONE : ms_mascotresults
  • MSRES_DUPE_REMOVE_A : ms_mascotresults
  • MSRES_DUPE_REMOVE_B : ms_mascotresults
  • MSRES_DUPE_REMOVE_C : ms_mascotresults
  • MSRES_DUPE_REMOVE_D : ms_mascotresults
  • MSRES_DUPE_REMOVE_E : ms_mascotresults
  • MSRES_DUPE_REMOVE_F : ms_mascotresults
  • MSRES_DUPE_REMOVE_G : ms_mascotresults
  • MSRES_DUPE_REMOVE_H : ms_mascotresults
  • MSRES_DUPE_REMOVE_I : ms_mascotresults
  • MSRES_DUPE_REMOVE_NONE : ms_mascotresults
  • MSRES_ERR_TOL : ms_mascotresults
  • MSRES_GROUP_PROTEINS : ms_mascotresults
  • MSRES_IGNORE_PMF_MIXTURE : ms_mascotresults
  • MSRES_INTEGRATED_ERR_TOL : ms_mascotresults
  • MSRES_MAXHITS_OVERRIDES_MINPROB : ms_mascotresults
  • MSRES_MUDPIT_PROTEIN_SCORE : ms_mascotresults
  • MSRES_NOFLAG : ms_mascotresults
  • MSRES_REQUIRE_BOLD_RED : ms_mascotresults
  • MSRES_SHOW_ALL_FROM_ERR_TOL : ms_mascotresults
  • MSRES_SHOW_SUBSETS : ms_mascotresults
  • MSRES_SUBSETS_DIFF_PROT : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- n -

  • NTERM_CUTTER : ms_enzyme
  • NUM_PROCESSORS_AUTO_DETECT : ms_clusterparams
  • NUM_THREADS_AUTO_DETECT : ms_databaseoptions
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- b -

  • BUGFIX_10780 : ms_peptidesummary
  • BUGFIX_10995 : ms_peptidesummary
  • BUGFIX_11002 : ms_peptidesummary
  • BUGFIX_11018 : ms_peptidesummary
  • BUGFIX_11235 : ms_peptidesummary
  • BUGFIX_11254 : ms_peptidesummary
  • BUGFIX_11344 : ms_peptidesummary
  • BUGFIX_11411 : ms_peptidesummary
  • BUGFIX_11425 : ms_peptidesummary
  • BUGFIX_11438 : ms_peptidesummary
  • BUGFIX_11481 : ms_peptidesummary
  • BUGFIX_11483 : ms_peptidesummary
  • BUGFIX_11499 : ms_peptidesummary
  • BUGFIX_11856 : ms_peptidesummary
  • BUGFIX_12123 : ms_peptidesummary
  • BUGFIX_12317 : ms_peptidesummary
  • BUGFIX_12409 : ms_ms1quantitation
  • BUGFIX_12447 : ms_peptidesummary
  • BUGFIX_12538 : ms_peptidesummary
  • BUGFIX_12729 : ms_peptidesummary
  • BUGFIX_12740 : ms_peptidesummary
  • BUGFIX_13324 : ms_peptidesummary
  • BUGFIX_13759 : ms_peptidesummary
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- c -

  • CACHE_MISSING_RESFILE : ms_peptidesummary
  • CHARGETYPE_ALL : ms_ms1quant_match
  • CHARGETYPE_ORIGINAL : ms_ms1quant_match
  • CMD_ARGUMENT_PARSE_COLLISION : ms_fileutilities
  • CMD_ARGUMENT_PARSE_INVALIDCHAR : ms_fileutilities
  • CMD_ARGUMENT_PARSE_OK : ms_fileutilities
  • CMD_ARGUMENT_PARSE_UNBALANCED : ms_fileutilities
  • CMPXML_IGN_COL_SIZE_EQ_ONE : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_100_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_10_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_DIFF_1_PPM : ms_fileutilities
  • CMPXML_IGN_DBL_IDENTICAL : ms_fileutilities
  • CMPXML_IGN_FILE_URL : ms_fileutilities
  • CMPXML_IGN_INF_999999 : ms_fileutilities
  • CMPXML_IGN_RAWFILE_NAME : ms_fileutilities
  • CMPXML_IGN_TODAY_DATE : ms_fileutilities
  • CMPXML_NO_FLAG : ms_fileutilities
  • CMPXML_STRIP_TRAILING_ZEROS : ms_fileutilities
  • COL_ASC_TIME : ms_logger
  • COL_HEADERS : ms_logger
  • COL_IP_ADDRESS : ms_logger
  • COL_ISO8601_TIME : ms_logger
  • COL_LOGGER_DEFAULTS : ms_logger
  • COL_MSG : ms_logger
  • COL_MSG_NUM_DEC : ms_logger
  • COL_MSG_NUM_HEX : ms_logger
  • COL_MSG_SOURCE_TXT : ms_logger
  • COL_QUOTES : ms_logger
  • COL_SEVERITY_NUM : ms_logger
  • COL_SEVERITY_TXT : ms_logger
  • COL_SRC_FILE : ms_logger
  • COL_SRC_LINENUM : ms_logger
  • COL_THREAD_ID : ms_logger
  • COL_TSV : ms_logger
  • COMPATIBLE : ms_quant_method
  • COMPATIBLE_DIFF_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_DIFF_LOCAL_MOD : ms_quant_method
  • COMPATIBLE_DIFF_NUM_COMPONENTS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_ISOTOPES : ms_quant_method
  • COMPATIBLE_DIFF_NUM_LOCAL_MODS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MOD_GROUPS : ms_quant_method
  • COMPATIBLE_DIFF_NUM_MODS : ms_quant_method
  • COMPATIBLE_DIFF_PROTOCOL : ms_quant_method
  • COMPATIBLE_MISSING_COMPONENT : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION : ms_quant_method
  • COMPATIBLE_MISSING_INTEGRATION_PARAM : ms_quant_method
  • COMPATIBLE_MISSING_MOD : ms_quant_method
  • COMPATIBLE_MISSING_MOD_GROUP : ms_quant_method
  • CP_BADNEWPASSWORD : ms_http_client
  • CP_INCORRECTPASSWORD : ms_http_client
  • CP_SUCCESS : ms_http_client
  • CP_UNKNOWNUSER : ms_http_client
  • CP_UNSPECIFIEDERROR : ms_http_client
  • CTERM_CUTTER : ms_enzyme
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- d -

  • DECOY_ALGORITHM_NONE : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM : ms_mascotoptions
  • DECOY_PEPTIDE_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PEPTIDE_REVERSE : ms_mascotoptions
  • DECOY_PEPTIDE_SHUFFLE : ms_mascotoptions
  • DECOY_PROTEIN_BASED_MASK : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM : ms_mascotoptions
  • DECOY_PROTEIN_RANDOM_DIPEP : ms_mascotoptions
  • DECOY_PROTEIN_REVERSE : ms_mascotoptions
  • DECOY_PROTEIN_SHUFFLE : ms_mascotoptions
  • DEPRECATED_MAX_CORES_PER_LICENSE : ms_processors
  • DM_BOTH : ms_mascotresults
  • DM_FASTA : ms_mascotresults
  • DM_FASTA_FIRST_PASS : ms_mascotresults
  • DM_FASTA_SECOND_PASS : ms_mascotresults
  • DM_SPECTRAL_LIBRARY : ms_mascotresults
  • DO_NORMAL : ms_http_client_search
  • DO_WITH_IONS : ms_http_client_search
  • DPF_CHARGE : ms_protein
  • DPF_MODS : ms_protein
  • DPF_NODUPSAMEQUERY : ms_protein
  • DPF_SEQUENCE : ms_protein
  • DPF_UNIQUE : ms_protein
  • DS_COUNT_PSM : ms_mascotresults
  • DS_COUNT_SEQUENCE : ms_mascotresults
  • DUPE_Duplicate : ms_protein
  • DUPE_DuplicateSameQuery : ms_protein
  • DUPE_HighestScoringDuplicate : ms_protein
  • DUPE_Ignored : ms_protein
  • DUPE_NotDuplicate : ms_protein
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- e -

  • eAuto : ms_distiller_data_search
  • eFASTA : ms_distiller_data_search
  • eGroupAuto : ms_distiller_data_search
  • eGroupFamily : ms_distiller_data_search
  • eGroupStandard : ms_distiller_data_search
  • eIntegrated : ms_distiller_data_search
  • eLibrary : ms_distiller_data_search
  • eMudpit : ms_distiller_data_search
  • ERR_ABORTEDBYUSER : ms_http_helper_return
  • ERR_ACCINPEPTIDESTR : ms_mascotresfile
  • ERR_ADDPEPTIDES : ms_mascotresfile
  • ERR_CANNOT_APPEND_RESFILE : ms_mascotresfile
  • ERR_CANNOT_APPEND_RESFILE_NO_FNAMES : ms_mascotresfile
  • ERR_CDB_64_BIT_REMAKE : ms_mascotresfile
  • ERR_CDB_BEING_CREATED : ms_mascotresfile
  • ERR_CDB_FAIL_LOCK : ms_mascotresfile
  • ERR_CDB_FAIL_REMOVE : ms_mascotresfile
  • ERR_CDB_FAIL_UNLOCK : ms_mascotresfile
  • ERR_CDB_INCOMPLETE_NO_RETRY : ms_mascotresfile
  • ERR_CDB_INCOMPLETE_RETRY : ms_mascotresfile
  • ERR_CDB_OLD_VER_NO_RETRY : ms_mascotresfile
  • ERR_CDB_OLD_VER_RETRY : ms_mascotresfile
  • ERR_CDB_SOURCE_CHANGE_NO_RETRY : ms_mascotresfile
  • ERR_CDB_SOURCE_CHANGE_RETRY : ms_mascotresfile
  • ERR_CDB_TOO_LARGE : ms_mascotresfile
  • ERR_DUPE_ACCESSION : ms_mascotresfile
  • ERR_DUPLICATE_KEY : ms_mascotresfile
  • ERR_FAIL_CDB_INIT : ms_mascotresfile
  • ERR_FAIL_CLOSE_FILE : ms_mascotresfile
  • ERR_FAIL_MK_CACHE_DIR : ms_mascotresfile
  • ERR_FAIL_MK_CDB_FILE : ms_mascotresfile
  • ERR_FAIL_OPEN_DAT_FILE : ms_mascotresfile
  • ERR_HTTP : ms_http_helper_return
  • ERR_INVALID_CACHE_DIR : ms_mascotresfile
  • ERR_INVALID_CDB_FILE : ms_mascotresfile
  • ERR_INVALID_NUMQUERIES : ms_mascotresfile
  • ERR_INVALID_PROTDB : ms_mascotresfile
  • ERR_INVALID_RESFILE : ms_mascotresfile
  • ERR_MALFORMED_DRANGE : ms_mascotresfile
  • ERR_MALFORMED_ERR_TOL : ms_mascotresfile
  • ERR_MALFORMED_TAG : ms_mascotresfile
  • ERR_MALFORMED_TERMS : ms_mascotresfile
  • ERR_MISSING_CDB_FILE : ms_mascotresfile
  • ERR_MISSING_PERCOLATOR_FILE : ms_mascotresfile
  • ERR_MISSINGENTRY : ms_mascotresfile
  • ERR_MISSINGHIT : ms_mascotresfile
  • ERR_MISSINGSECTION : ms_mascotresfile
  • ERR_MISSINGSECTIONEND : ms_mascotresfile
  • ERR_NEED_64_BIT : ms_mascotresfile
  • ERR_NO_ERR_TOL_PARENT : ms_mascotresfile
  • ERR_NO_ERROR : ms_mascotresfile
  • ERR_NO_UNIGENE_FILE : ms_mascotresfile
  • ERR_NOMEM : ms_mascotresfile
  • ERR_NONE : ms_http_helper_return
  • ERR_NOSUCHFILE : ms_mascotresfile
  • ERR_NULL_ACC_PEP_SUM : ms_mascotresfile
  • ERR_NULL_ACC_PROT_SUM : ms_mascotresfile
  • ERR_OLDRESULTSFILE : ms_mascotresfile
  • ERR_PEPSUMMPEPGET : ms_mascotresfile
  • ERR_PEPTIDESTR : ms_mascotresfile
  • ERR_PROTSUMM : ms_mascotresfile
  • ERR_PROTSUMMPEP : ms_mascotresfile
  • ERR_QUERYOUTOFRANGE : ms_mascotresfile
  • ERR_READINGFILE : ms_mascotresfile
  • ERR_RESULTS_NOT_CREATED : ms_mascotresfile
  • ERR_SYSTEM : ms_http_helper_return
  • ERR_UNASSIGNED_PROG : ms_mascotresfile
  • ERR_UNASSIGNED_RANGE : ms_mascotresfile
  • ERR_UNASSIGNED_UNK : ms_mascotresfile
  • ERR_UNIGENE_MULTIDB : ms_mascotresfile
  • ERR_UNSPECIFIED : ms_http_helper_return
  • ERR_WRITE_CDB_FILE : ms_mascotresfile
  • eStandard : ms_distiller_data_search
  • eUnknown : ms_distiller_data_search
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- f -

  • FC_ALL_PEPTIDES : ms_mascotresults
  • FC_ALL_PEPTITDES : ms_mascotresults
  • FC_CASE_INSENSITIVE : ms_mascotresults
  • FC_CASE_SENSITIVE : ms_mascotresults
  • FC_COMPLETESTR : ms_mascotresults
  • FC_FORWARD : ms_mascotresults
  • FC_LOOP_FROM_UNASSIGNED : ms_mascotresults
  • FC_LOOP_INTO_UNASSIGNED : ms_mascotresults
  • FC_MASK_CASE : ms_mascotresults
  • FC_MASK_DIRECTION : ms_mascotresults
  • FC_MASK_STR_PART : ms_mascotresults
  • FC_PROTEIN_IGN_FAMILY : ms_mascotresults
  • FC_PROTEIN_IGN_MASK : ms_mascotresults
  • FC_PROTEIN_IGN_SAMESETS : ms_mascotresults
  • FC_PROTEIN_IGN_SUBSETS : ms_mascotresults
  • FC_PROTEIN_INC_ALT_ACC : ms_mascotresults
  • FC_RESTRICT_TO_HIT : ms_mascotresults
  • FC_REVERSE : ms_mascotresults
  • FC_SCORING_MASK : ms_mascotresults
  • FC_SEARCH_ALL_RANKS : ms_mascotresults
  • FC_SEARCH_IGNORED_RANKS : ms_mascotresults
  • FC_SIGNIFICANT_PEPTIDES : ms_mascotresults
  • FC_STARTSTR : ms_mascotresults
  • FC_STRTOK : ms_mascotresults
  • FC_SUBSTR : ms_mascotresults
  • FC_UNASSIGNED_MASK : ms_mascotresults
  • FM_binary : ms_http_helper
  • FM_text : ms_http_helper
  • FRAG_A_MINUS_H2O : ms_fragmentationrules
  • FRAG_A_MINUS_NH3 : ms_fragmentationrules
  • FRAG_A_SERIES : ms_fragmentationrules
  • FRAG_B_MINUS_H2O : ms_fragmentationrules
  • FRAG_B_MINUS_NH3 : ms_fragmentationrules
  • FRAG_B_SERIES : ms_fragmentationrules
  • FRAG_C_SERIES : ms_fragmentationrules
  • FRAG_D_SERIES : ms_fragmentationrules
  • FRAG_IMMONIUM : ms_fragmentationrules
  • FRAG_INTERNAL_YA : ms_fragmentationrules
  • FRAG_INTERNAL_YB : ms_fragmentationrules
  • FRAG_NL_PRIMARY : ms_aahelper
  • FRAG_NL_SECONDARY : ms_aahelper
  • FRAG_V_SERIES : ms_fragmentationrules
  • FRAG_W_SERIES : ms_fragmentationrules
  • FRAG_X_SERIES : ms_fragmentationrules
  • FRAG_Y_MINUS_H2O : ms_fragmentationrules
  • FRAG_Y_MINUS_NH3 : ms_fragmentationrules
  • FRAG_Y_SERIES : ms_fragmentationrules
  • FRAG_Z_PLUS_1 : ms_fragmentationrules
  • FRAG_Z_PLUS_2 : ms_fragmentationrules
  • FRAG_Z_SERIES : ms_fragmentationrules
  • FT_PEPTIDE_CALC_MR : ms_mascotresults
  • FT_PEPTIDE_CALC_MZ : ms_mascotresults
  • FT_PEPTIDE_ETMOD : ms_mascotresults
  • FT_PEPTIDE_EXP_MR : ms_mascotresults
  • FT_PEPTIDE_EXP_MZ : ms_mascotresults
  • FT_PEPTIDE_FIND_MASK : ms_mascotresults
  • FT_PEPTIDE_FIXMOD : ms_mascotresults
  • FT_PEPTIDE_QUERY : ms_mascotresults
  • FT_PEPTIDE_SLMOD : ms_mascotresults
  • FT_PEPTIDE_STRING : ms_mascotresults
  • FT_PEPTIDE_VARMOD : ms_mascotresults
  • FT_PEPTIDE_VARMOD_BYNAME : ms_mascotresults
  • FT_PROTEIN_ACCESSION : ms_mascotresults
  • FT_PROTEIN_DESCRIPTION : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- g -

  • GROUP_COMPLETE : ms_protein
  • GROUP_FAMILY : ms_protein
  • GROUP_NO : ms_protein
  • GROUP_SUBSET : ms_protein
  • GROUP_UNKNOWN : ms_protein
  • GROUPID_ADMINISTRATORS : ms_group
  • GROUPID_DAEMONS : ms_group
  • GROUPID_GUESTS : ms_group
  • GROUPID_INTEGRA_SYSTEM : ms_group
  • GROUPID_LAST : ms_group
  • GROUPID_POWERUSERS : ms_group
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- h -

  • HOMTHR_FASTA : ms_mascotresults
  • HOMTHR_SL : ms_mascotresults
  • HT_CANNOT_DETECT : ms_processors
  • HT_DISABLED : ms_processors
  • HT_ENABLED : ms_processors
  • HT_NOT_CAPABLE : ms_processors
  • HT_SUPPORTED_NOT_ENABLED : ms_processors
  • HTTP_1_0 : ms_connection_settings
  • HTTP_1_1 : ms_connection_settings
  • HTTP_SYSTEM_DEFAULT : ms_connection_settings
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- i -

  • IFLG_ADDMISSINGOPTIONS : ms_datfile
  • IFLG_ADDPERCOLATOROPT : ms_datfile
  • IFLG_ADDREPORTAUTO : ms_datfile
  • IFLG_DEFAULTNEWINSTALL : ms_datfile
  • IFLG_DEFAULTUPGRADE : ms_datfile
  • IFLG_UPDATEAPACHEFORKOPT : ms_datfile
  • IFLG_UPDATECLUSTER : ms_datfile
  • IFLG_UPDATEDBMANAGERPERLPATH : ms_datfile
  • IFLG_UPDATEESTTAX : ms_datfile
  • IFLG_UPDATEEXECAFTERSEARCH : ms_datfile
  • IFLG_UPDATEMSPEPSEARCHOPTS : ms_datfile
  • IFLG_UPDATENCBIHTTPS : ms_datfile
  • IFLG_UPDATEPARSERULES : ms_datfile
  • IFLG_UPDATEPERCOLATORFEATS : ms_datfile
  • IFLG_UPDATEPRIDECONTAMINANTS : ms_datfile
  • IFLG_UPDATEPROTFAMILYSWITCH : ms_datfile
  • IFLG_UPDATESWISSPROT : ms_datfile
  • IFLG_UPDATETAXONOMY : ms_datfile
  • IH_INCLUDE_TOP_10_MATCHES : ms_mascotresults
  • IH_INCLUDE_TOP_MATCHES : ms_mascotresults
  • INTENSITY : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- p -

  • PEAK_STATE_DISCARD : ms_xic
  • PEAK_STATE_OK : ms_xic
  • PEAK_STATE_UNKNOWN : ms_xic
  • PEPSUMMARY_CACHE_BEING_CREATED : ms_peptidesummary
  • PEPSUMMARY_CACHE_CAN_CREATE : ms_peptidesummary
  • PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • PEPSUMMARY_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • PEPSUMMARY_CACHE_NOT_FOR_PMF : ms_peptidesummary
  • PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE : ms_peptidesummary
  • PEPSUMMARY_CACHE_VALID : ms_peptidesummary
  • PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN : ms_quant_helper
  • PEPTIDE_EXPECT_ABOVE_THRESHOLD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_EXCLUDED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_EXCLUSIVE_MODS : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD : ms_quant_helper
  • PEPTIDE_HAS_NO_REQUIRED_VARMOD : ms_quant_helper
  • PEPTIDE_HAS_UNMODIFIED_SITE : ms_quant_helper
  • PEPTIDE_IS_QUANTIFIABLE : ms_quant_helper
  • PEPTIDE_NOT_UNIQUE : ms_quant_helper
  • PEPTIDE_QUALITY_IS_OK : ms_quant_helper
  • PEPTIDE_QUALITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_QUANTIFIABILITY_UNAVAILABLE : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_HOMOLOGY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM : ms_quant_helper
  • PEPTIDE_SCORE_BELOW_SCORE_THR : ms_quant_helper
  • PERC_EXE_RT_FORCE_OFF : ms_mascotoptions
  • PERC_EXE_RT_FORCE_ON : ms_mascotoptions
  • PERC_EXE_RT_USE_DEFAULT : ms_mascotoptions
  • PERCOLATOR_INPUT_FILE : ms_mascotresfile
  • PERCOLATOR_OUTPUT_DECOY : ms_mascotresfile
  • PERCOLATOR_OUTPUT_TARGET : ms_mascotresfile
  • PROXY_TYPE_AUTO : ms_connection_settings
  • PROXY_TYPE_ENVIRONMENT : ms_connection_settings
  • PROXY_TYPE_FROM_REGISTRY : ms_connection_settings
  • PROXY_TYPE_NO_PROXY : ms_connection_settings
  • PROXY_TYPE_SPECIFY : ms_connection_settings
  • PROXY_TYPE_WPAD : ms_connection_settings
  • PS_DUPLICATESAMEQUERY : ms_ms1quant_peptide_status
  • PS_EXCLUDE_LOCALDEF : ms_ms1quant_peptide_status
  • PS_EXCLUDE_MODFILE : ms_ms1quant_peptide_status
  • PS_EXCLUDE_UNMODIFIED : ms_ms1quant_peptide_status
  • PS_EXPECTGREATERTHAN : ms_ms1quant_peptide_status
  • PS_LESSTHANIDENTITY : ms_ms1quant_peptide_status
  • PS_MAX : ms_ms1quant_peptide_status
  • PS_MINCHARGE : ms_ms1quant_peptide_status
  • PS_NOTPARTOFQUANTITATION : ms_ms1quant_peptide_status
  • PS_NOTUNIQUE : ms_ms1quant_peptide_status
  • PS_OK : ms_ms1quant_peptide_status
  • PS_SCORELESSHOMOLOGY : ms_ms1quant_peptide_status
  • PS_SCORELESSIDENTITY_NOHOMO : ms_ms1quant_peptide_status
  • PS_SCORELESSTHRESHOLD : ms_ms1quant_peptide_status
  • PSM_COMPLETE : ms_peptide
  • PSM_CROSSLINK_ALPHA : ms_peptide
  • PSM_CROSSLINK_BETA : ms_peptide
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- q -

  • QCS_ERROR_BAD_COMPONENT_NAME : ms_mascotresults
  • QCS_ERROR_NO_COMPONENTS : ms_mascotresults
  • QCS_ERROR_NO_METHOD : ms_mascotresults
  • QCS_OK : ms_mascotresults
  • QCS_OK_MULTIPLE_MATCHES : ms_mascotresults
  • QCS_OK_NO_MATCH : ms_mascotresults
  • QL_ALL : ms_peptidesummary
  • QL_BELOW_HOMOLOGY : ms_peptidesummary
  • QL_BELOW_IDENTITY : ms_peptidesummary
  • QL_IGNORE_IONS_SCORE_BELOW : ms_peptidesummary
  • QL_LAST : ms_peptidesummary
  • QL_UNASSIGNED : ms_peptidesummary
  • QUERY : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- r -

  • REDIRECT_POLICY_ALWAYS : ms_connection_settings
  • REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP : ms_connection_settings
  • REDIRECT_POLICY_NEVER : ms_connection_settings
  • RESFILE_CACHE_BEING_CREATED : ms_peptidesummary
  • RESFILE_CACHE_CAN_CREATE : ms_peptidesummary
  • RESFILE_CACHE_DISABLED_IN_OPTIONS : ms_peptidesummary
  • RESFILE_CACHE_FILE_NOT_PRESENT : ms_peptidesummary
  • RESFILE_CACHE_IGNORE_ACC_DUPES : ms_mascotresfile
  • RESFILE_CACHE_IGNORE_DATE_CHANGE : ms_mascotresfile
  • RESFILE_CACHE_VALID : ms_peptidesummary
  • RESFILE_NOFLAG : ms_mascotresfile
  • RESFILE_USE_CACHE : ms_mascotresfile
  • RESFILE_USE_PARENT_PARAMS : ms_mascotresfile
  • RS_DO_NOT_USE : ms_ms1quant_match_ratio
  • RS_EMPTY : ms_ms1quant_match_ratio
  • RS_FITEXYSIGMA : ms_ms1quant_match_ratio
  • RS_INFINITERATIO : ms_ms1quant_match_ratio
  • RS_INTEFERENCEFAILED : ms_ms1quant_match_ratio
  • RS_ISOLATEDPRECURSORFAILED : ms_ms1quant_match_ratio
  • RS_NEGATIVERATIO : ms_ms1quant_match_ratio
  • RS_NODATA : ms_ms1quant_match_ratio
  • RS_OK : ms_ms1quant_match_ratio
  • RS_TOTALINTENSITYFAILED : ms_ms1quant_match_ratio
  • RS_ZERORATIO : ms_ms1quant_match_ratio
  • RT_auto : ms_http_client_search
  • RT_file : ms_http_client_search
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- s -

  • S_NOT_STARTED : ms_progress_info
  • S_RUNNING : ms_progress_info
  • S_RUNNING_INDETERMINATE : ms_progress_info
  • S_STOPPED_BREAK : ms_progress_info
  • S_STOPPED_COMPLETE : ms_progress_info
  • S_STOPPED_FAIL : ms_progress_info
  • SAR_FAIL_CHMOD : ms_fileutilities
  • SAR_FAIL_CHOWN : ms_fileutilities
  • SAR_FAIL_GET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_FAIL_SET_ENTRIES_IN_ACL : ms_fileutilities
  • SAR_FAIL_SET_NAMED_SECURITY_INFO : ms_fileutilities
  • SAR_SUCCESS : ms_fileutilities
  • SCORE : ms_mascotresults
  • SEC_CROSSLINK_PEPTIDES : ms_mascotresfile
  • SEC_CROSSLINK_SUMMARY : ms_mascotresfile
  • SEC_CROSSLINKING : ms_mascotresfile
  • SEC_DECOYMIXTURE : ms_mascotresfile
  • SEC_DECOYPEPTIDES : ms_mascotresfile
  • SEC_DECOYPROTEINS : ms_mascotresfile
  • SEC_DECOYSUMMARY : ms_mascotresfile
  • SEC_ENZYME : ms_mascotresfile
  • SEC_ERRTOLDECOYPEPTIDES : ms_mascotresfile
  • SEC_ERRTOLDECOYSUMMARY : ms_mascotresfile
  • SEC_ERRTOLPEPTIDES : ms_mascotresfile
  • SEC_ERRTOLSUMMARY : ms_mascotresfile
  • SEC_HEADER : ms_mascotresfile
  • SEC_INDEX : ms_mascotresfile
  • SEC_LIBRARYPEPTIDES : ms_mascotresfile
  • SEC_LIBRARYSUMMARY : ms_mascotresfile
  • SEC_MASSES : ms_mascotresfile
  • SEC_MIXTURE : ms_mascotresfile
  • SEC_NUMSECTIONS : ms_mascotresfile
  • SEC_PARAMETERS : ms_mascotresfile
  • SEC_PEPTIDES : ms_mascotresfile
  • SEC_PROTEINS : ms_mascotresfile
  • SEC_QUANTITATION : ms_mascotresfile
  • SEC_QUERY1 : ms_mascotresfile
  • SEC_SPECTRAL_LIBRARY : ms_mascotresfile
  • SEC_SUMMARY : ms_mascotresfile
  • SEC_TAXONOMY : ms_mascotresfile
  • SEC_UNIMOD : ms_mascotresfile
  • SEC_UNIMOD_XL : ms_mascotresfile
  • SECTASK_ACCESSDBSETUP : ms_security_tasks
  • SECTASK_ADMINPAGES : ms_security_tasks
  • SECTASK_ALLFASTA : ms_security_tasks
  • SECTASK_ALLOWMSMS : ms_security_tasks
  • SECTASK_ALLOWMSMSNOENZYME : ms_security_tasks
  • SECTASK_ALLOWPMF : ms_security_tasks
  • SECTASK_ALLOWPMFNOENZYME : ms_security_tasks
  • SECTASK_ALLOWSPOOFOTHERUSER : ms_security_tasks
  • SECTASK_BIOTOOLSBATCH : ms_security_tasks
  • SECTASK_DAEMONCLIENT : ms_security_tasks
  • SECTASK_DATAURLMAXSIZE : ms_security_tasks
  • SECTASK_DATAURLPROTOCOLS : ms_security_tasks
  • SECTASK_DENYQUANT : ms_security_tasks
  • SECTASK_DISTILLERCLIENT : ms_security_tasks
  • SECTASK_DOWNLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_EDITCONFIG : ms_security_tasks
  • SECTASK_INTEGRASYSTEMACCOUNT : ms_security_tasks
  • SECTASK_KILLALLTASK : ms_security_tasks
  • SECTASK_KILLTASKINGROUP : ms_security_tasks
  • SECTASK_MAXCONCURRENTSEARCHES : ms_security_tasks
  • SECTASK_MAXETACCESSIONS : ms_security_tasks
  • SECTASK_MAXETVARMODS : ms_security_tasks
  • SECTASK_MAXEXECUTIONTIME : ms_security_tasks
  • SECTASK_MAXFASTAFILES : ms_security_tasks
  • SECTASK_MAXJOBPRIORITY : ms_security_tasks
  • SECTASK_MAXNOENZQUERIES : ms_security_tasks
  • SECTASK_MAXQUERIES : ms_security_tasks
  • SECTASK_MAXVARMODS : ms_security_tasks
  • SECTASK_MODIFYOWNPROFILE : ms_security_tasks
  • SECTASK_MSSTATUSEXECLUSTER : ms_security_tasks
  • SECTASK_MSSTATUSEXERETRYDB : ms_security_tasks
  • SECTASK_NAMEDFASTA : ms_security_tasks
  • SECTASK_SEEALLSEARCHESWITHUSERID : ms_security_tasks
  • SECTASK_SEEOLDSEARCHES : ms_security_tasks
  • SECTASK_SEESEARCHINANYGROUP : ms_security_tasks
  • SECTASK_SEESEARCHINGROUP : ms_security_tasks
  • SECTASK_SPOOFNAMEDGROUPSONLY : ms_security_tasks
  • SECTASK_UPLOAD_DISTILLER_XML : ms_security_tasks
  • SECTASK_USEMSREVIEWEXE : ms_security_tasks
  • SECTASK_USEMSSTATUSEXE : ms_security_tasks
  • SECTASK_VIEWCONFIG : ms_security_tasks
  • SECTASK_VIEWCONFIGUSINGMSSTATUS : ms_security_tasks
  • SEQDB_INSTALL_CURRENT_RULES : ms_datfile
  • SEQDB_INSTALL_CUSTOMISED : ms_datfile
  • SEQDB_INSTALL_EXISTING_LARGER : ms_datfile
  • SEQDB_INSTALL_INACTIVE : ms_datfile
  • SEQDB_INSTALL_INVALID_CONFIG : ms_datfile
  • SEQDB_INSTALL_INVALID_DBNAME : ms_datfile
  • SEQDB_INSTALL_MISSING_CONFIG : ms_datfile
  • SEQDB_INSTALL_MUST_UPDATE_CFG : ms_datfile
  • SEQDB_INSTALL_OLD_RULES : ms_datfile
  • SEQDB_INSTALL_SHOULD_QUERY_USER : ms_datfile
  • SEQDB_INSTALL_WRONG_WILDCARD : ms_datfile
  • sev_debug1 : ms_log
  • sev_debug2 : ms_log
  • sev_debug3 : ms_log
  • sev_fatal : ms_log
  • sev_info : ms_log
  • sev_warn : ms_log
  • SHOW_ALL : ms_http_client_session
  • SHOW_LENGTH : ms_http_client_session
  • SHOW_NONE : ms_http_client_session
  • SHOW_PI : ms_http_client_session
  • SHOW_REFERENCE : ms_http_client_session
  • SHOW_SEQUENCE : ms_http_client_session
  • SHOW_TITLE : ms_http_client_session
  • SRC_ALL : ms_loggingmonitor
  • SRC_APPLICATION : ms_loggingmonitor
  • SRC_DENOVOLIB : ms_loggingmonitor
  • SRC_MASCOTSERVER : ms_loggingmonitor
  • SRC_MDRO : ms_loggingmonitor
  • SRC_MSPARSER : ms_loggingmonitor
  • SRC_MSQUANTLIB : ms_loggingmonitor
  • SRC_PURIFIERAPI : ms_loggingmonitor
  • SRC_PURIFIERAPP : ms_loggingmonitor
  • SRC_VENDORSTART : ms_loggingmonitor
  • SS_ASSIGNED : ms_http_client_search
  • SS_COMPLETE : ms_http_client_search
  • SS_ERROR : ms_http_client_search
  • SS_QUEUED : ms_http_client_search
  • SS_RUNNING : ms_http_client_search
  • SS_SEARCH_CONTROL_ERROR : ms_http_client_search
  • SS_UNKNOWN : ms_http_client_search
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- t -

  • TAX_CHOP_PREFIX : ms_parserule_plus
  • TAX_CHOP_SUFFIX : ms_parserule_plus
  • TAX_CHOP_WORDS : ms_parserule_plus
  • TCD_ABS_CORRELATION : ms_treecluster
  • TCD_ABS_UNCENTERED_CORRELATION : ms_treecluster
  • TCD_CITY_BLOCK : ms_treecluster
  • TCD_CORRELATION : ms_treecluster
  • TCD_EUCLIDEAN : ms_treecluster
  • TCD_KENDALLS_TAU_CORRELATION : ms_treecluster
  • TCD_SPEARMANS_RANK_CORRELATION : ms_treecluster
  • TCD_UNCENTERED_CORRELATION : ms_treecluster
  • TCM_PAIRWISE_AVERAGE : ms_mascotresults
  • TCM_PAIRWISE_MAXIMUM : ms_mascotresults
  • TCM_PAIRWISE_SINGLE : ms_mascotresults
  • TT_HOMOLOGY : ms_mascotresults
  • TT_IDENTITY : ms_mascotresults
  • TT_PEPSUM_DEFAULT : ms_mascotresults
  • TYPE_ALL_USERS_ARRAY : ms_security_task
  • TYPE_BOOL : ms_security_task
  • TYPE_DOUBLE_ARRAY : ms_security_task
  • TYPE_EQ_DOUBLE : ms_security_task
  • TYPE_EQ_LONG : ms_security_task
  • TYPE_EQ_STRING : ms_security_task
  • TYPE_GTE_DOUBLE : ms_security_task
  • TYPE_GTE_LONG : ms_security_task
  • TYPE_LONG_ARRAY : ms_security_task
  • TYPE_LTE_DOUBLE : ms_security_task
  • TYPE_LTE_LONG : ms_security_task
  • TYPE_STRING_ARRAY : ms_security_task
  • TYPE_USERS_ARRAY : ms_security_task
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- u -

  • UNDEFINED_CUTTER : ms_enzyme
  • UPR_DEFAULT : ms_mascotresults
  • UPR_IGNORE_SUBSET_PROTEINS : ms_mascotresults
  • UPR_WITHIN_FAMILY : ms_mascotresults
  • UPR_WITHIN_FAMILY_MEMBER : ms_mascotresults
  • UR_ACCESS_DENIED : ms_http_client_search
  • UR_ERROR : ms_http_client_search
  • UR_FILE_ALREADY_EXISTS : ms_http_client_search
  • UR_INVALID_TASKID : ms_http_client_search
  • UR_NO_RESULT_FILE : ms_http_client_search
  • UR_NO_RESULT_FILENAME : ms_http_client_search
  • UR_SUCCESS : ms_http_client_search
  • USER_AGENT_STRING : ms_user
  • USER_COMPUTER_NAME : ms_user
  • USER_INTEGRA : ms_user
  • USER_IP_ADDRESS : ms_user
  • USER_NORMAL : ms_user
  • USER_SECURITY_DISABLED : ms_user
  • USER_WEBAUTH : ms_user
  • USERID_ADMINISTRATOR : ms_user
  • USERID_CMDLINE : ms_user
  • USERID_DAEMON : ms_user
  • USERID_GUEST : ms_user
  • USERID_INTEGRA_SYSTEM : ms_user
  • USERID_LAST : ms_user
  • USERID_PUBLIC_SEARCHES : ms_user
  • USERID_SECURITY_DISABLED : ms_user
  • USERID_SORTBY_FULLNAME : ms_security
  • USERID_SORTBY_ID : ms_security
  • USERID_SORTBY_LOGINNAME : ms_security
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- w -

  • WST_APACHE : ms_datfile
  • WST_IIS : ms_datfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • x

- x -

  • XML_SCHEMA_CROSSLINKING : ms_mascotresfile
  • XML_SCHEMA_DIRECTORY : ms_mascotresfile
  • XML_SCHEMA_LAST : ms_mascotresfile
  • XML_SCHEMA_QUANTITATION : ms_mascotresfile
  • XML_SCHEMA_UNIMOD : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • abortedByUser() : ms_http_helper_return
  • addComponent() : ms_ms1quant_match
  • addCreatedComponent() : ms_ms1quant_match
  • addCutter() : ms_enzyme
  • addDoubleParam() : ms_security_task
  • addExperimentalData() : ms_fragmentvector
  • addHeaderField() : ms_quantitation
  • addLogEventsHandler() : ms_loggingmonitor
  • addLongParam() : ms_security_task
  • addMatchInferred() : ms_ms1quantitation
  • addMatchPeptide() : ms_ms1quantitation
  • addMatchStatus() : ms_ms1quantitation
  • addNewGroup() : ms_security
  • addNewUser() : ms_security
  • addPeaks() : ms_spectral_lib_peak_list
  • addPeptideQuantKey() : ms_customquantitation
  • addPeptideQuantKeys() : ms_customquantitation
  • addPeptideRatio() : ms_customquantitation
  • addPermittedTask() : ms_group
  • addRawFileField() : ms_quantitation
  • addStringParam() : ms_security_task
  • addSubtask() : ms_progress_info
  • addTask() : ms_security_tasks
  • addToCatalog() : ms_log
  • addUser() : ms_group
  • allComponentsIdentified() : ms_ms1quant_match
  • annotatePeaks() : ms_spectral_lib_entry , ms_spectral_lib_peak_list
  • anyBoldRedPeptides() : ms_protein
  • anyEmPAI() : ms_peptidesummary , ms_mascotresults
  • anyMatchToQuery() : ms_protein
  • anyMatchToQueryAndP() : ms_protein
  • anyMSMS() : ms_mascotresfile
  • anyNLseriesUsed() : ms_fragmentationrules
  • anyNumDiscoveredMods() : ms_mascotresults
  • anyPeptideSummaryMatches() : ms_mascotresfile
  • anyPercolatorResults() : ms_peptide
  • anyPMF() : ms_mascotresfile
  • anySQ() : ms_mascotresfile
  • anyTag() : ms_mascotresfile
  • append() : ms_http_client_mime , ms_linker_site_vector , ms_peptide_quant_key_vector
  • appendAccession() : ms_crosslinking_accessions
  • appendAltName() : ms_umod_modification
  • appendAminoAcid() : ms_umod_configfile
  • appendComponent() : ms_quant_method
  • appendCorrection() : ms_quant_component
  • appendCronJob() : ms_cronoptions
  • appendDatabase() : ms_databases , ms_processoroptions
  • appendDenominator() : ms_quant_ratio
  • appendDoesNotPairWith() : ms_crosslinking_linker
  • appendElement() : ms_quant_composition , ms_umod_configfile
  • appendElemRef() : ms_umod_composition , ms_umod_modbrick , ms_umod_aminoacid
  • appendEntry() : ms_taxonomyfile , ms_wwwoptions
  • appendEnzyme() : ms_enzymefile
  • appendErrors() : ms_errs , ms_errors , ms_mascotresfile
  • appendExcludeTaxonomy() : ms_taxonomychoice
  • appendExclusion() : ms_quant_method
  • appendFile() : ms_http_client_mime
  • appendFragment() : ms_fragmentvector
  • appendGencodeFile() : ms_taxonomyrules
  • appendIgnore() : ms_quant_localdef , ms_umod_modification
  • appendIgnoreDupeAccession() : ms_mascotoptions
  • appendIgnoreMass() : ms_modification
  • appendIncludeTaxonomy() : ms_taxonomychoice
  • appendInstrument() : ms_fragrulesfile
  • appendIonSeries() : ms_quant_multiplex
  • appendIsotope() : ms_quant_component
  • appendLinker() : ms_crosslinking_linkers
  • appendLocalDefinition() : ms_quant_modgroup
  • appendMethod() : ms_quant_configfile , ms_crosslinking_configfile
  • appendModBrick() : ms_umod_configfile
  • appendModFile() : ms_quant_modgroup
  • appendModification() : ms_modfile , ms_umod_configfile , ms_modvector
  • appendModificationGroup() : ms_quant_component , ms_quant_method
  • appendModifications() : ms_modvector
  • appendModifiedResidue() : ms_modification
  • appendMonoLink() : ms_crosslinking_linker
  • appendNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • appendNoBreakDescLineIf() : ms_taxonomyrules
  • appendNodesFile() : ms_taxonomyrules
  • appendNumerator() : ms_quant_ratio
  • appendParameter() : ms_quant_parameters , ms_crosslinking_parameters
  • appendPepNeutralLoss() : ms_umod_specificity , ms_quant_specificity
  • appendPeptide() : ms_quant_normalisation_peptides
  • appendPerDbSrcRule() : ms_taxonomyrules
  • appendPrefixRemove() : ms_taxonomyrules
  • appendProcessor() : ms_processoroptions
  • appendProperty() : ms_customproperty
  • appendProtein() : ms_quant_normalisation_proteins
  • appendReportNumberChoice() : ms_mascotoptions
  • appendReportRatio() : ms_quant_method
  • appendResfile() : ms_mascotresfile
  • appendSampleValue() : ms_shapiro_wilk
  • appendSeq() : ms_quant_method
  • appendSpeciesFile() : ms_taxonomyrules
  • appendSpecificity() : ms_umod_modification , ms_quant_localdef
  • appendStrFile() : ms_taxonomyrules
  • appendSubCluster() : ms_clusterparams
  • appendSuffixRemove() : ms_taxonomyrules
  • appendTargetFDRPercentage() : ms_mascotoptions
  • appendText() : ms_customproperty
  • appendThreadProcessorID() : ms_dbprocessors
  • appendUnmodified() : ms_quant_modgroup
  • appendXref() : ms_umod_modification
  • applyFixedMods() : ms_masses
  • applyIsotopes() : ms_masses
  • applyVisibility() : ms_umod_configfile
  • arithmeticMean() : ms_quant_stats
  • arithmeticStandardDeviation() : ms_quant_stats
  • arithmeticStandardErrorOfMean() : ms_quant_stats
  • arithmeticStandardErrorOfMedian() : ms_quant_stats
  • asText() : ms_spectral_lib_peak_list , ms_spectral_lib_peak
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • loadCdbFile() : ms_ms1quantitation , ms_ms2quantitation
  • loadCdbFiles() : ms_ms2quantitation
  • loadFromFile() : ms_security_tasks
  • loadXml() : ms_distiller_data , ms_distiller_master_project , ms_distiller_search_status_list
  • loadXmlFile() : ms_distiller_data , ms_ms1quantitation , ms_distiller_master_project , ms_distiller_search_status_list
  • loadXmlStream() : ms_distiller_master_project , ms_distiller_search_status_list , ms_distiller_data
  • logContents() : ms_matrix
  • logMessage() : ms_loggingmonitor
  • logout() : ms_http_client_session
  • logTransform() : ms_quant_stats
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • makeExists() : ms_tinycdb
  • mascotresfile() : ms_peptidesummary
  • meanCentre() : ms_quant_stats
  • medianStandardErrorCorrection() : ms_quant_stats
  • mergeQuantitationResults() : ms_ms1quantitation
  • messageSourceAsText() : ms_loggingmonitor
  • ms_aahelper() : ms_aahelper
  • ms_buffer_logger() : ms_buffer_logger
  • ms_clusterparams() : ms_clusterparams
  • ms_computeraddress() : ms_computeraddress
  • ms_connection_settings() : ms_connection_settings
  • ms_cronjob() : ms_cronjob
  • ms_cronoptions() : ms_cronoptions
  • ms_crosslinking_accession() : ms_crosslinking_accession
  • ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ms_crosslinking_filters() : ms_crosslinking_filters
  • ms_crosslinking_linker() : ms_crosslinking_linker
  • ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ms_crosslinking_method() : ms_crosslinking_method
  • ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ms_crosslinking_scope() : ms_crosslinking_scope
  • ms_crosslinking_settings() : ms_crosslinking_settings
  • ms_customproperty() : ms_customproperty
  • ms_customquantitation() : ms_customquantitation
  • ms_databaseoptions() : ms_databaseoptions
  • ms_databases() : ms_databases
  • ms_datfile() : ms_datfile
  • ms_dbprocessors() : ms_dbprocessors
  • ms_distiller_data() : ms_distiller_data
  • ms_distiller_data_search() : ms_distiller_data_search
  • ms_distiller_master_project() : ms_distiller_master_project
  • ms_distiller_search_status_list() : ms_distiller_search_status_list
  • ms_enzyme() : ms_enzyme
  • ms_enzymefile() : ms_enzymefile
  • ms_errors() : ms_errors
  • ms_errs() : ms_errs
  • ms_file_logger() : ms_file_logger
  • ms_fileutilities() : ms_fileutilities
  • ms_fitexy_result() : ms_fitexy_result
  • ms_fragment() : ms_fragment
  • ms_fragmentationrules() : ms_fragmentationrules
  • ms_fragmentvector() : ms_fragmentvector
  • ms_fragrulesfile() : ms_fragrulesfile
  • ms_group() : ms_group
  • ms_http_client() : ms_http_client
  • ms_http_client_search() : ms_http_client_search
  • ms_http_client_session() : ms_http_client_session
  • ms_http_helper() : ms_http_helper
  • ms_http_helper_handles() : ms_http_helper_handles
  • ms_http_helper_progress() : ms_http_helper_progress
  • ms_http_helper_return() : ms_http_helper_return
  • ms_inputquery() : ms_inputquery
  • ms_libraryoptions() : ms_libraryoptions
  • ms_license() : ms_license
  • ms_linker_site() : ms_linker_site
  • ms_linker_site_vector() : ms_linker_site_vector
  • ms_log() : ms_log
  • ms_logger() : ms_logger
  • ms_loggingmonitor() : ms_loggingmonitor
  • ms_mascotfiles() : ms_mascotfiles
  • ms_mascotoptions() : ms_mascotoptions
  • ms_mascotresfile() : ms_mascotresfile
  • ms_mascotresults() : ms_mascotresults
  • ms_mascotresults_params() : ms_mascotresults_params
  • ms_masses() : ms_masses
  • ms_matrix() : ms_matrix
  • ms_modfile() : ms_modfile
  • ms_modification() : ms_modification
  • ms_modvector() : ms_modvector
  • ms_ms1quant_average_results() : ms_ms1quant_average_results
  • ms_ms1quant_charge_state() : ms_ms1quant_charge_state
  • ms_ms1quant_match() : ms_ms1quant_match
  • ms_ms1quant_match_component() : ms_ms1quant_match_component
  • ms_ms1quant_match_range() : ms_ms1quant_match_range
  • ms_ms1quant_match_ratio() : ms_ms1quant_match_ratio
  • ms_ms1quant_peptide_status() : ms_ms1quant_peptide_status
  • ms_ms1quantitation() : ms_ms1quantitation
  • ms_ms2quantitation() : ms_ms2quantitation
  • ms_obofile() : ms_obofile
  • ms_parseoptions() : ms_parseoptions
  • ms_parserule() : ms_parserule
  • ms_parserule_plus() : ms_parserule_plus
  • ms_peptide() : ms_peptide
  • ms_peptide_quant_key() : ms_peptide_quant_key
  • ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ms_peptidesummary() : ms_peptidesummary
  • ms_processoroptions() : ms_processoroptions
  • ms_processors() : ms_processors
  • ms_progress_info() : ms_progress_info
  • ms_protein() : ms_protein
  • ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ms_proteinsummary() : ms_proteinsummary
  • ms_quant_average() : ms_quant_average
  • ms_quant_component() : ms_quant_component
  • ms_quant_composition() : ms_quant_composition
  • ms_quant_configfile() : ms_quant_configfile
  • ms_quant_correction() : ms_quant_correction
  • ms_quant_element() : ms_quant_element
  • ms_quant_helper() : ms_quant_helper
  • ms_quant_integration() : ms_quant_integration
  • ms_quant_isotope() : ms_quant_isotope
  • ms_quant_localdef() : ms_quant_localdef
  • ms_quant_method() : ms_quant_method
  • ms_quant_modgroup() : ms_quant_modgroup
  • ms_quant_moverz() : ms_quant_moverz
  • ms_quant_multiplex() : ms_quant_multiplex
  • ms_quant_neutralloss() : ms_quant_neutralloss
  • ms_quant_normalisation() : ms_quant_normalisation
  • ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ms_quant_numerator() : ms_quant_numerator
  • ms_quant_outliers() : ms_quant_outliers
  • ms_quant_parameter() : ms_quant_parameter
  • ms_quant_parameters() : ms_quant_parameters
  • ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ms_quant_precursor() : ms_quant_precursor
  • ms_quant_protocol() : ms_quant_protocol
  • ms_quant_quality() : ms_quant_quality
  • ms_quant_ratio() : ms_quant_ratio
  • ms_quant_replicate() : ms_quant_replicate
  • ms_quant_reporter() : ms_quant_reporter
  • ms_quant_satellite() : ms_quant_satellite
  • ms_quant_specificity() : ms_quant_specificity
  • ms_quant_unmodified() : ms_quant_unmodified
  • ms_searchparams() : ms_searchparams
  • ms_security() : ms_security
  • ms_security_options() : ms_security_options
  • ms_security_task() : ms_security_task
  • ms_security_tasks() : ms_security_tasks
  • ms_session() : ms_session
  • ms_shapiro_wilk() : ms_shapiro_wilk
  • ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ms_spectral_lib_file() : ms_spectral_lib_file
  • ms_spectral_lib_peak() : ms_spectral_lib_peak
  • ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ms_stdout_logger() : ms_stdout_logger
  • ms_taxnodesfiles() : ms_taxnodesfiles
  • ms_taxonomychoice() : ms_taxonomychoice
  • ms_taxonomyfile() : ms_taxonomyfile
  • ms_taxonomyrules() : ms_taxonomyrules
  • ms_taxonomytree() : ms_taxonomytree
  • ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ms_tinycdb() : ms_tinycdb
  • ms_treecluster() : ms_treecluster
  • ms_umod_aminoacid() : ms_umod_aminoacid
  • ms_umod_composition() : ms_umod_composition
  • ms_umod_configfile() : ms_umod_configfile
  • ms_umod_element() : ms_umod_element
  • ms_umod_elemref() : ms_umod_elemref
  • ms_umod_modbrick() : ms_umod_modbrick
  • ms_umod_modification() : ms_umod_modification
  • ms_umod_neutralloss() : ms_umod_neutralloss
  • ms_umod_specificity() : ms_umod_specificity
  • ms_umod_xref() : ms_umod_xref
  • ms_unigene() : ms_unigene
  • ms_unigene_entry() : ms_unigene_entry
  • ms_unigeneoptions() : ms_unigeneoptions
  • ms_user() : ms_user
  • ms_wwwentry() : ms_wwwentry
  • ms_wwwoptions() : ms_wwwoptions
  • ms_xic() : ms_xic
  • ms_xml_parameter() : ms_xml_parameter
  • ms_xml_parameters() : ms_xml_parameters
  • ms_zip() : ms_zip
  • multiplyByRow() : ms_matrix
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • normalCriticalValue() : ms_quant_stats
  • normalCumulativeProbability() : ms_quant_stats
  • normaliseIntensities() : ms_ms2quantitation
  • normalisePeptideRatios() : ms_ms2quantitation
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • onLogMessage() : ms_logger , ms_stdout_logger , ms_buffer_logger , ms_file_logger
  • openIndexFile() : ms_tinycdb
  • openQuantitationCdbResults() : ms_ms1quantitation
  • openQuantitationXmlResults() : ms_ms1quantitation
  • operator bool() : ms_http_helper_return
  • operator!=() : ms_matrix , ms_peptide_quant_key , ms_protein_quant_ratio
  • operator*() : ms_matrix
  • operator<() : ms_peptide_quant_key
  • operator<=() : ms_peptide_quant_key
  • operator=() : ms_umod_xref , ms_umod_specificity , ms_umod_neutralloss , ms_umod_modification , ms_umod_modbrick , ms_umod_elemref , ms_umod_element , ms_umod_configfile , ms_umod_composition , ms_umod_aminoacid , ms_treecluster , ms_taxonomytree , ms_taxonomyrules , ms_parserule_plus , ms_xml_parameter , ms_clusterparams , ms_taxonomyfile , ms_taxonomychoice , ms_spectral_lib_peak_list , ms_spectral_lib_peak , ms_spectral_lib_entry , ms_security_options , ms_quant_unmodified , ms_crosslinking_scope , ms_quant_satellite , ms_quant_reporter , ms_quant_replicate , ms_quant_ratio , ms_quant_quality , ms_quant_protocol , ms_parserule , ms_unigeneoptions , ms_quant_parameters , ms_quant_parameter , ms_quant_outliers , ms_quant_numerator , ms_quant_normalisation_proteins , ms_quant_normalisation_protein , ms_quant_normalisation_peptides , ms_wwwentry , ms_quant_normalisation , ms_quant_neutralloss , ms_quant_multiplex , ms_quant_moverz , ms_quant_modgroup , ms_quant_method , ms_quant_localdef , ms_parseoptions , ms_quant_integration , ms_quant_correction , ms_quant_configfile , ms_quant_composition , ms_quant_element , ms_quant_component , ms_quant_average , ms_crosslinking_settings , ms_processors , ms_processoroptions , ms_dbprocessors , ms_peptide_quant_key , ms_peptide_quant_key_vector , ms_computeraddress , ms_databaseoptions , ms_peptide_quant_ratio , ms_obofile , ms_modfile , ms_modvector , ms_modification , ms_masses , ms_mascotresults_params , ms_protein , ms_taxnodesfiles , ms_mascotoptions , ms_mascotfiles , ms_linker_site_vector , ms_quant_specificity , ms_license , ms_libraryoptions , ms_http_helper , ms_quant_precursor , ms_http_client_search , ms_http_client , ms_fragmentvector , ms_quant_normalisation_peptide , ms_fragmentationrules , ms_fragment , ms_enzymefile , ms_quant_isotope , ms_distiller_search_status_list , ms_distiller_master_project , ms_distiller_data , ms_databases , ms_connection_settings , ms_datfile , ms_protein_quant_ratio , ms_cronjob , ms_crosslinking_parameters , ms_crosslinking_parameter , ms_crosslinking_monolink , ms_taxspeciesfiles , ms_crosslinking_linkers , ms_linker_site , ms_crosslinking_filters , ms_quant_pepneutralloss , ms_crosslinking_configfile , ms_fragrulesfile , ms_crosslinking_accession , ms_zip , ms_cronoptions , ms_enzyme , ms_crosslinking_accessions , ms_wwwoptions , ms_aahelper , ms_peptide , ms_crosslinking_linker , ms_crosslinking_does_not_pair_with , ms_http_client_session , ms_crosslinking_method
  • operator==() : ms_matrix , ms_protein_quant_ratio , ms_peptide_quant_key
  • operator>() : ms_peptide_quant_key
  • operator>=() : ms_peptide_quant_key
  • operator[]() : ms_matrix
  • outputKeepAlive() : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~ms_aahelper() : ms_aahelper
  • ~ms_buffer_logger() : ms_buffer_logger
  • ~ms_clusterparams() : ms_clusterparams
  • ~ms_computeraddress() : ms_computeraddress
  • ~ms_connection_settings() : ms_connection_settings
  • ~ms_cronjob() : ms_cronjob
  • ~ms_cronoptions() : ms_cronoptions
  • ~ms_crosslinking_accession() : ms_crosslinking_accession
  • ~ms_crosslinking_accessions() : ms_crosslinking_accessions
  • ~ms_crosslinking_configfile() : ms_crosslinking_configfile
  • ~ms_crosslinking_does_not_pair_with() : ms_crosslinking_does_not_pair_with
  • ~ms_crosslinking_filters() : ms_crosslinking_filters
  • ~ms_crosslinking_linker() : ms_crosslinking_linker
  • ~ms_crosslinking_linkers() : ms_crosslinking_linkers
  • ~ms_crosslinking_method() : ms_crosslinking_method
  • ~ms_crosslinking_monolink() : ms_crosslinking_monolink
  • ~ms_crosslinking_parameter() : ms_crosslinking_parameter
  • ~ms_crosslinking_parameters() : ms_crosslinking_parameters
  • ~ms_crosslinking_scope() : ms_crosslinking_scope
  • ~ms_crosslinking_settings() : ms_crosslinking_settings
  • ~ms_customproperty() : ms_customproperty
  • ~ms_customquantitation() : ms_customquantitation
  • ~ms_databaseoptions() : ms_databaseoptions
  • ~ms_databases() : ms_databases
  • ~ms_datfile() : ms_datfile
  • ~ms_dbprocessors() : ms_dbprocessors
  • ~ms_enzyme() : ms_enzyme
  • ~ms_enzymefile() : ms_enzymefile
  • ~ms_errors() : ms_errors
  • ~ms_errs() : ms_errs
  • ~ms_file_logger() : ms_file_logger
  • ~ms_fragmentationrules() : ms_fragmentationrules
  • ~ms_fragmentvector() : ms_fragmentvector
  • ~ms_fragrulesfile() : ms_fragrulesfile
  • ~ms_http_client() : ms_http_client
  • ~ms_http_client_mime() : ms_http_client_mime
  • ~ms_http_client_search() : ms_http_client_search
  • ~ms_http_client_session() : ms_http_client_session
  • ~ms_http_helper() : ms_http_helper
  • ~ms_http_helper_handles() : ms_http_helper_handles
  • ~ms_libraryoptions() : ms_libraryoptions
  • ~ms_license() : ms_license
  • ~ms_linker_site() : ms_linker_site
  • ~ms_linker_site_vector() : ms_linker_site_vector
  • ~ms_log() : ms_log
  • ~ms_logger() : ms_logger
  • ~ms_loggingmonitor() : ms_loggingmonitor
  • ~ms_mascotfiles() : ms_mascotfiles
  • ~ms_mascotoptions() : ms_mascotoptions
  • ~ms_masses() : ms_masses
  • ~ms_modfile() : ms_modfile
  • ~ms_modification() : ms_modification
  • ~ms_modvector() : ms_modvector
  • ~ms_ms2quantitation() : ms_ms2quantitation
  • ~ms_obofile() : ms_obofile
  • ~ms_parseoptions() : ms_parseoptions
  • ~ms_parserule() : ms_parserule
  • ~ms_parserule_plus() : ms_parserule_plus
  • ~ms_peptide() : ms_peptide
  • ~ms_peptide_quant_key() : ms_peptide_quant_key
  • ~ms_peptide_quant_key_vector() : ms_peptide_quant_key_vector
  • ~ms_peptide_quant_ratio() : ms_peptide_quant_ratio
  • ~ms_processoroptions() : ms_processoroptions
  • ~ms_processors() : ms_processors
  • ~ms_progress_info() : ms_progress_info
  • ~ms_protein() : ms_protein
  • ~ms_protein_quant_ratio() : ms_protein_quant_ratio
  • ~ms_quant_average() : ms_quant_average
  • ~ms_quant_component() : ms_quant_component
  • ~ms_quant_composition() : ms_quant_composition
  • ~ms_quant_configfile() : ms_quant_configfile
  • ~ms_quant_correction() : ms_quant_correction
  • ~ms_quant_element() : ms_quant_element
  • ~ms_quant_helper() : ms_quant_helper
  • ~ms_quant_integration() : ms_quant_integration
  • ~ms_quant_isotope() : ms_quant_isotope
  • ~ms_quant_localdef() : ms_quant_localdef
  • ~ms_quant_method() : ms_quant_method
  • ~ms_quant_modgroup() : ms_quant_modgroup
  • ~ms_quant_moverz() : ms_quant_moverz
  • ~ms_quant_multiplex() : ms_quant_multiplex
  • ~ms_quant_neutralloss() : ms_quant_neutralloss
  • ~ms_quant_normalisation() : ms_quant_normalisation
  • ~ms_quant_normalisation_peptide() : ms_quant_normalisation_peptide
  • ~ms_quant_normalisation_peptides() : ms_quant_normalisation_peptides
  • ~ms_quant_normalisation_protein() : ms_quant_normalisation_protein
  • ~ms_quant_normalisation_proteins() : ms_quant_normalisation_proteins
  • ~ms_quant_numerator() : ms_quant_numerator
  • ~ms_quant_outliers() : ms_quant_outliers
  • ~ms_quant_parameter() : ms_quant_parameter
  • ~ms_quant_parameters() : ms_quant_parameters
  • ~ms_quant_pepneutralloss() : ms_quant_pepneutralloss
  • ~ms_quant_precursor() : ms_quant_precursor
  • ~ms_quant_protocol() : ms_quant_protocol
  • ~ms_quant_quality() : ms_quant_quality
  • ~ms_quant_ratio() : ms_quant_ratio
  • ~ms_quant_replicate() : ms_quant_replicate
  • ~ms_quant_reporter() : ms_quant_reporter
  • ~ms_quant_satellite() : ms_quant_satellite
  • ~ms_quant_specificity() : ms_quant_specificity
  • ~ms_quant_unmodified() : ms_quant_unmodified
  • ~ms_quantitation() : ms_quantitation
  • ~ms_searchparams() : ms_searchparams
  • ~ms_security_task() : ms_security_task
  • ~ms_security_tasks() : ms_security_tasks
  • ~ms_spectral_lib_entry() : ms_spectral_lib_entry
  • ~ms_spectral_lib_file() : ms_spectral_lib_file
  • ~ms_spectral_lib_peak_list() : ms_spectral_lib_peak_list
  • ~ms_stdout_logger() : ms_stdout_logger
  • ~ms_taxnodesfiles() : ms_taxnodesfiles
  • ~ms_taxonomychoice() : ms_taxonomychoice
  • ~ms_taxonomyfile() : ms_taxonomyfile
  • ~ms_taxonomyrules() : ms_taxonomyrules
  • ~ms_taxonomytree() : ms_taxonomytree
  • ~ms_taxspeciesfiles() : ms_taxspeciesfiles
  • ~ms_tinycdb() : ms_tinycdb
  • ~ms_treecluster() : ms_treecluster
  • ~ms_umod_aminoacid() : ms_umod_aminoacid
  • ~ms_umod_composition() : ms_umod_composition
  • ~ms_umod_configfile() : ms_umod_configfile
  • ~ms_umod_element() : ms_umod_element
  • ~ms_umod_elemref() : ms_umod_elemref
  • ~ms_umod_modbrick() : ms_umod_modbrick
  • ~ms_umod_modification() : ms_umod_modification
  • ~ms_umod_neutralloss() : ms_umod_neutralloss
  • ~ms_umod_specificity() : ms_umod_specificity
  • ~ms_umod_xref() : ms_umod_xref
  • ~ms_unigene() : ms_unigene
  • ~ms_unigene_entry() : ms_unigene_entry
  • ~ms_unigeneoptions() : ms_unigeneoptions
  • ~ms_wwwentry() : ms_wwwentry
  • ~ms_wwwoptions() : ms_wwwoptions
  • ~ms_xml_parameter() : ms_xml_parameter
  • ~ms_xml_parameters() : ms_xml_parameters
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • baseUrl() : ms_http_client , ms_http_helper
  • binomialCoefficient() : ms_quant_stats
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • calcFragments() : ms_aahelper
  • calcFragmentsEx() : ms_aahelper
  • calcPeptideMZ() : ms_aahelper
  • calculate() : ms_shapiro_wilk
  • calculateGeometricMeanRatio() : ms_quantitation
  • calculateMedianRatio() : ms_quantitation
  • calculateNormalMeanPvalue() : ms_quant_stats
  • calculateNormalMedianPvalue() : ms_quant_stats
  • calculateNormalWeightedPvalue() : ms_quant_stats
  • calculateWeightedGeometricMeanRatio() : ms_quantitation
  • cancelCreateSummary() : ms_mascotresults
  • canCleave() : ms_enzyme
  • canResultsFileBeViewed() : ms_session
  • changePassword() : ms_http_client
  • checkSeqDBInstallRequest() : ms_datfile
  • chisqLowerCriticalValue() : ms_quant_stats
  • chisqUpperCriticalValue() : ms_quant_stats
  • clear() : ms_linker_site_vector , ms_peptide_quant_key_vector , ms_progress_info
  • clearAccessions() : ms_crosslinking_accessions
  • clearAllCutters() : ms_enzyme
  • clearAllErrors() : ms_errs , ms_errors
  • clearAltNames() : ms_umod_modification
  • clearAminoAcids() : ms_umod_configfile
  • clearAnnotation() : ms_spectral_lib_entry , ms_spectral_lib_peak , ms_spectral_lib_peak_list
  • clearComponents() : ms_quant_method
  • clearCorrections() : ms_quant_component
  • clearCronJobs() : ms_cronoptions
  • clearDatabases() : ms_databases , ms_processoroptions
  • clearDBLevelTaxId() : ms_taxonomyrules
  • clearDenominators() : ms_quant_ratio
  • clearDoesNotPairWiths() : ms_crosslinking_linker
  • clearElements() : ms_quant_composition , ms_umod_configfile
  • clearElemRefs() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • clearEntries() : ms_taxonomyfile , ms_wwwoptions
  • clearEnzymes() : ms_enzymefile
  • clearExcludeTaxonomies() : ms_taxonomychoice
  • clearExclusions() : ms_quant_method
  • clearFragments() : ms_fragmentvector
  • clearGencodeFiles() : ms_taxonomyrules
  • clearHeaderFields() : ms_quantitation
  • clearHitRatioExcluded() : ms_ms1quant_match
  • clearHitRatioOutlier() : ms_ms1quant_match
  • clearIgnoreDupeAccessions() : ms_mascotoptions
  • clearIgnoreMasses() : ms_modification
  • clearIgnores() : ms_quant_localdef , ms_umod_modification
  • clearIncludeTaxonomies() : ms_taxonomychoice
  • clearInstruments() : ms_fragrulesfile
  • clearIonSeries() : ms_quant_multiplex
  • clearIsotopes() : ms_quant_component
  • clearLinkers() : ms_crosslinking_linkers
  • clearLocalDefinitions() : ms_quant_modgroup
  • clearMatchedIon() : ms_fragment
  • clearMethods() : ms_crosslinking_configfile , ms_quant_configfile
  • clearModBricks() : ms_umod_configfile
  • clearModFiles() : ms_quant_modgroup
  • clearModificationGroups() : ms_quant_component , ms_quant_method
  • clearModifications() : ms_modvector , ms_modfile , ms_umod_configfile
  • clearModifiedResidues() : ms_modification
  • clearMonoLinks() : ms_crosslinking_linker
  • clearNeutralLosses() : ms_quant_specificity , ms_umod_specificity
  • clearNoBreakDescLineIf() : ms_taxonomyrules
  • clearNodesFiles() : ms_taxonomyrules
  • clearNumerators() : ms_quant_ratio
  • clearParam() : ms_group , ms_session , ms_user
  • clearParameters() : ms_crosslinking_parameters , ms_quant_parameters , ms_xml_parameters
  • clearParams() : ms_security_task
  • clearParseRules() : ms_parseoptions
  • clearPepNeutralLosses() : ms_quant_specificity , ms_umod_specificity
  • clearPeptideQuantKeys() : ms_customquantitation
  • clearPeptideRatios() : ms_customquantitation
  • clearPeptides() : ms_quant_normalisation_peptides
  • clearPerDbSrcRules() : ms_taxonomyrules
  • clearPrefixRemoves() : ms_taxonomyrules
  • clearProcessors() : ms_processoroptions
  • clearProteins() : ms_quant_normalisation_proteins
  • clearRawFileFields() : ms_quantitation
  • clearReloadableInfo() : ms_peptide
  • clearReportNumberChoices() : ms_mascotoptions
  • clearReportRatios() : ms_quant_method
  • clearSampleValues() : ms_shapiro_wilk
  • clearSeqs() : ms_quant_method
  • clearSeries() : ms_fragmentationrules
  • clearSpeciesFiles() : ms_taxonomyrules
  • clearSpecificities() : ms_quant_localdef , ms_umod_modification
  • clearSubClusters() : ms_clusterparams
  • clearSuffixRemoves() : ms_taxonomyrules
  • clearTargetFDRPercentages() : ms_mascotoptions
  • clearThreads() : ms_dbprocessors
  • clearUnmodified() : ms_quant_modgroup
  • clearXrefs() : ms_umod_modification
  • closeHandles() : ms_http_helper_handles
  • closeIndexFile() : ms_tinycdb
  • cluster() : ms_treecluster
  • columnMatrix() : ms_matrix
  • compareXmlFiles() : ms_fileutilities
  • compressMore() : ms_zip
  • connectionSettings() : ms_http_client , ms_http_helper
  • containsVarModIdx() : ms_linker_site_vector
  • convertFromLogLevel() : ms_errs
  • convertToLogLevel() : ms_errs
  • copyFrom() : ms_modvector , ms_quant_correction , ms_crosslinking_parameters , ms_crosslinking_parameter , ms_crosslinking_monolink , ms_crosslinking_method , ms_crosslinking_linkers , ms_quant_normalisation , ms_crosslinking_filters , ms_umod_elemref , ms_crosslinking_configfile , ms_crosslinking_accessions , ms_crosslinking_accession , ms_clusterparams , ms_zip , ms_computeraddress , ms_xic , ms_connection_settings , ms_aahelper , ms_cronjob , ms_quant_pepneutralloss , ms_umod_modification , ms_enzymefile , ms_spectral_lib_peak_list , ms_quant_protocol , ms_cronoptions , ms_fragrulesfile , ms_quant_replicate , ms_quant_ratio , ms_taxonomytree , ms_quant_parameter , ms_umod_aminoacid , ms_umod_modification , ms_quant_normalisation_peptide , ms_linker_site , ms_quant_unmodified , ms_quant_specificity , ms_umod_specificity , ms_quant_normalisation_proteins , ms_umod_neutralloss , ms_security_options , ms_crosslinking_does_not_pair_with , ms_masses , ms_umod_modbrick , ms_quant_neutralloss , ms_quant_moverz , ms_quant_reporter , ms_quant_isotope , ms_umod_neutralloss , ms_crosslinking_linker , ms_parseoptions , ms_taxnodesfiles , ms_taxspeciesfiles , ms_wwwentry , ms_processoroptions , ms_unigeneoptions , ms_parserule_plus , ms_modvector , ms_quant_component , ms_treecluster , ms_peptide , ms_mascotfiles , ms_taxonomychoice , ms_wwwoptions , ms_umod_xref , ms_http_client_search , ms_quant_method , ms_umod_configfile , ms_umod_composition , ms_enzyme , ms_distiller_data , ms_xml_parameter , ms_umod_element , ms_crosslinking_settings , ms_quant_normalisation_peptides , ms_umod_specificity , ms_quant_normalisation_protein , ms_quant_integration , ms_umod_composition , ms_crosslinking_scope , ms_quant_multiplex , ms_quant_modgroup , ms_quant_precursor , ms_distiller_master_project , ms_umod_modification , ms_umod_elemref , ms_fragmentationrules , ms_fragmentvector , ms_umod_neutralloss , ms_spectral_lib_peak , ms_license , ms_linker_site_vector , ms_mascotoptions , ms_quant_numerator , ms_masses , ms_modification , ms_quant_outliers , ms_quant_composition , ms_parserule , ms_peptide_quant_key_vector , ms_dbprocessors , ms_taxonomyfile , ms_quant_average , ms_quant_element , ms_quant_configfile , ms_http_client , ms_distiller_search_status_list , ms_quant_localdef , ms_modfile , ms_processors , ms_taxonomyrules , ms_protein_quant_ratio , ms_modfile , ms_peptide_quant_ratio , ms_datfile , ms_quant_parameters , ms_fragment , ms_quant_quality , ms_libraryoptions , ms_quant_satellite , ms_mascotresults_params , ms_spectral_lib_entry , ms_obofile , ms_customproperty , ms_http_client_session , ms_protein , ms_http_helper , ms_databaseoptions , ms_errors , ms_databases
  • copyMassFile() : ms_modification
  • countDistinctPeptides() : ms_quantitation , ms_ms2quantitation , ms_ms1quantitation
  • createCrosslinkedPeptide() : ms_aahelper
  • createDefaults() : ms_security
  • createDirectory() : ms_fileutilities
  • createMissingComponents() : ms_quant_helper
  • createPeptide() : ms_aahelper
  • createSummary() : ms_peptidesummary , ms_mascotresults
  • createUnassignedList() : ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • data() : ms_matrix
  • defaultValues() : ms_aahelper , ms_computeraddress , ms_crosslinking_accession , ms_crosslinking_monolink , ms_mascotoptions , ms_quant_precursor , ms_quant_protocol , ms_masses , ms_quant_quality , ms_quant_ratio , ms_crosslinking_parameter , ms_modification , ms_quant_replicate , ms_quant_reporter , ms_modfile , ms_quant_satellite , ms_quant_specificity , ms_crosslinking_accessions , ms_crosslinking_parameters , ms_obofile , ms_quant_unmodified , ms_taxonomychoice , ms_parserule , ms_taxonomyfile , ms_taxspeciesfiles , ms_crosslinking_scope , ms_parseoptions , ms_taxnodesfiles , ms_parserule_plus , ms_dbprocessors , ms_taxonomyrules , ms_treecluster , ms_connection_settings , ms_crosslinking_configfile , ms_crosslinking_settings , ms_processoroptions , ms_umod_aminoacid , ms_umod_composition , ms_quant_average , ms_umod_configfile , ms_umod_element , ms_customproperty , ms_quant_component , ms_umod_elemref , ms_umod_modbrick , ms_quant_element , ms_umod_modification , ms_umod_neutralloss , ms_crosslinking_does_not_pair_with , ms_databaseoptions , ms_quant_composition , ms_umod_specificity , ms_umod_xref , ms_quant_configfile , ms_unigeneoptions , ms_wwwentry , ms_databases , ms_quant_correction , ms_wwwoptions , ms_xic , ms_quant_integration , ms_xml_parameter , ms_xml_parameters , ms_clusterparams , ms_cronjob , ms_crosslinking_filters , ms_datfile , ms_quant_isotope , ms_quant_localdef , ms_enzyme , ms_quant_method , ms_quant_modgroup , ms_crosslinking_linker , ms_enzymefile , ms_quant_moverz , ms_quant_multiplex , ms_fragmentationrules , ms_quant_neutralloss , ms_quant_normalisation , ms_cronoptions , ms_crosslinking_linkers , ms_fragrulesfile , ms_quant_normalisation_peptide , ms_quant_normalisation_peptides , ms_libraryoptions , ms_quant_normalisation_protein , ms_quant_normalisation_proteins , ms_crosslinking_method , ms_license , ms_quant_numerator , ms_quant_outliers , ms_mascotfiles , ms_quant_parameters , ms_quant_pepneutralloss
  • deleteAccessionByNumber() : ms_crosslinking_accessions
  • deleteAltName() : ms_umod_modification
  • deleteAminoAcidByName() : ms_umod_configfile
  • deleteAminoAcidByNumber() : ms_umod_configfile
  • deleteComponentByName() : ms_quant_method
  • deleteComponentByNumber() : ms_quant_method
  • deleteCorrection() : ms_quant_component
  • deleteCronJob() : ms_cronoptions
  • deleteDatabaseByName() : ms_databases
  • deleteDatabaseByNumber() : ms_databases
  • deleteDenominatorByName() : ms_quant_ratio
  • deleteDenominatorByNumber() : ms_quant_ratio
  • deleteDirectory() : ms_fileutilities
  • deleteDoesNotPairWithByNumber() : ms_crosslinking_linker
  • deleteElement() : ms_quant_composition
  • deleteElementByName() : ms_umod_configfile
  • deleteElementByNumber() : ms_umod_configfile
  • deleteElemRef() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • deleteEnzymeByName() : ms_enzymefile
  • deleteEnzymeByNumber() : ms_enzymefile
  • deleteExclusion() : ms_quant_method
  • deleteGroup() : ms_security
  • deleteIgnore() : ms_quant_localdef , ms_umod_modification
  • deleteInstrumentByName() : ms_fragrulesfile
  • deleteInstrumentByNumber() : ms_fragrulesfile
  • deleteIonSeries() : ms_quant_multiplex
  • deleteIsotope() : ms_quant_component
  • deleteLinkerByNumber() : ms_crosslinking_linkers
  • deleteLocalDefinition() : ms_quant_modgroup
  • deleteMethodByName() : ms_crosslinking_configfile , ms_quant_configfile
  • deleteMethodByNumber() : ms_crosslinking_configfile , ms_quant_configfile
  • deleteModBrickByName() : ms_umod_configfile
  • deleteModBrickByNumber() : ms_umod_configfile
  • deleteModFile() : ms_quant_modgroup
  • deleteModificationByName() : ms_modfile , ms_umod_configfile
  • deleteModificationByNumber() : ms_modfile , ms_umod_configfile
  • deleteModificationGroupByName() : ms_quant_component , ms_quant_method
  • deleteModificationGroupByNumber() : ms_quant_component , ms_quant_method
  • deleteMonoLinkByNumber() : ms_crosslinking_linker
  • deleteNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • deleteNumeratorByName() : ms_quant_ratio
  • deleteNumeratorByNumber() : ms_quant_ratio
  • deleteParameterByName() : ms_crosslinking_parameters , ms_quant_parameters , ms_xml_parameters
  • deleteParameterByNumber() : ms_crosslinking_parameters , ms_quant_parameters , ms_xml_parameters
  • deletePepNeutralLoss() : ms_quant_specificity , ms_umod_specificity
  • deletePeptide() : ms_quant_normalisation_peptides
  • deleteProtein() : ms_quant_normalisation_proteins
  • deleteReportRatioByName() : ms_quant_method
  • deleteReportRatioByNumber() : ms_quant_method
  • deleteSeq() : ms_quant_method
  • deleteSpecificity() : ms_quant_localdef , ms_umod_modification
  • deleteUnmodified() : ms_quant_modgroup
  • deleteUser() : ms_security , ms_group
  • deleteXref() : ms_umod_modification
  • delNonEmpty() : ms_customproperty
  • delProp() : ms_customproperty
  • delPropByNumber() : ms_customproperty
  • delPropStart() : ms_customproperty
  • destroy() : ms_session
  • detectOutliers() : ms_quant_stats
  • diagonalMatrix() : ms_matrix
  • doesFileExist() : ms_fileutilities
  • doesSectionExist() : ms_mascotresfile
  • downloadDaemonResultsFile() : ms_http_client_search
  • downloadPercolatorFile() : ms_http_client_search
  • downloadResultsFile() : ms_http_client_search
  • downloadXmlResultsFile() : ms_http_client_search
  • dropAccession() : ms_quant_normalisation_protein
  • dropAccessions() : ms_crosslinking_method
  • dropAllChargeStates() : ms_quant_integration , ms_quant_precursor
  • dropAllChargeStatesThreshold() : ms_quant_integration
  • dropAllowElutionShift() : ms_quant_precursor , ms_quant_integration
  • dropAllowMassTimeMatch() : ms_quant_precursor
  • dropApproved() : ms_umod_modification
  • dropAverage() : ms_quant_moverz
  • dropAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • dropClassification() : ms_umod_specificity
  • dropCode() : ms_umod_neutralloss
  • dropCoefficient() : ms_quant_numerator
  • dropComp() : ms_quant_method
  • dropCompositionString() : ms_umod_composition
  • dropConstrainSearch() : ms_quant_method
  • dropDatabaseName() : ms_crosslinking_accession
  • dropDateTimeModified() : ms_umod_modification
  • dropDateTimePosted() : ms_umod_modification
  • dropDelta() : ms_quant_localdef , ms_umod_modification
  • dropDescription() : ms_crosslinking_method , ms_umod_neutralloss , ms_xml_parameter , ms_quant_method
  • dropElement() : ms_quant_correction
  • dropElutionProfileCorrelationThreshold() : ms_quant_integration
  • dropElutionTimeDelta() : ms_quant_integration
  • dropElutionTimeDeltaUnit() : ms_quant_integration
  • dropEntry() : ms_wwwoptions
  • dropExcludeInternalLabel() : ms_quant_multiplex
  • dropExcludeIsobaricFragments() : ms_quant_multiplex
  • dropFileIndex() : ms_quant_component
  • dropFilters() : ms_crosslinking_method
  • dropFlag() : ms_umod_neutralloss , ms_quant_neutralloss
  • dropFullName() : ms_umod_aminoacid , ms_umod_element , ms_umod_modification , ms_umod_modbrick
  • dropGroupOfPoster() : ms_umod_modification
  • dropHidden() : ms_umod_specificity
  • dropIntegration() : ms_quant_method
  • dropIonIntensityThreshold() : ms_quant_multiplex
  • dropIonSeries() : ms_quant_multiplex
  • dropIsolatedPrecursor() : ms_quant_quality
  • dropIsolatedPrecursorThreshold() : ms_quant_quality
  • dropLinkers() : ms_crosslinking_method
  • dropMassDelta() : ms_quant_integration
  • dropMassDeltaUnit() : ms_quant_integration
  • dropMatchedRho() : ms_quant_integration
  • dropMethod() : ms_quant_normalisation , ms_quant_integration , ms_quant_outliers
  • dropMinimumA1() : ms_quant_quality
  • dropMinIonPairs() : ms_quant_multiplex
  • dropMinNumPeptides() : ms_quant_method
  • dropMinPrecursorCharge() : ms_quant_quality
  • dropMiscNotes() : ms_umod_specificity , ms_umod_modification
  • dropMode() : ms_quant_modgroup
  • dropModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • dropModifications() : ms_quant_satellite
  • dropMonoisotopic() : ms_quant_moverz
  • dropMonoMass() : ms_umod_modbrick , ms_umod_aminoacid , ms_umod_composition , ms_umod_element
  • dropMoverz() : ms_quant_component
  • dropName() : ms_quant_component , ms_quant_method , ms_quant_modgroup , ms_quant_ratio , ms_xml_parameter , ms_crosslinking_method , ms_quant_numerator
  • dropNew() : ms_quant_isotope
  • dropNormalisation() : ms_quant_method
  • dropNumber() : ms_quant_element , ms_umod_elemref
  • dropNumPeptides() : ms_quant_average
  • dropOld() : ms_quant_isotope
  • dropOutliers() : ms_quant_method
  • dropPairsWith() : ms_umod_neutralloss
  • dropParseRule() : ms_parseoptions
  • dropPepThresholdType() : ms_quant_quality
  • dropPepThresholdValue() : ms_quant_quality
  • dropPeptides() : ms_quant_normalisation
  • dropPosition() : ms_umod_specificity , ms_quant_unmodified , ms_quant_specificity
  • dropPrecursorRange() : ms_quant_integration
  • dropProcessingOptions() : ms_quant_integration
  • dropProteinRatioType() : ms_quant_method
  • dropProteins() : ms_quant_normalisation
  • dropProtocol() : ms_quant_method
  • dropProtScoreType() : ms_quant_method
  • dropQuality() : ms_quant_method
  • dropRecordID() : ms_umod_modification
  • dropReferenceAccession() : ms_quant_average
  • dropReferenceAmount() : ms_quant_average
  • dropReferenceDatabase() : ms_quant_average
  • dropReportDetail() : ms_quant_method
  • dropReporterTol() : ms_quant_reporter
  • dropReporterTolUnit() : ms_quant_reporter
  • dropRequireBoldRed() : ms_quant_method
  • dropRequired() : ms_quant_pepneutralloss , ms_quant_modgroup
  • dropSatellite() : ms_quant_component
  • dropScope() : ms_crosslinking_method
  • dropSelection() : ms_quant_average
  • dropSequence() : ms_quant_normalisation_peptide
  • dropSettings() : ms_crosslinking_method
  • dropShift() : ms_quant_correction
  • dropShowSubSets() : ms_quant_method
  • dropSigThresholdValue() : ms_quant_method
  • dropSimpleRatio() : ms_quant_integration
  • dropSite() : ms_quant_specificity , ms_quant_unmodified , ms_umod_specificity
  • dropSource() : ms_umod_xref , ms_quant_integration
  • dropSpecGroup() : ms_umod_specificity
  • dropSpectralLibrary() : ms_libraryoptions
  • dropStrategy() : ms_crosslinking_method
  • dropSymbol() : ms_umod_elemref , ms_quant_element
  • dropText() : ms_umod_xref
  • dropThreeLetter() : ms_umod_aminoacid
  • dropTitle() : ms_umod_element , ms_umod_modification , ms_umod_aminoacid , ms_quant_localdef , ms_umod_modbrick
  • dropTotalIntensity() : ms_quant_quality
  • dropTotalIntensityThreshold() : ms_quant_quality
  • dropType() : ms_quant_correction
  • dropUniquePepseq() : ms_quant_quality
  • dropUrl() : ms_umod_xref
  • dropUsernameOfPoster() : ms_umod_modification
  • dropValue() : ms_crosslinking_accession
  • dropXicMaxWidth() : ms_quant_integration
  • dropXicSmoothing() : ms_quant_integration
  • dropXicThreshold() : ms_quant_integration
  • dumpCDB() : ms_peptidesummary
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • editedByDatabaseManager() : ms_datfile
  • empty() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • enumerateQuerySectionKeys() : ms_mascotresfile
  • enumerateSectionKeys() : ms_mascotresfile
  • erase() : ms_http_client_mime
  • excludeProteinPeptideRatioKeys() : ms_ms2quantitation
  • expTransform() : ms_quant_stats
  • extend() : ms_ms1quant_match_range
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • findClose() : ms_fileutilities
  • findDatabase() : ms_databases
  • findEntries() : ms_spectral_lib_file
  • findEntry() : ms_unigene
  • findIDFromTagValue() : ms_obofile
  • findMascotDat() : ms_fileutilities
  • findMatch() : ms_ms1quantitation
  • findModFile() : ms_quant_modgroup
  • findModFileName() : ms_umod_configfile
  • findModification() : ms_umod_configfile
  • findNext() : ms_fileutilities
  • findOpen() : ms_fileutilities
  • findPeptides() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findPeptideStatus() : ms_ms1quantitation
  • findProperty() : ms_customproperty
  • findPropertyBeginning() : ms_customproperty
  • findProteins() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findProteinsByAccession() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • findProteinsByDescription() : ms_mascotresults , ms_peptidesummary , ms_proteinsummary
  • findSpecGroup() : ms_umod_modification
  • finishCreate() : ms_tinycdb
  • flush() : ms_buffer_logger
  • format() : ms_http_client_mime
  • formatHeader() : ms_http_client_mime
  • formatMessage() : ms_logger
  • forwardToParentInstance() : ms_errs
  • freeHit() : ms_peptidesummary , ms_mascotresults
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • geometricMean() : ms_quant_stats
  • geometricStandardDeviation() : ms_quant_stats
  • get() : ms_peptide_quant_key_vector , ms_spectral_lib_entry , ms_linker_site_vector
  • get_ms_mascotresults_params() : ms_mascotresfile , ms_distiller_data , ms_mascotresfile
  • getA() : ms_fitexy_result
  • getAbsoluteValue() : ms_ms1quant_match_component
  • getACCESSION() : ms_searchparams
  • getAccession() : ms_protein , ms_protein_quant_ratio , ms_quant_normalisation_protein
  • getAccessionByNumber() : ms_crosslinking_accessions
  • getAccessionFromNumber() : ms_spectral_lib_file
  • getAccessionParseRuleIndex() : ms_databaseoptions
  • getAccessionRefParseRuleIndex() : ms_databaseoptions
  • getAccessions() : ms_crosslinking_method
  • getAccessionSchemaType() : ms_crosslinking_accessions , ms_quant_normalisation_protein
  • getAccessionsSchemaType() : ms_crosslinking_method
  • getAccFromSpeciesLine() : ms_taxonomyrules
  • getActiveKeys() : ms_protein_quant_ratio
  • getAllChargeStatesSchemaType() : ms_quant_integration , ms_quant_precursor
  • getAllChargeStatesThreshold() : ms_quant_integration
  • getAllChargeStatesThresholdSchemaType() : ms_quant_integration
  • getAllCustomParamsForUser() : ms_security
  • getAllFamilyMembersWithThisPepMatch() : ms_mascotresults , ms_peptidesummary , ms_proteinsummary
  • getAllGroupIDs() : ms_security
  • getAllMatchedIons() : ms_fragment
  • getAllMods() : ms_spectral_lib_file
  • getAllowElutionShiftSchemaType() : ms_quant_integration , ms_quant_precursor
  • getAllowMassTimeMatchSchemaType() : ms_quant_precursor
  • getAllParamsAsString() : ms_security_task
  • getAllProteinsWithThisPepMatch() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getAllUserIDs() : ms_security , ms_group
  • getAllUSERParams() : ms_searchparams
  • getAllValuesFromKey() : ms_tinycdb
  • getAlphaVarModsStrLength() : ms_linker_site_vector
  • getAltName() : ms_umod_modification
  • getAltNameSchemaType() : ms_umod_modification
  • getAmbiguityString() : ms_peptide
  • getAminoAcidByName() : ms_umod_configfile
  • getAminoAcidByNumber() : ms_umod_configfile
  • getAnnotation() : ms_spectral_lib_peak
  • getAnyMatch() : ms_peptide
  • getAnyProteinTermination() : ms_peptide
  • getApprovedSchemaType() : ms_umod_modification
  • getAutoDetectNumThreads() : ms_processors
  • getAvePeptideIdentityThreshold() : ms_mascotresults
  • getAverage() : ms_quant_moverz , ms_quant_protocol
  • getAveragePeptideIntensity() : ms_ms1quantitation
  • getAverageResults() : ms_ms1quantitation
  • getAverageSchemaType() : ms_quant_moverz , ms_quant_protocol
  • getAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getAvgeMassAsNumber() : ms_umod_element
  • getAvgeMassSchemaType() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getB() : ms_fitexy_result
  • getBetaVarModsStrLength() : ms_linker_site_vector
  • getBoolParam() : ms_session
  • getBucket() : ms_ms1quant_charge_state
  • getBucketWidth() : ms_ms1quant_charge_state
  • getCacheDirectory() : ms_mascotoptions , ms_mascotresfile
  • getCacheFileName() : ms_distiller_data_search , ms_mascotresfile , ms_peptidesummary
  • getCacheFilename() : ms_distiller_master_search , ms_peptidesummary
  • getCacheStreamName() : ms_distiller_data_quant
  • getCarbonMass() : ms_searchparams , ms_masses
  • getCentroidWidth() : ms_mascotoptions
  • getCentroidWidthCount() : ms_mascotoptions
  • getCHARGE() : ms_searchparams
  • getCharge() : ms_fragment , ms_inputquery , ms_peptide , ms_peptide_quant_key , ms_spectral_lib_entry
  • getChargeState() : ms_ms1quant_match
  • getChargeStateData() : ms_ms1quant_match
  • getChargeType() : ms_ms1quant_match
  • getCheckNodesAliveFreq() : ms_clusterparams
  • getChecksum() : ms_spectral_lib_peak_list
  • getChecksumFromNumber() : ms_spectral_lib_file
  • getChi2() : ms_fitexy_result
  • getChopSource() : ms_parserule_plus
  • getChromosome() : ms_unigene_entry
  • getClassification() : ms_umod_specificity
  • getClassificationSchemaType() : ms_umod_specificity
  • getCLE() : ms_searchparams
  • getCleave() : ms_enzyme
  • getClusterParams() : ms_datfile
  • getCode() : ms_modification , ms_umod_neutralloss
  • getCodeFromXml() : ms_ms1quant_match , ms_ms1quant_match_ratio , ms_ms1quant_peptide_status , ms_xic
  • getCodeInfo() : ms_ms1quant_match_ratio
  • getCodeSchemaType() : ms_umod_neutralloss
  • getCoefficient() : ms_quant_numerator
  • getCoefficientSchemaType() : ms_quant_numerator
  • getColsToOutput() : ms_logger
  • getColumn() : ms_fragment
  • getCOM() : ms_searchparams
  • getCombinedPeptideSummaryCacheStreamName() : ms_distiller_master_search
  • getCombinedReportRatio() : ms_ms2quantitation
  • getCombinedReportRatioNames() : ms_ms2quantitation
  • getCombineRepeats() : ms_errs
  • getCommandStr() : ms_cronjob
  • getComment() : ms_spectral_lib_entry
  • getCommentField() : ms_spectral_lib_entry
  • getComp() : ms_inputquery , ms_quant_method
  • getComponent() : ms_protein , ms_ms1quant_match , ms_ms1quant_match_component , ms_ms1quant_peptide_status
  • getComponentByName() : ms_quant_method
  • getComponentByNumber() : ms_quant_method
  • getComponentIntensities() : ms_ms2quantitation
  • getComponentIntensity() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getComponentProtein() : ms_peptidesummary , ms_mascotresults
  • getComponentSchemaType() : ms_quant_method
  • getComponentStr() : ms_peptide
  • getComponentString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getCompositionString() : ms_umod_composition
  • getCompositionStringSchemaType() : ms_umod_composition
  • getCompressToolAA() : ms_mascotoptions
  • getCompressToolCommandLineFasta() : ms_mascotoptions
  • getCompressToolCommandLineLibrary() : ms_mascotoptions
  • getCompressToolNA() : ms_mascotoptions
  • getCompressToolSL() : ms_mascotoptions
  • getCompSchemaType() : ms_quant_method
  • getConciseLabelFreeVarMods() : ms_ms1quant_match
  • getConnectionSettings() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_umod_configfile
  • getConnectionTimeout() : ms_connection_settings
  • getConsensusData() : ms_spectral_lib_peak
  • getConstantName() : ms_security_task
  • getConstrainSearchSchemaType() : ms_quant_method
  • getContent() : ms_quant_correction , ms_quant_numerator , ms_quant_unmodified
  • getContentSchemaType() : ms_quant_correction , ms_quant_numerator , ms_quant_unmodified
  • getCoreFromLogical() : ms_processors
  • getCorrectedMaxSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedMinSPPwidth() : ms_ms1quant_charge_state
  • getCorrectedSPPwidth() : ms_ms1quant_charge_state
  • getCorrection() : ms_quant_component
  • getCorrectionMatrix() : ms_ms1quant_match
  • getCorrectionSchemaType() : ms_quant_component
  • getCount() : ms_http_client_mime
  • getCoverage() : ms_protein
  • getCR() : ms_matrix
  • getCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • getCreatePipThreadBlockSize() : ms_mascotoptions
  • getCreatePipThreads() : ms_mascotoptions
  • getCreateSummaryProgress() : ms_mascotresults
  • getCronJob() : ms_cronoptions
  • getCronOptions() : ms_datfile
  • getCROSSLINKING() : ms_searchparams
  • getCrosslinkingMethod() : ms_mascotresfile , ms_peptidesummary
  • getCtermDelta() : ms_masses
  • getCterminalMass() : ms_masses
  • getCTerminusMass() : ms_modification
  • getCTermMass() : ms_searchparams
  • getCtermNeutralLoss() : ms_masses
  • getCurrentBytes() : ms_http_helper_progress
  • getCutterType() : ms_enzyme
  • getCytoBand() : ms_unigene_entry
  • getDatabase() : ms_databases , ms_processoroptions
  • getDatabaseName() : ms_crosslinking_accession
  • getDatabaseNameSchemaType() : ms_crosslinking_accession
  • getDatabases() : ms_datfile
  • getDatabaseType() : ms_mascotresfile
  • getDataSourceId() : ms_ms1quant_match
  • getDATAURL() : ms_searchparams
  • getDate() : ms_mascotresfile
  • getDateTimeModified() : ms_umod_modification
  • getDateTimeModifiedSchemaType() : ms_umod_modification
  • getDateTimePosted() : ms_umod_modification
  • getDateTimePostedSchemaType() : ms_umod_modification
  • getDatfile() : ms_distiller_data
  • getDB() : ms_searchparams , ms_protein , ms_protein_quant_ratio
  • getDBLevelTaxId() : ms_taxonomyrules
  • getDBType() : ms_databaseoptions
  • getDechargeFragmentPeaks() : ms_mascotoptions
  • getDECOY() : ms_searchparams
  • getDecoyTypeForDB() : ms_mascotresfile
  • getDecoyTypeNoEnzyme() : ms_mascotoptions
  • getDecoyTypeSpecific() : ms_mascotoptions
  • getDefaultDelimiter() : ms_customproperty
  • getDefaultMonitor() : ms_loggingmonitor
  • getDefaultNodeHomeDir() : ms_clusterparams
  • getDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • getDefaultNodeOS() : ms_clusterparams
  • getDefaultPasswordExpiryTime() : ms_security_options
  • getDefaultPort() : ms_clusterparams
  • getDefaultRule() : ms_taxonomyrules
  • getDefaultSchemaFileName() : ms_crosslinking_configfile , ms_umod_configfile
  • getDelimiterByNumber() : ms_customproperty
  • getDelta() : ms_peptide , ms_modification , ms_quant_localdef , ms_spectral_lib_peak , ms_umod_modification
  • getDeltaSchemaType() : ms_quant_localdef , ms_umod_modification
  • getDenominatorByName() : ms_quant_ratio
  • getDenominatorByNumber() : ms_quant_ratio
  • getDenominatorSchemaType() : ms_quant_ratio
  • getDescription() : ms_progress_info , ms_quant_method , ms_security_task , ms_umod_neutralloss , ms_xml_parameter , ms_crosslinking_method
  • getDescriptionLineSep() : ms_taxonomyrules
  • getDescriptionParseRuleIndex() : ms_databaseoptions
  • getDescriptionSchemaType() : ms_crosslinking_method , ms_crosslinking_parameter , ms_quant_method , ms_quant_parameter , ms_umod_neutralloss , ms_xml_parameter
  • getDiffsAsText() : ms_security_tasks
  • getDiscoveredErrTolModDeltas() : ms_mascotresults
  • getDiscoveredErrTolModNames() : ms_mascotresults
  • getDiscoveredLocalModDeltas() : ms_mascotresults
  • getDiscoveredLocalModNames() : ms_mascotresults
  • getDisplayIntensity() : ms_ms1quant_match
  • getDisplayNonSignificantMatches() : ms_mascotoptions
  • getDistillerProjectStreamName() : ms_distiller_data
  • getDistillerResfileTimestamp() : ms_distiller_data
  • getDistillerVersion() : ms_distiller_data
  • getDistinctPeptide() : ms_protein
  • getDistributor() : ms_license
  • getDoesNotPairWithByNumber() : ms_crosslinking_linker
  • getDoesNotPairWithSchemaType() : ms_crosslinking_linker
  • getDoThisRuleFirst() : ms_taxonomyrules
  • getDoubleParam() : ms_session
  • getDoubleParams() : ms_security_task
  • getElectronMass() : ms_searchparams , ms_masses
  • getElement() : ms_quant_composition , ms_quant_correction
  • getElementByName() : ms_umod_configfile
  • getElementByNumber() : ms_umod_configfile
  • getElementSchemaType() : ms_quant_composition , ms_quant_correction
  • getElemRef() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • getElemRefSchemaType() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • getElutionProfileCorrelationThreshold() : ms_quant_integration
  • getElutionProfileCorrelationThresholdSchemaType() : ms_quant_integration
  • getElutionTimeDelta() : ms_quant_integration
  • getElutionTimeDeltaSchemaType() : ms_quant_integration
  • getElutionTimeDeltaUnit() : ms_quant_integration
  • getElutionTimeDeltaUnitSchemaType() : ms_quant_integration
  • getElutionTimeShift() : ms_xic
  • getEmailAddress() : ms_session , ms_user
  • getEmailFromTextName() : ms_mascotoptions
  • getEmailFromUser() : ms_mascotoptions
  • getEmailPassword() : ms_mascotoptions
  • getEmailProfile() : ms_mascotoptions
  • getEmailService() : ms_mascotoptions
  • getEmailTimeOutPeriod() : ms_mascotoptions
  • getEncryptedPassword() : ms_user
  • getEnd() : ms_fragment
  • getEndDate() : ms_license
  • getEndIndex() : ms_xic
  • getEndScanId() : ms_xic
  • getEntry() : ms_wwwoptions
  • getEntryByName() : ms_taxonomyfile
  • getEntryByNumber() : ms_taxonomyfile
  • getEntryFromNumber() : ms_spectral_lib_file
  • getEntryFromNumberAsText() : ms_spectral_lib_file
  • getEnzyme() : ms_aahelper , ms_mascotresfile
  • getEnzymeByName() : ms_enzymefile
  • getEnzymeByNumber() : ms_enzymefile
  • getEnzymes() : ms_mascotfiles
  • getErrMessageEmailTo() : ms_mascotoptions
  • getError() : ms_distiller_search_status
  • getErrorCode() : ms_shapiro_wilk
  • getErrorHandler() : ms_errors
  • getErrorLevel() : ms_taxonomyrules
  • getErrorLogFile() : ms_mascotoptions
  • getErrorNumber() : ms_errs , ms_mascotresfile
  • getErrorRepeats() : ms_errs
  • getErrorSeverity() : ms_errs
  • getErrorString() : ms_errs , ms_mascotresfile
  • getErrorText() : ms_http_helper_return
  • getERRORTOLERANT() : ms_searchparams
  • getErrorType() : ms_http_helper_return
  • getErrTolMaxAccessions() : ms_mascotoptions
  • getErrTolModDelta() : ms_mascotresults
  • getErrTolModMasterNeutralLoss() : ms_mascotresults
  • getErrTolModMasterString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModName() : ms_mascotresults
  • getErrTolModNeutralLoss() : ms_mascotresults
  • getErrTolModPepNeutralLoss() : ms_mascotresults
  • getErrTolModPepString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModReqPepNeutralLoss() : ms_mascotresults
  • getErrTolModReqPepString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModSlaveNeutralLoss() : ms_mascotresults
  • getErrTolModSlaveString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolModString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getErrTolParentFilename() : ms_searchparams
  • getErrTolPeptide() : ms_distiller_data_search
  • getErrTolProbabilityThreshold() : ms_mascotresults
  • getExcludedKeys() : ms_protein_quant_ratio
  • getExcludeInternalLabelSchemaType() : ms_quant_multiplex
  • getExcludeIsobaricFragmentsSchemaType() : ms_quant_multiplex
  • getExcludeTaxonomy() : ms_taxonomychoice
  • getExclusion() : ms_quant_method
  • getExclusionSchemaType() : ms_quant_method
  • getExecAfterSearch() : ms_mascotoptions
  • getExecTime() : ms_mascotresfile
  • getExpectationValue() : ms_peptide
  • getExpress() : ms_unigene_entry
  • getFastaPath() : ms_mascotresfile
  • getFastaVer() : ms_mascotresfile
  • getFeatures() : ms_license
  • getFeatureTableLength() : ms_mascotoptions
  • getFeatureTableMinScore() : ms_mascotoptions
  • getFileIndex() : ms_quant_component
  • getFileIndexSchemaType() : ms_quant_component
  • getFilename() : ms_http_client_mime
  • getFILENAME() : ms_searchparams
  • getFileName() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_license , ms_mascotresfile , ms_masses , ms_modfile , ms_quant_configfile , ms_spectral_lib_entry , ms_spectral_lib_file , ms_taxonomyfile , ms_taxspeciesfiles , ms_taxnodesfiles , ms_umod_configfile
  • getFileOffset() : ms_unigene_entry
  • getFileOffsetFromKey() : ms_tinycdb
  • getFileSize() : ms_fileutilities
  • getFileTypeToSearch() : ms_parserule_plus
  • getFilters() : ms_crosslinking_method
  • getFiltersSchemaType() : ms_crosslinking_method
  • getFindFileTimeout() : ms_datfile
  • getFirstProtAppearedIn() : ms_peptide
  • getFirstSerie() : ms_fragmentationrules
  • getFirstSeries() : ms_fragmentationrules
  • getFirstXicScanId() : ms_ms1quant_match
  • getFitexy() : ms_ms1quant_match_ratio
  • getFixedMods() : ms_aahelper
  • getFixedModsDelta() : ms_searchparams
  • getFixedModsName() : ms_searchparams
  • getFixedModsNeutralLoss() : ms_searchparams
  • getFixedModsResidues() : ms_searchparams
  • getFlags() : ms_mascotresults , ms_mascotresults_params
  • getFlags2() : ms_mascotresults , ms_mascotresults_params
  • getFlagSchemaType() : ms_quant_neutralloss , ms_umod_neutralloss
  • getFORMAT() : ms_searchparams
  • getFormat() : ms_spectral_lib_file , ms_taxspeciesfiles , ms_taxnodesfiles
  • getFORMVER() : ms_searchparams
  • getFormVersion() : ms_mascotoptions
  • getFragmentByNumber() : ms_fragmentvector
  • getFragResidueMass() : ms_masses
  • getFragRulesFile() : ms_distiller_data
  • getFrame() : ms_protein
  • getFrequencies() : ms_mascotfiles
  • getFromUnimod() : ms_modification
  • getFullName() : ms_user , ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • getFullNameSchemaType() : ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • getFullUserName() : ms_session
  • getGencodeFile() : ms_taxonomyrules
  • getGene() : ms_unigene_entry
  • getGetSeqBlastAccession() : ms_mascotoptions
  • getGetSeqJobIdFile() : ms_mascotoptions
  • getGroup() : ms_security
  • getGroupFromID() : ms_security
  • getGrouping() : ms_protein
  • getGroupOfPoster() : ms_umod_modification
  • getGroupOfPosterSchemaType() : ms_umod_modification
  • getHavePeakList() : ms_distiller_sub_project
  • getHeaderComments() : ms_datfile
  • getHeaderLine() : ms_logger
  • getHeaderValue() : ms_http_helper
  • getHiddenSchemaType() : ms_umod_specificity
  • getHit() : ms_peptidesummary , ms_mascotresults , ms_ms1quant_match , ms_ms1quantitation
  • getHitNumber() : ms_protein
  • getHomologyThreshold() : ms_mascotresults
  • getHomologyThresholdForHistogram() : ms_mascotresults
  • getHostName() : ms_computeraddress , ms_wwwentry
  • getHT_IDFromLogical() : ms_processors
  • getHttpPassword() : ms_connection_settings
  • getHttpProtocol() : ms_connection_settings
  • getHttpStatusCode() : ms_http_helper_return
  • getHttpUsername() : ms_connection_settings
  • getHydrogenMass() : ms_searchparams , ms_masses
  • getHyperThreadedCPUsMask() : ms_processors
  • getHyperThreadingState() : ms_processors
  • getHypothesisPvalue() : ms_protein_quant_ratio
  • getICAT() : ms_searchparams
  • getICATFilter() : ms_mascotoptions
  • getICATHeavy() : ms_mascotoptions
  • getICATLight() : ms_mascotoptions
  • getICATQuantitationMethod() : ms_mascotoptions
  • getID() : ms_unigene_entry , ms_peptide_quant_key , ms_group , ms_session , ms_security_task , ms_user
  • getId() : ms_distiller_master_search , ms_distiller_search_status , ms_distiller_sub_project
  • getIdentifier() : ms_taxonomyrules
  • getIgnore() : ms_quant_localdef , ms_umod_modification
  • getIgnoredQPs() : ms_protein
  • getIgnoreDupeAccession() : ms_mascotoptions
  • getIgnoreIonsScoreBelow() : ms_mascotoptions , ms_mascotresults_params
  • getIgnoreMass() : ms_modification
  • getIgnoreSchemaType() : ms_quant_localdef , ms_umod_modification
  • getIncludeTaxonomy() : ms_taxonomychoice
  • getIndex() : ms_inputquery
  • getIndexFileName() : ms_tinycdb
  • getInetAddress() : ms_computeraddress
  • getINSTRUMENT() : ms_inputquery , ms_searchparams
  • getInstrumentByName() : ms_fragrulesfile
  • getInstrumentByNumber() : ms_fragrulesfile
  • getInstrumentName() : ms_fragrulesfile
  • getIntactLinks() : ms_peptide
  • getIntegraAppServerURL() : ms_security_options
  • getIntegraDatabaseName() : ms_security_options
  • getIntegraOracleServerName() : ms_security_options
  • getIntegration() : ms_quant_method
  • getIntegrationSchemaType() : ms_quant_method
  • getIntegraUsers() : ms_security
  • getIntensity() : ms_spectral_lib_peak
  • getIntensityNormalisationBase() : ms_ms2quantitation
  • getIntensitySigFigs() : ms_mascotoptions
  • getInterFileBasePath() : ms_mascotoptions
  • getInterFileRelPath() : ms_mascotoptions
  • getINTERMEDIATE() : ms_searchparams
  • getIntFromKey() : ms_tinycdb
  • getIntMax() : ms_inputquery
  • getIntMin() : ms_inputquery
  • getIntParam() : ms_session
  • getIonIntensityThreshold() : ms_quant_multiplex
  • getIonIntensityThresholdSchemaType() : ms_quant_multiplex
  • getIonMobility() : ms_inputquery
  • getIonsDecimalPlaces() : ms_mascotoptions
  • getIonSeries() : ms_quant_multiplex
  • getIonSeriesSchemaType() : ms_quant_multiplex
  • getIonsIntensity() : ms_peptide
  • getIonsScore() : ms_peptide , ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getIonsScoreCorrected() : ms_mascotresults
  • getIonsScoreHistogram() : ms_mascotresults
  • getIPAddress() : ms_session
  • getIPCLogfile() : ms_clusterparams
  • getIPCLogging() : ms_clusterparams
  • getIPCTimeout() : ms_clusterparams
  • getIsDatabaseActive() : ms_http_client
  • getIsFromErrorTolerant() : ms_peptide
  • getIsFromLibrary() : ms_peptide
  • getIsolatedPrecursorSchemaType() : ms_quant_quality
  • getIsolatedPrecursorThreshold() : ms_quant_quality
  • getIsolatedPrecursorThresholdSchemaType() : ms_quant_quality
  • getIsotope() : ms_quant_component
  • getIsotopeSchemaType() : ms_quant_component
  • getIsPermitted() : ms_http_client_session
  • getIsSecurityEnabled() : ms_http_client
  • getIsWebAuthenticationEnabled() : ms_http_client
  • getIsXmlUploadedList() : ms_http_client_session
  • getIT_MODS() : ms_inputquery , ms_searchparams
  • getItemFromId() : ms_obofile
  • getITOL() : ms_searchparams
  • getITOLU() : ms_searchparams
  • getJobNumber() : ms_mascotresfile
  • getKeepAlive() : ms_mascotresfile
  • getKey() : ms_ms1quant_match , ms_peptide_quant_ratio
  • getLabel() : ms_fragment
  • getLabelFree() : ms_ms1quantitation
  • getLabelFreeVarMods() : ms_ms1quant_match
  • getLastAccessed() : ms_session
  • getLastError() : ms_errs , ms_errors , ms_mascotresfile
  • getLastErrorString() : ms_errs , ms_errors , ms_mascotresfile
  • getLastModificationTime() : ms_fileutilities
  • getLastQueryAscFile() : ms_mascotoptions
  • getLastSerie() : ms_fragmentationrules
  • getLastSeries() : ms_fragmentationrules
  • getLastXicScanId() : ms_ms1quant_match
  • getLessThanMinPepLen() : ms_peptide
  • getLIBRARY_SEARCH() : ms_searchparams
  • getLibraryEntryId() : ms_peptidesummary
  • getLibraryModDelta() : ms_searchparams
  • getLibraryModName() : ms_searchparams
  • getLibraryModString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getLibraryName() : ms_libraryoptions
  • getLibraryOptions() : ms_datfile
  • getLICENSE() : ms_searchparams
  • getLicensee() : ms_license
  • getLicenseString() : ms_license
  • getLicenseVersion() : ms_license
  • getLine() : ms_spectral_lib_entry
  • getLinkerByNumber() : ms_crosslinking_linkers
  • getLinkerMass() : ms_linker_site
  • getLinkers() : ms_crosslinking_method
  • getLinkerSchemaType() : ms_crosslinking_linkers
  • getLinkersSchemaType() : ms_crosslinking_method
  • getLinkFrom() : ms_linker_site
  • getLinkTo() : ms_linker_site
  • getLoaded() : ms_distiller_data_search
  • getLoadedSearchIndex() : ms_distiller_data
  • getLoadUnassigned() : ms_distiller_data_search
  • getLocalDefinition() : ms_quant_modgroup
  • getLocalDefinitionSchemaType() : ms_quant_modgroup
  • getLocalModifications() : ms_quant_method
  • getLocalModsNlStr() : ms_peptide
  • getLocalModsStr() : ms_peptide
  • getLocalVarModName() : ms_inputquery
  • getLocus() : ms_inputquery
  • getLocusLink() : ms_unigene_entry
  • getLogEventsHandler() : ms_loggingmonitor
  • getLogFilename() : ms_file_logger
  • getLogFileName() : ms_cronoptions , ms_security_options
  • getLoggingFileName() : ms_errs
  • getLoggingLevel() : ms_cronoptions , ms_errs , ms_log , ms_security_options
  • getLogMask() : ms_loggingmonitor
  • getLogoImageFile() : ms_mascotoptions
  • getLongestPeptideLen() : ms_protein
  • getLongestSigPeptideLen() : ms_protein
  • getLongParam() : ms_session
  • getLongParams() : ms_security_task
  • getLoopLinks() : ms_peptide
  • getMailTempFile() : ms_mascotoptions
  • getMailTransport() : ms_mascotoptions
  • getMajorVersion() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • getMascNodeCtrlFile() : ms_mascotoptions
  • getMascotCmdLine() : ms_mascotoptions
  • getMascotControlFile() : ms_mascotoptions
  • getMascotFileProcessingThreads() : ms_mascotoptions
  • getMascotFiles() : ms_datfile
  • getMascotJobIdFile() : ms_mascotoptions
  • getMascotMessage() : ms_mascotoptions
  • getMascotNodeRebootScript() : ms_clusterparams
  • getMascotNodeScript() : ms_clusterparams
  • getMascotOptions() : ms_datfile
  • getMascotSearchURL() : ms_distiller_data_search
  • getMascotSecurityOptions() : ms_security
  • getMascotServerURL() : ms_distiller_data_search
  • getMascotVer() : ms_mascotresfile
  • getMass() : ms_fragment
  • getMASS() : ms_searchparams
  • getMassDecimalPlaces() : ms_mascotoptions
  • getMassDelta() : ms_quant_integration
  • getMassDeltaSchemaType() : ms_quant_integration
  • getMassDeltaUnit() : ms_quant_integration
  • getMassDeltaUnitSchemaType() : ms_quant_integration
  • getMasses() : ms_aahelper , ms_mascotresfile , ms_protein
  • getMassesWithinTolerance() : ms_fragmentvector
  • getMassFile() : ms_modification , ms_modfile
  • getMassMax() : ms_inputquery
  • getMassMin() : ms_inputquery
  • getMassType() : ms_searchparams
  • getMasterComputer() : ms_clusterparams
  • getMasterProjectStreamName() : ms_distiller_master_project
  • getMatch() : ms_ms1quantitation
  • getMatchedFraction() : ms_ms1quant_charge_state
  • getMatchedIonIntensity() : ms_fragment
  • getMatchedIonMass() : ms_fragment
  • getMatchedRho() : ms_ms1quant_charge_state , ms_quant_integration
  • getMatchedRhoSchemaType() : ms_quant_integration
  • getMatchForHit() : ms_ms1quantitation
  • getMaxAlignment() : ms_ms1quant_charge_state
  • getMaxConcurrentSearches() : ms_mascotoptions
  • getMaxDatabases() : ms_mascotoptions
  • getMaxDescriptionLen() : ms_mascotoptions
  • getMaxEtagMassDelta() : ms_mascotoptions
  • getMaxEtVarMods() : ms_mascotoptions
  • getMaxHitsToReport() : ms_mascotresults_params
  • getMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • getMaxInternalMass() : ms_fragmentationrules , ms_inputquery , ms_searchparams
  • getMaxNumOfReportBuilderColumnArrangements() : ms_mascotoptions
  • getMaxNumPeptides() : ms_mascotoptions
  • getMaxPepModArrangements() : ms_mascotoptions
  • getMaxPepNumModifiedSites() : ms_mascotoptions
  • getMaxPepNumVarMods() : ms_mascotoptions
  • getMaxPeptideIdentityThreshold() : ms_mascotresults
  • getMaxQueries() : ms_mascotoptions
  • getMaxRankValue() : ms_mascotresults
  • getMaxSearchesPerUser() : ms_mascotoptions
  • getMaxSequenceLen() : ms_mascotoptions
  • getMaxTaxonomyRules() : ms_datfile
  • getMaxVarMods() : ms_mascotoptions
  • getMD5Sum() : ms_fileutilities
  • getMemberNumber() : ms_protein
  • getMessageSource() : ms_log
  • getMethod() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • getMethodByName() : ms_crosslinking_configfile , ms_quant_configfile
  • getMethodByNumber() : ms_crosslinking_configfile , ms_quant_configfile
  • getMethodSchemaType() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • getMinEtagMassDelta() : ms_mascotoptions
  • getMinimumA1() : ms_quant_quality
  • getMinimumA1SchemaType() : ms_quant_quality
  • getMinimumPasswordLength() : ms_security_options
  • getMinInternalMass() : ms_fragmentationrules , ms_inputquery , ms_searchparams
  • getMinIonPairs() : ms_quant_multiplex
  • getMinIonPairsSchemaType() : ms_quant_multiplex
  • getMinNumPeptides() : ms_quant_method , ms_quantitation
  • getMinNumPeptidesSchemaType() : ms_quant_method
  • getMinNumSigUniqueSequences() : ms_mascotresults_params
  • getMinorVersion() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • getMinPepLenInPepSummary() : ms_distiller_data_search , ms_mascotoptions , ms_mascotresults
  • getMinPepLenInPeptideSummary() : ms_mascotresults_params
  • getMinPepLenInSearch() : ms_mascotoptions
  • getMinPrecursorCharge() : ms_quant_quality
  • getMinPrecursorChargeSchemaType() : ms_quant_quality
  • getMinProbability() : ms_mascotresults_params
  • getMinProbabilityForSLScore() : ms_peptidesummary
  • getMiscNotes() : ms_umod_modification , ms_umod_specificity
  • getMiscNotesSchemaType() : ms_umod_modification , ms_umod_specificity
  • getMissed() : ms_aahelper
  • getMissedCleavages() : ms_peptide
  • getModBrickByName() : ms_umod_configfile
  • getModBrickByNumber() : ms_umod_configfile
  • getMode() : ms_quant_modgroup
  • getModeSchemaType() : ms_quant_modgroup
  • getModFile() : ms_quant_modgroup
  • getModFileList() : ms_umod_configfile , ms_umod_modification
  • getModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • getModFileNameSchemaType() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • getModFileSchemaType() : ms_quant_modgroup
  • getModificationByName() : ms_modvector , ms_modfile , ms_umod_configfile
  • getModificationByNumber() : ms_modvector , ms_modfile , ms_umod_configfile
  • getModificationGroupByName() : ms_quant_component , ms_quant_method
  • getModificationGroupByNumber() : ms_quant_component , ms_quant_method
  • getModificationGroupSchemaType() : ms_quant_component , ms_quant_method
  • getModifications() : ms_mascotfiles , ms_quant_satellite
  • getModificationsSchemaType() : ms_quant_satellite
  • getModificationType() : ms_modification
  • getModifiedResidue() : ms_modification
  • getMODS() : ms_searchparams
  • getMods() : ms_spectral_lib_entry
  • getModsFromNumber() : ms_spectral_lib_file
  • getMonitorEmailCheckFreq() : ms_mascotoptions
  • getMonitorLogFile() : ms_mascotoptions
  • getMonitorPidFile() : ms_mascotoptions
  • getMonitorTestTimeout() : ms_mascotoptions
  • getMonoisotopic() : ms_quant_moverz
  • getMonoisotopicSchemaType() : ms_quant_moverz
  • getMonoLinkByNumber() : ms_crosslinking_linker
  • getMonoLinkModification() : ms_mascotresfile
  • getMonoLinkSchemaType() : ms_crosslinking_linker
  • getMonoLinkStr() : ms_peptide
  • getMonoLinkTitle() : ms_modification
  • getMonoMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getMonoMassAsNumber() : ms_umod_element
  • getMonoMassSchemaType() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • getMoverz() : ms_ms1quant_match_component , ms_quant_component
  • getMoverzSchemaType() : ms_quant_component
  • getMrCalc() : ms_peptide
  • getMrExperimental() : ms_peptide
  • getMSParserVersion() : ms_mascotresfile
  • getMudpit() : ms_mascotoptions
  • getMudpitSwitch() : ms_mascotoptions
  • getMULTI_SITE_MODS() : ms_searchparams
  • getMultiFileQueryNumber() : ms_mascotresfile
  • getMultiplex() : ms_quant_protocol
  • getMultiplexSchemaType() : ms_quant_protocol
  • getMultithreadedName() : ms_processors
  • getMW() : ms_spectral_lib_entry
  • getMz() : ms_spectral_lib_peak
  • getName() : ms_crosslinking_method , ms_databaseoptions , ms_distiller_sub_project , ms_http_client_mime , ms_dbprocessors , ms_quant_component , ms_quant_method , ms_quant_modgroup , ms_quant_numerator , ms_quant_ratio , ms_group , ms_user , ms_spectral_lib_entry , ms_wwwentry , ms_xml_parameter
  • getNameOfDB() : ms_parserule_plus
  • getNameSchemaType() : ms_crosslinking_method , ms_crosslinking_parameter , ms_quant_component , ms_quant_method , ms_quant_modgroup , ms_quant_numerator , ms_quant_parameter , ms_quant_ratio , ms_xml_parameter
  • getNeutralLoss() : ms_fragment , ms_modification , ms_quant_specificity , ms_umod_specificity
  • getNeutralLossRequired() : ms_modification
  • getNeutralLossSchemaType() : ms_quant_specificity , ms_umod_specificity
  • getNew() : ms_quant_isotope
  • getNewSchemaType() : ms_quant_isotope
  • getNextFamilyProtein() : ms_mascotresults
  • getNextPeptide() : ms_aahelper
  • getNextSimilarProtein() : ms_mascotresults
  • getNextSimilarProteinOf() : ms_mascotresults
  • getNextSubsetProtein() : ms_mascotresults
  • getNextSubsetProteinOf() : ms_mascotresults
  • getNitrogenMass() : ms_searchparams , ms_masses
  • getNoBreakDescLineIf() : ms_taxonomyrules
  • getNodeListFile() : ms_mascotfiles
  • getNodeSequenceDatabaseDir() : ms_clusterparams
  • getNodesFile() : ms_taxonomyrules
  • getNonMudpitScore() : ms_protein
  • getNoResultsScript() : ms_mascotoptions
  • getNormalisation() : ms_quant_method
  • getNormalisationSchemaType() : ms_quant_method
  • getNormalityPvalue() : ms_protein_quant_ratio
  • getNotes() : ms_security_task
  • getNtermDelta() : ms_masses
  • getNterminalMass() : ms_masses
  • getNTerminusMass() : ms_modification
  • getNTermMass() : ms_searchparams
  • getNtermNeutralLoss() : ms_masses
  • getNTIUserGroup() : ms_mascotoptions
  • getNTMonitorGroup() : ms_mascotoptions
  • getNum13C() : ms_peptide
  • getNumAccessions() : ms_unigene_entry
  • getNumAvailableToProcess() : ms_processors
  • getNumber() : ms_quant_element , ms_umod_elemref
  • getNumberOfAccessionDBTypes() : ms_peptidesummary
  • getNumberOfAccessions() : ms_crosslinking_accessions
  • getNumberOfAltNames() : ms_umod_modification
  • getNumberOfAminoAcids() : ms_umod_configfile
  • getNumberOfBuckets() : ms_ms1quant_charge_state
  • getNumberOfComponents() : ms_quant_method
  • getNumberOfCorrections() : ms_quant_component
  • getNumberOfCronJobs() : ms_cronoptions
  • getNumberOfCutters() : ms_enzyme
  • getNumberOfDatabases() : ms_databases , ms_searchparams , ms_processoroptions
  • getNumberOfDenominators() : ms_quant_ratio
  • getNumberOfDoesNotPairWiths() : ms_crosslinking_linker
  • getNumberOfElements() : ms_quant_composition , ms_umod_configfile
  • getNumberOfElemRefs() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • getNumberOfEntries() : ms_obofile , ms_taxonomyfile , ms_wwwoptions
  • getNumberOfEnzymes() : ms_enzymefile
  • getNumberOfErrors() : ms_mascotresfile , ms_errs
  • getNumberOfExcludeTaxonomies() : ms_taxonomychoice
  • getNumberOfExclusions() : ms_quant_method
  • getNumberOfFamilyAccessionDBTypes() : ms_peptidesummary
  • getNumberOfFamilyMembers() : ms_mascotresults
  • getNumberOfFragments() : ms_fragmentvector
  • getNumberOfGencodeFiles() : ms_taxonomyrules
  • getNumberOfHits() : ms_mascotresults
  • getNumberOfIgnoreDupeAccessions() : ms_mascotoptions
  • getNumberOfIgnoreMasses() : ms_modification
  • getNumberOfIgnores() : ms_quant_localdef , ms_umod_modification
  • getNumberOfIncludeTaxonomies() : ms_taxonomychoice
  • getNumberOfInstruments() : ms_fragrulesfile
  • getNumberOfIonSeries() : ms_quant_multiplex
  • getNumberOfIsotopes() : ms_quant_component
  • getNumberOfLibraries() : ms_libraryoptions
  • getNumberOfLibraryMods() : ms_searchparams
  • getNumberOfLinkedPeptides() : ms_peptide
  • getNumberOfLinkers() : ms_crosslinking_linkers
  • getNumberOfLocalDefinitions() : ms_quant_modgroup
  • getNumberOfLocalVarMods() : ms_inputquery
  • getNumberOfMethods() : ms_crosslinking_configfile , ms_quant_configfile
  • getNumberOfModBricks() : ms_umod_configfile
  • getNumberOfModFiles() : ms_quant_modgroup
  • getNumberOfModificationGroups() : ms_quant_component , ms_quant_method
  • getNumberOfModifications() : ms_modvector , ms_modfile , ms_umod_configfile
  • getNumberOfModifiedResidues() : ms_modification
  • getNumberOfMonoLinks() : ms_crosslinking_linker
  • getNumberOfNeutralLosses() : ms_quant_specificity , ms_umod_specificity
  • getNumberOfNoBreakDescLineIf() : ms_taxonomyrules
  • getNumberOfNodesFiles() : ms_taxonomyrules
  • getNumberOfNumerators() : ms_quant_ratio
  • getNumberOfParameters() : ms_xml_parameters , ms_crosslinking_parameters , ms_quant_parameters
  • getNumberOfParseRules() : ms_parseoptions
  • getNumberOfPeaks() : ms_inputquery
  • getNumberOfPepNeutralLosses() : ms_umod_specificity , ms_quant_specificity
  • getNumberOfPeptides() : ms_quant_normalisation_peptides
  • getNumberOfPerDbSrcRules() : ms_taxonomyrules
  • getNumberOfPrefixRemoves() : ms_taxonomyrules
  • getNumberOfProcessors() : ms_processoroptions
  • getNumberOfProperties() : ms_customproperty
  • getNumberOfProteins() : ms_quant_normalisation_proteins
  • getNumberOfReportNumberChoices() : ms_mascotoptions
  • getNumberOfReportRatios() : ms_quant_method
  • getNumberOfResfiles() : ms_mascotresfile
  • getNumberOfSeqs() : ms_quant_method
  • getNumberOfSpeciesFiles() : ms_taxonomyrules
  • getNumberOfSpecificities() : ms_quant_localdef , ms_umod_modification
  • getNumberOfStrFiles() : ms_taxonomyrules
  • getNumberOfSubClusters() : ms_clusterparams
  • getNumberOfSubtasks() : ms_progress_info
  • getNumberOfSuffixRemoves() : ms_taxonomyrules
  • getNumberOfTargetFDRPercentages() : ms_mascotoptions
  • getNumberOfTasks() : ms_security_tasks
  • getNumberOfThreads() : ms_databaseoptions , ms_dbprocessors
  • getNumberOfUnassigned() : ms_mascotresults
  • getNumberOfUnmodified() : ms_quant_modgroup
  • getNumberOfXrefs() : ms_umod_modification
  • getNumberSchemaType() : ms_quant_element , ms_umod_elemref
  • getNumComponents() : ms_ms1quant_match , ms_protein
  • getNumCores() : ms_processors
  • getNumDecoyHitsAboveHomology() : ms_mascotresults
  • getNumDecoyHitsAboveIdentity() : ms_mascotresults
  • getNumDiscoveredErrTolMods() : ms_mascotresults
  • getNumDiscoveredFixedMods() : ms_mascotresults
  • getNumDiscoveredIntactLinks() : ms_mascotresults
  • getNumDiscoveredLibraryMods() : ms_mascotresults
  • getNumDiscoveredLocalMods() : ms_mascotresults
  • getNumDiscoveredNonSpecCleavage() : ms_mascotresults
  • getNumDiscoveredVariableMods() : ms_mascotresults
  • getNumDisplayPeptides() : ms_protein
  • getNumDistinctPeptideRepeats() : ms_protein
  • getNumDistinctPeptides() : ms_protein
  • getNumEntries() : ms_spectral_lib_file
  • getNumeratorByName() : ms_quant_ratio
  • getNumeratorByNumber() : ms_quant_ratio
  • getNumeratorSchemaType() : ms_quant_ratio
  • getNumEtSeqsSearched() : ms_mascotresfile
  • getNumGroups() : ms_ms1quantitation
  • getNumHits() : ms_mascotresfile , ms_ms1quant_match , ms_ms1quantitation
  • getNumHitsAboveHomology() : ms_mascotresults
  • getNumHitsAboveIdentity() : ms_mascotresults
  • getNumIonsMatched() : ms_peptide
  • getNumLibraryEntries() : ms_mascotresfile
  • getNumLogEventsHandlers() : ms_loggingmonitor
  • getNumLogicalPerPhysical() : ms_processors
  • getNumMatches() : ms_ms1quantitation
  • getNumMatchesForGroup() : ms_ms1quantitation
  • getNumMatchesForHit() : ms_ms1quantitation
  • getNumObservedForEmPAI() : ms_protein
  • getNumOnSystem() : ms_processors
  • getNumPeaks() : ms_spectral_lib_peak_list , ms_spectral_lib_entry
  • getNumPeptideRatios() : ms_ms1quant_match
  • getNumPeptides() : ms_quant_average , ms_protein , ms_ms1quant_match_component
  • getNumPeptidesSchemaType() : ms_quant_average
  • getNumPeptideStatuses() : ms_ms1quantitation
  • getNumPhysicalOnSystem() : ms_processors
  • getNumPmfQueriesUsed() : ms_proteinsummary
  • getNumPoints() : ms_xic
  • getNumProcessorGroups() : ms_processors
  • getNumProcessorsLicensed() : ms_license
  • getNumProteinFamilies() : ms_ms1quantitation
  • getNumProteins() : ms_peptide
  • getNumQueries() : ms_mascotresfile
  • getNumRanges() : ms_ms1quant_match_component
  • getNumResidues() : ms_spectral_lib_file , ms_mascotresfile
  • getNumSearches() : ms_distiller_master_project , ms_distiller_search_status_list
  • getNumSeqs() : ms_mascotresfile
  • getNumSeqsAfterTax() : ms_mascotresfile
  • getNumSubprojects() : ms_distiller_master_project
  • getNumSubsearches() : ms_distiller_master_search
  • getNumUsed() : ms_inputquery
  • getNumVals() : ms_inputquery
  • getObserved() : ms_peptide
  • getObservedCharge() : ms_mascotresfile
  • getObservedIntensity() : ms_mascotresfile
  • getObservedMass() : ms_mascotresfile
  • getObservedMrValue() : ms_mascotresfile
  • getOld() : ms_quant_isotope
  • getOldSchemaType() : ms_quant_isotope
  • getOpaqueString() : ms_peptide_quant_key
  • getOpaqueStringAndID() : ms_peptide_quant_key
  • getOsName() : ms_http_client
  • getOutlierKeys() : ms_protein_quant_ratio
  • getOutliers() : ms_quant_method
  • getOutliersSchemaType() : ms_quant_method
  • getOVERVIEW() : ms_searchparams
  • getOxygenMass() : ms_searchparams , ms_masses
  • getPairsWith() : ms_modification , ms_umod_neutralloss
  • getPairsWithSchemaType() : ms_umod_neutralloss
  • getParameterByName() : ms_crosslinking_parameters , ms_quant_parameters
  • getParameterByNumber() : ms_crosslinking_parameters , ms_quant_parameters
  • getParameterSchemaType() : ms_crosslinking_filters , ms_crosslinking_parameters , ms_crosslinking_scope , ms_quant_parameters , ms_xml_parameters , ms_crosslinking_settings
  • getParams() : ms_session
  • getParent() : ms_taxonomytree
  • getParseOptions() : ms_datfile
  • getParseRule() : ms_parseoptions , ms_wwwentry
  • getPasswordExpiry() : ms_user
  • getPath() : ms_databaseoptions , ms_wwwentry
  • getPeak() : ms_spectral_lib_peak_list
  • getPeakAnnotationLevel() : ms_spectral_lib_peak_list
  • getPeakEndIndex() : ms_xic
  • getPeakEndScanId() : ms_xic
  • getPeakIntensity() : ms_inputquery
  • getPeakList() : ms_spectral_lib_entry , ms_inputquery
  • getPeakListChecksum() : ms_spectral_lib_entry
  • getPeakListObject() : ms_spectral_lib_entry
  • getPeakMass() : ms_inputquery
  • getPeakStartIndex() : ms_xic
  • getPeakStartScanId() : ms_xic
  • getPeakState() : ms_xic
  • getPeaksUsedFromIons1() : ms_peptide
  • getPeaksUsedFromIons2() : ms_peptide
  • getPeaksUsedFromIons3() : ms_peptide
  • getPEP_ISOTOPE_ERROR() : ms_searchparams
  • getPepEnd() : ms_aahelper
  • getPepIdentThreshProtected() : ms_mascotresults
  • getPepNeutralLoss() : ms_modification , ms_quant_specificity , ms_umod_specificity
  • getPepNeutralLossSchemaType() : ms_quant_specificity , ms_umod_specificity
  • getPepNumber() : ms_protein
  • getPepSearchTool() : ms_mascotoptions
  • getPepSearchToolCommandLine() : ms_mascotoptions
  • getPepStart() : ms_aahelper
  • getPepsWithSameScore() : ms_peptidesummary , ms_mascotresults , ms_proteinsummary
  • getPepThresholdType() : ms_quant_quality
  • getPepThresholdTypeSchemaType() : ms_quant_quality
  • getPepThresholdValue() : ms_quant_quality
  • getPepThresholdValueSchemaType() : ms_quant_quality
  • getPeptide() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults , ms_quant_normalisation_peptides , ms_proteinsummary
  • getPeptideAmbiguityRanks() : ms_peptidesummary
  • getPeptideComponentID() : ms_protein
  • getPeptideDuplicate() : ms_protein
  • getPeptideEnd() : ms_protein
  • getPeptideExpectationValue() : ms_mascotresults
  • getPeptideFrame() : ms_protein
  • getPeptideIdentityThreshold() : ms_mascotresults
  • getPeptideIonsScore() : ms_protein
  • getPeptideIsBold() : ms_protein
  • getPeptideKey() : ms_ms1quant_match_component
  • getPeptideLength() : ms_peptide
  • getPeptideMultiplicity() : ms_protein
  • getPeptideP() : ms_protein
  • getPeptideQuantKeys() : ms_quantitation
  • getPeptideQuery() : ms_protein
  • getPeptideRatio() : ms_customquantitation , ms_ms1quant_match , ms_ms2quantitation , ms_quantitation
  • getPeptideRatioNormalisationBase() : ms_quantitation
  • getPeptideResidueAfter() : ms_protein
  • getPeptideResidueBefore() : ms_protein
  • getPeptides() : ms_quant_normalisation
  • getPeptideSchemaType() : ms_quant_normalisation_peptides
  • getPeptideShowCheckbox() : ms_protein
  • getPeptidesSchemaType() : ms_quant_normalisation
  • getPeptideStart() : ms_protein
  • getPeptideStatus() : ms_ms1quantitation
  • getPeptideStr() : ms_peptide
  • getPeptideString() : ms_ms1quant_match
  • getPeptideSubstring() : ms_fragment
  • getPeptideSummaryCacheStreamName() : ms_distiller_search_status
  • getPeptideSummaryFlags() : ms_distiller_data_search
  • getPeptideSummaryFlags2() : ms_distiller_data_search
  • getPeptideThreshold() : ms_mascotresults
  • getPepTol() : ms_inputquery
  • getPepTolString() : ms_inputquery
  • getPepTolUnits() : ms_inputquery
  • getPercolator() : ms_distiller_data_search
  • getPercolatorExeFlags() : ms_mascotoptions
  • getPercolatorFeatures() : ms_mascotoptions
  • getPercolatorFileNames() : ms_mascotresfile
  • getPercolatorMinQueries() : ms_mascotoptions
  • getPercolatorMinSequences() : ms_mascotoptions
  • getPercolatorScores() : ms_peptide
  • getPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • getPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • getPercolatorUseProteins() : ms_distiller_data_search
  • getPercolatorUseRT() : ms_distiller_data_search
  • getPerDbSrcRule() : ms_taxonomyrules
  • getPerfectObservedMatrix() : ms_ms1quant_match
  • getPermittedTasks() : ms_group , ms_session
  • getPermittedTasksForUser() : ms_security
  • getPFA() : ms_searchparams
  • getPhysicalFromLogical() : ms_processors
  • getPoint() : ms_xic
  • getPort() : ms_computeraddress
  • getPortNumber() : ms_wwwentry
  • getPosition() : ms_quant_specificity , ms_quant_unmodified , ms_umod_specificity
  • getPositionSchemaType() : ms_quant_specificity , ms_quant_unmodified , ms_umod_specificity
  • getPreceedingComments() : ms_customproperty , ms_databaseoptions
  • getPRECURSOR() : ms_searchparams
  • getPrecursor() : ms_quant_protocol
  • getPrecursorChargeFromNumber() : ms_spectral_lib_file
  • getPrecursorCutOutLowerLimit() : ms_mascotoptions
  • getPrecursorCutOutUpperLimit() : ms_mascotoptions
  • getPrecursorMZ() : ms_spectral_lib_entry
  • getPrecursorMZFromNumber() : ms_spectral_lib_file
  • getPrecursorRange() : ms_quant_integration
  • getPrecursorRangeSchemaType() : ms_quant_integration
  • getPrecursorSchemaType() : ms_quant_protocol
  • getPredictionMatrix() : ms_ms1quant_match
  • getPrefixRemove() : ms_taxonomyrules
  • getPrettyRank() : ms_peptide
  • getPrimaryNlStr() : ms_peptide
  • getProbabilityThreshold() : ms_mascotresults
  • getProbFromScore() : ms_mascotresults
  • getProbOfPepBeingRandomMatch() : ms_mascotresults
  • getProbOfProteinBeingRandomMatch() : ms_mascotresults
  • getProcessingOptions() : ms_quant_integration
  • getProcessingOptionsSchemaType() : ms_quant_integration
  • getProcessor() : ms_processoroptions
  • getProcessorName() : ms_processors
  • getProcessors() : ms_datfile
  • getProgress() : ms_progress_info
  • getProgressInfo() : ms_mascotresfile , ms_quantitation
  • getProjectRelativePath() : ms_distiller_sub_project
  • getPropertyName() : ms_customproperty
  • getProportion() : ms_http_helper_progress
  • getPropValStringByName() : ms_customproperty
  • getPropValStringByNumber() : ms_customproperty
  • getProtein() : ms_mascotresults , ms_peptide , ms_peptidesummary , ms_quant_normalisation_proteins
  • getProteinDescription() : ms_mascotresults
  • getProteinEmPAI() : ms_peptidesummary , ms_mascotresults
  • getProteinExpectationValue() : ms_mascotresults
  • getProteinFamilySwitch() : ms_mascotoptions
  • getProteinGrouping() : ms_distiller_data_search
  • getProteinMass() : ms_mascotresults
  • getProteinRatio() : ms_ms2quantitation , ms_quantitation , ms_customquantitation , ms_ms1quantitation , ms_quantitation , ms_ms2quantitation , ms_ms1quantitation
  • getProteinRatioSample() : ms_quantitation
  • getProteinRatioType() : ms_quant_method
  • getProteinRatioTypeSchemaType() : ms_quant_method
  • getProteins() : ms_quant_normalisation , ms_peptide
  • getProteinSchemaType() : ms_quant_normalisation_proteins
  • getProteinScoreCutoff() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getProteinScoreForHistogram() : ms_mascotresults
  • getProteinsInResultsFile() : ms_mascotoptions
  • getProteinsSchemaType() : ms_quant_normalisation
  • getProteinSummaryHit() : ms_protein
  • getProteinsWithThisPepMatch() : ms_mascotresults , ms_peptidesummary , ms_proteinsummary
  • getProteinTaxonomyIDs() : ms_mascotresults
  • getProteinThreshold() : ms_mascotresults
  • getProtocol() : ms_quant_method
  • getProtocolSchemaType() : ms_quant_method
  • getProtScoreType() : ms_quant_method
  • getProtScoreTypeSchemaType() : ms_quant_method
  • getProxyConfig() : ms_http_helper
  • getProxyPassword() : ms_mascotoptions , ms_connection_settings
  • getProxyServer() : ms_connection_settings , ms_mascotoptions
  • getProxyServerType() : ms_connection_settings
  • getProxyType() : ms_mascotoptions
  • getProxyUserAndPassword() : ms_connection_settings
  • getProxyUsername() : ms_mascotoptions , ms_connection_settings
  • getPValue() : ms_shapiro_wilk
  • getQ() : ms_fitexy_result
  • getQmatch() : ms_mascotresults , ms_spectral_lib_file , ms_mascotresults
  • getQuality() : ms_ms1quant_match_ratio , ms_quant_method
  • getQualitySchemaType() : ms_quant_method
  • getQuant() : ms_distiller_data
  • getQuantCount() : ms_distiller_data
  • getQuantForSearch() : ms_distiller_data
  • getQuantitation() : ms_mascotresfile
  • getQUANTITATION() : ms_searchparams
  • getQuantitationComponentForPeptide() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getQuantitationDatasources() : ms_ms1quantitation
  • getQuantitationMethod() : ms_mascotresfile , ms_quantitation
  • getQuantMethod() : ms_peptidesummary , ms_distiller_data
  • getQuantMethodXml() : ms_distiller_data_search
  • getQUE() : ms_searchparams
  • getQuery() : ms_peptide , ms_ms1quant_peptide_status
  • getQueryAndRank() : ms_peptide_quant_key
  • getQueryList() : ms_peptidesummary
  • getQuerySectionValue() : ms_mascotresfile
  • getQuerySectionValueDouble() : ms_mascotresfile
  • getQuerySectionValueInt() : ms_mascotresfile
  • getQuerySectionValueStr() : ms_mascotresfile
  • getQuickRefSearch() : ms_taxonomyrules
  • getRange() : ms_ms1quant_match_component
  • getRank() : ms_ms1quant_peptide_status , ms_peptide
  • getRatioName() : ms_protein_quant_ratio , ms_peptide_quant_ratio , ms_ms1quant_match_ratio
  • getRawAbsolutePath() : ms_distiller_sub_project
  • getRawfile() : ms_inputquery
  • getRawFormat() : ms_distiller_sub_project
  • getRawRelativePath() : ms_distiller_sub_project
  • getRawSampleNumber() : ms_distiller_sub_project
  • getRawScans() : ms_inputquery
  • getRC() : ms_matrix
  • getReadableLabelFreeVarMods() : ms_ms1quant_match
  • getReadableVarMods() : ms_ms1quantitation , ms_mascotresults
  • getReadableVarModsConcise() : ms_ms1quantitation
  • getRecordID() : ms_umod_modification
  • getRecordIDSchemaType() : ms_umod_modification
  • getRedirectPolicy() : ms_connection_settings
  • getReferenceAccession() : ms_quant_average
  • getReferenceAccessionSchemaType() : ms_quant_average
  • getReferenceAmount() : ms_quant_average
  • getReferenceAmountSchemaType() : ms_quant_average
  • getReferenceDatabase() : ms_quant_average
  • getReferenceDatabaseNumberOfSL() : ms_mascotresfile
  • getReferenceDatabaseSchemaType() : ms_quant_average
  • getReferenceFasta() : ms_libraryoptions
  • getReferenceFastaTaxonomyTitle() : ms_libraryoptions
  • getReferenceHitId() : ms_ms1quant_average_results
  • getReferenceMemberNumber() : ms_ms1quant_average_results
  • getRegionEndIndex() : ms_xic
  • getRegionEndScanId() : ms_xic
  • getRegionStartIndex() : ms_xic
  • getRegionStartScanId() : ms_xic
  • getRelativeMass() : ms_ms1quant_match_component
  • getRepeatSearchString() : ms_mascotresfile
  • getRepEntryByName() : ms_wwwoptions
  • getReplicate() : ms_quant_protocol
  • getReplicateSchemaType() : ms_quant_protocol
  • getREPORT() : ms_searchparams
  • getReportBuilderColumnArrangement() : ms_mascotoptions
  • getReportDetailSchemaType() : ms_quant_method
  • getReporter() : ms_quant_protocol
  • getReporterSchemaType() : ms_quant_protocol
  • getReporterTol() : ms_quant_reporter
  • getReporterTolSchemaType() : ms_quant_reporter
  • getReporterTolUnit() : ms_quant_reporter
  • getReporterTolUnitSchemaType() : ms_quant_reporter
  • getReportNumberChoice() : ms_mascotoptions
  • getReportRatioByName() : ms_quant_method
  • getReportRatioByNumber() : ms_quant_method
  • getReportRatioFromFile() : ms_ms2quantitation
  • getReportRatioNamesInFile() : ms_ms2quantitation
  • getReportRatioSchemaType() : ms_quant_method
  • getReporttop() : ms_distiller_data_search
  • getREPTYPE() : ms_searchparams
  • getReqPepNeutralLoss() : ms_modification
  • getRequestData() : ms_http_helper_handles
  • getRequireBoldRed() : ms_distiller_data_search
  • getRequireBoldRedSchemaType() : ms_quant_method
  • getRequiredSchemaFileNames() : ms_distiller_data
  • getRequiredSchemaType() : ms_quant_pepneutralloss , ms_quant_modgroup
  • getResfile() : ms_mascotresults , ms_mascotresfile
  • getResfileCache() : ms_mascotoptions
  • getResfileStreamName() : ms_distiller_search_status
  • getResidueMass() : ms_masses , ms_modification , ms_searchparams
  • getRestrict() : ms_enzyme
  • getResult() : ms_shapiro_wilk
  • getResultsCache() : ms_mascotoptions
  • getResultsFile() : ms_distiller_subsearch , ms_distiller_search_status
  • getResultsFileFormatVersion() : ms_mascotoptions
  • getResultsFileName() : ms_http_client_search
  • getResultsFullURL() : ms_mascotoptions
  • getResultsFullURL_2() : ms_mascotoptions
  • getResultsListStreamName() : ms_distiller_sub_project
  • getResultsParameters() : ms_mascotresults
  • getResultsPerlScript() : ms_mascotoptions
  • getResultsPerlScript_2() : ms_mascotoptions
  • getResultsStreamName() : ms_distiller_data_quant
  • getRetentionTimes() : ms_inputquery
  • getReviewColDisplay() : ms_mascotoptions
  • getReviewColWidth() : ms_mascotoptions
  • getRMSDeltas() : ms_protein
  • getRt() : ms_ms1quant_match_range
  • getRtPeakEnd() : ms_xic
  • getRtPeakStart() : ms_xic
  • getRtRegionEnd() : ms_xic
  • getRtRegionStart() : ms_xic
  • getRule() : ms_parserule_plus
  • getRULES() : ms_searchparams , ms_inputquery
  • getRuleStr() : ms_parserule
  • getSampleSize() : ms_protein_quant_ratio
  • getSARExtendedErrorCode() : ms_fileutilities
  • getSatellite() : ms_quant_component
  • getSatelliteSchemaType() : ms_quant_component
  • getScan() : ms_ms1quant_match_range
  • getScanNumbers() : ms_inputquery
  • getSchemaDirectory() : ms_quant_configfile
  • getSchemaFileName() : ms_crosslinking_configfile , ms_umod_configfile , ms_quant_configfile
  • getSchemaType() : ms_quant_component , ms_quant_protocol , ms_quant_parameter , ms_umod_element , ms_quant_element , ms_crosslinking_accessions , ms_crosslinking_filters , ms_quant_satellite , ms_crosslinking_monolink , ms_umod_aminoacid , ms_crosslinking_settings , ms_quant_composition , ms_quant_specificity , ms_quant_localdef , ms_quant_quality , ms_quant_multiplex , ms_quant_normalisation , ms_quant_normalisation_peptides , ms_quant_outliers , ms_quant_ratio , ms_quant_precursor , ms_quant_parameters , ms_quant_replicate , ms_quant_unmodified , ms_umod_elemref , ms_quant_pepneutralloss , ms_quant_normalisation_proteins , ms_quant_neutralloss , ms_quant_numerator , ms_quant_normalisation_protein , ms_quant_normalisation_peptide , ms_quant_modgroup , ms_quant_correction , ms_quant_moverz , ms_quant_integration , ms_quant_method , ms_quant_isotope , ms_crosslinking_parameter , ms_crosslinking_parameters , ms_quant_average , ms_crosslinking_scope , ms_crosslinking_linkers , ms_crosslinking_accession , ms_crosslinking_method , ms_crosslinking_linker , ms_crosslinking_does_not_pair_with , ms_quant_reporter , ms_umod_composition , ms_umod_neutralloss , ms_umod_specificity , ms_umod_modification , ms_umod_xref , ms_xml_parameters , ms_umod_modbrick , ms_xml_parameter
  • getScope() : ms_crosslinking_method
  • getScopeSchemaType() : ms_crosslinking_method
  • getScore() : ms_protein
  • getScoreExpectCutOff() : ms_distiller_data_search
  • getScoreWithET() : ms_protein
  • getScoring() : ms_distiller_data_search
  • getSearch() : ms_distiller_master_project , ms_distiller_data
  • getSEARCH() : ms_searchparams
  • getSearch() : ms_distiller_search_status_list
  • getSearchCount() : ms_distiller_data
  • getSearchLogFile() : ms_mascotoptions
  • getSearchStatusListStreamName() : ms_distiller_search_status_list
  • getSearchSubmitMode() : ms_mascotoptions
  • getSearchTaskID() : ms_http_client_search
  • getSecsToWaitForNodeAtStartup() : ms_clusterparams
  • getSectionName() : ms_mascotresfile
  • getSectionValue() : ms_mascotresfile
  • getSectionValueDouble() : ms_mascotresfile
  • getSectionValueInt() : ms_mascotresfile
  • getSectionValueStr() : ms_mascotresfile
  • getSEG() : ms_searchparams
  • getSelection() : ms_quant_average
  • getSelectionSchemaType() : ms_quant_average
  • getSelectSwitch() : ms_mascotoptions
  • getSendmailPath() : ms_mascotoptions
  • getSeparateLockMem() : ms_mascotoptions
  • getSeq() : ms_inputquery , ms_quant_method
  • getSeqEntryByName() : ms_wwwoptions
  • getSeqSchemaType() : ms_quant_method
  • getSequence() : ms_quant_normalisation_peptide , ms_spectral_lib_entry
  • getSequenceFile() : ms_http_client_session
  • getSequenceFromNumber() : ms_spectral_lib_file
  • getSequenceMass() : ms_mascotresults
  • getSequenceSchemaType() : ms_quant_normalisation_peptide
  • getSeriesDescription() : ms_fragmentationrules
  • getSeriesName() : ms_fragmentationrules , ms_fragment
  • getSeriesUsedStr() : ms_peptide
  • getServer() : ms_distiller_search_status
  • getSessionID() : ms_connection_settings , ms_http_client_search , ms_http_client_session
  • getSessionTimeout() : ms_security_options
  • getSettings() : ms_crosslinking_method
  • getSettingsSchemaType() : ms_crosslinking_method
  • getShift() : ms_quant_correction
  • getShiftSchemaType() : ms_quant_correction
  • getShowSamesets() : ms_distiller_data_search
  • getShowSamesetsFamily() : ms_distiller_data_search
  • getShowSubset() : ms_distiller_data_search
  • getShowSubsetFamily() : ms_distiller_data_search
  • getShowSubSets() : ms_quant_method
  • getShowSubsets() : ms_mascotoptions
  • getShowSubSetsSchemaType() : ms_quant_method
  • getSigmaA() : ms_fitexy_result
  • getSigmaB() : ms_fitexy_result
  • getSigmaX() : ms_fitexy_result
  • getSigmaY() : ms_fitexy_result
  • getSignificanceThreshold() : ms_distiller_data_search
  • getSigThreshold() : ms_mascotoptions
  • getSigThresholdValue() : ms_quant_method
  • getSigThresholdValueSchemaType() : ms_quant_method
  • getSimilarProteinDB() : ms_protein
  • getSimilarProteinName() : ms_protein
  • getSimilarProteins() : ms_protein
  • getSimpleRatioSchemaType() : ms_quant_integration
  • getSingleHit() : ms_mascotresults_params
  • getSite() : ms_quant_specificity , ms_quant_unmodified , ms_umod_specificity
  • getSiteAnalysisMD10Prob() : ms_mascotoptions
  • getSiteFrom() : ms_linker_site
  • getSiteSchemaType() : ms_quant_specificity , ms_umod_specificity , ms_quant_unmodified
  • getSiteTo() : ms_linker_site
  • getSkippedKeys() : ms_protein_quant_ratio
  • getSLDatabaseNumbersOfReference() : ms_mascotresfile
  • getSLFragmentTolerance() : ms_mascotresfile
  • getSLFragmentToleranceUnit() : ms_mascotresfile
  • getSLThresholdFromMinProbability() : ms_peptidesummary
  • getSortedFinitePeptideRatioValues() : ms_customquantitation , ms_ms2quantitation , ms_quantitation
  • getSortUnassigned() : ms_mascotoptions
  • getSource() : ms_quant_integration , ms_umod_xref
  • getSourceSchemaType() : ms_quant_integration , ms_umod_xref
  • getSpecGroup() : ms_umod_specificity
  • getSpecGroupSchemaType() : ms_umod_specificity
  • getSpeciesFile() : ms_taxonomyrules
  • getSpeciesFormatRegex() : ms_taxonomyrules
  • getSpecificity() : ms_quant_localdef , ms_umod_modification
  • getSpecificityBySite() : ms_umod_modification
  • getSpecificityBySiteAndPosition() : ms_umod_modification
  • getSpecificitySchemaType() : ms_quant_localdef , ms_umod_modification
  • getSpectralLibraryDisplayOption() : ms_distiller_data_search
  • getSpectraPerLibraryBlock() : ms_mascotoptions
  • getSpectrumViewerColourSchemeNames() : ms_mascotoptions
  • getSpectrumViewerColourSchemeString() : ms_mascotoptions
  • getSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • getSplitDataFileSize() : ms_mascotoptions
  • getSplitNumberOfQueries() : ms_mascotoptions
  • getSpoofableUsers() : ms_session
  • getSrcDatabaseRule() : ms_taxonomyrules
  • getSrcQueryAndFileIdForMultiFile() : ms_mascotresfile
  • getSrcRank() : ms_peptidesummary
  • getSrcSection() : ms_peptidesummary
  • getStandardDeviation() : ms_protein_quant_ratio
  • getStandardError() : ms_protein_quant_ratio
  • getStart() : ms_fragment
  • getStartDate() : ms_license
  • getStartIndex() : ms_xic
  • getStartScanId() : ms_xic
  • getStatsInformation() : ms_spectral_lib_file
  • getStatus() : ms_progress_info , ms_ms1quant_match_ratio , ms_http_client_search , ms_ms1quant_peptide_status
  • getStatusList() : ms_ms1quant_match_ratio
  • getStatusMsg() : ms_distiller_search_status
  • getStrategy() : ms_crosslinking_method
  • getStrategySchemaType() : ms_crosslinking_method
  • getStreamNumber() : ms_distiller_data_quant
  • getStrFile() : ms_taxonomyrules
  • getStringIons1() : ms_inputquery
  • getStringIons2() : ms_inputquery
  • getStringIons3() : ms_inputquery
  • getStringParam() : ms_session , ms_group , ms_user , ms_session , ms_user , ms_group
  • getStringParams() : ms_security_task
  • getStringTitle() : ms_inputquery
  • getStrRule() : ms_taxonomyrules
  • getSUBCLUSTER() : ms_searchparams
  • getSubClusterID() : ms_clusterparams
  • getSubClusterMaxCPU() : ms_clusterparams
  • getSubmitTime() : ms_distiller_search_status
  • getSubproject() : ms_distiller_master_project
  • getSubsearch() : ms_distiller_master_search
  • getSubtaskProgress() : ms_progress_info
  • getSuffixRemove() : ms_taxonomyrules
  • getSummary() : ms_ms1quantitation
  • getSummedModsNlStr() : ms_peptide
  • getSummedModsStr() : ms_peptide , ms_ms1quant_match_component
  • getSVGSpectrumSwitch() : ms_mascotoptions
  • getSymbol() : ms_umod_elemref , ms_quant_element
  • getSymbolSchemaType() : ms_umod_elemref , ms_quant_element
  • getSystemError() : ms_http_helper_return
  • getTag() : ms_inputquery
  • getTagDeltaRangeEnd() : ms_peptidesummary , ms_mascotresults , ms_proteinsummary
  • getTagDeltaRangeStart() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getTagEnd() : ms_mascotresults
  • getTagSeries() : ms_mascotresults
  • getTagStart() : ms_mascotresults
  • getTagString() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • getTARGET_FDR_PERCENT() : ms_searchparams
  • getTargetFDR() : ms_mascotresults_params
  • getTargetFDRPercentage() : ms_mascotoptions
  • getTargetFDRType() : ms_mascotresults_params
  • getTask() : ms_security_tasks
  • getTaskFromID() : ms_security_tasks
  • getTaskId() : ms_distiller_data_search , ms_distiller_search_status , ms_distiller_data_quant , ms_distiller_subsearch
  • getTasks() : ms_security
  • getTaxBrowserUrl() : ms_mascotoptions
  • getTaxIDArray() : ms_taxonomytree
  • getTAXONOMY() : ms_searchparams
  • getTaxonomy() : ms_mascotresfile
  • getTaxonomyParseRuleIndex() : ms_databaseoptions
  • getTaxonomyRules() : ms_datfile
  • getTerminalResiduesString() : ms_mascotresults , ms_peptidesummary , ms_proteinsummary
  • getTestDirectory() : ms_mascotoptions
  • getText() : ms_umod_xref
  • getTextSchemaType() : ms_umod_xref
  • getThreadProcessorID() : ms_dbprocessors
  • getThreeLetter() : ms_umod_aminoacid
  • getThreeLetterSchemaType() : ms_umod_aminoacid
  • getThresholdForFDRAboveHomology() : ms_mascotresults
  • getThresholdForFDRAboveIdentity() : ms_mascotresults
  • getTimeout() : ms_session
  • getTimeParam() : ms_session
  • getTitle() : ms_distiller_subsearch , ms_unigene_entry , ms_enzyme , ms_distiller_search_status , ms_umod_element , ms_fragmentationrules , ms_umod_aminoacid , ms_umod_modbrick , ms_umod_modification , ms_modification , ms_taxonomychoice , ms_quant_localdef
  • getTitleSchemaType() : ms_umod_aminoacid , ms_quant_localdef , ms_umod_modbrick , ms_umod_modification , ms_umod_element
  • getTOL() : ms_searchparams
  • getToleranceInDa() : ms_libraryoptions
  • getToleranceInDalton() : ms_mascotresults
  • getToleranceInPPM() : ms_libraryoptions
  • getTOLU() : ms_searchparams
  • getTotal() : ms_progress_info
  • getTotalBytes() : ms_http_helper_progress
  • getTotalIntensity() : ms_ms1quant_charge_state
  • getTotalIntensitySchemaType() : ms_quant_quality
  • getTotalIntensityThreshold() : ms_quant_quality
  • getTotalIntensityThresholdSchemaType() : ms_quant_quality
  • getTotalIonsIntensity() : ms_inputquery
  • getTotalSeriesOutput() : ms_fragmentationrules
  • getTreeClusterNodes() : ms_mascotresults , ms_peptidesummary
  • getType() : ms_security_task , ms_quant_correction , ms_quant_protocol , ms_distiller_sub_project , ms_wwwentry
  • getTypeSchemaType() : ms_quant_correction
  • getUnassigned() : ms_mascotresults
  • getUnassignedIsBold() : ms_mascotresults
  • getUnassignedShowCheckbox() : ms_mascotresults
  • getUnigeneForAccession() : ms_unigene
  • getUnigeneIndexFile() : ms_mascotresults_params
  • getUniGeneOptions() : ms_datfile
  • getUnimod() : ms_mascotresfile
  • getUnimodXL() : ms_mascotresfile
  • getUniqueJobStartNumber() : ms_mascotoptions
  • getUniquePepseqSchemaType() : ms_quant_quality
  • getUniqueTaskID() : ms_mascotresfile
  • getUnixDirPerm() : ms_mascotoptions
  • getUnixWebUserGroup() : ms_mascotoptions
  • getUnmatchedAnnotationStr() : ms_spectral_lib_peak
  • getUnmatchedMasses() : ms_protein
  • getUnmodified() : ms_quant_modgroup
  • getUnmodifiedSchemaType() : ms_quant_modgroup
  • getUnnormalisedAveragePeptideRatio() : ms_customquantitation
  • getUnZipped() : ms_zip
  • getUnZippedLen() : ms_zip
  • getUrl() : ms_umod_xref
  • getUrlSchemaType() : ms_umod_xref
  • getUser() : ms_security
  • getUserAgent() : ms_connection_settings
  • getUSEREMAIL() : ms_searchparams
  • getUSERField() : ms_searchparams
  • getUserFromID() : ms_security
  • getUSERID() : ms_searchparams
  • getUserID() : ms_session
  • getUserName() : ms_session
  • getUSERNAME() : ms_searchparams
  • getUsernameOfPoster() : ms_umod_modification
  • getUsernameOfPosterSchemaType() : ms_umod_modification
  • getUserType() : ms_user , ms_session
  • getUseSessionCookies() : ms_security_options
  • getUseTimeShift() : ms_xic
  • getValue() : ms_xml_parameter , ms_crosslinking_monolink , ms_ms1quant_match_ratio , ms_peptide_quant_ratio , ms_protein_quant_ratio , ms_http_client_mime , ms_crosslinking_accession
  • getValueFromKey() : ms_tinycdb
  • getValueSchemaType() : ms_xml_parameter , ms_crosslinking_accession , ms_quant_parameter , ms_crosslinking_monolink , ms_crosslinking_parameter
  • getVarModIdxFrom() : ms_linker_site
  • getVarModIdxOfLinkedSite() : ms_linker_site_vector
  • getVarModIdxTo() : ms_linker_site
  • getVarMods() : ms_ms1quant_match , ms_aahelper
  • getVarModsDelta() : ms_searchparams
  • getVarModsName() : ms_searchparams
  • getVarModsNeutralLoss() : ms_searchparams
  • getVarModsNeutralLosses() : ms_searchparams
  • getVarModsPepNeutralLoss() : ms_searchparams
  • getVarModsReqPepNeutralLoss() : ms_searchparams
  • getVarModsStr() : ms_peptide , ms_ms1quant_match_component
  • getVector() : ms_fragmentvector
  • getVerifySessionIPAddress() : ms_security_options
  • getVersion() : ms_http_client
  • getVmemory() : ms_mascotoptions
  • getWeight() : ms_peptide_quant_ratio
  • getWhichAvailableForMascot() : ms_processors
  • getWhichAvailableForMascot2() : ms_processors
  • getWWWOptions() : ms_datfile
  • getXic() : ms_ms1quant_match_component
  • getXicMaxWidth() : ms_quant_integration
  • getXicMaxWidthSchemaType() : ms_quant_integration
  • getXicSmoothing() : ms_quant_integration
  • getXicSmoothingSchemaType() : ms_quant_integration
  • getXicThreshold() : ms_quant_integration
  • getXicThresholdSchemaType() : ms_quant_integration
  • getXmlCode() : ms_ms1quant_match , ms_ms1quant_match_ratio , ms_xic , ms_ms1quant_peptide_status
  • getXMLschemaFilePath() : ms_mascotresfile
  • getXref() : ms_umod_modification
  • getXrefSchemaType() : ms_umod_modification
  • getZipped() : ms_zip
  • getZippedLen() : ms_zip
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • hasAbsoluteValue() : ms_ms1quant_match_component
  • hasComponent() : ms_ms1quant_match
  • hasCrosslinkingMethod() : ms_peptidesummary
  • hasFilename() : ms_http_client_mime
  • hasIdentifiedComponent() : ms_ms1quant_match
  • hasIndexes() : ms_xic
  • hasIntensityNormalisation() : ms_ms2quantitation
  • hasPasswordExpired() : ms_user
  • hasPeptideRatio() : ms_customquantitation , ms_ms1quant_match , ms_ms2quantitation , ms_quantitation
  • hasPeptideRatioNormalisation() : ms_ms2quantitation
  • hasQuantMethod() : ms_peptidesummary
  • haveAccession() : ms_quant_normalisation_protein
  • haveAccessions() : ms_crosslinking_method
  • haveAllChargeStates() : ms_quant_integration , ms_quant_precursor
  • haveAllChargeStatesThreshold() : ms_quant_integration
  • haveAllowElutionShift() : ms_quant_integration , ms_quant_precursor
  • haveAllowMassTimeMatch() : ms_quant_precursor
  • haveApproved() : ms_umod_modification
  • haveAverage() : ms_quant_moverz
  • haveAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • haveClassification() : ms_umod_specificity
  • haveCode() : ms_umod_neutralloss
  • haveCoefficient() : ms_quant_numerator
  • haveComp() : ms_quant_method
  • haveCompositionString() : ms_umod_composition
  • haveConstrainSearch() : ms_quant_method
  • haveDatabaseName() : ms_crosslinking_accession
  • haveDateTimeModified() : ms_umod_modification
  • haveDateTimePosted() : ms_umod_modification
  • haveDelta() : ms_quant_localdef , ms_umod_modification
  • haveDescription() : ms_crosslinking_method , ms_quant_method , ms_umod_neutralloss , ms_xml_parameter
  • haveElement() : ms_quant_correction
  • haveElutionProfileCorrelationThreshold() : ms_quant_integration
  • haveElutionTimeDelta() : ms_quant_integration
  • haveElutionTimeDeltaUnit() : ms_quant_integration
  • haveExcludeInternalLabel() : ms_quant_multiplex
  • haveExcludeIsobaricFragments() : ms_quant_multiplex
  • haveFileIndex() : ms_quant_component
  • haveFilters() : ms_crosslinking_method
  • haveFlag() : ms_quant_neutralloss , ms_umod_neutralloss
  • haveFullName() : ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • haveGroupOfPoster() : ms_umod_modification
  • haveHidden() : ms_umod_specificity
  • haveIntegration() : ms_quant_method
  • haveIonIntensityThreshold() : ms_quant_multiplex
  • haveIonSeries() : ms_quant_multiplex
  • haveIsolatedPrecursor() : ms_quant_quality
  • haveIsolatedPrecursorThreshold() : ms_quant_quality
  • haveLinkers() : ms_crosslinking_method
  • haveMassDelta() : ms_quant_integration
  • haveMassDeltaUnit() : ms_quant_integration
  • haveMatchedRho() : ms_quant_integration
  • haveMethod() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • haveMinimumA1() : ms_quant_quality
  • haveMinIonPairs() : ms_quant_multiplex
  • haveMinNumPeptides() : ms_quant_method
  • haveMinPrecursorCharge() : ms_quant_quality
  • haveMiscNotes() : ms_umod_modification , ms_umod_specificity
  • haveMode() : ms_quant_modgroup
  • haveModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • haveModifications() : ms_quant_satellite
  • haveMonoisotopic() : ms_quant_moverz
  • haveMonoMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • haveMoverz() : ms_quant_component
  • haveName() : ms_quant_modgroup , ms_crosslinking_method , ms_quant_component , ms_quant_method , ms_quant_numerator , ms_quant_ratio , ms_xml_parameter
  • haveNew() : ms_quant_isotope
  • haveNormalisation() : ms_quant_method
  • haveNumber() : ms_quant_element , ms_umod_elemref
  • haveNumPeptides() : ms_quant_average
  • haveOld() : ms_quant_isotope
  • haveOutliers() : ms_quant_method
  • havePairsWith() : ms_umod_neutralloss
  • havePepThresholdType() : ms_quant_quality
  • havePepThresholdValue() : ms_quant_quality
  • havePeptides() : ms_quant_normalisation
  • havePosition() : ms_quant_unmodified , ms_quant_specificity , ms_umod_specificity
  • havePrecursorRange() : ms_quant_integration
  • haveProcessingOptions() : ms_quant_integration
  • haveProteinRatioType() : ms_quant_method
  • haveProteins() : ms_quant_normalisation
  • haveProtocol() : ms_quant_method
  • haveProtScoreType() : ms_quant_method
  • haveQuality() : ms_quant_method
  • haveRecordID() : ms_umod_modification
  • haveReferenceAccession() : ms_quant_average
  • haveReferenceAmount() : ms_quant_average
  • haveReferenceDatabase() : ms_quant_average
  • haveReportDetail() : ms_quant_method
  • haveReporterTol() : ms_quant_reporter
  • haveReporterTolUnit() : ms_quant_reporter
  • haveRequireBoldRed() : ms_quant_method
  • haveRequired() : ms_quant_pepneutralloss , ms_quant_modgroup
  • haveSatellite() : ms_quant_component
  • haveScope() : ms_crosslinking_method
  • haveSelection() : ms_quant_average
  • haveSequence() : ms_quant_normalisation_peptide
  • haveSettings() : ms_crosslinking_method
  • haveShift() : ms_quant_correction
  • haveShowSubSets() : ms_quant_method
  • haveSigThresholdValue() : ms_quant_method
  • haveSimpleRatio() : ms_quant_integration
  • haveSite() : ms_quant_unmodified , ms_quant_specificity , ms_umod_specificity
  • haveSource() : ms_quant_integration , ms_umod_xref
  • haveSpecGroup() : ms_umod_specificity
  • haveStrategy() : ms_crosslinking_method
  • haveSymbol() : ms_quant_element , ms_umod_elemref
  • haveText() : ms_umod_xref
  • haveThreeLetter() : ms_umod_aminoacid
  • haveTitle() : ms_umod_element , ms_umod_modification , ms_umod_modbrick , ms_quant_localdef , ms_umod_aminoacid
  • haveTotalIntensity() : ms_quant_quality
  • haveTotalIntensityThreshold() : ms_quant_quality
  • haveType() : ms_quant_correction
  • haveUniquePepseq() : ms_quant_quality
  • haveUrl() : ms_umod_xref
  • haveUsernameOfPoster() : ms_umod_modification
  • haveValue() : ms_crosslinking_accession
  • haveXicMaxWidth() : ms_quant_integration
  • haveXicSmoothing() : ms_quant_integration
  • haveXicThreshold() : ms_quant_integration
  • httpBufferedClose() : ms_http_helper
  • httpBufferedGetString() : ms_http_helper
  • httpBufferedOpen() : ms_http_helper
  • httpError() : ms_http_helper_return
  • httpGetFile() : ms_http_helper
  • httpGetHeader() : ms_http_helper
  • httpGetString() : ms_http_helper
  • httpPostFile() : ms_http_helper
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • identityMatrix() : ms_matrix
  • includeProteinPeptideRatioKeys() : ms_ms2quantitation
  • inErrorTolerant() : ms_umod_specificity , ms_modification
  • initGroupChargeStates() : ms_ms1quantitation
  • initialiseBaseSettings() : ms_quantitation
  • inLongList() : ms_umod_specificity , ms_modification
  • inShortList() : ms_modification , ms_umod_specificity
  • isAbortSet() : ms_http_helper_progress
  • isAccountEnabled() : ms_user
  • isActive() : ms_databaseoptions
  • isAllChargeStates() : ms_quant_integration , ms_quant_precursor
  • isAllowElutionShift() : ms_quant_integration , ms_quant_precursor
  • isAllowMassTimeMatch() : ms_quant_precursor
  • isApproved() : ms_umod_modification
  • isASimilarProtein() : ms_protein
  • isAutoSelectCharge() : ms_mascotoptions
  • isAvailable() : ms_parserule
  • isAverageProtocol() : ms_ms1quantitation
  • isBackboneSeries() : ms_fragmentationrules
  • isBreaking() : ms_progress_info
  • isCharged2Plus() : ms_fragmentationrules
  • isCharged3Plus() : ms_fragmentationrules
  • isComplete() : ms_http_helper_progress
  • isComponentIdentified() : ms_ms1quant_match_component
  • isConcatRefFileLines() : ms_taxonomyrules
  • isConstrainSearch() : ms_quant_method
  • isCreating() : ms_tinycdb
  • isCronEnabled() : ms_cronoptions
  • isCTerminal() : ms_fragment
  • isDatabaseTypeAvailable() : ms_mascotresfile
  • isDataCached() : ms_peptidesummary , ms_ms1quantitation
  • isDayOfMonth() : ms_cronjob
  • isDayOfWeek() : ms_cronjob
  • isDBLevelTaxId() : ms_taxonomyrules
  • isDefaultTargetFDRPercentage() : ms_mascotoptions
  • isDirectory() : ms_fileutilities
  • isEmailErrorsEnabled() : ms_mascotoptions
  • isEmailUsersEnabled() : ms_mascotoptions
  • isEmPAIallowed() : ms_mascotresults
  • isEnabled() : ms_clusterparams , ms_cronjob , ms_taxonomyrules
  • isErrorTolerant() : ms_mascotresfile
  • isExcluded() : ms_peptide_quant_ratio
  • isExcludeInternalLabel() : ms_quant_multiplex
  • isExcludeIsobaricFragments() : ms_quant_multiplex
  • isFastaPermitted() : ms_session , ms_security_tasks
  • isFileWritable() : ms_fileutilities
  • isFlag() : ms_quant_neutralloss , ms_umod_neutralloss
  • isForkForUnixApache() : ms_mascotoptions
  • isFromAlpha() : ms_fragment
  • isFromBeta() : ms_fragment
  • isFromRefFile() : ms_taxonomyrules
  • isFromSubstitutions() : ms_modfile
  • isGeneratedMonoLinker() : ms_modification
  • isHidden() : ms_modification , ms_umod_specificity
  • isHitRatioExcluded() : ms_ms1quant_match
  • isHitRatioOutlier() : ms_ms1quant_match
  • isHitRatioUsedForAverage() : ms_ms1quant_match
  • isHour() : ms_cronjob
  • isImmonium() : ms_fragment
  • isIncluded() : ms_ms1quant_match_ratio
  • isIncludedIn() : ms_taxonomytree
  • isIndependent() : ms_enzyme
  • isInfinite() : ms_peptide_quant_ratio
  • isInIgnoreDupeAccessionList() : ms_mascotoptions
  • isInternal() : ms_fragment
  • isIsolatedPrecursor() : ms_quant_quality
  • isIteratePMFIntensities() : ms_mascotoptions
  • isLabelAll() : ms_mascotoptions
  • isLicenseValid() : ms_license
  • isLocalRefFile() : ms_databaseoptions
  • isLockMemory() : ms_databaseoptions
  • isLogicalCPUAvailableForMascot() : ms_processors
  • isLogNormal() : ms_protein_quant_ratio
  • isLoopLinker() : ms_modification
  • isMatchedToCalculatedPeak() : ms_spectral_lib_peak
  • isMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • isMemoryMapFiles() : ms_databaseoptions
  • isMethodCompatible() : ms_quant_method
  • isMinute() : ms_cronjob
  • isMissing() : ms_peptide_quant_ratio , ms_protein_quant_ratio
  • isMitochondrialTranslation() : ms_taxonomyrules
  • isMonthOfYear() : ms_cronjob
  • isMoveOldDbToOldDir() : ms_mascotoptions
  • isMSMS() : ms_mascotresfile
  • isNA() : ms_mascotresults
  • isNeutralLossSeries() : ms_fragmentationrules
  • isNil() : ms_peptide_quant_key
  • isNoneFound() : ms_enzymefile
  • isNTerminal() : ms_fragment
  • isOk() : ms_http_helper_return
  • isOpenForReading() : ms_tinycdb
  • isPeptideComponentMatch() : ms_peptidesummary
  • isPeptideModificationMatch() : ms_peptidesummary
  • isPeptideQualityOK() : ms_quant_helper
  • isPeptideQuantifiable() : ms_quant_helper
  • isPeptideRatioExcluded() : ms_customquantitation , ms_ms2quantitation , ms_quantitation
  • isPeptideUnique() : ms_peptidesummary , ms_proteinsummary , ms_mascotresults
  • isPercolator() : ms_mascotoptions
  • isPercolatorUseProteins() : ms_mascotoptions
  • isPercolatorUseRT() : ms_mascotoptions
  • isPermitted() : ms_security_tasks , ms_session , ms_security_task
  • isPermitted_double() : ms_session , ms_security_task , ms_security_tasks
  • isPermitted_long() : ms_session , ms_security_task , ms_security_tasks
  • isPermitted_string() : ms_security_tasks , ms_security_task , ms_session
  • isPMF() : ms_mascotresfile
  • isPMFMixture() : ms_protein
  • isPmfQueryUsed() : ms_proteinsummary
  • isPossibleToCreate() : ms_tinycdb
  • isPrecursorNL() : ms_fragment
  • isPrimaryLogicalProcessor() : ms_processors
  • isPrivacyEnabled() : ms_umod_modification
  • isPrivate() : ms_umod_modification
  • isProcessAffinitySupported() : ms_processors
  • isReferenceUserSelected() : ms_ms1quant_average_results
  • isRegular() : ms_fragment
  • isRemoveOldIndexFiles() : ms_mascotoptions
  • isReportDetail() : ms_quant_method
  • isRequireBoldRed() : ms_quant_method , ms_mascotoptions
  • isRequired() : ms_quant_modgroup , ms_quant_pepneutralloss
  • isResidueModified() : ms_masses , ms_modification
  • isSame() : ms_masses
  • isSameAs() : ms_umod_xref , ms_umod_modification , ms_umod_specificity , ms_umod_composition
  • isSamePeptideStr() : ms_peptide
  • isSameSummedModsStr() : ms_peptide
  • isSameVarModsStr() : ms_peptide
  • isSaveEveryLastQueryAsc() : ms_mascotoptions
  • isSaveLastQueryAsc() : ms_mascotoptions
  • isSectionAvailable() : ms_mascotoptions , ms_parseoptions , ms_databases , ms_libraryoptions , ms_processoroptions , ms_taxonomyrules , ms_unigeneoptions , ms_wwwoptions , ms_clusterparams , ms_cronoptions
  • isSecurityEnabled() : ms_security_options , ms_session
  • isSemiSpecific() : ms_enzyme
  • isSeriesUsed() : ms_fragmentationrules
  • isSet() : ms_ms1quant_match_ratio
  • isShowAllFromErrorTolerant() : ms_mascotoptions
  • isShowSubsets() : ms_mascotoptions
  • isSignificant() : ms_protein_quant_ratio
  • isSimilarProtein() : ms_protein
  • isSimpleRatio() : ms_quant_integration
  • isSinglyCharged() : ms_fragmentationrules
  • isSpeciesDescendantOf() : ms_taxonomytree
  • isSQ() : ms_mascotresfile
  • isStarted() : ms_http_helper_progress
  • isStoreModPermutations() : ms_mascotoptions
  • isSubstitution() : ms_modification
  • isSuspectAssignment() : ms_spectral_lib_peak
  • isTaskExists() : ms_security_tasks , ms_security
  • isThreadedLogicalProcessor() : ms_processors
  • isTimedOut() : ms_session
  • isTotalIntensity() : ms_quant_quality
  • isUnigene() : ms_protein
  • isUniquePepseq() : ms_quant_quality
  • isUnixDirPermDefined() : ms_mascotoptions
  • isUsedForAverage() : ms_ms1quant_match_ratio
  • isUseHTTPProxyForFTP() : ms_connection_settings , ms_mascotoptions
  • isUseHTTPProxyForHTTPS() : ms_connection_settings , ms_mascotoptions
  • isUsePeptideSummary() : ms_mascotresults_params
  • isUseProcessesNotThreads() : ms_processors
  • isUserExists() : ms_security
  • isUserInGroup() : ms_group
  • isValid() : ms_errors , ms_fragmentationrules , ms_errs , ms_ms1quant_match_ratio , ms_enzyme , ms_spectral_lib_peak
  • isZero() : ms_matrix
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • params() : ms_mascotresfile
  • parseCommandLineArgumentString() : ms_fileutilities
  • parseLine() : ms_obofile
  • poissonDensity() : ms_quant_stats
  • pop() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • prepareToCreate() : ms_tinycdb
  • proxyTypeStringToEnum() : ms_connection_settings
  • proxyTypeToString() : ms_connection_settings
  • push() : ms_linker_site_vector , ms_peptide_quant_key_vector
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • read_buffer() : ms_crosslinking_configfile , ms_enzymefile , ms_quant_configfile , ms_taxonomyfile , ms_fragrulesfile , ms_umod_configfile
  • read_file() : ms_datfile , ms_umod_configfile , ms_enzymefile , ms_fragrulesfile , ms_license , ms_masses , ms_modfile , ms_crosslinking_configfile , ms_quant_configfile , ms_taxonomyfile
  • readResultCounters() : ms_ms1quantitation
  • removeAllTasks() : ms_security_tasks
  • removeCombinedReportRatio() : ms_ms2quantitation
  • removeComponent() : ms_ms1quant_match
  • removeIntensityNormalisationBase() : ms_ms2quantitation
  • removeIntensityNormalisationBases() : ms_ms2quantitation
  • removeLogEventsHandler() : ms_loggingmonitor
  • removeMatch() : ms_ms1quantitation
  • removePeptideQuantKey() : ms_customquantitation
  • removePeptideRatio() : ms_customquantitation
  • removePeptideRatioNormalisationBase() : ms_quantitation
  • removePeptideRatioNormalisationBases() : ms_quantitation
  • removePermittedTask() : ms_group
  • removeReportRatioInFile() : ms_ms2quantitation
  • removeSubtask() : ms_progress_info
  • removeTask() : ms_security_tasks
  • resetKeepAlive() : ms_mascotresfile
  • resize() : ms_matrix
  • rowMatrix() : ms_matrix
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • save_buffer() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • save_file() : ms_crosslinking_configfile , ms_masses , ms_modfile , ms_datfile , ms_quant_configfile , ms_taxonomyfile , ms_enzymefile , ms_umod_configfile , ms_fragrulesfile
  • saveAs() : ms_spectral_lib_file
  • saveBoolParam() : ms_session
  • saveCdbFile() : ms_ms2quantitation , ms_ms1quantitation
  • saveDoubleParam() : ms_session
  • saveFileOffsetForKey() : ms_tinycdb
  • saveIntForKey() : ms_tinycdb
  • saveIntParam() : ms_session
  • saveLongParam() : ms_session
  • saveStringParam() : ms_group , ms_session , ms_user
  • saveTimeParam() : ms_session
  • saveToFile() : ms_security_tasks
  • saveToString() : ms_modfile
  • saveValueForKey() : ms_tinycdb
  • saveXmlFile() : ms_ms1quantitation , ms_ms2quantitation
  • serverVersionNewerOrSameAs() : ms_distiller_data_search
  • sessionId() : ms_http_client_search
  • set() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • setAbort() : ms_http_helper_progress
  • setAccession() : ms_quant_normalisation_protein
  • setAccessionParseRuleIndex() : ms_databaseoptions
  • setAccessionRefParseRuleIndex() : ms_databaseoptions
  • setAccessions() : ms_crosslinking_method
  • setAccessRights() : ms_fileutilities
  • setAccFromSpeciesLine() : ms_taxonomyrules
  • setAccountEnabled() : ms_user
  • setActive() : ms_databaseoptions
  • setAllChargeStates() : ms_quant_integration
  • setAllChargeStatesThreshold() : ms_quant_integration
  • setAllowElutionShift() : ms_quant_integration
  • setAllowMassTimeMatch() : ms_quant_precursor
  • setAnnotation() : ms_spectral_lib_peak
  • setAnnotationLevel() : ms_spectral_lib_peak_list
  • setAPI() : ms_errs
  • setApproved() : ms_umod_modification
  • setAutoSelectCharge() : ms_mascotoptions
  • setAvailable() : ms_parserule
  • setAvailableModifications() : ms_aahelper
  • setAverage() : ms_quant_moverz , ms_quant_protocol
  • setAverageNumPeptides() : ms_ms1quantitation
  • setAverageReferenceProtein() : ms_ms1quantitation
  • setAverageSelection() : ms_ms1quantitation
  • setAvgeMass() : ms_umod_aminoacid , ms_umod_composition , ms_umod_element , ms_umod_modbrick
  • setBaseUrl() : ms_http_client
  • setBreak() : ms_progress_info
  • setCacheDirectory() : ms_mascotoptions
  • setCarbonMass() : ms_masses
  • setCentroidWidth() : ms_mascotoptions
  • setCentroidWidthCount() : ms_mascotoptions
  • setCharged2Plus() : ms_fragmentationrules
  • setCharged3Plus() : ms_fragmentationrules
  • setCheckNodesAliveFreq() : ms_clusterparams
  • setChopSource() : ms_parserule_plus
  • setClassification() : ms_umod_specificity
  • setClusterParams() : ms_datfile
  • setCode() : ms_umod_neutralloss
  • setCoefficient() : ms_quant_numerator
  • setColsToOutput() : ms_logger
  • setColumnDown() : ms_matrix
  • setColumnUp() : ms_matrix
  • setCombinedReportRatio() : ms_ms2quantitation
  • setCombineRepeats() : ms_errs
  • setCommandStr() : ms_cronjob
  • setComp() : ms_quant_method
  • setCompositionString() : ms_umod_composition
  • setCompressToolAA() : ms_mascotoptions
  • setCompressToolNA() : ms_mascotoptions
  • setCompressToolSL() : ms_mascotoptions
  • setConcatRefFileLines() : ms_taxonomyrules
  • setConnectionSettings() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_http_client , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_umod_configfile
  • setConnectionTimeout() : ms_connection_settings
  • setConstrainSearch() : ms_quant_method
  • setContent() : ms_quant_correction , ms_quant_numerator , ms_quant_unmodified
  • setCR() : ms_matrix
  • setCrawlerNumPeaksPer100Da() : ms_mascotoptions
  • setCreatePipThreadBlockSize() : ms_mascotoptions
  • setCreatePipThreads() : ms_mascotoptions
  • setCronEnabled() : ms_cronoptions
  • setCronJob() : ms_cronoptions
  • setCronOptions() : ms_datfile
  • setCTerminusMass() : ms_modification
  • setCtermModification() : ms_masses
  • setDatabaseName() : ms_crosslinking_accession
  • setDatabases() : ms_datfile
  • setDateTimeModified() : ms_umod_modification
  • setDateTimePosted() : ms_umod_modification
  • setDayOfMonth() : ms_cronjob
  • setDayOfWeek() : ms_cronjob
  • setDB() : ms_protein
  • setDBLevelTaxId() : ms_taxonomyrules
  • setDBType() : ms_databaseoptions
  • setDechargeFragmentPeaks() : ms_mascotoptions
  • setDecoyTypeNoEnzyme() : ms_mascotoptions
  • setDecoyTypeSpecific() : ms_mascotoptions
  • setDefaultDelimiter() : ms_customproperty
  • setDefaultMonitor() : ms_loggingmonitor
  • setDefaultNodeHomeDir() : ms_clusterparams
  • setDefaultNodeHomeDirFromMaster() : ms_clusterparams
  • setDefaultNodeOS() : ms_clusterparams
  • setDefaultPasswordExpiryTime() : ms_security_options
  • setDefaultPort() : ms_clusterparams
  • setDefaultRule() : ms_taxonomyrules
  • setDefaultTargetFDRPercentage() : ms_mascotoptions
  • setDelta() : ms_modification , ms_quant_localdef , ms_umod_modification
  • setDescription() : ms_crosslinking_method , ms_quant_method , ms_umod_neutralloss , ms_xml_parameter
  • setDescriptionLineSep() : ms_taxonomyrules
  • setDescriptionParseRuleIndex() : ms_databaseoptions
  • setDisplayNonSignificantMatches() : ms_mascotoptions
  • setDoThisRuleFirst() : ms_taxonomyrules
  • setElectronMass() : ms_masses
  • setElement() : ms_quant_correction
  • setElutionProfileCorrelationThreshold() : ms_quant_integration
  • setElutionTimeDelta() : ms_quant_integration
  • setElutionTimeDeltaUnit() : ms_quant_integration
  • setEmailAddress() : ms_user
  • setEmailErrorsEnabled() : ms_mascotoptions
  • setEmailFromTextName() : ms_mascotoptions
  • setEmailFromUser() : ms_mascotoptions
  • setEmailPassword() : ms_mascotoptions
  • setEmailProfile() : ms_mascotoptions
  • setEmailService() : ms_mascotoptions
  • setEmailTimeOutPeriod() : ms_mascotoptions
  • setEmailUsersEnabled() : ms_mascotoptions
  • setEnabled() : ms_clusterparams , ms_cronjob , ms_taxonomyrules
  • setEncryptedPassword() : ms_user
  • setEntry() : ms_wwwoptions
  • setEnzyme() : ms_aahelper
  • setEnzymes() : ms_mascotfiles
  • setErrMessageEmailTo() : ms_mascotoptions
  • setErrorLevel() : ms_taxonomyrules
  • setErrorLogFile() : ms_mascotoptions
  • setErrTolMaxAccessions() : ms_mascotoptions
  • setExcludeInternalLabel() : ms_quant_multiplex
  • setExcludeIsobaricFragments() : ms_quant_multiplex
  • setExecAfterSearch() : ms_mascotoptions
  • setFeatureTableLength() : ms_mascotoptions
  • setFeatureTableMinScore() : ms_mascotoptions
  • setFileIndex() : ms_quant_component
  • setFileName() : ms_crosslinking_configfile , ms_datfile , ms_enzymefile , ms_fragrulesfile , ms_license , ms_masses , ms_modfile , ms_quant_configfile , ms_taxonomyfile , ms_taxspeciesfiles , ms_taxnodesfiles , ms_umod_configfile
  • setFileTypeToSearch() : ms_parserule_plus
  • setFilters() : ms_crosslinking_method
  • setFindFileTimeout() : ms_datfile
  • setFlag() : ms_mascotresults_params , ms_quant_neutralloss , ms_umod_neutralloss
  • setFlag2() : ms_mascotresults_params
  • setFlags() : ms_mascotresults_params
  • setFlags2() : ms_mascotresults_params
  • setForkForUnixApache() : ms_mascotoptions
  • setFormat() : ms_taxspeciesfiles , ms_taxnodesfiles
  • setFormVersion() : ms_mascotoptions
  • setFrequencies() : ms_mascotfiles
  • setFromRefFile() : ms_taxonomyrules
  • setFromSubstitutions() : ms_modfile
  • setFullName() : ms_user , ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick , ms_umod_modification
  • setGetSeqBlastAccession() : ms_mascotoptions
  • setGetSeqJobIdFile() : ms_mascotoptions
  • setGroupOfPoster() : ms_umod_modification
  • setHeaderComments() : ms_datfile
  • setHidden() : ms_modification , ms_umod_specificity
  • setHitRatioExcluded() : ms_ms1quant_match
  • setHitRatioOutlier() : ms_ms1quant_match
  • setHostName() : ms_computeraddress , ms_wwwentry
  • setHour() : ms_cronjob
  • setHttpPassword() : ms_connection_settings
  • setHttpProtocol() : ms_connection_settings
  • setHttpUsername() : ms_connection_settings
  • setHydrogenMass() : ms_masses
  • setICATFilter() : ms_mascotoptions
  • setICATHeavy() : ms_mascotoptions
  • setICATLight() : ms_mascotoptions
  • setICATQuantitationMethod() : ms_mascotoptions
  • setID() : ms_group , ms_user
  • setIdentifier() : ms_taxonomyrules
  • setIgnoreDupeAccession() : ms_mascotoptions
  • setIgnoreIonsScoreBelow() : ms_mascotoptions , ms_mascotresults_params
  • setIndependent() : ms_enzyme
  • setIndexFileName() : ms_tinycdb
  • setInErrorTolerant() : ms_modification
  • setInetAddress() : ms_computeraddress
  • setInLongList() : ms_modification
  • setInShortList() : ms_modification
  • setIntegraAppServerURL() : ms_security_options
  • setIntegraDatabaseName() : ms_security_options
  • setIntegraOracleServerName() : ms_security_options
  • setIntegration() : ms_quant_method
  • setIntensityNormalisationBase() : ms_ms2quantitation
  • setIntensitySigFigs() : ms_mascotoptions
  • setInterFileBasePath() : ms_mascotoptions
  • setInterFileRelPath() : ms_mascotoptions
  • setIonIntensityThreshold() : ms_quant_multiplex
  • setIonsDecimalPlaces() : ms_mascotoptions
  • setIonSeries() : ms_quant_multiplex
  • setIPCLogfile() : ms_clusterparams
  • setIPCLogging() : ms_clusterparams
  • setIPCTimeout() : ms_clusterparams
  • setIsolatedPrecursor() : ms_quant_quality
  • setIsolatedPrecursorThreshold() : ms_quant_quality
  • setIteratePMFIntensities() : ms_mascotoptions
  • setLabelAll() : ms_mascotoptions
  • setLastModificationTime() : ms_fileutilities
  • setLastQueryAscFile() : ms_mascotoptions
  • setLibraryOptions() : ms_datfile
  • setLinkers() : ms_crosslinking_method
  • setLocalModsStr() : ms_peptide
  • setLocalRefFile() : ms_databaseoptions
  • setLockMemory() : ms_databaseoptions
  • setLogFileName() : ms_cronoptions , ms_security_options
  • setLoggingFile() : ms_errs
  • setLoggingLevel() : ms_cronoptions , ms_errs , ms_security_options
  • setLogMask() : ms_loggingmonitor
  • setLogoImageFile() : ms_mascotoptions
  • setMailTempFile() : ms_mascotoptions
  • setMailTransport() : ms_mascotoptions
  • setMajorVersion() : ms_umod_configfile
  • setMascNodeCtrlFile() : ms_mascotoptions
  • setMascotCmdLine() : ms_mascotoptions
  • setMascotControlFile() : ms_mascotoptions
  • setMascotFileProcessingThreads() : ms_mascotoptions
  • setMascotFiles() : ms_datfile
  • setMascotJobIdFile() : ms_mascotoptions
  • setMascotMessage() : ms_mascotoptions
  • setMascotNodeRebootScript() : ms_clusterparams
  • setMascotNodeScript() : ms_clusterparams
  • setMascotOptions() : ms_datfile
  • setMassDecimalPlaces() : ms_mascotoptions
  • setMassDelta() : ms_quant_integration
  • setMassDeltaUnit() : ms_quant_integration
  • setMasses() : ms_aahelper
  • setMassFile() : ms_modification , ms_modfile
  • setMasterComputer() : ms_clusterparams
  • setMatchedIon() : ms_fragment
  • setMatchedRho() : ms_quant_integration
  • setMatchOppositeCrosslinkPairs() : ms_mascotoptions
  • setMaxConcurrentSearches() : ms_mascotoptions
  • setMaxDatabases() : ms_mascotoptions
  • setMaxDescriptionLen() : ms_mascotoptions
  • setMaxEtagMassDelta() : ms_mascotoptions
  • setMaxEtVarMods() : ms_mascotoptions
  • setMaxHitsToReport() : ms_mascotresults_params
  • setMaxIntactCrosslinkPeptides() : ms_mascotoptions
  • setMaxInternalMass() : ms_fragmentationrules
  • setMaxNumPeptides() : ms_mascotoptions
  • setMaxPepModArrangements() : ms_mascotoptions
  • setMaxPepNumModifiedSites() : ms_mascotoptions
  • setMaxPepNumVarMods() : ms_mascotoptions
  • setMaxQueries() : ms_mascotoptions
  • setMaxSearchesPerUser() : ms_mascotoptions
  • setMaxSequenceLen() : ms_mascotoptions
  • setMaxVarMods() : ms_mascotoptions
  • setMemoryMapFiles() : ms_databaseoptions
  • setMethod() : ms_quant_integration , ms_quant_normalisation , ms_quant_outliers
  • setMinEtagMassDelta() : ms_mascotoptions
  • setMinimumA1() : ms_quant_quality
  • setMinimumPasswordLength() : ms_security_options
  • setMinInternalMass() : ms_fragmentationrules
  • setMinIonPairs() : ms_quant_multiplex
  • setMinNumPeptides() : ms_quant_method , ms_quantitation
  • setMinNumSigUniqueSequences() : ms_mascotresults_params
  • setMinorVersion() : ms_umod_configfile
  • setMinPepLenInPepSummary() : ms_mascotoptions
  • setMinPepLenInPeptideSummary() : ms_mascotresults_params
  • setMinPepLenInSearch() : ms_mascotoptions
  • setMinPrecursorCharge() : ms_quant_quality
  • setMinProbability() : ms_mascotresults_params
  • setMinute() : ms_cronjob
  • setMiscNotes() : ms_umod_modification , ms_umod_specificity
  • setMitochondrialTranslation() : ms_taxonomyrules
  • setMode() : ms_quant_modgroup
  • setModFileName() : ms_crosslinking_does_not_pair_with , ms_crosslinking_linker
  • setModifications() : ms_mascotfiles , ms_quant_satellite
  • setModificationType() : ms_modification
  • setMonitorEmailCheckFreq() : ms_mascotoptions
  • setMonitorLogFile() : ms_mascotoptions
  • setMonitorPidFile() : ms_mascotoptions
  • setMonitorTestTimeout() : ms_mascotoptions
  • setMonoisotopic() : ms_quant_moverz
  • setMonoMass() : ms_umod_composition , ms_umod_aminoacid , ms_umod_element , ms_umod_modbrick
  • setMonthOfYear() : ms_cronjob
  • setMoveOldDbToOldDir() : ms_mascotoptions
  • setMoverz() : ms_quant_component
  • setMudpit() : ms_mascotoptions
  • setMudpitSwitch() : ms_mascotoptions
  • setMultiplex() : ms_quant_protocol
  • setName() : ms_xml_parameter , ms_quant_ratio , ms_quant_component , ms_crosslinking_method , ms_databaseoptions , ms_dbprocessors , ms_quant_method , ms_quant_modgroup , ms_quant_numerator , ms_group , ms_user , ms_wwwentry
  • setNameOfDB() : ms_parserule_plus
  • setNeutralLoss() : ms_modification
  • setNew() : ms_quant_isotope
  • setNitrogenMass() : ms_masses
  • setNodeListFile() : ms_mascotfiles
  • setNodeSequenceDatabaseDir() : ms_clusterparams
  • setNoResultsScript() : ms_mascotoptions
  • setNormalisation() : ms_quant_method
  • setNTerminusMass() : ms_modification
  • setNtermModification() : ms_masses
  • setNTIUserGroup() : ms_mascotoptions
  • setNTMonitorGroup() : ms_mascotoptions
  • setNull() : ms_quant_protocol
  • setNumber() : ms_quant_element , ms_umod_elemref
  • setNumberOfThreads() : ms_databaseoptions
  • setNumPeptides() : ms_quant_average
  • setOld() : ms_quant_isotope
  • setOutliers() : ms_quant_method
  • setOxygenMass() : ms_masses
  • setPairsWith() : ms_umod_neutralloss
  • setParams() : ms_security_task
  • setParseOptions() : ms_datfile
  • setParseRule() : ms_parseoptions , ms_wwwentry
  • setPassword() : ms_user
  • setPasswordExpiry() : ms_user
  • setPath() : ms_databaseoptions , ms_wwwentry
  • setPepNeutralLoss() : ms_modification
  • setPepSearchTool() : ms_mascotoptions
  • setPepThresholdType() : ms_quant_quality
  • setPepThresholdValue() : ms_quant_quality
  • setPeptideIsBold() : ms_protein
  • setPeptideRatioExcluded() : ms_customquantitation , ms_ms2quantitation , ms_quantitation
  • setPeptideRatioIncluded() : ms_customquantitation , ms_ms2quantitation , ms_quantitation
  • setPeptideRatioNormalisationBase() : ms_quantitation
  • setPeptides() : ms_quant_normalisation
  • setPeptideShowCheckbox() : ms_protein
  • setPercolator() : ms_mascotoptions
  • setPercolatorExeFlags() : ms_mascotoptions
  • setPercolatorFeatures() : ms_mascotoptions , ms_mascotresfile
  • setPercolatorMinQueries() : ms_mascotoptions
  • setPercolatorMinSequences() : ms_mascotoptions
  • setPercolatorTargetRankRelativeThreshold() : ms_mascotoptions
  • setPercolatorTargetRankScoreThreshold() : ms_mascotoptions
  • setPercolatorUseProteins() : ms_mascotoptions
  • setPercolatorUseRT() : ms_mascotoptions
  • setPermittedTasks() : ms_group , ms_session
  • setPort() : ms_computeraddress
  • setPortNumber() : ms_wwwentry
  • setPosition() : ms_quant_specificity , ms_umod_specificity , ms_quant_unmodified
  • setPreceedingComments() : ms_customproperty , ms_databaseoptions
  • setPrecursor() : ms_quant_protocol
  • setPrecursorCutOutLowerLimit() : ms_mascotoptions
  • setPrecursorCutOutUpperLimit() : ms_mascotoptions
  • setPrecursorRange() : ms_quant_integration
  • setPrivacyEnabled() : ms_umod_modification
  • setPrivate() : ms_umod_modification
  • setProcessingOptions() : ms_quant_integration
  • setProcessors() : ms_datfile
  • setPropertyName() : ms_customproperty
  • setPropValBoolByName() : ms_customproperty
  • setPropValCharByName() : ms_customproperty
  • setPropValFloatByName() : ms_customproperty
  • setPropValInt64ByName() : ms_customproperty
  • setPropValIntByName() : ms_customproperty
  • setPropValStringByName() : ms_customproperty
  • setPropValStringByNumber() : ms_customproperty
  • setProteinFamilySwitch() : ms_mascotoptions
  • setProteinRatioType() : ms_quantitation , ms_customquantitation , ms_ms2quantitation , ms_quant_method
  • setProteins() : ms_quant_normalisation
  • setProteinsInResultsFile() : ms_mascotoptions
  • setProtocol() : ms_quant_method
  • setProtScoreType() : ms_quant_method
  • setProxyPassword() : ms_connection_settings , ms_mascotoptions
  • setProxyServer() : ms_mascotoptions , ms_connection_settings
  • setProxyServerType() : ms_connection_settings
  • setProxyType() : ms_mascotoptions
  • setProxyUsername() : ms_mascotoptions , ms_connection_settings
  • setQuality() : ms_quant_method
  • setQuantNormalisation() : ms_ms2quantitation
  • setQuantOutliers() : ms_ms2quantitation , ms_customquantitation , ms_quantitation
  • setQuickRefSearch() : ms_taxonomyrules
  • setRC() : ms_matrix
  • setRecordID() : ms_umod_modification
  • setRedirectPolicy() : ms_connection_settings
  • setReferenceAccession() : ms_quant_average
  • setReferenceAmount() : ms_quant_average
  • setReferenceDatabase() : ms_quant_average
  • setReferenceFasta() : ms_libraryoptions
  • setRemoveOldIndexFiles() : ms_mascotoptions
  • setReplicate() : ms_quant_protocol
  • setReportBuilderColumnArrangement() : ms_mascotoptions
  • setReportDetail() : ms_quant_method
  • setReporter() : ms_quant_protocol
  • setReporterTol() : ms_quant_reporter
  • setReporterTolUnit() : ms_quant_reporter
  • setReportNumberChoice() : ms_mascotoptions
  • setReportRatioInFile() : ms_ms2quantitation
  • setReqPepNeutralLoss() : ms_modification
  • setRequireBoldRed() : ms_mascotoptions , ms_quant_method
  • setRequired() : ms_quant_modgroup , ms_quant_pepneutralloss
  • setResfileCache() : ms_mascotoptions
  • setResidueMasses() : ms_masses
  • setResidueModification() : ms_masses
  • setResultsCache() : ms_mascotoptions
  • setResultsFileFormatVersion() : ms_mascotoptions
  • setResultsFullURL() : ms_mascotoptions
  • setResultsFullURL_2() : ms_mascotoptions
  • setResultsPerlScript() : ms_mascotoptions
  • setResultsPerlScript_2() : ms_mascotoptions
  • setReviewColDisplay() : ms_mascotoptions
  • setReviewColWidth() : ms_mascotoptions
  • setRow() : ms_treecluster
  • setRule() : ms_parserule_plus
  • setRuleStr() : ms_parserule
  • setSatellite() : ms_quant_component
  • setSaveEveryLastQueryAsc() : ms_mascotoptions
  • setSaveLastQueryAsc() : ms_mascotoptions
  • setSchemaDirectory() : ms_quant_configfile
  • setSchemaFileName() : ms_quant_configfile , ms_umod_configfile , ms_crosslinking_configfile
  • setScope() : ms_crosslinking_method
  • setSearchLogFile() : ms_mascotoptions
  • setSearchSubmitMode() : ms_mascotoptions
  • setSecsToWaitForNodeAtStartup() : ms_clusterparams
  • setSectionAvailable() : ms_clusterparams , ms_mascotoptions , ms_processoroptions , ms_unigeneoptions , ms_taxonomyrules , ms_parseoptions , ms_cronoptions , ms_databases , ms_libraryoptions , ms_wwwoptions
  • setSecurityEnabled() : ms_security_options
  • setSelection() : ms_quant_average
  • setSelectSwitch() : ms_mascotoptions
  • setSemiSpecific() : ms_enzyme
  • setSendmailPath() : ms_mascotoptions
  • setSeparateLockMem() : ms_mascotoptions
  • setSequence() : ms_quant_normalisation_peptide
  • setSeriesUsed() : ms_fragmentationrules
  • setSessionID() : ms_connection_settings
  • setSessionTimeout() : ms_security_options
  • setSettings() : ms_crosslinking_method
  • setShift() : ms_quant_correction
  • setShowAllFromErrorTolerant() : ms_mascotoptions
  • setShowSubsets() : ms_mascotoptions
  • setShowSubSets() : ms_quant_method
  • setShowSubsets() : ms_mascotoptions
  • setSigThreshold() : ms_mascotoptions
  • setSigThresholdValue() : ms_quant_method
  • setSimpleRatio() : ms_quant_integration
  • setSingleHit() : ms_mascotresults_params
  • setSinglyCharged() : ms_fragmentationrules
  • setSite() : ms_quant_unmodified , ms_quant_specificity , ms_umod_specificity
  • setSiteAnalysisMD10Prob() : ms_mascotoptions
  • setSortUnassigned() : ms_mascotoptions
  • setSource() : ms_quant_integration , ms_umod_xref
  • setSpecGroup() : ms_umod_specificity
  • setSpeciesFormatRegex() : ms_taxonomyrules
  • setSpectraPerLibraryBlock() : ms_mascotoptions
  • setSpectrumViewerColourSchemeString() : ms_mascotoptions
  • setSpectrumViewerDefaultColourSchemeName() : ms_mascotoptions
  • setSplitDataFileSize() : ms_mascotoptions
  • setSplitNumberOfQueries() : ms_mascotoptions
  • setSrcDatabaseRule() : ms_taxonomyrules
  • setStoreModPermutations() : ms_mascotoptions
  • setStrategy() : ms_crosslinking_method
  • setStrRule() : ms_taxonomyrules
  • setSubsetsThreshold() : ms_mascotresults
  • setSummedModsStr() : ms_peptide
  • setSVGSpectrumSwitch() : ms_mascotoptions
  • setSymbol() : ms_umod_elemref , ms_quant_element
  • setTargetFDR() : ms_mascotresults_params
  • setTargetFDRPercentage() : ms_mascotoptions
  • setTargetFDRType() : ms_mascotresults_params
  • setTaxBrowserUrl() : ms_mascotoptions
  • setTaxonomyParseRuleIndex() : ms_databaseoptions
  • setTaxonomyRules() : ms_datfile
  • setTestDirectory() : ms_mascotoptions
  • setText() : ms_umod_xref
  • setThreeLetter() : ms_umod_aminoacid
  • setTitle() : ms_fragmentationrules , ms_enzyme , ms_quant_localdef , ms_umod_element , ms_modification , ms_umod_aminoacid , ms_umod_modification , ms_umod_modbrick , ms_taxonomychoice
  • setTitleSource() : ms_modification
  • setToleranceInDa() : ms_libraryoptions
  • setToleranceInPPM() : ms_libraryoptions
  • setTotalIntensity() : ms_quant_quality
  • setTotalIntensityThreshold() : ms_quant_quality
  • setType() : ms_quant_correction , ms_wwwentry
  • setUnigeneIndexFile() : ms_mascotresults_params
  • setUniGeneOptions() : ms_datfile
  • setUniqueJobStartNumber() : ms_mascotoptions
  • setUniquePepseq() : ms_quant_quality
  • setUnixDirPerm() : ms_mascotoptions
  • setUnixWebUserGroup() : ms_mascotoptions
  • setUrl() : ms_umod_xref
  • setUseHTTPProxyForFTP() : ms_connection_settings , ms_mascotoptions
  • setUseHTTPProxyForHTTPS() : ms_mascotoptions , ms_connection_settings
  • setUsePeptideSummary() : ms_mascotresults_params
  • setUserAgent() : ms_connection_settings
  • setUsernameOfPoster() : ms_umod_modification
  • setUserType() : ms_user
  • setUseSessionCookies() : ms_security_options
  • setValue() : ms_xml_parameter , ms_crosslinking_monolink , ms_crosslinking_accession , ms_http_client_mime
  • setValueWithFilename() : ms_http_client_mime
  • setVarModsStr() : ms_peptide
  • setVerifySessionIPAddress() : ms_security_options
  • setVmemory() : ms_mascotoptions
  • setWWWOptions() : ms_datfile
  • setXicMaxWidth() : ms_quant_integration
  • setXicSmoothing() : ms_quant_integration
  • setXicThreshold() : ms_quant_integration
  • setXMLschemaFilePath() : ms_mascotresfile
  • severityAsText() : ms_loggingmonitor
  • showInLongList() : ms_umod_specificity
  • showInShortList() : ms_umod_specificity
  • size() : ms_peptide_quant_key_vector , ms_linker_site_vector
  • sizei() : ms_matrix
  • sizej() : ms_matrix
  • snedecorsCriticalValue() : ms_quant_stats
  • sortedMedian() : ms_quant_stats
  • sortModifications() : ms_modfile
  • sortPeptides() : ms_protein
  • sortUsers() : ms_security
  • startIteratePeptides() : ms_aahelper
  • staticGetPercolatorFileNames() : ms_mascotresfile
  • stopIteratePeptides() : ms_aahelper
  • stripLastFolder() : ms_fileutilities
  • studentsCriticalValue() : ms_quant_stats
  • submitSearch() : ms_http_client_session
  • sum() : ms_quant_stats
  • sumsq() : ms_quant_stats
  • swap() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • swilk() : ms_shapiro_wilk
  • systemError() : ms_http_helper_return
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • testDixonsN9() : ms_quant_stats
  • testGrubbsN2() : ms_quant_stats
  • testRosners() : ms_quant_stats
  • testShapiroWilkW() : ms_quant_stats
  • toVector() : ms_linker_site_vector , ms_peptide_quant_key_vector
  • transpose() : ms_matrix
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • uncommentProp() : ms_customproperty
  • unsortedMedian() : ms_quant_stats
  • unspecifiedError() : ms_http_helper_return
  • update() : ms_session
  • updateAccessionByNumber() : ms_crosslinking_accessions
  • updateAllSessionFiles() : ms_security
  • updateAltName() : ms_umod_modification
  • updateAminoAcidByName() : ms_umod_configfile
  • updateAminoAcidByNumber() : ms_umod_configfile
  • updateBreak() : ms_progress_info
  • updateComplete() : ms_progress_info
  • updateComponentByName() : ms_quant_method
  • updateComponentByNumber() : ms_quant_method
  • updateCorrection() : ms_quant_component
  • updateDatabaseByName() : ms_databases
  • updateDatabaseByNumber() : ms_databases
  • updateDenominatorByName() : ms_quant_ratio
  • updateDenominatorByNumber() : ms_quant_ratio
  • updateDoesNotPairWithByNumber() : ms_crosslinking_linker
  • updateElement() : ms_quant_composition
  • updateElementByName() : ms_umod_configfile
  • updateElementByNumber() : ms_umod_configfile
  • updateElemRef() : ms_umod_aminoacid , ms_umod_composition , ms_umod_modbrick
  • updateEnzymeByName() : ms_enzymefile
  • updateEnzymeByNumber() : ms_enzymefile
  • updateExclusion() : ms_quant_method
  • updateFail() : ms_progress_info
  • updateForInstaller() : ms_datfile
  • updateGroup() : ms_security
  • updateIgnore() : ms_quant_localdef , ms_umod_modification
  • updateIndeterminate() : ms_progress_info
  • updateInstrumentByName() : ms_fragrulesfile
  • updateInstrumentByNumber() : ms_fragrulesfile
  • updateIonSeries() : ms_quant_multiplex
  • updateIsotope() : ms_quant_component
  • updateLinkerByNumber() : ms_crosslinking_linkers
  • updateLocalDefinition() : ms_quant_modgroup
  • updateMasses() : ms_umod_composition , ms_umod_configfile , ms_umod_modification
  • updateMethodByName() : ms_crosslinking_configfile , ms_quant_configfile
  • updateMethodByNumber() : ms_quant_configfile , ms_crosslinking_configfile
  • updateModBrickByName() : ms_umod_configfile
  • updateModBrickByNumber() : ms_umod_configfile
  • updateModificationByName() : ms_modfile , ms_umod_configfile
  • updateModificationByNumber() : ms_modfile , ms_umod_configfile
  • updateModificationGroupByName() : ms_quant_method , ms_quant_component
  • updateModificationGroupByNumber() : ms_quant_component , ms_quant_method
  • updateMonoLinkByNumber() : ms_crosslinking_linker
  • updateNeutralLoss() : ms_umod_specificity , ms_quant_specificity
  • updateNumeratorByName() : ms_quant_ratio
  • updateNumeratorByNumber() : ms_quant_ratio
  • updateParameterByName() : ms_quant_parameters , ms_crosslinking_parameters
  • updateParameterByNumber() : ms_crosslinking_parameters , ms_quant_parameters
  • updatePassword() : ms_security
  • updatePepNeutralLoss() : ms_umod_specificity , ms_quant_specificity
  • updatePeptide() : ms_quant_normalisation_peptides
  • updateProgress() : ms_progress_info
  • updateProtein() : ms_quant_normalisation_proteins
  • updateReportRatioByName() : ms_quant_method
  • updateReportRatioByNumber() : ms_quant_method
  • updateSeq() : ms_quant_method
  • updateSpecificity() : ms_umod_modification , ms_quant_localdef
  • updateTask() : ms_security_tasks
  • updateUnmodified() : ms_quant_modgroup
  • updateUser() : ms_security
  • updateXref() : ms_umod_modification
  • uploadDistillerXmlResultsFile() : ms_http_client_search
  • useInErrorTolerant() : ms_umod_specificity
  • userLogin() : ms_http_client
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • validateDeep() : ms_crosslinking_accession , ms_crosslinking_accessions , ms_crosslinking_linker , ms_quant_average , ms_quant_method , ms_quant_ratio , ms_quant_replicate , ms_quant_modgroup , ms_quant_reporter , ms_quant_satellite , ms_quant_component , ms_quant_moverz , ms_quant_specificity , ms_quant_unmodified , ms_quant_multiplex , ms_umod_aminoacid , ms_umod_composition , ms_crosslinking_linkers , ms_quant_element , ms_quant_neutralloss , ms_umod_element , ms_umod_elemref , ms_quant_normalisation , ms_umod_modbrick , ms_umod_modification , ms_quant_composition , ms_quant_normalisation_peptide , ms_umod_neutralloss , ms_umod_specificity , ms_quant_normalisation_peptides , ms_umod_xref , ms_xml_parameter , ms_crosslinking_does_not_pair_with , ms_crosslinking_method , ms_quant_correction , ms_quant_normalisation_protein , ms_xml_parameters , ms_quant_normalisation_proteins , ms_quant_integration , ms_quant_numerator , ms_quant_outliers , ms_crosslinking_monolink , ms_quant_isotope , ms_quant_pepneutralloss , ms_quant_precursor , ms_quant_localdef , ms_quant_protocol , ms_quant_quality
  • validateDocument() : ms_crosslinking_configfile , ms_quant_configfile , ms_umod_configfile
  • validatePassword() : ms_user
  • validateShallow() : ms_crosslinking_accession , ms_quant_normalisation_peptide , ms_umod_aminoacid , ms_umod_xref , ms_quant_neutralloss , ms_quant_correction , ms_quant_numerator , ms_quant_outliers , ms_quant_precursor , ms_quant_protocol , ms_quant_replicate , ms_quant_reporter , ms_quant_specificity , ms_quant_unmodified , ms_umod_elemref , ms_umod_modbrick , ms_umod_neutralloss , ms_umod_specificity , ms_xml_parameters , ms_quant_integration , ms_quant_isotope , ms_xml_parameter , ms_quant_component , ms_quant_element , ms_crosslinking_method , ms_crosslinking_linker , ms_crosslinking_accessions , ms_quant_modgroup , ms_quant_multiplex , ms_quant_normalisation , ms_quant_normalisation_proteins , ms_quant_pepneutralloss , ms_quant_ratio , ms_quant_satellite , ms_umod_element , ms_quant_method , ms_umod_composition , ms_umod_modification , ms_quant_average , ms_quant_composition , ms_quant_localdef , ms_quant_moverz , ms_quant_normalisation_protein , ms_quant_normalisation_peptides , ms_quant_quality , ms_crosslinking_does_not_pair_with , ms_crosslinking_monolink , ms_crosslinking_linkers
  • verifyEnzyme() : ms_enzyme
  • verifyRule() : ms_fragmentationrules
  • verifyThatModsAreInUnimod() : ms_spectral_lib_file
  • versionGreaterOrEqual() : ms_mascotresfile
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • weightedArithmeticMean() : ms_quant_stats
  • weightedArithmeticStandardDeviation() : ms_quant_stats
  • weightedArithmeticStandardError() : ms_quant_stats
  • weightedGeometricMean() : ms_quant_stats
  • weightedGeometricStandardDeviation() : ms_quant_stats
  • willCreateCache() : ms_peptidesummary , ms_mascotresfile , ms_peptidesummary , ms_mascotresfile
  • willMessageBeLogged() : ms_log , ms_errs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • operator< : ms_protein
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • err : ms_errs
  • msg_num_t : ms_log
  • TAX_CHOP_SRC : ms_parserule_plus
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • e
  • l
  • p

- e -

  • ERR_ACCINPEPTIDESTR : ms_errs
  • ERR_ADDPEPTIDES : ms_errs
  • ERR_CANNOT_APPEND_RESFILE : ms_errs
  • ERR_CANNOT_APPEND_RESFILE_NO_FNAMES : ms_errs
  • ERR_CDB_64_BIT_REMAKE : ms_errs
  • ERR_CDB_BEING_CREATED : ms_errs
  • ERR_CDB_FAIL_LOCK : ms_errs
  • ERR_CDB_FAIL_REMOVE : ms_errs
  • ERR_CDB_FAIL_UNLOCK : ms_errs
  • ERR_CDB_INCOMPLETE_NO_RETRY : ms_errs
  • ERR_CDB_INCOMPLETE_RETRY : ms_errs
  • ERR_CDB_OLD_VER_NO_RETRY : ms_errs
  • ERR_CDB_OLD_VER_RETRY : ms_errs
  • ERR_CDB_SOURCE_CHANGE_NO_RETRY : ms_errs
  • ERR_CDB_SOURCE_CHANGE_RETRY : ms_errs
  • ERR_CDB_TOO_LARGE : ms_errs
  • ERR_DUPE_ACCESSION : ms_errs
  • ERR_DUPLICATE_KEY : ms_errs
  • ERR_FAIL_CDB_INIT : ms_errs
  • ERR_FAIL_CLOSE_FILE : ms_errs
  • ERR_FAIL_MK_CACHE_DIR : ms_errs
  • ERR_FAIL_MK_CDB_FILE : ms_errs
  • ERR_FAIL_OPEN_DAT_FILE : ms_errs
  • ERR_INVALID_CACHE_DIR : ms_errs
  • ERR_INVALID_CDB_FILE : ms_errs
  • ERR_INVALID_NUMQUERIES : ms_errs
  • ERR_INVALID_PROTDB : ms_errs
  • ERR_INVALID_RESFILE : ms_errs
  • ERR_MALFORMED_DRANGE : ms_errs
  • ERR_MALFORMED_ERR_TOL : ms_errs
  • ERR_MALFORMED_TAG : ms_errs
  • ERR_MALFORMED_TERMS : ms_errs
  • ERR_MISSING_CDB_FILE : ms_errs
  • ERR_MISSING_PERCOLATOR_FILE : ms_errs
  • ERR_MISSINGENTRY : ms_errs
  • ERR_MISSINGHIT : ms_errs
  • ERR_MISSINGSECTION : ms_errs
  • ERR_MISSINGSECTIONEND : ms_errs
  • ERR_MSP_BIND_INVALID_CPU : ms_errs
  • ERR_MSP_CACHE_DATAOFFSETINVALID : ms_errs
  • ERR_MSP_CACHE_DUPLICATESTREAMID : ms_errs
  • ERR_MSP_CACHE_FILESEEKFAILED : ms_errs
  • ERR_MSP_CACHE_INVALIDFORMAT : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMID : ms_errs
  • ERR_MSP_CACHE_INVALIDSTREAMPOSITION : ms_errs
  • ERR_MSP_CACHE_INVALIDVERSION : ms_errs
  • ERR_MSP_CACHE_MODIFYCLOSED : ms_errs
  • ERR_MSP_CACHE_MODIFYREADONLYMODE : ms_errs
  • ERR_MSP_CACHE_OPENFAILED : ms_errs
  • ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD : ms_errs
  • ERR_MSP_CACHE_READFAILED : ms_errs
  • ERR_MSP_CACHE_SIGNATUREINVALID : ms_errs
  • ERR_MSP_CACHE_SLREF_UPDATE : ms_errs
  • ERR_MSP_CACHE_STREAMNOTFOUND : ms_errs
  • ERR_MSP_CACHE_UNINITIALISEDSTREAM : ms_errs
  • ERR_MSP_CACHE_WRITEFAILED : ms_errs
  • ERR_MSP_CACHE_WRITETRUNCATED : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_ET : ms_errs
  • ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_COLOURSCHEME_INVALID : ms_errs
  • ERR_MSP_COMPILE_PARSE_RULE : ms_errs
  • ERR_MSP_CONFLICT_BETWEEN_MODS : ms_errs
  • ERR_MSP_CRON_INVALID_CHAR : ms_errs
  • ERR_MSP_CRON_INVALID_NUMBER : ms_errs
  • ERR_MSP_CRON_INVALID_STAR : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_COMMA : ms_errs
  • ERR_MSP_CRON_NO_NUM_BEFORE_MINUS : ms_errs
  • ERR_MSP_CRON_TOO_MANY_JOBS : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDLOAD : ms_errs
  • ERR_MSP_CROSSLINKING_FAILEDSAVE : ms_errs
  • ERR_MSP_CROSSLINKING_INVALID_LINK : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_LINKS : ms_errs
  • ERR_MSP_CROSSLINKING_MULTI_PEPTIDE : ms_errs
  • ERR_MSP_CROSSLINKING_VARMOD_CONFLICT : ms_errs
  • ERR_MSP_CUSTQUANT_FAILEDINIT : ms_errs
  • ERR_MSP_CUSTQUANT_PROTR_UNIM : ms_errs
  • ERR_MSP_DB_USES_MISSING_RULE : ms_errs
  • ERR_MSP_DIFFERENT_1ST_PASS_THR_ET : ms_errs
  • ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED : ms_errs
  • ERR_MSP_DUP_TAXONOMYRULE : ms_errs
  • ERR_MSP_DUPLICATE_MOD : ms_errs
  • ERR_MSP_EMPTY_MOD : ms_errs
  • ERR_MSP_ENZYME_DEFINITION_PROBLEM : ms_errs
  • ERR_MSP_ENZYME_FILE_FORMAT : ms_errs
  • ERR_MSP_ENZYME_TOO_MANY_RULES : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_INVALID : ms_errs
  • ERR_MSP_EXEC_AFTER_SEARCH_LOGGING : ms_errs
  • ERR_MSP_FAIL_GET_PROCESS_AFFINITY : ms_errs
  • ERR_MSP_FAIL_GET_SYSINFO : ms_errs
  • ERR_MSP_FAIL_HWLOC_INIT : ms_errs
  • ERR_MSP_FAIL_HWLOC_LOAD : ms_errs
  • ERR_MSP_FAIL_PROCESSOR_BIND : ms_errs
  • ERR_MSP_FAIL_STAT : ms_errs
  • ERR_MSP_FAIL_THREAD_BIND : ms_errs
  • ERR_MSP_FAIL_UTIME : ms_errs
  • ERR_MSP_FAILED_TO_CLOSE_FILE : ms_errs
  • ERR_MSP_FAILED_TO_OPEN_FILE : ms_errs
  • ERR_MSP_FAILED_TO_WRITE_FILE : ms_errs
  • ERR_MSP_FILE_DOESNT_EXIST : ms_errs
  • ERR_MSP_FRAGMENTATION_RULES : ms_errs
  • ERR_MSP_GET_VOLUME_INFO : ms_errs
  • ERR_MSP_HTTP_ABORTEDBYUSER : ms_errs
  • ERR_MSP_HTTP_BADHTTPSTATUS : ms_errs
  • ERR_MSP_HTTP_CHANGEPASSWORDDISABLED : ms_errs
  • ERR_MSP_HTTP_CLOSECONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSEREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_CLOSESESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_DOWNLOADFAILED : ms_errs
  • ERR_MSP_HTTP_ERROR : ms_errs
  • ERR_MSP_HTTP_GETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_GETRESULTSFILENAME : ms_errs
  • ERR_MSP_HTTP_HEADERFAILED : ms_errs
  • ERR_MSP_HTTP_INVALID_URL : ms_errs
  • ERR_MSP_HTTP_LOGINERROR : ms_errs
  • ERR_MSP_HTTP_LOGINERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINPARSERERRORINT : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERROR : ms_errs
  • ERR_MSP_HTTP_LOGINSERVERERRORINT : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONS10FAILED : ms_errs
  • ERR_MSP_HTTP_MAXCONECTIONSFAILED : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGINERROR : ms_errs
  • ERR_MSP_HTTP_MISSINGLOGININFO : ms_errs
  • ERR_MSP_HTTP_NORESPONSE : ms_errs
  • ERR_MSP_HTTP_OPENCONNECTIONFAILED : ms_errs
  • ERR_MSP_HTTP_OPENOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_OPENREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_OPENSESSIONFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYDATAFAILED : ms_errs
  • ERR_MSP_HTTP_QUERYSTATUSFAILED : ms_errs
  • ERR_MSP_HTTP_READDATAFAILED : ms_errs
  • ERR_MSP_HTTP_READRESPONSEFAILED : ms_errs
  • ERR_MSP_HTTP_RELOGINFAILED : ms_errs
  • ERR_MSP_HTTP_SENDREQUESTFAILED : ms_errs
  • ERR_MSP_HTTP_SESSIONALREADYOPEN : ms_errs
  • ERR_MSP_HTTP_SETHTTPPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYPASSWORDFAILED : ms_errs
  • ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED : ms_errs
  • ERR_MSP_HTTP_SETREDIRECTFAILED : ms_errs
  • ERR_MSP_HTTP_TRANSMISSION_FAILED : ms_errs
  • ERR_MSP_HTTP_VERSIONERROR : ms_errs
  • ERR_MSP_HTTP_WEBAUTHERROR : ms_errs
  • ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED : ms_errs
  • ERR_MSP_HTTP_XMLUPLOADFAILED : ms_errs
  • ERR_MSP_IN_CLUSTER_SECTION : ms_errs
  • ERR_MSP_IN_MASCOT_DAT_DB_SECT : ms_errs
  • ERR_MSP_IN_MASSES_FILE : ms_errs
  • ERR_MSP_IN_MODS_FILE : ms_errs
  • ERR_MSP_IN_OPTIONS_SECTION : ms_errs
  • ERR_MSP_IN_TAXONOMY_SECTION : ms_errs
  • ERR_MSP_INCOMPATIBLE_TAX_RULES : ms_errs
  • ERR_MSP_INST_CANTGETHOSTNAME : ms_errs
  • ERR_MSP_INST_FAILADDPARSERULE : ms_errs
  • ERR_MSP_INST_INVALIDCPUINFO : ms_errs
  • ERR_MSP_INST_MISSINGDATABASE : ms_errs
  • ERR_MSP_INVALID_CPU_PACKAGE_NUM : ms_errs
  • ERR_MSP_INVALID_LOGICAL_CPU_NUM : ms_errs
  • ERR_MSP_INVALID_MASS_IN_MASSES_FILE : ms_errs
  • ERR_MSP_INVALID_NUM_LICENSED : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE : ms_errs
  • ERR_MSP_INVALID_PARSE_RULE_NO : ms_errs
  • ERR_MSP_INVALID_PROCESSOR_LINE : ms_errs
  • ERR_MSP_LICENSE_DES_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_EXPIRED : ms_errs
  • ERR_MSP_LICENSE_INTERNAL_CONFIG : ms_errs
  • ERR_MSP_LICENSE_LINE_CHECKSUM : ms_errs
  • ERR_MSP_LICENSE_LINE_INVALID : ms_errs
  • ERR_MSP_LICENSE_NOT_YET_AVAIL : ms_errs
  • ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED : ms_errs
  • ERR_MSP_MALFORMED_PEPTIDE : ms_errs
  • ERR_MSP_MASCOT_NOT_RUNNING : ms_errs
  • ERR_MSP_MAX_PREFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_SUFFIX_REMOVES : ms_errs
  • ERR_MSP_MAX_TAX_NO_BREAKS : ms_errs
  • ERR_MSP_MISSING_DEFINITION_END : ms_errs
  • ERR_MSP_MISSING_ENZYME_TITLE : ms_errs
  • ERR_MSP_MISSING_ET_MOD : ms_errs
  • ERR_MSP_MISSING_MASCOT_DAT : ms_errs
  • ERR_MSP_MISSING_MONOLINK_MOD : ms_errs
  • ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE : ms_errs
  • ERR_MSP_MISSING_SECTION : ms_errs
  • ERR_MSP_MISSING_SL_MOD : ms_errs
  • ERR_MSP_MOD_MUST_BE_VAR : ms_errs
  • ERR_MSP_MS1QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_DROP : ms_errs
  • ERR_MSP_MS1QUANTITATION_HITREF_NEW : ms_errs
  • ERR_MSP_MS2QUANTITATION_COMPONENTS : ms_errs
  • ERR_MSP_MS2QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_NO_SUM : ms_errs
  • ERR_MSP_MS2QUANTITATION_NORM_UNIMP : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTR_UNIM : ms_errs
  • ERR_MSP_MS2QUANTITATION_PROTWEIGH : ms_errs
  • ERR_MSP_MS2QUANTITATION_QUERY_SECS : ms_errs
  • ERR_MSP_NEED_1_EXP_IN_PARSE_RULE : ms_errs
  • ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK : ms_errs
  • ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY : ms_errs
  • ERR_MSP_NIST_INDEX_OUT_OF_RANGE : ms_errs
  • ERR_MSP_NIST_MODIFICATION_NOT_FOUND : ms_errs
  • ERR_MSP_NIST_MSP_INCONSISTENT_MODS : ms_errs
  • ERR_MSP_NIST_MSP_INVALID_LINE : ms_errs
  • ERR_MSP_NIST_MSP_MISSING_PARAMETER : ms_errs
  • ERR_MSP_NIST_MSP_NO_CREATE_CDB : ms_errs
  • ERR_MSP_NIST_MSP_NO_SPECTRA : ms_errs
  • ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM : ms_errs
  • ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE : ms_errs
  • ERR_MSP_NIST_SAVE_ZERO_SPECTRA : ms_errs
  • ERR_MSP_NO_COMMAS_IN_MOD_NAME : ms_errs
  • ERR_MSP_NO_ENZYME_SET : ms_errs
  • ERR_MSP_NO_LICENSE_FILE : ms_errs
  • ERR_MSP_NO_REGEX_MATCH : ms_errs
  • ERR_MSP_NO_SUCH_MOD : ms_errs
  • ERR_MSP_PARSE_LEN_EXCEED : ms_errs
  • ERR_MSP_PROCESSOR_NOT_IN_SET : ms_errs
  • ERR_MSP_QUANT_ACCESSION_NOT_FOUND : ms_errs
  • ERR_MSP_QUANT_CDB_MATCH_STREAM : ms_errs
  • ERR_MSP_QUANT_CDB_MISSING_KEY : ms_errs
  • ERR_MSP_QUANT_EMPTY_REF_ACCESSION : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_MATCH : ms_errs
  • ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE : ms_errs
  • ERR_MSP_QUANT_FAILEDLOAD : ms_errs
  • ERR_MSP_QUANT_FAILEDSAVE : ms_errs
  • ERR_MSP_QUANT_HELPER_FAILEDINIT : ms_errs
  • ERR_MSP_QUANT_INVALID_REF_AMOUNT : ms_errs
  • ERR_MSP_QUANT_MISSING_COMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADCOMPONENT : ms_errs
  • ERR_MSP_QUANTITATION_BADMETHOD : ms_errs
  • ERR_MSP_QUANTITATION_FAILEDINIT : ms_errs
  • ERR_MSP_QUANTITATION_NOMETHOD : ms_errs
  • ERR_MSP_REGEX_ERROR : ms_errs
  • ERR_MSP_REPORTBUILDERCOLARR_INVALID : ms_errs
  • ERR_MSP_RESIDUE_AND_TERMINUS_MOD : ms_errs
  • ERR_MSP_RULE_NO_ALREADY_DEFINED : ms_errs
  • ERR_MSP_SECURITY_ACCOUNT_DISABLED : ms_errs
  • ERR_MSP_SECURITY_ADDGROUP : ms_errs
  • ERR_MSP_SECURITY_ADDUSER : ms_errs
  • ERR_MSP_SECURITY_BAD_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_BAD_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_CMDLINE_CGI : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP : ms_errs
  • ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_GROUP : ms_errs
  • ERR_MSP_SECURITY_DEL_SPECIAL_USER : ms_errs
  • ERR_MSP_SECURITY_DELETEGROUP : ms_errs
  • ERR_MSP_SECURITY_DELUSER : ms_errs
  • ERR_MSP_SECURITY_DIFFERENTIPADDR : ms_errs
  • ERR_MSP_SECURITY_DISABLE_ADMIN : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_GROUP_NAME_U : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_ID : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME : ms_errs
  • ERR_MSP_SECURITY_DUPE_USER_NAME_U : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_GROUP : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_SEC : ms_errs
  • ERR_MSP_SECURITY_FAIL_LOAD_USER : ms_errs
  • ERR_MSP_SECURITY_FAIL_SAVE_SEC : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRA : ms_errs
  • ERR_MSP_SECURITY_FAILGETINTEGRAURL : ms_errs
  • ERR_MSP_SECURITY_GETALLGROUPIDS : ms_errs
  • ERR_MSP_SECURITY_GETALLUSERIDS : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETGROUPFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETGROUPOK : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS1 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS2 : ms_errs
  • ERR_MSP_SECURITY_GETINTEGRAUSERS3 : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSFAIL : ms_errs
  • ERR_MSP_SECURITY_GETPERMTASKSOK : ms_errs
  • ERR_MSP_SECURITY_GETUSERFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDFAIL : ms_errs
  • ERR_MSP_SECURITY_GETUSERFROMIDOK : ms_errs
  • ERR_MSP_SECURITY_GETUSEROK : ms_errs
  • ERR_MSP_SECURITY_GROUPID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_INTEGRACONNFORMAT : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDCO : ms_errs
  • ERR_MSP_SECURITY_INTEGRAINVALIDPW : ms_errs
  • ERR_MSP_SECURITY_INVALID_SESSION_ID : ms_errs
  • ERR_MSP_SECURITY_INVALIDPASSWORD : ms_errs
  • ERR_MSP_SECURITY_INVALIDSESSION : ms_errs
  • ERR_MSP_SECURITY_INVALIDUSER : ms_errs
  • ERR_MSP_SECURITY_LOADINGSESS : ms_errs
  • ERR_MSP_SECURITY_LOADSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MISSINGSESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_MSSESSCOOKIE : ms_errs
  • ERR_MSP_SECURITY_MSSESSINTEGRA : ms_errs
  • ERR_MSP_SECURITY_MSSESSIONCTOR : ms_errs
  • ERR_MSP_SECURITY_MSSESSLOGIN : ms_errs
  • ERR_MSP_SECURITY_MSSESSRESULTSPERM : ms_errs
  • ERR_MSP_SECURITY_NO_GUEST_PWD : ms_errs
  • ERR_MSP_SECURITY_NO_INTEGRA_LOGIN : ms_errs
  • ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR : ms_errs
  • ERR_MSP_SECURITY_NOCREATEGUEST : ms_errs
  • ERR_MSP_SECURITY_NOSAVEPARAMS : ms_errs
  • ERR_MSP_SECURITY_NOT_ADMIN_SESSION : ms_errs
  • ERR_MSP_SECURITY_NOT_ENABLED : ms_errs
  • ERR_MSP_SECURITY_NOT_INTEGRA_USER : ms_errs
  • ERR_MSP_SECURITY_NOTLOGGEDIN : ms_errs
  • ERR_MSP_SECURITY_NOTNORMALUSER : ms_errs
  • ERR_MSP_SECURITY_OLD_PW_INVALID : ms_errs
  • ERR_MSP_SECURITY_PASSWORD_TOO_SHORT : ms_errs
  • ERR_MSP_SECURITY_PASSWORDEXPIRED : ms_errs
  • ERR_MSP_SECURITY_SAMEPASSWORD : ms_errs
  • ERR_MSP_SECURITY_SAVESESSIONFILE : ms_errs
  • ERR_MSP_SECURITY_SESSIONDESTROYED : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT1 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT2 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT3 : ms_errs
  • ERR_MSP_SECURITY_SPOOFATTEMPT4 : ms_errs
  • ERR_MSP_SECURITY_TIMEDOUT : ms_errs
  • ERR_MSP_SECURITY_UPDATEALLSESSFILES : ms_errs
  • ERR_MSP_SECURITY_UPDATEGROUP : ms_errs
  • ERR_MSP_SECURITY_UPDATEPW : ms_errs
  • ERR_MSP_SECURITY_UPDATESESS : ms_errs
  • ERR_MSP_SECURITY_UPDATEUSER : ms_errs
  • ERR_MSP_SECURITY_USERID_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_USERNAME_NOT_FOUND : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRACO2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW1 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW2 : ms_errs
  • ERR_MSP_SECURITY_VALIDATEINTEGRAPW3 : ms_errs
  • ERR_MSP_SESSION_UTIME_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_FAIL : ms_errs
  • ERR_MSP_SL_SCORING_MODEL_WARN : ms_errs
  • ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR : ms_errs
  • ERR_MSP_SYSMP_FAIL : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_ET : ms_errs
  • ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS : ms_errs
  • ERR_MSP_TAXONOMY_CONFLICT_PARENTS : ms_errs
  • ERR_MSP_TAXONOMY_DEFINITION_END : ms_errs
  • ERR_MSP_TAXONOMY_INVALID_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_MISSING_NODE_FILE : ms_errs
  • ERR_MSP_TAXONOMY_NO_COMMAS : ms_errs
  • ERR_MSP_TAXONOMY_NO_TITLE : ms_errs
  • ERR_MSP_TAXONOMY_WRONG_LINE : ms_errs
  • ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE : ms_errs
  • ERR_MSP_TOO_MANY_PROCESSORS : ms_errs
  • ERR_MSP_TOO_MANY_TH_PROCESSORS : ms_errs
  • ERR_MSP_UMOD_FAILEDLOAD : ms_errs
  • ERR_MSP_UMOD_FAILEDSAVE : ms_errs
  • ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT : ms_errs
  • ERR_MSP_WRONG_ICAT_FILTER : ms_errs
  • ERR_MSP_WRONG_MOD_VECTOR : ms_errs
  • ERR_MSP_WWW_SECTION : ms_errs
  • ERR_MSP_XHUNTER_WRONG_FORMAT : ms_errs
  • ERR_MSP_XML_ELEMENT_NOT_FOUND : ms_errs
  • ERR_MSP_XML_FAILEDLOAD : ms_errs
  • ERR_MSP_XML_FAILEDSAVE : ms_errs
  • ERR_MSP_XML_FIELD_NOTFOUND : ms_errs
  • ERR_MSP_XML_INVALID_FIELD_FORMAT : ms_errs
  • ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED : ms_errs
  • ERR_MSP_XML_MEMORY_ERROR : ms_errs
  • ERR_MSP_XML_NO_ROOT_ELEMENT : ms_errs
  • ERR_MSP_XML_SYSTEM_FAILED : ms_errs
  • ERR_MSP_XML_TABLE_NOTFOUND : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDLOAD : ms_errs
  • ERR_MSP_XMLSCHEMA_FAILEDSAVE : ms_errs
  • ERR_MSP_ZIP_BUFTOOSMALL : ms_errs
  • ERR_MSP_ZIP_ENDIAN : ms_errs
  • ERR_MSP_ZIP_INVALIDDATA : ms_errs
  • ERR_MSP_ZIP_LENGTHDIFFERS : ms_errs
  • ERR_MSP_ZIP_NOTSTREAMING : ms_errs
  • ERR_MSP_ZIP_OUTOFMEMORY : ms_errs
  • ERR_MSP_ZIP_STREAMERROR : ms_errs
  • ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG : ms_errs
  • ERR_MSP_ZIP_UNKNOWN : ms_errs
  • ERR_MSP_ZIP_VERSIONERROR : ms_errs
  • ERR_MSP_ZIP_ZEROLENGTH : ms_errs
  • ERR_NEED_64_BIT : ms_errs
  • ERR_NO_ERR_TOL_PARENT : ms_errs
  • ERR_NO_ERROR : ms_errs
  • ERR_NO_UNIGENE_FILE : ms_errs
  • ERR_NOMEM : ms_errs
  • ERR_NOSUCHFILE : ms_errs
  • ERR_NULL_ACC_PEP_SUM : ms_errs
  • ERR_NULL_ACC_PROT_SUM : ms_errs
  • ERR_OLDRESULTSFILE : ms_errs
  • ERR_PEPSUMMPEPGET : ms_errs
  • ERR_PEPTIDESTR : ms_errs
  • ERR_PROTSUMM : ms_errs
  • ERR_PROTSUMMPEP : ms_errs
  • ERR_QUERYOUTOFRANGE : ms_errs
  • ERR_READINGFILE : ms_errs
  • ERR_RESFILE_INVALID_DB_TYPE : ms_errs
  • ERR_RESFILE_LINKED_SITES : ms_errs
  • ERR_RESFILE_LOOPLINKED_SITES : ms_errs
  • ERR_RESFILE_MISSING_QEXP : ms_errs
  • ERR_RESULTS_NOT_CREATED : ms_errs
  • ERR_UNASSIGNED_PROG : ms_errs
  • ERR_UNASSIGNED_RANGE : ms_errs
  • ERR_UNASSIGNED_UNK : ms_errs
  • ERR_UNIGENE_MULTIDB : ms_errs
  • ERR_WRITE_CDB_FILE : ms_errs
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • e
  • l
  • p

- l -

  • LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES : ms_log
  • LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER : ms_log
  • LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK : ms_log
  • LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK : ms_log
  • LOGMSG_AAHELPER_CFR_MASSES_VALUE : ms_log
  • LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE : ms_log
  • LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT : ms_log
  • LOGMSG_AAHELPER_CFR_START_FRAGMENTS : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_END : ms_log
  • LOGMSG_AAHELPER_CROSSLINKED_START : ms_log
  • LOGMSG_AAHELPER_CUMULATIVE_MASS_NL : ms_log
  • LOGMSG_AAHELPER_ETMOD_LOOKUP : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_ADD : ms_log
  • LOGMSG_AAHELPER_IMMONIUM_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_ADD : ms_log
  • LOGMSG_AAHELPER_INTERNAL_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_MASTER_NL_VALS : ms_log
  • LOGMSG_AAHELPER_MULTINL_INDICES : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD : ms_log
  • LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT : ms_log
  • LOGMSG_AAHELPER_SERIES_PARAMS : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG : ms_log
  • LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT : ms_log
  • LOGMSG_AAHELPER_TOTAL_NL_VALS : ms_log
  • LOGMSG_CUSTQUANT_ADD_QUANT_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_ALL_KEY : ms_log
  • LOGMSG_CUSTQUANT_REMOVE_KEY : ms_log
  • LOGMSG_DBG1_NUM_PROCESSOR_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_GETAUTODETECT : ms_log
  • LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_MT_STATUS : ms_log
  • LOGMSG_DBG2_CPU_INF_NAME : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_AVAIL : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_GROUPS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_ON_SYS : ms_log
  • LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL : ms_log
  • LOGMSG_DBG2_CPU_INF_PROC_AFFINITY : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_LINE : ms_log
  • LOGMSG_DBG2_CPU_INF_TABLE_TITLE : ms_log
  • LOGMSG_DBG2_CPU_INF_USE_PROCESSES : ms_log
  • LOGMSG_DBG2_NUM_CONFIG_MISMATCH : ms_log
  • LOGMSG_DBG2_NUM_ONLINE_MISMATCH : ms_log
  • LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD : ms_log
  • LOGMSG_DBG3_BINDING_PROCESSORS : ms_log
  • LOGMSG_DBG3_BINDING_THREAD : ms_log
  • LOGMSG_DBG3_CALL_GET_CHIP_MFCTR : ms_log
  • LOGMSG_DBG3_HWLOC_GROUPS : ms_log
  • LOGMSG_DBG3_HWLOC_TREE : ms_log
  • LOGMSG_DBG3_PROCESSOR_NAME : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_START : ms_log
  • LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT : ms_log
  • LOGMSG_GET_THR_REACH_COND : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET : ms_log
  • LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR : ms_log
  • LOGMSG_HTTP_GETRETURNSTRING : ms_log
  • LOGMSG_HTTP_MAXCONECTIONS10FAILED : ms_log
  • LOGMSG_HTTP_MAXCONECTIONSFAILED : ms_log
  • LOGMSG_HTTP_QUERYSTATUSRESULT : ms_log
  • LOGMSG_HTTP_URLSTRING : ms_log
  • LOGMSG_INST_ADDINGDATABASE : ms_log
  • LOGMSG_INST_ADDOPTIONSSECTION : ms_log
  • LOGMSG_INST_APPENDPARSERULE : ms_log
  • LOGMSG_INST_APPENDTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEDBTAXONOMY : ms_log
  • LOGMSG_INST_CHANGEPARSERULE : ms_log
  • LOGMSG_INST_CHANGEPERCOLATORFEATS : ms_log
  • LOGMSG_INST_CHANGEPROTFAMILYSWITCH : ms_log
  • LOGMSG_INST_CLUSTERSECTION : ms_log
  • LOGMSG_INST_FAILSAVEPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_LOGICALPERPHYSICALCPU : ms_log
  • LOGMSG_INST_MASCOTDATOK : ms_log
  • LOGMSG_INST_NOSUBCLUSTERSET : ms_log
  • LOGMSG_INST_NOTMASCOTDATOK : ms_log
  • LOGMSG_INST_NUMTHREADS : ms_log
  • LOGMSG_INST_REMOVEOPTIONSSECTION : ms_log
  • LOGMSG_INST_SAVEDPOSTINSTALLFILE : ms_log
  • LOGMSG_INST_SETOPTIONSSECTION : ms_log
  • LOGMSG_MATRIX_OUTPUT_VALS : ms_log
  • LOGMSG_PEPSUM_GETHIT : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_START : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY : ms_log
  • LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_CLUSTER_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT : ms_log
  • LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_END : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_QUEUE : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS : ms_log
  • LOGMSG_PROTINFER_FIND_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START : ms_log
  • LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST : ms_log
  • LOGMSG_PROTINFER_GROUP_FAMILY_START : ms_log
  • LOGMSG_PROTINFER_GROUP_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY : ms_log
  • LOGMSG_PROTINFER_PEPTIDE_MATRIX : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP : ms_log
  • LOGMSG_PROTINFER_REMOVE_CONFLICTING_START : ms_log
  • LOGMSG_PROTINFER_SINGLETON_FROM_ACC : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_DONE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE : ms_log
  • LOGMSG_PROTINFER_SORT_BY_SCORE_START : ms_log
  • LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT : ms_log
  • LOGMSG_QUANT_ADDED_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_ADDING_PROTEIN_HIT : ms_log
  • LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED : ms_log
  • LOGMSG_QUANT_CLOSING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN : ms_log
  • LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN : ms_log
  • LOGMSG_QUANT_FINISH_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_FINISH_LOAD_CDB : ms_log
  • LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_HELPER_TEST_REQUIRED : ms_log
  • LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES : ms_log
  • LOGMSG_QUANT_LOADING_MATCHES : ms_log
  • LOGMSG_QUANT_OPENING_CACHE_FILE : ms_log
  • LOGMSG_QUANT_REAPPLY_THRESHOLDS : ms_log
  • LOGMSG_QUANT_REMATCHING_INFERRED : ms_log
  • LOGMSG_QUANT_REMOVE_INFERRED_MATCH : ms_log
  • LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE : ms_log
  • LOGMSG_QUANT_START_CALC_COMPLETE : ms_log
  • LOGMSG_QUANT_START_LOAD_CDB : ms_log
  • LOGMSG_QUANT_START_REORDER_AFTER_MERGE : ms_log
  • LOGMSG_QUANT_START_UPDATE_PROT_MATCHES : ms_log
  • LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES : ms_log
  • LOGMSG_QUANT_UPDATING_PEP_EVIDENCE : ms_log
  • LOGMSG_REPORT_FUNCTION_CALLED_BY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3 : ms_log
  • LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4 : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT : ms_log
  • LOGMSG_REPORT_FUNCTION_EXIT_WITH : ms_log
  • LOGMSG_RESFILE_APPEND : ms_log
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • e
  • l
  • p

- p -

  • proteinKeys_ : ms_quantitation
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • ms_computeraddress
  • ms_connection_settings
  • ms_cronjob
  • ms_crosslinking_accession
  • ms_crosslinking_accessions
  • ms_crosslinking_does_not_pair_with
  • ms_crosslinking_linker
  • ms_crosslinking_linkers
  • ms_crosslinking_method
  • ms_crosslinking_monolink
  • ms_customproperty
    • ms_clusterparams
    • ms_cronoptions
    • ms_databases
    • ms_enzyme
    • ms_fragmentationrules
    • ms_libraryoptions
    • ms_mascotfiles
    • ms_mascotoptions
    • ms_modification
    • ms_parseoptions
    • ms_processoroptions
    • ms_taxonomychoice
    • ms_taxonomyrules
    • ms_unigeneoptions
    • ms_wwwoptions
  • ms_databaseoptions
  • ms_dbprocessors
  • ms_distiller_data_quant
  • ms_distiller_data_search
  • ms_distiller_master_search
  • ms_distiller_search_status
  • ms_distiller_sub_project
  • ms_distiller_subsearch
  • ms_errors
    • ms_aahelper
    • ms_crosslinking_configfile
    • ms_datfile
    • ms_distiller_data
    • ms_distiller_master_project
    • ms_distiller_search_status_list
    • ms_enzymefile
    • ms_fragrulesfile
    • ms_http_client
    • ms_http_client_search
    • ms_http_client_session
    • ms_http_helper
    • ms_http_helper_handles
    • ms_license
    • ms_mascotresfile
    • ms_masses
    • ms_modfile
    • ms_obofile
    • ms_processors
    • ms_quant_configfile
    • ms_quant_helper
    • ms_quantitation
      • ms_customquantitation
        • ms_ms1quantitation
      • ms_ms2quantitation
    • ms_security
    • ms_security_options
    • ms_security_tasks
    • ms_session
    • ms_spectral_lib_entry
    • ms_spectral_lib_file
    • ms_spectral_lib_peak_list
    • ms_taxonomyfile
    • ms_taxonomytree
    • ms_tinycdb
    • ms_treecluster
    • ms_umod_configfile
    • ms_zip
  • ms_fileutilities
  • ms_fitexy_result
  • ms_fragment
  • ms_fragmentvector
  • ms_group
  • ms_http_client_mime
  • ms_http_helper_progress
  • ms_http_helper_return
  • ms_inputquery
  • ms_linker_site
  • ms_linker_site_vector
  • ms_log
    • ms_errs
  • ms_logger
    • ms_buffer_logger
    • ms_file_logger
    • ms_stdout_logger
  • ms_loggingmonitor
  • ms_mascotresults
    • ms_peptidesummary
    • ms_proteinsummary
  • ms_mascotresults_params
  • ms_matrix
  • ms_modvector
  • ms_ms1quant_average_results
  • ms_ms1quant_charge_state
  • ms_ms1quant_match
  • ms_ms1quant_match_component
  • ms_ms1quant_match_range
  • ms_ms1quant_match_ratio
  • ms_ms1quant_peptide_status
  • ms_parserule
  • ms_parserule_plus
  • ms_peptide
  • ms_peptide_quant_key
  • ms_peptide_quant_key_vector
  • ms_peptide_quant_ratio
  • ms_progress_info
  • ms_protein
  • ms_protein_quant_ratio
  • ms_quant_component
  • ms_quant_composition
    • ms_quant_neutralloss
    • ms_quant_pepneutralloss
  • ms_quant_correction
  • ms_quant_element
  • ms_quant_isotope
  • ms_quant_localdef
  • ms_quant_method
  • ms_quant_modgroup
  • ms_quant_moverz
  • ms_quant_normalisation_peptide
  • ms_quant_normalisation_peptides
  • ms_quant_normalisation_protein
  • ms_quant_normalisation_proteins
  • ms_quant_numerator
  • ms_quant_protocol
  • ms_quant_ratio
  • ms_quant_satellite
  • ms_quant_specificity
  • ms_quant_stats
  • ms_quant_unmodified
  • ms_searchparams
  • ms_security_task
  • ms_shapiro_wilk
  • ms_spectral_lib_peak
  • ms_taxnodesfiles
  • ms_taxspeciesfiles
  • ms_umod_aminoacid
  • ms_umod_composition
    • ms_umod_neutralloss
  • ms_umod_element
  • ms_umod_elemref
  • ms_umod_modbrick
  • ms_umod_modification
  • ms_umod_specificity
  • ms_umod_xref
  • ms_unigene
  • ms_unigene_entry
  • ms_user
  • ms_wwwentry
  • ms_xic
  • ms_xic_point
  • ms_xml_parameter
    • ms_crosslinking_parameter
    • ms_quant_parameter
  • ms_xml_parameters
    • ms_crosslinking_parameters
      • ms_crosslinking_filters
      • ms_crosslinking_scope
      • ms_crosslinking_settings
    • ms_quant_parameters
      • ms_quant_average
      • ms_quant_integration
      • ms_quant_multiplex
      • ms_quant_normalisation
      • ms_quant_outliers
      • ms_quant_precursor
      • ms_quant_quality
      • ms_quant_replicate
      • ms_quant_reporter
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:23


http_client.cs

Accessing a Mascot Server using http

/*
##############################################################################
# file: http_client.cs                                                       #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/http_client.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Collections.Generic;
using System.IO;
using System.Threading;
using matrix_science.msparser;

namespace MsParserExamples
{
    class http_client
    {
        public static int Main(string[] argv)
        {
            Dictionary<string, bool> allowedCommands = new Dictionary<string, bool>
            {
                {"search", true},
                {"getresults", true},
                {"getseq", true}
            };

            Dictionary<string, string> options = GetOptions(argv);
            if ((!options.ContainsKey("url") || !options.ContainsKey("cmd") || !allowedCommands.ContainsKey(options["cmd"]))
                || (options["cmd"]=="search" && !options.ContainsKey("mgf"))
                || (options["cmd"]=="getresults" && !options.ContainsKey("taskID"))
                || (options["cmd"]=="getseq" && (!options.ContainsKey("accession") || !options.ContainsKey("database"))))
            {
                showUsage();
                return 1;
            }

            // Common code for all cases

            // Create connection settings
            // Any settings for web server authentication or a proxy server should be set here
            ms_connection_settings oSettings = new ms_connection_settings();
            oSettings.setUserAgent("CSharpTest/1.0 " + oSettings.getUserAgent());
            // try to auto detect any proxy settings
            oSettings.setProxyServerType(ms_connection_settings.PROXY_TYPE.PROXY_TYPE_AUTO);

            // Connect to the server
            ms_http_client oHttpClient = new ms_http_client(options["url"], oSettings);
            if (!oHttpClient.isValid())
            {
                showErrors(oHttpClient.getErrorHandler());
                return -1;
            }

            // Enable logging, mostly for debugging
            oHttpClient.getErrorHandler().setLoggingFile("log.txt", ms_errs.msg_sev.sev_debug3);

            // Create a Mascot security session
            // If security is disabled, the empty user name and password return the
            // 'all_secdisabledsession' session
            ms_http_client_session oSession = new ms_http_client_session();
            ms_http_client.LoginResultCode loginReturnCode = oHttpClient.userLogin((options.ContainsKey("username") ? options["username"] : ""),
                (options.ContainsKey("password") ? options["password"] : ""),
                oSession);
            if (loginReturnCode != ms_http_client.LoginResultCode.L_SUCCESS &&
                loginReturnCode != ms_http_client.LoginResultCode.L_SECURITYDISABLED)
            {
                Console.Error.WriteLine("Failed to login to {0} as user {1}. Return code id {2}",
                    options["url"], (options.ContainsKey("username") ? options["username"] : ""), (int) loginReturnCode);
                return -1;
            }
            else
            {
                Console.WriteLine("Logged in to {0} with session: {1}", options["url"], oSession.sessionId());
            }

            if (options["cmd"] == "search")
            {
                if (!doSearch(options, oHttpClient, oSession)) return -1;
            }
            else if (options["cmd"] == "getresults")
            {
                if (!doGetResults(options, oSession)) return -1;
            }
            else if (options["cmd"] == "getseq")
            {
                if(!doGetSeq(options, oSession)) return -1;
            }

            // and finally logout
            oSession.logout();
            return 0;
        }

        private static bool doSearch(Dictionary<string, string> options, ms_http_client oHttpClient, ms_http_client_session oSession)
        {
            string httpHeader = "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH";
            // You may need to alter the search conditions embedded in this string to match your own
            // dataset
            string prologue = @"-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""FORMVER""

1.01
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""SEARCH""

MIS
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""COM""

C# test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""DB""

SwissProt
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""CLE""

Trypsin/P
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""PFA""

1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""QUANTITATION""

None
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""TAXONOMY""

. . . . . . . . . . . . . . . . Homo sapiens (human)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""MODS""

Carbamidomethyl (C)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""IT_MODS""

Oxidation (M)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""TOL""

10
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""TOLU""

ppm
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""PEP_ISOTOPE_ERROR""

1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""ITOL""

0.1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""ITOLU""

Da
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""CHARGE""

2+
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""MASS""

Monoisotopic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""FORMAT""

Mascot generic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""INSTRUMENT""

ESI-TRAP
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""REPORT""

AUTO
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""USERNAME""

Mascot Parser Test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""USEREMAIL""

dcreasy@matrixscience.com
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name=""FILE""; filename=""test.mgf""";
            string epilogue = "-----------FormBoundary4C9ByKKVofH--";

            // Request a Mascot task id for the search
            string taskID = "";
            ms_http_client_search oSearch = new ms_http_client_search(oSession, taskID);
            if (!oSearch.isValid())
            {
                showErrors(oSearch.getErrorHandler());
                return false;
            }

            // Submit the search
            Console.WriteLine("Submitting search");
            ms_http_helper_progress oProgress = new ms_http_helper_progress();
            if (oSession.submitSearch(oSearch, httpHeader, prologue, options["mgf"], epilogue, oProgress))
            {
                Console.WriteLine("Search submitted.  Task ID = {0}", oSearch.searchTaskId());
                bool success;
                int returnValue;
                int returnCode = (int) ms_http_client_search.SearchStatusCode.SS_UNKNOWN;
                bool complete = false;
                while (!complete)
                {
                    success = oSearch.getStatus(out returnCode, out returnValue);
                    if (!success)
                    {
                        Console.Error.WriteLine("Unable to call getStatus()");
                        return false;
                    }
                    if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_UNKNOWN)
                    {
                        Console.WriteLine("Unknown search id");
                        complete = false;
                    }
                    else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_ASSIGNED)
                    {
                        Console.WriteLine("Search no started");
                        complete = false;
                    }
                    else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_QUEUED)
                    {
                        Console.WriteLine("Search queued");
                        complete = false;
                    }
                    else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_RUNNING)
                    {
                        Console.WriteLine("Search running: {0}% complete", returnValue);
                        complete = false;
                    }
                    else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_COMPLETE)
                    {
                        Console.WriteLine("Search complete");
                        complete = true;
                    }
                    else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_ERROR)
                    {
                        Console.WriteLine("Search error : {0}", returnValue);
                        complete = true;
                    }
                    else if (returnCode == (int)ms_http_client_search.SearchStatusCode.SS_SEARCH_CONTROL_ERROR)
                    {
                        Console.WriteLine("Search control error: {0}", returnValue);
                        complete = true;
                    }
                    // Sleep thread for 1 second
                    if(!complete) Thread.Sleep(1000);
                }

                // Search complete - get the relative path to the result file
                string remoteFileName;
                bool ok = oSearch.getResultsFileName(out remoteFileName);
                if (!ok)
                {
                    Console.Error.WriteLine("Unable to get filename for results file");
                    showErrors(oHttpClient.getErrorHandler());
                    return false;
                }

                // Display URL for search result report
                Console.WriteLine("Search result report can be viewed at this URL:");
                Console.WriteLine("{0}master_results_2.pl?file={1}", oHttpClient.baseUrl(),
                    remoteFileName);
            }
            else
            {
                Console.Error.WriteLine("Failed to submit search");
                showErrors(oSession.getErrorHandler());
                return false;
            }

            return true;
        }

        private static bool doGetResults(Dictionary<string, string> options, ms_http_client_session oSession)
        {
            ms_http_client_search oSearch = new ms_http_client_search(oSession, options["taskID"]);
            if (!oSearch.isValid())
            {
                showErrors(oSearch.getErrorHandler());
                return false;
            }
            string remoteFileName;
            bool ok = oSearch.getResultsFileName(out remoteFileName);
            if (!ok || string.IsNullOrWhiteSpace(remoteFileName))
            {
                Console.Error.WriteLine("Unable to get filename for results file");
                return false;
            }
            string localFileName = Path.GetFileName(remoteFileName);
            Console.WriteLine("Downloading remote results file ({0}) to {1}", remoteFileName, localFileName);
            ms_http_helper_progress oProgress = new ms_http_helper_progress();
            // Download the complete, uncompressed result file
            if (oSearch.downloadResultsFile(localFileName, oProgress))
            {
                Console.WriteLine("Downloaded remote file to {0}", localFileName);
            }
            else
            {
                Console.Error.WriteLine("Failed to download remote file to {0}", localFileName);
                return false;
            }
            return true;
        }

        private static bool doGetSeq(Dictionary<string, string> options, ms_http_client_session oSession)
        {
            VectorString accessions = new VectorString();
            vectori frames = new vectori();
            accessions.Add(options["accession"]);
            string localFileName = "sequence.xml";
            if (oSession.getSequenceFile(options["database"], accessions, frames, localFileName))
            {
                Console.WriteLine("Successfully saved sequence to {0}", localFileName);
                return true;
            }
            else
            {
                Console.Error.WriteLine("Failed to get sequence or failed to save it to {0}", localFileName);
                showErrors(oSession.getErrorHandler());
                return false;
            }
        }

        private static void showErrors(ms_errs ms_errs)
        {
            Console.Error.WriteLine("Error: {0}", ms_errs.getLastErrorString());
            for (int i = 1; i <= ms_errs.getNumberOfErrors(); i++)
            {
                Console.Error.WriteLine("Error number: {0} ({1} times) : {2}",
                    ms_errs.getErrorNumber(i),
                    ms_errs.getErrorRepeats(i) + 1,
                    ms_errs.getErrorString(i));
            }
            Console.Error.WriteLine();
        }

        private static void showUsage()
        {
            Console.Error.WriteLine(@"Usage {0} --url=<URL> --cmd=<command> [options]

    --url       Mascot Server URL in the form
                  http://your-server/mascot/cgi/
    --cmd       One of the following:
                  --cmd=search to submit a Mascot search
                  --cmd=getresults to download the search results file
                  --cmd=getseq to save protein sequence to XML file
    --mgf       Path to an MGF peak list file
                  Required if --cmd=search
    --taskID    Mascot task ID for the search
                  Required if --cmd=getresults
    --accession Accession string for protein
                  Required if --cmd=getseq
    --database  Mascot database name
                  Required if --cmd=getseq
    --username  Mascot Server username
                  Required if Mascot Security is enabled
    --password  Mascot Server password
                  May be required if Mascot Security is enabled

Note that the Mascot search parameters are hard coded towards the end of this
class, and may need modifying for different peak lists.", Path.GetFileName((new http_client()).GetType().Assembly.Location));
        }

        // Parses the passed arguments and returns a Dictionary containing only
        // valid commands
        private static Dictionary<string, string> GetOptions(string[] argv)
        {
            Dictionary<string, string> options = new Dictionary<string, string>();
            Dictionary<string, bool> allowedCommands = new Dictionary<string, bool>
            {
                {"url",true},
                {"cmd",true},
                {"mgf",true},
                {"taskID",true},
                {"accession",true},
                {"database",true},
                {"username",true},
                {"password",true}
            };

            foreach (string arg in argv)
            {
                if(!arg.StartsWith("--")) continue;
                string arg2 = ReplaceFirst(arg, "--", "");
                string key=null, value=null;
                if (arg2.Contains("="))
                {
                    string[] split = arg2.Split('=');
                    if (split.Length == 2)
                    {
                        key = split[0];
                        value = split[1];
                    }
                    else if (split.Length == 1)
                    {
                        key = split[0];
                        value = "";
                    }
                }
                else
                {
                    key = arg2;
                    value = "";
                }

                if (!string.IsNullOrEmpty(key) && allowedCommands.ContainsKey(key) && allowedCommands[key] && !string.IsNullOrWhiteSpace(value))
                {
                    options.Add(key,value);
                }
            }

            return options;
        }

        public static string ReplaceFirst(string text, string search, string replace)
        {
            int pos = text.IndexOf(search);
            if (pos < 0)
            {
                return text;
            }
            return text.Substring(0, pos) + replace + text.Substring(pos + search.Length);
        }
    }
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


http_client.pl

Accessing a Mascot Server using http

#!/usr/local/bin/perl
##############################################################################
# File: http_client.pl                                                       #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/http_client.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
use warnings;
##############################################################################

# required Perl packages
use lib "../bin";
use msparser;
use Getopt::Long;
use File::Basename;

my ($url, $cmd, $mgf, $taskID, $accession, $database, $username, $password);
my %allowedCommands = ("search" => 1, "getresults" => 1, "getseq" => 1);
$username = "";
$password = "";

GetOptions('url=s'      => \$url,
           'cmd=s'      => \$cmd,
           'mgf=s'      => \$mgf,
           'taskID=s'   => \$taskID,
           'accession=s'=> \$accession,
           'database=s' => \$database,
           'username=s' => \$username,
           'password=s' => \$password);

if ((not defined $url or not defined $cmd or not exists($allowedCommands{$cmd}))
    or ($cmd eq 'search' and not defined $mgf)
    or ($cmd eq 'getresults' and not defined $taskID)
    or ($cmd eq 'getseq' and (not defined $accession or not defined $database))
   ) {
   print <<USAGE;

Usage http_client.pl --url=<URL> --cmd=<command> [options]

    --url         Mascot Server URL of the form
                    http://your-server/mascot/cgi/
    --cmd         One of the following
                    --cmd=search to submit a Mascot search
                    --cmd=getresults to download the search results file
                    --cmd=getseq to save protein sequence to XML file
    --mgf         Path to an MGF peak list file
                    Required if --cmd=search
    --taskID      Mascot task ID for the search
                    Required if --cmd=getresults
    --accession   Accession string for protein
                    Required if --cmd=getseq
    --database    Mascot database name
                    Required if --cmd=getseq
    --username    Mascot Server user name
                    May be required if Mascot Security is enabled
    --password    Mascot Server password
                    May be required if Mascot Security is enabled

Note that the Mascot search parameters are hard coded towards the end
of this script, and may need modifying for different peak lists.

USAGE
  exit 1;
}

# Common code for all cases

# Create connection settings.
# Any settings for web server authentication or a proxy server should be set here
my $objSettings = new msparser::ms_connection_settings;
$objSettings->setUserAgent("PerlScriptTest/1.0 " . $objSettings->getUserAgent);

# Connect to the server
my $objHttpClient = new msparser::ms_http_client($url, $objSettings);
unless ($objHttpClient->isValid) {
  showErrorsAndExit($objHttpClient);
}

# Enable logging, mostly for debugging
$objHttpClient->getErrorHandler->setLoggingFile("log.txt", $msparser::ms_errs::sev_debug3);

# Create a Mascot security session
# If security is disabled, the empty user name and password return the 'all_secdisabledsession' session
my $objSession = new msparser::ms_http_client_session;
my $loginReturnCode = $objHttpClient->userLogin($username, $password, $objSession);
if ($loginReturnCode != $msparser::ms_http_client::L_SUCCESS and $loginReturnCode != $msparser::ms_http_client::L_SECURITYDISABLED) {
  die "Failed to login to $url as user $username. return code is $loginReturnCode\n";
} else {
  print "Logged in to $url with session: " . $objSession->sessionId() . "\n";
}

if ($cmd eq 'search') {
  doSearch();
}
if ($cmd eq 'getresults') {
  doGetResults();
}
if ($cmd  eq 'getseq') {
  doGetSeq();
}

# and finally logout
$objSession->logout();

sub doSearch {

# The input to Mascot is the peak list and search parameters in MIME format
  my $httpHeader = "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH";
  my $prologue = "";
  while (<DATA>){
    $prologue .= $_;
  }
  my $epilogue = "-----------FormBoundary4C9ByKKVofH--";

# Request a Mascot task id for the search
  my $taskID = "";
  my $objSearch = new msparser::ms_http_client_search($objSession, $taskID);
  unless ($objSearch->isValid) {
    showErrorsAndExit($objSearch);
  }

# Submit the search
  print "Submitting search\n";
  my $objProgress = new msparser::ms_http_helper_progress;
  if ($objSession->submitSearch($objSearch, $httpHeader, $prologue, $mgf, $epilogue, $objProgress)) {
    print "Search submitted. Task ID = " . $objSearch->searchTaskId . "\n";
    my ($success, $returnValue);
    my $returnCode = $msparser::ms_http_client_search::SS_UNKNOWN;
    my $complete = 0;
    while (!$complete) {
        ($success, $returnCode, $returnValue) = $objSearch->getStatus();
        if (!$success) {
          print "Unable to call getStatus()\n";
          exit 1;
        }
      if    ($returnCode == $msparser::ms_http_client_search::SS_UNKNOWN   ) {
        print "Unknown search id\n";   $complete = 0;
      } elsif ($returnCode == $msparser::ms_http_client_search::SS_ASSIGNED) {
        print "Search not started\n";  $complete = 0;
      } elsif ($returnCode == $msparser::ms_http_client_search::SS_QUEUED  ) {
        print "Search queued\n";       $complete = 0;
      } elsif ($returnCode == $msparser::ms_http_client_search::SS_RUNNING ) {
        print "Seach running: $returnValue\% complete\n";
      } elsif ($returnCode == $msparser::ms_http_client_search::SS_COMPLETE) {
        print "Search complete\n";     $complete = 1;
      } elsif ($returnCode == $msparser::ms_http_client_search::SS_ERROR   ) {
        print "Search error : $returnValue \n"; $complete = 1;
      } elsif ($returnCode == $msparser::ms_http_client_search::SS_SEARCH_CONTROL_ERROR) {
        print "Search control  error: $returnValue\n"; $complete = 1;
      }
        sleep 1;
    }

  # Search complete - get the relative path to the result file
    my ($ok, $remoteFileName) = $objSearch->getResultsFileName();
    unless ($ok) {
      print "Unable to get filename for results file";
      showErrorsAndExit($objHttpClient);
    }

  # Display URL for search result report
    print "Search result report can be viewed at this URL:\n"
      . $objHttpClient->baseUrl
      . "master_results_2.pl?file="
      . $remoteFileName
      . "\n";

  } else {
    print "Failed to submit search\n";
    showErrorsAndExit($objSession);
  }
}

sub doGetResults {
  my $objSearch = new msparser::ms_http_client_search($objSession, $taskID);
  unless ($objSearch->isValid) {
    showErrorsAndExit($objSearch);
  }

  my ($ok, $remoteFileName) = $objSearch->getResultsFileName();
  unless ($ok && $remoteFileName) {
    print "Unable to get filename for results file";
    exit -1;
  }

  my ($localFileName, undef, undef) = fileparse($remoteFileName);
  print "Downloading remote results file ($remoteFileName) to $localFileName\n";
  my $objProgress = new msparser::ms_http_helper_progress;
# Download the complete, uncompressed result file
  if ($objSearch->downloadResultsFile($localFileName, $objProgress)) {
    print "Downloaded remote file to $localFileName \n";
  } else {
    print "Failed to downloaded remote file to $localFileName \n";
    showErrorsAndExit($objSearch);
  }
}

sub doGetSeq {
  my $accessions = new msparser::VectorString;
  my $frames     = new msparser::vectori;
  $accessions->push($accession);
  my $localFileName = "sequence.xml";
  if ($objSession->getSequenceFile($database, $accessions, $frames, $localFileName)) {
    print "Successfully saved sequence to $localFileName \n";
  } else {
    print "Failed to get sequence or failed to save it to $localFileName \n";
    showErrorsAndExit($objSession);
  }
}

sub showErrorsAndExit {
    my ($obj) = @_;
    print "Error: ", $obj->getLastErrorString(), "\n";

    my $err = $obj->getErrorHandler();
    my $i;

    for my $i (1 .. $err->getNumberOfErrors) {
        print "Error number: ";
        print $err->getErrorNumber($i);
        print " (";
        print $err->getErrorRepeats($i) + 1;
        print " times) : ";
        print $err->getErrorString($i), "\n";
    }

    print "\n";

    exit -1;
}

__END__
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FORMVER"

1.01
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="SEARCH"

MIS
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="COM"

Perl script test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="DB"

SwissProt
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="CLE"

Trypsin/P
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="PFA"

1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="QUANTITATION"

None
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TAXONOMY"

. . . . . . . . . . . . . . . . Homo sapiens (human)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="MODS"

Carbamidomethyl (C)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="IT_MODS"

Oxidation (M)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TOL"

10
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TOLU"

ppm
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="PEP_ISOTOPE_ERROR"

1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="ITOL"

0.1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="ITOLU"

Da
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="CHARGE"

2+
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="MASS"

Monoisotopic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FORMAT"

Mascot generic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="INSTRUMENT"

ESI-TRAP
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="REPORT"

AUTO
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="USERNAME"

Mascot Parser Test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="USEREMAIL"

dcreasy@matrixscience.com
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FILE"; filename="test.mgf"
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:16


http_client.py

Accessing a Mascot Server using http

#!/usr/bin/python
##############################################################################
# file: http_client.py                                                       #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/http_client.py $   #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys
import getopt
import ntpath
import time

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

# Define Global argument variables
msurl = ''
mscmd = ''
msmgf = ''
mstaskID = ''
msaccession = ''
msdatabase = ''
msusername = ''
mspassword = ''

# Define help text
usage = """
Usage http_client.py --url=<URL> --cmd=<command> [options]

    --help        Print this message

    --url         Mascot Server URL of the form
                    http://your-server/mascot/cgi/
    --cmd         One of the following
                    --cmd=search to submit a Mascot search
                    --cmd=getresults to download the search results file
                    --cmd=getseq to save protein sequence to XML file
    --mgf         Path to an MGF peak list file
                    Required if --cmd=search
    --taskID      Mascot task ID for the search
                    Required if --cmd=getresults
    --accession   Accession string for protein
                    Required if --cmd=getseq
    --database    Mascot database name
                    Required if --cmd=getseq
    --username    Mascot Server user name
                    May be required if Mascot Security is enabled
    --password    Mascot Server password
                    May be required if Mascot Security is enabled
"""

# If no arguments supplied, print help and exit
if len(sys.argv) < 2 :
    print(usage)
    sys.exit(1)

# Ensure arguments are legal. if not, exit
try:
    opts, args = getopt.getopt(sys.argv[1:],"",["help","url=","cmd=","mgf=","taskID=","accession=","database=","username=","password="])
except getopt.GetoptError:
    sys.exit(1)

# If argument is --help, display help then exit
for opt, arg in opts:
    if opt == '--help':
        print(usage)
        sys.exit(2)

# Read arguments and assign each option to appropriate variables
    elif opt in ("--url"):
        msurl = arg
    elif opt in ("--cmd"):
        mscmd = arg
    elif opt in ("--mgf"):
        msmgf = arg
    elif opt in ("--taskID"):
        mstaskID = arg
    elif opt in ("--accession"):
        msaccession = arg
    elif opt in ("--database"):
        msdatabase = arg
    elif opt in ("--username"):
        msusername = arg
    elif opt in ("--password"):
        mspassword = arg

# ensure that the correct combinations of arguments are assigned
if not msurl:
    print(usage)
    sys.exit(1)
elif mscmd == "search":
    if not msmgf:
        print(usage)
        sys.exit(1)
elif mscmd == "getresults":
    if not mstaskID:
        print(usage)
        sys.exit(1)
elif mscmd == "getseq":
    if not msaccession:
        print(usage)
        sys.exit(1)
    elif not msdatabase:
        print(usage)
        sys.exit(1)

# Common Code for all cases

# Create connection settings
# Any settings for web server authentication or a proxy server should be set here
objSettings = msparser.ms_connection_settings()
objSettings.setUserAgent("PythonScriptTest/1.0 " + objSettings.getUserAgent())
# Try to auto detect any proxy settings
objSettings.setProxyServerType(msparser.ms_connection_settings.PROXY_TYPE_AUTO)

# Connect to the server
objHttpClient = msparser.ms_http_client(msurl, objSettings)
if not objHttpClient.isValid():
    print("Connection to server %s is not valid" % msurl)
    showErrorsAndExit(objHttpClient)

# Enable Logging, mostly for debugging
objHttpClient.getErrorHandler().setLoggingFile("log.txt", msparser.ms_errs.sev_debug3)

# Create Mascot Security Session
# If security is disabled, the empty username and password return the 'all_secdisabledsession' session
objSession = msparser.ms_http_client_session()
loginReturnCode = objHttpClient.userLogin(msusername, mspassword, objSession)
if loginReturnCode != msparser.ms_http_client.L_SUCCESS and loginReturnCode != msparser.ms_http_client.L_SECURITYDISABLED:
    print("Failed to login to %s as user %s. Return code id %d" % (msurl, msusername, loginReturnCode))
    sys.exit(1)
else:
    print("Logged in to %s with session: %s" % (msurl, objSession.sessionId()))

def doGetSeq():
    print("Get Sequence")
    accessions = msparser.VectorString()
    frames = msparser.vectori()
    accessions.append(msaccession)
    localFileName = "sequence.xml"
    if objSession.getSequenceFile(msdatabase, accessions, frames, localFileName):
        print("Successfully saved sequence to %s" % localFileName)
    else:
        print("Failed to get sequence or failed to save it to %s" % localFileName)
        showErrorsAndExit(objSession)

def doGetResults():
    print("Get Results")
    objSearch = msparser.ms_http_client_search(objSession, mstaskID)
    if not objSearch.isValid():
        print("Search is not valid")
        showErrorsAndExit(objSearch)
    ok, remoteFileName = objSearch.getResultsFileName()
    print(remoteFileName)
    if ok and remoteFileName:
        print("Found filename for results file")
    else:
        print("Unable to find filename for results file")
        sys.exit(1)

    localFileName = ntpath.basename(remoteFileName)
    print("Downloading remote results file %s to %s" % (remoteFileName, localFileName))
    objProgress = msparser.ms_http_helper_progress()
    # Download the complete, uncompressed results file
    if objSearch.downloadResultsFile(localFileName, objProgress):
        print("Downloaded remote file to %s" % localFileName)
    else:
        print("Failed to download remote file to %s" % localFileName)
        return False
    return True

def doSearch():
    print("Searching" )
# The input to Mascot is the peak list and search parameters in MIME format
    httpHeader = "Content-Type: multipart/mixed; boundary=---------FormBoundary4C9ByKKVofH"
    prologue = """-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FORMVER"

1.01
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="SEARCH"

MIS
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="COM"

Python script test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="DB"

SwissProt
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="CLE"

Trypsin/P
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="PFA"

1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="QUANTITATION"

None
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TAXONOMY"

. . . . . . . . . . . . . . . . Homo sapiens (human)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="MODS"

Carbamidomethyl (C)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="IT_MODS"

Oxidation (M)
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TOL"

10
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="TOLU"

ppm
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="PEP_ISOTOPE_ERROR"

1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="ITOL"

0.1
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="ITOLU"

Da
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="CHARGE"

2+
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="MASS"

Monoisotopic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FORMAT"

Mascot generic
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="INSTRUMENT"

ESI-TRAP
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="REPORT"

AUTO
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="USERNAME"

Mascot Parser Test
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="USEREMAIL"

dcreasy@matrixscience.com
-----------FormBoundary4C9ByKKVofH
Content-Disposition: form-data; name="FILE"; filename="test.mgf"
"""

    epilogue = "-----------FormBoundary4C9ByKKVofH--"

# Request a Mascot task id for the search
    objSearch = msparser.ms_http_client_search(objSession, mstaskID)
    if not objSearch.isValid():
        showErrorsAndExit(objSearch)
# Submit the search
    print("Submitting search")
    objProgress = msparser.ms_http_helper_progress()
    if objSession.submitSearch(objSearch, httpHeader, prologue, msmgf, epilogue, objProgress):
        print("Search submitted. Task ID = %s" % objSearch.searchTaskId())
        success = False
        returnValue = 0
        returnCode = msparser.ms_http_client_search.SS_UNKNOWN
        complete = False
        while not complete:
            success, returnCode, returnValue = objSearch.getStatus()
            if not success:
                print("Unable to call getStatus()")
                sys.exit(1)
            if returnCode == msparser.ms_http_client_search.SS_UNKNOWN:
                print("Unkown search id")
                complete = False
            elif returnCode == msparser.ms_http_client_search.SS_ASSIGNED:
                    print("Search not started")
                    complete = False
            elif returnCode == msparser.ms_http_client_search.SS_QUEUED:
                    print("Search Queued")
                    complete = False
            elif returnCode == msparser.ms_http_client_search.SS_RUNNING:
                    print("Search running: %s complete" % returnValue)
                    complete = False
            elif returnCode == msparser.ms_http_client_search.SS_COMPLETE:
                    print("Search Complete")
                    complete = True
            elif returnCode == msparser.ms_http_client_search.SS_ERROR:
                    print("Search Error : %s " % returnValue)
                    complete = True
            elif returnCode == msparser.ms_http_client_search.SS_SEARCH_CONTROL_ERROR:
                    print("Search control error: %s " % returnValue)
                    complete = True
            time.sleep(1)

# Search complete - get the relative path to the result file
        ok, remoteFileName = objSearch.getResultsFileName()
        if not ok:
            print("Unable to get filename for results file")
            showErrorsAndExit(objHttpClient)
        else:
            print("Search result report can be viewed at this URL:")
            print(objHttpClient.baseUrl() + "master_results_2.pl?file=" + remoteFileName)
    else:
        print("Failed to submit search")
        showErrorsAndExit(objSession)

def showErrorsAndExit(ms_errs):
    print("Error: %s" % ms_errs.getLastErrorString())
    errs = ms_errs.getErrorHandler()
    for i in ms_range(1, errs.getNumberOfErrors()):
        print("Error Number: " + str(errs.getErrorNumber(i)) + " (" + str(errs.getErrorRepeats(i + 1)) + " times :")
    sys.exit(1)

if mscmd == "search":
    doSearch()

if mscmd == "getresults":
    doGetResults()

if mscmd == "getseq":
    doGetSeq()

# And finally logout
objSession.logout()
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


http_helper_getstring.cpp

Accessing any server using http(s)

#include <iostream>
#include "msparser.hpp"

using namespace matrix_science;

int main(int argc, char ** argv)
{
    std::string url, action, httpUserName, httpPassword, username, password;

    if (argc == 3 || argc == 5 || argc == 7)
    {
        url = argv[1];
        action = argv[2];
        if(argc == 5 || argc == 7)
        {
            httpUserName = argv[3];
            httpPassword = argv[4];
        }
        if (argc == 7)
        {
            username = argv[5];
            password = argv[6];
        }
    }
    else
    {
        std::cerr << "Usage: " << argv[0] << " <url> <action> [httpUserName] [httpPassword] [username] [password]" << std::endl;
        return 1;
    }

    std::cout << "url: " << url << " action: " << action;
    if(httpUserName != "")
    {
         std::cout << " httpUserName: " << httpUserName << " httpPassword: " << httpPassword;
    }
    if(username != "")
    {
        std::cout << " username: " << username << " password: " << password;
    }
    std::cout << std::endl;

    ms_connection_settings connectionSettings;
    connectionSettings.setUserAgent("CppTest/1.0" + connectionSettings.getUserAgent());

    if(httpUserName != "")
    {
         connectionSettings.setHttpUsername(httpUserName);
    }

    if(httpPassword != "")
    {
         connectionSettings.setHttpPassword(httpPassword);
    }

    ms_http_helper httpHelper(url, connectionSettings);

    if(!httpHelper.isValid())
    {
        std::cout << "Error: " << httpHelper.getLastErrorString() << std::endl;
        for(int i = 0 ; httpHelper.getErrorHandler() && i < httpHelper.getErrorHandler()->getNumberOfErrors() ; i++ )
        {
            std::cout << "Error number: " << httpHelper.getErrorHandler()->getErrorNumber(i) << " (" << httpHelper.getErrorHandler()->getErrorRepeats(i) << " times) : "
                << httpHelper.getErrorHandler()->getErrorString(i) << std::endl;
        }
        std::cout << std::endl;

        return -1;
    }

    std::string httpGETString;
    ms_http_helper_return helperReturn_string(httpHelper.httpGetString(action, httpGETString));

    if(helperReturn_string.isOk())
    {
        std::cout << "httpGETString - OK: " << std::endl << httpGETString << std::endl;
    }
    else
    {
        std::cout << "httpGETString - Error: " << helperReturn_string.getErrorText() << " (" << helperReturn_string.getHttpStatusCode() << ")" << std::endl;
    }

    std::string header;
    ms_http_helper_return helperReturn_header(httpHelper.httpGetHeader("", header));

    if(helperReturn_header.isOk())
    {
        std::cout << "httpGetHeader - OK : " << std::endl << header << std::endl;
    }
    else
    {
        std::cout << "httpGetHeader - Error: " << helperReturn_header.getErrorText() << " (" << helperReturn_header.getHttpStatusCode() << ")" << std::endl;
    }

    ms_http_helper_return helperReturn_buffer(httpHelper.httpBufferedOpen(""));
    if(helperReturn_buffer.isOk())
    {
        std::cout << "httpBufferedOpen - OK :" << std::endl;
        std::string buffer;
        while (true)
        {
            ms_http_helper_return result = httpHelper.httpBufferedGetString(buffer, 10000);
            if (buffer.length() == 0 || !result.isOk())
            {
                break;
            }
            std::cout << buffer;
        }
        httpHelper.httpBufferedClose();
    }
    else
    {
        std::cout << "httpBufferedOpen - Error: " << helperReturn_buffer.getErrorText() << " (" << helperReturn_buffer.getHttpStatusCode() << ")" << std::endl;
    }

    std::cout << std::endl;

    return 0;
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


http_helper_getstring.pl

Accessing any server using http(s)

#!/usr/local/bin/perl
##############################################################################
# File: http_helper_getstring.pl                                             #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/http_helper_getstring.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
use warnings;
##############################################################################

# required Perl packages
use lib "../bin";
use msparser;
use Getopt::Long;
use File::Basename;

my ($url, $action, $httpUserName, $httpPassword, $username, $password);
$username = "";
$password = "";

GetOptions('url=s'          => \$url,
           'action=s'       => \$action,
           'httpUserName=s' => \$httpUserName,
           'httpPassword=s' => \$httpPassword,
           'username=s'     => \$username,
           'password=s'     => \$password);

if (not defined $url or not defined $action) {
   print <<USAGE;

Usage http_client.pl --url=<URL> --action=<command> [options]

    --url           Base URL, e.g
                      http://your-server/
    --action        An action for a get command.
                      Appended to the base URL
    --httpUserName  the username for an authenticated web server.
    --httpPassword  the password for an authenticated web server.
    --username      Mascot Server user name
                      May be required if Mascot Security is enabled
    --password      Mascot Server password
                      May be required if Mascot Security is enabled

USAGE
  exit 1;
}

# Common code for all cases

# Create connection settings.
# Any settings for web server authentication or a proxy server should be set here
my $objSettings = new msparser::ms_connection_settings;
$objSettings->setUserAgent("PerlScriptTest/1.0 " . $objSettings->getUserAgent);

if ($httpUserName) {
  $objSettings->setHttpUsername($httpUserName);
}

if ($httpPassword) {
  $objSettings->setHttpPassword($httpPassword);
}

# Connect to the server
my $httpHelper = new msparser::ms_http_helper($url, $objSettings);

if (!$httpHelper->isValid()) {
  showErrorsAndExit($httpHelper);
}

my ($errCodeString, $retString) = $httpHelper->httpGetString($action);

if ($errCodeString->isOk()) {
  print "httpGetString OK : " . $retString . "\n";
} else {
  print "Error: " . $errCodeString->getErrorText() . "\n";
}

my ($errCodeHeader, $retHeader) = $httpHelper->httpGetHeader($action);

if ($errCodeHeader->isOk()) {
  print "httpGetHeader OK : " . $retHeader . "\n";
} else {
  print "Error: " . $errCodeHeader->getErrorText() . "\n";
}

my ($errCodeBufferOpen) = $httpHelper->httpBufferedOpen($action);

if ($errCodeBufferOpen->isOk()) {
  print "httpBufferedOpen OK : \n";
    while (1)
    {
        my ($errCodeBufferString, $retBufferString) = $httpHelper->httpBufferedGetString(10000);
        if (! length $retBufferString || !$errCodeBufferString->isOk())
        {
            last;
        }
        print $retBufferString;
    }
    $httpHelper->httpBufferedClose();
} else {
  print "Error: " . $errCodeBufferOpen->getErrorText() . "\n";
}

sub showErrorsAndExit {
    my ($obj) = @_;
    print "Error: ", $obj->getLastErrorString(), "\n";

    my $err = $obj->getErrorHandler();
    my $i;

    for my $i (1 .. $err->getNumberOfErrors) {
        print "Error number: ";
        print $err->getErrorNumber($i);
        print " (";
        print $err->getErrorRepeats($i) + 1;
        print " times) : ";
        print $err->getErrorString($i), "\n";
    }

    print "\n";

    exit -1;
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


http_helper_getstring.py

Accessing any server using http(s)

#!/usr/bin/python
##############################################################################
# file: http_helper_getstring.py                                                       #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/http_helper_getstring.py $   #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys
import getopt
import ntpath
import time

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

# Define Global argument variables
msurl = ''
msaction = ''
msmgf = ''
mshttpusername = ''
mshttppassword = ''
msusername = ''
mspassword = ''

# Define help text
usage = """
Usage http_client.py --url=<URL> --action=<command> [options]

    --help          Display this message
    --url           Base URL, e.g
                      http://your-server/
    --action        An action for a get command.
                      Appended to the base URL
    --httpUserName  the username for an authenticated web server.
    --httpPassword  the password for an authenticated web server.
    --username      Mascot Server user name
                      May be required if Mascot Security is enabled
    --password      Mascot Server password
                      May be required if Mascot Security is enabled
"""
# If no arguments supplied, print help and exit
if len(sys.argv) < 2 :
    print(usage)
    sys.exit(1)

# Ensure arguments are legal. if not, exit
try:
    opts, args = getopt.getopt(sys.argv[1:],"",["help","url=","action=","httpUserName=","httpPassword=","username=","password="])
except getopt.GetoptError:
    sys.exit(1)

# If argument is --help, display help then exit
for opt, arg in opts:
    if opt == '--help':
        print(usage)
        sys.exit(2)

# Read arguments and assign each option to appropriate variables
    elif opt in ("--url"):
        msurl = arg
    elif opt in ("--action"):
        msaction = arg
    elif opt in ("--httpUserName"):
        mshttpusername = arg
    elif opt in ("--httpPassword"):
        mshttppassword = arg
    elif opt in ("--username"):
        msusername = arg
    elif opt in ("--password"):
        mspassword = arg

# Common Code for all cases

# Create connection settings
# Any settings for web server authentication or a proxy server should be set here
objSettings = msparser.ms_connection_settings()
objSettings.setUserAgent("PythonScriptTest/1.0 " + objSettings.getUserAgent())
# Try to auto detect any proxy settings
objSettings.setProxyServerType(msparser.ms_connection_settings.PROXY_TYPE_AUTO)

if mshttpusername:
    objSettings.setHttpUsername(mshttpusername)

if mshttppassword:
    objSettings.setHttpPassword(mshttppassword)

# Connect to the server
httpHelper = msparser.ms_http_helper(msurl, objSettings)
if not httpHelper.isValid():
    showErrorsAndExit(httpHelper)

errCodeString, retString = httpHelper.httpGetString(msaction)
if errCodeString.isOk():
    print("httpGetString OK : " + retString)
else:
    print("Error: " + errCodeString.getErrorText())

errCodeHeader, retHeader = httpHelper.httpGetHeader(msaction)
if errCodeHeader.isOk():
    print("httpGetHeader OK : " + retHeader)
else:
    print("Error: " + errCodeHeader.getErrorText())

errCodeBufferOpen = httpHelper.httpBufferedOpen(msaction)
if errCodeBufferOpen.isOk():
    print("httpBufferedOpen OK : ")
    while True:
        errCodeBufferString, retBufferString = httpHelper.httpBufferedGetString(10000)
        if len(retBufferString) == 0 or not errCodeBufferString.isOk():
            break
        print(retBufferString)
    httpHelper.httpBufferedClose()

def showErrorsAndExit(ms_errs):
    print("Error: %s" % ms_errs.getLastErrorString())
    errs = ms_errs.getErrorHandler()
    for i in ms_range(1, errs.getNumberOfErrors()):
        print("Error Number: " + str(errs.getErrorNumber(i)) + " (" + str(errs.getErrorRepeats(i + 1)) + " times :")
    sys.exit(1)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


java_helper.pl

Used to run security_session.java as a cgi script.

#!/usr/bin/perl
##############################################################################
# file: java_helper.pl                                                       #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#
# Perl helper cgi script to run security_session.java
#

use strict;
use CGI ':standard';
my %param_hash;
my @param_name = param();
my $param_name;
my $param_hash;

my $thisScript = new CGI;

# identify the host OS
my $os = $^O;
my $jarSep = ";";
if ($os !~ /MSWin32/i) {
    $jarSep = ":";
}

foreach $param_name (@param_name){
  $param_hash{$param_name} =param($param_name);
  $param_hash{$param_name} =~s/\|/-pipe-/;
  $param_hash{$param_name} =~s/\(system\)/SYSTEM/;
  $param_hash{$param_name} =~tr/\(\)a-zA-Z0-9\t\@ _:\-\/\.//cd;   # remove any potentially dodgy characters
}

my $command = "";
if ($os !~ /MSWin32/i) {
    $command = "LD_LIBRARY_PATH=\"\$LD_LIBRARY_PATH:.\"; export LD_LIBRARY_PATH; ";
}

$command .= "java -cp .".$jarSep."msparser.jar security_session ";

foreach $param_name (@param_name) {
    $command .= " ".$param_name." ".$param_hash{$param_name};
}

if (defined($thisScript->cookie(-name=>'MASCOT_SESSION'))) {
    my $cookieText = $thisScript->cookie(-name=>'MASCOT_SESSION');
    $cookieText = "null" if !$cookieText;
    $command .= " COOKIE_MASCOT_SESSION ".$cookieText
}

if (defined($ENV{'REMOTE_USER'})) {
    $command .= " ENV_ROMOTE_USER ".$ENV{'REMOTE_USER'};
}

system($command);
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


login.pl

Logging in using the security module.

#!/usr/local/bin/perl
##############################################################################
# file: login.pl                                                             #
# 'msparser' toolkit                                                         #
# Mascot general purpose login script                                        #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /www/cgi/login.pl                                          $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################
#
# When the script is run, the 'action' (if any) is performed, and then the
# display= is performed.
#
# If display=nothing, onerrdisplay=nothing and referer= is not defined,
# then the output will be of the form:
#   error=[error number or 0 for ok]
#   errorstring=[error string or empty]
#   sessionID=[sessionID or empty]
#
# Postive error numbers are msparser error numbers
# Negative error numbers are login.pl error numbers:
# -1   An error in the parameters
# -2   User is not authorised to perform requested task
# -3   Security is enabled - returned from issecuritydisabled
# -4   If action=webauthentication and webauthentication is not enabled
# -5   If action=guestlogin and the guest account is not enabled
#
# Parameter     Default       Allowed_values     Description
# ------------------------------------------------------------------------------
# action=                     login              Requires username and password
#                                                If sectask is specified and the
#                                                user is not permitted an error
#                                                of -2 will be set and sessionID
#                                                will be empty
#                             logout             Uses sessionID or cookie
#                             newpassword        Requires username, newpw1
#                                                newpw2 and password
#                             issecuritydisabled Used to determine if
#                                                Mascot security is disabled.
#                                                If it is disabled, it returns
#                                                error=0 and sessionID will be
#                                                a 'disabled' sessionID that
#                                                can be used.blank. If security
#                                                is enabled, then error=-3
#                                                and sessionID is blank.
#                             webauthentication  If web server authentication is
#                                                enabled for the user who is
#                                                submitting this request, then
#                                                then this will return error=0
#                                                and sessionID will be the
#                                                session to use. If it is not
#                                                enabled then error=-4
#                             guestlogin         If the guest account is enabled
#                                                then this will return error=0
#                                                and sessionID will be the
#                                                session to use. If it is not
#                                                enabled then error=-5
#                             ispermitted        Pass sessionID and sectask
#                                                if it fails, the sessionID
#                                                output will be empty. The
#                                                error= output is undefined.
#                             isfastapermitted   Use to determine if the user
#                                                has access to the fasta file
#                                                specified with fasta=
#                                                Also pass sessionID. If it
#                                                fails, the sessionID output
#                                                will be empty. The
#                                                error= output is undefined.
#                             integralogin       Requires username,
#                                                connectionID and integradb.
#                                                Returns a sessionID if it
#                                                succeeds.
# display=      login_prompt  nothing            No display - just text output
#                             login_prompt       Displays prompt for login
#                             newpw_prompt       Displays request for a new
#                                                password.
#                             logout_prompt      Not particularly useful except
#                                                for testing
#
# onerrdisplay= login_prompt  as display=        If there is an error in the
#                                                action (e.g. invalid password)
#                                                then display this form.
#
# username=                   any username       Performs the actual login.
#
# password=                   valid password
#
# newpw1=                                        For action=newpassword. User
# newpw2=                                        enters password twice to check
#
# sessionID=                  valid sessionID    Used for logout action, or
#                                                used to logout before logging
#                                                in with action=login
#
# savecookie=   0 or 1           0 or 1          Default is 1 for action=login
# clearcookie=  0 or 1           0 or 1          Default is 1 for action=logout
#
#
# referer=                    any URL            After performing the action go
#                                                to this URL. display= should
#                                                not be set when using this
#
# sectask=                    any valid integer  For login and ispermitted
#
# fasta=                      name of fasta      For example, MSDB. Use with
#                                                action=isfastapermitted
#
# connectionID=               integra connection Used with action=integralogin.
#                                                The connection string is the
#                                                integra equivalent of the
#                                                Mascot sessionID
# integradb=                  integra database   Used with action=integralogin.
#
# error=                      error number       For action=nothing or when no
# errorstring=                error string       action verb supplied. The error
#                                                string will be displayed on the
#                                                login form
#
################################################################################

use lib "../bin";
use CGI;
use msparser 2.000_054;

my ($session,
    $thisScript,
    $cookie1,
    $cookie2,
    $sec,
    $opts,
    $sessionID,
    $error,
    $errorstring,
    $action,
    $display,
    $onerrdisplay,
    $savecookie,
    $clearcookie,
    $shipper,
    );

$thisScript = new CGI;

# pull in common subroutines
require "./common_subs.pl";

$error = 0 unless ($error = $thisScript->param('error'));
$errorstring = "" unless ($errorstring = $thisScript->param('errorstring'));

if (defined($thisScript->param('sessionID'))) {
    # sessionID supplied as argument takes priority
    # empty string may be useful when debugging
    $sessionID = $thisScript->param('sessionID');
} else {
    # try to get from cookie
    $sessionID = $thisScript->cookie('MASCOT_SESSION');
}

# Set variables according to defaults
if (defined($thisScript->param('action'))) {
    $action = $thisScript->param('action');
} else {
    $action = 'nothing';
}

# If display is not defined then assume login_prompt
if (defined($thisScript->param('display'))) {
    $display = $thisScript->param('display');
} else {
    $display = 'login_prompt';
}

if (defined($thisScript->param('savecookie'))) {
    $savecookie = $thisScript->param('savecookie');
} else {
    if ($action eq 'login' && $display ne 'nothing') {
        $savecookie = 1;
    } else {
        $savecookie = 0;
    }
}

if (defined($thisScript->param('clearcookie'))) {
    $clearcookie = $thisScript->param('clearcookie');
} else {
    if ($action eq 'logout' && $display ne 'nothing') {
        $clearcookie = 1;
    } else {
        $clearcookie = 0;
    }
}

if (defined($thisScript->param('onerrdisplay'))) {
    $onerrdisplay = $thisScript->param('onerrdisplay');
} else {
    $onerrdisplay = 'login_prompt';
}

# Check required parameters
if (($action ne 'nothing')
&&  ($action ne 'login')
&&  ($action ne 'logout')
&&  ($action ne 'newpassword')
&&  ($action ne 'issecuritydisabled')
&&  ($action ne 'webauthentication')
&&  ($action ne 'guestlogin')
&&  ($action ne 'ispermitted')
&&  ($action ne 'isfastapermitted')
&&  ($action ne 'integralogin')) {
    $error = -1;
    $errorstring = $action . " is not a valid value for the action parameter";
    $sessionID="";
}

if (($display ne 'nothing')
&&  ($display ne 'login_prompt')
&&  ($display ne 'newpw_prompt')
&&  ($display ne 'logout_prompt')) {
    $error = -1;
    $errorstring = $display . " is not a valid value for the display parameter";
    $sessionID="";
}

if (($onerrdisplay ne 'nothing')
&&  ($onerrdisplay ne 'login_prompt')
&&  ($onerrdisplay ne 'newpw_prompt')
&&  ($onerrdisplay ne 'logout_prompt')) {
    $error = -1;
    $errorstring = $onerrdisplay . " is not a valid value for the onerrdisplay parameter";
    $sessionID="";
}

if (($action eq 'login')
&&  (!defined($thisScript->param('username')) || !defined($thisScript->param('password')))) {
    $error = -1;
    $errorstring = "action parameter is login, but username and password have not been defined";
    $sessionID="";
}

if (($action eq 'integralogin')
&&  (!defined($thisScript->param('username')) || !defined($thisScript->param('connectionID')) || !defined($thisScript->param('integradb')))) {
    $error = -1;
    $errorstring = "action parameter is integralogin, but username, connectionID and integradb have not been defined";
    $sessionID="";
}

if ($action eq 'newpassword') {
    if (defined($thisScript->param('username'))
    &&  defined($thisScript->param('newpw1'))
    &&  defined($thisScript->param('newpw2'))
    &&  defined($thisScript->param('password'))) {
        if ($thisScript->param('newpw1') ne $thisScript->param('newpw2')) {
            $error = -1;
            $errorstring = "Confirmation password does not match. Please try again.";
            $sessionID="";
        }
    } else {
        $error = -1;
        $errorstring = "Require username, newpw1, newpw2 and password parameters to change password";
        $sessionID="";
    }
}

if ($action eq 'ispermitted') {
    if (!$sessionID || !$thisScript->param('sectask')) {
        $error = -1;
        $errorstring = "The ispermitted action requires both sessionID and task identifier";
        $sessionID="";
    }
}

if ($action eq 'isfastapermitted') {
    if (!$sessionID || !$thisScript->param('fasta')) {
        $error = -1;
        $errorstring = "The isfastapermitted action requires sessionID and fasta file";
        $sessionID="";
    }
}

# Do any action now. Must not print errors or anything at this stage because
# headers have not been printed.
if (!$error) {
    if ($action eq 'login') {
        $session = new msparser::ms_session($thisScript->param('username'),
                                            $thisScript->param('password'));
        if ($session->isValid) {
            $sessionID = $session->getID;
            if (defined($thisScript->param('sectask'))) {
              unless ($session->isPermitted($thisScript->param('sectask'))) {
                $session->destroy;
                undef $session;
                $error = -2;
                $errorstring = 'User is not authorised to perform requested task';
                $sessionID="";
              }
            }
        } else {
            $error = $session->getLastError;
            $errorstring = $session->getLastErrorString;
            $sessionID="";

            # Special case - if the error is 'new password required' and
            # the onerrdisplay is set, need to reset onerrdisplay to
            # show the update password form
            if (($error == $msparser::ms_errs::ERR_MSP_SECURITY_PASSWORDEXPIRED)
            &&  ($onerrdisplay ne 'nothing')) {
                $onerrdisplay = 'newpw_prompt';
            }
        }
    }
    if ($action eq 'logout') {
        if ($sessionID) {
            $session = new msparser::ms_session($sessionID);
        } else {
            $session = new msparser::ms_session;
        }
        if ($session->isValid) {
            $session->destroy;
    #    } else {
    #        $error = $session->getLastError;
    #        $errorstring = $session->getLastErrorString;
        }
        undef $session;
        $sessionID="";
    }
    if ($action eq 'integralogin') {
        $session = new msparser::ms_session($thisScript->param('username'),
                                            $thisScript->param('connectionID'),
                                            $thisScript->param('integradb'));
        if ($session->isValid) {
            $sessionID = $session->getID;
            if (defined($thisScript->param('sectask'))) {
              unless ($session->isPermitted($thisScript->param('sectask'))) {
                $session->destroy;
                undef $session;
                $error = -2;
                $errorstring = 'User is not authorised to perform requested task';
                $sessionID="";
              }
            }
        } else {
            $error = $session->getLastError;
            $errorstring = $session->getLastErrorString;
            $sessionID="";
        }
    }
    if ($action eq 'newpassword') {
        $sec = new msparser::ms_security;
        if (!$sec->updatePassword("", # $session->getID,
                                  $thisScript->param('username'),
                                  $thisScript->param('password'),
                                  $thisScript->param('newpw1'))) {
            $error = $sec->getLastError;
            $errorstring = $sec->getLastErrorString;
        }
    }
    if ($action eq 'issecuritydisabled') {
        $session = new msparser::ms_session;
        if ($session->isValid && $session->getUserType == $msparser::ms_user::USER_SECURITY_DISABLED ) {
            $sessionID = $session->getID;
            $error = 0;
            $errorstring = "";
        } else {
            $error = -3;
            $errorstring = "Mascot security is enabled";
            $sessionID="";
        }
    }

    if ($action eq 'webauthentication') {
        if (defined($ENV{'REMOTE_USER'})) {
            my ($sess_name) = $ENV{'REMOTE_USER'} . "_webserverauth";
            $session = new msparser::ms_session($sess_name);
            if ($session->isValid && $session->getUserType == $msparser::ms_user::USER_WEBAUTH ) {
                $sessionID = $session->getID;
            } else {
                $error = -4;
                $errorstring = $ENV{'REMOTE_USER'} . " is not set up to use web server authentication in Mascot";
                $sessionID="";
            }
        } else {
            $error = -4;
            $errorstring = "Web authentication is not enabled on your web server";
            $sessionID="";
        }
    }

    if ($action eq 'guestlogin') {
        $session = new msparser::ms_session('guest_guestsession');
        if ($session->isValid && $session->getUserID == $msparser::ms_user::USERID_GUEST) {
            $sessionID = $session->getID;
        } else {
            $error = -5;
            $errorstring = "Mascot guest account is disabled";
            $sessionID="";
        }
    }

    if ($action eq 'ispermitted') {
        $session = new msparser::ms_session($sessionID);
        if ($session->isValid) {
            unless ($session->isPermitted($thisScript->param('sectask'))) {
                $sessionID="";
                undef $session;
            }
        } else {
            $error = $session->getLastError;
            $errorstring = $session->getLastErrorString;
            $sessionID = "";
        }
    }

    if ($action eq 'isfastapermitted') {
        $session = new msparser::ms_session($sessionID);
        if ($session->isValid) {
            unless ($session->isFastaPermitted($thisScript->param('fasta'))) {
                $sessionID="";
                undef $session;
            }
        } else {
            $error = $session->getLastError;
            $errorstring = $session->getLastErrorString;
            $sessionID = "";
        }
    }
}

# If from the login or logout button, set/clear cookie.
# Has to be done before outputting any other html, so store up errors.
if ($savecookie && !$error) {
    $opts = new msparser::ms_security_options;
    if ($opts->getUseSessionCookies) {
        $cookie1 = $thisScript->cookie (
                    -name    => 'MASCOT_SESSION',
                    -value   => $session->getID,
                    -path    => '/'); # no expiry
        $cookie2 = $thisScript->cookie (
                    -name    => 'MASCOT_USERNAME',
                    -value   => $session->getUserName,
                    -path    => '/'); # no expiry
    } else {
        $cookie1 = $thisScript->cookie (
                    -name    => 'MASCOT_SESSION',
                    -value   => $session->getID,
                    -path    => '/',
                    -expires => '+3M'); # 3 months in the future
        $cookie2 = $thisScript->cookie (
                    -name    => 'MASCOT_USERNAME',
                    -value   => $session->getUserName,
                    -path    => '/',
                    -expires => '+3M'); # 3 months in the future
    }
    # The expires in the next line is for the page, not the cookie
    print $thisScript->header(-cookie => [$cookie1,$cookie2], -expires=>'-1d');
} elsif ($clearcookie) {
    $cookie1 = $thisScript->cookie (
                -name    => 'MASCOT_SESSION',
                -value   => '',
                -path    => '/',
                -expires => '-1d'); # -1d means delete cookie
    $cookie2 = $thisScript->cookie (
                -name    => 'MASCOT_USERNAME',
                -value   => '',
                -path    => '/',
                -expires => '-1d'); # -1d means delete cookie
    # The expires in the next line is for the page, not the cookie
    print $thisScript->header(-cookie => [$cookie1,$cookie2], -expires=>'-1d');
} else {
    print $thisScript->header(-expires=>'-1d');
}

# Now the display
# Print html 'header' if doing a display
if ((!$error && $display ne 'nothing')
||  ($error && defined($onerrdisplay) && $onerrdisplay ne 'nothing')) {
    &printHeader1("Matrix Science - Mascot Login");
    &printHeader2("", "Mascot Login", 0);
    print "<TABLE BORDER=0 CELLSPACING=0 CELLPADDING=0>\n";
    print "<TR><TD COLSPAN=2>\n";
    print "<H1>Mascot Login</H1>\n";

    if (defined($onerrdisplay) && $error) {
        print "<B><FONT COLOR=#FF0000>Error: " . $errorstring . "</FONT></B><p>\n";
        if ($onerrdisplay eq 'login_prompt' ) {
            &displayLoginForm;
        } elsif ($onerrdisplay eq 'newpw_prompt' ) {
            &displayNewPasswordForm;
        } elsif ($onerrdisplay eq 'logout_prompt') {
            &displayLogoutForm;
        } else {
            print "Error with onerrdisplay parameter<br>\n";
        }
    } else {
        if ($display eq 'login_prompt') {
            &displayLoginForm;
        } elsif ($display eq 'newpw_prompt') {
            &displayNewPasswordForm;
        } elsif ($display eq 'logout_prompt') {
            &displayLogoutForm;
        } else {
            print "Error with display parameter<br>\n";
        }
    }

  print "</TD></TR>\n";
  print "</TABLE>\n";
  &printFooter();
  print "</BODY>\n";
  print "</HTML>\n";

} elsif (defined($thisScript->param('referer'))) {
    &displayReferer();
} else {
    # text output
    print "error=" . $error . "\n";
    print "errorstring=" . $errorstring . "\n";
    print "sessionID=" . $sessionID . "\n";
}

sub displayLoginForm {
    print "<form ID=\"mascot_login\" NAME=\"mascot_login\" action=\"" . $thisScript->url(-relative=>1) . "\" ENCTYPE=\"multipart/form-data\" METHOD=\"POST\">\n";
    print "<table align=\"center\" border=\"0\" cellspacing=\"0\" cellpadding=\"3\">\n";
    print "<tr><td>Username:</td><td>\n";
    print "<input type=\"text\" ID=\"username\" name=\"username\" value=\""
      . $thisScript->cookie('MASCOT_USERNAME')
      . "\" maxlength=\"40\">\n";
    print "</td></tr>\n";
    print "<tr><td>Password:</td><td>\n";
    print "<input type=\"password\" name=\"password\" maxlength=\"50\">\n";
    print "</td></tr>\n";
    print "<tr><td colspan=\"2\" align=\"right\">\n";
    print "<input type=\"submit\" name=\"submit\" value=\"Login\">\n";
    print "</td></tr>\n";
    print "<tr><td colspan=\"2\" align=\"right\">&nbsp;</td></tr>\n";
    print "<tr><td>&nbsp;</td><td><A HREF=\"./edit_profile.pl\">Edit profile</A></td></tr>\n";
    print "</table>\n";
    if (defined($thisScript->param('referer'))) {
        print "<input type=\"hidden\" name=\"referer\" value=\"" . $thisScript->param('referer') . "\">\n";
        print "<input type=\"hidden\" name=\"display\" value=\"nothing\">\n";
    } else {
        print "<input type=\"hidden\" name=\"display\" value=\"logout_prompt\">\n";
    }
    print "<input type=\"hidden\" name=\"savecookie\" value=\"1\">\n";
    print "<input type=\"hidden\" name=\"action\" value=\"login\">\n";

    print "<input type=\"hidden\" name=\"onerrdisplay\" value=\"login_prompt\">\n";
    print "</form>\n";
    print "<script type=\"text/javascript\"><!--\n";
    if ($thisScript->cookie('MASCOT_USERNAME')) {
      print "document.mascot_login.password.focus();\n";
    } else {
      print "document.mascot_login.username.focus();\n";
    }
    print "//--></script>\n";
}

sub displayLogoutForm {
    print "<form action=\"" . $thisScript->url(-relative=>1) . "\" ENCTYPE=\"multipart/form-data\" METHOD=\"POST\">\n";
    if ($sessionID) {
        print "<input type=\"hidden\" name=\"sessionID\" value=\"" . $sessionID . "\">\n";
    }
    print "<input type=\"hidden\" name=\"action\" value=\"logout\">\n";
    print "<input type=\"hidden\" name=\"display\" value=\"login_prompt\">\n";
    print "Logged in as " . $session->getUserName . "&nbsp;";
    print "<input type=\"submit\" name=\"logout\" value=\"Logout\">\n";
    print "</form>\n";
}

sub displayNewPasswordForm {
    print "<form ID=\"mascot_newpw\" NAME=\"mascot_newpw\" action=\"" . $thisScript->url(-relative=>1) . "\" ENCTYPE=\"multipart/form-data\" METHOD=\"POST\">\n";
    print "<table align=\"center\" border=\"0\" cellspacing=\"0\" cellpadding=\"3\">\n";
    print "<tr><td>Old password:</td><td>\n";
    print "<input type=\"password\" id=\"password\" name=\"password\" maxlength=\"40\">\n";
    print "</td></tr>\n";
    print "<tr><td>New password:</td><td>\n";
    print "<input type=\"password\" name=\"newpw1\" maxlength=\"50\">\n";
    print "</td></tr>\n";
    print "<tr><td>Confirm new password:</td><td>\n";
    print "<input type=\"password\" name=\"newpw2\" maxlength=\"50\">\n";
    print "</td></tr>\n";
    print "<tr><td colspan=\"2\" align=\"right\">\n";
    print "<input type=\"hidden\" name=\"action\" value=\"newpassword\">\n";
    print "<input type=\"submit\" name=\"submit\" value=\"Change password\">\n";
    print "</td></tr>\n";
    print "</table>\n";
    if (defined($thisScript->param('referer'))) {
        print "<input type=\"hidden\" name=\"referer\" value=\"" . $thisScript->param('referer') . "\">\n";
    } else {
        print "<input type=\"hidden\" name=\"display\" value=\"login_prompt\">\n";
    }
    print "<input type=\"hidden\" name=\"onerrdisplay\" value=\"newpw_prompt\">\n";
    print "<input type=\"hidden\" name=\"username\"  value=\"" . $thisScript->param('username') . "\">\n";
    print "</form>\n";

    print "<script type=\"text/javascript\"><!--\n";
    print "document.mascot_login.username.focus();\n";
    print "//--></script>\n";
}

# Cannot just use the cgi redirect function:
# - The redirect() function redirects the browser to a different URL.
# - If you use redirection like this, you should not print out a header as well.
# Which would also mean that you cannot set cookies. So, do it the hard way.
sub displayReferer() {
    print "<html>\n";
    print "<head>\n";
    print "<title>Login</title>\n";
    print "</head>\n";
    print "<body>\n";
    print "Logged in successfuly - please wait<br>\n";
    print "<SCRIPT LANGUAGE=\"JavaScript\">\n";
    print "<!-- Begin hiding Javascript from old browsers.\n";
    print "if(window.navigator.userAgent.indexOf(\"MSIE\") != -1){\n";
    print "  window.location.replace(\"" . $thisScript->param('referer') . "\");\n";
    print "} else if (window.location.replace == null){\n";
    print "  window.location.assign(\"" . $thisScript->param('referer') . "\");\n";
    print "} else {\n";
    print "  window.location.replace(\"" . $thisScript->param('referer') . "\");\n";
    print "}\n";
    print "\n";
    print "\n";
    print "// End hiding Javascript from old browsers. -->\n";
    print "</SCRIPT>\n";
    print "<NOSCRIPT>\n";
    print "<A HREF=\"" . $thisScript->param('referer') . "\">Click here to if you are not redirected automatically</A>",
    print "</NOSCRIPT>\n";
    print "</body>\n";
    print "</html>\n";
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


ms_aahelper.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_aahelper.hpp                                                      #
00004 # Mascot Parser toolkit                                                      #
00005 # Utility functions for generating peptides, peptide and fragment masses     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_aahelper.hpp $
00012 #    $Author: villek@matrixscience.com $
00013 #      $Date: 2019-11-08 15:15:24 +0000 $
00014 #  $Revision: 3515c2de6fecc95325d37682f127179265ced370 | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_AAHELPER_HPP
00019 #define MS_AAHELPER_HPP
00020
00021
00022 #include <string>
00023 #include <vector>
00024
00025
00026 namespace matrix_science {
00033
00034     class MS_MASCOTRESFILE_API ms_aahelper: public ms_errors
00035     {
00036     public:
00038
00047         enum FRAG_NL {
00048             FRAG_NL_PRIMARY = 0x0001,
00049             FRAG_NL_SECONDARY = 0x0010
00050         };
00051
00053         ms_aahelper();
00054
00056         ms_aahelper(const ms_mascotresfile & resfile,
00057                     const char * enzymeFileName,
00058                     const char * quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
00059                     const char * unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd");
00060
00062         ms_aahelper(const ms_mascotresults & summary,
00063                     const char * enzymeFileName,
00064                     const char * quantSchemaFilePath = "http://www.matrixscience.com/xmlns/schema/quantitation_2  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd",
00065                     const char * unimodSchemaFilePath = "http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd");
00066
00068         ms_aahelper(const ms_aahelper& right);
00069
00071         ~ms_aahelper();
00072
00073 #ifndef SWIG
00074
00075         ms_aahelper& operator=(const ms_aahelper& right);
00076 #endif
00077
00078         void copyFrom(const ms_aahelper* right);
00079
00081         void defaultValues();
00082
00084         void setEnzyme(const ms_enzyme* enzyme);
00085
00087         const ms_enzyme* getEnzyme() const;
00088
00090         void setMasses(const ms_masses *masses);
00091
00093         const ms_masses* getMasses() const;
00094
00096         void setAvailableModifications(const ms_modvector *fixedModVector,
00097                                        const ms_modvector *varModVector);
00098
00100         ms_modvector getFixedMods() const;
00101
00103         ms_modvector getVarMods() const;
00104
00106         void startIteratePeptides(const char* sequenceProtein,
00107                                   const int sizeProtein,
00108                                   const int pfa);
00109
00111         bool getNextPeptide();
00112
00114         int getPepStart() const;
00115
00117         int getPepEnd() const;
00118
00120         int getMissed() const;
00121
00123         void stopIteratePeptides();
00124
00126         double calcPeptideMZ(const char* proteinStr,
00127                              const int proteinLen,
00128                              const int startPos,
00129                              const int endPos,
00130                              const std::vector< int > numThatMustBeModded,
00131                              const int charge,
00132                              const MASS_TYPE massType,
00133                              ms_errs *err) const;
00134
00136         ms_peptide createPeptide(const char* proteinStr,
00137                                  const int proteinLen,
00138                                  const int startPos,
00139                                  const int endPos,
00140                                  const std::vector< int > varMods,
00141                                  const std::vector< int > varModsWhichNl,
00142                                  const int charge,
00143                                  const MASS_TYPE massType,
00144                                  ms_errs *err) const;
00145
00147         ms_peptide createPeptide(const char* proteinStr,
00148                                  const int proteinLen,
00149                                  const int startPos,
00150                                  const int endPos,
00151                                  const std::vector< int > varMods,
00152                                  const std::vector< int > varModsWhichNl,
00153                                  const std::vector< int > summedMods,
00154                                  const std::vector< int > summedModsWhichNl,
00155                                  const int charge,
00156                                  const MASS_TYPE massType,
00157                                  ms_errs *err) const;
00158
00160         ms_peptide createCrosslinkedPeptide(const ms_peptide &pepAlpha,
00161                                             const ms_peptide &pepBeta,
00162                                             const ms_linker_site_vector &linkedSites,
00163                                             ms_errs *err) const;
00164
00166         std::vector< double > calcFragments(const ms_peptide* peptide,
00167                                             const int seriesID,
00168                                             const bool doubleCharged,
00169                                             const double minMass,
00170                                             const double maxMass,
00171                                             const MASS_TYPE massType,
00172                                             ms_fragmentvector* fragments,
00173                                             ms_errs* err,
00174                                             const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
00175
00177         bool calcFragmentsEx(const ms_peptide* peptide,
00178                              const int seriesID,
00179                              const int fragCharge,
00180                              const double minMass,
00181                              const double maxMass,
00182                              const MASS_TYPE massType,
00183                              ms_fragmentvector* fragments,
00184                              ms_errs* err,
00185                              const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
00186
00187 #ifndef SWIG
00188
00189         std::vector< double > calcFragments(const ms_peptide* peptide,
00190                                             const int seriesID,
00191                                             const bool doubleCharged,
00192                                             const double minMass,
00193                                             const double maxMass,
00194                                             const MASS_TYPE massType,
00195                                             std::vector< ms_fragment > *fragments,
00196                                             ms_errs* err,
00197                                             const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
00198
00200         bool calcFragmentsEx(const ms_peptide* peptide,
00201                              const int seriesID,
00202                              const int fragCharge,
00203                              const double minMass,
00204                              const double maxMass,
00205                              const MASS_TYPE massType,
00206                              std::vector< ms_fragment > *fragments,
00207                              ms_errs* err,
00208                              const FRAG_NL fragNlType = FRAG_NL_PRIMARY) const;
00209 #endif
00210
00211
00212     private:
00213         // Nasty const issue with logging and tracing.
00214         ms_errs* getLog() const { return const_cast<ms_errs*>(getErrorHandler()); }
00215
00216         std::string convertPrimaryNlVectorToString(const std::vector< int > modded,
00217                                                    const std::vector< int > whichNl,
00218                                                    const ms_modvector &varMods,
00219                                                    const ms_modvector &varMods_used,
00220                                                    ms_errs* err) const;
00221
00222         std::vector< int > convertPrimaryNlStringToVector(const std::string varModStr,
00223                                                           const std::string primaryNlStr,
00224                                                           const ms_modvector &varMods_used,
00225                                                           ms_errs* err) const;
00226
00227         void initialiseFromResfile(const ms_mascotresfile & resfile,
00228                                    const char * enzymeFileName,
00229                                    const char * quantSchemaFilePath,
00230                                    const char * unimodSchemaFilePath);
00231         bool checkVarModConflicts(const ms_modvector *varModVector, ms_modvector &varMods, std::vector<int> &varModsSrc, ms_modvector &varMods_used, ms_errs &err) const;
00232         bool iscleavagepoint(const char left, const char right) const;
00233         bool switchIndependent();
00234         void updatemissed(const int leftPos);
00235         void dropmissed();
00236         void clearMods();
00237         bool calcUnionFragmentList(const ms_peptide* peptide,
00238                                    const int seriesID,
00239                                    const int fragCharge,
00240                                    const double minMass,
00241                                    const double maxMass,
00242                                    const MASS_TYPE massType,
00243                                    const FRAG_NL fragNlType,
00244                                    std::vector< ms_fragment > *fragments,
00245                                    ms_errs *err,
00246                                    std::vector< double > *vi) const;
00247         bool calcCrosslinkedFragments(const ms_peptide *peptide,
00248                                       const int seriesID,
00249                                       const int fragCharge,
00250                                       const double minMass,
00251                                       const double maxMass,
00252                                       const MASS_TYPE massType,
00253                                       const FRAG_NL fragNlType,
00254                                       std::vector< ms_fragment > *fragments,
00255                                       ms_errs *err,
00256                                       std::vector< double > *vi) const;
00257         bool cfr(const ms_peptide* peptide,
00258                 const ms_peptide::PSM psmComponent,
00259                 const int seriesID,
00260                 const int fragCharge,
00261                 const double minMass,
00262                 const double maxMass,
00263                 const MASS_TYPE massType,
00264                 const FRAG_NL fragNlType,
00265                 const int linkerColumn,
00266                 const double linkerMassOffset,
00267                 std::vector< ms_fragment > *fragments,
00268                 ms_errs* err,
00269                 std::vector< double > *vi) const;
00270
00271         void getSeriesParams(const char* pepStr,
00272                              const int seriesID,
00273                              const ms_masses & masses,
00274                              const MASS_TYPE massType,
00275                              double& delta,
00276                              int& start,
00277                              int& end,
00278                              bool& forward) const;
00279
00280         void prepareCumulativeMassAndNL(const std::string &pepStr,
00281                                         const ms_masses *pMasses,
00282                                         const MASS_TYPE massType,
00283                                         const std::vector<bool> &residue_has_varmod,
00284                                         const std::vector<double> &fixedModNlVals,
00285                                         const std::vector<double> &totalModDelta,
00286                                         const std::vector<double> &totalNlVals,
00287                                         const bool isMasterNL,
00288                                         std::vector<double> &m,
00289                                         std::vector<double> &cumulativeNlVals) const;
00290
00291         class IonSet;
00292         void calculateSeriesMasses(const int seriesID,
00293                                    const int fragCharge,
00294                                    const MASS_TYPE massType,
00295                                    const ms_peptide::PSM psmComponent,
00296                                    const int linkerColumn,
00297                                    const double linkerMassOffset,
00298                                    const ms_masses *pMasses,
00299                                    const std::string &pepStr,
00300                                    const std::vector<double> &m,
00301                                    const std::vector<double> &cumulativeNlVals,
00302                                    const std::vector<bool> &loopLinkingAllows,
00303                                    IonSet &ionSet) const;
00304
00305         void setupFromPre2_2ResultsFile(const std::string & peptide, const std::string & varMods);
00306
00307         class ModLookupHelper;
00308         bool initialiseModsAtResidues(const ModLookupHelper &lookupHelper,
00309                                       const std::string &pepStr,
00310                                       const std::string &modStr,
00311                                       const std::vector<int> &primaryNl,
00312                                       const std::string &monoLinkStr,
00313                                       const ms_modvector *varmods,
00314                                       const std::vector<int> *varmods_src,
00315                                       const ms_modvector *varmods_used,
00316                                       const ms_peptide::PSM psmComponent,
00317                                       std::vector< const ms_modification* > &mod_at_residue,
00318                                       ms_errs *err) const;
00319
00320         bool lookupLocalModVectors(int q, const ms_modvector* &local_mods, const std::vector<int>* &local_mods_src, const ms_modvector* &local_mods_used);
00321         void clearLocalModVectors();
00322
00323         ms_masses   massesUnmod_;
00324         ms_masses   masses_;
00325         ms_umod_configfile umodFile_;
00326         ms_quant_configfile quantFile_;
00327         const ms_mascotresfile * pResfile_;
00328         const ms_mascotresults * pSummary_;
00329
00330         ms_modvector fixedMods_;
00331         ms_modvector varMods_;
00332         std::vector< int > varModsSrc_;
00333         ms_modvector varMods_used_;
00334
00335         typedef std::map<int, ms_modvector > queryParsedLocalMods_t;
00336         typedef std::map<int, std::vector<int> > queryParsedLocalModsSrc_t;
00337         queryParsedLocalMods_t queryParsedLocalMods_;
00338         queryParsedLocalModsSrc_t queryParsedLocalModsSrc_;
00339         queryParsedLocalMods_t queryParsedLocalModsUsed_;
00340
00341         ms_enzyme   enzyme_;
00342         bool        bEnzymeSet_;
00343         std::string protStr_;
00344         int         protLen_;
00345         int         pfa_; // missed cleavages limit
00346
00347         // internal iteration parameters
00348         int         numInd_; // current independent enzyme ID
00349         int         l_, r_; // the last peptide ends
00350         int         missed_; // number of missed cleavages in the current peptide
00351         int         enzymesPassed_;
00352
00353         // for the sake of semi-specific enzymes
00354         bool        forward_;
00355
00356         // For a pre 2.2 results file, need to keep track of what we know
00357         enum DERIVED_MOD_SPECIFICITY_STATUS
00358         {
00359             DMSS_NOT_INITIALISED,
00360             DMSS_WORKING,
00361             DMSS_COMPLETED,
00362             DMSS_FROM_V2_2_OR_LATER_RESFILE,
00363             DMSS_NOT_FROM_RESFILE
00364         };
00365         DERIVED_MOD_SPECIFICITY_STATUS derivedModSpecificityStatus_;
00366         std::vector<MOD_TYPES> derivedModSpecificities_;
00367         typedef std::vector< std::vector<bool> > modifiedResidues_t;
00368         modifiedResidues_t derivedModifiedResidues_;
00369
00370     }; // ms_aahelper // end of mass_calculation_group
00372 } // matrix_science
00373
00374 #endif // MS_AAHELPER_HPP
00375
00376 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_body.hpp
00004 # 'msparser' toolkit
00005 # Implements a reference counted body (pimpl) idiom
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_body.hpp $
00012  * @(#)$Revision: f7c430569a82a92eac8833564053b59680ac20a8 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2021-01-11 13:23:17 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_BODY_HPP
00018 #define MS_BODY_HPP
00019
00020
00021 namespace matrix_science
00022 {
00023
00024     //=========================================================================
00029     class MS_MASCOTRESFILE_API ms_body
00030     {
00031         protected:
00032             ms_body() : refcount_(0) {}
00033             virtual ~ms_body() {}
00034             ms_body(const ms_body &) : refcount_(0) {}
00035 #ifndef SWIG
00036             void operator=(const ms_body &) {}
00037 #endif
00038         private:
00039             void addRef();
00040             bool release(); // true means final release (refcount now zero)
00041             long refcount_;
00042         friend class ms_handle;
00043     };
00044
00045     class MS_MASCOTRESFILE_API ms_handle
00046     {
00047         protected:
00048             explicit ms_handle(ms_body * bodyPtr);
00049             explicit ms_handle(const ms_handle & copy);
00050             virtual ~ms_handle()
00051             {
00052                 attachBody(0);
00053             };
00054 #ifndef SWIG
00055             const ms_handle & operator=(const ms_handle & copy);
00056             ms_body * body();
00057             const ms_body * body() const;
00058 #endif
00059             void attachBody(ms_body * newBody);
00060         private:
00061             ms_body * body_;
00062     };
00063      // end of tools_group
00065     //=========================================================================
00066
00067 } // namespace matrix_science
00068
00069 #endif // MS_BODY_HPP
00070
00071 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_cache_file.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_cache_file.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Used internally in Mascot Parser as well as being available externally     #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive::  $
00013 #     $Author: villek@matrixscience.com $
00014 #       $Date: 2018-07-30 16:23:53 +0100 $
00015 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 # $NoKeywords:: $
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_CACHE_FILE_HPP
00021 #define MS_CACHE_FILE_HPP
00022
00023
00024
00025 // Includes from the standard template library
00026 #include <map>
00027 #include <string>
00028
00029 #ifndef SWIG
00030     // Helper class - don't use from outside library
00031
00032 namespace matrix_science {
00033
00034     class ms_cache_stream;
00035
00036     // internal
00037     struct ms_cache_record
00038     {
00039         UINT64 position;
00040         unsigned length;
00041
00042         inline ms_cache_record()
00043         {
00044             position = 0;
00045             length = 0;
00046         }
00047     };
00048
00049     // internal
00050     class MS_MASCOTRESFILE_API ms_cache_file :
00051         public ms_errors
00052     {
00053         public:
00054             static const unsigned OPEN_FLAG_READ_ONLY = 1;
00055
00056         public:
00057             ms_cache_file();
00058             ~ms_cache_file();
00059
00060             bool open(const std::string & filename, unsigned flags = 0);
00061             void close();
00062             bool save();
00063
00064             bool readStream(ms_cache_stream * stream);
00065             bool writeStream(ms_cache_stream * stream);
00066             bool deleteStream(ms_cache_stream * stream);
00067
00068             std::string getFileName() const { return filename_; }
00069
00070         private:
00071             //Do not copy this object
00072             ms_cache_file(const ms_cache_file & src);
00073             ms_cache_file& operator=(const ms_cache_file & right);
00074
00075             UINT64 appendPos_;
00076             INT64 lastAssignedId_;
00077             unsigned flags_;
00078             std::string filename_;
00079             FILE * fileHandle_;
00080             unsigned version_;
00081             std::map<INT64, ms_cache_record> recordMap_;
00082             bool open_;
00083     }; // end of tools_group
00085 } // matrix_science
00086
00087 #endif // SWIG
00088
00089 #endif // MS_CACHE_FILE_HPP
00090
00091 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_cache_stream.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_cache_stream.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Used internally in Mascot Parser as well as being available externally     #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive::  $
00013 #     $Author: villek@matrixscience.com $
00014 #       $Date: 2018-07-30 16:23:53 +0100 $
00015 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 # $NoKeywords:: $
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_CACHE_STREAM_HPP
00021 #define MS_CACHE_STREAM_HPP
00022
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <vector>
00028
00029 #ifndef SWIG
00030     // Helper class - don't use from outside library
00031
00032 namespace matrix_science
00033 {
00034     class ms_cache_file;
00035     class ms_tinycdb;
00036
00037     class MS_MASCOTRESFILE_API ms_cache_stream
00038     {
00039         public:
00040             ms_cache_stream();
00041             virtual ~ms_cache_stream();
00042
00043             INT64 getId() const;
00044             void setId(INT64 id);
00045
00046             void clear(); // clear the stream, free up storage
00047             void reserve(size_t byteCount); // pre-allocate space for copying data into
00048             unsigned getBytesAvailable() const; // number of bytes currently available for reading
00049             bool isOverExhausted() const; // true is attempt has been made to read more data than the stream has avaialble
00050
00051             void add(int value); // 4 bytes
00052             void add(unsigned value); // 4 bytes
00053             void add(INT64 value); // 8 bytes
00054             void add(UINT64 value); // 8 bytes
00055             void add(bool value);  // 4 bytes (yes, really)
00056             void add(double value); // 8 bytes
00057             void add(const char * value, size_t length); // 4 byte unsigned length plus n x char (1 byte each), NOT null terminated
00058             void add(const char * value); // 4 byte unsigned length plus n x char (1 byte each), NOT null terminated
00059             void add(const std::string & value); // 4 byte unsigned length plus n x char (1 byte each), NOT null terminated
00060
00061             int getInt32();
00062             unsigned getUnsigned32();
00063             INT64 getInt64();
00064             UINT64 getUnsigned64();
00065             bool getBool();
00066             double getDouble();
00067             std::string getString();
00068
00069             void addBytes(const void * bytes, size_t size); // add bytes to the end of the stream
00070             void getBytes(void * bytes, size_t size); // copy bytes from the stream, extend read position
00071
00072             const char * getBuffer() const;
00073             unsigned getBufferLength() const;
00074
00075             bool save(matrix_science::ms_tinycdb & cdbFile, const std::string & streamName) const;
00076
00077         private:
00078             INT64 id_;
00079             size_t readPosition_;
00080             std::vector<char> buffer_;
00081             bool isOverExhausted_;
00082
00083         friend class ms_cache_file;
00084     };
00085
00086 } // matrix_science
00087
00088 #endif // SWIG
00089
00090 #endif // MS_CACHE_STREAM_HPP
00091
00092 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_cdb_sharding.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_cdb_sharding.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Sharding of the cdb files based on the content and the size                #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2021 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #     $Author: francoisr@matrixscience.com $
00013 #       $Date: 2022-02-18 16:21:35 +0000 $
00014 #   $Revision: b37898d7f040eb50775669c2cfd1f9c88ef4d2da | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_CDB_SHARDING_HPP
00019 #define MS_CDB_SHARDING_HPP
00020
00021 #ifndef SWIG
00022
00023 using namespace matrix_science;
00024
00025 namespace msparser_internal {
00026
00027     class CdbPreparingHelper
00028     {
00029     public:
00038         static bool moveFileSafely(const std::string & sourceFile, const std::string & targetFile, std::string & strError);
00039
00049         static bool archiveFileToDirectory(const std::string & archiveDir, const std::string & sourceFile, const std::string & targetFile, std::string & strError);
00050
00060         static bool moveAllFilesInDirectory(const std::string & sourceDir, const std::string & targetDir, std::string & strError, const ms_taxonomyrules * taxRules = nullptr);
00061     };
00062
00063     class CdbShard : public ms_errors
00064     {
00065     public:
00066
00076         CdbShard(const std::string & baseFileName, const char letter, const unsigned numCbdFiles, const bool keepFilesOpen, const bool splitShards);
00077
00078         ~CdbShard();
00079
00085         bool isGood() const { return success_; };
00086
00091         void prepareFiles();
00092
00097         void finaliseFiles();
00098
00104         std::string openFiles();
00105
00110         void closeFiles();
00111
00116         void retargetFiles(const std::string & targetBaseFileName, const std::string & compressionDir, const std::string & targetDir);
00117
00123         char getLetter() const { return letter_; };
00124
00130         int getNumCdb() const { return static_cast<int>(vecCdbFiles_.size()); };
00131
00138         int getIntValue(const std::string & key) const;
00139
00147         bool setIntValue(const std::string & key, const int intValue);
00148
00149     private:
00150         std::string getCdbFileName(char c, int num) const;
00151
00152         std::string baseFileName_;
00153         char letter_;
00154         bool success_;
00155         UINT64 currentCdbSize_;
00156         unsigned currentCdbFileIdx_;
00157         unsigned numCdbFiles_; //only relevant when reading if splitShards is true
00158
00159         //performance tuning
00160         bool keepFilesOpen_;
00161         bool splitShards_;
00162
00163         std::vector<matrix_science::ms_tinycdb *> vecCdbFiles_;
00164     };
00165
00166     class CdbSharding : public ms_errors
00167     {
00168     public:
00169
00178         CdbSharding(const std::string & baseFileName, const bool keepFilesOpen, const bool splitShards, const std::string preparingDir = ".");
00179
00180         ~CdbSharding();
00181
00187         bool isGood() const;
00188
00194         bool mustCreate() { return mustCreate_; }
00195
00201         bool prepareShards();
00202
00208         std::string getWorkingBaseFileName();
00209
00215         bool finaliseShards();
00216
00222         bool openShards();
00223
00228         void closeShards();
00229
00236         int getIntValue(const std::string & accession) const;
00237
00245         bool setIntValue(const std::string & accession, const int intValue);
00246
00247     private:
00248         bool deletePreviousFiles();
00249         bool isNumberOrLetter(const char c) const;
00250         CdbShard * getShardForAccession(const std::string & accession) const;
00251
00252         std::string baseFileName_;
00253         bool success_;
00254
00255         bool mustCreate_;
00256
00257         //performance tuning
00258         bool keepFilesOpen_;
00259         bool splitShards_;
00260
00261         matrix_science::ms_tinycdb * mainCdbFile_; //this is used to store how many cdb files each shard has
00262         std::vector<CdbShard *> vecCharToShard_;
00263         std::vector<CdbShard *> vecShards_;
00264
00265         std::string preparingDir_;
00266         std::string sourceDir_;
00267         std::string baseFileName_withoutPath_;
00268         bool differentCompressionDir_;
00269         std::string working_baseFileName_;
00270     };
00271
00272 } // namespace msparser_internal
00273
00274 #endif // SWIG
00275
00276 #endif // MS_CDB_SHARDING_HPP
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_clusterparams.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_clusterparams.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "mascot.dat"-file that describes most important parameters    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_clusterparams.hpp       $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_CLUSTERPARAMS_HPP
00020 #define MS_CLUSTERPARAMS_HPP
00021
00022
00023 #include <string>
00024
00025
00026 namespace matrix_science {
00040     enum OPERATING_SYS
00041     {
00042         _OS_UNKNOWN           = 0,
00043         _OS_WINDOWS_NT        = 1,
00044         _OS_LINUX             = 2,
00045         _OS_NUM_OPERATING_SYS = 3
00046     };
00047
00049
00071     class MS_MASCOTRESFILE_API ms_clusterparams: public ms_customproperty
00072     {
00073         friend class ms_datfile;
00074     public:
00076
00083         enum {
00084             NUM_PROCESSORS_AUTO_DETECT = -1
00085         };
00086
00088         ms_clusterparams();
00089
00091         ms_clusterparams(const ms_clusterparams& src);
00092
00094         ~ms_clusterparams();
00095
00097         void defaultValues();
00098
00100         void copyFrom(const ms_clusterparams* right);
00101
00102 #ifndef SWIG
00103
00104         ms_clusterparams& operator=(const ms_clusterparams& right);
00105 #endif
00106
00107         bool isSectionAvailable() const;
00108
00110         void setSectionAvailable(const bool value);
00111
00113         bool isEnabled() const;
00114
00116         void setEnabled(const bool flag);
00117
00119         const ms_computeraddress* getMasterComputer() const;
00120
00122         void setMasterComputer(const ms_computeraddress* value);
00123
00125         OPERATING_SYS getDefaultNodeOS() const;
00126
00128         void setDefaultNodeOS(const OPERATING_SYS value);
00129
00131         std::string getDefaultNodeHomeDir() const;
00132
00134         void setDefaultNodeHomeDir(const char* str);
00135
00137         int getDefaultPort() const;
00138
00140         void setDefaultPort(const int value);
00141
00143         std::string getDefaultNodeHomeDirFromMaster() const;
00144
00146         void setDefaultNodeHomeDirFromMaster(const char* str);
00147
00149         std::string getMascotNodeScript() const;
00150
00152         void setMascotNodeScript(const char* str);
00153
00155         std::string getMascotNodeRebootScript() const;
00156
00158         void setMascotNodeRebootScript(const char* str);
00159
00161         int getNumberOfSubClusters() const;
00162
00164         void clearSubClusters();
00165
00167         int getSubClusterID(const int index) const;
00168
00170         int getSubClusterMaxCPU(const int index) const;
00171
00173         void appendSubCluster(const int id, const int maxCPUs);
00174
00175         // internal usage only
00176         int getThisSubClusterID() const;
00177
00178         // internal usage only
00179         void setThisSubClusterID(const int id);
00180
00182         int getIPCTimeout() const;
00183
00185         void setIPCTimeout(const int value);
00186
00188         int getIPCLogging() const;
00189
00191         void setIPCLogging(const int value);
00192
00194         std::string getIPCLogfile() const;
00195
00197         void setIPCLogfile(const char* str);
00198
00200         int getCheckNodesAliveFreq() const;
00201
00203         void setCheckNodesAliveFreq(const int value);
00204
00206         int getSecsToWaitForNodeAtStartup() const;
00207
00209         void setSecsToWaitForNodeAtStartup(const int value);
00210
00212         std::string getNodeSequenceDatabaseDir() const;
00213
00215         void setNodeSequenceDatabaseDir(const char* str);
00216
00217 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00218 #include "suppress_ms_customproperty.hpp"
00219 #endif
00220
00221     private:
00222         bool            sectionAvailable_;
00223         bool            enabled_;
00224
00225         ms_computeraddress masterComputer_;
00226
00227         OPERATING_SYS   defaultNodeOS_;
00228         std::string     szDefaultNodeHomeDir_;
00229         int             defaultPort_;
00230         std::string     szDefaultNodeHomeDirFromMaster_;
00231         std::string     szMascotNodeScript_;
00232         std::string     szMascotNodeRebootScript_;
00233
00234         std::vector<int> subClusterIDs_;
00235         std::vector<int> maxCpusPerSubCluster_;
00236         bool             anySubCluster_;
00237
00238         int             thisSubCluster_;
00239
00240         int             IPCTimeout_;
00241         int             IPCLogging_;
00242         std::string     IPCLogfile_;
00243         int             checkNodesAliveFreq_;
00244         int             secsToWaitForNodeAtStartup_;
00245
00246         std::string     szNodeSequenceDatabaseDir_;
00247     }; // class ms_clusterparams // end of config_group
00249 } // namespace matrix_science
00250
00251 #endif // MS_CLUSTERPARAMS_HPP
00252
00253 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_computeraddress.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_computeraddress.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Contains computer address parameters required by cluster mode              #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_computeraddress.hpp     $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_COMPUTERADDRESS_HPP
00020 #define MS_COMPUTERADDRESS_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026 namespace matrix_science {
00032
00033     class MS_MASCOTRESFILE_API ms_computeraddress
00034     {
00035         friend class ms_datfile;
00036         friend class ms_clusterparams;
00037
00038     public:
00040         ms_computeraddress();
00041
00043         ms_computeraddress(const ms_computeraddress& src);
00044
00046         ~ms_computeraddress();
00047
00049         void defaultValues();
00050
00052         void copyFrom(const ms_computeraddress* right);
00053
00054 #ifndef SWIG
00055
00056         ms_computeraddress& operator=(const ms_computeraddress& right);
00057 #endif
00058
00059         std::string getInetAddress() const;
00060
00062         void setInetAddress(const char* address);
00063
00065         std::string getHostName() const;
00066
00068         void setHostName(const char* name);
00069
00071         unsigned int getPort() const;
00072
00074         void setPort(const unsigned int value);
00075
00076     private:
00077         std::string     inetAddress_;
00078         std::string     hostName_;
00079         unsigned short  port_;
00080
00081         void setCustomString();
00082         std::string     customString_;
00083     }; // class ms_computeraddress // end of config_group
00085 } // namespace matrix_science
00086
00087 #endif // MS_COMPUTERADDRESS_HPP
00088
00089 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_connection_settings.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_connection_settings.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Holds the proxy server and Mascot sessionID string                         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_connection_settings.hpp $ #
00012 #     $Author: villek@matrixscience.com $                                                      #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $                                         #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                        #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020
00021 #if !defined(ms_connection_settings_INCLUDED_)
00022 #define ms_connection_settings_INCLUDED_
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027
00028
00029 namespace matrix_science {
00030     class ms_mascotoptions;
00031
00038
00039
00053     class MS_MASCOTRESFILE_API ms_connection_settings
00054     {
00055
00056     public:
00058
00061         enum PROXY_TYPE
00062         {
00063             PROXY_TYPE_NO_PROXY       = 0x0000,
00064             PROXY_TYPE_FROM_REGISTRY  = 0x0001,
00065             PROXY_TYPE_SPECIFY        = 0x0002,
00066             PROXY_TYPE_WPAD           = 0x0003,
00067             PROXY_TYPE_ENVIRONMENT    = 0x0004,
00068             PROXY_TYPE_AUTO           = 0x0005
00069         };
00070
00075         enum HTTP_PROTOCOL
00076         {
00077             HTTP_1_0                = 0x0000,
00078             HTTP_1_1                = 0x0001,
00079             HTTP_SYSTEM_DEFAULT     = 0x0002
00080         };
00081
00086         enum REDIRECT_POLICY
00087         {
00088             REDIRECT_POLICY_ALWAYS                 = 0x0000,
00089             REDIRECT_POLICY_DISALLOW_HTTPS_TO_HTTP = 0x0001,
00090             REDIRECT_POLICY_NEVER                  = 0x0002
00091         };
00092
00094         ms_connection_settings();
00095
00097         ms_connection_settings(const std::string sessionID,
00098                                const std::string proxyServer,
00099                                const std::string proxyUserName,
00100                                const std::string proxyUserPassword);
00101
00103         ~ms_connection_settings();
00104
00106         void defaultValues();
00107
00109         void copyFrom(const ms_connection_settings* right);
00110
00111 #ifndef SWIG
00112
00113         ms_connection_settings& operator=(const ms_connection_settings & right);
00114 #endif
00115
00116         void setSessionID(const std::string sessionID);
00117
00119         void setProxyServerType(ms_connection_settings::PROXY_TYPE proxyType);
00120
00122         ms_connection_settings::PROXY_TYPE getProxyServerType() const;
00123
00125         void setHttpProtocol(ms_connection_settings::HTTP_PROTOCOL httpProtocol);
00126
00128         ms_connection_settings::HTTP_PROTOCOL getHttpProtocol() const;
00129
00131         void setProxyServer(const std::string proxyServer);
00132
00134         void setProxyUsername(const std::string proxyUserName);
00135
00137         void setProxyPassword(const std::string proxyUserPassword);
00138
00140         void setUserAgent(const std::string userAgent);
00141
00143         void setUseHTTPProxyForFTP(bool value);
00144
00146         void setUseHTTPProxyForHTTPS(bool value);
00147
00149         std::string getSessionID() const;
00150
00152         std::string getProxyServer() const;
00153
00155         std::string getProxyUsername() const;
00156
00158         std::string getProxyPassword() const;
00159
00161         std::string getProxyUserAndPassword() const;
00162
00164         std::string getUserAgent() const;
00165
00167         bool isUseHTTPProxyForFTP() const;
00168
00170         bool isUseHTTPProxyForHTTPS() const;
00171
00173         void setConnectionTimeout(int timeout);
00174
00176         int getConnectionTimeout() const;
00177
00179         void setHttpUsername(const std::string httpUsername);
00180
00182         std::string getHttpUsername() const;
00183
00185         void setHttpPassword(const std::string httpPassword);
00186
00188         std::string getHttpPassword() const;
00189
00191         void setRedirectPolicy(ms_connection_settings::REDIRECT_POLICY redirectPolicy);
00192
00194         ms_connection_settings::REDIRECT_POLICY getRedirectPolicy() const;
00195
00197         void getProxySettings(const ms_mascotoptions &opts);
00198
00200         static int proxyTypeStringToEnum(std::string str);
00201
00203         static std::string proxyTypeToString(int type);
00204
00205     private:
00206         std::string sessionID_;
00207         std::string proxyServer_;
00208         std::string proxyUserName_;
00209         std::string proxyUserPassword_;
00210         bool useHTTPProxyForFTP_;
00211         bool useHTTPProxyForHTTPS_;
00212         std::string userAgent_;
00213         PROXY_TYPE proxyType_;
00214         HTTP_PROTOCOL httpProtocol_;
00215         int connectionTimeout_;
00216         std::string httpUsername_;
00217         std::string httpPassword_;
00218         REDIRECT_POLICY redirectPolicy_;
00219
00220         struct proxy_type_strings_t {
00221             const char *str;
00222             const char *pretty_str;
00223             int type;
00224         };
00225
00226         static const struct proxy_type_strings_t proxy_type_strings[];
00227     }; // end of http_client_groupp
00229 }
00230 #endif // !defined(ms_connection_settings_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_cronoptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_cronoptions.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Represents parameters from cron-section of 'mascot.dat' configuration file #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_cronoptions.hpp         $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_CRONOPTIONS_HPP
00020 #define MS_CRONOPTIONS_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00033
00034
00037     class MS_MASCOTRESFILE_API ms_cronjob
00038     {
00039         friend class ms_datfile;
00040         friend class ms_cronoptions;
00041
00042     public:
00044         ms_cronjob();
00045
00047         ms_cronjob(const ms_cronjob& src);
00048
00050         ~ms_cronjob();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_cronjob* right);
00057
00058 #ifndef SWIG
00059
00060         ms_cronjob& operator=(const ms_cronjob& right);
00061 #endif
00062
00063         bool isEnabled() const;
00064
00066         void setEnabled(const bool enabled);
00067
00069         bool isMinute(const int min) const;
00070
00072         void setMinute(const int min, const bool value);
00073
00075         bool isHour(const int hour) const;
00076
00078         void setHour(const int hour, const bool value);
00079
00081         bool isDayOfMonth(const int day) const;
00082
00084         void setDayOfMonth(const int day, const bool value);
00085
00087         bool isMonthOfYear(const int month) const;
00088
00090         void setMonthOfYear(const int month, const bool value);
00091
00093         bool isDayOfWeek(const int day) const;
00094
00096         void setDayOfWeek(const int day, const bool value);
00097
00099         std::string getCommandStr() const;
00100
00102         void setCommandStr(const char* str);
00103
00104         // used internally
00105         std::string getStringValue() const;
00106
00107     private:
00108         bool  enabled_;               /* If false, then a #[space] at start of line */
00109         bool  minute_[60];            /* index of 0-59 - Value of true means do it  */
00110         bool  hour_[24];              /* index of 0-23 - Value of true means do it  */
00111         bool  dayOfMonth_[32];        /* index of 1-31 - Value of true means do it  */
00112         bool  monthOfYear_[13];       /* index of 1-12 - Value of true means do it  */
00113         bool  dayOfWeek_[7];          /* index of  0-6 (0 = Sunday)                 */
00114         std::string szCommand_;
00115
00116         void setCustomString();
00117         std::string customString_;
00118     }; // class ms_cronjob
00119
00121
00149     class MS_MASCOTRESFILE_API ms_cronoptions: public ms_customproperty
00150     {
00151         friend class ms_datfile;
00152     public:
00153
00155         ms_cronoptions();
00156
00158         ms_cronoptions(const ms_cronoptions& src);
00159
00161         ~ms_cronoptions();
00162
00164         void defaultValues();
00165
00167         void copyFrom(const ms_cronoptions* right);
00168
00169 #ifndef SWIG
00170
00171         ms_cronoptions& operator=(const ms_cronoptions& right);
00172 #endif
00173
00174         bool isSectionAvailable() const;
00175
00177         void setSectionAvailable(const bool value);
00178
00180         bool isCronEnabled() const;
00181
00183         void setCronEnabled(const bool value);
00184
00186         int getNumberOfCronJobs() const;
00187
00189         const ms_cronjob getCronJob(const int idx) const;
00190
00192         bool setCronJob(const int idx, const ms_cronjob job);
00193
00195         bool deleteCronJob(const int idx);
00196
00198         void clearCronJobs();
00199
00201         void appendCronJob(const ms_cronjob* job);
00202
00204         int getLoggingLevel() const;
00205
00207         bool setLoggingLevel(const int level);
00208
00210         std::string getLogFileName() const;
00211
00213         bool setLogFileName(const std::string & fileName);
00214
00215
00216 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00217 #include "suppress_ms_customproperty.hpp"
00218 #endif
00219
00220     private:
00221         int findProperty(const ms_cronjob & job) const;
00222         bool getPropertyNameValue(const ms_cronjob & job, std::string & name, std::string & value) const;
00223         bool                        sectionAvailable_;
00224         bool                        cronEnabled_;
00225         std::vector< ms_cronjob  >  cronJobArray_;
00226         int                         loggingLevel_;
00227         std::string                 logFileName_;
00228     }; // ms_cronoptions // end of config_group
00230 } // namespace matrix_science
00231
00232 #endif // MS_CRONOPTIONS_HPP
00233
00234 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_accession.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_accession.hpp                                        #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates accession element in crosslinking.xml                         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_accession.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_ACCESSION_HPP
00018 #define MS_CROSSLINKING_ACCESSION_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030
00036
00037
00042     class MS_MASCOTRESFILE_API ms_crosslinking_accession: public ms_xml_IValidatable
00043     {
00044         friend class msparser_internal::ms_crosslinking_xmlloader;
00045
00046     public:
00048         ms_crosslinking_accession();
00049
00051         ms_crosslinking_accession(const ms_crosslinking_accession& src);
00052
00054         virtual ~ms_crosslinking_accession();
00055
00057         void defaultValues();
00058
00060         void copyFrom(const ms_crosslinking_accession* right);
00061
00062 #ifndef SWIG
00063
00064         ms_crosslinking_accession& operator=(const ms_crosslinking_accession& right);
00065 #endif
00066
00068         virtual std::string getSchemaType() const;
00069
00071         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00072
00074         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00075
00076
00078         bool haveDatabaseName() const;
00079
00081         std::string getDatabaseName() const;
00082
00084         void setDatabaseName(const char* value);
00085
00087         void dropDatabaseName();
00088
00090         std::string getDatabaseNameSchemaType() const;
00091
00092
00094         bool haveValue() const;
00095
00097         std::string getValue() const;
00098
00100         void setValue(const char* value);
00101
00103         void dropValue();
00104
00106         std::string getValueSchemaType() const;
00107
00108
00109     private:
00110         std::string _databaseName;
00111         bool _databaseName_set;
00112
00113         std::string _value;
00114
00115     }; // class ms_crosslinking_accession
00116  // end of config_group
00118
00119 } // namespace matrix_science
00120
00121 #endif // MS_CROSSLINKING_ACCESSION_HPP
00122
00123 /*------------------------------- End of File -------------------------------*/
00124
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_accessions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_accessions.hpp                                       #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates accessions element in crosslinking.xml                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_accessions.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_ACCESSIONS_HPP
00018 #define MS_CROSSLINKING_ACCESSIONS_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_crosslinking_accession;
00030     class ms_xml_schema; // forward declaration
00031
00037
00038
00043     class MS_MASCOTRESFILE_API ms_crosslinking_accessions: public ms_xml_IValidatable
00044     {
00045         friend class msparser_internal::ms_crosslinking_xmlloader;
00046
00047     public:
00049         ms_crosslinking_accessions();
00050
00052         ms_crosslinking_accessions(const ms_crosslinking_accessions& src);
00053
00055         virtual ~ms_crosslinking_accessions();
00056
00058         void defaultValues();
00059
00061         void copyFrom(const ms_crosslinking_accessions* right);
00062
00063 #ifndef SWIG
00064
00065         ms_crosslinking_accessions& operator=(const ms_crosslinking_accessions& right);
00066 #endif
00067
00069         virtual std::string getSchemaType() const;
00070
00072         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00073
00075         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00076
00077
00079         int getNumberOfAccessions() const;
00080
00082         void clearAccessions();
00083
00085         void appendAccession(const ms_crosslinking_accession *item);
00086
00088         const ms_crosslinking_accession * getAccessionByNumber(const int idx) const;
00089
00091         bool updateAccessionByNumber(const int idx, const ms_crosslinking_accession* accession);
00092
00094         bool deleteAccessionByNumber(const int idx);
00095
00097         std::string getAccessionSchemaType() const;
00098
00099
00100     private:
00101         typedef std::vector< ms_crosslinking_accession * > accession_vector;
00102         accession_vector _accessions;
00103
00104     }; // class ms_crosslinking_accessions
00105  // end of config_group
00107
00108 } // namespace matrix_science
00109
00110 #endif // MS_CROSSLINKING_ACCESSIONS_HPP
00111
00112 /*------------------------------- End of File -------------------------------*/
00113
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_configfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_configfile.hpp                                       #
00004 # 'msparser' toolkit                                                         #
00005 # Represents crosslinking.xml file                                           #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 # $Author: villek@matrixscience.com $ #
00012 # $Date: 2018-12-20 12:05:22 +0000 $ #
00013 # $Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 ##############################################################################
00015 */
00016
00017 #ifndef MS_CROSSLINKING_CONFIGFILE_HPP
00018 #define MS_CROSSLINKING_CONFIGFILE_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024
00025 namespace matrix_science {
00026     class ms_crosslinking_method; // forward declaration
00027
00033
00034
00048     class MS_MASCOTRESFILE_API ms_crosslinking_configfile: public ms_errors
00049     {
00050     public:
00052         ms_crosslinking_configfile();
00053
00055         ms_crosslinking_configfile(const char* fileName, const char* schemaFileName,
00056             const ms_connection_settings * cs = 0, bool useSchema = true);
00057
00059         ms_crosslinking_configfile(const ms_crosslinking_configfile& right);
00060
00062         virtual ~ms_crosslinking_configfile();
00063
00064 #ifndef SWIG
00065
00066         ms_crosslinking_configfile& operator=(const ms_crosslinking_configfile& right);
00067 #endif
00068
00069         void copyFrom(const ms_crosslinking_configfile* right);
00070
00072         virtual void defaultValues();
00073
00075         std::string getFileName() const;
00076
00078         void setFileName(const char* filename);
00079
00081         void setSchemaFileName(const char* name);
00082
00084         std::string getSchemaFileName() const;
00085
00087         static std::string getDefaultSchemaFileName();
00088
00090         void setConnectionSettings(const ms_connection_settings & cs);
00091
00093         ms_connection_settings getConnectionSettings() const;
00094
00096         void read_file();
00097
00099         void save_file();
00100
00102         void read_buffer(const char* buffer);
00103
00105         std::string save_buffer(bool validateAgainstSchema = true);
00106
00108         std::string validateDocument() const;
00109
00111         std::string getMajorVersion() const;
00112
00114         std::string getMinorVersion() const;
00115
00116
00118         int getNumberOfMethods() const;
00119
00121         void clearMethods();
00122
00124         void appendMethod(const ms_crosslinking_method *elem);
00125
00127         const ms_crosslinking_method * getMethodByNumber(const int idx) const;
00128
00130         const ms_crosslinking_method * getMethodByName(const char *name) const;
00131
00133         bool updateMethodByNumber(const int idx, const ms_crosslinking_method* method);
00134
00136         bool updateMethodByName(const char *name, const ms_crosslinking_method* method);
00137
00139         bool deleteMethodByNumber(const int idx);
00140
00142         bool deleteMethodByName(const char *name);
00143
00144
00145     private:
00146         std::string             m_fileName;
00147         std::string             m_schemaFileName;
00148         ms_connection_settings  m_cs;
00149
00150         std::string m_majorVersion;
00151         std::string m_minorVersion;
00152
00153         std::string m_encodingName;
00154         bool m_useSchema;
00155
00156         typedef std::vector< ms_crosslinking_method* > method_vector;
00157         method_vector          m_methods;
00158
00159     }; // class ms_crosslinking_configfile
00160  // end of config_group
00162
00163 } // namespace matrix_science
00164
00165 #endif // MS_CROSSLINKING_CONFIGFILE_HPP
00166 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_does_not_pair_with.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_does_not_pair_with.hpp                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates does_not_pair_with element in crosslinking.xml                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_does_not_pair_with.hpp $
00012  * @(#)$Revision: 5a6646e705a1dce6cb8493dec184ed46d0bd6c08 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-10-18 16:39:04 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_DOES_NOT_PAIR_WITH_HPP
00018 #define MS_CROSSLINKING_DOES_NOT_PAIR_WITH_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030
00036
00037     class MS_MASCOTRESFILE_API ms_crosslinking_does_not_pair_with: public ms_xml_IValidatable
00038     {
00039         friend class msparser_internal::ms_crosslinking_xmlloader;
00040
00041     public:
00043         ms_crosslinking_does_not_pair_with();
00044
00046         ms_crosslinking_does_not_pair_with(const ms_crosslinking_does_not_pair_with& src);
00047
00049         virtual ~ms_crosslinking_does_not_pair_with();
00050
00052         void defaultValues();
00053
00055         void copyFrom(const ms_crosslinking_does_not_pair_with* right);
00056
00057 #ifndef SWIG
00058
00059         ms_crosslinking_does_not_pair_with& operator=(const ms_crosslinking_does_not_pair_with& right);
00060 #endif
00061
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00073         bool haveModFileName() const;
00074
00076         std::string getModFileName() const;
00077
00079         void setModFileName(const char* value);
00080
00082         void dropModFileName();
00083
00085         std::string getModFileNameSchemaType() const;
00086
00087
00088     private:
00089         std::string _modFileName;
00090         bool _modFileName_set;
00091
00092     }; // class ms_crosslinking_does_not_pair_with
00093  // end of config_group
00095
00096 } // namespace matrix_science
00097
00098 #endif // MS_CROSSLINKING_DOES_NOT_PAIR_WITH_HPP
00099
00100 /*------------------------------- End of File -------------------------------*/
00101
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_filters.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_filters.hpp                                          #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the filters element in crosslinking.xml                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_filters.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_FILTERS_HPP
00018 #define MS_CROSSLINKING_FILTERS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030     class ms_crosslinking_parameters;
00031
00037
00038
00051     class MS_MASCOTRESFILE_API ms_crosslinking_filters: public ms_crosslinking_parameters
00052     {
00053         friend class msparser_internal::ms_crosslinking_xmlloader;
00054
00055     public:
00057         ms_crosslinking_filters();
00058
00060         ms_crosslinking_filters(const ms_crosslinking_filters& src);
00061
00063         virtual ~ms_crosslinking_filters();
00064
00066         void defaultValues();
00067
00069         void copyFrom(const ms_crosslinking_filters* right);
00070
00071 #ifndef SWIG
00072
00073         ms_crosslinking_filters& operator=(const ms_crosslinking_filters& right);
00074 #endif
00075
00076         virtual std::string getSchemaType() const;
00077
00079         virtual std::string getParameterSchemaType() const;
00080
00081     }; // class ms_crosslinking_filters
00082  // end of config_group
00084
00085 } // namespace matrix_science
00086
00087 #endif // MS_CROSSLINKING_FILTERS_HPP
00088
00089 /*------------------------------- End of File -------------------------------*/
00090
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_linker.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_linker.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates linker element in crosslinking.xml                            #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_linker.hpp $
00012  * @(#)$Revision: 5a6646e705a1dce6cb8493dec184ed46d0bd6c08 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-10-18 16:39:04 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_LINKER_HPP
00018 #define MS_CROSSLINKING_LINKER_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_crosslinking_monolink;
00030     class ms_crosslinking_does_not_pair_with;
00031     class ms_xml_schema; // forward declaration
00032
00038
00039
00056     class MS_MASCOTRESFILE_API ms_crosslinking_linker: public ms_xml_IValidatable
00057     {
00058         friend class msparser_internal::ms_crosslinking_xmlloader;
00059
00060     public:
00062         ms_crosslinking_linker();
00063
00065         ms_crosslinking_linker(const ms_crosslinking_linker& src);
00066
00068         virtual ~ms_crosslinking_linker();
00069
00071         void defaultValues();
00072
00074         void copyFrom(const ms_crosslinking_linker* right);
00075
00076 #ifndef SWIG
00077
00078         ms_crosslinking_linker& operator=(const ms_crosslinking_linker& right);
00079 #endif
00080
00082         virtual std::string getSchemaType() const;
00083
00085         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00086
00088         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00089
00091         bool haveModFileName() const;
00092
00094         std::string getModFileName() const;
00095
00097         void setModFileName(const char* value);
00098
00100         void dropModFileName();
00101
00103         std::string getModFileNameSchemaType() const;
00104
00105
00107         int getNumberOfMonoLinks() const;
00108
00110         void clearMonoLinks();
00111
00113         void appendMonoLink(const ms_crosslinking_monolink *item);
00114
00116         const ms_crosslinking_monolink * getMonoLinkByNumber(const int idx) const;
00117
00119         bool updateMonoLinkByNumber(const int idx, const ms_crosslinking_monolink* monolink);
00120
00122         bool deleteMonoLinkByNumber(const int idx);
00123
00125         std::string getMonoLinkSchemaType() const;
00126
00127
00129         int getNumberOfDoesNotPairWiths() const;
00130
00132         void clearDoesNotPairWiths();
00133
00135         void appendDoesNotPairWith(const ms_crosslinking_does_not_pair_with *item);
00136
00138         const ms_crosslinking_does_not_pair_with * getDoesNotPairWithByNumber(const int idx) const;
00139
00141         bool updateDoesNotPairWithByNumber(const int idx, const ms_crosslinking_does_not_pair_with* does_not_pair_with);
00142
00144         bool deleteDoesNotPairWithByNumber(const int idx);
00145
00147         std::string getDoesNotPairWithSchemaType() const;
00148
00149     private:
00150         typedef std::vector< ms_crosslinking_monolink * > monolink_vector;
00151         monolink_vector _monolinks;
00152
00153         typedef std::vector< ms_crosslinking_does_not_pair_with * > does_not_pair_with_vector;
00154         does_not_pair_with_vector _does_not_pair_withs;
00155
00156         std::string _modFileName;
00157         bool _modFileName_set;
00158
00159     }; // class ms_crosslinking_linker
00160  // end of config_group
00162
00163 } // namespace matrix_science
00164
00165 #endif // MS_CROSSLINKING_LINKER_HPP
00166
00167 /*------------------------------- End of File -------------------------------*/
00168
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_linkers.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_linkers.hpp                                          #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates linkers element in crosslinking.xml                           #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_linkers.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_LINKERS_HPP
00018 #define MS_CROSSLINKING_LINKERS_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_crosslinking_linker;
00030     class ms_xml_schema; // forward declaration
00031
00037
00038
00053     class MS_MASCOTRESFILE_API ms_crosslinking_linkers: public ms_xml_IValidatable
00054     {
00055         friend class msparser_internal::ms_crosslinking_xmlloader;
00056
00057     public:
00059         ms_crosslinking_linkers();
00060
00062         ms_crosslinking_linkers(const ms_crosslinking_linkers& src);
00063
00065         virtual ~ms_crosslinking_linkers();
00066
00068         void defaultValues();
00069
00071         void copyFrom(const ms_crosslinking_linkers* right);
00072
00073 #ifndef SWIG
00074
00075         ms_crosslinking_linkers& operator=(const ms_crosslinking_linkers& right);
00076 #endif
00077
00079         virtual std::string getSchemaType() const;
00080
00082         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00083
00085         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00086
00087
00089         int getNumberOfLinkers() const;
00090
00092         void clearLinkers();
00093
00095         void appendLinker(const ms_crosslinking_linker *item);
00096
00098         const ms_crosslinking_linker * getLinkerByNumber(const int idx) const;
00099
00101         bool updateLinkerByNumber(const int idx, const ms_crosslinking_linker* linker);
00102
00104         bool deleteLinkerByNumber(const int idx);
00105
00107         std::string getLinkerSchemaType() const;
00108
00109     private:
00110         typedef std::vector< ms_crosslinking_linker * > linker_vector;
00111         linker_vector _linkers;
00112
00113     }; // class ms_crosslinking_linkers
00114  // end of config_group
00116
00117 } // namespace matrix_science
00118
00119 #endif // MS_CROSSLINKING_LINKERS_HPP
00120
00121 /*------------------------------- End of File -------------------------------*/
00122
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_method.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_method.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Represents a method object in crosslinking.xml file                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_method.hpp $
00012  * @(#)$Revision: 20373858f9250b373e137e3d5de4992e9e7d19e6 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-01-08 14:42:05 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_METHOD_HPP
00018 #define MS_CROSSLINKING_METHOD_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_crosslinking_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030     class ms_crosslinking_linkers; // forward declaration
00031     class ms_crosslinking_accessions; // forward declaration
00032     class ms_crosslinking_scope; // forward declaration
00033     class ms_crosslinking_filters; // forward declaration
00034     class ms_crosslinking_settings; // forward declaration
00035     class ms_crosslinking_configfile; // forward declaration
00036     class ms_xml_schema; // forward declaration
00037
00043
00044
00049     class MS_MASCOTRESFILE_API ms_crosslinking_method: public ms_xml_IValidatable
00050     {
00051         friend class msparser_internal::ms_crosslinking_xmlloader;
00052         friend class ms_crosslinking_configfile;
00053
00054     public:
00056         ms_crosslinking_method();
00057
00059         ms_crosslinking_method(const ms_crosslinking_method& src);
00060
00062         virtual ~ms_crosslinking_method();
00063
00065         void defaultValues();
00066
00068         void copyFrom(const ms_crosslinking_method* right);
00069
00070 #ifndef SWIG
00071
00072         ms_crosslinking_method& operator=(const ms_crosslinking_method& right);
00073 #endif
00074
00076         virtual std::string getSchemaType() const;
00077
00079         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00080
00082         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00083
00084
00086         bool haveName() const;
00087
00089         std::string getName() const;
00090
00092         void setName(const char* value);
00093
00095         void dropName();
00096
00098         std::string getNameSchemaType() const;
00099
00100
00102         bool haveDescription() const;
00103
00105         std::string getDescription() const;
00106
00108         void setDescription(const char* value);
00109
00111         void dropDescription();
00112
00114         std::string getDescriptionSchemaType() const;
00115
00116
00118         bool haveStrategy() const;
00119
00121         std::string getStrategy() const;
00122
00124         void setStrategy(const char* value);
00125
00127         void dropStrategy();
00128
00130         std::string getStrategySchemaType() const;
00131
00132
00134         bool haveLinkers() const;
00135
00137         const ms_crosslinking_linkers* getLinkers() const;
00138
00140         void setLinkers(const ms_crosslinking_linkers* linkers);
00141
00143         void dropLinkers();
00144
00146         std::string getLinkersSchemaType() const;
00147
00148
00150         bool haveAccessions() const;
00151
00153         const ms_crosslinking_accessions* getAccessions() const;
00154
00156         void setAccessions(const ms_crosslinking_accessions* accessions);
00157
00159         void dropAccessions();
00160
00162         std::string getAccessionsSchemaType() const;
00163
00164
00166         bool haveScope() const;
00167
00169         const ms_crosslinking_scope* getScope() const;
00170
00172         void setScope(const ms_crosslinking_scope* scope);
00173
00175         void dropScope();
00176
00178         std::string getScopeSchemaType() const;
00179
00180
00182         bool haveFilters() const;
00183
00185         const ms_crosslinking_filters* getFilters() const;
00186
00188         void setFilters(const ms_crosslinking_filters* filters);
00189
00191         void dropFilters();
00192
00194         std::string getFiltersSchemaType() const;
00195
00196
00198         bool haveSettings() const;
00199
00201         const ms_crosslinking_settings* getSettings() const;
00202
00204         void setSettings(const ms_crosslinking_settings* settings);
00205
00207         void dropSettings();
00208
00210         std::string getSettingsSchemaType() const;
00211
00212
00213     private:
00214         std::string _name;
00215         bool _name_set;
00216
00217         std::string _strategy;
00218         bool _strategy_set;
00219
00220         std::string _description;
00221         bool _description_set;
00222
00223         ms_crosslinking_linkers *_pLinkers;
00224         ms_crosslinking_accessions *_pAccessions;
00225         ms_crosslinking_scope *_pScope;
00226         ms_crosslinking_filters *_pFilters;
00227         ms_crosslinking_settings *_pSettings;
00228
00229     }; // class ms_crosslinking_method
00230  // end of config_group
00232
00233 } // namespace matrix_science
00234
00235 #endif // MS_CROSSLINKING_METHOD_HPP
00236
00237 /*------------------------------- End of File -------------------------------*/
00238
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_monolink.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_monolink.hpp                                         #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates monolink element in crosslinking.xml                          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_monolink.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_MONOLINK_HPP
00018 #define MS_CROSSLINKING_MONOLINK_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030
00036
00037     class MS_MASCOTRESFILE_API ms_crosslinking_monolink: public ms_xml_IValidatable
00038     {
00039         friend class msparser_internal::ms_crosslinking_xmlloader;
00040
00041     public:
00043         ms_crosslinking_monolink();
00044
00046         ms_crosslinking_monolink(const ms_crosslinking_monolink& src);
00047
00049         virtual ~ms_crosslinking_monolink();
00050
00052         void defaultValues();
00053
00055         void copyFrom(const ms_crosslinking_monolink* right);
00056
00057 #ifndef SWIG
00058
00059         ms_crosslinking_monolink& operator=(const ms_crosslinking_monolink& right);
00060 #endif
00061
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00073         std::string getValue() const;
00074
00076         void setValue(const char* value);
00077
00079         std::string getValueSchemaType() const;
00080
00081
00082     private:
00083         std::string _value;
00084
00085     }; // class ms_crosslinking_monolink
00086  // end of config_group
00088
00089 } // namespace matrix_science
00090
00091 #endif // MS_CROSSLINKING_MONOLINK_HPP
00092
00093 /*------------------------------- End of File -------------------------------*/
00094
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_parameters.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_parameters.hpp                                       #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates parameterType-definition from crosslinking_1.xsd              #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_parameters.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_PARAMETERS_HPP
00018 #define MS_CROSSLINKING_PARAMETERS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_parameters;
00030     class ms_xml_schema; // forward declaration
00031
00037
00038     class MS_MASCOTRESFILE_API ms_crosslinking_parameter: public ms_xml_parameter
00039     {
00040         friend class msparser_internal::ms_crosslinking_xmlloader;
00041
00042     public:
00044         ms_crosslinking_parameter();
00045
00047         ms_crosslinking_parameter(const ms_crosslinking_parameter& src);
00048
00050         virtual ~ms_crosslinking_parameter();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_crosslinking_parameter* right);
00057
00058 #ifndef SWIG
00059
00060         ms_crosslinking_parameter& operator=(const ms_crosslinking_parameter& right);
00061 #endif
00062
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string getNameSchemaType() const;
00067
00069         virtual std::string getDescriptionSchemaType() const;
00070
00072         virtual std::string getValueSchemaType() const;
00073
00074     protected:
00075         virtual bool saveToXML_ParameterByNumber(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
00076
00077     }; // class ms_crosslinking_parameter
00078
00080
00083     class MS_MASCOTRESFILE_API ms_crosslinking_parameters: public ms_xml_parameters
00084     {
00085         friend class msparser_internal::ms_crosslinking_xmlloader;
00086
00087     public:
00089         ms_crosslinking_parameters();
00090
00092         ms_crosslinking_parameters(const ms_crosslinking_parameters& src);
00093
00095         virtual ~ms_crosslinking_parameters();
00096
00098         void defaultValues();
00099
00101         void copyFrom(const ms_crosslinking_parameters* right);
00102
00103 #ifndef SWIG
00104
00105         ms_crosslinking_parameters& operator=(const ms_crosslinking_parameters& right);
00106 #endif
00107
00108         virtual std::string getSchemaType() const;
00109
00111         virtual int getNumberOfParameters() const;
00112
00114         virtual void clearParameters();
00115
00117         void appendParameter(const ms_crosslinking_parameter *item);
00118
00120         const ms_crosslinking_parameter * getParameterByNumber(const int idx) const;
00121
00123         const ms_crosslinking_parameter * getParameterByName(const char *name) const;
00124
00126         bool updateParameterByNumber(const int idx, const ms_crosslinking_parameter *param);
00127
00129         bool updateParameterByName(const char *name, const ms_crosslinking_parameter *param);
00130
00132         virtual bool deleteParameterByNumber(const int idx);
00133
00135         virtual bool deleteParameterByName(const char *name);
00136
00138         virtual std::string getParameterSchemaType() const;
00139
00140     protected:
00141         virtual bool saveToXML_Parameters(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
00142
00143     private:
00144         typedef std::vector< ms_crosslinking_parameter* > entries_vector;
00145         entries_vector _entries;
00146
00147     }; // class ms_crosslinking_parameters
00148  // end of config_group
00150
00151 } // namespace matrix_science
00152
00153 #endif // MS_CROSSLINKING_PARAMETERS_HPP
00154
00155 /*------------------------------- End of File -------------------------------*/
00156
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_scope.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_scope.hpp                                            #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the scope element in crosslinking.xml                         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_scope.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_SCOPE_HPP
00018 #define MS_CROSSLINKING_SCOPE_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030     class ms_crosslinking_parameters;
00031
00037
00038
00051     class MS_MASCOTRESFILE_API ms_crosslinking_scope: public ms_crosslinking_parameters
00052     {
00053         friend class msparser_internal::ms_crosslinking_xmlloader;
00054
00055     public:
00057         ms_crosslinking_scope();
00058
00060         ms_crosslinking_scope(const ms_crosslinking_scope& src);
00061
00063         virtual ~ms_crosslinking_scope();
00064
00066         void defaultValues();
00067
00069         void copyFrom(const ms_crosslinking_scope* right);
00070
00071 #ifndef SWIG
00072
00073         ms_crosslinking_scope& operator=(const ms_crosslinking_scope& right);
00074 #endif
00075
00076         virtual std::string getSchemaType() const;
00077
00079         virtual std::string getParameterSchemaType() const;
00080
00081     }; // class ms_crosslinking_scope
00082  // end of config_group
00084
00085 } // namespace matrix_science
00086
00087 #endif // MS_CROSSLINKING_SCOPE_HPP
00088
00089 /*------------------------------- End of File -------------------------------*/
00090
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_crosslinking_settings.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_crosslinking_settings.hpp                                         #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the settings element in crosslinking.xml                      #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_crosslinking_settings.hpp $
00012  * @(#)$Revision: 9de60354aaae13272cadfa764dbabd92c93c724c | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 12:05:22 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_CROSSLINKING_SETTINGS_HPP
00018 #define MS_CROSSLINKING_SETTINGS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_crosslinking_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030     class ms_crosslinking_parameters;
00031
00037
00038
00075     class MS_MASCOTRESFILE_API ms_crosslinking_settings: public ms_crosslinking_parameters
00076     {
00077         friend class msparser_internal::ms_crosslinking_xmlloader;
00078
00079     public:
00081         ms_crosslinking_settings();
00082
00084         ms_crosslinking_settings(const ms_crosslinking_settings& src);
00085
00087         virtual ~ms_crosslinking_settings();
00088
00090         void defaultValues();
00091
00093         void copyFrom(const ms_crosslinking_settings* right);
00094
00095 #ifndef SWIG
00096
00097         ms_crosslinking_settings& operator=(const ms_crosslinking_settings& right);
00098 #endif
00099
00100         virtual std::string getSchemaType() const;
00101
00103         virtual std::string getParameterSchemaType() const;
00104
00105     }; // class ms_crosslinking_settings
00106  // end of config_group
00108
00109 } // namespace matrix_science
00110
00111 #endif // MS_CROSSLINKING_SETTINGS_HPP
00112
00113 /*------------------------------- End of File -------------------------------*/
00114
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_customproperty.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_customproperty.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Represents a custom property with unknown structure. It is useful for new  #
00006 # properties or for properties with variable structure that can be explored  #
00007 # at run-time                                                                #
00008 ##############################################################################
00009 # COPYRIGHT NOTICE                                                           #
00010 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00011 #                                                                            #
00012 ##############################################################################
00013 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_customproperty.hpp      $ #
00014 #     $Author: villek@matrixscience.com $ #
00015 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00016 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00017 # $NoKeywords::                                                            $ #
00018 ##############################################################################
00019 */
00020
00021 #ifndef MS_CUSTOMPROPERTY_HPP
00022 #define MS_CUSTOMPROPERTY_HPP
00023
00024
00025 #include <string>
00026 #include <vector>
00027
00028 #include "msparser_lim.hpp"
00029
00030 namespace matrix_science {
00031
00033
00090     class MS_MASCOTRESFILE_API ms_customproperty
00091     {
00092     public:
00094         ms_customproperty();
00095
00097         ~ms_customproperty();
00098
00100         void defaultValues();
00101
00103         void copyFrom(const ms_customproperty* src);
00104
00106         int getNumberOfProperties() const;
00107
00109         std::string getPropertyName(const int index) const;
00110
00112         void setPropertyName(const int index, const char* name);
00113
00115         int findProperty(const char* name, const int startFrom = 0) const;
00116
00118         int findPropertyBeginning(const char* nameBeginning, const int startFrom = 0) const;
00119
00121         std::string getPropValStringByName(const char* name) const;
00122
00124         std::string getPropValStringByNumber(const int index) const;
00125
00127         std::string getDelimiterByNumber(const int index) const;
00128
00130         void appendProperty
00131             ( const char* name
00132             , const char* value
00133             , const char* delimiter
00134             , const bool bFirstPlace = false
00135             );
00136
00138         void appendText
00139             ( const char* line
00140             , const bool bFirstPlace = false
00141             );
00142
00144         void setPropValStringByName
00145             ( const char* name
00146             , const char* value
00147             , const bool bFirstPlace = false
00148             );
00149
00151         void setPropValCharByName
00152             ( const char* name
00153             , const char value
00154             , const bool bFirstPlace = false
00155             );
00156
00158         void setPropValIntByName
00159             ( const char* name
00160             , const int value
00161             , const bool bFirstPlace = false
00162             );
00163
00165         void setPropValInt64ByName
00166             ( const char* name
00167             , const INT64 value
00168             , const bool bFirstPlace = false
00169             );
00170
00172         void setPropValBoolByName
00173             ( const char* name
00174             , const bool value
00175             , const bool bFirstPlace = false
00176             );
00177
00179         void setPropValFloatByName
00180             ( const char* name
00181             , const double value
00182             , const bool bFirstPlace = false
00183             );
00184
00186         void setPropValStringByNumber
00187             ( const int index
00188             , const char* value
00189             );
00190
00191
00193         std::string getDefaultDelimiter() const;
00194
00196         void setDefaultDelimiter(const char* delim);
00197
00199         void delProp(const char* name);
00200
00202         void delPropStart(const char* nameBeginning);
00203
00205         void delNonEmpty();
00206
00208         void delPropByNumber(const int index);
00209
00211         bool uncommentProp(const int index, const char * delimeter = 0);
00212
00214         std::string getPreceedingComments() const;
00215
00217         void setPreceedingComments(const std::string & comments);
00218
00219     private:
00220         std::vector< std::string > names_;
00221         std::vector< std::string > values_;
00222         std::vector< std::string > delimiters_;
00223         std::string                defaultDelimiter_;
00224         std::string                preceedingComments_;
00225     }; // class ms_customproperty
00226 } // namespace matrix_science
00227
00228 #endif // MS_CUSTOMPROPERTY_HPP
00229
00230 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_customquantitation.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_customquantitation.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Quantitation for Reporter and Multiplex protocols                          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: francoisr@matrixscience.com $ #
00012 #       $Date: 2018-11-22 11:02:10 +0000 $ #
00013 #   $Revision: b577d675f5daad88ac6730bda521ef7317380154 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_CUSTOMQUANTITATION_HPP
00019 #define MS_CUSTOMQUANTITATION_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024 #include <vector>
00025 #include <utility>
00026
00027 namespace msparser_internal {
00028     struct peptide_ratio_data_t;
00029 }
00030
00031 namespace matrix_science {
00032     class ms_peptide_quant_ratio;
00033     class ms_quantitation;
00034     class ms_peptidesummary;
00035     class ms_ms2quantitation;
00036     class ms_protein;
00037     class ms_peptide_quant_key;
00038     class ms_peptide_quant_key_vector;
00039     class ms_quant_average;
00040
00046
00047
00118     class MS_MASCOTRESFILE_API ms_customquantitation: public ms_quantitation
00119     {
00120         public:
00122             explicit ms_customquantitation(const ms_quant_method &qm);
00123
00125             explicit ms_customquantitation(const ms_peptidesummary &initFrom);
00126
00128             ms_customquantitation(const ms_peptidesummary &initFrom, const ms_quant_method &qm);
00129
00131             explicit ms_customquantitation(const ms_ms2quantitation &copyFrom);
00132
00134             virtual ~ms_customquantitation();
00135
00136             virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
00137             virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
00138
00139             virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const;
00140             virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName);
00141             virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName);
00142
00143             virtual void setProteinRatioType(const char *value);
00144
00145             virtual void setQuantOutliers(const ms_quant_outliers *);
00146
00147             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const;
00148
00149             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const;
00150
00152             void addPeptideRatio(const ms_peptide_quant_ratio &ratio);
00153
00155             void removePeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName);
00156
00158             void clearPeptideRatios();
00159
00161             void addPeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key);
00162
00164             void addPeptideQuantKeys(const std::string &accession, int dbIdx, const std::vector<ms_peptide_quant_key> &keys);
00165
00167             void addPeptideQuantKeys(const std::string &accession, int dbIdx, const ms_peptide_quant_key_vector &keys);
00168
00170             void removePeptideQuantKey(const std::string &accession, int dbIdx, const ms_peptide_quant_key &key);
00171
00173             void clearPeptideQuantKeys(const std::string &accession, int dbIdx);
00174
00176             double getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType) const;
00177
00179             double getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const ms_peptide_quant_key_vector &keys) const;
00180
00182             double getUnnormalisedAveragePeptideRatio(const std::string &ratioName, const std::string &averageType, const std::string &accession, int dbIdx) const;
00183
00184         protected:
00185             virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set<ms_peptide_quant_key> &keys, const std::set<ms_peptide_quant_key> &includeKeys, const std::set<ms_peptide_quant_key> &excludeKEys, std::vector<double> &values, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys) const;
00186
00187             void addPeptideQuantKeySibling(const ms_peptide_quant_key & originalKey, const ms_peptide_quant_key & newKey);
00188             void removePeptideQuantKeySibling(const ms_peptide_quant_key & newKey);
00189
00190         private:
00191             ms_customquantitation(const ms_customquantitation &copyFrom);
00192             ms_customquantitation& operator=(const ms_customquantitation &right);
00193
00194             typedef std::string ratio_name_t;
00195
00196             typedef std::map< ms_peptide_quant_key, msparser_internal::peptide_ratio_data_t* > peptide_quant_key_to_ratio_pointer_t;
00197             typedef std::multimap< msparser_internal::peptide_ratio_data_t*, ms_peptide_quant_key > ratio_pointer_to_peptide_quant_key_t;
00198
00199             typedef std::map< ratio_name_t, peptide_quant_key_to_ratio_pointer_t > ratio_name_to_peptide_quant_key_map_t;
00200             typedef std::map< ratio_name_t, ratio_pointer_to_peptide_quant_key_t > ratio_name_to_pointer_map_t;
00201
00202             bool lookupPeptideRatioNondestructive(const ms_peptide_quant_key &key, const std::string &ratioName, peptide_quant_key_to_ratio_pointer_t **qpmap, msparser_internal::peptide_ratio_data_t **rp);
00203             bool lookupPeptideRatioNondestructive(const ms_peptide_quant_key &key, const std::string &ratioName, const peptide_quant_key_to_ratio_pointer_t **qpmap = NULL, const msparser_internal::peptide_ratio_data_t **rp = NULL) const;
00204
00205             bool insertPeptideRatio(const ms_peptide_quant_ratio &ratio);
00206             msparser_internal::peptide_ratio_data_t* insertPeptideRatio(const std::string &ratioName, bool isMissing, const ms_peptide_quant_key &key, bool isInfinite, bool isExcluded, double value, double weight);
00207             void deleteAlias(const std::string &ratioName, const ms_peptide_quant_key &key);
00208             void deleteAliases(const std::string &ratioName, const ms_peptide_quant_key &key);
00209             void deallocatePeptideRatios();
00210
00211             double calculateAverageRatio(const std::vector<double> &values, const std::string &kind) const;
00212
00213             std::set< msparser_internal::peptide_ratio_data_t* > peptideRatioPool_;
00214             ratio_name_to_peptide_quant_key_map_t ratioNameToPeptideQuantKeyMap_;
00215             ratio_name_to_pointer_map_t ratioNameToPointerMap_;
00216
00217             enum SUPPORTED_PROTEIN_RATIO_TYPE {
00218                 PROTEIN_RATIO_TYPE_MEDIAN = 0,
00219                 PROTEIN_RATIO_TYPE_AVERAGE,
00220                 PROTEIN_RATIO_TYPE_WEIGHTED
00221             };
00222
00223             int proteinRatioType_;
00224
00225             bool initialiseProteinMappingFromResultsFile(const ms_peptidesummary &pepsum);
00226             bool initialisePeptideQuantKeys(const ms_peptidesummary &pepsum, const ms_protein *protein);
00227
00228     }; // end of quantitation_group
00230 }   // matrix_science namespace
00231
00232 #endif // MS_CUSTOMQUANTITATION_HPP
00233
00234 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_databaseoptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_databaseoptions.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "mascot.dat"-file that describes most important parameters    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_databaseoptions.hpp     $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_DATABASEOPTIONS_HPP
00020 #define MS_DATABASEOPTIONS_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00038     enum DATABASE_TYPE
00039     {
00040         AA=0,
00041         NA=1,
00042         SL=2,
00043         SLREF=3,
00044     };
00045
00047
00058     class MS_MASCOTRESFILE_API ms_databaseoptions
00059     {
00060         friend class ms_datfile;
00061         friend class ms_databases;
00062
00063     public:
00065
00070         enum {
00071             NUM_THREADS_AUTO_DETECT = -1
00072         };
00073
00074
00076         ms_databaseoptions();
00077
00079         ms_databaseoptions(const ms_databaseoptions& src);
00080
00082         ~ms_databaseoptions();
00083
00085         void defaultValues();
00086
00088         void copyFrom(const ms_databaseoptions* right);
00089
00090 #ifndef SWIG
00091
00092         ms_databaseoptions& operator=(const ms_databaseoptions& right);
00093 #endif
00094
00095         bool isActive() const;
00096
00098         void setActive(const bool value);
00099
00101         std::string getName() const;
00102
00104         void setName(const char* name);
00105
00107         std::string getPath() const;
00108
00110         void setPath(const char* path);
00111
00113         int getDBType() const;
00114
00116         void setDBType(const int type);
00117
00119         bool isMemoryMapFiles() const;
00120
00122         void setMemoryMapFiles(const bool flag);
00123
00125         int getNumberOfThreads() const;
00126
00128         void setNumberOfThreads(const int number);
00129
00131         bool isLockMemory() const;
00132
00134         void setLockMemory(const bool flag);
00135
00137         bool isLocalRefFile() const;
00138
00140         void setLocalRefFile(const bool flag);
00141
00143         int getAccessionParseRuleIndex() const;
00144
00146         void setAccessionParseRuleIndex(const int index);
00147
00149         int getDescriptionParseRuleIndex() const;
00150
00152         void setDescriptionParseRuleIndex(const int index);
00153
00155         int getAccessionRefParseRuleIndex() const;
00156
00158         void setAccessionRefParseRuleIndex(const int index);
00159
00161         int getTaxonomyParseRuleIndex() const;
00162
00164         void setTaxonomyParseRuleIndex(const int index);
00165
00167         bool isBlastIndexFiles() const;
00168
00170         void setBlastIndexFiles(const bool flag);
00171
00173         void setPreceedingComments(const std::string &str);
00174
00176         const std::string& getPreceedingComments() const;
00177
00178     private:
00179         std::string getStringValue() const;
00180
00181         bool        active_;
00182         std::string name_;
00183         std::string path_;
00184         int         type_;
00185         int         __numEntries_;  // no longer used
00186         int         __uniqueID_;    // no longer used
00187         bool        mmapFiles_;
00188         bool        __useBlastIndexFiles_;    // no longer used - was also blocks
00189         int         numThreads_;
00190         bool        lockMemory_;
00191         bool        hasRefFile_;
00192         int         accessionParseRule_;
00193         int         descriptionParseRule_;
00194         int         accessionRefParseRule_;
00195         int         taxonomyParseRule_;
00196         std::string comment_;
00197     }; // class ms_databaseoptions
00198
00200
00224     class MS_MASCOTRESFILE_API ms_databases: public ms_customproperty
00225     {
00226         friend class ms_datfile;
00227     public:
00229         ms_databases();
00230
00232         ms_databases(const ms_databases& src);
00233
00235         ~ms_databases();
00236
00238         void defaultValues();
00239
00241         void copyFrom(const ms_databases* right);
00242
00243 #ifndef SWIG
00244
00245         ms_databases& operator=(const ms_databases& right);
00246 #endif
00247
00248         bool isSectionAvailable() const;
00249
00251         void setSectionAvailable(const bool value);
00252
00254         int getNumberOfDatabases() const;
00255
00257         const ms_databaseoptions* getDatabase(const int index) const;
00258
00260         void clearDatabases();
00261
00263         void appendDatabase(const ms_databaseoptions* item);
00264
00266         int findDatabase(const char* dbName, const bool searchInactive = false) const;
00267
00269         bool updateDatabaseByNumber(const int num, const ms_databaseoptions db);
00270
00272         bool updateDatabaseByName(const char* name, const ms_databaseoptions db);
00273
00275         bool deleteDatabaseByNumber(const int num);
00276
00278         bool deleteDatabaseByName(const char* name);
00279
00280 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00281 #include "suppress_ms_customproperty.hpp"
00282 #endif
00283
00284     private:
00285         void appendDatabase(const ms_databaseoptions* item, const char *propVal);
00286         void setFollowingComments(const std::string &str);
00287         const std::string& getFollowingComments() const;
00288
00289         bool sectionAvailable_;
00290         std::vector< ms_databaseoptions* > dbases_;
00291         std::string followingComments_;
00292     }; // class ms_databases // end of config_group
00294 } // namespace matrix_science
00295
00296 #endif // MS_DATABASEOPTIONS_HPP
00297
00298 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_datfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_datfile.hpp                                                       #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "mascot.dat"-file that describes most important parameters    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_datfile.hpp             $ #
00012 #     $Author: francoisr@matrixscience.com $ #
00013 #       $Date: 2021-04-01 13:53:38 +0100 $ #
00014 #   $Revision: 3751734795f3869ea922a585f719718bbde3b800 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_DATFILE_HPP
00020 #define MS_DATFILE_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00028
00029     class ms_filesource;
00030
00036
00037
00046     class MS_MASCOTRESFILE_API ms_datfile : public ms_errors
00047     {
00048     public:
00049
00051
00054         enum WST
00055         {
00056             WST_APACHE=0,
00057             WST_IIS=1
00058         };
00059
00061
00066         enum SEQDB_INSTALL
00067         {
00068             // Anything in the lower 16 bits (1..16) should result in asking the user to confirm that they want to update
00069             SEQDB_INSTALL_SHOULD_QUERY_USER = 0x0000FFFF,
00070             SEQDB_INSTALL_CUSTOMISED        = 0x00000001,
00071             SEQDB_INSTALL_INACTIVE          = 0x00000002,
00072             SEQDB_INSTALL_INVALID_CONFIG    = 0x00000004,
00073             SEQDB_INSTALL_EXISTING_LARGER   = 0x00000010,
00074
00075             // Bit 32 for something really bad.
00076             SEQDB_INSTALL_INVALID_DBNAME    = 0x00000000,
00077
00078             // Further information that may be useful in bits 16 to 31
00079             SEQDB_INSTALL_MUST_UPDATE_CFG   = 0x000F000F,
00080             SEQDB_INSTALL_MISSING_CONFIG    = 0x00010000,
00081             SEQDB_INSTALL_OLD_RULES         = 0x00020000,
00082             SEQDB_INSTALL_WRONG_WILDCARD    = 0x00040000,
00083
00084             // Additional information, but no need to update
00085             SEQDB_INSTALL_CURRENT_RULES     = 0x01000000
00086         };
00087
00089
00092         enum INST_FLAGS
00093         {
00094             IFLG_UPDATETAXONOMY          = 0x00000001,
00095             IFLG_UPDATEPARSERULES        = 0x00000002,
00096             IFLG_UPDATESWISSPROT         = 0x00000004,
00097             IFLG_UPDATECLUSTER           = 0x00000008,
00098             IFLG_UPDATEESTTAX            = 0x00000010,
00099             IFLG_ADDMISSINGOPTIONS       = 0x00000020,
00100             IFLG_ADDREPORTAUTO           = 0x00000040,
00101             IFLG_UPDATEAPACHEFORKOPT     = 0x00000080,
00102             IFLG_ADDPERCOLATOROPT        = 0x00000100,
00103             IFLG_UPDATENCBIHTTPS         = 0x00000200,
00104             IFLG_UPDATEPRIDECONTAMINANTS = 0x00000400,
00105             IFLG_UPDATEDBMANAGERPERLPATH = 0x00000800,
00106             IFLG_UPDATEMSPEPSEARCHOPTS   = 0x00001000,
00107             IFLG_UPDATEEXECAFTERSEARCH   = 0x00002000,
00108             IFLG_UPDATEPERCOLATORFEATS   = 0x00004000,
00109             IFLG_UPDATEPROTFAMILYSWITCH  = 0x00008000,
00110
00111             IFLG_DEFAULTNEWINSTALL   = IFLG_UPDATECLUSTER       |
00112                                        IFLG_UPDATEAPACHEFORKOPT,
00113             IFLG_DEFAULTUPGRADE      = IFLG_UPDATETAXONOMY      |
00114                                        IFLG_UPDATEPARSERULES    |
00115                                        IFLG_UPDATEESTTAX        |
00116                                        IFLG_ADDMISSINGOPTIONS   |
00117                                        IFLG_ADDREPORTAUTO       |
00118                                        IFLG_UPDATEAPACHEFORKOPT |
00119                                        IFLG_ADDPERCOLATOROPT    |
00120                                        IFLG_UPDATEPERCOLATORFEATS  |
00121                                        IFLG_UPDATENCBIHTTPS     |
00122                                        IFLG_UPDATEDBMANAGERPERLPATH |
00123                                        IFLG_UPDATEMSPEPSEARCHOPTS  |
00124                                        IFLG_UPDATEEXECAFTERSEARCH |
00125                                        IFLG_UPDATEPROTFAMILYSWITCH
00126         };
00127
00129         ms_datfile();
00130
00132         ms_datfile(const ms_datfile& src);
00133
00135         ms_datfile(const char* filename, const int timeoutSec = 0,
00136                    const matrix_science::ms_connection_settings * cs = 0);
00137
00139         ~ms_datfile();
00140
00142         void defaultValues();
00143
00145         void copyFrom(const ms_datfile* right);
00146
00147 #ifndef SWIG
00148
00149         ms_datfile& operator=(const ms_datfile& right);
00150 #endif
00151
00152         std::string getFileName() const;
00153
00155         void setFileName(const char* name);
00156
00158         void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
00159
00161         matrix_science::ms_connection_settings getConnectionSettings() const;
00162
00164         void read_file();
00165
00166         void read_buffer(const char * buffer);
00167
00169         void save_file();
00170
00172         bool editedByDatabaseManager() const;
00173
00175         const ms_databases* getDatabases() const;
00176
00178         void setDatabases(const ms_databases* dbs);
00179
00181         const ms_libraryoptions* getLibraryOptions() const;
00182
00184         void setLibraryOptions(const ms_libraryoptions* spectralLibraryOptions);
00185
00187         const ms_parseoptions* getParseOptions() const;
00188
00190         void setParseOptions(const ms_parseoptions* rules);
00191
00193         const ms_wwwoptions* getWWWOptions() const;
00194
00196         void setWWWOptions(const ms_wwwoptions* www);
00197
00199         const ms_processoroptions* getProcessors() const;
00200
00202         void setProcessors(const ms_processoroptions* info);
00203
00205         const ms_taxonomyrules* getTaxonomyRules(const int idx) const;
00206
00208         void setTaxonomyRules(const int idx, const ms_taxonomyrules* rules);
00209
00211         int getMaxTaxonomyRules() const;
00212
00214         const ms_clusterparams* getClusterParams() const;
00215
00217         void setClusterParams(const ms_clusterparams* params);
00218
00220         const ms_unigeneoptions* getUniGeneOptions() const;
00221
00223         void setUniGeneOptions(const ms_unigeneoptions * uoptions);
00224
00226         const ms_mascotoptions* getMascotOptions() const;
00227
00229         void setMascotOptions(const ms_mascotoptions* opt);
00230
00232         const ms_cronoptions* getCronOptions() const;
00233
00235         void setCronOptions(const ms_cronoptions* options);
00236
00238         const ms_mascotfiles* getMascotFiles() const;
00239
00241         void setMascotFiles(const ms_mascotfiles* src);
00242
00244         void setFindFileTimeout(const int seconds);
00245
00247         int getFindFileTimeout() const;
00248
00250         unsigned int checkSeqDBInstallRequest(const std::string & dbName,
00251                                               const double newFastaSize) const;
00252
00254         bool updateForInstaller(ms_errs    & log,
00255                                 const char         * not_mascot_dat_path,
00256                                 const char         * mascot_dat_path,
00257                                 const char         * licenseFilePath,
00258                                 const char         * pathToMascot,
00259                                 const char         * mascotURL,
00260                                 const char         * sequenceDatabases,
00261                                 const bool           clusterEnable,
00262                                 const WST            wst,
00263                                 const char         * NTGuestName,
00264                                 const char         * NTAdminName,
00265                                 const unsigned int   flags);
00266
00268         std::string getHeaderComments() const;
00269
00271         void setHeaderComments(const std::string headerComments);
00272
00273     private:
00274         std::string         filename_;
00275
00276         int                 findFileTimeout_;
00277
00278         ms_databases        Databases;
00279
00280         ms_libraryoptions   libraryOptions;
00281
00282         ms_parseoptions     parseOptions;
00283
00284         ms_wwwoptions       wwwOptions;
00285
00286         ms_processoroptions Processors;
00287
00288         ms_taxonomyrules    **taxonomyRules;
00289
00290         ms_clusterparams    clusterParams;
00291
00292         ms_unigeneoptions   unigeneOptions;
00293
00294         ms_mascotoptions    Options;
00295
00296         ms_cronoptions      cronOptions;
00297
00298         ms_mascotfiles      MascotFiles;
00299
00300         std::string         headerComments_;
00301         std::string         footerComments_;
00302
00303         ms_connection_settings  cs_;
00304
00305     private:
00306         void defaultFileName();
00307
00308         void defaultTaxonomyRules();
00309         void copyTaxonomyRules(const ms_datfile* right);
00310
00311         void get_db_info(ms_filesource *f);
00312         void save_db_info(void *f);
00313
00314         void get_library_options(ms_filesource *f, const std::string & preceedingComments);
00315         void save_library_options(void *f);
00316
00317         void get_parse_rules(ms_filesource *f, const std::string & preceedingComments);
00318         void save_parse_rules(void *f);
00319
00320         void get_www(ms_filesource *f, const std::string & preceedingComments);
00321         void save_www(void *f);
00322
00323         void get_taxonomy_rules(ms_filesource *f, const char * sectionTitle, const std::string & preceedingComments);
00324         void save_taxonomy(void *f, const int index);
00325
00326         void get_cluster_params(ms_filesource *f, const std::string & preceedingComments);
00327         void save_cluster_params(void *f);
00328
00329         void get_unigene_options(ms_filesource *f, const std::string & preceedingComments);
00330         void save_unigene_options(void *f);
00331
00332         void get_processors(ms_filesource *f, const std::string & preceedingComments);
00333         void save_processors(void *f);
00334
00335         void get_options(ms_filesource *f, const std::string & preceedingComments);
00336         void save_options(void *f);
00337
00338         void get_cron_job_list(ms_filesource *f, const std::string & preceedingComments);
00339         void save_cron_job_list(void *f);
00340
00341         bool get_parse_rule_plus(const char *lineForError, char *pSrc, ms_parserule_plus *pRulePlus);
00342         void setIamParameter();
00343         void checkAndCompileParseRules();
00344         bool parseStringIntoCron(const char *szBuf, ms_cronjob & cron);
00345
00346         int parseIntoArray(const char * szBufCopy,
00347                            bool * array,
00348                            int minVal,
00349                            int maxVal,
00350                            int starMeans,
00351                            const char * wholeLine);
00352
00353         bool skipToEndOfSection(ms_filesource *f);
00354         bool getStringExcludingQuotes(const char *line, char *pDst);
00355         void readToEndOfLine(const char * pSrc, char * pDst, int maximumLength);
00356         void replaceHashes(matrix_science::ms_customproperty & section,
00357                            const std::string & localPath,
00358                            const std::string & hostname,
00359                            const std::string & url);
00360
00361         void read_filesource(ms_filesource & fsource);
00362         bool updateForInstallerDatabase(ms_errs               & log,
00363                                         const std::string     & dbName,
00364                                         const std::string     & defaultWildcard,
00365                                         ms_databases          & dbs,
00366                                         const ms_databases    * not_dbs,
00367                                         ms_parseoptions       & thisParse,
00368                                         const ms_parseoptions * notMascotDatParse);
00369         void updateForInstaller_ExecAfterSearch(ms_errs & log, matrix_science::ms_mascotoptions & options, const std::string & createPipCompleteString);
00370     }; // class ms_datfile // end of config_group
00372 } // namespace matrix_science
00373
00374 #endif // MS_DATFILE_HPP
00375
00376 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_data.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_data.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_data.hpp $
00012  * @(#)$Revision: 139db2ce351604ce12f000b2856b34e818ff0a1f | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-10-29 11:55:03 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_DATA_HPP
00018 #define MS_DISTILLER_DATA_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023 #include <vector>
00024
00025 namespace msparser_internal
00026 {
00027     class ms_XMLHelper;
00028     class ms_XMLElement;
00029 }
00030
00031 namespace matrix_science
00032 {
00033     class ms_distiller_data_quant;
00034     class ms_distiller_data_search;
00035
00036     //=========================================================================
00043
00044
00047     class MS_MASCOTRESFILE_API ms_distiller_data :
00048         public matrix_science::ms_errors
00049     {
00050         public:
00051
00053             static time_t getDistillerResfileTimestamp();
00054
00056             static std::vector<std::string> getRequiredSchemaFileNames();
00057
00059             static std::string getDistillerProjectStreamName();
00060
00061             ms_distiller_data();
00062             virtual ~ms_distiller_data();
00063             ms_distiller_data(const ms_distiller_data & copy);
00064
00066             virtual std::string getDistillerVersion() const;
00067
00069             void copyFrom(const ms_distiller_data* right);
00070
00071 #ifndef SWIG
00072             const ms_distiller_data & operator=(const ms_distiller_data & copy);
00073 #endif
00074
00076             virtual int getSearchCount() const;
00078             virtual const ms_distiller_data_search & getSearch(int index) const;
00080             virtual int getLoadedSearchIndex() const;
00081
00083             virtual int getQuantCount() const;
00085             virtual const ms_distiller_data_quant & getQuant(int index) const;
00086
00088             virtual const ms_distiller_data_quant * getQuantForSearch(const std::string & taskId) const;
00089
00091             virtual const ms_datfile & getDatfile() const;
00092
00094             virtual const ms_fragrulesfile & getFragRulesFile() const;
00095
00097             virtual const ms_quant_method & getQuantMethod() const;
00098
00100             virtual ms_mascotresults_params get_ms_mascotresults_params(const int searchIndex) const;
00101
00103             virtual bool loadXml(const char * xmlSchemaPath, const std::string & xmlText);
00105             virtual bool loadXmlFile(const char * xmlSchemaPath, const std::string & xmlFilename);
00107             virtual bool loadXmlStream(const char * xmlSchemaPath, matrix_science::ms_input_string_stream * xmlStream);
00108
00109             virtual bool saveXmlFile(const char * xmlSchemaPath, const std::string & xmlFilename);
00110             virtual int addQuant(const std::string & taskId);
00111
00112         private:
00113             bool extractXml(const char * xmlSchemaPath, msparser_internal::ms_XMLHelper & helper);
00114             bool saveXml(const char * xmlSchemaPath, msparser_internal::ms_XMLHelper & helper);
00115
00116             int quantStreamCounter_;
00117             std::vector<ms_distiller_data_search> searches_;
00118             std::vector<ms_distiller_data_quant> quantStreams_;
00119             ms_datfile datfile_;
00120             ms_fragrulesfile fragfile_;
00121             ms_quant_method quantMethod_;
00122
00123             msparser_internal::ms_XMLHelper * helper_;
00124             std::string distillerVersion_;
00125             std::string serverURL_;
00126             std::string serverVersion_;
00127     };
00128  // end of quantitation_group
00130     //=========================================================================
00131
00132 } // namespace matrix_science
00133
00134 #endif // MS_DISTILLER_DATA_HPP
00135
00136 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_data_quant.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_data_quant.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_data_quant.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_DATA_QUANT_HPP
00018 #define MS_DISTILLER_DATA_QUANT_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024
00025 namespace msparser_internal
00026 {
00027     class ms_XMLHelper;
00028     class ms_XMLElement;
00029 }
00030
00031 namespace matrix_science
00032 {
00033     //=========================================================================
00039
00040
00043     class MS_MASCOTRESFILE_API ms_distiller_data_quant
00044     {
00045         public:
00046
00047             // used internally
00048             ms_distiller_data_quant();
00049             ms_distiller_data_quant(const std::string & taskId, int streamNumber);
00050             bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00051
00053             std::string getTaskId() const;
00055             int getStreamNumber() const;
00056
00058             std::string getResultsStreamName() const;
00060             std::string getCacheStreamName() const;
00061
00062             int getResultsStreamNumber() const;
00063             int getCacheStreamNumber() const;
00064
00065         private:
00066             std::string taskId_;
00067             int streamNumber_;
00068     };
00069  // end of quantitation_group
00071     //=========================================================================
00072
00073 } // namespace matrix_science
00074
00075 #endif // MS_DISTILLER_DATA_QUANT_HPP
00076
00077 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_data_search.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_data_search.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_data_search.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_DATA_SEARCH_HPP
00018 #define MS_DISTILLER_DATA_SEARCH_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024
00025 namespace msparser_internal
00026 {
00027     class ms_XMLHelper;
00028     class ms_XMLElement;
00029 }
00030
00031 namespace matrix_science
00032 {
00033     class ms_quant_configfile;
00034
00035
00036     //=========================================================================
00043
00044
00051     class MS_MASCOTRESFILE_API ms_distiller_data_search
00052     {
00053         friend class ms_distiller_data;
00054
00055         public:
00056
00058
00061             enum eScoring
00062             {
00063                 eAuto = 0,
00064                 eMudpit = 1,
00065                 eStandard = 99999999,
00066             };
00067
00069
00072             enum eGrouping
00073             {
00074                 eGroupAuto = 0,
00075                 eGroupStandard = 1,
00076                 eGroupFamily = 2
00077             };
00078
00080
00083             enum eSpectralLibrary
00084             {
00085                 eUnknown = -1,
00086                 eFASTA = 0,
00087                 eLibrary = 1,
00088                 eIntegrated = 2,
00089             };
00090
00092             ms_distiller_data_search();
00093
00095             ms_distiller_data_search(
00096                 const std::string & taskId,
00097                 bool isLoaded,
00098                 const std::string & cacheFileName,
00099                 const std::string & quantMethodXml,
00100                 const std::string & mascotServerURL,
00101                 const std::string & mascotServerVersion,
00102                 unsigned int flags,
00103                 unsigned int flags2,
00104                 bool requireBoldRed,
00105                 bool showSameset,
00106                 double showSubset,
00107                 bool loadUnassigned,
00108                 double significanceThreshold,
00109                 eScoring scoring,
00110                 int reporttop,
00111                 bool errTolPeptide,
00112                 eGrouping proteinGrouping,
00113                 bool percolator,
00114                 double scoreExpectCutOff,
00115                 bool showSamesetFamily,
00116                 bool showSubsetFamily,
00117                 eSpectralLibrary libraryDisplayOption,
00118                 bool percolatorUseProteins,
00119                 bool percolatorUseRT,
00120                 int minPepLenInPepSummary
00121             );
00122
00123             // Copying constructor for c++ programs - don't document
00124             ms_distiller_data_search(const ms_distiller_data_search &src);
00125
00126 #ifndef SWIG
00127             // Assignment operator for c++ programs - don't document
00128             ms_distiller_data_search & operator=(const ms_distiller_data_search & right);
00129 #endif
00130
00131             std::string getTaskId() const;
00132
00134             bool getLoaded() const;
00135
00137             std::string getCacheFileName() const;
00138
00140             std::string getQuantMethodXml() const;
00141
00143             std::string getMascotServerURL() const;
00144
00146             bool serverVersionNewerOrSameAs(int major, int minor, int patch) const;
00147
00149             std::string getMascotSearchURL(const std::string & resultsFilePath) const;
00150
00152             eGrouping getProteinGrouping() const;
00153
00155             eScoring getScoring() const;
00156
00158             double getScoreExpectCutOff() const;
00159
00161             double getShowSubset() const;
00162
00164             bool getShowSubsetFamily() const;
00165
00167             bool getRequireBoldRed() const;
00168
00170             double getSignificanceThreshold() const; // = minProbability
00171
00173             int getReporttop() const;
00174
00176             bool getPercolator() const;
00177
00179             bool getPercolatorUseProteins() const;
00180
00182             bool getPercolatorUseRT() const;
00183
00185             bool getErrTolPeptide() const;
00186
00188             unsigned int getPeptideSummaryFlags() const;
00189
00191             unsigned getPeptideSummaryFlags2() const;
00192
00194             bool getLoadUnassigned() const;
00195
00197             bool getShowSamesets() const;
00198
00200             bool getShowSamesetsFamily() const;
00201
00203             int getMinPepLenInPepSummary() const;
00204
00206             eSpectralLibrary getSpectralLibraryDisplayOption() const;
00207
00208         private:
00209             // Used internally to read from the rover_data XML file
00210             bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00211             void copyFrom(const ms_distiller_data_search * src);
00212             void setMissingBlueOptionValues(const std::string & mascotServerURL,
00213                                             const std::string & mascotServerVersion,
00214                                             int minPepLenInPepSummary,
00215                                             bool percolatorUseProteins,
00216                                             bool percolatorUseRT);
00217
00218             std::string taskId_;
00219             bool isLoaded_;
00220             std::string cacheFileName_;
00221             std::string quantMethodXml_;
00222             std::string mascotServerURL_;
00223             std::string mascotServerVersion_;
00224             unsigned int flags_;
00225             unsigned int flags2_;
00226
00227             // From blueoptions (same order as schema)
00228             bool requireBoldRed_;
00229             bool showSameset_;
00230             double showSubset_;
00231             bool loadUnassigned_;
00232             double significanceThreshold_; // = minProbability
00233             eScoring scoring_;
00234             int reporttop_;
00235             bool errTolPeptide_;
00236             eGrouping proteinGrouping_;
00237             bool percolator_;
00238             double scoreExpectCutOff_;
00239             bool showSamesetFamily_;
00240             bool showSubsetFamily_;
00241             eSpectralLibrary libraryDisplayOption_;
00242             bool percolatorUseProteins_;
00243             bool percolatorUseRT_;
00244             int minPepLenInPepSummary_;
00245     };
00246  // end of quantitation_group
00248     //=========================================================================
00249
00250 } // namespace matrix_science
00251
00252 #endif // MS_DISTILLER_DATA_SEARCH_HPP
00253
00254 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_master_project.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_master_project.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_master_project.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_MASTER_PROJECT_HPP
00018 #define MS_DISTILLER_MASTER_PROJECT_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024
00025 namespace msparser_internal
00026 {
00027     class ms_XMLHelper;
00028     class ms_XMLElement;
00029 }
00030
00031 namespace matrix_science
00032 {
00033     //=========================================================================
00039      class ms_distiller_master_search;
00040      class ms_distiller_sub_project;
00041
00043
00046     class MS_MASCOTRESFILE_API ms_distiller_master_project :
00047         public matrix_science::ms_errors
00048     {
00049         public:
00050             ms_distiller_master_project();
00051             virtual ~ms_distiller_master_project() { }
00052
00053             ms_distiller_master_project(const ms_distiller_master_project & src);
00054 #ifndef SWIG
00055             ms_distiller_master_project& operator=(const ms_distiller_master_project & right);
00056 #endif
00057             void copyFrom(const ms_distiller_master_project * right);
00058
00060             static std::string getMasterProjectStreamName();
00061
00063             virtual int getNumSubprojects() const;
00065             virtual const ms_distiller_sub_project & getSubproject(int index) const;
00066
00068             virtual int getNumSearches() const;
00070             virtual const ms_distiller_master_search & getSearch(int index) const;
00071
00073             virtual bool loadXml(const char * xmlSchemaPath, std::string xmlText);
00075             virtual bool loadXmlFile(const char * xmlSchemaPath, std::string xmlFilename);
00077             virtual bool loadXmlStream(const char * xmlSchemaPath, matrix_science::ms_input_string_stream * xmlStream);
00078
00079         private:
00080             bool extractXml(msparser_internal::ms_XMLHelper & helper);
00081
00082             std::vector<ms_distiller_sub_project> subprojects;
00083             std::vector<ms_distiller_master_search> searches;
00084     };
00085  // end of quantitation_group
00087     //=========================================================================
00088
00089 } // namespace matrix_science
00090
00091 #endif // MS_DISTILLER_MASTER_PROJECT_HPP
00092
00093 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_master_search.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_master_search.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_master_search.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_MASTER_SEARCH_HPP
00018 #define MS_DISTILLER_MASTER_SEARCH_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024
00025 namespace msparser_internal
00026 {
00027     class ms_XMLHelper;
00028     class ms_XMLElement;
00029 }
00030
00031 namespace matrix_science
00032 {
00033     //=========================================================================
00039
00040
00043     class MS_MASCOTRESFILE_API ms_distiller_master_search
00044     {
00045         public:
00046             // used internally
00047             ms_distiller_master_search();
00048             virtual ~ms_distiller_master_search() { }
00049
00050             bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00051
00053             virtual int getId() const;
00055             virtual std::string getCacheFilename() const;
00056
00058             virtual int getNumSubsearches() const;
00060             virtual const ms_distiller_subsearch & getSubsearch(int index) const;
00061
00063             virtual std::string getCombinedPeptideSummaryCacheStreamName() const;
00064
00065         private:
00066             int id;
00067             std::string cacheFilename;
00068             std::vector<ms_distiller_subsearch> subsearches;
00069     };
00070  // end of quantitation_group
00072     //=========================================================================
00073
00074 } // namespace matrix_science
00075
00076 #endif // MS_DISTILLER_MASTER_SEARCH_HPP
00077
00078 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_search_status.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_search_status.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_search_status.hpp $
00012  * @(#)$Revision: 5f5a3230c85e277f402844ad1dcf49796e9a3e42 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-04-03 10:57:19 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_SEARCH_STATUS_HPP
00018 #define MS_DISTILLER_SEARCH_STATUS_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace msparser_internal
00025 {
00026     class ms_XMLHelper;
00027     class ms_XMLElement;
00028 }
00029
00030 namespace matrix_science
00031 {
00032     //=========================================================================
00038
00039
00042     class MS_MASCOTRESFILE_API ms_distiller_search_status
00043     {
00044         public:
00045             // used internally
00046             ms_distiller_search_status();
00047             bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00048
00050             int getId() const;
00052             std::string getTaskId() const;
00053 #ifndef SWIGCSHARP
00054
00055             std::string getTitle() const;
00056 #else
00057             std::wstring getTitle() const {
00058                 return getTitleWide();
00059             };
00060 #endif
00061
00062             std::string getServer() const;
00064             std::string getSubmitTime() const; // ISO 8601 date and time format, e.g. "2013-05-29T15:55:40"
00066             std::string getResultsFile() const;
00068             std::string getStatusMsg() const; // usually empty
00070             int getError() const; // zero if no error
00071
00073             std::string getResfileStreamName() const;
00075             std::string getPeptideSummaryCacheStreamName() const;
00076
00077         private:
00078             std::wstring getTitleWide() const;
00079
00080             int id_;
00081             std::string taskId_;
00082             std::string title_;
00083             std::string server_;
00084             std::string submitTime_; // ISO 8601 date and time format, e.g. "2013-05-29T15:55:40"
00085             std::string resultsFile_;
00086             std::string statusMsg_;
00087             int error_;
00088     };
00089  // end of quantitation_group
00091     //=========================================================================
00092
00093 } // namespace matrix_science
00094
00095 #endif // MS_DISTILLER_SEARCH_STATUS_HPP
00096
00097 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_search_status_list.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_search_status_list.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_search_status_list.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_SEARCH_STATUS_LIST_HPP
00018 #define MS_DISTILLER_SEARCH_STATUS_LIST_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace msparser_internal
00025 {
00026     class ms_XMLHelper;
00027     class ms_XMLElement;
00028 }
00029
00030 namespace matrix_science
00031 {
00032     class ms_input_stream;
00033
00034     //=========================================================================
00040      class ms_distiller_search_status;
00041
00043
00046     class MS_MASCOTRESFILE_API ms_distiller_search_status_list :
00047         public matrix_science::ms_errors
00048     {
00049         public:
00050             ms_distiller_search_status_list();
00051             ms_distiller_search_status_list(const ms_distiller_search_status_list & src);
00052 #ifndef SWIG
00053             ms_distiller_search_status_list& operator=(const ms_distiller_search_status_list & right);
00054 #endif
00055             void copyFrom(const ms_distiller_search_status_list * right);
00056
00058             static std::string getSearchStatusListStreamName();
00059
00061             int getNumSearches() const;
00063             const ms_distiller_search_status & getSearch(int index) const; // (index 1..n)
00064
00066             bool loadXml(const char * xmlSchemaPath, const std::string & xmlText);
00068             bool loadXmlFile(const char * xmlSchemaPath, const std::string & xmlFilename);
00070             bool loadXmlStream(const char * xmlSchemaPath, matrix_science::ms_input_string_stream * xmlStream);
00071
00072         private:
00073             bool extractXml(msparser_internal::ms_XMLHelper & helper);
00074
00075             std::vector<ms_distiller_search_status> searches_;
00076     };
00077  // end of quantitation_group
00079     //=========================================================================
00080
00081 } // namespace matrix_science
00082
00083 #endif // MS_DISTILLER_SEARCH_STATUS_LIST_HPP
00084
00085 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_sub_project.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_sub_project.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_distiller_sub_project.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_DISTILLER_SUB_PROJECT_HPP
00018 #define MS_DISTILLER_SUB_PROJECT_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024
00025 namespace msparser_internal
00026 {
00027     class ms_XMLHelper;
00028     class ms_XMLElement;
00029 }
00030
00031 namespace matrix_science
00032 {
00033     //=========================================================================
00039
00040
00043     class MS_MASCOTRESFILE_API ms_distiller_sub_project
00044     {
00045         public:
00047             static std::string getResultsListStreamName();
00048
00049             // used internally
00050             ms_distiller_sub_project();
00051             virtual ~ms_distiller_sub_project() { }
00052
00053             bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00054
00056             virtual int getId() const;
00058             virtual std::string getType() const;
00060             virtual std::string getName() const;
00062             virtual int getRawSampleNumber() const;
00064             virtual int getRawFormat() const;
00066             virtual std::string getRawAbsolutePath() const;
00068             virtual std::string getRawRelativePath() const;
00070             virtual std::string getProjectRelativePath() const;
00072             virtual bool getHavePeakList() const;
00073
00074         private:
00075             int id;
00076             std::string type; // "project" or "raw"
00077             std::string name;
00078             int rawSampleNumber;
00079             int rawFormat;
00080             std::string rawAbsolutePath;
00081             std::string rawRelativePath;
00082             std::string projectRelativePath;
00083             bool havePeakList;
00084     };
00085  // end of quantitation_group
00087     //=========================================================================
00088
00089 } // namespace matrix_science
00090
00091 #endif // MS_DISTILLER_SUB_PROJECT_HPP
00092
00093 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_distiller_subsearch.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_distiller_subsearch.hpp
00004 # 'msparser' toolkit
00005 ##############################################################################
00006 # COPYRIGHT NOTICE
00007 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00008 #
00009 ##############################################################################
00010  * @(#)$Source: parser/inc/ms_distiller_subsearch.hpp $
00011  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00012  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00013 ##############################################################################
00014  */
00015
00016 #ifndef MS_DISTILLER_SUBSEARCH_HPP
00017 #define MS_DISTILLER_SUBSEARCH_HPP
00018
00019
00020 // Includes from the standard template library
00021 #include <string>
00022
00023
00024 namespace msparser_internal
00025 {
00026     class ms_XMLHelper;
00027     class ms_XMLElement;
00028 }
00029
00030 namespace matrix_science
00031 {
00032     //=========================================================================
00038
00039
00042     class MS_MASCOTRESFILE_API ms_distiller_subsearch
00043     {
00044         public:
00045             // used internally
00046             ms_distiller_subsearch();
00047             virtual ~ms_distiller_subsearch() { }
00048
00049             bool extractXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00050
00052             virtual std::string getTaskId() const;
00054             virtual std::string getTitle() const;
00056             virtual std::string getResultsFile() const;
00057
00058         private:
00059             std::string taskId_;
00060             std::string title_;
00061             std::string resultsFile_;
00062     };
00063  // end of quantitation_group
00065     //=========================================================================
00066
00067 } // namespace matrix_science
00068
00069 #endif // ms_distiller_subsearch_HPP
00070
00071 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_enzyme.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_enzyme.hpp                                                        #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "enzymes"-file that describes available enzymes               #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_enzyme.hpp              $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_ENZYME_HPP
00020 #define MS_ENZYME_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00033
00034
00066     class MS_MASCOTRESFILE_API ms_enzyme : public ms_customproperty
00067     {
00068         friend class ms_enzymefile;
00069
00070     public:
00072
00075         enum cuttertype
00076         {
00077             UNDEFINED_CUTTER = 0x0000,
00078             NTERM_CUTTER     = 0x0001,
00079             CTERM_CUTTER     = 0x0002
00080         };
00081
00083         ms_enzyme();
00084
00086         ms_enzyme(const ms_enzyme& src);
00087
00089         ~ms_enzyme();
00090
00092         void defaultValues();
00093
00095         void copyFrom(const ms_enzyme* right);
00096
00097 #ifndef SWIG
00098
00099         ms_enzyme& operator=(const ms_enzyme& right);
00100 #endif
00101
00102         bool isValid() const;
00103
00105         bool verifyEnzyme(ms_errs* errObj) const;
00106
00108         std::string getTitle() const;
00109
00111         void setTitle(const char* str);
00112
00114         bool isSemiSpecific() const;
00115
00117         void setSemiSpecific(const bool value);
00118
00120         bool isIndependent() const;
00121
00123         void setIndependent(const bool bit);
00124
00126         int getNumberOfCutters() const;
00127
00129         void clearAllCutters();
00130
00132         void addCutter(const cuttertype type, const char* cleaveAtStr, const char* restrictStr);
00133
00135         ms_enzyme::cuttertype getCutterType(const int cutterNum) const;
00136
00138         std::string getCleave(const int cutterNum) const;
00139
00141         std::string getRestrict(const int cutterNum) const;
00142
00144         bool canCleave(const int  cutterNum,
00145                        const char leftResidue,
00146                        const char rightResidue) const;
00147
00148 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00149 #include "suppress_ms_customproperty.hpp"
00150 #endif
00151
00152     private:
00153         void setNTerm(std::string& cleaveStr, std::string& restrictStr);
00154         void setCTerm(std::string& cleaveStr, std::string& restrictStr);
00155         std::string::size_type prepareNextNTerm();
00156         std::string::size_type prepareNextCTerm();
00157         void setIndependentInternal(const bool bit);
00158         void setSemiSpecificInternal(const bool bit);
00159         void makeCustomPropIndexed();
00160
00161     private:
00162         std::string     title_;
00163         bool            semiSpecific_;
00164
00165         bool            independent_;
00166
00167         typedef std::vector< bool* > residue_flags_vector;
00168
00169         residue_flags_vector cleavageNTerm;
00170         residue_flags_vector cleavageCTerm;
00171         residue_flags_vector restrictNTerm;
00172         residue_flags_vector restrictCTerm;
00173     };// class ms_enzyme
00174
00175     class ms_filesource;
00176
00178
00193     class MS_MASCOTRESFILE_API ms_enzymefile : public ms_errors
00194     {
00195     public:
00197         ms_enzymefile();
00198
00200         ms_enzymefile(const ms_enzymefile& src);
00201
00203         ms_enzymefile(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
00204
00206         ~ms_enzymefile();
00207
00209         void defaultValues();
00210
00212         void copyFrom(const ms_enzymefile* right);
00213
00214 #ifndef SWIG
00215
00216         ms_enzymefile& operator=(const ms_enzymefile& right);
00217 #endif
00218
00219         void setFileName(const char* filename);
00220
00222         std::string getFileName() const;
00223
00225         void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
00226
00228         matrix_science::ms_connection_settings getConnectionSettings() const;
00229
00231         void read_file();
00232
00234         void read_buffer(const char* buffer);
00235
00237         void save_file();
00238
00240         int getNumberOfEnzymes() const;
00241
00243         void clearEnzymes();
00244
00246         void appendEnzyme(const ms_enzyme* item);
00247
00249         const ms_enzyme* getEnzymeByNumber(const int num) const;
00250
00252         const ms_enzyme* getEnzymeByName(const char* name) const;
00253
00255         bool isNoneFound() const;
00256
00258         bool updateEnzymeByNumber(const int num, const ms_enzyme enzyme);
00259
00261         bool updateEnzymeByName(const char* name, const ms_enzyme enzyme);
00262
00264         bool deleteEnzymeByNumber(const int num);
00265
00267         bool deleteEnzymeByName(const char* name);
00268
00269
00270     private:
00271
00272         void read_internal(ms_filesource *pFSource);
00273
00274         std::string filename_;
00275         std::vector<ms_enzyme*> entries_;
00276         std::vector< std::string > comments_;
00277         bool noneFound_;
00278         ms_connection_settings cs_;
00279
00280     }; // class ms_enzymefile // end of config_group
00282 } // matrix_science
00283
00284 #endif // MS_ENZYME_HPP
00285
00286 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_errors.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_errors.hpp                                                        #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a general-purpose error object that collects information      #
00006 # about several consecutive erros                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_errors.hpp              $ #
00013 #     $Author: francoisr@matrixscience.com $ #
00014 #       $Date: 2021-11-12 13:16:16 +0000 $ #
00015 #   $Revision: 5251a32edef6e83f068a07f3e337e11458b5b069 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_ERRORS_HPP
00021 #define MS_ERRORS_HPP
00022
00023
00024 #include <cstdarg>
00025 #include <vector>
00026 #include <string>
00027 #include <set>
00028
00029 namespace matrix_science {
00035
00036     class MS_MASCOTRESFILE_API ms_errs : public ms_log
00037     {
00038     public:
00039
00041         typedef msg_num_t err;
00042
00043         // errors for result files
00044         static const err ERR_NO_ERROR                          = 0x0000;
00045         static const err ERR_NOMEM                             = 0x0001;
00046         static const err ERR_NOSUCHFILE                        = 0x0002;
00047         static const err ERR_READINGFILE                       = 0x0003;
00048         static const err ERR_QUERYOUTOFRANGE                   = 0x0004;
00049         static const err ERR_MISSINGENTRY                      = 0x0005;
00050         static const err ERR_PEPSUMMPEPGET                     = 0x0006;
00051         static const err ERR_PEPTIDESTR                        = 0x0007;
00052         static const err ERR_ACCINPEPTIDESTR                   = 0x0008;
00053         static const err ERR_PROTSUMM                          = 0x0009;
00054         static const err ERR_PROTSUMMPEP                       = 0x000A;
00055         static const err ERR_ADDPEPTIDES                       = 0x000B;
00056         static const err ERR_MISSINGHIT                        = 0x000C;
00057         static const err ERR_MISSINGSECTION                    = 0x000D;
00058         static const err ERR_MISSINGSECTIONEND                 = 0x000E;
00059         static const err ERR_MALFORMED_ERR_TOL                 = 0x000F;
00060         static const err ERR_NO_ERR_TOL_PARENT                 = 0x0010;
00061         static const err ERR_NULL_ACC_PEP_SUM                  = 0x0011;
00062         static const err ERR_NULL_ACC_PROT_SUM                 = 0x0012;
00063         static const err ERR_DUPE_ACCESSION                    = 0x0013;
00064         static const err ERR_UNASSIGNED_PROG                   = 0x0014;
00065         static const err ERR_UNASSIGNED_RANGE                  = 0x0015;
00066         static const err ERR_UNASSIGNED_UNK                    = 0x0016;
00067         static const err ERR_NO_UNIGENE_FILE                   = 0x0017;
00068         static const err ERR_DUPLICATE_KEY                     = 0x0018;
00069         static const err ERR_OLDRESULTSFILE                    = 0x0019;
00070         static const err ERR_MALFORMED_TAG                     = 0x001A;
00071         static const err ERR_MALFORMED_DRANGE                  = 0x001B;
00072         static const err ERR_INVALID_NUMQUERIES                = 0x001C;
00073         static const err ERR_MALFORMED_TERMS                   = 0x001D;
00074         static const err ERR_INVALID_RESFILE                   = 0x001E;
00075         static const err ERR_INVALID_PROTDB                    = 0x001F;
00076         static const err ERR_UNIGENE_MULTIDB                   = 0x0020;
00077         static const err ERR_INVALID_CACHE_DIR                 = 0x0021;
00078         static const err ERR_FAIL_OPEN_DAT_FILE                = 0x0022;
00079         static const err ERR_MISSING_CDB_FILE                  = 0x0023;
00080         static const err ERR_FAIL_MK_CACHE_DIR                 = 0x0024;
00081         static const err ERR_FAIL_MK_CDB_FILE                  = 0x0025;
00082         static const err ERR_FAIL_CLOSE_FILE                   = 0x0026;
00083         static const err ERR_FAIL_CDB_INIT                     = 0x0027;
00084         static const err ERR_INVALID_CDB_FILE                  = 0x0028;
00085         static const err ERR_WRITE_CDB_FILE                    = 0x0029;
00086         static const err ERR_CDB_TOO_LARGE                     = 0x002A;
00087         static const err ERR_NEED_64_BIT                       = 0x002B;
00088         static const err ERR_CDB_64_BIT_REMAKE                 = 0x002C;
00089         static const err ERR_CDB_OLD_VER_RETRY                 = 0x002D;
00090         static const err ERR_CDB_OLD_VER_NO_RETRY              = 0x002E;
00091         static const err ERR_CDB_INCOMPLETE_RETRY              = 0x002F;
00092         static const err ERR_CDB_INCOMPLETE_NO_RETRY           = 0x0030;
00093         static const err ERR_CDB_BEING_CREATED                 = 0x0031;
00094         static const err ERR_CDB_FAIL_REMOVE                   = 0x0032;
00095         static const err ERR_CDB_FAIL_LOCK                     = 0x0033;
00096         static const err ERR_CDB_FAIL_UNLOCK                   = 0x0034;
00097         static const err ERR_CDB_SOURCE_CHANGE_RETRY           = 0x0035;
00098         static const err ERR_CDB_SOURCE_CHANGE_NO_RETRY        = 0x0036;
00099         static const err ERR_MISSING_PERCOLATOR_FILE           = 0x0037;
00100         static const err ERR_CANNOT_APPEND_RESFILE             = 0x0038;
00101         static const err ERR_CANNOT_APPEND_RESFILE_NO_FNAMES   = 0x0039;
00102         static const err ERR_RESULTS_NOT_CREATED               = 0x003A;
00103         // End of errors for ms_mascotresfile. Above errors are duplicated in ms_mascotresfile.hpp
00104         // After fixing bug 11415, should not be necessary to add more errors into the list above.
00105
00106         // OS errors
00107         static const err ERR_MSP_FAILED_TO_OPEN_FILE           = 0x0100;
00108         static const err ERR_MSP_FAILED_TO_CLOSE_FILE          = 0x0101;
00109         static const err ERR_MSP_FAIL_STAT                     = 0x0102;
00110         static const err ERR_MSP_GET_VOLUME_INFO               = 0x0103;
00111         static const err ERR_MSP_FILE_DOESNT_EXIST             = 0x0104;
00112         static const err ERR_MSP_FAIL_GET_PROCESS_AFFINITY     = 0x0105;
00113         static const err ERR_MSP_SYSMP_FAIL                    = 0x0106;
00114         static const err ERR_MSP_FAIL_GET_SYSINFO              = 0x0107;
00115         static const err ERR_MSP_FAILED_TO_WRITE_FILE          = 0x0108;
00116         static const err ERR_MSP_FAIL_UTIME                    = 0x0109;
00117
00118         // ms_processors errors
00119         static const err ERR_MSP_FAIL_HWLOC_INIT               = 0x0150;
00120         static const err ERR_MSP_FAIL_HWLOC_LOAD               = 0x0151;
00121         static const err ERR_MSP_BIND_INVALID_CPU              = 0x0152;
00122         static const err ERR_MSP_FAIL_PROCESSOR_BIND           = 0x0153;
00123         static const err ERR_MSP_FAIL_THREAD_BIND              = 0x0154;
00124         static const err ERR_MSP_INVALID_LOGICAL_CPU_NUM       = 0x0155;
00125         static const err ERR_MSP_INVALID_CPU_PACKAGE_NUM       = 0x0156;
00126         static const err ERR_MSP_INVALID_NUM_LICENSED          = 0x0157;
00127
00128         // fragmentation rules file related errors
00129         static const err ERR_MSP_FRAGMENTATION_RULES           = 0x0200;
00130
00131         // masses file related errors
00132         static const err ERR_MSP_IN_MASSES_FILE                = 0x0300;
00133         static const err ERR_MSP_INVALID_MASS_IN_MASSES_FILE   = 0x0301;
00134
00135         // mod_file related errors
00136         static const err ERR_MSP_DUPLICATE_MOD                 = 0x0400;
00137         static const err ERR_MSP_RESIDUE_AND_TERMINUS_MOD      = 0x0401;
00138         static const err ERR_MSP_TOO_MANY_MODS_IN_MOD_FILE     = 0x0402;
00139         static const err ERR_MSP_NO_COMMAS_IN_MOD_NAME         = 0x0403;
00140         static const err ERR_MSP_IN_MODS_FILE                  = 0x0404;
00141         static const err ERR_MSP_MISSING_DEFINITION_END        = 0x0405;
00142         static const err ERR_MSP_NO_SUCH_MOD                   = 0x0406;
00143
00144         // enzymes file related errors
00145         static const err ERR_MSP_ENZYME_FILE_FORMAT            = 0x0500;
00146         static const err ERR_MSP_MISSING_ENZYME_TITLE          = 0x0501;
00147         static const err ERR_MSP_ENZYME_DEFINITION_PROBLEM     = 0x0502;
00148         static const err ERR_MSP_ENZYME_TOO_MANY_RULES         = 0x0503;
00149
00150         // mascot.dat file related errors
00151         static const err ERR_MSP_MISSING_MASCOT_DAT            = 0x0601;
00152         static const err ERR_MSP_DB_USES_MISSING_RULE          = 0x0602;
00153         static const err ERR_MSP_COMPILE_PARSE_RULE            = 0x0603;
00154         static const err ERR_MSP_NEED_1_EXP_IN_PARSE_RULE      = 0x0604;
00155         static const err ERR_MSP_IN_MASCOT_DAT_DB_SECT         = 0x0605;
00156         static const err ERR_MSP_IN_OPTIONS_SECTION            = 0x0606;
00157         static const err ERR_MSP_IN_CLUSTER_SECTION            = 0x0607;
00158      // static const err ERR_MSP_TOO_MANY_CPUS_IN_SUB_CLUSTER  = 0x0608; //!< [W] The number of CPUs for the sub cluster is too high.
00159         static const err ERR_MSP_CRON_TOO_MANY_JOBS            = 0x0609;
00160         static const err ERR_MSP_INVALID_PARSE_RULE            = 0x060A;
00161         static const err ERR_MSP_INVALID_PARSE_RULE_NO         = 0x060B;
00162         static const err ERR_MSP_RULE_NO_ALREADY_DEFINED       = 0x060C;
00163         static const err ERR_MSP_MISSING_QUOTE_IN_PARSE_RULE   = 0x060D;
00164         static const err ERR_MSP_PARSE_LEN_EXCEED              = 0x060E;
00165         static const err ERR_MSP_IN_TAXONOMY_SECTION           = 0x060F;
00166         static const err ERR_MSP_INCOMPATIBLE_TAX_RULES        = 0x0610;
00167         static const err ERR_MSP_MAX_PREFIX_REMOVES            = 0x0611;
00168         static const err ERR_MSP_MAX_SUFFIX_REMOVES            = 0x0612;
00169         static const err ERR_MSP_MAX_TAX_NO_BREAKS             = 0x0613;
00170         static const err ERR_MSP_CRON_INVALID_CHAR             = 0x0614;
00171         static const err ERR_MSP_CRON_INVALID_NUMBER           = 0x0615;
00172         static const err ERR_MSP_CRON_INVALID_STAR             = 0x0616;
00173         static const err ERR_MSP_CRON_NO_NUM_BEFORE_COMMA      = 0x0617;
00174         static const err ERR_MSP_CRON_NO_NUM_BEFORE_MINUS      = 0x0618;
00175         static const err ERR_MSP_INVALID_PROCESSOR_LINE        = 0x0619;
00176         static const err ERR_MSP_PROCESSOR_NOT_IN_SET          = 0x061A;
00177         static const err ERR_MSP_SPECIFY_UNAVAILABLE_PROCESSOR = 0x061B;
00178         static const err ERR_MSP_TOO_MANY_PROCESSORS           = 0x061C;
00179         static const err ERR_MSP_TOO_MANY_TH_PROCESSORS        = 0x061D;
00180         static const err ERR_MSP_WWW_SECTION                   = 0x061E;
00181         static const err ERR_MSP_DUP_TAXONOMYRULE              = 0x061F;
00182         static const err ERR_MSP_WRONG_ICAT_FILTER             = 0x0620;
00183         static const err ERR_MSP_EXEC_AFTER_SEARCH_INVALID     = 0x0621;
00184         static const err ERR_MSP_EXEC_AFTER_SEARCH_DEPENDS     = 0x0622;
00185         static const err ERR_MSP_EXEC_AFTER_SEARCH_LOGGING     = 0x0623;
00186         static const err ERR_MSP_REPORTBUILDERCOLARR_INVALID   = 0x0624;
00187         static const err ERR_MSP_UNEXPECTED_LINE_OUT_OF_SECT   = 0x0625;
00188         static const err ERR_MSP_MISSING_SECTION               = 0x0626;
00189         static const err ERR_MSP_NO_REGEX_MATCH                = 0x0627;
00190         static const err ERR_MSP_REGEX_ERROR                   = 0x0628;
00191         static const err ERR_MSP_COLOURSCHEME_INVALID          = 0x0629;
00192
00193             // license file related errors
00194         static const err ERR_MSP_NO_LICENSE_FILE               = 0x0700;
00195         static const err ERR_MSP_LICENSE_DES_CHECKSUM          = 0x0701;
00196         static const err ERR_MSP_LICENSE_LINE_CHECKSUM         = 0x0702;
00197         static const err ERR_MSP_LICENSE_NOT_YET_AVAIL         = 0x0703;
00198         static const err ERR_MSP_LICENSE_EXPIRED               = 0x0704;
00199         static const err ERR_MSP_LICENSE_INTERNAL_CONFIG       = 0x0705;
00200         static const err ERR_MSP_LICENSE_LINE_INVALID          = 0x0706;
00201
00202         static const err ERR_MSP_XML_SYSTEM_FAILED             = 0x0801;
00203         static const err ERR_MSP_XML_NO_ROOT_ELEMENT           = 0x0802;
00204         static const err ERR_MSP_XML_TABLE_NOTFOUND            = 0x0803;
00205         static const err ERR_MSP_XML_FIELD_NOTFOUND            = 0x0804;
00206         static const err ERR_MSP_XML_INVALID_FIELD_FORMAT      = 0x0805;
00207         static const err ERR_MSP_XML_LOCAL_SCHEMA_NOT_STORED   = 0x0806;
00208         static const err ERR_MSP_XML_ELEMENT_NOT_FOUND         = 0x0807;
00209         static const err ERR_MSP_XML_MEMORY_ERROR              = 0x0808;
00210         static const err ERR_MSP_XML_FAILEDLOAD                = 0x0809;
00211         static const err ERR_MSP_XML_FAILEDSAVE                = 0x0810;
00212
00213         static const err ERR_MSP_HTTP_TRANSMISSION_FAILED      = 0x0901;
00214         static const err ERR_MSP_HTTP_INVALID_URL              = 0x0902;
00215         static const err ERR_MSP_MASCOT_NOT_RUNNING            = 0x0903;
00216         // Removed at version 2.5
00217      // static const err ERR_MSP_HTTP_WININET_FAILED           = 0x0904; //!< [F] Wininet failure.
00218
00219         // ms_aahelper errors
00220         static const err ERR_MSP_CONFLICT_BETWEEN_MODS         = 0x0A01;
00221         static const err ERR_MSP_WRONG_MOD_VECTOR              = 0x0A02;
00222         static const err ERR_MSP_MOD_MUST_BE_VAR               = 0x0A03;
00223         static const err ERR_MSP_MALFORMED_PEPTIDE             = 0x0A04;
00224         static const err ERR_MSP_DOUBLE_CHARGE_NOT_ALLOWED     = 0x0A05;
00225         static const err ERR_MSP_NO_ENZYME_SET                 = 0x0A06;
00226         static const err ERR_MSP_EMPTY_MOD                     = 0x0A07;
00227         static const err ERR_MSP_LOOPLINKING_NOT_IMPLEMENTED   = 0x0A08;
00228         static const err ERR_MSP_CROSSLINKING_MULTI_PEPTIDE    = 0x0A09;
00229         static const err ERR_MSP_CROSSLINKING_MULTI_LINKS      = 0x0A10;
00230         static const err ERR_MSP_CROSSLINKING_INVALID_LINK     = 0x0A11;
00231         static const err ERR_MSP_CROSSLINKING_VARMOD_CONFLICT  = 0x0A12;
00232         static const err ERR_MSP_MISSING_ET_MOD                = 0x0A13;
00233         static const err ERR_MSP_MISSING_SL_MOD                = 0x0A14;
00234         static const err ERR_MSP_MISSING_MONOLINK_MOD          = 0x0A15;
00235
00236         static const err ERR_MSP_TAXONOMY_NO_TITLE             = 0x0B01;
00237         static const err ERR_MSP_TAXONOMY_NO_COMMAS            = 0x0B02;
00238         static const err ERR_MSP_TAXONOMY_WRONG_LINE           = 0x0B03;
00239         static const err ERR_MSP_TAXONOMY_DEFINITION_END       = 0x0B04;
00240         static const err ERR_MSP_TAXONOMY_CONFLICT_PARENTS     = 0x0B05;
00241         static const err ERR_MSP_TAXONOMY_INVALID_NODE_FILE    = 0x0B06;
00242         static const err ERR_MSP_TAXONOMY_MISSING_NODE_FILE    = 0x0B07;
00243
00244             // Security related errors
00245         static const err ERR_MSP_SECURITY_INVALID_SESSION_ID   = 0x1000;
00246         static const err ERR_MSP_SECURITY_NOT_ADMIN_SESSION    = 0x1001;
00247         static const err ERR_MSP_SECURITY_DUPE_USER_ID         = 0x1002;
00248         static const err ERR_MSP_SECURITY_DUPE_USER_NAME       = 0x1003;
00249         static const err ERR_MSP_SECURITY_BAD_USER_NAME        = 0x1004;
00250         static const err ERR_MSP_SECURITY_USERNAME_NOT_FOUND   = 0x1005;
00251         static const err ERR_MSP_SECURITY_USERID_NOT_FOUND     = 0x1006;
00252         static const err ERR_MSP_SECURITY_DUPE_GROUP_ID        = 0x1007;
00253         static const err ERR_MSP_SECURITY_DUPE_GROUP_NAME      = 0x1008;
00254         static const err ERR_MSP_SECURITY_BAD_GROUP_NAME       = 0x1009;
00255         static const err ERR_MSP_SECURITY_GROUPNAME_NOT_FOUND  = 0x100A;
00256         static const err ERR_MSP_SECURITY_GROUPID_NOT_FOUND    = 0x100B;
00257         static const err ERR_MSP_SECURITY_FAIL_LOAD_SEC        = 0x100C;
00258         static const err ERR_MSP_SECURITY_FAIL_LOAD_USER       = 0x100D;
00259         static const err ERR_MSP_SECURITY_FAIL_LOAD_GROUP      = 0x100E;
00260         static const err ERR_MSP_SECURITY_DEL_SPECIAL_GROUP    = 0x100F;
00261         static const err ERR_MSP_SECURITY_DEL_SPECIAL_USER     = 0x1010;
00262         static const err ERR_MSP_SECURITY_DISABLE_ADMIN        = 0x1011;
00263         static const err ERR_MSP_SECURITY_DEL_ADMIN_RIGHTS     = 0x1012;
00264         static const err ERR_MSP_SECURITY_DEL_ADMIN_FROM_GP    = 0x1013;
00265         static const err ERR_MSP_SECURITY_DUPE_GROUP_NAME_U    = 0x1014;
00266         static const err ERR_MSP_SECURITY_DUPE_USER_NAME_U     = 0x1015;
00267         static const err ERR_MSP_SECURITY_OLD_PW_INVALID       = 0x1016;
00268         static const err ERR_MSP_SECURITY_NO_GUEST_PWD         = 0x1017;
00269         static const err ERR_MSP_SECURITY_PASSWORD_TOO_SHORT   = 0x1018;
00270         static const err ERR_MSP_SECURITY_FAIL_SAVE_SEC        = 0x1019;
00271         static const err ERR_MSP_SECURITY_NO_RIGHTS_UPD_USR    = 0x101A;
00272
00273         static const err ERR_MSP_SECURITY_INVALIDUSER          = 0x1101;
00274         static const err ERR_MSP_SECURITY_INVALIDPASSWORD      = 0x1102;
00275         static const err ERR_MSP_SECURITY_MISSINGSESSIONFILE   = 0x1103;
00276         static const err ERR_MSP_SECURITY_SAVESESSIONFILE      = 0x1104;
00277         static const err ERR_MSP_SECURITY_TIMEDOUT             = 0x1105;
00278         static const err ERR_MSP_SECURITY_DIFFERENTIPADDR      = 0x1106;
00279         static const err ERR_MSP_SECURITY_PASSWORDEXPIRED      = 0x1107;
00280         static const err ERR_MSP_SECURITY_NOTLOGGEDIN          = 0x1108;
00281         static const err ERR_MSP_SECURITY_INVALIDSESSION       = 0x1109;
00282         static const err ERR_MSP_SECURITY_NOSAVEPARAMS         = 0x110A;
00283         static const err ERR_MSP_SECURITY_SESSIONDESTROYED     = 0x110B;
00284         static const err ERR_MSP_SECURITY_NOCREATEGUEST        = 0x110C;
00285         static const err ERR_MSP_SECURITY_UPDATESESS           = 0x110D;
00286         static const err ERR_MSP_SECURITY_ACCOUNT_DISABLED     = 0x110E;
00287         static const err ERR_MSP_SECURITY_NOTNORMALUSER        = 0x110F;
00288         static const err ERR_MSP_SECURITY_SAMEPASSWORD         = 0x1110;
00289         static const err ERR_MSP_SECURITY_SPOOFATTEMPT1        = 0x1111;
00290         static const err ERR_MSP_SECURITY_SPOOFATTEMPT2        = 0x1112;
00291         static const err ERR_MSP_SECURITY_SPOOFATTEMPT3        = 0x1113;
00292         static const err ERR_MSP_SECURITY_SPOOFATTEMPT4        = 0x1114;
00293         static const err ERR_MSP_SECURITY_FAILGETINTEGRAURL    = 0x1115;
00294         static const err ERR_MSP_SECURITY_FAILGETINTEGRA       = 0x1116;
00295         static const err ERR_MSP_SECURITY_INTEGRACONNFORMAT    = 0x1117;
00296         static const err ERR_MSP_SECURITY_INTEGRAINVALIDPW     = 0x1118;
00297         static const err ERR_MSP_SECURITY_INTEGRAINVALIDCO     = 0x1119;
00298         static const err ERR_MSP_SECURITY_LOADSESSIONFILE      = 0x111A;
00299         static const err ERR_MSP_SECURITY_NOT_INTEGRA_USER     = 0x111B;
00300         static const err ERR_MSP_SECURITY_NOT_ENABLED          = 0x111C;
00301         static const err ERR_MSP_SECURITY_NO_INTEGRA_LOGIN     = 0x111D;
00302         static const err ERR_MSP_SESSION_UTIME_FAIL            = 0x111E;
00303         static const err ERR_MSP_SECURITY_CMDLINE_CGI          = 0x111F;
00304
00305
00306         // Security logging messages
00307         static const err ERR_MSP_SECURITY_ADDUSER              = 0x1200;
00308         static const err ERR_MSP_SECURITY_DELUSER              = 0x1201;
00309         static const err ERR_MSP_SECURITY_UPDATEUSER           = 0x1202;
00310         static const err ERR_MSP_SECURITY_UPDATEPW             = 0x1203;
00311         static const err ERR_MSP_SECURITY_ADDGROUP             = 0x1204;
00312         static const err ERR_MSP_SECURITY_DELETEGROUP          = 0x1205;
00313         static const err ERR_MSP_SECURITY_UPDATEGROUP          = 0x1206;
00314
00315         static const err ERR_MSP_SECURITY_GETALLGROUPIDS       = 0x1300;
00316         static const err ERR_MSP_SECURITY_GETGROUPOK           = 0x1301;
00317         static const err ERR_MSP_SECURITY_GETGROUPFAIL         = 0x1302;
00318         static const err ERR_MSP_SECURITY_GETUSEROK            = 0x1303;
00319         static const err ERR_MSP_SECURITY_GETUSERFAIL          = 0x1304;
00320         static const err ERR_MSP_SECURITY_GETUSERFROMIDOK      = 0x1305;
00321         static const err ERR_MSP_SECURITY_GETUSERFROMIDFAIL    = 0x1306;
00322         static const err ERR_MSP_SECURITY_GETALLUSERIDS        = 0x1307;
00323         static const err ERR_MSP_SECURITY_GETGROUPFROMIDOK     = 0x1308;
00324         static const err ERR_MSP_SECURITY_GETGROUPFROMIDFAIL   = 0x1309;
00325         static const err ERR_MSP_SECURITY_GETPERMTASKSOK       = 0x130A;
00326         static const err ERR_MSP_SECURITY_GETPERMTASKSFAIL     = 0x130B;
00327         static const err ERR_MSP_SECURITY_UPDATEALLSESSFILES   = 0x130C;
00328         static const err ERR_MSP_SECURITY_GETINTEGRAUSERS1     = 0x130D;
00329         static const err ERR_MSP_SECURITY_GETINTEGRAUSERS2     = 0x130E;
00330         static const err ERR_MSP_SECURITY_GETINTEGRAUSERS3     = 0x130F;
00331         static const err ERR_MSP_SECURITY_VALIDATEINTEGRAPW1   = 0x1310;
00332         static const err ERR_MSP_SECURITY_VALIDATEINTEGRAPW2   = 0x1311;
00333         static const err ERR_MSP_SECURITY_VALIDATEINTEGRAPW3   = 0x1312;
00334         static const err ERR_MSP_SECURITY_VALIDATEINTEGRACO1   = 0x1313;
00335         static const err ERR_MSP_SECURITY_VALIDATEINTEGRACO2   = 0x1314;
00336
00337         static const err ERR_MSP_SECURITY_MSSESSIONCTOR        = 0x1330;
00338         static const err ERR_MSP_SECURITY_MSSESSCOOKIE         = 0x1331;
00339         static const err ERR_MSP_SECURITY_LOADINGSESS          = 0x1332;
00340         static const err ERR_MSP_SECURITY_MSSESSLOGIN          = 0x1333;
00341         static const err ERR_MSP_SECURITY_MSSESSINTEGRA        = 0x1334;
00342         static const err ERR_MSP_SECURITY_MSSESSRESULTSPERM    = 0x1335;
00343
00344         static const err ERR_MSP_QUANT_FAILEDLOAD              = 0x1400;
00345         static const err ERR_MSP_QUANT_FAILEDSAVE              = 0x1401;
00346
00347         static const err ERR_MSP_QUANT_HELPER_FAILEDINIT       = 0x1410;
00348
00349         static const err ERR_MSP_QUANTITATION_FAILEDINIT       = 0x1420;
00350         static const err ERR_MSP_QUANTITATION_NOMETHOD         = 0x1421;
00351         static const err ERR_MSP_QUANTITATION_BADMETHOD        = 0x1422;
00352         static const err ERR_MSP_QUANTITATION_BADCOMPONENT     = 0x1423;
00353
00354         static const err ERR_MSP_MS2QUANTITATION_FAILEDINIT    = 0x1430;
00355         static const err ERR_MSP_MS2QUANTITATION_NORM_NO_SUM   = 0x1431;
00356         static const err ERR_MSP_MS2QUANTITATION_NORM_UNIMP    = 0x1432;
00357         static const err ERR_MSP_MS2QUANTITATION_PROTWEIGH     = 0x1433;
00358         static const err ERR_MSP_MS2QUANTITATION_PROTR_UNIM    = 0x1434;
00359         static const err ERR_MSP_MS2QUANTITATION_COMPONENTS    = 0x1435;
00360         static const err ERR_MSP_MS2QUANTITATION_QUERY_SECS    = 0x1436;
00361
00362         static const err ERR_MSP_CUSTQUANT_FAILEDINIT          = 0x1450;
00363         static const err ERR_MSP_CUSTQUANT_PROTR_UNIM          = 0x1451;
00364
00365         static const err ERR_MSP_MS1QUANTITATION_HITREF_NEW    = 0x1470;
00366         static const err ERR_MSP_MS1QUANTITATION_HITREF_DROP   = 0x1471;
00367         static const err ERR_MSP_MS1QUANTITATION_FAILEDINIT    = 0x1472;
00368
00369         static const err ERR_MSP_UMOD_FAILEDLOAD               = 0x1500;
00370         static const err ERR_MSP_UMOD_FAILEDSAVE               = 0x1501;
00371
00372         static const err ERR_MSP_XMLSCHEMA_FAILEDLOAD          = 0x1600;
00373         static const err ERR_MSP_XMLSCHEMA_FAILEDSAVE          = 0x1601;
00374
00375         static const err ERR_MSP_ZIP_ENDIAN                    = 0x1700;
00376         static const err ERR_MSP_ZIP_OUTOFMEMORY               = 0x1701;
00377         static const err ERR_MSP_ZIP_BUFTOOSMALL               = 0x1702;
00378         static const err ERR_MSP_ZIP_INVALIDDATA               = 0x1703;
00379         static const err ERR_MSP_ZIP_UNKNOWN                   = 0x1704;
00380         static const err ERR_MSP_ZIP_LENGTHDIFFERS             = 0x1705;
00381         static const err ERR_MSP_ZIP_UNCOMPRESSEDDATATOOLONG   = 0x1706;
00382         static const err ERR_MSP_ZIP_ZEROLENGTH                = 0x1707;
00383         static const err ERR_MSP_ZIP_VERSIONERROR              = 0x1708;
00384         static const err ERR_MSP_ZIP_NOTSTREAMING              = 0x1709;
00385         static const err ERR_MSP_ZIP_STREAMERROR               = 0x1710;
00386
00387         // Installer error messages
00388         static const err ERR_MSP_INST_INVALIDCPUINFO           = 0x1800;
00389         static const err ERR_MSP_INST_MISSINGDATABASE          = 0x1801;
00390         static const err ERR_MSP_INST_FAILADDPARSERULE         = 0x1802;
00391         static const err ERR_MSP_INST_CANTGETHOSTNAME          = 0x1803;
00392
00393         // HTTP communication
00394         static const err ERR_MSP_HTTP_WEBAUTHERROR             = 0x1901;
00395         static const err ERR_MSP_HTTP_VERSIONERROR             = 0x1902;
00396         static const err ERR_MSP_HTTP_MISSINGLOGINERROR        = 0x1903;
00397         static const err ERR_MSP_HTTP_MISSINGLOGININFO         = 0x1904;
00398         static const err ERR_MSP_HTTP_LOGINPARSERERROR         = 0x1905;
00399         static const err ERR_MSP_HTTP_LOGINPARSERERRORINT      = 0x1906;
00400         static const err ERR_MSP_HTTP_LOGINSERVERERROR         = 0x1907;
00401         static const err ERR_MSP_HTTP_LOGINSERVERERRORINT      = 0x1908;
00402         static const err ERR_MSP_HTTP_LOGINERROR               = 0x1909;
00403         static const err ERR_MSP_HTTP_LOGINERRORINT            = 0x190A;
00404         static const err ERR_MSP_HTTP_CHANGEPASSWORDDISABLED   = 0x190B;
00405         static const err ERR_MSP_HTTP_OPENOUTPUTFILEFAILED     = 0x190C;
00406         static const err ERR_MSP_HTTP_WRITEOUTPUTFILEFAILED    = 0x190D;
00407         static const err ERR_MSP_HTTP_RELOGINFAILED            = 0x190E;
00408
00409         static const err ERR_MSP_HTTP_SETPROXYFAILED           = 0x1A01;
00410         static const err ERR_MSP_HTTP_SETPROXYUSERNAMEFAILED   = 0x1A02;
00411         static const err ERR_MSP_HTTP_SETPROXYPASSWORDFAILED   = 0x1A03;
00412         static const err ERR_MSP_HTTP_SETHTTPUSERNAMEFAILED    = 0x1A04;
00413         static const err ERR_MSP_HTTP_SETHTTPPASSWORDFAILED    = 0x1A05;
00414         static const err ERR_MSP_HTTP_SETREDIRECTFAILED        = 0x1A06;
00415         static const err ERR_MSP_HTTP_NORESPONSE               = 0x1A08;
00416         static const err ERR_MSP_HTTP_QUERYSTATUSFAILED        = 0x1A0A;
00417         static const err ERR_MSP_HTTP_OPENSESSIONFAILED        = 0x1A0B;
00418         static const err ERR_MSP_HTTP_OPENCONNECTIONFAILED     = 0x1A0C;
00419         static const err ERR_MSP_HTTP_OPENREQUESTFAILED        = 0x1A0D;
00420         static const err ERR_MSP_HTTP_CLOSESESSIONFAILED       = 0x1A0B;
00421         static const err ERR_MSP_HTTP_CLOSECONNECTIONFAILED    = 0x1A0C;
00422         static const err ERR_MSP_HTTP_CLOSEREQUESTFAILED       = 0x1A0D;
00423         static const err ERR_MSP_HTTP_ABORTEDBYUSER            = 0x1A0E;
00424         static const err ERR_MSP_HTTP_MAXCONECTIONSFAILED      = 0x1A0F;
00425         static const err ERR_MSP_HTTP_MAXCONECTIONS10FAILED    = 0x1A10;
00426         static const err ERR_MSP_HTTP_READRESPONSEFAILED       = 0x1A11;
00427         static const err ERR_MSP_HTTP_SENDREQUESTFAILED        = 0x1A12;
00428         static const err ERR_MSP_HTTP_QUERYDATAFAILED          = 0x1A13;
00429         static const err ERR_MSP_HTTP_READDATAFAILED           = 0x1A14;
00430         static const err ERR_MSP_HTTP_GETPROXYFAILED           = 0x1A15;
00431         static const err ERR_MSP_HTTP_BADHTTPSTATUS            = 0x1A16;
00432         static const err ERR_MSP_HTTP_ERROR                    = 0x1A17;
00433         static const err ERR_MSP_HTTP_SESSIONALREADYOPEN       = 0x1A18;
00434         static const err ERR_MSP_HTTP_GETRESULTSFILENAME       = 0x1A1A;
00435         static const err ERR_MSP_HTTP_DOWNLOADFAILED           = 0x1A1B;
00436         static const err ERR_MSP_HTTP_HEADERFAILED             = 0x1A1C;
00437
00438         // Error messages related to opening or reading cache files
00439         static const err ERR_MSP_CACHE_OPENFAILED              = 0x1B01;
00440         static const err ERR_MSP_CACHE_READFAILED              = 0x1B02;
00441         static const err ERR_MSP_CACHE_INVALIDFORMAT           = 0x1B03;
00442         static const err ERR_MSP_CACHE_SIGNATUREINVALID        = 0x1B04;
00443         static const err ERR_MSP_CACHE_DATAOFFSETINVALID       = 0x1B05;
00444         static const err ERR_MSP_CACHE_FILESEEKFAILED          = 0x1B06;
00445         static const err ERR_MSP_CACHE_INVALIDVERSION          = 0x1B07;
00446         static const err ERR_MSP_CACHE_INVALIDSTREAMID         = 0x1B08;
00447         static const err ERR_MSP_CACHE_INVALIDSTREAMPOSITION   = 0x1B09;
00448         static const err ERR_MSP_CACHE_DUPLICATESTREAMID       = 0x1B0A;
00449         static const err ERR_MSP_CACHE_WRITEFAILED             = 0x1B0B;
00450         static const err ERR_MSP_CACHE_STREAMNOTFOUND          = 0x1B0C;
00451         static const err ERR_MSP_CACHE_WRITETRUNCATED          = 0x1B0D;
00452         static const err ERR_MSP_CACHE_MODIFYREADONLYMODE      = 0x1B0E;
00453         static const err ERR_MSP_CACHE_MODIFYCLOSED            = 0x1B0F;
00454         static const err ERR_MSP_CACHE_UNINITIALISEDSTREAM     = 0x1B10;
00455         static const err ERR_MSP_CACHE_SLREF_UPDATE            = 0x1B11;
00456         static const err ERR_MSP_CACHE_PROT_NUMPEPTIDES_RELOAD = 0x1B12;
00457
00458         static const err ERR_MSP_HTTP_XMLUPLOADFAILED          = 0x1C01;
00459
00460         static const err ERR_MSP_NIST_MSP_INVALID_LINE         = 0x1D01;
00461         static const err ERR_MSP_NIST_MSP_MISSING_PARAMETER    = 0x1D02;
00462         static const err ERR_MSP_NIST_MSP_NO_SPECTRA           = 0x1D03;
00463         static const err ERR_MSP_NIST_MSP_NO_CREATE_CDB        = 0x1D04;
00464         static const err ERR_MSP_NIST_MSP_INCONSISTENT_MODS    = 0x1D05;
00465         static const err ERR_MSP_NIST_FAILED_TO_LOAD_ENTRY     = 0x1D06;
00466         static const err ERR_MSP_NIST_SAVE_ZERO_SPECTRA        = 0x1D07;
00467         static const err ERR_MSP_NIST_NO_PEAKS_IN_SPECTRUM     = 0x1D08;
00468         static const err ERR_MSP_NIST_CANNOT_ANNOTATE_PEAK     = 0x1D09;
00469         static const err ERR_MSP_NIST_INDEX_OUT_OF_RANGE       = 0x1D0A;
00470         static const err ERR_MSP_NIST_NO_PRECURSOR_MZ_VALUE    = 0x1D0B;
00471         static const err ERR_MSP_NIST_MODIFICATION_NOT_FOUND   = 0x1D0C;
00472
00473         static const err ERR_MSP_XHUNTER_WRONG_FORMAT          = 0x1D20;
00474
00475         // More results file parsing errors
00476         static const err ERR_RESFILE_INVALID_DB_TYPE           = 0x1E01;
00477         static const err ERR_RESFILE_LINKED_SITES              = 0x1E02;
00478         static const err ERR_RESFILE_LOOPLINKED_SITES          = 0x1E03;
00479         static const err ERR_RESFILE_MISSING_QEXP              = 0x1E04;
00480
00481         // Model fitting and related errors
00482         static const err ERR_MSP_SL_SCORING_MODEL_FAIL         = 0x1F01;
00483         static const err ERR_MSP_SL_SCORING_MODEL_WARN         = 0x1F02;
00484         static const err ERR_MSP_TARGET_FDR_FAILED_FOR_ET      = 0x1F03;
00485         static const err ERR_MSP_CLOSEST_FDR_FOR_ET            = 0x1F04;
00486         static const err ERR_MSP_DIFFERENT_1ST_PASS_THR_ET     = 0x1F05;
00487         static const err ERR_MSP_TARGET_FDR_FAILED_FOR_FIRST_PASS = 0x1F06;
00488         static const err ERR_MSP_CLOSEST_FDR_FOR_FIRST_PASS    = 0x1F07;
00489
00490         static const err ERR_MSP_QUANT_CDB_MATCH_STREAM        = 0x2000;
00491         static const err ERR_MSP_QUANT_CDB_MISSING_KEY         = 0x2001;
00492         static const err ERR_MSP_QUANT_MISSING_COMPONENT       = 0x2002;
00493         static const err ERR_MSP_QUANT_FAIL_LOAD_PEPTIDE       = 0x2003;
00494         static const err ERR_MSP_QUANT_EMPTY_REF_ACCESSION     = 0x2004;
00495         static const err ERR_MSP_QUANT_ACCESSION_NOT_FOUND     = 0x2005;
00496         static const err ERR_MSP_QUANT_INVALID_REF_AMOUNT      = 0x2006;
00497         static const err ERR_MSP_QUANT_FAIL_LOAD_MATCH         = 0x2007;
00498
00499         static const err ERR_MSP_CROSSLINKING_FAILEDLOAD       = 0x2100;
00500         static const err ERR_MSP_CROSSLINKING_FAILEDSAVE       = 0x2101;
00501
00502         static const err ERR_MSP_LASTONE                       = 0xFFFF;
00503
00504
00505     public:
00507         ms_errs(msg_sev loglevel = sev_warn,
00508                 bool combineRepeats = true,
00509                 ms_loggingmonitor::Source_e api = ms_loggingmonitor::SRC_MSPARSER);
00510
00512         virtual ~ms_errs();
00513
00515         bool isValid() const;
00516
00517 #ifndef SWIG
00518
00519         void setError(const ms_errs::err errorNum, ...);
00520
00522         void vsetError(const ms_errs::err errorNum, va_list argptr, const char * srcFileName = "", const int srcFileLineNum = -1);
00523
00524
00526         void setError(const std::string sessionID,
00527                       const int userID,
00528                       const ms_errs::err errorNum, ...);
00529
00531         void setError(const int     errorNum,
00532                       const char*   strBuffer,
00533                       const msg_sev severity,
00534                       const int     srcLineNumber = -1,
00535                       const char *  srcFileName = "");
00536
00538         void setErrorPlusErrno(const ms_errs::err errorNum, ...);
00539
00541         bool anyIoErrors(FILE *f) const;
00542
00544         void appendError(const ms_errs::err errorNum, const int numRepeats, const std::string & errorString);
00545
00546 #ifdef _WIN32
00547
00548         static std::string systemErrorText(unsigned winErrNum);
00549 #endif
00550
00551 #endif
00552
00554         void setAPI(ms_loggingmonitor::Source_e api);
00555
00557         void appendErrors(const ms_errs& src);
00558
00560         int  getNumberOfErrors() const;
00561
00563         void clearAllErrors();
00564
00566         int  getErrorNumber(const int num = -1) const;
00567
00569         int  getLastError() const;
00570
00572         std::string getErrorString(const int num) const;
00573
00575         std::string getLastErrorString() const;
00576
00578         msg_sev getErrorSeverity(const int num = -1) const;
00579
00581         int getErrorRepeats(const int num = -1) const;
00582
00584         void setLoggingFile(const std::string filename, const msg_sev level);
00585
00587         std::string getLoggingFileName() const;
00588
00590         virtual msg_sev getLoggingLevel() const;
00591
00593         void setLoggingLevel(const msg_sev level);
00594
00596         bool getCombineRepeats() const;
00597
00599         void setCombineRepeats(const bool flag);
00600
00602         bool willMessageBeLogged(const ms_errs::err errorNum) const;
00603
00605         void forwardToParentInstance(ms_errs * parent);
00606
00608         static ms_loggingmonitor::Level_e convertToLogLevel(ms_errs::msg_sev severity);
00609
00611         static ms_errs::msg_sev convertFromLogLevel(ms_loggingmonitor::Level_e logLevel);
00612
00614         static std::string _lookUpError(const ms_errs::err errorNum, ms_errs::msg_sev & severity);
00615
00616     protected:
00617         virtual void _setError(const int /*ms_errs::err*/ errorNum,
00618                                const char* strBuffer,
00619                                const msg_sev severity,
00620                                const std::string & sessionID = "",
00621                                const int userID = -1,
00622                                const int srcLineNumber = -1,
00623                                const char * srcFileName = "");
00624
00625     private:
00626         std::vector<int> errorNumbers_;
00627         std::vector<std::string>errorStrings_; // Will include 'user' data
00628         std::vector<msg_sev> errorSeverities_;
00629         std::vector<int> errorRepeats_;        // So that we don't get multiple errors
00630         std::string logfileName_;
00631         msg_sev loglevel_;
00632         bool combineRepeats_;
00633         ms_loggingmonitor::Source_e api_;
00634
00635         ms_errs * pParentToForwardTo_;
00636         std::set<ms_errs *> objectsUsingMyData_;
00637     }; // class ms_errs
00638
00639
00640
00642     class MS_MASCOTRESFILE_API ms_errors
00643     {
00644     public:
00646         ms_errors();
00647
00649         ~ms_errors();
00650
00652         void copyFrom(const ms_errors* right);
00653
00655         void appendErrors(const ms_errors& src);
00656
00658         void clearAllErrors();
00659
00661         bool isValid() const;
00662
00664         std::string getLastErrorString() const;
00665
00667         int getLastError() const;
00668
00670         const ms_errs* getErrorHandler() const;
00671
00672 #if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
00673         // \internal Internal use only - returning a non-const pointer
00674         ms_errs* getErrorHandler();
00675 #endif
00676
00677     protected:
00678         void appendError(const ms_errs::err errorNum, const int numRepeats, const std::string & errorString);
00679         ms_errs   err_; // error object that does all the work
00680     }; // end of error_handling_group
00682 } // namespace matrix_science
00683
00684 #endif // MS_ERRORS_HPP
00685
00686 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_fileutilities.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_fileutilities.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Utilities class that encompasses all file-system-related functionality     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_fileutilities.hpp       $ #
00012 #     $Author: francoisr@matrixscience.com $ #
00013 #       $Date: 2022-02-17 16:09:54 +0000 $ #
00014 #   $Revision: 200ee577031818b3e4ee95b4941bfb798dc45748 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_FILEUTILITIES_HPP
00020 #define MS_FILEUTILITIES_HPP
00021
00022
00023 #include <string>
00024
00025 // For _finddata_t
00026 #ifdef _WIN32
00027 #include <io.h>
00028 #endif
00029
00030 // For off_t
00031 #ifdef __GNU__
00032 #include <unistd.h>
00033 #endif
00034
00035 namespace matrix_science {
00036     class ms_mascotoptions;
00042 #ifdef _WIN32
00043 #if defined(_MSC_VER) && (_MSC_VER < 1300)
00044 #define OFFSET64_C(c) c ## i64
00045 #else
00046 #define OFFSET64_C(c) c ## LL
00047 #endif
00048     typedef INT64 OFFSET64_T;
00049 #else // !_WIN32
00050 #define OFFSET64_C(c) c ## LL
00051     typedef off_t   OFFSET64_T;
00052 #endif // !_WIN32
00053
00055
00060     class MS_MASCOTRESFILE_API ms_fileutilities
00061     {
00062     public:
00064         ms_fileutilities();
00065
00067         static time_t getLastModificationTime(const char* filename, ms_errs* err = NULL);
00068
00070         static void setLastModificationTime(const char* filename, time_t modificationTime, ms_errs* err = NULL);
00071
00073         static UINT64 getFileSize(const char* filename, ms_errs* err = NULL);
00074
00076         static std::string findMascotDat(const char *szMascotDatFilename,
00077                                          ms_errs * err = NULL,
00078                                          const int timeoutSec = 0 );
00079
00081         static bool doesFileExist(const char* filename);
00082
00083         static bool isFileWritable(const char * filePath);
00084
00086         enum err_sar {
00087             SAR_SUCCESS,
00088             SAR_FAIL_CHMOD,
00089             SAR_FAIL_GET_NAMED_SECURITY_INFO,
00090             SAR_FAIL_SET_ENTRIES_IN_ACL,
00091             SAR_FAIL_SET_NAMED_SECURITY_INFO,
00092             SAR_FAIL_CHOWN
00093         };
00095
00098         err_sar setAccessRights(const char * filename,
00099                                 const bool bWrite,
00100                                 const bool bExecute,
00101                                 const bool isFile,
00102                                 const ms_mascotoptions & Options,
00103                                 const bool avoid_reapply = false);
00104         unsigned long getSARExtendedErrorCode() const;
00105
00107         static bool isDirectory(const char * path);
00108
00109 #ifndef SWIG
00110
00111         static int createDirectory(const std::string & directory, std::string & errorDirectory);
00112 #else // SWIG Multiple return values
00113         static int createDirectory(const std::string & directory, std::string & OUTPUT);
00114 #endif
00115
00116         static int deleteDirectory(const std::string & directory, const bool bDeleteSubdirectories = true);
00117
00119         bool findOpen(const std::string directory,
00120                       const std::string wildcard);
00121
00123         bool findNext(std::string & fileName);
00124
00126         void findClose();
00127
00129         static std::string stripLastFolder(const std::string pathname);
00130
00132         static std::string getMD5Sum(const std::string &str, const bool b32bitEncoding = true);
00133
00135         enum CMD_ARGUMENT_PARSE_RESULT {
00136             CMD_ARGUMENT_PARSE_OK = 0,
00137             CMD_ARGUMENT_PARSE_UNBALANCED = -1,
00138             CMD_ARGUMENT_PARSE_COLLISION = -2,
00139             CMD_ARGUMENT_PARSE_INVALIDCHAR = -3,
00140         };
00141
00143         static int parseCommandLineArgumentString(const std::string &command, std::vector<std::string> &components);
00144
00146         enum compareXMLFiles_flags {
00147             CMPXML_NO_FLAG              = 0x0000,
00148             CMPXML_IGN_DBL_IDENTICAL    = 0x0001,
00149             CMPXML_IGN_DBL_DIFF_100_PPM = 0x0002,
00150             CMPXML_IGN_DBL_DIFF_10_PPM  = 0x0004,
00151             CMPXML_IGN_DBL_DIFF_1_PPM   = 0x0008,
00152             CMPXML_IGN_DBL_MASK                  = (CMPXML_IGN_DBL_IDENTICAL | CMPXML_IGN_DBL_DIFF_100_PPM | CMPXML_IGN_DBL_DIFF_10_PPM | CMPXML_IGN_DBL_DIFF_1_PPM),
00153
00154             CMPXML_STRIP_TRAILING_ZEROS = 0x0010,
00155             CMPXML_IGN_COL_SIZE_EQ_ONE  = 0x0020,
00156             CMPXML_IGN_TODAY_DATE       = 0x0040,
00157             CMPXML_IGN_INF_999999       = 0x0080,
00158             CMPXML_IGN_FILE_URL         = 0x0100,
00159             CMPXML_IGN_RAWFILE_NAME     = 0x0200,
00160
00161             // CMPXML_IGN_IF_CWD_INCLUDED  = 0x0100,  //!< If there's a path name in an attribute and if that contains the current directory, then it's unlikey to match
00162         };
00163 #ifndef SWIG
00164
00165         static bool compareXmlFiles(const std::string & filePath1,
00166                                     const std::string & filePath2,
00167                                     const std::string & schemaPath,
00168                                     const int           flags,
00169                                     const std::vector<std::string> & ignoreElements,
00170                                     const std::vector<std::string> & ignoreAttributes,
00171                                           ms_errs     & errs,
00172                                           std::string & differences,
00173                                           std::string & lhsOnly,
00174                                           std::string & rhsOnly);
00175 #else // SWIG Multiple return values
00176         static bool compareXmlFiles(const std::string & filePath1,
00177                                     const std::string & filePath2,
00178                                     const std::string & schemaPath,
00179                                     const int           flags,
00180                                     const std::vector<std::string> & ignoreElements,
00181                                     const std::vector<std::string> & ignoreAttributes,
00182                                     ms_errs     & errs,
00183                                     std::string & OUTPUT,
00184                                     std::string & OUTPUT,
00185                                     std::string & OUTPUT);
00186 #endif
00187
00188     private:
00189         unsigned long errorCode_;
00190 #ifdef _WIN32
00191 #if defined(_MSC_VER) && (_MSC_VER < 1300)
00192         struct _finddata_t fileFindInfo_;
00193         int fileFindPtr_;
00194 #else
00195         struct __finddata64_t fileFindInfo_;
00196         intptr_t fileFindPtr_;
00197 #endif
00198 #else
00199         void * fileFindDir_;     // void * rather than DIR * so no need to include dirent.h
00200 #endif
00201         std::string fileFindWildcard_;
00202         std::string fileFindDirectory_;
00203
00204         static CMD_ARGUMENT_PARSE_RESULT splitCommandString(const std::string &command, const std::string::size_type j1, const std::string::size_type j2, std::vector<std::string> &argvstr);
00205
00206         static const std::string ws_delims_;
00207         static const char begin_quote_ = '"';
00208         static const char end_quote_ = '"';
00209         static const std::string invalid_chars_;
00210
00211     }; // class ms_fileutilities // end of tools_group
00213 } // namespace matrix_science
00214 #endif // MS_FILEUTILITIES_HPP
00215
00216 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_fitexy_result.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_fitexy_result.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_fitexy_result.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_FITEXY_RESULT_HPP
00018 #define MS_FITEXY_RESULT_HPP
00019
00020
00021 namespace matrix_science
00022 {
00023     //=========================================================================
00029     class ms_fitexy_result_body;
00030
00032
00038     class MS_MASCOTRESFILE_API ms_fitexy_result :
00039         public ms_handle
00040     {
00041         public:
00043             ms_fitexy_result();
00044
00046             ms_fitexy_result(const ms_fitexy_result_body & body);
00047
00048 #ifndef SWIG
00049             ms_fitexy_result_body * body();
00050             const ms_fitexy_result_body * body() const;
00051
00053             ms_fitexy_result(double sigx, double sigy, double a, double siga, double b, double sigb, double chi2, double q);
00054 #endif
00055
00057             double getSigmaX() const;
00059             double getSigmaY() const;
00060
00062             double getA() const;
00064             double getSigmaA() const;
00065
00067             double getB() const;
00069             double getSigmaB() const;
00070
00072             double getChi2() const;
00073
00075             double getQ() const;
00076     };
00077  // end of quantitation_group
00079     //=========================================================================
00080
00081 } // namespace matrix_science
00082
00083 #endif // MS_FITEXY_RESULT_HPP
00084
00085 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_fitexy_result_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_fitexy_result_body.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_FITEXY_RESULT_BODY_HPP
00018 #define MS_FITEXY_RESULT_BODY_HPP
00019
00020 namespace matrix_science
00021 {
00022     class ms_fitexy_result_body :
00023         public ms_body
00024     {
00025         public:
00026             double sigx_;
00027             double sigy_;
00028             double a_;
00029             double siga_;
00030             double b_;
00031             double sigb_;
00032             double chi2_;
00033             double q_;
00034
00035             ms_fitexy_result_body();
00036
00037             bool loadStream(matrix_science::ms_cache_stream & stream);
00038             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00039
00040             bool saveToStream(matrix_science::ms_cache_stream & stream) const;
00041             bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element) const;
00042     };
00043 }
00044
00045 #endif // MS_FITEXY_RESULT_BODY_HPP
00046
00047 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_fragment.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_fragment.hpp                                                      #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates a single fragment ion                                         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_fragment.hpp $
00012 #    $Author: villek@matrixscience.com $
00013 #      $Date: 2019-10-25 16:58:28 +0100 $
00014 #  $Revision: 729a9d2d2b60ca4ca4ccf3b95c449b13288dba7d | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 ##############################################################################
00016 */
00017
00018
00019 #if !defined(ms_fragment_INCLUDED_)
00020 #define ms_fragment_INCLUDED_
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <set>
00026 #include <vector>
00027 #include <map>
00028
00029
00030 namespace matrix_science {
00036
00037     class MS_MASCOTRESFILE_API ms_fragment
00038     {
00039     public:
00041
00067         enum LABEL_FORMAT {
00068             LABEL_FORMAT_TRADITIONAL = 0,
00069             LABEL_FORMAT_PEPTIDE_VIEW = 1
00070         };
00071
00073         ms_fragment();
00074
00076         ms_fragment(const ms_fragment &src);
00077
00078 #ifndef SWIG
00079
00080         ms_fragment& operator=(const ms_fragment& right);
00081 #endif
00082
00083         void copyFrom(const ms_fragment* src);
00084
00086         ms_fragment(const int    seriesID,
00087                     const double massValue,
00088                     const double nlValue,
00089                     const int    col,
00090                     const int    chargeState = 1,
00091                     const double matchedExptMass = 0,
00092                     const double matchedExptIntensity = 0);
00093
00095         ms_fragment(const ms_peptide::PSM psmComponent,
00096                     const int    seriesID,
00097                     const double massValue,
00098                     const double nlValue,
00099                     const int    col,
00100                     const int    chargeState,
00101                     const double matchedExptMass = 0,
00102                     const double matchedExptIntensity = 0);
00103
00105         ms_fragment(const char * seriesName,
00106                     const double massValue,
00107                     const double nlValue,
00108                     const int    col,
00109                     const int    chargeState = 1,
00110                     const double matchedExptMass = 0,
00111                     const double matchedExptIntensity = 0);
00112
00114         ms_fragment(const ms_peptide::PSM psmComponent,
00115                     const char * seriesName,
00116                     const double massValue,
00117                     const double nlValue,
00118                     const int    col,
00119                     const int    chargeState,
00120                     const double matchedExptMass = 0,
00121                     const double matchedExptIntensity = 0);
00122
00124         ms_fragment(const int    seriesID,
00125                     const double massValue,
00126                     const double nlValue,
00127                     const char * peptideStr,
00128                     const int    startPos,
00129                     const int    endPos,
00130                     const int    chargeState = 1,
00131                     const double matchedExptMass = 0,
00132                     const double matchedExptIntensity = 0);
00133
00135         ms_fragment(const ms_peptide::PSM psmComponent,
00136                     const int    seriesID,
00137                     const double massValue,
00138                     const double nlValue,
00139                     const char * peptideStr,
00140                     const int    startPos,
00141                     const int    endPos,
00142                     const int    chargeState,
00143                     const double matchedExptMass = 0,
00144                     const double matchedExptIntensity = 0);
00145
00147         ms_fragment(const char   residueName,
00148                     const double massValue,
00149                     const double nlValue,
00150                     const int    col = -1,
00151                     const int    chargeState = 1,
00152                     const double matchedExptMass = 0,
00153                     const double matchedExptIntensity = 0);
00154
00156         ms_fragment(const ms_peptide::PSM psmComponent,
00157                     const char   residueName,
00158                     const double massValue,
00159                     const double nlValue,
00160                     const int    col,
00161                     const int    chargeState,
00162                     const double matchedExptMass = 0,
00163                     const double matchedExptIntensity = 0);
00164
00166         ms_fragment(const double massValue,
00167                     const double nlValue,
00168                     const int    chargeState,
00169                     const double matchedExptMass = 0,
00170                     const double matchedExptIntensity = 0);
00171
00173         bool isFromAlpha() const;
00174
00176         bool isFromBeta() const;
00177
00179         bool isRegular() const;
00180
00182         bool isNTerminal() const;
00183
00185         bool isCTerminal() const;
00186
00188         bool isInternal() const;
00189
00191         bool isImmonium() const;
00192
00194         bool isPrecursorNL() const;
00195
00197         double getMass() const;
00198
00200         double getNeutralLoss() const;
00201
00203         std::string getLabel(const LABEL_FORMAT fmt = LABEL_FORMAT_TRADITIONAL) const;
00204
00206         std::string getPeptideSubstring() const;
00207
00209         std::string getSeriesName() const;
00210
00212         int getColumn() const;
00213
00215         int getStart() const;
00216
00218         int getEnd() const;
00219
00221         int getCharge() const;
00222
00224         void clearMatchedIon();
00225
00227         void setMatchedIon(const double mass, const double intensity);
00228
00230         double getMatchedIonMass() const;
00231
00233         double getMatchedIonIntensity() const;
00234
00236         int getAllMatchedIons(std::vector<double> & masses, std::vector<double> & intensities) const;
00237
00238     protected:
00239         enum ION_TYPE {ION_TYPE_UNKNOWN,
00240                        ION_TYPE_REGULAR,
00241                        ION_TYPE_INTERNAL,
00242                        ION_TYPE_IMMONIUM,
00243                        ION_TYPE_PRECURSOR_NL};
00244         enum ION_TERMINUS {ION_TERM_AMBIGUOUS,
00245                            ION_TERM_N,
00246                            ION_TERM_C};
00247         ms_peptide::PSM psmComponent_;
00248         double      mass_;
00249         double      nl_;
00250         std::string labelTraditional_;
00251         std::string labelPeptideView_;
00252         std::string peptideSubstring_;
00253         std::string series_;
00254         int         start_;
00255         int         end_;
00256         int         charge_;
00257         ION_TYPE    type_;
00258         ION_TERMINUS terminus_;
00259         bool        matchedValueSet_;
00260         double      matchedExptMass_;
00261         double      matchedExptIntensity_;
00262         std::vector<double> matchedExptMasses_;
00263         std::vector<double> matchedExptIntensities_;
00264
00265     private:
00266         void initRegularFragment(const ms_peptide::PSM psmComponent,
00267                                  const int seriesID,
00268                                  const double massValue,
00269                                  const double nlValue,
00270                                  const int col,
00271                                  const int chargeState,
00272                                  const double matchedExptMass,
00273                                  const double matchedExptIntensity);
00274
00275         void initRegularFragment(const ms_peptide::PSM psmComponent,
00276                                  const char* seriesName,
00277                                  const double massValue,
00278                                  const double nlValue,
00279                                  const int col,
00280                                  const int chargeState,
00281                                  const double matchedExptMass,
00282                                  const double matchedExptIntensity);
00283
00284         void initInternalFragment(const ms_peptide::PSM psmComponent,
00285                                   const int seriesID,
00286                                   const double massValue,
00287                                   const double nlValue,
00288                                   const char* peptideStr,
00289                                   const int startPos,
00290                                   const int endPos,
00291                                   const int chargeState,
00292                                   const double matchedExptMass,
00293                                   const double matchedExptIntensity);
00294
00295         void initImmoniumFragment(const ms_peptide::PSM psmComponent,
00296                                   const char residueName,
00297                                   const double massValue,
00298                                   const double nlValue,
00299                                   const int col,
00300                                   const int chargeState,
00301                                   const double matchedExptMass,
00302                                   const double matchedExptIntensity);
00303
00304     }; //class ms_fragment // end of mass_calculation_group
00306 } // matrix_science
00307
00308 #endif // !defined(ms_fragment_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_fragmentationrules.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_fragmentationrules.hpp                                            #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a fragmentation_rules file (mascot configuration files)       #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 # @(#)$Source: parser/inc/ms_fragmentationrules.hpp $
00013 # @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00014 # @(#)$Date: 2018-07-30 16:23:53 +0100 $
00015 # @(#)$Author: villek@matrixscience.com $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_FRAGMENTATIONRULES_HPP
00020 #define MS_FRAGMENTATIONRULES_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <vector>
00025 #include <string>
00026
00027
00028 namespace matrix_science {
00034     class ms_filesource;
00035
00037
00055     class MS_MASCOTRESFILE_API ms_fragmentationrules : public ms_customproperty
00056     {
00057         friend class ms_fragrulesfile;
00058     public:
00059
00061
00067         enum  FRAG_SERIES_TYPE
00068         {
00069             FRAG_IMMONIUM        = 4,
00070             FRAG_A_SERIES        = 5,
00071             FRAG_A_MINUS_NH3     = 6,
00072             FRAG_A_MINUS_H2O     = 7,
00073             FRAG_B_SERIES        = 8,
00074             FRAG_B_MINUS_NH3     = 9,
00075             FRAG_B_MINUS_H2O     = 10,
00076             FRAG_C_SERIES        = 11,
00077             FRAG_X_SERIES        = 12,
00078             FRAG_Y_SERIES        = 13,
00079             FRAG_Y_MINUS_NH3     = 14,
00080             FRAG_Y_MINUS_H2O     = 15,
00081             FRAG_Z_SERIES        = 16,
00082             FRAG_INTERNAL_YB     = 17,
00083             FRAG_INTERNAL_YA     = 18,
00084             FRAG_Z_PLUS_1        = 21,
00085             FRAG_D_SERIES        = 22,
00086             FRAG_V_SERIES        = 23,
00087             FRAG_W_SERIES        = 24,
00088             FRAG_Z_PLUS_2        = 25
00089         };
00090
00092         ms_fragmentationrules();
00093
00095         ms_fragmentationrules(const ms_fragmentationrules& src);
00096
00098         ~ms_fragmentationrules();
00099
00101         void defaultValues();
00102
00104         void copyFrom(const ms_fragmentationrules* right);
00105
00106 #ifndef SWIG
00107
00108         ms_fragmentationrules& operator=(const ms_fragmentationrules& right);
00109 #endif
00110
00111         std::string getTitle() const;
00112
00114         void setTitle(const char * title);
00115
00117         static int getFirstSeries();
00118
00120         static int getFirstSerie();
00121
00123         static int getLastSeries();
00124
00126         static int getLastSerie();
00127
00129         bool isSinglyCharged() const;
00130
00132         void setSinglyCharged(const bool value);
00133
00135         bool isCharged2Plus() const;
00136
00138         void setCharged2Plus(const bool value);
00139
00141         bool isCharged3Plus() const;
00142
00144         void setCharged3Plus(const bool value);
00145
00147         bool isSeriesUsed(const int series) const;
00148
00150         void clearSeries();
00151
00153         void setSeriesUsed(const int series, const bool val);
00154
00156         bool isValid() const;
00157
00159         bool verifyRule(ms_errs* err_, const bool tryToFix);
00160
00162         static std::string getSeriesDescription(const int series);
00163
00165         double getMinInternalMass() const;
00166
00168         void setMinInternalMass(const double mass);
00169
00171         double getMaxInternalMass() const;
00172
00174         void setMaxInternalMass(const double mass);
00175
00177         static std::string getSeriesName(const int series);
00178
00180         static bool isBackboneSeries(const int series);
00181
00183         static bool isNeutralLossSeries(const int series);
00184
00186         bool anyNLseriesUsed(const int series) const;
00187
00189         static int getTotalSeriesOutput();
00190
00191 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00192 #include "suppress_ms_customproperty.hpp"
00193 #endif
00194
00195     private:
00196         std::string title_;
00197         bool* which_series_;
00198         double minInternalMass_;
00199         double maxInternalMass_;
00200     }; // class ms_fragmentationrules
00201
00203
00208     class MS_MASCOTRESFILE_API ms_fragrulesfile: public ms_errors
00209     {
00210     public:
00212         ms_fragrulesfile();
00213
00215         ms_fragrulesfile(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
00216
00218         ms_fragrulesfile(const ms_fragrulesfile& src);
00219
00221         ~ms_fragrulesfile();
00222
00224         void defaultValues();
00225
00227         void copyFrom(const ms_fragrulesfile* right);
00228
00229 #ifndef SWIG
00230
00231         ms_fragrulesfile& operator=(const ms_fragrulesfile& right);
00232 #endif
00233
00234         void setFileName(const char* filename);
00235
00237         std::string getFileName() const;
00238
00240         void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
00241
00243         matrix_science::ms_connection_settings getConnectionSettings() const;
00244
00246         void read_file();
00247
00249         void read_buffer(const char * buffer);
00250
00252         void save_file();
00253
00255         int  getNumberOfInstruments() const;
00256
00258         void clearInstruments();
00259
00261         void appendInstrument(const ms_fragmentationrules* item);
00262
00264         std::string getInstrumentName(const int instrumentNum) const;
00265
00267         const ms_fragmentationrules* getInstrumentByName(const char * name) const;
00268
00270         const ms_fragmentationrules* getInstrumentByNumber(const int instrumentNum) const;
00271
00273         bool updateInstrumentByNumber(const int num, const ms_fragmentationrules item);
00274
00276         bool updateInstrumentByName(const char* name, const ms_fragmentationrules item);
00277
00279         bool deleteInstrumentByNumber(const int num);
00280
00282         bool deleteInstrumentByName(const char* name);
00283
00284     private:
00285         void read_filesource(ms_filesource & fsource);
00286
00287         std::string filename_;
00288         std::vector< ms_fragmentationrules* > rules_;
00289         std::vector< std::string > comments_;
00290         ms_connection_settings cs_;
00291     }; // ms_fragrulesfile // end of config_group
00293 }   // matrix_science namespace
00294
00295 #endif // MS_FRAGMENTATIONRULES_HPP
00296
00297 /*------------------------------- End of File -------------------------------*/
00298
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_fragmentvector.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_fragmentvector.hpp                                                #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates a list (vector) of single fragment ions                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_fragmentvector.hpp $
00012 #    $Author: villek@matrixscience.com $
00013 #      $Date: 2018-07-30 16:23:53 +0100 $
00014 #  $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 ##############################################################################
00016 */
00017
00018 #if !defined(ms_fragmentvector_INCLUDED_)
00019 #define ms_fragmentvector_INCLUDED_
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024 #include <set>
00025 #include <vector>
00026 #include <map>
00027
00028
00029 namespace matrix_science {
00030      class ms_mascotresfile;
00031
00037
00038
00046     class MS_MASCOTRESFILE_API ms_fragmentvector
00047     {
00048     public:
00049
00051
00058         enum MATCH_PEAKS
00059         {
00060
00061             MATCH_MOST_INTENSE_PEAK  = 0x0000,
00062             MATCH_CLOSEST_PEAK       = 0x0001
00063         };
00064
00065         enum TOLERANCE_UNIT
00066         {
00067             TOLERANCE_DALTON,
00068             TOLERANCE_MMU,
00069             TOLERANCE_PERCENT,
00070             TOLERANCE_PPM
00071         };
00072
00074         ms_fragmentvector();
00075
00077         ms_fragmentvector(const ms_fragmentvector& src);
00078
00080         virtual ~ms_fragmentvector();
00081
00083         void copyFrom(const ms_fragmentvector* right);
00084
00085 #ifndef SWIG
00086
00087         ms_fragmentvector& operator=(const ms_fragmentvector& right);
00088 #endif
00089
00090         int getNumberOfFragments() const;
00091
00093         void clearFragments();
00094
00096         void appendFragment(const ms_fragment * item);
00097
00099         const ms_fragment * getFragmentByNumber(const unsigned int numFrag) const;
00100
00101         typedef std::vector<ms_fragment> frag_vector;
00102
00103 #if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
00104
00105         frag_vector * getVector();
00106 #endif
00107
00108         const frag_vector * getVector() const;
00109
00111         bool addExperimentalData(const std::string & peakList,
00112                                  const int           numPeaks,
00113                                  const double        tolerance,
00114                                  const std::string & toleranceUnits,
00115                                  const bool          updateMatchList = true);
00116
00118         bool addExperimentalData(const ms_mascotresfile * resfile,
00119                                  const int query,
00120                                  const int flags = MATCH_MOST_INTENSE_PEAK,
00121                                  const int peaksUsedFromIons1 = -1,
00122                                  const int peaksUsedFromIons2 = -1,
00123                                  const int peaksUsedFromIons3 = -1);
00124
00125         typedef std::map<double, double> peaklist_t;  // Mass, intensity
00126
00128         bool addExperimentalData(const peaklist_t &  peakList,
00129                                  const double        tolerance,
00130                                  const std::string & toleranceUnits,
00131                                  const bool          updateMatchList = true);
00132
00134         static void getMassesWithinTolerance(const double & fragmentMass, const double & fragmentToleranceValue, const TOLERANCE_UNIT & fragmentToleranceUnit,
00135                                              double & minMass, double & maxMass);
00136
00137     private:
00138         frag_vector  entries_;
00139         peaklist_t experimentalData_;
00140         void matchFragments();
00141         double   matchingTol_;
00142         std::string matchingTolUnits_;
00143     }; // class ms_fragmentvector // end of mass_calculation_group
00145 } // matrix_science
00146
00147 #endif // !defined(ms_fragmentvector_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_client.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_client.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Represents a Mascot server, providing communication to that server         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_client.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_CLIENT_HPP
00018 #define MS_HTTP_CLIENT_HPP
00019
00020
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00030     class ms_http_client_session;
00031
00033
00046     class MS_MASCOTRESFILE_API ms_http_client :
00047         public ms_errors
00048     {
00049         public:
00051
00054             enum LoginResultCode
00055             {
00056                 L_SUCCESS,
00057                 L_SECURITYDISABLED,
00058                 L_UNKNOWNUSER,
00059                 L_INCORRECTPASSWORD,
00060                 L_PASSWORDEXPIRED,
00061                 L_WEBAUTHENTICATIONFAILED,
00062                 L_GUESTLOGINDISABLED,
00063                 L_UNSPECIFIEDERROR
00064             };
00065
00067
00070             enum ChangePasswordResultCode
00071             {
00072                 CP_SUCCESS,
00073                 CP_UNKNOWNUSER,
00074                 CP_INCORRECTPASSWORD,
00075                 CP_BADNEWPASSWORD,
00076                 CP_UNSPECIFIEDERROR
00077             };
00078
00079 #ifndef SWIG
00080             // C++ STL collection support
00081             ms_http_client();
00082 #endif
00083
00084             ms_http_client(const std::string & baseUrl, ms_connection_settings settings);
00086             virtual ~ms_http_client();
00087
00088             ms_http_client(const ms_http_client & src);
00089 #ifndef SWIG
00090             ms_http_client& operator=(const ms_http_client & right);
00091 #endif
00092             void copyFrom(const ms_http_client * right);
00093
00095             std::string baseUrl() const;
00097             ms_connection_settings connectionSettings() const;
00098
00100             void setBaseUrl(const std::string & baseUrl);
00102             void setConnectionSettings(const ms_connection_settings & settings);
00103 #ifndef SWIG
00104
00105             bool getIsDatabaseActive(const std::string & databaseName, bool & returnIsActive);
00106
00108             bool getVersion(int & major, int & minor, int & part3, int & part4);
00109
00111             bool getOsName(std::string & osname);
00112
00113 #else // SWIG Multiple return values
00114             bool getIsDatabaseActive(const std::string & databaseName, bool & OUTPUT);
00115             bool getVersion(int & OUTPUT, int & OUTPUT, int & OUTPUT, int & OUTPUT);
00116             bool getOsName(std::string & OUTPUT);
00117 #endif
00118
00119             LoginResultCode userLogin(
00120                     const std::string & username,
00121                     const std::string & password,
00122                     ms_http_client_session & returnSession);
00123
00125             ChangePasswordResultCode changePassword(
00126                     const std::string & userName,
00127                     const std::string & oldPassword,
00128                     const std::string & newPassword);
00129 #ifndef SWIG
00130
00131             bool getIsSecurityEnabled(bool & returnIsSecurityEnabled, std::string & returnUnsecuredSessionId);
00132
00134             bool getIsWebAuthenticationEnabled(bool & returnIsWebAuthenticationEnabled, std::string & returnWebAuthenticatedSessionId);
00135 #else // SWIG Multiple return values
00136             bool getIsSecurityEnabled(bool & OUTPUT, std::string & OUTPUT);
00137             bool getIsWebAuthenticationEnabled(bool & OUTPUT, std::string & OUTPUT);
00138 #endif
00139
00140         private:
00141             LoginResultCode secureGuestLogin(
00142                     ms_http_client_session & session);
00143             LoginResultCode secureUserLogin(
00144                     const std::string & username,
00145                     const std::string & password,
00146                     ms_http_client_session & returnSession);
00147             bool httpGetString(const std::string & action, std::string & returnString);
00148
00149             ms_http_helper connection_;
00150     };
00151  // end of http_client_group
00153 } // namespace matrix_science
00154
00155 #endif // MS_HTTP_CLIENT_HPP
00156
00157 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_client_mime.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_client_mime.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Builds a MIME string from the boundary separator and the element values    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_client_mime.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_CLIENT_MIME_HPP
00018 #define MS_HTTP_CLIENT_MIME_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace matrix_science
00025 {
00031     // for internal use
00032     class MS_MASCOTRESFILE_API ms_http_client_mime_item
00033     {
00034         public:
00035             ms_http_client_mime_item();
00036             ms_http_client_mime_item(const std::string & name, const std::string & value);
00037             ms_http_client_mime_item(const std::string & name, const std::string & value, const std::string & filename, const std::string & contentType);
00038
00039             std::string name() const;
00040             std::string value() const;
00041             bool hasFilename() const;
00042             std::string filename() const;
00043             std::string contentType() const;
00044
00045             void setName(const std::string & name);
00046             void setValue(const std::string & value);
00047             void setValueWithFilename(const std::string & value, const std::string & filename, const std::string & contentType);
00048
00049         private:
00050             std::string name_;
00051             std::string value_;
00052             bool        hasFilename_;
00053             std::string filename_;
00054             std::string contentType_;
00055     };
00056
00058
00066     class MS_MASCOTRESFILE_API ms_http_client_mime
00067     {
00068         public:
00069             enum ContentType {
00070                 CT_MIXED,
00071                 CT_FORMDATA
00072             };
00073
00074             enum Continuation {
00075                 CONTENT_CONTINUES,
00076                 CONTENT_TERMINATES
00077             };
00078
00080             static std::string formatHeader(
00081                     const std::string & boundary,
00082                     ContentType contentType);
00083
00085             virtual ~ms_http_client_mime();
00086
00088             void append(const std::string & name, const std::string & value);
00089
00091             void appendFile(const std::string & name, const std::string & filename, const std::string & contentType, const std::string & prefixData = "");
00092
00093
00095             int getCount() const;
00096             int count() const { return getCount(); }   // Deprecated. Released with 2.5.2
00097
00098             // index 1..count inclusive (not zero based!)
00100             std::string getName(int oneBasedIndex) const;
00101             std::string name(int oneBasedIndex) const { return getName(oneBasedIndex); }  // Deprecated. Released with 2.5.2
00102
00104             std::string getValue(int oneBasedIndex) const;
00105             std::string value(int oneBasedIndex) const { return getValue(oneBasedIndex); } // Deprecated. Released with 2.5.2
00106
00108             bool hasFilename(int oneBasedIndex) const;
00109
00111             std::string getFilename(int oneBasedIndex) const;
00112             std::string filename(int oneBasedIndex) const { return getFilename(oneBasedIndex); } // Deprecated. Released with 2.5.2
00113
00114             // index 1..count inclusive (not zero based!)
00116             void setValue(int oneBasedIndex, const std::string & value);
00117
00119             void setValueWithFilename(int oneBasedIndex, const std::string & value, const std::string & filename, const std::string & contentType);
00120
00121             // index 1..count inclusive (not zero based!)
00123             void erase(int oneBasedIndex);
00124
00126             std::string format(
00127                     const std::string & boundary,
00128                     matrix_science::ms_http_client_mime::Continuation continuation) const;
00129
00130         private:
00131             std::vector<ms_http_client_mime_item> items_;
00132     };
00133  // end of http_client_group
00135
00136 } // namespace matrix_science
00137
00138 #endif // MS_HTTP_CLIENT_MIME_HPP
00139
00140 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_client_search.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_client_search.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Represents a task on a Mascot server and can be used to sumbit and track   #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_client_search.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_CLIENT_SEARCH_HPP
00018 #define MS_HTTP_CLIENT_SEARCH_HPP
00019
00020
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00030     class ms_http_helper;
00031     class ms_http_client_session;
00032
00034
00042     class MS_MASCOTRESFILE_API ms_http_client_search :
00043         public ms_errors
00044     {
00045         public:
00046
00048
00051             enum SearchStatusCode
00052             {
00053                 SS_UNKNOWN,
00054                 SS_ASSIGNED,
00055                 SS_QUEUED,
00056                 SS_RUNNING,
00057                 SS_COMPLETE,
00058                 SS_ERROR,
00059                 SS_SEARCH_CONTROL_ERROR
00060             };
00061
00063
00066             enum UploadResponseCode
00067             {
00068                 UR_SUCCESS,
00069                 UR_ACCESS_DENIED,
00070                 UR_INVALID_TASKID,
00071                 UR_NO_RESULT_FILENAME,
00072                 UR_NO_RESULT_FILE,
00073                 UR_FILE_ALREADY_EXISTS,
00074                 UR_ERROR
00075             };
00076
00078
00081             enum DownloadOption
00082             {
00083                 DO_NORMAL = 0,
00084                 DO_WITH_IONS = 1
00085             };
00086
00088
00092             enum ReportTopSpecialValues
00093             {
00094                 RT_auto = 0,
00095                 RT_file = -1
00096             };
00097
00098 #ifndef SWIG
00099             // C++ STL collection support
00100             ms_http_client_search();
00101 #endif
00102
00103             ms_http_client_search(ms_http_client_session & session, const std::string & searchTaskId);
00104
00106             virtual ~ms_http_client_search();
00107
00108             ms_http_client_search(const ms_http_client_search & src);
00109 #ifndef SWIG
00110             ms_http_client_search& operator=(const ms_http_client_search & right);
00111 #endif
00112             void copyFrom(const ms_http_client_search * right);
00113
00115
00118             std::string sessionId() const { return getSessionID(); }
00119
00121             std::string getSessionID() const;
00122
00124             std::string getSearchTaskID() const;
00125
00127
00132             std::string searchTaskId() const { return getSearchTaskID(); }
00133
00135             bool getStatus(SearchStatusCode & returnCode, int & statusValue);
00136
00137 #ifndef SWIG
00138             // Undocumented for Perl compatibility. Unable to return an enum
00139             bool getStatus(int & returnCodeAsInt, int & statusValue);
00140
00142             bool getResultsFileName(std::string & returnFileName);
00143 #else // SWIG Multiple return values
00144             bool getStatus(int & OUTPUT, int & OUTPUT);
00145             bool getResultsFileName(std::string & OUTPUT);
00146 #endif
00147
00149
00155             bool getResultsFilename(std::string & returnFilename) { return getResultsFileName(returnFilename); }
00156
00158             bool downloadResultsFile(std::string filename, ms_http_helper_progress & progress, DownloadOption options = DO_WITH_IONS);
00159
00161             bool downloadDaemonResultsFile(std::string filename, ms_http_helper_progress & progress);
00162
00164             bool downloadPercolatorFile(std::string filename, ms_http_helper_progress & progress);
00165
00167             bool downloadXmlResultsFile(std::string filename, ms_http_helper_progress & progress, int reportTop = RT_auto);
00168 #ifndef SWIG
00169
00170             bool uploadDistillerXmlResultsFile(std::string filename, UploadResponseCode & responseCode, std::string & responseText);
00171 #else // SWIG Multiple return values
00172             bool uploadDistillerXmlResultsFile(std::string filename, UploadResponseCode & OUTPUT, std::string & OUTPUT);
00173 #endif
00174         private:
00175             // Constructor for a newly submitted search
00176             ms_http_client_search(ms_http_client_session & session, std::string searchTaskId, const std::string & actionString);
00177
00178             ms_http_client_session * session_;
00179             std::string searchTaskId_;
00180             std::string actionString_;
00181             ms_http_helper_handles postRequestHandles_;
00182
00183         friend class ms_http_client_session; // access to constructor and private member variables when starting a search
00184     };
00185  // end of http_client_group
00187 } // namespace matrix_science
00188
00189 #endif // MS_HTTP_CLIENT_SEARCH_HPP
00190
00191 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_client_session.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_client_session.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Represents a session on a Mascot server                                    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_client_session.hpp $
00012  * @(#)$Revision: ad538b116c843eb04f4e6cb8ff8f73b915de025f | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2020-02-14 10:16:25 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_CLIENT_SESSION_HPP
00018 #define MS_HTTP_CLIENT_SESSION_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace matrix_science
00025 {
00031     class ms_http_client;
00032     class ms_http_client_search;
00033
00035
00046     class MS_MASCOTRESFILE_API ms_http_client_session :
00047         public ms_errors
00048     {
00049     public:
00051
00057         enum SequenceShowOptions
00058         {
00059             SHOW_PI = 0x0001,
00060             SHOW_TITLE = 0x0002,
00061             SHOW_LENGTH = 0x0004,
00062             SHOW_SEQUENCE = 0x0008,
00063             SHOW_REFERENCE = 0x0010,
00064
00065             SHOW_NONE = 0,
00066             SHOW_ALL = 0xFFFF
00067         };
00068
00069
00071         ms_http_client_session();
00072
00074         ms_http_client_session(const ms_http_helper connection, const std::string sessionId);
00075
00077         virtual ~ms_http_client_session();
00078
00079         ms_http_client_session(const ms_http_client_session & src);
00080 #ifndef SWIG
00081         ms_http_client_session& operator=(const ms_http_client_session & right);
00082 #endif
00083         void copyFrom(const ms_http_client_session * right);
00084
00086         std::string getSessionID() const;
00087         std::string sessionId() const { return getSessionID(); }   // Deprecated. Released with 2.5.2
00088 #ifndef SWIG
00089
00090         bool getIsPermitted(ms_security_tasks::TASKID taskType, bool & returnIsPermitted);
00091 #else // SWIG Multiple return values
00092         bool getIsPermitted(ms_security_tasks::TASKID taskType, bool & OUTPUT);
00093 #endif
00094
00095 #ifndef SWIGCSHARP
00096
00097         bool submitSearch(
00098             ms_http_client_search & returnTask,
00099             const std::string & httpHeader,
00100             const std::string & prologue,
00101             const std::string & filename,
00102             const std::string & epilogue,
00103             ms_http_helper_progress & progress,
00104             bool batch = false);
00105 #else
00106         bool submitSearch(
00107             ms_http_client_search & returnTask,
00108             const std::wstring & httpHeader,
00109             const std::wstring & prologue,
00110             const std::wstring & filename,
00111             const std::wstring & epilogue,
00112             ms_http_helper_progress & progress,
00113             bool batch = false) {
00114                 return submitSearchWide(returnTask, httpHeader, prologue, filename, epilogue, progress, batch);
00115             };
00116 #endif
00117
00119             bool getSequenceFile(
00120                     const std::string & database,
00121                     const std::vector<std::string> & accessionNames,
00122                     const std::vector<int> & accessionFrames,
00123                     const std::string & filename,
00124                     const SequenceShowOptions options = SHOW_ALL
00125                     );
00126
00128             bool logout();
00129
00131             bool getIsXmlUploadedList(const std::vector<std::string> & taskIds, std::vector<int> & xmlUploaded);
00132
00133         private:
00134
00135             // type of login for the session to allow re-login if session has expired
00136             enum SessionSecurityType {
00137                 SECURITY_NONE,
00138                 SECURITY_DISABLED,
00139                 SECURITY_GUEST,
00140                 SECURITY_WEB,
00141                 SECURITY_USER
00142             };
00143
00144             ms_http_client_session(
00145                     ms_http_helper connection,
00146                     std::string sessionId,
00147                     SessionSecurityType security,
00148                     const std::string & username = "",
00149                     const std::string & password = "");
00150
00151             // Create a new Mascot task attached to this Mascot session.
00152             bool createTask(
00153                     ms_http_client_search & returnTask);
00154
00155             // http functions to be used by the task class to re-try is Mascot session has expired
00156             bool httpGetString(const std::string & action, std::string & result);
00157             bool httpGetResponseUsingSessionId(const std::string & action, ms_http_helper_response & response);
00158             bool httpGetFileUsingSessionId(
00159                     const std::string & action,
00160                     const std::string & filename,
00161                     ms_http_helper_progress & progress,
00162                     ms_http_helper::FileMode fileMode = ms_http_helper::FM_binary);
00163             bool httpPostFileAppendingSessionId(
00164                     const std::string & action,
00165                     const std::string & httpHeader,
00166                     const std::string & prologue,
00167                     const std::string & filename,
00168                     const std::string & epilogue,
00169                     ms_http_helper_handles & handles,
00170                     ms_http_helper_progress & progress);
00171             bool relogin();
00172
00173             bool submitSearchWide(
00174                 ms_http_client_search & returnTask,
00175                 const std::wstring & httpHeader,
00176                 const std::wstring & prologue,
00177                 const std::wstring & filename,
00178                 const std::wstring & epilogue,
00179                 ms_http_helper_progress & progress,
00180                 bool batch = false
00181             );
00182
00183             ms_http_helper connection_;
00184             std::string sessionId_;
00185
00186             SessionSecurityType security_;
00187             std::string username_;
00188             std::string password_;
00189
00190             bool isLoggedIn_;
00191
00192         friend class ms_http_client; // access to private constructor used when logging in
00193         friend class ms_http_client_search; // access to useful getString and getFile functions
00194     };
00195  // end of http_client_group
00197 } // namespace matrix_science
00198
00199 #endif // MS_HTTP_CLIENT_SESSION_HPP
00200
00201 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_helper.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_helper.hpp                                                          #
00004 # 'msparser' toolkit                                                         #
00005 # Provides functions for an HTTP link (eg to a Mascot server)                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_helper.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #if !defined(MS_HTTP_HELPER_HPP_)
00018 #define MS_HTTP_HELPER_HPP_
00019
00020 #ifdef _WIN32
00021 #ifdef __MINGW__
00022 // No ATL or MFC support -- use curl
00023 #else
00024 #define USE_ATL
00025 #endif
00026 #endif
00027
00028 #include <string>
00029
00030 class LocalHelper;
00031
00032 namespace matrix_science
00033 {
00039     class ms_connection_settings;
00040     class ms_http_helper_handles;
00041     class ms_http_helper_progress;
00042     class ms_http_helper_proxy_list;
00043
00045
00055     class MS_MASCOTRESFILE_API ms_http_helper :
00056         public ms_errors
00057     {
00058         public:
00060
00063             enum FileMode
00064             {
00065                 FM_binary,
00066                 FM_text
00067             };
00068
00069 #ifdef USE_ATL
00070
00071             static void yieldToCom();
00072 #endif
00073
00075             bool getProxyConfig(std::vector<std::string> &proxyServers, std::vector<std::string> &proxyUsernames, std::vector<std::string> &proxyPasswords);
00076
00077 #ifndef SWIG
00078
00079             ms_http_helper();
00080
00082             ms_http_helper(const ms_http_helper & copy);
00083
00085             const ms_http_helper & operator =(const ms_http_helper & copy);
00086 #endif
00087             void copyFrom(const ms_http_helper * right);
00088
00090             ms_http_helper(
00091                     const std::string & baseUrl,
00092                     const ms_connection_settings & settings);
00093
00095             ~ms_http_helper();
00096
00098             const std::string & baseUrl() const;
00099
00101             const ms_connection_settings & connectionSettings() const;
00102 #ifndef SWIG
00103
00104             ms_http_helper_return httpGetString(const std::string & action, std::string & httpGETString);
00105 #else // SWIG Multiple return values
00106             ms_http_helper_return httpGetString(const std::string & action, std::string & OUTPUT);
00107 #endif
00108
00109             ms_http_helper_return httpPostFile(
00110                     const std::string & action,
00111                     const std::string & httpHeader,
00112                     const std::string & prologue,
00113                     const std::string & filename,
00114                     const std::string & epilogue,
00115                     ms_http_helper_handles & handles,
00116                     ms_http_helper_progress & progress);
00117
00119             ms_http_helper_return httpGetFile(
00120                     const std::string & action,
00121                     const std::string & filename,
00122                     ms_http_helper_progress & progress,
00123                     FileMode fileMode = FM_binary);
00124
00126             ms_http_helper_return httpBufferedOpen(const std::string & action);
00127 #ifndef SWIG
00128
00129             ms_http_helper_return httpBufferedGetString(std::string & httpBuffer, unsigned long requiredSize );
00130
00132             ms_http_helper_return httpGetHeader(const std::string & action, std::string & httpHeaderInfo);
00133 #else // SWIG Multiple return values
00134             ms_http_helper_return httpBufferedGetString(std::string & OUTPUT, unsigned long requiredSize);
00135             ms_http_helper_return httpGetHeader(const std::string & action, std::string & OUTPUT);
00136 #endif
00137
00138             ms_http_helper_return httpBufferedClose();
00139
00140
00142             static std::string getHeaderValue(const std::string &name, const std::string & header);
00143
00144         private:
00145
00146 #ifndef USE_ATL
00147             bool analyseCurlResult(void * pVoidCurl, ms_http_helper_return & returnCode, std::string & performError, char * errorBuffer = NULL, std::vector< std::pair<int, std::string> > * pProxyErrors = NULL);
00148             void * performCurlAndCheckHttpsCertificate(void * pVoidCurl, std::string & certificateError, std::string & systemCertPath, std::string & userCertPath, bool bCheckCertificate = true);
00149 #endif // USE_ATL
00150
00151             const std::string completeUrl(const std::string & action) const;
00152
00153             ms_http_helper_return httpGetLocal(
00154                     const std::string & action,
00155                     std::string & strResult,
00156                     const std::string & filename,
00157                     FileMode fileMode,
00158                     ms_http_helper_progress & progress);
00159
00160             ms_http_helper_return httpOpenLocal(const std::string & action, bool bHeaderOnly = false);
00161
00162             ms_http_helper_return httpGetNextLocal(
00163                     std::string & buffer,
00164                     unsigned long requiredSize );
00165
00166             ms_http_helper_return curlOpenLocal(const std::string & action);
00167
00168             ms_http_helper_return curlGetNextLocal(
00169                     std::string & buffer,
00170                     unsigned long requiredSize);
00171
00172             ms_http_helper_return closeLocal();
00173
00174             bool determineProxy();
00175
00176             std::string baseUrl_;
00177             ms_connection_settings connectionSettings_;
00178
00179             // autoproxy detect cache
00180             ms_http_helper_proxy_list * proxyList_;
00181
00182             LocalHelper * localHelper_;
00183
00184     };
00185      // end of http_client_group
00187 } // namespace matrix_science
00188
00189 #endif // MS_HTTP_HELPER_HPP_
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_helper_handles.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_helper_handles.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Hold the handles for an internet file post function.                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_helper_handles.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_HELPER_HANDLES_HPP
00018 #define MS_HTTP_HELPER_HANDLES_HPP
00019
00020
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00025     class ms_http_helper_handles_body;
00026
00032
00033
00045     class MS_MASCOTRESFILE_API ms_http_helper_handles :
00046         public ms_errors
00047     {
00048         public:
00050             ms_http_helper_handles();
00051             ms_http_helper_handles(const ms_http_helper_handles &);
00052 #ifndef SWIG
00053             const ms_http_helper_handles & operator=(const ms_http_helper_handles &);
00054             ms_http_helper_handles(const ms_http_helper_handles_body & impl);
00055 #endif
00056
00058             virtual ~ms_http_helper_handles();
00059 #ifndef SWIG
00060
00061             bool getRequestData(bool & isStillActive, std::string & requestDataRef);
00062 #else // SWIG Multiple return values
00063             bool getRequestData(bool & OUTPUT, std::string & OUTPUT);
00064 #endif
00065
00066             void setRequestData(const std::string & strResult);
00067
00069             bool closeHandles();
00070
00071         private:
00072             void copyFrom(const ms_http_helper_handles & copy);
00073             void release();
00074
00075             ms_http_helper_handles_body * pimpl_;
00076             std::string strResult_;
00077     };
00078  // end of http_client_group
00080 } // namespace matrix_science
00081
00082 #endif // MS_HTTP_HELPER_HANDLES_HPP
00083
00084 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_helper_handles_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_helper_handles_body.hpp
00004 # 'msparser' toolkit
00005 # Hold the handles for an internet file post function.
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef _HTTP_HELPER_HANDLES_BODY_HPP
00018 #define _HTTP_HELPER_HANDLES_BODY_HPP
00019
00020 #include <string>
00021
00022 #ifdef _WIN32
00023 #define WIN32_LEAN_AND_MEAN // Exclude rarely-used stuff from Windows headers
00024 #include <windows.h>
00025 #include <winhttp.h>
00026 #endif
00027
00028 namespace matrix_science
00029 {
00030     class ms_http_helper_handles_body
00031     {
00032         public:
00033         volatile long refCount;
00034     #ifdef _WIN32
00035         HINTERNET hSession;
00036         HINTERNET hConnection;
00037         HINTERNET hRequest;
00038
00039         ms_http_helper_handles_body()
00040         {
00041             refCount = 1;
00042             hSession = NULL;
00043             hConnection = NULL;
00044             hRequest = NULL;
00045         }
00046
00047         ms_http_helper_handles_body(
00048             HINTERNET hSess,
00049             HINTERNET hConn,
00050             HINTERNET hRequ)
00051         {
00052             refCount = 1;
00053             hSession = hSess;
00054             hConnection = hConn;
00055             hRequest = hRequ;
00056         }
00057     #endif
00058         void addRef()
00059         {
00060     #ifdef _WIN32
00061             InterlockedIncrement(&refCount);
00062     #endif
00063         }
00064
00065         long release()
00066         {
00067             long r = 0;
00068     #ifdef _WIN32
00069             r = InterlockedDecrement(&refCount);
00070     #endif
00071             return r;
00072         }
00073     };
00074 }
00075
00076 #endif // _HTTP_HELPER_HANDLES_BODY_HPP
00077
00078 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_helper_progress.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_helper_progress.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Hold information about the progress of an internet file transfer           #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_helper_progress.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_HELPER_PROGRESS_HPP
00018 #define MS_HTTP_HELPER_PROGRESS_HPP
00019
00020
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00030
00031
00041     class MS_MASCOTRESFILE_API ms_http_helper_progress
00042     {
00043         public:
00044 #ifndef SWIG
00045
00046             ms_http_helper_progress();
00047 #endif
00048
00050             void setAbort();
00051
00053             bool isAbortSet() const;
00054
00056             bool isStarted() const;
00057
00059             UINT64 getCurrentBytes() const;
00060             UINT64 current() const { return getCurrentBytes(); } // Deprecated and undocumented - not a normal Parser function name
00061
00063             UINT64 getTotalBytes() const;
00064             UINT64 total() const { return getTotalBytes(); } // Deprecated and undocumented - not a normal Parser function name
00065
00067             double getProportion() const;
00068             double proportion() const { return getProportion(); } // Deprecated and undocumented - not a normal Parser function name
00069
00071             bool isComplete() const;
00072
00073         private:
00074             void setStarted();
00075             void setProgress(UINT64 current, UINT64 total);
00076             void setComplete();
00077
00078             bool   abort_;
00079             bool   isStarted_;
00080             bool   isComplete_;
00081             UINT64 current_;
00082             UINT64 total_;
00083             int    count_;
00084             double proportion_;
00085
00086         friend class ms_http_helper;
00087     };
00088      // end of http_client_group
00090 } // namespace matrix_science
00091
00092 #endif // MS_HTTP_HELPER_PROGRESS_HPP
00093
00094 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_helper_response.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_helper_response.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Hold a response from a Mascot server function invocation                   #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_helper_response.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_HELPER_RESPONSE_HPP
00018 #define MS_HTTP_HELPER_RESPONSE_HPP
00019
00020
00021 #include <map>
00022 #include <string>
00023
00024 namespace matrix_science
00025 {
00031     class MS_MASCOTRESFILE_API ms_http_helper_response
00032     {
00033         public:
00035             enum StatusCode {
00036                 S_SUCCESS = 0,
00037                 S_LOGINERROR = 1,
00038                 S_PARSERERROR = 2,
00039                 S_SERVERERROR = 3,
00040                 S_MISSING = 4
00041             };
00042
00044
00047             enum LoginErrorCode {
00048                 L_SUCCESS = 0,
00049                 L_PARAMETER = -1,
00050                 L_NOT_AUTHORISED = -2,
00051                 L_SECURITYENABLED = -3,
00052                 L_WEBAUTHENTICATIONDISABLED = -4,
00053                 L_GUESTLOGINDISABLED = -5
00054             };
00055
00056 #ifndef SWIG
00057             // C++ STL collection support.
00058             ms_http_helper_response();
00059 #endif
00060
00061             ms_http_helper_response(const std::string & text);
00062
00064             virtual ~ms_http_helper_response();
00065
00067             StatusCode getStatus() const;
00068             StatusCode status() const { return getStatus(); } // Deprecated and undocumented - not a normal Parser function name
00069
00071             LoginErrorCode getLoginError() const;
00072             LoginErrorCode loginError() const { return getLoginError(); } // Deprecated and undocumented - not a normal Parser function name
00073
00075             long getParserError() const;
00076             long parserError() const { return getParserError(); } // Deprecated and undocumented - not a normal Parser function name
00077
00079             bool hasErrorText() const;
00080
00082             std::string getErrorText() const;
00083             std::string errorText() const { return getErrorText(); } // Deprecated and undocumented - not a normal Parser function name
00084
00086             bool hasSessionId() const;
00087
00089             std::string getSessionID() const;
00090             std::string sessionId() const { return getSessionID(); } // Deprecated and undocumented - not a normal Parser function name
00091
00093             bool hasTaskId() const;
00094
00096             std::string getTaskID() const;
00097             std::string taskId() const { return getTaskID(); } // Deprecated and undocumented - not a normal Parser function name
00098
00100             std::string getText() const;
00101             std::string text() const { return getText(); }  // Deprecated and undocumented - not a normal Parser function name
00102 #ifndef SWIG
00103
00104             bool findValue(const std::string & label, std::string & valueFromLabel) const;
00105 #else // SWIG Multiple return values
00106             bool findValue(const std::string & label, std::string & OUTPUT) const;
00107 #endif
00108         private:
00109             std::string     text_;
00110
00111             StatusCode      status_;
00112             LoginErrorCode  loginError_;
00113             long            parserError_;
00114
00115             bool            hasErrorText_;
00116             std::string     errorText_;
00117             bool            hasSessionId_;
00118             std::string     sessionId_;
00119             bool            hasTaskId_;
00120             std::string     searchTaskId_;
00121
00122             std::map<std::string, std::string> values_;
00123     };
00124  // end of http_client_group
00126 } // namespace matrix_science
00127
00128 #endif // MS_HTTP_HELPER_RESPONSE_HPP
00129
00130 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_http_helper_return.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_http_helper_return.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Hold a response from an internet function                                  #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_http_helper_return.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_HTTP_HELPER_RETURN_HPP
00018 #define MS_HTTP_HELPER_RETURN_HPP
00019
00020
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00030
00031
00036     class MS_MASCOTRESFILE_API ms_http_helper_return
00037     {
00038         public:
00040
00043             enum ErrorTypeCode
00044             {
00045                 ERR_NONE,
00046                 ERR_ABORTEDBYUSER,
00047                 ERR_SYSTEM,
00048                 ERR_HTTP,
00049                 ERR_UNSPECIFIED
00050             };
00051
00053             static ms_http_helper_return systemError(int systemError);
00055             static ms_http_helper_return httpError(int httpStatusCode, std::string errorText);
00057             static ms_http_helper_return unspecifiedError();
00059             static ms_http_helper_return abortedByUser();
00060
00061 #ifndef SWIG
00062
00063             ms_http_helper_return();
00064 #endif
00065
00067             bool isOk() const;
00068 #ifndef SWIG
00069
00070             operator bool () const;
00071 #endif
00072
00074             ErrorTypeCode getErrorType() const;
00075             ErrorTypeCode errorType() const { return getErrorType();      } // Deprecated and undocumented - not a normal Parser function name
00076
00078             int getSystemError() const;
00079             int systemError() const         { return getSystemError();    }  // Deprecated and undocumented - not a normal Parser function name
00080
00082             int getHttpStatusCode() const;
00083             int httpStatusCode() const      { return getHttpStatusCode(); } // Deprecated and undocumented - not a normal Parser function name
00084
00086             std::string getErrorText() const;
00087             std::string errorText() const   { return getErrorText();      } // Deprecated and undocumented - not a normal Parser function name
00088
00089         private:
00090             ErrorTypeCode errorType_;
00091             int           systemError_;
00092             int           httpStatusCode_;
00093             std::string   errorText_;
00094     };
00095  // end of http_client_group
00097 } // namespace matrix_science
00098
00099 #endif // MS_HTTP_HELPER_RETURN_HPP
00100
00101 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_input_stream.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_input_stream.hpp                                                     #
00004 # 'msparser' toolkit                                                         #
00005 #                                                                            #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 2014 Matrix Science Limited  All Rights Reserved.                #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive::  $
00012 #     $Author: villek@matrixscience.com $
00013 #       $Date: 2018-07-30 16:23:53 +0100 $
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 # $NoKeywords:: $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_INPUT_STREAM_HPP
00020 #define MS_INPUT_STREAM_HPP
00021
00022
00023 namespace matrix_science
00024 {
00025     class ms_input_string_stream
00026     {
00027         public:
00028             virtual ~ms_input_string_stream() {}
00029             virtual void beginRead() {}
00030             virtual std::string read(unsigned maxToRead) {
00031                 std::string emptyString = "";
00032                 return emptyString;
00033             }
00034             virtual void endRead() {}
00035     };
00036 }
00037
00038 #endif // MS_INPUT_STREAM_HPP
00039
00040 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_inputquery.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_inputquery.hpp                                                    #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a query from the mascot results file                          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2002 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_inputquery. $ #
00012 #     $Author: dcreasy@matrixscience.com $ #
00013 #       $Date: 2019-11-07 13:48:45 +0000 $ #
00014 #   $Revision: aae33ae602127b2f755e8fa9c5d9391218d406e4 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_INPUTQUERY_HPP
00020 #define MS_INPUTQUERY_HPP
00021
00022
00023 #include <string>
00024
00025 namespace matrix_science {
00026
00032
00033
00038     class MS_MASCOTRESFILE_API ms_inputquery
00039     {
00040     public:
00041
00043         ms_inputquery(const ms_mascotresfile &resfile, const int q);
00044         ~ms_inputquery();
00045
00046 #ifndef SWIGCSHARP
00047
00048         std::string getStringTitle(bool unescaped) const;
00049 #else
00050         std::wstring getStringTitle(bool unescaped) const
00051         {
00052             return getStringTitleWide(unescaped);
00053         };
00054 #endif
00055
00056         std::string getCharge() const;
00057
00059         std::string getSeq(int seq_no)   const;
00060
00062         std::string getComp(int comp_no) const;
00063
00065         std::string getTag(int tag_no) const;
00066
00068         double getMassMin() const;
00069
00071         double getMassMax() const;
00072
00074         double getIonMobility() const;
00075
00077         int getNumVals()    const;
00078
00080         int getNumUsed()    const;
00081
00083         std::string getStringIons1(bool includeCharges = false);
00084
00086         std::string getStringIons2(bool includeCharges = false);
00087
00089         std::string getStringIons3(bool includeCharges = false);
00090
00092         double getIntMax() const;
00093
00095         double getIntMin() const;
00096
00098         std::vector<std::pair<double,double> > getPeakList(const int ions);
00099
00101         double getPeakMass(const int ions, const int peakNo);
00102
00104         double getPeakIntensity(const int ions, const int peakNo);
00105
00107         int    getNumberOfPeaks(const int ions);
00108
00110         double getTotalIonsIntensity();
00111
00113         double getPepTol() const;
00114
00116         std::string getPepTolUnits() const;
00117
00119         std::string getPepTolString() const;
00120
00122         std::string getINSTRUMENT(const bool unescaped = true) const;
00123
00125         std::string getRULES() const;
00126
00128         double getMinInternalMass() const;
00129
00131         double getMaxInternalMass() const;
00132
00134         std::string getIT_MODS(const bool unescaped = true) const;
00135
00137         int getNumberOfLocalVarMods() const;
00138
00140         std::string getLocalVarModName(const int num) const;
00141
00143         std::string getScanNumbers(const int rawFileIdx = -1) const;
00144
00146         void getScanNumbers(std::vector<int> &index, std::vector<std::string> &scans) const;
00147
00149         std::string getRawScans(const int rawFileIdx = -1) const;
00150
00152         void getRawScans(std::vector<int> &index, std::vector<std::string> &rawscans) const;
00153
00155         std::string getRetentionTimes(const int rawFileIdx = -1) const;
00156
00158         void getRetentionTimes(std::vector<int> &index, std::vector<std::string> &times) const;
00159
00161         std::string getRawfile() const;
00162
00164         std::string getLocus() const;
00165
00167         int getIndex() const;
00168
00169 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00170         static std::vector<std::string> splitIT_MODS(std::string itmods);
00171 #endif
00172
00173     private:
00174         enum { max_seqs_  = 20, max_comps_ = 20, max_tags_ = 20 };
00175         const ms_mascotresfile &resfile_;
00176         const int q_;
00177
00178         mutable bool has_title_;
00179         mutable std::string title_;
00180         mutable std::string unescapedTitle_;
00181
00182         mutable bool has_charge_;
00183         mutable std::string charge_;
00184
00185         mutable bool has_seq_;
00186         mutable std::string seq_[max_seqs_   +1];
00187
00188         mutable bool has_comp_;
00189         mutable std::string comp_[max_comps_ +1];
00190
00191         mutable bool has_tag_;
00192         mutable std::string tag_[max_tags_ + 1];
00193
00194         mutable bool has_mass_min_;
00195         mutable double mass_min_;
00196
00197         mutable bool has_mass_max_;
00198         mutable double mass_max_;
00199
00200         mutable bool has_ion_mobility_;
00201         mutable double ion_mobility_;
00202
00203         mutable bool has_num_vals_;
00204         mutable int num_vals_;
00205
00206         mutable bool has_num_used_;
00207         mutable int num_used_;
00208
00209         bool has_ions_;
00210         std::string ions_[3], ionsCharges_[3];
00211         std::vector<std::pair<double,double> > peakList_[3];  // for ions1, 2 and 3
00212         std::vector<std::string> peakListCharges_[3];  // Also for ions1, 2 and 3
00213
00214         mutable bool has_int_max_;
00215         mutable double int_max_;
00216
00217         mutable bool has_int_min_;
00218         mutable double int_min_;
00219
00220         mutable bool has_tol_;
00221         mutable double tol_;
00222         mutable std::string tol_units_;
00223
00224         mutable bool has_instrument_;
00225         mutable std::string instrument_;
00226         mutable std::string unescaped_instrument_;
00227
00228         mutable bool has_rules_;
00229         mutable std::string rules_;
00230
00231         mutable bool has_internalMasses_;
00232         mutable double minInternalMass_;
00233         mutable double maxInternalMass_;
00234
00235         mutable bool has_it_mods_;
00236         mutable std::string it_mods_;
00237         mutable std::string unescaped_it_mods_;
00238         mutable std::vector<std::string> local_modtitles_;
00239
00240         ms_umod_configfile umodfile_;
00241
00242         mutable bool has_rt_;
00243         mutable std::vector<int> rtIndices_;
00244         mutable std::vector<std::string> rtValues_;
00245
00246         mutable bool has_scans_;
00247         mutable std::vector<int> scansIndices_;
00248         mutable std::vector<std::string> scansValues_;
00249
00250         mutable bool has_rawscans_;
00251         mutable std::vector<int> rawscansIndices_;
00252         mutable std::vector<std::string> rawscansValues_;
00253
00254         mutable bool has_rawfile_;
00255         mutable std::string rawfile_;
00256
00257         mutable bool has_locus_;
00258         mutable std::string locus_;
00259
00260         mutable bool has_index_;
00261         mutable int index_;
00262
00263         void fillPeakList(const int ions);
00264         void loadIons();
00265         void retrieveAllValuesOf(const std::string &prefix, std::vector<int> &index, std::vector<std::string> &values) const;
00266         std::wstring getStringTitleWide(bool unescaped) const;
00267         std::wstring getRawfileWide() const;
00268         std::string getStringIonsWithCharges(const int index);
00269     }; // end of resfile_group
00271 }   // matrix_science namespace
00272
00273 #endif // !defined(MS_INPUTQUERY_HPP)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_libraryoptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_parserule.hpp                                                     #
00004 # 'msparser' toolkit                                                         #
00005 # Represents LibraryOptions section of mascot.dat file                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_parserule.hpp           $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_LIBRARYOPTIONS_HPP
00020 #define MS_LIBRARYOPTIONS_HPP
00021
00022
00023
00024 #include <string>
00025 #include <map>
00026
00027 namespace matrix_science {
00034
00035
00052     class MS_MASCOTRESFILE_API ms_libraryoptions : public ms_customproperty
00053     {
00054         friend class ms_datfile;
00055     public:
00057         ms_libraryoptions();
00058
00060         ms_libraryoptions(const ms_libraryoptions& src);
00061
00063         ~ms_libraryoptions();
00064
00066         void defaultValues();
00067
00069         void copyFrom(const ms_libraryoptions* right);
00070
00071 #ifndef SWIG
00072
00073         ms_libraryoptions& operator=(const ms_libraryoptions& right);
00074 #endif
00075
00076
00080         bool isSectionAvailable() const;
00081
00083         void setSectionAvailable(const bool value);
00084
00086         double getToleranceInPPM(const char * spectralLibraryName) const;
00087
00089         void setToleranceInPPM(const char * spectralLibraryName, double tolerance);
00090
00092         double getToleranceInDa(const char * spectralLibraryName) const;
00093
00095         void setToleranceInDa(const char * spectralLibraryName, double tolerance);
00096
00098         std::string getReferenceFasta(const char * spectralLibraryName) const;
00099
00101         std::string getReferenceFastaTaxonomyTitle(const char * spectralLibraryName) const;
00102
00104         void setReferenceFasta(const char * spectralLibraryName, const char * fastaDatabaseName, const char * taxonomyTitle);
00105
00107         void dropSpectralLibrary(const char * spectralLibraryName);
00108
00110         int getNumberOfLibraries() const;
00111
00113         std::string getLibraryName(const int num) const;
00114
00115 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00116 #include "suppress_ms_customproperty.hpp"
00117 #endif
00118
00119     private:
00120         bool sectionAvailable_;
00121         struct sl_info_t {
00122         public:
00123             std::string referenceFastaDB;
00124             std::string referenceFastaTaxonomyTitle;
00125             double tolInPPM;
00126             double tolInDa;
00127         };
00128         typedef std::map<std::string, sl_info_t> slInfoMap_t;
00129         slInfoMap_t slInfoMap_;
00130     }; // end of config_group
00132 } // namespace matrix_science
00133
00134 #endif // MS_LIBRARYOPTIONS_HPP
00135
00136 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_license.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_license.hpp                                                       #
00004 # 'msparser' toolkit                                                         #
00005 # Provides read-only interface for mascot license file                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_license.hpp             $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_LICENSE_HPP
00020 #define MS_LICENSE_HPP
00021
00022
00023 #include <string>
00024
00025
00026 namespace matrix_science {
00032
00033
00051     class MS_MASCOTRESFILE_API ms_license: public ms_errors
00052     {
00053     public:
00055         ms_license();
00056
00058         ms_license(const ms_license& src);
00059
00061         ms_license(const char* filename);
00062
00064         ~ms_license();
00065
00067         void defaultValues();
00068
00070         void copyFrom(const ms_license* right);
00071
00072 #ifndef SWIG
00073
00074         ms_license& operator=(const ms_license& right);
00075 #endif
00076
00077         std::string getFileName() const;
00078
00080         void setFileName(const char* filename);
00081
00083         void read_file();
00084
00086         bool isLicenseValid() const;
00087
00089         std::string getLicenseString() const;
00090
00092         std::string getLicenseVersion() const;
00093
00095         std::string getStartDate() const;
00096
00098         std::string getEndDate() const;
00099
00101         int getNumProcessorsLicensed() const;
00102
00104         std::string getLicensee() const;
00105
00107         std::string getDistributor() const;
00108
00110         std::string getFeatures() const;
00111
00112         int getInternalConfigurationCode() const;
00113
00114     private:
00115         bool loadLicenseFile(FILE *f);
00116         bool checkLicenseValid(const char* startDate, const char* endDate);
00117         int  calcChecksum(void* entity);
00118         void formLicenseString();
00119         void checkInternalConfiguration();
00120
00121         bool bLicenseValid_;
00122         std::string filename_;
00123         std::string strLicenseString_;
00124
00125         std::string licenseVer_;
00126         std::string startDate_;
00127         std::string endDate_;
00128         int processors_;
00129         std::string licensee_;
00130         std::string distributor_;
00131         std::string features_;
00132
00133         int internalConfigurationCode_;
00134     }; // class ms_license // end of config_group
00136 } // namespace matrix_science
00137
00138 #endif // MS_LICENSE_HPP
00139
00140 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_linker_site.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_linker_site.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Linker site used in ms_peptide                                             #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2020-01-23 19:01:43 +0000 $ #
00013 #   $Revision: #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_LINKERSITE_HPP
00019 #define MS_LINKERSITE_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024
00025 namespace matrix_science {
00026     class ms_peptide;
00027
00033
00034
00042     class MS_MASCOTRESFILE_API ms_linker_site
00043     {
00044         public:
00046             ms_linker_site();
00047
00049             ms_linker_site(ms_peptide::PSM linkFrom,
00050                            ms_peptide::PSM linkTo,
00051                            int siteFrom,
00052                            int siteTo,
00053                            int varModIdxFrom,
00054                            int varModIdxTo,
00055                            double linkerMass);
00056
00058             ms_linker_site(const ms_linker_site& src);
00059
00061             ~ms_linker_site();
00062
00063 #ifndef SWIG
00064
00065             ms_linker_site& operator=(const ms_linker_site& right);
00066
00067             bool operator<(const ms_linker_site &right) const;
00068 #endif
00069
00071             void copyFrom(const ms_linker_site *right);
00072
00074             int getSiteFrom() const;
00075
00077             int getSiteTo() const;
00078
00080             int getVarModIdxFrom() const;
00081
00083             int getVarModIdxTo() const;
00084
00086             ms_peptide::PSM getLinkFrom() const;
00087
00089             ms_peptide::PSM getLinkTo() const;
00090
00092             double getLinkerMass() const;
00093
00094         private:
00095             ms_peptide::PSM linkFrom_, linkTo_;
00096             int siteFrom_, siteTo_;
00097             int varModIdxFrom_, varModIdxTo_;
00098             double linkerMr_;
00099     }; // end of resfile_group
00101 }   // matrix_science namespace
00102
00103 #endif // MS_LINKERSITE_HPP
00104
00105 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_linker_site_vector.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_linker_site_vector.hpp                                            #
00004 # 'msparser' toolkit                                                         #
00005 # A vector of ms_linker_site objects                                         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2020-01-23 19:01:43 +0000 $ #
00013 #   $Revision: 319ea315661ca493dc5ff56750ff3ee780e76da0 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_LINKERSITEVECTOR_HPP
00019 #define MS_LINKERSITEVECTOR_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <vector>
00024 #include <list>
00025
00026 namespace matrix_science {
00027     class ms_linker_site;
00028 }
00029
00030 namespace matrix_science {
00036
00037
00045     class MS_MASCOTRESFILE_API ms_linker_site_vector
00046     {
00047         public:
00049             ms_linker_site_vector();
00050
00051 #ifndef SWIG
00052
00053             ms_linker_site_vector(const std::vector<ms_linker_site> &v, const int alphaVarModsLen, const int betaVarModsLen);
00054
00056             ms_linker_site_vector(const std::list<ms_linker_site> &v, const int alphaVarModsLen, const int betaVarModsLen);
00057 #endif
00058
00060             ms_linker_site_vector(const ms_linker_site_vector& src);
00061
00063             ~ms_linker_site_vector();
00064
00065 #ifndef SWIG
00066
00067             ms_linker_site_vector& operator=(const ms_linker_site_vector& right);
00068
00070             const std::vector<ms_linker_site>& toVector() const;
00071 #endif
00072
00074             void copyFrom(const ms_linker_site_vector *src);
00075
00077             void append(const ms_linker_site_vector & src);
00078
00080             int size() const;
00081
00083             bool empty() const;
00084
00086             void push(const ms_linker_site &linkerSite);
00087
00089             ms_linker_site pop();
00090
00092             ms_linker_site get(int idx) const;
00093
00095             void set(int idx, const ms_linker_site &linkerSite);
00096
00098             void clear();
00099
00101             void swap(ms_linker_site_vector &right);
00102
00104             bool containsVarModIdx(int idx) const;
00105
00107             int getVarModIdxOfLinkedSite(const ms_peptide::PSM psmComponent, const int i) const;
00108
00110             int getAlphaVarModsStrLength() const;
00111
00113             int getBetaVarModsStrLength() const;
00114
00116             void setVarModsStrLengths(const int alphaVarModsLen, const int betaVarModsLen);
00117
00119             std::string stringify() const;
00120
00121         private:
00122             std::vector<ms_linker_site> data_;
00123             int alphaVarModsLen_, betaVarModsLen_;
00124     }; // end of resfile_group
00126 }   // matrix_science namespace
00127
00128 #endif // MS_LINKERSITEVECTOR_HPP
00129
00130 /*------------------------------- End of File -------------------------------*/
00131
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_log.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_log.hpp                                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a general-purpose error object that collects information      #
00006 # about several consecutive erros                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_errors.hpp              $ #
00013 #     $Author: robertog@matrixscience.com $ #
00014 #       $Date: 2022-01-21 10:45:21 +0000 $ #
00015 #   $Revision: 9c3ccb8f3d173eef7cffd2b17803e1b7dac3efa7 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_LOG_HPP
00021 #define MS_LOG_HPP
00022
00023
00024 #include <cstdarg>
00025 #include <vector>
00026 #include <string>
00027 #include <map>
00028 #include <set>
00029 #include <utility>
00030
00031 namespace matrix_science {
00037
00038     class MS_MASCOTRESFILE_API ms_log
00039     {
00040     public:
00042
00047         enum msg_sev {
00048             sev_fatal  = 1,
00049             sev_warn   = 2,
00050             sev_info   = 3,
00051             sev_debug1 = 4,
00052             sev_debug2 = 5,
00053             sev_debug3 = 6
00054         };
00055
00057
00127         typedef int msg_num_t;
00128
00129 #ifndef SWIG
00130         typedef struct {
00131             ms_log::msg_sev     severity;
00132             ms_log::msg_num_t   msgNum;
00133             const char        * pMsgText;
00134         } msg_catalog_t;
00135         typedef std::map<ms_log::msg_num_t, const msg_catalog_t *> catalog_map_t;
00136 #endif
00137
00138         static const msg_num_t LOGMSG_DBG1_NUM_PROCESSOR_GROUPS        = 0x00010160;
00139         static const msg_num_t LOGMSG_DBG3_HWLOC_TREE                  = 0x00010161;
00140         static const msg_num_t LOGMSG_DBG3_HWLOC_GROUPS                = 0x00010162;
00141         static const msg_num_t LOGMSG_DBG3_AUTO_DETECT_NUM_THREAD      = 0x00010163;
00142         static const msg_num_t LOGMSG_DBG3_CALL_GET_CHIP_MFCTR         = 0x00010164;
00143         static const msg_num_t LOGMSG_DBG3_PROCESSOR_NAME              = 0x00010165;
00144         static const msg_num_t LOGMSG_DBG3_BINDING_PROCESSORS          = 0x00010166;
00145         static const msg_num_t LOGMSG_DBG3_BINDING_THREAD              = 0x00010167;
00146         static const msg_num_t LOGMSG_DBG2_NUM_CONFIG_MISMATCH         = 0x00010168;
00147         static const msg_num_t LOGMSG_DBG2_NUM_ONLINE_MISMATCH         = 0x00010169;
00148         static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_ON_SYS          = 0x00010170;
00149         static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_AVAIL           = 0x00010171;
00150         static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_GROUPS          = 0x00010172;
00151         static const msg_num_t LOGMSG_DBG2_CPU_INF_NAME                = 0x00010173;
00152         static const msg_num_t LOGMSG_DBG2_CPU_INF_PROC_AFFINITY       = 0x00010174;
00153         static const msg_num_t LOGMSG_DBG2_CPU_INF_USE_PROCESSES       = 0x00010175;
00154         static const msg_num_t LOGMSG_DBG2_CPU_INF_NUM_PHYSICAL        = 0x00010176;
00155         static const msg_num_t LOGMSG_DBG2_CPU_INF_LOGI_PER_PHYS       = 0x00010177;
00156         static const msg_num_t LOGMSG_DBG2_CPU_INF_CORE_PER_PHYS       = 0x00010178;
00157         static const msg_num_t LOGMSG_DBG2_CPU_INF_GETAUTODETECT       = 0x00010179;
00158         static const msg_num_t LOGMSG_DBG2_CPU_INF_MT_NAME             = 0x0001017A;
00159         static const msg_num_t LOGMSG_DBG2_CPU_INF_MT_STATUS           = 0x0001017B;
00160         static const msg_num_t LOGMSG_DBG2_CPU_INF_TABLE_TITLE         = 0x0001017C;
00161         static const msg_num_t LOGMSG_DBG2_CPU_INF_TABLE_LINE          = 0x0001017D;
00162
00163         // Installer logging messages
00164         static const msg_num_t LOGMSG_INST_LOGICALPERPHYSICALCPU       = 0x00010200;
00165         static const msg_num_t LOGMSG_INST_NUMTHREADS                  = 0x00010201;
00166         static const msg_num_t LOGMSG_INST_NOTMASCOTDATOK              = 0x00010202;
00167         static const msg_num_t LOGMSG_INST_MASCOTDATOK                 = 0x00010203;
00168         static const msg_num_t LOGMSG_INST_APPENDTAXONOMY              = 0x00010204;
00169         static const msg_num_t LOGMSG_INST_ADDINGDATABASE              = 0x00010205;
00170         static const msg_num_t LOGMSG_INST_CHANGEDBTAXONOMY            = 0x00010206;
00171         static const msg_num_t LOGMSG_INST_APPENDPARSERULE             = 0x00010207;
00172         static const msg_num_t LOGMSG_INST_ADDOPTIONSSECTION           = 0x00010208;
00173         static const msg_num_t LOGMSG_INST_SETOPTIONSSECTION           = 0x00010209;
00174         static const msg_num_t LOGMSG_INST_CLUSTERSECTION              = 0x0001020A;
00175         static const msg_num_t LOGMSG_INST_NOSUBCLUSTERSET             = 0x0001020B;
00176         static const msg_num_t LOGMSG_INST_CHANGEPARSERULE             = 0x0001020C;
00177         static const msg_num_t LOGMSG_INST_SAVEDPOSTINSTALLFILE        = 0x0001020D;
00178         static const msg_num_t LOGMSG_INST_FAILSAVEPOSTINSTALLFILE     = 0x0001020E;
00179         static const msg_num_t LOGMSG_INST_REMOVEOPTIONSSECTION        = 0x0001020F;
00180         static const msg_num_t LOGMSG_INST_CHANGEPERCOLATORFEATS       = 0x00010210;
00181         static const msg_num_t LOGMSG_INST_CHANGEPROTFAMILYSWITCH      = 0x00010211;
00182
00183         static const msg_num_t LOGMSG_HTTP_URLSTRING                   = 0x00010300;
00184         static const msg_num_t LOGMSG_HTTP_QUERYSTATUSRESULT           = 0x00010301;
00185         static const msg_num_t LOGMSG_HTTP_MAXCONECTIONSFAILED         = 0x00010302;
00186         static const msg_num_t LOGMSG_HTTP_MAXCONECTIONS10FAILED       = 0x00010303;
00187         static const msg_num_t LOGMSG_HTTP_GETRETURNSTRING             = 0x00010304;
00188
00189
00190         // Quantitation logging messages
00191         static const msg_num_t LOGMSG_CUSTQUANT_ADD_QUANT_KEY          = 0x00010400;
00192         static const msg_num_t LOGMSG_CUSTQUANT_REMOVE_ALL_KEY         = 0x00010401;
00193         static const msg_num_t LOGMSG_CUSTQUANT_REMOVE_KEY             = 0x00010402;
00194         static const msg_num_t LOGMSG_QUANT_START_UPDATE_PROT_MATCHES  = 0x00010403;
00195         static const msg_num_t LOGMSG_QUANT_FINISH_UPDATE_PROT_MATCHES = 0x00010404;
00196         static const msg_num_t LOGMSG_QUANT_START_CALC_COMPLETE        = 0x00010405;
00197         static const msg_num_t LOGMSG_QUANT_FINISH_CALC_COMPLETE       = 0x00010406;
00198         static const msg_num_t LOGMSG_QUANT_START_LOAD_CDB             = 0x00010408;
00199         static const msg_num_t LOGMSG_QUANT_FINISH_LOAD_CDB            = 0x00010409;
00200         static const msg_num_t LOGMSG_QUANT_LOAD_PEP_STATUS_MATCHES    = 0x0001040A;
00201         static const msg_num_t LOGMSG_QUANT_LOADING_MATCHES            = 0x0001040B;
00202         static const msg_num_t LOGMSG_QUANT_UPDATING_PEP_EVIDENCE      = 0x0001040C;
00203         static const msg_num_t LOGMSG_QUANT_REAPPLY_THRESHOLDS         = 0x0001040D;
00204         static const msg_num_t LOGMSG_QUANT_UPDATE_EXCLUDED_MATCHES    = 0x0001040E;
00205         static const msg_num_t LOGMSG_QUANT_CALC_COMPLETE_ON_MERGED    = 0x0001040F;
00206         static const msg_num_t LOGMSG_QUANT_REMATCHING_INFERRED        = 0x00010410;
00207         static const msg_num_t LOGMSG_QUANT_EXCLUDING_PEPTIDE          = 0x00010411;
00208         static const msg_num_t LOGMSG_QUANT_EXCLUDING_PEPTIDE_LESSTHAN = 0x00010412;
00209         static const msg_num_t LOGMSG_QUANT_EXCLUDING_PEPTIDE_GREATHAN = 0x00010413;
00210         static const msg_num_t LOGMSG_QUANT_REMOVE_MATCH_NO_EVIDENCE   = 0x00010414;
00211         static const msg_num_t LOGMSG_QUANT_REMOVE_INFERRED_MATCH      = 0x00010415;
00212         static const msg_num_t LOGMSG_QUANT_ADDING_PROTEIN_HIT         = 0x00010416;
00213         static const msg_num_t LOGMSG_QUANT_ADDED_PROTEIN_HIT          = 0x00010417;
00214         static const msg_num_t LOGMSG_QUANT_OPENING_CACHE_FILE         = 0x00010418;
00215         static const msg_num_t LOGMSG_QUANT_CLOSING_CACHE_FILE         = 0x00010419;
00216         static const msg_num_t LOGMSG_QUANT_START_REORDER_AFTER_MERGE  = 0x0001041A;
00217         static const msg_num_t LOGMSG_QUANT_FINISH_REORDER_AFTER_MERGE = 0x0001041B;
00218
00219         // ms_matrix (mathematical matrix, not matrix science) debugging
00220         static const msg_num_t LOGMSG_MATRIX_OUTPUT_VALS               = 0x00010500;
00221
00222         // ms_aahelper tracing
00223         static const msg_num_t LOGMSG_AAHELPER_CFR_NUM_FRAGMENTS       = 0x00010600;
00224         static const msg_num_t LOGMSG_AAHELPER_REGULAR_ION_REJECT      = 0x00010601;
00225         static const msg_num_t LOGMSG_AAHELPER_REGULAR_ION_ADD         = 0x00010602;
00226         static const msg_num_t LOGMSG_AAHELPER_REGULAR_PRIME_ION_REJECT= 0x00010603;
00227         static const msg_num_t LOGMSG_AAHELPER_REGULAR_PRIME_ION_ADD   = 0x00010604;
00228         static const msg_num_t LOGMSG_AAHELPER_IMMONIUM_ION_REJECT     = 0x00010605;
00229         static const msg_num_t LOGMSG_AAHELPER_IMMONIUM_ION_ADD        = 0x00010606;
00230         static const msg_num_t LOGMSG_AAHELPER_INTERNAL_ION_REJECT     = 0x00010607;
00231         static const msg_num_t LOGMSG_AAHELPER_INTERNAL_ION_ADD        = 0x00010608;
00232         static const msg_num_t LOGMSG_AAHELPER_CROSSLINKED_START       = 0x00010609;
00233         static const msg_num_t LOGMSG_AAHELPER_MULTINL_INDICES         = 0x0001060A;
00234         static const msg_num_t LOGMSG_AAHELPER_MASTER_NL_VALS          = 0x0001060B;
00235         static const msg_num_t LOGMSG_AAHELPER_TOTAL_NL_VALS           = 0x0001060C;
00236         static const msg_num_t LOGMSG_AAHELPER_CUMULATIVE_MASS_NL      = 0x0001060D;
00237         static const msg_num_t LOGMSG_AAHELPER_SERIES_PARAMS           = 0x0001060E;
00238         static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_MAX_REACHED   = 0x0001060F;
00239         static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_D_PRIME_RES = 0x00010610;
00240         static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_D_RESIDUE = 0x00010611;
00241         static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_V_RESIDUE = 0x00010612;
00242         static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_W_PRIME_RES = 0x00010613;
00243         static const msg_num_t LOGMSG_AAHELPER_CALC_MASS_SKIP_W_RESIDUE = 0x00010614;
00244         static const msg_num_t LOGMSG_AAHELPER_ETMOD_LOOKUP            = 0x00010615;
00245         static const msg_num_t LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_INIT  = 0x00010616;
00246         static const msg_num_t LOGMSG_AAHELPER_SETUP_FROM_PRE2_2_ANYCHNG = 0x00010617;
00247         static const msg_num_t LOGMSG_AAHELPER_CFR_START_FRAGMENTS     = 0x00010618;
00248         static const msg_num_t LOGMSG_AAHELPER_CROSSLINKED_END         = 0x00010619;
00249         static const msg_num_t LOGMSG_AAHELPER_CFR_SET_QUANT_COMPONENT = 0x0001061A;
00250         static const msg_num_t LOGMSG_AAHELPER_CFR_MASSES_VALUE        = 0x0001061B;
00251         static const msg_num_t LOGMSG_AAHELPER_CFR_MOD_DELTA_AT_SITE   = 0x0001061C;
00252         static const msg_num_t LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_LINKER   = 0x0001061D;
00253         static const msg_num_t LOGMSG_AAHELPER_CFR_INIT_VARMOD_IS_MONOLINK = 0x0001061E;
00254         static const msg_num_t LOGMSG_AAHELPER_CFR_LOOPLINKING_MASK    = 0x0001061F;
00255
00256         // ms_proteininference tracing
00257         static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_START      = 0x00010700;
00258         static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_QUEUE      = 0x00010701;
00259         static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_REP_SEQS   = 0x00010702;
00260         static const msg_num_t LOGMSG_PROTINFER_PEPTIDE_MATRIX         = 0x00010703;
00261         static const msg_num_t LOGMSG_PROTINFER_FIND_FAMILY_END        = 0x00010704;
00262         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_START     = 0x00010705;
00263         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_PARENT_LIST = 0x00010706;
00264         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_SAMESET_LEAD_LIST   = 0x00010707;
00265         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_DISCARDED_SL_LIST   = 0x00010708;
00266         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION             = 0x00010709;
00267         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_MEMBER_LIST = 0x0001070A;
00268         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_LEAD_LIST   = 0x0001070B;
00269         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_ELIMINATION_SUBSET_LIST = 0x0001070C;
00270         static const msg_num_t LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_FREE_COUNT_ZERO = 0x0001070D;
00271         static const msg_num_t LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_NEXT            = 0x0001070E;
00272         static const msg_num_t LOGMSG_PROTINFER_ELIMINATE_INTERSECTIONS_SUPERSET_LIST   = 0x0001070F;
00273         static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_START          = 0x00010710;
00274         static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_EMPTY = 0x00010711;
00275         static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_SUPERSET_LIST  = 0x00010712;
00276         static const msg_num_t LOGMSG_PROTINFER_CHOOSE_NEXT_KEEP           = 0x00010713;
00277         static const msg_num_t LOGMSG_PROTINFER_REMOVE_CONFLICTING_START   = 0x00010714;
00278         static const msg_num_t LOGMSG_PROTINFER_REMOVE_CONFLICTING_KEEP    = 0x00010715;
00279         static const msg_num_t LOGMSG_PROTINFER_REMOVE_CONFLICTING_DISCARD = 0x00010716;
00280         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_START        = 0x00010717;
00281         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_CREATE       = 0x00010718;
00282         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_CREATED      = 0x00010719;
00283         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_NO_PROTEINS  = 0x0001071A;
00284         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MINPROTEINSCORE  = 0x0001071B;
00285         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_MAXHITS          = 0x0001071C;
00286         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTPEPLEN    = 0x0001071D;
00287         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_LONGESTSIGPEPLEN = 0x0001071E;
00288         static const msg_num_t LOGMSG_PROTINFER_SUBSET_STARTS_NEW_HIT                 = 0x0001071F;
00289         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_REMOVE_CHECKBOLD        = 0x00010720;
00290         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_NEXT_PROTEIN = 0x00010721;
00291         static const msg_num_t LOGMSG_PROTINFER_SORT_BY_SCORE_DONE         = 0x00010722;
00292         static const msg_num_t LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_START = 0x00010723;
00293         static const msg_num_t LOGMSG_PROTINFER_FIND_MATCHES_SUBSET_START  = 0x00010724;
00294         static const msg_num_t LOGMSG_PROTINFER_FIND_MATCHES_PROTEIN_END   = 0x00010725;
00295         static const msg_num_t LOGMSG_PROTINFER_CLUSTER_FROM_ACC           = 0x00010726;
00296         static const msg_num_t LOGMSG_PROTINFER_GROUP_FROM_ACC             = 0x00010727;
00297         static const msg_num_t LOGMSG_PROTINFER_SINGLETON_FROM_ACC         = 0x00010728;
00298         static const msg_num_t LOGMSG_PEPSUM_GETHIT                        = 0x00010729;
00299         static const msg_num_t LOGMSG_PROTINFER_NUM_PEPTIDES_IN_FAMILY     = 0x0001072A;
00300         static const msg_num_t LOGMSG_PROTINFER_GROUP_FAMILY_PULL_IN       = 0x0001072B;
00301
00302         // ms_quant_helper tracing
00303         static const msg_num_t LOGMSG_QUANT_HELPER_TEST_REQUIRED           = 0x00010800;
00304
00305         // Generic tracing messages
00306         static const msg_num_t LOGMSG_REPORT_FUNCTION_CALLED_BY            = 0x00010900;
00307         static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY                = 0x00010901;
00308         static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS1     = 0x00010902;
00309         static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS2     = 0x00010903;
00310         static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS3     = 0x00010904;
00311         static const msg_num_t LOGMSG_REPORT_FUNCTION_ENTRY_WITH_ARGS4     = 0x00010905;
00312
00313         static const msg_num_t LOGMSG_REPORT_FUNCTION_EXIT                 = 0x00010910;
00314         static const msg_num_t LOGMSG_REPORT_FUNCTION_EXIT_WITH            = 0x00010911;
00315
00316         // ms_mascotresfile or ms_mascotresults tracing
00317         static const msg_num_t LOGMSG_RESFILE_APPEND                       = 0x00010A00;
00318         static const msg_num_t LOGMSG_GET_THRESHOLD_FOR_FIRST_PASS_FDR     = 0x00010A01;
00319         static const msg_num_t LOGMSG_GET_THRESHOLD_FOR_FDR_FOR_ET         = 0x00010A02;
00320         static const msg_num_t LOGMSG_GET_THR_LOOP_BODY_START              = 0x00010A03;
00321         static const msg_num_t LOGMSG_GET_THR_LOOP_BODY_ZERO_COUNT         = 0x00010A04;
00322         static const msg_num_t LOGMSG_GET_THR_LOOP_BODY_MIN_FOUND          = 0x00010A05;
00323         static const msg_num_t LOGMSG_GET_THR_REACH_COND                   = 0x00010A06;
00324
00325     public:
00327         ms_log();
00328
00330         virtual ~ms_log();
00331
00332     public:
00333 #ifndef SWIG
00334 #if defined(_INTERNAL_USE_AND_HAVE_BOOST_FORMAT) || defined(DOXYGEN_SHOULD_SKIP_THIS)
00335
00337
00344         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum) {
00345             ms_log::msg_sev severity;
00346             std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00347             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00348         }
00349
00350
00352         template <typename T1>
00353         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1);
00354
00356         template <typename T1, typename T2>
00357         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2);
00358
00360         template <typename T1, typename T2, typename T3>
00361         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3);
00362
00364         template <typename T1, typename T2, typename T3, typename T4>
00365         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4);
00366
00368         template <typename T1, typename T2, typename T3, typename T4, typename T5>
00369         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5);
00370
00372         template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6>
00373         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6);
00374
00376         template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7>
00377         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7);
00378
00380         template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8>
00381         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8);
00382
00384         template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8, typename T9>
00385         void logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8, T9 arg9);
00386 #endif
00387 #endif
00388
00390         virtual msg_sev getLoggingLevel() const = 0;
00391
00393         bool willMessageBeLogged(const msg_num_t msgNum) const;
00394
00396         std::string _lookUpMsg(const ms_log::msg_num_t msgNum, ms_log::msg_sev & severity) const;
00397
00399         ms_log::msg_sev getMessageSeverity(const ms_log::msg_num_t msgNum) const;
00400
00402         ms_loggingmonitor::Source_e getMessageSource(const ms_log::msg_num_t msgNum) const;
00403
00404 #ifndef SWIG
00405         enum errorOrLogMessages_e { MSG_LOG, MSG_ERR };
00406
00408         void addToCatalog(const msg_catalog_t catalog[], size_t numEntries, ms_loggingmonitor::Source_e src, errorOrLogMessages_e errorOrLogMessages);
00409 #endif
00410
00411     protected:
00412         virtual void _setError(const int /* ms_errs::err*/ errorNum,
00413             const char* strBuffer,
00414             const msg_sev severity,
00415             const std::string & sessionID = "",
00416             const int userID = -1,
00417             const int srcLineNumber = -1,
00418             const char * srcFileName = "") = 0;
00419
00420     private:
00421         typedef std::pair<ms_loggingmonitor::Source_e, errorOrLogMessages_e> msgsSrcAndType_t;
00422         catalog_map_t& getGlobalCatalog() const;
00423         std::set<msgsSrcAndType_t>& getGlobalAddedToCatalog() const;
00424     }; // class ms_log
00425  // end of error_handling_group
00427 } // namespace matrix_science
00428
00429 #ifndef SWIG
00430 #ifdef _INTERNAL_USE_AND_HAVE_BOOST_FORMAT
00431 #include "private/ms_log_impl.hpp"
00432 #endif
00433 #endif
00434
00435
00436 #endif // MS_LOG_HPP
00437
00438 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_log_impl.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_log_impl.hpp                                                      #
00004 # 'msparser' toolkit                                                         #
00005 # Included from ms_log.hpp - but conditionally for when building the library #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_errors.hpp              $ #
00013 #     $Author: dcreasy@matrixscience.com $ #
00014 #       $Date: 2020-02-17 11:03:19 +0000 $ #
00015 #   $Revision: 16a3f4baa19a07d69f3cdf5833b81caa60bbc674 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_LOG_IMPL_HPP
00021 #define MS_LOG_IMPL_HPP
00022
00023
00024 #ifndef SWIG
00025 #if defined(_INTERNAL_USE_AND_HAVE_BOOST_FORMAT) || defined(DOXYGEN_SHOULD_SKIP_THIS)
00026
00027 #include "boost/format.hpp"
00028
00029 namespace matrix_science {
00030
00031
00032
00033 // It's OK to have templated functions in this file.
00034 // If the code for this, non template, function is added here you will
00035 // get multiply defined link warnings
00036 /*
00037 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum)
00038 {
00039     ms_log::msg_sev severity;
00040     std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00041     _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00042 } */
00043
00052 template <typename T1>
00053 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1) {
00054     if (willMessageBeLogged(msgNum)) {
00055         ms_log::msg_sev severity;
00056         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00057         boost::format fmter(unformattedMsg);
00058         if (fmter.expected_args() == 1) {
00059             fmter % arg1;
00060             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00061         } else {
00062             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00063         }
00064     }
00065 }
00066
00076 template <typename T1, typename T2>
00077 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2) {
00078     if (willMessageBeLogged(msgNum)) {
00079         ms_log::msg_sev severity;
00080         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00081         boost::format fmter(unformattedMsg);
00082         if (fmter.expected_args() == 2) {
00083             fmter % arg1 %arg2;
00084             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00085         } else {
00086             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00087         }
00088     }
00089 }
00090
00101 template <typename T1, typename T2, typename T3>
00102 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3) {
00103     if (willMessageBeLogged(msgNum)) {
00104         ms_log::msg_sev severity;
00105         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00106         boost::format fmter(unformattedMsg);
00107         if (fmter.expected_args() == 3) {
00108             fmter % arg1 %arg2 %arg3;
00109             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00110         } else {
00111             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00112         }
00113     }
00114 }
00115
00116
00128 template <typename T1, typename T2, typename T3, typename T4>
00129 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4) {
00130     if (willMessageBeLogged(msgNum)) {
00131         ms_log::msg_sev severity;
00132         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00133         boost::format fmter(unformattedMsg);
00134         if (fmter.expected_args() == 4) {
00135             fmter % arg1 %arg2 %arg3 %arg4;
00136             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00137         } else {
00138             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00139         }
00140     }
00141 }
00142
00143
00156 template <typename T1, typename T2, typename T3, typename T4, typename T5>
00157 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5) {
00158     if (willMessageBeLogged(msgNum)) {
00159         ms_log::msg_sev severity;
00160         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00161         boost::format fmter(unformattedMsg);
00162         if (fmter.expected_args() == 5) {
00163             fmter % arg1 %arg2 %arg3 %arg4 %arg5;
00164             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00165         } else {
00166             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00167         }
00168     }
00169 }
00170
00184 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6>
00185 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6) {
00186     if (willMessageBeLogged(msgNum)) {
00187         ms_log::msg_sev severity;
00188         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00189         boost::format fmter(unformattedMsg);
00190         if (fmter.expected_args() == 6) {
00191             fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6;
00192             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00193         } else {
00194             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00195         }
00196     }
00197 }
00198
00213 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7>
00214 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7) {
00215     if (willMessageBeLogged(msgNum)) {
00216         ms_log::msg_sev severity;
00217         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00218         boost::format fmter(unformattedMsg);
00219         if (fmter.expected_args() == 7) {
00220             fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6 %arg7;
00221             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00222         }
00223         else {
00224             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00225         }
00226     }
00227 }
00228
00244 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8>
00245 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8) {
00246     if (willMessageBeLogged(msgNum)) {
00247         ms_log::msg_sev severity;
00248         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00249         boost::format fmter(unformattedMsg);
00250         if (fmter.expected_args() == 8) {
00251             fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6 %arg7 %arg8;
00252             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00253         }
00254         else {
00255             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00256         }
00257     }
00258 }
00259
00276 template <typename T1, typename T2, typename T3, typename T4, typename T5, typename T6, typename T7, typename T8, typename T9>
00277 void ms_log::logMessage(ms_log::msg_num_t msgNum, const char * srcFile, const int lineNum, T1 arg1, T2 arg2, T3 arg3, T4 arg4, T5 arg5, T6 arg6, T7 arg7, T8 arg8, T9 arg9) {
00278     if (willMessageBeLogged(msgNum)) {
00279         ms_log::msg_sev severity;
00280         std::string unformattedMsg = _lookUpMsg(msgNum, severity);
00281         boost::format fmter(unformattedMsg);
00282         if (fmter.expected_args() == 9) {
00283             fmter % arg1 %arg2 %arg3 %arg4 %arg5 %arg6 %arg7 %arg8 %arg9;
00284             _setError(static_cast<int>(msgNum), fmter.str().c_str(), severity, "", -1, lineNum, srcFile);
00285         }
00286         else {
00287             _setError(static_cast<int>(msgNum), unformattedMsg.c_str(), severity, "", -1, lineNum, srcFile);
00288         }
00289     }
00290 }
00291
00292 #endif
00293 #endif
00294
00295 } // namespace matrix_science
00296
00297 #endif // MS_LOG_IMPL_HPP
00298
00299 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_logging.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_logging.hpp                                                       #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates general purpose objects which act as conduits for receiving   #
00006 # and processing logging events                                              #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 2015-2016 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Source: parser/inc/ms_logging.hpp $
00013 #    $Author: dcreasy@matrixscience.com $
00014 #      $Date: 2020-02-17 11:11:01 +0000 $
00015 #  $Revision: 568c8a55fee82c07355ed0cee4a6cbf220d9a6fe | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_LOGGING_HPP
00020 #define MS_LOGGING_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <vector>
00026 #include <list>
00027
00028 namespace msparser_internal {
00029     class ms_loggingmonitor_impl;
00030 }
00031
00032 namespace matrix_science {
00033     class ms_logger;
00034
00039
00040
00043     class MS_MASCOTRESFILE_API ms_loggingmonitor
00044     {
00045     public:
00047
00051         enum Level_e {
00052             LVL_NONE     = 0,
00053             LVL_ERROR    = 1,
00054             LVL_WARNING  = 2,
00055             LVL_INFO     = 4,
00056             LVL_DEBUG1   = 8,
00057             LVL_DEBUG2   = 16,
00058             LVL_DEBUG3   = 32
00059         }; // enum LogLevel_e
00060
00062
00065         enum Source_e {
00066             SRC_APPLICATION  = 1,
00067             SRC_MASCOTSERVER = 2,
00068             SRC_MSPARSER     = 3,
00069             SRC_MDRO         = 4,
00070             SRC_MSQUANTLIB   = 5,
00071             SRC_PURIFIERAPI  = 6,
00072             SRC_PURIFIERAPP  = 7,
00073             SRC_DENOVOLIB    = 8,
00074             SRC_VENDORSTART  = 100,
00075             SRC_ALL          = 0xFFFF
00076         }; // enum LogSource_e
00077
00078     private:
00079         msparser_internal::ms_loggingmonitor_impl *pImpl_;
00080         static ms_loggingmonitor defaultLoggingMonitor;
00081
00082     public:
00084         ms_loggingmonitor();
00085
00087         virtual ~ms_loggingmonitor();
00088
00090         virtual int addLogEventsHandler(ms_logger& logger);
00091
00093         virtual bool removeLogEventsHandler(const int uid);
00094
00096         virtual ms_logger * getLogEventsHandler(const int uid);
00097
00099         virtual int getNumLogEventsHandlers() const;
00100
00102         virtual void logMessage(Level_e eSeverity,
00103             Source_e eSource,
00104             long lMsgId,
00105             const std::string & text,
00106             const char * srcFileName,
00107             const int srcFileLineNum,
00108             long lContextId=0) const;
00109
00111         virtual long getLogMask(unsigned source = SRC_ALL);
00112
00114         virtual void setLogMask(long newVal, unsigned source = SRC_ALL);
00115
00117         static matrix_science::ms_loggingmonitor & getDefaultMonitor();
00119         static void setDefaultMonitor(ms_loggingmonitor & loggingMonitor);
00120
00122         static std::string messageSourceAsText(Source_e eSource);
00123
00125         static std::string severityAsText(Level_e eSeverity);
00126
00127     }; // class ms_loggingmonitor
00128
00130
00135     class MS_MASCOTRESFILE_API ms_logger {
00136     public:
00138
00149         enum LogOutputColumns_e {
00150             COL_ASC_TIME         = 0x0001,
00151             COL_ISO8601_TIME     = 0x0002,
00152             COL_IP_ADDRESS       = 0x0004,
00153             COL_MSG_NUM_DEC      = 0x0008,
00154             COL_MSG_NUM_HEX      = 0x0010,
00155             COL_SEVERITY_NUM     = 0x0020,
00156             COL_SEVERITY_TXT     = 0x0040,
00157             COL_MSG_SOURCE_TXT   = 0x0080,
00158             COL_SRC_FILE         = 0x0100,
00159             COL_SRC_LINENUM      = 0x0200,
00160             COL_THREAD_ID        = 0x0400,
00161             COL_MSG              = 0x0800,
00162
00163             COL_TSV              = 0x1000,
00164             COL_QUOTES           = 0x2000,
00165             COL_HEADERS          = 0x4000,
00166
00167             COL_LOGGER_DEFAULTS = COL_ISO8601_TIME | COL_MSG_NUM_HEX | COL_SEVERITY_TXT | COL_MSG_SOURCE_TXT | COL_SRC_FILE | COL_SRC_LINENUM | COL_MSG | COL_HEADERS
00168         };
00169
00171         ms_logger(const unsigned int colsToOutput = COL_MSG);
00172
00174         virtual ~ms_logger() {}
00175
00177         virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
00178             ms_loggingmonitor::Source_e eSource,
00179             long lMsgId,
00180             const std::string & text,
00181             const char * srcFileName,
00182             const int srcFileLineNum,
00183             long lContextId=0)=0;
00184
00186         virtual unsigned int getColsToOutput() const;
00187
00189         virtual void setColsToOutput(const unsigned int colsToOutput);
00190
00192         std::string formatMessage(ms_loggingmonitor::Level_e eSeverity,
00193                                   ms_loggingmonitor::Source_e eSource,
00194                                   long lMsgId,
00195                                   const std::string & text,
00196                                   const char * srcFileName,
00197                                   const int srcFileLineNum,
00198                                   long lContextId) const;
00199
00201         std::string getHeaderLine() const;
00202
00203     protected:
00204         unsigned int colsToOutput_;
00205     }; // class ms_logger
00206
00208     class MS_MASCOTRESFILE_API ms_stdout_logger : public ms_logger {
00209     public:
00211         ms_stdout_logger(unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS);
00213         virtual ~ms_stdout_logger();
00214
00216         virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
00217             ms_loggingmonitor::Source_e eSource,
00218             long lMsgId,
00219             const std::string & text,
00220             const char * srcFileName,
00221             const int srcFileLineNum,
00222             long lContextId=0);
00223
00224     }; // class ms_stdout_logger
00225
00227     class MS_MASCOTRESFILE_API ms_file_logger : public ms_logger {
00228     public:
00230         ms_file_logger(const std::string logFileName, unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS);
00231
00233         virtual ~ms_file_logger();
00234
00236         std::string getLogFilename();
00237
00239         virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
00240             ms_loggingmonitor::Source_e eSource,
00241             long lMsgId,
00242             const std::string & text,
00243             const char * srcFileName,
00244             const int srcFileLineNum,
00245             long lContextId=0);
00246
00247     private:
00248         std::string logfilename_;
00249
00250     }; // class ms_file_logger
00251
00253     class MS_MASCOTRESFILE_API ms_buffer_logger : public ms_logger {
00254     public:
00256         ms_buffer_logger(unsigned int colsToOutput = ms_logger::COL_LOGGER_DEFAULTS);
00257
00259         virtual ~ms_buffer_logger();
00260
00262         std::vector<std::string> flush();
00263
00265         virtual void onLogMessage(ms_loggingmonitor::Level_e eSeverity,
00266             ms_loggingmonitor::Source_e eSource,
00267             long lMsgId,
00268             const std::string & text,
00269             const char * srcFileName,
00270             const int srcFileLineNum,
00271             long lContextId=0);
00272
00273     private:
00274         std::list<std::string> messages_;
00275         std::list<std::string>::size_type numMessages_;
00276
00277     }; // class ms_file_logger
00278  // end of error_handling_group
00280 } // namespace matrix_science
00281
00282 #endif // MS_LOGGING_HPP
00283
00284 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_loggingmonitor_impl.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_loggingmonitor_impl.hpp                                           #
00004 # Mascot Parser toolkit                                                      #
00005 # Private implementation of ms_loggingmonitor
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 2015-2016 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source$
00012 #    $Author$
00013 #      $Date$
00014 #  $Revision$
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_LOGGINGMONITOR_IMPL_HPP
00019 #define MS_LOGGINGMONITOR_IMPL_HPP
00020
00021 #include "ms_logging.hpp"
00022
00023 #include <map>
00024
00025 namespace msparser_internal {
00026     // Bug 12291: Logging monitor must use the pImpl pattern, because we
00027     // don't want to leak the mutex class in the public API.
00028
00029     class ms_loggingmonitor_impl
00030     {
00031     public:
00032         ms_loggingmonitor_impl();
00033         ~ms_loggingmonitor_impl();
00034
00035         int addLogEventsHandler(matrix_science::ms_logger &logger);
00036
00037         bool removeLogEventsHandler(const int uid);
00038
00039         matrix_science::ms_logger* getLogEventsHandler(const int uid);
00040
00041         int getNumLogEventsHandlers() const;
00042
00043         void logMessage(matrix_science::ms_loggingmonitor::Level_e eSeverity,
00044             matrix_science::ms_loggingmonitor::Source_e eSource,
00045             long lMsgId,
00046             const std::string & text,
00047             const char * srcFileName,
00048             const int srcFileLineNum,
00049             long lContextId=0) const;
00050
00051         long getLogMask(unsigned source) const;
00052
00053         void setLogMask(long newVal, unsigned source);
00054
00055     private:
00056         mutable ms_mutex loggingMutex_;
00057         bool _isMaskedOut(matrix_science::ms_loggingmonitor::Level_e eLvl, matrix_science::ms_loggingmonitor::Source_e eSource) const;
00058         std::map<long, long> logMask_;  // source -> mask
00059         int nextuid_;
00060         typedef std::map<const int, matrix_science::ms_logger *> loggers_t;
00061         loggers_t loggers_;
00062
00063     };
00064 } // msparser_internal
00065
00066 #endif // MS_LOGGINGMONITOR_IMPL_HPP
00067
00068 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotfiles.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotfiles.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Contains pathes to some configuration files                                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotfiles.hpp         $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTFILES_HPP
00020 #define MS_MASCOTFILES_HPP
00021
00022
00023 #include <string>
00024
00025
00026 namespace matrix_science {
00032
00033
00052     class MS_MASCOTRESFILE_API ms_mascotfiles: public ms_customproperty
00053     {
00054         friend class ms_datfile;
00055     public:
00056
00058         ms_mascotfiles();
00059
00061         ms_mascotfiles(const ms_mascotfiles& src);
00062
00064         ~ms_mascotfiles();
00065
00067         void defaultValues();
00068
00070         void copyFrom(const ms_mascotfiles* right);
00071
00072 #ifndef SWIG
00073
00074         ms_mascotfiles& operator=(const ms_mascotfiles& right);
00075 #endif
00076
00077         std::string getModifications() const;
00078
00080         void setModifications(const char* filename);
00081
00083         std::string getEnzymes() const;
00084
00086         void setEnzymes(const char* filename);
00087
00089         std::string getFrequencies() const;
00090
00092         void setFrequencies(const char* filename);
00093
00095         std::string getNodeListFile() const;
00096
00098         void setNodeListFile(const char* filename);
00099
00100 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00101 #include "suppress_ms_customproperty.hpp"
00102 #endif
00103
00104     private:
00105         std::string mods_;
00106         std::string enzymes_;
00107         std::string freqs_;
00108         std::string nodeListFile_;
00109     };// class ms_mascotfiles // end of config_group
00111
00112 } // namespace matrix_science
00113
00114 #endif // MS_MASCOTFILES_HPP
00115
00116 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotoptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotoptions.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "Options" section of "mascot.dat" file that describes most    #
00006 # important parameters                                                       #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotoptions.hpp       $ #
00013 #     $Author: francoisr@matrixscience.com $ #
00014 #       $Date: 2021-05-21 16:59:53 +0100 $ #
00015 #   $Revision: 666210a89688eb394d284ca454da0ad70252e9db | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_MASCOTOPTIONS_HPP
00021 #define MS_MASCOTOPTIONS_HPP
00022
00023
00024 #include <string>
00025 #include <vector>
00026
00027 namespace matrix_science {
00032 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00033     class MS_MASCOTRESFILE_API ms_blastaccession
00034     {
00035         friend class ms_datfile;
00036
00037     public:
00038         ms_blastaccession();
00039         ms_blastaccession(const ms_blastaccession& src);
00040         ~ms_blastaccession();
00041
00042         void defaultValues();
00043         void copyFrom(const ms_blastaccession* right);
00044 #ifndef SWIG
00045         ms_blastaccession& operator=(const ms_blastaccession& right);
00046 #endif
00047         bool isUseRegex() const;
00048         void setUseRegex(const bool flag);
00049
00050         int getMinLength() const;
00051         void setMinLength(const int value);
00052
00053         const char* getStart() const;
00054         const char* getStop() const;
00055
00056     private:
00057
00058         bool useRegex_;
00059         int  minLen_;
00060         char start_[255];
00061         char stop_[255];
00062     }; // class ms_blastaccession
00063 #endif
00064
00066
00090     class MS_MASCOTRESFILE_API ms_mascotoptions: public ms_customproperty
00091     {
00092         friend class ms_datfile;
00093
00094     public:
00096
00099         enum MS_REVIEW_COL
00100         {
00101             MS_REVIEW_COL_JOB               = 0x0000,
00102             MS_REVIEW_COL_PID               = 0x0001,
00103             MS_REVIEW_COL_DATABASE          = 0x0002,
00104             MS_REVIEW_COL_USERNAME          = 0x0003,
00105             MS_REVIEW_COL_USEREMAIL         = 0x0004,
00106             MS_REVIEW_COL_TITLE             = 0x0005,
00107             MS_REVIEW_COL_RESULTS_FILE      = 0x0006,
00108             MS_REVIEW_COL_START_TIME        = 0x0007,
00109             MS_REVIEW_COL_DURATION          = 0x0008,
00110             MS_REVIEW_COL_STATUS            = 0x0009,
00111             MS_REVIEW_COL_PRIORITY          = 0x000A,
00112             MS_REVIEW_COL_SEARCHTYPE        = 0x000B,
00113             MS_REVIEW_COL_ENZYMEUSED        = 0x000C,
00114             MS_REVIEW_COL_IPADDRESS         = 0x000D,
00115             MS_REVIEW_COL_USERID            = 0x000E,
00116             MS_REVIEW_COL_PEAKLISTDATAFILE  = 0x000F,
00117             MS_REVIEW_COL____LAST___        = 0x0010
00118         };
00119
00121
00124         enum PERC_EXE_RT {
00125             PERC_EXE_RT_USE_DEFAULT = 1,
00126             PERC_EXE_RT_FORCE_ON    = 2,
00127             PERC_EXE_RT_FORCE_OFF   = 3
00128         };
00129
00131
00156         enum DECOY_ALGORITHM {
00157             DECOY_ALGORITHM_NONE        = 0,
00158             DECOY_PROTEIN_REVERSE       = 1,
00159             DECOY_PEPTIDE_REVERSE       = 2,
00160             DECOY_PROTEIN_RANDOM        = 3,
00161             DECOY_PEPTIDE_RANDOM        = 4,
00162             DECOY_PROTEIN_RANDOM_DIPEP  = 5,
00163             DECOY_PEPTIDE_RANDOM_DIPEP  = 6,
00164             DECOY_PROTEIN_SHUFFLE       = 7,
00165             DECOY_PEPTIDE_SHUFFLE       = 8,
00166
00167             DECOY_PROTEIN_BASED_MASK    = 0x0001
00168         };
00169
00170
00172
00175         enum EXEC_AFTER_SEARCH
00176         {
00177             MAX_EXEC_AFTER_SEARCH = 10
00178         };
00179
00180         enum REPORTBUILDER_COL_ARR
00181         {
00182             MAX_REPORTBUILDER_COL_ARR = 10
00183         };
00184
00186         enum NUMERICAL_VALUE_STORAGE
00187         {
00188             MASS_DECIMAL_PLACES = 6
00189         };
00190
00192         ms_mascotoptions();
00193
00195         ms_mascotoptions(const ms_mascotoptions& src);
00196
00198         ~ms_mascotoptions();
00199
00201         void copyFrom(const ms_mascotoptions* right);
00202
00203 #ifndef SWIG
00204
00205         ms_mascotoptions& operator=(const ms_mascotoptions& right);
00206 #endif
00207
00208         void defaultValues();
00209
00211         bool isSectionAvailable() const;
00212
00214         void setSectionAvailable(const bool value);
00215
00217         bool isSaveLastQueryAsc() const;
00218
00220         void setSaveLastQueryAsc(const bool flag);
00221
00223         bool isSaveEveryLastQueryAsc() const;
00224
00226         void setSaveEveryLastQueryAsc(const bool flag);
00227
00229         std::string getLastQueryAscFile() const;
00230
00232         void setLastQueryAscFile(const char* str);
00233
00235         std::string getErrorLogFile() const;
00236
00238         void setErrorLogFile(const char* str);
00239
00241         std::string getSearchLogFile() const;
00242
00244         void setSearchLogFile(const char* str);
00245
00247         std::string getMonitorLogFile() const;
00248
00250         void setMonitorLogFile(const char* str);
00251
00253         std::string getInterFileBasePath() const;
00254
00256         void setInterFileBasePath(const char* str);
00257
00259         std::string getInterFileRelPath() const;
00260
00262         void setInterFileRelPath(const char* str);
00263
00265         std::string getMascotCmdLine() const;
00266
00268         void setMascotCmdLine(const char* str);
00269
00271         std::string getTestDirectory() const;
00272
00274         void setTestDirectory(const char* str);
00275
00277         std::string getMascotControlFile() const;
00278
00280         void setMascotControlFile(const char* str);
00281
00283         std::string getMascNodeCtrlFile() const;
00284
00286         void setMascNodeCtrlFile(const char* str);
00287
00289         std::string getMascotJobIdFile() const;
00290
00292         void setMascotJobIdFile(const char* str);
00293
00295         std::string getGetSeqJobIdFile() const;
00296
00298         void setGetSeqJobIdFile(const char* str);
00299
00301         int getUniqueJobStartNumber() const;
00302
00304         void setUniqueJobStartNumber(const int value);
00305
00307         std::string getResultsPerlScript() const;
00308
00310         void setResultsPerlScript(const char* str);
00311
00313         std::string getNoResultsScript() const;
00314
00316         void setNoResultsScript(const char* str);
00317
00319         std::string getResultsFullURL() const;
00320
00322         void setResultsFullURL(const char* str);
00323
00325         std::string getLogoImageFile() const;
00326
00328         void setLogoImageFile(const char* str);
00329
00331         int getMassDecimalPlaces() const;
00332
00334         void setMassDecimalPlaces(const int value);
00335
00337         int getIonsDecimalPlaces() const;
00338
00340         void setIonsDecimalPlaces(const int value);
00341
00343         int getIntensitySigFigs() const;
00344
00346         void setIntensitySigFigs(const int value);
00347
00349         bool isEmailUsersEnabled() const;
00350
00352         void setEmailUsersEnabled(const bool value);
00353
00355         bool isEmailErrorsEnabled() const;
00356
00358         void setEmailErrorsEnabled(const bool value);
00359
00361         int getMailTransport() const;
00362
00364         void setMailTransport(const int value);
00365
00367         std::string getEmailService() const;
00368
00370         void setEmailService(const char* str);
00371
00373         std::string getEmailPassword() const;
00374
00376         void setEmailPassword(const char* str);
00377
00379         std::string getEmailProfile() const;
00380
00382         void setEmailProfile(const char* str);
00383
00385         std::string getSendmailPath() const;
00386
00388         void setSendmailPath(const char* str);
00389
00391         std::string getEmailFromUser() const;
00392
00394         void setEmailFromUser(const char* str);
00395
00397         std::string getEmailFromTextName() const;
00398
00400         void setEmailFromTextName(const char* str);
00401
00403         int getEmailTimeOutPeriod() const;
00404
00406         void setEmailTimeOutPeriod(const int value);
00407
00409         int getMonitorEmailCheckFreq() const;
00410
00412         void setMonitorEmailCheckFreq(const int value);
00413
00415         std::string getMailTempFile() const;
00416
00418         void setMailTempFile(const char* str);
00419
00421         std::string getErrMessageEmailTo() const;
00422
00424         void setErrMessageEmailTo(const char* str);
00425
00427         int getMonitorTestTimeout() const;
00428
00430         void setMonitorTestTimeout(const int value);
00431
00433         std::string getNTMonitorGroup() const;
00434
00436         void setNTMonitorGroup(const char* str);
00437
00439         std::string getNTIUserGroup() const;
00440
00442         void setNTIUserGroup(const char* str);
00443
00445         int getUnixWebUserGroup() const;
00446
00448         void setUnixWebUserGroup(const int value);
00449
00451         bool isForkForUnixApache() const;
00452
00454         void setForkForUnixApache(const bool value);
00455
00457         int getSeparateLockMem() const;
00458
00460         void setSeparateLockMem(const int value);
00461
00463         std::string getFormVersion() const;
00464
00466         void setFormVersion(const char* str);
00467
00469         int getMaxSequenceLen() const;
00470
00472         void setMaxSequenceLen(const int value);
00473
00475         int getMaxConcurrentSearches() const;
00476
00478         void setMaxConcurrentSearches(const int value);
00479
00481         int getMaxSearchesPerUser() const;
00482
00484         void setMaxSearchesPerUser(const int value);
00485
00487         double getCentroidWidth() const;
00488
00490         void setCentroidWidth(const double value);
00491
00493         int getCentroidWidthCount() const;
00494
00496         void setCentroidWidthCount(const int value);
00497
00499         int getMaxDescriptionLen() const;
00500
00502         void setMaxDescriptionLen(const int value);
00503
00505         int getMaxNumPeptides() const;
00506
00508         void setMaxNumPeptides(const int value);
00509
00511         INT64 getVmemory() const;
00512
00514         void setVmemory(const INT64 value);
00515
00517         int getNumberOfReportNumberChoices() const;
00518
00520         void clearReportNumberChoices();
00521
00523         int getReportNumberChoice(const int index) const;
00524
00526         void setReportNumberChoice(const int index, const int value);
00527
00529         void appendReportNumberChoice(const int value);
00530
00532         int getNumberOfTargetFDRPercentages() const;
00533
00535         void clearTargetFDRPercentages();
00536
00538         double getTargetFDRPercentage(const int index) const;
00539
00541         void setTargetFDRPercentage(const int index, const double value, const bool makeDefault = false);
00542
00544         void appendTargetFDRPercentage(const double value, const bool makeDefault = false);
00545
00547         bool isDefaultTargetFDRPercentage(const int index) const;
00548
00550         void setDefaultTargetFDRPercentage(const int index);
00551
00553         int getReviewColWidth(const MS_REVIEW_COL index) const;
00554
00556         void setReviewColWidth(const MS_REVIEW_COL index, const int value);
00557
00559         bool getReviewColDisplay(const MS_REVIEW_COL index) const;
00560
00562         void setReviewColDisplay(const MS_REVIEW_COL index, const bool value);
00563
00565         std::string getReportBuilderColumnArrangement(const int index) const;
00566
00568         int getMaxNumOfReportBuilderColumnArrangements() const;
00569
00571         void setReportBuilderColumnArrangement(const int index, const std::string str);
00572
00574         std::string getSpectrumViewerColourSchemeString(const std::string &name) const;
00575
00577         std::vector<std::string> getSpectrumViewerColourSchemeNames() const;
00578
00580         void setSpectrumViewerColourSchemeString(const std::string &name, const std::string &str, bool doCheck = true);
00581
00583         std::string getSpectrumViewerDefaultColourSchemeName() const;
00584
00586         void setSpectrumViewerDefaultColourSchemeName(const std::string &name);
00587
00589         std::string getProxyType() const;
00590
00592         void setProxyType(const std::string &value);
00593
00595         bool isUseHTTPProxyForFTP() const;
00596
00598         void setUseHTTPProxyForFTP(const bool value);
00599
00601         bool isUseHTTPProxyForHTTPS() const;
00602
00604         void setUseHTTPProxyForHTTPS(const bool value);
00605
00607         std::string getProxyServer() const;
00608
00610         void setProxyServer(const char* str);
00611
00613         std::string getProxyUsername() const;
00614
00616         void setProxyUsername(const char* str);
00617
00619         std::string getProxyPassword() const;
00620
00622         void setProxyPassword(const char* str);
00623
00625         int getMinPepLenInPepSummary() const;
00626
00628         void setMinPepLenInPepSummary(const int value);
00629
00631         int getMaxQueries() const;
00632
00634         void setMaxQueries(const int value);
00635
00637         bool isShowSubsets() const;
00638
00640         void setShowSubsets(const bool value);
00641
00643         double getShowSubsets() const;
00644
00646         void setShowSubsets(const double value);
00647
00649         bool isRequireBoldRed() const;
00650
00652         void setRequireBoldRed(const bool value);
00653
00655         double getSigThreshold() const;
00656
00658         void setSigThreshold(const double value);
00659
00661         double getSiteAnalysisMD10Prob() const;
00662
00664         void setSiteAnalysisMD10Prob(const double value);
00665
00667         int getMaxVarMods() const;
00668
00670         void setMaxVarMods(const int value);
00671
00673         int getMaxEtVarMods() const;
00674
00676         void setMaxEtVarMods(const int value);
00677
00679         int getErrTolMaxAccessions() const;
00680
00682         void setErrTolMaxAccessions(const int value);
00683
00685         bool isLabelAll() const;
00686
00688         void setLabelAll(const bool value);
00689
00691         bool isShowAllFromErrorTolerant() const;
00692
00694         void setShowAllFromErrorTolerant(const bool value);
00695
00697         double getIgnoreIonsScoreBelow() const;
00698
00700         void setIgnoreIonsScoreBelow(const double value);
00701
00703         std::string getMonitorPidFile() const;
00704
00706         void setMonitorPidFile(const char* str);
00707
00709         bool isStoreModPermutations() const;
00710
00712         void setStoreModPermutations(const bool value);
00713
00715         int getProteinsInResultsFile() const;
00716
00718         void setProteinsInResultsFile(const int value);
00719
00721         std::string getMascotMessage() const;
00722
00724         void setMascotMessage(const char* str);
00725
00727         int getSplitNumberOfQueries() const;
00728
00730         void setSplitNumberOfQueries(const int value);
00731
00733         int getSplitDataFileSize() const;
00734
00736         void setSplitDataFileSize(const int value);
00737
00739         bool isMoveOldDbToOldDir() const;
00740
00742         void setMoveOldDbToOldDir(const bool value);
00743
00745         bool isRemoveOldIndexFiles() const;
00746
00748         void setRemoveOldIndexFiles(const bool value);
00749
00751         int getFeatureTableLength() const;
00752
00754         void setFeatureTableLength(const int value);
00755
00757         double getFeatureTableMinScore() const;
00758
00760         void setFeatureTableMinScore(const double value);
00761
00763         std::string getICATLight() const;
00764
00766         void setICATLight(const char* modName);
00767
00769         std::string getICATHeavy() const;
00770
00772         void setICATHeavy(const char* modName);
00773
00775         std::string getICATFilter() const;
00776
00778         void setICATFilter(const char* filterString);
00779
00781         std::string getICATQuantitationMethod() const;
00782
00784         void setICATQuantitationMethod(const char* methodName);
00785
00787         unsigned int getNumberOfIgnoreDupeAccessions() const;
00788
00790         void clearIgnoreDupeAccessions();
00791
00793         std::string getIgnoreDupeAccession(const unsigned int index) const;
00794
00796         void setIgnoreDupeAccession(const unsigned int index, const std::string value);
00797
00799         void appendIgnoreDupeAccession(const std::string value);
00800
00802         bool isInIgnoreDupeAccessionList(const std::string value) const;
00803
00805         int getUnixDirPerm() const;
00806
00808         void setUnixDirPerm(const int value);
00809
00811         bool isUnixDirPermDefined() const;
00812
00814         int getMudpit() const;
00815
00817         void setMudpit(const int value);
00818
00820         double getPrecursorCutOutLowerLimit() const;
00821
00823         void setPrecursorCutOutLowerLimit(const double value);
00824
00826         double getPrecursorCutOutUpperLimit() const;
00827
00829         void setPrecursorCutOutUpperLimit(const double value);
00830
00832         bool isAutoSelectCharge() const;
00833
00835         void setAutoSelectCharge(const bool value);
00836
00838         std::string getTaxBrowserUrl() const;
00839
00841         void setTaxBrowserUrl(const std::string value);
00842
00844         int getMinPepLenInSearch() const;
00845
00847         void setMinPepLenInSearch(const int value);
00848
00850         int getMaxPepModArrangements() const;
00851
00853         void setMaxPepModArrangements(const int value);
00854
00856         int getMaxPepNumVarMods() const;
00857
00859         void setMaxPepNumVarMods(const int value);
00860
00862         int getMaxPepNumModifiedSites() const;
00863
00865         void setMaxPepNumModifiedSites(const int value);
00866
00868         bool isIteratePMFIntensities() const;
00869
00871         void setIteratePMFIntensities(const bool value);
00872
00874         double getMinEtagMassDelta() const;
00875
00877         void setMinEtagMassDelta(const double value);
00878
00880         double getMaxEtagMassDelta() const;
00881
00883         void setMaxEtagMassDelta(const double value);
00884
00886         std::string getResultsFileFormatVersion() const;
00887
00889         void setResultsFileFormatVersion(const char *value);
00890
00892         std::string getSortUnassigned() const;
00893
00895         void setSortUnassigned(const std::string newValue);
00896
00898         int getSelectSwitch() const;
00899
00901         void setSelectSwitch(const int value);
00902
00904         double getMudpitSwitch() const;
00905
00907         void setMudpitSwitch(const double value);
00908
00910         int getMaxDatabases() const;
00911
00913         void setMaxDatabases(const int value);
00914
00916         std::string getCacheDirectory() const;
00917
00919         void setCacheDirectory(const char * value);
00920
00922         std::string getResfileCache() const;
00923
00925         void setResfileCache(const char * value);
00926
00928         std::string getResultsCache() const;
00929
00931         void setResultsCache(const char * value);
00932
00934         bool isPercolator() const;
00935
00937         void setPercolator(const bool value);
00938
00940         std::string getPercolatorFeatures() const;
00941
00943         void setPercolatorFeatures(std::string value);
00944
00946         int getPercolatorMinQueries() const;
00947
00949         void setPercolatorMinQueries(const int value);
00950
00952         int getPercolatorMinSequences() const;
00953
00955         void setPercolatorMinSequences(const int value);
00956
00958         bool isPercolatorUseProteins() const;
00959
00961         void setPercolatorUseProteins(const bool value);
00962
00964         bool isPercolatorUseRT() const;
00965
00967         void setPercolatorUseRT(const bool value);
00968
00970         std::string getPercolatorExeFlags(bool anyRetentionTimes,
00971                                           const std::vector<std::string> percolatorFiles,
00972                                           const PERC_EXE_RT rt = PERC_EXE_RT_USE_DEFAULT) const;
00973
00975         void setPercolatorExeFlags(const char * value);
00976
00978         int getPercolatorTargetRankScoreThreshold() const;
00979
00981         void setPercolatorTargetRankScoreThreshold(const int threshold);
00982
00984         double getPercolatorTargetRankRelativeThreshold() const;
00985
00987         void setPercolatorTargetRankRelativeThreshold(const double threshold);
00988
00990         int getCreatePipThreads() const;
00991
00993         void setCreatePipThreads(const int nThreads);
00994
00996         int getCreatePipThreadBlockSize() const;
00997
00999         void setCreatePipThreadBlockSize(const int blockSize);
01000
01002         int getExecAfterSearch(const char               * szResultsFilePath,
01003                                std::vector<std::string> & commands,
01004                                std::vector<std::string> & titles,
01005                                std::vector<int>         & waitfor,
01006                                std::vector<int>         & logging,
01007                                std::vector<std::string> & additionalFlags,
01008                                const char               * sessionID = 0,
01009                                const char               * taskID = 0) const;
01010
01012         void setExecAfterSearch(const int num, std::string value);
01013
01015         std::string getResultsPerlScript_2() const;
01016
01018         void setResultsPerlScript_2(std::string value);
01019
01021         std::string getResultsFullURL_2() const;
01022
01024         void setResultsFullURL_2(std::string value);
01025
01027         int getProteinFamilySwitch() const;
01028
01030         void setProteinFamilySwitch(const int value);
01031
01033         int getDecoyTypeSpecific() const;
01034
01036         void setDecoyTypeSpecific(const int value);
01037
01039         int getDecoyTypeNoEnzyme() const;
01040
01042         void setDecoyTypeNoEnzyme(const int value);
01043
01045         int getSVGSpectrumSwitch() const;
01046
01048         void setSVGSpectrumSwitch(const int value);
01049
01051         int getDisplayNonSignificantMatches() const;
01052
01054         void setDisplayNonSignificantMatches(const int value);
01055
01057         std::string getCompressToolAA() const;
01058
01060         void setCompressToolAA(const std::string value);
01061
01063         std::string getCompressToolNA() const;
01064
01066         void setCompressToolNA(const std::string value);
01067
01069         std::string getCompressToolSL() const;
01070
01072         void setCompressToolSL(const std::string value);
01073
01075         std::string getCompressToolCommandLineFasta(DATABASE_TYPE dbType,
01076                                                const std::string & dbname,
01077                                                const std::string & dbpath) const;
01078
01080         std::string getCompressToolCommandLineLibrary(const std::string & logfilepath,
01081                                                       const std::string & inputfile,
01082                                                       const std::string & outputdirectory) const;
01083
01085         std::string getPepSearchTool() const;
01086
01088         void setPepSearchTool(const std::string value);
01089
01091         std::string getPepSearchToolCommandLine(const std::string & peptideToleranceUnit,
01092                                                 const double      & peptideTolerance,
01093                                                 const std::string & ionToleranceUnit,
01094                                                 const double      & ionTolerance,
01095                                                 const std::string & libraryDirectoryPath,
01096                                                 const std::string & inputFileRelativePath,
01097                                                 const std::string & outputFileRelativePath) const;
01098
01100         int getSpectraPerLibraryBlock() const;
01101
01103         void setSpectraPerLibraryBlock(const int value);
01104
01106         int getCrawlerNumPeaksPer100Da() const;
01107
01109         void setCrawlerNumPeaksPer100Da(const int value);
01110
01112         std::string getSearchSubmitMode() const;
01113
01115         void setSearchSubmitMode(const std::string value);
01116
01118         int getDechargeFragmentPeaks() const;
01119
01121         void setDechargeFragmentPeaks(const int maxCharge);
01122
01124
01126         const ms_blastaccession* getGetSeqBlastAccession() const;
01127
01129         void setGetSeqBlastAccession(const ms_blastaccession* value);
01130
01131         // MatrixScience internal usage only
01132         int getMinPeakIteration() const;
01133
01134         // MatrixScience internal usage only
01135         void setMinPeakIteration(const int value);
01136
01137         // MatrixScience internal usage only
01138         bool isEncryptURL() const;
01139
01140         // MatrixScience internal usage only
01141         void setEncryptURL(const bool value);
01142
01143         // MatrixScience internal usage only
01144         std::string getPercolatorExeFlags() const;
01145
01146         // MatrixScience internal usage only
01147         std::string getPercolatorRtFlags(const bool anyRetentionTimes, const bool useRT) const;
01148
01149         // MatrixScience internal usage only
01150         std::string getExecAfterSearch(const int num) const;
01151
01152         // MatrixScience internal usage only
01153         void checkExecAfterSearch(ms_errs & err);
01154
01155         // MatrixScience internal usage only
01156         void checkReportBuilderColumnArrangement(ms_errs & err);
01157
01158         // MatrixScience internal usage only
01159         void checkSpectrumViewerColourSchemes(ms_errs & err, bool addToList = true);
01160
01162         bool isMatchOppositeCrosslinkPairs() const;
01163
01165         void setMatchOppositeCrosslinkPairs(const bool value);
01166
01168         int getMaxIntactCrosslinkPeptides() const;
01169
01171         void setMaxIntactCrosslinkPeptides(const int value);
01172
01174         bool isTransferParsingToNodes() const;
01175
01177         void setTransferParsingToNodes(const bool value);
01178
01180         int getMascotFileProcessingThreads() const;
01181
01183         void setMascotFileProcessingThreads(const int value);
01184
01186         int getInputFileParsingThreads() const;
01187
01189         void setInputFileParsingThreads(const int value);
01190
01192         int getChunkReadingThreads() const;
01193
01195         void setChunkReadingThreads(const int value);
01196
01198         int getChunkPreparationThreads() const;
01199
01201         void setChunkPreparationThreads(const int value);
01202
01203 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
01204 #include "suppress_ms_customproperty.hpp"
01205 #endif
01206
01207     private:
01208         void        synchronizeReportNumberChoices_();
01209         void        synchronizeIgnoreDupeAccession_();
01210         void        synchronizeTargetFDRPercentages_();
01211
01212         bool        sectionAvailable_;
01213
01214         bool        saveLastQueryAsc_;
01215         bool        saveEveryLastQueryAsc_;
01216         std::string lastQueryAscFile_;
01217
01218         std::string errorLogFile_;
01219         std::string searchLogFile_;
01220         std::string monitorLogFile_;
01221         std::string interFileBasePath_;
01222         std::string interFileRelPath_;
01223
01224         std::string mascotCmdLine_;
01225         std::string testDirectory_;
01226         std::string mascotControlFile_;
01227         std::string mascNodeCtrlFile_;
01228         std::string mascotJobIdFile_;
01229         std::string getSeqJobIdFile_;
01230         int         uniqueJobStartNumber_;
01231
01232         std::string resultsPerlScript_;
01233         std::string noResultsScript_;
01234         std::string resultsFullURL_;
01235         std::string logoImageFile_;
01236
01237         int         massDecimalPlaces_;
01238         int         ionsDecimalPlaces_;
01239         int         intensitySigFigs_;
01240
01241         bool        emailUsersEnabled_;
01242         bool        emailErrorsEnabled_;
01243         int         mailTransport_;
01244         std::string emailService_;
01245         std::string emailPassword_;
01246         std::string emailProfile_;
01247         std::string sendmailPath_;
01248         std::string emailFromUser_;
01249         std::string emailFromTextName_;
01250         int         emailTimeOutPeriod_;
01251         int         monitorEmailCheckFreq_;
01252         std::string mailTempFile_;
01253         std::string errMessageEmailTo_;
01254
01255         int         monitorTestTimeout_;
01256         std::string NTMonitorGroup_;
01257         std::string NTIUserGroup_;
01258         int         unixWebUserGroup_;
01259         bool        forkForUnixApache_;
01260         int         separateLockMem_;
01261
01262         std::string formVersion_;
01263         int         maxSequenceLen_;
01264         int         maxConcurrentSearches_;
01265         int         maxSearchesPerUser_;
01266         double      centroidWidth_;
01267         int         centroidWidthCount_;
01268         int         maxDescriptionLen_;
01269         int         maxNumPeptides_;
01270         INT64       vmemory_;
01271
01272         std::vector< int > reportNumberChoices_;
01273         std::vector< double > targetFDRPercentages_;
01274         int         defaultTargetFDRPercentagesIx_;
01275
01276         int         reviewColWidths_[MS_REVIEW_COL____LAST___];
01277         bool        reviewColDisplay_[MS_REVIEW_COL____LAST___];
01278         std::vector<std::string> reportBuilderColArr_;
01279
01280         std::string defaultColourSchemeName_;
01281         std::vector<std::string> colourSchemeNames_;
01282         std::vector<std::string> colourSchemeStrings_;
01283
01284         std::string proxyType_;
01285         bool        useHTTPProxyForFTP_;
01286         bool        useHTTPProxyForHTTPS_;
01287         std::string proxy_server_;
01288         std::string proxy_username_;
01289         std::string proxy_password_;
01290
01291         int         maxVarMods_;
01292         int         maxEtVarMods_;
01293         int         errTolMaxAccessions_;
01294         bool        labelAll_;
01295         bool        showAllFromErrorTolerant_;
01296
01297         int         minPepLenInPepSummary_;
01298         int         maxPepModArrangements_;
01299         int         maxPepNumVarMods_;
01300         int         maxPepNumModifiedSites_;
01301         int         maxQueries_;
01302         double      showSubsets_;
01303         bool        requireBoldRed_;
01304         double      sigThreshold_;
01305         double      siteAnalysisMD10Prob_;
01306         double      ignoreIonsScoreBelow_;
01307
01308         std::string monitorPidFile_;
01309         bool        storeModPermutations_;
01310         int         proteinsInResultsFile_;
01311         std::string mascotMessage_;
01312         int         splitNumberOfQueries_;
01313         int         splitDataFileSize_;
01314         bool        moveOldDbToOldDir_;
01315         bool        removeOldIndexFiles_;
01316
01317         int         featureTableLength_;
01318         double      featureTableMinScore_;
01319
01320         std::string ICATLight_;
01321         std::string ICATHeavy_;
01322         std::string ICATFilter_;
01323         std::string ICATQuantitationMethod_;
01324
01325         int         UnixDirPerm_;
01326         bool        UnixDirPermDefined_;
01327         int         mudpit_;
01328
01329         typedef std::vector<std::string> t_dupeAccs;
01330         t_dupeAccs ignoreDupeAccessions_;
01331
01332         double      precursorCutOutLowerLimit_;
01333         double      precursorCutOutUpperLimit_;
01334
01335         bool        autoSelectCharge_;
01336         std::string taxBrowserUrl_;
01337         int         minPepLenInSearch_;
01338         bool        iteratePMFIntensities_;
01339
01340         double      minEtagMassDelta_;
01341         double      maxEtagMassDelta_;
01342
01343         std::string resultsFileFormatVersion_;
01344         std::string sortUnassigned_;
01345         int         selectSwitch_;
01346         double      mudpitSwitch_;
01347
01348         int         maxDatabases_;
01349         std::string cacheDirectory_;
01350
01351         std::string resfileCache_;
01352         std::string resultsCache_;
01353
01354         bool        percolator_;
01355         std::string percolatorFeatures_;
01356         int         percolatorMinQueries_;
01357         int         percolatorMinSequences_;
01358         bool        percolatorUseProteins_;
01359         bool        percolatorUseRT_;
01360         std::string percolatorExeFlags_;
01361         int percolatorTargetRankScoreThreshold_;
01362         double percolatorTargetRankRelativeThreshold_;
01363
01364         int createPipThreads_;
01365         int createPipThreadBlockSize_;
01366
01367         std::vector<std::string> execAfterSearch_;
01368         std::vector<std::string> execAfterSearchCommands_;
01369         std::vector<std::string> execAfterSearchTitles_;
01370         std::vector<int>         execAfterSearchWaitFor_;
01371         std::vector<int>         execAfterSearchLogging_;
01372         std::vector<std::string> execAfterSearchAdditionalFlags_;
01373         std::string resultsPerlScript_2_;
01374         std::string resultsFullURL_2_;
01375         int         proteinFamilySwitch_;
01376
01377         int         decoyTypeSpecific_;
01378         int         decoyTypeNoEnzyme_;
01379
01380         int         svgSpectrumSwitch_;
01381         int         displayNonSigMatches_;
01382
01383         ms_blastaccession   getSeqBlastAccession_;
01384         int         minPeakIteration_;
01385         bool        encryptURL_;
01386
01387         std::string compressToolAA_;
01388         std::string compressToolNA_;
01389         std::string compressToolSL_;
01390         std::string pepSearchTool_;
01391         int         spectraPerLibraryBlock_;
01392         int         crawlerNumPeaksPer100Da_;
01393         bool        matchOppositeCrosslinkPairs_;
01394         int         maxIntactCrosslinkPeptides_;
01395         std::string searchSubmitMode_;
01396         int         dechargeFragmentPeaks_;
01397         bool        transferParsingToNodes_; //internal Mascot debug option
01398         int         mascotFileProcessingThreads_;
01399         int         inputFileParsingThreads_; //internal Mascot debug option
01400         int         chunkReadingThreads_; //internal Mascot debug option
01401         int         chunkPreparationThreads_; //internal Mascot debug option
01402     }; // class ms_mascotoptions // end of config_group
01404 } // namespace matrix_science
01405
01406 #endif // MS_MASCOTOPTIONS_HPP
01407
01408 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotresfile.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a  mascot results file                                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2002 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2021-07-08 14:45:37 +0100 $ #
00014 #   $Revision: 1c420cd7e2bac7ee9d3dec2956a84cc96c80d860 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTRESFILE_HPP
00020 #define MS_MASCOTRESFILE_HPP
00021
00022
00023
00024 // Includes from the standard template library
00025 #include <stdarg.h>
00026 #include <time.h>
00027 #include <string>
00028 #include <list>
00029 #include <vector>
00030 #include <set>
00031
00032 namespace msparser_internal {
00033     class ms_cdb;
00034     class ms_peptidesumcdb;
00035 }
00036
00037 namespace matrix_science {
00038     class ms_searchparams;
00039     class ms_umod_configfile;
00040     class ms_masses;
00041     class ms_enzymefile;
00042     class ms_taxonomyfile;
00043     class ms_mascotresults_params;
00044
00050 #ifndef SWIG
00051     class multiBuf {
00052     public:
00053         multiBuf()  {pMem_ = 0; len_ = 0; pEnd_ = 0;}
00054     public :
00055         char *pMem_;  // pointer to first block of memory
00056         int  len_;    // excluding any null terminator
00057         char *pEnd_;  // Pointer to last byte (not the null terminator)
00058     private:
00059     };
00060     typedef std::vector<multiBuf> multiBuf_v;
00061
00062     class multiBufMemPtr {
00063     public:
00064         enum MBMP { MBMP_INVALID = -1, MBMP_USING_CDB = -2 };
00065         multiBufMemPtr(int bufNum, char *pMem)
00066             : bufNum_(bufNum), pMem_(pMem) {};
00067         multiBufMemPtr() : bufNum_(MBMP_INVALID), pMem_(0) {};
00068         void decrement(const multiBuf_v & buffers);
00069         void decrementUntil(const multiBuf_v & buffers, const char * chars);
00070         void increment(const multiBuf_v & buffers);
00071         bool isValid() const {return bufNum_ != MBMP_INVALID;}
00072         bool operator<(const multiBufMemPtr & rhs);
00073         bool operator<=(const multiBufMemPtr & rhs);
00074
00075     public:
00076         int    bufNum_;
00077         char * pMem_;
00078     };
00079
00080     // ms_sortByKeyCriterion class is used internally in the library
00081     // to give fast access to the keys. Don't use it from outside the DLL
00082     class ms_sortByKeyCriterion
00083     {
00084         public:
00085             enum CMP_MODE {CASE_INSENSITIVE=0x01, CASE_SENSITIVE=0x02, QUOTED=0x04};
00086             ms_sortByKeyCriterion(int m=(int)CASE_INSENSITIVE) : mode_(m) {}
00087             bool operator() (const char * p1, const char * p2) const;
00088
00089         private:
00090             int mode_;
00091             // Unfortunately, when called from Perl in Windows,
00092             // the toupper function ends up calling extra functions
00093             // to convert to wide char and back again. We don't
00094             // want language independent conversion here - the
00095             // key names are all single byte.
00096             inline char my_toupper(char ch) const
00097             {
00098                 if ((mode_ & CASE_INSENSITIVE) && ch >= 'a' && ch <= 'z')
00099                     return static_cast<char>('A' + (ch-'a'));
00100                 else
00101                     return ch;
00102             }
00103
00104     };
00105 #endif
00106
00108
00113     class MS_MASCOTRESFILE_API ms_mascotresfile : public ms_errors
00114     {
00115         friend class msparser_internal::ms_peptidesumcdb;
00116         public:
00118
00121             // Developer note: Add new sections to this enum just before
00122             // SEC_INDEX, so that existing values are not changed.
00123             enum section
00124             {
00125                 SEC_PARAMETERS,
00126                 SEC_HEADER,
00127                 SEC_MASSES,
00128                 SEC_SUMMARY,
00129                 SEC_MIXTURE,
00130                 SEC_PEPTIDES,
00131                 SEC_PROTEINS,
00132                 SEC_QUERY1,
00133                 SEC_QUANTITATION,
00134                 SEC_UNIMOD,
00135                 SEC_ENZYME,
00136                 SEC_TAXONOMY,
00137                 SEC_DECOYSUMMARY,
00138                 SEC_DECOYMIXTURE,
00139                 SEC_DECOYPEPTIDES,
00140                 SEC_DECOYPROTEINS,
00141                 SEC_ERRTOLSUMMARY,
00142                 SEC_ERRTOLPEPTIDES,
00143                 SEC_SPECTRAL_LIBRARY,
00144                 SEC_LIBRARYPEPTIDES,
00145                 SEC_LIBRARYSUMMARY,
00146                 SEC_CROSSLINK_SUMMARY,
00147                 SEC_CROSSLINK_PEPTIDES,
00148                 SEC_CROSSLINKING,
00149                 SEC_UNIMOD_XL,
00150                 SEC_ERRTOLDECOYSUMMARY,
00151                 SEC_ERRTOLDECOYPEPTIDES,
00152                 SEC_INDEX,
00153                 SEC_NUMSECTIONS
00154             };
00155
00157             static const char *getSectionName(const section sec);
00158
00160
00167             enum err
00168             {
00169                 ERR_NO_ERROR                        = 0x0000,
00170                 ERR_NOMEM                           = 0x0001,
00171                 ERR_NOSUCHFILE                      = 0x0002,
00172                 ERR_READINGFILE                     = 0x0003,
00173                 ERR_QUERYOUTOFRANGE                 = 0x0004,
00174                 ERR_MISSINGENTRY                    = 0x0005,
00175                 ERR_PEPSUMMPEPGET                   = 0x0006,
00176                 ERR_PEPTIDESTR                      = 0x0007,
00177                 ERR_ACCINPEPTIDESTR                 = 0x0008,
00178                 ERR_PROTSUMM                        = 0x0009,
00179                 ERR_PROTSUMMPEP                     = 0x000A,
00180                 ERR_ADDPEPTIDES                     = 0x000B,
00181                 ERR_MISSINGHIT                      = 0x000C,
00182                 ERR_MISSINGSECTION                  = 0x000D,
00183                 ERR_MISSINGSECTIONEND               = 0x000E,
00184                 ERR_MALFORMED_ERR_TOL               = 0x000F,
00185                 ERR_NO_ERR_TOL_PARENT               = 0x0010,
00186                 ERR_NULL_ACC_PEP_SUM                = 0x0011,
00187                 ERR_NULL_ACC_PROT_SUM               = 0x0012,
00188                 ERR_DUPE_ACCESSION                  = 0x0013,
00189                 ERR_UNASSIGNED_PROG                 = 0x0014,
00190                 ERR_UNASSIGNED_RANGE                = 0x0015,
00191                 ERR_UNASSIGNED_UNK                  = 0x0016,
00192                 ERR_NO_UNIGENE_FILE                 = 0x0017,
00193                 ERR_DUPLICATE_KEY                   = 0x0018,
00194                 ERR_OLDRESULTSFILE                  = 0x0019,
00195                 ERR_MALFORMED_TAG                   = 0x001A,
00196                 ERR_MALFORMED_DRANGE                = 0x001B,
00197                 ERR_INVALID_NUMQUERIES              = 0x001C,
00198                 ERR_MALFORMED_TERMS                 = 0x001D,
00199                 ERR_INVALID_RESFILE                 = 0x001E,
00200                 ERR_INVALID_PROTDB                  = 0x001F,
00201                 ERR_UNIGENE_MULTIDB                 = 0x0020,
00202                 ERR_INVALID_CACHE_DIR               = 0x0021,
00203                 ERR_FAIL_OPEN_DAT_FILE              = 0x0022,
00204                 ERR_MISSING_CDB_FILE                = 0x0023,
00205                 ERR_FAIL_MK_CACHE_DIR               = 0x0024,
00206                 ERR_FAIL_MK_CDB_FILE                = 0x0025,
00207                 ERR_FAIL_CLOSE_FILE                 = 0x0026,
00208                 ERR_FAIL_CDB_INIT                   = 0x0027,
00209                 ERR_INVALID_CDB_FILE                = 0x0028,
00210                 ERR_WRITE_CDB_FILE                  = 0x0029,
00211                 ERR_CDB_TOO_LARGE                   = 0x002A,
00212                 ERR_NEED_64_BIT                     = 0x002B,
00213                 ERR_CDB_64_BIT_REMAKE               = 0x002C,
00214                 ERR_CDB_OLD_VER_RETRY               = 0x002D,
00215                 ERR_CDB_OLD_VER_NO_RETRY            = 0x002E,
00216                 ERR_CDB_INCOMPLETE_RETRY            = 0x002F,
00217                 ERR_CDB_INCOMPLETE_NO_RETRY         = 0x0030,
00218                 ERR_CDB_BEING_CREATED               = 0x0031,
00219                 ERR_CDB_FAIL_REMOVE                 = 0x0032,
00220                 ERR_CDB_FAIL_LOCK                   = 0x0033,
00221                 ERR_CDB_FAIL_UNLOCK                 = 0x0034,
00222                 ERR_CDB_SOURCE_CHANGE_RETRY         = 0x0035,
00223                 ERR_CDB_SOURCE_CHANGE_NO_RETRY      = 0x0036,
00224                 ERR_MISSING_PERCOLATOR_FILE         = 0x0037,
00225                 ERR_CANNOT_APPEND_RESFILE           = 0x0038,
00226                 ERR_CANNOT_APPEND_RESFILE_NO_FNAMES = 0x0039,
00227                 ERR_RESULTS_NOT_CREATED             = 0x003A,
00228                 ERR_LASTONE                         = 0x003B
00229             };
00230             // this list has to be included into ms_errors.hpp file too !!!
00231
00232
00234
00238             enum FLAGS
00239             {
00240
00241                 RESFILE_NOFLAG                 = 0x00000000,
00242                 RESFILE_USE_CACHE              = 0x00000001,
00243                 RESFILE_CACHE_IGNORE_ACC_DUPES = 0x00000002,
00244                 RESFILE_USE_PARENT_PARAMS           = 0x00000004,
00245                 RESFILE_CACHE_IGNORE_DATE_CHANGE    = 0x00000008
00246             };
00247
00249
00254             enum PERCOLATOR_FILE_NAMES
00255             {
00256                 PERCOLATOR_INPUT_FILE       = 0,
00257                 PERCOLATOR_OUTPUT_TARGET    = 1,
00258                 PERCOLATOR_OUTPUT_DECOY     = 2
00259             };
00260
00262
00267             enum KA_TASK
00268             {
00269                 KA_CREATEINDEX_CI    = 0,
00270                 KA_READFILE_RF       = 1,
00271                 KA_ASSIGNPROTEINS_AP = 2,
00272                 KA_GROUPPROTEINS_GP  = 3,
00273                 KA_UNASSIGNEDLIST_UL = 4,
00274                 KA_QUANTITATION      = 5,
00275                 KA_CREATECACHE_CC    = 6,
00276                 KA_THRESHFORFDR_FDR  = 7,
00277                 KA_LAST              = 8
00278             };
00279
00281
00283             enum XML_SCHEMA
00284             {
00285                 XML_SCHEMA_QUANTITATION = 0,
00286                 XML_SCHEMA_UNIMOD       = 1,
00287                 XML_SCHEMA_DIRECTORY    = 2,
00288                 XML_SCHEMA_CROSSLINKING = 3,
00289                 XML_SCHEMA_LAST         = 4
00290             };
00291
00293             ms_mascotresfile(const char * szFileName,
00294                              const int    keepAliveInterval = 0,
00295                              const char * keepAliveText = "<!-- %d seconds -->\n",
00296                              const unsigned int flags = RESFILE_NOFLAG,
00297                              const char * cacheDirectory = "../data/cache/%Y/%m",
00298                              const char * XMLschemaDirectory = 0,
00299                              ms_progress_info * progressMonitor = 0);
00300
00301             ~ms_mascotresfile();
00302
00303             // ------------------- Basic generic functions -------------------
00304
00306             std::string getMSParserVersion() const;
00307
00309             bool versionGreaterOrEqual(int major, int minor, int revision) const;
00310
00312             int appendResfile(const char * filename,
00313                               int flags=RESFILE_USE_PARENT_PARAMS,
00314                               const char * cacheDirectory = 0);  // returns 'id' of added file
00315
00317             const ms_mascotresfile * getResfile(int id) const;
00318
00320             int getNumberOfResfiles() const;
00321
00323             bool doesSectionExist(const section sec) const;
00324
00326             bool anyPeptideSummaryMatches(const section sec=SEC_PEPTIDES) const;
00327
00328             // When calling 'getSectionValue' from outside the dll, be careful
00329             // that enough space is 'reserved' in the string.
00330             // Return value is length of the actual string that it wanted to
00331             // to return, so if this is larger than maxLen, then you are
00332             // missing some of the string. Best to call getSectionValueStr
00334             int  getSectionValue(const section sec, const char * key, char * str, int maxLen) const;
00335
00337             int  getSectionValueInt(const section sec, const char * key) const;
00338
00340             double getSectionValueDouble(const section sec, const char * key) const;
00341
00343             std::string getSectionValueStr(const section sec, const char * key) const;
00344
00346             int  getQuerySectionValue(const int query, const char * key, char * str, int maxLen) const;
00347
00349             int  getQuerySectionValueInt(const int query, const char * key) const;
00350
00352             double getQuerySectionValueDouble(const int query, const char * key) const;
00353
00355             std::string getQuerySectionValueStr(const int query, const char * key) const;
00356
00358             int getJobNumber(const int resfileID = 1) const;
00359
00361             std::string enumerateSectionKeys(const section sec,
00362                                              const int num,
00363                                              int        * pPreviousNum    = 0,
00364                                              OFFSET64_T * pPreviousOffset = 0) const;
00365
00367             std::string enumerateQuerySectionKeys(const int query,
00368                                                   const int num,
00369                                                   int        * pPreviousNum    = 0,
00370                                                   OFFSET64_T * pPreviousOffset = 0) const;
00371
00372 #ifndef SWIG
00373             // Not used from the outside world...
00374             void setError(int error, ...);
00375             void vsetError(int error, va_list arg);
00376 #endif
00377
00379             int  getNumberOfErrors() const;
00380
00382             int  getErrorNumber(const int num = -1) const;
00383
00385             int  getLastError() const;
00386
00388             std::string getErrorString(const int num) const;
00389
00391             std::string getLastErrorString() const;
00392
00394             void resetKeepAlive(const int keepAliveInterval, const char * keepAliveText,
00395                                 const bool propagateToAppended = true, const bool resetStartTime = false);
00396
00397 #ifndef SWIG
00398
00399             bool getNextSubStr(const std::string & input,
00400                                std::string::size_type & idx,
00401                                std::string & output,
00402                                const char * separator = ",",
00403                                const bool removeQuotes = false) const;
00404 #endif
00405
00406             // ----------------- Specific results functions ------------------
00408             int    getNumQueries(const int resfileID = 0) const;
00409
00411             int    getNumHits(const section sec=SEC_SUMMARY) const;
00412
00414             int getNumSeqs(const int idx = 0) const;
00415
00417             int getNumSeqsAfterTax(const int idx = 0) const;
00418
00420             int getNumEtSeqsSearched(const int idx = 0) const;
00421
00423             int getNumLibraryEntries(const int idx = 0) const;
00424
00426             double getNumResidues(const int idx = 0) const;
00427
00429             bool isDatabaseTypeAvailable() const;
00431             DATABASE_TYPE getDatabaseType(const int idx) const;
00433             int getReferenceDatabaseNumberOfSL(const int idx) const;
00434
00436             std::vector<int> getSLDatabaseNumbersOfReference(const int idx) const;
00437
00439
00444             int    getExecTime()        const { return execTime_;             }
00445
00447
00453             int    getDate()            const { return searchDate_;           }
00454
00456
00463             std::string getMascotVer()  const { return version_;              }
00464
00466             std::string getFastaVer(int idx = 1) const;
00467
00469             std::string getFastaPath(int idx = 1) const;
00470
00472             std::string getUniqueTaskID() const;
00473
00475             ms_mascotoptions::DECOY_ALGORITHM getDecoyTypeForDB(const int idx = 1) const;
00476
00478             double getSLFragmentTolerance(int idx = 1) const;
00479
00481             std::string getSLFragmentToleranceUnit(int idx = 1) const;
00482
00484             bool isPMF()            const;
00485
00487             bool isMSMS()           const;
00488
00490             bool isSQ()             const;
00491
00493             bool isErrorTolerant()  const;
00494
00496             bool anyPMF() const;
00497
00499             bool anyMSMS() const;
00500
00502             bool anySQ() const;
00503
00505             bool anyTag() const;
00506
00508             double getObservedMass(const int query) const;
00509
00511             int    getObservedCharge(const int query, const bool decoy=false) const;
00512
00514             double getObservedMrValue(const int query, const bool decoy=false) const;
00515
00517             double getObservedIntensity(const int query) const;
00518
00520             std::string getRepeatSearchString(const int query, const bool fullQuery = false) const;
00521
00523             std::string getFileName(const int id = 1) const;
00524
00526
00530             ms_searchparams & params() const { return *params_;              }
00531
00533             bool getQuantitation(ms_quant_configfile *qfile) const;
00534
00536             bool getQuantitationMethod(ms_quant_method *qmethod) const;
00537
00539             bool getCrosslinkingMethod(ms_crosslinking_method *method) const;
00540
00542             bool setXMLschemaFilePath(XML_SCHEMA XMLschema, const char * path);
00543
00545             std::string getXMLschemaFilePath(XML_SCHEMA XMLschema) const;
00546
00548             bool getUnimod(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const;
00549
00551             bool getUnimodXL(ms_umod_configfile *ufile, bool useSchemaFromResfile = false) const;
00552
00554             const ms_modification* getMonoLinkModification(const int modNum, const int monoLink) const;
00555
00557             bool getMasses(ms_masses  * masses) const;
00558
00560             bool getEnzyme(ms_enzymefile *efile, const char * enzymeFileName = 0) const;
00561
00563             bool getTaxonomy(ms_taxonomyfile *tfile) const;
00564
00566             bool outputKeepAlive() const;
00567
00568 #ifndef SWIG
00569
00570             void getKeepAlive(KA_TASK     & kaTask,
00571                               int         & kaPercentage,
00572                               std::string & kaAccession,
00573                               int         & kaHit,
00574                               int         & kaQuery,
00575                               std::string & kaText) const;
00576 #else // SWIG Multiple return values
00577             void getKeepAlive(KA_TASK     & OUTPUT,
00578                               int         & OUTPUT,
00579                               std::string & OUTPUT,
00580                               int         & OUTPUT,
00581                               int         & OUTPUT,
00582                               std::string & OUTPUT) const;
00583 #endif
00584             // \internal Internal use only
00585             bool outputKeepAlive(KA_TASK kaTask, int percentageComplete, const char * accession, int hit, int query) const;
00586
00588             ms_progress_info * getProgressInfo(bool forPeptideSummary = false) const;
00589
00591             std::string getCacheDirectory(bool processed = true) const;
00592
00594             std::string getCacheFileName() const;
00595
00596 #ifndef SWIG
00597
00598             static bool willCreateCache(const char * szFileName,
00599                                         const unsigned int flags,
00600                                         const char * cacheDirectory,
00601                                         std::string * cacheFileName);
00602             // Can't / don't want to allow std::string * as OUTPUT in Java and C#
00603             static bool willCreateCache(const char * szFileName,
00604                                         const unsigned int flags,
00605                                         const char * cacheDirectory,
00606                                         std::string & cacheFileName) {
00607                 return (ms_mascotresfile::willCreateCache(szFileName, flags, cacheDirectory, &cacheFileName));
00608             }
00609
00611             static bool willCreateCache(const char             * szFileName,
00612                                         const ms_mascotoptions & opts,
00613                                         const char             * applicationName,
00614                                               std::string      & resfileCacheFileName,
00615                                               unsigned int     & cacheStatus);
00616
00618             std::string get_ms_mascotresults_params(const ms_mascotoptions & opts,
00619                 unsigned int * gpFlags,
00620                 double       * gpMinProbability,
00621                 int          * gpMaxHitsToReport,
00622                 double       * gpIgnoreIonsScoreBelow,
00623                 unsigned int * gpMinPepLenInPepSummary,
00624                 bool         * gpUsePeptideSummary,
00625                 unsigned int * gpFlags2) const;
00626 #else // SWIG Multiple return values
00627             static bool willCreateCache(const char * szFileName,
00628                                         const unsigned int flags,
00629                                         const char * cacheDirectory,
00630                                         std::string & OUTPUT);
00631
00632             static bool willCreateCache(const char             * szFileName,
00633                                         const ms_mascotoptions & opts,
00634                                         const char             * applicationName,
00635                                               std::string      & OUTPUT,
00636                                               unsigned int     & OUTPUT);
00637
00638             std::string get_ms_mascotresults_params(const ms_mascotoptions & opts,
00639                 unsigned int * OUTPUT,
00640                 double       * OUTPUT,
00641                 int          * OUTPUT,
00642                 double       * OUTPUT,
00643                 unsigned int * OUTPUT,
00644                 bool         * OUTPUT,
00645                 unsigned int * OUTPUT) const;
00646 #endif
00647
00649             std::string get_ms_mascotresults_params(const ms_mascotoptions          & opts,
00650                                                           ms_mascotresults_params   & params) const;
00651
00653             static bool staticGetPercolatorFileNames(const char * szDatFileName,
00654                                                      const char * cacheDirectory,
00655                                                      const char * percolatorFeatures,
00656                                                      const char * additionalFeatures,
00657                                                      const bool   useRetentionTimes,
00658                                                      std::vector<std::string> & filenames,
00659                                                      std::vector<bool> & exists);
00660
00662             static bool staticGetPercolatorFileNames(const char * szDatFileName,
00663                                                     const char * cacheDirectory,
00664                                                     const ms_mascotoptions &  options,
00665                                                     const char * additionalFeatures,
00666                                                     std::vector<std::string> & filenames,
00667                                                      std::vector<bool> & exists);
00668
00670             void setPercolatorFeatures(const char * percolatorFeatures,
00671                                        const char * additionalFeatures,
00672                                        const bool   useRetentionTimes);
00673
00675             void setPercolatorFeatures(const ms_mascotoptions & options,
00676                                        const char * additionalFeatures);
00677
00679             std::vector<std::string> getPercolatorFileNames() const;
00680
00681 #ifndef SWIG
00682
00683             bool getSrcQueryAndFileIdForMultiFile(const int q, int & gsqNewQuery, int & gsqFileId) const;
00684 #else // SWIG Multiple return values
00685             bool getSrcQueryAndFileIdForMultiFile(const int q, int & OUTPUT, int & OUTPUT) const;
00686 #endif
00687
00688             int getMultiFileQueryNumber(const int localQuery, const int fileId) const;
00689
00691             void appendErrors(ms_errs & errs);
00692             std::string getEncodedPercolatorFeatures() const { return percolatorFeatures_; }
00693
00694         protected:
00695 #ifndef SWIG
00696             // Not safe to copy or assign this object.
00697             ms_mascotresfile(const ms_mascotresfile & rhs);
00698             ms_mascotresfile & operator=(const ms_mascotresfile & rhs);
00699 #endif
00700
00701         private:
00702             std::string  fileName_;
00703             int          numQueries_;              // For multifile, this is the total of all queries for all files.
00704             std::vector<int> multifileNumQueries_; // 0 based vector, with 0 being the primary file
00705             typedef std::vector<ms_mascotresfile *> resfileV_t; // 0 based vector, with 0 being the primary file
00706             resfileV_t   multifileResfiles_;
00707             int          protSummaryHits_;
00708             int          numSequences_;
00709             int          numSequencesAfterTax_;
00710             double       numResidues_;
00711             int          numLibraryEntries_;
00712             int          execTime_;
00713             int          searchDate_;
00714             std::string  version_;
00715
00716             std::vector<DATABASE_TYPE> dbType_;
00717             std::vector<int>           slReferenceMap_;
00718
00719             int  keepAliveInterval_;
00720             std::string  keepAliveTextStr_;
00721             std::string  keepAliveText_[KA_LAST];
00722             time_t       keepAliveStartTime_;
00723             // Following are mutable so outputKeepAlive can be a const function
00724             mutable KA_TASK     keepAliveTask_;
00725             mutable time_t      lastKeepAliveTime_;
00726             mutable int         keepAlivePercentage_;
00727             mutable std::string keepAliveAccession_;
00728             mutable int         keepAliveHit_;
00729             mutable int         keepAliveQuery_;
00730
00731             bool         anyMSMS_;
00732             bool         cachedAnyMSMS_;
00733             bool         anyPMF_;
00734             bool         cachedAnyPMF_;
00735             bool         anySQ_;
00736             bool         cachedAnySQ_;
00737             bool         anyTag_;
00738             bool         cachedAnyTag_;
00739             mutable bool isErrorTolerant_;
00740             mutable bool cachedIsErrorTolerant_;
00741
00742             unsigned int flags_;
00743             msparser_internal::ms_cdb * pIndexFile_;
00744             bool         useIndexFile_;
00745             std::string  cacheDirectory_;
00746             int          hFile_;
00747             mutable char *       readlnBuf_;
00748             mutable unsigned int readlnBufSize_;
00749
00750             ms_searchparams *params_;
00751
00752             std::string percolatorFeatures_;       // Encoded string
00753             std::vector<std::string> percolatorFileNames_;
00754
00755             const char * sectionTitles_[SEC_NUMSECTIONS];
00756
00757             multiBufMemPtr sectionStart_[SEC_NUMSECTIONS];
00758             multiBufMemPtr sectionEnd_  [SEC_NUMSECTIONS];
00759
00760             multiBuf_v buffers_;
00761
00762             std::string endSectionKey_;
00763             std::string lineBasedEndSectionKey_;
00764             std::string genericQuerySectionKey_;
00765             bool   isWinIniFormat_;
00766             std::vector<double> cachedMrValues_;
00767             std::vector<double> cachedExpValues_;
00768             std::vector<short>  cachedCharges_;
00769
00770             std::vector<std::string> xmlSchemaPath_;
00771             ms_progress_info * progressMonitor_;
00772             mutable ms_progress_info * pepSummaryProgressMonitor_;
00773
00774             multiBufMemPtr findSectionStart(const char * szSectionName,
00775                                            const multiBufMemPtr * startLookingAt = 0) const;
00776             multiBufMemPtr findSectionEnd(const multiBufMemPtr sectionStart) const;
00777
00778             // Array of maps for each section
00779             typedef std::set<const char *,ms_sortByKeyCriterion> sortedKeys;
00780             sortedKeys sorted_[SEC_NUMSECTIONS];
00781             bool fillUpSortedList(const int section,
00782                                   const multiBufMemPtr sectionStart,
00783                                   const multiBufMemPtr sectionEnd,
00784                                   sortedKeys & sorted_keys) const;
00785
00786             // There are an 'unknown' number of query sections
00787             bool hasQuerySectionBeenIndexed;
00788             std::vector<multiBufMemPtr> querySectionStart_;
00789             std::vector<multiBufMemPtr> querySectionEnd_;
00790             std::vector<sortedKeys> sortedQueries_;
00791
00792             // Private function to get string
00793             bool inDLLgetSectVal(const section sec,
00794                                  const int queryNumber,
00795                                  const multiBufMemPtr sectionStart,
00796                                  const multiBufMemPtr sectionEnd,
00797                                  sortedKeys & sorted_keys,
00798                                  const char * key,
00799                                  std::string & result) const;
00800
00801             // Private function to get string
00802             bool inDLLgetSectionAsString(const section sec,
00803                                          std::string & result) const;
00804
00805             bool readFile(const char * szFileName);
00806             bool readLine(char * & buf, unsigned int & bufSize) const;
00807             void getSectionTitles();
00808             void debugCheckReadFileOK();
00809             bool getCrosslinking(ms_crosslinking_configfile *crosslinkingFile) const;
00810             bool createCDBFile();
00811             void prepareKeepAlive(const char * keepAliveText, const bool resetStartTime);
00812             std::string getKeepAliveString(const double elapsedTime) const;
00813             static std::string getSortedPercolatorFeatures(const ms_mascotoptions & options,
00814                                                            const char * additionalFeatures);
00815             static std::string getSortedPercolatorFeatures(const char * percolatorFeatures,
00816                                                            const char * additionalFeatures,
00817                                                            const bool   useRetentionTimes);
00818
00819             void setError(int error, ...) const;
00820             bool setErrorInfoFromString(const std::string & e);
00821             std::string getErrorInfoAsString(const int num) const;
00822
00823             int extractObservedCharge(char *szKey, std::string str) const;
00824             std::string enumerateQuerySection(const int     query,
00825                                               const int     num,
00826                                               int         * pPreviousNum,
00827                                               OFFSET64_T  * pPreviousOffset,
00828                                               OFFSET64_T  * pSectionEnd,
00829                                               std::string & value) const;
00830
00831             void getSLFragmentToleranceAndUnit_Value(int idx, double & tolerance, std::string & toleranceUnit) const;
00832
00833             std::map<section, bool> mapSectionAnyMatch_;
00834
00835             void cacheMonoLinkModifications() const;
00836             mutable std::map< std::pair<int, int>, ms_modification > monoLinkCache_;
00837             mutable bool monoLinksCached_;
00838
00839     }; // end of resfile_group
00841 }   // matrix_science namespace
00842 #endif // MS_MASCOTRESFILE_HPP
00843
00844 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresparams.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotresparams.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the parameters & masses sections from the mascot results file #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespa $ #
00012 #     $Author: francoisr@matrixscience.com $ #
00013 #       $Date: 2021-07-22 14:03:31 +0100 $ #
00014 #   $Revision: 0ea29aa2aa389c9ba7d3f7b5485b56c02719f01e | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTRESPARAMS_HPP
00020 #define MS_MASCOTRESPARAMS_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025
00026 namespace matrix_science {
00027
00033
00034
00040     class MS_MASCOTRESFILE_API ms_searchparams
00041     {
00042         public:
00043
00045
00052             enum MULTI_SITE_MODS {
00053                 MSM_NOT_PERMITTED           = 0x0000,
00054                 MSM_EXCLUSIVE_PLUS_VARIABLE = 0x0001
00055             };
00056
00058             ms_searchparams(const ms_mascotresfile &resfile);
00059
00061             ~ms_searchparams() {};
00062
00064             std::string  getLICENSE();
00065 #ifndef SWIGCSHARP
00066
00067             std::string  getCOM();
00068 #else
00069             std::wstring getCOM() {
00070                 return getCOMWide();
00071             };
00072 #endif
00073
00074             int          getSEG();
00075
00077             double       getTOL();
00078
00080             std::string  getTOLU();
00081
00083             double       getITOL();
00084
00086             std::string  getITOLU();
00087
00089             int          getPFA();
00090
00092             std::string  getDB(int idx = 1);
00093
00095             int getNumberOfDatabases();
00096
00098             std::string  getMODS();
00099
00101             std::string  getMASS();
00102
00104             MASS_TYPE    getMassType();
00105
00107             std::string  getCLE();
00108
00110             std::string  getFILENAME();
00111
00113             std::string  getDATAURL();
00114
00116             std::string  getQUE();
00117
00119             std::string  getSEARCH();
00120
00121 #ifndef SWIGCSHARP
00122
00123             std::string  getUSERNAME();
00124 #else
00125             std::wstring getUSERNAME() {
00126                 return getUSERNAMEWide();
00127             };
00128 #endif
00129
00130 #ifndef SWIGCSHARP
00131
00132             std::string  getUSEREMAIL();
00133 #else
00134             std::wstring getUSEREMAIL() {
00135                 return getUSEREMAILWide();
00136             };
00137 #endif
00138
00140             int getUSERID();
00141
00143             std::string  getCHARGE();
00144
00146             std::string  getINTERMEDIATE();
00147
00149             int          getREPORT();
00150
00152             bool         getOVERVIEW();
00153
00155             std::string  getFORMAT();
00156
00158             std::string  getFORMVER();
00159
00161             std::string  getIT_MODS();
00162
00164             std::string  getUSERField(int num);
00165
00167             std::string getAllUSERParams() const;
00168
00170             double       getPRECURSOR();
00171
00173             std::string  getTAXONOMY();
00174
00176             std::string  getREPTYPE();
00177
00179             std::string  getACCESSION();
00180
00182             int          getSUBCLUSTER();
00183
00185             bool         getICAT();
00186
00188             std::string  getINSTRUMENT();
00189
00191             bool         getERRORTOLERANT();
00192
00194             std::string  getRULES();
00195
00197             double getMinInternalMass();
00198
00200             double getMaxInternalMass();
00201
00203             double       getResidueMass(char residue);
00204
00206             double       getCTermMass();
00207
00209             double       getNTermMass();
00210
00212             double       getHydrogenMass() const;
00213
00215             double       getOxygenMass() const;
00216
00218             double       getCarbonMass() const;
00219
00221             double       getNitrogenMass() const;
00222
00224             double       getElectronMass() const;
00225
00226             // Returns the name of the specified variable modification selected by the user.
00227             std::string  getVarModsName(int num) const;
00228
00230             double       getVarModsDelta(int num);
00231
00233             double       getVarModsNeutralLoss(int num);
00234
00236             std::vector<double> getVarModsNeutralLosses(int num) const;
00237
00239             std::vector<double> getVarModsPepNeutralLoss(int num);
00240
00242             std::vector<double> getVarModsReqPepNeutralLoss(int num);
00243
00244             // Returns the name of the specified fixed modification selected by the user.
00245             std::string  getFixedModsName(int num) const;
00246
00248             double       getFixedModsDelta(int num);
00249
00251             double       getFixedModsNeutralLoss(int num);
00252
00254             std::string  getFixedModsResidues(int num) const;
00255
00257             int          getNumberOfLibraryMods() const;
00258
00260             std::string  getLibraryModName(int num) const;
00261
00263             double       getLibraryModDelta(int num) const;
00264
00266             std::string  getErrTolParentFilename();
00267
00269             std::string  getQUANTITATION() const;
00270
00272             std::string  getCROSSLINKING() const;
00273
00275             int  getPEP_ISOTOPE_ERROR() const;
00276
00278             int  getDECOY() const;
00279
00281             double getTARGET_FDR_PERCENT() const;
00282
00284             int  getLIBRARY_SEARCH() const;
00285
00287             unsigned int getMULTI_SITE_MODS() const;
00288
00289         protected:
00290             // Not safe to copy or assign this object.
00291 #ifndef SWIG
00292             ms_searchparams(const ms_searchparams & rhs);
00293             ms_searchparams & operator=(const ms_searchparams & rhs);
00294 #endif
00295
00296         private:
00297             std::wstring getCOMWide();
00298             std::wstring getUSERNAMEWide();
00299             std::wstring getUSEREMAILWide();
00300             std::string decryptNumber(const std::string & input) const;
00301             bool parseLibraryMod(const ms_mascotresfile & resfile, int num, std::string & name, double & delta) const;
00302
00303
00304             int numDB_;
00305             std::string license_;
00306             std::string com_;
00307             int seg_;
00308             double tol_;
00309             std::string tolu_;
00310             double itol_;
00311             std::string itolu_;
00312             int PFA_;
00313             std::vector<std::string> DBnames_;
00314             std::string mods_;
00315             std::string massTypeStr_;
00316             std::string cle_;
00317             std::string FILENAME_;
00318             std::string DATAURL_;
00319             std::string QUE_;
00320             std::string SEARCH_;
00321             std::string USERNAME_;
00322             int USERID_;
00323             std::string USEREMAIL_;
00324             std::string CHARGE_;
00325             std::string INTERMEDIATE_;
00326             int REPORT_;
00327             bool OVERVIEW_;
00328             std::string FORMAT_;
00329             std::string FORMVER_;
00330             std::string IT_MODS_;
00331             std::vector<std::string> userField_;
00332             std::string allUserParams_;
00333             double PRECURSOR_;
00334             std::string TAXONOMY_;
00335             std::string REPTYPE_;
00336             std::string ACCESSION_;
00337             int SUBCLUSTER_;
00338             bool ICAT_;
00339             std::string INSTRUMENT_;
00340             bool ERRORTOLERANT_;
00341             std::string RULES_;
00342             double minInternalMass_;
00343             double maxInternalMass_;
00344             std::map<char, double> residueMasses_;
00345             double C_term_;
00346             double N_term_;
00347             double HydrogenMass_;
00348             double OxygenMass_;
00349             double CarbonMass_;
00350             double NitrogenMass_;
00351             double ElectronMass_;
00352             std::map<int, std::string> varModsName_;
00353             std::map<int, double> varModsDelta_;
00354             std::map<int, std::vector<double> > varModsNeutralLosses_;
00355             std::map<int, std::vector<double> > pepNeutralLoss_;
00356             std::map<int, std::vector<double> > reqPepNeutralLoss_;
00357             std::map<int, std::string> fixedModsName_;
00358             std::map<int, double> fixedModsDelta_;
00359             std::map<int, double> fixedModsNeutralLoss_;
00360             std::map<int, std::string> fixedModsResidues_;
00361             std::vector<std::string> libraryModNames_;
00362             std::vector<double> libraryModDeltas_;
00363             int numLibraryMods_;
00364             std::string errTolParentFilename_;
00365             std::string QUANTITATION_;
00366             std::string CROSSLINKING_;
00367             int PEP_ISOTOPE_ERROR_;
00368             int decoy_;
00369             double TARGET_FDR_PERCENT_;
00370             int LIBRARY_SEARCH_;
00371             int MULTI_SITE_MODS_;
00372
00373             int getNumberOfDatabases(const ms_mascotresfile & resfile) const;
00374
00375     }; // end of resfile_group
00377 }   // matrix_science namespace
00378
00379 #endif // MS_MASCOTRESPARAMS_HPP
00380
00381 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotrespeptide.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotrespeptide.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a peptide from the summary section or peptides section of the #
00006 # mascot results file                                                        #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2002 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
00013 #     $Author: robertog@matrixscience.com $ #
00014 #       $Date: 2020-08-18 11:02:02 +0100 $ #
00015 #   $Revision: 465f19fb3667b818b76f7d5918f62bd50d73edd6 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_MASCOTRESPEPTIDE_HPP
00021 #define MS_MASCOTRESPEPTIDE_HPP
00022
00023
00024 // Includes from the standard template library
00025 #include <string>
00026 #include <vector>
00027
00028 namespace msparser_internal {
00029     class ms_peptide_impl;
00030 }
00031
00032 namespace matrix_science {
00033     class ms_protein;
00034     class ms_mascotresults;
00035     class ms_linker_site;
00036     class ms_linker_site_vector;
00037
00043
00044
00055     class MS_MASCOTRESFILE_API ms_peptide
00056     {
00057         public:
00059             ms_peptide();
00060
00062             ms_peptide( int         query,
00063                         int         rank,
00064                         int         missedCleavages,
00065                         double      mrCalc,
00066                         double      delta,
00067                         double      observed,
00068                         int         charge,
00069                         int         numIonsMatched,
00070                         std::string peptideStr,
00071                         int         peaksUsedFromIons1,
00072                         std::string varModsStr,
00073                         double      ionsScore,
00074                         std::string seriesUsedStr,
00075                         int         peaksUsedFromIons2,
00076                         int         peaksUsedFromIons3,
00077                         const ms_mascotresults * pResults = 0,
00078                         bool        storeReloadableInfo = true);
00079
00080             enum SEARCH_PHASE {
00081                 SEARCH_PHASE_PRIMARY = 0,
00082                 SEARCH_PHASE_ERRTOL = 1,
00083                 SEARCH_PHASE_LIBRARY = 2
00084             };
00085
00087
00097             enum PSM {
00098                 PSM_COMPLETE = 0,
00099                 PSM_CROSSLINK_ALPHA = 1,
00100                 PSM_CROSSLINK_BETA = 2
00101             };
00102
00104             ms_peptide( const int                query,
00105                         const int                rank,
00106                         const SEARCH_PHASE       searchPhase,
00107                         const int                missedCleavages,
00108                         const double             mrCalc,
00109                         const double             delta,
00110                         const double             observed,
00111                         const int                charge,
00112                         const int                numIonsMatched,
00113                         const std::string      & peptideStr,
00114                         const int                peaksUsedFromIons1,
00115                         const std::string      & varModsStr,
00116                         const std::string      & summedModsStr,
00117                         const std::string      & localModsStr,
00118                         const std::string      & monoLinkStr,
00119                         const ms_linker_site_vector & loopLinks,
00120                         const double             ionsScore,
00121                         const std::string      & seriesUsedStr,
00122                         const int                peaksUsedFromIons2,
00123                         const int                peaksUsedFromIons3,
00124                         const std::string      & primaryNlStr,
00125                         const std::string      & summedModsNlStr,
00126                         const std::string      & localModsNlStr,
00127                         const std::string      & substStr,
00128                         const std::string      & componentStr,
00129                         const ms_mascotresults * pResults = 0,
00130                         const bool               storeReloadableInfo = true);
00131
00133             ms_peptide( const int                query,
00134                         const int                rank,
00135                         const SEARCH_PHASE       searchPhase,
00136                         const double             delta,
00137                         const double             observed,
00138                         const int                charge,
00139                         const int                numIonsMatched,
00140                         const int                peaksUsedFromIons1,
00141                         const double             ionsScore,
00142                         const std::string      & seriesUsedStr,
00143                         const int                peaksUsedFromIons2,
00144                         const int                peaksUsedFromIons3,
00145                         const ms_peptide       & pepAlpha,
00146                         const ms_peptide       & pepBeta,
00147                         const ms_linker_site   & linkerSite,
00148                         const ms_mascotresults * pResults = 0,
00149                         const bool               storeReloadableInfo = true);
00150
00152             ms_peptide(const ms_peptide& src);
00153
00155             ms_peptide(msparser_internal::ms_peptide_impl *pImpl);
00156
00158             ~ms_peptide();
00159
00160 #ifndef SWIG
00161
00162             ms_peptide& operator=(const ms_peptide& right);
00163 #endif
00164
00165             void copyFrom(const ms_peptide* src);
00166
00168             bool clearReloadableInfo();
00169
00170 #ifndef SWIG
00171
00172             bool getAllProperties(int          & outQuery,
00173                                   int          & outRank,
00174                                   int          & outPrettyRank,
00175                                   int          & outMissedCleavages,
00176                                   double       & outMrCalc,
00177                                   double       & outDelta,
00178                                   double       & outObserved,
00179                                   int          & outCharge,
00180                                   int          & outNumIonsMatched,
00181                                   std::string  & outPeptideStr,
00182                                   int          & outPeaksUsedFromIons1,
00183                                   std::string  & outVarModsStr,
00184                                   std::string  & outSummedModsStr,
00185                                   std::string  & outLocalModsStr,
00186                                   std::string  & outMonoLinkStr,
00187                                   double       & outIonsScore,
00188                                   std::string  & outSeriesUsedStr,
00189                                   int          & outPeaksUsedFromIons2,
00190                                   int          & outPeaksUsedFromIons3,
00191                                   std::string  & outPrimaryNlStr,
00192                                   std::string  & outSummedModsNlStr,
00193                                   std::string  & outLocalModsNlStr,
00194                                   std::string  & outComponentStr) const;
00195 #else // SWIG Multiple return values
00196             bool getAllProperties(int          & OUTPUT,
00197                                   int          & OUTPUT,
00198                                   int          & OUTPUT,
00199                                   int          & OUTPUT,
00200                                   double       & OUTPUT,
00201                                   double       & OUTPUT,
00202                                   double       & OUTPUT,
00203                                   int          & OUTPUT,
00204                                   int          & OUTPUT,
00205                                   std::string  & OUTPUT,
00206                                   int          & OUTPUT,
00207                                   std::string  & OUTPUT,
00208                                   std::string  & OUTPUT,
00209                                   std::string  & OUTPUT,
00210                                   std::string  & OUTPUT,
00211                                   double       & OUTPUT,
00212                                   std::string  & OUTPUT,
00213                                   int          & OUTPUT,
00214                                   int          & OUTPUT,
00215                                   std::string  & OUTPUT,
00216                                   std::string  & OUTPUT,
00217                                   std::string  & OUTPUT,
00218                                   std::string  & OUTPUT) const;
00219 #endif
00220
00221             int         getQuery()              const;
00222
00224             int         getRank()               const;
00225             void        setRank(int rank);
00226
00228             int         getPrettyRank()         const;
00229             void        setPrettyRank(int rank);
00230
00232             int         getAmbiguityGroupId()         const;
00234             void        setAmbiguityGroupId(int group);
00235
00237             bool        getAnyMatch()           const;
00238
00240             int         getMissedCleavages(const PSM psmComponent = PSM_COMPLETE)    const;
00241
00243             double      getMrCalc(const PSM psmComponent = PSM_COMPLETE)             const;
00244
00246             double      getDelta()              const;
00247
00249             double      getObserved()           const;
00250
00252             double      getMrExperimental()     const;
00253
00255             int         getCharge()             const;
00256
00258             int         getNumIonsMatched()     const;
00259
00261             std::string getPeptideStr(bool substituteAmbiguous = true, const PSM psmComponent = PSM_COMPLETE) const;
00262
00264             int         getPeptideLength(const PSM psmComponent = PSM_COMPLETE)      const;
00265
00267             int         getPeaksUsedFromIons1() const;
00268
00270             int         getPeaksUsedFromIons2() const;
00271
00273             int         getPeaksUsedFromIons3() const;
00274
00276             std::string getVarModsStr(const PSM psmComponent = PSM_COMPLETE)         const;
00277
00279             void        setVarModsStr(const std::string str, const PSM psmComponent = PSM_COMPLETE);
00280
00282             std::string getSummedModsStr(const PSM psmComponent = PSM_COMPLETE)         const;
00283
00285             void        setSummedModsStr(const std::string str, const PSM psmComponent = PSM_COMPLETE);
00286
00288             std::string getLocalModsStr(const PSM psmComponent = PSM_COMPLETE)         const;
00289
00291             void        setLocalModsStr(const std::string str, const PSM psmComponent = PSM_COMPLETE);
00292
00294             std::string getParsedLocalModsStr(const PSM psmComponent = PSM_COMPLETE)         const;
00295
00297             double      getIonsScore()          const;
00298
00300             double      getExpectationValue() const;
00301
00303             std::string getSeriesUsedStr()      const;
00304
00306             bool        isSamePeptideStr(ms_peptide * peptide,
00307                                          bool substituteAmbiguous = true) const;
00308
00310             bool        isSameVarModsStr(ms_peptide * peptide) const;
00311
00313             bool        isSameSummedModsStr(ms_peptide * peptide) const;
00314
00316             int         getFirstProtAppearedIn() const;
00317
00320             void        setFirstProtAppearedIn(int n);
00321
00324             void        makeUnassigned();
00325
00327             double      getIonsIntensity()      const;
00329             void        setIonsIntensity(double n);
00330
00332             const ms_protein * getProtein(int num) const;
00333
00335             const std::vector<int> getProteins() const;
00336
00338             int         getNumProteins()         const;
00339             void        addProtein(const ms_protein * protein);
00340             void        addProtein(const int hitNumber);
00341
00343             std::string getAmbiguityString(const PSM psmComponent = PSM_COMPLETE)    const;
00345             bool setAmbiguityString(const std::string val, const PSM psmComponent = PSM_COMPLETE);
00346
00348             std::string getPrimaryNlStr(const PSM psmComponent = PSM_COMPLETE)       const;
00350             void        setPrimaryNlStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
00351
00353             std::string getSummedModsNlStr(const PSM psmComponent = PSM_COMPLETE)       const;
00355             void        setSummedModsNlStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
00356
00358             std::string getLocalModsNlStr(const PSM psmComponent = PSM_COMPLETE)       const;
00360             void        setLocalModsNlStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
00361
00363             std::string getMonoLinkStr(const PSM psmComponent = PSM_COMPLETE)       const;
00365             void        setMonoLinkStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
00366
00368             bool getIsFromErrorTolerant()       const;
00370             void setIsFromErrorTolerant(const bool isFromErrorTolerant);
00371
00373             std::string getComponentStr(const PSM psmComponent = PSM_COMPLETE)       const;
00375             void        setComponentStr(const std::string value, const PSM psmComponent = PSM_COMPLETE);
00376
00378             bool        getLessThanMinPepLen()  const;
00379
00381             int getNum13C(const double tol, const std::string tolu, const std::string mass_type) const;
00382
00384             void setPercolatorScores(double posteriorErrorProbability,
00385                                      double qValue,
00386                                      double internalPercolatorScore);
00387
00389             bool anyPercolatorResults()     const;
00390
00391 #ifndef SWIG
00392
00393             void getPercolatorScores(double * posteriorErrorProbability,
00394                                      double * qValue,
00395                                      double * internalPercolatorScore,
00396                                      double * mascotIonsScore) const;
00397 #else // SWIG Multiple return values
00398             void getPercolatorScores(double * OUTPUT,
00399                                      double * OUTPUT,
00400                                      double * OUTPUT,
00401                                      double * OUTPUT) const;
00402 #endif
00403
00405             bool getIsFromLibrary()       const;
00407             void setIsFromLibrary(const bool isFromLibrary);
00408
00410             void getAnyProteinTermination(
00411                     bool & isNterminus,
00412                     bool & isCterminus,
00413                     const PSM psmComponent = PSM_COMPLETE) const;
00414
00416             void setInternalSortingScore(double s);
00417
00419             double getInternalSortingScore() const;
00420
00422             int getNumberOfLinkedPeptides() const;
00423
00425             void getIntactLinks(ms_linker_site_vector &vec) const;
00426
00428             ms_linker_site_vector getIntactLinks() const;
00429
00431             void getLoopLinks(ms_linker_site_vector &vec, const PSM psmComponent = PSM_COMPLETE) const;
00432
00434             ms_linker_site_vector getLoopLinks(const PSM psmComponent = PSM_COMPLETE) const;
00435
00436         private:
00437             msparser_internal::ms_peptide_impl * pImpl_;
00438     }; // end of resfile_group
00440 }   // matrix_science namespace
00441
00442 #endif // MS_MASCOTRESPEPTIDE_HPP
00443
00444 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotrespeptidesum.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotrespeptidesum.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the peptide summary report from the mascot results file       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2021-04-22 10:00:41 +0100 $ #
00014 #   $Revision: 7bc84c21208ba1258516c93fb7b0917dc734c462 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTRESPEPTIDESUM_HPP
00020 #define MS_MASCOTRESPEPTIDESUM_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <list>
00025 #include <map>
00026 #include <set>
00027 #include <string>
00028 #include <vector>
00029
00030 namespace msparser_internal {
00031     class ms_peptidesumcdb;
00032     class ms_peptide_impl;
00033     class ms_peptide_impl_reloadable;
00034     class ms_SEQINFO;
00035     class ms_peptidesummary_fdr_query_data_extractor;
00036     class ms_peptidesummary_fdr_peptides_vector_extractor;
00037 }
00038
00039 namespace matrix_science {
00040     class ms_tinycdb;
00041     class ms_mascotresults_params;
00042     class ms_protein;
00043     class ms_datfile;
00044     class ms_distiller_data;
00045     class ms_distiller_data_search;
00046     class ms_quant_component;
00047     class ms_quant_modgroup;
00048     class ms_linker_site;
00049
00055     struct ms_percolator_score {
00056         double percolatorScore;
00057         double qValue;
00058         double percolatorPEP;
00059         double mascotScore;
00060         bool foundInPopFile;
00061         ms_percolator_score()
00062             : percolatorScore(0.0)
00063             , qValue(1.0)
00064             , percolatorPEP(1.0)
00065             , mascotScore(0.0)
00066             , foundInPopFile(false)
00067         {}
00068     };
00069     typedef std::vector<ms_percolator_score> ms_percolator_scores_vector;
00070
00071     typedef struct structExpectTargetDecoy //Bug 11481, alternative algorithm by sorting and counting to adjust FDR
00072     {
00073         double expect;
00074         int target;
00075         int decoy;
00076
00077 #ifndef SWIG
00078         bool operator<(const structExpectTargetDecoy &other) const
00079         {
00080             return expect > other.expect;//we want the smallest values first
00081         }
00082 #endif
00083     } structExpectTargetDecoy;
00084
00086
00092     class MS_MASCOTRESFILE_API ms_peptidesummary : public matrix_science::ms_mascotresults
00093     {
00094         friend class msparser_internal::ms_peptide_impl;
00095         friend class ms_protein;
00096         friend class msparser_internal::ms_peptidesumcdb;
00097         friend class ms_ms2quantitation;
00098         friend class ms_customquantitation;
00099         friend class ms_quant_helper;
00100         friend class msparser_internal::ms_peptidesummary_fdr_query_data_extractor;
00101         friend class msparser_internal::ms_peptidesummary_fdr_peptides_vector_extractor;
00102         public:
00104
00107             enum QL_FLAG
00108             {
00109                 QL_FIRST                    = 0x0000,
00110                 QL_ALL                      = 0x0000,
00111                 QL_UNASSIGNED               = 0x0001,
00112                 QL_BELOW_IDENTITY           = 0x0002,
00113                 QL_BELOW_HOMOLOGY           = 0x0003,
00114                 QL_IGNORE_IONS_SCORE_BELOW  = 0x0004,
00115
00116                 QL_LAST                     = 0x0004
00117             };
00118
00120
00123             enum MSPEPSUM
00124             {
00125                 MSPEPSUM_NONE               = 0x0000,
00126                 MSPEPSUM_PERCOLATOR         = 0x0001,
00127                 MSPEPSUM_USE_CACHE          = 0x0002,
00128                 MSPEPSUM_SINGLE_HIT_DBIDX   = 0x0004,
00129                 MSPEPSUM_USE_HOMOLOGY_THRESH= 0x0008,
00130                 MSPEPSUM_NO_PROTEIN_GROUPING= 0x0010,
00131                 MSPEPSUM_DISCARD_RELOADABLE = 0x0020,
00132                 MSPEPSUM_DEFERRED_CREATE            = 0x0040,
00133                 MSPEPSUM_CACHE_IGNORE_DATE_CHANGE   = 0x0080,
00134                 MSPEPSUM_REMOVE_CHIMERIC_DUPES      = 0x0100,
00135                 MSPEPSUM_SL_INTEGRATED              = 0x0200,
00136                 MSPEPSUM_SL_ONLY                    = 0x0400,
00137                 MSPEPSUM_CROSSLINK_INTEGRATED       = 0x0800,
00138                 MSPEPSUM_CROSSLINK_ONLY             = 0x1000,
00139             };
00140
00142
00156             enum BUGFIX_NUM
00157             {
00158                 BUGFIX_10780 = 10780,
00159                 BUGFIX_10995 = 10995,
00160                 BUGFIX_11002 = 11002,
00161                 BUGFIX_11018 = 11018,
00162                 BUGFIX_11235 = 11235,
00163                 BUGFIX_11254 = 11254,
00164                 BUGFIX_11344 = 11344,
00165                 BUGFIX_11411 = 11411,
00166                 BUGFIX_11425 = 11425,
00167                 BUGFIX_11438 = 11438,
00168                 BUGFIX_11483 = 11483,
00169                 BUGFIX_11499 = 11499,
00170                 BUGFIX_11856 = 11856,
00171                 BUGFIX_12123 = 12123,
00172                 BUGFIX_12317 = 12317,
00173                 BUGFIX_11481 = 11481,
00174                 BUGFIX_12538 = 12538,
00175                 BUGFIX_12729 = 12729,
00176                 BUGFIX_12740 = 12740,
00177                 BUGFIX_13324 = 13324,
00178                 BUGFIX_12447 = 12447,
00179                 BUGFIX_13759 = 13759
00180             };
00181
00183
00188             enum CACHE_STATUS {
00189             CACHE_MISSING_RESFILE                = 0x10000,
00190
00191             RESFILE_CACHE_FILE_NOT_PRESENT       = 0x00001,
00192             RESFILE_CACHE_BEING_CREATED          = 0x00002,
00193             RESFILE_CACHE_DISABLED_IN_OPTIONS    = 0x00004,
00194             RESFILE_CACHE_VALID                  = 0x00008,
00195             RESFILE_CACHE_CAN_CREATE             = 0x00010,
00196
00197             PEPSUMMARY_CACHE_FILE_NOT_PRESENT    = 0x00100,
00198             PEPSUMMARY_CACHE_BEING_CREATED       = 0x00200,
00199             PEPSUMMARY_CACHE_DISABLED_IN_OPTIONS = 0x00400,
00200             PEPSUMMARY_CACHE_VALID               = 0x00800,
00201             PEPSUMMARY_CACHE_CAN_CREATE          = 0x01000,
00202             PEPSUMMARY_CACHE_STATUS_NOT_AVAILABLE= 0x02000,
00203             PEPSUMMARY_CACHE_NOT_FOR_PMF         = 0x04000
00204             };
00205
00207             static std::string getCacheFilename(
00208                     const ms_mascotresfile & resfile,
00209                     const unsigned int flags,
00210                     double             minProbability = 0.0,
00211                     int                maxHitsToReport = 50,
00212                     const char *       unigeneIndexFile = 0,
00213                     double             ignoreIonsScoreBelow = 0.0,
00214                     int                minPepLenInPepSummary = 0,
00215                     const char *       singleHit = 0,
00216                     const unsigned int flags2 = MSPEPSUM_NONE);
00217
00219             static std::string getCacheFilename(
00220                     const ms_mascotresfile & resfile,
00221                     const ms_mascotresults_params & parameters);
00222
00224             ms_peptidesummary(const ms_mascotresfile  &resfile,
00225                               const unsigned int flags = MSRES_GROUP_PROTEINS,
00226                               double             minProbability = 0.0,
00227                               int                maxHits = 50,
00228                               const char *       unigeneIndexFile = 0,
00229                               double             ignoreIonsScoreBelow = 0.0,
00230                               int                minPepLenInPepSummary = 0,
00231                               const char *       singleHit = 0,
00232                               const unsigned int flags2 = MSPEPSUM_NONE);
00233
00235             ms_peptidesummary(
00236                     const ms_mascotresfile & resfile,
00237                     const ms_mascotresults_params & parameters);
00238
00239             virtual ~ms_peptidesummary();
00240
00242             const ms_mascotresfile & mascotresfile() const;
00243
00245             virtual bool createSummary();
00246
00247             virtual bool anyEmPAI() const;
00248
00250             virtual double getProteinEmPAI(const char *accession, const int dbIdx = 1, const int length = -1) const;
00251
00253             virtual ms_protein * getHit(const int hit, const int memberNumber = 0) const;
00254
00256             virtual void freeHit(const int hit);
00257
00258             // This is 'hard-coded' to 10 in Mascot
00259             enum { PEPS_PER_QUERY = 10 };
00260
00262             virtual ms_peptide getPeptide(const int q, const int p) const;
00263
00265             virtual bool getPeptide(const int q, const int p, ms_peptide * & pep) const;
00266
00268             virtual double getIonsScore(const int q, const int p, const bool decoy) const;
00269
00271             virtual bool isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules = UPR_DEFAULT) const;
00272
00274             virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false);
00275
00277             virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
00278                                                                             std::vector<int> & start,
00279                                                                             std::vector<int> & end,
00280                                                                             std::vector<std::string> &pre,
00281                                                                             std::vector<std::string> &post,
00282                                                                             std::vector<int> & frame,
00283                                                                             std::vector<int> & multiplicity,
00284                                                                             std::vector<int> & db) const;
00285
00287             virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
00288                                                                             std::vector<int> & start,
00289                                                                             std::vector<int> & end,
00290                                                                             std::vector<std::string> &pre,
00291                                                                             std::vector<std::string> &post,
00292                                                                             std::vector<int> & frame,
00293                                                                             std::vector<int> & multiplicity,
00294                                                                             std::vector<int> & db,
00295                                                                             std::vector<int> & psmComponent) const;
00296
00298             std::vector<int> getNumberOfAccessionDBTypes(int q, int p) const;
00299
00301             virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
00302                                                             const int q,
00303                                                             const int p,
00304                                                             std::vector< int >& db,
00305                                                             std::vector< std::string >& acc,
00306                                                             std::vector< int >& dupe_status) const;
00307
00309             std::vector<int> getNumberOfFamilyAccessionDBTypes(int hit, int q, int p, bool includeSamesets = true) const;
00310
00312             virtual std::string getErrTolModString(const int q, const int p) const;
00313
00315             virtual std::string getLibraryModString(const int q, const int p) const;
00316
00318             virtual std::string getErrTolModMasterString(const int q, const int p) const;
00319
00321             virtual std::string getErrTolModSlaveString(const int q, const int p) const;
00322
00324             virtual std::string getErrTolModPepString(const int q, const int p) const;
00325
00327             virtual std::string getErrTolModReqPepString(const int q, const int p) const;
00328
00330             virtual std::string getTagString(const int q, const int p) const;
00331
00333             virtual int getTagDeltaRangeStart(const int q, const int p) const;
00334
00336             virtual int getTagDeltaRangeEnd(const int q, const int p) const;
00337
00339             virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00340
00342             virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00343
00345             virtual int getProteinScoreCutoff(double OneInXprobRnd) const;
00346
00348             int getSrcRank(int q, int p) const;
00349
00351             ms_mascotresfile::section getSrcSection(int q, int p)const;
00352
00354             std::string getQueryList(QL_FLAG flag, bool outputListOfQueries = true);
00355
00357             virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const;
00358 #ifndef SWIG
00359
00360             virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const;
00361 #else // SWIG Multiple return values
00362             virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const;
00363 #endif
00364
00365             virtual int findProteins(const int startHit,
00366                                      const std::string & str,
00367                                      const int dbIdx,
00368                                      FIND_FLAGS item,
00369                                      FIND_COMPARE_FLAGS compareFlags,
00370                                      std::vector<std::string> & accessions,
00371                                      std::vector<int> & dbIndexes) const;
00372
00374             virtual int findProteinsByAccession(const int startHit,
00375                                                 const std::string & str,
00376                                                 const int dbIdx,
00377                                                 FIND_COMPARE_FLAGS compareFlags,
00378                                                 std::vector<std::string> & accessions,
00379                                                 std::vector<int> & dbIndexes) const;
00380
00382             virtual int findProteinsByDescription(const int startHit,
00383                                                   const std::string & str,
00384                                                   FIND_COMPARE_FLAGS compareFlags,
00385                                                   std::vector<std::string> & accessions,
00386                                                   std::vector<int> & dbIndexes) const;
00387
00389             virtual int findPeptides(const int startHit,
00390                                      const std::string & str,
00391                                      FIND_FLAGS item,
00392                                      FIND_COMPARE_FLAGS compareFlags,
00393                                      std::vector<int> & q,
00394                                      std::vector<int> & p) const;
00395
00397             virtual QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
00398                     const ms_peptide & peptide,
00399                     ms_quant_component & component,
00400                     const ms_quant_method * method = NULL) const;
00401
00403             virtual const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const;
00404
00406             virtual const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const;
00407
00409             virtual bool getTreeClusterNodes(const int hit,
00410                                              std::vector<int>    &left,
00411                                              std::vector<int>    &right,
00412                                              std::vector<double> &distance,
00413                                              TREE_CLUSTER_METHOD  tcm = TCM_PAIRWISE_MAXIMUM,
00414                                              double           *** reserved1 = 0,
00415                                              unsigned int       * reserved2 = 0) const;
00416
00418             static bool willCreateCache(const ms_mascotresfile  &resfile,
00419                                         const unsigned int flags = MSRES_GROUP_PROTEINS,
00420                                         double             minProbability = 0.0,
00421                                         int                maxHits = 50,
00422                                         const char *       unigeneIndexFile = 0,
00423                                         double             ignoreIonsScoreBelow = 0.0,
00424                                         int                minPepLenInPepSummary = 0,
00425                                         const char *       singleHit = 0,
00426                                         const unsigned int flags2 = MSPEPSUM_NONE);
00427
00429             static bool willCreateCache(const ms_mascotresfile  &resfile,
00430                                         const ms_mascotresults_params & parameters);
00431
00432 #ifndef SWIG
00433
00434             static bool willCreateCache(const char             * resultsFileName,
00435                                         const ms_mascotoptions & opts,
00436                                         const char             * unigeneIndexFile,
00437                                         const char             * singleHit,
00438                                         const char             * applicationName,
00439                                               std::string      & resfileCacheFileName,
00440                                               std::string      & peptideSummaryCacheFileName,
00441                                               unsigned int     & cacheStatus);
00442
00444             static bool willCreateCache(const ms_mascotresfile        & resfile,
00445                                         const ms_mascotresults_params & parameters,
00446                                         const ms_mascotoptions        & opts,
00447                                               std::string             & peptideSummaryCacheFileName,
00448                                               unsigned int            & cacheStatus);
00449 #else // SWIG Multiple return values
00450             static bool willCreateCache(const char             * resultsFileName,
00451                                         const ms_mascotoptions & opts,
00452                                         const char             * unigeneIndexFile,
00453                                         const char             * singleHit,
00454                                         const char             * applicationName,
00455                                               std::string      & OUTPUT,
00456                                               std::string      & OUTPUT,
00457                                               unsigned int     & OUTPUT);
00458
00459             static bool willCreateCache(const ms_mascotresfile        & resfile,
00460                                         const ms_mascotresults_params & parameters,
00461                                         const ms_mascotoptions        & opts,
00462                                               std::string             & OUTPUT,
00463                                               unsigned int            & OUTPUT);
00464 #endif
00465
00467             bool isPeptideModificationMatch(
00468                     const ms_quant_modgroup & group,
00469                     const ms_peptide & peptide) const;
00470
00472             bool isPeptideComponentMatch(
00473                     const ms_quant_component & component,
00474                     const ms_peptide & peptide) const;
00475
00477             bool hasQuantMethod() const;
00479             const ms_quant_method * getQuantMethod() const;
00480
00482             bool hasCrosslinkingMethod() const;
00484             const ms_crosslinking_method * getCrosslinkingMethod() const;
00485
00487             std::string getCacheFileName() const;
00488
00490             bool isDataCached(BUGFIX_NUM bugNum) const;
00491
00493             virtual bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated = true);
00494
00496             virtual bool isValidQandP(const int q, const int p) const;
00497
00499             bool dumpCDB(const std::string dumpFileName);
00500
00502             void getLibraryEntryId(const int q, const int p, std::vector<int> &dbIdx, std::vector<int> &offset, std::vector<std::string> &checksum, std::vector<std::string> &mods) const;
00503
00505             static double getMinProbabilityForSLScore(double score);
00506
00508             static double getSLThresholdFromMinProbability(double minProbability);
00509
00511             std::vector<int> getPeptideAmbiguityRanks(const int q, const int p);
00512
00513         protected:
00514             // Not safe to copy or assign this object.
00515 #ifndef SWIG
00516             ms_peptidesummary(const ms_peptidesummary & rhs);
00517             ms_peptidesummary & operator=(const ms_peptidesummary & rhs);
00518 #endif
00519
00520             virtual bool queryHasSignificantRank1Match(ms_mascotresfile::section secSummary,
00521                                                        int query) const;
00522
00523             double       getFirstPassRank1Score(int query, bool decoy) const;
00524
00525             virtual bool getThresholdForFDR(bool homology, double targetFDR,
00526                     DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType,
00527                     double * closestFDR, double * minProbability,
00528                     int * pNumTargetMatches, int * pNumDecoyMatches);
00529             void calculateDecoyStats(double dOneInXprobRnd);
00530             virtual void getQmatchValuesFromCacheFile(const QMATCH_PLUGHOLE_INDEX_SECTIONS index) const;
00531             virtual void getPlugholeValuesFromCacheFile(const QMATCH_PLUGHOLE_INDEX_SECTIONS index) const;
00532             virtual ms_mascotresfile::section getSrcSectionProtected(const int query, const int rank) const;
00533
00534             virtual bool cacheModificationCounts();
00535
00536         private:
00537
00538             ms_errs* getLogger() const;
00539
00540             static ms_mascotresults_params getValidatedResultsParameters(const ms_mascotresfile &resfile, const ms_mascotresults_params &params,
00541                                                                          double * minProbabilityForCache = 0);
00542
00543             void initialise(const ms_mascotresults_params& parameters, double minProbabilityForCache);
00544
00545             void loadQuery(int q, std::vector<ms_peptide*> &peptides,
00546                     int rankStart, int rankEnd,
00547                     ms_mascotresfile::section secPeptides,
00548                     ms_mascotresfile::section secPeptidesCompanion);
00549
00550             void accumulateSameSequenceScores(int q, const std::vector<ms_peptide*> &peptides,
00551                     std::vector< std::pair<double, double> > *observed_rank_1_same_seq,
00552                     std::vector<double> *library_rank_1_scores) const;
00553
00554             void determineFirstPassSignificance(const std::vector<ms_peptide*> &peptides,
00555                     ms_mascotresfile::section secSummary,
00556                     std::vector<bool> &queryHasSignificantFirstPass,
00557                     std::vector<double> &memoFirstPassRank1Score) const;
00558
00559             void detectChimericDuplicates(const std::list<int> &query_set,
00560                     const std::vector<ms_peptide*> &peptides,
00561                     std::set<int> &is_chimeric_duplicate) const;
00562             void massageQuery(int q, std::vector<ms_peptide*> &peptides,
00563                     ms_mascotresfile::section secPeptides,
00564                     ms_mascotresfile::section secPeptidesCompanion,
00565                     std::vector<unsigned short> &srcRank,
00566                     const std::set<int> &is_chimeric_duplicate,
00567                     bool load_proteins);
00568             void determinePrettyRanksAndAmbiguityGroupIds(const int q, std::vector<ms_peptide*> &peptides);
00569             void loadIonsScoresIntoCache(const bool decoy, const int p=1);
00570
00571             ms_peptide * loadPepRes(const ms_mascotresfile::section sec,
00572                                     int q, int srcRank, int p,
00573                                     msparser_internal::ms_peptide_impl_reloadable * * pReloadable = 0,
00574                                     bool *canLoadIntoProteins = 0);
00575
00576             typedef struct {
00577                 std::string primaryNlStr;
00578                 std::string substStr;
00579                 std::string componentStr;
00580                 std::string summedModsStr;
00581                 std::string summedModsNlStr;
00582                 std::string localModsStr;
00583                 std::string parsedLocalModsStr;
00584                 std::string localModsNlStr;
00585                 std::string monoLinkStr;
00586                 ms_linker_site_vector loopLinks;
00587             } qp_attribute_lines_t;
00588
00589             struct psm_seq_attributes_t {
00590                 psm_seq_attributes_t()
00591                     : mrCalc(0.0)
00592                     , missedCleavages(-1)
00593                     , peptideStr()
00594                     , varModsStr()
00595                     {}
00596                 double mrCalc;
00597                 int missedCleavages;
00598                 std::string peptideStr, varModsStr;
00599             };
00600
00601             void loadAdditionalMatchAttributes(const ms_mascotresfile::section sec,
00602                                                const int q, const int srcRank,
00603                                                const ms_peptide::PSM psmComponent,
00604                                                const std::string &varModsStr,
00605                                                qp_attribute_lines_t &lines) const;
00606
00607             int loadPepResCharge(const ms_mascotresfile::section chargeSection, int q) const;
00608
00609             ms_peptide * loadPepResLinear(const ms_mascotresfile::section sec,
00610                                          int q, int srcRank, int p,
00611                                          double observed,
00612                                          ms_peptide::SEARCH_PHASE searchPhase,
00613                                          msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
00614                                          bool *canLoadIntoProteins,
00615                                          bool &etOK);
00616             ms_peptide * loadPepResCrossLinked(const ms_mascotresfile::section sec,
00617                                                int q, int srcRank, int p,
00618                                                double observed,
00619                                                ms_peptide::SEARCH_PHASE searchPhase,
00620                                                msparser_internal::ms_peptide_impl_reloadable * * pReloadable,
00621                                                bool *canLoadIntoProteins,
00622                                                bool &etOK);
00623
00624             bool loadCrossLinkedSequenceData(const int q,
00625                                              const int srcRank,
00626                                              const ms_mascotresfile::section sec,
00627                                              const std::string &str,
00628                                              const ms_peptide::PSM psmComponent,
00629                                              psm_seq_attributes_t &seq,
00630                                              qp_attribute_lines_t &attributeLines) const;
00631
00632             ms_linker_site parseLinkerSite(const int q,
00633                                            const int srcRank,
00634                                            const ms_mascotresfile::section sec,
00635                                            const int alphaVarModsLen,
00636                                            const int betaVarModsLen) const;
00637             bool parseLinkedSiteTriplet(const int q,
00638                                         const int srcRank,
00639                                         const ms_mascotresfile::section sec,
00640                                         const std::string &str,
00641                                         const int alphaVarModsLen,
00642                                         const int betaVarModsLen,
00643                                         ms_peptide::PSM &psmComponent,
00644                                         int &pos,
00645                                         int &varmodIdx) const;
00646
00647             bool parseLoopLinkedSites(const int q,
00648                                       const int srcRank,
00649                                       const ms_mascotresfile::section sec,
00650                                       const std::string &loopLinkedSitesStr,
00651                                       const ms_peptide::PSM psmComponent,
00652                                       const std::string &varModsStr,
00653                                       ms_linker_site_vector &loopLinks) const;
00654
00655             void determineSortingScore(ms_peptide *pep) const;
00656             void loadIntoProteins(const ms_mascotresfile::section sec,
00657                                   int q, int srcRank, int p,
00658                                   double ionsScore,
00659                                   acc_dbidx_set_t * pAccessions,
00660                                   bool isIgnored);
00661
00662             typedef std::pair<acc_dbidx_t, msparser_internal::ms_SEQINFO> acc_dbidx_match_tuple_t;
00663             typedef std::list<acc_dbidx_match_tuple_t> acc_dbidx_tuple_list_t;
00664
00665             void gatherProteinMatchData(acc_dbidx_tuple_list_t &proteinInputOrder,
00666                                         const ms_mascotresfile::section sec,
00667                                         std::string str,
00668                                         const int q, const int srcRank, const int p,
00669                                         const ms_peptide::PSM thisPsmComponent,
00670                                         const ms_peptide::SEARCH_PHASE searchPhase,
00671                                         const acc_dbidx_set_t * pAccessions);
00672             void insertIntoProtein(const int q,
00673                                    const int p,
00674                                    const std::string &accession,
00675                                    const int dbIdx,
00676                                    const msparser_internal::ms_protein_match_data &proteinMatchData,
00677                                    const ms_peptide::SEARCH_PHASE searchPhase,
00678                                    const double ionsScore,
00679                                    const bool isIgnored);
00680
00681             double minIonsScoreForMatch(const int q,
00682                                         const ms_mascotresfile::section sec) const;
00683             int               singleHitDbIdx_;
00684
00685             struct componentIdentifier_t {
00686                 int q_;
00687                 short p_;
00688                 short componentID_;
00689                 componentIdentifier_t(int q, short p, short cid) : q_(q), p_(p), componentID_(cid) { };
00690                 componentIdentifier_t(const std::string & q, const std::string & p, const std::string & componentID);
00691                 std::string asString() const;
00692                 bool operator<(const componentIdentifier_t & right) const;
00693              };
00694             typedef std::map<componentIdentifier_t, std::pair<double, double> > componentIntensities_t;
00695             componentIntensities_t cachedComponentIntensities_;
00696             bool cacheComponentIntensities(bool & isUsable);
00697             typedef std::map<std::string, short> componentNames_t;
00698             componentNames_t componentNames_;
00699             bool componentIntensitiesLoaded_;
00700
00701             bool isPeptideModificationMatch(
00702                     const ms_quant_modgroup &group,
00703                     const std::string &varModStr,
00704                     const std::string &summedModStr,
00705                     const std::vector<int> &slModifiedPositions,
00706                     const std::string &pepStr,
00707                     const bool isAnyProteinNterminus,
00708                     const bool isAnyProteinCterminus) const;
00709
00710             // Some private variables and functions for error tolerant search
00711             bool checkErrorTolerantStatus(ms_mascotresfile::section sec,
00712                                           int q, int p, double ionsScore,
00713                                           bool fromET,
00714                                           const std::string & pepStr);
00715             const ms_mascotresfile  * errTolSource_;
00716             const ms_peptidesummary * errTolPepSummary_;
00717             unsigned int        errTolType_;
00718             bool                missingErrTolParent_;
00719             bool                acceptAllErrTolMatches_;
00720
00721             std::vector<bool>   queryHasSignificant1stPassTarget_, queryHasSignificant1stPassDecoy_;
00722             mutable std::vector<double> memoFirstPassRank1ScoreTarget_, memoFirstPassRank1ScoreDecoy_;
00723
00724             ms_mascotresfile::section secPeptidesInactive_, secPeptidesActiveCompanion_, secPeptidesInactiveCompanion_;
00725             std::vector<unsigned short> srcRankActiveSection_, srcRankInactiveSection_;
00726             bool srcRankInitialised_;
00727
00728             bool rerankingCouldHappen() const;
00729
00730             void setSrcRank(int q, int p, int srcRank, ms_mascotresfile::section peptideSec, bool rejected, std::vector<unsigned short> &srcRankVec) const;
00731             int getSrcRank(int q, int p, ms_mascotresfile::section & peptideSec, bool * pRejected = 0, bool inactiveSection = false) const;
00732             enum PEP_SECTIONS { PEP_SEC_INVALID         = 0,
00733                                 PEP_SEC_PEPTIDES        = 1,
00734                                 PEP_SEC_DECOYPEPTIDES   = 2,
00735                                 PEP_SEC_ERRTOLPEPTIDES  = 3,
00736                                 // Do not ever add more enums here. Maximum is 4.
00737                                 PEP_SEC_LAST            = 4};
00738             // For each of these, use SR_MASK_ and then, if required, >> SR_SHIFT_
00739             enum SRC_RANK_MASKS { SR_MASK_RANK      = 0x0F,  // bits 0..3
00740                                   SR_MASK_SEC       = 0x30,  // bits 4..5
00741                                   SR_MASK_REJECT    = 0x40,  // bit  6     If discarded because below threshold or other rule
00742                                   SR_MASK_LIBRARY   = 0x80,  // bit  7
00743
00744                                   SR_MASK_CROSSLINK = 0x0100, // bit  8 (bit 1 in upper 8 bits)
00745                                   SR_MASK_ERRTOL    = 0x0200, // bit  9 (bit 2 in upper 8 bits)
00746
00747                                   SR_SHIFT_RANK     = 0x00,  // bits 0..3 - no need to shift
00748                                   SR_SHIFT_SEC      = 0x04,  // bits 4..5
00749                                   SR_SHIFT_REJECT   = 0x06,  // bit  6     If discarded because below threshold or other rule
00750                                   SR_SHIFT_LIBRARY  = 0x07,  // bit  7
00751
00752                                   SR_SHIFT_CROSSLINK = 0x08, // bit  8 (bit 1 in upper 8 bits)
00753                                   SR_SHIFT_ERRTOL    = 0x09  // bit  9 (bit 2 in upper 8 bits)
00754                                   };
00755             unsigned char secLookupFwd_[ms_mascotresfile::SEC_NUMSECTIONS];
00756             int secLookupRev_[PEP_SEC_LAST];
00757
00758             void getUnassignedListAsString(std::string & str);
00759             bool findCompareProtein(const std::string & accRequired,
00760                                     const std::string & accToTest,
00761                                     const int dbIdxRequired,
00762                                     const int dbIdxToTest,
00763                                     FIND_FLAGS item,
00764                                     FIND_COMPARE_FLAGS compareFlags,
00765                                     const ms_protein * prot,
00766                                     const std::vector<int> & q,
00767                                     const std::vector<int> & p) const;
00768             bool findCompare(const std::string & find,
00769                              const std::string & findIn,
00770                              FIND_COMPARE_FLAGS compareFlags) const;
00771             bool findCompare(const double find_value,
00772                              const double find_range,
00773                              const double value,
00774                              FIND_COMPARE_FLAGS compareFlags) const;
00775
00776             struct distanceInfo_t {
00777                 double scoreExcess;
00778                 std::string peptideStr;
00779                 bool isFromLibrary;
00780                 distanceInfo_t():
00781                     scoreExcess(0.0), peptideStr(), isFromLibrary(false)
00782                 {}
00783                 distanceInfo_t(double se, std::string & pep, bool fromLib):
00784                     scoreExcess(se), peptideStr(pep), isFromLibrary(fromLib)
00785                 {}
00786             };
00787             typedef std::map<std::pair<int, int>, distanceInfo_t> distanceInfoMap_t;
00788             double getDistance(const distanceInfoMap_t & a, const distanceInfoMap_t & b) const;
00789             bool readPercolatorOutputFile(bool decoyResults,
00790                                           ms_percolator_scores_vector * pVector = 0,
00791                                           long * pNumAboveIdentity = 0,
00792                                           double threshold = 0.05);
00793
00794             typedef std::set<std::pair<int,int> > hitAndFamily_t;
00795             bool getHitAndFamilyMember(const ms_protein * prot, hitAndFamily_t & hitAndFamily, const UNIQUE_PEP_RULES rules) const;
00796
00797             ms_percolator_scores_vector targetPercolatorScores_;
00798             ms_percolator_scores_vector decoyPercolatorScores_;
00799
00800             // percolatorScores_ references targetPercolatorScores_ unless
00801             // MSRES_DECOY is specified, in which case it references
00802             // decoyPercolatorScores_
00803             ms_percolator_scores_vector & percolatorScores_;
00804
00805             //BUG#13406
00806             bool usePercolatorQValSigThres_;
00807
00808             msparser_internal::ms_peptidesumcdb * pCacheFile_;
00809             ms_tinycdb  * pTmpCache_;
00810
00811             mutable std::vector< std::vector<double> > cachedScores_[2]; // Use cachedScores_[decoy][p][q]. Order important for performance with FDR
00812             mutable std::vector<bool> attemptedLoadScoresFromCache_[2];  // Use attemptedLoadScoresFromCache_[decoy][p].
00813
00814             /* emPAI related values and helper methods */
00815
00816             bool emPAIminmaxDone_;
00817             int emPAIminCleavageN_;
00818             int emPAImaxCleavageN_;
00819             bool emPAInetCleavageDone_;
00820             double netCleavageAbundance_;
00821
00822             void init_emPAImzRange();
00823             void init_netCleavageAbundance();
00824             double calculate_AA_abundance(std::string) const;
00825             double calculate_emPAI_num_observable(int) const;
00826
00827             mutable std::map<std::string, char> modfileLookup_;
00828             mutable bool quantMethodCached_;
00829             mutable ms_quant_method * quantMethod_;
00830             mutable bool crosslinkingMethodCached_;
00831             mutable ms_crosslinking_method * crosslinkingMethod_;
00832
00833             mutable std::map< std::pair<int, int>, bool > uniquePepLookup_; // only used when no cache file
00834
00835             std::vector<int> parseDBstr(const std::string &strDB, bool &has_fasta_acc, bool &has_sl_ref_acc) const;
00836             void parseMatchAccessionDBTermsLines(const int q,
00837                                                  const int p,
00838                                                  const int srcRank,
00839                                                  const ms_mascotresfile::section sec,
00840                                                  const ms_peptide::PSM thisPsmComponent,
00841                                                  std::string str,
00842                                                  std::vector<std::string> & acc,
00843                                                  std::vector<int> & start,
00844                                                  std::vector<int> & end,
00845                                                  std::vector<std::string> &pre,
00846                                                  std::vector<std::string> &post,
00847                                                  std::vector<int> & frame,
00848                                                  std::vector<int> & multiplicity,
00849                                                  std::vector<int> & db,
00850                                                  std::vector<int> & psmComponent) const;
00851
00852             int addExpectationValue(bool homology, DECOY_STATS_COUNT_TYPE countType, bool decoy, int q,
00853                                      std::map<std::string, size_t> & mapSequenceToIndex, std::vector<structExpectTargetDecoy> & vecExpectTargetDecoy);
00854             double truncateExpectationValue(double dValue, int sigfig);
00855
00856             bool getQPsFromMapValueToQP(const std::string & strSearch, const map_mod_value_to_qp & mapValueToQP, std::set<std::pair<int, int> > & setQP, bool bCaseSensitive = true) const;
00857
00858             void countDBTypes(const std::vector<int> &db, std::vector<int> &counts) const;
00859
00860             std::string getDecoyPeptideString(int q, int p) const;
00861
00862             bool getPeptideFromCache(const int q, const int p, ms_peptide *  & pep) const;
00863
00864             void dumpFlags(std::string fileName);
00865     }; // end of resfile_group
00867 }   // matrix_science namespace
00868
00869 #endif // MS_MASCOTRESPEPTIDESUM_HPP
00870
00871 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresprotein.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotresprotein.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a protein - either for protein summary or peptide summary     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotresprotein.hpp    $ #
00012 #     $Author: robertog@matrixscience.com $ #
00013 #       $Date: 2019-09-26 12:13:39 +0100 $ #
00014 #   $Revision: dfb5ce6a52a298b40097fe6b12c45e552d08f950 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTRESPROTEIN_HPP
00020 #define MS_MASCOTRESPROTEIN_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <list>
00026 #include <vector>
00027 #include <set>
00028 #include <map>
00029
00030 namespace msparser_internal {
00031     class ms_protein_match_data;
00032     class PEPINFO;
00033 }
00034
00035 namespace matrix_science {
00036
00037     class ms_mascotresults;
00038     class ms_proteinsummary;
00039     class ms_pepinfoSortByScore;
00040     class ms_peptide;
00041
00047
00048
00054     class MS_MASCOTRESFILE_API ms_protein
00055     {
00056         public:
00058
00071             enum GROUP
00072             {
00073                 GROUP_UNKNOWN,
00074                 GROUP_NO,
00075                 GROUP_SUBSET,
00076                 GROUP_COMPLETE,
00077                 GROUP_FAMILY
00078             };
00079
00080 #ifdef DUPLICATE
00081     #ifdef _WIN32
00082 //        #pragma message("WARNING: The identifier 'DUPLICATE' was defined but is incompatible with the definition for ms_protein")
00083     #endif
00084     #undef DUPLICATE
00085 #endif
00086
00088
00095             enum DUPLICATE
00096             {
00097                 DUPE_NotDuplicate,
00098                 DUPE_Duplicate,
00099                 DUPE_DuplicateSameQuery,
00100                 DUPE_HighestScoringDuplicate,
00101                 DUPE_Ignored
00102             };
00103
00105
00114             enum MASS_FLAGS
00115             {
00116                 MASS_NON_SELECT_NON_MATCH   = 0x0001,
00117                 MASS_SELECT_NON_MATCH       = 0x0010,
00118                 MASS_NON_SELECT_MATCH       = 0x0100,
00119                 MASS_SELECT_MATCH           = 0x1000
00120             };
00121
00123
00184             enum DISTINCT_PEPTIDE_FLAGS
00185             {
00186                 DPF_SEQUENCE        = 0x0001,
00187                 DPF_CHARGE          = 0x0002,
00188                 DPF_MODS            = 0x0004,
00189                 DPF_UNIQUE          = 0x0008,
00190                 DPF_NODUPSAMEQUERY  = 0x0010
00191             };
00192
00193             // Types for uniquely identifying a protein
00194             typedef std::pair<int, std::string> dbIdxPlusAcc_t;
00195             typedef std::vector<dbIdxPlusAcc_t> dbIdxPlusAccVect_t;
00196             typedef std::set<dbIdxPlusAcc_t>    dbIdxPlusAccSet_t;
00197
00198
00200             ms_protein(const double score,
00201                        const std::string accession,
00202                        const bool updateScoreFromPepScores,
00203                        const int  proteinSummaryHit = 0);
00204
00206             ms_protein(const ms_protein& src);
00207
00209             ~ms_protein();
00210
00211 #ifndef SWIG
00212
00213             ms_protein& operator=(const ms_protein& right);
00214 #endif
00215
00217             void copyFrom(const ms_protein* src);
00218
00220             std::string getAccession() const;
00221
00223             int getDB() const;
00224
00226             void setDB(int dbIdx);
00227
00229             double getScore()          const;
00230
00232             double getNonMudpitScore()     const;
00233
00235             double getScoreWithET() const;
00236
00238             int    getNumPeptides()    const;
00239
00241             int    getNumDisplayPeptides(bool aboveThreshold = false)    const;
00242
00244             GROUP getGrouping() const;
00245
00246 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00247
00248             void setGrouping(GROUP g)         { group_ = g;       }
00249
00251             std::string getForCache(dbIdxPlusAccVect_t & supersetProteinsUnsorted,
00252                                     dbIdxPlusAccVect_t & components) const;
00253
00255             bool setFromCache(const std::string & str, ms_mascotresults & results,
00256                               const dbIdxPlusAccVect_t & supersetProteinsUnsorted,
00257                               const dbIdxPlusAccVect_t & components,
00258                               const std::string & cdbFeatures);
00259
00261             std::vector<std::pair<int, int> > getIgnoredQPs() const;
00262
00264             bool isIgnoredQP(const int q, const int p) const;
00265 #endif
00266
00268             void getIgnoredQPs(std::vector<int> &q, std::vector<int> &p) const;
00269
00271             int    getPeptideQuery         (const int   pepNumber) const;
00272
00274             int    getPeptideP             (const int   pepNumber) const;
00275
00277             int getPepNumber(const int q, const int p) const;
00278
00280             int    getPeptideFrame         (const int   pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00281
00283             long   getPeptideStart         (const int   pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00284
00286             long   getPeptideEnd           (const int   pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00287
00289             long   getPeptideMultiplicity  (const int   pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00290
00292             DUPLICATE getPeptideDuplicate  (const int   pepNumber, const bool allowErrTolDuplicate = true) const;
00293
00295             double getPeptideIonsScore     (const int   pepNumber) const;
00296
00298             bool   getPeptideIsBold        (const int   pepNumber) const;
00299
00301             void   setPeptideIsBold        (const int   pepNumber);
00302
00304             bool   getPeptideShowCheckbox  (const int   pepNumber) const;
00305
00307             void   setPeptideShowCheckbox  (const int   pepNumber);
00308
00310             int    getPeptideComponentID   (const int   pepNumber) const;
00311
00313             char   getPeptideResidueBefore (const int   pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00314
00316             char   getPeptideResidueAfter  (const int   pepNumber, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00317
00319             bool isASimilarProtein(const ms_protein       * prot,
00320                                    const ms_mascotresults * results,
00321                                    const bool groupByQueryNumber = false);
00322
00324             std::string getSimilarProteinName() const;
00325
00327             int getSimilarProteinDB() const;
00328
00330             bool isSimilarProtein(const std::string & acc, const int dbIdx) const;
00331
00333             int getSimilarProteins(std::vector<std::string> & accessions, std::vector<int> & dbIdxs) const;
00334
00336             void setSimilarProtein(const ms_protein * prot);
00337
00340             void addOnePeptide(      ms_mascotresults & results,
00341                                const int q, const int p,
00342                                const msparser_internal::ms_protein_match_data &proteinMatchData,
00343                                const double correctedScore,
00344                                const double uncorrectedScore,
00345                                const ms_protein * component,
00346                                const ms_peptide::SEARCH_PHASE searchPhase,
00347                                const bool isIgnored);
00348
00349
00351             long getCoverage() const;
00352
00354             bool anyMatchToQuery(const int query) const;
00355
00357             bool anyMatchToQueryAndP(const int query, const int P) const;
00358
00360             std::string getUnmatchedMasses(ms_mascotresfile & resfile,
00361                                            const int numDecimalPlaces = 2) const;
00362
00364             std::string getMasses(ms_mascotresfile & resfile,
00365                                   const ms_proteinsummary & summary,
00366                                   const unsigned int flags = MASS_SELECT_MATCH,
00367                                   const int numDecimalPlaces = 2) const;
00368
00370             int getFrame() const;
00371
00373             bool anyBoldRedPeptides(const ms_mascotresults & results) const;
00374
00376             bool isUnigene() const;
00377
00379             void setIsUnigeneEntry();
00380
00382             bool isPMFMixture() const;
00383
00385             void setIsPMFMixture();
00386
00388             void sortPeptides(const ms_mascotresults & results, bool keepAlive = false, int keepAlivePercent = 0, const char * keepAliveAccession = "", int keepAliveCount = 0);
00389
00391             int getNumComponents() const;
00392
00394             const ms_protein * getComponent(const int componentNumber) const;
00395
00397             int getProteinSummaryHit() const;
00398
00400             double getRMSDeltas(const ms_mascotresults & results) const;
00401
00403             int getHitNumber() const;
00404
00411             void setHitNumber(const int hit) { hitNum_ = hit;}
00412
00414             int getMemberNumber() const;
00415
00417             int getLongestPeptideLen() const;
00418
00420             int getNumDistinctPeptides(bool aboveThreshold = false,
00421                                        DISTINCT_PEPTIDE_FLAGS flags = DPF_SEQUENCE) const;
00422
00424             int getNumDistinctPeptideRepeats(
00425                     int distinctIndex, // 1..getNumDistinctPeptides
00426                     bool aboveThreshold = false,
00427                     DISTINCT_PEPTIDE_FLAGS flags = DPF_SEQUENCE) const;
00428
00430             ms_peptide getDistinctPeptide(
00431                     int distinctIndex, // 1..getNumDistinctPeptides
00432                     int repeatIndex = 1, // 1..getNumDistinctPeptideRepeats
00433                     bool aboveThreshold = false,
00434                     DISTINCT_PEPTIDE_FLAGS flags = DPF_SEQUENCE) const;
00435
00437             int getLongestSigPeptideLen() const;
00438
00440             int getNumObservedForEmPAI() const;
00441 #ifndef SWIG
00442
00443
00452             friend inline bool operator<(const ms_protein & lhs, const ms_protein & rhs) {
00453                 if (lhs.dbIdx_ == rhs.dbIdx_) {
00454                     if ( lhs.proteinSummaryHit_ == 0 ) {
00455                         return lhs.accession_ < rhs.accession_;
00456                     } else { // i.e ms_proteinsummary - see parser bug 493
00457                         if ( lhs.accession_ == rhs.accession_) {
00458                             return lhs.getFrame() < rhs.getFrame();
00459                         } else {
00460                             return lhs.accession_ < rhs.accession_;
00461                         }
00462                     }
00463                 } else {
00464                     return lhs.dbIdx_ < rhs.dbIdx_;
00465                 }
00466             }
00467 #endif
00468             // Undocumented function for fast access
00469             const char * getAccessionStr() const { return accession_.c_str(); }
00470
00471         private:
00472             void initialiseDistinctPeptideTree(
00473                     bool  aboveThreshold,
00474                     DISTINCT_PEPTIDE_FLAGS flags) const;
00475
00476             ms_errs* getErrorHandler() const;
00477
00478             // --- Start of uncached variables
00479             mutable std::vector<msparser_internal::PEPINFO *> peptides_; // sort by query
00480             mutable std::vector<msparser_internal::PEPINFO *> ignoredPeptides_;
00481             mutable std::vector<msparser_internal::PEPINFO>   allPeptides_;
00482
00483             ms_mascotresults * results_;
00484 //          bool loadedFromCache_;
00485             // --- End of uncached variables
00486
00487             // Start of all cached variables
00488             unsigned char    flags_; // See FL_... not all bits are cached
00489
00490             int numPeptides_;  // Only used if loadedFromCache_ is true - otherwise peptides_.size();
00491             mutable int numDisplayPeptides_;
00492             mutable int numDisplayPeptidesAboveThresh_;
00493             mutable int numDistinctPeptides_;
00494             mutable int numDistinctPeptidesAboveThresh_;
00495             mutable int numDistinctUniquePeptides_;
00496             mutable int numDistinctUniqPepAboveThresh_;
00497             mutable int lenLongestPeptideAboveThresh_;
00498             mutable int numObservedForEmPAI_;
00499             mutable int frame_;
00500             mutable bool distinctPeptideAboveThreshold_;
00501             mutable DISTINCT_PEPTIDE_FLAGS distinctPeptideFlags_;
00502             mutable std::list<std::list<ms_peptide*> > distinctPeptideTree_;
00503             dbIdxPlusAccSet_t  supersetProteins_;  // This one is filled when loading from cache
00504             dbIdxPlusAccVect_t supersetProteinsUnsorted_;
00505
00506             // For unignene and PMF mixture, the protein is really a 'pseudo'
00507             // protein, made up from a number of 'real' proteins
00508             dbIdxPlusAccVect_t components_;
00509
00510             std::string accession_;
00511             int dbIdx_;
00512             double score_;
00513             double nonMudPITScore_;
00514             double scoreWithET_;
00515             GROUP group_;
00516             int proteinSummaryHit_;
00517             int hitNum_;
00518             mutable int memberNum_;
00519             int longestPeptideLen_;         // Useful with minPepLenInPepSummary
00520             mutable long coverage_;
00521 //          bool pmfMixture_;               // True if protein actually originates from a PMF mixture
00522 //          bool sorted_;                   // Sorting the list of peptides is expensive - don't repeat...
00523 //          bool unigene_;                  // For unigene, we need to get the description line from the unigene file
00524 //          bool updateScoreFromPepScores_; // For protein summary, the protein score is calculated by
00525                                             // nph-mascot.exe, and is in the results file. For the
00526                                             // peptide summary, the score is calculated by adding the ions
00527                                             // scores
00528
00529             // Functions
00530             void copyPeptidePointers(std::vector<msparser_internal::PEPINFO *> &pointersTo, const std::vector<msparser_internal::PEPINFO *> &pointersFrom, const ms_protein *src);
00531             void checkFromCache(const char * calledBy) const;
00532             void checkQPFromCache(const char * calledBy) const;
00533             bool isFlagSet(unsigned char fl) const { return (flags_ & fl)?true:false; }
00534             void setFlag(unsigned char fl, bool val) {
00535                 if (val) {
00536                     flags_ |= fl;
00537                 } else {
00538                     //the standard says that complement must promote to an int... there is no performance difference though
00539                     flags_ = static_cast<unsigned char>(flags_ & ~fl);
00540                 }
00541             }
00542
00543             static bool isVarModStrEmpty(const std::string &str);
00544
00545             friend class prot_sort;
00546             friend class ms_pepinfoSortByScore;
00547     };
00548 #ifndef SWIG
00549     // Helper class - don't use from outside library
00550     class ms_proteinPtrSortByAccession
00551     {
00552         public:
00553             bool operator() (const ms_protein * p1, const ms_protein * p2) const {
00554                 return (*p1 < *p2);
00555             }
00556     };
00557
00558     class ms_proteinPtrSortByScore
00559     {
00560         public:
00561             bool operator() (const ms_protein * p1, const ms_protein * p2) const {
00562                 if (p1->getScore() != p2->getScore()) {
00563                     return (p1->getScore() > p2->getScore());
00564                 } else {
00565                     return (*p1 < *p2);
00566                 }
00567             }
00568     };
00569
00570
00571     class ms_pepinfoSortByScore
00572     {
00573     public:
00574         ms_pepinfoSortByScore(std::pair<bool, bool> pairParam): removeDiffPos_(pairParam.first), anyLibraryMatches_(pairParam.second) { }
00575         bool operator() (const msparser_internal::PEPINFO * p1, const msparser_internal::PEPINFO * p2) const;
00576         ms_pepinfoSortByScore(const ms_pepinfoSortByScore& other): removeDiffPos_(other.removeDiffPos_), anyLibraryMatches_(other.anyLibraryMatches_){}
00577         ms_pepinfoSortByScore& operator=(const ms_pepinfoSortByScore& other)
00578         {
00579             if (&other != this) {
00580                 removeDiffPos_ = other.removeDiffPos_;
00581                 anyLibraryMatches_ = other.anyLibraryMatches_;
00582             }
00583             return *this;
00584         }
00585
00586     private:
00587         bool removeDiffPos_;
00588         bool anyLibraryMatches_;
00589     };
00590
00591 #endif
00592  // end of resfile_group
00593 }   // matrix_science namespace
00594
00595 #endif // MS_MASCOTRESPROTEIN_HPP
00596
00597 /*------------------------------- End of File -------------------------------*/
00598
00599
00600
00601
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresproteinsum.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotresproteinsum.cpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the protein summary report from the mascot results file       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2002 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespr $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2021-01-14 15:39:42 +0000 $ #
00014 #   $Revision: 3df1effe4b9d5696c343804b398ed8a5afaaffce | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTRESPROTEINSUM_HPP
00020 #define MS_MASCOTRESPROTEINSUM_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025
00026
00027 namespace matrix_science {
00028     class ms_mascotresults_parameters;
00029
00041     class MS_MASCOTRESFILE_API ms_proteinsummary : public ms_mascotresults
00042     {
00043         public:
00045             ms_proteinsummary(const ms_mascotresfile  &resfile,
00046                 const unsigned int flags = ms_mascotresults::MSRES_GROUP_PROTEINS
00047                                          | ms_mascotresults::MSRES_SHOW_SUBSETS,
00048                               double             minProbability = 0.0,
00049                               int                maxHitsToReport = 50,
00050                               const char *       unigeneIndexFile = 0,
00051                               const char *       singleHit = 0);
00052
00054             ms_proteinsummary(const ms_mascotresfile &resfile,
00055                               const ms_mascotresults_params & parameters);
00056
00057             virtual ~ms_proteinsummary();
00058
00060             virtual ms_peptide getPeptide(const int q, const int p) const;
00061
00063             virtual double getIonsScore(const int q, const int p, const bool decoy) const;
00064
00066             virtual bool isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules = UPR_DEFAULT) const;
00067
00069             virtual bool getPeptide(const int q, const int p, ms_peptide * & pep) const;
00070
00072             virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false);
00073
00075             virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
00076                                                                             std::vector<int> & start,
00077                                                                             std::vector<int> & end,
00078                                                                             std::vector<std::string> &pre,
00079                                                                             std::vector<std::string> &post,
00080                                                                             std::vector<int> & frame,
00081                                                                             std::vector<int> & multiplicity,
00082                                                                             std::vector<int> & db) const;
00083
00085             virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
00086                                                                             std::vector<int> & start,
00087                                                                             std::vector<int> & end,
00088                                                                             std::vector<std::string> &pre,
00089                                                                             std::vector<std::string> &post,
00090                                                                             std::vector<int> & frame,
00091                                                                             std::vector<int> & multiplicity,
00092                                                                             std::vector<int> & db,
00093                                                                             std::vector<int> & psmComponent) const;
00094
00096             virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
00097                                                             const int q,
00098                                                             const int p,
00099                                                             std::vector< int >& db,
00100                                                             std::vector< std::string >& acc,
00101                                                             std::vector< int >& dupe_status) const;
00102
00103
00105             virtual std::string getErrTolModString(const int q, const int p) const;
00106
00108             virtual std::string getLibraryModString(const int q, const int p) const;
00109
00111             virtual std::string getErrTolModMasterString(const int q, const int p) const;
00112
00114             virtual std::string getErrTolModSlaveString(const int q, const int p) const;
00115
00117             virtual std::string getErrTolModPepString(const int q, const int p) const;
00118
00120             virtual std::string getErrTolModReqPepString(const int q, const int p) const;
00121
00123             virtual std::string getTagString(const int q, const int p) const;
00124
00126             virtual int getTagDeltaRangeStart(const int q, const int p) const;
00127
00129             virtual int getTagDeltaRangeEnd(const int q, const int p) const;
00130
00132             virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00133
00135             virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00136
00138             virtual int getProteinScoreCutoff(double OneInXprobRnd) const;
00139
00141             int    getNumPmfQueriesUsed() const;
00142
00144             bool   isPmfQueryUsed(const int queryIdx) const;
00145
00147             virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const;
00148 #ifndef SWIG
00149
00150             virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const;
00151 #else // SWIG Multiple return values
00152             virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const;
00153 #endif
00154
00155             virtual bool isValidQandP(const int q, const int h) const;
00156
00158             virtual QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
00159                     const matrix_science::ms_peptide & peptide,
00160                     matrix_science::ms_quant_component & component,
00161                     const matrix_science::ms_quant_method * method = NULL) const;
00162
00163         protected:
00164             // Not safe to copy or assign this object.
00165             ms_proteinsummary(const ms_proteinsummary & rhs);
00166 #ifndef SWIG
00167             ms_proteinsummary & operator=(const ms_proteinsummary & rhs);
00168 #endif
00169
00170             virtual bool queryHasSignificantRank1Match(ms_mascotresfile::section secSummary,
00171                                                        int query) const;
00172
00173             virtual void calculateDecoyStats( double dOneInXprobRnd);
00174             virtual bool getThresholdForFDR(bool homology, double targetFDR,
00175                     DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType,
00176                     double * closestFDR, double * minProbability,
00177                     int * pNumTargetMatches, int * pNumDecoyMatches);
00178
00180             virtual int findProteins(const int startHit,
00181                                      const std::string & str,
00182                                      const int dbIdx,
00183                                      FIND_FLAGS item,
00184                                      FIND_COMPARE_FLAGS compareFlags,
00185                                      std::vector<std::string> & accessions,
00186                                      std::vector<int> & dbIndexes) const;
00187
00189             virtual int findProteinsByAccession(const int startHit,
00190                                                 const std::string & str,
00191                                                 const int dbIdx,
00192                                                 FIND_COMPARE_FLAGS compareFlags,
00193                                                 std::vector<std::string> & accessions,
00194                                                 std::vector<int> & dbIndexes) const;
00195
00197             virtual int findProteinsByDescription(const int startHit,
00198                                                   const std::string & str,
00199                                                   FIND_COMPARE_FLAGS compareFlags,
00200                                                   std::vector<std::string> & accessions,
00201                                                   std::vector<int> & dbIndexes) const;
00202
00204             virtual int findPeptides(const int startHit,
00205                                      const std::string & str,
00206                                      FIND_FLAGS item,
00207                                      FIND_COMPARE_FLAGS compareFlags,
00208                                      std::vector<int> & q,
00209                                      std::vector<int> & p) const;
00210
00211             virtual bool cacheModificationCounts();
00212
00213         private:
00214             void initialise();
00215             bool parseProtein(const int hit);
00216             void loadPepRes(const int hit,
00217                             const int dbIdx,
00218                             std::string & accession,
00219                             const int frame);
00220             void addMixtureHits();
00221             int singleHitAsInt_;
00222             ms_peptide emptyPeptide_;
00223
00224             bool         isPmfRanks_;
00225             int          numPmfQueriesUsed_;
00226             std::vector<int> pmfQueriesUsed_;
00227             int          numPmfHitsPreserved_;
00228
00229     }; // end of resfile_group
00231 }   // matrix_science namespace
00232
00233 #endif // MS_MASCOTRESPROTEINSUM_HPP
00234
00235 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresults.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotresults.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Abstract class for either ms_peptidesummary or ms_proteinsummary           #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresul $ #
00012 #     $Author: robertog@matrixscience.com $ #
00013 #       $Date: 2021-06-11 12:37:42 +0100 $ #
00014 #   $Revision: 648c718df8892c870480b014ac4e78d375583334 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MASCOTRESULTS_HPP
00020 #define MS_MASCOTRESULTS_HPP
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <list>
00026 #include <vector>
00027 #include <set>
00028 #include <map>
00029 #include <algorithm>
00030
00031 namespace msparser_internal {
00032     class ms_proteininference;
00033     class ms_unassigned;
00034     class ms_peptidesumcdb;
00035     class ms_protein_match_data;
00036 }
00037
00038 namespace matrix_science {
00044     class ms_unigene;
00045     class ms_protein;
00046     class ms_peptide;
00047     class ms_mascotresfile;
00048     class ms_quant_component;
00049     class ms_mascotresults_params;
00050
00051 #ifndef SWIG
00052
00053     struct LexicoCompare
00054     {
00055         bool caseSensitive_;
00056         LexicoCompare(bool caseSensitive) : caseSensitive_(caseSensitive) { }
00057         bool operator()(const std::string& left, const std::string& right ) const;
00058     };
00059 #endif
00060
00062
00079     class MS_MASCOTRESFILE_API ms_mascotresults
00080     {
00081         friend class ms_protein;
00082         friend class msparser_internal::ms_proteininference;
00083         friend class msparser_internal::ms_peptidesumcdb;
00084
00085         public:
00086
00088
00095             enum FLAGS
00096             {
00097
00098                 MSRES_NOFLAG                    = 0x00000000,
00099                 MSRES_GROUP_PROTEINS            = 0x00000001,
00100                 MSRES_SHOW_SUBSETS              = 0x00000002,
00101                 MSRES_SUBSETS_DIFF_PROT         = 0x00000004,
00102                 MSRES_REQUIRE_BOLD_RED          = 0x00000008,
00103                 MSRES_SHOW_ALL_FROM_ERR_TOL     = 0x00000010,
00104                 MSRES_IGNORE_PMF_MIXTURE        = 0x00000020,
00105                 MSRES_MUDPIT_PROTEIN_SCORE      = 0x00000040,
00106                 MSRES_DECOY                     = 0x00000080,
00107                 MSRES_INTEGRATED_ERR_TOL        = 0x00000100,
00108                 MSRES_ERR_TOL                   = 0x00000200,
00109                 MSRES_MAXHITS_OVERRIDES_MINPROB = 0x00000400,
00110                 MSRES_CLUSTER_PROTEINS          = 0x00000800,
00111
00112                 MSRES_DUPE_INCL_IN_SCORE_NONE   = 0x00000000,
00113                 MSRES_DUPE_INCL_IN_SCORE_A      = 0x00002000,
00114                 MSRES_DUPE_INCL_IN_SCORE_B      = 0x00004000,
00115                 MSRES_DUPE_INCL_IN_SCORE_C      = 0x00008000,
00116                 MSRES_DUPE_INCL_IN_SCORE_D      = 0x00010000,
00117                 MSRES_DUPE_INCL_IN_SCORE_E      = 0x00020000,
00118                 MSRES_DUPE_INCL_IN_SCORE_F      = 0x00040000,
00119                 MSRES_DUPE_INCL_IN_SCORE_G      = 0x00080000,
00120                 MSRES_DUPE_INCL_IN_SCORE_H      = 0x00100000,
00121                 MSRES_DUPE_INCL_IN_SCORE_I      = 0x00200000,
00122                 MSRES_DUPE_REMOVE_NONE          = 0x00400000,
00123                 MSRES_DUPE_REMOVE_A             = 0x00800000,
00124                 MSRES_DUPE_REMOVE_B             = 0x01000000,
00125                 MSRES_DUPE_REMOVE_C             = 0x02000000,
00126                 MSRES_DUPE_REMOVE_D             = 0x04000000,
00127                 MSRES_DUPE_REMOVE_E             = 0x08000000,
00128                 MSRES_DUPE_REMOVE_F             = 0x10000000,
00129                 MSRES_DUPE_REMOVE_G             = 0x20000000,
00130                 MSRES_DUPE_REMOVE_H             = 0x40000000,
00131     #ifndef SWIG // 'live' version for C++ compiler
00132                 MSRES_DUPE_REMOVE_I             = 0x80000000,
00133     #else // SWIG version
00134                 // The C# 'unchecked' keyword is only used when generating C# bindings.
00135                 MSRES_DUPE_REMOVE_I             = unchecked((int)0x80000000),
00136     #endif
00137                 MSRES_DUPE_DEFAULT              = 0x04800000
00138             };
00139
00141
00144             enum sortBy
00145             {
00146                 QUERY,
00147                 SCORE,
00148                 INTENSITY
00149
00150             };
00151
00160             enum dupeStatus
00161             {
00162                 dupe_query_same = 0x0001,
00163                 dupe_seq_same   = 0x0002,
00164                 dupe_mods_same  = 0x0004,
00165                 dupe_pos_same   = 0x0008,
00166
00167                 // Bug 13818: Conceptually different to the other duplicate statuses.
00168                 // Used to indicate if all the components (alpha and beta in a crosslinked match)
00169                 // are in the same protein.
00170                 dupe_protein_same  = 0x0010
00171             };
00172
00174
00177             enum TREE_CLUSTER_METHOD
00178             {
00179                 TCM_FIRST_VALUE       = 0x0001, // For looping - undocumented
00180                 TCM_PAIRWISE_SINGLE   = 0x0001,
00181                 TCM_PAIRWISE_MAXIMUM  = 0x0002,
00182                 TCM_PAIRWISE_AVERAGE  = 0x0003,
00183
00184                 TCM_LAST_VALUE        = 0x0003  // For looping - undocumented
00185             };
00186
00188
00195             enum FIND_FLAGS
00196             {
00197                 FT_PEPTIDE_EXP_MZ        = 0x00000001,
00198                 FT_PEPTIDE_EXP_MR        = 0x00000002,
00199                 FT_PEPTIDE_CALC_MZ       = 0x00000004,
00200                 FT_PEPTIDE_CALC_MR       = 0x00000008,
00201                 FT_PEPTIDE_STRING        = 0x00000010,
00202                 FT_PEPTIDE_QUERY         = 0x00000020,
00203
00204                 FT_PEPTIDE_VARMOD        = 0x00000040,
00205                 FT_PEPTIDE_FIXMOD        = 0x00000080,
00206                 FT_PEPTIDE_ETMOD         = 0x00000100,
00207                 FT_PEPTIDE_SLMOD         = 0x00000200,
00208                 FT_PEPTIDE_VARMOD_BYNAME = 0x00000400,
00209
00210                 FT_PEPTIDE_FIND_MASK     = 0x00000FFF,
00211
00212                 FT_PROTEIN_ACCESSION     = 0x00001000,
00213                 FT_PROTEIN_DESCRIPTION   = 0x00002000
00214             };
00215
00217
00238             enum FIND_COMPARE_FLAGS
00239             {
00240                 FC_COMPLETESTR          = 0x00000001,
00241                 FC_SUBSTR               = 0x00000002,
00242                 FC_STARTSTR             = 0x00000003,
00243                 FC_STRTOK               = 0x00000004,
00244                 FC_MASK_STR_PART        = 0x0000000F,
00245
00246                 FC_CASE_INSENSITIVE     = 0x00000000,
00247                 FC_CASE_SENSITIVE       = 0x00000010,
00248                 FC_MASK_CASE            = 0x000000F0,
00249
00250                 FC_FORWARD              = 0x00000000,
00251                 FC_REVERSE              = 0x00000100,
00252                 FC_MASK_DIRECTION       = 0x00000F00,
00253
00254                 FC_RESTRICT_TO_HIT      = 0x00001000,
00255                 FC_LOOP_INTO_UNASSIGNED = 0x00002000,
00256                 FC_LOOP_FROM_UNASSIGNED = 0x00004000,
00257                 FC_UNASSIGNED_MASK      = 0x00006000,
00258
00259                 FC_SEARCH_ALL_RANKS     = 0x00008000,
00260
00261                 FC_ALL_PEPTIDES         = 0x00000000,
00262                 FC_ALL_PEPTITDES        = 0x00000000,
00263
00264                 FC_SIGNIFICANT_PEPTIDES = 0x00010000,
00265                 FC_SEARCH_IGNORED_RANKS = 0x00020000,
00266                 FC_SCORING_MASK         = 0x000F0000,
00267
00268                 FC_PROTEIN_IGN_SAMESETS = 0x00100000,
00269                 FC_PROTEIN_IGN_SUBSETS  = 0x00200000,
00270                 FC_PROTEIN_IGN_FAMILY   = 0x00400000,
00271                 FC_PROTEIN_IGN_MASK     = 0x00F00000,
00272
00273                 FC_PROTEIN_INC_ALT_ACC  = 0x01000000
00274             };
00275
00277
00280             enum IONS_HISTOGRAM
00281             {
00282                 IH_INCLUDE_TOP_MATCHES           = 0x0000,
00283                 IH_INCLUDE_TOP_10_MATCHES        = 0x0001
00284 /*              IH_INCLUDE_TOP_ERRTOL_MATCHES    = 0x0002, //!< Not yet implemented. Include top error tolerant match
00285                 IH_INCLUDE_TOP_10_ERRTOL_MATCHES = 0x0004, //!< Not yet implemented. Include top 10 error tolerant match
00286                 IH_INCLUDE_TOP_DECOY_MATCHES     = 0x0008, //!< Not yet implemented. Include top decoy matche
00287                 IH_INCLUDE_TOP_10_DECOY_MATCHES  = 0x0010  //!< Not yet implemented. Include top 10 decoy matches */
00288             };
00289
00291
00296             enum UNIQUE_PEP_RULES
00297             {
00298                 UPR_WITHIN_FAMILY                = 0x0001,
00299                 UPR_WITHIN_FAMILY_MEMBER         = 0x0002,
00300                 UPR_IGNORE_SUBSET_PROTEINS       = 0x0004,
00301
00302                 UPR_DEFAULT                      = (UPR_WITHIN_FAMILY_MEMBER + UPR_IGNORE_SUBSET_PROTEINS)
00303             };
00304
00306
00309             enum THRESHOLD_TYPE
00310             {
00311                 TT_HOMOLOGY       = 0x0000,
00312                 TT_IDENTITY       = 0x0001,
00313                 TT_PEPSUM_DEFAULT = 0x0002
00314             };
00315
00317
00323             enum HOMOLOGY_THRESHOLD_SOURCE
00324             {
00325                 HOMTHR_RANK1    = 1,
00326                 HOMTHR_RANK2    = 2,
00327                 HOMTHR_RANK3    = 3,
00328                 HOMTHR_RANK4    = 4,
00329                 HOMTHR_RANK5    = 5,
00330                 HOMTHR_RANK6    = 6,
00331                 HOMTHR_RANK7    = 7,
00332                 HOMTHR_RANK8    = 8,
00333                 HOMTHR_RANK9    = 9,
00334                 HOMTHR_RANK10   = 10,
00335                 HOMTHR_RANK11   = 11,
00336                 HOMTHR_RANK12   = 12,
00337                 HOMTHR_RANK13   = 13,
00338                 HOMTHR_RANK14   = 14,
00339                 HOMTHR_RANK15   = 15,
00340                 HOMTHR_RANK16   = 16,
00341                 HOMTHR_RANK17   = 17,
00342                 HOMTHR_RANK18   = 18,
00343                 HOMTHR_RANK19   = 19,
00344                 HOMTHR_RANK20   = 20,
00345
00346                 HOMTHR_FASTA    = -1,
00347                 HOMTHR_SL       = -2
00348             };
00349
00351
00354             enum QUANT_COMPONENT_STATUS
00355             {
00356                 QCS_OK,
00357                 QCS_OK_NO_MATCH,
00358                 QCS_ERROR_NO_METHOD,
00359                 QCS_ERROR_NO_COMPONENTS,
00360                 QCS_ERROR_BAD_COMPONENT_NAME,
00361                 QCS_OK_MULTIPLE_MATCHES
00362             };
00363
00365             enum DECOY_STATS_COUNT_TYPE
00366             {
00367                 DS_COUNT_PSM = 0,
00368                 DS_COUNT_SEQUENCE = 1
00369             };
00370
00372             enum DB_MATCH_TYPE
00373             {
00374                 DM_FASTA = 0,
00375                 DM_SPECTRAL_LIBRARY = 1,
00376                 DM_BOTH = 2,
00377
00378                 DM_FASTA_FIRST_PASS = 3,
00379                 DM_FASTA_SECOND_PASS = 4,
00380             };
00381
00382         public:
00383
00384             // Some useful types
00385             typedef std::set<ms_protein> proteinSet;  // ms_protein has operator< which compares accession and dbIdx
00386             typedef std::pair<std::string, int> acc_dbidx_t;
00387             typedef std::set<acc_dbidx_t> acc_dbidx_set_t;
00388             typedef std::set<std::pair<int, int> > q_p_set_t;
00389             typedef std::vector<acc_dbidx_t> acc_dbidx_vect_t;
00390             typedef std::vector<std::pair<int, int> > q_p_vect_t;
00391
00392
00394             ms_mascotresults(const ms_mascotresfile  &resfile,
00395                              const ms_mascotresults_params &params);
00396             virtual ~ms_mascotresults();
00397
00399             const ms_mascotresfile & getResfile() const;
00400
00402             virtual bool createSummary();
00403
00404 #ifndef SWIG  // Can't / don't want to allow std::string * as OUTPUT in Java and C#
00405
00406             bool getCreateSummaryProgress(int          * cspTotalPercentComplete,
00407                                           unsigned int * cspCurrTask,
00408                                           int          * cspCurrTaskPercentageComplete,
00409                                           std::string  * cspAccession,
00410                                           int          * cspHit,
00411                                           int          * cspQuery,
00412                                           std::string  * cspKeepAliveText) const;
00413
00414             bool getCreateSummaryProgress(int          * cspTotalPercentComplete,
00415                                           unsigned int * cspCurrTask,
00416                                           int          * cspCurrTaskPercentageComplete,
00417                                           std::string  & cspAccession,
00418                                           int          * cspHit,
00419                                           int          * cspQuery,
00420                                           std::string  & cspKeepAliveText) const {
00421                                               return getCreateSummaryProgress(cspTotalPercentComplete, cspCurrTask, cspCurrTaskPercentageComplete, &cspAccession, cspHit, cspQuery, &cspKeepAliveText);
00422             }
00423 #else // SWIG Multiple return values
00424             bool getCreateSummaryProgress(int          * OUTPUT,
00425                                           unsigned int * OUTPUT,
00426                                           int          * OUTPUT,
00427                                           std::string  & OUTPUT,
00428                                           int          * OUTPUT,
00429                                           int          * OUTPUT,
00430                                           std::string  & OUTPUT) const;
00431 #endif
00432
00433             void cancelCreateSummary(bool newValue = true);
00434
00436             virtual ms_protein * getHit(const int hit, const int memberNumber = 0) const;
00437
00439             virtual void freeHit(const int hit);
00440
00442             virtual int getNumberOfHits() const;
00443
00445             virtual int getNumberOfFamilyMembers() const;
00446
00448             std::string getProteinDescription(const char * accession, const int dbIdx = 1) const;
00449
00451             double getProteinMass(const char * accession, const int dbIdx = 1) const;
00452
00454             virtual double getProteinEmPAI(const char *accession, const int dbIdx = 1, const int length = -1) const;
00455
00457             bool isEmPAIallowed() const;
00458
00460             virtual bool anyEmPAI() const;
00461
00463             double getSequenceMass(const char * seq) const;
00464
00466             void getProteinTaxonomyIDs(const char * accession, const int dbIdx,
00467                                        std::vector<int> & gpt_ids, std::vector<std::string> & gpt_accessions) const;
00468
00470             virtual const ms_protein * getProtein(const char * accession, const int dbIdx = 1) const;
00471
00473             virtual const ms_protein * getComponentProtein(const char * accession, const int dbIdx = 1) const;
00474
00476             virtual ms_protein * getNextSimilarProtein(const int masterHit, const int id) const;
00477
00479             virtual ms_protein * getNextSimilarProteinOf(const char * masterAccession, const int masterDB, const int id) const;
00480
00482             virtual ms_protein * getNextFamilyProtein(const int masterHit, const int id) const;
00483
00484
00486             virtual ms_protein * getNextSubsetProtein(const int masterHit, const int id,
00487                                                       const bool searchWholeFamily = true) const;
00488
00490             virtual ms_protein * getNextSubsetProteinOf(const char * masterAccession, const int masterDB, const int id) const;
00491
00493             virtual ms_peptide getPeptide(const int q, const int p) const = 0;
00494
00496             virtual bool getPeptide(const int q, const int p, ms_peptide * & pep) const = 0;
00497
00499             virtual double getIonsScore(const int q, const int p, const bool decoy) const = 0;
00500
00502             virtual bool isPeptideUnique(const int q, const int p, const UNIQUE_PEP_RULES rules = UPR_DEFAULT) const = 0;
00503
00505             virtual int getQmatch(const int query) const;
00506
00508             virtual int getQmatch(const int query, const ms_mascotresfile::section sec) const;
00509
00511             virtual int getPeptideIdentityThreshold(const int query, double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
00512
00514             virtual int getAvePeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
00515
00517             virtual int getMaxPeptideIdentityThreshold(double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
00518
00520             double getPeptideThreshold(const int query, double OneInXprobRnd, const int rank=1, const THRESHOLD_TYPE thresholdType=TT_PEPSUM_DEFAULT) const;
00521
00522             enum ERROR_TOLERANT_PEPTIDE { ETPEP_YES, ETPEP_NO, ETPEP_UNKNOWN };
00523 #ifndef SWIG
00524             double getPeptideThresholdProtected(const int query, double OneInXprobRnd, const int rank,
00525                                                 const ERROR_TOLERANT_PEPTIDE etPep,
00526                                                 const ms_mascotresfile::section secSummary,
00527                                                 const THRESHOLD_TYPE thresholdType,
00528                                                 const DB_MATCH_TYPE dbType) const;
00529 #endif
00530
00532             virtual int getProteinScoreCutoff(double OneInXprobRnd) const = 0;
00533
00535             virtual int getProteinThreshold(double OneInXprobRnd) const;
00536
00538             virtual int getHomologyThreshold(const int query,
00539                                              double OneInXprobRnd,
00540                                              const int rank=1) const;
00541
00543             virtual int getHomologyThresholdForHistogram(double OneInXprobRnd, DB_MATCH_TYPE dbType = DM_FASTA) const;
00544
00546             virtual int getProbFromScore(const double score) const;
00547
00549             virtual double getPeptideExpectationValue(const double score,
00550                                                       const int query,
00551                                                       const int rank = 0) const;
00552
00554             virtual double getProbOfPepBeingRandomMatch(const double score,
00555                                                         const int query) const;
00556
00558             virtual double getProteinExpectationValue(const double score) const;
00559
00561             virtual double getProbOfProteinBeingRandomMatch(const double score) const;
00562
00564             virtual std::string getProteinsWithThisPepMatch(const int q, const int p, const bool quotes=false) = 0;
00565
00567             virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
00568                                                                             std::vector<int> & start,
00569                                                                             std::vector<int> & end,
00570                                                                             std::vector<std::string> &pre,
00571                                                                             std::vector<std::string> &post,
00572                                                                             std::vector<int> & frame,
00573                                                                             std::vector<int> & multiplicity,
00574                                                                             std::vector<int> & db) const = 0;
00575
00577             virtual std::vector<std::string> getAllProteinsWithThisPepMatch(const int q, const int p,
00578                                                                             std::vector<int> & start,
00579                                                                             std::vector<int> & end,
00580                                                                             std::vector<std::string> &pre,
00581                                                                             std::vector<std::string> &post,
00582                                                                             std::vector<int> & frame,
00583                                                                             std::vector<int> & multiplicity,
00584                                                                             std::vector<int> & db,
00585                                                                             std::vector<int> & psmComponent) const = 0;
00586
00588             virtual int getAllFamilyMembersWithThisPepMatch(const int hit,
00589                                                             const int q,
00590                                                             const int p,
00591                                                             std::vector< int >& db,
00592                                                             std::vector< std::string >& acc,
00593                                                             std::vector< int >& dupe_status) const = 0;
00594
00595
00597             virtual std::string getErrTolModString(const int q, const int p) const = 0;
00598
00600             virtual std::string getLibraryModString(const int q, const int p) const = 0;
00601
00603             virtual std::string getErrTolModMasterString(const int q, const int p) const = 0;
00604
00606             virtual std::string getErrTolModSlaveString(const int q, const int p) const = 0;
00607
00609             virtual std::string getErrTolModPepString(const int q, const int p) const = 0;
00610
00612             virtual std::string getErrTolModReqPepString(const int q, const int p) const = 0;
00613
00615             virtual std::string getErrTolModName(const int q, const int p, std::string * modString = NULL) const;
00616
00618             virtual double getErrTolModDelta(const int q, const int p, std::string * modString = NULL, std::string * deltaAsString = NULL) const;
00619
00621             virtual double getErrTolModNeutralLoss(const int q, const int p) const;
00622
00624             virtual std::vector<double> getErrTolModMasterNeutralLoss(const int q, const int p) const;
00625
00627             virtual std::vector<double> getErrTolModSlaveNeutralLoss(const int q, const int p) const;
00628
00630             virtual std::vector<double> getErrTolModPepNeutralLoss(const int q, const int p) const;
00631
00633             virtual std::vector<double> getErrTolModReqPepNeutralLoss(const int q, const int p) const;
00634
00636             std::string getVarModsForQP(const int q, const int p, const ms_peptide & pep,
00637                                         const ms_peptide::PSM psmComponent,
00638                                         int * numETMods = NULL, int * numLibraryMods = NULL,
00639                                         std::set<std::string> * listMods = NULL) const;
00640
00642             std::string getLocalModsForQP(const int q, const int p, const ms_peptide & pep, const ms_peptide::PSM psmComponent, std::set<std::string> * listMods = NULL) const;
00643
00645             std::string getLibraryModsForQP(const int q, const int p, const ms_peptide & pep, std::set<std::string> * listMods = NULL) const;
00646
00648             virtual std::string getReadableVarMods(const int q, const int p,
00649                                                    const int numDecimalPlaces=2,
00650                                                    const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const;
00651
00653             virtual bool anyNumDiscoveredMods() const;
00654
00656             virtual std::vector<int> getNumDiscoveredFixedMods(const int num,
00657                                                                std::vector<std::string> &positions,
00658                                                                std::vector<std::string> &sites) const;
00659
00661             virtual std::vector<int> getNumDiscoveredVariableMods(const int num,
00662                                                                   std::vector<std::string> &positions,
00663                                                                   std::vector<std::string> &sites,
00664                                                                   std::vector<double> &deltas,
00665                                                                   std::vector<std::string> &names) const;
00666
00668             virtual std::vector<int> getNumDiscoveredVariableMods(const int num, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
00669
00671             virtual std::vector<std::string> getDiscoveredLocalModNames() const;
00672
00674             virtual std::vector<double> getDiscoveredLocalModDeltas(std::vector<std::string> * vecDeltaStrings = NULL) const;
00675
00677             virtual std::vector<int> getNumDiscoveredLocalMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
00678
00680             virtual std::vector<std::string> getDiscoveredErrTolModNames() const;
00681
00683             virtual std::vector<double> getDiscoveredErrTolModDeltas(std::vector<std::string> * vecDeltaStrings = NULL) const;
00684
00686             virtual std::vector<int> getNumDiscoveredErrTolMods(const std::string modName, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
00687
00689             std::vector<int> getNumDiscoveredLibraryMods(const int modId, std::vector<std::string> &positions, std::vector<std::string> &sites) const;
00690
00692             std::vector<int> getNumDiscoveredIntactLinks(std::vector<int> &varModNum1,
00693                                                          std::vector<std::string> &position1,
00694                                                          std::vector<std::string> &site1,
00695                                                          std::vector<int> &varModNum2,
00696                                                          std::vector<std::string> &position2,
00697                                                          std::vector<std::string> &site2,
00698                                                          std::vector<int> &numLinkedPeptides) const;
00699
00701             virtual int getNumDiscoveredNonSpecCleavage() const;
00702
00704             virtual std::string getTagString(const int q, const int p) const = 0;
00705
00707             virtual int getTagStart(const int q, const int p, const int tagNumber) const;
00708
00710             virtual int getTagEnd(const int q, const int p, const int tagNumber) const;
00711
00713             virtual int getTagSeries(const int q, const int p, const int tagNumber) const;
00714
00716             virtual int getTagDeltaRangeStart(const int q, const int p) const = 0;
00717
00719             virtual int getTagDeltaRangeEnd(const int q, const int p) const = 0;
00720
00722             virtual std::string getTerminalResiduesString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const = 0;
00723
00725             virtual std::string getComponentString(const int q, const int p, const ms_peptide::PSM psmComponent = ms_peptide::PSM_COMPLETE) const = 0;
00726
00728             virtual int getMaxRankValue() const;
00729
00731             virtual std::vector<int> getIonsScoreHistogram(IONS_HISTOGRAM flags = IH_INCLUDE_TOP_MATCHES, DB_MATCH_TYPE dbType = DM_FASTA) const;
00732
00734             double getToleranceInDalton(bool & needMass, const double * const pMass = NULL) const;
00735
00737             bool createUnassignedList(sortBy s  = QUERY);
00738
00740             int getNumberOfUnassigned() const;
00741
00743             ms_peptide getUnassigned(const int num) const;
00744
00746             bool getUnassignedIsBold(const int num) const;
00747
00749             bool getUnassignedShowCheckbox(const int num) const;
00750
00752             ms_mascotresults_params getResultsParameters();
00753
00755             virtual bool getTreeClusterNodes(const int hit,
00756                                              std::vector<int>    &left,
00757                                              std::vector<int>    &right,
00758                                              std::vector<double> &distance,
00759                                              TREE_CLUSTER_METHOD  tcm = TCM_PAIRWISE_MAXIMUM,
00760                                              double           *** reserved1 = 0,
00761                                              unsigned int       * reserved2 = 0) const;
00762
00764             virtual int findProteins(const int startHit,
00765                                      const std::string & str,
00766                                      const int dbIdx,
00767                                      FIND_FLAGS item,
00768                                      FIND_COMPARE_FLAGS compareFlags,
00769                                      std::vector<std::string> & accessions,
00770                                      std::vector<int> & dbIndexes) const = 0;
00771
00773             virtual int findProteinsByAccession(const int startHit,
00774                                                 const std::string & str,
00775                                                 const int dbIdx,
00776                                                 FIND_COMPARE_FLAGS compareFlags,
00777                                                 std::vector<std::string> & accessions,
00778                                                 std::vector<int> & dbIndexes) const = 0;
00779
00781             virtual int findProteinsByDescription(const int startHit,
00782                                                   const std::string & str,
00783                                                   FIND_COMPARE_FLAGS compareFlags,
00784                                                   std::vector<std::string> & accessions,
00785                                                   std::vector<int> & dbIndexes) const = 0;
00786
00788             virtual int findPeptides(const int startHit,
00789                                      const std::string & str,
00790                                      FIND_FLAGS item,
00791                                      FIND_COMPARE_FLAGS compareFlags,
00792                                      std::vector<int> & q,
00793                                      std::vector<int> & p) const = 0;
00794
00796             virtual QUANT_COMPONENT_STATUS getQuantitationComponentForPeptide(
00797                     const matrix_science::ms_peptide & peptide,
00798                     matrix_science::ms_quant_component & component,
00799                     const matrix_science::ms_quant_method * method = NULL) const = 0;
00800
00802             virtual double getProteinScoreForHistogram(const int num) const;
00803
00805             bool isNA() const;
00806
00808
00811             unsigned int getFlags() const { return flags_; }
00812
00814
00818             unsigned int getFlags2() const { return flags2_; }
00819
00821             int getMinPepLenInPepSummary() const;
00822
00824             virtual long getNumHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
00825
00827             virtual long getNumDecoyHitsAboveIdentity(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
00828
00830             virtual long getNumHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
00831
00833             virtual long getNumDecoyHitsAboveHomology(double OneInXprobRnd, DECOY_STATS_COUNT_TYPE countType = DS_COUNT_PSM, DB_MATCH_TYPE dbType = DM_FASTA);
00834
00836             virtual void setSubsetsThreshold(const double scoreFraction);
00837
00839             virtual double getProbabilityThreshold() const;
00840
00842             virtual double getErrTolProbabilityThreshold() const;
00843
00844 #ifndef SWIG
00845
00846             bool getThresholdForFDRAboveIdentity(double targetFDR, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
00847
00849             bool getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
00850
00852             bool getThresholdForFDRAboveHomology(double targetFDR, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
00853
00855             bool getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *closestFDR, double *minProbability, int * numTargetMatches = 0, int * numDecoyMatches = 0);
00856
00858             virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & value, double & rawValue) const = 0;
00859 #else // SWIG Multiple return values
00860             // Don't supply default parameters for perl or python because these are defined as output parameters
00861             bool getThresholdForFDRAboveIdentity(double targetFDR, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
00862             bool getThresholdForFDRAboveIdentity(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
00863             bool getThresholdForFDRAboveHomology(double targetFDR, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
00864             bool getThresholdForFDRAboveHomology(double targetFDR, DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType, double *OUTPUT, double *OUTPUT, int * OUTPUT, int * OUTPUT);
00865             virtual bool getComponentIntensity(const int q, const int p, const std::string & componentName, double & OUTPUT, double & OUTPUT) const;
00866 #endif
00867
00869             virtual std::vector<int> getPepsWithSameScore(const int q, const int p) const = 0;
00887             bool queryRemoveThisPeptide(const unsigned short dupeFlags) const { return dupeRemoveIDs_.find(dupeFlags) != dupeRemoveIDs_.end(); }
00888
00905             bool queryScoreThisPeptide(const unsigned short dupeFlags) const { return dupeIncludeInScoreIDs_.find(dupeFlags) != dupeIncludeInScoreIDs_.end(); }
00906
00908             virtual bool loadPepMatchesForProteinFromCache(ms_protein * prot, const bool loadRelated=true) { return false; }
00909
00911             virtual bool isValidQandP(const int q, const int p) const = 0;
00912
00914             std::string lookupParsedLocalModsStr(const int q, const std::string localModsStr) const;
00915
00917             std::string lookupParsedLocalModsStr(const ms_peptide *thisOnePep) const;
00918
00919         protected:
00920             // Not safe to copy or assign this object.
00921 #ifndef SWIG
00922             ms_mascotresults(const ms_mascotresults & rhs);
00923             ms_mascotresults & operator=(const ms_mascotresults & rhs);
00924
00925             void setResfileError(int error, ...) const;
00926
00927             ms_protein* addProtein(const std::string & accession,
00928                             const int dbIdx,
00929                             const int q, const int p,
00930                             const msparser_internal::ms_protein_match_data &proteinMatchData,
00931                             const double score,
00932                             const double uncorrectedScore,
00933                             const ms_peptide::SEARCH_PHASE searchPhase = ms_peptide::SEARCH_PHASE_PRIMARY,
00934                             const bool isIgnored = false);
00935
00936             bool canAddPeptideToProtein(const int dbIdx,
00937                                         const ms_peptide::SEARCH_PHASE searchPhase,
00938                                         const bool isIgnored) const;
00939
00940             ms_protein* addMixtureComponentProtein(const std::string & mixAccession,
00941                                                    const int q, const int p,
00942                                                    const msparser_internal::ms_protein_match_data &proteinMatchData,
00943                                                    const double score,
00944                                                    const double uncorrectedScore,
00945                                                    const ms_protein * master,
00946                                                    const ms_peptide::SEARCH_PHASE searchPhase);
00947
00948             ms_protein * addUniGeneComponentProtein(const std::string & accession,
00949                                                     const int dbIdx,
00950                                                     const int q, const int p,
00951                                                     const msparser_internal::ms_protein_match_data &proteinMatchData,
00952                                                     const double score,
00953                                                     const double uncorrectedScore,
00954                                                     const ms_peptide::SEARCH_PHASE searchPhase,
00955                                                     const bool isIgnored = false);
00956
00957             ms_protein * addUniGeneProtein(const std::string & unigeneID,
00958                                            const int q, const int p,
00959                                            const msparser_internal::ms_protein_match_data &proteinMatchData,
00960                                            const double score,
00961                                            const double uncorrectedScore,
00962                                            const ms_protein * component,
00963                                            const ms_peptide::SEARCH_PHASE searchPhase,
00964                                            const bool isIgnored = false);
00965
00966             bool   queryHasSecondPassMatches(ms_mascotresfile::section secSummary, int query) const;
00967             double overrideOneInXprobRnd(bool hasSecondPassMatches) const;
00968
00969             double calculateFirstPassThreshold(ms_mascotresfile::section secSummary,
00970                                                int query,
00971                                                double OneInXprobRnd,
00972                                                THRESHOLD_TYPE tt) const;
00973
00974             double calculateHomologyThreshold(int query,
00975                                               double qplughole,
00976                                               double OneInXprobRnd,
00977                                               double identityThreshold,
00978                                               double qmatch) const;
00979
00980             virtual bool queryHasSignificantRank1Match(ms_mascotresfile::section secSummary,
00981                                                        int query) const = 0;
00982
00983             virtual bool getThresholdForFDR(bool homology, double targetFDR,
00984                     DECOY_STATS_COUNT_TYPE countType, DB_MATCH_TYPE dbType,
00985                     double * closestFDR, double * minProbability,
00986                     int * pNumTargetMatches, int * pNumDecoyMatches) = 0;
00987             virtual void calculateDecoyStats(double dOneInXprobRnd) = 0;
00988
00989             virtual double getPeptideExpectationValueProtected(const double score,
00990                                                                const int query,
00991                                                                const ms_mascotresfile::section summary_section,
00992                                                                const THRESHOLD_TYPE thresholdType,
00993                                                                const DB_MATCH_TYPE dbType) const;
00994             virtual double getQplughole(const int query, const ms_mascotresfile::section sec) const;
00995             virtual ms_mascotresfile::section getSrcSectionProtected(const int query, const int rank) const;
00996
00997
00998             enum QMATCH_PLUGHOLE_INDEX_SECTIONS {
00999                 QMATCH_PLUGHOLE_SEC_SUMMARY       = 0,
01000                 QMATCH_PLUGHOLE_SEC_DECOYSUMMARY  = 1,
01001                 QMATCH_PLUGHOLE_SEC_ERRTOLSUMMARY = 2,
01002                 QMATCH_PLUGHOLE_SEC_LIBRARYSUMMARY= 3,
01003                 QMATCH_PLUGHOLE_SEC_CROSSLINK_SUMMARY = 4,
01004                 QMATCH_PLUGHOLE_SEC_ERRTOLDECOYSUMMARY = 5,
01005                 QMATCH_PLUGHOLE_SEC_LAST          = 6
01006             };
01007             virtual void getQmatchValuesFromCacheFile(const QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {} ;
01008             virtual void getPlugholeValuesFromCacheFile(const QMATCH_PLUGHOLE_INDEX_SECTIONS index) const {};
01009
01010 #endif
01011
01012             static double getValidMinProbability(double minProbability);
01013             static double getValidIgnoreIonsScoreBelow(double ignoreIonsScoreBelow);
01014             static int getValidMinNumSigUniqueSeqs(int n);
01015             static int getValidFlags1(const ms_mascotresfile &resfile, int flags);
01016             static double getValidOneInXprobRnd(double OneInXprobRnd);
01017             static double getValidTargetFDR(double fdr);
01018             static DECOY_STATS_COUNT_TYPE getValidTargetFDRType(DECOY_STATS_COUNT_TYPE type);
01019
01020             const ms_mascotresfile &resfile_;
01021             const int   numQueries_;
01022             const double tolFactor_;
01023
01024             proteinSet proteins_;
01025
01026             // For unigene, the original proteins are not saved in proteins_
01027             proteinSet componentProteins_;
01028
01029             // - Not documented - Get the 'corrected' ions score given multiplicity
01030             double getIonsScoreCorrected(const double ionsScore,
01031                                          const long   multiplicity) const;
01032
01033             const ms_mascotresults_params *resultsParams_;
01034
01035             const unsigned int      flags_;
01036             const unsigned int      flags2_;
01037             const double            minProbability_;
01038             const int               maxHitsToReport_;
01039             const std::string       unigeneIndexFile_;
01040                   ms_unigene      * unigene_;
01041             const bool              tooOld_;
01042             const int               minPepLenInPepSummary_;
01043                   std::string       singleHit_;
01044             const double            ignoreIonsScoreBelow_;
01045             const int               minNumSigUniqueSeqs_;
01046             const double            targetFDR_;
01047             const DECOY_STATS_COUNT_TYPE targetFDRtype_;
01048
01049             const int               numDatabases_;
01050
01051             double                  minErrTolProbability_;
01052
01053             // Not documented - check that minProbability is the same as first_pass_threshold
01054             bool isMinProbabilityDifferentFromFirstPassThreshold() const;
01055
01056             // The elements in the vector of peptides are accessed by
01057             // q + (p * num queries)
01058             std::vector<ms_peptide *> peptides_;
01059
01060             double slScoreStats_[4];
01061             double& slScoreStatsMascotMean() { return slScoreStats_[0]; }
01062             double& slScoreStatsMascotStdev() { return slScoreStats_[1]; }
01063             double& slScoreStatsLibraryMean() { return slScoreStats_[2]; }
01064             double& slScoreStatsLibraryStdev() { return slScoreStats_[3]; }
01065             const double& slScoreStatsMascotMean() const { return slScoreStats_[0]; }
01066             const double& slScoreStatsMascotStdev() const { return slScoreStats_[1]; }
01067             const double& slScoreStatsLibraryMean() const { return slScoreStats_[2]; }
01068             const double& slScoreStatsLibraryStdev() const { return slScoreStats_[3]; }
01069
01071             virtual double getPepIdentThreshProtected(const int query,
01072                                                       double OneInXprobRnd,
01073                                                       ms_mascotresfile::section sec,
01074                                                       DB_MATCH_TYPE dbType,
01075                                                       double * pQmatch = 0) const;
01076             virtual double getHomologyThreshProtected(const int query,
01077                                                       double OneInXprobRnd,
01078                                                       ms_mascotresfile::section sec,
01079                                                       const int rank=1,
01080                                                       const ERROR_TOLERANT_PEPTIDE etPep = ETPEP_UNKNOWN ) const;
01081
01082             inline bool checkCreated(const char * funcname, unsigned int t) const {
01083                 if (!(completedTasks_ & t)) {
01084                     setResfileError(ms_mascotresfile::ERR_RESULTS_NOT_CREATED, funcname);
01085                     return false;
01086                 } else {
01087                     return true;
01088                 }
01089             }
01090
01091
01092             msparser_internal::ms_unassigned * unassigned_;
01093
01094             double top50Scores_[50];
01095             std::set<unsigned short>dupeRemoveIDs_;
01096             std::set<unsigned short>dupeIncludeInScoreIDs_;
01097
01098             bool bDecoyStatsCalculated_;
01099             double dOneInXprobRndForDecoy_;
01100             // Array sizes must match the number of factor levels for each enum.
01101             enum DECOY_STATS_THRESHOLD_TYPE { DS_IDENTITY = 0, DS_HOMOLOGY = 1 };
01102             enum {
01103                 DECOY_STATS_TD_LEVELS         = 2,
01104                 DECOY_STATS_COUNT_TYPE_LEVELS = 2,
01105                 DECOY_STATS_THR_TYPE_LEVELS   = 3,
01106                 DECOY_STATS_DB_TYPE_LEVELS    = 5
01107             };
01108             long decoyStats_[DECOY_STATS_TD_LEVELS][DECOY_STATS_COUNT_TYPE_LEVELS][DECOY_STATS_THR_TYPE_LEVELS][DECOY_STATS_DB_TYPE_LEVELS];
01109             inline long& decoyStatsOf(bool decoy, DECOY_STATS_COUNT_TYPE countType, DECOY_STATS_THRESHOLD_TYPE thrType, DB_MATCH_TYPE dbType)
01110             {
01111                 return decoyStats_[decoy ? 1 : 0][countType][thrType][dbType];
01112             }
01113             static void checkDecoyStatsArguments(double &OneInXprobRnd, DECOY_STATS_COUNT_TYPE &countType, DB_MATCH_TYPE &dbType);
01114             inline void resetDecoyStats(long c)
01115             {
01116                 for (int i = 0; i < DECOY_STATS_TD_LEVELS; i++) {
01117                     for (int j = 0; j < DECOY_STATS_COUNT_TYPE_LEVELS; j++) {
01118                         for (int k = 0; k < DECOY_STATS_THR_TYPE_LEVELS; k++) {
01119                             for (int l = 0; l < DECOY_STATS_DB_TYPE_LEVELS; l++) {
01120                                 decoyStats_[i][j][k][l] = c;
01121                             }
01122                         }
01123                     }
01124                 }
01125             }
01126
01127             ms_mascotresfile::section secSummary_;
01128             ms_mascotresfile::section secMixture_;
01129             ms_mascotresfile::section secPeptides_;
01130             ms_mascotresfile::section secProteins_;
01131             double subsetsScoreFraction_;
01132             msparser_internal::ms_proteininference * pProteinInferencer_;
01133             bool nucleicAcid_;
01134             mutable int cachedAvePepIdentThreshMascot_;
01135             mutable int cachedAvePepIdentThreshSL_;
01136             std::vector<int> ionsScoreHistogramTopMatchMascot_;
01137             std::vector<int> ionsScoreHistogramTop10Mascot_;
01138             std::vector<int> ionsScoreHistogramTopMatchSL_;
01139             std::vector<int> ionsScoreHistogramTop10SL_;
01140             int maxRankValue_;
01141             bool isPercolator_;
01142             THRESHOLD_TYPE thresholdType_;
01143             double minScoreThreshold_;
01144             bool useFusionETthresholds_;
01145
01146             typedef std::map<char, int> mod_residue_count_t;
01147             typedef std::map<std::pair<char, char>, int> linked_residue_count_t;
01148             static const char mod_residue_count_NTERM;
01149             static const char mod_residue_count_CTERM;
01150             static const double probability_lower_bound;
01151             static std::string site_char_to_string(char);
01152             bool countModificationInstances(
01153                     std::vector<mod_residue_count_t> &fixed_mod_count,
01154                     std::vector<mod_residue_count_t> &var_mod_count,
01155                     std::map<std::pair<int, int>, mod_residue_count_t> &monolink_count,
01156                     std::map<std::pair<int, int>, linked_residue_count_t> &looplink_count,
01157                     std::map<std::pair<int, int>, linked_residue_count_t> &intact_link_count,
01158                     std::vector<std::string> &var_mod_position_types,
01159                     std::map< std::string, std::map<std::string, mod_residue_count_t> > &local_mod_count,
01160                     std::vector<std::string> &local_mod_deltas,
01161                     std::map< std::string, std::map<std::string, mod_residue_count_t> > &et_mod_count,
01162                     std::vector<std::string> &et_mod_deltas,
01163                     int &num_nonspecific_cleavage,
01164                     std::vector<mod_residue_count_t> &library_mod_count);
01165             virtual bool cacheModificationCounts() = 0;
01166             std::vector<mod_residue_count_t> discoveredFixedMods_;
01167             std::vector<mod_residue_count_t> discoveredVariableMods_;
01168             std::map<std::pair<int, int>, mod_residue_count_t> discoveredMonoLinks_;
01169             std::map<std::pair<int, int>, linked_residue_count_t> discoveredLoopLinks_;
01170             std::map<std::pair<int, int>, linked_residue_count_t> discoveredIntactLinks_;
01171             std::vector<std::string> discoveredVariableModPositionTypes_;
01172             std::map<std::string, std::map<std::string, mod_residue_count_t> > discoveredLocalMods_;
01173             std::vector<std::string> discoveredLocalModDeltas_;
01174             std::map<std::string, std::map<std::string, mod_residue_count_t> > discoveredErrorTolerantMods_;
01175             std::vector<std::string> discoveredErrorTolerantModDeltas_;
01176             int discoveredNonSpecificCleavageNum_;
01177             std::vector<mod_residue_count_t> discoveredLibraryMods_;
01178             bool modificationCountsLoaded_;
01179             bool modificationCountsAvailable_;
01180
01181             typedef std::map<std::string, std::set<std::pair<int, int> >, LexicoCompare > map_mod_value_to_qp;
01182
01183             enum COMPLETED_TASKS {
01184                 CT_NONE                 = 0x0000,
01185                 CT_LOADQUERIES          = 0x0001,
01186                 CT_SRCRANKINITIALISED   = 0x0002,
01187                 CT_PERCOLATORRESULTS    = 0x0004,
01188                 CT_INFERENCING          = 0x0008,
01189                 CT_UNASSIGNEDLIST       = 0x0010,
01190                 CT_COMPONENTINTENSITIES = 0x0020,
01191                 CT_COUNTMODS            = 0x0040,
01192                 CT_CREATECDB            = 0x0080,
01193                 CT_ALLDONE              = 0xFFFF
01194             };
01195             mutable unsigned int completedTasks_;
01196
01197             bool isCancelling() const;
01198
01199         private:
01200             ms_protein*
01201             addProteinInternal(ms_mascotresults::proteinSet &proteinSet,
01202                                const std::string &accession,
01203                                const int dbIdx,
01204                                const int q, const int p,
01205                                const msparser_internal::ms_protein_match_data &proteinMatchData,
01206                                const double correctedScore,
01207                                const double uncorrectedScore,
01208                                const ms_protein * component,
01209                                const ms_peptide::SEARCH_PHASE searchPhase,
01210                                const bool isUnigene,
01211                                const bool isIgnored);
01212
01213             mutable bool   cachedHomology_[2];
01214             mutable double cachedHomologyProb_[2];
01215             mutable std::vector<double> cachedHomologyValues_[2];
01216             mutable std::vector<int> cachedQMatch_[QMATCH_PLUGHOLE_SEC_LAST];
01217             mutable std::vector<double> cachedQPlughole_[QMATCH_PLUGHOLE_SEC_LAST];
01218             typedef std::map<std::pair<int, std::string>, int> dbIdxPlusAccToId_t;
01219             mutable dbIdxPlusAccToId_t summarySectionAccs_;
01220             mutable bool cancelCreateSummary_;
01221             ms_progress_info * progress_;
01222
01223             mutable bool loadedQmatchFromCacheFile_[QMATCH_PLUGHOLE_SEC_LAST];
01224             mutable bool loadedPlugholeFromCacheFile_[QMATCH_PLUGHOLE_SEC_LAST];
01225
01226             bool getProteinDescriptionAndMass(const char * accession, const int dbIdx,
01227                                               double & mass, std::string & desc) const;
01228             void cacheSummarySectionAccs() const;
01229             void debugCheckReloadablePeps() const;
01230             bool setQmatch(const int query, const QMATCH_PLUGHOLE_INDEX_SECTIONS index, const int value) const;
01231             bool setPlughole(const int query, const QMATCH_PLUGHOLE_INDEX_SECTIONS index, const double value) const;
01232
01233             // Reduce IT_MODS parsing.
01234             typedef std::map<int, std::string> queryIT_MODS_t;
01235             mutable queryIT_MODS_t queryIT_MODS_;
01236             typedef std::map<std::string, std::vector<std::string> > parsedLocalMods_t;
01237             mutable parsedLocalMods_t parsedLocalMods_;
01238             typedef std::map<std::pair<int, std::string>, std::string> pepParsedLocalMods_t;
01239             mutable pepParsedLocalMods_t pepParsedLocalMods_;
01240
01241             static std::string parseLocalModsStr(const std::string &localModsStr, const std::vector<std::string> &local_modnames);
01242
01243             const std::vector<std::string>& lookupParsedIT_MODS(int q) const;
01244
01245             double sequenceMassResidueLookup_[256];
01246     };
01247  // end of resfile_group
01249 }   // matrix_science namespace
01250
01251 #endif // MS_MASCOTRESULTS_HPP
01252
01253 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresults_params.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotresults_params.hpp                                          #
00004 # 'msparser' toolkit                                                         #
00005 # Parameter storage for ms_peptidesummary and ms_proteinsummary              #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2021-04-16 16:53:57 +0100 $ #
00013 #   $Revision: 11d32bab75bd4a36805819329c7ad7887156b404 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_MASCOTRESULTS_PARAMS_HPP
00019 #define MS_MASCOTRESULTS_PARAMS_HPP
00020
00021 namespace matrix_science {
00027     class ms_mascotresults;
00028     class ms_peptidesummary;
00029
00031     class MS_MASCOTRESFILE_API ms_mascotresults_params
00032     {
00033         public:
00035             ms_mascotresults_params(const unsigned int flags = ms_mascotresults::MSRES_GROUP_PROTEINS,
00036                                     double             minProbability = 0.05,
00037                                     int                maxHitsToReport = 0,
00038                                     const char *       unigeneIndexFile = 0,
00039                                     double             ignoreIonsScoreBelow = 0.0,
00040                                     int                minPepLenInPepSummary = 0,
00041                                     const char *       singleHit = 0,
00042                                     const unsigned int flags2 = 0);
00043
00044             virtual ~ms_mascotresults_params();
00045
00047             ms_mascotresults_params(const ms_mascotresults_params & src);
00048
00049 #ifndef SWIG
00050
00051             ms_mascotresults_params& operator=(const ms_mascotresults_params & right);
00052 #endif
00053
00055             void copyFrom(const ms_mascotresults_params * right);
00056
00058             void setFlags(const unsigned int flags);
00059
00061             void setFlag(const ms_mascotresults::FLAGS flag, bool enabled);
00062
00064             unsigned int getFlags() const;
00065
00067             void setFlags2(const unsigned int flags2);
00068
00070             void setFlag2(const ms_peptidesummary::MSPEPSUM flag, bool enabled);
00071
00073             unsigned int getFlags2() const;
00074
00076             double getMinProbability() const;
00077
00079             void setMinProbability(const double minProbability);
00080
00082             double getTargetFDR() const;
00083
00085             void setTargetFDR(double fdr);
00086
00088             ms_mascotresults::DECOY_STATS_COUNT_TYPE getTargetFDRType() const;
00089
00091             void setTargetFDRType(ms_mascotresults::DECOY_STATS_COUNT_TYPE fdrType);
00092
00094             double getIgnoreIonsScoreBelow() const;
00095
00097             void setIgnoreIonsScoreBelow(const double ignoreIonsScoreBelow);
00098
00100             int getMinNumSigUniqueSequences() const;
00101
00103             void setMinNumSigUniqueSequences(const int n);
00104
00106             int getMaxHitsToReport() const;
00107
00109             void setMaxHitsToReport(const int maxHitsToReport);
00110
00112             int getMinPepLenInPeptideSummary() const;
00113
00115             void setMinPepLenInPeptideSummary(const int minPepLenInPeptideSummary);
00116
00118             std::string getUnigeneIndexFile() const;
00119
00121             void setUnigeneIndexFile(const char* unigeneIndexFile);
00122
00124             std::string getSingleHit() const;
00125
00127             void setSingleHit(const char* singleHit);
00128
00130             bool isUsePeptideSummary() const;
00131
00133             void setUsePeptideSummary(const bool usePeptideSummary);
00134
00135         private:
00136             unsigned int      flags_;
00137             double            minProbability_;
00138             double            targetFDR_;
00139             ms_mascotresults::DECOY_STATS_COUNT_TYPE targetFDRtype_;
00140             int               maxHitsToReport_;
00141             double            ignoreIonsScoreBelow_;
00142             std::string       unigeneIndexFile_;
00143             int               minPepLenInPepSummary_;
00144             std::string       singleHit_;
00145             unsigned int      flags2_;
00146             bool              usePeptideSummary_;
00147
00148             int               minNumSigUniqueSeqs_;
00149     };
00150  // end of resfile_group
00152 }   // matrix_science namespace
00153
00154 #endif // MS_MASCOTRESULTS_PARAMS_HPP
00155
00156 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_mascotresunigene.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotrespeptide.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a Unigene file (from NCBI)                                    #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_mascotresunigene.hpp    $ #
00013 #     $Author: villek@matrixscience.com $ #
00014 #       $Date: 2018-09-21 11:02:51 +0100 $ #
00015 #   $Revision: 7de186ba48b69fe269342dd6d9425df8679c4d3a | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_MASCOTRESUNIGENE_HPP
00021 #define MS_MASCOTRESUNIGENE_HPP
00022
00023
00024 // Includes from the standard template library
00025 #include <stdio.h>
00026 #include <string>
00027 #include <vector>
00028
00029
00030
00031 namespace matrix_science {
00032     class ms_tinycdb;
00033
00039
00040
00045     class MS_MASCOTRESFILE_API ms_unigene_entry
00046     {
00047         public:
00049             ms_unigene_entry(FILE * f, ms_unigene & unigene);
00050
00052             ms_unigene_entry(const std::string & id,
00053                              const std::string & title,
00054                              const std::string & gene,
00055                              const std::string & cytoBand,
00056                              const std::string & locusLink,
00057                              const std::string & express,
00058                              const long          chromosome,
00059                              const int           numAccessions,
00060                              const OFFSET64_T    fileOffset);
00061
00063             ~ms_unigene_entry();
00064
00066
00071             int getNumAccessions() const     { return numAccessions_; }
00072
00074
00077             std::string getID() const        { return id_;                }
00078
00080
00083             std::string getTitle() const     { return title_;             }
00084
00086
00089             std::string getGene() const      { return gene_;              }
00090
00092
00095             std::string getCytoBand() const  { return cytoBand_;          }
00096
00098
00102             std::string getLocusLink() const { return locuslink_;         }
00103
00105
00111             std::string getExpress() const   { return express_;           }
00112
00114
00117             long getChromosome() const       { return chromosome_;        }
00118
00120
00124             OFFSET64_T getFileOffset() const { return fileOffset_;        }
00125
00126         protected:
00127             // Not safe to copy or assign this object.
00128 #ifndef SWIG
00129             ms_unigene_entry(const ms_unigene_entry & rhs);
00130             ms_unigene_entry & operator=(const ms_unigene_entry & rhs);
00131 #endif
00132         private:
00134             bool getString(const char * buf, const char * id,
00135                            const int idLen,  std::string &res);
00136
00138             bool getLong(const char * buf, const char * id,
00139                          const int idLen,  long &res);
00140
00142             bool getAccessions(const char * buf, const char * id, const int idLen,
00143                                std::string & giNumber, std::string & accession);
00144             std::string id_;
00145             std::string title_;
00146             std::string gene_;
00147             std::string cytoBand_;
00148             std::string locuslink_;
00149             std::string express_;
00150             long        chromosome_;
00151             int         numAccessions_;
00152             OFFSET64_T  fileOffset_;
00153     };
00154
00156
00161     class MS_MASCOTRESFILE_API ms_unigene
00162     {
00163         friend class ms_unigene_entry;
00164
00165         public:
00167             ms_unigene(const ms_mascotresfile  &resfile, const char * filename);
00168
00170             ~ms_unigene();
00171
00173             const ms_unigene_entry * findEntry(const char * id);
00174
00176             std::string getUnigeneForAccession(const std::string accession,
00177                                                const int index);
00178
00179         protected:
00180             // Not safe to copy or assign this object.
00181 #ifndef SWIG
00182             ms_unigene(const ms_unigene & rhs);
00183             ms_unigene & operator=(const ms_unigene & rhs);
00184 #endif
00185     private:
00186             const ms_mascotresfile  &resfile_;
00187             std::vector<ms_unigene_entry *> entries_;
00188             std::string filename_;
00189             int numAccessions_;
00190             ms_tinycdb * pcdb_;
00191             typedef std::multimap<std::string, const ms_unigene_entry *> unigenesForAcc;
00192             unigenesForAcc accessionToUnigene_;
00193
00195             void addAccessionUnigenePair(const ms_unigene_entry * unigene,
00196                                          const std::string & accession);
00197     }; // end of resfile_group
00199 }   // matrix_science namespace
00200
00201 #endif // MS_MASCOTRESUNIGENE_HPP
00202
00203 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


ms_masses.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_masses.hpp                                                        #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "masses"-file that defines atom and residue masses            #
00006 # about several consecutive erros                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_masses.hpp              $ #
00013 #     $Author: villek@matrixscience.com $ #
00014 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00015 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_MASSES_HPP
00021 #define MS_MASSES_HPP
00022
00023
00024 #include <string>
00025
00026
00027 namespace matrix_science {
00028
00029     class ms_umod_configfile; // forward declaration
00030     class ms_quant_component; // forward declaration
00031
00037
00038
00047     class MS_MASCOTRESFILE_API ms_masses: public ms_errors
00048     {
00049     public:
00051         ms_masses();
00052
00054         ms_masses(const ms_masses& src);
00055
00057         ms_masses(const ms_umod_configfile& src, bool addMissingResidueMasses=true);
00058
00060         ms_masses(const ms_umod_configfile& src, const ms_quant_component& quantComp);
00061
00063         ms_masses(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
00064
00066         ~ms_masses();
00067
00069         void defaultValues(bool useDefaultResidueMasses=true);
00070
00072         void copyFrom(const ms_masses* right);
00073
00075         void copyFrom(const ms_umod_configfile *right, bool addMissingResidueMasses=true);
00076
00078         ms_modvector applyFixedMods(const ms_modvector *mods, ms_errs *err);
00079
00081         void applyIsotopes(const ms_umod_configfile *umodFile, const ms_quant_component *quantComp);
00082
00084         bool isSame(const ms_masses& other, const MASS_TYPE massType) const;
00085
00086 #ifndef SWIG
00087
00088         ms_masses& operator=(const ms_masses& right);
00089 #endif
00090
00091         std::string getFileName() const;
00092
00094         void setFileName(const char* name);
00095
00097         void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
00098
00100         matrix_science::ms_connection_settings getConnectionSettings() const;
00101
00103         void read_file();
00104
00106         void save_file();
00107
00109         double getResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const;
00110
00112         void setResidueMasses(const char residue, const double massMono, const double massAve);
00113
00115         double getNtermDelta(const matrix_science::MASS_TYPE massType) const;
00116
00118         double getNterminalMass(const matrix_science::MASS_TYPE massType) const;
00119
00121         double getNtermNeutralLoss(const matrix_science::MASS_TYPE massType) const;
00122
00124         void setNtermModification(const double monoDelta,
00125                                   const double aveDelta,
00126                                   const double monoNeutralLoss = 0.0,
00127                                   const double aveNeutralLoss = 0.0);
00128
00130         double getCtermDelta(const matrix_science::MASS_TYPE massType) const;
00131
00133         double getCterminalMass(const matrix_science::MASS_TYPE massType) const;
00134
00136         double getCtermNeutralLoss(const matrix_science::MASS_TYPE massType) const;
00137
00139         void setCtermModification(const double monoDelta,
00140                                   const double aveDelta,
00141                                   const double monoNeutralLoss = 0.0,
00142                                   const double aveNeutralLoss = 0.0);
00143
00145         double getFragResidueMass(const matrix_science::MASS_TYPE massType, const char residue) const;
00146
00148         bool isResidueModified(const char residue) const;
00149
00151         void setResidueModification(const double monoDelta,
00152                                     const double aveDelta,
00153                                     const double monoNeutralLoss,
00154                                     const double aveNeutralLoss,
00155                                     const char *residues);
00156
00158         double getHydrogenMass(const matrix_science::MASS_TYPE massType) const;
00159
00161         void setHydrogenMass(const double massMono, const double massAve);
00162
00164         double getCarbonMass(const matrix_science::MASS_TYPE massType) const;
00165
00167         void setCarbonMass(const double massMono, const double massAve);
00168
00170         double getNitrogenMass(const matrix_science::MASS_TYPE  massType) const;
00171
00173         void setNitrogenMass(const double massMono, const double massAve);
00174
00176         double getOxygenMass(const matrix_science::MASS_TYPE  massType) const;
00177
00179         void setOxygenMass(const double massMono, const double massAve);
00180
00182         double getElectronMass() const;
00183
00185         void setElectronMass(const double mass);
00186
00188         void setStorage(double* res_mono,
00189                         double* res_ave,
00190                         double* hydrogen,
00191                         double* carbon,
00192                         double* nitrogen,
00193                         double* oxygen,
00194                         double* electron);
00195
00197         void defaultMasses(double* res_mono,
00198                            double* res_ave,
00199                            double* hydrogen,
00200                            double* carbon,
00201                            double* nitrogen,
00202                            double* oxygen,
00203                            double* electron,
00204                            bool useDefaultResidueMasses = true);
00205
00206     private:
00207
00208         bool getTwoMasses(char * line,
00209                           char *lineForError,
00210                           double *pMono,
00211                           double *pAve,
00212                           const double dMin,
00213                           const double dMax);
00214
00215         void setCustomProperty();
00216
00217     private:
00218         // final destinations - they are assigned either
00219         // 1) supplied array pointers
00220         // 2) the internal storages
00221         double* res_mono;
00222         double* res_ave;
00223
00224         // mass combined with neutral loss for residue-specific mods
00225         bool res_mod[26];
00226         double* frag_res_mono;
00227         double* frag_res_ave;
00228
00229         // masses of terminal groups for terminus mods
00230         double ntermDelta[2];
00231         double ctermDelta[2];
00232
00233         // neutral losses on terminal groups for terminus mods
00234         double neutralLossNterm[2];
00235         double neutralLossCterm[2];
00236
00237         double* hydrogen;
00238         double* carbon;
00239         double* nitrogen;
00240         double* oxygen;
00241
00242         double* electron;
00243
00244         // internal storages in case they are not supplied with a proper constructor
00245         double _res_mono[26];
00246         double _res_ave[26];
00247         double _frag_res_mono[26];
00248         double _frag_res_ave[26];
00249
00250         double _hydrogen[2];
00251         double _carbon[2];
00252         double _nitrogen[2];
00253         double _oxygen[2];
00254
00255         double _electron;
00256
00257         std::string _fn;
00258         ms_customproperty _custprop;
00259         ms_connection_settings cs_;
00260     }; // class ms_masses // end of config_group
00262 }
00263
00264 #endif // MS_MASSES_HPP
00265
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_matrix.hpp

00001 /*
00002  * Copyright (C) 2002-2013, Matrix Science Limited, London, UK.
00003  * All rights reserved.
00004  *
00005  * @(#)$Source: parser/inc/ms_matrix.hpp $
00006  * @(#)$Revision: 436aa2996c6a3d2d2f0cdb88fab902c2780ae29a | MSPARSER_REL_2_8_1-0-gea32989045 $
00007  * @(#)$Date: 2019-05-16 11:53:33 +0100 $
00008  */
00009
00010 #ifndef MS_MATRIX_HPP
00011 #define MS_MATRIX_HPP
00012
00013
00014 #include <vector>
00015
00016 namespace matrix_science
00017 {
00023
00024
00035     class MS_MASCOTRESFILE_API ms_matrix
00036     {
00037         public:
00038
00039             typedef std::vector<double> column_vector_t;
00040             typedef std::vector<column_vector_t> matrix_t;
00041
00043             static ms_matrix diagonalMatrix(size_t s, double v);
00044
00046             static ms_matrix identityMatrix(size_t s);
00047
00049             static ms_matrix rowMatrix(const std::vector<double> & v);
00050
00052             static ms_matrix columnMatrix(const std::vector<double> & v);
00053
00055             ms_matrix();
00056
00058             ms_matrix(const matrix_t & m);
00059
00061             ms_matrix(size_t si, size_t sj, double v = 0.0);
00062
00064             size_t sizei() const;
00065
00067             size_t sizej() const;
00068
00069 #ifndef SWIG
00070
00071             column_vector_t & operator[](size_t i);
00072
00074             const column_vector_t & operator[](size_t i) const;
00075 #endif
00076
00077             double getCR(size_t i, size_t j) const;
00079             void setCR(size_t i, size_t j, double value);
00080
00082             double getRC(size_t i, size_t j) const { return getCR(j, i); }
00084             void setRC(size_t i, size_t j, double value) {  setCR(j, i, value); }
00085
00087             const matrix_t & data() const;
00088 #ifndef SWIG
00089
00090             bool operator==(const ms_matrix & m) const;
00091
00093             bool operator!=(const ms_matrix & m) const;
00094
00096             ms_matrix operator*(const ms_matrix & m) const;
00097 #endif
00098
00099             bool isZero() const;
00100
00102             void resize(size_t si, size_t sj, double v = 0.0);
00103
00105             double multiplyByRow(const std::vector<double> & column, size_t row) const;
00106
00108             void setColumnDown(size_t row, size_t col, const std::vector<double> & vec);
00109
00111             void setColumnUp(size_t row, size_t col, const std::vector<double> & vec);
00112
00114             void transpose();
00115
00117             void logContents(ms_errs & errs, const char * description) const;
00118
00119         private:
00120             matrix_t matrix_;
00121     };
00122  // end of tools_group
00124 } // namespace matrix_science
00125
00126 #endif // MS_MATRIX_HPP
00127
00128 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_mod_visibility_helper.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_mod_visibility_helper.hpp                                         #
00004 # Mascot Parser toolkit                                                      #
00005 # Utility classes for managing modification visibility                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_mod_visibility_helper.hpp $
00012 #    $Author: francoisr@matrixscience.com $
00013 #      $Date: 2019-03-15 14:15:26 +0000 $
00014 #  $Revision:
00015 ##############################################################################
00016 */
00017
00018 #ifndef _MS_SPECIFICITY_VISIBILITY_H
00019 #define _MS_SPECIFICITY_VISIBILITY_H
00020
00021
00022 #include <string>
00023 #include <vector>
00024
00025 namespace matrix_science {
00026
00027     class ms_umod_specificity;
00028     class ms_umod_configfile;
00029     class ms_modfile;
00030
00036     // \cond INTERNAL
00038
00048     class MS_MASCOTRESFILE_API ms_spec_visibility
00049     {
00050     public:
00052         ms_spec_visibility();
00053
00055         ms_spec_visibility(std::string site);
00057         ms_spec_visibility(std::string site, std::string position);
00059         ~ms_spec_visibility();
00060
00062         std::string getSite();
00064         void setSite(std::string s);
00066         std::string getPosition();
00068         void setPosition(std::string s);
00069
00071         bool isHidden();
00073         void setHidden(bool bHide);
00074
00076         bool inShortList() const;
00078         void showInShortList(bool b);
00080         bool inLongList() const;
00082         void showInLongList(bool b);
00084         bool inErrorTolerant() const;
00086         void useInErrorTolerant(bool b);
00087
00089         bool isOveridden();
00091         void setOveridden(bool b);
00092
00093     private:
00094         void initialise();
00095
00096         std::string m_site;
00097         std::string m_position;
00098         bool        m_show_in_short_list;
00099         bool        m_show_in_long_list;
00100         bool        m_use_in_error_tolerant;
00101         bool        m_overridden;
00102     }; // class ms_spec_visibility
00103     // \endcond
00104
00105
00106     // \cond INTERNAL
00108
00117     class MS_MASCOTRESFILE_API ms_mod_visibility
00118     {
00119     public:
00121         ms_mod_visibility();
00122
00124         ~ms_mod_visibility();
00125
00127         std::string getName();
00129         void setName(std::string s);
00130
00132         void setNumberOfSpecs(int spec_count);
00134         int getNumberOfSpecs();
00136         void getDefaults(int spec_number, const ms_umod_specificity *spec);
00138         void setDefaults(int spec_number, const char site, bool hidden);
00140         void setDefaults(int spec_number, const char site, std::string position, bool hidden);
00141
00142
00144         void applyVisibilities( ms_umod_specificity *spec);
00146         bool updateVisibilities( const ms_umod_specificity *spec);
00148         bool updateIsPrivate(bool is_private);
00149
00151         bool isPrivate() const;
00153         void setPrivate(bool b);
00154
00156         bool isPrivacyEnabled() const;
00158         void setPrivacyEnabled(bool b);
00159
00161         bool hasOverrides();
00163         bool isOveridden();
00165         void setOveridden(bool b);
00166
00168         bool isDeleted();
00170         void setDeleted(bool b);
00171
00173         ms_spec_visibility &getSpecVisibility(int index);
00175         ms_spec_visibility &getSpecVisibility(std::string site, bool bCreate);
00177         ms_spec_visibility &getSpecVisibility(std::string site, std::string position, bool bCreate);
00178
00179     private:
00180
00181         typedef std::vector< ms_spec_visibility> spec_vis_vector;
00182         spec_vis_vector     m_specs;
00183
00184         std::string         m_name;
00185         ms_spec_visibility  m_default_spec;
00186
00187         bool                m_isPrivacyEnabled;
00188         bool                m_isPrivate;
00189         bool                m_overridden;
00190         bool                m_deleted;
00191     }; // class ms_mod_visibility
00192     // \endcond
00193
00194     // \cond INTERNAL
00196
00203     class MS_MASCOTRESFILE_API ms_mod_visibility_helper : public ms_errors
00204     {
00205     public:
00207         ms_mod_visibility_helper();
00208
00210         ms_mod_visibility_helper(const matrix_science::ms_session *session, const std::string &visibility_filename, ms_umod_configfile *config);
00212         ms_mod_visibility_helper(const std::vector<int> & groupIds, const std::string &visibility_filename, ms_umod_configfile *config);
00214         ms_mod_visibility_helper(const matrix_science::ms_session *session, const std::string &visibility_filename, ms_modfile *modfile);
00216         ms_mod_visibility_helper(const std::string &visibility_full_filename);
00218         ~ms_mod_visibility_helper();
00219
00221         bool hasPrivacy();
00222
00224         bool saveToGroupFiles(const matrix_science::ms_session *session, const std::string &visibility_filename, const bool saveAllForCrosslinking = false);
00226         bool saveToFile(const std::string &filename, const bool saveAllForCrosslinking = false);
00227
00229         ms_mod_visibility *getModVisibility(int index);
00231         ms_mod_visibility *getModVisibility(const std::string &mod_title, bool bCreate);
00233         void removeModVisibilty(const std::string &mod_title);
00234
00236         void setVisibilities(matrix_science::ms_umod_configfile *config);
00238         void setVisibilities(matrix_science::ms_modfile *modfile);
00239
00241         static void getUserGroupVisibilty(
00242             matrix_science::ms_session *session, const std::string &mod_title, std::string &visibility_filename,
00243             std::vector<std::string> &excluded_usergroups, std::vector<std::string> &included_usergroups);
00245         static void setUserGroupVisibilty(
00246             matrix_science::ms_session *session, const std::string &mod_title, std::string &visibility_filename,
00247             std::vector<std::string> &excluded_usergroups, std::vector<std::string> &included_usergroups);
00248
00250         static void getDefaultUserGroups(
00251             matrix_science::ms_session *session,
00252             std::vector<std::string> &excluded_usergroups, std::vector<std::string> &included_usergroups);
00253
00254     private:
00255         //Do not copy this object
00256         ms_mod_visibility_helper(const ms_mod_visibility_helper & src);
00257         ms_mod_visibility_helper& operator=(const ms_mod_visibility_helper & right);
00258
00259         // Setup m_show_in_long_list defaults for config specifity "hidden" attributes.
00260         void getDefaults(ms_umod_configfile *config);
00261         void getDefaults(ms_modfile *modfile);
00262         bool getUserGroupFileNames(const matrix_science::ms_session *session, const std::string &visibility_filename, bool bAllGroups, const std::vector<int> * groupIds = NULL);
00263
00264         bool loadFromFile(const std::string &filename);
00265         void loadVisibility(const matrix_science::ms_session *session, const std::string &visibility_filename, const std::vector<int> * groupIds = NULL);
00266
00267         void clearOverrideFlags();
00268
00269         bool getSpecSitesFromModString(std::string modfile_spec_name, std::string &sites, std::string &position);
00270
00271         typedef std::vector< ms_mod_visibility> mod_vis_vector;
00272         mod_vis_vector      m_mods;
00273
00274         ms_mod_visibility   m_default_mod;
00275
00276         std::vector<std::string> m_userGroupVisibilityFiles;
00277         bool            m_inAdminGroup;
00278         bool            m_hasPrivacy;
00279     }; // class ms_mod_visibility_helper
00280     // \endcond
00281  // end of config_group
00283
00284
00285
00286 } // namespace matrix_science
00287
00288 #endif // _MS_SPECIFICITY_VISIBILITY_H
00289
00290 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_modfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_modfile.hpp                                                       #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "mod_file"-file that defines amino acid modifications         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_modfile.hpp             $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2019-12-06 15:52:32 +0000 $ #
00014 #   $Revision: 8cfd594dba4971f7c8b9392eb98e042f7c93fb06 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_MODFILE_HPP
00020 #define MS_MODFILE_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025 #include <memory>
00026
00027 namespace msparser_internal {
00028     class ms_modification_impl;
00029 }
00030
00031 namespace matrix_science {
00032
00033     class ms_masses;
00034     class ms_umod_modification;
00035
00046     enum MOD_TYPES
00047     {
00048         MOD_TYPE_RESIDUE        = 0,
00049         MOD_TYPE_N_TERM         = 1,
00050         MOD_TYPE_C_TERM         = 2,
00051         MOD_TYPE_N_PROTEIN      = 3,
00052         MOD_TYPE_C_PROTEIN      = 4,
00053         MOD_TYPE_N_TERM_RESIDUE = 5,
00054         MOD_TYPE_C_TERM_RESIDUE = 6,
00055         MOD_TYPE_N_PROTEIN_RESIDUE= 7,
00056         MOD_TYPE_C_PROTEIN_RESIDUE= 8,
00057         MOD_TYPE_______LAST     = 9     // This must always be last....
00058     };
00059
00061
00064     enum MASS_TYPE
00065     {
00066         MASS_TYPE_MONO = 0x0000,
00067         MASS_TYPE_AVE  = 0x0001
00068     };
00069
00071
00074     enum
00075     {
00076         MAX_VAR_MODS = 'W' -'A' + 10
00077     };
00078
00079     typedef std::vector<double> ms_vectorDouble;
00080     typedef std::vector< bool > ms_vectorBool;
00081
00083
00133     class MS_MASCOTRESFILE_API ms_modification: public ms_customproperty
00134     {
00135         friend class ms_modfile;
00136         friend class ms_modvector;
00137     public:
00138
00140         ms_modification(const ms_masses* massFile = NULL);
00141
00143         ms_modification(const ms_modification& src);
00144
00146         ~ms_modification();
00147
00149         void defaultValues();
00150
00152         void copyFrom(const ms_modification* src);
00153
00154 #ifndef SWIG
00155
00156         ms_modification& operator=(const ms_modification& right);
00157 #endif
00158
00159         bool getFromUnimod(const char* modName, const ms_umod_configfile *umod_file);
00160
00162         void setMassFile(const ms_masses* massFile);
00163
00165         const ms_masses* getMassFile() const;
00166
00168         void copyMassFile(const ms_masses* massFile);
00169
00171         std::string getTitle() const;
00172
00174         void setTitle(const char* value);
00175
00177         int getModificationType() const;
00178
00180         void setModificationType(const int type);
00181
00183         bool isHidden() const;
00184
00186         void setHidden(const bool value);
00187
00189         bool inShortList() const;
00190
00192         void setInShortList(const bool value);
00193
00195         bool inLongList() const;
00196
00198         void setInLongList(const bool value);
00199
00201         bool inErrorTolerant() const;
00202
00204         void setInErrorTolerant(const bool value);
00205
00207         bool isSubstitution() const;
00208
00210         double getDelta(const MASS_TYPE massType) const;
00211
00213         void setDelta(const double massMono, const double massAve);
00214
00216         ms_vectorDouble getNeutralLoss(const MASS_TYPE massType) const;
00217
00219         ms_vectorBool getNeutralLossRequired() const;
00220
00222         //std::vector< double > getNeutralLossFrequencies() const;
00223
00225         void setNeutralLoss(const ms_vectorDouble massMono, const ms_vectorDouble massAve, const ms_vectorBool required);
00226
00228         int getNumberOfModifiedResidues() const;
00229
00231         char getModifiedResidue(const int n) const;
00232
00234         bool isResidueModified(const char residue) const;
00235
00237         double getResidueMass(const MASS_TYPE massType, const char residue) const;
00238
00240         void clearModifiedResidues();
00241
00243         void appendModifiedResidue(const char residue, const double massMono, const double massAve);
00244
00246         double getNTerminusMass(const MASS_TYPE massType) const;
00247
00249         void setNTerminusMass(const double massMono, const double massAve);
00250
00252         double getCTerminusMass(const MASS_TYPE massType) const;
00253
00255         void setCTerminusMass(const double massMono, const double massAve);
00256
00258         int getNumberOfIgnoreMasses() const;
00259
00261         double getIgnoreMass(const MASS_TYPE massType, const int idx) const;
00262
00264         void clearIgnoreMasses();
00265
00267         void appendIgnoreMass(const double massMono, const double massAve);
00268
00270         ms_vectorDouble getReqPepNeutralLoss(const MASS_TYPE massType) const;
00271
00273         void setReqPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve);
00274
00276         ms_vectorDouble getPepNeutralLoss(const MASS_TYPE massType) const;
00277
00279         void setPepNeutralLoss(const ms_vectorDouble valuesMono, const ms_vectorDouble valuesAve);
00280
00282         bool isGeneratedMonoLinker() const;
00283
00285         bool isLoopLinker() const;
00286
00288         std::string getCode() const;
00289
00291         std::string getPairsWith() const;
00292
00294         std::string getMonoLinkTitle() const;
00295
00297         bool isCrossLinker() const;
00298
00300         void setIsCrossLinker(const bool value);
00301
00303         void setIsGeneratedMonoLinker(const bool value);
00304
00306         void setIsLoopLinker(const bool value);
00307
00309         int getPositionInUnimodAsNeutralLoss() const;
00310
00312         void setPositionInUnimodAsNeutralLoss(const int value);
00313
00315         void setCode(std::string code);
00316
00318         void setPairsWith(std::string pairsWith);
00319
00321         void setTitleSource(const char *unimodName, const char *specString);
00322
00323 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00324 #include "suppress_ms_customproperty.hpp"
00325 #endif
00326
00327     private:
00328         void setCustomProperty();
00329
00330         msparser_internal::ms_modification_impl * m_pImpl;
00331     }; // ms_modification
00332
00334     class MS_MASCOTRESFILE_API ms_modvector
00335     {
00336         friend class ms_modfile;
00337     public:
00339         ms_modvector();
00340
00342         ms_modvector(const ms_modvector& src);
00343
00345         ms_modvector(const ms_umod_modification &src, const ms_umod_configfile &umod_file);
00346
00348         ~ms_modvector();
00349
00351         void copyFrom(const ms_modvector* right);
00352
00354         void copyFrom(const ms_umod_modification* right, const ms_umod_configfile *umod_file);
00355
00356 #ifndef SWIG
00357
00358         ms_modvector& operator=(const ms_modvector& right);
00359 #endif
00360
00362         int getNumberOfModifications() const;
00363
00365         void clearModifications();
00366
00368         void appendModification(const ms_modification* item);
00369
00371         void appendModifications(ms_modvector &right);
00372
00374         const ms_modification * getModificationByNumber(const int numMod) const;
00375
00377         const ms_modification * getModificationByName(const std::string &name) const;
00378
00379     private:
00380         typedef std::vector<ms_modification* > mod_vector;
00381
00382         mod_vector  entries_;
00383     }; // class ms_modvector
00384
00386
00402     class MS_MASCOTRESFILE_API ms_modfile: public ms_errors
00403     {
00404     public:
00406         ms_modfile();
00407
00409         ms_modfile(const ms_modfile& src);
00410
00411
00413         ms_modfile(const ms_umod_configfile& src,
00414             const unsigned int flags = ms_umod_configfile::MODFILE_FLAGS_ALL);
00415
00417         ms_modfile(const char* filename,
00418                    const ms_masses* massFile,
00419                    const bool fromSubstitutions = false,
00420                    const ms_connection_settings * cs = 0);
00421
00423         ~ms_modfile();
00424
00426         void defaultValues();
00427
00429         void copyFrom(const ms_modfile* right);
00430
00432         void copyFrom(const ms_umod_configfile* right,
00433                       const unsigned int flags = ms_umod_configfile::MODFILE_FLAGS_ALL);
00434
00435 #ifndef SWIG
00436
00437         ms_modfile& operator=(const ms_modfile& right);
00438 #endif
00439
00440         void setFileName(const char* name);
00441
00443         std::string getFileName() const;
00444
00446         void setConnectionSettings(const ms_connection_settings & cs);
00447
00449         ms_connection_settings getConnectionSettings() const;
00450
00452         void setMassFile(const ms_masses* massFile);
00453
00455         const ms_masses* getMassFile() const;
00456
00458         bool isFromSubstitutions() const;
00459
00461         void setFromSubstitutions(const bool value);
00462
00464         void read_file();
00465
00467         void save_file();
00468 #ifndef SWIG
00469
00470         void saveToString(std::string & modfileAsStr);
00471 #else // SWIG Multiple return values
00472         void saveToString(std::string & OUTPUT);
00473 #endif
00474
00475         void sortModifications();
00476
00478         int getNumberOfModifications() const;
00479
00481         void clearModifications();
00482
00484         void appendModification(const ms_modification* item);
00485
00487         const ms_modification * getModificationByNumber(const int numMod) const;
00488
00490         const ms_modification * getModificationByName(const char* nameMod) const;
00491
00493         bool updateModificationByNumber(const int num, const ms_modification mod);
00494
00496         bool updateModificationByName(const char* name, const ms_modification mod);
00497
00499         bool deleteModificationByNumber(const int num);
00500
00502         bool deleteModificationByName(const char* name);
00503
00504     private:
00505         void read_text();
00506         void save_text();
00507         void applyVisibility(const ms_session *session);
00508
00509         typedef std::vector<ms_modification* > entries_vector;
00510         entries_vector  entries;
00511
00512         std::string     filename_;
00513 #if !defined(_WIN32) && !defined(__INTEL_COMPILER)
00514 #pragma GCC diagnostic push
00515 #pragma GCC diagnostic ignored "-Wdeprecated-declarations"
00516 #endif
00517         std::auto_ptr<ms_masses> m_massFile;
00518 #if !defined(_WIN32) && !defined(__INTEL_COMPILER)
00519 #pragma GCC diagnostic pop
00520 #endif
00521         std::vector< std::string > comments_;
00522         bool            bFromSubstitutions_;
00523         ms_connection_settings cs_;
00524
00525     }; // ms_modfile // end of config_group
00527 } // namespace matrix_science
00528
00529 #endif // MS_MODFILE_HPP
00530
00531 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_average_results.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_average_results.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_average_results.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_AVERAGE_RESULTS_HPP
00018 #define MS_MS1QUANT_AVERAGE_RESULTS_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace matrix_science
00025 {
00026     //=========================================================================
00032     class ms_ms1quant_average_results_body;
00033
00035
00040     class MS_MASCOTRESFILE_API ms_ms1quant_average_results :
00041         public ms_handle
00042     {
00043         public:
00044
00046             ms_ms1quant_average_results();
00047
00048 #ifndef SWIG
00049             ms_ms1quant_average_results_body * body();
00050             const ms_ms1quant_average_results_body * body() const;
00051 #endif
00052
00054             ms_ms1quant_average_results(const ms_ms1quant_average_results_body & body);
00055
00057             int getReferenceHitId() const;
00059             int getReferenceMemberNumber() const;
00061             int isReferenceUserSelected() const;
00062     };
00063  // end of quantitation_group
00065     //=========================================================================
00066
00067 } // namespace matrix_science
00068
00069 #endif // MS_MS1QUANT_AVERAGE_RESULTS_HPP
00070
00071 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_average_results_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_average_results_body.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram - body
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_AVERAGE_RESULTS_BODY_HPP
00018 #define MS_MS1QUANT_AVERAGE_RESULTS_BODY_HPP
00019
00020 namespace matrix_science
00021 {
00022
00023     class ms_ms1quant_average_results_body :
00024         public ms_body
00025     {
00026         public:
00027             ms_ms1quant_average_results_body();
00028
00029             // Load data from a CDB file, extracting the cache stream and then calling loadStream.
00030             // Returns true if the data stream is present and there was no error loading it (sets isDataFound to true).
00031             // Returns true if the data stream is not present (sets isDataFound to false).
00032             // Returns false if an error was encountered; an absent data stream is not an error.
00033             bool loadFromCdb(matrix_science::ms_tinycdb & cdbFile, bool & isDataFound);
00034             bool loadStream(matrix_science::ms_cache_stream & stream);
00035             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00036
00037             bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00038             bool saveToCdb(matrix_science::ms_tinycdb & cdbFile);
00039             bool saveToStream(matrix_science::ms_cache_stream & stream);
00040
00041             int referenceHitId_;
00042             int referenceMemberNumber_;
00043             bool isReferenceUserSelected_;
00044     };
00045
00046 } // namespace matrix_science
00047
00048 #endif // MS_MS1QUANT_AVERAGE_RESULTS_BODY_HPP
00049
00050 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_charge_state.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_fitexy_result.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_charge_state.hpp $
00012  * @(#)$Revision: 6d5aba983d4d59b45bccc248fadc51d481872df4 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-04-23 16:05:56 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_CHARGE_STATE_HPP
00018 #define MS_MS1QUANT_CHARGE_STATE_HPP
00019
00020
00021 namespace matrix_science
00022 {
00023     //=========================================================================
00029     class ms_ms1quant_charge_state_body;
00030
00032
00035     class MS_MASCOTRESFILE_API ms_ms1quant_charge_state :
00036         public ms_handle
00037     {
00038         public:
00040             ms_ms1quant_charge_state();
00041
00043             ms_ms1quant_charge_state(const ms_ms1quant_charge_state_body & body);
00044
00045 #ifndef SWIG
00046             ms_ms1quant_charge_state_body * body();
00047             const ms_ms1quant_charge_state_body * body() const;
00048
00050             ms_ms1quant_charge_state(const double correctSppWidthMin,
00051                                      const double correctSppWidthMax,
00052                                      const double correctSppWidth,
00053                                      const double bucketWidth,
00054                                      const double maxAlignment,
00055                                      const double matchedRho,
00056                                      const double matchedFraction,
00057                                      const double totalIntensity,
00058                                      const std::map<int, double> & bucketAreas,  // scanId -> area
00059                                      const std::vector<double>   & calcMzVar,                // row matrix calcmz
00060                                      const std::vector<int>     & idx2Comp
00061
00062                 );
00063 #endif
00064
00066             double getCorrectedMinSPPwidth() const;
00067
00069             double getCorrectedMaxSPPwidth() const;
00070
00072             double getCorrectedSPPwidth() const;
00073
00075             double getBucketWidth() const;
00076
00078             double getMaxAlignment() const;
00079
00081             double getMatchedRho() const;
00082
00084             double getMatchedFraction() const;
00085
00087             double getTotalIntensity() const;
00088
00090             int getNumberOfBuckets() const;
00091 #ifndef SWIG
00092
00093             bool getBucket(int index, unsigned & scanId, double & area) const;
00094 #else // SWIG Multiple return values
00095             bool getBucket(int index, unsigned & OUTPUT, double & OUTPUT) const;
00096 #endif
00097             // \cond INTERNAL
00098
00100             void setCorrectedMinSPPwidth(double width);
00101
00103             void setCorrectedMaxSPPwidth(double width);
00104
00106             void setCorrectedSPPwidth(double width) ;
00107
00109             void setBucketWidth(double width);
00110
00112             void setMaxAlignment(double alignemnt);
00113
00115             void setMatchedRho(double rho);
00116
00118             void setMatchedFraction(double fraction);
00119
00121             void setTotalIntensity(double intensity);
00122
00124             std::vector<double> & getCalcMz();
00125
00127             const std::vector<double> & getCalcMz() const;
00128
00130             std::vector<int> & getIdx2Comp();
00131
00133             int getIdx2Comp(std::size_t index) const;
00134
00136             std::map<int, double> & getBucketAreas();
00137
00138             // \endcond
00139     };
00140  // end of quantitation_group
00142     //=========================================================================
00143
00144 } // namespace matrix_science
00145
00146 #endif // MS_MS1QUANT_CHARGE_STATE_HPP
00147
00148 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_charge_state_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_charge_state_body.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_CHARGE_STATE_BODY_HPP
00018 #define MS_MS1QUANT_CHARGE_STATE_BODY_HPP
00019
00020 #include <map>
00021
00022 namespace matrix_science
00023 {
00024     class ms_ms1quant_charge_state_body :
00025         public ms_body
00026     {
00027         public:
00028             double correctSppWidthMin_;
00029             double correctSppWidthMax_;
00030             double correctSppWidth_;
00031             double bucketWidth_;
00032             double maxAlignment_;
00033             double matchedRho_;
00034             double matchedFraction_;
00035             double totalIntensity_;
00036             std::map<int, double> bucketAreas_; // scanId -> area
00037             std::vector<double> calcMzVar_;     // Saved as a matrix in the xml/cdb, but it's only ever one column
00038             std::vector<int> idx2comp_;
00039
00040             ms_ms1quant_charge_state_body();
00041
00042             bool loadStream(matrix_science::ms_cache_stream & stream);
00043             bool loadCache(matrix_science::ms_cache_stream & stream);
00044             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00045
00046             bool saveToStream(matrix_science::ms_cache_stream & stream) const;
00047             bool saveCacheToStream(matrix_science::ms_cache_stream & stream) const;
00048             bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, bool completeReport) const;
00049     };
00050 }
00051
00052 #endif // MS_MS1QUANT_CHARGE_STATE_BODY_HPP
00053
00054 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_match.hpp $
00012  * @(#)$Revision: f505c54c65f9b7a686953cde690d0fe22a5a6c85 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-08-19 16:33:39 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_HPP
00018 #define MS_MS1QUANT_MATCH_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace matrix_science
00025 {
00026     //=========================================================================
00032     class ms_ms1quant_match_body;
00033     class ms_protein;
00034     class ms_peptide;
00035     class ms_quant_component;
00036
00038
00045     class MS_MASCOTRESFILE_API ms_ms1quant_match :
00046         public ms_handle
00047     {
00048         public:
00050
00053             enum chargeType
00054             {
00055                 CHARGETYPE_ORIGINAL,
00056                 CHARGETYPE_ALL
00057             };
00058
00060             static std::string getXmlCode(chargeType code);
00061
00063             static chargeType getCodeFromXml(std::string text);
00064
00066             ms_ms1quant_match();
00067
00069             ms_ms1quant_match(const ms_ms1quant_match_body & body);
00070
00071 #ifndef SWIG
00072
00073             ms_ms1quant_match_body * body();
00075             const ms_ms1quant_match_body * body() const;
00076
00078             bool addProteinHit(const int hit, const int member);
00080             void setKey(const int id);
00082             void applyThresholds();
00083 #endif
00084
00086             matrix_science::ms_peptide_quant_key getKey() const;
00087
00089             bool hasIdentifiedComponent() const;
00090
00092             bool allComponentsIdentified() const;
00093
00095             std::string getPeptideString() const;
00096
00098             std::string getVarMods() const;
00099
00101             int getFirstXicScanId() const;
00102
00104             void setFirstXicScanId(int value) ;
00105
00107             int getLastXicScanId() const;
00108
00110             void setLastXicScanId(int value) ;
00111
00113             double getDisplayIntensity() const;
00114
00116             void setDisplayIntensity(double value);
00117
00119             int getChargeState() const;
00120
00122             chargeType getChargeType() const;
00123
00125             std::string getLabelFreeVarMods() const;
00126
00128             std::string getReadableLabelFreeVarMods() const;
00129
00131             std::string getConciseLabelFreeVarMods() const;
00132
00134             int getDataSourceId() const;
00135
00137             const ms_matrix & getCorrectionMatrix() const;
00138
00139 #if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
00140
00141             ms_matrix & getCorrectionMatrix();
00142 #endif
00143
00144             const ms_matrix & getPerfectObservedMatrix() const;
00145
00146 #if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
00147
00148             ms_matrix & getPerfectObservedMatrix();
00149 #endif
00150
00151             const ms_matrix & getPredictionMatrix() const;
00152
00153 #if !defined(SWIGJAVA) && !defined(SWIGCSHARP)
00154
00155             ms_matrix & getPredictionMatrix();
00156 #endif
00157
00158             int getNumHits() const;
00160             const ms_protein * getHit(int index1) const;
00161
00163             int getNumComponents() const;
00165             ms_ms1quant_match_component getComponent(int index) const;
00166
00168             bool hasComponent(std::string componentName) const;
00170             ms_ms1quant_match_component getComponent(std::string componentName) const;
00171
00172             ms_ms1quant_match_component * addCreatedComponent(
00173                     const matrix_science::ms_peptide & peptide,
00174                     const matrix_science::ms_quant_component & component);
00175
00176             ms_ms1quant_match_component * addCreatedComponent(const std::string & componentName);
00177
00179             ms_ms1quant_match_component * addCreatedComponent(
00180                 const matrix_science::ms_ms1quant_match_component & component);
00181
00183             ms_ms1quant_match_component * addComponent(const matrix_science::ms_ms1quant_match_component & component);
00184
00186             bool removeComponent(const std::string & componentName);
00187
00188             ms_ms1quant_match_component * addIdentifiedComponent(
00189                     const matrix_science::ms_peptide & peptide,
00190                     const matrix_science::ms_quant_component & component);
00191
00193             int getNumPeptideRatios() const;
00195             ms_ms1quant_match_ratio getPeptideRatio(int index) const;
00196
00198             bool hasPeptideRatio(const std::string & ratioName) const;
00200             ms_ms1quant_match_ratio getPeptideRatio(const std::string & ratioName) const;
00202             void setPeptideRatio(const std::string & ratioName, const ms_ms1quant_match_ratio & ratio);
00203
00205             ms_ms1quant_charge_state getChargeStateData() const;
00207             void setChargeStateData(const ms_ms1quant_charge_state & csData);
00208
00210             bool isHitRatioOutlier(const std::string & ratioName, int hitId, int memberNumber) const;
00212             bool isHitRatioUsedForAverage(const std::string & ratioName, int hitId, int memberNumber) const;
00214             bool isHitRatioExcluded(const std::string & ratioName, int hitId, int memberNumber) const;
00215
00217             void setHitRatioExcluded(const std::string & ratioName, int hitId, int memberNumber);
00218
00220             void clearHitRatioExcluded(const std::string & ratioName, int hitId, int memberNumber);
00221
00223             void setHitRatioOutlier(const std::string & ratioName, int hitId, int memberNumber);
00224
00226             void clearHitRatioOutlier(const std::string & ratioName, int hitId, int memberNumber);
00227     };
00228
00229  // end of quantitation_group
00231     //=========================================================================
00232
00233 } // namespace matrix_science
00234
00235 #endif // MS_MS1QUANT_MATCH_HPP
00236
00237 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_body.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram - body
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_BODY_HPP
00018 #define MS_MS1QUANT_MATCH_BODY_HPP
00019
00020 // Includes from the standard template library
00021 #include <string>
00022 #include <map>
00023 #include <set>
00024
00025 namespace matrix_science
00026 {
00027     class ms_ms1quantitation;
00028     class ms_mascotresfile;
00029
00030     class MS_PARSERINTERNAL_API ms_ms1quant_match_body :
00031         public ms_body
00032     {
00033         public:
00034             typedef std::pair<int, int> Hitkey; // hitId, memberNumber (from file, may be different to peptide summary)
00035             typedef std::map<Hitkey, Hitkey> HitkeyMap; // map hitkey from the one loaded to the one in the peptide summary (and is actually used)
00036             typedef std::set<Hitkey> HitkeySet;
00037             typedef std::map<std::string, HitkeySet> ratioHitkeySetMap;
00038             typedef std::map<std::string, Hitkey> AccessionLookup;  // key = accession, Hitkey = hit/member from peptide summary
00039
00040             static std::string HitKeyString(const Hitkey & hitkey);
00041
00042             ms_ms1quant_match_body(ms_ms1quantitation & result);
00043             ms_ms1quant_match_body(const ms_ms1quant_match_body & sibling, int newCharge);
00044             ms_ms1quant_match_body(const ms_ms1quant_match_body & source, ms_ms1quantitation & result, const matrix_science::ms_mascotresfile & resfile, int matchID, int dataSourceID);
00045
00046
00047             const ms_ms1quant_match_ratio * getPeptideRatio(const std::string & ratioName) const;
00048             const ms_ms1quant_match_component * getComponent(const std::string & componentName) const;
00049             // validate the quant match
00050             void applyThresholds();
00051
00052             // Load data from a CDB file, extracting the cache stream and then calling loadStream
00053             bool loadFromCdb(matrix_science::ms_tinycdb & cdbFile, size_t iMatch, matrix_science::ms_cache_file & cacheFile, const ms_ms1quant_match_body::HitkeyMap & hitkeyMap);
00054             // Load data from a cache stream.
00055             bool loadStream(matrix_science::ms_cache_stream & stream, matrix_science::ms_cache_file & cacheFile, const ms_ms1quant_match_body::HitkeyMap & hitkeyMap);
00056             // load cache data (from the cache file, not the CDB)
00057             bool loadCacheMatrix(matrix_science::ms_matrix & matrix, matrix_science::ms_cache_stream & stream);
00058             // Load data from a CDB file, extracting the cache stream and then calling loadStream
00059             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const ms_ms1quant_match_body::HitkeyMap & hitkeyMap);
00060
00061             bool saveToCdb(matrix_science::ms_tinycdb & cdbFile, matrix_science::ms_cache_file & cacheFile, bool createEmptyMissingComponents = false) const;
00062             bool saveCacheToStream(matrix_science::ms_cache_stream & stream) const;
00063             bool saveCacheMatrix(const matrix_science::ms_matrix & matrix, matrix_science::ms_cache_stream & stream) const;
00064             bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, bool processSeparately, bool completeReport, const std::map<std::string, double> & normalisationBaseValues) const;
00065
00066             ms_ms1quantitation & result_;
00067
00068             bool isCacheLoaded_; // when loaded from the cache file this is set, false if not currently loaded
00069
00070             int matchId_; // when loaded from CDB this is the index 0..n-1
00071             mutable INT64 cacheStreamId_; // may change when saved to stream
00072             int dataSourceID_;
00073             int firstXicScanId_;
00074             int lastXicScanId_;
00075             double displayIntensity_;
00076             int charge_;
00077             ms_ms1quant_match::chargeType chargeType_;
00078             ms_ms1quant_charge_state chargeState_;
00079             std::string peptideString_;
00080             std::string labelFreeVarmods_;
00081             std::string readableLabelFreeMods_;
00082             std::string conciseLabelFreeMods_;
00083
00084             ms_matrix matA_;
00085             ms_matrix matPerfect_;
00086             ms_matrix matPredicted_;
00087             std::list<ms_ms1quant_match_component> components_;
00088             std::map<std::string, matrix_science::ms_ms1quant_match_ratio> ratios_; // key is ratio name
00089
00090             std::set<Hitkey> matchHitkeys_;
00091
00092             ratioHitkeySetMap outlierRatioHitkeys_;
00093             ratioHitkeySetMap usedForAverageRatioHitkeys_;
00094             ratioHitkeySetMap excludeRatioHitkeys_;
00095
00096             bool isHitRatioSet(const ms_ms1quant_match_body::ratioHitkeySetMap & map, Hitkey hitkey, const std::string & ratioName) const;
00097             void setHitRatioSet(ms_ms1quant_match_body::ratioHitkeySetMap * map, Hitkey hitkey, const std::string & ratioName);
00098             void clearHitRatioSet(ms_ms1quant_match_body::ratioHitkeySetMap * map, Hitkey hitkey, const std::string & ratioName);
00099
00100             ms_ms1quant_match_component * insertComponent(const ms_ms1quant_match_component_body & body);
00101
00102             bool removeComponent(const std::string & componentName);
00103
00105             bool isMatchInferred() const;
00106         private:
00107             bool saveToStream(matrix_science::ms_cache_stream & stream, bool createEmptyMissingComponents) const;
00108             bool saveToCache(matrix_science::ms_cache_file & cacheFile) const;
00109             bool convertHitkey(Hitkey * key, const HitkeyMap & map);
00110     };
00111
00112 } // namespace matrix_science
00113
00114 #endif // MS_MS1QUANT_MATCH_BODY_HPP
00115
00116 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_component.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_component.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_match_component.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_COMPONENT_HPP
00018 #define MS_MS1QUANT_MATCH_COMPONENT_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace matrix_science
00025 {
00026     //=========================================================================
00032     class ms_ms1quant_match_component_body;
00033
00035
00038     class MS_MASCOTRESFILE_API ms_ms1quant_match_component :
00039         public ms_handle
00040     {
00041         public:
00043             ms_ms1quant_match_component();
00044
00046             ms_ms1quant_match_component(const ms_ms1quant_match_component_body & body);
00047
00048 #ifndef SWIG
00049
00050             ms_ms1quant_match_component_body * body();
00052             const ms_ms1quant_match_component_body * body() const;
00054             void removePeptide(const int q, const int p);
00055 #endif
00056
00058             std::string getComponent() const;
00059
00061             bool isComponentIdentified() const;
00062
00064             double getRelativeMass() const;
00065
00067             double getMoverz() const;
00068
00070             std::string getVarModsStr() const;
00071
00073             std::string getSummedModsStr() const;
00074
00076             bool hasAbsoluteValue() const;
00077
00079             double getAbsoluteValue() const;
00080
00082             void setAbsoluteValue(double value);
00083
00085             ms_xic getXic() const;
00086
00088             ms_xic * getXicPtr();
00089
00091             int getNumRanges() const;
00093             ms_ms1quant_match_range getRange(int index) const;
00094
00095             void setRanges(std::vector<ms_ms1quant_match_range> ranges);
00096
00098             int getNumPeptides() const;
00099 #ifndef SWIG
00100
00101             void getPeptideKey(int index, int & q, int & p) const;
00102 #else // SWIG Multiple return values
00103             void getPeptideKey(int index, int & OUTPUT, int & OUTPUT) const;
00104 #endif
00105     };
00106  // end of quantitation_group
00108     //=========================================================================
00109
00110 } // namespace matrix_science
00111
00112 #ifndef SWIG
00113 namespace msparser_internal
00114 {
00115     MS_PARSERINTERNAL_API double calcRelMassFromMz(double mz, long charge);
00116     MS_PARSERINTERNAL_API double calcMzFromRelMass(double mr, long charge);
00117 }
00118 #endif
00119
00120 #endif // MS_MS1QUANT_MATCH_COMPONENT_HPP
00121
00122 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_component_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_component_body.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_COMPONENT_BODY_HPP
00018 #define MS_MS1QUANT_MATCH_COMPONENT_BODY_HPP
00019
00020
00021 // Define this to save CDB files compatible with Distiller 2.5.1 (which are then saved in project files).
00022 // Commented this out as part of Bug 13354. Files produced with this commented out are compatible with Distiller 2.6 and later
00023 // #define SAVE_CDB_DISTILLER_2_5_1
00024
00025 // See bug 13355
00026 // #define SAVE_CDB_DISTILLER_2_7_1
00027
00028
00029 // Includes from the standard template library
00030 #include <string>
00031
00032 namespace matrix_science
00033 {
00034     class ms_peptide_quant_key;
00035     class ms_ms1quantitation;
00036     class ms_quant_component;
00037     class ms_peptide;
00038
00039     class ms_ms1quant_match_component_body :
00040         public matrix_science::ms_body
00041     {
00042         public:
00043             enum ORIGIN
00044             {
00045                 origin_none,
00046                 origin_identified,
00047                 origin_created,
00048             };
00049
00050             std::string component_;
00051             ORIGIN origin_;
00052             double mrcalc_;
00053             double moverz_;
00054             bool hasAbsoluteValue_;
00055             double absoluteValue_;
00056
00057             std::string varModsStr_;
00058             std::string summedModsStr_;
00059
00060             std::vector<ms_ms1quant_match_range> ranges_;
00061             std::set<matrix_science::ms_peptide_quant_key> componentPeptides_;
00062             ms_xic xic_;
00063
00064             ms_ms1quant_match_component_body();
00065
00066             ms_ms1quant_match_component_body(const matrix_science::ms_quant_component & component, const matrix_science::ms_peptide & peptide, ORIGIN origin);
00067             ms_ms1quant_match_component_body(const matrix_science::ms_ms1quant_match_component & component, int newCharge);
00068
00069             void deepCopy(const ms_ms1quant_match_component_body & src);
00070
00071             bool loadStream(
00072                     matrix_science::ms_cache_stream & stream,
00073                     matrix_science::ms_cache_file & cacheFile,
00074                     int charge,
00075                     matrix_science::ms_ms1quantitation & result);
00076             bool loadFromXml(
00077                     msparser_internal::ms_XMLHelper & helper,
00078                     msparser_internal::ms_XMLElement & element,
00079                     int charge,
00080                     matrix_science::ms_ms1quantitation & result);
00081
00082             void updateMoverZ(int newCharge);
00083
00084             bool saveToStream(matrix_science::ms_cache_stream & stream) const;
00085             bool saveToCache(matrix_science::ms_cache_file & cacheFile) const;
00086             bool saveToXml(msparser_internal::ms_XMLHelper & helper,
00087                            msparser_internal::ms_XMLElement & element,
00088                            const std::string & peptideString,
00089                            const std::string & labelFreeVarMods,
00090                            bool processSeparately,
00091                            bool completeReport,
00092                            const std::string & overrideComponent,
00093                            const matrix_science::ms_ms1quantitation & ms1quantitation) const;
00094     };
00095
00096 } // namespace matrix_science
00097
00098 #endif // MS_MS1QUANT_MATCH_COMPONENT_BODY_HPP
00099
00100 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_range.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_range.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_match_range.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_RANGE_HPP
00018 #define MS_MS1QUANT_MATCH_RANGE_HPP
00019
00020
00021 namespace matrix_science
00022 {
00023     //=========================================================================
00029     class ms_ms1quant_match_range_body;
00030
00032
00035     class MS_MASCOTRESFILE_API ms_ms1quant_match_range :
00036         public ms_handle
00037     {
00038         public:
00040             ms_ms1quant_match_range();
00041
00043             ms_ms1quant_match_range(const ms_ms1quant_match_range_body & body);
00044
00046             ms_ms1quant_match_range(int scanId, double rt);
00047
00049             void extend(int scanId, double rt);
00050
00051 #ifndef SWIG
00052             ms_ms1quant_match_range_body * body();
00053             const ms_ms1quant_match_range_body * body() const;
00054 #endif
00055 #ifndef SWIG
00056
00057             void getRt(double & start, double & end) const;
00058
00060             void getScan(int & start, int & end) const;
00061 #else // SWIG Multiple return values
00062             void getRt(double & OUTPUT, double & OUTPUT) const;
00063             void getScan(int & OUTPUT, int & OUTPUT) const;
00064 #endif
00065     };
00066  // end of quantitation_group
00068     //=========================================================================
00069
00070 } // namespace matrix_science
00071
00072 #endif // MS_MS1QUANT_MATCH_RANGE_HPP
00073
00074 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_range_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_range_body.hpp
00004 # 'msparser' toolkit
00005 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_RANGE_BODY_HPP
00018 #define MS_MS1QUANT_MATCH_RANGE_BODY_HPP
00019
00020 // Includes from the standard template library
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00025
00026     class ms_ms1quant_match_range_body :
00027         public matrix_science::ms_body
00028     {
00029         public:
00030             bool  saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element) const;
00031
00032             double rtStart_;
00033             double rtFinish_;
00034             int scanStart_;
00035             int scanFinish_;
00036     };
00037
00038 } // namespace matrix_science
00039
00040 #endif // MS_MS1QUANT_MATCH_RANGE_BODY_HPP
00041
00042 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_ratio.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_ratio.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_match_ratio.hpp $
00012  * @(#)$Revision: 8e4151b262f3acce03627aeb892da3923c8383b8 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2021-06-15 17:07:47 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_RATIO_HPP
00018 #define MS_MS1QUANT_MATCH_RATIO_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023 #include <vector>
00024
00025 namespace matrix_science
00026 {
00027     //=========================================================================
00033     class ms_ms1quant_match_ratio_body;
00034     class ms_quant_method;
00035     class ms_fitexy_result;
00036
00038
00041     class MS_MASCOTRESFILE_API ms_ms1quant_match_ratio :
00042         public ms_handle
00043     {
00044         public:
00046
00055             enum ratioStatusCode
00056             {
00057                 RS_EMPTY = 0,
00058                 RS_OK = 1,
00059                 RS_ISOLATEDPRECURSORFAILED = 2,
00060                 RS_INTEFERENCEFAILED = 4,
00061                 RS_NODATA = 8,
00062                 RS_FITEXYSIGMA = 16,
00063                 RS_NEGATIVERATIO = 32,
00064                 RS_INFINITERATIO = 64,
00065                 RS_ZERORATIO = 128,
00066                 RS_DO_NOT_USE = 256,
00067                 RS_TOTALINTENSITYFAILED = 512,
00068                 RS_VALID_FLAGS = RS_OK | RS_ISOLATEDPRECURSORFAILED | RS_INTEFERENCEFAILED | RS_NODATA | RS_FITEXYSIGMA | RS_NEGATIVERATIO | RS_INFINITERATIO | RS_ZERORATIO | RS_TOTALINTENSITYFAILED
00069             };
00070
00072             static std::string getXmlCode(ratioStatusCode code);
00073
00075             static ratioStatusCode getCodeFromXml(std::string text);
00076
00078             static bool getCodeInfo(ratioStatusCode code, const ms_quant_method & method, double & info);
00079
00081             ms_ms1quant_match_ratio();
00082
00084             ms_ms1quant_match_ratio(const ms_ms1quant_match_ratio_body & body);
00085
00087             std::string getRatioName() const;
00088
00090             bool isSet() const;
00091
00093             double getValue() const;
00094
00096             double getQuality() const;
00097
00099             bool isValid() const;
00100
00102             bool isUsedForAverage() const;
00103
00105             bool isIncluded() const;
00106
00108             bool getFitexy(ms_fitexy_result & value) const;
00109
00111             int getStatus() const;
00112
00114             std::vector<ratioStatusCode> getStatusList() const;
00115
00116 #ifndef SWIG
00117
00118             ms_ms1quant_match_ratio_body * body();
00120             const ms_ms1quant_match_ratio_body * body() const;
00122             void setStatus(const int status);
00124             void setValid(const bool valid);
00126             void setInclude(const bool include);
00128             void setFitexy(const ms_fitexy_result & value);
00130             void setValue(const std::string & ratioName, double value, double quality, bool usedForAverage, bool include);
00131 #endif
00132     };
00133  // end of quantitation_group
00135     //=========================================================================
00136
00137 } // namespace matrix_science
00138
00139 #endif // MS_MS1QUANT_MATCH_RATIO_HPP
00140
00141 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_match_ratio_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_match_ratio_body.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram - body
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_MATCH_RATIO_BODY_HPP
00018 #define MS_MS1QUANT_MATCH_RATIO_BODY_HPP
00019
00020 // Includes from the standard template library
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00025
00026     class MS_PARSERINTERNAL_API ms_ms1quant_match_ratio_body :
00027         public ms_body
00028     {
00029         public:
00030             static bool loadRatioStatesFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, int * returnStates, bool * outlier);
00031
00032             ms_ms1quant_match_ratio_body();
00033
00034             // Load data from a cache stream.
00035             bool loadStream(matrix_science::ms_cache_stream & stream);
00036             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00037
00038             bool saveToStream(matrix_science::ms_cache_stream & stream) const;
00039             bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_quant_method & method, bool includeFitexy, bool outlier, const std::map<std::string, double> & normalisationBaseValues) const;
00040
00041             std::string ratioName_;
00042
00043             bool valid_;
00044             bool set_;
00045             bool include_;
00046             bool usedForAverage_;
00047             double quality_;
00048             double value_;
00049             int status_;
00050             bool hasFitexy_;
00051             ms_fitexy_result fitexy_;
00052     };
00053
00054 } // namespace matrix_science
00055
00056 #endif // MS_MS1QUANT_MATCH_RATIO_BODY_HPP
00057
00058 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_peptide_status.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_peptide_status.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quant_peptide_status.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_PEPTIDE_STATUS_HPP
00018 #define MS_MS1QUANT_PEPTIDE_STATUS_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace matrix_science
00025 {
00026     //=========================================================================
00032     class ms_ms1quant_peptide_status_body;
00033     class ms_peptide;
00034
00036
00039     class MS_MASCOTRESFILE_API ms_ms1quant_peptide_status :
00040         public ms_handle
00041     {
00042         public:
00044
00047             enum peptideStatus
00048             {
00049                 PS_OK = 0,
00050                 PS_EXPECTGREATERTHAN = 1,
00051                 PS_LESSTHANIDENTITY = 2,
00052                 PS_MINCHARGE = 3,
00053                 PS_NOTUNIQUE = 4,
00054                 PS_SCORELESSHOMOLOGY = 5,
00055                 PS_SCORELESSIDENTITY_NOHOMO = 6,
00056                 PS_SCORELESSTHRESHOLD = 7,
00057                 PS_EXCLUDE_LOCALDEF = 8,
00058                 PS_EXCLUDE_MODFILE = 9,
00059                 PS_EXCLUDE_UNMODIFIED = 10,
00060                 PS_NOTPARTOFQUANTITATION = 11,
00061                 PS_DUPLICATESAMEQUERY = 12,
00062                 PS_MAX = 13
00063             };
00064
00066             static std::string getXmlCode(peptideStatus code);
00067
00069             static peptideStatus getCodeFromXml(std::string str);
00070
00072             ms_ms1quant_peptide_status();
00073
00075             ms_ms1quant_peptide_status(const ms_ms1quant_peptide_status_body & body);
00076
00078             int getQuery() const;
00079
00081             int getRank() const;
00082
00084             std::string getComponent() const;
00085
00087             peptideStatus getStatus() const;
00088
00089 #ifndef SWIG
00090
00091             ms_ms1quant_peptide_status(
00092                     int query,
00093                     int rank,
00094                     const std::string & component,
00095                     ms_ms1quant_peptide_status::peptideStatus status);
00097             ms_ms1quant_peptide_status_body * body();
00099             const ms_ms1quant_peptide_status_body * body() const;
00101             void setStatus(const peptideStatus status);
00102 #endif
00103     };
00104  // end of quantitation_group
00106     //=========================================================================
00107
00108 } // namespace matrix_science
00109
00110 #endif // MS_MS1QUANT_PEPTIDE_STATUS_HPP
00111
00112 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quant_peptide_status_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quant_peptide_status_body.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram - body
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANT_PEPTIDE_STATUS_BODY_HPP
00018 #define MS_MS1QUANT_PEPTIDE_STATUS_BODY_HPP
00019
00020 // Includes from the standard template library
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00025     class ms_peptidesummary;
00026
00027     class ms_ms1quant_peptide_status_body :
00028         public ms_body
00029     {
00030         public:
00031             static bool greater ( const ms_ms1quant_peptide_status_body & elem1, const ms_ms1quant_peptide_status_body & elem2 );
00032
00033             int query_;
00034             int rank_;
00035             std::string component_;
00036             ms_ms1quant_peptide_status::peptideStatus status_;
00037
00038             ms_ms1quant_peptide_status_body();
00039
00040             // Load data from a cache stream.
00041             bool loadStream(matrix_science::ms_cache_stream & stream);
00042             // Load data from an XML element.
00043             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element);
00044
00045             bool saveToStream(matrix_science::ms_cache_stream & stream);
00046             bool saveHitToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_peptidesummary & peptideSummary);
00047     };
00048
00049 } // namespace matrix_science
00050
00051 #endif // MS_MS1QUANT_PEPTIDE_STATUS_BODY_HPP
00052
00053 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms1quantitation.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms1quantitation.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_ms1quantitation.hpp $
00012  * @(#)$Revision: 211b4f6d8eb604aac8475e054404febcf611b332 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2020-06-04 14:02:19 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_MS1QUANTITATION_HPP
00018 #define MS_MS1QUANTITATION_HPP
00019
00020
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <vector>
00026
00027 namespace msparser_internal
00028 {
00029     class ms_XMLElement;
00030     class ms_XMLHelper;
00031 }
00032
00033 namespace matrix_science
00034 {
00035     //=========================================================================
00041     class ms_msquant1_mod_format;
00042     class ms_cache_stream;
00043     class ms_progress_info;
00044     class ms_mascotresults_params;
00045
00047
00089     class MS_MASCOTRESFILE_API ms_ms1quantitation :
00090         public ms_customquantitation
00091     {
00092         public:
00094             enum MERGE_QUANT_RESULTS_FLAGS {
00095                 MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS = 0x0001,
00096                 MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH     = 0x0002,
00097                 MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC  = 0x0004,
00098                 MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE          = 0x0008,
00099
00100                 MERGE_QUANT_DEFAULT_PRECURSOR_METHOD              = MERGE_QUANT_APPLY_THRESHOLDS_AFTER_MERGE,
00101                 MERGE_QUANT_DEFAULT_REPLICATE_METHOD              = (MERGE_QUANT_QUERY_NUMBERS_ARE_FROM_MERGED_RESULTS | MERGE_QUANT_MERGE_COMPONENTS_INTO_QUANT_MATCH | MERGE_QUANT_USE_COMPONENT_FILE_INDEX_TO_FIND_XIC)
00102             };
00103
00105
00114             enum MS1QUANT_BUGFIX_NUM {
00115                 BUGFIX_12409 = 12409
00116             };
00117
00119             ms_ms1quantitation(const ms_peptidesummary & summary, const ms_quant_method & method);
00120
00121             ~ms_ms1quantitation();
00122
00124             int getNumPeptideStatuses() const;
00126             ms_ms1quant_peptide_status getPeptideStatus(int index) const;
00127
00129             int getNumHits() const;
00131             ms_protein * getHit(int index1) const;
00132
00134             int getNumProteinFamilies() const;
00135
00137             int getNumMatches() const;
00139             ms_ms1quant_match getMatch(int index) const;
00141             ms_ms1quant_match getMatch(const ms_peptide_quant_key & key) const;
00142
00143             void clearMatches();
00144
00146             void addMatchStatus(
00147                     matrix_science::ms_peptide * peptide,
00148                     matrix_science::ms_ms1quant_peptide_status::peptideStatus status,
00149                     matrix_science::ms_protein * hit = 0);
00150
00152             void addMatchPeptide(
00153                     matrix_science::ms_protein * hit,
00154                     matrix_science::ms_peptide * peptide,
00155                     const matrix_science::ms_quant_component & component,
00156                     const std::string & matchBelongsToComponent);
00157
00159             matrix_science::ms_ms1quant_match addMatchInferred(
00160                     const ms_ms1quant_match & siblingMatch,
00161                     int newCharge);
00162
00164             void removeMatch(matrix_science::ms_peptide_quant_key matchKey);
00165
00167             bool findPeptideStatus(int query, int rank, ms_ms1quant_peptide_status * peptideStatus) const;
00168
00170             bool findMatch(matrix_science::ms_peptide_quant_key matchKey, ms_ms1quant_match * match) const;
00171
00173             const ms_ms1quant_average_results * getAverageResults() const;
00174
00176             bool loadXmlFile(const std::string & filename, const std::string & xmlSchemaPath);
00177
00179             bool saveXmlFile(const std::string & xmlFilename, bool completeReport);
00180
00182             bool loadCdbFile(const std::string & cdbFilename, const std::string & cacheFilename, bool revalidateQualityThresholds=true);
00183
00185             bool saveCdbFile(const std::string & cdbFilename, const std::string & cacheFilename, bool createEmptyMissingComponents = false);
00186
00188             const ms_peptidesummary & getSummary() const;
00189
00191             std::string getReadableVarMods(std::string varmods);
00192
00194             std::string getReadableVarModsConcise(std::string varmods);
00195
00197             std::string getLabelFree(std::string peptideStr, std::string varMods, std::string summedMods, const matrix_science::ms_quant_component & comp) const;
00198
00200             int getNumMatchesForHit(int hitId, int memberNumber) const;
00202             ms_ms1quant_match getMatchForHit(int index, int hitId, int memberNumber) const;
00203
00205             int getNumGroups() const;
00206
00207             int getDatasourceForGroup(int groupIndex1) const;
00208
00210             int getNumMatchesForGroup(int groupIndex1) const;
00211
00212             ms_ms1quant_match getMatchForGroup(int matchIndex1, int groupIndex1) const;
00213
00215             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const;
00216
00218             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const;
00219
00221             std::vector<double> getAllProteinRatios(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
00222
00224             std::vector<std::vector<bool> > getAllProteinRatioFlags(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
00225
00227             std::vector<std::vector<double> > getAllProteinRatioValues(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
00228
00230             std::vector<std::string> getAllProteinRatioPepSeqs(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
00231
00233             bool isAverageProtocol() const;
00235             void setAverageReferenceProtein(const char *accession, int dbIdx, bool isReferenceUserSelected);
00237             void setAverageNumPeptides(unsigned int num = 3);
00239             void setAverageSelection(const char * value);
00240 #ifndef SWIG
00241
00242             bool getAveragePeptideIntensity(
00243                     const std::string &accession,
00244                     int dbIdx,
00245                     double * averageIntensity, // average of grouped intensities (each peptide ratio group summed and then average of those sums)
00246                     int * sampleSize, // number of different peptide groups available (after grouping by selection type)
00247                     ms_peptide_quant_key_vector * includeKeys, // peptide ratios selected (may be greater then sampleSize)
00248                     ms_peptide_quant_key_vector * excludeKeys // peptide ratios not selected
00249                     ) const;
00250 #else // SWIG Multiple return values
00251             bool getAveragePeptideIntensity(
00252                 const std::string & accession,
00253                 int                 dbIdx,
00254                 double *            OUTPUT,
00255                 int *               OUTPUT,
00256                 ms_peptide_quant_key_vector * includeKeys,
00257                 ms_peptide_quant_key_vector * excludeKeys
00258                 ) const;
00259 #endif
00260
00261             std::vector<int> getQuantitationDatasources() const;
00262
00263             int getNumMatchedPeptideStatuses() const;
00264
00266             void initGroupChargeStates(
00267                     std::set<int> * calc_chargestates,
00268                     int iGroup1,
00269                     int minCharge,
00270                     int maxCharge);
00271
00272             void calc_complete();
00273
00275             bool isDataCached(MS1QUANT_BUGFIX_NUM bugNum) const;
00276
00278             using ms_quantitation::countDistinctPeptides;
00279
00280 #ifndef SWIG
00281
00282             virtual int countDistinctPeptides(const std::vector<ms_peptide_quant_key> & activeKeys) const;
00283 #endif
00284
00285             static matrix_science::ms_ms1quantitation * openQuantitationCdbResults(
00286                 const matrix_science::ms_peptidesummary & summary,
00287                 const matrix_science::ms_quant_method & method,
00288                 const std::string & cdbFilename,
00289                 const std::string & cacheFilename,
00290                 const matrix_science::ms_quant_method * originalMethod = 0);
00291
00293             static matrix_science::ms_ms1quantitation * openQuantitationXmlResults(
00294                 const matrix_science::ms_peptidesummary & summary,
00295                 const matrix_science::ms_quant_method & method,
00296                 const std::string & filename,
00297                 const std::string & xmlSchemaPath="",
00298                 const matrix_science::ms_quant_method * originalMethod = 0);
00299
00301             bool mergeQuantitationResults(const std::vector<std::string> & cdbFilenames,
00302                                           const std::vector<std::string> & cacheFilenames,
00303                                           const MERGE_QUANT_RESULTS_FLAGS flags,
00304                                           const matrix_science::ms_quant_method * originalMethod = 0);
00305
00307             bool mergeQuantitationResults(const std::vector<std::string> & xmlFilenames,
00308                                           const MERGE_QUANT_RESULTS_FLAGS flags,
00309                                           const std::string & xmlSchemaPath="",
00310                                           const matrix_science::ms_quant_method * originalMethod = 0);
00311 #ifndef SWIG
00312
00313             static bool readResultCounters(const std::string & cdbFile,
00314                 int &numMatches, int &numHits, int &numPepGrp, int &numPeptideComponents);
00315 #else // SWIG Multiple return values
00316             static bool readResultCounters(const std::string & cdbFile,
00317                 int &OUTPUT, int &OUTPUT, int &OUTPUT, int &OUTPUT);
00318 #endif
00319
00320         protected:
00321
00322         private:
00323             //Do not copy this object
00324             ms_ms1quantitation(const ms_ms1quantitation & src);
00325             ms_ms1quantitation& operator=(const ms_ms1quantitation & right);
00326
00327             void initialiseAfterLoad();
00328             // normalisation
00329             std::list<ms_ms1quant_match> selectMatchesForNormalisation(const ms_quant_normalisation *norm);
00330             double calculatePeptideNormalisationBase(const std::string &ratioName) const;
00332             void normalisePeptideRatios();
00333             // end normalisation
00334
00335             bool saveHitToCdb(matrix_science::ms_tinycdb & cdbFile, const matrix_science::ms_protein * protein, int streamNumber) const;
00336             bool saveHitToStream(matrix_science::ms_cache_stream & stream, const matrix_science::ms_protein * protein) const;
00337             bool saveHitToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_protein * protein, int hitId, int memberNumber);
00338
00339             void getProteinRatioOverrideKeys(
00340                     ms_peptide_quant_key_vector * incFK,
00341                     ms_peptide_quant_key_vector * excFK,
00342                     const std::string & ratioName,
00343                     int hitId,
00344                     int memberNumber) const;
00345
00346             ms_protein_quant_ratio getProteinAverageIntensityRatio(
00347                     const std::string &accession,
00348                     int dbIdx
00349                     ) const;
00350
00351             void rematchInferredMatches(const bool allowMassTimeMatches);  // populates inferredMatchSource_
00352             void updatePeptideStatus(matrix_science::ms_ms1quant_peptide_status status, const matrix_science::ms_quant_quality * quality);
00353             void updateMatches(const matrix_science::ms_quant_method * method);           // removes any ms1 quant matches which don't have any valid ms2 peptide matches
00354             void updateMatchPeptideEvidence();  // updates the ms2 matches associated (or not associated) with an ms1 quant match
00355             bool updateProteinMatches();        // ensures only valid anchor proteins are returned
00356
00357             // Can the new settings be handled my ms_ms1quantitation, or do additional values need to be calculated by MsQuantLib
00358             static bool canHandleSettings(const matrix_science::ms_quant_method * originalMethod, const matrix_science::ms_quant_method * newMethod, matrix_science::ms_ms1quantitation * quantResults);
00359
00360             std::map<matrix_science::ms_peptide_quant_key, ms_ms1quant_peptide_status_body> getMatchedPeptideStatuses() const;
00361
00363             std::vector<ms_ms1quant_match> getMatchesForHit(int hitId, int memberNumber) const;
00364
00366             bool saveGroupToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_protein * protein, int hitId, int memberNumber) const;
00367             void reorderMatchesAfterMerge();
00368
00370             bool mergeCdbFiles(const std::vector<std::string> & cdbFilenames,
00371                 const std::vector<std::string> & cacheFilenames,
00372                 const std::vector<std::string> & resultFilenames,
00373                 const matrix_science::ms_mascotresults_params & parameters,
00374                 const std::string & cacheDirectory,
00375                 const MERGE_QUANT_RESULTS_FLAGS flags);
00376
00378             bool mergeXmlFiles(
00379                 const std::vector<std::string> & xmlFilenames,
00380                 const std::vector<std::string> & resultFilenames,
00381                 const std::string & cacheDirectory,
00382                 const std::string & xmlSchemaPath,
00383                 const MERGE_QUANT_RESULTS_FLAGS flags);
00384
00386             void getKeyStrings(const int dataSourceId, const std::string & peptideStr, const std::string & labelFreeVarMods, const int chargeState,
00387                                std::string & groupKey, std::string & uniqueKey) const;
00388
00389             const ms_peptidesummary & peptideSummary_;
00390             int nextMatchId_;
00391             std::map<ms_peptide_quant_key, ms_ms1quant_match> matches_; // matchId -> match
00392             std::map<std::pair<int, int>, ms_ms1quant_peptide_status> peptideStatuses_; // [query, rank] -> status
00393             std::map<std::string, ms_peptide_quant_key> matchKeys_; // peptideStr:datasourceId:labelFree:charge -> matchId
00394             std::map<std::string, std::set<ms_peptide_quant_key> > matchGroups_; // "datasource:peptideStr:labelFree" -> matchId[]
00395             std::vector<std::string> matchGroupNames_; // names in matchGroups in order of addition (to match with processing order in Distiller)
00396
00397
00398             // matchId -> matchId of the 'source/sibling' identified match - always the most intense sibling if there is more than one possibility
00399             std::map<ms_peptide_quant_key, ms_peptide_quant_key> inferredMatchSource_;
00400
00401             typedef std::pair<int, int> Hitkey; // hitId, memberNumber (0 if not a family)
00402             std::vector<Hitkey> hitkeys_;
00403
00404             bool hasAverageResults_;
00405             ms_ms1quant_average_results averageResults_;
00406
00407             matrix_science::ms_cache_file cacheFile_;
00408
00409             mutable const ms_msquant1_mod_format * modFormat_;
00410
00411             std::vector<matrix_science::ms_cache_file *> multifileCacheFiles_;
00412
00413             std::string bugsfixed_;
00414     };
00415  // end of quantitation_group
00417     //=========================================================================
00418
00419 }   // matrix_science namespace
00420
00421
00422 #endif // MS_MS1QUANTITATION_HPP
00423
00424 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms2quantitation.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms2quantitation.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Quantitation for Reporter and Multiplex protocols                          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2019-07-05 17:44:32 +0100 $ #
00013 #   $Revision: b176d02152f5e28fa0a8289d5f341dd8900b4e4b | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_MS2QUANTITATION_HPP
00019 #define MS_MS2QUANTITATION_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024 #include <vector>
00025 #include <list>
00026 #include <utility>
00027
00028 namespace msparser_internal {
00029     class ms_ms2ratiocalculator;
00030     class ms_XMLElement;
00031     class ms_XMLHelper;
00032 }
00033
00034 namespace matrix_science {
00035     class ms_quant_ratio;
00036     class ms_quantitation;
00037     class ms_peptidesummary;
00038     class ms_peptide_quant_key;
00039     class ms_peptide_quant_key_vector;
00040     class ms_quant_helper;
00041     class ms_protein;
00042
00048
00049
00125     class MS_MASCOTRESFILE_API ms_ms2quantitation: public ms_quantitation
00126     {
00127         friend class ms_customquantitation;
00128         public:
00130             explicit ms_ms2quantitation(const ms_peptidesummary& pepsum);
00131
00133             ms_ms2quantitation(const ms_peptidesummary& pepsum, const ms_quant_method &qm);
00134
00136             virtual ~ms_ms2quantitation();
00137
00138             virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
00139             virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const;
00140
00141             virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName);
00142             virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName);
00143             virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const;
00144
00145             virtual void setProteinRatioType(const char *value);
00146
00147             virtual void setQuantOutliers(const ms_quant_outliers *);
00148
00149             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const;
00150
00151             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const;
00152
00154             bool getAllProteinRatios(const std::string & accession, const int dbIdx,
00155                                      const std::string & ratioName,
00156                                      std::vector<double> & ratios,
00157                                      std::vector<std::vector<bool> > & flags,
00158                                      ms_peptide_quant_key_vector & keys) const;
00159
00161             std::vector<double> getAllProteinRatios(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
00162
00164             std::vector<std::vector<bool> > getAllProteinRatioFlags(const std::string & accession, const int dbIdx, const std::string & ratioName) const;
00165
00167             void setQuantNormalisation(const ms_quant_normalisation *norm);
00168
00170             bool hasPeptideRatioNormalisation() const;
00171
00173             void normalisePeptideRatios();
00174
00176             std::vector<double> getComponentIntensities(const ms_peptide_quant_key &key, bool raw = false) const;
00177
00179             void includeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys);
00180
00182             void excludeProteinPeptideRatioKeys(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &excludeKeys);
00183
00185             std::vector<std::string> getReportRatioNamesInFile(unsigned int fileNum) const;
00186
00188             const ms_quant_ratio* getReportRatioFromFile(unsigned int fileNum, const std::string &ratioName) const;
00189
00191             void setReportRatioInFile(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef);
00192
00194             void removeReportRatioInFile(unsigned int fileNum, const std::string &ratioName);
00195
00196
00198             std::vector<std::string> getCombinedReportRatioNames() const;
00199
00201             const ms_quant_ratio* getCombinedReportRatio(const std::string &ratioName) const;
00202
00204             void removeCombinedReportRatio(const std::string &ratioName);
00205
00207             void setCombinedReportRatio(const std::string &ratioName, const ms_quant_ratio &ratioDef);
00208
00210             double getIntensityNormalisationBase(const std::string &componentName) const;
00211
00213             void setIntensityNormalisationBase(const std::string &componentName, double b);
00214
00216             void removeIntensityNormalisationBase(const std::string &componentName);
00217
00219             void removeIntensityNormalisationBases();
00220
00222             bool hasIntensityNormalisation() const;
00223
00225             void normaliseIntensities();
00226
00228             bool loadCdbFile(const char* path);
00229
00231             bool loadCdbFiles(const std::vector<std::string> & cdbFiles);
00232
00234             bool saveXmlFile(const std::string & xmlFilename, bool completeReport);
00235
00237             bool saveCdbFile(const std::string & cdbFilename);
00238
00240             using ms_quantitation::countDistinctPeptides;
00241
00242 #ifndef SWIG
00243
00244             virtual int countDistinctPeptides(const std::vector<ms_peptide_quant_key> & activeKeys) const;
00245 #endif
00246         protected:
00247             virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set<ms_peptide_quant_key> &keys, const std::set<ms_peptide_quant_key> &includeKeys, const std::set<ms_peptide_quant_key> &excludeKEys, std::vector<double> &values, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys) const;
00248
00249
00250         private:
00251             // No copying.
00252             ms_ms2quantitation(const ms_ms2quantitation &copyFrom);
00253             ms_ms2quantitation& operator=(const ms_ms2quantitation &right);
00254
00255             enum SUPPORTED_PROTEIN_RATIO_TYPE {
00256                 PROTEIN_RATIO_TYPE_MEDIAN = 0,
00257                 PROTEIN_RATIO_TYPE_AVERAGE,
00258                 PROTEIN_RATIO_TYPE_WEIGHTED
00259             };
00260
00261             int proteinRatioType_;
00262
00263             const ms_peptidesummary &pepsum_;
00264             const unsigned int numResfiles_;
00265
00266             std::vector<std::string> componentNames_;
00267             std::vector<double>::size_type numComponents_;
00268
00269             std::vector<double> componentIntensityNormalisationBase_;
00270             bool normaliseComponentIntensities_;
00271
00272             bool renormaliseOnDemand_;
00273
00274             std::map<ms_peptide_quant_key, bool> peptideQuantKeyQualityTest_;
00275             bool testPeptideQuantKeyUniqueness_;
00276             bool testedAllKeysForNormalisation_;
00277             ms_quant_helper *quantHelper_;
00278
00279             typedef std::map< std::string, std::set<ms_peptide_quant_key> > ratio_name_to_peptide_quant_key_exclusion_t;
00280             std::vector< ratio_name_to_peptide_quant_key_exclusion_t > isPeptideQuantKeyExcluded_;
00281
00282             bool useCanonicalQPvalues_;
00283
00284             typedef std::pair<int, int> qp_t;
00285             qp_t keyToCanonicalQP(const ms_peptide_quant_key &key) const;
00286             int rankToCanonicalRank(int p) const;
00287
00288             std::vector<double> loadIntensities(const ms_peptide_quant_key &key) const;
00289             std::vector<double> loadIntensities(int q, int p) const;
00290
00291             static const unsigned int FILENUM_LOWER_BOUND;
00292             static const unsigned int FILENUM_UPPER_BOUND;
00293
00294             typedef std::pair<std::string, unsigned int> ratio_name_and_file_index_t;
00295             typedef std::set<ratio_name_and_file_index_t> ratio_name_in_files_t;
00296             ratio_name_in_files_t ratioNamesInFiles_;
00297
00298             typedef std::list<ms_quant_ratio> quant_ratio_list_t;
00299             std::vector<quant_ratio_list_t> fileToQuantRatioList_;
00300
00301             std::vector<msparser_internal::ms_ms2ratiocalculator> ratioCalculators_;
00302
00303             typedef std::map<std::string, std::set<ms_peptide_quant_key> > sequence_to_peptide_quant_key_t;
00304             sequence_to_peptide_quant_key_t sequencePeptideQuantKeys_;
00305             std::map<ms_peptide_quant_key, std::string> peptideQuantKeySequence_;
00306
00307             typedef std::pair<protein_key_t, std::string> protein_ratio_key_t;
00308             typedef std::map<protein_ratio_key_t, ms_peptide_quant_key_vector> user_prot_to_pept_quantkey_override_t;
00309             // used to record protein match-peptide keys which have been user excluded
00310             user_prot_to_pept_quantkey_override_t userExcludedKeys_;
00311             // used to record protein match-peptide keys which have been user included
00312             user_prot_to_pept_quantkey_override_t userIncludedKeys_;
00313
00314             void fixRatioSourceRemovalInQM(const std::string &ratioName);
00315             void setRatioContentInQM(const std::string &ratioName, unsigned int fileNum);
00316
00317             bool calculateUnnormalisedPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName, int *fileNum, bool *isInfinite, double *value) const;
00318
00319             void setQuantNormalisationOnly(const ms_quant_normalisation *norm);
00320
00321             double calculatePeptideNormalisationBase(const std::string &ratioName) const;
00322             std::map<std::string, double> calculatePeptideNormalisationBases() const;
00323             std::list<ms_peptide_quant_key> selectKeysForNormalisation(const ms_quant_normalisation *norm);
00324             void selectAllKeysForNormalisation(std::map<int, std::pair<int, ms_peptide_quant_key> > &query_keys);
00325             std::vector<double> normalisedComponentIntensities(const std::vector<double> &intensities) const;
00326
00327             bool initialiseReportRatios();
00328
00329             bool initialiseQuantHelper();
00330
00331             void setReportRatioInFileOnly(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef);
00332             void setReportRatioInFileOnly(unsigned int fileNum, const std::string &ratioName, const ms_quant_ratio &ratioDef, std::string &oldName, std::string &newName);
00333
00334             bool removeReportRatioInFileOnly(unsigned int fileNum, const std::string &ratioName);
00335
00336             std::map<ms_peptide_quant_key, bool>::const_iterator testPeptideQuantKeyQuality(int q, int p, const ms_peptide_quant_key &key);
00337             void initialiseProteinPeptideMapping(const std::string &accession, int dbIdx);
00338
00339             bool savePeptideGroupingToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const matrix_science::ms_protein * protein, int hitId, int memberNumber) const;
00340
00341             bool savePeptideMatchXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root, const ms_peptide_quant_key & key, long matchid) const;
00342
00343             bool saveEmptyMatrixXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & parent, const std::string matrixName) const;
00344
00345             bool savePeptideRatioToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const ms_peptide_quant_ratio ratio, const ms_protein * protein = NULL) const;
00346
00347             bool saveProteinHitRatiosToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, const ms_protein * protein, int q, int p) const;
00348
00350             bool isPeptideRatioUserExcluded(const ms_protein * protein, const std::string & ratioName, const ms_peptide_quant_key & key) const;
00351
00353             bool isPeptideRatioUserIncluded(const ms_protein * protein, const std::string & ratioName, const ms_peptide_quant_key & key) const;
00354
00356             static void saveResfileDetailsToCdb(ms_tinycdb & cdbFile, const ms_mascotresfile & resfile);
00357
00359             static bool readCdbCounterData(ms_tinycdb & cdbFile, unsigned & count);
00360
00361             static bool readUserRatioStream(ms_tinycdb & cdbFile, const unsigned & index, std::string & accession, int & db, std::string & ratio, ms_peptide_quant_key_vector & included, ms_peptide_quant_key_vector & excluded);
00362     }; // end of quantitation_group
00364 }   // matrix_science namespace
00365
00366 #endif // MS_MS2QUANTITATION_HPP
00367
00368 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_ms2ratiocalculator.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_ms2ratiocalculator.hpp                                            #
00004 # 'msparser' toolkit                                                         #
00005 # Ratio calculation helper class for ms_ms2ratiocalculator                      #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author$ #
00012 #       $Date$ #
00013 #   $Revision$ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_MS2RATIOCALCULATOR_HPP
00019 #define MS_MS2RATIOCALCULATOR_HPP
00020
00021 #include <map>
00022 #include <string>
00023 #include <vector>
00024 #include <utility>
00025
00026 namespace matrix_science {
00027     class ms_quant_ratio;
00028     class ms_quant_numerator;
00029 }
00030
00031 namespace msparser_internal {
00032     using namespace matrix_science;
00033
00034     class MS_MASCOTRESFILE_API ms_ms2ratiocalculator
00035     {
00036         public:
00037             ms_ms2ratiocalculator(const std::vector<std::string> &componentNames);
00038
00039             ms_ms2ratiocalculator(const ms_ms2ratiocalculator &copyFrom);
00040 #ifndef SWIG
00041             ms_ms2ratiocalculator& operator=(const ms_ms2ratiocalculator &right);
00042 #endif
00043             void copyFrom(const ms_ms2ratiocalculator *src);
00044
00045             virtual ~ms_ms2ratiocalculator();
00046
00047             void removeRatio(const std::string &ratioName);
00048             void setRatio(const std::string &ratioName, const ms_quant_ratio &ratioDef);
00049
00050             bool calculateRatio(const std::string &ratioName, const std::vector<double> &intensities, bool *isInfinite, double *value) const;
00051
00052         private:
00053             std::vector<std::string>::size_type numComponents_;
00054             std::vector<std::string> componentNames_;
00055
00056             typedef std::vector<double> coefficients_t;
00057             typedef std::pair<coefficients_t, coefficients_t> ratio_coefficients_t;
00058             std::map<std::string, ratio_coefficients_t> ratioCoefficients_;
00059
00060             long componentNameToIndex(const std::string &name) const;
00061             double parseCoefficient(const ms_quant_numerator *numer) const;
00062     };
00063 }   // matrix_science namespace
00064
00065 #endif // MS_MS2RATIOCALCULATOR_HPP
00066
00067 /*------------------------------- End of File -------------------------------*/
00068
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_obofile.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_obofile.hpp                                                       #
00004 # Mascot Parser toolkit                                                      #
00005 # Utility functions for accessing ontology files in the .obo format          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2008 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_obofile.hpp $
00012 #    $Author: villek@matrixscience.com $
00013 #      $Date: 2018-07-30 16:23:53 +0100 $
00014 #  $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_OBOFILE_HPP
00020 #define MS_OBOFILE_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025 #include <map>
00026
00027 namespace matrix_science {
00033
00034
00042     class MS_MASCOTRESFILE_API ms_obofile: public ms_errors
00043     {
00044     public:
00046         ms_obofile();
00047
00049         ms_obofile(const char * oboFileName);
00050
00052         ms_obofile(const ms_obofile& right);
00053
00055         ~ms_obofile();
00056
00057 #ifndef SWIG
00058
00059         ms_obofile& operator=(const ms_obofile& right);
00060 #endif
00061
00062         void copyFrom(const ms_obofile* right);
00063
00065         void defaultValues();
00066
00068         std::vector<std::string> getItemFromId(const char * id) const;
00069
00071         std::string findIDFromTagValue(const char * tag, const char * value) const;
00072
00074         void parseLine(const std::string str, std::string & tag, std::string & value, std::string & comment) const;
00075
00077         int getNumberOfEntries() const;
00078
00079
00080     private:
00081         void clearOntology();
00082         typedef std::vector<std::string> ontologyItem_t;
00083         typedef std::map<std::string, ontologyItem_t> ontology_t;
00084         ontology_t ontology_;
00085
00086     }; // class ms_obofile // end of config_group
00088 } // namespace matrix_science
00089
00090 #endif // MS_OBOFILE_HPP
00091
00092 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_parserule.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_parserule.hpp                                                     #
00004 # 'msparser' toolkit                                                         #
00005 # Represents PARSE section of mascot.dat file                                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_parserule.hpp           $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_PARSERULE_HPP
00020 #define MS_PARSERULE_HPP
00021
00022
00023 #include <string>
00024
00025
00026 namespace matrix_science {
00032
00033
00037     class MS_MASCOTRESFILE_API ms_parserule
00038     {
00039         friend class ms_datfile;
00040         friend class ms_parseoptions;
00041         friend class ms_spectral_lib_file;
00042
00043     public:
00045         ms_parserule();
00046
00048         ms_parserule(const ms_parserule& src);
00049
00051         ~ms_parserule();
00052
00054         void defaultValues();
00055
00057         void copyFrom(const ms_parserule* right);
00058
00059 #ifndef SWIG
00060
00061         ms_parserule& operator=(const ms_parserule& right);
00062 #endif
00063
00064         bool isAvailable() const;
00065
00067         void setAvailable(const bool value);
00068
00070         std::string getRuleStr() const;
00071
00073         void setRuleStr(const char* str);
00074
00075     private:
00076         bool    available_;
00077         std::string szRule_;
00078
00079         void *compiledExp_;
00080         void compileAccessionRegex(ms_errs* pErr);
00081         std::string regexStr(const char * input, ms_errs * pErr, bool reportErrorIfNoMatch) const;
00082
00083     };// class ms_parserule
00084
00086
00101     class MS_MASCOTRESFILE_API ms_parseoptions : public ms_customproperty
00102     {
00103         friend class ms_datfile;
00104     public:
00106         ms_parseoptions();
00107
00109         ms_parseoptions(const ms_parseoptions& src);
00110
00112         ~ms_parseoptions();
00113
00115         void defaultValues();
00116
00118         void copyFrom(const ms_parseoptions* right);
00119
00120 #ifndef SWIG
00121
00122         ms_parseoptions& operator=(const ms_parseoptions& right);
00123 #endif
00124
00125         bool isSectionAvailable() const;
00126
00128         void setSectionAvailable(const bool value);
00129
00131         int getNumberOfParseRules() const;
00132
00134         void clearParseRules();
00135
00137         const ms_parserule* getParseRule(const int index) const;
00138
00140         void setParseRule(const int index, const ms_parserule* rule);
00141
00143         void dropParseRule(const int index);
00144
00145         int findOrAddParseRule(const char * rule, bool & added);
00146
00147 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00148 #include "suppress_ms_customproperty.hpp"
00149 #endif
00150
00151     private:
00152         bool                sectionAvailable_;
00153         ms_parserule        *parseRules_;
00154     }; // end of config_group
00156 } // namespace matrix_science
00157
00158 #endif // MS_PARSERULE_HPP
00159
00160 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_peptide_impl.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_mascotrespeptide.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a peptide from the summary section or peptides section of the #
00006 # mascot results file                                                        #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2002 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotrespe $ #
00013 #     $Author$ #
00014 #       $Date$ #
00015 #   $Revision$ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_PEPTIDE_IMPL_HPP
00021 #define MS_PEPTIDE_IMPL_HPP
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <vector>
00026
00027 namespace matrix_science {
00028     class ms_peptide;
00029     class ms_protein;
00030     class ms_mascotresults;
00031 }
00032
00033 namespace msparser_internal {
00034
00035 // Flags are stored in unsigned char, so maximum flag is 0x80.
00036 #define FL_IS_FROM_ERROR_TOLERANT 0x01
00037 #define FL_LESS_THAN_MIN_PEP_LEN  0x02
00038 #define FL_STORE_RELOADABLE_INFO  0x04
00039 #define FL_PROTEIN_HITS_IS_VECTOR 0x08
00040 #define FL_ANY_MATCH              0x10
00041 #define FL_IS_FROM_LIBRARY        0x20
00042
00043     class ms_peptide_impl_reloadable
00044     {
00045         public:
00046             ms_peptide_impl_reloadable();
00047             ms_peptide_impl_reloadable(const double         delta,
00048                                        const double         observed,
00049                                        const int            charge,
00050                                        const int            numIonsMatched,
00051                                        const int            peaksUsedFromIons1,
00052                                        const std::string &  seriesUsedStr,
00053                                        const int         &  peaksUsedFromIons2,
00054                                        const int            peaksUsedFromIons3);
00055             ms_peptide_impl_reloadable(const ms_peptide_impl_reloadable& src);
00056             virtual ~ms_peptide_impl_reloadable();
00057 #ifndef SWIG
00058             ms_peptide_impl_reloadable& operator=(const ms_peptide_impl_reloadable& right);
00059 #endif
00060             void        copyFrom(const ms_peptide_impl_reloadable * src);
00061
00062             // Careful with initialiseDerivedFrom(): make sure you
00063             // have checked with typeid() or dynamic_cast() that *src
00064             // has the same dynamic type as *this.
00065             virtual void initialiseDerivedFrom(const ms_peptide_impl_reloadable *src) { copyFrom(src); }
00066
00067             // clone() always returns a base class pointer, but may
00068             // allocate a derived class object.
00069             virtual ms_peptide_impl_reloadable* clone() const = 0;
00070
00071             bool        getAnyMatch()               const { return PSM_data(matrix_science::ms_peptide::PSM_COMPLETE).getMissedCleavages() != -1;}
00072             int         getMissedCleavages(const matrix_science::ms_peptide::PSM entity)        const { return PSM_data(entity).getMissedCleavages(); }
00073             double      getMrCalc(const matrix_science::ms_peptide::PSM entity)                 const { return PSM_data(entity).getMrCalc();          }
00074             double      getDelta()                  const { return delta_;                }
00075             double      getObserved()               const { return observed_;             }
00076             double      getMrExperimental()         const { return PSM_data(matrix_science::ms_peptide::PSM_COMPLETE).getMrCalc() + getDelta();       }
00077             int         getCharge()                 const { return charge_;               }
00078             int         getNumIonsMatched()         const { return numIonsMatched_;       }
00079             std::string getPeptideStr(const bool substituteAmbiguous, const matrix_science::ms_peptide::PSM entity) const {
00080                 return PSM_data(entity).getPeptideStr(substituteAmbiguous);
00081             }
00082             int         getPeptideLength(const matrix_science::ms_peptide::PSM entity)          const { return static_cast<int>(PSM_data(entity).getPeptideLength()); }
00083             int         getPeaksUsedFromIons1()     const { return peaksUsedFromIons1_;   }
00084             int         getPeaksUsedFromIons2()     const { return peaksUsedFromIons2_;   }
00085             int         getPeaksUsedFromIons3()     const { return peaksUsedFromIons3_;   }
00086             std::string getVarModsStr(const matrix_science::ms_peptide::PSM entity)             const { return PSM_data(entity).getVarModsStr();      }
00087             void setVarModsStr(const std::string &str, const matrix_science::ms_peptide::PSM entity)  { PSM_data(entity).setVarModsStr(str);          }
00088             std::string getSummedModsStr(const matrix_science::ms_peptide::PSM entity)          const { return PSM_data(entity).getSummedModsStr();   }
00089             void setSummedModsStr(const std::string &str, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setSummedModsStr(str);     }
00090             std::string getLocalModsStr(const matrix_science::ms_peptide::PSM entity)           const   { return PSM_data(entity).getLocalModsStr();  }
00091             void setLocalModsStr(const std::string & strRaw, const std::string & strParsed, const matrix_science::ms_peptide::PSM entity) {
00092                 PSM_data(entity).setLocalModsStr(strRaw, strParsed);
00093             }
00094             std::string getMonoLinkStr(const matrix_science::ms_peptide::PSM entity)           const    { return PSM_data(entity).getMonoLinkStr();    }
00095             void        setMonoLinkStr(const std::string & value, const matrix_science::ms_peptide::PSM entity)  { PSM_data(entity).setMonoLinkStr(value);   }
00096             std::string getParsedLocalModsStr(const matrix_science::ms_peptide::PSM entity)     const   { return PSM_data(entity).getParsedLocalModsStr(); }
00097             std::string getSeriesUsedStr()          const { return seriesUsedStr_;        }
00098             double      getIonsIntensity()          const { return ionsIntensity_;        }
00099             void        setIonsIntensity(double n)        { ionsIntensity_       = n;     }
00100             std::string getAmbiguityString(const matrix_science::ms_peptide::PSM entity)        const   { return PSM_data(entity).getAmbiguityString(); }
00101             bool        setAmbiguityString(const std::string & val, const matrix_science::ms_peptide::PSM entity) { return PSM_data(entity).setAmbiguityString(val); }
00102             std::string getPrimaryNlStr(const matrix_science::ms_peptide::PSM entity)           const   { return PSM_data(entity).getPrimaryNlStr();    }
00103             void        setPrimaryNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setPrimaryNlStr(value);   }
00104             std::string getSummedModsNlStr(const matrix_science::ms_peptide::PSM entity)        const   { return PSM_data(entity).getSummedModsNlStr(); }
00105             void        setSummedModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setSummedModsNlStr(value); }
00106             std::string getLocalModsNlStr(const matrix_science::ms_peptide::PSM entity)        const    { return PSM_data(entity).getLocalModsNlStr();  }
00107             void        setLocalModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setLocalModsNlStr(value);   }
00108             std::string getComponentStr(const matrix_science::ms_peptide::PSM entity)           const   { return PSM_data(entity).getComponentStr();    }
00109             void        setComponentStr(const std::string & value, const matrix_science::ms_peptide::PSM entity)   { PSM_data(entity).setComponentStr(value);     }
00110             int         getNum13C(const double tol, const std::string tolu, const std::string & mass_type) const;
00111
00112             void        getLoopLinks(matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) const { return PSM_data(entity).getLoopLinks(vec); }
00113             void        setLoopLinks(const matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) { PSM_data(entity).setLoopLinks(vec); }
00114
00115             virtual bool isSamePeptideStr(const ms_peptide_impl_reloadable *pReloadable_, const bool substituteAmbiguous) const = 0;
00116             virtual bool isSameVarModsStr(const ms_peptide_impl_reloadable *pReloadable_) const = 0;
00117             virtual bool isSameSummedModsStr(const ms_peptide_impl_reloadable *pReloadable_) const = 0;
00118
00119             virtual int getNumberOfLinkedPeptides() const = 0;
00120
00121             virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const = 0;
00122
00123             /* Bug 13047: The peptide object can contain data either
00124              * for a linear peptide, or for a crosslinked alpha-beta
00125              * pair. The fields of linearPeptideData_t were previously
00126              * members of ms_peptide_impl_reloadable.
00127              */
00128             class linearPeptideData_t {
00129             public:
00130                 linearPeptideData_t();
00131
00132                 linearPeptideData_t(const int missedCleavages,
00133                                     const double mrCalc,
00134                                     const std::string &peptideStr,
00135                                     const std::string &varModsStr,
00136                                     const std::string &summedModsStr,
00137                                     const std::string &localModsStr,
00138                                     const std::string &parsedLocalModsStr,
00139                                     const std::string &monoLinkStr,
00140                                     const matrix_science::ms_linker_site_vector &loopLinks,
00141                                     const std::string &primaryNlStr,
00142                                     const std::string &summedModsNlStr,
00143                                     const std::string &localModsNlStr,
00144                                     const std::string &substStr,
00145                                     const std::string &componentStr);
00146
00147                 linearPeptideData_t(const ms_peptide_impl_reloadable *parent);
00148
00149                 linearPeptideData_t(const linearPeptideData_t &src);
00150
00151                 linearPeptideData_t& operator=(const linearPeptideData_t& right);
00152                 void copyFrom(const linearPeptideData_t *src);
00153
00154                 ~linearPeptideData_t();
00155
00156                 // Create a concatenated object (alpha + beta).
00157                 static linearPeptideData_t concat(const linearPeptideData_t &alpha,
00158                                                   const linearPeptideData_t &right,
00159                                                   const int query,
00160                                                   const double linkerMass,
00161                                                   const matrix_science::ms_mascotresults *pResults);
00162
00163                 int         getMissedCleavages() const { return missedCleavages_; }
00164                 double      getMrCalc()          const { return mrCalc_; }
00165
00166                 std::string getPeptideStr(const bool substituteAmbiguous) const;
00167                 int         getPeptideLength() const { return static_cast<int>(peptideStr_.size()); }
00168                 std::string getVarModsStr()    const { return varModsStr_; }
00169                 std::string getSummedModsStr() const { return summedModsStr_; }
00170                 void        setVarModsStr(const std::string& str)    { varModsStr_ = str; }
00171                 void        setSummedModsStr(const std::string& str) { summedModsStr_ = str; }
00172
00173                 std::string getLocalModsStr()           const;
00174                 void setLocalModsStr(const std::string & strRaw, const std::string & strParsed);
00175                 std::string getParsedLocalModsStr()     const;
00176
00177                 std::string getMonoLinkStr()            const { return monoLinkStr_; }
00178                 void        setMonoLinkStr(const std::string & value) { monoLinkStr_ = value; }
00179
00180                 std::string getAmbiguityString()        const;
00181                 bool        setAmbiguityString(const std::string & val);
00182                 std::string getPrimaryNlStr()           const;
00183                 void        setPrimaryNlStr(const std::string & value);
00184                 std::string getSummedModsNlStr()        const;
00185                 void        setSummedModsNlStr(const std::string & value);
00186                 std::string getLocalModsNlStr()        const;
00187                 void        setLocalModsNlStr(const std::string & value);
00188                 std::string getComponentStr()           const;
00189                 void        setComponentStr(const std::string & value);
00190
00191                 void        getLoopLinks(matrix_science::ms_linker_site_vector& vec) const;
00192                 void        setLoopLinks(const matrix_science::ms_linker_site_vector &vec);
00193
00194                 bool        isSamePeptideStr(const linearPeptideData_t *right, const bool substituteAmbiguous) const;
00195                 bool        isSameVarModsStr(const linearPeptideData_t *right) const;
00196                 bool        isSameSummedModsStr(const linearPeptideData_t *right) const;
00197
00198                 void        serialise(std::ostringstream &value) const;
00199                 void        setFromStream(std::istringstream &iss, const int alphaLen, const int betaLen);
00200
00201             private:
00202                 std::string getUnambiguousStr(const std::string val) const;
00203
00204                 int         missedCleavages_;
00205                 double      mrCalc_;
00206                 std::string peptideStr_;
00207                 std::string varModsStr_;
00208                 std::string summedModsStr_;
00209                 std::string monoLinkStr_;
00210
00211                 matrix_science::ms_linker_site_vector * loopLinks_;
00212
00213                 char      * primaryNlStr_;
00214                 char      * summedModsNlStr_;
00215                 char      * localModsNlStr_;
00216                 char      * ambiguousStr_;    // The subst string
00217                 char      * unambiguousStr_;  // The string with all ambiguous residues substituted
00218                 char      * componentStr_;
00219
00220                 struct localMods_t
00221                 {
00222                     std::string localModsStr_;
00223                     std::string parsedLocalModsStr_;
00224                 };
00225
00226                 localMods_t * localMods_;
00227             };
00228
00229         private:
00230             // Derived classes must implement data access to each entity.
00231             virtual const linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) const = 0;
00232             virtual linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) = 0;
00233
00234             // Peptide-spectrum match data
00235             double      delta_;
00236             double      observed_;
00237             int         charge_;
00238             int         numIonsMatched_;
00239             int         peaksUsedFromIons1_;
00240             std::string seriesUsedStr_;
00241             int         peaksUsedFromIons2_;
00242             int         peaksUsedFromIons3_;
00243             double      ionsIntensity_;
00244     };
00245
00246     /* Bug 13047: The ms_peptide_impl_reloadable class used to contain
00247     * the same data as the new ms_peptide_impl_reloadable_linear
00248     * class.
00249     */
00250     class ms_peptide_impl_reloadable_linear: public ms_peptide_impl_reloadable {
00251         public:
00252             ms_peptide_impl_reloadable_linear();
00253
00254             ms_peptide_impl_reloadable_linear(const double         delta,
00255                                               const double         observed,
00256                                               const int            charge,
00257                                               const int            numIonsMatched,
00258                                               const int            peaksUsedFromIons1,
00259                                               const std::string &  seriesUsedStr,
00260                                               const int         &  peaksUsedFromIons2,
00261                                               const int            peaksUsedFromIons3,
00262                                               const ms_peptide_impl_reloadable::linearPeptideData_t &peptideData);
00263
00264             ms_peptide_impl_reloadable_linear(const ms_peptide_impl_reloadable_linear &src);
00265
00266             virtual ~ms_peptide_impl_reloadable_linear() { }
00267 #ifndef SWIG
00268             ms_peptide_impl_reloadable_linear& operator=(const ms_peptide_impl_reloadable_linear& right);
00269 #endif
00270             void copyFrom(const ms_peptide_impl_reloadable_linear * src);
00271
00272             // Careful with initialiseDerivedFrom(): make sure you
00273             // have checked with typeid() or dynamic_cast() that *src
00274             // has the same dynamic type as *this.
00275             virtual void initialiseDerivedFrom(const ms_peptide_impl_reloadable *src) { copyFrom(dynamic_cast<const ms_peptide_impl_reloadable_linear*>(src)); }
00276
00277             // clone() always returns a base class pointer, but may
00278             // allocate a derived class object.
00279             virtual ms_peptide_impl_reloadable* clone() const { return new ms_peptide_impl_reloadable_linear(*this); }
00280
00281             virtual bool isSamePeptideStr(const ms_peptide_impl_reloadable *pReloadable_, const bool substituteAmbiguous) const;
00282             virtual bool isSameVarModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
00283             virtual bool isSameSummedModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
00284
00285             virtual int getNumberOfLinkedPeptides() const { return 0; }
00286             virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const {
00287                 vec.setVarModsStrLengths(
00288                     getPeptideLength(matrix_science::ms_peptide::PSM_COMPLETE) + 2,
00289                     0
00290                 );
00291             }
00292
00293         private:
00294             virtual const linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM) const { return peptideData_; }
00295             virtual linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM) { return peptideData_; }
00296
00297             linearPeptideData_t peptideData_;
00298     };
00299
00300     class ms_peptide_impl_reloadable_crosslinked: public ms_peptide_impl_reloadable {
00301         public:
00302             ms_peptide_impl_reloadable_crosslinked();
00303
00304             ms_peptide_impl_reloadable_crosslinked(const double         delta,
00305                                                    const double         observed,
00306                                                    const int            charge,
00307                                                    const int            numIonsMatched,
00308                                                    const int            peaksUsedFromIons1,
00309                                                    const std::string &  seriesUsedStr,
00310                                                    const int         &  peaksUsedFromIons2,
00311                                                    const int            peaksUsedFromIons3,
00312                                                    const ms_peptide_impl_reloadable::linearPeptideData_t & concatPeptideData,
00313                                                    const ms_peptide_impl_reloadable::linearPeptideData_t & alphaPeptideData,
00314                                                    const ms_peptide_impl_reloadable::linearPeptideData_t & betaPeptideData,
00315                                                    const matrix_science::ms_linker_site &linkerSite);
00316
00317             ms_peptide_impl_reloadable_crosslinked(const ms_peptide_impl_reloadable_crosslinked &src);
00318
00319             virtual ~ms_peptide_impl_reloadable_crosslinked() { }
00320 #ifndef SWIG
00321             ms_peptide_impl_reloadable_crosslinked& operator=(const ms_peptide_impl_reloadable_crosslinked& right);
00322 #endif
00323             void copyFrom(const ms_peptide_impl_reloadable_crosslinked * src);
00324
00325             // Careful with initialiseDerivedFrom(): make sure you
00326             // have checked with typeid() or dynamic_cast() that *src
00327             // has the same dynamic type as *this.
00328             virtual void initialiseDerivedFrom(const ms_peptide_impl_reloadable *src) { copyFrom(dynamic_cast<const ms_peptide_impl_reloadable_crosslinked*>(src)); }
00329
00330             // clone() always returns a base class pointer, but may
00331             // allocate a derived class object.
00332             virtual ms_peptide_impl_reloadable* clone() const { return new ms_peptide_impl_reloadable_crosslinked(*this); }
00333
00334             virtual bool isSamePeptideStr(const ms_peptide_impl_reloadable *pReloadable_, const bool substituteAmbiguous) const;
00335             virtual bool isSameVarModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
00336             virtual bool isSameSummedModsStr(const ms_peptide_impl_reloadable *pReloadable_) const;
00337
00338             virtual int getNumberOfLinkedPeptides() const { return 2; }
00339             virtual void getIntactLinks(matrix_science::ms_linker_site_vector &vec) const {
00340                 vec.setVarModsStrLengths(
00341                     getPeptideLength(matrix_science::ms_peptide::PSM_CROSSLINK_ALPHA) + 2,
00342                     getPeptideLength(matrix_science::ms_peptide::PSM_CROSSLINK_BETA) + 2
00343                 );
00344                 vec.push(linkerSite_);
00345             }
00346
00347         private:
00348             virtual const linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) const { return peptideData_[PSM_enum_to_index(e)]; }
00349             virtual linearPeptideData_t& PSM_data(matrix_science::ms_peptide::PSM e) { return peptideData_[PSM_enum_to_index(e)]; }
00350
00351             static int PSM_enum_to_index(const matrix_science::ms_peptide::PSM e) {
00352                 /* Could do static_cast<int>(e), but it doesn't
00353                  * provide a failsafe default and there's no warning
00354                  * if the enum values change.
00355                  */
00356                 if (e == matrix_science::ms_peptide::PSM_COMPLETE) {
00357                     return 0;
00358                 } else if (e == matrix_science::ms_peptide::PSM_CROSSLINK_ALPHA) {
00359                     return 1;
00360                 } else if (e == matrix_science::ms_peptide::PSM_CROSSLINK_BETA) {
00361                     return 2;
00362                 }
00363                 return 0;
00364             }
00365
00366             static const int peptideDataSize = 3;
00367             linearPeptideData_t peptideData_[peptideDataSize];
00368             matrix_science::ms_linker_site linkerSite_;
00369     };
00370
00371     class ms_peptide_impl
00372     {
00373         public:
00375             ms_peptide_impl();
00376
00378             ms_peptide_impl(const int           query,
00379                             const int           rank,
00380                             //const ms_peptide::SEARCH_PHASE searchPhase,
00381                             const int           searchPhase,
00382                             const int           missedCleavages,
00383                             const double        mrCalc,
00384                             const double        delta,
00385                             const double        observed,
00386                             const int           charge,
00387                             const int           numIonsMatched,
00388                             const std::string & peptideStr,
00389                             const int           peaksUsedFromIons1,
00390                             const std::string & varModsStr,
00391                             const std::string & summedModsStr,
00392                             const std::string & localModsStr,
00393                             const std::string &  monoLinkStr,
00394                             const matrix_science::ms_linker_site_vector & loopLinks,
00395                             const double        ionsScore,
00396                             const std::string & seriesUsedStr,
00397                             const int           peaksUsedFromIons2,
00398                             const int           peaksUsedFromIons3,
00399                             const std::string &  primaryNlStr,
00400                             const std::string &  summedModsNlStr,
00401                             const std::string &  localModsNlStr,
00402                             const std::string &  substStr,
00403                             const std::string &  componentStr,
00404                             const matrix_science::ms_mascotresults * pResults,
00405                             const bool          storeReloadableInfo);
00406
00407             ms_peptide_impl(const int            query,
00408                             const int            rank,
00409                             const int            searchPhase,
00410                             const double         delta,
00411                             const double         observed,
00412                             const int            charge,
00413                             const int            numIonsMatched,
00414                             const int            peaksUsedFromIons1,
00415                             const double         ionsScore,
00416                             const std::string  & seriesUsedStr,
00417                             const int            peaksUsedFromIons2,
00418                             const int            peaksUsedFromIons3,
00419                             const ms_peptide_impl_reloadable::linearPeptideData_t & concatData,
00420                             const ms_peptide_impl_reloadable::linearPeptideData_t & linearAlpha,
00421                             const ms_peptide_impl_reloadable::linearPeptideData_t & linearBeta,
00422                             const matrix_science::ms_linker_site   & linkerSite,
00423                             const matrix_science::ms_mascotresults * pResults,
00424                             const bool           storeNonPersistantInfo);
00425
00426             ms_peptide_impl(const ms_peptide_impl& src);
00427
00428             ~ms_peptide_impl();
00429             ms_peptide_impl& operator=(const ms_peptide_impl& right);
00430
00431             void        copyFrom(const ms_peptide_impl * src);
00432             bool        clearReloadableInfo();
00433             int         getQuery()                  const { return query_;                }
00434             int         getRank()                   const { return rank_;                 }
00435             void        setRank(int rank)                 { rank_ = static_cast<char>(rank); }
00436             int         getPrettyRank()             const { return prettyRank_;           }
00437             void        setPrettyRank(int rank)           { prettyRank_ = static_cast<char>(rank); }
00438             int         getAmbiguityGroupId_()      const { return ambiguityGroupId_;     }
00439             void        setAmbiguityGroupId_(int group)   { ambiguityGroupId_ = group;    }
00440
00441             bool        getAnyMatch()               const { return isFlagSet(FL_ANY_MATCH); }
00442             int         getMissedCleavages(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)        const;
00443             double      getMrCalc(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)                 const;
00444             double      getDelta()                  const;
00445             double      getObserved()               const;
00446             double      getMrExperimental()         const;
00447             int         getCharge()                 const;
00448             int         getNumIonsMatched()         const;
00449             std::string getPeptideStr(const bool substituteAmbiguous = true) const {
00450                 return getPeptideStr(matrix_science::ms_peptide::PSM_COMPLETE, substituteAmbiguous);
00451             }
00452             std::string getPeptideStr(const matrix_science::ms_peptide::PSM entity, const bool substituteAmbiguous = true) const;
00453             int         getPeptideLength(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)          const;
00454             int         getPeaksUsedFromIons1()     const;
00455             int         getPeaksUsedFromIons2()     const;
00456             int         getPeaksUsedFromIons3()     const;
00457             std::string getVarModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)             const;
00458             void setVarModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00459             std::string getSummedModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)          const;
00460             void setSummedModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00461             std::string getLocalModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)          const;
00462             void setLocalModsStr(const std::string & str, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00463             std::string getMonoLinkStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)            const;
00464             void        setMonoLinkStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00465             std::string getParsedLocalModsStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)          const;
00466             double      getIonsScore()              const { return ionsScore_;            }
00467             double      getExpectationValue()       const;
00468             std::string getSeriesUsedStr()          const;
00469             bool        isSamePeptideStr(const ms_peptide_impl * pImpl, const bool substituteAmbiguous = true) const;
00470             bool        isSameVarModsStr(const ms_peptide_impl * pImpl) const;
00471             bool        isSameSummedModsStr(const ms_peptide_impl * pImpl) const;
00472             int         getFirstProtAppearedIn()    const;
00473             void        setFirstProtAppearedIn(int n);
00474             void        makeUnassigned();
00475             double      getIonsIntensity()          const;
00476             void        setIonsIntensity(double n);
00477             const matrix_science::ms_protein * getProtein(int num)  const;
00478             const std::vector<int> getProteins()    const;
00479             int         getNumProteins()            const;
00480             std::string getAmbiguityString(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)        const;
00481             bool        setAmbiguityString(const std::string & val, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00482             void        addProtein(const matrix_science::ms_protein * protein);
00483             void        addProtein(const int hitNumber);
00484             std::string getPrimaryNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)           const;
00485             void        setPrimaryNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00486             std::string getSummedModsNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)        const;
00487             void        setSummedModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00488             std::string getLocalModsNlStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)        const;
00489             void        setLocalModsNlStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00490             bool        isFlagSet(unsigned char fl) const { return (flags_ & fl)?true:false; }
00491             void        setFlag(unsigned char fl, bool val) {
00492                 if (val) {
00493                     flags_ |= fl;
00494                 } else {
00495                     //standard says complement must promote to int, performance is equal though
00496                     flags_ = static_cast<unsigned char>(flags_ & ~fl);
00497                 }
00498             }
00499
00500             bool        getIsFromErrorTolerant()    const { return isFlagSet(FL_IS_FROM_ERROR_TOLERANT);  }
00501             void        setIsFromErrorTolerant(const bool val) {
00502                 if (val)
00503                     setFlag(FL_IS_FROM_LIBRARY, false);
00504                 setFlag(FL_IS_FROM_ERROR_TOLERANT, val);
00505             }
00506             std::string getComponentStr(const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE)           const;
00507             void        setComponentStr(const std::string & value, const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE);
00508             bool        getLessThanMinPepLen()      const { return isFlagSet(FL_LESS_THAN_MIN_PEP_LEN);   }
00509             int         getNum13C(const double tol, const std::string tolu, const std::string & mass_type) const;
00510             void        setPercolatorScores(double posteriorErrorProbability,
00511                                             double qValue,
00512                                             double internalPercolatorScore);
00513             bool        anyPercolatorResults() const;
00514             void        getPercolatorScores(double * posteriorErrorProbability,
00515                                             double * qValue,
00516                                             double * internalPercolatorScore,
00517                                             double * mascotIonsScore) const;
00518
00519             bool        getIsFromLibrary()    const { return isFlagSet(FL_IS_FROM_LIBRARY);  }
00520             void        setIsFromLibrary(const bool val) {
00521                 if (val)
00522                     setFlag(FL_IS_FROM_ERROR_TOLERANT, false);
00523                 setFlag(FL_IS_FROM_LIBRARY, val);
00524             }
00525
00526             void        getAnyProteinTermination(
00527                                             bool & isNterminus,
00528                                             bool & isCterminus,
00529                                             const matrix_science::ms_peptide::PSM entity = matrix_science::ms_peptide::PSM_COMPLETE) const;
00530
00531             void        setInternalSortingScore(double s) { internalSortingScore_ = s; }
00532             double      getInternalSortingScore() const   { return internalSortingScore_; }
00533
00534             int         getNumberOfLinkedPeptides() const;
00535
00536             void        getIntactLinks(matrix_science::ms_linker_site_vector &vec) const;
00537             void        getLoopLinks(matrix_science::ms_linker_site_vector &vec, const matrix_science::ms_peptide::PSM entity) const;
00538
00539         private:
00540             void initProteinHitNumbers();
00541             void initFlags(const int searchPhase,
00542                            const int missedCleavages,
00543                            const int peptideLengthAlpha,
00544                            const int peptideLengthBeta,
00545                            const matrix_science::ms_mascotresults * pResults,
00546                            const bool storeReloadableInfo);
00547
00548             struct percolator_t {
00549                 double posteriorErrorProbability;
00550                 double qValue;
00551                 double internalPercolatorScore;
00552                 double mascotIonsScore;
00553             };
00554             mutable ms_peptide_impl_reloadable *pReloadable_;
00555             const       matrix_science::ms_mascotresults * pResults_;
00556             percolator_t *   percolator_;
00557             double           ionsScore_;
00558             double           internalSortingScore_;
00559             union {
00560                 int proteinHitNumbers_[2];
00561                 std::vector<int> * pProteinHitVect_;
00562             };
00563             int              query_;
00564             char             rank_;
00565             char             prettyRank_;
00566             int              ambiguityGroupId_;
00567             unsigned char    flags_;
00568
00569             bool checkNonPersist() const;
00570
00571             std::string serialiseLinearPeptideToCDB(const int           missedCleavages,
00572                                                     const double        mrCalc,
00573                                                     const double        delta,
00574                                                     const double        observed,
00575                                                     const int           charge,
00576                                                     const int           numIonsMatched,
00577                                                     const std::string & peptideStr,
00578                                                     const int           peaksUsedFromIons1,
00579                                                     const std::string & varModsStr,
00580                                                     const std::string & summedModsStr,
00581                                                     const std::string & localModsStr,
00582                                                     const std::string & monoLinkStr,
00583                                                     const matrix_science::ms_linker_site_vector & loopLinks,
00584                                                     //const double        ionsScore,
00585                                                     const std::string & seriesUsedStr,
00586                                                     const int           peaksUsedFromIons2,
00587                                                     const int           peaksUsedFromIons3,
00588                                                     const std::string &  primaryNlStr,
00589                                                     const std::string &  summedModsNlStr,
00590                                                     const std::string &  localModsNlStr,
00591                                                     const std::string &  substStr,
00592                                                     const std::string &  componentStr,
00593                                                     const std::string &  parsedLocalModsStr) const;
00594
00595             ms_peptide_impl_reloadable* parseLinearPeptideFromCDB(const matrix_science::ms_peptidesummary *pPepSum,
00596                                                                   const std::string &val) const;
00597
00598             std::string serialiseCrossLinkedPeptideToCDB(const double        delta,
00599                                                          const double        observed,
00600                                                          const int           charge,
00601                                                          const int           numIonsMatched,
00602                                                          const int           peaksUsedFromIons1,
00603                                                          const std::string & seriesUsedStr,
00604                                                          const int           peaksUsedFromIons2,
00605                                                          const int           peaksUsedFromIons3,
00606                                                          const ms_peptide_impl_reloadable::linearPeptideData_t &linearAlpha,
00607                                                          const ms_peptide_impl_reloadable::linearPeptideData_t &linearBeta,
00608                                                          const matrix_science::ms_linker_site &linkerSite) const;
00609
00610             ms_peptide_impl_reloadable* parseCrossLinkedPeptideFromCDB(const matrix_science::ms_peptidesummary *pPepSum,
00611                                                                        const std::string &val,
00612                                                                        const int query) const;
00613
00614     };
00615
00616     // Helper function: reset linkFrom and linkTo to the given value.
00617     // Other attributes are copied over verbatim.
00618     void adjustLoopLinks(const matrix_science::ms_linker_site_vector & src,
00619                          const matrix_science::ms_peptide::PSM         psmComponent,
00620                          matrix_science::ms_linker_site_vector       & target);
00621
00622 }   // msparser_internal namespace
00623
00624 #endif // MS_PEPTIDE_IMPL_HPP
00625
00626 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_peptide_quant_key.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_peptide_quant_key.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Peptide quantitation key used in ms_quantitation                           #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00013 #   $Revision: #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_PEPQUANTKEY_HPP
00019 #define MS_PEPQUANTKEY_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024
00025 namespace matrix_science {
00031
00032
00068     class MS_MASCOTRESFILE_API ms_peptide_quant_key
00069     {
00070         public:
00072             ms_peptide_quant_key();
00073
00075             ms_peptide_quant_key(int q, int p);
00076
00078             ms_peptide_quant_key(int q, int p, int charge);
00079
00081             explicit ms_peptide_quant_key(int ID);
00082
00084             explicit ms_peptide_quant_key(const std::string &opaqueString);
00085
00087             explicit ms_peptide_quant_key(const std::string &opaqueString, int ID);
00088
00090             ms_peptide_quant_key(const ms_peptide_quant_key& src);
00091
00093             ~ms_peptide_quant_key();
00094
00095 #ifndef SWIG
00096
00097             ms_peptide_quant_key& operator=(const ms_peptide_quant_key& right);
00098
00100             bool operator<(const ms_peptide_quant_key& right) const;
00101
00103             bool operator<=(const ms_peptide_quant_key& right) const;
00104
00106             bool operator>(const ms_peptide_quant_key& right) const;
00107
00109             bool operator>=(const ms_peptide_quant_key& right) const;
00110
00112             bool operator==(const ms_peptide_quant_key& right) const;
00113
00115             bool operator!=(const ms_peptide_quant_key& right) const;
00116 #endif
00117
00118
00119 #ifndef SWIG
00120
00121             bool getQueryAndRank(int &q, int &p) const;
00122
00124             bool getCharge(int &charge) const;
00125
00127             bool getID(int &ID) const;
00128
00130             bool getOpaqueString(std::string & opaqueStringRef) const;
00131
00133             bool getOpaqueStringAndID(std::string & opaqueStringRef, int & ID) const;
00134 #else // SWIG Multiple return values
00135             bool getQueryAndRank(int & OUTPUT, int & OUTPUT) const;
00136             bool getCharge(int &OUTPUT) const;
00137             bool getID(int &OUTPUT) const;
00138             bool getOpaqueString(std::string & OUTPUT) const;
00139             bool getOpaqueStringAndID(std::string & OUTPUT, int & OUTPUT) const;
00140 #endif
00141
00143             bool isNil() const;
00144
00146             static ms_peptide_quant_key fromSerialisedString(const std::string &serialisedStr);
00147
00149             std::string serialise() const;
00150
00152             static std::string serialisationFormatVersion();
00153
00154         private:
00155             enum PEPQUANTKEY_TYPE {
00156                 PEPQUANTKEY_NIL,
00157                 PEPQUANTKEY_QP,
00158                 PEPQUANTKEY_QPCHARGE,
00159                 PEPQUANTKEY_ID,
00160                 PEPQUANTKEY_OPAQUE,
00161                 PEPQUANTKEY_OPAQUEID
00162             };
00163
00164             int type_, q_, p_, charge_, ID_;
00165             std::string *opaqueString_;
00166     }; // end of quantitation_group
00168 }   // matrix_science namespace
00169
00170 #endif // MS_PEPQUANTKEY_HPP
00171
00172 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_peptide_quant_key_vector.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_peptide_quant_key_vector.hpp                                      #
00004 # 'msparser' toolkit                                                         #
00005 # A vector of ms_peptide_quant_key objects                                   #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00013 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_PEPQUANTKEYVECTOR_HPP
00019 #define MS_PEPQUANTKEYVECTOR_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <vector>
00024 #include <list>
00025
00026 namespace matrix_science {
00027     class ms_peptide_quant_key;
00028 }
00029
00030 namespace matrix_science {
00036
00037
00046     class MS_MASCOTRESFILE_API ms_peptide_quant_key_vector
00047     {
00048         public:
00050             ms_peptide_quant_key_vector();
00051
00052 #ifndef SWIG
00053
00054             explicit ms_peptide_quant_key_vector(const std::vector<ms_peptide_quant_key> &v);
00055
00057             explicit ms_peptide_quant_key_vector(const std::list<ms_peptide_quant_key> &v);
00058 #endif
00059
00061             ms_peptide_quant_key_vector(const ms_peptide_quant_key_vector& src);
00062
00064             ~ms_peptide_quant_key_vector();
00065
00066 #ifndef SWIG
00067
00068             ms_peptide_quant_key_vector& operator=(const ms_peptide_quant_key_vector& right);
00069
00071             const std::vector<ms_peptide_quant_key>& toVector() const;
00072 #endif
00073
00075             void copyFrom(const ms_peptide_quant_key_vector *src);
00076
00078             void append(const ms_peptide_quant_key_vector & src);
00079
00081             int size() const;
00082
00084             bool empty() const;
00085
00087             void push(const ms_peptide_quant_key &key);
00088
00090             ms_peptide_quant_key pop();
00091
00093             ms_peptide_quant_key get(int idx) const;
00094
00096             void set(int idx, const ms_peptide_quant_key &key);
00097
00099             void clear();
00100
00102             void swap(ms_peptide_quant_key_vector &right);
00103
00104         private:
00105             std::vector<ms_peptide_quant_key> data_;
00106     }; // end of quantitation_group
00108 }   // matrix_science namespace
00109
00110 #endif // MS_PEPQUANTKEYVECTOR_HPP
00111
00112 /*------------------------------- End of File -------------------------------*/
00113
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_peptide_quant_ratio.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_peptide_quant_ratio.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Peptide intensity ratio for relative quantitation                          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00013 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_PEPTIDE_QUANT_RATIO_HPP
00019 #define MS_PEPTIDE_QUANT_RATIO_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024 #include <vector>
00025
00026 namespace matrix_science {
00027     class ms_peptide_quant_key;
00028
00034
00035
00060     class MS_MASCOTRESFILE_API ms_peptide_quant_ratio
00061     {
00062         public:
00064             ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, bool isInfinite = false);
00065
00067             ms_peptide_quant_ratio(const ms_peptide_quant_key &key, const std::string &ratioName, double value, bool isExcluded = false, double weight = 1.0);
00068
00070             ms_peptide_quant_ratio(const ms_peptide_quant_ratio& src);
00071
00073             ~ms_peptide_quant_ratio();
00074
00075 #ifndef SWIG
00076
00077             ms_peptide_quant_ratio& operator=(const ms_peptide_quant_ratio& right);
00078 #endif
00079
00080             void copyFrom(const ms_peptide_quant_ratio *src);
00081
00083             bool isMissing() const;
00084
00086             bool isInfinite() const;
00087
00089             double getValue() const;
00090
00092             ms_peptide_quant_key getKey() const;
00093
00095             std::string getRatioName() const;
00096
00098             bool isExcluded() const;
00099
00101             double getWeight() const;
00102
00103         private:
00104             bool isMissing_;
00105             bool isInfinite_;
00106             double value_;
00107
00108             ms_peptide_quant_key *peptideQuantKey_;
00109             std::string ratioName_;
00110
00111             bool isExcluded_;
00112             double weight_;
00113     }; // end of quantitation_group
00115 }   // matrix_science namespace
00116
00117 #endif // MS_PEPTIDE_QUANT_RATIO_HPP
00118
00119 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_processoroptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_processoroptions.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Represents parameters of "Processors" section of "mascot.dat"-file         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_processoroptions.hpp    $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_PROCESSOROPTIONS_HPP
00020 #define MS_PROCESSOROPTIONS_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00033
00034     class MS_MASCOTRESFILE_API ms_dbprocessors
00035     {
00036         friend class ms_datfile;
00037         friend class ms_processoroptions;
00038     public:
00040         ms_dbprocessors();
00041
00043         ms_dbprocessors(const ms_dbprocessors& src);
00044
00046         ~ms_dbprocessors();
00047
00049         void defaultValues();
00050
00052         void copyFrom(const ms_dbprocessors* right);
00053
00054 #ifndef SWIG
00055
00056         ms_dbprocessors& operator=(const ms_dbprocessors& right);
00057 #endif
00058
00059         std::string getName() const;
00060
00062         void setName(const char * str);
00063
00065         int getNumberOfThreads() const;
00066
00068         void clearThreads();
00069
00071         int getThreadProcessorID(const int threadIndex) const;
00072
00074         void appendThreadProcessorID(const int proccessorID);
00075     private:
00076         std::string         name_;
00077         std::vector<int>    threads_;
00078
00079         std::string getStringValue() const;
00080     }; // class ms_dbprocessors
00081
00083
00108     class MS_MASCOTRESFILE_API ms_processoroptions : public ms_customproperty
00109     {
00110         friend class ms_datfile;
00111     public:
00112
00114         ms_processoroptions();
00115
00117         ms_processoroptions(const ms_processoroptions& src);
00118
00120         ~ms_processoroptions();
00121
00123         void defaultValues();
00124
00126         void copyFrom(const ms_processoroptions* right);
00127
00128 #ifndef SWIG
00129
00130         ms_processoroptions& operator=(const ms_processoroptions& right);
00131 #endif
00132
00133         bool isSectionAvailable() const;
00134
00136         void setSectionAvailable(const bool value);
00137
00139         int getNumberOfProcessors() const;
00140
00142         void clearProcessors();
00143
00145         int getProcessor(const int index) const;
00146
00148         void appendProcessor(const int processorID);
00149
00151         int getNumberOfDatabases() const;
00152
00154         const ms_dbprocessors* getDatabase(const int index) const;
00155
00157         void clearDatabases();
00158
00160         void appendDatabase(const ms_dbprocessors* db);
00161
00162 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00163 #include "suppress_ms_customproperty.hpp"
00164 #endif
00165
00166     private:
00167         bool                            sectionAvailable_;
00168         std::vector<int>                processors_;
00169         std::vector<ms_dbprocessors*>   dbs_;
00170     }; // class ms_processoroptions // end of config_group
00172 } // namespace matrix_science;
00173
00174 #endif // MS_PROCESSOROPTIONS_HPP
00175
00176 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_processors.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_processors.hpp                                                    #
00004 # 'msparser' toolkit                                                         #
00005 # Use this class to retrieve current CPU configuration                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_processors.hpp          $ #
00012 #     $Author: dcreasy@matrixscience.com $ #
00013 #       $Date: 2019-10-15 16:50:41 +0100 $ #
00014 #   $Revision: 35b34891b5eee100f767f95780f54a007d0db4b5 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_PROCESSORS_HPP
00020 #define MS_PROCESSORS_HPP
00021
00022 #include <string>
00023 #include <vector>
00024
00025 namespace msparser_internal {
00026     class ms_processors_impl;
00027 }
00028
00029 namespace matrix_science {
00030
00036
00037
00049     class MS_MASCOTRESFILE_API ms_processors: public ms_errors
00050     {
00051     public:
00053
00060         enum HYPERTHREADING
00061         {
00062             HT_NOT_CAPABLE           = 0,
00063             HT_ENABLED               = 1,
00064             HT_DISABLED              = 2,
00065             HT_SUPPORTED_NOT_ENABLED = 3,
00066             HT_CANNOT_DETECT         = 4
00067         };
00068
00070
00079         enum {
00080             DEPRECATED_MAX_CORES_PER_LICENSE = 4
00081         };
00082
00084         ms_processors(bool checkLinuxHT, int unused);
00085
00087         ms_processors(const ms_processors& src);
00088
00090         ~ms_processors();
00091
00093         void copyFrom(const ms_processors* right);
00094
00095 #ifndef SWIG
00096
00097         ms_processors& operator=(const ms_processors& right);
00098 #endif
00099
00100         int getNumOnSystem() const;
00101
00103         int getNumAvailableToProcess() const;
00104
00106         bool isProcessAffinitySupported() const;
00107
00109         bool isUseProcessesNotThreads() const;
00110
00112         UINT64 getWhichAvailableForMascot() const;
00113
00115         std::vector<int> getWhichAvailableForMascot2() const;
00116
00118         bool isLogicalCPUAvailableForMascot(const int cpu) const;
00119
00121         int getNumProcessorGroups() const;
00122
00124         int getNumPhysicalOnSystem() const;
00125
00127         HYPERTHREADING getHyperThreadingState() const;
00128
00130         int getNumLogicalPerPhysical(const int packageID = 0) const;
00131
00133         int getNumCores(const int packageID = -1) const;
00134
00136         int getPhysicalFromLogical(const int cpu) const;
00137
00139         std::string getProcessorName() const;
00140
00142         std::string getMultithreadedName() const;
00143
00145         UINT64 getHyperThreadedCPUsMask() const;
00146
00148         bool isPrimaryLogicalProcessor(const int cpu) const;
00149
00151         bool isThreadedLogicalProcessor(const int cpu) const;
00152
00154         int getCoreFromLogical(const int cpu) const;
00155
00157         int getHT_IDFromLogical(const int cpu) const;
00158
00160         int getAutoDetectNumThreads(const int numLicensed, const int numCoresPerCpuLicense) const;
00161
00163         bool setProcessAffinity(const std::vector<unsigned int> & vecCpu) const;
00164
00166         bool setProcessAffinity(const std::vector<int> & vecCpu) const;
00167
00169         bool setThreadAffinity(const int logicalCpu) const;
00170
00171     private:
00172         msparser_internal::ms_processors_impl * pImpl_;
00173     }; // class ms_processors // end of config_group
00175 } // namespace matrix_science
00176
00177 #endif // MS_PROCESSORS_HPP
00178
00179 /*------------------------------- End of File -------------------------------*/
00180
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_processors_impl.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_processors_impl.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Use this class to retrieve current CPU configuration                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_processors.hpp          $ #
00012 #     $Author$ #
00013 #       $Date$ #
00014 #   $Revision$ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_PROCESSORS_INTERNAL_HPP
00020 #define MS_PROCESSORS_INTERNAL_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025 #include <map>
00026
00027 #include "hwloc.h"
00028
00029 namespace msparser_internal {
00030
00031     class ms_cpuinfo
00032     {
00033     public:
00034         ms_cpuinfo() : package_id_(0),
00035                        core_id_(0),
00036                        ht_id(0),
00037                        availableForMascot_(true),
00038                        isPrimary_(true) {};
00039         // int logical_id use as the map
00040         int  package_id_;          // i.e. what goes in a socket. Zero based
00041         int  core_id_;             // Zero based id, restarts at zero for each package
00042         int  ht_id;                // Zero based id, restarts at zero for each core
00043         bool availableForMascot_;  // Should always be true?
00044         bool isPrimary_;
00045         hwloc_cpuset_t hwloc_cpuset_;
00046     };
00047
00048    class ms_processors_impl
00049     {
00050     public:
00052         ms_processors_impl(matrix_science::ms_errs & errs);
00053
00055         ms_processors_impl(const ms_processors_impl & src);
00056
00058         ~ms_processors_impl();
00059
00061         void copyFrom(const ms_processors_impl* right);
00062
00064         ms_processors_impl& operator=(const ms_processors_impl & right);
00065
00067         int getNumOnSystem() const;
00068
00070         int getNumAvailableToProcess() const;
00071
00073         bool isProcessAffinitySupported() const;
00074
00076         bool isUseProcessesNotThreads() const;
00077
00079         UINT64 getWhichAvailableForMascot() const;
00080
00082         std::vector<int> getWhichAvailableForMascot2() const;
00083
00085         bool isLogicalCPUAvailableForMascot(const int cpu) const;
00086
00088         int getNumProcessorGroups() const;
00089
00091         int getNumPhysicalOnSystem() const;
00092
00094         matrix_science::ms_processors::HYPERTHREADING getHyperThreadingState() const;
00095
00097         int getNumLogicalPerPhysical(const int packageID = 0) const;
00098
00100         int getNumCores(const int packageID = -1) const;
00101
00103         int getPhysicalFromLogical(const int cpu) const;
00104
00106         std::string getProcessorName() const;
00107
00109         std::string getMultithreadedName() const;
00110
00112         UINT64 getHyperThreadedCPUsMask() const;
00113
00115         bool isPrimaryLogicalProcessor(const int cpu) const;
00116
00118         bool isThreadedLogicalProcessor(const int cpu) const;
00119
00121         int getCoreFromLogical(const int cpu) const;
00122
00124         int getHT_IDFromLogical(const int cpu) const;
00125
00127         int getAutoDetectNumThreads(const int numLicensed, const int numCoresPerCpuLicense) const;
00128
00130         bool setProcessAffinity(const std::vector<unsigned int> & vecCpu) const;
00131
00133         bool setProcessAffinity(const std::vector<int> & vecCpu) const;
00134
00136         bool setThreadAffinity(const int logicalCpu) const;
00137
00138     private:
00139         matrix_science::ms_errs & errs_;
00140         typedef std::map<int, ms_cpuinfo> cpuInfo_t;
00141         cpuInfo_t        cpuInfo_;
00142         int              numProcessorGroups_;
00143         bool             processAffinitySupported_;
00144         bool             useProcessesNotThreads_;
00145         matrix_science::ms_processors::HYPERTHREADING  hyperThreading_;
00146         std::string      processorName_;           // e.g. "Intel", "AMD Opteron", "Power 5"
00147         std::string      multiThreadName_;         // e.g. "Hyper-threading", "Dual Core", "SMT"
00148         bool             isIntelProcessor_;
00149         hwloc_topology_t hwlocTopology_;
00150
00151         void defaultValues();
00152         void getChipManufacturer();
00153         void iterateHwlocChildren(hwloc_obj_t hwLocObj, unsigned int depth,
00154                                   unsigned int & packageID, unsigned int & coreID, unsigned int & processingUnitID);
00155         void checkProcessorsAvailable();
00156     }; // class ms_processors_impl
00157 } // namespace msparser_internal
00158
00159 #endif // MS_PROCESSORS_INTERNAL_HPP
00160
00161 /*------------------------------- End of File -------------------------------*/
00162
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_progress_info.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_progress_info.hpp
00004 # 'msparser' toolkit
00005 # Current progress through a file load or dave
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_progress_info.hpp $
00012  * @(#)$Revision: 13eeeb76d98cb3364b3262ac81b740f5a2a28aba | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-10-18 17:21:45 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_PROGRESS_INFO_HPP
00018 #define MS_PROGRESS_INFO_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <list>
00023 #include <string>
00024
00025 namespace matrix_science
00026 {
00027     //=========================================================================
00033     class ms_progress_info;
00034
00036
00039     class MS_MASCOTRESFILE_API ms_progress_info
00040     {
00041         public:
00043             enum STATUS
00044             {
00045                 S_NOT_STARTED,
00046                 S_RUNNING,
00047                 S_RUNNING_INDETERMINATE,
00048                 S_STOPPED_FAIL,
00049                 S_STOPPED_BREAK,
00050                 S_STOPPED_COMPLETE
00051             };
00052
00054             ms_progress_info();
00055
00057             ms_progress_info(const std::string & description, size_t total);
00058
00060             ~ms_progress_info();
00061
00063             void clear(const std::string & description = "", size_t total = 0);
00065             STATUS getStatus() const;
00067             const std::string & getDescription() const;
00069             size_t getTotal() const;
00071             size_t getProgress() const;
00073             int getNumberOfSubtasks() const;
00075             const ms_progress_info * getSubtaskProgress(int index) const;
00077             void setBreak() const;
00078
00080             ms_progress_info * addSubtask(const std::string & description, size_t total);
00082             void addSubtask(const ms_progress_info * task);
00084             void updateProgress(size_t progress, size_t total);
00086             void updateFail();
00088             void updateBreak();
00090             void updateComplete();
00092             void updateIndeterminate();
00094             bool isBreaking() const;
00096             void removeSubtask(int index);
00097
00098         private:
00099             // noncopyable
00100             ms_progress_info(const ms_progress_info &);
00101             void operator= (const ms_progress_info &);
00102
00103             std::string description_;
00104             STATUS status_;
00105             size_t total_;
00106             size_t progress_;
00107             mutable bool break_;
00108
00109             // The bool item in the list is used to specify whether the parent
00110             // destructor should delete the child object.
00111             // If the object is created by calling
00112             // addSubtask(description, total) then it has been created by the
00113             // parent and will be deleted by the parent.
00114             std::list<std::pair<bool, ms_progress_info*> > subtasks_;
00115     };
00116  // end of quantitation_group
00118     //=========================================================================
00119
00120 } // namespace matrix_science
00121
00122 #endif // MS_PROGRESS_INFO_HPP
00123
00124 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_protein_match_data.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_protein_match_data.hpp                                            #
00004 # 'msparser' toolkit                                                         #
00005 # Dummy class for data transfer between ms_mascotresults and ms_protein      #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2018 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2018-11-19 15:11:26 +0000 $ #
00013 #   $Revision: d7f1d983172b5d8ac33cadb2a23dedd5512015ad | FRESH_CVS_IMPORT-68-g72a4e02de2 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_PROTEIN_MATCH_DATA_HPP
00019 #define MS_PROTEIN_MATCH_DATA_HPP
00020
00021 #include <boost/container/slist.hpp>
00022
00023 // TODO: When we update Boost, change the header path of boost::hash.
00024 // In Boost 1.65, it's boost/functional/hash.hpp. In later versions,
00025 // it's boost/container_hash/hash.hpp.
00026
00027 #include <boost/functional/hash.hpp>
00028
00029 namespace msparser_internal {
00030     /* Dummy class intended for data transfer between ms_mascotresults
00031      * and ms_protein.
00032      *
00033      * The auxiliary class SEQINFO holds all the actual data.
00034      * ms_protein_match_data has one public member, which is a singly
00035      * linked list of SEQINFO. The purpose of ms_protein_match_data is
00036      * to hide this implementation detail and avoid having to put a
00037      * Boost header or class declaration in our public API.
00038      */
00039     class ms_SEQINFO {
00040     public:
00041         ms_SEQINFO()
00042             : start(0)
00043             , end(0)
00044             , multiplicity(0)
00045             , psmComponent(ms_peptide::PSM_COMPLETE)
00046             , residueBefore('?')
00047             , residueAfter('?')
00048             , frame(-1)
00049             { }
00050         ms_SEQINFO(ms_peptide::PSM ent)
00051             : start(0)
00052             , end(0)
00053             , multiplicity(0)
00054             , psmComponent(ent)
00055             , residueBefore('?')
00056             , residueAfter('?')
00057             , frame(-1)
00058             { }
00059         ms_SEQINFO(ms_peptide::PSM ent, int fra)
00060             : start(0)
00061             , end(0)
00062             , multiplicity(0)
00063             , psmComponent(ent)
00064             , residueBefore('?')
00065             , residueAfter('?')
00066             , frame(fra)
00067             { }
00068
00069         // Equality operator needed for storing values in a hash
00070         // table.
00071         bool operator==(const ms_SEQINFO &right) const {
00072             return (start == right.start
00073                 && end == right.end
00074                 && multiplicity == right.multiplicity
00075                 && psmComponent == right.psmComponent
00076                 && residueBefore == right.residueBefore
00077                 && residueAfter == right.residueAfter
00078                 && frame == right.frame);
00079         }
00080
00081         // Boost.Hash function needed for storing values in a hash
00082         // table.
00083         friend std::size_t hash_value(const ms_SEQINFO &seq) {
00084             // See "Combining hash values" in Boost.Hash documentation.
00085             std::size_t seed = 0;
00086             boost::hash_combine(seed, seq.start);
00087             boost::hash_combine(seed, seq.end);
00088             boost::hash_combine(seed, seq.psmComponent);
00089             boost::hash_combine(seed, seq.residueBefore);
00090             boost::hash_combine(seed, seq.residueAfter);
00091             boost::hash_combine(seed, seq.frame);
00092             return seed;
00093         }
00094
00095         /*
00096          * \param ent one of ms_peptide::PSM (only relevant in crosslinked searches)
00097          * \param fra Frame number - zero for protein database
00098          * \param sta Zero based start residue in the protein sequence
00099          * \param end Zero based end residue in the protein sequence
00100          * \param mul is the number of precursor matches for this accession.
00101          *        See getPeptideMultiplicity ()
00102          * \param bef is the residue in the protein sequence before this
00103          *        peptide being added. See getPeptideResidueBefore()
00104          * \param aft is the residue in the protein sequence after this
00105          *        peptide being added. See getPeptideResidueAfter()
00106          */
00107         ms_SEQINFO(ms_peptide::PSM ent, int fra, long sta, long end, long mul, char bef, char aft)
00108             : start(sta), end(end), multiplicity(mul), psmComponent(ent), residueBefore(bef), residueAfter(aft), frame(fra)
00109             { }
00110
00111     public:
00112         // Note: packing this data tightly is important for memory
00113         // use within ms_protein.
00114         int         start;
00115         int         end;
00116         long        multiplicity;
00117         unsigned int psmComponent:2;
00118         char        residueBefore:8;
00119         char        residueAfter:8;
00120         int         frame:5;
00121     };
00122
00123     class ms_protein_match_data {
00124     public:
00125         ms_protein_match_data()
00126             : seqs()
00127             { }
00128         explicit ms_protein_match_data(const ms_SEQINFO &seqInfo)
00129             : seqs(1, seqInfo)
00130             { }
00131
00132     public:
00133         typedef boost::container::slist<ms_SEQINFO> seqInfoList_t;
00134         seqInfoList_t seqs;
00135     };
00136 }
00137
00138 #endif // MS_PROTEIN_MATCH_DATA_HPP
00139
00140 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_protein_quant_ratio.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_protein_quant_ratio.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Protein ratio for relative quantitation, estimated from peptide ratios     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00013 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_PROTEIN_QUANT_RATIO_HPP
00019 #define MS_PROTEIN_QUANT_RATIO_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024 #include <map>
00025
00026 namespace matrix_science {
00027     class ms_peptide_quant_key;
00028     class ms_peptide_quant_key_vector;
00029
00035
00036
00071     class MS_MASCOTRESFILE_API ms_protein_quant_ratio
00072     {
00073         friend class ms_quantitation;
00074         friend class ms_ms1quantitation;
00075         friend class ms_ms2quantitation;
00076         friend class ms_customquantitation;
00077
00078         public:
00081             ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName);
00082
00085             ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, unsigned int sampleSize);
00086
00088             ms_protein_quant_ratio(const ms_protein_quant_ratio& src);
00089
00091             ~ms_protein_quant_ratio();
00092
00093 #ifndef SWIG
00094
00095             ms_protein_quant_ratio& operator=(const ms_protein_quant_ratio& right);
00096
00098             bool operator==(const ms_protein_quant_ratio& right) const;
00099
00101             bool operator!=(const ms_protein_quant_ratio& right) const;
00102 #endif
00103
00104             void copyFrom(const ms_protein_quant_ratio* src);
00105
00107             bool isMissing() const;
00108
00110             std::string getAccession() const;
00111
00113             int getDB() const;
00114
00116             std::string getRatioName() const;
00117
00119             double getValue() const;
00120
00122             unsigned int getSampleSize() const;
00123
00125             double getStandardDeviation() const;
00126
00128             double getStandardDeviation(std::string &whyUnavailable) const;
00129
00131             double getStandardError() const;
00132
00134             double getStandardError(std::string &whyUnavailable) const;
00135
00137             ms_peptide_quant_key_vector getActiveKeys() const;
00138
00140             ms_peptide_quant_key_vector getSkippedKeys() const;
00141
00143             ms_peptide_quant_key_vector getOutlierKeys() const;
00144
00146             ms_peptide_quant_key_vector getExcludedKeys() const;
00147
00149             double getHypothesisPvalue() const;
00150
00152             double getHypothesisPvalue(std::string &whyUnavailable) const;
00153
00155             bool isSignificant(double threshold = 0.05) const;
00156
00158             double getNormalityPvalue() const;
00159
00161             double getNormalityPvalue(std::string &whyUnavailable) const;
00162
00164             bool isLogNormal(double threshold = 0.05) const;
00165
00167             static ms_protein_quant_ratio fromSerialisedString(const std::string &serialisedStr);
00168
00170             std::string serialise() const;
00171
00173             static std::string serialisationFormatVersion();
00174
00175         private:
00176             enum PEPQUANTKEY_STATE {
00177                 PEPQUANTKEY_SKIPPED  = 0x0001,
00178                 PEPQUANTKEY_OUTLIER  = 0x0002,
00179                 PEPQUANTKEY_EXCLUDED = 0x0004
00180             };
00181
00182             enum REASON_WHY_UNAVAILABLE {
00183                 REASON_NOT_UNAVAILABLE = 0,
00184                 REASON_MISSING_RATIO = 1,
00185                 REASON_TYPE_WEIGHTED = 2
00186             };
00187
00188             static std::string lookupWhyUnavailable(int reason);
00189
00190 //Warning 325: Nested struct not currently supported
00191 #ifndef SWIG
00192             typedef struct { int why; const char *str; } reason_why_t;
00193             static const reason_why_t reason_why_db[];
00194 #endif
00195
00196
00197             ms_protein_quant_ratio(const std::string &accession, int dbIdx, const std::string &ratioName, double value, double stdev, double stderror, double hypothesisPvalue, double normalityPvalue, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys);
00198
00199             ms_peptide_quant_key_vector collectKeys(int type) const;
00200
00201             bool isMissing_;
00202
00203             std::string accession_;
00204             int dbIdx_;
00205             std::string ratioName_;
00206
00207             double value_;
00208
00209             double stdev_;
00210             double stderror_;
00211             int whyStdevUnavailable_;
00212
00213             double hypothesisPvalue_;
00214             int whyHypothesisPUnavailable_;
00215
00216             double normalityPvalue_;
00217             int whyNormalityPUnavailable_;
00218
00219             unsigned int sampleSize_;
00220
00221             std::vector<ms_peptide_quant_key> activeKeys_;
00222             std::map<ms_peptide_quant_key, int> inactiveKeys_;
00223     }; // end of quantitation_group
00225 }   // matrix_science namespace
00226
00227 #endif // MS_PROTEIN_QUANT_RATIO_HPP
00228
00229 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_average.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_average.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates average-element from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_average.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_AVERAGE_HPP
00018 #define MS_QUANT_AVERAGE_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029
00035
00036
00039     class MS_MASCOTRESFILE_API ms_quant_average: public ms_quant_parameters
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042     public:
00044         ms_quant_average();
00045
00047         ms_quant_average(const ms_quant_average& src);
00048
00050         virtual ~ms_quant_average();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_quant_average* right);
00057
00058 #ifndef SWIG
00059
00060         ms_quant_average& operator=(const ms_quant_average& right);
00061 #endif
00062
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00073         bool haveNumPeptides() const;
00074
00076         int getNumPeptides() const;
00077
00079         void setNumPeptides(int value);
00080
00082         void dropNumPeptides();
00083
00085         std::string getNumPeptidesSchemaType() const;
00086
00087
00089         bool haveSelection() const;
00090
00092         std::string getSelection() const;
00093
00095         void setSelection(const char* value);
00096
00098         void dropSelection();
00099
00101         std::string getSelectionSchemaType() const;
00102
00103
00105         bool haveReferenceAccession() const;
00106
00108         std::string getReferenceAccession() const;
00109
00111         void setReferenceAccession(const char* value);
00112
00114         void dropReferenceAccession();
00115
00117         std::string getReferenceAccessionSchemaType() const;
00118
00119
00121         bool haveReferenceDatabase() const;
00122
00124         std::string getReferenceDatabase() const;
00125
00127         void setReferenceDatabase(const char* value);
00128
00130         void dropReferenceDatabase();
00131
00133         std::string getReferenceDatabaseSchemaType() const;
00134
00135
00137         bool haveReferenceAmount() const;
00138
00140         std::string getReferenceAmount() const;
00141
00143         void setReferenceAmount(const char* value);
00144
00146         void dropReferenceAmount();
00147
00149         std::string getReferenceAmountSchemaType() const;
00150     private:
00151
00152         int _numPeptides;
00153         bool _numPeptides_set;
00154
00155         std::string _selection;
00156         bool _selection_set;
00157
00158         std::string _referenceAccession;
00159         bool _referenceAccession_set;
00160
00161         std::string _referenceDatabase;
00162         bool _referenceDatabase_set;
00163
00164         std::string _referenceAmount;
00165         bool _referenceAmount_set;
00166     }; // class ms_quant_average
00167  // end of config_group
00169
00170 } // namespace matrix_science
00171
00172 #endif // MS_QUANT_AVERAGE_HPP
00173
00174 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_component.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_component.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates component-element from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_component.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_COMPONENT_HPP
00018 #define MS_QUANT_COMPONENT_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_modgroup; // forward declaration
00032     class ms_quant_moverz; // forward declaration
00033     class ms_quant_correction; // forward declaration
00034     class ms_quant_isotope; // forward declaration
00035     class ms_quant_satellite; // forward declaration
00036     class ms_xml_schema; // forward declaration
00037
00043
00044
00047     class MS_MASCOTRESFILE_API ms_quant_component: public ms_xml_IValidatable
00048     {
00049         friend class msparser_internal::ms_quant_xmlloader;
00050
00051     public:
00053         ms_quant_component();
00054
00056         ms_quant_component(const ms_quant_component& src);
00057
00059         virtual ~ms_quant_component();
00060
00062         void defaultValues();
00063
00065         void copyFrom(const ms_quant_component* right);
00066
00067 #ifndef SWIG
00068
00069         ms_quant_component& operator=(const ms_quant_component& right);
00070 #endif
00071
00073         virtual std::string getSchemaType() const;
00074
00076         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00077
00079         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00080
00081
00083         bool haveMoverz() const;
00084
00086         const ms_quant_moverz* getMoverz() const;
00087
00089         void setMoverz(const ms_quant_moverz* moverz);
00090
00092         void dropMoverz();
00093
00095         std::string getMoverzSchemaType() const;
00096
00097
00099         int getNumberOfModificationGroups() const;
00100
00102         void clearModificationGroups();
00103
00105         void appendModificationGroup(const ms_quant_modgroup *item);
00106
00108         const ms_quant_modgroup * getModificationGroupByNumber(const int idx) const;
00109
00111         const ms_quant_modgroup * getModificationGroupByName(const char *name) const;
00112
00114         bool updateModificationGroupByNumber(const int idx, const ms_quant_modgroup* modgroup);
00115
00117         bool updateModificationGroupByName(const char *name, const ms_quant_modgroup* modgroup);
00118
00120         bool deleteModificationGroupByNumber(const int idx);
00121
00123         bool deleteModificationGroupByName(const char *name);
00124
00126         std::string getModificationGroupSchemaType() const;
00127
00128
00130         int getNumberOfIsotopes() const;
00131
00133         void clearIsotopes();
00134
00136         void appendIsotope(const ms_quant_isotope* isotope);
00137
00139         const ms_quant_isotope* getIsotope(const int idx) const;
00140
00142         bool updateIsotope(const int idx, const ms_quant_isotope* isotope);
00143
00145         bool deleteIsotope(const int idx);
00146
00148         std::string getIsotopeSchemaType() const;
00149
00150
00151
00153         bool haveFileIndex() const;
00154
00156         int getFileIndex() const;
00157
00159         void setFileIndex(const int file_index);
00160
00162         void dropFileIndex();
00163
00165         std::string getFileIndexSchemaType() const;
00166
00167
00169         int getNumberOfCorrections() const;
00170
00172         void clearCorrections();
00173
00175         void appendCorrection(const ms_quant_correction* correction);
00176
00178         const ms_quant_correction* getCorrection(const int idx) const;
00179
00181         bool updateCorrection(const int idx, const ms_quant_correction* isotope);
00182
00184         bool deleteCorrection(const int idx);
00185
00187         std::string getCorrectionSchemaType() const;
00188
00189
00191         bool haveName() const;
00192
00194         std::string getName() const;
00195
00197         void setName(const char* value);
00198
00200         void dropName();
00201
00203         std::string getNameSchemaType() const;
00204
00205
00207         bool haveSatellite() const;
00208
00210         const ms_quant_satellite* getSatellite() const;
00211
00213         void setSatellite(const ms_quant_satellite* satellite);
00214
00216         void dropSatellite();
00217
00219         std::string getSatelliteSchemaType() const;
00220
00221     private:
00222         // elements
00223         ms_quant_moverz *_pMoverz;
00224         bool _moverz_set;
00225
00226         typedef std::vector< ms_quant_modgroup* > modgroup_vector;
00227         modgroup_vector _modgroups;
00228
00229         typedef std::vector< ms_quant_isotope* > isotope_vector;
00230         isotope_vector _isotopes;
00231
00232         int _fileIndex;
00233         bool _fileIndex_set;
00234
00235         typedef std::vector< ms_quant_correction* > correction_vector;
00236         correction_vector _corrections;
00237
00238         // attributes
00239         std::string _name;
00240         bool _name_set;
00241
00242         ms_quant_satellite *_pSatellite;
00243         bool _satellite_set;
00244     }; // class ms_quant_component
00245  // end of config_group
00247
00248 } // namespace matrix_science
00249
00250 #endif // MS_QUANT_COMPONENT_HPP
00251
00252 /*------------------------------- End of File -------------------------------*/
00253
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_composition.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_composition.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "compositionType" from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_composition.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_COMPOSITION_HPP
00018 #define MS_QUANT_COMPOSITION_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_quant_element: public ms_xml_IValidatable
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042
00043     public:
00045         ms_quant_element();
00046
00048         ms_quant_element(const ms_quant_element& src);
00049
00051         virtual ~ms_quant_element();
00052
00054         void defaultValues();
00055
00057         void copyFrom(const ms_quant_element* right);
00058
00059 #ifndef SWIG
00060
00061         ms_quant_element& operator=(const ms_quant_element& right);
00062 #endif
00063
00065         virtual std::string getSchemaType() const;
00066
00068         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00069
00071         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00072
00073
00075         bool haveSymbol() const;
00076
00078         std::string getSymbol() const;
00079
00081         void setSymbol(const char* symbol);
00082
00084         void dropSymbol();
00085
00087         std::string getSymbolSchemaType() const;
00088
00089
00091         bool haveNumber() const;
00092
00094         int getNumber() const;
00095
00097         void setNumber(const int number);
00098
00100         void dropNumber();
00101
00103         std::string getNumberSchemaType() const;
00104
00105
00106     private:
00107         std::string _symbol;
00108         bool _symbol_set;
00109
00110         int _number;
00111         bool _number_set;
00112
00113     }; // class ms_quant_element
00114
00116
00119     class MS_MASCOTRESFILE_API ms_quant_composition: public ms_xml_IValidatable
00120     {
00121         friend class msparser_internal::ms_quant_xmlloader;
00122     public:
00124         ms_quant_composition();
00125
00127         ms_quant_composition(const ms_quant_composition& src);
00128
00130         virtual ~ms_quant_composition();
00131
00133         void defaultValues();
00134
00136         void copyFrom(const ms_quant_composition* right);
00137
00138 #ifndef SWIG
00139
00140         ms_quant_composition& operator=(const ms_quant_composition& right);
00141 #endif
00142
00143         virtual std::string getSchemaType() const;
00144
00146         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00147
00149         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00150
00151
00153         int getNumberOfElements() const;
00154
00156         void clearElements();
00157
00159         void appendElement(const ms_quant_element *element);
00160
00162         const ms_quant_element * getElement(const int idx) const;
00163
00165         bool updateElement(const int idx, const ms_quant_element* element);
00166
00168         bool deleteElement(const int idx);
00169
00171         std::string getElementSchemaType() const;
00172
00173     private:
00174         typedef std::vector< ms_quant_element* > element_vector;
00175         element_vector _elements;
00176
00177     }; // class ms_quant_composition
00178  // end of config_group
00180
00181 } // namespace matrix_science
00182
00183 #endif // MS_QUANT_COMPOSITION_HPP
00184
00185 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_configfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_configfile.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "quantitation.xml"-file that serves as quantitation       #
00006 # configuration file                                                         #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012  * @(#)$Source: parser/inc/ms_quant_configfile.hpp $
00013  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00014  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00015 ##############################################################################
00016  */
00017
00018 #ifndef MS_QUANT_CONFIGFILE_HPP
00019 #define MS_QUANT_CONFIGFILE_HPP
00020
00021
00022 #include <string>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027     class ms_quant_configfile_impl;
00028 }
00029
00030 namespace matrix_science {
00031
00032     class ms_connection_settings; // forward declaration
00033     class ms_quant_method; // forward declaration
00034
00040
00041
00051     class MS_MASCOTRESFILE_API ms_quant_configfile: public ms_errors
00052     {
00053         friend class msparser_internal::ms_quant_xmlloader;
00054     public:
00056         ms_quant_configfile();
00057
00059         ms_quant_configfile(const ms_quant_configfile& src);
00060
00062         ms_quant_configfile(const char* fileName, const char* schemaFileName,
00063                    const ms_connection_settings * cs = 0);
00064
00066         ~ms_quant_configfile();
00067
00069         void defaultValues();
00070
00072         void copyFrom(const ms_quant_configfile* right);
00073
00074 #ifndef SWIG
00075
00076         ms_quant_configfile& operator=(const ms_quant_configfile& right);
00077 #endif
00078
00079         void setFileName(const char* name);
00080
00082         std::string getFileName() const;
00083
00085         void setSchemaFileName(const char* name);
00086
00088         std::string getSchemaFileName() const;
00089
00091         void setSchemaDirectory(const char * dir);
00092
00094         std::string getSchemaDirectory() const;
00095
00097         void setConnectionSettings(const ms_connection_settings & cs);
00098
00100         ms_connection_settings getConnectionSettings() const;
00101
00103         void read_file();
00104
00106         void save_file();
00107
00109         void read_buffer(const char *buffer);
00110
00112         std::string save_buffer();
00113
00115         std::string validateDocument() const;
00116
00118         int getNumberOfMethods() const;
00119
00121         void clearMethods();
00122
00124         void appendMethod(const ms_quant_method *item);
00125
00127         const ms_quant_method * getMethodByNumber(const int idx) const;
00128
00130         const ms_quant_method * getMethodByName(const char *name) const;
00131
00133         bool updateMethodByNumber(const int idx, const ms_quant_method *mod);
00134
00136         bool updateMethodByName(const char *name, const ms_quant_method *mod);
00137
00139         bool deleteMethodByNumber(const int idx);
00140
00142         bool deleteMethodByName(const char *name);
00143
00145         std::string getMajorVersion() const;
00146
00148         std::string getMinorVersion() const;
00149
00150     private:
00151         msparser_internal::ms_quant_configfile_impl * m_pImpl;
00152     }; // class ms_quant_configfile
00153  // end of config_group
00155
00156 } // namespace matrix_science
00157
00158 #endif // MS_QUANT_CONFIGFILE_HPP
00159
00160 /*------------------------------- End of File -------------------------------*/
00161
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_correction.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_correction.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates \c correction element from "quantitation.xml"-file             #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_correction.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_CORRECTION_HPP
00018 #define MS_QUANT_CORRECTION_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_quant_correction: public ms_xml_IValidatable
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042
00043     public:
00045         ms_quant_correction();
00046
00048         ms_quant_correction(const ms_quant_correction& src);
00049
00051         virtual ~ms_quant_correction();
00052
00054         void defaultValues();
00055
00057         void copyFrom(const ms_quant_correction* right);
00058
00059 #ifndef SWIG
00060
00061         ms_quant_correction& operator=(const ms_quant_correction& right);
00062 #endif
00063
00065         virtual std::string getSchemaType() const;
00066
00068         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00069
00071         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00072
00073
00075         bool haveShift() const;
00076
00078         int getShift() const;
00079
00081         void setShift(const int value);
00082
00084         void dropShift();
00085
00087         std::string getShiftSchemaType() const;
00088
00089
00091         bool haveType() const;
00092
00094         std::string getType() const;
00095
00097         void setType(const char* value);
00098
00100         void dropType();
00101
00103         std::string getTypeSchemaType() const;
00104
00105
00107         bool haveElement() const;
00108
00110         std::string getElement() const;
00111
00113         void setElement(const char* value);
00114
00116         void dropElement();
00117
00119         std::string getElementSchemaType() const;
00120
00121
00123         std::string getContent() const;
00124
00126         void setContent(const char* value);
00127
00129         std::string getContentSchemaType() const;
00130
00131     private:
00132         int _shift;
00133         bool _shift_set;
00134
00135         std::string _type;
00136         bool _type_set;
00137
00138         std::string _element;
00139         bool _element_set;
00140
00141         std::string _content;
00142
00143     }; // class ms_quant_correction
00144  // end of config_group
00146
00147 } // namespace matrix_science
00148
00149 #endif // MS_QUANT_CORRECTION_HPP
00150
00151 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_extractors.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_extractors.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Reporter and Multiplex MS/MS component intensity extractors                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author$ #
00012 #       $Date$ #
00013 #   $Revision$ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_QUANT_EXTRACTORS_HPP
00019 #define MS_QUANT_EXTRACTORS_HPP
00020
00021 #include <string>
00022 #include <vector>
00023 #include <utility>
00024
00025 #include "boost/format.hpp"
00026 #include "ms_matrix.hpp"
00027
00028 // Include "ms_quant_mod_parsing.hpp" and "ms_fragment.hpp" to use this header
00029
00030 namespace matrix_science {
00031     class ms_errors;
00032     class ms_quant_method;
00033     class ms_mascotresfile;
00034     class ms_inputquery;
00035     class ms_peptide;
00036     class ms_aahelper;
00037     class ms_quant_multiplex;
00038     class ms_fragment;
00039     class ms_umod_composition;
00040 }
00041
00042 namespace msparser_internal {
00043     using namespace matrix_science;
00044
00045     // There isn't much common code between the classes except error
00046     // handling and two method interfaces.
00047     class ms_quant_extractor
00048     {
00049         public:
00050             virtual ~ms_quant_extractor();
00051
00053             bool isValid() const { return !hasInitialisationError_; }
00054
00056             std::string getLastErrorString() const { return initialisationErrorString_; }
00057
00058             virtual unsigned int collectIntensities(ms_inputquery &query, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const = 0;
00059
00060         protected:
00061             ms_quant_extractor(): hasInitialisationError_(false), initialisationErrorString_("") { }
00062
00063             void setInitialisationError(const std::string &errstr) {
00064                 hasInitialisationError_ = true;
00065                 initialisationErrorString_ = errstr;
00066             }
00067
00068             void setInitialisationError(const boost::format &fmt);
00069
00070         private:
00071             ms_quant_extractor(const ms_quant_extractor &);
00072             ms_quant_extractor& operator=(const ms_quant_extractor &);
00073
00074             bool hasInitialisationError_;
00075             std::string initialisationErrorString_;
00076     };
00077
00078     typedef matrix_science::ms_matrix::column_vector_t column_vector_t;
00079     typedef matrix_science::ms_matrix::matrix_t matrix_t;
00080
00081     typedef std::pair<double, double> peak_t;
00082
00083     class ms_quant_reporter_extractor: public ms_quant_extractor
00084     {
00085         public:
00086             enum REPORTER_COLLECTION_STATE {
00087                 REPORTER_COLLECTION_SUCCEEDED   = 0x0000,
00088
00089                 REPORTER_COLLECTION_UNAVAILABLE = 0xf000
00090             };
00091
00093             ms_quant_reporter_extractor(const ms_mascotresfile &resfile, const ms_quant_method &qm);
00094
00096             virtual ~ms_quant_reporter_extractor();
00097
00099             virtual unsigned int collectIntensities(ms_inputquery &query, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const;
00100
00101         private:
00103             unsigned int collectIntensities(const std::vector<peak_t> &spectrum, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const;
00104
00105             // No copying.
00106             ms_quant_reporter_extractor(const ms_quant_reporter_extractor&);
00107             ms_quant_reporter_extractor& operator=(const ms_quant_reporter_extractor&);
00108
00109             bool populateCorrectionMatrix(const ms_quant_method &qm);
00110
00111             const int numComponents_;
00112             const unsigned int numComponentElts_;
00113             matrix_t *matA_;
00114             std::vector<unsigned int> *permutationVector_;
00115             std::vector<double> componentMz_;
00116             double mzTolerance_;
00117             double mzWindowMin_;
00118             double mzWindowMax_;
00119     };
00120
00121     class ms_quant_multiplex_extractor: public ms_quant_extractor
00122     {
00123         public:
00124             enum MULTIPLEX_COLLECTION_STATE {
00125                 MULTIPLEX_COLLECTION_SUCCEEDED        = 0x0000,
00126
00127                 MULTIPLEX_MATCHES_NO_COMPONENTS       = 0x0001,
00128                 MULTIPLEX_MATCHES_MULTIPLE_COMPONENTS = 0x0002,
00129
00130                 MULTIPLEX_NOT_ENOUGH_ION_PAIRS        = 0x0010,
00131
00132                 // MULTIPLEX_HAS_INTERNAL_MODIFICATION_SITE
00133
00134                 MULTIPLEX_COLLECTION_UNAVAILABLE      = 0xf000
00135             };
00136
00138             ms_quant_multiplex_extractor(const ms_mascotresfile &resfile, const ms_quant_method &qm);
00139
00140             virtual ~ms_quant_multiplex_extractor();
00141
00143             virtual unsigned int collectIntensities(ms_inputquery &query, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, std::string *reason = 0) const;
00144
00145         private:
00147             unsigned int collectIntensities(const std::vector<peak_t> &spectrum, const ms_peptide &peptide, std::vector<double> &intensities, std::vector<double> &rawIntensities, const std::string *queryRules = 0, double minInternalMass = -1, double maxInternalMass = -1, std::string *reason = 0) const;
00148
00149             // No copying.
00150             ms_quant_multiplex_extractor(const ms_quant_multiplex_extractor&);
00151             ms_quant_multiplex_extractor& operator=(const ms_quant_multiplex_extractor&);
00152
00153             const int numComponents_;
00154             const unsigned int numComponentElts_;
00155             double C13MassDiff_;
00156             const double defaultMinInternalMass_;
00157             const double defaultMaxInternalMass_;
00158             double ionTolerance_;
00159             MASS_TYPE massType_;
00160             double ionIntensityThreshold_;
00161             bool isExcludeIsobaricFragments_;
00162             int minIonPairs_;
00163
00164             static const int NUM_RULES;
00165             std::vector<bool> defaultRules_; // of size NUM_RULES
00166
00167             typedef struct { int index; char terminus; } supported_series_t;
00168             static const supported_series_t supported_series[];
00169
00170             // Ion series used in our quantitation method.
00171             std::set<const supported_series_t *> protocolIonSeries_;
00172
00173             bool determineProtocolIonSeries(const ms_quant_multiplex *multiplex);
00174             void initialiseC13massDiff(const ms_umod_configfile &umodfile);
00175
00176             const bool useAveragineCorrection_;
00177
00178             bool useImpurityCorrection_;
00179             double impurityLightCorrection_;
00180             double impurityHeavyCorrection_;
00181             std::string impurityHeavySymbol_;
00182             // int is large enough, as we don't expect the integer mass
00183             // difference to be bigger than a few Da.
00184             int impurityLightHeavyMassDiff_;
00185
00186             // Scratch variables for intensity correction
00187             matrix_t *matA_;
00188             matrix_t *matIN_;
00189             matrix_t *matIC_;
00190             matrix_t *matJ_;
00191             std::vector<unsigned int> *matIN_permutation_;
00192             std::vector<unsigned int> *matIC_permutation_;
00193             std::vector<unsigned int> *matA_permutation_;
00194
00195             bool determineImpurityCorrectionElements(const ms_quant_method &qm, const ms_umod_configfile &umodfile);
00196
00197             typedef std::pair<int, double> isotope_correction_def_t;
00198             typedef std::vector<isotope_correction_def_t> isotope_correction_defs_t;
00199
00200             typedef struct {
00201                 std::string title;
00202                 modification_sites_t modification_sites;
00203                 char varmod_char; // 0..9,A..W
00204                 char nl_char;     // nonnegative integer
00205
00206                 // Impurity correction (optional)
00207                 isotope_correction_defs_t isotope_corrections;
00208
00209                 // Delta is only needed in averagine and impurity corrections
00210                 int int_delta;
00211             } component_modification_t;
00212
00213             typedef std::vector<component_modification_t> component_modifications_t;
00214
00215             // Multiplex modifications in our quantitation method. Each
00216             // component has at least one modification, and each modification
00217             // has at least one site.
00218             std::vector<component_modifications_t> componentModifications_;
00219
00220             // Reverse mapping of the above by integer delta.
00221             static const unsigned int DELTA_NTERM = 0;
00222             static const unsigned int DELTA_CTERM = 1;
00223             typedef std::vector<int> component_to_delta_t;
00224             std::vector<component_to_delta_t> componentTerminusDelta_;
00225
00226             // Initialiser for the two data structures above:
00227             bool determineProtocolModificationSites(const ms_quant_method &qm, const ms_umod_configfile &umodfile, ms_searchparams &params);
00228             bool findComponentModifications(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile, const varmod_title_map_t &varmod_title_map, ms_searchparams &params, component_modifications_t &found_mods);
00229             char chooseNeutralLossIndex(ms_searchparams &params, char varmod_char);
00230             std::vector<isotope_correction_def_t> calculateIsotopeCorrections(const ms_umod_composition *comp) const;
00231             bool isComponentModificationOK(component_modification_t &compmod);
00232
00233             ms_aahelper *aahelper_;
00234
00235             bool initialiseAAhelper(const ms_umod_configfile &umodfile, ms_searchparams &params);
00236
00237             void ignoreMultiplexSeries(std::vector<bool> &rules) const;
00238             int countMatchingComponents(const ms_peptide &peptide) const;
00239             std::vector<ms_peptide> conformPeptideToComponents(const ms_peptide &peptide) const;
00240             void calculateFragments(int ruleID, const ms_peptide &conformingPeptide, double minMass, double maxMass, int max_fragment_charge, std::vector<ms_fragment> &fragments) const;
00241
00242             struct fragment_t {
00243                 unsigned int component;
00244                 int charge;
00245                 double mz;
00246                 double intensity;
00247                 std::string label;
00248                 bool isNterm;
00249                 bool isCterm;
00250
00251                 explicit fragment_t(double m);
00252                 fragment_t(unsigned int component_idx, const ms_fragment &frag);
00253                 bool operator<(const fragment_t &right) const;
00254             };
00255             typedef std::vector<fragment_t> fragments_t;
00256
00257             fragments_t calculateFragmentIons(const std::vector<ms_peptide> &conformingPeptides, int max_fragment_charge) const;
00258             void assignExperimentalIntensities(fragments_t &multiplexIons, const std::vector<peak_t> &spectrum) const;
00259
00260             void eliminateIsobaricOverlap(fragments_t &multiplexIons, const std::vector<ms_peptide> &conformingPeptides, double minInternalMass, double maxInternalMass, int max_fragment_charge, const std::vector<bool> &rules) const;
00261             void eliminateInternalCollisions(fragments_t &multiplexIons) const;
00262
00263             void initialiseAveragineCorrectionMatrix(matrix_t *matJ, int charge, double mz, const component_to_delta_t &componentToDelta) const;
00264             void initialiseImpurityCorrectionMatrices(matrix_t *matIN, matrix_t *matIC, const ms_peptide &peptide) const;
00265
00266             void correctTheseIntensities(std::vector<double> &ints, int charge, double mz, const component_to_delta_t &componentToDelta, matrix_t *matA, matrix_t *matI, matrix_t *matJ, std::vector<unsigned int> *matI_permutation) const;
00267
00268             // A fragment set is a vector of size numComponents_ of fragment
00269             // ion intensities, grouped by fragment ion label. We don't need
00270             // the label or the other attributes after the initial processing.
00271             typedef std::set< std::vector<double> > fragment_sets_t;
00272             void collectCompletePeakSets(const fragments_t &multiplexIons, const ms_peptide &peptide, fragment_sets_t &peakSets, fragment_sets_t &rawPeakSets) const;
00273
00274             int accumulateComponentIntensities(const fragment_sets_t &peakSets, std::vector<double> &intensities) const;
00275
00276             static std::vector<bool> split_rule_string(const std::string &str);
00277             static void _dump_fragments(const fragments_t &multiplexIons, bool printIntensity);
00278             static void _dump_peaksets(unsigned int numComponentElts, const std::string &fragment_label, const std::vector<fragment_t> &fragments, const std::vector<double> &ints, bool corrected);
00279     };
00280 }   // msparser_internal namespace
00281 #endif // MS_QUANT_EXTRACTORS_HPP
00282
00283 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_helper.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_helper.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Helper routines for peptide and protein quantitation                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: patricke@matrixscience.com $ #
00012 #       $Date: 2021-03-02 14:20:52 +0000 $ #
00013 #   $Revision: ead0a29935c733285496344df275096149f36406 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_QUANT_HELPER_HPP
00019 #define MS_QUANT_HELPER_HPP
00020
00021
00022 #include <string>
00023 #include <vector>
00024 #include <list>
00025
00026 namespace msparser_internal {
00027     typedef std::pair<char, int> modification_site_t;
00028     typedef std::vector<modification_site_t> modification_sites_t;
00029     typedef std::map<std::string, char> varmod_title_map_t;
00030 }
00031
00032 namespace matrix_science {
00033     class ms_quant_method;
00034     class ms_quant_localdef;
00035     class ms_quant_unmodified;
00036     class ms_peptide;
00037     class ms_peptidesummary;
00038     class ms_protein;
00039     class ms_ms1quant_match;
00040
00046
00047
00049     class MS_MASCOTRESFILE_API ms_quant_helper: public ms_errors
00050     {
00051         public:
00053             enum PEPTIDE_QUANTIFIABILITY {
00054                 PEPTIDE_IS_QUANTIFIABLE             = 0x0000,
00055                 PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD    = 0x0001,
00056                 PEPTIDE_HAS_NO_REQUIRED_VARMOD      = 0x0002,
00057                 PEPTIDE_HAS_EXCLUDED_FIXEDMOD       = 0x0010,
00058                 PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD = 0x0011,
00059                 PEPTIDE_HAS_EXCLUDED_VARMOD         = 0x0012,
00060                 PEPTIDE_HAS_UNMODIFIED_SITE         = 0x0013,
00061                 PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD   = 0x0014,
00062                 PEPTIDE_HAS_NO_EXCLUSIVE_MODS       = 0x0015,
00063
00064                 PEPTIDE_QUANTIFIABILITY_UNAVAILABLE = 0xf000
00065             };
00066
00068             enum PEPTIDE_QUALITY {
00069                 PEPTIDE_QUALITY_IS_OK                  = 0x0000,
00070                 PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN     = 0x0001,
00071                 PEPTIDE_SCORE_BELOW_SCORE_THR          = 0x0002,
00072                 PEPTIDE_EXPECT_ABOVE_THRESHOLD         = 0x0003,
00073                 PEPTIDE_SCORE_BELOW_IDENTITY_THR       = 0x0004,
00074                 PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM = 0x0005,
00075                 PEPTIDE_SCORE_BELOW_HOMOLOGY_THR       = 0x0006,
00076                 PEPTIDE_NOT_UNIQUE                     = 0x0007,
00077
00078                 PEPTIDE_QUALITY_UNAVAILABLE            = 0xf000
00079             };
00080
00082             ms_quant_helper(const ms_peptidesummary &pepsum, const ms_quant_method &qm, const ms_umod_configfile &umodfile);
00083
00085             ~ms_quant_helper();
00086
00087             const ms_peptidesummary & getSummary() const;
00088             const ms_quant_method & getMethod() const;
00089 #ifndef SWIG
00090
00091             int isPeptideQuantifiable(int q, int p, const ms_protein *protein, int peptideIndex, std::string & reasonStrRef) const;
00092
00094             int isPeptideQualityOK(int q, int p, std::string & reasonStrRef) const;
00095 #else // SWIG Multiple return values
00096             int isPeptideQuantifiable(int q, int p, const ms_protein *protein, int peptideIndex, std::string & OUTPUT) const;
00097             int isPeptideQualityOK(int q, int p, std::string & OUTPUT) const;
00098 #endif
00099
00100             int testProteinTerminusExclusion(int q, int p, const ms_protein *, int peptideIndex, std::string & reason) const;
00101
00103             int createMissingComponents(matrix_science::ms_ms1quant_match * match) const;
00104
00105             matrix_science::ms_ms1quant_peptide_status::peptideStatus group_peptide(
00106                     const matrix_science::ms_protein & hit,
00107                     int iPeptide,
00108                     matrix_science::ms_peptide *& peptide,
00109                     matrix_science::ms_quant_component & component,
00110                     matrix_science::ms_quant_helper::PEPTIDE_QUANTIFIABILITY * quantifiabilityStatus = 0,
00111                     matrix_science::ms_quant_helper::PEPTIDE_QUALITY * qualityStatus = 0,
00112                     matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS * componentStatus = 0,
00113                     std::string * reason = 0 ) const;
00114
00115             matrix_science::ms_ms1quant_peptide_status::peptideStatus group_peptide(
00116                     const matrix_science::ms_peptide & peptide,
00117                     matrix_science::ms_quant_component & component,
00118                     matrix_science::ms_quant_helper::PEPTIDE_QUANTIFIABILITY * quantifiabilityStatus = 0,
00119                     matrix_science::ms_quant_helper::PEPTIDE_QUALITY * qualityStatus = 0,
00120                     matrix_science::ms_mascotresults::QUANT_COMPONENT_STATUS * componentStatus = 0,
00121                     std::string * reason = 0,
00122                     const matrix_science::ms_protein * hit = 0,
00123                     int iPeptide = 0
00124                      ) const;
00125
00126         private:
00127             // No copying.
00128             ms_quant_helper(const ms_quant_helper& src);
00129             ms_quant_helper& operator=(const ms_quant_helper& right);
00130
00131             void applyComponentMods(
00132                     std::string * newVarMods,
00133                     std::string * newSummedMods,
00134                     const matrix_science::ms_quant_component & targetComponent,
00135                     const std::string & pepStr,
00136                     const std::string & labelFreeVarMods,
00137                     bool isProteinNterm,
00138                     bool isProteinCterm
00139                     ) const;
00140
00141             void applyComponentMods(
00142                 std::string * newVarMods,
00143                 std::string * newSummedMods,
00144                 const matrix_science::ms_quant_component & targetComponent,
00145                 const matrix_science::ms_quant_component & sourceComponent,
00146                 const std::string & pepStr,
00147                 const std::string & labelFreeVarMods,
00148                 const std::string & sourceVarMods,
00149                 const std::string & sourceSummedMods,
00150                 bool isProteinNterm,
00151                 bool isProteinCterm
00152             ) const;
00153
00154             char ModLetter(const std::string & modName) const;
00155
00156             const ms_peptidesummary &pepsum_;
00157             const ms_quant_method &method_;
00158             const ms_umod_configfile & umodfile_;
00159
00160             std::map<char, std::string> varModTitles_;
00161             std::map<char, std::string> fixedModTitles_;
00162
00163             bool haveRequiredMods_;
00164             std::string sortedRequiredFixedMods_;
00165             std::string sortedRequiredVarMods_;
00166
00167             bool haveExclusions_;
00168             bool haveProteinTerminusTest_;
00169
00170             bool initRequiredMods(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile, const msparser_internal::varmod_title_map_t &varmod_title_map, std::set<char> &requiredFixedMods, std::set<char> &requiredVarMods);
00171             bool initFixedExclusion(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile);
00172
00173             int testRequiredMods(const std::string &peptide_str, const std::string &varmods_str, std::string & reason) const;
00174
00175             int testFixedExclusions(const std::string &peptide_str, const std::string &varmods_str, const ms_protein *protein, int peptideIndex, std::string & reason) const;
00176             int testVariableExclusions(const std::string &peptide_str, const std::string &varmods_str, const ms_protein *protein, int peptideIndex, std::string & reason) const;
00177
00178             bool requireUniquePeptide_;
00179             int minPrecursorCharge_;
00180             double ionsScoreThreshold_;
00181             double expectationValueThreshold_;
00182             bool mustPassIdentityThreshold_;
00183             bool mustPassHomologyThreshold_;
00184             bool isAverageProtocol_;
00185
00186 //Warning 325: Nested struct not currently supported
00187 #ifndef SWIG
00188             typedef struct {
00189                 int why;
00190                 std::string fmt;
00191                 msparser_internal::modification_sites_t modsites;
00192             } fixed_exclusion_t;
00193
00194             typedef struct {
00195                 int why;
00196                 std::string fmt;
00197                 char varmod_id;
00198                 msparser_internal::modification_sites_t modsites;
00199             } variable_exclusion_t;
00200
00201             std::list<fixed_exclusion_t> fixedExclusions_;
00202             std::list<variable_exclusion_t> variableExclusions_;
00203
00204             std::list< std::list<variable_exclusion_t> > qualityExclusions_;
00205
00206             bool initVariableExclusion(const ms_quant_modgroup *modgroup, const ms_umod_configfile &umodfile, const msparser_internal::varmod_title_map_t &varmod_title_map, std::list<variable_exclusion_t> &variableExclusions);
00207 #endif
00208
00209             bool peptideFitsExclusiveGroup(const std::string &peptide_str, const std::string &varmods_str) const;
00210             bool peptideFitsExclusiveGroupMods(const std::string &peptide_str, const std::string &varmods_str, const std::list<variable_exclusion_t> &qualityExclusions) const;
00211
00212             static bool mod_can_be_fixed(char site, int position);
00213             static bool excluded_due_to_fixed_mod(const std::string &peptide_str, char site, int position);
00214             static bool excluded_due_to_variable_mod(const std::string &peptide_str, const std::string &varmods_str, char site, int position, char varmod_id, const ms_protein *protein, int peptideIndex);
00215
00216     }; // end of quantitation_group
00218 }   // matrix_science namespace
00219
00220 #endif // MS_QUANT_HELPER_HPP
00221
00222 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_integration.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_integration.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates integration-element from "quantitation.xml"-file              #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_integration.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_INTEGRATION_HPP
00018 #define MS_QUANT_INTEGRATION_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027     class ms_quant_integration_impl;
00028 }
00029
00030
00031 namespace matrix_science {
00032
00033     class ms_xml_schema; // forward declaration
00034
00040
00041
00045     class MS_MASCOTRESFILE_API ms_quant_integration: public ms_quant_parameters
00046     {
00047         friend class msparser_internal::ms_quant_xmlloader;
00048     public:
00050         ms_quant_integration();
00051
00053         ms_quant_integration(const ms_quant_integration& src);
00054
00056         virtual ~ms_quant_integration();
00057
00059         void defaultValues();
00060
00062         void copyFrom(const ms_quant_integration* right);
00063
00064 #ifndef SWIG
00065
00066         ms_quant_integration& operator=(const ms_quant_integration& right);
00067 #endif
00068
00069         virtual std::string getSchemaType() const;
00070
00072         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00073
00075         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00076
00077
00079         bool haveMethod() const;
00080
00082         std::string getMethod() const;
00083
00085         void setMethod(const char* value);
00086
00088         void dropMethod();
00089
00091         std::string getMethodSchemaType() const;
00092
00093
00095         bool haveSource() const;
00096
00098         std::string getSource() const;
00099
00101         void setSource(const char* value);
00102
00104         void dropSource();
00105
00107         std::string getSourceSchemaType() const;
00108
00109
00111         bool haveMassDelta() const;
00112
00114         std::string getMassDelta() const;
00115
00117         void setMassDelta(const char* value);
00118
00120         void dropMassDelta();
00121
00123         std::string getMassDeltaSchemaType() const;
00124
00125
00127         bool haveMassDeltaUnit() const;
00128
00130         std::string getMassDeltaUnit() const;
00131
00133         void setMassDeltaUnit(const char* value);
00134
00136         void dropMassDeltaUnit();
00137
00139         std::string getMassDeltaUnitSchemaType() const;
00140
00141
00143         bool haveElutionTimeDelta() const;
00144
00146         std::string getElutionTimeDelta() const;
00147
00149         void setElutionTimeDelta(const char* value);
00150
00152         void dropElutionTimeDelta();
00153
00155         std::string getElutionTimeDeltaSchemaType() const;
00156
00157
00159         bool haveElutionTimeDeltaUnit() const;
00160
00162         std::string getElutionTimeDeltaUnit() const;
00163
00165         void setElutionTimeDeltaUnit(const char* value);
00166
00168         void dropElutionTimeDeltaUnit();
00169
00171         std::string getElutionTimeDeltaUnitSchemaType() const;
00172
00173
00175         bool haveElutionProfileCorrelationThreshold() const;
00176
00178         std::string getElutionProfileCorrelationThreshold() const;
00179
00181         void setElutionProfileCorrelationThreshold(const char* value);
00182
00184         void dropElutionProfileCorrelationThreshold();
00185
00187         std::string getElutionProfileCorrelationThresholdSchemaType() const;
00188
00189
00191         bool haveProcessingOptions() const;
00192
00194         std::string getProcessingOptions() const;
00195
00197         void setProcessingOptions(const std::string value);
00198
00200         void dropProcessingOptions();
00201
00203         std::string getProcessingOptionsSchemaType() const;
00204
00205
00207         bool havePrecursorRange() const;
00208
00210         std::string getPrecursorRange() const;
00211
00213         void setPrecursorRange(const char* value);
00214
00216         void dropPrecursorRange();
00217
00219         std::string getPrecursorRangeSchemaType() const;
00220
00221
00223         bool haveMatchedRho() const;
00224
00226         std::string getMatchedRho() const;
00227
00229         void setMatchedRho(const char * value);
00230
00232         void dropMatchedRho();
00233
00235         std::string getMatchedRhoSchemaType() const;
00236
00237
00239         bool haveXicThreshold() const;
00240
00242         std::string getXicThreshold() const;
00243
00245         void setXicThreshold(const char * value);
00246
00248         void dropXicThreshold();
00249
00251         std::string getXicThresholdSchemaType() const;
00252
00253
00255         bool haveXicMaxWidth() const;
00256
00258         int getXicMaxWidth() const;
00259
00261         void setXicMaxWidth(int value);
00262
00264         void dropXicMaxWidth();
00265
00267         std::string getXicMaxWidthSchemaType() const;
00268
00269
00271         bool haveXicSmoothing() const;
00272
00274         int getXicSmoothing() const;
00275
00277         void setXicSmoothing(int value);
00278
00280         void dropXicSmoothing();
00281
00283         std::string getXicSmoothingSchemaType() const;
00284
00285
00287         bool haveAllChargeStates() const;
00288
00290         bool isAllChargeStates() const;
00291
00293         void setAllChargeStates(const bool value);
00294
00296         void dropAllChargeStates();
00297
00299         std::string getAllChargeStatesSchemaType() const;
00300
00301
00303         bool haveSimpleRatio() const;
00304
00306         bool isSimpleRatio() const;
00307
00309         void setSimpleRatio(const bool value);
00310
00312         void dropSimpleRatio();
00313
00315         std::string getSimpleRatioSchemaType() const;
00316
00317
00319         bool haveAllChargeStatesThreshold() const;
00320
00322         std::string getAllChargeStatesThreshold() const;
00323
00325         void setAllChargeStatesThreshold(const char * value);
00326
00328         void dropAllChargeStatesThreshold();
00329
00331         std::string getAllChargeStatesThresholdSchemaType() const;
00332
00333
00335         bool haveAllowElutionShift() const;
00336
00338         bool isAllowElutionShift() const;
00339
00341         void setAllowElutionShift(const bool value);
00342
00344         void dropAllowElutionShift();
00345
00347         std::string getAllowElutionShiftSchemaType() const;
00348
00349     private:
00350         msparser_internal::ms_quant_integration_impl *m_pImpl;
00351     }; // class ms_quant_integration
00352  // end of config_group
00354
00355 } // namespace matrix_science
00356
00357 #endif // MS_QUANT_INTEGRATION_HPP
00358
00359 /*------------------------------- End of File -------------------------------*/
00360
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_isotope.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_isotope.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates \c isotope element from "quantitation.xml"-file             #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_isotope.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_ISOTOPE_HPP
00018 #define MS_QUANT_ISOTOPE_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_quant_isotope: public ms_xml_IValidatable
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042
00043     public:
00045         ms_quant_isotope();
00046
00048         ms_quant_isotope(const ms_quant_isotope& src);
00049
00051         virtual ~ms_quant_isotope();
00052
00054         void defaultValues();
00055
00057         void copyFrom(const ms_quant_isotope* right);
00058
00059 #ifndef SWIG
00060
00061         ms_quant_isotope& operator=(const ms_quant_isotope& right);
00062 #endif
00063
00065         virtual std::string getSchemaType() const;
00066
00068         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00069
00071         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00072
00073
00075         bool haveOld() const;
00076
00078         std::string getOld() const;
00079
00081         void setOld(const char* value);
00082
00084         void dropOld();
00085
00087         std::string getOldSchemaType() const;
00088
00089
00091         bool haveNew() const;
00092
00094         std::string getNew() const;
00095
00097         void setNew(const char* value);
00098
00100         void dropNew();
00101
00103         std::string getNewSchemaType() const;
00104
00105     private:
00106
00107         std::string _old;
00108         bool _old_set;
00109
00110         std::string _new;
00111         bool _new_set;
00112
00113     }; // class ms_quant_isotope
00114  // end of config_group
00116
00117 } // namespace matrix_science
00118
00119 #endif // MS_QUANT_ISOTOPE_HPP
00120
00121 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_localdef.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_localdef.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates \c local_definition element from "quantitation.xml"-file       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_localdef.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_LOCALDEF_HPP
00018 #define MS_QUANT_LOCALDEF_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_specificity; // forward declaration
00032     class ms_quant_composition; // forward declaration
00033     class ms_xml_schema; // forward declaration
00034
00040
00041     class MS_MASCOTRESFILE_API ms_quant_localdef: public ms_xml_IValidatable
00042     {
00043         friend class msparser_internal::ms_quant_xmlloader;
00044
00045     public:
00047         ms_quant_localdef();
00048
00050         ms_quant_localdef(const ms_quant_localdef& src);
00051
00053         virtual ~ms_quant_localdef();
00054
00056         void defaultValues();
00057
00059         void copyFrom(const ms_quant_localdef* right);
00060
00061 #ifndef SWIG
00062
00063         ms_quant_localdef& operator=(const ms_quant_localdef& right);
00064 #endif
00065
00066         virtual std::string getSchemaType() const;
00067
00069         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00070
00072         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00073
00074
00076         int getNumberOfSpecificities() const;
00077
00079         void clearSpecificities();
00080
00082         void appendSpecificity(const ms_quant_specificity *specificity);
00083
00085         const ms_quant_specificity * getSpecificity(const int idx) const;
00086
00088         bool updateSpecificity(const int idx, const ms_quant_specificity* specificity);
00089
00091         bool deleteSpecificity(const int idx);
00092
00094         std::string getSpecificitySchemaType() const;
00095
00096
00098         bool haveDelta() const;
00099
00101         const ms_quant_composition* getDelta() const;
00102
00104         void setDelta(const ms_quant_composition *delta);
00105
00107         void dropDelta();
00108
00110         std::string getDeltaSchemaType() const;
00111
00112
00114         int getNumberOfIgnores() const;
00115
00117         void clearIgnores();
00118
00120         void appendIgnore(const ms_quant_composition *ignore);
00121
00123         const ms_quant_composition * getIgnore(const int idx) const;
00124
00126         bool updateIgnore(const int idx, const ms_quant_composition* ignore);
00127
00129         bool deleteIgnore(const int idx);
00130
00132         std::string getIgnoreSchemaType() const;
00133
00134
00136         bool haveTitle() const;
00137
00139         std::string getTitle() const;
00140
00142         void setTitle(const char* value);
00143
00145         void dropTitle();
00146
00148         std::string getTitleSchemaType() const;
00149
00150
00151     private:
00152         // elements
00153         typedef std::vector< ms_quant_specificity* > specificity_vector;
00154         specificity_vector _specificities;
00155
00156         ms_quant_composition* _pDelta;
00157         bool _delta_set;
00158
00159         typedef std::vector< ms_quant_composition* > composition_vector;
00160         composition_vector _ignores;
00161
00162         // attributes
00163         std::string _title;
00164         bool _title_set;
00165
00166     }; // class ms_quant_localdef
00167  // end of config_group
00169
00170 } // namespace matrix_science
00171
00172 #endif // MS_QUANT_LOCALDEF_HPP
00173
00174 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_method.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_method.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates method-element from "quantitation.xml"-file                 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_method.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_METHOD_HPP
00018 #define MS_QUANT_METHOD_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027     class ms_quant_method_impl;
00028     class ms_quant_configfile_impl;
00029 }
00030
00031 namespace matrix_science {
00032
00033     class ms_quant_modgroup; // forward declaration
00034     class ms_quant_component; // forward declaration
00035     class ms_quant_quality; // forward declaration
00036     class ms_quant_integration; // forward delcaration
00037     class ms_quant_outliers; // forward declaration
00038     class ms_quant_normalisation; // forward declaration
00039     class ms_quant_protocol; // forward declaration
00040     class ms_quant_ratio; // forward declaration
00041     class ms_xml_schema; // forward declaration
00042     class ms_quant_localdef; // forward declaration
00043
00049
00050     class MS_MASCOTRESFILE_API ms_quant_method: public ms_xml_IValidatable
00051     {
00052         friend class msparser_internal::ms_quant_xmlloader;
00053         friend class msparser_internal::ms_quant_configfile_impl;
00054
00055     public:
00057
00063         enum METHOD_COMPATIBLE{
00064             COMPATIBLE,
00065             COMPATIBLE_DIFF_PROTOCOL,
00066             COMPATIBLE_DIFF_NUM_COMPONENTS,
00067             COMPATIBLE_MISSING_COMPONENT,
00068             COMPATIBLE_DIFF_NUM_MOD_GROUPS,
00069             COMPATIBLE_MISSING_MOD_GROUP,
00070             COMPATIBLE_DIFF_NUM_LOCAL_MODS,
00071             COMPATIBLE_DIFF_LOCAL_MOD,
00072             COMPATIBLE_DIFF_NUM_MODS,
00073             COMPATIBLE_MISSING_MOD,
00074             COMPATIBLE_MISSING_INTEGRATION,
00075             COMPATIBLE_MISSING_INTEGRATION_PARAM,
00076             COMPATIBLE_DIFF_INTEGRATION_PARAM,
00077             COMPATIBLE_DIFF_NUM_ISOTOPES
00078         };
00079
00081         ms_quant_method();
00082
00084         ms_quant_method(const ms_quant_method& src);
00085
00087         virtual ~ms_quant_method();
00088
00090         void defaultValues();
00091
00093         void copyFrom(const ms_quant_method* right);
00094
00095 #ifndef SWIG
00096
00097         ms_quant_method& operator=(const ms_quant_method& right);
00098 #endif
00099
00100         virtual std::string getSchemaType() const;
00101
00103         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00104
00106         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00107
00108
00110         int getNumberOfModificationGroups() const;
00111
00113         void clearModificationGroups();
00114
00116         void appendModificationGroup(const ms_quant_modgroup *item);
00117
00119         const ms_quant_modgroup * getModificationGroupByNumber(const int idx) const;
00120
00122         const ms_quant_modgroup * getModificationGroupByName(const char *name) const;
00123
00125         bool updateModificationGroupByNumber(const int idx, const ms_quant_modgroup* modgroup);
00126
00128         bool updateModificationGroupByName(const char *name, const ms_quant_modgroup* modgroup);
00129
00131         bool deleteModificationGroupByNumber(const int idx);
00132
00134         bool deleteModificationGroupByName(const char *name);
00135
00137         std::string getModificationGroupSchemaType() const;
00138
00140         void getLocalModifications(std::vector<const ms_quant_localdef *> &localDefVector);
00141
00143         int getNumberOfComponents() const;
00144
00146         void clearComponents();
00147
00149         void appendComponent(const ms_quant_component *item);
00150
00152         const ms_quant_component * getComponentByNumber(const int idx) const;
00153
00155         const ms_quant_component * getComponentByName(const char *name) const;
00156
00158         bool updateComponentByNumber(const int idx, const ms_quant_component* comp);
00159
00161         bool updateComponentByName(const char *name, const ms_quant_component* comp);
00162
00164         bool deleteComponentByNumber(const int idx);
00165
00167         bool deleteComponentByName(const char *name);
00168
00170         std::string getComponentSchemaType() const;
00171
00172
00174         int getNumberOfReportRatios() const;
00175
00177         void clearReportRatios();
00178
00180         void appendReportRatio(const ms_quant_ratio *ratio);
00181
00183         const ms_quant_ratio * getReportRatioByNumber(const int idx) const;
00184
00186         const ms_quant_ratio * getReportRatioByName(const char *name) const;
00187
00189         bool updateReportRatioByNumber(const int idx, const ms_quant_ratio* ratio);
00190
00192         bool updateReportRatioByName(const char *name, const ms_quant_ratio* ratio);
00193
00195         bool deleteReportRatioByNumber(const int idx);
00196
00198         bool deleteReportRatioByName(const char *name);
00199
00201         std::string getReportRatioSchemaType() const;
00202
00203
00205         int getNumberOfExclusions() const;
00206
00208         void clearExclusions();
00209
00211         void appendExclusion(const char* exclusion);
00212
00214         std::string getExclusion(const int idx) const;
00215
00217         bool updateExclusion(const int idx, const char* exclusion);
00218
00220         bool deleteExclusion(const int idx);
00221
00223         std::string getExclusionSchemaType() const;
00224
00225
00227         int getNumberOfSeqs() const;
00228
00230         void clearSeqs();
00231
00233         void appendSeq(const char* seq);
00234
00236         std::string getSeq(const int idx) const;
00237
00239         bool updateSeq(const int idx, const char* seq);
00240
00242         bool deleteSeq(const int idx);
00243
00245         std::string getSeqSchemaType() const;
00246
00247
00249         bool haveComp() const;
00250
00252         std::string getComp() const;
00253
00255         void setComp(const char* value);
00256
00258         void dropComp();
00259
00261         std::string getCompSchemaType() const;
00262
00263
00265         bool haveQuality() const;
00266
00268         const ms_quant_quality* getQuality() const;
00269
00271         void setQuality(const ms_quant_quality* quality);
00272
00274         void dropQuality();
00275
00277         std::string getQualitySchemaType() const;
00278
00279
00281         bool haveIntegration() const;
00282
00284         const ms_quant_integration* getIntegration() const;
00285
00287         void setIntegration(const ms_quant_integration* integration);
00288
00290         void dropIntegration();
00291
00293         std::string getIntegrationSchemaType() const;
00294
00295
00297         bool haveOutliers() const;
00298
00300         const ms_quant_outliers* getOutliers() const;
00301
00303         void setOutliers(const ms_quant_outliers* outliers);
00304
00306         void dropOutliers();
00307
00309         std::string getOutliersSchemaType() const;
00310
00311
00313         bool haveNormalisation() const;
00314
00316         const ms_quant_normalisation* getNormalisation() const;
00317
00319         void setNormalisation(const ms_quant_normalisation* normalisation);
00320
00322         void dropNormalisation();
00323
00325         std::string getNormalisationSchemaType() const;
00326
00327
00329         bool haveProtocol() const;
00330
00332         const ms_quant_protocol* getProtocol() const;
00333
00335         void setProtocol(const ms_quant_protocol* protocol);
00336
00338         void dropProtocol();
00339
00341         std::string getProtocolSchemaType() const;
00342
00343
00345         bool haveName() const;
00346
00348         std::string getName() const;
00349
00351         void setName(const char* value);
00352
00354         void dropName();
00355
00357         std::string getNameSchemaType() const;
00358
00359
00361         bool haveDescription() const;
00362
00364         std::string getDescription() const;
00365
00367         void setDescription(const char* value);
00368
00370         void dropDescription();
00371
00373         std::string getDescriptionSchemaType() const;
00374
00375
00377         bool haveConstrainSearch() const;
00378
00380         bool isConstrainSearch() const;
00381
00383         void setConstrainSearch(const bool value);
00384
00386         void dropConstrainSearch();
00387
00389         std::string getConstrainSearchSchemaType() const;
00390
00391
00393         bool haveProteinRatioType() const;
00394
00396         std::string getProteinRatioType() const;
00397
00399         void setProteinRatioType(const char* value);
00400
00402         void dropProteinRatioType();
00403
00405         std::string getProteinRatioTypeSchemaType() const;
00406
00407
00409         bool haveReportDetail() const;
00410
00412         bool isReportDetail() const;
00413
00415         void setReportDetail(const bool value);
00416
00418         void dropReportDetail();
00419
00421         std::string getReportDetailSchemaType() const;
00422
00423
00425         bool haveMinNumPeptides() const;
00426
00428         int getMinNumPeptides() const;
00429
00431         void setMinNumPeptides(const int value);
00432
00434         void dropMinNumPeptides();
00435
00437         std::string getMinNumPeptidesSchemaType() const;
00438
00439
00441         bool haveProtScoreType() const;
00442
00444         std::string getProtScoreType() const;
00445
00447         void setProtScoreType(const char* value);
00448
00450         void dropProtScoreType();
00451
00453         std::string getProtScoreTypeSchemaType() const;
00454
00455
00457         bool haveSigThresholdValue() const;
00458
00460         std::string getSigThresholdValue() const;
00461
00463         void setSigThresholdValue(const char* value);
00464
00466         void dropSigThresholdValue();
00467
00469         std::string getSigThresholdValueSchemaType() const;
00470
00471
00473         bool haveShowSubSets() const;
00474
00476         std::string getShowSubSets() const;
00477
00479         void setShowSubSets(const char* value);
00480
00482         void dropShowSubSets();
00483
00485         std::string getShowSubSetsSchemaType() const;
00486
00487
00489         bool haveRequireBoldRed() const;
00490
00492         bool isRequireBoldRed() const;
00493
00495         void setRequireBoldRed(const bool value);
00496
00498         void dropRequireBoldRed();
00499
00501         std::string getRequireBoldRedSchemaType() const;
00502 #ifndef SWIG
00503
00504         int isMethodCompatible(const ms_quant_method &other, std::string & reasonStrRef) const;
00505 #else // SWIG Multiple return values
00506         int isMethodCompatible(const ms_quant_method &other, std::string & OUTPUT) const;
00507 #endif
00508     private:
00509         msparser_internal::ms_quant_method_impl * m_pImpl;
00510     }; // class ms_quant_method
00511  // end of config_group
00513
00514 } // namespace matrix_science
00515
00516 #endif // MS_QUANT_METHOD_HPP
00517
00518 /*------------------------------- End of File -------------------------------*/
00519
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_mod_parsing.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_mod_parsing.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Helper routines for parsing modification specificities                     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author$ #
00012 #       $Date$ #
00013 #   $Revision$ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_QUANT_MOD_PARSING_HPP
00019 #define MS_QUANT_MOD_PARSING_HPP
00020
00021 #include <string>
00022 #include <vector>
00023 #include <utility>
00024
00025 namespace matrix_science {
00026     class ms_quant_localdef;
00027     class ms_quant_unmodified;
00028 }
00029
00030 namespace msparser_internal {
00031     using namespace matrix_science;
00032
00033     typedef std::pair<char, int> modification_site_t;
00034     typedef std::vector<modification_site_t> modification_sites_t;
00035     typedef std::map<std::string, char> varmod_title_map_t;
00036
00037     // These are '0' and '1' so that we can use them with 'A'..'Z'.
00038     enum SITE_SPECIAL { SITE_NTERM = '0', SITE_CTERM = '1' };
00039
00040     enum MOD_POSITION {
00041         MOD_POSITION_ANYWHERE      = 0x0000,
00042
00043         MOD_POSITION_ANY_NTERM     = 0x0001,
00044         MOD_POSITION_PROTEIN_NTERM = 0x0002,
00045         MOD_POSITION_NTERM_MASK    = 0x000F,
00046
00047         MOD_POSITION_ANY_CTERM     = 0x0010,
00048         MOD_POSITION_PROTEIN_CTERM = 0x0020,
00049         MOD_POSITION_CTERM_MASK    = 0x00F0,
00050
00051         MOD_POSITION_PROTEIN_MASK  = 0x0022
00052     };
00053
00054     namespace ms_quant_mod_parsing {
00055         void addLocalDefinitions(const ms_quant_method &qm, ms_umod_configfile &umodfile);
00056
00057         bool parse_localdef_modification_sites(const ms_quant_localdef *def, modification_sites_t &modsites);
00058         bool parse_umod_modification_sites(const ms_umod_modification *def, modification_sites_t &modsites);
00059         bool parse_modfile_style_sites(const ms_modification &mod, modification_sites_t &modsites);
00060         bool parse_unmodified_sites(const ms_quant_unmodified *def, modification_sites_t &modsites);
00061
00062         bool parse_mod_site_str(std::string str, std::string &sites);
00063
00064         bool parse_mod_position_str(std::string str, int *position);
00065         std::string mod_position_to_str(int position);
00066
00067         varmod_title_map_t create_varmod_title_mapping(const ms_searchparams &params);
00068
00069         char varmod_int_to_char(int i);
00070         int varmod_char_to_int(char c);
00071     }
00072 } // msparser_internal namespace
00073
00074 #endif // MS_QUANT_MOD_PARSING_HPP
00075
00076 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_modgroup.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_modgroup.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates modification_group-element from "quantitation.xml"-file       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_modgroup.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_MODGROUP_HPP
00018 #define MS_QUANT_MODGROUP_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_unmodified; // forward declaration
00032     class ms_quant_localdef; // forward declaration
00033     class ms_xml_schema; // forward declaration
00034
00040
00041
00045     class MS_MASCOTRESFILE_API ms_quant_modgroup: public ms_xml_IValidatable
00046     {
00047         friend class msparser_internal::ms_quant_xmlloader;
00048
00049     public:
00051         ms_quant_modgroup();
00052
00054         ms_quant_modgroup(const ms_quant_modgroup& src);
00055
00057         virtual ~ms_quant_modgroup();
00058
00060         void defaultValues();
00061
00063         void copyFrom(const ms_quant_modgroup* right);
00064
00065 #ifndef SWIG
00066
00067         ms_quant_modgroup& operator=(const ms_quant_modgroup& right);
00068 #endif
00069
00070         virtual std::string getSchemaType() const;
00071
00073         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00074
00076         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00077
00078
00080         int getNumberOfModFiles() const;
00081
00083         void clearModFiles();
00084
00086         void appendModFile(const char* mod);
00087
00089         int findModFile(const char* mod) const;
00090
00092         std::string getModFile(const int idx) const;
00093
00095         bool deleteModFile(const int idx);
00096
00098         std::string getModFileSchemaType() const;
00099
00100
00102         int getNumberOfUnmodified() const;
00103
00105         void clearUnmodified();
00106
00108         void appendUnmodified(const ms_quant_unmodified* unmodified);
00109
00111         const ms_quant_unmodified* getUnmodified(const int idx) const;
00112
00114         bool updateUnmodified(const int idx, const ms_quant_unmodified* unmodified);
00115
00117         bool deleteUnmodified(const int idx);
00118
00120         std::string getUnmodifiedSchemaType() const;
00121
00122
00124         int getNumberOfLocalDefinitions() const;
00125
00127         void clearLocalDefinitions();
00128
00130         void appendLocalDefinition(const ms_quant_localdef* localdef);
00131
00133         const ms_quant_localdef* getLocalDefinition(const int idx) const;
00134
00136         bool updateLocalDefinition(const int idx, const ms_quant_localdef* localdef);
00137
00139         bool deleteLocalDefinition(const int idx);
00140
00142         std::string getLocalDefinitionSchemaType() const;
00143
00144
00146         bool haveName() const;
00147
00149         std::string getName() const;
00150
00152         void setName(const char* value);
00153
00155         void dropName();
00156
00158         std::string getNameSchemaType() const;
00159
00160
00162         bool haveMode() const;
00163
00165         std::string getMode() const;
00166
00168         void setMode(const char* value);
00169
00171         void dropMode();
00172
00174         std::string getModeSchemaType() const;
00175
00176
00178         bool haveRequired() const;
00179
00181         bool isRequired() const;
00182
00184         void setRequired(bool value);
00185
00187         void dropRequired();
00188
00190         std::string getRequiredSchemaType() const;
00191
00192     private:
00193
00194         typedef std::vector< std::string > modfile_vector;
00195         modfile_vector _modFiles;
00196
00197         typedef std::vector< ms_quant_unmodified* > unmodified_vector;
00198         unmodified_vector _unmodified;
00199
00200         typedef std::vector< ms_quant_localdef* > localdef_vector;
00201         localdef_vector _localdefs;
00202
00203         std::string _name;
00204         bool _name_set;
00205
00206         std::string _mode;
00207         bool _mode_set;
00208
00209         bool m_required;
00210         bool m_required_set;
00211
00212     }; // class ms_quant_modgroup
00213  // end of config_group
00215
00216 } // namespace matrix_science
00217
00218 #endif // MS_QUANT_MODGROUP_HPP
00219
00220 /*------------------------------- End of File -------------------------------*/
00221
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_moverz.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_moverz.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "moverz" element from "quantitation.xml"-file                 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_moverz.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_MOVERZ_HPP
00018 #define MS_QUANT_MOVERZ_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_quant_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029
00030     class ms_xml_schema; // forward declaration
00031
00037
00038     class MS_MASCOTRESFILE_API ms_quant_moverz: public ms_xml_IValidatable
00039     {
00040         friend class msparser_internal::ms_quant_xmlloader;
00041
00042     public:
00044         ms_quant_moverz();
00045
00047         ms_quant_moverz(const ms_quant_moverz& src);
00048
00050         virtual ~ms_quant_moverz();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_quant_moverz* right);
00057
00058 #ifndef SWIG
00059
00060         ms_quant_moverz& operator=(const ms_quant_moverz& right);
00061 #endif
00062
00064         virtual std::string getSchemaType() const;
00065
00067         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00068
00070         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00071
00072
00074         bool haveMonoisotopic() const;
00075
00077         std::string getMonoisotopic() const;
00078
00080         void setMonoisotopic(const char* value);
00081
00083         void dropMonoisotopic();
00084
00086         std::string getMonoisotopicSchemaType() const;
00087
00088
00090         bool haveAverage() const;
00091
00093         std::string getAverage() const;
00094
00096         void setAverage(const char* value);
00097
00099         void dropAverage();
00100
00102         std::string getAverageSchemaType() const;
00103
00104     private:
00105         std::string _monoisotopic;
00106         bool _monoisotopic_set;
00107
00108         std::string _average;
00109         bool _average_set;
00110
00111     }; // class ms_quant_moverz
00112  // end of config_group
00114
00115 } // namespace matrix_science
00116
00117 #endif // MS_QUANT_MOVERZ_HPP
00118
00119 /*------------------------------- End of File -------------------------------*/
00120
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_multiplex.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_multiplex.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates normalisation-element from "quantitation.xml"-file            #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_multiplex.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_MULTIPLEX_HPP
00018 #define MS_QUANT_MULTIPLEX_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029
00035
00036
00039     class MS_MASCOTRESFILE_API ms_quant_multiplex: public ms_quant_parameters
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042     public:
00044         ms_quant_multiplex();
00045
00047         ms_quant_multiplex(const ms_quant_multiplex& src);
00048
00050         virtual ~ms_quant_multiplex();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_quant_multiplex* right);
00057
00058 #ifndef SWIG
00059
00060         ms_quant_multiplex& operator=(const ms_quant_multiplex& right);
00061 #endif
00062
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00073         bool haveIonSeries() const;
00074
00076         void setIonSeries(const std::string ionSeries);
00077
00079         void dropIonSeries();
00080
00082         std::string getIonSeriesSchemaType() const;
00083
00085         int getNumberOfIonSeries() const;
00086
00088         void clearIonSeries();
00089
00091         void appendIonSeries(const std::string ionSeries);
00092
00094         const std::string getIonSeries(const int idx=0) const;
00095
00097         bool updateIonSeries(const int idx, const std::string ionSeries);
00098
00100         bool deleteIonSeries(const int idx);
00101
00103         bool haveExcludeInternalLabel() const;
00104
00106         bool isExcludeInternalLabel() const;
00107
00109         void setExcludeInternalLabel(const bool value);
00110
00112         void dropExcludeInternalLabel();
00113
00115         std::string getExcludeInternalLabelSchemaType() const;
00116
00117
00119         bool haveIonIntensityThreshold() const;
00120
00122         std::string getIonIntensityThreshold() const;
00123
00125         void setIonIntensityThreshold(const char* value);
00126
00128         void dropIonIntensityThreshold();
00129
00131         std::string getIonIntensityThresholdSchemaType() const;
00132
00133
00135         bool haveExcludeIsobaricFragments() const;
00136
00138         bool isExcludeIsobaricFragments() const;
00139
00141         void setExcludeIsobaricFragments(const bool value);
00142
00144         void dropExcludeIsobaricFragments();
00145
00147         std::string getExcludeIsobaricFragmentsSchemaType() const;
00148
00149
00151         bool haveMinIonPairs() const;
00152
00154         int getMinIonPairs() const;
00155
00157         void setMinIonPairs(const int value);
00158
00160         void dropMinIonPairs();
00161
00163         std::string getMinIonPairsSchemaType() const;
00164
00165     private:
00166
00167         typedef std::vector< std::string > string_vector;
00168         string_vector _ionSeries;
00169
00170         bool _excludeInternalLabel;
00171         bool _excludeInternalLabel_set;
00172
00173         std::string _ionIntensityThreshold;
00174         bool _ionIntensityThreshold_set;
00175
00176         bool _excludeIsobaricFragments;
00177         bool _excludeIsobaricFragments_set;
00178
00179         int _minIonPairs;
00180         bool _minIonPairs_set;
00181     }; // class ms_quant_multiplex
00182  // end of config_group
00184
00185 } // namespace matrix_science
00186
00187 #endif // MS_QUANT_MULTIPLEX_HPP
00188
00189 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_neutralloss.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_neutralloss.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "NeutralLoss" element from "quantitation.xml"-file            #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_neutralloss.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_NEUTRALLOSS_HPP
00018 #define MS_QUANT_NEUTRALLOSS_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029
00035
00036     class MS_MASCOTRESFILE_API ms_quant_neutralloss: public ms_quant_composition
00037     {
00038         friend class msparser_internal::ms_quant_xmlloader;
00039     public:
00041         ms_quant_neutralloss();
00042
00044         ms_quant_neutralloss(const ms_quant_neutralloss& src);
00045
00047         virtual ~ms_quant_neutralloss();
00048
00050         void defaultValues();
00051
00053         void copyFrom(const ms_quant_neutralloss* right);
00054
00055 #ifndef SWIG
00056
00057         ms_quant_neutralloss& operator=(const ms_quant_neutralloss& right);
00058 #endif
00059
00060         virtual std::string getSchemaType() const;
00061
00063         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00064
00066         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00067
00068
00070         bool haveFlag() const;
00071
00073         bool isFlag() const;
00074
00076         void setFlag(const bool flag);
00077
00079         void dropFlag();
00080
00082         std::string getFlagSchemaType() const;
00083
00084     private:
00085
00086         bool _flag;
00087         bool _flag_set;
00088
00089     }; // class ms_quant_neutralloss
00090  // end of config_group
00092
00093 } // namespace matrix_science
00094
00095 #endif // MS_QUANT_NEUTRALLOSS_HPP
00096
00097 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_normalisation.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_normalisation.hpp                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates normalisation-element from "quantitation.xml"-file            #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_normalisation.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_NORMALISATION_HPP
00018 #define MS_QUANT_NORMALISATION_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029     class ms_quant_normalisation_peptides; // forward declaration
00030     class ms_quant_normalisation_proteins; // forward declaration
00031
00037
00038
00041     class MS_MASCOTRESFILE_API ms_quant_normalisation: public ms_quant_parameters
00042     {
00043         friend class msparser_internal::ms_quant_xmlloader;
00044
00045     public:
00047         ms_quant_normalisation();
00048
00050         ms_quant_normalisation(const ms_quant_normalisation& src);
00051
00053         virtual ~ms_quant_normalisation();
00054
00056         void defaultValues();
00057
00059         void copyFrom(const ms_quant_normalisation* right);
00060
00061 #ifndef SWIG
00062
00063         ms_quant_normalisation& operator=(const ms_quant_normalisation& right);
00064 #endif
00065
00066         virtual std::string getSchemaType() const;
00067
00069         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00070
00072         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00073
00074
00076         bool haveMethod() const;
00077
00079         std::string getMethod() const;
00080
00082         void setMethod(const char* value);
00083
00085         void dropMethod();
00086
00088         std::string getMethodSchemaType() const;
00089
00090
00092         bool havePeptides() const;
00093
00095         const ms_quant_normalisation_peptides* getPeptides() const;
00096
00098         void setPeptides(const ms_quant_normalisation_peptides* peptides);
00099
00101         void dropPeptides();
00102
00104         std::string getPeptidesSchemaType() const;
00105
00106
00108         bool haveProteins() const;
00109
00111         const ms_quant_normalisation_proteins* getProteins() const;
00112
00114         void setProteins(const ms_quant_normalisation_proteins* proteins);
00115
00117         void dropProteins();
00118
00120         std::string getProteinsSchemaType() const;
00121
00122     private:
00123
00124         std::string _method;
00125         bool _method_set;
00126
00127         ms_quant_normalisation_peptides *_pPeptides;
00128         bool _peptides_set;
00129
00130         ms_quant_normalisation_proteins *_pProteins;
00131         bool _proteins_set;
00132     }; // class ms_quant_normalisation
00133  // end of config_group
00135
00136 } // namespace matrix_science
00137
00138 #endif // MS_QUANT_NORMALISATION_HPP
00139
00140 /*------------------------------- End of File -------------------------------*/
00141
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_normalisation_peptide.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_normalisation_peptide.hpp                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates peptide-element from "quantitation.xml"-file                  #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2009 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_normalisation_peptide.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_NORMALISATION_PEPTIDE_HPP
00018 #define MS_QUANT_NORMALISATION_PEPTIDE_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_modgroup; // forward declaration
00032     class ms_xml_schema; // forward declaration
00033
00039
00040
00043     class MS_MASCOTRESFILE_API ms_quant_normalisation_peptide: public ms_xml_IValidatable
00044     {
00045         friend class msparser_internal::ms_quant_xmlloader;
00046
00047     public:
00049         ms_quant_normalisation_peptide();
00050
00052         ms_quant_normalisation_peptide(const ms_quant_normalisation_peptide& src);
00053
00055         virtual ~ms_quant_normalisation_peptide();
00056
00058         void defaultValues();
00059
00061         void copyFrom(const ms_quant_normalisation_peptide* right);
00062
00063 #ifndef SWIG
00064
00065         ms_quant_normalisation_peptide& operator=(const ms_quant_normalisation_peptide& right);
00066 #endif
00067
00068         virtual std::string getSchemaType() const;
00069
00071         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00072
00074         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00075
00076
00078         bool haveSequence() const;
00079
00081         std::string getSequence() const;
00082
00084         void setSequence(const char * value);
00085
00087         void dropSequence();
00088
00090         std::string getSequenceSchemaType() const;
00091
00092     private:
00093
00094         std::string _sequence;
00095         bool _sequence_set;
00096     }; // class ms_quant_normalisation_peptide
00097
00099     class MS_MASCOTRESFILE_API ms_quant_normalisation_peptides: public ms_xml_IValidatable
00100     {
00101         friend class msparser_internal::ms_quant_xmlloader;
00102
00103     public:
00105         ms_quant_normalisation_peptides();
00106
00108         ms_quant_normalisation_peptides(const ms_quant_normalisation_peptides& src);
00109
00111         virtual ~ms_quant_normalisation_peptides();
00112
00114         void defaultValues();
00115
00117         void copyFrom(const ms_quant_normalisation_peptides* right);
00118
00119 #ifndef SWIG
00120
00121         ms_quant_normalisation_peptides& operator=(const ms_quant_normalisation_peptides& right);
00122 #endif
00123
00124         virtual std::string getSchemaType() const;
00125
00127         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00128
00130         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00131
00132
00134         int getNumberOfPeptides() const;
00135
00137         void clearPeptides();
00138
00140         void appendPeptide(const ms_quant_normalisation_peptide* pep);
00141
00143         const ms_quant_normalisation_peptide* getPeptide(const int idx) const;
00144
00146         bool updatePeptide(const int idx, const ms_quant_normalisation_peptide* pep);
00147
00149         bool deletePeptide(const int idx);
00150
00152         std::string getPeptideSchemaType() const;
00153
00154     private:
00155
00156         typedef std::vector< ms_quant_normalisation_peptide* > pep_vector;
00157         pep_vector _peptides;
00158     }; // class ms_quant_normalisation_peptides
00159  // end of config_group
00161
00162 } // namespace matrix_science
00163
00164 #endif // MS_QUANT_NORMALISATION_PEPTIDE_HPP
00165
00166 /*------------------------------- End of File -------------------------------*/
00167
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_normalisation_protein.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_normalisation_protein.hpp                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates protein-element from "quantitation.xml"-file                  #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2009 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_normalisation_protein.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_NORMALISATION_PROTEIN_HPP
00018 #define MS_QUANT_NORMALISATION_PROTEIN_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_modgroup; // forward declaration
00032     class ms_xml_schema; // forward declaration
00033
00039
00040
00043     class MS_MASCOTRESFILE_API ms_quant_normalisation_protein: public ms_xml_IValidatable
00044     {
00045         friend class msparser_internal::ms_quant_xmlloader;
00046
00047     public:
00049         ms_quant_normalisation_protein();
00050
00052         ms_quant_normalisation_protein(const ms_quant_normalisation_protein& src);
00053
00055         virtual ~ms_quant_normalisation_protein();
00056
00058         void defaultValues();
00059
00061         void copyFrom(const ms_quant_normalisation_protein* right);
00062
00063 #ifndef SWIG
00064
00065         ms_quant_normalisation_protein& operator=(const ms_quant_normalisation_protein& right);
00066 #endif
00067
00068         virtual std::string getSchemaType() const;
00069
00071         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00072
00074         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00075
00076
00078         bool haveAccession() const;
00079
00081         std::string getAccession() const;
00082
00084         void setAccession(const char * value);
00085
00087         void dropAccession();
00088
00090         std::string getAccessionSchemaType() const;
00091
00092     private:
00093
00094         std::string _accession;
00095         bool _accession_set;
00096     }; // class ms_quant_normalisation_protein
00097
00099     class MS_MASCOTRESFILE_API ms_quant_normalisation_proteins: public ms_xml_IValidatable
00100     {
00101         friend class msparser_internal::ms_quant_xmlloader;
00102
00103     public:
00105         ms_quant_normalisation_proteins();
00106
00108         ms_quant_normalisation_proteins(const ms_quant_normalisation_proteins& src);
00109
00111         virtual ~ms_quant_normalisation_proteins();
00112
00114         void defaultValues();
00115
00117         void copyFrom(const ms_quant_normalisation_proteins* right);
00118
00119 #ifndef SWIG
00120
00121         ms_quant_normalisation_proteins& operator=(const ms_quant_normalisation_proteins& right);
00122 #endif
00123
00124         virtual std::string getSchemaType() const;
00125
00127         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00128
00130         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00131
00132
00134         int getNumberOfProteins() const;
00135
00137         void clearProteins();
00138
00140         void appendProtein(const ms_quant_normalisation_protein* protein);
00141
00143         const ms_quant_normalisation_protein* getProtein(const int idx) const;
00144
00146         bool updateProtein(const int idx, const ms_quant_normalisation_protein* protein);
00147
00149         bool deleteProtein(const int idx);
00150
00152         std::string getProteinSchemaType() const;
00153
00154     private:
00155
00156         typedef std::vector< ms_quant_normalisation_protein* > prot_vector;
00157         prot_vector _proteins;
00158     }; // class ms_quant_normalisation_proteins
00159  // end of config_group
00161
00162 } // namespace matrix_science
00163
00164 #endif // MS_QUANT_NORMALISATION_PROTEIN_HPP
00165
00166 /*------------------------------- End of File -------------------------------*/
00167
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_numerator.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_numerator.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "numerator_component" and \c denominator_component elements    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_numerator.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_NUMERATOR_HPP
00018 #define MS_QUANT_NUMERATOR_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_quant_numerator: public ms_xml_IValidatable
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042
00043     public:
00045         ms_quant_numerator();
00046
00048         ms_quant_numerator(const ms_quant_numerator& src);
00049
00051         virtual ~ms_quant_numerator();
00052
00054         void defaultValues();
00055
00057         void copyFrom(const ms_quant_numerator* right);
00058
00059 #ifndef SWIG
00060
00061         ms_quant_numerator& operator=(const ms_quant_numerator& right);
00062 #endif
00063
00064         virtual std::string getSchemaType() const;
00065
00067         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00068
00070         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00071
00072
00074         bool haveName() const;
00075
00077         std::string getName() const;
00078
00080         void setName(const char* value);
00081
00083         void dropName();
00084
00086         std::string getNameSchemaType() const;
00087
00088
00090         bool haveCoefficient() const;
00091
00093         std::string getCoefficient() const;
00094
00096         void setCoefficient(const char* value);
00097
00099         void dropCoefficient();
00100
00102         std::string getCoefficientSchemaType() const;
00103
00104
00106         std::string getContent() const;
00107
00109         void setContent(const char* value);
00110
00112         std::string getContentSchemaType() const;
00113
00114     private:
00115         std::string _name;
00116         bool _name_set;
00117
00118         std::string _coefficient;
00119         bool _coefficient_set;
00120
00121         std::string _value;
00122
00123     }; // class ms_quant_numerator
00124  // end of config_group
00126
00127 } // namespace matrix_science
00128
00129 #endif // MS_QUANT_NUMERATOR_HPP
00130
00131 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_outliers.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_outliers.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates outliers-element from "quantitation.xml"-file                 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_outliers.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_OUTLIERS_HPP
00018 #define MS_QUANT_OUTLIERS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039
00043     class MS_MASCOTRESFILE_API ms_quant_outliers: public ms_quant_parameters
00044     {
00045         friend class msparser_internal::ms_quant_xmlloader;
00046     public:
00048         ms_quant_outliers();
00049
00051         ms_quant_outliers(const ms_quant_outliers& src);
00052
00054         virtual ~ms_quant_outliers();
00055
00057         void defaultValues();
00058
00060         void copyFrom(const ms_quant_outliers* right);
00061
00062 #ifndef SWIG
00063
00064         ms_quant_outliers& operator=(const ms_quant_outliers& right);
00065 #endif
00066
00067         virtual std::string getSchemaType() const;
00068
00070         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00071
00073         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00074
00075
00077         bool haveMethod() const;
00078
00080         std::string getMethod() const;
00081
00083         void setMethod(const char* value);
00084
00086         void dropMethod();
00087
00089         std::string getMethodSchemaType() const;
00090
00091     private:
00092
00093         std::string _method;
00094         bool _method_set;
00095
00096     }; // class ms_quant_outliers
00097  // end of config_group
00099
00100 } // namespace matrix_science
00101
00102 #endif // MS_QUANT_OUTLIERS_HPP
00103
00104 /*------------------------------- End of File -------------------------------*/
00105
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_parameters.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_parameters.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates parametersType-definition from "quantitation.xml"-file        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_parameters.hpp $
00012  * @(#)$Revision: 8fee77726a13a239ca8bcf2b46212bff297db9b7 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 10:50:55 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_PARAMETERS_HPP
00018 #define MS_QUANT_PARAMETERS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_quant_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029     class ms_xml_schema; // forward declaration
00030     class ms_xml_parameter;
00031     class ms_xml_parameters;
00032
00038
00039     class MS_MASCOTRESFILE_API ms_quant_parameter: public ms_xml_parameter
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042
00043     public:
00045         ms_quant_parameter();
00046
00048         ms_quant_parameter(const ms_quant_parameter& src);
00049
00051         virtual ~ms_quant_parameter();
00052
00054         void copyFrom(const ms_quant_parameter* right);
00055
00056 #ifndef SWIG
00057
00058         ms_quant_parameter& operator=(const ms_quant_parameter& right);
00059 #endif
00060
00061         virtual std::string getSchemaType() const;
00062
00064         virtual std::string getNameSchemaType() const;
00065
00067         virtual std::string getDescriptionSchemaType() const;
00068
00070         virtual std::string getValueSchemaType() const;
00071
00072     protected:
00073         virtual bool saveToXML_ParameterByNumber(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
00074
00075     }; // class ms_quant_parameter
00076
00078
00081     class MS_MASCOTRESFILE_API ms_quant_parameters: public ms_xml_parameters
00082     {
00083         friend class msparser_internal::ms_quant_xmlloader;
00084     public:
00086         ms_quant_parameters();
00087
00089         ms_quant_parameters(const ms_quant_parameters& src);
00090
00092         virtual ~ms_quant_parameters();
00093
00095         void defaultValues();
00096
00098         void copyFrom(const ms_quant_parameters* right);
00099
00100 #ifndef SWIG
00101
00102         ms_quant_parameters& operator=(const ms_quant_parameters& right);
00103 #endif
00104
00105         virtual std::string getSchemaType() const;
00106
00108         virtual int getNumberOfParameters() const;
00109
00111         virtual void clearParameters();
00112
00114         void appendParameter(const ms_quant_parameter *item);
00115
00117         const ms_quant_parameter * getParameterByNumber(const int idx) const;
00118
00120         const ms_quant_parameter * getParameterByName(const char *name) const;
00121
00123         bool updateParameterByNumber(const int idx, const ms_quant_parameter *param);
00124
00126         bool updateParameterByName(const char *name, const ms_quant_parameter *param);
00127
00129         virtual bool deleteParameterByNumber(const int idx);
00130
00132         virtual bool deleteParameterByName(const char *name);
00133
00135         virtual std::string getParameterSchemaType() const;
00136
00137     protected:
00138         virtual bool saveToXML_Parameters(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const;
00139
00140     private:
00141         typedef std::vector< ms_quant_parameter* > entries_vector;
00142         entries_vector _entries;
00143
00144     }; // class ms_quant_parameters
00145  // end of config_group
00147
00148 } // namespace matrix_science
00149
00150 #endif // MS_QUANT_PARAMETERS_HPP
00151
00152 /*------------------------------- End of File -------------------------------*/
00153
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_pepneutralloss.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_pepneutralloss.hpp                                          #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "PepNeutralLoss" element from "quantitation.xml"-file         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_pepneutralloss.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_PEPNEUTRALLOSS_HPP
00018 #define MS_QUANT_PEPNEUTRALLOSS_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029
00035
00036     class MS_MASCOTRESFILE_API ms_quant_pepneutralloss: public ms_quant_composition
00037     {
00038         friend class msparser_internal::ms_quant_xmlloader;
00039     public:
00041         ms_quant_pepneutralloss();
00042
00044         ms_quant_pepneutralloss(const ms_quant_pepneutralloss& src);
00045
00047         virtual ~ms_quant_pepneutralloss();
00048
00050         void defaultValues();
00051
00053         void copyFrom(const ms_quant_pepneutralloss* right);
00054
00055 #ifndef SWIG
00056
00057         ms_quant_pepneutralloss& operator=(const ms_quant_pepneutralloss& right);
00058 #endif
00059
00060         virtual std::string getSchemaType() const;
00061
00063         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00064
00066         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00067
00068
00070         bool haveRequired() const;
00071
00073         bool isRequired() const;
00074
00076         void setRequired(const bool required);
00077
00079         void dropRequired();
00080
00082         std::string getRequiredSchemaType() const;
00083
00084     private:
00085
00086         bool _required;
00087         bool _required_set;
00088
00089     }; // class ms_quant_pepneutralloss
00090  // end of config_group
00092
00093 } // namespace matrix_science
00094
00095 #endif // MS_QUANT_NEUTRALLOSS_HPP
00096
00097 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_precursor.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_precursor.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates precursor-element from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_precursor.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_PRECURSOR_HPP
00018 #define MS_QUANT_PRECURSOR_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024     class ms_quant_precursor_impl;
00025     class ms_quant_configfile_impl;
00026     class ms_quant_protocol_impl;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039
00042     class MS_MASCOTRESFILE_API ms_quant_precursor: public ms_quant_parameters
00043     {
00044         friend class msparser_internal::ms_quant_xmlloader;
00045         friend class msparser_internal::ms_quant_configfile_impl;
00046         friend class msparser_internal::ms_quant_protocol_impl;
00047     public:
00049         ms_quant_precursor();
00050
00052         ms_quant_precursor(const ms_quant_precursor& src);
00053
00055         virtual ~ms_quant_precursor();
00056
00058         void defaultValues();
00059
00061         void copyFrom(const ms_quant_precursor* right);
00062
00063 #ifndef SWIG
00064
00065         ms_quant_precursor& operator=(const ms_quant_precursor& right);
00066 #endif
00067
00068         virtual std::string getSchemaType() const;
00069
00071         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00072
00074         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00075
00076
00078         bool haveAllowMassTimeMatch() const;
00079
00081         bool isAllowMassTimeMatch() const;
00082
00084         void setAllowMassTimeMatch(const bool value);
00085
00087         void dropAllowMassTimeMatch();
00088
00090         std::string getAllowMassTimeMatchSchemaType() const;
00091
00092
00094         bool haveAllowElutionShift() const;
00095
00097         bool isAllowElutionShift() const;
00098
00100
00105         //void setAllowElutionShift(const bool value);
00106
00108         void dropAllowElutionShift();
00109
00111         std::string getAllowElutionShiftSchemaType() const;
00112
00113
00115         bool haveAllChargeStates() const;
00116
00118         bool isAllChargeStates() const;
00119
00121
00126         //void setAllChargeStates(const bool value);
00127
00129         void dropAllChargeStates();
00130
00132         std::string getAllChargeStatesSchemaType() const;
00133
00134     private:
00135
00136         msparser_internal::ms_quant_precursor_impl * m_pImpl;
00137     }; // class ms_quant_precursor
00138  // end of config_group
00140
00141 } // namespace matrix_science
00142
00143 #endif // MS_QUANT_PRECURSOR_HPP
00144
00145 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_protocol.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_protocol.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates protocol-element from "quantitation.xml"-file                 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_protocol.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_PROTOCOL_HPP
00018 #define MS_QUANT_PROTOCOL_HPP
00019
00020
00021 #include <string>
00022
00023 // forward declarations
00024 namespace msparser_internal {
00025     class ms_quant_xmlloader;
00026     class ms_quant_protocol_impl;
00027     class ms_quant_method_impl;
00028 }
00029
00030 namespace matrix_science {
00031
00032      // forward declarations
00033     class ms_quant_parameters;
00034     class ms_quant_reporter;
00035     class ms_quant_precursor;
00036     class ms_quant_replicate;
00037     class ms_quant_average;
00038     class ms_quant_multiplex;
00039     class ms_xml_schema;
00040
00046
00047
00054     class MS_MASCOTRESFILE_API ms_quant_protocol: public ms_xml_IValidatable
00055     {
00056         friend class msparser_internal::ms_quant_xmlloader;
00057         friend class msparser_internal::ms_quant_method_impl;
00058     public:
00060         ms_quant_protocol();
00061
00063         ms_quant_protocol(const ms_quant_protocol& src);
00064
00066         virtual ~ms_quant_protocol();
00067
00069         void defaultValues();
00070
00072         void copyFrom(const ms_quant_protocol* right);
00073
00074 #ifndef SWIG
00075
00076         ms_quant_protocol& operator=(const ms_quant_protocol& right);
00077 #endif
00078
00079         virtual std::string getSchemaType() const;
00080
00082         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00083
00085         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00086
00087
00089         std::string getType() const;
00090
00092         void setNull();
00093
00094
00096         const ms_quant_reporter* getReporter() const;
00097
00099         void setReporter(const ms_quant_reporter* reporter);
00100
00102         std::string getReporterSchemaType() const;
00103
00104
00106         const ms_quant_precursor* getPrecursor() const;
00107
00109         void setPrecursor(const ms_quant_precursor* precursor);
00110
00112         std::string getPrecursorSchemaType() const;
00113
00114
00116         const ms_quant_multiplex* getMultiplex() const;
00117
00119         void setMultiplex(const ms_quant_multiplex* multiplex);
00120
00122         std::string getMultiplexSchemaType() const;
00123
00124
00126         const ms_quant_replicate* getReplicate() const;
00127
00129         void setReplicate(const ms_quant_replicate* replicate);
00130
00132         std::string getReplicateSchemaType() const;
00133
00134
00136         const ms_quant_average* getAverage() const;
00137
00139         void setAverage(const ms_quant_average* average);
00140
00142         std::string getAverageSchemaType() const;
00143
00144     private:
00145
00146         msparser_internal::ms_quant_protocol_impl * m_pImpl;
00147
00148     }; // class ms_quant_protocol
00149  // end of config_group
00151
00152 } // namespace matrix_science
00153
00154 #endif // MS_QUANT_PROTOCOL_HPP
00155
00156 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_quality.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_quality.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates quality-element from "quantitation.xml"-file                  #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_quality.hpp $
00012  * @(#)$Revision: 23deec178247eb6704b4c85e1ed5642a21d26ed1 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2021-08-10 17:22:38 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_QUALITY_HPP
00018 #define MS_QUANT_QUALITY_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_quant_quality: public ms_quant_parameters
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042     public:
00044         ms_quant_quality();
00045
00047         ms_quant_quality(const ms_quant_quality& src);
00048
00050         virtual ~ms_quant_quality();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_quant_quality* right);
00057
00058 #ifndef SWIG
00059
00060         ms_quant_quality& operator=(const ms_quant_quality& right);
00061 #endif
00062
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00073         bool haveMinPrecursorCharge() const;
00074
00076         int getMinPrecursorCharge() const;
00077
00079         void setMinPrecursorCharge(const int value);
00080
00082         void dropMinPrecursorCharge();
00083
00085         std::string getMinPrecursorChargeSchemaType() const;
00086
00087
00089         bool haveIsolatedPrecursor() const;
00090
00092         bool isIsolatedPrecursor() const;
00093
00095         void setIsolatedPrecursor(const bool value);
00096
00098         void dropIsolatedPrecursor();
00099
00101         std::string getIsolatedPrecursorSchemaType() const;
00102
00103
00105         bool haveMinimumA1() const;
00106
00108         std::string getMinimumA1() const;
00109
00111         void setMinimumA1(const char* value);
00112
00114         void dropMinimumA1();
00115
00117         std::string getMinimumA1SchemaType() const;
00118
00119
00121         bool havePepThresholdType() const;
00122
00124         std::string getPepThresholdType() const;
00125
00127         void setPepThresholdType(const char* value);
00128
00130         void dropPepThresholdType();
00131
00133         std::string getPepThresholdTypeSchemaType() const;
00134
00135
00137         bool havePepThresholdValue() const;
00138
00140         std::string getPepThresholdValue() const;
00141
00143         void setPepThresholdValue(const char* value);
00144
00146         void dropPepThresholdValue();
00147
00149         std::string getPepThresholdValueSchemaType() const;
00150
00151
00153         bool haveUniquePepseq() const;
00154
00156         bool isUniquePepseq() const;
00157
00159         void setUniquePepseq(bool value);
00160
00162         void dropUniquePepseq();
00163
00165         std::string getUniquePepseqSchemaType() const;
00166
00167
00169         bool haveIsolatedPrecursorThreshold() const;
00170
00172         std::string getIsolatedPrecursorThreshold() const;
00173
00175         void setIsolatedPrecursorThreshold(const char * value);
00176
00178         void dropIsolatedPrecursorThreshold();
00179
00181         std::string getIsolatedPrecursorThresholdSchemaType() const;
00182
00184         bool haveTotalIntensity() const;
00185
00187         bool isTotalIntensity() const;
00188
00190         void setTotalIntensity(bool value);
00191
00193         void dropTotalIntensity();
00194
00196         std::string getTotalIntensitySchemaType() const;
00197
00199         bool haveTotalIntensityThreshold() const;
00200
00202         std::string getTotalIntensityThreshold() const;
00203
00205         void setTotalIntensityThreshold(std::string value);
00206
00208         void dropTotalIntensityThreshold();
00209
00211         std::string getTotalIntensityThresholdSchemaType() const;
00212     private:
00213
00214         int _minPrecursorCharge;
00215         bool _minPrecursorCharge_set;
00216
00217         bool _isolatedPrecursor;
00218         bool _isolatedPrecursor_set;
00219
00220         std::string _minimumA1;
00221         bool _minimumA1_set;
00222
00223         std::string _pepThresholdType;
00224         bool _pepThresholdType_set;
00225
00226         std::string _pepThresholdValue;
00227         bool _pepThresholdValue_set;
00228
00229         bool _uniquePepseq;
00230         bool _uniquePepseq_set;
00231
00232         std::string _isolatedPrecursorThreshold;
00233         bool _isolatedPrecursorThreshold_set;
00234
00235         bool _totalIntensity;
00236         bool _totalIntensity_set;
00237
00238         std::string _totalIntensityThreshold;
00239         bool _totalIntensityThreshold_set;
00240     }; // class ms_quant_quality
00241  // end of config_group
00243
00244 } // namespace matrix_science
00245
00246 #endif // MS_QUANT_QUALITY_HPP
00247
00248 /*------------------------------- End of File -------------------------------*/
00249
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_ratio.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_ratio.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "ratioType" from "quantitation.xml"-file                      #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_ratio.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_RATIO_HPP
00018 #define MS_QUANT_RATIO_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_numerator; // forward declaration
00032     class ms_xml_schema; // forward declaration
00033
00039
00040     class MS_MASCOTRESFILE_API ms_quant_ratio: public ms_xml_IValidatable
00041     {
00042         friend class msparser_internal::ms_quant_xmlloader;
00043
00044     public:
00046         ms_quant_ratio();
00047
00049         ms_quant_ratio(const ms_quant_ratio& src);
00050
00052         virtual ~ms_quant_ratio();
00053
00055         void defaultValues();
00056
00058         void copyFrom(const ms_quant_ratio* right);
00059
00060 #ifndef SWIG
00061
00062         ms_quant_ratio& operator=(const ms_quant_ratio& right);
00063 #endif
00064
00065         virtual std::string getSchemaType() const;
00066
00068         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00069
00071         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00072
00073
00075         int getNumberOfNumerators() const;
00076
00078         void clearNumerators();
00079
00081         void appendNumerator(const ms_quant_numerator *numerator);
00082
00084         const ms_quant_numerator * getNumeratorByNumber(const int idx) const;
00085
00087         const ms_quant_numerator * getNumeratorByName(const char *name) const;
00088
00090         bool updateNumeratorByNumber(const int idx, const ms_quant_numerator* numerator);
00091
00093         bool updateNumeratorByName(const char *name, const ms_quant_numerator* numerator);
00094
00096         bool deleteNumeratorByNumber(const int idx);
00097
00099         bool deleteNumeratorByName(const char *name);
00100
00102         std::string getNumeratorSchemaType() const;
00103
00104
00106         int getNumberOfDenominators() const;
00107
00109         void clearDenominators();
00110
00112         void appendDenominator(const ms_quant_numerator *denominator);
00113
00115         const ms_quant_numerator * getDenominatorByNumber(const int idx) const;
00116
00118         const ms_quant_numerator * getDenominatorByName(const char *name) const;
00119
00121         bool updateDenominatorByNumber(const int idx, const ms_quant_numerator* denominator);
00122
00124         bool updateDenominatorByName(const char *name, const ms_quant_numerator* denominator);
00125
00127         bool deleteDenominatorByNumber(const int idx);
00128
00130         bool deleteDenominatorByName(const char *name);
00131
00133         std::string getDenominatorSchemaType() const;
00134
00135
00137         bool haveName() const;
00138
00140         std::string getName() const;
00141
00143         void setName(const char* value);
00144
00146         void dropName();
00147
00149         std::string getNameSchemaType() const;
00150
00151     private:
00152         typedef std::vector< ms_quant_numerator* > numerator_vector;
00153         numerator_vector _numerators;
00154
00155         numerator_vector _denominators;
00156
00157         std::string _name;
00158         bool _name_set;
00159
00160     }; // class ms_quant_ratio
00161  // end of config_group
00163
00164 } // namespace matrix_science
00165
00166 #endif // MS_QUANT_RATIO_HPP
00167
00168 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_replicate.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_replicate.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates replicate-element from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_replicate.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_REPLICATE_HPP
00018 #define MS_QUANT_REPLICATE_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029
00035
00036
00039     class MS_MASCOTRESFILE_API ms_quant_replicate: public ms_quant_parameters
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042     public:
00044         ms_quant_replicate();
00045
00047         ms_quant_replicate(const ms_quant_replicate& src);
00048
00050         virtual ~ms_quant_replicate();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_quant_replicate* right);
00057
00058 #ifndef SWIG
00059
00060         ms_quant_replicate& operator=(const ms_quant_replicate& right);
00061 #endif
00062
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00072     private:
00073
00074     }; // class ms_quant_replicate
00075  // end of config_group
00077
00078 } // namespace matrix_science
00079
00080 #endif // MS_QUANT_REPLICATE_HPP
00081
00082 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_reporter.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_reporter.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates reporter-element from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_reporter.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_REPORTER_HPP
00018 #define MS_QUANT_REPORTER_HPP
00019
00020
00021 // forward declarations
00022 namespace msparser_internal {
00023     class ms_quant_xmlloader;
00024 }
00025
00026 namespace matrix_science {
00027
00028     class ms_xml_schema; // forward declaration
00029
00035
00036
00039     class MS_MASCOTRESFILE_API ms_quant_reporter: public ms_quant_parameters
00040     {
00041         friend class msparser_internal::ms_quant_xmlloader;
00042     public:
00044         ms_quant_reporter();
00045
00047         ms_quant_reporter(const ms_quant_reporter& src);
00048
00050         virtual ~ms_quant_reporter();
00051
00053         void defaultValues();
00054
00056         void copyFrom(const ms_quant_reporter* right);
00057
00058 #ifndef SWIG
00059
00060         ms_quant_reporter& operator=(const ms_quant_reporter& right);
00061 #endif
00062
00063         virtual std::string getSchemaType() const;
00064
00066         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00067
00069         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00070
00071
00073         bool haveReporterTol() const;
00074
00076         std::string getReporterTol() const;
00077
00079         void setReporterTol(const char* value);
00080
00082         void dropReporterTol();
00083
00085         std::string getReporterTolSchemaType() const;
00086
00087
00089         bool haveReporterTolUnit() const;
00090
00092         std::string getReporterTolUnit() const;
00093
00095         void setReporterTolUnit(const char* value);
00096
00098         void dropReporterTolUnit();
00099
00101         std::string getReporterTolUnitSchemaType() const;
00102     private:
00103
00104         std::string _reporterTol;
00105         bool _reporterTol_set;
00106
00107         std::string _reporterTolUnit;
00108         bool _reporterTolUnit_set;
00109     }; // class ms_quant_reporter
00110  // end of config_group
00112
00113 } // namespace matrix_science
00114
00115 #endif // MS_QUANT_REPORTER_HPP
00116
00117 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_satellite.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_satellite.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates satellite-element from "quantitation.xml"-file                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2009 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_satellite.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_SATELLITE_HPP
00018 #define MS_QUANT_SATELLITE_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_modgroup; // forward declaration
00032     class ms_xml_schema; // forward declaration
00033
00039
00040
00044     class MS_MASCOTRESFILE_API ms_quant_satellite: public ms_xml_IValidatable
00045     {
00046         friend class msparser_internal::ms_quant_xmlloader;
00047
00048     public:
00050         ms_quant_satellite();
00051
00053         ms_quant_satellite(const ms_quant_satellite& src);
00054
00056         virtual ~ms_quant_satellite();
00057
00059         void defaultValues();
00060
00062         void copyFrom(const ms_quant_satellite* right);
00063
00064 #ifndef SWIG
00065
00066         ms_quant_satellite& operator=(const ms_quant_satellite& right);
00067 #endif
00068
00069         virtual std::string getSchemaType() const;
00070
00072         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00073
00075         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00076
00077
00079         bool haveModifications() const;
00080
00082         const ms_quant_modgroup* getModifications() const;
00083
00085         void setModifications(const ms_quant_modgroup* moverz);
00086
00088         void dropModifications();
00089
00091         std::string getModificationsSchemaType() const;
00092
00093     private:
00094
00095         ms_quant_modgroup *_pModifications;
00096         bool _modifications_set;
00097     }; // class ms_quant_satellite
00098  // end of config_group
00100
00101 } // namespace matrix_science
00102
00103 #endif // MS_QUANT_SATELLITE_HPP
00104
00105 /*------------------------------- End of File -------------------------------*/
00106
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_specificity.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_specificity.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Describes \c specificity element from "quantitation.xml"-file               #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_specificity.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_SPECIFICITY_HPP
00018 #define MS_QUANT_SPECIFICITY_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_quant_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_neutralloss; // forward declaration
00032     class ms_quant_pepneutralloss; // forward declaration
00033     class ms_xml_schema; // forward declaration
00034
00040
00041
00044     class MS_MASCOTRESFILE_API ms_quant_specificity: public ms_xml_IValidatable // defined in "ms_xml_typeinfo.hpp"
00045     {
00046         friend class msparser_internal::ms_quant_xmlloader;
00047
00048     public:
00050         ms_quant_specificity();
00051
00053         ms_quant_specificity(const ms_quant_specificity& src);
00054
00056         virtual ~ms_quant_specificity();
00057
00059         void defaultValues();
00060
00062         void copyFrom(const ms_quant_specificity* right);
00063
00064 #ifndef SWIG
00065
00066         ms_quant_specificity& operator=(const ms_quant_specificity& right);
00067 #endif
00068         // methods of ms_quant_IValidatable interface
00069
00071         virtual std::string getSchemaType() const;
00072
00074         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00075
00077         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00078
00079
00081         int getNumberOfNeutralLosses() const;
00082
00084         void clearNeutralLosses();
00085
00087         void appendNeutralLoss(const ms_quant_neutralloss *neutralloss);
00088
00090         const ms_quant_neutralloss * getNeutralLoss(const int idx) const;
00091
00093         bool updateNeutralLoss(const int idx, const ms_quant_neutralloss* neutralloss);
00094
00096         bool deleteNeutralLoss(const int idx);
00097
00099         std::string getNeutralLossSchemaType() const;
00100
00101
00103         int getNumberOfPepNeutralLosses() const;
00104
00106         void clearPepNeutralLosses();
00107
00109         void appendPepNeutralLoss(const ms_quant_pepneutralloss *neutralloss);
00110
00112         const ms_quant_pepneutralloss* getPepNeutralLoss(const int idx) const;
00113
00115         bool updatePepNeutralLoss(const int idx, const ms_quant_pepneutralloss* neutralloss);
00116
00118         bool deletePepNeutralLoss(const int idx);
00119
00121         std::string getPepNeutralLossSchemaType() const;
00122
00123
00125         bool haveSite() const;
00126
00128         std::string getSite() const;
00129
00131         void setSite(const char* site);
00132
00134         void dropSite();
00135
00137         std::string getSiteSchemaType() const;
00138
00139
00141         bool havePosition() const;
00142
00144         std::string getPosition() const;
00145
00147         void setPosition(const char* position);
00148
00150         void dropPosition();
00151
00153         std::string getPositionSchemaType() const;
00154
00155     private:
00156         typedef std::vector< ms_quant_neutralloss* > neutralloss_vector;
00157         neutralloss_vector _neutrallosses;
00158
00159         typedef std::vector< ms_quant_pepneutralloss* > pepneutralloss_vector;
00160         pepneutralloss_vector _pepneutrallosses;
00161
00162         std::string _site;
00163         bool _site_set;
00164
00165         std::string _position;
00166         bool _position_set;
00167     }; // class ms_quant_specificity
00168  // end of config_group
00170
00171 } // namespace matrix_science
00172
00173 #endif // MS_QUANT_SPECIFICITY_HPP
00174
00175 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_stats.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_stats.hpp                                                   #
00004 # 'msparser' toolkit                                                         #
00005 # Statistics routines and distributions for peptide and protein quantitation #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: villek@matrixscience.com $ #
00012 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00013 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_QUANT_STATS_HPP
00019 #define MS_QUANT_STATS_HPP
00020
00021
00022 #include <deque>
00023 #include <string>
00024 #include <vector>
00025
00026 namespace matrix_science {
00027
00033
00034
00043     class MS_MASCOTRESFILE_API ms_quant_stats
00044     {
00045         public:
00046 #ifndef SWIG
00047
00048             static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod, unsigned int * const numLow, unsigned int * const numHigh);
00049
00051             static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod, double sigLevel, unsigned int * const numLow, unsigned int * const numHigh);
00052
00054             static void testRosners(const std::vector<double> &sample, unsigned int maxOutliers, double sigLevel, unsigned int * const numLow, unsigned int * const numHigh);
00055 #else // SWIG Multiple return values
00056             static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod,                unsigned int * const OUTPUT, unsigned int * const OUTPUT);
00057             static void detectOutliers(const std::vector<double> &sample, std::string outlierMethod,  double sigLevel, unsigned int * const OUTPUT, unsigned int * const OUTPUT);
00058             static void testRosners(const std::vector<double> &sample, unsigned int maxOutliers, double sigLevel, unsigned int * const OUTPUT, unsigned int * const OUTPUT);
00059 #endif
00060
00062             static int testDixonsN9(unsigned long sampleSize, double min, double x2, double xn_1, double max, double sigLevel);
00063
00065             static int testGrubbsN2(unsigned long sampleSize, double min, double mean, double max, double stdev, double sigLevel);
00066 #ifndef SWIG
00067
00068             static bool testShapiroWilkW(const std::vector<double> &sample, double * const W, double * const pValue);
00069 #else // SWIG Multiple return values
00070             static bool testShapiroWilkW(const std::vector<double> &sample, double * const OUTPUT, double * const OUTPUT);
00071 #endif
00072
00073             static double binomialCoefficient(unsigned int n, unsigned int k);
00074
00076             static double sum(const std::vector<double> &data);
00077
00079             static double sumsq(const std::vector<double> &data);
00080
00082             static std::vector<double> meanCentre(const std::vector<double> &data, double mean);
00083
00085             static std::vector<double> logTransform(const std::vector<double> &data);
00086
00088             static std::vector<double> expTransform(const std::vector<double> &logData);
00089
00091             static double sortedMedian(const std::vector<double> &data);
00092
00094             static double sortedMedian(const std::deque<double> &data);
00095
00097             static double unsortedMedian(const std::vector<double> &data);
00098
00100             static double arithmeticMean(const std::vector<double> &data);
00101
00103             static double weightedArithmeticMean(const std::vector<double> &data, const std::vector<double> &weights);
00104
00106             static double geometricMean(const std::vector<double> &data);
00107
00109             static double weightedGeometricMean(const std::vector<double> &data, const std::vector<double> &weights);
00110
00112             static double arithmeticStandardDeviation(const std::vector<double> &data, double arithmeticMean);
00113
00115             static double arithmeticStandardErrorOfMean(double arithmeticStdev, unsigned long sampleSize);
00116
00118             static double geometricStandardDeviation(const std::vector<double> &data, double geometricMean);
00119
00121             static double arithmeticStandardErrorOfMedian(double arithmeticStdev, unsigned long sampleSize);
00122
00124             static double weightedArithmeticStandardDeviation(const std::vector<double> &data, const std::vector<double> &weights, double weightedMean);
00125
00127             static double weightedArithmeticStandardError(const std::vector<double> &weights, double weightedStdev, unsigned long sampleSize);
00128
00130             static double weightedGeometricStandardDeviation(const std::vector<double> &data, const std::vector<double> &weights, double weightedMean);
00131
00133             static double normalCumulativeProbability(double x0);
00134
00136             static double normalCriticalValue(double p);
00137
00139             static double studentsCriticalValue(unsigned int df, double sigLevel);
00140
00142             static double chisqUpperCriticalValue(unsigned int df, double sigLevel);
00143
00145             static double chisqLowerCriticalValue(unsigned int df, double sigLevel);
00146
00148             static double snedecorsCriticalValue(unsigned int df1, unsigned int df2, double sigLevel);
00149
00151             static double calculateNormalMeanPvalue(double populationMean, double mean, double stdev, unsigned long sampleSize);
00152
00154             static double calculateNormalMedianPvalue(double populationMedian, double median, double stdev, unsigned long sampleSize);
00155
00157             static double calculateNormalWeightedPvalue(double populationMean, double weightedMean, const std::vector<double> &weights, double weightedStdev, unsigned long sampleSize);
00158
00160             static double medianStandardErrorCorrection(unsigned long sampleSize);
00161
00163             static double poissonDensity(double lambda, unsigned int k);
00164
00165         private:
00166             // No instances.
00167             ms_quant_stats();
00168             ~ms_quant_stats();
00169
00170             // No copying.
00171             ms_quant_stats(const ms_quant_stats& src);
00172             ms_quant_stats& operator=(const ms_quant_stats& right);
00173     }; // end of quantitation_group
00175 }   // matrix_science namespace
00176
00177 #endif // MS_QUANT_STATS_HPP
00178
00179 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quant_unmodified.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quant_unmodified.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "unmodified" element from "quantitation.xml"-file             #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_quant_unmodified.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_QUANT_UNMODIFIED_HPP
00018 #define MS_QUANT_UNMODIFIED_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_quant_xmlloader;
00026 }
00027
00028 namespace matrix_science {
00029
00030     class ms_xml_schema; // forward declaration
00031
00037
00038     class MS_MASCOTRESFILE_API ms_quant_unmodified: public ms_xml_IValidatable
00039     {
00040         friend class msparser_internal::ms_quant_xmlloader;
00041     public:
00043         ms_quant_unmodified();
00044
00046         ms_quant_unmodified(const ms_quant_unmodified& src);
00047
00049         virtual ~ms_quant_unmodified();
00050
00052         void defaultValues();
00053
00055         void copyFrom(const ms_quant_unmodified* right);
00056
00057 #ifndef SWIG
00058
00059         ms_quant_unmodified& operator=(const ms_quant_unmodified& right);
00060 #endif
00061
00062         virtual std::string getSchemaType() const;
00063
00065         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00066
00068         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00069
00070
00072         std::string getContent() const;
00073
00075         void setContent(const char* value);
00076
00078         std::string getContentSchemaType() const;
00079
00080
00082         bool haveSite() const;
00083
00085         std::string getSite() const;
00086
00088         void setSite(const char* site);
00089
00091         void dropSite();
00092
00094         std::string getSiteSchemaType() const;
00095
00096
00098         bool havePosition() const;
00099
00101         std::string getPosition() const;
00102
00104         void setPosition(const char* position);
00105
00107         void dropPosition();
00108
00110         std::string getPositionSchemaType() const;
00111
00112
00113     private:
00114         std::string _content;
00115
00116         std::string _site;
00117         bool _site_set;
00118
00119         std::string _position;
00120         bool _position_set;
00121
00122     }; // class ms_quant_unmodified
00123  // end of config_group
00125
00126 } // namespace matrix_science
00127
00128 #endif // MS_QUANT_UNMODIFIED_HPP
00129
00130 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_quantitation.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_quantitation.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Base class for the main quantitation interface                             #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: patricke@matrixscience.com $ #
00012 #       $Date: 2019-10-07 14:25:02 +0100 $ #
00013 #   $Revision: 7c90b0aa9fbdfe0a1d8c51bc7935dfea43c25dbb | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_QUANTITATION_HPP
00019 #define MS_QUANTITATION_HPP
00020
00021
00022 // Includes from the standard template library
00023 #include <string>
00024 #include <vector>
00025 #include <map>
00026 #include <set>
00027 #include <utility>
00028
00029 namespace msparser_internal
00030 {
00031     class ms_XMLElement;
00032     class ms_XMLHelper;
00033 }
00034
00035 namespace matrix_science {
00036     class ms_errors;
00037     class ms_mascotresfile;
00038     class ms_peptide_quant_key;
00039     class ms_peptide_quant_key_vector;
00040     class ms_peptide_quant_ratio;
00041     class ms_protein_quant_ratio;
00042     class ms_quant_outliers;
00043     class ms_peptidesummary;
00044     class ms_protein;
00045     class ms_peptide;
00046     class ms_progress_info;
00047
00053
00054
00138     class MS_MASCOTRESFILE_API ms_quantitation: public ms_errors
00139     {
00140         public:
00142             virtual ~ms_quantitation() = 0;
00143
00145             virtual bool hasPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const = 0;
00146
00148             virtual ms_peptide_quant_ratio getPeptideRatio(const ms_peptide_quant_key &key, const std::string &ratioName) const = 0;
00149
00151             virtual void setPeptideRatioIncluded(const ms_peptide_quant_key &key, const std::string &ratioName) = 0;
00152
00154             virtual void setPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) = 0;
00155
00157             virtual bool isPeptideRatioExcluded(const ms_peptide_quant_key &key, const std::string &ratioName) const = 0;
00158
00160             virtual void setQuantOutliers(const ms_quant_outliers *) = 0;
00161
00163             void setMinNumPeptides(int value);
00164
00166             virtual void setProteinRatioType(const char *value) = 0;
00167
00169             const ms_quant_method& getQuantitationMethod() const;
00170
00172             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName) const = 0;
00173
00175             virtual ms_protein_quant_ratio getProteinRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const ms_peptide_quant_key_vector &includeKeys, const ms_peptide_quant_key_vector &excludeKeys) const = 0;
00176
00178             virtual std::vector<double> getAllProteinRatios(const std::string & accession, const int dbIdx, const std::string & ratioName) const = 0;
00179
00181             virtual std::vector<std::vector<bool> > getAllProteinRatioFlags(const std::string & accession, const int dbIdx, const std::string & ratioName) const = 0;
00182
00183
00185             ms_peptide_quant_key_vector getPeptideQuantKeys(const std::string &accession, int dbIdx) const;
00186
00188             double getPeptideRatioNormalisationBase(const std::string &ratioName) const;
00189
00191             void setPeptideRatioNormalisationBase(const std::string &ratioName, double b);
00192
00194             void removePeptideRatioNormalisationBase(const std::string &ratioName);
00195
00197             void removePeptideRatioNormalisationBases();
00198
00200             const ms_progress_info & getProgressInfo();
00201
00203             void addRawFileField(const unsigned int id, const std::string & name, const std::string & value);
00205             void addHeaderField(const std::string & name, const std::string & value);
00207             void clearHeaderFields();
00209             void clearRawFileFields();
00210
00211 #ifndef SWIG
00212
00213             virtual int countDistinctPeptides(const std::vector<ms_peptide_quant_key> & activeKeys) const;
00214 #endif
00215
00216             virtual int countDistinctPeptides(const ms_peptide_quant_key_vector & activeKeys) const;
00217
00218
00219         protected:
00220             ms_quantitation();
00221
00222             ms_quant_method quantMethod_;
00223             typedef std::map<std::string, std::string> HeaderInfo_t;
00224             typedef std::vector<HeaderInfo_t> RawFileInfo_t;
00225             RawFileInfo_t rawFileInfo_;
00226             HeaderInfo_t  headerInfo_;
00227
00229             virtual void getSortedFinitePeptideRatioValues(const std::string &ratioName, const std::set<ms_peptide_quant_key> &keys, const std::set<ms_peptide_quant_key> &includeKeys, const std::set<ms_peptide_quant_key> &excludeKeys, std::vector<double> &values, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys) const = 0;
00230
00232             void getProteinRatioSample(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<ms_peptide_quant_key> &includeKeys, const std::vector<ms_peptide_quant_key> &excludeKeys, std::vector<double> &sample, std::vector<double> &logSample, std::vector<double> &weights, std::vector<ms_peptide_quant_key> &activeKeys, std::map<ms_peptide_quant_key, int> &inactiveKeys, double &normalityPvalue) const;
00233
00235             ms_protein_quant_ratio calculateMedianRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<double> &sample, const std::vector<double> &logSample, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys, double normalityPvalue) const;
00236
00238             ms_protein_quant_ratio calculateGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<double> &sample, const std::vector<double> &logSample, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys, double normalityPvalue) const;
00239
00241             ms_protein_quant_ratio calculateWeightedGeometricMeanRatio(const std::string &accession, int dbIdx, const std::string &ratioName, const std::vector<double> &sample, const std::vector<double> &logSample, const std::vector<double> &weights, const std::vector<ms_peptide_quant_key> &activeKeys, const std::map<ms_peptide_quant_key, int> &inactiveKeys, double normalityPvalue) const;
00242
00243             typedef std::pair<std::string, int> protein_key_t; // accession, dbIdx
00244             typedef std::map< protein_key_t, std::set<ms_peptide_quant_key> > protein_to_peptide_quant_key_t; // maps from [accession, dbidx] to set<ms_peptide_quant_key>
00246             protein_to_peptide_quant_key_t proteinKeys_;
00247
00249             bool initialiseBaseSettings(const ms_quant_method &qmBase, const ms_quant_method &qmConfig);
00250
00252             int getMinNumPeptides() const;
00253
00256             std::string encodeForXml(const std::string & value) const;
00257
00259             msparser_internal::ms_XMLElement createXmlRoot(msparser_internal::ms_XMLHelper & helper) const;
00260
00262             msparser_internal::ms_XMLElement createRawFilesElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root) const;
00263
00265             msparser_internal::ms_XMLElement createHeaderElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root) const;
00266
00268             bool addQuantitationMethodXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root) const;
00269
00271             bool populateProteinHitXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & proteinHitElement, const matrix_science::ms_protein * protein, const matrix_science::ms_peptidesummary & peptideSummary, int hitId, int memberNumber);
00272
00274             bool addPeptideElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & root, const matrix_science::ms_peptide & peptide, const std::string & component) const;
00275
00277             bool createPeptideGroupStatusElement(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & hitElement, const matrix_science::ms_peptidesummary & peptideSummary, long q, long p, const std::string & status, const std::string & component, char residueBefore, char residueAfter) const;
00279
00280             mutable ms_progress_info * progressInfo_;
00281         private:
00282             int minNumPeptides_;
00283
00284             std::map< std::string, double > logH0ProteinRatio_;
00285             typedef std::map< std::string, double > ratio_name_to_normalisation_base_t;
00286             ratio_name_to_normalisation_base_t peptideNormalisationBases_;
00287     }; // end of quantitation_group
00289 }   // matrix_science namespace
00290
00291 #endif // MS_QUANTITATION_HPP
00292
00293 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security.hpp                                                      #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates Mascot security as used in authentication                     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020
00021 #if !defined(ms_security_INCLUDED_)
00022 #define ms_security_INCLUDED_
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <set>
00028 #include <vector>
00029 #include <map>
00030
00031
00032 #ifdef _WIN32
00033 #include <io.h>
00034 #endif
00035
00036 #include <time.h>
00037
00038 namespace matrix_science {
00039     class ms_security_options;
00040     class ms_security_task;
00041     class ms_security_tasks;
00042
00043 #ifndef SWIG
00044     class ms_userSortByID
00045     {
00046     public:
00047         bool operator() (const ms_user * t1, const ms_user * t2) const
00048         {
00049             return (t1->getID() < t2->getID());
00050         }
00051     };
00052
00053     class ms_userSortByLoginName
00054     {
00055     public:
00056         bool operator() (const ms_user * t1, const ms_user * t2) const
00057         {
00058             return (t1->getName() < t2->getName());
00059         }
00060     };
00061
00062     class ms_userSortByFullName
00063     {
00064     public:
00065         bool operator() (const ms_user * t1, const ms_user * t2) const
00066         {
00067             return (t1->getFullName() < t2->getFullName());
00068         }
00069     };
00070
00071     class ms_groupSortByID
00072     {
00073     public:
00074         bool operator() (const ms_group * t1, const ms_group * t2) const
00075         {
00076             return (t1->getID() < t2->getID());
00077         }
00078     };
00079
00080 #endif
00081
00086
00087
00093     class MS_MASCOTRESFILE_API ms_security : public ms_errors
00094     {
00095
00096     public:
00098         ms_security();
00099         ~ms_security();
00100
00101     public:
00102
00104         enum USERID_SORTBY
00105         {
00106             USERID_SORTBY_ID         = 1,
00107             USERID_SORTBY_LOGINNAME  = 2,
00108             USERID_SORTBY_FULLNAME   = 3
00109         };
00110
00112         bool addNewUser(const std::string       sessionID,
00113                         const int               userID,
00114                         const std::string       userName,
00115                         const std::string       password,
00116                         const time_t            passwordExpiry,
00117                         const std::string       fullName,
00118                         const std::string       emailAddress,
00119                         const ms_user::usertype userType,
00120                         const bool              enabled);
00121
00123         ms_user getUser(const std::string userName) const;
00124
00126         ms_user getUserFromID(const int userID) const;
00127
00129         bool isUserExists(const int userID) const;
00130
00132         std::vector<int> sortUsers(std::vector<ms_user*> & vecUsers, const USERID_SORTBY sortby) const;
00133
00135         std::vector<int> getAllUserIDs(const USERID_SORTBY sortby = USERID_SORTBY_ID) const;
00136
00138         bool deleteUser(const std::string sessionID, const std::string userName);
00139
00141         bool updateUser(const std::string sessionID, const ms_user user);
00142
00144         bool updatePassword(const std::string sessionID,
00145                             const std::string userName,
00146                             const std::string oldPassword,
00147                             const std::string newPassword);
00148
00150         std::vector<std::string> getIntegraUsers() const;
00151
00153         bool addNewGroup(const std::string sessionID,
00154                          const int groupID,
00155                          const std::string groupName);
00156
00158         ms_group getGroup(const std::string groupName) const;
00159
00161         ms_group getGroupFromID(const int groupID) const;
00162
00164         std::vector<int> getAllGroupIDs() const;
00165
00167         bool deleteGroup(const std::string sessionID, const std::string groupName);
00168
00170         bool updateGroup(const std::string sessionID, const ms_group & group);
00171
00173         ms_security_tasks getPermittedTasksForUser(const std::string name) const;
00174
00176         ms_user::customParams_t getAllCustomParamsForUser(const ms_user & user) const;
00177
00179         ms_security_options getMascotSecurityOptions() const;
00180
00182         ms_security_tasks getTasks() const;
00183
00185         bool isTaskExists(const int taskID) const;
00186
00188         bool createDefaults(const std::string sessionID = "");
00189
00191         bool updateAllSessionFiles(bool deleteOnly = false);
00192
00193     protected:
00194         bool loadFromFile();
00195         bool saveToFile();
00196
00197     private:
00198         //do not copy this class
00199         ms_security(const ms_security & src);
00200         ms_security& operator=(const ms_security & right);
00201
00202         typedef std::set<ms_user  *, ms_userSortByID>  userlist_t;
00203         typedef std::set<ms_group *, ms_groupSortByID> grouplist_t;
00204
00205         const char * invalidChars_;
00206
00207         userlist_t users_;
00208         grouplist_t groups_;
00209         ms_security_tasks * tasks_;
00210         ms_security_options options_;
00211         int nextFreeGroupID_;
00212         int nextFreeUserID_;
00213
00214         void removeAllUsersFromMemory();
00215         void removeAllGroupsFromMemory();
00216         bool doUpdateUser(const ms_user user);
00217
00218     }; // end of security_group
00220 }
00221 #endif // !defined(ms_security_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security_group.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security_group.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a mascot user as used in authentication                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020
00021 #if !defined(ms_users_group_INCLUDED_)
00022 #define ms_users_group_INCLUDED_
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <set>
00028 #include <vector>
00029 #include <map>
00030 #include <time.h>
00031
00032 namespace matrix_science {
00037
00038     class MS_MASCOTRESFILE_API ms_group
00039     {
00040
00041     public:
00043
00046         enum systemids
00047         {
00048             GROUPID_GUESTS          = 0x0001,
00049             GROUPID_ADMINISTRATORS  = 0x0002,
00050             GROUPID_POWERUSERS      = 0x0003,
00051             GROUPID_DAEMONS         = 0x0004,
00052             GROUPID_INTEGRA_SYSTEM  = 0x0005,
00053             GROUPID_LAST            = 0x0006
00054         };
00055
00057         ms_group();
00058
00060         ms_group(const int groupID, const std::string groupName);
00061
00062         // Copying constructor for c++ programs - don't document
00063         ms_group(const ms_group &src);
00064
00065 #ifndef SWIG
00066         // Assignment operator for c++ programs - don't document
00067         ms_group & operator=(const ms_group & right);
00068 #endif
00069         ~ms_group();
00070
00072         bool addUser(const int userID);
00073
00075         bool deleteUser(const int userID);
00076
00078         bool isUserInGroup(const int userID) const;
00079
00081         std::vector<int> getAllUserIDs(const void * const security = NULL, const int voidSortby = 1) const;
00082
00084         std::string getName() const;
00085
00087         void setName(const std::string newVal);
00088
00090         void addPermittedTask(const matrix_science::ms_security_task & task);
00091
00093         bool removePermittedTask(const int taskID);
00094
00096         matrix_science::ms_security_tasks getPermittedTasks() const;
00097
00099         void setPermittedTasks(matrix_science::ms_security_tasks& tasks);
00100
00102         int  getID() const;
00103
00105         void setID(int newVal);
00106
00108         bool saveStringParam(const std::string name, const std::string param);
00109
00110 #ifndef SWIG
00111
00112         bool getStringParam(const std::string name, std::string & param) const;
00113 #endif
00114
00116         std::string getStringParam(const std::string name) const;
00117
00119         bool clearParam(const std::string name);
00120
00121 #ifndef SWIG
00122 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00123         typedef std::map<std::string, std::string> customParams_t;
00124         customParams_t getAllCustomParams() const { return params_; }
00125 #endif
00126 #endif
00127
00128     private:
00129         int groupID_;
00130         typedef std::set<int> users_t;
00131         ms_security_tasks tasks_;
00132         std::string groupName_;
00133         users_t     users_;
00134         customParams_t params_;
00135
00136         void copyFrom(const ms_group * src);
00137         void updateUsersArrayTasks();
00138     }; // end of security_group
00140 }
00141 #endif // !defined(ms_users_group_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security_options.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security_options.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates the global security options for Mascot authentication         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020 #if !defined(ms_security_options_INCLUDED_)
00021 #define ms_security_options_INCLUDED_
00022
00023
00024 // Includes from the standard template library
00025 #include <string>
00026 #include <set>
00027 #include <vector>
00028 #include <map>
00029 #include <time.h>
00030
00031 namespace matrix_science {
00037     class ms_security;
00038
00040
00045     class MS_MASCOTRESFILE_API ms_security_options: public ms_errors
00046     {
00047
00048     public:
00050         ms_security_options();
00051
00052         ~ms_security_options();
00053
00054         ms_security_options(const ms_security_options & src);
00055 #ifndef SWIG
00056         ms_security_options& operator=(const ms_security_options & right);
00057 #endif
00058         void copyFrom(const ms_security_options * right);
00059
00061         bool isSecurityEnabled() const;
00062
00064         void setSecurityEnabled(bool newVal);
00065
00067         time_t getSessionTimeout() const;
00068
00070         void setSessionTimeout(time_t newVal);
00071
00073         time_t getDefaultPasswordExpiryTime() const;
00074
00076         void setDefaultPasswordExpiryTime(time_t newVal);
00077
00079         unsigned int getMinimumPasswordLength() const;
00080
00082         void setMinimumPasswordLength(unsigned int newVal);
00083
00085         bool getUseSessionCookies() const;
00086
00088         void setUseSessionCookies(bool newVal);
00089
00091         bool getVerifySessionIPAddress() const;
00092
00094         void setVerifySessionIPAddress(bool newVal);
00095
00097         matrix_science::ms_errs::msg_sev getLoggingLevel() const;
00098
00100         void setLoggingLevel(ms_errs::msg_sev newVal);
00101
00103         std::string getIntegraAppServerURL() const;
00104
00106         void setIntegraAppServerURL(std::string newVal);
00107
00109         std::string getIntegraDatabaseName() const;
00110
00112         void setIntegraDatabaseName(std::string newVal);
00113
00115         std::string getIntegraOracleServerName() const;
00116
00118         void setIntegraOracleServerName(std::string newVal);
00119
00121         std::string getLogFileName();
00122
00124         void setLogFileName(std::string newVal);
00125
00126     protected:
00127         bool loadFromFile();
00128         bool saveToFile();
00129
00130     private:
00131         std::string filename_;
00132
00133         bool securityEnabled_;
00134         time_t sessionTimeout_;
00135         time_t defaultPasswordExpiryTime_;
00136         unsigned int minimumPasswordLength_;
00137         bool useSessionCookies_;
00138         bool verifySessionIPAddress_;
00139         ms_errs::msg_sev logLevel_;
00140         std::string logFile_;
00141         std::string integraAppServerURL_;
00142         std::string integraDatabaseName_;
00143         std::string integraOracleServerName_;
00144     }; // end of security_group
00146
00147 }
00148 #endif // !defined(ms_security_options_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security_session.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security_session.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a mascot session as used in authentication                    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #if !defined(mascot_session_DA3EC794_90F8_4c4f_AD5D_13C3B6971A51__INCLUDED_)
00020 #define mascot_session_DA3EC794_90F8_4c4f_AD5D_13C3B6971A51__INCLUDED_
00021
00022
00023 // Includes from the standard template library
00024 #include <string>
00025 #include <set>
00026 #include <vector>
00027 #include <map>
00028 #include <time.h>
00029
00030 namespace matrix_science {
00035     class ms_security;
00036     class ms_security_options;
00037
00039
00122     class MS_MASCOTRESFILE_API ms_session : public ms_errors
00123     {
00124     public:
00126         ms_session(const std::string session_id = "");
00127
00129         ms_session(const std::string userName,
00130                    const std::string userPassword);
00131
00133         ms_session(const std::string userName,
00134                    const std::string connectionID,
00135                    const std::string database);
00136
00138         ms_session(const int timeout, const std::string prefix);
00139
00140
00141 #if !defined(DOXYGEN_SHOULD_SKIP_THIS)
00142         ms_session(const ms_session& src);
00143 #endif
00144         /* SWIG function dispatcher fails in Perl 5.12 for some reason, and
00145          * tries to use ms_session(const ms_security&, const std::string&) as
00146          * the constructor for cases such as ms_session(300, "score_gif")...
00147          * This constructor is supposed to be for internal use anyway, which
00148          * is why it is defined out.
00149          */
00150 #if !defined(DOXYGEN_SHOULD_SKIP_THIS) && !defined(SWIG)
00151         ms_session(const ms_security &sec,
00152                    const std::string &session_id);
00153         ms_session(const ms_security &sec,
00154                    const ms_user & user);
00155         ms_session& operator =(const ms_session& right);
00156 #endif
00157
00158         ~ms_session();
00159
00160     public:
00162         std::string getID() const;
00163
00165         int getUserID() const;
00166
00168         std::string getUserName() const;
00169
00171         std::string getFullUserName() const;
00172
00174         std::string getEmailAddress() const;
00175
00177         bool isSecurityEnabled() const;
00178
00180         time_t getLastAccessed() const;
00181
00183         time_t getTimeout() const;
00184
00186         std::string getIPAddress() const;
00187
00189         matrix_science::ms_security_tasks getPermittedTasks() const;
00190
00192         bool setPermittedTasks(const matrix_science::ms_security_tasks & val);
00193
00195         std::map<std::string, std::string> getParams() const;
00196
00198         bool isPermitted(const int taskID) const;
00199
00201         bool isPermitted_long(const int taskID, const long value) const;
00202
00204         bool isPermitted_double(const int taskID, const double value) const;
00205
00207         bool isPermitted_string(const int taskID, const std::string value) const;
00208
00210         bool isFastaPermitted(const std::string database) const;
00211
00213         bool canResultsFileBeViewed(const int userID) const;
00214
00216         bool saveStringParam(const std::string name, const std::string param);
00217
00219         bool saveIntParam(const std::string name, int param);
00220
00222         bool saveLongParam(const std::string name, long param);
00223
00225         bool saveTimeParam(const std::string name, time_t param);
00226
00228         bool saveDoubleParam(const std::string name, double param);
00229
00231         bool saveBoolParam(const std::string name, bool param);
00232
00233 #ifndef SWIG
00234
00235         bool getStringParam(const std::string name, std::string & param) const;
00236 #endif
00237
00238         std::string getStringParam(const std::string name) const;
00239
00241         bool getIntParam(const std::string name, int & param) const;
00242
00244         int getIntParam(const std::string name) const;
00245
00247         bool getLongParam(const std::string name, long & param) const;
00248
00250         long getLongParam(const std::string name) const;
00251
00253         bool getTimeParam(const std::string name, time_t & param) const;
00254
00256         time_t getTimeParam(const std::string name) const;
00257
00259         bool getDoubleParam(const std::string name, double & param) const;
00260
00262         double getDoubleParam(const std::string name) const;
00263
00265         bool getBoolParam(const std::string name, bool & param) const;
00266
00268         bool clearParam(const std::string name);
00269
00271         bool destroy();
00272
00274         bool isTimedOut() const;
00275
00277         matrix_science::ms_user::usertype getUserType() const;
00278
00280         bool update(const ms_security & sec);
00281
00283         std::vector<int> getSpoofableUsers() const;
00284
00285     private:
00286         typedef std::map<std::string, std::string> param_t;
00287         std::string sessionID_;
00288         param_t  params_;
00289         param_t  customParams_;
00290         typedef std::set<std::string> cpIdentifier_t;
00291         cpIdentifier_t systemIdentifiers_;
00292         ms_security_tasks permittedTasks_;
00293         bool saveParamShouldSaveFile_;
00294         bool allowParamAndFileSaving_;
00295
00296         void init();
00297         bool loadSessionFromFile(const ms_security * const sec);
00298         bool saveSessionToFile(const ms_security * const sec);
00299         void setDisabledSession(const ms_security_options & opts);
00300         bool setCommandLineSession(const ms_security_options & secOpt);
00301         bool setGuestSession();
00302         bool doesSessionFileExist(const std::string sess);
00303         bool getAllParams(const ms_user & u, const ms_security & sec);
00304         std::string getSessionIDFromUser(const ms_user & user);
00305         std::string getWebSvrAuthSessionID(std::string userName = "");
00306         bool checkIPAddressOrComputerName(const std::string ipAddress,
00307                                           std::string & sessionID);
00308         bool checkAgentString(std::string & sessionID);
00309         bool validateIntegraPassword(const ms_user & u,
00310                                      const ms_security_options & secOpt,
00311                                      const std::string & userPassword,
00312                                      std::string & session_id,
00313                                      int & errorFlag) const;
00314         bool verifyIntegraConnection() const;
00315         bool isSessionIdentical(const ms_session & sess) const;
00316         void copyFrom(const ms_session * src);
00317         void createSessionFromID(const std::string session_id);
00318     }; // end of security_group
00320 }
00321 #endif // !defined(mascot_session_DA3EC794_90F8_4c4f_AD5D_13C3B6971A51__INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security_task.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security_task.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates Mascot security as used in authentication                     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020
00021 #if !defined(ms_sec_task_INCLUDED_)
00022 #define ms_sec_task_INCLUDED_
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <set>
00028 #include <time.h>
00029 #include <vector>
00030
00031 namespace matrix_science {
00032
00037
00038
00050     class MS_MASCOTRESFILE_API ms_security_task
00051     {
00052     public:
00054
00062         enum paramType
00063         {
00064             TYPE_BOOL           = 0x0000,
00065             TYPE_EQ_LONG        = 0x0001,
00066             TYPE_LTE_LONG       = 0x0002,
00067             TYPE_GTE_LONG       = 0x0003,
00068             TYPE_LONG_ARRAY     = 0x0004,
00069             TYPE_EQ_DOUBLE      = 0x0005,
00070             TYPE_LTE_DOUBLE     = 0x0006,
00071             TYPE_GTE_DOUBLE     = 0x0007,
00072             TYPE_DOUBLE_ARRAY   = 0x0008,
00073             TYPE_EQ_STRING      = 0x0009,
00074             TYPE_STRING_ARRAY   = 0x000A,
00075             TYPE_USERS_ARRAY    = 0x000B,
00076             TYPE_ALL_USERS_ARRAY= 0x000C
00077         };
00078
00080         ms_security_task();
00081
00083         ~ms_security_task();
00084
00085         // Copying constructor for c++ programs - don't document
00086         ms_security_task(const ms_security_task& src);
00087
00088 #ifndef SWIG
00089         // Assignment operator for c++ programs - don't document
00090         ms_security_task& operator=(const ms_security_task& right);
00091 #endif
00092
00093         int getID() const;
00094
00096         void setID(const int id);
00097
00099         std::string getConstantName() const;
00100
00101         void setConstantName(const std::string value);
00102
00104         std::string getNotes() const;
00105
00106         void setNotes(const std::string value);
00107
00109         std::string getDescription() const;
00110
00111         void setDescription(const std::string value);
00112
00114         paramType getType() const;
00115
00116         void setType(const paramType value);
00117
00119         void clearParams();
00120
00122         void setParams(const std::string value);
00123
00125         bool addLongParam(const long value);
00126
00128         bool addDoubleParam(const double value);
00129
00131         bool addStringParam(const std::string value);
00132
00134         std::vector<long> getLongParams() const;
00135
00137         std::vector<double> getDoubleParams() const;
00138
00140         std::vector<std::string> getStringParams() const;
00141
00143         std::string getAllParamsAsString() const;
00144
00146         bool isPermitted() const;
00147
00149         bool isPermitted_long(const long value) const;
00150
00152         bool isPermitted_double(const double value) const;
00153
00155         bool isPermitted_string(const std::string value) const;
00156
00157     private:
00158         int id_;
00159         std::string description_;
00160         std::string notes_;
00161         std::string constantName_;
00162         paramType type_;
00163         std::set<long>           longParams_;
00164         std::set<double>         doubleParams_;
00165         std::set<std::string>    stringParams_;
00166
00167         void copyFrom(const ms_security_task* src);
00168     }; // end of security_group
00170 }
00171
00172 #endif // !defined(ms_sec_task_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security_tasks.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security_tasks.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates Mascot security as used in authentication                     #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: francoisr@matrixscience.com $ #
00013 #       $Date: 2020-01-09 13:44:20 +0000 $ #
00014 #   $Revision: 8f2eed45ceb9f62bfae7c1eaa2c043cac1d9f802 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020
00021 #if !defined(ms_security_tasks_INCLUDED_)
00022 #define ms_security_tasks_INCLUDED_
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <map>
00028 #include <time.h>
00029 #include <vector>
00030
00031 namespace matrix_science {
00032
00037
00038
00050     class MS_MASCOTRESFILE_API ms_security_tasks: public ms_errors
00051     {
00052     public:
00054
00063         enum TASKID
00064         {
00065             SECTASK_ALLOWPMF                =  1,
00066             SECTASK_ALLOWMSMS               =  2,
00067             SECTASK_ALLOWMSMSNOENZYME       =  3,
00068             SECTASK_ALLOWPMFNOENZYME        =  4,
00069             SECTASK_MAXCONCURRENTSEARCHES   =  5,
00070             SECTASK_MAXJOBPRIORITY          =  6,
00071             SECTASK_MAXQUERIES              =  7,
00072             SECTASK_MAXEXECUTIONTIME        =  8,
00073             SECTASK_ALLFASTA                =  9,
00074             SECTASK_NAMEDFASTA              = 10,
00075             SECTASK_MAXVARMODS              = 11,
00076             SECTASK_MAXETVARMODS            = 12,
00077
00078             SECTASK_SEESEARCHINGROUP        = 13,
00079             SECTASK_SEEALLSEARCHESWITHUSERID= 14,
00080             SECTASK_SEEOLDSEARCHES          = 15,
00081             SECTASK_USEMSREVIEWEXE          = 16,
00082
00083             SECTASK_VIEWCONFIGUSINGMSSTATUS = 17,
00084             SECTASK_MODIFYOWNPROFILE        = 18,
00085
00086             SECTASK_DAEMONCLIENT            = 19,
00087             SECTASK_DISTILLERCLIENT         = 20,
00088             SECTASK_ALLOWSPOOFOTHERUSER     = 22,
00089             SECTASK_INTEGRASYSTEMACCOUNT    = 23,
00090             SECTASK_BIOTOOLSBATCH           = 24,
00091             SECTASK_SPOOFNAMEDGROUPSONLY    = 25,
00092             SECTASK_DOWNLOAD_DISTILLER_XML  = 26,
00093             SECTASK_UPLOAD_DISTILLER_XML    = 27,
00094
00095             SECTASK_ADMINPAGES              = 30,
00096             SECTASK_ACCESSDBSETUP           = 31,
00097             SECTASK_USEMSSTATUSEXE          = 32,
00098             SECTASK_MSSTATUSEXECLUSTER      = 33,
00099             SECTASK_MSSTATUSEXERETRYDB      = 34,
00100             SECTASK_KILLTASKINGROUP         = 35,
00101             SECTASK_KILLALLTASK             = 36,
00102             SECTASK_VIEWCONFIG              = 37,
00103             SECTASK_EDITCONFIG              = 38,
00104
00105             SECTASK_MAXETACCESSIONS         = 50,
00106             SECTASK_MAXNOENZQUERIES         = 51,
00107             SECTASK_MAXFASTAFILES           = 52,
00108             SECTASK_DENYQUANT               = 53,
00109             SECTASK_DATAURLPROTOCOLS        = 54,
00110             SECTASK_DATAURLMAXSIZE          = 55,
00111
00112             SECTASK_SEESEARCHINANYGROUP     = 60,
00113
00114             MISECTASK_ACCESS                =100,
00115             MISECTASK_PROTEINAPPROVAL       =101,
00116             MISECTASK_ADDIMPORTFILTER       =102,
00117             MISECTASK_ADMIN                 =103,
00118             MISECTASK_ADDCUSTOMREPORT       =104,
00119             MISECTASK_DELETECUSTOMREPORT    =105,
00120             MISECTASK_ADDEXCLUSIONFILE      =106,
00121             MISECTASK_DELETEEXCLUSIONFILE   =107,
00122             MISECTASK_SENDNOTIFICATION      =108
00123         };
00124
00126         ms_security_tasks();
00127
00129         ~ms_security_tasks();
00130
00131         // Copying constructor for c++ programs - don't document
00132         ms_security_tasks(const ms_security_tasks& src);
00133
00135         ms_security_tasks(const char * filename);
00136
00137 #ifndef SWIG
00138         // Assignment operator for c++ programs - don't document
00139         ms_security_tasks& operator=(const ms_security_tasks& right);
00140 #endif
00141
00142         bool loadFromFile(const char * filename);
00143
00145         bool saveToFile(const char * filename);
00146
00148         bool addTask(const ms_security_task & task);
00149
00151         bool removeTask(const int taskID);
00152
00154         void removeAllTasks();
00155
00157         bool isPermitted(const int taskID) const;
00158
00160         bool isPermitted_long(const int taskID, const long value) const;
00161
00163         bool isPermitted_double(const int taskID, const double value) const;
00164
00166         bool isPermitted_string(const int taskID, const std::string value) const;
00167
00169         bool isFastaPermitted(const std::string database) const;
00170
00172         int getNumberOfTasks() const;
00173
00175         ms_security_task getTask(const int num) const;
00176
00178         ms_security_task getTaskFromID(const int taskID) const;
00179
00181         bool isTaskExists(const int taskID) const;
00182
00184         bool updateTask(const ms_security_task & task);
00185 #ifndef SWIG
00186         ms_security_tasks & operator+=(const ms_security_tasks & a);
00187 #endif
00188
00189         std::string getDiffsAsText(const ms_security_tasks & old);
00190
00191         // Don't document
00192         void updateAllUsersTasks(const std::set<int> & allUsers);
00193
00194     private:
00195         typedef std::map<int, ms_security_task> tasksSet;
00196         tasksSet    tasks_;
00197
00198         void copyFrom(const ms_security_tasks* src);
00199     }; // end of security_group
00201
00202 }
00203
00204 #endif // !defined(ms_security_tasks_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_security_user.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_security_user.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates a mascot user as used in authentication                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019
00020
00021 #if !defined(ms_security_user_INCLUDED_)
00022 #define ms_security_user_INCLUDED_
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <set>
00028 #include <vector>
00029 #include <map>
00030 #include <time.h>
00031
00032
00033 namespace matrix_science {
00038
00039
00048     class MS_MASCOTRESFILE_API ms_user
00049     {
00050
00051     public:
00053
00056         enum usertype
00057         {
00058             USER_SECURITY_DISABLED  = 0x0000,
00059             USER_NORMAL             = 0x0001,
00060             USER_INTEGRA            = 0x0002,
00061             USER_COMPUTER_NAME      = 0x0003,
00062             USER_IP_ADDRESS         = 0x0004,
00063             USER_AGENT_STRING       = 0x0005,
00064             USER_WEBAUTH            = 0x0006
00065         };
00066
00068
00071         enum systemids
00072         {
00073             USERID_SECURITY_DISABLED= 0x0000,
00074             USERID_GUEST            = 0x0001,
00075             USERID_ADMINISTRATOR    = 0x0002,
00076             USERID_CMDLINE          = 0x0003,
00077             USERID_DAEMON           = 0x0004,
00078             USERID_PUBLIC_SEARCHES  = 0x0005,
00079             USERID_INTEGRA_SYSTEM   = 0x0006,
00080             USERID_LAST             = 0x0007
00081         };
00082
00084         ms_user(const int         userID,
00085                 const std::string userName,
00086                 const std::string password,
00087                 const long        passwordExpiry,
00088                 const std::string fullName,
00089                 const std::string emailAddress,
00090                 const usertype    userType,
00091                 const bool        enabled);
00092
00094         ms_user();
00095
00096         // Copying constructor for c++ programs - don't document
00097         ms_user(const ms_user &src);
00098
00099 #ifndef SWIG
00100         // Assignment operator for c++ programs - don't document
00101         ms_user & operator=(const ms_user & right);
00102 #endif
00103         ~ms_user();
00104
00106         usertype  getUserType() const;
00107
00109         void setUserType(usertype newVal);
00110
00112         std::string getFullName() const;
00113
00115         void setFullName(std::string newVal);
00116
00118         std::string getEncryptedPassword() const;
00119
00121         void setEncryptedPassword(std::string newVal);
00122
00124         void setPassword(std::string barePassword);
00125
00127         bool validatePassword(const std::string pwd, int & errorFlag) const;
00128
00130         time_t getPasswordExpiry() const;
00131
00133         void setPasswordExpiry(time_t newVal);
00134
00136         int getID() const;
00137
00139         void setID(int newVal);
00140
00142         std::string getName() const;
00143
00145         void setName(std::string newVal);
00146
00148         bool isAccountEnabled() const;
00149
00151         void setAccountEnabled(bool newVal);
00152
00154         std::string getEmailAddress() const;
00155
00157         void setEmailAddress(std::string newVal);
00158
00160         bool hasPasswordExpired() const;
00161
00163         bool saveStringParam(const std::string name, const std::string param);
00164
00165 #ifndef SWIG
00166
00167         bool getStringParam(const std::string name, std::string & param) const;
00168 #endif
00169
00171         std::string getStringParam(const std::string name) const;
00172
00174         bool clearParam(const std::string name);
00175
00176 #ifndef SWIG
00177 #ifndef DOXYGEN_SHOULD_SKIP_THIS
00178         typedef std::map<std::string, std::string> customParams_t;
00179         customParams_t getAllCustomParams() const { return params_; }
00180 #endif
00181 #endif
00182
00183     private:
00184         int userID_;
00185         std::string userName_;
00186         std::string fullName_;
00187         std::string encryptedPassword_;
00188         time_t  passwordExpiry_;
00189         std::string emailAddress_;
00190         bool accountEnabled_;
00191         usertype userType_;
00192         customParams_t params_;
00193
00194         void copyFrom(const ms_user * src);
00195     }; // end of security_group
00197 }
00198 #endif // !defined(ms_security_user_INCLUDED_)
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_shapiro_wilk.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_shapiro_wilk.hpp                                                  #
00004 # Mascot Parser toolkit                                                      #
00005 # Include file for Shapiro-Wilk W test (statistical algorithm)               #
00006 ##############################################################################
00007 #    $Source: parser/inc/ms_shapiro_wilk.hpp $
00008 #    $Author: villek@matrixscience.com $
00009 #      $Date: 2018-07-30 16:23:53 +0100 $
00010 #  $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00011 ##############################################################################
00012 */
00013 /*
00014 ##############################################################################
00015 # Applied Statistics algorithms                                              #
00016 #                                                                            #
00017 # Translated and adapted from routines that originally appeared in the       #
00018 # Journal of the Royal Statistical Society Series C (Applied Statistics)     #
00019 # and made available through StatLib http://lib.stat.cmu.edu/                #
00020 #                                                                            #
00021 # The implementation and source code for this algorithm is available as a    #
00022 # free download from http://www.matrixscience.com/msparser.html              #
00023 # to conform with the requirement that no fee is charged for their use       #
00024 ##############################################################################
00025 */
00026
00027
00028 #ifndef MS_SHAPIRO_WILK_HPP
00029 #define MS_SHAPIRO_WILK_HPP
00030
00031
00032 // Includes from the standard template library
00033 #include <string>
00034 #include <deque>
00035 #include <list>
00036 #include <vector>
00037 #include <set>
00038 #include <map>
00039
00040 namespace matrix_science {
00041     class ms_quant_stats;
00042
00049
00050
00095     class MS_MASCOTRESFILE_API ms_shapiro_wilk
00096     {
00097     public:
00098         ms_shapiro_wilk();
00099         ~ms_shapiro_wilk();
00100
00102         ms_shapiro_wilk(std::deque<std::pair<size_t,double> > x, long n, long n1, long n2);
00103
00105         void calculate(long n, long n1, long n2);
00106
00108         void appendSampleValue(double y);
00109
00111         void clearSampleValues();
00112
00114         double getResult() const;
00115
00117         double getPValue() const;
00118
00120         double getErrorCode() const;
00121
00122     private:
00123         bool   init_;
00124         double w_;       // The Shapiro-Wilks W-statistic.
00125         double pw_;      // the P-value for w
00126         int    ifault_;  // error indicator
00127         std::deque<double> a_;
00128         std::deque<std::pair<size_t,double> > x_;
00129
00130     public:
00132         static void swilk(bool init, std::deque<std::pair<size_t,double> > x, long n, long n1, long n2, std::deque<double> &a, double &w, double &pw, int &ifault);
00133
00134     private:
00136         static double poly(const double *cc, int nord, double x);
00138         static double ppnd7(double p,int &ifault);
00140         static double alnorm(double x,bool upper);
00141
00142         static long sign(long x,long y);
00143     };
00144  // end of quantitation_group
00146 } // matrix_science
00147
00148
00149 #endif // MS_SHAPIRO_WILK_HPP
00150 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_spectral_lib_entry.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_spectral_lib_entry.hpp                                            #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates a single entry from a spectral library file                   #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 2015 Matrix Science Limited  All Rights Reserved.                #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Source: parser/inc/ms_spectral_lib_entry.hpp $
00013 #    $Author: francoisr@matrixscience.com $
00014 #      $Date: 2021-05-27 10:03:04 +0100 $
00015 #  $Revision: a47aab4c911db687b9c37e6e2e3e9b23174da535 | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_SPECTRAL_LIB_ENTRY
00020 #define MS_SPECTRAL_LIB_ENTRY
00021
00022
00023 // Includes from the standard template library
00024
00025 #include <map>
00026 #include <string>
00027
00028
00029 namespace matrix_science {
00030
00037
00038
00067     class MS_MASCOTRESFILE_API ms_spectral_lib_entry : public ms_errors
00068     {
00069     public:
00071
00076         enum WHAT_TO_ANNOTATE {
00077             ANNOTATE_NONE,
00078             ANNOTATE_REPLACE_ALL,
00079             ANNOTATE_REPLACE_QUESTION_MARKS,
00080             ANNOTATE_REPLACE_IF_ALL_EMPTY
00081         };
00082
00084         ms_spectral_lib_entry();
00085
00087         ms_spectral_lib_entry(const ms_spectral_lib_entry & src);
00088
00090         ms_spectral_lib_entry(const std::string & entry, const std::string & fileName, const ms_spectral_lib::FILE_FORMAT format);
00091
00093         ms_spectral_lib_entry(const std::vector<std::string> & entry, const std::string & fileName, const ms_spectral_lib::FILE_FORMAT format);
00094
00096         virtual ~ms_spectral_lib_entry();
00097
00099         void copyFrom(const ms_spectral_lib_entry* right);
00100
00101 #ifndef SWIG
00102
00103         ms_spectral_lib_entry& operator=(const ms_spectral_lib_entry& right);
00104 #endif
00105
00107         const std::string get() const;
00108
00110         std::string getLine(const char * key) const;
00111
00113         std::string getName() const;
00114
00116         double getPrecursorMZ() const;
00117
00119         int getCharge() const;
00120
00122         std::string getSequence() const;
00123
00125         std::string getComment() const;
00126
00128          std::string getCommentField(const char * fieldName) const;
00129
00131         int getMods(std::vector<std::string> & names,
00132                     std::vector<int>         & positions) const;
00133
00135         int getMods(std::vector<std::string> & names,
00136                     std::vector<int>         & positions,
00137                     bool                     & anyModfileStyleName,
00138                     std::string              & modsWithoutSpecificities) const;
00139
00141         int getNumPeaks() const;
00142
00144         double getMW() const;
00145
00147         std::vector<std::string> getPeakList(bool convertToNISTformat = false) const;
00148
00150         matrix_science::ms_spectral_lib_peak_list getPeakListObject() const;
00151
00153         std::string getPeakListChecksum() const;
00154
00156         std::string getFileName() const;
00157
00159         bool annotatePeaks(const WHAT_TO_ANNOTATE whatToAnnotate, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, const ms_umod_configfile * unimod = 0);
00160
00162         void clearAnnotation();
00163
00164     private:
00165         bool parseLines(const std::vector<std::string> & lines);
00166         bool parseMSPLines(const std::vector<std::string> & lines, ms_spectral_lib::FILE_FORMAT format);
00167         bool parseXHunterLines(const std::vector<std::string> & lines);
00168
00169         typedef std::map<std::string, std::string> values_t;
00170         values_t values_;
00171         std::vector<std::string> originalLines_;
00172         ms_spectral_lib_peak_list peakList_;
00173         ms_spectral_lib::FILE_FORMAT format_;
00174         std::string fileName_;
00175     }; // class ms_spectral_lib_entry
00176  // end of tools_group
00178 } // namespace matrix_science
00179
00180 #endif // MS_SPECTRAL_LIB_ENTRY
00181
00182 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_spectral_lib_file.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_nist_msp.hpp                                                      #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates spectral library files (e.g. msp, sptext)                     #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 2015 Matrix Science Limited  All Rights Reserved.                #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Source: parser/inc/ms_spectral_lib_file.hpp $
00013 #    $Author: dcreasy@matrixscience.com $
00014 #      $Date: 2019-10-23 11:32:40 +0100 $
00015 #  $Revision: e1e932b0e014aa84a197578948d47baeca33fd07 | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_SPECTRAL_LIB_FILE
00020 #define MS_SPECTRAL_LIB_FILE
00021
00022
00023 // Includes from the standard template library
00024
00025 #include <map>
00026 #include <set>
00027 #include <string>
00028
00029
00030 namespace matrix_science {
00031
00037
00038
00065     class MS_MASCOTRESFILE_API ms_spectral_lib_file : public ms_errors
00066     {
00067     public:
00069         ms_spectral_lib_file(const char * fileName, const char * regexForAccession, const char * cdbFileName = 0);
00070
00071 #ifndef SWIG
00072
00073         ms_spectral_lib_file(const char * fileName, const char * regexForAccession, const char * cdbFileName, const std::map<std::string, std::string> & modificationAliases);
00074 #endif
00075
00077         ~ms_spectral_lib_file();
00078
00080         int getNumEntries() const;
00081
00083         int getNumResidues() const;
00084
00086         std::vector<int> findEntries(const char * sequence, const char * checksum = 0, const char * accession = 0, const char * mods=0) const;
00087
00089         ms_spectral_lib_entry getEntryFromNumber(const int number) const;
00090
00092         std::vector<std::string> getEntryFromNumberAsText(const int number) const;
00093
00094
00096         std::string getAccessionFromNumber(const int number) const;
00097
00099         std::string getChecksumFromNumber(const int number) const;
00100
00102         std::string getSequenceFromNumber(const int number) const;
00103
00105         std::string getModsFromNumber(const int number) const;
00106
00108         double getPrecursorMZFromNumber(const int number) const;
00109
00111         int getPrecursorChargeFromNumber(const int number) const;
00112
00114         std::vector<std::string> getAllMods() const;
00115
00117         ms_spectral_lib::FILE_FORMAT getFormat() const;
00118
00120         bool saveAs(const char * fileName,
00121                     const bool   replaceProteinName  = true,
00122                     ms_spectral_lib::FILE_FORMAT fileFormat = ms_spectral_lib::FORMAT_NIST_MSP,
00123                     const int    startNumber = 1,
00124                     const int    endNumber = -1,
00125                     const ms_spectral_lib_entry::WHAT_TO_ANNOTATE whatToAnnotate = ms_spectral_lib_entry::ANNOTATE_REPLACE_QUESTION_MARKS,
00126                     const double annotateTol = 0.6,
00127                     const char * annotateTolu = "Da",
00128                     const ms_umod_configfile * unimod = 0) const;
00129
00131         std::string getStatsInformation() const;
00132
00134         std::string getFileName() const;
00135
00137         long getQmatch(double minMz, double maxMz) const;
00138
00140         bool verifyThatModsAreInUnimod(const ms_umod_configfile & unimod);
00141
00142     private:
00143         //Do not copy this object
00144         ms_spectral_lib_file(const ms_spectral_lib_file & src);
00145         ms_spectral_lib_file& operator=(const ms_spectral_lib_file & right);
00146
00147         struct sequentialIndex_t {
00148             std::string accession;
00149             std::string checksum;
00150             std::string sequence;
00151             std::string mods;
00152             double      precursorMZ;
00153             int         precursorCharge;
00154             OFFSET64_T  fileOffset;
00155         };
00156         void initialise(const char * fileName, const char * regexForAccession, const char * cdbFileName, const std::map<std::string, std::string> & aliases);
00157         bool readFile(int recordNumber) const;
00158         void getline(std::string & str) const;
00159         ms_errs::err getEntryAsText(const int number, std::vector<std::string> & lines, std::string & errorMsg) const;
00160
00161         void saveIndexes(const  ms_spectral_lib_entry & msp,
00162                          const  OFFSET64_T          fileOffset);
00163         OFFSET64_T getFileOffsetFromId(int number) const;
00164         const char * getSpectrumDelimiter() const;
00165
00166         int applyModAliases(const std::map<std::string, std::string> & aliases);
00167         void replaceModAliases(std::string & comment, const ms_spectral_lib_entry & spect) const;
00168
00169         // the following are always valid - with or without a cdb file
00170                 std::string  fileName_;
00171         mutable int          numEntries_;  // May be less than the total in the file if it's being read on demand
00172         mutable int          numResidues_; // May be less than the total in the file if it's being read on demand
00173                 ms_parserule parseRule_;
00174         mutable bool         wholeFileRead_;
00175                 FILE       * ifs_;
00176         mutable ms_spectral_lib::FILE_FORMAT  fileFormat_;
00177
00178         // the following are valid when creating or using the cdb file
00179         ms_tinycdb * cdb_;
00180
00181         // the following are only valid when no cdb specified *or* when *first creating* the cdb file
00182         mutable OFFSET64_T offsetToNextRecord_;
00183         typedef std::map<std::string, std::vector<int> > strLookup_t;  // e.g. sequence => vector of spectra
00184         std::vector<strLookup_t> lookup_;
00185         std::vector<sequentialIndex_t> sequentialIndex_;
00186         typedef std::map<std::string, std::string> modMap_t;  // nameInMsp => nameInUnimod (or empty if no alias)
00187         mutable modMap_t modsMap_;
00188
00189         typedef std::multiset<double> precursors_t;
00190         mutable precursors_t precursors_;
00191
00192     }; // class ms_spectral_lib_file
00193  // end of tools_group
00195 } // namespace matrix_science
00196
00197 #endif // MS_SPECTRAL_LIB_FILE
00198
00199 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_spectral_lib_peak.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_spectral_lib_peak_list.hpp                                        #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates a single peak plus annotations for spectral library files     #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 2015 Matrix Science Limited  All Rights Reserved.                #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Source: parser/inc/ms_spectral_lib_peak.hpp $
00013 #    $Author: dcreasy@matrixscience.com $
00014 #      $Date: 2019-01-09 17:36:22 +0000 $
00015 #  $Revision: 8cb0d9cae7732a8c4def8cb60456be4a3be7a559 | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_SPECTRAL_LIB_PEAK
00020 #define MS_SPECTRAL_LIB_PEAK
00021
00022
00023 // Includes from the standard template library
00024
00025 #include <map>
00026 #include <string>
00027
00028
00029 namespace matrix_science {
00030
00040     namespace ms_spectral_lib {
00048         enum FILE_FORMAT {
00049             FORMAT_UNKNOWN,
00050             FORMAT_NIST_MSP,
00051             FORMAT_SPECTRAST,
00052             FORMAT_MGF,
00053             FORMAT_XHUNTER
00054         };
00055     };
00056
00058     class MS_MASCOTRESFILE_API ms_spectral_lib_peak
00059     {
00060     public:
00062         ms_spectral_lib_peak(const std::string & text,
00063                              ms_spectral_lib::FILE_FORMAT format,
00064                              matrix_science::ms_errs & errs);
00065
00067         ms_spectral_lib_peak(const double mz,
00068                              const double intensity,
00069                              const std::string & annotation,
00070                              ms_spectral_lib::FILE_FORMAT format);
00071
00073         ms_spectral_lib_peak(const ms_spectral_lib_peak & src);
00074
00076         void copyFrom(const ms_spectral_lib_peak* right);
00077
00078 #ifndef SWIG
00079
00080         ms_spectral_lib_peak& operator=(const ms_spectral_lib_peak& right);
00081 #endif
00082
00084         double getMz() const;
00085
00087         double getIntensity() const;
00088
00090         std::string getAnnotation(ms_spectral_lib::FILE_FORMAT format = ms_spectral_lib::FORMAT_NIST_MSP) const;
00091
00093         void setAnnotation(const std::string & annotation, ms_spectral_lib::FILE_FORMAT format);
00094
00096         void clearAnnotation();
00097
00099         double getDelta() const;
00100
00102         bool isMatchedToCalculatedPeak() const;
00103
00105         bool isSuspectAssignment() const;
00106
00108         bool getConsensusData(int * numerator, int * denominator, double * medianDeviation) const;
00109
00111         std::string asText(ms_spectral_lib::FILE_FORMAT format) const;
00112
00114         bool isValid() const;
00115
00117         static std::string getUnmatchedAnnotationStr(ms_spectral_lib::FILE_FORMAT format);
00118
00119
00120     private:
00121         bool            valid_;
00122         double          mz_;
00123         double          intensity_;
00124         std::string     mzText_;
00125         std::string     intensityText_;
00126         std::string     annotation_;
00127         ms_spectral_lib::FILE_FORMAT  currAnnotationFormat_;
00128         double          delta_;
00129         bool            consensusDataAvailable_;
00130         int             consensusNumerator_;
00131         int             consensusDenominator_;
00132         double          medianDeviationOfConsensusPeaks_;
00133     };
00134
00135  // end of tools_group
00137 } // namespace matrix_science
00138
00139 #endif // MS_SPECTRAL_LIB_PEAK
00140
00141 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_spectral_lib_peak_list.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_spectral_lib_peak_list.hpp                                        #
00004 # Mascot Parser toolkit                                                      #
00005 # Encapsulates peak lists for spectral library files (e.g. msp, sptext)      #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 2015 Matrix Science Limited  All Rights Reserved.                #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Source: parser/inc/ms_spectral_lib_peak_list.hpp $
00013 #    $Author: villek@matrixscience.com $
00014 #      $Date: 2018-07-30 16:23:53 +0100 $
00015 #  $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_SPECTRAL_LIB_PEAK_LIST
00020 #define MS_SPECTRAL_LIB_PEAK_LIST
00021
00022
00023 // Includes from the standard template library
00024
00025 #include <vector>
00026 #include <map>
00027 #include <string>
00028
00029
00030 namespace matrix_science {
00031
00037
00038     class MS_MASCOTRESFILE_API ms_spectral_lib_peak_list : public ms_errors
00039     {
00040     public:
00042
00049         enum PEAK_ANNOTATION_LEVEL {
00050             ANNOT_LVL_NONE,
00051             ANNOT_LVL_QUESTION_MARKS,
00052             ANNOT_LVL_SOME_PEAKS,
00053             ANNOT_LVL_CANNOT_ANNOTATE,
00054         };
00056         ms_spectral_lib_peak_list();
00057
00059         ~ms_spectral_lib_peak_list();
00060
00062         ms_spectral_lib_peak_list(std::vector<std::string> input, ms_spectral_lib::FILE_FORMAT format);
00063
00065         ms_spectral_lib_peak_list(const ms_spectral_lib_peak_list & src);
00066
00068         void copyFrom(const ms_spectral_lib_peak_list* right);
00069
00070 #ifndef SWIG
00071
00072         ms_spectral_lib_peak_list& operator=(const ms_spectral_lib_peak_list& right);
00073 #endif
00074
00075         int getNumPeaks() const;
00076
00078         const ms_spectral_lib_peak * getPeak(const int pkNum) const;
00079
00081         void addPeaks(const std::vector<double> &vecMz, const std::vector<double> &vecIntensity);
00082
00084         void annotatePeaks(const ms_fragmentvector *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz);
00085
00086 #ifndef SWIG
00087
00088         void annotatePeaks(const std::vector<ms_fragment> *fragments, const double fragmentToleranceValue, const std::string fragmentToleranceUnit, double precursorMz);
00089 #endif
00090
00092         void clearAnnotation();
00093
00095         PEAK_ANNOTATION_LEVEL getPeakAnnotationLevel() const;
00096
00098         std::vector<std::string> asText(ms_spectral_lib::FILE_FORMAT format) const;
00099
00101         std::string getChecksum() const;
00102
00104         void setAnnotationLevel(PEAK_ANNOTATION_LEVEL level);
00105
00106     private:
00107         void setAnnotationLevel(const ms_spectral_lib_peak & pk);
00108
00109         std::vector<ms_spectral_lib_peak> peakList_;
00110         bool isConsensusSpectrum_;
00111         PEAK_ANNOTATION_LEVEL annotationLevel_;
00112         std::string checksum_;
00113     };
00114
00115  // end of tools_group
00117 } // namespace matrix_science
00118
00119 #endif // MS_SPECTRAL_LIB_PEAK_LIST
00120
00121 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_taxonomyfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_taxonomyfile.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "taxonomy"-file that available taxonomy choices               #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_taxonomyfile.hpp        $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_TAXONOMYFILE_HPP
00020 #define MS_TAXONOMYFILE_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026 namespace matrix_science {
00032
00033
00048     class MS_MASCOTRESFILE_API ms_taxonomychoice: public ms_customproperty
00049     {
00050         friend class ms_taxonomyfile;
00051     public:
00052
00054         ms_taxonomychoice();
00055
00057         ms_taxonomychoice(const ms_taxonomychoice& src);
00058
00060         ~ms_taxonomychoice();
00061
00063         void defaultValues();
00064
00066         void copyFrom(const ms_taxonomychoice* src);
00067
00068 #ifndef SWIG
00069
00070         ms_taxonomychoice& operator=(const ms_taxonomychoice& right);
00071 #endif
00072
00073         std::string getTitle() const;
00074
00076         void setTitle(const char* value);
00077
00079         int getNumberOfIncludeTaxonomies() const;
00080
00082         int getIncludeTaxonomy(const int n) const;
00083
00085         void clearIncludeTaxonomies();
00086
00088         void appendIncludeTaxonomy(const int id);
00089
00091         int getNumberOfExcludeTaxonomies() const;
00092
00094         int getExcludeTaxonomy(const int n) const;
00095
00097         void clearExcludeTaxonomies();
00098
00100         void appendExcludeTaxonomy(const int id);
00101
00102 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00103 #include "suppress_ms_customproperty.hpp"
00104 #endif
00105
00106     private:
00107         void setCustomProperty();
00108
00109     private:
00110         std::string title;
00111
00112         std::vector< int > includeList;
00113         std::vector< int > excludeList;
00114     }; // ms_taxonomychoice
00115
00116     class ms_filesource;
00117
00119
00144     class MS_MASCOTRESFILE_API ms_taxonomyfile: public ms_errors
00145     {
00146     public:
00148         ms_taxonomyfile();
00149
00151         ms_taxonomyfile(const ms_taxonomyfile& src);
00152
00154         ms_taxonomyfile(const char* filename, const matrix_science::ms_connection_settings * cs = 0);
00155
00157         ~ms_taxonomyfile();
00158
00160         void defaultValues();
00161
00163         void copyFrom(const ms_taxonomyfile* right);
00164
00165 #ifndef SWIG
00166
00167         ms_taxonomyfile& operator=(const ms_taxonomyfile& right);
00168 #endif
00169
00170         void setFileName(const char* name);
00171
00173         std::string getFileName() const;
00174
00176
00180         void setConnectionSettings(const matrix_science::ms_connection_settings & cs);
00181
00183
00186         matrix_science::ms_connection_settings getConnectionSettings() const;
00187
00189         void read_file();
00190
00192         void read_buffer(const char* buffer);
00193
00195         void save_file();
00196
00198         int getNumberOfEntries() const;
00199
00201         void clearEntries();
00202
00204         void appendEntry(const ms_taxonomychoice* item);
00205
00207         const ms_taxonomychoice * getEntryByNumber(const int index) const;
00208
00210         ms_taxonomychoice * getEntryByName(const char* name);
00211
00212     private:
00213         void read_internal(ms_filesource *pFSource);
00214
00215         typedef std::vector<ms_taxonomychoice* > entries_vector;
00216         entries_vector  entries;
00217
00218         std::string     filename_;
00219         std::vector< std::string > comments_;
00220         ms_connection_settings cs_;
00221     }; // ms_taxonomyfile // end of config_group
00223 } // namespace matrix_science
00224
00225 #endif // MS_TAXONOMYFILE_HPP
00226
00227 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_taxonomyrules.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_taxonomyrules.hpp                                                 #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "mascot.dat"-file that describes most important parameters    #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_taxonomyrules.hpp       $ #
00012 #     $Author: francoisr@matrixscience.com $ #
00013 #       $Date: 2022-01-12 12:34:37 +0000 $ #
00014 #   $Revision: b158d77079a10225ce667f6e66a6df8412823ac0 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_TAXONOMYRULES_HPP
00020 #define MS_TAXONOMYRULES_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00038     enum TAX_SPECIES_FORMAT
00039     {
00040         TAX_SPECIES_NCBI,
00041         TAX_SPECIES_SWISSPROT,
00042         TAX_SPECIES_PDB,
00043         TAX_SPECIES_GI2TAXID,
00044         TAX_SPECIES_ACC2TAXID,
00045         TAX_SPECIES_EXPLICIT,
00046         TAX_SPECIES_FORMAT_COUNT        /* Always leave this one last */
00047     };
00048
00050     class MS_MASCOTRESFILE_API ms_taxspeciesfiles
00051     {
00052         friend class ms_datfile;
00053         friend class ms_taxonomyrules;
00054
00055     public:
00057         ms_taxspeciesfiles();
00058
00060         ms_taxspeciesfiles(const ms_taxspeciesfiles& src);
00061
00063         ~ms_taxspeciesfiles();
00064
00066         void defaultValues();
00067
00069         void copyFrom(const ms_taxspeciesfiles* right);
00070
00071 #ifndef SWIG
00072
00073         ms_taxspeciesfiles& operator=(const ms_taxspeciesfiles& right);
00074 #endif
00075
00076         TAX_SPECIES_FORMAT getFormat() const;
00077
00079         void setFormat(const TAX_SPECIES_FORMAT value);
00080
00082         std::string getFileName() const;
00083
00085         void setFileName(const char* name);
00086
00087     private:
00088         TAX_SPECIES_FORMAT  format_;
00089         std::string         filename_;
00090
00091         std::string getStringValue() const;
00092     }; // class ms_taxspeciesfiles
00093
00099     enum TAX_NODE_FORMAT
00100     {
00101         TAX_NODE_NCBI,
00102         TAX_NODE_GENCODE
00103     };
00104
00106
00108     class MS_MASCOTRESFILE_API ms_taxnodesfiles
00109     {
00110         friend class ms_datfile;
00111         friend class ms_taxonomyrules;
00112     public:
00113
00115         ms_taxnodesfiles();
00116
00118         ms_taxnodesfiles(const ms_taxnodesfiles& src);
00119
00121         ~ms_taxnodesfiles();
00122
00124         void defaultValues();
00125
00127         void copyFrom(const ms_taxnodesfiles* right);
00128
00129 #ifndef SWIG
00130
00131         ms_taxnodesfiles& operator=(const ms_taxnodesfiles& right);
00132 #endif
00133
00134         TAX_NODE_FORMAT getFormat() const;
00135
00137         void setFormat(const TAX_NODE_FORMAT value);
00138
00140         std::string getFileName() const;
00141
00143         void setFileName(const char* name);
00144
00145     private:
00146         TAX_NODE_FORMAT format_;
00147         std::string     filename_;
00148         std::string getStringValue() const;
00149     }; // class ms_taxnodesfiles
00150
00152     class MS_MASCOTRESFILE_API ms_parserule_plus
00153     {
00154         friend class ms_datfile;
00155         friend class ms_taxonomyrules;
00156
00157     public:
00159
00162         enum TAX_CHOP_TYPES
00163         {
00164             TAX_CHOP_PREFIX = 0x0001,
00165             TAX_CHOP_SUFFIX = 0x0002,
00166             TAX_CHOP_WORDS  = 0x0004
00167         };
00168
00170         typedef unsigned int TAX_CHOP_SRC;
00171
00173         ms_parserule_plus();
00174
00176         ms_parserule_plus(const ms_parserule_plus& src);
00177
00179         ~ms_parserule_plus();
00180
00182         void defaultValues();
00183
00185         void copyFrom(const ms_parserule_plus* right);
00186
00187 #ifndef SWIG
00188
00189         ms_parserule_plus& operator=(const ms_parserule_plus& right);
00190 #endif
00191
00192         TAX_SPECIES_FORMAT getFileTypeToSearch() const;
00193
00195         void setFileTypeToSearch(const TAX_SPECIES_FORMAT value);
00196
00198         const ms_parserule* getRule() const;
00199
00201         void setRule(const ms_parserule* src);
00202
00204         TAX_CHOP_SRC getChopSource() const;
00205
00207         void setChopSource(const TAX_CHOP_SRC value);
00208
00210         std::string getNameOfDB() const;
00211
00213         void setNameOfDB(const char* name);
00214
00215     private:
00216         TAX_SPECIES_FORMAT  fileTypeToSearch_;
00217         ms_parserule        rule_;
00218         TAX_CHOP_SRC        chopSrc_;
00219         std::string         nameOfDb_;
00220         std::string getStringValue() const;
00221     }; // ms_parserule_plus
00222
00224
00246     class MS_MASCOTRESFILE_API ms_taxonomyrules: public ms_customproperty
00247     {
00248         friend class ms_datfile;
00249
00250     public:
00252         ms_taxonomyrules();
00253
00255         ms_taxonomyrules(const ms_taxonomyrules& src);
00256
00258         ~ms_taxonomyrules();
00259
00261         void defaultValues();
00262
00264         void copyFrom(const ms_taxonomyrules* right);
00265
00266 #ifndef SWIG
00267
00268         ms_taxonomyrules& operator=(const ms_taxonomyrules& right);
00269 #endif
00270
00271         bool isSectionAvailable() const;
00272
00274         void setSectionAvailable(const bool value);
00275
00277         bool isEnabled() const;
00278
00280         void setEnabled(const bool flag);
00281
00283         std::string getIdentifier() const;
00284
00286         void setIdentifier(const char* str);
00287
00289         int getErrorLevel() const;
00290
00292         void setErrorLevel(const int value);
00293
00295         bool isFromRefFile() const;
00296
00298         void setFromRefFile(const bool flag);
00299
00301         bool isConcatRefFileLines() const;
00302
00304         void setConcatRefFileLines(const bool flag);
00305
00307         char getDescriptionLineSep() const;
00308
00310         void setDescriptionLineSep(const char value);
00311
00313         int getNumberOfNoBreakDescLineIf() const;
00314
00316         std::string getNoBreakDescLineIf(const int index) const;
00317
00319         void clearNoBreakDescLineIf();
00320
00322         void appendNoBreakDescLineIf(const char* str);
00323
00325         int getNumberOfSpeciesFiles() const;
00326
00328         const ms_taxspeciesfiles * getSpeciesFile(const int index) const;
00329
00331         void clearSpeciesFiles();
00332
00334         void appendSpeciesFile(const ms_taxspeciesfiles * item);
00335
00336         // no longer in use
00337         int getNumberOfStrFiles() const;
00338         // no longer in use
00339         const ms_taxspeciesfiles * getStrFile(const int index) const;
00340         // no longer in use
00341         void clearStrFiles();
00342         // no longer in use
00343         void appendStrFile(const ms_taxspeciesfiles * item);
00344
00345         // no longer in use
00346         const ms_parserule_plus* getStrRule() const;
00347         // no longer in use
00348         void setStrRule(const ms_parserule_plus* src);
00349
00351         int getNumberOfNodesFiles() const;
00352
00354         const ms_taxnodesfiles * getNodesFile(const int index) const;
00355
00357         void clearNodesFiles();
00358
00360         void appendNodesFile(const ms_taxnodesfiles * item);
00361
00363         int getNumberOfGencodeFiles() const;
00364
00366         const ms_taxnodesfiles * getGencodeFile(const int index) const;
00367
00369         void clearGencodeFiles();
00370
00372         void appendGencodeFile(const ms_taxnodesfiles * item);
00373
00375         const ms_parserule_plus* getDefaultRule() const;
00376
00378         void setDefaultRule(const ms_parserule_plus* src);
00379
00381         int getNumberOfPrefixRemoves() const;
00382
00384         std::string getPrefixRemove(const int index) const;
00385
00387         void clearPrefixRemoves();
00388
00390         void appendPrefixRemove(const char * item);
00391
00393         int getNumberOfSuffixRemoves() const;
00394
00396         std::string getSuffixRemove(const int index) const;
00397
00399         void clearSuffixRemoves();
00400
00402         void appendSuffixRemove(const char * item);
00403
00405         const ms_parserule* getSrcDatabaseRule() const;
00406
00408         void setSrcDatabaseRule(const ms_parserule* src);
00409
00411         int getNumberOfPerDbSrcRules() const;
00412
00414         const ms_parserule_plus * getPerDbSrcRule(const int index) const;
00415
00417         void clearPerDbSrcRules();
00418
00420         void appendPerDbSrcRule(const ms_parserule_plus * item);
00421
00423         const ms_parserule* getDoThisRuleFirst() const;
00424
00426         void setDoThisRuleFirst(const ms_parserule* src);
00427
00429         const ms_parserule* getAccFromSpeciesLine() const;
00430
00432         void setAccFromSpeciesLine(const ms_parserule* src);
00433
00435         std::string getQuickRefSearch() const;
00436
00438         void setQuickRefSearch(const char* str);
00439
00441         int getDBLevelTaxId() const;
00442
00444         void setDBLevelTaxId(const int value);
00445
00447         bool isDBLevelTaxId() const;
00448
00450         void clearDBLevelTaxId();
00451
00453         bool isMitochondrialTranslation() const;
00454
00456         void setMitochondrialTranslation(const bool flag);
00457
00459         std::string getSpeciesFormatRegex(const TAX_SPECIES_FORMAT format) const;
00460
00462         void setSpeciesFormatRegex(const TAX_SPECIES_FORMAT format, const std::string regex);
00463
00464 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00465 #include "suppress_ms_customproperty.hpp"
00466 #endif
00467
00468     private:
00469         bool                sectionAvailable_;
00470         bool                enabled_;
00471         std::string         identifier_;
00472         int                 errorLevel_;
00473         bool                fromRefFile_;
00474         bool                concatRefFileLines_;
00475         char                descriptionLineSep_;
00476
00477         std::vector< std::string > noBreakDescLineIf_;
00478         std::vector< ms_taxspeciesfiles* > speciesFiles_;
00479         std::vector< ms_taxspeciesfiles* > strStrFiles_;
00480         std::vector< ms_taxnodesfiles* > nodesFiles_;
00481         std::vector< ms_taxnodesfiles* > gencodeFiles_;
00482         std::vector< ms_parserule_plus* > perDbSrcRules_;
00483         std::vector< std::string > prefixRemoves_;
00484         std::vector< std::string > suffixRemoves_;
00485         std::vector< std::string > speciesFormatRegex_;
00486
00487         ms_parserule        srcDatabaseRule_;
00488         ms_parserule        doThisRuleFirst_;
00489         ms_parserule        accFromSpeciesLine_;
00490         ms_parserule_plus   defaultRule_;
00491         ms_parserule_plus   strStrRule_;
00492
00493         std::string         quickRefSearch_;
00494         int                 dbLevelTaxId_;
00495         bool                mitochondrialTranslation_;
00496     }; // class ms_taxonomyrules
00497
00498     class ms_tinycdb;
00499     class ms_taxonomychoice;
00500
00502
00540     class MS_MASCOTRESFILE_API ms_taxonomytree : public ms_errors
00541     {
00542     public:
00544         ms_taxonomytree(const ms_taxonomyrules * taxonomyRules,
00545                         const char * taxonomyDirectory = "../taxonomy",
00546                         const bool useIndex = true,
00547                         const bool createList = false,
00548                         const char * preparingDirectory = "../taxonomy/preparing",
00549                         const char * oldDirectory = "../taxonomy/old");
00550
00552         ms_taxonomytree(const ms_taxonomytree & src);
00553
00555         ~ms_taxonomytree();
00556
00558         void copyFrom(const ms_taxonomytree * right);
00559
00560 #ifndef SWIG
00561
00562         ms_taxonomytree& operator=(const ms_taxonomytree & right);
00563
00564         struct TAX_TREE_NODE {
00565             int parentId;
00566             int tableId;
00567         };
00568         typedef std::vector<TAX_TREE_NODE> TAX_TREE_NODES;
00569
00571         TAX_TREE_NODES * getTaxIDArray();
00572 #endif
00573
00575         bool usingIndex() const;
00576
00578         std::string getTaxonomyAndIndexFiles() const;
00579
00581         bool isSpeciesDescendantOf(const int parentID, const int id) const;
00582
00583 #ifndef SWIG
00584
00585         bool getParent(const int id, int & ttParent, int & ttGenTable) const;
00586 #else // SWIG Multiple return values
00587         bool getParent(const int id, int & OUTPUT, int & OUTPUT) const;
00588 #endif
00589
00591         bool isIncludedIn(const int id, const ms_taxonomychoice * choice) const;
00592
00593     private:
00594         bool usingCDB_;
00595         std::vector<ms_taxnodesfiles> files_;
00596         TAX_TREE_NODES nodes_;
00597         std::vector<std::string> fileNames_;
00598         std::vector<ms_tinycdb *> cdbFiles_;
00599
00600         bool readFile(const std::string & filename,
00601                       const bool isMitochondrialTranslation);
00602
00603     };
00604
00605  // end of config_group
00607 } // namespace matrix_science
00608
00609 #endif // MS_TAXONOMYRULES_HPP
00610
00611 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_tinycdb.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_tinycdb.hpp                                                      #
00004 # 'msparser' toolkit                                                         #
00005 # Used internally in Mascot Parser as well as being available externally     #
00006 #                                                                            #
00007 ##############################################################################
00008 # COPYRIGHT NOTICE                                                           #
00009 # Copyright 1998-2009 Matrix Science Limited  All Rights Reserved.           #
00010 #                                                                            #
00011 ##############################################################################
00012 #    $Archive:: /MowseBranches/ms_mascotresfile_1.2/include/ms_mascotresfi $ #
00013 #     $Author: villek@matrixscience.com $ #
00014 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00015 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00016 # $NoKeywords::                                                            $ #
00017 ##############################################################################
00018 */
00019
00020 #ifndef MS_TINYCDB_HPP
00021 #define MS_TINYCDB_HPP
00022
00023
00024
00025 // Includes from the standard template library
00026 #include <string>
00027 #include <vector>
00028
00029 // These values are the key names for special cases
00030 // User defined keys must not begin with "=0."
00031 #define CDBIDX_DUPE_ACCESSION   "=0.1"
00032 #define CDBIDX_VERSION          "=0.2"
00033 #define CDBIDX_FILE_TOO_LARGE   "=0.3"
00034 #define CDBIDX_SRC_FILE_SIZE    "=0.4"
00035 #define CDBIDX_SRC_FILE_DATE    "=0.5"
00036 #define CDBIDX_BUGFIX_10627     "=0.6"
00037
00038
00039 // Need to be a bit less than 2Gb / 4Gb so that we can write the error strings...
00040 #define MAX_CDB_SIZE                 (OFFSET64_C(0xFFFFFFFFFFFF) - OFFSET64_C(0x1000000)) // 281,474,959,933,439 = 256 TB
00041 #define MAX_CDB_SIZE_STR             "256TB"
00042 #define OLD_MAX_CDB_SIZE_STR_4GB     "4Gb"
00043 #define OLD_MAX_32_BIT_CDB_SIZE      (0x7FFFFFFF - 0x1000000)
00044 #define OLD_MAX_32_BIT_CDB_SIZE_STR  "2Gb"
00045
00046
00047 // Forward declarations, so no need to include cdb.h
00048 struct cdb;
00049 struct cdb_make;
00050
00051
00052 namespace matrix_science {
00053
00058
00059
00123     class MS_MASCOTRESFILE_API ms_tinycdb : public ms_errors
00124     {
00125         public:
00127             ms_tinycdb(const char * indexFileName,
00128                        const char * versionNumber,
00129                        const char * sourceFileName);
00130
00132             ~ms_tinycdb();
00133
00134
00136             std::string getIndexFileName() const;
00137
00139             void setIndexFileName(const char * filename);
00140
00142             bool openIndexFile(const bool mayRetryBuilding);
00143
00145             void closeIndexFile();
00146
00148             bool isPossibleToCreate() const;
00149
00151             bool isOpenForReading() const;
00152
00154             bool isCreating() const;
00155
00157             bool prepareToCreate();
00158
00160             bool saveValueForKey(const char * keyName,
00161                                  const char * value,
00162                                  const unsigned int keyNameLen = 0,
00163                                  const unsigned int valueLen = 0);
00164
00166             bool finishCreate();
00167
00169             std::string getValueFromKey(const std::string & keyName, const int count = 0);
00170
00172             std::vector<std::string> getAllValuesFromKey(const std::string & keyName);
00173
00175             OFFSET64_T getFileOffsetFromKey(const std::string & keyName);
00176
00178             bool saveFileOffsetForKey(const std::string & keyName, OFFSET64_T offset);
00179
00181             int getIntFromKey(const std::string & keyName);
00182
00184             int getIntFromKey(const std::string & keyName, bool & found);
00185
00187             bool saveIntForKey(const std::string & keyName, int value);
00188
00190             int makeExists(const char * key) const;
00191
00192
00193         protected:
00194             // Not safe to copy or assign this object.
00195             ms_tinycdb(const ms_tinycdb & rhs);
00196 #ifndef SWIG
00197             ms_tinycdb & operator=(const ms_tinycdb & rhs);
00198 #endif
00199         private:
00200             std::string  indexFileName_;
00201             std::string  versionNumber_;
00202             std::string  sourceFileName_;
00203             bool         isPossibleToCreate_;
00204             int          fdCDB_;
00205             struct cdb      * cdb_;
00206             struct cdb_make * cdbm_;
00207             bool         creatingCDB_;
00208             OFFSET64_T   calcFileSize_;
00209             bool         addKeyErrorReported_;
00210             bool         tooLargeErrorReported_;
00211             bool         cdbInitOK_;
00212
00213             bool lockFile(int hFile);
00214             bool unlockFile(int hFile);
00215     }; // end of tools_group
00217 } // matrix_science
00218
00219 #endif // MS_TINYCDB_HPP
00220
00221 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_treecluster.hpp

00001 /*
00002 ##############################################################################
00003 # File: ms_treecluster.hpp                                                      #
00004 # Mascot Parser toolkit                                                      #
00005 # Utility functions for hierarchical clustering                              #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/ms_treecluster.hpp $
00012 #    $Author: villek@matrixscience.com $
00013 #      $Date: 2019-05-10 10:45:13 +0100 $
00014 #  $Revision: 3770d1f7ee65bb20469e6c0ca909b2045b16fd74 | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 ##############################################################################
00016 */
00017
00018 #ifndef MS_TREECLUSTER_HPP
00019 #define MS_TREECLUSTER_HPP
00020
00021
00022 #include <string>
00023 #include <vector>
00024
00025
00026 namespace matrix_science {
00033
00034
00048     class MS_MASCOTRESFILE_API ms_treecluster: public ms_errors
00049     {
00050     public:
00051
00053
00060         enum TREE_CLUSTER_DISTANCE {
00061             TCD_CORRELATION,
00062             TCD_ABS_CORRELATION,
00063             TCD_UNCENTERED_CORRELATION,
00064             TCD_ABS_UNCENTERED_CORRELATION,
00065             TCD_SPEARMANS_RANK_CORRELATION,
00066             TCD_KENDALLS_TAU_CORRELATION,
00067             TCD_EUCLIDEAN,
00068             TCD_CITY_BLOCK
00069         };
00070
00072         ms_treecluster(int rows, int columns);
00073
00075         ms_treecluster(const ms_treecluster& right);
00076
00078         ~ms_treecluster();
00079
00080 #ifndef SWIG
00081
00082         ms_treecluster& operator=(const ms_treecluster& right);
00083 #endif
00084
00085         void copyFrom(const ms_treecluster* right);
00086
00088         void defaultValues();
00089
00091         bool setRow(int row, std::vector< double > datarow, std::vector< int > maskrow);
00092
00094         bool cluster(TREE_CLUSTER_DISTANCE tcd,
00095                      ms_mascotresults::TREE_CLUSTER_METHOD tcm,
00096                      const std::vector< double > & weight,
00097                      std::vector< int >    &left,
00098                      std::vector< int >    &right,
00099                      std::vector< double > &distance,
00100                      bool transpose = false );
00101
00102     private:
00103         int numRows_;
00104         int numCols_;
00105         double ** data_;
00106         int    ** mask_;
00107
00108         void freeMemory();
00109
00110     }; // ms_treecluster // end of tools_group
00112 } // matrix_science
00113
00114 #endif // MS_TREECLUSTER_HPP
00115
00116 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_aminoacid.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_aminoacid.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Represents 'amino acid' object from unimod.xml file                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_aminoacid.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_AMINOACID_HPP
00018 #define MS_UMOD_AMINOACID_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_umod_elemref; // forward declaration
00032     class ms_xml_schema; // forward declaration
00033
00039
00040     class MS_MASCOTRESFILE_API ms_umod_aminoacid: public ms_xml_IValidatable
00041     {
00042         friend class msparser_internal::ms_umod_xmlloader;
00043         friend class ms_umod_configfile;
00044
00045     public:
00047         ms_umod_aminoacid();
00048
00050         ms_umod_aminoacid(const ms_umod_aminoacid& src);
00051
00053         virtual ~ms_umod_aminoacid();
00054
00056         void defaultValues();
00057
00059         void copyFrom(const ms_umod_aminoacid* right);
00060
00061 #ifndef SWIG
00062
00063         ms_umod_aminoacid& operator=(const ms_umod_aminoacid& right);
00064 #endif
00065
00066         virtual std::string getSchemaType() const;
00067
00069         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00070
00072         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00073
00074
00076         int getNumberOfElemRefs() const;
00077
00079         void clearElemRefs();
00080
00082         void appendElemRef(const ms_umod_elemref *elemref);
00083
00085         const ms_umod_elemref* getElemRef(const int idx) const;
00086
00088         bool updateElemRef(const int idx, const ms_umod_elemref *elemref);
00089
00091         bool deleteElemRef(const int idx);
00092
00094         std::string getElemRefSchemaType() const;
00095
00096
00098         bool haveTitle() const;
00099
00101         std::string getTitle() const;
00102
00104         void setTitle(const char* value);
00105
00107         void dropTitle();
00108
00110         std::string getTitleSchemaType() const;
00111
00112
00114         bool haveThreeLetter() const;
00115
00117         std::string getThreeLetter() const;
00118
00120         void setThreeLetter(const char* value);
00121
00123         void dropThreeLetter();
00124
00126         std::string getThreeLetterSchemaType() const;
00127
00128
00130         bool haveFullName() const;
00131
00133         std::string getFullName() const;
00134
00136         void setFullName(const char* value);
00137
00139         void dropFullName();
00140
00142         std::string getFullNameSchemaType() const;
00143
00144
00146         bool haveAvgeMass() const;
00147
00149         double getAvgeMass() const;
00150
00152         void setAvgeMass(const double value);
00153
00155         void dropAvgeMass();
00156
00158         std::string getAvgeMassSchemaType() const;
00159
00160
00162         bool haveMonoMass() const;
00163
00165         double getMonoMass() const;
00166
00168         void setMonoMass(const double value);
00169
00171         void dropMonoMass();
00172
00174         std::string getMonoMassSchemaType() const;
00175
00176     private:
00177
00178         typedef std::vector< ms_umod_elemref* > elemref_vector;
00179         elemref_vector _elemRefs;
00180
00181         std::string _title;
00182         bool _title_set;
00183
00184         std::string _threeLetter;
00185         bool _threeLetter_set;
00186
00187         std::string _fullName;
00188         bool _fullName_set;
00189
00190         double _avgeMass;
00191         bool _avgeMass_set;
00192
00193         double _monoMass;
00194         bool _monoMass_set;
00195     }; // class ms_umod_aminoacid
00196  // end of config_group
00198
00199 } // namespace matrix_science
00200
00201 #endif // MS_UMOD_AMINOACID_HPP
00202
00203 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_composition.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_composition.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Represents 'composition_t' type from unimod.xml file                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_composition.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_COMPOSITION_HPP
00018 #define MS_UMOD_COMPOSITION_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_umod_elemref; // forward declaration
00032     class ms_quant_composition; // forward declaration
00033     class ms_quant_component;  // forward declaration
00034     class ms_umod_configfile;  // forward declaration
00035     class ms_xml_schema; // forward declaration
00036
00042
00043
00047     class MS_MASCOTRESFILE_API ms_umod_composition: public ms_xml_IValidatable
00048     {
00049         friend class msparser_internal::ms_umod_xmlloader;
00050         friend class ms_umod_configfile;
00051
00052     public:
00054         ms_umod_composition();
00055
00057         ms_umod_composition(const ms_umod_composition& src);
00058
00060         ms_umod_composition(const ms_quant_composition& src, const ms_umod_configfile& umodFile);
00061
00063         void updateMasses(const ms_umod_configfile& umodFile, const ms_quant_component& quantComp);
00064
00066         virtual ~ms_umod_composition();
00067
00069         void defaultValues();
00070
00072         void copyFrom(const ms_umod_composition* right);
00073
00075         void copyFrom(const ms_quant_composition* right, const ms_umod_configfile& umodFile);
00076
00077 #ifndef SWIG
00078
00079         ms_umod_composition& operator=(const ms_umod_composition& right);
00080 #endif
00081
00082         virtual std::string getSchemaType() const;
00083
00085         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00086
00088         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00089
00090
00092         int getNumberOfElemRefs() const;
00093
00095         void clearElemRefs();
00096
00098         void appendElemRef(const ms_umod_elemref *elemref);
00099
00101         const ms_umod_elemref* getElemRef(const int idx) const;
00102
00104         bool updateElemRef(const int idx, const ms_umod_elemref *elemref);
00105
00107         bool deleteElemRef(const int idx);
00108
00110         std::string getElemRefSchemaType() const;
00111
00112
00114         bool haveCompositionString() const;
00115
00117         std::string getCompositionString() const;
00118
00120         void setCompositionString(const char* value);
00121
00123         void dropCompositionString();
00124
00126         std::string getCompositionStringSchemaType() const;
00127
00128
00130         bool haveAvgeMass() const;
00131
00133         double getAvgeMass() const;
00134
00136         void setAvgeMass(const double value);
00137
00139         void dropAvgeMass();
00140
00142         std::string getAvgeMassSchemaType() const;
00143
00144
00146         bool haveMonoMass() const;
00147
00149         double getMonoMass() const;
00150
00152         void setMonoMass(const double value);
00153
00155         void dropMonoMass();
00156
00158         std::string getMonoMassSchemaType() const;
00159
00161         bool isSameAs(const ms_umod_composition& right) const;
00162
00163     private:
00164
00165         typedef std::vector< ms_umod_elemref* > elemref_vector;
00166         elemref_vector _elemRefs;
00167
00168         std::string _composition;
00169         bool _composition_set;
00170
00171         double _avgeMass;
00172         bool _avgeMass_set;
00173
00174         double _monoMass;
00175         bool _monoMass_set;
00176     }; // class ms_umod_composition
00177  // end of config_group
00179
00180 } // namespace matrix_science
00181
00182 #endif // MS_UMOD_COMPOSITION_HPP
00183
00184 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_configfile.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_configfile.hpp                                               #
00004 # 'msparser' toolkit                                                         #
00005 # Represents unimod.xml file                                                 #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 # $Archive:: /Mowse/ms_mascotresfile/include/ms_umod_configfile.hpp                 $ #
00012 # $Author: francoisr@matrixscience.com $ #
00013 # $Date: 2019-03-08 13:54:54 +0000 $ #
00014 # $Revision: 7979cc541377e595bc9460c7439a78c7ed72e3d9 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_UMOD_CONFIGFILE_HPP
00020 #define MS_UMOD_CONFIGFILE_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00028
00029     class ms_umod_element; // forward declaration
00030     class ms_umod_modification; // forward declaration
00031     class ms_umod_aminoacid; // forward declaration
00032     class ms_umod_modbrick; // forward declaration
00033     class ms_session;
00034
00040
00041
00053     class MS_MASCOTRESFILE_API ms_umod_configfile: public ms_errors
00054     {
00055     public:
00057
00064             enum MODFILE_FLAGS
00065             {
00066                 MODFILE_FLAGS_EMPTY   = 0x00000000,
00067                 MODFILE_FLAGS_REGULAR = 0x00000001,
00068                 MODFILE_FLAGS_HIDDEN  = 0x00000002,
00069                 MODFILE_FLAGS_AASUBST = 0x00000004,
00070                 MODFILE_FLAGS_ALL     = 0x7FFFFFFF
00071             };
00072
00074         ms_umod_configfile();
00075
00077         ms_umod_configfile(const char* fileName, const char* schemaFileName,
00078             const ms_connection_settings * cs = 0, bool useSchema = true);
00079
00081         ms_umod_configfile(const ms_umod_configfile& right);
00082
00084         virtual ~ms_umod_configfile();
00085
00086 #ifndef SWIG
00087
00088         ms_umod_configfile& operator=(const ms_umod_configfile& right);
00089 #endif
00090
00091         void copyFrom(const ms_umod_configfile* right);
00092
00094         virtual void defaultValues();
00095
00097         void updateMasses();
00098
00099
00101         std::string getFileName() const;
00102
00104         void setFileName(const char* filename);
00105
00106
00108         void setSchemaFileName(const char* name);
00109
00111         std::string getSchemaFileName() const;
00112
00114         static std::string getDefaultSchemaFileName();
00115
00117         void setConnectionSettings(const ms_connection_settings & cs);
00118
00120         ms_connection_settings getConnectionSettings() const;
00121
00122
00124         void read_file();
00125
00127         void save_file();
00128
00130         void applyVisibility( const ms_session *session);
00131
00133         void applyVisibility(const std::vector<int> & groupIds);
00134
00136         void read_buffer(const char* buffer);
00137
00139         std::string save_buffer(bool validateAgainstSchema = true);
00140
00141
00143         std::string validateDocument() const;
00144
00145
00147         int getNumberOfElements() const;
00148
00150         void clearElements();
00151
00153         void appendElement(const ms_umod_element *elem);
00154
00156         const ms_umod_element * getElementByNumber(const int idx) const;
00157
00159         const ms_umod_element * getElementByName(const char *name) const;
00160
00162         bool updateElementByNumber(const int idx, const ms_umod_element* element);
00163
00165         bool updateElementByName(const char *name, const ms_umod_element* element);
00166
00168         bool deleteElementByNumber(const int idx);
00169
00171         bool deleteElementByName(const char *name);
00172
00173
00175         std::vector< std::string > getModFileList(const unsigned int flags = MODFILE_FLAGS_ALL) const;
00176
00178         int findModFileName(const char * modFileName) const;
00179
00181         int findModification(const char* modName) const;
00182
00183
00185         int getNumberOfModifications() const;
00186
00188         void clearModifications();
00189
00191         void appendModification(const ms_umod_modification *mod);
00192
00194         const ms_umod_modification * getModificationByNumber(const int idx) const;
00195
00197         const ms_umod_modification * getModificationByName(const char *name) const;
00198
00200         bool updateModificationByNumber(const int idx, const ms_umod_modification *mod);
00201
00203         bool updateModificationByName(const char *name, const ms_umod_modification *mod);
00204
00206         bool deleteModificationByNumber(const int idx);
00207
00209         bool deleteModificationByName(const char *name);
00210
00211
00213         int getNumberOfAminoAcids() const;
00214
00216         void clearAminoAcids();
00217
00219         void appendAminoAcid(const ms_umod_aminoacid *aa);
00220
00222         const ms_umod_aminoacid * getAminoAcidByNumber(const int idx) const;
00223
00225         const ms_umod_aminoacid * getAminoAcidByName(const char *name) const;
00226
00228         bool updateAminoAcidByNumber(const int idx, const ms_umod_aminoacid *aa);
00229
00231         bool updateAminoAcidByName(const char *name, const ms_umod_aminoacid *aa);
00232
00234         bool deleteAminoAcidByNumber(const int idx);
00235
00237         bool deleteAminoAcidByName(const char *name);
00238
00239
00241         int getNumberOfModBricks() const;
00242
00244         void clearModBricks();
00245
00247         void appendModBrick(const ms_umod_modbrick *brick);
00248
00250         const ms_umod_modbrick * getModBrickByNumber(const int idx) const;
00251
00253         const ms_umod_modbrick * getModBrickByName(const char *name) const;
00254
00256         bool updateModBrickByNumber(const int idx, const ms_umod_modbrick *brick);
00257
00259         bool updateModBrickByName(const char *name, const ms_umod_modbrick *brick);
00260
00262         bool deleteModBrickByNumber(const int idx);
00263
00265         bool deleteModBrickByName(const char *name);
00266
00268         std::string getMajorVersion() const;
00269
00271         std::string getMinorVersion() const;
00272
00274         void setMajorVersion(const std::string & version);
00275
00277         void setMinorVersion(const std::string & version);
00278     private:
00279
00280         void applyVisibilityHelper();
00281
00282         std::string             m_fileName;
00283         std::string             m_schemaFileName;
00284         ms_connection_settings  m_cs;
00285
00286         typedef std::vector< ms_umod_element* > element_vector;
00287         element_vector          m_elements;
00288
00289         typedef std::vector< ms_umod_modification* > modification_vector;
00290         modification_vector     m_modifications;
00291         typedef std::map<std::string, size_t> modification_index_map;
00292         modification_index_map  m_modifications_nameToIndex;
00293
00294         typedef std::vector< ms_umod_aminoacid* > aminoacid_vector;
00295         aminoacid_vector        m_aminoacids;
00296
00297         typedef std::vector< ms_umod_modbrick* > modbrick_vector;
00298         modbrick_vector         m_modbricks;
00299
00300         std::string m_majorVersion;
00301         std::string m_minorVersion;
00302
00303         std::string m_encodingName;
00304         bool m_useSchema;
00305     }; // class ms_umod_configfile
00306  // end of config_group
00308
00309 } // namespace matrix_science
00310
00311 #endif // MS_UMOD_CONFIGFILE_HPP
00312 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_element.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_element.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Represents chemical element information from unimod.xml file               #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_element.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_ELEMENT_HPP
00018 #define MS_UMOD_ELEMENT_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_umod_element: public ms_xml_IValidatable
00040     {
00041         friend class msparser_internal::ms_umod_xmlloader;
00042         friend class ms_umod_configfile;
00043
00044     public:
00046         ms_umod_element();
00047
00049         ms_umod_element(const ms_umod_element& src);
00050
00052         virtual ~ms_umod_element();
00053
00055         void defaultValues();
00056
00058         void copyFrom(const ms_umod_element* right);
00059
00060 #ifndef SWIG
00061
00062         ms_umod_element& operator=(const ms_umod_element& right);
00063 #endif
00064
00065         virtual std::string getSchemaType() const;
00066
00068         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00069
00071         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00072
00073
00075         bool haveTitle() const;
00076
00078         std::string getTitle() const;
00079
00081         void setTitle(const char* value);
00082
00084         void dropTitle();
00085
00087         std::string getTitleSchemaType() const;
00088
00089
00091         bool haveFullName() const;
00092
00094         std::string getFullName() const;
00095
00097         void setFullName(const char* value);
00098
00100         void dropFullName();
00101
00103         std::string getFullNameSchemaType() const;
00104
00105
00107         bool haveAvgeMass() const;
00108
00110         std::string getAvgeMass() const;
00111
00113         double getAvgeMassAsNumber() const;
00114
00116         bool setAvgeMass(const char* value, ms_errs* err = NULL);
00117
00119         void dropAvgeMass();
00120
00122         std::string getAvgeMassSchemaType() const;
00123
00124
00126         bool haveMonoMass() const;
00127
00129         std::string getMonoMass() const;
00130
00132         double getMonoMassAsNumber() const;
00133
00135         bool setMonoMass(const char* value, ms_errs* err = NULL);
00136
00138         void dropMonoMass();
00139
00141         std::string getMonoMassSchemaType() const;
00142
00143     private:
00144         std::string _title;
00145         bool _title_set;
00146
00147         std::string _fullName;
00148         bool _fullName_set;
00149
00150         std::string _avgeMass;
00151         double _avgeMassDouble;
00152         bool _avgeMass_set;
00153
00154         std::string _monoMass;
00155         double _monoMassDouble;
00156         bool _monoMass_set;
00157     }; // class ms_umod_element
00158  // end of config_group
00160
00161 } // namespace matrix_science
00162
00163 #endif // MS_UMOD_ELEMENT_HPP
00164
00165 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_elemref.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_elemref.hpp                                                  #
00004 # 'msparser' toolkit                                                         #
00005 # Represents 'elemref_t' type in unimod.xml file                             #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_elemref.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_ELEMREF_HPP
00018 #define MS_UMOD_ELEMREF_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_element; // forward declaration;
00032     class ms_xml_schema; // forward declaration
00033
00039
00040
00044     class MS_MASCOTRESFILE_API ms_umod_elemref: public ms_xml_IValidatable
00045     {
00046         friend class msparser_internal::ms_umod_xmlloader;
00047         friend class ms_umod_configfile;
00048
00049     public:
00051         ms_umod_elemref();
00052
00054         ms_umod_elemref(const ms_umod_elemref& src);
00055
00057         ms_umod_elemref(const ms_quant_element& src);
00058
00059
00061         virtual ~ms_umod_elemref();
00062
00064         void defaultValues();
00065
00067         void copyFrom(const ms_umod_elemref* right);
00068
00070         void copyFrom(const ms_quant_element* right);
00071
00072 #ifndef SWIG
00073
00074         ms_umod_elemref& operator=(const ms_umod_elemref& right);
00075 #endif
00076
00077         virtual std::string getSchemaType() const;
00078
00080         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00081
00083         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00084
00085
00087         bool haveSymbol() const;
00088
00090         std::string getSymbol() const;
00091
00093         void setSymbol(const char* value);
00094
00096         void dropSymbol();
00097
00099         std::string getSymbolSchemaType() const;
00100
00101
00103         bool haveNumber() const;
00104
00106         int getNumber() const;
00107
00109         void setNumber(const int value);
00110
00112         void dropNumber();
00113
00115         std::string getNumberSchemaType() const;
00116
00117     private:
00118
00119         std::string _symbol;
00120         bool _symbol_set;
00121
00122         int _number;
00123         bool _number_set;
00124     }; // class ms_umod_elemref
00125  // end of config_group
00127
00128 } // namespace matrix_science
00129
00130 #endif // MS_UMOD_ELEMREF_HPP
00131
00132 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_modbrick.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_modbrick.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Represents modbrick object from unimod.xml file                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_modbrick.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_MODBRICK_HPP
00018 #define MS_UMOD_MODBRICK_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_umod_elemref; // forward declaration
00032     class ms_xml_schema; // forward declaration
00033
00039
00040     class MS_MASCOTRESFILE_API ms_umod_modbrick: public ms_xml_IValidatable
00041     {
00042         friend class msparser_internal::ms_umod_xmlloader;
00043         friend class ms_umod_configfile;
00044
00045     public:
00047         ms_umod_modbrick();
00048
00050         ms_umod_modbrick(const ms_umod_modbrick& src);
00051
00053         virtual ~ms_umod_modbrick();
00054
00056         void defaultValues();
00057
00059         void copyFrom(const ms_umod_modbrick* right);
00060
00061 #ifndef SWIG
00062
00063         ms_umod_modbrick& operator=(const ms_umod_modbrick& right);
00064 #endif
00065
00066         virtual std::string getSchemaType() const;
00067
00069         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00070
00072         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00073
00074
00076         int getNumberOfElemRefs() const;
00077
00079         void clearElemRefs();
00080
00082         void appendElemRef(const ms_umod_elemref *elemref);
00083
00085         const ms_umod_elemref* getElemRef(const int idx) const;
00086
00088         bool updateElemRef(const int idx, const ms_umod_elemref *elemref);
00089
00091         bool deleteElemRef(const int idx);
00092
00094         std::string getElemRefSchemaType() const;
00095
00096
00098         bool haveTitle() const;
00099
00101         std::string getTitle() const;
00102
00104         void setTitle(const char* value);
00105
00107         void dropTitle();
00108
00110         std::string getTitleSchemaType() const;
00111
00112
00114         bool haveFullName() const;
00115
00117         std::string getFullName() const;
00118
00120         void setFullName(const char* value);
00121
00123         void dropFullName();
00124
00126         std::string getFullNameSchemaType() const;
00127
00128
00130         bool haveAvgeMass() const;
00131
00133         double getAvgeMass() const;
00134
00136         void setAvgeMass(const double value);
00137
00139         void dropAvgeMass();
00140
00142         std::string getAvgeMassSchemaType() const;
00143
00144
00146         bool haveMonoMass() const;
00147
00149         double getMonoMass() const;
00150
00152         void setMonoMass(const double value);
00153
00155         void dropMonoMass();
00156
00158         std::string getMonoMassSchemaType() const;
00159
00160     private:
00161
00162         typedef std::vector< ms_umod_elemref* > elemref_vector;
00163         elemref_vector _elemRefs;
00164
00165         std::string _title;
00166         bool _title_set;
00167
00168         std::string _fullName;
00169         bool _fullName_set;
00170
00171         double _avgeMass;
00172         bool _avgeMass_set;
00173
00174         double _monoMass;
00175         bool _monoMass_set;
00176     }; // class ms_umod_modbrick
00177  // end of config_group
00179
00180 } // namespace matrix_science
00181
00182 #endif // MS_UMOD_MODBRICK_HPP
00183
00184 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_modification.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_modification.hpp                                             #
00004 # 'msparser' toolkit                                                         #
00005 # Represents modification object in unimod.xml file                          #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_modification.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_MODIFICATION_HPP
00018 #define MS_UMOD_MODIFICATION_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_umod_composition; // forward declaration
00032     class ms_umod_specificity;  // forward declaration
00033     class ms_umod_xref; // forward declaration
00034     class ms_quant_localdef; // forward declaration
00035     class ms_quant_unmodified;  // forward declaration
00036     class ms_umod_configfile; // forward declaration
00037     class ms_quant_component; // forward declaration
00038     class ms_xml_schema; // forward declaration
00039
00045
00046     class MS_MASCOTRESFILE_API ms_umod_modification: public ms_xml_IValidatable
00047     {
00048         friend class msparser_internal::ms_umod_xmlloader;
00049         friend class ms_umod_configfile;
00050
00051     public:
00053         ms_umod_modification();
00054
00056         ms_umod_modification(const ms_umod_modification& src);
00057
00059         ms_umod_modification(const ms_quant_localdef& src, const ms_umod_configfile& umodFile);
00060
00062         ms_umod_modification(const ms_quant_unmodified& src);
00063
00065         void updateMasses(const ms_umod_configfile& umodFile, const ms_quant_component& quantComp);
00066
00068         virtual ~ms_umod_modification();
00069
00071         void defaultValues();
00072
00074         void copyFrom(const ms_umod_modification* right);
00075
00077         void copyFrom(const ms_quant_localdef* right, const ms_umod_configfile& umodFile);
00078
00080         void copyFrom(const ms_quant_unmodified* right);
00081
00082 #ifndef SWIG
00083
00084         ms_umod_modification& operator=(const ms_umod_modification& right);
00085 #endif
00086
00088         bool isSameAs(const ms_umod_modification& right_mod) const;
00089
00091         virtual std::string getSchemaType() const;
00092
00094         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00095
00097         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00098
00099
00101         std::vector< std::string > getModFileList(const unsigned int flags = ms_umod_configfile::MODFILE_FLAGS_ALL) const;
00102
00104         int findSpecGroup(const char* modFileName) const;
00105
00107         int getNumberOfSpecificities() const;
00108
00110         void clearSpecificities();
00111
00113         void appendSpecificity(const ms_umod_specificity *specificity);
00114
00116         const ms_umod_specificity * getSpecificity(const int idx) const;
00117
00119         const ms_umod_specificity * getSpecificityBySite(const char *site) const;
00120
00122         const ms_umod_specificity * getSpecificityBySiteAndPosition(const char *site, const char *position) const;
00123
00125         bool updateSpecificity(const int idx, const ms_umod_specificity *specificity);
00126
00128         bool deleteSpecificity(const int idx);
00129
00131         std::string getSpecificitySchemaType() const;
00132
00133
00135         bool haveDelta() const;
00136
00138         const ms_umod_composition* getDelta() const;
00139
00141         void setDelta(const ms_umod_composition* delta);
00142
00144         void dropDelta();
00145
00147         std::string getDeltaSchemaType() const;
00148
00149
00151         int getNumberOfIgnores() const;
00152
00154         void clearIgnores();
00155
00157         void appendIgnore(const ms_umod_composition *ignore);
00158
00160         const ms_umod_composition * getIgnore(const int idx) const;
00161
00163         bool updateIgnore(const int idx, const ms_umod_composition *ignore);
00164
00166         bool deleteIgnore(const int idx);
00167
00169         std::string getIgnoreSchemaType() const;
00170
00171
00173         int getNumberOfAltNames() const;
00174
00176         void clearAltNames();
00177
00179         void appendAltName(const char *alt_name);
00180
00182         std::string getAltName(const int idx) const;
00183
00185         bool updateAltName(const int idx, const char *alt_name);
00186
00188         bool deleteAltName(const int idx);
00189
00191         std::string getAltNameSchemaType() const;
00192
00193
00195         int getNumberOfXrefs() const;
00196
00198         void clearXrefs();
00199
00201         void appendXref(const ms_umod_xref *xref);
00202
00204         const ms_umod_xref* getXref(const int idx) const;
00205
00207         bool updateXref(const int idx, const ms_umod_xref *xref);
00208
00210         bool deleteXref(const int idx);
00211
00213         std::string getXrefSchemaType() const;
00214
00215
00217         bool haveMiscNotes() const;
00218
00220         std::string getMiscNotes() const;
00221
00223         void setMiscNotes(const char* value);
00224
00226         void dropMiscNotes();
00227
00229         std::string getMiscNotesSchemaType() const;
00230
00231
00233         bool haveTitle() const;
00234
00236         std::string getTitle() const;
00237
00239         void setTitle(const char* value);
00240
00242         void dropTitle();
00243
00245         std::string getTitleSchemaType() const;
00246
00247
00249         bool haveFullName() const;
00250
00252         std::string getFullName() const;
00253
00255         void setFullName(const char* value);
00256
00258         void dropFullName();
00259
00261         std::string getFullNameSchemaType() const;
00262
00263
00265         bool haveApproved() const;
00266
00268         bool isApproved() const;
00269
00271         void setApproved(const bool value);
00272
00274         void dropApproved();
00275
00277         std::string getApprovedSchemaType() const;
00278
00279
00281         bool haveUsernameOfPoster() const;
00282
00284         std::string getUsernameOfPoster() const;
00285
00287         void setUsernameOfPoster(const char* value);
00288
00290         void dropUsernameOfPoster();
00291
00293         std::string getUsernameOfPosterSchemaType() const;
00294
00295
00297         bool haveGroupOfPoster() const;
00298
00300         std::string getGroupOfPoster() const;
00301
00303         void setGroupOfPoster(const char* value);
00304
00306         void dropGroupOfPoster();
00307
00309         std::string getGroupOfPosterSchemaType() const;
00310
00311
00313         bool haveDateTimePosted() const;
00314
00316         std::string getDateTimePosted() const;
00317
00319         void setDateTimePosted(const char* value);
00320
00322         void dropDateTimePosted();
00323
00325         std::string getDateTimePostedSchemaType() const;
00326
00327
00329         bool haveDateTimeModified() const;
00330
00332         std::string getDateTimeModified() const;
00333
00335         void setDateTimeModified(const char* value);
00336
00338         void dropDateTimeModified();
00339
00341         std::string getDateTimeModifiedSchemaType() const;
00342
00344         bool haveRecordID() const;
00345
00347         std::string getRecordID() const;
00348
00350         void setRecordID(const char* value);
00351
00353         void dropRecordID();
00354
00356         std::string getRecordIDSchemaType() const;
00357
00359         bool isPrivate() const;
00360
00362         void setPrivate(bool b);
00363
00365         bool isPrivacyEnabled() const;
00366
00368         void setPrivacyEnabled(bool b);
00369
00370     private:
00371
00372         typedef std::vector< ms_umod_specificity * > specificity_vector;
00373         specificity_vector _specificities;
00374
00375         ms_umod_composition* _delta;
00376         bool _delta_set;
00377
00378         typedef std::vector< ms_umod_composition* > ignore_vector;
00379         ignore_vector _ignores;
00380
00381         typedef std::vector< std::string > altNames_vector;
00382         altNames_vector _altnames;
00383
00384         typedef std::vector< ms_umod_xref* > xref_vector;
00385         xref_vector _xrefs;
00386
00387         std::string _miscNotes;
00388         bool _miscNotes_set;
00389
00390         std::string _title;
00391         bool _title_set;
00392
00393         std::string _fullName;
00394         bool _fullName_set;
00395
00396         bool _approved;
00397         bool _approved_set;
00398
00399         std::string _usernameOfPoster;
00400         bool _usernameOfPoster_set;
00401
00402         std::string _groupOfPoster;
00403         bool _groupOfPoster_set;
00404
00405         std::string _dateTimePosted;
00406         bool _dateTimePosted_set;
00407
00408         std::string _dateTimeModified;
00409         bool _dateTimeModified_set;
00410
00411         std::string _recordID;
00412         bool _recordID_set;
00413
00414         bool _isPrivate;
00415         bool _isPrivacyEnabled;
00416
00417     }; // class ms_umod_modification
00418  // end of config_group
00420
00421 } // namespace matrix_science
00422
00423 #endif // MS_UMOD_MODIFICATION_HPP
00424
00425 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_neutralloss.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_neutralloss.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Represents 'NeutralLoss' element in unimod.xml file                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_neutralloss.hpp $
00012  * @(#)$Revision: 0bb105c754f1d83ce7437808601186f321028555 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2019-04-17 12:17:44 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_NEUTRALLOSS_HPP
00018 #define MS_UMOD_NEUTRALLOSS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_quant_neutralloss; // forward declaration
00032     class ms_quant_pepneutralloss; // forward declaration
00033     class ms_umod_configfile;
00034     class ms_xml_schema; // forward declaration
00035
00041
00042
00047     class MS_MASCOTRESFILE_API ms_umod_neutralloss: public ms_umod_composition
00048     {
00049         friend class msparser_internal::ms_umod_xmlloader;
00050
00051     public:
00053         ms_umod_neutralloss();
00054
00056         ms_umod_neutralloss(const ms_umod_neutralloss& src);
00057
00059         ms_umod_neutralloss(const ms_quant_neutralloss& src, const ms_umod_configfile& umodFile);
00060
00062         ms_umod_neutralloss(const ms_quant_pepneutralloss& src, const ms_umod_configfile& umodFile);
00063
00065         virtual ~ms_umod_neutralloss();
00066
00068         void defaultValues();
00069
00071         void copyFrom(const ms_umod_neutralloss* right);
00072
00074         void copyFrom(const ms_quant_neutralloss* right, const ms_umod_configfile& umodFile);
00075
00077         void copyFrom(const ms_quant_pepneutralloss* right, const ms_umod_configfile& umodFile);
00078
00079 #ifndef SWIG
00080
00081         ms_umod_neutralloss& operator=(const ms_umod_neutralloss& right);
00082 #endif
00083
00084         virtual std::string getSchemaType() const;
00085
00087         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00088
00090         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00091
00092
00094         bool haveFlag() const;
00095
00097         bool isFlag() const;
00098
00100         void setFlag(const bool value);
00101
00103         void dropFlag();
00104
00106         std::string getFlagSchemaType() const;
00107
00108
00110         bool haveCode() const;
00111
00113         std::string getCode() const;
00114
00116         void setCode(const char* value);
00117
00119         void dropCode();
00120
00122         std::string getCodeSchemaType() const;
00123
00124
00126         bool havePairsWith() const;
00127
00129         std::string getPairsWith() const;
00130
00132         void setPairsWith(const char* value);
00133
00135         void dropPairsWith();
00136
00138         std::string getPairsWithSchemaType() const;
00139
00140
00142         bool haveDescription() const;
00143
00145         std::string getDescription() const;
00146
00148         void setDescription(const char* value);
00149
00151         void dropDescription();
00152
00154         std::string getDescriptionSchemaType() const;
00155
00156     private:
00157
00158         bool _flag;
00159         bool _flag_set;
00160
00161         std::string _code;
00162         bool _code_set;
00163
00164         std::string _pairsWith;
00165         bool _pairsWith_set;
00166
00167         std::string _description;
00168         bool _description_set;
00169     }; // class ms_umod_neutralloss
00170  // end of config_group
00172
00173 } // namespace matrix_science
00174
00175 #endif // MS_UMOD_NEUTRALLOSS_HPP
00176
00177 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_specificity.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_specificity.hpp                                              #
00004 # 'msparser' toolkit                                                         #
00005 # Represents 'specificity' object from unimod.xml file                       #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_specificity.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_SPECIFICITY_HPP
00018 #define MS_UMOD_SPECIFICITY_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_umod_neutralloss; // forward declaration
00032     class ms_quant_specificity; // forward declaration
00033     class ms_umod_configfile;  // forward declaration
00034     class ms_xml_schema; // forward declaration
00035
00041
00042     class MS_MASCOTRESFILE_API ms_umod_specificity
00043     {
00044         friend class msparser_internal::ms_umod_xmlloader;
00045         friend class ms_umod_modification;
00046         friend class ms_umod_configfile;
00047
00048     public:
00050         ms_umod_specificity();
00051
00053         ms_umod_specificity(const ms_umod_specificity& src);
00054
00056         ms_umod_specificity(const ms_quant_specificity& src, const ms_umod_configfile& umodFile);
00057
00059         virtual ~ms_umod_specificity();
00060
00062         void defaultValues();
00063
00065         void copyFrom(const ms_umod_specificity* right);
00066
00068         void copyFrom(const ms_quant_specificity* right, const ms_umod_configfile& umodFile);
00069
00070 #ifndef SWIG
00071
00072         ms_umod_specificity& operator=(const ms_umod_specificity& right);
00073 #endif
00074
00075         virtual std::string getSchemaType() const;
00076
00078         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00079
00081         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00082
00083
00085         int getNumberOfNeutralLosses() const;
00086
00088         void clearNeutralLosses();
00089
00091         void appendNeutralLoss(const ms_umod_neutralloss *nl);
00092
00094         const ms_umod_neutralloss* getNeutralLoss(const int idx) const;
00095
00097         bool updateNeutralLoss(const int idx, const ms_umod_neutralloss *nl);
00098
00100         bool deleteNeutralLoss(const int idx);
00101
00103         std::string getNeutralLossSchemaType() const;
00104
00105
00107         int getNumberOfPepNeutralLosses() const;
00108
00110         void clearPepNeutralLosses();
00111
00113         void appendPepNeutralLoss(const ms_umod_neutralloss *pnl);
00114
00116         const ms_umod_neutralloss* getPepNeutralLoss(const int idx) const;
00117
00119         bool updatePepNeutralLoss(const int idx, const ms_umod_neutralloss *pnl);
00120
00122         bool deletePepNeutralLoss(const int idx);
00123
00125         std::string getPepNeutralLossSchemaType() const;
00126
00127
00129         bool haveMiscNotes() const;
00130
00132         std::string getMiscNotes() const;
00133
00135         void setMiscNotes(const char* value);
00136
00138         void dropMiscNotes();
00139
00141         std::string getMiscNotesSchemaType() const;
00142
00143
00145         bool haveHidden() const;
00146
00148         bool isHidden() const;
00149
00151         void setHidden(const bool value);
00152
00154         void dropHidden();
00155
00157         std::string getHiddenSchemaType() const;
00158
00159
00161         bool haveSite() const;
00162
00164         std::string getSite() const;
00165
00167         void setSite(const char* value);
00168
00170         void dropSite();
00171
00173         std::string getSiteSchemaType() const;
00174
00175
00177         bool havePosition() const;
00178
00180         std::string getPosition() const;
00181
00183         void setPosition(const char* value);
00184
00186         void dropPosition();
00187
00189         std::string getPositionSchemaType() const;
00190
00191
00193         bool haveClassification() const;
00194
00196         std::string getClassification() const;
00197
00199         void setClassification(const char* value);
00200
00202         void dropClassification();
00203
00205         std::string getClassificationSchemaType() const;
00206
00207
00209         bool haveSpecGroup() const;
00210
00212         int getSpecGroup() const;
00213
00215         void setSpecGroup(const int value);
00216
00218         void dropSpecGroup();
00219
00221         std::string getSpecGroupSchemaType() const;
00222
00224         bool inShortList() const;
00225
00226         // ! Sets whether this specificity is in the short list on the Mascot search form.
00227         void showInShortList(bool b);
00228
00230         bool inLongList() const;
00231
00232         // ! Sets whether this specificity is in the full list on the Mascot search form.
00233         void showInLongList(bool b);
00234
00235         // ! Indicates if this specificity is included in error tolerant searches.
00236         bool inErrorTolerant() const;
00237
00238         // ! Sets if this specificity is included in error tolerant searches.
00239         void useInErrorTolerant(bool b);
00240
00242         bool isSameAs(const ms_umod_specificity& right) const;
00243
00244     private:
00245
00246         typedef std::vector< ms_umod_neutralloss* > nl_vector;
00247         nl_vector _neutrallosses;
00248
00249         typedef std::vector< ms_umod_neutralloss* > pnl_vector;
00250         pnl_vector _pepneutrallosses;
00251
00252         std::string _miscNotes;
00253         bool _miscNotes_set;
00254
00255         bool _hidden;
00256         bool _hidden_set;
00257
00258         std::string _site;
00259         bool _site_set;
00260
00261         std::string _position;
00262         bool _position_set;
00263
00264         std::string _classification;
00265         bool _classification_set;
00266
00267         int _specGroup;
00268         bool _specGroup_set;
00269
00270         // Not persistent in unimod xml files
00271         bool _show_in_long_list;
00272         bool _use_in_error_tolerant;
00273
00274     }; // class ms_umod_specificity
00275  // end of config_group
00277
00278 } // namespace matrix_science
00279
00280 #endif // MS_UMOD_SPECIFICITY_HPP
00281
00282 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_umod_xref.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_umod_xref.hpp                                                     #
00004 # 'msparser' toolkit                                                         #
00005 # Represents 'xref_t' type in unimod.xml file                                #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_umod_xref.hpp $
00012  * @(#)$Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-07-30 16:23:53 +0100 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_UMOD_XREF_HPP
00018 #define MS_UMOD_XREF_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 // forward declarations
00025 namespace msparser_internal {
00026     class ms_umod_xmlloader;
00027 }
00028
00029 namespace matrix_science {
00030
00031     class ms_xml_schema; // forward declaration
00032
00038
00039     class MS_MASCOTRESFILE_API ms_umod_xref: public ms_xml_IValidatable
00040     {
00041         friend class msparser_internal::ms_umod_xmlloader;
00042
00043     public:
00045         ms_umod_xref();
00046
00048         ms_umod_xref(const ms_umod_xref& src);
00049
00051         virtual ~ms_umod_xref();
00052
00054         void defaultValues();
00055
00057         void copyFrom(const ms_umod_xref* right);
00058
00059 #ifndef SWIG
00060
00061         ms_umod_xref& operator=(const ms_umod_xref& right);
00062 #endif
00063
00064         virtual std::string getSchemaType() const;
00065
00067         virtual std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00068
00070         virtual std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00071
00072
00074         bool haveText() const;
00075
00077         std::string getText() const;
00078
00080         void setText(const char* value);
00081
00083         void dropText();
00084
00086         std::string getTextSchemaType() const;
00087
00088
00090         bool haveSource() const;
00091
00093         std::string getSource() const;
00094
00096         void setSource(const char* value);
00097
00099         void dropSource();
00100
00102         std::string getSourceSchemaType() const;
00103
00104
00106         bool haveUrl() const;
00107
00109         std::string getUrl() const;
00110
00112         void setUrl(const char* value);
00113
00115         void dropUrl();
00116
00118         std::string getUrlSchemaType() const;
00119
00121         bool isSameAs(const ms_umod_xref& right) const;
00122
00123     private:
00124
00125         std::string _text;
00126         bool _text_set;
00127
00128         std::string _source;
00129         bool _source_set;
00130
00131         std::string _url;
00132         bool _url_set;
00133     }; // class ms_umod_xref
00134  // end of config_group
00136
00137 } // namespace matrix_science
00138
00139 #endif // MS_UMOD_XREF_HPP
00140
00141 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_unigeneoptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_unigeneoptions.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Encapsulates "UniGene" section of "mascot.dat" file                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2007 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_unigeneoptions.hpp      $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_UNIGENEOPTIONS_HPP
00020 #define MS_UNIGENEOPTIONS_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026 namespace matrix_science {
00032
00033
00058     class MS_MASCOTRESFILE_API ms_unigeneoptions: public ms_customproperty
00059     {
00060         friend class ms_datfile;
00061
00062     public:
00063
00065         ms_unigeneoptions();
00066
00068         ms_unigeneoptions(const ms_unigeneoptions& src);
00069
00071         virtual ~ms_unigeneoptions();
00072
00074         void copyFrom(const ms_unigeneoptions* right);
00075
00076 #ifndef SWIG
00077
00078         ms_unigeneoptions& operator=(const ms_unigeneoptions& right);
00079 #endif
00080
00081         virtual void defaultValues();
00082
00084         bool isSectionAvailable() const;
00085
00087         void setSectionAvailable(const bool value);
00088
00089 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00090 #include "suppress_ms_customproperty.hpp"
00091 #endif
00092
00093
00094     private:
00095         bool sectionAvailable_;
00096
00097     }; // class options // end of config_group
00099 } // namespace matrix_science
00100
00101 #endif // MS_UNIGEGEOPTIONS_HPP
00102
00103 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_wwwoptions.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_wwwoptions.hpp                                                    #
00004 # 'msparser' toolkit                                                         #
00005 # Represents "WWW" section of "mascot.dat" file                              #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_wwwoptions.hpp          $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MS_WWWOPTIONS_HPP
00020 #define MS_WWWOPTIONS_HPP
00021
00022
00023 #include <string>
00024 #include <vector>
00025
00026
00027 namespace matrix_science {
00038     enum WWW_TYPE
00039     {
00040         WWW_SEQ = 0,
00041         WWW_REP = 1
00042     };
00043
00045
00051     class MS_MASCOTRESFILE_API ms_wwwentry
00052     {
00053         friend class ms_datfile;
00054         friend class ms_wwwoptions;
00055
00056     public:
00058         ms_wwwentry();
00059
00061         ms_wwwentry(const ms_wwwentry& src);
00062
00064         ~ms_wwwentry();
00065
00067         void defaultValues();
00068
00070         void copyFrom(const ms_wwwentry* right);
00071
00072 #ifndef SWIG
00073
00074         ms_wwwentry& operator=(const ms_wwwentry& right);
00075 #endif
00076
00077         std::string getName() const;
00078
00080         void setName(const char* value);
00081
00083         WWW_TYPE getType() const;
00084
00086         void setType(const WWW_TYPE value);
00087
00089         int getParseRule() const;
00090
00092         void setParseRule(const int value);
00093
00095         std::string getHostName() const;
00096
00098         void setHostName(const char* value);
00099
00101         int getPortNumber() const;
00102
00104         void setPortNumber(const int value);
00105
00107         std::string getPath() const;
00108
00110         void setPath(const char* value);
00111
00112     private:
00113         std::string name_;
00114         WWW_TYPE type_;
00115         int parseRuleNum_;
00116         std::string hostName_;
00117         int portNumber_;
00118         std::string path_;
00119
00120         std::string getStringName() const;
00121         std::string getStringValue() const;
00122     }; // class MS_MASCOTRESFILE_API ms_wwwentry
00123
00125
00156     class MS_MASCOTRESFILE_API ms_wwwoptions: public ms_customproperty
00157     {
00158         friend class ms_datfile;
00159     public:
00160
00162         ms_wwwoptions();
00163
00165         ms_wwwoptions(const ms_wwwoptions& src);
00166
00168         ~ms_wwwoptions();
00169
00171         void defaultValues();
00172
00174         void copyFrom(const ms_wwwoptions* right);
00175
00176 #ifndef SWIG
00177
00178         ms_wwwoptions& operator=(const ms_wwwoptions& right);
00179 #endif
00180
00181         bool isSectionAvailable() const;
00182
00184         void setSectionAvailable(const bool value);
00185
00187         int getNumberOfEntries() const;
00188
00190         const ms_wwwentry* getEntry(const int index) const;
00191
00193         const ms_wwwentry* getSeqEntryByName(const char* dbName) const;
00194
00196         const ms_wwwentry* getRepEntryByName(const char* dbName) const;
00197
00199         void clearEntries();
00200
00202         void appendEntry(const ms_wwwentry* item);
00203
00205         void setEntry(const int index, const ms_wwwentry* item);
00206
00208         void dropEntry(const int index);
00209
00210 #ifdef SUPPRESS_MS_CUSTOMPROPERTY_INHERITANCE
00211 #include "suppress_ms_customproperty.hpp"
00212 #endif
00213
00214     private:
00215         bool sectionAvailable_;
00216         std::vector< ms_wwwentry* > entries_;
00217     }; // class ms_wwwoptions // end of config_group
00219 } // namespace matrix_science
00220
00221 #endif // MS_WWWOPTIONS_HPP
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_xic.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_xic.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_xic.hpp $
00012  * @(#)$Revision: f7c430569a82a92eac8833564053b59680ac20a8 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2021-01-11 13:23:17 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_XIC_HPP
00018 #define MS_XIC_HPP
00019
00020
00021 // Includes from the standard template library
00022 #include <string>
00023
00024 namespace matrix_science
00025 {
00026     //=========================================================================
00032     class ms_xic_body;
00033     class ms_cache_file;
00034
00036
00039     class MS_MASCOTRESFILE_API ms_xic_point
00040     {
00041         public:
00042             ms_xic_point();
00043             ms_xic_point(double rt, int scanId, double intensity);
00044
00045             double getRt() const;
00046             int    getScanId() const;
00047             double getIntensity() const;
00048
00049             void setRt(double rt);
00050             void setScanId(int scanId);
00051             void setIntensity(double intensity);
00052
00053         private:
00054             double rt_;
00055             int scanId_;
00056             double intensity_;
00057     };
00058
00060
00067     class MS_MASCOTRESFILE_API ms_xic :
00068         public ms_handle
00069     {
00070         public:
00072
00075             enum peakState
00076             {
00077                 PEAK_STATE_UNKNOWN = 0,
00078                 PEAK_STATE_OK = 1,
00079                 PEAK_STATE_DISCARD =3,
00080             };
00081
00083             static std::string getXmlCode(peakState code);
00084
00086             static peakState getCodeFromXml(std::string text);
00087
00089             ms_xic();
00090
00092             explicit ms_xic(const ms_xic_body & body);
00093
00095             explicit ms_xic(ms_xic_body * body);
00096
00098             void defaultValues();
00099
00101             void copyFrom(const ms_xic * src);
00102
00103 #ifndef SWIG
00104
00105             ms_xic_body * body();
00106
00108             const ms_xic_body * body() const;
00110             void setCacheFile(matrix_science::ms_cache_file * cacheFile);
00111 #endif
00112
00114             peakState getPeakState() const;
00115
00117             bool hasIndexes() const;
00118
00120             int getPeakStartIndex() const;
00121
00123             int getPeakEndIndex() const;
00124
00126             int getRegionStartIndex() const;
00127
00129             int getRegionEndIndex() const;
00130
00132             int getStartIndex() const;
00133
00135             int getEndIndex() const;
00136
00138             int getPeakStartScanId() const;
00139
00141             int getPeakEndScanId() const;
00142
00144             int getRegionStartScanId() const;
00145
00147             int getRegionEndScanId() const;
00148
00150             int getStartScanId() const;
00151
00153             int getEndScanId() const;
00154
00156             bool getUseTimeShift() const;
00157
00159             double getElutionTimeShift() const;
00160
00162             double getRtPeakStart() const;
00163
00165             double getRtPeakEnd() const;
00166
00168             double getRtRegionStart() const;
00169
00171             double getRtRegionEnd() const;
00172
00174             int getNumPoints() const;
00175 #ifndef SWIG
00176
00177             void getPoint(int index, double & rt, int & scanId, double & intensity) const;
00178 #else // SWIG Multiple return values
00179             void getPoint(int index, double & OUTPUT, int & OUTPUT, double & OUTPUT) const;
00180 #endif
00181
00182             void setPeakStartIndex(int value);
00183
00185             void setPeakEndIndex(int value);
00186
00188             void setRegionStartIndex(int value);
00189
00191             void setRegionEndIndex(int value);
00192
00194             void setStartIndex(int value);
00195
00197             void setEndIndex(int value);
00198
00200             void setPeakStartScanId(int value);
00201
00203             void setPeakEndScanId(int scanId);
00204
00206             void setRegionStartScanId(int scanId);
00207
00209             void setRegionEndScanId(int scanId);
00210
00212             void setStartScanId(int scanId);
00213
00215             void setEndScanId(int scanId);
00216
00218             void setRtPeakStart(double value);
00219
00221             void setRtPeakEnd(double value);
00222
00224             void setRtRegionStart(double value);
00225
00227             void setRtRegionEnd(double value);
00228
00230             void setUseTimeShift(bool value);
00231
00233             void setElutionTimeShift(double value);
00234
00236             void setPeakState(peakState value);
00237
00238         protected:
00240             std::deque<ms_xic_point> & getPoints();
00241
00243             const std::deque<ms_xic_point> & getPoints() const;
00244
00245     };
00246  // end of quantitation_group
00248     //=========================================================================
00249
00250 } // namespace matrix_science
00251
00252 #endif // MS_XIC_HPP
00253
00254 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_xic_body.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_xic_body.hpp
00004 # 'msparser' toolkit
00005 # An extracted ion chromatogram - body
00006 ##############################################################################
00007 # COPYRIGHT NOTICE
00008 # Copyright 1998-2014 Matrix Science Limited  All Rights Reserved.
00009 #
00010 ##############################################################################
00011  * @(#)$Source$
00012  * @(#)$Revision$
00013  * @(#)$Date$
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_XIC_BODY_HPP
00018 #define MS_XIC_BODY_HPP
00019
00020 // Includes from the standard template library
00021 #include <string>
00022
00023 namespace matrix_science
00024 {
00025     class MS_PARSERINTERNAL_API ms_xic_body :
00026         public matrix_science::ms_body
00027     {
00028         public:
00029
00030             ms_xic_body();
00031             ~ms_xic_body();
00032
00033             ms_xic_body(const ms_xic_body & copy);
00034             void operator =(const ms_xic_body & copy);
00035
00036             bool loadCacheData() const;
00037             void dropCacheData() const;
00038
00039             bool loadStream(matrix_science::ms_cache_stream & stream);
00040             bool loadCache(matrix_science::ms_cache_file & cacheFile);
00041             bool loadFromXmlParent(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & xmlParent);
00042             bool loadFromXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & xmlCurrent);
00043
00044             bool saveToStream(matrix_science::ms_cache_stream & stream) const;
00045             bool saveToCache(matrix_science::ms_cache_file & cacheFile) const;
00046             bool saveToXml(msparser_internal::ms_XMLHelper & helper, msparser_internal::ms_XMLElement & element, bool processSeparately, bool completeReport) const;
00047
00048             mutable INT64 cacheStreamId_;
00049
00050             int peakStartIndex_;
00051             int peakEndIndex_;
00052             int regionStartIndex_;
00053             int regionEndIndex_;
00054             int startIndex_;
00055             int endIndex_;
00056
00057             int peakStartScanId_;
00058             int peakEndScanId_;
00059             int regionStartScanId_;
00060             int regionEndScanId_;
00061             int startScanId_;
00062             int endScanId_;
00063
00064             ms_xic::peakState peakState_;
00065
00066             bool useTimeShift_;
00067             double elutionTimeShift_;
00068             double rtPeakStart_;
00069             double rtPeakEnd_;
00070             double rtRegionStart_;
00071             double rtRegionEnd_;
00072
00073             // points are the only cached data
00074             mutable matrix_science::ms_cache_file * cacheFile_; // null if not associated with a cache file, will change during saveToCache
00075             mutable bool isCacheDataLoaded_; // true if data is loaded, even if not from a cache file
00076             mutable std::deque<ms_xic_point> points_;
00077             mutable bool hasPointsRt_;
00078             mutable bool hasPointsScanid_;
00079     };
00080
00081 } // namespace matrix_science
00082
00083 #endif // MS_XIC_BODY_HPP
00084
00085 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_xml_parameters.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_xml_parameters.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Base class for parameterType-definitions                                   #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2019 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011  * @(#)$Source: parser/inc/ms_xml_parameters.hpp $
00012  * @(#)$Revision: 8fee77726a13a239ca8bcf2b46212bff297db9b7 | MSPARSER_REL_2_8_1-0-gea32989045 $
00013  * @(#)$Date: 2018-12-20 10:50:55 +0000 $
00014 ##############################################################################
00015  */
00016
00017 #ifndef MS_XML_PARAMETERS_HPP
00018 #define MS_XML_PARAMETERS_HPP
00019
00020
00021 #include <string>
00022 #include <vector>
00023
00024 namespace msparser_internal {
00025     class ms_xml_xmlloader;
00026     class ms_XMLHelper;
00027     class ms_XMLElement;
00028 }
00029
00030 namespace matrix_science {
00031     class ms_xml_schema; // forward declaration
00032
00038
00039
00045     class MS_MASCOTRESFILE_API ms_xml_parameter: public ms_xml_IValidatable
00046     {
00047     public:
00049         ms_xml_parameter();
00050
00052         ms_xml_parameter(const ms_xml_parameter& src);
00053
00055         virtual ~ms_xml_parameter();
00056
00058         void defaultValues();
00059
00061         void copyFrom(const ms_xml_parameter* right);
00062
00063 #ifndef SWIG
00064
00065         ms_xml_parameter& operator=(const ms_xml_parameter& right);
00066 #endif
00067
00068         virtual std::string getSchemaType() const = 0;
00069
00071         std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00072
00074         std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00075
00076
00078         bool haveName() const;
00079
00081         std::string getName() const;
00082
00084         void setName(const char* value);
00085
00087         void dropName();
00088
00090         virtual std::string getNameSchemaType() const = 0;
00091
00092
00094         bool haveDescription() const;
00095
00097         std::string getDescription() const;
00098
00100         void setDescription(const char* value);
00101
00103         void dropDescription();
00104
00106         virtual std::string getDescriptionSchemaType() const = 0;
00107
00108
00110         std::string getValue() const;
00111
00113         void setValue(const char* value);
00114
00116         virtual std::string getValueSchemaType() const = 0;
00117
00118     protected:
00119         virtual bool saveToXML_ParameterByNumber(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const = 0;
00120
00121         std::string _name;
00122         bool _name_set;
00123
00124         std::string _description;
00125         bool _description_set;
00126
00127         std::string _value;
00128
00129     }; // class ms_xml_parameter
00130
00132
00139     class MS_MASCOTRESFILE_API ms_xml_parameters: public ms_xml_IValidatable
00140     {
00141     public:
00143         ms_xml_parameters();
00144
00146         ms_xml_parameters(const ms_xml_parameters& src);
00147
00149         virtual ~ms_xml_parameters();
00150
00152         void defaultValues();
00153
00155         virtual std::string getSchemaType() const = 0;
00156
00158         std::string validateShallow(const ms_xml_schema *pSchemaFileObj) const;
00159
00161         std::string validateDeep(const ms_xml_schema *pSchemaFileObj) const;
00162
00163
00165         virtual int getNumberOfParameters() const = 0;
00166
00168         virtual void clearParameters() = 0;
00169
00171         virtual bool deleteParameterByNumber(const int idx) = 0;
00172
00174         virtual bool deleteParameterByName(const char *name) = 0;
00175
00177         virtual std::string getParameterSchemaType() const = 0;
00178
00179     protected:
00180         virtual bool saveToXML_Parameters(msparser_internal::ms_XMLHelper &helper, msparser_internal::ms_XMLElement &rootEl) const = 0;
00181
00182     }; // class ms_xml_parameters
00183  // end of config_group
00185
00186 } // namespace matrix_science
00187
00188 #endif // MS_XML_PARAMETERS_HPP
00189
00190 /*------------------------------- End of File -------------------------------*/
00191
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


ms_zip.hpp

00001 /*
00002 ##############################################################################
00003 # file: ms_zip.hpp                                                           #
00004 # 'msparser' toolkit                                                         #
00005 # Utilities class for zipping and unzipping a buffer                         #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/ms_zip.hpp       $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2018-07-30 16:23:53 +0100 $ #
00014 #   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef ms_zip_HPP
00020 #define ms_zip_HPP
00021
00022
00023 #include <string>
00024
00025
00026 namespace matrix_science {
00032
00033
00092     class MS_MASCOTRESFILE_API ms_zip : public ms_errors
00093     {
00094     public:
00096         ms_zip(const bool isZipped, const unsigned char * buffer, const unsigned long len);
00097
00099         ms_zip(const bool isZipped, const std::string & buffer);
00100
00102         explicit ms_zip(const bool isZipped);
00103
00105         ms_zip(const ms_zip& src);
00106
00108         void copyFrom(const ms_zip* right);
00109
00110 #ifndef SWIG
00111
00112         ms_zip& operator=(const ms_zip& right);
00113 #endif
00114         ~ms_zip();
00115
00117         std::string compressMore(const std::string& dataIn);
00118
00120         void compressMore(const unsigned char *dataIn, const unsigned long inputLen, unsigned char *dataOut, unsigned long *outputLen);
00121
00123         unsigned long getZipped(unsigned char * buffer, const unsigned long len) const;
00124
00126         unsigned long getUnZipped(unsigned char * buffer, const unsigned long len) const;
00127
00129         std::string getZipped() const;
00130
00132         std::string getUnZipped() const;
00133
00135         unsigned long getZippedLen() const;
00136
00138         unsigned long getUnZippedLen() const;
00139
00140         enum { MAX_UNCOMPRESSED_SIZE = (1024 * 1024 * 100) };
00141     private:
00142         void init_buffer(const bool isZipped, const unsigned char * buffer, const unsigned long len);
00143         unsigned long zippedLen_;
00144         unsigned long zippedCap_;
00145         unsigned long maxZippedCap_;
00146         unsigned long unZippedLen_;
00147         unsigned long unZippedCap_;
00148         unsigned char * pUnZipped_;
00149         unsigned char * pZipped_;
00150         void* pInStreamData_;
00151         bool doneStreaming_;
00152     }; // class ms_zip // end of tools_group
00154 } // namespace matrix_science
00155 #endif // ms_zip_HPP
00156
00157 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


msparser.hpp

00001 /*
00002 ##############################################################################
00003 # File: msparser.hpp                                                         #
00004 # Mascot Parser toolkit                                                      #
00005 # Master include file                                                        #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Source: parser/inc/msparser.hpp $
00012 #    $Author: villek@matrixscience.com $
00013 #      $Date: 2019-10-18 16:39:04 +0100 $
00014 #  $Revision: 5a6646e705a1dce6cb8493dec184ed46d0bd6c08 | MSPARSER_REL_2_8_1-0-gea32989045 $
00015 ##############################################################################
00016 */
00017
00019 //                      Configuration files functionality                   //
00021
00022 // Some necessary constants
00023 #include "msparser_lim.hpp"
00024
00025 // General-purpose functionality or base classes
00026 #include "ms_logging.hpp"               // generic logging mechanism
00027 #include "ms_log.hpp"                   // log messages for internal use
00028 #include "ms_errors.hpp"                // generic error-handling mechanism
00029 #include "ms_customproperty.hpp"        // custom property functionality
00030 #include "ms_fileutilities.hpp"         // file-handling utilities
00031 #include "ms_connection_settings.hpp"   // proxy server and sessionID for config files
00032 #include "ms_tinycdb.hpp"               // cdb index files
00033 #include "ms_input_stream.hpp"          // input sream interface
00034 #include "ms_progress_info.hpp"
00035
00036
00037 // 'mascot.dat' file
00038 #include "ms_computeraddress.hpp"       // auxiliary definition classes
00039 #include "ms_mascotfiles.hpp"           // location of other configuration files
00040 #include "ms_clusterparams.hpp"         // 'Cluster'-section
00041 #include "ms_unigeneoptions.hpp"
00042 #include "ms_cronoptions.hpp"           // 'Cron'-section
00043 #include "ms_databaseoptions.hpp"       // 'Databases'-section
00044 #include "ms_libraryoptions.hpp"        // 'LibraryOptions' -section
00045 #include "ms_parserule.hpp"             // 'Parse'-section
00046 #include "ms_processoroptions.hpp"      // 'Processor'-section
00047 #include "ms_taxonomyrules.hpp"         // 'Taxonomy_XXX'-section
00048 #include "ms_wwwoptions.hpp"            // 'WWW'-section
00049 #include "ms_mascotoptions.hpp"         // 'Options'-section
00050 #include "ms_datfile.hpp"               // main class that represents the whole file
00051
00052 // 'enzymes' file
00053 #include "ms_enzyme.hpp"
00054
00055 // 'fragmentation_rules' file
00056 #include "ms_fragmentationrules.hpp"
00057
00058 // 'mascot.license' file
00059 #include "ms_license.hpp"
00060
00061 #include "ms_umod_configfile.hpp"
00062
00063 // 'mod_file' and 'substitutions' files
00064 #include "ms_modfile.hpp"
00065
00066 // 'masses file'
00067 #include "ms_masses.hpp"
00068
00069 // CPU configuration retreival
00070 #include "ms_processors.hpp"
00071
00072 // 'taxonomy' file
00073 #include "ms_taxonomyfile.hpp"
00074
00075 // authentication
00076 #include "ms_security_task.hpp"
00077 #include "ms_security_tasks.hpp"
00078 #include "ms_security_user.hpp"
00079 #include "ms_security_group.hpp"
00080 #include "ms_security_options.hpp"
00081 #include "ms_security.hpp"
00082 #include "ms_security_session.hpp"
00083
00084 // generic XML handling
00085 #include "ms_xml_typeinfo.hpp"
00086 #include "ms_xml_schema.hpp"
00087 #include "ms_xml_parameters.hpp"
00088
00089 // crosslinking.xml programming interface
00090 #include "ms_crosslinking_accessions.hpp"
00091 #include "ms_crosslinking_accession.hpp"
00092 #include "ms_crosslinking_configfile.hpp"
00093 #include "ms_crosslinking_parameters.hpp"
00094 #include "ms_crosslinking_linkers.hpp"
00095 #include "ms_crosslinking_linker.hpp"
00096 #include "ms_crosslinking_method.hpp"
00097 #include "ms_crosslinking_monolink.hpp"
00098 #include "ms_crosslinking_does_not_pair_with.hpp"
00099 #include "ms_crosslinking_filters.hpp"
00100 #include "ms_crosslinking_scope.hpp"
00101 #include "ms_crosslinking_settings.hpp"
00102
00103 // quantitation.xml programming interface
00104 #include "ms_quant_moverz.hpp"
00105 #include "ms_quant_correction.hpp"
00106 #include "ms_quant_isotope.hpp"
00107 #include "ms_quant_component.hpp"
00108 #include "ms_quant_composition.hpp"
00109 #include "ms_quant_parameters.hpp"
00110 #include "ms_quant_integration.hpp"
00111 #include "ms_quant_neutralloss.hpp"
00112 #include "ms_quant_specificity.hpp"
00113 #include "ms_quant_pepneutralloss.hpp"
00114 #include "ms_quant_localdef.hpp"
00115 #include "ms_quant_unmodified.hpp"
00116 #include "ms_quant_modgroup.hpp"
00117 #include "ms_quant_quality.hpp"
00118 #include "ms_quant_outliers.hpp"
00119 #include "ms_quant_normalisation.hpp"
00120 #include "ms_quant_precursor.hpp"
00121 #include "ms_quant_average.hpp"
00122 #include "ms_quant_multiplex.hpp"
00123 #include "ms_quant_reporter.hpp"
00124 #include "ms_quant_replicate.hpp"
00125 #include "ms_quant_protocol.hpp"
00126 #include "ms_quant_numerator.hpp"
00127 #include "ms_quant_ratio.hpp"
00128 #include "ms_quant_method.hpp"
00129 #include "ms_quant_configfile.hpp"
00130 #include "ms_quant_satellite.hpp"
00131 #include "ms_quant_normalisation_peptide.hpp"
00132 #include "ms_quant_normalisation_protein.hpp"
00133 #include "ms_quant_stats.hpp"
00134 #include "ms_peptide_quant_key.hpp"
00135 #include "ms_peptide_quant_key_vector.hpp"
00136 #include "ms_peptide_quant_ratio.hpp"
00137 #include "ms_protein_quant_ratio.hpp"
00138 #include "ms_quantitation.hpp"
00139 #include "ms_ms2quantitation.hpp"
00140 #include "ms_customquantitation.hpp"
00141
00142 // unimod.xml programming interface
00143 #include "ms_umod_element.hpp"
00144 #include "ms_umod_modification.hpp"
00145 #include "ms_umod_aminoacid.hpp"
00146 #include "ms_umod_modbrick.hpp"
00147 #include "ms_umod_specificity.hpp"
00148 #include "ms_umod_composition.hpp"
00149 #include "ms_umod_neutralloss.hpp"
00150 #include "ms_umod_elemref.hpp"
00151 #include "ms_umod_xref.hpp"
00152
00153 // HTTP connection
00154 #include "ms_http_helper_handles.hpp"
00155 #include "ms_http_helper_progress.hpp"
00156 #include "ms_http_helper_response.hpp"
00157 #include "ms_http_helper_return.hpp"
00158 #include "ms_http_helper.hpp"
00159
00160 // remote Mascot server
00161 #include "ms_http_client_mime.hpp"
00162 #include "ms_http_client_search.hpp"
00163 #include "ms_http_client_session.hpp"
00164 #include "ms_http_client.hpp"
00165
00166
00168 //                      Mascot result files functionality                   //
00170
00171 #include "ms_mascotrespeptide.hpp"
00172 #include "ms_linker_site.hpp"
00173 #include "ms_linker_site_vector.hpp"
00174 #include "ms_mascotresfile.hpp"
00175 #include "ms_mascotresprotein.hpp"
00176 #include "ms_mascotresults.hpp"
00177 #include "ms_mascotresproteinsum.hpp"
00178 #include "ms_mascotrespeptidesum.hpp"
00179 #include "ms_mascotresults_params.hpp"
00180 #include "ms_inputquery.hpp"
00181 #include "ms_mascotresparams.hpp"
00182 #include "ms_mascotresunigene.hpp"
00183
00184 #include "ms_fragment.hpp"
00185 #include "ms_fragmentvector.hpp"
00186
00187 #include "ms_aahelper.hpp"
00188 #include "ms_zip.hpp"
00189 #include "ms_shapiro_wilk.hpp"
00190 #include "ms_obofile.hpp"
00191
00193
00194 #include "ms_body.hpp"
00195 #include "ms_ms1quant_peptide_status.hpp"
00196 #include "ms_quant_helper.hpp"
00197
00198 #include "ms_cache_file.hpp"
00199 #include "ms_cache_stream.hpp"
00200 #include "ms_matrix.hpp"
00201 #include "ms_body.hpp"
00202 #include "ms_xic.hpp"
00203 #include "ms_ms1quant_match_range.hpp"
00204 #include "ms_ms1quant_match_component.hpp"
00205 #include "ms_ms1quant_match_ratio.hpp"
00206 #include "ms_fitexy_result.hpp"
00207 #include "ms_ms1quant_charge_state.hpp"
00208 #include "ms_ms1quant_match.hpp"
00209 #include "ms_ms1quant_average_results.hpp"
00210 #include "ms_ms1quant_peptide_status.hpp"
00211
00212 #include "ms_ms1quantitation.hpp"
00213
00214 #include "ms_distiller_data.hpp"
00215 #include "ms_distiller_data_quant.hpp"
00216 #include "ms_distiller_data_search.hpp"
00217 #include "ms_distiller_master_project.hpp"
00218 #include "ms_distiller_subsearch.hpp"
00219 #include "ms_distiller_master_search.hpp"
00220 #include "ms_distiller_search_status.hpp"
00221 #include "ms_distiller_search_status_list.hpp"
00222 #include "ms_distiller_sub_project.hpp"
00223
00224 #include "ms_spectral_lib_peak.hpp"
00225 #include "ms_spectral_lib_peak_list.hpp"
00226 #include "ms_spectral_lib_entry.hpp"
00227 #include "ms_spectral_lib_file.hpp"
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


msparser.pl

Large example / test program that illustrates most functionality.

#!/usr/local/bin/perl
##############################################################################
# file: msparser.pl                                                          #
# This file illustrates how to call the Mascot perl module 'msparser'        #
# It mirrors the C++ test harness                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
# This program may be used and modified within the licensee's organisation   #
# provided that this copyright notice remains intact. Distribution of this   #
# program or parts thereof outside the licensee's organisation without the   #
# prior written consent of Matrix Science Limited is expressly forbidden.    #
##############################################################################
#     $Source: parser/examples/test_perl/msparser.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

die "Must specify results filename as parameter" unless defined $ARGV[0];

my $resfile = new msparser::ms_mascotresfile($ARGV[0]);

if (!$resfile->isValid) {
    print STDERR "Cannot process file '$ARGV[0]':\n";
    print STDERR "Error number: ", $resfile->getLastError(), "\n";
    print STDERR "Error string: ", $resfile->getLastErrorString(), "\n";
    exit(1);
}

checkErrorHandler($resfile);
searchInformation($resfile);
searchParameters($resfile);
inputData($resfile);

print "-------------------------------------------------------------\n";
print "---   Full Protein summary report                         ---\n";
print "-------------------------------------------------------------\n";

show_results(
    $resfile,
    0,
    $msparser::ms_mascotresults::MSRES_NOFLAG,
    1.0 / 20.0,      # minProbability
    5                # Number of hits
);

print "-------------------------------------------------------------\n";
print "---   Concise Protein summary report                      ---\n";
print "-------------------------------------------------------------\n";

show_results(
    $resfile,
    0,
    $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS
        | $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS,
    0,               # minProbability
    3                # Number of hits
);

if ($resfile->isMSMS()) {
    print "-------------------------------------------------------------\n";
    print "---   Peptide summary report                              ---\n";
    print "-------------------------------------------------------------\n";

    show_results(
        $resfile,
        1, # peptide summary
        $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS
            | $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS,
        0,               # minProbability
        8,               # number of hits
        0,               # ignoreIonsScoreBelow
        0                # minimum peptide length
    );
} else {
    print "Not an MS-MS results file - cannot show peptide summary report\n";
}

##############################################################################
# show_results                                                               #
#  - parameter 0 is ms_mascotresfile                                         #
#  - parameter 1 is true for peptide summary, false for protein              #
#  - parameter 2 is the flags for display                                    #
#  - parameter 3 is the minimum protein probability to display               #
#  - parameter 4 is the maximum number of hits to display                    #
#  - parameter 5 is the minimum ions score to use                            #
#  - parameter 6 is the minPepLenInPepSummary to use                         #
##############################################################################
sub show_results {
    my($file, $usePeptideSummary, $flags, $minProteinProb, $maxHits,
     $minIonsScore, $minPepLenInPepSummary) = @_;

    my $results;

    if ($usePeptideSummary) {
        $results = new msparser::ms_peptidesummary(
            $resfile, $flags, $minProteinProb, $maxHits, "", $minIonsScore, $minPepLenInPepSummary
        );
    } else {
        $results = new msparser::ms_proteinsummary(
            $file, $flags, $minProteinProb, $maxHits
        );
    }

    if ($resfile->getLastError()) {
        print STDERR "Error : ", $file->getLastErrorString(), "\n";
        return;
    }

    my $hit  = 1;
    my $prot = $results->getHit($hit);

    while (defined($prot)) {
        my $accession   = $prot->getAccession();
        my $description = $results->getProteinDescription($accession);
        my $mass        = $results->getProteinMass($accession);

        print "Protein Hit ", $hit, "\n===================\n";
        print "Accession   : " , $accession, "\n";
        print "Description : " , $description           , "\n";
        print "Score       : " , $prot->getScore()      , "\n";
        print "Mass        : " , $mass                  , "\n";
        print "Frame       : " , $prot->getFrame()      , "\n";
        print "Coverage    : " , $prot->getCoverage()   , "\n";
        print "RMS error   : " , $prot->getRMSDeltas($results), "\n";
        print "Peptides    : " , $prot->getNumDisplayPeptides(),"\n";

        # Each protein has a number of peptides that matched - list them:
        my $num_peps = $prot->getNumPeptides();

        for my $i (1 .. $num_peps) {
            my $query = $prot->getPeptideQuery($i);
            my $p     = $prot->getPeptideP($i);

            if (
                $p != -1
                    and $query != -1
                    and $prot->getPeptideDuplicate($i) != $msparser::ms_protein::DUPE_DuplicateSameQuery
            ) {
                my $pep = $results->getPeptide($query, $p);
                next unless defined $pep;

                displayPeptideInfo(
                    0, $pep, $results,
                    $prot->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_Duplicate,
                    $prot->getPeptideIsBold($i),
                    $prot->getPeptideShowCheckbox($i)
                );
            }
        }

        # Now display list of all proteins that contained subsets or and
        # identical list of the matching peptides

        if ($flags & $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS) {
            print "Proteins matching the same set of peptides:\n";

            my $i = 1;
            while (my $prot = $results->getNextSimilarProtein($hit, $i)) {
                my $accession = $prot->getAccession();
                print $accession, " Total score: ", $prot->getScore();
                print "  Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
                $i++;
            }

            if ($flags & $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS) {
                print "Proteins matching a subset of these peptides:\n";

                my $i = 1;
                while ($prot = $results->getNextSubsetProtein($hit, $i)) {
                    my $accession = $prot->getAccession();
                    print $accession,  " Total score: ", $prot->getScore();
                    print "  Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
                    $i++;
                }
            }
        }

        print "\n\n";

        $hit++;
        $prot = $results->getHit($hit);
    }

    $results->createUnassignedList($msparser::ms_mascotresults::SCORE);

    if ($results->getNumberOfUnassigned()) {
        print "Unassigned list\n";
        print "---------------\n";

        for my $u (1 .. $results->getNumberOfUnassigned) {
            my $pep = $results->getUnassigned($u);
            displayPeptideInfo(0, $pep, $results, 0, 1, 1);
        }
    }

    if ($usePeptideSummary) {
        print "\n";
        displayYellowPopupInfo($results, 97);
    }
}

##############################################################################
#  displayYellowPopupInfo                                                    #
#  Shows the equivalent of the yellow popup box for given query              #
#  - parameter 0 is the results object                                       #
#  - parameter 1 is the query number                                         #
##############################################################################
sub displayYellowPopupInfo {
    my ($results, $q) = @_;

    my $fmt = "%5s %5s %9s %7s %7s\n";
    printf $fmt, qw(Score Delta Hit Protein Peptide);

    for my $p (1 .. 10) {
        my $pep = $results->getPeptide($q, $p);
        next unless defined $pep;

        my $seq = $pep->getPeptideStr();
        next unless defined $seq;

        my $tmp = $results->getProteinsWithThisPepMatch($q, $p);

        my ($hit, $protein) = ('', '');

        if ($tmp) {
            ($hit, $protein, my $morethan) = $tmp =~ /(\d+):([^ ]*)[ ]*(.*)/;

            if ($morethan) {
                $hit .= "+";
            }
        }

        printf $fmt, $pep->getIonsScore(), $pep->getDelta(), $hit, $protein, $seq;

    }

    my $p = 1;
    print "Accessions that matched query ", $q, " rank ", $p, ":- ",
         $results->getProteinsWithThisPepMatch($q, $p), "\n";
}

##############################################################################
# displayPeptideInfo                                                         #
#  - parameter 0  showFullDetails?                                           #
#  - parameter 1  p                                                          #
#  - parameter 2  ms_mascotresults                                           #
#  - parameter 3  isDuplicate?                                               #
#  - parameter 4  isBold?                                                    #
#  - parameter 5  showCheckBox?                                              #
##############################################################################
sub displayPeptideInfo {
    my ($showFullDetails, $p, $r, $isDuplicate, $isBold, $showCheckBox) = @_;

    my $q = $p->getQuery();

    if (!$showFullDetails) {
        my $fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3s\n";

        printf $fmt,
            $showCheckBox ? "CB" : "--",
            $isBold       ? "BOLD" : "dim",
            $q,
            $p->getObserved,
            $p->getRank,
            $p->getPrettyRank,
            $p->getPeptideStr,
            $isDuplicate ? '(' : '',
            $p->getIonsScore,
            $isDuplicate ? ')' : '',
            $r->getReadableVarMods($q, $p->getRank),
            ;

        return;
    }

    print "Peptide hit\n";

    if ($p->getAnyMatch()) {
        my $fmt = "    %-12s: %s\n";
        printf $fmt, 'Query'       , $q;
        printf $fmt, 'Rank'        , $p->getRank;
        printf $fmt, 'Matched'     , $p->getAnyMatch;
        printf $fmt, 'missedCleave', $p->getMissedCleavages;
        printf $fmt, 'mrCalc'      , $p->getMrCalc;
        printf $fmt, 'delta'       , $p->getDelta;
        printf $fmt, 'observed'    , $p->getObserved;
        printf $fmt, 'charge'      , $p->getCharge;
        printf $fmt, 'mrExp'       , $p->getMrExperimental;
        printf $fmt, 'ionsMatched' , $p->getNumIonsMatched;
        printf $fmt, 'peptideStr'  , $p->getPeptideStr;
        printf $fmt, 'peaksUsed1'  , $p->getPeaksUsedFromIons1;
        printf $fmt, 'varModsStr'  , $p->getVarModsStr;
        printf $fmt, 'readable mod', $r->getReadableVarMods($q, $p->getRank);
        printf $fmt, 'ionsScore'   , $p->getIonsScore;
        printf $fmt, 'seriesUsedS' , $p->getSeriesUsedStr;
        printf $fmt, 'peaksUsed2'  , $p->getPeaksUsedFromIons2;
        printf $fmt, 'peaksUsed3'  , $p->getPeaksUsedFromIons3;
        printf $fmt, 'idth, hth, p', join(', ',
            $r->getPeptideIdentityThreshold($q, 20),
            $r->getHomologyThreshold($q, 20),
            $r->getProbOfPepBeingRandomMatch($p->getIonsScore, $q)
        );
        print "\n";
    } else {
        print "    No match\n";
    }
}

##############################################################################
# checkErrorHandler                                                          #
#  - parameter 0  ms_mascotresfile                                           #
# Calls a couple of functions with invalid arguments                         #
##############################################################################
sub checkErrorHandler {
    my ($resfile) = @_;

    print "Testing the error handling...            \n";
    print "=========================================\n";

    my $numQueries = $resfile->getNumQueries();
    $resfile->getObservedCharge($numQueries + 40);  # Should fail

    print "Error number: ", $resfile->getLastError(), "\n";
    print "Error string: ", $resfile->getLastErrorString(), "\n";

    $resfile->clearAllErrors();
    print "Cleared all errors - should have no errors left: ", $resfile->getNumberOfErrors();
    print " errors left\n\n";

    for my $x (1 .. 20) {
        $resfile->getObservedCharge($numQueries + $x);  # Should fail
    }

    # Now, the best way, print out all errors.
    print "More errors added - there are now ", $resfile->getNumberOfErrors();
    print " errors\n";

    for my $i (1 .. $resfile->getNumberOfErrors) {
        print "Error number: ", $resfile->getErrorNumber($i);
        print " : ", $resfile->getErrorString($i);
        print "\n";
    }

    print "\n";
    $resfile->clearAllErrors();
}

##############################################################################
#  searchInformation                                                         #
#  - parameter 0  ms_mascotresfile                                           #
#  Display parameters from the ms_mascotresfile object. The functions        #
#  anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc #
#  because some people submit MSMS though the sequence query window etc.     #
##############################################################################
sub searchInformation {
    my ($resfile) = @_;

    my $fmt = "%-20s: %s\n";

    print "Search information from ms_mascotresfile", "\n";
    print "========================================", "\n";
    printf $fmt, "Number of queries"   , $resfile->getNumQueries();
    printf $fmt, "Number of hits"      , $resfile->getNumHits();
    printf $fmt, "Number of sequences" , $resfile->getNumSeqs();
    printf $fmt, "Sequences after tax" , $resfile->getNumSeqsAfterTax();
    printf $fmt, "Number of residues"  , $resfile->getNumResidues();
    printf $fmt, "Execution time"      , $resfile->getExecTime();
    printf $fmt, "Date (seconds)"      , $resfile->getDate();

    # Let's jump through a few hoops to get the equivalent of a 'C' asctime call
    my ($sec, $min, $hour, $mday, $mon, $year, $wday, $yday, $isdst)
        = localtime($resfile->getDate);

    printf $fmt, "Date", sprintf("%s %s %d %02d:%02d:%02d %d",
        (qw(Sun Mon Tue Wed Thu Fri Sat))[$wday],
        (qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec))[$mon],
        $mday,
        $hour,
        $min,
        $sec,
        $year+1900
    );

    printf $fmt, "Mascot version"       , $resfile->getMascotVer();
    printf $fmt, "Fasta version"        , $resfile->getFastaVer();
    printf $fmt, "Is PMF?"              , $resfile->isPMF();
    printf $fmt, "Is MSMS?"             , $resfile->isMSMS();
    printf $fmt, "Is SQ?"               , $resfile->isSQ();
    printf $fmt, "Is Error tolerant"    , $resfile->isErrorTolerant();
    printf $fmt, "Any PMF?"             , $resfile->anyPMF();
    printf $fmt, "Any MSMS?"            , $resfile->anyMSMS();
    printf $fmt, "Any SQ?"              , $resfile->anySQ();
    printf $fmt, "Any peptides section" , $resfile->doesSectionExist($msparser::ms_mascotresfile::SEC_PEPTIDES);
    printf $fmt, "Any peptide matches"  , $resfile->anyPeptideSummaryMatches();

    print "\n";
}

##############################################################################
#  searchParameters                                                          #
#  Display parameters from the ms_searchparams object.                       #
#  The values come from the parameters and the masses sections of the file   #
##############################################################################
sub searchParameters {
    my ($resfile) = @_;

    my $params = $resfile->params;
    my $fmt = "%-20s: %s\n";

    print "Search parameters from ms_searchparams"         , "\n";
    print "========================================="      , "\n";
    printf $fmt, "License"             , $params->getLICENSE();
    printf $fmt, "Search title"        , $params->getCOM();
    printf $fmt, "SEG mass"            , $params->getSEG();
    printf $fmt, "Peptide tol"         , $params->getTOL();
    printf $fmt, "Peptide tol units"   , $params->getTOLU();
    printf $fmt, "Fragment tol"        , $params->getITOL();
    printf $fmt, "Fragment tol units"  , $params->getITOLU();
    printf $fmt, "Missed cleavages"    , $params->getPFA();
    printf $fmt, "Database"            , $params->getDB();
    printf $fmt, "Static mods"         , $params->getMODS();
    printf $fmt, "Average/monoisotopic", $params->getMASS();
    printf $fmt, "Enzyme"              , $params->getCLE();
    printf $fmt, "Raw data file name"  , $params->getFILENAME();
    printf $fmt, "Input data"          , $params->getQUE();
    printf $fmt, "Type of search"      , $params->getSEARCH();
    printf $fmt, "User name"           , $params->getUSERNAME();
    printf $fmt, "User email"          , $params->getUSEREMAIL();
    printf $fmt, "Charge state"        , $params->getCHARGE();
    printf $fmt, "Repeat search file"  , $params->getINTERMEDIATE();
    printf $fmt, "Num hits to display" , $params->getREPORT();
    printf $fmt, "Show overview"       , $params->getOVERVIEW();
    printf $fmt, "Data file format"    , $params->getFORMAT();
    printf $fmt, "Form version"        , $params->getFORMVER();
    printf $fmt, "Variable mods"       , $params->getIT_MODS();

    for my $i (0 .. 12) {
        printf $fmt, sprintf("User%02d", $i), $params->getUSERField($i);
    }

    printf $fmt, "Precursor mass"      , $params->getPRECURSOR();
    printf $fmt, "Taxonomy filter"     , $params->getTAXONOMY();
    printf $fmt, "Type of report"      , $params->getREPTYPE();
    printf $fmt, "Accessions to search", $params->getACCESSION();
    printf $fmt, "Subcluster used"     , $params->getSUBCLUSTER();
    printf $fmt, "ICAT search?"        , $params->getICAT();
    printf $fmt, "Instrument type"     , $params->getINSTRUMENT();
    printf $fmt, "Error tolerant?"     , $params->getERRORTOLERANT();
    printf $fmt, "Rules (ions series)" , $params->getRULES();

    for my $ch (ord('A') .. ord('Z')) {
        printf $fmt, join(' ', "Residue", chr($ch)), $params->getResidueMass(chr($ch));
    }

    printf $fmt, "C terminus mass" , $params->getCTermMass();
    printf $fmt, "N terminus mass" , $params->getNTermMass();
    printf $fmt, "Mass of hydrogen", $params->getHydrogenMass();
    printf $fmt, "Mass of oxygen"  , $params->getOxygenMass();
    printf $fmt, "Mass of carbon"  , $params->getCarbonMass();
    printf $fmt, "Mass of nitrogen", $params->getNitrogenMass();
    printf $fmt, "Mass of electron", $params->getElectronMass();

    my $i = 1;
    while ($params->getVarModsName($i)) {
        printf $fmt, "Variable mod name"   , $params->getVarModsName($i);
        printf $fmt, "Variable mod delta"  , $params->getVarModsDelta($i), "\n";
        printf $fmt, "Variable mod neutral", $params->getVarModsNeutralLoss($i), "\n";
        $i++;
    }

    print "\n\n";
}

##############################################################################
#  inputData                                                                 #
#  - parameter 0  ms_mascotresfile                                           #
#  Display input data                                                        #
##############################################################################
sub inputData {
    my ($resfile) = @_;

    # display input data via inputquery get functions
    for my $i (1 .. 1) {
        # replace 1 .. 1 with 1 .. $resfile->getNumQueries() to get all input
        # data.

        print "Input data for query number ", $i      ,    "\n";
        print "=========================================", "\n";

        my $q = new msparser::ms_inputquery($resfile, $i);
        my $fmt = "    %-16s: %s\n";

        printf $fmt, "title"       , $q->getStringTitle(1);
        printf $fmt, "mass_min"    , $q->getMassMin();
        printf $fmt, "mass_max"    , $q->getMassMax();
        printf $fmt, "int_min"     , $q->getIntMin();
        printf $fmt, "int_max"     , $q->getIntMax();
        printf $fmt, "num_vals"    , $q->getNumVals();
        printf $fmt, "num_used1"   , $q->getNumUsed();
        printf $fmt, "ions1"       , $q->getStringIons1();
        printf $fmt, "ions2"       , $q->getStringIons2();
        printf $fmt, "ions3"       , $q->getStringIons3();
        printf $fmt, "peptol"      , $q->getPepTol();
        printf $fmt, "peptol units", $q->getPepTolUnits();
        printf $fmt, "peptol str"  , $q->getPepTolString();
        printf $fmt, "repeat srch" , $resfile->getRepeatSearchString($i);

        my $num_peaks = $q->getNumberOfPeaks(1);
        for my $j (1 .. $num_peaks) {
            print $q->getPeakMass(1, $j), ", ", $q->getPeakIntensity(1, $j), "\n";
        }
    }

    print "\n\n";
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


msparser_lim.hpp

00001 /*
00002 ##############################################################################
00003 # file: msparser_lim.hpp                                                     #
00004 # 'msparser' toolkit                                                         #
00005 # Contains definitions used in all projects                                  #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #    $Archive:: /Mowse/ms_mascotresfile/include/msparser_lim.hpp           $ #
00012 #     $Author: villek@matrixscience.com $ #
00013 #       $Date: 2019-07-19 12:20:12 +0100 $ #
00014 #   $Revision: e9a05e64c0974c6b7b9e18e38ad5b4430cfa45bd | MSPARSER_REL_2_8_1-0-gea32989045 $ #
00015 # $NoKeywords::                                                            $ #
00016 ##############################################################################
00017 */
00018
00019 #ifndef MSPARSER_LIM_HPP
00020 #define MSPARSER_LIM_HPP
00021
00022 /* Define some other values depending on the compiler / platform */
00023 #ifdef _WIN32
00024 #ifdef __GNUC__
00025 typedef long long INT64;
00026 typedef unsigned long long UINT64;
00027 #define FORMAT_STRING_FOR_I64 "%lld" // checked with man pages
00028 #define FORMAT_STRING_FOR_UI64 "%llu"
00029 #else
00030 #include <basetsd.h>
00031 #ifndef SWIG
00032 #define FORMAT_STRING_FOR_I64 "%I64d" // checked with MSDN
00033 #define FORMAT_STRING_FOR_UI64 "%I64u"
00034 #endif // !SWIG
00035 #endif
00036 #endif
00037
00038 #ifdef __LINUX__
00039 #include <stdint.h>
00040 typedef int64_t INT64;
00041 typedef uint64_t UINT64;
00042 #define FORMAT_STRING_FOR_I64 "%lld" // checked with man pages
00043 #define FORMAT_STRING_FOR_UI64 "%llu"
00044 #endif
00045
00046 #ifdef __LINUX64__
00047 #include <stdint.h>
00048 typedef int64_t INT64;
00049 typedef uint64_t UINT64;
00050 #define FORMAT_STRING_FOR_I64 "%ld" // checked with man pages
00051 #define FORMAT_STRING_FOR_UI64 "%lu"
00052 #endif
00053
00054 #ifdef SWIG_VERSION
00055 namespace matrix_science {
00056 #ifdef _USE_32BIT_TIME_T
00057     // See comments in "msparser.i"
00058     typedef __time64_t time_t;
00059 #endif
00060 } // namespace matrix_science
00061 #endif // SWIG_VERSION
00062
00063 #ifdef _MSC_VER
00064 #pragma warning(disable:4251)   // Don't want all classes to be exported
00065 #pragma warning(disable:4786)   // Debug symbols too long
00066 #endif
00067
00068 #ifdef _WIN32
00069 #   ifndef _MATRIX_USE_STATIC_LIB
00070 #       ifdef MS_MASCOTRESFILE_EXPORTS
00071 #           define MS_MASCOTRESFILE_API __declspec(dllexport)
00072 #           define MS_PARSERINTERNAL_API __declspec(dllexport)
00073 #       else
00074 #           define MS_MASCOTRESFILE_API __declspec(dllimport)
00075 #           define MS_PARSERINTERNAL_API __declspec(dllimport)
00076 #       endif
00077 #   else
00078 #       define MS_MASCOTRESFILE_API
00079 #       define MS_PARSERINTERNAL_API
00080 #   endif
00081 #else
00082 #   define MS_MASCOTRESFILE_API
00083 #   define MS_PARSERINTERNAL_API
00084 #endif
00085
00086 #endif // MSPARSER_LIM_HPP
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


msparser_full.py

Large example / test program that illustrates most functionality.

#!/usr/bin/python
##############################################################################
# file: msparser_full.py                                                     #
# This file illustrates how to call the Mascot python module 'msparser'      #
# It mirrors the C++ test harness                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
# This program may be used and modified within the licensee's organisation   #
# provided that this copyright notice remains intact. Distribution of this   #
# program or parts thereof outside the licensee's organisation without the   #
# prior written consent of Matrix Science Limited is expressly forbidden.    #
##############################################################################
#     $Source: parser/examples/test_python/msparser_full.py $ #
#     $Author: robertog@matrixscience.com $ #
#       $Date: 2019-02-08 15:47:54 +0000 $ #
#   $Revision: 114cf8df51d19fb8224d065619ae2a168da82d85 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords:: $                                                             #
##############################################################################

import msparser
import sys
import re
import time

def main() :
    if len(sys.argv) < 2 :
        print("Must specify results filename as parameter")
        return 1

    resfile = msparser.ms_mascotresfile(sys.argv[1])

    if not resfile.isValid() :
        print("Cannot process file '%s':" % sys.argv[1])
        print("Error number: %s" % resfile.getLastError())
        print("Error string: %s" % resfile.getLastErrorString())
        return 1

    checkErrorHandler(resfile)
    searchInformation(resfile)
    searchParameters(resfile)
    inputData(resfile)

    print("-------------------------------------------------------------")
    print("---   Full Protein summary report                         ---")
    print("-------------------------------------------------------------")

    show_results(
        resfile,
        0,
        msparser.ms_mascotresults.MSRES_NOFLAG,
        1.0 / 20.0,      # minProbability
        5                # Number of hits
        )

    print("-------------------------------------------------------------")
    print("---   Concise Protein summary report                      ---")
    print("-------------------------------------------------------------")

    show_results(
        resfile,
        0,
        msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
            | msparser.ms_mascotresults.MSRES_SHOW_SUBSETS,
        0,               # minProbability
        3                # Number of hits
        )

    if resfile.isMSMS() :
        print("-------------------------------------------------------------")
        print( "---   Peptide summary report                              ---")
        print("-------------------------------------------------------------")

        show_results(
            resfile,
            1, # peptide summary
            msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
                | msparser.ms_mascotresults.MSRES_SHOW_SUBSETS,
            0,               # minProbability
            8,               # number of hits
            0,               # ignoreIonsScoreBelow
            0                # minimum peptide length
            )
    else :
        print("Not an MS-MS results file - cannot show peptide summary report")

def show_results(resfile, usePeptideSummary, flags, minProteinProb, maxHits, minIonsScore = 0, minPepLenInPepSummary = 0) :
    """
    - file is ms_mascotresfile
    - usePeptideSummary is true for peptide summary, false for protein
    - flags is the flags for display
    - minProteinProb is the minimum protein probability to display
    - maxHits is the maximum number of hits to display
    - minIonsScore is the minimum ions score to use
    - minPepLenInPepSummary is the minPepLenInPepSummary to use
    """

    if usePeptideSummary :
        results = msparser.ms_peptidesummary(
            resfile, flags, minProteinProb, maxHits, "", minIonsScore, minPepLenInPepSummary
            )
    else :
        results = msparser.ms_proteinsummary(
            resfile, flags, minProteinProb, maxHits
            )

    if resfile.getLastError() :
        print("Error : %s" % resfile.getLastErrorString())
        return

    hit  = 1
    prot = results.getHit(hit)

    while prot :
        accession   = prot.getAccession()
        description = results.getProteinDescription(accession)
        mass        = results.getProteinMass(accession)

        print("Protein Hit %d" % hit)
        print("===================")
        print("Accession   : %s" % accession)
        print("Description : %s" % description)
        print("Score       : %s" % prot.getScore())
        print("Mass        : %s" % mass)
        print("Frame       : %s" % prot.getFrame())
        print("Coverage    : %s" % prot.getCoverage())
        print("RMS error   : %s" % prot.getRMSDeltas(results))
        print("Peptides    : %s" % prot.getNumDisplayPeptides())

        # Each protein has a number of peptides that matched - list them:
        num_peps = prot.getNumPeptides()

        for i in range(1, 1+ num_peps) :
            query = prot.getPeptideQuery(i)
            p     = prot.getPeptideP(i)

            isDupSameQuery = prot.getPeptideDuplicate(i) != msparser.ms_protein.DUPE_DuplicateSameQuery
            if p != -1 and query != -1 and not isDupSameQuery :
                pep = results.getPeptide(query, p)
                if not pep:
                    continue

                displayPeptideInfo(
                    0, pep, results,
                    prot.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_Duplicate,
                    prot.getPeptideIsBold(i),
                    prot.getPeptideShowCheckbox(i)
                    )

        # Now display list of all proteins that contained subsets or and
        # identical list of the matching peptides

        if flags & msparser.ms_mascotresults.MSRES_GROUP_PROTEINS :
            print("Proteins matching the same set of peptides:")

            i = 1
            similar_prot = results.getNextSimilarProtein(hit, 1)
            while similar_prot :
                accession = prot.getAccession()
                print(accession, "Total score:", similar_prot.getScore(),)
                print(" Peptides matched:", similar_prot.getNumDisplayPeptides())
                i += 1
                similar_prot = results.getNextSimilarProtein(hit, i)

            if flags & msparser.ms_mascotresults.MSRES_SHOW_SUBSETS :
                print("Proteins matching a subset of these peptides:")

                i = 1
                subset_prot = results.getNextSubsetProtein(hit, 1)
                while subset_prot :
                    accession = subset_prot.getAccession()
                    print(accession,  "Total score:", subset_prot.getScore(),)
                    print(" Peptides matched:", subset_prot.getNumDisplayPeptides(), "")
                    i += 1
                    subset_prot = results.getNextSubsetProtein(hit, i)

        print(" ")

        hit += 1
        prot = results.getHit(hit)

    results.createUnassignedList(msparser.ms_mascotresults.SCORE)

    if results.getNumberOfUnassigned() :
        print("Unassigned list")
        print("---------------")

        for u in range(1, 1 + results.getNumberOfUnassigned()) :
            pep = results.getUnassigned(u)
            displayPeptideInfo(0, pep, results, 0, 1, 1)

    if usePeptideSummary :
        print(" ")
        displayYellowPopupInfo(results, 97)

def displayYellowPopupInfo(results, q) :
    """
    Shows the equivalent of the yellow popup box for given query
    - results is the results object
    - q is the query number
    """

    fmt = "%5s %5s %9s %7s %7s"
    print(fmt % ("Score", "Delta", "Hit", "Protein", "Peptide"))

    for p in range(1, 11) :
        pep = results.getPeptide(q, p)
        if not pep: continue

        seq = pep.getPeptideStr()
        if not seq: continue

        tmp = results.getProteinsWithThisPepMatch(q, p)

        (hit, protein) = ('', '')

        if tmp :
            match = re.search('(\d+):([^ ]*)[ ]*(.*)', tmp)
            hit, protein, morethan = match.group(1), match.group(2), match.group(3)

            if morethan :
                hit += "+"

        print(fmt % (pep.getIonsScore(), pep.getDelta(), hit, protein, seq))

    p = 1
    print("Accessions that matched query %s rank %s :- %s" % (q, p, results.getProteinsWithThisPepMatch(q, p)))

def displayPeptideInfo(showFullDetails, p, results, isDuplicate, isBold, showCheckBox) :
    q = p.getQuery()

    if not showFullDetails :
        fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3s"

        cb, bold = "--", "dim"
        if showCheckBox : cb = "CB"
        if isBold : bold = "BOLD"

        paren1, paren2 = "", ""
        if isDuplicate : paren1 = "(" ; paren2 = ")"

        print(fmt % (
            cb,
            bold,
            q,
            p.getObserved(),
            p.getRank(),
            p.getPrettyRank(),
            p.getPeptideStr(),
            paren1,
            p.getIonsScore(),
            paren2,
            results.getReadableVarMods(q, p.getRank())
            ))

        return

    print("Peptide hit")

    if p.getAnyMatch() :
        fmt = "    %-12s: %s"
        print(fmt % ('Query'       , q))
        print(fmt % ('Rank'        , p.getRank()))
        print(fmt % ('Matched'     , p.getAnyMatch()))
        print(fmt % ('missedCleave', p.getMissedCleavages()))
        print(fmt % ('mrCalc'      , p.getMrCalc()))
        print(fmt % ('delta'       , p.getDelta()))
        print(fmt % ('observed'    , p.getObserved()))
        print(fmt % ('charge'      , p.getCharge()))
        print(fmt % ('mrExp'       , p.getMrExperimental()))
        print(fmt % ('ionsMatched' , p.getNumIonsMatched()))
        print(fmt % ('peptideStr'  , p.getPeptideStr()))
        print(fmt % ('peaksUsed1'  , p.getPeaksUsedFromIons1()))
        print(fmt % ('varModsStr'  , p.getVarModsStr()))
        print(fmt % ('readable mod', results.getReadableVarMods(q, p.getRank)))
        print(fmt % ('ionsScore'   , p.getIonsScore()))
        print(fmt % ('seriesUsedS' , p.getSeriesUsedStr()))
        print(fmt % ('peaksUsed2'  , p.getPeaksUsedFromIons2()))
        print(fmt % ('peaksUsed3'  , p.getPeaksUsedFromIons3()))
        print(fmt % ('idth, hth, p', ', '.join(
            results.getPeptideIdentityThreshold(q, 20),
            results.getHomologyThreshold(q, 20),
            results.getProbOfPepBeingRandomMatch(p.getIonsScore(), q)
            )))
        print(" ")
    else :
        print("    No match")

def checkErrorHandler(resfile) :
    """
    Calls a couple of functions with invalid arguments, then prints
    their error messages.
    """

    print("Testing the error handling...            ")
    print("=========================================")

    numQueries = resfile.getNumQueries()
    resfile.getObservedCharge(numQueries + 40);  # Should fail

    print("Error number: %s" % resfile.getLastError())
    print("Error string: %s" % resfile.getLastErrorString())

    resfile.clearAllErrors()
    print("Cleared all errors - should have no errors left: %s errors left" %resfile.getNumberOfErrors())

    for x in range(1, 21) :
        resfile.getObservedCharge(numQueries + x);  # Should fail

    # Now, the best way, print out all errors.
    print("More errors added - there are now %s errors" % resfile.getNumberOfErrors())

    for i in range(1, 1 + resfile.getNumberOfErrors()) :
        print("Error number: %s : %s" % (resfile.getErrorNumber(i), resfile.getErrorString(i)))

    print(" ")
    resfile.clearAllErrors()

def searchInformation(resfile) :
    """
    Display parameters from the ms_mascotresfile object. The functions
    anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc
    because some people submit MSMS though the sequence query window etc.
    """

    fmt = "%-20s: %s"

    print("Search information from ms_mascotresfile")
    print("========================================")
    print(fmt % ("Number of queries"   , resfile.getNumQueries()))
    print(fmt % ("Number of hits"      , resfile.getNumHits()))
    print(fmt % ("Number of sequences" , resfile.getNumSeqs()))
    print(fmt % ("Sequences after tax" , resfile.getNumSeqsAfterTax()))
    print(fmt % ("Number of residues"  , resfile.getNumResidues()))
    print(fmt % ("Execution time"      , resfile.getExecTime()))
    print(fmt % ("Date (seconds)"      , resfile.getDate()))

    date = time.localtime(resfile.getDate())
    Wdays = "Mon Tue Wed Thu Fri Sat Sun".split(" ")
    Mons = "Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec".split(" ")

    print(fmt %( "Date", "%s %s %d %02d:%02d:%02d %d" % (
        Wdays[date.tm_wday],
        Mons[date.tm_mon - 1],
        date.tm_mday,
        date.tm_hour,
        date.tm_min,
        date.tm_sec,
        date.tm_year
        )))

    print(fmt % ("Mascot version"       , resfile.getMascotVer()))
    print(fmt % ("Fasta version"        , resfile.getFastaVer()))
    print(fmt % ("Is PMF?"              , resfile.isPMF()))
    print(fmt % ("Is MSMS?"             , resfile.isMSMS()))
    print(fmt % ("Is SQ?"               , resfile.isSQ()))
    print(fmt % ("Is Error tolerant"    , resfile.isErrorTolerant()))
    print(fmt % ("Any PMF?"             , resfile.anyPMF()))
    print(fmt % ("Any MSMS?"            , resfile.anyMSMS()))
    print(fmt % ("Any SQ?"              , resfile.anySQ()))
    print(fmt % ("Any peptides section" , resfile.doesSectionExist(msparser.ms_mascotresfile.SEC_PEPTIDES)))
    print(fmt % ("Any peptide matches"  , resfile.anyPeptideSummaryMatches()))

    print(" ")

def searchParameters(resfile) :
    """
    Display parameters from the ms_searchparams object.
    The values come from the parameters and the masses sections of the file.
    """

    params = resfile.params()
    fmt = "%-20s: %s"

    print("Search parameters from ms_searchparams")
    print("=========================================")
    print(fmt % ("License"             , params.getLICENSE()))
    print(fmt % ("Search title"        , params.getCOM()))
    print(fmt % ("SEG mass"            , params.getSEG()))
    print(fmt % ("Peptide tol"         , params.getTOL()))
    print(fmt % ("Peptide tol units"   , params.getTOLU()))
    print(fmt % ("Fragment tol"        , params.getITOL()))
    print(fmt % ("Fragment tol units"  , params.getITOLU()))
    print(fmt % ("Missed cleavages"    , params.getPFA()))
    print(fmt % ("Database"            , params.getDB()))
    print(fmt % ("Static mods"         , params.getMODS()))
    print(fmt % ("Average/monoisotopic", params.getMASS()))
    print(fmt % ("Enzyme"              , params.getCLE()))
    print(fmt % ("Raw data file name"  , params.getFILENAME()))
    print(fmt % ("Input data"          , params.getQUE()))
    print(fmt % ("Type of search"      , params.getSEARCH()))
    print(fmt % ("User name"           , params.getUSERNAME()))
    print(fmt % ("User email"          , params.getUSEREMAIL()))
    print(fmt % ("Charge state"        , params.getCHARGE()))
    print(fmt % ("Repeat search file"  , params.getINTERMEDIATE()))
    print(fmt % ("Num hits to display" , params.getREPORT()))
    print(fmt % ("Show overview"       , params.getOVERVIEW()))
    print(fmt % ("Data file format"    , params.getFORMAT()))
    print(fmt % ("Form version"        , params.getFORMVER()))
    print(fmt % ("Variable mods"       , params.getIT_MODS()))

    for i in range(12) :
        print(fmt % ( "User%02d" % i, params.getUSERField(i)))

    print(fmt % ("Precursor mass"      , params.getPRECURSOR()))
    print(fmt % ("Taxonomy filter"     , params.getTAXONOMY()))
    print(fmt % ("Type of report"      , params.getREPTYPE()))
    print(fmt % ("Accessions to search", params.getACCESSION()))
    print(fmt % ("Subcluster used"     , params.getSUBCLUSTER()))
    print(fmt % ("ICAT search?"        , params.getICAT()))
    print(fmt % ("Instrument type"     , params.getINSTRUMENT()))
    print(fmt % ("Error tolerant?"     , params.getERRORTOLERANT()))
    print(fmt % ("Rules (ions series)" , params.getRULES()))

    for ch in range(ord('A'), 1 + ord('Z')) :
        print(fmt % ("Residue " + chr(ch), params.getResidueMass(chr(ch))))

    print(fmt % ("C terminus mass" , params.getCTermMass()))
    print(fmt % ("N terminus mass" , params.getNTermMass()))
    print(fmt % ("Mass of hydrogen", params.getHydrogenMass()))
    print(fmt % ("Mass of oxygen"  , params.getOxygenMass()))
    print(fmt % ("Mass of carbon"  , params.getCarbonMass()))
    print(fmt % ("Mass of nitrogen", params.getNitrogenMass()))
    print(fmt % ("Mass of electron", params.getElectronMass()))

    i = 1
    while params.getVarModsName(i) :
        print(fmt % ("Variable mod name"   , params.getVarModsName(i)))
        print(fmt % ("Variable mod delta"  , params.getVarModsDelta(i)))
        print(fmt % ("Variable mod neutral", params.getVarModsNeutralLoss(i)))
        i += 1

    print(" ")

def inputData(resfile) :
    # display input data via inputquery get functions
    for i in range(1, 2) :
        # replace range with (1, 1 + resfile.getNumQueries()) to get all input
        # data.

        print("Input data for query number %d" % i)
        print("=========================================")

        q = msparser.ms_inputquery(resfile, i)
        fmt = "    %-16s: %s"

        print(fmt % ("title"       , q.getStringTitle(True)))
        print(fmt % ("mass_min"    , q.getMassMin()))
        print(fmt % ("mass_max"    , q.getMassMax()))
        print(fmt % ("int_min"     , q.getIntMin()))
        print(fmt % ("int_max"     , q.getIntMax()))
        print(fmt % ("num_vals"    , q.getNumVals()))
        print(fmt % ("num_used1"   , q.getNumUsed()))
        print(fmt % ("ions1"       , q.getStringIons1()))
        print(fmt % ("ions2"       , q.getStringIons2()))
        print(fmt % ("ions3"       , q.getStringIons3()))
        print(fmt % ("peptol"      , q.getPepTol()))
        print(fmt % ("peptol units", q.getPepTolUnits()))
        print(fmt % ("peptol str"  , q.getPepTolString()))
        print(fmt % ("repeat srch" , resfile.getRepeatSearchString(i)))

        num_peaks = q.getNumberOfPeaks(1)
        for j in range (1, 1+ num_peaks) :
            print("%f, %f" % (q.getPeakMass(1, j), q.getPeakIntensity(1, j)))

    print(" ")

if __name__ == "__main__" :
    sys.exit(main())
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


  • All
  • Enumerations
  • Enumerator
  • FILE_FORMAT : matrix_science::ms_spectral_lib
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


  • All
  • Enumerations
  • Enumerator
  • FORMAT_MGF : matrix_science::ms_spectral_lib
  • FORMAT_NIST_MSP : matrix_science::ms_spectral_lib
  • FORMAT_SPECTRAST : matrix_science::ms_spectral_lib
  • FORMAT_UNKNOWN : matrix_science::ms_spectral_lib
  • FORMAT_XHUNTER : matrix_science::ms_spectral_lib
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:28


numerical_recipes.hpp

00001 /*
00002 ##############################################################################
00003 # file: numerical_recipes.hpp                                                #
00004 # 'msparser' toolkit                                                         #
00005 # Numerical algorithms for internal use                                      #
00006 ##############################################################################
00007 # COPYRIGHT NOTICE                                                           #
00008 # Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
00009 #                                                                            #
00010 ##############################################################################
00011 #     $Author: #
00012 #       $Date$ #
00013 #   $Revision$ #
00014 # $NoKeywords::                                                            $ #
00015 ##############################################################################
00016 */
00017
00018 #ifndef NUMERICAL_RECIPES_HPP
00019 #define NUMERICAL_RECIPES_HPP
00020
00021 #include <math.h>
00022
00023 namespace msparser_internal {
00024     // \cond INTERNAL
00025
00030     namespace NR {
00032         inline double SQR(const double x) { return x*x; }
00033
00035         MS_PARSERINTERNAL_API double gammaln(const double xx);
00036
00038         double factrl(const int n);
00040         double factln(const int n);
00041
00043         MS_PARSERINTERNAL_API double students_aa(const long nu, const double t);
00044
00046         MS_PARSERINTERNAL_API double studenttdistribution(const long nu, const double t);
00048         MS_PARSERINTERNAL_API double invstudenttdistribution(const long nu, const double p);
00049
00051
00058         inline bool approximately_equal(const double x1, const double x2, const double rel_error) {
00059            return fabs(x1 - x2) <= rel_error * fabs(x2);
00060         }
00061     }
00062
00063     // \endcond
00064 } // msparser_internal namespace
00065
00066 #endif // NUMERICAL_RECIPES_HPP
00067
00068 /*------------------------------- End of File -------------------------------*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


Related Pages

Here is a list of all related documentation pages:
  • License information for Mascot Parser
  • Release notes and version history
  • Updating from earlier versions of Mascot Parser
  • Deprecated List
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:14


peptide_list.cpp

Show the list of peptides in a table - for use as a CGI application.

/*
##############################################################################
# file: peptide_list.cpp                                                     #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/peptide_list.cpp $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

/*
##############################################################################
# Print out a table of results - peptide based list for QA
# Table should contain a list of unique peptides - every significant match
# Copy the executable to the mascot/cgi directory, and then, when looking
# at a report replace the master_results.pl in the URL with peptide_list.exe
##############################################################################
*/

#include "msparser.hpp"

#include <set>
#include <iostream>
#include <time.h>
#include <iomanip>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - file=[name of the .dat file]   */
/*****************************************************************************/
int main(int argc, char * argv[])
{
#ifdef _DEBUG
    putenv("QUERY_STRING=file=../data/20021123/F018521.dat");
#endif
    std::cout << "Content-type: text/html"         << std::endl << std::endl;
    std::cout << "<HTML>"                          << std::endl;
    std::cout << "<HEAD>"                          << std::endl;
    std::cout << "  <TITLE>Mascot summary</TITLE>" << std::endl;
    std::cout << "</HEAD>"                         << std::endl;
    std::cout << "<BODY BGCOLOR=\"#ffffff\">"      << std::endl;;

    if (getenv("QUERY_STRING") && strncmp(getenv("QUERY_STRING"), "file=", 5) == 0)
    {
        ms_mascotresfile file(getenv("QUERY_STRING")+strlen("file="));

        if (file.isValid())
        {
            if (file.isMSMS())
            {
                ms_mascotresults * results;
                results = new ms_peptidesummary(file,
                                                ms_mascotresults::MSRES_GROUP_PROTEINS |
                                                ms_mascotresults::MSRES_SHOW_SUBSETS,
                                                0,               // minProbability
                                                1000,            // number of hits
                                                0,               // ignoreIonsScoreBelow
                                                0);              // minimum peptide length

                ms_protein * prot = results->getHit(1);
                if (!prot)
                    std::cout << "No significant matches" << std::endl;
                else
                {
                    std::set<std::string> pep_strings;

                    std::cout << "<TABLE BORDER=1>" << std::endl;
                    std::cout << "  <TR>" << std::endl;
                    std::cout << "    <TD><B>Peptide</B></TD>"     << std::endl
                              << "    <TD><B>Score</B></TD>"       << std::endl
                              << "    <TD><B>Query</B></TD>"       << std::endl
                              << "    <TD><B>Rank</B></TD>"       << std::endl
                              << "    <TD><B>Proteins</B></TD>"    << std::endl;
                    std::cout << "  </TR>" << std::endl;
                    for (int query=1; query <= file.getNumQueries(); query++)
                    {
                        for (int p=1; p <= 10; p++)
                        {
                            double threshold = results->getPeptideIdentityThreshold(query, 20);
                            ms_peptide * pep;
                            if ( results->getPeptide(query, p, pep)
                            &&  (pep->getIonsScore() >= threshold))
                            {
                                if (pep_strings.insert(pep->getPeptideStr()).second)
                                {
                                    std::cout << "  <TR>" << std::endl;
                                    std::cout << "    <TD>"
                                              << pep->getPeptideStr().c_str()
                                              << "    </TD>"
                                              << std::endl;
                                    std::cout << "    <TD>"
                                              << pep->getIonsScore()
                                              << "    </TD>"
                                              << std::endl;
                                    std::cout << "    <TD>" << query << "    </TD>" << std::endl;
                                    std::cout << "    <TD>" << p     << "    </TD>" << std::endl;
                                    std::cout << "    <TD>"
                                              << results->getProteinsWithThisPepMatch(query, p).c_str()
                                              << "    </TD>"
                                              << std::endl;
                                    std::cout << "  </TR>" << std::endl;
                                }
                            }
                        }
                    }
                    std::cout << "</TABLE>" << std::endl;
                }
                if (file.getLastError())
                {
                    std::cout << "There was an error..." << std::endl;
                    std::cout << "Error: " << file.getLastErrorString() << std::endl;
                }
            }
        }
        else
            std::cout << "Error: " << file.getLastErrorString() << std::endl;
    }
    else
        std::cout << "Must supply 'file=[name of a .dat file]'"
                  << "Number of args = " << argc
                  << "QS=" << getenv("QUERY_STRING")
                  <<std::endl;
    std::cout << "</BODY>"   << std::endl;;
    std::cout << "</HTML>"   << std::endl;;
    return 0;
}

/* Will give for example the following output:
<TABLE BORDER=1>
  <TR>
    <TD><B>Peptide</B></TD>
    <TD><B>Score</B></TD>
    <TD><B>Query</B></TD>
    <TD><B>Rank</B></TD>
    <TD><B>Proteins</B></TD>
  </TR>
  <TR>
    <TD>GPSSVEDIK    </TD>
    <TD>68.06    </TD>
    <TD>17    </TD>
    <TD>1    </TD>
    <TD>9:Q96AT6      </TD>
  </TR>
  <TR>
    <TD>SGEVLVNVK    </TD>
    <TD>79.37    </TD>
    <TD>18    </TD>
    <TD>1    </TD>
    <TD>13:S60335  15:Q9QZD9      </TD>
  </TR>
  <TR>
    <TD>MSDGLFLQK    </TD>
    <TD>54.93    </TD>
    <TD>29    </TD>
    <TD>1    </TD>
    <TD>16:S55282      </TD>
  </TR>
  <TR>
    <TD>LGGSQEDQIK    </TD>
    <TD>67.93    </TD>
    <TD>31    </TD>
    <TD>1    </TD>
    <TD>2:AAH10103      </TD>
  </TR>
  <TR>
    <TD>AGLGHPAAFGR    </TD>
    <TD>57.48    </TD>
    <TD>34    </TD>
    <TD>1    </TD>
    <TD>19:DDH1_HUMAN      </TD>
  </TR>
  <TR>
    <TD>TPEEYPESAK    </TD>
    <TD>54.88    </TD>
    <TD>37    </TD>
    <TD>1    </TD>
    <TD>19:DDH1_HUMAN      </TD>
  </TR>
  <TR>
    <TD>SSGTSYPDVLK    </TD>
    <TD>63.42    </TD>
    <TD>38    </TD>
    <TD>1    </TD>
    <TD>4:TRBOTR  6:1NTP      </TD>
  </TR>
  <TR>
    <TD>VCNYVSWIK    </TD>
    <TD>55.78    </TD>
    <TD>41    </TD>
    <TD>1    </TD>
    <TD>4:TRBOTR  6:1NTP      </TD>
  </TR>
  <TR>
    <TD>IDTIEIITDR    </TD>
    <TD>69.04    </TD>
    <TD>43    </TD>
    <TD>1    </TD>
    <TD>8:AAC26867  11:Q9TTV2      </TD>
  </TR>
  <TR>
    <TD>DITSDTSGDFR    </TD>
    <TD>69.53    </TD>
    <TD>45    </TD>
    <TD>1    </TD>
    <TD>1:LUHU  3:AAB19866  7:ANX1_MOUSE      </TD>
  </TR>
  <TR>
    <TD>LLGELLQDNAK    </TD>
    <TD>64.14    </TD>
    <TD>46    </TD>
    <TD>1    </TD>
    <TD>2:AAH10103      </TD>
  </TR>
  <TR>
    <TD>VGMIPVPYVEK    </TD>
    <TD>54.23    </TD>
    <TD>52    </TD>
    <TD>1    </TD>
    <TD>18:S41754      </TD>
  </TR>
  <TR>
    <TD>TPAQFDADELR    </TD>
    <TD>66.27    </TD>
    <TD>53    </TD>
    <TD>1    </TD>
    <TD>1:LUHU  3:AAB19866  5:AAC78495  7:ANX1_MOUSE  27:CAA64477      </TD>
  </TR>
  <TR>
    <TD>LSSTWEGIQAGK    </TD>
    <TD>77.53    </TD>
    <TD>54    </TD>
    <TD>1    </TD>
    <TD>2:AAH10103      </TD>
  </TR>
  <TR>
    <TD>SLDLDSIIAEVK    </TD>
    <TD>80.49    </TD>
    <TD>56    </TD>
    <TD>1    </TD>
    <TD>17:AAG41947      </TD>
  </TR>
  <TR>
    <TD>AVLENNLGAAVLR    </TD>
    <TD>57.63    </TD>
    <TD>63    </TD>
    <TD>1    </TD>
    <TD>36:Q9BS89      </TD>
  </TR>
  <TR>
    <TD>ALEESNYELEGK    </TD>
    <TD>59.06    </TD>
    <TD>67    </TD>
    <TD>1    </TD>
    <TD>22:KRMSE1      </TD>
  </TR>
  <TR>
    <TD>VLGTEELYGYLK    </TD>
    <TD>65.31    </TD>
    <TD>68    </TD>
    <TD>1    </TD>
    <TD>14:B35838      </TD>
  </TR>
  <TR>
    <TD>VLGTDELYGYLK    </TD>
    <TD>65.31    </TD>
    <TD>68    </TD>
    <TD>2    </TD>
    <TD>12:B38611      </TD>
  </TR>
  <TR>
    <TD>GVDEATIIDILTK    </TD>
    <TD>73.44    </TD>
    <TD>69    </TD>
    <TD>1    </TD>
    <TD>1:LUHU  3:AAB19866  5:AAC78495  7:ANX1_MOUSE  20:LUGP1      </TD>
  </TR>
  <TR>
    <TD>QSLEASLAETEGR    </TD>
    <TD>60.48    </TD>
    <TD>70    </TD>
    <TD>1    </TD>
    <TD>22:KRMSE1      </TD>
  </TR>
  <TR>
    <TD>TPYTDVNIVTIR    </TD>
    <TD>73.23    </TD>
    <TD>71    </TD>
    <TD>1    </TD>
    <TD>16:S55282      </TD>
  </TR>
  <TR>
    <TD>ALAGCDFLTISPK    </TD>
    <TD>58.07    </TD>
    <TD>72    </TD>
    <TD>1    </TD>
    <TD>2:AAH10103      </TD>
  </TR>
  <TR>
    <TD>WELLQQVDTSTR    </TD>
    <TD>64.49    </TD>
    <TD>80    </TD>
    <TD>1    </TD>
    <TD>17:AAG41947      </TD>
  </TR>
  <TR>
    <TD>EVYQQQQYGSGGR    </TD>
    <TD>66.95    </TD>
    <TD>83    </TD>
    <TD>1    </TD>
    <TD>10:Q9BQ99      </TD>
  </TR>
  <TR>
    <TD>IFVGGLNPEATEEK    </TD>
    <TD>62.15    </TD>
    <TD>84    </TD>
    <TD>1    </TD>
    <TD>10:Q9BQ99      </TD>
  </TR>
  <TR>
    <TD>IFVGGINPEATEEK    </TD>
    <TD>62.15    </TD>
    <TD>84    </TD>
    <TD>2    </TD>
    <TD>23:PC4375      </TD>
  </TR>
  <TR>
    <TD>QLYQILTDFDIR    </TD>
    <TD>63.62    </TD>
    <TD>87    </TD>
    <TD>1    </TD>
    <TD>12:B38611  14:B35838      </TD>
  </TR>
  <TR>
    <TD>GTDVNVFNTILTTR    </TD>
    <TD>71.62    </TD>
    <TD>93    </TD>
    <TD>1    </TD>
    <TD>1:LUHU  3:AAB19866      </TD>
  </TR>
  <TR>
    <TD>SDSEKLNLDSIIGR    </TD>
    <TD>58.2    </TD>
    <TD>96    </TD>
    <TD>1    </TD>
    <TD>39:Q9Z1G2      </TD>
  </TR>
  <TR>
    <TD>DSCQGDSGGPVVCSGK    </TD>
    <TD>71.13    </TD>
    <TD>97    </TD>
    <TD>1    </TD>
    <TD>4:TRBOTR  6:1NTP      </TD>
  </TR>
  <TR>
    <TD>DLAKDITSDTSGDFR    </TD>
    <TD>57.65    </TD>
    <TD>99    </TD>
    <TD>1    </TD>
    <TD>1:LUHU  3:AAB19866  7:ANX1_MOUSE      </TD>
  </TR>
  <TR>
    <TD>GLGTDEDTLIEILASR    </TD>
    <TD>87.32    </TD>
    <TD>103    </TD>
    <TD>1    </TD>
    <TD>1:LUHU  5:AAC78495      </TD>
  </TR>
  <TR>
    <TD>GAGTEEACLIDILASR    </TD>
    <TD>54.48    </TD>
    <TD>103    </TD>
    <TD>2    </TD>
    <TD>33:O93444      </TD>
  </TR>
  <TR>
    <TD>SEDFGVNEDLADSDAR    </TD>
    <TD>103.46    </TD>
    <TD>105    </TD>
    <TD>1    </TD>
    <TD>1:LUHU      </TD>
  </TR>
  <TR>
    <TD>LISWYDNEFGYSNR    </TD>
    <TD>58.42    </TD>
    <TD>107    </TD>
    <TD>1    </TD>
    <TD>28:DEHUG3  30:AAC16069      </TD>
  </TR>
  <TR>
    <TD>LVTWYDNEFGYSNR    </TD>
    <TD>57.61    </TD>
    <TD>107    </TD>
    <TD>2    </TD>
    <TD>37:Q90Z48      </TD>
  </TR>
  <TR>
    <TD>TPALVFEYINNTDFK    </TD>
    <TD>69.27    </TD>
    <TD>108    </TD>
    <TD>1    </TD>
    <TD>12:B38611  14:B35838      </TD>
  </TR>
  <TR>
    <TD>IFVGGLNPEATEEKIR    </TD>
    <TD>54.63    </TD>
    <TD>109    </TD>
    <TD>1    </TD>
    <TD>10:Q9BQ99      </TD>
  </TR>
  <TR>
    <TD>IFVGGINPEATEEKIR    </TD>
    <TD>54.63    </TD>
    <TD>109    </TD>
    <TD>2    </TD>
    <TD>23:PC4375      </TD>
  </TR>
  <TR>
    <TD>VGAVAGNDWLIWDITR    </TD>
    <TD>63.06    </TD>
    <TD>113    </TD>
    <TD>1    </TD>
    <TD>35:Q9H644      </TD>
  </TR>
  <TR>
    <TD>VGAVAGNDWIIWDITR    </TD>
    <TD>63.06    </TD>
    <TD>113    </TD>
    <TD>2    </TD>
    <TD>32:Q9CWU9      </TD>
  </TR>
  <TR>
    <TD>LFIGGLSFETTDESLR    </TD>
    <TD>61.89    </TD>
    <TD>117    </TD>
    <TD>1    </TD>
    <TD>25:1HA11      </TD>
  </TR>
  <TR>
    <TD>LFIGGLSFETTEESLR    </TD>
    <TD>61.89    </TD>
    <TD>117    </TD>
    <TD>2    </TD>
    <TD>8:AAC26867  21:S40776      </TD>
  </TR>
  <TR>
    <TD>LFIGGLSFETTDDSLR    </TD>
    <TD>61.89    </TD>
    <TD>117    </TD>
    <TD>3    </TD>
    <TD>26:Q9CRI0      </TD>
  </TR>
  <TR>
    <TD>MTDQEAIQDLWQWR    </TD>
    <TD>58.31    </TD>
    <TD>118    </TD>
    <TD>1    </TD>
    <TD>9:Q96AT6      </TD>
  </TR>
  <TR>
    <TD>GFSEGLWEIENNPTVK    </TD>
    <TD>54.12    </TD>
    <TD>119    </TD>
    <TD>1    </TD>
    <TD>24:Q9XSK7      </TD>
  </TR>
  <TR>
    <TD>QAWFIENEEQEYVQTVK    </TD>
    <TD>71.47    </TD>
    <TD>132    </TD>
    <TD>1    </TD>
    <TD>1:LUHU      </TD>
  </TR>
  <TR>
    <TD>LGEDNINVVEGNEQFISASK    </TD>
    <TD>83.36    </TD>
    <TD>134    </TD>
    <TD>1    </TD>
    <TD>4:TRBOTR  6:1NTP      </TD>
  </TR>
  <TR>
    <TD>MSVQPTVSLGGFEITPPVVLR    </TD>
    <TD>81.19    </TD>
    <TD>140    </TD>
    <TD>1    </TD>
    <TD>9:Q96AT6      </TD>
  </TR>
  <TR>
    <TD>GGPGSAVSPYPTFNPSSDVAALHK    </TD>
    <TD>64.58    </TD>
    <TD>149    </TD>
    <TD>1    </TD>
    <TD>1:LUHU      </TD>
  </TR>
</TABLE>
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


repeat_search.cpp

Repeating a search from a Mascot results file.

/*
##############################################################################
# file: repeat_search.cpp                                                    #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/repeat_search.cpp $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"
#include <stdio.h>  // For 'popen'
#include <iostream>
#include <sstream>
#include <string>

#ifdef _WIN32
#define popen  _popen
#define pclose _pclose
#endif

using namespace matrix_science;

// forward declarations
static bool repeatSearch(const char * filename);
static int  usage(const char * progName);
static void compareResults(ms_mascotresfile & originalSearch,
                           const char * repeatedSearchFileName);

int main(int argc, char * argv[])
{
    if (argc == 2)
        return repeatSearch(argv[1]);
    else
        return usage(argv[0]);
}

static bool repeatSearch(const char * filename)
{
    bool success = false;

    ms_mascotresfile file(filename);
    if (file.isValid())
    {
        std::ostringstream s;     // Build up a MIME format string with all parameters
        s << "----12345\n"
          << "Content-Disposition: form-data; name=\"QUE\""
          << std::endl << std::endl;

        // Parameters section
        int count = 1;
        std::string key = file.enumerateSectionKeys(ms_mascotresfile::SEC_PARAMETERS,
                                                    count);
        while (!key.empty())
        {
            std::string val = file.getSectionValueStr(ms_mascotresfile::SEC_PARAMETERS,
                                         key.c_str());
            // To search against a different database, add && key != "DB"
            if (!val.empty() && key != "INTERMEDIATE" && key != "RULES" && key != "SEARCH")
                s << key << "=" << val << std::endl;
            key = file.enumerateSectionKeys(ms_mascotresfile::SEC_PARAMETERS, ++count);
        }
        // To search against a different DB add: s << "DB=MY_DB" << std::endl;

        // Most flexible to repeat each search as a 'sequence' search.
        s << "SEARCH=SQ" << std::endl;

        // For ms-ms data, tell nph-mascot where to find the ions data
        s << "INTERMEDIATE=" << filename << std::endl;

        // Now the repeat search data
        for (int q=1; q <= file.getNumQueries(); q++)
            s << file.getRepeatSearchString(q) << std::endl;

        s << "----12345--\n"; // terminating line for MIME format file

        // Start nph-mascot.exe, and redirect the output to tmp.txt
        // Note that for Unix, you may need to use ./nph-mascot.exe
        FILE * f = popen("./nph-mascot.exe 4 -commandline > tmp.txt", "w"); // 4 = repeat search
        if (f)
        {
            fwrite(s.str().c_str(), s.str().length(), 1, f);
            pclose(f);

            if ((f = fopen("tmp.txt", "r")) != 0)
            {
                char buf[1000];
                while (fgets(buf, sizeof(buf), f))
                {
                    if (strstr(buf, "SUCCESS") && fgets(buf, sizeof(buf), f))
                    {
                        if (buf[strlen(buf)-1] == '\n')
                            buf[strlen(buf)-1] = '\0';
                        compareResults(file, buf);
                        success = true;
                    }
                    else if (strstr(buf, "ERROR"))
                    {
                        std::cout << "Search failed: " << buf;
                        while (fgets(buf, sizeof(buf), f))
                        {
                            std::cout << buf;
                        }
                    }
                }
                fclose(f);
            }
            else
            {
                std::cout << "Can't open tmp file. \n";
            }
        }
        else
        {
            std::cout << "Cannot open pipe to nph-mascot.exe to repeat search for file "
                      << filename << std::endl;
        }
    }
    else
    {
        std::cout << "Cannot open results file " << filename
                  << " " << file.getLastErrorString() << std::endl;
    }
    return success;
}

static void compareResults(ms_mascotresfile & originalSearch,
                           const char * repeatedSearchFileName)
{
    ms_mascotresfile repeatedSearch(repeatedSearchFileName);
    bool anyReport = false;

    if (repeatedSearch.isValid())
    {
        if (originalSearch.anyPMF())
        {
            // Use protein summary
            ms_proteinsummary originalResults(originalSearch);
            ms_proteinsummary repeatedResults(repeatedSearch);

            ms_protein * originalProt = originalResults.getHit(1);
            ms_protein * repeatedProt = repeatedResults.getHit(1);
            if (originalProt && repeatedProt)
            {
                double diff = repeatedProt->getScore()-originalProt->getScore();
                if (diff > 10.0)
                {
                    std::cout << "Protein score is "
                              << diff
                              << " higher for search "
                              << originalSearch.getFileName()
                              << " than "
                              << repeatedSearchFileName
                              << std::endl;
                    anyReport = true;
                }
            }
        }
        else
        {
            // Use peptide summary
            ms_peptidesummary originalResults(originalSearch);
            ms_peptidesummary repeatedResults(repeatedSearch);

            // Compare peptide scores
            for (int q=1; q <= originalSearch.getNumQueries(); q++)
            {
                ms_peptide * pepOriginal, *pepRepeated;
                if (originalResults.getPeptide(q, 1, pepOriginal)
                &&  repeatedResults.getPeptide(q, 1, pepRepeated))
                {
                    double diff = pepRepeated->getIonsScore()
                                - pepOriginal->getIonsScore();
                    if (diff > 10.0)
                    {
                        std::cout << "Query " << q
                                  << "has score " << diff
                                  << " higher for search "
                                  << originalSearch.getFileName()
                                  << " than "
                                  << repeatedSearchFileName
                                  << std::endl;

                        anyReport = true;
                    }
                }
            }
        }
        if (!anyReport)
            std::cout << "Similar results for "
                      << originalSearch.getFileName()
                      << " and "
                      << repeatedSearchFileName
                      << std::endl;
    }
    else
        std::cout << "Invalid repeat search "
                  << repeatedSearch.getLastErrorString();
}

static int usage(const char * progName)
{
    std::cout << progName << " results_file " << std::endl
              << "Given an mascot results file name, repeat the search "
              << "against the same data" << std::endl
              << "   results_file is a full path to a results file" << std::endl
              << "The program must be run from the mascot cgi directory"
              << std::endl;
    return 1;
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


repeat_search.cs

Repeating a search from a Mascot results file.

/*
##############################################################################
# file: repeat_search.cs                                                #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/repeat_search.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Diagnostics;
using System.IO;
using System.Text;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class repeat_search
    {
        public static void Main(string[] argv)
        {
            if (argv.Length < 1)
            {
                usage();
                return;
            }
            repeatSearch(argv[0]);
        }

        private static bool repeatSearch(string filename)
        {
            bool success = false;

            ms_mascotresfile file = new ms_mascotresfile(filename, 0, "");
            if (file.isValid())
            {
                StringBuilder s = new StringBuilder();            // Build up a MIME format string with all parameters
                s.Append("----12345\n");
                s.Append("Content-Disposition: form-data; name=\"QUE\"");
                s.Append("\n\n");

                // Parameters section
                int count = 1;
                string key = file.enumerateSectionKeys(ms_mascotresfile.section.SEC_PARAMETERS, count);
                while (key.Length != 0)
                {
                    string val = file.getSectionValueStr(ms_mascotresfile.section.SEC_PARAMETERS, key);
                    // To search against a different database, add && key != "DB"
                    if (val.Length > 0 && !key.Equals("INTERMEDIATE") && !key.Equals("RULES") && !key.Equals("INTERNALS") && !key.Equals("SEARCH"))
                    {
                        s.Append(string.Format("{0}={1}\n", key, val));
                    }
                    key = file.enumerateSectionKeys(ms_mascotresfile.section.SEC_PARAMETERS, ++count);
                }
                // To search against a different DB add: s.Append("DB=MY_DB\n");
                //s.Append("DB=repeat\n");

                // Most flexible to repeat each search as a 'sequence' search.
                s.Append("SEARCH=SQ\n");

                // For ms-ms data, tell nph-mascot where to find the ions data
                s.Append("INTERMEDIATE=").Append(filename).Append("\n");

                // Now the repeat search data
                for (int q = 1; q <= file.getNumQueries(); q++)
                {
                    s.Append(file.getRepeatSearchString(q)).Append("\n");
                }
                s.Append("----12345--\n");

                // Start nph-mascot.exe, and redirect the output to tmp.txt
                // Note that for Unix, you may need to use ./nph-mascot.exe
                try
                {
                    ProcessStartInfo start = new ProcessStartInfo();
                    start.FileName = @"./nph-mascot.exe";
                    start.Arguments = "4 -commandline";
                    start.RedirectStandardOutput = true;
                    start.RedirectStandardInput = true;
                    start.UseShellExecute = false;

                    using (Process process = Process.Start(start))
                    {
                        using (StreamWriter writer = process.StandardInput)
                        {
                            writer.Write(s.ToString());
                            writer.Flush();
                        }
                        using (StreamReader reader = process.StandardOutput)
                        {
                            string buf;
                            while ((buf = reader.ReadLine()) != null)
                            {
                                if (buf.Contains("SUCCESS"))
                                {
                                    if ((buf = reader.ReadLine()) != null)
                                    {
                                        Console.WriteLine(buf);
                                        compareResults(file, buf);
                                        success = true;
                                    }
                                }
                                else if (buf.Contains("ERROR"))
                                {

                                }
                            }
                        }
                    }

                }
                catch (Exception e)
                {
                    Console.WriteLine(e.Message);
                }
            }
            else
            {
                Console.WriteLine("Cannot open results file {0}", filename);
                Console.WriteLine(file.getLastErrorString());
            }

            return success;
        }

        private static void compareResults(ms_mascotresfile originalSearch, string repeatedSearchFileName)
        {
            ms_mascotresfile repeatedSearch = new ms_mascotresfile(repeatedSearchFileName, 0, "");
            Boolean anyReport = false;
            if (repeatedSearch.isValid())
            {
                if (originalSearch.anyPMF())
                {
                    // Use protein summary
                    ms_proteinsummary originalResults = new ms_proteinsummary(originalSearch,
                        (uint) ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, null);
                    ms_proteinsummary repeatedResults = new ms_proteinsummary(repeatedSearch,
                        (uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, null);

                    ms_protein originalProt = originalResults.getHit(1);
                    ms_protein repeatedProt = repeatedResults.getHit(1);
                    if (originalProt != null & repeatedProt != null)
                    {
                        double diff = repeatedProt.getScore() - originalProt.getScore();
                        if (diff > 10)
                        {
                            Console.WriteLine("Protein score is {0} higher for search {1} than {2}",
                                diff, repeatedSearchFileName, originalSearch.getFileName());
                            anyReport = true;
                        }
                    }
                }
                else
                {
                    // use peptide summary
                    ms_peptidesummary originalResults = new ms_peptidesummary(originalSearch,
                        (uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, 0, 0, null);

                    ms_peptidesummary repeatedResults = new ms_peptidesummary(repeatedSearch,
                        (uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS, 0, 1, null, 0, 0, null);

                    // Compare peptide scores
                    for (int q = 1; q <= originalSearch.getNumQueries(); q++)
                    {
                        ms_peptide pepOriginal = originalResults.getPeptide(q, 1);
                        ms_peptide pepRepeated = repeatedResults.getPeptide(q, 1);
                        if (pepOriginal != null && pepRepeated != null)
                        {
                            double diff = pepRepeated.getIonsScore() - pepOriginal.getIonsScore();
                            if (diff > 10)
                            {
                                Console.WriteLine("Query {0} has core {1} higher for search {2} than {3}",
                                    q, diff, repeatedSearchFileName, originalSearch.getFileName());
                                anyReport = true;
                            }
                        }
                    }
                }
                if (!anyReport)
                {
                    Console.WriteLine("Similar results for {0} and {1}", originalSearch.getFileName(), repeatedSearchFileName);
                }
            }
            else
            {
                Console.WriteLine("Invalid repeat search: {0}", repeatedSearch.getLastErrorString());
            }
        }

        private static void usage()
        {
            Console.WriteLine("Usage: repeat_search <results_file> ");
            Console.WriteLine("Given a mascot results file name, repeat the search ");
            Console.WriteLine("against the same data");
            Console.WriteLine("   result_file is a full path to a result file");
            Console.WriteLine("The program must be run from the mascot cgi directory");
        }
    }
}

/*
C:\inetpub\mascot\cgi>repeat_search.exe ..\data\F981123.dat
Will give the following output:

../data/20150728/F002065.dat
Similar results for ..\data\F981123.dat and ../data/20150728/F002065.dat
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


repeat_search.java

Repeating a search from a Mascot results file.

/*
##############################################################################
# file: repeat_search.java                                                   #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/repeat_searc $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;
import java.io.*;

public class repeat_search {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load.\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[]) {
        // ----- Object creation -----
        if(argv.length < 1) {
            usage();
            System.exit(0);
        }
        repeatSearch(argv[0]);
    }

    private static boolean repeatSearch(String filename) {
        boolean success = false;

        ms_mascotresfile file = new ms_mascotresfile(filename, 0, "");
        if (file.isValid()) {
            String s;     // Build up a MIME format string with all parameters
            s = "----12345\n";
            s += "Content-Disposition: form-data; name=\"QUE\"";
            s += "\n\n";

            // Parameters section
            int count = 1;
            String key = file.enumerateSectionKeys(ms_mascotresfile.SEC_PARAMETERS,
                                                   count);
            while (key.length() != 0)
            {
                String val = file.getSectionValueStr(ms_mascotresfile.SEC_PARAMETERS,
                                                     key);
                // To search against a different database, add && key != "DB"
                if ((val.length()) != 0 && !key.equals("INTERMEDIATE") && !key.equals("RULES") && !key.equals("INTERNALS") && !key.equals("SEARCH"))
                    s += key+ "=" +val+ "\n";
                key = file.enumerateSectionKeys(ms_mascotresfile.SEC_PARAMETERS, ++count);

            }
            // To search against a different DB add: s += "DB=MY_DB\n";
            s += "DB=repeat\n";

            // Most flexible to repeat each search as a 'sequence' search.
            s += "SEARCH=SQ\n";

            // For ms-ms data, tell nph-mascot where to find the ions data
            s += "INTERMEDIATE=" +filename+ "\n";

            // Now the repeat search data
            for (int q=1; q <= file.getNumQueries(); q++) {
                s += file.getRepeatSearchString(q) + "\n";
            }

            s += "----12345--\n"; // terminating line for MIME format file
            System.out.println(s);

            // Start nph-mascot.exe, and redirect the output to tmp.txt
            // Note that for Unix, you may need to use ./nph-mascot.exe
            try {
                String runTimeCommand;
                runTimeCommand = "./nph-mascot.exe 4 -commandline > tmp.txt";
                Process p = Runtime.getRuntime().exec(runTimeCommand);
                OutputStream output = p.getOutputStream();
                BufferedWriter bwrite = new BufferedWriter(new OutputStreamWriter(output));

                InputStream input = p.getInputStream();
                BufferedReader bread = new BufferedReader(new InputStreamReader(input));

                bwrite.write(s);
                bwrite.close();
                int returnValue = p.waitFor();

                String buf = null;
                while((buf = bread.readLine()) != null){
                    if (buf.indexOf("SUCCESS") != -1) {
                        if ((buf = bread.readLine()) != null){
                            System.out.println(buf);
                            compareResults(file, buf);
                            success = true;
                        }
                    } else if (buf.indexOf("ERROR") != -1) {
                        System.out.println("Search failed: " +buf);
                        while ((buf = bread.readLine()) != null) {
                            System.out.println(buf);
                        }
                    }
                }
                bread.close();

            }
            catch(java.io.IOException e){
                e.printStackTrace();
            }
            catch(java.lang.InterruptedException e){
                e.printStackTrace();
            }
        }
        else
        {
            System.out.println("Cannot open results file " +filename);
            System.out.println(file.getLastErrorString() + "\n");
        }
        return success;
    }

    private static void compareResults(ms_mascotresfile originalSearch,
                                       String repeatedSearchFileName)
    {
        ms_mascotresfile repeatedSearch = new ms_mascotresfile(repeatedSearchFileName, 0, "");
        boolean anyReport = false;

        if (repeatedSearch.isValid()) {
            if (originalSearch.anyPMF()) {
                // Use protein summary
                ms_proteinsummary originalResults
                    = new ms_proteinsummary(originalSearch,
                                            ms_mascotresults.MSRES_GROUP_PROTEINS,
                                            0, 1, null, null);
                ms_proteinsummary repeatedResults
                    = new ms_proteinsummary(repeatedSearch,
                                            ms_mascotresults.MSRES_GROUP_PROTEINS,
                                            0, 1, null, null);

                ms_protein  originalProt = originalResults.getHit(1);
                ms_protein  repeatedProt = repeatedResults.getHit(1);
                if (originalProt != null && repeatedProt != null) {
                    double diff = repeatedProt.getScore() - originalProt.getScore();
                    if (diff > 10.0) {
                        System.out.println("Protein score is "
                                            + diff
                                            + " higher for search "
                                            +  originalSearch.getFileName()
                                            + " than "
                                            + repeatedSearchFileName
                                            + "\n");
                        anyReport = true;
                    }
                }
            } else {
                // Use peptide summary
                ms_peptidesummary originalResults
                    = new ms_peptidesummary(originalSearch,
                                            ms_mascotresults.MSRES_GROUP_PROTEINS,
                                            0, 1, null, 0, 0, null);

                ms_peptidesummary repeatedResults
                    = new ms_peptidesummary(repeatedSearch,
                                            ms_mascotresults.MSRES_GROUP_PROTEINS,
                                            0, 1, null, 0, 0, null);

                // Compare peptide scores
                for (int q=1; q <= originalSearch.getNumQueries(); q++) {
                    ms_peptide pepOriginal = originalResults.getPeptide(q, 1);
                    ms_peptide pepRepeated = repeatedResults.getPeptide(q, 1);
                    if (pepOriginal != null && pepRepeated != null) {
                        double diff = pepRepeated.getIonsScore()
                                    - pepOriginal.getIonsScore();
                        if (diff > 10.0) {
                            System.out.println("Query "
                                                + q
                                                + "has score " + diff
                                                + " higher for search "
                                                + originalSearch.getFileName()
                                                + " than "
                                                + repeatedSearchFileName
                                                + "\n");

                            anyReport = true;
                        }
                    }
                }
            }
            if (!anyReport) {
                System.out.println("Similar results for "
                                   + originalSearch.getFileName()
                                   + " and "
                                   + repeatedSearchFileName
                                   + "\n");
            }
        } else {
            System.out.println("Invalid repeat search "
                               + repeatedSearch.getLastErrorString());
        }
    }

    private static void usage()
    {
        System.out.println("Usage: java repeat_search <results_file> ");
        System.out.println("Given an mascot results file name, repeat the search ");
        System.out.println("against the same data");
        System.out.println("   results_file is a full path to a results file");
        System.out.println("The program must be run from the mascot cgi directory");
    }
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


repeat_search.pl

Repeating a search from a Mascot results file.

#!/usr/local/bin/perl
##############################################################################
# file: repeat_search.pl                                                     #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/repeat_search.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

# This script must be run in the Mascot Server cgi directory.

use lib '../bin';
use msparser;

if (!defined($ARGV[0])) {
    usage();
    exit(1);
}
# If this script is being run as a cgi script, then a
# boundary string may be set in the environment.
# This will be different from the simple boundary string defined
# below, so nph-mascot.exe will fail. The following two
# lines clear the relevant environment variables.
delete $ENV{'CONTENT_TYPE'};
delete $ENV{'CONTENT_LENGTH'};

repeatSearch($ARGV[0]);

sub repeatSearch {
    my ($filename) = @_;

    my $resfile = new msparser::ms_mascotresfile($filename);

    if (!$resfile->isValid) {
        print "Cannot open results file ", $filename, ": ";
        print $resfile->getLastErrorString(), "\n";
        return;
    }

    my @s = ();

    push @s, "----12345";
    push @s, 'Content-Disposition: form-data; name="QUE"';
    push @s, '';

    # Parameters section
    my $count = 1;
    my $key = $resfile->enumerateSectionKeys(
        $msparser::ms_mascotresfile::SEC_PARAMETERS, $count
    );

    while ($key) {
        my $val = $resfile->getSectionValueStr(
            $msparser::ms_mascotresfile::SEC_PARAMETERS, $key
        );

        # To search against a different database, add 'and key ne "DB"'
        if ($val
                and ($key ne "INTERMEDIATE")
                and ($key ne "RULES")
                and ($key ne "INTERNALS")
                and ($key ne "SEARCH")) {
            push @s, $key . "=" . $val;
        }

        ++$count;
        $key = $resfile->enumerateSectionKeys(
            $msparser::ms_mascotresfile::SEC_PARAMETERS, $count
        );
    }

    # To search against a different DB add e.g.
    # push @s, "DB=MY_DB";

    # Most flexible to repeat each search as a 'sequence' search.
    push @s, "SEARCH=SQ";

    # For ms-ms data, tell nph-mascot where to find the ions data
    push @s, "INTERMEDIATE=" . $filename;

    # Now the repeat search data
    for my $q (1 .. $resfile->getNumQueries) {
        push @s, $resfile->getRepeatSearchString($q);
    }

    # Terminating line for MIME format file
    push @s, "----12345--";

    # Start nph-mascot.exe, and redirect the output to tmp.txt
    # (Could use open2 here, but this can be unreliable with nph-mascot.exe)
    # For Unix systems, change nph-mascot.exe to ./nph-mascot.exe
    open (my $sock, "| nph-mascot.exe 4 -commandline > tmp.txt");
    print $sock $_, "\n" for @s;
    close $sock;

    open(my $fh, '<', 'tmp.txt');

    while (<$fh>) {
        if ( /SUCCESS/ ) {
            # Next line contains the results file name
            chomp(my $buffer = <$fh>);

            compareResults($resfile, $buffer);
            next;
        }

        if ( /ERROR/ ) {
            print "Search failed: ", $_;
            # Print details of error messages
            print while <$fh>;
            next;
        }
    }
}

sub compareResults {
    my ($originalSearch, $repeatedSearchFileName) = @_;

    my $repeatedSearch = new msparser::ms_mascotresfile($repeatedSearchFileName);
    my $anyReport = 0;

    if (!$repeatedSearch->isValid()) {
        print "Invalid repeat search: ",$repeatedSearch->getLastErrorString(), "\n";
        return;
    }

    if ($originalSearch->anyPMF()) {
        # Use protein summary
        my $originalResults = new msparser::ms_proteinsummary($originalSearch);
        my $repeatedResults = new msparser::ms_proteinsummary($repeatedSearch);

        my $originalProt = $originalResults->getHit(1);
        my $repeatedProt = $repeatedResults->getHit(1);

        if ($originalProt and $repeatedProt) {
            my $diff = $repeatedProt->getScore() - $originalProt->getScore();

            if ($diff > 10.0) {
                print "Protein score is ", $diff, " higher for search ";
                print $originalSearch->getFileName();
                print " than ";
                print $repeatedSearchFileName;
                print "\n";

                $anyReport = 1;
            }
        }
    } else {
        #  Use peptide summary
        my $originalResults = new msparser::ms_peptidesummary($originalSearch);
        my $repeatedResults = new msparser::ms_peptidesummary($repeatedSearch);

        # Compare peptide scores
        for my $q (1 .. $originalSearch->getNumQueries) {
            my $pepOriginal = $originalResults->getPeptide($q, 1);
            my $pepRepeated = $repeatedResults->getPeptide($q, 1);
            my $diff = $pepRepeated->getIonsScore() - $pepOriginal->getIonsScore();

            if ($diff > 10.0) {
                print "Query ", $q, " has score ", $diff;
                print " higher for search ", $originalSearch->getFileName();
                print " than ", $repeatedSearchFileName, "\n";

                $anyReport = 1;
            }
        }
    }

    if (!$anyReport) {
        print "Similar results for ", $originalSearch->getFileName();
        print " and ", $repeatedSearchFileName, "\n";
    }
}

sub usage {
    print <<EOF;
Usage: repeat_search.pl <results file>

Given an mascot results file name, repeat the search against the same data.

The program must be run from the mascot cgi directory.
EOF
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


repeat_search.py

Repeating a search from a Mascot results file.

#!/usr/bin/perl
##############################################################################
# file: repeat_search.py                                                     #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/repeat_search.py $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys
import subprocess
import re

def main() :
    if len(sys.argv) < 2 :
        usage()
        return 1

    return repeatSearch(sys.argv[1])

def repeatSearch(filename) :
    resfile = msparser.ms_mascotresfile(filename)

    if not resfile.isValid() :
        print("Cannot open results file %s : %s" % (filename, resfile.getLastErrorString()))
        return 1

    s = []

    s.append("----12345")
    s.append('Content-Disposition: form-data; name="QUE"')
    s.append('')

    # Parameters section
    sec_params = msparser.ms_mascotresfile.SEC_PARAMETERS
    count = 1
    key = resfile.enumerateSectionKeys(sec_params, count)

    while len(key) > 0 :
        val = resfile.getSectionValueStr(sec_params, key)

        # To search against a different database, add 'and key ne "DB"'
        if len(val) > 0 and key != "INTERMEDIATE" and key != "RULES" and key != "INTERNALS" and key != "SEARCH" :
            s.append("%s=%s" % (key, val))

        count += 1
        key = resfile.enumerateSectionKeys(sec_params, count)

    # To search against a different DB add e.g.
    # s.append("DB=MY_DB")

    # Most flexible to repeat each search as a 'sequence' search.
    s.append("SEARCH=SQ")

    # For ms-ms data, tell nph-mascot where to find the ions data
    s.append("INTERMEDIATE=" + filename)

    # Now the repeat search data.
    for q in range(1, 1 + resfile.getNumQueries()) :
        s.append(resfile.getRepeatSearchString(q))

    # Terminating line for MIME format file
    s.append("----12345--")

    # Start nph-mascot.exe, and redirect the output to tmp.txt.
    try :
        tmp = open("tmp.txt", "w")

    except IOError as err:
        errno, strerror = err.args
        print("Cannot open tmp.txt for writing: %s" % strerror)
        return 1
    # Replace 'nph-mascot.exe' with './nph-mascot.exe' in Unix.

    try :
        proc = subprocess.Popen(
                ['./nph-mascot.exe', '4', '-commandline'],
                stdin=subprocess.PIPE,
                stdout=tmp
                )
    except OSError as e :
        print("Cannot run nph-mascot.exe: %s" % e)
        return 1

    for line in s :
        proc.stdin.write(line.encode('utf-8'))
        proc.stdin.write("\n".encode('utf-8'))

    proc.stdin.close()
    proc.wait()

    tmp.close()

    try :
        tmp = open("tmp.txt", "r")
    except IOError as err:
        errno, strerror = err.args
        print("Cannot open tmp.txt for reading: %s" % strerror)
        return 1

    while True :
        line = tmp.readline()

        if len(line) == 0 : break

        if re.match('.*SUCCESS.*', line) :
            # Next line contains the results file name
            line = tmp.readline()

            compareResults(resfile, line.rstrip('\n'))
            continue

        if re.match('.*ERROR.*', line) :
            print("Search failed:", line.rstrip('\n'))
            # Print details of error messages

            while len(line) != 0 :
                line = tmp.readline()
                print(line.rstrip('\n'))

            break

def compareResults(originalSearch, repeatedSearchFileName) :
    repeatedSearch = msparser.ms_mascotresfile(repeatedSearchFileName)
    anyReport = 0

    if not repeatedSearch.isValid() :
        print("Invalid repeat search: %s" % repeatedSearch.getLastErrorString())
        return

    if originalSearch.anyPMF() :
        # Use protein summary
        originalResults = msparser.ms_proteinsummary(originalSearch)
        repeatedResults = msparser.ms_proteinsummary(repeatedSearch)

        originalProt = originalResults.getHit(1)
        repeatedProt = repeatedResults.getHit(1)

        if originalProt and repeatedProt :
            diff = repeatedProt.getScore() - originalProt.getScore()

            if diff > 10.0 :
                print("Protein score is %d higher for search" % diff)
                print("%s than %s " % (originalSearch.getFileName(), repeatedSearchFileName))

                anyReport = 1
    else :
        #  Use peptide summary
        originalResults = msparser.ms_peptidesummary(originalSearch)
        repeatedResults = msparser.ms_peptidesummary(repeatedSearch)

        # Compare peptide scores
        for q in range(1, 1 + originalSearch.getNumQueries()) :
            pepOriginal = originalResults.getPeptide(q, 1)
            pepRepeated = repeatedResults.getPeptide(q, 1)
            diff = pepRepeated.getIonsScore() - pepOriginal.getIonsScore()

            if diff > 10.0 :
                print("Query %d has score %d higher for search %s than %s" % (q, diff, originalSearch.getFileName(), repeatedSearchFileName))

                anyReport = 1

    if not anyReport :
        print("Similar results for %s and %s" % (originalSearch.getFileName(), repeatedSearchFileName))

def usage() :
    print("""
Usage: repeat_search.py <results file>

Given an mascot results file name, repeat the search against the same data.

This program must be run in the Mascot Server cgi directory.
""")

if __name__ == "__main__" :
    sys.exit(main())
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


resfile_customquantitation.cs

Example program illustrating basic usage of ms_customquantitation.

/*
##############################################################################
# file: resfile_customquantitation.cs                                        #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_customquantitation.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Collections.Generic;
using matrix_science.msparser;

namespace MsParserExamples
{
    class resfile_customquantitation
    {
        public static int Main(string[] argv)
        {
            Dictionary<string, List<int[]>> proteinPeptideMap = new Dictionary<string, List<int[]>>()
            {
                {"ALBU_HUMAN", new List<int[]> {
                    {new int[] {1,1}},
                    {new int[] {2,1}},
                    {new int[] {3,1}}
                }},
                {"ALBU_BOVIN", new List<int[]> {
                    {new int[] {2,2}},
                    {new int[] {5,1}},
                    {new int[] {7,1}}
                }}
            };

            Dictionary<string, int> peptideIntensities = new Dictionary<string, int>
            {
                {"q1p1", 1000},
                {"q2p1", 500},
                {"q3p1", 750},
                {"q2p2", 750},
                {"q5p1", 2000},
                {"q7p1", 1000}
            };

            ms_quant_method qmethod = new ms_quant_method();

            ms_quant_average average = new ms_quant_average();
            average.setReferenceAccession("ALBU_HUMAN");
            average.setReferenceAmount("1.0");
            // We set the number of top N peptides to 2, so we expect the following
            // peptide intensities to be used:
            //   ALBU_HUMAN = 1000, 750
            //   ALBU_BOVIN = 2000, 1000
            average.setNumPeptides(2);

            ms_quant_protocol protocol = new ms_quant_protocol();
            protocol.setAverage(average);
            qmethod.setProtocol(protocol);

            // Since ms_customquantitation does not use the ratio definitions in the
            // quantitation method, we need not define them at all. Ratios are meaningless
            // in the Average protocol anyway, so we can use any name we want to denote
            // the intensity values.
            String rationame = "amount";
            setParams(qmethod, "none", "none", "average", 1);

            ms_customquantitation customquant = new ms_customquantitation(qmethod);
            if (!customquant.isValid())
            {
                Console.Error.WriteLine(customquant.getLastErrorString());
                return 1;
            }

            dumpWarnings(customquant.getErrorHandler());
            customquant.clearAllErrors();
            dumpQuantMethod(qmethod, new string[] {rationame});

            // Create the protein-peptide mapping
            foreach (string accession in proteinPeptideMap.Keys)
            {
                List<int[]> peptides = proteinPeptideMap[accession];
                foreach (int[] peptide in peptides)
                {
                    customquant.addPeptideQuantKey(accession, 0, new ms_peptide_quant_key(peptide[0], peptide[1]));
                }
            }

            // Add peptide intensities
            foreach (string qp in peptideIntensities.Keys)
            {
                double intensity = peptideIntensities[qp];
                int q, p;
                extractQP(qp, out q, out p);
                ms_peptide_quant_ratio ratio = new ms_peptide_quant_ratio(new ms_peptide_quant_key(q, p), rationame, intensity);
                customquant.addPeptideRatio(ratio);
            }
            Console.WriteLine();

            // print it all out immediately
            foreach (string accession in proteinPeptideMap.Keys)
            {
                Console.WriteLine(accession);
                List<int[]> aPeptides = proteinPeptideMap[accession];

                ms_protein_quant_ratio ratio = customquant.getProteinRatio(accession, 0, rationame);
                if (ratio.isMissing())
                {
                    Console.WriteLine("{0} ---", rationame);
                }
                else
                {
                    Console.WriteLine("{0} = {1}, stderr = {2}, n = {3} normal-p = {4}, hypo-p = {5}",
                                rationame, ratio.getValue(), ratio.getStandardError(),
                                ratio.getSampleSize(), ratio.getNormalityPvalue(),
                                ratio.getHypothesisPvalue()
                            );
                }

                Console.WriteLine("{0} {1}", "Peptide".PadRight(10), rationame.PadRight(10));
                foreach(int[] peptide in aPeptides)
                {
                    ms_peptide_quant_ratio pepRatio = customquant.getPeptideRatio(new ms_peptide_quant_key(peptide[0], peptide[1]), rationame);
                    string ratioValue;
                    if (pepRatio.isMissing())
                    {
                        ratioValue = "---".PadLeft(10);
                    }
                    else if (pepRatio.isInfinite())
                    {
                        ratioValue = "###".PadLeft(10);
                    }
                    else
                    {
                        ratioValue = string.Format("{0:0.######}", pepRatio.getValue()).PadLeft(10);
                    }
                    Console.WriteLine("{0} {1}", string.Format("q{0}_p{1}", peptide[0], peptide[1]).PadLeft(10), ratioValue);
                }
                Console.WriteLine();

            }

            return 0;
        }

        private static void extractQP(string qp, out int q, out int p)
        {
            string[] bits = qp.Split('p');
            bits[0] = bits[0].Replace("q", "");
            q = Int32.Parse(bits[0]);
            p = Int32.Parse(bits[1]);
        }

        private static void dumpQuantMethod(ms_quant_method qmethod, string[] ratioNames)
        {
            {
                List<string> comps = new List<string>();
                for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
                {
                    comps.Add(qmethod.getComponentByNumber(i).getName());
                }
                Console.WriteLine("Components: [{0}]", string.Join(", ", comps));
            }

            Console.WriteLine("Report ratios: [{0}]", string.Join(", ", ratioNames));
            Console.WriteLine("Protein ratio type = {0}", qmethod.getProteinRatioType());
            Console.WriteLine("Min. number of peptides = {0}", qmethod.getMinNumPeptides());

            if (qmethod.haveQuality())
            {
                var q = qmethod.getQuality();
                Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
                Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
                Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
            }
            else
            {
                Console.WriteLine("Quality: no restrictions");
            }

            if (qmethod.haveNormalisation())
            {
                var q = qmethod.getNormalisation();
                Console.WriteLine("Normalisation = {0}", q.getMethod());
            }
            else
            {
                Console.WriteLine("Normalisation: none");
            }

            if (qmethod.haveOutliers())
            {
                var q = qmethod.getOutliers();
                Console.WriteLine("Outliers = {0}", q.getMethod());
            }
            else
            {
                Console.WriteLine("Outliers: none");
            }
        }

        private static void dumpWarnings(ms_errs ms_errs)
        {
            for (int i = 1; i <= ms_errs.getNumberOfErrors(); i++)
            {
                Console.Error.WriteLine("Warning: {0}", ms_errs.getErrorString(i));
            }
        }

        private static void setParams(ms_quant_method qmethod, string normalisationMethod, string outliersMethod, string proteinRatioType, int minNoPeptides)
        {
            ms_quant_quality quality = (qmethod.haveQuality()) ? qmethod.getQuality() : new ms_quant_quality();
            ms_quant_normalisation normalisation = (qmethod.haveNormalisation()) ? qmethod.getNormalisation() : new ms_quant_normalisation();
            ms_quant_outliers outliers = (qmethod.haveOutliers()) ? qmethod.getOutliers() : new ms_quant_outliers();

            normalisation.setMethod((string.IsNullOrEmpty(normalisationMethod)) ? "none" : normalisationMethod);
            outliers.setMethod((string.IsNullOrEmpty(outliersMethod)) ? "none" : outliersMethod);
            qmethod.setMinNumPeptides((minNoPeptides > 1) ? minNoPeptides : 2);
            qmethod.setProteinRatioType((string.IsNullOrEmpty(proteinRatioType)) ? "none" : proteinRatioType);
            quality.setMinPrecursorCharge(1);
            quality.setPepThresholdType("maximum expect");
            quality.setPepThresholdValue("0.05");

            qmethod.setQuality(quality);
            qmethod.setNormalisation(normalisation);
            qmethod.setOutliers(outliers);
        }
    }
}

/*
resfile_customquantitation.exe
Will give the following output:

Components: []
Report ratios: [amount]
Protein ratio type = average
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = maximum expect
Quality: pep. threshold value = 0.05
Normalisation = none
Outliers = none

ALBU_HUMAN
amount = 721.124785153704, stderr = 1.2226920025227, n = 3 normal-p = 0.813227565666875, hypo-p = 0.000932101414662601
Peptide    amount
     q1_p1       1000
     q2_p1        500
     q3_p1        750

ALBU_BOVIN
amount = 1144.71424255333, stderr = 1.33788997067188, n = 3 normal-p = 0.552542164299708, hypo-p = 0.00170392414333331
Peptide    amount
     q2_p2        750
     q5_p1       2000
     q7_p1       1000
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


resfile_customquantitation.java

Example program illustrating basic usage of ms_customquantitation.

/*
 * ##############################################################################
 * # file: resfile_customquantitation                                           #
 * # Mascot Parser toolkit example code                                         #
 * ##############################################################################
 * # COPYRIGHT NOTICE                                                           #
 * # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
 * #                                                                            #
 * ##############################################################################
 */

import java.util.ArrayList;
import java.util.Arrays;
import java.util.HashMap;
import java.util.List;
import java.util.Set;
import matrix_science.msparser.ms_customquantitation;
import matrix_science.msparser.ms_errs;
import matrix_science.msparser.ms_peptide_quant_key;
import matrix_science.msparser.ms_peptide_quant_ratio;
import matrix_science.msparser.ms_protein_quant_ratio;
import matrix_science.msparser.ms_quant_average;
import matrix_science.msparser.ms_quant_method;
import matrix_science.msparser.ms_quant_normalisation;
import matrix_science.msparser.ms_quant_outliers;
import matrix_science.msparser.ms_quant_protocol;
import matrix_science.msparser.ms_quant_quality;

public class resfile_customquantitation {

    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String[] args) {
        HashMap<String, List<Integer[]>> hmProteinPeptideMapping = new HashMap<String, List<Integer[]>>();
        ArrayList<Integer[]> aAlbuHuman = new ArrayList<Integer[]>();
        aAlbuHuman.add(new Integer[]{1,1});
        aAlbuHuman.add(new Integer[]{2,1});
        aAlbuHuman.add(new Integer[]{3,1});
        hmProteinPeptideMapping.put("ALBU_HUMAN", aAlbuHuman);
        ArrayList<Integer[]> aAlbuBovin = new ArrayList<Integer[]>();
        aAlbuBovin.add(new Integer[]{2,2});
        aAlbuBovin.add(new Integer[]{5,1});
        aAlbuBovin.add(new Integer[]{7,1});
        hmProteinPeptideMapping.put("ALBU_BOVIN", aAlbuBovin);

        HashMap<String, Double> hmPeptideIntensities = new HashMap<String,Double>();
        hmPeptideIntensities.put("q1p1",1000d);
        hmPeptideIntensities.put("q2p1",500d);
        hmPeptideIntensities.put("q3p1",750d);
        hmPeptideIntensities.put("q2p2",750d);
        hmPeptideIntensities.put("q5p1",2000d);
        hmPeptideIntensities.put("q7p1",1000d);

        ms_quant_method qmethod = new ms_quant_method();
        ms_quant_average average = new ms_quant_average();
        average.setReferenceAccession("ALBU_HUMAN");
        average.setReferenceAmount("1.0");

        // We set the number of top N peptides to 2, so we expect the following
        // peptide intensities to be used:
        //   ALBU_HUMAN = 1000, 750
        //   ALBU_BOVIN = 2000, 1000
        average.setNumPeptides(2);

        ms_quant_protocol protocol = new ms_quant_protocol();
        protocol.setAverage(average);
        qmethod.setProtocol(protocol);

        // Since ms_customquantitation does not use the ratio definitions in the
        // quantitation method, we need not define them at all. Ratios are meaningless
        // in the Average protocol anyway, so we can use any name we want to denote
        // the intensity values.
        String rationame = "amount";

        setParams(qmethod, "none", "none", "average", 1);

        ms_customquantitation customquant = new ms_customquantitation(qmethod);

        if(!customquant.isValid()) {
            System.err.println(customquant.getLastErrorString());
            System.exit(1);
        }

        dumpWarnings(customquant.getErrorHandler());
        customquant.clearAllErrors();
        dumpQuantMethod(qmethod, new String[] {rationame});

        // create the protein-peptide mapping
        Set<String> aProteinAccessions = hmProteinPeptideMapping.keySet();
        for(String sAccession : aProteinAccessions) {
            List<Integer[]> aPeptides = hmProteinPeptideMapping.get(sAccession);
            for(Integer[] aQP : aPeptides) {
                customquant.addProteinPeptideKey(sAccession, 0, new ms_peptide_quant_key(aQP[0], aQP[1]));
            }
        }

        // add peptide intensities
        Set<String> aPeptideQP = hmPeptideIntensities.keySet();
        for(String qp : aPeptideQP) {
            double dIntensity = hmPeptideIntensities.get(qp);
            int[] aQP = extractQP(qp);
            ms_peptide_quant_ratio ratio = new ms_peptide_quant_ratio(new ms_peptide_quant_key(aQP[0], aQP[1]), rationame, dIntensity);
            customquant.addPeptideRatio(ratio);
        }

        System.out.println();

        // print is all out immediately
        for(String sAccession : aProteinAccessions) {
            System.out.printf("%s\n", sAccession);
            List<Integer[]> aPeptides = hmProteinPeptideMapping.get(sAccession);

            ms_protein_quant_ratio ratio = customquant.getProteinRatio(sAccession, 0, rationame);

            if(ratio.isMissing()) {
                System.out.printf("%10s: ---", rationame);
            } else {
                System.out.printf("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n", rationame, ratio.getValue(), ratio.getStandardError(), ratio.getSampleSize(), ratio.getNormalityPvalue(), ratio.getHypothesisPvalue());
            }
            System.out.println();
            StringBuilder sbPeptideRatioHeader = new StringBuilder();
            sbPeptideRatioHeader.append(String.format("%10s", "Peptide"));
            sbPeptideRatioHeader.append(" ");
            sbPeptideRatioHeader.append(String.format("%10s",rationame));
            System.out.println(sbPeptideRatioHeader);

            for(Integer[] aQP : aPeptides) {
                List<String> aValues = new ArrayList<String>();
                ms_peptide_quant_ratio oRatio = customquant.getPeptideRatio(new ms_peptide_quant_key(aQP[0],aQP[1]), rationame);

                if(oRatio.isMissing()) {
                    aValues.add(String.format("%10s", "---"));
                }
                if(oRatio.isInfinite()) {
                    aValues.add(String.format("%10s", "---"));
                } else {
                    aValues.add(String.format("%10g", oRatio.getValue()));
                }

                StringBuilder sbValues = new StringBuilder();
                for(String sValue : aValues) {
                    if(sbValues.length() > 0) sbValues.append(" ");
                    sbValues.append(sValue);
                }
                System.out.printf("%10s %s\n", String.format("q%d_p%d", aQP[0], aQP[1]), sbValues);
            }

            System.out.println();
        }
    }

    private static void setParams(ms_quant_method qmethod, String normalisation, String outliers, String proteinRatioType, int iMinNoPeptides) {
        ms_quant_quality oQuality = null;
        if(qmethod.haveQuality()) {
            oQuality = qmethod.getQuality();
        } else {
            oQuality = new ms_quant_quality();
        }

        ms_quant_normalisation oNormalisation = null;

        if(qmethod.haveNormalisation()) {
            oNormalisation = qmethod.getNormalisation();
        } else {
            oNormalisation = new ms_quant_normalisation();
        }

        ms_quant_outliers oOutliers = null;

        if(qmethod.haveOutliers()) {
            oOutliers = qmethod.getOutliers();
        } else {
            oOutliers = new ms_quant_outliers();
        }

        if(normalisation == null || normalisation.length() == 0) normalisation = "none";
        if(outliers == null || outliers.length() == 0) outliers = "none";
        if(iMinNoPeptides <= 0) iMinNoPeptides = 2;
        if(proteinRatioType == null || proteinRatioType.length() == 0) proteinRatioType="Average";

        oNormalisation.setMethod(normalisation);
        oOutliers.setMethod(outliers);
        qmethod.setMinNumPeptides(iMinNoPeptides);
        qmethod.setProteinRatioType(proteinRatioType);
        oQuality.setMinPrecursorCharge(1);
        oQuality.setPepThresholdType("maximum expect");
        oQuality.setPepThresholdValue("0.05");

        qmethod.setQuality(oQuality);
        qmethod.setNormalisation(oNormalisation);
        qmethod.setOutliers(oOutliers);
    }

    private static void dumpWarnings(ms_errs errorHandler) {
        for(int i = 1; i <= errorHandler.getNumberOfErrors(); i++) {
            System.out.println("Warning: "+errorHandler.getErrorString(i));
        }
    }

    private static void dumpQuantMethod(ms_quant_method qmethod, String[] aRatioNames) {
        String[] aComps = new String[qmethod.getNumberOfComponents()];
        for(int i = 0; i < qmethod.getNumberOfComponents(); i++) {
            aComps[i] = qmethod.getComponentByNumber(i).getName();
        }
        System.out.printf("Components: [%s]\n", Arrays.toString(aComps));

        System.out.printf("Report ratios: [%s]\n", Arrays.toString(aRatioNames));

        System.out.printf("Protein ratio type = %s\n", qmethod.getProteinRatioType());
        System.out.printf("Min. number of peptides = %d\n", qmethod.getMinNumPeptides());

        if(qmethod.haveQuality()) {
            ms_quant_quality quality = qmethod.getQuality();
            System.out.printf("Quality: min. precursor charge = %s\n", quality.getMinPrecursorCharge());
            System.out.printf("Quality: pep. threshold type = %s\n", quality.getPepThresholdType());
            System.out.printf("Quality: pep. threshold value = %s\n", quality.getPepThresholdValue());
        } else {
            System.out.print("Quality: no restrictions\n");
        }

        if(qmethod.haveNormalisation()) {
            System.out.printf("Normalisation = %s\n", qmethod.getNormalisation().getMethod());
        } else {
            System.out.print("Normalisation: none\n");
        }

        if(qmethod.haveOutliers()) {
            System.out.printf("Outliers = %s\n", qmethod.getOutliers().getMethod());
        } else {
            System.out.print("Outliers: none\n");
        }
    }

    private static int[] extractQP(String qp) {
        String[] aBits = qp.split("p");
        aBits[0] = aBits[0].replace("q", "");
        return new int[] {Integer.parseInt(aBits[0]), Integer.parseInt(aBits[1])};
    }

}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


resfile_customquantitation.pl

Example program illustrating basic usage of ms_customquantitation.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_customquantitation.pl                                        #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_customquantitation.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
use warnings;
##############################################################################

use msparser;

# This example uses fictitious data to illustrate how ms_customquantitation can
# be used with the Average protocol. In a real situation peptide intensities
# and the protein-peptide mapping would come from some external source.

my @protein_peptide_mapping = (
    { accession => 'ALBU_HUMAN', peptides => [ [1, 1], [2, 1], [3, 1] ] },
    { accession => 'ALBU_BOVIN', peptides => [ [2, 2], [5, 1], [7, 1] ] },
);

my %peptide_intensities = (
    'q1p1' => 1_000,
    'q2p1' => 500,
    'q3p1' => 750,

    'q2p2' => 750,
    'q5p1' => 2_000,
    'q7p1' => 1_000,
);

my $qmethod = msparser::ms_quant_method->new();

do {
    my $average = msparser::ms_quant_average->new;
    $average->setReferenceAccession('ALBU_HUMAN');
    $average->setReferenceAmount('1.0');

    # We set the number of top N peptides to 2, so we expect the following
    # peptide intensities to be used:
    #   ALBU_HUMAN = 1000, 750
    #   ALBU_BOVIN = 2000, 1000
    $average->setNumPeptides(2);

    my $p = msparser::ms_quant_protocol->new;
    $p->setAverage($average);
    $qmethod->setProtocol($p);
};

# Since ms_customquantitation does not use the ratio definitions in the
# quantitation method, we need not define them at all. Ratios are meaningless
# in the Average protocol anyway, so we can use any name we want to denote
# the intensity values.
my $rationame = "amount";

set_params($qmethod,
    normalisation => 'none',
    outliers => 'none',
    protein_ratio_type => 'average',
    min_num_peptides => 1,
);

my $customquant = msparser::ms_customquantitation->new($qmethod);

if (not $customquant->isValid) {
    print STDERR $customquant->getLastErrorString(), "\n";
    exit 1;
}

dump_warnings($customquant->getErrorHandler());
$customquant->clearAllErrors();

dump_quant_method($qmethod, [$rationame]);

# Create the protein-peptide mapping:

for (@protein_peptide_mapping) {
    my ($acc, $peptides) = @$_{qw(accession peptides)};

    for (@$peptides) {
        # Note that the q,p arguments to ms_peptide_quant_key must be integers.
        # Otherwise the wrong constructor is chosen. Adding to 0 converts the
        # values to integers.

        $customquant->addPeptideQuantKey($acc, 0, msparser::ms_peptide_quant_key->new(0+$$_[0], 0+$$_[1]));
    }
}

# Add peptide intensities:

for (keys %peptide_intensities) {
    my ($q, $p) = $_ =~ /q(\d+)p(\d+)/;

    my $ratio = msparser::ms_peptide_quant_ratio->new(msparser::ms_peptide_quant_key->new(0+$q, 0+$p), $rationame, $peptide_intensities{$_});
    $customquant->addPeptideRatio($ratio);
}

print "\n";

# Print it all out immediately:

for my $mapping (@protein_peptide_mapping) {
    printf "%s:\n", $$mapping{'accession'};

    my $ratio = $customquant->getProteinRatio($$mapping{'accession'}, 0, $rationame);

    if ($ratio->isMissing()) {
        printf "%10s: ---\n", $rationame;
    } else {
        printf "%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
            $rationame, $ratio->getValue(), $ratio->getStandardError(),
            $ratio->getSampleSize(), $ratio->getNormalityPvalue(),
            $ratio->getHypothesisPvalue();
    }

    print "\n";
    print join(' ', map { sprintf("%10s", $_) } 'Peptide', $rationame), "\n";

    for (@{ $$mapping{'peptides'} }) {
        my ($q, $p) = @$_;

        my @values = ();

        my $ratio = $customquant->getPeptideRatio(msparser::ms_peptide_quant_key->new(0+$q, 0+$p), $rationame);

        if ($ratio->isMissing()) {
            push @values, sprintf("%10s", '---');
        } elsif ($ratio->isInfinite()) {
            push @values, sprintf("%10s", '###');
        } else {
            push @values, sprintf("%10g", $ratio->getValue());
        }

        printf "%10s %s\n", sprintf("q%d_p%d", $q, $p), join(' ', @values);
    }

    print "\n";
}

sub set_params {
    my ($qmethod, %h) = @_;

    my $quality;

    if ($qmethod->haveQuality) {
        $quality = $qmethod->getQuality();
    } else {
        $quality = msparser::ms_quant_quality->new();
    }

    my $normalisation;

    if ($qmethod->haveNormalisation) {
        $normalisation = $qmethod->getNormalisation();
    } else {
        $normalisation = msparser::ms_quant_normalisation->new();
    }

    my $outliers;

    if ($qmethod->haveOutliers) {
        $outliers = $qmethod->getOutliers();
    } else {
        $outliers = msparser::ms_quant_outliers->new();
    }

    $normalisation->setMethod($h{'normalisation'} || 'none');
    $outliers->setMethod($h{'outliers'} || 'none');
    $qmethod->setMinNumPeptides($h{'min_num_peptides'} || 2);
    $qmethod->setProteinRatioType($h{'protein_ratio_type'} || 'average');
    $quality->setMinPrecursorCharge($h{'min_precursor_charge'} || 1);
    $quality->setPepThresholdType($h{'pep_threshold_type'} || 'maximum expect');
    $quality->setPepThresholdValue($h{'pep_threshold_value'} || '0.05');

    $qmethod->setQuality($quality);
    $qmethod->setNormalisation($normalisation);
    $qmethod->setOutliers($outliers);
}

sub dump_quant_method {
    my ($qmethod, $rationames) = @_;

    do {
        my @comps = ();

        for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
            my $comp = $qmethod->getComponentByNumber($i);
            $comps[$i] = $comp->getName();
        }

        printf "Components: [%s]\n", join(', ', @comps);
    };

    printf "Report ratios: [%s]\n", join(', ', @$rationames);

    printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
    printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();

    if ($qmethod->haveQuality()) {
        my $q = $qmethod->getQuality();
        printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
        printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
        printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
    } else {
        printf "Quality: no restrictions\n";
    }

    if ($qmethod->haveNormalisation()) {
        my $q = $qmethod->getNormalisation();
        printf "Normalisation = %s\n", $q->getMethod();
    } else {
        printf "Normalisation: none\n";
    }

    if ($qmethod->haveOutliers()) {
        my $q = $qmethod->getOutliers();
        printf "Outliers = %s\n", $q->getMethod();
    } else {
        printf "Outliers: none\n";
    }
}

sub dump_warnings {
    my ($err) = @_;

    for my $i (1 .. $err->getNumberOfErrors()) {
        print 'Warning: ', $err->getErrorString($i), "\n";
    }
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


resfile_customquantitation.py

Example program illustrating basic usage of ms_customquantitation.

#!/usr/bin/python
##############################################################################
# file: resfile_customquantitation.py                                        #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/resfile_customquantitation.py $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################

import msparser
import sys
import re

def main():

# This example uses fictitious data to illustrate how ms_customquantitation can
# be used with the Average protocol. In a real situation peptide intensities
# and the protein-peptide mapping would come from some external source.

    protein_peptide_mapping = {'ALBU_HUMAN': [ [1, 1], [2, 1], [3, 1] ],
                           'ALBU_BOVIN': [ [2, 2], [5, 1], [7, 1] ]}

    peptide_intensities = {'q1p1': 1000, 'q2p1': 500, 'q3p1': 750, 'q2p2': 750, 'q5p1': 2000, 'q7p1': 1000}

    qmethod = msparser.ms_quant_method()
    average = msparser.ms_quant_average()

    average.setReferenceAccession("ALBU_HUMAN")
    average.setReferenceAmount("1.0")

# We set the number of top N peptides to 2, so we expect the following
# peptide intensities to be used:
#   ALBU_HUMAN = 1000, 750
#   ALBU_BOVIN = 2000, 1000
    average.setNumPeptides(2)

    p = msparser.ms_quant_protocol()
    p.setAverage(average)
    qmethod.setProtocol(p)

# Since ms_customquantitation does not use the ratio definitions in the
# quantitation method, we need not define them at all. Ratios are meaningless
# in the Average protocol anyway, so we can use any name we want to denote
# the intensity values.

    rationame = "amount"
    h = {'normalisation': 'none', 'outliers': 'none', 'protein_ratio_type': 'average', 'min_num_peptides': 2}
    set_params(qmethod, h)

    customquant = msparser.ms_customquantitation(qmethod)

    if not customquant.isValid():
        print(customquant.getLastErrorString())
        sys.exit(1)

    dump_warnings(customquant.getErrorHandler())
    customquant.clearAllErrors()

    dump_quant_method(qmethod, rationame)

# Create the protein-peptide mapping

    for accession in protein_peptide_mapping:
        peptides = protein_peptide_mapping[accession]
        for peptide in peptides:
            customquant.addPeptideQuantKey(accession, 0, msparser.ms_peptide_quant_key(peptide[0], peptide[1]))

# Add peptide intensities

    for keys in peptide_intensities:
        match = re.match(r"[a-z](\d+)[a-z](\d+)", keys)
        q = int(match.group(1))
        p = int(match.group(2))
        ratioValue = peptide_intensities[keys]
        quantKey = msparser.ms_peptide_quant_key(q, p)
        ratio = msparser.ms_peptide_quant_ratio(quantKey, rationame, ratioValue)
        customquant.addPeptideRatio(ratio)

    print("\n")

# Print it all out immediately:

    for accession in protein_peptide_mapping:
        print("%s:" %(accession))
        ratio = customquant.getProteinRatio(accession, 0, rationame)

        if ratio.isMissing():
            print("%10s: ---" %(rationame))
        else:
            print("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g" %(rationame, ratio.getValue(), ratio.getStandardError_only(), ratio.getSampleSize(), ratio.getNormalityPvalue_only(), ratio.getHypothesisPvalue_only()))

        print(" %10s    %s" %('Peptide', rationame))

        peptides = protein_peptide_mapping[accession]
        for i in ms_range(1, len(peptides)-1):
            peptide = peptides[i]
            for i in range(len(peptide)):
                q = peptide[0]
                p = peptide[1]

            values = ''

            ratio = customquant.getPeptideRatio(msparser.ms_peptide_quant_key(q, p), rationame)

            if ratio.isMissing():
                values = "---"
            elif ratio.isInfinite():
                values = "###"
            else:
                values = ratio.getValue()

            print("    %-9s  %-10s" %("q%d_p%d" %(q, p), str(values)))

        print("\n")

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

def set_params(qmethod, h):

    if qmethod.haveQuality():
        quality = qmethod.getQuality()
    else:
        quality = msparser.ms_quant_quality()

    if qmethod.haveNormalisation():
        normalisation = qmethod.getNormalisation()
    else:
        normalisation = msparser.ms_quant_normalisation()

    if qmethod.haveOutliers():
        outliers = qmethod.getOutliers()
    else:
        outliers = msparser.ms_quant_outliers()

    normalisation.setMethod(h['normalisation'])
    outliers.setMethod(h['outliers'])
    qmethod.setMinNumPeptides(h['min_num_peptides'])
    qmethod.setProteinRatioType(h['protein_ratio_type'])
    quality.setMinPrecursorCharge(1)
    quality.setPepThresholdType('maximum expect')
    quality.setPepThresholdValue('0.05')

    qmethod.setQuality(quality)
    qmethod.setNormalisation(normalisation)
    qmethod.setOutliers(outliers)

def dump_quant_method(qmethod, rationames):

    comps = []

    for i in ms_range(1, qmethod.getNumberOfComponents()-1):
        comp = qmethod.getComponentByNumber(i)
        comps.append(comp.getName())

    print("Components: %s" %(comps))
    print("Report ratios: %s" %(rationames))

    print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
    print("Min. number of peptides: %d" %(qmethod.getMinNumPeptides()))

    if qmethod.haveQuality():
        q = qmethod.getQuality()
        print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
        print("QualityL pep. threshold type = %s" %(q.getPepThresholdType()))
        print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
    else:
        print("Quality: no restrictions")

    if qmethod.haveNormalisation():
        q = qmethod.getNormalisation()
        print("Normalisation = %s" %(q.getMethod()))
    else:
        print("Normalisation: none")

    if qmethod.haveOutliers():
        q = qmethod.getOutliers()
        print("Outliers = %s" %(q.getMethod()))
    else:
        print("Outliers: none")

def dump_warnings(err):
    for i in range(1, err.getNumberOfErrors()):
        print("Warning: %s" %(err.getErrorString(i)))

if __name__ == "__main__":
    main()

'''
resfile_customquantitation.py
Will give the following output:

Components: []
Report ratios: amount
Protein ratio type = average
Min. number of peptides: 2
Quality: min. precursor charge = 1
QualityL pep. threshold type = maximum expect
Quality: pep. threshold value = 0.05
Normalisation = none
Outliers = none

ALBU_HUMAN:
    amount =    721.125, stderr =    1.22269, N = 3, normal-p = 0.813228, hypo-p = 0.000932101
    Peptide    amount
    q1_p1      1000.0
    q2_p1      500.0
    q3_p1      750.0

ALBU_BOVIN:
    amount =    1144.71, stderr =    1.33789, N = 3, normal-p = 0.552542, hypo-p = 0.00170392
    Peptide    amount
    q2_p2      750.0
    q5_p1      2000.0
    q7_p1      1000.0

'''
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:17


resfile_error.cpp

Example program for handling errors in the Mascot results files.

/*
##############################################################################
# file: resfile_error.cpp                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/resfile_error.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
#include "msparser.hpp"

#include <iostream>
#include <time.h>
#include <iomanip>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* Local functions                                                           */
/* (This test harness is 'C' and not C++)                                    */
/*****************************************************************************/
static void checkErrorHandler(ms_mascotresfile & file);

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - the name of the .dat file      */
/*****************************************************************************/
int main(int argc, char * argv[])
{
    if (argc == 2)
    {
        ms_mascotresfile file(argv[1]);

        if (file.isValid())
        {
            checkErrorHandler(file);
        }
        else
            std::cout << "Error: " << file.getLastErrorString() << std::endl;
    }
    else
        std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
    return 0;
}

/*****************************************************************************/
/* checkErrorHandler                                                         */
/* Calls a couple of functions with invalid arguments                        */
/*****************************************************************************/
static void checkErrorHandler(ms_mascotresfile & file)
{
    std::cout << "Testing the error handling...            "      << std::endl;
    std::cout << "========================================="      << std::endl;

    int numQueries = file.getNumQueries();

    file.getObservedCharge(numQueries + 40);  // Should fail
    std::cout << "Error number: " << file.getLastError()           << std::endl;
    std::cout << "Error string: " << file.getLastErrorString()     << std::endl;

    file.clearAllErrors();
    std::cout << "Cleared all errors - should have no errors left: "
              << file.getNumberOfErrors()
              << " errors left"
              << std::endl << std::endl;

    for (int x=1; x <= 20; x++)
        file.getObservedCharge(numQueries + x);  // Should fail

    // Now, the best way, print out all errors.
    std::cout << "More errors added - there are now "
              << file.getNumberOfErrors()
              << " errors"
              << std::endl;

    for (int i=1; i <= file.getNumberOfErrors(); i++)
    {
        std::cout << "Error number: "
                  << file.getErrorNumber(i)
                  << " : "
                  << file.getErrorString(i)
                  << std::endl;
    }

    std::cout << std::endl;
    file.clearAllErrors();
}

/*
will give the output:

# resfile_error_handling F981123.dat

Testing the error handling...
=========================================
Error number: 4
Error string: c:\inetpub\mascot\data\F981123.dat. Query out of range.
In function getObservedCharge. Request query 44, num queries: 4
Cleared all errors - should have no errors left: 0 errors left

More errors added - there are now 2 errors
Error number: 4 : c:\inetpub\mascot\data\F981123.dat. Query out of range. In function
getObservedCharge. Request query 5, num queries: 4
Error number: 4 : c:\inetpub\mascot\data\F981123.dat. Query out of range. In function
getObservedCharge. Request query 6, num queries: 4 (Error repeated 19 times)

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_error.cs

Example program for handling errors in the Mascot results files.

/*
##############################################################################
# file: resfile_error.cs                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_error.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class resfile_error
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.WriteLine("Must specify results filename as parameter");
                return;
            }

            ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
            if (file.isValid())
            {
                checkErrorHandler(file);
            }
            else
            {
                Console.WriteLine("Error number: {0}", file.getLastError());
                Console.WriteLine("Error string: {0}", file.getLastErrorString());
                return;
            }
        }

        private static void checkErrorHandler(ms_mascotresfile file)
        {
            int numberOfQueries, loop, loopTwo;

            Console.WriteLine("Testing the error handling...            ");
            Console.WriteLine("=========================================");

            numberOfQueries = file.getNumQueries();
            file.getObservedCharge(numberOfQueries + 40);                   // should fail
            Console.WriteLine("Error number: {0}", file.getLastError());
            Console.WriteLine("Error string: {0}", file.getLastErrorString());

            file.clearAllErrors();
            Console.WriteLine("Cleared all errors - should have no errors left: {0} errors left", file.getNumberOfErrors());

            for (loop = 1; loop <= 20; loop++)
            {
                file.getObservedCharge(numberOfQueries + loop);     // should fail
            }

            // Now, the best way, print out all errors
            Console.WriteLine("More errors added - there are now {0} errors", file.getNumberOfErrors());

            for (loopTwo = 1; loopTwo <= file.getNumberOfErrors(); loopTwo++)
            {
                Console.WriteLine("Error number: {0} : {1}", file.getErrorNumber(loopTwo), file.getErrorString(loopTwo));
            }

            Console.WriteLine();
            file.clearAllErrors();
        }

    }
}

/*

resfile_error.exe c:\inetpub\mascot\data\F001261.dat

Will give the following output:

Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 7
7368, num queries: 77328
Cleared all errors - should have no errors left: 0 errors left
More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 77329, num queries: 77328
Error number: 4 : Query out of range. In function getObservedCharge. Request query 77330, num queries: 77328 (Error repeated 19 times)
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_error.java

Example program for handling errors in the Mascot results files.

/*
##############################################################################
# file: resfile_error.java                                                   #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2004 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_errorha $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class resfile_error {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("Must specify results filename as parameter");
            System.exit(0);
        }

        ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
        if (file.isValid()) {
            checkErrorHandler(file);
        } else {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }
    }

    private static void checkErrorHandler(ms_mascotresfile file) {
        int numberOfQueries;
        int loop;
        int loopTwo;

        System.out.println("Testing the error handling...            ");
        System.out.println("=========================================");

        numberOfQueries = file.getNumQueries();
        file.getObservedCharge(numberOfQueries+40);                // should fail
        System.out.println("Error number: "+file.getLastError());
        System.out.println("Error string: "+file.getLastErrorString());

        file.clearAllErrors();
        System.out.print("Cleared all errors - should have no errors left: "+file.getNumberOfErrors());
        System.out.println(" errors left\n");

        for(loop=1; loop <= 20; loop++) {
            file.getObservedCharge(numberOfQueries+loop);          // should fail
        }

        // Now, the best way, print out all errors.
        System.out.println("More errors added - there are now "+file.getNumberOfErrors()+" errors");

        for(loopTwo=1; loopTwo <= file.getNumberOfErrors(); loopTwo++) {
            System.out.print("Error number: "+file.getErrorNumber(loopTwo));
            System.out.print(" : "+file.getErrorString(loopTwo));
            System.out.println("");
        }

        System.out.println("");
        file.clearAllErrors();
    }
}

/*

will give the output:

C:>java -classpath .;../java/msparser.jar test_errorhandler F981123.dat
Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 44, num queries: 4
Cleared all errors - should have no errors left: 0 errors left

More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 5, num queries: 4
Error number: 4 : Query out of range. In function getObservedCharge. Request query 6, num queries: 4 (Error repeated 19 times)

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_error.pl

Example program for handling errors in the Mascot results files.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_error_handling.pl                                            #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_error.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }

my $file = new msparser::ms_mascotresfile($ARGV[0]);

if ($file->isValid) {
    checkErrorHandler($file);
}

##############################################################################
# checkErrorHandler                                                          #
#  - parameter 0  ms_mascotresfile                                           #
# Calls a couple of functions with invalid arguments                         #
##############################################################################
sub checkErrorHandler {
    my ($resfile) = @_;

    print "Testing the error handling...            \n";
    print "=========================================\n";

    my $numQueries = $resfile->getNumQueries();
    $resfile->getObservedCharge($numQueries + 40);  # Should fail

    print "Error number: ", $resfile->getLastError(), "\n";
    print "Error string: ", $resfile->getLastErrorString(), "\n";

    $resfile->clearAllErrors();
    print "Cleared all errors - should have no errors left: ", $resfile->getNumberOfErrors();
    print " errors left\n\n";

    for my $x (1 .. 20) {
        $resfile->getObservedCharge($numQueries + $x);  # Should fail
    }

    # Now, the best way, print out all errors.
    print "More errors added - there are now ", $resfile->getNumberOfErrors();
    print " errors\n";

    for my $i (1 .. $resfile->getNumberOfErrors) {
        print "Error number: ", $resfile->getErrorNumber($i);
        print " : ", $resfile->getErrorString($i);
        print "\n";
    }

    print "\n";
    $resfile->clearAllErrors();
}

=pod

Running the program as 'perl resfile_error.pl ../data/F981123.dat' will
give the following output under Mascot Server 2.3:

Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 107, num queries: 67
Cleared all errors - should have no errors left: 0 errors left

More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 68, num queries: 67
Error number: 4 : Query out of range. In function getObservedCharge. Request query 69, num queries: 67 (Error repeated 19 times)

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_error.py

Example program for handling errors in the Mascot results files.

#!/usr/bin/python
##############################################################################
# file: resfile_error.py                                                     #
# 'msparser' toolkit example code                                            #
#                                                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/resfile_error.py $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import sys
import msparser

def main() :
    if len(sys.argv) < 2 :
        print("Must specify results filename as parameter")
        return 1

    file = msparser.ms_mascotresfile(sys.argv[1])

    if file.isValid() :
        checkErrorHandler(file)
    else :
        print("Invalid file: %s" % file.getLastErrorString())

def checkErrorHandler(resfile) :
    """
    Calls a couple of functions with invalid arguments, then prints
    their error messages.
    """

    print("Testing the error handling...            ")
    print("=========================================")

    numQueries = resfile.getNumQueries()
    resfile.getObservedCharge(numQueries + 40);  # Should fail

    print("Error number: %s" % resfile.getLastError())
    print("Error string: %s" % resfile.getLastErrorString())

    resfile.clearAllErrors()
    print("Cleared all errors - should have no errors left: %s errors left" %resfile.getNumberOfErrors())

    for x in range(1, 21) :
        resfile.getObservedCharge(numQueries + x);  # Should fail

    # Now, the best way, print out all errors.
    print("More errors added - there are now %s errors" % resfile.getNumberOfErrors())

    for i in range(1, 1 + resfile.getNumberOfErrors()) :
        print("Error number: %s : %s" % (resfile.getErrorNumber(i), resfile.getErrorString(i)))

    print(" ")
    resfile.clearAllErrors()

if __name__ == "__main__":
    sys.exit(main())

""" Running the program as

python resfile_error.py F981123.dat

will give the following output:

Testing the error handling...
=========================================
Error number: 4
Error string: Query out of range. In function getObservedCharge. Request query 107, num queries: 67
Cleared all errors - should have no errors left: 0 errors left
More errors added - there are now 2 errors
Error number: 4 : Query out of range. In function getObservedCharge. Request query 68, num queries: 67
Error number: 4 : Query out of range. In function getObservedCharge. Request query 69, num queries: 67 (Error repeated 19 times)

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_info.cpp

Example program for retrieving general search information.

/*
##############################################################################
# file: resfile_info.cpp                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/resfile_info.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

#include "msparser.hpp"
#include <iostream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* Local functions                                                           */
/* (This test harness is 'C' and not C++)                                    */
/*****************************************************************************/
static void searchInformation(ms_mascotresfile & file);

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - the name of the .dat file      */
/*****************************************************************************/
int main(int argc, char * argv[])
{
    if (argc == 2)
    {
        ms_mascotresfile file(argv[1]);

        if (file.isValid())
        {
            searchInformation(file);
        }
        else
            std::cout << "Error: " << file.getLastErrorString() << std::endl;
    }
    else
        std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
    return 0;
}

/*****************************************************************************/
/* searchInformation                                                         */
/* Display parameters from the ms_mascotresfile object. The functions        */
/* anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF     */
/* etc. because some people submit MSMS though the sequence query window.    */
/*****************************************************************************/
static void searchInformation(ms_mascotresfile & file)
{
    time_t t = (time_t)file.getDate();
    struct tm * t1 = localtime(&t);

    std::cout << "Search information from ms_mascotresfile"       << std::endl;
    std::cout << "========================================"       << std::endl;
    std::cout << "Number of queries   : " << file.getNumQueries()  << std::endl;
    std::cout << "Number of hits      : " << file.getNumHits()     << std::endl;
    std::cout << "Number of sequences : " << file.getNumSeqs()     << std::endl;
    std::cout << "Sequences after tax : " << file.getNumSeqsAfterTax()
                                                                  << std::endl;
    std::cout << "Number of residues  : " << file.getNumResidues() << std::endl;
    std::cout << "Execution time      : " << file.getExecTime()    << std::endl;
    std::cout << "Date (seconds)      : " << file.getDate()        << std::endl;
    std::cout << "Date                : " << asctime(t1);
    std::cout << "Mascot version      : " << file.getMascotVer()   << std::endl;
    std::cout << "Fasta version       : " << file.getFastaVer()    << std::endl;
    std::cout << "Is PMF?             : " << file.isPMF()          << std::endl;
    std::cout << "Is MSMS?            : " << file.isMSMS()         << std::endl;
    std::cout << "Is SQ?              : " << file.isSQ()           << std::endl;
    std::cout << "Is Error tolerant   : " << file.isErrorTolerant()<< std::endl;
    std::cout << "Any PMF?            : " << file.anyPMF()         << std::endl;
    std::cout << "Any MSMS?           : " << file.anyMSMS()        << std::endl;
    std::cout << "Any SQ?             : " << file.anySQ()          << std::endl;
    std::cout << "Any peptides section: " << file.doesSectionExist(ms_mascotresfile::SEC_PEPTIDES)
                                                                  << std::endl;
    std::cout << "Any peptide matches : " << file.anyPeptideSummaryMatches()
                                                                  << std::endl;
    std::cout << std::endl;
}

/*

will give the output:

# test.exe F981123.dat

Search information from ms_mascotresfile
========================================
Number of queries   : 4
Number of hits      : 50
Number of sequences : 820227
Sequences after tax : 820227
Number of residues  : 2.55697e+008
Execution time      : 14
Date (seconds)      : 1014568786
Date                : Sun Feb 24 16:39:46 2002
Mascot version      : 1.7.17
Fasta version       : MSDB_20020121.fasta
Is PMF?             : 0
Is MSMS?            : 1
Is SQ?              : 0
Is Error tolerant   : 0
Any PMF?            : 0
Any MSMS?           : 1
Any SQ?             : 0
Any peptides section: 1
Any peptide matches : 1

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_info.cs

Example program for retrieving general search information.

/*
##############################################################################
# file: resfile_info.cs                                                      #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_info.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
 */

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class resfile_info
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.WriteLine("Must specify results filename as parameter");
                return;
            }

            ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
            if (file.isValid())
            {
                searchInformation(file);
            }
            else
            {
                Console.WriteLine("Error number: {0}", file.getLastError());
                Console.WriteLine("Error string: {0}", file.getLastErrorString());
                return;
            }

        }

        private static void searchInformation(ms_mascotresfile file)
        {
            DateTime searchDate;                        // C# DateTime struct
            int seconds = file.getDate();               // get date of search in seconds since midnight GMT Jan 1st 1970
            long milliseconds = (long) seconds * 1000;        // convert to milliseconds
            searchDate = (new DateTime(1970, 1, 1)).AddMilliseconds(milliseconds);    // create the DateTime struct.  .NET DateTime
                                                                                // are intialised to 1/1/0001, so we need to reset to
                                                                                // 1/1/1970

            Console.WriteLine("Search information from ms_mascotresfile");
            Console.WriteLine("========================================");

            Console.WriteLine("Number of queries    : {0}", file.getNumQueries());
            Console.WriteLine("Number of hits       : {0}", file.getNumHits());
            Console.WriteLine("Number of sequences  : {0}", file.getNumSeqs());
            Console.WriteLine("Sequences after tax  : {0}", file.getNumSeqsAfterTax());
            Console.WriteLine("Number of residues   : {0}", (int) file.getNumResidues());
            Console.WriteLine("Execution time       : {0}", file.getExecTime());
            Console.WriteLine("Date (seconds)       : {0}", file.getDate());
            Console.WriteLine("Date                 : {0}", searchDate.ToString("ddd MMM dd hh:mm:ss yyyy")); // Change output format to match Perl
            Console.WriteLine("Mascot version       : {0}", file.getMascotVer());
            Console.WriteLine("Fasta version        : {0}", file.getFastaVer());

            // make C# output identical to perl output
            Console.WriteLine("Is PMF?              : {0}", toBinary(file.isPMF()));
            Console.WriteLine("Is MSMS?             : {0}", toBinary(file.isMSMS()));
            Console.WriteLine("Is SQ?               : {0}", toBinary(file.isSQ()));
            Console.WriteLine("Is Error tolerant    : {0}", toBinary(file.isErrorTolerant()));
            Console.WriteLine("Any PMF?             : {0}", toBinary(file.anyPMF()));
            Console.WriteLine("Any MSMS?            : {0}", toBinary(file.anyMSMS()));
            Console.WriteLine("Any SQ?              : {0}", toBinary(file.anySQ()));

            // C++ enum converted to C# enum, so we need to use the enum name when referencing the
            // required section constant
            Console.WriteLine("Any peptides section : {0}", toBinary(file.doesSectionExist(ms_mascotresfile.section.SEC_PEPTIDES)));
            Console.WriteLine("Any peptide matches  : {0}", toBinary(file.anyPeptideSummaryMatches()));
            Console.WriteLine();

        }

        public static int toBinary(bool b)
        {
            return (b) ? 1 : 0;
        }
    }
}

/*
resfile_info.exe c:\inetpub\mascot\data\F981118.dat
Will give the following output:

Search information from ms_mascotresfile
========================================
Number of queries    : 6
Number of hits       : 50
Number of sequences  : 257964
Sequences after tax  : 15720
Number of residues   : 93947433
Execution time       : 8
Date (seconds)       : 1171893592
Date                 : Mon Feb 19 01:59:52 2007
Mascot version       : 2.1.119
Fasta version        : SwissProt_51.6.fasta
Is PMF?              : 1
Is MSMS?             : 0
Is SQ?               : 0
Is Error tolerant    : 0
Any PMF?             : 1
Any MSMS?            : 0
Any SQ?              : 0
Any peptides section : 0
Any peptide matches  : 0
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_info.java

Example program for retrieving general search information.

/*
##############################################################################
# file: resfile_info.java                                                    #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchi $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class resfile_info {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("Must specify results filename as parameter");
            System.exit(0);
        }

        ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
        if (file.isValid()) {
            searchInformation(file);
        } else {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }
    }

    private static void searchInformation(ms_mascotresfile file) {
        Date searchDate = null;                       // Java.util.date object
        int seconds = file.getDate();                 // get date of search in seconds since midnight GMT Jan 1st 1970
        long milliseconds = (long) seconds * 1000;    // convert to milliseconds
        searchDate=new Date(milliseconds);            // create the date object

        System.out.println("Search information from ms_mascotresfile");
        System.out.println("========================================");

        System.out.println("Number of queries   : "+file.getNumQueries());
        System.out.println("Number of hits      : "+file.getNumHits());
        System.out.println("Number of sequences : "+file.getNumSeqs());
        System.out.println("Sequences after tax : "+file.getNumSeqsAfterTax());
        System.out.println("Number of residues  : "+(int)file.getNumResidues());
        System.out.println("Execution time      : "+file.getExecTime());
        System.out.println("Date (seconds)      : "+file.getDate());

        // make java output identical to perl output
        System.out.print("Date                : ");
        String toPerlDate = searchDate.toString();
        if(toPerlDate.indexOf("GMT ") > -1) {
            String beforeGMT = toPerlDate.substring(0,toPerlDate.indexOf("GMT"));
            String afterGMT = toPerlDate.substring(toPerlDate.indexOf("GMT ")+4,toPerlDate.length());
            System.out.println(beforeGMT+afterGMT);
        } else {
            System.out.println(searchDate);
        }

        System.out.println("Mascot version      : "+file.getMascotVer());
        System.out.println("Fasta version       : "+file.getFastaVer());
        // make java output identical to perl output

        System.out.println("Is PMF?             : "+toBinary(file.isPMF()));
        System.out.println("Is MSMS?            : "+toBinary(file.isMSMS()));
        System.out.println("Is SQ?              : "+toBinary(file.isSQ()));
        System.out.println("Is Error tolerant   : "+toBinary(file.isErrorTolerant()));
        System.out.println("Any PMF?            : "+toBinary(file.anyPMF()));
        System.out.println("Any MSMS?           : "+toBinary(file.anyMSMS()));
        System.out.println("Any SQ?             : "+toBinary(file.anySQ()));
        System.out.println("Any peptides section: "+toBinary(file.doesSectionExist(ms_mascotresfile.SEC_PEPTIDES)));
        System.out.println("Any peptide matches : "+toBinary(file.anyPeptideSummaryMatches()));
        System.out.println();
    }

    private static int toBinary(boolean bool) {
        if(bool) return 1;
        return 0;
    }
}

/*
will give the output:

C:>java -classpath .;../java/msparser.jar resfile_info F981123.dat
Search information from ms_mascotresfile
========================================
Number of queries   : 4
Number of hits      : 50
Number of sequences : 820227
Sequences after tax : 820227
Number of residues  : 255696937
Execution time      : 14
Date (seconds)      : 1014568786
Date                : Sun Feb 24 16:39:46 2002
Mascot version      : 1.7.17
Fasta version       : MSDB_20020121.fasta
Is PMF?             : 0
Is MSMS?            : 1
Is SQ?              : 0
Is Error tolerant   : 0
Any PMF?            : 0
Any MSMS?           : 1
Any SQ?             : 0
Any peptides section: 1
Any peptide matches : 1

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_info.pl

Example program for retrieving general search information.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_info.pl                                                      #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_info.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }

my $file = new msparser::ms_mascotresfile($ARGV[0]);

if ($file->isValid) {
    searchInformation($file);
}

##############################################################################
#  searchInformation                                                         #
#  - parameter 0  ms_mascotresfile                                           #
#  Display parameters from the ms_mascotresfile object. The functions        #
#  anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc #
#  because some people submit MSMS though the sequence query window etc.     #
##############################################################################
sub searchInformation {
    my ($resfile) = @_;

    my $fmt = "%-20s: %s\n";

    print "Search information from ms_mascotresfile", "\n";
    print "========================================", "\n";
    printf $fmt, "Number of queries"   , $resfile->getNumQueries();
    printf $fmt, "Number of hits"      , $resfile->getNumHits();
    printf $fmt, "Number of sequences" , $resfile->getNumSeqs();
    printf $fmt, "Sequences after tax" , $resfile->getNumSeqsAfterTax();
    printf $fmt, "Number of residues"  , $resfile->getNumResidues();
    printf $fmt, "Execution time"      , $resfile->getExecTime();
    printf $fmt, "Date (seconds)"      , $resfile->getDate();

    # Let's jump through a few hoops to get the equivalent of a 'C' asctime call
    my ($sec, $min, $hour, $mday, $mon, $year, $wday, $yday, $isdst)
        = localtime($resfile->getDate);

    printf $fmt, "Date", sprintf("%s %s %d %02d:%02d:%02d %d",
        (qw(Sun Mon Tue Wed Thu Fri Sat))[$wday],
        (qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec))[$mon],
        $mday,
        $hour,
        $min,
        $sec,
        $year+1900
    );

    printf $fmt, "Mascot version"       , $resfile->getMascotVer();
    printf $fmt, "Fasta version"        , $resfile->getFastaVer();
    printf $fmt, "Is PMF?"              , $resfile->isPMF();
    printf $fmt, "Is MSMS?"             , $resfile->isMSMS();
    printf $fmt, "Is SQ?"               , $resfile->isSQ();
    printf $fmt, "Is Error tolerant"    , $resfile->isErrorTolerant();
    printf $fmt, "Any PMF?"             , $resfile->anyPMF();
    printf $fmt, "Any MSMS?"            , $resfile->anyMSMS();
    printf $fmt, "Any SQ?"              , $resfile->anySQ();
    printf $fmt, "Any peptides section" , $resfile->doesSectionExist($msparser::ms_mascotresfile::SEC_PEPTIDES);
    printf $fmt, "Any peptide matches"  , $resfile->anyPeptideSummaryMatches();

    print "\n";
}

=pod

Running the program as

perl -I../bin resfile_info.pl ../data/F981123.dat

will give the following output under Mascot Server 2.3

Search information from ms_mascotresfile
========================================
Number of queries   : 67
Number of hits      : 50
Number of sequences : 257964
Sequences after tax : 257964
Number of residues  : 93947433
Execution time      : 6
Date (seconds)      : 1171894187
Date                : Mon Feb 19 14:09:47 2007
Mascot version      : 2.1.119
Fasta version       : SwissProt_51.6.fasta
Is PMF?             :
Is MSMS?            : 1
Is SQ?              :
Is Error tolerant   :
Any PMF?            :
Any MSMS?           : 1
Any SQ?             :
Any peptides section: 1
Any peptide matches : 1

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_info.py

Example program for retrieving general search information.

#!/usr/bin/python
##############################################################################
# file: resfile_info.py                                                      #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/resfile_info.py $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################

import sys
import time
import msparser

def main() :
    if len(sys.argv) < 2 :
        print("Must specify results filename as parameter")
        return 1

    file = msparser.ms_mascotresfile(sys.argv[1])

    if file.isValid() :
        searchInformation(file)
        return 0

    print("Failure")
    return -1

def searchInformation(resfile) :
    """
    Display parameters from the ms_mascotresfile object. The functions
    anyPMF, anyMSMS, anySQ should normally be used in preference to isPMF etc
    because some people submit MSMS though the sequence query window etc.
    """

    fmt = "%-20s: %s"

    print("Search information from ms_mascotresfile")
    print("========================================")
    print(fmt % ("Number of queries"   , resfile.getNumQueries()))
    print(fmt % ("Number of hits"      , resfile.getNumHits()))
    print(fmt % ("Number of sequences" , resfile.getNumSeqs()))
    print(fmt % ("Sequences after tax" , resfile.getNumSeqsAfterTax()))
    print(fmt % ("Number of residues"  , resfile.getNumResidues()))
    print(fmt % ("Execution time"      , resfile.getExecTime()))
    print(fmt % ("Date (seconds)"      , resfile.getDate()))

    date = time.localtime(resfile.getDate())
    Wdays = "Mon Tue Wed Thu Fri Sat Sun".split(" ")
    Mons = "Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec".split(" ")

    print(fmt %( "Date", "%s %s %d %02d:%02d:%02d %d" % (
        Wdays[date.tm_wday],
        Mons[date.tm_mon - 1],
        date.tm_mday,
        date.tm_hour,
        date.tm_min,
        date.tm_sec,
        date.tm_year
        )))

    print(fmt % ("Mascot version"       , resfile.getMascotVer()))
    print(fmt % ("Fasta version"        , resfile.getFastaVer()))
    print(fmt % ("Is PMF?"              , resfile.isPMF()))
    print(fmt % ("Is MSMS?"             , resfile.isMSMS()))
    print(fmt % ("Is SQ?"               , resfile.isSQ()))
    print(fmt % ("Is Error tolerant"    , resfile.isErrorTolerant()))
    print(fmt % ("Any PMF?"             , resfile.anyPMF()))
    print(fmt % ("Any MSMS?"            , resfile.anyMSMS()))
    print(fmt % ("Any SQ?"              , resfile.anySQ()))
    print(fmt % ("Any peptides section" , resfile.doesSectionExist(msparser.ms_mascotresfile.SEC_PEPTIDES)))
    print(fmt % ("Any peptide matches"  , resfile.anyPeptideSummaryMatches()))

    print(" ")

if __name__ == "__main__":
    sys.exit(main())

""" Running the program as

python resfile_info.py F981123.dat

will give the following output under Mascot Server 2.3:

Search information from ms_mascotresfile
========================================
Number of queries   : 67
Number of hits      : 50
Number of sequences : 257964
Sequences after tax : 257964
Number of residues  : 93947433.0
Execution time      : 6
Date (seconds)      : 1171894187
Date                : Mon Feb 19 14:09:47 2007
Mascot version      : 2.1.119
Fasta version       : SwissProt_51.6.fasta
Is PMF?             : False
Is MSMS?            : True
Is SQ?              : False
Is Error tolerant   : False
Any PMF?            : False
Any MSMS?           : True
Any SQ?             : False
Any peptides section: True
Any peptide matches : True

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_input.cpp

Example program for retrieving input spectrum data.

/*
##############################################################################
# file: resfile_input.cpp                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/resfile_input.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <vector>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* Local functions                                                           */
/* (This test harness is 'C' and not C++)                                    */
/*****************************************************************************/
static void inputData(ms_mascotresfile & file);

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - the name of the .dat file      */
/*****************************************************************************/
int main(int argc, char * argv[])
{
    if (argc == 2)
    {
        ms_mascotresfile file(argv[1]);

        if (file.isValid())
        {
            inputData(file);
        }
        else
            std::cout << "Error: " << file.getLastErrorString() << std::endl;
    }
    else
        std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
    return 0;
}

/*****************************************************************************/
/* inputData                                                                 */
/* Display input data                                                        */
/*****************************************************************************/
static void inputData(ms_mascotresfile & file)
{
    //display input data via inputquery get functions
    for (int i = 1; i <= 1 /* file.getNumQueries()*/; i++)
    {
        std::cout << "Input data for query number " << i              << std::endl;
        std::cout << "========================================="      << std::endl;
        ms_inputquery q(file, i);

        std::cout << "    title       : " << q.getStringTitle(1).c_str()<< std::endl;
        std::cout << "    mass_min    : " << q.getMassMin()             << std::endl;
        std::cout << "    mass_max    : " << q.getMassMax()             << std::endl;
        std::cout << "    int_min     : " << q.getIntMin()              << std::endl;
        std::cout << "    int_max     : " << q.getIntMax()              << std::endl;
        std::cout << "    num_vals    : " << q.getNumVals()             << std::endl;
        std::cout << "    num_used1   : " << q.getNumUsed()             << std::endl;
        std::cout << "    ions1       : " << q.getStringIons1().c_str() << std::endl;
        std::cout << "    ions2       : " << q.getStringIons2().c_str() << std::endl;
        std::cout << "    ions3       : " << q.getStringIons3().c_str() << std::endl;
        std::cout << "    peptol      : " << q.getPepTol()              << std::endl;
        std::cout << "    peptol units: " << q.getPepTolUnits().c_str() << std::endl;
        std::cout << "    peptol str  : " << q.getPepTolString().c_str()<< std::endl;
        std::cout << "    INSTRUMENT  : " << q.getINSTRUMENT().c_str()  << std::endl;
        std::cout << "    RULES       : " << q.getRULES().c_str()       << std::endl;
        std::cout << "    IT_MODS     : " << q.getIT_MODS().c_str()     << std::endl;
        std::cout << "    repeat srch : " << file.getRepeatSearchString(i).c_str() << std::endl;

        std::vector< std::pair< double, double > > tmp = q.getPeakList(1);
        for (unsigned int j=0; j < tmp.size(); j++)
        {
            std::cout << tmp[j].first << ", " << tmp[j].second << std::endl;
        }
    }
    std::cout << std::endl;
}

/*
will give the output:

Input data for query number 1
=========================================
        title       : dp210198c                      21 Jan 98 DERIVED SPECTRUM    P9
        mass_min    : 214.8
        mass_max    : 1228.7
        int_min     : 7
        int_max     : 114465
        num_vals    : 443
        num_used1   : 0
        ions1       : 288.200000:2137,371.127841:1663,472.096295:2.939e+04,567.000000:5.469e+04,663.100000:1.145e+05,758
.200000:7.356e+04,871.200000:2.539e+04,956.100000:2241,1055.000000:1.227e+04,1167.994665:1.725e+04,1215.400000:257,314.2
00000:1308,377.992647:1088,501.400000:1.043e+04,584.997427:3.906e+04,654.180103:3.006e+04,759.300000:1.557e+04,841.90000
0:1.917e+04,972.292156:1874,1056.300000:3799,1169.100000:1.123e+04,1225.200000:58,242.800000:417,377.000000:828,454.1000
00:5162,586.200000:5258,662.700000:1.83e+04,728.800000:1397,842.900000:4893,956.800000:443,1029.300000:1846,1170.200000:
1280,1216.200000:51,313.900000:187,387.200000:656,473.200000:1342,568.100000:5122,663.600000:9782,729.200000:626,872.300
000:4300,973.515686:255,1100.300000:1290,1198.200000:117,1217.500000:45,243.200000:159,379.100000:231,502.400000:556,599
.100000:1504,655.000000:1672,814.100000:277,841.200000:215,958.138974:195,1056.000000:492,1196.900000:96,1226.400000:38,
286.100000:83,408.200000:187,428.200000:283,614.400000:1403,710.900000:1144,730.000000:214,843.600000:194,1011.400000:78
,1057.200000:416,1198.900000:80,1227.000000:20,289.000000:60,353.300000:136,500.700000:143,551.300000:800,665.994513:565
,757.300000:182,873.300000:166,955.000000:51,1101.262914:302,1197.600000:53,1228.700000:19,253.900000:44,394.000000:115,
426.400000:75,566.263208:424,665.300000:563,801.800000:171,827.400000:165,1002.100000:46,1030.500000:193,1168.500000:42,
290.200000:25,388.100000:63,444.100000:75,542.000000:399,664.600000:388,760.000000:160,825.200000:76,937.900000:38,1082.
400000:126,1170.500000:40,287.100000:23,342.800000:48,454.900000:64,614.100000:373,644.000000:290,769.300000:111,902.100
000:67,917.300000:37,1029.800000:125,1149.800000:38,214.800000:18,242.100000:19,252.100000:20,315.200000:44,325.800000:1
7,333.100000:21,347.500000:19,348.700000:13,349.500000:23,352.600000:47,359.100000:28,366.000000:36,367.900000:7,376.100
000:14,380.100000:46,407.300000:11,410.900000:22,412.400000:31,418.000000:17,429.900000:57,431.000000:15,436.400000:11,4
44.900000:27,447.200000:18,453.200000:11,455.500000:33,456.100000:14,459.900000:15,461.600000:19,463.300000:7,465.600000
:22,470.400000:12,470.900000:51,474.200000:44,477.100000:15,477.900000:32,483.900000:37,486.200000:20,496.900000:11,497.
600000:14,499.100000:41,503.800000:24,505.400000:22,508.300000:12,508.900000:17,511.800000:19,513.000000:20,515.000000:1
8,517.000000:16,522.100000:58,523.900000:15,524.600000:78,525.300000:19,525.900000:370,526.700000:36,532.900000:11,533.5
00000:14,536.900000:19,538.200000:44,539.261607:224,540.200000:39,541.100000:133,543.043902:41,545.100000:9,545.600000:3
0,547.300000:23,547.900000:13,548.700000:340,549.600000:81,550.200000:41,551.700000:16,552.300000:69,555.500000:29,557.0
68975:361,558.300000:54,560.100000:7,561.100000:24,563.400000:39,564.100000:101,567.600000:35,568.900000:37,569.500000:1
4,570.000000:49,571.100000:45,572.300000:76,574.000000:99,574.600000:22,576.300000:18,580.800000:34,582.300000:41,587.10
0000:131,587.900000:53,590.300000:12,591.800000:17,592.500000:18,594.800000:9,595.300000:56,596.100000:97,596.600000:62,
597.100000:27,597.700000:63,600.000000:57,602.100000:28,603.900000:16,605.200000:69,606.800000:24,607.500000:13,608.5000
00:57,608.800000:12,610.200000:50,610.500000:12,611.200000:96,612.200000:24,613.200000:13,615.000000:194,615.600000:19,6
16.200000:23,618.400000:15,619.100000:31,621.100000:120,621.700000:36,622.600000:11,623.200000:43,624.100000:147,624.800
000:32,626.000000:22,627.000000:53,627.900000:21,628.900000:16,629.500000:29,630.500000:14,631.400000:45,633.200000:61,6
35.000000:58,635.736413:184,636.600000:29,637.500000:78,638.600000:14,639.800000:72,640.500000:51,641.100000:33,641.7000
00:40,642.400000:121,642.800000:170,643.300000:57,644.600000:48,645.700000:36,646.500000:39,647.400000:28,648.500000:30,
649.500000:108,650.000000:13,650.600000:43,651.800000:107,652.300000:33,652.900000:33,656.300000:178,657.100000:78,658.2
00000:19,658.800000:76,660.590741:108,661.900000:216,667.000000:193,677.300000:8,680.500000:13,683.500000:38,684.500000:
28,685.500000:24,686.200000:13,687.275862:87,688.200000:28,688.900000:28,689.400000:50,691.500000:28,692.700000:25,693.2
00000:15,694.000000:31,697.100000:8,698.300000:42,700.300000:17,700.900000:21,703.500000:39,704.200000:20,704.900000:14,
708.300000:15,709.000000:42,711.500000:90,711.800000:119,713.100000:35,715.200000:29,718.500000:57,719.900000:52,721.500
000:78,722.400000:29,725.400000:30,731.100000:13,731.800000:13,734.500000:36,735.300000:46,735.700000:28,738.600000:23,7
39.900000:20,740.500000:81,741.800000:64,744.700000:23,745.500000:18,747.400000:23,751.100000:21,751.900000:34,755.20000
0:13,756.200000:28,760.900000:21,762.800000:19,764.100000:19,767.600000:41,768.200000:75,771.200000:9,771.800000:10,773.
800000:10,776.100000:21,777.500000:39,783.400000:39,785.100000:26,786.800000:15,788.200000:23,789.300000:14,791.700000:2
1,792.600000:29,795.700000:53,796.200000:25,798.900000:13,799.400000:14,800.200000:12,800.700000:32,802.300000:25,802.80
0000:103,804.000000:26,805.200000:83,807.900000:15,808.700000:25,809.800000:36,810.900000:50,811.500000:85,812.100000:36
,813.400000:22,814.600000:78,815.100000:52,815.900000:25,817.300000:21,821.300000:30,822.000000:9,827.800000:33,828.9000
00:20,832.100000:13,834.800000:18,835.700000:25,836.600000:20,846.700000:8,851.100000:25,852.054545:66,853.200000:20,854
.400000:28,857.000000:21,857.800000:21,859.500000:14,861.100000:17,864.500000:20,867.800000:49,868.800000:47,869.100000:
19,869.700000:22,872.900000:22,877.100000:16,880.800000:20,885.000000:21,885.800000:12,886.300000:16,888.800000:11,890.5
00000:10,899.339024:41,907.800000:39,909.400000:8,911.200000:27,911.900000:9,925.900000:10,928.800000:30,930.700000:26,9
33.700000:9,935.700000:13,945.100000:20,948.900000:10,953.600000:14,960.500000:14,974.100000:36,994.000000:37,1003.30000
0:18,1010.200000:18,1010.800000:27,1012.100000:21,1014.000000:14,1020.100000:20,1021.000000:31,1028.900000:118,1031.0000
00:18,1031.600000:40,1033.100000:14,1037.900000:55,1041.100000:17,1045.300000:13,1054.000000:92,1057.700000:19,1061.9000
00:20,1069.100000:16,1083.600000:41,1093.400000:49,1098.500000:32,1099.800000:46,1102.500000:52,1103.200000:18,1104.5000
00:9,1125.400000:16,1131.800000:24,1132.400000:21,1139.800000:12,1150.800000:22,1152.900000:15,1157.600000:8,1165.300000
:14,1166.700000:11,1178.700000:25,1179.500000:23,1180.400000:25,1185.800000:12,1192.800000:18,1194.800000:12,1214.700000
:35
    ions2       :
    ions3       :
    ions2       :
    ions3       :
    peptol      : 0
    peptol units:
    peptol str  :
    repeat srch : 1341.784350 from(671.900000,2+)  title(dp210198c%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20
%20%20%20%2021%2dJan%2d98%20DERIVED%20SPECTRUM%20%20%20%20%239)  query(1)
371.128, 1663
472.096, 29390
567, 54690
663.1, 114500
758.2, 73560
871.2, 25390
956.1, 2241
1055, 12270
1167.99, 17250
1215.4, 257
314.2, 1308
377.993, 1088
501.4, 10430
584.997, 39060
654.18, 30060
759.3, 15570
841.9, 19170
972.292, 1874
1056.3, 3799
1169.1, 11230
1225.2, 58
242.8, 417
377, 828
454.1, 5162
586.2, 5258
662.7, 18300
728.8, 1397
842.9, 4893
956.8, 443
1029.3, 1846
1170.2, 1280
1216.2, 51
313.9, 187
387.2, 656
473.2, 1342
568.1, 5122
663.6, 9782
729.2, 626
872.3, 4300
973.516, 255
1100.3, 1290
1198.2, 117
1217.5, 45
243.2, 159
379.1, 231
502.4, 556
599.1, 1504
655, 1672
814.1, 277
841.2, 215
958.139, 195
1056, 492
1196.9, 96
1226.4, 38
286.1, 83
408.2, 187
428.2, 283
614.4, 1403
710.9, 1144
730, 214
843.6, 194
1011.4, 78
1057.2, 416
1198.9, 80
1227, 20
289, 60
353.3, 136
500.7, 143
551.3, 800
665.995, 565
757.3, 182
873.3, 166
955, 51
1101.26, 302
1197.6, 53
1228.7, 19
253.9, 44
394, 115
426.4, 75
566.263, 424
665.3, 563
801.8, 171
827.4, 165
1002.1, 46
1030.5, 193
1168.5, 42
290.2, 25
388.1, 63
444.1, 75
542, 399
664.6, 388
760, 160
825.2, 76
937.9, 38
1082.4, 126
1170.5, 40
287.1, 23
342.8, 48
454.9, 64
614.1, 373
644, 290
769.3, 111
902.1, 67
917.3, 37
1029.8, 125
1149.8, 38
214.8, 18
242.1, 19
252.1, 20
315.2, 44
325.8, 17
333.1, 21
347.5, 19
348.7, 13
349.5, 23
352.6, 47
359.1, 28
366, 36
367.9, 7
376.1, 14
380.1, 46
407.3, 11
410.9, 22
412.4, 31
418, 17
429.9, 57
431, 15
436.4, 11
444.9, 27
447.2, 18
453.2, 11
455.5, 33
456.1, 14
459.9, 15
461.6, 19
463.3, 7
465.6, 22
470.4, 12
470.9, 51
474.2, 44
477.1, 15
477.9, 32
483.9, 37
486.2, 20
496.9, 11
497.6, 14
499.1, 41
503.8, 24
505.4, 22
508.3, 12
508.9, 17
511.8, 19
513, 20
515, 18
517, 16
522.1, 58
523.9, 15
524.6, 78
525.3, 19
525.9, 370
526.7, 36
532.9, 11
533.5, 14
536.9, 19
538.2, 44
539.262, 224
540.2, 39
541.1, 133
543.044, 41
545.1, 9
545.6, 30
547.3, 23
547.9, 13
548.7, 340
549.6, 81
550.2, 41
551.7, 16
552.3, 69
555.5, 29
557.069, 361
558.3, 54
560.1, 7
561.1, 24
563.4, 39
564.1, 101
567.6, 35
568.9, 37
569.5, 14
570, 49
571.1, 45
572.3, 76
574, 99
574.6, 22
576.3, 18
580.8, 34
582.3, 41
587.1, 131
587.9, 53
590.3, 12
591.8, 17
592.5, 18
594.8, 9
595.3, 56
596.1, 97
596.6, 62
597.1, 27
597.7, 63
600, 57
602.1, 28
603.9, 16
605.2, 69
606.8, 24
607.5, 13
608.5, 57
608.8, 12
610.2, 50
610.5, 12
611.2, 96
612.2, 24
613.2, 13
615, 194
615.6, 19
616.2, 23
618.4, 15
619.1, 31
621.1, 120
621.7, 36
622.6, 11
623.2, 43
624.1, 147
624.8, 32
626, 22
627, 53
627.9, 21
628.9, 16
629.5, 29
630.5, 14
631.4, 45
633.2, 61
635, 58
635.736, 184
636.6, 29
637.5, 78
638.6, 14
639.8, 72
640.5, 51
641.1, 33
641.7, 40
642.4, 121
642.8, 170
643.3, 57
644.6, 48
645.7, 36
646.5, 39
647.4, 28
648.5, 30
649.5, 108
650, 13
650.6, 43
651.8, 107
652.3, 33
652.9, 33
656.3, 178
657.1, 78
658.2, 19
658.8, 76
660.591, 108
661.9, 216
667, 193
677.3, 8
680.5, 13
683.5, 38
684.5, 28
685.5, 24
686.2, 13
687.276, 87
688.2, 28
688.9, 28
689.4, 50
691.5, 28
692.7, 25
693.2, 15
694, 31
697.1, 8
698.3, 42
700.3, 17
700.9, 21
703.5, 39
704.2, 20
704.9, 14
708.3, 15
709, 42
711.5, 90
711.8, 119
713.1, 35
715.2, 29
718.5, 57
719.9, 52
721.5, 78
722.4, 29
725.4, 30
731.1, 13
731.8, 13
734.5, 36
735.3, 46
735.7, 28
738.6, 23
739.9, 20
740.5, 81
741.8, 64
744.7, 23
745.5, 18
747.4, 23
751.1, 21
751.9, 34
755.2, 13
756.2, 28
760.9, 21
762.8, 19
764.1, 19
767.6, 41
768.2, 75
771.2, 9
771.8, 10
773.8, 10
776.1, 21
777.5, 39
783.4, 39
785.1, 26
786.8, 15
788.2, 23
789.3, 14
791.7, 21
792.6, 29
795.7, 53
796.2, 25
798.9, 13
799.4, 14
800.2, 12
800.7, 32
802.3, 25
802.8, 103
804, 26
805.2, 83
807.9, 15
808.7, 25
809.8, 36
810.9, 50
811.5, 85
812.1, 36
813.4, 22
814.6, 78
815.1, 52
815.9, 25
817.3, 21
821.3, 30
822, 9
827.8, 33
828.9, 20
832.1, 13
834.8, 18
835.7, 25
836.6, 20
846.7, 8
851.1, 25
852.055, 66
853.2, 20
854.4, 28
857, 21
857.8, 21
859.5, 14
861.1, 17
864.5, 20
867.8, 49
868.8, 47
869.1, 19
869.7, 22
872.9, 22
877.1, 16
880.8, 20
885, 21
885.8, 12
886.3, 16
888.8, 11
890.5, 10
899.339, 41
907.8, 39
909.4, 8
911.2, 27
911.9, 9
925.9, 10
928.8, 30
930.7, 26
933.7, 9
935.7, 13
945.1, 20
948.9, 10
953.6, 14
960.5, 14
974.1, 36
994, 37
1003.3, 18
1010.2, 18
1010.8, 27
1012.1, 21
1014, 14
1020.1, 20
1021, 31
1028.9, 118
1031, 18
1031.6, 40
1033.1, 14
1037.9, 55
1041.1, 17
1045.3, 13
1054, 92
1057.7, 19
1061.9, 20
1069.1, 16
1083.6, 41
1093.4, 49
1098.5, 32
1099.8, 46
1102.5, 52
1103.2, 18
1104.5, 9
1125.4, 16
1131.8, 24
1132.4, 21
1139.8, 12
1150.8, 22
1152.9, 15
1157.6, 8
1165.3, 14
1166.7, 11
1178.7, 25
1179.5, 23
1180.4, 25
1185.8, 12
1192.8, 18
1194.8, 12
1214.7, 35

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_input.cs

Example program for retrieving input spectrum data.

/*
##############################################################################
# file: resfile_input.cs                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_input.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class resfile_input
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.WriteLine("Must specify results filename as parameter");
                return;
            }
             ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
             if (file.isValid())
             {
                 inputData(file);
             }
             else
             {
                 Console.WriteLine("Error number: {0}", file.getLastError());
                 Console.WriteLine("Error string: {0}", file.getLastErrorString());
                 return;
             }

        }

        private static void inputData(ms_mascotresfile file)
        {
            int i, j, num_peaks;

            // display input data via inputquery get functions
            for (i = 1; i <= 1; i++)
            {
                Console.WriteLine("Input data for query number {0}", i);
                Console.WriteLine("=========================================");
                ms_inputquery q = new ms_inputquery(file, i);
                Console.WriteLine("      title       : {0}", q.getStringTitle(true));
                Console.WriteLine("      mass_min    : {0}", q.getMassMin());
                Console.WriteLine("      mass_max    : {0}", q.getMassMax());
                Console.WriteLine("      int_min     : {0}", q.getIntMin());
                Console.WriteLine("      int_max     : {0}", q.getIntMax());
                Console.WriteLine("      num_vals    : {0}", q.getNumVals());
                Console.WriteLine("      num_used1   : {0}", q.getNumUsed());
                Console.WriteLine("      ions1       : {0}", q.getStringIons1());
                Console.WriteLine("      ions2       : {0}", q.getStringIons2());
                Console.WriteLine("      ions3       : {0}", q.getStringIons3());
                Console.WriteLine("      peptol      : {0}", q.getPepTol());
                Console.WriteLine("      peptol units: {0}", q.getPepTolUnits());
                Console.WriteLine("      peptol str  : {0}", q.getPepTolString());
                Console.WriteLine("      INSTRUMENT  : {0}", q.getINSTRUMENT());
                Console.WriteLine("      RULES       : {0}", q.getRULES());
                Console.WriteLine("      IT_MODS     : {0}", q.getIT_MODS());
                Console.WriteLine("      repeat srch : {0}", file.getRepeatSearchString(i));

                num_peaks = q.getNumberOfPeaks(1);
                for (j = 1; j <= num_peaks; j++)
                {
                    Console.WriteLine("{0:#}, {1:#}",q.getPeakMass(1,j), q.getPeakIntensity(1,j));
                }

            }
        }
    }
}

/*
resfile_input.exe c:\inetpub\mascot\data\F981123.dat >resfile_input_output.txt
Will give the following output:

Input data for query number 1
=========================================
      title       :
      mass_min    : 72.09
      mass_max    : 1711.52
      int_min     : 1.103
      int_max     : 80.7
      num_vals    : 425
      num_used1   : 0
      ions1       : 157.096962:23.72,185.160000:26.69,286.134951:80.7,385.210000:13.49,480.270000:4.363,129.102412:18.84,187.070000:22.51,354.189124:13.57,399.246727:9.489,482.140542:3.205,130.110251:9.257,258.132661:15.93,357.210000:13.57,443.810000:6.256,481.210000:3.182,136.070000:7.387,213.139215:13.84,371.204929:11.24,459.280000:6.216,489.233770:3.157,147.117662:6.333,229.120000:9.72,326.133204:5.268,423.125582:4.262,483.115000:2.205,159.080000:5.222,240.130000:7.562,298.110000:5.231,444.168974:3.247,474.300000:1.103,158.090000:4.301,270.180000:7.432,324.170000:5.17,411.200000:3.23,475.270000:1.103,86.110000:3.276,175.110000:7.308,312.150879:4.235,463.265712:3.205,476.700000:1.103,102.060000:3.276,241.085275:5.361,293.110000:4.178,445.810000:3.182,478.180000:1.103,115.088725:3.255,243.139772:4.378,353.155308:4.149,401.150000:3.138,486.880000:1.103,72.090000:2.174,76.400000:1.103,84.075000:2.111,87.110000:1.103,88.100000:1.103,98.060000:1.103,103.060000:1.103,105.070000:1.103,116.070000:1.103,117.110000:1.103,118.400000:1.103,120.090000:2.205,126.070000:1.103,127.090000:1.103,128.090000:2.103,131.085000:2.118,132.090000:1.103,135.800000:1.103,137.080000:1.103,138.070000:1.103,139.090000:1.103,140.150000:2.174,141.060000:2.174,143.120000:2.174,146.080000:1.103,152.060000:1.103,155.070000:2.205,156.100000:1.103,159.450000:1.103,165.080000:2.136,166.110000:1.103,167.110000:1.103,169.710000:1.103,170.450000:1.103,171.090000:1.103,173.120000:2.174,177.090000:1.103,178.080000:1.103,181.160000:1.103,182.030000:1.103,183.110000:2.174,183.930000:1.103,186.131024:4.374,188.070000:1.103,188.760000:1.103,189.070000:1.103,190.065000:2.103,191.300000:1.103,197.130000:1.103,199.180000:1.103,200.080000:1.103,201.100000:3.138,202.110000:2.091,203.080000:2.174,203.610000:1.103,211.140000:4.189,212.115000:2.103,212.490000:1.103,214.985000:2.205,216.110000:2.103,217.100000:1.103,218.080000:1.103,219.090000:2.103,223.090000:3.154,224.130000:1.103,225.130000:1.103,227.170000:1.103,227.880000:1.103,228.170000:2.136,229.760000:1.103,231.950000:1.103,233.130000:1.103,234.430000:1.103,235.080000:2.103,236.590000:1.103,238.080000:4.332,239.139997:3.131,242.170000:2.205,244.090000:2.136,244.430000:2.091,245.165685:3.205,246.160000:2.197,247.110000:2.102,248.145000:2.118,249.110000:2.136,250.080000:1.103,251.160000:1.103,253.100000:1.103,254.130000:1.103,255.165000:2.22,256.170000:1.103,257.060000:1.103,259.150000:2.197,260.000000:1.103,260.490000:1.103,262.110000:1.103,265.120000:1.103,266.130000:2.159,266.950000:1.103,267.210000:1.103,268.120000:3.214,269.090000:1.103,271.150000:2.136,272.170000:2.103,274.120000:1.103,275.030000:1.103,276.175000:2.22,278.190000:1.103,279.720000:2.205,281.120000:1.103,283.070000:1.103,284.110000:1.103,285.070000:1.103,287.140000:3.296,287.780000:1.103,288.090000:2.103,290.130000:1.103,294.110000:2.174,295.150000:3.114,295.730000:1.103,297.180000:2.136,300.160000:3.143,302.070000:1.103,303.160000:1.103,303.590000:1.103,304.600000:1.103,305.130000:1.103,306.140000:3.182,307.050000:1.103,308.150000:2.174,308.490000:1.103,312.610000:1.103,312.880000:1.103,314.120000:1.103,316.085000:2.111,317.150000:3.183,318.140000:1.103,320.140000:1.103,322.149731:3.255,323.034482:3.149,327.020000:1.103,328.020000:1.103,331.140000:2.091,332.165000:2.103,333.140000:1.103,335.500000:1.103,336.190000:1.103,337.030000:2.118,338.620000:1.103,338.940000:1.103,339.200000:3.261,341.210000:2.103,342.180000:1.103,342.800000:1.103,343.225000:2.111,343.800000:1.103,344.150000:2.174,346.010000:1.103,347.660000:1.103,348.200000:2.197,349.800000:1.103,350.110000:2.118,351.130000:3.276,352.130000:2.136,353.910000:1.103,354.470000:1.103,355.193955:3.376,358.200000:1.103,359.210000:2.174,359.910000:1.103,360.470000:1.103,361.080000:1.103,362.190000:1.103,363.040000:1.103,364.080000:1.103,366.120000:1.103,367.150000:1.103,368.330000:1.103,368.730000:1.103,369.230000:3.15,369.820000:1.103,370.177065:3.279,373.130000:2.197,374.055000:2.217,374.510000:2.205,376.040000:1.103,377.040000:1.103,380.160000:2.103,382.180000:3.102,383.115000:2.209,385.890000:2.205,386.370000:1.103,387.170000:3.114,387.680000:2.217,388.050000:1.103,389.620000:1.103,390.190000:1.103,390.610000:1.103,394.260000:1.103,395.180000:1.103,396.140000:2.205,397.980000:1.103,400.165000:2.209,403.210000:1.103,404.150000:1.103,404.470000:1.103,410.165000:2.111,411.550000:1.103,413.240000:1.103,414.080000:1.103,415.000000:1.103,416.190000:1.103,416.830000:1.103,417.230000:1.103,417.760000:1.103,418.285000:2.111,418.680000:1.103,420.650000:1.103,421.170000:2.136,422.580000:1.103,425.215000:2.103,425.690000:1.103,426.220000:3.125,428.140000:2.155,428.650000:1.103,430.260000:1.103,430.995000:2.205,433.200000:1.103,433.690000:1.103,435.000000:1.103,435.260000:1.103,437.180000:1.103,438.710000:2.174,439.230000:1.103,440.210000:1.103,442.190000:1.103,443.120000:1.103,444.680000:1.103,445.120000:1.103,449.110000:1.103,450.710000:1.103,452.150000:2.209,453.240000:3.12,454.200000:1.103,454.700000:1.103,458.310000:1.103,460.290000:1.103,461.250000:1.103,461.830000:1.103,462.195000:2.103,463.850000:1.103,464.250000:1.103,467.180000:2.174,470.210000:1.103,471.120000:1.103,489.700000:1.103,493.200000:1.103,494.200000:1.103,505.200000:1.103,508.170000:2.197,508.840000:1.103,509.200000:2.103,511.450000:1.103,522.170000:2.197,523.190000:1.103,524.150000:2.174,527.160000:1.103,528.410000:2.19,529.280000:1.103,530.230000:1.103,531.250000:1.103,533.130000:1.103,533.670000:1.103,536.720000:1.103,537.240000:1.103,538.080000:1.103,538.450000:1.103,540.220000:1.103,545.210000:2.174,545.490000:1.103,546.250000:1.103,547.350000:1.103,550.750000:2.205,558.070000:1.103,561.360000:1.103,562.200000:1.103,563.330000:1.103,568.230000:1.103,571.290000:3.136,573.010000:1.103,575.410000:1.103,580.240000:1.103,581.260000:1.103,585.160000:1.103,588.380000:1.103,590.120000:1.103,599.450000:1.103,605.210000:2.197,607.285000:4.499,608.270000:3.143,613.330000:2.103,614.330000:1.103,617.320000:1.103,621.230000:1.103,622.310000:1.103,625.320000:3.23,626.210000:1.103,633.275000:2.205,640.350000:1.103,642.220000:1.103,644.280000:1.103,646.250000:1.103,648.390000:1.103,651.335000:2.103,653.360000:2.136,658.300000:1.103,662.320000:1.103,663.800000:1.103,668.275000:2.209,674.370000:1.103,676.090000:1.103,677.350000:1.103,678.070000:1.103,683.370000:1.103,684.920000:1.103,685.380000:2.091,686.390000:1.103,701.410000:1.103,702.380000:7.387,703.420000:3.12,707.360000:1.103,713.340000:1.103,718.370000:2.197,720.400000:1.103,724.180000:1.103,728.390000:1.103,734.380000:1.103,735.430000:1.103,736.360000:1.103,737.310000:1.103,741.070000:1.103,745.480000:1.103,747.290000:1.103,748.320000:1.103,754.358237:6.383,755.370000:2.136,760.490000:1.103,765.360000:1.103,767.500000:1.103,770.370000:1.103,775.230000:1.103,778.490000:1.103,792.360000:1.103,796.420000:1.103,801.380000:1.103,814.390000:2.118,815.390000:1.103,816.410000:1.103,820.470000:1.103,825.350000:1.103,841.510000:1.103,848.450000:1.103,883.450000:1.103,884.470000:1.103,896.410000:1.103,907.420000:1.103,908.430000:1.103,916.380000:1.103,1074.300000:1.103,1092.600000:1.103,1164.300000:1.103,1231.540000:1.103,1397.690000:1.103,1660.400000:1.103,1711.520000:1.103
      ions2       :
      ions3       :
      peptol      : 0
      peptol units:
      peptol str  :
      INSTRUMENT  :
      RULES       :
      IT_MODS     :
      repeat srch : 497.265612 from(498.272888,1+) query(1)
157, 24
185, 27
286, 81
385, 13
480, 4
129, 19
187, 23
354, 14
399, 9
482, 3
130, 9
258, 16
357, 14
444, 6
481, 3
136, 7
213, 14
371, 11
459, 6
489, 3
147, 6
229, 10
326, 5
423, 4
483, 2
159, 5
240, 8
298, 5
444, 3
474, 1
158, 4
270, 7
324, 5
411, 3
475, 1
86, 3
175, 7
312, 4
463, 3
477, 1
102, 3
241, 5
293, 4
446, 3
478, 1
115, 3
243, 4
353, 4
401, 3
487, 1
72, 2
76, 1
84, 2
87, 1
88, 1
98, 1
103, 1
105, 1
116, 1
117, 1
118, 1
120, 2
126, 1
127, 1
128, 2
131, 2
132, 1
136, 1
137, 1
138, 1
139, 1
140, 2
141, 2
143, 2
146, 1
152, 1
155, 2
156, 1
159, 1
165, 2
166, 1
167, 1
170, 1
170, 1
171, 1
173, 2
177, 1
178, 1
181, 1
182, 1
183, 2
184, 1
186, 4
188, 1
189, 1
189, 1
190, 2
191, 1
197, 1
199, 1
200, 1
201, 3
202, 2
203, 2
204, 1
211, 4
212, 2
212, 1
215, 2
216, 2
217, 1
218, 1
219, 2
223, 3
224, 1
225, 1
227, 1
228, 1
228, 2
230, 1
232, 1
233, 1
234, 1
235, 2
237, 1
238, 4
239, 3
242, 2
244, 2
244, 2
245, 3
246, 2
247, 2
248, 2
249, 2
250, 1
251, 1
253, 1
254, 1
255, 2
256, 1
257, 1
259, 2
260, 1
260, 1
262, 1
265, 1
266, 2
267, 1
267, 1
268, 3
269, 1
271, 2
272, 2
274, 1
275, 1
276, 2
278, 1
280, 2
281, 1
283, 1
284, 1
285, 1
287, 3
288, 1
288, 2
290, 1
294, 2
295, 3
296, 1
297, 2
300, 3
302, 1
303, 1
304, 1
305, 1
305, 1
306, 3
307, 1
308, 2
308, 1
313, 1
313, 1
314, 1
316, 2
317, 3
318, 1
320, 1
322, 3
323, 3
327, 1
328, 1
331, 2
332, 2
333, 1
336, 1
336, 1
337, 2
339, 1
339, 1
339, 3
341, 2
342, 1
343, 1
343, 2
344, 1
344, 2
346, 1
348, 1
348, 2
350, 1
350, 2
351, 3
352, 2
354, 1
354, 1
355, 3
358, 1
359, 2
360, 1
360, 1
361, 1
362, 1
363, 1
364, 1
366, 1
367, 1
368, 1
369, 1
369, 3
370, 1
370, 3
373, 2
374, 2
375, 2
376, 1
377, 1
380, 2
382, 3
383, 2
386, 2
386, 1
387, 3
388, 2
388, 1
390, 1
390, 1
391, 1
394, 1
395, 1
396, 2
398, 1
400, 2
403, 1
404, 1
404, 1
410, 2
412, 1
413, 1
414, 1
415, 1
416, 1
417, 1
417, 1
418, 1
418, 2
419, 1
421, 1
421, 2
423, 1
425, 2
426, 1
426, 3
428, 2
429, 1
430, 1
431, 2
433, 1
434, 1
435, 1
435, 1
437, 1
439, 2
439, 1
440, 1
442, 1
443, 1
445, 1
445, 1
449, 1
451, 1
452, 2
453, 3
454, 1
455, 1
458, 1
460, 1
461, 1
462, 1
462, 2
464, 1
464, 1
467, 2
470, 1
471, 1
490, 1
493, 1
494, 1
505, 1
508, 2
509, 1
509, 2
511, 1
522, 2
523, 1
524, 2
527, 1
528, 2
529, 1
530, 1
531, 1
533, 1
534, 1
537, 1
537, 1
538, 1
538, 1
540, 1
545, 2
545, 1
546, 1
547, 1
551, 2
558, 1
561, 1
562, 1
563, 1
568, 1
571, 3
573, 1
575, 1
580, 1
581, 1
585, 1
588, 1
590, 1
599, 1
605, 2
607, 4
608, 3
613, 2
614, 1
617, 1
621, 1
622, 1
625, 3
626, 1
633, 2
640, 1
642, 1
644, 1
646, 1
648, 1
651, 2
653, 2
658, 1
662, 1
664, 1
668, 2
674, 1
676, 1
677, 1
678, 1
683, 1
685, 1
685, 2
686, 1
701, 1
702, 7
703, 3
707, 1
713, 1
718, 2
720, 1
724, 1
728, 1
734, 1
735, 1
736, 1
737, 1
741, 1
745, 1
747, 1
748, 1
754, 6
755, 2
760, 1
765, 1
768, 1
770, 1
775, 1
778, 1
792, 1
796, 1
801, 1
814, 2
815, 1
816, 1
820, 1
825, 1
842, 1
848, 1
883, 1
884, 1
896, 1
907, 1
908, 1
916, 1
1074, 1
1093, 1
1164, 1
1232, 1
1398, 1
1660, 1
1712, 1
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_input.java

Example program for retrieving input spectrum data.

/*
##############################################################################
# file: resfile_input.java                                                   #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_inputda $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class resfile_input {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("Must specify results filename as parameter");
            System.exit(0);
        }

        ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
        if (file.isValid()) {
            inputData(file);
        } else {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }
    }

    private static void inputData(ms_mascotresfile file) {
        int i;
        int j;
        int num_peaks;

        // display input data via inputquery get functions
        for(i=1; i <=1; i++) { // replace i<=1 with i<=file.getNumQueries() for complete dataset
            System.out.println("Input data for query number "+i);
            System.out.println("=========================================");
            ms_inputquery q=new ms_inputquery(file,i);
            System.out.println("      title       : "+q.getStringTitle(true));
            System.out.println("      mass_min    : "+q.getMassMin());
            System.out.println("      mass_max    : "+q.getMassMax());
            System.out.println("      int_min     : "+q.getIntMin());
            System.out.println("      int_max     : "+q.getIntMax());
            System.out.println("      num_vals    : "+q.getNumVals());
            System.out.println("      num_used1   : "+q.getNumUsed());
            System.out.println("      ions1       : "+q.getStringIons1());
            System.out.println("      ions2       : "+q.getStringIons2());
            System.out.println("      ions3       : "+q.getStringIons3());
            System.out.println("      peptol      : "+q.getPepTol());
            System.out.println("      peptol units: "+q.getPepTolUnits());
            System.out.println("      peptol str  : "+q.getPepTolString());
            System.out.println("      INSTRUMENT  : "+q.getINSTRUMENT());
            System.out.println("      RULES       : "+q.getRULES());
            System.out.println("      IT_MODS     : "+q.getIT_MODS());
            System.out.println("      repeat srch : "+file.getRepeatSearchString(i));

            num_peaks = q.getNumberOfPeaks(1);
            for(j=1; j <= num_peaks; j++) {
                System.out.println(roundWholeNumber(q.getPeakMass(1,j))+", "+roundWholeNumber(q.getPeakIntensity(1,j)));
            }
        }
        System.out.println("\n");
    }

    private static int toBinary(boolean bool) {
        if(bool) return 1;
        return 0;
    }

    private static String roundWholeNumber (double toRound) {
        String myInt = ""+toRound;
        myInt += "\n";
        if(myInt.indexOf(".0\n")>-1) {
            return myInt.substring(0,myInt.indexOf(".0\n"));
        }
        return ""+toRound;
    }

}

/*

will give the output:

C>java -classpath .;../java/msparser.jar resfile_input F981123.dat
Input data for query number 1
=========================================
      title       : dp210198c                      21-Jan-98 DERIVED SPECTRUM    #9
      mass_min    : 214.8
      mass_max    : 1228.7
      int_min     : 7.0
      int_max     : 114465.0
      num_vals    : 443
      num_used1   : 0
      ions1       : 288.200000:2137,371.127841:1663,472.096295:2.939e+04,567.000000:5.469e+04,663.100000:1.145e+05,758.2
00000:7.356e+04,871.200000:2.539e+04,956.100000:2241,1055.000000:1.227e+04,1167.994665:1.725e+04,1215.400000:257,314.200
000:1308,377.992647:1088,501.400000:1.043e+04,584.997427:3.906e+04,654.180103:3.006e+04,759.300000:1.557e+04,841.900000:
1.917e+04,972.292156:1874,1056.300000:3799,1169.100000:1.123e+04,1225.200000:58,242.800000:417,377.000000:828,454.100000
:5162,586.200000:5258,662.700000:1.83e+04,728.800000:1397,842.900000:4893,956.800000:443,1029.300000:1846,1170.200000:12
80,1216.200000:51,313.900000:187,387.200000:656,473.200000:1342,568.100000:5122,663.600000:9782,729.200000:626,872.30000
0:4300,973.515686:255,1100.300000:1290,1198.200000:117,1217.500000:45,243.200000:159,379.100000:231,502.400000:556,599.1
00000:1504,655.000000:1672,814.100000:277,841.200000:215,958.138974:195,1056.000000:492,1196.900000:96,1226.400000:38,28
6.100000:83,408.200000:187,428.200000:283,614.400000:1403,710.900000:1144,730.000000:214,843.600000:194,1011.400000:78,1
057.200000:416,1198.900000:80,1227.000000:20,289.000000:60,353.300000:136,500.700000:143,551.300000:800,665.994513:565,7
57.300000:182,873.300000:166,955.000000:51,1101.262914:302,1197.600000:53,1228.700000:19,253.900000:44,394.000000:115,42
6.400000:75,566.263208:424,665.300000:563,801.800000:171,827.400000:165,1002.100000:46,1030.500000:193,1168.500000:42,29
0.200000:25,388.100000:63,444.100000:75,542.000000:399,664.600000:388,760.000000:160,825.200000:76,937.900000:38,1082.40
0000:126,1170.500000:40,287.100000:23,342.800000:48,454.900000:64,614.100000:373,644.000000:290,769.300000:111,902.10000
0:67,917.300000:37,1029.800000:125,1149.800000:38,214.800000:18,242.100000:19,252.100000:20,315.200000:44,325.800000:17,
333.100000:21,347.500000:19,348.700000:13,349.500000:23,352.600000:47,359.100000:28,366.000000:36,367.900000:7,376.10000
0:14,380.100000:46,407.300000:11,410.900000:22,412.400000:31,418.000000:17,429.900000:57,431.000000:15,436.400000:11,444
.900000:27,447.200000:18,453.200000:11,455.500000:33,456.100000:14,459.900000:15,461.600000:19,463.300000:7,465.600000:2
2,470.400000:12,470.900000:51,474.200000:44,477.100000:15,477.900000:32,483.900000:37,486.200000:20,496.900000:11,497.60
0000:14,499.100000:41,503.800000:24,505.400000:22,508.300000:12,508.900000:17,511.800000:19,513.000000:20,515.000000:18,
517.000000:16,522.100000:58,523.900000:15,524.600000:78,525.300000:19,525.900000:370,526.700000:36,532.900000:11,533.500
000:14,536.900000:19,538.200000:44,539.261607:224,540.200000:39,541.100000:133,543.043902:41,545.100000:9,545.600000:30,
547.300000:23,547.900000:13,548.700000:340,549.600000:81,550.200000:41,551.700000:16,552.300000:69,555.500000:29,557.068
975:361,558.300000:54,560.100000:7,561.100000:24,563.400000:39,564.100000:101,567.600000:35,568.900000:37,569.500000:14,
570.000000:49,571.100000:45,572.300000:76,574.000000:99,574.600000:22,576.300000:18,580.800000:34,582.300000:41,587.1000
00:131,587.900000:53,590.300000:12,591.800000:17,592.500000:18,594.800000:9,595.300000:56,596.100000:97,596.600000:62,59
7.100000:27,597.700000:63,600.000000:57,602.100000:28,603.900000:16,605.200000:69,606.800000:24,607.500000:13,608.500000
:57,608.800000:12,610.200000:50,610.500000:12,611.200000:96,612.200000:24,613.200000:13,615.000000:194,615.600000:19,616
.200000:23,618.400000:15,619.100000:31,621.100000:120,621.700000:36,622.600000:11,623.200000:43,624.100000:147,624.80000
0:32,626.000000:22,627.000000:53,627.900000:21,628.900000:16,629.500000:29,630.500000:14,631.400000:45,633.200000:61,635
.000000:58,635.736413:184,636.600000:29,637.500000:78,638.600000:14,639.800000:72,640.500000:51,641.100000:33,641.700000
:40,642.400000:121,642.800000:170,643.300000:57,644.600000:48,645.700000:36,646.500000:39,647.400000:28,648.500000:30,64
9.500000:108,650.000000:13,650.600000:43,651.800000:107,652.300000:33,652.900000:33,656.300000:178,657.100000:78,658.200
000:19,658.800000:76,660.590741:108,661.900000:216,667.000000:193,677.300000:8,680.500000:13,683.500000:38,684.500000:28
,685.500000:24,686.200000:13,687.275862:87,688.200000:28,688.900000:28,689.400000:50,691.500000:28,692.700000:25,693.200
000:15,694.000000:31,697.100000:8,698.300000:42,700.300000:17,700.900000:21,703.500000:39,704.200000:20,704.900000:14,70
8.300000:15,709.000000:42,711.500000:90,711.800000:119,713.100000:35,715.200000:29,718.500000:57,719.900000:52,721.50000
0:78,722.400000:29,725.400000:30,731.100000:13,731.800000:13,734.500000:36,735.300000:46,735.700000:28,738.600000:23,739
.900000:20,740.500000:81,741.800000:64,744.700000:23,745.500000:18,747.400000:23,751.100000:21,751.900000:34,755.200000:
13,756.200000:28,760.900000:21,762.800000:19,764.100000:19,767.600000:41,768.200000:75,771.200000:9,771.800000:10,773.80
0000:10,776.100000:21,777.500000:39,783.400000:39,785.100000:26,786.800000:15,788.200000:23,789.300000:14,791.700000:21,
792.600000:29,795.700000:53,796.200000:25,798.900000:13,799.400000:14,800.200000:12,800.700000:32,802.300000:25,802.8000
00:103,804.000000:26,805.200000:83,807.900000:15,808.700000:25,809.800000:36,810.900000:50,811.500000:85,812.100000:36,8
13.400000:22,814.600000:78,815.100000:52,815.900000:25,817.300000:21,821.300000:30,822.000000:9,827.800000:33,828.900000
:20,832.100000:13,834.800000:18,835.700000:25,836.600000:20,846.700000:8,851.100000:25,852.054545:66,853.200000:20,854.4
00000:28,857.000000:21,857.800000:21,859.500000:14,861.100000:17,864.500000:20,867.800000:49,868.800000:47,869.100000:19
,869.700000:22,872.900000:22,877.100000:16,880.800000:20,885.000000:21,885.800000:12,886.300000:16,888.800000:11,890.500
000:10,899.339024:41,907.800000:39,909.400000:8,911.200000:27,911.900000:9,925.900000:10,928.800000:30,930.700000:26,933
.700000:9,935.700000:13,945.100000:20,948.900000:10,953.600000:14,960.500000:14,974.100000:36,994.000000:37,1003.300000:
18,1010.200000:18,1010.800000:27,1012.100000:21,1014.000000:14,1020.100000:20,1021.000000:31,1028.900000:118,1031.000000
:18,1031.600000:40,1033.100000:14,1037.900000:55,1041.100000:17,1045.300000:13,1054.000000:92,1057.700000:19,1061.900000
:20,1069.100000:16,1083.600000:41,1093.400000:49,1098.500000:32,1099.800000:46,1102.500000:52,1103.200000:18,1104.500000
:9,1125.400000:16,1131.800000:24,1132.400000:21,1139.800000:12,1150.800000:22,1152.900000:15,1157.600000:8,1165.300000:1
4,1166.700000:11,1178.700000:25,1179.500000:23,1180.400000:25,1185.800000:12,1192.800000:18,1194.800000:12,1214.700000:3
5
      ions2       :
      ions3       :
      peptol      : 0.0
      peptol units:
      peptol str  :
      repeat srch : 1341.784350 from(671.900000,2+)  title(dp210198c%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%
20%20%20%20%2021%2dJan%2d98%20DERIVED%20SPECTRUM%20%20%20%20%239)  query(1)
288.2, 2137
371.127841, 1663
472.096295, 29390
567, 54690
663.1, 114500
758.2, 73560
871.2, 25390
956.1, 2241
1055, 12270
1167.994665, 17250
1215.4, 257
314.2, 1308
377.992647, 1088
501.4, 10430
584.997427, 39060
654.180103, 30060
759.3, 15570
841.9, 19170
972.292156, 1874
1056.3, 3799
1169.1, 11230
1225.2, 58
242.8, 417
377, 828
454.1, 5162
586.2, 5258
662.7, 18300
728.8, 1397
842.9, 4893
956.8, 443
1029.3, 1846
1170.2, 1280
1216.2, 51
313.9, 187
387.2, 656
473.2, 1342
568.1, 5122
663.6, 9782
729.2, 626
872.3, 4300
973.515686, 255
1100.3, 1290
1198.2, 117
1217.5, 45
243.2, 159
379.1, 231
502.4, 556
599.1, 1504
655, 1672
814.1, 277
841.2, 215
958.138974, 195
1056, 492
1196.9, 96
1226.4, 38
286.1, 83
408.2, 187
428.2, 283
614.4, 1403
710.9, 1144
730, 214
843.6, 194
1011.4, 78
1057.2, 416
1198.9, 80
1227, 20
289, 60
353.3, 136
500.7, 143
551.3, 800
665.994513, 565
757.3, 182
873.3, 166
955, 51
1101.262914, 302
1197.6, 53
1228.7, 19
253.9, 44
394, 115
426.4, 75
566.263208, 424
665.3, 563
801.8, 171
827.4, 165
1002.1, 46
1030.5, 193
1168.5, 42
290.2, 25
388.1, 63
444.1, 75
542, 399
664.6, 388
760, 160
825.2, 76
937.9, 38
1082.4, 126
1170.5, 40
287.1, 23
342.8, 48
454.9, 64
614.1, 373
644, 290
769.3, 111
902.1, 67
917.3, 37
1029.8, 125
1149.8, 38
214.8, 18
242.1, 19
252.1, 20
315.2, 44
325.8, 17
333.1, 21
347.5, 19
348.7, 13
349.5, 23
352.6, 47
359.1, 28
366, 36
367.9, 7
376.1, 14
380.1, 46
407.3, 11
410.9, 22
412.4, 31
418, 17
429.9, 57
431, 15
436.4, 11
444.9, 27
447.2, 18
453.2, 11
455.5, 33
456.1, 14
459.9, 15
461.6, 19
463.3, 7
465.6, 22
470.4, 12
470.9, 51
474.2, 44
477.1, 15
477.9, 32
483.9, 37
486.2, 20
496.9, 11
497.6, 14
499.1, 41
503.8, 24
505.4, 22
508.3, 12
508.9, 17
511.8, 19
513, 20
515, 18
517, 16
522.1, 58
523.9, 15
524.6, 78
525.3, 19
525.9, 370
526.7, 36
532.9, 11
533.5, 14
536.9, 19
538.2, 44
539.261607, 224
540.2, 39
541.1, 133
543.043902, 41
545.1, 9
545.6, 30
547.3, 23
547.9, 13
548.7, 340
549.6, 81
550.2, 41
551.7, 16
552.3, 69
555.5, 29
557.068975, 361
558.3, 54
560.1, 7
561.1, 24
563.4, 39
564.1, 101
567.6, 35
568.9, 37
569.5, 14
570, 49
571.1, 45
572.3, 76
574, 99
574.6, 22
576.3, 18
580.8, 34
582.3, 41
587.1, 131
587.9, 53
590.3, 12
591.8, 17
592.5, 18
594.8, 9
595.3, 56
596.1, 97
596.6, 62
597.1, 27
597.7, 63
600, 57
602.1, 28
603.9, 16
605.2, 69
606.8, 24
607.5, 13
608.5, 57
608.8, 12
610.2, 50
610.5, 12
611.2, 96
612.2, 24
613.2, 13
615, 194
615.6, 19
616.2, 23
618.4, 15
619.1, 31
621.1, 120
621.7, 36
622.6, 11
623.2, 43
624.1, 147
624.8, 32
626, 22
627, 53
627.9, 21
628.9, 16
629.5, 29
630.5, 14
631.4, 45
633.2, 61
635, 58
635.736413, 184
636.6, 29
637.5, 78
638.6, 14
639.8, 72
640.5, 51
641.1, 33
641.7, 40
642.4, 121
642.8, 170
643.3, 57
644.6, 48
645.7, 36
646.5, 39
647.4, 28
648.5, 30
649.5, 108
650, 13
650.6, 43
651.8, 107
652.3, 33
652.9, 33
656.3, 178
657.1, 78
658.2, 19
658.8, 76
660.590741, 108
661.9, 216
667, 193
677.3, 8
680.5, 13
683.5, 38
684.5, 28
685.5, 24
686.2, 13
687.275862, 87
688.2, 28
688.9, 28
689.4, 50
691.5, 28
692.7, 25
693.2, 15
694, 31
697.1, 8
698.3, 42
700.3, 17
700.9, 21
703.5, 39
704.2, 20
704.9, 14
708.3, 15
709, 42
711.5, 90
711.8, 119
713.1, 35
715.2, 29
718.5, 57
719.9, 52
721.5, 78
722.4, 29
725.4, 30
731.1, 13
731.8, 13
734.5, 36
735.3, 46
735.7, 28
738.6, 23
739.9, 20
740.5, 81
741.8, 64
744.7, 23
745.5, 18
747.4, 23
751.1, 21
751.9, 34
755.2, 13
756.2, 28
760.9, 21
762.8, 19
764.1, 19
767.6, 41
768.2, 75
771.2, 9
771.8, 10
773.8, 10
776.1, 21
777.5, 39
783.4, 39
785.1, 26
786.8, 15
788.2, 23
789.3, 14
791.7, 21
792.6, 29
795.7, 53
796.2, 25
798.9, 13
799.4, 14
800.2, 12
800.7, 32
802.3, 25
802.8, 103
804, 26
805.2, 83
807.9, 15
808.7, 25
809.8, 36
810.9, 50
811.5, 85
812.1, 36
813.4, 22
814.6, 78
815.1, 52
815.9, 25
817.3, 21
821.3, 30
822, 9
827.8, 33
828.9, 20
832.1, 13
834.8, 18
835.7, 25
836.6, 20
846.7, 8
851.1, 25
852.054545, 66
853.2, 20
854.4, 28
857, 21
857.8, 21
859.5, 14
861.1, 17
864.5, 20
867.8, 49
868.8, 47
869.1, 19
869.7, 22
872.9, 22
877.1, 16
880.8, 20
885, 21
885.8, 12
886.3, 16
888.8, 11
890.5, 10
899.339024, 41
907.8, 39
909.4, 8
911.2, 27
911.9, 9
925.9, 10
928.8, 30
930.7, 26
933.7, 9
935.7, 13
945.1, 20
948.9, 10
953.6, 14
960.5, 14
974.1, 36
994, 37
1003.3, 18
1010.2, 18
1010.8, 27
1012.1, 21
1014, 14
1020.1, 20
1021, 31
1028.9, 118
1031, 18
1031.6, 40
1033.1, 14
1037.9, 55
1041.1, 17
1045.3, 13
1054, 92
1057.7, 19
1061.9, 20
1069.1, 16
1083.6, 41
1093.4, 49
1098.5, 32
1099.8, 46
1102.5, 52
1103.2, 18
1104.5, 9
1125.4, 16
1131.8, 24
1132.4, 21
1139.8, 12
1150.8, 22
1152.9, 15
1157.6, 8
1165.3, 14
1166.7, 11
1178.7, 25
1179.5, 23
1180.4, 25
1185.8, 12
1192.8, 18
1194.8, 12
1214.7, 35

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_input.py

Example program for retrieving input spectrum data.

#!/usr/bin/python
##############################################################################
# file: resfile_input.py                                                     #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/resfile_input.py $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

def main() :
    if len(sys.argv) < 2 :
        print("Must specify results filename as parameter")
        return 1

    resfile = msparser.ms_mascotresfile(sys.argv[1])

    if resfile.isValid() :
        inputData(resfile)

def inputData(resfile) :
    # display input data via inputquery get functions
    for i in range(1, 2) :
        # replace range with (1, 1 + resfile.getNumQueries()) to get all input
        # data.

        print("Input data for query number %d" % i)
        print("=========================================")

        q = msparser.ms_inputquery(resfile, i)
        fmt = "    %-16s: %s"

        print(fmt % ("title"       , q.getStringTitle(1)))
        print(fmt % ("mass_min"    , q.getMassMin()))
        print(fmt % ("mass_max"    , q.getMassMax()))
        print(fmt % ("int_min"     , q.getIntMin()))
        print(fmt % ("int_max"     , q.getIntMax()))
        print(fmt % ("num_vals"    , q.getNumVals()))
        print(fmt % ("num_used1"   , q.getNumUsed()))
        print(fmt % ("ions1"       , q.getStringIons1()))
        print(fmt % ("ions2"       , q.getStringIons2()))
        print(fmt % ("ions3"       , q.getStringIons3()))
        print(fmt % ("peptol"      , q.getPepTol()))
        print(fmt % ("peptol units", q.getPepTolUnits()))
        print(fmt % ("peptol str"  , q.getPepTolString()))
        print(fmt % ("repeat srch" , resfile.getRepeatSearchString(i)))

        num_peaks = q.getNumberOfPeaks(1)
        for j in range (1, 1+ num_peaks) :
            print("%f, %f" % (q.getPeakMass(1, j), q.getPeakIntensity(1, j)))

    print(" ")

if __name__ == "__main__" :
    sys.exit(main())

"""

Running the program as

python resfile_input.pl F981123.dat

will give the following output under Mascot Server 2.3:

Input data for query number  1
=========================================
    title           :
    mass_min        : 72.09
    mass_max        : 1711.52
    int_min         : 1.103
    int_max         : 80.7
    num_vals        : 425
    num_used1       : 0
    ions1           : 157.096962:23.72,185.160000:26.69,286.134951:80.7,385.210000:13.49,480.270000:4.363,129.102412:18.84,187.070000:22.51,354.189124:13.57,399.246727:9.489,482.140542:3.205,130.110251:9.257,258.132661:15.93,357.210000:13.57,443.810000:6.256,481.210000:3.182,136.070000:7.387,213.139215:13.84,371.204929:11.24,459.280000:6.216,489.233770:3.157,147.117662:6.333,229.120000:9.72,326.133204:5.268,423.125582:4.262,483.115000:2.205,159.080000:5.222,240.130000:7.562,298.110000:5.231,444.168974:3.247,474.300000:1.103,158.090000:4.301,270.180000:7.432,324.170000:5.17,411.200000:3.23,475.270000:1.103,86.110000:3.276,175.110000:7.308,312.150879:4.235,463.265712:3.205,476.700000:1.103,102.060000:3.276,241.085275:5.361,293.110000:4.178,445.810000:3.182,478.180000:1.103,115.088725:3.255,243.139772:4.378,353.155308:4.149,401.150000:3.138,486.880000:1.103,72.090000:2.174,76.400000:1.103,84.075000:2.111,87.110000:1.103,88.100000:1.103,98.060000:1.103,103.060000:1.103,105.070000:1.103,116.070000:1.103,117.110000:1.103,118.400000:1.103,120.090000:2.205,126.070000:1.103,127.090000:1.103,128.090000:2.103,131.085000:2.118,132.090000:1.103,135.800000:1.103,137.080000:1.103,138.070000:1.103,139.090000:1.103,140.150000:2.174,141.060000:2.174,143.120000:2.174,146.080000:1.103,152.060000:1.103,155.070000:2.205,156.100000:1.103,159.450000:1.103,165.080000:2.136,166.110000:1.103,167.110000:1.103,169.710000:1.103,170.450000:1.103,171.090000:1.103,173.120000:2.174,177.090000:1.103,178.080000:1.103,181.160000:1.103,182.030000:1.103,183.110000:2.174,183.930000:1.103,186.131024:4.374,188.070000:1.103,188.760000:1.103,189.070000:1.103,190.065000:2.103,191.300000:1.103,197.130000:1.103,199.180000:1.103,200.080000:1.103,201.100000:3.138,202.110000:2.091,203.080000:2.174,203.610000:1.103,211.140000:4.189,212.115000:2.103,212.490000:1.103,214.985000:2.205,216.110000:2.103,217.100000:1.103,218.080000:1.103,219.090000:2.103,223.090000:3.154,224.130000:1.103,225.130000:1.103,227.170000:1.103,227.880000:1.103,228.170000:2.136,229.760000:1.103,231.950000:1.103,233.130000:1.103,234.430000:1.103,235.080000:2.103,236.590000:1.103,238.080000:4.332,239.139997:3.131,242.170000:2.205,244.090000:2.136,244.430000:2.091,245.165685:3.205,246.160000:2.197,247.110000:2.102,248.145000:2.118,249.110000:2.136,250.080000:1.103,251.160000:1.103,253.100000:1.103,254.130000:1.103,255.165000:2.22,256.170000:1.103,257.060000:1.103,259.150000:2.197,260.000000:1.103,260.490000:1.103,262.110000:1.103,265.120000:1.103,266.130000:2.159,266.950000:1.103,267.210000:1.103,268.120000:3.214,269.090000:1.103,271.150000:2.136,272.170000:2.103,274.120000:1.103,275.030000:1.103,276.175000:2.22,278.190000:1.103,279.720000:2.205,281.120000:1.103,283.070000:1.103,284.110000:1.103,285.070000:1.103,287.140000:3.296,287.780000:1.103,288.090000:2.103,290.130000:1.103,294.110000:2.174,295.150000:3.114,295.730000:1.103,297.180000:2.136,300.160000:3.143,302.070000:1.103,303.160000:1.103,303.590000:1.103,304.600000:1.103,305.130000:1.103,306.140000:3.182,307.050000:1.103,308.150000:2.174,308.490000:1.103,312.610000:1.103,312.880000:1.103,314.120000:1.103,316.085000:2.111,317.150000:3.183,318.140000:1.103,320.140000:1.103,322.149731:3.255,323.034482:3.149,327.020000:1.103,328.020000:1.103,331.140000:2.091,332.165000:2.103,333.140000:1.103,335.500000:1.103,336.190000:1.103,337.030000:2.118,338.620000:1.103,338.940000:1.103,339.200000:3.261,341.210000:2.103,342.180000:1.103,342.800000:1.103,343.225000:2.111,343.800000:1.103,344.150000:2.174,346.010000:1.103,347.660000:1.103,348.200000:2.197,349.800000:1.103,350.110000:2.118,351.130000:3.276,352.130000:2.136,353.910000:1.103,354.470000:1.103,355.193955:3.376,358.200000:1.103,359.210000:2.174,359.910000:1.103,360.470000:1.103,361.080000:1.103,362.190000:1.103,363.040000:1.103,364.080000:1.103,366.120000:1.103,367.150000:1.103,368.330000:1.103,368.730000:1.103,369.230000:3.15,369.820000:1.103,370.177065:3.279,373.130000:2.197,374.055000:2.217,374.510000:2.205,376.040000:1.103,377.040000:1.103,380.160000:2.103,382.180000:3.102,383.115000:2.209,385.890000:2.205,386.370000:1.103,387.170000:3.114,387.680000:2.217,388.050000:1.103,389.620000:1.103,390.190000:1.103,390.610000:1.103,394.260000:1.103,395.180000:1.103,396.140000:2.205,397.980000:1.103,400.165000:2.209,403.210000:1.103,404.150000:1.103,404.470000:1.103,410.165000:2.111,411.550000:1.103,413.240000:1.103,414.080000:1.103,415.000000:1.103,416.190000:1.103,416.830000:1.103,417.230000:1.103,417.760000:1.103,418.285000:2.111,418.680000:1.103,420.650000:1.103,421.170000:2.136,422.580000:1.103,425.215000:2.103,425.690000:1.103,426.220000:3.125,428.140000:2.155,428.650000:1.103,430.260000:1.103,430.995000:2.205,433.200000:1.103,433.690000:1.103,435.000000:1.103,435.260000:1.103,437.180000:1.103,438.710000:2.174,439.230000:1.103,440.210000:1.103,442.190000:1.103,443.120000:1.103,444.680000:1.103,445.120000:1.103,449.110000:1.103,450.710000:1.103,452.150000:2.209,453.240000:3.12,454.200000:1.103,454.700000:1.103,458.310000:1.103,460.290000:1.103,461.250000:1.103,461.830000:1.103,462.195000:2.103,463.850000:1.103,464.250000:1.103,467.180000:2.174,470.210000:1.103,471.120000:1.103,489.700000:1.103,493.200000:1.103,494.200000:1.103,505.200000:1.103,508.170000:2.197,508.840000:1.103,509.200000:2.103,511.450000:1.103,522.170000:2.197,523.190000:1.103,524.150000:2.174,527.160000:1.103,528.410000:2.19,529.280000:1.103,530.230000:1.103,531.250000:1.103,533.130000:1.103,533.670000:1.103,536.720000:1.103,537.240000:1.103,538.080000:1.103,538.450000:1.103,540.220000:1.103,545.210000:2.174,545.490000:1.103,546.250000:1.103,547.350000:1.103,550.750000:2.205,558.070000:1.103,561.360000:1.103,562.200000:1.103,563.330000:1.103,568.230000:1.103,571.290000:3.136,573.010000:1.103,575.410000:1.103,580.240000:1.103,581.260000:1.103,585.160000:1.103,588.380000:1.103,590.120000:1.103,599.450000:1.103,605.210000:2.197,607.285000:4.499,608.270000:3.143,613.330000:2.103,614.330000:1.103,617.320000:1.103,621.230000:1.103,622.310000:1.103,625.320000:3.23,626.210000:1.103,633.275000:2.205,640.350000:1.103,642.220000:1.103,644.280000:1.103,646.250000:1.103,648.390000:1.103,651.335000:2.103,653.360000:2.136,658.300000:1.103,662.320000:1.103,663.800000:1.103,668.275000:2.209,674.370000:1.103,676.090000:1.103,677.350000:1.103,678.070000:1.103,683.370000:1.103,684.920000:1.103,685.380000:2.091,686.390000:1.103,701.410000:1.103,702.380000:7.387,703.420000:3.12,707.360000:1.103,713.340000:1.103,718.370000:2.197,720.400000:1.103,724.180000:1.103,728.390000:1.103,734.380000:1.103,735.430000:1.103,736.360000:1.103,737.310000:1.103,741.070000:1.103,745.480000:1.103,747.290000:1.103,748.320000:1.103,754.358237:6.383,755.370000:2.136,760.490000:1.103,765.360000:1.103,767.500000:1.103,770.370000:1.103,775.230000:1.103,778.490000:1.103,792.360000:1.103,796.420000:1.103,801.380000:1.103,814.390000:2.118,815.390000:1.103,816.410000:1.103,820.470000:1.103,825.350000:1.103,841.510000:1.103,848.450000:1.103,883.450000:1.103,884.470000:1.103,896.410000:1.103,907.420000:1.103,908.430000:1.103,916.380000:1.103,1074.300000:1.103,1092.600000:1.103,1164.300000:1.103,1231.540000:1.103,1397.690000:1.103,1660.400000:1.103,1711.520000:1.103
    ions2           :
    ions3           :
    peptol          : 0.0
    peptol units    :
    peptol str      :
    repeat srch     : 497.265612 from(498.272888,1+) query(1)
157.096962, 23.720000
185.160000, 26.690000
286.134951, 80.700000
385.210000, 13.490000
480.270000, 4.363000
129.102412, 18.840000
187.070000, 22.510000
354.189124, 13.570000
399.246727, 9.489000
482.140542, 3.205000
130.110251, 9.257000
258.132661, 15.930000
357.210000, 13.570000
443.810000, 6.256000
481.210000, 3.182000
136.070000, 7.387000
213.139215, 13.840000
371.204929, 11.240000
459.280000, 6.216000
489.233770, 3.157000
147.117662, 6.333000
229.120000, 9.720000
326.133204, 5.268000
423.125582, 4.262000
483.115000, 2.205000
159.080000, 5.222000
240.130000, 7.562000
298.110000, 5.231000
444.168974, 3.247000
474.300000, 1.103000
158.090000, 4.301000
270.180000, 7.432000
324.170000, 5.170000
411.200000, 3.230000
475.270000, 1.103000
86.110000, 3.276000
175.110000, 7.308000
312.150879, 4.235000
463.265712, 3.205000
476.700000, 1.103000
102.060000, 3.276000
241.085275, 5.361000
293.110000, 4.178000
445.810000, 3.182000
478.180000, 1.103000
115.088725, 3.255000
243.139772, 4.378000
353.155308, 4.149000
401.150000, 3.138000
486.880000, 1.103000
72.090000, 2.174000
76.400000, 1.103000
84.075000, 2.111000
87.110000, 1.103000
88.100000, 1.103000
98.060000, 1.103000
103.060000, 1.103000
105.070000, 1.103000
116.070000, 1.103000
117.110000, 1.103000
118.400000, 1.103000
120.090000, 2.205000
126.070000, 1.103000
127.090000, 1.103000
128.090000, 2.103000
131.085000, 2.118000
132.090000, 1.103000
135.800000, 1.103000
137.080000, 1.103000
138.070000, 1.103000
139.090000, 1.103000
140.150000, 2.174000
141.060000, 2.174000
143.120000, 2.174000
146.080000, 1.103000
152.060000, 1.103000
155.070000, 2.205000
156.100000, 1.103000
159.450000, 1.103000
165.080000, 2.136000
166.110000, 1.103000
167.110000, 1.103000
169.710000, 1.103000
170.450000, 1.103000
171.090000, 1.103000
173.120000, 2.174000
177.090000, 1.103000
178.080000, 1.103000
181.160000, 1.103000
182.030000, 1.103000
183.110000, 2.174000
183.930000, 1.103000
186.131024, 4.374000
188.070000, 1.103000
188.760000, 1.103000
189.070000, 1.103000
190.065000, 2.103000
191.300000, 1.103000
197.130000, 1.103000
199.180000, 1.103000
200.080000, 1.103000
201.100000, 3.138000
202.110000, 2.091000
203.080000, 2.174000
203.610000, 1.103000
211.140000, 4.189000
212.115000, 2.103000
212.490000, 1.103000
214.985000, 2.205000
216.110000, 2.103000
217.100000, 1.103000
218.080000, 1.103000
219.090000, 2.103000
223.090000, 3.154000
224.130000, 1.103000
225.130000, 1.103000
227.170000, 1.103000
227.880000, 1.103000
228.170000, 2.136000
229.760000, 1.103000
231.950000, 1.103000
233.130000, 1.103000
234.430000, 1.103000
235.080000, 2.103000
236.590000, 1.103000
238.080000, 4.332000
239.139997, 3.131000
242.170000, 2.205000
244.090000, 2.136000
244.430000, 2.091000
245.165685, 3.205000
246.160000, 2.197000
247.110000, 2.102000
248.145000, 2.118000
249.110000, 2.136000
250.080000, 1.103000
251.160000, 1.103000
253.100000, 1.103000
254.130000, 1.103000
255.165000, 2.220000
256.170000, 1.103000
257.060000, 1.103000
259.150000, 2.197000
260.000000, 1.103000
260.490000, 1.103000
262.110000, 1.103000
265.120000, 1.103000
266.130000, 2.159000
266.950000, 1.103000
267.210000, 1.103000
268.120000, 3.214000
269.090000, 1.103000
271.150000, 2.136000
272.170000, 2.103000
274.120000, 1.103000
275.030000, 1.103000
276.175000, 2.220000
278.190000, 1.103000
279.720000, 2.205000
281.120000, 1.103000
283.070000, 1.103000
284.110000, 1.103000
285.070000, 1.103000
287.140000, 3.296000
287.780000, 1.103000
288.090000, 2.103000
290.130000, 1.103000
294.110000, 2.174000
295.150000, 3.114000
295.730000, 1.103000
297.180000, 2.136000
300.160000, 3.143000
302.070000, 1.103000
303.160000, 1.103000
303.590000, 1.103000
304.600000, 1.103000
305.130000, 1.103000
306.140000, 3.182000
307.050000, 1.103000
308.150000, 2.174000
308.490000, 1.103000
312.610000, 1.103000
312.880000, 1.103000
314.120000, 1.103000
316.085000, 2.111000
317.150000, 3.183000
318.140000, 1.103000
320.140000, 1.103000
322.149731, 3.255000
323.034482, 3.149000
327.020000, 1.103000
328.020000, 1.103000
331.140000, 2.091000
332.165000, 2.103000
333.140000, 1.103000
335.500000, 1.103000
336.190000, 1.103000
337.030000, 2.118000
338.620000, 1.103000
338.940000, 1.103000
339.200000, 3.261000
341.210000, 2.103000
342.180000, 1.103000
342.800000, 1.103000
343.225000, 2.111000
343.800000, 1.103000
344.150000, 2.174000
346.010000, 1.103000
347.660000, 1.103000
348.200000, 2.197000
349.800000, 1.103000
350.110000, 2.118000
351.130000, 3.276000
352.130000, 2.136000
353.910000, 1.103000
354.470000, 1.103000
355.193955, 3.376000
358.200000, 1.103000
359.210000, 2.174000
359.910000, 1.103000
360.470000, 1.103000
361.080000, 1.103000
362.190000, 1.103000
363.040000, 1.103000
364.080000, 1.103000
366.120000, 1.103000
367.150000, 1.103000
368.330000, 1.103000
368.730000, 1.103000
369.230000, 3.150000
369.820000, 1.103000
370.177065, 3.279000
373.130000, 2.197000
374.055000, 2.217000
374.510000, 2.205000
376.040000, 1.103000
377.040000, 1.103000
380.160000, 2.103000
382.180000, 3.102000
383.115000, 2.209000
385.890000, 2.205000
386.370000, 1.103000
387.170000, 3.114000
387.680000, 2.217000
388.050000, 1.103000
389.620000, 1.103000
390.190000, 1.103000
390.610000, 1.103000
394.260000, 1.103000
395.180000, 1.103000
396.140000, 2.205000
397.980000, 1.103000
400.165000, 2.209000
403.210000, 1.103000
404.150000, 1.103000
404.470000, 1.103000
410.165000, 2.111000
411.550000, 1.103000
413.240000, 1.103000
414.080000, 1.103000
415.000000, 1.103000
416.190000, 1.103000
416.830000, 1.103000
417.230000, 1.103000
417.760000, 1.103000
418.285000, 2.111000
418.680000, 1.103000
420.650000, 1.103000
421.170000, 2.136000
422.580000, 1.103000
425.215000, 2.103000
425.690000, 1.103000
426.220000, 3.125000
428.140000, 2.155000
428.650000, 1.103000
430.260000, 1.103000
430.995000, 2.205000
433.200000, 1.103000
433.690000, 1.103000
435.000000, 1.103000
435.260000, 1.103000
437.180000, 1.103000
438.710000, 2.174000
439.230000, 1.103000
440.210000, 1.103000
442.190000, 1.103000
443.120000, 1.103000
444.680000, 1.103000
445.120000, 1.103000
449.110000, 1.103000
450.710000, 1.103000
452.150000, 2.209000
453.240000, 3.120000
454.200000, 1.103000
454.700000, 1.103000
458.310000, 1.103000
460.290000, 1.103000
461.250000, 1.103000
461.830000, 1.103000
462.195000, 2.103000
463.850000, 1.103000
464.250000, 1.103000
467.180000, 2.174000
470.210000, 1.103000
471.120000, 1.103000
489.700000, 1.103000
493.200000, 1.103000
494.200000, 1.103000
505.200000, 1.103000
508.170000, 2.197000
508.840000, 1.103000
509.200000, 2.103000
511.450000, 1.103000
522.170000, 2.197000
523.190000, 1.103000
524.150000, 2.174000
527.160000, 1.103000
528.410000, 2.190000
529.280000, 1.103000
530.230000, 1.103000
531.250000, 1.103000
533.130000, 1.103000
533.670000, 1.103000
536.720000, 1.103000
537.240000, 1.103000
538.080000, 1.103000
538.450000, 1.103000
540.220000, 1.103000
545.210000, 2.174000
545.490000, 1.103000
546.250000, 1.103000
547.350000, 1.103000
550.750000, 2.205000
558.070000, 1.103000
561.360000, 1.103000
562.200000, 1.103000
563.330000, 1.103000
568.230000, 1.103000
571.290000, 3.136000
573.010000, 1.103000
575.410000, 1.103000
580.240000, 1.103000
581.260000, 1.103000
585.160000, 1.103000
588.380000, 1.103000
590.120000, 1.103000
599.450000, 1.103000
605.210000, 2.197000
607.285000, 4.499000
608.270000, 3.143000
613.330000, 2.103000
614.330000, 1.103000
617.320000, 1.103000
621.230000, 1.103000
622.310000, 1.103000
625.320000, 3.230000
626.210000, 1.103000
633.275000, 2.205000
640.350000, 1.103000
642.220000, 1.103000
644.280000, 1.103000
646.250000, 1.103000
648.390000, 1.103000
651.335000, 2.103000
653.360000, 2.136000
658.300000, 1.103000
662.320000, 1.103000
663.800000, 1.103000
668.275000, 2.209000
674.370000, 1.103000
676.090000, 1.103000
677.350000, 1.103000
678.070000, 1.103000
683.370000, 1.103000
684.920000, 1.103000
685.380000, 2.091000
686.390000, 1.103000
701.410000, 1.103000
702.380000, 7.387000
703.420000, 3.120000
707.360000, 1.103000
713.340000, 1.103000
718.370000, 2.197000
720.400000, 1.103000
724.180000, 1.103000
728.390000, 1.103000
734.380000, 1.103000
735.430000, 1.103000
736.360000, 1.103000
737.310000, 1.103000
741.070000, 1.103000
745.480000, 1.103000
747.290000, 1.103000
748.320000, 1.103000
754.358237, 6.383000
755.370000, 2.136000
760.490000, 1.103000
765.360000, 1.103000
767.500000, 1.103000
770.370000, 1.103000
775.230000, 1.103000
778.490000, 1.103000
792.360000, 1.103000
796.420000, 1.103000
801.380000, 1.103000
814.390000, 2.118000
815.390000, 1.103000
816.410000, 1.103000
820.470000, 1.103000
825.350000, 1.103000
841.510000, 1.103000
848.450000, 1.103000
883.450000, 1.103000
884.470000, 1.103000
896.410000, 1.103000
907.420000, 1.103000
908.430000, 1.103000
916.380000, 1.103000
1074.300000, 1.103000
1092.600000, 1.103000
1164.300000, 1.103000
1231.540000, 1.103000
1397.690000, 1.103000
1660.400000, 1.103000
1711.520000, 1.103000

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:18


resfile_ms2quant_to_custom.cs

Example program converting ms_ms2quantitation to ms_customquantitation.

/*
##############################################################################
# file: resfile_ms2quant_to_custom.cs                                        #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_ms2quant_to_custom.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Collections.Generic;
using System.Text;
using System.IO;
using matrix_science.msparser;

namespace MsParserExamples
{
    class resfile_ms2quant_to_custom
    {
        public static int Main(string[] argv)
        {
            if (argv.Length < 4)
            {
                Console.Error.WriteLine("Usage: {0} <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>", Path.GetFileName((new resfile_ms2quant_to_custom()).GetType().Assembly.Location));
                Console.Error.WriteLine(@"The location of schema files should be e.g.
  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd
  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd
  ../html/xmlns/schema/unimod_2/unimod_2.xsd
if running from the Mascot cgi directory.");
                return 1;
            }

            string sQuantSchema1Filepath = argv[0], sQuantSchema2Filepath = argv[1], sUnimodSchemaFilepath = argv[2], sResultFile = argv[3];
            ms_mascotresfile resfile = new ms_mascotresfile(sResultFile);
            if (!resfile.isValid())
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return 1;
            }

            // print out any warnings, if any (we know these are only warnings,
            // because isValid() returned true
            dumpWarnings(resfile.getErrorHandler());
            resfile.clearAllErrors();

            resfile.setXMLschemaFilePath(ms_mascotresfile.XML_SCHEMA.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " +
                sQuantSchema2Filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + sQuantSchema1Filepath);
            resfile.setXMLschemaFilePath(ms_mascotresfile.XML_SCHEMA.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + sUnimodSchemaFilepath);

            ms_quant_method qmethod = new ms_quant_method();
            if (!resfile.getQuantitationMethod(qmethod))
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return 1;
            }

            ms_peptidesummary pepsum;
            {
                ms_datfile datfile = new ms_datfile();
                uint flags, flags2, minpeplen;
                int maxhits;
                double minprob, iisb;
                bool usePepsum;
                resfile.get_ms_mascotresults_params(datfile.getMascotOptions(), out flags, out minprob, out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);
                if (!usePepsum)
                {
                    Console.Error.WriteLine("Results file cannot be opened as a peptide summary");
                    return 1;
                }

                pepsum = new ms_peptidesummary(resfile, flags, minprob, maxhits, "", iisb, (int)minpeplen, "", flags2);

                if (!resfile.isValid())
                {
                    Console.Error.WriteLine(resfile.getLastErrorString());
                    return 1;
                }
                dumpWarnings(resfile.getErrorHandler());
                resfile.clearAllErrors();
            }

            // First quantitate the file using ms_ms2quantitation:
            ms_ms2quantitation ms2quant = new ms_ms2quantitation(pepsum, qmethod);
            if (!ms2quant.isValid())
            {
                Console.Error.WriteLine(ms2quant.getLastErrorString());
                return 1;
            }

            if (ms2quant.hasIntensityNormalisation())
            {
                ms2quant.normaliseIntensities();
            }
            else if (ms2quant.hasPeptideRatioNormalisation())
            {
                ms2quant.normalisePeptideRatios();
            }

            dumpWarnings(ms2quant.getErrorHandler());
            ms2quant.clearAllErrors();

            // Then import the data into ms_customquantitation:
            ms_customquantitation customquant = new ms_customquantitation(ms2quant);
            if (!customquant.isValid())
            {
                Console.Error.WriteLine(customquant.getLastErrorString());
                return 1;
            }
            dumpWarnings(customquant.getErrorHandler());
            customquant.clearAllErrors();

            // Refresh the quantitation method object, incase customquant altered
            // some of the parameters during conversion
            qmethod = customquant.getQuantitationMethod();

            // Now we can inspect peptide and protein data in customquant
            // But first, dump the quantitation method parameters to see what we have:
            {
                List<string> comps = new List<string>();
                for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
                {
                    comps.Add(qmethod.getComponentByNumber(i).getName());
                }
                Console.WriteLine("Components: {0}", string.Join(", ", comps));
            }

            List<string> ratioNames = new List<string>();
            for(int i = 0; i < qmethod.getNumberOfReportRatios(); i++) {
                ratioNames.Add(qmethod.getReportRatioByNumber(i).getName());
            }
            Console.WriteLine("Report ratios: [{0}]", string.Join(", ", ratioNames));

            Console.WriteLine("Protein ratio type = {0}", qmethod.getProteinRatioType());
            Console.WriteLine("Min. number of peptides = {0}", qmethod.getMinNumPeptides());
            if(qmethod.haveQuality()) {
                ms_quant_quality q = qmethod.getQuality();
                Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
                Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
                Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
            } else {
                Console.WriteLine("Quality: no restrictions");
            }

            if (qmethod.haveNormalisation())
            {
                ms_quant_normalisation _n = qmethod.getNormalisation();
                Console.WriteLine("Normalisation = {0}", _n.getMethod());

                if (_n.haveProteins())
                {
                    ms_quant_normalisation_proteins _p = _n.getProteins();
                    StringBuilder sbJoin = new StringBuilder();
                    for (int i = 0; i < _p.getNumberOfProteins(); i++)
                    {
                        if (i > 0) sbJoin.Append(", ");
                        sbJoin.Append(_p.getProtein(i).getAccession());
                    }
                    Console.WriteLine(" - Accessions = {0}", sbJoin);
                }

                if (_n.havePeptides())
                {
                    ms_quant_normalisation_peptides _p = _n.getPeptides();
                    StringBuilder sbJoin = new StringBuilder();
                    for (int i = 0; i < _p.getNumberOfPeptides(); i++)
                    {
                        if (i > 0) sbJoin.Append(", ");
                        sbJoin.Append(_p.getPeptide(i).getSequence());
                    }
                    Console.WriteLine(" - Sequences = {0}", sbJoin);
                }

                double[] intensityComponentBases = new double[qmethod.getNumberOfComponents()];
                for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
                {
                    intensityComponentBases[i] = ms2quant.getIntensityNormalisationBase(qmethod.getComponentByNumber(i).getName());
                }
                double[] ratioComponentBases = new double[ratioNames.Count];
                for (int i = 0; i < ratioComponentBases.Length; i++)
                {
                    ratioComponentBases[i] = ms2quant.getPeptideRatioNormalisationBase(ratioNames[i]);
                }

                Console.WriteLine("Intensity normalisation constants: [{0}]", string.Join(", ", intensityComponentBases));
                Console.WriteLine("Ratio normalisation constants: [{0}]", string.Join(", ", ratioComponentBases));
            }
            else
            {
                Console.WriteLine("Normalisation: none");
            }

            if (qmethod.haveOutliers())
            {
                Console.WriteLine("Outliers = {0}", qmethod.getOutliers().getMethod());
            }
            else
            {
                Console.WriteLine("Outliers: none");
            }
            Console.WriteLine();

            //Collect the proteins we're interested in
            List<ms_protein> proteins = new List<ms_protein>();
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                proteins.Add(pepsum.getHit(i));
                int j = 0;
                ms_protein protein;
                while ((protein = pepsum.getNextFamilyProtein(i, ++j)) != null)
                {
                    proteins.Add(protein);
                }
            }

            foreach (ms_protein protein in proteins)
            {
                Console.WriteLine("{0}::{1}", protein.getDB(), protein.getAccession());

                foreach (string rationame in ratioNames)
                {
                    ms_protein_quant_ratio ratio = ms2quant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame);
                    if (ratio.isMissing())
                    {
                        Console.WriteLine("{0}: ---", rationame.PadLeft(10));
                    }
                    else
                    {
                        Console.WriteLine("{0} = {1}, stderr = {2}, n = {3} normal-p = {4}, hypo-p = {5}",
                                rationame, ratio.getValue(), ratio.getStandardError(),
                                ratio.getSampleSize(), ratio.getNormalityPvalue(),
                                ratio.getHypothesisPvalue()
                            );
                    }
                    ratio.Dispose();
                    ratio = null;
                }
                Console.WriteLine();

                StringBuilder sbHeader = new StringBuilder();
                sbHeader.Append("Peptide".PadRight(11));
                foreach (string rationame in ratioNames)
                {
                    sbHeader.Append(" ").Append(rationame.PadRight(9));
                }
                Console.WriteLine(sbHeader);

                for (int i = 1; i <= protein.getNumPeptides(); i++)
                {
                    if (protein.getPeptideDuplicate(i) == ms_protein.DUPLICATE.DUPE_DuplicateSameQuery) continue;
                    int q = protein.getPeptideQuery(i), p = protein.getPeptideP(i);
                    ms_peptide peptide = pepsum.getPeptide(q, p);
                    if (peptide == null) continue;
                    List<string> aValues = new List<string>();
                    foreach (string rationame in ratioNames)
                    {
                        ms_peptide_quant_ratio ratio = ms2quant.getPeptideRatio(new ms_peptide_quant_key(q, p), rationame);
                        if (ratio.isMissing())
                        {
                            aValues.Add("---".PadRight(9));
                            continue;
                        }
                        if (ratio.isInfinite())
                        {
                            aValues.Add("###".PadRight(9));
                        }
                        else
                        {
                            string sValue = ratio.getValue().ToString("0.####").PadRight(9);
                            aValues.Add(sValue);
                        }
                    }
                    Console.WriteLine("{0}  {1}", string.Format("q{0}_p{1}", q, p).PadRight(11), string.Join(" ", aValues));
                }
                Console.WriteLine();
            }

            pepsum.getNumberOfHits();
            resfile._params();

            return 0;
        }

        private static void dumpWarnings(ms_errs ms_errs)
        {
            for (int i = 1; i <= ms_errs.getNumberOfErrors(); i++)
            {
                Console.Error.WriteLine("Warning: {0}", ms_errs.getErrorString(i));
            }
        }
    }
}

/*
resfile_ms2quant_to_custom.exe c:\inetpub\mascot\html\xmlns\schema\quantitation_1\quantitation_1.xsd c:\inetpub\mascot\html\xmlns\schema\quantitation_2\quantitation_2.xsd c:\inetpub\mascot\html\xmlns\schema\unimod_2\unimod_2.xsd c:\inetpub\mascot\data\F981133.dat

Will give the following output:

Warning: Protein ratio type weighted is only implemented in Reporter (current protocol is multiplex); resetting to median
Components: light, heavy
Report ratios: [Heavy/Light]
Protein ratio type = median
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto

1::K2C1_PANTR
Heavy/Light = 0.0579803721548197, stderr = 1.43947598358519, n = 5 normal-p = 0.636188020087278, hypo-p = 0.0014453988365255

Peptide     Heavy/Light
q18_p1       ---
q28_p1       0
q33_p2       0.153
q38_p1       0.0406
q39_p1       0.0309
q40_p1       0.1156
q55_p1       0.058

1::TRYP_PIG
Heavy/Light = 0.0953455094336426, stderr = 1.24484972786916, n = 10 normal-p = 0.325749316021252, hypo-p = 1.98308193710695E-06

Peptide     Heavy/Light
q1_p1        0
q2_p1        ---
q3_p1        0.1477
q9_p1        0
q72_p1       0.0829
q73_p1       0.0843
q74_p1       0.059
q75_p1       0.0552
q76_p1       0.0936
q77_p1       0.3288
q78_p1       0.2642
q81_p1       ---
q82_p1       0.1249
q90_p1       ---
q91_p1       0.0972

1::IGG2B_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q12_p1       0
q57_p1       ---
q58_p1       ---
q62_p1       -0.0007
q66_p1       -0.0008

1::ALBU_BOVIN
Heavy/Light = 0.0213058637909053, stderr = 1.21840219076313, n = 2 normal-p = -1, hypo-p = 0.0326462021178481

Peptide     Heavy/Light
q16_p1       ---
q30_p1       0.0175
q46_p1       0.026
q49_p1       -0.0006
q50_p1       ---

1::ENPL_MOUSE
Heavy/Light = 0.826726169499555, stderr = 1.47145311768354, n = 3 normal-p = 0.429488582555117, hypo-p = 0.671039840711699

Peptide     Heavy/Light
q4_p1        ---
q19_p1       ---
q20_p1       ---
q24_p2       0.3551
q26_p2       1.0692
q41_p1       0.8267
q42_p1       ---

1::NUCL_MOUSE
Heavy/Light = 1.32117663975823, stderr = 1.26401425891289, n = 3 normal-p = 0.980416559320101, hypo-p = 0.356540636322033

Peptide     Heavy/Light
q5_p1        ---
q6_p1        ---
q7_p1        ---
q8_p1        ---
q44_p1       ---
q45_p1       0.937
q92_p1       1.8861
q93_p1       1.3212

1::EPHB2_HUMAN
Heavy/Light = 10.9654930264722, stderr = 1.03789418103362, n = 2 normal-p = -1,hypo-p = 0.00988679141070892

Peptide     Heavy/Light
q13_p1       10.5651
q21_p1       ---
q53_p1       11.381
q88_p1       ---

1::K2C1_RAT
Heavy/Light = 0.0405615762807822, stderr = 1.59441776859148, n = 3 normal-p = 0.374888347489863, hypo-p = 0.0205371306366633

Peptide     Heavy/Light
q33_p4       ---
q38_p1       0.0406
q39_p1       0.0309
q40_p1       0.1156

1::K2C75_BOVIN
Heavy/Light: ---

Peptide     Heavy/Light
q28_p1       0
q38_p4       ---
q40_p6       ---

1::HNRPU_HUMAN
Heavy/Light = 0.870877403713838, stderr = 1.12071669533565, n = 2 normal-p = -1, hypo-p = 0.438890343357515

Peptide     Heavy/Light
q32_p1       ---
q34_p1       ---
q51_p1       0.976
q52_p1       0.7771

1::SFPQ_HUMAN
Heavy/Light = 0.890580462682766, stderr = 1.58916835083167, n = 3 normal-p = 0.968098028626276, hypo-p = 0.825807022031107

Peptide     Heavy/Light
q14_p1       0.8906
q15_p1       ---
q22_p1       ---
q69_p1       0.4372
q70_p1       1.7429

1::CAPR1_MOUSE
Heavy/Light = 1.19967671408572, stderr = 1.06348879302472, n = 3 normal-p = 0.901608333526897, hypo-p = 0.0978334823884838

Peptide     Heavy/Light
q23_p1       1.0855
q36_p1       1.3043
q37_p1       1.1997

1::K2C1B_HUMAN
Heavy/Light = 0.0684746549583752, stderr = 1.68816553095394, n = 2 normal-p = -1, hypo-p = 0.122783146524372

Peptide     Heavy/Light
q18_p2       ---
q38_p1       0.0406
q40_p1       0.1156
q53_p3       ---

1::ENPL_ARATH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351

Peptide     Heavy/Light
q24_p2       0.3551
q26_p2       1.0692
q41_p2       ---
q42_p10      ---
q67_p10      ---

1::VIME_CRIGR
Heavy/Light: ---

Peptide     Heavy/Light
q17_p1       0.4569
q35_p1       ---

1::BCAR1_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q10_p1       ---
q11_p1       ---
q63_p1       1.025

1::HTPG_ALKEH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351

Peptide     Heavy/Light
q24_p1       0.3551
q26_p1       1.0692
q67_p9       ---

1::FAK1_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q29_p1       0.4906

1::HTPG_BDEBA
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351

Peptide     Heavy/Light
q24_p3       0.3551
q26_p3       1.0692

1::K2C8_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q33_p1       0.153

1::TRY1_RAT
Heavy/Light: ---

Peptide     Heavy/Light
q72_p10      ---
q73_p2       ---
q74_p2       0.2836
q75_p2       ---
q76_p2       ---
q78_p2       ---
q81_p4       ---
q82_p2       ---

1::IGKC_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q47_p1       -0.0002
q48_p1       0
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_ms2quant_to_custom.pl

Example program converting ms_ms2quantitation to ms_customquantitation.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_ms2quant_to_custom.pl                                        #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_ms2quant_to_custom.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
use warnings;
##############################################################################

use msparser;

if (@ARGV != 4) {
    print STDERR "Usage: $0 <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>\n";
    print STDERR "The location of schema files should be e.g.\n";
    print STDERR "  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd\n";
    print STDERR "  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd\n";
    print STDERR "  ../html/xmlns/schema/unimod_2/unimod_2.xsd\n";
    print STDERR "if running from the Mascot cgi directory.\n";
    exit 1;
}

my $quant_schema1_filepath = $ARGV[0];
my $quant_schema2_filepath = $ARGV[1];
my $unimod_schema_filepath = $ARGV[2];

my $resfile = msparser::ms_mascotresfile->new($ARGV[3], 1);

if (not $resfile->isValid) {
    print STDERR $resfile->getLastErrorString(), "\n";
    exit 1;
}

# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):
dump_warnings($resfile->getErrorHandler());
$resfile->clearAllErrors();

my $qmethod = msparser::ms_quant_method->new();

$resfile->setXMLschemaFilePath(
    $msparser::ms_mascotresfile::XML_SCHEMA_QUANTITATION,
    "http://www.matrixscience.com/xmlns/schema/quantitation_2 $quant_schema2_filepath http://www.matrixscience.com/xmlns/schema/quantitation_1 $quant_schema1_filepath"
);

$resfile->setXMLschemaFilePath(
    $msparser::ms_mascotresfile::XML_SCHEMA_UNIMOD,
    "http://www.unimod.org/xmlns/schema/unimod_2 $unimod_schema_filepath",
);

my $qmethod = msparser::ms_quant_method->new();

if (not $resfile->getQuantitationMethod($qmethod)) {
    print STDERR $resfile->getLastErrorString(), "\n";
    exit 1;
}

my $pepsum;

do {
    my $datfile = msparser::ms_datfile->new();

    my (undef, $flags, $minprob, $maxhits, $iisb, $minpeplen, $use_pepsum, $flags2)
        = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions());

    if (not $use_pepsum) {
        print STDERR "Results file cannot be opened as a peptide summary\n";
        exit 1;
    }

    $pepsum = msparser::ms_peptidesummary->new(
        $resfile, $flags, $minprob, $maxhits, '', $iisb, $minpeplen, '', $flags2
    );

    if (not $resfile->isValid) {
        print STDERR $resfile->getLastErrorString, "\n";
        exit 1;
    }

    dump_warnings($resfile->getErrorHandler());
    $resfile->clearAllErrors();
};

# First quantitate the file using ms_ms2quantitation:

my $ms2quant = msparser::ms_ms2quantitation->new($pepsum, $qmethod);

if (not $ms2quant->isValid) {
    print STDERR $ms2quant->getLastErrorString(), "\n";
    exit 1;
}

if ($ms2quant->hasIntensityNormalisation()) {
    $ms2quant->normaliseIntensities();
} elsif ($ms2quant->hasPeptideRatioNormalisation()) {
    $ms2quant->normalisePeptideRatios();
}

dump_warnings($ms2quant->getErrorHandler());
$ms2quant->clearAllErrors();

# Then import the data into ms_customquantitation:

my $customquant = msparser::ms_customquantitation->new($ms2quant);

if (not $customquant->isValid) {
    print STDERR $customquant->getLastErrorString(), "\n";
    exit 1;
}

do {
    my $err = $customquant->getErrorHandler();

    # And print out related warnings, if any (we know these are only warnings,
    # because isValid() returned true earlier):
    for my $i (1 .. $err->getNumberOfErrors()) {
        print 'Warning: ', $err->getErrorString($i), "\n";
    }
};

$customquant->clearAllErrors();

# Refresh the quantitation method object, in case $customquant altered
# some of the parameters during conversion:

$qmethod = $customquant->getQuantitationMethod();

# Now we can inspect peptide and protein data in $customquant.
# But first, dump quantitation method parameters to see what we have:

do {
    my @comps = ();

    for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
        my $comp = $qmethod->getComponentByNumber($i);
        $comps[$i] = $comp->getName();
    }

    printf "Components: [%s]\n", join(', ', @comps);
};

my @rationames = ();

for my $i (0 .. $qmethod->getNumberOfReportRatios()-1) {
    push @rationames, $qmethod->getReportRatioByNumber($i)->getName();
}

printf "Report ratios: [%s]\n", join(', ', @rationames);

printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();

if ($qmethod->haveQuality()) {
    my $q = $qmethod->getQuality();
    printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
    printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
    printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
} else {
    printf "Quality: no restrictions\n";
}

if ($qmethod->haveNormalisation()) {
    my $q = $qmethod->getNormalisation();
    printf "Normalisation = %s\n", $q->getMethod();

    if ($q->haveProteins()) {
        my $p = $q->getProteins();
        printf " - Accessions = %s\n", join(', ',
            map { $p->getProtein($_)->getAccession() } 0 .. $p->getNumberOfProteins()-1
        );
    }

    if ($q->havePeptides()) {
        my $p = $q->getPeptides();
        printf "  - Sequences = %s\n", join(', ',
            map { $p->getPeptide($_)->getSequence() } 0 .. $p->getNumberOfPeptides()-1
        );
    }

    my @component_bases = ();

    for (1 .. $qmethod->getNumberOfComponents()) {
        my $base = $ms2quant->getIntensityNormalisationBase($qmethod->getComponentByNumber($_-1)->getName());
        push @component_bases, $base;
    }

    printf "Intensity normalisation constants: [%s]\n", join(', ', @component_bases);
    printf "Ratio normalisation constants: [%s]\n", join(', ',
        map { $ms2quant->getNormalisationBase($_) } @rationames
    );
} else {
    printf "Normalisation: none\n";
}

if ($qmethod->haveOutliers()) {
    my $q = $qmethod->getOutliers();
    printf "Outliers = %s\n", $q->getMethod();
} else {
    printf "Outliers: none\n";
}

print "\n";

# Collect proteins we're interested in:
my @proteins = ();

for my $i (1 .. $pepsum->getNumberOfHits()) {
    my $hit = $pepsum->getHit($i);
    push @proteins, $hit;

    my $j = 0;
    while (my $protein = $pepsum->getNextFamilyProtein($i, ++$j)) {
        push @proteins, $protein;
    }
}

for my $protein (@proteins) {
    printf "%d::%s:\n", $protein->getDB(), $protein->getAccession();

    for (@rationames) {
        my $ratio = $customquant->getProteinRatio($protein->getAccession(), $protein->getDB(), $_);

        if ($ratio->isMissing()) {
            printf "%10s: ---\n", $_;
        } else {
            printf "%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
                $_, $ratio->getValue(), $ratio->getStandardError(),
                $ratio->getSampleSize(), $ratio->getNormalityPvalue(),
                $ratio->getHypothesisPvalue();
        }
    }

    print "\n";
    print join(' ', map { sprintf("%10s", $_) } 'Peptide', @rationames), "\n";

    for my $i (1 .. $protein->getNumPeptides()) {
        next if $protein->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_DuplicateSameQuery;

        my $q = $protein->getPeptideQuery($i);
        my $p = $protein->getPeptideP($i);

        my $peptide = $pepsum->getPeptide($q, $p);

        next if not $peptide;

        my @values = ();

        for (@rationames) {
            # Note that the q,p arguments to ms_peptide_quant_key must be
            # integers. Otherwise the wrong constructor is chosen. Here they
            # are integers, as they are return values from Parser functions
            # that return ints.
            my $ratio = $customquant->getPeptideRatio(msparser::ms_peptide_quant_key->new($q, $p), $_);

            if ($ratio->isMissing()) {
                push @values, sprintf("%10s", '---');
                next;
            }

            if ($ratio->isInfinite()) {
                push @values, sprintf("%10s", '###');
            } else {
                push @values, sprintf("%10g", $ratio->getValue());
            }
        }

        printf "%10s %s\n", sprintf("q%d_p%d", $q, $p), join(' ', @values);
    }

    print "\n";
}

sub dump_warnings {
    my ($err) = @_;

    for my $i (1 .. $err->getNumberOfErrors()) {
        print 'Warning: ', $err->getErrorString($i), "\n";
    }
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_ms2quant_to_custom.py

Example program converting ms_ms2quantitation to ms_customquantitation.

#!/usr/bin/python
##############################################################################
# file: resfile_ms2quant_to_custom.py                                        #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/resfile_ms2quant_to_custom.py $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################

import msparser
import sys

# If no arguments supplied, print help and exit

if len(sys.argv) != 5:
    print("Usage: %s <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>" % sys.argv[0])
    print("The location of schema files should be e.g.")
    print("  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd")
    print("  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd")
    print("  ../html/xmlns/schema/unimod_2/unimod_2.xsd")
    print("if running from the Mascot cgi directory.")
    sys.exit(1)

quant_schema1_filepath = sys.argv[1]
quant_schema2_filepath = sys.argv[2]
unimod_schema_filepath = sys.argv[3]

resfile = msparser.ms_mascotresfile(sys.argv[4], 1)

if not resfile.isValid():
    print(resfile.getLastErrorString())
    sys.exit(1)

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

def dump_warnings(err):

    for i in ms_range(1, err.getNumberOfErrors()):
        print('Warning: %s' %(err.getErrorString(i)))

# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):

dump_warnings(resfile.getErrorHandler())
resfile.clearAllErrors()

resfile.setXMLschemaFilePath(msparser.ms_mascotresfile.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " + quant_schema2_filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + quant_schema1_filepath)
resfile.setXMLschemaFilePath(msparser.ms_mascotresfile.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + unimod_schema_filepath)

qmethod = msparser.ms_quant_method()

if not resfile.getQuantitationMethod(qmethod):
    print(resfile.getLastErrorString())
    sys.exit(1)

datfile = msparser.ms_datfile()
undef, flags, minprob, maxhits, iisb, minpeplen, use_pepsum, flags2 = resfile.get_ms_mascotresults_params(datfile.getMascotOptions())

if not use_pepsum:
    print("Results File cannot be opened as a peptide summary")
    sys.exit(1)

pepsum = msparser.ms_peptidesummary(resfile, flags, minprob, maxhits, '', iisb, minpeplen, '', flags2)

if not resfile.isValid():
    print(resfile.getLastErrorString)
    sys.exit(1)

dump_warnings(resfile.getErrorHandler())
resfile.clearAllErrors()

# Quantitate the file using ms_ms2quantitation:

ms2quant = msparser.ms_ms2quantitation(pepsum, qmethod)

if not ms2quant.isValid():
    print(ms2quant.getLastErrorString())
    sys.exit(1)

if ms2quant.hasIntensityNormalisation():
    ms2quant.normaliseIntensities()
elif ms2quant.hasPeptideRatioNormalisation():
    ms2quant.normalisePeptideRatios()

dump_warnings(ms2quant.getErrorHandler())
ms2quant.clearAllErrors()

# Then import the data into ms_customquantitation:

customquant = msparser.ms_customquantitation(ms2quant)

if not customquant.isValid():
    print(customquant.getLastErrorString())
    sys.exit(1)

err = customquant.getErrorHandler()
# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):

for i in range(1, err.getNumberOfErrors()):
    print("Warning: %s" %(err.getErrorString(i)))

customquant.clearAllErrors()

# Refresh the quantitation method object, in case customquant altered
# some of the parameters during conversion:

qmethod = customquant.getQuantitationMethod()

# Now we can inspect peptide and protein data in customquant.
# But first, dump quantitation method parameters to see what we have:

comps = []

for i in ms_range(0, qmethod.getNumberOfComponents()-1):
    comp = qmethod.getComponentByNumber(i)
    comps.append(comp.getName())

print("Components: %s" %(comps))

rationames = []

for i in ms_range(0, qmethod.getNumberOfReportRatios()-1):
    ratioByNumber = qmethod.getReportRatioByNumber(i)
    rationames.append(ratioByNumber.getName())

print("Report Ratios: %s" %(rationames))
print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
print("Min. number of peptides = %d" %(qmethod.getMinNumPeptides()))

if qmethod.haveQuality():
    q = qmethod.getQuality()
    print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
    print("Quality: pep. threshold type = %s" %(q.getPepThresholdType()))
    print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
else:
    print("Quality: no restrictions")

if qmethod.haveNormalisation():
    q = qmethod.getNormalisation()
    print("Normalisation = %s" %(q.getMethod()))
    if q.haveProteins():
        p = q.getProteins()
        print("getProteins")
        for i in ms_range(0, p.getNumberOfProteins()-1):
            proteins = p.getProteins(i)
            protein = proteins.getAccession()
            print(" - Accessions = %s" %(protein))

    if q.havePeptides():
        p = q.getPeptides()
        peptides = p.getPeptides()
        for i in ms_range(0, p.getNumberOfPeptides()-1):
            peptides = p.getPeptides(i)
            peptide = peptides.getSequence()
            print(" - Sequences = %s" %(peptide))

    component_bases = []
    for i in ms_range(0, qmethod.getNumberOfComponents()-1):
        gcbn = qmethod.getComponentByNumber(i)
        base = ms2quant.getIntensityNormalisationBase(gcbn.getName())
        component_bases.append(base)

    print("Intensity normalisation constants: %s" %(component_bases))
    print("Ration normalisation constants: %s" %(rationames))

else:
    print("Normalisation: none")

if qmethod.haveOutliers():
    q = qmethod.getOutliers()
    print("Outliers = %s" %(q.getMethod()))
else:
    print("Outliers: none")

print("\n")

# Collect proteins we're interested in:

proteins = []

for i in ms_range(1, pepsum.getNumberOfHits()):
    hit = pepsum.getHit(i)
    proteins.append(hit)
    j = 0
    protein = pepsum.getNextFamilyProtein(i, j)
    while protein !=None:
        proteins.append(protein)
        j += 1

for protein in proteins:
    print("%d::%s:" %(protein.getDB(), protein.getAccession()))

    for rationame in rationames:
        ratio = customquant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame)

        if ratio.isMissing():
            print("%10s: ---" %(rationame))
        else:
            print("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hyp-p = %6g" %(rationame, ratio.getValue(), ratio.getStandardError_only(), ratio.getSampleSize(), ratio.getNormalityPvalue_only(), ratio.getHypothesisPvalue_only()))

    print("  %10s %s" %('Peptide:', rationame))

    for i in ms_range(1, protein.getNumPeptides()):
        if protein.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery:
            continue
        q = protein.getPeptideQuery(i)
        p = protein.getPeptideP(i)

        peptide = pepsum.getPeptide(q, p)

        if not peptide:
            continue

        values = ''
        for rationame in rationames:
            # Note that the q,p arguments to ms_peptide_quant_key must be
            # integers. Otherwise the wrong constructor is chosen. Here they
            # are integers, as they are return values from Parser functions
            # that return ints.
            quantKey = msparser.ms_peptide_quant_key(q, p)
            ratio = ms2quant.getPeptideRatio(quantKey, rationame)

            if ratio.isMissing():
                values = "---"
                continue

            if ratio.isInfinite():
                values = "###"
            else:
                values = ratio.getValue()

        print("    %-9s  %-10s" %("q%d_p%d" %(q, p), str(values)))

    print("\n")
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_ms2quantitation.cs

Example program extracting peptide ratios from a Reporter or Multiplex file.

/*
##############################################################################
# file: resfile_ms2quantitaion.cs                                            #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_ms2quantitation.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Collections.Generic;
using System.IO;
using System.Text;
using matrix_science.msparser;

namespace MsParserExamples
{
    class resfile_ms2quantitation
    {
        public static void Main(string[] argv)
        {
            if (argv.Length < 4)
            {
                Console.Error.WriteLine("Usage: {0} <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>", Path.GetFileName((new resfile_ms2quantitation()).GetType().Assembly.Location));
                Console.Error.WriteLine(@"The location of schema files should be e.g.
  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd
  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd
  ../html/xmlns/schema/unimod_2/unimod_2.xsd
if running from the Mascot cgi directory.");
                return;
            }

            string sQuantSchema1Filepath = argv[0], sQuantSchema2Filepath = argv[1], sUnimodSchemaFilepath = argv[2], sResultFile = argv[3];

            ms_mascotresfile resfile = new ms_mascotresfile(sResultFile, 0);
            if (!resfile.isValid())
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return;
            }

            resfile.setXMLschemaFilePath(ms_mascotresfile.XML_SCHEMA.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " +
                sQuantSchema2Filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + sQuantSchema1Filepath);
            resfile.setXMLschemaFilePath(ms_mascotresfile.XML_SCHEMA.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + sUnimodSchemaFilepath);

            ms_quant_method qMethod = new ms_quant_method();
            if (!resfile.getQuantitationMethod(qMethod))
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return;
            }

            // calls to generate ms_peptidesummary object are not important for this example,
            // see loadPeptideSummary at the end of the file for details
            ms_peptidesummary pepsum;
            if (!loadPeptideSummary(resfile, out pepsum))
            {
                return;
            }
            // Quantitation the file using ms_ms2quantitation:
            ms_ms2quantitation ms2quant = new ms_ms2quantitation(pepsum, qMethod);

            if (!ms2quant.isValid())
            {
                Console.Error.WriteLine(ms2quant.getLastErrorString());
                return;
            }

            if (ms2quant.hasIntensityNormalisation())
            {
                ms2quant.normaliseIntensities();
            }
            else if (ms2quant.hasPeptideRatioNormalisation())
            {
                ms2quant.normalisePeptideRatios();
            }

            // Update the quantitation method in case ms_ms2quantitation changed any
            // of the parameters:
            qMethod = ms2quant.getQuantitationMethod();

            dumpWarnings(ms2quant.getErrorHandler());
            ms2quant.clearAllErrors();

            // Now we can inspect protein and peptide data in ms2quant
            // But first, dump the quantitation method parameters we have:
            {
                string[] comps = new string[qMethod.getNumberOfComponents()];
                for (int i = 0; i < comps.Length; i++)
                {
                    comps[i] = qMethod.getComponentByNumber(i).getName();
                }
                Console.WriteLine("Components: [{0}]", string.Join(", ", comps));
            }

            string[] ratioNames = new string[qMethod.getNumberOfReportRatios()];
            for (int i = 0; i < ratioNames.Length; i++)
            {
                ratioNames[i] = qMethod.getReportRatioByNumber(i).getName();
            }
            Console.WriteLine("Report ratios [{0}]", string.Join(", ", ratioNames));

            Console.WriteLine("Report ratio type = {0}", qMethod.getProteinRatioType());
            Console.WriteLine("Min. number of peptides = {0}", qMethod.getMinNumPeptides());

            if (qMethod.haveQuality())
            {
                ms_quant_quality q = qMethod.getQuality();
                Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
                Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
                Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
            }
            else
            {
                Console.WriteLine("Quality: no restrictions");
            }

            if (qMethod.haveNormalisation())
            {
                ms_quant_normalisation _n = qMethod.getNormalisation();
                Console.WriteLine("Normalisation = {0}", _n.getMethod());

                if (_n.haveProteins())
                {
                    ms_quant_normalisation_proteins _p = _n.getProteins();
                    StringBuilder sbJoin = new StringBuilder();
                    for (int i = 0; i < _p.getNumberOfProteins(); i++)
                    {
                        if (i > 0) sbJoin.Append(", ");
                        sbJoin.Append(_p.getProtein(i).getAccession());
                    }
                    Console.WriteLine(" - Accessions = {0}", sbJoin);
                }

                if (_n.havePeptides())
                {
                    ms_quant_normalisation_peptides _p = _n.getPeptides();
                    StringBuilder sbJoin = new StringBuilder();
                    for (int i = 0; i < _p.getNumberOfPeptides(); i++)
                    {
                        if (i > 0) sbJoin.Append(", ");
                        sbJoin.Append(_p.getPeptide(i).getSequence());
                    }
                    Console.WriteLine(" - Sequences = {0}", sbJoin);
                }

                double[] intensityComponentBases = new double[qMethod.getNumberOfComponents()];
                for (int i = 0; i < qMethod.getNumberOfComponents(); i++)
                {
                    intensityComponentBases[i] = ms2quant.getIntensityNormalisationBase(qMethod.getComponentByNumber(i).getName());
                }
                double[] ratioComponentBases = new double[ratioNames.Length];
                for (int i = 0; i < ratioComponentBases.Length; i++)
                {
                    ratioComponentBases[i] = ms2quant.getPeptideRatioNormalisationBase(ratioNames[i]);
                }

                Console.WriteLine("Intensity normalisation constants: [{0}]", string.Join(", ", intensityComponentBases));
                Console.WriteLine("Ratio normalisation constants: [{0}]", string.Join(", ", ratioComponentBases));
            }
            else
            {
                Console.WriteLine("Normalisation: none");
            }

            if (qMethod.haveOutliers())
            {
                Console.WriteLine("Outliers = {0}", qMethod.getOutliers().getMethod());
            }
            else
            {
                Console.WriteLine("Outliers: none");
            }
            Console.WriteLine();

            // Collect the proteins we're interested in
            List<ms_protein> proteins = new List<ms_protein>();
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                proteins.Add(pepsum.getHit(i));
                int j = 0;
                ms_protein protein;
                while ((protein = pepsum.getNextFamilyProtein(i, ++j)) != null)
                {
                    proteins.Add(protein);
                }
            }

            foreach (ms_protein protein in proteins)
            {
                Console.WriteLine("{0}::{1}", protein.getDB(), protein.getAccession());

                foreach (string rationame in ratioNames)
                {
                    ms_protein_quant_ratio ratio = ms2quant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame);
                    if (ratio.isMissing())
                    {
                        Console.WriteLine("{0}: ---", rationame.PadLeft(10));
                    }
                    else
                    {
                        Console.WriteLine("{0} = {1}, stderr = {2}, n = {3} normal-p = {4}, hypo-p = {5}",
                                rationame, ratio.getValue(), ratio.getStandardError(),
                                ratio.getSampleSize(), ratio.getNormalityPvalue(),
                                ratio.getHypothesisPvalue()
                            );
                    }
                    ratio.Dispose();
                    ratio = null;
                }
                Console.WriteLine();

                StringBuilder sbHeader = new StringBuilder();
                sbHeader.Append("Peptide".PadRight(11));
                foreach (string rationame in ratioNames)
                {
                    sbHeader.Append(" ").Append(rationame.PadRight(9));
                }
                Console.WriteLine(sbHeader);

                for (int i = 1; i <= protein.getNumPeptides(); i++)
                {
                    if (protein.getPeptideDuplicate(i) == ms_protein.DUPLICATE.DUPE_DuplicateSameQuery) continue;
                    int q = protein.getPeptideQuery(i), p = protein.getPeptideP(i);
                    ms_peptide peptide = pepsum.getPeptide(q, p);
                    if (peptide == null) continue;
                    List<string> aValues = new List<string>();
                    foreach (string rationame in ratioNames)
                    {
                        ms_peptide_quant_ratio ratio = ms2quant.getPeptideRatio(new ms_peptide_quant_key(q, p), rationame);
                        if (ratio.isMissing())
                        {
                            aValues.Add("---".PadRight(9));
                            continue;
                        }
                        if (ratio.isInfinite())
                        {
                            aValues.Add("###".PadRight(9));
                        }
                        else
                        {
                            string sValue = ratio.getValue().ToString("0.####").PadRight(9);
                            aValues.Add(sValue);
                        }
                    }
                    Console.WriteLine("{0}  {1}", string.Format("q{0}_p{1}", q, p).PadRight(11), string.Join(" ", aValues));
                }
                Console.WriteLine();
            }

            pepsum.getNumberOfHits();
            resfile._params();

        }

        private static void dumpWarnings(ms_errs ms_errs)
        {
            for (int i = 0; i < ms_errs.getNumberOfErrors(); i++)
            {
                Console.WriteLine("Warning: {0}", ms_errs.getErrorString(i));
            }
        }

        private static bool loadPeptideSummary(ms_mascotresfile resfile, out ms_peptidesummary pepsum)
        {
            // set pepsum to null so we can return out with false if the method fails
            pepsum = null;

            ms_mascotoptions opts = new ms_mascotoptions();

            uint flags, flags2, minpeplen;
            int maxhits;
            double minprob, iisb;
            bool usePepsum;
            resfile.get_ms_mascotresults_params(opts, out flags, out minprob, out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);

            if (!usePepsum)
            {
                Console.Error.WriteLine("Results file cannot be opened as a peptide summary");
                return false;
            }

            pepsum = new ms_peptidesummary(resfile, flags, minprob, maxhits, "", iisb, (int)minpeplen, "", flags2);

            if (!resfile.isValid())
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return false;
            }
            return true;
        }
    }
}

/*
 resfile_ms2quantitation.exe c:\inetpub\mascot\html\xmlns\schema\quantitation_1\quantitation_1.xsd c:\inetpub\mascot\html\xmlns\schema\quantitation_2\quantitation_2.xsd c:\inetpub\mascot\html\xmlns\schema\unimod_2\unimod_2.xsd c:\inetpub\mascot\data\F981133.dat

Will give the following output:

Warning:
Components: [light, heavy]
Report ratios [Heavy/Light]
Report ratio type = median
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto

1::K2C1_PANTR
Heavy/Light = 0.0579803721548197, stderr = 1.43947598358519, n = 5 normal-p = 0.636188020087278, hypo-p = 0.0014453988365255

Peptide     Heavy/Light
q18_p1       ---
q28_p1       0
q33_p2       0.153
q38_p1       0.0406
q39_p1       0.0309
q40_p1       0.1156
q55_p1       0.058

1::TRYP_PIG
Heavy/Light = 0.0953455094336426, stderr = 1.24484972786916, n = 10 normal-p = 0.325749316021252, hypo-p = 1.98308193710695E-06

Peptide     Heavy/Light
q1_p1        0
q2_p1        ---
q3_p1        0.1477
q9_p1        0
q72_p1       0.0829
q73_p1       0.0843
q74_p1       0.059
q75_p1       0.0552
q76_p1       0.0936
q77_p1       0.3288
q78_p1       0.2642
q81_p1       ---
q82_p1       0.1249
q90_p1       ---
q91_p1       0.0972

1::IGG2B_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q12_p1       0
q57_p1       ---
q58_p1       ---
q62_p1       -0.0007
q66_p1       -0.0008

1::ALBU_BOVIN
Heavy/Light = 0.0213058637909053, stderr = 1.21840219076313, n = 2 normal-p = -1, hypo-p = 0.0326462021178481

Peptide     Heavy/Light
q16_p1       ---
q30_p1       0.0175
q46_p1       0.026
q49_p1       -0.0006
q50_p1       ---

1::ENPL_MOUSE
Heavy/Light = 0.826726169499555, stderr = 1.47145311768354, n = 3 normal-p = 0.429488582555117, hypo-p = 0.671039840711699

Peptide     Heavy/Light
q4_p1        ---
q19_p1       ---
q20_p1       ---
q24_p2       0.3551
q26_p2       1.0692
q41_p1       0.8267
q42_p1       ---

1::NUCL_MOUSE
Heavy/Light = 1.32117663975823, stderr = 1.26401425891289, n = 3 normal-p = 0.980416559320101, hypo-p = 0.356540636322033

Peptide     Heavy/Light
q5_p1        ---
q6_p1        ---
q7_p1        ---
q8_p1        ---
q44_p1       ---
q45_p1       0.937
q92_p1       1.8861
q93_p1       1.3212

1::EPHB2_HUMAN
Heavy/Light = 10.9654930264722, stderr = 1.03789418103362, n = 2 normal-p = -1,hypo-p = 0.00988679141070892

Peptide     Heavy/Light
q13_p1       10.5651
q21_p1       ---
q53_p1       11.381
q88_p1       ---

1::K2C1_RAT
Heavy/Light = 0.0405615762807822, stderr = 1.59441776859148, n = 3 normal-p = 0.374888347489863, hypo-p = 0.0205371306366633

Peptide     Heavy/Light
q33_p4       ---
q38_p1       0.0406
q39_p1       0.0309
q40_p1       0.1156

1::K2C75_BOVIN
Heavy/Light: ---

Peptide     Heavy/Light
q28_p1       0
q38_p4       ---
q40_p6       ---

1::HNRPU_HUMAN
Heavy/Light = 0.870877403713838, stderr = 1.12071669533565, n = 2 normal-p = -1, hypo-p = 0.438890343357515

Peptide     Heavy/Light
q32_p1       ---
q34_p1       ---
q51_p1       0.976
q52_p1       0.7771

1::SFPQ_HUMAN
Heavy/Light = 0.890580462682766, stderr = 1.58916835083167, n = 3 normal-p = 0.968098028626276, hypo-p = 0.825807022031107

Peptide     Heavy/Light
q14_p1       0.8906
q15_p1       ---
q22_p1       ---
q69_p1       0.4372
q70_p1       1.7429

1::CAPR1_MOUSE
Heavy/Light = 1.19967671408572, stderr = 1.06348879302472, n = 3 normal-p = 0.901608333526897, hypo-p = 0.0978334823884838

Peptide     Heavy/Light
q23_p1       1.0855
q36_p1       1.3043
q37_p1       1.1997

1::K2C1B_HUMAN
Heavy/Light = 0.0684746549583752, stderr = 1.68816553095394, n = 2 normal-p = -1, hypo-p = 0.122783146524372

Peptide     Heavy/Light
q18_p2       ---
q38_p1       0.0406
q40_p1       0.1156
q53_p3       ---

1::ENPL_ARATH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351

Peptide     Heavy/Light
q24_p2       0.3551
q26_p2       1.0692
q41_p2       ---
q42_p10      ---
q67_p10      ---

1::VIME_CRIGR
Heavy/Light: ---

Peptide     Heavy/Light
q17_p1       0.4569
q35_p1       ---

1::BCAR1_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q10_p1       ---
q11_p1       ---
q63_p1       1.025

1::HTPG_ALKEH
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351

Peptide     Heavy/Light
q24_p1       0.3551
q26_p1       1.0692
q67_p9       ---

1::FAK1_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q29_p1       0.4906

1::HTPG_BDEBA
Heavy/Light = 0.616183752030204, stderr = 1.73514843004814, n = 2 normal-p = -1, hypo-p = 0.541069995173351

Peptide     Heavy/Light
q24_p3       0.3551
q26_p3       1.0692

1::K2C8_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q33_p1       0.153

1::TRY1_RAT
Heavy/Light: ---

Peptide     Heavy/Light
q72_p10      ---
q73_p2       ---
q74_p2       0.2836
q75_p2       ---
q76_p2       ---
q78_p2       ---
q81_p4       ---
q82_p2       ---

1::IGKC_MOUSE
Heavy/Light: ---

Peptide     Heavy/Light
q47_p1       -0.0002
q48_p1       0
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_ms2quantitation.java

Example program extracting peptide ratios from a Reporter or Multiplex file.

/*
 * ##############################################################################
 * # file: resfile_ms2quantitation.java                                         #
 * # Mascot Parser toolkit example code                                         #
 * ##############################################################################
 * # COPYRIGHT NOTICE                                                           #
 * # Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
 * #                                                                            #
 * ##############################################################################
 *
 */

import java.util.ArrayList;
import java.util.Arrays;
import java.util.List;
import matrix_science.msparser.ms_peptide_quant_key;
import matrix_science.msparser.ms_mascotresfile;
import matrix_science.msparser.ms_quant_method;
import matrix_science.msparser.ms_mascotoptions;
import matrix_science.msparser.ms_peptidesummary;
import matrix_science.msparser.ms_ms2quantitation;
import matrix_science.msparser.ms_peptide;
import matrix_science.msparser.ms_peptide_quant_ratio;
import matrix_science.msparser.ms_protein;
import matrix_science.msparser.ms_protein_quant_ratio;
import matrix_science.msparser.ms_quant_normalisation;
import matrix_science.msparser.ms_quant_outliers;
import matrix_science.msparser.ms_quant_quality;

public class resfile_ms2quantitation {

    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String[] args) {
        if(args.length < 4) {
            System.err.println("Usage: <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>");
            System.err.println("The location of schema files should be e.g.");
            System.err.println("  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd");
            System.err.println("  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd");
            System.err.println("  ../html/xmlns/schema/unimod_2/unimod_2.xsd");
            System.err.println("if running from the Mascot cgi directory.");
            System.exit(1);
        }

        String sQuantSchema1Filepath = args[0];
        String sQuantSchema2Filepath = args[1];
        String sUnimodSchemaFilepath = args[2];

        ms_mascotresfile oResfile = new ms_mascotresfile(args[3],1);
        if(!oResfile.isValid()) {
            System.err.println(oResfile.getLastErrorString());
            System.exit(1);
        }

        oResfile.setXMLschemaFilePath(ms_mascotresfile.XML_SCHEMA_QUANTITATION,
                "http://www.matrixscience.com/xmlns/schema/quantitation_2 "+sQuantSchema2Filepath+" http://www.matrixscience.com/xmlns/schema/quantitation_1 "+sQuantSchema1Filepath);

        oResfile.setXMLschemaFilePath(ms_mascotresfile.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 "+sUnimodSchemaFilepath);

        ms_quant_method oQMethod = new ms_quant_method();

        if(!oResfile.getQuantitationMethod(oQMethod)) {
            System.err.println(oResfile.getLastErrorString());
            System.exit(1);
        }

        // See section 'Multiple return values in Perl, Java and Python' in ms_parser help
        long[] iFlags = {0};
        double[] dMinProb = {0};
        int[] iMaxHits = {0};
        double[] dIgnoreIonsBelow = {0};
        long[] iMinPepLen = {0};
        boolean[] bUsePepSum = {false};
        long[] iFlags2 = {0};
        ms_mascotoptions oOptions = new ms_mascotoptions();

        oResfile.get_ms_mascotresults_params(oOptions, iFlags, dMinProb, iMaxHits, dIgnoreIonsBelow, iMinPepLen, bUsePepSum, iFlags2);

        if(!bUsePepSum[0]) {
            System.err.println("Results file cannot be used to open as a peptide summary");
            System.exit(1);
        }

        ms_peptidesummary oPepsum = new ms_peptidesummary(oResfile, (int) iFlags[0], dMinProb[0], iMaxHits[0], "", dIgnoreIonsBelow[0], (int) iMinPepLen[0], "", (int) iFlags2[0]);
        if(!oResfile.isValid()) {
            System.err.println(oResfile.getLastErrorString());
            System.exit(1);
        }

        // Quantitate the file using ms_ms2quantitation:
        ms_ms2quantitation oMs2Quant = new ms_ms2quantitation(oPepsum, oQMethod);

        if(!oMs2Quant.isValid()) {
            System.err.println(oMs2Quant.getLastErrorString());
            System.exit(1);
        }

        // Now we can inspect protein and peptide data in oMs2Quant
        // But first, dump the quantitation method parameters to see what we have:

        String[] aComps = new String[oQMethod.getNumberOfComponents()];
        for(int i = 0; i < oQMethod.getNumberOfComponents(); i++) {
            aComps[i] = oQMethod.getComponentByNumber(i).getName();
        }
        System.out.printf("Components: %s\n", Arrays.toString(aComps));

        String[] aRationames = new String[oQMethod.getNumberOfReportRatios()];
        for(int i = 0; i < oQMethod.getNumberOfReportRatios(); i++) {
            aRationames[i] = oQMethod.getReportRatioByNumber(i).getName();
        }
        System.out.printf("Report ratios: %s\n", Arrays.toString(aRationames));

        System.out.printf("Protein ratio type = %s\n", oQMethod.getProteinRatioType());
        System.out.printf("Min. number of peptides = %d\n", oQMethod.getMinNumPeptides());

        if (oQMethod.haveQuality()) {
            ms_quant_quality oQuality = oQMethod.getQuality();
            System.out.printf("Quality: min. precursor charge = %s\n", oQuality.getMinPrecursorCharge());
            System.out.printf("Quality: pep. threshold type = %s\n", oQuality.getPepThresholdType());
            System.out.printf("Quality: pep. threshold value = %s\n", oQuality.getPepThresholdValue());
        } else {
            System.out.print("Quality: no restrictions\n");
        }

        if (oQMethod.haveNormalisation()) {
            ms_quant_normalisation oNormalisation = oQMethod.getNormalisation();
            System.out.printf("Normalisation = %s\n", oNormalisation.getMethod());
        } else {
            System.out.print("Normalisation: none\n");
        }

        if (oQMethod.haveOutliers()) {
            ms_quant_outliers oOutliers = oQMethod.getOutliers();
            System.out.printf("Outliers = %s\n", oOutliers.getMethod());
        } else {
            System.out.print("Outliers: none\n");
        }
        System.out.println();

        // collect proteins we're interested in
        List<ms_protein> aProteins = new ArrayList<ms_protein>();
        for(int i = 1; i <= oPepsum.getNumberOfHits(); i++) {
            aProteins.add(oPepsum.getHit(i));

            int j = 0;
            ms_protein oProtein;
            while((oProtein = oPepsum.getNextFamilyProtein(i, ++j)) != null) {
                aProteins.add(oProtein);
            }
        }

        for(ms_protein oProtein : aProteins) {
            System.out.printf("%d::%s:\n", oProtein.getDB(), oProtein.getAccession());
            for(String sRationame : aRationames) {
                ms_protein_quant_ratio oRatio = oMs2Quant.getProteinRatio(oProtein.getAccession(), oProtein.getDB(), sRationame);
                if(oRatio.isMissing()) {
                    System.out.printf("%10s: ---\n", sRationame);
                } else {
                    System.out.printf("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
                            sRationame, oRatio.getValue(), oRatio.getStandardError(),
                            oRatio.getSampleSize(), oRatio.getNormalityPvalue(),
                            oRatio.getHypothesisPvalue());
                }
            }
            System.out.println();
            StringBuilder sbPeptideRatioHeader = new StringBuilder();
            sbPeptideRatioHeader.append(String.format("%10s", "Peptide"));
            for(String sRationame : aRationames) {
                sbPeptideRatioHeader.append(" ");
                sbPeptideRatioHeader.append(String.format("%10s",sRationame));
            }
            System.out.println(sbPeptideRatioHeader);
            for(int i = 1; i <= oProtein.getNumPeptides(); i++) {
                if(oProtein.getPeptideDuplicate(i) == ms_protein.DUPE_DuplicateSameQuery) continue;
                int q = oProtein.getPeptideQuery(i);
                int p = oProtein.getPeptideP(i);

                ms_peptide oPeptide = oPepsum.getPeptide(q, p);
                if(oPeptide == null) continue;

                List<String> aValues = new ArrayList<String>();
                for(String sRationame : aRationames) {
                    // Note that the q,p arguments to ms_peptide_quant_key must be integers.
                    // Otherwise the wrong constructor is chosen. Here they are
                    // integers, as they are return values from Parser functions that
                    // return ints.
                    ms_peptide_quant_ratio oRatio = oMs2Quant.getPeptideRatio(new ms_peptide_quant_key(q,p), sRationame);

                    if(oRatio.isMissing()) {
                        aValues.add(String.format("%10s", "---"));
                        continue;
                    }

                    if(oRatio.isInfinite()) {
                        aValues.add(String.format("%10s", "---"));
                    } else {
                        aValues.add(String.format("%10g", oRatio.getValue()));
                    }
                }
                StringBuilder sbValues = new StringBuilder();
                for(String sValue : aValues) {
                    if(sbValues.length() > 0) sbValues.append(" ");
                    sbValues.append(sValue);
                }
                System.out.printf("%10s %s\n", String.format("q%d_p%d", q, p), sbValues);
            }
            System.out.println();
        }

    }

}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_ms2quantitation.pl

Example program extracting peptide ratios from a Reporter or Multiplex file.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_ms2quantitation.pl                                           #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2013 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_ms2quantitation.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
use warnings;
##############################################################################

use msparser;

if (@ARGV != 4) {
    print STDERR "Usage: $0 <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>\n";
    print STDERR "The location of schema files should be e.g.\n";
    print STDERR "  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd\n";
    print STDERR "  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd\n";
    print STDERR "  ../html/xmlns/schema/unimod_2/unimod_2.xsd\n";
    print STDERR "if running from the Mascot cgi directory.\n";
    exit 1;
}

my $quant_schema1_filepath = $ARGV[0];
my $quant_schema2_filepath = $ARGV[1];
my $unimod_schema_filepath = $ARGV[2];

my $resfile = msparser::ms_mascotresfile->new($ARGV[3], 1);

if (not $resfile->isValid) {
    print STDERR $resfile->getLastErrorString(), "\n";
    exit 1;
}

# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):
dump_warnings($resfile->getErrorHandler());
$resfile->clearAllErrors();

$resfile->setXMLschemaFilePath(
    $msparser::ms_mascotresfile::XML_SCHEMA_QUANTITATION,
    "http://www.matrixscience.com/xmlns/schema/quantitation_2 $quant_schema2_filepath http://www.matrixscience.com/xmlns/schema/quantitation_1 $quant_schema1_filepath"
);

$resfile->setXMLschemaFilePath(
    $msparser::ms_mascotresfile::XML_SCHEMA_UNIMOD,
    "http://www.unimod.org/xmlns/schema/unimod_2 $unimod_schema_filepath",
);

my $qmethod = msparser::ms_quant_method->new();

if (not $resfile->getQuantitationMethod($qmethod)) {
    print STDERR $resfile->getLastErrorString(), "\n";
    exit 1;
}

my $pepsum;

do {
    my $datfile = msparser::ms_datfile->new();

    my (undef, $flags, $minprob, $maxhits, $iisb, $minpeplen, $use_pepsum, $flags2)
        = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions());

    if (not $use_pepsum) {
        print STDERR "Results file cannot be opened as a peptide summary\n";
        exit 1;
    }

    $pepsum = msparser::ms_peptidesummary->new(
        $resfile, $flags, $minprob, $maxhits, '', $iisb, $minpeplen, '', $flags2
    );

    if (not $resfile->isValid) {
        print STDERR $resfile->getLastErrorString, "\n";
        exit 1;
    }

    dump_warnings($resfile->getErrorHandler());
    $resfile->clearAllErrors();
};

# Quantitate the file using ms_ms2quantitation:

my $ms2quant = msparser::ms_ms2quantitation->new($pepsum, $qmethod);

if (not $ms2quant->isValid) {
    print STDERR $ms2quant->getLastErrorString(), "\n";
    exit 1;
}

if ($ms2quant->hasIntensityNormalisation()) {
    $ms2quant->normaliseIntensities();
} elsif ($ms2quant->hasPeptideRatioNormalisation()) {
    $ms2quant->normalisePeptideRatios();
}

# Update the quantitation method in case ms_ms2quantitation changed any of
# the parameters:
$qmethod = $ms2quant->getQuantitationMethod();

dump_warnings($ms2quant->getErrorHandler());
$ms2quant->clearAllErrors();

# Now we can inspect peptide and protein data in $ms2quant.
# But first, dump quantitation method parameters to see what we have:

do {
    my @comps = ();

    for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
        my $comp = $qmethod->getComponentByNumber($i);
        $comps[$i] = $comp->getName();
    }

    printf "Components: [%s]\n", join(', ', @comps);
};

my @rationames = ();

for my $i (0 .. $qmethod->getNumberOfReportRatios()-1) {
    push @rationames, $qmethod->getReportRatioByNumber($i)->getName();
}

printf "Report ratios: [%s]\n", join(', ', @rationames);

printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();

if ($qmethod->haveQuality()) {
    my $q = $qmethod->getQuality();
    printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
    printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
    printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
} else {
    printf "Quality: no restrictions\n";
}

if ($qmethod->haveNormalisation()) {
    my $q = $qmethod->getNormalisation();
    printf "Normalisation = %s\n", $q->getMethod();

    if ($q->haveProteins()) {
        my $p = $q->getProteins();
        printf " - Accessions = %s\n", join(', ',
            map { $p->getProtein($_)->getAccession() } 0 .. $p->getNumberOfProteins()-1
        );
    }

    if ($q->havePeptides()) {
        my $p = $q->getPeptides();
        printf "  - Sequences = %s\n", join(', ',
            map { $p->getPeptide($_)->getSequence() } 0 .. $p->getNumberOfPeptides()-1
        );
    }

    my @component_bases = ();

    for (1 .. $qmethod->getNumberOfComponents()) {
        my $base = $ms2quant->getIntensityNormalisationBase($qmethod->getComponentByNumber($_-1)->getName());
        push @component_bases, $base;
    }

    printf "Intensity normalisation constants: [%s]\n", join(', ', @component_bases);
    printf "Ratio normalisation constants: [%s]\n", join(', ',
        map { $ms2quant->getPeptideRatioNormalisationBase($_) } @rationames
    );
} else {
    printf "Normalisation: none\n";
}

if ($qmethod->haveOutliers()) {
    my $q = $qmethod->getOutliers();
    printf "Outliers = %s\n", $q->getMethod();
} else {
    printf "Outliers: none\n";
}

print "\n";

# Collect proteins we're interested in:
my @proteins = ();

for my $i (1 .. $pepsum->getNumberOfHits()) {
    my $hit = $pepsum->getHit($i);
    push @proteins, $hit;

    my $j = 0;
    while (my $protein = $pepsum->getNextFamilyProtein($i, ++$j)) {
        push @proteins, $protein;
    }
}

for my $protein (@proteins) {
    printf "%d::%s:\n", $protein->getDB(), $protein->getAccession();

    for (@rationames) {
        my $ratio = $ms2quant->getProteinRatio($protein->getAccession(), $protein->getDB(), $_);

        if ($ratio->isMissing()) {
            printf "%10s: ---\n", $_;
        } else {
            printf "%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g\n",
                $_, $ratio->getValue(), $ratio->getStandardError(),
                $ratio->getSampleSize(), $ratio->getNormalityPvalue(),
                $ratio->getHypothesisPvalue();
        }
    }

    print "\n";
    print join(' ', map { sprintf("%10s", $_) } 'Peptide', @rationames), "\n";

    for my $i (1 .. $protein->getNumPeptides()) {
        next if $protein->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_DuplicateSameQuery;

        my $q = $protein->getPeptideQuery($i);
        my $p = $protein->getPeptideP($i);

        my $peptide = $pepsum->getPeptide($q, $p);

        next if not $peptide;

        my @values = ();

        for (@rationames) {
            # Note that the q,p arguments to ms_peptide_quant_key must be
            # integers. Otherwise the wrong constructor is chosen. Here they
            # are integers, as they are return values from Parser functions
            # that return ints.
            my $ratio = $ms2quant->getPeptideRatio(msparser::ms_peptide_quant_key->new($q, $p), $_);

            if ($ratio->isMissing()) {
                push @values, sprintf("%10s", '---');
                next;
            }

            if ($ratio->isInfinite()) {
                push @values, sprintf("%10s", '###');
            } else {
                push @values, sprintf("%10g", $ratio->getValue());
            }
        }

        printf "%10s %s\n", sprintf("q%d_p%d", $q, $p), join(' ', @values);
    }

    print "\n";
}

sub dump_warnings {
    my ($err) = @_;

    for my $i (1 .. $err->getNumberOfErrors()) {
        print 'Warning: ', $err->getErrorString($i), "\n";
    }
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_ms2quantitation.py

Example program extracting peptide ratios from a Reporter or Multiplex file.

#!/usr/bin/python
##############################################################################
# file: resfile_ms2quantitaion.py                                            #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_python/resfile_ms2quantitation.py $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

# If no arguments supplied, print help and exit

if len(sys.argv) != 5:
    print("Usage: %s <quantitation schema 1 filepath> <quantitation schema 2 filepath> <unimod schema filepath> <results file>" % sys.argv[0])
    print("The location of schema files should be e.g.")
    print("  ../html/xmlns/schema/quantitation_1/quantitation_1.xsd")
    print("  ../html/xmlns/schema/quantitation_2/quantitation_2.xsd")
    print("  ../html/xmlns/schema/unimod_2/unimod_2.xsd")
    print("if running from the Mascot cgi directory.")
    sys.exit(1)

quant_schema1_filepath = sys.argv[1]
quant_schema2_filepath = sys.argv[2]
unimod_schema_filepath = sys.argv[3]

resfile = msparser.ms_mascotresfile(sys.argv[4], 1)

if not resfile.isValid():
    print(resfile.getLastErrorString())
    sys.exit(1)

def dump_warnings(err):

    for i in ms_range(1, err.getNumberOfErrors()):
        print('Warning: %s' %(err.getErrorString(i)))

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

# And print out related warnings, if any (we know these are only warnings,
# because isValid() returned true earlier):

dump_warnings(resfile.getErrorHandler())
resfile.clearAllErrors()

resfile.setXMLschemaFilePath(msparser.ms_mascotresfile.XML_SCHEMA_QUANTITATION, "http://www.matrixscience.com/xmlns/schema/quantitation_2 " + quant_schema2_filepath + " http://www.matrixscience.com/xmlns/schema/quantitation_1 " + quant_schema1_filepath)
resfile.setXMLschemaFilePath(msparser.ms_mascotresfile.XML_SCHEMA_UNIMOD, "http://www.unimod.org/xmlns/schema/unimod_2 " + unimod_schema_filepath)

qmethod = msparser.ms_quant_method()

if not resfile.getQuantitationMethod(qmethod):
    print(resfile.getLastErrorString())
    sys.exit(1)

datfile = msparser.ms_datfile()
undef, flags, minprob, maxhits, iisb, minpeplen, use_pepsum, flags2 = resfile.get_ms_mascotresults_params(datfile.getMascotOptions())

if not use_pepsum:
    print("Results File cannot be opened as a peptide summary")
    sys.exit(1)

pepsum = msparser.ms_peptidesummary(resfile, flags, minprob, maxhits, '', iisb, minpeplen, '', flags2)

if not resfile.isValid():
    print(resfile.getLastErrorString)
    sys.exit(1)

dump_warnings(resfile.getErrorHandler())
resfile.clearAllErrors()

# Quantitate the file using ms_ms2quantitation:

ms2quant = msparser.ms_ms2quantitation(pepsum, qmethod)

if not ms2quant.isValid():
    sys.exit(1)

if ms2quant.hasIntensityNormalisation():
    ms2quant.normaliseIntensities()
elif ms2quant.hasPeptideRatioNormalisation():
    ms2quant.normalisePeptideRatios()

# Update the quantitation method in case ms_ms2quantitation changed any of
# the parameters:
qmethod = ms2quant.getQuantitationMethod()

dump_warnings(ms2quant.getErrorHandler())
ms2quant.clearAllErrors()

# Now we can inspect peptide and protein data in ms2quant.
# But first, dump quantitation method parameters to see what we have:

comps = []
for i in ms_range(0, qmethod.getNumberOfComponents()-1):
    comp = qmethod.getComponentByNumber(i)
    comps.append(comp.getName())

print("Components: %s" %(comps))

rationames = []
for i in ms_range(0, qmethod.getNumberOfReportRatios()-1):
    reportratio = qmethod.getReportRatioByNumber(i)
    reportrationame = reportratio.getName()
    rationames.append(reportrationame)
print("Report ratios: %s" %(rationames))

print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
print("Min. number of peptides = %d" %(qmethod.getMinNumPeptides()))

if qmethod.haveQuality():
    q = qmethod.getQuality()
    print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
    print("Quality: pep. threshold type = %s" %(q.getPepThresholdType()))
    print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
else:
    print("Quality: no restrictions")

# Check for Normalisation

if qmethod.haveNormalisation():
    q = qmethod.getNormalisation()
    print("Normalisation = %s" %(q.getMethod()))

    if q.haveProteins():
        p = q.getProteins()
        for i in ms_range(0, p.getNumberOfProteins()-1):
            accessions = []
            accessions.append(p.getProtein().getAccession())
        print(" - Accessions = %s" %(accessions))

    if q.havePeptides():
        p = q.getPeptides()
        for i in ms_range(0, p.getNumberOfPeptides()-1):
            peptides = []
            peptides.append(p.getPeptide().getSequence())
        print(" - Sequences = %s" %(peptides))

    component_bases = []

    for i in ms_range(0, qmethod.getNumberOfComponents()-1):
        component = qmethod.getComponentByNumber(i)
        compname = component.getName()
        baseNormalisation = ms2quant.getIntensityNormalisationBase(compname)
        component_bases.append(baseNormalisation)
        for rationame in rationames:
            ms2gprn = ms2quant.getPeptideRatioNormalisationBase(rationame)
    print("Intensity normalisation constants: %s" %(component_bases))
    print("Ratio normalisation constants: %s" %(ms2gprn))

else:
    print("Normalisation: none")

if qmethod.haveOutliers():
    q = qmethod.getOutliers()
    print("Outliers = %s" %(q.getMethod()))
else:
    print("Outliers: none")

print("\n")

# Collect proteins we're interested in:
proteins = []

for i in ms_range(1, pepsum.getNumberOfHits()):
    hit = pepsum.getHit(i)
    proteins.append(hit)
    j = 0
    protein = pepsum.getNextFamilyProtein(i, j)
    while protein !=None:
        proteins.append(protein)
        j += 1

protein = ''
for protein in proteins:
    print("%d::%s:" %(protein.getDB(), protein.getAccession()))

    for rationame in rationames:
        ratio = ms2quant.getProteinRatio(protein.getAccession(), protein.getDB(), rationame)
        print(rationame)
        if ratio.isMissing():
            print("%10s: ---" %(rationame))
        else:
            print("%10s = %10g, stderr = %10g, N = %d, normal-p = %6g, hypo-p = %6g" %(rationame, ratio.getValue(), ratio.getStandardError_only(), ratio.getSampleSize(), ratio.getNormalityPvalue_only(), ratio.getHypothesisPvalue_only()))
    print(rationame)
    print("  %10s %s" %('Peptide:', rationame))
    for i in ms_range(1, protein.getNumPeptides()):
        if protein.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery:
            continue

        q = protein.getPeptideQuery(i)
        p = protein.getPeptideP(i)

        peptide = pepsum.getPeptide(q, p)

        if not peptide:
            continue

        values = ''
        for rationame in rationames:
            # Note that the q,p arguments to ms_peptide_quant_key must be
            # integers. Otherwise the wrong constructor is chosen. Here they
            # are integers, as they are return values from Parser functions
            # that return ints.
            quantKey = msparser.ms_peptide_quant_key(q, p)
            ratio = ms2quant.getPeptideRatio(quantKey, rationame)

            if ratio.isMissing():
                values = "---"
                continue

            if ratio.isInfinite():
                values = "###"
            else:
                values = ratio.getValue()

        print("    %-9s  %-10s" %("q%d_p%d" %(q, p), str(values)))

    print("\n")
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_params.cpp

Example program for retrieving search parameter data.

/*
##############################################################################
# file: resfile_params.cpp                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/resfile_params.cpp $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <iomanip>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* Local functions                                                           */
/* (This test harness is 'C' and not C++)                                    */
/*****************************************************************************/
static void searchParameters(ms_mascotresfile & file);

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - the name of the .dat file      */
/*****************************************************************************/
int main(int argc, char * argv[])
{
    if (argc == 2)
    {
        ms_mascotresfile file(argv[1]);

        if (file.isValid())
        {
            searchParameters(file);
        }
        else
            std::cout << "Error: " << file.getLastErrorString() << std::endl;
    }
    else
        std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
    return 0;
}

/*****************************************************************************/
/* searchParameters                                                          */
/* Display parameters from the ms_searchparams object.                       */
/* The values come from the parameters and the masses sections of the file   */
/*****************************************************************************/
static void searchParameters(ms_mascotresfile & file)
{
    ms_searchparams p(file);

    std::cout << "Search parameters from ms_searchparams"             << std::endl;
    std::cout << "========================================="          << std::endl;
    std::cout << "License             : " << p.getLICENSE()           << std::endl;
    std::cout << "Search title        : " << p.getCOM()               << std::endl;
    std::cout << "SEG mass            : " << p.getSEG()               << std::endl;
    std::cout << "Peptide tol         : " << p.getTOL()               << std::endl;
    std::cout << "Peptide tol units   : " << p.getTOLU()              << std::endl;
    std::cout << "Fragment tol        : " << p.getITOL()              << std::endl;
    std::cout << "Fragment tol units  : " << p.getITOLU()             << std::endl;
    std::cout << "Missed cleavages    : " << p.getPFA()               << std::endl;
    std::cout << "Database            : " << p.getDB()                << std::endl;
    std::cout << "Static mods         : " << p.getMODS()              << std::endl;
    std::cout << "Average/monoisotopic: " << p.getMASS()              << std::endl;
    std::cout << "Enzyme              : " << p.getCLE()               << std::endl;
    std::cout << "Raw data file name  : " << p.getFILENAME()          << std::endl;
    std::cout << "Input data          : " << p.getQUE()               << std::endl;
    std::cout << "Type of search      : " << p.getSEARCH()            << std::endl;
    std::cout << "User name           : " << p.getUSERNAME()          << std::endl;
    std::cout << "User email          : " << p.getUSEREMAIL()         << std::endl;
    std::cout << "Charge state        : " << p.getCHARGE()            << std::endl;
    std::cout << "Repeat search file  : " << p.getINTERMEDIATE()      << std::endl;
    std::cout << "Num hits to display : " << p.getREPORT()            << std::endl;
    std::cout << "Show overview       : " << p.getOVERVIEW()          << std::endl;
    std::cout << "Data file format    : " << p.getFORMAT()            << std::endl;
    std::cout << "Form version        : " << p.getFORMVER()           << std::endl;
    std::cout << "Variable mods       : " << p.getIT_MODS()           << std::endl;

    for (int u=0; u <=12; u++)
        std::cout << "User"
        << std::setw(2) << std::setfill('0')  << u
              <<       "              : " << p.getUSERField(u)        << std::endl;
    std::cout << "Precursor mass      : " << p.getPRECURSOR()         << std::endl;
    std::cout << "Taxonomy filter     : " << p.getTAXONOMY()          << std::endl;
    std::cout << "Type of report      : " << p.getREPTYPE()           << std::endl;
    std::cout << "Accessions to search: " << p.getACCESSION()         << std::endl;
    std::cout << "Subcluster used     : " << p.getSUBCLUSTER()        << std::endl;
    std::cout << "ICAT search?        : " << p.getICAT()              << std::endl;
    std::cout << "Instrument type     : " << p.getINSTRUMENT()        << std::endl;
    std::cout << "Error tolerant?     : " << p.getERRORTOLERANT()     << std::endl;
    std::cout << "Rules (ions series) : " << p.getRULES()             << std::endl;
    std::cout << "Quantitation method : " << p.getQUANTITATION()      << std::endl;
    std::cout << "Peptide isotope err : " << p.getPEP_ISOTOPE_ERROR() << std::endl;
    std::cout << "Decoy database      : " << p.getDECOY()             << std::endl;

    for (char ch='A'; ch <= 'Z'; ch++)
    {
        std::cout << "Residue " << ch << "           : "
                  << p.getResidueMass(ch)
                  << std::endl;
    }
    std::cout << "C terminus mass     : " << p.getCTermMass()         << std::endl;
    std::cout << "N terminus mass     : " << p.getNTermMass()         << std::endl;
    std::cout << "Mass of hydrogen    : " << p.getHydrogenMass()      << std::endl;
    std::cout << "Mass of oxygen      : " << p.getOxygenMass()        << std::endl;
    std::cout << "Mass of carbon      : " << p.getCarbonMass()        << std::endl;
    std::cout << "Mass of nitrogen    : " << p.getNitrogenMass()      << std::endl;
    std::cout << "Mass of electron    : " << p.getElectronMass()      << std::endl;

    int i = 1;
    while (p.getVarModsName(i).length())
    {
    std::cout << "Variable mod name   : " << p.getVarModsName(i)      << std::endl;
    std::cout << "Variable mod delta  : " << p.getVarModsDelta(i)     << std::endl;
    std::cout << "Variable mod neutral: " << p.getVarModsNeutralLoss(i)<< std::endl;
    i++;
    }
    std::cout << std::endl << std::endl;
}

/*
will give the output:

Search parameters from ms_searchparams
=========================================
License             :
Search title        : A few peptides from an LCMS run
SEG mass            : -1
Peptide tol         : 2
Peptide tol units   : Da
Fragment tol        : 1
Fragment tol units  : Da
Missed cleavages    : 1
Database            : MSDB
Static mods         : Oxidation (M),SMA (K),SMA (N-term)
Average/monoisotopic: Monoisotopic
Enzyme              : Trypsin
Raw data file name  : U:\\Mascot test data\\TSQ\\dyckall_1.asc
Input data          :
Type of search      : MIS
User name           : Cat R. Piller
User email          : crp@brassica.com
Charge state        : 2+
Repeat search file  :
Num hits to display : 5
Show overview       : 0
Data file format    : Finnigan (.ASC)
Form version        : 1.01
Variable mods       :
User00              :
User01              :
User02              :
User03              :
User04              :
User05              :
User06              :
User07              :
User08              :
User09              :
User10              :
User11              :
User12              :
Precursor mass      : 0
Taxonomy filter     : All entries
Type of report      : peptide
Accessions to search:
Subcluster used     : -1
ICAT search?        : 0
Instrument type     : ESI-QUAD-TOF
Error tolerant?     : 0
Rules (ions series) : 1,2,8,9,10,13,14,15
Quantitation method : ICAT
Peptide isotope err : 2
Decoy database      : 1
Residue A           : 71.0371
Residue B           : 114.535
Residue C           : 103.009
Residue D           : 115.027
Residue E           : 129.043
Residue F           : 147.068
Residue G           : 57.0215
Residue H           : 137.059
Residue I           : 113.084
Residue J           : 0
Residue K           : 255.158
Residue L           : 113.084
Residue M           : 147.035
Residue N           : 114.043
Residue O           : 0
Residue P           : 97.0528
Residue Q           : 128.059
Residue R           : 156.101
Residue S           : 87.032
Residue T           : 101.048
Residue U           : 0
Residue V           : 99.0684
Residue W           : 186.079
Residue X           : 111
Residue Y           : 163.063
Residue Z           : 128.551
C terminus mass     : 17.0027
N terminus mass     : 128.071
Mass of hydrogen    : 1.00783
Mass of oxygen      : 15.9949
Mass of carbon      : 12
Mass of nitrogen    : 14.0031
Mass of electron    : 0

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_params.cs

Example program for retrieving search parameter data.

/*
##############################################################################
# file: resfile_params.cs                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_params.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class resfile_params
    {
        public static void Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.WriteLine("Must specify results filename as parameter");
                return;
            }

            ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
            if (file.isValid())
            {
                searchParameters(file);
            }
            else
            {
                Console.WriteLine("Error number: {0}", file.getLastError());
                Console.WriteLine("Error string: {0}", file.getLastErrorString());
                return;
            }

        }

        private static void searchParameters(ms_mascotresfile file)
        {
            int i;
            char ch;
            ms_searchparams p = file._params();

            Console.WriteLine("Search parameters from ms_searchparams");
            Console.WriteLine("=========================================");
            Console.WriteLine("License             : {0}", p.getLICENSE());
            Console.WriteLine("Search title        : {0}", p.getCOM());
            Console.WriteLine("SEG mass            : {0}", p.getSEG());
            Console.WriteLine("Peptide tol         : {0}", p.getTOL());
            Console.WriteLine("Peptide tol units   : {0}", p.getTOLU());
            Console.WriteLine("Fragment tol        : {0}", p.getITOL());
            Console.WriteLine("Fragment tol units  : {0}", p.getITOLU());
            Console.WriteLine("Missed cleavages    : {0}", p.getPFA());
            Console.WriteLine("Database            : {0}", p.getDB());
            Console.WriteLine("Static mods         : {0}", p.getMODS());
            Console.WriteLine("Average/monoisotopic: {0}", p.getMASS());
            Console.WriteLine("Enzyme              : {0}", p.getCLE());
            Console.WriteLine("Raw data file name  : {0}", p.getFILENAME());
            Console.WriteLine("Input data          : {0}", p.getQUE());
            Console.WriteLine("Type of search      : {0}", p.getSEARCH());
            Console.WriteLine("User name           : {0}", p.getUSERNAME());
            Console.WriteLine("User email          : {0}", p.getUSEREMAIL());
            Console.WriteLine("Charge state        : {0}", p.getCHARGE());
            Console.WriteLine("Repeat searhc file  : {0}", p.getINTERMEDIATE());
            Console.WriteLine("Num hits to display : {0}", p.getREPORT());
            Console.WriteLine("Show overview       : {0}", ((p.getOVERVIEW()) ? 1 : 0));
            Console.WriteLine("Data file format    : {0}", p.getFORMAT());
            Console.WriteLine("Form version        : {0}", p.getFORMVER());
            Console.WriteLine("Variable mods       : {0}", p.getIT_MODS());

            for (i = 0; i <= 12; i++)
            {
                Console.WriteLine("User{0}              : {1}", "" + i.ToString("D2"), p.getUSERField(i));
            }

            Console.WriteLine("Precursor mass      : {0:#}", p.getPRECURSOR());
            Console.WriteLine("Taxonomy filter     : {0}", p.getTAXONOMY());
            Console.WriteLine("Type of report      : {0}", p.getREPTYPE());
            Console.WriteLine("Accessions to search: {0}", p.getACCESSION());
            Console.WriteLine("Subcluster used     : {0}", p.getSUBCLUSTER());
            Console.WriteLine("ICAT search?        : {0}", ((p.getICAT()) ? 1 : 0));
            Console.WriteLine("Instrument type     : {0}", p.getINSTRUMENT());
            Console.WriteLine("Error tolerant?     : {0}", ((p.getERRORTOLERANT()) ? 1 : 0));
            Console.WriteLine("Rules (ions series) : {0}", p.getRULES());
            Console.WriteLine("Quantitation method : {0}", p.getQUANTITATION());
            Console.WriteLine("Peptide isotope err : {0}", p.getPEP_ISOTOPE_ERROR());
            Console.WriteLine("Decoy database      : {0}", p.getDECOY());

            for (ch = 'A'; ch <= 'Z'; ch++)
            {
                Console.WriteLine("Residue {0}           : {1:#}", ch, p.getResidueMass(ch));
            }

            Console.WriteLine("C terminus mass     : {0:#}", p.getCTermMass());
            Console.WriteLine("N terminus mass     : {0:#}", p.getNTermMass());
            Console.WriteLine("Mass of hydrogen    : {0:#}", p.getHydrogenMass());
            Console.WriteLine("Mass of oxygen      : {0:#}", p.getOxygenMass());
            Console.WriteLine("Mass of carbon      : {0:#}", p.getCarbonMass());
            Console.WriteLine("Mass of nitrogen    : {0:#}", p.getNitrogenMass());
            Console.WriteLine("Mass of electron    : {0:#}", p.getElectronMass());

            i = 1;

            while (p.getVarModsName(i).Length > 0)
            {
                Console.WriteLine("Variable mod name   : {0}", p.getVarModsName(i));
                Console.WriteLine("Variable mod delta  : {0:#}", p.getVarModsDelta(i));
                Console.WriteLine("Variable mod neutral: {0:#}", p.getVarModsNeutralLoss(i));
                i++;
            }
            Console.WriteLine();
        }
    }
}

/*
resfile_params.exe c:\inetpub\mascot\data\F981123.dat
Will give the following output:

Search parameters from ms_searchparams
=========================================
License             : Matrix Science  (ECUK-U3C2-5RS5-AAQL-H2X5)
Search title        : MS/MS Example
SEG mass            : -1
Peptide tol         : 0.2
Peptide tol units   : Da
Fragment tol        : 0.2
Fragment tol units  : Da
Missed cleavages    : 1
Database            : SwissProt
Static mods         :
Average/monoisotopic: Monoisotopic
Enzyme              : Trypsin
Raw data file name  :
Input data          :
Type of search      : MIS
User name           :
User email          :
Charge state        : 2+
Repeat searhc file  : ../data/F981123.dat
Num hits to display : 0
Show overview       : 0
Data file format    : Mascot generic
Form version        : 1.01
Variable mods       : Oxidation (M)
User00              :
User01              :
User02              :
User03              :
User04              :
User05              :
User06              :
User07              :
User08              :
User09              :
User10              :
User11              :
User12              :
Precursor mass      :
Taxonomy filter     : All entries
Type of report      : Peptide
Accessions to search:
Subcluster used     : -1
ICAT search?        : 0
Instrument type     : ESI-QUAD-TOF
Error tolerant?     : 0
Rules (ions series) : 1,2,8,9,10,13,14,15
Quantitation method : None
Peptide isotope err : 0
Decoy database      : -1
Residue A           : 71
Residue B           : 115
Residue C           : 103
Residue D           : 115
Residue E           : 129
Residue F           : 147
Residue G           : 57
Residue H           : 137
Residue I           : 113
Residue J           : 113
Residue K           : 128
Residue L           : 113
Residue M           : 131
Residue N           : 114
Residue O           : 237
Residue P           : 97
Residue Q           : 128
Residue R           : 156
Residue S           : 87
Residue T           : 101
Residue U           : 151
Residue V           : 99
Residue W           : 186
Residue X           : 111
Residue Y           : 163
Residue Z           : 129
C terminus mass     : 17
N terminus mass     : 1
Mass of hydrogen    : 1
Mass of oxygen      : 16
Mass of carbon      : 12
Mass of nitrogen    : 14
Mass of electron    :
Variable mod name   : Oxidation (M)
Variable mod delta  : 16
Variable mod neutral:
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_params.java

Example program for retrieving search parameter data.

/*
##############################################################################
# file: resfile_params.java                                                  #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2003 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Archive:: /MowseBranches/ms_mascotresfile_1.2/test_java/test_searchp $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
*/

import java.util.Date;
import matrix_science.msparser.*;

public class resfile_params {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // ----- Object creation -----
        if(argv.length < 1) {
            System.out.println("Must specify results filename as parameter");
            System.exit(0);
        }

        ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");
        if (file.isValid()) {
            searchParameters(file);
        } else {
            System.out.println("Error number: "+file.getLastError());
            System.out.println("Error string: "+file.getLastErrorString());
            System.exit(0);
        }
    }

    private static void searchParameters(ms_mascotresfile file) {
        int i;
        char ch;
        ms_searchparams p = file.params();

        System.out.println("Search parameters from ms_searchparams");
        System.out.println("=========================================");

        System.out.println("License             : "+p.getLICENSE());
        System.out.println("Search title        : "+p.getCOM());
        System.out.println("SEG mass            : "+p.getSEG());
        System.out.println("Peptide tol         : "+p.getTOL());
        System.out.println("Peptide tol units   : "+p.getTOLU());
        System.out.println("Fragment tol        : "+p.getITOL());
        System.out.println("Fragment tol units  : "+p.getITOLU());
        System.out.println("Missed cleavages    : "+p.getPFA());
        System.out.println("Database            : "+p.getDB());
        System.out.println("Static mods         : "+p.getMODS());
        System.out.println("Average/monoisotopic: "+p.getMASS());
        System.out.println("Enzyme              : "+p.getCLE());
        System.out.println("Raw data file name  : "+p.getFILENAME());
        System.out.println("Input data          : "+p.getQUE());
        System.out.println("Type of search      : "+p.getSEARCH());
        System.out.println("User name           : "+p.getUSERNAME());
        System.out.println("User email          : "+p.getUSEREMAIL());
        System.out.println("Charge state        : "+p.getCHARGE());
        System.out.println("Repeat search file  : "+p.getINTERMEDIATE());
        System.out.println("Num hits to display : "+p.getREPORT());
        System.out.println("Show overview       : "+toBinary(p.getOVERVIEW()));
        System.out.println("Data file format    : "+p.getFORMAT());
        System.out.println("Form version        : "+p.getFORMVER());
        System.out.println("Variable mods       : "+p.getIT_MODS());

        // java lacks a printf equivalent by default
        for(i=0; i <=12; i++) {
            String output = "User";
            if(i < 10) output += "0";
            output += i+"              : "+p.getUSERField(i);
            System.out.println(output);
        }

        System.out.println("Precursor mass      : "+roundWholeNumber(p.getPRECURSOR()));
        System.out.println("Taxonomy filter     : "+p.getTAXONOMY());
        System.out.println("Type of report      : "+p.getREPTYPE());
        System.out.println("Accessions to search: "+p.getACCESSION());
        System.out.println("Subcluster used     : "+p.getSUBCLUSTER());
        System.out.println("ICAT search?        : "+toBinary(p.getICAT()));
        System.out.println("Instrument type     : "+p.getINSTRUMENT());
        System.out.println("Error tolerant?     : "+toBinary(p.getERRORTOLERANT()));
        System.out.println("Rules (ions series) : "+p.getRULES());
        System.out.println("Quantitation method : "+p.getQUANTITATION());
        System.out.println("Peptide isotope err : "+p.getPEP_ISOTOPE_ERROR());
        System.out.println("Decoy database      : "+p.getDECOY());

        for(ch='A'; ch <= 'Z'; ch++) {
            System.out.println("Residue "+ch+"           : "+roundWholeNumber(p.getResidueMass(ch)));
        }

        System.out.println("C terminus mass     : "+roundWholeNumber(p.getCTermMass()));
        System.out.println("N terminus mass     : "+roundWholeNumber(p.getNTermMass()));
        System.out.println("Mass of hydrogen    : "+roundWholeNumber(p.getHydrogenMass()));
        System.out.println("Mass of oxygen      : "+roundWholeNumber(p.getOxygenMass()));
        System.out.println("Mass of carbon      : "+roundWholeNumber(p.getCarbonMass()));
        System.out.println("Mass of nitrogen    : "+roundWholeNumber(p.getNitrogenMass()));
        System.out.println("Mass of electron    : "+roundWholeNumber(p.getElectronMass()));

        i=1;

        while(!(p.getVarModsName(i).equals(""))) {
            System.out.println("Variable mod name   : "+p.getVarModsName(i));
            System.out.println("Variable mod delta  : "+roundWholeNumber(p.getVarModsDelta(i)));
            System.out.println("Variable mod neutral: "+roundWholeNumber(p.getVarModsNeutralLoss(i)));
            i++;
        }
        System.out.println("\n");
    }

    private static int toBinary(boolean bool) {
        if(bool) return 1;
        return 0;
    }

    private static String roundWholeNumber (double toRound) {
        String myInt = ""+toRound;
        myInt += "\n";
        if(myInt.indexOf(".0\n")>-1) {
            return myInt.substring(0,myInt.indexOf(".0\n"));
        }
        return ""+toRound;
    }

}

/*

will give the output:

C:>java -classpath .;../java/msparser.jar resfile_params F981123.dat
Search parameters from ms_searchparams
=========================================
License             :
Search title        : A few peptides from an LCMS run
SEG mass            : -1
Peptide tol         : 2.0
Peptide tol units   : Da
Fragment tol        : 1.0
Fragment tol units  : Da
Missed cleavages    : 1
Database            : MSDB
Static mods         : Oxidation (M),SMA (K),SMA (N-term)
Average/monoisotopic: Monoisotopic
Enzyme              : Trypsin
Raw data file name  : U:\\Mascot test data\\TSQ\\dyckall_1.asc
Input data          :
Type of search      : MIS
User name           : Cat R. Piller
User email          : crp@brassica.com
Charge state        : 2+
Repeat search file  :
Num hits to display : 5
Show overview       : 0
Data file format    : Finnigan (.ASC)
Form version        : 1.01
Variable mods       :
User00              :
User01              :
User02              :
User03              :
User04              :
User05              :
User06              :
User07              :
User08              :
User09              :
User10              :
User11              :
User12              :
Precursor mass      : 0
Taxonomy filter     : All entries
Type of report      : peptide
Accessions to search:
Subcluster used     : -1
ICAT search?        : 0
Instrument type     : ESI-QUAD-TOF
Error tolerant?     : 0
Rules (ions series) : 1,2,8,9,10,13,14,15
Quantitation method : ICAT
Peptide isotope err : 2
Decoy database      : 1
Residue A           : 71.03711
Residue B           : 114.53493
Residue C           : 103.00919
Residue D           : 115.02694
Residue E           : 129.04259
Residue F           : 147.06841
Residue G           : 57.02146
Residue H           : 137.05891
Residue I           : 113.08406
Residue J           : 0
Residue K           : 255.15829
Residue L           : 113.08406
Residue M           : 147.03541
Residue N           : 114.04293
Residue O           : 0
Residue P           : 97.05276
Residue Q           : 128.05858
Residue R           : 156.10111
Residue S           : 87.03203
Residue T           : 101.04768
Residue U           : 0
Residue V           : 99.06841
Residue W           : 186.07931
Residue X           : 111
Residue Y           : 163.06333
Residue Z           : 128.55059
C terminus mass     : 17.002735
N terminus mass     : 128.07116
Mass of hydrogen    : 1.007825
Mass of oxygen      : 15.99491
Mass of carbon      : 12
Mass of nitrogen    : 14.00307
Mass of electron    : 0

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_params.pl

Example program for retrieving search parameter data.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_params.pl                                                    #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_params.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }

my $file = new msparser::ms_mascotresfile($ARGV[0]);

if ($file->isValid) {
    searchParameters($file);
}

##############################################################################
#  searchParameters                                                          #
#  Display parameters from the ms_searchparams object.                       #
#  The values come from the parameters and the masses sections of the file   #
##############################################################################
sub searchParameters {
    my ($resfile) = @_;

    my $params = $resfile->params;
    my $fmt = "%-20s: %s\n";

    print "Search parameters from ms_searchparams"         , "\n";
    print "========================================="      , "\n";
    printf $fmt, "License"             , $params->getLICENSE();
    printf $fmt, "Search title"        , $params->getCOM();
    printf $fmt, "SEG mass"            , $params->getSEG();
    printf $fmt, "Peptide tol"         , $params->getTOL();
    printf $fmt, "Peptide tol units"   , $params->getTOLU();
    printf $fmt, "Fragment tol"        , $params->getITOL();
    printf $fmt, "Fragment tol units"  , $params->getITOLU();
    printf $fmt, "Missed cleavages"    , $params->getPFA();
    printf $fmt, "Database"            , $params->getDB();
    printf $fmt, "Static mods"         , $params->getMODS();
    printf $fmt, "Average/monoisotopic", $params->getMASS();
    printf $fmt, "Enzyme"              , $params->getCLE();
    printf $fmt, "Raw data file name"  , $params->getFILENAME();
    printf $fmt, "Input data"          , $params->getQUE();
    printf $fmt, "Type of search"      , $params->getSEARCH();
    printf $fmt, "User name"           , $params->getUSERNAME();
    printf $fmt, "User email"          , $params->getUSEREMAIL();
    printf $fmt, "Charge state"        , $params->getCHARGE();
    printf $fmt, "Repeat search file"  , $params->getINTERMEDIATE();
    printf $fmt, "Num hits to display" , $params->getREPORT();
    printf $fmt, "Show overview"       , $params->getOVERVIEW();
    printf $fmt, "Data file format"    , $params->getFORMAT();
    printf $fmt, "Form version"        , $params->getFORMVER();
    printf $fmt, "Variable mods"       , $params->getIT_MODS();

    for my $i (0 .. 12) {
        printf $fmt, sprintf("User%02d", $i), $params->getUSERField($i);
    }

    printf $fmt, "Precursor mass"      , $params->getPRECURSOR();
    printf $fmt, "Taxonomy filter"     , $params->getTAXONOMY();
    printf $fmt, "Type of report"      , $params->getREPTYPE();
    printf $fmt, "Accessions to search", $params->getACCESSION();
    printf $fmt, "Subcluster used"     , $params->getSUBCLUSTER();
    printf $fmt, "ICAT search?"        , $params->getICAT();
    printf $fmt, "Instrument type"     , $params->getINSTRUMENT();
    printf $fmt, "Error tolerant?"     , $params->getERRORTOLERANT();
    printf $fmt, "Rules (ions series)" , $params->getRULES();

    for my $ch (ord('A') .. ord('Z')) {
        printf $fmt, join(' ', "Residue", chr($ch)), $params->getResidueMass(chr($ch));
    }

    printf $fmt, "C terminus mass" , $params->getCTermMass();
    printf $fmt, "N terminus mass" , $params->getNTermMass();
    printf $fmt, "Mass of hydrogen", $params->getHydrogenMass();
    printf $fmt, "Mass of oxygen"  , $params->getOxygenMass();
    printf $fmt, "Mass of carbon"  , $params->getCarbonMass();
    printf $fmt, "Mass of nitrogen", $params->getNitrogenMass();
    printf $fmt, "Mass of electron", $params->getElectronMass();

    my $i = 1;
    while ($params->getVarModsName($i)) {
        printf $fmt, "Variable mod name"   , $params->getVarModsName($i);
        printf $fmt, "Variable mod delta"  , $params->getVarModsDelta($i), "\n";
        printf $fmt, "Variable mod neutral", $params->getVarModsNeutralLoss($i), "\n";
        $i++;
    }

    print "\n\n";
}

=pod

Running the program as

perl -I../bin resfile_params.pl ../data/F981123.dat

will give the following output under Mascot Server 2.3:

Search parameters from ms_searchparams
=========================================
License             : Licensed to: Matrix Science Internal use only - Frill, (4 processors).
Search title        : MS/MS Example
SEG mass            : -1
Peptide tol         : 0.2
Peptide tol units   : Da
Fragment tol        : 0.2
Fragment tol units  : Da
Missed cleavages    : 1
Database            : SwissProt
Static mods         :
Average/monoisotopic: Monoisotopic
Enzyme              : Trypsin
Raw data file name  : C:\Auto MSMS output\Sample 1.pkl
Input data          :
Type of search      : MIS
User name           :
User email          :
Charge state        : 2+
Repeat search file  : ../data/F981123.dat
Num hits to display : 0
Show overview       :
Data file format    : Mascot generic
Form version        : 1.01
Variable mods       : Oxidation (M)
User00              :
User01              :
User02              :
User03              :
User04              :
User05              :
User06              :
User07              :
User08              :
User09              :
User10              :
User11              :
User12              :
Precursor mass      : 0
Taxonomy filter     : All entries
Type of report      : Peptide
Accessions to search:
Subcluster used     : -1
ICAT search?        :
Instrument type     : ESI-QUAD-TOF
Error tolerant?     :
Rules (ions series) : 1,2,8,9,10,13,14,15
Residue A           : 71.037114
Residue B           : 114.53494
Residue C           : 103.009185
Residue D           : 115.026943
Residue E           : 129.042593
Residue F           : 147.068414
Residue G           : 57.021464
Residue H           : 137.058912
Residue I           : 113.084064
Residue J           : 0
Residue K           : 128.094963
Residue L           : 113.084064
Residue M           : 131.040485
Residue N           : 114.042927
Residue O           : 0
Residue P           : 97.052764
Residue Q           : 128.058578
Residue R           : 156.101111
Residue S           : 87.032028
Residue T           : 101.047679
Residue U           : 150.95363
Residue V           : 99.068414
Residue W           : 186.079313
Residue X           : 111
Residue Y           : 163.063329
Residue Z           : 128.55059
C terminus mass     : 17.00274
N terminus mass     : 1.007825
Mass of hydrogen    : 1.007825
Mass of oxygen      : 15.994915
Mass of carbon      : 12
Mass of nitrogen    : 14.003074
Mass of electron    : 0.000549
Variable mod name   : Oxidation (M)
Variable mod delta  : 15.994919
Variable mod neutral: 0

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_params.py

Example program for retrieving search parameter data.

#!/usr/bin/perl
##############################################################################
# file: resfile_params.py                                                    #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/resfile_params.py $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys

def main() :
    if len(sys.argv) < 2 :
        print("Must specify results filename as parameter")
        return 1

    resfile = msparser.ms_mascotresfile(sys.argv[1])

    if resfile.isValid() :
        searchParameters(resfile)

def searchParameters(resfile) :
    """
    Display parameters from the ms_searchparams object.
    The values come from the parameters and the masses sections of the file.
    """

    params = resfile.params()
    fmt = "%-20s: %s"

    print("Search parameters from ms_searchparams")
    print("=========================================")
    print(fmt % ("License"             , params.getLICENSE()))
    print(fmt % ("Search title"        , params.getCOM()))
    print(fmt % ("SEG mass"            , params.getSEG()))
    print(fmt % ("Peptide tol"         , params.getTOL()))
    print(fmt % ("Peptide tol units"   , params.getTOLU()))
    print(fmt % ("Fragment tol"        , params.getITOL()))
    print(fmt % ("Fragment tol units"  , params.getITOLU()))
    print(fmt % ("Missed cleavages"    , params.getPFA()))
    print(fmt % ("Database"            , params.getDB()))
    print(fmt % ("Static mods"         , params.getMODS()))
    print(fmt % ("Average/monoisotopic", params.getMASS()))
    print(fmt % ("Enzyme"              , params.getCLE()))
    print(fmt % ("Raw data file name"  , params.getFILENAME()))
    print(fmt % ("Input data"          , params.getQUE()))
    print(fmt % ("Type of search"      , params.getSEARCH()))
    print(fmt % ("User name"           , params.getUSERNAME()))
    print(fmt % ("User email"          , params.getUSEREMAIL()))
    print(fmt % ("Charge state"        , params.getCHARGE()))
    print(fmt % ("Repeat search file"  , params.getINTERMEDIATE()))
    print(fmt % ("Num hits to display" , params.getREPORT()))
    print(fmt % ("Show overview"       , params.getOVERVIEW()))
    print(fmt % ("Data file format"    , params.getFORMAT()))
    print(fmt % ("Form version"        , params.getFORMVER()))
    print(fmt % ("Variable mods"       , params.getIT_MODS()))

    for i in range(12) :
        print(fmt % ( "User%02d" % i, params.getUSERField(i)))

    print(fmt % ("Precursor mass"      , params.getPRECURSOR()))
    print(fmt % ("Taxonomy filter"     , params.getTAXONOMY()))
    print(fmt % ("Type of report"      , params.getREPTYPE()))
    print(fmt % ("Accessions to search", params.getACCESSION()))
    print(fmt % ("Subcluster used"     , params.getSUBCLUSTER()))
    print(fmt % ("ICAT search?"        , params.getICAT()))
    print(fmt % ("Instrument type"     , params.getINSTRUMENT()))
    print(fmt % ("Error tolerant?"     , params.getERRORTOLERANT()))
    print(fmt % ("Rules (ions series)" , params.getRULES()))

    for ch in range(ord('A'), 1 + ord('Z')) :
        print(fmt % ("Residue " + chr(ch), params.getResidueMass(chr(ch))))

    print(fmt % ("C terminus mass" , params.getCTermMass()))
    print(fmt % ("N terminus mass" , params.getNTermMass()))
    print(fmt % ("Mass of hydrogen", params.getHydrogenMass()))
    print(fmt % ("Mass of oxygen"  , params.getOxygenMass()))
    print(fmt % ("Mass of carbon"  , params.getCarbonMass()))
    print(fmt % ("Mass of nitrogen", params.getNitrogenMass()))
    print(fmt % ("Mass of electron", params.getElectronMass()))

    i = 1
    while params.getVarModsName(i) :
        print(fmt % ("Variable mod name"   , params.getVarModsName(i)))
        print(fmt % ("Variable mod delta"  , params.getVarModsDelta(i)))
        print(fmt % ("Variable mod neutral", params.getVarModsNeutralLoss(i)))
        i += 1

    print(" ")

if __name__ == "__main__" :
    sys.exit(main())

"""

Running the program as

python resfile_params.pl F981123.dat

will give the following output under Mascot Server 2.3:

Search parameters from ms_searchparams
=========================================
License             : Licensed to: Matrix Science Internal use only - Frill, (4 processors).
Search title        : MS/MS Example
SEG mass            : -1
Peptide tol         : 0.2
Peptide tol units   : Da
Fragment tol        : 0.2
Fragment tol units  : Da
Missed cleavages    : 1
Database            : SwissProt
Static mods         :
Average/monoisotopic: Monoisotopic
Enzyme              : Trypsin
Raw data file name  : C:\Auto MSMS output\Sample 1.pkl
Input data          :
Type of search      : MIS
User name           :
User email          :
Charge state        : 2+
Repeat search file  : ../data/F981123.dat
Num hits to display : 0
Show overview       : False
Data file format    : Mascot generic
Form version        : 1.01
Variable mods       : Oxidation (M)
User00              :
User01              :
User02              :
User03              :
User04              :
User05              :
User06              :
User07              :
User08              :
User09              :
User10              :
User11              :
Precursor mass      : 0.0
Taxonomy filter     : All entries
Type of report      : Peptide
Accessions to search:
Subcluster used     : -1
ICAT search?        : False
Instrument type     : ESI-QUAD-TOF
Error tolerant?     : False
Rules (ions series) : 1,2,8,9,10,13,14,15
Residue A           : 71.037114
Residue B           : 114.53494
Residue C           : 103.009185
Residue D           : 115.026943
Residue E           : 129.042593
Residue F           : 147.068414
Residue G           : 57.021464
Residue H           : 137.058912
Residue I           : 113.084064
Residue J           : 0.0
Residue K           : 128.094963
Residue L           : 113.084064
Residue M           : 131.040485
Residue N           : 114.042927
Residue O           : 0.0
Residue P           : 97.052764
Residue Q           : 128.058578
Residue R           : 156.101111
Residue S           : 87.032028
Residue T           : 101.047679
Residue U           : 150.95363
Residue V           : 99.068414
Residue W           : 186.079313
Residue X           : 111.0
Residue Y           : 163.063329
Residue Z           : 128.55059
C terminus mass     : 17.00274
N terminus mass     : 1.007825
Mass of hydrogen    : 1.007825
Mass of oxygen      : 15.994915
Mass of carbon      : 12.0
Mass of nitrogen    : 14.003074
Mass of electron    : 0.000549
Variable mod name   : Oxidation (M)
Variable mod delta  : 15.994919
Variable mod neutral: 0.0

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_summary.cpp

Example program for extracting the peptide or protein summary.

/*
##############################################################################
# file: resfile_summary.cpp                                                  #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/resfile_summary.cpp $  #
#     $Author: villek@matrixscience.com $                                                   #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
#include "msparser.hpp"
#include <iostream>
#include <iomanip>
#include <fstream>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;

/*****************************************************************************/
/* Local functions                                                           */
/*****************************************************************************/
static void displayPeptideInfo(bool showFullDetails,
                               ms_peptide * pep,
                               ms_mascotresults * r,
                               bool isDuplicate,
                               bool isBold,
                               bool showCheckBox);
static bool showResults(ms_mascotresfile &  file,
                        bool                peptideSummary,
                        const int           flags,
                        const double        minProbability        =  0,
                        const int           maxHitsToDisplay      = 50,
                        const double        ignoreIonsScoreBelow  =  0,
                        const int           minPepLenInPepSummary =  0,
                        const int           flags2                = ms_peptidesummary::MSPEPSUM_NONE);
static void displayYellowPopupInfo(ms_mascotresults * results, int q);
static bool checkErrors(ms_mascotresfile & file);

/*****************************************************************************/
/* main                                                                      */
/* Call this program with a single argument - the name of the .dat file      */
/*****************************************************************************/
int main(int argc, char * argv[])
{
    int returnValue = EXIT_FAILURE;

    if (argc == 2)
    {
        ms_mascotresfile file(argv[1]);

        if (checkErrors(file))
        {
            bool         usePeptideSummary;
            unsigned int flags, flags2, minPepLenInPepSummary;
            int          maxHitsToReport;
            double       minProbability, ignoreIonsScoreBelow;

            /*
             * The parameters passed to ms_peptidesummary or ms_proteinsummary determine
             * the type of grouping and the number of proteins and peptides displayed.
             * Default parameters can be returned using ms_mascotresfile::get_ms_mascotresults_params().
             * The return values from this function depend on the type of search,
             * and also on values in the mascot.dat configuration file if that is available.
             */

            ms_datfile datfile("../config/mascot.dat"); //You may need to change this path

            //if the mascot.dat isn't available, use defaults
            ms_mascotoptions mascotOptions;

            if (datfile.isValid())
            {
                mascotOptions = *(datfile.getMascotOptions());
            }

            std::string scriptName = file.get_ms_mascotresults_params(
                                           mascotOptions,
                                           &flags,
                                           &minProbability,
                                           &maxHitsToReport,
                                           &ignoreIonsScoreBelow,
                                           &minPepLenInPepSummary,
                                           &usePeptideSummary,
                                           &flags2);

            bool bResult;
            if (usePeptideSummary)
            {
                /*
                 * For peptide summary
                 *
                 * Flags defined for hierarchical clustering algorithm:
                 *     flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
                 *            | ms_mascotresults::MSRES_SHOW_SUBSETS
                 *            | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
                 *     flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
                 *
                 * Flags defined for original simple parsimony algorithm:
                 *     flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
                 */

                std::cout << "-------------------------------------------------------------" << std::endl;
                std::cout << "---   Peptide summary report                              ---" << std::endl;
                std::cout << "-------------------------------------------------------------" << std::endl;

                bResult = showResults(file,
                                      usePeptideSummary,
                                      flags,
                                      minProbability,
                                      maxHitsToReport,
                                      ignoreIonsScoreBelow,
                                      minPepLenInPepSummary,
                                      flags2);
            }
            else
            {
                // Show results from full protein summary, remove grouping
                flags &= ~ms_mascotresults::MSRES_GROUP_PROTEINS;
                flags &= ~ms_mascotresults::MSRES_SHOW_SUBSETS;

                std::cout << "-------------------------------------------------------------" << std::endl;
                std::cout << "---   Full Protein summary report                         ---" << std::endl;
                std::cout << "-------------------------------------------------------------" << std::endl;
                bResult = showResults(file,
                                      usePeptideSummary,
                                      flags,
                                      minProbability,
                                      maxHitsToReport,
                                      ignoreIonsScoreBelow,
                                      minPepLenInPepSummary,
                                      flags2);

                if (bResult && checkErrors(file))
                {
                    std::cout << std::endl;

                    // Show results from concise protein summary, add grouping
                    flags |= ms_mascotresults::MSRES_GROUP_PROTEINS;
                    flags |= ms_mascotresults::MSRES_SHOW_SUBSETS;

                    std::cout << "-------------------------------------------------------------" << std::endl;
                    std::cout << "---   Concise Protein summary report                      ---" << std::endl;
                    std::cout << "-------------------------------------------------------------" << std::endl;
                    bResult = showResults(file,
                                          usePeptideSummary,
                                          flags,
                                          minProbability,
                                          maxHitsToReport,
                                          ignoreIonsScoreBelow,
                                          minPepLenInPepSummary,
                                          flags2);
                }
            }

            if (bResult && checkErrors(file))
            {
                returnValue = EXIT_SUCCESS;
            }
        }
    }
    else
    {
        std::cout << "Must supply the name of a .dat file as a command line argument" << std::endl;
    }

    return returnValue;
}

/*****************************************************************************/
/* showResults                                                               */
/* Shows results using either the peptide summary or the protein summary     */
/*****************************************************************************/
static bool showResults(ms_mascotresfile &  file,
                        bool                peptideSummary,
                        const int           flags,
                        const double        minProbability,
                        const int           maxHitsToDisplay,
                        const double        ignoreIonsScoreBelow,
                        const int           minPepLenInPepSummary,
                        const int           flags2)
{
    ms_mascotresults * results;

    if (peptideSummary)
    {
        results = new ms_peptidesummary(file, flags, minProbability, maxHitsToDisplay,
                                        0, ignoreIonsScoreBelow, minPepLenInPepSummary, "", flags2);
    }
    else
    {
        results = new ms_proteinsummary(file, flags, minProbability, maxHitsToDisplay);
    }

    //Stop there is any fatal error occurred
    if (!checkErrors(file))
    {
        return false;
    }

    int family = 1;
    int hit = 1;
    ms_protein * prot = results->getHit(hit);

    while (prot)
    {
        std::string accession   = prot->getAccession();
        std::string description = results->getProteinDescription(accession.c_str());
        double      mass        = results->getProteinMass(accession.c_str());
        int dbIdx               = prot->getDB();

        std::cout << "Protein Hit " << hit;
        if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
        {
            std::cout << "." << family;
        }
        std::cout << "\n===================\n";
        std::cout << "Accession   : " << accession             << std::endl;
        std::cout << "Description : " << description           << std::endl;
        std::cout << "Score       : " << prot->getScore()      << std::endl;
        std::cout << "Mass        : " << mass                  << std::endl;
        std::cout << "Frame       : " << prot->getFrame()      << std::endl;
        std::cout << "Coverage    : " << prot->getCoverage()   << std::endl;
        std::cout << "Peptides    : " << prot->getNumDisplayPeptides()<< std::endl;

        int i;

        // Each protein has a number of peptides that matched - list them:
        for (i=1; i <= prot->getNumPeptides(); i++)
        {
            int query = prot->getPeptideQuery(i);
            int p     = prot->getPeptideP(i);

            if (p != -1
                && query != -1
                && prot->getPeptideDuplicate(i) != ms_protein::DUPE_DuplicateSameQuery)
            {
                ms_peptide * pep;

                if (results->getPeptide(query, p, pep))
                {
                    displayPeptideInfo(false, pep, results,
                                       prot->getPeptideDuplicate(i) == ms_protein::DUPE_Duplicate,
                                       prot->getPeptideIsBold(i),
                                       prot->getPeptideShowCheckbox(i));
                }
            }
        }

        // Now display list of all proteins that contain a subset or a same set of the matching peptides
        if ( (flags & ms_mascotresults::MSRES_GROUP_PROTEINS) || (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS) )
        {
            std::cout << "Proteins matching the same set of peptides:" << std::endl;
            i = 1;
            while ((prot = results->getNextSimilarProteinOf(accession.c_str(), dbIdx, i)) != 0)
            {
                std::string accession = prot->getAccession();
                if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
                {
                    int dbIdx = prot->getDB();
                    if (dbIdx > 1)
                    {
                        std::cout << dbIdx << "::";
                    }
                }
                std::cout << accession.c_str()
                          << " - Total score: " << prot->getScore()
                          << " - Peptides matched: " << prot->getNumDisplayPeptides()
                          << std::endl;
                i++;
            }

            if (flags & ms_mascotresults::MSRES_SHOW_SUBSETS)
            {
                std::cout << "Proteins matching a subset of these peptides:" << std::endl;
                i = 1;
                while ((prot = results->getNextSubsetProteinOf(accession.c_str(), dbIdx, i)) != 0)
                {
                    std::string accession = prot->getAccession();
                    int dbIdx             = prot->getDB();
                    if ( (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS) && dbIdx > 1)
                    {
                        std::cout << dbIdx << "::";
                    }
                    std::cout << accession.c_str()
                              << " - Total score: " << prot->getScore()
                              << " - Peptides matched: " << prot->getNumDisplayPeptides()
                              << std::endl;

                    if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
                    {
                        int j = 1;
                        if (results->getNextSimilarProteinOf(accession.c_str(), dbIdx, j))
                        {
                            std::cout << "  Proteins matching the same set of peptides for this subset:" << std::endl;
                        }
                        ms_protein * similar_subset_prot;
                        while ((similar_subset_prot =
                                results->getNextSimilarProteinOf(accession.c_str(), dbIdx, j)) != 0)
                        {
                            std::string similar_subset_accession = similar_subset_prot->getAccession();
                            int similar_subset_dbIdx             = similar_subset_prot->getDB();
                            std::cout << "  ";
                            if (similar_subset_dbIdx > 1)
                            {
                                std::cout << similar_subset_dbIdx << "::";
                            }
                            std::cout << similar_subset_accession.c_str()
                                      << " - Total score:" << similar_subset_prot->getScore()
                                      << " - Peptides matched: " << similar_subset_prot->getNumDisplayPeptides()
                                      << std::endl;
                            j++;
                        }
                    }

                    i++;
                }
            }
        }

        if (flags & ms_mascotresults::MSRES_CLUSTER_PROTEINS)
        {
            prot = results->getNextFamilyProtein(hit, family++);

            if (!prot)
            {
                hit++;
                prot = results->getHit(hit);
                family = 1;
            }
        }
        else
        {
            hit++;
            prot = results->getHit(hit);
        }
        std::cout << std::endl;
    }

    results->createUnassignedList(ms_mascotresults::SCORE);
    if (results->getNumberOfUnassigned())
    {
        std::cout << "Unassigned list" << std::endl
                  << "---------------" << std::endl;
        for (int u = 1; u <= results->getNumberOfUnassigned(); u++)
        {
            ms_peptide pep = results->getUnassigned(u);
            displayPeptideInfo(false, &pep, results, false, true, true);
        }
    }

    if (peptideSummary)
        displayYellowPopupInfo(results, 1);
    delete results;

    return true;
}

/*****************************************************************************/
/* displayYellowPopupInfo                                                    */
/* Shows the equivalent of the yellow popup box for given query              */
/*****************************************************************************/
static void displayYellowPopupInfo(ms_mascotresults * results, int q)
{
    std::cout << "Score Delta      Hit Protein Peptide" << std::endl;

    int p;

    for (p=1; p <= 10; p++)
    {
        ms_peptide pep = results->getPeptide(q, p);
        std::string seq = pep.getPeptideStr();
        if (!seq.empty())
        {
            std::string tmp = results->getProteinsWithThisPepMatch(q, p, true);

            std::string hit = "   ";
            std::string protein = "      ";
            if (!tmp.empty())
            {
                hit = tmp.substr(0, tmp.find(':'));
                std::string::size_type start = tmp.find(":\"");
                if (start != tmp.rfind(":\""))
                    hit += "+";
                protein = tmp.substr(2 + start, tmp.find("\" ") - start -2);
            }
            std::cout << pep.getIonsScore()   << "  "
                      << pep.getDelta()       << "  "
                      << hit                  <<  "  "
                      << protein              <<  "  "
                      << pep.getPeptideStr()  << std::endl;
        }
    }

    p = 1;
    std::cout << "Accessions that matched query " << q
              << " rank " << p << ":- "
              << results->getProteinsWithThisPepMatch(q, p)
              << std::endl << std::endl;

}

/*****************************************************************************/
/* displayPeptideInfo                                                        */
/* Shows information about a peptide                                         */
/*****************************************************************************/
static void displayPeptideInfo(bool showFullDetails,
                               ms_peptide * p,
                               ms_mascotresults * r,
                               bool isDuplicate,
                               bool isBold,
                               bool showCheckBox)
{
    int q = p->getQuery();

    if (showFullDetails)
    {
        std::cout << "Peptide hit" << std::endl;
        if (p->getAnyMatch())
        {

            std::cout << "  Query       : " << q                          << std::endl;
            std::cout << "  Rank        : " << p->getRank()               << std::endl;
            std::cout << "  Matched     : " << p->getAnyMatch()           << std::endl;
            std::cout << "  missedCleave: " << p->getMissedCleavages()    << std::endl;
            std::cout << "  mrCalc      : " << p->getMrCalc()             << std::endl;
            std::cout << "  delta       : " << p->getDelta()              << std::endl;
            std::cout << "  observed    : " << p->getObserved()           << std::endl;
            std::cout << "  charge      : " << p->getCharge()             << std::endl;
            std::cout << "  mrExp       : " << p->getMrExperimental()     << std::endl;
            std::cout << "  ionsMatched : " << p->getNumIonsMatched()     << std::endl;
            std::cout << "  peptideStr  : " << p->getPeptideStr()         << std::endl;
            std::cout << "  peaksUsed1  : " << p->getPeaksUsedFromIons1() << std::endl;
            std::cout << "  varModsStr  : " << p->getVarModsStr()         << std::endl;
            std::cout << "  readable mod: " << r->getReadableVarMods(q, p->getRank()) << std::endl;
            std::cout << "  tag matches : " << r->getTagString(q, 1) << std::endl;
            std::cout << "  first tag   : 1:" << r->getTagStart(q,1,1)
                                              << ":" << r->getTagEnd(q,1,1)
                                              << ":" << r->getTagSeries(q,1,1) << std::endl;
            std::cout << "  etag drange : " << r->getTagDeltaRangeStart(q, 1)
                                          << "," << r->getTagDeltaRangeEnd(q, 1) << std::endl;
            std::cout << "  ionsScore   : " << p->getIonsScore()          << std::endl;
            std::cout << "  seriesUsed  : " << p->getSeriesUsedStr()      << std::endl;
            std::cout << "  peaksUsed2  : " << p->getPeaksUsedFromIons2() << std::endl;
            std::cout << "  peaksUsed3  : " << p->getPeaksUsedFromIons3() << std::endl;
            std::cout << "  idth, hth, p: "
                      << r->getPeptideIdentityThreshold(q,20) << ", "
                      << r->getHomologyThreshold(q, 20)       << ", "
                      << r->getProbOfPepBeingRandomMatch(p->getIonsScore(), q)
                      << std::endl;
        }
        else
            std::cout << "  No match" << std::endl;
    }
    else
    {
        if (showCheckBox)
            std::cout << "CB ";
        else
            std::cout << "-- ";

        if (isBold)
            std::cout << "BOLD ";
        else
            std::cout << "dim  ";
        std::cout << std::setiosflags(std::ios::left) << std::setw(4)  << std::setfill(' ') << q;
        std::cout << std::setiosflags(std::ios::left) << std::setw(11) << std::setfill(' ') << p->getObserved();
        std::cout << std::setiosflags(std::ios::left) << std::setw(3)  << std::setfill(' ') << p->getRank();
        std::cout << "(";
        std::cout << std::setiosflags(std::ios::left) << std::setw(3)  << std::setfill(' ') << p->getPrettyRank();
        std::cout << ")";
        std::cout << std::setiosflags(std::ios::left) << std::setw(20) << std::setfill(' ') << p->getPeptideStr()
                  << "\t";
        if (isDuplicate)
            std::cout << "(" << p->getIonsScore() << ")";
        else
            std::cout << p->getIonsScore();
        std::cout << "\t";
        std::cout << r->getReadableVarMods(q, p->getRank());
        std::cout << std::endl;
    }
}

/*****************************************************************************/
/* checkErrors                                                               */
/* Print errors and return false if a critical error occurred                */
/*****************************************************************************/
static bool checkErrors(ms_mascotresfile &  file)
{
    if (file.getLastError())
    {
        for (int i=1; i <= file.getNumberOfErrors(); i++)
        {
            std::cout << "Error number: "
                      << file.getErrorNumber(i)
                      << " : "
                      << file.getErrorString(i)
                      << std::endl;
        }
    }

    //Call isValid before clearAllErrors, otherwise this method always returns true
    bool bIsValid = file.isValid();
    file.clearAllErrors();

    return bIsValid;
}

/*

will give the output:

-------------------------------------------------------------
---   Peptide summary report                              ---
-------------------------------------------------------------
Protein Hit 1
===================
Accession   : Q9XZJ2
Description : HEAT SHOCK PROTEIN 70.- Crassostrea gigas (Pacific oyster).
Score       : 286.477
Mass        : 79480.1
Frame       : 0
Coverage    : 57
CB BOLD 1   671.9      1  (1  )DAGTISGLNVLR             95.12
CB BOLD 2   808.3      1  (1  )TTPSYVAFTDTER            74.55
CB BOLD 3   973.9      1  (1  )NQVAMNPNNTIFDAK          89.84
-- BOLD 4   1084.9     3  (3  )IINEPTAAAIAYGLDKK        30.07
Proteins matching the same set of peptides:
Q94805 Total score: 283.374
Proteins matching a subset of these peptides:
AAF09496 Total score: 211.927  Peptides matched: 3
BAB72169 Total score: 199.74  Peptides matched: 3
Q24789 Total score: 199.74  Peptides matched: 3
Q9I9Q5 Total score: 199.74  Peptides matched: 3
AAB93665 Total score: 196.637  Peptides matched: 3
Q9W6Y1 Total score: 196.637  Peptides matched: 3
Q95V47 Total score: 194.46  Peptides matched: 3
Q91993 Total score: 193.534  Peptides matched: 3
T45476 Total score: 191.357  Peptides matched: 3
O01948 Total score: 169.67  Peptides matched: 2
O97150 Total score: 166.567  Peptides matched: 2
AAA64872 Total score: 125.19  Peptides matched: 2
B44261 Total score: 125.19  Peptides matched: 2
P81159 Total score: 125.19  Peptides matched: 2
Q9NJ92 Total score: 125.19  Peptides matched: 2
Q9NJ93 Total score: 125.19  Peptides matched: 2
Q9PUF9 Total score: 125.19  Peptides matched: 2
S21175 Total score: 125.19  Peptides matched: 2
T45473 Total score: 125.19  Peptides matched: 2
JC4610 Total score: 122.087  Peptides matched: 2
O73788 Total score: 122.087  Peptides matched: 2
1ATR Total score: 104.62  Peptides matched: 2
1ATS Total score: 104.62  Peptides matched: 2
1BA0 Total score: 104.62  Peptides matched: 2
1BA1 Total score: 104.62  Peptides matched: 2
1BUPA Total score: 104.62  Peptides matched: 2
1HSC Total score: 104.62  Peptides matched: 2
1KAX Total score: 104.62  Peptides matched: 2
1KAY Total score: 104.62  Peptides matched: 2
1KAZ Total score: 104.62  Peptides matched: 2
1NGC Total score: 104.62  Peptides matched: 2
1NGD Total score: 104.62  Peptides matched: 2
1NGE Total score: 104.62  Peptides matched: 2
1NGF Total score: 104.62  Peptides matched: 2
1NGG Total score: 104.62  Peptides matched: 2
1NGH Total score: 104.62  Peptides matched: 2
1NGI Total score: 104.62  Peptides matched: 2
2BUPA Total score: 104.62  Peptides matched: 2
A25646 Total score: 104.62  Peptides matched: 2
A27077 Total score: 104.62  Peptides matched: 2
A35922 Total score: 104.62  Peptides matched: 2
A44985 Total score: 104.62  Peptides matched: 2
A45635 Total score: 104.62  Peptides matched: 2
A45935 Total score: 104.62  Peptides matched: 2
A48439 Total score: 104.62  Peptides matched: 2
AAA30130 Total score: 104.62  Peptides matched: 2
AAA30569 Total score: 104.62  Peptides matched: 2
AAA33009 Total score: 104.62  Peptides matched: 2
CAA81523 Total score: 104.62  Peptides matched: 2
HHKW7A Total score: 104.62  Peptides matched: 2
HHUM7B Total score: 104.62  Peptides matched: 2
JC2215 Total score: 104.62  Peptides matched: 2
JC4786 Total score: 104.62  Peptides matched: 2
JC5642 Total score: 104.62  Peptides matched: 2
O61003 Total score: 104.62  Peptides matched: 2
O61004 Total score: 104.62  Peptides matched: 2
O73885 Total score: 104.62  Peptides matched: 2
O76274 Total score: 104.62  Peptides matched: 2
O96541 Total score: 104.62  Peptides matched: 2
O96911 Total score: 104.62  Peptides matched: 2
P79984 Total score: 104.62  Peptides matched: 2
PQ0138 Total score: 104.62  Peptides matched: 2
Q27031 Total score: 104.62  Peptides matched: 2
Q43532 Total score: 104.62  Peptides matched: 2
Q93146 Total score: 104.62  Peptides matched: 2
Q93147 Total score: 104.62  Peptides matched: 2
Q94614 Total score: 104.62  Peptides matched: 2
Q95LN9 Total score: 104.62  Peptides matched: 2
Q9GPK0 Total score: 104.62  Peptides matched: 2
Q9GRE8 Total score: 104.62  Peptides matched: 2
Q9H3R6 Total score: 104.62  Peptides matched: 2
Q9M4E6 Total score: 104.62  Peptides matched: 2
Q9M6R1 Total score: 104.62  Peptides matched: 2
Q9NCC8 Total score: 104.62  Peptides matched: 2
Q9NGK9 Total score: 104.62  Peptides matched: 2
Q9NJB7 Total score: 104.62  Peptides matched: 2
Q9SAU8 Total score: 104.62  Peptides matched: 2
Q9TW75 Total score: 104.62  Peptides matched: 2
Q9U545 Total score: 104.62  Peptides matched: 2
Q9UAE9 Total score: 104.62  Peptides matched: 2
S07197 Total score: 104.62  Peptides matched: 2
S11456 Total score: 104.62  Peptides matched: 2
S27004 Total score: 104.62  Peptides matched: 2
S31716 Total score: 104.62  Peptides matched: 2
S36753 Total score: 104.62  Peptides matched: 2
S37165 Total score: 104.62  Peptides matched: 2
T21394 Total score: 104.62  Peptides matched: 2
T45478 Total score: 104.62  Peptides matched: 2
T45479 Total score: 104.62  Peptides matched: 2
A55719 Total score: 101.517  Peptides matched: 2
AAA37859 Total score: 101.517  Peptides matched: 2
AAD11466 Total score: 101.517  Peptides matched: 2
B36590 Total score: 101.517  Peptides matched: 2
B86295 Total score: 101.517  Peptides matched: 2
CAA33735 Total score: 101.517  Peptides matched: 2
HS74_YEAST Total score: 101.517  Peptides matched: 2
Q99KD7 Total score: 101.517  Peptides matched: 2
Q9TUG3 Total score: 101.517  Peptides matched: 2
Q9TX61 Total score: 101.517  Peptides matched: 2
S08211 Total score: 101.517  Peptides matched: 2
S10859 Total score: 101.517  Peptides matched: 2
AAA49563 Total score: 95.12  Peptides matched: 1
1HJOA Total score: 74.55  Peptides matched: 1
1NGA Total score: 74.55  Peptides matched: 1
1QQMA Total score: 74.55  Peptides matched: 1
1QQNA Total score: 74.55  Peptides matched: 1
1QQOA Total score: 74.55  Peptides matched: 1
A25773 Total score: 74.55  Peptides matched: 1
A29160 Total score: 74.55  Peptides matched: 1
A45871 Total score: 74.55  Peptides matched: 1
A48872 Total score: 74.55  Peptides matched: 1
A49242 Total score: 74.55  Peptides matched: 1
AAA03451 Total score: 74.55  Peptides matched: 1
AAA17441 Total score: 74.55  Peptides matched: 1
AAA57233 Total score: 74.55  Peptides matched: 1
AAA78276 Total score: 74.55  Peptides matched: 1
AAB03704 Total score: 74.55  Peptides matched: 1
AAD21815 Total score: 74.55  Peptides matched: 1
AAD21816 Total score: 74.55  Peptides matched: 1
AAL34314 Total score: 74.55  Peptides matched: 1
BAB72167 Total score: 74.55  Peptides matched: 1
BAB72168 Total score: 74.55  Peptides matched: 1
BAB72233 Total score: 74.55  Peptides matched: 1
BAB78505 Total score: 74.55  Peptides matched: 1
CAA52328 Total score: 74.55  Peptides matched: 1
E980236 Total score: 74.55  Peptides matched: 1
HS71_SCHPO Total score: 74.55  Peptides matched: 1
I37564 Total score: 74.55  Peptides matched: 1
I51129 Total score: 74.55  Peptides matched: 1
I54542 Total score: 74.55  Peptides matched: 1
JH0095 Total score: 74.55  Peptides matched: 1
JU0164 Total score: 74.55  Peptides matched: 1
O18474 Total score: 74.55  Peptides matched: 1
O73922 Total score: 74.55  Peptides matched: 1
PC1156 Total score: 74.55  Peptides matched: 1
Q26357 Total score: 74.55  Peptides matched: 1
Q26936 Total score: 74.55  Peptides matched: 1
Q26937 Total score: 74.55  Peptides matched: 1
Q63256 Total score: 74.55  Peptides matched: 1
Q63718 Total score: 74.55  Peptides matched: 1
Q98896 Total score: 74.55  Peptides matched: 1
Q98899 Total score: 74.55  Peptides matched: 1
Q98900 Total score: 74.55  Peptides matched: 1
Q98901 Total score: 74.55  Peptides matched: 1
Q9I8F9 Total score: 74.55  Peptides matched: 1
Q9IAC1 Total score: 74.55  Peptides matched: 1
Q9LU13 Total score: 74.55  Peptides matched: 1
Q9N1U2 Total score: 74.55  Peptides matched: 1
Q9NFT1 Total score: 74.55  Peptides matched: 1
Q9QWJ5 Total score: 74.55  Peptides matched: 1
S09036 Total score: 74.55  Peptides matched: 1
S25585 Total score: 74.55  Peptides matched: 1
S31766 Total score: 74.55  Peptides matched: 1
S37394 Total score: 74.55  Peptides matched: 1
S53357 Total score: 74.55  Peptides matched: 1
S67431 Total score: 74.55  Peptides matched: 1
T19211 Total score: 74.55  Peptides matched: 1
T22169 Total score: 74.55  Peptides matched: 1
T41121 Total score: 74.55  Peptides matched: 1
T43724 Total score: 74.55  Peptides matched: 1
T45468 Total score: 74.55  Peptides matched: 1
JQ1515 Total score: 71.4471  Peptides matched: 1
PC7036 Total score: 71.4471  Peptides matched: 1
Q9UVM0 Total score: 71.4471  Peptides matched: 1
A25089 Total score: 30.07  Peptides matched: 1
A32475 Total score: 30.07  Peptides matched: 1
A42582 Total score: 30.07  Peptides matched: 1
A48469 Total score: 30.07  Peptides matched: 1
AAA28075 Total score: 30.07  Peptides matched: 1
AAA34139 Total score: 30.07  Peptides matched: 1
AAA65099 Total score: 30.07  Peptides matched: 1
AAA92743 Total score: 30.07  Peptides matched: 1
AAA99920 Total score: 30.07  Peptides matched: 1
AAB06397 Total score: 30.07  Peptides matched: 1
AAB53051 Total score: 30.07  Peptides matched: 1
AAB63968 Total score: 30.07  Peptides matched: 1
AAF88019 Total score: 30.07  Peptides matched: 1
BAA13948 Total score: 30.07  Peptides matched: 1
BAB08435 Total score: 30.07  Peptides matched: 1
CAA02784 Total score: 30.07  Peptides matched: 1
CAA27330 Total score: 30.07  Peptides matched: 1
CAA28976 Total score: 30.07  Peptides matched: 1
CAA31393 Total score: 30.07  Peptides matched: 1
CAA31663 Total score: 30.07  Peptides matched: 1
CAA54419 Total score: 30.07  Peptides matched: 1
CAC84456 Total score: 30.07  Peptides matched: 1
D44261 Total score: 30.07  Peptides matched: 1
D90093 Total score: 30.07  Peptides matched: 1
H96605 Total score: 30.07  Peptides matched: 1
HHBYA1 Total score: 30.07  Peptides matched: 1
HS71_CANAL Total score: 30.07  Peptides matched: 1
HS71_PICAN Total score: 30.07  Peptides matched: 1
HS71_YEAST Total score: 30.07  Peptides matched: 1
HS72_PICAN Total score: 30.07  Peptides matched: 1
HS72_YEAST Total score: 30.07  Peptides matched: 1
HS7E_SPIOL Total score: 30.07  Peptides matched: 1
JC7132 Total score: 30.07  Peptides matched: 1
JQ0966 Total score: 30.07  Peptides matched: 1
O45038 Total score: 30.07  Peptides matched: 1
O48563 Total score: 30.07  Peptides matched: 1
O62564 Total score: 30.07  Peptides matched: 1
O65171 Total score: 30.07  Peptides matched: 1
O76306 Total score: 30.07  Peptides matched: 1
O93935 Total score: 30.07  Peptides matched: 1
O94104 Total score: 30.07  Peptides matched: 1
O94106 Total score: 30.07  Peptides matched: 1
P90655 Total score: 30.07  Peptides matched: 1
P91738 Total score: 30.07  Peptides matched: 1
P97966 Total score: 30.07  Peptides matched: 1
Q05829 Total score: 30.07  Peptides matched: 1
Q17310 Total score: 30.07  Peptides matched: 1
Q23712 Total score: 30.07  Peptides matched: 1
Q24895 Total score: 30.07  Peptides matched: 1
Q24928 Total score: 30.07  Peptides matched: 1
Q24952 Total score: 30.07  Peptides matched: 1
Q27078 Total score: 30.07  Peptides matched: 1
Q27121 Total score: 30.07  Peptides matched: 1
Q27146 Total score: 30.07  Peptides matched: 1
Q27147 Total score: 30.07  Peptides matched: 1
Q40924 Total score: 30.07  Peptides matched: 1
Q91624 Total score: 30.07  Peptides matched: 1
Q943K7 Total score: 30.07  Peptides matched: 1
Q94439 Total score: 30.07  Peptides matched: 1
Q961X6 Total score: 30.07  Peptides matched: 1
Q96IS6 Total score: 30.07  Peptides matched: 1
Q96W30 Total score: 30.07  Peptides matched: 1
Q9ATB8 Total score: 30.07  Peptides matched: 1
Q9DC27 Total score: 30.07  Peptides matched: 1
Q9FSY7 Total score: 30.07  Peptides matched: 1
Q9GPM5 Total score: 30.07  Peptides matched: 1
Q9GTX3 Total score: 30.07  Peptides matched: 1
Q9LHA8 Total score: 30.07  Peptides matched: 1
Q9M4E7 Total score: 30.07  Peptides matched: 1
Q9M4E8 Total score: 30.07  Peptides matched: 1
Q9NAX9 Total score: 30.07  Peptides matched: 1
Q9NCC9 Total score: 30.07  Peptides matched: 1
Q9NCD0 Total score: 30.07  Peptides matched: 1
Q9NCD1 Total score: 30.07  Peptides matched: 1
Q9NCD2 Total score: 30.07  Peptides matched: 1
Q9NCD3 Total score: 30.07  Peptides matched: 1
Q9NCD4 Total score: 30.07  Peptides matched: 1
Q9NCD5 Total score: 30.07  Peptides matched: 1
Q9NCD6 Total score: 30.07  Peptides matched: 1
Q9NCD7 Total score: 30.07  Peptides matched: 1
Q9NCD8 Total score: 30.07  Peptides matched: 1
Q9NCD9 Total score: 30.07  Peptides matched: 1
Q9NCE0 Total score: 30.07  Peptides matched: 1
Q9NHB4 Total score: 30.07  Peptides matched: 1
Q9P8E0 Total score: 30.07  Peptides matched: 1
Q9U540 Total score: 30.07  Peptides matched: 1
Q9ZS55 Total score: 30.07  Peptides matched: 1
S03250 Total score: 30.07  Peptides matched: 1
S14949 Total score: 30.07  Peptides matched: 1
S14950 Total score: 30.07  Peptides matched: 1
S18181 Total score: 30.07  Peptides matched: 1
S20139 Total score: 30.07  Peptides matched: 1
S21879 Total score: 30.07  Peptides matched: 1
S21880 Total score: 30.07  Peptides matched: 1
S24782 Total score: 30.07  Peptides matched: 1
S41372 Total score: 30.07  Peptides matched: 1
S42488 Total score: 30.07  Peptides matched: 1
S44168 Total score: 30.07  Peptides matched: 1
S46302 Total score: 30.07  Peptides matched: 1
S49303 Total score: 30.07  Peptides matched: 1
S51682 Total score: 30.07  Peptides matched: 1
S51712 Total score: 30.07  Peptides matched: 1
S53126 Total score: 30.07  Peptides matched: 1
S71171 Total score: 30.07  Peptides matched: 1
T03581 Total score: 30.07  Peptides matched: 1
T04078 Total score: 30.07  Peptides matched: 1
T04080 Total score: 30.07  Peptides matched: 1
T06358 Total score: 30.07  Peptides matched: 1
T06598 Total score: 30.07  Peptides matched: 1
T15513 Total score: 30.07  Peptides matched: 1
T34037 Total score: 30.07  Peptides matched: 1
T45298 Total score: 30.07  Peptides matched: 1
T45474 Total score: 30.07  Peptides matched: 1
T45475 Total score: 30.07  Peptides matched: 1
T45477 Total score: 30.07  Peptides matched: 1
T45517 Total score: 30.07  Peptides matched: 1
T45522 Total score: 30.07  Peptides matched: 1
T46574 Total score: 30.07  Peptides matched: 1
T46650 Total score: 30.07  Peptides matched: 1
T48270 Total score: 30.07  Peptides matched: 1
T48271 Total score: 30.07  Peptides matched: 1
AAB08760 Total score: 26.9671  Peptides matched: 1
AAC05418 Total score: 26.9671  Peptides matched: 1
AAF23276 Total score: 26.9671  Peptides matched: 1
P93937 Total score: 26.9671  Peptides matched: 1
Q91688 Total score: 26.9671  Peptides matched: 1
Q9NCC5 Total score: 26.9671  Peptides matched: 1
Q9NCC6 Total score: 26.9671  Peptides matched: 1
Q9NCC7 Total score: 26.9671  Peptides matched: 1

Protein Hit 2
===================
Accession   : S14992
Description : dnaK-type molecular chaperone hsp70 - soybean
Score       : 166.04
Mass        : 78349.7
Frame       : 0
Coverage    : 45
-- dim  2   808.3      1  (1  )TTPSYVAFTDTER            74.55
-- dim  3   973.9      2  (2  )NQVAMNPQNTVFDAK          61.42
-- dim  4   1084.9     3  (3  )IINEPTAAAIAYGLDKK        30.07
Proteins matching the same set of peptides:
S53498 Total score: 166.04
Proteins matching a subset of these peptides:
AAA74906 Total score: 135.97  Peptides matched: 2
B45871 Total score: 135.97  Peptides matched: 2
HHXL70 Total score: 135.97  Peptides matched: 2
I49761 Total score: 135.97  Peptides matched: 2
O75634 Total score: 135.97  Peptides matched: 2
O88686 Total score: 135.97  Peptides matched: 2
Q96QC9 Total score: 135.97  Peptides matched: 2
Q9R2A1 Total score: 135.97  Peptides matched: 2
S21365 Total score: 135.97  Peptides matched: 2
S41415 Total score: 135.97  Peptides matched: 2
AAA27868 Total score: 61.42  Peptides matched: 1
Q17228 Total score: 61.42  Peptides matched: 1
Q17289 Total score: 61.42  Peptides matched: 1
Q27379 Total score: 61.42  Peptides matched: 1
A34041 Total score: 58.3171  Peptides matched: 1

Protein Hit 3
===================
Accession   : A36333
Description : dnaK-type molecular chaperone Hsc70-4 - fruit fly (Drosophila melanogaster)
Score       : 147.45
Mass        : 77814.5
Frame       : 0
Coverage    : 45
-- dim  2   808.3      1  (1  )TTPSYVAFTDTER            74.55
-- dim  3   973.9      3  (3  )NQVAMNPTQTIFDAK          42.83
-- dim  4   1084.9     3  (3  )IINEPTAAAIAYGLDKK        30.07
Proteins matching the same set of peptides:
AAF55150 Total score: 147.45
Proteins matching a subset of these peptides:

Protein Hit 4
===================
Accession   : A03309
Description : dnaK-type molecular chaperone Dsim/Hsc70-1 - fruit fly (Drosophila simulans) (fragments)
Score       : 147.03
Mass        : 25558.9
Frame       : 0
Coverage    : 28
-- dim  2   808.3      3  (3  )TTPSYVAFTESER            57.19
-- dim  3   973.9      1  (1  )NQVAMNPNNTIFDAK          89.84
Proteins matching the same set of peptides:
AAA28632 Total score: 147.03
JN0668 Total score: 143.927
Proteins matching a subset of these peptides:
B03309 Total score: 57.19  Peptides matched: 1
Q9BIS1 Total score: 57.19  Peptides matched: 1
Q9BIS3 Total score: 57.19  Peptides matched: 1

Protein Hit 5
===================
Accession   : Q95PU3
Description : HEAT SHOCK PROTEIN (HSP70).- Euplotes crassus.
Score       : 113.66
Mass        : 80429.7
Frame       : 0
Coverage    : 30
-- dim  2   808.3      1  (1  )TTPSYVAFTDTER            74.55
CB dim  4   1084.9     1  (1  )IIIEPTAAAIAYGLDKK        39.11
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 6
===================
Accession   : 1NGB
Description : Heat-shock cognate 70kd protein (44kd atpase n-terminal Fragment) (EC 3.6.1.3) mutant with glu 175 replace
d by Gln (e175q) - bovine
Score       : 109.89
Mass        : 45220.2
Frame       : 0
Coverage    : 30
-- dim  2   808.3      1  (1  )TTPSYVAFTDTER            74.55
-- dim  4   1084.9     2  (2  )IINQPTAAAIAYGLDKK        35.34
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 7
===================
Accession   : O61226
Description :
Score       : 90.71
Mass        : 0
Frame       : 0
Coverage    : 30
-- dim  2   808.3      2  (2  )TTPSYVAFTNTER            60.64
-- dim  4   1084.9     3  (3  )IINEPTAAAIAYGLDKK        30.07
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 8
===================
Accession   : P87036
Description :
Score       : 81.27
Mass        : 0
Frame       : 0
Coverage    : 29
-- dim  1   671.9      3  (3  )DAGTIAGLEVLR             51.2
-- dim  4   1084.9     3  (3  )IINEPTAAAIAYGLDKK        30.07
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
A25398 Total score: 51.2  Peptides matched: 1
AAA30204 Total score: 51.2  Peptides matched: 1
AG2111 Total score: 51.2  Peptides matched: 1
CAB59514 Total score: 51.2  Peptides matched: 1
O76958 Total score: 51.2  Peptides matched: 1
S06158 Total score: 51.2  Peptides matched: 1
S74372 Total score: 51.2  Peptides matched: 1
A45515 Total score: 48.0971  Peptides matched: 1
CAA36551 Total score: 48.0971  Peptides matched: 1
Q94594 Total score: 48.0971  Peptides matched: 1
Q9GYW3 Total score: 48.0971  Peptides matched: 1
Q9HG01 Total score: 48.0971  Peptides matched: 1
S11448 Total score: 48.0971  Peptides matched: 1
S52727 Total score: 48.0971  Peptides matched: 1

Score Delta      Hit Protein Peptide
Accessions that matched query 97 rank 1:-

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_summary.cs

Example program for extracting the peptide or protein summary.

/*
##############################################################################
# file: resfile_summary.cs                                                   #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/resfile_summary.cs $#
#     $Author: villek@matrixscience.com $                                                   #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Text.RegularExpressions;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class resfile_summary
    {
        public static int Main(string[] argv)
        {
            // ----- Object creation -----
            if (argv.Length < 1)
            {
                Console.WriteLine("Must specify results filename as parameter");
                return 1;
            }

            int returnValue = 1; //failure

            ms_mascotresfile file = new ms_mascotresfile(argv[0], 0, "");

            if (checkErrors(file))
            {
                /*
                 * The parameters passed to ms_peptidesummary or ms_proteinsummary determine
                 * the type of grouping and the number of proteins and peptides displayed.
                 * Default parameters can be returned using ms_mascotresfile::get_ms_mascotresults_params().
                 * The return values from this function depend on the type of search,
                 * and also on values in the mascot.dat configuration file if that is available.
                 */

                ms_datfile datfile = new ms_datfile("../config/mascot.dat"); //You may need to change this path

                //if the mascot.dat isn't available, use defaults
                ms_mascotoptions mascotOptions = new ms_mascotoptions();

                if (datfile.isValid())
                {
                    mascotOptions = datfile.getMascotOptions();
                }

                uint flags, flags2, minPepLenInPepSummary;
                int maxHitsToReport;
                double minProbability, ignoreIonsScoreBelow;
                bool usePeptideSummary;

                string scriptName = file.get_ms_mascotresults_params(
                                        mascotOptions,
                                        out flags,
                                        out minProbability,
                                        out maxHitsToReport,
                                        out ignoreIonsScoreBelow,
                                        out minPepLenInPepSummary,
                                        out usePeptideSummary,
                                        out flags2);

                bool bResult;
                if (usePeptideSummary)
                {
                    /*
                     * For peptide summary
                     *
                     * Flags defined for hierarchical clustering algorithm:
                     *     flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
                     *            | ms_mascotresults::MSRES_SHOW_SUBSETS
                     *            | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
                     *     flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
                     *
                     * Flags defined for original simple parsimony algorithm:
                     *     flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
                     */

                    Console.WriteLine("-------------------------------------------------------------");
                    Console.WriteLine("---   Peptide summary report                              ---");
                    Console.WriteLine("-------------------------------------------------------------");

                    bResult = showResults(file,
                                          usePeptideSummary,
                                          flags,
                                          minProbability,
                                          maxHitsToReport,
                                          ignoreIonsScoreBelow,
                                          (int)minPepLenInPepSummary,
                                          flags2);
                }
                else
                {
                    // Show results from full protein summary, remove grouping
                    flags &= ~(uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS;
                    flags &= ~(uint)ms_mascotresults.FLAGS.MSRES_SHOW_SUBSETS;

                    Console.WriteLine("-------------------------------------------------------------");
                    Console.WriteLine("---   Full Protein summary report                         ---");
                    Console.WriteLine("-------------------------------------------------------------");

                    bResult = showResults(file,
                                          usePeptideSummary,
                                          flags,
                                          minProbability,
                                          maxHitsToReport,
                                          ignoreIonsScoreBelow,
                                          (int)minPepLenInPepSummary,
                                          flags2);

                    if (bResult && checkErrors(file))
                    {
                        // Show results from concise protein summary, add grouping
                        flags |= (uint)ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS;
                        flags |= (uint)ms_mascotresults.FLAGS.MSRES_SHOW_SUBSETS;

                        Console.WriteLine("-------------------------------------------------------------");
                        Console.WriteLine("---   Concise Protein summary report                      ---");
                        Console.WriteLine("-------------------------------------------------------------");

                        bResult = showResults(file,
                                              usePeptideSummary,
                                              flags,
                                              minProbability,
                                              maxHitsToReport,
                                              ignoreIonsScoreBelow,
                                              (int)minPepLenInPepSummary,
                                              flags2);
                    }
                }

                if (bResult && checkErrors(file))
                {
                    returnValue = 0; //success
                }
            }

            //ms_mascotresults has a reference on ms_mascotresfile, therefore the GC must not delete it too early
            GC.KeepAlive(file);

            return returnValue;
        }

        private static bool showResults(ms_mascotresfile file,
                                        bool pepSum,
                                        uint flags,
                                        double minProteinProb,
                                        int maxHits,
                                        double minIonsScore,
                                        int minPepLenInPepSummary,
                                        uint flags2)
        {
            int hit, num_peps, i, query, p, u, family, dbIdx;
            string accession, description;
            double mass;
            ms_mascotresults results;
            ms_protein prot;
            ms_peptide pep;

            if (pepSum)
            {
                results = new ms_peptidesummary(file,
                    flags,
                    minProteinProb,
                    maxHits,
                    "", //unigene file
                    minIonsScore,
                    minPepLenInPepSummary,
                    null,
                    flags2);
            }
            else
            {
                results = new ms_proteinsummary(file,
                    flags,
                    minProteinProb,
                    maxHits,
                    null,
                    null);
            }

            if (!checkErrors(file))
            {
                return false;
            }

            Console.WriteLine("{0} acid database", ((results.isNA()) ? "Nucleic" : "Amino"));

            family = 1;
            // get hit one
            hit = 1;
            prot = results.getHit(hit);

            while (hit <= results.getNumberOfHits())
            {
                accession = prot.getAccession();
                dbIdx = prot.getDB();
                description = results.getProteinDescription(accession);
                mass = results.getProteinMass(accession);

                if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
                {
                    Console.WriteLine("Protein Hit {0}.{1}\n===================", hit, family);
                }
                else
                {
                    Console.WriteLine("Protein Hit {0}\n===================", hit);
                }
                Console.WriteLine("Accession   : {0}", accession);
                Console.WriteLine("Description : {0}", description);
                Console.WriteLine("Score       : {0:#}", prot.getScore());
                Console.WriteLine("Mass        : {0}", mass);
                Console.WriteLine("Frame       : {0}", prot.getFrame());
                Console.WriteLine("Coverage    : {0}", prot.getCoverage());
                Console.WriteLine("RMS error   : {0}", prot.getRMSDeltas(results));
                Console.WriteLine("Peptides    : {0}", prot.getNumDisplayPeptides());

                // Each protein has a number of peptides that matched - list them
                num_peps = prot.getNumPeptides();
                for (i = 1; i <= num_peps; i++)
                {
                    query = prot.getPeptideQuery(i);
                    p = prot.getPeptideP(i);
                    if (p != -1 && query != -1 && prot.getPeptideDuplicate(i) != ms_protein.DUPLICATE.DUPE_DuplicateSameQuery)
                    {
                        pep = results.getPeptide(query, p);
                        if (pep != null)
                        {
                            displayPeptideInfo(false, pep, results, prot.getPeptideDuplicate(i) == ms_protein.DUPLICATE.DUPE_Duplicate,
                                prot.getPeptideIsBold(i), prot.getPeptideShowCheckbox(i));
                        }
                    }
                }

                // now display list of all proteins that contained subsets or an identical list of the matching peptides

                if ((flags & (uint) ms_mascotresults.FLAGS.MSRES_GROUP_PROTEINS) > 0 ||
                    (flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
                {
                    Console.WriteLine("Proteins matching the same set of peptides:");
                    i = 1;
                    while ((prot = results.getNextSimilarProteinOf(accession, dbIdx, i)) != null)
                    {
                        string similar_accession = prot.getAccession();
                        int similar_dbIdx = prot.getDB();
                        if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0 && similar_dbIdx > 1)
                        {
                            Console.Write("{0}::", similar_dbIdx);
                        }
                        Console.WriteLine("{0} Total score: {1:#}   Peptides matched: {2}", similar_accession,
                                          prot.getScore(), prot.getNumDisplayPeptides());
                        i++;
                    }
                    if ((flags & ((uint) ms_mascotresults.FLAGS.MSRES_SHOW_SUBSETS)) > 0)
                    {
                        Console.WriteLine("Proteins matching a subset of these peptides:");
                        i = 1;
                        while ((prot = results.getNextSubsetProteinOf(accession, dbIdx, i)) != null)
                        {
                            string subset_accession = prot.getAccession();
                            int subset_dbIdx = prot.getDB();
                            if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0 && subset_dbIdx > 1)
                            {
                                Console.Write("{0}::", subset_dbIdx);
                            }
                            Console.WriteLine("{0} Total score: {1:#}   Peptides matched: {2}", subset_accession,
                                              prot.getScore(), prot.getNumDisplayPeptides());

                            if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
                            {
                                int j = 1;
                                if (results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j) != null)
                                {
                                    Console.WriteLine("  Proteins matching the same set of peptides for this subset:");
                                }
                                ms_protein similar_subset_prot;
                                while ((similar_subset_prot =
                                        results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)) != null)
                                {
                                    string similar_subset_accession = similar_subset_prot.getAccession();
                                    int similar_subset_dbIdx        = similar_subset_prot.getDB();
                                    Console.Write("  ");
                                    if (similar_subset_dbIdx > 1)
                                    {
                                        Console.Write("{0}::", similar_subset_dbIdx);
                                    }
                                    Console.WriteLine("{0} Total score: {1:#}   Peptides matched: {2}",
                                                      similar_subset_accession, similar_subset_prot.getScore(),
                                                      similar_subset_prot.getNumDisplayPeptides());
                                    j++;
                                }
                            }

                            i++;
                        }
                    }
                }

                Console.WriteLine();
                Console.WriteLine();

                if ((flags & (uint)ms_mascotresults.FLAGS.MSRES_CLUSTER_PROTEINS) > 0)
                {
                    prot = results.getNextFamilyProtein(hit, family++);

                    if(prot == null)
                    {
                        hit++;
                        prot = results.getHit(hit);
                        family = 1;
                    }
                }
                else
                {
                    hit++;
                    prot = results.getHit(hit);
                }
            }

            results.createUnassignedList(ms_mascotresults.sortBy.SCORE);
            if (results.getNumberOfUnassigned() > 0)
            {
                Console.WriteLine("Unassigned list");
                Console.WriteLine("---------------");
                for (u = 1; u <= results.getNumberOfUnassigned(); u++)
                {
                    pep = results.getUnassigned(u);
                    displayPeptideInfo(false, pep, results, false, true, true);
                }
            }

            if (pepSum) displayYellowPopupInfo(results, 1);

            return true;
        } //method

        private static void displayYellowPopupInfo(ms_mascotresults results, int queryNo)
        {
            int p;
            ms_peptide pep;
            String seq, tmp, hit, protein, morethan = "";
            Regex regex = new Regex(@"(\d):([^ ]*)[ ]*(.*)");

            Console.WriteLine("Score Delta      Hit Protein Peptide");

            for (p = 1; p <= 10; p++)
            {
                if ((pep = results.getPeptide(queryNo, p)) != null)
                {
                    seq = pep.getPeptideStr();
                    if (seq.Length > 0)
                    {
                        tmp = results.getProteinsWithThisPepMatch(queryNo, p, true);
                        hit = "   ";
                        protein = "       ";
                        morethan = "";
                        if (tmp.Length > 0)
                        {
                            if (regex.IsMatch(tmp))
                            {
                                Match OneMatch = regex.Match(tmp);
                                if (OneMatch.Success)
                                {
                                    int groupCount = OneMatch.Groups.Count;
                                    if (groupCount >= 2) hit = OneMatch.Groups[1].Value;
                                    if (groupCount >= 3) protein = OneMatch.Groups[2].Value;
                                    if (groupCount >= 4) morethan = OneMatch.Groups[3].Value;
                                }
                            }
                            if (morethan.Length > 0)
                            {
                                hit = hit+"+";
                            }

                        }
                        Console.WriteLine("{0}  {1}  {2}  {3}  {4}", pep.getIonsScore(), pep.getDelta(), hit, protein, pep.getPeptideStr());
                    }
                }
            }
            p = 1;
            Console.WriteLine("Accessions that matched query {0} rank {1}:- {2}", queryNo, p, results.getProteinsWithThisPepMatch(queryNo, p, false));
        } //method

        private static void displayPeptideInfo(bool showFullDetails, ms_peptide p, ms_mascotresults r, bool isDuplicate, bool isBold, bool showCheckBox)
        {
            int q = p.getQuery();

            if (showFullDetails)
            {
                Console.WriteLine("Peptide hit");
                if (p.getAnyMatch())
                {
                    Console.WriteLine("  Query       : {0}", q);
                    Console.WriteLine("  Rank        : {0}", p.getRank());
                    Console.WriteLine("  Matched     : {0}", p.getAnyMatch());
                    Console.WriteLine("  missedCleave: {0}", p.getMissedCleavages());
                    Console.WriteLine("  mrCalc      : {0}", p.getMrCalc());
                    Console.WriteLine("  delta       : {0}", p.getDelta());
                    Console.WriteLine("  observed    : {0}", p.getObserved());
                    Console.WriteLine("  charge      : {0}", p.getCharge());
                    Console.WriteLine("  mrExp       : {0}", p.getMrExperimental());
                    Console.WriteLine("  ionsMatched : {0}", p.getNumIonsMatched());
                    Console.WriteLine("  peptideStr  : {0}", p.getPeptideStr());
                    Console.WriteLine("  peaksUsed1  : {0}", p.getPeaksUsedFromIons1());
                    Console.WriteLine("  varModsStr  : {0}", p.getVarModsStr());
                    Console.WriteLine("  readable mod: {0}", r.getReadableVarMods(q, p.getRank(), 2));
                    Console.WriteLine("  ionsScore   : {0}", p.getIonsScore());
                    Console.WriteLine("  seriesUsedS : {0}", p.getSeriesUsedStr());
                    Console.WriteLine("  peaksUsed2  : {0}", p.getPeaksUsedFromIons2());
                    Console.WriteLine("  peaksUsed3  : {0}", p.getPeaksUsedFromIons3());
                    Console.WriteLine("  idth, hth, p: {0},  {1},  {2}", r.getPeptideIdentityThreshold(q, 20),
                        r.getHomologyThreshold(q, 20), r.getProbOfPepBeingRandomMatch(p.getIonsScore(), q));
                    Console.WriteLine();
                }
                else
                {
                    Console.WriteLine("  No match");
                }
            }
            else
            {
                if (showCheckBox) Console.Write("CB ");
                else Console.Write("-- ");
                if (isBold) Console.Write("BOLD ");
                else Console.Write("dim  ");

                Console.Write(q.ToString().PadLeft(4));
                Console.Write(" ");
                double observed = p.getObserved();
                Console.Write(" ");
                Console.Write(string.Format("{0}", observed.ToString("0.000000")).PadLeft(11));
                Console.Write(" ");
                Console.Write(p.getRank().ToString().PadLeft(4));
                Console.Write("({0})", p.getPrettyRank().ToString().PadLeft(4));
                Console.Write(" ");
                Console.Write(p.getPeptideStr().ToString().PadLeft(20));
                Console.Write(" ");

                double score = p.getIonsScore();
                Console.Write(string.Format("{0}{1}{2}", (isDuplicate) ? "(" : "", score.ToString("0.00"), (isDuplicate) ? ")" : "").PadLeft(8));
                Console.Write(" ");
                if (r.getReadableVarMods(q, p.getRank(), 2).Length == 0) Console.WriteLine("  0");
                else
                {
                    string let = r.getReadableVarMods(q, p.getRank(), 2).Substring(0, 1);
                    int iLet;
                    if (int.TryParse(let, out iLet))
                    {
                        Console.WriteLine("  {0}", iLet);
                    }
                    else Console.WriteLine("  0");
                }
            }
        } //method

        private static bool checkErrors(ms_mascotresfile file)
        {
            for (int loop = 1; loop <= file.getNumberOfErrors(); loop++)
            {
                Console.WriteLine("Error number: {0} : {1}", file.getErrorNumber(loop), file.getErrorString(loop));
            }

            // Call isValid before clearAllErrors, otherwise this method always returns true
            bool isValid = file.isValid();
            file.clearAllErrors();

            return isValid;
        } //method

    } //class
} //namespace

/*
resfile_summary.exe c:\inetpub\mascot\data\F981123.dat
Will give the following output:

-------------------------------------------------------------
---   Peptide summary report                              ---
-------------------------------------------------------------
Amino acid database
Protein Hit 1
===================
Accession   : CH60_HUMAN
Description : 60 kDa heat shock protein, mitochondrial OS=Homo sapiens GN=HSPD1
PE=1 SV=2
Score       : 1225
Mass        : 61016.38
Frame       : 0
Coverage    : 283
RMS error   : 30.4200726378481
Peptides    : 31
CB BOLD   11   417.182190    1(   1)             APGFGDNR    45.35   0
CB BOLD   12   422.743286    1(   1)             VGEVIVTK    45.74   0
CB BOLD   13   430.732788    1(   1)             IPAMTIAK    36.27   0
CB BOLD   15   451.249908    1(   1)            LSDGVAVLK    51.95   0
CB BOLD   16   456.780609    1(   1)            VGLQVVAVK    59.00   0
CB BOLD   21   480.744690    1(   1)            VTDALNATR    45.33   0
CB BOLD   24   595.785522    1(   1)          EIGNIISDAMK  (56.55)   0
CB BOLD   25   603.771973    1(   1)          EIGNIISDAMK    59.52   0
CB BOLD   26   608.309875    1(   1)         NAGVEGSLIVEK    73.21   0
CB BOLD   27   617.285706    1(   1)         VGGTSDVEVNEK    80.63   0
CB BOLD   31   672.837524    1(   1)         TVIIEQSWGSPK    64.38   0
CB BOLD   34   714.888428    1(   1)       GVMLAVDAVIAELK  (64.52)   0
CB BOLD   35   714.893799    1(   1)       GVMLAVDAVIAELK  (72.61)   0
CB BOLD   36   722.884888    1(   1)       GVMLAVDAVIAELK    75.19   0
CB BOLD   37   722.893372    1(   1)       GVMLAVDAVIAELK  (72.57)   0
CB BOLD   39   752.864319    1(   1)        TLNDELEIIEGMK    89.56   0
CB BOLD   40   760.846130    1(   1)        TLNDELEIIEGMK  (88.82)   0
CB BOLD   45   640.328125    1(   1)   ISSIQSIVPALEIANAHR   101.50   0
CB BOLD   46   960.032715    1(   1)   ISSIQSIVPALEIANAHR  (87.34)   0
CB BOLD   48  1019.510620    1(   1)    IQEIIEQLDVTTSEYEK    52.42   0
CB BOLD   51  1057.053711    1(   1) ALMLQGVDLLADAVAVTMGPK   115.78   0
CB BOLD   52  1065.039917    1(   1) ALMLQGVDLLADAVAVTMGPK  (71.79)   0
CB BOLD   53  1065.062256    1(   1) ALMLQGVDLLADAVAVTMGPK  (26.17)   0
CB BOLD   54  1073.047729    1(   1) ALMLQGVDLLADAVAVTMGPK  (92.82)   2
CB BOLD   58   789.106201    1(   1) KPLVIIAEDVDGEALSTLVLNR  (55.53)   0
CB BOLD   59  1183.156982    1(   1) KPLVIIAEDVDGEALSTLVLNR  (65.46)   0
CB BOLD   60   789.109375    1(   1) KPLVIIAEDVDGEALSTLVLNR    94.59   0
CB BOLD   61   828.123779    1(   1) TALLDAAGVASLLTTAEVVVTEIPK  (26.50)   0
CB BOLD   62   828.132202    1(   1) TALLDAAGVASLLTTAEVVVTEIPK    47.53   0
CB BOLD   64   854.058777    1(   1) LVQDVANNTNEEAGDGTTTATVLAR    75.15   0
CB BOLD   65  1038.503052    1(   1) DMAIATGGAVFGEEGLTLNLEDVQPHDLGK    13.05   0

Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
CH60_PONAB Total score: 1008   Peptides matched: 25
CH60_CRIGR Total score: 951   Peptides matched: 23
CH60_MOUSE Total score: 951   Peptides matched: 23
CH60_RAT Total score: 951   Peptides matched: 23
CH60_BOVIN Total score: 918   Peptides matched: 22
CH60_CHICK Total score: 876   Peptides matched: 19
CH60_MESAU Total score: 664   Peptides matched: 18
CH60C_DROME Total score: 121   Peptides matched: 2
CH60C_ARATH Total score: 91   Peptides matched: 2
HSP60_CANAL Total score: 45   Peptides matched: 1
HSP60_EMENI Total score: 45   Peptides matched: 1
HSP60_PARBA Total score: 45   Peptides matched: 1
HSP60_YEAST Total score: 45   Peptides matched: 1
CH602_VIBPA Total score: 45   Peptides matched: 1
CH602_VIBVU Total score: 45   Peptides matched: 1
CH602_VIBVY Total score: 45   Peptides matched: 1
CH60_EUGGR Total score: 45   Peptides matched: 1

Protein Hit 2
===================
Accession   : CH60_DROME
Description : 60 kDa heat shock protein, mitochondrial OS=Drosophila melanogaste
r GN=Hsp60 PE=1 SV=3
Score       : 174
Mass        : 60770.89
Frame       : 0
Coverage    : 67
RMS error   : 29.5905072791318
Peptides    : 4
-- dim    11   417.182190    1(   1)             APGFGDNR    45.35   0
-- dim    27   617.285706    2(   2)         VGGSSEVEVNEK    41.69   0
-- dim    59  1183.156982    2(   2) KPLVIIAEDIDGEALSTLVVNR    12.20   0
-- dim    64   854.058777    1(   1) LVQDVANNTNEEAGDGTTTATVLAR    75.15   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
HSP60_SCHPO Total score: 87   Peptides matched: 2

Protein Hit 3
===================
Accession   : CH60_CAEEL
Description : Chaperonin homolog Hsp-60, mitochondrial OS=Caenorhabditis elegans
 GN=hsp-60 PE=1 SV=2
Score       : 135
Mass        : 60063.75
Frame       : 0
Coverage    : 21
RMS error   : 36.5383063193603
Peptides    : 3
-- dim    11   417.182190    1(   1)             APGFGDNR    45.35   0
-- dim    39   752.864319    2(   1)        TLNDELELIEGMK    89.56   0
-- dim    40   760.846130    2(   1)        TLNDELELIEGMK  (88.82)   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 4
===================
Accession   : CH60_STRM5
Description : 60 kDa chaperonin OS=Stenotrophomonas maltophilia (strain R551-3)
GN=groL PE=3 SV=1
Score       : 42
Mass        : 57311.84
Frame       : 0
Coverage    : 9
RMS error   : 76.92376960617
Peptides    : 1
-- dim    16   456.780609    2(   2)            GIVKVVAVK    42.20   0
Proteins matching the same set of peptides:
CH60_STRMK Total score: 42   Peptides matched: 1
CH60_XANAC Total score: 42   Peptides matched: 1
CH60_XANC5 Total score: 42   Peptides matched: 1
CH60_XANC8 Total score: 42   Peptides matched: 1
CH60_XANCB Total score: 42   Peptides matched: 1
CH60_XANCH Total score: 42   Peptides matched: 1
CH60_XANCP Total score: 42   Peptides matched: 1
CH60_XANOM Total score: 42   Peptides matched: 1
CH60_XANOP Total score: 42   Peptides matched: 1
CH60_XANOR Total score: 42   Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 5
===================
Accession   : NMDE4_HUMAN
Description :
Score       : 37
Mass        : 0
Frame       : 0
Coverage    : 10
RMS error   : 9.41906700790969
Peptides    : 1
-- dim    16   456.780609    3(   3)           VAAGVAVVAR    37.24   0
Proteins matching the same set of peptides:
NMDE4_MOUSE Total score: 37   Peptides matched: 1
NMDE4_RAT Total score: 36   Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 6
===================
Accession   : YF81_THET2
Description :
Score       : 35
Mass        : 0
Frame       : 0
Coverage    : 9
RMS error   : 37.0214184966023
Peptides    : 1
-- dim    16   456.780609    4(   4)            VAQVLGVVK    34.76   0
Proteins matching the same set of peptides:
Y1944_THET8 Total score: 35   Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 7
===================
Accession   : F4ST_FLACH
Description :
Score       : 34
Mass        : 0
Frame       : 0
Coverage    : 9
RMS error   : 87.8815544838649
Peptides    : 1
-- dim    15   451.249908    2(   2)            LSATGLVLK    33.85   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 8
===================
Accession   : ZN711_HUMAN
Description : Zinc finger protein 711 OS=Homo sapiens GN=ZNF711 PE=1 SV=2
Score       : 31
Mass        : 86190.24
Frame       : 0
Coverage    : 13
RMS error   : 69.4028633218151
Peptides    : 1
CB BOLD   33   714.364929    1(   1)        EASPLSSNKLILR    30.84   0
Proteins matching the same set of peptides:
ZN711_MOUSE Total score: 31   Peptides matched: 1
Proteins matching a subset of these peptides:

Unassigned list
---------------
CB BOLD   14   442.228302    1(   1)             IAIRGLLK    28.47   0
CB BOLD   22  1101.536621    1(   1)          ITVSTSGLVPK    14.40   0
CB BOLD    9   747.396179    1(   1)              DAEDVAK    13.59   0
CB BOLD   23  1101.621704    1(   1)           QLLMVAGVDR    12.04   0
CB BOLD    8   714.372498    1(   1)              LAPAQSK    10.69   0
CB BOLD    4   662.275574    1(   1)              AGNAVCK     9.73   0
CB BOLD   30   663.837891    1(   1)          AQLLEINEKLR     9.54   0
CB BOLD   57   747.036072    1(   1)  AMWRLVDEMVQDGFPTTAR     9.05   0
CB BOLD   55  1099.094727    1(   1) LNAEAVRTLLSANGQKPSEAK     8.05   0
CB BOLD   29   642.353577    1(   1)       VVGVAGQGASALVR     7.91   0
CB BOLD    6   673.349487    1(   1)              AVLGGTR     7.59   0
CB BOLD   28   642.352600    1(   1)         KNVSVSQGPDPR     7.22   0
CB BOLD   38   749.383972    1(   1)       QSTMQRSAAGTSTR     7.10   0
CB BOLD   50  1048.561523    1(   1)   ALDEILEYQNYPVVCAKK     5.70   0
CB BOLD   49  1020.987915    1(   1) VEPPGDKTLKPGPGAHSPEK     5.49   0
CB BOLD   19   932.364380    1(   1)              MHNLMDR     4.61   0
CB BOLD   20   933.499023    1(   1)             SRDPGMVR     3.21   0
CB BOLD   47   665.009583    1(   1)     QTLQVFKYYLMDENGK     2.25   0
CB BOLD   41   886.405884    1(   1)    AGLELADSPVTPEMLGR     1.93   0
CB BOLD   18   930.703003    1(   1)             ASRAQLER     1.60   0
CB BOLD    7   711.364685    1(   1)              GGAHEIK     1.34   0
CB BOLD   32   711.370728    1(   1)        DKAIGYTSCGNHR     1.20   0
CB BOLD   17   930.683105    1(   1)             KIQAEITK     1.00   0
CB BOLD   44   949.550720    1(   1)    LAARWLAEHPHAPSSVR     0.76   0
CB BOLD   43   933.003784    1(   1)    ISATCVPSAVQKWFAEK     0.70   0
CB BOLD    1   498.272888    1(   1)                          0.00   0
CB BOLD    2   500.256012    1(   1)                          0.00   0
CB BOLD    3   575.558411    1(   1)                          0.00   0
CB BOLD    5   662.417175    1(   1)                          0.00   0
CB BOLD   10   747.412476    1(   1)                          0.00   0
CB BOLD   42   932.460815    1(   1)                          0.00   0
CB BOLD   56  1119.045166    1(   1)                          0.00   0
CB BOLD   63   832.798584    1(   1)                          0.00   0
CB BOLD   66  1113.894653    1(   1)                          0.00   0
CB BOLD   67  1116.177490    1(   1)                          0.00   0
Score Delta      Hit Protein Peptide
Accessions that matched query 97 rank 1:-
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_summary.java

Example program for extracting the peptide or protein summary.

/*
##############################################################################
# file: resfile_summary.java                                                 #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
# $Source: parser/examples/test_java/resfile_summary.java $   #
#     $Author: villek@matrixscience.com $                                                   #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

// Note - uses java.util.regex - some lines will need to be commented out
// before this will work on JDK versions older than 1.4.  There are marked
// in the code

import java.util.Date;
import matrix_science.msparser.*;
import java.util.regex.*;           // comment out if using version of JDK prior to 1.4
import java.io.File;

public class resfile_summary {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        int returnValue = -1;

        // ----- Object creation -----
        if (argv.length < 1) {
            System.out.println("Must specify results filename as parameter");
            System.exit(returnValue);
        }

        ms_mascotresfile file = new ms_mascotresfile(argv[0]);
        if (checkErrors(file)) {

            /*
             * The parameters passed to ms_peptidesummary or ms_proteinsummary determine
             * the type of grouping and the number of proteins and peptides displayed.
             * Default parameters can be returned using ms_mascotresfile::get_ms_mascotresults_params().
             * The return values from this function depend on the type of search,
             * and also on values in the mascot.dat configuration file if that is available.
             */

            ms_datfile datfile = new ms_datfile("../config/mascot.dat"); //You may need to change this path

            //if the mascot.dat isn't available, use defaults
            ms_mascotoptions mascotOptions = new ms_mascotoptions();

            if (datfile.isValid())
            {
                mascotOptions = datfile.getMascotOptions();
            }

            boolean[]   usePeptideSummary = {false};
            long[]      flags = {0};
            double[]    minProbability = {0};
            int[]       maxHitsToReport = {0};
            double[]    ignoreIonsScoreBelow = {0};
            long[]      minPepLenInPepSummary = {0};
            long[]      flags2 = {0};

            String scriptName = file.get_ms_mascotresults_params(
                mascotOptions,
                flags,
                minProbability,
                maxHitsToReport,
                ignoreIonsScoreBelow,
                minPepLenInPepSummary,
                usePeptideSummary,
                flags2
            );

            boolean bResult;
            if (usePeptideSummary[0]) {
                /*
                 * For peptide summary
                 *
                 * Flags defined for hierarchical clustering algorithm:
                 *     flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
                 *            | ms_mascotresults::MSRES_SHOW_SUBSETS
                 *            | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
                 *     flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
                 *
                 * Flags defined for original simple parsimony algorithm:
                 *     flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;
                 */

                System.out.println("-------------------------------------------------------------");
                System.out.println("---   Peptide summary report                              ---");
                System.out.println("-------------------------------------------------------------");

                bResult = showResults(file,
                        usePeptideSummary[0],
                        (int)flags[0],
                        minProbability[0],
                        maxHitsToReport[0],
                        "", // Unigene file name
                        ignoreIonsScoreBelow[0],
                        (int)minPepLenInPepSummary[0],
                        (int)flags2[0]
                        );

            } else {

                // Show results from full protein summary, remove grouping
                flags[0] &= ~ms_mascotresults.MSRES_GROUP_PROTEINS;
                flags[0] &= ~ms_mascotresults.MSRES_SHOW_SUBSETS;

                System.out.println("-------------------------------------------------------------");
                System.out.println("---   Full Protein summary report                         ---");
                System.out.println("-------------------------------------------------------------");

                bResult = showResults(file,
                        usePeptideSummary[0],
                        (int)flags[0],
                        minProbability[0],
                        maxHitsToReport[0],
                        "", // Unigene file name
                        ignoreIonsScoreBelow[0],
                        (int)minPepLenInPepSummary[0],
                        (int)flags2[0]
                        );

                if(bResult && checkErrors(file)) {
                    System.out.println();

                    // Show results from concise protein summary, add grouping
                    flags[0] |= ms_mascotresults.MSRES_GROUP_PROTEINS;
                    flags[0] |= ms_mascotresults.MSRES_SHOW_SUBSETS;

                    System.out.println("-------------------------------------------------------------");
                    System.out.println("---   Concise Protein summary report                      ---");
                    System.out.println("-------------------------------------------------------------");

                    bResult = showResults(file,
                            usePeptideSummary[0],
                            (int)flags[0],
                            minProbability[0],
                            maxHitsToReport[0],
                            "", // Unigene file name
                            ignoreIonsScoreBelow[0],
                            (int)minPepLenInPepSummary[0],
                            (int)flags2[0]
                            );
                }
            }

            if (bResult && checkErrors(file)) {
                returnValue = 0;
            }
        }

        System.exit(returnValue);
    }

    private static boolean showResults(ms_mascotresfile file,
                                    boolean pepSum,
                                    int flags,
                                    double minProteinProb,
                                    int maxHits,
                                    String unigeneFile,
                                    double minIonsScore,
                                    int minPepLenInPepSummary,
                                    int flags2){

        ms_mascotresults results=null;
        int family;
        int hit;
        ms_protein prot;
        String accession;
        String description;
        double mass;
        int dbIdx;
        int num_peps;
        int i;
        int query;
        int p;
        int u;
        ms_peptide pep;

        if(pepSum) {
            results = new ms_peptidesummary(file,
                                            flags,
                                            minProteinProb,
                                            maxHits,
                                            unigeneFile,
                                            minIonsScore,
                                            minPepLenInPepSummary,
                                            null,
                                            flags2);
        } else {
            results = new ms_proteinsummary(file,
                                            flags,
                                            minProteinProb,
                                            maxHits,
                                            null,
                                            null);
        }

        //Stop there is any fatal error occurred
        if (!checkErrors(file))
        {
            return false;
        }

        if (results.isNA())
            System.out.println("Nucleic acid database\n");
        else
            System.out.println("Amino acid database ");

        // get hit one
        family = 1;
        hit = 1;
        prot = results.getHit(hit);

        while(hit <= results.getNumberOfHits()) {
            accession     =   prot.getAccession();
            description   =   results.getProteinDescription(accession);
            mass          =   results.getProteinMass(accession);
            dbIdx         =   prot.getDB();

            String protein_hit = "Protein Hit " + hit;
            if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
                protein_hit += "." + family;
            }

            System.out.println(protein_hit+"\n===================");
            System.out.println("Accession   : "+accession);
            System.out.println("Description : "+description);
            System.out.println("Score       : "+roundWholeNumber(prot.getScore()));
            System.out.println("Mass        : "+mass);
            System.out.println("Frame       : "+prot.getFrame());
            System.out.println("Coverage    : "+prot.getCoverage());
            System.out.println("RMS error   : "+prot.getRMSDeltas(results));
            System.out.println("Peptides    : "+prot.getNumDisplayPeptides());

            // Each protein has a number of peptides that matched - list them
            num_peps = prot.getNumPeptides();
            for(i=1; i <= num_peps; i++) {
                query = prot.getPeptideQuery(i);
                p     = prot.getPeptideP(i);
                if((p != -1) && (query != -1) && (prot.getPeptideDuplicate(i) !=
                ms_protein.DUPE_DuplicateSameQuery)) {
                    pep = results.getPeptide(query,p);
                    if(pep != null) {
                        displayPeptideInfo(false,pep,results,prot.getPeptideDuplicate(i)
                        == ms_protein.DUPE_Duplicate, prot.getPeptideIsBold(i),
                        prot.getPeptideShowCheckbox(i));
                    }
                }
            }

            // Now display list of all proteins that contain a subset or a same set of the matching peptides

            if((flags & ms_mascotresults.MSRES_GROUP_PROTEINS) == ms_mascotresults.MSRES_GROUP_PROTEINS
               || (flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
                System.out.println("Proteins matching the same set of peptides:");
                i = 1;

                while((prot = results.getNextSimilarProteinOf(accession, dbIdx, i)) != null) {
                    String similar_accession = prot.getAccession();
                    int similar_dbIdx        = prot.getDB();
                    if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS
                        && similar_dbIdx > 1) {
                        System.out.print(similar_dbIdx + "::");
                    }
                    System.out.print(similar_accession + " - Total score: " + roundWholeNumber(prot.getScore()));
                    System.out.println(" - Peptides matched: " + prot.getNumDisplayPeptides());
                    i++;
                }

                if((flags & ms_mascotresults.MSRES_SHOW_SUBSETS) == ms_mascotresults.MSRES_SHOW_SUBSETS) {
                    System.out.println("Proteins matching a subset of these peptides:");
                    i = 1;
                    while((prot = results.getNextSubsetProteinOf(accession, dbIdx, i)) != null) {
                        String subset_accession = prot.getAccession();
                        int subset_dbIdx     = prot.getDB();
                        if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS
                            && subset_dbIdx > 1) {
                            System.out.print(subset_dbIdx + "::");
                        }
                        System.out.print(subset_accession + " - Total score: " + roundWholeNumber(prot.getScore()));
                        System.out.println(" - Peptides matched: " + prot.getNumDisplayPeptides());

                        if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
                            int j = 1;
                            if(results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j) != null) {
                                System.out.println("  Proteins matching the same set of peptides for this subset:");
                            }
                            ms_protein similar_subset_prot;
                            while((similar_subset_prot = results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)) != null) {
                                String similar_subset_accession = similar_subset_prot.getAccession();
                                int similar_subset_dbIdx = similar_subset_prot.getDB();
                                System.out.print("  ");
                                if(similar_subset_dbIdx > 1) {
                                    System.out.print(similar_subset_dbIdx + "::");
                                }
                                System.out.print(similar_subset_accession + " - Total score: " + roundWholeNumber(similar_subset_prot.getScore()));
                                System.out.println(" - Peptides matched: " + similar_subset_prot.getNumDisplayPeptides());
                                j++;
                            }
                        }

                        i++;
                    }
                }
            }

            if((flags & ms_mascotresults.MSRES_CLUSTER_PROTEINS) == ms_mascotresults.MSRES_CLUSTER_PROTEINS) {
                prot = results.getNextFamilyProtein(hit, family++);
                if(prot == null) {
                    hit++;
                    prot = results.getHit(hit);
                    family = 1;
                }
            } else {
                hit++;
                prot = results.getHit(hit);
            }

            System.out.println("\n");
        }
        results.createUnassignedList(ms_mascotresults.SCORE);
        if(results.getNumberOfUnassigned() > 0) {
            System.out.println("Unassigned list");
            System.out.println("---------------");
            for(u=1; u <= results.getNumberOfUnassigned(); u++) {
                pep = results.getUnassigned(u);
                displayPeptideInfo(false, pep, results, false, true, true);
            }
        }

        if(pepSum) displayYellowPopupInfo(results,97);

        return true;
    }

    private static void displayYellowPopupInfo (ms_mascotresults results, int queryNo) {

        int p;
        ms_peptide pep;
        String seq;
        String tmp;
        String hit;
        String protein;
        String morethan="";

        System.out.println("Score Delta      Hit Protein Peptide");

        for(p=1; p <= 10; p++) {
            pep = results.getPeptide(queryNo,p);
            if(pep != null) {
                seq = pep.getPeptideStr();
                if(!(seq.equals(""))) {
                    tmp = results.getProteinsWithThisPepMatch(queryNo,p,true);
                    hit = "   ";
                    protein = "       ";

                    // comment from here

                    if(!(tmp.equals(""))) {
                        // uses Java 1.4 regex
                        String regex = "(\\d):([^ ]*)[ ]*(.*)";
                        Pattern pat = Pattern.compile(regex);
                        Matcher m = pat.matcher(tmp);

                        if(m.matches()) {
                            int groupCount = m.groupCount();
                            if (groupCount >= 1) hit = m.group(1);
                            if (groupCount >= 2) protein = m.group(2);
                            if (groupCount >= 3) morethan = m.group(3);
                        }
                        if(!(morethan.equals(""))) {
                            hit = hit+"+";
                        }
                    }

                    // to here out if using versions of java prior to 1.4
                    System.out.print(pep.getIonsScore()+ "  "+ pep.getDelta()+ "  ");
                    System.out.println(hit+ "  "+ protein+ " "+ pep.getPeptideStr());
                }
            }
        }
        p=1;
        System.out.println("Accessions that matched query "+ queryNo+ " rank "
        + p+ ":- "+results.getProteinsWithThisPepMatch(queryNo,p, false));
    }

    private static void displayPeptideInfo(boolean showFullDetails, ms_peptide p,
                                           ms_mascotresults r,
                                           boolean isDuplicate,
                                           boolean isBold,
                                           boolean showCheckBox) {
        int q;

        q=p.getQuery();

        if(showFullDetails) {
            System.out.println("Peptide hit");
            if(p.getAnyMatch()) {
                System.out.println("  Query       : "+q);
                System.out.println("  Rank        : "+p.getRank());
                System.out.println("  Matched     : "+p.getAnyMatch());
                System.out.println("  missedCleave: "+p.getMissedCleavages());
                System.out.println("  mrCalc      : "+p.getMrCalc());
                System.out.println("  delta       : "+p.getDelta());
                System.out.println("  observed    : "+p.getObserved());
                System.out.println("  charge      : "+p.getCharge());
                System.out.println("  mrExp       : "+p.getMrExperimental());
                System.out.println("  ionsMatched : "+p.getNumIonsMatched());
                System.out.println("  peptideStr  : "+p.getPeptideStr());
                System.out.println("  peaksUsed1  : "+p.getPeaksUsedFromIons1());
                System.out.println("  varModsStr  : "+p.getVarModsStr());
                System.out.println("  readable mod: "+r.getReadableVarMods(q, p.getRank(),2));
                System.out.println("  ionsScore   : "+p.getIonsScore());
                System.out.println("  seriesUsedS : "+p.getSeriesUsedStr());
                System.out.println("  peaksUsed2  : "+p.getPeaksUsedFromIons2());
                System.out.println("  peaksUsed3  : "+p.getPeaksUsedFromIons3());
                System.out.print("  idth, hth, p: "  +r.getPeptideIdentityThreshold(q,20));
                System.out.print(",  "               +r.getHomologyThreshold(q,20));
                System.out.println(",  "             +r.getProbOfPepBeingRandomMatch(p.getIonsScore(),q));
                System.out.println();
            } else {
                System.out.println("  No match");
            }
        } else {
            if(showCheckBox) System.out.print("CB ");
            else System.out.print("-- ");
            if(isBold) System.out.print("BOLD ");
            else System.out.print("dim  ");

            // java has no printf :
            String query = ""+q;
            String observed = ""+p.getObserved();
            System.out.print(padout(query,4," "));
            if(observed.indexOf(".")>-1) {
                String one = observed.substring(0,observed.indexOf("."));
                String two = observed.substring(observed.indexOf(".")+1,observed.length());
                two = padend(two,6,"0");
                observed = one+"."+two;
            }
            System.out.print(padout(observed,11," "));

            System.out.print(padout(""+p.getRank(),4," "));
            System.out.print("("+padout(""+p.getPrettyRank(),4," ")+")");
            System.out.print(padout(p.getPeptideStr(),20," "));

            double score = p.getIonsScore();
            String scoreString = ""+score;

            if(scoreString.indexOf(".")>-1) {
                String one = scoreString.substring(0,scoreString.indexOf("."));
                String two = scoreString.substring(scoreString.indexOf(".")+1,
                                                   scoreString.length());
                if(isDuplicate) {
                    System.out.print("("+padout(one,3,"")+"."+padend(two,2,"0")+")");
                } else {
                    System.out.print(" "+padout(one,3,"")+"."+padend(two,2,"0")+" ");
                }
            } else {
                System.out.println(scoreString);
            }

            // perl seems to take 1st letter of the readable mod, pad with 2 spaces
            // and ignore (set to 0) any letters, so this does the same (quick & nasty)
            if(r.getReadableVarMods(q,p.getRank(),2).equals("")) System.out.println("  0");
            else {
                String let = r.getReadableVarMods(q,p.getRank(),2).substring(0,1);
                try {
                    int intLet = Integer.parseInt(let);
                    System.out.println("  "+let);
                } catch (NumberFormatException notNumber) {
                    System.out.println("  0");
                }
            }
        }
    }

    private static String padout(String toPrint, int length,String padding) {

        String returnValue="";

        if(toPrint.length() < length) {
            for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
                returnValue += padding;
            }
            returnValue += toPrint;
        }
        else returnValue = toPrint;

        return returnValue;
    }

    private static String padend(String toPrint, int length,String padding) {

        String returnValue=toPrint;

        if(toPrint.length() < length) {
            for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
                returnValue += padding;
            }
        }
        return returnValue;
    }

    private static String roundWholeNumber (double toRound) {
        String myInt = ""+toRound;
        myInt += "\n";
        if(myInt.indexOf(".0\n")>-1) {
            return myInt.substring(0,myInt.indexOf(".0\n"));
        }
        return ""+toRound;
    }

    private static boolean checkErrors(ms_mascotresfile file) {
        if((file.getLastError())>0) {
            for(int loopErrors=1; loopErrors <= file.getNumberOfErrors(); loopErrors++) {
                System.out.print("Error number: "+file.getErrorNumber(loopErrors));
                System.out.print(" : "+file.getErrorString(loopErrors));
                System.out.println("");
            }
        }

        //Call isValid before clearAllErrors, otherwise this method always returns true
        boolean bIsValid = file.isValid();
        file.clearAllErrors();

        return bIsValid;
    }
}

/*

will give the output:

C:>java -classpath .;../java/msparser.jar resfile_summary F981123.dat
-------------------------------------------------------------
---   Peptide summary report                              ---
-------------------------------------------------------------
Amino acid database
Protein Hit 1
===================
Accession   : Q9XZJ2
Description : HEAT SHOCK PROTEIN 70.- Crassostrea gigas (Pacific oyster).
Score       : 286.47705382849546
Mass        : 79480.13
Frame       : 0
Coverage    : 57
RMS error   : 274.58772054111273
Peptides    : 4
CB BOLD    1 671.900000   1(   1)        DAGTISGLNVLR 95.12   0
CB BOLD    2 808.300000   1(   1)       TTPSYVAFTDTER 74.55   0
CB BOLD    3 973.900000   1(   1)     NQVAMNPNNTIFDAK 89.84   0
-- BOLD    41084.900000   3(   3)   IINEPTAAAIAYGLDKK 30.07   0
Proteins matching the same set of peptides:
Q94805 Total score: 283.3741076569909   Peptides matched: 4
Proteins matching a subset of these peptides:
AAF09496 Total score: 211.92705382849545  Peptides matched: 3
Q9I9Q5 Total score: 199.74  Peptides matched: 3
Q24789 Total score: 199.74  Peptides matched: 3
BAB72169 Total score: 199.74  Peptides matched: 3
Q9W6Y1 Total score: 196.63705382849543  Peptides matched: 3
AAB93665 Total score: 196.63705382849543  Peptides matched: 3
Q95V47 Total score: 194.45999999999998  Peptides matched: 3
Q91993 Total score: 193.5341076569909  Peptides matched: 3
T45476 Total score: 191.35705382849545  Peptides matched: 3
O01948 Total score: 169.67000000000002  Peptides matched: 2
O97150 Total score: 166.56705382849543  Peptides matched: 2
Q9NJ92 Total score: 125.19  Peptides matched: 2
Q9NJ93 Total score: 125.19  Peptides matched: 2
Q9PUF9 Total score: 125.19  Peptides matched: 2
S21175 Total score: 125.19  Peptides matched: 2
B44261 Total score: 125.19  Peptides matched: 2
T45473 Total score: 125.19  Peptides matched: 2
AAA64872 Total score: 125.19  Peptides matched: 2
P81159 Total score: 125.19  Peptides matched: 2
JC4610 Total score: 122.08705382849546  Peptides matched: 2
O73788 Total score: 122.08705382849544  Peptides matched: 2
1ATR Total score: 104.62  Peptides matched: 2
1ATS Total score: 104.62  Peptides matched: 2
1BA0 Total score: 104.62  Peptides matched: 2
1BA1 Total score: 104.62  Peptides matched: 2
1BUPA Total score: 104.62  Peptides matched: 2
1HSC Total score: 104.62  Peptides matched: 2
1KAX Total score: 104.62  Peptides matched: 2
1KAY Total score: 104.62  Peptides matched: 2
1KAZ Total score: 104.62  Peptides matched: 2
1NGC Total score: 104.62  Peptides matched: 2
1NGD Total score: 104.62  Peptides matched: 2
1NGE Total score: 104.62  Peptides matched: 2
1NGF Total score: 104.62  Peptides matched: 2
1NGG Total score: 104.62  Peptides matched: 2
1NGH Total score: 104.62  Peptides matched: 2
1NGI Total score: 104.62  Peptides matched: 2
2BUPA Total score: 104.62  Peptides matched: 2
HHKW7A Total score: 104.62  Peptides matched: 2
HHUM7B Total score: 104.62  Peptides matched: 2
Q9GPK0 Total score: 104.62  Peptides matched: 2
Q9GRE8 Total score: 104.62  Peptides matched: 2
Q9H3R6 Total score: 104.62  Peptides matched: 2
Q9M4E6 Total score: 104.62  Peptides matched: 2
Q9M6R1 Total score: 104.62  Peptides matched: 2
Q9NCC8 Total score: 104.62  Peptides matched: 2
Q9NGK9 Total score: 104.62  Peptides matched: 2
Q9NJB7 Total score: 104.62  Peptides matched: 2
Q9SAU8 Total score: 104.62  Peptides matched: 2
Q9TW75 Total score: 104.62  Peptides matched: 2
Q9U545 Total score: 104.62  Peptides matched: 2
Q9UAE9 Total score: 104.62  Peptides matched: 2
Q95LN9 Total score: 104.62  Peptides matched: 2
PQ0138 Total score: 104.62  Peptides matched: 2
JC2215 Total score: 104.62  Peptides matched: 2
JC4786 Total score: 104.62  Peptides matched: 2
JC5642 Total score: 104.62  Peptides matched: 2
S07197 Total score: 104.62  Peptides matched: 2
S11456 Total score: 104.62  Peptides matched: 2
T21394 Total score: 104.62  Peptides matched: 2
A25646 Total score: 104.62  Peptides matched: 2
S27004 Total score: 104.62  Peptides matched: 2
Q27031 Total score: 104.62  Peptides matched: 2
A27077 Total score: 104.62  Peptides matched: 2
AAA30130 Total score: 104.62  Peptides matched: 2
AAA30569 Total score: 104.62  Peptides matched: 2
S31716 Total score: 104.62  Peptides matched: 2
AAA33009 Total score: 104.62  Peptides matched: 2
A35922 Total score: 104.62  Peptides matched: 2
S36753 Total score: 104.62  Peptides matched: 2
S37165 Total score: 104.62  Peptides matched: 2
Q43532 Total score: 104.62  Peptides matched: 2
A44985 Total score: 104.62  Peptides matched: 2
T45478 Total score: 104.62  Peptides matched: 2
T45479 Total score: 104.62  Peptides matched: 2
A45635 Total score: 104.62  Peptides matched: 2
A45935 Total score: 104.62  Peptides matched: 2
A48439 Total score: 104.62  Peptides matched: 2
O61003 Total score: 104.62  Peptides matched: 2
O61004 Total score: 104.62  Peptides matched: 2
O73885 Total score: 104.62  Peptides matched: 2
O76274 Total score: 104.62  Peptides matched: 2
P79984 Total score: 104.62  Peptides matched: 2
CAA81523 Total score: 104.62  Peptides matched: 2
Q93146 Total score: 104.62  Peptides matched: 2
Q93147 Total score: 104.62  Peptides matched: 2
Q94614 Total score: 104.62  Peptides matched: 2
O96541 Total score: 104.62  Peptides matched: 2
O96911 Total score: 104.62  Peptides matched: 2
Q9TUG3 Total score: 101.51705382849545  Peptides matched: 2
Q9TX61 Total score: 101.51705382849545  Peptides matched: 2
HS74_YEAST Total score: 101.51705382849545  Peptides matched: 2
Q99KD7 Total score: 101.51705382849545  Peptides matched: 2
S08211 Total score: 101.51705382849545  Peptides matched: 2
S10859 Total score: 101.51705382849545  Peptides matched: 2
AAD11466 Total score: 101.51705382849545  Peptides matched: 2
CAA33735 Total score: 101.51705382849545  Peptides matched: 2
B36590 Total score: 101.51705382849545  Peptides matched: 2
AAA37859 Total score: 101.51705382849545  Peptides matched: 2
A55719 Total score: 101.51705382849545  Peptides matched: 2
B86295 Total score: 101.51705382849545  Peptides matched: 2
AAA49563 Total score: 95.12  Peptides matched: 1
1HJOA Total score: 74.55  Peptides matched: 1
1NGA Total score: 74.55  Peptides matched: 1
1QQMA Total score: 74.55  Peptides matched: 1
1QQNA Total score: 74.55  Peptides matched: 1
1QQOA Total score: 74.55  Peptides matched: 1
Q9I8F9 Total score: 74.55  Peptides matched: 1
Q9IAC1 Total score: 74.55  Peptides matched: 1
Q9LU13 Total score: 74.55  Peptides matched: 1
Q9N1U2 Total score: 74.55  Peptides matched: 1
Q9NFT1 Total score: 74.55  Peptides matched: 1
Q9QWJ5 Total score: 74.55  Peptides matched: 1
HS71_SCHPO Total score: 74.55  Peptides matched: 1
JH0095 Total score: 74.55  Peptides matched: 1
JU0164 Total score: 74.55  Peptides matched: 1
PC1156 Total score: 74.55  Peptides matched: 1
AAA03451 Total score: 74.55  Peptides matched: 1
AAB03704 Total score: 74.55  Peptides matched: 1
S09036 Total score: 74.55  Peptides matched: 1
AAA17441 Total score: 74.55  Peptides matched: 1
O18474 Total score: 74.55  Peptides matched: 1
T19211 Total score: 74.55  Peptides matched: 1
AAD21815 Total score: 74.55  Peptides matched: 1
AAD21816 Total score: 74.55  Peptides matched: 1
T22169 Total score: 74.55  Peptides matched: 1
S25585 Total score: 74.55  Peptides matched: 1
A25773 Total score: 74.55  Peptides matched: 1
Q26357 Total score: 74.55  Peptides matched: 1
Q26936 Total score: 74.55  Peptides matched: 1
Q26937 Total score: 74.55  Peptides matched: 1
A29160 Total score: 74.55  Peptides matched: 1
S31766 Total score: 74.55  Peptides matched: 1
AAL34314 Total score: 74.55  Peptides matched: 1
S37394 Total score: 74.55  Peptides matched: 1
I37564 Total score: 74.55  Peptides matched: 1
T41121 Total score: 74.55  Peptides matched: 1
T43724 Total score: 74.55  Peptides matched: 1
T45468 Total score: 74.55  Peptides matched: 1
A45871 Total score: 74.55  Peptides matched: 1
A48872 Total score: 74.55  Peptides matched: 1
A49242 Total score: 74.55  Peptides matched: 1
I51129 Total score: 74.55  Peptides matched: 1
CAA52328 Total score: 74.55  Peptides matched: 1
S53357 Total score: 74.55  Peptides matched: 1
I54542 Total score: 74.55  Peptides matched: 1
AAA57233 Total score: 74.55  Peptides matched: 1
Q63256 Total score: 74.55  Peptides matched: 1
Q63718 Total score: 74.55  Peptides matched: 1
S67431 Total score: 74.55  Peptides matched: 1
BAB72167 Total score: 74.55  Peptides matched: 1
BAB72168 Total score: 74.55  Peptides matched: 1
BAB72233 Total score: 74.55  Peptides matched: 1
O73922 Total score: 74.55  Peptides matched: 1
AAA78276 Total score: 74.55  Peptides matched: 1
BAB78505 Total score: 74.55  Peptides matched: 1
Q98896 Total score: 74.55  Peptides matched: 1
Q98899 Total score: 74.55  Peptides matched: 1
Q98900 Total score: 74.55  Peptides matched: 1
Q98901 Total score: 74.55  Peptides matched: 1
E980236 Total score: 74.55  Peptides matched: 1
Q9UVM0 Total score: 71.44705382849544  Peptides matched: 1
JQ1515 Total score: 71.44705382849544  Peptides matched: 1
PC7036 Total score: 71.44705382849544  Peptides matched: 1
HHBYA1 Total score: 30.07  Peptides matched: 1
HS7E_SPIOL Total score: 30.07  Peptides matched: 1
Q9ATB8 Total score: 30.07  Peptides matched: 1
Q9DC27 Total score: 30.07  Peptides matched: 1
Q9FSY7 Total score: 30.07  Peptides matched: 1
Q9GPM5 Total score: 30.07  Peptides matched: 1
Q9GTX3 Total score: 30.07  Peptides matched: 1
Q9LHA8 Total score: 30.07  Peptides matched: 1
Q9M4E7 Total score: 30.07  Peptides matched: 1
Q9M4E8 Total score: 30.07  Peptides matched: 1
Q9NAX9 Total score: 30.07  Peptides matched: 1
Q9NCC9 Total score: 30.07  Peptides matched: 1
Q9NCD0 Total score: 30.07  Peptides matched: 1
Q9NCD1 Total score: 30.07  Peptides matched: 1
Q9NCD2 Total score: 30.07  Peptides matched: 1
Q9NCD3 Total score: 30.07  Peptides matched: 1
Q9NCD4 Total score: 30.07  Peptides matched: 1
Q9NCD5 Total score: 30.07  Peptides matched: 1
Q9NCD6 Total score: 30.07  Peptides matched: 1
Q9NCD7 Total score: 30.07  Peptides matched: 1
Q9NCD8 Total score: 30.07  Peptides matched: 1
Q9NCD9 Total score: 30.07  Peptides matched: 1
Q9NCE0 Total score: 30.07  Peptides matched: 1
Q9NHB4 Total score: 30.07  Peptides matched: 1
Q9P8E0 Total score: 30.07  Peptides matched: 1
Q9U540 Total score: 30.07  Peptides matched: 1
Q9ZS55 Total score: 30.07  Peptides matched: 1
HS71_CANAL Total score: 30.07  Peptides matched: 1
HS71_PICAN Total score: 30.07  Peptides matched: 1
HS71_YEAST Total score: 30.07  Peptides matched: 1
HS72_PICAN Total score: 30.07  Peptides matched: 1
HS72_YEAST Total score: 30.07  Peptides matched: 1
Q96IS6 Total score: 30.07  Peptides matched: 1
Q96W30 Total score: 30.07  Peptides matched: 1
Q943K7 Total score: 30.07  Peptides matched: 1
Q961X6 Total score: 30.07  Peptides matched: 1
JQ0966 Total score: 30.07  Peptides matched: 1
CAA02784 Total score: 30.07  Peptides matched: 1
S03250 Total score: 30.07  Peptides matched: 1
T03581 Total score: 30.07  Peptides matched: 1
T04078 Total score: 30.07  Peptides matched: 1
T04080 Total score: 30.07  Peptides matched: 1
Q05829 Total score: 30.07  Peptides matched: 1
T06358 Total score: 30.07  Peptides matched: 1
AAB06397 Total score: 30.07  Peptides matched: 1
T06598 Total score: 30.07  Peptides matched: 1
JC7132 Total score: 30.07  Peptides matched: 1
BAB08435 Total score: 30.07  Peptides matched: 1
BAA13948 Total score: 30.07  Peptides matched: 1
S14949 Total score: 30.07  Peptides matched: 1
S14950 Total score: 30.07  Peptides matched: 1
T15513 Total score: 30.07  Peptides matched: 1
Q17310 Total score: 30.07  Peptides matched: 1
S18181 Total score: 30.07  Peptides matched: 1
S20139 Total score: 30.07  Peptides matched: 1
S21879 Total score: 30.07  Peptides matched: 1
S21880 Total score: 30.07  Peptides matched: 1
Q23712 Total score: 30.07  Peptides matched: 1
S24782 Total score: 30.07  Peptides matched: 1
Q24895 Total score: 30.07  Peptides matched: 1
Q24928 Total score: 30.07  Peptides matched: 1
Q24952 Total score: 30.07  Peptides matched: 1
A25089 Total score: 30.07  Peptides matched: 1
Q27078 Total score: 30.07  Peptides matched: 1
Q27121 Total score: 30.07  Peptides matched: 1
Q27146 Total score: 30.07  Peptides matched: 1
Q27147 Total score: 30.07  Peptides matched: 1
CAA27330 Total score: 30.07  Peptides matched: 1
AAA28075 Total score: 30.07  Peptides matched: 1
CAA28976 Total score: 30.07  Peptides matched: 1
CAA31393 Total score: 30.07  Peptides matched: 1
CAA31663 Total score: 30.07  Peptides matched: 1
A32475 Total score: 30.07  Peptides matched: 1
T34037 Total score: 30.07  Peptides matched: 1
AAA34139 Total score: 30.07  Peptides matched: 1
Q40924 Total score: 30.07  Peptides matched: 1
S41372 Total score: 30.07  Peptides matched: 1
S42488 Total score: 30.07  Peptides matched: 1
A42582 Total score: 30.07  Peptides matched: 1
S44168 Total score: 30.07  Peptides matched: 1
D44261 Total score: 30.07  Peptides matched: 1
O45038 Total score: 30.07  Peptides matched: 1
T45298 Total score: 30.07  Peptides matched: 1
T45474 Total score: 30.07  Peptides matched: 1
T45475 Total score: 30.07  Peptides matched: 1
T45477 Total score: 30.07  Peptides matched: 1
T45517 Total score: 30.07  Peptides matched: 1
T45522 Total score: 30.07  Peptides matched: 1
S46302 Total score: 30.07  Peptides matched: 1
T46574 Total score: 30.07  Peptides matched: 1
T46650 Total score: 30.07  Peptides matched: 1
T48270 Total score: 30.07  Peptides matched: 1
T48271 Total score: 30.07  Peptides matched: 1
A48469 Total score: 30.07  Peptides matched: 1
O48563 Total score: 30.07  Peptides matched: 1
S49303 Total score: 30.07  Peptides matched: 1
S51682 Total score: 30.07  Peptides matched: 1
S51712 Total score: 30.07  Peptides matched: 1
AAB53051 Total score: 30.07  Peptides matched: 1
S53126 Total score: 30.07  Peptides matched: 1
CAA54419 Total score: 30.07  Peptides matched: 1
O62564 Total score: 30.07  Peptides matched: 1
AAB63968 Total score: 30.07  Peptides matched: 1
AAA65099 Total score: 30.07  Peptides matched: 1
O65171 Total score: 30.07  Peptides matched: 1
S71171 Total score: 30.07  Peptides matched: 1
O76306 Total score: 30.07  Peptides matched: 1
CAC84456 Total score: 30.07  Peptides matched: 1
AAF88019 Total score: 30.07  Peptides matched: 1
D90093 Total score: 30.07  Peptides matched: 1
P90655 Total score: 30.07  Peptides matched: 1
Q91624 Total score: 30.07  Peptides matched: 1
P91738 Total score: 30.07  Peptides matched: 1
AAA92743 Total score: 30.07  Peptides matched: 1
O93935 Total score: 30.07  Peptides matched: 1
O94104 Total score: 30.07  Peptides matched: 1
O94106 Total score: 30.07  Peptides matched: 1
Q94439 Total score: 30.07  Peptides matched: 1
H96605 Total score: 30.07  Peptides matched: 1
P97966 Total score: 30.07  Peptides matched: 1
AAA99920 Total score: 30.07  Peptides matched: 1
Q9NCC5 Total score: 26.967053828495448  Peptides matched: 1
Q9NCC6 Total score: 26.967053828495448  Peptides matched: 1
Q9NCC7 Total score: 26.967053828495448  Peptides matched: 1
AAC05418 Total score: 26.967053828495448  Peptides matched: 1
AAB08760 Total score: 26.967053828495448  Peptides matched: 1
AAF23276 Total score: 26.967053828495448  Peptides matched: 1
Q91688 Total score: 26.967053828495448  Peptides matched: 1
P93937 Total score: 26.967053828495448  Peptides matched: 1

Protein Hit 2
===================
Accession   : S14992
Description : dnaK-type molecular chaperone hsp70 - soybean
Score       : 166.04
Mass        : 78349.66
Frame       : 0
Coverage    : 45
RMS error   : 316.0424369822863
Peptides    : 3
-- dim     2 808.300000   1(   1)       TTPSYVAFTDTER 74.55   0
-- dim     3 973.900000   2(   2)     NQVAMNPQNTVFDAK 61.42   0
-- dim     41084.900000   3(   3)   IINEPTAAAIAYGLDKK 30.07   0
Proteins matching the same set of peptides:
S53498 Total score: 166.04   Peptides matched: 3
Proteins matching a subset of these peptides:
Q9R2A1 Total score: 135.97  Peptides matched: 2
HHXL70 Total score: 135.97  Peptides matched: 2
Q96QC9 Total score: 135.97  Peptides matched: 2
S21365 Total score: 135.97  Peptides matched: 2
S41415 Total score: 135.97  Peptides matched: 2
B45871 Total score: 135.97  Peptides matched: 2
I49761 Total score: 135.97  Peptides matched: 2
AAA74906 Total score: 135.97  Peptides matched: 2
O75634 Total score: 135.97  Peptides matched: 2
O88686 Total score: 135.97  Peptides matched: 2
Q17228 Total score: 61.42  Peptides matched: 1
Q17289 Total score: 61.42  Peptides matched: 1
Q27379 Total score: 61.42  Peptides matched: 1
AAA27868 Total score: 61.42  Peptides matched: 1
A34041 Total score: 58.317053828495446  Peptides matched: 1

Protein Hit 3
===================
Accession   : A36333
Description : dnaK-type molecular chaperone Hsc70-4 - fruit fly (Drosophila melanogaster)
Score       : 147.45
Mass        : 77814.51
Frame       : 0
Coverage    : 45
RMS error   : 464.59967503590167
Peptides    : 3
-- dim     2 808.300000   1(   1)       TTPSYVAFTDTER 74.55   0
-- dim     3 973.900000   3(   3)     NQVAMNPTQTIFDAK 42.83   0
-- dim     41084.900000   3(   3)   IINEPTAAAIAYGLDKK 30.07   0
Proteins matching the same set of peptides:
AAF55150 Total score: 147.45   Peptides matched: 3
Proteins matching a subset of these peptides:

Protein Hit 4
===================
Accession   : A03309
Description : dnaK-type molecular chaperone Dsim/Hsc70-1 - fruit fly (Drosophila simulans) (fragments)
Score       : 147.03
Mass        : 25558.88
Frame       : 0
Coverage    : 28
RMS error   : 365.7556240028131
Peptides    : 2
-- dim     2 808.300000   3(   3)       TTPSYVAFTESER 57.19   0
-- dim     3 973.900000   1(   1)     NQVAMNPNNTIFDAK 89.84   0
Proteins matching the same set of peptides:
AAA28632 Total score: 147.03   Peptides matched: 2
JN0668 Total score: 143.92705382849545   Peptides matched: 2
Proteins matching a subset of these peptides:
Q9BIS1 Total score: 57.19  Peptides matched: 1
Q9BIS3 Total score: 57.19  Peptides matched: 1
B03309 Total score: 57.19  Peptides matched: 1

Protein Hit 5
===================
Accession   : Q95PU3
Description : HEAT SHOCK PROTEIN (HSP70).- Euplotes crassus.
Score       : 113.66
Mass        : 80429.66
Frame       : 0
Coverage    : 30
RMS error   : 407.38524706491955
Peptides    : 2
-- dim     2 808.300000   1(   1)       TTPSYVAFTDTER 74.55   0
CB dim     41084.900000   1(   1)   IIIEPTAAAIAYGLDKK 39.11   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 6
===================
Accession   : 1NGB
Description : Heat-shock cognate 70kd protein (44kd atpase n-terminal Fragment) (EC 3.6.1.3) mutant with glu 175 replace
d by Gln (e175q) - bovine
Score       : 109.89
Mass        : 45220.22
Frame       : 0
Coverage    : 30
RMS error   : 411.19901615189326
Peptides    : 2
-- dim     2 808.300000   1(   1)       TTPSYVAFTDTER 74.55   0
-- dim     41084.900000   2(   2)   IINQPTAAAIAYGLDKK 35.34   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 7
===================
Accession   : O61226
Description :
Score       : 90.71000000000001
Mass        : 0.0
Frame       : 0
Coverage    : 30
RMS error   : 804.0968914838121
Peptides    : 2
-- dim     2 808.300000   2(   2)       TTPSYVAFTNTER 60.64   0
-- dim     41084.900000   3(   3)   IINEPTAAAIAYGLDKK 30.07   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 8
===================
Accession   : P87036
Description :
Score       : 81.27000000000001
Mass        : 0.0
Frame       : 0
Coverage    : 29
RMS error   : 570.361400922183
Peptides    : 2
-- dim     1 671.900000   3(   3)        DAGTIAGLEVLR 51.20   0
-- dim     41084.900000   3(   3)   IINEPTAAAIAYGLDKK 30.07   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
AG2111 Total score: 51.2  Peptides matched: 1
S06158 Total score: 51.2  Peptides matched: 1
A25398 Total score: 51.2  Peptides matched: 1
AAA30204 Total score: 51.2  Peptides matched: 1
CAB59514 Total score: 51.2  Peptides matched: 1
S74372 Total score: 51.2  Peptides matched: 1
O76958 Total score: 51.2  Peptides matched: 1
Q9GYW3 Total score: 48.09705382849545  Peptides matched: 1
Q9HG01 Total score: 48.09705382849545  Peptides matched: 1
S11448 Total score: 48.09705382849545  Peptides matched: 1
CAA36551 Total score: 48.09705382849545  Peptides matched: 1
A45515 Total score: 48.09705382849545  Peptides matched: 1
S52727 Total score: 48.09705382849545  Peptides matched: 1
Q94594 Total score: 48.09705382849545  Peptides matched: 1

Score Delta      Hit Protein Peptide
Accessions that matched query 97 rank 1:-

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:19


resfile_summary.pl

Example program for extracting the peptide or protein summary.

#!/usr/local/bin/perl
##############################################################################
# file: resfile_summary.pl                                                   #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/resfile_summary.pl $ #
#     $Author: villek@matrixscience.com $                                                   #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0])) { die "Must specify results filename as parameter"; }

my $returnValue = 1;

my $resfile = new msparser::ms_mascotresfile($ARGV[0]);

if (checkErrors($resfile)) {
    # The parameters passed to ms_peptidesummary or ms_proteinsummary determine
    # the type of grouping and the number of proteins and peptides displayed.
    # Default parameters can be returned using ms_mascotresfile::get_ms_mascotresults_params().
    # The return values from this function depend on the type of search,
    # and also on values in the mascot.dat configuration file if that is available.

    my $datfile = new msparser::ms_datfile("../config/mascot.dat"); # You may need to change this path

    # if the mascot.dat isn't available, use defaults
    my $mascotOptions;

    if ($datfile->isValid()) {
       $mascotOptions = $datfile->getMascotOptions();
    }

    my ($scriptName,
        $flags,
        $minProbability,
        $maxHitsToReport,
        $ignoreIonsScoreBelow,
        $minPepLenInPepSummary,
        $usePeptideSummary,
        $flags2
    ) = $resfile->get_ms_mascotresults_params($datfile->getMascotOptions);

    my $bResult;
    if ($usePeptideSummary) {

        # For peptide summary
        #
        # Flags defined for hierarchical clustering algorithm:
        #     flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
        #            | ms_mascotresults::MSRES_SHOW_SUBSETS
        #            | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
        #     flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
        #
        # Flags defined for original simple parsimony algorithm:
        #     flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;

        print "-------------------------------------------------------------\n";
        print "---   Peptide summary report                              ---\n";
        print "-------------------------------------------------------------\n";

        $bResult = show_results(
                                $resfile,
                                $usePeptideSummary,
                                $flags,
                                $minProbability,
                                $maxHitsToReport,
                                $ignoreIonsScoreBelow,
                                $minPepLenInPepSummary,
                                $flags2
                                );
    } else {
        # Show results from full protein summary, remove grouping
        $flags &= ~$msparser::ms_mascotresults::MSRES_GROUP_PROTEINS;
        $flags &= ~$msparser::ms_mascotresults::MSRES_SHOW_SUBSETS;

        print "-------------------------------------------------------------\n";
        print "---   Full Protein summary report                         ---\n";
        print "-------------------------------------------------------------\n";

        $bResult = show_results(
                                $resfile,
                                $usePeptideSummary,
                                $flags,
                                $minProbability,
                                $maxHitsToReport,
                                $ignoreIonsScoreBelow,
                                $minPepLenInPepSummary,
                                $flags2
                                );

        if($bResult and checkErrors($resfile)) {
            # Show results from concise protein summary, add grouping
            $flags |= $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS;
            $flags |= $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS;

            print "-------------------------------------------------------------\n";
            print "---   Concise Protein summary report                      ---\n";
            print "-------------------------------------------------------------\n";

            $bResult = show_results(
                                    $resfile,
                                    $usePeptideSummary,
                                    $flags,
                                    $minProbability,
                                    $maxHitsToReport,
                                    $ignoreIonsScoreBelow,
                                    $minPepLenInPepSummary,
                                    $flags2
                                    );
        }
    }

    if($bResult and checkErrors($resfile)) {
        $returnValue = 0;
    }
}

exit($returnValue);

##############################################################################
# show_results                                                               #
#  - parameter 0 is ms_mascotresfile                                         #
#  - parameter 1 is true for peptide summary, false for protein              #
#  - parameter 2 is the flags for display                                    #
#  - parameter 3 is the minimum protein probability to display               #
#  - parameter 4 is the maximum number of hits to display                    #
#  - parameter 5 is the minimum ions score to use                            #
#  - parameter 6 is the minPepLenInPepSummary to use                         #
##############################################################################
sub show_results {
    my($file, $usePeptideSummary, $flags, $minProteinProb, $maxHits,
     $minIonsScore, $minPepLenInPepSummary, $flags2) = @_;

    my $results;

    if ($usePeptideSummary) {
        $results = new msparser::ms_peptidesummary(
            $file, $flags, $minProteinProb, $maxHits, "", $minIonsScore, $minPepLenInPepSummary, "", $flags2
        );
    } else {
        $results = new msparser::ms_proteinsummary(
            $file, $flags, $minProteinProb, $maxHits
        );
    }

    # Stop there is any fatal error occurred
    if (not checkErrors($file)) {
        return 0;
    }

    my $family = 1;
    my $hit  = 1;
    my $prot = $results->getHit($hit);

    while ($prot) {
        my $accession   = $prot->getAccession();
        my $description = $results->getProteinDescription($accession);
        my $mass        = $results->getProteinMass($accession);
        my $dbIdx       = $prot->getDB();

        if ($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
            print "Protein Hit ", $hit, ".", $family, "\n===================\n";
        }
        else {
            print "Protein Hit ", $hit, "\n===================\n";
        }

        print "Accession   : " , $accession, "\n";
        print "Description : " , $description           , "\n";
        print "Score       : " , $prot->getScore()      , "\n";
        print "Mass        : " , $mass                  , "\n";
        print "Frame       : " , $prot->getFrame()      , "\n";
        print "Coverage    : " , $prot->getCoverage()   , "\n";
        print "RMS error   : " , $prot->getRMSDeltas($results), "\n";
        print "Peptides    : " , $prot->getNumDisplayPeptides(),"\n";

        # Each protein has a number of peptides that matched - list them:
        my $num_peps = $prot->getNumPeptides();

        for my $i (1 .. $num_peps) {
            my $query = $prot->getPeptideQuery($i);
            my $p     = $prot->getPeptideP($i);

            if (
                $p != -1
                    and $query != -1
                    and $prot->getPeptideDuplicate($i) != $msparser::ms_protein::DUPE_DuplicateSameQuery
            ) {
                my $pep = $results->getPeptide($query, $p);
                next unless defined $pep;

                displayPeptideInfo(
                    0, $pep, $results,
                    $prot->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_Duplicate,
                    $prot->getPeptideIsBold($i),
                    $prot->getPeptideShowCheckbox($i)
                );
            }
        }

        # Now display list of all proteins that contained subsets or and
        # identical list of the matching peptides

        if ($flags & $msparser::ms_mascotresults::MSRES_GROUP_PROTEINS or
            $flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
            print "Proteins matching the same set of peptides:\n";

            my $i = 1;
            while (my $prot = $results->getNextSimilarProteinOf($accession, $dbIdx, $i)) {
                my $accession = $prot->getAccession();
                my $dbIdx = $prot->getDB();
                if($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS and $dbIdx > 1) {
                    print $dbIdx, "::";
                }
                print $accession, " - Total score: ", $prot->getScore();
                print " - Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";
                $i++;
            }

            if ($flags & $msparser::ms_mascotresults::MSRES_SHOW_SUBSETS) {
                print "Proteins matching a subset of these peptides:\n";

                my $i = 1;
                while ($prot = $results->getNextSubsetProteinOf($accession, $dbIdx, $i)) {
                    my $accession = $prot->getAccession();
                    my $dbIdx = $prot->getDB();
                    if($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS and $dbIdx > 1) {
                        print $dbIdx, "::";
                    }
                    print $accession,  " - Total score: ", $prot->getScore();
                    print " - Peptides matched: ", $prot->getNumDisplayPeptides(), "\n";

                    if ($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
                        my $j = 1;
                        if($results->getNextSimilarProteinOf($accession, $dbIdx, $j)){
                            print "  Proteins matching the same set of peptides for this subset:\n";
                        }
                        while (my $similar_subset_prot = $results->getNextSimilarProteinOf($accession, $dbIdx, $j)) {
                            my $similar_subset_accession = $similar_subset_prot->getAccession();
                            my $similar_subset_dbIdx = $similar_subset_prot->getDB();
                            print "  ";
                            if($similar_subset_dbIdx > 1) {
                                print $similar_subset_dbIdx, "::";
                            }
                            print $similar_subset_accession, " - Total score: ", $similar_subset_prot->getScore();
                            print " - Peptides matched: ", $similar_subset_prot->getNumDisplayPeptides(), "\n";
                            $j++;
                        }
                    }

                    $i++;
                }
            }
        }

        if ($flags & $msparser::ms_mascotresults::MSRES_CLUSTER_PROTEINS) {
            $prot = $results->getNextFamilyProtein($hit, $family++);

            if(!$prot) {
                $hit++;
                $prot = $results->getHit($hit);
                $family = 1;
            }
        }
        else {
            $hit++;
            $prot = $results->getHit($hit);
        }

        print "\n";
    }

    $results->createUnassignedList($msparser::ms_mascotresults::SCORE);

    if ($results->getNumberOfUnassigned()) {
        print "Unassigned list\n";
        print "---------------\n";

        for my $u (1 .. $results->getNumberOfUnassigned) {
            my $pep = $results->getUnassigned($u);
            displayPeptideInfo(0, $pep, $results, 0, 1, 1);
        }
    }

    if ($usePeptideSummary) {
        print "\n";
        displayYellowPopupInfo($results, 1);
    }

    return 1;
}

##############################################################################
#  displayYellowPopupInfo                                                    #
#  Shows the equivalent of the yellow popup box for given query              #
#  - parameter 0 is the results object                                       #
#  - parameter 1 is the query number                                         #
##############################################################################
sub displayYellowPopupInfo {
    my ($results, $q) = @_;

    my $fmt = "%5s %5s %9s %7s %7s\n";
    printf $fmt, qw(Score Delta Hit Protein Peptide);

    for my $p (1 .. 10) {
        my $pep = $results->getPeptide($q, $p);
        next unless defined $pep;

        my $seq = $pep->getPeptideStr();
        next unless defined $seq;

        my $tmp = $results->getProteinsWithThisPepMatch($q, $p);

        my ($hit, $protein) = ('', '');

        if ($tmp) {
            ($hit, $protein, my $morethan) = $tmp =~ /(\d+):([^ ]*)[ ]*(.*)/;

            if ($morethan) {
                $hit .= "+";
            }
        }

        printf $fmt, $pep->getIonsScore(), $pep->getDelta(), $hit, $protein, $seq;

    }

    my $p = 1;
    print "Accessions that matched query ", $q, " rank ", $p, ":- ",
         $results->getProteinsWithThisPepMatch($q, $p), "\n";
}

##############################################################################
# displayPeptideInfo                                                         #
#  - parameter 0  showFullDetails?                                           #
#  - parameter 1  p                                                          #
#  - parameter 2  ms_mascotresults                                           #
#  - parameter 3  isDuplicate?                                               #
#  - parameter 4  isBold?                                                    #
#  - parameter 5  showCheckBox?                                              #
##############################################################################
sub displayPeptideInfo {
    my ($showFullDetails, $p, $r, $isDuplicate, $isBold, $showCheckBox) = @_;

    my $q = $p->getQuery();

    if (!$showFullDetails) {
        my $fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3d\n";

        printf $fmt,
            $showCheckBox ? "CB" : "--",
            $isBold       ? "BOLD" : "dim",
            $q,
            $p->getObserved,
            $p->getRank,
            $p->getPrettyRank,
            $p->getPeptideStr,
            $isDuplicate ? '(' : '',
            $p->getIonsScore,
            $isDuplicate ? ')' : '',
            $r->getReadableVarMods($q, $p->getRank),
            ;

        return;
    }

    print "Peptide hit\n";

    if ($p->getAnyMatch()) {
        my $fmt = "    %-12s: %s\n";
        printf $fmt, 'Query'       , $q;
        printf $fmt, 'Rank'        , $p->getRank;
        printf $fmt, 'Matched'     , $p->getAnyMatch;
        printf $fmt, 'missedCleave', $p->getMissedCleavages;
        printf $fmt, 'mrCalc'      , $p->getMrCalc;
        printf $fmt, 'delta'       , $p->getDelta;
        printf $fmt, 'observed'    , $p->getObserved;
        printf $fmt, 'charge'      , $p->getCharge;
        printf $fmt, 'mrExp'       , $p->getMrExperimental;
        printf $fmt, 'ionsMatched' , $p->getNumIonsMatched;
        printf $fmt, 'peptideStr'  , $p->getPeptideStr;
        printf $fmt, 'peaksUsed1'  , $p->getPeaksUsedFromIons1;
        printf $fmt, 'varModsStr'  , $p->getVarModsStr;
        printf $fmt, 'readable mod', $r->getReadableVarMods($q, $p->getRank);
        printf $fmt, 'ionsScore'   , $p->getIonsScore;
        printf $fmt, 'seriesUsedS' , $p->getSeriesUsedStr;
        printf $fmt, 'peaksUsed2'  , $p->getPeaksUsedFromIons3;
        printf $fmt, 'peaksUsed3'  , $p->getPeaksUsedFromIons3;
        printf $fmt, 'idth, hth, p', join(', ',
            $r->getPeptideIdentityThreshold($q, 20),
            $r->getHomologyThreshold($q, 20),
            $r->getProbOfPepBeingRandomMatch($p->getIonsScore, $q)
        );
        print "\n";
    } else {
        print "    No match\n";
    }
}

##############################################################################
# checkErrors                                                                #
#  - parameter 0 file is a ms_mascotresfile                                  #
##############################################################################
sub checkErrors() {
    my ($file) = @_;

    if ($file->getLastError()) {
        for my $i (1 .. $file->getNumberOfErrors) {
            print "Error number: ", $file->getErrorNumber($i);
            print " : ", $file->getErrorString($i);
            print "\n";
        }
    }

    #Call isValid before clearAllErrors, otherwise this method always returns true
    my $bIsValid = $file->isValid();
    $file->clearAllErrors();

    return $bIsValid;
}

=pod

Running the program as

perl -I../bin resfile_summary.pl ../data/F981123.dat

will give the following output under Mascot Server 2.3:

-------------------------------------------------------------
---   Peptide summary report                              ---
-------------------------------------------------------------
Protein Hit 1
===================
Accession   : CH60_HUMAN
Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
Score       : 1225.18623376928
Mass        : 61016.38
Frame       : 0
Coverage    : 283
RMS error   : 30.4200726378481
Peptides    : 31
CB BOLD   11  417.182190    1(   1) APGFGDNR             45.35   0
CB BOLD   12  422.743286    1(   1) VGEVIVTK             45.74   0
CB BOLD   13  430.732788    1(   1) IPAMTIAK             36.27   0
CB BOLD   15  451.249908    1(   1) LSDGVAVLK            51.95   0
CB BOLD   16  456.780609    1(   1) VGLQVVAVK            59.00   0
CB BOLD   21  480.744690    1(   1) VTDALNATR            45.33   0
CB BOLD   24  595.785522    1(   1) EIGNIISDAMK          (56.55)   0
CB BOLD   25  603.771973    1(   1) EIGNIISDAMK          59.52   0
CB BOLD   26  608.309875    1(   1) NAGVEGSLIVEK         73.21   0
CB BOLD   27  617.285706    1(   1) VGGTSDVEVNEK         80.63   0
CB BOLD   31  672.837524    1(   1) TVIIEQSWGSPK         64.38   0
CB BOLD   34  714.888428    1(   1) GVMLAVDAVIAELK       (64.52)   0
CB BOLD   35  714.893799    1(   1) GVMLAVDAVIAELK       (72.61)   0
CB BOLD   36  722.884888    1(   1) GVMLAVDAVIAELK       75.19   0
CB BOLD   37  722.893372    1(   1) GVMLAVDAVIAELK       (72.57)   0
CB BOLD   39  752.864319    1(   1) TLNDELEIIEGMK        89.56   0
CB BOLD   40  760.846130    1(   1) TLNDELEIIEGMK        (88.82)   0
CB BOLD   45  640.328125    1(   1) ISSIQSIVPALEIANAHR   101.50   0
CB BOLD   46  960.032715    1(   1) ISSIQSIVPALEIANAHR   (87.34)   0
CB BOLD   48 1019.510620    1(   1) IQEIIEQLDVTTSEYEK    52.42   0
CB BOLD   51 1057.053711    1(   1) ALMLQGVDLLADAVAVTMGPK 115.78   0
CB BOLD   52 1065.039917    1(   1) ALMLQGVDLLADAVAVTMGPK (71.79)   0
CB BOLD   53 1065.062256    1(   1) ALMLQGVDLLADAVAVTMGPK (26.17)   0
CB BOLD   54 1073.047729    1(   1) ALMLQGVDLLADAVAVTMGPK (92.82)   2
CB BOLD   58  789.106201    1(   1) KPLVIIAEDVDGEALSTLVLNR (55.53)   0
CB BOLD   59 1183.156982    1(   1) KPLVIIAEDVDGEALSTLVLNR (65.46)   0
CB BOLD   60  789.109375    1(   1) KPLVIIAEDVDGEALSTLVLNR 94.59   0
CB BOLD   61  828.123779    1(   1) TALLDAAGVASLLTTAEVVVTEIPK (26.50)   0
CB BOLD   62  828.132202    1(   1) TALLDAAGVASLLTTAEVVVTEIPK 47.53   0
CB BOLD   64  854.058777    1(   1) LVQDVANNTNEEAGDGTTTATVLAR 75.15   0
CB BOLD   65 1038.503052    1(   1) DMAIATGGAVFGEEGLTLNLEDVQPHDLGK 13.05   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
CH60_PONPY Total score: 1007.90623376928  Peptides matched: 25
CH60_CRIGR Total score: 951.166233769285  Peptides matched: 23
CH60_MOUSE Total score: 951.166233769285  Peptides matched: 23
CH60_RAT Total score: 951.166233769285  Peptides matched: 23
CH60_BOVIN Total score: 917.68246753857  Peptides matched: 22
CH60_CHICK Total score: 875.976233769285  Peptides matched: 19
CH60C_DROME Total score: 120.5  Peptides matched: 2
CH60C_ARATH Total score: 90.68  Peptides matched: 2
HSP60_CANAL Total score: 45.35  Peptides matched: 1
HSP60_PARBR Total score: 45.35  Peptides matched: 1
HSP60_YEAST Total score: 45.35  Peptides matched: 1
CH602_VIBPA Total score: 45.35  Peptides matched: 1
CH602_VIBVU Total score: 45.35  Peptides matched: 1
CH602_VIBVY Total score: 45.35  Peptides matched: 1
CH60_EUGGR Total score: 45.33  Peptides matched: 1

Protein Hit 2
===================
Accession   : CH60_DROME
Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
Score       : 174.39
Mass        : 60770.89
Frame       : 0
Coverage    : 67
RMS error   : 29.5905072791318
Peptides    : 4
--  dim   11  417.182190    1(   1) APGFGDNR             45.35   0
--  dim   27  617.285706    2(   2) VGGSSEVEVNEK         41.69   0
--  dim   59 1183.156982    2(   2) KPLVIIAEDIDGEALSTLVVNR 12.20   0
--  dim   64  854.058777    1(   1) LVQDVANNTNEEAGDGTTTATVLAR 75.15   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
HSP60_SCHPO Total score: 87.04  Peptides matched: 2

Protein Hit 3
===================
Accession   : CH60_CAEEL
Description : Chaperonin homolog Hsp-60, mitochondrial precursor (Heat shock protein 60) (HSP-60) - Caenorhabditi
Score       : 134.91
Mass        : 60063.75
Frame       : 0
Coverage    : 21
RMS error   : 36.5383063193603
Peptides    : 3
--  dim   11  417.182190    1(   1) APGFGDNR             45.35   0
--  dim   39  752.864319    2(   1) TLNDELELIEGMK        89.56   0
--  dim   40  760.846130    2(   1) TLNDELELIEGMK        (88.82)   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 4
===================
Accession   : CH60_XANAC
Description : 60 kDa chaperonin (Protein Cpn60) (groEL protein) - Xanthomonas axonopodis pv. citri
Score       : 42.2
Mass        : 57130.83
Frame       : 0
Coverage    : 9
RMS error   : 76.92376960617
Peptides    : 1
--  dim   16  456.780609    2(   2) GIVKVVAVK            42.20   0
Proteins matching the same set of peptides:
CH60_XANC5 Total score: 42.2  Peptides matched: 1
CH60_XANC8 Total score: 42.2  Peptides matched: 1
CH60_XANCH Total score: 42.2  Peptides matched: 1
CH60_XANCP Total score: 42.2  Peptides matched: 1
CH60_XANOM Total score: 42.2  Peptides matched: 1
CH60_XANOR Total score: 42.2  Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 5
===================
Accession   : NMDE4_HUMAN
Description :
Score       : 37.24
Mass        : 0
Frame       : 0
Coverage    : 10
RMS error   : 9.41906700790969
Peptides    : 1
--  dim   16  456.780609    3(   3) VAAGVAVVAR           37.24   0
Proteins matching the same set of peptides:
NMDE4_MOUSE Total score: 37.24  Peptides matched: 1
NMDE4_RAT Total score: 36.2762337692848  Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 6
===================
Accession   : YF81_THET2
Description :
Score       : 34.76
Mass        : 0
Frame       : 0
Coverage    : 9
RMS error   : 37.0214184966023
Peptides    : 1
--  dim   16  456.780609    4(   4) VAQVLGVVK            34.76   0
Proteins matching the same set of peptides:
Y1944_THET8 Total score: 34.76  Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 7
===================
Accession   : F4ST_FLACH
Description :
Score       : 33.85
Mass        : 0
Frame       : 0
Coverage    : 9
RMS error   : 87.8815544838649
Peptides    : 1
--  dim   15  451.249908    2(   2) LSATGLVLK            33.85   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 8
===================
Accession   : ZN711_HUMAN
Description : Zinc finger protein 711 (Zinc finger protein 6) - Homo sapiens (Human)
Score       : 30.84
Mass        : 87153.77
Frame       : 0
Coverage    : 13
RMS error   : 69.4028633218151
Peptides    : 1
CB BOLD   33  714.364929    1(   1) EASPLSSNKLILR        30.84   0
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Unassigned list
---------------
CB BOLD   14  442.228302    1(   1) LIAQTPLK             25.09   0
CB BOLD    9  747.396179    1(   1) EGETRR               15.03   0
CB BOLD    4  662.275574    1(   1) KNAMAK               14.09   0
CB BOLD   23 1101.621704    1(   1) QLLMVAGVDR           12.04   0
CB BOLD    5  662.417175    1(   1) AIACER               11.79   0
CB BOLD    8  714.372498    1(   1) LAPAQSK              10.69   0
CB BOLD    6  673.349487    1(   1) AVNDVR               10.63   0
CB BOLD   22 1101.536621    1(   1) ENVIPADSEK           8.65   0
CB BOLD   55 1099.094727    1(   1) LNAEAVRTLLSANGQKPSEAK 8.05   0
CB BOLD   29  642.353577    1(   1) VVGVAGQGASALVR       7.91   0
CB BOLD   28  642.352600    1(   1) KNVSVSQGPDPR         7.22   0
CB BOLD   30  663.837891    1(   1) TPLLVGVAKGESR        7.20   0
CB BOLD   50 1048.561523    1(   1) ALDEILEYQNYPVVCAKK   5.70   0
CB BOLD   57  747.036072    1(   1) VMGSAFTALLDANEDAQKAMR 4.83   0
CB BOLD   49 1020.987915    1(   1) HQRLSGLMQTALEEQQR    4.11   0
CB BOLD   19  932.364380    1(   1) TGMTRNPR             4.09   0
CB BOLD    2  500.256012    1(   1) LAVPT                3.87   0
CB BOLD   38  749.383972    1(   1) IDLLADMMWDDK         3.43   2
CB BOLD   20  933.499023    1(   1) SRDPGMVR             3.21   0
CB BOLD   41  886.405884    1(   1) DRVALNQEVMAPEATK     1.85   0
CB BOLD   10  747.412476    1(   1) MAPSTPK              1.68   0
CB BOLD   18  930.703003    1(   1) LGSGIKAER            1.60   0
CB BOLD    7  711.364685    1(   1) GGAHEIK              1.34   0
CB BOLD   17  930.683105    1(   1) KIQAEITK             1.00   0
CB BOLD   44  949.550720    1(   1) LLSWDSVFFIKNITSK     0.30   0
CB BOLD    1  498.272888    1(   1)                      0.00   0
CB BOLD    3  575.558411    1(   1)                      0.00   0
CB BOLD   32  711.370728    1(   1)                      0.00   0
CB BOLD   42  932.460815    1(   1)                      0.00   0
CB BOLD   43  933.003784    1(   1)                      0.00   0
CB BOLD   47  665.009583    1(   1)                      0.00   0
CB BOLD   56 1119.045166    1(   1)                      0.00   0
CB BOLD   63  832.798584    1(   1)                      0.00   0
CB BOLD   66 1113.894653    1(   1)                      0.00   0
CB BOLD   67 1116.177490    1(   1)                      0.00   0

Score Delta       Hit Protein Peptide
    0     0
    0     0
    0     0
    0     0
    0     0
    0     0
    0     0
    0     0
    0     0
    0     0
Accessions that matched query 97 rank 1:-

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


resfile_summary.py

Example program for extracting the peptide or protein summary.

#!/usr/bin/python
##############################################################################
# file: resfile_summary.py                                                   #
# 'msparser' toolkit example code                                            #
#                                                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2016 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#   $Source: parser/examples/test_python/resfile_summary.py $ #
#   $Author: villek@matrixscience.com $                                                     #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser
import sys
import re

def main() :
    returnValue = 1

    if len(sys.argv) < 2 :
        print("Must specify results filename as parameter" )
        return returnValue

    resfile = msparser.ms_mascotresfile(sys.argv[1])

    if checkErrors(resfile) :

        # The parameters passed to ms_peptidesummary or ms_proteinsummary determine
        # the type of grouping and the number of proteins and peptides displayed.
        # Default parameters can be returned using ms_mascotresfile::get_ms_mascotresults_params().
        # The return values from this function depend on the type of search,
        # and also on values in the mascot.dat configuration file if that is available.

        # You may need to change this path
        datfile = msparser.ms_datfile("../config/mascot.dat")

        # if the mascot.dat isn't available, use defaults
        mascotOptions = msparser.ms_mascotoptions()

        if (datfile.isValid()) :
            mascotOptions = datfile.getMascotOptions()

        (scriptName,
        flags,
        minProbability,
        maxHitsToReport,
        ignoreIonsScoreBelow,
        minPepLenInPepSummary,
        usePeptideSummary,
        flags2) = resfile.get_ms_mascotresults_params(mascotOptions)

        bResult = False
        if (usePeptideSummary) :

            # For peptide summary
            #
            # Flags defined for hierarchical clustering algorithm:
            #     flags: ms_mascotresults::MSRES_CLUSTER_PROTEINS
            #            | ms_mascotresults::MSRES_SHOW_SUBSETS
            #            | ms_mascotresults::MSRES_MUDPIT_PROTEIN_SCORE;
            #     flags2: ms_peptidesummary::MSPEPSUM_USE_HOMOLOGY_THRESH;
            #
            # Flags defined for original simple parsimony algorithm:
            #     flags: ms_mascotresults::MSRES_GROUP_PROTEINS | ms_mascotresults::MSRES_SHOW_SUBSETS;

            print("-------------------------------------------------------------")
            print("---   Peptide summary report                              ---")
            print("-------------------------------------------------------------")

            bResult = show_results(resfile,
                                   usePeptideSummary,
                                   flags,
                                   minProbability,
                                   maxHitsToReport,
                                   ignoreIonsScoreBelow,
                                   minPepLenInPepSummary,
                                   flags2)
        else :
            # Show results from full protein summary, remove grouping
            flags &= ~msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
            flags &= ~msparser.ms_mascotresults.MSRES_SHOW_SUBSETS

            print("-------------------------------------------------------------")
            print("---   Full Protein summary report                         ---")
            print("-------------------------------------------------------------")
            bResult = show_results(resfile,
                                   usePeptideSummary,
                                   flags,
                                   minProbability,
                                   maxHitsToReport,
                                   ignoreIonsScoreBelow,
                                   minPepLenInPepSummary,
                                   flags2)

            if (bResult and checkErrors(resfile)) :
                print("")

                # Show results from concise protein summary, add grouping
                flags |= msparser.ms_mascotresults.MSRES_GROUP_PROTEINS
                flags |= msparser.ms_mascotresults.MSRES_SHOW_SUBSETS

                print("-------------------------------------------------------------")
                print("---   Concise Protein summary report                      ---")
                print("-------------------------------------------------------------")
                bResult = show_results(resfile,
                                       usePeptideSummary,
                                       flags,
                                       minProbability,
                                       maxHitsToReport,
                                       ignoreIonsScoreBelow,
                                       minPepLenInPepSummary,
                                       flags2)

        if (bResult and checkErrors(resfile)) :
            returnValue = 0

        return returnValue

def show_results(resfile, usePeptideSummary, flags, minProteinProb, maxHits, minIonsScore, minPepLenInPepSummary, flags2) :

    if usePeptideSummary :
        results = msparser.ms_peptidesummary(
            resfile, flags, minProteinProb, maxHits, "", minIonsScore, minPepLenInPepSummary, "", flags2
            )
    else :
        results = msparser.ms_proteinsummary(
            resfile, flags, minProteinProb, maxHits
            )

    if not checkErrors(resfile) :
        return False

    family = 1
    hit  = 1
    prot = results.getHit(hit)

    while prot :
        accession   = prot.getAccession()
        description = results.getProteinDescription(accession)
        mass        = results.getProteinMass(accession)
        dbIdx       = prot.getDB()

        protein_hit = "Protein Hit %d" % hit
        if flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS :
            protein_hit = protein_hit + "." + str(family)

        print protein_hit
        print("===================")
        print("Accession   : %s" % accession)
        print("Description : %s" % description)
        print("Score       : %s" % prot.getScore())
        print("Mass        : %s" % mass)
        print("Frame       : %s" % prot.getFrame())
        print("Coverage    : %s" % prot.getCoverage())
        print("RMS error   : %s" % prot.getRMSDeltas(results))
        print("Peptides    : %s" % prot.getNumDisplayPeptides())

        # Each protein has a number of peptides that matched - list them:
        num_peps = prot.getNumPeptides()

        for i in range(1, 1+ num_peps) :
            query = prot.getPeptideQuery(i)
            p     = prot.getPeptideP(i)

            isDupSameQuery = prot.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery
            if p != -1 and query != -1 and not isDupSameQuery :
                pep = results.getPeptide(query, p)
                if not pep:
                    continue

                displayPeptideInfo(
                    0, pep, results,
                    prot.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_Duplicate,
                    prot.getPeptideIsBold(i),
                    prot.getPeptideShowCheckbox(i)
                    )

        # Now display list of all proteins that contain a subset or a same set of the matching peptides

        if flags & msparser.ms_mascotresults.MSRES_GROUP_PROTEINS or flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS :
            print("Proteins matching the same set of peptides:")

            i = 1
            similar_prot = results.getNextSimilarProteinOf(accession, dbIdx, 1)
            while similar_prot :
                similar_accession = similar_prot.getAccession()
                similar_dbIdx = similar_prot.getDB()
                if(flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS and similar_dbIdx > 1) :
                    print(str(similar_dbIdx) + "::"),
                print(similar_accession + " - Total score:" + str(similar_prot.getScore())),
                print(" - Peptides matched:" + str(similar_prot.getNumDisplayPeptides()))
                i += 1
                similar_prot = results.getNextSimilarProteinOf(accession, dbIdx, i)

            if flags & msparser.ms_mascotresults.MSRES_SHOW_SUBSETS :
                print("Proteins matching a subset of these peptides:")

                i = 1
                subset_prot = results.getNextSubsetProteinOf(accession, dbIdx, 1)
                while subset_prot :
                    subset_accession = subset_prot.getAccession()
                    subset_dbIdx = subset_prot.getDB()
                    if(flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS and subset_dbIdx > 1) :
                        print(str(subset_dbIdx) + "::"),
                    print(subset_accession + " - Total score:" + str(subset_prot.getScore())),
                    print(" - Peptides matched:" + str(subset_prot.getNumDisplayPeptides()))

                    if(flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS) :
                        j = 1
                        similar_subset_prot = results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)
                        if similar_subset_prot :
                            print("  Proteins matching the same set of peptides for this subset:")
                        while similar_subset_prot :
                            similar_subset_accession = similar_subset_prot.getAccession()
                            similar_subset_dbIdx = similar_subset_prot.getDB()
                            print("  "),
                            if similar_subset_dbIdx > 1 :
                                print(str(similar_subset_dbIdx) + "::"),
                            print(similar_subset_accession + " - Total score:" + str(similar_subset_prot.getScore())),
                            print(" Peptides matched:" + str(similar_subset_prot.getNumDisplayPeptides()))
                            j += 1
                            similar_subset_prot = results.getNextSimilarProteinOf(subset_accession, subset_dbIdx, j)

                    i += 1
                    subset_prot = results.getNextSubsetProteinOf(accession, dbIdx, i)

        if flags & msparser.ms_mascotresults.MSRES_CLUSTER_PROTEINS :
            prot = results.getNextFamilyProtein(hit, family)
            family += 1
            if not prot :
                hit += 1
                prot = results.getHit(hit)
                family = 1
        else :
            hit += 1
            prot = results.getHit(hit)

        print(" ")

    results.createUnassignedList(msparser.ms_mascotresults.SCORE)

    if results.getNumberOfUnassigned() :
        print("Unassigned list")
        print("---------------")

        for u in range(1, 1 + results.getNumberOfUnassigned()) :
            pep = results.getUnassigned(u)
            displayPeptideInfo(0, pep, results, 0, 1, 1)

    if usePeptideSummary :
        print(" ")
        displayYellowPopupInfo(results, 1)

    return True

def displayYellowPopupInfo(results, q) :
    """
    Shows the equivalent of the yellow popup box for given query
    - results is the results object
    - q is the query number
    """

    fmt = "%5s %5s %9s %7s %7s"
    print(fmt % ("Score", "Delta", "Hit", "Protein", "Peptide"))

    for p in range(1, 11) :
        pep = results.getPeptide(q, p)
        if not pep: continue

        seq = pep.getPeptideStr()
        if not seq: continue

        tmp = results.getProteinsWithThisPepMatch(q, p)

        (hit, protein) = ('', '')

        if tmp :
            hit, protein, morethan = re.search('(\d+):([^ ]*)[ ]*(.*)', tmp).groups()

            if morethan :
                hit += "+"

        print(fmt % (pep.getIonsScore(), pep.getDelta(), hit, protein, seq))

    p = 1
    print("Accessions that matched query %s rank %s :- %s" % (q, p, results.getProteinsWithThisPepMatch(q, p)))

def displayPeptideInfo(showFullDetails, p, results, isDuplicate, isBold, showCheckBox) :
    q = p.getQuery()

    if not showFullDetails :
        fmt = "%2s %4s %4d %11f %4d(%4d) %-20s %s%3.2f%s %3s"

        cb, bold = "--", "dim"
        if showCheckBox : cb = "CB"
        if isBold : bold = "BOLD"

        paren1, paren2 = "", ""
        if isDuplicate : paren1 = "(" ; paren2 = ")"

        print(fmt % (
            cb,
            bold,
            q,
            p.getObserved(),
            p.getRank(),
            p.getPrettyRank(),
            p.getPeptideStr(),
            paren1,
            p.getIonsScore(),
            paren2,
            results.getReadableVarMods(q, p.getRank())
            ))

        return

    print("Peptide hit")

    if p.getAnyMatch() :
        fmt = "    %-12s: %s"
        print(fmt % ('Query'       , q))
        print(fmt % ('Rank'        , p.getRank()))
        print(fmt % ('Matched'     , p.getAnyMatch()))
        print(fmt % ('missedCleave', p.getMissedCleavages()))
        print(fmt % ('mrCalc'      , p.getMrCalc()))
        print(fmt % ('delta'       , p.getDelta()))
        print(fmt % ('observed'    , p.getObserved()))
        print(fmt % ('charge'      , p.getCharge()))
        print(fmt % ('mrExp'       , p.getMrExperimental()))
        print(fmt % ('ionsMatched' , p.getNumIonsMatched()))
        print(fmt % ('peptideStr'  , p.getPeptideStr()))
        print(fmt % ('peaksUsed1'  , p.getPeaksUsedFromIons1()))
        print(fmt % ('varModsStr'  , p.getVarModsStr()))
        print(fmt % ('readable mod', results.getReadableVarMods(q, p.getRank)))
        print(fmt % ('ionsScore'   , p.getIonsScore()))
        print(fmt % ('seriesUsedS' , p.getSeriesUsedStr()))
        print(fmt % ('peaksUsed2'  , p.getPeaksUsedFromIons2()))
        print(fmt % ('peaksUsed3'  , p.getPeaksUsedFromIons3()))
        print(fmt % ('idth, hth, p', ', '.join(
            results.getPeptideIdentityThreshold(q, 20),
            results.getHomologyThreshold(q, 20),
            results.getProbOfPepBeingRandomMatch(p.getIonsScore(), q)
            )))
        print(" ")
    else :
        print("    No match")

def checkErrors(resfile) :
    if resfile.getLastError() :
        for i in range(1, 1 + resfile.getNumberOfErrors()) :
            print("Error number: %s : %s" % (resfile.getErrorNumber(i), resfile.getErrorString(i)))

    #Call isValid before clearAllErrors, otherwise this method always returns true
    bIsValid = resfile.isValid()
    resfile.clearAllErrors()
    return bIsValid

if __name__ == "__main__" :
    sys.exit(main())

"""

Running the program as

python resfile_summary.py F981123.dat

will give the following output under Mascot Server 2.3:

-------------------------------------------------------------
---   Peptide summary report                              ---
-------------------------------------------------------------
Protein Hit 1
===================
Accession   : CH60_HUMAN
Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
Score       : 1225.18623377
Mass        : 61016.38
Frame       : 0
Coverage    : 283
RMS error   : 30.4200726378
Peptides    : 31
--  dim   52 1065.039917    2(   2) ALMLQGVDLLADAVAVTMGPK 57.90 Oxidation (M)
--  dim   53 1065.062256    2(   2) ALMLQGVDLLADAVAVTMGPK 7.49 Oxidation (M)
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
CH60_PONPY Total score: 1007.90623377  Peptides matched: 25
CH60_CRIGR Total score: 951.166233769  Peptides matched: 23
CH60_MOUSE Total score: 951.166233769  Peptides matched: 23
CH60_RAT Total score: 951.166233769  Peptides matched: 23
CH60_BOVIN Total score: 917.682467539  Peptides matched: 22
CH60_CHICK Total score: 875.976233769  Peptides matched: 19
CH60C_DROME Total score: 120.5  Peptides matched: 2
CH60C_ARATH Total score: 90.68  Peptides matched: 2
HSP60_CANAL Total score: 45.35  Peptides matched: 1
HSP60_PARBR Total score: 45.35  Peptides matched: 1
HSP60_YEAST Total score: 45.35  Peptides matched: 1
CH602_VIBPA Total score: 45.35  Peptides matched: 1
CH602_VIBVU Total score: 45.35  Peptides matched: 1
CH602_VIBVY Total score: 45.35  Peptides matched: 1
CH60_EUGGR Total score: 45.33  Peptides matched: 1

Protein Hit 2
===================
Accession   : CH60_DROME
Description : 60 kDa heat shock protein, mitochondrial precursor (Hsp60) (60 kDa chaperonin) (CPN60) (Heat shock
Score       : 174.39
Mass        : 60770.89
Frame       : 0
Coverage    : 67
RMS error   : 29.5905072791
Peptides    : 4
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:
HSP60_SCHPO Total score: 87.04  Peptides matched: 2

Protein Hit 3
===================
Accession   : CH60_CAEEL
Description : Chaperonin homolog Hsp-60, mitochondrial precursor (Heat shock protein 60) (HSP-60) - Caenorhabditi
Score       : 134.91
Mass        : 60063.75
Frame       : 0
Coverage    : 21
RMS error   : 36.5383063194
Peptides    : 3
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 4
===================
Accession   : CH60_XANAC
Description : 60 kDa chaperonin (Protein Cpn60) (groEL protein) - Xanthomonas axonopodis pv. citri
Score       : 42.2
Mass        : 57130.83
Frame       : 0
Coverage    : 9
RMS error   : 76.9237696062
Peptides    : 1
Proteins matching the same set of peptides:
CH60_XANAC Total score: 42.2  Peptides matched: 1
CH60_XANAC Total score: 42.2  Peptides matched: 1
CH60_XANAC Total score: 42.2  Peptides matched: 1
CH60_XANAC Total score: 42.2  Peptides matched: 1
CH60_XANAC Total score: 42.2  Peptides matched: 1
CH60_XANAC Total score: 42.2  Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 5
===================
Accession   : NMDE4_HUMAN
Description :
Score       : 37.24
Mass        : 0.0
Frame       : 0
Coverage    : 10
RMS error   : 9.41906700791
Peptides    : 1
Proteins matching the same set of peptides:
NMDE4_HUMAN Total score: 37.24  Peptides matched: 1
NMDE4_HUMAN Total score: 36.2762337693  Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 6
===================
Accession   : YF81_THET2
Description :
Score       : 34.76
Mass        : 0.0
Frame       : 0
Coverage    : 9
RMS error   : 37.0214184966
Peptides    : 1
Proteins matching the same set of peptides:
YF81_THET2 Total score: 34.76  Peptides matched: 1
Proteins matching a subset of these peptides:

Protein Hit 7
===================
Accession   : F4ST_FLACH
Description :
Score       : 33.85
Mass        : 0.0
Frame       : 0
Coverage    : 9
RMS error   : 87.8815544839
Peptides    : 1
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Protein Hit 8
===================
Accession   : ZN711_HUMAN
Description : Zinc finger protein 711 (Zinc finger protein 6) - Homo sapiens (Human)
Score       : 30.84
Mass        : 87153.77
Frame       : 0
Coverage    : 13
RMS error   : 69.4028633218
Peptides    : 1
Proteins matching the same set of peptides:
Proteins matching a subset of these peptides:

Unassigned list
---------------
CB BOLD   14  442.228302    1(   1) LIAQTPLK             25.09
CB BOLD    9  747.396179    1(   1) EGETRR               15.03
CB BOLD    4  662.275574    1(   1) KNAMAK               14.09
CB BOLD   23 1101.621704    1(   1) QLLMVAGVDR           12.04
CB BOLD    5  662.417175    1(   1) AIACER               11.79
CB BOLD    8  714.372498    1(   1) LAPAQSK              10.69
CB BOLD    6  673.349487    1(   1) AVNDVR               10.63
CB BOLD   22 1101.536621    1(   1) ENVIPADSEK           8.65
CB BOLD   55 1099.094727    1(   1) LNAEAVRTLLSANGQKPSEAK 8.05
CB BOLD   29  642.353577    1(   1) VVGVAGQGASALVR       7.91
CB BOLD   28  642.352600    1(   1) KNVSVSQGPDPR         7.22
CB BOLD   30  663.837891    1(   1) TPLLVGVAKGESR        7.20
CB BOLD   50 1048.561523    1(   1) ALDEILEYQNYPVVCAKK   5.70
CB BOLD   57  747.036072    1(   1) VMGSAFTALLDANEDAQKAMR 4.83
CB BOLD   49 1020.987915    1(   1) HQRLSGLMQTALEEQQR    4.11 Oxidation (M)
CB BOLD   19  932.364380    1(   1) TGMTRNPR             4.09
CB BOLD    2  500.256012    1(   1) LAVPT                3.87
CB BOLD   38  749.383972    1(   1) IDLLADMMWDDK         3.43 2 Oxidation (M)
CB BOLD   20  933.499023    1(   1) SRDPGMVR             3.21 Oxidation (M)
CB BOLD   41  886.405884    1(   1) DRVALNQEVMAPEATK     1.85
CB BOLD   10  747.412476    1(   1) MAPSTPK              1.68 Oxidation (M)
CB BOLD   18  930.703003    1(   1) LGSGIKAER            1.60
CB BOLD    7  711.364685    1(   1) GGAHEIK              1.34
CB BOLD   17  930.683105    1(   1) KIQAEITK             1.00
CB BOLD   44  949.550720    1(   1) LLSWDSVFFIKNITSK     0.30
CB BOLD    1  498.272888    1(   1)                      0.00
CB BOLD    3  575.558411    1(   1)                      0.00
CB BOLD   32  711.370728    1(   1)                      0.00
CB BOLD   42  932.460815    1(   1)                      0.00
CB BOLD   43  933.003784    1(   1)                      0.00
CB BOLD   47  665.009583    1(   1)                      0.00
CB BOLD   56 1119.045166    1(   1)                      0.00
CB BOLD   63  832.798584    1(   1)                      0.00
CB BOLD   66 1113.894653    1(   1)                      0.00
CB BOLD   67 1116.177490    1(   1)                      0.00

Score Delta       Hit Protein Peptide

Accessions that matched query 97 rank 1 :-

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


security_session.java

Checking the 'current' session using the security module.

/*
##############################################################################
# file: security_session.java                                                #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2005 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
*/

/*
 This file needs to be compiled and put into the mascot/cgi directory.
 The file 'java_helper.pl' also needs to be copied to the mascot/cgi
 directory. Run from a browser: http://localhost/mascot/cgi/java_helper.pl
 */

import matrix_science.msparser.*;
import java.util.HashMap;

public class security_session {
    // 1st of all, load the .dll
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. See the chapter on Dynamic Linking Problems in the SWIG Java documentation for help.\n" + e);
            e.printStackTrace();
            System.exit(1);
        }
    }

    public static void main(String[] args) {
        // copy the parameters into a HashMap
        HashMap parameters = new HashMap();
        for(int i = 0; i < args.length; i += 2) {
            args[i+1] = args[i+1].replaceAll("-pipe-","\\|");
            args[i+1] = args[i+1].replaceAll("SYSTEM","\\(system\\)");
            parameters.put(args[i],args[i+1]);
        }
        ms_session session;

        System.out.println("<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">");
        System.out.println("<HTML>");
        System.out.println("<HEAD>");
        System.out.println("<TITLE>Check Session</TITLE>");
        System.out.println("</head>\n");
        System.out.println("<body>\n");
        System.out.println("<p>This utility shows session information for when Mascot Security is enabled.<br>");
        System.out.println("You may be asked to give this information to a support engineer if you have security problems</p>");

        if(parameters.containsKey("COOKIE_MASCOT_SESSION")) System.out.println("Retrieved cookie value is: "+parameters.get("COOKIE_MASCOT_SESSION")+
        "<br>");
        if(parameters.containsKey("sessionID")) {
            System.out.println("Using passed sessionID: "+parameters.get("sessionID")+"<br>");
            session = new ms_session((String) parameters.get("sessionID"));
        } else {
            session = new ms_session();
        }

        if(session.isValid()) {
            System.out.println("<table border=\"1\">");
            System.out.print("  <tr><td>ID</td><td>"+session.getID()+"</td></tr>\n");
            System.out.print("  <tr><td>security enabled</td><td>"+session.isSecurityEnabled()+"</td></tr>\n");
            System.out.print("  <tr><td>last accessed</td><td>"+session.getLastAccessed()+"</td></tr>\n");
            System.out.print("  <tr><td>ip address</td><td>"+session.getIPAddress()+"</td></tr>\n");
            System.out.print("  <tr><td>user</td><td>"+session.getUserName()+"</td></tr>\n");
            System.out.print("  <tr><td>user ID</td><td>"+session.getUserID()+"</td></tr>\n");
            System.out.print("  <tr><td>full username</td><td>"+session.getFullUserName()+"</td></tr>\n");
            System.out.print("  <tr><td>email address</td><td>"+session.getEmailAddress()+"</td></tr>\n");
            System.out.print("  <tr><td>valid</td><td>"+session.isValid()+"</td></tr>\n");

            if(parameters.containsKey("ENV_ROMOTE_USER")) {
                System.out.print("  <tr><td>Web auth user</td><td>"+parameters.get("ENV_REMOTE_USER")+"</td></tr>");
            }
            System.out.print("</table><br><br>\n");
            showTasks(session);

        } else {
            System.out.print("Session is invalid<br>\n");
            displayWarningsAndErrors(session);
        }

        System.out.println("</body>\n");
        System.out.println("</html>\n");

    }

    private static void showTasks(ms_session session) {
        String[] param_desc = {"None","Integer =","Integer &lt;=","Integer &gt;=","Integer: one of",
                   "Float =", "Float &lt;=", "Float &gt;=", "Float: one of",
                   "String = ", "String: one of",
                   "User list"};
        ms_security_tasks tasks = session.getPermittedTasks();
        System.out.print("<b>Permitted tasks</b>\n");
        System.out.print("  <table align=\"left\" border=\"1\" cellspacing=\"0\" cellpadding=\"3\">\n");
        System.out.print("    <tr><td>Task</td><td nowrap>Param type</td><td>Parameter</td></tr>\n");
        for(int taskNo = 0; taskNo < tasks.getNumberOfTasks(); taskNo++) {
            ms_security_task currentTask = tasks.getTask(taskNo);
            int currentTT = currentTask.getType();
            System.out.print("      <tr>\n");
            System.out.print("        <td>"+currentTask.getDescription()+"</td>\n");
            System.out.print("        <td nowrap>"+param_desc[currentTT]+"</td>\n");
            System.out.print("        <td nowrap>"+currentTask.getAllParamsAsString()+"&nbsp;</td>\n");
            System.out.print("      </tr>\n");
        }
        System.out.print("  </table>\n");
    }

    private static void displayWarningsAndErrors(ms_session session) {
        if(!session.isValid()) {
            System.out.print("There were one or more errors:<br>\n");
        }

        ms_errs err = session.getErrorHandler();
        int numErrs = err.getNumberOfErrors();
        for(int i = 1; i <= numErrs; i++) {
            System.out.print(err.getErrorString(i)+"<br>\n");
        }
        session.clearAllErrors();
    }

}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


security_session.pl

Checking the 'current' session using the security module.

#!/usr/local/bin/perl
##############################################################################
# file: security_session.pl                                                  #
# 'msparser' toolkit                                                         #
# Test harness / example code                                                #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/security_session.pl $ #
#     $Author: villek@matrixscience.com $ #
#       $Date: 2018-07-30 16:23:53 +0100 $ #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $ #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
##############################################################################

use lib "../bin";
use CGI qw(:standard);
use msparser;

my $thisScript = new CGI;
print $thisScript->header;

print <<STARTHTML;
<html>
<head>
<title>Security session</title>
</head>
<body>
<h1>Security session</h1>
<p>
This utility shows session information for when Mascot Security is enabled.
</p>
<p>
You may be asked to give this information to a support engineer if you have
security problems.
</p>
STARTHTML

my $session;

#$session = new msparser::ms_session("admin", "admin");

if (defined($thisScript->param('sessionID'))) {
  print "<p>Using passed sessionID: ", $thisScript->param('sessionID'), "</p>\n";
  $session = new msparser::ms_session($thisScript->param('sessionID'));
} else {
  $session = new msparser::ms_session;
}

if ($session->isValid) {
    if (!$session->isSecurityEnabled) {
        print "<p><strong>Mascot Security is not enabled</strong></p>\n";
        print "<p>To enable Mascot security, please run 'enable_security' in the <code>mascot/bin</code> directory.</p>\n";
    } else {
        if (defined($thisScript->cookie(-name=>'MASCOT_SESSION'))) {
            print "<p>Retrieved cookie value is: <code>";
            print $thisScript->cookie(-name=>'MASCOT_SESSION');
            print "</code></p>\n";
        }

        my ($sec, $min, $hour, $mday, $mon, $year, $wday, $yday, $isdst)
            = gmtime ($session->getLastAccessed);

        $year += 1900;
        my $month = (qw(Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec))[$mon];
        my $lastAccessed = join(' ', $mday, $month, $year, $hour.":".$min.":".$sec);

        print '<table border="1" cellpadding="3" cellspacing="1">', "\n";

        my $fmt = "<tr><td>%s</td><td>%s</td></tr>\n";

        printf $fmt, 'ID', $session->getID;
        printf $fmt, 'Security enabled?', $session->isSecurityEnabled;
        printf $fmt, 'Last accessed', $lastAccessed;
        printf $fmt, 'IP address', $session->getIPAddress;
        printf $fmt, 'User', $session->getUserName;
        printf $fmt, 'User ID', $session->getUserID;
        printf $fmt, 'Full username', $session->getFullUserName;
        printf $fmt, 'Email address', $session->getEmailAddress;
        printf $fmt, 'Valid?', $session->isValid;

        if (defined($ENV{'REMOTE_USER'})) {
            printf $fmt, 'Web auth user', $ENV{'REMOTE_USER'};
        }

        print "</table>\n";

        showTasks($session);
    }
} else {
    print "<p>Session is <strong>invalid</strong>.</p>\n";
    displayWarningsAndErrors($session);
}

print <<ENDHTML;
</body>
</html>
ENDHTML

sub showTasks {
    my ($session) = @_;

    my @param_desc = (
        "None",

        "Integer =",
        "Integer &lt;=",
        "Integer &gt;=",
        "Integer: one of",

        "Float =",
        "Float &lt;=",
        "Float &gt;=",
        "Float: one of",

        "String = ",
        "String: one of",

        "User list"
    );

    my $tasks = $session->getPermittedTasks;

    if ($tasks->getNumberOfTasks == 0) {
        print "<h2>Permitted tasks</h2>\n<p><em>None</em</p>\n";
    } else {
        print <<TABLESTART;
<h2>Permitted tasks</h2>
<table border="1" cellspacing="0" cellpadding="3">
<tr><th>Task</th><th nowrap>Param type</th><th>Parameter</th></tr>
TABLESTART

        for my $taskno (0 .. $tasks->getNumberOfTasks - 1) {
            my $task = $tasks->getTask($taskno);
            my $tt = $task->getType;

            print <<ROW;
<tr>
    <td>$task->getDescription()</td>
    <td nowrap>$param_desc[$tt]</td>
    <td nowrap>$task->getAllParamsAsString()</td>
</tr>
ROW
        }

        print "</table>\n";
    }
}

sub displayWarningsAndErrors {
    my ($obj) = @_;

    return if $obj->isValid;

    print <<STARTERRORS;
<p>There were one or more errors:</p>
<ul>
STARTERRORS

    my $err = $obj->getErrorHandler;
    my $numErrs = $err->getNumberOfErrors;

    for my $i (1 .. $numErrs) {
        print "<li>", $err->getErrorString($i), "</li>\n";
    }

    print "</ul>\n";

    $obj->clearAllErrors;
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


time_utils.hpp

00001 /*
00002  * Copyright (C) 2002-2005, Matrix Science Limited, London, UK.
00003  * All rights reserved.
00004  *
00005  * @(#)$Source$
00006  * @(#)$Revision$
00007  * @(#)$Date$
00008  */
00009
00010 // NB: This file is originally a copy of mascot/src/matrix/time_utils.h.
00011
00012 #ifndef TIME_UTILS_h
00013 #define TIME_UTILS_h 1
00014
00015 #include <time.h>
00016
00017 namespace msparser_internal {
00018 // \cond INTERNAL
00019
00021
00027 class CTimeUtils {
00028 public:
00029     CTimeUtils(void);
00030     virtual ~CTimeUtils(void);
00031
00033     time_t time(void);
00034
00036     const char* ctime(time_t time);
00037
00039     const char* asctime(struct tm time);
00040
00042     const char* asctimeNoYear(struct tm time);
00043
00045     const struct tm *gmtime(time_t time);
00046
00048     const struct tm *localtime(time_t time);
00049
00051     time_t mktime(struct tm *time);
00052
00053
00055     const char *asctime(const struct tm *time) { if (time) return asctime(*time); return ""; }
00056
00058     std::string asctimeNonStandard(const struct tm *time);
00059
00061     bool compareTimesStandardFormat(std::string str1, std::string str2);
00062
00063 private:
00064     bool m_anyErrors;
00065
00066 #define INTERNAL_BUFFER_SIZE 64 // although 26 is enough
00067     char m_buffer[INTERNAL_BUFFER_SIZE];
00068     time_t m_buffer_time;
00069     struct tm m_buffer_tm;
00070 };
00071
00072 // \endcond
00073
00074 } // namespace
00075
00076 #endif // TIME_UTILS_h
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:22


tools_aahelper.cpp

For calculating peptide and fragment masses.

/*
##############################################################################
# File: tools_aahelper.cpp                                                   #
# Mascot Parser toolkit example code                                         #
# Example code for generating peptides, peptide and fragment masses          #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_cxx/tools_aahelper.cpp $
#    $Author: villek@matrixscience.com $
#      $Date: 2018-07-30 16:23:53 +0100 $
#  $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
*/

#include "msparser.hpp"

#include <iostream>
#include <iomanip>

// All the classes are part of the matrix_science namespace
using namespace matrix_science;
static void printFragmentsTable(ms_fragmentvector & fragments);
static void displayMascotTestSearch(const ms_modvector      vecFixed,
                                    const ms_modvector      vecVariable,
                                    const ms_enzyme       * enzyme,
                                    const double            mr,
                                    const ms_fragmentvector fragments);

int main(int argc, char * argv[])
{
    // We need an enzyme to build a list of peptides
    // and mod_file file if we want to apply any modifications
    if ( argc < 3 )
    {
        std::cout << "Location of enzymes file and mod_file has to be specified as parameters" << std::endl;
        return 0;
    }

    ms_enzymefile enzymefile(argv[1]);
    if ( !enzymefile.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << enzymefile.getLastErrorString() << std::endl;
        return 1;
    }
    const ms_enzyme *enzyme = enzymefile.getEnzymeByName("Trypsin");
    if ( enzyme == NULL )
    {
        std::cout << "Cannot find Trypsin enzyme in the file. Cannot continue." << std::endl;
        return 1;
    }

    // we need masses file, but can use default masses anyway
    ms_masses masses;
    ms_modfile modfile(argv[2], &masses);
    if ( !modfile.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << modfile.getLastErrorString() << std::endl;
        return 1;
    }

    const ms_modification *oxidation   = modfile.getModificationByName("Oxidation (M)");
    const ms_modification *acetylNterm = modfile.getModificationByName("Acetyl (N-term)");
    const ms_modification *phospho     = modfile.getModificationByName("Phospho (STY)");

    if ( oxidation == NULL || acetylNterm == NULL || phospho == NULL)
    {
        std::cout << "Cannot find necessary modifications in the mod_file. Cannot continue." << std::endl;
        return 1;
    }

    ms_aahelper aahelper;
    aahelper.setMasses(&masses);
    aahelper.setEnzyme(enzyme);

    // Now we can generate peptides for a given protein
    char proteinStr[] = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";

    aahelper.startIteratePeptides(proteinStr, static_cast<int>(strlen(proteinStr)), 0);// no missed cleavages are allowed
    std::cout << "List of peptides" << std::endl;
    while(aahelper.getNextPeptide())
    {
        int start = aahelper.getPepStart()-1; // the method returns 1-based position
        int len = aahelper.getPepEnd() - aahelper.getPepStart()+1;
        std::string peptideStr;
        peptideStr.assign(proteinStr+start, len);
        std::cout << peptideStr << std::endl;
    }

    std::cout << "End of list" << std::endl;

    // create a list of fixed modifications
    ms_modvector vecFixed;
    vecFixed.appendModification(phospho);

    // create a list of variable modifications
    ms_modvector vecVariable;
    vecVariable.appendModification(oxidation);
    vecVariable.appendModification(acetylNterm);

    aahelper.setAvailableModifications(&vecFixed, &vecVariable);

    // ms_aahelper can also contain errors that might happen when applying modifications
    // for instance, when we have a conflict between two modifications (same residue or same peptide end)
    if ( !aahelper.isValid() )
    {
        std::cout << "There are errors. Cannot continue. The last error description:" << std::endl;
        std::cout << aahelper.getLastErrorString() << std::endl;
        return 1;
    }

    // we will need also a separate error-object for collecting peptide-specific errors
    ms_errs err;

    // Example of how to call calcPeptideMZ
    // It will often be more convenient to create an ms_peptide and then
    // call getMrCalc() on that object.
    std::vector< int > numThatMustBeModded;
    numThatMustBeModded.push_back(1);  // 1 acetylNterm modification
    numThatMustBeModded.push_back(1);  // 1 site is oxidised

    double mr = aahelper.calcPeptideMZ(proteinStr,
                                       static_cast<int>(strlen(proteinStr)),
                                       1, 10, // peptide ends (1-based)
                                       numThatMustBeModded,
                                       0, // no charge - i.e. mr
                                       matrix_science::MASS_TYPE_MONO,
                                       &err);
    if ( !err.isValid() )
    {
        std::cout << "There have been errors while calculating peptide mass: " << std::endl;
        std::cout << err.getLastErrorString() << std::endl;
        // don't need to halt as they are not fatal errors
        err.clearAllErrors(); // prepare to re-use it
    }
    else
    {
        std::cout << "Peptide mass calculated using 'calcPeptideMZ' is "
                  << std::setprecision(3)
                  << std::fixed
                  << std::setw(8)
                  << mr
                  << std::endl << std::endl << std::endl;
    }

    // Create a peptide - which we can then fragment
    //
    // Specify which residues are modified by which modification.
    // as it has to correspond to a modification string
    // Nterm modification + 9 residues + Cterm modification
    std::vector< int > numModded;
    numModded.push_back(2);  // N-term  - modified by "Acetyl (N-term)"
    numModded.push_back(1);  // M       - modified by "Oxidation (M)"
    numModded.push_back(0);  // A
    numModded.push_back(0);  // I
    numModded.push_back(0);  // F
    numModded.push_back(0);  // R
    numModded.push_back(0);  // I
    numModded.push_back(0);  // D
    numModded.push_back(0);  // E
    numModded.push_back(0);  // I
    numModded.push_back(0);  // R
    numModded.push_back(0);  // C-term

    // we have to specify (or at least supply an empty vector) which neutral loss value to use
    // in case there are more than one available for a modification
    std::vector< int > whichNl;
    whichNl.push_back(0);  // N-term
    whichNl.push_back(1);  // M - has 2 neutral losses. Specify the first (-98)
    whichNl.push_back(0);  // A
    whichNl.push_back(0);  // I
    whichNl.push_back(0);  // F
    whichNl.push_back(0);  // R
    whichNl.push_back(0);  // I
    whichNl.push_back(0);  // D
    whichNl.push_back(0);  // E
    whichNl.push_back(0);  // I
    whichNl.push_back(0);  // R
    whichNl.push_back(0);  // C-term

    ms_peptide peptide = aahelper.createPeptide(proteinStr,
                                                static_cast<int>(strlen(proteinStr)),
                                                1,10,      // start, end positions
                                                numModded, // modification string-like vector
                                                whichNl,   // which neutral loss to use
                                                0,         // no charge
                                                matrix_science::MASS_TYPE_MONO,
                                                &err);     // collect errors in it
    if ( !err.isValid() )
    {
        std::cout << "There have been errors while creating a peptide: " << std::endl;
        std::cout << err.getLastErrorString() << std::endl;
        // don't need to halt as they are not fatal errors
        err.clearAllErrors(); // prepare to re-use it
    }
    else
    {
        std::cout
            << "Peptide has been created successfully: "
            << peptide.getPeptideStr()
            << std::endl;
    }

    std::vector< double > ions;
    ms_fragmentvector fragments;
    ms_fragmentvector all_fragments; // Keep a list of fragments from all series

    ions = aahelper.calcFragments(&peptide, // that is why we needed to create a peptide object first
                                  ms_fragmentationrules::FRAG_B_SERIES, // ions series ID
                                  false,    // single-charged ions only
                                  100.0,    // minimal fragment mass to return
                                  mr,       // maximal fragment mass to return
                                  matrix_science::MASS_TYPE_MONO,
                                  &fragments,
                                  &err);    // collect peptide-specific errors

    std::cout << "b-ion series fragments: " << std::endl;
    printFragmentsTable(fragments);
    all_fragments.copyFrom(&fragments);
    ms_fragmentvector b_ions;
    b_ions.copyFrom(&fragments);

    ions = aahelper.calcFragments(&peptide, // that is why we needed to create a peptide object first
                                  ms_fragmentationrules::FRAG_Y_SERIES, // ions series ID
                                  false,    // single-charged ions only
                                  100.0,    // minimal fragment mass to return
                                  mr,       // maximal fragment mass to return
                                  matrix_science::MASS_TYPE_MONO,
                                  &fragments,
                                  &err);    // collect peptide-specific errors

    std::cout << "y-ion series fragments: " << std::endl;
    printFragmentsTable(fragments);
    int i;
    for (i=0; i < fragments.getNumberOfFragments(); i++)
        all_fragments.appendFragment(fragments.getFragmentByNumber(i));

    aahelper.calcFragmentsEx(&peptide, // that is why we needed to create a peptide object first
                            ms_fragmentationrules::FRAG_Y_SERIES, // ions series ID
                            2,    // double-charged ions only
                            100.0,    // minimal fragment mass to return
                            mr,       // maximal fragment mass to return
                            matrix_science::MASS_TYPE_MONO,
                            &fragments,
                            &err);    // collect peptide-specific errors

    std::cout << "y++-ion series fragments: " << std::endl;
    printFragmentsTable(fragments);
    for (i=0; i < fragments.getNumberOfFragments(); i++)
        all_fragments.appendFragment(fragments.getFragmentByNumber(i));

    ions = aahelper.calcFragments(&peptide, // that is why we created a peptide object first
                                  ms_fragmentationrules::FRAG_INTERNAL_YB, // ions series ID
                                  false,    // single-charged ions only
                                  100.0,    // minimal fragment mass to return
                                  700,      // maximal fragment mass to return
                                  matrix_science::MASS_TYPE_MONO,
                                  &fragments,
                                  &err);    // collect peptide-specific errors

    std::cout << "internal yb-ion series fragments: " << std::endl;
    printFragmentsTable(fragments);
    for (i=0; i < fragments.getNumberOfFragments(); i++)
        all_fragments.appendFragment(fragments.getFragmentByNumber(i));

    std::cout << "Run a search under Mascot to verify the output above" << std::endl;
    std::cout << "Paste the following into a Mascot search query window:" << std::endl;
    displayMascotTestSearch(vecFixed, vecVariable,
                            enzyme,
                            mr,
                            b_ions);  // Or you can use all_fragments
    return 0;
}

static void printFragmentsTable(ms_fragmentvector & fragments)
{
    std::cout << "Number of fragments: " << fragments.getNumberOfFragments() << std::endl;

    std::cout << "Col\tStart\tEnd\tLabel\t\t Mass\t  NL\tName\tImmon\tIntern\tReg" << std::endl;
    for (int i=0; i < fragments.getNumberOfFragments(); i++)
    {
        const ms_fragment * frag = fragments.getFragmentByNumber(i);
        std::cout << frag->getColumn()     << "\t";
        std::cout << frag->getStart()      << "\t";
        std::cout << frag->getEnd()        << "\t";
        std::cout << std::setw(10) << frag->getLabel()      << "\t";
        std::cout << std::fixed << std::setprecision(2) << std::setw(7) << frag->getMass()       << "\t";
        std::cout << frag->getNeutralLoss()<< "\t";
        std::cout << frag->getSeriesName() << "\t";
        std::cout << frag->isImmonium()    << "\t";
        std::cout << frag->isInternal()    << "\t";
        std::cout << frag->isRegular()     << std::endl;
    }
    std::cout << std::endl;
}

static void displayMascotTestSearch(const ms_modvector      vecFixed,
                                    const ms_modvector      vecVariable,
                                    const ms_enzyme       * enzyme,
                                    const double            mr,
                                    const ms_fragmentvector fragments)
{
    /* fragments contains a list of b-ions from a peptide
     * vecVariable contains a list of variable mods applied to the peptide
     * vecFixed contains a list of fixed mods applied to the peptide
     * Use this information to generate an test search that can be run on Mascot.
     */
    int i;

    for (i=0; i < vecFixed.getNumberOfModifications(); i++)
    {
        std::cout << "MODS="
                  << vecFixed.getModificationByNumber(i)->getTitle()
                  << std::endl;
    }

    for (i=0; i < vecVariable.getNumberOfModifications(); i++)
    {
        std::cout << "IT_MODS="
                  << vecVariable.getModificationByNumber(i)->getTitle()
                  << std::endl;
    }
    std::cout << "CHARGE=Mr" << std::endl;
    std::cout << "CLE=" << enzyme->getTitle() << std::endl;
    std::cout << "INSTRUMENT=MALDI-TOF-TOF" << std::endl;
    std::cout << std::setprecision(3) << mr << " ions(";
    for(i=0; i < fragments.getNumberOfFragments(); i++)
    {
        if (i > 0)
            std::cout << ", ";
        std::cout << fragments.getFragmentByNumber(i)->getMass();
    }
    std::cout << ")" << std::endl;
}

/*
will give the output, for instance:

# tools_aahelper ../config/enzymes ../config/mod_file

List of peptides
M
MEDYLDELR
EDYLDELR
HK
IPSFIVELLK
NNLK
NR
NLTR
NQLNK
IVNR
VSDLYFGK
KPEDK
K
AAELTNK
INDLSHK
LDALMK
VATVSSATK
VSDDIK
K
EIDNLDELDL
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.494

Peptide has been created successfully: MEDYLDELR
b-ion series fragments:
Number of fragments: 8
Col     Start   End     Label            Mass     NL    Name    Immon   Intern  Reg
1       1       -1            b(1)       190.05 0.00    b       0       0       1
2       2       -1            b(2)       319.10 0.00    b       0       0       1
3       3       -1            b(3)       434.12 0.00    b       0       0       1
4       4       -1        b(4) -97       579.18 97.98   b       0       0       1
5       5       -1        b(5) -97       692.26 97.98   b       0       0       1
6       6       -1        b(6) -97       807.29 97.98   b       0       0       1
7       7       -1        b(7) -97       936.33 97.98   b       0       0       1
8       8       -1        b(8) -97      1049.41 97.98   b       0       0       1

y-ion series fragments:
Number of fragments: 8
Col     Start   End     Label            Mass     NL    Name    Immon   Intern  Reg
8       8       -1        y(8) -97      1034.48 97.98   y       0       0       1
7       7       -1        y(7) -97       905.44 97.98   y       0       0       1
6       6       -1        y(6) -97       790.41 97.98   y       0       0       1
5       5       -1            y(5)       645.36 0.00    y       0       0       1
4       4       -1            y(4)       532.27 0.00    y       0       0       1
3       3       -1            y(3)       417.25 0.00    y       0       0       1
2       2       -1            y(2)       288.20 0.00    y       0       0       1
1       1       -1            y(1)       175.12 0.00    y       0       0       1

internal yb-ion series fragments:
Number of fragments: 18
Col     Start   End     Label            Mass     NL    Name    Immon   Intern  Reg
2       2       3               ED       245.08 0.00    yb      0       1       0
2       2       4          EDY -97       390.13 97.98   yb      0       1       0
2       2       5         EDYL -97       503.21 97.98   yb      0       1       0
2       2       6        EDYLD -97       618.24 97.98   yb      0       1       0
3       3       4           DY -97       261.09 97.98   yb      0       1       0
3       3       5          DYL -97       374.17 97.98   yb      0       1       0
3       3       6         DYLD -97       489.20 97.98   yb      0       1       0
3       3       7        DYLDE -97       618.24 97.98   yb      0       1       0
4       4       5           YL -97       259.14 97.98   yb      0       1       0
4       4       6          YLD -97       374.17 97.98   yb      0       1       0
4       4       7         YLDE -97       503.21 97.98   yb      0       1       0
4       4       8        YLDEL -97       616.30 97.98   yb      0       1       0
5       5       6               LD       229.12 0.00    yb      0       1       0
5       5       7              LDE       358.16 0.00    yb      0       1       0
5       5       8             LDEL       471.24 0.00    yb      0       1       0
6       6       7               DE       245.08 0.00    yb      0       1       0
6       6       8              DEL       358.16 0.00    yb      0       1       0
7       7       8               EL       243.13 0.00    yb      0       1       0

Run a search under Mascot to verify the output above
Paste the following into a Mascot search query window:
MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
IT_MODS=Phospho (STY)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.494 ions(190.053, 319.096, 434.123, 579.176, 692.260, 807.287, 936.329, 1049.413)

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_aahelper.cs

For calculating peptide and fragment masses.

/*
##############################################################################
# file: tools_aahelper.cs                                                    #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/tools_aahelper.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Collections.Generic;
using matrix_science.msparser;
using System.Text;

namespace MsParserExamples
{
    class tools_aahelper
    {
        public static int Main(string[] argv)
        {
            if (argv.Length < 2)
            {
                // We need an enzyme to build a list of peptides and mod_file file if we
                // want to apply any modifications
                Console.Error.WriteLine("Location of enzymes file and mod_file have to be specified as parameters");
                return 1;
            }

            ms_enzymefile enzymefile;
            if (!openEnzymefile(argv[0], out enzymefile))
            {
                return 1;
            }

            // Note: enzymefile *must* me kept in scope for as long as you use 'trypsin'.
            // See "Using the toolkit from Perl, Java, Python and C#" in the Mascot Parser
            // manual.
            ms_enzyme trypsin = enzymefile.getEnzymeByName("Trypsin");

            if (trypsin == null)
            {
                Console.Error.WriteLine("Cannot find 'Trypsin' in the enzyme file.  Cannot continue.");
                return 1;
            }

            ms_modfile modfile;
            if(!openModfile(argv[1], out modfile)) {
                return 1;
            }

            ms_aahelper aahelper = new ms_aahelper();

            // Note: both modfile and trypsin *must* be kept in score for as long as
            // you use aahelper.  See "Using the toolkit from Perl, Java, Python and C#" in the
            // Mascot Parser manual.
            aahelper.setMasses(modfile.getMassFile());
            aahelper.setEnzyme(trypsin);

            // Now we can generate peptides for a given protein.  This is
            // RL29_METTP (50S ribosomal protein L29P OS=Methanosaeta thermophila (strain
            // DSM 6194 / PT) GN=rpl29p PE=3 SV=1) from SwissProt 2010_09.
            string proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";

            // No missed cleavages are allowed (third parameter)
            aahelper.startIteratePeptides(proteinStr, proteinStr.Length, 0);

            Console.WriteLine("List of peptides");

            while (aahelper.getNextPeptide())
            {
                int start = aahelper.getPepStart(), len = aahelper.getPepEnd() - aahelper.getPepStart() + 1;

                // getPepStart() returns one-based index
                string peptideStr = proteinStr.Substring(start - 1, len);
                Console.WriteLine(peptideStr);
            }

            Console.WriteLine("End of list\n");

            // Create a list of fixed modifications
            ms_modvector vecFixed = new ms_modvector();
            vecFixed.appendModification(modfile.getModificationByName("Phospho (Y)"));

            // Create a list of variable modifications
            ms_modvector vecVariable = new ms_modvector();
            vecVariable.appendModification(modfile.getModificationByName("Oxidation (M)"));
            vecVariable.appendModification(modfile.getModificationByName("Acetyl (N-term)"));

            // Note: Both vecFixed and vecVariable *must* be kept in scope for as long as you use
            // aahelper.  See "Using the toolkit from Perl, Java, Python and C#" in the
            // Mascot Parser manual
            aahelper.setAvailableModifications(vecFixed, vecVariable);

            // ms_aahelper can also contain errors that might happen when applying modifications,
            // for example when we have a conflict between two modifications (same residue or same
            // peptide end).
            if (!aahelper.isValid())
            {
                Console.WriteLine("Error while setting available modifications: {0}", aahelper.getLastErrorString());
                return 1;
            }

            // We will also need a separate error object for collecting peptide specific errors
            ms_errs err = new ms_errs();

            // Example of hot to call calcPeptideMZ().  It will often be more convenient to
            // create an ms_peptide instead, and the call getMrCalc() on that object
            vectori numThatMustBeModded = new vectori();
            numThatMustBeModded.Add(1); // 1 acetylNterm modification
            numThatMustBeModded.Add(1); // 1 site is oxidised

            double mr = aahelper.calcPeptideMZ(proteinStr,
                proteinStr.Length,
                1,
                10, // peptide ends (1-based)
                numThatMustBeModded,
                0,  // No charge - i.e. Mr
                MASS_TYPE.MASS_TYPE_MONO,
                err);

            if (!err.isValid())
            {
                Console.Error.WriteLine("Error while calculating peptide mass: {0}", err.getLastErrorString());
                // Don't need to halt as they are not fatal errors
                err.clearAllErrors();
            }
            else
            {
                Console.WriteLine("Peptide mass calculated using 'calcPeptideMZ' is {0:########.###}", mr);
            }

            // Create a peptide - which we can then fragment
            //
            // Specify which residues are modified and by whoch modification as it has to
            // correspond to a modification string:
            //
            // Nterm modification + 9 residues + Cterm modification
            vectori numModded = new vectori()
            {
                {2},    // N-term   - modified by 'Acetyl (N-term)'
                {1},    // M        - modified by 'Oxidation (M)'
                {0},    // A
                {0},    // I
                {0},    // F
                {0},    // R
                {0},    // I
                {0},    // D
                {0},    // E
                {0},    // I
                {0},    // R
                {0}     // C-Term
            };

            // We have to specify (or at least supply an empty vector) which neutral loss
            // value to use, in case there are more than one available for a modification
            vectori whichNL = new vectori() {
                {0},    // N-term
                {1},    // M            - has 2 neutral losses.  Specify the first (-98)
                {0},    // A
                {0},    // I
                {0},    // F
                {0},    // R
                {0},    // I
                {0},    // D
                {0},    // E
                {0},    // I
                {0},    // R
                {0}     // C-term
            };

            ms_peptide peptide = aahelper.createPeptide(
                proteinStr,
                proteinStr.Length,
                1,
                10,             // end position
                numModded,      // modification string-like vector
                whichNL,        // which neutral loss to use
                0,              // no charge
                MASS_TYPE.MASS_TYPE_MONO,
                err);

            if (!err.isValid())
            {
                Console.Error.WriteLine("Error while creating a peptide: {0}", err.getLastErrorString());
                // Don't need to halt as they are not fatal errors
                err.clearAllErrors();
            }
            else
            {
                Console.WriteLine("\n\nPeptide has been created successfully: {0}", peptide.getPeptideStr());
            }

            // Keep a list of fragments from all series
            ms_fragmentvector allFragments = new ms_fragmentvector();

            ms_fragmentvector bions = fragmentPeptide(aahelper,
                peptide,
                (int) ms_fragmentationrules.FRAG_SERIES_TYPE.FRAG_B_SERIES,
                "b-ions series",
                false,      // singly charged ions only
                mr      // maximal fragment mass to return
                );

            // copyFrom() an only be used to populate the list for the first time
            allFragments.copyFrom(bions);

            ms_fragmentvector fragments = fragmentPeptide(aahelper,
                peptide,
                (int) ms_fragmentationrules.FRAG_SERIES_TYPE.FRAG_Y_SERIES,
                "y-ion series",
                false,              // singly charged ions only
                mr                  // maximal fragment mass to return
                );

            for (uint i = 0; i < fragments.getNumberOfFragments(); i++)
            {
                allFragments.appendFragment(fragments.getFragmentByNumber(i));
            }

            fragments = fragmentPeptide(aahelper,
                peptide,
                (int)ms_fragmentationrules.FRAG_SERIES_TYPE.FRAG_INTERNAL_YB,
                "internal yb-ion series",
                false,              // singly charged ions only
                700                  // maximal fragment mass to return
                );

            for(uint i = 0; i < fragments.getNumberOfFragments(); i++) {
                allFragments.appendFragment(fragments.getFragmentByNumber(i));
            }

            Console.WriteLine("Paste the following into a Mascot search query window to verify this output:");
            displayMascotTestSearch(vecFixed, vecVariable, trypsin, peptide.getMrCalc(),
                bions); // or you can use allFragments

            return 0;
        }

        // vecFixed contains a list of fixed mods applied to the peptide
        // vecVariable contains a list of variable mods applied to the peptide
        // enzyme is the enzyme used
        // me if the peptide Mr(calc)
        // fragments contains a list of b-ions from a peptide
        //
        // use this information to generate a test search that can be run on Mascot
        private static void displayMascotTestSearch(ms_modvector vecFixed, ms_modvector vecVariable, ms_enzyme enzyme, double mr, ms_fragmentvector fragments)
        {
            for (int i = 0; i < vecFixed.getNumberOfModifications(); i++)
            {
                Console.WriteLine("MODS={0}", vecFixed.getModificationByNumber(i).getTitle());
            }
            for (int i = 0; i < vecVariable.getNumberOfModifications(); i++)
            {
                Console.WriteLine("IT_MODS={0}", vecVariable.getModificationByNumber(i).getTitle());
            }

            Console.WriteLine("CHARGE=Mr");
            Console.WriteLine("CLE={0}", enzyme.getTitle());
            Console.Write("{0:#.###} ions(", mr);

            StringBuilder sbIons = new StringBuilder();
            for (uint i = 0; i < fragments.getNumberOfFragments(); i++)
            {
                if (i > 0) sbIons.Append(", ");
                sbIons.Append(string.Format("{0:0.###}", fragments.getFragmentByNumber(i).getMass()));
            }
            Console.Write(sbIons);

            Console.WriteLine(")");
        }

        private static ms_fragmentvector fragmentPeptide(ms_aahelper aahelper, ms_peptide peptide, int series, string seriesLabel, bool doubleCharged, double massMax)
        {
            ms_fragmentvector fragments = new ms_fragmentvector();
            ms_errs err = new ms_errs();

            aahelper.calcFragments(
                peptide,
                series,
                doubleCharged,
                100d,
                massMax,
                MASS_TYPE.MASS_TYPE_MONO,
                fragments,
                err);

            if (!err.isValid())
            {
                Console.Error.WriteLine("Error while creating peptide {0} fragments: {1}", seriesLabel, err.getLastErrorString());
                err.clearAllErrors();
            }
            Console.WriteLine("{0} fragments", seriesLabel);
            printFragmentsTable(fragments);
            return fragments;
        }

        private static void printFragmentsTable(ms_fragmentvector fragments)
        {
            Console.WriteLine("Number of fragments: {0}", fragments.getNumberOfFragments());
            string fmt = "{0} {1} {2} {3} {4} {5} {6} {7} {8} {9}";

            Console.WriteLine(fmt, "Col".PadLeft(5),
                "Start".PadLeft(5),
                "End".PadLeft(5),
                "Label".PadLeft(10),
                "Mass".PadLeft(10),
                "NL".PadLeft(10),
                "Name",
                "Immon",
                "Intern",
                "Reg".PadLeft(4));

            for (uint i = 0; i < fragments.getNumberOfFragments(); i++)
            {
                ms_fragment frag = fragments.getFragmentByNumber(i);
                Console.WriteLine(fmt,
                    frag.getColumn().ToString().PadLeft(5),
                    frag.getStart().ToString().PadLeft(5),
                    frag.getEnd().ToString().PadLeft(5),
                    frag.getLabel().PadLeft(10),
                    string.Format("{0:######0.00}", frag.getMass()).PadLeft(10),
                    string.Format("{0:######0.00}", frag.getNeutralLoss()).PadLeft(10),
                    frag.getSeriesName().PadLeft(4),
                    (frag.isImmonium() ? "1" : "").PadLeft(5),
                    (frag.isInternal() ? "1" : "").PadLeft(6),
                    (frag.isRegular() ? "1" : "").PadLeft(4));
            }
            Console.WriteLine();
        }

        private static bool openModfile(string filename, out ms_modfile modfile)
        {
            // We can use the default masses in this example
            ms_masses masses = new ms_masses();
            modfile = new ms_modfile(filename, masses);
            if (!modfile.isValid())
            {
                Console.Error.WriteLine("Error while opening mod file: {0}", modfile.getLastErrorString());
                return false;
            }

            string[] aTargetMods = new string[]{"Oxidation (M)", "Acetyl (N-term)", "Phospho (Y)"};
            foreach(string mod in aTargetMods) {
                if (modfile.getModificationByName(mod) == null)
                {
                    Console.Error.WriteLine("Cannot find '{0}' in the mod file. Cannot continue.", mod);
                    return false;
                }
            }
            return true;
        }

        private static bool openEnzymefile(string filename, out ms_enzymefile enzymefile)
        {
            enzymefile = new ms_enzymefile(filename);
            if (!enzymefile.isValid())
            {
                Console.Error.WriteLine("Error while opening enzyme file: {0}", enzymefile.getLastErrorString());
                return false;
            }
            return true;
        }
    }
}

/*
tools_aahelper.exe c:\inetpub\mascot\config\enzymes c:\inetpub\mascot\config\mod_file
Will give the following output:

List of peptides
M
MAIFR
AIFR
IDEIR
NMSSEELEEELR
K
LEVELIR
ER
GAVR
AGGAPEKPGR
IR
EIR
R
TIAR
MK
TVQR
ER
VR
K
End of list

Peptide mass calculated using 'calcPeptideMZ' is 1320.686

Peptide has been created successfully: MAIFRIDEIR
b-ions series fragments
Number of fragments: 9
  Col Start   End      Label       Mass         NL Name Immon Intern  Reg
    1     1    -1       b(1)     190.05       0.00    b                 1
    2     2    -1       b(2)     261.09       0.00    b                 1
    3     3    -1       b(3)     374.17       0.00    b                 1
    4     4    -1       b(4)     521.24       0.00    b                 1
    5     5    -1       b(5)     677.34       0.00    b                 1
    6     6    -1       b(6)     790.43       0.00    b                 1
    7     7    -1       b(7)     905.45       0.00    b                 1
    8     8    -1       b(8)    1034.50       0.00    b                 1
    9     9    -1       b(9)    1147.58       0.00    b                 1

y-ion series fragments
Number of fragments: 9
  Col Start   End      Label       Mass         NL Name Immon Intern  Reg
    9     9    -1       y(9)    1132.65       0.00    y                 1
    8     8    -1       y(8)    1061.61       0.00    y                 1
    7     7    -1       y(7)     948.53       0.00    y                 1
    6     6    -1       y(6)     801.46       0.00    y                 1
    5     5    -1       y(5)     645.36       0.00    y                 1
    4     4    -1       y(4)     532.27       0.00    y                 1
    3     3    -1       y(3)     417.25       0.00    y                 1
    2     2    -1       y(2)     288.20       0.00    y                 1
    1     1    -1       y(1)     175.12       0.00    y                 1

internal yb-ion series fragments
Number of fragments: 22
  Col Start   End      Label       Mass         NL Name Immon Intern  Reg
    2     2     3         AI     185.13       0.00   yb            1
    2     2     4        AIF     332.20       0.00   yb            1
    2     2     5       AIFR     488.30       0.00   yb            1
    2     2     6      AIFRI     601.38       0.00   yb            1
    3     3     4         IF     261.16       0.00   yb            1
    3     3     5        IFR     417.26       0.00   yb            1
    3     3     6       IFRI     530.34       0.00   yb            1
    3     3     7      IFRID     645.37       0.00   yb            1
    4     4     5         FR     304.18       0.00   yb            1
    4     4     6        FRI     417.26       0.00   yb            1
    4     4     7       FRID     532.29       0.00   yb            1
    4     4     8      FRIDE     661.33       0.00   yb            1
    5     5     6         RI     270.19       0.00   yb            1
    5     5     7        RID     385.22       0.00   yb            1
    5     5     8       RIDE     514.26       0.00   yb            1
    5     5     9      RIDEI     627.35       0.00   yb            1
    6     6     7         ID     229.12       0.00   yb            1
    6     6     8        IDE     358.16       0.00   yb            1
    6     6     9       IDEI     471.24       0.00   yb            1
    7     7     8         DE     245.08       0.00   yb            1
    7     7     9        DEI     358.16       0.00   yb            1
    8     8     9         EI     243.13       0.00   yb            1

Paste the following into a Mascot search query window to verify this output:
MODS=Phospho (Y)
IT_MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
CHARGE=Mr
CLE=Trypsin
1320.686 ions(190.053, 261.09, 374.174, 521.243, 677.344, 790.428, 905.455, 1034.498, 1147.582)
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_aahelper.java

For calculating peptide and fragment masses.

/*
##############################################################################
# File: tools_aahelper.java                                                  #
# Mascot Parser toolkit example code                                         #
# Acknowledgment: Thanks to Tony Major, Celera Genomics for converting this  #
#                 file from the C++ example                                  #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2006 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_java/tools_aahelper.java $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
*/

import matrix_science.msparser.ms_enzymefile;
import matrix_science.msparser.ms_fragmentationrules;
import matrix_science.msparser.msparserConstants;
import matrix_science.msparser.*;
import java.text.*;

public class tools_aahelper {
    static {
        try {
            System.loadLibrary("msparserj");
        } catch (UnsatisfiedLinkError e) {
            System.err.println("Native code library failed to load. "
                               + "Is msparserj.dll on the path?\n" + e);
            System.exit(0);
        }
    }

    public static void main(String argv[])
    {
        // We need an enzyme to build a list of peptides
        // and mod_file file if we want to apply any modifications
        if(argv.length < 2) {
            System.out.println("Location of enzymes file and mod_file has to be specified as parameters");
            System.exit(0);
        }

        ms_enzymefile enzymefile = new ms_enzymefile(argv[0]);
        if ( !enzymefile.isValid() )
        {
            System.out.println("There are errors. Cannot continue. The last error description:");
            System.out.println(enzymefile.getLastErrorString());
            System.exit(1);
        }

        ms_enzyme enzyme = enzymefile.getEnzymeByName("Trypsin");
        if ( enzyme == null )
        {
            System.out.println("Cannot find Trypsin enzyme in the file. Cannot continue.");
            System.exit(1);
        }

        // we need masses file, but can use default masses anyway
        ms_masses masses = new ms_masses();
        ms_modfile modfile = new ms_modfile(argv[1], masses);
        if ( !modfile.isValid() )
        {
            System.out.println("There are errors. Cannot continue. The last error description:");
            System.out.println(modfile.getLastErrorString());
            System.exit(1);
        }

        ms_modification oxidation   = modfile.getModificationByName("Oxidation (M)");
        ms_modification acetylNterm = modfile.getModificationByName("Acetyl (N-term)");
        ms_modification phospho     = modfile.getModificationByName("Phospho (STY)");
        if ( oxidation == null || acetylNterm == null || phospho == null )
        {
            System.out.println("Cannot find necessary modifications in the mod_file. Cannot continue.");
            System.exit(1);
        }

        ms_aahelper aahelper = new ms_aahelper();
        aahelper.setMasses(masses);
        aahelper.setEnzyme(enzyme);

        // Now we can generate peptides for a given protein
        String proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";

        aahelper.startIteratePeptides(proteinStr, proteinStr.length(), 0);// no missed cleavages are allowed
        System.out.println("List of peptides");
        while(aahelper.getNextPeptide())
        {
            int start = aahelper.getPepStart()-1; // the method returns 1-based position
            int end = aahelper.getPepEnd();
            String peptideStr = proteinStr.substring(start, end);
            //peptideStr.assign(proteinStr+start, len);
            System.out.println(peptideStr);
        }

        System.out.println("End of list");

        // create a list of fixed modifications
        ms_modvector vecFixed = new ms_modvector();
        vecFixed.appendModification(phospho);

        // create a list of variable modifications
        ms_modvector vecVariable = new ms_modvector();
        vecVariable.appendModification(oxidation);
        vecVariable.appendModification(acetylNterm);

        aahelper.setAvailableModifications(vecFixed, vecVariable);

        // ms_aahelper can also contain errors that might happen when applying modifications
        // for instance, when we have a conflict between two modifications (same residue or same peptide end)
        if ( !aahelper.isValid() )
        {
            System.out.println("There are errors. Cannot continue. The last error description:");
            System.out.println(aahelper.getLastErrorString());
            System.exit(1);
        }

        // we will need also a separate error-object for collecting peptide-specific errors
        ms_errs err = new ms_errs();

        // Example of how to call calcPeptideMZ
        // It will often be more convenient to create an ms_peptide and then
        // call getMrCalc() on that object.
        vectori numThatMustBeModded = new vectori();
        numThatMustBeModded.add(1);  // 1 acetylNterm modification
        numThatMustBeModded.add(1);  // 1 site is phosphorylated

        double mr = aahelper.calcPeptideMZ(proteinStr, proteinStr.length(),
                                           1, 10, // peptide ends (1-based)
                                           numThatMustBeModded,
                                           0, // no charge
                                           msparserConstants.MASS_TYPE_MONO,
                                           err);
        if ( !err.isValid() )
        {
            System.out.println("There have been errors while calculating peptide mass: ");
            System.out.println(err.getLastErrorString());
            // don't need to halt as they are not fatal errors
            err.clearAllErrors(); // prepare to re-use it
        }
        else
        {
            DecimalFormat massFmt = new DecimalFormat("0.000");
            System.out.println("Peptide mass calculated using 'calcPeptideMZ' is " + massFmt.format(mr));
        }

        // Create a peptide - which we can then fragment
        //
        // Specify which residues are modified by which modification.
        // as it has to correspond to a modification string
        // Nterm modification + 9 residues + Cterm modification
        vectori numModded = new vectori();
        numModded.add(2);  // N-term  - modified by "Acetyl (N-term)"
        numModded.add(1);  // M       - modified by "Oxidation (M)"
        numModded.add(0);  // A
        numModded.add(0);  // I
        numModded.add(0);  // F
        numModded.add(0);  // R
        numModded.add(0);  // I
        numModded.add(0);  // D
        numModded.add(0);  // E
        numModded.add(0);  // I
        numModded.add(0);  // R
        numModded.add(0);  // C-term

        // we have to specify (or at least supply an empty vector) which neutral loss value to use
        // in case there are more than one available for a modification
        vectori whichNl = new vectori();
        whichNl.add(0);  // N-term
        whichNl.add(1);  // M - has 2 neutral losses. Specify the first (-98)
        whichNl.add(0);  // A
        whichNl.add(0);  // I
        whichNl.add(0);  // F
        whichNl.add(0);  // R
        whichNl.add(0);  // I
        whichNl.add(0);  // D
        whichNl.add(0);  // E
        whichNl.add(0);  // I
        whichNl.add(0);  // R
        whichNl.add(0);  // C-term

        ms_peptide peptide = aahelper.createPeptide(proteinStr, proteinStr.length(),
                                                    1,10, // end positions
                                                    numModded, // modification string-like vector
                                                    whichNl, // which neutral loss to use
                                                    0, // no charge
                                                    msparserConstants.MASS_TYPE_MONO,
                                                    err); // collect errors in it
        if ( !err.isValid() )
        {
            System.out.println("There have been errors while creating a peptide: ");
            System.out.println(err.getLastErrorString());
            // don't need to halt as they are not fatal errors
            err.clearAllErrors(); // prepare to re-use it
        }
        else
        {
            System.out.println();
            System.out.println();
            System.out.print("Peptide has been created successfully: ");
            System.out.println(peptide.getPeptideStr());
        }

        vectord ions;
        ms_fragmentvector fragments = new ms_fragmentvector();
        ms_fragmentvector all_fragments = new ms_fragmentvector();  // Keep a list of fragments from all series

        ions = aahelper.calcFragments(peptide, // that is why we needed to create a peptide object first
                                      ms_fragmentationrules.FRAG_B_SERIES, // ions series ID
                                      false, // single-charged ions only
                                      100.0, // minimal fragment mass to return
                                      mr,    // maximal fragment mass to return
                                      msparserConstants.MASS_TYPE_MONO,
                                      fragments,
                                      err); // collect peptide-specific errors

        System.out.println("b-ion series fragments: ");
        printFragmentsTable(fragments);
        all_fragments.copyFrom(fragments);
        ms_fragmentvector b_ions = new ms_fragmentvector();
        b_ions.copyFrom(fragments);

        ions = aahelper.calcFragments(peptide, // that is why we needed to create a peptide object first
                                      ms_fragmentationrules.FRAG_Y_SERIES, // ions series ID
                                      false, // single-charged ions only
                                      100.0, // minimal fragment mass to return
                                      mr,    // maximal fragment mass to return
                                      msparserConstants.MASS_TYPE_MONO,
                                      fragments,
                                      err); // collect peptide-specific errors

        System.out.println("y-ion series fragments: ");
        printFragmentsTable(fragments);
        for (int i=0; i < fragments.getNumberOfFragments(); i++)
            all_fragments.appendFragment(fragments.getFragmentByNumber(i));

        aahelper.calcFragmentsEx(peptide, // that is why we needed to create a peptide object first
                                 ms_fragmentationrules.FRAG_Y_SERIES, // ions series ID
                                 2, // double-charged only
                                 100.0, // minimal fragment mass to return
                                 mr,    // maximal fragment mass to return
                                 msparserConstants.MASS_TYPE_MONO,
                                 fragments,
                                 err); // collect peptide-specific errors

        System.out.println("y++-ion series fragments: ");
        printFragmentsTable(fragments);
        for (int i=0; i < fragments.getNumberOfFragments(); i++)
            all_fragments.appendFragment(fragments.getFragmentByNumber(i));

        ions = aahelper.calcFragments(peptide, // that is why we needed to create a peptide object first
                                      ms_fragmentationrules.FRAG_INTERNAL_YB, // ions series ID
                                      false, // single-charged ions only
                                      100.0, // minimal fragment mass to return
                                      700.0,    // maximal fragment mass to return
                                      msparserConstants.MASS_TYPE_MONO,
                                      fragments,
                                      err); // collect peptide-specific errors

        System.out.println("internal yb-ion series fragments: ");
        printFragmentsTable(fragments);
        for (int i=0; i < fragments.getNumberOfFragments(); i++)
            all_fragments.appendFragment(fragments.getFragmentByNumber(i));

        System.out.println("Run a search under Mascot to verify the output above");
        System.out.println("Paste the following into a Mascot search query window:");
        displayMascotTestSearch(vecFixed, vecVariable,
                                enzyme,
                                mr,
                                b_ions); // Or you can use all_fragments

        System.exit(0);
    }

    public static void printFragmentsTable(ms_fragmentvector fragments)
    {
        System.out.print("Number of fragments: ");
        System.out.println(fragments.getNumberOfFragments());

        System.out.println("Col\tStart\tEnd\tLabel\t\t Mass\t  NL\tName\tImmon\tIntern\tReg");
        int i;
        for (i=0; i < fragments.getNumberOfFragments(); i++)
        {
            ms_fragment frag = fragments.getFragmentByNumber(i);
            DecimalFormat fragMassFmt = new DecimalFormat("0.00");

            System.out.print(frag.getColumn());
            System.out.print("\t");
            System.out.print(frag.getStart());
            System.out.print("\t");
            System.out.print(frag.getEnd());
            System.out.print("\t");
            System.out.print(padding(frag.getLabel(), 10, " "));
            System.out.print("\t");
            System.out.print(padout(fragMassFmt.format(frag.getMass()),7," "));
            System.out.print("\t");
            System.out.print(fragMassFmt.format(frag.getNeutralLoss()));
            System.out.print("\t");
            System.out.print(frag.getSeriesName());
            System.out.print("\t");
            if (frag.isImmonium())
                System.out.print("1\t");
            else
                System.out.print("0\t");
            if (frag.isInternal())
                System.out.print("1\t");
            else
                System.out.print("0\t");
            if (frag.isRegular())
                System.out.print("1\n");
            else
                System.out.print("0\n");
        }
        System.out.println();
    }

    public static void displayMascotTestSearch(ms_modvector      vecFixed,
                                               ms_modvector      vecVariable,
                                               ms_enzyme         enzyme,
                                               double            mr,
                                               ms_fragmentvector fragments)
    {
        /* fragments contains a list of b-ions from a peptide
         * vecVariable contains a list of variable mods applied to the peptide
         * vecFixed contains a list of fixed mods applied to the peptide
         * Use this information to generate an test search that can be run on Mascot.
         */

        int i;
        for (i=0; i < vecFixed.getNumberOfModifications(); i++)
        {
            System.out.print("MODS=");
            System.out.println(vecFixed.getModificationByNumber(i).getTitle());
        }
        for (i=0; i < vecVariable.getNumberOfModifications(); i++)
        {
            System.out.print("IT_MODS=");
            System.out.println(vecVariable.getModificationByNumber(i).getTitle());
        }
        System.out.println("CHARGE=Mr");
        System.out.print("CLE=");
        System.out.println(enzyme.getTitle());
        System.out.println("INSTRUMENT=MALDI-TOF-TOF");
        DecimalFormat massFmt = new DecimalFormat("#0.000");
        System.out.print(massFmt.format(mr) + " ions(" );
        for(i=0; i < fragments.getNumberOfFragments(); i++)
        {
            if (i > 0)
                System.out.print(", ");
            double mz = fragments.getFragmentByNumber(i).getMass();
            System.out.print(massFmt.format(mz));
        }
        System.out.println(")");
    }

    private static String padout(String toPrint, int length,String padding) {

        String returnValue="";

        if(toPrint.length() < length) {
            for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
                returnValue += padding;
            }
            returnValue += toPrint;
        }
        else returnValue = toPrint;

        return returnValue;
    }

    private static String padding(String toPrint, int length,String padding) {

        String returnValue=toPrint;

        if(toPrint.length() < length) {
            for(int queryLoop = 1; queryLoop <= length - toPrint.length(); queryLoop++) {
                returnValue += padding;
            }
        }
        return returnValue;
    }

}

/*

will give the output:

C:\msparser\example_java>java  -classpath .;../java/msparser.jar tools_aahelper c:\Inetpub\MASCOT\config\enzymes c:\Inetpub\MASCOT\config\mod_file

List of peptides
M
MEDYLDELR
EDYLDELR
HK
IPSFIVELLK
NNLK
NR
NLTR
NQLNK
IVNR
VSDLYFGK
KPEDK
K
AAELTNK
INDLSHK
LDALMK
VATVSSATK
VSDDIK
K
EIDNLDELDL
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.494

Peptide has been created successfully: MEDYLDELR
b-ion series fragments:
Number of fragments: 8
Col     Start   End     Label            Mass     NL    Name    Immon   Intern  Reg
1       1       -1      b(1)             190.05 0.00    b       0       0       1
2       2       -1      b(2)             319.10 0.00    b       0       0       1
3       3       -1      b(3)             434.12 0.00    b       0       0       1
4       4       -1      b(4) -97         579.18 97.98   b       0       0       1
5       5       -1      b(5) -97         692.26 97.98   b       0       0       1
6       6       -1      b(6) -97         807.29 97.98   b       0       0       1
7       7       -1      b(7) -97         936.33 97.98   b       0       0       1
8       8       -1      b(8) -97        1049.41 97.98   b       0       0       1

y-ion series fragments:
Number of fragments: 8
Col     Start   End     Label            Mass     NL    Name    Immon   Intern  Reg
8       8       -1      y(8) -97        1034.48 97.98   y       0       0       1
7       7       -1      y(7) -97         905.44 97.98   y       0       0       1
6       6       -1      y(6) -97         790.41 97.98   y       0       0       1
5       5       -1      y(5)             645.36 0.00    y       0       0       1
4       4       -1      y(4)             532.27 0.00    y       0       0       1
3       3       -1      y(3)             417.25 0.00    y       0       0       1
2       2       -1      y(2)             288.20 0.00    y       0       0       1
1       1       -1      y(1)             175.12 0.00    y       0       0       1

internal yb-ion series fragments:
Number of fragments: 18
Col     Start   End     Label            Mass     NL    Name    Immon   Intern  Reg
2       2       3       ED               245.08 0.00    yb      0       1       0
2       2       4       EDY -97          390.13 97.98   yb      0       1       0
2       2       5       EDYL -97         503.21 97.98   yb      0       1       0
2       2       6       EDYLD -97        618.24 97.98   yb      0       1       0
3       3       4       DY -97           261.09 97.98   yb      0       1       0
3       3       5       DYL -97          374.17 97.98   yb      0       1       0
3       3       6       DYLD -97         489.20 97.98   yb      0       1       0
3       3       7       DYLDE -97        618.24 97.98   yb      0       1       0
4       4       5       YL -97           259.14 97.98   yb      0       1       0
4       4       6       YLD -97          374.17 97.98   yb      0       1       0
4       4       7       YLDE -97         503.21 97.98   yb      0       1       0
4       4       8       YLDEL -97        616.30 97.98   yb      0       1       0
5       5       6       LD               229.12 0.00    yb      0       1       0
5       5       7       LDE              358.16 0.00    yb      0       1       0
5       5       8       LDEL             471.24 0.00    yb      0       1       0
6       6       7       DE               245.08 0.00    yb      0       1       0
6       6       8       DEL              358.16 0.00    yb      0       1       0
7       7       8       EL               243.13 0.00    yb      0       1       0

Run a search under Mascot to verify the output above
Paste the following into a Mascot search query window:
MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
IT_MODS=Phospho (STY)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.494 ions(190.053, 319.096, 434.123, 579.176, 692.260, 807.287, 936.329, 1049.413)

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_aahelper.pl

For calculating peptide and fragment masses.

#!/usr/local/bin/perl
##############################################################################
# file: tools_aahelper.pl                                                    #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/tools_aahelper.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
##############################################################################

use msparser;

if (!defined($ARGV[0]) || !defined($ARGV[1])) {
    # We need an enzyme to build a list of peptides and mod_file file if we
    # want to apply any modifications.
    print "Location of enzymes file and mod_file has to be specified as parameters\n";
    exit 1;
}

my $enzymefile = open_enzymefile($ARGV[0]);

# Note: both $enzymefile *must* be kept in scope for as long as you use
# $Trypsin. See "Using the toolkit from Perl, Java and Python" in Mascot Parser
# manual.
my $Trypsin = $enzymefile->getEnzymeByName('Trypsin');

if (!$Trypsin) {
    print "Cannot find 'Trypsin' in the enzyme file. Cannot continue.\n";
    exit 1;
}

my $modfile = open_modfile($ARGV[1]);

my $aahelper = new msparser::ms_aahelper;
# Note: both $modfile and $Trypsin *must* be kept in scope for as
# long as you use $aahelper. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
$aahelper->setMasses($modfile->getMassFile);
$aahelper->setEnzyme($Trypsin);

# Now we can generate peptides for a given protein. This is
# RL29_METTP (50S ribosomal protein L29P OS=Methanosaeta thermophila (strain
# DSM 6194 / PT) GN=rpl29p PE=3 SV=1) from SwissProt 2010_09.
my $proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK";

# No missed cleavages are allowed (third parameter).
$aahelper->startIteratePeptides($proteinStr, length($proteinStr), 0);

print "List of peptides\n";

while ($aahelper->getNextPeptide) {
    my $start = $aahelper->getPepStart();
    my $len = $aahelper->getPepEnd() - $aahelper->getPepStart() + 1;

    # getPepStart() returns one-based index.
    my $peptideStr = substr($proteinStr, $start - 1, $len);
    print $peptideStr, "\n";
}

print "End of list\n\n";

# Create a list of fixed modifications.
my $vecFixed = new msparser::ms_modvector();
$vecFixed->appendModification(
    $modfile->getModificationByName('Phospho (Y)')
);

# Create a list of variable modifications.
my $vecVariable = new msparser::ms_modvector();
$vecVariable->appendModification(
    $modfile->getModificationByName('Oxidation (M)')
);
$vecVariable->appendModification(
    $modfile->getModificationByName('Acetyl (N-term)')
);

# Note: both $vecFixed and $vecVariable *must* be kept in scope for as
# long as you use $aahelper. See "Using the toolkit from Perl, Java and
# Python" in Mascot Parser manual.
$aahelper->setAvailableModifications($vecFixed, $vecVariable);

# ms_aahelper can also contain errors that might happen when applying
# modifications, for instance when we have a conflict between two
# modifications (same residue or same peptide end).
if (!$aahelper->isValid()) {
    print "Error while setting available modifications: ";
    print $aahelper->getLastErrorString(), "\n";
    exit(1);
}

# We will need also a separate error object for collecting peptide-specific
# errors.
my $err = new msparser::ms_errs();

# Example of how to call calcPeptideMZ(). It will often be more convenient to
# create an ms_peptide instead, and then call getMrCalc() on that object.
my $numThatMustBeModded = new msparser::vectori();
$numThatMustBeModded->push(1);  # 1 acetylNterm modification
$numThatMustBeModded->push(1);  # 1 site is oxidised

my $mr = $aahelper->calcPeptideMZ(
    $proteinStr,
    length($proteinStr),
    1,
    10, # peptide ends (1-based)
    $numThatMustBeModded,
    0, # no charge - i.e. Mr
    $msparser::MASS_TYPE_MONO,
    $err
);

if (!$err->isValid()) {
    print "Error while calculating peptide mass: ";
    print $err->getLastErrorString(), "\n";
    # Don't need to halt as they are not fatal errors.
    $err->clearAllErrors();
} else {
    printf "Peptide mass calculated using 'calcPeptideMZ' is %8.3f\n", $mr;
}

# Create a peptide - which we can then fragment.
#
# Specify which residues are modified by which modification as it has to
# correspond to a modification string:
#
# Nterm modification + 9 residues + Cterm modification
my $numModded = new msparser::vectori();
$numModded->push(2);  # N-term  - modified by "Acetyl (N-term)"
$numModded->push(1);  # M       - modified by "Oxidation (M)"
$numModded->push(0);  # A
$numModded->push(0);  # I
$numModded->push(0);  # F
$numModded->push(0);  # R
$numModded->push(0);  # I
$numModded->push(0);  # D
$numModded->push(0);  # E
$numModded->push(0);  # I
$numModded->push(0);  # R
$numModded->push(0);  # C-term

# We have to specify (or at least supply an empty vector) which neutral loss
# value to use, in case there are more than one available for a modification.
my $whichNl = new msparser::vectori();
$whichNl->push(0);  # N-term
$whichNl->push(1);  # M      - has 2 neutral losses. Specify the first (-98)
$whichNl->push(0);  # A
$whichNl->push(0);  # I
$whichNl->push(0);  # F
$whichNl->push(0);  # R
$whichNl->push(0);  # I
$whichNl->push(0);  # D
$whichNl->push(0);  # E
$whichNl->push(0);  # I
$whichNl->push(0);  # R
$whichNl->push(0);  # C-term

my $peptide = $aahelper->createPeptide(
    $proteinStr,
    length($proteinStr),
    1,
    10,          # end positions
    $numModded, # modification string-like vector
    $whichNl,   # which neutral loss to use
    0,          # no charge
    $msparser::MASS_TYPE_MONO,
    $err
);

if (!$err->isValid()) {
    print "Error while creating a peptide: ";
    print $err->getLastErrorString(), "\n";
    # Don't need to halt as they are not fatal errors.
    $err->clearAllErrors();
} else {
    print "\n\nPeptide has been created successfully: ";
    print $peptide->getPeptideStr(), "\n";
}

# Keep a list of fragments from all series
my $all_fragments = new msparser::ms_fragmentvector;

my $b_ions = fragmentPeptide(
    $aahelper,
    $peptide,
    $msparser::ms_fragmentationrules::FRAG_B_SERIES,
    'b-ion series',
    0,   # single-charged ions only
    $mr, # maximal fragment mass to return
);

# copyFrom() can only be used to populate the list for the first time.
$all_fragments->copyFrom($b_ions);

my $fragments = fragmentPeptide(
    $aahelper,
    $peptide,
    $msparser::ms_fragmentationrules::FRAG_Y_SERIES,
    'y-ion series',
    0,          # single-charged ions only
    $mr,        # maximal fragment mass to return
);

for my $i (0 .. $fragments->getNumberOfFragments - 1) {
    $all_fragments->appendFragment($fragments->getFragmentByNumber($i));
}

$fragments = fragmentPeptide(
    $aahelper,
    $peptide,
    $msparser::ms_fragmentationrules::FRAG_Y_SERIES,
    'y++-ion series',
    2,          # double-charged ions only
    $mr,        # maximal fragment mass to return
);

for my $i (0 .. $fragments->getNumberOfFragments - 1) {
    $all_fragments->appendFragment($fragments->getFragmentByNumber($i));
}

$fragments = fragmentPeptide(
    $aahelper,
    $peptide,
    $msparser::ms_fragmentationrules::FRAG_INTERNAL_YB,
    'internal yb-ion series',
    0,          # single-charged ions only
    700,        # maximal fragment mass to return
);

for my $i (0 .. $fragments->getNumberOfFragments - 1) {
    $all_fragments->appendFragment($fragments->getFragmentByNumber($i));
}

print "Paste the following into a Mascot search query window to verify this output:\n";

displayMascotTestSearch(
    $vecFixed, $vecVariable, $Trypsin, $peptide->getMrCalc,
    $b_ions # or you can use $all_fragments
);

sub open_enzymefile {
    my ($filename) = @_;

    my $enzymefile = new msparser::ms_enzymefile($filename);

    if (!$enzymefile->isValid) {
        print "Error while opening enzyme file: ";
        print $enzymefile->getLastErrorString() . "\n";
        exit 1;
    }

    return $enzymefile;
}

sub open_modfile {
    my ($filename) = @_;

    # We can use the default masses in this example.
    my $masses = new msparser::ms_masses;
    my $modfile = new msparser::ms_modfile($filename, $masses);

    if (!$modfile->isValid) {
        print "Error while opening mod file: ";
        print $modfile->getLastErrorString . "\n";
        exit 1;
    }

    for ('Oxidation (M)', 'Acetyl (N-term)', 'Phospho (Y)') {
        if (not $modfile->getModificationByName($_)) {
            print "Cannot find '$_' in the mod file. Cannot continue.\n";
            exit(1);
        }
    }

    return $modfile;
}

sub fragmentPeptide {
    my ($aa_helper, $peptide, $series, $series_label, $doubleCharged, $mass_max) = @_;

    my $fragments = new msparser::ms_fragmentvector;
    my $err = new msparser::ms_errs();

    $aahelper->calcFragments(
        $peptide,
        $series,
        $doubleCharged ? 1 : 0,
        100.0,
        $mass_max,
        $msparser::MASS_TYPE_MONO,
        $fragments,
        $err
    );

    # Check $err here.

    print $series_label, " fragments: \n";
    printFragmentsTable($fragments);

    return $fragments;
}

sub printFragmentsTable  {
    my ($fragments) = @_;

    print "Number of fragments: ", $fragments->getNumberOfFragments(), "\n";

    my $headerfmt = "%5s %5s %5s %-10s %7s %7s %4s %5s %6s %4s\n";
    my $fmt       = "%5s %5s %5s %-10s %7.2f %7.2f %4s %5s %6s %4s\n";

    printf $headerfmt, qw(Col Start End Label Mass NL Name Immon Intern Reg);

    for my $i (0 .. $fragments->getNumberOfFragments - 1) {
        my $frag = $fragments->getFragmentByNumber($i);

        printf $fmt,
            $frag->getColumn(),
            $frag->getStart(),
            $frag->getEnd(),
            $frag->getLabel(),
            $frag->getMass(),
            $frag->getNeutralLoss(),
            $frag->getSeriesName(),
            $frag->isImmonium(),
            $frag->isInternal(),
            $frag->isRegular(),
            ;
    }

    print "\n";
}

# $vecFixed contains a list of fixed mods applied to the peptide
# $vecVariable contains a list of variable mods applied to the peptide
# $enzyme is the enzyme used in fragmentation
# $mr is the peptide Mr(calc)
# $fragments contains a list of b-ions from a peptide
#
# Use this information to generate an test search that can be run on Mascot.
sub displayMascotTestSearch {
    my ($vecFixed, $vecVariable, $enzyme, $mr, $fragments) = @_;

    for my $i (0 .. $vecFixed->getNumberOfModifications-1) {
        printf "MODS=%s\n", $vecFixed->getModificationByNumber($i)->getTitle();
    }

    for my $i (0 .. $vecVariable->getNumberOfModifications-1) {
        printf "IT_MODS=%s\n", $vecVariable->getModificationByNumber($i)->getTitle();
    }

    print "CHARGE=Mr\n";
    print "CLE=", $enzyme->getTitle(), "\n";
    print "INSTRUMENT=MALDI-TOF-TOF\n";

    printf "%.3f ions(", $mr;

    print join(', ', map {
            sprintf("%.3f", $fragments->getFragmentByNumber($_)->getMass)
        } 0 .. $fragments->getNumberOfFragments-1
    );

    print ")\n";
}

=pod

Running the program as

perl -I../bin tools_aahelper.pl ../config/enzymes ../config/mod_file

will give the following output under Mascot 2.3:

List of peptides
M
MAIFR
AIFR
IDEIR
NMSSEELEEELR
K
LEVELIR
ER
GAVR
AGGAPEKPGR
IR
EIR
R
TIAR
MK
TVQR
ER
VR
K
End of list

Peptide mass calculated using 'calcPeptideMZ' is 1320.686

Peptide has been created successfully: MAIFRIDEIR
b-ion series fragments:
Number of fragments: 9
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    1     1    -1 b(1)        190.05    0.00    b                 1
    2     2    -1 b(2)        261.09    0.00    b                 1
    3     3    -1 b(3)        374.17    0.00    b                 1
    4     4    -1 b(4)        521.24    0.00    b                 1
    5     5    -1 b(5)        677.34    0.00    b                 1
    6     6    -1 b(6)        790.43    0.00    b                 1
    7     7    -1 b(7)        905.45    0.00    b                 1
    8     8    -1 b(8)       1034.50    0.00    b                 1
    9     9    -1 b(9)       1147.58    0.00    b                 1

y-ion series fragments:
Number of fragments: 9
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    9     9    -1 y(9)       1132.65    0.00    y                 1
    8     8    -1 y(8)       1061.61    0.00    y                 1
    7     7    -1 y(7)        948.53    0.00    y                 1
    6     6    -1 y(6)        801.46    0.00    y                 1
    5     5    -1 y(5)        645.36    0.00    y                 1
    4     4    -1 y(4)        532.27    0.00    y                 1
    3     3    -1 y(3)        417.25    0.00    y                 1
    2     2    -1 y(2)        288.20    0.00    y                 1
    1     1    -1 y(1)        175.12    0.00    y                 1

y++-ion series fragments:
Number of fragments: 8
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    9     9    -1 y(9)++      566.83    0.00    y                 1
    8     8    -1 y(8)++      531.31    0.00    y                 1
    7     7    -1 y(7)++      474.77    0.00    y                 1
    6     6    -1 y(6)++      401.23    0.00    y                 1
    5     5    -1 y(5)++      323.18    0.00    y                 1
    4     4    -1 y(4)++      266.64    0.00    y                 1
    3     3    -1 y(3)++      209.13    0.00    y                 1
    2     2    -1 y(2)++      144.61    0.00    y                 1

internal yb-ion series fragments:
Number of fragments: 22
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    2     2     3 AI          185.13    0.00   yb            1
    2     2     4 AIF         332.20    0.00   yb            1
    2     2     5 AIFR        488.30    0.00   yb            1
    2     2     6 AIFRI       601.38    0.00   yb            1
    3     3     4 IF          261.16    0.00   yb            1
    3     3     5 IFR         417.26    0.00   yb            1
    3     3     6 IFRI        530.34    0.00   yb            1
    3     3     7 IFRID       645.37    0.00   yb            1
    4     4     5 FR          304.18    0.00   yb            1
    4     4     6 FRI         417.26    0.00   yb            1
    4     4     7 FRID        532.29    0.00   yb            1
    4     4     8 FRIDE       661.33    0.00   yb            1
    5     5     6 RI          270.19    0.00   yb            1
    5     5     7 RID         385.22    0.00   yb            1
    5     5     8 RIDE        514.26    0.00   yb            1
    5     5     9 RIDEI       627.35    0.00   yb            1
    6     6     7 ID          229.12    0.00   yb            1
    6     6     8 IDE         358.16    0.00   yb            1
    6     6     9 IDEI        471.24    0.00   yb            1
    7     7     8 DE          245.08    0.00   yb            1
    7     7     9 DEI         358.16    0.00   yb            1
    8     8     9 EI          243.13    0.00   yb            1

Paste the following into a Mascot search query window to verify this output:
MODS=Phospho (Y)
IT_MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.686 ions(190.053, 261.090, 374.174, 521.243, 677.344, 790.428, 905.455, 1034.498, 1147.582)

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_aahelper.py

For calculating peptide and fragment masses.

#!/usr/bin/python
##############################################################################
# file: tools_aahelper.py                                                    #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/tools_aahelper.py $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################

import msparser
import sys

def main() :
    if len(sys.argv) < 3 :
        # We need an enzyme to build a list of peptides and mod_file file if we
        # want to apply any modifications.
        print("Location of enzymes file and mod_file has to be specified as parameters")
        return 1

    enzymefile = open_enzymefile(sys.argv[1])

    # Note: both enzymefile *must* be kept in scope for as long as you use
    # Trypsin. See "Using the toolkit from Perl, Java and Python" in Mascot Parser
    # manual.
    Trypsin = enzymefile.getEnzymeByName('Trypsin')

    if not Trypsin :
        print("Cannot find 'Trypsin' in the enzyme file. Cannot continue.")
        return 1

    modfile = open_modfile(sys.argv[2])

    aahelper = msparser.ms_aahelper()
    # Note: both modfile and Trypsin *must* be kept in scope for as
    # long as you use aahelper. See "Using the toolkit from Perl, Java and
    # Python" in Mascot Parser manual.
    aahelper.setMasses(modfile.getMassFile())
    aahelper.setEnzyme(Trypsin)

    # Now we can generate peptides for a given protein. This is
    # RL29_METTP (50S ribosomal protein L29P OS=Methanosaeta thermophila (strain
    # DSM 6194 / PT) GN=rpl29p PE=3 SV=1) from SwissProt 2010_09.
    proteinStr = "MAIFRIDEIRNMSSEELEEELRKLEVELIRERGAVRAGGAPEKPGRIREIRRTIARMKTVQRERVRK"

    # No missed cleavages are allowed (third parameter).
    aahelper.startIteratePeptides(proteinStr, len(proteinStr), 0);

    print("List of peptides")

    while aahelper.getNextPeptide() :
        start = aahelper.getPepStart();
        end = aahelper.getPepEnd()

        # getPepStart() and getPeptideEnd() return one-based index.
        peptideStr = proteinStr[start - 1 : end]
        print(peptideStr)

    print("End of list")

    # Create a list of fixed modifications.
    vecFixed = msparser.ms_modvector()
    vecFixed.appendModification( modfile.getModificationByName('Phospho (Y)') )

    # Create a list of variable modifications.
    vecVariable = msparser.ms_modvector()
    vecVariable.appendModification( modfile.getModificationByName('Oxidation (M)') )
    vecVariable.appendModification( modfile.getModificationByName('Acetyl (N-term)') )

    # Note: both vecFixed and vecVariable *must* be kept in scope for as
    # long as you use aahelper. See "Using the toolkit from Perl, Java and
    # Python" in Mascot Parser manual.
    aahelper.setAvailableModifications(vecFixed, vecVariable)

    # ms_aahelper can also contain errors that might happen when applying
    # modifications, for instance when we have a conflict between two
    # modifications (same residue or same peptide end).
    if not aahelper.isValid() :
        print("Error while setting available modifications: %s" % aahelper.getLastErrorString())
        return 1

    # We will need also a separate error object for collecting peptide-specific
    # errors.
    err = msparser.ms_errs()

    # Example of how to call calcPeptideMZ(). It will often be more convenient to
    # create an ms_peptide instead, and then call getMrCalc() on that object.
    numThatMustBeModded = msparser.vectori()
    numThatMustBeModded.append(1);  # 1 acetylNterm modification
    numThatMustBeModded.append(1);  # 1 site is oxidised

    mr = aahelper.calcPeptideMZ(
        proteinStr,
        len(proteinStr),
        1,
        10, # peptide ends (1-based)
        numThatMustBeModded,
        0, # no charge - i.e. Mr
        msparser.MASS_TYPE_MONO,
        err
        )

    if err.isValid() :
        print("Peptide mass calculated using 'calcPeptideMZ' is %8.3f" % mr)
    else :
        print("Error while calculating peptide mass: %s" % err.getLastErrorString())
        # Don't need to halt as they are not fatal errors.
        err.clearAllErrors();

    # Create a peptide - which we can then fragment.
    #
    # Specify which residues are modified by which modification as it has to
    # correspond to a modification string:
    #
    # Nterm modification + 9 residues + Cterm modification
    numModded = msparser.vectori()
    numModded.append(2)  # N-term  - modified by "Acetyl (N-term)"
    numModded.append(1)  # M       - modified by "Oxidation (M)"
    numModded.append(0)  # A
    numModded.append(0)  # I
    numModded.append(0)  # F
    numModded.append(0)  # R
    numModded.append(0)  # I
    numModded.append(0)  # D
    numModded.append(0)  # E
    numModded.append(0)  # I
    numModded.append(0)  # R
    numModded.append(0)  # C-term

    # We have to specify (or at least supply an empty vector) which neutral loss
    # value to use, in case there are more than one available for a modification.
    whichNl = msparser.vectori()
    whichNl.append(0)  # N-term
    whichNl.append(1)  # M      - has 2 neutral losses. Specify the first (-98)
    whichNl.append(0)  # A
    whichNl.append(0)  # I
    whichNl.append(0)  # F
    whichNl.append(0)  # R
    whichNl.append(0)  # I
    whichNl.append(0)  # D
    whichNl.append(0)  # E
    whichNl.append(0)  # I
    whichNl.append(0)  # R
    whichNl.append(0)  # C-term

    peptide = aahelper.createPeptide(
        proteinStr,
        len(proteinStr),
        1,
        10,          # end positions
        numModded, # modification string-like vector
        whichNl,   # which neutral loss to use
        0,          # no charge
        msparser.MASS_TYPE_MONO,
        err
        )

    if not err.isValid() :
        print("Error while creating a peptide: %s" % err.getLastErrorString())
        # Don't need to halt as they are not fatal errors.
        err.clearAllErrors()
    else :
        print("Peptide has been created successfully: %s" % peptide.getPeptideStr())

    # Keep a list of fragments from all series
    all_fragments = msparser.ms_fragmentvector()

    b_ions = fragmentPeptide(
        aahelper,
        peptide,
        msparser.ms_fragmentationrules.FRAG_B_SERIES,
        'b-ion series',
        0,   # single-charged ions only
        mr  # maximal fragment mass to return
        )

    # copyFrom() can only be used to populate the list for the first time.
    all_fragments.copyFrom(b_ions)

    fragments = fragmentPeptide(
        aahelper,
        peptide,
        msparser.ms_fragmentationrules.FRAG_Y_SERIES,
        'y-ion series',
        0,          # single-charged ions only
        mr         # maximal fragment mass to return
        )

    for i in range(fragments.getNumberOfFragments()) :
        all_fragments.appendFragment(fragments.getFragmentByNumber(i))

    fragments = fragmentPeptide(
        aahelper,
        peptide,
        msparser.ms_fragmentationrules.FRAG_Y_SERIES,
        'y++-ion series',
        2,          # double-charged ions only
        mr          # maximal fragment mass to return
        )

    for i in range(fragments.getNumberOfFragments()) :
        all_fragments.appendFragment(fragments.getFragmentByNumber(i))

    fragments = fragmentPeptide(
        aahelper,
        peptide,
        msparser.ms_fragmentationrules.FRAG_INTERNAL_YB,
        'internal yb-ion series',
        0,          # single-charged ions only
        700         # maximal fragment mass to return
        )

    for i in range(fragments.getNumberOfFragments()) :
        all_fragments.appendFragment(fragments.getFragmentByNumber(i))

    print("Paste the following into a Mascot search query window to verify this output:")

    displayMascotTestSearch(
        vecFixed, vecVariable, Trypsin, peptide.getMrCalc(),
        b_ions # or you can use all_fragments
        )

def open_enzymefile(filename) :
    enzymefile = msparser.ms_enzymefile(filename)

    if not enzymefile.isValid :
        print("Error while opening enzyme file: %s " % enzymefile.getLastErrorString())
        sys.exit(1)

    return enzymefile

def open_modfile(filename) :
    # We can use the default masses in this example.
    masses = msparser.ms_masses()
    modfile = msparser.ms_modfile(filename, masses)

    if not modfile.isValid() :
        print("Error while opening mod file: %s" % modfile.getLastErrorString())
        sys.exit(1)

    for mod in ['Oxidation (M)', 'Acetyl (N-term)', 'Phospho (Y)'] :
        if not modfile.getModificationByName(mod) :
            print("Cannot find '%s' in the mod file. Cannot continue." % mod)
            sys.exit(1)

    return modfile

def fragmentPeptide(aahelper, peptide, series, series_label, doubleCharged, mass_max) :
    fragments = msparser.ms_fragmentvector()
    err = msparser.ms_errs()

    aahelper.calcFragments(
        peptide,
        series,
        doubleCharged,
        100.0,
        mass_max,
        msparser.MASS_TYPE_MONO,
        fragments,
        err
        )

    # Check err here.

    print(series_label + " fragments:")
    printFragmentsTable(fragments)

    return fragments

def printFragmentsTable(fragments) :

    print("Number of fragments: %d" % fragments.getNumberOfFragments())

    headerfmt = "%5s %5s %5s %-10s %7s %7s %4s %5s %6s %4s"
    fmt       = "%5s %5s %5s %-10s %7.2f %7.2f %4s %5s %6s %4s"

    print(headerfmt % ("Col", "Start", "End", "Label", "Mass", "NL", "Name", "Immon", "Intern", "Reg"))

    for i in range(fragments.getNumberOfFragments()) :
        frag = fragments.getFragmentByNumber(i)

        print(fmt % (
            frag.getColumn(),
            frag.getStart(),
            frag.getEnd(),
            frag.getLabel(),
            frag.getMass(),
            frag.getNeutralLoss(),
            frag.getSeriesName(),
            frag.isImmonium(),
            frag.isInternal(),
            frag.isRegular()
            ))

    print(" ")

def displayMascotTestSearch(vecFixed, vecVariable, enzyme, mr, fragments) :
    """
    vecFixed contains a list of fixed mods applied to the peptide
    vecVariable contains a list of variable mods applied to the peptide
    enzyme is the enzyme used in fragmentation
    mr is the peptide Mr(calc)
    fragments contains a list of b-ions from a peptide

    Use this information to generate an test search that can be run on Mascot.
    """

    for i in range(vecFixed.getNumberOfModifications()) :
        print("MODS=%s" % vecFixed.getModificationByNumber(i).getTitle())

    for i in range(vecVariable.getNumberOfModifications()) :
        print("IT_MODS=%s" % vecVariable.getModificationByNumber(i).getTitle())

    print("CHARGE=Mr")
    print("CLE=%s" % enzyme.getTitle())
    print("INSTRUMENT=MALDI-TOF-TOF")

    masses = []
    for i in range(fragments.getNumberOfFragments()) :
        masses.append("%.3f" % fragments.getFragmentByNumber(i).getMass())

    print("%.3f ions(%s)" % (mr, ", ".join(masses)))

if __name__ == "__main__" :
    sys.exit(main())

"""

Running the program as

python tools_aahelper.pl /usr/local/mascot/config/enzymes /usr/local/mascot/config/mod_file

will give the following output under Mascot 2.3:

List of peptides
M
MAIFR
AIFR
IDEIR
NMSSEELEEELR
K
LEVELIR
ER
GAVR
AGGAPEKPGR
IR
EIR
R
TIAR
MK
TVQR
ER
VR
K
End of list
Peptide mass calculated using 'calcPeptideMZ' is 1320.686
Peptide has been created successfully: MAIFRIDEIR
b-ion series fragments:
Number of fragments: 9
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    1     1    -1 b(1)        190.05    0.00    b False  False True
    2     2    -1 b(2)        261.09    0.00    b False  False True
    3     3    -1 b(3)        374.17    0.00    b False  False True
    4     4    -1 b(4)        521.24    0.00    b False  False True
    5     5    -1 b(5)        677.34    0.00    b False  False True
    6     6    -1 b(6)        790.43    0.00    b False  False True
    7     7    -1 b(7)        905.45    0.00    b False  False True
    8     8    -1 b(8)       1034.50    0.00    b False  False True
    9     9    -1 b(9)       1147.58    0.00    b False  False True

y-ion series fragments:
Number of fragments: 9
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    9     9    -1 y(9)       1132.65    0.00    y False  False True
    8     8    -1 y(8)       1061.61    0.00    y False  False True
    7     7    -1 y(7)        948.53    0.00    y False  False True
    6     6    -1 y(6)        801.46    0.00    y False  False True
    5     5    -1 y(5)        645.36    0.00    y False  False True
    4     4    -1 y(4)        532.27    0.00    y False  False True
    3     3    -1 y(3)        417.25    0.00    y False  False True
    2     2    -1 y(2)        288.20    0.00    y False  False True
    1     1    -1 y(1)        175.12    0.00    y False  False True

y++-ion series fragments:
Number of fragments: 8
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    9     9    -1 y(9)++      566.83    0.00    y False  False True
    8     8    -1 y(8)++      531.31    0.00    y False  False True
    7     7    -1 y(7)++      474.77    0.00    y False  False True
    6     6    -1 y(6)++      401.23    0.00    y False  False True
    5     5    -1 y(5)++      323.18    0.00    y False  False True
    4     4    -1 y(4)++      266.64    0.00    y False  False True
    3     3    -1 y(3)++      209.13    0.00    y False  False True
    2     2    -1 y(2)++      144.61    0.00    y False  False True

internal yb-ion series fragments:
Number of fragments: 22
  Col Start   End Label         Mass      NL Name Immon Intern  Reg
    2     2     3 AI          185.13    0.00   yb False   True False
    2     2     4 AIF         332.20    0.00   yb False   True False
    2     2     5 AIFR        488.30    0.00   yb False   True False
    2     2     6 AIFRI       601.38    0.00   yb False   True False
    3     3     4 IF          261.16    0.00   yb False   True False
    3     3     5 IFR         417.26    0.00   yb False   True False
    3     3     6 IFRI        530.34    0.00   yb False   True False
    3     3     7 IFRID       645.37    0.00   yb False   True False
    4     4     5 FR          304.18    0.00   yb False   True False
    4     4     6 FRI         417.26    0.00   yb False   True False
    4     4     7 FRID        532.29    0.00   yb False   True False
    4     4     8 FRIDE       661.33    0.00   yb False   True False
    5     5     6 RI          270.19    0.00   yb False   True False
    5     5     7 RID         385.22    0.00   yb False   True False
    5     5     8 RIDE        514.26    0.00   yb False   True False
    5     5     9 RIDEI       627.35    0.00   yb False   True False
    6     6     7 ID          229.12    0.00   yb False   True False
    6     6     8 IDE         358.16    0.00   yb False   True False
    6     6     9 IDEI        471.24    0.00   yb False   True False
    7     7     8 DE          245.08    0.00   yb False   True False
    7     7     9 DEI         358.16    0.00   yb False   True False
    8     8     9 EI          243.13    0.00   yb False   True False

Paste the following into a Mascot search query window to verify this output:
MODS=Phospho (Y)
IT_MODS=Oxidation (M)
IT_MODS=Acetyl (N-term)
CHARGE=Mr
CLE=Trypsin
INSTRUMENT=MALDI-TOF-TOF
1320.686 ions(190.053, 261.090, 374.174, 521.243, 677.344, 790.428, 905.455, 1034.498, 1147.582)

"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_quant_helper.cs

Testing peptides for quantifiability.

/*
##############################################################################
# file: tools_quant_helper.cs                                                #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/tools_quant_helper.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.IO;
using System.Collections.Generic;
using matrix_science.msparser;

namespace MsParserExamples

{

    class tools_quant_helper

    {

        private const string QUANT_SCHEMA = @"http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd", UNIMOD_SCHEMA = @"http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd";

        public static int Main(string[] argv)
        {
            if (argv.Length == 0)
            {
                Console.Error.WriteLine("Usage: {0} <quantitation results.dat>", Path.GetFileName((new tools_quant_helper()).GetType().Assembly.Location));
                return 1;
            }

            ms_mascotresfile resfile = new ms_mascotresfile(argv[0]);

            if (!resfile.isValid())
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return 1;
            }

            // the details of loading the quantitation method and peptide summary object
            // are not relevant to this example (see methods at the end of the file for
            // implementation).
            ms_quant_configfile quantConfigFile;
            ms_quant_method qmethod;
            ms_peptidesummary pepSum;
            if (!loadMethod(resfile, out quantConfigFile, out qmethod)) return 1;
            ms_umod_configfile umodfile = null;
            if (!loadUmodConfigFile(resfile, out umodfile)) return 1;
            if (!loadPeptideSummary(resfile, out pepSum)) return 1;

            ms_quant_helper quantHelper = new ms_quant_helper(pepSum, qmethod, umodfile);
            if (!quantHelper.isValid())
            {
                Console.WriteLine("ms_quant_helper is not value: {0}", quantHelper.getLastErrorString());
                return 1;
            }
            List<ms_protein> proteins = pullProteinsFrom(pepSum);

            Console.WriteLine("File {0} uses {1} and has {2} family proteins", argv[0], qmethod.getName(), proteins.Count);

            dumpQuantMethod(qmethod);
            Console.WriteLine();

            Dictionary<int, string> peptideQuantStr = new Dictionary<int, string>()
            {
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_FIXEDMOD, "PEPTIDE_HAS_EXCLUDED_FIXEDMOD"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD, "PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD, "PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_EXCLUDED_VARMOD, "PEPTIDE_HAS_EXCLUDED_VARMOD"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD, "PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_NO_REQUIRED_VARMOD, "PEPTIDE_HAS_NO_REQUIRED_VARMOD"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_HAS_UNMODIFIED_SITE, "PEPTIDE_HAS_UNMODIFIED_SITE"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_IS_QUANTIFIABLE, "PEPTIDE_IS_QUANTIFIABLE"},
                {(int) ms_quant_helper.PEPTIDE_QUANTIFIABILITY.PEPTIDE_QUANTIFIABILITY_UNAVAILABLE, "PEPTIDE_QUANTIFIABILITY_UNAVAILABLE"}
            };

            Dictionary<int, string> peptideQualityStr = new Dictionary<int, string>()
            {
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_EXPECT_ABOVE_THRESHOLD, "PEPTIDE_EXPECT_ABOVE_THRESHOLD"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN, "PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_HAS_NO_EXCLUSIVE_MODS, "PEPTIDE_HAS_NO_EXCLUSIVE_MODS"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_NOT_UNIQUE, "PEPTIDE_NOT_UNIQUE"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_QUALITY_IS_OK, "PEPTIDE_QUALITY_IS_OK"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_QUALITY_UNAVAILABLE, "PEPTIDE_QUALITY_UNAVAILABLE"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_HOMOLOGY_THR, "PEPTIDE_SCORE_BELOW_HOMOLOGY_THR"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_IDENTITY_THR, "PEPTIDE_SCORE_BELOW_IDENTITY_THR"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM, "PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM"},
                {(int) ms_quant_helper.PEPTIDE_QUALITY.PEPTIDE_SCORE_BELOW_SCORE_THR, "PEPTIDE_SCORE_BELOW_SCORE_THR"}
            };

            foreach (ms_protein protein in proteins)
            {
                Console.WriteLine("Protein {0}::{1}", protein.getDB(), protein.getAccession());
                for (int i = 1; i <= protein.getNumPeptides(); i++)
                {
                    int q = protein.getPeptideQuery(i), p = protein.getPeptideP(i);
                    ms_peptide peptide = pepSum.getPeptide(q, p);
                    if (peptide == null) continue;

                    // Each peptide can be tested for two things:
                    // a) is it quantifiable?
                    // b) is it of high enough quality for quantification
                    //
                    // The two parameters are defined in the quantitation method object
                    // The two tests are orthogonal: the peptide need not pass test (a)
                    // in order to pass test (b), and vice versa.  Normally, for
                    // quantitation purposes, you can ignore peptides which fail either test,
                    // so you can continue straight to the next peptide if test (a) fails

                    // Test (a):
                    {
                        string reason;
                        int ok = quantHelper.isPeptideQuantifiable(q, p, protein, i, out reason);
                        Console.WriteLine("\tq{0}_p{1} quantifiable? {2} ({3})", q, p, peptideQuantStr[ok], (string.IsNullOrEmpty(reason) ? "" : reason));
                    }

                    // Test (b):
                    {
                        string reason;
                        int ok = quantHelper.isPeptideQualityOK(q, p, out reason);
                        Console.WriteLine("\tq{0}_p{1} quality? {2} ({3})", q, p, peptideQualityStr[ok], (string.IsNullOrEmpty(reason) ? "" : reason));
                    }

                }
            }

            pepSum.getNumberOfHits();
            resfile._params();

            return 0;
        }

        private static void dumpQuantMethod(ms_quant_method qmethod)
        {
            {
                List<string> comps = new List<string>();
                for (int i = 0; i < qmethod.getNumberOfComponents(); i++)
                {
                    comps.Add(qmethod.getComponentByNumber(i).getName());
                }
                Console.WriteLine("Components: [{0}]", string.Join(", ", comps));
            }

            Console.WriteLine("Protein ratio type = {0}", qmethod.getProteinRatioType());
            Console.WriteLine("Min. number of peptides = {0}", qmethod.getMinNumPeptides());

            if (qmethod.haveQuality())
            {
                var q = qmethod.getQuality();
                Console.WriteLine("Quality: min. precursor charge = {0}", q.getMinPrecursorCharge());
                Console.WriteLine("Quality: pep. threshold type = {0}", q.getPepThresholdType());
                Console.WriteLine("Quality: pep. threshold value = {0}", q.getPepThresholdValue());
            }
            else
            {
                Console.WriteLine("Quality: no restrictions");
            }

            if (qmethod.haveNormalisation())
            {
                var q = qmethod.getNormalisation();
                Console.WriteLine("Normalisation = {0}", q.getMethod());
            }
            else
            {
                Console.WriteLine("Normalisation: none");
            }

            if (qmethod.haveOutliers())
            {
                var q = qmethod.getOutliers();
                Console.WriteLine("Outliers = {0}", q.getMethod());
            }
            else
            {
                Console.WriteLine("Outliers: none");
            }
        }

        private static List<ms_protein> pullProteinsFrom(ms_peptidesummary pepsum)
        {
            List<ms_protein> proteins = new List<ms_protein>();
            for (int i = 1; i <= pepsum.getNumberOfHits(); i++)
            {
                ms_protein hit = pepsum.getHit(i);
                proteins.Add(hit);

                int j = 0;
                ms_protein protein;
                while((protein = pepsum.getNextFamilyProtein(i, ++j)) != null) {
                    proteins.Add(protein);
                }
            }
            return proteins;
        }

        private static bool loadPeptideSummary(ms_mascotresfile resfile, out ms_peptidesummary pepSum)//, out ms_peptidesummary pepsum)
        {
            // set pepsum to null so we can return out with false if the method fails
            pepSum = null;

            ms_mascotoptions opts = new ms_mascotoptions();

            uint flags, flags2, minpeplen;
            int maxhits;
            double minprob, iisb;
            bool usePepsum;
            resfile.get_ms_mascotresults_params(opts, out flags, out minprob, out maxhits, out iisb, out minpeplen, out usePepsum, out flags2);

            if (!usePepsum)
            {
                Console.Error.WriteLine("Results file cannot be opened as a peptide summary");
                return false;
            }

            pepSum = new ms_peptidesummary(resfile, flags, minprob, maxhits, "", iisb, (int) minpeplen, "", flags2);
            if (!resfile.isValid())
            {
                Console.Error.WriteLine(resfile.getLastErrorString());
                return false;
            }
            return true;
        }

        private static bool loadUmodConfigFile(ms_mascotresfile resfile, out ms_umod_configfile umodfile)
        {
            umodfile = new ms_umod_configfile();
            umodfile.setSchemaFileName(UNIMOD_SCHEMA);
            if (!resfile.getUnimod(umodfile))
            {
                Console.Error.WriteLine("Result file does not have a Unimod section");
                return false;
            }
            if (!umodfile.isValid())
            {
                Console.Error.WriteLine("Unimod file is not value: {0}", umodfile.getLastErrorString());
                return false;
            }

            string str = umodfile.validateDocument();
            if (str.Length > 0)
            {
                Console.Error.WriteLine("Unimod file does not validate: {0}", str);
                return false;
            }
            return true;
        }

        private static bool loadMethod(ms_mascotresfile resfile, out ms_quant_configfile quantConfigFile, out ms_quant_method qmethod)
        {
            // set the out values to null so we can return false without defining them
            quantConfigFile = null;
            qmethod = null;
            string quantMethodName = resfile._params().getQUANTITATION();
            if (quantMethodName == null || quantMethodName.Length == 0 || quantMethodName.Equals("none", StringComparison.OrdinalIgnoreCase))
            {
                Console.Error.WriteLine("File has no quantitation method");
                return false;
            }
            quantConfigFile = new ms_quant_configfile();
            quantConfigFile.setSchemaFileName(QUANT_SCHEMA);

            if (!resfile.getQuantitation(quantConfigFile))
            {
                Console.Error.WriteLine("File has no quantitation method: {0}", resfile.getLastErrorString());
                return false;
            }

            if (!quantConfigFile.isValid())
            {
                Console.Error.WriteLine("Quantitation file is not valid: {0}", quantConfigFile.getLastErrorString());
                return false;
            }

            string str = quantConfigFile.validateDocument();
            if (str.Length > 0)
            {
                Console.Error.WriteLine("Quantitation file does not validate: {0}", str);
                return false;
            }

            qmethod = quantConfigFile.getMethodByName(quantMethodName);

            if (qmethod == null)
            {
                Console.Error.WriteLine("Quantitation file has no method called: '{0}'", quantMethodName);
                return false;
            }
            return true;
        }
    }
}

/*
tools_quant_helper.exe ..\data\F981133.dat
Will give the following output:

File ..\data\F981133.dat uses SILAC K+6 R+6 multiplex and has 22 family proteins
Components: [light, heavy]
Protein ratio type = weighted
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto

Protein 1::K2C1_PANTR
    q18_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q18_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q33_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q33_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q55_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q55_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRYP_PIG
    q1_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q1_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q2_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q2_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q3_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q3_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q9_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q9_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q72_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q72_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q73_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q73_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q74_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q74_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q75_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q75_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q76_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q76_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q77_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q77_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q78_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q78_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q81_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q81_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q82_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q82_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q90_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q90_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q91_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q91_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGG2B_MOUSE
    q12_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q12_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q57_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q57_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q58_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q58_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q62_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q62_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q66_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q66_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ALBU_BOVIN
    q16_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q16_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q30_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q30_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q46_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q46_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q49_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q49_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q50_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q50_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::ENPL_MOUSE
    q4_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q4_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q19_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q19_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q20_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q20_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q41_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q41_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q42_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q42_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::NUCL_MOUSE
    q5_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q5_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q6_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q6_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q7_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q7_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q8_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q8_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q44_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q44_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q45_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q45_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q92_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q92_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q93_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q93_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::EPHB2_HUMAN
    q13_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q13_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q21_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q21_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q53_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q53_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q88_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q88_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::K2C1_RAT
    q33_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q33_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C75_BOVIN
    q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q38_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q40_p6 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p6 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HNRPU_HUMAN
    q32_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q32_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q34_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q34_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q51_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q51_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q52_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q52_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::SFPQ_HUMAN
    q14_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q14_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q15_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q15_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q22_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q22_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q69_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q69_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q70_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q70_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::CAPR1_MOUSE
    q23_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q23_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q36_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q36_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q37_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q37_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C1B_HUMAN
    q18_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q18_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q53_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q53_p3 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::ENPL_ARATH
    q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q41_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q41_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q42_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q42_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q67_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q67_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::VIME_CRIGR
    q17_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q17_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q35_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q35_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::BCAR1_MOUSE
    q10_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q10_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q11_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q11_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q63_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q63_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_ALKEH
    q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q67_p9 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q67_p9 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::FAK1_MOUSE
    q29_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q29_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_BDEBA
    q24_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p3 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p3 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C8_MOUSE
    q33_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q33_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRY1_RAT
    q72_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q72_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q73_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q73_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q74_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q74_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q75_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q75_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
    q76_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q76_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
    q78_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q78_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q81_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q81_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q82_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q82_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
Protein 1::IGKC_MOUSE
    q47_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q47_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q48_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q48_p1 quality? PEPTIDE_QUALITY_IS_OK ()
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_quant_helper.pl

Testing peptides for quantifiability.

#!/usr/local/bin/perl
##############################################################################
# file: tools_quant_helper.pl                                                #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/tools_quant_helper.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
##############################################################################

use msparser;

use constant {
    QUANT_SCHEMA => 'http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd',
    UNIMOD_SCHEMA => 'http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd',
};

if (not @ARGV) {
    print STDERR "Usage: $0 <quantitation results.dat>\n";
    exit 1;
}

my $resfile = msparser::ms_mascotresfile->new($ARGV[0]);

if (not $resfile->isValid) {
    print STDERR $resfile->getLastErrorString(), "\n";
    exit 1;
}

# The details of loading the quantitation method and peptide summary object
# are not relevant to this example (see end of file for implementation).
my ($quant_config_file, $qmethod) = load_method_or_exit($resfile);
my $umodfile = load_umod_configfile_or_exit($resfile);
my $pepsum = open_peptidesummary_or_exit($resfile);

my $quant_helper = msparser::ms_quant_helper->new($pepsum, $qmethod, $umodfile);

if (not $quant_helper->isValid) {
    printf STDERR "ms_quant_helper is not valid: %s\n", $quant_helper->getLastErrorString();
    exit 1;
}

my @proteins = pull_proteins_from($pepsum);

printf "File %s uses %s and has %d family proteins\n\n",
    $ARGV[0], $qmethod->getName(), scalar(@proteins);

dump_quant_method($qmethod);

print "\n";

# Reverse map of test result values for pretty printing purposes:
my (%peptide_quality_str, %peptide_quant_str);

do {
    no strict 'refs';

    %peptide_quality_str = map { ${"msparser::ms_quant_helper::$_"} => $_ } qw(
        PEPTIDE_QUALITY_IS_OK
        PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN
        PEPTIDE_SCORE_BELOW_SCORE_THR
        PEPTIDE_EXPECT_ABOVE_THRESHOLD
        PEPTIDE_SCORE_BELOW_IDENTITY_THR
        PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM
        PEPTIDE_SCORE_BELOW_HOMOLOGY_THR
        PEPTIDE_HAS_NO_EXCLUSIVE_MODS
        PEPTIDE_QUALITY_UNAVAILABLE
    );

    %peptide_quant_str = map { ${"msparser::ms_quant_helper::$_"} => $_ } qw(
        PEPTIDE_IS_QUANTIFIABLE
        PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD
        PEPTIDE_HAS_NO_REQUIRED_VARMOD
        PEPTIDE_HAS_EXCLUDED_FIXEDMOD
        PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD
        PEPTIDE_HAS_EXCLUDED_VARMOD
        PEPTIDE_HAS_UNMODIFIED_SITE
        PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD
        PEPTIDE_QUANTIFIABILITY_UNAVAILABLE
    );
};

for my $protein (@proteins) {
    printf "Protein %d::%s\n", $protein->getDB(), $protein->getAccession();

    for my $i (1 .. $protein->getNumPeptides()) {
        next if $protein->getPeptideDuplicate($i) == $msparser::ms_protein::DUPE_DuplicateSameQuery;

        my $q = $protein->getPeptideQuery($i);
        my $p = $protein->getPeptideP($i);

        my $peptide = $pepsum->getPeptide($q, $p);

        next if not $peptide;

        # Each peptide can be tested for two things:
        # a) is it quantifiable?
        # b) is it of high enough quality for quantification?
        #
        # The test parameters are defined in the quantitation method object.
        # The two tests are orthogonal: the peptide need not pass test (a)
        # in order to pass test (b), and vice versa. Normally, for quantitation
        # purposes, you can ignore peptides which fail either test, so you
        # can continue straight to the next peptide if test (a) fails.

        # Test (a):
        do {
            my ($ok, $reason) = $quant_helper->isPeptideQuantifiable($q, $p, $protein, $i);
            printf "\tq%d_p%d quantifiable? %s (%s)\n", $q, $p, $peptide_quant_str{$ok}, (defined $reason ? $reason : '<undef>');
        };

        # Test (b):
        do {
            my ($ok, $reason) = $quant_helper->isPeptideQualityOK($q, $p);
            printf "\tq%d_p%d quality? %s (%s)\n", $q, $p, $peptide_quality_str{$ok}, (defined $reason ? $reason : '<undef>');
        };
    }
}

# Load the quantitation method from the results file or exit with an error.
sub load_method_or_exit {
    my ($resfile) = @_;

    my $quant_method_name = $resfile->params->getQUANTITATION();

    if (not $quant_method_name or lc($quant_method_name) eq 'none') {
        print STDERR "File has no quantitation method\n";
        exit 1;
    }

    my $qf = msparser::ms_quant_configfile->new();

    $qf->setSchemaFileName(QUANT_SCHEMA);

    if (not $resfile->getQuantitation($qf)) {
        printf STDERR "File has no quantitation method (%s)\n", $resfile->getLastErrorString();
        exit 1;
    }

    if (not $qf->isValid) {
        printf STDERR "Quantitation file is not valid (%s)\n", $qf->getLastErrorString();
        exit 1;
    }

    if ('' ne (my $str = $qf->validateDocument())) {
        printf STDERR "Quantitation file does not validate (%s)\n", $str;
        exit 1;
    }

    my $qmethod = $qf->getMethodByName($quant_method_name);

    if (not $qmethod) {
        printf STDERR "Quantitation file has no method called '%s'\n", $quant_method_name;
        exit 1;
    }

    return ($qf, $qmethod);
}

# Load the Unimod section from the results file or exit with an error.
sub load_umod_configfile_or_exit {
    my ($resfile) = @_;

    my $umodfile = msparser::ms_umod_configfile->new();

    $umodfile->setSchemaFileName(UNIMOD_SCHEMA);

    if (not $resfile->getUnimod($umodfile)) {
        print STDERR "Results file does not have a Unimod section\n";
        exit 1;
    }

    if (not $umodfile->isValid) {
        printf STDERR "Unimod file is not valid (%s)\n", $umodfile->getLastErrorString();
        exit 1;
    }

    if ('' ne (my $str = $umodfile->validateDocument())) {
        printf STDERR "Unimod file does not validate (%s)\n", $str;
        exit 1;
    }

    return $umodfile;
}

# Load the results file as ms_peptidesummary or exit with an error.
sub open_peptidesummary_or_exit {
    my ($resfile) = @_;

    my $opts = msparser::ms_mascotoptions->new();

    my (undef, $flags, $minprob, $maxhits, $iisb, $minpeplen, $use_pepsum, $flags2)
        = $resfile->get_ms_mascotresults_params($opts);

    if (not $use_pepsum) {
        print STDERR "Results file cannot be opened as a peptide summary\n";
        exit 1;
    }

    my $pepsum = msparser::ms_peptidesummary->new(
        $resfile, $flags, $minprob, $maxhits, '', $iisb, $minpeplen, '', $flags2
    );

    if (not $resfile->isValid) {
        print STDERR $resfile->getLastErrorString, "\n";
        exit 1;
    }

    return $pepsum;
}

# Return a list of all top-level protein hits.
sub pull_proteins_from {
    my ($pepsum) = @_;

    my @proteins = ();

    for my $i (1 .. $pepsum->getNumberOfHits()) {
        my $hit = $pepsum->getHit($i);
        push @proteins, $hit;

        my $j = 0;
        while (my $protein = $pepsum->getNextFamilyProtein($i, ++$j)) {
            push @proteins, $protein;
        }
    }

    return @proteins;
}

# Print quantitation method parameters relevant to ms_quant_helper.
sub dump_quant_method {
    my ($qmethod) = @_;

    do {
        my @comps = ();

        for my $i (0 .. $qmethod->getNumberOfComponents()-1) {
            my $comp = $qmethod->getComponentByNumber($i);
            $comps[$i] = $comp->getName();
        }

        printf "Components: [%s]\n", join(', ', @comps);
    };

    printf "Protein ratio type = %s\n", $qmethod->getProteinRatioType();
    printf "Min. number of peptides = %d\n", $qmethod->getMinNumPeptides();

    if ($qmethod->haveQuality()) {
        my $q = $qmethod->getQuality();
        printf "Quality: min. precursor charge = %s\n", $q->getMinPrecursorCharge();
        printf "Quality: pep. threshold type = %s\n", $q->getPepThresholdType();
        printf "Quality: pep. threshold value = %s\n", $q->getPepThresholdValue();
    } else {
        printf "Quality: no restrictions\n";
    }

    if ($qmethod->haveNormalisation()) {
        my $q = $qmethod->getNormalisation();
        printf "Normalisation = %s\n", $q->getMethod();
    } else {
        printf "Normalisation: none\n";
    }

    if ($qmethod->haveOutliers()) {
        my $q = $qmethod->getOutliers();
        printf "Outliers = %s\n", $q->getMethod();
    } else {
        printf "Outliers: none\n";
    }
}

=pod

Running the program as

perl -I../bin tools_quant_helper.pl ../data/F981133.dat

will give the following output under Mascot 2.5:

File ../data/F981133.dat uses SILAC K+6 R+6 multiplex and has 23 family proteins

Components: [light, heavy]
Protein ratio type = weighted
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto

Protein 1::K2C1_HUMAN
    q18_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q18_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q33_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q33_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q55_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q55_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRYP_PIG
    q1_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q1_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q2_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q2_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q3_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q3_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q9_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q9_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q72_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q72_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q73_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q73_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q74_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q74_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q75_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q75_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q76_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q76_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q77_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q77_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q78_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q78_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q81_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q81_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q82_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q82_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q90_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q90_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q91_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q91_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGG2B_MOUSE
    q12_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q12_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q57_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q57_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q58_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q58_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q62_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q62_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q66_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q66_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ALBU_BOVIN
    q16_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q16_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q30_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q30_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q46_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q46_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q49_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q49_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q50_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q50_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::ENPL_MOUSE
    q4_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q4_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q19_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q19_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q20_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q20_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q41_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q41_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q42_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q42_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::NUCL_MOUSE
    q5_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q5_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q6_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q6_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q7_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q7_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q8_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q8_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q44_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q44_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q45_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q45_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q92_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q92_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q93_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q93_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::EPHB2_HUMAN
    q13_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q13_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q21_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q21_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q53_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q53_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q88_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q88_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::K2C1_RAT
    q33_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q33_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C75_BOVIN
    q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q38_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q38_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q40_p6 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q40_p6 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HNRPU_HUMAN
    q32_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q32_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q34_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q34_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q51_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q51_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q52_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q52_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::SFPQ_HUMAN
    q14_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q14_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q15_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q15_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q22_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q22_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q69_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q69_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q70_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q70_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::CAPR1_MOUSE
    q23_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q23_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q36_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q36_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q37_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q37_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ENPL_ARATH
    q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q41_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q41_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q42_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q42_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q67_p8 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q67_p8 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::VIME_CRIGR
    q17_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q17_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q35_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q35_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::BCAR1_MOUSE
    q10_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q10_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q11_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q11_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q63_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q63_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_ALHEH
    q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q67_p7 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q67_p7 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HTPG_HALHL
    q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q67_p9 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q67_p9 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HSC90_DICDI
    q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q67_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q67_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::FAK1_MOUSE
    q29_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q29_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::HTPG_BDEBA
    q24_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q24_p3 quality? PEPTIDE_QUALITY_IS_OK ()
    q26_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q26_p3 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C8_MOUSE
    q33_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q33_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRY1_RAT
    q72_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q72_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q73_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q73_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q74_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q74_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q75_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q75_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q76_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q76_p2 quality? PEPTIDE_QUALITY_IS_OK ()
    q78_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q78_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q81_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q81_p3 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
    q82_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q82_p2 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGKC_MOUSE
    q47_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q47_p1 quality? PEPTIDE_QUALITY_IS_OK ()
    q48_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
    q48_p1 quality? PEPTIDE_QUALITY_IS_OK ()
=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_quant_helper.py

Testing peptides for quantifiability.

#!/usr/bin/python
##############################################################################
# file: tools_quant_helper.py                                                #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/tools_quant_helper.py $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################

import msparser
import sys

QUANT_SCHEMA = 'http://www.matrixscience.com/xmlns/schema/quantitation_2 ../html/xmlns/schema/quantitation_2/quantitation_2.xsd http://www.matrixscience.com/xmlns/schema/quantitation_1 ../html/xmlns/schema/quantitation_1/quantitation_1.xsd'
UNIMOD_SCHEMA = 'http://www.unimod.org/xmlns/schema/unimod_2 ../html/xmlns/schema/unimod_2/unimod_2.xsd'

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

# Load the quantitation method from the results file or exit with an error.
def load_method_or_exit(resfile):
    params = msparser.ms_searchparams(resfile)
    quant_method_name = params.getQUANTITATION()
    if not quant_method_name or quant_method_name.lower() == 'none':
        print("File has no quantitation method")
        sys.exit(1)

    qf = msparser.ms_quant_configfile()
    qf.setSchemaFileName(QUANT_SCHEMA)

    if not resfile.getQuantitation(qf):
        print("File has no quantitation method (%s)" %(resfile.getLastErrorString()))
        sys.exit(1)

    if not qf.isValid():
        print("Quantitation file is not valid (%s)" %(qf.getLastErrorString()))
        sys.exit(1)

    str = qf.validateDocument()
    if str != '':
        print("Quantitation file does not vaidate (%s)" %(str))
        sys.exit(1)

    qmethod = qf.getMethodByName(quant_method_name)

    if not qmethod:
        print("Quantitation file has no method called %s" %(quant_method_name))
        sys.exit(1)

    return(qf, qmethod)

# Load the Unimod section from the results file or exit with an error.
def load_umod_configfile_or_exit(resfile):
    umodfile = msparser.ms_umod_configfile()
    umodfile.setSchemaFileName(UNIMOD_SCHEMA)
    if not resfile.getUnimod(umodfile):
        print("Results file does not have a Unimod section")
        sys.exit(1)

    if not umodfile.isValid():
        print("Unimod file is not valid (%s)" %(umodfile.getLastErrorString))
        sys.exit(1)

    str = umodfile.validateDocument()
    if not str == '':
        print("Unimod file does not validate (%s)" %(str))
        sys.exit(1)

    return umodfile

# Load the results file as ms_peptidesummary or exit with an error.
def open_peptidesummary_or_exit(resfile):
    opts = msparser.ms_mascotoptions()
    undef, flags, minprob, maxhits, iisb, minpeplen, use_pepsum, flags2 = resfile.get_ms_mascotresults_params(opts)

    if not use_pepsum:
        print("Results file cannot be opened as a peptide summary")
        sys.exit(1)

    pepsum = msparser.ms_peptidesummary(resfile, flags, minprob, maxhits, '', iisb, minpeplen, '', flags2)
    if not resfile.isValid():
        print(resfile.getLastErrorString)
        sys.exit(1)

    return pepsum

# Return a list of all top-level protein hits.
def pull_proteins_from(pepsum):
    proteins = []

    for i in ms_range(1, pepsum.getNumberOfHits()-1):
        hit = pepsum.getHit(i)
        proteins.append(hit)
        j = 1
        protein = pepsum.getNextFamilyProtein(i, j)

        while protein !=None:
            proteins.append(protein)
            j += 1
            protein = pepsum.getNextFamilyProtein(i, j)

    return proteins

# Print quantitation method parameters relevant to ms_quant_helper.
def dump_quant_method(qmethod):
    comps=[]
    for i in ms_range(0, qmethod.getNumberOfComponents()-1):
        comp = qmethod.getComponentByNumber(i)
        comps.append(comp.getName())

    print("Components: %s" %(comps))

    print("Protein ratio type = %s" %(qmethod.getProteinRatioType()))
    print("Min. number of peptides = %d" %(qmethod.getMinNumPeptides()))

    if qmethod.haveQuality():
        q = qmethod.getQuality()
        print("Quality: min. precursor charge = %s" %(q.getMinPrecursorCharge()))
        print("Quality: pep. threshold type = %s" %(q.getPepThresholdType()))
        print("Quality: pep. threshold value = %s" %(q.getPepThresholdValue()))
    else:
        print("Quality: no restrictions")

    if qmethod.haveNormalisation():
        q = qmethod.getNormalisation()
        print("Normalisation = %s" %(q.getMethod()))
    else:
        print("Normalisation: none")

    if qmethod.haveOutliers():
        q = qmethod.getOutliers()
        print("Outliers = %s" %(q.getMethod()))
    else:
        print("Outliers: none")

# If no arguments supplied, print help and exit

if len(sys.argv) < 2:
    print("Usage: %s <quantitation results.dat>" % sys.argv[0])
    sys.exit(1)

resfile = msparser.ms_mascotresfile(sys.argv[1],1)

if not resfile.isValid():
    print(resfile.getLastErrorString())
    sys.exit(1)

# The details of loading the quantitation method and peptide summary object
# are not relevant to this example (see end of file for implementation).
quant_config_file, qmethod = load_method_or_exit(resfile)
umodfile = load_umod_configfile_or_exit(resfile)
pepsum = open_peptidesummary_or_exit(resfile)

quant_helper = msparser.ms_quant_helper(pepsum, qmethod, umodfile)

if not quant_helper.isValid():
    print("ms_quant_helper is not valid: %s" %(quant_helper.getLastErrorString()))
    sys.exit(1)

proteins = pull_proteins_from(pepsum)

print("File %s uses %s and has %d family proteins\n" %(sys.argv[1], qmethod.getName(), len(proteins)))

dump_quant_method(qmethod)

print("\n")

peptide_quant_str = {
msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_FIXEDMOD: "PEPTIDE_HAS_EXCLUDED_FIXEDMOD",
msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD: "PEPTIDE_HAS_EXCLUDED_LOCAL_FIXEDMOD",
msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD: "PEPTIDE_HAS_EXCLUDED_LOCAL_VARMOD",
msparser.ms_quant_helper.PEPTIDE_HAS_EXCLUDED_VARMOD: "PEPTIDE_HAS_EXCLUDED_VARMOD",
msparser.ms_quant_helper.PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD: "PEPTIDE_HAS_NO_REQUIRED_FIXEDMOD",
msparser.ms_quant_helper.PEPTIDE_HAS_NO_REQUIRED_VARMOD: "PEPTIDE_HAS_NO_REQUIRED_VARMOD",
msparser.ms_quant_helper.PEPTIDE_HAS_UNMODIFIED_SITE: "PEPTIDE_HAS_UNMODIFIED_SITE",
msparser.ms_quant_helper.PEPTIDE_IS_QUANTIFIABLE: "PEPTIDE_IS_QUANTIFIABLE",
msparser.ms_quant_helper.PEPTIDE_QUANTIFIABILITY_UNAVAILABLE: "PEPTIDE_QUANTIFIABILITY_UNAVAILABLE"
};

peptide_quality_str = {
msparser.ms_quant_helper.PEPTIDE_EXPECT_ABOVE_THRESHOLD: "PEPTIDE_EXPECT_ABOVE_THRESHOLD",
msparser.ms_quant_helper.PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN: "PEPTIDE_CHARGE_BELOW_PRECURSOR_MIN",
msparser.ms_quant_helper.PEPTIDE_HAS_NO_EXCLUSIVE_MODS: "PEPTIDE_HAS_NO_EXCLUSIVE_MODS",
msparser.ms_quant_helper.PEPTIDE_NOT_UNIQUE: "PEPTIDE_NOT_UNIQUE",
msparser.ms_quant_helper.PEPTIDE_QUALITY_IS_OK: "PEPTIDE_QUALITY_IS_OK",
msparser.ms_quant_helper.PEPTIDE_QUALITY_UNAVAILABLE: "PEPTIDE_QUALITY_UNAVAILABLE",
msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_HOMOLOGY_THR: "PEPTIDE_SCORE_BELOW_HOMOLOGY_THR",
msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_IDENTITY_THR: "PEPTIDE_SCORE_BELOW_IDENTITY_THR",
msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM: "PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM",
msparser.ms_quant_helper.PEPTIDE_SCORE_BELOW_SCORE_THR: "PEPTIDE_SCORE_BELOW_SCORE_THR"
};

for protein in proteins:

    print("Protein %d::%s" %(protein.getDB(), protein.getAccession()))

    for i in ms_range(1, protein.getNumPeptides()-1):

        if protein.getPeptideDuplicate(i) == msparser.ms_protein.DUPE_DuplicateSameQuery:
            continue

        q = protein.getPeptideQuery(i)
        p = protein.getPeptideP(i)

        peptide = pepsum.getPeptide(q, p)

        if not peptide:
            continue

# Each peptide can be tested for two things:
# a) is it quantifiable?
# b) is it of high enough quality for quantification?
#
# The test parameters are defined in the quantitation method object.
# The two tests are orthogonal: the peptide need not pass test (a)
# in order to pass test (b), and vice versa. Normally, for quantitation
# purposes, you can ignore peptides which fail either test, so you
# can continue straight to the next peptide if test (a) fails.

# Test (a):
        ok, reason = quant_helper.isPeptideQuantifiable(q, p, protein, i)
        if reason == None:
            reason = '<undef>'
        print("\tq%d_p%d quantifiable? %s (%s)" %(q, p, peptide_quant_str[ok], reason))

# Test (b):
        ok, reason = quant_helper.isPeptideQualityOK(q, p)
        if reason == None:
            reason = '<undef>'
        print("\tq%d_p%d quality? %s (%s)" %(q, p, peptide_quality_str[ok], reason))

'''
When run from bin, tools_quant_helper.py ../data/F981133.dat
Will give the following output:

File ../data/F981133.dat uses SILAC K+6 R+6 multiplex and has 21 family proteins

Components: ['light', 'heavy']
Protein ratio type = weighted
Min. number of peptides = 2
Quality: min. precursor charge = 1
Quality: pep. threshold type = at least homology
Quality: pep. threshold value = 0.05
Normalisation: none
Outliers = auto

Protein 1::K2C1_PANTR
        q18_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q18_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q33_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q33_p2 quality? PEPTIDE_QUALITY_IS_OK ()
        q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::TRYP_PIG
        q1_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q1_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q2_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q2_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q3_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q3_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q9_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q9_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q72_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q72_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q73_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q73_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q74_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q74_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q75_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q75_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q76_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q76_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q77_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q77_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q78_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q78_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q81_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q81_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q82_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q82_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q90_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q90_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::IGG2B_MOUSE
        q12_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q12_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q57_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q57_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q58_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q58_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q62_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q62_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ALBU_BOVIN
        q16_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q16_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q30_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q30_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q46_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q46_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q49_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q49_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ENPL_MOUSE
        q4_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q4_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q19_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q19_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q20_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q20_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
        q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
        q41_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q41_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::NUCL_MOUSE
        q5_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q5_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q6_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q6_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q7_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q7_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q8_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q8_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q44_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q44_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q45_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q45_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q92_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q92_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::EPHB2_HUMAN
        q13_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q13_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q21_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q21_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q53_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q53_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C1_RAT
        q33_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q33_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q39_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q39_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C75_BOVIN
        q28_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q28_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q38_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q38_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HNRPU_HUMAN
        q32_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q32_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q34_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q34_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q51_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q51_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::SFPQ_HUMAN
        q14_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q14_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q15_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q15_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q22_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q22_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q69_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q69_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::CAPR1_MOUSE
        q23_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q23_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q36_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q36_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C1B_HUMAN
        q18_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q18_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q38_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q38_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q40_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q40_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::ENPL_ARATH
        q24_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q24_p2 quality? PEPTIDE_QUALITY_IS_OK ()
        q26_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q26_p2 quality? PEPTIDE_QUALITY_IS_OK ()
        q41_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q41_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q42_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q42_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::VIME_CRIGR
        q17_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q17_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::BCAR1_MOUSE
        q10_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q10_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q11_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q11_p1 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
Protein 1::HTPG_ALKEH
        q24_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q24_p1 quality? PEPTIDE_QUALITY_IS_OK ()
        q26_p1 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q26_p1 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::FAK1_MOUSE
Protein 1::HTPG_BDEBA
        q24_p3 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q24_p3 quality? PEPTIDE_QUALITY_IS_OK ()
Protein 1::K2C8_MOUSE
Protein 1::TRY1_RAT
        q72_p10 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q72_p10 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q73_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q73_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q74_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q74_p2 quality? PEPTIDE_QUALITY_IS_OK ()
        q75_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q75_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
        q76_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q76_p2 quality? PEPTIDE_SCORE_BELOW_IDENTITY_THR_NOHOM (Peptide score is below identity threshold (no homology threshold))
        q78_p2 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q78_p2 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)
        q81_p4 quantifiable? PEPTIDE_IS_QUANTIFIABLE ()
        q81_p4 quality? PEPTIDE_SCORE_BELOW_HOMOLOGY_THR (Peptide score is below homology threshold)

'''
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_shapiro_wilk.cs

Using the Shapiro-Wilk W test algorithm.

/*
##############################################################################
# file: tools_shapiro_wilk.cs                                                #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/tools_shapiro_wilk.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/
using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    class tools_shapiro_wilk
    {
        public static void Main(string[] argv)
        {
            ms_shapiro_wilk sw = new ms_shapiro_wilk();
            sw.appendSampleValue(-0.1420);
            sw.appendSampleValue(-0.1184);
            sw.appendSampleValue(-0.0583);
            sw.appendSampleValue(-0.0402);
            sw.appendSampleValue(-0.0363);
            sw.appendSampleValue(-0.0363);
            sw.appendSampleValue(-0.0348);
            sw.appendSampleValue(-0.0333);
            sw.appendSampleValue(-0.0222);
            sw.appendSampleValue(-0.0139);
            sw.appendSampleValue(-0.0114);
            sw.appendSampleValue(-0.0042);
            sw.appendSampleValue(-0.0036);
            sw.appendSampleValue(-0.0026);
            sw.appendSampleValue( 0.0000);
            sw.appendSampleValue( 0.0016);
            sw.appendSampleValue( 0.0058);
            sw.appendSampleValue( 0.0077);
            sw.appendSampleValue( 0.0084);
            sw.appendSampleValue( 0.0102);
            sw.appendSampleValue( 0.0132);
            sw.appendSampleValue( 0.0172);
            sw.appendSampleValue( 0.0180);
            sw.appendSampleValue( 0.0191);
            sw.appendSampleValue( 0.0194);
            sw.appendSampleValue( 0.0200);
            sw.appendSampleValue( 0.0246);
            sw.appendSampleValue( 0.0293);
            sw.appendSampleValue( 0.0533);
            sw.appendSampleValue( 0.0987);

            sw.calculate(30, 30, 15);
            string format = "{0} W = {1:0.######} and P = {2:0.######}{3}";
            Console.WriteLine(format, "Test should give", 0.892184, 0.0054, "");
            Console.WriteLine(format, "Results:", sw.getResult(), sw.getPValue(), "; error code = " + sw.getErrorCode());
        }
    }
}

/*
tools_shapiro_wilk.exe
Will give the following output:

Test should give W = 0.892184 and P = 0.0054
Results: W = 0.892184 and P = 0.005437; error code = 0
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_shapiro_wilk.pl

Using the Shapiro-Wilk W test algorithm.

#!/usr/local/bin/perl
##############################################################################
# file: tools_shapiro_wilk.pl                                                #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/tools_shapiro_wilk.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
##############################################################################

use msparser;

my $sw = new msparser::ms_shapiro_wilk;

$sw->appendSampleValue(-0.1420);
$sw->appendSampleValue(-0.1184);
$sw->appendSampleValue(-0.0583);
$sw->appendSampleValue(-0.0402);
$sw->appendSampleValue(-0.0363);
$sw->appendSampleValue(-0.0363);
$sw->appendSampleValue(-0.0348);
$sw->appendSampleValue(-0.0333);
$sw->appendSampleValue(-0.0222);
$sw->appendSampleValue(-0.0139);
$sw->appendSampleValue(-0.0114);
$sw->appendSampleValue(-0.0042);
$sw->appendSampleValue(-0.0036);
$sw->appendSampleValue(-0.0026);
$sw->appendSampleValue( 0.0000);
$sw->appendSampleValue( 0.0016);
$sw->appendSampleValue( 0.0058);
$sw->appendSampleValue( 0.0077);
$sw->appendSampleValue( 0.0084);
$sw->appendSampleValue( 0.0102);
$sw->appendSampleValue( 0.0132);
$sw->appendSampleValue( 0.0172);
$sw->appendSampleValue( 0.0180);
$sw->appendSampleValue( 0.0191);
$sw->appendSampleValue( 0.0194);
$sw->appendSampleValue( 0.0200);
$sw->appendSampleValue( 0.0246);
$sw->appendSampleValue( 0.0293);
$sw->appendSampleValue( 0.0533);
$sw->appendSampleValue( 0.0987);

$sw->calculate(30,30,15);
my $fmt = "%16s W = %8.6f and P = %8.6f%s\n";
printf $fmt, "Test should give", 0.892184, 0.0054, '';
printf $fmt, "Results:", $sw->getResult, $sw->getPValue(), "; error code = " . $sw->getErrorCode();
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:20


tools_shapiro_wilk.py

Using the Shapiro-Wilk W test algorithm.

#!/usr/bin/python
##############################################################################
# file: tools_shapiro_wilk.py                                                #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/tools_shapiro_wilk.py $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################

import msparser

sw = msparser.ms_shapiro_wilk()

sw.appendSampleValue(-0.1420)
sw.appendSampleValue(-0.1184)
sw.appendSampleValue(-0.0583)
sw.appendSampleValue(-0.0402)
sw.appendSampleValue(-0.0363)
sw.appendSampleValue(-0.0363)
sw.appendSampleValue(-0.0348)
sw.appendSampleValue(-0.0333)
sw.appendSampleValue(-0.0222)
sw.appendSampleValue(-0.0139)
sw.appendSampleValue(-0.0114)
sw.appendSampleValue(-0.0042)
sw.appendSampleValue(-0.0036)
sw.appendSampleValue(-0.0026)
sw.appendSampleValue( 0.0000)
sw.appendSampleValue( 0.0016)
sw.appendSampleValue( 0.0058)
sw.appendSampleValue( 0.0077)
sw.appendSampleValue( 0.0084)
sw.appendSampleValue( 0.0102)
sw.appendSampleValue( 0.0132)
sw.appendSampleValue( 0.0172)
sw.appendSampleValue( 0.0180)
sw.appendSampleValue( 0.0191)
sw.appendSampleValue( 0.0194)
sw.appendSampleValue( 0.0200)
sw.appendSampleValue( 0.0246)
sw.appendSampleValue( 0.0293)
sw.appendSampleValue( 0.0533)
sw.appendSampleValue( 0.0987)

sw.calculate(30,30,15)

print("Test should give W = %8.6f and P = %8.6f" % (0.892184, 0.0054))
print("Results:         W = %8.6f and P = %8.6f; error code = %d" % (
        sw.getResult(), sw.getPValue(), sw.getErrorCode()
        ))
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_stats.cs

Using statistical routines.

/*
##############################################################################
# file: tools_stats.cs                                                       #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/tools_stats.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.Collections.Generic;
using matrix_science.msparser;

namespace MsParserExamples
{
    class tools_stats
    {

        public static void Main(string[] args)
        {
            Console.WriteLine("Binomial coefficients for sample size 6:");

            for (int i = 0; i <= 6; i++)
            {
                Console.WriteLine("\t6 choose {0} = {1}", i, ms_quant_stats.binomialCoefficient(6, (uint) i));
            }

            Console.WriteLine("First 10 values of the Poisson (lambda = 1) distribution");
            for (int i = 1; i <= 10; i++)
            {
                Console.WriteLine("\tPoisson(lambda 1, k {0}) = {1}", i, ms_quant_stats.poissonDensity(1, (uint) i));
            }

            Console.WriteLine("Common values of the standard normal distribution");
            foreach (double t in (new double[] {0.001, 0.01, 0.025, 0.05, 0.1, 0.5, 0.9, 0.95, 0.975, 0.99, 0.999})) {
                // Note that normalCriticalValue() takes and argument between 0.5 and 1.0;
                // that is, it returns only the right tail critical values
                double critval;
                if (t < 0.5)
                {
                    critval = -ms_quant_stats.normalCriticalValue(1d - t);
                }
                else
                {
                    critval = ms_quant_stats.normalCriticalValue(t);
                }
                Console.WriteLine("\tNormal-1({0}) = {1}", t, critval);
            }

            foreach (double t in (new double[] {-3.09, -2.32, -1.96, -1.64, -1.28, 0, 1.28, 1.64, 1.96, 2.32, 3.09}))
            {
                // Note that normalCumulativeProbability() takes and argument between 0 and 4.09; that is
                // it reports only the right tail probability
                double p;
                if (t < 0)
                {
                    p = 0.5 - ms_quant_stats.normalCumulativeProbability(-t);
                }
                else
                {
                    p = 0.5 + ms_quant_stats.normalCumulativeProbability(t);
                }
                Console.WriteLine("\tNormal(x <= {0}) = {1:0.######}", t, p);
            }

            Console.WriteLine("Common values of the chi-squared distribution at 10 degrees of freedom:");

            // Note the significance levels the chi-square functions support
            foreach (double t in (new double[] {0.001, 0.01, 0.025, 0.05, 0.1})) {
                double lowcrit = ms_quant_stats.chisqLowerCriticalValue(10, t);
                double upcrit = ms_quant_stats.chisqUpperCriticalValue(10, t);
                Console.WriteLine("\tchi-sq(df 10, sigLevel {0}) = <{1}, {2}>", t, lowcrit, upcrit);
            }

            Console.WriteLine("Common values of the Student's t distribution at 10 degrees of freedom:");

            // Note the significance levels the Student's t function supports.
            foreach (double t in (new double[] {0.001, 0.005, 0.01, 0.025, 0.05, 0.1}))
            {
                Console.WriteLine("\tt(df 10, sigLevel {0}) = {1}", t, ms_quant_stats.studentsCriticalValue(10, t));
            }

            Console.WriteLine("Common values of the F distribution at 10 and 1 degrees of freedom:");

            // Note the significance levels the F function supports
            foreach(double t in (new double[] {0.01, 0.05, 0.1}))
            {
                Console.WriteLine("\tF(df1 10, df2 1, sifLevel {0}) = {1}", t, ms_quant_stats.snedecorsCriticalValue(10, 1, t));
            }

            // see Sample struct below
            List<Sample> samples = new List<Sample>();

            // uniform data generated with
            // perl -e 'print join "\n", map {+ rand() } 0 .. 0'
            samples.Add(new Sample("uniform(0,1)",
                        new double[] { 0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424 ,
                        0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575},
                        0.5));

            // Normal (5, 2.5) data generated in R with
            // > rnorm(10, 5, 2.5)
            samples.Add(new Sample("normal(5, 2.5)",
                new double[] { 3.1476833, 9.2061900, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.0542840, 0.6643241,4.3697818},
                5));

            // Beta (0.5, 0.5) data generated in R with
            // > rbeta(10, 0.5, 0.5)
            samples.Add(new Sample("beta(0.5, 0.5)",
                new double[] { 0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737 ,
                0.877643550 ,0.128030530 },
                0.5));

            Console.WriteLine();
            foreach (Sample sample in samples)
            {
                vectord vec = sample.Data;
                // Note: vectord does not provided a ToArray method as standard.  The ToArray method used
                // here is an extension implemented in the VectordExtensionMethods class (see below)
                Console.WriteLine("Sample '{0}' = [{1}]", sample.SampleName, string.Join(", ", vec.ToArray()));

                // The sorted sample vector is needed for the Shapiro-Wilk W test
                // it also makes finsing the sample median fast
                vectord vecSorted = sample.SortedData;

                // Auxiliary helper functions:
                Console.WriteLine("\tSum = {0:#.#####}", ms_quant_stats.sum(vec));
                Console.WriteLine("\tSum of squares = {0:#.#####}", ms_quant_stats.sumsq(vec));

                // Note: vectord does not provided a ToArray method as standard.  The ToArray method used
                // here is an extension implemented in the VectordExtensionMethods class (see below)
                Console.WriteLine("\tLog transformed = [{0}]", string.Join(", ", ms_quant_stats.logTransform(vec).ToArray()));
                Console.WriteLine("\tExp transformed = [{0}]", string.Join(", ", ms_quant_stats.expTransform(vec).ToArray()));

                // Basic sample statistics
                double xbar = ms_quant_stats.arithmeticMean(vec);
                double stdev = ms_quant_stats.arithmeticStandardDeviation(vec, xbar);
                double median = ms_quant_stats.sortedMedian(vecSorted);
                // If the vector isn't sorted:
                // double median = ms_quant_stats.unsortedMedian(vec);

                double geombar = ms_quant_stats.geometricMean(vec);
                double geomdev = ms_quant_stats.geometricStandardDeviation(vec, xbar);

                Console.WriteLine("\tArithmetic stdev = {0}", stdev);
                Console.WriteLine("\tArithmetic mean = {0}", xbar);
                Console.WriteLine("\tStandard error of mean = {0}", ms_quant_stats.arithmeticStandardErrorOfMean(stdev, (uint)vec.Count));
                Console.WriteLine("\tMedian = {0}", median);
                Console.WriteLine("\tStandard error of median = {0}", ms_quant_stats.arithmeticStandardErrorOfMedian(stdev, (uint)vec.Count));
                Console.WriteLine("\tGeometric mean = {0}", geombar);
                Console.WriteLine("\tGeometric stdev = {0}", geomdev);

                // Basic distribution tests for normally distributed data:
                Console.WriteLine("\tHypothesis: distribution is N({0}, sigma^2) (mean test). p-value = {1:0.#####}", sample.PopulationMean,
                    ms_quant_stats.calculateNormalMeanPvalue(sample.PopulationMean, xbar, stdev, (uint)vec.Count));

                Console.WriteLine("\tHypothesis: distribution is N({0}, sigma^2) (median test). p-value = {1:0.#####}", sample.PopulationMean,
                    ms_quant_stats.calculateNormalMedianPvalue(sample.PopulationMean, median, stdev, (uint)vec.Count));

                // (We would expect the normal sample to have the highest p-value, i.e.
                // least evidence against the hypothesis, while the uniform and beta
                // distributions should have fairly low p-values.  However, sample size is
                // so small that the tests are not very reliable)

                {
                    double W, p;
                    bool ok = ms_quant_stats.testShapiroWilkW(vecSorted, out W, out p);
                    Console.WriteLine("\tShapiro-Wilk ok = {0}, W = {1}, p-value = {2}", ok, W != 0 ? W.ToString() : "(none)",
                        p != 0 ? p.ToString() : "(none)");
                }

                // outlier detection can be done even when the above tests indicate that the
                // sample is not normally distributed - after outlier removal, the sample may
                // be normally distributed!
                {
                    uint numL, numH;
                    ms_quant_stats.detectOutliers(vecSorted, "auto", 0.05, out numL, out numH);

                    // numL and numH are the number of elements at each end of vecSorted
                    // which seem to be outliers.  That is, elements between 0 and numL-1, and
                    // vecSorted.Count-numH to vecSorted.Count-1.

                    Console.WriteLine("\tOutlier detection('auto',0.05) = <{0}, {1}>", numL,
                        numH);
                }

                Console.WriteLine();
            }

        }

    }

    public static class VectordExtensionMethods
    {
        // vectord doesn't provide a ToArray method, instead providing a CopyTo method for
        // populating an existing double array.  This extension class adds a
        // ToArray helper method to vectord
        public static double[] ToArray(this vectord vector)
        {
            double[] data = new double[vector.Count];
            vector.CopyTo(data);
            return data;
        }
    }

    struct Sample
    {
        private string Name;
        private double[] data;
        private double PopMean;

        public Sample(string name, double[] data, double popmean)
        {
            this.Name = name;
            this.data = data;
            this.PopMean = popmean;
        }

        public string SampleName
        {
            get
            {
                return Name;
            }
        }

        public double PopulationMean
        {
            get
            {
                return PopMean;
            }
        }

        public vectord Data
        {
            get
            {
                return new vectord(data);
            }
        }

        public vectord SortedData
        {
            get
            {
                // maintain the underlying data array unsorted
                double[] dataCopy = new double[data.Length];
                this.Data.CopyTo(dataCopy);
                Array.Sort(dataCopy);
                return new vectord(dataCopy);
            }
        }
    }
}

/*
tools_stats.exe
Will give the following output

Binomial coefficients for sample size 6:
    6 choose 0 = 1
    6 choose 1 = 6
    6 choose 2 = 15
    6 choose 3 = 20
    6 choose 4 = 15
    6 choose 5 = 6
    6 choose 6 = 1
First 10 values of the Poisson (lambda = 1) distribution
    Poisson(lambda 1, k 1) = 0.367879441171442
    Poisson(lambda 1, k 2) = 0.183939720585721
    Poisson(lambda 1, k 3) = 0.0613132401952405
    Poisson(lambda 1, k 4) = 0.0153283100488101
    Poisson(lambda 1, k 5) = 0.00306566200976203
    Poisson(lambda 1, k 6) = 0.00051094366829367
    Poisson(lambda 1, k 7) = 7.29919526133814E-05
    Poisson(lambda 1, k 8) = 9.12399407667265E-06
    Poisson(lambda 1, k 9) = 1.0137771196303E-06
    Poisson(lambda 1, k 10) = 1.01377711963029E-07
Common values of the standard normal distribution
    Normal-1(0.001) = -3.09
    Normal-1(0.01) = -2.318
    Normal-1(0.025) = -1.959
    Normal-1(0.05) = -1.642
    Normal-1(0.1) = -1.282
    Normal-1(0.5) = 0
    Normal-1(0.9) = 1.282
    Normal-1(0.95) = 1.642
    Normal-1(0.975) = 1.959
    Normal-1(0.99) = 2.318
    Normal-1(0.999) = 3.09
    Normal(x <= -3.09) = 0.001
    Normal(x <= -2.32) = 0.00554
    Normal(x <= -1.96) = 0.025
    Normal(x <= -1.64) = 0.0505
    Normal(x <= -1.28) = 0.10027
    Normal(x <= 0) = 0.5
    Normal(x <= 1.28) = 0.89973
    Normal(x <= 1.64) = 0.9495
    Normal(x <= 1.96) = 0.975
    Normal(x <= 2.32) = 0.99446
    Normal(x <= 3.09) = 0.999
Common values of the chi-squared distribution at 10 degrees of freedom:
    chi-sq(df 10, sigLevel 0.001) = <1.479, 29.588>
    chi-sq(df 10, sigLevel 0.01) = <2.558, 23.209>
    chi-sq(df 10, sigLevel 0.025) = <3.247, 20.483>
    chi-sq(df 10, sigLevel 0.05) = <3.94, 18.307>
    chi-sq(df 10, sigLevel 0.1) = <4.865, 15.987>
Common values of the Student's t distribution at 10 degrees of freedom:
    t(df 10, sigLevel 0.001) = 4.143
    t(df 10, sigLevel 0.005) = 3.169
    t(df 10, sigLevel 0.01) = 2.764
    t(df 10, sigLevel 0.025) = 2.228
    t(df 10, sigLevel 0.05) = 1.812
    t(df 10, sigLevel 0.1) = 1.372
Common values of the F distribution at 10 and 1 degrees of freedom:
    F(df1 10, df2 1, sifLevel 0.01) = 6055.85
    F(df1 10, df2 1, sifLevel 0.05) = 241.882
    F(df1 10, df2 1, sifLevel 0.1) = 60.195

Sample 'uniform(0,1)' = [0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]
    Sum = 5.21488
    Sum of squares = 3.10813
    Log transformed = [-0.915507673489646, -0.4538866166025, -0.229000608568736, -0.765547572658224, -0.342958886300134, -0.272310191628172, -0.482512635488649, -1.26378098321243, -1.37949288361674, -1.21671534624448]
    Exp transformed = [1.49229222822126, 1.88731417160841, 2.2151675622189, 1.59214027596837, 2.03331484127, 2.14173870243289, 1.85378698617621, 1.32655261769313, 1.28621804590024, 1.34474108162913]
    Arithmetic stdev = 0.207799545425621
    Arithmetic mean = 0.521488248410716
    Standard error of mean = 0.0657119860292586
    Median = 0.541154881470578
    Standard error of median = 0.0773298651592315
    Geometric mean = 0.480863737139541
    Geometric stdev = 1.56255472576704
    Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.75114
    Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.60747
    Shapiro-Wilk ok = True, W = 0.904955259787869, p-value = 0.248103833545881
    Outlier detection('auto',0.05) = <0, 0>

Sample 'normal(5, 2.5)' = [3.1476833, 9.20619, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.054284, 0.6643241, 4.3697818]
    Sum = 41.83307
    Sum of squares = 222.94057
    Log transformed = [1.14666672193647, 2.21987608389596, 0.958560599320351, 1.48977682935013, 1.85838281560642, 1.47581277827312, 1.26942888874853, 1.11654519526921, -0.408985146179298, 1.47471307651077]
    Exp transformed = [23.2820644952793, 9958.58228914508, 13.5710642846326, 84.4454192814535, 609.93768731081, 79.4072679533238, 35.1217114826069, 21.2059965963608, 1.94317668425472, 79.0263862606734]
    Arithmetic stdev = 2.30795630958355
    Arithmetic mean = 4.18330747
    Standard error of mean = 0.729839867844071
    Median = 3.96430065
    Standard error of median = 0.858875556478903
    Geometric mean = 3.52569572037875
    Geometric stdev = 2.04835540793366
    Hypothesis: distribution is N(5, sigma^2) (mean test). p-value = 0.29211
    Hypothesis: distribution is N(5, sigma^2) (median test). p-value = 0.25861
    Shapiro-Wilk ok = True, W = 0.917418368639979, p-value = 0.335925333025062
    Outlier detection('auto',0.05) = <0, 0>

Sample 'beta(0.5, 0.5)' = [0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.87764355, 0.12803053]
    Sum = 3.85904
    Sum of squares = 2.3588
    Log transformed = [-0.28216072584468, -4.71130900444498, -1.50671052190953, -0.852971168207217, -0.420952863607245, -1.49246301212003, -3.8144033127847, -0.617773070154802, -0.130514747277869, -2.05548652787785]
    Exp transformed = [2.12580905780365, 1.00903355649617, 1.24811929335097, 1.53134570563969, 1.92788017044885, 1.2520951184563, 1.02229578528984, 1.71453813789789, 2.40522523023951, 1.13658770218992]
    Arithmetic stdev = 0.310837187272829
    Arithmetic mean = 0.3859038179
    Standard error of mean = 0.0982953493262443
    Median = 0.325482569
    Standard error of median = 0.115673967087124
    Geometric mean = 0.204236938593202
    Geometric stdev = 5.41293770078999
    Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.27561
    Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.16565
    Shapiro-Wilk ok = True, W = 0.930482521074392, p-value = 0.452655082151213
    Outlier detection('auto',0.05) = <0, 0>

*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_stats.pl

Using statistical routines.

#!/usr/local/bin/perl
##############################################################################
# file: tools_stats.pl                                                       #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/tools_stats.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
##############################################################################

use msparser;

print "Binomial coefficients for sample size 6:\n";

for my $i (0 .. 6) {
    printf "\t6 choose %d = %g\n", $i, msparser::ms_quant_stats::binomialCoefficient(6, $i);
}

print "First 10 values of the Poisson(lambda = 1) distribution:\n";

for my $i (1 .. 10) {
    printf "\tPoisson(lambda 1, k %d) = %g\n", $i, msparser::ms_quant_stats::poissonDensity(1, $i);
}

print "Common values of the standard normal distribution:\n";

for (0.001, 0.01, 0.025, 0.05, 0.1, 0.5, 0.9, 0.95, 0.975, 0.99, 0.999) {
    # Note that normalCriticalValue() takes an argument between 0.5 and 1.0;
    # that is, it returns only the right tail critical values.
    my $critval;

    if ($_ < 0.5) {
        $critval = -msparser::ms_quant_stats::normalCriticalValue(1 - $_);
    } else {
        $critval = msparser::ms_quant_stats::normalCriticalValue($_);
    }

    printf "\tNormal-1(%g) = %g\n", $_, $critval;
}

for (-3.09, -2.32, -1.96, -1.64, -1.28, 0, 1.28, 1.64, 1.96, 2.32, 3.09) {
    # Note that normalCumulativeProbability() takes an argument between 0 and
    # 4.09; that is, it reports only the right tail probability.
    my $p;

    if ($_ < 0) {
        $p = 0.5 - msparser::ms_quant_stats::normalCumulativeProbability(-$_);
    } else {
        $p = 0.5 + msparser::ms_quant_stats::normalCumulativeProbability($_);
    }

    printf "\tNormal(x <= %g) = %g\n", $_, $p;
}

print "Common values of the chi-square distribution at 10 degrees of freedom:\n";

# Note the significance levels the chi-square functions support.
for (0.001, 0.01, 0.025, 0.05, 0.1) {
    my $lowcrit = msparser::ms_quant_stats::chisqLowerCriticalValue(10, $_);
    my $upcrit = msparser::ms_quant_stats::chisqUpperCriticalValue(10, $_);

    printf "\tchi-sq(df 10, sigLevel %g) = <%g, %g>\n", $_, $lowcrit, $upcrit;
}

print "Common values of the Student's t distribution at 10 degrees of freedom:\n";

# Note the significance levels the Student's t function supports.
for (0.001, 0.005, 0.01, 0.025, 0.05, 0.1) {
    printf "\tt(df 10, sigLevel %g) = %g\n",
        $_,
        msparser::ms_quant_stats::studentsCriticalValue(10, $_);
}

print "Common values of the F distribution at 10 and 1 degrees of freedom:\n";

# Note the significance levels the F function supports.
for (0.01, 0.05, 0.1) {
    printf "\tF(df1 10, df2 1, sigLevel %g) = %g\n",
        $_,
        msparser::ms_quant_stats::snedecorsCriticalValue(10, 1, $_);
}

my @samples = (
    # Uniform data generated with
    #   perl -e 'print join "\n", map {+ rand() } 0 .. 9'
    { name => 'uniform(0,1)', popmean => 0.5, data => [split /\s+/, <<EOD] },
0.400313346021907
0.635154745166318
0.795328049493161
0.465079196585926
0.709667388012424
0.76161797692474
0.617230566355229
0.282583560369936
0.251706165020014
0.2962014901575
EOD
    # Normal(5, 2.5) data generated in R with
    # > rnorm(10, 5, 2.5)
    { name => 'normal(5,2.5)', popmean => 5, data => [split /\s+/, <<EOD] },
3.1476833
9.2061900
2.6079399
4.4361054
6.4133568
4.3745899
3.5588195
3.0542840
0.6643241
4.3697818
EOD
    # Beta(0.5, 0.5) data generated in R with
    # > rbeta(10, 0.5, 0.5)
    { name => 'beta(0.5,0.5)', popmean => 0.5, data => [split /\s+/, <<EOD] },
0.754152463
0.008992998
0.221637853
0.426146895
0.656421042
0.224818243
0.022050868
0.539143737
0.877643550
0.128030530
EOD
);

print "\n";

for my $sample (@samples) {
    printf "Sample '%s' = [%s]\n", $sample->{'name'}, join(', ', @{ $$sample{'data'} });

    # ms_quant_stats takes as input STL vectors of type double. We can easily
    # convert a Perl array into one:
    my $vec = msparser::vectord->new(scalar(@{ $$sample{'data'} }));

    for (0 .. $#{ $$sample{'data'} }) {
        $vec->set($_, $$sample{'data'}[$_]);
    }

    # The sorted sample vector is needed for the Shapiro-Wilk W test.
    # It also makes finding the sample median fast.
    my $vec_sorted;

    do {
        my @sorted = sort { $a <=> $b } @{ $$sample{'data'} };
        $vec_sorted = msparser::vectord->new(scalar(@sorted));

        for (0 .. $#{ $$sample{'data'} }) {
            $vec_sorted->set($_, $sorted[$_]);
        }
    };

    # Auxiliary helper functions:

    printf "\tSum = %g\n", msparser::ms_quant_stats::sum($vec);
    printf "\tSum of squares = %g\n", msparser::ms_quant_stats::sumsq($vec);
    printf "\tLog transformed = [%s]\n", join(', ', @{ msparser::ms_quant_stats::logTransform($vec) });
    printf "\tExp transformed = [%s]\n", join(', ', @{ msparser::ms_quant_stats::expTransform($vec) });

    # Basic sample statistics:

    my $xbar = msparser::ms_quant_stats::arithmeticMean($vec);
    my $stdev = msparser::ms_quant_stats::arithmeticStandardDeviation($vec, $xbar);
    my $median = msparser::ms_quant_stats::sortedMedian($vec_sorted);
    # If the vector isn't sorted:
    # my $median = msparser::ms_quant_stats::unsortedMedian($vec);

    my $geombar = msparser::ms_quant_stats::geometricMean($vec);
    my $geomdev = msparser::ms_quant_stats::geometricStandardDeviation($vec, $geombar);

    printf "\tArithmetic stdev = %g\n", $stdev;
    printf "\tArithmetic mean = %g\n", $xbar;
    printf "\tStandard error of mean = %g\n", msparser::ms_quant_stats::arithmeticStandardErrorOfMean($stdev, $vec->size());
    printf "\tMedian = %g\n", $median;
    printf "\tStandard error of median = %g\n", msparser::ms_quant_stats::arithmeticStandardErrorOfMedian($stdev, $vec->size());
    printf "\tGeometric mean = %g\n", $geombar;
    printf "\tGeometric stdev = %g\n", $geomdev;

    # Basic distribution tests for normally distributed data:

    printf "\tHypothesis: distribution is N(%g, sigma^2) (mean test). p-value = %g\n",
        $$sample{'popmean'},
        msparser::ms_quant_stats::calculateNormalMeanPvalue($$sample{'popmean'}, $xbar, $stdev, $vec->size());

    printf "\tHypothesis: distribution is N(%g, sigma^2) (median test). p-value = %g\n",
        $$sample{'popmean'},
        msparser::ms_quant_stats::calculateNormalMedianPvalue($$sample{'popmean'}, $median, $stdev, $vec->size());

    # (We would expect the normal sample to have the highest p-value, i.e.
    # least evidence against the hypothesis, while the uniform and beta
    # distribution should have fairly low p-values. However, sample size is
    # so small that the tests are not very reliable.)

    do {
        my ($ok, $W, $p) = msparser::ms_quant_stats::testShapiroWilkW($vec_sorted);
        printf "\tShapiro-Wilk ok = %d, W = %s, p-value = %s\n", $ok, (defined $W ? $W : '(none)'), (defined $p ? $p : '(none)');
    };

    # Outlier detection can be done even when the above tests indicate that
    # the sample is not normally distributed. However, don't trust the results!

    do {
        # Note that the input vector must be sorted for outlier testing to
        # work.
        my ($numL, $numH) = msparser::ms_quant_stats::detectOutliers($vec_sorted, "auto", 0.05);

        # $numL and $numH are the number of elements at each end of $vec_sorted
        # which seem to be outliers. That is, elements between 0 and $numL-1,
        # and $vec_sorted->size()-$numH to $vec_sorted->size()-1.

        printf "\tOutlier detection('auto', 0.05') = <%s, %s>\n", (defined $numL ? $numL : '(none)'), (defined $numH ? $numH : '(none)');
    };

    print "\n";
}

=pod

Running the program as

perl -I../bin tools_stats.pl

will give the following output under Mascot 2.5:

Binomial coefficients for sample size 6:
    6 choose 0 = 1
    6 choose 1 = 6
    6 choose 2 = 15
    6 choose 3 = 20
    6 choose 4 = 15
    6 choose 5 = 6
    6 choose 6 = 1
First 10 values of the Poisson(lambda = 1) distribution:
    Poisson(lambda 1, k 1) = 0.367879
    Poisson(lambda 1, k 2) = 0.18394
    Poisson(lambda 1, k 3) = 0.0613132
    Poisson(lambda 1, k 4) = 0.0153283
    Poisson(lambda 1, k 5) = 0.00306566
    Poisson(lambda 1, k 6) = 0.000510944
    Poisson(lambda 1, k 7) = 7.2992e-05
    Poisson(lambda 1, k 8) = 9.12399e-06
    Poisson(lambda 1, k 9) = 1.01378e-06
    Poisson(lambda 1, k 10) = 1.01378e-07
Common values of the standard normal distribution:
    Normal-1(0.001) = -3.09
    Normal-1(0.01) = -2.318
    Normal-1(0.025) = -1.959
    Normal-1(0.05) = -1.642
    Normal-1(0.1) = -1.282
    Normal-1(0.5) = 0
    Normal-1(0.9) = 1.282
    Normal-1(0.95) = 1.642
    Normal-1(0.975) = 1.959
    Normal-1(0.99) = 2.318
    Normal-1(0.999) = 3.09
    Normal(x <= -3.09) = 0.001
    Normal(x <= -2.32) = 0.00554
    Normal(x <= -1.96) = 0.025
    Normal(x <= -1.64) = 0.0505
    Normal(x <= -1.28) = 0.10027
    Normal(x <= 0) = 0.5
    Normal(x <= 1.28) = 0.89973
    Normal(x <= 1.64) = 0.9495
    Normal(x <= 1.96) = 0.975
    Normal(x <= 2.32) = 0.99446
    Normal(x <= 3.09) = 0.999
Common values of the chi-square distribution at 10 degrees of freedom:
    chi-sq(df 10, sigLevel 0.001) = <1.479, 29.588>
    chi-sq(df 10, sigLevel 0.01) = <2.558, 23.209>
    chi-sq(df 10, sigLevel 0.025) = <3.247, 20.483>
    chi-sq(df 10, sigLevel 0.05) = <3.94, 18.307>
    chi-sq(df 10, sigLevel 0.1) = <4.865, 15.987>
Common values of the Student's t distribution at 10 degrees of freedom:
    t(df 10, sigLevel 0.001) = 4.143
    t(df 10, sigLevel 0.005) = 3.169
    t(df 10, sigLevel 0.01) = 2.764
    t(df 10, sigLevel 0.025) = 2.228
    t(df 10, sigLevel 0.05) = 1.812
    t(df 10, sigLevel 0.1) = 1.372
Common values of the F distribution at 10 and 1 degrees of freedom:
    F(df1 10, df2 1, sigLevel 0.01) = 6055.85
    F(df1 10, df2 1, sigLevel 0.05) = 241.882
    F(df1 10, df2 1, sigLevel 0.1) = 60.195

Sample 'uniform(0,1)' = [0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]
    Sum = 5.21488
    Sum of squares = 3.10813
    Log transformed = [-0.915507673489646, -0.4538866166025, -0.229000608568736, -0.765547572658224, -0.342958886300134, -0.272310191628172, -0.482512635488649, -1.26378098321243, -1.37949288361674, -1.21671534624448]
    Exp transformed = [1.49229222822126, 1.88731417160841, 2.2151675622189, 1.59214027596837, 2.03331484127, 2.14173870243289, 1.85378698617621, 1.32655261769313, 1.28621804590024, 1.34474108162913]
    Arithmetic stdev = 0.2078
    Arithmetic mean = 0.521488
    Standard error of mean = 0.065712
    Median = 0.541155
    Standard error of median = 0.0773299
    Geometric mean = 0.480864
    Geometric stdev = 1.54969
    Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.75114
    Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.607474
    Shapiro-Wilk ok = 1, W = 0.904955259787869, p-value = 0.248103833545881
    Outlier detection('auto', 0.05') = <0, 0>

Sample 'normal(5,2.5)' = [3.1476833, 9.2061900, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.0542840, 0.6643241, 4.3697818]
    Sum = 41.8331
    Sum of squares = 222.941
    Log transformed = [1.14666672193647, 2.21987608389596, 0.958560599320351, 1.48977682935013, 1.85838281560642, 1.47581277827312, 1.26942888874853, 1.11654519526921, -0.408985146179298, 1.47471307651077]
    Exp transformed = [23.2820644952793, 9958.58228914508, 13.5710642846326, 84.4454192814535, 609.93768731081, 79.4072679533238, 35.1217114826069, 21.2059965963608, 1.94317668425472, 79.0263862606734]
    Arithmetic stdev = 2.30796
    Arithmetic mean = 4.18331
    Standard error of mean = 0.72984
    Median = 3.9643
    Standard error of median = 0.858876
    Geometric mean = 3.5257
    Geometric stdev = 2.00172
    Hypothesis: distribution is N(5, sigma^2) (mean test). p-value = 0.292114
    Hypothesis: distribution is N(5, sigma^2) (median test). p-value = 0.258609
    Shapiro-Wilk ok = 1, W = 0.917418368639979, p-value = 0.335925333025062
    Outlier detection('auto', 0.05') = <0, 0>

Sample 'beta(0.5,0.5)' = [0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.877643550, 0.128030530]
    Sum = 3.85904
    Sum of squares = 2.3588
    Log transformed = [-0.28216072584468, -4.71130900444498, -1.50671052190953, -0.852971168207217, -0.420952863607245, -1.49246301212003, -3.8144033127847, -0.617773070154802, -0.130514747277869, -2.05548652787785]
    Exp transformed = [2.12580905780365, 1.00903355649617, 1.24811929335097, 1.53134570563969, 1.92788017044885, 1.2520951184563, 1.02229578528984, 1.71453813789789, 2.40522523023951, 1.13658770218992]
    Arithmetic stdev = 0.310837
    Arithmetic mean = 0.385904
    Standard error of mean = 0.0982953
    Median = 0.325483
    Standard error of median = 0.115674
    Geometric mean = 0.204237
    Geometric stdev = 4.71093
    Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.275606
    Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.165651
    Shapiro-Wilk ok = 1, W = 0.930482521074392, p-value = 0.452655082151213
    Outlier detection('auto', 0.05') = <0, 0>

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_stats.py

Using statistical routines.

#!/usr/bin/python
##############################################################################
# file: tools_stats.py                                                       #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_python/tools_stats.py $    #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser

# ms_range function has been added to make the range supplied consistent with other languages such as Perl and C#
def ms_range(start, stop, step=1):
    i = start
    while i <= stop:
        yield i
        i += step

print("\n")
print("Bionominal coefficients for sample size 6:")

for i in ms_range(0, 6):
    print("\t6 choose %d = %f" %(i, msparser.ms_quant_stats.binomialCoefficient(6, i)))

print("\n")
print("First 10 values of the Poisson(lambda = 1) distribution:")

for i in ms_range(0, 10):
    print("\tPoisson(lambda 1, k %d) = %f" %(i, msparser.ms_quant_stats.poissonDensity(1, i)))

print("\n")
print("Common values of the standard normal distribution:")

for i in [0.001, 0.01, 0.025, 0.05, 0.1, 0.5, 0.9, 0.95, 0.975, 0.99, 0.999]:
# Note that normalCriticalValue() takes an argument between 0.5 and 1.0;
# that is, it returns only the right tail critical values.
    if (i < 0.5):
        critval = msparser.ms_quant_stats.normalCriticalValue(1 - i)
    else:
        critval = msparser.ms_quant_stats.normalCriticalValue(i)
    print("\tNormal-1(%f) = %f" %(i, critval))

print("\n")
for i in [-3.09, -2.32, -1.96, -1.64, -1.28, 0, 1.28, 1.64, 1.96, 2.32, 3.09]:
# Note that normalCumulativeProbability() takes an argument between 0 and
# 4.09; that is, it reports only the right tail probability.
    if (i < 0):
        p = 0.5 - msparser.ms_quant_stats.normalCumulativeProbability(-i)
    else:
        p = 0.5 + msparser.ms_quant_stats.normalCumulativeProbability(i)
    print("\tNormal(x <= %f) = %f" %(i, p))

print("\n")
print("Common values of the chi-square distribution at 10 degrees of freedom:")

# Note the significance levels the chi-square functions support.
for i in [0.001, 0.01, 0.025, 0.05, 0.1]:
    lowcrit = msparser.ms_quant_stats.chisqLowerCriticalValue(10, i)
    upcrit = msparser.ms_quant_stats.chisqUpperCriticalValue(10, i)
    print("\tchi-sq(df 10, sigLevel %f) = <%f, %f>" %(i, lowcrit, upcrit))

print("\n")
print("Common values of the Student's t distribution at 10 degrees of freedom:")
# Note the significance levels the Student's t function supports.
for i in [0.001, 0.005, 0.01, 0.025, 0.05, 0.1]:
    print("\tt(df 10, sigLevel %f) = %f" %(i, msparser.ms_quant_stats.studentsCriticalValue(10, i)))

print("\n")
print("Common values of the F distribution at 10 and 1 degrees of freedom:")
# Note the significance levels the F function supports.
for i in [0.01, 0.05, 0.1]:
    print("\tF(df1 10, df2 1, sigLevel %f) = %f" %(i, msparser.ms_quant_stats.snedecorsCriticalValue(10, 1, i)))

print("\n")

samples = [
# Uniform data generated with
#   perl -e 'print join "\n", map {+ rand() } 0 .. 9'
['uniform(0,1)', 0.5, [0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]],
# Normal(5, 2.5) data generated in R with
# > rnorm(10, 5, 2.5)
['normal(5,2.5)', 5, [3.1476833, 9.2061900, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.0542840, 0.6643241, 4.3697818]],
# Beta(0.5, 0.5) data generated in R with
# > rbeta(10, 0.5, 0.5)
['beta(0.5,0.5)', 0.5, [0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.877643550, 0.128030530]]
]

# Auxiliary helper functions:
def aux_helper(vec, vec_sorted):
    print("\tSum = %g" %(msparser.ms_quant_stats.sum(vec)))
    print("\tSum of squares = %g" %(msparser.ms_quant_stats.sumsq(vec)))
    print("\tLog transformed = [%s]" %str((msparser.ms_quant_stats.logTransform(vec))))
    print("\tExp transformed = [%s]" %str((msparser.ms_quant_stats.expTransform(vec))))

# Basic sample statistics:

    xbar = msparser.ms_quant_stats.arithmeticMean(vec)
    stdev = msparser.ms_quant_stats.arithmeticStandardDeviation(vec, xbar)
    median = msparser.ms_quant_stats.sortedMedian(vec_sorted)

# If the vector isn't sorted:
# median = msparser.ms_quant_stats.unsortedMedian(vec)

    geombar = msparser.ms_quant_stats.geometricMean(vec)
    geomdev = msparser.ms_quant_stats.geometricStandardDeviation(vec, geombar)

    print("\tArithmetic stdev = %g" %(stdev))
    print("\tArithmetic mean = %g" %(xbar))
    print("\tStandard error of mean = %g" %(msparser.ms_quant_stats.arithmeticStandardErrorOfMean(stdev, len(vec))))
    print("\tMedian = %g" %(median))
    print("\tStandard error of median = %g" %(msparser.ms_quant_stats.arithmeticStandardErrorOfMedian(stdev, len(vec))))
    print("\tGeometric mean = %g" %(geombar))
    print("\tGeometric stdev = %g" %(geomdev))

# Basic distribution tests for normally distributed data:

    print("\tHypothesis: distribution is N(%g, sigma^2) (mean test). p-value = %g" %(sample[1], msparser.ms_quant_stats.calculateNormalMeanPvalue(sample[1], xbar, stdev, len(vec))))
    print("\tHypothesis: distribution is N(%g, sigma^2) (median test). p-value = %g" %(sample[1], msparser.ms_quant_stats.calculateNormalMedianPvalue(sample[1], median, stdev, len(vec))))

# (We would expect the normal sample to have the highest p-value, i.e.
# least evidence against the hypothesis, while the uniform and beta
# distribution should have fairly low p-values. However, sample size is
# so small that the tests are not very reliable.)

    ok, W, p = msparser.ms_quant_stats.testShapiroWilkW(vec_sorted)
    if W == None:
        W = 'None'
    if p == None:
        p = 'None'
    print("\tShapiro-Wilk ok = %d, W = %s, p-value = %s" %(ok, W, p))

# Outlier detection can be done even when the above tests indicate that
# the sample is not normally distributed. However, don't trust the results!

# Note that the input vector must be sorted for outlier testing to
# work.
    numL, numH = msparser.ms_quant_stats.detectOutliers(vec_sorted, "auto", 0.05)
    if numL == None:
        numL = 'None'
    if numH == None:
        numH = 'None'
# numL and numH are the number of elements at each end of vec_sorted
# which seem to be outliers. That is, elements between 0 and numL-1,
# and len(vec_sorted)-numH to len(vec_sorted)-1.

    print("\tOutlier detection('auto', 0.05') = <%s, %s>" %(numL, numH))

for sample in samples:
    print("Sample '%s' = [%s]" %(sample[0], sample[2]))
# ms_quant_stats takes as input STL vectors of type double. We can easily
# convert a Python list into one:
    vec = msparser.vectord()
    vectors = sample[2]
    for i in ms_range(0, len(vectors)-1):
        vec.append(vectors[i])

# The sorted sample vector is needed for the Shapiro-Wilk W test.
# It also makes finding the sample median fast.
    vec_sorted = msparser.vectord()
    vectors_sorted = sample[2]
    vectors_sorted.sort()
    for i in ms_range(0, len(vectors_sorted)-1):
        vec_sorted.append(vectors_sorted[i])
    aux_helper(vec, vec_sorted)
    print("\n")

'''
Running the program as

python tools_stats.pl

will give the following output under Mascot 2.5:

Bionominal coefficients for sample size 6:
        6 choose 0 = 1.000000
        6 choose 1 = 6.000000
        6 choose 2 = 15.000000
        6 choose 3 = 20.000000
        6 choose 4 = 15.000000
        6 choose 5 = 6.000000

First 10 values of the Poisson(lambda = 1) distribution:
        Poisson(lambda 1, k 0) = 0.367879
        Poisson(lambda 1, k 1) = 0.367879
        Poisson(lambda 1, k 2) = 0.183940
        Poisson(lambda 1, k 3) = 0.061313
        Poisson(lambda 1, k 4) = 0.015328
        Poisson(lambda 1, k 5) = 0.003066
        Poisson(lambda 1, k 6) = 0.000511
        Poisson(lambda 1, k 7) = 0.000073
        Poisson(lambda 1, k 8) = 0.000009
        Poisson(lambda 1, k 9) = 0.000001

Common values of the standard normal distribution:
        Normal-1(0.001000) = 3.090000
        Normal-1(0.010000) = 2.318000
        Normal-1(0.025000) = 1.959000
        Normal-1(0.050000) = 1.642000
        Normal-1(0.100000) = 1.282000
        Normal-1(0.500000) = 0.000000
        Normal-1(0.900000) = 1.282000
        Normal-1(0.950000) = 1.642000
        Normal-1(0.975000) = 1.959000
        Normal-1(0.990000) = 2.318000
        Normal-1(0.999000) = 3.090000

        Normal(x <= -3.090000) = 0.001000
        Normal(x <= -2.320000) = 0.005540
        Normal(x <= -1.960000) = 0.025000
        Normal(x <= -1.640000) = 0.050500
        Normal(x <= -1.280000) = 0.100270
        Normal(x <= 0.000000) = 0.500000
        Normal(x <= 1.280000) = 0.899730
        Normal(x <= 1.640000) = 0.949500
        Normal(x <= 1.960000) = 0.975000
        Normal(x <= 2.320000) = 0.994460
        Normal(x <= 3.090000) = 0.999000

Common values of the chi-square distribution at 10 degrees of freedom:
        chi-sq(df 10, sigLevel 0.001000) = <1.479000, 29.588000>
        chi-sq(df 10, sigLevel 0.010000) = <2.558000, 23.209000>
        chi-sq(df 10, sigLevel 0.025000) = <3.247000, 20.483000>
        chi-sq(df 10, sigLevel 0.050000) = <3.940000, 18.307000>
        chi-sq(df 10, sigLevel 0.100000) = <4.865000, 15.987000>

Common values of the Student's t distribution at 10 degrees of freedom:
        t(df 10, sigLevel 0.001000) = 4.143000
        t(df 10, sigLevel 0.005000) = 3.169000
        t(df 10, sigLevel 0.010000) = 2.764000
        t(df 10, sigLevel 0.025000) = 2.228000
        t(df 10, sigLevel 0.050000) = 1.812000
        t(df 10, sigLevel 0.100000) = 1.372000

Common values of the F distribution at 10 and 1 degrees of freedom:
        F(df1 10, df2 1, sigLevel 0.010000) = 6055.850000
        F(df1 10, df2 1, sigLevel 0.050000) = 241.882000
        F(df1 10, df2 1, sigLevel 0.100000) = 60.195000

Sample 'uniform(0,1)' = [[0.400313346021907, 0.635154745166318, 0.795328049493161, 0.465079196585926, 0.709667388012424, 0.76161797692474, 0.617230566355229, 0.282583560369936, 0.251706165020014, 0.2962014901575]]
        Sum = 5.21488
        Sum of squares = 3.10813
        Log transformed = [(-0.915507673489646, -0.4538866166025002, -0.22900060856873583, -0.7655475726582238, -0.342958886300134, -0.2723101916281718, -0.48251263548864914, -1.2637809832124323, -1.379492883616736, -1.216715346244483)]
        Exp transformed = [(1.4922922282212572, 1.8873141716084079, 2.215167562218903, 1.592140275968374, 2.03331484127, 2.1417387024328853, 1.853786986176205, 1.3265526176931346, 1.2862180459002401, 1.3447410816291303)]
        Arithmetic stdev = 0.2078
        Arithmetic mean = 0.521488
        Standard error of mean = 0.065712
        Median = 0.541155
        Standard error of median = 0.0773299
        Geometric mean = 0.480864
        Geometric stdev = 1.54969
        Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.75114
        Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.607474
        Shapiro-Wilk ok = 1, W = 0.904955259788, p-value = 0.248103833546
        Outlier detection('auto', 0.05') = <0, 0>

Sample 'normal(5,2.5)' = [[3.1476833, 9.20619, 2.6079399, 4.4361054, 6.4133568, 4.3745899, 3.5588195, 3.054284, 0.6643241, 4.3697818]]
        Sum = 41.8331
        Sum of squares = 222.941
        Log transformed = [(1.146666721936465, 2.2198760838959566, 0.9585605993203508, 1.489776829350127, 1.8583828156064155, 1.47581277827312, 1.2694288887485337, 1.1165451952692114, -0.40898514617929754, 1.474713076510773)]
        Exp transformed = [(23.282064495279258, 9958.582289145075, 13.571064284632554, 84.44541928145347, 609.9376873108102, 79.40726795332382, 35.1217114826069, 21.205996596360794, 1.9431766842547191, 79.02638626067342)]
        Arithmetic stdev = 2.30796
        Arithmetic mean = 4.18331
        Standard error of mean = 0.72984
        Median = 3.9643
        Standard error of median = 0.858876
        Geometric mean = 3.5257
        Geometric stdev = 2.00172
        Hypothesis: distribution is N(5, sigma^2) (mean test). p-value = 0.292114
        Hypothesis: distribution is N(5, sigma^2) (median test). p-value = 0.258609
        Shapiro-Wilk ok = 1, W = 0.91741836864, p-value = 0.335925333025
        Outlier detection('auto', 0.05') = <0, 0>

Sample 'beta(0.5,0.5)' = [[0.754152463, 0.008992998, 0.221637853, 0.426146895, 0.656421042, 0.224818243, 0.022050868, 0.539143737, 0.87764355, 0.12803053]]
        Sum = 3.85904
        Sum of squares = 2.3588
        Log transformed = [(-0.28216072584468, -4.7113090044449795, -1.506710521909531, -0.8529711682072173, -0.42095286360724493, -1.4924630121200262, -3.8144033127847012, -0.6177730701548017, -0.13051474727786935, -2.055486527877849)]
        Exp transformed = [(2.1258090578036466, 1.0090335564961697, 1.2481192933509702, 1.5313457056396895, 1.9278801704488464, 1.252095118456305, 1.0222957852898442, 1.7145381378978928, 2.4052252302395134, 1.1365877021899178)]
        Arithmetic stdev = 0.310837
        Arithmetic mean = 0.385904
        Standard error of mean = 0.0982953
        Median = 0.325483
        Standard error of median = 0.115674
        Geometric mean = 0.204237
        Geometric stdev = 4.71093
        Hypothesis: distribution is N(0.5, sigma^2) (mean test). p-value = 0.275606
        Hypothesis: distribution is N(0.5, sigma^2) (median test). p-value = 0.165651
        Shapiro-Wilk ok = 1, W = 0.930482521074, p-value = 0.452655082151
        Outlier detection('auto', 0.05') = <0, 0>

'''
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_tinycdb.cs

Using the tinycdb index files.

/*
##############################################################################
# file: tools_tinycdb.cs                                                     #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/tools_tinycdb.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using System.IO;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class tools_tinycdb
    {
        public static void Main(string[] argv)
        {
            if (argv.Length < 1)
            {
                Console.WriteLine("The location of the source file for this application (tools_tinycdb.cs) should be specified as a parameter");
                return;
            }
            string version = "1.1";
            // this should return the current executable name and full path
            string sourceFile = System.IO.Path.GetFileName((new tools_tinycdb()).GetType().Assembly.Location);
            string cdbname = sourceFile + ".cdb";
            // this section just creates the object.  it doesn't open a file
            // the 'source file' is (unusually!) the executable for this class, meaning
            // that if this file is changed, the index will be re-created
            ms_tinycdb cdb = new ms_tinycdb(cdbname, version, sourceFile);

            if (!cdb.isValid())
            {
                showErrors(cdb);
                return;
            }

            if (!cdb.openIndexFile(true))
            {
                if (cdb.isPossibleToCreate())
                {
                    Console.WriteLine("Creating file because: {0}", cdb.getLastErrorString());
                    cdb.prepareToCreate();
                    cdb.saveValueForKey("Hello", "world");

                    // it is unusual to use the same key for 2 values, but it can be done:
                    cdb.saveValueForKey("HELP", "me");
                    cdb.saveValueForKey("HELP", "me too");

                    // Example of saving a file offset using the binary offset into the file
                    // with the saveFileOffsetForKey() function.  This example uses the
                    // C# source file as the input
                    // and saves an offset to THIS line!
                    using (StreamReader fh = new StreamReader(argv[0]))
                    {
                        long _pos = -1;
                        string line;
                        while ((line = fh.ReadLine()) != null)
                        {
                            if (line.Contains("// and saves an offset to THIS line!"))
                            {
                                break;
                            }
                            // fetch the current position in the file
                            _pos = GetActualPosition(fh);
                        }
                        cdb.saveFileOffsetForKey("Line", _pos);
                    }

                    cdb.finishCreate();
                }
            }
            if (cdb.isValid())
            {
                Console.WriteLine("Retrieving value for Hello      : {0}", cdb.getValueFromKey("Hello"));
                Console.WriteLine("Retrieving first value for HELP : {0}", cdb.getValueFromKey("HELP", 0));
                Console.WriteLine("Retrieving second value for HELP: {0}", cdb.getValueFromKey("HELP", 1));

                // check saved position index
                long pos = cdb.getFileOffsetFromKey("Line");
                if (pos != -1)
                {
                    using (FileStream fs = new FileStream(argv[0], FileMode.Open, FileAccess.Read))
                    {
                        fs.Seek(pos, SeekOrigin.Begin);
                        using (StreamReader sr = new StreamReader(fs))
                        {
                            Console.WriteLine("Testing file offset. Offset {0}: {1}", pos, sr.ReadLine());
                        }
                    }
                }
                else
                {
                    Console.WriteLine("Target line was not found during .cdb file creation");
                }
            }
            else
            {
                showErrors(cdb);
            }

        }

        // Finds the current position in the underlying Stream for the passed StreamReader
        // See http://stackoverflow.com/questions/5404267/streamreader-and-seeking
        private static long GetActualPosition(StreamReader reader)
        {
            // The current buffer of decoded characters
            char[] charBuffer = (char[])reader.GetType().InvokeMember("charBuffer"
                , System.Reflection.BindingFlags.DeclaredOnly | System.Reflection.BindingFlags.NonPublic | System.Reflection.BindingFlags.Instance | System.Reflection.BindingFlags.GetField
                , null, reader, null);

            // The current position in the buffer of decoded characters
            int charPos = (int)reader.GetType().InvokeMember("charPos"
                , System.Reflection.BindingFlags.DeclaredOnly | System.Reflection.BindingFlags.NonPublic | System.Reflection.BindingFlags.Instance | System.Reflection.BindingFlags.GetField
                , null, reader, null);

            // The number of bytes that the already-read characters need when encoded.
            int numReadBytes = reader.CurrentEncoding.GetByteCount(charBuffer, 0, charPos);

            // The number of encoded bytes that are in the current buffer
            int byteLen = (int)reader.GetType().InvokeMember("byteLen"
                , System.Reflection.BindingFlags.DeclaredOnly | System.Reflection.BindingFlags.NonPublic | System.Reflection.BindingFlags.Instance | System.Reflection.BindingFlags.GetField
                , null, reader, null);

            return reader.BaseStream.Position - byteLen + numReadBytes;
        }

        private static void showErrors(ms_tinycdb cdb)
        {
            ms_errs err = cdb.getErrorHandler();
            for (int i = 1; i <= err.getNumberOfErrors(); i++)
            {
                Console.WriteLine("Error number: {0} ({1} times) : {2}", err.getErrorNumber(i), err.getErrorRepeats(i) + 1, err.getErrorString(i));
            }
        }
    }
}
/*
tools_tinycdb.exe .\tools_tinycdb.cs
Will give the following output:

Creating file because: Cache file tools_tinycdb.exe.cdb is missing or cannot be opened
Retrieving value for Hello      : world
Retrieving first value for HELP : me
Retrieving second value for HELP: me too
Testing file offset. Offset 3060:                     // and saves an offset to THIS line!
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_tinycdb.pl

Using the tinycdb index files.

#!/usr/local/bin/perl
##############################################################################
# file: tools_tinycdb.pl                                                     #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/tools_tinycdb.pl $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################
use strict;
##############################################################################

use msparser;

# This next line just creates the object. It doesn't open a file
# The 'source file' is (unusually!) this perl script ($0), meaning that
# if this file is changed, the index will be re-created.
my $version = "1.1";
my $sourceFile = $0;
my $cdbname = $0.'.cdb';
my $cdb = new msparser::ms_tinycdb($cdbname, $version, $sourceFile);

if (!$cdb->isValid()) {
  showErrors($cdb);
  exit;
}

if (!$cdb->openIndexFile(1)) {
  if ($cdb->isPossibleToCreate) {
    print "Creating file because: " . $cdb->getLastErrorString . "\n";
    $cdb->prepareToCreate();
    $cdb->saveValueForKey("Hello", "world");

    # It is unusual to use the same key for 2 values, but it can be done:
    $cdb->saveValueForKey("HELP", "me");
    $cdb->saveValueForKey("HELP", "me too");

    # Example of saving a file offset. Can use a binary offset into the file
    # with the ms_tincycdb::saveFileOffsetForKey() function, but this example
    # uses saveIntForKey and a line offset. This facile example uses this
    # perl source file as the input!
    # and saves an offset to THIS line!
    open(my $fh, '<', $0) or die $!;
    my @list = <$fh>;
    close $fh;

    my $line=0;
    while ($list[$line] !~ m/# and saves an/) {
      $line++;
    }
    $cdb->saveIntForKey("Line", $line);
    $cdb->finishCreate();
  }
}

if ($cdb->isValid) {
  print "Retrieving value for Hello    : ", $cdb->getValueFromKey("Hello"), "\n";
  print "Retrieving 1st value for HELP : ", $cdb->getValueFromKey("HELP", 0), "\n";
  print "Retrieving 2nd value for HELP : ", $cdb->getValueFromKey("HELP", 1), "\n";

  # Check saved line index
  open(my $fh, '<', $0) or die $!;
  my @list = <$fh>;
  close $fh;
  my $line = $cdb->getIntFromKey("Line");
  print "Testing line index. Line ", ($line + 1), ": ", $list[$line], "\n";

} else {
  showErrors($cdb);
}

sub showErrors {
    my ($obj) = @_;

    my $err = $obj->getErrorHandler();
    my $i;

    for my $i (1 .. $err->getNumberOfErrors) {
        print "Error number: ";
        print $err->getErrorNumber($i);
        print " (";
        print $err->getErrorRepeats($i)+1 . " times) : ";
        print $err->getErrorString($i) . "\n";
    }

    print "\n";
    $obj->clearAllErrors();
}
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_tinycdb.py

Using the tinycdb index files.

#!/usr/bin/python
##############################################################################
# file: tools_tinycdb.py                                                     #
# Mascot Parser toolkit example code                                         #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/tools_tinycdb.py $
#     $Author: villek@matrixscience.com $
#       $Date: 2018-07-30 16:23:53 +0100 $
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $
##############################################################################

import msparser
import sys
import re

def main() :
  # This next line just creates the object. It doesn't open a file
  # The 'source file' is (unusually!) this Python script (sys.argv[0]),
  # meaning that if this file is changed, the index will be re-created.
  version = "1.1"
  sourceFile = sys.argv[0]
  cdbname = sys.argv[0] + '.cdb'
  cdb = msparser.ms_tinycdb(cdbname, version, sourceFile)

  if not cdb.isValid() :
    showErrors(cdb)
    return 1

  if not cdb.openIndexFile(1) :
    if cdb.isPossibleToCreate() :
      print("Creating file because: %s" % cdb.getLastErrorString())
      cdb.prepareToCreate()
      cdb.saveValueForKey("Hello", "world")

      # It is unusual to use the same key for 2 values, but it can be done:
      cdb.saveValueForKey("HELP", "me")
      cdb.saveValueForKey("HELP", "me too")

      # Example of saving a file offset. Can use a binary offset into the
      # file with the ms_tincycdb.saveFileOffsetForKey() function, but this
      # example uses saveIntForKey and a line offset. This facile example
      # uses this source file as the input!
      # and saves an offset to THIS line!
      try :
          fh = open(sys.argv[0], 'r')
      except IOError as err:
        errno, strerror = err.args
        print("Cannot open " + sys.argv[0] + " for reading: " + strerror)
        return 1
        sys.exit(1)
      line_nr = 1
      for line in fh :
        if re.search('\s*# and saves an.*', line) :
            break

        line_nr += 1

      fh.close();

      cdb.saveIntForKey("Line", line_nr)
      cdb.finishCreate()

  if cdb.isValid() :
    print("Retrieving value for Hello    : %s" % cdb.getValueFromKey("Hello"))
    print("Retrieving 1st value for HELP : %s" % cdb.getValueFromKey("HELP", 0))
    print("Retrieving 2nd value for HELP : %s" % cdb.getValueFromKey("HELP", 1))

    # Check saved line index
    try :
        fh = open(sys.argv[0], 'r')
    except IOError as err:
        errno, strerror = err.args
        print("Cannot open " + sys.argv[0] + " for reading: " + strerror)
        return 1

    line_nr = cdb.getIntFromKey("Line")

    i = 1
    for line in fh :
        if i == line_nr : break
        i += 1

    print("Testing line index. Line " + str(line_nr + 1) + " : " + line)
    fh.close()
  else :
    showErrors(cdb)

def showErrors(obj) :
    err = obj.getErrorHandler()

    for i in range(1, 1 + err.getNumberOfErrors()) :
        print("Error number: %d (%d times): %s" % (err.getErrorNumber(i), err.getErrorRepeats(i) + 1, err.getErrorString(i)))

    print(" ")
    obj.clearAllErrors()

if __name__ == "__main__" :
    sys.exit(main())
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_treecluster.cs

Using the matrix_science::ms_treecluster class.

/*
##############################################################################
# file: tools_treecluster.cs                                                 #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2015 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#    $Source: parser/examples/test_csharp/tools_treecluster.cs $                                #
#     $Author: villek@matrixscience.com $                                                    #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
*/

using System;
using matrix_science.msparser;

namespace MsParserExamples
{
    public class tools_treecluster
    {
        public static void Main(string[] argv)
        {
            int rows = 11;
            int cols = 5;
            ms_treecluster tc = new ms_treecluster(rows, cols);

            var data = new vectord();
            var mask = new vectori();

            data.Add(1.623866862); data.Add(-0.052894948); data.Add(1.182692298); data.Add(2.298658316); data.Add(1.13422094);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(0 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.156396617); data.Add(0.0000000000); data.Add(0.521050737); data.Add(1.544979883); data.Add(0.65718266);
            mask.Add(1);           mask.Add(0);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(1 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.523561956); data.Add(-0.017417053); data.Add(1.168000125); data.Add(2.459693903); data.Add(1.308011315);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(2 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.55875743);  data.Add(-0.241270432); data.Add(0.440420721); data.Add(2.427337989); data.Add(1.043344505);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(3 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.449957484); data.Add(-0.169744676); data.Add(0.867896464); data.Add(2.418999465); data.Add(1.171206827);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(4 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.171206827); data.Add(0.0000000000); data.Add(0.854394678); data.Add(2.075532631); data.Add(0.950095094);
            mask.Add(1);           mask.Add(0);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(5 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.361768359); data.Add(-0.120294234); data.Add(0.992043276); data.Add(2.238786860); data.Add(1.090175950);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(6 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.781149852); data.Add(0.0028825090); data.Add(1.079975377); data.Add(2.464929601); data.Add(1.301002256);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(7 , data, mask); data.Clear(); mask.Clear();

            data.Add(-1.227692025);data.Add(-3.522840789); data.Add(-2.434402824);data.Add(-0.873027144);data.Add(-1.977099598);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(8 , data, mask); data.Clear(); mask.Clear();

            data.Add(1.272023189); data.Add(-0.535331733); data.Add(0.608809243); data.Add(2.004681156); data.Add(0.826192536);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);
            tc.setRow(9 , data, mask);
            data.Clear(); mask.Clear();

            data.Add(1.069014678); data.Add(-0.623709617); data.Add(0.412510571); data.Add(1.82822536);  data.Add(0.650764559);
            mask.Add(1);           mask.Add(1);            mask.Add(1);           mask.Add(1);           mask.Add(1);

            var weights = new vectord();
            var left = new vectori();
            var right = new vectori();
            var distance = new vectord();

            if (!tc.cluster(ms_treecluster.TREE_CLUSTER_DISTANCE.TCD_EUCLIDEAN, ms_mascotresults.TREE_CLUSTER_METHOD.TCM_PAIRWISE_AVERAGE,
                weights, left, right, distance))
            {
                Console.WriteLine("Failed");
            }
            else
            {
                Console.WriteLine("Node\tleft\tright\tdistance\t");
                for (int i = 0; i < left.Count; i++)
                {
                    int _node = -1 - i;
                    Console.WriteLine("{0}\t{1}\t{2}\t{3}", _node, left[i], right[i], distance[i]);
                }
            }
        }
    }
}

/*
tools_treecluster.exe
Will give the following output:

Node    left    right   distance
-1      6       4       0.0129355369880599
-2      2       0       0.0135342339743674
-3      7       -2      0.0168450469179865
-4      5       9       0.0227119800299183
-5      -1      -3      0.0358259860933716
-6      -4      1       0.0924477619793738
-7      3       -5      0.098592161220467
-8      -6      -7      0.201808959296598
-9      10      -8      1.88084728645169
-10     8       -9      9.01668349698743
*/
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_treecluster.pl

Using the matrix_science::ms_treecluster class.

#!/usr/local/bin/perl
##############################################################################
# file: tools_treecluster.pl                                                 #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2012 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_perl/tools_treecluster.pl $ #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################
use strict;
use warnings;
##############################################################################

use msparser;

my $rows = 11;
my $cols = 5;
my $tc = msparser::ms_treecluster->new($rows, $cols);

my $data = new msparser::vectord;
my $mask = new msparser::vectori;

$data->push(1.623866862); $data->push(-0.052894948); $data->push(1.182692298); $data->push(2.298658316); $data->push(1.13422094);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(0 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.156396617); $data->push(0.0000000000); $data->push(0.521050737); $data->push(1.544979883); $data->push(0.65718266);
$mask->push(1);           $mask->push(0);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(1 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.523561956); $data->push(-0.017417053); $data->push(1.168000125); $data->push(2.459693903); $data->push(1.308011315);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(2 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.55875743);  $data->push(-0.241270432); $data->push(0.440420721); $data->push(2.427337989); $data->push(1.043344505);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(3 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.449957484); $data->push(-0.169744676); $data->push(0.867896464); $data->push(2.418999465); $data->push(1.171206827);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(4 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.171206827); $data->push(0.0000000000); $data->push(0.854394678); $data->push(2.075532631); $data->push(0.950095094);
$mask->push(1);           $mask->push(0);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(5 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.361768359); $data->push(-0.120294234); $data->push(0.992043276); $data->push(2.238786860); $data->push(1.090175950);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(6 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.781149852); $data->push(0.0028825090); $data->push(1.079975377); $data->push(2.464929601); $data->push(1.301002256);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(7 , $data, $mask); $data->clear(); $mask->clear();

$data->push(-1.227692025);$data->push(-3.522840789); $data->push(-2.434402824);$data->push(-0.873027144);$data->push(-1.977099598);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(8 , $data, $mask); $data->clear(); $mask->clear();

$data->push(1.272023189); $data->push(-0.535331733); $data->push(0.608809243); $data->push(2.004681156); $data->push(0.826192536);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(9 , $data, $mask);
$data->clear(); $mask->clear();

$data->push(1.069014678); $data->push(-0.623709617); $data->push(0.412510571); $data->push(1.82822536);  $data->push(0.650764559);
$mask->push(1);           $mask->push(1);            $mask->push(1);           $mask->push(1);           $mask->push(1);
$tc->setRow(10, $data, $mask);
$data->clear(); $mask->clear();

my $weights  = new msparser::vectord;
my $left     = new msparser::vectori;
my $right    = new msparser::vectori;
my $distance = new msparser::vectord;

if (!$tc->cluster($msparser::ms_treecluster::TCD_EUCLIDEAN,
                  $msparser::ms_mascotresults::TCM_PAIRWISE_AVERAGE,
                  $weights,
                  $left,
                  $right,
                  $distance)) {
  print "Failed\n";
} else {
  print "Node\tleft\tright\tdistance\n";
  for my $i (0 .. $left->size-1) {
    my  $node = -1 -$i;
        print $node . "\t" . $left->get($i) . "\t" . $right->get($i) . "\t" . $distance->get($i), "\n";
  }
}

=pod

Running the program with no arguments, for example with

perl -I../bin treecluster.pl

will give the output:

Node    left    right   distance
-1      6       4       0.0129355369880599
-2      2       0       0.0135342339743674
-3      7       -2      0.0168450469179865
-4      5       9       0.0227119800299183
-5      10      1       0.0249214407900278
-6      -1      -3      0.0358259860933716
-7      -4      -5      0.0759763042954681
-8      3       -6      0.098592161220467
-9      -7      -8      0.225907496391906
-10     8       -9      9.24612595642236

=cut
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21


tools_treecluster.py

Using the matrix_science::ms_treecluster class.

#!/usr/bin/python
##############################################################################
# file: tools_treecluster.py                                                       #
# 'msparser' toolkit example code                                            #
##############################################################################
# COPYRIGHT NOTICE                                                           #
# Copyright 1998-2010 Matrix Science Limited  All Rights Reserved.           #
#                                                                            #
##############################################################################
#     $Source: parser/examples/test_python/tools_treecluster.py $   #
#     $Author: villek@matrixscience.com $                                                      #
#       $Date: 2018-07-30 16:23:53 +0100 $                                         #
#   $Revision: 1b450440f9c97e1e41d0fc6016a27d68951d4532 | MSPARSER_REL_2_8_1-0-gea32989045 $                                                         #
# $NoKeywords::                                                            $ #
##############################################################################

import msparser

rows = 11
cols = 5
tc = msparser.ms_treecluster(rows, cols)

data = msparser.vectord()
mask = msparser.vectori()

data.append(1.623866862); data.append(-0.052894948); data.append(1.182692298); data.append(2.298658316); data.append(1.13422094)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(0 , data, mask); data.clear(); mask.clear()

data.append(1.156396617); data.append(0.0000000000); data.append(0.521050737); data.append(1.544979883); data.append(0.65718266)
mask.append(1);           mask.append(0);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(1 , data, mask); data.clear(); mask.clear()

data.append(1.523561956); data.append(-0.017417053); data.append(1.168000125); data.append(2.459693903); data.append(1.308011315)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(2 , data, mask); data.clear(); mask.clear()

data.append(1.55875743);  data.append(-0.241270432); data.append(0.440420721); data.append(2.427337989); data.append(1.043344505)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(3 , data, mask); data.clear(); mask.clear()

data.append(1.449957484); data.append(-0.169744676); data.append(0.867896464); data.append(2.418999465); data.append(1.171206827)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(4 , data, mask); data.clear(); mask.clear()

data.append(1.171206827); data.append(0.0000000000); data.append(0.854394678); data.append(2.075532631); data.append(0.950095094)
mask.append(1);           mask.append(0);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(5 , data, mask); data.clear(); mask.clear()

data.append(1.361768359); data.append(-0.120294234); data.append(0.992043276); data.append(2.238786860); data.append(1.090175950)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(6 , data, mask); data.clear(); mask.clear()

data.append(1.781149852); data.append(0.0028825090); data.append(1.079975377); data.append(2.464929601); data.append(1.301002256)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(7 , data, mask); data.clear(); mask.clear()

data.append(-1.227692025); data.append(-3.522840789);data.append(-2.434402824);data.append(-0.873027144);data.append(-1.977099598)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(8 , data, mask); data.clear(); mask.clear()

data.append(1.272023189); data.append(-0.535331733); data.append(0.608809243); data.append(2.004681156); data.append(0.826192536)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(9 , data, mask); data.clear(); mask.clear()

data.append(1.069014678); data.append(-0.623709617); data.append(0.412510571); data.append(1.82822536);  data.append(0.650764559)
mask.append(1);           mask.append(1);            mask.append(1);           mask.append(1);           mask.append(1)
tc.setRow(10 , data, mask); data.clear(); mask.clear()

weights = msparser.vectord()
left = msparser.vectori()
right = msparser.vectori()
distance = msparser.vectord()

if not tc.cluster(msparser.ms_treecluster.TCD_EUCLIDEAN, msparser.ms_mascotresults.TCM_PAIRWISE_AVERAGE, weights, left, right, distance):
    print("Failed")
else:
    print("Node\tleft\tright\tdistance\n")
    for i in range(0, len(left)):
        node = -1 - i
        print("%d \t %d \t %d \t %.16f " % (node, left[i], right[i], distance[i]))

"""
tools_treecluster.py
Will give the following output:

Node    left    right   distance

-1       6       4       0.0129355369880599
-2       2       0       0.0135342339743674
-3       7       -2      0.0168450469179865
-4       5       9       0.0227119800299183
-5       10      1       0.0249214407900277
-6       -1      -3      0.0358259860933716
-7       -4      -5      0.0759763042954681
-8       3       -6      0.0985921612204670
-9       -7      -8      0.2259074963919064
-10      8       -9      9.2461259564223610
"""
Copyright © 2022 Matrix Science Ltd. All Rights Reserved. Generated on Wed Mar 30 2022 23:57:21